ZRX API Reference: Modules

ZRX API Reference 2023
Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Modules
Here is a list of all modules:
o AcAp Classes
o AcAx Classes
o AcCm Classes
o AcDb Classes
o AcEd Classes
o AcFd Classes
o AcGe Classes
o AcGi Classes
o AcGs Classes
o AcLy Classes
o AcPl Classes
o AcRx Classes
o AcTransaction Classes
o AcTrayItem Classes
o AcDMM Classes
o Global Functions
o Macros Classes
o MFC Classes
o Misc Classes
o OPM Classes
o Structs
\ Global Enums


ZRX API Reference: AcAp Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Typedefs
AcAp Classes

Classes

class | AcApDataManager< T >
class | AcApDocManager
class | AcApDocManagerReactor
class | AcApDocument
class | AcApDocumentIterator
class | AcApLayoutManager
class | AcApProfileManager
class | AcApProfileManagerReactor
class | AcApProfileStorage
class | AcApStatusBar

Typedefs

typedef AcArray< ACHAR * > AcApProfileNameArray

Detailed Description


ZRX API Reference: AcApDataManager< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcApDataManager< T > Class Template Reference
AcAp Classes
+ Inheritance diagram for AcApDataManager< T >:

Public Member Functions

T & | docData (AcApDocument *pDoc)
T & | docData ()
virtual void | documentToBeDestroyed (AcApDocument *pDoc)
- Public Member Functions inherited from AcApDocManagerReactor
ACRX_DECLARE_MEMBERS (AcApDocManagerReactor)
virtual void | documentActivated (AcApDocument *pActivatedDoc)
virtual void | documentActivationModified (bool bActivation)
virtual void | documentBecameCurrent (AcApDocument *)
virtual void | documentCreateCanceled (AcApDocument *pDocCreateCancelled)
virtual void | documentCreated (AcApDocument *pDocCreating)
virtual void | documentCreateStarted (AcApDocument *pDocCreating)
virtual void | documentDestroyed (const ACHAR *fileName)
virtual void | documentLockModeChanged (AcApDocument *, AcAp::DocLockMode myPreviousMode, AcAp::DocLockMode myCurrentMode, AcAp::DocLockMode currentMode, const ACHAR *pGlobalCmdName)
virtual void | documentLockModeChangeVetoed (AcApDocument *, const ACHAR *pGlobalCmdName)
virtual void | documentLockModeWillChange (AcApDocument *, AcAp::DocLockMode myCurrentMode, AcAp::DocLockMode myNewMode, AcAp::DocLockMode currentMode, const ACHAR *pGlobalCmdName)
virtual void | documentToBeActivated (AcApDocument *pActivatingDoc)
virtual void | documentToBeDeactivated (AcApDocument *pDeActivatedDoc)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Member Functions inherited from AcApDocManagerReactor
Acad::ErrorStatus | veto ()
The documentation for this class was generated from the following file:
  • AcApDMgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApDataManager< T > Member List

This is the complete list of members for AcApDataManager< T >, including all inherited members.

AcApDataManager() (defined in AcApDataManager< T >) | AcApDataManager< T > | inline
AcApDocManagerReactor() (defined in AcApDocManagerReactor) | AcApDocManagerReactor | inlineprotected
ACRX_DECLARE_MEMBERS(AcApDocManagerReactor) (defined in AcApDocManagerReactor) | AcApDocManagerReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
docData(AcApDocument *pDoc) (defined in AcApDataManager< T >) | AcApDataManager< T > | inline
docData() (defined in AcApDataManager< T >) | AcApDataManager< T > | inline
documentActivated(AcApDocument *pActivatedDoc) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentActivationModified(bool bActivation) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentBecameCurrent(AcApDocument *) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentCreateCanceled(AcApDocument *pDocCreateCancelled) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentCreated(AcApDocument *pDocCreating) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentCreateStarted(AcApDocument *pDocCreating) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentDestroyed(const ACHAR *fileName) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentLockModeChanged(AcApDocument *, AcAp::DocLockMode myPreviousMode, AcAp::DocLockMode myCurrentMode, AcAp::DocLockMode currentMode, const ACHAR *pGlobalCmdName) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentLockModeChangeVetoed(AcApDocument *, const ACHAR *pGlobalCmdName) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentLockModeWillChange(AcApDocument *, AcAp::DocLockMode myCurrentMode, AcAp::DocLockMode myNewMode, AcAp::DocLockMode currentMode, const ACHAR *pGlobalCmdName) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentToBeActivated(AcApDocument *pActivatingDoc) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentToBeDeactivated(AcApDocument *pDeActivatedDoc) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentToBeDestroyed(AcApDocument *pDoc) (defined in AcApDataManager< T >) | AcApDataManager< T > | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
veto() (defined in AcApDocManagerReactor) | AcApDocManagerReactor | protected
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcApDataManager() (defined in AcApDataManager< T >) | AcApDataManager< T > | inline
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcApDocManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | List of all members
AcApDocManager Class Reference
AcAp Classes
+ Inheritance diagram for AcApDocManager:

Classes

struct DocOpenParams

Public Member Functions

ACRX_DECLARE_MEMBERS (AcApDocManager)
virtual Acad::ErrorStatus | activateDocument (AcApDocument *pAcTargetDocument, bool bPassScript=false)=0
virtual void | addReactor (AcApDocManagerReactor *)=0
virtual Acad::ErrorStatus | appContextNewDocument (const ACHAR *pszTemplateName)=0
virtual Acad::ErrorStatus | appContextOpenDocument (const ACHAR *pszDrawingName)=0
virtual Acad::ErrorStatus | closeDocument (AcApDocument *pAcTargetDocument)=0
virtual AcApDocument * | curDocument () const =0
virtual Acad::ErrorStatus | disableDocumentActivation ()=0
virtual AcApDocument * | document (const AcDbDatabase *) const =0
virtual int | documentCount () const =0
virtual Acad::ErrorStatus | enableDocumentActivation ()=0
virtual void | executeInApplicationContext (void(*procAddr)(void *), void *pData) const =0
virtual int | inputPending (AcApDocument *pAcTargetDocument)=0
virtual bool | isApplicationContext () const =0
virtual bool | isDocumentActivationEnabled ()=0
virtual Acad::ErrorStatus | lockDocument (AcApDocument *pDoc, AcAp::DocLockMode=AcAp::kWrite, const ACHAR *pGlobalCmdName=NULL, const ACHAR *pLocalCmdName=NULL, bool prompt=true)=0
virtual AcApDocument * | mdiActiveDocument () const =0
virtual AcApDocumentIterator * | newAcApDocumentIterator ()=0
virtual Acad::ErrorStatus | newDocument ()=0
virtual Acad::ErrorStatus | openDocument ()=0
virtual void | popResourceHandle ()=0
virtual void | pushAcadResourceHandle ()=0
virtual void | pushResourceHandle (HINSTANCE hNewResourceHandle)=0
virtual void | removeReactor (AcApDocManagerReactor *)=0
virtual Acad::ErrorStatus | sendModelessInterrupt (AcApDocument *pAcTargetDocument)=0
virtual Acad::ErrorStatus | sendStringToExecute (AcApDocument *pAcTargetDocument, const ACHAR *pszExecute, bool bActivate=true, bool bWrapUpInactiveDoc=false, bool bEchoString=true)=0
virtual Acad::ErrorStatus | setCurDocument (AcApDocument *pDoc, AcAp::DocLockMode=AcAp::kNone, bool activate=false)=0
virtual Acad::ErrorStatus | setDefaultFormatForSave (AcApDocument::SaveFormat format)=0
virtual Acad::ErrorStatus | unlockDocument (AcApDocument *pDoc)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acdocman.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApDocManager Member List

This is the complete list of members for AcApDocManager, including all inherited members.

ACRX_DECLARE_MEMBERS(AcApDocManager) (defined in AcApDocManager) | AcApDocManager |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
activateDocument(AcApDocument *pAcTargetDocument, bool bPassScript=false)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
addReactor(AcApDocManagerReactor *)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
appContextNewDocument(const ACHAR *pszTemplateName)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
appContextOpenDocument(const ACHAR *pszDrawingName)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
closeDocument(AcApDocument *pAcTargetDocument)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
curDocument() const =0 (defined in AcApDocManager) | AcApDocManager | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableDocumentActivation()=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
document(const AcDbDatabase *) const =0 (defined in AcApDocManager) | AcApDocManager | pure virtual
documentCount() const =0 (defined in AcApDocManager) | AcApDocManager | pure virtual
enableDocumentActivation()=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
executeInApplicationContext(void(*procAddr)(void *), void *pData) const =0 (defined in AcApDocManager) | AcApDocManager | pure virtual
inputPending(AcApDocument *pAcTargetDocument)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isApplicationContext() const =0 (defined in AcApDocManager) | AcApDocManager | pure virtual
isDocumentActivationEnabled()=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
lockDocument(AcApDocument *pDoc, AcAp::DocLockMode=AcAp::kWrite, const ACHAR *pGlobalCmdName=NULL, const ACHAR *pLocalCmdName=NULL, bool prompt=true)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
mdiActiveDocument() const =0 (defined in AcApDocManager) | AcApDocManager | pure virtual
newAcApDocumentIterator()=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
newDocument()=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
openDocument()=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
popResourceHandle()=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
pushAcadResourceHandle()=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
pushResourceHandle(HINSTANCE hNewResourceHandle)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeReactor(AcApDocManagerReactor *)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
sendModelessInterrupt(AcApDocument *pAcTargetDocument)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
sendStringToExecute(AcApDocument *pAcTargetDocument, const ACHAR *pszExecute, bool bActivate=true, bool bWrapUpInactiveDoc=false, bool bEchoString=true)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
setCurDocument(AcApDocument *pDoc, AcAp::DocLockMode=AcAp::kNone, bool activate=false)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
setDefaultFormatForSave(AcApDocument::SaveFormat format)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
unlockDocument(AcApDocument *pDoc)=0 (defined in AcApDocManager) | AcApDocManager | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcApDocManagerReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcApDocManagerReactor Class Reference
AcAp Classes
+ Inheritance diagram for AcApDocManagerReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcApDocManagerReactor)
virtual void | documentActivated (AcApDocument *pActivatedDoc)
virtual void | documentActivationModified (bool bActivation)
virtual void | documentBecameCurrent (AcApDocument *)
virtual void | documentCreateCanceled (AcApDocument *pDocCreateCancelled)
virtual void | documentCreated (AcApDocument *pDocCreating)
virtual void | documentCreateStarted (AcApDocument *pDocCreating)
virtual void | documentDestroyed (const ACHAR *fileName)
virtual void | documentLockModeChanged (AcApDocument *, AcAp::DocLockMode myPreviousMode, AcAp::DocLockMode myCurrentMode, AcAp::DocLockMode currentMode, const ACHAR *pGlobalCmdName)
virtual void | documentLockModeChangeVetoed (AcApDocument *, const ACHAR *pGlobalCmdName)
virtual void | documentLockModeWillChange (AcApDocument *, AcAp::DocLockMode myCurrentMode, AcAp::DocLockMode myNewMode, AcAp::DocLockMode currentMode, const ACHAR *pGlobalCmdName)
virtual void | documentToBeActivated (AcApDocument *pActivatingDoc)
virtual void | documentToBeDeactivated (AcApDocument *pDeActivatedDoc)
virtual void | documentToBeDestroyed (AcApDocument *pDocToDestroy)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

Acad::ErrorStatus veto ()

Friends

class AcApDocImpManager

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acdocman.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApDocManagerReactor Member List

This is the complete list of members for AcApDocManagerReactor, including all inherited members.

AcApDocImpManager (defined in AcApDocManagerReactor) | AcApDocManagerReactor | friend
AcApDocManagerReactor() (defined in AcApDocManagerReactor) | AcApDocManagerReactor | inlineprotected
ACRX_DECLARE_MEMBERS(AcApDocManagerReactor) (defined in AcApDocManagerReactor) | AcApDocManagerReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
documentActivated(AcApDocument *pActivatedDoc) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentActivationModified(bool bActivation) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentBecameCurrent(AcApDocument *) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentCreateCanceled(AcApDocument *pDocCreateCancelled) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentCreated(AcApDocument *pDocCreating) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentCreateStarted(AcApDocument *pDocCreating) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentDestroyed(const ACHAR *fileName) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentLockModeChanged(AcApDocument *, AcAp::DocLockMode myPreviousMode, AcAp::DocLockMode myCurrentMode, AcAp::DocLockMode currentMode, const ACHAR *pGlobalCmdName) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentLockModeChangeVetoed(AcApDocument *, const ACHAR *pGlobalCmdName) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentLockModeWillChange(AcApDocument *, AcAp::DocLockMode myCurrentMode, AcAp::DocLockMode myNewMode, AcAp::DocLockMode currentMode, const ACHAR *pGlobalCmdName) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentToBeActivated(AcApDocument *pActivatingDoc) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentToBeDeactivated(AcApDocument *pDeActivatedDoc) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
documentToBeDestroyed(AcApDocument *pDocToDestroy) (defined in AcApDocManagerReactor) | AcApDocManagerReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
veto() (defined in AcApDocManagerReactor) | AcApDocManagerReactor | protected
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcApDocument Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcApDocument Class Reference
AcAp Classes
+ Inheritance diagram for AcApDocument:

Public Types

enum SaveFormat {
kUnknown = -1, kR12_dxf = 1, kR13_dwg = 4, kR13_dxf = 5,
kR14_dwg = 8, kR14_dxf = 9, k2000_dwg = 12, k2000_dxf = 13,
k2000_Template = 14, k2000_Standard = 15, k2000_xml = 16, k2004_dwg = 24,
k2004_dxf = 25, k2004_Template = 26, k2004_Standard = 27, k2007_dwg = 36,
k2007_dxf = 37, k2007_Template = 38, k2007_Standard = 39, k2010_dwg = 48,
k2010_dxf = 49, k2010_Template = 50, k2010_Standard = 51, k2013_dwg = 60,
k2013_dxf = 61, k2013_Template = 62, k2013_Standard = 63, kNative = k2013_dwg,
kNative = k2013_dwg, kR15_dwg = k2000_dwg, kR15_dxf = k2000_dxf, kR15_Template = k2000_Template,
kR15_Standard = k2000_Standard, kR15_xml = k2000_xml, kR18_dwg = k2004_dwg, kR18_dxf = k2004_dxf,
kR18_Template = k2004_Template, kR18_Standard = k2004_Standard, kR21_dwg = k2007_dwg, kR21_dxf = k2007_dxf,
kR21_Template = k2007_Template, kR21_Standard = k2007_Standard, kR24_dwg = k2010_dwg, kR24_dxf = k2010_dxf,
kR24_Template = k2010_Template, kR24_Standard = k2010_Standard, kR27_dwg = k2013_dwg, kR27_dxf = k2013_dxf,
kR27_Template = k2013_Template, kR27_Standard = k2013_Standard
}

Public Member Functions

ACRX_DECLARE_MEMBERS (AcApDocument)
virtual CDocument * | cDoc () const =0
virtual void * | contextPtr () const =0
virtual AcDbDatabase * | database () const =0
virtual const ACHAR * | docTitle () const =0
virtual AcApStatusBar * | drawingStatusBar () const =0
virtual const ACHAR * | fileName () const =0
virtual SaveFormat | formatForSave () const =0
virtual int | GetCountOfLispList () const =0
virtual IDispatch * | GetIDispatch (bool bAddRef)=0
virtual AcLispAppInfo * | GetItemOfLispList (int nIndex) const =0
virtual AcEdInputPointManager * | inputPointManager ()=0
virtual bool | isQuiescent () const =0
virtual bool | isReadOnly () const =0
virtual AcAp::DocLockMode | lockMode (bool bIncludeMyLocks=false) const =0
virtual AcAp::DocLockMode | myLockMode () const =0
Acad::ErrorStatus | popDbmod ()
void | pushDbmod ()
virtual AcTransactionManager * | transactionManager () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acdocman.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApDocument Member List

This is the complete list of members for AcApDocument, including all inherited members.

ACRX_DECLARE_MEMBERS(AcApDocument) (defined in AcApDocument) | AcApDocument |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
cDoc() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contextPtr() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
database() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
docTitle() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
drawingStatusBar() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
fileName() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
formatForSave() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
GetCountOfLispList() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
GetIDispatch(bool bAddRef)=0 (defined in AcApDocument) | AcApDocument | pure virtual
GetItemOfLispList(int nIndex) const =0 (defined in AcApDocument) | AcApDocument | pure virtual
inputPointManager()=0 (defined in AcApDocument) | AcApDocument | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isQuiescent() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
isReadOnly() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
k2000_dwg enum value (defined in AcApDocument) | AcApDocument |
k2000_dxf enum value (defined in AcApDocument) | AcApDocument |
k2000_Standard enum value (defined in AcApDocument) | AcApDocument |
k2000_Template enum value (defined in AcApDocument) | AcApDocument |
k2000_xml enum value (defined in AcApDocument) | AcApDocument |
k2004_dwg enum value (defined in AcApDocument) | AcApDocument |
k2004_dxf enum value (defined in AcApDocument) | AcApDocument |
k2004_Standard enum value (defined in AcApDocument) | AcApDocument |
k2004_Template enum value (defined in AcApDocument) | AcApDocument |
k2007_dwg enum value (defined in AcApDocument) | AcApDocument |
k2007_dxf enum value (defined in AcApDocument) | AcApDocument |
k2007_Standard enum value (defined in AcApDocument) | AcApDocument |
k2007_Template enum value (defined in AcApDocument) | AcApDocument |
k2010_dwg enum value (defined in AcApDocument) | AcApDocument |
k2010_dxf enum value (defined in AcApDocument) | AcApDocument |
k2010_Standard enum value (defined in AcApDocument) | AcApDocument |
k2010_Template enum value (defined in AcApDocument) | AcApDocument |
k2013_dwg enum value (defined in AcApDocument) | AcApDocument |
k2013_dxf enum value (defined in AcApDocument) | AcApDocument |
k2013_Standard enum value (defined in AcApDocument) | AcApDocument |
k2013_Template enum value (defined in AcApDocument) | AcApDocument |
kNative enum value (defined in AcApDocument) | AcApDocument |
kR12_dxf enum value (defined in AcApDocument) | AcApDocument |
kR13_dwg enum value (defined in AcApDocument) | AcApDocument |
kR13_dxf enum value (defined in AcApDocument) | AcApDocument |
kR14_dwg enum value (defined in AcApDocument) | AcApDocument |
kR14_dxf enum value (defined in AcApDocument) | AcApDocument |
kR15_dwg enum value (defined in AcApDocument) | AcApDocument |
kR15_dxf enum value (defined in AcApDocument) | AcApDocument |
kR15_Standard enum value (defined in AcApDocument) | AcApDocument |
kR15_Template enum value (defined in AcApDocument) | AcApDocument |
kR15_xml enum value (defined in AcApDocument) | AcApDocument |
kR18_dwg enum value (defined in AcApDocument) | AcApDocument |
kR18_dxf enum value (defined in AcApDocument) | AcApDocument |
kR18_Standard enum value (defined in AcApDocument) | AcApDocument |
kR18_Template enum value (defined in AcApDocument) | AcApDocument |
kR21_dwg enum value (defined in AcApDocument) | AcApDocument |
kR21_dxf enum value (defined in AcApDocument) | AcApDocument |
kR21_Standard enum value (defined in AcApDocument) | AcApDocument |
kR21_Template enum value (defined in AcApDocument) | AcApDocument |
kR24_dwg enum value (defined in AcApDocument) | AcApDocument |
kR24_dxf enum value (defined in AcApDocument) | AcApDocument |
kR24_Standard enum value (defined in AcApDocument) | AcApDocument |
kR24_Template enum value (defined in AcApDocument) | AcApDocument |
kR27_dwg enum value (defined in AcApDocument) | AcApDocument |
kR27_dxf enum value (defined in AcApDocument) | AcApDocument |
kR27_Standard enum value (defined in AcApDocument) | AcApDocument |
kR27_Template enum value (defined in AcApDocument) | AcApDocument |
kUnknown enum value (defined in AcApDocument) | AcApDocument |
lockMode(bool bIncludeMyLocks=false) const =0 (defined in AcApDocument) | AcApDocument | pure virtual
myLockMode() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
popDbmod() (defined in AcApDocument) | AcApDocument |
pushDbmod() (defined in AcApDocument) | AcApDocument |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
SaveFormat enum name (defined in AcApDocument) | AcApDocument |
transactionManager() const =0 (defined in AcApDocument) | AcApDocument | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcApDocumentIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcApDocumentIterator Class Reference
AcAp Classes
+ Inheritance diagram for AcApDocumentIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcApDocumentIterator)
virtual AcApDocument * | document ()=0
virtual bool | done () const =0
virtual void | step ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acdocman.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApDocumentIterator Member List

This is the complete list of members for AcApDocumentIterator, including all inherited members.

ACRX_DECLARE_MEMBERS(AcApDocumentIterator) (defined in AcApDocumentIterator) | AcApDocumentIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
document()=0 (defined in AcApDocumentIterator) | AcApDocumentIterator | pure virtual
done() const =0 (defined in AcApDocumentIterator) | AcApDocumentIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
step()=0 (defined in AcApDocumentIterator) | AcApDocumentIterator | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcApLayoutManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcApLayoutManager Class Reference
AcAp Classes
+ Inheritance diagram for AcApLayoutManager:

Public Member Functions

virtual Adesk::Boolean | createViewports ()=0
virtual const ACHAR * | findActiveTab ()=0
virtual Acad::ErrorStatus | getClipBoundaryElaboration (AcDbObjectId clipId, AcGePoint2dArray *&clipBoundary)=0
virtual ACHAR * | getNextNewLayoutName (AcDbDatabase *useDb=NULL)=0
virtual int | pageSetup (AcDbObjectId layoutBTRId=AcDbObjectId::kNull, void *pParent=NULL, Adesk::Boolean isPageSetupDlg=TRUE)=0
virtual Acad::ErrorStatus | pointInViewports (const AcGePoint3d &pickPt, AcDbObjectIdArray &viewports)=0
virtual void | setCreateViewports (Adesk::Boolean createViewports)=0
virtual void | setDefaultPlotConfig (AcDbObjectId layoutBTRId)=0
virtual void | setShowPageSetup (Adesk::Boolean showPageSetupDlg)=0
virtual void | setShowPaperBackground (Adesk::Boolean showPaperBackground)=0
virtual void | setShowPaperMargins (Adesk::Boolean showPaperMargins)=0
virtual void | setShowPrintBorder (Adesk::Boolean showPrintBorder)=0
virtual void | setShowTabs (Adesk::Boolean showTabs)=0
virtual Adesk::Boolean | showPageSetup ()=0
virtual Adesk::Boolean | showPaperBackground ()=0
virtual Adesk::Boolean | showPaperMargins ()=0
virtual Adesk::Boolean | showPrintBorder ()=0
virtual Adesk::Boolean | showTabs ()=0
virtual void | updateCurrentPaper (Adesk::Boolean zoomToPaper=FALSE)=0
virtual void | updateLayoutTabs ()=0
- Public Member Functions inherited from AcDbLayoutManager
virtual void | addReactor (AcDbLayoutManagerReactor *newObj)=0
virtual Acad::ErrorStatus | cloneLayout (AcDbLayout *pLBTR, const ACHAR *newname, int newTabOrder=0)=0
virtual Acad::ErrorStatus | copyLayout (const ACHAR *copyname, const ACHAR *newname)=0
virtual int | countLayouts (AcDbDatabase *useDb=NULL)=0
virtual Acad::ErrorStatus | createLayout (const ACHAR *newname, AcDbObjectId &layoutId, AcDbObjectId &blockTableRecId, AcDbDatabase *pDatabase=NULL)=0
virtual Acad::ErrorStatus | deleteLayout (const ACHAR *delname)=0
virtual const ACHAR * | findActiveLayout (bool allowModel)=0
virtual AcDbLayout * | findLayoutNamed (const ACHAR *name, bool leaveRecordOpen=false)=0
virtual AcDbObjectId | getActiveLayoutBTRId ()=0
virtual AcDbObjectId | getNonRectVPIdFromClipId (AcDbObjectId clipId)=0
virtual bool | isVpnumClipped (int index)=0
virtual void | removeReactor (AcDbLayoutManagerReactor *delObj)=0
virtual Acad::ErrorStatus | renameLayout (const ACHAR *oldname, const ACHAR *newname)=0
virtual Acad::ErrorStatus | setCurrentLayout (const ACHAR *newname)=0
virtual Acad::ErrorStatus | setCurrentLayoutId (AcDbObjectId layoutId)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • AcApLMgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApLayoutManager Member List

This is the complete list of members for AcApLayoutManager, including all inherited members.

AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addReactor(AcDbLayoutManagerReactor *newObj)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
cloneLayout(AcDbLayout *pLBTR, const ACHAR *newname, int newTabOrder=0)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
copyLayout(const ACHAR *copyname, const ACHAR *newname)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
countLayouts(AcDbDatabase *useDb=NULL)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
createLayout(const ACHAR *newname, AcDbObjectId &layoutId, AcDbObjectId &blockTableRecId, AcDbDatabase *pDatabase=NULL)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
createViewports()=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
deleteLayout(const ACHAR *delname)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
findActiveLayout(bool allowModel)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
findActiveTab()=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
findLayoutNamed(const ACHAR *name, bool leaveRecordOpen=false)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
getActiveLayoutBTRId()=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
getClipBoundaryElaboration(AcDbObjectId clipId, AcGePoint2dArray *&clipBoundary)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
getNextNewLayoutName(AcDbDatabase *useDb=NULL)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
getNonRectVPIdFromClipId(AcDbObjectId clipId)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isVpnumClipped(int index)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
pageSetup(AcDbObjectId layoutBTRId=AcDbObjectId::kNull, void *pParent=NULL, Adesk::Boolean isPageSetupDlg=TRUE)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
pointInViewports(const AcGePoint3d &pickPt, AcDbObjectIdArray &viewports)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeReactor(AcDbLayoutManagerReactor *delObj)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
renameLayout(const ACHAR *oldname, const ACHAR *newname)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
setCreateViewports(Adesk::Boolean createViewports)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
setCurrentLayout(const ACHAR *newname)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
setCurrentLayoutId(AcDbObjectId layoutId)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
setDefaultPlotConfig(AcDbObjectId layoutBTRId)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
setShowPageSetup(Adesk::Boolean showPageSetupDlg)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
setShowPaperBackground(Adesk::Boolean showPaperBackground)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
setShowPaperMargins(Adesk::Boolean showPaperMargins)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
setShowPrintBorder(Adesk::Boolean showPrintBorder)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
setShowTabs(Adesk::Boolean showTabs)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
showPageSetup()=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
showPaperBackground()=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
showPaperMargins()=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
showPrintBorder()=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
showTabs()=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
updateCurrentPaper(Adesk::Boolean zoomToPaper=FALSE)=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
updateLayoutTabs()=0 (defined in AcApLayoutManager) | AcApLayoutManager | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcApProfileManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcApProfileManager Class Reference
AcAp Classes

Public Member Functions

virtual void | addReactor (AcApProfileManagerReactor *)=0
virtual Acad::ErrorStatus | FixedProfileStorage (AcApProfileStorage *&pStore, BOOL bCreateIfNotExists=TRUE)=0
virtual Acad::ErrorStatus | ProfileCopy (const ACHAR *newProfileName, const ACHAR *oldProfileName, const ACHAR *newProfileDesc)=0
virtual Acad::ErrorStatus | ProfileDelete (const ACHAR *strProfileName)=0
virtual Acad::ErrorStatus | ProfileExport (const ACHAR *strProfileName, const ACHAR *exportFileName)=0
virtual Acad::ErrorStatus | ProfileImport (const ACHAR *strProfileName, const ACHAR *importFileName, const ACHAR *profileDescription, Adesk::Boolean bImportPathInfo)=0
virtual int | ProfileListNames (AcApProfileNameArray &nameList)=0
virtual void | ProfileRegistryKey (ACHAR *&strRegProfileKey, const ACHAR *strProfileName)=0
virtual Acad::ErrorStatus | ProfileRename (const ACHAR *newProfileName, const ACHAR *oldProfileName, const ACHAR *newProfileDesc)=0
virtual Acad::ErrorStatus | ProfileReset (const ACHAR *strProfileName)=0
virtual Acad::ErrorStatus | ProfileSetCurrent (const ACHAR *strProfileName)=0
virtual Acad::ErrorStatus | ProfileStorage (AcApProfileStorage *&pStore, const ACHAR *strProfileName, BOOL bCreateIfNotExists=TRUE)=0
virtual void | removeReactor (AcApProfileManagerReactor *)=0
The documentation for this class was generated from the following file:
  • acprofile.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApProfileManager Member List

This is the complete list of members for AcApProfileManager, including all inherited members.

addReactor(AcApProfileManagerReactor *)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
FixedProfileStorage(AcApProfileStorage *&pStore, BOOL bCreateIfNotExists=TRUE)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileCopy(const ACHAR *newProfileName, const ACHAR *oldProfileName, const ACHAR *newProfileDesc)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileDelete(const ACHAR *strProfileName)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileExport(const ACHAR *strProfileName, const ACHAR *exportFileName)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileImport(const ACHAR *strProfileName, const ACHAR *importFileName, const ACHAR *profileDescription, Adesk::Boolean bImportPathInfo)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileListNames(AcApProfileNameArray &nameList)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileRegistryKey(ACHAR *&strRegProfileKey, const ACHAR *strProfileName)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileRename(const ACHAR *newProfileName, const ACHAR *oldProfileName, const ACHAR *newProfileDesc)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileReset(const ACHAR *strProfileName)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileSetCurrent(const ACHAR *strProfileName)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
ProfileStorage(AcApProfileStorage *&pStore, const ACHAR *strProfileName, BOOL bCreateIfNotExists=TRUE)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual
removeReactor(AcApProfileManagerReactor *)=0 (defined in AcApProfileManager) | AcApProfileManager | pure virtual


ZRX API Reference: AcApProfileManagerReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcApProfileManagerReactor Class Reference
AcAp Classes

Public Member Functions

virtual void | currentProfileChanged (const ACHAR *newProfile)
virtual void | currentProfileReset (const ACHAR *currentProfile)
virtual void | currentProfileSaved (const ACHAR *currentProfile)
virtual void | currentProfileWillBeReset (const ACHAR *currentProfile)
virtual void | currentProfileWillBeSaved (const ACHAR *currentProfile)
virtual void | currentProfileWillChange (const ACHAR *newProfile)
virtual void | profileReset (const ACHAR *profileName)
virtual void | profileSaved (const ACHAR *profileName)
virtual void | profileWillBeSaved (const ACHAR *profileName)
virtual void | profileWillReset (const ACHAR *profileName)
The documentation for this class was generated from the following file:
  • acprofile.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApProfileManagerReactor Member List

This is the complete list of members for AcApProfileManagerReactor, including all inherited members.

currentProfileChanged(const ACHAR *newProfile) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
currentProfileReset(const ACHAR *currentProfile) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
currentProfileSaved(const ACHAR *currentProfile) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
currentProfileWillBeReset(const ACHAR *currentProfile) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
currentProfileWillBeSaved(const ACHAR *currentProfile) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
currentProfileWillChange(const ACHAR *newProfile) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
profileReset(const ACHAR *profileName) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
profileSaved(const ACHAR *profileName) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
profileWillBeSaved(const ACHAR *profileName) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
profileWillReset(const ACHAR *profileName) (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | virtual
~AcApProfileManagerReactor() (defined in AcApProfileManagerReactor) | AcApProfileManagerReactor | inlinevirtual


ZRX API Reference: AcApProfileStorage Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcApProfileStorage Class Reference
AcAp Classes

Public Member Functions

virtual Acad::ErrorStatus | CreateNode (const ACHAR *pszNodePath, IUnknown *&pUnknown)=0
virtual Acad::ErrorStatus | DeleteNode (const ACHAR *pszNodePath)=0
virtual Acad::ErrorStatus | GetNode (const ACHAR *pszNodePath, IUnknown *&pUnknown)=0
virtual Acad::ErrorStatus | GetStorageFile (LPTSTR pszFile)=0
virtual Acad::ErrorStatus | ReplaceNode (const ACHAR *pszNodePath, IUnknown *pUnknown)=0
virtual Acad::ErrorStatus | Save (void)=0
The documentation for this class was generated from the following file:
  • acprofile.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApProfileStorage Member List

This is the complete list of members for AcApProfileStorage, including all inherited members.

CreateNode(const ACHAR *pszNodePath, IUnknown *&pUnknown)=0 (defined in AcApProfileStorage) | AcApProfileStorage | pure virtual
DeleteNode(const ACHAR *pszNodePath)=0 (defined in AcApProfileStorage) | AcApProfileStorage | pure virtual
GetNode(const ACHAR *pszNodePath, IUnknown *&pUnknown)=0 (defined in AcApProfileStorage) | AcApProfileStorage | pure virtual
GetStorageFile(LPTSTR pszFile)=0 (defined in AcApProfileStorage) | AcApProfileStorage | pure virtual
ReplaceNode(const ACHAR *pszNodePath, IUnknown *pUnknown)=0 (defined in AcApProfileStorage) | AcApProfileStorage | pure virtual
Save(void)=0 (defined in AcApProfileStorage) | AcApProfileStorage | pure virtual
~AcApProfileStorage() (defined in AcApProfileStorage) | AcApProfileStorage | inlinevirtual


ZRX API Reference: AcApStatusBar Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcApStatusBar Class Reference
AcAp Classes

Public Member Functions

virtual int | Add (AcPane *pPane, BOOL bUpdate=TRUE)=0
virtual int | Add (AcTrayItem *pTrayItem, BOOL bUpdate=TRUE)=0
virtual BOOL | ClientToScreen (LPPOINT lpPoint)=0
virtual BOOL | ClientToScreen (LPRECT lpRect)=0
virtual BOOL | CloseAllBubbleWindows (AcTrayItem *pTrayItem)=0
virtual UINT | DisplayContextMenu (CMenu &menu, CPoint point)=0
virtual UINT | DisplayPopupPaneMenu (AcPane *pPane, CMenu &menu)=0
virtual AcPane * | GetDefaultPane (AcDefaultPane nPane)=0
virtual int | GetID (AcPane *pPane) const =0
virtual int | GetID (AcTrayItem *pTrayItem) const =0
virtual int | GetID (int nIndex, BOOL bTrayItem=FALSE) const =0
virtual int | GetIndex (AcPane *pPane) const =0
virtual int | GetIndex (AcTrayItem *pTrayItem) const =0
virtual int | GetIndex (int nID, BOOL bTrayItem=FALSE) const =0
virtual AcPane * | GetPane (int nIndex)=0
virtual int | GetPaneCount () const =0
virtual int | GetTextWidth (const CString &strText) const =0
virtual AcTrayItem * | GetTrayItem (int nIndex)=0
virtual int | GetTrayItemCount () const =0
virtual BOOL | GetTraySettingsShowIcons () const =0
virtual BOOL | GetTraySettingsShowNotifications () const =0
virtual BOOL | Insert (int nIndex, AcPane *pPane, BOOL bUpdate=TRUE)=0
virtual BOOL | Insert (int nIndex, AcTrayItem *pTrayItem, BOOL bUpdate=TRUE)=0
virtual BOOL | Remove (AcPane *pPane, BOOL bUpdate=TRUE)=0
virtual BOOL | Remove (AcTrayItem *pTrayItem, BOOL bUpdate=TRUE)=0
virtual BOOL | Remove (int nIndex, BOOL bTrayItem=FALSE, BOOL bUpdate=TRUE)=0
virtual BOOL | RemoveAllPanes (BOOL bUpdate=TRUE)=0
virtual BOOL | RemoveAllTrayIcons (BOOL bUpdate=TRUE)=0
virtual BOOL | RemoveCleanScreenIcon ()=0
virtual BOOL | RemoveDefaultPane (AcDefaultPane nPane, BOOL bUpdate=TRUE)=0
virtual BOOL | ScreenToClient (LPPOINT lpPoint)=0
virtual BOOL | ScreenToClient (LPRECT lpRect)=0
virtual BOOL | SetStatusBarMenuItem (AcPane *pPane)=0
virtual void | ShowCleanScreenIcon (BOOL bShow)=0
virtual void | ShowStatusBarMenuIcon (BOOL bShow)=0
virtual BOOL | ShowTraySettingsDialog ()=0
virtual void | Update ()=0
The documentation for this class was generated from the following file:
  • acStatusBar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApStatusBar Member List

This is the complete list of members for AcApStatusBar, including all inherited members.

Add(AcPane *pPane, BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
Add(AcTrayItem *pTrayItem, BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
ClientToScreen(LPPOINT lpPoint)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
ClientToScreen(LPRECT lpRect)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
CloseAllBubbleWindows(AcTrayItem *pTrayItem)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
DisplayContextMenu(CMenu &menu, CPoint point)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
DisplayPopupPaneMenu(AcPane *pPane, CMenu &menu)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetDefaultPane(AcDefaultPane nPane)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetID(AcPane *pPane) const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetID(AcTrayItem *pTrayItem) const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetID(int nIndex, BOOL bTrayItem=FALSE) const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetIndex(AcPane *pPane) const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetIndex(AcTrayItem *pTrayItem) const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetIndex(int nID, BOOL bTrayItem=FALSE) const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetPane(int nIndex)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetPaneCount() const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetTextWidth(const CString &strText) const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetTrayItem(int nIndex)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetTrayItemCount() const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetTraySettingsShowIcons() const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
GetTraySettingsShowNotifications() const =0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
Insert(int nIndex, AcPane *pPane, BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
Insert(int nIndex, AcTrayItem *pTrayItem, BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
Remove(AcPane *pPane, BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
Remove(AcTrayItem *pTrayItem, BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
Remove(int nIndex, BOOL bTrayItem=FALSE, BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
RemoveAllPanes(BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
RemoveAllTrayIcons(BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
RemoveCleanScreenIcon()=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
RemoveDefaultPane(AcDefaultPane nPane, BOOL bUpdate=TRUE)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
ScreenToClient(LPPOINT lpPoint)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
ScreenToClient(LPRECT lpRect)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
SetStatusBarMenuItem(AcPane *pPane)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
ShowCleanScreenIcon(BOOL bShow)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
ShowStatusBarMenuIcon(BOOL bShow)=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
ShowTraySettingsDialog()=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual
Update()=0 (defined in AcApStatusBar) | AcApStatusBar | pure virtual


ZRX API Reference: AcAx Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Typedefs | Functions
AcAx Classes

Classes

class | AcAxDocLock
class | AcAxMatrix3d
class | AcAxObjectRef
class | AcAxObjectRefPtr< T_OBJECT >
class | AcAxOleLinkManager
class | AcAxPoint2d
class | AcAxPoint2dArray
class | AcAxPoint3d
class | AcAxPoint3dArray

Typedefs

typedef AcAxObjectRefPtr
< AcDbEntity > 		AcDbEntityRefPtr
typedef AcAxObjectRefPtr
< AcDbObject > 		AcDbObjectRefPtr

Functions

AcAxOleLinkManager * | AcAxGetOleLinkManager ()
AcAxObjectRef::AcAxObjectRef (AcDbObjectId objId)
AcAxObjectRef::AcAxObjectRef (AcDbObject *&pObj)
AcAxObjectRefPtr< T_OBJECT >::AcAxObjectRefPtr (AcAxObjectRef *const pRef, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | AcAxObjectRef::acquire (AcDbObjectId objId)
Acad::ErrorStatus | AcAxObjectRef::acquire (AcDbObject *&pObj)
bool | AcAxObjectRef::isNull ()
AcDbObjectId | AcAxObjectRef::objectId ()
Acad::ErrorStatus | AcAxObjectRef::release (AcDbObjectId &objId, AcDbObject *&pObj)

Detailed Description


ZRX API Reference: AcAxDocLock Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcAxDocLock Class Reference
AcAx Classes

Public Types

enum DocLockType { kNormal = 0, kCurDocSwitch = 1 }

Public Member Functions

AcAxDocLock (const AcDbObjectId &objectId, DocLockType=kNormal)
AcAxDocLock (AcDbDatabase *pDatabase, DocLockType=kNormal)
Acad::ErrorStatus lockStatus () const
The documentation for this class was generated from the following file:
  • axlock.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAxDocLock Member List

This is the complete list of members for AcAxDocLock, including all inherited members.

AcAxDocLock() (defined in AcAxDocLock) | AcAxDocLock
AcAxDocLock(const AcDbObjectId &objectId, DocLockType=kNormal) (defined in AcAxDocLock) | AcAxDocLock
AcAxDocLock(AcDbDatabase *pDatabase, DocLockType=kNormal) (defined in AcAxDocLock) | AcAxDocLock
DocLockType enum name (defined in AcAxDocLock) | AcAxDocLock
kCurDocSwitch enum value (defined in AcAxDocLock) | AcAxDocLock
kNormal enum value (defined in AcAxDocLock) | AcAxDocLock
lockStatus() const (defined in AcAxDocLock) | AcAxDocLock
~AcAxDocLock() (defined in AcAxDocLock) | AcAxDocLock


ZRX API Reference: AcAxMatrix3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcAxMatrix3d Class Reference
AcAx Classes
+ Inheritance diagram for AcAxMatrix3d:

Public Member Functions

AcAxMatrix3d (const VARIANT *var) throw (HRESULT)
AcAxMatrix3d (const VARIANT &var) throw (HRESULT)
AcAxMatrix3d (const SAFEARRAY *safeArrayPt) throw (HRESULT)
AcAxMatrix3d & | operator= (const VARIANT *var) throw (HRESULT)
AcAxMatrix3d & | operator= (const VARIANT &var) throw (HRESULT)
AcAxMatrix3d & | operator= (const SAFEARRAY *safeArrayPt) throw (HRESULT)
- Public Member Functions inherited from AcGeMatrix3d
AcGeMatrix3d (const AcGeMatrix3d &src)
AcGeMatrix2d | convertToLocal (AcGeVector3d &normal, double &elev) const
double | det () const
void | getCoordSystem (AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis, AcGeVector3d &zAxis) const
AcGeMatrix3d | inverse () const
Adesk::Boolean | inverse (AcGeMatrix3d &inv, double tol) const
AcGeMatrix3d & | invert ()
bool | isEqualTo (const AcGeMatrix3d &mat, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isScaledOrtho (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isSingular (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isUniScaledOrtho (const AcGeTol &tol=AcGeContext::gTol) const
double | norm () const
bool | operator!= (const AcGeMatrix3d &mat) const
double | operator() (unsigned int, unsigned int) const
double & | operator() (unsigned int, unsigned int)
AcGeMatrix3d | operator* (const AcGeMatrix3d &mat) const
AcGeMatrix3d & | operator*= (const AcGeMatrix3d &mat)
bool | operator== (const AcGeMatrix3d &mat) const
AcGeMatrix3d & | postMultBy (const AcGeMatrix3d &rightSide)
AcGeMatrix3d & | preMultBy (const AcGeMatrix3d &leftSide)
double | scale (void) const
AcGeMatrix3d & | setCoordSystem (const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis, const AcGeVector3d &zAxis)
AcGeMatrix3d & | setToAlignCoordSys (const AcGePoint3d &fromOrigin, const AcGeVector3d &fromXAxis, const AcGeVector3d &fromYAxis, const AcGeVector3d &fromZAxis, const AcGePoint3d &toOrigin, const AcGeVector3d &toXAxis, const AcGeVector3d &toYAxis, const AcGeVector3d &toZAxis)
AcGeMatrix3d & | setToIdentity ()
AcGeMatrix3d & | setToMirroring (const AcGePlane &pln)
AcGeMatrix3d & | setToMirroring (const AcGePoint3d &pnt)
AcGeMatrix3d & | setToMirroring (const AcGeLine3d &line)
AcGeMatrix3d & | setToPlaneToWorld (const AcGeVector3d &normal)
AcGeMatrix3d & | setToPlaneToWorld (const AcGePlane &plane)
AcGeMatrix3d & | setToProduct (const AcGeMatrix3d &mat1, const AcGeMatrix3d &mat2)
AcGeMatrix3d & | setToProjection (const AcGePlane &projectionPlane, const AcGeVector3d &projectDir)
AcGeMatrix3d & | setToRotation (double angle, const AcGeVector3d &axis, const AcGePoint3d &center=AcGePoint3d::kOrigin)
AcGeMatrix3d & | setToScaling (double scaleAll, const AcGePoint3d &center=AcGePoint3d::kOrigin)
AcGeMatrix3d & | setToTranslation (const AcGeVector3d &vec)
AcGeMatrix3d & | setToWorldToPlane (const AcGeVector3d &normal)
AcGeMatrix3d & | setToWorldToPlane (const AcGePlane &plane)
AcGeMatrix3d & | setTranslation (const AcGeVector3d &vec)
AcGeVector3d | translation () const
AcGeMatrix3d | transpose () const
AcGeMatrix3d & | transposeIt ()

Additional Inherited Members

- Static Public Member Functions inherited from AcGeMatrix3d
static AcGeMatrix3d | alignCoordSys (const AcGePoint3d &fromOrigin, const AcGeVector3d &fromXAxis, const AcGeVector3d &fromYAxis, const AcGeVector3d &fromZAxis, const AcGePoint3d &toOrigin, const AcGeVector3d &toXAxis, const AcGeVector3d &toYAxis, const AcGeVector3d &toZAxis)
static AcGeMatrix3d | mirroring (const AcGePlane &pln)
static AcGeMatrix3d | mirroring (const AcGePoint3d &pnt)
static AcGeMatrix3d | mirroring (const AcGeLine3d &line)
static AcGeMatrix3d | planeToWorld (const AcGeVector3d &normal)
static AcGeMatrix3d | planeToWorld (const AcGePlane &)
static AcGeMatrix3d | projection (const AcGePlane &projectionPlane, const AcGeVector3d &projectDir)
static AcGeMatrix3d | rotation (double angle, const AcGeVector3d &axis, const AcGePoint3d &center=AcGePoint3d::kOrigin)
static AcGeMatrix3d | scaling (double scaleAll, const AcGePoint3d &center=AcGePoint3d::kOrigin)
static AcGeMatrix3d | translation (const AcGeVector3d &vec)
static AcGeMatrix3d | worldToPlane (const AcGeVector3d &normal)
static AcGeMatrix3d | worldToPlane (const AcGePlane &)
- Public Attributes inherited from AcGeMatrix3d
double | entry [4][4]
- Static Public Attributes inherited from AcGeMatrix3d
static const AcGeMatrix3d | kIdentity
The documentation for this class was generated from the following file:
  • axmat3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAxMatrix3d Member List

This is the complete list of members for AcAxMatrix3d, including all inherited members.

AcAxMatrix3d() (defined in AcAxMatrix3d) | AcAxMatrix3d |
AcAxMatrix3d(const VARIANT *var) (defined in AcAxMatrix3d) | AcAxMatrix3d |
AcAxMatrix3d(const VARIANT &var) (defined in AcAxMatrix3d) | AcAxMatrix3d |
AcAxMatrix3d(const SAFEARRAY *safeArrayPt) (defined in AcAxMatrix3d) | AcAxMatrix3d |
AcGeMatrix3d() (defined in AcGeMatrix3d) | AcGeMatrix3d |
AcGeMatrix3d(const AcGeMatrix3d &src) (defined in AcGeMatrix3d) | AcGeMatrix3d |
alignCoordSys(const AcGePoint3d &fromOrigin, const AcGeVector3d &fromXAxis, const AcGeVector3d &fromYAxis, const AcGeVector3d &fromZAxis, const AcGePoint3d &toOrigin, const AcGeVector3d &toXAxis, const AcGeVector3d &toYAxis, const AcGeVector3d &toZAxis) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
convertToLocal(AcGeVector3d &normal, double &elev) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
det() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
entry (defined in AcGeMatrix3d) | AcGeMatrix3d |
getCoordSystem(AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis, AcGeVector3d &zAxis) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
inverse() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
inverse(AcGeMatrix3d &inv, double tol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
invert() (defined in AcGeMatrix3d) | AcGeMatrix3d |
isEqualTo(const AcGeMatrix3d &mat, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
isScaledOrtho(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
isSingular(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
isUniScaledOrtho(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
kIdentity (defined in AcGeMatrix3d) | AcGeMatrix3d | static
mirroring(const AcGePlane &pln) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
mirroring(const AcGePoint3d &pnt) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
mirroring(const AcGeLine3d &line) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
norm() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator!=(const AcGeMatrix3d &mat) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator()(unsigned int, unsigned int) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator()(unsigned int, unsigned int) (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator*(const AcGeMatrix3d &mat) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator*=(const AcGeMatrix3d &mat) (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator=(const VARIANT *var) (defined in AcAxMatrix3d) | AcAxMatrix3d |
operator=(const VARIANT &var) (defined in AcAxMatrix3d) | AcAxMatrix3d |
operator=(const SAFEARRAY *safeArrayPt) (defined in AcAxMatrix3d) | AcAxMatrix3d |
operator==(const AcGeMatrix3d &mat) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
planeToWorld(const AcGeVector3d &normal) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
planeToWorld(const AcGePlane &) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
postMultBy(const AcGeMatrix3d &rightSide) (defined in AcGeMatrix3d) | AcGeMatrix3d |
preMultBy(const AcGeMatrix3d &leftSide) (defined in AcGeMatrix3d) | AcGeMatrix3d |
projection(const AcGePlane &projectionPlane, const AcGeVector3d &projectDir) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
rotation(double angle, const AcGeVector3d &axis, const AcGePoint3d &center=AcGePoint3d::kOrigin) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
scale(void) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
scaling(double scaleAll, const AcGePoint3d &center=AcGePoint3d::kOrigin) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
setCoordSystem(const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis, const AcGeVector3d &zAxis) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToAlignCoordSys(const AcGePoint3d &fromOrigin, const AcGeVector3d &fromXAxis, const AcGeVector3d &fromYAxis, const AcGeVector3d &fromZAxis, const AcGePoint3d &toOrigin, const AcGeVector3d &toXAxis, const AcGeVector3d &toYAxis, const AcGeVector3d &toZAxis) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToIdentity() (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToMirroring(const AcGePlane &pln) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToMirroring(const AcGePoint3d &pnt) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToMirroring(const AcGeLine3d &line) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToPlaneToWorld(const AcGeVector3d &normal) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToPlaneToWorld(const AcGePlane &plane) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToProduct(const AcGeMatrix3d &mat1, const AcGeMatrix3d &mat2) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToProjection(const AcGePlane &projectionPlane, const AcGeVector3d &projectDir) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToRotation(double angle, const AcGeVector3d &axis, const AcGePoint3d &center=AcGePoint3d::kOrigin) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToScaling(double scaleAll, const AcGePoint3d &center=AcGePoint3d::kOrigin) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToTranslation(const AcGeVector3d &vec) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToWorldToPlane(const AcGeVector3d &normal) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToWorldToPlane(const AcGePlane &plane) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setTranslation(const AcGeVector3d &vec) (defined in AcGeMatrix3d) | AcGeMatrix3d |
translation() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
translation(const AcGeVector3d &vec) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
transpose() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
transposeIt() (defined in AcGeMatrix3d) | AcGeMatrix3d |
worldToPlane(const AcGeVector3d &normal) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
worldToPlane(const AcGePlane &) (defined in AcGeMatrix3d) | AcGeMatrix3d | static


ZRX API Reference: AcAxObjectRef Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcAxObjectRef Class Reference
AcAx Classes

Public Member Functions

AcAxObjectRef (AcDbObjectId objId)
AcAxObjectRef (AcDbObject *&pObj)
Acad::ErrorStatus | acquire (AcDbObjectId objId)
Acad::ErrorStatus | acquire (AcDbObject *&pObj)
bool | isNull ()
AcDbObjectId | objectId ()
Acad::ErrorStatus | release (AcDbObjectId &objId, AcDbObject *&pObj)
The documentation for this class was generated from the following file:
  • axobjref.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAxObjectRef Member List

This is the complete list of members for AcAxObjectRef, including all inherited members.

AcAxObjectRef() (defined in AcAxObjectRef) | AcAxObjectRef | inline
AcAxObjectRef(AcDbObjectId objId) (defined in AcAxObjectRef) | AcAxObjectRef | inline
AcAxObjectRef(AcDbObject *&pObj) (defined in AcAxObjectRef) | AcAxObjectRef | inline
acquire(AcDbObjectId objId) (defined in AcAxObjectRef) | AcAxObjectRef | inline
acquire(AcDbObject *&pObj) (defined in AcAxObjectRef) | AcAxObjectRef | inline
isNull() (defined in AcAxObjectRef) | AcAxObjectRef | inline
objectId() (defined in AcAxObjectRef) | AcAxObjectRef | inline
release(AcDbObjectId &objId, AcDbObject *&pObj) (defined in AcAxObjectRef) | AcAxObjectRef | inline
~AcAxObjectRef() (defined in AcAxObjectRef) | AcAxObjectRef | inline


ZRX API Reference: AcAxObjectRefPtr< T_OBJECT > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcAxObjectRefPtr< T_OBJECT > Class Template Reference
AcAx Classes
+ Inheritance diagram for AcAxObjectRefPtr< T_OBJECT >:

Public Member Functions

AcAxObjectRefPtr (AcAxObjectRef *const pRef, AcDb::OpenMode mode, bool openErased=false)
- Public Member Functions inherited from AcDbObjectPointer< T_OBJECT >
AcDbObjectPointer (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | open (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
- Public Member Functions inherited from AcDbObjectPointerBase< T_OBJECT >
Acad::ErrorStatus | acquire (T_OBJECT *&pObjToAcquire)
Acad::ErrorStatus | close ()
Acad::ErrorStatus | create ()
const T_OBJECT * | object () const
T_OBJECT * | object ()
Acad::ErrorStatus | openStatus () const
operator const T_OBJECT * () const
operator T_OBJECT * ()
const T_OBJECT * | operator-> () const
T_OBJECT * | operator-> ()
Acad::ErrorStatus | release (T_OBJECT *&pReleasedObj)

Additional Inherited Members

- Protected Member Functions inherited from AcDbObjectPointerBase< T_OBJECT >
AcDbObjectPointerBase (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased)
- Protected Attributes inherited from AcDbObjectPointerBase< T_OBJECT >
T_OBJECT * | m_ptr
Acad::ErrorStatus | m_status
The documentation for this class was generated from the following file:
  • axobjref.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAxObjectRefPtr< T_OBJECT > Member List

This is the complete list of members for AcAxObjectRefPtr< T_OBJECT >, including all inherited members.

AcAxObjectRefPtr() (defined in AcAxObjectRefPtr< T_OBJECT >) | AcAxObjectRefPtr< T_OBJECT > | inline
AcAxObjectRefPtr(AcAxObjectRef *const pRef, AcDb::OpenMode mode, bool openErased=false) (defined in AcAxObjectRefPtr< T_OBJECT >) | AcAxObjectRefPtr< T_OBJECT > | inline
AcDbObjectPointer() (defined in AcDbObjectPointer< T_OBJECT >) | AcDbObjectPointer< T_OBJECT > | inline
AcDbObjectPointer(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbObjectPointer< T_OBJECT >) | AcDbObjectPointer< T_OBJECT > | inline
AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
AcDbObjectPointerBase(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlineprotected
acquire(T_OBJECT *&pObjToAcquire) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
close() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
create() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
m_ptr (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
m_status (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
object() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
object() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
open(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbObjectPointer< T_OBJECT >) | AcDbObjectPointer< T_OBJECT > | inline
openStatus() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator const T_OBJECT *() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator T_OBJECT *() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
release(T_OBJECT *&pReleasedObj) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
~AcAxObjectRefPtr() (defined in AcAxObjectRefPtr< T_OBJECT >) | AcAxObjectRefPtr< T_OBJECT > | inline
~AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlinevirtual


ZRX API Reference: AcAxOleLinkManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcAxOleLinkManager Class Reference
AcAx Classes

Public Member Functions

virtual IDispatch * | GetDocIDispatch (AcDbDatabase *pDatabase)=0
virtual IUnknown * | GetIUnknown (AcDbObject *pObject)=0
virtual IUnknown * | GetIUnknown (AcDbDatabase *pDatabase)=0
virtual IUnknown * | GetIUnknown (AcDbObject *pObject, const AcDbSubentId &id)=0
virtual Adesk::Boolean | SetDocIDispatch (AcDbDatabase *pDatabase, IDispatch *pDispatch)=0
virtual Adesk::Boolean | SetIUnknown (AcDbObject *pObject, IUnknown *pUnknown)=0
virtual Adesk::Boolean | SetIUnknown (AcDbDatabase *pDatabase, IUnknown *pUnknown)=0
virtual Adesk::Boolean | SetIUnknown (AcDbObject *pObject, const AcDbSubentId &id, IUnknown *pUnknown)=0
The documentation for this class was generated from the following file:
  • oleaprot.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAxOleLinkManager Member List

This is the complete list of members for AcAxOleLinkManager, including all inherited members.

GetDocIDispatch(AcDbDatabase *pDatabase)=0 (defined in AcAxOleLinkManager) | AcAxOleLinkManager | pure virtual
GetIUnknown(AcDbObject *pObject)=0 (defined in AcAxOleLinkManager) | AcAxOleLinkManager | pure virtual
GetIUnknown(AcDbDatabase *pDatabase)=0 (defined in AcAxOleLinkManager) | AcAxOleLinkManager | pure virtual
GetIUnknown(AcDbObject *pObject, const AcDbSubentId &id)=0 (defined in AcAxOleLinkManager) | AcAxOleLinkManager | pure virtual
SetDocIDispatch(AcDbDatabase *pDatabase, IDispatch *pDispatch)=0 (defined in AcAxOleLinkManager) | AcAxOleLinkManager | pure virtual
SetIUnknown(AcDbObject *pObject, IUnknown *pUnknown)=0 (defined in AcAxOleLinkManager) | AcAxOleLinkManager | pure virtual
SetIUnknown(AcDbDatabase *pDatabase, IUnknown *pUnknown)=0 (defined in AcAxOleLinkManager) | AcAxOleLinkManager | pure virtual
SetIUnknown(AcDbObject *pObject, const AcDbSubentId &id, IUnknown *pUnknown)=0 (defined in AcAxOleLinkManager) | AcAxOleLinkManager | pure virtual


ZRX API Reference: AcAxPoint2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcAxPoint2d Class Reference
AcAx Classes
+ Inheritance diagram for AcAxPoint2d:

Public Member Functions

AcAxPoint2d (double x, double y)
AcAxPoint2d (const AcGePoint2d &pt)
AcAxPoint2d (const AcGeVector2d &pt)
AcAxPoint2d (const VARIANT *var) throw (HRESULT)
AcAxPoint2d (const VARIANT &var) throw (HRESULT)
AcAxPoint2d (const SAFEARRAY *safeArrayPt) throw (HRESULT)
SAFEARRAY * | asSafeArrayPtr () const throw (HRESULT)
VARIANT * | asVariantPtr () const throw (HRESULT)
AcAxPoint2d & | operator= (const AcGePoint2d &pt)
AcAxPoint2d & | operator= (const AcGeVector2d &pt)
AcAxPoint2d & | operator= (const VARIANT *var) throw (HRESULT)
AcAxPoint2d & | operator= (const VARIANT &var) throw (HRESULT)
AcAxPoint2d & | operator= (const SAFEARRAY *safeArrayPt) throw (HRESULT)
VARIANT & | setVariant (VARIANT &var) const throw (HRESULT)
VARIANT * | setVariant (VARIANT *var) const throw (HRESULT)
- Public Member Functions inherited from AcGePoint2d
AcGePoint2d (const AcGePoint2d &pnt)
AcGePoint2d (double x, double y)
AcGeVector2d | asVector () const
double | distanceTo (const AcGePoint2d &pnt) const
bool | isEqualTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d & | mirror (const AcGeLine2d &line)
bool | operator!= (const AcGePoint2d &pnt) const
AcGePoint2d | operator* (double) const
AcGePoint2d & | operator*= (double scl)
AcGePoint2d | operator+ (const AcGeVector2d &vec) const
AcGePoint2d & | operator+= (const AcGeVector2d &vec)
AcGePoint2d | operator- (const AcGeVector2d &vec) const
AcGeVector2d | operator- (const AcGePoint2d &pnt) const
AcGePoint2d & | operator-= (const AcGeVector2d &vec)
AcGePoint2d | operator/ (double scl) const
AcGePoint2d & | operator/= (double scl)
bool | operator== (const AcGePoint2d &pnt) const
double | operator[] (unsigned int i) const
double & | operator[] (unsigned int idx)
AcGePoint2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGePoint2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGePoint2d & | set (double x, double y)
AcGePoint2d & | setToProduct (const AcGeMatrix2d &mat, const AcGePoint2d &pnt)
AcGePoint2d & | setToSum (const AcGePoint2d &pnt, const AcGeVector2d &vec)
AcGePoint2d & | transformBy (const AcGeMatrix2d &leftSide)

Additional Inherited Members

- Public Attributes inherited from AcGePoint2d
double | x
double | y
- Static Public Attributes inherited from AcGePoint2d
static const AcGePoint2d | kOrigin
The documentation for this class was generated from the following file:
  • axpnt2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAxPoint2d Member List

This is the complete list of members for AcAxPoint2d, including all inherited members.

AcAxPoint2d() (defined in AcAxPoint2d) | AcAxPoint2d |
AcAxPoint2d(double x, double y) (defined in AcAxPoint2d) | AcAxPoint2d |
AcAxPoint2d(const AcGePoint2d &pt) (defined in AcAxPoint2d) | AcAxPoint2d |
AcAxPoint2d(const AcGeVector2d &pt) (defined in AcAxPoint2d) | AcAxPoint2d |
AcAxPoint2d(const VARIANT *var) (defined in AcAxPoint2d) | AcAxPoint2d |
AcAxPoint2d(const VARIANT &var) (defined in AcAxPoint2d) | AcAxPoint2d |
AcAxPoint2d(const SAFEARRAY *safeArrayPt) (defined in AcAxPoint2d) | AcAxPoint2d |
AcGePoint2d() (defined in AcGePoint2d) | AcGePoint2d |
AcGePoint2d(const AcGePoint2d &pnt) (defined in AcGePoint2d) | AcGePoint2d |
AcGePoint2d(double x, double y) (defined in AcGePoint2d) | AcGePoint2d |
asSafeArrayPtr() const (defined in AcAxPoint2d) | AcAxPoint2d |
asVariantPtr() const (defined in AcAxPoint2d) | AcAxPoint2d |
asVector() const (defined in AcGePoint2d) | AcGePoint2d |
distanceTo(const AcGePoint2d &pnt) const (defined in AcGePoint2d) | AcGePoint2d |
isEqualTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePoint2d) | AcGePoint2d |
kOrigin (defined in AcGePoint2d) | AcGePoint2d | static
mirror(const AcGeLine2d &line) (defined in AcGePoint2d) | AcGePoint2d |
operator!=(const AcGePoint2d &pnt) const (defined in AcGePoint2d) | AcGePoint2d |
operator*(double) const (defined in AcGePoint2d) | AcGePoint2d |
operator*=(double scl) (defined in AcGePoint2d) | AcGePoint2d |
operator+(const AcGeVector2d &vec) const (defined in AcGePoint2d) | AcGePoint2d |
operator+=(const AcGeVector2d &vec) (defined in AcGePoint2d) | AcGePoint2d |
operator-(const AcGeVector2d &vec) const (defined in AcGePoint2d) | AcGePoint2d |
operator-(const AcGePoint2d &pnt) const (defined in AcGePoint2d) | AcGePoint2d |
operator-=(const AcGeVector2d &vec) (defined in AcGePoint2d) | AcGePoint2d |
operator/(double scl) const (defined in AcGePoint2d) | AcGePoint2d |
operator/=(double scl) (defined in AcGePoint2d) | AcGePoint2d |
operator=(const AcGePoint2d &pt) (defined in AcAxPoint2d) | AcAxPoint2d |
operator=(const AcGeVector2d &pt) (defined in AcAxPoint2d) | AcAxPoint2d |
operator=(const VARIANT *var) (defined in AcAxPoint2d) | AcAxPoint2d |
operator=(const VARIANT &var) (defined in AcAxPoint2d) | AcAxPoint2d |
operator=(const SAFEARRAY *safeArrayPt) (defined in AcAxPoint2d) | AcAxPoint2d |
operator==(const AcGePoint2d &pnt) const (defined in AcGePoint2d) | AcGePoint2d |
operator[](unsigned int i) const (defined in AcGePoint2d) | AcGePoint2d |
operator[](unsigned int idx) (defined in AcGePoint2d) | AcGePoint2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGePoint2d) | AcGePoint2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGePoint2d) | AcGePoint2d |
set(double x, double y) (defined in AcGePoint2d) | AcGePoint2d |
setToProduct(const AcGeMatrix2d &mat, const AcGePoint2d &pnt) (defined in AcGePoint2d) | AcGePoint2d |
setToSum(const AcGePoint2d &pnt, const AcGeVector2d &vec) (defined in AcGePoint2d) | AcGePoint2d |
setVariant(VARIANT &var) const (defined in AcAxPoint2d) | AcAxPoint2d |
setVariant(VARIANT *var) const (defined in AcAxPoint2d) | AcAxPoint2d |
transformBy(const AcGeMatrix2d &leftSide) (defined in AcGePoint2d) | AcGePoint2d |
x (defined in AcGePoint2d) | AcGePoint2d |
y (defined in AcGePoint2d) | AcGePoint2d |


ZRX API Reference: AcAxPoint2dArray Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcAxPoint2dArray Class Reference
AcAx Classes
+ Inheritance diagram for AcAxPoint2dArray:

Public Member Functions

AcAxPoint2dArray & | append (const AcGePoint2d &pt)
AcAxPoint2dArray & | append (const VARIANT *var) throw (HRESULT)
AcAxPoint2dArray & | append (const VARIANT &var) throw (HRESULT)
AcAxPoint2dArray & | append (const SAFEARRAY *safeArrayPt) throw (HRESULT)
SAFEARRAY * | asSafeArrayPtr () const throw (HRESULT)
VARIANT & | setVariant (VARIANT &var) const throw (HRESULT)
VARIANT * | setVariant (VARIANT *var) const throw (HRESULT)
- Public Member Functions inherited from AcArray< AcGePoint2d >
AcArray (int initPhysicalLength=0, int initGrowLength=8)
AcArray (const AcArray< AcGePoint2d, AcArrayMemCopyReallocator< AcGePoint2d > > &)
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		append (const AcArray< AcGePoint2d, AcArrayMemCopyReallocator< AcGePoint2d > > &array)
const AcGePoint2d * | asArrayPtr () const
AcGePoint2d * | asArrayPtr ()
const AcGePoint2d & | at (int index) const
AcGePoint2d & | at (int index)
bool | contains (const AcGePoint2d &value, int start=0) const
bool | find (const AcGePoint2d &value, int &foundAt, int start=0) const
int | find (const AcGePoint2d &value) const
int | findFrom (const AcGePoint2d &value, int start) const
AcGePoint2d & first ()
const AcGePoint2d & | first () const
int | growLength () const
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		insertAt (int index, const AcGePoint2d &value)
bool | isEmpty () const
AcGePoint2d & last ()
const AcGePoint2d & | last () const
int | length () const
int | logicalLength () const
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		operator= (const AcArray< AcGePoint2d, AcArrayMemCopyReallocator< AcGePoint2d > > &)
bool | operator== (const AcArray< AcGePoint2d, AcArrayMemCopyReallocator< AcGePoint2d > > &) const
AcGePoint2d & | operator[] (int)
const AcGePoint2d & | operator[] (int) const
int | physicalLength () const
bool | remove (const AcGePoint2d &value, int start=0)
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		removeAll ()
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		removeAt (int index)
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		removeFirst ()
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		removeLast ()
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		removeSubArray (int startIndex, int endIndex)
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		reverse ()
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		setAll (const AcGePoint2d &value)
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		setAt (int index, const AcGePoint2d &value)
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		setGrowLength (int)
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		setLogicalLength (int)
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		setPhysicalLength (int)
AcArray< AcGePoint2d,
AcArrayMemCopyReallocator
< AcGePoint2d > > & 		swap (int i1, int i2)

Additional Inherited Members

- Protected Member Functions inherited from AcArray< AcGePoint2d >
bool | isValid (int) const
- Protected Attributes inherited from AcArray< AcGePoint2d >
int | mGrowLen
int | mLogicalLen
AcGePoint2d * | mpArray
int | mPhysicalLen
The documentation for this class was generated from the following file:
  • axpnt2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAxPoint2dArray Member List

This is the complete list of members for AcAxPoint2dArray, including all inherited members.

AcArray(int initPhysicalLength=0, int initGrowLength=8) (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > |
AcArray(const AcArray< AcGePoint2d, AcArrayMemCopyReallocator< AcGePoint2d > > &) (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > |
append(const AcGePoint2d &pt) (defined in AcAxPoint2dArray) | AcAxPoint2dArray |
append(const VARIANT *var) (defined in AcAxPoint2dArray) | AcAxPoint2dArray |
append(const VARIANT &var) (defined in AcAxPoint2dArray) | AcAxPoint2dArray |
append(const SAFEARRAY *safeArrayPt) (defined in AcAxPoint2dArray) | AcAxPoint2dArray |
append(const AcArray< AcGePoint2d, AcArrayMemCopyReallocator< AcGePoint2d > > &array) (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > |
asArrayPtr() const (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > |
asArrayPtr() (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > |
asSafeArrayPtr() const (defined in AcAxPoint2dArray) | AcAxPoint2dArray |
at(int index) const (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > |
at(int index) (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > |
contains(const AcGePoint2d &value, int start=0) const (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > |
find(const AcGePoint2d &value, int &foundAt, int start=0) const | AcArray< AcGePoint2d > |
find(const AcGePoint2d &value) const | AcArray< AcGePoint2d > |
findFrom(const AcGePoint2d &value, int start) const | AcArray< AcGePoint2d > |
first() | AcArray< AcGePoint2d > |
first() const | AcArray< AcGePoint2d > |
growLength() const | AcArray< AcGePoint2d > |
insertAt(int index, const AcGePoint2d &value) | AcArray< AcGePoint2d > |
isEmpty() const | AcArray< AcGePoint2d > |
isValid(int) const (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > | protected
last() | AcArray< AcGePoint2d > |
last() const | AcArray< AcGePoint2d > |
length() const | AcArray< AcGePoint2d > |
logicalLength() const | AcArray< AcGePoint2d > |
mGrowLen (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > | protected
mLogicalLen (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > | protected
mpArray (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > | protected
mPhysicalLen (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > | protected
operator=(const AcArray< AcGePoint2d, AcArrayMemCopyReallocator< AcGePoint2d > > &) | AcArray< AcGePoint2d > |
operator==(const AcArray< AcGePoint2d, AcArrayMemCopyReallocator< AcGePoint2d > > &) const | AcArray< AcGePoint2d > |
operator[](int) | AcArray< AcGePoint2d > |
operator[](int) const | AcArray< AcGePoint2d > |
physicalLength() const | AcArray< AcGePoint2d > |
remove(const AcGePoint2d &value, int start=0) | AcArray< AcGePoint2d > |
removeAll() | AcArray< AcGePoint2d > |
removeAt(int index) | AcArray< AcGePoint2d > |
removeFirst() | AcArray< AcGePoint2d > |
removeLast() | AcArray< AcGePoint2d > |
removeSubArray(int startIndex, int endIndex) | AcArray< AcGePoint2d > |
reverse() | AcArray< AcGePoint2d > |
setAll(const AcGePoint2d &value) | AcArray< AcGePoint2d > |
setAt(int index, const AcGePoint2d &value) | AcArray< AcGePoint2d > |
setGrowLength(int) | AcArray< AcGePoint2d > |
setLogicalLength(int) | AcArray< AcGePoint2d > |
setPhysicalLength(int) | AcArray< AcGePoint2d > |
setVariant(VARIANT &var) const (defined in AcAxPoint2dArray) | AcAxPoint2dArray |
setVariant(VARIANT *var) const (defined in AcAxPoint2dArray) | AcAxPoint2dArray |
swap(int i1, int i2) | AcArray< AcGePoint2d > |
~AcArray() (defined in AcArray< AcGePoint2d >) | AcArray< AcGePoint2d > |


ZRX API Reference: AcAxPoint3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcAxPoint3d Class Reference
AcAx Classes
+ Inheritance diagram for AcAxPoint3d:

Public Member Functions

AcAxPoint3d (double x, double y, double z)
AcAxPoint3d (const AcGePoint3d &pt)
AcAxPoint3d (const AcGeVector3d &pt)
AcAxPoint3d (const VARIANT *var) throw (HRESULT)
AcAxPoint3d (const VARIANT &var) throw (HRESULT)
AcAxPoint3d (const SAFEARRAY *safeArrayPt) throw (HRESULT)
SAFEARRAY * | asSafeArrayPtr () const throw (HRESULT)
VARIANT * | asVariantPtr () const throw (HRESULT)
AcAxPoint3d & | operator= (const AcGePoint3d &pt)
AcAxPoint3d & | operator= (const AcGeVector3d &pt)
AcAxPoint3d & | operator= (const VARIANT *var) throw (HRESULT)
AcAxPoint3d & | operator= (const VARIANT &var) throw (HRESULT)
AcAxPoint3d & | operator= (const SAFEARRAY *safeArrayPt) throw (HRESULT)
VARIANT & | setVariant (VARIANT &var) const throw (HRESULT)
VARIANT * | setVariant (VARIANT *var) const throw (HRESULT)
- Public Member Functions inherited from AcGePoint3d
AcGePoint3d (const AcGePoint3d &pnt)
AcGePoint3d (double x, double y, double z)
AcGePoint3d (const AcGePlanarEnt &pln, const AcGePoint2d &pnt2d)
AcGeVector3d | asVector () const
AcGePoint2d | convert2d (const AcGePlanarEnt &pln) const
double | distanceTo (const AcGePoint3d &pnt) const
bool | isEqualTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d & | mirror (const AcGePlane &pln)
bool | operator!= (const AcGePoint3d &pnt) const
AcGePoint3d | operator* (double scl) const
AcGePoint3d & | operator*= (double scl)
AcGePoint3d | operator+ (const AcGeVector3d &vec) const
AcGePoint3d & | operator+= (const AcGeVector3d &vec)
AcGePoint3d | operator- (const AcGeVector3d &vec) const
AcGeVector3d | operator- (const AcGePoint3d &pnt) const
AcGePoint3d & | operator-= (const AcGeVector3d &vec)
AcGePoint3d | operator/ (double scl) const
AcGePoint3d & | operator/= (double scl)
bool | operator== (const AcGePoint3d &pnt) const
double | operator[] (unsigned int i) const
double & | operator[] (unsigned int idx)
AcGePoint3d | orthoProject (const AcGePlane &pln) const
AcGePoint3d | project (const AcGePlane &pln, const AcGeVector3d &vec) const
AcGePoint3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGePoint3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGePoint3d & | set (double x, double y, double z)
AcGePoint3d & | set (const AcGePlanarEnt &pln, const AcGePoint2d &pnt)
AcGePoint3d & | setToProduct (const AcGeMatrix3d &mat, const AcGePoint3d &pnt)
AcGePoint3d & | setToSum (const AcGePoint3d &pnt, const AcGeVector3d &vec)
AcGePoint3d & | transformBy (const AcGeMatrix3d &leftSide)

Additional Inherited Members

- Public Attributes inherited from AcGePoint3d
double | x
double | y
double | z
- Static Public Attributes inherited from AcGePoint3d
static const AcGePoint3d | kOrigin
The documentation for this class was generated from the following file:
  • axpnt3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAxPoint3d Member List

This is the complete list of members for AcAxPoint3d, including all inherited members.

AcAxPoint3d() (defined in AcAxPoint3d) | AcAxPoint3d |
AcAxPoint3d(double x, double y, double z) (defined in AcAxPoint3d) | AcAxPoint3d |
AcAxPoint3d(const AcGePoint3d &pt) (defined in AcAxPoint3d) | AcAxPoint3d |
AcAxPoint3d(const AcGeVector3d &pt) (defined in AcAxPoint3d) | AcAxPoint3d |
AcAxPoint3d(const VARIANT *var) (defined in AcAxPoint3d) | AcAxPoint3d |
AcAxPoint3d(const VARIANT &var) (defined in AcAxPoint3d) | AcAxPoint3d |
AcAxPoint3d(const SAFEARRAY *safeArrayPt) (defined in AcAxPoint3d) | AcAxPoint3d |
AcGePoint3d() (defined in AcGePoint3d) | AcGePoint3d |
AcGePoint3d(const AcGePoint3d &pnt) (defined in AcGePoint3d) | AcGePoint3d |
AcGePoint3d(double x, double y, double z) (defined in AcGePoint3d) | AcGePoint3d |
AcGePoint3d(const AcGePlanarEnt &pln, const AcGePoint2d &pnt2d) (defined in AcGePoint3d) | AcGePoint3d |
asSafeArrayPtr() const (defined in AcAxPoint3d) | AcAxPoint3d |
asVariantPtr() const (defined in AcAxPoint3d) | AcAxPoint3d |
asVector() const (defined in AcGePoint3d) | AcGePoint3d |
convert2d(const AcGePlanarEnt &pln) const (defined in AcGePoint3d) | AcGePoint3d |
distanceTo(const AcGePoint3d &pnt) const (defined in AcGePoint3d) | AcGePoint3d |
isEqualTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePoint3d) | AcGePoint3d |
kOrigin (defined in AcGePoint3d) | AcGePoint3d | static
mirror(const AcGePlane &pln) (defined in AcGePoint3d) | AcGePoint3d |
operator!=(const AcGePoint3d &pnt) const (defined in AcGePoint3d) | AcGePoint3d |
operator*(double scl) const (defined in AcGePoint3d) | AcGePoint3d |
operator*=(double scl) (defined in AcGePoint3d) | AcGePoint3d |
operator+(const AcGeVector3d &vec) const (defined in AcGePoint3d) | AcGePoint3d |
operator+=(const AcGeVector3d &vec) (defined in AcGePoint3d) | AcGePoint3d |
operator-(const AcGeVector3d &vec) const (defined in AcGePoint3d) | AcGePoint3d |
operator-(const AcGePoint3d &pnt) const (defined in AcGePoint3d) | AcGePoint3d |
operator-=(const AcGeVector3d &vec) (defined in AcGePoint3d) | AcGePoint3d |
operator/(double scl) const (defined in AcGePoint3d) | AcGePoint3d |
operator/=(double scl) (defined in AcGePoint3d) | AcGePoint3d |
operator=(const AcGePoint3d &pt) (defined in AcAxPoint3d) | AcAxPoint3d |
operator=(const AcGeVector3d &pt) (defined in AcAxPoint3d) | AcAxPoint3d |
operator=(const VARIANT *var) (defined in AcAxPoint3d) | AcAxPoint3d |
operator=(const VARIANT &var) (defined in AcAxPoint3d) | AcAxPoint3d |
operator=(const SAFEARRAY *safeArrayPt) (defined in AcAxPoint3d) | AcAxPoint3d |
operator==(const AcGePoint3d &pnt) const (defined in AcGePoint3d) | AcGePoint3d |
operator[](unsigned int i) const (defined in AcGePoint3d) | AcGePoint3d |
operator[](unsigned int idx) (defined in AcGePoint3d) | AcGePoint3d |
orthoProject(const AcGePlane &pln) const (defined in AcGePoint3d) | AcGePoint3d |
project(const AcGePlane &pln, const AcGeVector3d &vec) const (defined in AcGePoint3d) | AcGePoint3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGePoint3d) | AcGePoint3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGePoint3d) | AcGePoint3d |
set(double x, double y, double z) (defined in AcGePoint3d) | AcGePoint3d |
set(const AcGePlanarEnt &pln, const AcGePoint2d &pnt) (defined in AcGePoint3d) | AcGePoint3d |
setToProduct(const AcGeMatrix3d &mat, const AcGePoint3d &pnt) (defined in AcGePoint3d) | AcGePoint3d |
setToSum(const AcGePoint3d &pnt, const AcGeVector3d &vec) (defined in AcGePoint3d) | AcGePoint3d |
setVariant(VARIANT &var) const (defined in AcAxPoint3d) | AcAxPoint3d |
setVariant(VARIANT *var) const (defined in AcAxPoint3d) | AcAxPoint3d |
transformBy(const AcGeMatrix3d &leftSide) (defined in AcGePoint3d) | AcGePoint3d |
x (defined in AcGePoint3d) | AcGePoint3d |
y (defined in AcGePoint3d) | AcGePoint3d |
z (defined in AcGePoint3d) | AcGePoint3d |


ZRX API Reference: AcAxPoint3dArray Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcAxPoint3dArray Class Reference
AcAx Classes
+ Inheritance diagram for AcAxPoint3dArray:

Public Member Functions

AcAxPoint3dArray & | append (const AcGePoint3d &pt)
AcAxPoint3dArray & | append (const VARIANT *var) throw (HRESULT)
AcAxPoint3dArray & | append (const VARIANT &var) throw (HRESULT)
AcAxPoint3dArray & | append (const SAFEARRAY *safeArrayPt) throw (HRESULT)
SAFEARRAY * | asSafeArrayPtr () const throw (HRESULT)
VARIANT & | setVariant (VARIANT &var) const throw (HRESULT)
VARIANT * | setVariant (VARIANT *var) const throw (HRESULT)
- Public Member Functions inherited from AcArray< T, R >
AcArray (int initPhysicalLength=0, int initGrowLength=8)
AcArray (const AcArray< T, R > &)
int | append (const T &value)
AcArray< T, R > & | append (const AcArray< T, R > &array)
const T * | asArrayPtr () const
T * | asArrayPtr ()
const T & | at (int index) const
T & | at (int index)
bool | contains (const T &value, int start=0) const
bool | find (const T &value, int &foundAt, int start=0) const
int | find (const T &value) const
int | findFrom (const T &value, int start) const
T & | first ()
const T & | first () const
int | growLength () const
AcArray< T, R > & | insertAt (int index, const T &value)
bool | isEmpty () const
T & | last ()
const T & | last () const
int | length () const
int | logicalLength () const
AcArray< T, R > & | operator= (const AcArray< T, R > &)
bool | operator== (const AcArray< T, R > &) const
T & | operator[] (int)
const T & | operator[] (int) const
int | physicalLength () const
bool | remove (const T &value, int start=0)
AcArray< T, R > & | removeAll ()
AcArray< T, R > & | removeAt (int index)
AcArray< T, R > & | removeFirst ()
AcArray< T, R > & | removeLast ()
AcArray< T, R > & | removeSubArray (int startIndex, int endIndex)
AcArray< T, R > & | reverse ()
AcArray< T, R > & | setAll (const T &value)
AcArray< T, R > & | setAt (int index, const T &value)
AcArray< T, R > & | setGrowLength (int)
AcArray< T, R > & | setLogicalLength (int)
AcArray< T, R > & | setPhysicalLength (int)
AcArray< T, R > & | swap (int i1, int i2)

Additional Inherited Members

- Protected Member Functions inherited from AcArray< T, R >
bool | isValid (int) const
- Protected Attributes inherited from AcArray< T, R >
int | mGrowLen
int | mLogicalLen
T * | mpArray
int | mPhysicalLen
The documentation for this class was generated from the following file:
  • axpnt3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAxPoint3dArray Member List

This is the complete list of members for AcAxPoint3dArray, including all inherited members.

AcArray(int initPhysicalLength=0, int initGrowLength=8) (defined in AcArray< T, R >) | AcArray< T, R > |
AcArray(const AcArray< T, R > &) (defined in AcArray< T, R >) | AcArray< T, R > |
append(const AcGePoint3d &pt) (defined in AcAxPoint3dArray) | AcAxPoint3dArray |
append(const VARIANT *var) (defined in AcAxPoint3dArray) | AcAxPoint3dArray |
append(const VARIANT &var) (defined in AcAxPoint3dArray) | AcAxPoint3dArray |
append(const SAFEARRAY *safeArrayPt) (defined in AcAxPoint3dArray) | AcAxPoint3dArray |
append(const T &value) (defined in AcArray< T, R >) | AcArray< T, R > | inline
append(const AcArray< T, R > &array) (defined in AcArray< T, R >) | AcArray< T, R > |
asArrayPtr() const (defined in AcArray< T, R >) | AcArray< T, R > | inline
asArrayPtr() (defined in AcArray< T, R >) | AcArray< T, R > | inline
asSafeArrayPtr() const (defined in AcAxPoint3dArray) | AcAxPoint3dArray |
at(int index) const (defined in AcArray< T, R >) | AcArray< T, R > | inline
at(int index) (defined in AcArray< T, R >) | AcArray< T, R > | inline
contains(const T &value, int start=0) const (defined in AcArray< T, R >) | AcArray< T, R > | inline
find(const T &value, int &foundAt, int start=0) const | AcArray< T, R > |
find(const T &value) const | AcArray< T, R > |
findFrom(const T &value, int start) const | AcArray< T, R > |
first() | AcArray< T, R > | inline
first() const | AcArray< T, R > | inline
growLength() const | AcArray< T, R > | inline
insertAt(int index, const T &value) | AcArray< T, R > |
isEmpty() const | AcArray< T, R > | inline
isValid(int) const (defined in AcArray< T, R >) | AcArray< T, R > | inlineprotected
last() | AcArray< T, R > | inline
last() const | AcArray< T, R > | inline
length() const | AcArray< T, R > | inline
logicalLength() const | AcArray< T, R > | inline
mGrowLen (defined in AcArray< T, R >) | AcArray< T, R > | protected
mLogicalLen (defined in AcArray< T, R >) | AcArray< T, R > | protected
mpArray (defined in AcArray< T, R >) | AcArray< T, R > | protected
mPhysicalLen (defined in AcArray< T, R >) | AcArray< T, R > | protected
operator=(const AcArray< T, R > &) | AcArray< T, R > |
operator==(const AcArray< T, R > &) const | AcArray< T, R > |
operator[](int) | AcArray< T, R > | inline
operator[](int) const | AcArray< T, R > | inline
physicalLength() const | AcArray< T, R > | inline
remove(const T &value, int start=0) | AcArray< T, R > |
removeAll() | AcArray< T, R > | inline
removeAt(int index) | AcArray< T, R > |
removeFirst() | AcArray< T, R > | inline
removeLast() | AcArray< T, R > | inline
removeSubArray(int startIndex, int endIndex) | AcArray< T, R > |
reverse() | AcArray< T, R > |
setAll(const T &value) | AcArray< T, R > |
setAt(int index, const T &value) | AcArray< T, R > | inline
setGrowLength(int) | AcArray< T, R > | inline
setLogicalLength(int) | AcArray< T, R > |
setPhysicalLength(int) | AcArray< T, R > |
setVariant(VARIANT &var) const (defined in AcAxPoint3dArray) | AcAxPoint3dArray |
setVariant(VARIANT *var) const (defined in AcAxPoint3dArray) | AcAxPoint3dArray |
swap(int i1, int i2) | AcArray< T, R > |
~AcArray() (defined in AcArray< T, R >) | AcArray< T, R > |


ZRX API Reference: AcCm Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Functions
AcCm Classes

Classes

class | AcCmColor
class | AcCmColorBase
class | AcCmComplexColor
class | AcCmDialogColor
class | AcCmEntityColor
class | AcCmTransparency

Functions

AcCmEntityColor::AcCmEntityColor (const AcCmEntityColor &color)
AcCmEntityColor::AcCmEntityColor (const ColorMethod eColorMethod)
AcCmEntityColor::AcCmEntityColor (const Adesk::UInt8 red, const Adesk::UInt8 green, const Adesk::UInt8 blue)
Adesk::UInt8 | AcCmEntityColor::blue () const
Adesk::UInt32 | AcCmEntityColor::color () const
ColorMethod | AcCmEntityColor::colorMethod () const
Adesk::UInt8 | AcCmEntityColor::green () const
Adesk::Int16 | AcCmEntityColor::indirect () const
bool | AcCmEntityColor::isByACI () const
bool | AcCmEntityColor::isByBlock () const
bool | AcCmEntityColor::isByColor () const
bool | AcCmEntityColor::isByLayer () const
bool | AcCmEntityColor::isByPen () const
bool | AcCmEntityColor::isForeground () const
bool | AcCmEntityColor::isLayerFrozen () const
bool | AcCmEntityColor::isLayerFrozenOrOff () const
bool | AcCmEntityColor::isLayerOff () const
bool | AcCmEntityColor::isNone () const
Adesk::Int16 | AcCmEntityColor::layerIndex () const
bool | AcCmEntityColor::operator!= (const AcCmEntityColor &color) const
AcCmEntityColor & | AcCmEntityColor::operator= (const AcCmEntityColor &color)
bool | AcCmEntityColor::operator== (const AcCmEntityColor &color) const
Adesk::UInt16 | AcCmEntityColor::penIndex () const
Adesk::UInt8 | AcCmEntityColor::red () const
Acad::ErrorStatus | AcCmEntityColor::setIndirect (const Adesk::Int16 Indirect)

Detailed Description


ZRX API Reference: AcCmColor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Attributes | List of all members
AcCmColor Class Reference
AcCm Classes
+ Inheritance diagram for AcCmColor:

Public Member Functions

AcCmColor (const AcCmColor &)
AcCmColor (const AcCmColorBase &)
Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
virtual Adesk::UInt8 | blue () const
virtual const ACHAR * | bookName (void) const
virtual Adesk::UInt32 | color () const
virtual Adesk::UInt16 | colorIndex () const
virtual
AcCmEntityColor::ColorMethod 		colorMethod () const
virtual const ACHAR * | colorName (void) const
virtual const ACHAR * | colorNameForDisplay (void)
AcCmComplexColor * | complexColor () const
int | dictionaryKeyLength (void) const
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pInputFiler)
Acad::ErrorStatus | dwgInAsTrueColor (AcDbDwgFiler *pInputFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pOutputFiler) const
Acad::ErrorStatus | dwgOutAsTrueColor (AcDbDwgFiler *pOutputFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler, int groupCodeOffset=0)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, int groupCodeOffset=0) const
AcCmEntityColor | entityColor (void) const
Acad::ErrorStatus | getDescription (ACHAR *&desc) const
void | getDictionaryKey (ACHAR *) const
Acad::ErrorStatus | getExplanation (ACHAR *&expl) const
virtual Adesk::UInt8 | green () const
virtual bool | hasBookName (void) const
virtual bool | hasColorName (void) const
virtual bool | isByACI () const
virtual bool | isByBlock () const
virtual bool | isByColor () const
virtual bool | isByLayer () const
virtual bool | isByPen () const
virtual bool | isForeground () const
bool | isNone () const
bool | operator!= (const AcCmColor &color) const
bool | operator!= (const AcCmColorBase &color) const
AcCmColor & | operator= (const AcCmColor &inputColor)
AcCmColor & | operator= (const AcCmColorBase &inputColor)
bool | operator== (const AcCmColor &color) const
bool | operator== (const AcCmColorBase &color) const
virtual Adesk::UInt16 | penIndex () const
virtual Adesk::UInt8 | red () const
Acad::ErrorStatus | serializeIn (const void *pBuff, int *pBuflen)
Acad::ErrorStatus | serializeOut (void *pBuff, int *pBuflen, AcDb::AcDbDwgVersion ver=AcDb::kDHL_CURRENT) const
virtual Acad::ErrorStatus | setBlue (Adesk::UInt8 blue)
virtual Acad::ErrorStatus | setColor (Adesk::UInt32 color)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 colorIndex)
virtual Acad::ErrorStatus | setColorMethod (AcCmEntityColor::ColorMethod eColorMethod)
void | setComplexColor (AcCmComplexColor *pComplex)
virtual Acad::ErrorStatus | setGreen (Adesk::UInt8 green)
virtual Acad::ErrorStatus | setNames (const ACHAR *colorName, const ACHAR *bookName=NULL)
Acad::ErrorStatus | setNamesFromDictionaryKey (const ACHAR *)
virtual Acad::ErrorStatus | setPenIndex (Adesk::UInt16 penIndex)
virtual Acad::ErrorStatus | setRed (Adesk::UInt8 red)
virtual Acad::ErrorStatus | setRGB (Adesk::UInt8 red, Adesk::UInt8 green, Adesk::UInt8 blue)

Static Public Attributes

static const Adesk::UInt16 MaxColorIndex
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCmColor Member List

This is the complete list of members for AcCmColor, including all inherited members.

AcCmColor() (defined in AcCmColor) | AcCmColor |
AcCmColor(const AcCmColor &) (defined in AcCmColor) | AcCmColor |
AcCmColor(const AcCmColorBase &) (defined in AcCmColor) | AcCmColor |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcCmColor) | AcCmColor |
blue() const (defined in AcCmColor) | AcCmColor | virtual
bookName(void) const (defined in AcCmColor) | AcCmColor | virtual
color() const (defined in AcCmColor) | AcCmColor | virtual
colorIndex() const (defined in AcCmColor) | AcCmColor | virtual
colorMethod() const (defined in AcCmColor) | AcCmColor | virtual
colorName(void) const (defined in AcCmColor) | AcCmColor | virtual
colorNameForDisplay(void) (defined in AcCmColor) | AcCmColor | virtual
complexColor() const (defined in AcCmColor) | AcCmColor |
dictionaryKeyLength(void) const (defined in AcCmColor) | AcCmColor |
dwgIn(AcDbDwgFiler *pInputFiler) (defined in AcCmColor) | AcCmColor |
dwgInAsTrueColor(AcDbDwgFiler *pInputFiler) (defined in AcCmColor) | AcCmColor |
dwgOut(AcDbDwgFiler *pOutputFiler) const (defined in AcCmColor) | AcCmColor |
dwgOutAsTrueColor(AcDbDwgFiler *pOutputFiler) const (defined in AcCmColor) | AcCmColor |
dxfIn(AcDbDxfFiler *pFiler, int groupCodeOffset=0) (defined in AcCmColor) | AcCmColor |
dxfOut(AcDbDxfFiler *pFiler, int groupCodeOffset=0) const (defined in AcCmColor) | AcCmColor |
entityColor(void) const (defined in AcCmColor) | AcCmColor |
getDescription(ACHAR *&desc) const (defined in AcCmColor) | AcCmColor |
getDictionaryKey(ACHAR *) const (defined in AcCmColor) | AcCmColor |
getExplanation(ACHAR *&expl) const (defined in AcCmColor) | AcCmColor |
green() const (defined in AcCmColor) | AcCmColor | virtual
hasBookName(void) const (defined in AcCmColor) | AcCmColor | virtual
hasColorName(void) const (defined in AcCmColor) | AcCmColor | virtual
isByACI() const (defined in AcCmColor) | AcCmColor | virtual
isByBlock() const (defined in AcCmColor) | AcCmColor | virtual
isByColor() const (defined in AcCmColor) | AcCmColor | virtual
isByLayer() const (defined in AcCmColor) | AcCmColor | virtual
isByPen() const (defined in AcCmColor) | AcCmColor | virtual
isForeground() const (defined in AcCmColor) | AcCmColor | virtual
isNone() const (defined in AcCmColor) | AcCmColor |
MaxColorIndex (defined in AcCmColor) | AcCmColor | static
operator!=(const AcCmColor &color) const (defined in AcCmColor) | AcCmColor |
operator!=(const AcCmColorBase &color) const (defined in AcCmColor) | AcCmColor |
operator=(const AcCmColor &inputColor) (defined in AcCmColor) | AcCmColor |
operator=(const AcCmColorBase &inputColor) (defined in AcCmColor) | AcCmColor |
operator==(const AcCmColor &color) const (defined in AcCmColor) | AcCmColor |
operator==(const AcCmColorBase &color) const (defined in AcCmColor) | AcCmColor |
penIndex() const (defined in AcCmColor) | AcCmColor | virtual
red() const (defined in AcCmColor) | AcCmColor | virtual
serializeIn(const void *pBuff, int *pBuflen) (defined in AcCmColor) | AcCmColor |
serializeOut(void *pBuff, int *pBuflen, AcDb::AcDbDwgVersion ver=AcDb::kDHL_CURRENT) const (defined in AcCmColor) | AcCmColor |
setBlue(Adesk::UInt8 blue) (defined in AcCmColor) | AcCmColor | virtual
setColor(Adesk::UInt32 color) (defined in AcCmColor) | AcCmColor | virtual
setColorIndex(Adesk::UInt16 colorIndex) (defined in AcCmColor) | AcCmColor | virtual
setColorMethod(AcCmEntityColor::ColorMethod eColorMethod) (defined in AcCmColor) | AcCmColor | virtual
setComplexColor(AcCmComplexColor *pComplex) (defined in AcCmColor) | AcCmColor |
setGreen(Adesk::UInt8 green) (defined in AcCmColor) | AcCmColor | virtual
setNames(const ACHAR *colorName, const ACHAR *bookName=NULL) (defined in AcCmColor) | AcCmColor | virtual
setNamesFromDictionaryKey(const ACHAR *) (defined in AcCmColor) | AcCmColor |
setPenIndex(Adesk::UInt16 penIndex) (defined in AcCmColor) | AcCmColor | virtual
setRed(Adesk::UInt8 red) (defined in AcCmColor) | AcCmColor | virtual
setRGB(Adesk::UInt8 red, Adesk::UInt8 green, Adesk::UInt8 blue) (defined in AcCmColor) | AcCmColor | virtual
~AcCmColor() (defined in AcCmColor) | AcCmColor |
~AcCmColorBase() (defined in AcCmColorBase) | AcCmColorBase | inlinevirtual


ZRX API Reference: AcCmColorBase Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcCmColorBase Class Reference
AcCm Classes
+ Inheritance diagram for AcCmColorBase:

Public Member Functions

virtual Adesk::UInt8 | blue () const =0
virtual const ACHAR * | bookName (void) const =0
virtual Adesk::UInt32 | color () const =0
virtual Adesk::UInt16 | colorIndex () const =0
virtual
AcCmEntityColor::ColorMethod 		colorMethod () const =0
virtual const ACHAR * | colorName (void) const =0
virtual const ACHAR * | colorNameForDisplay (void)=0
virtual Adesk::UInt8 | green () const =0
virtual bool | hasBookName (void) const =0
virtual bool | hasColorName (void) const =0
virtual bool | isByACI () const =0
virtual bool | isByBlock () const =0
virtual bool | isByColor () const =0
virtual bool | isByLayer () const =0
virtual bool | isByPen () const =0
virtual bool | isForeground () const =0
virtual Adesk::UInt16 | penIndex () const =0
virtual Adesk::UInt8 | red () const =0
virtual Acad::ErrorStatus | setBlue (Adesk::UInt8 blue)=0
virtual Acad::ErrorStatus | setColor (Adesk::UInt32 color)=0
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 colorIndex)=0
virtual Acad::ErrorStatus | setColorMethod (AcCmEntityColor::ColorMethod eColorMethod)=0
virtual Acad::ErrorStatus | setGreen (Adesk::UInt8 green)=0
virtual Acad::ErrorStatus | setNames (const ACHAR *colorName, const ACHAR *bookName=NULL)=0
virtual Acad::ErrorStatus | setPenIndex (Adesk::UInt16 penIndex)=0
virtual Acad::ErrorStatus | setRed (Adesk::UInt8 red)=0
virtual Acad::ErrorStatus | setRGB (Adesk::UInt8 red, Adesk::UInt8 green, Adesk::UInt8 blue)=0
The documentation for this class was generated from the following file:
  • dbcolor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCmColorBase Member List

This is the complete list of members for AcCmColorBase, including all inherited members.

blue() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
bookName(void) const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
color() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
colorIndex() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
colorMethod() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
colorName(void) const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
colorNameForDisplay(void)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
green() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
hasBookName(void) const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
hasColorName(void) const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
isByACI() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
isByBlock() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
isByColor() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
isByLayer() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
isByPen() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
isForeground() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
penIndex() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
red() const =0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
setBlue(Adesk::UInt8 blue)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
setColor(Adesk::UInt32 color)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
setColorIndex(Adesk::UInt16 colorIndex)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
setColorMethod(AcCmEntityColor::ColorMethod eColorMethod)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
setGreen(Adesk::UInt8 green)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
setNames(const ACHAR *colorName, const ACHAR *bookName=NULL)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
setPenIndex(Adesk::UInt16 penIndex)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
setRed(Adesk::UInt8 red)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
setRGB(Adesk::UInt8 red, Adesk::UInt8 green, Adesk::UInt8 blue)=0 (defined in AcCmColorBase) | AcCmColorBase | pure virtual
~AcCmColorBase() (defined in AcCmColorBase) | AcCmColorBase | inlinevirtual


ZRX API Reference: AcCmComplexColor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcCmComplexColor Class Reference
AcCm Classes
+ Inheritance diagram for AcCmComplexColor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcCmComplexColor)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
virtual Adesk::UInt8 | blue () const
virtual Adesk::UInt32 | color () const
virtual Adesk::UInt16 | colorIndex () const
virtual
AcCmEntityColor::ColorMethod 		colorMethod () const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *)
virtual void | decReference ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Acad::ErrorStatus | getDescription (ACHAR *&desc) const
virtual Acad::ErrorStatus | getExplanation (ACHAR *&expl) const
virtual Adesk::UInt8 | green () const
virtual AcCmComplexColor * | incReference ()
virtual bool | isByACI () const
virtual bool | isByBlock () const
virtual bool | isByColor () const
virtual bool | isByLayer () const
virtual bool | isByPen () const
virtual bool | isForeground () const
virtual Adesk::UInt16 | penIndex () const
virtual Adesk::UInt8 | red () const
virtual Acad::ErrorStatus | setBlue (Adesk::UInt8 blue)
virtual Acad::ErrorStatus | setColor (Adesk::UInt32 color)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 colorIndex)
virtual Acad::ErrorStatus | setColorMethod (AcCmEntityColor::ColorMethod eColorMethod)
virtual Acad::ErrorStatus | setGreen (Adesk::UInt8 green)
virtual Acad::ErrorStatus | setPenIndex (Adesk::UInt16 penIndex)
virtual Acad::ErrorStatus | setRed (Adesk::UInt8 red)
virtual Acad::ErrorStatus | setRGB (Adesk::UInt8 red, Adesk::UInt8 green, Adesk::UInt8 blue)
- Public Member Functions inherited from AcDbXObject
ACRX_DECLARE_MEMBERS (AcDbXObject)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCmComplexColor Member List

This is the complete list of members for AcCmComplexColor, including all inherited members.

AcDbXObject() (defined in AcDbXObject) | AcDbXObject | protected
ACRX_DECLARE_MEMBERS(AcCmComplexColor) (defined in AcCmComplexColor) | AcCmComplexColor |
ACRX_DECLARE_MEMBERS(AcDbXObject) (defined in AcDbXObject) | AcDbXObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
audit(AcDbAuditInfo *pAuditInfo) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
blue() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
colorIndex() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
colorMethod() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
decReference() (defined in AcCmComplexColor) | AcCmComplexColor | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbXObject) | AcDbXObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbXObject) | AcDbXObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbXObject) | AcDbXObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
dxfOut(AcDbDxfFiler *pFiler) const (defined in AcDbXObject) | AcDbXObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
getDescription(ACHAR *&desc) const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
getExplanation(ACHAR *&expl) const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
green() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
incReference() (defined in AcCmComplexColor) | AcCmComplexColor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isByACI() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
isByBlock() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
isByColor() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
isByLayer() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
isByPen() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isForeground() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
penIndex() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
red() const (defined in AcCmComplexColor) | AcCmComplexColor | virtual
setBlue(Adesk::UInt8 blue) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
setColor(Adesk::UInt32 color) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
setColorIndex(Adesk::UInt16 colorIndex) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
setColorMethod(AcCmEntityColor::ColorMethod eColorMethod) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
setGreen(Adesk::UInt8 green) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
setPenIndex(Adesk::UInt16 penIndex) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
setRed(Adesk::UInt8 red) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
setRGB(Adesk::UInt8 red, Adesk::UInt8 green, Adesk::UInt8 blue) (defined in AcCmComplexColor) | AcCmComplexColor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcCmDialogColor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcCmDialogColor Class Reference
AcCm Classes
+ Inheritance diagram for AcCmDialogColor:

Public Member Functions

AcCmDialogColor ()
AcCmDialogColor (const AcCmDialogColor &other)
AcCmDialogColor (const AcCmColorBase &other)
virtual Adesk::UInt8 | blue () const
virtual const ACHAR * | bookName (void) const
virtual Adesk::UInt32 | color () const
virtual Adesk::UInt16 | colorIndex () const
virtual
AcCmEntityColor::ColorMethod 		colorMethod () const
virtual const ACHAR * | colorName (void) const
virtual const ACHAR * | colorNameForDisplay (void)
virtual Adesk::UInt8 | green () const
virtual bool | hasBookName (void) const
virtual bool | hasColorName (void) const
virtual bool | isByACI () const
virtual bool | isByBlock () const
virtual bool | isByColor () const
virtual bool | isByLayer () const
virtual bool | isByPen () const
virtual bool | isForeground () const
bool | operator!= (const AcCmDialogColor &color) const
bool | operator!= (const AcCmColorBase &color) const
AcCmDialogColor & | operator= (const AcCmDialogColor &inputColor)
AcCmDialogColor & | operator= (const AcCmColorBase &inputColor)
bool | operator== (const AcCmDialogColor &color) const
bool | operator== (const AcCmColorBase &color) const
virtual Adesk::UInt16 | penIndex () const
virtual Adesk::UInt8 | red () const
virtual Acad::ErrorStatus | setBlue (Adesk::UInt8 blue)
virtual Acad::ErrorStatus | setColor (Adesk::UInt32 color)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 colorIndex)
virtual Acad::ErrorStatus | setColorMethod (AcCmEntityColor::ColorMethod eColorMethod)
virtual Acad::ErrorStatus | setGreen (Adesk::UInt8 green)
virtual Acad::ErrorStatus | setNames (const ACHAR *colorName, const ACHAR *bookName=NULL)
virtual Acad::ErrorStatus | setPenIndex (Adesk::UInt16 penIndex)
virtual Acad::ErrorStatus | setRed (Adesk::UInt8 red)
virtual Acad::ErrorStatus | setRGB (Adesk::UInt8 red, Adesk::UInt8 green, Adesk::UInt8 blue)
virtual | ~AcCmDialogColor ()

Constructor & Destructor Documentation

AcCmDialogColor::AcCmDialogColor ( )
Warning
Not implemented!
AcCmDialogColor::AcCmDialogColor ( const AcCmDialogColor & other )
Warning
Not implemented!
AcCmDialogColor::AcCmDialogColor ( const AcCmColorBase & other )
Warning
Not implemented!
virtual AcCmDialogColor::~AcCmDialogColor ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Adesk::UInt8 AcCmDialogColor::blue ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual const ACHAR* AcCmDialogColor::bookName ( void ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Adesk::UInt32 AcCmDialogColor::color ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Adesk::UInt16 AcCmDialogColor::colorIndex ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual AcCmEntityColor::ColorMethod AcCmDialogColor::colorMethod ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual const ACHAR* AcCmDialogColor::colorName ( void ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual const ACHAR* AcCmDialogColor::colorNameForDisplay ( void )
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Adesk::UInt8 AcCmDialogColor::green ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual bool AcCmDialogColor::hasBookName ( void ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual bool AcCmDialogColor::hasColorName ( void ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual bool AcCmDialogColor::isByACI ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual bool AcCmDialogColor::isByBlock ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual bool AcCmDialogColor::isByColor ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual bool AcCmDialogColor::isByLayer ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual bool AcCmDialogColor::isByPen ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual bool AcCmDialogColor::isForeground ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

bool AcCmDialogColor::operator!= ( const AcCmDialogColor & color ) const
Warning
Not implemented!
bool AcCmDialogColor::operator!= ( const AcCmColorBase & color ) const
Warning
Not implemented!
AcCmDialogColor& AcCmDialogColor::operator= ( const AcCmDialogColor & inputColor )
Warning
Not implemented!
AcCmDialogColor& AcCmDialogColor::operator= ( const AcCmColorBase & inputColor )
Warning
Not implemented!
bool AcCmDialogColor::operator== ( const AcCmDialogColor & color ) const
Warning
Not implemented!
bool AcCmDialogColor::operator== ( const AcCmColorBase & color ) const
Warning
Not implemented!
virtual Adesk::UInt16 AcCmDialogColor::penIndex ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Adesk::UInt8 AcCmDialogColor::red ( ) const
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Acad::ErrorStatus AcCmDialogColor::setBlue ( Adesk::UInt8 blue )
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Acad::ErrorStatus AcCmDialogColor::setColor ( Adesk::UInt32 color )
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Acad::ErrorStatus AcCmDialogColor::setColorIndex ( Adesk::UInt16 colorIndex )
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Acad::ErrorStatus AcCmDialogColor::setColorMethod ( AcCmEntityColor::ColorMethod eColorMethod )
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Acad::ErrorStatus AcCmDialogColor::setGreen ( Adesk::UInt8 green )
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Acad::ErrorStatus AcCmDialogColor::setNames | ( | const ACHAR * | colorName,
 |  | const ACHAR * | bookName = NULL
 | ) |  |
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Acad::ErrorStatus AcCmDialogColor::setPenIndex ( Adesk::UInt16 penIndex )
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Acad::ErrorStatus AcCmDialogColor::setRed ( Adesk::UInt8 red )
virtual
Warning
Not implemented!

Implements AcCmColorBase.

virtual Acad::ErrorStatus AcCmDialogColor::setRGB | ( | Adesk::UInt8 | red,
 |  | Adesk::UInt8 | green,
 |  | Adesk::UInt8 | blue
 | ) |  |
virtual
Warning
Not implemented!

Implements AcCmColorBase.

The documentation for this class was generated from the following file:
  • dbcolor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCmDialogColor Member List

This is the complete list of members for AcCmDialogColor, including all inherited members.

AcCmDialogColor() | AcCmDialogColor |
AcCmDialogColor(const AcCmDialogColor &other) | AcCmDialogColor |
AcCmDialogColor(const AcCmColorBase &other) | AcCmDialogColor |
blue() const | AcCmDialogColor | virtual
bookName(void) const | AcCmDialogColor | virtual
color() const | AcCmDialogColor | virtual
colorIndex() const | AcCmDialogColor | virtual
colorMethod() const | AcCmDialogColor | virtual
colorName(void) const | AcCmDialogColor | virtual
colorNameForDisplay(void) | AcCmDialogColor | virtual
green() const | AcCmDialogColor | virtual
hasBookName(void) const | AcCmDialogColor | virtual
hasColorName(void) const | AcCmDialogColor | virtual
isByACI() const | AcCmDialogColor | virtual
isByBlock() const | AcCmDialogColor | virtual
isByColor() const | AcCmDialogColor | virtual
isByLayer() const | AcCmDialogColor | virtual
isByPen() const | AcCmDialogColor | virtual
isForeground() const | AcCmDialogColor | virtual
operator!=(const AcCmDialogColor &color) const | AcCmDialogColor |
operator!=(const AcCmColorBase &color) const | AcCmDialogColor |
operator=(const AcCmDialogColor &inputColor) | AcCmDialogColor |
operator=(const AcCmColorBase &inputColor) | AcCmDialogColor |
operator==(const AcCmDialogColor &color) const | AcCmDialogColor |
operator==(const AcCmColorBase &color) const | AcCmDialogColor |
penIndex() const | AcCmDialogColor | virtual
red() const | AcCmDialogColor | virtual
setBlue(Adesk::UInt8 blue) | AcCmDialogColor | virtual
setColor(Adesk::UInt32 color) | AcCmDialogColor | virtual
setColorIndex(Adesk::UInt16 colorIndex) | AcCmDialogColor | virtual
setColorMethod(AcCmEntityColor::ColorMethod eColorMethod) | AcCmDialogColor | virtual
setGreen(Adesk::UInt8 green) | AcCmDialogColor | virtual
setNames(const ACHAR *colorName, const ACHAR *bookName=NULL) | AcCmDialogColor | virtual
setPenIndex(Adesk::UInt16 penIndex) | AcCmDialogColor | virtual
setRed(Adesk::UInt8 red) | AcCmDialogColor | virtual
setRGB(Adesk::UInt8 red, Adesk::UInt8 green, Adesk::UInt8 blue) | AcCmDialogColor | virtual
~AcCmColorBase() (defined in AcCmColorBase) | AcCmColorBase | inlinevirtual
~AcCmDialogColor() | AcCmDialogColor | virtual


ZRX API Reference: AcCmEntityColor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Classes | Public Types | Public Member Functions | Static Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
AcCmEntityColor Class Reference
AcCm Classes

Classes

union RGBM

Public Types

enum ACIcolorMethod {
kACIbyBlock = 0, kACIforeground = 7, kACIbyLayer = 256, kACIclear = 0,
kACIstandard = 7, kACImaximum = 255, kACInone = 257, kACIminimum = -255,
kACIfrozenLayer = -32700
}
enum Color { kRed, kGreen, kBlue }
enum ColorMethod {
kByLayer = 0xC0, kByBlock, kByColor, kByACI,
kByPen, kForeground, kLayerOff, kLayerFrozen,
kNone
}

Public Member Functions

AcCmEntityColor (const AcCmEntityColor &color)
AcCmEntityColor (const ColorMethod eColorMethod)
AcCmEntityColor (const Adesk::UInt8 red, const Adesk::UInt8 green, const Adesk::UInt8 blue)
Adesk::UInt8 | blue () const
Adesk::UInt32 | color () const
Adesk::Int16 | colorIndex () const
ColorMethod | colorMethod () const
Adesk::UInt8 | green () const
bool | isByACI () const
bool | isByBlock () const
bool | isByColor () const
bool | isByLayer () const
bool | isByPen () const
bool | isForeground () const
bool | isLayerFrozen () const
bool | isLayerFrozenOrOff () const
bool | isLayerOff () const
bool | isNone () const
Adesk::Int16 | layerIndex () const
bool | operator!= (const AcCmEntityColor &color) const
AcCmEntityColor & | operator= (const AcCmEntityColor &color)
bool | operator== (const AcCmEntityColor &color) const
Adesk::UInt16 | penIndex () const
Adesk::UInt8 | red () const
Acad::ErrorStatus | setBlue (const Adesk::UInt8 blue)
Acad::ErrorStatus | setColor (const Adesk::UInt32 color)
Acad::ErrorStatus | setColorIndex (const Adesk::Int16 colorIndex)
Acad::ErrorStatus | setColorMethod (const ColorMethod eColorMethod)
Acad::ErrorStatus | setGreen (const Adesk::UInt8 green)
Acad::ErrorStatus | setLayerIndex (const Adesk::Int16 layerIndex)
Acad::ErrorStatus | setPenIndex (const Adesk::UInt16 penIndex)
Acad::ErrorStatus | setRed (const Adesk::UInt8 red)
Acad::ErrorStatus | setRGB (const Adesk::UInt8 red, const Adesk::UInt8 green, const Adesk::UInt8 blue)
Acad::ErrorStatus | setTrueColor ()
Acad::ErrorStatus | setTrueColorMethod ()
Adesk::UInt32 | trueColor () const
Adesk::UInt8 | trueColorMethod () const

Static Public Member Functions

static Adesk::UInt8 | blue (const RGBM *rgbm)
static Adesk::UInt32 | color (const RGBM *rgbm)
static Adesk::Int16 | colorIndex (const RGBM *rgbm)
static ColorMethod | colorMethod (const RGBM *rgbm)
static Adesk::UInt8 | green (const RGBM *rgbm)
static bool | isByACI (const RGBM *rgbm)
static bool | isByBlock (const RGBM *rgbm)
static bool | isByColor (const RGBM *rgbm)
static bool | isByLayer (const RGBM *rgbm)
static bool | isByPen (const RGBM *rgbm)
static bool | isForeground (const RGBM *rgbm)
static bool | isLayerFrozen (const RGBM *rgbm)
static bool | isLayerOff (const RGBM *rgbm)
static bool | isNone (const RGBM *rgbm)
static Adesk::Int16 | layerIndex (const RGBM *rgbm)
static Adesk::UInt8 | lookUpACI (const Adesk::UInt8 red, const Adesk::UInt8 green, const Adesk::UInt8 blue)
static Adesk::UInt32 | lookUpRGB (const Adesk::UInt8 colorIndex)
static Adesk::UInt16 | penIndex (const RGBM *rgbm)
static Adesk::UInt8 | red (const RGBM *rgbm)
static Acad::ErrorStatus | setBlue (RGBM *rgbm, const Adesk::UInt8 blue)
static Acad::ErrorStatus | setColor (RGBM *rgbm, const Adesk::UInt32 color)
static Acad::ErrorStatus | setColorIndex (RGBM *rgbm, const Adesk::Int16 colorIndex)
static Acad::ErrorStatus | setColorMethod (RGBM *rgbm, const ColorMethod eColorMethod)
static Acad::ErrorStatus | setGreen (RGBM *rgbm, const Adesk::UInt8 green)
static Acad::ErrorStatus | setLayerIndex (RGBM *rgbm, const Adesk::Int16 layerIndex)
static Acad::ErrorStatus | setPenIndex (RGBM *rgbm, const Adesk::UInt16 penIndex)
static Acad::ErrorStatus | setRed (RGBM *rgbm, const Adesk::UInt8 red)
static Acad::ErrorStatus | setRGB (RGBM *rgbm, const Adesk::UInt8 red, const Adesk::UInt8 green, const Adesk::UInt8 blue)
static Acad::ErrorStatus | setTrueColor (RGBM *rgbm)
static Acad::ErrorStatus | setTrueColorMethod (RGBM *rgbm)
static Adesk::UInt32 | trueColor (const RGBM *rgbm)
static Adesk::UInt8 | trueColorMethod (const Adesk::Int16)

Static Public Attributes

static const Adesk::UInt8 mLUT [256][3]

Protected Member Functions

Adesk::Int16 | indirect () const
Acad::ErrorStatus | setIndirect (const Adesk::Int16 Indirect)

Protected Attributes

RGBM mRGBM
The documentation for this class was generated from the following file:
  • dbcolor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCmEntityColor Member List

This is the complete list of members for AcCmEntityColor, including all inherited members.

AcCmEntityColor() (defined in AcCmEntityColor) | AcCmEntityColor | inline
AcCmEntityColor(const AcCmEntityColor &color) (defined in AcCmEntityColor) | AcCmEntityColor | inline
AcCmEntityColor(const ColorMethod eColorMethod) (defined in AcCmEntityColor) | AcCmEntityColor | inline
AcCmEntityColor(const Adesk::UInt8 red, const Adesk::UInt8 green, const Adesk::UInt8 blue) (defined in AcCmEntityColor) | AcCmEntityColor | inline
ACIcolorMethod enum name (defined in AcCmEntityColor) | AcCmEntityColor |
blue() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
blue(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
color() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
color(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
Color enum name (defined in AcCmEntityColor) | AcCmEntityColor |
colorIndex() const (defined in AcCmEntityColor) | AcCmEntityColor |
colorIndex(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
colorMethod() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
colorMethod(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
ColorMethod enum name (defined in AcCmEntityColor) | AcCmEntityColor |
green() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
green(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
indirect() const (defined in AcCmEntityColor) | AcCmEntityColor | inlineprotected
isByACI() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isByACI(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
isByBlock() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isByBlock(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
isByColor() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isByColor(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
isByLayer() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isByLayer(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
isByPen() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isByPen(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
isForeground() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isForeground(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
isLayerFrozen() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isLayerFrozen(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
isLayerFrozenOrOff() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isLayerOff() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isLayerOff(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
isNone() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
isNone(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
kACIbyBlock enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kACIbyLayer enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kACIclear enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kACIforeground enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kACIfrozenLayer enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kACImaximum enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kACIminimum enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kACInone enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kACIstandard enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kBlue enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kByACI enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kByBlock enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kByColor enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kByLayer enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kByPen enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kForeground enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kGreen enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kLayerFrozen enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kLayerOff enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kNone enum value (defined in AcCmEntityColor) | AcCmEntityColor |
kRed enum value (defined in AcCmEntityColor) | AcCmEntityColor |
layerIndex() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
layerIndex(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
lookUpACI(const Adesk::UInt8 red, const Adesk::UInt8 green, const Adesk::UInt8 blue) (defined in AcCmEntityColor) | AcCmEntityColor | static
lookUpRGB(const Adesk::UInt8 colorIndex) (defined in AcCmEntityColor) | AcCmEntityColor | static
mLUT (defined in AcCmEntityColor) | AcCmEntityColor | static
mRGBM (defined in AcCmEntityColor) | AcCmEntityColor | protected
operator!=(const AcCmEntityColor &color) const (defined in AcCmEntityColor) | AcCmEntityColor | inline
operator=(const AcCmEntityColor &color) (defined in AcCmEntityColor) | AcCmEntityColor | inline
operator==(const AcCmEntityColor &color) const (defined in AcCmEntityColor) | AcCmEntityColor | inline
penIndex() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
penIndex(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
red() const (defined in AcCmEntityColor) | AcCmEntityColor | inline
red(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
setBlue(const Adesk::UInt8 blue) (defined in AcCmEntityColor) | AcCmEntityColor |
setBlue(RGBM *rgbm, const Adesk::UInt8 blue) (defined in AcCmEntityColor) | AcCmEntityColor | static
setColor(const Adesk::UInt32 color) (defined in AcCmEntityColor) | AcCmEntityColor |
setColor(RGBM *rgbm, const Adesk::UInt32 color) (defined in AcCmEntityColor) | AcCmEntityColor | static
setColorIndex(const Adesk::Int16 colorIndex) (defined in AcCmEntityColor) | AcCmEntityColor |
setColorIndex(RGBM *rgbm, const Adesk::Int16 colorIndex) (defined in AcCmEntityColor) | AcCmEntityColor | static
setColorMethod(const ColorMethod eColorMethod) (defined in AcCmEntityColor) | AcCmEntityColor |
setColorMethod(RGBM *rgbm, const ColorMethod eColorMethod) (defined in AcCmEntityColor) | AcCmEntityColor | static
setGreen(const Adesk::UInt8 green) (defined in AcCmEntityColor) | AcCmEntityColor |
setGreen(RGBM *rgbm, const Adesk::UInt8 green) (defined in AcCmEntityColor) | AcCmEntityColor | static
setIndirect(const Adesk::Int16 Indirect) (defined in AcCmEntityColor) | AcCmEntityColor | inlineprotected
setLayerIndex(const Adesk::Int16 layerIndex) (defined in AcCmEntityColor) | AcCmEntityColor |
setLayerIndex(RGBM *rgbm, const Adesk::Int16 layerIndex) (defined in AcCmEntityColor) | AcCmEntityColor | static
setPenIndex(const Adesk::UInt16 penIndex) (defined in AcCmEntityColor) | AcCmEntityColor |
setPenIndex(RGBM *rgbm, const Adesk::UInt16 penIndex) (defined in AcCmEntityColor) | AcCmEntityColor | static
setRed(const Adesk::UInt8 red) (defined in AcCmEntityColor) | AcCmEntityColor |
setRed(RGBM *rgbm, const Adesk::UInt8 red) (defined in AcCmEntityColor) | AcCmEntityColor | static
setRGB(const Adesk::UInt8 red, const Adesk::UInt8 green, const Adesk::UInt8 blue) (defined in AcCmEntityColor) | AcCmEntityColor |
setRGB(RGBM *rgbm, const Adesk::UInt8 red, const Adesk::UInt8 green, const Adesk::UInt8 blue) (defined in AcCmEntityColor) | AcCmEntityColor | static
setTrueColor() (defined in AcCmEntityColor) | AcCmEntityColor |
setTrueColor(RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
setTrueColorMethod() (defined in AcCmEntityColor) | AcCmEntityColor |
setTrueColorMethod(RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
trueColor() const (defined in AcCmEntityColor) | AcCmEntityColor |
trueColor(const RGBM *rgbm) (defined in AcCmEntityColor) | AcCmEntityColor | static
trueColorMethod() const (defined in AcCmEntityColor) | AcCmEntityColor |
trueColorMethod(const Adesk::Int16) (defined in AcCmEntityColor) | AcCmEntityColor | static


ZRX API Reference: AcCmTransparency Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Classes | Public Types | Public Member Functions | List of all members
AcCmTransparency Class Reference
AcCm Classes

Classes

union AM

Public Types

enum | { kTransparencyByLayer = (unsigned long)kByLayer, kTransparencyByBlock = (unsigned long)kByBlock, kTransparencySolid = ((unsigned long)(kByAlpha | (0xff << 24))), kTransparencyClear = (unsigned long)kByAlpha }
enum | transparencyMethod { kByLayer = 0, kByBlock, kByAlpha, kErrorValue }

Public Member Functions

AcCmTransparency (const AcCmTransparency &other)
Adesk::UInt8 | alpha (void) const
bool | isByAlpha (void) const
bool | isByBlock (void) const
bool | isByLayer (void) const
bool | isClear (void) const
bool | isSolid (void) const
bool | operator!= (const AcCmTransparency &other) const
AcCmTransparency & | operator= (const AcCmTransparency &other)
bool | operator== (const AcCmTransparency &other) const
void | serializeIn (Adesk::UInt32)
Adesk::UInt32 | serializeOut (void) const
void | setAlpha (Adesk::UInt8 alpha)
void | setMethod (transparencyMethod method)
The documentation for this class was generated from the following file:
  • dbcolor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCmTransparency Member List

This is the complete list of members for AcCmTransparency, including all inherited members.

AcCmTransparency() (defined in AcCmTransparency) | AcCmTransparency | inline
AcCmTransparency(const AcCmTransparency &other) (defined in AcCmTransparency) | AcCmTransparency | inline
alpha(void) const (defined in AcCmTransparency) | AcCmTransparency |
isByAlpha(void) const (defined in AcCmTransparency) | AcCmTransparency | inline
isByBlock(void) const (defined in AcCmTransparency) | AcCmTransparency | inline
isByLayer(void) const (defined in AcCmTransparency) | AcCmTransparency | inline
isClear(void) const (defined in AcCmTransparency) | AcCmTransparency |
isSolid(void) const (defined in AcCmTransparency) | AcCmTransparency |
kByAlpha enum value (defined in AcCmTransparency) | AcCmTransparency |
kByBlock enum value (defined in AcCmTransparency) | AcCmTransparency |
kByLayer enum value (defined in AcCmTransparency) | AcCmTransparency |
kErrorValue enum value (defined in AcCmTransparency) | AcCmTransparency |
kTransparencyByBlock enum value (defined in AcCmTransparency) | AcCmTransparency |
kTransparencyByLayer enum value (defined in AcCmTransparency) | AcCmTransparency |
kTransparencyClear enum value (defined in AcCmTransparency) | AcCmTransparency |
kTransparencySolid enum value (defined in AcCmTransparency) | AcCmTransparency |
operator!=(const AcCmTransparency &other) const (defined in AcCmTransparency) | AcCmTransparency |
operator=(const AcCmTransparency &other) (defined in AcCmTransparency) | AcCmTransparency |
operator==(const AcCmTransparency &other) const (defined in AcCmTransparency) | AcCmTransparency |
serializeIn(Adesk::UInt32) (defined in AcCmTransparency) | AcCmTransparency |
serializeOut(void) const (defined in AcCmTransparency) | AcCmTransparency | inline
setAlpha(Adesk::UInt8 alpha) (defined in AcCmTransparency) | AcCmTransparency |
setMethod(transparencyMethod method) (defined in AcCmTransparency) | AcCmTransparency |
transparencyMethod enum name (defined in AcCmTransparency) | AcCmTransparency |
~AcCmTransparency() (defined in AcCmTransparency) | AcCmTransparency | inline


ZRX API Reference: AcDb Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Macros | Typedefs | Functions | Variables
AcDb Classes

Classes

class | AcDb2dPolyline
class | AcDb2dVertex
class | AcDb2LineAngularDimension
class | AcDb3dPolyline
class | AcDb3dPolylineVertex
class | AcDb3dSolid
class | AcDb3PointAngularDimension
class | AcDbAbstractViewTable
class | AcDbAbstractViewTableIterator
class | AcDbAbstractViewTableRecord
class | AcDbAlignedDimension
class | AcDbAlignment
class | AcDbAnnotationScale
class | AcDbAnnotativeObjectPE
class | AcDbAppEntityGrips
class | AcDbAppSystemVariables
class | AcDbArc
class | AcDbArcDimension
class | AcDbAttribute
class | AcDbAttributeDefinition
class | AcDbAuditInfo
class | AcDbAuditRecreatePE
class | AcDbBackground
class | AcDbBlockBegin
class | AcDbBlockChangeIterator
class | AcDbBlockEnd
class | AcDbBlockInsertionPoints
class | AcDbBlockReference
class | AcDbBlockReferenceIdIterator
class | AcDbBlockTable
class | AcDbBlockTableIterator
class | AcDbBlockTableRecord
class | AcDbBlockTableRecordIterator
class | AcDbBody
class | AcDbBreakData
class | AcDbBreakPointRef
class | AcDbCamera
class | AcDbCircle
class | AcDbColor
class | AcDbCompositeFilteredBlockIterator
class | AcDbCurve
class | AcDbCurvePath
class | AcDbCustomOsnapInfo
class | AcDbCustomOsnapManager
class | AcDbCustomOsnapMode
class | AcDbDatabase
class | AcDbDatabaseReactor
class | AcDbDatabaseSummaryInfo
class | AcDbDataCell
class | AcDbDataColumn
class | AcDbDataLink
class | AcDbDataLinkManager
class | AcDbDataTable
class | AcDbDate
class | AcDbDeepCloneFiler
class | AcDbDgnDefinition
class | AcDbDgnReference
class | AcDbDgnUnderlayItem
class | AcDbDiametricDimension
class | AcDbDictionary
class | AcDbDictionaryIterator
class | AcDbDictionaryWithDefault
class | AcDbDimAssoc
class | AcDbDimData
class | AcDbDimension
class | AcDbDimStyleTable
class | AcDbDimStyleTableIterator
class | AcDbDimStyleTableRecord
class | AcDbDwfDefinition
class | AcDbDwfReference
class | AcDbDwgFiler
class | AcDbDxfFiler
class | AcDbDynamicUCSPE
class | AcDbDynBlockReference
class | AcDbDynBlockReferenceProperty
class | AcDbEllipse
class | AcDbEntity
class | AcDbEntityHyperlinkPE
class | AcDbEntityReactor
class | AcDbEvalConnectable
class | AcDbEvalContext
class | AcDbEvalContextIterator
class | AcDbEvalContextPair
class | AcDbEvalEdgeInfo
class | AcDbEvalExpr
class | AcDbEvalGraph
class | AcDbEvalIdMap
class | AcDbEvalVariant
class | AcDbExtents
class | AcDbExtrudedSurface
class | AcDbFace
class | AcDbFaceRecord
class | AcDbFcf
class | AcDbField
class | AcDbFilter
class | AcDbFilteredBlockIterator
class | AcDbFormattedTableData
class | AcDbFrame
class | AcDbFullSubentPath
class | AcDbGradientBackground
class | AcDbGraph
class | AcDbGraphNode
class | AcDbGraphStack
class | AcDbGripData
class | AcDbGroundPlaneBackground
class | AcDbGroup
class | AcDbGroupIterator
class | AcDbHandle
class | AcDbHardOwnershipId
class | AcDbHardPointerId
class | AcDbHatch
class | AcDbHelix
class | AcDbHostApplicationProgressMeter
class | AcDbHostApplicationServices
class | AcDbHyperlink
class | AcDbHyperlinkCollection
class | AcDbIdMapping
class | AcDbIdMappingIter
class | AcDbIdPair
class | AcDbImage
class | AcDbImageBackground
class | AcDbIndex
class | AcDbIndexUpdateData
class | AcDbIndexUpdateDataIterator
class | AcDbInterferencePE
class | AcDbLayerFilter
class | AcDbLayerIndex
class | AcDbLayerIndexIterator
class | AcDbLayerStateManager
class | AcDbLayerStateManagerReactor
class | AcDbLayerTable
class | AcDbLayerTableIterator
class | AcDbLayerTableRecord
class | AcDbLayout
class | AcDbLayoutManager
class | AcDbLayoutManagerReactor
class | AcDbLeader
class | AcDbLight
class | AcDbLine
class | AcDbLinetypeTable
class | AcDbLinetypeTableIterator
class | AcDbLinetypeTableRecord
class | AcDbLinkedData
class | AcDbLinkedTableData
class | AcDbLoftedSurface
class | AcDbLoftOptions
class | AcDbLongTransaction
class | AcDbLongTransWorkSetIterator
class | AcDbMatchProperties
class | AcDbMaterial
class | AcDbMentalRayRenderSettings
class | AcDbMInsertBlock
class | AcDbMLeader
class | AcDbMLeaderStyle
class | AcDbMline
class | AcDbMlineStyle
class | AcDbMotionPath
class | AcDbMPolygon
class | AcDbMPolygonCrossing
class | AcDbMPolygonCrossingArray
class | AcDbMpolygonLoops
class | AcDbMPolygonNode
class | AcDbMText
class | AcDbNamedPath
class | AcDbObject
class | AcDbObjectContext
class | AcDbObjectContextCollection
class | AcDbObjectContextCollectionIterator
class | AcDbObjectContextInterface
class | AcDbObjectContextManager
class | AcDbObjectId
class | AcDbObjectIterator
class | AcDbObjectPointer< T_OBJECT >
class | AcDbObjectPointerBase< T_OBJECT >
class | AcDbObjectReactor
class | AcDbOle2Frame
class | AcDbOleFrame
class | AcDbOrdinateDimension
class | AcDbOsnapPointRef
class | AcDbPaperOrientationPE
class | AcDbPasswordedFile
class | AcDbPlaceHolder
class | AcDbPlaneSurface
class | AcDbPlotSettings
class | AcDbPlotSettingsValidator
class | AcDbPoint
class | AcDbPointPath
class | AcDbPointRef
class | AcDbPolyFaceMesh
class | AcDbPolyFaceMeshVertex
class | AcDbPolygonMesh
class | AcDbPolygonMeshVertex
class | AcDbPolyline
class | AcDbProxyEntity
class | AcDbProxyObject
class | AcDbR13ObjectId
class | AcDbRadialDimension
class | AcDbRadialDimensionLarge
class | AcDbRasterImage
class | AcDbRasterImageDef
class | AcDbRasterImageDefFileAccessReactor
class | AcDbRasterImageDefReactor
class | AcDbRasterImageDefTransReactor
class | AcDbRasterVariables
class | AcDbRay
class | AcDbRecover
class | AcDbRecoverCallBack
class | AcDbRegAppTable
class | AcDbRegAppTableIterator
class | AcDbRegAppTableRecord
class | AcDbRegion
class | AcDbRenderEnvironment
class | AcDbRenderGlobal
class | AcDbRenderSettings
class | AcDbRevolvedSurface
class | AcDbRevolveOptions
class | AcDbRotatedDimension
class | AcDbSection
class | AcDbSectionManager
class | AcDbSectionManagerIterator
class | AcDbSectionSettings
class | AcDbSelectGrip
class | AcDbSequenceEnd
class | AcDbServices
class | AcDbShape
class | AcDbSkyBackground
class | AcDbSoftOwnershipId
class | AcDbSoftPointerId
class | AcDbSolid
class | AcDbSolidBackground
class | AcDbSpatialFilter
class | AcDbSpatialIndex
class | AcDbSpatialIndexIterator
class | AcDbSpline
class | AcDbSubentId
class | AcDbSummaryInfoManager
class | AcDbSummaryInfoReactor
class | AcDbSun
class | AcDbSurface
class | AcDbSweepOptions
class | AcDbSweptSurface
class | AcDbSymbolTable
class | AcDbSymbolTableIterator
class | AcDbSymbolTablePointer< T_OBJECT >
class | AcDbSymbolTableRecord
class | AcDbSymbolTableRecordPointer< T_OBJECT >
class | AcDbTable
class | AcDbTableContent
class | AcDbTableIterator
class | AcDbTableStyle
class | AcDbTableTemplate
class | AcDbText
class | AcDbTextStyleTable
class | AcDbTextStyleTableIterator
class | AcDbTextStyleTableRecord
class | AcDbTrace
class | AcDbTransactionManager
class | AcDbUCSTable
class | AcDbUCSTableIterator
class | AcDbUCSTableRecord
class | AcDbUnderlayDefinition
class | AcDbUnderlayFile
class | AcDbUnderlayHost
class | AcDbUnderlayItem
class | AcDbUnderlayReference
class | AcDbVertex
class | AcDbViewport
class | AcDbViewportTable
class | AcDbViewportTableIterator
class | AcDbViewportTableRecord
class | AcDbViewTable
class | AcDbViewTableIterator
class | AcDbViewTableRecord
class | AcDbVisualStyle
class | AcDbWblockCloneFiler
class | AcDbWipeout
class | AcDbXline
class | AcDbXObject
class | AcDbXrecord
class | AcDbXrecordIterator
class | AcDbXrefGraph
class | AcDbXrefGraphNode
class | AcDbXrefObjectId
class | AcGiGlyph
class | AcGiLineAttrUtils
class | AcGiStyleAttributes
class | AcTransaction
class | AcTransactionReactor

Macros

#define DBCURVE_METHODS

Typedefs

typedef AcDbSymbolTablePointer
< AcDbBlockTable > 		AcDbBlockTablePointer
typedef
AcDbSymbolTableRecordPointer
< AcDbBlockTableRecord > 		AcDbBlockTableRecordPointer
typedef AcArray< AcDbDataCell,
AcArrayObjectCopyReallocator
< AcDbDataCell > > 		AcDbDataCellArray
typedef AcArray< AcDbDataLink * > | AcDbDataLinkArray
typedef AcDbObjectPointer
< AcDbDictionary > 		AcDbDictionaryPointer
typedef AcDbSymbolTablePointer
< AcDbDimStyleTable > 		AcDbDimStyleTablePointer
typedef
AcDbSymbolTableRecordPointer
< AcDbDimStyleTableRecord > 		AcDbDimStyleTableRecordPointer
typedef AcArray
< AcDbDynBlockReferenceProperty,
AcArrayObjectCopyReallocator
< AcDbDynBlockReferenceProperty > > 		AcDbDynBlockReferencePropertyArray
typedef AcDbObjectPointer
< AcDbEntity > 		AcDbEntityPointer
typedef AcArray< AcDbGripData > | AcDbGripDataArray
typedef AcArray< AcDbGripData * > | AcDbGripDataPtrArray
typedef AcDbSymbolTablePointer
< AcDbLayerTable > 		AcDbLayerTablePointer
typedef
AcDbSymbolTableRecordPointer
< AcDbLayerTableRecord > 		AcDbLayerTableRecordPointer
typedef AcDbSymbolTablePointer
< AcDbLinetypeTable > 		AcDbLinetypeTablePointer
typedef
AcDbSymbolTableRecordPointer
< AcDbLinetypeTableRecord > 		AcDbLinetypeTableRecordPointer
typedef AcDbSymbolTablePointer
< AcDbRegAppTable > 		AcDbRegAppTablePointer
typedef
AcDbSymbolTableRecordPointer
< AcDbRegAppTableRecord > 		AcDbRegAppTableRecordPointer
typedef AcDbSymbolTablePointer
< AcDbTextStyleTable > 		AcDbTextStyleTablePointer
typedef
AcDbSymbolTableRecordPointer
< AcDbTextStyleTableRecord > 		AcDbTextStyleTableRecordPointer
typedef AcDbSymbolTablePointer
< AcDbUCSTable > 		AcDbUCSTablePointer
typedef
AcDbSymbolTableRecordPointer
< AcDbUCSTableRecord > 		AcDbUCSTableRecordPointer
typedef AcDbSymbolTablePointer
< AcDbViewportTable > 		AcDbViewportTablePointer
typedef
AcDbSymbolTableRecordPointer
< AcDbViewportTableRecord > 		AcDbViewportTableRecordPointer
typedef AcDbSymbolTablePointer
< AcDbViewTable > 		AcDbViewTablePointer
typedef
AcDbSymbolTableRecordPointer
< AcDbViewTableRecord > 		AcDbViewTableRecordPointer
typedef void(* | ContextMenuItemIndexPtr )(unsigned int itemIndex)
typedef void(* | GripDimensionPtr )(AcDbGripData *pThis, const AcDbObjectId &entId, double dimScale, AcDbDimDataPtrArray &dimData)
typedef
AcDbGripOperations::ReturnValue(* 		GripInputPointPtr )(AcDbGripData *pThis, const AcDbObjectId &entId, bool &changedPoint, AcGePoint3d &newPoint, const AcGiViewport &viewContext, const AcDbObjectId &viewportId, bool pointComputed, int history, const AcGePoint3d &lastPoint, const AcGePoint3d &rawPoint, const AcGePoint3d &grippedPoint, const AcGePoint3d &cartesianSnappedPoint, const AcGePoint3d &osnappedPoint, AcDb::OsnapMask osnapMask, const AcArray< AcDbCustomOsnapMode * > &customOsnapModes, AcDb::OsnapMask osnapOverrides, const AcArray< AcDbCustomOsnapMode * > &customOsnapOverrides, const AcArray< AcDbObjectId > &pickedEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedPickedEntities, const AcArray< Adesk::GsMarker > &gsSelectionMark, const AcArray< AcDbObjectId > &keyPointEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedKeyPointEntities, const AcArray< Adesk::GsMarker > &keyPointGsSelectionMark, const AcArray< AcGeCurve3d * > &alignmentPaths, const AcGePoint3d &computedPoint)
typedef
AcDbGripOperations::ReturnValue(* 		GripOperationPtr )(AcDbGripData *pThis, const AcDbObjectId &entId, int contextFlags)
typedef void(* | GripOpStatusPtr )(AcDbGripData *pThis, const AcDbObjectId &entId, AcDbGripOperations::GripStatus stat)
typedef
AcDbGripOperations::ReturnValue(* 		GripRtClkHandler )(AcDbGripDataArray &hotGrips, const AcDbObjectIdArray &ents, ACHAR *&menuName, HMENU &menu, ContextMenuItemIndexPtr &cb)
typedef const ACHAR *(* | GripToolTipPtr )(AcDbGripData *pThis)
typedef void(* | GripViewportDrawPtr )(AcDbGripData *pThis, AcGiViewportDraw *pWd, const AcDbObjectId &entId, AcDbGripOperations::DrawType type, AcGePoint3d *imageGripPoint, int gripSize)
typedef bool(* | GripWorldDrawPtr )(AcDbGripData *pThis, AcGiWorldDraw *pWd, const AcDbObjectId &entId, AcDbGripOperations::DrawType type, AcGePoint3d *imageGripPoint, double dGripSize)
typedef void(* | MAPFILENOTIFYPROC )(const ACHAR *filename, const ACHAR *newName, int context, void *pReserved)
typedef Acad::ErrorStatus(* | REMAPPROC )(ACHAR *&newName, const ACHAR *filename, int context, void *pReserved)
typedef Acad::ErrorStatus(* | SELECTFILEPROC )(short *userCancel, ACHAR *&chosenPath, void *h, const int nFlags, const ACHAR *prompt, const ACHAR *dir, const ACHAR *name, const ACHAR *type, int *pnChoice, bool *pbReadOnly, const ACHAR *pszWSTags, void *pReserved)

Functions

AcDbDimData::AcDbDimData (AcDbDimension *pDim, DimDataSetValueFuncPtr setDimFunc=NULL, unsigned int bitFlags=0, void *appData=NULL, DimDataSetCustomStringFuncPtr setCustomStringFunc=NULL)
AcDbDimData::AcDbDimData (const AcDbDimData &)
AcDbFullSubentPath::AcDbFullSubentPath (AcDb::SubentType type, Adesk::GsMarker index)
Acad::ErrorStatus | acdbGetBreakSubentIndex (AcDbEntity *pEnt, const AcGePoint3d &pickPt, const AcGeVector3d &viewDir, int &subentIndex, AcGePoint3d &ptOnEnt, const AcGeTol &tol=AcGeContext::gTol)
Acad::ErrorStatus ADESK_STDCALL | acdbGetSummaryInfo (AcDbDatabase *pDb, AcDbDatabaseSummaryInfo *&pInfo)
AcDbGripData::AcDbGripData (const AcGePoint3d &, void *, GripOperationPtr hotGrip=NULL, GripOperationPtr hoverGrip=NULL, GripRtClkHandler RtClk=NULL, GripWorldDrawPtr wd=NULL, GripViewportDrawPtr vd=NULL, GripOpStatusPtr stat=NULL, GripToolTipPtr tt=NULL, GripDimensionPtr hoverDim=NULL, GripDimensionPtr hotGripDim=NULL, unsigned int bitFlags=0, AcGePoint3d *altBasePt=NULL, GripInputPointPtr inputPointFunc=NULL)
AcDbGripData::AcDbGripData (const AcGePoint3d &, void *, AcRxClass *, GripOperationPtr hotGrip=NULL, GripOperationPtr hoverGrip=NULL, GripRtClkHandler RtClk=NULL, GripWorldDrawPtr wd=NULL, GripViewportDrawPtr vd=NULL, GripOpStatusPtr stat=NULL, GripToolTipPtr tt=NULL, GripDimensionPtr hoverDim=NULL, GripDimensionPtr hotGripDim=NULL, unsigned int bitFlags=0, AcGePoint3d *altBasePt=NULL, GripInputPointPtr inputPointFunc=NULL)
AcDbGripData::AcDbGripData (const AcDbGripData &)
AcDbHandle::AcDbHandle (int lo, int hi)
AcDbHandle::AcDbHandle (const Adesk::UInt64 &)
AcDbHardOwnershipId::AcDbHardOwnershipId (const AcDbObjectId &)
AcDbHardOwnershipId::AcDbHardOwnershipId (const AcDbStub *)
AcDbHardPointerId::AcDbHardPointerId (const AcDbObjectId &)
AcDbHardPointerId::AcDbHardPointerId (const AcDbStub *)
AcDbMpolygonLoops::AcDbMpolygonLoops (int lindex, int gindex=0, int gcnt=0)
AcDbObjectId::AcDbObjectId (const AcDbStub *)
AcDbObjectPointer< T_OBJECT >::AcDbObjectPointer (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
AcDbObjectPointerBase< T_OBJECT >::AcDbObjectPointerBase (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased)
Acad::ErrorStatus ADESK_STDCALL | acdbPutSummaryInfo (const AcDbDatabaseSummaryInfo *pInfo, AcDbDatabase *pDb)
Acad::ErrorStatus | acdbPutSummaryInfo (const AcDbDatabaseSummaryInfo *pInfo)
AcDbSoftOwnershipId::AcDbSoftOwnershipId (const AcDbObjectId &)
AcDbSoftOwnershipId::AcDbSoftOwnershipId (const AcDbStub *)
AcDbSoftPointerId::AcDbSoftPointerId (const AcDbObjectId &)
AcDbSoftPointerId::AcDbSoftPointerId (const AcDbStub *)
AcDbSubentId::AcDbSubentId (AcDb::SubentType type, Adesk::GsMarker index)
AcDbSubentId::AcDbSubentId (AcRxClass *pTypeClass, Adesk::GsMarker index)
AcDbSymbolTablePointer< T_OBJECT >::AcDbSymbolTablePointer (AcDbObjectId objId, AcDb::OpenMode mode)
AcDbSymbolTablePointer< T_OBJECT >::AcDbSymbolTablePointer (AcDbDatabase *pDb, AcDb::OpenMode mode)
AcDbSymbolTableRecordPointer< T_OBJECT >::AcDbSymbolTableRecordPointer (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
AcDbSymbolTableRecordPointer< T_OBJECT >::AcDbSymbolTableRecordPointer (const ACHAR *name, AcDbDatabase *pDb, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | acedGetCurDwgXrefGraph (AcDbXrefGraph &, Adesk::Boolean includeGhosts=Adesk::kFalse)
AcGiStyleAttributes::AcGiStyleAttributes (const AcGiStyleAttributes &source)
Acad::ErrorStatus | AcDbObjectPointerBase< T_OBJECT >::acquire (T_OBJECT *&pObjToAcquire)
const AcDbDate & | AcDbDate::add (const AcDbDate &date)
AcGePoint3d * | AcDbGripData::alternateBasePoint () const
void * | AcDbDimData::appData () const
void * | AcDbGripData::appData () const
AcRxClass * | AcDbGripData::appDataAcRxClass () const
Acad::ErrorStatus | applyCurDwgLayerTableChanges ()
bool | AcDbGripData::areModeKeywordsDisabled () const
Adesk::IntDbId | AcDbObjectId::asOldId () const
bool | AcDbAppSystemVariables::attdia () const
bool | AcDbAppSystemVariables::attreq () const
unsigned int | AcDbDimData::bitFlags () const
unsigned int | AcDbGripData::bitFlags () const
bool | AcDbAppSystemVariables::blipmode () const
AcDbObjectId | AcDbXrefGraphNode::btrId () const
int | AcDbHandle::byte (Adesk::UInt32 i) const
static ClassVersion | AcDbRasterVariables::classVersion ()
static ClassVersion | AcDbRasterImageDef::classVersion ()
static ClassVersion | AcDbRasterImage::classVersion ()
static ClassVersion | AcDbRasterImageDefReactor::classVersion ()
Acad::ErrorStatus | AcDbObjectPointerBase< T_OBJECT >::close ()
int | AcDbHandle::compare (const AcDbHandle &) const
Adesk::Int16 | AcDbAppSystemVariables::coords () const
Acad::ErrorStatus | AcDbObjectPointerBase< T_OBJECT >::create ()
DimDataSetCustomStringFuncPtr | AcDbDimData::customStringFunc () const
AcDbGraphNode * | AcDbGraphNode::cycleIn (int) const
AcDbGraphNode * | AcDbGraphNode::cycleOut (int) const
void * | AcDbGraphNode::data () const
AcDbDatabase * | AcDbXrefGraphNode::database () const
void | AcDbHandle::decrement (void)
Adesk::Int16 | AcDbAppSystemVariables::delUsedObj () const
AcDbDimension * | AcDbDimData::dimension () const
DimDataSetValueFuncPtr | AcDbDimData::dimValueFunc () const
void | AcDbGripData::disableModeKeywords (bool disable)
void | AcDbGripData::disableRubberBandLine (bool disable)
Adesk::Int16 | AcDbAppSystemVariables::dragmode () const
bool | AcDbGripData::drawAtDragImageGripPoint () const
virtual const long | AcDbHyperlink::flags () const
bool | AcDbGripData::forcedPickOn () const
Acad::ErrorStatus | AcDbDatabase::getBlockTable (AcDbBlockTable *&pTable, AcDb::OpenMode mode)
AcCmEntityColor & | AcGiStyleAttributes::getColorAttribute ()
const AcCmEntityColor & | AcGiStyleAttributes::getColorAttribute () const
Acad::ErrorStatus | AcDbDatabase::getDimStyleTable (AcDbDimStyleTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | AcDbDatabase::getLayerTable (AcDbLayerTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | AcDbDatabase::getLinetypeTable (AcDbLinetypeTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | AcDbDatabase::getRegAppTable (AcDbRegAppTable *&pTable, AcDb::OpenMode mode)
virtual Acad::ErrorStatus | AcDbPolyline::getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | AcDbPolyline::getStartParam (double &startParam) const
Acad::ErrorStatus | AcDbDatabase::getTextStyleTable (AcDbTextStyleTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | AcDbDatabase::getUCSTable (AcDbUCSTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | AcDbDatabase::getViewportTable (AcDbViewportTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | AcDbDatabase::getViewTable (AcDbViewTable *&pTable, AcDb::OpenMode mode)
bool | AcDbGripData::gizmosEnabled () const
bool | AcDbGripData::gripIsPerViewport () const
GripOpStatusPtr | AcDbGripData::gripOpStatFunc () const
const AcGePoint3d & | AcDbGripData::gripPoint () const
Adesk::UInt32 | AcDbHandle::high () const
AcDbXrefGraphNode * | AcDbXrefGraph::hostDwg () const
GripDimensionPtr | AcDbGripData::hotGripDimensionFunc () const
GripOperationPtr | AcDbGripData::hotGripFunc () const
GripDimensionPtr | AcDbGripData::hoverDimensionFunc () const
GripOperationPtr | AcDbGripData::hoverFunc () const
bool | AcDbAppSystemVariables::hpassoc () const
AcDbGraphNode * | AcDbGraphNode::in (int) const
void | AcDbHandle::increment (void)
Adesk::GsMarker | AcDbSubentId::index () const
GripInputPointPtr | AcDbGripData::inputPointFunc () const
bool | AcDbIdPair::isCloned () const
bool | AcDbDimData::isConstrained () const
bool | AcDbDimData::isCustomDimValue () const
bool | AcDbDimData::isCustomString () const
bool | AcDbGraphNode::isCycleNode () const
bool | AcDbDimData::isDimDeltaAngle () const
bool | AcDbDimData::isDimDeltaLength () const
bool | AcDbDimData::isDimEditable () const
bool | AcDbDimData::isDimFocal () const
bool | AcDbDimData::isDimHideIfValueIsZero () const
bool | AcDbDimData::isDimInvisible () const
bool | AcDbDimData::isDimRadius () const
bool | AcDbDimData::isDimResultantAngle () const
bool | AcDbDimData::isDimResultantLength () const
bool | AcDbGraph::isEmpty () const
bool | AcDbGraphStack::isEmpty () const
bool | AcDbGraphNode::isMarkedAs (Adesk::UInt8 flags) const
bool | AcDbXrefGraphNode::isNested () const
bool | AcDbObjectId::isNull () const
bool | AcDbHandle::isNull () const
bool | AcDbHandle::isOne (void) const
bool | AcDbIdPair::isOwnerXlated () const
virtual Adesk::Boolean | AcDbPolyline::isPlanar () const
bool | AcDbIdPair::isPrimary () const
bool | AcDbGripData::isRubberBandLineDisabled () const
AcDbObjectId | AcDbIdPair::key () const
AcDbObjectId | AcGiStyleAttributes::linetypeObjectId () const
Adesk::UInt32 | AcDbHandle::low () const
AcDb::LineWeight | AcDbAppSystemVariables::lwdefault () const
bool | AcDbGripData::mapGripHotToRtClk () const
void | modelToPixel (const AcGeMatrix3d &modToPix, const AcGePoint3d &modPt, AcGePoint2d &pixPt)
void | modelToPixel (const AcGeVector3d &viewDir, const AcGeMatrix3d &modToPix, const AcGePlane &plane, const AcGePoint3d &modPt, AcGePoint2d &pixPt)
const ACHAR * | AcDbXrefGraphNode::name () const
AcDbGraphNode * | AcDbGraphNode::nextCycleNode () const
AcDbGraphNode * | AcDbGraph::node (int index) const
int | AcDbGraphNode::numCycleIn () const
int | AcDbGraphNode::numCycleOut () const
int | AcDbGraphNode::numIn () const
int | AcDbGraph::numNodes () const
int | AcDbGraphNode::numOut () const
const T_OBJECT * | AcDbObjectPointerBase< T_OBJECT >::object () const
T_OBJECT * | AcDbObjectPointerBase< T_OBJECT >::object ()
void | AcDbFullSubentPath::objectIds (AcDbObjectIdArray &objectIds) const
AcDbObjectIdArray & | AcDbFullSubentPath::objectIds ()
const AcDbObjectIdArray & | AcDbFullSubentPath::objectIds () const
Acad::ErrorStatus | AcDbObjectPointerBase< T_OBJECT >::open (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | AcDbObjectPointer< T_OBJECT >::open (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | AcDbSymbolTablePointer< T_OBJECT >::open (AcDbObjectId objId, AcDb::OpenMode mode)
Acad::ErrorStatus | AcDbSymbolTablePointer< T_OBJECT >::open (AcDbDatabase *pDb, AcDb::OpenMode mode)
Acad::ErrorStatus | AcDbSymbolTableRecordPointer< T_OBJECT >::open (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | AcDbSymbolTableRecordPointer< T_OBJECT >::open (const ACHAR *name, AcDbDatabase *pDb, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | AcDbObjectPointerBase< T_OBJECT >::openStatus () const
AcDbObjectId::operator AcDbStub * () const
AcDbHardOwnershipId::operator AcDbStub * () const
AcDbSoftOwnershipId::operator AcDbStub * () const
AcDbHardPointerId::operator AcDbStub * () const
AcDbSoftPointerId::operator AcDbStub * () const
AcDbHandle::operator Adesk::UInt32 () const
AcDbObjectPointerBase< T_OBJECT >::operator const T_OBJECT * () const
AcDbObjectPointerBase< T_OBJECT >::operator T_OBJECT * ()
bool | AcDbSubentId::operator!= (const AcDbSubentId &id) const
bool | AcDbHandle::operator!= (const AcDbHandle &) const
bool | AcDbR13ObjectId::operator!= (const AcDbR13ObjectId &id) const
bool | AcDbR13ObjectId::operator!= (const AcDbStub *pStub) const
bool | AcDbHardOwnershipId::operator!= (const AcDbObjectId &) const
bool | AcDbHardOwnershipId::operator!= (const AcDbStub *) const
bool | AcDbSoftOwnershipId::operator!= (const AcDbObjectId &) const
bool | AcDbSoftOwnershipId::operator!= (const AcDbStub *) const
bool | AcDbHardPointerId::operator!= (const AcDbObjectId &) const
bool | AcDbHardPointerId::operator!= (const AcDbStub *) const
bool | AcDbSoftPointerId::operator!= (const AcDbObjectId &) const
bool | AcDbSoftPointerId::operator!= (const AcDbStub *) const
AcDbHandle | AcDbHandle::operator+ (const AcDbHandle &) const
AcDbHandle | AcDbHandle::operator+ (Adesk::ULongPtr) const
const AcDbDate | AcDbDate::operator+ (const AcDbDate &date) const
AcDbHandle & | AcDbHandle::operator++ ()
AcDbHandle | AcDbHandle::operator++ (int)
const AcDbDate | AcDbDate::operator- (const AcDbDate &date) const
const T_OBJECT * | AcDbObjectPointerBase< T_OBJECT >::operator-> () const
T_OBJECT * | AcDbObjectPointerBase< T_OBJECT >::operator-> ()
bool | AcDbHandle::operator< (const AcDbHandle &) const
bool | AcDbR13ObjectId::operator< (const AcDbR13ObjectId &id) const
bool | AcDbDate::operator< (const AcDbDate &) const
bool | AcDbR13ObjectId::operator< (const AcDbStub *pStub) const
bool | AcDbR13ObjectId::operator<= (const AcDbR13ObjectId &id) const
bool | AcDbDate::operator<= (const AcDbDate &) const
bool | AcDbR13ObjectId::operator<= (const AcDbStub *pStub) const
AcDbHandle & | AcDbHandle::operator= (const AcDbHandle &)
AcDbObjectId & | AcDbObjectId::operator= (const AcDbObjectId &)
AcDbObjectId & | AcDbObjectId::operator= (const AcDbStub *)
AcDbDimData & | AcDbDimData::operator= (const AcDbDimData &)
AcDbHandle & | AcDbHandle::operator= (Adesk::UInt32)
AcDbHardOwnershipId & | AcDbHardOwnershipId::operator= (const AcDbHardOwnershipId &)
AcDbHardOwnershipId & | AcDbHardOwnershipId::operator= (const AcDbObjectId &)
AcDbHardOwnershipId & | AcDbHardOwnershipId::operator= (const AcDbStub *)
AcDbSoftOwnershipId & | AcDbSoftOwnershipId::operator= (const AcDbSoftOwnershipId &)
AcDbSoftOwnershipId & | AcDbSoftOwnershipId::operator= (const AcDbObjectId &)
AcDbSoftOwnershipId & | AcDbSoftOwnershipId::operator= (const AcDbStub *)
AcDbHardPointerId & | AcDbHardPointerId::operator= (const AcDbHardPointerId &)
AcDbHardPointerId & | AcDbHardPointerId::operator= (const AcDbObjectId &)
AcDbHardPointerId & | AcDbHardPointerId::operator= (const AcDbStub *)
AcDbSoftPointerId & | AcDbSoftPointerId::operator= (const AcDbSoftPointerId &)
AcDbSoftPointerId & | AcDbSoftPointerId::operator= (const AcDbObjectId &)
AcDbSoftPointerId & | AcDbSoftPointerId::operator= (const AcDbStub *)
AcDbGripData & | AcDbGripData::operator= (const AcDbGripData &)
bool | AcDbSubentId::operator== (const AcDbSubentId &id) const
bool | AcDbHandle::operator== (const AcDbHandle &) const
bool | AcDbR13ObjectId::operator== (const AcDbR13ObjectId &id) const
bool | AcDbR13ObjectId::operator== (const AcDbStub *pStub) const
bool | AcDbHardOwnershipId::operator== (const AcDbObjectId &) const
bool | AcDbHardOwnershipId::operator== (const AcDbStub *) const
bool | AcDbSoftOwnershipId::operator== (const AcDbObjectId &) const
bool | AcDbSoftOwnershipId::operator== (const AcDbStub *) const
bool | AcDbHardPointerId::operator== (const AcDbObjectId &) const
bool | AcDbHardPointerId::operator== (const AcDbStub *) const
bool | AcDbSoftPointerId::operator== (const AcDbObjectId &) const
bool | AcDbSoftPointerId::operator== (const AcDbStub *) const
bool | AcDbHandle::operator> (const AcDbHandle &) const
bool | AcDbR13ObjectId::operator> (const AcDbR13ObjectId &id) const
bool | AcDbR13ObjectId::operator> (const AcDbStub *pStub) const
bool | AcDbR13ObjectId::operator>= (const AcDbR13ObjectId &id) const
bool | AcDbR13ObjectId::operator>= (const AcDbStub *pStub) const
Adesk::Int16 | AcDbAppSystemVariables::osmode () const
AcDbGraphNode * | AcDbGraphNode::out (int) const
AcDbGraph * | AcDbGraphNode::owner () const
AcDbObjectId | AcDbDimData::ownerId () const
Adesk::Int16 | AcDbAppSystemVariables::pickstyle () const
void | pixelToModel (const AcGeMatrix3d &pixToMod, const AcGePoint2d &pixPt, AcGePoint3d &modPt)
AcDbObjectId | AcGiStyleAttributes::plotStyleNameId () const
RasterImageDefImp * | AcDbRasterImageDef::ptrImp () const
RasterImageImp * | AcDbRasterImage::ptrImp () const
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcDbHardOwnershipId *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcDbSoftOwnershipId *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcDbHardPointerId *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcDbSoftPointerId *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (ACHAR **)
Acad::ErrorStatus | AcDbDwgFiler::readItem (ads_binary *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcDbHandle *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (Adesk::Int32 *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (Adesk::Int16 *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (Adesk::Int8 *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (Adesk::UInt32 *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (Adesk::UInt16 *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (Adesk::UInt8 *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (Adesk::Boolean *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (bool *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (double *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcGePoint2d *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcGePoint3d *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcGeVector2d *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcGeVector3d *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (AcGeScale3d *)
Acad::ErrorStatus | AcDbDwgFiler::readItem (void *, Adesk::UInt32)
Acad::ErrorStatus | AcDbDwgFiler::readItem (void **)
Acad::ErrorStatus | AcDbDxfFiler::readItem (resbuf *pItem)
Acad::ErrorStatus | AcDbObjectPointerBase< T_OBJECT >::release (T_OBJECT *&pReleasedObj)
int | AcDbHandle::restZeros (int i) const
AcDbGraphNode * | AcDbGraph::rootNode () const
GripRtClkHandler | AcDbGripData::rtClk () const
void | AcDbGripData::setAllData (const AcGePoint3d &, void *, GripOperationPtr hotGrip=NULL, GripOperationPtr hoverGrip=NULL, GripRtClkHandler RtClk=NULL, GripWorldDrawPtr wd=NULL, GripViewportDrawPtr vd=NULL, GripOpStatusPtr stat=NULL, GripToolTipPtr tt=NULL, GripDimensionPtr hoverDim=NULL, GripDimensionPtr hotGripDim=NULL, unsigned int bitFlags=0, AcGePoint3d *altBasePt=NULL, GripInputPointPtr inputPointFunc=NULL, AcRxClass *appDataAcRxClass=NULL)
void | AcDbGripData::setAlternateBasePoint (AcGePoint3d *altBasePt)
Acad::ErrorStatus | AcDbDimData::setAppData (void *appData)
void | AcDbGripData::setAppData (void *appData)
void | AcDbGripData::setAppDataAcRxClass (AcRxClass *pClass)
Acad::ErrorStatus | AcDbDimData::setBitFlags (unsigned int flags)
void | AcDbGripData::setBitFlags (unsigned int flags)
void | AcDbXrefGraphNode::setBtrId (const AcDbObjectId &id)
void | AcGiStyleAttributes::setColorAttribute (const AcCmEntityColor &color)
Acad::ErrorStatus | AcDbDimData::setConstrain (bool bValue)
Acad::ErrorStatus | AcDbDimData::setCustomDimValue (bool custom)
Acad::ErrorStatus | AcDbDimData::setCustomString (bool bValue)
Acad::ErrorStatus | AcDbDimData::setCustomStringFunc (DimDataSetCustomStringFuncPtr funcPtr)
void | AcDbGraphNode::setData (void *)
void | AcDbXrefGraphNode::setDatabase (AcDbDatabase *pDb)
Acad::ErrorStatus | AcDbDimData::setDimDeltaAngle (bool bValue)
Acad::ErrorStatus | AcDbDimData::setDimDeltaLength (bool bValue)
Acad::ErrorStatus | AcDbDimData::setDimEditable (bool editable)
Acad::ErrorStatus | AcDbDimData::setDimension (AcDbDimension *pDim)
Acad::ErrorStatus | AcDbDimData::setDimFocal (bool focal)
Acad::ErrorStatus | AcDbDimData::setDimHideIfValueIsZero (bool hide)
Acad::ErrorStatus | AcDbDimData::setDimInvisible (bool invisible)
Acad::ErrorStatus | AcDbDimData::setDimRadius (bool bValue)
Acad::ErrorStatus | AcDbDimData::setDimResultantAngle (bool bValue)
Acad::ErrorStatus | AcDbDimData::setDimResultantLength (bool bValue)
Acad::ErrorStatus | AcDbDimData::setDimValueFunc (DimDataSetValueFuncPtr funcPtr)
void | AcDbGripData::setDrawAtDragImageGripPoint (bool atDragPoint)
virtual void | AcDbHyperlink::setFlags (const long lFlags)
void | AcDbGripData::setForcedPickOn (bool on)
AcDbObjectId & | AcDbObjectId::setFromOldId (Adesk::IntDbId oldId)
void | AcDbGripData::setGizmosEnabled (bool on)
void | AcDbGripData::setGripIsPerViewport (bool on)
void | AcDbGripData::setGripOpStatFunc (GripOpStatusPtr pFunc)
void | AcDbGripData::setGripPoint (const AcGePoint3d &pt)
void | AcDbHandle::setHigh (Adesk::UInt32 high)
void | AcDbGripData::setHotGripDimensionFunc (GripDimensionPtr pFunc)
void | AcDbGripData::setHotGripFunc (GripOperationPtr pFunc)
void | AcDbGripData::setHoverDimensionFunc (GripDimensionPtr pFunc)
void | AcDbGripData::setHoverFunc (GripOperationPtr pFunc)
void | AcDbSubentId::setIndex (Adesk::GsMarker)
void | AcDbGripData::setInputPointFunc (GripInputPointPtr pFunc)
void | AcDbIdPair::setIsCloned (bool isCloned)
void | AcDbIdPair::setIsOwnerXlated (bool isOwnerXlated)
void | AcDbIdPair::setIsPrimary (bool isPrimary)
void | AcDbIdPair::setKey (AcDbObjectId)
void | AcGiStyleAttributes::setLinetypeObjectId (const AcDbObjectId &newId)
void | AcDbHandle::setLow (Adesk::UInt32 low)
void | AcDbGripData::setMapGripHotToRtClk (bool on)
void | AcDbObjectId::setNull ()
void | AcDbHandle::setNull ()
Acad::ErrorStatus | AcDbDimData::setOwnerId (const AcDbObjectId &objId)
void | AcGiStyleAttributes::setPlotStyleName (const AcDbObjectId &newId)
RasterImageDefImp * | AcDbRasterImageDef::setPtrImp (RasterImageDefImp *pImp)
RasterImageImp * | AcDbRasterImage::setPtrImp (RasterImageImp *pImp)
void | AcDbGripData::setRtClk (GripRtClkHandler pFunc)
void | AcDbGripData::setSkipWhenShared (bool skip)
void | AcDbGripData::setToolTipFunc (GripToolTipPtr pFunc)
void | AcDbGripData::setTriggerGrip (bool trigger)
void | AcDbSubentId::setType (AcDb::SubentType)
void | AcDbSubentId::setTypeClass (AcRxClass *pClass)
void | AcDbIdPair::setValue (AcDbObjectId)
void | AcDbGripData::setViewportDraw (GripViewportDrawPtr pFunc)
void | AcDbGripData::setWorldDraw (GripWorldDrawPtr pFunc)
void | AcDbXrefGraphNode::setXrefNotificationStatus (AcDb::XrefNotificationStatus stat)
void | AcDbXrefGraphNode::setXrefStatus (AcDb::XrefStatus stat)
bool | AcDbGripData::skipWhenShared () const
const AcDbSubentId | AcDbFullSubentPath::subentId () const
AcDbSubentId & | AcDbFullSubentPath::subentId ()
const AcDbDate & | AcDbDate::subtract (const AcDbDate &date)
GripToolTipPtr | AcDbGripData::toolTipFunc () const
AcDbGraphNode * | AcDbGraphStack::top () const
bool | AcDbGripData::triggerGrip () const
AcDb::SubentType | AcDbSubentId::type () const
AcRxClass * | AcDbSubentId::typeClass () const
AcDbObjectId | AcDbIdPair::value () const
GripViewportDrawPtr | AcDbGripData::viewportDraw () const
GripWorldDrawPtr | AcDbGripData::worldDraw () const
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcDbHardOwnershipId &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcDbSoftOwnershipId &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcDbHardPointerId &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcDbSoftPointerId &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const ACHAR *)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const ads_binary &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcDbHandle &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (Adesk::Int32)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (Adesk::Int16)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (Adesk::Int8)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (Adesk::UInt32)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (Adesk::UInt16)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (Adesk::UInt8)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (Adesk::Boolean)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (bool)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (double)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcGePoint2d &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcGePoint3d &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcGeVector2d &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcGeVector3d &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const AcGeScale3d &)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const void *, Adesk::UInt32)
Acad::ErrorStatus | AcDbDwgFiler::writeItem (const void *)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (const resbuf &pItem)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, const AcDbObjectId &)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, const ACHAR *)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, const ads_binary &)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, const AcDbHandle &)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, Adesk::Int64)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, Adesk::Int32)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, Adesk::Int16)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, Adesk::Int8)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, Adesk::UInt64)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, Adesk::UInt32)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, Adesk::UInt16)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, Adesk::UInt8)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, Adesk::Boolean)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, bool)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, double, int=kDfltPrec)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, const AcGePoint2d &, int=kDfltPrec)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, const AcGePoint3d &, int=kDfltPrec)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, const AcGeVector2d &, int=kDfltPrec)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, const AcGeVector3d &, int=kDfltPrec)
Acad::ErrorStatus | AcDbDxfFiler::writeItem (AcDb::DxfCode, const AcGeScale3d &, int=kDfltPrec)
AcDbXrefGraphNode * | AcDbXrefGraph::xrefNode (int idx) const
AcDb::XrefNotificationStatus | AcDbXrefGraphNode::xrefNotificationStatus () const
AcDb::XrefStatus | AcDbXrefGraphNode::xrefStatus () const

Variables

const Adesk::UInt32 | kBadUInt32Handle = 0xFFFFFFFF
ZRX_DB_EXPORT_GLOBAL const
AcDbSubentId 		kNullSubentId
const Adesk::GsMarker | kNullSubentIndex = 0
T_OBJECT * | AcDbObjectPointerBase< T_OBJECT >::m_ptr
Acad::ErrorStatus | AcDbObjectPointerBase< T_OBJECT >::m_status

Detailed Description

Function Documentation

Acad::ErrorStatus acdbGetBreakSubentIndex | ( | AcDbEntity * | pEnt,
 |  | const AcGePoint3d & | pickPt,
 |  | const AcGeVector3d & | viewDir,
 |  | int & | subentIndex,
 |  | AcGePoint3d & | ptOnEnt,
 |  | const AcGeTol & | tol = AcGeContext::gTol
 | ) |  |
Warning
Not implemented!


ZRX API Reference: AcDb2dPolyline Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDb2dPolyline Class Reference
AcDb Classes
+ Inheritance diagram for AcDb2dPolyline:

Public Member Functions

AcDb2dPolyline (AcDb::Poly2dType type, AcGePoint3dArray &vertices, double elevation=0, Adesk::Boolean closed=Adesk::kFalse, double defStartWidth=0, double defEndWidth=0, AcGeDoubleArray *bulges=NULL)
ACDB_DECLARE_MEMBERS (AcDb2dPolyline)
Acad::ErrorStatus | appendVertex (AcDb2dVertex *)
Acad::ErrorStatus | appendVertex (AcDbObjectId &objId, AcDb2dVertex *)
Acad::ErrorStatus | convertToPolyType (AcDb::Poly2dType newVal)
Acad::ErrorStatus | curveFit ()
double | defaultEndWidth () const
double | defaultStartWidth () const
double | elevation () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | insertVertexAt (const AcDb2dVertex *pIndexVert, AcDb2dVertex *pNewVertex)
Acad::ErrorStatus | insertVertexAt (AcDbObjectId &newVertId, const AcDbObjectId &indexVertId, AcDb2dVertex *pNewVertex)
Adesk::Boolean | isLinetypeGenerationOn () const
Acad::ErrorStatus | makeClosed ()
Acad::ErrorStatus | makeOpen ()
AcGeVector3d | normal () const
Acad::ErrorStatus | openSequenceEnd (AcDbSequenceEnd *&, AcDb::OpenMode)
Acad::ErrorStatus | openVertex (AcDb2dVertex *&, AcDbObjectId vertId, AcDb::OpenMode, bool openErasedOne=false) const
DBCURVE_METHODS AcDb::Poly2dType | polyType () const
Acad::ErrorStatus | setDefaultEndWidth (double)
Acad::ErrorStatus | setDefaultStartWidth (double)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setLinetypeGenerationOff ()
Acad::ErrorStatus | setLinetypeGenerationOn ()
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setPolyType (AcDb::Poly2dType)
Acad::ErrorStatus | setThickness (double)
Acad::ErrorStatus | splineFit ()
Acad::ErrorStatus | splineFit (AcDb::Poly2dType splineType, Adesk::Int16 splineSegs)
Acad::ErrorStatus | straighten ()
double | thickness () const
AcDbObjectIterator * | vertexIterator () const
AcGePoint3d | vertexPosition (const AcDb2dVertex &vert) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDb2dPolyline Member List

This is the complete list of members for AcDb2dPolyline, including all inherited members.

AcDb2dPolyline() (defined in AcDb2dPolyline) | AcDb2dPolyline |
AcDb2dPolyline(AcDb::Poly2dType type, AcGePoint3dArray &vertices, double elevation=0, Adesk::Boolean closed=Adesk::kFalse, double defStartWidth=0, double defEndWidth=0, AcGeDoubleArray *bulges=NULL) (defined in AcDb2dPolyline) | AcDb2dPolyline |
ACDB_DECLARE_MEMBERS(AcDb2dPolyline) (defined in AcDb2dPolyline) | AcDb2dPolyline |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
appendVertex(AcDb2dVertex *) (defined in AcDb2dPolyline) | AcDb2dPolyline |
appendVertex(AcDbObjectId &objId, AcDb2dVertex *) (defined in AcDb2dPolyline) | AcDb2dPolyline |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToPolyType(AcDb::Poly2dType newVal) (defined in AcDb2dPolyline) | AcDb2dPolyline |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
curveFit() (defined in AcDb2dPolyline) | AcDb2dPolyline |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
defaultEndWidth() const (defined in AcDb2dPolyline) | AcDb2dPolyline |
defaultStartWidth() const (defined in AcDb2dPolyline) | AcDb2dPolyline |
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDb2dPolyline) | AcDb2dPolyline |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDb2dPolyline) | AcDb2dPolyline | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
insertVertexAt(const AcDb2dVertex *pIndexVert, AcDb2dVertex *pNewVertex) (defined in AcDb2dPolyline) | AcDb2dPolyline |
insertVertexAt(AcDbObjectId &newVertId, const AcDbObjectId &indexVertId, AcDb2dVertex *pNewVertex) (defined in AcDb2dPolyline) | AcDb2dPolyline |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLinetypeGenerationOn() const (defined in AcDb2dPolyline) | AcDb2dPolyline |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
makeClosed() (defined in AcDb2dPolyline) | AcDb2dPolyline |
makeOpen() (defined in AcDb2dPolyline) | AcDb2dPolyline |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDb2dPolyline) | AcDb2dPolyline |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
openSequenceEnd(AcDbSequenceEnd *&, AcDb::OpenMode) (defined in AcDb2dPolyline) | AcDb2dPolyline |
openVertex(AcDb2dVertex *&, AcDbObjectId vertId, AcDb::OpenMode, bool openErasedOne=false) const (defined in AcDb2dPolyline) | AcDb2dPolyline |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
polyType() const (defined in AcDb2dPolyline) | AcDb2dPolyline |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDefaultEndWidth(double) (defined in AcDb2dPolyline) | AcDb2dPolyline |
setDefaultStartWidth(double) (defined in AcDb2dPolyline) | AcDb2dPolyline |
setElevation(double) (defined in AcDb2dPolyline) | AcDb2dPolyline |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeGenerationOff() (defined in AcDb2dPolyline) | AcDb2dPolyline |
setLinetypeGenerationOn() (defined in AcDb2dPolyline) | AcDb2dPolyline |
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDb2dPolyline) | AcDb2dPolyline |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPolyType(AcDb::Poly2dType) (defined in AcDb2dPolyline) | AcDb2dPolyline |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setThickness(double) (defined in AcDb2dPolyline) | AcDb2dPolyline |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
splineFit() (defined in AcDb2dPolyline) | AcDb2dPolyline |
splineFit(AcDb::Poly2dType splineType, Adesk::Int16 splineSegs) (defined in AcDb2dPolyline) | AcDb2dPolyline |
straighten() (defined in AcDb2dPolyline) | AcDb2dPolyline |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thickness() const (defined in AcDb2dPolyline) | AcDb2dPolyline |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
vertexIterator() const (defined in AcDb2dPolyline) | AcDb2dPolyline |
vertexPosition(const AcDb2dVertex &vert) const (defined in AcDb2dPolyline) | AcDb2dPolyline |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDb2dPolyline) | AcDb2dPolyline | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDb2dPolyline() (defined in AcDb2dPolyline) | AcDb2dPolyline |
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDb2dVertex Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDb2dVertex Class Reference
AcDb Classes
+ Inheritance diagram for AcDb2dVertex:

Public Member Functions

AcDb2dVertex (const AcGePoint3d &position, double bulge=0, double startWidth=0, double endWidth=0, double tangent=0)
ACDB_DECLARE_MEMBERS (AcDb2dVertex)
double | bulge () const
double | endWidth () const
Acad::ErrorStatus | ignoreTangent ()
Adesk::Boolean | isTangentUsed () const
AcGePoint3d | position () const
Acad::ErrorStatus | setBulge (double newVal)
Acad::ErrorStatus | setEndWidth (double newVal)
Acad::ErrorStatus | setPosition (const AcGePoint3d &)
Acad::ErrorStatus | setStartWidth (double newVal)
Acad::ErrorStatus | setTangent (double newVal)
double | startWidth () const
double | tangent () const
Acad::ErrorStatus | useTangent ()
AcDb::Vertex2dType | vertexType () const
- Public Member Functions inherited from AcDbVertex
ACDB_DECLARE_MEMBERS (AcDbVertex)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDb2dVertex Member List

This is the complete list of members for AcDb2dVertex, including all inherited members.

AcDb2dVertex() (defined in AcDb2dVertex) | AcDb2dVertex |
AcDb2dVertex(const AcGePoint3d &position, double bulge=0, double startWidth=0, double endWidth=0, double tangent=0) (defined in AcDb2dVertex) | AcDb2dVertex |
ACDB_DECLARE_MEMBERS(AcDb2dVertex) (defined in AcDb2dVertex) | AcDb2dVertex |
ACDB_DECLARE_MEMBERS(AcDbVertex) (defined in AcDbVertex) | AcDbVertex |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbVertex() (defined in AcDbVertex) | AcDbVertex |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
bulge() const (defined in AcDb2dVertex) | AcDb2dVertex |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
endWidth() const (defined in AcDb2dVertex) | AcDb2dVertex |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
ignoreTangent() (defined in AcDb2dVertex) | AcDb2dVertex |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTangentUsed() const (defined in AcDb2dVertex) | AcDb2dVertex |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDb2dVertex) | AcDb2dVertex |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBulge(double newVal) (defined in AcDb2dVertex) | AcDb2dVertex |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setEndWidth(double newVal) (defined in AcDb2dVertex) | AcDb2dVertex |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDb2dVertex) | AcDb2dVertex |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setStartWidth(double newVal) (defined in AcDb2dVertex) | AcDb2dVertex |
setTangent(double newVal) (defined in AcDb2dVertex) | AcDb2dVertex |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
startWidth() const (defined in AcDb2dVertex) | AcDb2dVertex |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
tangent() const (defined in AcDb2dVertex) | AcDb2dVertex |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useTangent() (defined in AcDb2dVertex) | AcDb2dVertex |
vertexType() const (defined in AcDb2dVertex) | AcDb2dVertex |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDb2dVertex() (defined in AcDb2dVertex) | AcDb2dVertex |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbVertex() (defined in AcDbVertex) | AcDbVertex | inline
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDb2LineAngularDimension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDb2LineAngularDimension Class Reference
AcDb Classes
+ Inheritance diagram for AcDb2LineAngularDimension:

Public Member Functions

AcDb2LineAngularDimension (const AcGePoint3d &xLine1Start, const AcGePoint3d &xLine1End, const AcGePoint3d &xLine2Start, const AcGePoint3d &xLine2End, const AcGePoint3d &arcPoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull)
ACDB_DECLARE_MEMBERS (AcDb2LineAngularDimension)
AcGePoint3d | arcPoint () const
bool | extArcOn () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | setArcPoint (const AcGePoint3d &)
Acad::ErrorStatus | setExtArcOn (bool value)
Acad::ErrorStatus | setXLine1End (const AcGePoint3d &)
Acad::ErrorStatus | setXLine1Start (const AcGePoint3d &)
Acad::ErrorStatus | setXLine2End (const AcGePoint3d &)
Acad::ErrorStatus | setXLine2Start (const AcGePoint3d &)
AcGePoint3d | xLine1End () const
AcGePoint3d | xLine1Start () const
AcGePoint3d | xLine2End () const
AcGePoint3d | xLine2Start () const
- Public Member Functions inherited from AcDbDimension
ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbDimension
enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDb2LineAngularDimension Member List

This is the complete list of members for AcDb2LineAngularDimension, including all inherited members.

AcDb2LineAngularDimension() (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
AcDb2LineAngularDimension(const AcGePoint3d &xLine1Start, const AcGePoint3d &xLine1End, const AcGePoint3d &xLine2Start, const AcGePoint3d &xLine2End, const AcGePoint3d &arcPoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull) (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
ACDB_DECLARE_MEMBERS(AcDb2LineAngularDimension) (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
arcPoint() const (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extArcOn() const (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArcPoint(const AcGePoint3d &) (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setExtArcOn(bool value) (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXLine1End(const AcGePoint3d &) (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
setXLine1Start(const AcGePoint3d &) (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
setXLine2End(const AcGePoint3d &) (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
setXLine2Start(const AcGePoint3d &) (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xLine1End() const (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
xLine1Start() const (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
xLine2End() const (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
xLine2Start() const (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDb2LineAngularDimension() (defined in AcDb2LineAngularDimension) | AcDb2LineAngularDimension |
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDb3dPolyline Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDb3dPolyline Class Reference
AcDb Classes
+ Inheritance diagram for AcDb3dPolyline:

Public Member Functions

AcDb3dPolyline (AcDb::Poly3dType, AcGePoint3dArray &vertices, Adesk::Boolean closed=Adesk::kFalse)
ACDB_DECLARE_MEMBERS (AcDb3dPolyline)
Acad::ErrorStatus | appendVertex (AcDb3dPolylineVertex *)
Acad::ErrorStatus | appendVertex (AcDbObjectId &objId, AcDb3dPolylineVertex *)
Acad::ErrorStatus | convertToPolyType (AcDb::Poly3dType newVal)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | insertVertexAt (const AcDb3dPolylineVertex *pIndexVert, AcDb3dPolylineVertex *pNewVertex)
Acad::ErrorStatus | insertVertexAt (AcDbObjectId &newVertId, const AcDbObjectId &indexVertId, AcDb3dPolylineVertex *pNewVertex)
DBCURVE_METHODS Acad::ErrorStatus | makeClosed ()
Acad::ErrorStatus | makeOpen ()
Acad::ErrorStatus | openSequenceEnd (AcDbSequenceEnd *&, AcDb::OpenMode)
Acad::ErrorStatus | openVertex (AcDb3dPolylineVertex *&, AcDbObjectId vertId, AcDb::OpenMode, bool openErasedOne=false)
AcDb::Poly3dType | polyType () const
Acad::ErrorStatus | setPolyType (AcDb::Poly3dType)
Acad::ErrorStatus | splineFit ()
Acad::ErrorStatus | splineFit (AcDb::Poly3dType splineType, Adesk::Int16 splineSegs)
Acad::ErrorStatus | straighten ()
AcDbObjectIterator * | vertexIterator () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDb3dPolyline Member List

This is the complete list of members for AcDb3dPolyline, including all inherited members.

AcDb3dPolyline() (defined in AcDb3dPolyline) | AcDb3dPolyline |
AcDb3dPolyline(AcDb::Poly3dType, AcGePoint3dArray &vertices, Adesk::Boolean closed=Adesk::kFalse) (defined in AcDb3dPolyline) | AcDb3dPolyline |
ACDB_DECLARE_MEMBERS(AcDb3dPolyline) (defined in AcDb3dPolyline) | AcDb3dPolyline |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
appendVertex(AcDb3dPolylineVertex *) (defined in AcDb3dPolyline) | AcDb3dPolyline |
appendVertex(AcDbObjectId &objId, AcDb3dPolylineVertex *) (defined in AcDb3dPolyline) | AcDb3dPolyline |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToPolyType(AcDb::Poly3dType newVal) (defined in AcDb3dPolyline) | AcDb3dPolyline |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDb3dPolyline) | AcDb3dPolyline | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
insertVertexAt(const AcDb3dPolylineVertex *pIndexVert, AcDb3dPolylineVertex *pNewVertex) (defined in AcDb3dPolyline) | AcDb3dPolyline |
insertVertexAt(AcDbObjectId &newVertId, const AcDbObjectId &indexVertId, AcDb3dPolylineVertex *pNewVertex) (defined in AcDb3dPolyline) | AcDb3dPolyline |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
makeClosed() (defined in AcDb3dPolyline) | AcDb3dPolyline |
makeOpen() (defined in AcDb3dPolyline) | AcDb3dPolyline |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
openSequenceEnd(AcDbSequenceEnd *&, AcDb::OpenMode) (defined in AcDb3dPolyline) | AcDb3dPolyline |
openVertex(AcDb3dPolylineVertex *&, AcDbObjectId vertId, AcDb::OpenMode, bool openErasedOne=false) (defined in AcDb3dPolyline) | AcDb3dPolyline |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
polyType() const (defined in AcDb3dPolyline) | AcDb3dPolyline |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPolyType(AcDb::Poly3dType) (defined in AcDb3dPolyline) | AcDb3dPolyline |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
splineFit() (defined in AcDb3dPolyline) | AcDb3dPolyline |
splineFit(AcDb::Poly3dType splineType, Adesk::Int16 splineSegs) (defined in AcDb3dPolyline) | AcDb3dPolyline |
straighten() (defined in AcDb3dPolyline) | AcDb3dPolyline |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
vertexIterator() const (defined in AcDb3dPolyline) | AcDb3dPolyline |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDb3dPolyline) | AcDb3dPolyline | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDb3dPolyline() (defined in AcDb3dPolyline) | AcDb3dPolyline |
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDb3dPolylineVertex Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDb3dPolylineVertex Class Reference
AcDb Classes
+ Inheritance diagram for AcDb3dPolylineVertex:

Public Member Functions

AcDb3dPolylineVertex (const AcGePoint3d &)
ACDB_DECLARE_MEMBERS (AcDb3dPolylineVertex)
AcGePoint3d | position () const
Acad::ErrorStatus | setPosition (const AcGePoint3d &)
AcDb::Vertex3dType | vertexType () const
- Public Member Functions inherited from AcDbVertex
ACDB_DECLARE_MEMBERS (AcDbVertex)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDb3dPolylineVertex Member List

This is the complete list of members for AcDb3dPolylineVertex, including all inherited members.

AcDb3dPolylineVertex() (defined in AcDb3dPolylineVertex) | AcDb3dPolylineVertex |
AcDb3dPolylineVertex(const AcGePoint3d &) (defined in AcDb3dPolylineVertex) | AcDb3dPolylineVertex |
ACDB_DECLARE_MEMBERS(AcDb3dPolylineVertex) (defined in AcDb3dPolylineVertex) | AcDb3dPolylineVertex |
ACDB_DECLARE_MEMBERS(AcDbVertex) (defined in AcDbVertex) | AcDbVertex |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbVertex() (defined in AcDbVertex) | AcDbVertex |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDb3dPolylineVertex) | AcDb3dPolylineVertex |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDb3dPolylineVertex) | AcDb3dPolylineVertex |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
vertexType() const (defined in AcDb3dPolylineVertex) | AcDb3dPolylineVertex |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDb3dPolylineVertex() (defined in AcDb3dPolylineVertex) | AcDb3dPolylineVertex |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbVertex() (defined in AcDbVertex) | AcDbVertex | inline
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDb3dSolid Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDb3dSolid Class Reference
AcDb Classes
+ Inheritance diagram for AcDb3dSolid:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDb3dSolid)
virtual void * | body () const
virtual Acad::ErrorStatus | booleanOper (AcDb::BoolOperType operation, AcDb3dSolid *solid)
virtual Acad::ErrorStatus | chamferEdges (const AcArray< AcDbSubentId * > &edgeSubentIds, const AcDbSubentId &baseFaceSubentId, double baseDist, double otherDist)
virtual Acad::ErrorStatus | checkInterference (const AcDb3dSolid *otherSolid, Adesk::Boolean createNewSolid, Adesk::Boolean &solidsInterfere, AcDb3dSolid *&commonVolumeSolid) const
virtual Acad::ErrorStatus | cleanBody ()
virtual Acad::ErrorStatus | convertToBrepAtSubentPaths (const AcDbFullSubentPathArray &paths)
virtual Acad::ErrorStatus | copyEdge (const AcDbSubentId &subentId, AcDbEntity *&newEntity)
virtual Acad::ErrorStatus | copyFace (const AcDbSubentId &subentId, AcDbEntity *&newEntity)
virtual Acad::ErrorStatus | createBox (double xLen, double yLen, double zLen)
virtual Acad::ErrorStatus | createExtrudedSolid (AcDbEntity *pSweepEnt, const AcGeVector3d &directionVec, AcDbSweepOptions &sweepOptions)
virtual Acad::ErrorStatus | createExtrudedSolid (AcDbEntity *pSweepEnt, const AcDbSubentId &faceSubentId, const AcGeVector3d &directionVec, AcDbSweepOptions &sweepOptions)
virtual Acad::ErrorStatus | createExtrudedSolid (AcDbEntity *pSweepEnt, const AcDbSubentId &faceSubentId, double height, AcDbSweepOptions &sweepOptions)
virtual Acad::ErrorStatus | createFrustum (double height, double xRadius, double yRadius, double topXRadius)
virtual Acad::ErrorStatus | createLoftedSolid (AcArray< AcDbEntity * > &crossSectionCurves, AcArray< AcDbEntity * > &guideCurves, AcDbEntity *pPathCurve, AcDbLoftOptions &loftOptions)
virtual Acad::ErrorStatus | createPyramid (double height, int sides, double radius, double topRadius=0.0)
virtual Acad::ErrorStatus | createRevolvedSolid (AcDbEntity *pRevEnt, const AcGePoint3d &axisPnt, const AcGeVector3d &axisDir, double revAngle, double startAngle, AcDbRevolveOptions &revolveOptions)
virtual Acad::ErrorStatus | createRevolvedSolid (AcDbEntity *pRevEnt, const AcDbSubentId &faceSubentId, const AcGePoint3d &axisPnt, const AcGeVector3d &axisDir, double revAngle, double startAngle, AcDbRevolveOptions &revolveOptions)
virtual Acad::ErrorStatus | createSphere (double radius)
virtual Acad::ErrorStatus | createSweptSolid (AcDbEntity *pSweepEnt, AcDbEntity *pPathEnt, AcDbSweepOptions &sweepOptions)
virtual Acad::ErrorStatus | createSweptSolid (AcDbEntity *pSweepEnt, const AcDbSubentId &faceSubentId, AcDbEntity *pPathEnt, AcDbSweepOptions &sweepOptions)
virtual Acad::ErrorStatus | createTorus (double majorRadius, double minorRadius)
virtual Acad::ErrorStatus | createWedge (double xLen, double yLen, double zLen)
virtual Acad::ErrorStatus | extrude (const AcDbRegion *region, double height, double taperAngle=0.0)
virtual Acad::ErrorStatus | extrudeAlongPath (const AcDbRegion *region, const AcDbCurve *path, double taperAngle=0.0)
virtual Acad::ErrorStatus | extrudeFaces (const AcArray< AcDbSubentId * > &faceSubentIds, double height, double taper)
virtual Acad::ErrorStatus | extrudeFacesAlongPath (const AcArray< AcDbSubentId * > &faceSubentIds, const AcDbCurve *path)
virtual Acad::ErrorStatus | filletEdges (const AcArray< AcDbSubentId * > &edgeSubentIds, const AcGeDoubleArray &radius, const AcGeDoubleArray &startSetback, const AcGeDoubleArray &endSetback)
virtual Acad::ErrorStatus | getArea (double &area) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMassProp (double &volume, AcGePoint3d &centroid, double momInertia[3], double prodInertia[3], double prinMoments[3], AcGeVector3d prinAxes[3], double radiiGyration[3], AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSection (const AcGePlane &plane, AcDbRegion *&sectionRegion) const
virtual Acad::ErrorStatus | getSlice (const AcGePlane &plane, Adesk::Boolean getNegHalfToo, AcDb3dSolid *&negHalfSolid)
virtual Acad::ErrorStatus | getSlice (AcDbSurface *pSurface, bool bGetNegHalfToo, AcDb3dSolid *&pNegHalfSolid)
virtual Acad::ErrorStatus | getSubentColor (const AcDbSubentId &subentId, AcCmColor &color) const
virtual Acad::ErrorStatus | getSubentMaterial (const AcDbSubentId &subentId, AcDbObjectId &matId) const
virtual Acad::ErrorStatus | getSubentMaterialMapper (const AcDbSubentId &subentId, AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | imprintEntity (const AcDbEntity *pEntity)
virtual AcDbSubentId | internalSubentId (void *ent) const
virtual void * | internalSubentPtr (const AcDbSubentId &id) const
virtual Adesk::Boolean | isNull () const
virtual void | list () const
virtual Adesk::UInt32 | numChanges () const
virtual Acad::ErrorStatus | offsetBody (double offsetDistance)
virtual Acad::ErrorStatus | offsetFaces (const AcArray< AcDbSubentId * > &faceSubentIds, double offsetDistance)
virtual bool | recordHistory () const
virtual Acad::ErrorStatus | removeFaces (const AcArray< AcDbSubentId * > &faceSubentIds)
virtual Acad::ErrorStatus | revolve (const AcDbRegion *region, const AcGePoint3d &axisPoint, const AcGeVector3d &axisDir, double angleOfRevolution)
virtual Acad::ErrorStatus | separateBody (AcArray< AcDb3dSolid * > &newSolids)
virtual Acad::ErrorStatus | setBody (const void *modelerBody)
virtual Acad::ErrorStatus | setRecordHistory (bool bRecord)
virtual Acad::ErrorStatus | setShowHistory (bool bShow)
virtual Acad::ErrorStatus | setSubentColor (const AcDbSubentId &subentId, const AcCmColor &color)
virtual Acad::ErrorStatus | setSubentMaterial (const AcDbSubentId &subentId, AcDbObjectId matId)
virtual Acad::ErrorStatus | setSubentMaterialMapper (const AcDbSubentId &subentId, const AcGiMapper &mapper)
virtual Acad::ErrorStatus | shellBody (const AcArray< AcDbSubentId * > &faceSubentIds, double offsetDistance)
virtual bool | showHistory () const
virtual Acad::ErrorStatus | stlOut (const ACHAR *fileName, Adesk::Boolean asciiFormat) const
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual Acad::ErrorStatus | taperFaces (const AcArray< AcDbSubentId * > &faceSubentIds, const AcGePoint3d &basePoint, const AcGeVector3d &draftVector, double draftAngle)
virtual Acad::ErrorStatus | transformFaces (const AcArray< AcDbSubentId * > &faceSubentIds, const AcGeMatrix3d &matrix)
virtual void | viewportDraw (AcGiViewportDraw *pVpDraw)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

virtual void* AcDb3dSolid::body ( ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDb3dSolid::convertToBrepAtSubentPaths ( const AcDbFullSubentPathArray & paths )
virtual
Warning
Not implemented!
virtual AcDbSubentId AcDb3dSolid::internalSubentId ( void * ent ) const
virtual
Warning
Not implemented!
virtual void* AcDb3dSolid::internalSubentPtr ( const AcDbSubentId & id ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDb3dSolid::setBody ( const void * modelerBody )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDb3dSolid::stlOut | ( | const ACHAR * | fileName,
 |  | Adesk::Boolean | asciiFormat
 | ) |  | const
 virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbsol3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDb3dSolid Member List

This is the complete list of members for AcDb3dSolid, including all inherited members.

AcDb3dSolid() (defined in AcDb3dSolid) | AcDb3dSolid |
ACDB_DECLARE_MEMBERS(AcDb3dSolid) (defined in AcDb3dSolid) | AcDb3dSolid |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
body() const | AcDb3dSolid | virtual
booleanOper(AcDb::BoolOperType operation, AcDb3dSolid *solid) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
chamferEdges(const AcArray< AcDbSubentId * > &edgeSubentIds, const AcDbSubentId &baseFaceSubentId, double baseDist, double otherDist) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
checkInterference(const AcDb3dSolid *otherSolid, Adesk::Boolean createNewSolid, Adesk::Boolean &solidsInterfere, AcDb3dSolid *&commonVolumeSolid) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
cleanBody() (defined in AcDb3dSolid) | AcDb3dSolid | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToBrepAtSubentPaths(const AcDbFullSubentPathArray &paths) | AcDb3dSolid | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyEdge(const AcDbSubentId &subentId, AcDbEntity *&newEntity) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
copyFace(const AcDbSubentId &subentId, AcDbEntity *&newEntity) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createBox(double xLen, double yLen, double zLen) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createExtrudedSolid(AcDbEntity *pSweepEnt, const AcGeVector3d &directionVec, AcDbSweepOptions &sweepOptions) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createExtrudedSolid(AcDbEntity *pSweepEnt, const AcDbSubentId &faceSubentId, const AcGeVector3d &directionVec, AcDbSweepOptions &sweepOptions) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createExtrudedSolid(AcDbEntity *pSweepEnt, const AcDbSubentId &faceSubentId, double height, AcDbSweepOptions &sweepOptions) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createFrustum(double height, double xRadius, double yRadius, double topXRadius) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createLoftedSolid(AcArray< AcDbEntity * > &crossSectionCurves, AcArray< AcDbEntity * > &guideCurves, AcDbEntity *pPathCurve, AcDbLoftOptions &loftOptions) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createPyramid(double height, int sides, double radius, double topRadius=0.0) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createRevolvedSolid(AcDbEntity *pRevEnt, const AcGePoint3d &axisPnt, const AcGeVector3d &axisDir, double revAngle, double startAngle, AcDbRevolveOptions &revolveOptions) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createRevolvedSolid(AcDbEntity *pRevEnt, const AcDbSubentId &faceSubentId, const AcGePoint3d &axisPnt, const AcGeVector3d &axisDir, double revAngle, double startAngle, AcDbRevolveOptions &revolveOptions) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createSphere(double radius) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createSweptSolid(AcDbEntity *pSweepEnt, AcDbEntity *pPathEnt, AcDbSweepOptions &sweepOptions) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createSweptSolid(AcDbEntity *pSweepEnt, const AcDbSubentId &faceSubentId, AcDbEntity *pPathEnt, AcDbSweepOptions &sweepOptions) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createTorus(double majorRadius, double minorRadius) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
createWedge(double xLen, double yLen, double zLen) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
extrude(const AcDbRegion *region, double height, double taperAngle=0.0) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
extrudeAlongPath(const AcDbRegion *region, const AcDbCurve *path, double taperAngle=0.0) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
extrudeFaces(const AcArray< AcDbSubentId * > &faceSubentIds, double height, double taper) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
extrudeFacesAlongPath(const AcArray< AcDbSubentId * > &faceSubentIds, const AcDbCurve *path) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
filletEdges(const AcArray< AcDbSubentId * > &edgeSubentIds, const AcGeDoubleArray &radius, const AcGeDoubleArray &startSetback, const AcGeDoubleArray &endSetback) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &area) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getMassProp(double &volume, AcGePoint3d &centroid, double momInertia[3], double prodInertia[3], double prinMoments[3], AcGeVector3d prinAxes[3], double radiiGyration[3], AcDbExtents &extents) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getSection(const AcGePlane &plane, AcDbRegion *&sectionRegion) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getSlice(const AcGePlane &plane, Adesk::Boolean getNegHalfToo, AcDb3dSolid *&negHalfSolid) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getSlice(AcDbSurface *pSurface, bool bGetNegHalfToo, AcDb3dSolid *&pNegHalfSolid) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentColor(const AcDbSubentId &subentId, AcCmColor &color) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getSubentMaterial(const AcDbSubentId &subentId, AcDbObjectId &matId) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getSubentMaterialMapper(const AcDbSubentId &subentId, AcGiMapper &mapper) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
imprintEntity(const AcDbEntity *pEntity) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
internalSubentId(void *ent) const | AcDb3dSolid | virtual
internalSubentPtr(const AcDbSubentId &id) const | AcDb3dSolid | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isNull() const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
numChanges() const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
offsetBody(double offsetDistance) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
offsetFaces(const AcArray< AcDbSubentId * > &faceSubentIds, double offsetDistance) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recordHistory() const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeFaces(const AcArray< AcDbSubentId * > &faceSubentIds) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
revolve(const AcDbRegion *region, const AcGePoint3d &axisPoint, const AcGeVector3d &axisDir, double angleOfRevolution) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
separateBody(AcArray< AcDb3dSolid * > &newSolids) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBody(const void *modelerBody) | AcDb3dSolid | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRecordHistory(bool bRecord) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
setShowHistory(bool bShow) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
setSubentColor(const AcDbSubentId &subentId, const AcCmColor &color) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
setSubentMaterial(const AcDbSubentId &subentId, AcDbObjectId matId) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
setSubentMaterialMapper(const AcDbSubentId &subentId, const AcGiMapper &mapper) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shellBody(const AcArray< AcDbSubentId * > &faceSubentIds, double offsetDistance) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
showHistory() const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
stlOut(const ACHAR *fileName, Adesk::Boolean asciiFormat) const | AcDb3dSolid | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDb3dSolid) | AcDb3dSolid | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
taperFaces(const AcArray< AcDbSubentId * > &faceSubentIds, const AcGePoint3d &basePoint, const AcGeVector3d &draftVector, double draftAngle) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformFaces(const AcArray< AcDbSubentId * > &faceSubentIds, const AcGeMatrix3d &matrix) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVpDraw) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDb3dSolid) | AcDb3dSolid | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDb3dSolid() (defined in AcDb3dSolid) | AcDb3dSolid | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDb3PointAngularDimension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDb3PointAngularDimension Class Reference
AcDb Classes
+ Inheritance diagram for AcDb3PointAngularDimension:

Public Member Functions

AcDb3PointAngularDimension (const AcGePoint3d &centerPoint, const AcGePoint3d &xLine1Point, const AcGePoint3d &xLine2Point, const AcGePoint3d &arcPoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull)
ACDB_DECLARE_MEMBERS (AcDb3PointAngularDimension)
AcGePoint3d | arcPoint () const
AcGePoint3d | centerPoint () const
bool | extArcOn () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | setArcPoint (const AcGePoint3d &)
Acad::ErrorStatus | setCenterPoint (const AcGePoint3d &)
Acad::ErrorStatus | setExtArcOn (bool value)
Acad::ErrorStatus | setXLine1Point (const AcGePoint3d &)
Acad::ErrorStatus | setXLine2Point (const AcGePoint3d &)
AcGePoint3d | xLine1Point () const
AcGePoint3d | xLine2Point () const
- Public Member Functions inherited from AcDbDimension
ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbDimension
enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDb3PointAngularDimension Member List

This is the complete list of members for AcDb3PointAngularDimension, including all inherited members.

AcDb3PointAngularDimension() (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
AcDb3PointAngularDimension(const AcGePoint3d &centerPoint, const AcGePoint3d &xLine1Point, const AcGePoint3d &xLine2Point, const AcGePoint3d &arcPoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull) (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
ACDB_DECLARE_MEMBERS(AcDb3PointAngularDimension) (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
arcPoint() const (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
centerPoint() const (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extArcOn() const (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArcPoint(const AcGePoint3d &) (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setCenterPoint(const AcGePoint3d &) (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setExtArcOn(bool value) (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXLine1Point(const AcGePoint3d &) (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
setXLine2Point(const AcGePoint3d &) (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xLine1Point() const (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
xLine2Point() const (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDb3PointAngularDimension() (defined in AcDb3PointAngularDimension) | AcDb3PointAngularDimension |
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAbstractViewTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbAbstractViewTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAbstractViewTable:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbAbstractViewTable)
Acad::ErrorStatus | add (AcDbAbstractViewTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbAbstractViewTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbAbstractViewTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbAbstractViewTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbSymbolTable
typedef AcDbSymbolTableRecord | RecordType
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAbstractViewTable Member List

This is the complete list of members for AcDbAbstractViewTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbAbstractViewTable) (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbAbstractViewTable() (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbAbstractViewTableRecord *pRecord) (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
add(AcDbObjectId &recordId, AcDbAbstractViewTableRecord *pRecord) (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbAbstractViewTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
has(AcDbObjectId id) const (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbAbstractViewTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbSymbolTable) | AcDbSymbolTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbAbstractViewTable() (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAbstractViewTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbAbstractViewTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAbstractViewTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbAbstractViewTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbAbstractViewTableRecord *pRecord)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbAbstractViewTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAbstractViewTableIterator Member List

This is the complete list of members for AcDbAbstractViewTableIterator, including all inherited members.

AcDbAbstractViewTable (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator | friend
AcDbAbstractViewTableIterator() (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator | protected
AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbAbstractViewTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator |
seek(const AcDbAbstractViewTableRecord *pRecord) (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbAbstractViewTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbAbstractViewTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAbstractViewTableRecord:

Public Types

enum RenderMode {
k2DOptimized, kWireframe, kHiddenLine, kFlatShaded,
kGouraudShaded, kFlatShadedWithWireframe, kGouraudShadedWithWireframe
}
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbAbstractViewTableRecord)
AcCmColor | ambientLightColor () const
double | backClipDistance () const
bool | backClipEnabled () const
const AcDbObjectId & | background () const
AcDbObjectId & background ()
double | brightness () const
AcGePoint2d | centerPoint () const
double | contrast () const
AcGiViewportTraits::DefaultLightingType | defaultLightingType () const
double | elevation () const
bool | frontClipAtEye () const
double | frontClipDistance () const
bool | frontClipEnabled () const
Acad::ErrorStatus | getUcs (AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis) const
double | height () const
bool | isDefaultLightingOn () const
bool | isUcsOrthographic (AcDb::OrthographicView &view) const
bool | isViewOrthographic (AcDb::OrthographicView &view) const
double | lensLength () const
bool | perspectiveEnabled () const
RenderMode | renderMode () const
Acad::ErrorStatus | setAmbientLightColor (const AcCmColor &clr)
void | setBackClipDistance (double distance)
void | setBackClipEnabled (bool enabled)
Acad::ErrorStatus | setBackground (const AcDbObjectId &backgroundId)
Acad::ErrorStatus | setBrightness (double)
void | setCenterPoint (const AcGePoint2d &)
Acad::ErrorStatus | setContrast (double)
Acad::ErrorStatus | setDefaultLightingOn (bool on)
Acad::ErrorStatus | setDefaultLightingType (AcGiViewportTraits::DefaultLightingType typ)
Acad::ErrorStatus | setElevation (double elev)
void | setFrontClipAtEye (bool atEye)
void | setFrontClipDistance (double distance)
void | setFrontClipEnabled (bool enabled)
void | setHeight (double height)
void | setLensLength (double length)
void | setPerspectiveEnabled (bool enabled)
void | setRenderMode (RenderMode mode)
Acad::ErrorStatus | setSun (AcDbObjectId &retId, AcDbObject *pSun)
void | setTarget (const AcGePoint3d &target)
Acad::ErrorStatus | setToneOperatorParameters (const AcGiToneOperatorParameters &params)
Acad::ErrorStatus | setUcs (const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis)
Acad::ErrorStatus | setUcs (AcDb::OrthographicView view)
Acad::ErrorStatus | setUcs (const AcDbObjectId &ucsId)
Acad::ErrorStatus | setUcsToWorld ()
void | setViewDirection (const AcGeVector3d &viewDirection)
Acad::ErrorStatus | setViewDirection (AcDb::OrthographicView view)
void | setViewTwist (double angle)
Acad::ErrorStatus | setVisualStyle (const AcDbObjectId &visualStyleId)
void | setWidth (double width)
AcDbObjectId | sunId () const
AcGePoint3d | target () const
Acad::ErrorStatus | toneOperatorParameters (AcGiToneOperatorParameters &params) const
AcDbObjectId | ucsName () const
AcGeVector3d | viewDirection () const
double | viewTwist () const
AcDbObjectId | visualStyle () const
double | width () const
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

AcCmColor AcDbAbstractViewTableRecord::ambientLightColor ( ) const
Warning
Not implemented!
const AcDbObjectId& AcDbAbstractViewTableRecord::background ( ) const
Warning
Not implemented!
AcDbObjectId& AcDbAbstractViewTableRecord::background ( )
Warning
Not implemented!
double AcDbAbstractViewTableRecord::brightness ( ) const
Warning
Not implemented!
double AcDbAbstractViewTableRecord::contrast ( ) const
Warning
Not implemented!
AcGiViewportTraits::DefaultLightingType AcDbAbstractViewTableRecord::defaultLightingType ( ) const
Warning
Not implemented!
bool AcDbAbstractViewTableRecord::isDefaultLightingOn ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbAbstractViewTableRecord::setAmbientLightColor ( const AcCmColor & clr )
Warning
Not implemented!
Acad::ErrorStatus AcDbAbstractViewTableRecord::setBackground ( const AcDbObjectId & backgroundId )
Warning
Not implemented!
Acad::ErrorStatus AcDbAbstractViewTableRecord::setBrightness ( double )
Warning
Not implemented!
Acad::ErrorStatus AcDbAbstractViewTableRecord::setContrast ( double )
Warning
Not implemented!
Acad::ErrorStatus AcDbAbstractViewTableRecord::setDefaultLightingOn ( bool on )
Warning
Not implemented!
Acad::ErrorStatus AcDbAbstractViewTableRecord::setDefaultLightingType ( AcGiViewportTraits::DefaultLightingType typ )
Warning
Not implemented!
Acad::ErrorStatus AcDbAbstractViewTableRecord::setSun | ( | AcDbObjectId & | retId,
 |  | AcDbObject * | pSun
 | ) |  |
Warning
Not implemented!

Reimplemented in AcDbViewTableRecord.

Acad::ErrorStatus AcDbAbstractViewTableRecord::setToneOperatorParameters ( const AcGiToneOperatorParameters & params )
Warning
Not implemented!
Acad::ErrorStatus AcDbAbstractViewTableRecord::setVisualStyle ( const AcDbObjectId & visualStyleId )
Warning
Not implemented!
Acad::ErrorStatus AcDbAbstractViewTableRecord::toneOperatorParameters ( AcGiToneOperatorParameters & params ) const
Warning
Not implemented!
AcDbObjectId AcDbAbstractViewTableRecord::visualStyle ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAbstractViewTableRecord Member List

This is the complete list of members for AcDbAbstractViewTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbAbstractViewTableRecord) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbAbstractViewTableRecord() (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
ambientLightColor() const | AcDbAbstractViewTableRecord |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
backClipDistance() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
backClipEnabled() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
background() const | AcDbAbstractViewTableRecord |
background() | AcDbAbstractViewTableRecord |
brightness() const | AcDbAbstractViewTableRecord |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
centerPoint() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const | AcDbAbstractViewTableRecord |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
defaultLightingType() const | AcDbAbstractViewTableRecord |
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
elevation() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
frontClipAtEye() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
frontClipDistance() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
frontClipEnabled() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getUcs(AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis) const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDefaultLightingOn() const | AcDbAbstractViewTableRecord |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUcsOrthographic(AcDb::OrthographicView &view) const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isViewOrthographic(AcDb::OrthographicView &view) const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
k2DOptimized enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kFlatShaded enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kFlatShadedWithWireframe enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGouraudShaded enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kGouraudShadedWithWireframe enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHiddenLine enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kWireframe enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
lensLength() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
perspectiveEnabled() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RenderMode enum name (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
renderMode() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAmbientLightColor(const AcCmColor &clr) | AcDbAbstractViewTableRecord |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBackClipDistance(double distance) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setBackClipEnabled(bool enabled) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setBackground(const AcDbObjectId &backgroundId) | AcDbAbstractViewTableRecord |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBrightness(double) | AcDbAbstractViewTableRecord |
setCenterPoint(const AcGePoint2d &) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setContrast(double) | AcDbAbstractViewTableRecord |
setDefaultLightingOn(bool on) | AcDbAbstractViewTableRecord |
setDefaultLightingType(AcGiViewportTraits::DefaultLightingType typ) | AcDbAbstractViewTableRecord |
setElevation(double elev) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFrontClipAtEye(bool atEye) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setFrontClipDistance(double distance) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setFrontClipEnabled(bool enabled) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double height) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setLensLength(double length) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPerspectiveEnabled(bool enabled) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setRenderMode(RenderMode mode) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setSun(AcDbObjectId &retId, AcDbObject *pSun) | AcDbAbstractViewTableRecord |
setTarget(const AcGePoint3d &target) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setToneOperatorParameters(const AcGiToneOperatorParameters &params) | AcDbAbstractViewTableRecord |
setUcs(const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUcs(AcDb::OrthographicView view) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUcs(const AcDbObjectId &ucsId) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUcsToWorld() (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setViewDirection(const AcGeVector3d &viewDirection) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setViewDirection(AcDb::OrthographicView view) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setViewTwist(double angle) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setVisualStyle(const AcDbObjectId &visualStyleId) | AcDbAbstractViewTableRecord |
setWidth(double width) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
sunId() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
target() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
toneOperatorParameters(AcGiToneOperatorParameters &params) const | AcDbAbstractViewTableRecord |
ucsName() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewDirection() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
viewTwist() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
visualStyle() const | AcDbAbstractViewTableRecord |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
width() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbAbstractViewTableRecord() (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAlignedDimension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbAlignedDimension Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAlignedDimension:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbAlignedDimension)
AcDbAlignedDimension (const AcGePoint3d &xLine1Point, const AcGePoint3d &xLine2Point, const AcGePoint3d &dimLinePoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull)
AcGePoint3d | dimLinePoint () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | jogSymbolOn () const
AcGePoint3d | jogSymbolPosition () const
double | oblique () const
Acad::ErrorStatus | setDimLinePoint (const AcGePoint3d &)
Acad::ErrorStatus | setJogSymbolOn (bool value)
Acad::ErrorStatus | setJogSymbolPosition (const AcGePoint3d &pt)
Acad::ErrorStatus | setOblique (double)
Acad::ErrorStatus | setXLine1Point (const AcGePoint3d &)
Acad::ErrorStatus | setXLine2Point (const AcGePoint3d &)
AcGePoint3d | xLine1Point () const
AcGePoint3d | xLine2Point () const
- Public Member Functions inherited from AcDbDimension
ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbDimension
enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAlignedDimension Member List

This is the complete list of members for AcDbAlignedDimension, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbAlignedDimension) (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbAlignedDimension() (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
AcDbAlignedDimension(const AcGePoint3d &xLine1Point, const AcGePoint3d &xLine2Point, const AcGePoint3d &dimLinePoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull) (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimLinePoint() const (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbAlignedDimension) | AcDbAlignedDimension | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
jogSymbolOn() const (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
jogSymbolPosition() const (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
oblique() const (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimLinePoint(const AcGePoint3d &) (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setJogSymbolOn(bool value) (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
setJogSymbolPosition(const AcGePoint3d &pt) (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOblique(double) (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXLine1Point(const AcGePoint3d &) (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
setXLine2Point(const AcGePoint3d &) (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xLine1Point() const (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
xLine2Point() const (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbAlignedDimension() (defined in AcDbAlignedDimension) | AcDbAlignedDimension |
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAlignment Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbAlignment Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAlignment:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbAlignment)
virtual Acad::ErrorStatus | getAlignment (AcDbEntity *pEnt, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedPickedEntities, const AcGePoint3d &pickPoint, const AcGeVector3d &normal, AcGePoint3d &closestPoint, AcGeVector3d &direction)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbAlignment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAlignment Member List

This is the complete list of members for AcDbAlignment, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbAlignment) (defined in AcDbAlignment) | AcDbAlignment |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getAlignment(AcDbEntity *pEnt, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedPickedEntities, const AcGePoint3d &pickPoint, const AcGeVector3d &normal, AcGePoint3d &closestPoint, AcGeVector3d &direction)=0 (defined in AcDbAlignment) | AcDbAlignment | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAnnotationScale Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
AcDbAnnotationScale Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAnnotationScale:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbAnnotationScale)
virtual AcString | collectionName () const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pOther)
virtual Acad::ErrorStatus | getDrawingUnits (double &dDrawingUnits) const
virtual Acad::ErrorStatus | getIsTemporaryScale (bool &bTemporary) const
virtual Acad::ErrorStatus | getName (AcString &name) const
virtual Acad::ErrorStatus | getPaperUnits (double &dPaperUnits) const
virtual Acad::ErrorStatus | getScale (double &dScale) const
virtual bool | matchScaleId (Adesk::LongPtr id) const
virtual Acad::ErrorStatus | setDrawingUnits (const double dDrawingUnits)
virtual Acad::ErrorStatus | setName (const AcString &name)
virtual Acad::ErrorStatus | setPaperUnits (double dPaperUnits)
virtual Adesk::LongPtr | uniqueIdentifier () const
- Public Member Functions inherited from AcDbObjectContext
ACRX_DECLARE_MEMBERS (AcDbObjectContext)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcDbAnnotationScale (bool)

Protected Attributes

AcDbImpAnnotationScale * mpImp

Friends

class AcDbSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

virtual AcString AcDbAnnotationScale::collectionName ( ) const
virtual
Warning
Not implemented!

Implements AcDbObjectContext.

virtual Acad::ErrorStatus AcDbAnnotationScale::getName ( AcString & name ) const
virtual
Warning
Not implemented!

Implements AcDbObjectContext.

virtual Acad::ErrorStatus AcDbAnnotationScale::setName ( const AcString & name )
virtual
Warning
Not implemented!

Implements AcDbObjectContext.

The documentation for this class was generated from the following file:
  • dbAnnotationScale.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAnnotationScale Member List

This is the complete list of members for AcDbAnnotationScale, including all inherited members.

AcDbAnnotationScale() (defined in AcDbAnnotationScale) | AcDbAnnotationScale |
AcDbAnnotationScale(bool) (defined in AcDbAnnotationScale) | AcDbAnnotationScale | protected
AcDbObjectContext() (defined in AcDbObjectContext) | AcDbObjectContext |
AcDbSystemInternals (defined in AcDbAnnotationScale) | AcDbAnnotationScale | friend
ACRX_DECLARE_MEMBERS(AcDbAnnotationScale) (defined in AcDbAnnotationScale) | AcDbAnnotationScale |
ACRX_DECLARE_MEMBERS(AcDbObjectContext) (defined in AcDbObjectContext) | AcDbObjectContext |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
collectionName() const | AcDbAnnotationScale | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *pOther) (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getDrawingUnits(double &dDrawingUnits) const (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
getIsTemporaryScale(bool &bTemporary) const (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
getName(AcString &name) const | AcDbAnnotationScale | virtual
getPaperUnits(double &dPaperUnits) const (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
getScale(double &dScale) const (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
matchScaleId(Adesk::LongPtr id) const (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
mpImp (defined in AcDbAnnotationScale) | AcDbAnnotationScale | protected
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setDrawingUnits(const double dDrawingUnits) (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
setName(const AcString &name) | AcDbAnnotationScale | virtual
setPaperUnits(double dPaperUnits) (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
uniqueIdentifier() const (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbAnnotationScale() (defined in AcDbAnnotationScale) | AcDbAnnotationScale | virtual
~AcDbObjectContext() (defined in AcDbObjectContext) | AcDbObjectContext | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAnnotativeObjectPE Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbAnnotativeObjectPE Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAnnotativeObjectPE:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbAnnotativeObjectPE)
virtual bool | annotative (AcDbObject *pObject) const =0
virtual bool | forceAnnoAllVisible (AcDbObject *pObj) const
virtual Acad::ErrorStatus | resetScaleDependentProperties (AcDbObject *pObject)
virtual Acad::ErrorStatus | setAnnotative (AcDbObject *pObject, const bool bAnnotative)=0
virtual Acad::ErrorStatus | setForceAnnoAllVisible (AcDbObject *pObj, bool bForce) const
virtual Acad::ErrorStatus | setFromStyle (AcDbObject *pObject, bool &bUpdated)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbAnnotativeObjectPE.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAnnotativeObjectPE Member List

This is the complete list of members for AcDbAnnotativeObjectPE, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbAnnotativeObjectPE) (defined in AcDbAnnotativeObjectPE) | AcDbAnnotativeObjectPE |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
annotative(AcDbObject *pObject) const =0 (defined in AcDbAnnotativeObjectPE) | AcDbAnnotativeObjectPE | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
forceAnnoAllVisible(AcDbObject *pObj) const (defined in AcDbAnnotativeObjectPE) | AcDbAnnotativeObjectPE | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
resetScaleDependentProperties(AcDbObject *pObject) (defined in AcDbAnnotativeObjectPE) | AcDbAnnotativeObjectPE | inlinevirtual
setAnnotative(AcDbObject *pObject, const bool bAnnotative)=0 (defined in AcDbAnnotativeObjectPE) | AcDbAnnotativeObjectPE | pure virtual
setForceAnnoAllVisible(AcDbObject *pObj, bool bForce) const (defined in AcDbAnnotativeObjectPE) | AcDbAnnotativeObjectPE | inlinevirtual
setFromStyle(AcDbObject *pObject, bool &bUpdated)=0 (defined in AcDbAnnotativeObjectPE) | AcDbAnnotativeObjectPE | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAppEntityGrips Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbAppEntityGrips Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAppEntityGrips:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbAppEntityGrips)
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags, AcDbEntity *pEntity)=0
virtual void | gripStatus (const AcDb::GripStat status, AcDbEntity *pEntity)=0
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags, AcDbEntity *pEntity)=0
- Public Member Functions inherited from AcRxProtocolReactor
ACRX_DECLARE_MEMBERS (AcRxProtocolReactor)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbappgrip.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAppEntityGrips Member List

This is the complete list of members for AcDbAppEntityGrips, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbAppEntityGrips) (defined in AcDbAppEntityGrips) | AcDbAppEntityGrips |
ACRX_DECLARE_MEMBERS(AcRxProtocolReactor) (defined in AcRxProtocolReactor) | AcRxProtocolReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags, AcDbEntity *pEntity)=0 (defined in AcDbAppEntityGrips) | AcDbAppEntityGrips | pure virtual
gripStatus(const AcDb::GripStat status, AcDbEntity *pEntity)=0 (defined in AcDbAppEntityGrips) | AcDbAppEntityGrips | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags, AcDbEntity *pEntity)=0 (defined in AcDbAppEntityGrips) | AcDbAppEntityGrips | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAppSystemVariables Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbAppSystemVariables Class Reference
AcDb Classes

Public Member Functions

bool | attdia () const
bool | attreq () const
bool | blipmode () const
Adesk::Int16 | coords () const
Adesk::Int16 | delUsedObj () const
Adesk::Int16 | dragmode () const
bool | hpassoc () const
AcDb::LineWeight | lwdefault () const
Adesk::Int16 | osmode () const
Adesk::Int16 | pickstyle () const
Acad::ErrorStatus | setAttdia (bool value, bool bUndo=false)
Acad::ErrorStatus | setAttreq (bool, bool bUndo=false)
Acad::ErrorStatus | setBlipmode (bool, bool bUndo=false)
Acad::ErrorStatus | setCoords (Adesk::Int16 value, bool bUndo=false)
Acad::ErrorStatus | setDelUsedObj (Adesk::Int16, bool bUndo=false)
Acad::ErrorStatus | setDragmode (Adesk::Int16, bool bUndo=false)
Acad::ErrorStatus | setHpassoc (bool value, bool bUndo=false)
Acad::ErrorStatus | setLwdefault (AcDb::LineWeight value, bool bUndo=false)
Acad::ErrorStatus | setOsmode (Adesk::Int16 value, bool bUndo=false)
Acad::ErrorStatus | setPickstyle (Adesk::Int16 value, bool bUndo=false)
The documentation for this class was generated from the following file:
  • acappvar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAppSystemVariables Member List

This is the complete list of members for AcDbAppSystemVariables, including all inherited members.

AcDbAppSystemVariables() (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
attdia() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
attreq() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
blipmode() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
coords() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
delUsedObj() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
dragmode() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
hpassoc() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
lwdefault() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
osmode() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
pickstyle() const (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline
setAttdia(bool value, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
setAttreq(bool, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
setBlipmode(bool, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
setCoords(Adesk::Int16 value, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
setDelUsedObj(Adesk::Int16, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
setDragmode(Adesk::Int16, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
setHpassoc(bool value, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
setLwdefault(AcDb::LineWeight value, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
setOsmode(Adesk::Int16 value, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
setPickstyle(Adesk::Int16 value, bool bUndo=false) (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables |
~AcDbAppSystemVariables() (defined in AcDbAppSystemVariables) | AcDbAppSystemVariables | inline


ZRX API Reference: AcDbArc Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbArc Class Reference
AcDb Classes
+ Inheritance diagram for AcDbArc:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbArc)
AcDbArc (const AcGePoint3d &center, double radius, double startAngle, double endAngle)
AcDbArc (const AcGePoint3d &center, const AcGeVector3d &normal, double radius, double startAngle, double endAngle)
virtual bool | castShadows () const
AcGePoint3d | center () const
double | endAngle () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
DBCURVE_METHODS Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&ent) const
virtual void | gripStatus (const AcDb::GripStat status)
AcGeVector3d | normal () const
double | radius () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | setCenter (const AcGePoint3d &)
Acad::ErrorStatus | setEndAngle (double)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setRadius (double)
Acad::ErrorStatus | setStartAngle (double)
Acad::ErrorStatus | setThickness (double)
double | startAngle () const
double | thickness () const
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbArc Member List

This is the complete list of members for AcDbArc, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbArc) (defined in AcDbArc) | AcDbArc |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbArc() (defined in AcDbArc) | AcDbArc |
AcDbArc(const AcGePoint3d &center, double radius, double startAngle, double endAngle) (defined in AcDbArc) | AcDbArc |
AcDbArc(const AcGePoint3d &center, const AcGeVector3d &normal, double radius, double startAngle, double endAngle) (defined in AcDbArc) | AcDbArc |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbArc) | AcDbArc | virtual
center() const (defined in AcDbArc) | AcDbArc |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
endAngle() const (defined in AcDbArc) | AcDbArc |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbArc) | AcDbArc | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbArc) | AcDbArc | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbArc) | AcDbArc | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&ent) const (defined in AcDbArc) | AcDbArc | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbArc) | AcDbArc | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbArc) | AcDbArc |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
radius() const (defined in AcDbArc) | AcDbArc |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbArc) | AcDbArc | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setCenter(const AcGePoint3d &) (defined in AcDbArc) | AcDbArc |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setEndAngle(double) (defined in AcDbArc) | AcDbArc |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbArc) | AcDbArc |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setRadius(double) (defined in AcDbArc) | AcDbArc |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setStartAngle(double) (defined in AcDbArc) | AcDbArc |
setThickness(double) (defined in AcDbArc) | AcDbArc |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
startAngle() const (defined in AcDbArc) | AcDbArc |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thickness() const (defined in AcDbArc) | AcDbArc |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbArc() (defined in AcDbArc) | AcDbArc |
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbArcDimension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbArcDimension Class Reference
AcDb Classes
+ Inheritance diagram for AcDbArcDimension:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbArcDimension)
AcDbArcDimension (const AcGePoint3d &centerPoint, const AcGePoint3d &xLine1Point, const AcGePoint3d &xLine2Point, const AcGePoint3d &arcPoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull)
double | arcEndParam () const
AcGePoint3d | arcPoint () const
double | arcStartParam () const
int | arcSymbolType () const
AcGePoint3d | centerPoint () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | hasLeader () const
bool | isPartial () const
AcGePoint3d | leader1Point () const
AcGePoint3d | leader2Point () const
Acad::ErrorStatus | setArcEndParam (const double &arcParam)
Acad::ErrorStatus | setArcPoint (const AcGePoint3d &arcPt)
Acad::ErrorStatus | setArcStartParam (const double &arcParam)
Acad::ErrorStatus | setArcSymbolType (const int symbol)
Acad::ErrorStatus | setCenterPoint (const AcGePoint3d &ctrPt)
Acad::ErrorStatus | setHasLeader (const bool &leaderVal)
Acad::ErrorStatus | setIsPartial (const bool &partial)
Acad::ErrorStatus | setLeader1Point (const AcGePoint3d &ldr1Pt)
Acad::ErrorStatus | setLeader2Point (const AcGePoint3d &ldr2Pt)
Acad::ErrorStatus | setXLine1Point (const AcGePoint3d &xLine1Pt)
Acad::ErrorStatus | setXLine2Point (const AcGePoint3d &xLine2Pt)
AcGePoint3d | xLine1Point () const
AcGePoint3d | xLine2Point () const
- Public Member Functions inherited from AcDbDimension
ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbDimension
enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbArcDimension Member List

This is the complete list of members for AcDbArcDimension, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbArcDimension) (defined in AcDbArcDimension) | AcDbArcDimension |
ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbArcDimension() (defined in AcDbArcDimension) | AcDbArcDimension |
AcDbArcDimension(const AcGePoint3d &centerPoint, const AcGePoint3d &xLine1Point, const AcGePoint3d &xLine2Point, const AcGePoint3d &arcPoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull) (defined in AcDbArcDimension) | AcDbArcDimension |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
arcEndParam() const (defined in AcDbArcDimension) | AcDbArcDimension |
arcPoint() const (defined in AcDbArcDimension) | AcDbArcDimension |
arcStartParam() const (defined in AcDbArcDimension) | AcDbArcDimension |
arcSymbolType() const (defined in AcDbArcDimension) | AcDbArcDimension |
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
centerPoint() const (defined in AcDbArcDimension) | AcDbArcDimension |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbArcDimension) | AcDbArcDimension | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasLeader() const (defined in AcDbArcDimension) | AcDbArcDimension |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPartial() const (defined in AcDbArcDimension) | AcDbArcDimension |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
leader1Point() const (defined in AcDbArcDimension) | AcDbArcDimension |
leader2Point() const (defined in AcDbArcDimension) | AcDbArcDimension |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArcEndParam(const double &arcParam) (defined in AcDbArcDimension) | AcDbArcDimension |
setArcPoint(const AcGePoint3d &arcPt) (defined in AcDbArcDimension) | AcDbArcDimension |
setArcStartParam(const double &arcParam) (defined in AcDbArcDimension) | AcDbArcDimension |
setArcSymbolType(const int symbol) (defined in AcDbArcDimension) | AcDbArcDimension |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setCenterPoint(const AcGePoint3d &ctrPt) (defined in AcDbArcDimension) | AcDbArcDimension |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasLeader(const bool &leaderVal) (defined in AcDbArcDimension) | AcDbArcDimension |
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setIsPartial(const bool &partial) (defined in AcDbArcDimension) | AcDbArcDimension |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLeader1Point(const AcGePoint3d &ldr1Pt) (defined in AcDbArcDimension) | AcDbArcDimension |
setLeader2Point(const AcGePoint3d &ldr2Pt) (defined in AcDbArcDimension) | AcDbArcDimension |
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXLine1Point(const AcGePoint3d &xLine1Pt) (defined in AcDbArcDimension) | AcDbArcDimension |
setXLine2Point(const AcGePoint3d &xLine2Pt) (defined in AcDbArcDimension) | AcDbArcDimension |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xLine1Point() const (defined in AcDbArcDimension) | AcDbArcDimension |
xLine2Point() const (defined in AcDbArcDimension) | AcDbArcDimension |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbArcDimension() (defined in AcDbArcDimension) | AcDbArcDimension |
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAttribute Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbAttribute Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAttribute:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbAttribute)
AcDbAttribute (const AcGePoint3d &position, const ACHAR *text, const ACHAR *tag, AcDbObjectId style=AcDbObjectId::kNull)
Acad::ErrorStatus | convertIntoMTextAttribute (Adesk::Boolean val=Adesk::kTrue)
Adesk::UInt16 | fieldLength () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
AcDbMText * | getMTextAttribute () const
const AcDbMText * | getMTextAttributeConst () const
Adesk::Boolean | isConstant () const
Adesk::Boolean | isInvisible () const
bool | isMTextAttribute () const
Adesk::Boolean | isPreset () const
bool | isReallyLocked () const
Adesk::Boolean | isVerifiable () const
bool | lockPositionInBlock () const
Acad::ErrorStatus | setAttributeFromBlock (const AcGeMatrix3d &blkXform)
Acad::ErrorStatus | setAttributeFromBlock (const AcDbAttributeDefinition *pAttdef, const AcGeMatrix3d &blkXform)
Acad::ErrorStatus | setFieldLength (Adesk::UInt16)
Acad::ErrorStatus | setInvisible (Adesk::Boolean)
Acad::ErrorStatus | setLockPositionInBlock (bool bValue)
Acad::ErrorStatus | setMTextAttribute (AcDbMText *)
Acad::ErrorStatus | setTag (const ACHAR *newTag)
ACHAR * | tag () const
const ACHAR * | tagConst () const
Acad::ErrorStatus | updateMTextAttribute ()
- Public Member Functions inherited from AcDbText
ACDB_DECLARE_MEMBERS (AcDbText)
AcDbText (const AcGePoint3d &position, const ACHAR *text, AcDbObjectId style=AcDbObjectId::kNull, double height=0, double rotation=0)
virtual Acad::ErrorStatus | adjustAlignment (const AcDbDatabase *pDb=NULL)
AcGePoint3d | alignmentPoint () const
virtual bool | castShadows () const
Acad::ErrorStatus | convertFieldToText ()
int | correctSpelling ()
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | height () const
AcDb::TextHorzMode | horizontalMode () const
Adesk::Boolean | isDefaultAlignment () const
Adesk::Boolean | isMirroredInX () const
Adesk::Boolean | isMirroredInY () const
virtual Adesk::Boolean | isPlanar () const
Acad::ErrorStatus | mirrorInX (Adesk::Boolean)
Acad::ErrorStatus | mirrorInY (Adesk::Boolean)
AcGeVector3d | normal () const
double | oblique () const
AcGePoint3d | position () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
double | rotation () const
Acad::ErrorStatus | setAlignmentPoint (const AcGePoint3d &)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
Acad::ErrorStatus | setHeight (double)
Acad::ErrorStatus | setHorizontalMode (AcDb::TextHorzMode)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setOblique (double)
Acad::ErrorStatus | setPosition (const AcGePoint3d &)
Acad::ErrorStatus | setRotation (double)
Acad::ErrorStatus | setTextString (const ACHAR *)
Acad::ErrorStatus | setTextStyle (AcDbObjectId)
Acad::ErrorStatus | setThickness (double)
Acad::ErrorStatus | setVerticalMode (AcDb::TextVertMode)
Acad::ErrorStatus | setWidthFactor (double)
ACHAR * | textString () const
const ACHAR * | textStringConst () const
AcDbObjectId | textStyle () const
double | thickness () const
AcDb::TextVertMode | verticalMode () const
double | widthFactor () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAttribute Member List

This is the complete list of members for AcDbAttribute, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbAttribute) (defined in AcDbAttribute) | AcDbAttribute |
ACDB_DECLARE_MEMBERS(AcDbText) (defined in AcDbText) | AcDbText |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbAttribute() (defined in AcDbAttribute) | AcDbAttribute |
AcDbAttribute(const AcGePoint3d &position, const ACHAR *text, const ACHAR *tag, AcDbObjectId style=AcDbObjectId::kNull) (defined in AcDbAttribute) | AcDbAttribute |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbText() (defined in AcDbText) | AcDbText |
AcDbText(const AcGePoint3d &position, const ACHAR *text, AcDbObjectId style=AcDbObjectId::kNull, double height=0, double rotation=0) (defined in AcDbText) | AcDbText |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
adjustAlignment(const AcDbDatabase *pDb=NULL) (defined in AcDbText) | AcDbText | virtual
alignmentPoint() const (defined in AcDbText) | AcDbText |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbText) | AcDbText | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertFieldToText() (defined in AcDbText) | AcDbText |
convertIntoMTextAttribute(Adesk::Boolean val=Adesk::kTrue) (defined in AcDbAttribute) | AcDbAttribute |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
correctSpelling() (defined in AcDbText) | AcDbText |
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldLength() const (defined in AcDbAttribute) | AcDbAttribute |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbAttribute) | AcDbAttribute | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getMTextAttribute() const (defined in AcDbAttribute) | AcDbAttribute |
getMTextAttributeConst() const (defined in AcDbAttribute) | AcDbAttribute |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbText) | AcDbText | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height() const (defined in AcDbText) | AcDbText |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalMode() const (defined in AcDbText) | AcDbText |
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isConstant() const (defined in AcDbAttribute) | AcDbAttribute |
isDefaultAlignment() const (defined in AcDbText) | AcDbText |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isInvisible() const (defined in AcDbAttribute) | AcDbAttribute |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isMirroredInX() const (defined in AcDbText) | AcDbText |
isMirroredInY() const (defined in AcDbText) | AcDbText |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isMTextAttribute() const (defined in AcDbAttribute) | AcDbAttribute |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbText) | AcDbText | inlinevirtual
isPreset() const (defined in AcDbAttribute) | AcDbAttribute |
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isReallyLocked() const (defined in AcDbAttribute) | AcDbAttribute |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isVerifiable() const (defined in AcDbAttribute) | AcDbAttribute |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
lockPositionInBlock() const (defined in AcDbAttribute) | AcDbAttribute |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
mirrorInX(Adesk::Boolean) (defined in AcDbText) | AcDbText |
mirrorInY(Adesk::Boolean) (defined in AcDbText) | AcDbText |
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbText) | AcDbText |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
oblique() const (defined in AcDbText) | AcDbText |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbText) | AcDbText |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbText) | AcDbText | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbText) | AcDbText | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbText) | AcDbText | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbText) | AcDbText | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const (defined in AcDbText) | AcDbText |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAlignmentPoint(const AcGePoint3d &) (defined in AcDbText) | AcDbText |
setAttributeFromBlock(const AcGeMatrix3d &blkXform) (defined in AcDbAttribute) | AcDbAttribute |
setAttributeFromBlock(const AcDbAttributeDefinition *pAttdef, const AcGeMatrix3d &blkXform) (defined in AcDbAttribute) | AcDbAttribute |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbText) | AcDbText | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbText) | AcDbText | virtual
setFieldLength(Adesk::UInt16) (defined in AcDbAttribute) | AcDbAttribute |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double) (defined in AcDbText) | AcDbText |
setHorizontalMode(AcDb::TextHorzMode) (defined in AcDbText) | AcDbText |
setInvisible(Adesk::Boolean) (defined in AcDbAttribute) | AcDbAttribute |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLockPositionInBlock(bool bValue) (defined in AcDbAttribute) | AcDbAttribute |
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMTextAttribute(AcDbMText *) (defined in AcDbAttribute) | AcDbAttribute |
setNormal(const AcGeVector3d &) (defined in AcDbText) | AcDbText |
setOblique(double) (defined in AcDbText) | AcDbText |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbText) | AcDbText |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double) (defined in AcDbText) | AcDbText |
setTag(const ACHAR *newTag) (defined in AcDbAttribute) | AcDbAttribute |
setTextString(const ACHAR *) (defined in AcDbText) | AcDbText |
setTextStyle(AcDbObjectId) (defined in AcDbText) | AcDbText |
setThickness(double) (defined in AcDbText) | AcDbText |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVerticalMode(AcDb::TextVertMode) (defined in AcDbText) | AcDbText |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWidthFactor(double) (defined in AcDbText) | AcDbText |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
tag() const (defined in AcDbAttribute) | AcDbAttribute |
tagConst() const (defined in AcDbAttribute) | AcDbAttribute |
textString() const (defined in AcDbText) | AcDbText |
textStringConst() const (defined in AcDbText) | AcDbText |
textStyle() const (defined in AcDbText) | AcDbText |
thickness() const (defined in AcDbText) | AcDbText |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
updateMTextAttribute() (defined in AcDbAttribute) | AcDbAttribute |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
verticalMode() const (defined in AcDbText) | AcDbText |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
widthFactor() const (defined in AcDbText) | AcDbText |
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbAttribute() (defined in AcDbAttribute) | AcDbAttribute |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbText() (defined in AcDbText) | AcDbText |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAttributeDefinition Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbAttributeDefinition Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAttributeDefinition:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbAttributeDefinition)
AcDbAttributeDefinition (const AcGePoint3d &position, const ACHAR *text, const ACHAR *tag, const ACHAR *prompt, AcDbObjectId style=AcDbObjectId::kNull)
virtual Acad::ErrorStatus | adjustAlignment (const AcDbDatabase *pDb=NULL)
Acad::ErrorStatus | convertIntoMTextAttributeDefinition (Adesk::Boolean val=Adesk::kTrue)
Adesk::UInt16 | fieldLength () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
AcDbMText * | getMTextAttributeDefinition () const
const AcDbMText * | getMTextAttributeDefinitionConst () const
Adesk::Boolean | isConstant () const
Adesk::Boolean | isInvisible () const
bool | isMTextAttributeDefinition () const
Adesk::Boolean | isPreset () const
Adesk::Boolean | isVerifiable () const
bool | lockPositionInBlock () const
ACHAR * | prompt () const
const ACHAR * | promptConst () const
Acad::ErrorStatus | setConstant (Adesk::Boolean)
Acad::ErrorStatus | setFieldLength (Adesk::UInt16)
Acad::ErrorStatus | setInvisible (Adesk::Boolean)
Acad::ErrorStatus | setLockPositionInBlock (bool bValue)
Acad::ErrorStatus | setMTextAttributeDefinition (AcDbMText *)
Acad::ErrorStatus | setPreset (Adesk::Boolean)
Acad::ErrorStatus | setPrompt (const ACHAR *)
Acad::ErrorStatus | setTag (const ACHAR *)
Acad::ErrorStatus | setVerifiable (Adesk::Boolean)
ACHAR * | tag () const
const ACHAR * | tagConst () const
Acad::ErrorStatus | updateMTextAttributeDefinition ()
- Public Member Functions inherited from AcDbText
ACDB_DECLARE_MEMBERS (AcDbText)
AcDbText (const AcGePoint3d &position, const ACHAR *text, AcDbObjectId style=AcDbObjectId::kNull, double height=0, double rotation=0)
AcGePoint3d | alignmentPoint () const
virtual bool | castShadows () const
Acad::ErrorStatus | convertFieldToText ()
int | correctSpelling ()
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | height () const
AcDb::TextHorzMode | horizontalMode () const
Adesk::Boolean | isDefaultAlignment () const
Adesk::Boolean | isMirroredInX () const
Adesk::Boolean | isMirroredInY () const
virtual Adesk::Boolean | isPlanar () const
Acad::ErrorStatus | mirrorInX (Adesk::Boolean)
Acad::ErrorStatus | mirrorInY (Adesk::Boolean)
AcGeVector3d | normal () const
double | oblique () const
AcGePoint3d | position () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
double | rotation () const
Acad::ErrorStatus | setAlignmentPoint (const AcGePoint3d &)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
Acad::ErrorStatus | setHeight (double)
Acad::ErrorStatus | setHorizontalMode (AcDb::TextHorzMode)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setOblique (double)
Acad::ErrorStatus | setPosition (const AcGePoint3d &)
Acad::ErrorStatus | setRotation (double)
Acad::ErrorStatus | setTextString (const ACHAR *)
Acad::ErrorStatus | setTextStyle (AcDbObjectId)
Acad::ErrorStatus | setThickness (double)
Acad::ErrorStatus | setVerticalMode (AcDb::TextVertMode)
Acad::ErrorStatus | setWidthFactor (double)
ACHAR * | textString () const
const ACHAR * | textStringConst () const
AcDbObjectId | textStyle () const
double | thickness () const
AcDb::TextVertMode | verticalMode () const
double | widthFactor () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAttributeDefinition Member List

This is the complete list of members for AcDbAttributeDefinition, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbAttributeDefinition) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
ACDB_DECLARE_MEMBERS(AcDbText) (defined in AcDbText) | AcDbText |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbAttributeDefinition() (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
AcDbAttributeDefinition(const AcGePoint3d &position, const ACHAR *text, const ACHAR *tag, const ACHAR *prompt, AcDbObjectId style=AcDbObjectId::kNull) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbText() (defined in AcDbText) | AcDbText |
AcDbText(const AcGePoint3d &position, const ACHAR *text, AcDbObjectId style=AcDbObjectId::kNull, double height=0, double rotation=0) (defined in AcDbText) | AcDbText |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
adjustAlignment(const AcDbDatabase *pDb=NULL) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition | virtual
alignmentPoint() const (defined in AcDbText) | AcDbText |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbText) | AcDbText | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertFieldToText() (defined in AcDbText) | AcDbText |
convertIntoMTextAttributeDefinition(Adesk::Boolean val=Adesk::kTrue) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
correctSpelling() (defined in AcDbText) | AcDbText |
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldLength() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getMTextAttributeDefinition() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
getMTextAttributeDefinitionConst() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbText) | AcDbText | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height() const (defined in AcDbText) | AcDbText |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalMode() const (defined in AcDbText) | AcDbText |
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isConstant() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
isDefaultAlignment() const (defined in AcDbText) | AcDbText |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isInvisible() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isMirroredInX() const (defined in AcDbText) | AcDbText |
isMirroredInY() const (defined in AcDbText) | AcDbText |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isMTextAttributeDefinition() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbText) | AcDbText | inlinevirtual
isPreset() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isVerifiable() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
lockPositionInBlock() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
mirrorInX(Adesk::Boolean) (defined in AcDbText) | AcDbText |
mirrorInY(Adesk::Boolean) (defined in AcDbText) | AcDbText |
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbText) | AcDbText |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
oblique() const (defined in AcDbText) | AcDbText |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbText) | AcDbText |
prompt() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
promptConst() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbText) | AcDbText | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbText) | AcDbText | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbText) | AcDbText | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbText) | AcDbText | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const (defined in AcDbText) | AcDbText |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAlignmentPoint(const AcGePoint3d &) (defined in AcDbText) | AcDbText |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbText) | AcDbText | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setConstant(Adesk::Boolean) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbText) | AcDbText | virtual
setFieldLength(Adesk::UInt16) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double) (defined in AcDbText) | AcDbText |
setHorizontalMode(AcDb::TextHorzMode) (defined in AcDbText) | AcDbText |
setInvisible(Adesk::Boolean) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLockPositionInBlock(bool bValue) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMTextAttributeDefinition(AcDbMText *) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
setNormal(const AcGeVector3d &) (defined in AcDbText) | AcDbText |
setOblique(double) (defined in AcDbText) | AcDbText |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbText) | AcDbText |
setPreset(Adesk::Boolean) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
setPrompt(const ACHAR *) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double) (defined in AcDbText) | AcDbText |
setTag(const ACHAR *) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
setTextString(const ACHAR *) (defined in AcDbText) | AcDbText |
setTextStyle(AcDbObjectId) (defined in AcDbText) | AcDbText |
setThickness(double) (defined in AcDbText) | AcDbText |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVerifiable(Adesk::Boolean) (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
setVerticalMode(AcDb::TextVertMode) (defined in AcDbText) | AcDbText |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWidthFactor(double) (defined in AcDbText) | AcDbText |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
tag() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
tagConst() const (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
textString() const (defined in AcDbText) | AcDbText |
textStringConst() const (defined in AcDbText) | AcDbText |
textStyle() const (defined in AcDbText) | AcDbText |
thickness() const (defined in AcDbText) | AcDbText |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
updateMTextAttributeDefinition() (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
verticalMode() const (defined in AcDbText) | AcDbText |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
widthFactor() const (defined in AcDbText) | AcDbText |
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbAttributeDefinition() (defined in AcDbAttributeDefinition) | AcDbAttributeDefinition |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbText() (defined in AcDbText) | AcDbText |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbAuditInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes | List of all members
AcDbAuditInfo Class Reference
AcDb Classes

Public Types

enum AuditPass { PASS1 = 1, PASS2 = 2 }

Public Member Functions

AuditPass | auditPass (void) const
void | errorsFixed (int count)
void | errorsFound (int count)
Acad::ErrorStatus | fetchObject (AcDbObjectId originalObjId, AcDbObjectId &newObjId, AcRxClass *pObjClass, bool uneraseIfPossible=false, bool createIfNotFound=true, bool externalDbOk=false)
bool | fixErrors (void) const
void | incNumEntities ()
int | numEntities ()
int | numErrors () const
int | numFixes (void) const
void | printError (const ACHAR *name, const ACHAR *value, const ACHAR *validation, const ACHAR *defaultValue)
void | printError (const AcDbObject *pObj, const ACHAR *value, const ACHAR *validation, const ACHAR *defaultValue)
void | printNumEntities (const ACHAR *msg)
Acad::ErrorStatus | registerObject (AcDbHandle handle, bool objIsValid, AcRxClass *pObjClass)
void | requestRegen ()
void | resetNumEntities ()
Acad::ErrorStatus | updateObject (AcDbHandle handle, bool setFileObjIsValid, bool setNewObjIsValid, bool setFileObjClass, bool setNewObjClass, bool setNewObjId, bool fileObjIsValid, bool newObjIsValid, AcRxClass *pFileObjClass, AcRxClass *pNewObjClass, AcDbObjectId newObjId)

Public Attributes

friend | AcDbAuditImp
friend | AcDbImpAuditInfo

Member Function Documentation

Acad::ErrorStatus AcDbAuditInfo::registerObject | ( | AcDbHandle | handle,
 |  | bool | objIsValid,
 |  | AcRxClass * | pObjClass
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbAuditInfo::updateObject | ( | AcDbHandle | handle,
 |  | bool | setFileObjIsValid,
 |  | bool | setNewObjIsValid,
 |  | bool | setFileObjClass,
 |  | bool | setNewObjClass,
 |  | bool | setNewObjId,
 |  | bool | fileObjIsValid,
 |  | bool | newObjIsValid,
 |  | AcRxClass * | pFileObjClass,
 |  | AcRxClass * | pNewObjClass,
 |  | AcDbObjectId | newObjId
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbaudita.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAuditInfo Member List

This is the complete list of members for AcDbAuditInfo, including all inherited members.

AcDbAuditImp (defined in AcDbAuditInfo) | AcDbAuditInfo
AcDbAuditInfo() (defined in AcDbAuditInfo) | AcDbAuditInfo
AcDbImpAuditInfo (defined in AcDbAuditInfo) | AcDbAuditInfo
AuditPass enum name (defined in AcDbAuditInfo) | AcDbAuditInfo
auditPass(void) const (defined in AcDbAuditInfo) | AcDbAuditInfo
errorsFixed(int count) (defined in AcDbAuditInfo) | AcDbAuditInfo
errorsFound(int count) (defined in AcDbAuditInfo) | AcDbAuditInfo
fetchObject(AcDbObjectId originalObjId, AcDbObjectId &newObjId, AcRxClass *pObjClass, bool uneraseIfPossible=false, bool createIfNotFound=true, bool externalDbOk=false) (defined in AcDbAuditInfo) | AcDbAuditInfo
fixErrors(void) const (defined in AcDbAuditInfo) | AcDbAuditInfo
incNumEntities() (defined in AcDbAuditInfo) | AcDbAuditInfo
numEntities() (defined in AcDbAuditInfo) | AcDbAuditInfo
numErrors() const (defined in AcDbAuditInfo) | AcDbAuditInfo
numFixes(void) const (defined in AcDbAuditInfo) | AcDbAuditInfo
PASS1 enum value (defined in AcDbAuditInfo) | AcDbAuditInfo
PASS2 enum value (defined in AcDbAuditInfo) | AcDbAuditInfo
printError(const ACHAR *name, const ACHAR *value, const ACHAR *validation, const ACHAR *defaultValue) (defined in AcDbAuditInfo) | AcDbAuditInfo
printError(const AcDbObject *pObj, const ACHAR *value, const ACHAR *validation, const ACHAR *defaultValue) (defined in AcDbAuditInfo) | AcDbAuditInfo
printNumEntities(const ACHAR *msg) (defined in AcDbAuditInfo) | AcDbAuditInfo
registerObject(AcDbHandle handle, bool objIsValid, AcRxClass *pObjClass) | AcDbAuditInfo
requestRegen() (defined in AcDbAuditInfo) | AcDbAuditInfo
resetNumEntities() (defined in AcDbAuditInfo) | AcDbAuditInfo
updateObject(AcDbHandle handle, bool setFileObjIsValid, bool setNewObjIsValid, bool setFileObjClass, bool setNewObjClass, bool setNewObjId, bool fileObjIsValid, bool newObjIsValid, AcRxClass *pFileObjClass, AcRxClass *pNewObjClass, AcDbObjectId newObjId) | AcDbAuditInfo
~AcDbAuditInfo() (defined in AcDbAuditInfo) | AcDbAuditInfo


ZRX API Reference: AcDbAuditRecreatePE Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbAuditRecreatePE Class Reference
AcDb Classes
+ Inheritance diagram for AcDbAuditRecreatePE:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbAuditRecreatePE)
virtual bool | redirect (AcDbObjectId &newObjId, AcDbObjectId originalObjId, AcRxClass *pObjClass, AcDbDatabase *pDb, AcDbAuditInfo *pAuditInfo)
virtual bool | replace (AcDbObject *&pNewObj, AcDbObjectId originalObjId, AcRxClass *pObjClass, AcDbDatabase *pDb, AcDbAuditInfo *pAuditInfo)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbAuditRecreate.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbAuditRecreatePE Member List

This is the complete list of members for AcDbAuditRecreatePE, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbAuditRecreatePE) (defined in AcDbAuditRecreatePE) | AcDbAuditRecreatePE |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
redirect(AcDbObjectId &newObjId, AcDbObjectId originalObjId, AcRxClass *pObjClass, AcDbDatabase *pDb, AcDbAuditInfo *pAuditInfo) (defined in AcDbAuditRecreatePE) | AcDbAuditRecreatePE | inlinevirtual
replace(AcDbObject *&pNewObj, AcDbObjectId originalObjId, AcRxClass *pObjClass, AcDbDatabase *pDb, AcDbAuditInfo *pAuditInfo) (defined in AcDbAuditRecreatePE) | AcDbAuditRecreatePE | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBackground Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcDbBackground Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBackground:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbBackground)
virtual AcGiDrawable * | drawable ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcDbBackground (AcDbImpBackground *pImp)
AcDbImpBackground * imp () const

Friends

class AcDbImpBackground

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbbackground.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBackground Member List

This is the complete list of members for AcDbBackground, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBackground(AcDbImpBackground *pImp) (defined in AcDbBackground) | AcDbBackground | protected
AcDbImpBackground (defined in AcDbBackground) | AcDbBackground | friend
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbBackground) (defined in AcDbBackground) | AcDbBackground |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbBackground) | AcDbBackground | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imp() const (defined in AcDbBackground) | AcDbBackground | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBackground() (defined in AcDbBackground) | AcDbBackground | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBlockBegin Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbBlockBegin Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBlockBegin:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbBlockBegin)
virtual bool | castShadows () const
virtual bool | receiveShadows () const
virtual void | setCastShadows (bool newVal)
virtual void | setReceiveShadows (bool newVal)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockBegin Member List

This is the complete list of members for AcDbBlockBegin, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbBlockBegin) (defined in AcDbBlockBegin) | AcDbBlockBegin |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBlockBegin() (defined in AcDbBlockBegin) | AcDbBlockBegin |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbBlockBegin) | AcDbBlockBegin | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbBlockBegin) | AcDbBlockBegin | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbBlockBegin) | AcDbBlockBegin | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbBlockBegin) | AcDbBlockBegin | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBlockBegin() (defined in AcDbBlockBegin) | AcDbBlockBegin |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBlockChangeIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbBlockChangeIterator Class Reference
AcDb Classes

Public Member Functions

void | clearProcessedFlags ()
Acad::ErrorStatus | curIdInfo (AcDbObjectId &id, Adesk::UInt8 &flags, Adesk::ULongPtr &data) const
bool | done ()
AcDbObjectId | id () const
void | next ()
Acad::ErrorStatus | setCurIdInfo (Adesk::UInt8 flags, Adesk::ULongPtr data)
void | start ()
AcDbIndexUpdateData * | updateData () const
The documentation for this class was generated from the following file:
  • dbindex.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockChangeIterator Member List

This is the complete list of members for AcDbBlockChangeIterator, including all inherited members.

clearProcessedFlags() (defined in AcDbBlockChangeIterator) | AcDbBlockChangeIterator
curIdInfo(AcDbObjectId &id, Adesk::UInt8 &flags, Adesk::ULongPtr &data) const (defined in AcDbBlockChangeIterator) | AcDbBlockChangeIterator
done() (defined in AcDbBlockChangeIterator) | AcDbBlockChangeIterator
id() const (defined in AcDbBlockChangeIterator) | AcDbBlockChangeIterator
next() (defined in AcDbBlockChangeIterator) | AcDbBlockChangeIterator
setCurIdInfo(Adesk::UInt8 flags, Adesk::ULongPtr data) (defined in AcDbBlockChangeIterator) | AcDbBlockChangeIterator
start() (defined in AcDbBlockChangeIterator) | AcDbBlockChangeIterator
updateData() const (defined in AcDbBlockChangeIterator) | AcDbBlockChangeIterator


ZRX API Reference: AcDbBlockEnd Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbBlockEnd Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBlockEnd:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbBlockEnd)
virtual bool | castShadows () const
virtual bool | receiveShadows () const
virtual void | setCastShadows (bool newVal)
virtual void | setReceiveShadows (bool newVal)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockEnd Member List

This is the complete list of members for AcDbBlockEnd, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbBlockEnd) (defined in AcDbBlockEnd) | AcDbBlockEnd |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBlockEnd() (defined in AcDbBlockEnd) | AcDbBlockEnd |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbBlockEnd) | AcDbBlockEnd | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbBlockEnd) | AcDbBlockEnd | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbBlockEnd) | AcDbBlockEnd | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbBlockEnd) | AcDbBlockEnd | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBlockEnd() (defined in AcDbBlockEnd) | AcDbBlockEnd |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBlockInsertionPoints Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbBlockInsertionPoints Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBlockInsertionPoints:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbBlockInsertionPoints)
virtual Acad::ErrorStatus | getInsertionPoints (const AcDbBlockTableRecord *pBlock, const AcDbBlockReference *pBlkRef, AcGePoint3dArray &insPts, AcGeVector3dArray &alignmentDirections)=0
- Public Member Functions inherited from AcRxProtocolReactor
ACRX_DECLARE_MEMBERS (AcRxProtocolReactor)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbappgrip.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockInsertionPoints Member List

This is the complete list of members for AcDbBlockInsertionPoints, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbBlockInsertionPoints) (defined in AcDbBlockInsertionPoints) | AcDbBlockInsertionPoints |
ACRX_DECLARE_MEMBERS(AcRxProtocolReactor) (defined in AcRxProtocolReactor) | AcRxProtocolReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getInsertionPoints(const AcDbBlockTableRecord *pBlock, const AcDbBlockReference *pBlkRef, AcGePoint3dArray &insPts, AcGeVector3dArray &alignmentDirections)=0 (defined in AcDbBlockInsertionPoints) | AcDbBlockInsertionPoints | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBlockReference Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbBlockReference Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBlockReference:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbBlockReference)
AcDbBlockReference (const AcGePoint3d &position, AcDbObjectId blockTableRec)
Acad::ErrorStatus | appendAttribute (AcDbAttribute *)
Acad::ErrorStatus | appendAttribute (AcDbObjectId &, AcDbAttribute *)
AcDbObjectIterator * | attributeIterator () const
AcDbObjectId | blockTableRecord () const
AcGeMatrix3d | blockTransform () const
virtual Acad::ErrorStatus | explodeToOwnerSpace () const
Acad::ErrorStatus | geomExtentsBestFit (AcDbExtents &extents, const AcGeMatrix3d &parentXform=AcGeMatrix3d::kIdentity) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const
virtual Adesk::Boolean | isPlanar () const
AcGeMatrix3d | nonAnnotationBlockTransform () const
AcGeScale3d | nonAnnotationScaleFactors () const
AcGeVector3d | normal () const
Acad::ErrorStatus | openAttribute (AcDbAttribute *&, AcDbObjectId, AcDb::OpenMode, bool openErasedOne=false)
Acad::ErrorStatus | openSequenceEnd (AcDbSequenceEnd *&, AcDb::OpenMode)
AcGePoint3d | position () const
double | rotation () const
AcGeScale3d | scaleFactors () const
virtual Acad::ErrorStatus | setBlockTableRecord (AcDbObjectId)
virtual Acad::ErrorStatus | setBlockTransform (const AcGeMatrix3d &)
virtual Acad::ErrorStatus | setNormal (const AcGeVector3d &newVal)
virtual Acad::ErrorStatus | setPosition (const AcGePoint3d &)
virtual Acad::ErrorStatus | setRotation (double newVal)
virtual Acad::ErrorStatus | setScaleFactors (const AcGeScale3d &scale)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &) const
virtual Adesk::Boolean | treatAsAcDbBlockRefForExplode () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockReference Member List

This is the complete list of members for AcDbBlockReference, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbBlockReference) (defined in AcDbBlockReference) | AcDbBlockReference |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBlockReference() (defined in AcDbBlockReference) | AcDbBlockReference |
AcDbBlockReference(const AcGePoint3d &position, AcDbObjectId blockTableRec) (defined in AcDbBlockReference) | AcDbBlockReference |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
appendAttribute(AcDbAttribute *) (defined in AcDbBlockReference) | AcDbBlockReference |
appendAttribute(AcDbObjectId &, AcDbAttribute *) (defined in AcDbBlockReference) | AcDbBlockReference |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
attributeIterator() const (defined in AcDbBlockReference) | AcDbBlockReference |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTableRecord() const (defined in AcDbBlockReference) | AcDbBlockReference |
blockTransform() const (defined in AcDbBlockReference) | AcDbBlockReference |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
explodeToOwnerSpace() const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
geomExtentsBestFit(AcDbExtents &extents, const AcGeMatrix3d &parentXform=AcGeMatrix3d::kIdentity) const (defined in AcDbBlockReference) | AcDbBlockReference |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbBlockReference) | AcDbBlockReference | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
nonAnnotationBlockTransform() const (defined in AcDbBlockReference) | AcDbBlockReference |
nonAnnotationScaleFactors() const (defined in AcDbBlockReference) | AcDbBlockReference |
normal() const (defined in AcDbBlockReference) | AcDbBlockReference |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openAttribute(AcDbAttribute *&, AcDbObjectId, AcDb::OpenMode, bool openErasedOne=false) (defined in AcDbBlockReference) | AcDbBlockReference |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
openSequenceEnd(AcDbSequenceEnd *&, AcDb::OpenMode) (defined in AcDbBlockReference) | AcDbBlockReference |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbBlockReference) | AcDbBlockReference |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const (defined in AcDbBlockReference) | AcDbBlockReference |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
scaleFactors() const (defined in AcDbBlockReference) | AcDbBlockReference |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockTableRecord(AcDbObjectId) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setBlockTransform(const AcGeMatrix3d &) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &newVal) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double newVal) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setScaleFactors(const AcGeScale3d &scale) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
treatAsAcDbBlockRefForExplode() const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBlockReference() (defined in AcDbBlockReference) | AcDbBlockReference |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBlockReferenceIdIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbBlockReferenceIdIterator Class Reference
AcDb Classes

Public Member Functions

bool | done () const
Acad::ErrorStatus | getBlockReference (AcDbBlockReference *&pBlkRef, AcDb::OpenMode openMode, bool openErasedEntity=false) const
Acad::ErrorStatus | getBlockReferenceId (AcDbObjectId &id) const
Acad::ErrorStatus | getDatabase (AcDbDatabase *&pDb) const
Acad::ErrorStatus | seek (AcDbObjectId id)
void | start ()
void | step ()

Friends

class AcDbBlockTableRecord
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockReferenceIdIterator Member List

This is the complete list of members for AcDbBlockReferenceIdIterator, including all inherited members.

AcDbBlockTableRecord (defined in AcDbBlockReferenceIdIterator) | AcDbBlockReferenceIdIterator | friend
done() const (defined in AcDbBlockReferenceIdIterator) | AcDbBlockReferenceIdIterator | inline
getBlockReference(AcDbBlockReference *&pBlkRef, AcDb::OpenMode openMode, bool openErasedEntity=false) const (defined in AcDbBlockReferenceIdIterator) | AcDbBlockReferenceIdIterator |
getBlockReferenceId(AcDbObjectId &id) const (defined in AcDbBlockReferenceIdIterator) | AcDbBlockReferenceIdIterator |
getDatabase(AcDbDatabase *&pDb) const (defined in AcDbBlockReferenceIdIterator) | AcDbBlockReferenceIdIterator |
seek(AcDbObjectId id) (defined in AcDbBlockReferenceIdIterator) | AcDbBlockReferenceIdIterator |
start() (defined in AcDbBlockReferenceIdIterator) | AcDbBlockReferenceIdIterator | inline
step() (defined in AcDbBlockReferenceIdIterator) | AcDbBlockReferenceIdIterator | inline
~AcDbBlockReferenceIdIterator() (defined in AcDbBlockReferenceIdIterator) | AcDbBlockReferenceIdIterator |


ZRX API Reference: AcDbBlockTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbBlockTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBlockTable:

Public Types

typedef AcDbBlockTableRecord | RecordType
- Public Types inherited from AcDbSymbolTable
typedef AcDbSymbolTableRecord | RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbBlockTable)
Acad::ErrorStatus | add (AcDbBlockTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbBlockTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbBlockTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbBlockTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockTable Member List

This is the complete list of members for AcDbBlockTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbBlockTable) (defined in AcDbBlockTable) | AcDbBlockTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBlockTable() (defined in AcDbBlockTable) | AcDbBlockTable |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbBlockTableRecord *pRecord) (defined in AcDbBlockTable) | AcDbBlockTable |
add(AcDbObjectId &recordId, AcDbBlockTableRecord *pRecord) (defined in AcDbBlockTable) | AcDbBlockTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbBlockTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbBlockTable) | AcDbBlockTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const (defined in AcDbBlockTable) | AcDbBlockTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbBlockTable) | AcDbBlockTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbBlockTable) | AcDbBlockTable |
has(AcDbObjectId id) const (defined in AcDbBlockTable) | AcDbBlockTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbBlockTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbBlockTable) | AcDbBlockTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbBlockTable) | AcDbBlockTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBlockTable() (defined in AcDbBlockTable) | AcDbBlockTable | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBlockTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbBlockTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBlockTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbBlockTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbBlockTableRecord *pRecord)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbBlockTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockTableIterator Member List

This is the complete list of members for AcDbBlockTableIterator, including all inherited members.

AcDbBlockTable (defined in AcDbBlockTableIterator) | AcDbBlockTableIterator | friend
AcDbBlockTableIterator() (defined in AcDbBlockTableIterator) | AcDbBlockTableIterator | protected
AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbBlockTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbBlockTableIterator) | AcDbBlockTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbBlockTableIterator) | AcDbBlockTableIterator |
seek(const AcDbBlockTableRecord *pRecord) (defined in AcDbBlockTableIterator) | AcDbBlockTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbBlockTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
AcDbBlockTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBlockTableRecord:

Public Types

enum | BlockScaling { kAny, kUniform }
typedef AcArray< Adesk::UInt8 > | PreviewIcon
typedef AcDbBlockTable | TableType
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable | TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbBlockTableRecord)
Acad::ErrorStatus | addAnnoScalestoBlkRefs (const bool bScale=false)
Acad::ErrorStatus | appendAcDbEntity (AcDbEntity *pEntity)
Acad::ErrorStatus | appendAcDbEntity (AcDbObjectId &pOutputId, AcDbEntity *pEntity)
virtual Acad::ErrorStatus | assumeOwnershipOf (AcArray< AcDbObjectId > entitiesToMove)
AcDb::UnitsValue | blockInsertUnits () const
AcDbBlockTableRecord::BlockScaling | blockScaling () const
Acad::ErrorStatus | comments (ACHAR *&pString) const
Acad::ErrorStatus | comments (const ACHAR *&pString) const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
bool | explodable () const
Acad::ErrorStatus | getBlockReferenceIds (AcDbObjectIdArray &ids, bool bDirectOnly=true, bool bForceValidity=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getErasedBlockReferenceIds (AcDbObjectIdArray &)
AcDbObjectId | getLayoutId () const
Acad::ErrorStatus | getPreviewIcon (PreviewIcon &previewIcon) const
Acad::ErrorStatus | getSortentsTable (AcDbSortentsTable *&pSortents, AcDb::OpenMode openMode, bool createIfNecessary=false)
AcGsNode * | gsNode () const
bool | hasAttributeDefinitions () const
bool | hasPreviewIcon () const
bool | isAnonymous () const
bool | isFromExternalReference () const
bool | isFromOverlayReference () const
bool | isLayout () const
bool | isUnloaded () const
Acad::ErrorStatus | newBlockReferenceIdIterator (AcDbBlockReferenceIdIterator *&pIter) const
Acad::ErrorStatus | newIterator (AcDbBlockTableRecordIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
Acad::ErrorStatus | openBlockBegin (AcDbBlockBegin *&pBlockBegin, AcDb::OpenMode openMode)
Acad::ErrorStatus | openBlockEnd (AcDbBlockEnd *&pBlockEnd, AcDb::OpenMode openMode)
AcGePoint3d | origin () const
Acad::ErrorStatus | pathName (ACHAR *&pPath) const
Acad::ErrorStatus | pathName (const ACHAR *&pPath) const
Acad::ErrorStatus | postProcessAnnotativeBTR (int &stripCnt, const bool bqueryOnly=false, const bool bScale=true)
Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBlockInsertUnits (AcDb::UnitsValue insunits)
Acad::ErrorStatus | setBlockScaling (AcDbBlockTableRecord::BlockScaling blockScaling)
Acad::ErrorStatus | setComments (const ACHAR *pString)
Acad::ErrorStatus | setExplodable (bool bExplodable)
void | setGsNode (AcGsNode *pNode)
Acad::ErrorStatus | setIsUnloaded (bool isUnloaded)
Acad::ErrorStatus | setLayoutId (AcDbObjectId)
Acad::ErrorStatus | setOrigin (const AcGePoint3d &pt)
Acad::ErrorStatus | setPathName (const ACHAR *pathStr)
Acad::ErrorStatus | setPreviewIcon (const PreviewIcon &previewIcon)
void | viewportDraw (AcGiViewportDraw *pVd)
Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
AcDbDatabase * | xrefDatabase (bool incUnres=false) const
AcDb::XrefStatus | xrefStatus () const
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

virtual Acad::ErrorStatus subGetClassID (CLSID *pClsid) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockTableRecord Member List

This is the complete list of members for AcDbBlockTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbBlockTableRecord) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBlockTableRecord() (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addAnnoScalestoBlkRefs(const bool bScale=false) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
appendAcDbEntity(AcDbEntity *pEntity) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
appendAcDbEntity(AcDbObjectId &pOutputId, AcDbEntity *pEntity) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
assumeOwnershipOf(AcArray< AcDbObjectId > entitiesToMove) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
blockInsertUnits() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
blockScaling() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
BlockScaling enum name (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comments(ACHAR *&pString) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
comments(const ACHAR *&pString) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explodable() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBlockReferenceIds(AcDbObjectIdArray &ids, bool bDirectOnly=true, bool bForceValidity=false) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
getClassID(CLSID *pClsid) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
getErasedBlockReferenceIds(AcDbObjectIdArray &) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getLayoutId() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getPreviewIcon(PreviewIcon &previewIcon) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
getSortentsTable(AcDbSortentsTable *&pSortents, AcDb::OpenMode openMode, bool createIfNecessary=false) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasAttributeDefinitions() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasPreviewIcon() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAnonymous() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFromExternalReference() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
isFromOverlayReference() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLayout() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUnloaded() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kAny enum value (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kUniform enum value (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newBlockReferenceIdIterator(AcDbBlockReferenceIdIterator *&pIter) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
newIterator(AcDbBlockTableRecordIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openBlockBegin(AcDbBlockBegin *&pBlockBegin, AcDb::OpenMode openMode) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
openBlockEnd(AcDbBlockEnd *&pBlockEnd, AcDb::OpenMode openMode) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
origin() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
ownerId() const (defined in AcDbObject) | AcDbObject |
pathName(ACHAR *&pPath) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
pathName(const ACHAR *&pPath) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
postProcessAnnotativeBTR(int &stripCnt, const bool bqueryOnly=false, const bool bScale=true) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
PreviewIcon typedef (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockInsertUnits(AcDb::UnitsValue insunits) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
setBlockScaling(AcDbBlockTableRecord::BlockScaling blockScaling) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
setComments(const ACHAR *pString) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
setExplodable(bool bExplodable) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setIsUnloaded(bool isUnloaded) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
setLayoutId(AcDbObjectId) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setOrigin(const AcGePoint3d &pt) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPathName(const ACHAR *pathStr) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
setPreviewIcon(const PreviewIcon &previewIcon) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subGetClassID(CLSID *pClsid) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | protectedvirtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
xrefDatabase(bool incUnres=false) const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
xrefStatus() const (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord |
~AcDbBlockTableRecord() (defined in AcDbBlockTableRecord) | AcDbBlockTableRecord | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBlockTableRecordIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
AcDbBlockTableRecordIterator Class Reference
AcDb Classes

Public Member Functions

AcDbBlockTableRecord * | blockTableRecord () const
bool | done () const
Acad::ErrorStatus | getEntity (AcDbEntity *&pEntity, AcDb::OpenMode openMode, bool openErasedEntity=false) const
Acad::ErrorStatus | getEntityId (AcDbObjectId &entityId) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbEntity *pEntity)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Protected Attributes

class
AcDbImpBlockTableRecordIterator * 		mpImp

Friends

class AcDbImpBlockTableRecord
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBlockTableRecordIterator Member List

This is the complete list of members for AcDbBlockTableRecordIterator, including all inherited members.

AcDbImpBlockTableRecord (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator | friend
blockTableRecord() const (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator |
done() const (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator |
getEntity(AcDbEntity *&pEntity, AcDb::OpenMode openMode, bool openErasedEntity=false) const (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator |
getEntityId(AcDbObjectId &entityId) const (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator |
mpImp (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator | protected
seek(AcDbObjectId id) (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator |
seek(const AcDbEntity *pEntity) (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator |
~AcDbBlockTableRecordIterator() (defined in AcDbBlockTableRecordIterator) | AcDbBlockTableRecordIterator | virtual


ZRX API Reference: AcDbBody Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcDbBody Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBody:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbBody)
virtual void * | body () const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcDbSubentId | internalSubentId (void *) const
virtual void * | internalSubentPtr (const AcDbSubentId &id) const
void | invalidateCachedBodySubentIds ()
virtual Adesk::Boolean | isNull () const
virtual void | list () const
virtual Adesk::UInt32 | numChanges () const
virtual Acad::ErrorStatus | setBody (const void *modelerBody)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static Acad::ErrorStatus | acisIn (const ACHAR *fileName, AcDbVoidPtrArray &)
static Acad::ErrorStatus | acisOut (const ACHAR *fileName, const AcDbVoidPtrArray &)

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Member Function Documentation

virtual void* AcDbBody::body ( ) const
virtual
Warning
Not implemented!
virtual AcDbSubentId AcDbBody::internalSubentId ( void * ) const
virtual
Warning
Not implemented!
virtual void* AcDbBody::internalSubentPtr ( const AcDbSubentId & id ) const
virtual
Warning
Not implemented!
void AcDbBody::invalidateCachedBodySubentIds ( )
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbBody::setBody ( const void * modelerBody )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbbody.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBody Member List

This is the complete list of members for AcDbBody, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbBody) (defined in AcDbBody) | AcDbBody |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBody() (defined in AcDbBody) | AcDbBody |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
acisIn(const ACHAR *fileName, AcDbVoidPtrArray &) (defined in AcDbBody) | AcDbBody | static
acisOut(const ACHAR *fileName, const AcDbVoidPtrArray &) (defined in AcDbBody) | AcDbBody | static
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
body() const | AcDbBody | virtual
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbBody) | AcDbBody | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbBody) | AcDbBody | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
internalSubentId(void *) const | AcDbBody | virtual
internalSubentPtr(const AcDbSubentId &id) const | AcDbBody | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
invalidateCachedBodySubentIds() | AcDbBody |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isNull() const (defined in AcDbBody) | AcDbBody | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbBody) | AcDbBody | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
numChanges() const (defined in AcDbBody) | AcDbBody | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBody(const void *modelerBody) | AcDbBody | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbBody) | AcDbBody | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBody() (defined in AcDbBody) | AcDbBody | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBreakData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbBreakData Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBreakData:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbBreakData)
Acad::ErrorStatus | addBreakPointRef (AcDbBreakPointRef *ptRef)
Acad::ErrorStatus | deleteAllBreakPointRefs ()
AcDbObjectId | dimObjId () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *) const
Acad::ErrorStatus | eraseFromDb (void)
Acad::ErrorStatus | getBreakPointRef (int lineIndex, AcArray< AcDbBreakPointRef * > &ptRefs) const
Acad::ErrorStatus | getBreakPointRef (AcArray< AcDbBreakPointRef * > &ptRefs) const
virtual void | modifiedGraphics (const AcDbEntity *pEnt)
Acad::ErrorStatus | postToDb (AcDbObjectId &breakObjId)
Acad::ErrorStatus | removeAssociativity (bool force=true)
Acad::ErrorStatus | setDimObjId (const AcDbObjectId &dimId)
Acad::ErrorStatus | updateAssociativity (const AcDbObjectIdArray &ids, int cmdType)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

Acad::ErrorStatus AcDbBreakData::addBreakPointRef ( AcDbBreakPointRef * ptRef )
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakData::deleteAllBreakPointRefs ( )
Warning
Not implemented!
AcDbObjectId AcDbBreakData::dimObjId ( ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbBreakData::dwgInFields ( AcDbDwgFiler * )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbBreakData::dwgOutFields ( AcDbDwgFiler * ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbBreakData::dxfInFields ( AcDbDxfFiler * )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbBreakData::dxfOutFields ( AcDbDxfFiler * ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Acad::ErrorStatus AcDbBreakData::eraseFromDb ( void )
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakData::getBreakPointRef | ( | int | lineIndex,
 |  | AcArray< AcDbBreakPointRef * > & | ptRefs
 | ) |  | const
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakData::getBreakPointRef ( AcArray< AcDbBreakPointRef * > & ptRefs ) const
Warning
Not implemented!
virtual void AcDbBreakData::modifiedGraphics ( const AcDbEntity * pEnt )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Acad::ErrorStatus AcDbBreakData::postToDb ( AcDbObjectId & breakObjId )
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakData::removeAssociativity ( bool force = true )
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakData::setDimObjId ( const AcDbObjectId & dimId )
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakData::updateAssociativity | ( | const AcDbObjectIdArray & | ids,
 |  | int | cmdType
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbBreakData.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBreakData Member List

This is the complete list of members for AcDbBreakData, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbBreakData) (defined in AcDbBreakData) | AcDbBreakData |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBreakData() (defined in AcDbBreakData) | AcDbBreakData |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addBreakPointRef(AcDbBreakPointRef *ptRef) | AcDbBreakData |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteAllBreakPointRefs() | AcDbBreakData |
desc() (defined in AcRxObject) | AcRxObject | static
dimObjId() const | AcDbBreakData |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *) | AcDbBreakData | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *) const | AcDbBreakData | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *) | AcDbBreakData | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *) const | AcDbBreakData | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
eraseFromDb(void) | AcDbBreakData |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBreakPointRef(int lineIndex, AcArray< AcDbBreakPointRef * > &ptRefs) const | AcDbBreakData |
getBreakPointRef(AcArray< AcDbBreakPointRef * > &ptRefs) const | AcDbBreakData |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *pEnt) | AcDbBreakData | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
postToDb(AcDbObjectId &breakObjId) | AcDbBreakData |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeAssociativity(bool force=true) | AcDbBreakData |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDimObjId(const AcDbObjectId &dimId) | AcDbBreakData |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
updateAssociativity(const AcDbObjectIdArray &ids, int cmdType) | AcDbBreakData |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBreakData() (defined in AcDbBreakData) | AcDbBreakData | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbBreakPointRef Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbBreakPointRef Class Reference
AcDb Classes
+ Inheritance diagram for AcDbBreakPointRef:

Public Types

enum BreakPointType { kDynamic = 0, kStatic = 1, kStatic2Point = 2 }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbBreakPointRef)
AcGePoint3d | breakPoint () const
AcGePoint3d | breakPoint2 () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *) const
Acad::ErrorStatus | getBreakPointId (AcDbFullSubentPath &idPath) const
Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcGePoint3dArray &points, AcGePoint3dArray &textBoxPts)
Adesk::Int32 | lineIndex () const
AcDbBreakPointRef::BreakPointType | pointType () const
Acad::ErrorStatus | setBreakPoint (const AcGePoint3d &pt)
Acad::ErrorStatus | setBreakPoint2 (const AcGePoint3d &pt)
Acad::ErrorStatus | setBreakPointId (const AcDbFullSubentPath &idPath)
Acad::ErrorStatus | setLineIndex (Adesk::Int32 index)
Acad::ErrorStatus | setPointType (AcDbBreakPointRef::BreakPointType newVal)
AcDbEntity * | subentPtr () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

AcGePoint3d AcDbBreakPointRef::breakPoint ( ) const
Warning
Not implemented!
AcGePoint3d AcDbBreakPointRef::breakPoint2 ( ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbBreakPointRef::dwgInFields ( AcDbDwgFiler * )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbBreakPointRef::dwgOutFields ( AcDbDwgFiler * ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbBreakPointRef::dxfInFields ( AcDbDxfFiler * )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbBreakPointRef::dxfOutFields ( AcDbDxfFiler * ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Acad::ErrorStatus AcDbBreakPointRef::getBreakPointId ( AcDbFullSubentPath & idPath ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakPointRef::intersectWith | ( | const AcDbEntity * | pEnt,
 |  | AcGePoint3dArray & | points,
 |  | AcGePoint3dArray & | textBoxPts
 | ) |  |
Warning
Not implemented!
Adesk::Int32 AcDbBreakPointRef::lineIndex ( ) const
Warning
Not implemented!
AcDbBreakPointRef::BreakPointType AcDbBreakPointRef::pointType ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakPointRef::setBreakPoint ( const AcGePoint3d & pt )
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakPointRef::setBreakPoint2 ( const AcGePoint3d & pt )
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakPointRef::setBreakPointId ( const AcDbFullSubentPath & idPath )
Warning
Not implemented!
Acad::ErrorStatus AcDbBreakPointRef::setPointType ( AcDbBreakPointRef::BreakPointType newVal )
Warning
Not implemented!
AcDbEntity* AcDbBreakPointRef::subentPtr ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbBreakData.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbBreakPointRef Member List

This is the complete list of members for AcDbBreakPointRef, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbBreakPointRef) (defined in AcDbBreakPointRef) | AcDbBreakPointRef |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBreakPointRef() (defined in AcDbBreakPointRef) | AcDbBreakPointRef |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
breakPoint() const | AcDbBreakPointRef |
breakPoint2() const | AcDbBreakPointRef |
BreakPointType enum name (defined in AcDbBreakPointRef) | AcDbBreakPointRef |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *) | AcDbBreakPointRef | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *) const | AcDbBreakPointRef | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *) | AcDbBreakPointRef | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *) const | AcDbBreakPointRef | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBreakPointId(AcDbFullSubentPath &idPath) const | AcDbBreakPointRef |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcGePoint3dArray &points, AcGePoint3dArray &textBoxPts) | AcDbBreakPointRef |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDynamic enum value (defined in AcDbBreakPointRef) | AcDbBreakPointRef |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kStatic enum value (defined in AcDbBreakPointRef) | AcDbBreakPointRef |
kStatic2Point enum value (defined in AcDbBreakPointRef) | AcDbBreakPointRef |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
lineIndex() const | AcDbBreakPointRef |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
pointType() const | AcDbBreakPointRef |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBreakPoint(const AcGePoint3d &pt) | AcDbBreakPointRef |
setBreakPoint2(const AcGePoint3d &pt) | AcDbBreakPointRef |
setBreakPointId(const AcDbFullSubentPath &idPath) | AcDbBreakPointRef |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLineIndex(Adesk::Int32 index) (defined in AcDbBreakPointRef) | AcDbBreakPointRef |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPointType(AcDbBreakPointRef::BreakPointType newVal) | AcDbBreakPointRef |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentPtr() const | AcDbBreakPointRef |
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBreakPointRef() (defined in AcDbBreakPointRef) | AcDbBreakPointRef | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbCamera Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbCamera Class Reference
AcDb Classes
+ Inheritance diagram for AcDbCamera:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbCamera)
AcDbCamera ()
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const
virtual void | list () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setView (const AcDbObjectId viewId)
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode openMode)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const
AcDbObjectId | view () const
virtual void | viewportDraw (AcGiViewportDraw *mode)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
virtual | ~AcDbCamera ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpCamera

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbCamera::AcDbCamera ( )
Warning
Not implemented!
virtual AcDbCamera::~AcDbCamera ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbCamera::deepClone | ( | AcDbObject * | pOwnerObject,
 |  | AcDbObject *& | pClonedObject,
 |  | AcDbIdMapping & | idMap,
 |  | Adesk::Boolean | isPrimary = Adesk::kTrue
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbCamera::dwgInFields ( AcDbDwgFiler * filer )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::dwgOutFields ( AcDbDwgFiler * filer ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::dxfInFields ( AcDbDxfFiler * filer )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::dxfOutFields ( AcDbDxfFiler * filer ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::getGripPoints | ( | AcDbGripDataPtrArray & | grips,
 |  | const double | curViewUnitSize,
 |  | const int | gripSize,
 |  | const AcGeVector3d & | curViewDir,
 |  | const int | bitflags
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::getStretchPoints ( AcGePoint3dArray & stretchPoints ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::highlight | ( | const AcDbFullSubentPath & | subId = kNullSubent,
 |  | const Adesk::Boolean | highlightAll = Adesk::kFalse
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual void AcDbCamera::list ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::moveGripPointsAt | ( | const AcDbVoidPtrArray & | gripAppData,
 |  | const AcGeVector3d & | offset,
 |  | const int | bitflags
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::moveStretchPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Adesk::UInt32 AcDbCamera::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Acad::ErrorStatus AcDbCamera::setView ( const AcDbObjectId viewId )
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbCamera::subClose ( )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbCamera::subErase ( Adesk::Boolean erasing )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbCamera::subOpen ( AcDb::OpenMode openMode )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbCamera::transformBy ( const AcGeMatrix3d & xform )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::unhighlight | ( | const AcDbFullSubentPath & | subId = kNullSubent,
 |  | const Adesk::Boolean | highlightAll = Adesk::kFalse
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

AcDbObjectId AcDbCamera::view ( ) const
Warning
Not implemented!
virtual void AcDbCamera::viewportDraw ( AcGiViewportDraw * mode )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbCamera::wblockClone | ( | AcRxObject * | pOwnerObject,
 |  | AcDbObject *& | pClonedObject,
 |  | AcDbIdMapping & | idMap,
 |  | Adesk::Boolean | isPrimary = Adesk::kTrue
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Adesk::Boolean AcDbCamera::worldDraw ( AcGiWorldDraw * mode )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

The documentation for this class was generated from the following file:
  • AcCamera.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbCamera Member List

This is the complete list of members for AcDbCamera, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbCamera) (defined in AcDbCamera) | AcDbCamera |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCamera() | AcDbCamera |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbImpCamera (defined in AcDbCamera) | AcDbCamera | friend
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const | AcDbCamera | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) | AcDbCamera | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const | AcDbCamera | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) | AcDbCamera | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const | AcDbCamera | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbCamera | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const | AcDbCamera | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const | AcDbCamera | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const | AcDbCamera | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const | AcDbCamera | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) | AcDbCamera | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbCamera | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbCamera | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setView(const AcDbObjectId viewId) | AcDbCamera |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() | AcDbCamera | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) | AcDbCamera | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode openMode) | AcDbCamera | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) | AcDbCamera | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const | AcDbCamera | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
view() const | AcDbCamera |
viewportDraw(AcGiViewportDraw *mode) | AcDbCamera | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const | AcDbCamera | virtual
worldDraw(AcGiWorldDraw *mode) | AcDbCamera | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCamera() | AcDbCamera | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbCircle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbCircle Class Reference
AcDb Classes
+ Inheritance diagram for AcDbCircle:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbCircle)
AcDbCircle (const AcGePoint3d &cntr, const AcGeVector3d &nrm, double radius)
virtual bool | castShadows () const
AcGePoint3d | center () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
DBCURVE_METHODS Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&ent) const
virtual void | gripStatus (const AcDb::GripStat status)
AcGeVector3d | normal () const
double | radius () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | setCenter (const AcGePoint3d &)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setRadius (double)
Acad::ErrorStatus | setThickness (double)
double | thickness () const
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbCircle Member List

This is the complete list of members for AcDbCircle, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbCircle) (defined in AcDbCircle) | AcDbCircle |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCircle() (defined in AcDbCircle) | AcDbCircle |
AcDbCircle(const AcGePoint3d &cntr, const AcGeVector3d &nrm, double radius) (defined in AcDbCircle) | AcDbCircle |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbCircle) | AcDbCircle | virtual
center() const (defined in AcDbCircle) | AcDbCircle |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbCircle) | AcDbCircle | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbCircle) | AcDbCircle | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbCircle) | AcDbCircle | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&ent) const (defined in AcDbCircle) | AcDbCircle | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbCircle) | AcDbCircle | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbCircle) | AcDbCircle |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
radius() const (defined in AcDbCircle) | AcDbCircle |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbCircle) | AcDbCircle | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setCenter(const AcGePoint3d &) (defined in AcDbCircle) | AcDbCircle |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbCircle) | AcDbCircle |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setRadius(double) (defined in AcDbCircle) | AcDbCircle |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setThickness(double) (defined in AcDbCircle) | AcDbCircle |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thickness() const (defined in AcDbCircle) | AcDbCircle |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCircle() (defined in AcDbCircle) | AcDbCircle |
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbColor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbColor Class Reference
AcDb Classes
+ Inheritance diagram for AcDbColor:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbColor)
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
const AcCmEntityColor & | entityColor (void) const
void | getColor (AcCmColor &color) const
void | setColor (const AcCmColor &color)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbColor Member List

This is the complete list of members for AcDbColor, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbColor) (defined in AcDbColor) | AcDbColor |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbColor() (defined in AcDbColor) | AcDbColor |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbColor) | AcDbColor | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbColor) | AcDbColor | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbColor) | AcDbColor | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbColor) | AcDbColor | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbColor) | AcDbColor | virtual
entityColor(void) const (defined in AcDbColor) | AcDbColor |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getColor(AcCmColor &color) const (defined in AcDbColor) | AcDbColor |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setColor(const AcCmColor &color) (defined in AcDbColor) | AcDbColor |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbColor) | AcDbColor | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbColor() (defined in AcDbColor) | AcDbColor | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbCompositeFilteredBlockIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcDbCompositeFilteredBlockIterator Class Reference
AcDb Classes

Public Member Functions

virtual AcDbObjectId | id () const =0
virtual Acad::ErrorStatus | init (AcDbFilter *const *ppFilters, int numFilters, const AcDbBlockTableRecord *pBtr)=0
virtual AcDbObjectId | next ()=0
virtual Acad::ErrorStatus | seek (AcDbObjectId id)=0
virtual Acad::ErrorStatus | start ()=0

Static Public Member Functions

static
AcDbCompositeFilteredBlockIterator * 		newIterator ()
The documentation for this class was generated from the following file:
  • dbindex.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbCompositeFilteredBlockIterator Member List

This is the complete list of members for AcDbCompositeFilteredBlockIterator, including all inherited members.

AcDbCompositeFilteredBlockIterator() (defined in AcDbCompositeFilteredBlockIterator) | AcDbCompositeFilteredBlockIterator | inlineprotected
id() const =0 (defined in AcDbCompositeFilteredBlockIterator) | AcDbCompositeFilteredBlockIterator | pure virtual
init(AcDbFilter *const *ppFilters, int numFilters, const AcDbBlockTableRecord *pBtr)=0 (defined in AcDbCompositeFilteredBlockIterator) | AcDbCompositeFilteredBlockIterator | pure virtual
newIterator() (defined in AcDbCompositeFilteredBlockIterator) | AcDbCompositeFilteredBlockIterator | static
next()=0 (defined in AcDbCompositeFilteredBlockIterator) | AcDbCompositeFilteredBlockIterator | pure virtual
seek(AcDbObjectId id)=0 (defined in AcDbCompositeFilteredBlockIterator) | AcDbCompositeFilteredBlockIterator | pure virtual
start()=0 (defined in AcDbCompositeFilteredBlockIterator) | AcDbCompositeFilteredBlockIterator | pure virtual
~AcDbCompositeFilteredBlockIterator() (defined in AcDbCompositeFilteredBlockIterator) | AcDbCompositeFilteredBlockIterator | inlinevirtual


ZRX API Reference: AcDbCurve Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbCurve Class Reference
AcDb Classes
+ Inheritance diagram for AcDbCurve:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbcurve.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbCurve Member List

This is the complete list of members for AcDbCurve, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbCurvePath Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbCurvePath Class Reference
AcDb Classes
+ Inheritance diagram for AcDbCurvePath:

Public Member Functions

AcDbCurvePath ()
ACRX_DECLARE_MEMBERS (AcDbCurvePath)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcDbObjectId | entityId () const
virtual Acad::ErrorStatus | getGeometry (AcGeCurve3d *&pCurveGeometry) const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setGeometry (const AcDbObjectId &id)
virtual | ~AcDbCurvePath ()
- Public Member Functions inherited from AcDbNamedPath
ACRX_DECLARE_MEMBERS (AcDbNamedPath)
virtual | ~AcDbNamedPath ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpCurvePath

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcDbNamedPath
AcDbNamedPath (AcDbImpNamedPath *pImp)
AcDbImpNamedPath * | imp () const

Constructor & Destructor Documentation

AcDbCurvePath::AcDbCurvePath ( )
Warning
Not implemented!
virtual AcDbCurvePath::~AcDbCurvePath ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbCurvePath::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbCurvePath::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbCurvePath::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbCurvePath::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

AcDbObjectId AcDbCurvePath::entityId ( ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbCurvePath::getGeometry ( AcGeCurve3d *& pCurveGeometry ) const
virtual
Warning
Not implemented!

Implements AcDbNamedPath.

virtual Adesk::UInt32 AcDbCurvePath::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Acad::ErrorStatus AcDbCurvePath::setGeometry ( const AcDbObjectId & id )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbNamedPath.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbCurvePath Member List

This is the complete list of members for AcDbCurvePath, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurvePath() | AcDbCurvePath |
AcDbImpCurvePath (defined in AcDbCurvePath) | AcDbCurvePath | friend
AcDbNamedPath(AcDbImpNamedPath *pImp) | AcDbNamedPath | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbCurvePath) (defined in AcDbCurvePath) | AcDbCurvePath |
ACRX_DECLARE_MEMBERS(AcDbNamedPath) (defined in AcDbNamedPath) | AcDbNamedPath |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbCurvePath | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbCurvePath | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbCurvePath | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbCurvePath | virtual
entityId() const | AcDbCurvePath |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeometry(AcGeCurve3d *&pCurveGeometry) const | AcDbCurvePath | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imp() const | AcDbNamedPath | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbCurvePath | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGeometry(const AcDbObjectId &id) | AcDbCurvePath |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurvePath() | AcDbCurvePath | virtual
~AcDbNamedPath() | AcDbNamedPath | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbCustomOsnapInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbCustomOsnapInfo Class Reference
AcDb Classes
+ Inheritance diagram for AcDbCustomOsnapInfo:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbCustomOsnapInfo)
virtual Acad::ErrorStatus | getOsnapInfo (AcDbEntity *pickedObject, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcArray< AcGePoint3d > &snapPoints, AcDbIntArray &geomIdsForPts, AcArray< AcGeCurve3d * > &snapCurves, AcDbIntArray &geomIdsForLines)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbosnap.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbCustomOsnapInfo Member List

This is the complete list of members for AcDbCustomOsnapInfo, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbCustomOsnapInfo) (defined in AcDbCustomOsnapInfo) | AcDbCustomOsnapInfo |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getOsnapInfo(AcDbEntity *pickedObject, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcArray< AcGePoint3d > &snapPoints, AcDbIntArray &geomIdsForPts, AcArray< AcGeCurve3d * > &snapCurves, AcDbIntArray &geomIdsForLines)=0 (defined in AcDbCustomOsnapInfo) | AcDbCustomOsnapInfo | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbCustomOsnapManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbCustomOsnapManager Class Reference
AcDb Classes

Public Member Functions

virtual Acad::ErrorStatus | activateOsnapMode (const ACHAR *modeStr)=0
virtual Acad::ErrorStatus | addCustomOsnapMode (AcDbCustomOsnapMode *pMode)=0
virtual Acad::ErrorStatus | deactivateOsnapMode (const ACHAR *modeStr)=0
virtual Adesk::Boolean | modeIsActive (const ACHAR *modeStr)=0
virtual int | osnapGlyphSize () const =0
virtual Acad::ErrorStatus | removeCustomOsnapMode (AcDbCustomOsnapMode *pMode)=0
The documentation for this class was generated from the following file:
  • dbosnap.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbCustomOsnapManager Member List

This is the complete list of members for AcDbCustomOsnapManager, including all inherited members.

activateOsnapMode(const ACHAR *modeStr)=0 (defined in AcDbCustomOsnapManager) | AcDbCustomOsnapManager | pure virtual
addCustomOsnapMode(AcDbCustomOsnapMode *pMode)=0 (defined in AcDbCustomOsnapManager) | AcDbCustomOsnapManager | pure virtual
deactivateOsnapMode(const ACHAR *modeStr)=0 (defined in AcDbCustomOsnapManager) | AcDbCustomOsnapManager | pure virtual
modeIsActive(const ACHAR *modeStr)=0 (defined in AcDbCustomOsnapManager) | AcDbCustomOsnapManager | pure virtual
osnapGlyphSize() const =0 (defined in AcDbCustomOsnapManager) | AcDbCustomOsnapManager | pure virtual
removeCustomOsnapMode(AcDbCustomOsnapMode *pMode)=0 (defined in AcDbCustomOsnapManager) | AcDbCustomOsnapManager | pure virtual


ZRX API Reference: AcDbCustomOsnapMode Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbCustomOsnapMode Class Reference
AcDb Classes

Public Member Functions

virtual const AcRxClass * | entityOsnapClass () const =0
virtual const ACHAR * | globalModeString () const =0
virtual AcGiGlyph * | glyph () const =0
virtual const ACHAR * | localModeString () const =0
virtual const ACHAR * | tooltipString () const =0
The documentation for this class was generated from the following file:
  • dbosnap.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbCustomOsnapMode Member List

This is the complete list of members for AcDbCustomOsnapMode, including all inherited members.

entityOsnapClass() const =0 (defined in AcDbCustomOsnapMode) | AcDbCustomOsnapMode | pure virtual
globalModeString() const =0 (defined in AcDbCustomOsnapMode) | AcDbCustomOsnapMode | pure virtual
glyph() const =0 (defined in AcDbCustomOsnapMode) | AcDbCustomOsnapMode | pure virtual
localModeString() const =0 (defined in AcDbCustomOsnapMode) | AcDbCustomOsnapMode | pure virtual
tooltipString() const =0 (defined in AcDbCustomOsnapMode) | AcDbCustomOsnapMode | pure virtual
~AcDbCustomOsnapMode() (defined in AcDbCustomOsnapMode) | AcDbCustomOsnapMode | inlinevirtual


ZRX API Reference: AcDbDatabase Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | Friends | List of all members
AcDbDatabase Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDatabase:

Public Types

enum OpenMode { kForReadAndReadShare = 1, kForReadAndWriteNoShare = 2, kForReadAndAllShare = 3, kTryForReadShare = 4 }

Public Member Functions

void | abortDeepClone (AcDbIdMapping &idMap)
AcDbDatabase (bool buildDefaultDrawing=true, bool noDocument=false)
ACRX_DECLARE_MEMBERS (AcDbDatabase)
Acad::ErrorStatus | addAcDbObject (AcDbObject *pObj)
Acad::ErrorStatus | addAcDbObject (AcDbObjectId &objId, AcDbObject *pObj)
void | addReactor (AcDbDatabaseReactor *pReactor) const
double | angbase () const
bool | angdir () const
bool | annoAllVisible () const
bool | annotativeDwg () const
Acad::ErrorStatus | applyPartialOpenFilters (const AcDbSpatialFilter *pSpatialFilter, const AcDbLayerFilter *pLayerFilter)
int | approxNumObjects () const
bool | attdia () const
Adesk::Int16 | attmode () const
bool | attreq () const
Acad::ErrorStatus | audit (AcDbAuditInfo *pInfo)
Acad::ErrorStatus | auditXData (AcDbAuditInfo *pInfo)
Adesk::Int16 | aunits () const
Adesk::Int16 | auprec () const
bool | blipmode () const
AcDbObjectId | blockTableId ()
AcDbObjectId | byBlockLinetype () const
AcDbObjectId | byBlockMaterial () const
AcDbObjectId | byLayerLinetype () const
AcDbObjectId | byLayerMaterial () const
bool | cameraDisplay () const
double | cameraHeight () const
AcDbAnnotationScale * | cannoscale () const
AcCmColor | cecolor () const
double | celtscale () const
AcDbObjectId | celtype () const
AcDb::LineWeight | celweight () const
double | chamfera () const
double | chamferb () const
double | chamferc () const
double | chamferd () const
const ACHAR * | classDxfName (const AcRxClass *pClass)
AcDbObjectId | clayer () const
const SecurityParams * | cloneSecurityParams ()
Acad::ErrorStatus | closeInput (bool bCloseFile=false)
AcDbObjectId | cmaterial () const
Adesk::Int16 | cmljust () const
double | cmlscale () const
AcDbObjectId | cmlstyleID () const
AcDbObjectId | colorDictionaryId ()
AcDbObjectId | continuousLinetype () const
Adesk::Int16 | coords () const
Acad::ErrorStatus | countHardReferences (const AcDbObjectIdArray &ids, Adesk::UInt32 *pCount)
Adesk::UInt8 | cshadow () const
AcDbObjectId | currentSpaceId () const
AcDbObjectId | dataLinkDictionaryId (void) const
Acad::ErrorStatus | deepCloneObjects (AcDbObjectIdArray &objectIds, AcDbObjectId &owner, AcDbIdMapping &idMap, bool deferXlation=false)
Adesk::Int16 | delUsedObj () const
Adesk::UInt8 | dgnframe () const
bool | dimaso () const
Adesk::UInt8 | dimAssoc () const
int | dimfit () const
bool | dimsho () const
AcDbObjectId | dimstyle () const
AcDbObjectId | dimStyleTableId ()
int | dimunit () const
void | disablePartialOpen ()
void | disableUndoRecording (bool disable)
bool | dispSilh () const
Adesk::Int16 | dragmode () const
AcDbObjectId | dragVisStyle () const
Adesk::UInt8 | drawOrderCtl () const
Adesk::UInt8 | dwfframe () const
bool | dwgFileWasSavedByAutodeskSoftware () const
Adesk::Int16 | dxeVal () const
Acad::ErrorStatus | dxfIn (const ACHAR *dxfFilename, const ACHAR *logFilename=NULL)
Acad::ErrorStatus | dxfOut (const ACHAR *fileName, int precision=16, AcDb::AcDbDwgVersion dwgVer=AcDb::kDHL_CURRENT, bool saveThumbnailImage=false)
double | elevation () const
AcDb::EndCaps | endCaps () const
Acad::ErrorStatus | evaluateFields (int nContext, const ACHAR *pszPropName=NULL, AcDbDatabase *pDb=NULL, int *pNumFound=NULL, int *pNumEvaluated=NULL)
AcGePoint3d | extmax () const
AcGePoint3d | extmin () const
double | facetres () const
AcFileDependencyManager * | fileDependencyManager () const
double | filletrad () const
bool | fillmode () const
void | forceWblockDatabaseCopy ()
double | get3dDwfPrec () const
Acad::ErrorStatus | getAcDbObjectId (AcDbObjectId &retId, bool createIfNotFound, const AcDbHandle &objHandle, Adesk::UInt32 xRefId=0)
Acad::ErrorStatus | getBlockTable (AcDbSymbolTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getBlockTable (AcDbBlockTable *&pTable, AcDb::OpenMode mode)
AcDb::PlotStyleNameType | getCePlotStyleNameId (AcDbObjectId &id) const
Acad::ErrorStatus | getColorDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getDataLinkDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
AcDbDataLinkManager * | getDataLinkManager (void) const
Acad::ErrorStatus | getDimapost (ACHAR *&pOutput) const
Acad::ErrorStatus | getDimblk (ACHAR *&pOutput) const
Acad::ErrorStatus | getDimblk1 (ACHAR *&pOutput) const
Acad::ErrorStatus | getDimblk2 (ACHAR *&pOutput) const
Acad::ErrorStatus | getDimpost (ACHAR *&pOutput) const
Acad::ErrorStatus | getDimRecentStyleList (AcDbObjectIdArray &objIds) const
Acad::ErrorStatus | getDimstyleChildData (const AcRxClass *pDimClass, AcDbDimStyleTableRecord *&pRec, AcDbObjectId &style) const
AcDbObjectId | getDimstyleChildId (const AcRxClass *pDimClass, AcDbObjectId &parentStyle) const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRec) const
AcDbObjectId | getDimstyleParentId (AcDbObjectId &childStyle) const
Acad::ErrorStatus | getDimStyleTable (AcDbSymbolTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getDimStyleTable (AcDbDimStyleTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getFilename (const ACHAR *&pOutput) const
Acad::ErrorStatus | getFingerprintGuid (ACHAR *&guidString) const
Acad::ErrorStatus | getGroupDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getHyperlinkBase (ACHAR *&pOutput) const
AcDbLayerStateManager * | getLayerStateManager () const
Acad::ErrorStatus | getLayerTable (AcDbSymbolTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getLayerTable (AcDbLayerTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getLayoutDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getLinetypeTable (AcDbSymbolTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getLinetypeTable (AcDbLinetypeTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getMaterialDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getMenu (ACHAR *&pOutput) const
Acad::ErrorStatus | getMLeaderStyleDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getMLStyleDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getNamedObjectsDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getPlotSettingsDictionary (AcDbDictionary *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getPlotStyleNameDictionary (AcDbDictionaryWithDefault *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getProjectName (ACHAR *&pOutput) const
Acad::ErrorStatus | getRegAppTable (AcDbSymbolTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getRegAppTable (AcDbRegAppTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getScaleListDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
AcDbObjectId | getSectionManager (void) const
Acad::ErrorStatus | getSectionManager (AcDbSectionManager *&pMgr, AcDb::OpenMode mode) const
Acad::ErrorStatus | getStyleSheet (ACHAR *&pOutput) const
Acad::ErrorStatus | getSymbolTable (AcDbBlockTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getSymbolTable (AcDbLayerTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getSymbolTable (AcDbTextStyleTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getSymbolTable (AcDbLinetypeTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getSymbolTable (AcDbViewTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getSymbolTable (AcDbUCSTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getSymbolTable (AcDbViewportTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getSymbolTable (AcDbRegAppTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getSymbolTable (AcDbDimStyleTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getTableStyleDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getTextStyleTable (AcDbSymbolTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getTextStyleTable (AcDbTextStyleTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getTimeZoneInfo (AcDb::TimeZone tz, double &offset, AcString &desc) const
Acad::ErrorStatus | getUCSTable (AcDbSymbolTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getUCSTable (AcDbUCSTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getVersionGuid (ACHAR *&guidString) const
Acad::ErrorStatus | getViewportArray (AcDbObjectIdArray &vportIds, bool bGetPaperspaceVports=true) const
Acad::ErrorStatus | getViewportTable (AcDbSymbolTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getViewportTable (AcDbViewportTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getViewTable (AcDbSymbolTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getViewTable (AcDbViewTable *&pTable, AcDb::OpenMode mode)
Acad::ErrorStatus | getVisualStyleDictionary (AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | getVisualStyleList (AcArray< const ACHAR * > &vstyleList)
AcDbObjectId | globalMaterial () const
AcDbObjectId | groupDictionaryId ()
AcGsModel * | gsHighlightModel () const
AcGsModel * | gsModel () const
Adesk::UInt8 | haloGap () const
AcDbHandle | handseed () const
Adesk::UInt8 | hideText () const
bool | hpInherit () const
AcGePoint2d | hpOrigin () const
AcDwgFileHandle * | inputFiler () const
AcGePoint3d | insbase () const
Acad::ErrorStatus | insert (AcDbObjectId &blockId, const ACHAR *pBlockName, AcDbDatabase *pDb, bool preserveSourceDatabase=true)
Acad::ErrorStatus | insert (const AcGeMatrix3d &xform, AcDbDatabase *pDb, bool preserveSourceDatabase=true)
Acad::ErrorStatus | insert (AcDbObjectId &blockId, const ACHAR *pSourceBlockName, const ACHAR *pDestinationBlockName, AcDbDatabase *pDb, bool preserveSourceDatabase=true)
AcDb::UnitsValue | insunits () const
AcCmColor | interfereColor () const
AcDbObjectId | interfereObjVisStyle () const
AcDbObjectId | interfereVpVisStyle () const
Adesk::UInt16 | intersectColor () const
Adesk::UInt8 | intersectDisplay () const
bool | isEMR () const
Adesk::Int16 | isolines () const
bool | isPartiallyOpened () const
bool | isPucsOrthographic (AcDb::OrthographicView &orthoView) const
bool | isUcsOrthographic (AcDb::OrthographicView &orthoView) const
AcDb::JoinStyle | joinStyle () const
AcDb::MaintenanceReleaseVersion | lastSavedAsMaintenanceVersion () const
AcDb::AcDbDwgVersion | lastSavedAsVersion () const
double | latitude () const
AcDbObjectId | layerTableId ()
AcDbObjectId | layerZero () const
AcDbObjectId | layoutDictionaryId ()
double | lensLength () const
Adesk::UInt8 | lightGlyphDisplay () const
Adesk::UInt8 | lightingUnits () const
bool | lightsInBlocks () const
bool | limcheck () const
AcGePoint2d | limmax () const
AcGePoint2d | limmin () const
AcDbObjectId | linetypeTableId ()
bool | lineWeightDisplay () const
Acad::ErrorStatus | loadLineTypeFile (const ACHAR *ltn, const ACHAR *filename)
double | loftAng1 () const
double | loftAng2 () const
double | loftMag1 () const
double | loftMag2 () const
Adesk::UInt8 | loftNormals () const
Adesk::UInt16 | loftParam () const
double | longitude () const
double | ltscale () const
Adesk::Int16 | lunits () const
Adesk::Int16 | luprec () const
Adesk::UInt8 | maintenanceReleaseVersion () const
AcDbObjectId | materialDictionaryId ()
Adesk::Int16 | maxactvp () const
AcDb::MeasurementValue | measurement () const
bool | mirrtext () const
AcDbObjectId | mleaderstyle () const
AcDbObjectId | mleaderStyleDictionaryId () const
AcDbObjectId | mLStyleDictionaryId ()
bool | msltscale () const
AcDbObjectId | namedObjectsDictionaryId ()
double | northDirection () const
Adesk::Int32 | numberOfSaves () const
AcDbObjectContextManager * | objectContextManager () const
Adesk::UInt16 | obscuredColor () const
Adesk::UInt8 | obscuredLineType () const
bool | oleStartUp () const
AcDb::MaintenanceReleaseVersion | originalFileMaintenanceVersion () const
const ACHAR * | originalFileName () const
AcDb::MaintenanceReleaseVersion | originalFileSavedByMaintenanceVersion () const
AcDb::AcDbDwgVersion | originalFileSavedByVersion () const
AcDb::AcDbDwgVersion | originalFileVersion () const
bool | orthomode () const
AcDbObjectId | paperSpaceVportId () const
Adesk::Int16 | pdmode () const
double | pdsize () const
double | pelevation () const
AcGePoint3d | pextmax () const
AcGePoint3d | pextmin () const
Adesk::Int16 | pickstyle () const
AcGePoint3d | pinsbase () const
bool | plimcheck () const
AcGePoint2d | plimmax () const
AcGePoint2d | plimmin () const
bool | plineEllipse () const
bool | plinegen () const
double | plinewid () const
AcDbObjectId | plotSettingsDictionaryId ()
bool | plotStyleMode () const
AcDbObjectId | plotStyleNameDictionaryId ()
bool | psltscale () const
double | psolHeight () const
double | psolWidth () const
AcDbObjectId | pucsBase () const
AcDbObjectId | pucsname () const
AcGePoint3d | pucsorg () const
AcGeVector3d | pucsxdir () const
AcGeVector3d | pucsydir () const
Acad::ErrorStatus | purge (AcDbObjectIdArray &ids)
Acad::ErrorStatus | purge (AcDbObjectIdGraph &idGraph)
bool | qtextmode () const
Acad::ErrorStatus | readDwgFile (const ACHAR *fileName, OpenMode openmode, bool bAllowCPConversion=false, const wchar_t *wszPassword=NULL)
Acad::ErrorStatus | readDwgFile (const ACHAR *fileName, const int shmode=_SH_DENYWR, bool bAllowCPConversion=false, const wchar_t *wszPassword=NULL)
Acad::ErrorStatus | readDwgFile (AcDwgFileHandle *pDwgFile, bool bAllowCPConversion=false, const wchar_t *wszPassword=NULL)
bool | realWorldScale () const
Acad::ErrorStatus | reclaimMemoryFromErasedObjects (const AcDbObjectIdArray &erasedObjects)
AcDbObjectId | regAppTableId ()
bool | regenmode () const
void | removeReactor (AcDbDatabaseReactor *pReactor) const
Acad::ErrorStatus | restoreForwardingXrefSymbols ()
Acad::ErrorStatus | restoreOriginalXrefSymbols ()
bool | retainOriginalThumbnailBitmap () const
Acad::ErrorStatus | save ()
Acad::ErrorStatus | saveAs (const ACHAR *fileName, const SecurityParams *pSecParams=0)
Acad::ErrorStatus | saveAs (const ACHAR *fileName, const bool bBakAndRename, const AcDb::AcDbDwgVersion dwgVer=AcDb::kDHL_CURRENT, const SecurityParams *pSecParams=0)
Adesk::Int16 | saveproxygraphics () const
AcDbObjectId | scaleListDictionaryId ()
Acad::ErrorStatus | set3dDwfPrec (double DwfPrec)
Acad::ErrorStatus | setAngbase (double angle)
Acad::ErrorStatus | setAngdir (bool dir)
Acad::ErrorStatus | setAnnoAllVisible (bool allvis)
Acad::ErrorStatus | setAnnotativeDwg (bool ao)
Acad::ErrorStatus | setAttdia (bool dia)
Acad::ErrorStatus | setAttmode (Adesk::Int16 mode)
Acad::ErrorStatus | setAttreq (bool req)
Acad::ErrorStatus | setAunits (Adesk::Int16 aunits)
Acad::ErrorStatus | setAuprec (Adesk::Int16 auprec)
Acad::ErrorStatus | setBlipmode (bool mode)
Acad::ErrorStatus | setCameraDisplay (const bool cameraDisplay)
Acad::ErrorStatus | setCameraHeight (const double cameraHeight)
Acad::ErrorStatus | setCannoscale (AcDbAnnotationScale *)
Acad::ErrorStatus | setCecolor (const AcCmColor &color)
Acad::ErrorStatus | setCeltscale (double scale)
Acad::ErrorStatus | setCeltype (AcDbObjectId objId)
Acad::ErrorStatus | setCelweight (AcDb::LineWeight weight)
Acad::ErrorStatus | setCePlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull)
Acad::ErrorStatus | setChamfera (double val)
Acad::ErrorStatus | setChamferb (double val)
Acad::ErrorStatus | setChamferc (double val)
Acad::ErrorStatus | setChamferd (double val)
Acad::ErrorStatus | setClayer (AcDbObjectId objId)
Acad::ErrorStatus | setCmaterial (AcDbObjectId objId)
Acad::ErrorStatus | setCmljust (Adesk::Int16 just)
Acad::ErrorStatus | setCmlscale (double scale)
Acad::ErrorStatus | setCmlstyleID (AcDbObjectId objId)
Acad::ErrorStatus | setCoords (Adesk::Int16 coords)
Acad::ErrorStatus | setCshadow (Adesk::UInt8 val)
Acad::ErrorStatus | setDelUsedObj (Adesk::Int16 deleteObj)
Acad::ErrorStatus | setDgnframe (Adesk::UInt8)
Acad::ErrorStatus | setDimaso (bool aso)
Acad::ErrorStatus | setDimAssoc (Adesk::UInt8 val)
Acad::ErrorStatus | setDimfit (int fit)
Acad::ErrorStatus | setDimsho (bool sho)
Acad::ErrorStatus | setDimstyle (AcDbObjectId styleId)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pRec)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId id)
Acad::ErrorStatus | setDimunit (int unit)
Acad::ErrorStatus | setDispSilh (bool silh)
Acad::ErrorStatus | setDragmode (Adesk::Int16 mode)
Acad::ErrorStatus | setDragVisStyle (AcDbObjectId id)
Acad::ErrorStatus | setDrawOrderCtl (Adesk::UInt8 val)
Acad::ErrorStatus | setDwfframe (Adesk::UInt8)
Acad::ErrorStatus | setDxeVal (Adesk::Int16 val)
Acad::ErrorStatus | setElevation (double elev)
Acad::ErrorStatus | setEndCaps (AcDb::EndCaps type)
Acad::ErrorStatus | setExtmax (const AcGePoint3d &max)
Acad::ErrorStatus | setExtmin (const AcGePoint3d &min)
Acad::ErrorStatus | setFacetres (double facetres)
Acad::ErrorStatus | setFilletrad (double radius)
Acad::ErrorStatus | setFillmode (bool mode)
Acad::ErrorStatus | setFingerprintGuid (const ACHAR *pNewGuid)
void | setGsHighlightModel (AcGsModel *)
void | setGsModel (AcGsModel *)
Acad::ErrorStatus | setHaloGap (Adesk::UInt8 val)
Acad::ErrorStatus | setHandseed (const AcDbHandle &handle)
Acad::ErrorStatus | setHideText (Adesk::UInt8 val)
Acad::ErrorStatus | setHpInherit (const bool inherit)
Acad::ErrorStatus | setHpOrigin (const AcGePoint2d &origin)
Acad::ErrorStatus | setHyperlinkBase (const ACHAR *)
Acad::ErrorStatus | setInsbase (const AcGePoint3d &base)
Acad::ErrorStatus | setInsunits (const AcDb::UnitsValue units)
Acad::ErrorStatus | setInterfereColor (const AcCmColor &color)
Acad::ErrorStatus | setInterfereObjVisStyle (AcDbObjectId id)
Acad::ErrorStatus | setInterfereVpVisStyle (AcDbObjectId id)
Acad::ErrorStatus | setIntersectColor (Adesk::UInt16 val)
Acad::ErrorStatus | setIntersectDisplay (Adesk::UInt8 val)
Acad::ErrorStatus | setIsolines (Adesk::Int16 isolines)
Acad::ErrorStatus | setJoinStyle (AcDb::JoinStyle style)
Acad::ErrorStatus | setLatitude (double lat)
Acad::ErrorStatus | setLensLength (const double lensLength)
Acad::ErrorStatus | setLightGlyphDisplay (Adesk::UInt8 val)
Acad::ErrorStatus | setLightingUnits (Adesk::UInt8 val)
Acad::ErrorStatus | setLightsInBlocks (bool val)
Acad::ErrorStatus | setLimcheck (bool check)
Acad::ErrorStatus | setLimmax (const AcGePoint2d &max)
Acad::ErrorStatus | setLimmin (const AcGePoint2d &min)
Acad::ErrorStatus | setLineWeightDisplay (bool display)
Acad::ErrorStatus | setLoftAng1 (double ang1)
Acad::ErrorStatus | setLoftAng2 (double ang2)
Acad::ErrorStatus | setLoftMag1 (double mag1)
Acad::ErrorStatus | setLoftMag2 (double mag2)
Acad::ErrorStatus | setLoftNormals (Adesk::UInt8 value)
Acad::ErrorStatus | setLoftParam (Adesk::UInt16 flags)
Acad::ErrorStatus | setLongitude (double lng)
Acad::ErrorStatus | setLtscale (double scale)
Acad::ErrorStatus | setLunits (Adesk::Int16 lunits)
Acad::ErrorStatus | setLuprec (Adesk::Int16 prec)
Acad::ErrorStatus | setMaxactvp (Adesk::Int16 max)
Acad::ErrorStatus | setMeasurement (AcDb::MeasurementValue type)
Acad::ErrorStatus | setMirrtext (bool mirror)
Acad::ErrorStatus | setMLeaderstyle (AcDbObjectId objId)
Acad::ErrorStatus | setMsltscale (bool val)
Acad::ErrorStatus | setNorthDirection (double northdir)
Acad::ErrorStatus | setObscuredColor (Adesk::UInt16 val)
Acad::ErrorStatus | setObscuredLineType (Adesk::UInt8 val)
Acad::ErrorStatus | setOleStartUp (bool val)
Acad::ErrorStatus | setOrthomode (bool mode)
Acad::ErrorStatus | setPdmode (Adesk::Int16 mode)
Acad::ErrorStatus | setPdsize (double size)
Acad::ErrorStatus | setPelevation (double elev)
Acad::ErrorStatus | setPextmax (const AcGePoint3d &max)
Acad::ErrorStatus | setPextmin (const AcGePoint3d &min)
Acad::ErrorStatus | setPickstyle (Adesk::Int16 style)
Acad::ErrorStatus | setPinsbase (const AcGePoint3d &base)
Acad::ErrorStatus | setPlimcheck (bool check)
Acad::ErrorStatus | setPlimmax (const AcGePoint2d &max)
Acad::ErrorStatus | setPlimmin (const AcGePoint2d &min)
Acad::ErrorStatus | setPlineEllipse (bool pline)
Acad::ErrorStatus | setPlinegen (bool gen)
Acad::ErrorStatus | setPlinewid (double width)
Acad::ErrorStatus | setProjectName (const ACHAR *)
Acad::ErrorStatus | setPsltscale (bool scale)
Acad::ErrorStatus | setPsolHeight (double height)
Acad::ErrorStatus | setPsolWidth (double width)
Acad::ErrorStatus | setPucsBase (const AcDbObjectId &ucsid)
Acad::ErrorStatus | setQtextmode (bool mode)
Acad::ErrorStatus | setRealWorldScale (const bool realWorldScale)
Acad::ErrorStatus | setRegenmode (bool mode)
void | setRetainOriginalThumbnailBitmap (bool retain)
Acad::ErrorStatus | setSaveproxygraphics (Adesk::Int16 saveimg)
bool | setSecurityParams (const SecurityParams *pSecParams, bool bSetDbMod=true)
Acad::ErrorStatus | setShadedge (Adesk::Int16 mode)
Acad::ErrorStatus | setShadedif (Adesk::Int16 dif)
Acad::ErrorStatus | setShadowPlaneLocation (double val)
Acad::ErrorStatus | setShowHist (Adesk::UInt8 val)
Acad::ErrorStatus | setSketchinc (double inc)
Acad::ErrorStatus | setSkpoly (bool asPoly)
Acad::ErrorStatus | setSolidHist (Adesk::UInt8 val)
Acad::ErrorStatus | setSortEnts (Adesk::UInt8 sortEnts)
Acad::ErrorStatus | setSplframe (bool disp)
Acad::ErrorStatus | setSplinesegs (Adesk::Int16 segs)
Acad::ErrorStatus | setSplinetype (Adesk::Int16 type)
Acad::ErrorStatus | setStepSize (double stepSize)
Acad::ErrorStatus | setStepsPerSec (double stepsPerSec)
Acad::ErrorStatus | setStyleSheet (const ACHAR *)
Acad::ErrorStatus | setSurftab1 (Adesk::Int16 tab1)
Acad::ErrorStatus | setSurftab2 (Adesk::Int16 tab2)
Acad::ErrorStatus | setSurftype (Adesk::Int16 type)
Acad::ErrorStatus | setSurfu (Adesk::Int16 u)
Acad::ErrorStatus | setSurfv (Adesk::Int16 v)
Acad::ErrorStatus | setTablestyle (AcDbObjectId objId)
Acad::ErrorStatus | setTextsize (double size)
Acad::ErrorStatus | setTextstyle (AcDbObjectId objId)
Acad::ErrorStatus | setThickness (double thickness)
Acad::ErrorStatus | setThumbnailBitmap (void *pBmp)
Acad::ErrorStatus | setTilemode (bool mode)
Acad::ErrorStatus | setTileModeLightSynch (Adesk::UInt8 val)
Acad::ErrorStatus | setTimeZone (AcDb::TimeZone tz)
Acad::ErrorStatus | setTimeZoneAsUtcOffset (double offset)
Acad::ErrorStatus | setTracewid (double width)
Acad::ErrorStatus | setTreedepth (Adesk::Int16 depth)
Acad::ErrorStatus | setTStackAlign (int val)
Acad::ErrorStatus | setTStackSize (int val)
Acad::ErrorStatus | setUcsBase (AcDbObjectId ucsid)
Acad::ErrorStatus | setUnitmode (Adesk::Int16 mode)
Acad::ErrorStatus | setUseri1 (Adesk::Int16 val)
Acad::ErrorStatus | setUseri2 (Adesk::Int16 val)
Acad::ErrorStatus | setUseri3 (Adesk::Int16 val)
Acad::ErrorStatus | setUseri4 (Adesk::Int16 val)
Acad::ErrorStatus | setUseri5 (Adesk::Int16 val)
Acad::ErrorStatus | setUserr1 (double val)
Acad::ErrorStatus | setUserr2 (double val)
Acad::ErrorStatus | setUserr3 (double val)
Acad::ErrorStatus | setUserr4 (double val)
Acad::ErrorStatus | setUserr5 (double val)
Acad::ErrorStatus | setUsrtimer (bool timer)
Acad::ErrorStatus | setVersionGuid (const ACHAR *pNewGuid)
Acad::ErrorStatus | setViewportScaleDefault (double newDefaultVPScale)
Acad::ErrorStatus | setVisretain (bool retain)
Acad::ErrorStatus | setWorldPucsBaseOrigin (const AcGePoint3d &origin, AcDb::OrthographicView orthoView)
Acad::ErrorStatus | setWorldUcsBaseOrigin (const AcGePoint3d &origin, AcDb::OrthographicView orthoView)
Acad::ErrorStatus | setWorldview (bool view)
Acad::ErrorStatus | setXclipFrame (bool disp)
Acad::ErrorStatus | setXrefEditEnabled (bool enable)
Adesk::Int16 | shadedge () const
Adesk::Int16 | shadedif () const
double | shadowPlaneLocation () const
Adesk::UInt8 | showHist () const
double | sketchinc () const
bool | skpoly () const
Adesk::UInt8 | solidHist () const
Adesk::UInt8 | sortEnts () const
bool | splframe () const
Adesk::Int16 | splinesegs () const
Adesk::Int16 | splinetype () const
double | stepSize () const
double | stepsPerSec () const
Adesk::Int16 | surftab1 () const
Adesk::Int16 | surftab2 () const
Adesk::Int16 | surftype () const
Adesk::Int16 | surfu () const
Adesk::Int16 | surfv () const
AcDbObjectId | tablestyle () const
AcDbObjectId | tableStyleDictionaryId () const
const AcDbDate | tdcreate () const
const AcDbDate | tdindwg () const
const AcDbDate | tducreate () const
const AcDbDate | tdupdate () const
const AcDbDate | tdusrtimer () const
const AcDbDate | tduupdate () const
double | textsize () const
AcDbObjectId | textstyle () const
AcDbObjectId | textStyleTableId ()
double | thickness () const
void * | thumbnailBitmap () const
bool | tilemode () const
Adesk::UInt8 | tileModeLightSynch () const
AcDb::TimeZone | timeZone () const
double | tracewid () const
AcDbTransactionManager * | transactionManager () const
Adesk::Int16 | treedepth () const
int | tstackalign () const
int | tstacksize () const
AcDbObjectId | ucsBase () const
AcDbObjectId | ucsname () const
AcGePoint3d | ucsorg () const
AcDbObjectId | UCSTableId ()
AcGeVector3d | ucsxdir () const
AcGeVector3d | ucsydir () const
AcDbUndoController * | undoController () const
bool | undoRecording () const
Adesk::Int16 | unitmode () const
Acad::ErrorStatus | updateDataLink (AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
Acad::ErrorStatus | updateExt (bool doBestFit=FALSE)
Adesk::Int16 | useri1 () const
Adesk::Int16 | useri2 () const
Adesk::Int16 | useri3 () const
Adesk::Int16 | useri4 () const
Adesk::Int16 | useri5 () const
double | userr1 () const
double | userr2 () const
double | userr3 () const
double | userr4 () const
double | userr5 () const
bool | usrtimer () const
double | viewportScaleDefault () const
AcDbObjectId | viewportTableId ()
AcDbObjectId | viewTableId ()
bool | visretain () const
AcDbObjectId | visualStyleDictionaryId ()
Acad::ErrorStatus | wblock (AcDbDatabase *&pOutputDb, const AcDbObjectIdArray &outObjIds, const AcGePoint3d &basePoint)
Acad::ErrorStatus | wblock (AcDbDatabase *pOutputDb, const AcDbObjectIdArray &outObjIds, const AcGePoint3d &basePoint, AcDb::DuplicateRecordCloning drc)
Acad::ErrorStatus | wblock (AcDbDatabase *&pOutputDb, AcDbObjectId blockId)
Acad::ErrorStatus | wblock (AcDbDatabase *&pOutputDb)
Acad::ErrorStatus | wblockCloneObjects (AcDbObjectIdArray &objectIds, AcDbObjectId &owner, AcDbIdMapping &idMap, AcDb::DuplicateRecordCloning drc, bool deferXlation=false)
AcGePoint3d | worldPucsBaseOrigin (AcDb::OrthographicView orthoView) const
AcGePoint3d | worldUcsBaseOrigin (AcDb::OrthographicView orthoView) const
bool | worldview () const
bool | xclipFrame () const
AcDbObjectId | xrefBlockId () const
bool | xrefEditEnabled () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static void | disposeSecurityParams (const SecurityParams *pSecParams)
static AcDb::LineWeight | getNearestLineWeight (int weight)
static bool | isObjectNonPersistent (AcDbObjectId id)
static bool | isValidLineWeight (int weight)
static Acad::ErrorStatus | markObjectNonPersistent (AcDbObjectId id, bool value)
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Friends

class AcDbSystemInternals

Member Function Documentation

bool AcDbDatabase::annoAllVisible ( ) const
Warning
Not implemented!
bool AcDbDatabase::annotativeDwg ( ) const
Warning
Not implemented!
bool AcDbDatabase::cameraDisplay ( ) const
Warning
Not implemented!
double AcDbDatabase::cameraHeight ( ) const
Warning
Not implemented!
AcDbAnnotationScale* AcDbDatabase::cannoscale ( ) const
Warning
Not implemented!
AcDbObjectId AcDbDatabase::cmaterial ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbDatabase::cshadow ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbDatabase::dgnframe ( ) const
Warning
Not implemented!
AcDbObjectId AcDbDatabase::dragVisStyle ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbDatabase::dwfframe ( ) const
Warning
Not implemented!
Adesk::Int16 AcDbDatabase::dxeVal ( ) const
Warning
Not implemented!
double AcDbDatabase::get3dDwfPrec ( ) const
Warning
Not implemented!
AcDbObjectId AcDbDatabase::getSectionManager ( void ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::getSectionManager | ( | AcDbSectionManager *& | pMgr,
 |  | AcDb::OpenMode | mode
 | ) |  | const
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::getTimeZoneInfo | ( | AcDb::TimeZone | tz,
 |  | double & | offset,
 |  | AcString & | desc
 | ) |  | const
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::getVisualStyleDictionary | ( | AcDbDictionary *& | pDict,
 |  | AcDb::OpenMode | mode
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::getVisualStyleList ( AcArray< const ACHAR * > & vstyleList )
Warning
Not implemented!
AcGsModel* AcDbDatabase::gsHighlightModel ( ) const
Warning
Not implemented!
bool AcDbDatabase::hpInherit ( ) const
Warning
Not implemented!
AcGePoint2d AcDbDatabase::hpOrigin ( ) const
Warning
Not implemented!
AcCmColor AcDbDatabase::interfereColor ( ) const
Warning
Not implemented!
AcDbObjectId AcDbDatabase::interfereObjVisStyle ( ) const
Warning
Not implemented!
AcDbObjectId AcDbDatabase::interfereVpVisStyle ( ) const
Warning
Not implemented!
double AcDbDatabase::latitude ( ) const
Warning
Not implemented!
double AcDbDatabase::lensLength ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbDatabase::lightGlyphDisplay ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbDatabase::lightingUnits ( ) const
Warning
Not implemented!
bool AcDbDatabase::lightsInBlocks ( ) const
Warning
Not implemented!
double AcDbDatabase::loftAng1 ( ) const
Warning
Not implemented!
double AcDbDatabase::loftAng2 ( ) const
Warning
Not implemented!
double AcDbDatabase::loftMag1 ( ) const
Warning
Not implemented!
double AcDbDatabase::loftMag2 ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbDatabase::loftNormals ( ) const
Warning
Not implemented!
Adesk::UInt16 AcDbDatabase::loftParam ( ) const
Warning
Not implemented!
double AcDbDatabase::longitude ( ) const
Warning
Not implemented!
bool AcDbDatabase::msltscale ( ) const
Warning
Not implemented!
double AcDbDatabase::northDirection ( ) const
Warning
Not implemented!
double AcDbDatabase::psolHeight ( ) const
Warning
Not implemented!
double AcDbDatabase::psolWidth ( ) const
Warning
Not implemented!
bool AcDbDatabase::realWorldScale ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::set3dDwfPrec ( double DwfPrec )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setAnnoAllVisible ( bool allvis )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setAnnotativeDwg ( bool ao )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setCameraDisplay ( const bool cameraDisplay )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setCameraHeight ( const double cameraHeight )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setCannoscale ( AcDbAnnotationScale * )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setCmaterial ( AcDbObjectId objId )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setCshadow ( Adesk::UInt8 val )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setDgnframe ( Adesk::UInt8 )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setDragVisStyle ( AcDbObjectId id )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setDwfframe ( Adesk::UInt8 )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setDxeVal ( Adesk::Int16 val )
Warning
Not implemented!
void AcDbDatabase::setGsHighlightModel ( AcGsModel * )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setHpInherit ( const bool inherit )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setHpOrigin ( const AcGePoint2d & origin )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setInterfereColor ( const AcCmColor & color )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setInterfereObjVisStyle ( AcDbObjectId id )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setInterfereVpVisStyle ( AcDbObjectId id )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLatitude ( double lat )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLensLength ( const double lensLength )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLightGlyphDisplay ( Adesk::UInt8 val )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLightingUnits ( Adesk::UInt8 val )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLightsInBlocks ( bool val )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLoftAng1 ( double ang1 )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLoftAng2 ( double ang2 )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLoftMag1 ( double mag1 )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLoftMag2 ( double mag2 )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLoftNormals ( Adesk::UInt8 value )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLoftParam ( Adesk::UInt16 flags )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setLongitude ( double lng )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setMsltscale ( bool val )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setNorthDirection ( double northdir )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setPsolHeight ( double height )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setPsolWidth ( double width )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setRealWorldScale ( const bool realWorldScale )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setShadowPlaneLocation ( double val )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setShowHist ( Adesk::UInt8 val )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setSolidHist ( Adesk::UInt8 val )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setStepSize ( double stepSize )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setStepsPerSec ( double stepsPerSec )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setTileModeLightSynch ( Adesk::UInt8 val )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setTimeZone ( AcDb::TimeZone tz )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setTimeZoneAsUtcOffset ( double offset )
Warning
Not implemented!
Acad::ErrorStatus AcDbDatabase::setXclipFrame ( bool disp )
Warning
Not implemented!
double AcDbDatabase::shadowPlaneLocation ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbDatabase::showHist ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbDatabase::solidHist ( ) const
Warning
Not implemented!
double AcDbDatabase::stepSize ( ) const
Warning
Not implemented!
double AcDbDatabase::stepsPerSec ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbDatabase::tileModeLightSynch ( ) const
Warning
Not implemented!
AcDb::TimeZone AcDbDatabase::timeZone ( ) const
Warning
Not implemented!
bool AcDbDatabase::xclipFrame ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDatabase Member List

This is the complete list of members for AcDbDatabase, including all inherited members.

abortDeepClone(AcDbIdMapping &idMap) (defined in AcDbDatabase) | AcDbDatabase |
AcDbDatabase(bool buildDefaultDrawing=true, bool noDocument=false) (defined in AcDbDatabase) | AcDbDatabase |
AcDbSystemInternals (defined in AcDbDatabase) | AcDbDatabase | friend
ACRX_DECLARE_MEMBERS(AcDbDatabase) (defined in AcDbDatabase) | AcDbDatabase |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addAcDbObject(AcDbObject *pObj) (defined in AcDbDatabase) | AcDbDatabase |
addAcDbObject(AcDbObjectId &objId, AcDbObject *pObj) (defined in AcDbDatabase) | AcDbDatabase |
addReactor(AcDbDatabaseReactor *pReactor) const (defined in AcDbDatabase) | AcDbDatabase |
angbase() const (defined in AcDbDatabase) | AcDbDatabase |
angdir() const (defined in AcDbDatabase) | AcDbDatabase |
annoAllVisible() const | AcDbDatabase |
annotativeDwg() const | AcDbDatabase |
applyPartialOpenFilters(const AcDbSpatialFilter *pSpatialFilter, const AcDbLayerFilter *pLayerFilter) (defined in AcDbDatabase) | AcDbDatabase |
approxNumObjects() const (defined in AcDbDatabase) | AcDbDatabase |
attdia() const (defined in AcDbDatabase) | AcDbDatabase |
attmode() const (defined in AcDbDatabase) | AcDbDatabase |
attreq() const (defined in AcDbDatabase) | AcDbDatabase |
audit(AcDbAuditInfo *pInfo) (defined in AcDbDatabase) | AcDbDatabase |
auditXData(AcDbAuditInfo *pInfo) (defined in AcDbDatabase) | AcDbDatabase |
aunits() const (defined in AcDbDatabase) | AcDbDatabase |
auprec() const (defined in AcDbDatabase) | AcDbDatabase |
blipmode() const (defined in AcDbDatabase) | AcDbDatabase |
blockTableId() (defined in AcDbDatabase) | AcDbDatabase |
byBlockLinetype() const (defined in AcDbDatabase) | AcDbDatabase |
byBlockMaterial() const (defined in AcDbDatabase) | AcDbDatabase |
byLayerLinetype() const (defined in AcDbDatabase) | AcDbDatabase |
byLayerMaterial() const (defined in AcDbDatabase) | AcDbDatabase |
cameraDisplay() const | AcDbDatabase |
cameraHeight() const | AcDbDatabase |
cannoscale() const | AcDbDatabase |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
cecolor() const (defined in AcDbDatabase) | AcDbDatabase |
celtscale() const (defined in AcDbDatabase) | AcDbDatabase |
celtype() const (defined in AcDbDatabase) | AcDbDatabase |
celweight() const (defined in AcDbDatabase) | AcDbDatabase |
chamfera() const (defined in AcDbDatabase) | AcDbDatabase |
chamferb() const (defined in AcDbDatabase) | AcDbDatabase |
chamferc() const (defined in AcDbDatabase) | AcDbDatabase |
chamferd() const (defined in AcDbDatabase) | AcDbDatabase |
classDxfName(const AcRxClass *pClass) (defined in AcDbDatabase) | AcDbDatabase |
clayer() const (defined in AcDbDatabase) | AcDbDatabase |
clone() const (defined in AcRxObject) | AcRxObject | virtual
cloneSecurityParams() (defined in AcDbDatabase) | AcDbDatabase |
closeInput(bool bCloseFile=false) (defined in AcDbDatabase) | AcDbDatabase |
cmaterial() const | AcDbDatabase |
cmljust() const (defined in AcDbDatabase) | AcDbDatabase |
cmlscale() const (defined in AcDbDatabase) | AcDbDatabase |
cmlstyleID() const (defined in AcDbDatabase) | AcDbDatabase |
colorDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
continuousLinetype() const (defined in AcDbDatabase) | AcDbDatabase |
coords() const (defined in AcDbDatabase) | AcDbDatabase |
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
countHardReferences(const AcDbObjectIdArray &ids, Adesk::UInt32 *pCount) (defined in AcDbDatabase) | AcDbDatabase |
cshadow() const | AcDbDatabase |
currentSpaceId() const (defined in AcDbDatabase) | AcDbDatabase |
dataLinkDictionaryId(void) const (defined in AcDbDatabase) | AcDbDatabase |
deepCloneObjects(AcDbObjectIdArray &objectIds, AcDbObjectId &owner, AcDbIdMapping &idMap, bool deferXlation=false) (defined in AcDbDatabase) | AcDbDatabase |
delUsedObj() const (defined in AcDbDatabase) | AcDbDatabase |
desc() (defined in AcRxObject) | AcRxObject | static
dgnframe() const | AcDbDatabase |
dimaso() const (defined in AcDbDatabase) | AcDbDatabase |
dimAssoc() const (defined in AcDbDatabase) | AcDbDatabase |
dimfit() const (defined in AcDbDatabase) | AcDbDatabase |
dimsho() const (defined in AcDbDatabase) | AcDbDatabase |
dimstyle() const (defined in AcDbDatabase) | AcDbDatabase |
dimStyleTableId() (defined in AcDbDatabase) | AcDbDatabase |
dimunit() const (defined in AcDbDatabase) | AcDbDatabase |
disablePartialOpen() (defined in AcDbDatabase) | AcDbDatabase |
disableUndoRecording(bool disable) (defined in AcDbDatabase) | AcDbDatabase |
disposeSecurityParams(const SecurityParams *pSecParams) (defined in AcDbDatabase) | AcDbDatabase | static
dispSilh() const (defined in AcDbDatabase) | AcDbDatabase |
dragmode() const (defined in AcDbDatabase) | AcDbDatabase |
dragVisStyle() const | AcDbDatabase |
drawOrderCtl() const (defined in AcDbDatabase) | AcDbDatabase |
dwfframe() const | AcDbDatabase |
dwgFileWasSavedByAutodeskSoftware() const (defined in AcDbDatabase) | AcDbDatabase |
dxeVal() const | AcDbDatabase |
dxfIn(const ACHAR *dxfFilename, const ACHAR *logFilename=NULL) (defined in AcDbDatabase) | AcDbDatabase |
dxfOut(const ACHAR *fileName, int precision=16, AcDb::AcDbDwgVersion dwgVer=AcDb::kDHL_CURRENT, bool saveThumbnailImage=false) (defined in AcDbDatabase) | AcDbDatabase |
elevation() const (defined in AcDbDatabase) | AcDbDatabase |
endCaps() const (defined in AcDbDatabase) | AcDbDatabase |
evaluateFields(int nContext, const ACHAR *pszPropName=NULL, AcDbDatabase *pDb=NULL, int *pNumFound=NULL, int *pNumEvaluated=NULL) (defined in AcDbDatabase) | AcDbDatabase |
extmax() const (defined in AcDbDatabase) | AcDbDatabase |
extmin() const (defined in AcDbDatabase) | AcDbDatabase |
facetres() const (defined in AcDbDatabase) | AcDbDatabase |
fileDependencyManager() const (defined in AcDbDatabase) | AcDbDatabase |
filletrad() const (defined in AcDbDatabase) | AcDbDatabase |
fillmode() const (defined in AcDbDatabase) | AcDbDatabase |
forceWblockDatabaseCopy() (defined in AcDbDatabase) | AcDbDatabase |
get3dDwfPrec() const | AcDbDatabase |
getAcDbObjectId(AcDbObjectId &retId, bool createIfNotFound, const AcDbHandle &objHandle, Adesk::UInt32 xRefId=0) (defined in AcDbDatabase) | AcDbDatabase |
getBlockTable(AcDbSymbolTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getBlockTable(AcDbBlockTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase | inline
getCePlotStyleNameId(AcDbObjectId &id) const (defined in AcDbDatabase) | AcDbDatabase |
getColorDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getDataLinkDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getDataLinkManager(void) const (defined in AcDbDatabase) | AcDbDatabase |
getDimapost(ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getDimblk(ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getDimblk1(ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getDimblk2(ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getDimpost(ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getDimRecentStyleList(AcDbObjectIdArray &objIds) const (defined in AcDbDatabase) | AcDbDatabase |
getDimstyleChildData(const AcRxClass *pDimClass, AcDbDimStyleTableRecord *&pRec, AcDbObjectId &style) const (defined in AcDbDatabase) | AcDbDatabase |
getDimstyleChildId(const AcRxClass *pDimClass, AcDbObjectId &parentStyle) const (defined in AcDbDatabase) | AcDbDatabase |
getDimstyleData(AcDbDimStyleTableRecord *&pRec) const (defined in AcDbDatabase) | AcDbDatabase |
getDimstyleParentId(AcDbObjectId &childStyle) const (defined in AcDbDatabase) | AcDbDatabase |
getDimStyleTable(AcDbSymbolTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getDimStyleTable(AcDbDimStyleTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase | inline
getFilename(const ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getFingerprintGuid(ACHAR *&guidString) const (defined in AcDbDatabase) | AcDbDatabase |
getGroupDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getHyperlinkBase(ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getLayerStateManager() const (defined in AcDbDatabase) | AcDbDatabase |
getLayerTable(AcDbSymbolTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getLayerTable(AcDbLayerTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase | inline
getLayoutDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getLinetypeTable(AcDbSymbolTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getLinetypeTable(AcDbLinetypeTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase | inline
getMaterialDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getMenu(ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getMLeaderStyleDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getMLStyleDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getNamedObjectsDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getNearestLineWeight(int weight) (defined in AcDbDatabase) | AcDbDatabase | static
getPlotSettingsDictionary(AcDbDictionary *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getPlotStyleNameDictionary(AcDbDictionaryWithDefault *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getProjectName(ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getRegAppTable(AcDbSymbolTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getRegAppTable(AcDbRegAppTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase | inline
getScaleListDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getSectionManager(void) const | AcDbDatabase |
getSectionManager(AcDbSectionManager *&pMgr, AcDb::OpenMode mode) const | AcDbDatabase |
getStyleSheet(ACHAR *&pOutput) const (defined in AcDbDatabase) | AcDbDatabase |
getSymbolTable(AcDbBlockTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getSymbolTable(AcDbLayerTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getSymbolTable(AcDbTextStyleTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getSymbolTable(AcDbLinetypeTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getSymbolTable(AcDbViewTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getSymbolTable(AcDbUCSTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getSymbolTable(AcDbViewportTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getSymbolTable(AcDbRegAppTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getSymbolTable(AcDbDimStyleTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getTableStyleDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getTextStyleTable(AcDbSymbolTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getTextStyleTable(AcDbTextStyleTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase | inline
getTimeZoneInfo(AcDb::TimeZone tz, double &offset, AcString &desc) const | AcDbDatabase |
getUCSTable(AcDbSymbolTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getUCSTable(AcDbUCSTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase | inline
getVersionGuid(ACHAR *&guidString) const (defined in AcDbDatabase) | AcDbDatabase |
getViewportArray(AcDbObjectIdArray &vportIds, bool bGetPaperspaceVports=true) const (defined in AcDbDatabase) | AcDbDatabase |
getViewportTable(AcDbSymbolTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getViewportTable(AcDbViewportTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase | inline
getViewTable(AcDbSymbolTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase |
getViewTable(AcDbViewTable *&pTable, AcDb::OpenMode mode) (defined in AcDbDatabase) | AcDbDatabase | inline
getVisualStyleDictionary(AcDbDictionary *&pDict, AcDb::OpenMode mode) | AcDbDatabase |
getVisualStyleList(AcArray< const ACHAR * > &vstyleList) | AcDbDatabase |
globalMaterial() const (defined in AcDbDatabase) | AcDbDatabase |
groupDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
gsHighlightModel() const | AcDbDatabase |
gsModel() const (defined in AcDbDatabase) | AcDbDatabase |
haloGap() const (defined in AcDbDatabase) | AcDbDatabase |
handseed() const (defined in AcDbDatabase) | AcDbDatabase |
hideText() const (defined in AcDbDatabase) | AcDbDatabase |
hpInherit() const | AcDbDatabase |
hpOrigin() const | AcDbDatabase |
inputFiler() const (defined in AcDbDatabase) | AcDbDatabase |
insbase() const (defined in AcDbDatabase) | AcDbDatabase |
insert(AcDbObjectId &blockId, const ACHAR *pBlockName, AcDbDatabase *pDb, bool preserveSourceDatabase=true) (defined in AcDbDatabase) | AcDbDatabase |
insert(const AcGeMatrix3d &xform, AcDbDatabase *pDb, bool preserveSourceDatabase=true) (defined in AcDbDatabase) | AcDbDatabase |
insert(AcDbObjectId &blockId, const ACHAR *pSourceBlockName, const ACHAR *pDestinationBlockName, AcDbDatabase *pDb, bool preserveSourceDatabase=true) (defined in AcDbDatabase) | AcDbDatabase |
insunits() const (defined in AcDbDatabase) | AcDbDatabase |
interfereColor() const | AcDbDatabase |
interfereObjVisStyle() const | AcDbDatabase |
interfereVpVisStyle() const | AcDbDatabase |
intersectColor() const (defined in AcDbDatabase) | AcDbDatabase |
intersectDisplay() const (defined in AcDbDatabase) | AcDbDatabase |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEMR() const (defined in AcDbDatabase) | AcDbDatabase |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isObjectNonPersistent(AcDbObjectId id) (defined in AcDbDatabase) | AcDbDatabase | static
isolines() const (defined in AcDbDatabase) | AcDbDatabase |
isPartiallyOpened() const (defined in AcDbDatabase) | AcDbDatabase |
isPucsOrthographic(AcDb::OrthographicView &orthoView) const (defined in AcDbDatabase) | AcDbDatabase |
isUcsOrthographic(AcDb::OrthographicView &orthoView) const (defined in AcDbDatabase) | AcDbDatabase |
isValidLineWeight(int weight) (defined in AcDbDatabase) | AcDbDatabase | static
joinStyle() const (defined in AcDbDatabase) | AcDbDatabase |
kForReadAndAllShare enum value (defined in AcDbDatabase) | AcDbDatabase |
kForReadAndReadShare enum value (defined in AcDbDatabase) | AcDbDatabase |
kForReadAndWriteNoShare enum value (defined in AcDbDatabase) | AcDbDatabase |
kTryForReadShare enum value (defined in AcDbDatabase) | AcDbDatabase |
lastSavedAsMaintenanceVersion() const (defined in AcDbDatabase) | AcDbDatabase |
lastSavedAsVersion() const (defined in AcDbDatabase) | AcDbDatabase |
latitude() const | AcDbDatabase |
layerTableId() (defined in AcDbDatabase) | AcDbDatabase |
layerZero() const (defined in AcDbDatabase) | AcDbDatabase |
layoutDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
lensLength() const | AcDbDatabase |
lightGlyphDisplay() const | AcDbDatabase |
lightingUnits() const | AcDbDatabase |
lightsInBlocks() const | AcDbDatabase |
limcheck() const (defined in AcDbDatabase) | AcDbDatabase |
limmax() const (defined in AcDbDatabase) | AcDbDatabase |
limmin() const (defined in AcDbDatabase) | AcDbDatabase |
linetypeTableId() (defined in AcDbDatabase) | AcDbDatabase |
lineWeightDisplay() const (defined in AcDbDatabase) | AcDbDatabase |
loadLineTypeFile(const ACHAR *ltn, const ACHAR *filename) (defined in AcDbDatabase) | AcDbDatabase |
loftAng1() const | AcDbDatabase |
loftAng2() const | AcDbDatabase |
loftMag1() const | AcDbDatabase |
loftMag2() const | AcDbDatabase |
loftNormals() const | AcDbDatabase |
loftParam() const | AcDbDatabase |
longitude() const | AcDbDatabase |
ltscale() const (defined in AcDbDatabase) | AcDbDatabase |
lunits() const (defined in AcDbDatabase) | AcDbDatabase |
luprec() const (defined in AcDbDatabase) | AcDbDatabase |
maintenanceReleaseVersion() const (defined in AcDbDatabase) | AcDbDatabase |
markObjectNonPersistent(AcDbObjectId id, bool value) (defined in AcDbDatabase) | AcDbDatabase | static
materialDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
maxactvp() const (defined in AcDbDatabase) | AcDbDatabase |
measurement() const (defined in AcDbDatabase) | AcDbDatabase |
mirrtext() const (defined in AcDbDatabase) | AcDbDatabase |
mleaderstyle() const (defined in AcDbDatabase) | AcDbDatabase |
mleaderStyleDictionaryId() const (defined in AcDbDatabase) | AcDbDatabase |
mLStyleDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
msltscale() const | AcDbDatabase |
namedObjectsDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
northDirection() const | AcDbDatabase |
numberOfSaves() const (defined in AcDbDatabase) | AcDbDatabase |
objectContextManager() const (defined in AcDbDatabase) | AcDbDatabase |
obscuredColor() const (defined in AcDbDatabase) | AcDbDatabase |
obscuredLineType() const (defined in AcDbDatabase) | AcDbDatabase |
oleStartUp() const (defined in AcDbDatabase) | AcDbDatabase |
OpenMode enum name (defined in AcDbDatabase) | AcDbDatabase |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
originalFileMaintenanceVersion() const (defined in AcDbDatabase) | AcDbDatabase |
originalFileName() const (defined in AcDbDatabase) | AcDbDatabase |
originalFileSavedByMaintenanceVersion() const (defined in AcDbDatabase) | AcDbDatabase |
originalFileSavedByVersion() const (defined in AcDbDatabase) | AcDbDatabase |
originalFileVersion() const (defined in AcDbDatabase) | AcDbDatabase |
orthomode() const (defined in AcDbDatabase) | AcDbDatabase |
paperSpaceVportId() const (defined in AcDbDatabase) | AcDbDatabase |
pdmode() const (defined in AcDbDatabase) | AcDbDatabase |
pdsize() const (defined in AcDbDatabase) | AcDbDatabase |
pelevation() const (defined in AcDbDatabase) | AcDbDatabase |
pextmax() const (defined in AcDbDatabase) | AcDbDatabase |
pextmin() const (defined in AcDbDatabase) | AcDbDatabase |
pickstyle() const (defined in AcDbDatabase) | AcDbDatabase |
pinsbase() const (defined in AcDbDatabase) | AcDbDatabase |
plimcheck() const (defined in AcDbDatabase) | AcDbDatabase |
plimmax() const (defined in AcDbDatabase) | AcDbDatabase |
plimmin() const (defined in AcDbDatabase) | AcDbDatabase |
plineEllipse() const (defined in AcDbDatabase) | AcDbDatabase |
plinegen() const (defined in AcDbDatabase) | AcDbDatabase |
plinewid() const (defined in AcDbDatabase) | AcDbDatabase |
plotSettingsDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
plotStyleMode() const (defined in AcDbDatabase) | AcDbDatabase |
plotStyleNameDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
psltscale() const (defined in AcDbDatabase) | AcDbDatabase |
psolHeight() const | AcDbDatabase |
psolWidth() const | AcDbDatabase |
pucsBase() const (defined in AcDbDatabase) | AcDbDatabase |
pucsname() const (defined in AcDbDatabase) | AcDbDatabase |
pucsorg() const (defined in AcDbDatabase) | AcDbDatabase |
pucsxdir() const (defined in AcDbDatabase) | AcDbDatabase |
pucsydir() const (defined in AcDbDatabase) | AcDbDatabase |
purge(AcDbObjectIdArray &ids) (defined in AcDbDatabase) | AcDbDatabase |
purge(AcDbObjectIdGraph &idGraph) (defined in AcDbDatabase) | AcDbDatabase |
qtextmode() const (defined in AcDbDatabase) | AcDbDatabase |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readDwgFile(const ACHAR *fileName, OpenMode openmode, bool bAllowCPConversion=false, const wchar_t *wszPassword=NULL) (defined in AcDbDatabase) | AcDbDatabase |
readDwgFile(const ACHAR *fileName, const int shmode=_SH_DENYWR, bool bAllowCPConversion=false, const wchar_t *wszPassword=NULL) (defined in AcDbDatabase) | AcDbDatabase |
readDwgFile(AcDwgFileHandle *pDwgFile, bool bAllowCPConversion=false, const wchar_t *wszPassword=NULL) (defined in AcDbDatabase) | AcDbDatabase |
realWorldScale() const | AcDbDatabase |
reclaimMemoryFromErasedObjects(const AcDbObjectIdArray &erasedObjects) (defined in AcDbDatabase) | AcDbDatabase |
regAppTableId() (defined in AcDbDatabase) | AcDbDatabase |
regenmode() const (defined in AcDbDatabase) | AcDbDatabase |
removeReactor(AcDbDatabaseReactor *pReactor) const (defined in AcDbDatabase) | AcDbDatabase |
restoreForwardingXrefSymbols() (defined in AcDbDatabase) | AcDbDatabase |
restoreOriginalXrefSymbols() (defined in AcDbDatabase) | AcDbDatabase |
retainOriginalThumbnailBitmap() const (defined in AcDbDatabase) | AcDbDatabase |
save() (defined in AcDbDatabase) | AcDbDatabase |
saveAs(const ACHAR *fileName, const SecurityParams *pSecParams=0) (defined in AcDbDatabase) | AcDbDatabase | inline
saveAs(const ACHAR *fileName, const bool bBakAndRename, const AcDb::AcDbDwgVersion dwgVer=AcDb::kDHL_CURRENT, const SecurityParams *pSecParams=0) (defined in AcDbDatabase) | AcDbDatabase |
saveproxygraphics() const (defined in AcDbDatabase) | AcDbDatabase |
scaleListDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
set3dDwfPrec(double DwfPrec) | AcDbDatabase |
setAngbase(double angle) (defined in AcDbDatabase) | AcDbDatabase |
setAngdir(bool dir) (defined in AcDbDatabase) | AcDbDatabase |
setAnnoAllVisible(bool allvis) | AcDbDatabase |
setAnnotativeDwg(bool ao) | AcDbDatabase |
setAttdia(bool dia) (defined in AcDbDatabase) | AcDbDatabase |
setAttmode(Adesk::Int16 mode) (defined in AcDbDatabase) | AcDbDatabase |
setAttreq(bool req) (defined in AcDbDatabase) | AcDbDatabase |
setAunits(Adesk::Int16 aunits) (defined in AcDbDatabase) | AcDbDatabase |
setAuprec(Adesk::Int16 auprec) (defined in AcDbDatabase) | AcDbDatabase |
setBlipmode(bool mode) (defined in AcDbDatabase) | AcDbDatabase |
setCameraDisplay(const bool cameraDisplay) | AcDbDatabase |
setCameraHeight(const double cameraHeight) | AcDbDatabase |
setCannoscale(AcDbAnnotationScale *) | AcDbDatabase |
setCecolor(const AcCmColor &color) (defined in AcDbDatabase) | AcDbDatabase |
setCeltscale(double scale) (defined in AcDbDatabase) | AcDbDatabase |
setCeltype(AcDbObjectId objId) (defined in AcDbDatabase) | AcDbDatabase |
setCelweight(AcDb::LineWeight weight) (defined in AcDbDatabase) | AcDbDatabase |
setCePlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull) (defined in AcDbDatabase) | AcDbDatabase |
setChamfera(double val) (defined in AcDbDatabase) | AcDbDatabase |
setChamferb(double val) (defined in AcDbDatabase) | AcDbDatabase |
setChamferc(double val) (defined in AcDbDatabase) | AcDbDatabase |
setChamferd(double val) (defined in AcDbDatabase) | AcDbDatabase |
setClayer(AcDbObjectId objId) (defined in AcDbDatabase) | AcDbDatabase |
setCmaterial(AcDbObjectId objId) | AcDbDatabase |
setCmljust(Adesk::Int16 just) (defined in AcDbDatabase) | AcDbDatabase |
setCmlscale(double scale) (defined in AcDbDatabase) | AcDbDatabase |
setCmlstyleID(AcDbObjectId objId) (defined in AcDbDatabase) | AcDbDatabase |
setCoords(Adesk::Int16 coords) (defined in AcDbDatabase) | AcDbDatabase |
setCshadow(Adesk::UInt8 val) | AcDbDatabase |
setDelUsedObj(Adesk::Int16 deleteObj) (defined in AcDbDatabase) | AcDbDatabase |
setDgnframe(Adesk::UInt8) | AcDbDatabase |
setDimaso(bool aso) (defined in AcDbDatabase) | AcDbDatabase |
setDimAssoc(Adesk::UInt8 val) (defined in AcDbDatabase) | AcDbDatabase |
setDimfit(int fit) (defined in AcDbDatabase) | AcDbDatabase |
setDimsho(bool sho) (defined in AcDbDatabase) | AcDbDatabase |
setDimstyle(AcDbObjectId styleId) (defined in AcDbDatabase) | AcDbDatabase |
setDimstyleData(AcDbDimStyleTableRecord *pRec) (defined in AcDbDatabase) | AcDbDatabase |
setDimstyleData(AcDbObjectId id) (defined in AcDbDatabase) | AcDbDatabase |
setDimunit(int unit) (defined in AcDbDatabase) | AcDbDatabase |
setDispSilh(bool silh) (defined in AcDbDatabase) | AcDbDatabase |
setDragmode(Adesk::Int16 mode) (defined in AcDbDatabase) | AcDbDatabase |
setDragVisStyle(AcDbObjectId id) | AcDbDatabase |
setDrawOrderCtl(Adesk::UInt8 val) (defined in AcDbDatabase) | AcDbDatabase |
setDwfframe(Adesk::UInt8) | AcDbDatabase |
setDxeVal(Adesk::Int16 val) | AcDbDatabase |
setElevation(double elev) (defined in AcDbDatabase) | AcDbDatabase |
setEndCaps(AcDb::EndCaps type) (defined in AcDbDatabase) | AcDbDatabase |
setExtmax(const AcGePoint3d &max) (defined in AcDbDatabase) | AcDbDatabase |
setExtmin(const AcGePoint3d &min) (defined in AcDbDatabase) | AcDbDatabase |
setFacetres(double facetres) (defined in AcDbDatabase) | AcDbDatabase |
setFilletrad(double radius) (defined in AcDbDatabase) | AcDbDatabase |
setFillmode(bool mode) (defined in AcDbDatabase) | AcDbDatabase |
setFingerprintGuid(const ACHAR *pNewGuid) (defined in AcDbDatabase) | AcDbDatabase |
setGsHighlightModel(AcGsModel *) | AcDbDatabase |
setGsModel(AcGsModel *) (defined in AcDbDatabase) | AcDbDatabase |
setHaloGap(Adesk::UInt8 val) (defined in AcDbDatabase) | AcDbDatabase |
setHandseed(const AcDbHandle &handle) (defined in AcDbDatabase) | AcDbDatabase |
setHideText(Adesk::UInt8 val) (defined in AcDbDatabase) | AcDbDatabase |
setHpInherit(const bool inherit) | AcDbDatabase |
setHpOrigin(const AcGePoint2d &origin) | AcDbDatabase |
setHyperlinkBase(const ACHAR *) (defined in AcDbDatabase) | AcDbDatabase |
setInsbase(const AcGePoint3d &base) (defined in AcDbDatabase) | AcDbDatabase |
setInsunits(const AcDb::UnitsValue units) (defined in AcDbDatabase) | AcDbDatabase |
setInterfereColor(const AcCmColor &color) | AcDbDatabase |
setInterfereObjVisStyle(AcDbObjectId id) | AcDbDatabase |
setInterfereVpVisStyle(AcDbObjectId id) | AcDbDatabase |
setIntersectColor(Adesk::UInt16 val) (defined in AcDbDatabase) | AcDbDatabase |
setIntersectDisplay(Adesk::UInt8 val) (defined in AcDbDatabase) | AcDbDatabase |
setIsolines(Adesk::Int16 isolines) (defined in AcDbDatabase) | AcDbDatabase |
setJoinStyle(AcDb::JoinStyle style) (defined in AcDbDatabase) | AcDbDatabase |
setLatitude(double lat) | AcDbDatabase |
setLensLength(const double lensLength) | AcDbDatabase |
setLightGlyphDisplay(Adesk::UInt8 val) | AcDbDatabase |
setLightingUnits(Adesk::UInt8 val) | AcDbDatabase |
setLightsInBlocks(bool val) | AcDbDatabase |
setLimcheck(bool check) (defined in AcDbDatabase) | AcDbDatabase |
setLimmax(const AcGePoint2d &max) (defined in AcDbDatabase) | AcDbDatabase |
setLimmin(const AcGePoint2d &min) (defined in AcDbDatabase) | AcDbDatabase |
setLineWeightDisplay(bool display) (defined in AcDbDatabase) | AcDbDatabase |
setLoftAng1(double ang1) | AcDbDatabase |
setLoftAng2(double ang2) | AcDbDatabase |
setLoftMag1(double mag1) | AcDbDatabase |
setLoftMag2(double mag2) | AcDbDatabase |
setLoftNormals(Adesk::UInt8 value) | AcDbDatabase |
setLoftParam(Adesk::UInt16 flags) | AcDbDatabase |
setLongitude(double lng) | AcDbDatabase |
setLtscale(double scale) (defined in AcDbDatabase) | AcDbDatabase |
setLunits(Adesk::Int16 lunits) (defined in AcDbDatabase) | AcDbDatabase |
setLuprec(Adesk::Int16 prec) (defined in AcDbDatabase) | AcDbDatabase |
setMaxactvp(Adesk::Int16 max) (defined in AcDbDatabase) | AcDbDatabase |
setMeasurement(AcDb::MeasurementValue type) (defined in AcDbDatabase) | AcDbDatabase |
setMirrtext(bool mirror) (defined in AcDbDatabase) | AcDbDatabase |
setMLeaderstyle(AcDbObjectId objId) (defined in AcDbDatabase) | AcDbDatabase |
setMsltscale(bool val) | AcDbDatabase |
setNorthDirection(double northdir) | AcDbDatabase |
setObscuredColor(Adesk::UInt16 val) (defined in AcDbDatabase) | AcDbDatabase |
setObscuredLineType(Adesk::UInt8 val) (defined in AcDbDatabase) | AcDbDatabase |
setOleStartUp(bool val) (defined in AcDbDatabase) | AcDbDatabase |
setOrthomode(bool mode) (defined in AcDbDatabase) | AcDbDatabase |
setPdmode(Adesk::Int16 mode) (defined in AcDbDatabase) | AcDbDatabase |
setPdsize(double size) (defined in AcDbDatabase) | AcDbDatabase |
setPelevation(double elev) (defined in AcDbDatabase) | AcDbDatabase |
setPextmax(const AcGePoint3d &max) (defined in AcDbDatabase) | AcDbDatabase |
setPextmin(const AcGePoint3d &min) (defined in AcDbDatabase) | AcDbDatabase |
setPickstyle(Adesk::Int16 style) (defined in AcDbDatabase) | AcDbDatabase |
setPinsbase(const AcGePoint3d &base) (defined in AcDbDatabase) | AcDbDatabase |
setPlimcheck(bool check) (defined in AcDbDatabase) | AcDbDatabase |
setPlimmax(const AcGePoint2d &max) (defined in AcDbDatabase) | AcDbDatabase |
setPlimmin(const AcGePoint2d &min) (defined in AcDbDatabase) | AcDbDatabase |
setPlineEllipse(bool pline) (defined in AcDbDatabase) | AcDbDatabase |
setPlinegen(bool gen) (defined in AcDbDatabase) | AcDbDatabase |
setPlinewid(double width) (defined in AcDbDatabase) | AcDbDatabase |
setProjectName(const ACHAR *) (defined in AcDbDatabase) | AcDbDatabase |
setPsltscale(bool scale) (defined in AcDbDatabase) | AcDbDatabase |
setPsolHeight(double height) | AcDbDatabase |
setPsolWidth(double width) | AcDbDatabase |
setPucsBase(const AcDbObjectId &ucsid) (defined in AcDbDatabase) | AcDbDatabase |
setQtextmode(bool mode) (defined in AcDbDatabase) | AcDbDatabase |
setRealWorldScale(const bool realWorldScale) | AcDbDatabase |
setRegenmode(bool mode) (defined in AcDbDatabase) | AcDbDatabase |
setRetainOriginalThumbnailBitmap(bool retain) (defined in AcDbDatabase) | AcDbDatabase |
setSaveproxygraphics(Adesk::Int16 saveimg) (defined in AcDbDatabase) | AcDbDatabase |
setSecurityParams(const SecurityParams *pSecParams, bool bSetDbMod=true) (defined in AcDbDatabase) | AcDbDatabase |
setShadedge(Adesk::Int16 mode) (defined in AcDbDatabase) | AcDbDatabase |
setShadedif(Adesk::Int16 dif) (defined in AcDbDatabase) | AcDbDatabase |
setShadowPlaneLocation(double val) | AcDbDatabase |
setShowHist(Adesk::UInt8 val) | AcDbDatabase |
setSketchinc(double inc) (defined in AcDbDatabase) | AcDbDatabase |
setSkpoly(bool asPoly) (defined in AcDbDatabase) | AcDbDatabase |
setSolidHist(Adesk::UInt8 val) | AcDbDatabase |
setSortEnts(Adesk::UInt8 sortEnts) (defined in AcDbDatabase) | AcDbDatabase |
setSplframe(bool disp) (defined in AcDbDatabase) | AcDbDatabase |
setSplinesegs(Adesk::Int16 segs) (defined in AcDbDatabase) | AcDbDatabase |
setSplinetype(Adesk::Int16 type) (defined in AcDbDatabase) | AcDbDatabase |
setStepSize(double stepSize) | AcDbDatabase |
setStepsPerSec(double stepsPerSec) | AcDbDatabase |
setStyleSheet(const ACHAR *) (defined in AcDbDatabase) | AcDbDatabase |
setSurftab1(Adesk::Int16 tab1) (defined in AcDbDatabase) | AcDbDatabase |
setSurftab2(Adesk::Int16 tab2) (defined in AcDbDatabase) | AcDbDatabase |
setSurftype(Adesk::Int16 type) (defined in AcDbDatabase) | AcDbDatabase |
setSurfu(Adesk::Int16 u) (defined in AcDbDatabase) | AcDbDatabase |
setSurfv(Adesk::Int16 v) (defined in AcDbDatabase) | AcDbDatabase |
setTablestyle(AcDbObjectId objId) (defined in AcDbDatabase) | AcDbDatabase |
setTextsize(double size) (defined in AcDbDatabase) | AcDbDatabase |
setTextstyle(AcDbObjectId objId) (defined in AcDbDatabase) | AcDbDatabase |
setThickness(double thickness) (defined in AcDbDatabase) | AcDbDatabase |
setThumbnailBitmap(void *pBmp) (defined in AcDbDatabase) | AcDbDatabase |
setTilemode(bool mode) (defined in AcDbDatabase) | AcDbDatabase |
setTileModeLightSynch(Adesk::UInt8 val) | AcDbDatabase |
setTimeZone(AcDb::TimeZone tz) | AcDbDatabase |
setTimeZoneAsUtcOffset(double offset) | AcDbDatabase |
setTracewid(double width) (defined in AcDbDatabase) | AcDbDatabase |
setTreedepth(Adesk::Int16 depth) (defined in AcDbDatabase) | AcDbDatabase |
setTStackAlign(int val) (defined in AcDbDatabase) | AcDbDatabase |
setTStackSize(int val) (defined in AcDbDatabase) | AcDbDatabase |
setUcsBase(AcDbObjectId ucsid) (defined in AcDbDatabase) | AcDbDatabase |
setUnitmode(Adesk::Int16 mode) (defined in AcDbDatabase) | AcDbDatabase |
setUseri1(Adesk::Int16 val) (defined in AcDbDatabase) | AcDbDatabase |
setUseri2(Adesk::Int16 val) (defined in AcDbDatabase) | AcDbDatabase |
setUseri3(Adesk::Int16 val) (defined in AcDbDatabase) | AcDbDatabase |
setUseri4(Adesk::Int16 val) (defined in AcDbDatabase) | AcDbDatabase |
setUseri5(Adesk::Int16 val) (defined in AcDbDatabase) | AcDbDatabase |
setUserr1(double val) (defined in AcDbDatabase) | AcDbDatabase |
setUserr2(double val) (defined in AcDbDatabase) | AcDbDatabase |
setUserr3(double val) (defined in AcDbDatabase) | AcDbDatabase |
setUserr4(double val) (defined in AcDbDatabase) | AcDbDatabase |
setUserr5(double val) (defined in AcDbDatabase) | AcDbDatabase |
setUsrtimer(bool timer) (defined in AcDbDatabase) | AcDbDatabase |
setVersionGuid(const ACHAR *pNewGuid) (defined in AcDbDatabase) | AcDbDatabase |
setViewportScaleDefault(double newDefaultVPScale) (defined in AcDbDatabase) | AcDbDatabase |
setVisretain(bool retain) (defined in AcDbDatabase) | AcDbDatabase |
setWorldPucsBaseOrigin(const AcGePoint3d &origin, AcDb::OrthographicView orthoView) (defined in AcDbDatabase) | AcDbDatabase |
setWorldUcsBaseOrigin(const AcGePoint3d &origin, AcDb::OrthographicView orthoView) (defined in AcDbDatabase) | AcDbDatabase |
setWorldview(bool view) (defined in AcDbDatabase) | AcDbDatabase |
setXclipFrame(bool disp) | AcDbDatabase |
setXrefEditEnabled(bool enable) (defined in AcDbDatabase) | AcDbDatabase |
shadedge() const (defined in AcDbDatabase) | AcDbDatabase |
shadedif() const (defined in AcDbDatabase) | AcDbDatabase |
shadowPlaneLocation() const | AcDbDatabase |
showHist() const | AcDbDatabase |
sketchinc() const (defined in AcDbDatabase) | AcDbDatabase |
skpoly() const (defined in AcDbDatabase) | AcDbDatabase |
solidHist() const | AcDbDatabase |
sortEnts() const (defined in AcDbDatabase) | AcDbDatabase |
splframe() const (defined in AcDbDatabase) | AcDbDatabase |
splinesegs() const (defined in AcDbDatabase) | AcDbDatabase |
splinetype() const (defined in AcDbDatabase) | AcDbDatabase |
stepSize() const | AcDbDatabase |
stepsPerSec() const | AcDbDatabase |
surftab1() const (defined in AcDbDatabase) | AcDbDatabase |
surftab2() const (defined in AcDbDatabase) | AcDbDatabase |
surftype() const (defined in AcDbDatabase) | AcDbDatabase |
surfu() const (defined in AcDbDatabase) | AcDbDatabase |
surfv() const (defined in AcDbDatabase) | AcDbDatabase |
tablestyle() const (defined in AcDbDatabase) | AcDbDatabase |
tableStyleDictionaryId() const (defined in AcDbDatabase) | AcDbDatabase |
tdcreate() const (defined in AcDbDatabase) | AcDbDatabase |
tdindwg() const (defined in AcDbDatabase) | AcDbDatabase |
tducreate() const (defined in AcDbDatabase) | AcDbDatabase |
tdupdate() const (defined in AcDbDatabase) | AcDbDatabase |
tdusrtimer() const (defined in AcDbDatabase) | AcDbDatabase |
tduupdate() const (defined in AcDbDatabase) | AcDbDatabase |
textsize() const (defined in AcDbDatabase) | AcDbDatabase |
textstyle() const (defined in AcDbDatabase) | AcDbDatabase |
textStyleTableId() (defined in AcDbDatabase) | AcDbDatabase |
thickness() const (defined in AcDbDatabase) | AcDbDatabase |
thumbnailBitmap() const (defined in AcDbDatabase) | AcDbDatabase |
tilemode() const (defined in AcDbDatabase) | AcDbDatabase |
tileModeLightSynch() const | AcDbDatabase |
timeZone() const | AcDbDatabase |
tracewid() const (defined in AcDbDatabase) | AcDbDatabase |
transactionManager() const (defined in AcDbDatabase) | AcDbDatabase |
treedepth() const (defined in AcDbDatabase) | AcDbDatabase |
tstackalign() const (defined in AcDbDatabase) | AcDbDatabase |
tstacksize() const (defined in AcDbDatabase) | AcDbDatabase |
ucsBase() const (defined in AcDbDatabase) | AcDbDatabase |
ucsname() const (defined in AcDbDatabase) | AcDbDatabase |
ucsorg() const (defined in AcDbDatabase) | AcDbDatabase |
UCSTableId() (defined in AcDbDatabase) | AcDbDatabase |
ucsxdir() const (defined in AcDbDatabase) | AcDbDatabase |
ucsydir() const (defined in AcDbDatabase) | AcDbDatabase |
undoController() const (defined in AcDbDatabase) | AcDbDatabase |
undoRecording() const (defined in AcDbDatabase) | AcDbDatabase |
unitmode() const (defined in AcDbDatabase) | AcDbDatabase |
updateDataLink(AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbDatabase) | AcDbDatabase |
updateExt(bool doBestFit=FALSE) (defined in AcDbDatabase) | AcDbDatabase |
useri1() const (defined in AcDbDatabase) | AcDbDatabase |
useri2() const (defined in AcDbDatabase) | AcDbDatabase |
useri3() const (defined in AcDbDatabase) | AcDbDatabase |
useri4() const (defined in AcDbDatabase) | AcDbDatabase |
useri5() const (defined in AcDbDatabase) | AcDbDatabase |
userr1() const (defined in AcDbDatabase) | AcDbDatabase |
userr2() const (defined in AcDbDatabase) | AcDbDatabase |
userr3() const (defined in AcDbDatabase) | AcDbDatabase |
userr4() const (defined in AcDbDatabase) | AcDbDatabase |
userr5() const (defined in AcDbDatabase) | AcDbDatabase |
usrtimer() const (defined in AcDbDatabase) | AcDbDatabase |
viewportScaleDefault() const (defined in AcDbDatabase) | AcDbDatabase |
viewportTableId() (defined in AcDbDatabase) | AcDbDatabase |
viewTableId() (defined in AcDbDatabase) | AcDbDatabase |
visretain() const (defined in AcDbDatabase) | AcDbDatabase |
visualStyleDictionaryId() (defined in AcDbDatabase) | AcDbDatabase |
wblock(AcDbDatabase *&pOutputDb, const AcDbObjectIdArray &outObjIds, const AcGePoint3d &basePoint) (defined in AcDbDatabase) | AcDbDatabase |
wblock(AcDbDatabase *pOutputDb, const AcDbObjectIdArray &outObjIds, const AcGePoint3d &basePoint, AcDb::DuplicateRecordCloning drc) (defined in AcDbDatabase) | AcDbDatabase |
wblock(AcDbDatabase *&pOutputDb, AcDbObjectId blockId) (defined in AcDbDatabase) | AcDbDatabase |
wblock(AcDbDatabase *&pOutputDb) (defined in AcDbDatabase) | AcDbDatabase |
wblockCloneObjects(AcDbObjectIdArray &objectIds, AcDbObjectId &owner, AcDbIdMapping &idMap, AcDb::DuplicateRecordCloning drc, bool deferXlation=false) (defined in AcDbDatabase) | AcDbDatabase |
worldPucsBaseOrigin(AcDb::OrthographicView orthoView) const (defined in AcDbDatabase) | AcDbDatabase |
worldUcsBaseOrigin(AcDb::OrthographicView orthoView) const (defined in AcDbDatabase) | AcDbDatabase |
worldview() const (defined in AcDbDatabase) | AcDbDatabase |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xclipFrame() const | AcDbDatabase |
xrefBlockId() const (defined in AcDbDatabase) | AcDbDatabase |
xrefEditEnabled() const (defined in AcDbDatabase) | AcDbDatabase |
~AcDbDatabase() (defined in AcDbDatabase) | AcDbDatabase | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDatabaseReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDatabaseReactor Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDatabaseReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbDatabaseReactor)
virtual void | goodbye (const AcDbDatabase *dwg)
virtual void | headerSysVarChanged (const AcDbDatabase *dwg, const ACHAR *name, Adesk::Boolean bSuccess)
virtual void | headerSysVarWillChange (const AcDbDatabase *dwg, const ACHAR *name)
virtual void | objectAppended (const AcDbDatabase *dwg, const AcDbObject *dbObj)
virtual void | objectErased (const AcDbDatabase *dwg, const AcDbObject *dbObj, Adesk::Boolean pErased=true)
virtual void | objectModified (const AcDbDatabase *dwg, const AcDbObject *dbObj)
virtual void | objectOpenedForModify (const AcDbDatabase *dwg, const AcDbObject *dbObj)
virtual void | objectReAppended (const AcDbDatabase *dwg, const AcDbObject *dbObj)
virtual void | objectUnAppended (const AcDbDatabase *dwg, const AcDbObject *dbObj)
virtual void | proxyResurrectionCompleted (const AcDbDatabase *dwg, const ACHAR *appname, AcDbObjectIdArray &objects)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDatabaseReactor Member List

This is the complete list of members for AcDbDatabaseReactor, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbDatabaseReactor) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
goodbye(const AcDbDatabase *dwg) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
headerSysVarChanged(const AcDbDatabase *dwg, const ACHAR *name, Adesk::Boolean bSuccess) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
headerSysVarWillChange(const AcDbDatabase *dwg, const ACHAR *name) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
objectAppended(const AcDbDatabase *dwg, const AcDbObject *dbObj) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
objectErased(const AcDbDatabase *dwg, const AcDbObject *dbObj, Adesk::Boolean pErased=true) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
objectModified(const AcDbDatabase *dwg, const AcDbObject *dbObj) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
objectOpenedForModify(const AcDbDatabase *dwg, const AcDbObject *dbObj) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
objectReAppended(const AcDbDatabase *dwg, const AcDbObject *dbObj) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
objectUnAppended(const AcDbDatabase *dwg, const AcDbObject *dbObj) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
proxyResurrectionCompleted(const AcDbDatabase *dwg, const ACHAR *appname, AcDbObjectIdArray &objects) (defined in AcDbDatabaseReactor) | AcDbDatabaseReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDatabaseSummaryInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDatabaseSummaryInfo Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDatabaseSummaryInfo:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbDatabaseSummaryInfo)
virtual Acad::ErrorStatus | addCustomSummaryInfo (const ACHAR *key, const ACHAR *value)=0
virtual AcDbDatabase * | database () const =0
virtual Acad::ErrorStatus | deleteCustomSummaryInfo (const int index)=0
virtual Acad::ErrorStatus | deleteCustomSummaryInfo (const ACHAR *key)=0
virtual Acad::ErrorStatus | getAuthor (ACHAR *&author) const =0
virtual Acad::ErrorStatus | getComments (ACHAR *&comments) const =0
virtual Acad::ErrorStatus | getCustomSummaryInfo (const int index, ACHAR *&key, ACHAR *&value) const =0
virtual Acad::ErrorStatus | getCustomSummaryInfo (const ACHAR *customInfoKey, ACHAR *&value) const =0
virtual Acad::ErrorStatus | getHyperlinkBase (ACHAR *&HyperlinkBase) const =0
virtual Acad::ErrorStatus | getKeywords (ACHAR *&keywordlist) const =0
virtual Acad::ErrorStatus | getLastSavedBy (ACHAR *&lastSavedBy) const =0
virtual Acad::ErrorStatus | getRevisionNumber (ACHAR *&revisionNumber) const =0
virtual Acad::ErrorStatus | getSubject (ACHAR *&subject) const =0
virtual Acad::ErrorStatus | getTitle (ACHAR *&title) const =0
virtual int | numCustomInfo () const =0
virtual Acad::ErrorStatus | setAuthor (const ACHAR *author)=0
virtual Acad::ErrorStatus | setComments (const ACHAR *comments)=0
virtual Acad::ErrorStatus | setCustomSummaryInfo (const int index, const ACHAR *key, const ACHAR *value)=0
virtual Acad::ErrorStatus | setCustomSummaryInfo (const ACHAR *customInfoKey, const ACHAR *value)=0
virtual void | setDatabase (AcDbDatabase *pDb)=0
virtual Acad::ErrorStatus | setHyperlinkBase (const ACHAR *HyperlinkBase)=0
virtual Acad::ErrorStatus | setKeywords (const ACHAR *keywordlist)=0
virtual Acad::ErrorStatus | setLastSavedBy (const ACHAR *lastSavedBy)=0
virtual Acad::ErrorStatus | setRevisionNumber (const ACHAR *revisionNumber)=0
virtual Acad::ErrorStatus | setSubject (const ACHAR *subject)=0
virtual Acad::ErrorStatus | setTitle (const ACHAR *title)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • summinfo.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDatabaseSummaryInfo Member List

This is the complete list of members for AcDbDatabaseSummaryInfo, including all inherited members.

AcDbDatabaseSummaryInfo() (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | protected
ACRX_DECLARE_MEMBERS(AcDbDatabaseSummaryInfo) (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addCustomSummaryInfo(const ACHAR *key, const ACHAR *value)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
database() const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
deleteCustomSummaryInfo(const int index)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
deleteCustomSummaryInfo(const ACHAR *key)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
getAuthor(ACHAR *&author) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
getComments(ACHAR *&comments) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
getCustomSummaryInfo(const int index, ACHAR *&key, ACHAR *&value) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
getCustomSummaryInfo(const ACHAR *customInfoKey, ACHAR *&value) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
getHyperlinkBase(ACHAR *&HyperlinkBase) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
getKeywords(ACHAR *&keywordlist) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
getLastSavedBy(ACHAR *&lastSavedBy) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
getRevisionNumber(ACHAR *&revisionNumber) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
getSubject(ACHAR *&subject) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
getTitle(ACHAR *&title) const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
numCustomInfo() const =0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setAuthor(const ACHAR *author)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setComments(const ACHAR *comments)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setCustomSummaryInfo(const int index, const ACHAR *key, const ACHAR *value)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setCustomSummaryInfo(const ACHAR *customInfoKey, const ACHAR *value)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setDatabase(AcDbDatabase *pDb)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setHyperlinkBase(const ACHAR *HyperlinkBase)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setKeywords(const ACHAR *keywordlist)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setLastSavedBy(const ACHAR *lastSavedBy)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setRevisionNumber(const ACHAR *revisionNumber)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setSubject(const ACHAR *subject)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
setTitle(const ACHAR *title)=0 (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbDatabaseSummaryInfo() (defined in AcDbDatabaseSummaryInfo) | AcDbDatabaseSummaryInfo | inlinevirtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDataCell Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcDbDataCell Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDataCell:

Public Types

enum CellType {
kUnknown = 0, kInteger, kDouble, kCharPtr,
kPoint, kObjectId, kHardOwnerId, kSoftOwnerId,
kHardPtrId, kSoftPtrId, kBool, kVector
}

Public Member Functions

AcDbDataCell (const AcDbDataCell &rCell)
AcDbDataCell (bool b)
AcDbDataCell (int i)
AcDbDataCell (double d)
AcDbDataCell (const ACHAR *pChar)
AcDbDataCell (const AcGePoint3d &point)
AcDbDataCell (const AcGeVector3d &vec)
AcDbDataCell (const AcDbObjectId &id)
AcDbDataCell (const AcDbHardOwnershipId &hoId)
AcDbDataCell (const AcDbSoftOwnershipId &soId)
AcDbDataCell (const AcDbHardPointerId &hpId)
AcDbDataCell (const AcDbSoftPointerId &spId)
ACRX_DECLARE_MEMBERS (AcDbDataCell)
virtual void | init ()
virtual | operator AcDbHardOwnershipId & () const
virtual | operator AcDbHardPointerId & () const
virtual | operator AcDbObjectId & () const
virtual | operator AcDbSoftOwnershipId & () const
virtual | operator AcDbSoftPointerId & () const
virtual | operator AcGePoint3d & () const
virtual | operator AcGeVector3d & () const
virtual | operator bool () const
virtual | operator const ACHAR * () const
virtual | operator double () const
virtual | operator int () const
virtual bool | operator!= (const AcDbDataCell &cell) const
virtual AcDbDataCell & | operator= (const AcDbDataCell &cell)
virtual AcDbDataCell & | operator= (bool b)
virtual AcDbDataCell & | operator= (int i)
virtual AcDbDataCell & | operator= (double d)
virtual AcDbDataCell & | operator= (const ACHAR *pChar)
virtual AcDbDataCell & | operator= (const AcGePoint3d &pt)
virtual AcDbDataCell & | operator= (const AcGeVector3d &vec)
virtual AcDbDataCell & | operator= (const AcDbObjectId &id)
virtual AcDbDataCell & | operator= (const AcDbHardOwnershipId &hoId)
virtual AcDbDataCell & | operator= (const AcDbSoftOwnershipId &soId)
virtual AcDbDataCell & | operator= (const AcDbHardPointerId &hpId)
virtual AcDbDataCell & | operator= (const AcDbSoftPointerId &spId)
virtual bool | operator== (const AcDbDataCell &cell) const
virtual AcDbDataCell::CellType | type () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbDataTable.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDataCell Member List

This is the complete list of members for AcDbDataCell, including all inherited members.

AcDbDataCell() (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(const AcDbDataCell &rCell) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(bool b) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(int i) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(double d) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(const ACHAR *pChar) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(const AcGePoint3d &point) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(const AcGeVector3d &vec) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(const AcDbObjectId &id) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(const AcDbHardOwnershipId &hoId) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(const AcDbSoftOwnershipId &soId) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(const AcDbHardPointerId &hpId) (defined in AcDbDataCell) | AcDbDataCell |
AcDbDataCell(const AcDbSoftPointerId &spId) (defined in AcDbDataCell) | AcDbDataCell |
AcDbSystemInternals (defined in AcDbDataCell) | AcDbDataCell | friend
ACRX_DECLARE_MEMBERS(AcDbDataCell) (defined in AcDbDataCell) | AcDbDataCell |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
CellType enum name (defined in AcDbDataCell) | AcDbDataCell |
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
init() (defined in AcDbDataCell) | AcDbDataCell | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kBool enum value (defined in AcDbDataCell) | AcDbDataCell |
kCharPtr enum value (defined in AcDbDataCell) | AcDbDataCell |
kDouble enum value (defined in AcDbDataCell) | AcDbDataCell |
kHardOwnerId enum value (defined in AcDbDataCell) | AcDbDataCell |
kHardPtrId enum value (defined in AcDbDataCell) | AcDbDataCell |
kInteger enum value (defined in AcDbDataCell) | AcDbDataCell |
kObjectId enum value (defined in AcDbDataCell) | AcDbDataCell |
kPoint enum value (defined in AcDbDataCell) | AcDbDataCell |
kSoftOwnerId enum value (defined in AcDbDataCell) | AcDbDataCell |
kSoftPtrId enum value (defined in AcDbDataCell) | AcDbDataCell |
kUnknown enum value (defined in AcDbDataCell) | AcDbDataCell |
kVector enum value (defined in AcDbDataCell) | AcDbDataCell |
operator AcDbHardOwnershipId &() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator AcDbHardPointerId &() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator AcDbObjectId &() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator AcDbSoftOwnershipId &() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator AcDbSoftPointerId &() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator AcGePoint3d &() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator AcGeVector3d &() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator bool() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator const ACHAR *() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator double() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator int() const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator!=(const AcDbDataCell &cell) const (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(const AcDbDataCell &cell) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(bool b) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(int i) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(double d) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(const ACHAR *pChar) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(const AcGePoint3d &pt) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(const AcGeVector3d &vec) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(const AcDbObjectId &id) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(const AcDbHardOwnershipId &hoId) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(const AcDbSoftOwnershipId &soId) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(const AcDbHardPointerId &hpId) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator=(const AcDbSoftPointerId &spId) (defined in AcDbDataCell) | AcDbDataCell | virtual
operator==(const AcDbDataCell &cell) const (defined in AcDbDataCell) | AcDbDataCell | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
type() const (defined in AcDbDataCell) | AcDbDataCell | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbDataCell() (defined in AcDbDataCell) | AcDbDataCell | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDataColumn Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbDataColumn Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDataColumn:

Public Member Functions

AcDbDataColumn (const AcDbDataColumn &rCol)
AcDbDataColumn (const AcDbDataCell::CellType type, const ACHAR *pColName=NULL)
ACRX_DECLARE_MEMBERS (AcDbDataColumn)
virtual Acad::ErrorStatus | appendCell (const AcDbDataCell &cell)
virtual const ACHAR * | columnName () const
virtual AcDbDataCell::CellType | columnType () const
virtual Acad::ErrorStatus | getCellAt (Adesk::UInt32 index, AcDbDataCell &outCell) const
virtual Acad::ErrorStatus | getIndexAtCell (const AcDbDataCell &cell, Adesk::UInt32 &index) const
virtual Adesk::UInt32 | growLength () const
virtual Acad::ErrorStatus | insertCellAt (Adesk::UInt32 index, const AcDbDataCell &cell)
virtual Adesk::UInt32 | numCells () const
virtual AcDbDataColumn & | operator= (const AcDbDataColumn &col)
virtual Adesk::UInt32 | physicalLength () const
virtual Acad::ErrorStatus | removeCellAt (Adesk::UInt32 index)
virtual Acad::ErrorStatus | setCellAt (Adesk::UInt32 index, const AcDbDataCell &cell)
virtual Acad::ErrorStatus | setColumnName (const ACHAR *pName)
virtual Acad::ErrorStatus | setColumnType (AcDbDataCell::CellType type)
virtual Acad::ErrorStatus | setGrowLength (Adesk::UInt32 n)
virtual Acad::ErrorStatus | setPhysicalLength (Adesk::UInt32 n)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class | AcDbImpDataColumn
class | AcDbSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbDataTable.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDataColumn Member List

This is the complete list of members for AcDbDataColumn, including all inherited members.

AcDbDataColumn() (defined in AcDbDataColumn) | AcDbDataColumn |
AcDbDataColumn(const AcDbDataColumn &rCol) (defined in AcDbDataColumn) | AcDbDataColumn |
AcDbDataColumn(const AcDbDataCell::CellType type, const ACHAR *pColName=NULL) (defined in AcDbDataColumn) | AcDbDataColumn |
AcDbImpDataColumn (defined in AcDbDataColumn) | AcDbDataColumn | friend
AcDbSystemInternals (defined in AcDbDataColumn) | AcDbDataColumn | friend
ACRX_DECLARE_MEMBERS(AcDbDataColumn) (defined in AcDbDataColumn) | AcDbDataColumn |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
appendCell(const AcDbDataCell &cell) (defined in AcDbDataColumn) | AcDbDataColumn | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
columnName() const (defined in AcDbDataColumn) | AcDbDataColumn | virtual
columnType() const (defined in AcDbDataColumn) | AcDbDataColumn | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getCellAt(Adesk::UInt32 index, AcDbDataCell &outCell) const (defined in AcDbDataColumn) | AcDbDataColumn | virtual
getIndexAtCell(const AcDbDataCell &cell, Adesk::UInt32 &index) const (defined in AcDbDataColumn) | AcDbDataColumn | virtual
growLength() const (defined in AcDbDataColumn) | AcDbDataColumn | virtual
insertCellAt(Adesk::UInt32 index, const AcDbDataCell &cell) (defined in AcDbDataColumn) | AcDbDataColumn | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
numCells() const (defined in AcDbDataColumn) | AcDbDataColumn | virtual
operator=(const AcDbDataColumn &col) (defined in AcDbDataColumn) | AcDbDataColumn | virtual
physicalLength() const (defined in AcDbDataColumn) | AcDbDataColumn | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeCellAt(Adesk::UInt32 index) (defined in AcDbDataColumn) | AcDbDataColumn | virtual
setCellAt(Adesk::UInt32 index, const AcDbDataCell &cell) (defined in AcDbDataColumn) | AcDbDataColumn | virtual
setColumnName(const ACHAR *pName) (defined in AcDbDataColumn) | AcDbDataColumn | virtual
setColumnType(AcDbDataCell::CellType type) (defined in AcDbDataColumn) | AcDbDataColumn | virtual
setGrowLength(Adesk::UInt32 n) (defined in AcDbDataColumn) | AcDbDataColumn | virtual
setPhysicalLength(Adesk::UInt32 n) (defined in AcDbDataColumn) | AcDbDataColumn | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbDataColumn() (defined in AcDbDataColumn) | AcDbDataColumn | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDataLink Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDataLink Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDataLink:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDataLink)
ACDB_PORT const ACHAR * | connectionString (void) const
ACDB_PORT const ACHAR * | dataAdapterId (void) const
ACDB_PORT const ACHAR * | description (void) const
virtual ACDB_PORT Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
ACDB_PORT Acad::ErrorStatus | getCustomData (const ACHAR *pszKey, AcValue *pData) const
ACDB_PORT Acad::ErrorStatus | getSourceFiles (AcDb::DataLinkGetSourceContext nContext, AcStringArray &files) const
ACDB_PORT int | getTargets (AcDbObjectIdArray &targetIds) const
ACDB_PORT AcString | getToolTip (void) const
ACDB_PORT Acad::ErrorStatus | getUpdateStatus (AcDb::UpdateDirection *pDir, SYSTEMTIME *pTime, AcString *pErrMessage) const
ACDB_PORT bool | isValid (void) const
ACDB_PORT AcString | name (void) const
ACDB_PORT AcDb::DataLinkOption | option (void) const
ACDB_PORT Acad::ErrorStatus | repathSourceFiles (LPCTSTR pszBasePath, AcDb::PathOption nOption)
ACDB_PORT Acad::ErrorStatus | setConnectionString (const ACHAR *pszConnectionString)
ACDB_PORT Acad::ErrorStatus | setCustomData (const ACHAR *pszKey, const AcValue *pData)
ACDB_PORT Acad::ErrorStatus | setDataAdapterId (const ACHAR *pszAdapterId)
ACDB_PORT Acad::ErrorStatus | setDescription (const ACHAR *pszDescription)
ACDB_PORT Acad::ErrorStatus | setName (const ACHAR *pszName)
ACDB_PORT Acad::ErrorStatus | setOption (AcDb::DataLinkOption nOption)
ACDB_PORT Acad::ErrorStatus | setToolTip (const ACHAR *pszToolTip)
ACDB_PORT Acad::ErrorStatus | setUpdateOption (int nOption)
ACDB_PORT Acad::ErrorStatus | setUpdateStatus (const ACHAR *pszErrMessage)
ACDB_PORT Acad::ErrorStatus | update (AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
ACDB_PORT int | updateOption (void) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • DbDataLink.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDataLink Member List

This is the complete list of members for AcDbDataLink, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDataLink) (defined in AcDbDataLink) | AcDbDataLink |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDataLink(void) (defined in AcDbDataLink) | AcDbDataLink |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
connectionString(void) const (defined in AcDbDataLink) | AcDbDataLink |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
dataAdapterId(void) const (defined in AcDbDataLink) | AcDbDataLink |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbDataLink) | AcDbDataLink |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbDataLink) | AcDbDataLink | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbDataLink) | AcDbDataLink | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbDataLink) | AcDbDataLink | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbDataLink) | AcDbDataLink | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getCustomData(const ACHAR *pszKey, AcValue *pData) const (defined in AcDbDataLink) | AcDbDataLink |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getSourceFiles(AcDb::DataLinkGetSourceContext nContext, AcStringArray &files) const (defined in AcDbDataLink) | AcDbDataLink |
getTargets(AcDbObjectIdArray &targetIds) const (defined in AcDbDataLink) | AcDbDataLink |
getToolTip(void) const (defined in AcDbDataLink) | AcDbDataLink |
getUpdateStatus(AcDb::UpdateDirection *pDir, SYSTEMTIME *pTime, AcString *pErrMessage) const (defined in AcDbDataLink) | AcDbDataLink |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isValid(void) const (defined in AcDbDataLink) | AcDbDataLink |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
name(void) const (defined in AcDbDataLink) | AcDbDataLink |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
option(void) const (defined in AcDbDataLink) | AcDbDataLink |
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
repathSourceFiles(LPCTSTR pszBasePath, AcDb::PathOption nOption) (defined in AcDbDataLink) | AcDbDataLink |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setConnectionString(const ACHAR *pszConnectionString) (defined in AcDbDataLink) | AcDbDataLink |
setCustomData(const ACHAR *pszKey, const AcValue *pData) (defined in AcDbDataLink) | AcDbDataLink |
setDataAdapterId(const ACHAR *pszAdapterId) (defined in AcDbDataLink) | AcDbDataLink |
setDescription(const ACHAR *pszDescription) (defined in AcDbDataLink) | AcDbDataLink |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setName(const ACHAR *pszName) (defined in AcDbDataLink) | AcDbDataLink |
setOption(AcDb::DataLinkOption nOption) (defined in AcDbDataLink) | AcDbDataLink |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setToolTip(const ACHAR *pszToolTip) (defined in AcDbDataLink) | AcDbDataLink |
setUpdateOption(int nOption) (defined in AcDbDataLink) | AcDbDataLink |
setUpdateStatus(const ACHAR *pszErrMessage) (defined in AcDbDataLink) | AcDbDataLink |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
update(AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbDataLink) | AcDbDataLink |
updateOption(void) const (defined in AcDbDataLink) | AcDbDataLink |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDataLink(void) (defined in AcDbDataLink) | AcDbDataLink | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDataLinkManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDataLinkManager Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDataLinkManager:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbDataLinkManager)
ACDB_PORT Acad::ErrorStatus | addDataLink (AcDbDataLink *pDataLink)
ACDB_PORT Acad::ErrorStatus | addDataLink (AcDbDataLink *pDataLink, AcDbObjectId &idDataLink)
ACDB_PORT Acad::ErrorStatus | createDataLink (const ACHAR *pszAdapterId, const ACHAR *pszName, const ACHAR *pszDescription, const ACHAR *pszConnectionString, AcDbObjectId &idDataLink)
ACDB_PORT int | dataLinkCount (void) const
ACDB_PORT Acad::ErrorStatus | getDataLink (const ACHAR *pszName, AcDbObjectId &idDataLink) const
ACDB_PORT Acad::ErrorStatus | getDataLink (const ACHAR *pszName, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const
ACDB_PORT int | getDataLink (AcDbObjectIdArray &dataLinks) const
Acad::ErrorStatus | removeDataLink (const ACHAR *pszKey, AcDbObjectId &idDataLink)
ACDB_PORT Acad::ErrorStatus | removeDataLink (const AcDbObjectId &idDataLink)
ACDB_PORT Acad::ErrorStatus | update (const AcDbObjectIdArray &dataIds, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
ACDB_PORT Acad::ErrorStatus | update (AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • DbDataLink.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDataLinkManager Member List

This is the complete list of members for AcDbDataLinkManager, including all inherited members.

AcDbDataLinkManager(void) (defined in AcDbDataLinkManager) | AcDbDataLinkManager | protected
ACRX_DECLARE_MEMBERS(AcDbDataLinkManager) (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addDataLink(AcDbDataLink *pDataLink) (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
addDataLink(AcDbDataLink *pDataLink, AcDbObjectId &idDataLink) (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
createDataLink(const ACHAR *pszAdapterId, const ACHAR *pszName, const ACHAR *pszDescription, const ACHAR *pszConnectionString, AcDbObjectId &idDataLink) (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
dataLinkCount(void) const (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
desc() (defined in AcRxObject) | AcRxObject | static
getDataLink(const ACHAR *pszName, AcDbObjectId &idDataLink) const (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
getDataLink(const ACHAR *pszName, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
getDataLink(AcDbObjectIdArray &dataLinks) const (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeDataLink(const ACHAR *pszKey, AcDbObjectId &idDataLink) (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
removeDataLink(const AcDbObjectId &idDataLink) (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
update(const AcDbObjectIdArray &dataIds, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
update(AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbDataLinkManager) | AcDbDataLinkManager |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbDataLinkManager(void) (defined in AcDbDataLinkManager) | AcDbDataLinkManager | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDataTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDataTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDataTable:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDataTable)
virtual Acad::ErrorStatus | appendColumn (AcDbDataCell::CellType type, const ACHAR *pColName=NULL)
virtual Acad::ErrorStatus | appendRow (const AcDbDataCellArray &row, bool bValidate=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual Acad::ErrorStatus | getCellAt (Adesk::UInt32 row, Adesk::UInt32 col, AcDbDataCell &outCell) const
virtual Acad::ErrorStatus | getColumnAt (Adesk::UInt32 index, const AcDbDataColumn *&pCol) const
virtual Acad::ErrorStatus | getColumnIndexAtName (const ACHAR *pName, Adesk::UInt32 &index) const
virtual Acad::ErrorStatus | getColumnNameAt (Adesk::UInt32 index, ACHAR *&pName) const
virtual Acad::ErrorStatus | getColumnTypeAt (Adesk::UInt32 index, AcDbDataCell::CellType &type) const
virtual Acad::ErrorStatus | getRowAt (Adesk::UInt32 index, AcDbDataCellArray &outRow) const
virtual Acad::ErrorStatus | insertColumnAt (Adesk::UInt32 index, AcDbDataCell::CellType type, const ACHAR *pColName=NULL)
virtual Acad::ErrorStatus | insertRowAt (Adesk::UInt32 index, const AcDbDataCellArray &row, bool bValidate=true)
virtual Adesk::UInt32 | numColsGrowSize () const
virtual Adesk::UInt32 | numColsPhysicalSize () const
virtual Adesk::UInt32 | numColumns () const
virtual Adesk::UInt32 | numRows () const
virtual Adesk::UInt32 | numRowsGrowSize () const
virtual Adesk::UInt32 | numRowsPhysicalSize () const
virtual AcDbDataTable & | operator= (const AcDbDataTable &table)
virtual Acad::ErrorStatus | removeColumnAt (Adesk::UInt32 index)
virtual Acad::ErrorStatus | removeRowAt (Adesk::UInt32 index)
virtual Acad::ErrorStatus | setCellAt (Adesk::UInt32 row, Adesk::UInt32 col, const AcDbDataCell &cell)
virtual Acad::ErrorStatus | setNumColsGrowSize (Adesk::UInt32 n)
virtual Acad::ErrorStatus | setNumColsPhysicalSize (Adesk::UInt32 n)
virtual Acad::ErrorStatus | setNumRowsGrowSize (Adesk::UInt32 n)
virtual Acad::ErrorStatus | setNumRowsPhysicalSize (Adesk::UInt32 n)
virtual Acad::ErrorStatus | setRowAt (Adesk::UInt32 index, const AcDbDataCellArray &row, bool bValidate=true)
virtual Acad::ErrorStatus | setTableName (const ACHAR *pName)
virtual const ACHAR * | tableName () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbDataTable.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDataTable Member List

This is the complete list of members for AcDbDataTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDataTable) (defined in AcDbDataTable) | AcDbDataTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDataTable() (defined in AcDbDataTable) | AcDbDataTable |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
appendColumn(AcDbDataCell::CellType type, const ACHAR *pColName=NULL) (defined in AcDbDataTable) | AcDbDataTable | virtual
appendRow(const AcDbDataCellArray &row, bool bValidate=true) (defined in AcDbDataTable) | AcDbDataTable | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbDataTable) | AcDbDataTable | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbDataTable) | AcDbDataTable | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbDataTable) | AcDbDataTable | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbDataTable) | AcDbDataTable | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbDataTable) | AcDbDataTable | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getCellAt(Adesk::UInt32 row, Adesk::UInt32 col, AcDbDataCell &outCell) const (defined in AcDbDataTable) | AcDbDataTable | virtual
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getColumnAt(Adesk::UInt32 index, const AcDbDataColumn *&pCol) const (defined in AcDbDataTable) | AcDbDataTable | virtual
getColumnIndexAtName(const ACHAR *pName, Adesk::UInt32 &index) const (defined in AcDbDataTable) | AcDbDataTable | virtual
getColumnNameAt(Adesk::UInt32 index, ACHAR *&pName) const (defined in AcDbDataTable) | AcDbDataTable | virtual
getColumnTypeAt(Adesk::UInt32 index, AcDbDataCell::CellType &type) const (defined in AcDbDataTable) | AcDbDataTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getRowAt(Adesk::UInt32 index, AcDbDataCellArray &outRow) const (defined in AcDbDataTable) | AcDbDataTable | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
insertColumnAt(Adesk::UInt32 index, AcDbDataCell::CellType type, const ACHAR *pColName=NULL) (defined in AcDbDataTable) | AcDbDataTable | virtual
insertRowAt(Adesk::UInt32 index, const AcDbDataCellArray &row, bool bValidate=true) (defined in AcDbDataTable) | AcDbDataTable | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
numColsGrowSize() const (defined in AcDbDataTable) | AcDbDataTable | virtual
numColsPhysicalSize() const (defined in AcDbDataTable) | AcDbDataTable | virtual
numColumns() const (defined in AcDbDataTable) | AcDbDataTable | virtual
numRows() const (defined in AcDbDataTable) | AcDbDataTable | virtual
numRowsGrowSize() const (defined in AcDbDataTable) | AcDbDataTable | virtual
numRowsPhysicalSize() const (defined in AcDbDataTable) | AcDbDataTable | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator=(const AcDbDataTable &table) (defined in AcDbDataTable) | AcDbDataTable | virtual
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeColumnAt(Adesk::UInt32 index) (defined in AcDbDataTable) | AcDbDataTable | virtual
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeRowAt(Adesk::UInt32 index) (defined in AcDbDataTable) | AcDbDataTable | virtual
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCellAt(Adesk::UInt32 row, Adesk::UInt32 col, const AcDbDataCell &cell) (defined in AcDbDataTable) | AcDbDataTable | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setNumColsGrowSize(Adesk::UInt32 n) (defined in AcDbDataTable) | AcDbDataTable | virtual
setNumColsPhysicalSize(Adesk::UInt32 n) (defined in AcDbDataTable) | AcDbDataTable | virtual
setNumRowsGrowSize(Adesk::UInt32 n) (defined in AcDbDataTable) | AcDbDataTable | virtual
setNumRowsPhysicalSize(Adesk::UInt32 n) (defined in AcDbDataTable) | AcDbDataTable | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setRowAt(Adesk::UInt32 index, const AcDbDataCellArray &row, bool bValidate=true) (defined in AcDbDataTable) | AcDbDataTable | virtual
setTableName(const ACHAR *pName) (defined in AcDbDataTable) | AcDbDataTable | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
tableName() const (defined in AcDbDataTable) | AcDbDataTable | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDataTable() (defined in AcDbDataTable) | AcDbDataTable | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDate Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcDbDate Class Reference
AcDb Classes

Public Types

enum InitialValue { kInitZero = 1, kInitLocalTime = 2, kInitUniversalTime = 3 }

Public Member Functions

AcDbDate (InitialValue i)
AcDbDate (const AcDbDate &)
const AcDbDate & | add (const AcDbDate &date)
short | day () const
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *inFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *outFiler) const
void | getDate (short &month, short &day, short &year) const
void | getLocalTime ()
void | getTime (short &hour, short &min, short &sec, short &msec) const
void | getUniversalTime ()
short | hour () const
long | julianDay () const
double | julianFraction () const
void | localToUniversal ()
short | millisecond () const
short | minute () const
short | month () const
long | msecsPastMidnight () const
const AcDbDate | operator+ (const AcDbDate &date) const
const AcDbDate & | operator+= (const AcDbDate &date)
const AcDbDate | operator- (const AcDbDate &date) const
const AcDbDate & | operator-= (const AcDbDate &date)
bool | operator< (const AcDbDate &) const
bool | operator<= (const AcDbDate &) const
const AcDbDate & | operator= (const AcDbDate &)
bool | operator== (const AcDbDate &) const
bool | operator> (const AcDbDate &) const
bool | operator>= (const AcDbDate &) const
short | second () const
void | setDate (short month, short day, short year)
void | setDay (short)
void | setHour (short)
void | setJulianDate (long julianDay, long msec)
void | setJulianDay (long julianDay)
void | setJulianFraction (double)
void | setMillisecond (short)
void | setMinute (short)
void | setMonth (short)
void | setMsecsPastMidnight (long msec)
void | setSecond (short)
void | setTime (short hour, short min, short sec, short msec)
void | setToZero ()
void | setYear (short)
const AcDbDate & | subtract (const AcDbDate &date)
void | universalToLocal ()
short | year () const

Friends

class AcDbImpDate
The documentation for this class was generated from the following file:
  • dbdate.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDate Member List

This is the complete list of members for AcDbDate, including all inherited members.

AcDbDate() (defined in AcDbDate) | AcDbDate |
AcDbDate(InitialValue i) (defined in AcDbDate) | AcDbDate |
AcDbDate(const AcDbDate &) (defined in AcDbDate) | AcDbDate |
AcDbImpDate (defined in AcDbDate) | AcDbDate | friend
add(const AcDbDate &date) (defined in AcDbDate) | AcDbDate | inline
day() const (defined in AcDbDate) | AcDbDate |
dwgIn(AcDbDwgFiler *inFiler) (defined in AcDbDate) | AcDbDate |
dwgOut(AcDbDwgFiler *outFiler) const (defined in AcDbDate) | AcDbDate |
getDate(short &month, short &day, short &year) const (defined in AcDbDate) | AcDbDate |
getLocalTime() (defined in AcDbDate) | AcDbDate |
getTime(short &hour, short &min, short &sec, short &msec) const (defined in AcDbDate) | AcDbDate |
getUniversalTime() (defined in AcDbDate) | AcDbDate |
hour() const (defined in AcDbDate) | AcDbDate |
InitialValue enum name (defined in AcDbDate) | AcDbDate |
julianDay() const (defined in AcDbDate) | AcDbDate |
julianFraction() const (defined in AcDbDate) | AcDbDate |
kInitLocalTime enum value (defined in AcDbDate) | AcDbDate |
kInitUniversalTime enum value (defined in AcDbDate) | AcDbDate |
kInitZero enum value (defined in AcDbDate) | AcDbDate |
localToUniversal() (defined in AcDbDate) | AcDbDate |
millisecond() const (defined in AcDbDate) | AcDbDate |
minute() const (defined in AcDbDate) | AcDbDate |
month() const (defined in AcDbDate) | AcDbDate |
msecsPastMidnight() const (defined in AcDbDate) | AcDbDate |
operator+(const AcDbDate &date) const (defined in AcDbDate) | AcDbDate | inline
operator+=(const AcDbDate &date) (defined in AcDbDate) | AcDbDate |
operator-(const AcDbDate &date) const (defined in AcDbDate) | AcDbDate | inline
operator-=(const AcDbDate &date) (defined in AcDbDate) | AcDbDate |
operator<(const AcDbDate &) const (defined in AcDbDate) | AcDbDate | inline
operator<=(const AcDbDate &) const (defined in AcDbDate) | AcDbDate | inline
operator=(const AcDbDate &) (defined in AcDbDate) | AcDbDate |
operator==(const AcDbDate &) const (defined in AcDbDate) | AcDbDate |
operator>(const AcDbDate &) const (defined in AcDbDate) | AcDbDate |
operator>=(const AcDbDate &) const (defined in AcDbDate) | AcDbDate |
second() const (defined in AcDbDate) | AcDbDate |
setDate(short month, short day, short year) (defined in AcDbDate) | AcDbDate |
setDay(short) (defined in AcDbDate) | AcDbDate |
setHour(short) (defined in AcDbDate) | AcDbDate |
setJulianDate(long julianDay, long msec) (defined in AcDbDate) | AcDbDate |
setJulianDay(long julianDay) (defined in AcDbDate) | AcDbDate |
setJulianFraction(double) (defined in AcDbDate) | AcDbDate |
setMillisecond(short) (defined in AcDbDate) | AcDbDate |
setMinute(short) (defined in AcDbDate) | AcDbDate |
setMonth(short) (defined in AcDbDate) | AcDbDate |
setMsecsPastMidnight(long msec) (defined in AcDbDate) | AcDbDate |
setSecond(short) (defined in AcDbDate) | AcDbDate |
setTime(short hour, short min, short sec, short msec) (defined in AcDbDate) | AcDbDate |
setToZero() (defined in AcDbDate) | AcDbDate |
setYear(short) (defined in AcDbDate) | AcDbDate |
subtract(const AcDbDate &date) (defined in AcDbDate) | AcDbDate | inline
universalToLocal() (defined in AcDbDate) | AcDbDate |
year() const (defined in AcDbDate) | AcDbDate |
~AcDbDate() (defined in AcDbDate) | AcDbDate | virtual


ZRX API Reference: AcDbDeepCloneFiler Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcDbDeepCloneFiler Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDeepCloneFiler:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbDeepCloneFiler)
virtual Acad::ErrorStatus | addReferences (AcDbIdRefQueue &)
virtual AcDbFilerController & | controller () const
virtual Acad::ErrorStatus | filerStatus () const
virtual AcDb::FilerType | filerType () const
virtual bool | getNextOwnedObject (AcDbObjectId &id)
virtual bool | moreOwnedObjects () const
virtual Acad::ErrorStatus | readAcDbHandle (AcDbHandle *)
virtual Acad::ErrorStatus | readAddress (void **)
virtual Acad::ErrorStatus | readBChunk (ads_binary *)
virtual Acad::ErrorStatus | readBool (bool *)
virtual Acad::ErrorStatus | readBoolean (Adesk::Boolean *)
virtual Acad::ErrorStatus | readBytes (void *, Adesk::UInt32)
virtual Acad::ErrorStatus | readDouble (double *)
virtual Acad::ErrorStatus | readHardOwnershipId (AcDbHardOwnershipId *)
virtual Acad::ErrorStatus | readHardPointerId (AcDbHardPointerId *)
virtual Acad::ErrorStatus | readInt16 (Adesk::Int16 *)
virtual Acad::ErrorStatus | readInt32 (Adesk::Int32 *)
virtual Acad::ErrorStatus | readInt64 (Adesk::Int64 *)
virtual Acad::ErrorStatus | readInt8 (Adesk::Int8 *)
virtual Acad::ErrorStatus | readPoint2d (AcGePoint2d *)
virtual Acad::ErrorStatus | readPoint3d (AcGePoint3d *)
virtual Acad::ErrorStatus | readScale3d (AcGeScale3d *)
virtual Acad::ErrorStatus | readSoftOwnershipId (AcDbSoftOwnershipId *)
virtual Acad::ErrorStatus | readSoftPointerId (AcDbSoftPointerId *)
virtual Acad::ErrorStatus | readString (ACHAR **)
virtual Acad::ErrorStatus | readString (AcString &)
virtual Acad::ErrorStatus | readUInt16 (Adesk::UInt16 *)
virtual Acad::ErrorStatus | readUInt32 (Adesk::UInt32 *)
virtual Acad::ErrorStatus | readUInt64 (Adesk::UInt64 *)
virtual Acad::ErrorStatus | readUInt8 (Adesk::UInt8 *)
virtual Acad::ErrorStatus | readVector2d (AcGeVector2d *)
virtual Acad::ErrorStatus | readVector3d (AcGeVector3d *)
virtual void | resetFilerStatus ()
virtual Acad::ErrorStatus | seek (long offset, int method)
virtual void | setFilerStatus (Acad::ErrorStatus)
virtual long | tell () const
virtual bool | usesReferences () const
virtual Acad::ErrorStatus | writeAcDbHandle (const AcDbHandle &)
virtual Acad::ErrorStatus | writeAddress (const void *)
virtual Acad::ErrorStatus | writeBChunk (const ads_binary &)
virtual Acad::ErrorStatus | writeBool (bool)
virtual Acad::ErrorStatus | writeBoolean (Adesk::Boolean)
virtual Acad::ErrorStatus | writeBytes (const void *, Adesk::UInt32)
virtual Acad::ErrorStatus | writeDouble (double)
virtual Acad::ErrorStatus | writeHardOwnershipId (const AcDbHardOwnershipId &)
virtual Acad::ErrorStatus | writeHardPointerId (const AcDbHardPointerId &)
virtual Acad::ErrorStatus | writeInt16 (Adesk::Int16)
virtual Acad::ErrorStatus | writeInt32 (Adesk::Int32)
virtual Acad::ErrorStatus | writeInt64 (Adesk::Int64)
virtual Acad::ErrorStatus | writeInt8 (Adesk::Int8)
virtual Acad::ErrorStatus | writePoint2d (const AcGePoint2d &)
virtual Acad::ErrorStatus | writePoint3d (const AcGePoint3d &)
virtual Acad::ErrorStatus | writeScale3d (const AcGeScale3d &)
virtual Acad::ErrorStatus | writeSoftOwnershipId (const AcDbSoftOwnershipId &)
virtual Acad::ErrorStatus | writeSoftPointerId (const AcDbSoftPointerId &)
virtual Acad::ErrorStatus | writeString (const ACHAR *)
virtual Acad::ErrorStatus | writeString (const AcString &)
virtual Acad::ErrorStatus | writeUInt16 (Adesk::UInt16)
virtual Acad::ErrorStatus | writeUInt32 (Adesk::UInt32)
virtual Acad::ErrorStatus | writeUInt64 (Adesk::UInt64)
virtual Acad::ErrorStatus | writeUInt8 (Adesk::UInt8)
virtual Acad::ErrorStatus | writeVector2d (const AcGeVector2d &)
virtual Acad::ErrorStatus | writeVector3d (const AcGeVector3d &)
- Public Member Functions inherited from AcDbDwgFiler
ACRX_DECLARE_MEMBERS (AcDbDwgFiler)
virtual Acad::ErrorStatus | dwgVersion (AcDb::AcDbDwgVersion &, AcDb::MaintenanceReleaseVersion &) const
virtual AcDbAuditInfo * | getAuditInfo () const
Acad::ErrorStatus | readChar (Adesk::Int8 *p)
Acad::ErrorStatus | readItem (AcDbHardOwnershipId *)
Acad::ErrorStatus | readItem (AcDbSoftOwnershipId *)
Acad::ErrorStatus | readItem (AcDbHardPointerId *)
Acad::ErrorStatus | readItem (AcDbSoftPointerId *)
Acad::ErrorStatus | readItem (ACHAR **)
Acad::ErrorStatus | readItem (ads_binary *)
Acad::ErrorStatus | readItem (AcDbHandle *)
Acad::ErrorStatus | readItem (Adesk::Int32 *)
Acad::ErrorStatus | readItem (Adesk::Int16 *)
Acad::ErrorStatus | readItem (Adesk::Int8 *)
Acad::ErrorStatus | readItem (Adesk::UInt32 *)
Acad::ErrorStatus | readItem (Adesk::UInt16 *)
Acad::ErrorStatus | readItem (Adesk::UInt8 *)
Acad::ErrorStatus | readItem (Adesk::Boolean *)
Acad::ErrorStatus | readItem (bool *)
Acad::ErrorStatus | readItem (double *)
Acad::ErrorStatus | readItem (AcGePoint2d *)
Acad::ErrorStatus | readItem (AcGePoint3d *)
Acad::ErrorStatus | readItem (AcGeVector2d *)
Acad::ErrorStatus | readItem (AcGeVector3d *)
Acad::ErrorStatus | readItem (AcGeScale3d *)
Acad::ErrorStatus | readItem (void *, Adesk::UInt32)
Acad::ErrorStatus | readItem (void **)
Acad::ErrorStatus | writeChar (Adesk::Int8 c)
Acad::ErrorStatus | writeItem (const AcDbHardOwnershipId &)
Acad::ErrorStatus | writeItem (const AcDbSoftOwnershipId &)
Acad::ErrorStatus | writeItem (const AcDbHardPointerId &)
Acad::ErrorStatus | writeItem (const AcDbSoftPointerId &)
Acad::ErrorStatus | writeItem (const ACHAR *)
Acad::ErrorStatus | writeItem (const ads_binary &)
Acad::ErrorStatus | writeItem (const AcDbHandle &)
Acad::ErrorStatus | writeItem (Adesk::Int32)
Acad::ErrorStatus | writeItem (Adesk::Int16)
Acad::ErrorStatus | writeItem (Adesk::Int8)
Acad::ErrorStatus | writeItem (Adesk::UInt32)
Acad::ErrorStatus | writeItem (Adesk::UInt16)
Acad::ErrorStatus | writeItem (Adesk::UInt8)
Acad::ErrorStatus | writeItem (Adesk::Boolean)
Acad::ErrorStatus | writeItem (bool)
Acad::ErrorStatus | writeItem (double)
Acad::ErrorStatus | writeItem (const AcGePoint2d &)
Acad::ErrorStatus | writeItem (const AcGePoint3d &)
Acad::ErrorStatus | writeItem (const AcGeVector2d &)
Acad::ErrorStatus | writeItem (const AcGeVector3d &)
Acad::ErrorStatus | writeItem (const AcGeScale3d &)
Acad::ErrorStatus | writeItem (const void *, Adesk::UInt32)
Acad::ErrorStatus | writeItem (const void *)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcDbDeepCloneFiler (AcDbSystemInternals *)

Friends

class AcDbSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbcfilrs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDeepCloneFiler Member List

This is the complete list of members for AcDbDeepCloneFiler, including all inherited members.

AcDbDeepCloneFiler() (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler |
AcDbDeepCloneFiler(AcDbSystemInternals *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | protected
AcDbDwgFiler() (defined in AcDbDwgFiler) | AcDbDwgFiler |
AcDbSystemInternals (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | friend
ACRX_DECLARE_MEMBERS(AcDbDeepCloneFiler) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler |
ACRX_DECLARE_MEMBERS(AcDbDwgFiler) (defined in AcDbDwgFiler) | AcDbDwgFiler |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addReferences(AcDbIdRefQueue &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
controller() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgVersion(AcDb::AcDbDwgVersion &, AcDb::MaintenanceReleaseVersion &) const (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
filerStatus() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
filerType() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
getAuditInfo() const (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
getNextOwnedObject(AcDbObjectId &id) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
moreOwnedObjects() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readAcDbHandle(AcDbHandle *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readAddress(void **) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readBChunk(ads_binary *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readBool(bool *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readBoolean(Adesk::Boolean *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readBytes(void *, Adesk::UInt32) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readChar(Adesk::Int8 *p) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readDouble(double *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readHardOwnershipId(AcDbHardOwnershipId *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readHardPointerId(AcDbHardPointerId *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readInt16(Adesk::Int16 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readInt32(Adesk::Int32 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readInt64(Adesk::Int64 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readInt8(Adesk::Int8 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readItem(AcDbHardOwnershipId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbSoftOwnershipId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbHardPointerId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbSoftPointerId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(ACHAR **) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(ads_binary *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbHandle *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Int32 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Int16 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Int8 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::UInt32 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::UInt16 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::UInt8 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Boolean *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(bool *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(double *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGePoint2d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGePoint3d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGeVector2d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGeVector3d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGeScale3d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(void *, Adesk::UInt32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(void **) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readPoint2d(AcGePoint2d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readPoint3d(AcGePoint3d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readScale3d(AcGeScale3d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readSoftOwnershipId(AcDbSoftOwnershipId *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readSoftPointerId(AcDbSoftPointerId *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readString(ACHAR **) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readString(AcString &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readUInt16(Adesk::UInt16 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readUInt32(Adesk::UInt32 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readUInt64(Adesk::UInt64 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readUInt8(Adesk::UInt8 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readVector2d(AcGeVector2d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readVector3d(AcGeVector3d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
resetFilerStatus() (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
seek(long offset, int method) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
setFilerStatus(Acad::ErrorStatus) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
tell() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
usesReferences() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeAcDbHandle(const AcDbHandle &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeAddress(const void *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeBChunk(const ads_binary &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeBool(bool) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeBoolean(Adesk::Boolean) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeBytes(const void *, Adesk::UInt32) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeChar(Adesk::Int8 c) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeDouble(double) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeHardOwnershipId(const AcDbHardOwnershipId &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeHardPointerId(const AcDbHardPointerId &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeInt16(Adesk::Int16) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeInt32(Adesk::Int32) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeInt64(Adesk::Int64) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeInt8(Adesk::Int8) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeItem(const AcDbHardOwnershipId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbSoftOwnershipId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbHardPointerId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbSoftPointerId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const ACHAR *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const ads_binary &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbHandle &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Int32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Int16) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Int8) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::UInt32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::UInt16) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::UInt8) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Boolean) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(bool) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(double) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGePoint2d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGePoint3d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGeVector2d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGeVector3d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGeScale3d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const void *, Adesk::UInt32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const void *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writePoint2d(const AcGePoint2d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writePoint3d(const AcGePoint3d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeScale3d(const AcGeScale3d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeSoftOwnershipId(const AcDbSoftOwnershipId &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeSoftPointerId(const AcDbSoftPointerId &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeString(const ACHAR *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeString(const AcString &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeUInt16(Adesk::UInt16) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeUInt32(Adesk::UInt32) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeUInt64(Adesk::UInt64) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeUInt8(Adesk::UInt8) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeVector2d(const AcGeVector2d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeVector3d(const AcGeVector3d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbDeepCloneFiler() (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
~AcDbDwgFiler() (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDgnDefinition Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDgnDefinition Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDgnDefinition:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDgnDefinition)
AcDbDgnDefinition ()
void | setShowRasterRef (bool bShow)
void | setUseMasterUnits (bool useMaster)
void | setXrefDepth (int depth)
bool | showRasterRef () const
bool | useMasterUnits () const
int | xrefDepth () const
virtual | ~AcDbDgnDefinition ()
- Public Member Functions inherited from AcDbUnderlayDefinition
ACDB_DECLARE_MEMBERS (AcDbUnderlayDefinition)
AcDbUnderlayDefinition ()
Acad::ErrorStatus | getActiveFileName (const ACHAR *&file) const
Acad::ErrorStatus | getActiveFileName (AcString &file) const
const ACHAR * | getItemName () const
const ACHAR * | getSourceFileName () const
const AcDbUnderlayItem * | getUnderlayItem () const
bool | isLoaded () const
Acad::ErrorStatus | load (const wchar_t *password)
Acad::ErrorStatus | setItemName (const ACHAR *item)
Acad::ErrorStatus | setSourceFileName (const ACHAR *file)
Acad::ErrorStatus | setUnderlayItem (const ACHAR *sourceFileName, const ACHAR *activeFileName, AcDbUnderlayItem *pItem)
void | unload ()
virtual | ~AcDbUnderlayDefinition ()=0
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcDbUnderlayDefinition
static AcString dictionaryKey (const AcRxClass *underlayDefinitionType)

Constructor & Destructor Documentation

AcDbDgnDefinition::AcDbDgnDefinition ( )
Warning
Not implemented!
virtual AcDbDgnDefinition::~AcDbDgnDefinition ( )
virtual
Warning
Not implemented!

Member Function Documentation

void AcDbDgnDefinition::setShowRasterRef ( bool bShow )
Warning
Not implemented!
void AcDbDgnDefinition::setUseMasterUnits ( bool useMaster )
Warning
Not implemented!
void AcDbDgnDefinition::setXrefDepth ( int depth )
Warning
Not implemented!
bool AcDbDgnDefinition::showRasterRef ( ) const
Warning
Not implemented!
bool AcDbDgnDefinition::useMasterUnits ( ) const
Warning
Not implemented!
int AcDbDgnDefinition::xrefDepth ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbunderlaydef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDgnDefinition Member List

This is the complete list of members for AcDbDgnDefinition, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDgnDefinition) (defined in AcDbDgnDefinition) | AcDbDgnDefinition |
ACDB_DECLARE_MEMBERS(AcDbUnderlayDefinition) (defined in AcDbUnderlayDefinition) | AcDbUnderlayDefinition |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDgnDefinition() | AcDbDgnDefinition |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbUnderlayDefinition() | AcDbUnderlayDefinition |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dictionaryKey(const AcRxClass *underlayDefinitionType) | AcDbUnderlayDefinition | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getActiveFileName(const ACHAR *&file) const | AcDbUnderlayDefinition |
getActiveFileName(AcString &file) const | AcDbUnderlayDefinition |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getItemName() const | AcDbUnderlayDefinition |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getSourceFileName() const | AcDbUnderlayDefinition |
getUnderlayItem() const | AcDbUnderlayDefinition |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLoaded() const | AcDbUnderlayDefinition |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
load(const wchar_t *password) | AcDbUnderlayDefinition |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setItemName(const ACHAR *item) | AcDbUnderlayDefinition |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setShowRasterRef(bool bShow) | AcDbDgnDefinition |
setSourceFileName(const ACHAR *file) | AcDbUnderlayDefinition |
setUnderlayItem(const ACHAR *sourceFileName, const ACHAR *activeFileName, AcDbUnderlayItem *pItem) | AcDbUnderlayDefinition |
setUseMasterUnits(bool useMaster) | AcDbDgnDefinition |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXrefDepth(int depth) | AcDbDgnDefinition |
showRasterRef() const | AcDbDgnDefinition |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unload() | AcDbUnderlayDefinition |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useMasterUnits() const | AcDbDgnDefinition |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
xrefDepth() const | AcDbDgnDefinition |
~AcDbDgnDefinition() | AcDbDgnDefinition | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbUnderlayDefinition()=0 | AcDbUnderlayDefinition | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDgnReference Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDgnReference Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDgnReference:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDgnReference)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
void | setXrefDepth (int depth)
- Public Member Functions inherited from AcDbUnderlayReference
ACDB_DECLARE_MEMBERS (AcDbUnderlayReference)
const AcGePoint2dArray & | clipBoundary () const
Adesk::UInt8 | contrast () const
AcDbObjectId | definitionId () const
Adesk::UInt8 | fade () const
Acad::ErrorStatus | getUnderlayLayer (int index, AcUnderlayLayer &layer) const
bool | isAdjustedForBackground () const
bool | isClipped () const
virtual bool | isContentSnappable () const
virtual bool | isFramePlottable () const
virtual bool | isFrameVisible () const
bool | isMonochrome () const
bool | isOn () const
AcGeVector3d | normal () const
AcGePoint3d | position () const
double | rotation () const
AcGeScale3d | scaleFactors () const
Acad::ErrorStatus | setClipBoundary (const AcGePoint2dArray &clipBoundary)
Acad::ErrorStatus | setContrast (Adesk::UInt8 value)
Acad::ErrorStatus | setDefinitionId (AcDbObjectId id)
Acad::ErrorStatus | setFade (Adesk::UInt8 value)
Acad::ErrorStatus | setIsAdjustedForBackground (bool value)
Acad::ErrorStatus | setIsClipped (bool value)
Acad::ErrorStatus | setIsMonochrome (bool value)
Acad::ErrorStatus | setIsOn (bool value)
Acad::ErrorStatus | setNormal (const AcGeVector3d &normal)
Acad::ErrorStatus | setPosition (const AcGePoint3d &position)
Acad::ErrorStatus | setRotation (double rotation)
Acad::ErrorStatus | setScaleFactors (const AcGeScale3d &scale)
Acad::ErrorStatus | setTransform (const AcGeMatrix3d &transform)
Acad::ErrorStatus | setUnderlayLayer (int index, const AcUnderlayLayer &layer)
AcGeMatrix3d | transform () const
Adesk::UInt32 | underlayLayerCount () const
virtual | ~AcDbUnderlayReference ()=0
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcDbUnderlayReference
static Adesk::UInt8 | contrastDefault ()
static Adesk::UInt8 | contrastLowerLimit ()
static Adesk::UInt8 | contrastUpperLimit ()
static Adesk::UInt8 | fadeDefault ()
static Adesk::UInt8 | fadeLowerLimit ()
static Adesk::UInt8 | fadeUpperLimit ()
The documentation for this class was generated from the following file:
  • dbunderlayref.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDgnReference Member List

This is the complete list of members for AcDbDgnReference, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDgnReference) (defined in AcDbDgnReference) | AcDbDgnReference |
ACDB_DECLARE_MEMBERS(AcDbUnderlayReference) (defined in AcDbUnderlayReference) | AcDbUnderlayReference |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDgnReference() (defined in AcDbDgnReference) | AcDbDgnReference |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clipBoundary() const | AcDbUnderlayReference |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const | AcDbUnderlayReference |
contrastDefault() | AcDbUnderlayReference | static
contrastLowerLimit() | AcDbUnderlayReference | static
contrastUpperLimit() | AcDbUnderlayReference | static
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
definitionId() const | AcDbUnderlayReference |
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fade() const | AcDbUnderlayReference |
fadeDefault() | AcDbUnderlayReference | static
fadeLowerLimit() | AcDbUnderlayReference | static
fadeUpperLimit() | AcDbUnderlayReference | static
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbDgnReference) | AcDbDgnReference | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
getUnderlayLayer(int index, AcUnderlayLayer &layer) const | AcDbUnderlayReference |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAdjustedForBackground() const | AcDbUnderlayReference |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClipped() const | AcDbUnderlayReference |
isContentSnappable() const | AcDbUnderlayReference | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFramePlottable() const | AcDbUnderlayReference | virtual
isFrameVisible() const | AcDbUnderlayReference | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isMonochrome() const | AcDbUnderlayReference |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isOn() const | AcDbUnderlayReference |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const | AcDbUnderlayReference |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const | AcDbUnderlayReference |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const | AcDbUnderlayReference |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
scaleFactors() const | AcDbUnderlayReference |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setClipBoundary(const AcGePoint2dArray &clipBoundary) | AcDbUnderlayReference |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setContrast(Adesk::UInt8 value) | AcDbUnderlayReference |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDefinitionId(AcDbObjectId id) | AcDbUnderlayReference |
setFade(Adesk::UInt8 value) | AcDbUnderlayReference |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setIsAdjustedForBackground(bool value) | AcDbUnderlayReference |
setIsClipped(bool value) | AcDbUnderlayReference |
setIsMonochrome(bool value) | AcDbUnderlayReference |
setIsOn(bool value) | AcDbUnderlayReference |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &normal) | AcDbUnderlayReference |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &position) | AcDbUnderlayReference |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double rotation) | AcDbUnderlayReference |
setScaleFactors(const AcGeScale3d &scale) | AcDbUnderlayReference |
setTransform(const AcGeMatrix3d &transform) | AcDbUnderlayReference |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUnderlayLayer(int index, const AcUnderlayLayer &layer) | AcDbUnderlayReference |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXrefDepth(int depth) (defined in AcDbDgnReference) | AcDbDgnReference |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transform() const | AcDbUnderlayReference |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
underlayLayerCount() const | AcDbUnderlayReference |
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDgnReference() (defined in AcDbDgnReference) | AcDbDgnReference | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbUnderlayReference()=0 | AcDbUnderlayReference | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDgnUnderlayItem Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDgnUnderlayItem Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDgnUnderlayItem:

Public Member Functions

virtual void | setShowRasterRef (bool bShow)=0
virtual void | setUseMasterUnits (bool bUseMasterUnits)=0
virtual bool | showRasterRef () const =0
virtual bool | useMasterUnits () const =0
- Public Member Functions inherited from AcDbUnderlayItem
virtual Acad::ErrorStatus | draw (AcGiWorldDraw *pWorldDraw, AcGiViewportDraw *pViewportDraw, const AcDbUnderlayDrawContext &context) const =0
virtual Acad::ErrorStatus | getExtents (AcGePoint2d &min, AcGePoint2d &max) const =0
virtual AcString | getName () const =0
virtual Acad::ErrorStatus | getOsnapPoints (const AcGeMatrix3d &modelToWorld, AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const =0
virtual AcDbEntity * | getSubEntityAtGsMarker (const AcGeMatrix3d &modelToWorld, Adesk::GsMarker gsSelectionMark) const =0
virtual Acad::ErrorStatus | getThumbnail (BITMAPINFO *&thumbnail) const =0
virtual Acad::ErrorStatus | getUnderlayLayer (int idx, AcUnderlayLayer &layer) const
virtual AcDb::UnitsValue | getUnits () const =0
virtual Acad::ErrorStatus | intersectWith (const AcGeMatrix3d &modelToWorld, const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane *projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const =0
virtual AcGeMatrix3d | modelTransform () const =0
virtual Adesk::UInt32 | underlayLayerCount () const
virtual bool | usingPartialContent () const =0
int | version () const
The documentation for this class was generated from the following file:
  • dbunderlayhost.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDgnUnderlayItem Member List

This is the complete list of members for AcDbDgnUnderlayItem, including all inherited members.

draw(AcGiWorldDraw *pWorldDraw, AcGiViewportDraw *pViewportDraw, const AcDbUnderlayDrawContext &context) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getExtents(AcGePoint2d &min, AcGePoint2d &max) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getName() const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getOsnapPoints(const AcGeMatrix3d &modelToWorld, AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getSubEntityAtGsMarker(const AcGeMatrix3d &modelToWorld, Adesk::GsMarker gsSelectionMark) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getThumbnail(BITMAPINFO *&thumbnail) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getUnderlayLayer(int idx, AcUnderlayLayer &layer) const (defined in AcDbUnderlayItem) | AcDbUnderlayItem | inlinevirtual
getUnits() const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
intersectWith(const AcGeMatrix3d &modelToWorld, const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane *projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
modelTransform() const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
setShowRasterRef(bool bShow)=0 (defined in AcDbDgnUnderlayItem) | AcDbDgnUnderlayItem | pure virtual
setUseMasterUnits(bool bUseMasterUnits)=0 (defined in AcDbDgnUnderlayItem) | AcDbDgnUnderlayItem | pure virtual
showRasterRef() const =0 (defined in AcDbDgnUnderlayItem) | AcDbDgnUnderlayItem | pure virtual
underlayLayerCount() const (defined in AcDbUnderlayItem) | AcDbUnderlayItem | inlinevirtual
useMasterUnits() const =0 (defined in AcDbDgnUnderlayItem) | AcDbDgnUnderlayItem | pure virtual
usingPartialContent() const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
version() const (defined in AcDbUnderlayItem) | AcDbUnderlayItem |
~AcDbUnderlayItem()=0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual


ZRX API Reference: AcDbDiametricDimension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDiametricDimension Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDiametricDimension:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDiametricDimension)
AcDbDiametricDimension (const AcGePoint3d &chordPoint, const AcGePoint3d &farChordPoint, double leaderLength, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull)
AcGePoint3d | chordPoint () const
double | extArcEndAngle () const
double | extArcStartAngle () const
AcGePoint3d | farChordPoint () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
double | leaderLength () const
Acad::ErrorStatus | setChordPoint (const AcGePoint3d &)
Acad::ErrorStatus | setExtArcEndAngle (double newAngle)
Acad::ErrorStatus | setExtArcStartAngle (double newAngle)
Acad::ErrorStatus | setFarChordPoint (const AcGePoint3d &)
Acad::ErrorStatus | setLeaderLength (double)
- Public Member Functions inherited from AcDbDimension
ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbDimension
enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDiametricDimension Member List

This is the complete list of members for AcDbDiametricDimension, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDiametricDimension) (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDiametricDimension() (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
AcDbDiametricDimension(const AcGePoint3d &chordPoint, const AcGePoint3d &farChordPoint, double leaderLength, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull) (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
chordPoint() const (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extArcEndAngle() const (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
extArcStartAngle() const (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
farChordPoint() const (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbDiametricDimension) | AcDbDiametricDimension | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
leaderLength() const (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setChordPoint(const AcGePoint3d &) (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setExtArcEndAngle(double newAngle) (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
setExtArcStartAngle(double newAngle) (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
setFarChordPoint(const AcGePoint3d &) (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLeaderLength(double) (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDiametricDimension() (defined in AcDbDiametricDimension) | AcDbDiametricDimension |
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDictionary Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDictionary Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDictionary:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDictionary)
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual void | erased (const AcDbObject *pObject, Adesk::Boolean pErasing=Adesk::kTrue)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObject *&entryObj, AcDb::OpenMode mode) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &entryObj) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual void | goodbye (const AcDbObject *pObject)
bool | has (const ACHAR *entryName) const
bool | has (AcDbObjectId objId) const
bool | isTreatElementsAsHard () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
Acad::ErrorStatus | nameAt (AcDbObjectId objId, ACHAR *&name) const
Acad::ErrorStatus | nameAt (AcDbObjectId objId, AcString &name) const
AcDbDictionaryIterator * | newIterator () const
Adesk::UInt32 | numEntries () const
Acad::ErrorStatus | remove (const ACHAR *key)
Acad::ErrorStatus | remove (const ACHAR *key, AcDbObjectId &returnId)
Acad::ErrorStatus | remove (AcDbObjectId objId)
Acad::ErrorStatus | setAt (const ACHAR *srchKey, AcDbObject *newValue, AcDbObjectId &retObjId)
virtual void | setMergeStyle (AcDb::DuplicateRecordCloning style)
bool | setName (const ACHAR *oldName, const ACHAR *newName)
void | setTreatElementsAsHard (bool doIt)
virtual Acad::ErrorStatus | subErase (Adesk::Boolean pErasing=Adesk::kTrue)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdict.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDictionary Member List

This is the complete list of members for AcDbDictionary, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDictionary) (defined in AcDbDictionary) | AcDbDictionary |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDictionary() (defined in AcDbDictionary) | AcDbDictionary |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbDictionary) | AcDbDictionary | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbDictionary) | AcDbDictionary | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbDictionary) | AcDbDictionary | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbDictionary) | AcDbDictionary | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbDictionary) | AcDbDictionary | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *pObject, Adesk::Boolean pErasing=Adesk::kTrue) (defined in AcDbDictionary) | AcDbDictionary | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbObject *&entryObj, AcDb::OpenMode mode) const (defined in AcDbDictionary) | AcDbDictionary |
getAt(const ACHAR *entryName, AcDbObjectId &entryObj) const (defined in AcDbDictionary) | AcDbDictionary |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbDictionary) | AcDbDictionary | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *pObject) (defined in AcDbDictionary) | AcDbDictionary | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *entryName) const (defined in AcDbDictionary) | AcDbDictionary |
has(AcDbObjectId objId) const (defined in AcDbDictionary) | AcDbDictionary |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isTreatElementsAsHard() const (defined in AcDbDictionary) | AcDbDictionary |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbDictionary) | AcDbDictionary | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
nameAt(AcDbObjectId objId, ACHAR *&name) const (defined in AcDbDictionary) | AcDbDictionary |
nameAt(AcDbObjectId objId, AcString &name) const (defined in AcDbDictionary) | AcDbDictionary |
newIterator() const (defined in AcDbDictionary) | AcDbDictionary |
numEntries() const (defined in AcDbDictionary) | AcDbDictionary |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
remove(const ACHAR *key) (defined in AcDbDictionary) | AcDbDictionary |
remove(const ACHAR *key, AcDbObjectId &returnId) (defined in AcDbDictionary) | AcDbDictionary |
remove(AcDbObjectId objId) (defined in AcDbDictionary) | AcDbDictionary |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAt(const ACHAR *srchKey, AcDbObject *newValue, AcDbObjectId &retObjId) (defined in AcDbDictionary) | AcDbDictionary |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setMergeStyle(AcDb::DuplicateRecordCloning style) (defined in AcDbDictionary) | AcDbDictionary | virtual
setName(const ACHAR *oldName, const ACHAR *newName) (defined in AcDbDictionary) | AcDbDictionary |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setTreatElementsAsHard(bool doIt) (defined in AcDbDictionary) | AcDbDictionary |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean pErasing=Adesk::kTrue) (defined in AcDbDictionary) | AcDbDictionary | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDictionary() (defined in AcDbDictionary) | AcDbDictionary | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDictionaryIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDictionaryIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDictionaryIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbDictionaryIterator)
virtual bool | done () const =0
virtual Acad::ErrorStatus | getObject (AcDbObject *&pObject, AcDb::OpenMode mode)=0
virtual const ACHAR * | name () const =0
virtual bool | next ()=0
virtual AcDbObjectId | objectId () const =0
virtual bool | setPosition (AcDbObjectId objId)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbdict.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDictionaryIterator Member List

This is the complete list of members for AcDbDictionaryIterator, including all inherited members.

AcDbDictionaryIterator() (defined in AcDbDictionaryIterator) | AcDbDictionaryIterator | inlineprotected
ACRX_DECLARE_MEMBERS(AcDbDictionaryIterator) (defined in AcDbDictionaryIterator) | AcDbDictionaryIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const =0 (defined in AcDbDictionaryIterator) | AcDbDictionaryIterator | pure virtual
getObject(AcDbObject *&pObject, AcDb::OpenMode mode)=0 (defined in AcDbDictionaryIterator) | AcDbDictionaryIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
name() const =0 (defined in AcDbDictionaryIterator) | AcDbDictionaryIterator | pure virtual
next()=0 (defined in AcDbDictionaryIterator) | AcDbDictionaryIterator | pure virtual
objectId() const =0 (defined in AcDbDictionaryIterator) | AcDbDictionaryIterator | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setPosition(AcDbObjectId objId)=0 (defined in AcDbDictionaryIterator) | AcDbDictionaryIterator | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbDictionaryIterator() (defined in AcDbDictionaryIterator) | AcDbDictionaryIterator | inlinevirtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDictionaryWithDefault Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDictionaryWithDefault Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDictionaryWithDefault:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDictionaryWithDefault)
AcDbObjectId | defaultId () const
virtual Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
Acad::ErrorStatus | setDefaultId (const AcDbObjectId &newId)
- Public Member Functions inherited from AcDbDictionary
ACDB_DECLARE_MEMBERS (AcDbDictionary)
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual void | erased (const AcDbObject *pObject, Adesk::Boolean pErasing=Adesk::kTrue)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObject *&entryObj, AcDb::OpenMode mode) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &entryObj) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual void | goodbye (const AcDbObject *pObject)
bool | has (const ACHAR *entryName) const
bool | has (AcDbObjectId objId) const
bool | isTreatElementsAsHard () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
Acad::ErrorStatus | nameAt (AcDbObjectId objId, ACHAR *&name) const
Acad::ErrorStatus | nameAt (AcDbObjectId objId, AcString &name) const
AcDbDictionaryIterator * | newIterator () const
Adesk::UInt32 | numEntries () const
Acad::ErrorStatus | remove (const ACHAR *key)
Acad::ErrorStatus | remove (const ACHAR *key, AcDbObjectId &returnId)
Acad::ErrorStatus | remove (AcDbObjectId objId)
Acad::ErrorStatus | setAt (const ACHAR *srchKey, AcDbObject *newValue, AcDbObjectId &retObjId)
virtual void | setMergeStyle (AcDb::DuplicateRecordCloning style)
bool | setName (const ACHAR *oldName, const ACHAR *newName)
void | setTreatElementsAsHard (bool doIt)
virtual Acad::ErrorStatus | subErase (Adesk::Boolean pErasing=Adesk::kTrue)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdictdflt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDictionaryWithDefault Member List

This is the complete list of members for AcDbDictionaryWithDefault, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDictionaryWithDefault) (defined in AcDbDictionaryWithDefault) | AcDbDictionaryWithDefault |
ACDB_DECLARE_MEMBERS(AcDbDictionary) (defined in AcDbDictionary) | AcDbDictionary |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDictionary() (defined in AcDbDictionary) | AcDbDictionary |
AcDbDictionaryWithDefault() (defined in AcDbDictionaryWithDefault) | AcDbDictionaryWithDefault |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbDictionary) | AcDbDictionary | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
defaultId() const (defined in AcDbDictionaryWithDefault) | AcDbDictionaryWithDefault |
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbDictionary) | AcDbDictionary | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbDictionary) | AcDbDictionary | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbDictionary) | AcDbDictionary | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbDictionary) | AcDbDictionary | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *pObject, Adesk::Boolean pErasing=Adesk::kTrue) (defined in AcDbDictionary) | AcDbDictionary | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbObject *&entryObj, AcDb::OpenMode mode) const (defined in AcDbDictionary) | AcDbDictionary |
getAt(const ACHAR *entryName, AcDbObjectId &entryObj) const (defined in AcDbDictionary) | AcDbDictionary |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbDictionary) | AcDbDictionary | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbDictionaryWithDefault) | AcDbDictionaryWithDefault | virtual
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *pObject) (defined in AcDbDictionary) | AcDbDictionary | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *entryName) const (defined in AcDbDictionary) | AcDbDictionary |
has(AcDbObjectId objId) const (defined in AcDbDictionary) | AcDbDictionary |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isTreatElementsAsHard() const (defined in AcDbDictionary) | AcDbDictionary |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbDictionary) | AcDbDictionary | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
nameAt(AcDbObjectId objId, ACHAR *&name) const (defined in AcDbDictionary) | AcDbDictionary |
nameAt(AcDbObjectId objId, AcString &name) const (defined in AcDbDictionary) | AcDbDictionary |
newIterator() const (defined in AcDbDictionary) | AcDbDictionary |
numEntries() const (defined in AcDbDictionary) | AcDbDictionary |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
remove(const ACHAR *key) (defined in AcDbDictionary) | AcDbDictionary |
remove(const ACHAR *key, AcDbObjectId &returnId) (defined in AcDbDictionary) | AcDbDictionary |
remove(AcDbObjectId objId) (defined in AcDbDictionary) | AcDbDictionary |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAt(const ACHAR *srchKey, AcDbObject *newValue, AcDbObjectId &retObjId) (defined in AcDbDictionary) | AcDbDictionary |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDefaultId(const AcDbObjectId &newId) (defined in AcDbDictionaryWithDefault) | AcDbDictionaryWithDefault |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setMergeStyle(AcDb::DuplicateRecordCloning style) (defined in AcDbDictionary) | AcDbDictionary | virtual
setName(const ACHAR *oldName, const ACHAR *newName) (defined in AcDbDictionary) | AcDbDictionary |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setTreatElementsAsHard(bool doIt) (defined in AcDbDictionary) | AcDbDictionary |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean pErasing=Adesk::kTrue) (defined in AcDbDictionary) | AcDbDictionary | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDictionary() (defined in AcDbDictionary) | AcDbDictionary | virtual
~AcDbDictionaryWithDefault() (defined in AcDbDictionaryWithDefault) | AcDbDictionaryWithDefault | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDimAssoc Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
AcDbDimAssoc Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDimAssoc:

Public Types

enum | { kMaxPointRefs = 4 }
enum | AssocFlags { kFirstPointRef = 1, kSecondPointRef = 2, kThirdPointRef = 4, kFourthPointRef = 8 }
enum PointType {
kXline1Point = 0, kXline2Point = 1, kOriginPoint = 0, kDefiningPoint = 1,
kXline1Start = 0, kXline1End = 1, kXline2Start = 2, kXline2End = 3,
kVertexPoint = 2, kChordPoint = 0, kCenterPoint = 1, kFarChordPoint = 1,
kOverrideCenterPoint = 2, kAngLineStart = 2, kJogPoint = 3, kAngLineEnd = 3,
kLeaderPoint = 0
}
enum | RotatedDimType { kUnknown = 0, kParallel = 1, kPerpendicular = 2 }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDimAssoc)
Acad::ErrorStatus | addToDimensionReactor (bool isAdd=true)
Acad::ErrorStatus | addToPointRefReactor ()
bool | assocFlag (int ptType) const
int | assocFlag (void)
AcDbObjectId | dimObjId () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *) const
Acad::ErrorStatus | getDimAssocGeomIds (AcDbObjectIdArray &geomIds) const
bool | hasOopsWatcher (void) const
bool | isAllGeomErased () const
bool | isTransSpatial () const
virtual void | modifiedGraphics (const AcDbEntity *pObj)
const AcDbPointRef * | pointRef (int ptType) const
Acad::ErrorStatus | post (AcDbObjectId dimId, AcDbObjectId &dimAssocId, bool isActive=true)
Acad::ErrorStatus | removeAssociativity (bool force=true)
void | removeOopsWatcher (void)
Acad::ErrorStatus | removePointRef (int ptType)
Acad::ErrorStatus | restoreAssocFromOopsWatcher (void)
RotatedDimType | rotatedDimType () const
Acad::ErrorStatus | setAssocFlag (int ptType, bool value)
void | setAssocFlag (int assocFlg)
Acad::ErrorStatus | setDimObjId (const AcDbObjectId &dimId)
Acad::ErrorStatus | setPointRef (int ptType, AcDbPointRef *ptRef)
Acad::ErrorStatus | setRotatedDimType (RotatedDimType dimType)
Acad::ErrorStatus | setTransSpatial (bool value)
Acad::ErrorStatus | startCmdWatcher ()
Acad::ErrorStatus | startOopsWatcher (bool bAddAll=true)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
Acad::ErrorStatus | updateAssociativity (const AcDbObjectIdArray &ids)
Acad::ErrorStatus | updateDimension (bool update=true, bool skipReactors=false)
void | updateDueToMirror (bool wasInMirror)
Acad::ErrorStatus | updateFillet (const AcDbObjectIdArray &ids)
Acad::ErrorStatus | updateSubentPath (AcDbIdMapping &idMap)
Acad::ErrorStatus | updateXrefSubentPath ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

Acad::ErrorStatus | calculate2LineAngDimArcLocation (const AcGePoint3d *kpOldPts, const AcGePoint3d &kOldArcPt, const AcGePoint3d &kOldTextPt, const AcGePoint3d *kpNewPts, const AcGeVector3d &kNormal, AcGePoint3d &newArcPt, AcGePoint3d &newTextPt)
Acad::ErrorStatus | calculate3PointAngDimArcLocation (const AcGePoint3d *kpOldPts, const AcGePoint3d &kOldArcPt, const AcGePoint3d &kOldTextPt, const AcGePoint3d *kpNewPts, const AcGeVector3d &normal, AcGePoint3d &newArcPt, AcGePoint3d &newTextPt)
bool | isPointBetweenRays (const AcGePoint3d &vertex, const AcGePoint3d &firstPt, const AcGePoint3d &secondPt, const AcGePoint3d &angPt, const AcGeVector3d &normal)
Acad::ErrorStatus | removeDimExtDict (void)
Acad::ErrorStatus | setPointRefReactor (int ptType, bool isAdd=true)
Acad::ErrorStatus | updateDimension (AcDbRotatedDimension *pRotDim, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDbAlignedDimension *pAlnDim, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDbRadialDimension *pRadDim, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDbRadialDimensionLarge *pRadDimLarge, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDbDiametricDimension *pDiaDim, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDb2LineAngularDimension *pA2Dim, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDb3PointAngularDimension *pA3Dim, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDbOrdinateDimension *pOrdDim, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDbArcDimension *pArcDim, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDbLeader *pLeader, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimension (AcDbMLeader *pMLeader, AcGePoint3d *pNewPts, bool bUpdate=true)
Acad::ErrorStatus | updateDimLineAndTextLocation (AcDbRotatedDimension *pAlnDim, const AcGePoint3d *kpOldPts, const AcGePoint3d *kpNewPts)
Acad::ErrorStatus | updateDimLineAndTextLocation (AcDbAlignedDimension *pAlnDim, const AcGePoint3d *pOldPts, const AcGePoint3d *pNewPts)
Acad::ErrorStatus | updateDimLineAndTextLocation (AcDb2LineAngularDimension *pA2Dim, const AcGePoint3d *pOldPts, const AcGePoint3d *pNewPts)
Acad::ErrorStatus | updateDimLineAndTextLocation (AcDb3PointAngularDimension *pA3Dim, const AcGePoint3d *pOldPts, const AcGePoint3d *pNewPts)
Acad::ErrorStatus | updateDimLineAndTextLocation (AcDbArcDimension *pArcDim, const AcGePoint3d *kpOldPts, const AcGePoint3d *kpNewPts)

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdimassoc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDimAssoc Member List

This is the complete list of members for AcDbDimAssoc, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDimAssoc) (defined in AcDbDimAssoc) | AcDbDimAssoc |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimAssoc() (defined in AcDbDimAssoc) | AcDbDimAssoc |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addToDimensionReactor(bool isAdd=true) (defined in AcDbDimAssoc) | AcDbDimAssoc |
addToPointRefReactor() (defined in AcDbDimAssoc) | AcDbDimAssoc |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
assocFlag(int ptType) const (defined in AcDbDimAssoc) | AcDbDimAssoc |
assocFlag(void) (defined in AcDbDimAssoc) | AcDbDimAssoc |
AssocFlags enum name (defined in AcDbDimAssoc) | AcDbDimAssoc |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
calculate2LineAngDimArcLocation(const AcGePoint3d *kpOldPts, const AcGePoint3d &kOldArcPt, const AcGePoint3d &kOldTextPt, const AcGePoint3d *kpNewPts, const AcGeVector3d &kNormal, AcGePoint3d &newArcPt, AcGePoint3d &newTextPt) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
calculate3PointAngDimArcLocation(const AcGePoint3d *kpOldPts, const AcGePoint3d &kOldArcPt, const AcGePoint3d &kOldTextPt, const AcGePoint3d *kpNewPts, const AcGeVector3d &normal, AcGePoint3d &newArcPt, AcGePoint3d &newTextPt) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimObjId() const (defined in AcDbDimAssoc) | AcDbDimAssoc |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *) (defined in AcDbDimAssoc) | AcDbDimAssoc | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *) const (defined in AcDbDimAssoc) | AcDbDimAssoc | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *) (defined in AcDbDimAssoc) | AcDbDimAssoc | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *) const (defined in AcDbDimAssoc) | AcDbDimAssoc | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getDimAssocGeomIds(AcDbObjectIdArray &geomIds) const (defined in AcDbDimAssoc) | AcDbDimAssoc |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasOopsWatcher(void) const (defined in AcDbDimAssoc) | AcDbDimAssoc |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAllGeomErased() const (defined in AcDbDimAssoc) | AcDbDimAssoc |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPointBetweenRays(const AcGePoint3d &vertex, const AcGePoint3d &firstPt, const AcGePoint3d &secondPt, const AcGePoint3d &angPt, const AcGeVector3d &normal) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isTransSpatial() const (defined in AcDbDimAssoc) | AcDbDimAssoc |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kAngLineEnd enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kAngLineStart enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kCenterPoint enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kChordPoint enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kDefiningPoint enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kFarChordPoint enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kFirstPointRef enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kFourthPointRef enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kJogPoint enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kLeaderPoint enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kMaxPointRefs enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kOriginPoint enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kOverrideCenterPoint enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kParallel enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kPerpendicular enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSecondPointRef enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kThirdPointRef enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kUnknown enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kVertexPoint enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kXline1End enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kXline1Point enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kXline1Start enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kXline2End enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kXline2Point enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
kXline2Start enum value (defined in AcDbDimAssoc) | AcDbDimAssoc |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *pObj) (defined in AcDbDimAssoc) | AcDbDimAssoc | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
pointRef(int ptType) const (defined in AcDbDimAssoc) | AcDbDimAssoc |
PointType enum name (defined in AcDbDimAssoc) | AcDbDimAssoc |
post(AcDbObjectId dimId, AcDbObjectId &dimAssocId, bool isActive=true) (defined in AcDbDimAssoc) | AcDbDimAssoc |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeAssociativity(bool force=true) (defined in AcDbDimAssoc) | AcDbDimAssoc |
removeDimExtDict(void) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeOopsWatcher(void) (defined in AcDbDimAssoc) | AcDbDimAssoc |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removePointRef(int ptType) (defined in AcDbDimAssoc) | AcDbDimAssoc |
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
restoreAssocFromOopsWatcher(void) (defined in AcDbDimAssoc) | AcDbDimAssoc |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
RotatedDimType enum name (defined in AcDbDimAssoc) | AcDbDimAssoc |
rotatedDimType() const (defined in AcDbDimAssoc) | AcDbDimAssoc |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAssocFlag(int ptType, bool value) (defined in AcDbDimAssoc) | AcDbDimAssoc |
setAssocFlag(int assocFlg) (defined in AcDbDimAssoc) | AcDbDimAssoc |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDimObjId(const AcDbObjectId &dimId) (defined in AcDbDimAssoc) | AcDbDimAssoc |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPointRef(int ptType, AcDbPointRef *ptRef) (defined in AcDbDimAssoc) | AcDbDimAssoc |
setPointRefReactor(int ptType, bool isAdd=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
setRotatedDimType(RotatedDimType dimType) (defined in AcDbDimAssoc) | AcDbDimAssoc |
setTransSpatial(bool value) (defined in AcDbDimAssoc) | AcDbDimAssoc |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
startCmdWatcher() (defined in AcDbDimAssoc) | AcDbDimAssoc |
startOopsWatcher(bool bAddAll=true) (defined in AcDbDimAssoc) | AcDbDimAssoc |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbDimAssoc) | AcDbDimAssoc | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
updateAssociativity(const AcDbObjectIdArray &ids) (defined in AcDbDimAssoc) | AcDbDimAssoc |
updateDimension(bool update=true, bool skipReactors=false) (defined in AcDbDimAssoc) | AcDbDimAssoc |
updateDimension(AcDbRotatedDimension *pRotDim, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDbAlignedDimension *pAlnDim, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDbRadialDimension *pRadDim, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDbRadialDimensionLarge *pRadDimLarge, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDbDiametricDimension *pDiaDim, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDb2LineAngularDimension *pA2Dim, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDb3PointAngularDimension *pA3Dim, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDbOrdinateDimension *pOrdDim, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDbArcDimension *pArcDim, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDbLeader *pLeader, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimension(AcDbMLeader *pMLeader, AcGePoint3d *pNewPts, bool bUpdate=true) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimLineAndTextLocation(AcDbRotatedDimension *pAlnDim, const AcGePoint3d *kpOldPts, const AcGePoint3d *kpNewPts) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimLineAndTextLocation(AcDbAlignedDimension *pAlnDim, const AcGePoint3d *pOldPts, const AcGePoint3d *pNewPts) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimLineAndTextLocation(AcDb2LineAngularDimension *pA2Dim, const AcGePoint3d *pOldPts, const AcGePoint3d *pNewPts) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimLineAndTextLocation(AcDb3PointAngularDimension *pA3Dim, const AcGePoint3d *pOldPts, const AcGePoint3d *pNewPts) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDimLineAndTextLocation(AcDbArcDimension *pArcDim, const AcGePoint3d *kpOldPts, const AcGePoint3d *kpNewPts) (defined in AcDbDimAssoc) | AcDbDimAssoc | protected
updateDueToMirror(bool wasInMirror) (defined in AcDbDimAssoc) | AcDbDimAssoc |
updateFillet(const AcDbObjectIdArray &ids) (defined in AcDbDimAssoc) | AcDbDimAssoc |
updateSubentPath(AcDbIdMapping &idMap) (defined in AcDbDimAssoc) | AcDbDimAssoc |
updateXrefSubentPath() (defined in AcDbDimAssoc) | AcDbDimAssoc |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDimAssoc() (defined in AcDbDimAssoc) | AcDbDimAssoc | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDimData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbDimData Class Reference
AcDb Classes

Public Types

enum DimDataFlags {
kDimEditable = 0x1, kDimInvisible = 0x2, kDimFocal = 0x4, kDimHideIfValueIsZero = 0x8,
kDimEmptyData = 0x10, kDimResultantLength = 0x20, kDimDeltaLength = 0x40, kDimResultantAngle = 0x80,
kDimDeltaAngle = 0x100, kDimRadius = 0x200, kDimCustomValue = 0x400, kDimConstrained = 0x800,
kDimCustomString = 0x1000
}

Public Member Functions

AcDbDimData (AcDbDimension *pDim, DimDataSetValueFuncPtr setDimFunc=NULL, unsigned int bitFlags=0, void *appData=NULL, DimDataSetCustomStringFuncPtr setCustomStringFunc=NULL)
AcDbDimData (const AcDbDimData &)
void * | appData () const
unsigned int | bitFlags () const
DimDataSetCustomStringFuncPtr | customStringFunc () const
AcDbDimension * | dimension () const
DimDataSetValueFuncPtr | dimValueFunc () const
bool | isConstrained () const
bool | isCustomDimValue () const
bool | isCustomString () const
bool | isDimDeltaAngle () const
bool | isDimDeltaLength () const
bool | isDimEditable () const
bool | isDimFocal () const
bool | isDimHideIfValueIsZero () const
bool | isDimInvisible () const
bool | isDimRadius () const
bool | isDimResultantAngle () const
bool | isDimResultantLength () const
AcDbDimData & | operator= (const AcDbDimData &)
AcDbObjectId | ownerId () const
Acad::ErrorStatus | setAppData (void *appData)
Acad::ErrorStatus | setBitFlags (unsigned int flags)
Acad::ErrorStatus | setConstrain (bool bValue)
Acad::ErrorStatus | setCustomDimValue (bool custom)
Acad::ErrorStatus | setCustomString (bool bValue)
Acad::ErrorStatus | setCustomStringFunc (DimDataSetCustomStringFuncPtr funcPtr)
Acad::ErrorStatus | setDimDeltaAngle (bool bValue)
Acad::ErrorStatus | setDimDeltaLength (bool bValue)
Acad::ErrorStatus | setDimEditable (bool editable)
Acad::ErrorStatus | setDimension (AcDbDimension *pDim)
Acad::ErrorStatus | setDimFocal (bool focal)
Acad::ErrorStatus | setDimHideIfValueIsZero (bool hide)
Acad::ErrorStatus | setDimInvisible (bool invisible)
Acad::ErrorStatus | setDimRadius (bool bValue)
Acad::ErrorStatus | setDimResultantAngle (bool bValue)
Acad::ErrorStatus | setDimResultantLength (bool bValue)
Acad::ErrorStatus | setDimValueFunc (DimDataSetValueFuncPtr funcPtr)
Acad::ErrorStatus | setOwnerId (const AcDbObjectId &objId)
The documentation for this class was generated from the following file:
  • dbdimdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDimData Member List

This is the complete list of members for AcDbDimData, including all inherited members.

AcDbDimData() (defined in AcDbDimData) | AcDbDimData | inline
AcDbDimData(AcDbDimension *pDim, DimDataSetValueFuncPtr setDimFunc=NULL, unsigned int bitFlags=0, void *appData=NULL, DimDataSetCustomStringFuncPtr setCustomStringFunc=NULL) (defined in AcDbDimData) | AcDbDimData | inline
AcDbDimData(const AcDbDimData &) (defined in AcDbDimData) | AcDbDimData | inline
appData() const (defined in AcDbDimData) | AcDbDimData | inline
bitFlags() const (defined in AcDbDimData) | AcDbDimData | inline
customStringFunc() const (defined in AcDbDimData) | AcDbDimData | inline
DimDataFlags enum name (defined in AcDbDimData) | AcDbDimData |
dimension() const (defined in AcDbDimData) | AcDbDimData | inline
dimValueFunc() const (defined in AcDbDimData) | AcDbDimData | inline
isConstrained() const (defined in AcDbDimData) | AcDbDimData | inline
isCustomDimValue() const (defined in AcDbDimData) | AcDbDimData | inline
isCustomString() const (defined in AcDbDimData) | AcDbDimData | inline
isDimDeltaAngle() const (defined in AcDbDimData) | AcDbDimData | inline
isDimDeltaLength() const (defined in AcDbDimData) | AcDbDimData | inline
isDimEditable() const (defined in AcDbDimData) | AcDbDimData | inline
isDimFocal() const (defined in AcDbDimData) | AcDbDimData | inline
isDimHideIfValueIsZero() const (defined in AcDbDimData) | AcDbDimData | inline
isDimInvisible() const (defined in AcDbDimData) | AcDbDimData | inline
isDimRadius() const (defined in AcDbDimData) | AcDbDimData | inline
isDimResultantAngle() const (defined in AcDbDimData) | AcDbDimData | inline
isDimResultantLength() const (defined in AcDbDimData) | AcDbDimData | inline
kDimConstrained enum value (defined in AcDbDimData) | AcDbDimData |
kDimCustomString enum value (defined in AcDbDimData) | AcDbDimData |
kDimCustomValue enum value (defined in AcDbDimData) | AcDbDimData |
kDimDeltaAngle enum value (defined in AcDbDimData) | AcDbDimData |
kDimDeltaLength enum value (defined in AcDbDimData) | AcDbDimData |
kDimEditable enum value (defined in AcDbDimData) | AcDbDimData |
kDimEmptyData enum value (defined in AcDbDimData) | AcDbDimData |
kDimFocal enum value (defined in AcDbDimData) | AcDbDimData |
kDimHideIfValueIsZero enum value (defined in AcDbDimData) | AcDbDimData |
kDimInvisible enum value (defined in AcDbDimData) | AcDbDimData |
kDimRadius enum value (defined in AcDbDimData) | AcDbDimData |
kDimResultantAngle enum value (defined in AcDbDimData) | AcDbDimData |
kDimResultantLength enum value (defined in AcDbDimData) | AcDbDimData |
operator=(const AcDbDimData &) (defined in AcDbDimData) | AcDbDimData | inline
ownerId() const (defined in AcDbDimData) | AcDbDimData | inline
setAppData(void *appData) (defined in AcDbDimData) | AcDbDimData | inline
setBitFlags(unsigned int flags) (defined in AcDbDimData) | AcDbDimData | inline
setConstrain(bool bValue) (defined in AcDbDimData) | AcDbDimData | inline
setCustomDimValue(bool custom) (defined in AcDbDimData) | AcDbDimData | inline
setCustomString(bool bValue) (defined in AcDbDimData) | AcDbDimData | inline
setCustomStringFunc(DimDataSetCustomStringFuncPtr funcPtr) (defined in AcDbDimData) | AcDbDimData | inline
setDimDeltaAngle(bool bValue) (defined in AcDbDimData) | AcDbDimData | inline
setDimDeltaLength(bool bValue) (defined in AcDbDimData) | AcDbDimData | inline
setDimEditable(bool editable) (defined in AcDbDimData) | AcDbDimData | inline
setDimension(AcDbDimension *pDim) (defined in AcDbDimData) | AcDbDimData | inline
setDimFocal(bool focal) (defined in AcDbDimData) | AcDbDimData | inline
setDimHideIfValueIsZero(bool hide) (defined in AcDbDimData) | AcDbDimData | inline
setDimInvisible(bool invisible) (defined in AcDbDimData) | AcDbDimData | inline
setDimRadius(bool bValue) (defined in AcDbDimData) | AcDbDimData | inline
setDimResultantAngle(bool bValue) (defined in AcDbDimData) | AcDbDimData | inline
setDimResultantLength(bool bValue) (defined in AcDbDimData) | AcDbDimData | inline
setDimValueFunc(DimDataSetValueFuncPtr funcPtr) (defined in AcDbDimData) | AcDbDimData | inline
setOwnerId(const AcDbObjectId &objId) (defined in AcDbDimData) | AcDbDimData | inline
~AcDbDimData() (defined in AcDbDimData) | AcDbDimData | inline


ZRX API Reference: AcDbDimension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbDimension Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDimension:

Public Types

enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Public Types inherited from AcDbEntity
enum VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

int AcDbDimension::dimfit ( ) const
Warning
Not implemented!
int AcDbDimension::dimunit ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbDimension::getOsnapPoints | ( | AcDb::OsnapMode | osnapMode,
 |  | const AcDbFullSubentPath & | subentId,
 |  | const AcGePoint3d & | pickPoint,
 |  | const AcGePoint3d & | lastPoint,
 |  | const AcGeMatrix3d & | viewXform,
 |  | AcGePoint3dArray & | snapPoints,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
Warning
Not implemented!
Acad::ErrorStatus AcDbDimension::getOsnapPoints | ( | AcDb::OsnapMode | osnapMode,
 |  | Adesk::GsMarker | gsSelectionMark,
 |  | const AcGePoint3d & | pickPoint,
 |  | const AcGePoint3d & | lastPoint,
 |  | const AcGeMatrix3d & | viewXform,
 |  | AcGePoint3dArray & | snapPoints,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

bool AcDbDimension::isHorizontalRefTextRotation ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbDimension::setDimfit ( int )
Warning
Not implemented!
Acad::ErrorStatus AcDbDimension::setDimunit ( int )
Warning
Not implemented!
Acad::ErrorStatus AcDbDimension::setHorizontalRefTextRotation ( bool newVal )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDimension Member List

This is the complete list of members for AcDbDimension, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDimStyleTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbDimStyleTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDimStyleTable:

Public Types

typedef AcDbDimStyleTableRecord | RecordType
- Public Types inherited from AcDbSymbolTable
typedef AcDbSymbolTableRecord | RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDimStyleTable)
Acad::ErrorStatus | add (AcDbDimStyleTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbDimStyleTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbDimStyleTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbDimStyleTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDimStyleTable Member List

This is the complete list of members for AcDbDimStyleTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDimStyleTable) (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimStyleTable() (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbDimStyleTableRecord *pRecord) (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
add(AcDbObjectId &recordId, AcDbDimStyleTableRecord *pRecord) (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbDimStyleTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbDimStyleTable) | AcDbDimStyleTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
has(AcDbObjectId id) const (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbDimStyleTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbDimStyleTable) | AcDbDimStyleTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDimStyleTable() (defined in AcDbDimStyleTable) | AcDbDimStyleTable | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDimStyleTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbDimStyleTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDimStyleTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbDimStyleTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbDimStyleTableRecord *pRecord)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbDimStyleTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDimStyleTableIterator Member List

This is the complete list of members for AcDbDimStyleTableIterator, including all inherited members.

AcDbDimStyleTable (defined in AcDbDimStyleTableIterator) | AcDbDimStyleTableIterator | friend
AcDbDimStyleTableIterator() (defined in AcDbDimStyleTableIterator) | AcDbDimStyleTableIterator | protected
AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbDimStyleTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbDimStyleTableIterator) | AcDbDimStyleTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbDimStyleTableIterator) | AcDbDimStyleTableIterator |
seek(const AcDbDimStyleTableRecord *pRecord) (defined in AcDbDimStyleTableIterator) | AcDbDimStyleTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbDimStyleTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbDimStyleTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDimStyleTableRecord:

Public Types

typedef AcDbDimStyleTable | TableType
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable | TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDimStyleTableRecord)
AcDbObjectId | arrowId (AcDb::DimArrowFlags whichArrow) const
int | dimfit () const
int | dimunit () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getDimapost (ACHAR *&pOutput) const
Acad::ErrorStatus | getDimblk (ACHAR *&pOutput) const
Acad::ErrorStatus | getDimblk1 (ACHAR *&pOutput) const
Acad::ErrorStatus | getDimblk2 (ACHAR *&pOutput) const
Acad::ErrorStatus | getDimpost (ACHAR *&pOutput) const
bool | isModifiedForRecompute () const
Acad::ErrorStatus | setDimfit (int fit)
Acad::ErrorStatus | setDimunit (int unit)
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDimStyleTableRecord Member List

This is the complete list of members for AcDbDimStyleTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDimStyleTableRecord) (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimStyleTableRecord() (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
arrowId(AcDb::DimArrowFlags whichArrow) const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimfit() const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
dimunit() const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord | virtual
getDimapost(ACHAR *&pOutput) const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
getDimblk(ACHAR *&pOutput) const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
getDimblk1(ACHAR *&pOutput) const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
getDimblk2(ACHAR *&pOutput) const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
getDimpost(ACHAR *&pOutput) const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedForRecompute() const (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDimfit(int fit) (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
setDimunit(int unit) (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDimStyleTableRecord() (defined in AcDbDimStyleTableRecord) | AcDbDimStyleTableRecord | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDwfDefinition Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDwfDefinition Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDwfDefinition:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDwfDefinition)
AcDbDwfDefinition ()
virtual | ~AcDbDwfDefinition ()
- Public Member Functions inherited from AcDbUnderlayDefinition
ACDB_DECLARE_MEMBERS (AcDbUnderlayDefinition)
AcDbUnderlayDefinition ()
Acad::ErrorStatus | getActiveFileName (const ACHAR *&file) const
Acad::ErrorStatus | getActiveFileName (AcString &file) const
const ACHAR * | getItemName () const
const ACHAR * | getSourceFileName () const
const AcDbUnderlayItem * | getUnderlayItem () const
bool | isLoaded () const
Acad::ErrorStatus | load (const wchar_t *password)
Acad::ErrorStatus | setItemName (const ACHAR *item)
Acad::ErrorStatus | setSourceFileName (const ACHAR *file)
Acad::ErrorStatus | setUnderlayItem (const ACHAR *sourceFileName, const ACHAR *activeFileName, AcDbUnderlayItem *pItem)
void | unload ()
virtual | ~AcDbUnderlayDefinition ()=0
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcDbUnderlayDefinition
static AcString dictionaryKey (const AcRxClass *underlayDefinitionType)

Constructor & Destructor Documentation

AcDbDwfDefinition::AcDbDwfDefinition ( )
Warning
Not implemented!
virtual AcDbDwfDefinition::~AcDbDwfDefinition ( )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbunderlaydef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDwfDefinition Member List

This is the complete list of members for AcDbDwfDefinition, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDwfDefinition) (defined in AcDbDwfDefinition) | AcDbDwfDefinition |
ACDB_DECLARE_MEMBERS(AcDbUnderlayDefinition) (defined in AcDbUnderlayDefinition) | AcDbUnderlayDefinition |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDwfDefinition() | AcDbDwfDefinition |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbUnderlayDefinition() | AcDbUnderlayDefinition |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dictionaryKey(const AcRxClass *underlayDefinitionType) | AcDbUnderlayDefinition | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getActiveFileName(const ACHAR *&file) const | AcDbUnderlayDefinition |
getActiveFileName(AcString &file) const | AcDbUnderlayDefinition |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getItemName() const | AcDbUnderlayDefinition |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getSourceFileName() const | AcDbUnderlayDefinition |
getUnderlayItem() const | AcDbUnderlayDefinition |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLoaded() const | AcDbUnderlayDefinition |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
load(const wchar_t *password) | AcDbUnderlayDefinition |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setItemName(const ACHAR *item) | AcDbUnderlayDefinition |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setSourceFileName(const ACHAR *file) | AcDbUnderlayDefinition |
setUnderlayItem(const ACHAR *sourceFileName, const ACHAR *activeFileName, AcDbUnderlayItem *pItem) | AcDbUnderlayDefinition |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unload() | AcDbUnderlayDefinition |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDwfDefinition() | AcDbDwfDefinition | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbUnderlayDefinition()=0 | AcDbUnderlayDefinition | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDwfReference Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDwfReference Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDwfReference:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbDwfReference)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
- Public Member Functions inherited from AcDbUnderlayReference
ACDB_DECLARE_MEMBERS (AcDbUnderlayReference)
const AcGePoint2dArray & | clipBoundary () const
Adesk::UInt8 | contrast () const
AcDbObjectId | definitionId () const
Adesk::UInt8 | fade () const
Acad::ErrorStatus | getUnderlayLayer (int index, AcUnderlayLayer &layer) const
bool | isAdjustedForBackground () const
bool | isClipped () const
virtual bool | isContentSnappable () const
virtual bool | isFramePlottable () const
virtual bool | isFrameVisible () const
bool | isMonochrome () const
bool | isOn () const
AcGeVector3d | normal () const
AcGePoint3d | position () const
double | rotation () const
AcGeScale3d | scaleFactors () const
Acad::ErrorStatus | setClipBoundary (const AcGePoint2dArray &clipBoundary)
Acad::ErrorStatus | setContrast (Adesk::UInt8 value)
Acad::ErrorStatus | setDefinitionId (AcDbObjectId id)
Acad::ErrorStatus | setFade (Adesk::UInt8 value)
Acad::ErrorStatus | setIsAdjustedForBackground (bool value)
Acad::ErrorStatus | setIsClipped (bool value)
Acad::ErrorStatus | setIsMonochrome (bool value)
Acad::ErrorStatus | setIsOn (bool value)
Acad::ErrorStatus | setNormal (const AcGeVector3d &normal)
Acad::ErrorStatus | setPosition (const AcGePoint3d &position)
Acad::ErrorStatus | setRotation (double rotation)
Acad::ErrorStatus | setScaleFactors (const AcGeScale3d &scale)
Acad::ErrorStatus | setTransform (const AcGeMatrix3d &transform)
Acad::ErrorStatus | setUnderlayLayer (int index, const AcUnderlayLayer &layer)
AcGeMatrix3d | transform () const
Adesk::UInt32 | underlayLayerCount () const
virtual | ~AcDbUnderlayReference ()=0
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcDbUnderlayReference
static Adesk::UInt8 | contrastDefault ()
static Adesk::UInt8 | contrastLowerLimit ()
static Adesk::UInt8 | contrastUpperLimit ()
static Adesk::UInt8 | fadeDefault ()
static Adesk::UInt8 | fadeLowerLimit ()
static Adesk::UInt8 | fadeUpperLimit ()
The documentation for this class was generated from the following file:
  • dbunderlayref.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDwfReference Member List

This is the complete list of members for AcDbDwfReference, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbDwfReference) (defined in AcDbDwfReference) | AcDbDwfReference |
ACDB_DECLARE_MEMBERS(AcDbUnderlayReference) (defined in AcDbUnderlayReference) | AcDbUnderlayReference |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDwfReference() (defined in AcDbDwfReference) | AcDbDwfReference |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clipBoundary() const | AcDbUnderlayReference |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const | AcDbUnderlayReference |
contrastDefault() | AcDbUnderlayReference | static
contrastLowerLimit() | AcDbUnderlayReference | static
contrastUpperLimit() | AcDbUnderlayReference | static
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
definitionId() const | AcDbUnderlayReference |
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fade() const | AcDbUnderlayReference |
fadeDefault() | AcDbUnderlayReference | static
fadeLowerLimit() | AcDbUnderlayReference | static
fadeUpperLimit() | AcDbUnderlayReference | static
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbDwfReference) | AcDbDwfReference | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
getUnderlayLayer(int index, AcUnderlayLayer &layer) const | AcDbUnderlayReference |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAdjustedForBackground() const | AcDbUnderlayReference |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClipped() const | AcDbUnderlayReference |
isContentSnappable() const | AcDbUnderlayReference | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFramePlottable() const | AcDbUnderlayReference | virtual
isFrameVisible() const | AcDbUnderlayReference | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isMonochrome() const | AcDbUnderlayReference |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isOn() const | AcDbUnderlayReference |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const | AcDbUnderlayReference |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const | AcDbUnderlayReference |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const | AcDbUnderlayReference |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
scaleFactors() const | AcDbUnderlayReference |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setClipBoundary(const AcGePoint2dArray &clipBoundary) | AcDbUnderlayReference |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setContrast(Adesk::UInt8 value) | AcDbUnderlayReference |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDefinitionId(AcDbObjectId id) | AcDbUnderlayReference |
setFade(Adesk::UInt8 value) | AcDbUnderlayReference |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setIsAdjustedForBackground(bool value) | AcDbUnderlayReference |
setIsClipped(bool value) | AcDbUnderlayReference |
setIsMonochrome(bool value) | AcDbUnderlayReference |
setIsOn(bool value) | AcDbUnderlayReference |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &normal) | AcDbUnderlayReference |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &position) | AcDbUnderlayReference |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double rotation) | AcDbUnderlayReference |
setScaleFactors(const AcGeScale3d &scale) | AcDbUnderlayReference |
setTransform(const AcGeMatrix3d &transform) | AcDbUnderlayReference |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUnderlayLayer(int index, const AcUnderlayLayer &layer) | AcDbUnderlayReference |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transform() const | AcDbUnderlayReference |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
underlayLayerCount() const | AcDbUnderlayReference |
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDwfReference() (defined in AcDbDwfReference) | AcDbDwfReference | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbUnderlayReference()=0 | AcDbUnderlayReference | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDwgFiler Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDwgFiler Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDwgFiler:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbDwgFiler)
virtual Acad::ErrorStatus | addReferences (AcDbIdRefQueue &)
virtual AcDbFilerController & | controller () const
virtual Acad::ErrorStatus | dwgVersion (AcDb::AcDbDwgVersion &, AcDb::MaintenanceReleaseVersion &) const
virtual Acad::ErrorStatus | filerStatus () const =0
virtual AcDb::FilerType | filerType () const =0
virtual AcDbAuditInfo * | getAuditInfo () const
virtual Acad::ErrorStatus | readAcDbHandle (AcDbHandle *)=0
virtual Acad::ErrorStatus | readAddress (void **)
virtual Acad::ErrorStatus | readBChunk (ads_binary *)=0
virtual Acad::ErrorStatus | readBool (bool *)=0
virtual Acad::ErrorStatus | readBoolean (Adesk::Boolean *)=0
virtual Acad::ErrorStatus | readBytes (void *, Adesk::UInt32)=0
Acad::ErrorStatus | readChar (Adesk::Int8 *p)
virtual Acad::ErrorStatus | readDouble (double *)=0
virtual Acad::ErrorStatus | readHardOwnershipId (AcDbHardOwnershipId *)=0
virtual Acad::ErrorStatus | readHardPointerId (AcDbHardPointerId *)=0
virtual Acad::ErrorStatus | readInt16 (Adesk::Int16 *)=0
virtual Acad::ErrorStatus | readInt32 (Adesk::Int32 *)=0
virtual Acad::ErrorStatus | readInt64 (Adesk::Int64 *)=0
virtual Acad::ErrorStatus | readInt8 (Adesk::Int8 *)=0
Acad::ErrorStatus | readItem (AcDbHardOwnershipId *)
Acad::ErrorStatus | readItem (AcDbSoftOwnershipId *)
Acad::ErrorStatus | readItem (AcDbHardPointerId *)
Acad::ErrorStatus | readItem (AcDbSoftPointerId *)
Acad::ErrorStatus | readItem (ACHAR **)
Acad::ErrorStatus | readItem (ads_binary *)
Acad::ErrorStatus | readItem (AcDbHandle *)
Acad::ErrorStatus | readItem (Adesk::Int32 *)
Acad::ErrorStatus | readItem (Adesk::Int16 *)
Acad::ErrorStatus | readItem (Adesk::Int8 *)
Acad::ErrorStatus | readItem (Adesk::UInt32 *)
Acad::ErrorStatus | readItem (Adesk::UInt16 *)
Acad::ErrorStatus | readItem (Adesk::UInt8 *)
Acad::ErrorStatus | readItem (Adesk::Boolean *)
Acad::ErrorStatus | readItem (bool *)
Acad::ErrorStatus | readItem (double *)
Acad::ErrorStatus | readItem (AcGePoint2d *)
Acad::ErrorStatus | readItem (AcGePoint3d *)
Acad::ErrorStatus | readItem (AcGeVector2d *)
Acad::ErrorStatus | readItem (AcGeVector3d *)
Acad::ErrorStatus | readItem (AcGeScale3d *)
Acad::ErrorStatus | readItem (void *, Adesk::UInt32)
Acad::ErrorStatus | readItem (void **)
virtual Acad::ErrorStatus | readPoint2d (AcGePoint2d *)=0
virtual Acad::ErrorStatus | readPoint3d (AcGePoint3d *)=0
virtual Acad::ErrorStatus | readScale3d (AcGeScale3d *)=0
virtual Acad::ErrorStatus | readSoftOwnershipId (AcDbSoftOwnershipId *)=0
virtual Acad::ErrorStatus | readSoftPointerId (AcDbSoftPointerId *)=0
virtual Acad::ErrorStatus | readString (ACHAR **)=0
virtual Acad::ErrorStatus | readString (AcString &)=0
virtual Acad::ErrorStatus | readUInt16 (Adesk::UInt16 *)=0
virtual Acad::ErrorStatus | readUInt32 (Adesk::UInt32 *)=0
virtual Acad::ErrorStatus | readUInt64 (Adesk::UInt64 *)=0
virtual Acad::ErrorStatus | readUInt8 (Adesk::UInt8 *)=0
virtual Acad::ErrorStatus | readVector2d (AcGeVector2d *)=0
virtual Acad::ErrorStatus | readVector3d (AcGeVector3d *)=0
virtual void | resetFilerStatus ()=0
virtual Acad::ErrorStatus | seek (long offset, int method)=0
virtual void | setFilerStatus (Acad::ErrorStatus)=0
virtual long | tell () const =0
virtual bool | usesReferences () const
virtual Acad::ErrorStatus | writeAcDbHandle (const AcDbHandle &)=0
virtual Acad::ErrorStatus | writeAddress (const void *)
virtual Acad::ErrorStatus | writeBChunk (const ads_binary &)=0
virtual Acad::ErrorStatus | writeBool (bool)=0
virtual Acad::ErrorStatus | writeBoolean (Adesk::Boolean)=0
virtual Acad::ErrorStatus | writeBytes (const void *, Adesk::UInt32)=0
Acad::ErrorStatus | writeChar (Adesk::Int8 c)
virtual Acad::ErrorStatus | writeDouble (double)=0
virtual Acad::ErrorStatus | writeHardOwnershipId (const AcDbHardOwnershipId &)=0
virtual Acad::ErrorStatus | writeHardPointerId (const AcDbHardPointerId &)=0
virtual Acad::ErrorStatus | writeInt16 (Adesk::Int16)=0
virtual Acad::ErrorStatus | writeInt32 (Adesk::Int32)=0
virtual Acad::ErrorStatus | writeInt64 (Adesk::Int64)=0
virtual Acad::ErrorStatus | writeInt8 (Adesk::Int8)=0
Acad::ErrorStatus | writeItem (const AcDbHardOwnershipId &)
Acad::ErrorStatus | writeItem (const AcDbSoftOwnershipId &)
Acad::ErrorStatus | writeItem (const AcDbHardPointerId &)
Acad::ErrorStatus | writeItem (const AcDbSoftPointerId &)
Acad::ErrorStatus | writeItem (const ACHAR *)
Acad::ErrorStatus | writeItem (const ads_binary &)
Acad::ErrorStatus | writeItem (const AcDbHandle &)
Acad::ErrorStatus | writeItem (Adesk::Int32)
Acad::ErrorStatus | writeItem (Adesk::Int16)
Acad::ErrorStatus | writeItem (Adesk::Int8)
Acad::ErrorStatus | writeItem (Adesk::UInt32)
Acad::ErrorStatus | writeItem (Adesk::UInt16)
Acad::ErrorStatus | writeItem (Adesk::UInt8)
Acad::ErrorStatus | writeItem (Adesk::Boolean)
Acad::ErrorStatus | writeItem (bool)
Acad::ErrorStatus | writeItem (double)
Acad::ErrorStatus | writeItem (const AcGePoint2d &)
Acad::ErrorStatus | writeItem (const AcGePoint3d &)
Acad::ErrorStatus | writeItem (const AcGeVector2d &)
Acad::ErrorStatus | writeItem (const AcGeVector3d &)
Acad::ErrorStatus | writeItem (const AcGeScale3d &)
Acad::ErrorStatus | writeItem (const void *, Adesk::UInt32)
Acad::ErrorStatus | writeItem (const void *)
virtual Acad::ErrorStatus | writePoint2d (const AcGePoint2d &)=0
virtual Acad::ErrorStatus | writePoint3d (const AcGePoint3d &)=0
virtual Acad::ErrorStatus | writeScale3d (const AcGeScale3d &)=0
virtual Acad::ErrorStatus | writeSoftOwnershipId (const AcDbSoftOwnershipId &)=0
virtual Acad::ErrorStatus | writeSoftPointerId (const AcDbSoftPointerId &)=0
virtual Acad::ErrorStatus | writeString (const ACHAR *)=0
virtual Acad::ErrorStatus | writeString (const AcString &)=0
virtual Acad::ErrorStatus | writeUInt16 (Adesk::UInt16)=0
virtual Acad::ErrorStatus | writeUInt32 (Adesk::UInt32)=0
virtual Acad::ErrorStatus | writeUInt64 (Adesk::UInt64)=0
virtual Acad::ErrorStatus | writeUInt8 (Adesk::UInt8)=0
virtual Acad::ErrorStatus | writeVector2d (const AcGeVector2d &)=0
virtual Acad::ErrorStatus | writeVector3d (const AcGeVector3d &)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbfiler.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDwgFiler Member List

This is the complete list of members for AcDbDwgFiler, including all inherited members.

AcDbDwgFiler() (defined in AcDbDwgFiler) | AcDbDwgFiler |
ACRX_DECLARE_MEMBERS(AcDbDwgFiler) (defined in AcDbDwgFiler) | AcDbDwgFiler |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addReferences(AcDbIdRefQueue &) (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
controller() const (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgVersion(AcDb::AcDbDwgVersion &, AcDb::MaintenanceReleaseVersion &) const (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
filerStatus() const =0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
filerType() const =0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
getAuditInfo() const (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readAcDbHandle(AcDbHandle *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readAddress(void **) (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
readBChunk(ads_binary *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readBool(bool *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readBoolean(Adesk::Boolean *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readBytes(void *, Adesk::UInt32)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readChar(Adesk::Int8 *p) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readDouble(double *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readHardOwnershipId(AcDbHardOwnershipId *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readHardPointerId(AcDbHardPointerId *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readInt16(Adesk::Int16 *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readInt32(Adesk::Int32 *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readInt64(Adesk::Int64 *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readInt8(Adesk::Int8 *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readItem(AcDbHardOwnershipId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbSoftOwnershipId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbHardPointerId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbSoftPointerId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(ACHAR **) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(ads_binary *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbHandle *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Int32 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Int16 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Int8 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::UInt32 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::UInt16 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::UInt8 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Boolean *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(bool *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(double *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGePoint2d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGePoint3d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGeVector2d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGeVector3d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGeScale3d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(void *, Adesk::UInt32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(void **) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readPoint2d(AcGePoint2d *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readPoint3d(AcGePoint3d *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readScale3d(AcGeScale3d *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readSoftOwnershipId(AcDbSoftOwnershipId *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readSoftPointerId(AcDbSoftPointerId *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readString(ACHAR **)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readString(AcString &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readUInt16(Adesk::UInt16 *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readUInt32(Adesk::UInt32 *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readUInt64(Adesk::UInt64 *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readUInt8(Adesk::UInt8 *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readVector2d(AcGeVector2d *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
readVector3d(AcGeVector3d *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
resetFilerStatus()=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
seek(long offset, int method)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
setFilerStatus(Acad::ErrorStatus)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
tell() const =0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
usesReferences() const (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
writeAcDbHandle(const AcDbHandle &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeAddress(const void *) (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
writeBChunk(const ads_binary &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeBool(bool)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeBoolean(Adesk::Boolean)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeBytes(const void *, Adesk::UInt32)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeChar(Adesk::Int8 c) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeDouble(double)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeHardOwnershipId(const AcDbHardOwnershipId &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeHardPointerId(const AcDbHardPointerId &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeInt16(Adesk::Int16)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeInt32(Adesk::Int32)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeInt64(Adesk::Int64)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeInt8(Adesk::Int8)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeItem(const AcDbHardOwnershipId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbSoftOwnershipId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbHardPointerId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbSoftPointerId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const ACHAR *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const ads_binary &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbHandle &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Int32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Int16) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Int8) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::UInt32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::UInt16) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::UInt8) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Boolean) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(bool) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(double) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGePoint2d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGePoint3d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGeVector2d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGeVector3d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGeScale3d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const void *, Adesk::UInt32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const void *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writePoint2d(const AcGePoint2d &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writePoint3d(const AcGePoint3d &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeScale3d(const AcGeScale3d &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeSoftOwnershipId(const AcDbSoftOwnershipId &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeSoftPointerId(const AcDbSoftPointerId &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeString(const ACHAR *)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeString(const AcString &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeUInt16(Adesk::UInt16)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeUInt32(Adesk::UInt32)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeUInt64(Adesk::UInt64)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeUInt8(Adesk::UInt8)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeVector2d(const AcGeVector2d &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
writeVector3d(const AcGeVector3d &)=0 (defined in AcDbDwgFiler) | AcDbDwgFiler | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbDwgFiler() (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDxfFiler Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbDxfFiler Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDxfFiler:

Public Types

enum { kDfltPrec = -1, kMaxPrec = 16 }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbDxfFiler)
virtual bool | atEmbeddedObjectStart ()
virtual bool | atEndOfObject ()
virtual bool | atEOF ()
virtual bool | atExtendedData ()
virtual bool | atSubclassData (const ACHAR *)
AcDbFilerController & | controller () const
virtual AcDbDatabase * | database () const =0
virtual Acad::ErrorStatus | dwgVersion (AcDb::AcDbDwgVersion &, AcDb::MaintenanceReleaseVersion &) const
virtual double | elevation () const
virtual const ACHAR * | errorMessage () const
virtual Acad::ErrorStatus | filerStatus () const =0
virtual AcDb::FilerType | filerType () const =0
virtual void | haltAtClassBoundries (bool)
virtual bool | includesDefaultValues () const =0
virtual bool | isModifyingExistingObject () const
virtual int | precision () const
virtual Acad::ErrorStatus | pushBackItem ()
Acad::ErrorStatus | readItem (resbuf *pItem)
virtual Acad::ErrorStatus | readResBuf (resbuf *)
virtual void | resetFilerStatus ()=0
virtual int | rewindFiler ()=0
virtual Acad::ErrorStatus | setError (Acad::ErrorStatus, const ACHAR *,...)
virtual Acad::ErrorStatus | setError (const ACHAR *,...)
virtual void | setPrecision (int prec)
virtual double | thickness () const
virtual Acad::ErrorStatus | writeAcDbHandle (AcDb::DxfCode, const AcDbHandle &)=0
virtual Acad::ErrorStatus | writeBChunk (AcDb::DxfCode, const ads_binary &)=0
virtual Acad::ErrorStatus | writeBool (AcDb::DxfCode, bool)=0
virtual Acad::ErrorStatus | writeBoolean (AcDb::DxfCode, Adesk::Boolean)=0
Acad::ErrorStatus | writeChar (AcDb::DxfCode c, Adesk::Int8 n)
virtual Acad::ErrorStatus | writeDouble (AcDb::DxfCode, double, int=kDfltPrec)=0
virtual Acad::ErrorStatus | writeEmbeddedObjectStart ()
virtual Acad::ErrorStatus | writeInt16 (AcDb::DxfCode, Adesk::Int16)=0
virtual Acad::ErrorStatus | writeInt32 (AcDb::DxfCode, Adesk::Int32)=0
virtual Acad::ErrorStatus | writeInt64 (AcDb::DxfCode, Adesk::Int64)=0
virtual Acad::ErrorStatus | writeInt8 (AcDb::DxfCode, Adesk::Int8)=0
Acad::ErrorStatus | writeItem (const resbuf &pItem)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, const AcDbObjectId &)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, const ACHAR *)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, const ads_binary &)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, const AcDbHandle &)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, Adesk::Int64)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, Adesk::Int32)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, Adesk::Int16)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, Adesk::Int8)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, Adesk::UInt64)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, Adesk::UInt32)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, Adesk::UInt16)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, Adesk::UInt8)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, Adesk::Boolean)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, bool)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, double, int=kDfltPrec)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, const AcGePoint2d &, int=kDfltPrec)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, const AcGePoint3d &, int=kDfltPrec)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, const AcGeVector2d &, int=kDfltPrec)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, const AcGeVector3d &, int=kDfltPrec)
Acad::ErrorStatus | writeItem (AcDb::DxfCode, const AcGeScale3d &, int=kDfltPrec)
virtual Acad::ErrorStatus | writeObjectId (AcDb::DxfCode, const AcDbObjectId &)=0
virtual Acad::ErrorStatus | writePoint2d (AcDb::DxfCode, const AcGePoint2d &, int=kDfltPrec)=0
virtual Acad::ErrorStatus | writePoint3d (AcDb::DxfCode, const AcGePoint3d &, int=kDfltPrec)=0
virtual Acad::ErrorStatus | writeResBuf (const resbuf &)
virtual Acad::ErrorStatus | writeScale3d (AcDb::DxfCode, const AcGeScale3d &, int=kDfltPrec)=0
virtual Acad::ErrorStatus | writeString (AcDb::DxfCode, const ACHAR *)=0
virtual Acad::ErrorStatus | writeString (AcDb::DxfCode, const AcString &)=0
virtual Acad::ErrorStatus | writeUInt16 (AcDb::DxfCode, Adesk::UInt16)=0
virtual Acad::ErrorStatus | writeUInt32 (AcDb::DxfCode, Adesk::UInt32)=0
virtual Acad::ErrorStatus | writeUInt64 (AcDb::DxfCode, Adesk::UInt64)=0
virtual Acad::ErrorStatus | writeUInt8 (AcDb::DxfCode, Adesk::UInt8)=0
virtual Acad::ErrorStatus | writeVector2d (AcDb::DxfCode, const AcGeVector2d &, int=kDfltPrec)=0
virtual Acad::ErrorStatus | writeVector3d (AcDb::DxfCode, const AcGeVector3d &, int=kDfltPrec)=0
virtual Acad::ErrorStatus | writeXDataStart ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbfiler.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDxfFiler Member List

This is the complete list of members for AcDbDxfFiler, including all inherited members.

AcDbDxfFiler() (defined in AcDbDxfFiler) | AcDbDxfFiler |
ACRX_DECLARE_MEMBERS(AcDbDxfFiler) (defined in AcDbDxfFiler) | AcDbDxfFiler |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
atEmbeddedObjectStart() (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
atEndOfObject() (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
atEOF() (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
atExtendedData() (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
atSubclassData(const ACHAR *) (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
controller() const (defined in AcDbDxfFiler) | AcDbDxfFiler |
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
database() const =0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgVersion(AcDb::AcDbDwgVersion &, AcDb::MaintenanceReleaseVersion &) const (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
elevation() const (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
errorMessage() const (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
filerStatus() const =0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
filerType() const =0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
haltAtClassBoundries(bool) (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
includesDefaultValues() const =0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModifyingExistingObject() const (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
kDfltPrec enum value (defined in AcDbDxfFiler) | AcDbDxfFiler |
kMaxPrec enum value (defined in AcDbDxfFiler) | AcDbDxfFiler |
precision() const (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
pushBackItem() (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readItem(resbuf *pItem) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
readResBuf(resbuf *) (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
resetFilerStatus()=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
rewindFiler()=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
setError(Acad::ErrorStatus, const ACHAR *,...) (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
setError(const ACHAR *,...) (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
setPrecision(int prec) (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
thickness() const (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
writeAcDbHandle(AcDb::DxfCode, const AcDbHandle &)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeBChunk(AcDb::DxfCode, const ads_binary &)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeBool(AcDb::DxfCode, bool)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeBoolean(AcDb::DxfCode, Adesk::Boolean)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeChar(AcDb::DxfCode c, Adesk::Int8 n) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeDouble(AcDb::DxfCode, double, int=kDfltPrec)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeEmbeddedObjectStart() (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
writeInt16(AcDb::DxfCode, Adesk::Int16)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeInt32(AcDb::DxfCode, Adesk::Int32)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeInt64(AcDb::DxfCode, Adesk::Int64)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeInt8(AcDb::DxfCode, Adesk::Int8)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeItem(const resbuf &pItem) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, const AcDbObjectId &) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, const ACHAR *) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, const ads_binary &) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, const AcDbHandle &) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, Adesk::Int64) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, Adesk::Int32) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, Adesk::Int16) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, Adesk::Int8) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, Adesk::UInt64) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, Adesk::UInt32) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, Adesk::UInt16) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, Adesk::UInt8) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, Adesk::Boolean) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, bool) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, double, int=kDfltPrec) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, const AcGePoint2d &, int=kDfltPrec) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, const AcGePoint3d &, int=kDfltPrec) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, const AcGeVector2d &, int=kDfltPrec) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, const AcGeVector3d &, int=kDfltPrec) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeItem(AcDb::DxfCode, const AcGeScale3d &, int=kDfltPrec) (defined in AcDbDxfFiler) | AcDbDxfFiler | inline
writeObjectId(AcDb::DxfCode, const AcDbObjectId &)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writePoint2d(AcDb::DxfCode, const AcGePoint2d &, int=kDfltPrec)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writePoint3d(AcDb::DxfCode, const AcGePoint3d &, int=kDfltPrec)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeResBuf(const resbuf &) (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
writeScale3d(AcDb::DxfCode, const AcGeScale3d &, int=kDfltPrec)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeString(AcDb::DxfCode, const ACHAR *)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeString(AcDb::DxfCode, const AcString &)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeUInt16(AcDb::DxfCode, Adesk::UInt16)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeUInt32(AcDb::DxfCode, Adesk::UInt32)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeUInt64(AcDb::DxfCode, Adesk::UInt64)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeUInt8(AcDb::DxfCode, Adesk::UInt8)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeVector2d(AcDb::DxfCode, const AcGeVector2d &, int=kDfltPrec)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeVector3d(AcDb::DxfCode, const AcGeVector3d &, int=kDfltPrec)=0 (defined in AcDbDxfFiler) | AcDbDxfFiler | pure virtual
writeXDataStart() (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbDxfFiler() (defined in AcDbDxfFiler) | AcDbDxfFiler | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDynamicUCSPE Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbDynamicUCSPE Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDynamicUCSPE:

Public Types

enum Flags { kDefault = 0x00 }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbDynamicUCSPE)
virtual Acad::ErrorStatus | getCandidatePlanes (AcArray< AcGePlane > &results, double &distToEdge, double &objWidth, double &objHeight, AcDbEntity *pEnt, const AcDbSubentId &subentId, const AcGePlane &viewplane, AcDbDynamicUCSPE::Flags flags=kDefault) const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbDynamicUCSpe.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDynamicUCSPE Member List

This is the complete list of members for AcDbDynamicUCSPE, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbDynamicUCSPE) (defined in AcDbDynamicUCSPE) | AcDbDynamicUCSPE |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
Flags enum name (defined in AcDbDynamicUCSPE) | AcDbDynamicUCSPE |
getCandidatePlanes(AcArray< AcGePlane > &results, double &distToEdge, double &objWidth, double &objHeight, AcDbEntity *pEnt, const AcDbSubentId &subentId, const AcGePlane &viewplane, AcDbDynamicUCSPE::Flags flags=kDefault) const =0 (defined in AcDbDynamicUCSPE) | AcDbDynamicUCSPE | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDefault enum value (defined in AcDbDynamicUCSPE) | AcDbDynamicUCSPE |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbDynBlockReference Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcDbDynBlockReference Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDynBlockReference:

Public Member Functions

AcDbDynBlockReference (AcDbObjectId blockRefId)
AcDbDynBlockReference (AcDbBlockReference *pRef)
AcDbObjectId | anonymousBlockTableRecord () const
AcDbObjectId | blockId () const
Acad::ErrorStatus | convertToStaticBlock ()
Acad::ErrorStatus | convertToStaticBlock (const AcString &newBlockName)
AcDbObjectId | dynamicBlockTableRecord () const
void | getBlockProperties (AcDbDynBlockReferencePropertyArray &properties) const
bool | isDynamicBlock () const
Acad::ErrorStatus | resetBlock ()

Static Public Member Functions

static bool | isDynamicBlock (AcDbObjectId blockTableRecordId)
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdynblk.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDynBlockReference Member List

This is the complete list of members for AcDbDynBlockReference, including all inherited members.

AcDbDynBlockReference(AcDbObjectId blockRefId) (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
AcDbDynBlockReference(AcDbBlockReference *pRef) (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
anonymousBlockTableRecord() const (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
blockId() const (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
convertToStaticBlock() (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
convertToStaticBlock(const AcString &newBlockName) (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
dynamicBlockTableRecord() const (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
getBlockProperties(AcDbDynBlockReferencePropertyArray &properties) const (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
isDynamicBlock(AcDbObjectId blockTableRecordId) (defined in AcDbDynBlockReference) | AcDbDynBlockReference | static
isDynamicBlock() const (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
resetBlock() (defined in AcDbDynBlockReference) | AcDbDynBlockReference |
~AcDbDynBlockReference() (defined in AcDbDynBlockReference) | AcDbDynBlockReference | virtual


ZRX API Reference: AcDbDynBlockReferenceProperty Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbDynBlockReferenceProperty Class Reference
AcDb Classes
+ Inheritance diagram for AcDbDynBlockReferenceProperty:

Public Types

enum UnitsType { kNoUnits = 0, kAngular, kDistance, kArea }

Public Member Functions

AcDbDynBlockReferenceProperty (const AcDbDynBlockReferenceProperty &other)
AcDbObjectId | blockId () const
AcString | description () const
Acad::ErrorStatus | getAllowedValues (AcDbEvalVariantArray &values)
AcDbDynBlockReferenceProperty & | operator= (const AcDbDynBlockReferenceProperty &other)
AcString | propertyName () const
AcDbEvalVariant::Type | propertyType () const
bool | readOnly () const
Acad::ErrorStatus | setValue (const AcDbEvalVariant &value)
bool | show () const
UnitsType | unitsType () const
AcDbEvalVariant | value () const

Additional Inherited Members

- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdynblk.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDynBlockReferenceProperty Member List

This is the complete list of members for AcDbDynBlockReferenceProperty, including all inherited members.

AcDbDynBlockReferenceProperty() (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
AcDbDynBlockReferenceProperty(const AcDbDynBlockReferenceProperty &other) (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
blockId() const (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
description() const (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
getAllowedValues(AcDbEvalVariantArray &values) (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
kAngular enum value (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
kArea enum value (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
kDistance enum value (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
kNoUnits enum value (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator=(const AcDbDynBlockReferenceProperty &other) (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
propertyName() const (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
propertyType() const (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
readOnly() const (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
setValue(const AcDbEvalVariant &value) (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
show() const (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
UnitsType enum name (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
unitsType() const (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
value() const (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty |
~AcDbDynBlockReferenceProperty() (defined in AcDbDynBlockReferenceProperty) | AcDbDynBlockReferenceProperty | virtual


ZRX API Reference: AcDbEllipse Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbEllipse Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEllipse:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbEllipse)
AcDbEllipse (const AcGePoint3d &center, const AcGeVector3d &unitNormal, const AcGeVector3d &majorAxis, double radiusRatio, double startAngle=0.0, double endAngle=6.28318530717958647692)
double | angleAtParam (double param) const
virtual bool | castShadows () const
AcGePoint3d | center () const
double | endAngle () const
Acad::ErrorStatus | get (AcGePoint3d &center, AcGeVector3d &unitNormal, AcGeVector3d &majorAxis, double &radiusRatio, double &startAngle, double &endAngle) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual DBCURVE_METHODS
Acad::ErrorStatus 		getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapMasks, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&ent) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
Adesk::Boolean | isNull () const
AcGeVector3d | majorAxis () const
AcGeVector3d | minorAxis () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
AcGeVector3d | normal () const
double | paramAtAngle (double angle) const
double | radiusRatio () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | set (const AcGePoint3d &center, const AcGeVector3d &unitNormal, const AcGeVector3d &majorAxis, double radiusRatio, double startAngle=0.0, double endAngle=6.28318530717958647692)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setCenter (const AcGePoint3d &center)
Acad::ErrorStatus | setEndAngle (double endAngle)
Acad::ErrorStatus | setEndParam (double endParam)
Acad::ErrorStatus | setRadiusRatio (double ratio)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setStartAngle (double startAngle)
Acad::ErrorStatus | setStartParam (double startParam)
double | startAngle () const
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbelipse.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEllipse Member List

This is the complete list of members for AcDbEllipse, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEllipse) (defined in AcDbEllipse) | AcDbEllipse |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEllipse() (defined in AcDbEllipse) | AcDbEllipse |
AcDbEllipse(const AcGePoint3d &center, const AcGeVector3d &unitNormal, const AcGeVector3d &majorAxis, double radiusRatio, double startAngle=0.0, double endAngle=6.28318530717958647692) (defined in AcDbEllipse) | AcDbEllipse |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
angleAtParam(double param) const (defined in AcDbEllipse) | AcDbEllipse |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEllipse) | AcDbEllipse | virtual
center() const (defined in AcDbEllipse) | AcDbEllipse |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
endAngle() const (defined in AcDbEllipse) | AcDbEllipse |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
get(AcGePoint3d &center, AcGeVector3d &unitNormal, AcGeVector3d &majorAxis, double &radiusRatio, double &startAngle, double &endAngle) const (defined in AcDbEllipse) | AcDbEllipse |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEllipse) | AcDbEllipse | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapMasks, AcDbIntArray &geomIds) const (defined in AcDbEllipse) | AcDbEllipse | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEllipse) | AcDbEllipse | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&ent) const (defined in AcDbEllipse) | AcDbEllipse | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEllipse) | AcDbEllipse | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEllipse) | AcDbEllipse | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEllipse) | AcDbEllipse | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isNull() const (defined in AcDbEllipse) | AcDbEllipse |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
majorAxis() const (defined in AcDbEllipse) | AcDbEllipse |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
minorAxis() const (defined in AcDbEllipse) | AcDbEllipse |
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEllipse) | AcDbEllipse | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbEllipse) | AcDbEllipse |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
paramAtAngle(double angle) const (defined in AcDbEllipse) | AcDbEllipse |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
radiusRatio() const (defined in AcDbEllipse) | AcDbEllipse |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEllipse) | AcDbEllipse | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
set(const AcGePoint3d &center, const AcGeVector3d &unitNormal, const AcGeVector3d &majorAxis, double radiusRatio, double startAngle=0.0, double endAngle=6.28318530717958647692) (defined in AcDbEllipse) | AcDbEllipse |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEllipse) | AcDbEllipse | virtual
setCenter(const AcGePoint3d &center) (defined in AcDbEllipse) | AcDbEllipse |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setEndAngle(double endAngle) (defined in AcDbEllipse) | AcDbEllipse |
setEndParam(double endParam) (defined in AcDbEllipse) | AcDbEllipse |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setRadiusRatio(double ratio) (defined in AcDbEllipse) | AcDbEllipse |
setReceiveShadows(bool newVal) (defined in AcDbEllipse) | AcDbEllipse | virtual
setStartAngle(double startAngle) (defined in AcDbEllipse) | AcDbEllipse |
setStartParam(double startParam) (defined in AcDbEllipse) | AcDbEllipse |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
startAngle() const (defined in AcDbEllipse) | AcDbEllipse |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEllipse() (defined in AcDbEllipse) | AcDbEllipse | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbEntity Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbEntity Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEntity:

Public Types

enum VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEntity Member List

This is the complete list of members for AcDbEntity, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbEntityHyperlinkPE Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbEntityHyperlinkPE Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEntityHyperlinkPE:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbEntityHyperlinkPE)
virtual Acad::ErrorStatus | getHyperlinkCollection (AcDbObject *pObj, AcDbHyperlinkCollection *&pcHCL, bool bOneOnly=false, bool bIgnoreBlockDefinition=true)=0
virtual Acad::ErrorStatus | getHyperlinkCollection (const AcArray< AcDbObjectId > *&idContainers, AcDbHyperlinkCollection *&pcHCL, bool bOneOnly=false, bool bIgnoreBlockDefinition=true)=0
virtual Acad::ErrorStatus | getHyperlinkCount (AcDbObject *pObj, UINT &nCount, bool bIgnoreBlockDefinition=true)=0
virtual Acad::ErrorStatus | getHyperlinkCount (const AcArray< AcDbObjectId > *&idContainers, UINT &nCount, bool bIgnoreBlockDefinition=true)=0
virtual Acad::ErrorStatus | hasHyperlink (AcDbObject *pObj, bool &bHasHyperlink, bool bIgnoreBlockDefinition=true)=0
virtual Acad::ErrorStatus | hasHyperlink (const AcArray< AcDbObjectId > *&idContainers, bool &bHasHyperlink, bool bIgnoreBlockDefinition=true)=0
virtual Acad::ErrorStatus | setHyperlinkCollection (AcDbObject *pObj, AcDbHyperlinkCollection *pcHCL)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • achapi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEntityHyperlinkPE Member List

This is the complete list of members for AcDbEntityHyperlinkPE, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbEntityHyperlinkPE) (defined in AcDbEntityHyperlinkPE) | AcDbEntityHyperlinkPE |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getHyperlinkCollection(AcDbObject *pObj, AcDbHyperlinkCollection *&pcHCL, bool bOneOnly=false, bool bIgnoreBlockDefinition=true)=0 (defined in AcDbEntityHyperlinkPE) | AcDbEntityHyperlinkPE | pure virtual
getHyperlinkCollection(const AcArray< AcDbObjectId > *&idContainers, AcDbHyperlinkCollection *&pcHCL, bool bOneOnly=false, bool bIgnoreBlockDefinition=true)=0 (defined in AcDbEntityHyperlinkPE) | AcDbEntityHyperlinkPE | pure virtual
getHyperlinkCount(AcDbObject *pObj, UINT &nCount, bool bIgnoreBlockDefinition=true)=0 (defined in AcDbEntityHyperlinkPE) | AcDbEntityHyperlinkPE | pure virtual
getHyperlinkCount(const AcArray< AcDbObjectId > *&idContainers, UINT &nCount, bool bIgnoreBlockDefinition=true)=0 (defined in AcDbEntityHyperlinkPE) | AcDbEntityHyperlinkPE | pure virtual
hasHyperlink(AcDbObject *pObj, bool &bHasHyperlink, bool bIgnoreBlockDefinition=true)=0 (defined in AcDbEntityHyperlinkPE) | AcDbEntityHyperlinkPE | pure virtual
hasHyperlink(const AcArray< AcDbObjectId > *&idContainers, bool &bHasHyperlink, bool bIgnoreBlockDefinition=true)=0 (defined in AcDbEntityHyperlinkPE) | AcDbEntityHyperlinkPE | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setHyperlinkCollection(AcDbObject *pObj, AcDbHyperlinkCollection *pcHCL)=0 (defined in AcDbEntityHyperlinkPE) | AcDbEntityHyperlinkPE | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbEntityReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbEntityReactor Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEntityReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbEntityReactor)
virtual void | dragCloneToBeDeleted (const AcDbEntity *pOriginalObj, const AcDbEntity *pClone)
virtual void | modifiedGraphics (const AcDbEntity *dbObj)
- Public Member Functions inherited from AcDbObjectReactor
ACRX_DECLARE_MEMBERS (AcDbObjectReactor)
virtual void | cancelled (const AcDbObject *dbObj)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
virtual void | goodbye (const AcDbObject *dbObj)
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
virtual void | openedForModify (const AcDbObject *dbObj)
virtual void | reappended (const AcDbObject *dbObj)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual void | unappended (const AcDbObject *dbObj)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEntityReactor Member List

This is the complete list of members for AcDbEntityReactor, including all inherited members.

AcDbEntityReactor() (defined in AcDbEntityReactor) | AcDbEntityReactor | protected
AcDbObjectReactor() (defined in AcDbObjectReactor) | AcDbObjectReactor | protected
ACRX_DECLARE_MEMBERS(AcDbEntityReactor) (defined in AcDbEntityReactor) | AcDbEntityReactor |
ACRX_DECLARE_MEMBERS(AcDbObjectReactor) (defined in AcDbObjectReactor) | AcDbObjectReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cancelled(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dragCloneToBeDeleted(const AcDbEntity *pOriginalObj, const AcDbEntity *pClone) (defined in AcDbEntityReactor) | AcDbEntityReactor | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
modified(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
modifiedGraphics(const AcDbEntity *dbObj) (defined in AcDbEntityReactor) | AcDbEntityReactor | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
openedForModify(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbEvalConnectable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbEvalConnectable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEvalConnectable:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbEvalConnectable)
virtual bool | connectionAllowed (const AcString &thisConnection, const AcDbEvalNodeId sourceConnectableId, const AcString &sourceConnectionName) const
virtual Acad::ErrorStatus | connectTo (const AcString &thisConnection, const AcDbEvalNodeId sourceConnectableId, const AcString &sourceConnectionName)
virtual Acad::ErrorStatus | disconnectFrom (const AcString &thisConnection, const AcDbEvalNodeId sourceConnectableId, const AcString &sourceConnectionName)
virtual Acad::ErrorStatus | getConnectedNames (const AcString &thisConnection, const AcDbEvalNodeId sourceConnectableId, AcStringArray &sourceConnectionNames) const
virtual Acad::ErrorStatus | getConnectedObjects (const AcString &thisConnection, AcDbEvalNodeIdArray &connectedObjects) const
virtual Acad::ErrorStatus | getConnectionNames (AcStringArray &names) const
virtual Acad::ErrorStatus | getConnectionType (const AcString &name, AcDbEvalVariant::Type &type) const
virtual Acad::ErrorStatus | getConnectionValue (const AcString &name, AcDbEvalVariant &value) const
virtual bool | hasConnectionNamed (const AcString &name) const
virtual Acad::ErrorStatus | setConnectionValue (const AcString &name, const AcDbEvalVariant &value)
virtual | ~AcDbEvalConnectable ()
- Public Member Functions inherited from AcDbEvalExpr
ACDB_DECLARE_MEMBERS (AcDbEvalExpr)
AcDbEvalExpr ()
virtual void | activated (AcDbEvalNodeIdArray &argumentActiveList)
virtual void | addedToGraph (AcDbEvalGraph *pGraph)
virtual void | adjacentEdgeAdded (const AcDbEvalNodeId &fromId, const AcDbEvalNodeId &toId, bool bIsInvertible)
virtual void | adjacentEdgeRemoved (const AcDbEvalNodeId &adjEdgeNodeId)
virtual void | adjacentNodeRemoved (const AcDbEvalNodeId &adjNodeId)
virtual void | copiedIntoGraph (AcDbEvalGraph *pIntoGraph)
virtual bool | equals (const AcDbEvalExpr *pOther) const
virtual Acad::ErrorStatus | evaluate (const AcDbEvalContext *ctxt)
Acad::ErrorStatus | getGraph (AcDbEvalGraph **pGraph, AcDb::OpenMode mode) const
virtual void | graphEvalAbort (bool bNodeIsActive)
virtual void | graphEvalEnd (bool bNodeIsActive)
virtual void | graphEvalStart (bool bNodeIsActive)
virtual bool | isActivatable ()
virtual void | movedFromGraph (AcDbEvalGraph *pFromGraph)
virtual void | movedIntoGraph (AcDbEvalGraph *pIntoGraph)
AcDbEvalNodeId | nodeId () const
virtual Acad::ErrorStatus | postInDatabase (AcDbObjectId &objId, AcDbDatabase *pDb)
virtual void | remappedNodeIds (AcDbEvalIdMap &idMap)
virtual void | removedFromGraph (AcDbEvalGraph *pGraph)
AcDbEvalVariant | value () const
virtual | ~AcDbEvalExpr ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Attributes inherited from AcDbEvalExpr
AcDbEvalVariant | m_lastValue

Constructor & Destructor Documentation

virtual AcDbEvalConnectable::~AcDbEvalConnectable ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual bool AcDbEvalConnectable::connectionAllowed | ( | const AcString & | thisConnection,
 |  | const AcDbEvalNodeId | sourceConnectableId,
 |  | const AcString & | sourceConnectionName
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalConnectable::connectTo | ( | const AcString & | thisConnection,
 |  | const AcDbEvalNodeId | sourceConnectableId,
 |  | const AcString & | sourceConnectionName
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalConnectable::disconnectFrom | ( | const AcString & | thisConnection,
 |  | const AcDbEvalNodeId | sourceConnectableId,
 |  | const AcString & | sourceConnectionName
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalConnectable::getConnectedNames | ( | const AcString & | thisConnection,
 |  | const AcDbEvalNodeId | sourceConnectableId,
 |  | AcStringArray & | sourceConnectionNames
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalConnectable::getConnectedObjects | ( | const AcString & | thisConnection,
 |  | AcDbEvalNodeIdArray & | connectedObjects
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalConnectable::getConnectionNames ( AcStringArray & names ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalConnectable::getConnectionType | ( | const AcString & | name,
 |  | AcDbEvalVariant::Type & | type
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalConnectable::getConnectionValue | ( | const AcString & | name,
 |  | AcDbEvalVariant & | value
 | ) |  | const
 virtual
Warning
Not implemented!
virtual bool AcDbEvalConnectable::hasConnectionNamed ( const AcString & name ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalConnectable::setConnectionValue | ( | const AcString & | name,
 |  | const AcDbEvalVariant & | value
 | ) |  |
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbeval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEvalConnectable Member List

This is the complete list of members for AcDbEvalConnectable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEvalExpr) (defined in AcDbEvalExpr) | AcDbEvalExpr |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEvalConnectable() (defined in AcDbEvalConnectable) | AcDbEvalConnectable | protected
AcDbEvalExpr() | AcDbEvalExpr |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbEvalConnectable) (defined in AcDbEvalConnectable) | AcDbEvalConnectable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
activated(AcDbEvalNodeIdArray &argumentActiveList) | AcDbEvalExpr | virtual
addedToGraph(AcDbEvalGraph *pGraph) | AcDbEvalExpr | virtual
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
adjacentEdgeAdded(const AcDbEvalNodeId &fromId, const AcDbEvalNodeId &toId, bool bIsInvertible) | AcDbEvalExpr | virtual
adjacentEdgeRemoved(const AcDbEvalNodeId &adjEdgeNodeId) | AcDbEvalExpr | virtual
adjacentNodeRemoved(const AcDbEvalNodeId &adjNodeId) | AcDbEvalExpr | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
connectionAllowed(const AcString &thisConnection, const AcDbEvalNodeId sourceConnectableId, const AcString &sourceConnectionName) const | AcDbEvalConnectable | virtual
connectTo(const AcString &thisConnection, const AcDbEvalNodeId sourceConnectableId, const AcString &sourceConnectionName) | AcDbEvalConnectable | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copiedIntoGraph(AcDbEvalGraph *pIntoGraph) | AcDbEvalExpr | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
disconnectFrom(const AcString &thisConnection, const AcDbEvalNodeId sourceConnectableId, const AcString &sourceConnectionName) | AcDbEvalConnectable | virtual
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
equals(const AcDbEvalExpr *pOther) const | AcDbEvalExpr | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
evaluate(const AcDbEvalContext *ctxt) | AcDbEvalExpr | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getConnectedNames(const AcString &thisConnection, const AcDbEvalNodeId sourceConnectableId, AcStringArray &sourceConnectionNames) const | AcDbEvalConnectable | virtual
getConnectedObjects(const AcString &thisConnection, AcDbEvalNodeIdArray &connectedObjects) const | AcDbEvalConnectable | virtual
getConnectionNames(AcStringArray &names) const | AcDbEvalConnectable | virtual
getConnectionType(const AcString &name, AcDbEvalVariant::Type &type) const | AcDbEvalConnectable | virtual
getConnectionValue(const AcString &name, AcDbEvalVariant &value) const | AcDbEvalConnectable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGraph(AcDbEvalGraph **pGraph, AcDb::OpenMode mode) const | AcDbEvalExpr |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
graphEvalAbort(bool bNodeIsActive) | AcDbEvalExpr | virtual
graphEvalEnd(bool bNodeIsActive) | AcDbEvalExpr | virtual
graphEvalStart(bool bNodeIsActive) | AcDbEvalExpr | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasConnectionNamed(const AcString &name) const | AcDbEvalConnectable | virtual
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isActivatable() | AcDbEvalExpr | virtual
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
m_lastValue (defined in AcDbEvalExpr) | AcDbEvalExpr | protected
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
movedFromGraph(AcDbEvalGraph *pFromGraph) | AcDbEvalExpr | virtual
movedIntoGraph(AcDbEvalGraph *pIntoGraph) | AcDbEvalExpr | virtual
nodeId() const | AcDbEvalExpr |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
postInDatabase(AcDbObjectId &objId, AcDbDatabase *pDb) | AcDbEvalExpr | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
remappedNodeIds(AcDbEvalIdMap &idMap) | AcDbEvalExpr | virtual
removedFromGraph(AcDbEvalGraph *pGraph) | AcDbEvalExpr | virtual
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setConnectionValue(const AcString &name, const AcDbEvalVariant &value) | AcDbEvalConnectable | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
value() const | AcDbEvalExpr |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEvalConnectable() | AcDbEvalConnectable | virtual
~AcDbEvalExpr() | AcDbEvalExpr | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbEvalContext Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbEvalContext Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEvalContext:

Public Member Functions

AcDbEvalContext ()
ACRX_DECLARE_MEMBERS (AcDbEvalContext)
virtual Acad::ErrorStatus | getAt (AcDbEvalContextPair &pair) const
virtual void | insertAt (const AcDbEvalContextPair &pair)
virtual AcDbEvalContextIterator * | newIterator () const
virtual void | removeAt (const ACHAR *szKey)
virtual | ~AcDbEvalContext ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbEvalContext::AcDbEvalContext ( )
Warning
Not implemented!
virtual AcDbEvalContext::~AcDbEvalContext ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbEvalContext::getAt ( AcDbEvalContextPair & pair ) const
virtual
Warning
Not implemented!
virtual void AcDbEvalContext::insertAt ( const AcDbEvalContextPair & pair )
virtual
Warning
Not implemented!
virtual AcDbEvalContextIterator* AcDbEvalContext::newIterator ( ) const
virtual
Warning
Not implemented!
virtual void AcDbEvalContext::removeAt ( const ACHAR * szKey )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbeval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEvalContext Member List

This is the complete list of members for AcDbEvalContext, including all inherited members.

AcDbEvalContext() | AcDbEvalContext |
ACRX_DECLARE_MEMBERS(AcDbEvalContext) (defined in AcDbEvalContext) | AcDbEvalContext |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getAt(AcDbEvalContextPair &pair) const | AcDbEvalContext | virtual
insertAt(const AcDbEvalContextPair &pair) | AcDbEvalContext | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
newIterator() const | AcDbEvalContext | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeAt(const ACHAR *szKey) | AcDbEvalContext | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbEvalContext() | AcDbEvalContext | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbEvalContextIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbEvalContextIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEvalContextIterator:

Public Member Functions

AcDbEvalContextIterator ()
ACRX_DECLARE_MEMBERS (AcDbEvalContextIterator)
virtual AcDbEvalContextPair | contextPair () const
virtual bool | done () const
virtual bool | next ()
virtual void | start ()
virtual | ~AcDbEvalContextIterator ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpEvalContext

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbEvalContextIterator::AcDbEvalContextIterator ( )
Warning
Not implemented!
virtual AcDbEvalContextIterator::~AcDbEvalContextIterator ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual AcDbEvalContextPair AcDbEvalContextIterator::contextPair ( ) const
virtual
Warning
Not implemented!
virtual bool AcDbEvalContextIterator::done ( ) const
virtual
Warning
Not implemented!
virtual bool AcDbEvalContextIterator::next ( )
virtual
Warning
Not implemented!
virtual void AcDbEvalContextIterator::start ( )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbeval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEvalContextIterator Member List

This is the complete list of members for AcDbEvalContextIterator, including all inherited members.

AcDbEvalContextIterator() | AcDbEvalContextIterator |
AcDbImpEvalContext (defined in AcDbEvalContextIterator) | AcDbEvalContextIterator | friend
ACRX_DECLARE_MEMBERS(AcDbEvalContextIterator) (defined in AcDbEvalContextIterator) | AcDbEvalContextIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contextPair() const | AcDbEvalContextIterator | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const | AcDbEvalContextIterator | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
next() | AcDbEvalContextIterator | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
start() | AcDbEvalContextIterator | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbEvalContextIterator() | AcDbEvalContextIterator | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbEvalContextPair Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbEvalContextPair Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEvalContextPair:

Public Member Functions

AcDbEvalContextPair ()
AcDbEvalContextPair (const ACHAR *szKey, void *pValue)
const ACHAR * | key () const
void | setKey (const ACHAR *szKey)
void | setValue (void *pValue)
void * | value () const
virtual | ~AcDbEvalContextPair ()

Additional Inherited Members

- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbEvalContextPair::AcDbEvalContextPair ( )
Warning
Not implemented!
AcDbEvalContextPair::AcDbEvalContextPair | ( | const ACHAR * | szKey,
 |  | void * | pValue
 | ) |  |
Warning
Not implemented!
virtual AcDbEvalContextPair::~AcDbEvalContextPair ( )
virtual
Warning
Not implemented!

Member Function Documentation

const ACHAR* AcDbEvalContextPair::key ( ) const
Warning
Not implemented!
void AcDbEvalContextPair::setKey ( const ACHAR * szKey )
Warning
Not implemented!
void AcDbEvalContextPair::setValue ( void * pValue )
Warning
Not implemented!
void* AcDbEvalContextPair::value ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbeval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEvalContextPair Member List

This is the complete list of members for AcDbEvalContextPair, including all inherited members.

AcDbEvalContextPair() | AcDbEvalContextPair |
AcDbEvalContextPair(const ACHAR *szKey, void *pValue) | AcDbEvalContextPair |
key() const | AcDbEvalContextPair |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
setKey(const ACHAR *szKey) | AcDbEvalContextPair |
setValue(void *pValue) | AcDbEvalContextPair |
value() const | AcDbEvalContextPair |
~AcDbEvalContextPair() | AcDbEvalContextPair | virtual


ZRX API Reference: AcDbEvalEdgeInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbEvalEdgeInfo Class Reference
AcDb Classes

Public Member Functions

AcDbEvalEdgeInfo ()
AcDbEvalEdgeInfo (AcDbEvalNodeId from, AcDbEvalNodeId to, long flags, unsigned long count)
AcDbEvalNodeId | from () const
bool | isInvertible () const
bool | isSuppressed () const
bool | operator== (const AcDbEvalEdgeInfo &other) const
unsigned long | refCount () const
AcDbEvalNodeId | to () const

Constructor & Destructor Documentation

AcDbEvalEdgeInfo::AcDbEvalEdgeInfo ( )
inline
Warning
Not implemented!
AcDbEvalEdgeInfo::AcDbEvalEdgeInfo | ( | AcDbEvalNodeId | from,
 |  | AcDbEvalNodeId | to,
 |  | long | flags,
 |  | unsigned long | count
 | ) |  |
inline
Warning
Not implemented!

Member Function Documentation

AcDbEvalNodeId AcDbEvalEdgeInfo::from ( ) const
Warning
Not implemented!
bool AcDbEvalEdgeInfo::isInvertible ( ) const
Warning
Not implemented!
bool AcDbEvalEdgeInfo::isSuppressed ( ) const
Warning
Not implemented!
bool AcDbEvalEdgeInfo::operator== ( const AcDbEvalEdgeInfo & other ) const
Warning
Not implemented!
unsigned long AcDbEvalEdgeInfo::refCount ( ) const
Warning
Not implemented!
AcDbEvalNodeId AcDbEvalEdgeInfo::to ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbeval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEvalEdgeInfo Member List

This is the complete list of members for AcDbEvalEdgeInfo, including all inherited members.

AcDbEvalEdgeInfo() | AcDbEvalEdgeInfo | inline
AcDbEvalEdgeInfo(AcDbEvalNodeId from, AcDbEvalNodeId to, long flags, unsigned long count) | AcDbEvalEdgeInfo | inline
from() const | AcDbEvalEdgeInfo |
isInvertible() const | AcDbEvalEdgeInfo |
isSuppressed() const | AcDbEvalEdgeInfo |
operator==(const AcDbEvalEdgeInfo &other) const | AcDbEvalEdgeInfo |
refCount() const | AcDbEvalEdgeInfo |
to() const | AcDbEvalEdgeInfo |


ZRX API Reference: AcDbEvalExpr Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
AcDbEvalExpr Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEvalExpr:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbEvalExpr)
AcDbEvalExpr ()
virtual void | activated (AcDbEvalNodeIdArray &argumentActiveList)
virtual void | addedToGraph (AcDbEvalGraph *pGraph)
virtual void | adjacentEdgeAdded (const AcDbEvalNodeId &fromId, const AcDbEvalNodeId &toId, bool bIsInvertible)
virtual void | adjacentEdgeRemoved (const AcDbEvalNodeId &adjEdgeNodeId)
virtual void | adjacentNodeRemoved (const AcDbEvalNodeId &adjNodeId)
virtual void | copiedIntoGraph (AcDbEvalGraph *pIntoGraph)
virtual bool | equals (const AcDbEvalExpr *pOther) const
virtual Acad::ErrorStatus | evaluate (const AcDbEvalContext *ctxt)
Acad::ErrorStatus | getGraph (AcDbEvalGraph **pGraph, AcDb::OpenMode mode) const
virtual void | graphEvalAbort (bool bNodeIsActive)
virtual void | graphEvalEnd (bool bNodeIsActive)
virtual void | graphEvalStart (bool bNodeIsActive)
virtual bool | isActivatable ()
virtual void | movedFromGraph (AcDbEvalGraph *pFromGraph)
virtual void | movedIntoGraph (AcDbEvalGraph *pIntoGraph)
AcDbEvalNodeId | nodeId () const
virtual Acad::ErrorStatus | postInDatabase (AcDbObjectId &objId, AcDbDatabase *pDb)
virtual void | remappedNodeIds (AcDbEvalIdMap &idMap)
virtual void | removedFromGraph (AcDbEvalGraph *pGraph)
AcDbEvalVariant | value () const
virtual | ~AcDbEvalExpr ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Attributes

AcDbEvalVariant m_lastValue

Friends

class AcDbImpEvalExpr

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbEvalExpr::AcDbEvalExpr ( )
Warning
Not implemented!
virtual AcDbEvalExpr::~AcDbEvalExpr ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual void AcDbEvalExpr::activated ( AcDbEvalNodeIdArray & argumentActiveList )
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::addedToGraph ( AcDbEvalGraph * pGraph )
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::adjacentEdgeAdded | ( | const AcDbEvalNodeId & | fromId,
 |  | const AcDbEvalNodeId & | toId,
 |  | bool | bIsInvertible
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::adjacentEdgeRemoved ( const AcDbEvalNodeId & adjEdgeNodeId )
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::adjacentNodeRemoved ( const AcDbEvalNodeId & adjNodeId )
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::copiedIntoGraph ( AcDbEvalGraph * pIntoGraph )
virtual
Warning
Not implemented!
virtual bool AcDbEvalExpr::equals ( const AcDbEvalExpr * pOther ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalExpr::evaluate ( const AcDbEvalContext * ctxt )
virtual
Warning
Not implemented!
Acad::ErrorStatus AcDbEvalExpr::getGraph | ( | AcDbEvalGraph ** | pGraph,
 |  | AcDb::OpenMode | mode
 | ) |  | const
Warning
Not implemented!
virtual void AcDbEvalExpr::graphEvalAbort ( bool bNodeIsActive )
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::graphEvalEnd ( bool bNodeIsActive )
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::graphEvalStart ( bool bNodeIsActive )
virtual
Warning
Not implemented!
virtual bool AcDbEvalExpr::isActivatable ( )
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::movedFromGraph ( AcDbEvalGraph * pFromGraph )
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::movedIntoGraph ( AcDbEvalGraph * pIntoGraph )
virtual
Warning
Not implemented!
AcDbEvalNodeId AcDbEvalExpr::nodeId ( ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalExpr::postInDatabase | ( | AcDbObjectId & | objId,
 |  | AcDbDatabase * | pDb
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::remappedNodeIds ( AcDbEvalIdMap & idMap )
virtual
Warning
Not implemented!
virtual void AcDbEvalExpr::removedFromGraph ( AcDbEvalGraph * pGraph )
virtual
Warning
Not implemented!
AcDbEvalVariant AcDbEvalExpr::value ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbeval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEvalExpr Member List

This is the complete list of members for AcDbEvalExpr, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEvalExpr) (defined in AcDbEvalExpr) | AcDbEvalExpr |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEvalExpr() | AcDbEvalExpr |
AcDbImpEvalExpr (defined in AcDbEvalExpr) | AcDbEvalExpr | friend
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
activated(AcDbEvalNodeIdArray &argumentActiveList) | AcDbEvalExpr | virtual
addedToGraph(AcDbEvalGraph *pGraph) | AcDbEvalExpr | virtual
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
adjacentEdgeAdded(const AcDbEvalNodeId &fromId, const AcDbEvalNodeId &toId, bool bIsInvertible) | AcDbEvalExpr | virtual
adjacentEdgeRemoved(const AcDbEvalNodeId &adjEdgeNodeId) | AcDbEvalExpr | virtual
adjacentNodeRemoved(const AcDbEvalNodeId &adjNodeId) | AcDbEvalExpr | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copiedIntoGraph(AcDbEvalGraph *pIntoGraph) | AcDbEvalExpr | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
equals(const AcDbEvalExpr *pOther) const | AcDbEvalExpr | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
evaluate(const AcDbEvalContext *ctxt) | AcDbEvalExpr | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGraph(AcDbEvalGraph **pGraph, AcDb::OpenMode mode) const | AcDbEvalExpr |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
graphEvalAbort(bool bNodeIsActive) | AcDbEvalExpr | virtual
graphEvalEnd(bool bNodeIsActive) | AcDbEvalExpr | virtual
graphEvalStart(bool bNodeIsActive) | AcDbEvalExpr | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isActivatable() | AcDbEvalExpr | virtual
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
m_lastValue (defined in AcDbEvalExpr) | AcDbEvalExpr | protected
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
movedFromGraph(AcDbEvalGraph *pFromGraph) | AcDbEvalExpr | virtual
movedIntoGraph(AcDbEvalGraph *pIntoGraph) | AcDbEvalExpr | virtual
nodeId() const | AcDbEvalExpr |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
postInDatabase(AcDbObjectId &objId, AcDbDatabase *pDb) | AcDbEvalExpr | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
remappedNodeIds(AcDbEvalIdMap &idMap) | AcDbEvalExpr | virtual
removedFromGraph(AcDbEvalGraph *pGraph) | AcDbEvalExpr | virtual
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
value() const | AcDbEvalExpr |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEvalExpr() | AcDbEvalExpr | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbEvalGraph Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcDbEvalGraph Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEvalGraph:

Public Types

enum NodeId { kNullNodeId = 0 }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbEvalGraph)
virtual Acad::ErrorStatus | activate (const AcDbEvalNodeIdArray &activatedNodes) const
virtual Acad::ErrorStatus | activate (const AcDbEvalNodeIdArray &activatedNodes, AcDbEvalNodeIdArray *pActiveSubgraph) const
virtual Acad::ErrorStatus | activate (const AcDbEvalNodeIdArray &activatedNodes, AcDbEvalNodeIdArray *pActiveSubgraph, AcDbEvalNodeIdArray *pCycleNodes) const
virtual Acad::ErrorStatus | addEdge (const AcDbEvalNodeId &idFrom, const AcDbEvalNodeId &idTo)
virtual Acad::ErrorStatus | addEdge (const AcDbEvalNodeId &idFrom, const AcDbEvalNodeId &idTo, bool bInvertible)
virtual Acad::ErrorStatus | addGraph (AcDbEvalGraph *pGraphToAdd, AcDbEvalIdMap *&idMap)
virtual Acad::ErrorStatus | addNode (AcDbEvalExpr *pNode, AcDbEvalNodeId &id)
virtual bool | equals (const AcDbEvalGraph *pOther) const
virtual Acad::ErrorStatus | evaluate () const
virtual Acad::ErrorStatus | evaluate (const AcDbEvalContext *pContext) const
virtual Acad::ErrorStatus | evaluate (const AcDbEvalContext *pContext, const AcDbEvalNodeIdArray *activatedNodes) const
virtual Acad::ErrorStatus | getAllNodes (AcDbEvalNodeIdArray &nodes) const
virtual Acad::ErrorStatus | getEdgeInfo (const AcDbEvalNodeId &nodeFrom, const AcDbEvalNodeId &nodeTo, AcDbEvalEdgeInfo &einfo) const
virtual Acad::ErrorStatus | getIncomingEdges (const AcDbEvalNodeId &nodeId, AcDbEvalEdgeInfoArray &edges) const
virtual Acad::ErrorStatus | getIsActive (const AcDbEvalNodeId &id, bool &bIsActive) const
virtual Acad::ErrorStatus | getNode (const AcDbEvalNodeId &nodeId, AcDb::OpenMode mode, AcDbObject **ppNode) const
virtual Acad::ErrorStatus | getOutgoingEdges (const AcDbEvalNodeId &nodeId, AcDbEvalEdgeInfoArray &edges) const
virtual bool | isSubgraphOf (const AcDbEvalGraph *pOther) const
virtual Acad::ErrorStatus | postInDatabase (AcDbObjectId &objId, AcDbDatabase *pDb)
virtual Acad::ErrorStatus | removeEdge (const AcDbEvalNodeId &idFrom, const AcDbEvalNodeId &idTo)
virtual Acad::ErrorStatus | removeNode (const AcDbEvalNodeId &id)
virtual Acad::ErrorStatus | removeNode (AcDbEvalExpr *pNode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static Acad::ErrorStatus | createGraph (AcDbObject *pObj, const ACHAR *pKey)
static Acad::ErrorStatus | createGraph (AcDbDatabase *pDb, const ACHAR *pKey)
static Acad::ErrorStatus | getGraph (const AcDbObject *pObj, const ACHAR *pKey, AcDbEvalGraph **pGraph, const AcDb::OpenMode mode)
static Acad::ErrorStatus | getGraph (AcDbDatabase *pDb, const ACHAR *pKey, AcDbEvalGraph **pGraph, const AcDb::OpenMode mode)
static bool | hasGraph (const AcDbObject *pObj, const ACHAR *pKey)
static bool | hasGraph (AcDbDatabase *pDb, const ACHAR *pKey)
static Acad::ErrorStatus | removeGraph (AcDbObject *pObj, const ACHAR *pKey)
static Acad::ErrorStatus | removeGraph (AcDbDatabase *pDb, const ACHAR *pKey)
static Acad::ErrorStatus | replaceGraph (AcDbObject *pObj, const ACHAR *pKey, AcDbObjectId grphId)

Member Function Documentation

virtual Acad::ErrorStatus AcDbEvalGraph::activate ( const AcDbEvalNodeIdArray & activatedNodes ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::activate | ( | const AcDbEvalNodeIdArray & | activatedNodes,
 |  | AcDbEvalNodeIdArray * | pActiveSubgraph
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::activate | ( | const AcDbEvalNodeIdArray & | activatedNodes,
 |  | AcDbEvalNodeIdArray * | pActiveSubgraph,
 |  | AcDbEvalNodeIdArray * | pCycleNodes
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::addEdge | ( | const AcDbEvalNodeId & | idFrom,
 |  | const AcDbEvalNodeId & | idTo
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::addEdge | ( | const AcDbEvalNodeId & | idFrom,
 |  | const AcDbEvalNodeId & | idTo,
 |  | bool | bInvertible
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::addGraph | ( | AcDbEvalGraph * | pGraphToAdd,
 |  | AcDbEvalIdMap *& | idMap
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::addNode | ( | AcDbEvalExpr * | pNode,
 |  | AcDbEvalNodeId & | id
 | ) |  |
virtual
Warning
Not implemented!
static Acad::ErrorStatus AcDbEvalGraph::createGraph | ( | AcDbObject * | pObj,
 |  | const ACHAR * | pKey
 | ) |  |
static
Warning
Not implemented!
static Acad::ErrorStatus AcDbEvalGraph::createGraph | ( | AcDbDatabase * | pDb,
 |  | const ACHAR * | pKey
 | ) |  |
static
Warning
Not implemented!
virtual bool AcDbEvalGraph::equals ( const AcDbEvalGraph * pOther ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::evaluate ( ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::evaluate ( const AcDbEvalContext * pContext ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::evaluate | ( | const AcDbEvalContext * | pContext,
 |  | const AcDbEvalNodeIdArray * | activatedNodes
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::getAllNodes ( AcDbEvalNodeIdArray & nodes ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::getEdgeInfo | ( | const AcDbEvalNodeId & | nodeFrom,
 |  | const AcDbEvalNodeId & | nodeTo,
 |  | AcDbEvalEdgeInfo & | einfo
 | ) |  | const
 virtual
Warning
Not implemented!
static Acad::ErrorStatus AcDbEvalGraph::getGraph | ( | const AcDbObject * | pObj,
 |  | const ACHAR * | pKey,
 |  | AcDbEvalGraph ** | pGraph,
 |  | const AcDb::OpenMode | mode
 | ) |  |
static
Warning
Not implemented!
static Acad::ErrorStatus AcDbEvalGraph::getGraph | ( | AcDbDatabase * | pDb,
 |  | const ACHAR * | pKey,
 |  | AcDbEvalGraph ** | pGraph,
 |  | const AcDb::OpenMode | mode
 | ) |  |
static
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::getIncomingEdges | ( | const AcDbEvalNodeId & | nodeId,
 |  | AcDbEvalEdgeInfoArray & | edges
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::getIsActive | ( | const AcDbEvalNodeId & | id,
 |  | bool & | bIsActive
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::getNode | ( | const AcDbEvalNodeId & | nodeId,
 |  | AcDb::OpenMode | mode,
 |  | AcDbObject ** | ppNode
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::getOutgoingEdges | ( | const AcDbEvalNodeId & | nodeId,
 |  | AcDbEvalEdgeInfoArray & | edges
 | ) |  | const
 virtual
Warning
Not implemented!
static bool AcDbEvalGraph::hasGraph | ( | AcDbDatabase * | pDb,
 |  | const ACHAR * | pKey
 | ) |  |
static
Warning
Not implemented!
virtual bool AcDbEvalGraph::isSubgraphOf ( const AcDbEvalGraph * pOther ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::postInDatabase | ( | AcDbObjectId & | objId,
 |  | AcDbDatabase * | pDb
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::removeEdge | ( | const AcDbEvalNodeId & | idFrom,
 |  | const AcDbEvalNodeId & | idTo
 | ) |  |
virtual
Warning
Not implemented!
static Acad::ErrorStatus AcDbEvalGraph::removeGraph | ( | AcDbDatabase * | pDb,
 |  | const ACHAR * | pKey
 | ) |  |
static
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::removeNode ( const AcDbEvalNodeId & id )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbEvalGraph::removeNode ( AcDbEvalExpr * pNode )
virtual
Warning
Not implemented!
static Acad::ErrorStatus AcDbEvalGraph::replaceGraph | ( | AcDbObject * | pObj,
 |  | const ACHAR * | pKey,
 |  | AcDbObjectId | grphId
 | ) |  |
static
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbeval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEvalGraph Member List

This is the complete list of members for AcDbEvalGraph, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEvalGraph) (defined in AcDbEvalGraph) | AcDbEvalGraph |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEvalGraph() (defined in AcDbEvalGraph) | AcDbEvalGraph |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
activate(const AcDbEvalNodeIdArray &activatedNodes) const | AcDbEvalGraph | virtual
activate(const AcDbEvalNodeIdArray &activatedNodes, AcDbEvalNodeIdArray *pActiveSubgraph) const | AcDbEvalGraph | virtual
activate(const AcDbEvalNodeIdArray &activatedNodes, AcDbEvalNodeIdArray *pActiveSubgraph, AcDbEvalNodeIdArray *pCycleNodes) const | AcDbEvalGraph | virtual
addEdge(const AcDbEvalNodeId &idFrom, const AcDbEvalNodeId &idTo) | AcDbEvalGraph | virtual
addEdge(const AcDbEvalNodeId &idFrom, const AcDbEvalNodeId &idTo, bool bInvertible) | AcDbEvalGraph | virtual
addGraph(AcDbEvalGraph *pGraphToAdd, AcDbEvalIdMap *&idMap) | AcDbEvalGraph | virtual
addNode(AcDbEvalExpr *pNode, AcDbEvalNodeId &id) | AcDbEvalGraph | virtual
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createGraph(AcDbObject *pObj, const ACHAR *pKey) | AcDbEvalGraph | static
createGraph(AcDbDatabase *pDb, const ACHAR *pKey) | AcDbEvalGraph | static
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
equals(const AcDbEvalGraph *pOther) const | AcDbEvalGraph | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
evaluate() const | AcDbEvalGraph | virtual
evaluate(const AcDbEvalContext *pContext) const | AcDbEvalGraph | virtual
evaluate(const AcDbEvalContext *pContext, const AcDbEvalNodeIdArray *activatedNodes) const | AcDbEvalGraph | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAllNodes(AcDbEvalNodeIdArray &nodes) const | AcDbEvalGraph | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getEdgeInfo(const AcDbEvalNodeId &nodeFrom, const AcDbEvalNodeId &nodeTo, AcDbEvalEdgeInfo &einfo) const | AcDbEvalGraph | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGraph(const AcDbObject *pObj, const ACHAR *pKey, AcDbEvalGraph **pGraph, const AcDb::OpenMode mode) | AcDbEvalGraph | static
getGraph(AcDbDatabase *pDb, const ACHAR *pKey, AcDbEvalGraph **pGraph, const AcDb::OpenMode mode) | AcDbEvalGraph | static
getIncomingEdges(const AcDbEvalNodeId &nodeId, AcDbEvalEdgeInfoArray &edges) const | AcDbEvalGraph | virtual
getIsActive(const AcDbEvalNodeId &id, bool &bIsActive) const | AcDbEvalGraph | virtual
getNode(const AcDbEvalNodeId &nodeId, AcDb::OpenMode mode, AcDbObject **ppNode) const | AcDbEvalGraph | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOutgoingEdges(const AcDbEvalNodeId &nodeId, AcDbEvalEdgeInfoArray &edges) const | AcDbEvalGraph | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasGraph(const AcDbObject *pObj, const ACHAR *pKey) (defined in AcDbEvalGraph) | AcDbEvalGraph | static
hasGraph(AcDbDatabase *pDb, const ACHAR *pKey) | AcDbEvalGraph | static
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isSubgraphOf(const AcDbEvalGraph *pOther) const | AcDbEvalGraph | virtual
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kNullNodeId enum value (defined in AcDbEvalGraph) | AcDbEvalGraph |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
NodeId enum name (defined in AcDbEvalGraph) | AcDbEvalGraph |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
postInDatabase(AcDbObjectId &objId, AcDbDatabase *pDb) | AcDbEvalGraph | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeEdge(const AcDbEvalNodeId &idFrom, const AcDbEvalNodeId &idTo) | AcDbEvalGraph | virtual
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeGraph(AcDbObject *pObj, const ACHAR *pKey) (defined in AcDbEvalGraph) | AcDbEvalGraph | static
removeGraph(AcDbDatabase *pDb, const ACHAR *pKey) | AcDbEvalGraph | static
removeNode(const AcDbEvalNodeId &id) | AcDbEvalGraph | virtual
removeNode(AcDbEvalExpr *pNode) | AcDbEvalGraph | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
replaceGraph(AcDbObject *pObj, const ACHAR *pKey, AcDbObjectId grphId) | AcDbEvalGraph | static
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEvalGraph() (defined in AcDbEvalGraph) | AcDbEvalGraph | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbEvalIdMap Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbEvalIdMap Class Reference
AcDb Classes

Public Member Functions

virtual AcDbEvalNodeId | find (const AcDbEvalNodeId &key)=0
virtual void | kill ()=0
The documentation for this class was generated from the following file:
  • dbeval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEvalIdMap Member List

This is the complete list of members for AcDbEvalIdMap, including all inherited members.

find(const AcDbEvalNodeId &key)=0 (defined in AcDbEvalIdMap) | AcDbEvalIdMap | pure virtual
kill()=0 (defined in AcDbEvalIdMap) | AcDbEvalIdMap | pure virtual


ZRX API Reference: AcDbEvalVariant Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
AcDbEvalVariant Class Reference
AcDb Classes
+ Inheritance diagram for AcDbEvalVariant:

Public Types

enum Type {
kNone = AcDb::kDxfInvalid, kShort = AcDb::kDxfInt16, kLong = AcDb::kDxfInt32, kDouble = AcDb::kDxfReal,
kString = AcDb::kDxfText, kOldId = AcDb::kDxfInt32+1, kPoint2d = AcDb::kDxfXCoord, kPoint3d = AcDb::kDxfXCoord+1
}

Public Member Functions

AcDbEvalVariant (const AcDbEvalVariant &other)
AcDbEvalVariant (const AcDbEvalVariant *pOther)
AcDbEvalVariant (double dVal)
AcDbEvalVariant (short iVal)
AcDbEvalVariant (const ACHAR *szVal)
AcDbEvalVariant (long lVal)
AcDbEvalVariant (const AcDbObjectId &id)
AcDbEvalVariant (const AcGePoint2d &pt)
AcDbEvalVariant (const AcGePoint3d &pt)
ACRX_DECLARE_MEMBERS (AcDbEvalVariant)
void | clear ()
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pOther)
AcDbEvalVariant & | operator= (double dVal)
AcDbEvalVariant & | operator= (short iVal)
AcDbEvalVariant & | operator= (long lVal)
AcDbEvalVariant & | operator= (const ACHAR *szVal)
AcDbEvalVariant & | operator= (const AcDbEvalVariant &other)
AcDbEvalVariant & | operator= (const AcDbObjectId &id)
AcDbEvalVariant & | operator= (const AcGePoint2d &pt)
AcDbEvalVariant & | operator= (const AcGePoint3d &pt)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

void init ()

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Public Attributes inherited from resbuf
struct resbuf * | rbnext
short | restype
union ads_u_val | resval
The documentation for this class was generated from the following file:
  • dbeval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbEvalVariant Member List

This is the complete list of members for AcDbEvalVariant, including all inherited members.

AcDbEvalVariant() (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcDbEvalVariant(const AcDbEvalVariant &other) (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcDbEvalVariant(const AcDbEvalVariant *pOther) (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcDbEvalVariant(double dVal) (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcDbEvalVariant(short iVal) (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcDbEvalVariant(const ACHAR *szVal) (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcDbEvalVariant(long lVal) (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcDbEvalVariant(const AcDbObjectId &id) (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcDbEvalVariant(const AcGePoint2d &pt) (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcDbEvalVariant(const AcGePoint3d &pt) (defined in AcDbEvalVariant) | AcDbEvalVariant |
ACRX_DECLARE_MEMBERS(AcDbEvalVariant) (defined in AcDbEvalVariant) | AcDbEvalVariant |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clear() (defined in AcDbEvalVariant) | AcDbEvalVariant |
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *pOther) (defined in AcDbEvalVariant) | AcDbEvalVariant | virtual
desc() (defined in AcRxObject) | AcRxObject | static
init() (defined in AcDbEvalVariant) | AcDbEvalVariant | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDouble enum value (defined in AcDbEvalVariant) | AcDbEvalVariant |
kLong enum value (defined in AcDbEvalVariant) | AcDbEvalVariant |
kNone enum value (defined in AcDbEvalVariant) | AcDbEvalVariant |
kOldId enum value (defined in AcDbEvalVariant) | AcDbEvalVariant |
kPoint2d enum value (defined in AcDbEvalVariant) | AcDbEvalVariant |
kPoint3d enum value (defined in AcDbEvalVariant) | AcDbEvalVariant |
kShort enum value (defined in AcDbEvalVariant) | AcDbEvalVariant |
kString enum value (defined in AcDbEvalVariant) | AcDbEvalVariant |
operator=(double dVal) (defined in AcDbEvalVariant) | AcDbEvalVariant |
operator=(short iVal) (defined in AcDbEvalVariant) | AcDbEvalVariant |
operator=(long lVal) (defined in AcDbEvalVariant) | AcDbEvalVariant |
operator=(const ACHAR *szVal) (defined in AcDbEvalVariant) | AcDbEvalVariant |
operator=(const AcDbEvalVariant &other) (defined in AcDbEvalVariant) | AcDbEvalVariant |
operator=(const AcDbObjectId &id) (defined in AcDbEvalVariant) | AcDbEvalVariant |
operator=(const AcGePoint2d &pt) (defined in AcDbEvalVariant) | AcDbEvalVariant |
operator=(const AcGePoint3d &pt) (defined in AcDbEvalVariant) | AcDbEvalVariant |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rbnext (defined in resbuf) | resbuf |
restype (defined in resbuf) | resbuf |
resval (defined in resbuf) | resbuf |
Type enum name (defined in AcDbEvalVariant) | AcDbEvalVariant |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbEvalVariant() (defined in AcDbEvalVariant) | AcDbEvalVariant |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbExtents Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbExtents Class Reference
AcDb Classes
+ Inheritance diagram for AcDbExtents:

Public Member Functions

AcDbExtents (const AcDbExtents &src)
AcDbExtents (const AcGePoint3d &min, const AcGePoint3d &max)
Acad::ErrorStatus | addBlockExt (AcDbBlockTableRecord *pBTR)
void | addExt (const AcDbExtents &src)
void | addPoint (const AcGePoint3d &pt)
void | expandBy (const AcGeVector3d &vec)
AcGePoint3d | maxPoint () const
AcGePoint3d | minPoint () const
Acad::ErrorStatus | set (const AcGePoint3d &min, const AcGePoint3d &max)
void | transformBy (const AcGeMatrix3d &mat)

Additional Inherited Members

- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbExtents Member List

This is the complete list of members for AcDbExtents, including all inherited members.

AcDbExtents() (defined in AcDbExtents) | AcDbExtents |
AcDbExtents(const AcDbExtents &src) (defined in AcDbExtents) | AcDbExtents |
AcDbExtents(const AcGePoint3d &min, const AcGePoint3d &max) (defined in AcDbExtents) | AcDbExtents |
addBlockExt(AcDbBlockTableRecord *pBTR) (defined in AcDbExtents) | AcDbExtents |
addExt(const AcDbExtents &src) (defined in AcDbExtents) | AcDbExtents |
addPoint(const AcGePoint3d &pt) (defined in AcDbExtents) | AcDbExtents |
expandBy(const AcGeVector3d &vec) (defined in AcDbExtents) | AcDbExtents |
maxPoint() const (defined in AcDbExtents) | AcDbExtents | inline
minPoint() const (defined in AcDbExtents) | AcDbExtents | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
set(const AcGePoint3d &min, const AcGePoint3d &max) (defined in AcDbExtents) | AcDbExtents |
transformBy(const AcGeMatrix3d &mat) (defined in AcDbExtents) | AcDbExtents |


ZRX API Reference: AcDbExtrudedSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbExtrudedSurface Class Reference
AcDb Classes
+ Inheritance diagram for AcDbExtrudedSurface:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbExtrudedSurface)
AcDbExtrudedSurface ()
virtual Acad::ErrorStatus | createExtrudedSurface (AcDbEntity *pSweepEnt, const AcGeVector3d &directionVec, AcDbSweepOptions &sweepOptions)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
double | getHeight () const
AcDbEntity * | getSweepEntity () const
void | getSweepOptions (AcDbSweepOptions &sweepOptions) const
AcGeVector3d | getSweepVec () const
virtual bool | isDependent () const
virtual void | list () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
Acad::ErrorStatus | setExtrude (const AcGeVector3d &sweepVec, const AcDbSweepOptions &sweepOptions)
Acad::ErrorStatus | setHeight (double height)
Acad::ErrorStatus | setSweepOptions (const AcDbSweepOptions &sweepOptions)
Acad::ErrorStatus | setSweepVec (const AcGeVector3d &sweepVec)
virtual | ~AcDbExtrudedSurface ()
- Public Member Functions inherited from AcDbSurface
ACDB_DECLARE_MEMBERS (AcDbSurface)
AcDbSurface ()
virtual void * | body () const
virtual Acad::ErrorStatus | convertToRegion (AcArray< AcDbEntity * > &regions)
virtual Acad::ErrorStatus | getArea (double &area) const
virtual AcDbSubentId | internalSubentId (void *ent) const
virtual void * | internalSubentPtr (const AcDbSubentId &id) const
virtual Acad::ErrorStatus | setBody (const void *modelerBody)
virtual Acad::ErrorStatus | setUIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | setVIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | thicken (double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const
virtual Adesk::UInt16 | uIsolineDensity () const
virtual Adesk::UInt16 | vIsolineDensity () const
virtual | ~AcDbSurface ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcDbSurface
static Acad::ErrorStatus | createFrom (const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface)

Constructor & Destructor Documentation

AcDbExtrudedSurface::AcDbExtrudedSurface ( )
Warning
Not implemented!
virtual AcDbExtrudedSurface::~AcDbExtrudedSurface ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbExtrudedSurface::createExtrudedSurface | ( | AcDbEntity * | pSweepEnt,
 |  | const AcGeVector3d & | directionVec,
 |  | AcDbSweepOptions & | sweepOptions
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbExtrudedSurface::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbExtrudedSurface::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbExtrudedSurface::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbExtrudedSurface::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbExtrudedSurface::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbExtrudedSurface::getGripEntityUCS | ( | const void * | pGripAppData,
 |  | AcGeVector3d & | normalVec,
 |  | AcGePoint3d & | origin,
 |  | AcGeVector3d & | xAxis
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbExtrudedSurface::getGripPoints | ( | AcGePoint3dArray & | gripPoints,
 |  | AcDbIntArray & | osnapModes,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbExtrudedSurface::getGripPoints | ( | AcDbGripDataPtrArray & | grips,
 |  | const double | curViewUnitSize,
 |  | const int | gripSize,
 |  | const AcGeVector3d & | curViewDir,
 |  | const int | bitflags
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

double AcDbExtrudedSurface::getHeight ( ) const
Warning
Not implemented!
AcDbEntity* AcDbExtrudedSurface::getSweepEntity ( ) const
Warning
Not implemented!
void AcDbExtrudedSurface::getSweepOptions ( AcDbSweepOptions & sweepOptions ) const
Warning
Not implemented!
AcGeVector3d AcDbExtrudedSurface::getSweepVec ( ) const
Warning
Not implemented!
virtual bool AcDbExtrudedSurface::isDependent ( ) const
virtual
Warning
Not implemented!
virtual void AcDbExtrudedSurface::list ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbExtrudedSurface::moveGripPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbExtrudedSurface::moveStretchPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Acad::ErrorStatus AcDbExtrudedSurface::setExtrude | ( | const AcGeVector3d & | sweepVec,
 |  | const AcDbSweepOptions & | sweepOptions
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbExtrudedSurface::setHeight ( double height )
Warning
Not implemented!
Acad::ErrorStatus AcDbExtrudedSurface::setSweepOptions ( const AcDbSweepOptions & sweepOptions )
Warning
Not implemented!
Acad::ErrorStatus AcDbExtrudedSurface::setSweepVec ( const AcGeVector3d & sweepVec )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbextrudedsurf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbExtrudedSurface Member List

This is the complete list of members for AcDbExtrudedSurface, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbExtrudedSurface) (defined in AcDbExtrudedSurface) | AcDbExtrudedSurface |
ACDB_DECLARE_MEMBERS(AcDbSurface) (defined in AcDbSurface) | AcDbSurface |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbExtrudedSurface() | AcDbExtrudedSurface |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSurface() | AcDbSurface |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
body() const | AcDbSurface | virtual
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToRegion(AcArray< AcDbEntity * > &regions) | AcDbSurface | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createExtrudedSurface(AcDbEntity *pSweepEnt, const AcGeVector3d &directionVec, AcDbSweepOptions &sweepOptions) | AcDbExtrudedSurface | virtual
createFrom(const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface) | AcDbSurface | static
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbExtrudedSurface | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbExtrudedSurface | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbExtrudedSurface | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbExtrudedSurface | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &area) const | AcDbSurface | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbExtrudedSurface | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const | AcDbExtrudedSurface | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const | AcDbExtrudedSurface | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const | AcDbExtrudedSurface | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getHeight() const | AcDbExtrudedSurface |
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSweepEntity() const | AcDbExtrudedSurface |
getSweepOptions(AcDbSweepOptions &sweepOptions) const | AcDbExtrudedSurface |
getSweepVec() const | AcDbExtrudedSurface |
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
internalSubentId(void *ent) const | AcDbSurface | virtual
internalSubentPtr(const AcDbSubentId &id) const | AcDbSurface | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const | AcDbExtrudedSurface | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const | AcDbExtrudedSurface | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbExtrudedSurface | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbExtrudedSurface | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBody(const void *modelerBody) | AcDbSurface | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setExtrude(const AcGeVector3d &sweepVec, const AcDbSweepOptions &sweepOptions) | AcDbExtrudedSurface |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double height) | AcDbExtrudedSurface |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setSweepOptions(const AcDbSweepOptions &sweepOptions) | AcDbExtrudedSurface |
setSweepVec(const AcGeVector3d &sweepVec) | AcDbExtrudedSurface |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thicken(double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const | AcDbSurface | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
uIsolineDensity() const | AcDbSurface | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
vIsolineDensity() const | AcDbSurface | virtual
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbExtrudedSurface() | AcDbExtrudedSurface | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSurface() | AcDbSurface | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbFace Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbFace Class Reference
AcDb Classes
+ Inheritance diagram for AcDbFace:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbFace)
AcDbFace (const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2, const AcGePoint3d &pt3, Adesk::Boolean e0vis=Adesk::kTrue, Adesk::Boolean e1vis=Adesk::kTrue, Adesk::Boolean e2vis=Adesk::kTrue, Adesk::Boolean e3vis=Adesk::kTrue)
AcDbFace (const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2, Adesk::Boolean e0vis=Adesk::kTrue, Adesk::Boolean e1vis=Adesk::kTrue, Adesk::Boolean e2vis=Adesk::kTrue, Adesk::Boolean e3vis=Adesk::kTrue)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getVertexAt (Adesk::UInt16, AcGePoint3d &) const
Acad::ErrorStatus | isEdgeVisibleAt (Adesk::UInt16, Adesk::Boolean &) const
Acad::ErrorStatus | makeEdgeInvisibleAt (Adesk::UInt16)
Acad::ErrorStatus | makeEdgeVisibleAt (Adesk::UInt16)
Acad::ErrorStatus | setVertexAt (Adesk::UInt16, const AcGePoint3d &)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbFace Member List

This is the complete list of members for AcDbFace, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbFace) (defined in AcDbFace) | AcDbFace |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbFace() (defined in AcDbFace) | AcDbFace |
AcDbFace(const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2, const AcGePoint3d &pt3, Adesk::Boolean e0vis=Adesk::kTrue, Adesk::Boolean e1vis=Adesk::kTrue, Adesk::Boolean e2vis=Adesk::kTrue, Adesk::Boolean e3vis=Adesk::kTrue) (defined in AcDbFace) | AcDbFace |
AcDbFace(const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2, Adesk::Boolean e0vis=Adesk::kTrue, Adesk::Boolean e1vis=Adesk::kTrue, Adesk::Boolean e2vis=Adesk::kTrue, Adesk::Boolean e3vis=Adesk::kTrue) (defined in AcDbFace) | AcDbFace |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbFace) | AcDbFace | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
getVertexAt(Adesk::UInt16, AcGePoint3d &) const (defined in AcDbFace) | AcDbFace |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEdgeVisibleAt(Adesk::UInt16, Adesk::Boolean &) const (defined in AcDbFace) | AcDbFace |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
makeEdgeInvisibleAt(Adesk::UInt16) (defined in AcDbFace) | AcDbFace |
makeEdgeVisibleAt(Adesk::UInt16) (defined in AcDbFace) | AcDbFace |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVertexAt(Adesk::UInt16, const AcGePoint3d &) (defined in AcDbFace) | AcDbFace |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbFace() (defined in AcDbFace) | AcDbFace |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbFaceRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbFaceRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbFaceRecord:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbFaceRecord)
AcDbFaceRecord (Adesk::Int16 vtx0, Adesk::Int16 vtx1, Adesk::Int16 vtx2, Adesk::Int16 vtx3)
Acad::ErrorStatus | getVertexAt (Adesk::UInt16 faceIdx, Adesk::Int16 &vtxIdx) const
Acad::ErrorStatus | isEdgeVisibleAt (Adesk::UInt16 faceIndex, Adesk::Boolean &visible) const
Acad::ErrorStatus | makeEdgeInvisibleAt (Adesk::UInt16 faceIndex)
Acad::ErrorStatus | makeEdgeVisibleAt (Adesk::UInt16 faceIndex)
Acad::ErrorStatus | setVertexAt (Adesk::UInt16 faceIdx, Adesk::Int16 vtxIdx)
- Public Member Functions inherited from AcDbVertex
ACDB_DECLARE_MEMBERS (AcDbVertex)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbFaceRecord Member List

This is the complete list of members for AcDbFaceRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbFaceRecord) (defined in AcDbFaceRecord) | AcDbFaceRecord |
ACDB_DECLARE_MEMBERS(AcDbVertex) (defined in AcDbVertex) | AcDbVertex |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbFaceRecord() (defined in AcDbFaceRecord) | AcDbFaceRecord |
AcDbFaceRecord(Adesk::Int16 vtx0, Adesk::Int16 vtx1, Adesk::Int16 vtx2, Adesk::Int16 vtx3) (defined in AcDbFaceRecord) | AcDbFaceRecord |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbVertex() (defined in AcDbVertex) | AcDbVertex |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
getVertexAt(Adesk::UInt16 faceIdx, Adesk::Int16 &vtxIdx) const (defined in AcDbFaceRecord) | AcDbFaceRecord |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEdgeVisibleAt(Adesk::UInt16 faceIndex, Adesk::Boolean &visible) const (defined in AcDbFaceRecord) | AcDbFaceRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
makeEdgeInvisibleAt(Adesk::UInt16 faceIndex) (defined in AcDbFaceRecord) | AcDbFaceRecord |
makeEdgeVisibleAt(Adesk::UInt16 faceIndex) (defined in AcDbFaceRecord) | AcDbFaceRecord |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVertexAt(Adesk::UInt16 faceIdx, Adesk::Int16 vtxIdx) (defined in AcDbFaceRecord) | AcDbFaceRecord |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbFaceRecord() (defined in AcDbFaceRecord) | AcDbFaceRecord |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbVertex() (defined in AcDbVertex) | AcDbVertex | inline
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbFcf Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbFcf Class Reference
AcDb Classes
+ Inheritance diagram for AcDbFcf:

Public Types

enum | whichLine { kAll = -1 }
- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbFcf)
AcDbFcf (const ACHAR *, const AcGePoint3d &, const AcGeVector3d &, const AcGeVector3d &)
virtual bool | castShadows () const
AcCmColor | dimclrd () const
AcCmColor | dimclrt () const
virtual AcDbHardPointerId | dimensionStyle () const
double | dimgap () const
double | dimscale () const
AcDbObjectId | dimtxsty () const
double | dimtxt () const
virtual AcGeVector3d | direction () const
virtual void | getBoundingPline (AcGePoint3dArray &) const
virtual void | getBoundingPoints (AcGePoint3dArray &) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &, AcDbIntArray &, AcDbIntArray &) const
virtual void | list () const
virtual AcGePoint3d | location () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &, const AcGeVector3d &)
virtual AcGeVector3d | normal () const
virtual bool | receiveShadows () const
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimclrd (AcCmColor &val)
Acad::ErrorStatus | setDimclrt (AcCmColor &val)
virtual void | setDimensionStyle (AcDbHardPointerId)
Acad::ErrorStatus | setDimgap (double val)
Acad::ErrorStatus | setDimscale (double val)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimtxsty (AcDbObjectId val)
Acad::ErrorStatus | setDimtxt (double val)
virtual void | setDimVars ()
virtual void | setLocation (const AcGePoint3d &)
virtual void | setOrientation (const AcGeVector3d &norm, const AcGeVector3d &dir)
virtual void | setReceiveShadows (bool newVal)
virtual void | setText (const ACHAR *)
virtual ACHAR * | text (const int lineNo=kAll) const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbfcf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbFcf Member List

This is the complete list of members for AcDbFcf, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbFcf) (defined in AcDbFcf) | AcDbFcf |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbFcf() (defined in AcDbFcf) | AcDbFcf |
AcDbFcf(const ACHAR *, const AcGePoint3d &, const AcGeVector3d &, const AcGeVector3d &) (defined in AcDbFcf) | AcDbFcf |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbFcf) | AcDbFcf | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimclrd() const (defined in AcDbFcf) | AcDbFcf |
dimclrt() const (defined in AcDbFcf) | AcDbFcf |
dimensionStyle() const (defined in AcDbFcf) | AcDbFcf | virtual
dimgap() const (defined in AcDbFcf) | AcDbFcf |
dimscale() const (defined in AcDbFcf) | AcDbFcf |
dimtxsty() const (defined in AcDbFcf) | AcDbFcf |
dimtxt() const (defined in AcDbFcf) | AcDbFcf |
direction() const (defined in AcDbFcf) | AcDbFcf | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBoundingPline(AcGePoint3dArray &) const (defined in AcDbFcf) | AcDbFcf | virtual
getBoundingPoints(AcGePoint3dArray &) const (defined in AcDbFcf) | AcDbFcf | virtual
getClassID(CLSID *pClsid) const (defined in AcDbFcf) | AcDbFcf | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbFcf) | AcDbFcf |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &, AcDbIntArray &, AcDbIntArray &) const (defined in AcDbFcf) | AcDbFcf | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAll enum value (defined in AcDbFcf) | AcDbFcf |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbFcf) | AcDbFcf | virtual
location() const (defined in AcDbFcf) | AcDbFcf | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &, const AcGeVector3d &) (defined in AcDbFcf) | AcDbFcf | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbFcf) | AcDbFcf | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbFcf) | AcDbFcf | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbFcf) | AcDbFcf | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimclrd(AcCmColor &val) (defined in AcDbFcf) | AcDbFcf |
setDimclrt(AcCmColor &val) (defined in AcDbFcf) | AcDbFcf |
setDimensionStyle(AcDbHardPointerId) (defined in AcDbFcf) | AcDbFcf | virtual
setDimgap(double val) (defined in AcDbFcf) | AcDbFcf |
setDimscale(double val) (defined in AcDbFcf) | AcDbFcf |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbFcf) | AcDbFcf |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbFcf) | AcDbFcf |
setDimtxsty(AcDbObjectId val) (defined in AcDbFcf) | AcDbFcf |
setDimtxt(double val) (defined in AcDbFcf) | AcDbFcf |
setDimVars() (defined in AcDbFcf) | AcDbFcf | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLocation(const AcGePoint3d &) (defined in AcDbFcf) | AcDbFcf | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOrientation(const AcGeVector3d &norm, const AcGeVector3d &dir) (defined in AcDbFcf) | AcDbFcf | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbFcf) | AcDbFcf | virtual
setText(const ACHAR *) (defined in AcDbFcf) | AcDbFcf | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
text(const int lineNo=kAll) const (defined in AcDbFcf) | AcDbFcf | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
whichLine enum name (defined in AcDbFcf) | AcDbFcf |
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbFcf() (defined in AcDbFcf) | AcDbFcf | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbField Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbField Class Reference
AcDb Classes
+ Inheritance diagram for AcDbField:

Public Types

enum EvalContext {
kOpen = (0x1 << 0), kSave = (0x1 << 1), kPlot = (0x1 << 2), kEtransmit = (0x1 << 3),
kRegen = (0x1 << 4), kDemand = (0x1 << 5), kPreview = (0x1 << 6), kPlotPreview = (0x1 << 7)
}
enum EvalOption {
kDisable = 0, kOnOpen = (0x1 << 0), kOnSave = (0x1 << 1), kOnPlot = (0x1 << 2),
kOnEtransmit = (0x1 << 3), kOnRegen = (0x1 << 4), kOnDemand = (0x1 << 5), kAutomatic
}
enum EvalStatus {
kNotYetEvaluated = (0x1 << 0), kSuccess = (0x1 << 1), kEvaluatorNotFound = (0x1 << 2), kSyntaxError = (0x1 << 3),
kInvalidCode = (0x1 << 4), kInvalidContext = (0x1 << 5), kOtherError = (0x1 << 6)
}
enum FieldCodeFlag {
kFieldCode = (0x1 << 0), kEvaluatedText = (0x1 << 1), kEvaluatedChildren = (0x1 << 2), kObjectReference = (0x1 << 3),
kAddMarkers = (0x1 << 4), kEscapeBackslash = (0x1 << 5), kStripOptions = (0x1 << 6), kPreserveFields = (0x1 << 7),
kTextField = (0x1 << 8), kPreserveOptions = (0x1 << 9), kDetachChildren = (0x1 << 10), kChildObjectReference = (0x1 << 11),
kForExpression = (0x1 << 12)
}
enum FilingOption { kSkipFilingResult = (0x1 << 0) }
enum State {
kInitialized = (0x1 << 0), kCompiled = (0x1 << 1), kModified = (0x1 << 2), kEvaluated = (0x1 << 3),
kHasCache = (0x1 << 4), kHasFormattedString = (0x1 << 5)
}

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbField)
ACDB_PORT | AcDbField (const ACHAR *pszFieldCode, bool bTextField=false)
ACDB_PORT int | childCount (void) const
Acad::ErrorStatus | convertToTextField (void)
ACDB_PORT AcValue::DataType | dataType (void) const
virtual ACDB_PORT Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
ACDB_PORT Acad::ErrorStatus | evaluate (int nContext, AcDbDatabase *pDb, int *pNumFound=NULL, int *pNumEvaluated=NULL)
ACDB_PORT AcDbField::EvalOption | evaluationOption (void) const
ACDB_PORT AcDbField::EvalStatus | evaluationStatus (int *pnErrCode=NULL, ACHAR **pszErrMsg=NULL) const
ACDB_PORT const ACHAR * | evaluatorId (void) const
ACDB_PORT AcDbField::FilingOption | filingOption (void) const
ACDB_PORT Acad::ErrorStatus | getChild (int iIndex, AcDbField *&pField, AcDb::OpenMode mode)
ACDB_PORT Acad::ErrorStatus | getData (const ACHAR *pszKey, AcValue *pData) const
ACDB_PORT const ACHAR * | getFieldCode (AcDbField::FieldCodeFlag nFlag, AcArray< AcDbField * > *pChildFields=NULL, AcDb::OpenMode mode=AcDb::kForRead) const
ACDB_PORT Acad::ErrorStatus | getFieldCode (ACHAR *&pszFieldCode, AcDbField::FieldCodeFlag nFlag, AcArray< AcDbField * > *pChildFields=NULL, AcDb::OpenMode mode=AcDb::kForRead) const
ACDB_PORT const ACHAR * | getFormat (void) const
ACDB_PORT Acad::ErrorStatus | getFormat (ACHAR *&pszFormat) const
ACDB_PORT Acad::ErrorStatus | getHyperlink (AcHyperlink &hlink) const
ACDB_PORT Acad::ErrorStatus | getHyperlink (ACHAR **pszName, ACHAR **pszDescription, ACHAR **pszSubLocation, ACHAR **pszDisplayString, long *pFlag) const
ACDB_PORT const ACHAR * | getValue (void) const
ACDB_PORT Acad::ErrorStatus | getValue (ACHAR *&pszValue) const
ACDB_PORT Acad::ErrorStatus | getValue (AcValue &value) const
ACDB_PORT Acad::ErrorStatus | getValue (AcFdFieldValue &value) const
ACDB_PORT bool | hasHyperlink (void) const
bool | isTextField (void) const
ACDB_PORT Acad::ErrorStatus | postInDatabase (AcDbDatabase *pDb)
ACDB_PORT Acad::ErrorStatus | removeHyperlink (void)
ACDB_PORT Acad::ErrorStatus | setData (const ACHAR *pszKey, const AcValue *pData)
ACDB_PORT Acad::ErrorStatus | setData (const ACHAR *pszKey, const AcValue *pData, bool bRecursive)
ACDB_PORT Acad::ErrorStatus | setEvaluationOption (AcDbField::EvalOption nEvalOption)
ACDB_PORT Acad::ErrorStatus | setEvaluatorId (const ACHAR *pszEvaluatorId)
ACDB_PORT Acad::ErrorStatus | setFieldCode (const ACHAR *pszFieldCode, AcDbField::FieldCodeFlag nFlag=(AcDbField::FieldCodeFlag) 0, AcDbFieldArray *pChildFields=NULL)
ACDB_PORT Acad::ErrorStatus | setFilingOption (AcDbField::FilingOption nOption)
ACDB_PORT Acad::ErrorStatus | setFormat (const ACHAR *pszFormat)
ACDB_PORT Acad::ErrorStatus | setHyperlink (const AcHyperlink &hlink)
ACDB_PORT Acad::ErrorStatus | setHyperlink (const ACHAR *pszName, const ACHAR *pszDescription, const ACHAR *pszSubLocation=NULL)
ACDB_PORT Acad::ErrorStatus | setHyperlink (const ACHAR *pszName, const ACHAR *pszDescription, const ACHAR *pszSubLocation, long lFlag)
ACDB_PORT Acad::ErrorStatus | setInObject (AcDbObject *pObj, const ACHAR *pszPropName)
ACDB_PORT AcDbField::State | state (void) const
virtual ACDB_PORT Acad::ErrorStatus | subClose ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

Acad::ErrorStatus AcDbField::convertToTextField ( void )
Warning
Not implemented!
bool AcDbField::isTextField ( void ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • DbField.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbField Member List

This is the complete list of members for AcDbField, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbField) (defined in AcDbField) | AcDbField |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbField(void) (defined in AcDbField) | AcDbField |
AcDbField(const ACHAR *pszFieldCode, bool bTextField=false) (defined in AcDbField) | AcDbField |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
childCount(void) const (defined in AcDbField) | AcDbField |
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToTextField(void) | AcDbField |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
dataType(void) const (defined in AcDbField) | AcDbField |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbField) | AcDbField | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbField) | AcDbField | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbField) | AcDbField | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbField) | AcDbField | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
EvalContext enum name (defined in AcDbField) | AcDbField |
EvalOption enum name (defined in AcDbField) | AcDbField |
EvalStatus enum name (defined in AcDbField) | AcDbField |
evaluate(int nContext, AcDbDatabase *pDb, int *pNumFound=NULL, int *pNumEvaluated=NULL) (defined in AcDbField) | AcDbField |
evaluationOption(void) const (defined in AcDbField) | AcDbField |
evaluationStatus(int *pnErrCode=NULL, ACHAR **pszErrMsg=NULL) const (defined in AcDbField) | AcDbField |
evaluatorId(void) const (defined in AcDbField) | AcDbField |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
FieldCodeFlag enum name (defined in AcDbField) | AcDbField |
FilingOption enum name (defined in AcDbField) | AcDbField |
filingOption(void) const (defined in AcDbField) | AcDbField |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getChild(int iIndex, AcDbField *&pField, AcDb::OpenMode mode) (defined in AcDbField) | AcDbField |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getData(const ACHAR *pszKey, AcValue *pData) const (defined in AcDbField) | AcDbField |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldCode(AcDbField::FieldCodeFlag nFlag, AcArray< AcDbField * > *pChildFields=NULL, AcDb::OpenMode mode=AcDb::kForRead) const (defined in AcDbField) | AcDbField |
getFieldCode(ACHAR *&pszFieldCode, AcDbField::FieldCodeFlag nFlag, AcArray< AcDbField * > *pChildFields=NULL, AcDb::OpenMode mode=AcDb::kForRead) const (defined in AcDbField) | AcDbField |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFormat(void) const (defined in AcDbField) | AcDbField |
getFormat(ACHAR *&pszFormat) const (defined in AcDbField) | AcDbField |
getHyperlink(AcHyperlink &hlink) const (defined in AcDbField) | AcDbField |
getHyperlink(ACHAR **pszName, ACHAR **pszDescription, ACHAR **pszSubLocation, ACHAR **pszDisplayString, long *pFlag) const (defined in AcDbField) | AcDbField |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getValue(void) const (defined in AcDbField) | AcDbField |
getValue(ACHAR *&pszValue) const (defined in AcDbField) | AcDbField |
getValue(AcValue &value) const (defined in AcDbField) | AcDbField |
getValue(AcFdFieldValue &value) const (defined in AcDbField) | AcDbField |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasHyperlink(void) const (defined in AcDbField) | AcDbField |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTextField(void) const | AcDbField |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAddMarkers enum value (defined in AcDbField) | AcDbField |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kAutomatic enum value (defined in AcDbField) | AcDbField |
kChildObjectReference enum value (defined in AcDbField) | AcDbField |
kCompiled enum value (defined in AcDbField) | AcDbField |
kDemand enum value (defined in AcDbField) | AcDbField |
kDetachChildren enum value (defined in AcDbField) | AcDbField |
kDisable enum value (defined in AcDbField) | AcDbField |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEscapeBackslash enum value (defined in AcDbField) | AcDbField |
kEtransmit enum value (defined in AcDbField) | AcDbField |
kEvaluated enum value (defined in AcDbField) | AcDbField |
kEvaluatedChildren enum value (defined in AcDbField) | AcDbField |
kEvaluatedText enum value (defined in AcDbField) | AcDbField |
kEvaluatorNotFound enum value (defined in AcDbField) | AcDbField |
kFieldCode enum value (defined in AcDbField) | AcDbField |
kForExpression enum value (defined in AcDbField) | AcDbField |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHasCache enum value (defined in AcDbField) | AcDbField |
kHasFormattedString enum value (defined in AcDbField) | AcDbField |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kInitialized enum value (defined in AcDbField) | AcDbField |
kInvalidCode enum value (defined in AcDbField) | AcDbField |
kInvalidContext enum value (defined in AcDbField) | AcDbField |
kModified enum value (defined in AcDbField) | AcDbField |
kNotYetEvaluated enum value (defined in AcDbField) | AcDbField |
kObjectReference enum value (defined in AcDbField) | AcDbField |
kOnDemand enum value (defined in AcDbField) | AcDbField |
kOnEtransmit enum value (defined in AcDbField) | AcDbField |
kOnOpen enum value (defined in AcDbField) | AcDbField |
kOnPlot enum value (defined in AcDbField) | AcDbField |
kOnRegen enum value (defined in AcDbField) | AcDbField |
kOnSave enum value (defined in AcDbField) | AcDbField |
kOpen enum value (defined in AcDbField) | AcDbField |
kOtherError enum value (defined in AcDbField) | AcDbField |
kPlot enum value (defined in AcDbField) | AcDbField |
kPlotPreview enum value (defined in AcDbField) | AcDbField |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kPreserveFields enum value (defined in AcDbField) | AcDbField |
kPreserveOptions enum value (defined in AcDbField) | AcDbField |
kPreview enum value (defined in AcDbField) | AcDbField |
kRegen enum value (defined in AcDbField) | AcDbField |
kSave enum value (defined in AcDbField) | AcDbField |
kSkipFilingResult enum value (defined in AcDbField) | AcDbField |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kStripOptions enum value (defined in AcDbField) | AcDbField |
kSuccess enum value (defined in AcDbField) | AcDbField |
kSyntaxError enum value (defined in AcDbField) | AcDbField |
kTextField enum value (defined in AcDbField) | AcDbField |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
postInDatabase(AcDbDatabase *pDb) (defined in AcDbField) | AcDbField |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeHyperlink(void) (defined in AcDbField) | AcDbField |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setData(const ACHAR *pszKey, const AcValue *pData) (defined in AcDbField) | AcDbField |
setData(const ACHAR *pszKey, const AcValue *pData, bool bRecursive) (defined in AcDbField) | AcDbField |
setEvaluationOption(AcDbField::EvalOption nEvalOption) (defined in AcDbField) | AcDbField |
setEvaluatorId(const ACHAR *pszEvaluatorId) (defined in AcDbField) | AcDbField |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFieldCode(const ACHAR *pszFieldCode, AcDbField::FieldCodeFlag nFlag=(AcDbField::FieldCodeFlag) 0, AcDbFieldArray *pChildFields=NULL) (defined in AcDbField) | AcDbField |
setFilingOption(AcDbField::FilingOption nOption) (defined in AcDbField) | AcDbField |
setFormat(const ACHAR *pszFormat) (defined in AcDbField) | AcDbField |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHyperlink(const AcHyperlink &hlink) (defined in AcDbField) | AcDbField |
setHyperlink(const ACHAR *pszName, const ACHAR *pszDescription, const ACHAR *pszSubLocation=NULL) (defined in AcDbField) | AcDbField |
setHyperlink(const ACHAR *pszName, const ACHAR *pszDescription, const ACHAR *pszSubLocation, long lFlag) (defined in AcDbField) | AcDbField |
setInObject(AcDbObject *pObj, const ACHAR *pszPropName) (defined in AcDbField) | AcDbField |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
State enum name (defined in AcDbField) | AcDbField |
state(void) const (defined in AcDbField) | AcDbField |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbField) | AcDbField | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbField(void) (defined in AcDbField) | AcDbField |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbFilter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbFilter Class Reference
AcDb Classes
+ Inheritance diagram for AcDbFilter:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbFilter)
virtual AcRxClass * | indexClass () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbfilter.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbFilter Member List

This is the complete list of members for AcDbFilter, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbFilter) (defined in AcDbFilter) | AcDbFilter |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbFilter() (defined in AcDbFilter) | AcDbFilter |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
indexClass() const (defined in AcDbFilter) | AcDbFilter | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbFilter() (defined in AcDbFilter) | AcDbFilter | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbFilteredBlockIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbFilteredBlockIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbFilteredBlockIterator:

Public Member Functions

virtual Acad::ErrorStatus | accepts (AcDbObjectId id, Adesk::Boolean &idPassesFilter) const =0
virtual Acad::ErrorStatus | addToBuffer (AcDbObjectId id)
virtual Adesk::Boolean | buffersForComposition () const
virtual double | estimatedHitFraction () const =0
virtual AcDbObjectId | id () const =0
virtual AcDbObjectId | next ()=0
virtual Acad::ErrorStatus | seek (AcDbObjectId id)=0
virtual Acad::ErrorStatus | start ()=0
The documentation for this class was generated from the following file:
  • dbindex.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbFilteredBlockIterator Member List

This is the complete list of members for AcDbFilteredBlockIterator, including all inherited members.

accepts(AcDbObjectId id, Adesk::Boolean &idPassesFilter) const =0 (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | pure virtual
AcDbFilteredBlockIterator() (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | inline
addToBuffer(AcDbObjectId id) (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | virtual
buffersForComposition() const (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | virtual
estimatedHitFraction() const =0 (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | pure virtual
id() const =0 (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | pure virtual
next()=0 (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | pure virtual
seek(AcDbObjectId id)=0 (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | pure virtual
start()=0 (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | pure virtual
~AcDbFilteredBlockIterator() (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | inlinevirtual


ZRX API Reference: AcDbFormattedTableData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbFormattedTableData Class Reference
AcDb Classes
+ Inheritance diagram for AcDbFormattedTableData:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbFormattedTableData)
virtual ACDB_PORT
AcDb::CellAlignment 		alignment (int nRow, int nCol) const
virtual ACDB_PORT AcCmColor | backgroundColor (int nRow, int nCol) const
virtual ACDB_PORT AcCmColor | contentColor (int nRow, int nCol) const
virtual ACDB_PORT AcCmColor | contentColor (int nRow, int nCol, int nContent) const
virtual ACDB_PORT
AcDb::CellContentLayout 		contentLayout (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | enableMergeAll (int nRow, int nCol, bool bEnable)
virtual ACDB_PORT
AcDb::FlowDirection 		flowDirection (void) const
virtual ACDB_PORT Acad::ErrorStatus | getGridProperty (int nRow, int nCol, AcDb::GridLineType nGridLineType, AcGridProperty &gridProp) const
virtual ACDB_PORT AcCellRange | getMergeRange (int nRow, int nCol) const
virtual ACDB_PORT
AcDb::CellProperty 		getOverride (int nRow, int nCol, int nContent) const
virtual ACDB_PORT
AcDb::GridProperty 		getOverride (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcCmColor | gridColor (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT double | gridDoubleLineSpacing (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT
AcDb::GridLineStyle 		gridLineStyle (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcDbObjectId | gridLinetype (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcDb::LineWeight | gridLineWeight (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcDb::Visibility | gridVisibility (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT int | insertColumnAndInherit (int nIndex, int nInheritFrom, int nNumCols)
virtual ACDB_PORT int | insertRowAndInherit (int nIndex, int nInheritFrom, int nNumRows)
virtual ACDB_PORT bool | isAutoScale (int nRow, int nCol) const
virtual ACDB_PORT bool | isAutoScale (int nRow, int nCol, int nContent) const
virtual ACDB_PORT bool | isFormatEditable (int nRow, int nCol) const
virtual ACDB_PORT bool | isMergeAllEnabled (int nRow, int nCol) const
virtual ACDB_PORT bool | isMerged (int nRow, int nCol) const
virtual ACDB_PORT double | margin (int nRow, int nCol, AcDb::CellMargin nMargin) const
virtual ACDB_PORT Acad::ErrorStatus | merge (const AcCellRange &range)
virtual ACDB_PORT Acad::ErrorStatus | removeAllOverrides (int nRow, int nCol)
virtual ACDB_PORT double | rotation (int nRow, int nCol) const
virtual ACDB_PORT double | rotation (int nRow, int nCol, int nIndex) const
virtual ACDB_PORT double | scale (int nRow, int nCol) const
virtual ACDB_PORT double | scale (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | setAlignment (int nRow, int nCol, AcDb::CellAlignment nAlignment)
virtual ACDB_PORT Acad::ErrorStatus | setAutoScale (int nRow, int nCol, bool bAutoScale)
virtual ACDB_PORT Acad::ErrorStatus | setAutoScale (int nRow, int nCol, int nContent, bool bAutoScale)
virtual ACDB_PORT Acad::ErrorStatus | setBackgroundColor (int nRow, int nCol, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setContentColor (int nRow, int nCol, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setContentColor (int nRow, int nCol, int nContent, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setContentLayout (int nRow, int nCol, AcDb::CellContentLayout nLayout)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, const AcDbObjectId &idField, AcDb::CellOption nFlag)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, int nIndex, const AcDbObjectId &idField, AcDb::CellOption nFlag)
virtual ACDB_PORT Acad::ErrorStatus | setFlowDirection (AcDb::FlowDirection nDir)
virtual ACDB_PORT Acad::ErrorStatus | setGridColor (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setGridDoubleLineSpacing (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, double fSpacing)
virtual ACDB_PORT Acad::ErrorStatus | setGridLineStyle (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::GridLineStyle nLineStyle)
virtual ACDB_PORT Acad::ErrorStatus | setGridLinetype (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcDbObjectId &idLinetype)
virtual ACDB_PORT Acad::ErrorStatus | setGridLineWeight (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::LineWeight nLineWeight)
virtual ACDB_PORT Acad::ErrorStatus | setGridProperty (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp)
virtual ACDB_PORT Acad::ErrorStatus | setGridProperty (const AcCellRange &range, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp)
virtual ACDB_PORT Acad::ErrorStatus | setGridVisibility (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::Visibility nVisibility)
virtual ACDB_PORT Acad::ErrorStatus | setMargin (int nRow, int nCol, AcDb::CellMargin nMargins, double fMargin)
virtual ACDB_PORT Acad::ErrorStatus | setOverride (int nRow, int nCol, int nContent, AcDb::CellProperty nOverride)
virtual ACDB_PORT Acad::ErrorStatus | setOverride (int nRow, int nCol, AcDb::GridLineType nGridLineType, AcDb::GridProperty nOverride)
virtual ACDB_PORT Acad::ErrorStatus | setRotation (int nRow, int nCol, double fRotation)
virtual ACDB_PORT Acad::ErrorStatus | setRotation (int nRow, int nCol, int nContent, double fRotation)
virtual ACDB_PORT Acad::ErrorStatus | setScale (int nRow, int nCol, double fScale)
virtual ACDB_PORT Acad::ErrorStatus | setScale (int nRow, int nCol, int nIndex, double fScale)
virtual ACDB_PORT Acad::ErrorStatus | setTextHeight (int nRow, int nCol, double fTextHeight)
virtual ACDB_PORT Acad::ErrorStatus | setTextHeight (int nRow, int nCol, int nContent, double fTextHeight)
virtual ACDB_PORT Acad::ErrorStatus | setTextStyle (int nRow, int nCol, const AcDbObjectId &idTextStyle)
virtual ACDB_PORT Acad::ErrorStatus | setTextStyle (int nRow, int nCol, int nContent, const AcDbObjectId &idTextStyle)
virtual ACDB_PORT double | textHeight (int nRow, int nCol) const
virtual ACDB_PORT double | textHeight (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcDbObjectId | textStyle (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | textStyle (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | unmerge (const AcCellRange &range)
- Public Member Functions inherited from AcDbLinkedTableData
ACDB_DECLARE_MEMBERS (AcDbLinkedTableData)
virtual ACDB_PORT int | appendColumn (int nNumCols)
virtual ACDB_PORT int | appendRow (int nNumRows)
virtual ACDB_PORT bool | canDelete (int nIndex, int nCount, bool bRow) const
virtual ACDB_PORT bool | canInsert (int nIndex, bool bRow) const
virtual ACDB_PORT AcDb::CellState | cellState (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | clear (void)
virtual ACDB_PORT
AcDb::CellContentType 		contentType (int nRow, int nCol) const
virtual ACDB_PORT
AcDb::CellContentType 		contentType (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRange)
virtual ACDB_PORT int | createContent (int nRow, int nCol, int nIndex)
virtual ACDB_PORT AcString | dataFormat (int nRow, int nCol) const
virtual ACDB_PORT AcString | dataFormat (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | deleteColumn (int nIndex, int nNumColsToDelete)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (int nRow, int nCol, int nContent)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (int nRow, int nCol)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (const AcCellRange &range)
virtual ACDB_PORT Acad::ErrorStatus | deleteRow (int nIndex, int nNumRowsToDelete)
virtual ACDB_PORT Acad::ErrorStatus | evaluateFormula (void)
virtual ACDB_PORT AcString | getBlockAttributeValue (int nRow, int nCol, const AcDbObjectId &idAttDef) const
virtual ACDB_PORT AcString | getBlockAttributeValue (int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef) const
virtual ACDB_PORT AcDbObjectId | getBlockTableRecordId (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | getBlockTableRecordId (int nRow, int nCol, int nContent) const
virtual ACDB_PORT const ACHAR * | getColumnName (int nIndex) const
virtual ACDB_PORT int | getCustomData (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getCustomData (int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const
virtual ACDB_PORT AcDbObjectId | getDataLink (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getDataLink (int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const
virtual ACDB_PORT int | getDataLink (const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const
virtual ACDB_PORT AcCellRange | getDataLinkRange (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getDataType (int nRow, int nCol, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
virtual ACDB_PORT Acad::ErrorStatus | getDataType (int nRow, int nCol, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
virtual ACDB_PORT Acad::ErrorStatus | getField (int nRow, int nCol, int nContent, AcDbField *&pField, AcDb::OpenMode mode) const
virtual ACDB_PORT AcDbObjectId | getFieldId (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | getFieldId (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcString | getFormula (int nRow, int nCol, int nContent) const
ACDB_PORT AcDbTableIterator * | getIterator (void) const
ACDB_PORT AcDbTableIterator * | getIterator (const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol, int nContent, AcValue::FormatOption nOption) const
virtual ACDB_PORT AcString | getToolTip (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getValue (int nRow, int nCol, AcValue &value) const
virtual ACDB_PORT Acad::ErrorStatus | getValue (int nRow, int nCol, int nContent, AcValue::FormatOption nOption, AcValue &value) const
virtual ACDB_PORT bool | hasFormula (int nRow, int nCol, int nContent) const
virtual ACDB_PORT int | insertColumn (int nIndex, int nNumCols)
virtual ACDB_PORT int | insertRow (int nIndex, int nNumRows)
virtual ACDB_PORT bool | isContentEditable (int nRow, int nCol) const
virtual ACDB_PORT bool | isLinked (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | moveContent (int nRow, int nCol, int nFromIndex, int nToIndex)
virtual ACDB_PORT int | numColumns (void) const
virtual ACDB_PORT int | numContents (int nRow, int nCol) const
virtual ACDB_PORT int | numRows (void) const
virtual ACDB_PORT Acad::ErrorStatus | removeDataLink (int nRow, int nCol)
virtual ACDB_PORT Acad::ErrorStatus | removeDataLink (void)
virtual ACDB_PORT Acad::ErrorStatus | setBlockAttributeValue (int nRow, int nCol, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue)
virtual ACDB_PORT Acad::ErrorStatus | setBlockAttributeValue (int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue)
virtual ACDB_PORT Acad::ErrorStatus | setBlockTableRecordId (int nRow, int nCol, const AcDbObjectId &idBTR)
virtual ACDB_PORT Acad::ErrorStatus | setBlockTableRecordId (int nRow, int nCol, int nContent, const AcDbObjectId &idBTR)
virtual ACDB_PORT Acad::ErrorStatus | setCellState (int nRow, int nCol, AcDb::CellState nCellState)
virtual ACDB_PORT Acad::ErrorStatus | setColumnName (int nIndex, const ACHAR *pszName)
virtual ACDB_PORT Acad::ErrorStatus | setCustomData (int nRow, int nCol, int nData)
virtual ACDB_PORT Acad::ErrorStatus | setCustomData (int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData)
virtual ACDB_PORT Acad::ErrorStatus | setDataFormat (int nRow, int nCol, const ACHAR *pszFormat)
virtual ACDB_PORT Acad::ErrorStatus | setDataFormat (int nRow, int nCol, int nContent, const ACHAR *pszFormat)
virtual ACDB_PORT Acad::ErrorStatus | setDataLink (int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate)
virtual ACDB_PORT Acad::ErrorStatus | setDataLink (const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate)
virtual ACDB_PORT Acad::ErrorStatus | setDataType (int nRow, int nCol, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ACDB_PORT Acad::ErrorStatus | setDataType (int nRow, int nCol, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, const AcDbObjectId &idField)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, int nContent, const AcDbObjectId &idField)
virtual ACDB_PORT Acad::ErrorStatus | setFormula (int nRow, int nCol, int nContent, const ACHAR *pszFormula)
virtual ACDB_PORT Acad::ErrorStatus | setSize (int nRows, int nCols)
virtual ACDB_PORT Acad::ErrorStatus | setText (int nRow, int nCol, const ACHAR *pszText)
virtual ACDB_PORT Acad::ErrorStatus | setText (int nRow, int nCol, int nContent, const ACHAR *pszText)
virtual ACDB_PORT Acad::ErrorStatus | setToolTip (int nRow, int nCol, const ACHAR *pszToolTip)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, const AcValue &value)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, int nContent, const AcValue &value)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, int nContent, const AcValue &value, AcValue::ParseOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | updateDataLink (int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | updateDataLink (AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
- Public Member Functions inherited from AcDbLinkedData
ACDB_DECLARE_MEMBERS (AcDbLinkedData)
virtual ACDB_PORT const ACHAR * | description (void) const
virtual ACDB_PORT bool | isEmpty (void) const
virtual ACDB_PORT const ACHAR * | name (void) const
virtual ACDB_PORT Acad::ErrorStatus | setDescription (const ACHAR *pszDescription)
virtual ACDB_PORT Acad::ErrorStatus | setName (const ACHAR *pszName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • DbFormattedTableData.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbFormattedTableData Member List

This is the complete list of members for AcDbFormattedTableData, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbFormattedTableData) (defined in AcDbFormattedTableData) | AcDbFormattedTableData |
ACDB_DECLARE_MEMBERS(AcDbLinkedTableData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
ACDB_DECLARE_MEMBERS(AcDbLinkedData) (defined in AcDbLinkedData) | AcDbLinkedData |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbFormattedTableData(void) (defined in AcDbFormattedTableData) | AcDbFormattedTableData |
AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData |
AcDbLinkedTableData(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
alignment(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
appendColumn(int nNumCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
appendRow(int nNumRows) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
backgroundColor(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
canDelete(int nIndex, int nCount, bool bRow) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
canInsert(int nIndex, bool bRow) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
cellState(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
clear(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contentColor(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
contentColor(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
contentLayout(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
contentType(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
contentType(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRange) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createContent(int nRow, int nCol, int nIndex) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
dataFormat(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
dataFormat(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteColumn(int nIndex, int nNumColsToDelete) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(int nRow, int nCol, int nContent) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(int nRow, int nCol) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(const AcCellRange &range) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteRow(int nIndex, int nNumRowsToDelete) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
enableMergeAll(int nRow, int nCol, bool bEnable) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
evaluateFormula(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
flowDirection(void) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBlockAttributeValue(int nRow, int nCol, const AcDbObjectId &idAttDef) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockAttributeValue(int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockTableRecordId(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockTableRecordId(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getColumnName(int nIndex) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getCustomData(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getCustomData(int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLinkRange(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataType(int nRow, int nCol, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataType(int nRow, int nCol, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getField(int nRow, int nCol, int nContent, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldId(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getFieldId(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getFormula(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getGridProperty(int nRow, int nCol, AcDb::GridLineType nGridLineType, AcGridProperty &gridProp) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getIterator(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
getIterator(const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
getMergeRange(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOverride(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getOverride(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getText(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getText(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getText(int nRow, int nCol, int nContent, AcValue::FormatOption nOption) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getToolTip(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getValue(int nRow, int nCol, AcValue &value) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getValue(int nRow, int nCol, int nContent, AcValue::FormatOption nOption, AcValue &value) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gridColor(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridDoubleLineSpacing(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridLineStyle(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridLinetype(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridLineWeight(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridVisibility(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasFormula(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
insertColumn(int nIndex, int nNumCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
insertColumnAndInherit(int nIndex, int nInheritFrom, int nNumCols) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
insertRow(int nIndex, int nNumRows) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
insertRowAndInherit(int nIndex, int nInheritFrom, int nNumRows) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isAutoScale(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isAutoScale(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isCancelling() const (defined in AcDbObject) | AcDbObject |
isContentEditable(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
isEmpty(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFormatEditable(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLinked(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
isMergeAllEnabled(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isMerged(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
margin(int nRow, int nCol, AcDb::CellMargin nMargin) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
merge(const AcCellRange &range) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveContent(int nRow, int nCol, int nFromIndex, int nToIndex) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
name(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
numColumns(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
numContents(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
numRows(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeAllOverrides(int nRow, int nCol) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
removeDataLink(int nRow, int nCol) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
removeDataLink(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
rotation(int nRow, int nCol, int nIndex) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
scale(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
scale(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAlignment(int nRow, int nCol, AcDb::CellAlignment nAlignment) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setAutoScale(int nRow, int nCol, bool bAutoScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setAutoScale(int nRow, int nCol, int nContent, bool bAutoScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setBackgroundColor(int nRow, int nCol, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockAttributeValue(int nRow, int nCol, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockAttributeValue(int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockTableRecordId(int nRow, int nCol, const AcDbObjectId &idBTR) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockTableRecordId(int nRow, int nCol, int nContent, const AcDbObjectId &idBTR) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCellState(int nRow, int nCol, AcDb::CellState nCellState) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setColumnName(int nIndex, const ACHAR *pszName) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setContentColor(int nRow, int nCol, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setContentColor(int nRow, int nCol, int nContent, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setContentLayout(int nRow, int nCol, AcDb::CellContentLayout nLayout) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setCustomData(int nRow, int nCol, int nData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCustomData(int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataFormat(int nRow, int nCol, const ACHAR *pszFormat) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataFormat(int nRow, int nCol, int nContent, const ACHAR *pszFormat) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataLink(int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataLink(const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataType(int nRow, int nCol, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataType(int nRow, int nCol, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDescription(const ACHAR *pszDescription) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFieldId(int nRow, int nCol, const AcDbObjectId &idField, AcDb::CellOption nFlag) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setFieldId(int nRow, int nCol, int nIndex, const AcDbObjectId &idField, AcDb::CellOption nFlag) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setFieldId(int nRow, int nCol, const AcDbObjectId &idField) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setFieldId(int nRow, int nCol, int nContent, const AcDbObjectId &idField) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setFlowDirection(AcDb::FlowDirection nDir) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setFormula(int nRow, int nCol, int nContent, const ACHAR *pszFormula) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setGridColor(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridDoubleLineSpacing(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, double fSpacing) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridLineStyle(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::GridLineStyle nLineStyle) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridLinetype(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcDbObjectId &idLinetype) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridLineWeight(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::LineWeight nLineWeight) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridProperty(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridProperty(const AcCellRange &range, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridVisibility(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::Visibility nVisibility) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setMargin(int nRow, int nCol, AcDb::CellMargin nMargins, double fMargin) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setName(const ACHAR *pszName) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setOverride(int nRow, int nCol, int nContent, AcDb::CellProperty nOverride) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setOverride(int nRow, int nCol, AcDb::GridLineType nGridLineType, AcDb::GridProperty nOverride) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setRotation(int nRow, int nCol, double fRotation) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setRotation(int nRow, int nCol, int nContent, double fRotation) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setScale(int nRow, int nCol, double fScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setScale(int nRow, int nCol, int nIndex, double fScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setSize(int nRows, int nCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setText(int nRow, int nCol, const ACHAR *pszText) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setText(int nRow, int nCol, int nContent, const ACHAR *pszText) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setTextHeight(int nRow, int nCol, double fTextHeight) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setTextHeight(int nRow, int nCol, int nContent, double fTextHeight) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setTextStyle(int nRow, int nCol, const AcDbObjectId &idTextStyle) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setTextStyle(int nRow, int nCol, int nContent, const AcDbObjectId &idTextStyle) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setToolTip(int nRow, int nCol, const ACHAR *pszToolTip) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, const AcValue &value) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, int nContent, const AcValue &value) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, int nContent, const AcValue &value, AcValue::ParseOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textHeight(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
textHeight(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
textStyle(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
textStyle(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unmerge(const AcCellRange &range) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
updateDataLink(int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
updateDataLink(AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbFormattedTableData(void) (defined in AcDbFormattedTableData) | AcDbFormattedTableData |
~AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
~AcDbLinkedTableData(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbFrame Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbFrame Class Reference
AcDb Classes
+ Inheritance diagram for AcDbFrame:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbFrame)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbframe.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbFrame Member List

This is the complete list of members for AcDbFrame, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbFrame) (defined in AcDbFrame) | AcDbFrame |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbFrame() (defined in AcDbFrame) | AcDbFrame | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbFrame() (defined in AcDbFrame) | AcDbFrame | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbFullSubentPath Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbFullSubentPath Class Reference
AcDb Classes

Public Member Functions

AcDbFullSubentPath (AcDb::SubentType type, Adesk::GsMarker index)
AcDbFullSubentPath (AcDbObjectId entId, AcDb::SubentType type, Adesk::GsMarker index)
AcDbFullSubentPath (AcDbObjectId entId, AcDbSubentId subId)
AcDbFullSubentPath (AcDbObjectIdArray objectIds, AcDbSubentId subId)
AcDbFullSubentPath (const AcDbFullSubentPath &)
void | objectIds (AcDbObjectIdArray &objectIds) const
AcDbObjectIdArray & | objectIds ()
const AcDbObjectIdArray & | objectIds () const
bool | operator!= (const AcDbFullSubentPath &id) const
AcDbFullSubentPath & | operator= (const AcDbFullSubentPath &)
bool | operator== (const AcDbFullSubentPath &id) const
const AcDbSubentId | subentId () const
AcDbSubentId & | subentId ()
The documentation for this class was generated from the following file:
  • dbsubeid.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbFullSubentPath Member List

This is the complete list of members for AcDbFullSubentPath, including all inherited members.

AcDbFullSubentPath() (defined in AcDbFullSubentPath) | AcDbFullSubentPath | inline
AcDbFullSubentPath(AcDb::SubentType type, Adesk::GsMarker index) (defined in AcDbFullSubentPath) | AcDbFullSubentPath | inline
AcDbFullSubentPath(AcDbObjectId entId, AcDb::SubentType type, Adesk::GsMarker index) (defined in AcDbFullSubentPath) | AcDbFullSubentPath |
AcDbFullSubentPath(AcDbObjectId entId, AcDbSubentId subId) (defined in AcDbFullSubentPath) | AcDbFullSubentPath |
AcDbFullSubentPath(AcDbObjectIdArray objectIds, AcDbSubentId subId) (defined in AcDbFullSubentPath) | AcDbFullSubentPath |
AcDbFullSubentPath(const AcDbFullSubentPath &) (defined in AcDbFullSubentPath) | AcDbFullSubentPath |
objectIds(AcDbObjectIdArray &objectIds) const (defined in AcDbFullSubentPath) | AcDbFullSubentPath | inline
objectIds() (defined in AcDbFullSubentPath) | AcDbFullSubentPath | inline
objectIds() const (defined in AcDbFullSubentPath) | AcDbFullSubentPath | inline
operator!=(const AcDbFullSubentPath &id) const (defined in AcDbFullSubentPath) | AcDbFullSubentPath |
operator=(const AcDbFullSubentPath &) (defined in AcDbFullSubentPath) | AcDbFullSubentPath |
operator==(const AcDbFullSubentPath &id) const (defined in AcDbFullSubentPath) | AcDbFullSubentPath |
subentId() const (defined in AcDbFullSubentPath) | AcDbFullSubentPath | inline
subentId() (defined in AcDbFullSubentPath) | AcDbFullSubentPath | inline
~AcDbFullSubentPath() (defined in AcDbFullSubentPath) | AcDbFullSubentPath |


ZRX API Reference: AcDbGradientBackground Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbGradientBackground Class Reference
AcDb Classes
+ Inheritance diagram for AcDbGradientBackground:

Public Member Functions

AcDbGradientBackground ()
ACRX_DECLARE_MEMBERS (AcDbGradientBackground)
AcCmEntityColor | colorBottom (void) const
AcCmEntityColor | colorMiddle (void) const
AcCmEntityColor | colorTop (void) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcGiDrawable::DrawableType | drawableType () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
double | height (void) const
double | horizon (void) const
double | rotation (void) const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
void | setColorBottom (const AcCmEntityColor &color)
void | setColorMiddle (const AcCmEntityColor &color)
void | setColorTop (const AcCmEntityColor &color)
void | setHeight (double height)
void | setHorizon (double horizon)
void | setRotation (double rotation)
virtual | ~AcDbGradientBackground ()
- Public Member Functions inherited from AcDbBackground
ACRX_DECLARE_MEMBERS (AcDbBackground)
virtual AcGiDrawable * | drawable ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpGradientBackground

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcDbBackground
AcDbBackground (AcDbImpBackground *pImp)
AcDbImpBackground * | imp () const

Constructor & Destructor Documentation

AcDbGradientBackground::AcDbGradientBackground ( )
Warning
Not implemented!
virtual AcDbGradientBackground::~AcDbGradientBackground ( )
virtual
Warning
Not implemented!

Member Function Documentation

AcCmEntityColor AcDbGradientBackground::colorBottom ( void ) const
Warning
Not implemented!
AcCmEntityColor AcDbGradientBackground::colorMiddle ( void ) const
Warning
Not implemented!
AcCmEntityColor AcDbGradientBackground::colorTop ( void ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbGradientBackground::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual AcGiDrawable::DrawableType AcDbGradientBackground::drawableType ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiDrawable.

virtual Acad::ErrorStatus AcDbGradientBackground::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbGradientBackground::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbGradientBackground::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbGradientBackground::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

double AcDbGradientBackground::height ( void ) const
Warning
Not implemented!
double AcDbGradientBackground::horizon ( void ) const
Warning
Not implemented!
double AcDbGradientBackground::rotation ( void ) const
Warning
Not implemented!
virtual Adesk::UInt32 AcDbGradientBackground::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

void AcDbGradientBackground::setColorBottom ( const AcCmEntityColor & color )
Warning
Not implemented!
void AcDbGradientBackground::setColorMiddle ( const AcCmEntityColor & color )
Warning
Not implemented!
void AcDbGradientBackground::setColorTop ( const AcCmEntityColor & color )
Warning
Not implemented!
void AcDbGradientBackground::setHeight ( double height )
Warning
Not implemented!
void AcDbGradientBackground::setHorizon ( double horizon )
Warning
Not implemented!
void AcDbGradientBackground::setRotation ( double rotation )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbbackground.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbGradientBackground Member List

This is the complete list of members for AcDbGradientBackground, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBackground(AcDbImpBackground *pImp) (defined in AcDbBackground) | AcDbBackground | protected
AcDbGradientBackground() | AcDbGradientBackground |
AcDbImpGradientBackground (defined in AcDbGradientBackground) | AcDbGradientBackground | friend
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbGradientBackground) (defined in AcDbGradientBackground) | AcDbGradientBackground |
ACRX_DECLARE_MEMBERS(AcDbBackground) (defined in AcDbBackground) | AcDbBackground |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
colorBottom(void) const | AcDbGradientBackground |
colorMiddle(void) const | AcDbGradientBackground |
colorTop(void) const | AcDbGradientBackground |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) | AcDbGradientBackground | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbBackground) | AcDbBackground | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const | AcDbGradientBackground | virtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbGradientBackground | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbGradientBackground | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbGradientBackground | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbGradientBackground | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height(void) const | AcDbGradientBackground |
horizon(void) const | AcDbGradientBackground |
id() const (defined in AcDbObject) | AcDbObject | virtual
imp() const (defined in AcDbBackground) | AcDbBackground | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation(void) const | AcDbGradientBackground |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbGradientBackground | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setColorBottom(const AcCmEntityColor &color) | AcDbGradientBackground |
setColorMiddle(const AcCmEntityColor &color) | AcDbGradientBackground |
setColorTop(const AcCmEntityColor &color) | AcDbGradientBackground |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double height) | AcDbGradientBackground |
setHorizon(double horizon) | AcDbGradientBackground |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setRotation(double rotation) | AcDbGradientBackground |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBackground() (defined in AcDbBackground) | AcDbBackground | virtual
~AcDbGradientBackground() | AcDbGradientBackground | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbGraph Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcDbGraph Class Reference
AcDb Classes
+ Inheritance diagram for AcDbGraph:

Public Member Functions

AcDbGraph (AcDbGraphNode *pRoot=NULL)
Acad::ErrorStatus | addEdge (AcDbGraphNode *pFrom, AcDbGraphNode *pTo)
Acad::ErrorStatus | addNode (AcDbGraphNode *)
Acad::ErrorStatus | breakCycleEdge (AcDbGraphNode *pFrom, AcDbGraphNode *pTo)
void | clearAll (Adesk::UInt8 flags)
Acad::ErrorStatus | delNode (AcDbGraphNode *)
virtual Adesk::Boolean | findCycles (AcDbGraphNode *pStart=NULL)
void | getOutgoing (AcDbVoidPtrArray &)
bool | isEmpty () const
AcDbGraphNode * | node (int index) const
int | numNodes () const
void | reset ()
AcDbGraphNode * | rootNode () const
void | setNodeGrowthRate (int rate)

Protected Member Functions

Acad::ErrorStatus clearAllCycles ()

Additional Inherited Members

- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • graph.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbGraph Member List

This is the complete list of members for AcDbGraph, including all inherited members.

AcDbGraph(AcDbGraphNode *pRoot=NULL) (defined in AcDbGraph) | AcDbGraph |
addEdge(AcDbGraphNode *pFrom, AcDbGraphNode *pTo) (defined in AcDbGraph) | AcDbGraph |
addNode(AcDbGraphNode *) (defined in AcDbGraph) | AcDbGraph |
breakCycleEdge(AcDbGraphNode *pFrom, AcDbGraphNode *pTo) (defined in AcDbGraph) | AcDbGraph |
clearAll(Adesk::UInt8 flags) (defined in AcDbGraph) | AcDbGraph |
clearAllCycles() (defined in AcDbGraph) | AcDbGraph | protected
delNode(AcDbGraphNode *) (defined in AcDbGraph) | AcDbGraph |
findCycles(AcDbGraphNode *pStart=NULL) (defined in AcDbGraph) | AcDbGraph | virtual
getOutgoing(AcDbVoidPtrArray &) (defined in AcDbGraph) | AcDbGraph |
isEmpty() const (defined in AcDbGraph) | AcDbGraph | inline
node(int index) const (defined in AcDbGraph) | AcDbGraph | inline
numNodes() const (defined in AcDbGraph) | AcDbGraph | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
reset() (defined in AcDbGraph) | AcDbGraph |
rootNode() const (defined in AcDbGraph) | AcDbGraph | inline
setNodeGrowthRate(int rate) (defined in AcDbGraph) | AcDbGraph |
~AcDbGraph() (defined in AcDbGraph) | AcDbGraph | virtual


ZRX API Reference: AcDbGraphNode Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbGraphNode Class Reference
AcDb Classes
+ Inheritance diagram for AcDbGraphNode:

Public Types

enum Flags {
kNone = 0x00, kVisited = 0x01, kOutsideRefed = 0x02, kSelected = 0x04,
kInList = 0x08, kListAll = 0x0E, kFirstLevel = 0x10, kUnresTree = 0x20,
kAll = 0x2F
}

Public Member Functions

AcDbGraphNode (void *pData=NULL)
Acad::ErrorStatus | addRefTo (AcDbGraphNode *)
Acad::ErrorStatus | clear (Adesk::UInt8 flags)
AcDbGraphNode * | cycleIn (int) const
AcDbGraphNode * | cycleOut (int) const
void * | data () const
Acad::ErrorStatus | disconnectAll ()
AcDbGraphNode * | in (int) const
bool | isCycleNode () const
bool | isMarkedAs (Adesk::UInt8 flags) const
Acad::ErrorStatus | markAs (Adesk::UInt8 flags)
Acad::ErrorStatus | markTree (Adesk::UInt8 flags, AcDbVoidPtrArray *=NULL)
AcDbGraphNode * | nextCycleNode () const
int | numCycleIn () const
int | numCycleOut () const
int | numIn () const
int | numOut () const
AcDbGraphNode * | out (int) const
AcDbGraph * | owner () const
Acad::ErrorStatus | removeRefTo (AcDbGraphNode *)
void | setData (void *)
void | setEdgeGrowthRate (int outEdgeRate, int inEdgeRate)

Additional Inherited Members

- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • graph.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbGraphNode Member List

This is the complete list of members for AcDbGraphNode, including all inherited members.

AcDbGraphNode(void *pData=NULL) (defined in AcDbGraphNode) | AcDbGraphNode |
addRefTo(AcDbGraphNode *) (defined in AcDbGraphNode) | AcDbGraphNode |
clear(Adesk::UInt8 flags) (defined in AcDbGraphNode) | AcDbGraphNode |
cycleIn(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
cycleOut(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
data() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
disconnectAll() (defined in AcDbGraphNode) | AcDbGraphNode |
Flags enum name (defined in AcDbGraphNode) | AcDbGraphNode |
in(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
isCycleNode() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
isMarkedAs(Adesk::UInt8 flags) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
kAll enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kFirstLevel enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kInList enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kListAll enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kNone enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kOutsideRefed enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kSelected enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kUnresTree enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kVisited enum value (defined in AcDbGraphNode) | AcDbGraphNode |
markAs(Adesk::UInt8 flags) (defined in AcDbGraphNode) | AcDbGraphNode |
markTree(Adesk::UInt8 flags, AcDbVoidPtrArray *=NULL) (defined in AcDbGraphNode) | AcDbGraphNode |
nextCycleNode() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numCycleIn() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numCycleOut() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numIn() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numOut() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
out(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
owner() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
removeRefTo(AcDbGraphNode *) (defined in AcDbGraphNode) | AcDbGraphNode |
setData(void *) (defined in AcDbGraphNode) | AcDbGraphNode | inline
setEdgeGrowthRate(int outEdgeRate, int inEdgeRate) (defined in AcDbGraphNode) | AcDbGraphNode |
~AcDbGraphNode() (defined in AcDbGraphNode) | AcDbGraphNode | virtual


ZRX API Reference: AcDbGraphStack Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbGraphStack Class Reference
AcDb Classes
+ Inheritance diagram for AcDbGraphStack:

Public Member Functions

AcDbGraphStack (int initPhysicalLength=0, int initGrowLength=8)
bool | isEmpty () const
AcDbGraphNode * | pop ()
Acad::ErrorStatus | push (AcDbGraphNode *)
AcDbGraphNode * | top () const

Additional Inherited Members

- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • graph.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbGraphStack Member List

This is the complete list of members for AcDbGraphStack, including all inherited members.

AcDbGraphStack(int initPhysicalLength=0, int initGrowLength=8) (defined in AcDbGraphStack) | AcDbGraphStack |
isEmpty() const (defined in AcDbGraphStack) | AcDbGraphStack | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
pop() (defined in AcDbGraphStack) | AcDbGraphStack |
push(AcDbGraphNode *) (defined in AcDbGraphStack) | AcDbGraphStack |
top() const (defined in AcDbGraphStack) | AcDbGraphStack | inline
~AcDbGraphStack() (defined in AcDbGraphStack) | AcDbGraphStack |


ZRX API Reference: AcDbGripData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbGripData Class Reference
AcDb Classes

Public Member Functions

AcDbGripData (const AcGePoint3d &, void *, GripOperationPtr hotGrip=NULL, GripOperationPtr hoverGrip=NULL, GripRtClkHandler RtClk=NULL, GripWorldDrawPtr wd=NULL, GripViewportDrawPtr vd=NULL, GripOpStatusPtr stat=NULL, GripToolTipPtr tt=NULL, GripDimensionPtr hoverDim=NULL, GripDimensionPtr hotGripDim=NULL, unsigned int bitFlags=0, AcGePoint3d *altBasePt=NULL, GripInputPointPtr inputPointFunc=NULL)
AcDbGripData (const AcGePoint3d &, void *, AcRxClass *, GripOperationPtr hotGrip=NULL, GripOperationPtr hoverGrip=NULL, GripRtClkHandler RtClk=NULL, GripWorldDrawPtr wd=NULL, GripViewportDrawPtr vd=NULL, GripOpStatusPtr stat=NULL, GripToolTipPtr tt=NULL, GripDimensionPtr hoverDim=NULL, GripDimensionPtr hotGripDim=NULL, unsigned int bitFlags=0, AcGePoint3d *altBasePt=NULL, GripInputPointPtr inputPointFunc=NULL)
AcDbGripData (const AcDbGripData &)
AcGePoint3d * | alternateBasePoint () const
void * | appData () const
AcRxClass * | appDataAcRxClass () const
bool | areModeKeywordsDisabled () const
unsigned int | bitFlags () const
void | disableModeKeywords (bool disable)
void | disableRubberBandLine (bool disable)
bool | drawAtDragImageGripPoint () const
bool | forcedPickOn () const
bool | gizmosEnabled () const
bool | gripIsPerViewport () const
GripOpStatusPtr | gripOpStatFunc () const
const AcGePoint3d & | gripPoint () const
GripDimensionPtr | hotGripDimensionFunc () const
GripOperationPtr | hotGripFunc () const
GripDimensionPtr | hoverDimensionFunc () const
GripOperationPtr | hoverFunc () const
GripInputPointPtr | inputPointFunc () const
bool | isRubberBandLineDisabled () const
bool | mapGripHotToRtClk () const
AcDbGripData & | operator= (const AcDbGripData &)
GripRtClkHandler | rtClk () const
void | setAllData (const AcGePoint3d &, void *, GripOperationPtr hotGrip=NULL, GripOperationPtr hoverGrip=NULL, GripRtClkHandler RtClk=NULL, GripWorldDrawPtr wd=NULL, GripViewportDrawPtr vd=NULL, GripOpStatusPtr stat=NULL, GripToolTipPtr tt=NULL, GripDimensionPtr hoverDim=NULL, GripDimensionPtr hotGripDim=NULL, unsigned int bitFlags=0, AcGePoint3d *altBasePt=NULL, GripInputPointPtr inputPointFunc=NULL, AcRxClass *appDataAcRxClass=NULL)
void | setAlternateBasePoint (AcGePoint3d *altBasePt)
void | setAppData (void *appData)
void | setAppDataAcRxClass (AcRxClass *pClass)
void | setBitFlags (unsigned int flags)
void | setDrawAtDragImageGripPoint (bool atDragPoint)
void | setForcedPickOn (bool on)
void | setGizmosEnabled (bool on)
void | setGripIsPerViewport (bool on)
void | setGripOpStatFunc (GripOpStatusPtr pFunc)
void | setGripPoint (const AcGePoint3d &pt)
void | setHotGripDimensionFunc (GripDimensionPtr pFunc)
void | setHotGripFunc (GripOperationPtr pFunc)
void | setHoverDimensionFunc (GripDimensionPtr pFunc)
void | setHoverFunc (GripOperationPtr pFunc)
void | setInputPointFunc (GripInputPointPtr pFunc)
void | setMapGripHotToRtClk (bool on)
void | setRtClk (GripRtClkHandler pFunc)
void | setSkipWhenShared (bool skip)
void | setToolTipFunc (GripToolTipPtr pFunc)
void | setTriggerGrip (bool trigger)
void | setViewportDraw (GripViewportDrawPtr pFunc)
void | setWorldDraw (GripWorldDrawPtr pFunc)
bool | skipWhenShared () const
GripToolTipPtr | toolTipFunc () const
bool | triggerGrip () const
GripViewportDrawPtr | viewportDraw () const
GripWorldDrawPtr | worldDraw () const
The documentation for this class was generated from the following file:
  • dbgrip.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbGripData Member List

This is the complete list of members for AcDbGripData, including all inherited members.

AcDbGripData() (defined in AcDbGripData) | AcDbGripData | inline
AcDbGripData(const AcGePoint3d &, void *, GripOperationPtr hotGrip=NULL, GripOperationPtr hoverGrip=NULL, GripRtClkHandler RtClk=NULL, GripWorldDrawPtr wd=NULL, GripViewportDrawPtr vd=NULL, GripOpStatusPtr stat=NULL, GripToolTipPtr tt=NULL, GripDimensionPtr hoverDim=NULL, GripDimensionPtr hotGripDim=NULL, unsigned int bitFlags=0, AcGePoint3d *altBasePt=NULL, GripInputPointPtr inputPointFunc=NULL) (defined in AcDbGripData) | AcDbGripData | inline
AcDbGripData(const AcGePoint3d &, void *, AcRxClass *, GripOperationPtr hotGrip=NULL, GripOperationPtr hoverGrip=NULL, GripRtClkHandler RtClk=NULL, GripWorldDrawPtr wd=NULL, GripViewportDrawPtr vd=NULL, GripOpStatusPtr stat=NULL, GripToolTipPtr tt=NULL, GripDimensionPtr hoverDim=NULL, GripDimensionPtr hotGripDim=NULL, unsigned int bitFlags=0, AcGePoint3d *altBasePt=NULL, GripInputPointPtr inputPointFunc=NULL) (defined in AcDbGripData) | AcDbGripData | inline
AcDbGripData(const AcDbGripData &) (defined in AcDbGripData) | AcDbGripData | inline
alternateBasePoint() const (defined in AcDbGripData) | AcDbGripData | inline
appData() const (defined in AcDbGripData) | AcDbGripData | inline
appDataAcRxClass() const (defined in AcDbGripData) | AcDbGripData | inline
areModeKeywordsDisabled() const (defined in AcDbGripData) | AcDbGripData | inline
bitFlags() const (defined in AcDbGripData) | AcDbGripData | inline
disableModeKeywords(bool disable) (defined in AcDbGripData) | AcDbGripData | inline
disableRubberBandLine(bool disable) (defined in AcDbGripData) | AcDbGripData | inline
drawAtDragImageGripPoint() const (defined in AcDbGripData) | AcDbGripData | inline
forcedPickOn() const (defined in AcDbGripData) | AcDbGripData | inline
gizmosEnabled() const (defined in AcDbGripData) | AcDbGripData | inline
gripIsPerViewport() const (defined in AcDbGripData) | AcDbGripData | inline
gripOpStatFunc() const (defined in AcDbGripData) | AcDbGripData | inline
gripPoint() const (defined in AcDbGripData) | AcDbGripData | inline
hotGripDimensionFunc() const (defined in AcDbGripData) | AcDbGripData | inline
hotGripFunc() const (defined in AcDbGripData) | AcDbGripData | inline
hoverDimensionFunc() const (defined in AcDbGripData) | AcDbGripData | inline
hoverFunc() const (defined in AcDbGripData) | AcDbGripData | inline
inputPointFunc() const (defined in AcDbGripData) | AcDbGripData | inline
isRubberBandLineDisabled() const (defined in AcDbGripData) | AcDbGripData | inline
mapGripHotToRtClk() const (defined in AcDbGripData) | AcDbGripData | inline
operator=(const AcDbGripData &) (defined in AcDbGripData) | AcDbGripData | inline
rtClk() const (defined in AcDbGripData) | AcDbGripData | inline
setAllData(const AcGePoint3d &, void *, GripOperationPtr hotGrip=NULL, GripOperationPtr hoverGrip=NULL, GripRtClkHandler RtClk=NULL, GripWorldDrawPtr wd=NULL, GripViewportDrawPtr vd=NULL, GripOpStatusPtr stat=NULL, GripToolTipPtr tt=NULL, GripDimensionPtr hoverDim=NULL, GripDimensionPtr hotGripDim=NULL, unsigned int bitFlags=0, AcGePoint3d *altBasePt=NULL, GripInputPointPtr inputPointFunc=NULL, AcRxClass *appDataAcRxClass=NULL) (defined in AcDbGripData) | AcDbGripData | inline
setAlternateBasePoint(AcGePoint3d *altBasePt) (defined in AcDbGripData) | AcDbGripData | inline
setAppData(void *appData) (defined in AcDbGripData) | AcDbGripData | inline
setAppDataAcRxClass(AcRxClass *pClass) (defined in AcDbGripData) | AcDbGripData | inline
setBitFlags(unsigned int flags) (defined in AcDbGripData) | AcDbGripData | inline
setDrawAtDragImageGripPoint(bool atDragPoint) (defined in AcDbGripData) | AcDbGripData | inline
setForcedPickOn(bool on) (defined in AcDbGripData) | AcDbGripData | inline
setGizmosEnabled(bool on) (defined in AcDbGripData) | AcDbGripData | inline
setGripIsPerViewport(bool on) (defined in AcDbGripData) | AcDbGripData | inline
setGripOpStatFunc(GripOpStatusPtr pFunc) (defined in AcDbGripData) | AcDbGripData | inline
setGripPoint(const AcGePoint3d &pt) (defined in AcDbGripData) | AcDbGripData | inline
setHotGripDimensionFunc(GripDimensionPtr pFunc) (defined in AcDbGripData) | AcDbGripData | inline
setHotGripFunc(GripOperationPtr pFunc) (defined in AcDbGripData) | AcDbGripData | inline
setHoverDimensionFunc(GripDimensionPtr pFunc) (defined in AcDbGripData) | AcDbGripData | inline
setHoverFunc(GripOperationPtr pFunc) (defined in AcDbGripData) | AcDbGripData | inline
setInputPointFunc(GripInputPointPtr pFunc) (defined in AcDbGripData) | AcDbGripData | inline
setMapGripHotToRtClk(bool on) (defined in AcDbGripData) | AcDbGripData | inline
setRtClk(GripRtClkHandler pFunc) (defined in AcDbGripData) | AcDbGripData | inline
setSkipWhenShared(bool skip) (defined in AcDbGripData) | AcDbGripData | inline
setToolTipFunc(GripToolTipPtr pFunc) (defined in AcDbGripData) | AcDbGripData | inline
setTriggerGrip(bool trigger) (defined in AcDbGripData) | AcDbGripData | inline
setViewportDraw(GripViewportDrawPtr pFunc) (defined in AcDbGripData) | AcDbGripData | inline
setWorldDraw(GripWorldDrawPtr pFunc) (defined in AcDbGripData) | AcDbGripData | inline
skipWhenShared() const (defined in AcDbGripData) | AcDbGripData | inline
toolTipFunc() const (defined in AcDbGripData) | AcDbGripData | inline
triggerGrip() const (defined in AcDbGripData) | AcDbGripData | inline
viewportDraw() const (defined in AcDbGripData) | AcDbGripData | inline
worldDraw() const (defined in AcDbGripData) | AcDbGripData | inline
~AcDbGripData() (defined in AcDbGripData) | AcDbGripData | inline


ZRX API Reference: AcDbGroundPlaneBackground Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbGroundPlaneBackground Class Reference
AcDb Classes
+ Inheritance diagram for AcDbGroundPlaneBackground:

Public Member Functions

AcDbGroundPlaneBackground ()
ACRX_DECLARE_MEMBERS (AcDbGroundPlaneBackground)
AcCmEntityColor | colorGroundPlaneFar (void) const
AcCmEntityColor | colorGroundPlaneNear (void) const
AcCmEntityColor | colorSkyHorizon (void) const
AcCmEntityColor | colorSkyZenith (void) const
AcCmEntityColor | colorUndergroundAzimuth (void) const
AcCmEntityColor | colorUndergroundHorizon (void) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcGiDrawable::DrawableType | drawableType () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
void | setColorGroundPlaneFar (const AcCmEntityColor &color)
void | setColorGroundPlaneNear (const AcCmEntityColor &color)
void | setColorSkyHorizon (const AcCmEntityColor &color)
void | setColorSkyZenith (const AcCmEntityColor &color)
void | setColorUndergroundAzimuth (const AcCmEntityColor &color)
void | setColorUndergroundHorizon (const AcCmEntityColor &color)
virtual | ~AcDbGroundPlaneBackground ()
- Public Member Functions inherited from AcDbBackground
ACRX_DECLARE_MEMBERS (AcDbBackground)
virtual AcGiDrawable * | drawable ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpGroundPlaneBackground

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcDbBackground
AcDbBackground (AcDbImpBackground *pImp)
AcDbImpBackground * | imp () const

Constructor & Destructor Documentation

AcDbGroundPlaneBackground::AcDbGroundPlaneBackground ( )
Warning
Not implemented!
virtual AcDbGroundPlaneBackground::~AcDbGroundPlaneBackground ( )
virtual
Warning
Not implemented!

Member Function Documentation

AcCmEntityColor AcDbGroundPlaneBackground::colorGroundPlaneFar ( void ) const
Warning
Not implemented!
AcCmEntityColor AcDbGroundPlaneBackground::colorGroundPlaneNear ( void ) const
Warning
Not implemented!
AcCmEntityColor AcDbGroundPlaneBackground::colorSkyHorizon ( void ) const
Warning
Not implemented!
AcCmEntityColor AcDbGroundPlaneBackground::colorSkyZenith ( void ) const
Warning
Not implemented!
AcCmEntityColor AcDbGroundPlaneBackground::colorUndergroundAzimuth ( void ) const
Warning
Not implemented!
AcCmEntityColor AcDbGroundPlaneBackground::colorUndergroundHorizon ( void ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbGroundPlaneBackground::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual AcGiDrawable::DrawableType AcDbGroundPlaneBackground::drawableType ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiDrawable.

virtual Acad::ErrorStatus AcDbGroundPlaneBackground::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbGroundPlaneBackground::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbGroundPlaneBackground::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbGroundPlaneBackground::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Adesk::UInt32 AcDbGroundPlaneBackground::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

void AcDbGroundPlaneBackground::setColorGroundPlaneFar ( const AcCmEntityColor & color )
Warning
Not implemented!
void AcDbGroundPlaneBackground::setColorGroundPlaneNear ( const AcCmEntityColor & color )
Warning
Not implemented!
void AcDbGroundPlaneBackground::setColorSkyHorizon ( const AcCmEntityColor & color )
Warning
Not implemented!
void AcDbGroundPlaneBackground::setColorSkyZenith ( const AcCmEntityColor & color )
Warning
Not implemented!
void AcDbGroundPlaneBackground::setColorUndergroundAzimuth ( const AcCmEntityColor & color )
Warning
Not implemented!
void AcDbGroundPlaneBackground::setColorUndergroundHorizon ( const AcCmEntityColor & color )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbbackground.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbGroundPlaneBackground Member List

This is the complete list of members for AcDbGroundPlaneBackground, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBackground(AcDbImpBackground *pImp) (defined in AcDbBackground) | AcDbBackground | protected
AcDbGroundPlaneBackground() | AcDbGroundPlaneBackground |
AcDbImpGroundPlaneBackground (defined in AcDbGroundPlaneBackground) | AcDbGroundPlaneBackground | friend
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbGroundPlaneBackground) (defined in AcDbGroundPlaneBackground) | AcDbGroundPlaneBackground |
ACRX_DECLARE_MEMBERS(AcDbBackground) (defined in AcDbBackground) | AcDbBackground |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
colorGroundPlaneFar(void) const | AcDbGroundPlaneBackground |
colorGroundPlaneNear(void) const | AcDbGroundPlaneBackground |
colorSkyHorizon(void) const | AcDbGroundPlaneBackground |
colorSkyZenith(void) const | AcDbGroundPlaneBackground |
colorUndergroundAzimuth(void) const | AcDbGroundPlaneBackground |
colorUndergroundHorizon(void) const | AcDbGroundPlaneBackground |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) | AcDbGroundPlaneBackground | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbBackground) | AcDbBackground | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const | AcDbGroundPlaneBackground | virtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbGroundPlaneBackground | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbGroundPlaneBackground | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbGroundPlaneBackground | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbGroundPlaneBackground | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imp() const (defined in AcDbBackground) | AcDbBackground | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbGroundPlaneBackground | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setColorGroundPlaneFar(const AcCmEntityColor &color) | AcDbGroundPlaneBackground |
setColorGroundPlaneNear(const AcCmEntityColor &color) | AcDbGroundPlaneBackground |
setColorSkyHorizon(const AcCmEntityColor &color) | AcDbGroundPlaneBackground |
setColorSkyZenith(const AcCmEntityColor &color) | AcDbGroundPlaneBackground |
setColorUndergroundAzimuth(const AcCmEntityColor &color) | AcDbGroundPlaneBackground |
setColorUndergroundHorizon(const AcCmEntityColor &color) | AcDbGroundPlaneBackground |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBackground() (defined in AcDbBackground) | AcDbBackground | virtual
~AcDbGroundPlaneBackground() | AcDbGroundPlaneBackground | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbGroup Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbGroup Class Reference
AcDb Classes
+ Inheritance diagram for AcDbGroup:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbGroup)
AcDbGroup (const ACHAR *grpDesc, bool selectable=true)
Adesk::UInt32 | allEntityIds (AcDbObjectIdArray &ids) const
Acad::ErrorStatus | append (AcDbObjectId id)
Acad::ErrorStatus | append (AcDbObjectIdArray ids)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
Acad::ErrorStatus | clear ()
const ACHAR * | description () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean erasing=true)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getIndex (AcDbObjectId id, Adesk::UInt32 &idx) const
Acad::ErrorStatus | getName (ACHAR *&name) const
virtual void | goodbye (const AcDbObject *dbObj)
bool | has (const AcDbEntity *pEntity) const
Acad::ErrorStatus | insertAt (Adesk::UInt32 idx, AcDbObjectId id)
Acad::ErrorStatus | insertAt (Adesk::UInt32 idx, AcDbObjectIdArray ids)
bool | isAnonymous () const
bool | isNotAccessible () const
bool | isSelectable () const
const ACHAR * | name () const
AcDbGroupIterator * | newIterator ()
Adesk::UInt32 | numEntities () const
Acad::ErrorStatus | prepend (AcDbObjectId id)
Acad::ErrorStatus | prepend (AcDbObjectIdArray ids)
Acad::ErrorStatus | remove (AcDbObjectId id)
Acad::ErrorStatus | remove (AcDbObjectIdArray ids)
Acad::ErrorStatus | removeAt (Adesk::UInt32 idx)
Acad::ErrorStatus | removeAt (Adesk::UInt32 idx, AcDbObjectIdArray ids)
Acad::ErrorStatus | replace (AcDbObjectId oldId, AcDbObjectId newId)
Acad::ErrorStatus | reverse ()
Acad::ErrorStatus | setAnonymous ()
Acad::ErrorStatus | setColor (const AcCmColor &color)
Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color)
Acad::ErrorStatus | setDescription (const ACHAR *grpDesc)
Acad::ErrorStatus | setHighlight (bool newVal)
Acad::ErrorStatus | setLayer (const ACHAR *newVal)
Acad::ErrorStatus | setLayer (AcDbObjectId newVal)
Acad::ErrorStatus | setLinetype (const ACHAR *newVal)
Acad::ErrorStatus | setLinetype (AcDbObjectId newVal)
Acad::ErrorStatus | setLinetypeScale (double newval)
Acad::ErrorStatus | setMaterial (const ACHAR *newVal)
Acad::ErrorStatus | setMaterial (AcDbObjectId newVal)
Acad::ErrorStatus | setName (const ACHAR *newName)
Acad::ErrorStatus | setSelectable (bool selectable)
Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal)
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing=true)
Acad::ErrorStatus | transfer (Adesk::UInt32 fromIndex, Adesk::UInt32 toIndex, Adesk::UInt32 numItems)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

Acad::ErrorStatus AcDbGroup::setMaterial ( const ACHAR * newVal )
Warning
Not implemented!
Acad::ErrorStatus AcDbGroup::setMaterial ( AcDbObjectId newVal )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbgroup.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbGroup Member List

This is the complete list of members for AcDbGroup, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbGroup) (defined in AcDbGroup) | AcDbGroup |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbGroup() (defined in AcDbGroup) | AcDbGroup |
AcDbGroup(const ACHAR *grpDesc, bool selectable=true) (defined in AcDbGroup) | AcDbGroup |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
allEntityIds(AcDbObjectIdArray &ids) const (defined in AcDbGroup) | AcDbGroup |
append(AcDbObjectId id) (defined in AcDbGroup) | AcDbGroup |
append(AcDbObjectIdArray ids) (defined in AcDbGroup) | AcDbGroup |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbGroup) | AcDbGroup | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clear() (defined in AcDbGroup) | AcDbGroup |
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description() const (defined in AcDbGroup) | AcDbGroup |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbGroup) | AcDbGroup | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbGroup) | AcDbGroup | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbGroup) | AcDbGroup | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbGroup) | AcDbGroup | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean erasing=true) (defined in AcDbGroup) | AcDbGroup | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbGroup) | AcDbGroup | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getIndex(AcDbObjectId id, Adesk::UInt32 &idx) const (defined in AcDbGroup) | AcDbGroup |
getName(ACHAR *&name) const (defined in AcDbGroup) | AcDbGroup |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbGroup) | AcDbGroup | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const AcDbEntity *pEntity) const (defined in AcDbGroup) | AcDbGroup |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
insertAt(Adesk::UInt32 idx, AcDbObjectId id) (defined in AcDbGroup) | AcDbGroup |
insertAt(Adesk::UInt32 idx, AcDbObjectIdArray ids) (defined in AcDbGroup) | AcDbGroup |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAnonymous() const (defined in AcDbGroup) | AcDbGroup |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotAccessible() const (defined in AcDbGroup) | AcDbGroup |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isSelectable() const (defined in AcDbGroup) | AcDbGroup |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
name() const (defined in AcDbGroup) | AcDbGroup |
newIterator() (defined in AcDbGroup) | AcDbGroup |
numEntities() const (defined in AcDbGroup) | AcDbGroup |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
prepend(AcDbObjectId id) (defined in AcDbGroup) | AcDbGroup |
prepend(AcDbObjectIdArray ids) (defined in AcDbGroup) | AcDbGroup |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
remove(AcDbObjectId id) (defined in AcDbGroup) | AcDbGroup |
remove(AcDbObjectIdArray ids) (defined in AcDbGroup) | AcDbGroup |
removeAt(Adesk::UInt32 idx) (defined in AcDbGroup) | AcDbGroup |
removeAt(Adesk::UInt32 idx, AcDbObjectIdArray ids) (defined in AcDbGroup) | AcDbGroup |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
replace(AcDbObjectId oldId, AcDbObjectId newId) (defined in AcDbGroup) | AcDbGroup |
reverse() (defined in AcDbGroup) | AcDbGroup |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAnonymous() (defined in AcDbGroup) | AcDbGroup |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setColor(const AcCmColor &color) (defined in AcDbGroup) | AcDbGroup |
setColorIndex(Adesk::UInt16 color) (defined in AcDbGroup) | AcDbGroup |
setDescription(const ACHAR *grpDesc) (defined in AcDbGroup) | AcDbGroup |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHighlight(bool newVal) (defined in AcDbGroup) | AcDbGroup |
setLayer(const ACHAR *newVal) (defined in AcDbGroup) | AcDbGroup |
setLayer(AcDbObjectId newVal) (defined in AcDbGroup) | AcDbGroup |
setLinetype(const ACHAR *newVal) (defined in AcDbGroup) | AcDbGroup |
setLinetype(AcDbObjectId newVal) (defined in AcDbGroup) | AcDbGroup |
setLinetypeScale(double newval) (defined in AcDbGroup) | AcDbGroup |
setMaterial(const ACHAR *newVal) | AcDbGroup |
setMaterial(AcDbObjectId newVal) | AcDbGroup |
setName(const ACHAR *newName) (defined in AcDbGroup) | AcDbGroup |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setSelectable(bool selectable) (defined in AcDbGroup) | AcDbGroup |
setVisibility(AcDb::Visibility newVal) (defined in AcDbGroup) | AcDbGroup |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbGroup) | AcDbGroup | virtual
subErase(Adesk::Boolean erasing=true) (defined in AcDbGroup) | AcDbGroup | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transfer(Adesk::UInt32 fromIndex, Adesk::UInt32 toIndex, Adesk::UInt32 numItems) (defined in AcDbGroup) | AcDbGroup |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbGroup() (defined in AcDbGroup) | AcDbGroup | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbGroupIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbGroupIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbGroupIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbGroupIterator)
virtual bool | done () const =0
virtual Acad::ErrorStatus | getObject (AcDbObject *&pObject, AcDb::OpenMode)=0
virtual bool | next ()=0
virtual AcDbObjectId | objectId () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbgroup.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbGroupIterator Member List

This is the complete list of members for AcDbGroupIterator, including all inherited members.

AcDbGroupIterator() (defined in AcDbGroupIterator) | AcDbGroupIterator | inlineprotected
ACRX_DECLARE_MEMBERS(AcDbGroupIterator) (defined in AcDbGroupIterator) | AcDbGroupIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const =0 (defined in AcDbGroupIterator) | AcDbGroupIterator | pure virtual
getObject(AcDbObject *&pObject, AcDb::OpenMode)=0 (defined in AcDbGroupIterator) | AcDbGroupIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
next()=0 (defined in AcDbGroupIterator) | AcDbGroupIterator | pure virtual
objectId() const =0 (defined in AcDbGroupIterator) | AcDbGroupIterator | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbGroupIterator() (defined in AcDbGroupIterator) | AcDbGroupIterator | inlinevirtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbHandle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcDbHandle Class Reference
AcDb Classes

Public Types

enum { kMaxValueBytes = 8 }

Public Member Functions

AcDbHandle (int lo, int hi)
AcDbHandle (const ACHAR *)
AcDbHandle (const Adesk::UInt64 &)
int | byte (Adesk::UInt32 i) const
int | compare (const AcDbHandle &) const
void | copyFromOldType (const Adesk::UInt8 hand[8])
void | copyToOldType (Adesk::UInt8 hand[8]) const
void | decrement (void)
void | getIntoAsciiBuffer (ACHAR *pBuf) const
void | getValueBytes (Adesk::UInt8 *, Adesk::UInt8 *) const
Adesk::UInt32 | high () const
void | increment (void)
bool | isNull () const
bool | isOne (void) const
Adesk::UInt32 | low () const
operator Adesk::UInt32 () const
bool | operator!= (const AcDbHandle &) const
AcDbHandle | operator+ (const AcDbHandle &) const
AcDbHandle | operator+ (Adesk::ULongPtr) const
AcDbHandle & | operator++ ()
AcDbHandle | operator++ (int)
AcDbHandle & | operator+= (const AcDbHandle &)
AcDbHandle | operator- (const AcDbHandle &) const
AcDbHandle & | operator-= (const AcDbHandle &)
bool | operator< (const AcDbHandle &) const
bool | operator<= (const AcDbHandle &) const
AcDbHandle & | operator= (const AcDbHandle &)
AcDbHandle & | operator= (const ACHAR *)
AcDbHandle & | operator= (Adesk::UInt32)
bool | operator== (const AcDbHandle &) const
bool | operator> (const AcDbHandle &) const
bool | operator>= (const AcDbHandle &) const
void | print () const
int | restZeros (int i) const
void | setHigh (Adesk::UInt32 high)
void | setLow (Adesk::UInt32 low)
void | setNull ()
void | setValueBytes (Adesk::UInt8, const Adesk::UInt8 *)
AcDbHandle | slowOperatorPlus (const AcDbHandle &) const

Friends

class | AcDbHandleTable
class | HandleDataBase
The documentation for this class was generated from the following file:
  • dbhandle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbHandle Member List

This is the complete list of members for AcDbHandle, including all inherited members.

AcDbHandle() (defined in AcDbHandle) | AcDbHandle | inline
AcDbHandle(int lo, int hi) (defined in AcDbHandle) | AcDbHandle | inline
AcDbHandle(const ACHAR *) (defined in AcDbHandle) | AcDbHandle |
AcDbHandle(const Adesk::UInt64 &) (defined in AcDbHandle) | AcDbHandle | inline
AcDbHandleTable (defined in AcDbHandle) | AcDbHandle | friend
byte(Adesk::UInt32 i) const (defined in AcDbHandle) | AcDbHandle | inline
compare(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle | inline
copyFromOldType(const Adesk::UInt8 hand[8]) (defined in AcDbHandle) | AcDbHandle |
copyToOldType(Adesk::UInt8 hand[8]) const (defined in AcDbHandle) | AcDbHandle |
decrement(void) (defined in AcDbHandle) | AcDbHandle | inline
getIntoAsciiBuffer(ACHAR *pBuf) const (defined in AcDbHandle) | AcDbHandle |
getValueBytes(Adesk::UInt8 *, Adesk::UInt8 *) const (defined in AcDbHandle) | AcDbHandle |
HandleDataBase (defined in AcDbHandle) | AcDbHandle | friend
high() const (defined in AcDbHandle) | AcDbHandle | inline
increment(void) (defined in AcDbHandle) | AcDbHandle | inline
isNull() const (defined in AcDbHandle) | AcDbHandle | inline
isOne(void) const (defined in AcDbHandle) | AcDbHandle | inline
kMaxValueBytes enum value (defined in AcDbHandle) | AcDbHandle |
low() const (defined in AcDbHandle) | AcDbHandle | inline
operator Adesk::UInt32() const (defined in AcDbHandle) | AcDbHandle | inline
operator!=(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle | inline
operator+(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle | inline
operator+(Adesk::ULongPtr) const (defined in AcDbHandle) | AcDbHandle | inline
operator++() (defined in AcDbHandle) | AcDbHandle | inline
operator++(int) (defined in AcDbHandle) | AcDbHandle | inline
operator+=(const AcDbHandle &) (defined in AcDbHandle) | AcDbHandle |
operator-(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle |
operator-=(const AcDbHandle &) (defined in AcDbHandle) | AcDbHandle |
operator<(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle | inline
operator<=(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle |
operator=(const AcDbHandle &) (defined in AcDbHandle) | AcDbHandle | inline
operator=(const ACHAR *) (defined in AcDbHandle) | AcDbHandle |
operator=(Adesk::UInt32) (defined in AcDbHandle) | AcDbHandle | inline
operator==(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle | inline
operator>(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle | inline
operator>=(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle |
print() const (defined in AcDbHandle) | AcDbHandle |
restZeros(int i) const (defined in AcDbHandle) | AcDbHandle | inline
setHigh(Adesk::UInt32 high) (defined in AcDbHandle) | AcDbHandle | inline
setLow(Adesk::UInt32 low) (defined in AcDbHandle) | AcDbHandle | inline
setNull() (defined in AcDbHandle) | AcDbHandle | inline
setValueBytes(Adesk::UInt8, const Adesk::UInt8 *) (defined in AcDbHandle) | AcDbHandle |
slowOperatorPlus(const AcDbHandle &) const (defined in AcDbHandle) | AcDbHandle |


ZRX API Reference: AcDbHardOwnershipId Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbHardOwnershipId Class Reference
AcDb Classes
+ Inheritance diagram for AcDbHardOwnershipId:

Public Member Functions

AcDbHardOwnershipId (const AcDbObjectId &)
AcDbHardOwnershipId (const AcDbStub *)
operator AcDbStub * () const
bool | operator!= (const AcDbObjectId &) const
bool | operator!= (const AcDbStub *) const
AcDbHardOwnershipId & | operator= (const AcDbHardOwnershipId &)
AcDbHardOwnershipId & | operator= (const AcDbObjectId &)
AcDbHardOwnershipId & | operator= (const AcDbStub *)
bool | operator== (const AcDbObjectId &) const
bool | operator== (const AcDbStub *) const
- Public Member Functions inherited from AcDbObjectId
AcDbObjectId (const AcDbStub *)
Adesk::IntDbId | asOldId () const
void | convertToRedirectedId ()
AcDbDatabase * | database () const
AcDbHandle | handle () const
bool | isEffectivelyErased () const
bool | isErased () const
bool | isNull () const
bool | isResident () const
bool | isValid () const
AcDbHandle | nonForwardedHandle () const
bool | objectLeftOnDisk () const
bool | operator< (const AcDbObjectId &) const
bool | operator< (const AcDbStub *) const
bool | operator<= (const AcDbObjectId &) const
bool | operator<= (const AcDbStub *) const
bool | operator> (const AcDbObjectId &) const
bool | operator> (const AcDbStub *) const
bool | operator>= (const AcDbObjectId &) const
bool | operator>= (const AcDbStub *) const
AcDbDatabase * | originalDatabase () const
AcDbObjectId & | setFromOldId (Adesk::IntDbId oldId)
void | setNull ()

Additional Inherited Members

- Static Public Attributes inherited from AcDbObjectId
static ZRX_DB_STATIC_EXPORT
const AcDbObjectId 		kNull
- Protected Attributes inherited from AcDbObjectId
AcDbStub * mId
The documentation for this class was generated from the following file:
  • dbid.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbHardOwnershipId Member List

This is the complete list of members for AcDbHardOwnershipId, including all inherited members.

AcDbHardOwnershipId() (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
AcDbHardOwnershipId(const AcDbObjectId &) (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
AcDbHardOwnershipId(const AcDbStub *) (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
AcDbObjectId() (defined in AcDbObjectId) | AcDbObjectId | inline
AcDbObjectId(const AcDbStub *) (defined in AcDbObjectId) | AcDbObjectId | inline
asOldId() const (defined in AcDbObjectId) | AcDbObjectId | inline
convertToRedirectedId() (defined in AcDbObjectId) | AcDbObjectId |
database() const (defined in AcDbObjectId) | AcDbObjectId |
handle() const (defined in AcDbObjectId) | AcDbObjectId |
isEffectivelyErased() const (defined in AcDbObjectId) | AcDbObjectId |
isErased() const (defined in AcDbObjectId) | AcDbObjectId |
isNull() const (defined in AcDbObjectId) | AcDbObjectId | inline
isResident() const | AcDbObjectId |
isValid() const (defined in AcDbObjectId) | AcDbObjectId |
kNull (defined in AcDbObjectId) | AcDbObjectId | static
mId (defined in AcDbObjectId) | AcDbObjectId | protected
nonForwardedHandle() const (defined in AcDbObjectId) | AcDbObjectId |
objectLeftOnDisk() const (defined in AcDbObjectId) | AcDbObjectId |
operator AcDbStub *() const (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
operator!=(const AcDbObjectId &) const (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
operator!=(const AcDbStub *) const (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
operator<(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator=(const AcDbHardOwnershipId &) (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
operator=(const AcDbObjectId &) (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
operator=(const AcDbStub *) (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
operator==(const AcDbObjectId &) const (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
operator==(const AcDbStub *) const (defined in AcDbHardOwnershipId) | AcDbHardOwnershipId | inline
operator>(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
originalDatabase() const (defined in AcDbObjectId) | AcDbObjectId |
setFromOldId(Adesk::IntDbId oldId) (defined in AcDbObjectId) | AcDbObjectId | inline
setNull() (defined in AcDbObjectId) | AcDbObjectId | inline


ZRX API Reference: AcDbHardPointerId Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbHardPointerId Class Reference
AcDb Classes
+ Inheritance diagram for AcDbHardPointerId:

Public Member Functions

AcDbHardPointerId (const AcDbObjectId &)
AcDbHardPointerId (const AcDbStub *)
operator AcDbStub * () const
bool | operator!= (const AcDbObjectId &) const
bool | operator!= (const AcDbStub *) const
AcDbHardPointerId & | operator= (const AcDbHardPointerId &)
AcDbHardPointerId & | operator= (const AcDbObjectId &)
AcDbHardPointerId & | operator= (const AcDbStub *)
bool | operator== (const AcDbObjectId &) const
bool | operator== (const AcDbStub *) const
- Public Member Functions inherited from AcDbObjectId
AcDbObjectId (const AcDbStub *)
Adesk::IntDbId | asOldId () const
void | convertToRedirectedId ()
AcDbDatabase * | database () const
AcDbHandle | handle () const
bool | isEffectivelyErased () const
bool | isErased () const
bool | isNull () const
bool | isResident () const
bool | isValid () const
AcDbHandle | nonForwardedHandle () const
bool | objectLeftOnDisk () const
bool | operator< (const AcDbObjectId &) const
bool | operator< (const AcDbStub *) const
bool | operator<= (const AcDbObjectId &) const
bool | operator<= (const AcDbStub *) const
bool | operator> (const AcDbObjectId &) const
bool | operator> (const AcDbStub *) const
bool | operator>= (const AcDbObjectId &) const
bool | operator>= (const AcDbStub *) const
AcDbDatabase * | originalDatabase () const
AcDbObjectId & | setFromOldId (Adesk::IntDbId oldId)
void | setNull ()

Additional Inherited Members

- Static Public Attributes inherited from AcDbObjectId
static ZRX_DB_STATIC_EXPORT
const AcDbObjectId 		kNull
- Protected Attributes inherited from AcDbObjectId
AcDbStub * mId
The documentation for this class was generated from the following file:
  • dbid.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbHardPointerId Member List

This is the complete list of members for AcDbHardPointerId, including all inherited members.

AcDbHardPointerId() (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
AcDbHardPointerId(const AcDbObjectId &) (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
AcDbHardPointerId(const AcDbStub *) (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
AcDbObjectId() (defined in AcDbObjectId) | AcDbObjectId | inline
AcDbObjectId(const AcDbStub *) (defined in AcDbObjectId) | AcDbObjectId | inline
asOldId() const (defined in AcDbObjectId) | AcDbObjectId | inline
convertToRedirectedId() (defined in AcDbObjectId) | AcDbObjectId |
database() const (defined in AcDbObjectId) | AcDbObjectId |
handle() const (defined in AcDbObjectId) | AcDbObjectId |
isEffectivelyErased() const (defined in AcDbObjectId) | AcDbObjectId |
isErased() const (defined in AcDbObjectId) | AcDbObjectId |
isNull() const (defined in AcDbObjectId) | AcDbObjectId | inline
isResident() const | AcDbObjectId |
isValid() const (defined in AcDbObjectId) | AcDbObjectId |
kNull (defined in AcDbObjectId) | AcDbObjectId | static
mId (defined in AcDbObjectId) | AcDbObjectId | protected
nonForwardedHandle() const (defined in AcDbObjectId) | AcDbObjectId |
objectLeftOnDisk() const (defined in AcDbObjectId) | AcDbObjectId |
operator AcDbStub *() const (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
operator!=(const AcDbObjectId &) const (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
operator!=(const AcDbStub *) const (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
operator<(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator=(const AcDbHardPointerId &) (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
operator=(const AcDbObjectId &) (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
operator=(const AcDbStub *) (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
operator==(const AcDbObjectId &) const (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
operator==(const AcDbStub *) const (defined in AcDbHardPointerId) | AcDbHardPointerId | inline
operator>(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
originalDatabase() const (defined in AcDbObjectId) | AcDbObjectId |
setFromOldId(Adesk::IntDbId oldId) (defined in AcDbObjectId) | AcDbObjectId | inline
setNull() (defined in AcDbObjectId) | AcDbObjectId | inline


ZRX API Reference: AcDbHatch Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbHatch Class Reference
AcDb Classes
+ Inheritance diagram for AcDbHatch:

Public Types

enum | GradientPatternType { kPreDefinedGradient = 0, kUserDefinedGradient = 1 }
enum | HatchEdgeType { kLine = 1, kCirArc = 2, kEllArc = 3, kSpline = 4 }
enum HatchLoopType {
kDefault = 0, kExternal = 1, kPolyline = 2, kDerived = 4,
kTextbox = 8, kOutermost = 0x10, kNotClosed = 0x20, kSelfIntersecting = 0x40,
kTextIsland = 0x80, kDuplicate = 0x100, kIsAnnotative = 0x200, kDoesNotSupportScale = 0x400,
kForceAnnoAllVisible = 0x800, kOrientToPaper = 0x1000, kIsAnnotativeBlock = 0x2000
}
enum | HatchObjectType { kHatchObject = 0, kGradientObject = 1 }
enum | HatchPatternType { kUserDefined = 0, kPreDefined = 1, kCustomDefined = 2 }
enum | HatchStyle { kNormal = 0, kOuter = 1, kIgnore = 2 }
- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbHatch)
Acad::ErrorStatus | appendLoop (Adesk::Int32 loopType, const AcGeVoidPointerArray &edgePtrs, const AcGeIntArray &edgeTypes)
Acad::ErrorStatus | appendLoop (Adesk::Int32 loopType, const AcGePoint2dArray &vertices, const AcGeDoubleArray &bulges)
Acad::ErrorStatus | appendLoop (Adesk::Int32 loopType, const AcDbObjectIdArray &dbObjIds)
bool | associative () const
virtual bool | castShadows () const
double | elevation () const
Acad::ErrorStatus | evaluateGradientColorAt (float value, AcCmColor &color)
Acad::ErrorStatus | evaluateHatch (bool bUnderestimateNumLines=false)
Acad::ErrorStatus | getArea (double &a) const
Acad::ErrorStatus | getAssocObjIds (AcDbObjectIdArray &dbObjIds) const
Acad::ErrorStatus | getAssocObjIdsAt (int loopIndex, AcDbObjectIdArray &dbObjIds) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getGradientColors (unsigned int &count, AcCmColor *&colors, float *&values)
Adesk::Boolean | getGradientOneColorMode () const
Acad::ErrorStatus | getHatchLineDataAt (int index, AcGePoint2d &startPt, AcGePoint2d &endPt) const
Acad::ErrorStatus | getHatchLinesData (AcGePoint2dArray &startPts, AcGePoint2dArray &endPts) const
Acad::ErrorStatus | getLoopAt (int loopIndex, Adesk::Int32 &loopType, AcGeVoidPointerArray &edgePtrs, AcGeIntArray &edgeTypes) const
Acad::ErrorStatus | getLoopAt (int loopIndex, Adesk::Int32 &loopType, AcGePoint2dArray &vertices, AcGeDoubleArray &bulges) const
Acad::ErrorStatus | getPatternDefinitionAt (int index, double &angle, double &baseX, double &baseY, double &offsetX, double &offsetY, AcGeDoubleArray &dashes) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDbRegion * | getRegionArea () const
float | getShadeTintValue () const
double | gradientAngle () const
const ACHAR * | gradientName () const
float | gradientShift () const
AcDbHatch::GradientPatternType | gradientType () const
AcDbHatch::HatchObjectType | hatchObjectType () const
AcDbHatch::HatchStyle | hatchStyle () const
Acad::ErrorStatus | insertLoopAt (int loopIndex, Adesk::Int32 loopType, const AcGeVoidPointerArray &edgePtrs, const AcGeIntArray &edgeTypes)
Acad::ErrorStatus | insertLoopAt (int loopIndex, Adesk::Int32 loopType, const AcGePoint2dArray &vertices, const AcGeDoubleArray &bulges)
Acad::ErrorStatus | insertLoopAt (int loopIndex, Adesk::Int32 loopType, const AcDbObjectIdArray &dbObjIds)
virtual Adesk::Boolean | isGradient () const
virtual Adesk::Boolean | isHatch () const
virtual Adesk::Boolean | isPlanar () const
bool | isSolidFill () const
bool | lineGenerationEnabled () const
Adesk::Int32 | loopTypeAt (int loopIndex) const
virtual void | modifiedGraphics (const AcDbEntity *pObj)
AcGeVector3d | normal () const
int | numHatchLines () const
int | numLoops () const
int | numPatternDefinitions () const
AcGePoint2d | originPoint () const
double | patternAngle () const
bool | patternDouble () const
const ACHAR * | patternName () const
double | patternScale () const
double | patternSpace () const
AcDbHatch::HatchPatternType | patternType () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | removeAssocObjIds ()
void | removeHatchLines ()
Acad::ErrorStatus | removeLoopAt (int loopIndex)
Acad::ErrorStatus | setAssociative (bool isAssociative)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setElevation (double elevation)
Acad::ErrorStatus | setGradient (AcDbHatch::GradientPatternType gradType, const ACHAR *gradName)
Acad::ErrorStatus | setGradientAngle (double angle)
Acad::ErrorStatus | setGradientColors (unsigned int count, AcCmColor *colors, float *values)
Acad::ErrorStatus | setGradientOneColorMode (Adesk::Boolean oneColorMode)
Acad::ErrorStatus | setGradientShift (float shiftValue)
Acad::ErrorStatus | setHatchObjectType (AcDbHatch::HatchObjectType type)
Acad::ErrorStatus | setHatchStyle (AcDbHatch::HatchStyle hstyle)
bool | setLineGenerationEnabled (bool bEnable)
Acad::ErrorStatus | setNormal (const AcGeVector3d &normal)
Acad::ErrorStatus | setOriginPoint (const AcGePoint2d &pt)
Acad::ErrorStatus | setPattern (AcDbHatch::HatchPatternType patType, const ACHAR *patName)
Acad::ErrorStatus | setPatternAngle (double angle)
Acad::ErrorStatus | setPatternDouble (bool isDouble)
Acad::ErrorStatus | setPatternScale (double scale)
Acad::ErrorStatus | setPatternSpace (double space)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setShadeTintValue (float value)
Acad::ErrorStatus | setShadeTintValueAndColor2 (float value)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbhatch.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbHatch Member List

This is the complete list of members for AcDbHatch, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbHatch) (defined in AcDbHatch) | AcDbHatch |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbHatch() (defined in AcDbHatch) | AcDbHatch |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
appendLoop(Adesk::Int32 loopType, const AcGeVoidPointerArray &edgePtrs, const AcGeIntArray &edgeTypes) (defined in AcDbHatch) | AcDbHatch |
appendLoop(Adesk::Int32 loopType, const AcGePoint2dArray &vertices, const AcGeDoubleArray &bulges) (defined in AcDbHatch) | AcDbHatch |
appendLoop(Adesk::Int32 loopType, const AcDbObjectIdArray &dbObjIds) (defined in AcDbHatch) | AcDbHatch |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
associative() const (defined in AcDbHatch) | AcDbHatch |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbHatch) | AcDbHatch | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbHatch) | AcDbHatch |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
evaluateGradientColorAt(float value, AcCmColor &color) (defined in AcDbHatch) | AcDbHatch |
evaluateHatch(bool bUnderestimateNumLines=false) (defined in AcDbHatch) | AcDbHatch |
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &a) const (defined in AcDbHatch) | AcDbHatch |
getAssocObjIds(AcDbObjectIdArray &dbObjIds) const (defined in AcDbHatch) | AcDbHatch |
getAssocObjIdsAt(int loopIndex, AcDbObjectIdArray &dbObjIds) const (defined in AcDbHatch) | AcDbHatch |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbHatch) | AcDbHatch | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGradientColors(unsigned int &count, AcCmColor *&colors, float *&values) (defined in AcDbHatch) | AcDbHatch |
getGradientOneColorMode() const (defined in AcDbHatch) | AcDbHatch |
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getHatchLineDataAt(int index, AcGePoint2d &startPt, AcGePoint2d &endPt) const (defined in AcDbHatch) | AcDbHatch |
getHatchLinesData(AcGePoint2dArray &startPts, AcGePoint2dArray &endPts) const (defined in AcDbHatch) | AcDbHatch |
getLoopAt(int loopIndex, Adesk::Int32 &loopType, AcGeVoidPointerArray &edgePtrs, AcGeIntArray &edgeTypes) const (defined in AcDbHatch) | AcDbHatch |
getLoopAt(int loopIndex, Adesk::Int32 &loopType, AcGePoint2dArray &vertices, AcGeDoubleArray &bulges) const (defined in AcDbHatch) | AcDbHatch |
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPatternDefinitionAt(int index, double &angle, double &baseX, double &baseY, double &offsetX, double &offsetY, AcGeDoubleArray &dashes) const (defined in AcDbHatch) | AcDbHatch |
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbHatch) | AcDbHatch | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getRegionArea() const (defined in AcDbHatch) | AcDbHatch |
getShadeTintValue() const (defined in AcDbHatch) | AcDbHatch |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gradientAngle() const (defined in AcDbHatch) | AcDbHatch |
gradientName() const (defined in AcDbHatch) | AcDbHatch |
GradientPatternType enum name (defined in AcDbHatch) | AcDbHatch |
gradientShift() const (defined in AcDbHatch) | AcDbHatch |
gradientType() const (defined in AcDbHatch) | AcDbHatch |
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
HatchEdgeType enum name (defined in AcDbHatch) | AcDbHatch |
HatchLoopType enum name (defined in AcDbHatch) | AcDbHatch |
HatchObjectType enum name (defined in AcDbHatch) | AcDbHatch |
hatchObjectType() const (defined in AcDbHatch) | AcDbHatch |
HatchPatternType enum name (defined in AcDbHatch) | AcDbHatch |
hatchStyle() const (defined in AcDbHatch) | AcDbHatch |
HatchStyle enum name (defined in AcDbHatch) | AcDbHatch |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
insertLoopAt(int loopIndex, Adesk::Int32 loopType, const AcGeVoidPointerArray &edgePtrs, const AcGeIntArray &edgeTypes) (defined in AcDbHatch) | AcDbHatch |
insertLoopAt(int loopIndex, Adesk::Int32 loopType, const AcGePoint2dArray &vertices, const AcGeDoubleArray &bulges) (defined in AcDbHatch) | AcDbHatch |
insertLoopAt(int loopIndex, Adesk::Int32 loopType, const AcDbObjectIdArray &dbObjIds) (defined in AcDbHatch) | AcDbHatch |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isGradient() const (defined in AcDbHatch) | AcDbHatch | virtual
isHatch() const (defined in AcDbHatch) | AcDbHatch | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbHatch) | AcDbHatch | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isSolidFill() const (defined in AcDbHatch) | AcDbHatch |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kCirArc enum value (defined in AcDbHatch) | AcDbHatch |
kCustomDefined enum value (defined in AcDbHatch) | AcDbHatch |
kDefault enum value (defined in AcDbHatch) | AcDbHatch |
kDerived enum value (defined in AcDbHatch) | AcDbHatch |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDoesNotSupportScale enum value (defined in AcDbHatch) | AcDbHatch |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDuplicate enum value (defined in AcDbHatch) | AcDbHatch |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kEllArc enum value (defined in AcDbHatch) | AcDbHatch |
kExternal enum value (defined in AcDbHatch) | AcDbHatch |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kForceAnnoAllVisible enum value (defined in AcDbHatch) | AcDbHatch |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientObject enum value (defined in AcDbHatch) | AcDbHatch |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHatchObject enum value (defined in AcDbHatch) | AcDbHatch |
kIgnore enum value (defined in AcDbHatch) | AcDbHatch |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kIsAnnotative enum value (defined in AcDbHatch) | AcDbHatch |
kIsAnnotativeBlock enum value (defined in AcDbHatch) | AcDbHatch |
kLine enum value (defined in AcDbHatch) | AcDbHatch |
kNormal enum value (defined in AcDbHatch) | AcDbHatch |
kNotClosed enum value (defined in AcDbHatch) | AcDbHatch |
kOrientToPaper enum value (defined in AcDbHatch) | AcDbHatch |
kOuter enum value (defined in AcDbHatch) | AcDbHatch |
kOutermost enum value (defined in AcDbHatch) | AcDbHatch |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kPolyline enum value (defined in AcDbHatch) | AcDbHatch |
kPreDefined enum value (defined in AcDbHatch) | AcDbHatch |
kPreDefinedGradient enum value (defined in AcDbHatch) | AcDbHatch |
kSelfIntersecting enum value (defined in AcDbHatch) | AcDbHatch |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpline enum value (defined in AcDbHatch) | AcDbHatch |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kTextbox enum value (defined in AcDbHatch) | AcDbHatch |
kTextIsland enum value (defined in AcDbHatch) | AcDbHatch |
kUserDefined enum value (defined in AcDbHatch) | AcDbHatch |
kUserDefinedGradient enum value (defined in AcDbHatch) | AcDbHatch |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
lineGenerationEnabled() const (defined in AcDbHatch) | AcDbHatch |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
loopTypeAt(int loopIndex) const (defined in AcDbHatch) | AcDbHatch |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *pObj) (defined in AcDbHatch) | AcDbHatch | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbHatch) | AcDbHatch |
numHatchLines() const (defined in AcDbHatch) | AcDbHatch |
numLoops() const (defined in AcDbHatch) | AcDbHatch |
numPatternDefinitions() const (defined in AcDbHatch) | AcDbHatch |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
originPoint() const (defined in AcDbHatch) | AcDbHatch |
ownerId() const (defined in AcDbObject) | AcDbObject |
patternAngle() const (defined in AcDbHatch) | AcDbHatch |
patternDouble() const (defined in AcDbHatch) | AcDbHatch |
patternName() const (defined in AcDbHatch) | AcDbHatch |
patternScale() const (defined in AcDbHatch) | AcDbHatch |
patternSpace() const (defined in AcDbHatch) | AcDbHatch |
patternType() const (defined in AcDbHatch) | AcDbHatch |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbHatch) | AcDbHatch | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeAssocObjIds() (defined in AcDbHatch) | AcDbHatch |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeHatchLines() (defined in AcDbHatch) | AcDbHatch |
removeLoopAt(int loopIndex) (defined in AcDbHatch) | AcDbHatch |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAssociative(bool isAssociative) (defined in AcDbHatch) | AcDbHatch |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbHatch) | AcDbHatch | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setElevation(double elevation) (defined in AcDbHatch) | AcDbHatch |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGradient(AcDbHatch::GradientPatternType gradType, const ACHAR *gradName) (defined in AcDbHatch) | AcDbHatch |
setGradientAngle(double angle) (defined in AcDbHatch) | AcDbHatch |
setGradientColors(unsigned int count, AcCmColor *colors, float *values) (defined in AcDbHatch) | AcDbHatch |
setGradientOneColorMode(Adesk::Boolean oneColorMode) (defined in AcDbHatch) | AcDbHatch |
setGradientShift(float shiftValue) (defined in AcDbHatch) | AcDbHatch |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHatchObjectType(AcDbHatch::HatchObjectType type) (defined in AcDbHatch) | AcDbHatch |
setHatchStyle(AcDbHatch::HatchStyle hstyle) (defined in AcDbHatch) | AcDbHatch |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLineGenerationEnabled(bool bEnable) (defined in AcDbHatch) | AcDbHatch |
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &normal) (defined in AcDbHatch) | AcDbHatch |
setOriginPoint(const AcGePoint2d &pt) (defined in AcDbHatch) | AcDbHatch |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPattern(AcDbHatch::HatchPatternType patType, const ACHAR *patName) (defined in AcDbHatch) | AcDbHatch |
setPatternAngle(double angle) (defined in AcDbHatch) | AcDbHatch |
setPatternDouble(bool isDouble) (defined in AcDbHatch) | AcDbHatch |
setPatternScale(double scale) (defined in AcDbHatch) | AcDbHatch |
setPatternSpace(double space) (defined in AcDbHatch) | AcDbHatch |
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbHatch) | AcDbHatch | virtual
setShadeTintValue(float value) (defined in AcDbHatch) | AcDbHatch |
setShadeTintValueAndColor2(float value) (defined in AcDbHatch) | AcDbHatch |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbHatch) | AcDbHatch | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbHatch) | AcDbHatch | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbHatch() (defined in AcDbHatch) | AcDbHatch | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbHelix Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbHelix Class Reference
AcDb Classes
+ Inheritance diagram for AcDbHelix:

Public Types

enum ConstrainType { kTurnHeight = 0, kTurns = 1, kHeight = 2 }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbHelix)
virtual AcGePoint3d | axisPoint () const
virtual AcGeVector3d | axisVector () const
virtual double | baseRadius () const
virtual ConstrainType | constrain () const
Acad::ErrorStatus | createHelix ()
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual double | height () const
virtual Acad::ErrorStatus | setAxisPoint (const AcGePoint3d &axisPoint, const bool bMoveStartPoint=true)
virtual Acad::ErrorStatus | setAxisVector (const AcGeVector3d &axisVector)
virtual Acad::ErrorStatus | setBaseRadius (double dRadius)
virtual Acad::ErrorStatus | setConstrain (ConstrainType constrain)
virtual Acad::ErrorStatus | setHeight (double dHeight)
virtual Acad::ErrorStatus | setStartPoint (const AcGePoint3d &startPoint)
virtual Acad::ErrorStatus | setTopRadius (double dRadius)
virtual Acad::ErrorStatus | setTurnHeight (double dTurnHeight)
virtual Acad::ErrorStatus | setTurns (double dTurns)
virtual Acad::ErrorStatus | setTwist (Adesk::Boolean bTwist)
virtual AcGePoint3d | startPoint () const
virtual double | topRadius () const
virtual double | totalLength () const
virtual double | turnHeight () const
virtual double | turns () const
virtual double | turnSlope () const
virtual Adesk::Boolean | twist () const
- Public Member Functions inherited from AcDbSpline
ACDB_DECLARE_MEMBERS (AcDbSpline)
AcDbSpline (const AcGePoint3dArray &points, int order=4, double fitTolerance=0.0)
AcDbSpline (const AcGePoint3dArray &points, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, int order=4, double fitTolerance=0.0)
AcDbSpline (int degree, Adesk::Boolean rational, Adesk::Boolean closed, Adesk::Boolean periodic, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &knots, const AcGeDoubleArray &weights, double controlPtTol=0.0, double knotTol=0.0)
AcDbSpline (const AcGePoint3d &center, const AcGeVector3d &unitNormal, const AcGeVector3d &majorAxis, double radiusRatio, double startAngle=0.0, double endAngle=6.28318530717958647692)
virtual bool | castShadows () const
int | degree () const
Acad::ErrorStatus | elevateDegree (int newDegree)
double | fitTolerance () const
Acad::ErrorStatus | getControlPointAt (int index, AcGePoint3d &point) const
Acad::ErrorStatus | getFitData (AcGePoint3dArray &fitPoints, int &degree, double &fitTolerance, Adesk::Boolean &tangentsExist, AcGeVector3d &startTangent, AcGeVector3d &endTangent) const
Acad::ErrorStatus | getFitPointAt (int index, AcGePoint3d &point) const
Acad::ErrorStatus | getFitTangents (AcGeVector3d &startTangent, AcGeVector3d &endTangent) const
Acad::ErrorStatus | getNurbsData (int &degree, Adesk::Boolean &rational, Adesk::Boolean &closed, Adesk::Boolean &periodic, AcGePoint3dArray &controlPoints, AcGeDoubleArray &knots, AcGeDoubleArray &weights, double &controlPtTol, double &knotTol) const
Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
Adesk::Boolean | hasFitData () const
Acad::ErrorStatus | insertFitPointAt (int index, const AcGePoint3d &point)
Acad::ErrorStatus | insertKnot (double param)
Adesk::Boolean | isNull () const
Adesk::Boolean | isRational () const
int | numControlPoints () const
int | numFitPoints () const
Acad::ErrorStatus | purgeFitData ()
virtual bool | receiveShadows () const
Acad::ErrorStatus | removeFitPointAt (int index)
Acad::ErrorStatus | reverseCurve ()
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setControlPointAt (int index, const AcGePoint3d &point)
Acad::ErrorStatus | setFitData (const AcGePoint3dArray &fitPoints, int degree, double fitTolerance, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent)
Acad::ErrorStatus | setFitPointAt (int index, const AcGePoint3d &point)
Acad::ErrorStatus | setFitTangents (const AcGeVector3d &startTangent, const AcGeVector3d &endTangent)
Acad::ErrorStatus | setFitTol (double tol)
Acad::ErrorStatus | setNurbsData (int degree, Adesk::Boolean rational, Adesk::Boolean closed, Adesk::Boolean periodic, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &knots, const AcGeDoubleArray &weights, double controlPtTol, double knotTol)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setWeightAt (int index, double weight)
Acad::ErrorStatus | toPolyline (AcDbCurve *&pCurve, int precision=10, int *maxSuggestedPrecision=NULL, unsigned int numOfVerticesThreshold=kPlineVerticesThrehold) const
Acad::ErrorStatus | updateFitData ()
double | weightAt (int index) const
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbhelix.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbHelix Member List

This is the complete list of members for AcDbHelix, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbHelix) (defined in AcDbHelix) | AcDbHelix |
ACDB_DECLARE_MEMBERS(AcDbSpline) (defined in AcDbSpline) | AcDbSpline |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbHelix() (defined in AcDbHelix) | AcDbHelix |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSpline() (defined in AcDbSpline) | AcDbSpline |
AcDbSpline(const AcGePoint3dArray &points, int order=4, double fitTolerance=0.0) (defined in AcDbSpline) | AcDbSpline |
AcDbSpline(const AcGePoint3dArray &points, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, int order=4, double fitTolerance=0.0) (defined in AcDbSpline) | AcDbSpline |
AcDbSpline(int degree, Adesk::Boolean rational, Adesk::Boolean closed, Adesk::Boolean periodic, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &knots, const AcGeDoubleArray &weights, double controlPtTol=0.0, double knotTol=0.0) (defined in AcDbSpline) | AcDbSpline |
AcDbSpline(const AcGePoint3d &center, const AcGeVector3d &unitNormal, const AcGeVector3d &majorAxis, double radiusRatio, double startAngle=0.0, double endAngle=6.28318530717958647692) (defined in AcDbSpline) | AcDbSpline |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
axisPoint() const (defined in AcDbHelix) | AcDbHelix | virtual
axisVector() const (defined in AcDbHelix) | AcDbHelix | virtual
baseRadius() const (defined in AcDbHelix) | AcDbHelix | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbSpline) | AcDbSpline | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
constrain() const (defined in AcDbHelix) | AcDbHelix | virtual
ConstrainType enum name (defined in AcDbHelix) | AcDbHelix |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createHelix() (defined in AcDbHelix) | AcDbHelix |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
degree() const (defined in AcDbSpline) | AcDbSpline |
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevateDegree(int newDegree) (defined in AcDbSpline) | AcDbSpline |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fitTolerance() const (defined in AcDbSpline) | AcDbSpline |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbHelix) | AcDbHelix | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getControlPointAt(int index, AcGePoint3d &point) const (defined in AcDbSpline) | AcDbSpline |
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFitData(AcGePoint3dArray &fitPoints, int &degree, double &fitTolerance, Adesk::Boolean &tangentsExist, AcGeVector3d &startTangent, AcGeVector3d &endTangent) const (defined in AcDbSpline) | AcDbSpline |
getFitPointAt(int index, AcGePoint3d &point) const (defined in AcDbSpline) | AcDbSpline |
getFitTangents(AcGeVector3d &startTangent, AcGeVector3d &endTangent) const (defined in AcDbSpline) | AcDbSpline |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getNurbsData(int &degree, Adesk::Boolean &rational, Adesk::Boolean &closed, Adesk::Boolean &periodic, AcGePoint3dArray &controlPoints, AcGeDoubleArray &knots, AcGeDoubleArray &weights, double &controlPtTol, double &knotTol) const (defined in AcDbSpline) | AcDbSpline |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbSpline) | AcDbSpline | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbHelix) | AcDbHelix | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasFitData() const (defined in AcDbSpline) | AcDbSpline |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height() const (defined in AcDbHelix) | AcDbHelix | virtual
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
insertFitPointAt(int index, const AcGePoint3d &point) (defined in AcDbSpline) | AcDbSpline |
insertKnot(double param) (defined in AcDbSpline) | AcDbSpline |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isNull() const (defined in AcDbSpline) | AcDbSpline |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isRational() const (defined in AcDbSpline) | AcDbSpline |
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHeight enum value (defined in AcDbHelix) | AcDbHelix |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kTurnHeight enum value (defined in AcDbHelix) | AcDbHelix |
kTurns enum value (defined in AcDbHelix) | AcDbHelix |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
numControlPoints() const (defined in AcDbSpline) | AcDbSpline |
numFitPoints() const (defined in AcDbSpline) | AcDbSpline |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
purgeFitData() (defined in AcDbSpline) | AcDbSpline |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbSpline) | AcDbSpline | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeFitPointAt(int index) (defined in AcDbSpline) | AcDbSpline |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
reverseCurve() (defined in AcDbSpline) | AcDbSpline |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setAxisPoint(const AcGePoint3d &axisPoint, const bool bMoveStartPoint=true) (defined in AcDbHelix) | AcDbHelix | virtual
setAxisVector(const AcGeVector3d &axisVector) (defined in AcDbHelix) | AcDbHelix | virtual
setBaseRadius(double dRadius) (defined in AcDbHelix) | AcDbHelix | virtual
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbSpline) | AcDbSpline | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setConstrain(ConstrainType constrain) (defined in AcDbHelix) | AcDbHelix | virtual
setControlPointAt(int index, const AcGePoint3d &point) (defined in AcDbSpline) | AcDbSpline |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFitData(const AcGePoint3dArray &fitPoints, int degree, double fitTolerance, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent) (defined in AcDbSpline) | AcDbSpline |
setFitPointAt(int index, const AcGePoint3d &point) (defined in AcDbSpline) | AcDbSpline |
setFitTangents(const AcGeVector3d &startTangent, const AcGeVector3d &endTangent) (defined in AcDbSpline) | AcDbSpline |
setFitTol(double tol) (defined in AcDbSpline) | AcDbSpline |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double dHeight) (defined in AcDbHelix) | AcDbHelix | virtual
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNurbsData(int degree, Adesk::Boolean rational, Adesk::Boolean closed, Adesk::Boolean periodic, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &knots, const AcGeDoubleArray &weights, double controlPtTol, double knotTol) (defined in AcDbSpline) | AcDbSpline |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbSpline) | AcDbSpline | virtual
setStartPoint(const AcGePoint3d &startPoint) (defined in AcDbHelix) | AcDbHelix | virtual
setTopRadius(double dRadius) (defined in AcDbHelix) | AcDbHelix | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setTurnHeight(double dTurnHeight) (defined in AcDbHelix) | AcDbHelix | virtual
setTurns(double dTurns) (defined in AcDbHelix) | AcDbHelix | virtual
setTwist(Adesk::Boolean bTwist) (defined in AcDbHelix) | AcDbHelix | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWeightAt(int index, double weight) (defined in AcDbSpline) | AcDbSpline |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
startPoint() const (defined in AcDbHelix) | AcDbHelix | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
toPolyline(AcDbCurve *&pCurve, int precision=10, int *maxSuggestedPrecision=NULL, unsigned int numOfVerticesThreshold=kPlineVerticesThrehold) const (defined in AcDbSpline) | AcDbSpline |
topRadius() const (defined in AcDbHelix) | AcDbHelix | virtual
totalLength() const (defined in AcDbHelix) | AcDbHelix | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
turnHeight() const (defined in AcDbHelix) | AcDbHelix | virtual
turns() const (defined in AcDbHelix) | AcDbHelix | virtual
turnSlope() const (defined in AcDbHelix) | AcDbHelix | virtual
twist() const (defined in AcDbHelix) | AcDbHelix | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
updateFitData() (defined in AcDbSpline) | AcDbSpline |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
weightAt(int index) const (defined in AcDbSpline) | AcDbSpline |
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbHelix() (defined in AcDbHelix) | AcDbHelix | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSpline() (defined in AcDbSpline) | AcDbSpline | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbHostApplicationProgressMeter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbHostApplicationProgressMeter Class Reference
AcDb Classes

Public Member Functions

virtual void | meterProgress ()
virtual void | setLimit (int max)
virtual void | start (const ACHAR *displayString=NULL)
virtual void | stop ()
The documentation for this class was generated from the following file:
  • dbapserv.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbHostApplicationProgressMeter Member List

This is the complete list of members for AcDbHostApplicationProgressMeter, including all inherited members.

AcDbHostApplicationProgressMeter() (defined in AcDbHostApplicationProgressMeter) | AcDbHostApplicationProgressMeter |
meterProgress() (defined in AcDbHostApplicationProgressMeter) | AcDbHostApplicationProgressMeter | virtual
setLimit(int max) (defined in AcDbHostApplicationProgressMeter) | AcDbHostApplicationProgressMeter | virtual
start(const ACHAR *displayString=NULL) (defined in AcDbHostApplicationProgressMeter) | AcDbHostApplicationProgressMeter | virtual
stop() (defined in AcDbHostApplicationProgressMeter) | AcDbHostApplicationProgressMeter | virtual
~AcDbHostApplicationProgressMeter() (defined in AcDbHostApplicationProgressMeter) | AcDbHostApplicationProgressMeter | virtual


ZRX API Reference: AcDbHostApplicationServices Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AcDbHostApplicationServices Class Reference
AcDb Classes
+ Inheritance diagram for AcDbHostApplicationServices:

Public Types

enum FindFileHint {
kDefault = 0, kFontFile, kCompiledShapeFile, kTrueTypeFontFile,
kEmbeddedImageFile, kXRefDrawing, kPatternFile, kARXApplication,
kFontMapFile, kUnderlayFile
}
enum | ModelerFlavor { kModelerFull = 0, kModelerRegionsOnly = 1, kModelerObjectsOnly = 2 }
enum | PasswordOptions { kPasswordOptionDefault = 0, kPasswordOptionUpperCase = 1, kPasswordOptionIsExternalReference = 2 }
enum | RemapFileContext { kDrawingOpen, kXrefResolution, kRasterResolution, kAfterXrefResolution }

Public Member Functions

virtual Adesk::Boolean | _entToWorldTransform (double normal[3], flagmat *tran)
void * | acadInternalGetvar (const ACHAR *name)
virtual AcadInternalServices * | acadInternalServices ()
AcDbHostApplicationServices (int createGlobals=1)
ACRX_DECLARE_MEMBERS (AcDbHostApplicationServices)
virtual void | alert (const ACHAR *string) const
virtual void | auditPrintReport (AcDbAuditInfo *pAuditInfo, const ACHAR *line, int both) const
virtual bool | cacheSymbolIndices () const
virtual const ACHAR * | companyName ()
virtual AcDbGlobals * | createWorkingGlobals ()
virtual AcDbUndoController * | defaultUndoController ()
virtual void | displayChar (ACHAR c) const
virtual void | displayString (const ACHAR *string, int count) const
virtual Adesk::Boolean | doFullCRCCheck ()
virtual void | drawOleOwnerDrawItem (COleClientItem *pItem, Adesk::LongPtr hdc, long left, long top, long right, long bottom)
virtual void | enableMessageDisplay (Adesk::Boolean)
virtual void | fatalError (const ACHAR *format,...)
virtual Acad::ErrorStatus | findFile (ACHAR *pcFullPathOut, int nBufferLength, const ACHAR *pcFilename, AcDbDatabase *pDb=NULL, AcDbHostApplicationServices::FindFileHint hint=kDefault)=0
virtual ACHAR * | getAlternateFontName () const
virtual const ACHAR * | getColorBookLocation () const
virtual void | getDefaultPlotCfgInfo (ACHAR *plotDeviceName, ACHAR *plotStyleName)
virtual const ACHAR * | getEnv (const ACHAR *var)
virtual ACHAR * | getFontMapFileName () const
virtual Acad::ErrorStatus | getLocalRootFolder (const ACHAR *&folder)
virtual ModelerFlavor | getModelerFlavor () const
virtual Acad::ErrorStatus | getNewOleClientItem (COleClientItem *&pItem)
virtual bool | getPassword (const ACHAR *dwgName, PasswordOptions options, wchar_t *password, const size_t bufSize)
AcPwdCache * | getPasswordCache () const
virtual Acad::ErrorStatus | getRegisteredFileMapClients (AcArray< const ACHAR * > &clients)
virtual Acad::ErrorStatus | getRegisteredSelectFileClients (AcArray< const ACHAR * > &clients)
virtual LCID | getRegistryProductLCID ()
virtual const ACHAR * | getRegistryProductRootKey ()
virtual Acad::ErrorStatus | getRemoteFile (const ACHAR *pszURL, ACHAR *pszLocalFile, Adesk::Boolean bIgnoreCache=Adesk::kFalse) const
virtual Acad::ErrorStatus | getRoamableRootFolder (const ACHAR *&folder)
virtual Adesk::Boolean | getSubstituteFont (ACHAR **pFileName, ACHAR *prompt, int type, int fontAlt)
code_page_id | getSystemCodePage () const
virtual unsigned int | getTempPath (Adesk::UInt32 lBufferSize, ACHAR *pcBuffer)
virtual Adesk::Boolean | isRemoteFile (const ACHAR *pszLocalFile, ACHAR *pszURL) const
virtual Adesk::Boolean | isURL (const ACHAR *pszURL) const
virtual Adesk::Boolean | launchBrowserDialog (ACHAR *pszSelectedURL, const ACHAR *pszDialogTitle, const ACHAR *pszOpenButtonCaption, const ACHAR *pszStartURL, const ACHAR *pszRegistryRootKey=0, Adesk::Boolean bOpenButtonAlwaysEnabled=Adesk::kFalse) const
virtual AcDbLayoutManager * | layoutManager () const
virtual bool | loadApp (const ACHAR *appName, AcadApp::LoadReasons why, bool printit, bool asCmd)
virtual Acad::ErrorStatus | mapFile (ACHAR *&newName, const ACHAR *filename, int context, void *pReserved)
virtual void | missingCryptoProviderMsg ()
virtual ClipBoundaryArray * | newClipBoundaryArray ()
virtual
AcDbAbstractClipBoundaryDefinition * 		newClipBoundaryPolygonal ()
virtual
AcDbAbstractClipBoundaryDefinition * 		newClipBoundaryRectangular ()
virtual
AcDbHostApplicationProgressMeter * 		newProgressMeter ()
virtual AcDbPlotSettingsValidator * | plotSettingsValidator () const
virtual const ACHAR * | primaryClientForMapFileCallback ()
virtual const ACHAR * | primaryClientForSelectFileCallback ()
virtual const ProdIdCode | prodcode ()
virtual const ACHAR * | product ()
virtual const ACHAR * | program ()
virtual Acad::ErrorStatus | putRemoteFile (const ACHAR *pszURL, const ACHAR *pszLocalFile) const
virtual Adesk::Boolean | readyToDisplayMessages ()
virtual Acad::ErrorStatus | registerMapFileCallback (const ACHAR *appName, REMAPPROC proc, bool unRegister=false, bool asPrimary=false)
virtual Acad::ErrorStatus | registerMapFileNotification (const ACHAR *appName, MAPFILENOTIFYPROC, bool unRegister=false)
virtual Acad::ErrorStatus | registerSelectFileCallback (const ACHAR *appName, SELECTFILEPROC proc, bool unRegister=false, bool asPrimary=false)
virtual const ACHAR * | releaseMajorMinorString ()
virtual int | releaseMajorVersion ()
virtual int | releaseMinorVersion ()
virtual void | reportUnhandledArxException (const _EXCEPTION_POINTERS *pExcPtrs, const ACHAR *pAppName)
virtual Acad::ErrorStatus | selectFile (short *userCancel, ACHAR *&chosenPath, void *h, const int nFlags, const ACHAR *prompt, const ACHAR *dir, const ACHAR *name, const ACHAR *type, int *pnChoice, bool *pbReadOnly, const ACHAR *pszWSTags, void *pReserved)
virtual Acad::ErrorStatus | serializeOleItem (COleClientItem *pItem, CArchive *)
void | setDefaultUndoController (AcDbUndoController *pUndoCtrl)
virtual bool | setMapFlag (bool setIt)
void | setSystemCodePage (code_page_id)
void | setWorkingAppSysvars (AcDbAppSystemVariables *pSysvars)
void | setWorkingDatabase (AcDbDatabase *pDatabase)
void | setWorkingGlobals (AcDbGlobals *pGlobals)
void | setWorkingProgressMeter (AcDbHostApplicationProgressMeter *pNewMeter)
void | setWorkingTransactionManager (AcDbTransactionManager *pTM)
virtual Acad::ErrorStatus | signingComplete (Acad::ErrorStatus es, const ACHAR *msg, bool *result)
virtual bool | supportsMultiRedo () const
virtual void | terminateScript ()
virtual void | usedPasswordFromCacheMsg (const ACHAR *dwgName)
virtual Adesk::Boolean | userBreak (bool updCtrlsWhenEnteringIdle=true) const
virtual const ACHAR * | versionString ()
AcDbAppSystemVariables * | workingAppSysvars () const
AcDbDatabase * | workingDatabase () const
AcDbGlobals * | workingGlobals () const
virtual AcDbTransactionManager * | workingTransactionManager ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

void | acadInternalSetvar (const ACHAR *name, void *var)
Acad::ErrorStatus | mapInetStatusToAcadStatus (const AcadInet::Status status) const

Protected Attributes

void * mp_sessionVars

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Member Function Documentation

virtual bool AcDbHostApplicationServices::getPassword | ( | const ACHAR * | dwgName,
 |  | PasswordOptions | options,
 |  | wchar_t * | password,
 |  | const size_t | bufSize
 | ) |  |
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbapserv.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbHostApplicationServices Member List

This is the complete list of members for AcDbHostApplicationServices, including all inherited members.

_entToWorldTransform(double normal[3], flagmat *tran) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
acadInternalGetvar(const ACHAR *name) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
acadInternalServices() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
acadInternalSetvar(const ACHAR *name, void *var) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | protected
AcDbHostApplicationServices(int createGlobals=1) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
ACRX_DECLARE_MEMBERS(AcDbHostApplicationServices) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
alert(const ACHAR *string) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
auditPrintReport(AcDbAuditInfo *pAuditInfo, const ACHAR *line, int both) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
cacheSymbolIndices() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
companyName() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
createWorkingGlobals() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
defaultUndoController() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
desc() (defined in AcRxObject) | AcRxObject | static
displayChar(ACHAR c) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
displayString(const ACHAR *string, int count) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
doFullCRCCheck() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
drawOleOwnerDrawItem(COleClientItem *pItem, Adesk::LongPtr hdc, long left, long top, long right, long bottom) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
enableMessageDisplay(Adesk::Boolean) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
fatalError(const ACHAR *format,...) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
findFile(ACHAR *pcFullPathOut, int nBufferLength, const ACHAR *pcFilename, AcDbDatabase *pDb=NULL, AcDbHostApplicationServices::FindFileHint hint=kDefault)=0 (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | pure virtual
FindFileHint enum name (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
getAlternateFontName() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
getColorBookLocation() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
getDefaultPlotCfgInfo(ACHAR *plotDeviceName, ACHAR *plotStyleName) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
getEnv(const ACHAR *var) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
getFontMapFileName() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
getLocalRootFolder(const ACHAR *&folder) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
getModelerFlavor() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
getNewOleClientItem(COleClientItem *&pItem) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
getPassword(const ACHAR *dwgName, PasswordOptions options, wchar_t *password, const size_t bufSize) | AcDbHostApplicationServices | virtual
getPasswordCache() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inline
getRegisteredFileMapClients(AcArray< const ACHAR * > &clients) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
getRegisteredSelectFileClients(AcArray< const ACHAR * > &clients) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
getRegistryProductLCID() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
getRegistryProductRootKey() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
getRemoteFile(const ACHAR *pszURL, ACHAR *pszLocalFile, Adesk::Boolean bIgnoreCache=Adesk::kFalse) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
getRoamableRootFolder(const ACHAR *&folder) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
getSubstituteFont(ACHAR **pFileName, ACHAR *prompt, int type, int fontAlt) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
getSystemCodePage() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inline
getTempPath(Adesk::UInt32 lBufferSize, ACHAR *pcBuffer) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isRemoteFile(const ACHAR *pszLocalFile, ACHAR *pszURL) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
isURL(const ACHAR *pszURL) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
kAfterXrefResolution enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kARXApplication enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kCompiledShapeFile enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kDefault enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kDrawingOpen enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kEmbeddedImageFile enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kFontFile enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kFontMapFile enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kModelerFull enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kModelerObjectsOnly enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kModelerRegionsOnly enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kPasswordOptionDefault enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kPasswordOptionIsExternalReference enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kPasswordOptionUpperCase enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kPatternFile enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kRasterResolution enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kTrueTypeFontFile enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kUnderlayFile enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kXRefDrawing enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
kXrefResolution enum value (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
launchBrowserDialog(ACHAR *pszSelectedURL, const ACHAR *pszDialogTitle, const ACHAR *pszOpenButtonCaption, const ACHAR *pszStartURL, const ACHAR *pszRegistryRootKey=0, Adesk::Boolean bOpenButtonAlwaysEnabled=Adesk::kFalse) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
layoutManager() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
loadApp(const ACHAR *appName, AcadApp::LoadReasons why, bool printit, bool asCmd) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
mapFile(ACHAR *&newName, const ACHAR *filename, int context, void *pReserved) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
mapInetStatusToAcadStatus(const AcadInet::Status status) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | protected
missingCryptoProviderMsg() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
ModelerFlavor enum name (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
mp_sessionVars (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | protected
newClipBoundaryArray() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
newClipBoundaryPolygonal() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
newClipBoundaryRectangular() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
newProgressMeter() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
PasswordOptions enum name (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
plotSettingsValidator() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
primaryClientForMapFileCallback() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
primaryClientForSelectFileCallback() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
prodcode() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
product() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
program() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
putRemoteFile(const ACHAR *pszURL, const ACHAR *pszLocalFile) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readyToDisplayMessages() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
registerMapFileCallback(const ACHAR *appName, REMAPPROC proc, bool unRegister=false, bool asPrimary=false) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
registerMapFileNotification(const ACHAR *appName, MAPFILENOTIFYPROC, bool unRegister=false) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
registerSelectFileCallback(const ACHAR *appName, SELECTFILEPROC proc, bool unRegister=false, bool asPrimary=false) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
releaseMajorMinorString() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
releaseMajorVersion() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
releaseMinorVersion() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
RemapFileContext enum name (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
reportUnhandledArxException(const _EXCEPTION_POINTERS *pExcPtrs, const ACHAR *pAppName) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
selectFile(short *userCancel, ACHAR *&chosenPath, void *h, const int nFlags, const ACHAR *prompt, const ACHAR *dir, const ACHAR *name, const ACHAR *type, int *pnChoice, bool *pbReadOnly, const ACHAR *pszWSTags, void *pReserved) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
serializeOleItem(COleClientItem *pItem, CArchive *) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
setDefaultUndoController(AcDbUndoController *pUndoCtrl) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
setMapFlag(bool setIt) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
setSystemCodePage(code_page_id) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
setWorkingAppSysvars(AcDbAppSystemVariables *pSysvars) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inline
setWorkingDatabase(AcDbDatabase *pDatabase) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
setWorkingGlobals(AcDbGlobals *pGlobals) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
setWorkingProgressMeter(AcDbHostApplicationProgressMeter *pNewMeter) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
setWorkingTransactionManager(AcDbTransactionManager *pTM) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices |
signingComplete(Acad::ErrorStatus es, const ACHAR *msg, bool *result) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
supportsMultiRedo() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
terminateScript() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
usedPasswordFromCacheMsg(const ACHAR *dwgName) (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
userBreak(bool updCtrlsWhenEnteringIdle=true) const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
versionString() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
workingAppSysvars() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inline
workingDatabase() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inline
workingGlobals() const (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inline
workingTransactionManager() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbHostApplicationServices() (defined in AcDbHostApplicationServices) | AcDbHostApplicationServices | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbHyperlink Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbHyperlink Class Reference
AcDb Classes

Public Types

enum HLinkFlags { kUndefined = 0, kConvertDwgToDwf = 0x1 }

Public Member Functions

virtual const ACHAR * | description () const =0
virtual const long | flags () const
virtual const ACHAR * | getDisplayString () const =0
virtual const int | getNestedLevel () const =0
virtual bool | isOutermostContainer () const =0
virtual const ACHAR * | name () const =0
virtual void | setDescription (const ACHAR *cDescription)=0
virtual void | setFlags (const long lFlags)
virtual void | setName (const ACHAR *cName)=0
virtual void | setSubLocation (const ACHAR *cSubLocation)=0
virtual const ACHAR * | subLocation () const =0
The documentation for this class was generated from the following file:
  • achapi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbHyperlink Member List

This is the complete list of members for AcDbHyperlink, including all inherited members.

AcDbHyperlink() (defined in AcDbHyperlink) | AcDbHyperlink | inline
description() const =0 (defined in AcDbHyperlink) | AcDbHyperlink | pure virtual
flags() const (defined in AcDbHyperlink) | AcDbHyperlink | inlinevirtual
getDisplayString() const =0 (defined in AcDbHyperlink) | AcDbHyperlink | pure virtual
getNestedLevel() const =0 (defined in AcDbHyperlink) | AcDbHyperlink | pure virtual
HLinkFlags enum name (defined in AcDbHyperlink) | AcDbHyperlink |
isOutermostContainer() const =0 (defined in AcDbHyperlink) | AcDbHyperlink | pure virtual
kConvertDwgToDwf enum value (defined in AcDbHyperlink) | AcDbHyperlink |
kUndefined enum value (defined in AcDbHyperlink) | AcDbHyperlink |
name() const =0 (defined in AcDbHyperlink) | AcDbHyperlink | pure virtual
setDescription(const ACHAR *cDescription)=0 (defined in AcDbHyperlink) | AcDbHyperlink | pure virtual
setFlags(const long lFlags) (defined in AcDbHyperlink) | AcDbHyperlink | inlinevirtual
setName(const ACHAR *cName)=0 (defined in AcDbHyperlink) | AcDbHyperlink | pure virtual
setSubLocation(const ACHAR *cSubLocation)=0 (defined in AcDbHyperlink) | AcDbHyperlink | pure virtual
subLocation() const =0 (defined in AcDbHyperlink) | AcDbHyperlink | pure virtual
~AcDbHyperlink() (defined in AcDbHyperlink) | AcDbHyperlink | inlinevirtual


ZRX API Reference: AcDbHyperlinkCollection Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbHyperlinkCollection Class Reference
AcDb Classes

Public Member Functions

virtual void | addAt (const int nIndex, const ACHAR *sName, const ACHAR *sDescription, const ACHAR *sSubLocation=NULL)=0
virtual void | addHead (const ACHAR *sName, const ACHAR *sDescription, const ACHAR *sSubLocation=NULL)=0
virtual void | addTail (const ACHAR *sName, const ACHAR *sDescription, const ACHAR *sSubLocation=NULL)=0
virtual int | count () const =0
virtual AcDbHyperlink * | item (const int nIndex) const =0
virtual void | removeAt (const int nIndex)=0
virtual void | removeHead ()=0
virtual void | removeTail ()=0
The documentation for this class was generated from the following file:
  • achapi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbHyperlinkCollection Member List

This is the complete list of members for AcDbHyperlinkCollection, including all inherited members.

AcDbHyperlinkCollection() (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | inline
addAt(const int nIndex, const ACHAR *sName, const ACHAR *sDescription, const ACHAR *sSubLocation=NULL)=0 (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | pure virtual
addHead(const ACHAR *sName, const ACHAR *sDescription, const ACHAR *sSubLocation=NULL)=0 (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | pure virtual
addTail(const ACHAR *sName, const ACHAR *sDescription, const ACHAR *sSubLocation=NULL)=0 (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | pure virtual
count() const =0 (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | pure virtual
item(const int nIndex) const =0 (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | pure virtual
removeAt(const int nIndex)=0 (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | pure virtual
removeHead()=0 (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | pure virtual
removeTail()=0 (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | pure virtual
~AcDbHyperlinkCollection() (defined in AcDbHyperlinkCollection) | AcDbHyperlinkCollection | inlinevirtual


ZRX API Reference: AcDbIdMapping Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbIdMapping Class Reference
AcDb Classes
+ Inheritance diagram for AcDbIdMapping:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbIdMapping)
virtual Acad::ErrorStatus | assign (const AcDbIdPair &)
virtual bool | change (const AcDbIdPair &)
virtual bool | compute (AcDbIdPair &) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
AcDb::DeepCloneType | deepCloneContext () const
virtual bool | del (AcDbObjectId key)
Acad::ErrorStatus | destDb (AcDbDatabase *&db) const
AcDb::DuplicateRecordCloning | duplicateRecordCloning () const
Acad::ErrorStatus | origDb (AcDbDatabase *&db) const
Acad::ErrorStatus | setDestDb (AcDbDatabase *db)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class | AcDbImpIdMappingIter
class | AcDbSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbidmap.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbIdMapping Member List

This is the complete list of members for AcDbIdMapping, including all inherited members.

AcDbIdMapping() (defined in AcDbIdMapping) | AcDbIdMapping |
AcDbImpIdMappingIter (defined in AcDbIdMapping) | AcDbIdMapping | friend
AcDbSystemInternals (defined in AcDbIdMapping) | AcDbIdMapping | friend
ACRX_DECLARE_MEMBERS(AcDbIdMapping) (defined in AcDbIdMapping) | AcDbIdMapping |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
assign(const AcDbIdPair &) (defined in AcDbIdMapping) | AcDbIdMapping | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
change(const AcDbIdPair &) (defined in AcDbIdMapping) | AcDbIdMapping | virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
compute(AcDbIdPair &) const (defined in AcDbIdMapping) | AcDbIdMapping | virtual
copyFrom(const AcRxObject *other) (defined in AcDbIdMapping) | AcDbIdMapping | virtual
deepCloneContext() const (defined in AcDbIdMapping) | AcDbIdMapping |
del(AcDbObjectId key) (defined in AcDbIdMapping) | AcDbIdMapping | virtual
desc() (defined in AcRxObject) | AcRxObject | static
destDb(AcDbDatabase *&db) const (defined in AcDbIdMapping) | AcDbIdMapping |
duplicateRecordCloning() const (defined in AcDbIdMapping) | AcDbIdMapping |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
origDb(AcDbDatabase *&db) const (defined in AcDbIdMapping) | AcDbIdMapping |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setDestDb(AcDbDatabase *db) (defined in AcDbIdMapping) | AcDbIdMapping |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbIdMapping() (defined in AcDbIdMapping) | AcDbIdMapping | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbIdMappingIter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbIdMappingIter Class Reference
AcDb Classes
+ Inheritance diagram for AcDbIdMappingIter:

Public Member Functions

AcDbIdMappingIter (const AcDbIdMapping &)
ACRX_DECLARE_MEMBERS (AcDbIdMappingIter)
virtual bool | done ()
virtual bool | getMap (AcDbIdPair &)
virtual Acad::ErrorStatus | iterateOn (const AcDbIdMapping &)
virtual bool | next ()
virtual void | start ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbidmap.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbIdMappingIter Member List

This is the complete list of members for AcDbIdMappingIter, including all inherited members.

AcDbIdMappingIter(const AcDbIdMapping &) (defined in AcDbIdMappingIter) | AcDbIdMappingIter |
AcDbSystemInternals (defined in AcDbIdMappingIter) | AcDbIdMappingIter | friend
ACRX_DECLARE_MEMBERS(AcDbIdMappingIter) (defined in AcDbIdMappingIter) | AcDbIdMappingIter |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() (defined in AcDbIdMappingIter) | AcDbIdMappingIter | virtual
getMap(AcDbIdPair &) (defined in AcDbIdMappingIter) | AcDbIdMappingIter | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
iterateOn(const AcDbIdMapping &) (defined in AcDbIdMappingIter) | AcDbIdMappingIter | virtual
next() (defined in AcDbIdMappingIter) | AcDbIdMappingIter | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
start() (defined in AcDbIdMappingIter) | AcDbIdMappingIter | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbIdMappingIter() (defined in AcDbIdMappingIter) | AcDbIdMappingIter | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbIdPair Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbIdPair Class Reference
AcDb Classes

Public Member Functions

AcDbIdPair (const AcDbIdPair &)
AcDbIdPair (AcDbObjectId key, AcDbObjectId value, bool isCloned, bool isPrimary=false, bool isOwnerXlated=true)
bool | isCloned () const
bool | isOwnerXlated () const
bool | isPrimary () const
AcDbObjectId | key () const
void | setIsCloned (bool isCloned)
void | setIsOwnerXlated (bool isOwnerXlated)
void | setIsPrimary (bool isPrimary)
void | setKey (AcDbObjectId)
void | setValue (AcDbObjectId)
AcDbObjectId | value () const
The documentation for this class was generated from the following file:
  • dbidmap.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbIdPair Member List

This is the complete list of members for AcDbIdPair, including all inherited members.

AcDbIdPair() (defined in AcDbIdPair) | AcDbIdPair |
AcDbIdPair(const AcDbIdPair &) (defined in AcDbIdPair) | AcDbIdPair |
AcDbIdPair(AcDbObjectId key, AcDbObjectId value, bool isCloned, bool isPrimary=false, bool isOwnerXlated=true) (defined in AcDbIdPair) | AcDbIdPair |
isCloned() const (defined in AcDbIdPair) | AcDbIdPair | inline
isOwnerXlated() const (defined in AcDbIdPair) | AcDbIdPair | inline
isPrimary() const (defined in AcDbIdPair) | AcDbIdPair | inline
key() const (defined in AcDbIdPair) | AcDbIdPair | inline
setIsCloned(bool isCloned) (defined in AcDbIdPair) | AcDbIdPair | inline
setIsOwnerXlated(bool isOwnerXlated) (defined in AcDbIdPair) | AcDbIdPair | inline
setIsPrimary(bool isPrimary) (defined in AcDbIdPair) | AcDbIdPair | inline
setKey(AcDbObjectId) (defined in AcDbIdPair) | AcDbIdPair | inline
setValue(AcDbObjectId) (defined in AcDbIdPair) | AcDbIdPair | inline
value() const (defined in AcDbIdPair) | AcDbIdPair | inline


ZRX API Reference: AcDbImage Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbImage Class Reference
AcDb Classes
+ Inheritance diagram for AcDbImage:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbImage)
virtual Adesk::Boolean | freeScanLines (AcGiSentScanLines *) const =0
virtual AcGiSentScanLines * | getScanLines (const AcGiRequestScanLines &) const =0
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbimage.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbImage Member List

This is the complete list of members for AcDbImage, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbImage) (defined in AcDbImage) | AcDbImage |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
freeScanLines(AcGiSentScanLines *) const =0 (defined in AcDbImage) | AcDbImage | pure virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getScanLines(const AcGiRequestScanLines &) const =0 (defined in AcDbImage) | AcDbImage | pure virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbImageBackground Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbImageBackground Class Reference
AcDb Classes
+ Inheritance diagram for AcDbImageBackground:

Public Member Functions

AcDbImageBackground ()
ACRX_DECLARE_MEMBERS (AcDbImageBackground)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcGiDrawable::DrawableType | drawableType () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
bool | fitToScreen (void) const
const ACHAR * | imageFilename (void) const
bool | maintainAspectRatio (void) const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
void | setFitToScreen (bool bFitToScreen)
void | setImageFilename (const ACHAR *filename)
void | setMaintainAspectRatio (bool bMaintainAspectRatio)
void | setUseTiling (bool bUseTiling)
void | setXOffset (double xOffset)
void | setXScale (double xScale)
void | setYOffset (double yOffset)
void | setYScale (double yScale)
bool | useTiling (void) const
double | xOffset (void) const
double | xScale (void) const
double | yOffset (void) const
double | yScale (void) const
- Public Member Functions inherited from AcDbBackground
ACRX_DECLARE_MEMBERS (AcDbBackground)
virtual AcGiDrawable * | drawable ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpImageBackground

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcDbBackground
AcDbBackground (AcDbImpBackground *pImp)
AcDbImpBackground * | imp () const

Constructor & Destructor Documentation

AcDbImageBackground::AcDbImageBackground ( )
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbImageBackground::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual AcGiDrawable::DrawableType AcDbImageBackground::drawableType ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiDrawable.

virtual Acad::ErrorStatus AcDbImageBackground::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbImageBackground::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbImageBackground::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbImageBackground::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

bool AcDbImageBackground::fitToScreen ( void ) const
Warning
Not implemented!
const ACHAR* AcDbImageBackground::imageFilename ( void ) const
Warning
Not implemented!
bool AcDbImageBackground::maintainAspectRatio ( void ) const
Warning
Not implemented!
virtual Adesk::UInt32 AcDbImageBackground::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

void AcDbImageBackground::setFitToScreen ( bool bFitToScreen )
Warning
Not implemented!
void AcDbImageBackground::setImageFilename ( const ACHAR * filename )
Warning
Not implemented!
void AcDbImageBackground::setMaintainAspectRatio ( bool bMaintainAspectRatio )
Warning
Not implemented!
void AcDbImageBackground::setUseTiling ( bool bUseTiling )
Warning
Not implemented!
void AcDbImageBackground::setXOffset ( double xOffset )
Warning
Not implemented!
void AcDbImageBackground::setXScale ( double xScale )
Warning
Not implemented!
void AcDbImageBackground::setYOffset ( double yOffset )
Warning
Not implemented!
void AcDbImageBackground::setYScale ( double yScale )
Warning
Not implemented!
bool AcDbImageBackground::useTiling ( void ) const
Warning
Not implemented!
double AcDbImageBackground::xOffset ( void ) const
Warning
Not implemented!
double AcDbImageBackground::xScale ( void ) const
Warning
Not implemented!
double AcDbImageBackground::yOffset ( void ) const
Warning
Not implemented!
double AcDbImageBackground::yScale ( void ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbbackground.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbImageBackground Member List

This is the complete list of members for AcDbImageBackground, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBackground(AcDbImpBackground *pImp) (defined in AcDbBackground) | AcDbBackground | protected
AcDbImageBackground() | AcDbImageBackground |
AcDbImpImageBackground (defined in AcDbImageBackground) | AcDbImageBackground | friend
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbImageBackground) (defined in AcDbImageBackground) | AcDbImageBackground |
ACRX_DECLARE_MEMBERS(AcDbBackground) (defined in AcDbBackground) | AcDbBackground |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) | AcDbImageBackground | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbBackground) | AcDbBackground | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const | AcDbImageBackground | virtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbImageBackground | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbImageBackground | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbImageBackground | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbImageBackground | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fitToScreen(void) const | AcDbImageBackground |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imageFilename(void) const | AcDbImageBackground |
imp() const (defined in AcDbBackground) | AcDbBackground | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
maintainAspectRatio(void) const | AcDbImageBackground |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbImageBackground | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFitToScreen(bool bFitToScreen) | AcDbImageBackground |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setImageFilename(const ACHAR *filename) | AcDbImageBackground |
setMaintainAspectRatio(bool bMaintainAspectRatio) | AcDbImageBackground |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setUseTiling(bool bUseTiling) | AcDbImageBackground |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXOffset(double xOffset) | AcDbImageBackground |
setXScale(double xScale) | AcDbImageBackground |
setYOffset(double yOffset) | AcDbImageBackground |
setYScale(double yScale) | AcDbImageBackground |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useTiling(void) const | AcDbImageBackground |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
xOffset(void) const | AcDbImageBackground |
xScale(void) const | AcDbImageBackground |
yOffset(void) const | AcDbImageBackground |
yScale(void) const | AcDbImageBackground |
~AcDbBackground() (defined in AcDbBackground) | AcDbBackground | virtual
~AcDbImageBackground() (defined in AcDbImageBackground) | AcDbImageBackground | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbIndex Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcDbIndex Class Reference
AcDb Classes
+ Inheritance diagram for AcDbIndex:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbIndex)
Adesk::Boolean | isUptoDate () const
AcDbDate | lastUpdatedAt () const
AcDbDate | lastUpdatedAtU () const
virtual AcDbFilteredBlockIterator * | newIterator (const AcDbFilter *pFilter) const
virtual AcDbObjectId | objectBeingIndexedId () const
virtual Acad::ErrorStatus | rebuildFull (AcDbIndexUpdateData *pIdxData)
void | setLastUpdatedAt (const AcDbDate &time)
void | setLastUpdatedAtU (const AcDbDate &time)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

virtual Acad::ErrorStatus rebuildModified (AcDbBlockChangeIterator *iter)

Friends

class | AcDbImpIndex
Acad::ErrorStatus | processBTRIndexObjects (AcDbBlockTableRecord *pBTR, int indexCtlVal, AcDbBlockChangeIterator *pBlkChgIter, AcDbIndexUpdateData *pIdxUpdData)

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbindex.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbIndex Member List

This is the complete list of members for AcDbIndex, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbIndex) (defined in AcDbIndex) | AcDbIndex |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbImpIndex (defined in AcDbIndex) | AcDbIndex | friend
AcDbIndex() (defined in AcDbIndex) | AcDbIndex |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUptoDate() const (defined in AcDbIndex) | AcDbIndex |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
lastUpdatedAt() const (defined in AcDbIndex) | AcDbIndex |
lastUpdatedAtU() const (defined in AcDbIndex) | AcDbIndex |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(const AcDbFilter *pFilter) const (defined in AcDbIndex) | AcDbIndex | virtual
objectBeingIndexedId() const (defined in AcDbIndex) | AcDbIndex | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
processBTRIndexObjects (defined in AcDbIndex) | AcDbIndex | friend
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
rebuildFull(AcDbIndexUpdateData *pIdxData) (defined in AcDbIndex) | AcDbIndex | virtual
rebuildModified(AcDbBlockChangeIterator *iter) (defined in AcDbIndex) | AcDbIndex | protectedvirtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLastUpdatedAt(const AcDbDate &time) (defined in AcDbIndex) | AcDbIndex |
setLastUpdatedAtU(const AcDbDate &time) (defined in AcDbIndex) | AcDbIndex |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbIndex() (defined in AcDbIndex) | AcDbIndex | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbIndexUpdateData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcDbIndexUpdateData Class Reference
AcDb Classes

Public Types

enum UpdateFlags { kModified = 1, kDeleted = 2, kProcessed = 4, kUnknownKey = 8 }

Public Member Functions

Acad::ErrorStatus | addId (AcDbObjectId id)
Acad::ErrorStatus | getFlagsAndData (AcDbObjectId id, Adesk::UInt8 &flags, Adesk::ULongPtr &data) const
Acad::ErrorStatus | getIdData (AcDbObjectId id, Adesk::ULongPtr &data) const
Acad::ErrorStatus | getIdFlags (AcDbObjectId id, Adesk::UInt8 &flags) const
Acad::ErrorStatus | setIdData (AcDbObjectId id, Adesk::ULongPtr data)
Acad::ErrorStatus | setIdFlags (AcDbObjectId id, Adesk::UInt8 flags)

Friends

class | AcDbImpDatabase
class | AcDbIndexUpdateDataIterator
The documentation for this class was generated from the following file:
  • dbindex.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbIndexUpdateData Member List

This is the complete list of members for AcDbIndexUpdateData, including all inherited members.

AcDbImpDatabase (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData | friend
AcDbIndexUpdateDataIterator (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData | friend
addId(AcDbObjectId id) (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
getFlagsAndData(AcDbObjectId id, Adesk::UInt8 &flags, Adesk::ULongPtr &data) const (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
getIdData(AcDbObjectId id, Adesk::ULongPtr &data) const (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
getIdFlags(AcDbObjectId id, Adesk::UInt8 &flags) const (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
kDeleted enum value (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
kModified enum value (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
kProcessed enum value (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
kUnknownKey enum value (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
setIdData(AcDbObjectId id, Adesk::ULongPtr data) (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
setIdFlags(AcDbObjectId id, Adesk::UInt8 flags) (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |
UpdateFlags enum name (defined in AcDbIndexUpdateData) | AcDbIndexUpdateData |


ZRX API Reference: AcDbIndexUpdateDataIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbIndexUpdateDataIterator Class Reference
AcDb Classes

Public Member Functions

AcDbIndexUpdateDataIterator (const AcDbIndexUpdateData *p)
Acad::ErrorStatus | currentData (AcDbObjectId &id, Adesk::UInt8 &flags, Adesk::ULongPtr &data) const
bool | done ()
void | next ()
void | start ()
The documentation for this class was generated from the following file:
  • dbindex.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbIndexUpdateDataIterator Member List

This is the complete list of members for AcDbIndexUpdateDataIterator, including all inherited members.

AcDbIndexUpdateDataIterator(const AcDbIndexUpdateData *p) (defined in AcDbIndexUpdateDataIterator) | AcDbIndexUpdateDataIterator
currentData(AcDbObjectId &id, Adesk::UInt8 &flags, Adesk::ULongPtr &data) const (defined in AcDbIndexUpdateDataIterator) | AcDbIndexUpdateDataIterator
done() (defined in AcDbIndexUpdateDataIterator) | AcDbIndexUpdateDataIterator
next() (defined in AcDbIndexUpdateDataIterator) | AcDbIndexUpdateDataIterator
start() (defined in AcDbIndexUpdateDataIterator) | AcDbIndexUpdateDataIterator
~AcDbIndexUpdateDataIterator() (defined in AcDbIndexUpdateDataIterator) | AcDbIndexUpdateDataIterator


ZRX API Reference: AcDbInterferencePE Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbInterferencePE Class Reference
AcDb Classes
+ Inheritance diagram for AcDbInterferencePE:

Public Types

enum Flags { kDefault = 0x00 }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbInterferencePE)
virtual Acad::ErrorStatus | createInterferenceObjects (AcArray< AcDbEntity * > &interferenceObjects, AcDbEntity *pEnt1, AcDbEntity *pEnt2, unsigned int flags) const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbInterferencePE.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbInterferencePE Member List

This is the complete list of members for AcDbInterferencePE, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbInterferencePE) (defined in AcDbInterferencePE) | AcDbInterferencePE |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
createInterferenceObjects(AcArray< AcDbEntity * > &interferenceObjects, AcDbEntity *pEnt1, AcDbEntity *pEnt2, unsigned int flags) const =0 (defined in AcDbInterferencePE) | AcDbInterferencePE | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
Flags enum name (defined in AcDbInterferencePE) | AcDbInterferencePE |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDefault enum value (defined in AcDbInterferencePE) | AcDbInterferencePE |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLayerFilter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLayerFilter Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayerFilter:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLayerFilter)
Acad::ErrorStatus | add (const ACHAR *pLayer)
Acad::ErrorStatus | getAt (int index, const ACHAR *&pName) const
virtual AcRxClass * | indexClass () const
virtual Adesk::Boolean | isValid () const
int | layerCount () const
Acad::ErrorStatus | remove (const ACHAR *pLayer)
- Public Member Functions inherited from AcDbFilter
ACDB_DECLARE_MEMBERS (AcDbFilter)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dblyfilt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayerFilter Member List

This is the complete list of members for AcDbLayerFilter, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLayerFilter) (defined in AcDbLayerFilter) | AcDbLayerFilter |
ACDB_DECLARE_MEMBERS(AcDbFilter) (defined in AcDbFilter) | AcDbFilter |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbFilter() (defined in AcDbFilter) | AcDbFilter |
AcDbLayerFilter() (defined in AcDbLayerFilter) | AcDbLayerFilter |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(const ACHAR *pLayer) (defined in AcDbLayerFilter) | AcDbLayerFilter |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(int index, const ACHAR *&pName) const (defined in AcDbLayerFilter) | AcDbLayerFilter |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
indexClass() const (defined in AcDbLayerFilter) | AcDbLayerFilter | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isValid() const (defined in AcDbLayerFilter) | AcDbLayerFilter | virtual
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layerCount() const (defined in AcDbLayerFilter) | AcDbLayerFilter |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
remove(const ACHAR *pLayer) (defined in AcDbLayerFilter) | AcDbLayerFilter |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbFilter() (defined in AcDbFilter) | AcDbFilter | virtual
~AcDbLayerFilter() (defined in AcDbLayerFilter) | AcDbLayerFilter | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLayerIndex Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcDbLayerIndex Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayerIndex:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLayerIndex)
Acad::ErrorStatus | compute (AcDbLayerTable *pLT, AcDbBlockTableRecord *pBTR)
virtual AcDbFilteredBlockIterator * | newIterator (const AcDbFilter *pFilter) const
virtual Acad::ErrorStatus | rebuildFull (AcDbIndexUpdateData *pIdxData)
- Public Member Functions inherited from AcDbIndex
ACDB_DECLARE_MEMBERS (AcDbIndex)
Adesk::Boolean | isUptoDate () const
AcDbDate | lastUpdatedAt () const
AcDbDate | lastUpdatedAtU () const
virtual AcDbObjectId | objectBeingIndexedId () const
void | setLastUpdatedAt (const AcDbDate &time)
void | setLastUpdatedAtU (const AcDbDate &time)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

virtual Acad::ErrorStatus rebuildModified (AcDbBlockChangeIterator *iter)

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dblyindx.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayerIndex Member List

This is the complete list of members for AcDbLayerIndex, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLayerIndex) (defined in AcDbLayerIndex) | AcDbLayerIndex |
ACDB_DECLARE_MEMBERS(AcDbIndex) (defined in AcDbIndex) | AcDbIndex |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbIndex() (defined in AcDbIndex) | AcDbIndex |
AcDbLayerIndex() (defined in AcDbLayerIndex) | AcDbLayerIndex |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
compute(AcDbLayerTable *pLT, AcDbBlockTableRecord *pBTR) (defined in AcDbLayerIndex) | AcDbLayerIndex |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUptoDate() const (defined in AcDbIndex) | AcDbIndex |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
lastUpdatedAt() const (defined in AcDbIndex) | AcDbIndex |
lastUpdatedAtU() const (defined in AcDbIndex) | AcDbIndex |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(const AcDbFilter *pFilter) const (defined in AcDbLayerIndex) | AcDbLayerIndex | virtual
objectBeingIndexedId() const (defined in AcDbIndex) | AcDbIndex | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
rebuildFull(AcDbIndexUpdateData *pIdxData) (defined in AcDbLayerIndex) | AcDbLayerIndex | virtual
rebuildModified(AcDbBlockChangeIterator *iter) (defined in AcDbLayerIndex) | AcDbLayerIndex | protectedvirtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLastUpdatedAt(const AcDbDate &time) (defined in AcDbIndex) | AcDbIndex |
setLastUpdatedAtU(const AcDbDate &time) (defined in AcDbIndex) | AcDbIndex |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbIndex() (defined in AcDbIndex) | AcDbIndex | virtual
~AcDbLayerIndex() (defined in AcDbLayerIndex) | AcDbLayerIndex | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLayerIndexIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLayerIndexIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayerIndexIterator:

Public Member Functions

virtual Acad::ErrorStatus | accepts (AcDbObjectId id, Adesk::Boolean &idPassesFilter) const
AcDbLayerIndexIterator (const AcDbLayerIndex *pIndex, const AcDbLayerFilter *pFilter)
virtual double | estimatedHitFraction () const
virtual AcDbObjectId | id () const
virtual AcDbObjectId | next ()
virtual Acad::ErrorStatus | seek (AcDbObjectId id)
virtual Acad::ErrorStatus | start ()
- Public Member Functions inherited from AcDbFilteredBlockIterator
virtual Acad::ErrorStatus | addToBuffer (AcDbObjectId id)
virtual Adesk::Boolean | buffersForComposition () const
The documentation for this class was generated from the following file:
  • dblyindx.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayerIndexIterator Member List

This is the complete list of members for AcDbLayerIndexIterator, including all inherited members.

accepts(AcDbObjectId id, Adesk::Boolean &idPassesFilter) const (defined in AcDbLayerIndexIterator) | AcDbLayerIndexIterator | virtual
AcDbFilteredBlockIterator() (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | inline
AcDbLayerIndexIterator(const AcDbLayerIndex *pIndex, const AcDbLayerFilter *pFilter) (defined in AcDbLayerIndexIterator) | AcDbLayerIndexIterator |
addToBuffer(AcDbObjectId id) (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | virtual
buffersForComposition() const (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | virtual
estimatedHitFraction() const (defined in AcDbLayerIndexIterator) | AcDbLayerIndexIterator | virtual
id() const (defined in AcDbLayerIndexIterator) | AcDbLayerIndexIterator | virtual
next() (defined in AcDbLayerIndexIterator) | AcDbLayerIndexIterator | virtual
seek(AcDbObjectId id) (defined in AcDbLayerIndexIterator) | AcDbLayerIndexIterator | virtual
start() (defined in AcDbLayerIndexIterator) | AcDbLayerIndexIterator | virtual
~AcDbFilteredBlockIterator() (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | inlinevirtual
~AcDbLayerIndexIterator() (defined in AcDbLayerIndexIterator) | AcDbLayerIndexIterator | virtual


ZRX API Reference: AcDbLayerStateManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcDbLayerStateManager Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayerStateManager:

Public Types

enum { kUndefDoNothing = 0, kUndefTurnOff = 1, kUndefFreeze = 2, kRestoreAsOverrides = 4 }
enum LayerStateMask {
kNone = 0x0000, kOn = 0x0001, kFrozen = 0x0002, kLocked = 0x0004,
kPlot = 0x0008, kNewViewport = 0x0010, kColor = 0x0020, kLineType = 0x0040,
kLineWeight = 0x0080, kPlotStyle = 0x0100, kCurrentViewport = 0x0200, kAll,
kStateIsHidden = 0x8000, kLastRestored = 0x10000, kDecomposition = kAll | 0x20000
}

Public Member Functions

AcDbLayerStateManager (AcDbDatabase *pHostDb)
ACRX_DECLARE_MEMBERS (AcDbLayerStateManager)
Acad::ErrorStatus | addLayerStateLayers (const ACHAR *sName, const AcDbObjectIdArray &layerIds)
bool | addReactor (AcDbLayerStateManagerReactor *pReactor)
bool | compareLayerStateToDb (const ACHAR *sName, const AcDbObjectId &idVp)
Acad::ErrorStatus | deleteLayerState (const ACHAR *sName)
Acad::ErrorStatus | exportLayerState (const ACHAR *sNameToExport, const ACHAR *sFilename)
AcDbDatabase * | getDatabase () const
Acad::ErrorStatus | getLastRestoredLayerState (AcString &sName, AcDbObjectId &restoredLSId)
Acad::ErrorStatus | getLayerStateDescription (const ACHAR *sName, ACHAR *&sDesc)
Acad::ErrorStatus | getLayerStateLayers (AcStringArray &layerArray, const ACHAR *sName, bool bInvert=false)
Acad::ErrorStatus | getLayerStateMask (const ACHAR *sName, LayerStateMask &returnMask)
Acad::ErrorStatus | getLayerStateNames (AcStringArray &lsArray, bool bIncludeHidden=true, bool bIncludeXref=true)
bool | hasLayerState (const ACHAR *sName)
Acad::ErrorStatus | importLayerState (const ACHAR *sFilename)
Acad::ErrorStatus | importLayerState (const ACHAR *sFilename, AcString &sName)
Acad::ErrorStatus | importLayerStateFromDb (const ACHAR *pStateName, AcDbDatabase *pDb)
bool | isDependentLayerState (const ACHAR *sName)
bool | layerStateHasViewportData (const ACHAR *sName)
AcDbObjectId | layerStatesDictionaryId (bool bCreateIfNotPresent=false)
Acad::ErrorStatus | removeLayerStateLayers (const ACHAR *sName, const AcStringArray &layerNames)
bool | removeReactor (AcDbLayerStateManagerReactor *pReactor)
Acad::ErrorStatus | renameLayerState (const ACHAR *sName, const ACHAR *sNewName)
Acad::ErrorStatus | restoreLayerState (const ACHAR *sName)
Acad::ErrorStatus | restoreLayerState (const ACHAR *sName, const AcDbObjectId &idVp, int nRestoreFlags=0, const LayerStateMask *pClientMask=NULL)
Acad::ErrorStatus | saveLayerState (const ACHAR *sName, LayerStateMask mask)
Acad::ErrorStatus | saveLayerState (const ACHAR *sName, LayerStateMask mask, const AcDbObjectId &idVp)
Acad::ErrorStatus | setLayerStateDescription (const ACHAR *sName, const ACHAR *sDesc)
Acad::ErrorStatus | setLayerStateMask (const ACHAR *sName, LayerStateMask mask)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpDatabase

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dblstate.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayerStateManager Member List

This is the complete list of members for AcDbLayerStateManager, including all inherited members.

AcDbImpDatabase (defined in AcDbLayerStateManager) | AcDbLayerStateManager | friend
AcDbLayerStateManager() (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
AcDbLayerStateManager(AcDbDatabase *pHostDb) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
ACRX_DECLARE_MEMBERS(AcDbLayerStateManager) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLayerStateLayers(const ACHAR *sName, const AcDbObjectIdArray &layerIds) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
addReactor(AcDbLayerStateManagerReactor *pReactor) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
compareLayerStateToDb(const ACHAR *sName, const AcDbObjectId &idVp) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
deleteLayerState(const ACHAR *sName) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
desc() (defined in AcRxObject) | AcRxObject | static
exportLayerState(const ACHAR *sNameToExport, const ACHAR *sFilename) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
getDatabase() const (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
getLastRestoredLayerState(AcString &sName, AcDbObjectId &restoredLSId) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
getLayerStateDescription(const ACHAR *sName, ACHAR *&sDesc) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
getLayerStateLayers(AcStringArray &layerArray, const ACHAR *sName, bool bInvert=false) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
getLayerStateMask(const ACHAR *sName, LayerStateMask &returnMask) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
getLayerStateNames(AcStringArray &lsArray, bool bIncludeHidden=true, bool bIncludeXref=true) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
hasLayerState(const ACHAR *sName) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
importLayerState(const ACHAR *sFilename) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
importLayerState(const ACHAR *sFilename, AcString &sName) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
importLayerStateFromDb(const ACHAR *pStateName, AcDbDatabase *pDb) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isDependentLayerState(const ACHAR *sName) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAll enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kColor enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kCurrentViewport enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kDecomposition enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kFrozen enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kLastRestored enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kLineType enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kLineWeight enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kLocked enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kNewViewport enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kNone enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kOn enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kPlot enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kPlotStyle enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kRestoreAsOverrides enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kStateIsHidden enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kUndefDoNothing enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kUndefFreeze enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
kUndefTurnOff enum value (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
layerStateHasViewportData(const ACHAR *sName) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
LayerStateMask enum name (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
layerStatesDictionaryId(bool bCreateIfNotPresent=false) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeLayerStateLayers(const ACHAR *sName, const AcStringArray &layerNames) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
removeReactor(AcDbLayerStateManagerReactor *pReactor) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
renameLayerState(const ACHAR *sName, const ACHAR *sNewName) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
restoreLayerState(const ACHAR *sName) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
restoreLayerState(const ACHAR *sName, const AcDbObjectId &idVp, int nRestoreFlags=0, const LayerStateMask *pClientMask=NULL) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
saveLayerState(const ACHAR *sName, LayerStateMask mask) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
saveLayerState(const ACHAR *sName, LayerStateMask mask, const AcDbObjectId &idVp) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
setLayerStateDescription(const ACHAR *sName, const ACHAR *sDesc) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
setLayerStateMask(const ACHAR *sName, LayerStateMask mask) (defined in AcDbLayerStateManager) | AcDbLayerStateManager |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbLayerStateManager() (defined in AcDbLayerStateManager) | AcDbLayerStateManager | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLayerStateManagerReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLayerStateManagerReactor Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayerStateManagerReactor:

Public Member Functions

virtual void | abortLayerStateDelete (const ACHAR *layerStateName, const AcDbObjectId &layerStateId)
virtual void | abortLayerStateRename (const ACHAR *oldLayerStateName, const ACHAR *newLayerStateName)
virtual void | abortLayerStateRestore (const ACHAR *layerStateName, const AcDbObjectId &layerStateId)
ACRX_DECLARE_MEMBERS (AcDbLayerStateManagerReactor)
virtual void | layerStateCompareFailed (const ACHAR *layerStateName, const AcDbObjectId &layerStateId)
virtual void | layerStateCreated (const ACHAR *layerStateName, const AcDbObjectId &layerStateId)
virtual void | layerStateDeleted (const ACHAR *layerStateName)
virtual void | layerStateRenamed (const ACHAR *oldLayerStateName, const ACHAR *newLayerStateName)
virtual void | layerStateRestored (const ACHAR *layerStateName, const AcDbObjectId &layerStateId)
virtual void | layerStateToBeDeleted (const ACHAR *layerStateName, const AcDbObjectId &layerStateId)
virtual void | layerStateToBeRenamed (const ACHAR *oldLayerStateName, const ACHAR *newLayerStateName)
virtual void | layerStateToBeRestored (const ACHAR *layerStateName, const AcDbObjectId &layerStateId)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dblstate.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayerStateManagerReactor Member List

This is the complete list of members for AcDbLayerStateManagerReactor, including all inherited members.

abortLayerStateDelete(const ACHAR *layerStateName, const AcDbObjectId &layerStateId) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
abortLayerStateRename(const ACHAR *oldLayerStateName, const ACHAR *newLayerStateName) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
abortLayerStateRestore(const ACHAR *layerStateName, const AcDbObjectId &layerStateId) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
ACRX_DECLARE_MEMBERS(AcDbLayerStateManagerReactor) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
layerStateCompareFailed(const ACHAR *layerStateName, const AcDbObjectId &layerStateId) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
layerStateCreated(const ACHAR *layerStateName, const AcDbObjectId &layerStateId) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
layerStateDeleted(const ACHAR *layerStateName) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
layerStateRenamed(const ACHAR *oldLayerStateName, const ACHAR *newLayerStateName) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
layerStateRestored(const ACHAR *layerStateName, const AcDbObjectId &layerStateId) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
layerStateToBeDeleted(const ACHAR *layerStateName, const AcDbObjectId &layerStateId) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
layerStateToBeRenamed(const ACHAR *oldLayerStateName, const ACHAR *newLayerStateName) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
layerStateToBeRestored(const ACHAR *layerStateName, const AcDbObjectId &layerStateId) (defined in AcDbLayerStateManagerReactor) | AcDbLayerStateManagerReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLayerTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbLayerTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayerTable:

Public Types

typedef AcDbLayerTableRecord | RecordType
- Public Types inherited from AcDbSymbolTable
typedef AcDbSymbolTableRecord | RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLayerTable)
Acad::ErrorStatus | add (AcDbLayerTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbLayerTableRecord *pRecord)
void | generateUsageData ()
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbLayerTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getUnreconciledLayers (AcDbObjectIdArray &idArray) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
bool | hasUnreconciledLayers () const
Acad::ErrorStatus | newIterator (AcDbLayerTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

Acad::ErrorStatus AcDbLayerTable::getUnreconciledLayers ( AcDbObjectIdArray & idArray ) const
Warning
Not implemented!
bool AcDbLayerTable::hasUnreconciledLayers ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayerTable Member List

This is the complete list of members for AcDbLayerTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLayerTable) (defined in AcDbLayerTable) | AcDbLayerTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbLayerTable() (defined in AcDbLayerTable) | AcDbLayerTable |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbLayerTableRecord *pRecord) (defined in AcDbLayerTable) | AcDbLayerTable |
add(AcDbObjectId &recordId, AcDbLayerTableRecord *pRecord) (defined in AcDbLayerTable) | AcDbLayerTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
generateUsageData() (defined in AcDbLayerTable) | AcDbLayerTable |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbLayerTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbLayerTable) | AcDbLayerTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const (defined in AcDbLayerTable) | AcDbLayerTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbLayerTable) | AcDbLayerTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getUnreconciledLayers(AcDbObjectIdArray &idArray) const | AcDbLayerTable |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbLayerTable) | AcDbLayerTable |
has(AcDbObjectId id) const (defined in AcDbLayerTable) | AcDbLayerTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hasUnreconciledLayers() const | AcDbLayerTable |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbLayerTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbLayerTable) | AcDbLayerTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbLayerTable) | AcDbLayerTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbLayerTable() (defined in AcDbLayerTable) | AcDbLayerTable | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLayerTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbLayerTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayerTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbLayerTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
bool | getSkipHidden () const
bool | getSkipReconciled () const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbLayerTableRecord *pRecord)
void | setSkipHidden (bool value)
void | setSkipReconciled (bool value)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbLayerTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp

Member Function Documentation

bool AcDbLayerTableIterator::getSkipHidden ( ) const
Warning
Not implemented!
bool AcDbLayerTableIterator::getSkipReconciled ( ) const
Warning
Not implemented!
void AcDbLayerTableIterator::setSkipReconciled ( bool value )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayerTableIterator Member List

This is the complete list of members for AcDbLayerTableIterator, including all inherited members.

AcDbLayerTable (defined in AcDbLayerTableIterator) | AcDbLayerTableIterator | friend
AcDbLayerTableIterator() (defined in AcDbLayerTableIterator) | AcDbLayerTableIterator | protected
AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbLayerTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbLayerTableIterator) | AcDbLayerTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getSkipHidden() const | AcDbLayerTableIterator |
getSkipReconciled() const | AcDbLayerTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbLayerTableIterator) | AcDbLayerTableIterator |
seek(const AcDbLayerTableRecord *pRecord) (defined in AcDbLayerTableIterator) | AcDbLayerTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
setSkipHidden(bool value) (defined in AcDbLayerTableIterator) | AcDbLayerTableIterator |
setSkipReconciled(bool value) | AcDbLayerTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbLayerTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcDbLayerTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayerTableRecord:

Public Types

enum | { kDxfLayerPlotBit = AcDb::kDxfBool }
typedef AcDbLayerTable | TableType
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable | TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLayerTableRecord)
AcCmColor | color () const
AcCmColor | color (const AcDbObjectId &viewportId, bool &isOverride) const
ACHAR * | description () const
AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor (void) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
AcGsNode * | gsNode () const
bool | hasAnyOverrides () const
bool | hasOverrides (const AcDbObjectId &viewportId) const
bool | isFrozen () const
bool | isHidden () const
bool | isInUse () const
bool | isLocked () const
bool | isOff () const
bool | isPlottable () const
bool | isReconciled () const
AcDbObjectId | linetypeObjectId () const
AcDbObjectId | linetypeObjectId (const AcDbObjectId &viewportId, bool &isOverride) const
AcDb::LineWeight | lineWeight () const
AcDb::LineWeight | lineWeight (const AcDbObjectId &viewportId, bool &isOverride) const
AcDbObjectId | materialId () const
ACHAR * | plotStyleName () const
ACHAR * | plotStyleName (const AcDbObjectId &viewportId, bool &isOverride) const
AcDbObjectId | plotStyleNameId () const
AcDbObjectId | plotStyleNameId (const AcDbObjectId &viewportId, bool &isOverride) const
Acad::ErrorStatus | removeAllOverrides ()
Acad::ErrorStatus | removeColorOverride (const AcDbObjectId &viewportId)
Acad::ErrorStatus | removeLinetypeOverride (const AcDbObjectId &viewportId)
Acad::ErrorStatus | removeLineWeightOverride (const AcDbObjectId &viewportId)
Acad::ErrorStatus | removePlotStyleOverride (const AcDbObjectId &viewportId)
Acad::ErrorStatus | removeViewportOverrides (const AcDbObjectId &viewportId)
Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
void | setColor (const AcCmColor &color)
Acad::ErrorStatus | setColor (const AcCmColor &color, const AcDbObjectId &viewportId)
Acad::ErrorStatus | setDescription (const ACHAR *description)
void | setGsNode (AcGsNode *pNode)
Acad::ErrorStatus | setIsFrozen (bool frozen)
Acad::ErrorStatus | setIsHidden (bool on)
void | setIsLocked (bool locked)
void | setIsOff (bool off)
Acad::ErrorStatus | setIsPlottable (bool plot)
Acad::ErrorStatus | setIsReconciled (bool bReconcile=true)
void | setLinetypeObjectId (AcDbObjectId id)
Acad::ErrorStatus | setLinetypeObjectId (const AcDbObjectId &id, const AcDbObjectId &viewportId)
Acad::ErrorStatus | setLineWeight (AcDb::LineWeight weight)
Acad::ErrorStatus | setLineWeight (AcDb::LineWeight weight, const AcDbObjectId &viewportId)
Acad::ErrorStatus | setMaterialId (AcDbObjectId id)
Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName)
Acad::ErrorStatus | setPlotStyleName (const AcDbObjectId &newId)
Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, const AcDbObjectId &viewportId)
Acad::ErrorStatus | setPlotStyleName (const AcDbObjectId &newId, const AcDbObjectId &viewportId)
Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans)
void | setVPDFLT (bool frozen)
AcCmTransparency | transparency (void) const
void | viewportDraw (AcGiViewportDraw *pVd)
bool | VPDFLT () const
Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static bool | isHidden (AcDbObjectId)
static bool | isReconciled (const AcDbObjectId &id)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayerTableRecord Member List

This is the complete list of members for AcDbLayerTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLayerTableRecord) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbLayerTableRecord() (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
color() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
color(const AcDbObjectId &viewportId, bool &isOverride) const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
entityColor(void) const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasAnyOverrides() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasOverrides(const AcDbObjectId &viewportId) const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFrozen() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
isHidden() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
isHidden(AcDbObjectId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | static
isInUse() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLocked() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isOff() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlottable() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isReconciled() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
isReconciled(const AcDbObjectId &id) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | static
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDxfLayerPlotBit enum value (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
linetypeObjectId() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
linetypeObjectId(const AcDbObjectId &viewportId, bool &isOverride) const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
lineWeight() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
lineWeight(const AcDbObjectId &viewportId, bool &isOverride) const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
materialId() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
plotStyleName(const AcDbObjectId &viewportId, bool &isOverride) const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
plotStyleNameId() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
plotStyleNameId(const AcDbObjectId &viewportId, bool &isOverride) const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeAllOverrides() (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
removeColorOverride(const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeLinetypeOverride(const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
removeLineWeightOverride(const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removePlotStyleOverride(const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeViewportOverrides(const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setColor(const AcCmColor &color) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setColor(const AcCmColor &color, const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setDescription(const ACHAR *description) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setIsFrozen(bool frozen) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setIsHidden(bool on) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setIsLocked(bool locked) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setIsOff(bool off) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setIsPlottable(bool plot) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setIsReconciled(bool bReconcile=true) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setLinetypeObjectId(AcDbObjectId id) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setLinetypeObjectId(const AcDbObjectId &id, const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setLineWeight(AcDb::LineWeight weight) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setLineWeight(AcDb::LineWeight weight, const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setMaterialId(AcDbObjectId id) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setPlotStyleName(const AcDbObjectId &newId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setPlotStyleName(const ACHAR *newName, const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setPlotStyleName(const AcDbObjectId &newId, const AcDbObjectId &viewportId) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setTransparency(const AcCmTransparency &trans) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setVPDFLT(bool frozen) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
transparency(void) const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
VPDFLT() const (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbLayerTableRecord() (defined in AcDbLayerTableRecord) | AcDbLayerTableRecord | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLayout Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLayout Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayout:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLayout)
virtual Acad::ErrorStatus | addToLayoutDict (AcDbDatabase *towhichDb, AcDbObjectId BlockTableRecordId)
bool | annoAllVisible () const
AcDbObjectId | getBlockTableRecordId () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
void | getExtents (AcGePoint3d &extMin, AcGePoint3d &extMax) const
Acad::ErrorStatus | getLayoutName (const ACHAR *&layoutName) const
Acad::ErrorStatus | getLayoutName (ACHAR *&layoutName) const
void | getLimits (AcGePoint2d &limMin, AcGePoint2d &limMax) const
int | getTabOrder () const
bool | getTabSelected () const
AcDbObjectIdArray | getViewportArray () const
Acad::ErrorStatus | initialize (AcDbObjectId *paperVportId=NULL)
Acad::ErrorStatus | setAnnoAllVisible (bool newVal)
virtual Acad::ErrorStatus | setBlockTableRecordId (AcDbObjectId BlockTableRecordId)
virtual Acad::ErrorStatus | setLayoutName (const ACHAR *layoutName)
virtual void | setTabOrder (int newOrder)
virtual void | setTabSelected (Adesk::Boolean tabSelected)
- Public Member Functions inherited from AcDbPlotSettings
ACDB_DECLARE_MEMBERS (AcDbPlotSettings)
AcDbPlotSettings (bool ModelType)
Acad::ErrorStatus | addToPlotSettingsDict (AcDbDatabase *towhichDb)
Acad::ErrorStatus | copyFrom (AcDbPlotSettings *fromPlotSettings)
Adesk::Boolean | drawViewportsFirst () const
Acad::ErrorStatus | getCanonicalMediaName (const ACHAR *&mediaName) const
Acad::ErrorStatus | getCurrentStyleSheet (const ACHAR *&styleSheetName) const
Acad::ErrorStatus | getCustomPrintScale (double &numerator, double &denominator) const
Acad::ErrorStatus | getPlotCfgName (const ACHAR *&plotCfgName) const
Acad::ErrorStatus | getPlotOrigin (double &x, double &y) const
Acad::ErrorStatus | getPlotPaperMargins (double &printableXmin, double &printableYmin, double &printableXmax, double &printableYmax) const
Acad::ErrorStatus | getPlotPaperSize (double &paperWidth, double &paperHeight) const
Acad::ErrorStatus | getPlotSettingsName (const ACHAR *&plotSettingsName) const
Acad::ErrorStatus | getPlotSettingsName (ACHAR *&plotSettingsName) const
Acad::ErrorStatus | getPlotViewName (const ACHAR *&viewName) const
Acad::ErrorStatus | getPlotWindowArea (double &xmin, double &ymin, double &xmax, double &ymax) const
Acad::ErrorStatus | getStdScale (double &scale) const
Adesk::Boolean | modelType () const
bool | plotAsRaster () const
Adesk::Boolean | plotCentered () const
Adesk::Boolean | plotHidden () const
AcDbPlotSettings::PlotPaperUnits | plotPaperUnits () const
Adesk::Boolean | plotPlotStyles () const
AcDbPlotSettings::PlotRotation | plotRotation () const
AcDbPlotSettings::PlotType | plotType () const
Adesk::Boolean | plotViewportBorders () const
bool | plotWireframe () const
Adesk::Boolean | printLineweights () const
Adesk::Boolean | scaleLineweights () const
void | setDrawViewportsFirst (Adesk::Boolean drawViewportsFirst)
void | setPlotHidden (Adesk::Boolean plotHidden)
void | setPlotPlotStyles (Adesk::Boolean plotPlotStyles)
Acad::ErrorStatus | setPlotSettingsName (const ACHAR *plotSettingsName)
void | setPlotViewportBorders (Adesk::Boolean plotViewportBorders)
void | setPrintLineweights (Adesk::Boolean printLineweights)
void | setScaleLineweights (Adesk::Boolean scaleLineweights)
Acad::ErrorStatus | setShadePlot (AcDbPlotSettings::ShadePlotType shadePlot)
Acad::ErrorStatus | setShadePlot (const AcDbPlotSettings::ShadePlotType type, const AcDbObjectId shadePlotId)
Acad::ErrorStatus | setShadePlotCustomDPI (Adesk::Int16 val)
Acad::ErrorStatus | setShadePlotResLevel (AcDbPlotSettings::ShadePlotResLevel resLevel)
void | setShowPlotStyles (Adesk::Boolean showPlotStyles)
AcDbPlotSettings::ShadePlotType | shadePlot () const
Adesk::Int16 | shadePlotCustomDPI () const
AcDbObjectId | shadePlotId () const
AcDbPlotSettings::ShadePlotResLevel | shadePlotResLevel () const
Adesk::Boolean | showPlotStyles () const
AcDbPlotSettings::StdScaleType | stdScaleType () const
Adesk::Boolean | useStandardScale () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbPlotSettings
enum | PlotPaperUnits { kInches, kMillimeters, kPixels }
enum | PlotRotation { k0degrees, k90degrees, k180degrees, k270degrees }
enum PlotType {
kDisplay, kExtents, kLimits, kView,
kWindow, kLayout
}
enum ShadePlotResLevel {
kDraft, kPreview, kNormal, kPresentation,
kMaximum, kCustom
}
enum ShadePlotType {
kAsDisplayed = 0, kWireframe = 1, kHidden = 2, kRendered = 3,
kVisualStyle = 4, kRenderPreset = 5
}
enum StdScaleType {
kScaleToFit, k1_128in_1ft, k1_64in_1ft, k1_32in_1ft,
k1_16in_1ft, k3_32in_1ft, k1_8in_1ft, k3_16in_1ft,
k1_4in_1ft, k3_8in_1ft, k1_2in_1ft, k3_4in_1ft,
k1in_1ft, k3in_1ft, k6in_1ft, k1ft_1ft,
k1_1, k1_2, k1_4, k1_5,
k1_8, k1_10, k1_16, k1_20,
k1_30, k1_40, k1_50, k1_100,
k2_1, k4_1, k8_1, k10_1,
k100_1, k1000_1, k1and1_2in_1ft
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

bool AcDbLayout::annoAllVisible ( ) const
Warning
Not implemented!
void AcDbLayout::getLimits | ( | AcGePoint2d & | limMin,
 |  | AcGePoint2d & | limMax
 | ) |  | const
Warning
Not implemented!
Acad::ErrorStatus AcDbLayout::initialize ( AcDbObjectId * paperVportId = NULL )
Warning
Not implemented!
Acad::ErrorStatus AcDbLayout::setAnnoAllVisible ( bool newVal )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dblayout.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayout Member List

This is the complete list of members for AcDbLayout, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLayout) (defined in AcDbLayout) | AcDbLayout |
ACDB_DECLARE_MEMBERS(AcDbPlotSettings) (defined in AcDbPlotSettings) | AcDbPlotSettings |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbLayout() (defined in AcDbLayout) | AcDbLayout |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPlotSettings() (defined in AcDbPlotSettings) | AcDbPlotSettings |
AcDbPlotSettings(bool ModelType) (defined in AcDbPlotSettings) | AcDbPlotSettings |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addToLayoutDict(AcDbDatabase *towhichDb, AcDbObjectId BlockTableRecordId) (defined in AcDbLayout) | AcDbLayout | virtual
addToPlotSettingsDict(AcDbDatabase *towhichDb) (defined in AcDbPlotSettings) | AcDbPlotSettings |
annoAllVisible() const | AcDbLayout |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(AcDbPlotSettings *fromPlotSettings) (defined in AcDbPlotSettings) | AcDbPlotSettings |
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawViewportsFirst() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBlockTableRecordId() const (defined in AcDbLayout) | AcDbLayout |
getCanonicalMediaName(const ACHAR *&mediaName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getClassID(CLSID *pClsid) const (defined in AcDbLayout) | AcDbLayout | virtual
getCurrentStyleSheet(const ACHAR *&styleSheetName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getCustomPrintScale(double &numerator, double &denominator) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getExtents(AcGePoint3d &extMin, AcGePoint3d &extMax) const (defined in AcDbLayout) | AcDbLayout |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getLayoutName(const ACHAR *&layoutName) const (defined in AcDbLayout) | AcDbLayout |
getLayoutName(ACHAR *&layoutName) const (defined in AcDbLayout) | AcDbLayout |
getLimits(AcGePoint2d &limMin, AcGePoint2d &limMax) const | AcDbLayout |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getPlotCfgName(const ACHAR *&plotCfgName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotOrigin(double &x, double &y) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotPaperMargins(double &printableXmin, double &printableYmin, double &printableXmax, double &printableYmax) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotPaperSize(double &paperWidth, double &paperHeight) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotSettingsName(const ACHAR *&plotSettingsName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotSettingsName(ACHAR *&plotSettingsName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotViewName(const ACHAR *&viewName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotWindowArea(double &xmin, double &ymin, double &xmax, double &ymax) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getStdScale(double &scale) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getTabOrder() const (defined in AcDbLayout) | AcDbLayout |
getTabSelected() const (defined in AcDbLayout) | AcDbLayout |
getViewportArray() const (defined in AcDbLayout) | AcDbLayout |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
initialize(AcDbObjectId *paperVportId=NULL) | AcDbLayout |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
k0degrees enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1000_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k100_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k10_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k180degrees enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_10 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_100 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_128in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_16 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_16in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_2 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_20 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_2in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_30 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_32in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_4 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_40 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_4in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_5 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_50 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_64in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_8 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_8in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1and1_2in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1ft_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k270degrees enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k2_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3_16in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3_32in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3_4in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3_8in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k4_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k6in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k8_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k90degrees enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kAsDisplayed enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kCustom enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kDisplay enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDraft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kExtents enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHidden enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kInches enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kLayout enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kLimits enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kMaximum enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kMillimeters enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kNormal enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kPixels enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kPresentation enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kPreview enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kRendered enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kRenderPreset enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kScaleToFit enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kView enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kVisualStyle enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kWindow enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kWireframe enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modelType() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotAsRaster() const | AcDbPlotSettings |
plotCentered() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotHidden() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
PlotPaperUnits enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotPaperUnits() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotPlotStyles() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotRotation() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
PlotRotation enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
PlotType enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotType() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotViewportBorders() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotWireframe() const | AcDbPlotSettings |
printLineweights() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
scaleLineweights() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAnnoAllVisible(bool newVal) | AcDbLayout |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockTableRecordId(AcDbObjectId BlockTableRecordId) (defined in AcDbLayout) | AcDbLayout | virtual
setDrawViewportsFirst(Adesk::Boolean drawViewportsFirst) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayoutName(const ACHAR *layoutName) (defined in AcDbLayout) | AcDbLayout | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotHidden(Adesk::Boolean plotHidden) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setPlotPlotStyles(Adesk::Boolean plotPlotStyles) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setPlotSettingsName(const ACHAR *plotSettingsName) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setPlotViewportBorders(Adesk::Boolean plotViewportBorders) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setPrintLineweights(Adesk::Boolean printLineweights) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setScaleLineweights(Adesk::Boolean scaleLineweights) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShadePlot(AcDbPlotSettings::ShadePlotType shadePlot) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShadePlot(const AcDbPlotSettings::ShadePlotType type, const AcDbObjectId shadePlotId) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShadePlotCustomDPI(Adesk::Int16 val) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShadePlotResLevel(AcDbPlotSettings::ShadePlotResLevel resLevel) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShowPlotStyles(Adesk::Boolean showPlotStyles) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setTabOrder(int newOrder) (defined in AcDbLayout) | AcDbLayout | virtual
setTabSelected(Adesk::Boolean tabSelected) (defined in AcDbLayout) | AcDbLayout | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shadePlot() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
shadePlotCustomDPI() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
shadePlotId() const | AcDbPlotSettings |
ShadePlotResLevel enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
shadePlotResLevel() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
ShadePlotType enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
showPlotStyles() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
stdScaleType() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
StdScaleType enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useStandardScale() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbLayout() (defined in AcDbLayout) | AcDbLayout | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPlotSettings() (defined in AcDbPlotSettings) | AcDbPlotSettings | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLayoutManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLayoutManager Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayoutManager:

Public Member Functions

virtual void | addReactor (AcDbLayoutManagerReactor *newObj)=0
virtual Acad::ErrorStatus | cloneLayout (AcDbLayout *pLBTR, const ACHAR *newname, int newTabOrder=0)=0
virtual Acad::ErrorStatus | copyLayout (const ACHAR *copyname, const ACHAR *newname)=0
virtual int | countLayouts (AcDbDatabase *useDb=NULL)=0
virtual Acad::ErrorStatus | createLayout (const ACHAR *newname, AcDbObjectId &layoutId, AcDbObjectId &blockTableRecId, AcDbDatabase *pDatabase=NULL)=0
virtual Acad::ErrorStatus | deleteLayout (const ACHAR *delname)=0
virtual const ACHAR * | findActiveLayout (bool allowModel)=0
virtual AcDbLayout * | findLayoutNamed (const ACHAR *name, bool leaveRecordOpen=false)=0
virtual AcDbObjectId | getActiveLayoutBTRId ()=0
virtual AcDbObjectId | getNonRectVPIdFromClipId (AcDbObjectId clipId)=0
virtual bool | isVpnumClipped (int index)=0
virtual void | removeReactor (AcDbLayoutManagerReactor *delObj)=0
virtual Acad::ErrorStatus | renameLayout (const ACHAR *oldname, const ACHAR *newname)=0
virtual Acad::ErrorStatus | setCurrentLayout (const ACHAR *newname)=0
virtual Acad::ErrorStatus | setCurrentLayoutId (AcDbObjectId layoutId)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • AcDbLMgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayoutManager Member List

This is the complete list of members for AcDbLayoutManager, including all inherited members.

AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addReactor(AcDbLayoutManagerReactor *newObj)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
cloneLayout(AcDbLayout *pLBTR, const ACHAR *newname, int newTabOrder=0)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
copyLayout(const ACHAR *copyname, const ACHAR *newname)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
countLayouts(AcDbDatabase *useDb=NULL)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
createLayout(const ACHAR *newname, AcDbObjectId &layoutId, AcDbObjectId &blockTableRecId, AcDbDatabase *pDatabase=NULL)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
deleteLayout(const ACHAR *delname)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
findActiveLayout(bool allowModel)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
findLayoutNamed(const ACHAR *name, bool leaveRecordOpen=false)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
getActiveLayoutBTRId()=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
getNonRectVPIdFromClipId(AcDbObjectId clipId)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isVpnumClipped(int index)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeReactor(AcDbLayoutManagerReactor *delObj)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
renameLayout(const ACHAR *oldname, const ACHAR *newname)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
setCurrentLayout(const ACHAR *newname)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
setCurrentLayoutId(AcDbObjectId layoutId)=0 (defined in AcDbLayoutManager) | AcDbLayoutManager | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLayoutManagerReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLayoutManagerReactor Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLayoutManagerReactor:

Public Member Functions

virtual void | abortLayoutCopied (const ACHAR *layoutName, const AcDbObjectId &layoutId)
virtual void | abortLayoutRemoved (const ACHAR *layoutName, const AcDbObjectId &layoutId)
virtual void | abortLayoutRename (const ACHAR *oldName, const ACHAR *newName, const AcDbObjectId &layoutId)
ACRX_DECLARE_MEMBERS (AcDbLayoutManagerReactor)
virtual void | layoutCopied (const ACHAR *oldLayoutName, const AcDbObjectId &oldLayoutId, const ACHAR *newLayoutname, const AcDbObjectId &newLayoutId)
virtual void | layoutCreated (const ACHAR *newLayoutName, const AcDbObjectId &layoutId)
virtual void | layoutRemoved (const ACHAR *layoutName, const AcDbObjectId &layoutId)
virtual void | layoutRenamed (const ACHAR *oldName, const ACHAR *newName, const AcDbObjectId &layoutId)
virtual void | layoutsReordered ()
virtual void | layoutSwitched (const ACHAR *newLayoutname, const AcDbObjectId &newLayoutId)
virtual void | layoutToBeCopied (const ACHAR *layoutName, const AcDbObjectId &oldLayoutId)
virtual void | layoutToBeRemoved (const ACHAR *layoutName, const AcDbObjectId &layoutId)
virtual void | layoutToBeRenamed (const ACHAR *oldName, const ACHAR *newName, const AcDbObjectId &layoutId)
virtual void | plotStyleTableChanged (const ACHAR *newTableName, const AcDbObjectId &layoutId)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dblaymgrrctr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLayoutManagerReactor Member List

This is the complete list of members for AcDbLayoutManagerReactor, including all inherited members.

abortLayoutCopied(const ACHAR *layoutName, const AcDbObjectId &layoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
abortLayoutRemoved(const ACHAR *layoutName, const AcDbObjectId &layoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
abortLayoutRename(const ACHAR *oldName, const ACHAR *newName, const AcDbObjectId &layoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
ACRX_DECLARE_MEMBERS(AcDbLayoutManagerReactor) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
layoutCopied(const ACHAR *oldLayoutName, const AcDbObjectId &oldLayoutId, const ACHAR *newLayoutname, const AcDbObjectId &newLayoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
layoutCreated(const ACHAR *newLayoutName, const AcDbObjectId &layoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
layoutRemoved(const ACHAR *layoutName, const AcDbObjectId &layoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
layoutRenamed(const ACHAR *oldName, const ACHAR *newName, const AcDbObjectId &layoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
layoutsReordered() (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
layoutSwitched(const ACHAR *newLayoutname, const AcDbObjectId &newLayoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
layoutToBeCopied(const ACHAR *layoutName, const AcDbObjectId &oldLayoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
layoutToBeRemoved(const ACHAR *layoutName, const AcDbObjectId &layoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
layoutToBeRenamed(const ACHAR *oldName, const ACHAR *newName, const AcDbObjectId &layoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
plotStyleTableChanged(const ACHAR *newTableName, const AcDbObjectId &layoutId) (defined in AcDbLayoutManagerReactor) | AcDbLayoutManagerReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLeader Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbLeader Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLeader:

Public Types

enum AnnoType { kMText = 0, kFcf, kBlockRef, kNoAnno }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLeader)
double | annoHeight () const
virtual AcDbObjectId | annotationObjId () const
virtual AcGeVector3d | annotationOffset () const
AnnoType | annoType () const
double | annoWidth () const
virtual Adesk::Boolean | appendVertex (const AcGePoint3d &)
virtual Acad::ErrorStatus | attachAnnotation (const AcDbObjectId &annoId)
virtual void | copied (const AcDbObject *, const AcDbObject *)
virtual Acad::ErrorStatus | detachAnnotation ()
virtual double | dimasz () const
virtual AcCmColor | dimclrd () const
virtual AcDbHardPointerId | dimensionStyle () const
virtual double | dimgap () const
virtual AcDbObjectId | dimldrblk () const
virtual AcDb::LineWeight | dimlwd () const
virtual bool | dimsah () const
virtual double | dimscale () const
virtual int | dimtad () const
virtual AcDbObjectId | dimtxsty () const
virtual double | dimtxt () const
virtual void | disableArrowHead ()
virtual void | enableArrowHead ()
virtual void | erased (const AcDbObject *, Adesk::Boolean=Adesk::kTrue)
virtual Acad::ErrorStatus | evaluateLeader ()
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual AcGePoint3d | firstVertex () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
virtual void | goodbye (const AcDbObject *)
virtual Adesk::Boolean | hasArrowHead () const
virtual Adesk::Boolean | hasHookLine () const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *, AcDb::Intersect, AcGePoint3dArray &, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *, AcDb::Intersect, const AcGePlane &projPlane, AcGePoint3dArray &, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isSplined () const
virtual AcGePoint3d | lastVertex () const
virtual void | modified (const AcDbObject *)
virtual AcGeVector3d | normal () const
virtual int | numVertices () const
virtual void | removeLastVertex ()
virtual Acad::ErrorStatus | setAnnotationOffset (const AcGeVector3d &offset)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16, Adesk::Boolean doSubents=Adesk::kTrue)
virtual Acad::ErrorStatus | setDimasz (double val)
virtual Acad::ErrorStatus | setDimclrd (AcCmColor &val)
virtual void | setDimensionStyle (const AcDbHardPointerId &)
virtual Acad::ErrorStatus | setDimgap (double val)
virtual Acad::ErrorStatus | setDimldrblk (AcDbObjectId val)
virtual Acad::ErrorStatus | setDimldrblk (const ACHAR *val)
virtual Acad::ErrorStatus | setDimlwd (AcDb::LineWeight v)
virtual Acad::ErrorStatus | setDimsah (bool val)
virtual Acad::ErrorStatus | setDimscale (double val)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
virtual Acad::ErrorStatus | setDimtad (int val)
virtual Acad::ErrorStatus | setDimtxsty (AcDbObjectId val)
virtual Acad::ErrorStatus | setDimtxt (double val)
virtual void | setDimVars ()
virtual DBCURVE_METHODS void | setPlane (const AcGePlane &)
virtual void | setToSplineLeader ()
virtual void | setToStraightLeader ()
virtual Adesk::Boolean | setVertexAt (int, const AcGePoint3d &)
virtual AcGePoint3d | vertexAt (int) const
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dblead.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLeader Member List

This is the complete list of members for AcDbLeader, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLeader) (defined in AcDbLeader) | AcDbLeader |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbLeader() (defined in AcDbLeader) | AcDbLeader |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
annoHeight() const (defined in AcDbLeader) | AcDbLeader |
annotationObjId() const (defined in AcDbLeader) | AcDbLeader | virtual
annotationOffset() const (defined in AcDbLeader) | AcDbLeader | virtual
annoType() const (defined in AcDbLeader) | AcDbLeader |
AnnoType enum name (defined in AcDbLeader) | AcDbLeader |
annoWidth() const (defined in AcDbLeader) | AcDbLeader |
appendVertex(const AcGePoint3d &) (defined in AcDbLeader) | AcDbLeader | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
attachAnnotation(const AcDbObjectId &annoId) (defined in AcDbLeader) | AcDbLeader | virtual
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *, const AcDbObject *) (defined in AcDbLeader) | AcDbLeader | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
detachAnnotation() (defined in AcDbLeader) | AcDbLeader | virtual
dimasz() const (defined in AcDbLeader) | AcDbLeader | virtual
dimclrd() const (defined in AcDbLeader) | AcDbLeader | virtual
dimensionStyle() const (defined in AcDbLeader) | AcDbLeader | virtual
dimgap() const (defined in AcDbLeader) | AcDbLeader | virtual
dimldrblk() const (defined in AcDbLeader) | AcDbLeader | virtual
dimlwd() const (defined in AcDbLeader) | AcDbLeader | virtual
dimsah() const (defined in AcDbLeader) | AcDbLeader | virtual
dimscale() const (defined in AcDbLeader) | AcDbLeader | virtual
dimtad() const (defined in AcDbLeader) | AcDbLeader | virtual
dimtxsty() const (defined in AcDbLeader) | AcDbLeader | virtual
dimtxt() const (defined in AcDbLeader) | AcDbLeader | virtual
disableArrowHead() (defined in AcDbLeader) | AcDbLeader | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
enableArrowHead() (defined in AcDbLeader) | AcDbLeader | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *, Adesk::Boolean=Adesk::kTrue) (defined in AcDbLeader) | AcDbLeader | virtual
evaluateLeader() (defined in AcDbLeader) | AcDbLeader | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbLeader) | AcDbLeader | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
firstVertex() const (defined in AcDbLeader) | AcDbLeader | virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbLeader) | AcDbLeader | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbLeader) | AcDbLeader |
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *) (defined in AcDbLeader) | AcDbLeader | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasArrowHead() const (defined in AcDbLeader) | AcDbLeader | virtual
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasHookLine() const (defined in AcDbLeader) | AcDbLeader | virtual
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *, AcDb::Intersect, AcGePoint3dArray &, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbLeader) | AcDbLeader | virtual
intersectWith(const AcDbEntity *, AcDb::Intersect, const AcGePlane &projPlane, AcGePoint3dArray &, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbLeader) | AcDbLeader | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isSplined() const (defined in AcDbLeader) | AcDbLeader | virtual
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kBlockRef enum value (defined in AcDbLeader) | AcDbLeader |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFcf enum value (defined in AcDbLeader) | AcDbLeader |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kMText enum value (defined in AcDbLeader) | AcDbLeader |
kNoAnno enum value (defined in AcDbLeader) | AcDbLeader |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
lastVertex() const (defined in AcDbLeader) | AcDbLeader | virtual
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *) (defined in AcDbLeader) | AcDbLeader | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbLeader) | AcDbLeader | virtual
numVertices() const (defined in AcDbLeader) | AcDbLeader | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeLastVertex() (defined in AcDbLeader) | AcDbLeader | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAnnotationOffset(const AcGeVector3d &offset) (defined in AcDbLeader) | AcDbLeader | virtual
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16, Adesk::Boolean doSubents=Adesk::kTrue) (defined in AcDbLeader) | AcDbLeader | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimasz(double val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimclrd(AcCmColor &val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimensionStyle(const AcDbHardPointerId &) (defined in AcDbLeader) | AcDbLeader | virtual
setDimgap(double val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimldrblk(AcDbObjectId val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimldrblk(const ACHAR *val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimlwd(AcDb::LineWeight v) (defined in AcDbLeader) | AcDbLeader | virtual
setDimsah(bool val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimscale(double val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbLeader) | AcDbLeader |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbLeader) | AcDbLeader |
setDimtad(int val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimtxsty(AcDbObjectId val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimtxt(double val) (defined in AcDbLeader) | AcDbLeader | virtual
setDimVars() (defined in AcDbLeader) | AcDbLeader | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlane(const AcGePlane &) (defined in AcDbLeader) | AcDbLeader | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setToSplineLeader() (defined in AcDbLeader) | AcDbLeader | virtual
setToStraightLeader() (defined in AcDbLeader) | AcDbLeader | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVertexAt(int, const AcGePoint3d &) (defined in AcDbLeader) | AcDbLeader | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
vertexAt(int) const (defined in AcDbLeader) | AcDbLeader | virtual
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbLeader() (defined in AcDbLeader) | AcDbLeader |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLight Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcDbLight Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLight:

Public Types

enum LampColorPreset {
kD65White = 0, kFluorescent, kCoolWhite, kWhiteFluorescent,
kDaylightFluorescent, kIncandescent, kXenon, kHalogen,
kQuartz, kMetalHalide, kMercury, kPhosphorMercury,
kHighPressureSodium, kLowPressureSodium, kCustom
}
enum | LampColorType { kKelvin = 0, kPreset }
enum | PhysicalIntensityMethod { kPeakIntensity = 0, kFlux, kIlluminance }
- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

AcDbLight ()
ACRX_DECLARE_MEMBERS (AcDbLight)
virtual bool | castShadows () const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwner, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual AcGiDrawable::DrawableType | drawableType () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual double | falloffAngle () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
bool | hasTarget () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId, const Adesk::Boolean highlightAll) const
virtual double | hotspotAngle () const
double | illuminanceDistance () const
virtual double | intensity () const
virtual bool | isOn () const
virtual bool | isPlottable () const
AcDbLight::LampColorPreset | lampColorPreset () const
Acad::ErrorStatus | lampColorRGB (AcGiColorRGB &rgbColor) const
double | lampColorTemp () const
AcDbLight::LampColorType | lampColorType () const
virtual const
AcGiLightAttenuation & 		lightAttenuation () const
virtual const AcCmColor & | lightColor () const
virtual const AcGeVector3d & | lightDirection () const
virtual AcGiDrawable::DrawableType | lightType () const
virtual void | list () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual const AcString & | name () const
double | physicalIntensity () const
AcDbLight::PhysicalIntensityMethod | physicalIntensityMethod () const
virtual const AcGePoint3d & | position () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | resultingColor (AcCmColor &rgbColor) const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setHasTarget (bool hasTarget)
virtual Acad::ErrorStatus | setHotspotAndFalloff (double hotspot, double falloff)
Acad::ErrorStatus | setIlluminanceDistance (double distance)
virtual Acad::ErrorStatus | setIntensity (double intensity)
virtual Acad::ErrorStatus | setIsPlottable (bool plot)
Acad::ErrorStatus | setLampColorPreset (AcDbLight::LampColorPreset colorPreset)
Acad::ErrorStatus | setLampColorRGB (AcGiColorRGB rgbColor)
Acad::ErrorStatus | setLampColorTemp (double colorTemp)
Acad::ErrorStatus | setLampColorType (AcDbLight::LampColorType colorType)
virtual void | setLightAttenuation (const AcGiLightAttenuation &params)
virtual Acad::ErrorStatus | setLightColor (const AcCmColor &color)
virtual Acad::ErrorStatus | setLightDirection (const AcGeVector3d &lightvec)
virtual Acad::ErrorStatus | setLightType (AcGiDrawable::DrawableType type)
virtual Acad::ErrorStatus | setName (const AcString &name)
virtual Acad::ErrorStatus | setOn (bool value)
Acad::ErrorStatus | setPhysicalIntensity (double physicalIntensity)
Acad::ErrorStatus | setPhysicalIntensityMethod (AcDbLight::PhysicalIntensityMethod method)
virtual Acad::ErrorStatus | setPosition (const AcGePoint3d &pos)
virtual void | setReceiveShadows (bool newVal)
virtual void | setShadowParameters (const AcGiShadowParameters &params)
Acad::ErrorStatus | setShadowParameters (const AcGiShadowParameters2 &params)
virtual Acad::ErrorStatus | setTargetLocation (const AcGePoint3d &newVal)
Acad::ErrorStatus | setWebFile (const ACHAR *webFile)
Acad::ErrorStatus | setWebRotation (AcGeVector3d rotation)
virtual const
AcGiShadowParameters & 		shadowParameters () const
Acad::ErrorStatus | shadowParameters (AcGiShadowParameters2 &params) const
virtual Acad::ErrorStatus | subClose ()
virtual const AcGePoint3d & | targetLocation () const
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId, const Adesk::Boolean highlightAll) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary) const
Acad::ErrorStatus | webFile (AcString &webFile) const
Acad::ErrorStatus | webRotation (AcGeVector3d &rotation) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
~AcDbLight ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpLight

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbLight::AcDbLight ( )
Warning
Not implemented!
AcDbLight::~AcDbLight ( )
Warning
Not implemented!

Member Function Documentation

virtual bool AcDbLight::castShadows ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbLight::decomposeForSave | ( | AcDb::AcDbDwgVersion | ver,
 |  | AcDbObject *& | replaceObj,
 |  | AcDbObjectId & | replaceId,
 |  | Adesk::Boolean & | exchangeXData
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbLight::deepClone | ( | AcDbObject * | pOwner,
 |  | AcDbObject *& | pClonedObject,
 |  | AcDbIdMapping & | idMap,
 |  | Adesk::Boolean | isPrimary = true
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual AcGiDrawable::DrawableType AcDbLight::drawableType ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiDrawable.

virtual Acad::ErrorStatus AcDbLight::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual double AcDbLight::falloffAngle ( ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::getGeomExtents ( AcDbExtents & extents ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::getGripPoints | ( | AcDbGripDataPtrArray & | grips,
 |  | const double | curViewUnitSize,
 |  | const int | gripSize,
 |  | const AcGeVector3d & | curViewDir,
 |  | const int | bitflags
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::getOsnapPoints | ( | AcDb::OsnapMode | osnapMode,
 |  | Adesk::GsMarker | gsSelectionMark,
 |  | const AcGePoint3d & | pickPoint,
 |  | const AcGePoint3d & | lastPoint,
 |  | const AcGeMatrix3d & | viewXform,
 |  | AcGePoint3dArray & | snapPoints,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::getOsnapPoints | ( | AcDb::OsnapMode | osnapMode,
 |  | Adesk::GsMarker | gsSelectionMark,
 |  | const AcGePoint3d & | pickPoint,
 |  | const AcGePoint3d & | lastPoint,
 |  | const AcGeMatrix3d & | viewXform,
 |  | AcGePoint3dArray & | snapPoints,
 |  | AcDbIntArray & | geomIds,
 |  | const AcGeMatrix3d & | insertionMat
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::getTransformedCopy | ( | const AcGeMatrix3d & | xform,
 |  | AcDbEntity *& | pEnt
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

bool AcDbLight::hasTarget ( ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::highlight | ( | const AcDbFullSubentPath & | subId,
 |  | const Adesk::Boolean | highlightAll
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual double AcDbLight::hotspotAngle ( ) const
virtual
Warning
Not implemented!
double AcDbLight::illuminanceDistance ( ) const
Warning
Not implemented!
virtual double AcDbLight::intensity ( ) const
virtual
Warning
Not implemented!
virtual bool AcDbLight::isOn ( ) const
virtual
Warning
Not implemented!
virtual bool AcDbLight::isPlottable ( ) const
virtual
Warning
Not implemented!
AcDbLight::LampColorPreset AcDbLight::lampColorPreset ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::lampColorRGB ( AcGiColorRGB & rgbColor ) const
Warning
Not implemented!
double AcDbLight::lampColorTemp ( ) const
Warning
Not implemented!
AcDbLight::LampColorType AcDbLight::lampColorType ( ) const
Warning
Not implemented!
virtual const AcGiLightAttenuation& AcDbLight::lightAttenuation ( ) const
virtual
Warning
Not implemented!
virtual const AcCmColor& AcDbLight::lightColor ( ) const
virtual
Warning
Not implemented!
virtual const AcGeVector3d& AcDbLight::lightDirection ( ) const
virtual
Warning
Not implemented!
virtual AcGiDrawable::DrawableType AcDbLight::lightType ( ) const
virtual
Warning
Not implemented!
virtual void AcDbLight::list ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::moveGripPointsAt | ( | const AcDbVoidPtrArray & | gripAppData,
 |  | const AcGeVector3d & | offset,
 |  | const int | bitflags
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual const AcString& AcDbLight::name ( ) const
virtual
Warning
Not implemented!
double AcDbLight::physicalIntensity ( ) const
Warning
Not implemented!
AcDbLight::PhysicalIntensityMethod AcDbLight::physicalIntensityMethod ( ) const
Warning
Not implemented!
virtual const AcGePoint3d& AcDbLight::position ( ) const
virtual
Warning
Not implemented!
virtual bool AcDbLight::receiveShadows ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Acad::ErrorStatus AcDbLight::resultingColor ( AcCmColor & rgbColor ) const
Warning
Not implemented!
virtual Adesk::UInt32 AcDbLight::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual void AcDbLight::setCastShadows ( bool newVal )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Acad::ErrorStatus AcDbLight::setHasTarget ( bool hasTarget )
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setHotspotAndFalloff | ( | double | hotspot,
 |  | double | falloff
 | ) |  |
virtual
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setIlluminanceDistance ( double distance )
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setIntensity ( double intensity )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setIsPlottable ( bool plot )
virtual
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setLampColorPreset ( AcDbLight::LampColorPreset colorPreset )
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setLampColorRGB ( AcGiColorRGB rgbColor )
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setLampColorTemp ( double colorTemp )
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setLampColorType ( AcDbLight::LampColorType colorType )
Warning
Not implemented!
virtual void AcDbLight::setLightAttenuation ( const AcGiLightAttenuation & params )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setLightColor ( const AcCmColor & color )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setLightDirection ( const AcGeVector3d & lightvec )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setLightType ( AcGiDrawable::DrawableType type )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setName ( const AcString & name )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setOn ( bool value )
virtual
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setPhysicalIntensity ( double physicalIntensity )
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setPhysicalIntensityMethod ( AcDbLight::PhysicalIntensityMethod method )
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setPosition ( const AcGePoint3d & pos )
virtual
Warning
Not implemented!
virtual void AcDbLight::setReceiveShadows ( bool newVal )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual void AcDbLight::setShadowParameters ( const AcGiShadowParameters & params )
virtual
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setShadowParameters ( const AcGiShadowParameters2 & params )
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::setTargetLocation ( const AcGePoint3d & newVal )
virtual
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setWebFile ( const ACHAR * webFile )
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::setWebRotation ( AcGeVector3d rotation )
Warning
Not implemented!
virtual const AcGiShadowParameters& AcDbLight::shadowParameters ( ) const
virtual
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::shadowParameters ( AcGiShadowParameters2 & params ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::subClose ( )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual const AcGePoint3d& AcDbLight::targetLocation ( ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLight::transformBy ( const AcGeMatrix3d & xform )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::unhighlight | ( | const AcDbFullSubentPath & | subId,
 |  | const Adesk::Boolean | highlightAll
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual void AcDbLight::viewportDraw ( AcGiViewportDraw * mode )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLight::wblockClone | ( | AcRxObject * | pOwnerObject,
 |  | AcDbObject *& | pClonedObject,
 |  | AcDbIdMapping & | idMap,
 |  | Adesk::Boolean | isPrimary
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Acad::ErrorStatus AcDbLight::webFile ( AcString & webFile ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbLight::webRotation ( AcGeVector3d & rotation ) const
Warning
Not implemented!
virtual Adesk::Boolean AcDbLight::worldDraw ( AcGiWorldDraw * mode )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

The documentation for this class was generated from the following file:
  • dbLight.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLight Member List

This is the complete list of members for AcDbLight, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbImpLight (defined in AcDbLight) | AcDbLight | friend
AcDbLight() | AcDbLight |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbLight) (defined in AcDbLight) | AcDbLight |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const | AcDbLight | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) | AcDbLight | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) | AcDbLight | virtual
deepClone(AcDbObject *pOwner, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const | AcDbLight | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const | AcDbLight | virtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbLight | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbLight | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbLight | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbLight | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
falloffAngle() const | AcDbLight | virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbLight | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const | AcDbLight | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const | AcDbLight | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbLight | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const | AcDbLight | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const | AcDbLight | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hasTarget() const | AcDbLight |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId, const Adesk::Boolean highlightAll) const | AcDbLight | virtual
hotspotAngle() const | AcDbLight | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
illuminanceDistance() const | AcDbLight |
intensity() const | AcDbLight | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isOn() const | AcDbLight | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isPlottable() const | AcDbLight | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kCoolWhite enum value (defined in AcDbLight) | AcDbLight |
kCustom enum value (defined in AcDbLight) | AcDbLight |
kD65White enum value (defined in AcDbLight) | AcDbLight |
kDaylightFluorescent enum value (defined in AcDbLight) | AcDbLight |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFluorescent enum value (defined in AcDbLight) | AcDbLight |
kFlux enum value (defined in AcDbLight) | AcDbLight |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHalogen enum value (defined in AcDbLight) | AcDbLight |
kHighPressureSodium enum value (defined in AcDbLight) | AcDbLight |
kIlluminance enum value (defined in AcDbLight) | AcDbLight |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kIncandescent enum value (defined in AcDbLight) | AcDbLight |
kKelvin enum value (defined in AcDbLight) | AcDbLight |
kLowPressureSodium enum value (defined in AcDbLight) | AcDbLight |
kMercury enum value (defined in AcDbLight) | AcDbLight |
kMetalHalide enum value (defined in AcDbLight) | AcDbLight |
kPeakIntensity enum value (defined in AcDbLight) | AcDbLight |
kPhosphorMercury enum value (defined in AcDbLight) | AcDbLight |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kPreset enum value (defined in AcDbLight) | AcDbLight |
kQuartz enum value (defined in AcDbLight) | AcDbLight |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kWhiteFluorescent enum value (defined in AcDbLight) | AcDbLight |
kXenon enum value (defined in AcDbLight) | AcDbLight |
LampColorPreset enum name (defined in AcDbLight) | AcDbLight |
lampColorPreset() const | AcDbLight |
lampColorRGB(AcGiColorRGB &rgbColor) const | AcDbLight |
lampColorTemp() const | AcDbLight |
lampColorType() const | AcDbLight |
LampColorType enum name (defined in AcDbLight) | AcDbLight |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
lightAttenuation() const | AcDbLight | virtual
lightColor() const | AcDbLight | virtual
lightDirection() const | AcDbLight | virtual
lightType() const | AcDbLight | virtual
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const | AcDbLight | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) | AcDbLight | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
name() const | AcDbLight | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
physicalIntensity() const | AcDbLight |
PhysicalIntensityMethod enum name (defined in AcDbLight) | AcDbLight |
physicalIntensityMethod() const | AcDbLight |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const | AcDbLight | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const | AcDbLight | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
resultingColor(AcCmColor &rgbColor) const | AcDbLight |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbLight | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) | AcDbLight | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHasTarget(bool hasTarget) | AcDbLight |
setHotspotAndFalloff(double hotspot, double falloff) | AcDbLight | virtual
setIlluminanceDistance(double distance) | AcDbLight |
setIntensity(double intensity) | AcDbLight | virtual
setIsPlottable(bool plot) | AcDbLight | virtual
setLampColorPreset(AcDbLight::LampColorPreset colorPreset) | AcDbLight |
setLampColorRGB(AcGiColorRGB rgbColor) | AcDbLight |
setLampColorTemp(double colorTemp) | AcDbLight |
setLampColorType(AcDbLight::LampColorType colorType) | AcDbLight |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLightAttenuation(const AcGiLightAttenuation &params) | AcDbLight | virtual
setLightColor(const AcCmColor &color) | AcDbLight | virtual
setLightDirection(const AcGeVector3d &lightvec) | AcDbLight | virtual
setLightType(AcGiDrawable::DrawableType type) | AcDbLight | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setName(const AcString &name) | AcDbLight | virtual
setOn(bool value) | AcDbLight | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPhysicalIntensity(double physicalIntensity) | AcDbLight |
setPhysicalIntensityMethod(AcDbLight::PhysicalIntensityMethod method) | AcDbLight |
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &pos) | AcDbLight | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) | AcDbLight | virtual
setShadowParameters(const AcGiShadowParameters &params) | AcDbLight | virtual
setShadowParameters(const AcGiShadowParameters2 &params) | AcDbLight |
setTargetLocation(const AcGePoint3d &newVal) | AcDbLight | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWebFile(const ACHAR *webFile) | AcDbLight |
setWebRotation(AcGeVector3d rotation) | AcDbLight |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shadowParameters() const | AcDbLight | virtual
shadowParameters(AcGiShadowParameters2 &params) const | AcDbLight |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() | AcDbLight | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
targetLocation() const | AcDbLight | virtual
transformBy(const AcGeMatrix3d &xform) | AcDbLight | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId, const Adesk::Boolean highlightAll) const | AcDbLight | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) | AcDbLight | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary) const | AcDbLight | virtual
webFile(AcString &webFile) const | AcDbLight |
webRotation(AcGeVector3d &rotation) const | AcDbLight |
worldDraw(AcGiWorldDraw *mode) | AcDbLight | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbLight() | AcDbLight |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLine Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLine Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLine:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLine)
AcDbLine (const AcGePoint3d &start, const AcGePoint3d &end)
virtual bool | castShadows () const
AcGePoint3d | endPoint () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
DBCURVE_METHODS Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&ent) const
virtual void | gripStatus (const AcDb::GripStat status)
AcGeVector3d | normal () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | setEndPoint (const AcGePoint3d &)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setStartPoint (const AcGePoint3d &)
Acad::ErrorStatus | setThickness (double)
AcGePoint3d | startPoint () const
double | thickness () const
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLine Member List

This is the complete list of members for AcDbLine, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLine) (defined in AcDbLine) | AcDbLine |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbLine() (defined in AcDbLine) | AcDbLine |
AcDbLine(const AcGePoint3d &start, const AcGePoint3d &end) (defined in AcDbLine) | AcDbLine |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbLine) | AcDbLine | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
endPoint() const (defined in AcDbLine) | AcDbLine |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbLine) | AcDbLine | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbLine) | AcDbLine | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbLine) | AcDbLine | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbLine) | AcDbLine | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&ent) const (defined in AcDbLine) | AcDbLine | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbLine) | AcDbLine | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbLine) | AcDbLine |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbLine) | AcDbLine | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setEndPoint(const AcGePoint3d &) (defined in AcDbLine) | AcDbLine |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbLine) | AcDbLine |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setStartPoint(const AcGePoint3d &) (defined in AcDbLine) | AcDbLine |
setThickness(double) (defined in AcDbLine) | AcDbLine |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
startPoint() const (defined in AcDbLine) | AcDbLine |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thickness() const (defined in AcDbLine) | AcDbLine |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbLine() (defined in AcDbLine) | AcDbLine |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLinetypeTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbLinetypeTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLinetypeTable:

Public Types

typedef AcDbLinetypeTableRecord | RecordType
- Public Types inherited from AcDbSymbolTable
typedef AcDbSymbolTableRecord | RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLinetypeTable)
Acad::ErrorStatus | add (AcDbLinetypeTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbLinetypeTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbLinetypeTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbLinetypeTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLinetypeTable Member List

This is the complete list of members for AcDbLinetypeTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLinetypeTable) (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbLinetypeTable() (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbLinetypeTableRecord *pRecord) (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
add(AcDbObjectId &recordId, AcDbLinetypeTableRecord *pRecord) (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbLinetypeTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbLinetypeTable) | AcDbLinetypeTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
has(AcDbObjectId id) const (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbLinetypeTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbLinetypeTable) | AcDbLinetypeTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbLinetypeTable() (defined in AcDbLinetypeTable) | AcDbLinetypeTable | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLinetypeTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbLinetypeTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLinetypeTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbLinetypeTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbLinetypeTableRecord *pRecord)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbLinetypeTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLinetypeTableIterator Member List

This is the complete list of members for AcDbLinetypeTableIterator, including all inherited members.

AcDbLinetypeTable (defined in AcDbLinetypeTableIterator) | AcDbLinetypeTableIterator | friend
AcDbLinetypeTableIterator() (defined in AcDbLinetypeTableIterator) | AcDbLinetypeTableIterator | protected
AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbLinetypeTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbLinetypeTableIterator) | AcDbLinetypeTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbLinetypeTableIterator) | AcDbLinetypeTableIterator |
seek(const AcDbLinetypeTableRecord *pRecord) (defined in AcDbLinetypeTableIterator) | AcDbLinetypeTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbLinetypeTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbLinetypeTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLinetypeTableRecord:

Public Types

typedef AcDbLinetypeTable | TableType
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable | TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLinetypeTableRecord)
Acad::ErrorStatus | asciiDescription (ACHAR *&pString) const
Acad::ErrorStatus | asciiDescription (const ACHAR *&pString) const
Acad::ErrorStatus | comments (ACHAR *&pString) const
Acad::ErrorStatus | comments (const ACHAR *&pString) const
double | dashLengthAt (int index) const
AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
AcGsNode * | gsNode () const
bool | isScaledToFit () const
int | numDashes () const
double | patternLength () const
Acad::ErrorStatus | setAsciiDescription (const ACHAR *pString)
Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setComments (const ACHAR *pString)
void | setDashLengthAt (int index, double value)
void | setGsNode (AcGsNode *pNode)
void | setIsScaledToFit (bool scaledToFit)
void | setNumDashes (int count)
void | setPatternLength (double patternLength)
void | setShapeIsUcsOrientedAt (int index, bool isUcsOriented)
void | setShapeNumberAt (int index, int shapeNumber)
void | setShapeOffsetAt (int index, const AcGeVector2d &offset)
void | setShapeRotationAt (int index, double rotation)
void | setShapeScaleAt (int index, double scale)
void | setShapeStyleAt (int index, AcDbObjectId id)
Acad::ErrorStatus | setTextAt (int index, const ACHAR *text)
bool | shapeIsUcsOrientedAt (int index) const
int | shapeNumberAt (int index) const
AcGeVector2d | shapeOffsetAt (int index) const
double | shapeRotationAt (int index) const
double | shapeScaleAt (int index) const
AcDbObjectId | shapeStyleAt (int index) const
Acad::ErrorStatus | textAt (int index, ACHAR *&text) const
Acad::ErrorStatus | textAt (int index, const ACHAR *&text) const
void | viewportDraw (AcGiViewportDraw *pVd)
Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLinetypeTableRecord Member List

This is the complete list of members for AcDbLinetypeTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLinetypeTableRecord) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbLinetypeTableRecord() (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
asciiDescription(ACHAR *&pString) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | inline
asciiDescription(const ACHAR *&pString) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | inline
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comments(ACHAR *&pString) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
comments(const ACHAR *&pString) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
dashLengthAt(int index) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isScaledToFit() const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
numDashes() const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
patternLength() const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAsciiDescription(const ACHAR *pString) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | inline
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setComments(const ACHAR *pString) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setDashLengthAt(int index, double value) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setIsScaledToFit(bool scaledToFit) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setNumDashes(int count) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPatternLength(double patternLength) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setShapeIsUcsOrientedAt(int index, bool isUcsOriented) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setShapeNumberAt(int index, int shapeNumber) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setShapeOffsetAt(int index, const AcGeVector2d &offset) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setShapeRotationAt(int index, double rotation) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setShapeScaleAt(int index, double scale) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setShapeStyleAt(int index, AcDbObjectId id) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setTextAt(int index, const ACHAR *text) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shapeIsUcsOrientedAt(int index) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
shapeNumberAt(int index) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
shapeOffsetAt(int index) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
shapeRotationAt(int index) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
shapeScaleAt(int index) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
shapeStyleAt(int index) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
textAt(int index, ACHAR *&text) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
textAt(int index, const ACHAR *&text) const (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbLinetypeTableRecord() (defined in AcDbLinetypeTableRecord) | AcDbLinetypeTableRecord | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLinkedData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLinkedData Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLinkedData:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLinkedData)
virtual ACDB_PORT Acad::ErrorStatus | clear (void)
virtual ACDB_PORT const ACHAR * | description (void) const
virtual ACDB_PORT Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual ACDB_PORT bool | isEmpty (void) const
virtual ACDB_PORT const ACHAR * | name (void) const
virtual ACDB_PORT Acad::ErrorStatus | setDescription (const ACHAR *pszDescription)
virtual ACDB_PORT Acad::ErrorStatus | setName (const ACHAR *pszName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • DbLinkedData.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLinkedData Member List

This is the complete list of members for AcDbLinkedData, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLinkedData) (defined in AcDbLinkedData) | AcDbLinkedData |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clear(void) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEmpty(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
name(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDescription(const ACHAR *pszDescription) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setName(const ACHAR *pszName) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLinkedTableData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLinkedTableData Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLinkedTableData:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLinkedTableData)
virtual ACDB_PORT int | appendColumn (int nNumCols)
virtual ACDB_PORT int | appendRow (int nNumRows)
virtual ACDB_PORT bool | canDelete (int nIndex, int nCount, bool bRow) const
virtual ACDB_PORT bool | canInsert (int nIndex, bool bRow) const
virtual ACDB_PORT AcDb::CellState | cellState (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | clear (void)
virtual ACDB_PORT
AcDb::CellContentType 		contentType (int nRow, int nCol) const
virtual ACDB_PORT
AcDb::CellContentType 		contentType (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRange)
virtual ACDB_PORT int | createContent (int nRow, int nCol, int nIndex)
virtual ACDB_PORT AcString | dataFormat (int nRow, int nCol) const
virtual ACDB_PORT AcString | dataFormat (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | deleteColumn (int nIndex, int nNumColsToDelete)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (int nRow, int nCol, int nContent)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (int nRow, int nCol)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (const AcCellRange &range)
virtual ACDB_PORT Acad::ErrorStatus | deleteRow (int nIndex, int nNumRowsToDelete)
virtual ACDB_PORT Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | evaluateFormula (void)
virtual ACDB_PORT AcString | getBlockAttributeValue (int nRow, int nCol, const AcDbObjectId &idAttDef) const
virtual ACDB_PORT AcString | getBlockAttributeValue (int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef) const
virtual ACDB_PORT AcDbObjectId | getBlockTableRecordId (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | getBlockTableRecordId (int nRow, int nCol, int nContent) const
virtual ACDB_PORT const ACHAR * | getColumnName (int nIndex) const
virtual ACDB_PORT int | getCustomData (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getCustomData (int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const
virtual ACDB_PORT AcDbObjectId | getDataLink (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getDataLink (int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const
virtual ACDB_PORT int | getDataLink (const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const
virtual ACDB_PORT AcCellRange | getDataLinkRange (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getDataType (int nRow, int nCol, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
virtual ACDB_PORT Acad::ErrorStatus | getDataType (int nRow, int nCol, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
virtual ACDB_PORT Acad::ErrorStatus | getField (int nRow, int nCol, int nContent, AcDbField *&pField, AcDb::OpenMode mode) const
virtual ACDB_PORT AcDbObjectId | getFieldId (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | getFieldId (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcString | getFormula (int nRow, int nCol, int nContent) const
ACDB_PORT AcDbTableIterator * | getIterator (void) const
ACDB_PORT AcDbTableIterator * | getIterator (const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol, int nContent, AcValue::FormatOption nOption) const
virtual ACDB_PORT AcString | getToolTip (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getValue (int nRow, int nCol, AcValue &value) const
virtual ACDB_PORT Acad::ErrorStatus | getValue (int nRow, int nCol, int nContent, AcValue::FormatOption nOption, AcValue &value) const
virtual ACDB_PORT bool | hasFormula (int nRow, int nCol, int nContent) const
virtual ACDB_PORT int | insertColumn (int nIndex, int nNumCols)
virtual ACDB_PORT int | insertRow (int nIndex, int nNumRows)
virtual ACDB_PORT bool | isContentEditable (int nRow, int nCol) const
virtual ACDB_PORT bool | isLinked (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | moveContent (int nRow, int nCol, int nFromIndex, int nToIndex)
virtual ACDB_PORT int | numColumns (void) const
virtual ACDB_PORT int | numContents (int nRow, int nCol) const
virtual ACDB_PORT int | numRows (void) const
virtual ACDB_PORT Acad::ErrorStatus | removeDataLink (int nRow, int nCol)
virtual ACDB_PORT Acad::ErrorStatus | removeDataLink (void)
virtual ACDB_PORT Acad::ErrorStatus | setBlockAttributeValue (int nRow, int nCol, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue)
virtual ACDB_PORT Acad::ErrorStatus | setBlockAttributeValue (int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue)
virtual ACDB_PORT Acad::ErrorStatus | setBlockTableRecordId (int nRow, int nCol, const AcDbObjectId &idBTR)
virtual ACDB_PORT Acad::ErrorStatus | setBlockTableRecordId (int nRow, int nCol, int nContent, const AcDbObjectId &idBTR)
virtual ACDB_PORT Acad::ErrorStatus | setCellState (int nRow, int nCol, AcDb::CellState nCellState)
virtual ACDB_PORT Acad::ErrorStatus | setColumnName (int nIndex, const ACHAR *pszName)
virtual ACDB_PORT Acad::ErrorStatus | setCustomData (int nRow, int nCol, int nData)
virtual ACDB_PORT Acad::ErrorStatus | setCustomData (int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData)
virtual ACDB_PORT Acad::ErrorStatus | setDataFormat (int nRow, int nCol, const ACHAR *pszFormat)
virtual ACDB_PORT Acad::ErrorStatus | setDataFormat (int nRow, int nCol, int nContent, const ACHAR *pszFormat)
virtual ACDB_PORT Acad::ErrorStatus | setDataLink (int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate)
virtual ACDB_PORT Acad::ErrorStatus | setDataLink (const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate)
virtual ACDB_PORT Acad::ErrorStatus | setDataType (int nRow, int nCol, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ACDB_PORT Acad::ErrorStatus | setDataType (int nRow, int nCol, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, const AcDbObjectId &idField)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, int nContent, const AcDbObjectId &idField)
virtual ACDB_PORT Acad::ErrorStatus | setFormula (int nRow, int nCol, int nContent, const ACHAR *pszFormula)
virtual ACDB_PORT Acad::ErrorStatus | setSize (int nRows, int nCols)
virtual ACDB_PORT Acad::ErrorStatus | setText (int nRow, int nCol, const ACHAR *pszText)
virtual ACDB_PORT Acad::ErrorStatus | setText (int nRow, int nCol, int nContent, const ACHAR *pszText)
virtual ACDB_PORT Acad::ErrorStatus | setToolTip (int nRow, int nCol, const ACHAR *pszToolTip)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, const AcValue &value)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, int nContent, const AcValue &value)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, int nContent, const AcValue &value, AcValue::ParseOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | updateDataLink (int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | updateDataLink (AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
- Public Member Functions inherited from AcDbLinkedData
ACDB_DECLARE_MEMBERS (AcDbLinkedData)
virtual ACDB_PORT const ACHAR * | description (void) const
virtual ACDB_PORT bool | isEmpty (void) const
virtual ACDB_PORT const ACHAR * | name (void) const
virtual ACDB_PORT Acad::ErrorStatus | setDescription (const ACHAR *pszDescription)
virtual ACDB_PORT Acad::ErrorStatus | setName (const ACHAR *pszName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • DbLinkedTableData.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLinkedTableData Member List

This is the complete list of members for AcDbLinkedTableData, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLinkedTableData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
ACDB_DECLARE_MEMBERS(AcDbLinkedData) (defined in AcDbLinkedData) | AcDbLinkedData |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData |
AcDbLinkedTableData(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
appendColumn(int nNumCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
appendRow(int nNumRows) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
canDelete(int nIndex, int nCount, bool bRow) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
canInsert(int nIndex, bool bRow) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
cellState(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
clear(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contentType(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
contentType(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRange) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createContent(int nRow, int nCol, int nIndex) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
dataFormat(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
dataFormat(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteColumn(int nIndex, int nNumColsToDelete) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(int nRow, int nCol, int nContent) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(int nRow, int nCol) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(const AcCellRange &range) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteRow(int nIndex, int nNumRowsToDelete) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
evaluateFormula(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBlockAttributeValue(int nRow, int nCol, const AcDbObjectId &idAttDef) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockAttributeValue(int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockTableRecordId(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockTableRecordId(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getColumnName(int nIndex) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getCustomData(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getCustomData(int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLinkRange(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataType(int nRow, int nCol, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataType(int nRow, int nCol, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getField(int nRow, int nCol, int nContent, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldId(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getFieldId(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getFormula(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getIterator(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
getIterator(const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getText(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getText(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getText(int nRow, int nCol, int nContent, AcValue::FormatOption nOption) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getToolTip(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getValue(int nRow, int nCol, AcValue &value) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getValue(int nRow, int nCol, int nContent, AcValue::FormatOption nOption, AcValue &value) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasFormula(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
insertColumn(int nIndex, int nNumCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
insertRow(int nIndex, int nNumRows) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isContentEditable(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
isEmpty(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLinked(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveContent(int nRow, int nCol, int nFromIndex, int nToIndex) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
name(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
numColumns(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
numContents(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
numRows(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeDataLink(int nRow, int nCol) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
removeDataLink(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockAttributeValue(int nRow, int nCol, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockAttributeValue(int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockTableRecordId(int nRow, int nCol, const AcDbObjectId &idBTR) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockTableRecordId(int nRow, int nCol, int nContent, const AcDbObjectId &idBTR) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCellState(int nRow, int nCol, AcDb::CellState nCellState) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setColumnName(int nIndex, const ACHAR *pszName) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCustomData(int nRow, int nCol, int nData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCustomData(int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataFormat(int nRow, int nCol, const ACHAR *pszFormat) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataFormat(int nRow, int nCol, int nContent, const ACHAR *pszFormat) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataLink(int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataLink(const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataType(int nRow, int nCol, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataType(int nRow, int nCol, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDescription(const ACHAR *pszDescription) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFieldId(int nRow, int nCol, const AcDbObjectId &idField) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setFieldId(int nRow, int nCol, int nContent, const AcDbObjectId &idField) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setFormula(int nRow, int nCol, int nContent, const ACHAR *pszFormula) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setName(const ACHAR *pszName) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setSize(int nRows, int nCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setText(int nRow, int nCol, const ACHAR *pszText) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setText(int nRow, int nCol, int nContent, const ACHAR *pszText) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setToolTip(int nRow, int nCol, const ACHAR *pszToolTip) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, const AcValue &value) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, int nContent, const AcValue &value) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, int nContent, const AcValue &value, AcValue::ParseOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
updateDataLink(int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
updateDataLink(AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
~AcDbLinkedTableData(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLoftedSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLoftedSurface Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLoftedSurface:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLoftedSurface)
AcDbLoftedSurface ()
virtual Acad::ErrorStatus | createLoftedSurface (AcArray< AcDbEntity * > &crossSectionCurves, AcArray< AcDbEntity * > &guideCurves, AcDbEntity *pPathCurve, AcDbLoftOptions &loftOptions)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
AcDbEntity * | getCrossSection (int idx) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
AcDbEntity * | getGuideCurve (int idx) const
void | getLoftOptions (AcDbLoftOptions &loftOptions) const
AcDbEntity * | getPathEntity () const
virtual bool | isDependent () const
virtual void | list () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
int | numCrossSections () const
int | numGuideCurves () const
Acad::ErrorStatus | setLoftOptions (const AcDbLoftOptions &loftOptions)
virtual | ~AcDbLoftedSurface ()
- Public Member Functions inherited from AcDbSurface
ACDB_DECLARE_MEMBERS (AcDbSurface)
AcDbSurface ()
virtual void * | body () const
virtual Acad::ErrorStatus | convertToRegion (AcArray< AcDbEntity * > &regions)
virtual Acad::ErrorStatus | getArea (double &area) const
virtual AcDbSubentId | internalSubentId (void *ent) const
virtual void * | internalSubentPtr (const AcDbSubentId &id) const
virtual Acad::ErrorStatus | setBody (const void *modelerBody)
virtual Acad::ErrorStatus | setUIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | setVIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | thicken (double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const
virtual Adesk::UInt16 | uIsolineDensity () const
virtual Adesk::UInt16 | vIsolineDensity () const
virtual | ~AcDbSurface ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcDbSurface
static Acad::ErrorStatus | createFrom (const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface)

Constructor & Destructor Documentation

AcDbLoftedSurface::AcDbLoftedSurface ( )
Warning
Not implemented!
virtual AcDbLoftedSurface::~AcDbLoftedSurface ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbLoftedSurface::createLoftedSurface | ( | AcArray< AcDbEntity * > & | crossSectionCurves,
 |  | AcArray< AcDbEntity * > & | guideCurves,
 |  | AcDbEntity * | pPathCurve,
 |  | AcDbLoftOptions & | loftOptions
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLoftedSurface::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbLoftedSurface::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbLoftedSurface::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbLoftedSurface::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbLoftedSurface::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

AcDbEntity* AcDbLoftedSurface::getCrossSection ( int idx ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbLoftedSurface::getGripEntityUCS | ( | const void * | pGripAppData,
 |  | AcGeVector3d & | normalVec,
 |  | AcGePoint3d & | origin,
 |  | AcGeVector3d & | xAxis
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLoftedSurface::getGripPoints | ( | AcGePoint3dArray & | gripPoints,
 |  | AcDbIntArray & | osnapModes,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLoftedSurface::getGripPoints | ( | AcDbGripDataPtrArray & | grips,
 |  | const double | curViewUnitSize,
 |  | const int | gripSize,
 |  | const AcGeVector3d & | curViewDir,
 |  | const int | bitflags
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

AcDbEntity* AcDbLoftedSurface::getGuideCurve ( int idx ) const
Warning
Not implemented!
void AcDbLoftedSurface::getLoftOptions ( AcDbLoftOptions & loftOptions ) const
Warning
Not implemented!
AcDbEntity* AcDbLoftedSurface::getPathEntity ( ) const
Warning
Not implemented!
virtual bool AcDbLoftedSurface::isDependent ( ) const
virtual
Warning
Not implemented!
virtual void AcDbLoftedSurface::list ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbLoftedSurface::moveGripPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbLoftedSurface::moveStretchPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

int AcDbLoftedSurface::numCrossSections ( ) const
Warning
Not implemented!
int AcDbLoftedSurface::numGuideCurves ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbLoftedSurface::setLoftOptions ( const AcDbLoftOptions & loftOptions )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbloftedsurf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLoftedSurface Member List

This is the complete list of members for AcDbLoftedSurface, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLoftedSurface) (defined in AcDbLoftedSurface) | AcDbLoftedSurface |
ACDB_DECLARE_MEMBERS(AcDbSurface) (defined in AcDbSurface) | AcDbSurface |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbLoftedSurface() | AcDbLoftedSurface |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSurface() | AcDbSurface |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
body() const | AcDbSurface | virtual
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToRegion(AcArray< AcDbEntity * > &regions) | AcDbSurface | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createFrom(const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface) | AcDbSurface | static
createLoftedSurface(AcArray< AcDbEntity * > &crossSectionCurves, AcArray< AcDbEntity * > &guideCurves, AcDbEntity *pPathCurve, AcDbLoftOptions &loftOptions) | AcDbLoftedSurface | virtual
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbLoftedSurface | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbLoftedSurface | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbLoftedSurface | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbLoftedSurface | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &area) const | AcDbSurface | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbLoftedSurface | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getCrossSection(int idx) const | AcDbLoftedSurface |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const | AcDbLoftedSurface | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const | AcDbLoftedSurface | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const | AcDbLoftedSurface | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getGuideCurve(int idx) const | AcDbLoftedSurface |
getLoftOptions(AcDbLoftOptions &loftOptions) const | AcDbLoftedSurface |
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPathEntity() const | AcDbLoftedSurface |
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
internalSubentId(void *ent) const | AcDbSurface | virtual
internalSubentPtr(const AcDbSubentId &id) const | AcDbSurface | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const | AcDbLoftedSurface | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const | AcDbLoftedSurface | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbLoftedSurface | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbLoftedSurface | virtual
numCrossSections() const | AcDbLoftedSurface |
numGuideCurves() const | AcDbLoftedSurface |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBody(const void *modelerBody) | AcDbSurface | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLoftOptions(const AcDbLoftOptions &loftOptions) | AcDbLoftedSurface |
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thicken(double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const | AcDbSurface | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
uIsolineDensity() const | AcDbSurface | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
vIsolineDensity() const | AcDbSurface | virtual
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbLoftedSurface() | AcDbLoftedSurface | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSurface() | AcDbSurface | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLoftOptions Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcDbLoftOptions Class Reference
AcDb Classes

Public Types

enum NormalOption {
kNoNormal, kFirstNormal, kLastNormal, kEndsNormal,
kAllNormal, kUseDraftAngles
}

Public Member Functions

AcDbLoftOptions ()
AcDbLoftOptions (const AcDbLoftOptions &src)
bool | alignDirection () const
bool | arcLengthParam () const
Acad::ErrorStatus | checkCrossSectionCurves (AcArray< AcDbEntity * > &crossSectionCurves, bool &allOpen, bool &allClosed, bool &allPlanar, bool displayErrorMessages=false)
Acad::ErrorStatus | checkGuideCurves (AcArray< AcDbEntity * > &guideCurves, bool displayErrorMessages=false)
Acad::ErrorStatus | checkLoftCurves (AcArray< AcDbEntity * > &crossSectionCurves, AcArray< AcDbEntity * > &guideCurves, AcDbEntity *pPathCurve, bool &allOpen, bool &allClosed, bool &allPlanar, bool displayErrorMessages=false)
Acad::ErrorStatus | checkOptions (bool displayErrorMessages=false)
Acad::ErrorStatus | checkPathCurve (AcDbEntity *pPathCurve, bool displayErrorMessages=false)
bool | closed () const
double | draftEnd () const
double | draftEndMag () const
double | draftStart () const
double | draftStartMag () const
AcDbLoftOptions::NormalOption | normal () const
bool | noTwist () const
AcDbLoftOptions & | operator= (const AcDbLoftOptions &src)
bool | ruled () const
void | setAlignDirection (bool val)
void | setArcLengthParam (bool val)
void | setClosed (bool val)
void | setDraftEnd (double ang)
void | setDraftEndMag (double val)
void | setDraftStart (double ang)
void | setDraftStartMag (double val)
void | setNormal (AcDbLoftOptions::NormalOption val)
void | setNoTwist (bool val)
Acad::ErrorStatus | setOptionsFromSysvars ()
void | setRuled (bool val)
void | setSimplify (bool val)
Acad::ErrorStatus | setSysvarsFromOptions ()
void | setVirtualGuide (bool val)
bool | simplify () const
bool | virtualGuide () const
~AcDbLoftOptions ()

Friends

class AcDbImpLoftOptions

Constructor & Destructor Documentation

AcDbLoftOptions::AcDbLoftOptions ( )
Warning
Not implemented!
AcDbLoftOptions::AcDbLoftOptions ( const AcDbLoftOptions & src )
Warning
Not implemented!
AcDbLoftOptions::~AcDbLoftOptions ( )
Warning
Not implemented!

Member Function Documentation

bool AcDbLoftOptions::alignDirection ( ) const
Warning
Not implemented!
bool AcDbLoftOptions::arcLengthParam ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbLoftOptions::checkCrossSectionCurves | ( | AcArray< AcDbEntity * > & | crossSectionCurves,
 |  | bool & | allOpen,
 |  | bool & | allClosed,
 |  | bool & | allPlanar,
 |  | bool | displayErrorMessages = false
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbLoftOptions::checkGuideCurves | ( | AcArray< AcDbEntity * > & | guideCurves,
 |  | bool | displayErrorMessages = false
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbLoftOptions::checkLoftCurves | ( | AcArray< AcDbEntity * > & | crossSectionCurves,
 |  | AcArray< AcDbEntity * > & | guideCurves,
 |  | AcDbEntity * | pPathCurve,
 |  | bool & | allOpen,
 |  | bool & | allClosed,
 |  | bool & | allPlanar,
 |  | bool | displayErrorMessages = false
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbLoftOptions::checkOptions ( bool displayErrorMessages = false )
Warning
Not implemented!
Acad::ErrorStatus AcDbLoftOptions::checkPathCurve | ( | AcDbEntity * | pPathCurve,
 |  | bool | displayErrorMessages = false
 | ) |  |
Warning
Not implemented!
bool AcDbLoftOptions::closed ( ) const
Warning
Not implemented!
double AcDbLoftOptions::draftEnd ( ) const
Warning
Not implemented!
double AcDbLoftOptions::draftEndMag ( ) const
Warning
Not implemented!
double AcDbLoftOptions::draftStart ( ) const
Warning
Not implemented!
double AcDbLoftOptions::draftStartMag ( ) const
Warning
Not implemented!
AcDbLoftOptions::NormalOption AcDbLoftOptions::normal ( ) const
Warning
Not implemented!
bool AcDbLoftOptions::noTwist ( ) const
Warning
Not implemented!
AcDbLoftOptions& AcDbLoftOptions::operator= ( const AcDbLoftOptions & src )
Warning
Not implemented!
bool AcDbLoftOptions::ruled ( ) const
Warning
Not implemented!
void AcDbLoftOptions::setAlignDirection ( bool val )
Warning
Not implemented!
void AcDbLoftOptions::setArcLengthParam ( bool val )
Warning
Not implemented!
void AcDbLoftOptions::setClosed ( bool val )
Warning
Not implemented!
void AcDbLoftOptions::setDraftEnd ( double ang )
Warning
Not implemented!
void AcDbLoftOptions::setDraftEndMag ( double val )
Warning
Not implemented!
void AcDbLoftOptions::setDraftStart ( double ang )
Warning
Not implemented!
void AcDbLoftOptions::setDraftStartMag ( double val )
Warning
Not implemented!
void AcDbLoftOptions::setNormal ( AcDbLoftOptions::NormalOption val )
Warning
Not implemented!
void AcDbLoftOptions::setNoTwist ( bool val )
Warning
Not implemented!
Acad::ErrorStatus AcDbLoftOptions::setOptionsFromSysvars ( )
Warning
Not implemented!
void AcDbLoftOptions::setRuled ( bool val )
Warning
Not implemented!
void AcDbLoftOptions::setSimplify ( bool val )
Warning
Not implemented!
Acad::ErrorStatus AcDbLoftOptions::setSysvarsFromOptions ( )
Warning
Not implemented!
void AcDbLoftOptions::setVirtualGuide ( bool val )
Warning
Not implemented!
bool AcDbLoftOptions::simplify ( ) const
Warning
Not implemented!
bool AcDbLoftOptions::virtualGuide ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbLoftOptions.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLoftOptions Member List

This is the complete list of members for AcDbLoftOptions, including all inherited members.

AcDbImpLoftOptions (defined in AcDbLoftOptions) | AcDbLoftOptions | friend
AcDbLoftOptions() AcDbLoftOptions
AcDbLoftOptions(const AcDbLoftOptions &src) | AcDbLoftOptions
alignDirection() const | AcDbLoftOptions
arcLengthParam() const | AcDbLoftOptions
checkCrossSectionCurves(AcArray< AcDbEntity * > &crossSectionCurves, bool &allOpen, bool &allClosed, bool &allPlanar, bool displayErrorMessages=false) | AcDbLoftOptions
checkGuideCurves(AcArray< AcDbEntity * > &guideCurves, bool displayErrorMessages=false) | AcDbLoftOptions
checkLoftCurves(AcArray< AcDbEntity * > &crossSectionCurves, AcArray< AcDbEntity * > &guideCurves, AcDbEntity *pPathCurve, bool &allOpen, bool &allClosed, bool &allPlanar, bool displayErrorMessages=false) | AcDbLoftOptions
checkOptions(bool displayErrorMessages=false) | AcDbLoftOptions
checkPathCurve(AcDbEntity *pPathCurve, bool displayErrorMessages=false) | AcDbLoftOptions
closed() const | AcDbLoftOptions
draftEnd() const | AcDbLoftOptions
draftEndMag() const | AcDbLoftOptions
draftStart() const | AcDbLoftOptions
draftStartMag() const | AcDbLoftOptions
kAllNormal enum value (defined in AcDbLoftOptions) | AcDbLoftOptions
kEndsNormal enum value (defined in AcDbLoftOptions) | AcDbLoftOptions
kFirstNormal enum value (defined in AcDbLoftOptions) | AcDbLoftOptions
kLastNormal enum value (defined in AcDbLoftOptions) | AcDbLoftOptions
kNoNormal enum value (defined in AcDbLoftOptions) | AcDbLoftOptions
kUseDraftAngles enum value (defined in AcDbLoftOptions) | AcDbLoftOptions
normal() const | AcDbLoftOptions
NormalOption enum name (defined in AcDbLoftOptions) | AcDbLoftOptions
noTwist() const | AcDbLoftOptions
operator=(const AcDbLoftOptions &src) | AcDbLoftOptions
ruled() const | AcDbLoftOptions
setAlignDirection(bool val) | AcDbLoftOptions
setArcLengthParam(bool val) | AcDbLoftOptions
setClosed(bool val) | AcDbLoftOptions
setDraftEnd(double ang) | AcDbLoftOptions
setDraftEndMag(double val) | AcDbLoftOptions
setDraftStart(double ang) | AcDbLoftOptions
setDraftStartMag(double val) | AcDbLoftOptions
setNormal(AcDbLoftOptions::NormalOption val) | AcDbLoftOptions
setNoTwist(bool val) | AcDbLoftOptions
setOptionsFromSysvars() AcDbLoftOptions
setRuled(bool val) | AcDbLoftOptions
setSimplify(bool val) | AcDbLoftOptions
setSysvarsFromOptions() AcDbLoftOptions
setVirtualGuide(bool val) | AcDbLoftOptions
simplify() const | AcDbLoftOptions
virtualGuide() const | AcDbLoftOptions


ZRX API Reference: AcDbLongTransaction Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbLongTransaction Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLongTransaction:

Public Types

enum { kSameDb = 0, kXrefDb = 1, kUnrelatedDb = 2 }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbLongTransaction)
AcDbIdMapping * | activeIdMap ()
Acad::ErrorStatus | addToWorkSet (AcDbObjectId id)
AcDbObjectId | destinationBlock () const
bool | disallowDrawOrder ()
Acad::ErrorStatus | getLongTransactionName (ACHAR *&) const
Acad::ErrorStatus | newWorkSetIterator (AcDbLongTransWorkSetIterator *&pNewIter, bool incRemovedObjs=false, bool incSecondaryObjs=false) const
AcDbObjectId | originBlock () const
AcDbObjectId | originObject (AcDbObjectId id) const
void | regenWorkSetWithDrawOrder ()
Acad::ErrorStatus | removeFromWorkSet (AcDbObjectId id)
Acad::ErrorStatus | syncWorkSet ()
int | type () const
bool | workSetHas (AcDbObjectId id, bool bIncErased=false) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbltrans.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLongTransaction Member List

This is the complete list of members for AcDbLongTransaction, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbLongTransaction) (defined in AcDbLongTransaction) | AcDbLongTransaction |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbLongTransaction() (defined in AcDbLongTransaction) | AcDbLongTransaction |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
activeIdMap() (defined in AcDbLongTransaction) | AcDbLongTransaction |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addToWorkSet(AcDbObjectId id) (defined in AcDbLongTransaction) | AcDbLongTransaction |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
destinationBlock() const (defined in AcDbLongTransaction) | AcDbLongTransaction |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
disallowDrawOrder() (defined in AcDbLongTransaction) | AcDbLongTransaction |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getLongTransactionName(ACHAR *&) const (defined in AcDbLongTransaction) | AcDbLongTransaction |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSameDb enum value (defined in AcDbLongTransaction) | AcDbLongTransaction |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kUnrelatedDb enum value (defined in AcDbLongTransaction) | AcDbLongTransaction |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kXrefDb enum value (defined in AcDbLongTransaction) | AcDbLongTransaction |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newWorkSetIterator(AcDbLongTransWorkSetIterator *&pNewIter, bool incRemovedObjs=false, bool incSecondaryObjs=false) const (defined in AcDbLongTransaction) | AcDbLongTransaction |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
originBlock() const (defined in AcDbLongTransaction) | AcDbLongTransaction |
originObject(AcDbObjectId id) const (defined in AcDbLongTransaction) | AcDbLongTransaction |
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
regenWorkSetWithDrawOrder() (defined in AcDbLongTransaction) | AcDbLongTransaction |
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeFromWorkSet(AcDbObjectId id) (defined in AcDbLongTransaction) | AcDbLongTransaction |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
syncWorkSet() (defined in AcDbLongTransaction) | AcDbLongTransaction |
type() const (defined in AcDbLongTransaction) | AcDbLongTransaction |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
workSetHas(AcDbObjectId id, bool bIncErased=false) const (defined in AcDbLongTransaction) | AcDbLongTransaction |
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbLongTransaction() (defined in AcDbLongTransaction) | AcDbLongTransaction |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbLongTransWorkSetIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbLongTransWorkSetIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbLongTransWorkSetIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbLongTransWorkSetIterator)
virtual bool | curObjectIsErased () const =0
virtual bool | curObjectIsPrimary () const =0
virtual bool | curObjectIsRemoved () const =0
virtual bool | done ()=0
virtual AcDbObjectId | objectId () const =0
virtual void | start (bool incRemovedObjs=false, bool incSecondaryObjs=false)=0
virtual void | step ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbltrans.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbLongTransWorkSetIterator Member List

This is the complete list of members for AcDbLongTransWorkSetIterator, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbLongTransWorkSetIterator) (defined in AcDbLongTransWorkSetIterator) | AcDbLongTransWorkSetIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
curObjectIsErased() const =0 (defined in AcDbLongTransWorkSetIterator) | AcDbLongTransWorkSetIterator | pure virtual
curObjectIsPrimary() const =0 (defined in AcDbLongTransWorkSetIterator) | AcDbLongTransWorkSetIterator | pure virtual
curObjectIsRemoved() const =0 (defined in AcDbLongTransWorkSetIterator) | AcDbLongTransWorkSetIterator | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
done()=0 (defined in AcDbLongTransWorkSetIterator) | AcDbLongTransWorkSetIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
objectId() const =0 (defined in AcDbLongTransWorkSetIterator) | AcDbLongTransWorkSetIterator | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
start(bool incRemovedObjs=false, bool incSecondaryObjs=false)=0 (defined in AcDbLongTransWorkSetIterator) | AcDbLongTransWorkSetIterator | pure virtual
step()=0 (defined in AcDbLongTransWorkSetIterator) | AcDbLongTransWorkSetIterator | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbLongTransWorkSetIterator() (defined in AcDbLongTransWorkSetIterator) | AcDbLongTransWorkSetIterator | inlinevirtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMatchProperties Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbMatchProperties Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMatchProperties:

Public Types

enum Flags {
kColorFlag = 0x1, kLayerFlag = 0x2, kLtypeFlag = 0x4, kThicknessFlag = 0x8,
kLtscaleFlag = 0x10, kTextFlag = 0x20, kDimensionFlag = 0x40, kHatchFlag = 0x80,
kLweightFlag = 0x100, kPlotstylenameFlag = 0x200, kPolylineFlag = 0x400, kViewportFlag = 0x800,
kTableFlag = 0x1000, kMaterialFlag = 0x2000, kShadowDisplayFlag = 0x4000, kMultileaderFlag = 0x8000,
kSetAllFlagsOn = 0xFFFF
}

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbMatchProperties)
virtual void | copyProperties (AcDbEntity *pSrcEntity, AcDbEntity *pTrgEntity, unsigned int flag) const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbmatch.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMatchProperties Member List

This is the complete list of members for AcDbMatchProperties, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbMatchProperties) (defined in AcDbMatchProperties) | AcDbMatchProperties |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
copyProperties(AcDbEntity *pSrcEntity, AcDbEntity *pTrgEntity, unsigned int flag) const =0 (defined in AcDbMatchProperties) | AcDbMatchProperties | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
Flags enum name (defined in AcDbMatchProperties) | AcDbMatchProperties |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kColorFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kDimensionFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kHatchFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kLayerFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kLtscaleFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kLtypeFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kLweightFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kMaterialFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kMultileaderFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kPlotstylenameFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kPolylineFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kSetAllFlagsOn enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kShadowDisplayFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kTableFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kTextFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kThicknessFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
kViewportFlag enum value (defined in AcDbMatchProperties) | AcDbMatchProperties |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMaterial Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbMaterial Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMaterial:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbMaterial)
virtual void | ambient (AcGiMaterialColor &color) const
virtual void | bump (AcGiMaterialMap &map) const
virtual
AcGiMaterialTraits::ChannelFlags 		channelFlags () const
double | colorBleedScale () const
virtual const ACHAR * | description (void) const
virtual void | diffuse (AcGiMaterialColor &color, AcGiMaterialMap &map) const
virtual AcGiDrawable * | drawable (void)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcGiMaterialTraits2::FinalGatherMode | finalGather () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
AcGiMaterialTraits2::GlobalIlluminationMode | globalIllumination () const
virtual AcGsNode * | gsNode (void) const
virtual
AcGiMaterialTraits::IlluminationModel 		illuminationModel () const
double | indirectBumpScale () const
Adesk::Boolean | isAnonymous () const
double | luminance () const
AcGiMaterialTraits2::LuminanceMode | luminanceMode () const
virtual AcGiMaterialTraits::Mode | mode () const
virtual const ACHAR * | name (void) const
Acad::ErrorStatus | normalMap (AcGiMaterialMap &map, AcGiMaterialTraits2::NormalMapMethod &method, double &strength) const
virtual void | opacity (double &dPercentage, AcGiMaterialMap &map) const
double | reflectanceScale () const
virtual void | reflection (AcGiMaterialMap &map) const
virtual double | reflectivity () const
virtual void | refraction (double &dIndex, AcGiMaterialMap &map) const
virtual double | selfIllumination () const
virtual void | setAmbient (const AcGiMaterialColor &color)
Acad::ErrorStatus | setAnonymous (Adesk::Boolean isAnonymous)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setBump (const AcGiMaterialMap &map)
virtual Acad::ErrorStatus | setChannelFlags (AcGiMaterialTraits::ChannelFlags value)
Acad::ErrorStatus | setColorBleedScale (double value)
virtual Acad::ErrorStatus | setDescription (const ACHAR *pDescription)
virtual void | setDiffuse (const AcGiMaterialColor &color, const AcGiMaterialMap &map)
void | setFinalGather (AcGiMaterialTraits2::FinalGatherMode mode)
void | setGlobalIllumination (AcGiMaterialTraits2::GlobalIlluminationMode mode)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setIlluminationModel (AcGiMaterialTraits::IlluminationModel model)
Acad::ErrorStatus | setIndirectBumpScale (double value)
Acad::ErrorStatus | setLuminance (double value)
Acad::ErrorStatus | setLuminanceMode (AcGiMaterialTraits2::LuminanceMode value)
virtual Acad::ErrorStatus | setMode (AcGiMaterialTraits::Mode value)
virtual Acad::ErrorStatus | setName (const ACHAR *pName)
Acad::ErrorStatus | setNormalMap (const AcGiMaterialMap &map, AcGiMaterialTraits2::NormalMapMethod method, double strength)
virtual void | setOpacity (double dPercentage, const AcGiMaterialMap &map)
Acad::ErrorStatus | setReflectanceScale (double value)
virtual void | setReflection (const AcGiMaterialMap &map)
virtual Acad::ErrorStatus | setReflectivity (double value)
virtual void | setRefraction (double dIndex, const AcGiMaterialMap &map)
virtual Acad::ErrorStatus | setSelfIllumination (double value)
Acad::ErrorStatus | setShininess (double value)
virtual void | setSpecular (const AcGiMaterialColor &color, const AcGiMaterialMap &map, double dGloss)
virtual Acad::ErrorStatus | setTranslucence (double value)
Acad::ErrorStatus | setTransmittanceScale (double value)
Acad::ErrorStatus | setTwoSided (Adesk::Boolean value)
double | shininess () const
virtual void | specular (AcGiMaterialColor &color, AcGiMaterialMap &map, double &dGloss) const
virtual double | translucence () const
double | transmittanceScale () const
Adesk::Boolean | twoSided () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

virtual Acad::ErrorStatus AcDbMaterial::setChannelFlags ( AcGiMaterialTraits::ChannelFlags value )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbmaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMaterial Member List

This is the complete list of members for AcDbMaterial, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbMaterial) (defined in AcDbMaterial) | AcDbMaterial |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbMaterial() (defined in AcDbMaterial) | AcDbMaterial |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
ambient(AcGiMaterialColor &color) const (defined in AcDbMaterial) | AcDbMaterial | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
bump(AcGiMaterialMap &map) const (defined in AcDbMaterial) | AcDbMaterial | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
channelFlags() const (defined in AcDbMaterial) | AcDbMaterial | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
colorBleedScale() const (defined in AcDbMaterial) | AcDbMaterial |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbMaterial) | AcDbMaterial | virtual
diffuse(AcGiMaterialColor &color, AcGiMaterialMap &map) const (defined in AcDbMaterial) | AcDbMaterial | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable(void) (defined in AcDbMaterial) | AcDbMaterial | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbMaterial) | AcDbMaterial | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbMaterial) | AcDbMaterial | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbMaterial) | AcDbMaterial | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbMaterial) | AcDbMaterial | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
finalGather() const (defined in AcDbMaterial) | AcDbMaterial |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbMaterial) | AcDbMaterial | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
globalIllumination() const (defined in AcDbMaterial) | AcDbMaterial |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode(void) const (defined in AcDbMaterial) | AcDbMaterial | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
illuminationModel() const (defined in AcDbMaterial) | AcDbMaterial | virtual
indirectBumpScale() const (defined in AcDbMaterial) | AcDbMaterial |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAnonymous() const (defined in AcDbMaterial) | AcDbMaterial |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
luminance() const (defined in AcDbMaterial) | AcDbMaterial |
luminanceMode() const (defined in AcDbMaterial) | AcDbMaterial |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
mode() const (defined in AcDbMaterial) | AcDbMaterial | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
name(void) const (defined in AcDbMaterial) | AcDbMaterial | virtual
normalMap(AcGiMaterialMap &map, AcGiMaterialTraits2::NormalMapMethod &method, double &strength) const (defined in AcDbMaterial) | AcDbMaterial |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
opacity(double &dPercentage, AcGiMaterialMap &map) const (defined in AcDbMaterial) | AcDbMaterial | virtual
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
reflectanceScale() const (defined in AcDbMaterial) | AcDbMaterial |
reflection(AcGiMaterialMap &map) const (defined in AcDbMaterial) | AcDbMaterial | virtual
reflectivity() const (defined in AcDbMaterial) | AcDbMaterial | virtual
refraction(double &dIndex, AcGiMaterialMap &map) const (defined in AcDbMaterial) | AcDbMaterial | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
selfIllumination() const (defined in AcDbMaterial) | AcDbMaterial | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAmbient(const AcGiMaterialColor &color) (defined in AcDbMaterial) | AcDbMaterial | virtual
setAnonymous(Adesk::Boolean isAnonymous) (defined in AcDbMaterial) | AcDbMaterial |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbMaterial) | AcDbMaterial | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBump(const AcGiMaterialMap &map) (defined in AcDbMaterial) | AcDbMaterial | virtual
setChannelFlags(AcGiMaterialTraits::ChannelFlags value) | AcDbMaterial | virtual
setColorBleedScale(double value) (defined in AcDbMaterial) | AcDbMaterial |
setDescription(const ACHAR *pDescription) (defined in AcDbMaterial) | AcDbMaterial | virtual
setDiffuse(const AcGiMaterialColor &color, const AcGiMaterialMap &map) (defined in AcDbMaterial) | AcDbMaterial | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFinalGather(AcGiMaterialTraits2::FinalGatherMode mode) (defined in AcDbMaterial) | AcDbMaterial |
setGlobalIllumination(AcGiMaterialTraits2::GlobalIlluminationMode mode) (defined in AcDbMaterial) | AcDbMaterial |
setGsNode(AcGsNode *pNode) (defined in AcDbMaterial) | AcDbMaterial | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setIlluminationModel(AcGiMaterialTraits::IlluminationModel model) (defined in AcDbMaterial) | AcDbMaterial | virtual
setIndirectBumpScale(double value) (defined in AcDbMaterial) | AcDbMaterial |
setLuminance(double value) (defined in AcDbMaterial) | AcDbMaterial |
setLuminanceMode(AcGiMaterialTraits2::LuminanceMode value) (defined in AcDbMaterial) | AcDbMaterial |
setMode(AcGiMaterialTraits::Mode value) (defined in AcDbMaterial) | AcDbMaterial | virtual
setName(const ACHAR *pName) (defined in AcDbMaterial) | AcDbMaterial | virtual
setNormalMap(const AcGiMaterialMap &map, AcGiMaterialTraits2::NormalMapMethod method, double strength) (defined in AcDbMaterial) | AcDbMaterial |
setOpacity(double dPercentage, const AcGiMaterialMap &map) (defined in AcDbMaterial) | AcDbMaterial | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setReflectanceScale(double value) (defined in AcDbMaterial) | AcDbMaterial |
setReflection(const AcGiMaterialMap &map) (defined in AcDbMaterial) | AcDbMaterial | virtual
setReflectivity(double value) (defined in AcDbMaterial) | AcDbMaterial | virtual
setRefraction(double dIndex, const AcGiMaterialMap &map) (defined in AcDbMaterial) | AcDbMaterial | virtual
setSelfIllumination(double value) (defined in AcDbMaterial) | AcDbMaterial | virtual
setShininess(double value) (defined in AcDbMaterial) | AcDbMaterial |
setSpecular(const AcGiMaterialColor &color, const AcGiMaterialMap &map, double dGloss) (defined in AcDbMaterial) | AcDbMaterial | virtual
setTranslucence(double value) (defined in AcDbMaterial) | AcDbMaterial | virtual
setTransmittanceScale(double value) (defined in AcDbMaterial) | AcDbMaterial |
setTwoSided(Adesk::Boolean value) (defined in AcDbMaterial) | AcDbMaterial |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shininess() const (defined in AcDbMaterial) | AcDbMaterial |
specular(AcGiMaterialColor &color, AcGiMaterialMap &map, double &dGloss) const (defined in AcDbMaterial) | AcDbMaterial | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
translucence() const (defined in AcDbMaterial) | AcDbMaterial | virtual
transmittanceScale() const (defined in AcDbMaterial) | AcDbMaterial |
twoSided() const (defined in AcDbMaterial) | AcDbMaterial |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbMaterial() (defined in AcDbMaterial) | AcDbMaterial | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMentalRayRenderSettings Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbMentalRayRenderSettings Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMentalRayRenderSettings:

Public Types

enum ShadowSamplingMultiplier {
kSamplingMultiplierZero = 0, kSamplingMultiplierOneEighth, kSamplingMultiplierOneFourth, kSamplingMultiplierOneHalf,
kSamplingMultiplierOne, kSamplingMultiplierTwo
}

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbMentalRayRenderSettings)
Acad::ErrorStatus | copyFrom (const AcRxObject *other)
AcGiMrDiagnosticBSPMode | diagnosticBSPMode () const
void | diagnosticGridMode (AcGiMrDiagnosticGridMode &eDiagnosticGridMode, float &fSize) const
AcGiMrDiagnosticMode | diagnosticMode () const
AcGiMrDiagnosticPhotonMode | diagnosticPhotonMode () const
bool | diagnosticSamplesMode () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
float | energyMultiplier () const
bool | exportMIEnabled () const
AcString | exportMIFileName () const
int | fgRayCount () const
void | fgSampleRadius (double &fMin, double &fMax) const
void | fgSampleRadiusState (bool &bMin, bool &bMax, bool &bPixels) const
bool | finalGatheringEnabled () const
AcGiMrFinalGatheringMode | finalGatheringMode () const
int | giPhotonsPerLight () const
int | giSampleCount () const
double | giSampleRadius () const
bool | giSampleRadiusEnabled () const
bool | globalIlluminationEnabled () const
double | lightLuminanceScale () const
int | memoryLimit () const
virtual bool | operator== (const AcDbMentalRayRenderSettings &settings)
void | photonTraceDepth (int &iReflection, int &iRefraction, int &iSum) const
void | rayTraceDepth (int &iReflection, int &iRefraction, int &iSum) const
bool | rayTracingEnabled () const
void | sampling (int &iMin, int &iMax) const
void | samplingContrastColor (float &r, float &g, float &b, float &a) const
void | SamplingFilter (AcGiMrFilter &eFilter, double &fWidth, double &fHeight) const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
void | setDiagnosticBSPMode (AcGiMrDiagnosticBSPMode eDiagnosticBSPMode)
Acad::ErrorStatus | setDiagnosticGridMode (AcGiMrDiagnosticGridMode eDiagnosticGridMode, float fSize)
void | setDiagnosticMode (AcGiMrDiagnosticMode eDiagnosticMode)
void | setDiagnosticPhotonMode (AcGiMrDiagnosticPhotonMode eDiagnosticPhotonMode)
void | setDiagnosticSamplesMode (bool bDiagnosticSamplesMode)
Acad::ErrorStatus | setEnergyMultiplier (float fScale)
void | setExportMIEnabled (bool bEnabled)
Acad::ErrorStatus | setExportMIFileName (const AcString &strFileName)
void | setFGRadiusState (bool bMin, bool bMax, bool bPixels)
Acad::ErrorStatus | setFGRayCount (int iNum)
Acad::ErrorStatus | setFGSampleRadius (double fMin, double fMax)
void | setFinalGatheringEnabled (bool bEnabled)
Acad::ErrorStatus | setFinalGatheringMode (AcGiMrFinalGatheringMode mode)
Acad::ErrorStatus | setGIPhotonsPerLight (int iNum)
Acad::ErrorStatus | setGISampleCount (int iNum)
Acad::ErrorStatus | setGISampleRadius (double fRadius)
void | setGISampleRadiusEnabled (bool bEnabled)
void | setGlobalIlluminationEnabled (bool bEnabled)
Acad::ErrorStatus | setLightLuminanceScale (double fLuminance)
Acad::ErrorStatus | setMemoryLimit (int iMemoryLimit)
Acad::ErrorStatus | setPhotonTraceDepth (int iReflection, int iRefraction, int iSum)
Acad::ErrorStatus | setRayTraceDepth (int iReflection, int iRefraction, int iSum)
void | setRayTracingEnabled (bool bEnabled)
Acad::ErrorStatus | setSampling (int iMin, int iMax)
Acad::ErrorStatus | setSamplingContrastColor (float r, float g, float b, float a)
Acad::ErrorStatus | setSamplingFilter (AcGiMrFilter eFilter, double fWidth, double fHeight)
void | setShadowMapsEnabled (bool bEnabled)
void | setShadowMode (AcGiMrShadowMode eShadowMode)
Acad::ErrorStatus | setShadowSamplingMultiplier (AcDbMentalRayRenderSettings::ShadowSamplingMultiplier multiplier)
void | setTileOrder (AcGiMrTileOrder eTileOrder)
Acad::ErrorStatus | setTileSize (int iTileSize)
bool | shadowMapsEnabled () const
AcGiMrShadowMode | shadowMode () const
AcDbMentalRayRenderSettings::ShadowSamplingMultiplier | shadowSamplingMultiplier () const
AcGiMrTileOrder | tileOrder () const
int | tileSize () const
- Public Member Functions inherited from AcDbRenderSettings
AcDbRenderSettings ()
ACRX_DECLARE_MEMBERS (AcDbRenderSettings)
bool | backFacesEnabled () const
AcString | description () const
bool | diagnosticBackgroundEnabled () const
int | displayIndex () const
virtual AcGiDrawable * | drawable ()
bool | materialsEnabled () const
AcString | name () const
virtual bool | operator== (const AcDbRenderSettings &settings)
AcString | previewImageFileName () const
void | setBackFacesEnabled (bool bEnabled)
void | setDescription (const AcString &strDes)
void | setDiagnosticBackgroundEnabled (bool bEnabled)
void | setDisplayIndex (int idx)
void | setMaterialsEnabled (bool bEnabled)
Acad::ErrorStatus | setName (const AcString &strName)
Acad::ErrorStatus | setPreviewImageFileName (const AcString &strFileName)
void | setShadowsEnabled (bool bEnabled)
void | setTextureSampling (bool bSampling)
bool | shadowsEnabled () const
bool | textureSampling () const
virtual | ~AcDbRenderSettings ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbRender.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMentalRayRenderSettings Member List

This is the complete list of members for AcDbMentalRayRenderSettings, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbMentalRayRenderSettings() (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRenderSettings() | AcDbRenderSettings |
ACRX_DECLARE_MEMBERS(AcDbMentalRayRenderSettings) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
ACRX_DECLARE_MEMBERS(AcDbRenderSettings) (defined in AcDbRenderSettings) | AcDbRenderSettings |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
backFacesEnabled() const | AcDbRenderSettings |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description() const | AcDbRenderSettings |
diagnosticBackgroundEnabled() const | AcDbRenderSettings |
diagnosticBSPMode() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
diagnosticGridMode(AcGiMrDiagnosticGridMode &eDiagnosticGridMode, float &fSize) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
diagnosticMode() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
diagnosticPhotonMode() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
diagnosticSamplesMode() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
displayIndex() const | AcDbRenderSettings |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() | AcDbRenderSettings | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings | virtual
energyMultiplier() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
exportMIEnabled() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
exportMIFileName() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fgRayCount() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
fgSampleRadius(double &fMin, double &fMax) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
fgSampleRadiusState(bool &bMin, bool &bMax, bool &bPixels) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
finalGatheringEnabled() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
finalGatheringMode() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
giPhotonsPerLight() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
giSampleCount() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
giSampleRadius() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
giSampleRadiusEnabled() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
globalIlluminationEnabled() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSamplingMultiplierOne enum value (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
kSamplingMultiplierOneEighth enum value (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
kSamplingMultiplierOneFourth enum value (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
kSamplingMultiplierOneHalf enum value (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
kSamplingMultiplierTwo enum value (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
kSamplingMultiplierZero enum value (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
lightLuminanceScale() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
materialsEnabled() const | AcDbRenderSettings |
memoryLimit() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
name() const | AcDbRenderSettings |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator==(const AcDbMentalRayRenderSettings &settings) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings | virtual
AcDbRenderSettings::operator==(const AcDbRenderSettings &settings) | AcDbRenderSettings | virtual
ownerId() const (defined in AcDbObject) | AcDbObject |
photonTraceDepth(int &iReflection, int &iRefraction, int &iSum) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
previewImageFileName() const | AcDbRenderSettings |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rayTraceDepth(int &iReflection, int &iRefraction, int &iSum) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
rayTracingEnabled() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
sampling(int &iMin, int &iMax) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
samplingContrastColor(float &r, float &g, float &b, float &a) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
SamplingFilter(AcGiMrFilter &eFilter, double &fWidth, double &fHeight) const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBackFacesEnabled(bool bEnabled) | AcDbRenderSettings |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDescription(const AcString &strDes) | AcDbRenderSettings |
setDiagnosticBackgroundEnabled(bool bEnabled) | AcDbRenderSettings |
setDiagnosticBSPMode(AcGiMrDiagnosticBSPMode eDiagnosticBSPMode) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setDiagnosticGridMode(AcGiMrDiagnosticGridMode eDiagnosticGridMode, float fSize) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setDiagnosticMode(AcGiMrDiagnosticMode eDiagnosticMode) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setDiagnosticPhotonMode(AcGiMrDiagnosticPhotonMode eDiagnosticPhotonMode) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setDiagnosticSamplesMode(bool bDiagnosticSamplesMode) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setDisplayIndex(int idx) | AcDbRenderSettings |
setEnergyMultiplier(float fScale) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setExportMIEnabled(bool bEnabled) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setExportMIFileName(const AcString &strFileName) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setFGRadiusState(bool bMin, bool bMax, bool bPixels) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setFGRayCount(int iNum) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setFGSampleRadius(double fMin, double fMax) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFinalGatheringEnabled(bool bEnabled) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setFinalGatheringMode(AcGiMrFinalGatheringMode mode) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setGIPhotonsPerLight(int iNum) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setGISampleCount(int iNum) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setGISampleRadius(double fRadius) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setGISampleRadiusEnabled(bool bEnabled) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setGlobalIlluminationEnabled(bool bEnabled) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLightLuminanceScale(double fLuminance) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setMaterialsEnabled(bool bEnabled) | AcDbRenderSettings |
setMemoryLimit(int iMemoryLimit) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setName(const AcString &strName) | AcDbRenderSettings |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPhotonTraceDepth(int iReflection, int iRefraction, int iSum) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setPreviewImageFileName(const AcString &strFileName) | AcDbRenderSettings |
setRayTraceDepth(int iReflection, int iRefraction, int iSum) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setRayTracingEnabled(bool bEnabled) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setSampling(int iMin, int iMax) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setSamplingContrastColor(float r, float g, float b, float a) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setSamplingFilter(AcGiMrFilter eFilter, double fWidth, double fHeight) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setShadowMapsEnabled(bool bEnabled) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setShadowMode(AcGiMrShadowMode eShadowMode) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setShadowSamplingMultiplier(AcDbMentalRayRenderSettings::ShadowSamplingMultiplier multiplier) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setShadowsEnabled(bool bEnabled) | AcDbRenderSettings |
setTextureSampling(bool bSampling) | AcDbRenderSettings |
setTileOrder(AcGiMrTileOrder eTileOrder) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setTileSize(int iTileSize) (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shadowMapsEnabled() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
shadowMode() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
shadowSamplingMultiplier() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
ShadowSamplingMultiplier enum name (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
shadowsEnabled() const | AcDbRenderSettings |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textureSampling() const | AcDbRenderSettings |
tileOrder() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
tileSize() const (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbMentalRayRenderSettings() (defined in AcDbMentalRayRenderSettings) | AcDbMentalRayRenderSettings | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRenderSettings() | AcDbRenderSettings | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMInsertBlock Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbMInsertBlock Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMInsertBlock:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbMInsertBlock)
AcDbMInsertBlock (const AcGePoint3d &position, AcDbObjectId blockTableRec, Adesk::UInt16 columns, Adesk::UInt16 rows, double colSpacing, double rowSpacing)
Adesk::UInt16 | columns () const
double | columnSpacing () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Adesk::UInt16 | rows () const
double | rowSpacing () const
Acad::ErrorStatus | setColumns (Adesk::UInt16)
Acad::ErrorStatus | setColumnSpacing (double)
Acad::ErrorStatus | setRows (Adesk::UInt16)
Acad::ErrorStatus | setRowSpacing (double)
- Public Member Functions inherited from AcDbBlockReference
ACDB_DECLARE_MEMBERS (AcDbBlockReference)
AcDbBlockReference (const AcGePoint3d &position, AcDbObjectId blockTableRec)
Acad::ErrorStatus | appendAttribute (AcDbAttribute *)
Acad::ErrorStatus | appendAttribute (AcDbObjectId &, AcDbAttribute *)
AcDbObjectIterator * | attributeIterator () const
AcDbObjectId | blockTableRecord () const
AcGeMatrix3d | blockTransform () const
virtual Acad::ErrorStatus | explodeToOwnerSpace () const
Acad::ErrorStatus | geomExtentsBestFit (AcDbExtents &extents, const AcGeMatrix3d &parentXform=AcGeMatrix3d::kIdentity) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const
virtual Adesk::Boolean | isPlanar () const
AcGeMatrix3d | nonAnnotationBlockTransform () const
AcGeScale3d | nonAnnotationScaleFactors () const
AcGeVector3d | normal () const
Acad::ErrorStatus | openAttribute (AcDbAttribute *&, AcDbObjectId, AcDb::OpenMode, bool openErasedOne=false)
Acad::ErrorStatus | openSequenceEnd (AcDbSequenceEnd *&, AcDb::OpenMode)
AcGePoint3d | position () const
double | rotation () const
AcGeScale3d | scaleFactors () const
virtual Acad::ErrorStatus | setBlockTableRecord (AcDbObjectId)
virtual Acad::ErrorStatus | setBlockTransform (const AcGeMatrix3d &)
virtual Acad::ErrorStatus | setNormal (const AcGeVector3d &newVal)
virtual Acad::ErrorStatus | setPosition (const AcGePoint3d &)
virtual Acad::ErrorStatus | setRotation (double newVal)
virtual Acad::ErrorStatus | setScaleFactors (const AcGeScale3d &scale)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &) const
virtual Adesk::Boolean | treatAsAcDbBlockRefForExplode () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMInsertBlock Member List

This is the complete list of members for AcDbMInsertBlock, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbMInsertBlock) (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
ACDB_DECLARE_MEMBERS(AcDbBlockReference) (defined in AcDbBlockReference) | AcDbBlockReference |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBlockReference() (defined in AcDbBlockReference) | AcDbBlockReference |
AcDbBlockReference(const AcGePoint3d &position, AcDbObjectId blockTableRec) (defined in AcDbBlockReference) | AcDbBlockReference |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbMInsertBlock() (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
AcDbMInsertBlock(const AcGePoint3d &position, AcDbObjectId blockTableRec, Adesk::UInt16 columns, Adesk::UInt16 rows, double colSpacing, double rowSpacing) (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
appendAttribute(AcDbAttribute *) (defined in AcDbBlockReference) | AcDbBlockReference |
appendAttribute(AcDbObjectId &, AcDbAttribute *) (defined in AcDbBlockReference) | AcDbBlockReference |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
attributeIterator() const (defined in AcDbBlockReference) | AcDbBlockReference |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTableRecord() const (defined in AcDbBlockReference) | AcDbBlockReference |
blockTransform() const (defined in AcDbBlockReference) | AcDbBlockReference |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
columns() const (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
columnSpacing() const (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
explodeToOwnerSpace() const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
geomExtentsBestFit(AcDbExtents &extents, const AcGeMatrix3d &parentXform=AcGeMatrix3d::kIdentity) const (defined in AcDbBlockReference) | AcDbBlockReference |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbMInsertBlock) | AcDbMInsertBlock | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbBlockReference) | AcDbBlockReference | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
nonAnnotationBlockTransform() const (defined in AcDbBlockReference) | AcDbBlockReference |
nonAnnotationScaleFactors() const (defined in AcDbBlockReference) | AcDbBlockReference |
normal() const (defined in AcDbBlockReference) | AcDbBlockReference |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openAttribute(AcDbAttribute *&, AcDbObjectId, AcDb::OpenMode, bool openErasedOne=false) (defined in AcDbBlockReference) | AcDbBlockReference |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
openSequenceEnd(AcDbSequenceEnd *&, AcDb::OpenMode) (defined in AcDbBlockReference) | AcDbBlockReference |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbBlockReference) | AcDbBlockReference |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const (defined in AcDbBlockReference) | AcDbBlockReference |
rows() const (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
rowSpacing() const (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
scaleFactors() const (defined in AcDbBlockReference) | AcDbBlockReference |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockTableRecord(AcDbObjectId) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setBlockTransform(const AcGeMatrix3d &) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColumns(Adesk::UInt16) (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
setColumnSpacing(double) (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &newVal) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double newVal) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setRows(Adesk::UInt16) (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
setRowSpacing(double) (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
setScaleFactors(const AcGeScale3d &scale) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
treatAsAcDbBlockRefForExplode() const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBlockReference() (defined in AcDbBlockReference) | AcDbBlockReference |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbMInsertBlock() (defined in AcDbMInsertBlock) | AcDbMInsertBlock |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMLeader Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
AcDbMLeader Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMLeader:

Public Types

enum gsMarkType {
kNone = 0, kArrowMark = 1, kLeaderLineMark = kArrowMark + MAX_LEADERLINE_NUMBER, kDoglegMark = kLeaderLineMark + MAX_LEADERLINE_NUMBER,
kMTextMark = kDoglegMark + MAX_LEADER_NUMBER, kMTextUnderLineMark = kMTextMark + 1, kToleranceMark = kMTextUnderLineMark + 1, kBlockMark = kToleranceMark + 1,
kBlockAttribute = kBlockMark + 1
}
enum | MoveType { kMoveAllPoints = 0, kMoveAllExceptArrowHeaderPoints = 1, kMoveContentAndDoglegPoints = 2 }
enum PropertyOverrideType {
kLeaderLineType = 0, kLeaderLineColor = 1, kLeaderLineTypeId = 2, kLeaderLineWeight = 3,
kEnableLanding = 4, kLandingGap = 5, kEnableDogleg = 6, kDoglegLength = 7,
kArrowSymbolId = 8, kArrowSize = 9, kContentType = 10, kTextStyleId = 11,
kTextLeftAttachmentType = 12, kTextAngleType = 13, kTextAlignmentType = 14, kTextColor = 15,
kTextHeight = 16, kEnableFrameText = 17, kDefaultMText = 18, kBlockId = 19,
kBlockColor = 20, kBlockScale = 21, kBlockRotation = 22, kBlockConnectionType = 23,
kScale = 24, kTextRightAttachmentType = 25, kTextSwitchAlignmentType = 26, kTextAttachmentDirection = 27,
kTextTopAttachmentType = 28, kTextBottomAttachmentType = 29, kExtendLeaderToText = 30, kSize = kExtendLeaderToText + 1
}
- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbMLeader)
Acad::ErrorStatus | addFirstVertex (int leaderLineIndex, const AcGePoint3d &point)
Acad::ErrorStatus | addLastVertex (int leaderLineIndex, const AcGePoint3d &point)
Acad::ErrorStatus | addLeader (int &leaderIndex)
Acad::ErrorStatus | addLeaderLine (int leaderIndex, int &leaderLineIndex)
Acad::ErrorStatus | addLeaderLine (const AcGePoint3d &point, int &leaderLineIndex)
double | arrowSize () const
AcDbObjectId | arrowSymbolId () const
AcDbObjectId | arrowSymbolId (int leaderLineIndex) const
AcCmColor | blockColor () const
AcDbMLeaderStyle::BlockConnectionType | blockConnectionType () const
AcDbObjectId | blockContentId () const
double | blockRotation () const
AcGeScale3d | blockScale () const
Acad::ErrorStatus | connectionPoint (const AcGeVector3d &vect, AcGePoint3d &point) const
Acad::ErrorStatus | connectionPoint (const AcGeVector3d &vect, AcGePoint3d &point, AcDbMLeaderStyle::TextAttachmentDirection textAttachmentDirection) const
AcDbMLeaderStyle::ContentType | contentType () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
Acad::ErrorStatus | doglegLength (int leaderIndex, double &doglegLength) const
double | doglegLength () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
bool | enableAnnotationScale () const
bool | enableDogleg () const
bool | enableFrameText () const
bool | enableLanding () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
bool | extendLeaderToText () const
Acad::ErrorStatus | getArrowSize (int leaderLineIndex, double &arrowSize) const
Acad::ErrorStatus | getArrowSymbolId (int leaderLineIndex, AcDbObjectId &arrowSymbolId) const
Acad::ErrorStatus | getBlockAttributeValue (const AcDbObjectId &attdefId, AcDbAttribute *&pAtt) const
Acad::ErrorStatus | getBlockAttributeValue (const AcDbObjectId &attdefId, ACHAR *&value) const
Acad::ErrorStatus | getBlockPosition (AcGePoint3d &position) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getContentGeomExtents (AcDbExtents &extents) const
void * | getContextDataManager () const
Acad::ErrorStatus | getDoglegDirection (int leaderIndex, AcGeVector3d &vector) const
Acad::ErrorStatus | getFirstVertex (int leaderLineIndex, AcGePoint3d &point) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
Acad::ErrorStatus | getLastVertex (int leaderLineIndex, AcGePoint3d &point) const
Acad::ErrorStatus | getLeaderIndex (int leaderLineIndex, int &leaderIndex) const
Acad::ErrorStatus | getLeaderIndexes (AcArray< int > &leaderIndexes) const
Acad::ErrorStatus | getLeaderLineColor (int leaderLineIndex, AcCmColor &leaderLineColor) const
Acad::ErrorStatus | getLeaderLineIndexes (AcArray< int > &leaderLineIndexes) const
Acad::ErrorStatus | getLeaderLineIndexes (int leaderIndex, AcArray< int > &leaderLineIndexes) const
Acad::ErrorStatus | getLeaderLineType (int leaderLineIndex, AcDbMLeaderStyle::LeaderType &leaderLineType) const
Acad::ErrorStatus | getLeaderLineTypeId (int leaderLineIndex, AcDbObjectId &leaderLineTypeId) const
Acad::ErrorStatus | getLeaderLineWeight (int leaderLineIndex, AcDb::LineWeight &leaderLineWeight) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOverridedMLeaderStyle (AcDbMLeaderStyle &mleaderStyle)
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
Acad::ErrorStatus | getTextLocation (AcGePoint3d &location) const
Acad::ErrorStatus | getToleranceLocation (AcGePoint3d &location) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
Acad::ErrorStatus | getVertex (int leaderLineIndex, int index, AcGePoint3d &point) const
virtual void | gripStatus (const AcDb::GripStat status)
bool | hasContent () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
bool | isOverride (PropertyOverrideType propertyType) const
double | landingGap () const
AcCmColor | leaderLineColor () const
AcDbMLeaderStyle::LeaderType | leaderLineType () const
AcDbObjectId | leaderLineTypeId () const
AcDb::LineWeight | leaderLineWeight () const
virtual void | list () const
AcDbObjectId | MLeaderStyle ()
virtual void | modified (const AcDbObject *dbObj)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
Acad::ErrorStatus | moveMLeader (const AcGeVector3d &vector, MoveType moveType, bool bAutoSwitchDogleg=true)
virtual Acad::ErrorStatus | moveStretchPoints (const AcDbIntArray &indices, const AcGeVector3d &offset)
AcDbMText * | mtext () const
AcGeVector3d | normal () const
int | numLeaderLines () const
int | numLeaders () const
Acad::ErrorStatus | numVertices (int leaderLineIndex, int &num) const
virtual void | objectClosed (const AcDbObjectId dbObjId)
AcGePlane | plane () const
Acad::ErrorStatus | postMLeaderToDb (AcDbDatabase *pDb)
Acad::ErrorStatus | recomputeBreakPoints ()
Acad::ErrorStatus | removeFirstVertex (int leaderLineIndex)
Acad::ErrorStatus | removeLastVertex (int leaderLineIndex)
Acad::ErrorStatus | removeLeader (int leaderIndex)
Acad::ErrorStatus | removeLeaderLine (int leaderLineIndex)
Acad::ErrorStatus | removeLeaderLineRefAssoc (int leaderLineIndex) const
double | scale () const
Acad::ErrorStatus | setArrowSize (double arrowSize)
Acad::ErrorStatus | setArrowSize (int leaderLineIndex, double arrowSize)
Acad::ErrorStatus | setArrowSymbolId (AcDbObjectId arrowSymbolId)
Acad::ErrorStatus | setArrowSymbolId (int leaderLineIndex, AcDbObjectId arrowSymbolId)
Acad::ErrorStatus | setBlockAttributeValue (const AcDbObjectId &attdefId, const AcDbAttribute *pAtt)
Acad::ErrorStatus | setBlockAttributeValue (const AcDbObjectId &attdefId, const ACHAR *value)
Acad::ErrorStatus | setBlockColor (const AcCmColor &blockColor)
Acad::ErrorStatus | setBlockConnectionType (AcDbMLeaderStyle::BlockConnectionType blockConnectionType)
Acad::ErrorStatus | setBlockContentId (AcDbObjectId blockId)
Acad::ErrorStatus | setBlockPosition (const AcGePoint3d &position)
Acad::ErrorStatus | setBlockRotation (double rotation)
Acad::ErrorStatus | setBlockScale (const AcGeScale3d &scale)
Acad::ErrorStatus | setContentType (AcDbMLeaderStyle::ContentType contentType)
Acad::ErrorStatus | setContextDataManager (void *pContextDataManager)
Acad::ErrorStatus | setDoglegDirection (int leaderIndex, const AcGeVector3d &vector)
Acad::ErrorStatus | setDoglegLength (int leaderIndex, double doglegLength)
Acad::ErrorStatus | setDoglegLength (double doglegLength)
Acad::ErrorStatus | setEnableAnnotationScale (bool enableAnnotationScale)
Acad::ErrorStatus | setEnableDogleg (bool enableDogleg)
Acad::ErrorStatus | setEnableFrameText (bool enableFrameText)
Acad::ErrorStatus | setEnableLanding (bool enableLanding)
Acad::ErrorStatus | setExtendLeaderToText (bool value)
Acad::ErrorStatus | setFirstVertex (int leaderLineIndex, const AcGePoint3d &point)
Acad::ErrorStatus | setLandingGap (double landingGap)
Acad::ErrorStatus | setLastVertex (int leaderLineIndex, const AcGePoint3d &point)
Acad::ErrorStatus | setLeaderLineColor (const AcCmColor &leaderLineColor)
Acad::ErrorStatus | setLeaderLineColor (int leaderLineIndex, const AcCmColor &leaderLineColor)
Acad::ErrorStatus | setLeaderLineType (AcDbMLeaderStyle::LeaderType leaderLineType)
Acad::ErrorStatus | setLeaderLineType (int leaderLineIndex, AcDbMLeaderStyle::LeaderType leaderLineType)
Acad::ErrorStatus | setLeaderLineTypeId (AcDbObjectId leaderLineTypeId)
Acad::ErrorStatus | setLeaderLineTypeId (int leaderLineIndex, AcDbObjectId leaderLineTypeId)
Acad::ErrorStatus | setLeaderLineWeight (AcDb::LineWeight leaderLineWeight)
Acad::ErrorStatus | setLeaderLineWeight (int leaderLineIndex, AcDb::LineWeight leaderLineWeight)
Acad::ErrorStatus | setMLeaderStyle (AcDbObjectId newStyleId)
Acad::ErrorStatus | setMText (const AcDbMText *pMText)
Acad::ErrorStatus | setOverride (PropertyOverrideType propertyType, bool isOverride=true)
void | setPlane (const AcGePlane &plane)
Acad::ErrorStatus | setScale (double scale)
Acad::ErrorStatus | setTextAlignmentType (AcDbMLeaderStyle::TextAlignmentType textAlignmentType)
Acad::ErrorStatus | setTextAngleType (AcDbMLeaderStyle::TextAngleType textAngleType)
Acad::ErrorStatus | setTextAttachmentDirection (AcDbMLeaderStyle::TextAttachmentDirection textAttachmentDirection)
Acad::ErrorStatus | setTextAttachmentType (AcDbMLeaderStyle::TextAttachmentType textAttachmentType, AcDbMLeaderStyle::LeaderDirectionType leaderDirection)
Acad::ErrorStatus | setTextAttachmentType (AcDbMLeaderStyle::TextAttachmentType textAttachmentType)
Acad::ErrorStatus | setTextColor (const AcCmColor &textColor)
Acad::ErrorStatus | setTextHeight (double textHeight)
Acad::ErrorStatus | setTextLocation (const AcGePoint3d &location)
Acad::ErrorStatus | setTextStyleId (AcDbObjectId textStyleId)
Acad::ErrorStatus | setToleranceLocation (const AcGePoint3d &location)
Acad::ErrorStatus | setVertex (int leaderLineIndex, int index, const AcGePoint3d &point)
virtual Acad::ErrorStatus | subClose ()
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &path) const
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
AcDbMLeaderStyle::TextAlignmentType | textAlignmentType () const
AcDbMLeaderStyle::TextAngleType | textAngleType () const
AcDbMLeaderStyle::TextAttachmentDirection | textAttachmentDirection () const
AcDbMLeaderStyle::TextAttachmentType | textAttachmentType (AcDbMLeaderStyle::LeaderDirectionType leaderDirection) const
AcDbMLeaderStyle::TextAttachmentType | textAttachmentType () const
AcCmColor | textColor () const
double | textHeight () const
AcDbObjectId | textStyleId () const
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
Acad::ErrorStatus | updateContentScale (AcDbMLeaderObjectContextData *pContext)
Acad::ErrorStatus | updateLeaderLinePosition ()
virtual void | viewportDraw (AcGiViewportDraw *mode)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

virtual Acad::ErrorStatus subGetClassID (CLSID *pClsid) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

virtual Acad::ErrorStatus AcDbMLeader::getOsnapPoints | ( | AcDb::OsnapMode | osnapMode,
 |  | Adesk::GsMarker | gsSelectionMark,
 |  | const AcGePoint3d & | pickPoint,
 |  | const AcGePoint3d & | lastPoint,
 |  | const AcGeMatrix3d & | viewXform,
 |  | AcGePoint3dArray & | snapPoints,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbMLeader::getStretchPoints ( AcGePoint3dArray & stretchPoints ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Acad::ErrorStatus AcDbMLeader::setToleranceLocation ( const AcGePoint3d & location )
Warning
Not implemented!
Acad::ErrorStatus AcDbMLeader::setVertex | ( | int | leaderLineIndex,
 |  | int | index,
 |  | const AcGePoint3d & | point
 | ) |  |
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbMLeader::subClose ( )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual AcDbEntity* AcDbMLeader::subentPtr ( const AcDbFullSubentPath & path ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbMLeader::subErase ( Adesk::Boolean erasing )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbMLeader::unhighlight | ( | const AcDbFullSubentPath & | subId = kNullSubent,
 |  | const Adesk::Boolean | highlightAll = false
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Acad::ErrorStatus AcDbMLeader::updateContentScale ( AcDbMLeaderObjectContextData * pContext )
Warning
Not implemented!
Acad::ErrorStatus AcDbMLeader::updateLeaderLinePosition ( )
Warning
Not implemented!
virtual void AcDbMLeader::viewportDraw ( AcGiViewportDraw * mode )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

The documentation for this class was generated from the following file:
  • dbmleader.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMLeader Member List

This is the complete list of members for AcDbMLeader, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbMLeader) (defined in AcDbMLeader) | AcDbMLeader |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbMLeader() (defined in AcDbMLeader) | AcDbMLeader |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addFirstVertex(int leaderLineIndex, const AcGePoint3d &point) (defined in AcDbMLeader) | AcDbMLeader |
addLastVertex(int leaderLineIndex, const AcGePoint3d &point) (defined in AcDbMLeader) | AcDbMLeader |
addLeader(int &leaderIndex) (defined in AcDbMLeader) | AcDbMLeader |
addLeaderLine(int leaderIndex, int &leaderLineIndex) (defined in AcDbMLeader) | AcDbMLeader |
addLeaderLine(const AcGePoint3d &point, int &leaderLineIndex) (defined in AcDbMLeader) | AcDbMLeader |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
arrowSize() const (defined in AcDbMLeader) | AcDbMLeader |
arrowSymbolId() const (defined in AcDbMLeader) | AcDbMLeader |
arrowSymbolId(int leaderLineIndex) const (defined in AcDbMLeader) | AcDbMLeader |
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockColor() const (defined in AcDbMLeader) | AcDbMLeader |
blockConnectionType() const (defined in AcDbMLeader) | AcDbMLeader |
blockContentId() const (defined in AcDbMLeader) | AcDbMLeader |
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockRotation() const (defined in AcDbMLeader) | AcDbMLeader |
blockScale() const (defined in AcDbMLeader) | AcDbMLeader |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
connectionPoint(const AcGeVector3d &vect, AcGePoint3d &point) const (defined in AcDbMLeader) | AcDbMLeader |
connectionPoint(const AcGeVector3d &vect, AcGePoint3d &point, AcDbMLeaderStyle::TextAttachmentDirection textAttachmentDirection) const (defined in AcDbMLeader) | AcDbMLeader |
contentType() const (defined in AcDbMLeader) | AcDbMLeader |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbMLeader) | AcDbMLeader | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
doglegLength(int leaderIndex, double &doglegLength) const (defined in AcDbMLeader) | AcDbMLeader |
doglegLength() const (defined in AcDbMLeader) | AcDbMLeader |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbMLeader) | AcDbMLeader | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbMLeader) | AcDbMLeader | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbMLeader) | AcDbMLeader | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbMLeader) | AcDbMLeader | virtual
enableAnnotationScale() const (defined in AcDbMLeader) | AcDbMLeader |
enableDogleg() const (defined in AcDbMLeader) | AcDbMLeader |
enableFrameText() const (defined in AcDbMLeader) | AcDbMLeader |
enableLanding() const (defined in AcDbMLeader) | AcDbMLeader |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbMLeader) | AcDbMLeader | virtual
extendLeaderToText() const (defined in AcDbMLeader) | AcDbMLeader |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowSize(int leaderLineIndex, double &arrowSize) const (defined in AcDbMLeader) | AcDbMLeader |
getArrowSymbolId(int leaderLineIndex, AcDbObjectId &arrowSymbolId) const (defined in AcDbMLeader) | AcDbMLeader |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBlockAttributeValue(const AcDbObjectId &attdefId, AcDbAttribute *&pAtt) const (defined in AcDbMLeader) | AcDbMLeader |
getBlockAttributeValue(const AcDbObjectId &attdefId, ACHAR *&value) const (defined in AcDbMLeader) | AcDbMLeader |
getBlockPosition(AcGePoint3d &position) const (defined in AcDbMLeader) | AcDbMLeader |
getClassID(CLSID *pClsid) const (defined in AcDbMLeader) | AcDbMLeader | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getContentGeomExtents(AcDbExtents &extents) const (defined in AcDbMLeader) | AcDbMLeader |
getContextDataManager() const (defined in AcDbMLeader) | AcDbMLeader |
getDoglegDirection(int leaderIndex, AcGeVector3d &vector) const (defined in AcDbMLeader) | AcDbMLeader |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstVertex(int leaderLineIndex, AcGePoint3d &point) const (defined in AcDbMLeader) | AcDbMLeader |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbMLeader) | AcDbMLeader | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbMLeader) | AcDbMLeader | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbMLeader) | AcDbMLeader | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbMLeader) | AcDbMLeader | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbMLeader) | AcDbMLeader | virtual
getLastVertex(int leaderLineIndex, AcGePoint3d &point) const (defined in AcDbMLeader) | AcDbMLeader |
getLeaderIndex(int leaderLineIndex, int &leaderIndex) const (defined in AcDbMLeader) | AcDbMLeader |
getLeaderIndexes(AcArray< int > &leaderIndexes) const (defined in AcDbMLeader) | AcDbMLeader |
getLeaderLineColor(int leaderLineIndex, AcCmColor &leaderLineColor) const (defined in AcDbMLeader) | AcDbMLeader |
getLeaderLineIndexes(AcArray< int > &leaderLineIndexes) const (defined in AcDbMLeader) | AcDbMLeader |
getLeaderLineIndexes(int leaderIndex, AcArray< int > &leaderLineIndexes) const (defined in AcDbMLeader) | AcDbMLeader |
getLeaderLineType(int leaderLineIndex, AcDbMLeaderStyle::LeaderType &leaderLineType) const (defined in AcDbMLeader) | AcDbMLeader |
getLeaderLineTypeId(int leaderLineIndex, AcDbObjectId &leaderLineTypeId) const (defined in AcDbMLeader) | AcDbMLeader |
getLeaderLineWeight(int leaderLineIndex, AcDb::LineWeight &leaderLineWeight) const (defined in AcDbMLeader) | AcDbMLeader |
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbMLeader | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOverridedMLeaderStyle(AcDbMLeaderStyle &mleaderStyle) (defined in AcDbMLeader) | AcDbMLeader |
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const | AcDbMLeader | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbMLeader) | AcDbMLeader | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTextLocation(AcGePoint3d &location) const (defined in AcDbMLeader) | AcDbMLeader |
getToleranceLocation(AcGePoint3d &location) const (defined in AcDbMLeader) | AcDbMLeader |
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbMLeader) | AcDbMLeader | virtual
getVertex(int leaderLineIndex, int index, AcGePoint3d &point) const (defined in AcDbMLeader) | AcDbMLeader |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbMLeader) | AcDbMLeader | virtual
gsMarkType enum name (defined in AcDbMLeader) | AcDbMLeader |
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasContent() const (defined in AcDbMLeader) | AcDbMLeader |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbMLeader) | AcDbMLeader | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbMLeader) | AcDbMLeader | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbMLeader) | AcDbMLeader | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isOverride(PropertyOverrideType propertyType) const (defined in AcDbMLeader) | AcDbMLeader |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kArrowMark enum value (defined in AcDbMLeader) | AcDbMLeader |
kArrowSize enum value (defined in AcDbMLeader) | AcDbMLeader |
kArrowSymbolId enum value (defined in AcDbMLeader) | AcDbMLeader |
kBlockAttribute enum value (defined in AcDbMLeader) | AcDbMLeader |
kBlockColor enum value (defined in AcDbMLeader) | AcDbMLeader |
kBlockConnectionType enum value (defined in AcDbMLeader) | AcDbMLeader |
kBlockId enum value (defined in AcDbMLeader) | AcDbMLeader |
kBlockMark enum value (defined in AcDbMLeader) | AcDbMLeader |
kBlockRotation enum value (defined in AcDbMLeader) | AcDbMLeader |
kBlockScale enum value (defined in AcDbMLeader) | AcDbMLeader |
kContentType enum value (defined in AcDbMLeader) | AcDbMLeader |
kDefaultMText enum value (defined in AcDbMLeader) | AcDbMLeader |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDoglegLength enum value (defined in AcDbMLeader) | AcDbMLeader |
kDoglegMark enum value (defined in AcDbMLeader) | AcDbMLeader |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kEnableDogleg enum value (defined in AcDbMLeader) | AcDbMLeader |
kEnableFrameText enum value (defined in AcDbMLeader) | AcDbMLeader |
kEnableLanding enum value (defined in AcDbMLeader) | AcDbMLeader |
kExtendLeaderToText enum value (defined in AcDbMLeader) | AcDbMLeader |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kLandingGap enum value (defined in AcDbMLeader) | AcDbMLeader |
kLeaderLineColor enum value (defined in AcDbMLeader) | AcDbMLeader |
kLeaderLineMark enum value (defined in AcDbMLeader) | AcDbMLeader |
kLeaderLineType enum value (defined in AcDbMLeader) | AcDbMLeader |
kLeaderLineTypeId enum value (defined in AcDbMLeader) | AcDbMLeader |
kLeaderLineWeight enum value (defined in AcDbMLeader) | AcDbMLeader |
kMoveAllExceptArrowHeaderPoints enum value (defined in AcDbMLeader) | AcDbMLeader |
kMoveAllPoints enum value (defined in AcDbMLeader) | AcDbMLeader |
kMoveContentAndDoglegPoints enum value (defined in AcDbMLeader) | AcDbMLeader |
kMTextMark enum value (defined in AcDbMLeader) | AcDbMLeader |
kMTextUnderLineMark enum value (defined in AcDbMLeader) | AcDbMLeader |
kNone enum value (defined in AcDbMLeader) | AcDbMLeader |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kScale enum value (defined in AcDbMLeader) | AcDbMLeader |
kSize enum value (defined in AcDbMLeader) | AcDbMLeader |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kTextAlignmentType enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextAngleType enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextAttachmentDirection enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextBottomAttachmentType enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextColor enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextHeight enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextLeftAttachmentType enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextRightAttachmentType enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextStyleId enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextSwitchAlignmentType enum value (defined in AcDbMLeader) | AcDbMLeader |
kTextTopAttachmentType enum value (defined in AcDbMLeader) | AcDbMLeader |
kToleranceMark enum value (defined in AcDbMLeader) | AcDbMLeader |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
landingGap() const (defined in AcDbMLeader) | AcDbMLeader |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
leaderLineColor() const (defined in AcDbMLeader) | AcDbMLeader |
leaderLineType() const (defined in AcDbMLeader) | AcDbMLeader |
leaderLineTypeId() const (defined in AcDbMLeader) | AcDbMLeader |
leaderLineWeight() const (defined in AcDbMLeader) | AcDbMLeader |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbMLeader) | AcDbMLeader | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
MLeaderStyle() (defined in AcDbMLeader) | AcDbMLeader |
modified(const AcDbObject *dbObj) (defined in AcDbMLeader) | AcDbMLeader | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbMLeader) | AcDbMLeader | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbMLeader) | AcDbMLeader | virtual
moveMLeader(const AcGeVector3d &vector, MoveType moveType, bool bAutoSwitchDogleg=true) (defined in AcDbMLeader) | AcDbMLeader |
moveStretchPoints(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbMLeader) | AcDbMLeader | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
MoveType enum name (defined in AcDbMLeader) | AcDbMLeader |
mtext() const (defined in AcDbMLeader) | AcDbMLeader |
normal() const (defined in AcDbMLeader) | AcDbMLeader |
numLeaderLines() const (defined in AcDbMLeader) | AcDbMLeader |
numLeaders() const (defined in AcDbMLeader) | AcDbMLeader |
numVertices(int leaderLineIndex, int &num) const (defined in AcDbMLeader) | AcDbMLeader |
objectClosed(const AcDbObjectId dbObjId) (defined in AcDbMLeader) | AcDbMLeader | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plane() const (defined in AcDbMLeader) | AcDbMLeader |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
postMLeaderToDb(AcDbDatabase *pDb) (defined in AcDbMLeader) | AcDbMLeader |
PropertyOverrideType enum name (defined in AcDbMLeader) | AcDbMLeader |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recomputeBreakPoints() (defined in AcDbMLeader) | AcDbMLeader |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeFirstVertex(int leaderLineIndex) (defined in AcDbMLeader) | AcDbMLeader |
removeLastVertex(int leaderLineIndex) (defined in AcDbMLeader) | AcDbMLeader |
removeLeader(int leaderIndex) (defined in AcDbMLeader) | AcDbMLeader |
removeLeaderLine(int leaderLineIndex) (defined in AcDbMLeader) | AcDbMLeader |
removeLeaderLineRefAssoc(int leaderLineIndex) const (defined in AcDbMLeader) | AcDbMLeader |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
scale() const (defined in AcDbMLeader) | AcDbMLeader |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArrowSize(double arrowSize) (defined in AcDbMLeader) | AcDbMLeader |
setArrowSize(int leaderLineIndex, double arrowSize) (defined in AcDbMLeader) | AcDbMLeader |
setArrowSymbolId(AcDbObjectId arrowSymbolId) (defined in AcDbMLeader) | AcDbMLeader |
setArrowSymbolId(int leaderLineIndex, AcDbObjectId arrowSymbolId) (defined in AcDbMLeader) | AcDbMLeader |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockAttributeValue(const AcDbObjectId &attdefId, const AcDbAttribute *pAtt) (defined in AcDbMLeader) | AcDbMLeader |
setBlockAttributeValue(const AcDbObjectId &attdefId, const ACHAR *value) (defined in AcDbMLeader) | AcDbMLeader |
setBlockColor(const AcCmColor &blockColor) (defined in AcDbMLeader) | AcDbMLeader |
setBlockConnectionType(AcDbMLeaderStyle::BlockConnectionType blockConnectionType) (defined in AcDbMLeader) | AcDbMLeader |
setBlockContentId(AcDbObjectId blockId) (defined in AcDbMLeader) | AcDbMLeader |
setBlockPosition(const AcGePoint3d &position) (defined in AcDbMLeader) | AcDbMLeader |
setBlockRotation(double rotation) (defined in AcDbMLeader) | AcDbMLeader |
setBlockScale(const AcGeScale3d &scale) (defined in AcDbMLeader) | AcDbMLeader |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setContentType(AcDbMLeaderStyle::ContentType contentType) (defined in AcDbMLeader) | AcDbMLeader |
setContextDataManager(void *pContextDataManager) (defined in AcDbMLeader) | AcDbMLeader |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDoglegDirection(int leaderIndex, const AcGeVector3d &vector) (defined in AcDbMLeader) | AcDbMLeader |
setDoglegLength(int leaderIndex, double doglegLength) (defined in AcDbMLeader) | AcDbMLeader |
setDoglegLength(double doglegLength) (defined in AcDbMLeader) | AcDbMLeader |
setEnableAnnotationScale(bool enableAnnotationScale) (defined in AcDbMLeader) | AcDbMLeader |
setEnableDogleg(bool enableDogleg) (defined in AcDbMLeader) | AcDbMLeader |
setEnableFrameText(bool enableFrameText) (defined in AcDbMLeader) | AcDbMLeader |
setEnableLanding(bool enableLanding) (defined in AcDbMLeader) | AcDbMLeader |
setExtendLeaderToText(bool value) (defined in AcDbMLeader) | AcDbMLeader |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFirstVertex(int leaderLineIndex, const AcGePoint3d &point) (defined in AcDbMLeader) | AcDbMLeader |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLandingGap(double landingGap) (defined in AcDbMLeader) | AcDbMLeader |
setLastVertex(int leaderLineIndex, const AcGePoint3d &point) (defined in AcDbMLeader) | AcDbMLeader |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLeaderLineColor(const AcCmColor &leaderLineColor) (defined in AcDbMLeader) | AcDbMLeader |
setLeaderLineColor(int leaderLineIndex, const AcCmColor &leaderLineColor) (defined in AcDbMLeader) | AcDbMLeader |
setLeaderLineType(AcDbMLeaderStyle::LeaderType leaderLineType) (defined in AcDbMLeader) | AcDbMLeader |
setLeaderLineType(int leaderLineIndex, AcDbMLeaderStyle::LeaderType leaderLineType) (defined in AcDbMLeader) | AcDbMLeader |
setLeaderLineTypeId(AcDbObjectId leaderLineTypeId) (defined in AcDbMLeader) | AcDbMLeader |
setLeaderLineTypeId(int leaderLineIndex, AcDbObjectId leaderLineTypeId) (defined in AcDbMLeader) | AcDbMLeader |
setLeaderLineWeight(AcDb::LineWeight leaderLineWeight) (defined in AcDbMLeader) | AcDbMLeader |
setLeaderLineWeight(int leaderLineIndex, AcDb::LineWeight leaderLineWeight) (defined in AcDbMLeader) | AcDbMLeader |
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMLeaderStyle(AcDbObjectId newStyleId) (defined in AcDbMLeader) | AcDbMLeader |
setMText(const AcDbMText *pMText) (defined in AcDbMLeader) | AcDbMLeader |
setOverride(PropertyOverrideType propertyType, bool isOverride=true) (defined in AcDbMLeader) | AcDbMLeader |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlane(const AcGePlane &plane) (defined in AcDbMLeader) | AcDbMLeader |
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setScale(double scale) (defined in AcDbMLeader) | AcDbMLeader |
setTextAlignmentType(AcDbMLeaderStyle::TextAlignmentType textAlignmentType) (defined in AcDbMLeader) | AcDbMLeader |
setTextAngleType(AcDbMLeaderStyle::TextAngleType textAngleType) (defined in AcDbMLeader) | AcDbMLeader |
setTextAttachmentDirection(AcDbMLeaderStyle::TextAttachmentDirection textAttachmentDirection) (defined in AcDbMLeader) | AcDbMLeader |
setTextAttachmentType(AcDbMLeaderStyle::TextAttachmentType textAttachmentType, AcDbMLeaderStyle::LeaderDirectionType leaderDirection) (defined in AcDbMLeader) | AcDbMLeader |
setTextAttachmentType(AcDbMLeaderStyle::TextAttachmentType textAttachmentType) (defined in AcDbMLeader) | AcDbMLeader |
setTextColor(const AcCmColor &textColor) (defined in AcDbMLeader) | AcDbMLeader |
setTextHeight(double textHeight) (defined in AcDbMLeader) | AcDbMLeader |
setTextLocation(const AcGePoint3d &location) (defined in AcDbMLeader) | AcDbMLeader |
setTextStyleId(AcDbObjectId textStyleId) (defined in AcDbMLeader) | AcDbMLeader |
setToleranceLocation(const AcGePoint3d &location) | AcDbMLeader |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVertex(int leaderLineIndex, int index, const AcGePoint3d &point) | AcDbMLeader |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() | AcDbMLeader | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &path) const | AcDbMLeader | virtual
subErase(Adesk::Boolean erasing) | AcDbMLeader | virtual
subGetClassID(CLSID *pClsid) const (defined in AcDbMLeader) | AcDbMLeader | protectedvirtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAlignmentType() const (defined in AcDbMLeader) | AcDbMLeader |
textAngleType() const (defined in AcDbMLeader) | AcDbMLeader |
textAttachmentDirection() const (defined in AcDbMLeader) | AcDbMLeader |
textAttachmentType(AcDbMLeaderStyle::LeaderDirectionType leaderDirection) const (defined in AcDbMLeader) | AcDbMLeader |
textAttachmentType() const (defined in AcDbMLeader) | AcDbMLeader |
textColor() const (defined in AcDbMLeader) | AcDbMLeader |
textHeight() const (defined in AcDbMLeader) | AcDbMLeader |
textStyleId() const (defined in AcDbMLeader) | AcDbMLeader |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbMLeader) | AcDbMLeader | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const | AcDbMLeader | virtual
updateContentScale(AcDbMLeaderObjectContextData *pContext) | AcDbMLeader |
updateLeaderLinePosition() | AcDbMLeader |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) | AcDbMLeader | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbMLeader) | AcDbMLeader | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbMLeader() (defined in AcDbMLeader) | AcDbMLeader |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMLeaderStyle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
AcDbMLeaderStyle Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMLeaderStyle:

Public Types

enum | BlockConnectionType { kConnectExtents = 0, kConnectBase = 1 }
enum | ContentType { kNoneContent = 0, kBlockContent = 1, kMTextContent = 2, kToleranceContent = 3 }
enum | DrawLeaderOrderType { kDrawLeaderHeadFirst = 0, kDrawLeaderTailFirst = 1 }
enum | DrawMLeaderOrderType { kDrawContentFirst = 0, kDrawLeaderFirst = 1 }
enum LeaderDirectionType {
kUnknownLeader = 0, kLeftLeader = 1, kRightLeader = 2, kTopLeader = 3,
kBottomLeader = 4
}
enum | LeaderType { kInVisibleLeader = 0, kStraightLeader = 1, kSplineLeader = 2 }
enum SegmentAngleType {
kAny = 0, k15 = 1, k30 = 2, k45 = 3,
k60 = 4, k90 = 6, kHorz = 12
}
enum | TextAlignmentType { kLeftAlignment = 0, kCenterAlignment = 1, kRightAlignment = 2 }
enum | TextAngleType { kInsertAngle = 0, kHorizontalAngle = 1, kAlwaysRightReadingAngle = 2 }
enum | TextAttachmentDirection { kAttachmentHorizontal = 0, kAttachmentVertical = 1 }
enum TextAttachmentType {
kAttachmentTopOfTop = 0, kAttachmentMiddleOfTop = 1, kAttachmentMiddle = 2, kAttachmentMiddleOfBottom = 3,
kAttachmentBottomOfBottom = 4, kAttachmentBottomLine = 5, kAttachmentBottomOfTopLine = 6, kAttachmentBottomOfTop = 7,
kAttachmentAllLine = 8, kAttachmentCenter = 9, kAttachmentLinedCenter = 10
}

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbMLeaderStyle)
double | alignSpace () const
bool | annotative () const
double | arrowSize () const
AcDbObjectId | arrowSymbolId () const
virtual Adesk::UInt32 | bitFlags () const
AcCmColor | blockColor () const
BlockConnectionType | blockConnectionType () const
AcDbObjectId | blockId () const
double | blockRotation () const
AcGeScale3d | blockScale () const
double | breakSize () const
ContentType | contentType () const
AcDbMText * | defaultMText () const
virtual const ACHAR * | description (void) const
double | doglegLength () const
DrawLeaderOrderType | drawLeaderOrderType () const
DrawMLeaderOrderType | drawMLeaderOrderType () const
bool | enableBlockRotation () const
bool | enableBlockScale () const
bool | enableDogleg () const
bool | enableFrameText () const
bool | enableLanding () const
bool | extendLeaderToText () const
SegmentAngleType | firstSegmentAngleConstraint () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getName (ACHAR *&pszName) const
double | landingGap () const
AcCmColor | leaderLineColor () const
LeaderType | leaderLineType () const
AcDbObjectId | leaderLineTypeId () const
AcDb::LineWeight | leaderLineWeight () const
int | maxLeaderSegmentsPoints () const
bool | overwritePropChanged () const
Acad::ErrorStatus | postMLeaderStyleToDb (AcDbDatabase *pDb, const ACHAR *styleName, AcDbObjectId &mleaderStyleId)
double | scale () const
SegmentAngleType | secondSegmentAngleConstraint () const
Acad::ErrorStatus | setAlignSpace (double alignSpace)
Acad::ErrorStatus | setAnnotative (bool isAnnotative)
Acad::ErrorStatus | setArrowSize (double arrowSize)
Acad::ErrorStatus | setArrowSymbolId (const ACHAR *name)
Acad::ErrorStatus | setArrowSymbolId (AcDbObjectId arrowSymbolId)
virtual Acad::ErrorStatus | setBitFlags (Adesk::UInt32 flags)
Acad::ErrorStatus | setBlockColor (const AcCmColor &blockColor)
Acad::ErrorStatus | setBlockConnectionType (BlockConnectionType blockConnectionType)
Acad::ErrorStatus | setBlockId (const ACHAR *name)
Acad::ErrorStatus | setBlockId (AcDbObjectId blockId)
Acad::ErrorStatus | setBlockRotation (double rotation)
Acad::ErrorStatus | setBlockScale (const AcGeScale3d &scale)
Acad::ErrorStatus | setBreakSize (double size)
Acad::ErrorStatus | setContentType (ContentType contentType)
Acad::ErrorStatus | setDefaultMText (const AcDbMText *defaultMText)
virtual Acad::ErrorStatus | setDescription (const ACHAR *pszDescription)
Acad::ErrorStatus | setDoglegLength (double doglegLength)
Acad::ErrorStatus | setDrawLeaderOrderType (DrawLeaderOrderType drawLeaderOrderType)
Acad::ErrorStatus | setDrawMLeaderOrderType (DrawMLeaderOrderType drawMLeaderOrderType)
Acad::ErrorStatus | setEnableBlockRotation (bool enableBlockRotation)
Acad::ErrorStatus | setEnableBlockScale (bool enableBlockScale)
Acad::ErrorStatus | setEnableDogleg (bool enableDogleg)
Acad::ErrorStatus | setEnableFrameText (bool enableFrameText)
Acad::ErrorStatus | setEnableLanding (bool enableLanding)
Acad::ErrorStatus | setExtendLeaderToText (bool value)
Acad::ErrorStatus | setFirstSegmentAngleConstraint (SegmentAngleType angle)
Acad::ErrorStatus | setLandingGap (double landingGap)
Acad::ErrorStatus | setLeaderLineColor (const AcCmColor &leaderLineColor)
Acad::ErrorStatus | setLeaderLineType (LeaderType leaderLineType)
Acad::ErrorStatus | setLeaderLineTypeId (AcDbObjectId leaderLineTypeId)
Acad::ErrorStatus | setLeaderLineWeight (AcDb::LineWeight leaderLineWeight)
Acad::ErrorStatus | setMaxLeaderSegmentsPoints (int maxLeaderSegmentsPoints)
virtual Acad::ErrorStatus | setName (const ACHAR *pszName)
Acad::ErrorStatus | setScale (double scale)
Acad::ErrorStatus | setSecondSegmentAngleConstraint (SegmentAngleType angle)
Acad::ErrorStatus | setTextAlignAlwaysLeft (bool bAlwaysLeft)
Acad::ErrorStatus | setTextAlignmentType (TextAlignmentType textAlignmentType)
Acad::ErrorStatus | setTextAngleType (TextAngleType textAngleType)
Acad::ErrorStatus | setTextAttachmentDirection (AcDbMLeaderStyle::TextAttachmentDirection textAttachmentDirection)
Acad::ErrorStatus | setTextAttachmentType (TextAttachmentType textAttachmentType, LeaderDirectionType leaderDirection)
Acad::ErrorStatus | setTextAttachmentType (TextAttachmentType textAttachmentType)
Acad::ErrorStatus | setTextColor (const AcCmColor &textColor)
Acad::ErrorStatus | setTextHeight (double textHeight)
Acad::ErrorStatus | setTextStyleId (AcDbObjectId textStyleId)
bool | textAlignAlwaysLeft () const
TextAlignmentType | textAlignmentType () const
TextAngleType | textAngleType () const
TextAttachmentDirection | textAttachmentDirection () const
TextAttachmentType | textAttachmentType (LeaderDirectionType leaderDirection) const
TextAttachmentType | textAttachmentType () const
AcCmColor | textColor () const
double | textHeight () const
AcDbObjectId | textStyleId () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

virtual Acad::ErrorStatus subGetClassID (CLSID *pClsid) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

double AcDbMLeaderStyle::alignSpace ( ) const
Warning
Not implemented!
bool AcDbMLeaderStyle::annotative ( ) const
Warning
Not implemented!
AcDbObjectId AcDbMLeaderStyle::arrowSymbolId ( ) const
Warning
Not implemented!
virtual Adesk::UInt32 AcDbMLeaderStyle::bitFlags ( ) const
virtual
Warning
Not implemented!
AcCmColor AcDbMLeaderStyle::blockColor ( ) const
Warning
Not implemented!
BlockConnectionType AcDbMLeaderStyle::blockConnectionType ( ) const
Warning
Not implemented!
AcDbObjectId AcDbMLeaderStyle::blockId ( ) const
Warning
Not implemented!
double AcDbMLeaderStyle::blockRotation ( ) const
Warning
Not implemented!
AcGeScale3d AcDbMLeaderStyle::blockScale ( ) const
Warning
Not implemented!
double AcDbMLeaderStyle::breakSize ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbMLeaderStyle::setArrowSize ( double arrowSize )
Warning
Not implemented!
AcCmColor AcDbMLeaderStyle::textColor ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbmleaderstyle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMLeaderStyle Member List

This is the complete list of members for AcDbMLeaderStyle, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbMLeaderStyle) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbMLeaderStyle() (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
alignSpace() const | AcDbMLeaderStyle |
annotative() const | AcDbMLeaderStyle |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
arrowSize() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
arrowSymbolId() const | AcDbMLeaderStyle |
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
bitFlags() const | AcDbMLeaderStyle | virtual
blockColor() const | AcDbMLeaderStyle |
blockConnectionType() const | AcDbMLeaderStyle |
BlockConnectionType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
blockId() const | AcDbMLeaderStyle |
blockRotation() const | AcDbMLeaderStyle |
blockScale() const | AcDbMLeaderStyle |
breakSize() const | AcDbMLeaderStyle |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contentType() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
ContentType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
defaultMText() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
doglegLength() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
drawLeaderOrderType() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
DrawLeaderOrderType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
DrawMLeaderOrderType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
drawMLeaderOrderType() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
enableBlockRotation() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
enableBlockScale() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
enableDogleg() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
enableFrameText() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
enableLanding() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extendLeaderToText() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
firstSegmentAngleConstraint() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pszName) const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
k15 enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
k30 enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
k45 enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
k60 enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
k90 enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAlwaysRightReadingAngle enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kAny enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentAllLine enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentBottomLine enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentBottomOfBottom enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentBottomOfTop enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentBottomOfTopLine enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentCenter enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentHorizontal enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentLinedCenter enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentMiddle enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentMiddleOfBottom enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentMiddleOfTop enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentTopOfTop enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kAttachmentVertical enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kBlockContent enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kBottomLeader enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kCenterAlignment enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kConnectBase enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kConnectExtents enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawContentFirst enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kDrawLeaderFirst enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kDrawLeaderHeadFirst enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kDrawLeaderTailFirst enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHorizontalAngle enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kHorz enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kInsertAngle enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kInVisibleLeader enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kLeftAlignment enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kLeftLeader enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kMTextContent enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kNoneContent enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kRightAlignment enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kRightLeader enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSplineLeader enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kStraightLeader enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kToleranceContent enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kTopLeader enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kUnknownLeader enum value (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
landingGap() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
LeaderDirectionType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
leaderLineColor() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
leaderLineType() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
leaderLineTypeId() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
leaderLineWeight() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
LeaderType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
maxLeaderSegmentsPoints() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
overwritePropChanged() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
ownerId() const (defined in AcDbObject) | AcDbObject |
postMLeaderStyleToDb(AcDbDatabase *pDb, const ACHAR *styleName, AcDbObjectId &mleaderStyleId) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
scale() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
secondSegmentAngleConstraint() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
SegmentAngleType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAlignSpace(double alignSpace) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setAnnotative(bool isAnnotative) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setArrowSize(double arrowSize) | AcDbMLeaderStyle |
setArrowSymbolId(const ACHAR *name) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setArrowSymbolId(AcDbObjectId arrowSymbolId) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBitFlags(Adesk::UInt32 flags) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle | virtual
setBlockColor(const AcCmColor &blockColor) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setBlockConnectionType(BlockConnectionType blockConnectionType) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setBlockId(const ACHAR *name) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setBlockId(AcDbObjectId blockId) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setBlockRotation(double rotation) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setBlockScale(const AcGeScale3d &scale) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setBreakSize(double size) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setContentType(ContentType contentType) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setDefaultMText(const AcDbMText *defaultMText) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setDescription(const ACHAR *pszDescription) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle | virtual
setDoglegLength(double doglegLength) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setDrawLeaderOrderType(DrawLeaderOrderType drawLeaderOrderType) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setDrawMLeaderOrderType(DrawMLeaderOrderType drawMLeaderOrderType) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setEnableBlockRotation(bool enableBlockRotation) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setEnableBlockScale(bool enableBlockScale) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setEnableDogleg(bool enableDogleg) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setEnableFrameText(bool enableFrameText) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setEnableLanding(bool enableLanding) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setExtendLeaderToText(bool value) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFirstSegmentAngleConstraint(SegmentAngleType angle) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLandingGap(double landingGap) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setLeaderLineColor(const AcCmColor &leaderLineColor) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setLeaderLineType(LeaderType leaderLineType) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setLeaderLineTypeId(AcDbObjectId leaderLineTypeId) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setLeaderLineWeight(AcDb::LineWeight leaderLineWeight) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setMaxLeaderSegmentsPoints(int maxLeaderSegmentsPoints) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setName(const ACHAR *pszName) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setScale(double scale) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setSecondSegmentAngleConstraint(SegmentAngleType angle) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setTextAlignAlwaysLeft(bool bAlwaysLeft) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setTextAlignmentType(TextAlignmentType textAlignmentType) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setTextAngleType(TextAngleType textAngleType) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setTextAttachmentDirection(AcDbMLeaderStyle::TextAttachmentDirection textAttachmentDirection) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setTextAttachmentType(TextAttachmentType textAttachmentType, LeaderDirectionType leaderDirection) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setTextAttachmentType(TextAttachmentType textAttachmentType) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setTextColor(const AcCmColor &textColor) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setTextHeight(double textHeight) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setTextStyleId(AcDbObjectId textStyleId) (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subGetClassID(CLSID *pClsid) const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle | protectedvirtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAlignAlwaysLeft() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
textAlignmentType() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
TextAlignmentType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
TextAngleType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
textAngleType() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
TextAttachmentDirection enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
textAttachmentDirection() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
TextAttachmentType enum name (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
textAttachmentType(LeaderDirectionType leaderDirection) const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
textAttachmentType() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
textColor() const | AcDbMLeaderStyle |
textHeight() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
textStyleId() const (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbMLeaderStyle() (defined in AcDbMLeaderStyle) | AcDbMLeaderStyle | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMline Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbMline Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMline:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbMline)
Acad::ErrorStatus | appendSeg (const AcGePoint3d &newVertex)
AcGeVector3d | axisAt (int index) const
bool | closedMline () const
int | element (const AcGePoint3d &pt) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPoint, AcGePoint3d &pointOnCurve, bool extend, bool excludeCaps=false) const
Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPoint, const AcGeVector3d &normal, AcGePoint3d &pointOnCurve, bool extend, bool excludeCaps=false) const
Acad::ErrorStatus | getGeomExtents (AcDbExtents &) const
Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
Acad::ErrorStatus | getParametersAt (int index, AcGeVoidPointerArray &params) const
void | getPlane (AcGePlane &) const
Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
Mline::MlineJustification | justification () const
void | list () const
AcGeVector3d | miterAt (int index) const
Acad::ErrorStatus | moveVertexAt (int index, const AcGePoint3d &newPosition)
AcGeVector3d | normal () const
int | numVertices () const
Acad::ErrorStatus | removeLastSeg (AcGePoint3d &lastVertex)
double | scale () const
Acad::ErrorStatus | setClosedMline (bool closed)
Acad::ErrorStatus | setJustification (Mline::MlineJustification newJust)
Acad::ErrorStatus | setNormal (const AcGeVector3d &newNormal)
Acad::ErrorStatus | setParametersAt (int index, AcGeVoidPointerArray &params)
Acad::ErrorStatus | setScale (double newScale)
Acad::ErrorStatus | setStyle (const AcDbObjectId &newStyleId)
void | setSupressEndCaps (bool supressIt)
void | setSupressStartCaps (bool supressIt)
AcDbObjectId | style () const
AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
bool | supressEndCaps () const
bool | supressStartCaps () const
AcGePoint3d | vertexAt (int index) const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

Acad::ErrorStatus AcDbMline::getGeomExtents ( AcDbExtents & ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Acad::ErrorStatus AcDbMline::setParametersAt | ( | int | index,
 |  | AcGeVoidPointerArray & | params
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbmline.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMline Member List

This is the complete list of members for AcDbMline, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbMline) (defined in AcDbMline) | AcDbMline |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbMline() (defined in AcDbMline) | AcDbMline |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
appendSeg(const AcGePoint3d &newVertex) (defined in AcDbMline) | AcDbMline |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
axisAt(int index) const (defined in AcDbMline) | AcDbMline |
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
closedMline() const (defined in AcDbMline) | AcDbMline |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
element(const AcGePoint3d &pt) const (defined in AcDbMline) | AcDbMline |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbMline) | AcDbMline | virtual
getClosestPointTo(const AcGePoint3d &givenPoint, AcGePoint3d &pointOnCurve, bool extend, bool excludeCaps=false) const (defined in AcDbMline) | AcDbMline |
getClosestPointTo(const AcGePoint3d &givenPoint, const AcGeVector3d &normal, AcGePoint3d &pointOnCurve, bool extend, bool excludeCaps=false) const (defined in AcDbMline) | AcDbMline |
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &) const | AcDbMline | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbMline) | AcDbMline | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParametersAt(int index, AcGeVoidPointerArray &params) const (defined in AcDbMline) | AcDbMline |
getPlane(AcGePlane &) const (defined in AcDbMline) | AcDbMline |
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbMline) | AcDbMline | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
justification() const (defined in AcDbMline) | AcDbMline |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbMline) | AcDbMline | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
miterAt(int index) const (defined in AcDbMline) | AcDbMline |
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveVertexAt(int index, const AcGePoint3d &newPosition) (defined in AcDbMline) | AcDbMline |
normal() const (defined in AcDbMline) | AcDbMline |
numVertices() const (defined in AcDbMline) | AcDbMline |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeLastSeg(AcGePoint3d &lastVertex) (defined in AcDbMline) | AcDbMline |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
scale() const (defined in AcDbMline) | AcDbMline |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setClosedMline(bool closed) (defined in AcDbMline) | AcDbMline |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setJustification(Mline::MlineJustification newJust) (defined in AcDbMline) | AcDbMline |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &newNormal) (defined in AcDbMline) | AcDbMline |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setParametersAt(int index, AcGeVoidPointerArray &params) | AcDbMline |
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setScale(double newScale) (defined in AcDbMline) | AcDbMline |
setStyle(const AcDbObjectId &newStyleId) (defined in AcDbMline) | AcDbMline |
setSupressEndCaps(bool supressIt) (defined in AcDbMline) | AcDbMline |
setSupressStartCaps(bool supressIt) (defined in AcDbMline) | AcDbMline |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
style() const (defined in AcDbMline) | AcDbMline |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbMline) | AcDbMline | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
supressEndCaps() const (defined in AcDbMline) | AcDbMline |
supressStartCaps() const (defined in AcDbMline) | AcDbMline |
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
vertexAt(int index) const (defined in AcDbMline) | AcDbMline |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbMline() (defined in AcDbMline) | AcDbMline | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMlineStyle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbMlineStyle Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMlineStyle:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbMlineStyle)
Acad::ErrorStatus | addElement (int &index, double offset, const AcCmColor &color, AcDbObjectId linetypeId, bool checkIfReferenced=true)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
const ACHAR * | description () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
double | endAngle () const
bool | endInnerArcs () const
bool | endRoundCap () const
bool | endSquareCap () const
const AcCmColor & | fillColor () const
bool | filled () const
Acad::ErrorStatus | getElementAt (int elem, double &offset, AcCmColor &color, AcDbObjectId &linetypeId) const
void | initMlineStyle ()
const ACHAR * | name () const
int | numElements () const
Acad::ErrorStatus | removeElementAt (int elem)
void | set (const AcDbMlineStyle &src, bool checkIfReferenced=true)
Acad::ErrorStatus | setDescription (const ACHAR *description)
Acad::ErrorStatus | setElement (int &elem, double offset, const AcCmColor &color, AcDbObjectId linetypeId)
Acad::ErrorStatus | setEndAngle (double ang)
void | setEndInnerArcs (bool showThem)
void | setEndRoundCap (bool showIt)
void | setEndSquareCap (bool showIt)
Acad::ErrorStatus | setFillColor (const AcCmColor &color)
void | setFilled (bool onOff)
Acad::ErrorStatus | setName (const ACHAR *name)
void | setShowMiters (bool showThem)
Acad::ErrorStatus | setStartAngle (double ang)
void | setStartInnerArcs (bool showThem)
void | setStartRoundCap (bool showIt)
void | setStartSquareCap (bool showIt)
bool | showMiters () const
double | startAngle () const
bool | startInnerArcs () const
bool | startRoundCap () const
bool | startSquareCap () const
virtual Acad::ErrorStatus | subErase (Adesk::Boolean pErasing=true)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbmstyle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMlineStyle Member List

This is the complete list of members for AcDbMlineStyle, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbMlineStyle) (defined in AcDbMlineStyle) | AcDbMlineStyle |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbMlineStyle() (defined in AcDbMlineStyle) | AcDbMlineStyle |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addElement(int &index, double offset, const AcCmColor &color, AcDbObjectId linetypeId, bool checkIfReferenced=true) (defined in AcDbMlineStyle) | AcDbMlineStyle |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) (defined in AcDbMlineStyle) | AcDbMlineStyle | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbMlineStyle) | AcDbMlineStyle | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbMlineStyle) | AcDbMlineStyle | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbMlineStyle) | AcDbMlineStyle | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbMlineStyle) | AcDbMlineStyle | virtual
endAngle() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
endInnerArcs() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
endRoundCap() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
endSquareCap() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fillColor() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
filled() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getElementAt(int elem, double &offset, AcCmColor &color, AcDbObjectId &linetypeId) const (defined in AcDbMlineStyle) | AcDbMlineStyle |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
initMlineStyle() (defined in AcDbMlineStyle) | AcDbMlineStyle |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
name() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
numElements() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeElementAt(int elem) (defined in AcDbMlineStyle) | AcDbMlineStyle |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
set(const AcDbMlineStyle &src, bool checkIfReferenced=true) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDescription(const ACHAR *description) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setElement(int &elem, double offset, const AcCmColor &color, AcDbObjectId linetypeId) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setEndAngle(double ang) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setEndInnerArcs(bool showThem) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setEndRoundCap(bool showIt) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setEndSquareCap(bool showIt) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFillColor(const AcCmColor &color) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setFilled(bool onOff) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setName(const ACHAR *name) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setShowMiters(bool showThem) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setStartAngle(double ang) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setStartInnerArcs(bool showThem) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setStartRoundCap(bool showIt) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setStartSquareCap(bool showIt) (defined in AcDbMlineStyle) | AcDbMlineStyle |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
showMiters() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
startAngle() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
startInnerArcs() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
startRoundCap() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
startSquareCap() const (defined in AcDbMlineStyle) | AcDbMlineStyle |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean pErasing=true) (defined in AcDbMlineStyle) | AcDbMlineStyle | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbMlineStyle() (defined in AcDbMlineStyle) | AcDbMlineStyle | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMotionPath Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcDbMotionPath Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMotionPath:

Public Member Functions

AcDbMotionPath ()
ACRX_DECLARE_MEMBERS (AcDbMotionPath)
AcDbObjectId | cameraPath () const
bool | cornerDecel () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Adesk::UInt32 | frameRate () const
Adesk::UInt32 | frames () const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setCameraPath (const AcDbObjectId &id)
Acad::ErrorStatus | setCornerDecel (bool cornerDecel)
Acad::ErrorStatus | setFrameRate (Adesk::UInt16 rate)
Acad::ErrorStatus | setFrames (Adesk::UInt16 frames)
Acad::ErrorStatus | setTargetPath (const AcDbObjectId &id)
Acad::ErrorStatus | setViewTableRecordId (const AcDbObjectId &id)
AcDbObjectId | targetPath () const
AcDbObjectId | viewTableRecordId () const
virtual | ~AcDbMotionPath ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcDbImpMotionPath * imp () const

Friends

class AcDbImpMotionPath

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbMotionPath::AcDbMotionPath ( )
Warning
Not implemented!
virtual AcDbMotionPath::~AcDbMotionPath ( )
virtual
Warning
Not implemented!

Member Function Documentation

AcDbObjectId AcDbMotionPath::cameraPath ( ) const
Warning
Not implemented!
bool AcDbMotionPath::cornerDecel ( ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbMotionPath::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbMotionPath::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbMotionPath::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbMotionPath::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Adesk::UInt32 AcDbMotionPath::frameRate ( ) const
Warning
Not implemented!
Adesk::UInt32 AcDbMotionPath::frames ( ) const
Warning
Not implemented!
virtual Adesk::UInt32 AcDbMotionPath::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Acad::ErrorStatus AcDbMotionPath::setCameraPath ( const AcDbObjectId & id )
Warning
Not implemented!
Acad::ErrorStatus AcDbMotionPath::setCornerDecel ( bool cornerDecel )
Warning
Not implemented!
Acad::ErrorStatus AcDbMotionPath::setFrameRate ( Adesk::UInt16 rate )
Warning
Not implemented!
Acad::ErrorStatus AcDbMotionPath::setFrames ( Adesk::UInt16 frames )
Warning
Not implemented!
Acad::ErrorStatus AcDbMotionPath::setTargetPath ( const AcDbObjectId & id )
Warning
Not implemented!
Acad::ErrorStatus AcDbMotionPath::setViewTableRecordId ( const AcDbObjectId & id )
Warning
Not implemented!
AcDbObjectId AcDbMotionPath::targetPath ( ) const
Warning
Not implemented!
AcDbObjectId AcDbMotionPath::viewTableRecordId ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbMotionPath.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMotionPath Member List

This is the complete list of members for AcDbMotionPath, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbImpMotionPath (defined in AcDbMotionPath) | AcDbMotionPath | friend
AcDbMotionPath() | AcDbMotionPath |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbMotionPath) (defined in AcDbMotionPath) | AcDbMotionPath |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cameraPath() const | AcDbMotionPath |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
cornerDecel() const | AcDbMotionPath |
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbMotionPath | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbMotionPath | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbMotionPath | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbMotionPath | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
frameRate() const | AcDbMotionPath |
frames() const | AcDbMotionPath |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imp() const (defined in AcDbMotionPath) | AcDbMotionPath | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbMotionPath | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCameraPath(const AcDbObjectId &id) | AcDbMotionPath |
setCornerDecel(bool cornerDecel) | AcDbMotionPath |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFrameRate(Adesk::UInt16 rate) | AcDbMotionPath |
setFrames(Adesk::UInt16 frames) | AcDbMotionPath |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setTargetPath(const AcDbObjectId &id) | AcDbMotionPath |
setViewTableRecordId(const AcDbObjectId &id) | AcDbMotionPath |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
targetPath() const | AcDbMotionPath |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
viewTableRecordId() const | AcDbMotionPath |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbMotionPath() | AcDbMotionPath | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMPolygon Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcDbMPolygon Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMPolygon:

Public Types

enum | loopDir { kExterior = 0, kInterior, kAnnotation }
- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbMPolygon)
virtual Acad::ErrorStatus | appendLoopFromBoundary (const AcDbCircle *pCircle, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz)
virtual Acad::ErrorStatus | appendLoopFromBoundary (const AcDbPolyline *pPoly, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz)
virtual Acad::ErrorStatus | appendLoopFromBoundary (const AcDb2dPolyline *pPoly, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz)
virtual Acad::ErrorStatus | appendMPolygonLoop (const AcGePoint2dArray &vertices, const AcGeDoubleArray &bulges, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *)
virtual Acad::ErrorStatus | balanceDisplay ()
virtual Acad::ErrorStatus | balanceTree ()
virtual Acad::ErrorStatus | createLoops (const AcArray< AcGePoint2dArray, AcArrayObjectCopyReallocator< AcGePoint2dArray > > &vertices, const AcArray< AcGeDoubleArray, AcArrayObjectCopyReallocator< AcGeDoubleArray > > &bulges, AcDbIntArray &rejectedObjs, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz)
virtual Acad::ErrorStatus | createLoopsFromBoundaries (const AcDbObjectIdArray &ids, AcDbIntArray &rejectedObjs, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz)
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual void | deleteMPolygonTree (AcDbMPolygonNode *loopNode) const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual double | elevation () const
virtual Acad::ErrorStatus | evaluateHatch (bool bUnderestimateNumLines=false)
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual double | getArea () const
virtual void | getChildLoops (int curLoop, AcGeIntArray &selectedLoopIndexes) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual int | getClosestLoopTo (const AcGePoint3d &worldPt) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcDbIntArray &gsMarkers) const
virtual Acad::ErrorStatus | getLoopAtGsMarker (int gsMark, int &loop) const
virtual Acad::ErrorStatus | getLoopDirection (int lindex, AcDbMPolygon::loopDir &dir) const
virtual Acad::ErrorStatus | getMPolygonLoopAt (int loopIndex, AcGePoint2dArray &vertices, AcGeDoubleArray &bulges) const
virtual Acad::ErrorStatus | getMPolygonTree (AcDbMPolygonNode *&loopNode) const
virtual AcGeVector2d | getOffsetVector () const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, int gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual int | getParentLoop (int curLoop) const
virtual Acad::ErrorStatus | getPatternDefinitionAt (int index, double &angle, double &baseX, double &baseY, double &offsetX, double &offsetY, AcGeDoubleArray &dashes) const
virtual double | getPerimeter () const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, int gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcDbHatch * | hatch ()
virtual bool | includesTouchingLoops (double tol=AcDbMPolygonCrossingFuzz) const
virtual Acad::ErrorStatus | insertMPolygonLoopAt (int loopIndex, const AcGePoint2dArray &vertices, const AcGeDoubleArray &bulges, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz)
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, int thisGsMarker=0, int otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, int thisGsMarker=0, int otherGsMarker=0) const
virtual bool | isBalanced () const
virtual int | isPointInsideMPolygon (const AcGePoint3d &worldPt, AcGeIntArray &loopsArray, double tol=AcDbMPolygonCrossingFuzz) const
virtual bool | isPointOnLoopBoundary (const AcGePoint3d &worldPt, int loop, double tol=AcDbMPolygonCrossingFuzz) const
virtual void | list () const
virtual Acad::ErrorStatus | loopCrossesItself (bool &crosses, bool findAll, AcDbMPolygonCrossingArray &crossingsArray, const AcGePoint2dArray &vertexPts, const AcGeDoubleArray &vertexBulges, double tol=AcDbMPolygonCrossingFuzz) const
virtual bool | loopCrossesItself (const AcGePoint2dArray &vertexPts, const AcGeDoubleArray &vertexBulges, double tol=AcDbMPolygonCrossingFuzz) const
virtual Acad::ErrorStatus | loopCrossesMPolygon (bool &crosses, bool findAll, AcDbMPolygonCrossingArray &crossingsArray, const AcGePoint2dArray &testVertexPts, const AcGeDoubleArray &testVertexBulges, double tol=AcDbMPolygonCrossingFuzz) const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual AcGeVector3d | normal () const
virtual int | numMPolygonLoops () const
virtual int | numPatternDefinitions () const
virtual double | patternAngle () const
virtual AcCmColor | patternColor () const
virtual bool | patternDouble () const
virtual const TCHAR * | patternName () const
virtual double | patternScale () const
virtual double | patternSpace () const
virtual AcDbHatch::HatchPatternType | patternType () const
virtual Acad::ErrorStatus | removeMPolygonLoopAt (int loopIndex)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual bool | selfCrosses (const AcGePoint2dArray &vertexPts, const AcGeDoubleArray &vertexBulges, double tol=AcDbMPolygonCrossingFuzz) const
virtual Acad::ErrorStatus | setElevation (double elevation)
Acad::ErrorStatus | setGradient (AcDbHatch::GradientPatternType gradType, const TCHAR *gradName)
Acad::ErrorStatus | setGradientAngle (double angle)
Acad::ErrorStatus | setGradientColors (unsigned int count, AcCmColor *colors, float *values)
Acad::ErrorStatus | setGradientOneColorMode (Adesk::Boolean oneColorMode)
Acad::ErrorStatus | setGradientShift (float shiftValue)
virtual Acad::ErrorStatus | setLoopDirection (int lindex, AcDbMPolygon::loopDir dir)
virtual Acad::ErrorStatus | setNormal (const AcGeVector3d &normal)
virtual Acad::ErrorStatus | setPattern (AcDbHatch::HatchPatternType patType, const TCHAR *patName)
virtual Acad::ErrorStatus | setPatternAngle (double angle)
virtual Acad::ErrorStatus | setPatternColor (const AcCmColor &pc)
virtual Acad::ErrorStatus | setPatternDouble (bool isDouble)
virtual Acad::ErrorStatus | setPatternScale (double scale)
virtual Acad::ErrorStatus | setPatternSpace (double space)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpMPolygon

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

virtual Acad::ErrorStatus AcDbMPolygon::createLoops | ( | const AcArray< AcGePoint2dArray, AcArrayObjectCopyReallocator< AcGePoint2dArray > > & | vertices,
 |  | const AcArray< AcGeDoubleArray, AcArrayObjectCopyReallocator< AcGeDoubleArray > > & | bulges,
 |  | AcDbIntArray & | rejectedObjs,
 |  | bool | excludeCrossing = true,
 |  | double | tol = AcDbMPolygonCrossingFuzz
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbMPolygon::createLoopsFromBoundaries | ( | const AcDbObjectIdArray & | ids,
 |  | AcDbIntArray & | rejectedObjs,
 |  | bool | excludeCrossing = true,
 |  | double | tol = AcDbMPolygonCrossingFuzz
 | ) |  |
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbMPolygon.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMPolygon Member List

This is the complete list of members for AcDbMPolygon, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbMPolygon) (defined in AcDbMPolygon) | AcDbMPolygon |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbImpMPolygon (defined in AcDbMPolygon) | AcDbMPolygon | friend
AcDbMPolygon() (defined in AcDbMPolygon) | AcDbMPolygon |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
appendLoopFromBoundary(const AcDbCircle *pCircle, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
appendLoopFromBoundary(const AcDbPolyline *pPoly, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
appendLoopFromBoundary(const AcDb2dPolyline *pPoly, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
appendMPolygonLoop(const AcGePoint2dArray &vertices, const AcGeDoubleArray &bulges, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
balanceDisplay() (defined in AcDbMPolygon) | AcDbMPolygon | virtual
balanceTree() (defined in AcDbMPolygon) | AcDbMPolygon | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createLoops(const AcArray< AcGePoint2dArray, AcArrayObjectCopyReallocator< AcGePoint2dArray > > &vertices, const AcArray< AcGeDoubleArray, AcArrayObjectCopyReallocator< AcGeDoubleArray > > &bulges, AcDbIntArray &rejectedObjs, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz) | AcDbMPolygon | virtual
createLoopsFromBoundaries(const AcDbObjectIdArray &ids, AcDbIntArray &rejectedObjs, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz) | AcDbMPolygon | virtual
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteMPolygonTree(AcDbMPolygonNode *loopNode) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
elevation() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
evaluateHatch(bool bUnderestimateNumLines=false) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getChildLoops(int curLoop, AcGeIntArray &selectedLoopIndexes) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getClassID(CLSID *pClsid) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getClosestLoopTo(const AcGePoint3d &worldPt) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcDbIntArray &gsMarkers) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getLoopAtGsMarker(int gsMark, int &loop) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getLoopDirection(int lindex, AcDbMPolygon::loopDir &dir) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getMPolygonLoopAt(int loopIndex, AcGePoint2dArray &vertices, AcGeDoubleArray &bulges) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getMPolygonTree(AcDbMPolygonNode *&loopNode) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetVector() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, int gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParentLoop(int curLoop) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getPatternDefinitionAt(int index, double &angle, double &baseX, double &baseY, double &offsetX, double &offsetY, AcGeDoubleArray &dashes) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getPerimeter() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, int gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hatch() (defined in AcDbMPolygon) | AcDbMPolygon | virtual
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
includesTouchingLoops(double tol=AcDbMPolygonCrossingFuzz) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
insertMPolygonLoopAt(int loopIndex, const AcGePoint2dArray &vertices, const AcGeDoubleArray &bulges, bool excludeCrossing=true, double tol=AcDbMPolygonCrossingFuzz) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, int thisGsMarker=0, int otherGsMarker=0) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, int thisGsMarker=0, int otherGsMarker=0) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isBalanced() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isPointInsideMPolygon(const AcGePoint3d &worldPt, AcGeIntArray &loopsArray, double tol=AcDbMPolygonCrossingFuzz) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
isPointOnLoopBoundary(const AcGePoint3d &worldPt, int loop, double tol=AcDbMPolygonCrossingFuzz) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kAnnotation enum value (defined in AcDbMPolygon) | AcDbMPolygon |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kExterior enum value (defined in AcDbMPolygon) | AcDbMPolygon |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kInterior enum value (defined in AcDbMPolygon) | AcDbMPolygon |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
loopCrossesItself(bool &crosses, bool findAll, AcDbMPolygonCrossingArray &crossingsArray, const AcGePoint2dArray &vertexPts, const AcGeDoubleArray &vertexBulges, double tol=AcDbMPolygonCrossingFuzz) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
loopCrossesItself(const AcGePoint2dArray &vertexPts, const AcGeDoubleArray &vertexBulges, double tol=AcDbMPolygonCrossingFuzz) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
loopCrossesMPolygon(bool &crosses, bool findAll, AcDbMPolygonCrossingArray &crossingsArray, const AcGePoint2dArray &testVertexPts, const AcGeDoubleArray &testVertexBulges, double tol=AcDbMPolygonCrossingFuzz) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
loopDir enum name (defined in AcDbMPolygon) | AcDbMPolygon |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
normal() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
numMPolygonLoops() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
numPatternDefinitions() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
patternAngle() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
patternColor() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
patternDouble() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
patternName() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
patternScale() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
patternSpace() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
patternType() const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeMPolygonLoopAt(int loopIndex) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
selfCrosses(const AcGePoint2dArray &vertexPts, const AcGeDoubleArray &vertexBulges, double tol=AcDbMPolygonCrossingFuzz) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setElevation(double elevation) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGradient(AcDbHatch::GradientPatternType gradType, const TCHAR *gradName) (defined in AcDbMPolygon) | AcDbMPolygon |
setGradientAngle(double angle) (defined in AcDbMPolygon) | AcDbMPolygon |
setGradientColors(unsigned int count, AcCmColor *colors, float *values) (defined in AcDbMPolygon) | AcDbMPolygon |
setGradientOneColorMode(Adesk::Boolean oneColorMode) (defined in AcDbMPolygon) | AcDbMPolygon |
setGradientShift(float shiftValue) (defined in AcDbMPolygon) | AcDbMPolygon |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLoopDirection(int lindex, AcDbMPolygon::loopDir dir) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &normal) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPattern(AcDbHatch::HatchPatternType patType, const TCHAR *patName) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setPatternAngle(double angle) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setPatternColor(const AcCmColor &pc) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setPatternDouble(bool isDouble) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setPatternScale(double scale) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setPatternSpace(double space) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbMPolygon) | AcDbMPolygon | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbMPolygon) | AcDbMPolygon | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbMPolygon() (defined in AcDbMPolygon) | AcDbMPolygon | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbMPolygonCrossing Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbMPolygonCrossing Class Reference
AcDb Classes

Public Member Functions

AcGePoint2d | getCrossingPoint () const
int | getEdgeIndex () const
int | getLoopIndex () const
void | setCrossingPoint (const AcGePoint2d &pt)
void | setEdgeIndex (int index)
void | setLoopIndex (int index)
The documentation for this class was generated from the following file:
  • dbMPolygon.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMPolygonCrossing Member List

This is the complete list of members for AcDbMPolygonCrossing, including all inherited members.

AcDbMPolygonCrossing() (defined in AcDbMPolygonCrossing) | AcDbMPolygonCrossing
getCrossingPoint() const (defined in AcDbMPolygonCrossing) | AcDbMPolygonCrossing
getEdgeIndex() const (defined in AcDbMPolygonCrossing) | AcDbMPolygonCrossing
getLoopIndex() const (defined in AcDbMPolygonCrossing) | AcDbMPolygonCrossing
setCrossingPoint(const AcGePoint2d &pt) (defined in AcDbMPolygonCrossing) | AcDbMPolygonCrossing
setEdgeIndex(int index) (defined in AcDbMPolygonCrossing) | AcDbMPolygonCrossing
setLoopIndex(int index) (defined in AcDbMPolygonCrossing) | AcDbMPolygonCrossing
~AcDbMPolygonCrossing() (defined in AcDbMPolygonCrossing) | AcDbMPolygonCrossing


ZRX API Reference: AcDbMPolygonCrossingArray Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcDbMPolygonCrossingArray Class Reference
AcDb Classes

Public Attributes

AcArray< AcDbMPolygonCrossing * > mCrossingArray
The documentation for this class was generated from the following file:
  • dbMPolygon.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMPolygonCrossingArray Member List

This is the complete list of members for AcDbMPolygonCrossingArray, including all inherited members.

mCrossingArray (defined in AcDbMPolygonCrossingArray) | AcDbMPolygonCrossingArray |
~AcDbMPolygonCrossingArray() (defined in AcDbMPolygonCrossingArray) | AcDbMPolygonCrossingArray | inline


ZRX API Reference: AcDbMpolygonLoops Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
AcDbMpolygonLoops Class Reference
AcDb Classes

Public Member Functions

AcDbMpolygonLoops (int lindex, int gindex=0, int gcnt=0)

Public Attributes

int | mGripCount
int | mGripIndex
bool | mIsText
int | mLoopIndex
AcGeDoubleArray | mVertexBulges
AcGePoint2dArray | mVertexPoints
The documentation for this class was generated from the following file:
  • dbMPolygon.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMpolygonLoops Member List

This is the complete list of members for AcDbMpolygonLoops, including all inherited members.

AcDbMpolygonLoops(int lindex, int gindex=0, int gcnt=0) (defined in AcDbMpolygonLoops) | AcDbMpolygonLoops | inline
mGripCount (defined in AcDbMpolygonLoops) | AcDbMpolygonLoops |
mGripIndex (defined in AcDbMpolygonLoops) | AcDbMpolygonLoops |
mIsText (defined in AcDbMpolygonLoops) | AcDbMpolygonLoops |
mLoopIndex (defined in AcDbMpolygonLoops) | AcDbMpolygonLoops |
mVertexBulges (defined in AcDbMpolygonLoops) | AcDbMpolygonLoops |
mVertexPoints (defined in AcDbMpolygonLoops) | AcDbMpolygonLoops |


ZRX API Reference: AcDbMPolygonNode Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcDbMPolygonNode Class Reference
AcDb Classes

Public Attributes

AcArray< AcDbMPolygonNode * > | mChildren
int | mLoopIndex
AcDbMPolygonNode * | mParent
The documentation for this class was generated from the following file:
  • dbMPolygon.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMPolygonNode Member List

This is the complete list of members for AcDbMPolygonNode, including all inherited members.

AcDbMPolygonNode() (defined in AcDbMPolygonNode) | AcDbMPolygonNode | inline
mChildren (defined in AcDbMPolygonNode) | AcDbMPolygonNode |
mLoopIndex (defined in AcDbMPolygonNode) | AcDbMPolygonNode |
mParent (defined in AcDbMPolygonNode) | AcDbMPolygonNode |


ZRX API Reference: AcDbMText Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcDbMText Class Reference
AcDb Classes
+ Inheritance diagram for AcDbMText:

Public Types

enum AttachmentPoint {
kTopLeft = 1, kTopCenter = 2, kTopRight = 3, kMiddleLeft = 4,
kMiddleCenter = 5, kMiddleRight = 6, kBottomLeft = 7, kBottomCenter = 8,
kBottomRight = 9, kBaseLeft = 10, kBaseCenter = 11, kBaseRight = 12,
kBaseAlign = 13, kBottomAlign = 14, kMiddleAlign = 15, kTopAlign = 16,
kBaseFit = 17, kBottomFit = 18, kMiddleFit = 19, kTopFit = 20,
kBaseMid = 21, kBottomMid = 22, kMiddleMid = 23, kTopMid = 24
}
enum | ColumnType { kNoColumns, kStaticColumns, kDynamicColumns }
enum FlowDirection {
kLtoR = 1, kRtoL = 2, kTtoB = 3, kBtoT = 4,
kByStyle = 5
}
- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbMText)
double | actualHeight (AcGiWorldDraw *ctxt=NULL) const
double | actualWidth () const
double | ascent () const
AttachmentPoint | attachment () const
bool | backgroundFillOn () const
ACHAR * | contents () const
Acad::ErrorStatus | convertFieldToText ()
int | correctSpelling ()
double | descent () const
AcGeVector3d | direction () const
void | explodeFragments (AcDbMTextEnum, void *, AcGiWorldDraw *ctxt=NULL) const
FlowDirection | flowDirection () const
Acad::ErrorStatus | getBackgroundFillColor (AcCmColor &color) const
Acad::ErrorStatus | getBackgroundScaleFactor (double &scale) const
Acad::ErrorStatus | getBackgroundTransparency (AcCmTransparency &transp) const
void | getBoundingPoints (AcGePoint3dArray &) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getColumnAutoHeight (bool &) const
Acad::ErrorStatus | getColumnCount (int &) const
Acad::ErrorStatus | getColumnFlowReversed (bool &) const
Acad::ErrorStatus | getColumnGutterWidth (double &) const
Acad::ErrorStatus | getColumnHeight (int, double &) const
Acad::ErrorStatus | getColumnType (ColumnType &) const
Acad::ErrorStatus | getColumnWidth (double &) const
void | getEcs (AcGeMatrix3d &retVal) const
double | height () const
double | lineSpacingFactor () const
AcDb::LineSpacingStyle | lineSpacingStyle () const
AcGePoint3d | location () const
AcGeVector3d | normal () const
Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
double | rotation () const
Acad::ErrorStatus | setAttachment (AttachmentPoint)
Acad::ErrorStatus | setAttachmentMovingLocation (AttachmentPoint)
Acad::ErrorStatus | setBackgroundFill (bool enable)
Acad::ErrorStatus | setBackgroundFillColor (const AcCmColor &color)
Acad::ErrorStatus | setBackgroundScaleFactor (const double scale)
Acad::ErrorStatus | setBackgroundTransparency (const AcCmTransparency &transp)
Acad::ErrorStatus | setColumnAutoHeight (bool)
Acad::ErrorStatus | setColumnCount (int)
Acad::ErrorStatus | setColumnFlowReversed (bool)
Acad::ErrorStatus | setColumnGutterWidth (double)
Acad::ErrorStatus | setColumnHeight (int, double)
Acad::ErrorStatus | setColumnType (ColumnType)
Acad::ErrorStatus | setColumnWidth (double)
int | setContents (const ACHAR *)
int | setContentsRTF (const ACHAR *)
Acad::ErrorStatus | setDirection (const AcGeVector3d &)
Acad::ErrorStatus | setDynamicColumns (double width, double gutter, bool auto_height)
Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
Acad::ErrorStatus | setFlowDirection (FlowDirection)
Acad::ErrorStatus | setHeight (double)
Acad::ErrorStatus | setLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setLocation (const AcGePoint3d &)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setRotation (double)
Acad::ErrorStatus | setStaticColumns (double width, double gutter, int count)
Acad::ErrorStatus | setTextHeight (double)
Acad::ErrorStatus | setTextStyle (AcDbObjectId)
Acad::ErrorStatus | setUseBackgroundColor (bool enable)
Acad::ErrorStatus | setUseWordBreak (bool bEnable)
Acad::ErrorStatus | setWidth (double)
ACHAR * | text () const
double | textHeight () const
AcDbObjectId | textStyle () const
bool | useBackgroundColorOn () const
bool | useWordBreak () const
double | width () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static const ACHAR *const | alignChange ()
static const ACHAR *const | blockBegin ()
static const ACHAR *const | blockEnd ()
static const ACHAR *const | colorChange ()
static const ACHAR *const | fontChange ()
static const ACHAR *const | heightChange ()
static const ACHAR *const | lineBreak ()
static const ACHAR *const | nonBreakSpace ()
static const ACHAR *const | obliqueChange ()
static const ACHAR *const | overlineOff ()
static const ACHAR *const | overlineOn ()
static const ACHAR *const | paragraphBreak ()
static const ACHAR *const | stackStart ()
static const ACHAR *const | strikethroughOff ()
static const ACHAR *const | strikethroughOn ()
static const ACHAR *const | trackChange ()
static const ACHAR *const | underlineOff ()
static const ACHAR *const | underlineOn ()
static const ACHAR *const | widthChange ()
The documentation for this class was generated from the following file:
  • dbmtext.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMText Member List

This is the complete list of members for AcDbMText, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbMText) (defined in AcDbMText) | AcDbMText |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbMText() (defined in AcDbMText) | AcDbMText |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
actualHeight(AcGiWorldDraw *ctxt=NULL) const (defined in AcDbMText) | AcDbMText |
actualWidth() const (defined in AcDbMText) | AcDbMText |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
alignChange() (defined in AcDbMText) | AcDbMText | static
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
ascent() const (defined in AcDbMText) | AcDbMText |
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
attachment() const (defined in AcDbMText) | AcDbMText |
AttachmentPoint enum name (defined in AcDbMText) | AcDbMText |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
backgroundFillOn() const (defined in AcDbMText) | AcDbMText |
blockBegin() (defined in AcDbMText) | AcDbMText | static
blockEnd() (defined in AcDbMText) | AcDbMText | static
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorChange() (defined in AcDbMText) | AcDbMText | static
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
ColumnType enum name (defined in AcDbMText) | AcDbMText |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contents() const (defined in AcDbMText) | AcDbMText |
convertFieldToText() (defined in AcDbMText) | AcDbMText |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
correctSpelling() (defined in AcDbMText) | AcDbMText |
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
descent() const (defined in AcDbMText) | AcDbMText |
direction() const (defined in AcDbMText) | AcDbMText |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
explodeFragments(AcDbMTextEnum, void *, AcGiWorldDraw *ctxt=NULL) const (defined in AcDbMText) | AcDbMText |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
FlowDirection enum name (defined in AcDbMText) | AcDbMText |
flowDirection() const (defined in AcDbMText) | AcDbMText |
fontChange() (defined in AcDbMText) | AcDbMText | static
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBackgroundFillColor(AcCmColor &color) const (defined in AcDbMText) | AcDbMText |
getBackgroundScaleFactor(double &scale) const (defined in AcDbMText) | AcDbMText |
getBackgroundTransparency(AcCmTransparency &transp) const (defined in AcDbMText) | AcDbMText |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBoundingPoints(AcGePoint3dArray &) const (defined in AcDbMText) | AcDbMText |
getClassID(CLSID *pClsid) const (defined in AcDbMText) | AcDbMText | virtual
getColumnAutoHeight(bool &) const (defined in AcDbMText) | AcDbMText |
getColumnCount(int &) const (defined in AcDbMText) | AcDbMText |
getColumnFlowReversed(bool &) const (defined in AcDbMText) | AcDbMText |
getColumnGutterWidth(double &) const (defined in AcDbMText) | AcDbMText |
getColumnHeight(int, double &) const (defined in AcDbMText) | AcDbMText |
getColumnType(ColumnType &) const (defined in AcDbMText) | AcDbMText |
getColumnWidth(double &) const (defined in AcDbMText) | AcDbMText |
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbMText) | AcDbMText | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height() const (defined in AcDbMText) | AcDbMText |
heightChange() (defined in AcDbMText) | AcDbMText | static
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kBaseAlign enum value (defined in AcDbMText) | AcDbMText |
kBaseCenter enum value (defined in AcDbMText) | AcDbMText |
kBaseFit enum value (defined in AcDbMText) | AcDbMText |
kBaseLeft enum value (defined in AcDbMText) | AcDbMText |
kBaseMid enum value (defined in AcDbMText) | AcDbMText |
kBaseRight enum value (defined in AcDbMText) | AcDbMText |
kBottomAlign enum value (defined in AcDbMText) | AcDbMText |
kBottomCenter enum value (defined in AcDbMText) | AcDbMText |
kBottomFit enum value (defined in AcDbMText) | AcDbMText |
kBottomLeft enum value (defined in AcDbMText) | AcDbMText |
kBottomMid enum value (defined in AcDbMText) | AcDbMText |
kBottomRight enum value (defined in AcDbMText) | AcDbMText |
kBtoT enum value (defined in AcDbMText) | AcDbMText |
kByStyle enum value (defined in AcDbMText) | AcDbMText |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDynamicColumns enum value (defined in AcDbMText) | AcDbMText |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kLtoR enum value (defined in AcDbMText) | AcDbMText |
kMiddleAlign enum value (defined in AcDbMText) | AcDbMText |
kMiddleCenter enum value (defined in AcDbMText) | AcDbMText |
kMiddleFit enum value (defined in AcDbMText) | AcDbMText |
kMiddleLeft enum value (defined in AcDbMText) | AcDbMText |
kMiddleMid enum value (defined in AcDbMText) | AcDbMText |
kMiddleRight enum value (defined in AcDbMText) | AcDbMText |
kNoColumns enum value (defined in AcDbMText) | AcDbMText |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kRtoL enum value (defined in AcDbMText) | AcDbMText |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kStaticColumns enum value (defined in AcDbMText) | AcDbMText |
kTopAlign enum value (defined in AcDbMText) | AcDbMText |
kTopCenter enum value (defined in AcDbMText) | AcDbMText |
kTopFit enum value (defined in AcDbMText) | AcDbMText |
kTopLeft enum value (defined in AcDbMText) | AcDbMText |
kTopMid enum value (defined in AcDbMText) | AcDbMText |
kTopRight enum value (defined in AcDbMText) | AcDbMText |
kTtoB enum value (defined in AcDbMText) | AcDbMText |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
lineBreak() (defined in AcDbMText) | AcDbMText | static
lineSpacingFactor() const (defined in AcDbMText) | AcDbMText |
lineSpacingStyle() const (defined in AcDbMText) | AcDbMText |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
location() const (defined in AcDbMText) | AcDbMText |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
nonBreakSpace() (defined in AcDbMText) | AcDbMText | static
normal() const (defined in AcDbMText) | AcDbMText |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
obliqueChange() (defined in AcDbMText) | AcDbMText | static
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
overlineOff() (defined in AcDbMText) | AcDbMText | static
overlineOn() (defined in AcDbMText) | AcDbMText | static
ownerId() const (defined in AcDbObject) | AcDbObject |
paragraphBreak() (defined in AcDbMText) | AcDbMText | static
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbMText) | AcDbMText | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbMText) | AcDbMText | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbMText) | AcDbMText | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const (defined in AcDbMText) | AcDbMText |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttachment(AttachmentPoint) (defined in AcDbMText) | AcDbMText |
setAttachmentMovingLocation(AttachmentPoint) (defined in AcDbMText) | AcDbMText |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBackgroundFill(bool enable) (defined in AcDbMText) | AcDbMText |
setBackgroundFillColor(const AcCmColor &color) (defined in AcDbMText) | AcDbMText |
setBackgroundScaleFactor(const double scale) (defined in AcDbMText) | AcDbMText |
setBackgroundTransparency(const AcCmTransparency &transp) (defined in AcDbMText) | AcDbMText |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColumnAutoHeight(bool) (defined in AcDbMText) | AcDbMText |
setColumnCount(int) (defined in AcDbMText) | AcDbMText |
setColumnFlowReversed(bool) (defined in AcDbMText) | AcDbMText |
setColumnGutterWidth(double) (defined in AcDbMText) | AcDbMText |
setColumnHeight(int, double) (defined in AcDbMText) | AcDbMText |
setColumnType(ColumnType) (defined in AcDbMText) | AcDbMText |
setColumnWidth(double) (defined in AcDbMText) | AcDbMText |
setContents(const ACHAR *) (defined in AcDbMText) | AcDbMText |
setContentsRTF(const ACHAR *) (defined in AcDbMText) | AcDbMText |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDirection(const AcGeVector3d &) (defined in AcDbMText) | AcDbMText |
setDynamicColumns(double width, double gutter, bool auto_height) (defined in AcDbMText) | AcDbMText |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbMText) | AcDbMText | virtual
setFlowDirection(FlowDirection) (defined in AcDbMText) | AcDbMText |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double) (defined in AcDbMText) | AcDbMText |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLineSpacingFactor(double dFactor) (defined in AcDbMText) | AcDbMText |
setLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbMText) | AcDbMText |
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLocation(const AcGePoint3d &) (defined in AcDbMText) | AcDbMText |
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbMText) | AcDbMText |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double) (defined in AcDbMText) | AcDbMText |
setStaticColumns(double width, double gutter, int count) (defined in AcDbMText) | AcDbMText |
setTextHeight(double) (defined in AcDbMText) | AcDbMText |
setTextStyle(AcDbObjectId) (defined in AcDbMText) | AcDbMText |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUseBackgroundColor(bool enable) (defined in AcDbMText) | AcDbMText |
setUseWordBreak(bool bEnable) (defined in AcDbMText) | AcDbMText |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWidth(double) (defined in AcDbMText) | AcDbMText |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
stackStart() (defined in AcDbMText) | AcDbMText | static
strikethroughOff() (defined in AcDbMText) | AcDbMText | static
strikethroughOn() (defined in AcDbMText) | AcDbMText | static
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
text() const (defined in AcDbMText) | AcDbMText |
textHeight() const (defined in AcDbMText) | AcDbMText |
textStyle() const (defined in AcDbMText) | AcDbMText |
trackChange() (defined in AcDbMText) | AcDbMText | static
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
underlineOff() (defined in AcDbMText) | AcDbMText | static
underlineOn() (defined in AcDbMText) | AcDbMText | static
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useBackgroundColorOn() const (defined in AcDbMText) | AcDbMText |
useWordBreak() const (defined in AcDbMText) | AcDbMText |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
width() const (defined in AcDbMText) | AcDbMText |
widthChange() (defined in AcDbMText) | AcDbMText | static
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbMText() (defined in AcDbMText) | AcDbMText |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbNamedPath Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcDbNamedPath Class Reference
AcDb Classes
+ Inheritance diagram for AcDbNamedPath:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbNamedPath)
virtual Acad::ErrorStatus | getGeometry (AcGeCurve3d *&pCurveGeometry) const =0
virtual | ~AcDbNamedPath ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcDbNamedPath (AcDbImpNamedPath *pImp)
AcDbImpNamedPath * imp () const

Friends

class AcDbImpNamedPath

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

virtual AcDbNamedPath::~AcDbNamedPath ( )
virtual
Warning
Not implemented!
AcDbNamedPath::AcDbNamedPath ( AcDbImpNamedPath * pImp )
protected
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbNamedPath::getGeometry ( AcGeCurve3d *& pCurveGeometry ) const
pure virtual
Warning
Not implemented!

Implemented in AcDbPointPath, and AcDbCurvePath.

AcDbImpNamedPath* AcDbNamedPath::imp ( ) const
protected
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbNamedPath.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbNamedPath Member List

This is the complete list of members for AcDbNamedPath, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbImpNamedPath (defined in AcDbNamedPath) | AcDbNamedPath | friend
AcDbNamedPath(AcDbImpNamedPath *pImp) | AcDbNamedPath | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbNamedPath) (defined in AcDbNamedPath) | AcDbNamedPath |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeometry(AcGeCurve3d *&pCurveGeometry) const =0 | AcDbNamedPath | pure virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imp() const | AcDbNamedPath | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbNamedPath() | AcDbNamedPath | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbObject Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbObject Class Reference
AcDb Classes
+ Inheritance diagram for AcDbObject:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbSystemInternals

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObject Member List

This is the complete list of members for AcDbObject, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSystemInternals (defined in AcDbObject) | AcDbObject | friend
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbObjectContext Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbObjectContext Class Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectContext:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbObjectContext)
virtual AcString | collectionName () const =0
virtual Acad::ErrorStatus | getName (AcString &name) const =0
virtual Acad::ErrorStatus | setName (const AcString &name)=0
virtual Adesk::LongPtr | uniqueIdentifier () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbObjContext.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectContext Member List

This is the complete list of members for AcDbObjectContext, including all inherited members.

AcDbObjectContext() (defined in AcDbObjectContext) | AcDbObjectContext |
ACRX_DECLARE_MEMBERS(AcDbObjectContext) (defined in AcDbObjectContext) | AcDbObjectContext |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
collectionName() const =0 (defined in AcDbObjectContext) | AcDbObjectContext | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getName(AcString &name) const =0 (defined in AcDbObjectContext) | AcDbObjectContext | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setName(const AcString &name)=0 (defined in AcDbObjectContext) | AcDbObjectContext | pure virtual
uniqueIdentifier() const =0 (defined in AcDbObjectContext) | AcDbObjectContext | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbObjectContext() (defined in AcDbObjectContext) | AcDbObjectContext | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbObjectContextCollection Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbObjectContextCollection Class Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectContextCollection:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbObjectContextCollection)
virtual Acad::ErrorStatus | addContext (const AcDbObjectContext *pContext)=0
virtual AcDbObjectContext * | currentContext (const AcDbObject *pRequestingObject) const =0
virtual AcDbObjectContext * | getContext (const AcString &contextName) const =0
virtual bool | hasContext (const AcString &contextName) const =0
virtual Acad::ErrorStatus | lockContext (const AcDbObjectContext *pContext)=0
virtual bool | locked () const =0
virtual AcString | name () const =0
virtual
AcDbObjectContextCollectionIterator * 		newIterator () const =0
virtual Acad::ErrorStatus | removeContext (const AcString &contextName)=0
virtual Acad::ErrorStatus | setCurrentContext (const AcDbObjectContext *pContext)=0
virtual Acad::ErrorStatus | unlockContext ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbObjectContextCollection.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectContextCollection Member List

This is the complete list of members for AcDbObjectContextCollection, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbObjectContextCollection) (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addContext(const AcDbObjectContext *pContext)=0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
currentContext(const AcDbObject *pRequestingObject) const =0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
getContext(const AcString &contextName) const =0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
hasContext(const AcString &contextName) const =0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
lockContext(const AcDbObjectContext *pContext)=0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
locked() const =0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
name() const =0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
newIterator() const =0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeContext(const AcString &contextName)=0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
setCurrentContext(const AcDbObjectContext *pContext)=0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
unlockContext()=0 (defined in AcDbObjectContextCollection) | AcDbObjectContextCollection | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbObjectContextCollectionIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbObjectContextCollectionIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectContextCollectionIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbObjectContextCollectionIterator)
virtual bool | done () const =0
virtual Acad::ErrorStatus | getContext (AcDbObjectContext *&pObjectContext) const =0
virtual bool | next ()=0
virtual Acad::ErrorStatus | start ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbObjectContextCollection.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectContextCollectionIterator Member List

This is the complete list of members for AcDbObjectContextCollectionIterator, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbObjectContextCollectionIterator) (defined in AcDbObjectContextCollectionIterator) | AcDbObjectContextCollectionIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const =0 (defined in AcDbObjectContextCollectionIterator) | AcDbObjectContextCollectionIterator | pure virtual
getContext(AcDbObjectContext *&pObjectContext) const =0 (defined in AcDbObjectContextCollectionIterator) | AcDbObjectContextCollectionIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
next()=0 (defined in AcDbObjectContextCollectionIterator) | AcDbObjectContextCollectionIterator | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
start()=0 (defined in AcDbObjectContextCollectionIterator) | AcDbObjectContextCollectionIterator | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbObjectContextInterface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbObjectContextInterface Class Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectContextInterface:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbObjectContextInterface)
virtual Acad::ErrorStatus | addContext (AcDbObject *pObject, const AcDbObjectContext &context) const =0
virtual bool | hasContext (const AcDbObject *pObject, const AcDbObjectContext &context) const =0
virtual Acad::ErrorStatus | removeContext (AcDbObject *pObject, const AcDbObjectContext &context) const =0
virtual bool | supportsCollection (const AcDbObject *pObject, const AcString &collectionName) const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbObjectContextInterface.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectContextInterface Member List

This is the complete list of members for AcDbObjectContextInterface, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbObjectContextInterface) (defined in AcDbObjectContextInterface) | AcDbObjectContextInterface |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addContext(AcDbObject *pObject, const AcDbObjectContext &context) const =0 (defined in AcDbObjectContextInterface) | AcDbObjectContextInterface | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
hasContext(const AcDbObject *pObject, const AcDbObjectContext &context) const =0 (defined in AcDbObjectContextInterface) | AcDbObjectContextInterface | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeContext(AcDbObject *pObject, const AcDbObjectContext &context) const =0 (defined in AcDbObjectContextInterface) | AcDbObjectContextInterface | pure virtual
supportsCollection(const AcDbObject *pObject, const AcString &collectionName) const =0 (defined in AcDbObjectContextInterface) | AcDbObjectContextInterface | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbObjectContextManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbObjectContextManager Class Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectContextManager:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbObjectContextManager)
AcDbObjectContextCollection *const | contextCollection (const AcString &collectionName) const
Acad::ErrorStatus | registerContextCollection (const AcString &collectionName, AcDbObjectContextCollection *pCollection)
Acad::ErrorStatus | unregisterContextCollection (const AcString &collectionName)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbContextDataSubManager

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Member Function Documentation

AcDbObjectContextCollection* const AcDbObjectContextManager::contextCollection ( const AcString & collectionName ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbObjectContextManager::registerContextCollection | ( | const AcString & | collectionName,
 |  | AcDbObjectContextCollection * | pCollection
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbObjectContextManager::unregisterContextCollection ( const AcString & collectionName )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbObjectContextManager.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectContextManager Member List

This is the complete list of members for AcDbObjectContextManager, including all inherited members.

AcDbContextDataSubManager (defined in AcDbObjectContextManager) | AcDbObjectContextManager | friend
AcDbObjectContextManager() (defined in AcDbObjectContextManager) | AcDbObjectContextManager |
ACRX_DECLARE_MEMBERS(AcDbObjectContextManager) (defined in AcDbObjectContextManager) | AcDbObjectContextManager |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contextCollection(const AcString &collectionName) const | AcDbObjectContextManager |
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
registerContextCollection(const AcString &collectionName, AcDbObjectContextCollection *pCollection) | AcDbObjectContextManager |
unregisterContextCollection(const AcString &collectionName) | AcDbObjectContextManager |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbObjectContextManager() (defined in AcDbObjectContextManager) | AcDbObjectContextManager | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbObjectId Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Attributes | Protected Attributes | List of all members
AcDbObjectId Class Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectId:

Public Member Functions

AcDbObjectId (const AcDbStub *)
Adesk::IntDbId | asOldId () const
void | convertToRedirectedId ()
AcDbDatabase * | database () const
AcDbHandle | handle () const
bool | isEffectivelyErased () const
bool | isErased () const
bool | isNull () const
bool | isResident () const
bool | isValid () const
AcDbHandle | nonForwardedHandle () const
bool | objectLeftOnDisk () const
operator AcDbStub * () const
bool | operator!= (const AcDbObjectId &) const
bool | operator!= (const AcDbStub *) const
bool | operator< (const AcDbObjectId &) const
bool | operator< (const AcDbStub *) const
bool | operator<= (const AcDbObjectId &) const
bool | operator<= (const AcDbStub *) const
AcDbObjectId & | operator= (const AcDbObjectId &)
AcDbObjectId & | operator= (const AcDbStub *)
bool | operator== (const AcDbObjectId &) const
bool | operator== (const AcDbStub *) const
bool | operator> (const AcDbObjectId &) const
bool | operator> (const AcDbStub *) const
bool | operator>= (const AcDbObjectId &) const
bool | operator>= (const AcDbStub *) const
AcDbDatabase * | originalDatabase () const
AcDbObjectId & | setFromOldId (Adesk::IntDbId oldId)
void | setNull ()

Static Public Attributes

static ZRX_DB_STATIC_EXPORT
const AcDbObjectId 		kNull

Protected Attributes

AcDbStub * mId

Member Function Documentation

bool AcDbObjectId::isResident ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following files:
  • dbid.h
  • dbidapps.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectId Member List

This is the complete list of members for AcDbObjectId, including all inherited members.

AcDbObjectId() (defined in AcDbObjectId) | AcDbObjectId | inline
AcDbObjectId(const AcDbStub *) (defined in AcDbObjectId) | AcDbObjectId | inline
asOldId() const (defined in AcDbObjectId) | AcDbObjectId | inline
convertToRedirectedId() (defined in AcDbObjectId) | AcDbObjectId |
database() const (defined in AcDbObjectId) | AcDbObjectId |
handle() const (defined in AcDbObjectId) | AcDbObjectId |
isEffectivelyErased() const (defined in AcDbObjectId) | AcDbObjectId |
isErased() const (defined in AcDbObjectId) | AcDbObjectId |
isNull() const (defined in AcDbObjectId) | AcDbObjectId | inline
isResident() const | AcDbObjectId |
isValid() const (defined in AcDbObjectId) | AcDbObjectId |
kNull (defined in AcDbObjectId) | AcDbObjectId | static
mId (defined in AcDbObjectId) | AcDbObjectId | protected
nonForwardedHandle() const (defined in AcDbObjectId) | AcDbObjectId |
objectLeftOnDisk() const (defined in AcDbObjectId) | AcDbObjectId |
operator AcDbStub *() const (defined in AcDbObjectId) | AcDbObjectId | inline
operator!=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator!=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator=(const AcDbObjectId &) (defined in AcDbObjectId) | AcDbObjectId | inline
operator=(const AcDbStub *) (defined in AcDbObjectId) | AcDbObjectId | inline
operator==(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator==(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
originalDatabase() const (defined in AcDbObjectId) | AcDbObjectId |
setFromOldId(Adesk::IntDbId oldId) (defined in AcDbObjectId) | AcDbObjectId | inline
setNull() (defined in AcDbObjectId) | AcDbObjectId | inline


ZRX API Reference: AcDbObjectIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbObjectIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbObjectIterator)
bool | done () const
AcDbEntity * | entity ()
AcDbObjectId | objectId ()
void | setPosition (AcDbEntity *pEnt)
void | setPosition (AcDbObjectId pObj)
void | start (bool atEnd=false)
void | step (bool backwards=false, bool skipDeleted=true)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectIterator Member List

This is the complete list of members for AcDbObjectIterator, including all inherited members.

AcDbSystemInternals (defined in AcDbObjectIterator) | AcDbObjectIterator | friend
ACRX_DECLARE_MEMBERS(AcDbObjectIterator) (defined in AcDbObjectIterator) | AcDbObjectIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const (defined in AcDbObjectIterator) | AcDbObjectIterator |
entity() (defined in AcDbObjectIterator) | AcDbObjectIterator |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
objectId() (defined in AcDbObjectIterator) | AcDbObjectIterator |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setPosition(AcDbEntity *pEnt) (defined in AcDbObjectIterator) | AcDbObjectIterator |
setPosition(AcDbObjectId pObj) (defined in AcDbObjectIterator) | AcDbObjectIterator |
start(bool atEnd=false) (defined in AcDbObjectIterator) | AcDbObjectIterator |
step(bool backwards=false, bool skipDeleted=true) (defined in AcDbObjectIterator) | AcDbObjectIterator |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbObjectIterator() (defined in AcDbObjectIterator) | AcDbObjectIterator | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbObjectPointer< T_OBJECT > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbObjectPointer< T_OBJECT > Class Template Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectPointer< T_OBJECT >:

Public Member Functions

AcDbObjectPointer (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | open (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
- Public Member Functions inherited from AcDbObjectPointerBase< T_OBJECT >
Acad::ErrorStatus | acquire (T_OBJECT *&pObjToAcquire)
Acad::ErrorStatus | close ()
Acad::ErrorStatus | create ()
const T_OBJECT * | object () const
T_OBJECT * | object ()
Acad::ErrorStatus | openStatus () const
operator const T_OBJECT * () const
operator T_OBJECT * ()
const T_OBJECT * | operator-> () const
T_OBJECT * | operator-> ()
Acad::ErrorStatus | release (T_OBJECT *&pReleasedObj)

Additional Inherited Members

- Protected Member Functions inherited from AcDbObjectPointerBase< T_OBJECT >
AcDbObjectPointerBase (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased)
- Protected Attributes inherited from AcDbObjectPointerBase< T_OBJECT >
T_OBJECT * | m_ptr
Acad::ErrorStatus | m_status
The documentation for this class was generated from the following file:
  • dbobjptr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectPointer< T_OBJECT > Member List

This is the complete list of members for AcDbObjectPointer< T_OBJECT >, including all inherited members.

AcDbObjectPointer() (defined in AcDbObjectPointer< T_OBJECT >) | AcDbObjectPointer< T_OBJECT > | inline
AcDbObjectPointer(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbObjectPointer< T_OBJECT >) | AcDbObjectPointer< T_OBJECT > | inline
AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
AcDbObjectPointerBase(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlineprotected
acquire(T_OBJECT *&pObjToAcquire) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
close() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
create() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
m_ptr (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
m_status (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
object() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
object() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
open(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbObjectPointer< T_OBJECT >) | AcDbObjectPointer< T_OBJECT > | inline
openStatus() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator const T_OBJECT *() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator T_OBJECT *() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
release(T_OBJECT *&pReleasedObj) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
~AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlinevirtual


ZRX API Reference: AcDbObjectPointerBase< T_OBJECT > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AcDbObjectPointerBase< T_OBJECT > Class Template Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectPointerBase< T_OBJECT >:

Public Member Functions

Acad::ErrorStatus | acquire (T_OBJECT *&pObjToAcquire)
Acad::ErrorStatus | close ()
Acad::ErrorStatus | create ()
const T_OBJECT * | object () const
T_OBJECT * | object ()
Acad::ErrorStatus | open (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | openStatus () const
operator const T_OBJECT * () const
operator T_OBJECT * ()
const T_OBJECT * | operator-> () const
T_OBJECT * | operator-> ()
Acad::ErrorStatus | release (T_OBJECT *&pReleasedObj)

Protected Member Functions

AcDbObjectPointerBase (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased)

Protected Attributes

T_OBJECT * | m_ptr
Acad::ErrorStatus | m_status
The documentation for this class was generated from the following file:
  • dbobjptr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectPointerBase< T_OBJECT > Member List

This is the complete list of members for AcDbObjectPointerBase< T_OBJECT >, including all inherited members.

AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
AcDbObjectPointerBase(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlineprotected
acquire(T_OBJECT *&pObjToAcquire) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
close() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
create() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
m_ptr (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
m_status (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
object() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
object() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
open(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
openStatus() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator const T_OBJECT *() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator T_OBJECT *() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
release(T_OBJECT *&pReleasedObj) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
~AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlinevirtual


ZRX API Reference: AcDbObjectReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbObjectReactor Class Reference
AcDb Classes
+ Inheritance diagram for AcDbObjectReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbObjectReactor)
virtual void | cancelled (const AcDbObject *dbObj)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
virtual void | goodbye (const AcDbObject *dbObj)
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
virtual void | openedForModify (const AcDbObject *dbObj)
virtual void | reappended (const AcDbObject *dbObj)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual void | unappended (const AcDbObject *dbObj)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectReactor Member List

This is the complete list of members for AcDbObjectReactor, including all inherited members.

AcDbObjectReactor() (defined in AcDbObjectReactor) | AcDbObjectReactor | protected
ACRX_DECLARE_MEMBERS(AcDbObjectReactor) (defined in AcDbObjectReactor) | AcDbObjectReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cancelled(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
modified(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
openedForModify(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbOle2Frame Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbOle2Frame Class Reference
AcDb Classes
+ Inheritance diagram for AcDbOle2Frame:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbOle2Frame)
Adesk::Boolean | autoOutputQuality () const
virtual bool | castShadows () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Adesk::Boolean | getLinkName (ACHAR *pszName, int nNameSize) const
virtual Adesk::Boolean | getLinkPath (ACHAR *pszPath, int nPathSize) const
virtual void | getLocation (AcGePoint3d &point3d) const
virtual void * | getOleObject (void) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=0) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&ent) const
virtual int | getType (void) const
virtual void | getUserType (ACHAR *pszName, int nNameSize) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual void | list () const
Adesk::Boolean | lockAspect () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Adesk::UInt8 | outputQuality () const
virtual void | position (CRectangle3d &rect3d) const
virtual void | position (RECT &rect) const
virtual bool | receiveShadows () const
double | rotation () const
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
double | scaleHeight () const
double | scaleWidth () const
void | setAutoOutputQuality (Adesk::UInt8)
virtual void | setCastShadows (bool newVal)
void | setLocation (const AcGePoint3d &point3d)
Acad::ErrorStatus | setLockAspect (const Adesk::Boolean bLockAspect)
virtual void | setOleObject (const void *pItem)
virtual void | setOutputQuality (Adesk::UInt8)
virtual void | setPosition (const CRectangle3d &rect3d)
virtual void | setPosition (const RECT &rect)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setRotation (const double rotation)
Acad::ErrorStatus | setScaleHeight (const double scaleHeight)
Acad::ErrorStatus | setScaleWidth (const double scaleWidth)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setWcsHeight (const double wcsHeight)
Acad::ErrorStatus | setWcsWidth (const double wcsWidth)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
double | wcsHeight () const
double | wcsWidth () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *)
- Public Member Functions inherited from AcDbOleFrame
ACDB_DECLARE_MEMBERS (AcDbOleFrame)
- Public Member Functions inherited from AcDbFrame
ACDB_DECLARE_MEMBERS (AcDbFrame)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbole.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbOle2Frame Member List

This is the complete list of members for AcDbOle2Frame, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbOle2Frame) (defined in AcDbOle2Frame) | AcDbOle2Frame |
ACDB_DECLARE_MEMBERS(AcDbOleFrame) (defined in AcDbOleFrame) | AcDbOleFrame |
ACDB_DECLARE_MEMBERS(AcDbFrame) (defined in AcDbFrame) | AcDbFrame |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbFrame() (defined in AcDbFrame) | AcDbFrame | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbOle2Frame() (defined in AcDbOle2Frame) | AcDbOle2Frame |
AcDbOleFrame() (defined in AcDbOleFrame) | AcDbOleFrame |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
autoOutputQuality() const (defined in AcDbOle2Frame) | AcDbOle2Frame |
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getLinkName(ACHAR *pszName, int nNameSize) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getLinkPath(ACHAR *pszPath, int nPathSize) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getLocation(AcGePoint3d &point3d) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOleObject(void) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=0) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&ent) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getType(void) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
getUserType(ACHAR *pszName, int nNameSize) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
lockAspect() const (defined in AcDbOle2Frame) | AcDbOle2Frame |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
outputQuality() const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position(CRectangle3d &rect3d) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
position(RECT &rect) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const (defined in AcDbOle2Frame) | AcDbOle2Frame |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
scaleHeight() const (defined in AcDbOle2Frame) | AcDbOle2Frame |
scaleWidth() const (defined in AcDbOle2Frame) | AcDbOle2Frame |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setAutoOutputQuality(Adesk::UInt8) (defined in AcDbOle2Frame) | AcDbOle2Frame |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLocation(const AcGePoint3d &point3d) (defined in AcDbOle2Frame) | AcDbOle2Frame |
setLockAspect(const Adesk::Boolean bLockAspect) (defined in AcDbOle2Frame) | AcDbOle2Frame |
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOleObject(const void *pItem) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
setOutputQuality(Adesk::UInt8) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const CRectangle3d &rect3d) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
setPosition(const RECT &rect) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
setRotation(const double rotation) (defined in AcDbOle2Frame) | AcDbOle2Frame |
setScaleHeight(const double scaleHeight) (defined in AcDbOle2Frame) | AcDbOle2Frame |
setScaleWidth(const double scaleWidth) (defined in AcDbOle2Frame) | AcDbOle2Frame |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
setWcsHeight(const double wcsHeight) (defined in AcDbOle2Frame) | AcDbOle2Frame |
setWcsWidth(const double wcsWidth) (defined in AcDbOle2Frame) | AcDbOle2Frame |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbOle2Frame) | AcDbOle2Frame |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbOle2Frame) | AcDbOle2Frame |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
wcsHeight() const (defined in AcDbOle2Frame) | AcDbOle2Frame |
wcsWidth() const (defined in AcDbOle2Frame) | AcDbOle2Frame |
worldDraw(AcGiWorldDraw *) (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbFrame() (defined in AcDbFrame) | AcDbFrame | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbOle2Frame() (defined in AcDbOle2Frame) | AcDbOle2Frame | virtual
~AcDbOleFrame() (defined in AcDbOleFrame) | AcDbOleFrame | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbOleFrame Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbOleFrame Class Reference
AcDb Classes
+ Inheritance diagram for AcDbOleFrame:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbOleFrame)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual void * | getOleObject (void) const
virtual void | setOleObject (const void *pItem)
virtual void | viewportDraw (AcGiViewportDraw *mode)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *)
- Public Member Functions inherited from AcDbFrame
ACDB_DECLARE_MEMBERS (AcDbFrame)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbole.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbOleFrame Member List

This is the complete list of members for AcDbOleFrame, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbOleFrame) (defined in AcDbOleFrame) | AcDbOleFrame |
ACDB_DECLARE_MEMBERS(AcDbFrame) (defined in AcDbFrame) | AcDbFrame |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbFrame() (defined in AcDbFrame) | AcDbFrame | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbOleFrame() (defined in AcDbOleFrame) | AcDbOleFrame |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbOleFrame) | AcDbOleFrame | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbOleFrame) | AcDbOleFrame | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbOleFrame) | AcDbOleFrame | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbOleFrame) | AcDbOleFrame | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbOleFrame) | AcDbOleFrame | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOleObject(void) const (defined in AcDbOleFrame) | AcDbOleFrame | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOleObject(const void *pItem) (defined in AcDbOleFrame) | AcDbOleFrame | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbOleFrame) | AcDbOleFrame | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *) (defined in AcDbOleFrame) | AcDbOleFrame | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbFrame() (defined in AcDbFrame) | AcDbFrame | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbOleFrame() (defined in AcDbOleFrame) | AcDbOleFrame | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbOrdinateDimension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbOrdinateDimension Class Reference
AcDb Classes
+ Inheritance diagram for AcDbOrdinateDimension:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbOrdinateDimension)
AcDbOrdinateDimension (Adesk::Boolean useXAxis, const AcGePoint3d &definingPoint, const AcGePoint3d &leaderEndPoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull)
AcGePoint3d | definingPoint () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Adesk::Boolean | isUsingXAxis () const
Adesk::Boolean | isUsingYAxis () const
AcGePoint3d | leaderEndPoint () const
AcGePoint3d | origin () const
Acad::ErrorStatus | setDefiningPoint (const AcGePoint3d &)
Acad::ErrorStatus | setLeaderEndPoint (const AcGePoint3d &)
Acad::ErrorStatus | setOrigin (const AcGePoint3d &)
Acad::ErrorStatus | useXAxis ()
Acad::ErrorStatus | useYAxis ()
- Public Member Functions inherited from AcDbDimension
ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbDimension
enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbOrdinateDimension Member List

This is the complete list of members for AcDbOrdinateDimension, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbOrdinateDimension) (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbOrdinateDimension() (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
AcDbOrdinateDimension(Adesk::Boolean useXAxis, const AcGePoint3d &definingPoint, const AcGePoint3d &leaderEndPoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull) (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
definingPoint() const (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isUsingXAxis() const (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
isUsingYAxis() const (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
leaderEndPoint() const (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
origin() const (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDefiningPoint(const AcGePoint3d &) (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLeaderEndPoint(const AcGePoint3d &) (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOrigin(const AcGePoint3d &) (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
useXAxis() (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
useYAxis() (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbOrdinateDimension() (defined in AcDbOrdinateDimension) | AcDbOrdinateDimension |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbOsnapPointRef Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcDbOsnapPointRef Class Reference
AcDb Classes
+ Inheritance diagram for AcDbOsnapPointRef:

Public Member Functions

AcDbOsnapPointRef (const AcGePoint3d &refPt)
AcDbOsnapPointRef (AcDbPointRef::OsnapType osnapType, const AcDbFullSubentPath *objPath, const AcDbFullSubentPath *intObjPath=NULL, const AcGePoint3d *refPt=NULL, AcDbPointRef *lastPtRef=NULL)
AcDbOsnapPointRef (const AcDbOsnapPointRef &src)
ACRX_DECLARE_MEMBERS (AcDbOsnapPointRef)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer, AcDbDatabase *pDb)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer, AcDbDatabase *pDb) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer, AcDbDatabase *pDb)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer, AcDbDatabase *pDb) const
virtual Acad::ErrorStatus | evalPoint (AcGePoint3d &pt)
virtual Acad::ErrorStatus | getEntities (AcDbFullSubentPathArray &ents, bool getLastPtRef=true) const
Acad::ErrorStatus | getIdPath (AcDbFullSubentPath &idPath) const
Acad::ErrorStatus | getIntIdPath (AcDbFullSubentPath &intIdPath) const
Acad::ErrorStatus | getXrefHandles (AcDbHandleArrayPtRef &xrefHandles) const
Acad::ErrorStatus | getXrefIntHandles (AcDbHandleArrayPtRef &xrefHandles) const
virtual bool | isGeomErased () const
virtual bool | isXrefObj (AcDbObjectIdArray &ids1, AcDbObjectIdArray &ids2, bool isMainObj=true) const
AcDbPointRef * | lastPointRef () const
double | nearPointParam () const
virtual AcDbPointRef & | operator= (const AcDbPointRef &src)
AcDbOsnapPointRef & | operator= (const AcDbOsnapPointRef &src)
AcDbPointRef::OsnapType | osnapType () const
AcGePoint3d | point () const
Acad::ErrorStatus | setIdPath (const AcDbFullSubentPath &idPath)
Acad::ErrorStatus | setIntIdPath (const AcDbFullSubentPath &intIdPath)
Acad::ErrorStatus | setLastPointRef (AcDbPointRef *ptRef)
Acad::ErrorStatus | setNearPointParam (double newVal)
Acad::ErrorStatus | setOsnapType (AcDbPointRef::OsnapType osnType)
Acad::ErrorStatus | setPoint (const AcGePoint3d &pt)
Acad::ErrorStatus | setXrefHandles (const AcDbHandleArrayPtRef &xrefHandles)
Acad::ErrorStatus | setXrefIntHandles (const AcDbHandleArrayPtRef &xrefHandles)
virtual void | updateDueToMirror (bool inMirror=false)
virtual Acad::ErrorStatus | updateSubentPath (AcDbIdMapping &idMap)
virtual Acad::ErrorStatus | updateXrefSubentPath ()
- Public Member Functions inherited from AcDbPointRef
ACRX_DECLARE_MEMBERS (AcDbPointRef)
virtual Acad::ErrorStatus | deepClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

Acad::ErrorStatus | evalPointGuts (AcDbPointRef::OsnapType ospType, const AcGePoint3d &pickPt, const AcGePoint3d &lastPt, AcGePoint3d &pt)
double | findNearPointParam (const AcGePoint3d &pt) const
bool | getEllipseParams (double &sP, double &eP) const
Acad::ErrorStatus | getIntPoints (const AcDbEntity *pEnt, const AcDbEntity *pIntEnt, AcDb::Intersect intType, AcGePoint3dArray &intPts, int gsMarker1=0, int gsMarker2=0) const
bool | isTransSpatial (bool isMainObj=true) const
AcGePoint3d | nearPoint ()
Acad::ErrorStatus | updateSubentPathGuts (AcDbFullSubentPath &path, AcDbIdMapping &idMap)

Additional Inherited Members

- Public Types inherited from AcDbPointRef
enum OsnapType {
kOsnapNone = 0, kOsnapEnd = 1, kOsnapMid = 2, kOsnapCen = 3,
kOsnapNode = 4, kOsnapQuad = 5, kOsnapInt = 6, kOsnapIns = 7,
kOsnapPerp = 8, kOsnapTan = 9, kOsnapNear = 10, kOsnapApint = 11,
kOsnapStart = 13
}
- Static Public Member Functions inherited from AcDbPointRef
static bool | calcTransform (const AcDbObjectIdArray &ids, AcGeMatrix3d &A_Ecs2Wcs)
static Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer, AcDbDatabase *pDb, AcDbPointRef *&pPointRef)
static Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer, AcDbDatabase *pDb, const AcDbPointRef *pPointRef)
static Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer, AcDbDatabase *pDb, AcDbPointRef *&pPointRef)
static Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer, AcDbDatabase *pDb, const AcDbPointRef *pPointRef)
static AcGeMatrix3d | mswcsToPswcs (const AcDbViewport *pVPort)
static AcDbEntity * | subentPtr (const AcDbFullSubentPath &objPath, bool &isCloned, bool &reverseArc, bool &isStandAloneArc)
static AcGeMatrix3d | wcsToDcsMatrix (const AcDbViewport *pVPort)

Member Function Documentation

virtual void AcDbOsnapPointRef::updateDueToMirror ( bool inMirror = false )
virtual
Warning
Not implemented!

Implements AcDbPointRef.

virtual Acad::ErrorStatus AcDbOsnapPointRef::updateSubentPath ( AcDbIdMapping & idMap )
virtual
Warning
Not implemented!

Implements AcDbPointRef.

Acad::ErrorStatus AcDbOsnapPointRef::updateSubentPathGuts | ( | AcDbFullSubentPath & | path,
 |  | AcDbIdMapping & | idMap
 | ) |  |
protected
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbdimptref.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbOsnapPointRef Member List

This is the complete list of members for AcDbOsnapPointRef, including all inherited members.

AcDbOsnapPointRef() (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
AcDbOsnapPointRef(const AcGePoint3d &refPt) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
AcDbOsnapPointRef(AcDbPointRef::OsnapType osnapType, const AcDbFullSubentPath *objPath, const AcDbFullSubentPath *intObjPath=NULL, const AcGePoint3d *refPt=NULL, AcDbPointRef *lastPtRef=NULL) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
AcDbOsnapPointRef(const AcDbOsnapPointRef &src) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
ACRX_DECLARE_MEMBERS(AcDbOsnapPointRef) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
ACRX_DECLARE_MEMBERS(AcDbPointRef) (defined in AcDbPointRef) | AcDbPointRef |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
calcTransform(const AcDbObjectIdArray &ids, AcGeMatrix3d &A_Ecs2Wcs) (defined in AcDbPointRef) | AcDbPointRef | static
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
deepClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const (defined in AcDbPointRef) | AcDbPointRef | inlinevirtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgInFields(AcDbDwgFiler *filer, AcDbDatabase *pDb) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
dwgInFields(AcDbDwgFiler *filer, AcDbDatabase *pDb, AcDbPointRef *&pPointRef) (defined in AcDbPointRef) | AcDbPointRef | static
dwgOutFields(AcDbDwgFiler *filer, AcDbDatabase *pDb) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
dwgOutFields(AcDbDwgFiler *filer, AcDbDatabase *pDb, const AcDbPointRef *pPointRef) (defined in AcDbPointRef) | AcDbPointRef | static
dxfInFields(AcDbDxfFiler *filer, AcDbDatabase *pDb) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
dxfInFields(AcDbDxfFiler *filer, AcDbDatabase *pDb, AcDbPointRef *&pPointRef) (defined in AcDbPointRef) | AcDbPointRef | static
dxfOutFields(AcDbDxfFiler *filer, AcDbDatabase *pDb) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
dxfOutFields(AcDbDxfFiler *filer, AcDbDatabase *pDb, const AcDbPointRef *pPointRef) (defined in AcDbPointRef) | AcDbPointRef | static
evalPoint(AcGePoint3d &pt) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
evalPointGuts(AcDbPointRef::OsnapType ospType, const AcGePoint3d &pickPt, const AcGePoint3d &lastPt, AcGePoint3d &pt) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | protected
findNearPointParam(const AcGePoint3d &pt) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | protected
getEllipseParams(double &sP, double &eP) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | protected
getEntities(AcDbFullSubentPathArray &ents, bool getLastPtRef=true) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
getIdPath(AcDbFullSubentPath &idPath) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
getIntIdPath(AcDbFullSubentPath &intIdPath) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
getIntPoints(const AcDbEntity *pEnt, const AcDbEntity *pIntEnt, AcDb::Intersect intType, AcGePoint3dArray &intPts, int gsMarker1=0, int gsMarker2=0) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | protected
getXrefHandles(AcDbHandleArrayPtRef &xrefHandles) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
getXrefIntHandles(AcDbHandleArrayPtRef &xrefHandles) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isGeomErased() const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isTransSpatial(bool isMainObj=true) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | protected
isXrefObj(AcDbObjectIdArray &ids1, AcDbObjectIdArray &ids2, bool isMainObj=true) const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
kOsnapApint enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapCen enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapEnd enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapIns enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapInt enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapMid enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapNear enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapNode enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapNone enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapPerp enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapQuad enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapStart enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapTan enum value (defined in AcDbPointRef) | AcDbPointRef |
lastPointRef() const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
mswcsToPswcs(const AcDbViewport *pVPort) (defined in AcDbPointRef) | AcDbPointRef | static
nearPoint() (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | protected
nearPointParam() const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
operator=(const AcDbPointRef &src) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
operator=(const AcDbOsnapPointRef &src) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
osnapType() const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
OsnapType enum name (defined in AcDbPointRef) | AcDbPointRef |
point() const (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setIdPath(const AcDbFullSubentPath &idPath) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
setIntIdPath(const AcDbFullSubentPath &intIdPath) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
setLastPointRef(AcDbPointRef *ptRef) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
setNearPointParam(double newVal) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
setOsnapType(AcDbPointRef::OsnapType osnType) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
setPoint(const AcGePoint3d &pt) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
setXrefHandles(const AcDbHandleArrayPtRef &xrefHandles) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
setXrefIntHandles(const AcDbHandleArrayPtRef &xrefHandles) (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef |
subentPtr(const AcDbFullSubentPath &objPath, bool &isCloned, bool &reverseArc, bool &isStandAloneArc) (defined in AcDbPointRef) | AcDbPointRef | static
subErase(Adesk::Boolean erasing) (defined in AcDbPointRef) | AcDbPointRef | inlinevirtual
updateDueToMirror(bool inMirror=false) | AcDbOsnapPointRef | virtual
updateSubentPath(AcDbIdMapping &idMap) | AcDbOsnapPointRef | virtual
updateSubentPathGuts(AcDbFullSubentPath &path, AcDbIdMapping &idMap) | AcDbOsnapPointRef | protected
updateXrefSubentPath() (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const (defined in AcDbPointRef) | AcDbPointRef | inlinevirtual
wcsToDcsMatrix(const AcDbViewport *pVPort) (defined in AcDbPointRef) | AcDbPointRef | static
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbOsnapPointRef() (defined in AcDbOsnapPointRef) | AcDbOsnapPointRef | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPaperOrientationPE Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbPaperOrientationPE Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPaperOrientationPE:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbPaperOrientationPE)
virtual Acad::ErrorStatus | applyPaperOrientationTransform (AcDbObject *pObject, const AcDbViewport *pVport) const
virtual bool | paperOrientation (AcDbObject *pObject) const =0
virtual Acad::ErrorStatus | setPaperOrientation (AcDbObject *pObject, const bool bPaperOrientation)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbAnnotativeObjectPE.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPaperOrientationPE Member List

This is the complete list of members for AcDbPaperOrientationPE, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbPaperOrientationPE) (defined in AcDbPaperOrientationPE) | AcDbPaperOrientationPE |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
applyPaperOrientationTransform(AcDbObject *pObject, const AcDbViewport *pVport) const (defined in AcDbPaperOrientationPE) | AcDbPaperOrientationPE | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
paperOrientation(AcDbObject *pObject) const =0 (defined in AcDbPaperOrientationPE) | AcDbPaperOrientationPE | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setPaperOrientation(AcDbObject *pObject, const bool bPaperOrientation)=0 (defined in AcDbPaperOrientationPE) | AcDbPaperOrientationPE | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPasswordedFile Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcDbPasswordedFile Class Reference
AcDb Classes

Public Member Functions

Acad::ErrorStatus open (const wchar_t *wszPassword, AcDbHostApplicationServices::PasswordOptions options)

Protected Member Functions

virtual const ACHAR * | getFullPath ()=0
virtual Acad::ErrorStatus | tryPassword (const wchar_t *wzPassword)=0
The documentation for this class was generated from the following file:
  • dbapserv.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPasswordedFile Member List

This is the complete list of members for AcDbPasswordedFile, including all inherited members.

getFullPath()=0 (defined in AcDbPasswordedFile) | AcDbPasswordedFile | protectedpure virtual
open(const wchar_t *wszPassword, AcDbHostApplicationServices::PasswordOptions options) (defined in AcDbPasswordedFile) | AcDbPasswordedFile |
tryPassword(const wchar_t *wzPassword)=0 (defined in AcDbPasswordedFile) | AcDbPasswordedFile | protectedpure virtual


ZRX API Reference: AcDbPlaceHolder Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbPlaceHolder Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPlaceHolder:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbPlaceHolder)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbplhldr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPlaceHolder Member List

This is the complete list of members for AcDbPlaceHolder, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbPlaceHolder) (defined in AcDbPlaceHolder) | AcDbPlaceHolder |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPlaceHolder() (defined in AcDbPlaceHolder) | AcDbPlaceHolder | inline
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbPlaceHolder) | AcDbPlaceHolder | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbPlaceHolder) | AcDbPlaceHolder | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const (defined in AcDbPlaceHolder) | AcDbPlaceHolder | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPlaceHolder() (defined in AcDbPlaceHolder) | AcDbPlaceHolder | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPlaneSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbPlaneSurface Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPlaneSurface:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbPlaneSurface)
AcDbPlaneSurface ()
virtual Acad::ErrorStatus | createFromRegion (AcDbRegion *pRegion)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual bool | isDependent () const
virtual void | list () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
- Public Member Functions inherited from AcDbSurface
ACDB_DECLARE_MEMBERS (AcDbSurface)
AcDbSurface ()
virtual void * | body () const
virtual Acad::ErrorStatus | convertToRegion (AcArray< AcDbEntity * > &regions)
virtual Acad::ErrorStatus | getArea (double &area) const
virtual AcDbSubentId | internalSubentId (void *ent) const
virtual void * | internalSubentPtr (const AcDbSubentId &id) const
virtual Acad::ErrorStatus | setBody (const void *modelerBody)
virtual Acad::ErrorStatus | setUIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | setVIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | thicken (double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const
virtual Adesk::UInt16 | uIsolineDensity () const
virtual Adesk::UInt16 | vIsolineDensity () const
virtual | ~AcDbSurface ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcDbSurface
static Acad::ErrorStatus | createFrom (const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface)

Constructor & Destructor Documentation

AcDbPlaneSurface::AcDbPlaneSurface ( )
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbPlaneSurface::createFromRegion ( AcDbRegion * pRegion )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbPlaneSurface::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbPlaneSurface::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbPlaneSurface::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbPlaneSurface::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbPlaneSurface::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbPlaneSurface::getGripPoints | ( | AcGePoint3dArray & | gripPoints,
 |  | AcDbIntArray & | osnapModes,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbPlaneSurface::getGripPoints | ( | AcDbGripDataPtrArray & | grips,
 |  | const double | curViewUnitSize,
 |  | const int | gripSize,
 |  | const AcGeVector3d & | curViewDir,
 |  | const int | bitflags
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual bool AcDbPlaneSurface::isDependent ( ) const
virtual
Warning
Not implemented!
virtual void AcDbPlaneSurface::list ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbPlaneSurface::moveGripPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbPlaneSurface::moveStretchPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

The documentation for this class was generated from the following file:
  • dbplanesurf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPlaneSurface Member List

This is the complete list of members for AcDbPlaneSurface, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbPlaneSurface) (defined in AcDbPlaneSurface) | AcDbPlaneSurface |
ACDB_DECLARE_MEMBERS(AcDbSurface) (defined in AcDbSurface) | AcDbSurface |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPlaneSurface() | AcDbPlaneSurface |
AcDbSurface() | AcDbSurface |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
body() const | AcDbSurface | virtual
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToRegion(AcArray< AcDbEntity * > &regions) | AcDbSurface | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createFrom(const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface) | AcDbSurface | static
createFromRegion(AcDbRegion *pRegion) | AcDbPlaneSurface | virtual
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbPlaneSurface | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbPlaneSurface | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbPlaneSurface | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbPlaneSurface | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &area) const | AcDbSurface | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbPlaneSurface | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const | AcDbPlaneSurface | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const | AcDbPlaneSurface | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
internalSubentId(void *ent) const | AcDbSurface | virtual
internalSubentPtr(const AcDbSubentId &id) const | AcDbSurface | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const | AcDbPlaneSurface | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const | AcDbPlaneSurface | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbPlaneSurface | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbPlaneSurface | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBody(const void *modelerBody) | AcDbSurface | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thicken(double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const | AcDbSurface | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
uIsolineDensity() const | AcDbSurface | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
vIsolineDensity() const | AcDbSurface | virtual
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPlaneSurface() (defined in AcDbPlaneSurface) | AcDbPlaneSurface | virtual
~AcDbSurface() | AcDbSurface | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPlotSettings Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbPlotSettings Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPlotSettings:

Public Types

enum | PlotPaperUnits { kInches, kMillimeters, kPixels }
enum | PlotRotation { k0degrees, k90degrees, k180degrees, k270degrees }
enum PlotType {
kDisplay, kExtents, kLimits, kView,
kWindow, kLayout
}
enum ShadePlotResLevel {
kDraft, kPreview, kNormal, kPresentation,
kMaximum, kCustom
}
enum ShadePlotType {
kAsDisplayed = 0, kWireframe = 1, kHidden = 2, kRendered = 3,
kVisualStyle = 4, kRenderPreset = 5
}
enum StdScaleType {
kScaleToFit, k1_128in_1ft, k1_64in_1ft, k1_32in_1ft,
k1_16in_1ft, k3_32in_1ft, k1_8in_1ft, k3_16in_1ft,
k1_4in_1ft, k3_8in_1ft, k1_2in_1ft, k3_4in_1ft,
k1in_1ft, k3in_1ft, k6in_1ft, k1ft_1ft,
k1_1, k1_2, k1_4, k1_5,
k1_8, k1_10, k1_16, k1_20,
k1_30, k1_40, k1_50, k1_100,
k2_1, k4_1, k8_1, k10_1,
k100_1, k1000_1, k1and1_2in_1ft
}

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbPlotSettings)
AcDbPlotSettings (bool ModelType)
Acad::ErrorStatus | addToPlotSettingsDict (AcDbDatabase *towhichDb)
Acad::ErrorStatus | copyFrom (AcDbPlotSettings *fromPlotSettings)
Adesk::Boolean | drawViewportsFirst () const
Acad::ErrorStatus | getCanonicalMediaName (const ACHAR *&mediaName) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getCurrentStyleSheet (const ACHAR *&styleSheetName) const
Acad::ErrorStatus | getCustomPrintScale (double &numerator, double &denominator) const
Acad::ErrorStatus | getPlotCfgName (const ACHAR *&plotCfgName) const
Acad::ErrorStatus | getPlotOrigin (double &x, double &y) const
Acad::ErrorStatus | getPlotPaperMargins (double &printableXmin, double &printableYmin, double &printableXmax, double &printableYmax) const
Acad::ErrorStatus | getPlotPaperSize (double &paperWidth, double &paperHeight) const
Acad::ErrorStatus | getPlotSettingsName (const ACHAR *&plotSettingsName) const
Acad::ErrorStatus | getPlotSettingsName (ACHAR *&plotSettingsName) const
Acad::ErrorStatus | getPlotViewName (const ACHAR *&viewName) const
Acad::ErrorStatus | getPlotWindowArea (double &xmin, double &ymin, double &xmax, double &ymax) const
Acad::ErrorStatus | getStdScale (double &scale) const
Adesk::Boolean | modelType () const
bool | plotAsRaster () const
Adesk::Boolean | plotCentered () const
Adesk::Boolean | plotHidden () const
AcDbPlotSettings::PlotPaperUnits | plotPaperUnits () const
Adesk::Boolean | plotPlotStyles () const
AcDbPlotSettings::PlotRotation | plotRotation () const
AcDbPlotSettings::PlotType | plotType () const
Adesk::Boolean | plotViewportBorders () const
bool | plotWireframe () const
Adesk::Boolean | printLineweights () const
Adesk::Boolean | scaleLineweights () const
void | setDrawViewportsFirst (Adesk::Boolean drawViewportsFirst)
void | setPlotHidden (Adesk::Boolean plotHidden)
void | setPlotPlotStyles (Adesk::Boolean plotPlotStyles)
Acad::ErrorStatus | setPlotSettingsName (const ACHAR *plotSettingsName)
void | setPlotViewportBorders (Adesk::Boolean plotViewportBorders)
void | setPrintLineweights (Adesk::Boolean printLineweights)
void | setScaleLineweights (Adesk::Boolean scaleLineweights)
Acad::ErrorStatus | setShadePlot (AcDbPlotSettings::ShadePlotType shadePlot)
Acad::ErrorStatus | setShadePlot (const AcDbPlotSettings::ShadePlotType type, const AcDbObjectId shadePlotId)
Acad::ErrorStatus | setShadePlotCustomDPI (Adesk::Int16 val)
Acad::ErrorStatus | setShadePlotResLevel (AcDbPlotSettings::ShadePlotResLevel resLevel)
void | setShowPlotStyles (Adesk::Boolean showPlotStyles)
AcDbPlotSettings::ShadePlotType | shadePlot () const
Adesk::Int16 | shadePlotCustomDPI () const
AcDbObjectId | shadePlotId () const
AcDbPlotSettings::ShadePlotResLevel | shadePlotResLevel () const
Adesk::Boolean | showPlotStyles () const
AcDbPlotSettings::StdScaleType | stdScaleType () const
Adesk::Boolean | useStandardScale () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

bool AcDbPlotSettings::plotAsRaster ( ) const
Warning
Not implemented!
bool AcDbPlotSettings::plotWireframe ( ) const
Warning
Not implemented!
AcDbObjectId AcDbPlotSettings::shadePlotId ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbPlotSettings.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPlotSettings Member List

This is the complete list of members for AcDbPlotSettings, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbPlotSettings) (defined in AcDbPlotSettings) | AcDbPlotSettings |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPlotSettings() (defined in AcDbPlotSettings) | AcDbPlotSettings |
AcDbPlotSettings(bool ModelType) (defined in AcDbPlotSettings) | AcDbPlotSettings |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addToPlotSettingsDict(AcDbDatabase *towhichDb) (defined in AcDbPlotSettings) | AcDbPlotSettings |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(AcDbPlotSettings *fromPlotSettings) (defined in AcDbPlotSettings) | AcDbPlotSettings |
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
drawViewportsFirst() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getCanonicalMediaName(const ACHAR *&mediaName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getClassID(CLSID *pClsid) const (defined in AcDbPlotSettings) | AcDbPlotSettings | virtual
getCurrentStyleSheet(const ACHAR *&styleSheetName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getCustomPrintScale(double &numerator, double &denominator) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getPlotCfgName(const ACHAR *&plotCfgName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotOrigin(double &x, double &y) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotPaperMargins(double &printableXmin, double &printableYmin, double &printableXmax, double &printableYmax) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotPaperSize(double &paperWidth, double &paperHeight) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotSettingsName(const ACHAR *&plotSettingsName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotSettingsName(ACHAR *&plotSettingsName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotViewName(const ACHAR *&viewName) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getPlotWindowArea(double &xmin, double &ymin, double &xmax, double &ymax) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
getStdScale(double &scale) const (defined in AcDbPlotSettings) | AcDbPlotSettings |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
k0degrees enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1000_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k100_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k10_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k180degrees enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_10 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_100 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_128in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_16 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_16in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_2 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_20 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_2in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_30 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_32in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_4 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_40 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_4in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_5 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_50 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_64in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_8 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1_8in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1and1_2in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1ft_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k1in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k270degrees enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k2_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3_16in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3_32in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3_4in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3_8in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k3in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k4_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k6in_1ft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k8_1 enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
k90degrees enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kAsDisplayed enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kCustom enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kDisplay enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDraft enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kExtents enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHidden enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kInches enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kLayout enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kLimits enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kMaximum enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kMillimeters enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kNormal enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kPixels enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kPresentation enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kPreview enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kRendered enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kRenderPreset enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kScaleToFit enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kView enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kVisualStyle enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kWindow enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
kWireframe enum value (defined in AcDbPlotSettings) | AcDbPlotSettings |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modelType() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotAsRaster() const | AcDbPlotSettings |
plotCentered() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotHidden() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotPaperUnits() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
PlotPaperUnits enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotPlotStyles() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
PlotRotation enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotRotation() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotType() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
PlotType enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotViewportBorders() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
plotWireframe() const | AcDbPlotSettings |
printLineweights() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
scaleLineweights() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDrawViewportsFirst(Adesk::Boolean drawViewportsFirst) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotHidden(Adesk::Boolean plotHidden) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setPlotPlotStyles(Adesk::Boolean plotPlotStyles) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setPlotSettingsName(const ACHAR *plotSettingsName) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setPlotViewportBorders(Adesk::Boolean plotViewportBorders) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setPrintLineweights(Adesk::Boolean printLineweights) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setScaleLineweights(Adesk::Boolean scaleLineweights) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShadePlot(AcDbPlotSettings::ShadePlotType shadePlot) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShadePlot(const AcDbPlotSettings::ShadePlotType type, const AcDbObjectId shadePlotId) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShadePlotCustomDPI(Adesk::Int16 val) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShadePlotResLevel(AcDbPlotSettings::ShadePlotResLevel resLevel) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setShowPlotStyles(Adesk::Boolean showPlotStyles) (defined in AcDbPlotSettings) | AcDbPlotSettings |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shadePlot() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
shadePlotCustomDPI() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
shadePlotId() const | AcDbPlotSettings |
ShadePlotResLevel enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
shadePlotResLevel() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
ShadePlotType enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
showPlotStyles() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
StdScaleType enum name (defined in AcDbPlotSettings) | AcDbPlotSettings |
stdScaleType() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useStandardScale() const (defined in AcDbPlotSettings) | AcDbPlotSettings |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPlotSettings() (defined in AcDbPlotSettings) | AcDbPlotSettings | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPlotSettingsValidator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbPlotSettingsValidator Class Reference
AcDb Classes

Public Member Functions

virtual Acad::ErrorStatus | canonicalMediaNameList (AcDbPlotSettings *pPlotSet, AcArray< const ACHAR * > &mediaList)=0
virtual Acad::ErrorStatus | getLocaleMediaName (AcDbPlotSettings *pPlotSet, const ACHAR *canonicalName, const ACHAR *&localeName)=0
virtual Acad::ErrorStatus | getLocaleMediaName (AcDbPlotSettings *pPlotSet, int index, const ACHAR *&localeName)=0
virtual Acad::ErrorStatus | plotDeviceList (AcArray< const ACHAR * > &deviceList)=0
virtual Acad::ErrorStatus | plotStyleSheetList (AcArray< const ACHAR * > &styleList)=0
virtual void | refreshLists (AcDbPlotSettings *pPlotSet)=0
virtual Acad::ErrorStatus | setCanonicalMediaName (AcDbPlotSettings *pPlotSet, const ACHAR *mediaName)=0
virtual Acad::ErrorStatus | setClosestMediaName (AcDbPlotSettings *pPlotSet, const double paperWidth, const double paperHeight, const PlotPaperUnits units, Adesk::Boolean matchPrintableArea)=0
virtual Acad::ErrorStatus | setCurrentStyleSheet (AcDbPlotSettings *pPlotSet, const ACHAR *styleSheetName)=0
virtual Acad::ErrorStatus | setCustomPrintScale (AcDbPlotSettings *pPlotSet, const double numerator, const double denominator)=0
virtual Acad::ErrorStatus | setDefaultPlotConfig (AcDbPlotSettings *pPlotSet)=0
virtual Acad::ErrorStatus | setPlotCentered (AcDbPlotSettings *pPlotSet, Adesk::Boolean isCentered)=0
virtual Acad::ErrorStatus | setPlotCfgName (AcDbPlotSettings *pPlotSet, const ACHAR *plotDeviceName, const ACHAR *mediaName=NULL)=0
virtual Acad::ErrorStatus | setPlotOrigin (AcDbPlotSettings *pPlotSet, const double xCoordinate, const double yCoordinate)=0
virtual Acad::ErrorStatus | setPlotPaperUnits (AcDbPlotSettings *pPlotSet, const PlotPaperUnits units)=0
virtual Acad::ErrorStatus | setPlotRotation (AcDbPlotSettings *pPlotSet, const PlotRotation rotationType)=0
virtual Acad::ErrorStatus | setPlotType (AcDbPlotSettings *pPlotSet, const PlotType plotAreaType)=0
virtual Acad::ErrorStatus | setPlotViewName (AcDbPlotSettings *pPlotSet, const ACHAR *viewName)=0
virtual Acad::ErrorStatus | setPlotWindowArea (AcDbPlotSettings *pPlotSet, const double xmin, const double ymin, const double xmax, const double ymax)=0
virtual Acad::ErrorStatus | setStdScale (AcDbPlotSettings *pPlotSet, const double standardScale)=0
virtual Acad::ErrorStatus | setStdScaleType (AcDbPlotSettings *pPlotSet, const StdScaleType scaleType)=0
virtual Acad::ErrorStatus | setUseStandardScale (AcDbPlotSettings *pPlotSet, Adesk::Boolean useStandard)=0
virtual void | setZoomToPaperOnUpdate (AcDbPlotSettings *pPlotSet, Adesk::Boolean doZoom)=0
The documentation for this class was generated from the following file:
  • dbplotsetval.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPlotSettingsValidator Member List

This is the complete list of members for AcDbPlotSettingsValidator, including all inherited members.

canonicalMediaNameList(AcDbPlotSettings *pPlotSet, AcArray< const ACHAR * > &mediaList)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
getLocaleMediaName(AcDbPlotSettings *pPlotSet, const ACHAR *canonicalName, const ACHAR *&localeName)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
getLocaleMediaName(AcDbPlotSettings *pPlotSet, int index, const ACHAR *&localeName)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
plotDeviceList(AcArray< const ACHAR * > &deviceList)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
plotStyleSheetList(AcArray< const ACHAR * > &styleList)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
refreshLists(AcDbPlotSettings *pPlotSet)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setCanonicalMediaName(AcDbPlotSettings *pPlotSet, const ACHAR *mediaName)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setClosestMediaName(AcDbPlotSettings *pPlotSet, const double paperWidth, const double paperHeight, const PlotPaperUnits units, Adesk::Boolean matchPrintableArea)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setCurrentStyleSheet(AcDbPlotSettings *pPlotSet, const ACHAR *styleSheetName)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setCustomPrintScale(AcDbPlotSettings *pPlotSet, const double numerator, const double denominator)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setDefaultPlotConfig(AcDbPlotSettings *pPlotSet)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setPlotCentered(AcDbPlotSettings *pPlotSet, Adesk::Boolean isCentered)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setPlotCfgName(AcDbPlotSettings *pPlotSet, const ACHAR *plotDeviceName, const ACHAR *mediaName=NULL)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setPlotOrigin(AcDbPlotSettings *pPlotSet, const double xCoordinate, const double yCoordinate)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setPlotPaperUnits(AcDbPlotSettings *pPlotSet, const PlotPaperUnits units)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setPlotRotation(AcDbPlotSettings *pPlotSet, const PlotRotation rotationType)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setPlotType(AcDbPlotSettings *pPlotSet, const PlotType plotAreaType)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setPlotViewName(AcDbPlotSettings *pPlotSet, const ACHAR *viewName)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setPlotWindowArea(AcDbPlotSettings *pPlotSet, const double xmin, const double ymin, const double xmax, const double ymax)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setStdScale(AcDbPlotSettings *pPlotSet, const double standardScale)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setStdScaleType(AcDbPlotSettings *pPlotSet, const StdScaleType scaleType)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setUseStandardScale(AcDbPlotSettings *pPlotSet, Adesk::Boolean useStandard)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual
setZoomToPaperOnUpdate(AcDbPlotSettings *pPlotSet, Adesk::Boolean doZoom)=0 (defined in AcDbPlotSettingsValidator) | AcDbPlotSettingsValidator | pure virtual


ZRX API Reference: AcDbPoint Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbPoint Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPoint:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbPoint)
AcDbPoint (const AcGePoint3d &position)
virtual bool | castShadows () const
double | ecsRotation () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
virtual Adesk::Boolean | isPlanar () const
AcGeVector3d | normal () const
AcGePoint3d | position () const
virtual bool | receiveShadows () const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setEcsRotation (double)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setPosition (const AcGePoint3d &)
Acad::ErrorStatus | setThickness (double)
double | thickness () const
virtual void | viewportDraw (AcGiViewportDraw *pVpDraw)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPoint Member List

This is the complete list of members for AcDbPoint, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbPoint) (defined in AcDbPoint) | AcDbPoint |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPoint() (defined in AcDbPoint) | AcDbPoint |
AcDbPoint(const AcGePoint3d &position) (defined in AcDbPoint) | AcDbPoint |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbPoint) | AcDbPoint | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
ecsRotation() const (defined in AcDbPoint) | AcDbPoint |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbPoint) | AcDbPoint | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbPoint) | AcDbPoint | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbPoint) | AcDbPoint | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbPoint) | AcDbPoint |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbPoint) | AcDbPoint |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbPoint) | AcDbPoint | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbPoint) | AcDbPoint | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setEcsRotation(double) (defined in AcDbPoint) | AcDbPoint |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbPoint) | AcDbPoint |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbPoint) | AcDbPoint |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setThickness(double) (defined in AcDbPoint) | AcDbPoint |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thickness() const (defined in AcDbPoint) | AcDbPoint |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVpDraw) (defined in AcDbPoint) | AcDbPoint | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbPoint) | AcDbPoint | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPoint() (defined in AcDbPoint) | AcDbPoint |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPointPath Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbPointPath Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPointPath:

Public Member Functions

AcDbPointPath ()
ACRX_DECLARE_MEMBERS (AcDbPointPath)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Acad::ErrorStatus | getGeometry (AcGeCurve3d *&pCurveGeometry) const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setGeometry (const AcGePoint3d &pt)
virtual | ~AcDbPointPath ()
- Public Member Functions inherited from AcDbNamedPath
ACRX_DECLARE_MEMBERS (AcDbNamedPath)
virtual | ~AcDbNamedPath ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbPointPath

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcDbNamedPath
AcDbNamedPath (AcDbImpNamedPath *pImp)
AcDbImpNamedPath * | imp () const

Constructor & Destructor Documentation

AcDbPointPath::AcDbPointPath ( )
Warning
Not implemented!
virtual AcDbPointPath::~AcDbPointPath ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbPointPath::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbPointPath::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbPointPath::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbPointPath::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbPointPath::getGeometry ( AcGeCurve3d *& pCurveGeometry ) const
virtual
Warning
Not implemented!

Implements AcDbNamedPath.

virtual Adesk::UInt32 AcDbPointPath::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Acad::ErrorStatus AcDbPointPath::setGeometry ( const AcGePoint3d & pt )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbNamedPath.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPointPath Member List

This is the complete list of members for AcDbPointPath, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbNamedPath(AcDbImpNamedPath *pImp) | AcDbNamedPath | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPointPath (defined in AcDbPointPath) | AcDbPointPath | friend
AcDbPointPath() | AcDbPointPath |
ACRX_DECLARE_MEMBERS(AcDbPointPath) (defined in AcDbPointPath) | AcDbPointPath |
ACRX_DECLARE_MEMBERS(AcDbNamedPath) (defined in AcDbNamedPath) | AcDbNamedPath |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbPointPath | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbPointPath | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbPointPath | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbPointPath | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeometry(AcGeCurve3d *&pCurveGeometry) const | AcDbPointPath | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imp() const | AcDbNamedPath | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbPointPath | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGeometry(const AcGePoint3d &pt) | AcDbPointPath |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbNamedPath() | AcDbNamedPath | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPointPath() | AcDbPointPath | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPointRef Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcDbPointRef Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPointRef:

Public Types

enum OsnapType {
kOsnapNone = 0, kOsnapEnd = 1, kOsnapMid = 2, kOsnapCen = 3,
kOsnapNode = 4, kOsnapQuad = 5, kOsnapInt = 6, kOsnapIns = 7,
kOsnapPerp = 8, kOsnapTan = 9, kOsnapNear = 10, kOsnapApint = 11,
kOsnapStart = 13
}

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbPointRef)
virtual Acad::ErrorStatus | deepClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer, AcDbDatabase *pDb)=0
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer, AcDbDatabase *pDb) const =0
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer, AcDbDatabase *pDb)=0
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer, AcDbDatabase *pDb) const =0
virtual Acad::ErrorStatus | evalPoint (AcGePoint3d &pnt_wcs)=0
virtual Acad::ErrorStatus | getEntities (AcDbFullSubentPathArray &ents, bool getLastPtRef=true) const =0
virtual bool | isGeomErased () const =0
virtual bool | isXrefObj (AcDbObjectIdArray &ids1, AcDbObjectIdArray &ids2, bool isMainObj=true) const =0
virtual AcDbPointRef & | operator= (const AcDbPointRef &src)
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual void | updateDueToMirror (bool inMirror=false)=0
virtual Acad::ErrorStatus | updateSubentPath (AcDbIdMapping &idMap)=0
virtual Acad::ErrorStatus | updateXrefSubentPath ()=0
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static bool | calcTransform (const AcDbObjectIdArray &ids, AcGeMatrix3d &A_Ecs2Wcs)
static Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer, AcDbDatabase *pDb, AcDbPointRef *&pPointRef)
static Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer, AcDbDatabase *pDb, const AcDbPointRef *pPointRef)
static Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer, AcDbDatabase *pDb, AcDbPointRef *&pPointRef)
static Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer, AcDbDatabase *pDb, const AcDbPointRef *pPointRef)
static AcGeMatrix3d | mswcsToPswcs (const AcDbViewport *pVPort)
static AcDbEntity * | subentPtr (const AcDbFullSubentPath &objPath, bool &isCloned, bool &reverseArc, bool &isStandAloneArc)
static AcGeMatrix3d | wcsToDcsMatrix (const AcDbViewport *pVPort)
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbdimptref.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPointRef Member List

This is the complete list of members for AcDbPointRef, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbPointRef) (defined in AcDbPointRef) | AcDbPointRef |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
calcTransform(const AcDbObjectIdArray &ids, AcGeMatrix3d &A_Ecs2Wcs) (defined in AcDbPointRef) | AcDbPointRef | static
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
deepClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const (defined in AcDbPointRef) | AcDbPointRef | inlinevirtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgInFields(AcDbDwgFiler *filer, AcDbDatabase *pDb)=0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
dwgInFields(AcDbDwgFiler *filer, AcDbDatabase *pDb, AcDbPointRef *&pPointRef) (defined in AcDbPointRef) | AcDbPointRef | static
dwgOutFields(AcDbDwgFiler *filer, AcDbDatabase *pDb) const =0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
dwgOutFields(AcDbDwgFiler *filer, AcDbDatabase *pDb, const AcDbPointRef *pPointRef) (defined in AcDbPointRef) | AcDbPointRef | static
dxfInFields(AcDbDxfFiler *filer, AcDbDatabase *pDb)=0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
dxfInFields(AcDbDxfFiler *filer, AcDbDatabase *pDb, AcDbPointRef *&pPointRef) (defined in AcDbPointRef) | AcDbPointRef | static
dxfOutFields(AcDbDxfFiler *filer, AcDbDatabase *pDb) const =0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
dxfOutFields(AcDbDxfFiler *filer, AcDbDatabase *pDb, const AcDbPointRef *pPointRef) (defined in AcDbPointRef) | AcDbPointRef | static
evalPoint(AcGePoint3d &pnt_wcs)=0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
getEntities(AcDbFullSubentPathArray &ents, bool getLastPtRef=true) const =0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isGeomErased() const =0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isXrefObj(AcDbObjectIdArray &ids1, AcDbObjectIdArray &ids2, bool isMainObj=true) const =0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
kOsnapApint enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapCen enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapEnd enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapIns enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapInt enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapMid enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapNear enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapNode enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapNone enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapPerp enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapQuad enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapStart enum value (defined in AcDbPointRef) | AcDbPointRef |
kOsnapTan enum value (defined in AcDbPointRef) | AcDbPointRef |
mswcsToPswcs(const AcDbViewport *pVPort) (defined in AcDbPointRef) | AcDbPointRef | static
operator=(const AcDbPointRef &src) (defined in AcDbPointRef) | AcDbPointRef | virtual
OsnapType enum name (defined in AcDbPointRef) | AcDbPointRef |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
subentPtr(const AcDbFullSubentPath &objPath, bool &isCloned, bool &reverseArc, bool &isStandAloneArc) (defined in AcDbPointRef) | AcDbPointRef | static
subErase(Adesk::Boolean erasing) (defined in AcDbPointRef) | AcDbPointRef | inlinevirtual
updateDueToMirror(bool inMirror=false)=0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
updateSubentPath(AcDbIdMapping &idMap)=0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
updateXrefSubentPath()=0 (defined in AcDbPointRef) | AcDbPointRef | pure virtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=Adesk::kTrue) const (defined in AcDbPointRef) | AcDbPointRef | inlinevirtual
wcsToDcsMatrix(const AcDbViewport *pVPort) (defined in AcDbPointRef) | AcDbPointRef | static
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPolyFaceMesh Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbPolyFaceMesh Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPolyFaceMesh:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbPolyFaceMesh)
Acad::ErrorStatus | appendFaceRecord (AcDbFaceRecord *)
Acad::ErrorStatus | appendFaceRecord (AcDbObjectId &, AcDbFaceRecord *)
Acad::ErrorStatus | appendVertex (AcDbPolyFaceMeshVertex *)
Acad::ErrorStatus | appendVertex (AcDbObjectId &objId, AcDbPolyFaceMeshVertex *)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Adesk::Int16 | numFaces () const
Adesk::Int16 | numVertices () const
Acad::ErrorStatus | openSequenceEnd (AcDbSequenceEnd *&, AcDb::OpenMode)
Acad::ErrorStatus | openVertex (AcDbVertex *&, AcDbObjectId subObjId, AcDb::OpenMode, bool openErasedOne=false)
AcDbObjectIterator * | vertexIterator () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPolyFaceMesh Member List

This is the complete list of members for AcDbPolyFaceMesh, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbPolyFaceMesh) (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPolyFaceMesh() (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
appendFaceRecord(AcDbFaceRecord *) (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
appendFaceRecord(AcDbObjectId &, AcDbFaceRecord *) (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
appendVertex(AcDbPolyFaceMeshVertex *) (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
appendVertex(AcDbObjectId &objId, AcDbPolyFaceMeshVertex *) (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
numFaces() const (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
numVertices() const (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
openSequenceEnd(AcDbSequenceEnd *&, AcDb::OpenMode) (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
openVertex(AcDbVertex *&, AcDbObjectId subObjId, AcDb::OpenMode, bool openErasedOne=false) (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
vertexIterator() const (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPolyFaceMesh() (defined in AcDbPolyFaceMesh) | AcDbPolyFaceMesh |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPolyFaceMeshVertex Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbPolyFaceMeshVertex Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPolyFaceMeshVertex:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbPolyFaceMeshVertex)
AcDbPolyFaceMeshVertex (const AcGePoint3d &position)
AcGePoint3d | position () const
Acad::ErrorStatus | setPosition (const AcGePoint3d &)
- Public Member Functions inherited from AcDbVertex
ACDB_DECLARE_MEMBERS (AcDbVertex)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPolyFaceMeshVertex Member List

This is the complete list of members for AcDbPolyFaceMeshVertex, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbPolyFaceMeshVertex) (defined in AcDbPolyFaceMeshVertex) | AcDbPolyFaceMeshVertex |
ACDB_DECLARE_MEMBERS(AcDbVertex) (defined in AcDbVertex) | AcDbVertex |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPolyFaceMeshVertex() (defined in AcDbPolyFaceMeshVertex) | AcDbPolyFaceMeshVertex |
AcDbPolyFaceMeshVertex(const AcGePoint3d &position) (defined in AcDbPolyFaceMeshVertex) | AcDbPolyFaceMeshVertex |
AcDbVertex() (defined in AcDbVertex) | AcDbVertex |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbPolyFaceMeshVertex) | AcDbPolyFaceMeshVertex |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbPolyFaceMeshVertex) | AcDbPolyFaceMeshVertex |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPolyFaceMeshVertex() (defined in AcDbPolyFaceMeshVertex) | AcDbPolyFaceMeshVertex |
~AcDbVertex() (defined in AcDbVertex) | AcDbVertex | inline
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPolygonMesh Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbPolygonMesh Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPolygonMesh:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbPolygonMesh)
AcDbPolygonMesh (AcDb::PolyMeshType pType, Adesk::Int16 mSize, Adesk::Int16 nSize, const AcGePoint3dArray &vertices, Adesk::Boolean mClosed=Adesk::kTrue, Adesk::Boolean nClosed=Adesk::kTrue)
Acad::ErrorStatus | appendVertex (AcDbPolygonMeshVertex *)
Acad::ErrorStatus | appendVertex (AcDbObjectId &objId, AcDbPolygonMeshVertex *)
Acad::ErrorStatus | convertToPolyMeshType (AcDb::PolyMeshType newVal)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Adesk::Boolean | isMClosed () const
Adesk::Boolean | isNClosed () const
Acad::ErrorStatus | makeMClosed ()
Acad::ErrorStatus | makeMOpen ()
Acad::ErrorStatus | makeNClosed ()
Acad::ErrorStatus | makeNOpen ()
Adesk::Int16 | mSize () const
Adesk::Int16 | mSurfaceDensity () const
Adesk::Int16 | nSize () const
Adesk::Int16 | nSurfaceDensity () const
Acad::ErrorStatus | openSequenceEnd (AcDbSequenceEnd *&, AcDb::OpenMode)
Acad::ErrorStatus | openVertex (AcDbPolygonMeshVertex *&, AcDbObjectId vertId, AcDb::OpenMode, bool openErasedOne=false)
AcDb::PolyMeshType | polyMeshType () const
Acad::ErrorStatus | setMSize (Adesk::Int16)
Acad::ErrorStatus | setMSurfaceDensity (Adesk::Int16)
Acad::ErrorStatus | setNSize (Adesk::Int16)
Acad::ErrorStatus | setNSurfaceDensity (Adesk::Int16)
Acad::ErrorStatus | setPolyMeshType (AcDb::PolyMeshType)
Acad::ErrorStatus | straighten ()
Acad::ErrorStatus | surfaceFit ()
Acad::ErrorStatus | surfaceFit (AcDb::PolyMeshType surfType, Adesk::Int16 surfu, Adesk::Int16 surfv)
AcDbObjectIterator * | vertexIterator () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPolygonMesh Member List

This is the complete list of members for AcDbPolygonMesh, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbPolygonMesh) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPolygonMesh() (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
AcDbPolygonMesh(AcDb::PolyMeshType pType, Adesk::Int16 mSize, Adesk::Int16 nSize, const AcGePoint3dArray &vertices, Adesk::Boolean mClosed=Adesk::kTrue, Adesk::Boolean nClosed=Adesk::kTrue) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
appendVertex(AcDbPolygonMeshVertex *) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
appendVertex(AcDbObjectId &objId, AcDbPolygonMeshVertex *) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToPolyMeshType(AcDb::PolyMeshType newVal) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbPolygonMesh) | AcDbPolygonMesh | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isMClosed() const (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNClosed() const (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
makeMClosed() (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
makeMOpen() (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
makeNClosed() (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
makeNOpen() (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
mSize() const (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
mSurfaceDensity() const (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
nSize() const (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
nSurfaceDensity() const (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
openSequenceEnd(AcDbSequenceEnd *&, AcDb::OpenMode) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
openVertex(AcDbPolygonMeshVertex *&, AcDbObjectId vertId, AcDb::OpenMode, bool openErasedOne=false) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
polyMeshType() const (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMSize(Adesk::Int16) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
setMSurfaceDensity(Adesk::Int16) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
setNSize(Adesk::Int16) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
setNSurfaceDensity(Adesk::Int16) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPolyMeshType(AcDb::PolyMeshType) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
straighten() (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
surfaceFit() (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
surfaceFit(AcDb::PolyMeshType surfType, Adesk::Int16 surfu, Adesk::Int16 surfv) (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
vertexIterator() const (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPolygonMesh() (defined in AcDbPolygonMesh) | AcDbPolygonMesh |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPolygonMeshVertex Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbPolygonMeshVertex Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPolygonMeshVertex:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbPolygonMeshVertex)
AcDbPolygonMeshVertex (const AcGePoint3d &position)
AcGePoint3d | position () const
Acad::ErrorStatus | setPosition (const AcGePoint3d &)
AcDb::Vertex3dType | vertexType () const
- Public Member Functions inherited from AcDbVertex
ACDB_DECLARE_MEMBERS (AcDbVertex)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPolygonMeshVertex Member List

This is the complete list of members for AcDbPolygonMeshVertex, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbPolygonMeshVertex) (defined in AcDbPolygonMeshVertex) | AcDbPolygonMeshVertex |
ACDB_DECLARE_MEMBERS(AcDbVertex) (defined in AcDbVertex) | AcDbVertex |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPolygonMeshVertex() (defined in AcDbPolygonMeshVertex) | AcDbPolygonMeshVertex |
AcDbPolygonMeshVertex(const AcGePoint3d &position) (defined in AcDbPolygonMeshVertex) | AcDbPolygonMeshVertex |
AcDbVertex() (defined in AcDbVertex) | AcDbVertex |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbPolygonMeshVertex) | AcDbPolygonMeshVertex |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbPolygonMeshVertex) | AcDbPolygonMeshVertex |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
vertexType() const (defined in AcDbPolygonMeshVertex) | AcDbPolygonMeshVertex |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPolygonMeshVertex() (defined in AcDbPolygonMeshVertex) | AcDbPolygonMeshVertex |
~AcDbVertex() (defined in AcDbVertex) | AcDbVertex | inline
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbPolyline Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbPolyline Class Reference
AcDb Classes
+ Inheritance diagram for AcDbPolyline:

Public Types

enum SegType {
kLine, kArc, kCoincident, kPoint,
kEmpty
}

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbPolyline)
AcDbPolyline (unsigned int num_verts)
Acad::ErrorStatus | addVertexAt (unsigned int index, const AcGePoint2d &pt, double bulge=0., double startWidth=-1., double endWidth=-1)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *filer, AcRxClass *classobj)
virtual bool | castShadows () const
Acad::ErrorStatus | convertFrom (AcDbEntity *&pPline, Adesk::Boolean transferId=Adesk::kTrue)
Acad::ErrorStatus | convertTo (AcDb2dPolyline *&pPline, Adesk::Boolean transferId=Adesk::kTrue) const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
double | elevation () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
Acad::ErrorStatus | getArcSegAt (unsigned int index, AcGeCircArc2d &arc) const
Acad::ErrorStatus | getArcSegAt (unsigned int index, AcGeCircArc3d &arc) const
virtual Acad::ErrorStatus | getArea (double &area) const
Acad::ErrorStatus | getBulgeAt (unsigned int index, double &bulge) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPoint, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPoint, const AcGeVector3d &normal, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
Acad::ErrorStatus | getConstantWidth (double &) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &point, double &dist) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getEndParam (double &endParam) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &endPoint) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &point, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapMasks, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
Acad::ErrorStatus | getLineSegAt (unsigned int index, AcGeLineSeg2d &ln) const
Acad::ErrorStatus | getLineSegAt (unsigned int index, AcGeLineSeg3d &ln) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &plane, AcDbCurve *&projectedCurve) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &point, double &param) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &plane, AcDb::Planarity &type) const
Acad::ErrorStatus | getPointAt (unsigned int, AcGePoint3d &pt) const
Acad::ErrorStatus | getPointAt (unsigned int index, AcGePoint2d &pt) const
virtual Acad::ErrorStatus | getPointAtDist (double dist, AcGePoint3d &point) const
virtual Acad::ErrorStatus | getPointAtParam (double param, AcGePoint3d &point) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &plane, const AcGeVector3d &projDir, AcDbCurve *&projectedCurve) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secondDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &point, AcGeVector3d &secondDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &parameters, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &startParam) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &startPoint) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numIds, AcDbFullSubentPath *&subentIds, int numInserts, AcDbObjectId *entAndInsertStack) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&ent) const
Acad::ErrorStatus | getWidthsAt (unsigned int index, double &startWidth, double &endWidth) const
virtual void | gripStatus (const AcDb::GripStat status)
Adesk::Boolean | hasBulges () const
Adesk::Boolean | hasPlinegen () const
Adesk::Boolean | hasWidth () const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
Adesk::Boolean | isClosed () const
Adesk::Boolean | isOnlyLines () const
virtual Adesk::Boolean | isPeriodic () const
virtual Adesk::Boolean | isPlanar () const
Acad::ErrorStatus | maximizeMemory ()
Acad::ErrorStatus | minimizeMemory ()
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
AcGeVector3d | normal () const
unsigned int | numVerts () const
virtual Adesk::Boolean | onSegAt (unsigned int index, const AcGePoint2d &pt2d, double &param) const
virtual bool | receiveShadows () const
Acad::ErrorStatus | removeVertexAt (unsigned int index)
void | reset (Adesk::Boolean reuse, unsigned int numVerts)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
SegType | segType (unsigned int index) const
Acad::ErrorStatus | setBulgeAt (unsigned int index, double bulge)
void | setClosed (Adesk::Boolean)
Acad::ErrorStatus | setConstantWidth (double)
void | setElevation (double)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
void | setPlinegen (Adesk::Boolean)
Acad::ErrorStatus | setPointAt (unsigned int index, const AcGePoint2d &pt)
Acad::ErrorStatus | setThickness (double)
Acad::ErrorStatus | setWidthsAt (unsigned int index, double startWidth, double endWidth)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
double | thickness () const
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual void | viewportDraw (AcGiViewportDraw *mode)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbpl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbPolyline Member List

This is the complete list of members for AcDbPolyline, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbPolyline) (defined in AcDbPolyline) | AcDbPolyline |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbPolyline() (defined in AcDbPolyline) | AcDbPolyline |
AcDbPolyline(unsigned int num_verts) (defined in AcDbPolyline) | AcDbPolyline |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
addVertexAt(unsigned int index, const AcGePoint2d &pt, double bulge=0., double startWidth=-1., double endWidth=-1) (defined in AcDbPolyline) | AcDbPolyline |
applyPartialUndo(AcDbDwgFiler *filer, AcRxClass *classobj) (defined in AcDbPolyline) | AcDbPolyline | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbPolyline) | AcDbPolyline | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertFrom(AcDbEntity *&pPline, Adesk::Boolean transferId=Adesk::kTrue) (defined in AcDbPolyline) | AcDbPolyline |
convertTo(AcDb2dPolyline *&pPline, Adesk::Boolean transferId=Adesk::kTrue) const (defined in AcDbPolyline) | AcDbPolyline |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbPolyline) | AcDbPolyline | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbPolyline) | AcDbPolyline | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbPolyline) | AcDbPolyline | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbPolyline) | AcDbPolyline | virtual
elevation() const (defined in AcDbPolyline) | AcDbPolyline |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbPolyline) | AcDbPolyline | virtual
extend(double newParam) (defined in AcDbPolyline) | AcDbPolyline | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbPolyline) | AcDbPolyline | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArcSegAt(unsigned int index, AcGeCircArc2d &arc) const (defined in AcDbPolyline) | AcDbPolyline |
getArcSegAt(unsigned int index, AcGeCircArc3d &arc) const (defined in AcDbPolyline) | AcDbPolyline |
getArea(double &area) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBulgeAt(unsigned int index, double &bulge) const (defined in AcDbPolyline) | AcDbPolyline |
getClassID(CLSID *pClsid) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getClosestPointTo(const AcGePoint3d &givenPoint, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getClosestPointTo(const AcGePoint3d &givenPoint, const AcGeVector3d &normal, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getConstantWidth(double &) const (defined in AcDbPolyline) | AcDbPolyline |
getDistAtParam(double param, double &dist) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getDistAtPoint(const AcGePoint3d &point, double &dist) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getEndParam(double &endParam) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getEndPoint(AcGePoint3d &endPoint) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getFirstDeriv(const AcGePoint3d &point, AcGeVector3d &firstDeriv) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapMasks, AcDbIntArray &geomIds) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getLineSegAt(unsigned int index, AcGeLineSeg2d &ln) const (defined in AcDbPolyline) | AcDbPolyline |
getLineSegAt(unsigned int index, AcGeLineSeg3d &ln) const (defined in AcDbPolyline) | AcDbPolyline |
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOrthoProjectedCurve(const AcGePlane &plane, AcDbCurve *&projectedCurve) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getParamAtPoint(const AcGePoint3d &point, double &param) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getPlane(AcGePlane &plane, AcDb::Planarity &type) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAt(unsigned int, AcGePoint3d &pt) const (defined in AcDbPolyline) | AcDbPolyline |
getPointAt(unsigned int index, AcGePoint2d &pt) const (defined in AcDbPolyline) | AcDbPolyline |
getPointAtDist(double dist, AcGePoint3d &point) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getPointAtParam(double param, AcGePoint3d &point) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getProjectedCurve(const AcGePlane &plane, const AcGeVector3d &projDir, AcDbCurve *&projectedCurve) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getSecondDeriv(double param, AcGeVector3d &secondDeriv) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getSecondDeriv(const AcGePoint3d &point, AcGeVector3d &secondDeriv) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbPolyline) | AcDbPolyline | inlinevirtual
getSplitCurves(const AcGeDoubleArray &parameters, AcDbVoidPtrArray &curveSegments) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getStartParam(double &startParam) const (defined in AcDbPolyline) | AcDbPolyline | inlinevirtual
getStartPoint(AcGePoint3d &startPoint) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numIds, AcDbFullSubentPath *&subentIds, int numInserts, AcDbObjectId *entAndInsertStack) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&ent) const (defined in AcDbPolyline) | AcDbPolyline | virtual
getWidthsAt(unsigned int index, double &startWidth, double &endWidth) const (defined in AcDbPolyline) | AcDbPolyline |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbPolyline) | AcDbPolyline | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasBulges() const (defined in AcDbPolyline) | AcDbPolyline |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasPlinegen() const (defined in AcDbPolyline) | AcDbPolyline |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hasWidth() const (defined in AcDbPolyline) | AcDbPolyline |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbPolyline) | AcDbPolyline | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbPolyline) | AcDbPolyline | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbPolyline) | AcDbPolyline | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isOnlyLines() const (defined in AcDbPolyline) | AcDbPolyline |
isPeriodic() const (defined in AcDbPolyline) | AcDbPolyline | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbPolyline) | AcDbPolyline | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kArc enum value (defined in AcDbPolyline) | AcDbPolyline |
kCoincident enum value (defined in AcDbPolyline) | AcDbPolyline |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kEmpty enum value (defined in AcDbPolyline) | AcDbPolyline |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kLine enum value (defined in AcDbPolyline) | AcDbPolyline |
kPoint enum value (defined in AcDbPolyline) | AcDbPolyline |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
maximizeMemory() (defined in AcDbPolyline) | AcDbPolyline |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
minimizeMemory() (defined in AcDbPolyline) | AcDbPolyline |
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbPolyline) | AcDbPolyline | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbPolyline) | AcDbPolyline | virtual
normal() const (defined in AcDbPolyline) | AcDbPolyline |
numVerts() const (defined in AcDbPolyline) | AcDbPolyline |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
onSegAt(unsigned int index, const AcGePoint2d &pt2d, double &param) const (defined in AcDbPolyline) | AcDbPolyline | virtual
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbPolyline) | AcDbPolyline | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeVertexAt(unsigned int index) (defined in AcDbPolyline) | AcDbPolyline |
reset(Adesk::Boolean reuse, unsigned int numVerts) (defined in AcDbPolyline) | AcDbPolyline |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbPolyline) | AcDbPolyline | virtual
SegType enum name (defined in AcDbPolyline) | AcDbPolyline |
segType(unsigned int index) const (defined in AcDbPolyline) | AcDbPolyline |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBulgeAt(unsigned int index, double bulge) (defined in AcDbPolyline) | AcDbPolyline |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setClosed(Adesk::Boolean) (defined in AcDbPolyline) | AcDbPolyline |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setConstantWidth(double) (defined in AcDbPolyline) | AcDbPolyline |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setElevation(double) (defined in AcDbPolyline) | AcDbPolyline |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbPolyline) | AcDbPolyline |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlinegen(Adesk::Boolean) (defined in AcDbPolyline) | AcDbPolyline |
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPointAt(unsigned int index, const AcGePoint2d &pt) (defined in AcDbPolyline) | AcDbPolyline |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setThickness(double) (defined in AcDbPolyline) | AcDbPolyline |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWidthsAt(unsigned int index, double startWidth, double endWidth) (defined in AcDbPolyline) | AcDbPolyline |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbPolyline) | AcDbPolyline | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thickness() const (defined in AcDbPolyline) | AcDbPolyline |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbPolyline) | AcDbPolyline | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbPolyline) | AcDbPolyline | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbPolyline) | AcDbPolyline | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbPolyline() (defined in AcDbPolyline) | AcDbPolyline | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbProxyEntity Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbProxyEntity Class Reference
AcDb Classes
+ Inheritance diagram for AcDbProxyEntity:

Public Types

enum {
kNoOperation = 0, kEraseAllowed = 0x1, kTransformAllowed = 0x2, kColorChangeAllowed = 0x4,
kLayerChangeAllowed = 0x8, kLinetypeChangeAllowed = 0x10, kLinetypeScaleChangeAllowed = 0x20, kVisibilityChangeAllowed = 0x40,
kCloningAllowed = 0x80, kLineWeightChangeAllowed = 0x100, kPlotStyleNameChangeAllowed = 0x200, kAllButCloningAllowed = 0x37F,
kAllAllowedBits = 0xBFF, kDisableProxyWarning = 0x400, kMaterialChangeAllowed = 0x800
}
enum | GraphicsMetafileType { kNoMetafile = 0, kBoundingBox = 1, kFullGraphics = 2 }
- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbProxyEntity)
virtual const ACHAR * | applicationDescription () const =0
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getReferences (AcDbObjectIdArray &, AcDbIntArray &) const =0
virtual
AcDbProxyEntity::GraphicsMetafileType 		graphicsMetafileType () const =0
virtual const ACHAR * | originalClassName () const =0
virtual const ACHAR * | originalDxfName () const =0
virtual int | proxyFlags () const =0
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

virtual Acad::ErrorStatus AcDbProxyEntity::getGeomExtents ( AcDbExtents & extents ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

The documentation for this class was generated from the following file:
  • dbproxy.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbProxyEntity Member List

This is the complete list of members for AcDbProxyEntity, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbProxyEntity) (defined in AcDbProxyEntity) | AcDbProxyEntity |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applicationDescription() const =0 (defined in AcDbProxyEntity) | AcDbProxyEntity | pure virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbProxyEntity) | AcDbProxyEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const | AcDbProxyEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getReferences(AcDbObjectIdArray &, AcDbIntArray &) const =0 (defined in AcDbProxyEntity) | AcDbProxyEntity | pure virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
GraphicsMetafileType enum name (defined in AcDbProxyEntity) | AcDbProxyEntity |
graphicsMetafileType() const =0 (defined in AcDbProxyEntity) | AcDbProxyEntity | pure virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAllAllowedBits enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kAllButCloningAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kBoundingBox enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kCloningAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kColorChangeAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kDisableProxyWarning enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kEraseAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullGraphics enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kLayerChangeAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kLinetypeChangeAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kLinetypeScaleChangeAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kLineWeightChangeAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kMaterialChangeAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kNoMetafile enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kNoOperation enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kPlotStyleNameChangeAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kTransformAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kVisibilityChangeAllowed enum value (defined in AcDbProxyEntity) | AcDbProxyEntity |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
originalClassName() const =0 (defined in AcDbProxyEntity) | AcDbProxyEntity | pure virtual
originalDxfName() const =0 (defined in AcDbProxyEntity) | AcDbProxyEntity | pure virtual
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
proxyFlags() const =0 (defined in AcDbProxyEntity) | AcDbProxyEntity | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbProxyEntity) | AcDbProxyEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbProxyEntity() (defined in AcDbProxyEntity) | AcDbProxyEntity | inlinevirtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbProxyObject Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbProxyObject Class Reference
AcDb Classes
+ Inheritance diagram for AcDbProxyObject:

Public Types

enum {
kNoOperation = 0, kEraseAllowed = 0x01, kCloningAllowed = 0x80, kAllButCloningAllowed = 0x01,
kAllAllowedBits = 0x81, kMergeIgnore = 0, kMergeReplace = 0x100, kMergeMangleName = 0x200,
kDisableProxyWarning = 0x400
}

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbProxyObject)
virtual const ACHAR * | applicationDescription () const =0
virtual Acad::ErrorStatus | getReferences (AcDbObjectIdArray &, AcDbIntArray &) const =0
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const =0
virtual const ACHAR * | originalClassName () const =0
virtual const ACHAR * | originalDxfName () const =0
virtual int | proxyFlags () const =0
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbproxy.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbProxyObject Member List

This is the complete list of members for AcDbProxyObject, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcDbProxyObject) (defined in AcDbProxyObject) | AcDbProxyObject |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applicationDescription() const =0 (defined in AcDbProxyObject) | AcDbProxyObject | pure virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getReferences(AcDbObjectIdArray &, AcDbIntArray &) const =0 (defined in AcDbProxyObject) | AcDbProxyObject | pure virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAllAllowedBits enum value (defined in AcDbProxyObject) | AcDbProxyObject |
kAllButCloningAllowed enum value (defined in AcDbProxyObject) | AcDbProxyObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kCloningAllowed enum value (defined in AcDbProxyObject) | AcDbProxyObject |
kDisableProxyWarning enum value (defined in AcDbProxyObject) | AcDbProxyObject |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEraseAllowed enum value (defined in AcDbProxyObject) | AcDbProxyObject |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kMergeIgnore enum value (defined in AcDbProxyObject) | AcDbProxyObject |
kMergeMangleName enum value (defined in AcDbProxyObject) | AcDbProxyObject |
kMergeReplace enum value (defined in AcDbProxyObject) | AcDbProxyObject |
kNoOperation enum value (defined in AcDbProxyObject) | AcDbProxyObject |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const =0 (defined in AcDbProxyObject) | AcDbProxyObject | pure virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
originalClassName() const =0 (defined in AcDbProxyObject) | AcDbProxyObject | pure virtual
originalDxfName() const =0 (defined in AcDbProxyObject) | AcDbProxyObject | pure virtual
ownerId() const (defined in AcDbObject) | AcDbObject |
proxyFlags() const =0 (defined in AcDbProxyObject) | AcDbProxyObject | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbProxyObject() (defined in AcDbProxyObject) | AcDbProxyObject | inlinevirtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbR13ObjectId Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbR13ObjectId Class Reference
AcDb Classes
+ Inheritance diagram for AcDbR13ObjectId:

Public Member Functions

bool | operator!= (const AcDbR13ObjectId &id) const
bool | operator!= (const AcDbStub *pStub) const
bool | operator< (const AcDbR13ObjectId &id) const
bool | operator< (const AcDbStub *pStub) const
bool | operator<= (const AcDbR13ObjectId &id) const
bool | operator<= (const AcDbStub *pStub) const
bool | operator== (const AcDbR13ObjectId &id) const
bool | operator== (const AcDbStub *pStub) const
bool | operator> (const AcDbR13ObjectId &id) const
bool | operator> (const AcDbStub *pStub) const
bool | operator>= (const AcDbR13ObjectId &id) const
bool | operator>= (const AcDbStub *pStub) const
- Public Member Functions inherited from AcDbObjectId
AcDbObjectId (const AcDbStub *)
Adesk::IntDbId | asOldId () const
void | convertToRedirectedId ()
AcDbDatabase * | database () const
AcDbHandle | handle () const
bool | isEffectivelyErased () const
bool | isErased () const
bool | isNull () const
bool | isResident () const
bool | isValid () const
AcDbHandle | nonForwardedHandle () const
bool | objectLeftOnDisk () const
operator AcDbStub * () const
bool | operator!= (const AcDbObjectId &) const
bool | operator< (const AcDbObjectId &) const
bool | operator<= (const AcDbObjectId &) const
AcDbObjectId & | operator= (const AcDbObjectId &)
AcDbObjectId & | operator= (const AcDbStub *)
bool | operator== (const AcDbObjectId &) const
bool | operator> (const AcDbObjectId &) const
bool | operator>= (const AcDbObjectId &) const
AcDbDatabase * | originalDatabase () const
AcDbObjectId & | setFromOldId (Adesk::IntDbId oldId)
void | setNull ()

Additional Inherited Members

- Static Public Attributes inherited from AcDbObjectId
static ZRX_DB_STATIC_EXPORT
const AcDbObjectId 		kNull
- Protected Attributes inherited from AcDbObjectId
AcDbStub * mId
The documentation for this class was generated from the following file:
  • dbidapps.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbR13ObjectId Member List

This is the complete list of members for AcDbR13ObjectId, including all inherited members.

AcDbObjectId() (defined in AcDbObjectId) | AcDbObjectId | inline
AcDbObjectId(const AcDbStub *) (defined in AcDbObjectId) | AcDbObjectId | inline
asOldId() const (defined in AcDbObjectId) | AcDbObjectId | inline
convertToRedirectedId() (defined in AcDbObjectId) | AcDbObjectId |
database() const (defined in AcDbObjectId) | AcDbObjectId |
handle() const (defined in AcDbObjectId) | AcDbObjectId |
isEffectivelyErased() const (defined in AcDbObjectId) | AcDbObjectId |
isErased() const (defined in AcDbObjectId) | AcDbObjectId |
isNull() const (defined in AcDbObjectId) | AcDbObjectId | inline
isResident() const | AcDbObjectId |
isValid() const (defined in AcDbObjectId) | AcDbObjectId |
kNull (defined in AcDbObjectId) | AcDbObjectId | static
mId (defined in AcDbObjectId) | AcDbObjectId | protected
nonForwardedHandle() const (defined in AcDbObjectId) | AcDbObjectId |
objectLeftOnDisk() const (defined in AcDbObjectId) | AcDbObjectId |
operator AcDbStub *() const (defined in AcDbObjectId) | AcDbObjectId | inline
operator!=(const AcDbR13ObjectId &id) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator!=(const AcDbStub *pStub) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator!=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<(const AcDbR13ObjectId &id) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator<(const AcDbStub *pStub) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator<(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbR13ObjectId &id) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator<=(const AcDbStub *pStub) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator<=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator=(const AcDbObjectId &) (defined in AcDbObjectId) | AcDbObjectId | inline
operator=(const AcDbStub *) (defined in AcDbObjectId) | AcDbObjectId | inline
operator==(const AcDbR13ObjectId &id) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator==(const AcDbStub *pStub) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator==(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>(const AcDbR13ObjectId &id) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator>(const AcDbStub *pStub) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator>(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbR13ObjectId &id) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator>=(const AcDbStub *pStub) const (defined in AcDbR13ObjectId) | AcDbR13ObjectId | inline
operator>=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
originalDatabase() const (defined in AcDbObjectId) | AcDbObjectId |
setFromOldId(Adesk::IntDbId oldId) (defined in AcDbObjectId) | AcDbObjectId | inline
setNull() (defined in AcDbObjectId) | AcDbObjectId | inline


ZRX API Reference: AcDbRadialDimension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRadialDimension Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRadialDimension:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbRadialDimension)
AcDbRadialDimension (const AcGePoint3d &center, const AcGePoint3d &chordPoint, double leaderLength, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull)
AcGePoint3d | center () const
AcGePoint3d | chordPoint () const
double | extArcEndAngle () const
double | extArcStartAngle () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
double | leaderLength () const
Acad::ErrorStatus | setCenter (const AcGePoint3d &)
Acad::ErrorStatus | setChordPoint (const AcGePoint3d &)
Acad::ErrorStatus | setExtArcEndAngle (double newAngle)
Acad::ErrorStatus | setExtArcStartAngle (double newAngle)
Acad::ErrorStatus | setLeaderLength (double)
- Public Member Functions inherited from AcDbDimension
ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbDimension
enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRadialDimension Member List

This is the complete list of members for AcDbRadialDimension, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbRadialDimension) (defined in AcDbRadialDimension) | AcDbRadialDimension |
ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRadialDimension() (defined in AcDbRadialDimension) | AcDbRadialDimension |
AcDbRadialDimension(const AcGePoint3d &center, const AcGePoint3d &chordPoint, double leaderLength, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull) (defined in AcDbRadialDimension) | AcDbRadialDimension |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
center() const (defined in AcDbRadialDimension) | AcDbRadialDimension |
chordPoint() const (defined in AcDbRadialDimension) | AcDbRadialDimension |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extArcEndAngle() const (defined in AcDbRadialDimension) | AcDbRadialDimension |
extArcStartAngle() const (defined in AcDbRadialDimension) | AcDbRadialDimension |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbRadialDimension) | AcDbRadialDimension | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
leaderLength() const (defined in AcDbRadialDimension) | AcDbRadialDimension |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setCenter(const AcGePoint3d &) (defined in AcDbRadialDimension) | AcDbRadialDimension |
setChordPoint(const AcGePoint3d &) (defined in AcDbRadialDimension) | AcDbRadialDimension |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setExtArcEndAngle(double newAngle) (defined in AcDbRadialDimension) | AcDbRadialDimension |
setExtArcStartAngle(double newAngle) (defined in AcDbRadialDimension) | AcDbRadialDimension |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLeaderLength(double) (defined in AcDbRadialDimension) | AcDbRadialDimension |
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRadialDimension() (defined in AcDbRadialDimension) | AcDbRadialDimension |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRadialDimensionLarge Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRadialDimensionLarge Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRadialDimensionLarge:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbRadialDimensionLarge)
AcDbRadialDimensionLarge (const AcGePoint3d &center, const AcGePoint3d &chordPoint, const AcGePoint3d &overrideCenter, const AcGePoint3d &jogPoint, double jogAngle, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull)
AcGePoint3d | center () const
AcGePoint3d | chordPoint () const
double | extArcEndAngle () const
double | extArcStartAngle () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
double | jogAngle () const
AcGePoint3d | jogPoint () const
AcGePoint3d | overrideCenter () const
Acad::ErrorStatus | setCenter (const AcGePoint3d &centerPoint)
Acad::ErrorStatus | setChordPoint (const AcGePoint3d &chordPoint)
Acad::ErrorStatus | setExtArcEndAngle (double newAngle)
Acad::ErrorStatus | setExtArcStartAngle (double newAngle)
Acad::ErrorStatus | setJogAngle (double jogAngle)
Acad::ErrorStatus | setJogPoint (const AcGePoint3d &jogPoint)
Acad::ErrorStatus | setJogPointPP (const AcGePoint3d &jogPointPP)
Acad::ErrorStatus | setOverrideCenter (const AcGePoint3d &overrideCenterPoint)
Acad::ErrorStatus | setOverrideCenterPP (const AcGePoint3d &overrideCenterPointPP)
Acad::ErrorStatus | setTextPositionPP (const AcGePoint3d &textPointPP)
- Public Member Functions inherited from AcDbDimension
ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbDimension
enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

Acad::ErrorStatus AcDbRadialDimensionLarge::setJogPointPP ( const AcGePoint3d & jogPointPP )
Warning
Not implemented!
Acad::ErrorStatus AcDbRadialDimensionLarge::setOverrideCenterPP ( const AcGePoint3d & overrideCenterPointPP )
Warning
Not implemented!
Acad::ErrorStatus AcDbRadialDimensionLarge::setTextPositionPP ( const AcGePoint3d & textPointPP )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRadialDimensionLarge Member List

This is the complete list of members for AcDbRadialDimensionLarge, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbRadialDimensionLarge) (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRadialDimensionLarge() (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
AcDbRadialDimensionLarge(const AcGePoint3d &center, const AcGePoint3d &chordPoint, const AcGePoint3d &overrideCenter, const AcGePoint3d &jogPoint, double jogAngle, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull) (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
center() const (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
chordPoint() const (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extArcEndAngle() const (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
extArcStartAngle() const (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
jogAngle() const (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
jogPoint() const (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
overrideCenter() const (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setCenter(const AcGePoint3d &centerPoint) (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
setChordPoint(const AcGePoint3d &chordPoint) (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setExtArcEndAngle(double newAngle) (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
setExtArcStartAngle(double newAngle) (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setJogAngle(double jogAngle) (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
setJogPoint(const AcGePoint3d &jogPoint) (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
setJogPointPP(const AcGePoint3d &jogPointPP) | AcDbRadialDimensionLarge |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOverrideCenter(const AcGePoint3d &overrideCenterPoint) (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
setOverrideCenterPP(const AcGePoint3d &overrideCenterPointPP) | AcDbRadialDimensionLarge |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextPositionPP(const AcGePoint3d &textPointPP) | AcDbRadialDimensionLarge |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRadialDimensionLarge() (defined in AcDbRadialDimensionLarge) | AcDbRadialDimensionLarge |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRasterImage Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcDbRasterImage Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRasterImage:

Public Types

enum | ClipBoundaryType { kInvalid, kRect, kPoly }
enum | ImageDisplayOpt { kShow = 1, kShowUnAligned = 2, kClip = 4, kTransparent = 8 }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbRasterImage)
virtual Adesk::Int8 | brightness () const
virtual bool | castShadows () const
virtual const AcGePoint2dArray & | clipBoundary () const
virtual ClipBoundaryType | clipBoundaryType () const
virtual Adesk::Int8 | contrast () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Adesk::Int8 | fade () const
virtual Adesk::Boolean | freeScanLines (AcGiSentScanLines *pSSL) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual void | getOrientation (AcGePoint3d &origin, AcGeVector3d &u, AcGeVector3d &v) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPixelToModelTransform (AcGeMatrix3d &) const
virtual AcGiSentScanLines * | getScanLines (const AcGiRequestScanLines &req) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=0) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&ent) const
virtual Acad::ErrorStatus | getVertices (AcGePoint3dArray &verts) const
virtual AcDbObjectId | imageDefId () const
virtual AcGeVector2d | imageSize (Adesk::Boolean bGetCachedValue=Adesk::kFalse) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
Adesk::Boolean | isClipped () const
virtual Adesk::Boolean | isSetDisplayOpt (ImageDisplayOpt option) const
virtual void | list () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual AcGePoint3d | position () const
RasterImageImp * | ptrImp () const
virtual AcDbObjectId | reactorId () const
virtual bool | receiveShadows () const
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual AcGeVector2d | scale () const
virtual Acad::ErrorStatus | setBrightness (Adesk::Int8 value)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setClipBoundary (ClipBoundaryType type, const AcGePoint2dArray &)
virtual Acad::ErrorStatus | setClipBoundaryToWholeImage (AcGeVector2d &size=AcGeVector2d(0, 0))
virtual Acad::ErrorStatus | setContrast (Adesk::Int8 value)
virtual void | setDisplayOpt (ImageDisplayOpt option, Adesk::Boolean bValue)
virtual Acad::ErrorStatus | setFade (Adesk::Int8 value)
virtual Acad::ErrorStatus | setImageDefId (AcDbObjectId imageId)
virtual Adesk::Boolean | setOrientation (const AcGePoint3d &origin, const AcGeVector3d &uCorner, const AcGeVector3d &vOnPlane)
RasterImageImp * | setPtrImp (RasterImageImp *pImp)
virtual void | setReactorId (AcDbObjectId reactorId)
virtual void | setReceiveShadows (bool newVal)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=Adesk::kFalse, Adesk::Boolean swapExtDict=Adesk::kFalse)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual void | viewportDraw (AcGiViewportDraw *mode)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbImage
ACRX_DECLARE_MEMBERS (AcDbImage)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static ClassVersion classVersion ()
The documentation for this class was generated from the following file:
  • imgent.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRasterImage Member List

This is the complete list of members for AcDbRasterImage, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRasterImage() (defined in AcDbRasterImage) | AcDbRasterImage |
ACRX_DECLARE_MEMBERS(AcDbRasterImage) (defined in AcDbRasterImage) | AcDbRasterImage |
ACRX_DECLARE_MEMBERS(AcDbImage) (defined in AcDbImage) | AcDbImage |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
brightness() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
classVersion() (defined in AcDbRasterImage) | AcDbRasterImage | inlinestatic
clipBoundary() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
ClipBoundaryType enum name (defined in AcDbRasterImage) | AcDbRasterImage |
clipBoundaryType() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fade() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
freeScanLines(AcGiSentScanLines *pSSL) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOrientation(AcGePoint3d &origin, AcGeVector3d &u, AcGeVector3d &v) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPixelToModelTransform(AcGeMatrix3d &) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getScanLines(const AcGiRequestScanLines &req) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=0) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&ent) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getVertices(AcGePoint3dArray &verts) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
imageDefId() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
ImageDisplayOpt enum name (defined in AcDbRasterImage) | AcDbRasterImage |
imageSize(Adesk::Boolean bGetCachedValue=Adesk::kFalse) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClipped() const (defined in AcDbRasterImage) | AcDbRasterImage |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isSetDisplayOpt(ImageDisplayOpt option) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kClip enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kInvalid enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kPoly enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kRect enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kShow enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kShowUnAligned enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kTransparent enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
ptrImp() const (defined in AcDbRasterImage) | AcDbRasterImage | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactorId() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
scale() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBrightness(Adesk::Int8 value) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setCastShadows(bool newVal) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setClipBoundary(ClipBoundaryType type, const AcGePoint2dArray &) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setClipBoundaryToWholeImage(AcGeVector2d &size=AcGeVector2d(0, 0)) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setContrast(Adesk::Int8 value) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDisplayOpt(ImageDisplayOpt option, Adesk::Boolean bValue) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setFade(Adesk::Int8 value) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setImageDefId(AcDbObjectId imageId) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOrientation(const AcGePoint3d &origin, const AcGeVector3d &uCorner, const AcGeVector3d &vOnPlane) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setPtrImp(RasterImageImp *pImp) (defined in AcDbRasterImage) | AcDbRasterImage | inline
setReactorId(AcDbObjectId reactorId) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setReceiveShadows(bool newVal) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=Adesk::kFalse, Adesk::Boolean swapExtDict=Adesk::kFalse) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRasterImage() (defined in AcDbRasterImage) | AcDbRasterImage | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRasterImageDef Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcDbRasterImageDef Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRasterImageDef:

Public Types

enum { kMaxSuggestNameSize = 2049 }
enum Units {
kNone = 0, kMillimeter = 1, kCentimeter = 2, kMeter = 3,
kKilometer = 4, kInch = 5, kFoot = 6, kYard = 7,
kMile = 8, kMicroinches = 9, kMils = 10, kAngstroms = 11,
kNanometers = 12, kMicrons = 13, kDecimeters = 14, kDekameters = 15,
kHectometers = 16, kGigameters = 17, kAstronomical = 18, kLightYears = 19,
kParsecs = 20
}

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbRasterImageDef)
virtual const ACHAR * | activeFileName () const
virtual Acad::ErrorStatus | closeImage ()
virtual int | colorDepth () const
virtual void * | createThumbnailBitmap (BITMAPINFO *&pBitmapInfo, Adesk::UInt8 brightness=50, Adesk::UInt8 contrast=50, Adesk::UInt8 fade=0)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual Acad::ErrorStatus | embed ()
virtual int | entityCount (Adesk::Boolean *pbLocked=0) const
virtual Atil::FileReadDescriptor * | fileDescCopy () const
virtual const ACHAR * | fileType () const
virtual Atil::Image * | imageCopy (Adesk::Boolean bForceImageLoad=true) const
virtual Adesk::Boolean | imageModified () const
virtual Adesk::Boolean | isEmbedded () const
virtual Adesk::Boolean | isLoaded () const
virtual Acad::ErrorStatus | load ()
virtual Acad::ErrorStatus | loadThumbnail (Adesk::UInt16 &maxWidth, Adesk::UInt16 &maxHeight, Adesk::UInt8 *pPalette=0, int nPaletteEntries=0)
virtual AcGiSentScanLines * | makeScanLines (const AcGiRequestScanLines *pReq, const AcGeMatrix2d &pixToScreen, AcGePoint2dArray *pActiveClipBndy=0, Adesk::Boolean draftQuality=false, Adesk::Boolean isTransparent=false, const double brightness=50.0, const double contrast=50.0, const double fade=0.0) const
virtual Acad::ErrorStatus | openImage (Atil::Image *&pImage)
virtual AcGiImageOrg | organization () const
RasterImageDefImp * | ptrImp () const
virtual AcGeVector2d | resolutionMMPerPixel () const
virtual Units | resolutionUnits () const
virtual const ACHAR * | searchForActivePath ()
virtual Acad::ErrorStatus | setActiveFileName (const ACHAR *pPathName)
virtual Acad::ErrorStatus | setImage (const Atil::Image *pImage, const Atil::FileReadDescriptor *pFileDesc, Adesk::Boolean modifyDatabase=true)
virtual Acad::ErrorStatus | setImageModified (Adesk::Boolean modified)
RasterImageDefImp * | setPtrImp (RasterImageDefImp *pImp)
virtual Acad::ErrorStatus | setResolutionMMPerPixel (const AcGeVector2d &resMMPerPixel)
virtual void | setResolutionUnits (AcDbRasterImageDef::Units units)
virtual Acad::ErrorStatus | setSourceFileName (const ACHAR *pPathName)
virtual Acad::ErrorStatus | setUndoStoreSize (unsigned int maxImages=10)
virtual AcGeVector2d | size () const
virtual const ACHAR * | sourceFileName () const
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual unsigned int | undoStoreSize () const
virtual Acad::ErrorStatus | unload (Adesk::Boolean modifyDatabase=true)
virtual Acad::ErrorStatus | unloadThumbnail ()
virtual void | updateEntities () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static ClassVersion | classVersion ()
static Acad::ErrorStatus | createImageDictionary (AcDbDatabase *pDb, AcDbObjectId &dictId)
static AcDbObjectId | imageDictionary (AcDbDatabase *pDb)
static Acad::ErrorStatus | suggestName (AcDbDictionary *pImageDictionary, const ACHAR *pNewImagePathName, ACHAR *newImageName)
The documentation for this class was generated from the following file:
  • imgdef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRasterImageDef Member List

This is the complete list of members for AcDbRasterImageDef, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRasterImageDef() (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
ACRX_DECLARE_MEMBERS(AcDbRasterImageDef) (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
activeFileName() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
classVersion() (defined in AcDbRasterImageDef) | AcDbRasterImageDef | inlinestatic
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
closeImage() (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
colorDepth() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createImageDictionary(AcDbDatabase *pDb, AcDbObjectId &dictId) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | static
createThumbnailBitmap(BITMAPINFO *&pBitmapInfo, Adesk::UInt8 brightness=50, Adesk::UInt8 contrast=50, Adesk::UInt8 fade=0) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
embed() (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
entityCount(Adesk::Boolean *pbLocked=0) const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fileDescCopy() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
fileType() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imageCopy(Adesk::Boolean bForceImageLoad=true) const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
imageDictionary(AcDbDatabase *pDb) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | static
imageModified() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEmbedded() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLoaded() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kAngstroms enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kAstronomical enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kCentimeter enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kDecimeters enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kDekameters enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kFoot enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGigameters enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHectometers enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kInch enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kKilometer enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kLightYears enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kMaxSuggestNameSize enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kMeter enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kMicroinches enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kMicrons enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kMile enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kMillimeter enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kMils enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kNanometers enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kNone enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kParsecs enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kYard enum value (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
load() (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
loadThumbnail(Adesk::UInt16 &maxWidth, Adesk::UInt16 &maxHeight, Adesk::UInt8 *pPalette=0, int nPaletteEntries=0) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
makeScanLines(const AcGiRequestScanLines *pReq, const AcGeMatrix2d &pixToScreen, AcGePoint2dArray *pActiveClipBndy=0, Adesk::Boolean draftQuality=false, Adesk::Boolean isTransparent=false, const double brightness=50.0, const double contrast=50.0, const double fade=0.0) const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
openImage(Atil::Image *&pImage) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
organization() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
ownerId() const (defined in AcDbObject) | AcDbObject |
ptrImp() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
resolutionMMPerPixel() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
resolutionUnits() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
searchForActivePath() (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setActiveFileName(const ACHAR *pPathName) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setImage(const Atil::Image *pImage, const Atil::FileReadDescriptor *pFileDesc, Adesk::Boolean modifyDatabase=true) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
setImageModified(Adesk::Boolean modified) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPtrImp(RasterImageDefImp *pImp) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | inline
setResolutionMMPerPixel(const AcGeVector2d &resMMPerPixel) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
setResolutionUnits(AcDbRasterImageDef::Units units) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
setSourceFileName(const ACHAR *pPathName) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
setUndoStoreSize(unsigned int maxImages=10) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
size() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
sourceFileName() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
suggestName(AcDbDictionary *pImageDictionary, const ACHAR *pNewImagePathName, ACHAR *newImageName) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | static
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
undoStoreSize() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
Units enum name (defined in AcDbRasterImageDef) | AcDbRasterImageDef |
unload(Adesk::Boolean modifyDatabase=true) (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
unloadThumbnail() (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
updateEntities() const (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRasterImageDef() (defined in AcDbRasterImageDef) | AcDbRasterImageDef | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRasterImageDefFileAccessReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRasterImageDefFileAccessReactor Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRasterImageDefFileAccessReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbRasterImageDefFileAccessReactor)
virtual void | onAttach (const AcDbRasterImageDef *, const ACHAR *pPath)=0
virtual void | onClose (const AcDbRasterImageDef *, const ACHAR *pPath)=0
virtual void | onDetach (const AcDbRasterImageDef *, const ACHAR *pPath)=0
virtual void | onDialog (AcDbRasterImageDef *, const ACHAR *pCaption, const ACHAR *pFileExtensions)=0
virtual Adesk::Boolean | onOpen (const AcDbRasterImageDef *, const ACHAR *pPath, const ACHAR *pActivePath, Adesk::Boolean &replacePath, ACHAR *&replacementPath)=0
virtual Adesk::Boolean | onPathChange (const AcDbRasterImageDef *, const ACHAR *pPath, const ACHAR *pActivePath, Adesk::Boolean &replacePath, ACHAR *&replacementPath)=0
virtual | ~AcDbRasterImageDefFileAccessReactor ()
- Public Member Functions inherited from AcDbObjectReactor
ACRX_DECLARE_MEMBERS (AcDbObjectReactor)
virtual void | cancelled (const AcDbObject *dbObj)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
virtual void | goodbye (const AcDbObject *dbObj)
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
virtual void | openedForModify (const AcDbObject *dbObj)
virtual void | reappended (const AcDbObject *dbObj)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual void | unappended (const AcDbObject *dbObj)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

virtual AcDbRasterImageDefFileAccessReactor::~AcDbRasterImageDefFileAccessReactor ( )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • imgdef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRasterImageDefFileAccessReactor Member List

This is the complete list of members for AcDbRasterImageDefFileAccessReactor, including all inherited members.

AcDbObjectReactor() (defined in AcDbObjectReactor) | AcDbObjectReactor | protected
ACRX_DECLARE_MEMBERS(AcDbRasterImageDefFileAccessReactor) (defined in AcDbRasterImageDefFileAccessReactor) | AcDbRasterImageDefFileAccessReactor |
ACRX_DECLARE_MEMBERS(AcDbObjectReactor) (defined in AcDbObjectReactor) | AcDbObjectReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cancelled(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
modified(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
onAttach(const AcDbRasterImageDef *, const ACHAR *pPath)=0 (defined in AcDbRasterImageDefFileAccessReactor) | AcDbRasterImageDefFileAccessReactor | pure virtual
onClose(const AcDbRasterImageDef *, const ACHAR *pPath)=0 (defined in AcDbRasterImageDefFileAccessReactor) | AcDbRasterImageDefFileAccessReactor | pure virtual
onDetach(const AcDbRasterImageDef *, const ACHAR *pPath)=0 (defined in AcDbRasterImageDefFileAccessReactor) | AcDbRasterImageDefFileAccessReactor | pure virtual
onDialog(AcDbRasterImageDef *, const ACHAR *pCaption, const ACHAR *pFileExtensions)=0 (defined in AcDbRasterImageDefFileAccessReactor) | AcDbRasterImageDefFileAccessReactor | pure virtual
onOpen(const AcDbRasterImageDef *, const ACHAR *pPath, const ACHAR *pActivePath, Adesk::Boolean &replacePath, ACHAR *&replacementPath)=0 (defined in AcDbRasterImageDefFileAccessReactor) | AcDbRasterImageDefFileAccessReactor | pure virtual
onPathChange(const AcDbRasterImageDef *, const ACHAR *pPath, const ACHAR *pActivePath, Adesk::Boolean &replacePath, ACHAR *&replacementPath)=0 (defined in AcDbRasterImageDefFileAccessReactor) | AcDbRasterImageDefFileAccessReactor | pure virtual
openedForModify(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbRasterImageDefFileAccessReactor() | AcDbRasterImageDefFileAccessReactor | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRasterImageDefReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcDbRasterImageDefReactor Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRasterImageDefReactor:

Public Types

enum DeleteImageEvent { kUnload = 1, kErase = 2 }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbRasterImageDefReactor)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
virtual void | modified (const AcDbObject *dbObj)
virtual Adesk::Boolean | onDeleteImage (const AcDbRasterImageDef *pImageDef, Atil::Image *pImage, DeleteImageEvent event, Adesk::Boolean cancelAllowed)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static ClassVersion | classVersion ()
static void | setEnable (Adesk::Boolean enable)

Member Function Documentation

virtual void AcDbRasterImageDefReactor::erased | ( | const AcDbObject * | dbObj,
 |  | Adesk::Boolean | pErasing = true
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual void AcDbRasterImageDefReactor::modified ( const AcDbObject * dbObj )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Adesk::Boolean AcDbRasterImageDefReactor::onDeleteImage | ( | const AcDbRasterImageDef * | pImageDef,
 |  | Atil::Image * | pImage,
 |  | DeleteImageEvent | event,
 |  | Adesk::Boolean | cancelAllowed
 | ) |  |
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • imgdef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRasterImageDefReactor Member List

This is the complete list of members for AcDbRasterImageDefReactor, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRasterImageDefReactor() (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor |
ACRX_DECLARE_MEMBERS(AcDbRasterImageDefReactor) (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
classVersion() (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor | inlinestatic
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
DeleteImageEvent enum name (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor |
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) | AcDbRasterImageDefReactor | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kErase enum value (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kUnload enum value (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) | AcDbRasterImageDefReactor | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
onDeleteImage(const AcDbRasterImageDef *pImageDef, Atil::Image *pImage, DeleteImageEvent event, Adesk::Boolean cancelAllowed) | AcDbRasterImageDefReactor | virtual
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setEnable(Adesk::Boolean enable) (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor | static
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRasterImageDefReactor() (defined in AcDbRasterImageDefReactor) | AcDbRasterImageDefReactor | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRasterImageDefTransReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRasterImageDefTransReactor Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRasterImageDefTransReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbRasterImageDefTransReactor)
virtual Adesk::Boolean | onDeleteImage (const AcDbRasterImageDef *pImageDef, Atil::Image *pImage, AcDbRasterImageDefReactor::DeleteImageEvent event, Adesk::Boolean cancelAllowed)=0
virtual | ~AcDbRasterImageDefTransReactor ()
- Public Member Functions inherited from AcDbObjectReactor
ACRX_DECLARE_MEMBERS (AcDbObjectReactor)
virtual void | cancelled (const AcDbObject *dbObj)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
virtual void | goodbye (const AcDbObject *dbObj)
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
virtual void | openedForModify (const AcDbObject *dbObj)
virtual void | reappended (const AcDbObject *dbObj)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual void | unappended (const AcDbObject *dbObj)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

virtual AcDbRasterImageDefTransReactor::~AcDbRasterImageDefTransReactor ( )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • imgdef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRasterImageDefTransReactor Member List

This is the complete list of members for AcDbRasterImageDefTransReactor, including all inherited members.

AcDbObjectReactor() (defined in AcDbObjectReactor) | AcDbObjectReactor | protected
ACRX_DECLARE_MEMBERS(AcDbRasterImageDefTransReactor) (defined in AcDbRasterImageDefTransReactor) | AcDbRasterImageDefTransReactor |
ACRX_DECLARE_MEMBERS(AcDbObjectReactor) (defined in AcDbObjectReactor) | AcDbObjectReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cancelled(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
modified(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
onDeleteImage(const AcDbRasterImageDef *pImageDef, Atil::Image *pImage, AcDbRasterImageDefReactor::DeleteImageEvent event, Adesk::Boolean cancelAllowed)=0 (defined in AcDbRasterImageDefTransReactor) | AcDbRasterImageDefTransReactor | pure virtual
openedForModify(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObjectReactor) | AcDbObjectReactor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbRasterImageDefTransReactor() | AcDbRasterImageDefTransReactor | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRasterVariables Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcDbRasterVariables Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRasterVariables:

Public Types

enum FrameSettings {
kImageFrameInvalid = -1, kImageFrameOff = 0, kImageFrameAbove = 1, kImageFrameBelow = 2,
kImageFrameOnNoPlot = 3
}
enum ImageQuality { kImageQualityInvalid = -1, kImageQualityDraft = 0, kImageQualityHigh = 1 }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbRasterVariables)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual FrameSettings | imageFrame () const
virtual ImageQuality | imageQuality () const
virtual Acad::ErrorStatus | setImageFrame (FrameSettings value)
virtual Acad::ErrorStatus | setImageQuality (ImageQuality value)
virtual Acad::ErrorStatus | setUserScale (AcDbRasterImageDef::Units units)
virtual AcDbRasterImageDef::Units | userScale () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static ClassVersion | classVersion ()
static AcDbRasterVariables * | create ()
static AcDbRasterVariables * | openRasterVariables (AcDb::OpenMode mode, AcDbDatabase *pDatabase=0)
The documentation for this class was generated from the following file:
  • imgvars.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRasterVariables Member List

This is the complete list of members for AcDbRasterVariables, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRasterVariables() (defined in AcDbRasterVariables) | AcDbRasterVariables |
ACRX_DECLARE_MEMBERS(AcDbRasterVariables) (defined in AcDbRasterVariables) | AcDbRasterVariables |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
classVersion() (defined in AcDbRasterVariables) | AcDbRasterVariables | inlinestatic
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
create() (defined in AcDbRasterVariables) | AcDbRasterVariables | static
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
FrameSettings enum name (defined in AcDbRasterVariables) | AcDbRasterVariables |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imageFrame() const (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
ImageQuality enum name (defined in AcDbRasterVariables) | AcDbRasterVariables |
imageQuality() const (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageFrameAbove enum value (defined in AcDbRasterVariables) | AcDbRasterVariables |
kImageFrameBelow enum value (defined in AcDbRasterVariables) | AcDbRasterVariables |
kImageFrameInvalid enum value (defined in AcDbRasterVariables) | AcDbRasterVariables |
kImageFrameOff enum value (defined in AcDbRasterVariables) | AcDbRasterVariables |
kImageFrameOnNoPlot enum value (defined in AcDbRasterVariables) | AcDbRasterVariables |
kImageQualityDraft enum value (defined in AcDbRasterVariables) | AcDbRasterVariables |
kImageQualityHigh enum value (defined in AcDbRasterVariables) | AcDbRasterVariables |
kImageQualityInvalid enum value (defined in AcDbRasterVariables) | AcDbRasterVariables |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
openRasterVariables(AcDb::OpenMode mode, AcDbDatabase *pDatabase=0) (defined in AcDbRasterVariables) | AcDbRasterVariables | static
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setImageFrame(FrameSettings value) (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
setImageQuality(ImageQuality value) (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setUserScale(AcDbRasterImageDef::Units units) (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
userScale() const (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRasterVariables() (defined in AcDbRasterVariables) | AcDbRasterVariables | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRay Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRay Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRay:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbRay)
AcGePoint3d | basePoint () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
DBCURVE_METHODS Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
void | setBasePoint (const AcGePoint3d &pt)
void | setUnitDir (const AcGeVector3d &vec)
AcGeVector3d | unitDir () const
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbray.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRay Member List

This is the complete list of members for AcDbRay, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbRay) (defined in AcDbRay) | AcDbRay |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRay() (defined in AcDbRay) | AcDbRay |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
basePoint() const (defined in AcDbRay) | AcDbRay |
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbRay) | AcDbRay | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbRay) | AcDbRay | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBasePoint(const AcGePoint3d &pt) (defined in AcDbRay) | AcDbRay |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUnitDir(const AcGeVector3d &vec) (defined in AcDbRay) | AcDbRay |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
unitDir() const (defined in AcDbRay) | AcDbRay |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRay() (defined in AcDbRay) | AcDbRay |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRecover Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRecover Class Reference
AcDb Classes

Public Member Functions

virtual int callBack (AcDbDatabase *)=0
The documentation for this class was generated from the following file:
  • dbaudita.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRecover Member List

This is the complete list of members for AcDbRecover, including all inherited members.

callBack(AcDbDatabase *)=0 (defined in AcDbRecover) AcDbRecover pure virtual


ZRX API Reference: AcDbRecoverCallBack Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRecoverCallBack Class Reference
AcDb Classes

Public Member Functions

virtual Acad::ErrorStatus | registerCallBack (AcDbRecover *)
virtual Acad::ErrorStatus | removeCallBack ()
The documentation for this class was generated from the following file:
  • dbaudita.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRecoverCallBack Member List

This is the complete list of members for AcDbRecoverCallBack, including all inherited members.

AcDbRecoverCallBack() (defined in AcDbRecoverCallBack) | AcDbRecoverCallBack |
registerCallBack(AcDbRecover *) (defined in AcDbRecoverCallBack) | AcDbRecoverCallBack | virtual
removeCallBack() (defined in AcDbRecoverCallBack) | AcDbRecoverCallBack | virtual
~AcDbRecoverCallBack() (defined in AcDbRecoverCallBack) | AcDbRecoverCallBack | virtual


ZRX API Reference: AcDbRegAppTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbRegAppTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRegAppTable:

Public Types

typedef AcDbRegAppTableRecord | RecordType
- Public Types inherited from AcDbSymbolTable
typedef AcDbSymbolTableRecord | RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbRegAppTable)
Acad::ErrorStatus | add (AcDbRegAppTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbRegAppTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbRegAppTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbRegAppTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRegAppTable Member List

This is the complete list of members for AcDbRegAppTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbRegAppTable) (defined in AcDbRegAppTable) | AcDbRegAppTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRegAppTable() (defined in AcDbRegAppTable) | AcDbRegAppTable |
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbRegAppTableRecord *pRecord) (defined in AcDbRegAppTable) | AcDbRegAppTable |
add(AcDbObjectId &recordId, AcDbRegAppTableRecord *pRecord) (defined in AcDbRegAppTable) | AcDbRegAppTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbRegAppTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbRegAppTable) | AcDbRegAppTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const (defined in AcDbRegAppTable) | AcDbRegAppTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbRegAppTable) | AcDbRegAppTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbRegAppTable) | AcDbRegAppTable |
has(AcDbObjectId id) const (defined in AcDbRegAppTable) | AcDbRegAppTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbRegAppTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbRegAppTable) | AcDbRegAppTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbRegAppTable) | AcDbRegAppTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRegAppTable() (defined in AcDbRegAppTable) | AcDbRegAppTable | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRegAppTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbRegAppTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRegAppTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbRegAppTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbRegAppTableRecord *pRecord)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbRegAppTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRegAppTableIterator Member List

This is the complete list of members for AcDbRegAppTableIterator, including all inherited members.

AcDbRegAppTable (defined in AcDbRegAppTableIterator) | AcDbRegAppTableIterator | friend
AcDbRegAppTableIterator() (defined in AcDbRegAppTableIterator) | AcDbRegAppTableIterator | protected
AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbRegAppTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbRegAppTableIterator) | AcDbRegAppTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbRegAppTableIterator) | AcDbRegAppTableIterator |
seek(const AcDbRegAppTableRecord *pRecord) (defined in AcDbRegAppTableIterator) | AcDbRegAppTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbRegAppTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbRegAppTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRegAppTableRecord:

Public Types

typedef AcDbRegAppTable | TableType
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable | TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbRegAppTableRecord)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRegAppTableRecord Member List

This is the complete list of members for AcDbRegAppTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbRegAppTableRecord) (defined in AcDbRegAppTableRecord) | AcDbRegAppTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRegAppTableRecord() (defined in AcDbRegAppTableRecord) | AcDbRegAppTableRecord |
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbRegAppTableRecord) | AcDbRegAppTableRecord | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbRegAppTableRecord) | AcDbRegAppTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRegAppTableRecord() (defined in AcDbRegAppTableRecord) | AcDbRegAppTableRecord | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRegion Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcDbRegion Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRegion:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbRegion)
virtual void * | body () const
virtual Acad::ErrorStatus | booleanOper (AcDb::BoolOperType operation, AcDbRegion *otherRegion)
virtual Acad::ErrorStatus | getArea (double &regionArea) const
virtual Acad::ErrorStatus | getAreaProp (const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis, double &perimeter, double &area, AcGePoint2d &centroid, double momInertia[2], double &prodInertia, double prinMoments[2], AcGeVector2d prinAxes[2], double radiiGyration[2], AcGePoint2d &extentsLow, AcGePoint2d &extentsHigh) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getNormal (AcGeVector3d &) const
virtual Acad::ErrorStatus | getPerimeter (double &) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &regionPlane) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcDbSubentId | internalSubentId (void *ent) const
virtual void * | internalSubentPtr (const AcDbSubentId &id) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | isNull () const
virtual Adesk::UInt32 | numChanges () const
virtual Acad::ErrorStatus | setBody (const void *modelerBody)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static Acad::ErrorStatus createFromCurves (const AcDbVoidPtrArray &curveSegments, AcDbVoidPtrArray &regions)

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Member Function Documentation

virtual void* AcDbRegion::body ( ) const
virtual
Warning
Not implemented!
virtual AcDbSubentId AcDbRegion::internalSubentId ( void * ent ) const
virtual
Warning
Not implemented!
virtual void* AcDbRegion::internalSubentPtr ( const AcDbSubentId & id ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbRegion::setBody ( const void * modelerBody )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbregion.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRegion Member List

This is the complete list of members for AcDbRegion, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbRegion) (defined in AcDbRegion) | AcDbRegion |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRegion() (defined in AcDbRegion) | AcDbRegion |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
body() const | AcDbRegion | virtual
booleanOper(AcDb::BoolOperType operation, AcDbRegion *otherRegion) (defined in AcDbRegion) | AcDbRegion | virtual
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createFromCurves(const AcDbVoidPtrArray &curveSegments, AcDbVoidPtrArray &regions) (defined in AcDbRegion) | AcDbRegion | static
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &regionArea) const (defined in AcDbRegion) | AcDbRegion | virtual
getAreaProp(const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis, double &perimeter, double &area, AcGePoint2d &centroid, double momInertia[2], double &prodInertia, double prinMoments[2], AcGeVector2d prinAxes[2], double radiiGyration[2], AcGePoint2d &extentsLow, AcGePoint2d &extentsHigh) const (defined in AcDbRegion) | AcDbRegion | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbRegion) | AcDbRegion | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbRegion) | AcDbRegion | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getNormal(AcGeVector3d &) const (defined in AcDbRegion) | AcDbRegion | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPerimeter(double &) const (defined in AcDbRegion) | AcDbRegion | virtual
getPlane(AcGePlane &regionPlane) const (defined in AcDbRegion) | AcDbRegion | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbRegion) | AcDbRegion | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
internalSubentId(void *ent) const | AcDbRegion | virtual
internalSubentPtr(const AcDbSubentId &id) const | AcDbRegion | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbRegion) | AcDbRegion | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbRegion) | AcDbRegion | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isNull() const (defined in AcDbRegion) | AcDbRegion | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
numChanges() const (defined in AcDbRegion) | AcDbRegion | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBody(const void *modelerBody) | AcDbRegion | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbRegion) | AcDbRegion | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRegion() (defined in AcDbRegion) | AcDbRegion | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRenderEnvironment Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRenderEnvironment Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRenderEnvironment:

Public Member Functions

AcDbRenderEnvironment ()
ACRX_DECLARE_MEMBERS (AcDbRenderEnvironment)
void | distances (double &dNear, double &dFar) const
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
bool | environmentImageEnabled () const
AcString | environmentImageFileName () const
bool | fogBackgroundEnabled () const
AcCmEntityColor | fogColor () const
void | fogDensity (double &dNear, double &dFar) const
bool | fogEnabled () const
virtual bool | operator== (const AcDbRenderEnvironment &environment)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setDistances (double dNear, double dFar)
void | setEnvironmentImageEnabled (bool bEnabled)
Acad::ErrorStatus | setEnvironmentImageFileName (const AcString &strFileName)
void | setFogBackgroundEnabled (bool bEnable)
void | setFogColor (const AcCmEntityColor &color)
Acad::ErrorStatus | setFogDensity (double dNear, double dFar)
void | setFogEnabled (bool bEnable)
virtual | ~AcDbRenderEnvironment ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbRenderEnvironment::AcDbRenderEnvironment ( )
Warning
Not implemented!
virtual AcDbRenderEnvironment::~AcDbRenderEnvironment ( )
virtual
Warning
Not implemented!

Member Function Documentation

void AcDbRenderEnvironment::distances | ( | double & | dNear,
 |  | double & | dFar
 | ) |  | const
Warning
Not implemented!
virtual AcGiDrawable* AcDbRenderEnvironment::drawable ( )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderEnvironment::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderEnvironment::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderEnvironment::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderEnvironment::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

bool AcDbRenderEnvironment::environmentImageEnabled ( ) const
Warning
Not implemented!
AcString AcDbRenderEnvironment::environmentImageFileName ( ) const
Warning
Not implemented!
bool AcDbRenderEnvironment::fogBackgroundEnabled ( ) const
Warning
Not implemented!
AcCmEntityColor AcDbRenderEnvironment::fogColor ( ) const
Warning
Not implemented!
void AcDbRenderEnvironment::fogDensity | ( | double & | dNear,
 |  | double & | dFar
 | ) |  | const
Warning
Not implemented!
bool AcDbRenderEnvironment::fogEnabled ( ) const
Warning
Not implemented!
virtual bool AcDbRenderEnvironment::operator== ( const AcDbRenderEnvironment & environment )
virtual
Warning
Not implemented!
virtual Adesk::UInt32 AcDbRenderEnvironment::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Acad::ErrorStatus AcDbRenderEnvironment::setDistances | ( | double | dNear,
 |  | double | dFar
 | ) |  |
Warning
Not implemented!
void AcDbRenderEnvironment::setEnvironmentImageEnabled ( bool bEnabled )
Warning
Not implemented!
Acad::ErrorStatus AcDbRenderEnvironment::setEnvironmentImageFileName ( const AcString & strFileName )
Warning
Not implemented!
void AcDbRenderEnvironment::setFogBackgroundEnabled ( bool bEnable )
Warning
Not implemented!
void AcDbRenderEnvironment::setFogColor ( const AcCmEntityColor & color )
Warning
Not implemented!
Acad::ErrorStatus AcDbRenderEnvironment::setFogDensity | ( | double | dNear,
 |  | double | dFar
 | ) |  |
Warning
Not implemented!
void AcDbRenderEnvironment::setFogEnabled ( bool bEnable )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbRender.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRenderEnvironment Member List

This is the complete list of members for AcDbRenderEnvironment, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRenderEnvironment() | AcDbRenderEnvironment |
ACRX_DECLARE_MEMBERS(AcDbRenderEnvironment) (defined in AcDbRenderEnvironment) | AcDbRenderEnvironment |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
distances(double &dNear, double &dFar) const | AcDbRenderEnvironment |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() | AcDbRenderEnvironment | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbRenderEnvironment | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbRenderEnvironment | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbRenderEnvironment | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbRenderEnvironment | virtual
environmentImageEnabled() const | AcDbRenderEnvironment |
environmentImageFileName() const | AcDbRenderEnvironment |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fogBackgroundEnabled() const | AcDbRenderEnvironment |
fogColor() const | AcDbRenderEnvironment |
fogDensity(double &dNear, double &dFar) const | AcDbRenderEnvironment |
fogEnabled() const | AcDbRenderEnvironment |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator==(const AcDbRenderEnvironment &environment) | AcDbRenderEnvironment | virtual
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbRenderEnvironment | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDistances(double dNear, double dFar) | AcDbRenderEnvironment |
setEnvironmentImageEnabled(bool bEnabled) | AcDbRenderEnvironment |
setEnvironmentImageFileName(const AcString &strFileName) | AcDbRenderEnvironment |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFogBackgroundEnabled(bool bEnable) | AcDbRenderEnvironment |
setFogColor(const AcCmEntityColor &color) | AcDbRenderEnvironment |
setFogDensity(double dNear, double dFar) | AcDbRenderEnvironment |
setFogEnabled(bool bEnable) | AcDbRenderEnvironment |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRenderEnvironment() | AcDbRenderEnvironment | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRenderGlobal Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbRenderGlobal Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRenderGlobal:

Public Types

enum | Destination { krWindow = 0, krViewport }
enum | Procedure { krView = 0, krCrop, krSelected }

Public Member Functions

AcDbRenderGlobal ()
ACRX_DECLARE_MEMBERS (AcDbRenderGlobal)
Acad::ErrorStatus | copyFrom (const AcRxObject *other)
void | dimensions (int &w, int &h) const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcGiMrExposureType | exposureType () const
bool | highInfoLevel () const
bool | predefinedPresetsFirst () const
void | procedureAndDestination (Procedure &eProcedure, Destination &eDestination) const
bool | saveEnabled () const
AcString | saveFileName () const
Acad::ErrorStatus | setDimensions (int w, int h)
Acad::ErrorStatus | setExposureType (AcGiMrExposureType type)
void | setHighInfoLevel (bool bHighInfoLevel)
void | setPredefinedPresetsFirst (bool bPredefinedPresetsFirst)
void | setProcedureAndDestination (Procedure eProcedure, Destination eDestination)
void | setSaveEnabled (bool bEnabled)
Acad::ErrorStatus | setSaveFileName (const AcString &strFileName)
virtual | ~AcDbRenderGlobal ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbRenderGlobal::AcDbRenderGlobal ( )
Warning
Not implemented!
virtual AcDbRenderGlobal::~AcDbRenderGlobal ( )
virtual
Warning
Not implemented!

Member Function Documentation

Acad::ErrorStatus AcDbRenderGlobal::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

void AcDbRenderGlobal::dimensions | ( | int & | w,
 |  | int & | h
 | ) |  | const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbRenderGlobal::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderGlobal::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderGlobal::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderGlobal::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

AcGiMrExposureType AcDbRenderGlobal::exposureType ( ) const
Warning
Not implemented!
bool AcDbRenderGlobal::highInfoLevel ( ) const
Warning
Not implemented!
bool AcDbRenderGlobal::predefinedPresetsFirst ( ) const
Warning
Not implemented!
void AcDbRenderGlobal::procedureAndDestination | ( | Procedure & | eProcedure,
 |  | Destination & | eDestination
 | ) |  | const
Warning
Not implemented!
bool AcDbRenderGlobal::saveEnabled ( ) const
Warning
Not implemented!
AcString AcDbRenderGlobal::saveFileName ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbRenderGlobal::setDimensions | ( | int | w,
 |  | int | h
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbRenderGlobal::setExposureType ( AcGiMrExposureType type )
Warning
Not implemented!
void AcDbRenderGlobal::setHighInfoLevel ( bool bHighInfoLevel )
Warning
Not implemented!
void AcDbRenderGlobal::setPredefinedPresetsFirst ( bool bPredefinedPresetsFirst )
Warning
Not implemented!
void AcDbRenderGlobal::setProcedureAndDestination | ( | Procedure | eProcedure,
 |  | Destination | eDestination
 | ) |  |
Warning
Not implemented!
void AcDbRenderGlobal::setSaveEnabled ( bool bEnabled )
Warning
Not implemented!
Acad::ErrorStatus AcDbRenderGlobal::setSaveFileName ( const AcString & strFileName )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbRender.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRenderGlobal Member List

This is the complete list of members for AcDbRenderGlobal, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRenderGlobal() | AcDbRenderGlobal |
ACRX_DECLARE_MEMBERS(AcDbRenderGlobal) (defined in AcDbRenderGlobal) | AcDbRenderGlobal |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) | AcDbRenderGlobal | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
Destination enum name (defined in AcDbRenderGlobal) | AcDbRenderGlobal |
dimensions(int &w, int &h) const | AcDbRenderGlobal |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbRenderGlobal | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbRenderGlobal | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbRenderGlobal | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbRenderGlobal | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
exposureType() const | AcDbRenderGlobal |
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
highInfoLevel() const | AcDbRenderGlobal |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
krCrop enum value (defined in AcDbRenderGlobal) | AcDbRenderGlobal |
krSelected enum value (defined in AcDbRenderGlobal) | AcDbRenderGlobal |
krView enum value (defined in AcDbRenderGlobal) | AcDbRenderGlobal |
krViewport enum value (defined in AcDbRenderGlobal) | AcDbRenderGlobal |
krWindow enum value (defined in AcDbRenderGlobal) | AcDbRenderGlobal |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
predefinedPresetsFirst() const | AcDbRenderGlobal |
Procedure enum name (defined in AcDbRenderGlobal) | AcDbRenderGlobal |
procedureAndDestination(Procedure &eProcedure, Destination &eDestination) const | AcDbRenderGlobal |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveEnabled() const | AcDbRenderGlobal |
saveFileName() const | AcDbRenderGlobal |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDimensions(int w, int h) | AcDbRenderGlobal |
setExposureType(AcGiMrExposureType type) | AcDbRenderGlobal |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHighInfoLevel(bool bHighInfoLevel) | AcDbRenderGlobal |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPredefinedPresetsFirst(bool bPredefinedPresetsFirst) | AcDbRenderGlobal |
setProcedureAndDestination(Procedure eProcedure, Destination eDestination) | AcDbRenderGlobal |
setSaveEnabled(bool bEnabled) | AcDbRenderGlobal |
setSaveFileName(const AcString &strFileName) | AcDbRenderGlobal |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRenderGlobal() | AcDbRenderGlobal | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRenderSettings Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRenderSettings Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRenderSettings:

Public Member Functions

AcDbRenderSettings ()
ACRX_DECLARE_MEMBERS (AcDbRenderSettings)
bool | backFacesEnabled () const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
AcString | description () const
bool | diagnosticBackgroundEnabled () const
int | displayIndex () const
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
bool | materialsEnabled () const
AcString | name () const
virtual bool | operator== (const AcDbRenderSettings &settings)
AcString | previewImageFileName () const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
void | setBackFacesEnabled (bool bEnabled)
void | setDescription (const AcString &strDes)
void | setDiagnosticBackgroundEnabled (bool bEnabled)
void | setDisplayIndex (int idx)
void | setMaterialsEnabled (bool bEnabled)
Acad::ErrorStatus | setName (const AcString &strName)
Acad::ErrorStatus | setPreviewImageFileName (const AcString &strFileName)
void | setShadowsEnabled (bool bEnabled)
void | setTextureSampling (bool bSampling)
bool | shadowsEnabled () const
bool | textureSampling () const
virtual | ~AcDbRenderSettings ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbRenderSettings::AcDbRenderSettings ( )
Warning
Not implemented!
virtual AcDbRenderSettings::~AcDbRenderSettings ( )
virtual
Warning
Not implemented!

Member Function Documentation

bool AcDbRenderSettings::backFacesEnabled ( ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbRenderSettings::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

AcString AcDbRenderSettings::description ( ) const
Warning
Not implemented!
bool AcDbRenderSettings::diagnosticBackgroundEnabled ( ) const
Warning
Not implemented!
int AcDbRenderSettings::displayIndex ( ) const
Warning
Not implemented!
virtual AcGiDrawable* AcDbRenderSettings::drawable ( )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderSettings::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderSettings::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderSettings::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbRenderSettings::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

bool AcDbRenderSettings::materialsEnabled ( ) const
Warning
Not implemented!
AcString AcDbRenderSettings::name ( ) const
Warning
Not implemented!
virtual bool AcDbRenderSettings::operator== ( const AcDbRenderSettings & settings )
virtual
Warning
Not implemented!
AcString AcDbRenderSettings::previewImageFileName ( ) const
Warning
Not implemented!
virtual Adesk::UInt32 AcDbRenderSettings::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

void AcDbRenderSettings::setBackFacesEnabled ( bool bEnabled )
Warning
Not implemented!
void AcDbRenderSettings::setDescription ( const AcString & strDes )
Warning
Not implemented!
void AcDbRenderSettings::setDiagnosticBackgroundEnabled ( bool bEnabled )
Warning
Not implemented!
void AcDbRenderSettings::setDisplayIndex ( int idx )
Warning
Not implemented!
void AcDbRenderSettings::setMaterialsEnabled ( bool bEnabled )
Warning
Not implemented!
Acad::ErrorStatus AcDbRenderSettings::setName ( const AcString & strName )
Warning
Not implemented!
Acad::ErrorStatus AcDbRenderSettings::setPreviewImageFileName ( const AcString & strFileName )
Warning
Not implemented!
void AcDbRenderSettings::setShadowsEnabled ( bool bEnabled )
Warning
Not implemented!
void AcDbRenderSettings::setTextureSampling ( bool bSampling )
Warning
Not implemented!
bool AcDbRenderSettings::shadowsEnabled ( ) const
Warning
Not implemented!
bool AcDbRenderSettings::textureSampling ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbRender.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRenderSettings Member List

This is the complete list of members for AcDbRenderSettings, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRenderSettings() | AcDbRenderSettings |
ACRX_DECLARE_MEMBERS(AcDbRenderSettings) (defined in AcDbRenderSettings) | AcDbRenderSettings |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
backFacesEnabled() const | AcDbRenderSettings |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) | AcDbRenderSettings | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description() const | AcDbRenderSettings |
diagnosticBackgroundEnabled() const | AcDbRenderSettings |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
displayIndex() const | AcDbRenderSettings |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() | AcDbRenderSettings | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbRenderSettings | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbRenderSettings | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbRenderSettings | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbRenderSettings | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
materialsEnabled() const | AcDbRenderSettings |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
name() const | AcDbRenderSettings |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator==(const AcDbRenderSettings &settings) | AcDbRenderSettings | virtual
ownerId() const (defined in AcDbObject) | AcDbObject |
previewImageFileName() const | AcDbRenderSettings |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbRenderSettings | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBackFacesEnabled(bool bEnabled) | AcDbRenderSettings |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDescription(const AcString &strDes) | AcDbRenderSettings |
setDiagnosticBackgroundEnabled(bool bEnabled) | AcDbRenderSettings |
setDisplayIndex(int idx) | AcDbRenderSettings |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setMaterialsEnabled(bool bEnabled) | AcDbRenderSettings |
setName(const AcString &strName) | AcDbRenderSettings |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPreviewImageFileName(const AcString &strFileName) | AcDbRenderSettings |
setShadowsEnabled(bool bEnabled) | AcDbRenderSettings |
setTextureSampling(bool bSampling) | AcDbRenderSettings |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shadowsEnabled() const | AcDbRenderSettings |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textureSampling() const | AcDbRenderSettings |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRenderSettings() | AcDbRenderSettings | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRevolvedSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRevolvedSurface Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRevolvedSurface:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbRevolvedSurface)
AcDbRevolvedSurface ()
virtual Acad::ErrorStatus | createRevolvedSurface (AcDbEntity *pRevEnt, const AcGePoint3d &axisPnt, const AcGeVector3d &axisDir, double revAngle, double startAngle, AcDbRevolveOptions &revolveOptions)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcGePoint3d | getAxisPnt () const
AcGeVector3d | getAxisVec () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
double | getRevolveAngle () const
AcDbEntity * | getRevolveEntity () const
void | getRevolveOptions (AcDbRevolveOptions &revolveOptions) const
double | getStartAngle () const
virtual bool | isDependent () const
virtual void | list () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
Acad::ErrorStatus | setAxisPnt (const AcGePoint3d &pnt)
Acad::ErrorStatus | setAxisVec (const AcGeVector3d &vec)
Acad::ErrorStatus | setRevolve (const AcGePoint3d &axisPnt, const AcGeVector3d &axisVec, double revAngle, const AcDbRevolveOptions &revolveOptions)
Acad::ErrorStatus | setRevolveAngle (double ang)
Acad::ErrorStatus | setRevolveOptions (const AcDbRevolveOptions &revolveOptions)
virtual | ~AcDbRevolvedSurface ()
- Public Member Functions inherited from AcDbSurface
ACDB_DECLARE_MEMBERS (AcDbSurface)
AcDbSurface ()
virtual void * | body () const
virtual Acad::ErrorStatus | convertToRegion (AcArray< AcDbEntity * > &regions)
virtual Acad::ErrorStatus | getArea (double &area) const
virtual AcDbSubentId | internalSubentId (void *ent) const
virtual void * | internalSubentPtr (const AcDbSubentId &id) const
virtual Acad::ErrorStatus | setBody (const void *modelerBody)
virtual Acad::ErrorStatus | setUIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | setVIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | thicken (double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const
virtual Adesk::UInt16 | uIsolineDensity () const
virtual Adesk::UInt16 | vIsolineDensity () const
virtual | ~AcDbSurface ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcDbSurface
static Acad::ErrorStatus | createFrom (const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface)

Constructor & Destructor Documentation

AcDbRevolvedSurface::AcDbRevolvedSurface ( )
Warning
Not implemented!
virtual AcDbRevolvedSurface::~AcDbRevolvedSurface ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbRevolvedSurface::createRevolvedSurface | ( | AcDbEntity * | pRevEnt,
 |  | const AcGePoint3d & | axisPnt,
 |  | const AcGeVector3d & | axisDir,
 |  | double | revAngle,
 |  | double | startAngle,
 |  | AcDbRevolveOptions & | revolveOptions
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbRevolvedSurface::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbRevolvedSurface::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbRevolvedSurface::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbRevolvedSurface::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

AcGePoint3d AcDbRevolvedSurface::getAxisPnt ( ) const
Warning
Not implemented!
AcGeVector3d AcDbRevolvedSurface::getAxisVec ( ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbRevolvedSurface::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbRevolvedSurface::getGripEntityUCS | ( | const void * | pGripAppData,
 |  | AcGeVector3d & | normalVec,
 |  | AcGePoint3d & | origin,
 |  | AcGeVector3d & | xAxis
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbRevolvedSurface::getGripPoints | ( | AcGePoint3dArray & | gripPoints,
 |  | AcDbIntArray & | osnapModes,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbRevolvedSurface::getGripPoints | ( | AcDbGripDataPtrArray & | grips,
 |  | const double | curViewUnitSize,
 |  | const int | gripSize,
 |  | const AcGeVector3d & | curViewDir,
 |  | const int | bitflags
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

double AcDbRevolvedSurface::getRevolveAngle ( ) const
Warning
Not implemented!
AcDbEntity* AcDbRevolvedSurface::getRevolveEntity ( ) const
Warning
Not implemented!
void AcDbRevolvedSurface::getRevolveOptions ( AcDbRevolveOptions & revolveOptions ) const
Warning
Not implemented!
double AcDbRevolvedSurface::getStartAngle ( ) const
Warning
Not implemented!
virtual bool AcDbRevolvedSurface::isDependent ( ) const
virtual
Warning
Not implemented!
virtual void AcDbRevolvedSurface::list ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbRevolvedSurface::moveGripPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbRevolvedSurface::moveStretchPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Acad::ErrorStatus AcDbRevolvedSurface::setAxisPnt ( const AcGePoint3d & pnt )
Warning
Not implemented!
Acad::ErrorStatus AcDbRevolvedSurface::setAxisVec ( const AcGeVector3d & vec )
Warning
Not implemented!
Acad::ErrorStatus AcDbRevolvedSurface::setRevolve | ( | const AcGePoint3d & | axisPnt,
 |  | const AcGeVector3d & | axisVec,
 |  | double | revAngle,
 |  | const AcDbRevolveOptions & | revolveOptions
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbRevolvedSurface::setRevolveAngle ( double ang )
Warning
Not implemented!
Acad::ErrorStatus AcDbRevolvedSurface::setRevolveOptions ( const AcDbRevolveOptions & revolveOptions )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbrevolvedsurf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRevolvedSurface Member List

This is the complete list of members for AcDbRevolvedSurface, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbRevolvedSurface) (defined in AcDbRevolvedSurface) | AcDbRevolvedSurface |
ACDB_DECLARE_MEMBERS(AcDbSurface) (defined in AcDbSurface) | AcDbSurface |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRevolvedSurface() | AcDbRevolvedSurface |
AcDbSurface() | AcDbSurface |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
body() const | AcDbSurface | virtual
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToRegion(AcArray< AcDbEntity * > &regions) | AcDbSurface | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createFrom(const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface) | AcDbSurface | static
createRevolvedSurface(AcDbEntity *pRevEnt, const AcGePoint3d &axisPnt, const AcGeVector3d &axisDir, double revAngle, double startAngle, AcDbRevolveOptions &revolveOptions) | AcDbRevolvedSurface | virtual
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbRevolvedSurface | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbRevolvedSurface | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbRevolvedSurface | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbRevolvedSurface | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &area) const | AcDbSurface | virtual
getAxisPnt() const | AcDbRevolvedSurface |
getAxisVec() const | AcDbRevolvedSurface |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbRevolvedSurface | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const | AcDbRevolvedSurface | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const | AcDbRevolvedSurface | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const | AcDbRevolvedSurface | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getRevolveAngle() const | AcDbRevolvedSurface |
getRevolveEntity() const | AcDbRevolvedSurface |
getRevolveOptions(AcDbRevolveOptions &revolveOptions) const | AcDbRevolvedSurface |
getStartAngle() const | AcDbRevolvedSurface |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
internalSubentId(void *ent) const | AcDbSurface | virtual
internalSubentPtr(const AcDbSubentId &id) const | AcDbSurface | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const | AcDbRevolvedSurface | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const | AcDbRevolvedSurface | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbRevolvedSurface | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbRevolvedSurface | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setAxisPnt(const AcGePoint3d &pnt) | AcDbRevolvedSurface |
setAxisVec(const AcGeVector3d &vec) | AcDbRevolvedSurface |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBody(const void *modelerBody) | AcDbSurface | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRevolve(const AcGePoint3d &axisPnt, const AcGeVector3d &axisVec, double revAngle, const AcDbRevolveOptions &revolveOptions) | AcDbRevolvedSurface |
setRevolveAngle(double ang) | AcDbRevolvedSurface |
setRevolveOptions(const AcDbRevolveOptions &revolveOptions) | AcDbRevolvedSurface |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thicken(double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const | AcDbSurface | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
uIsolineDensity() const | AcDbSurface | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
vIsolineDensity() const | AcDbSurface | virtual
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRevolvedSurface() | AcDbRevolvedSurface | virtual
~AcDbSurface() | AcDbSurface | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbRevolveOptions Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbRevolveOptions Class Reference
AcDb Classes

Public Member Functions

AcDbRevolveOptions ()
AcDbRevolveOptions (const AcDbRevolveOptions &src)
Acad::ErrorStatus | checkRevolveCurve (AcDbEntity *pRevEnt, const AcGePoint3d &axisPnt, const AcGeVector3d &axisDir, bool &closed, bool &endPointsOnAxis, bool &planar, bool displayErrorMessages=false)
bool | closeToAxis () const
double | draftAngle () const
AcDbRevolveOptions & | operator= (const AcDbRevolveOptions &src)
void | setCloseToAxis (bool val)
void | setDraftAngle (double ang)
void | setTwistAngle (double ang)
double | twistAngle () const
~AcDbRevolveOptions ()

Friends

class AcDbImpRevolveOptions

Constructor & Destructor Documentation

AcDbRevolveOptions::AcDbRevolveOptions ( )
Warning
Not implemented!
AcDbRevolveOptions::AcDbRevolveOptions ( const AcDbRevolveOptions & src )
Warning
Not implemented!
AcDbRevolveOptions::~AcDbRevolveOptions ( )
Warning
Not implemented!

Member Function Documentation

Acad::ErrorStatus AcDbRevolveOptions::checkRevolveCurve | ( | AcDbEntity * | pRevEnt,
 |  | const AcGePoint3d & | axisPnt,
 |  | const AcGeVector3d & | axisDir,
 |  | bool & | closed,
 |  | bool & | endPointsOnAxis,
 |  | bool & | planar,
 |  | bool | displayErrorMessages = false
 | ) |  |
Warning
Not implemented!
bool AcDbRevolveOptions::closeToAxis ( ) const
Warning
Not implemented!
double AcDbRevolveOptions::draftAngle ( ) const
Warning
Not implemented!
AcDbRevolveOptions& AcDbRevolveOptions::operator= ( const AcDbRevolveOptions & src )
Warning
Not implemented!
void AcDbRevolveOptions::setCloseToAxis ( bool val )
Warning
Not implemented!
void AcDbRevolveOptions::setDraftAngle ( double ang )
Warning
Not implemented!
void AcDbRevolveOptions::setTwistAngle ( double ang )
Warning
Not implemented!
double AcDbRevolveOptions::twistAngle ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbRevolveOptions.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRevolveOptions Member List

This is the complete list of members for AcDbRevolveOptions, including all inherited members.

AcDbImpRevolveOptions (defined in AcDbRevolveOptions) | AcDbRevolveOptions | friend
AcDbRevolveOptions() AcDbRevolveOptions
AcDbRevolveOptions(const AcDbRevolveOptions &src) | AcDbRevolveOptions
checkRevolveCurve(AcDbEntity *pRevEnt, const AcGePoint3d &axisPnt, const AcGeVector3d &axisDir, bool &closed, bool &endPointsOnAxis, bool &planar, bool displayErrorMessages=false) | AcDbRevolveOptions
closeToAxis() const | AcDbRevolveOptions
draftAngle() const | AcDbRevolveOptions
operator=(const AcDbRevolveOptions &src) | AcDbRevolveOptions
setCloseToAxis(bool val) | AcDbRevolveOptions
setDraftAngle(double ang) | AcDbRevolveOptions
setTwistAngle(double ang) | AcDbRevolveOptions
twistAngle() const | AcDbRevolveOptions


ZRX API Reference: AcDbRotatedDimension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbRotatedDimension Class Reference
AcDb Classes
+ Inheritance diagram for AcDbRotatedDimension:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbRotatedDimension)
AcDbRotatedDimension (double rotation, const AcGePoint3d &xLine1Point, const AcGePoint3d &xLine2Point, const AcGePoint3d &dimLinePoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull)
AcGePoint3d | dimLinePoint () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | jogSymbolOn () const
AcGePoint3d | jogSymbolPosition () const
double | oblique () const
double | rotation () const
Acad::ErrorStatus | setDimLinePoint (const AcGePoint3d &)
Acad::ErrorStatus | setJogSymbolOn (bool value)
Acad::ErrorStatus | setJogSymbolPosition (const AcGePoint3d &pt)
Acad::ErrorStatus | setOblique (double)
Acad::ErrorStatus | setRotation (double)
Acad::ErrorStatus | setXLine1Point (const AcGePoint3d &)
Acad::ErrorStatus | setXLine2Point (const AcGePoint3d &)
AcGePoint3d | xLine1Point () const
AcGePoint3d | xLine2Point () const
- Public Member Functions inherited from AcDbDimension
ACDB_DECLARE_MEMBERS (AcDbDimension)
AcGeMatrix3d | blockTransform () const
virtual bool | castShadows () const
AcDbObjectId | dimBlockId () const
AcGePoint3d | dimBlockPosition () const
AcDbObjectId | dimensionStyle () const
ACHAR * | dimensionText () const
AcDbObjectId | dimExt1Linetype () const
AcDbObjectId | dimExt2Linetype () const
int | dimfit () const
AcDbObjectId | dimLineLinetype () const
int | dimunit () const
double | elevation () const
virtual void | erased (AcDbObject *dbObj, Adesk::Boolean bErasing)
Acad::ErrorStatus | fieldFromMText (AcDbMText *pDimMText)
Acad::ErrorStatus | fieldToMText (AcDbMText *pDimMText)
Acad::ErrorStatus | formatMeasurement (ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText)
Acad::ErrorStatus | generateLayout ()
bool | getArrowFirstIsFlipped () const
bool | getArrowSecondIsFlipped () const
Acad::ErrorStatus | getDimstyleData (AcDbDimStyleTableRecord *&pRecord) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | horizontalRotation () const
bool | inspection () const
int | inspectionFrame () const
const ACHAR * | inspectionLabel () const
const ACHAR * | inspectionRate () const
bool | isDynamicDimension () const
bool | isHorizontalRefTextRotation () const
virtual Adesk::Boolean | isPlanar () const
Adesk::Boolean | isUsingDefaultTextPosition () const
Acad::ErrorStatus | measurement (double &val)
AcGeVector3d | normal () const
virtual void | objectClosed (const AcDbObjectId dbObj)
virtual bool | receiveShadows () const
Acad::ErrorStatus | recomputeDimBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeTextField ()
Acad::ErrorStatus | setArrowFirstIsFlipped (bool bIsFlipped)
Acad::ErrorStatus | setArrowSecondIsFlipped (bool bIsFlipped)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setDimBlockId (const AcDbObjectId &)
Acad::ErrorStatus | setDimBlockPosition (const AcGePoint3d &)
Acad::ErrorStatus | setDimensionStyle (AcDbObjectId)
Acad::ErrorStatus | setDimensionText (const ACHAR *)
Acad::ErrorStatus | setDimExt1Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimExt2Linetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimfit (int)
Acad::ErrorStatus | setDimLineLinetype (const AcDbObjectId linetype)
Acad::ErrorStatus | setDimstyleData (AcDbDimStyleTableRecord *pNewData)
Acad::ErrorStatus | setDimstyleData (AcDbObjectId newDataId)
Acad::ErrorStatus | setDimunit (int)
Acad::ErrorStatus | setDynamicDimension (bool newVal)
Acad::ErrorStatus | setElevation (double)
Acad::ErrorStatus | setHorizontalRefTextRotation (bool newVal)
Acad::ErrorStatus | setHorizontalRotation (double newVal)
Acad::ErrorStatus | setInspection (bool val)
Acad::ErrorStatus | setInspectionFrame (int frame)
Acad::ErrorStatus | setInspectionLabel (const ACHAR *label)
Acad::ErrorStatus | setInspectionRate (const ACHAR *label)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setTextAttachment (AcDbMText::AttachmentPoint eAtt)
Acad::ErrorStatus | setTextLineSpacingFactor (double dFactor)
Acad::ErrorStatus | setTextLineSpacingStyle (AcDb::LineSpacingStyle eStyle)
Acad::ErrorStatus | setTextPosition (const AcGePoint3d &)
Acad::ErrorStatus | setTextRotation (double)
AcDbMText::AttachmentPoint | textAttachment () const
double | textLineSpacingFactor () const
AcDb::LineSpacingStyle | textLineSpacingStyle () const
AcGePoint3d | textPosition () const
double | textRotation () const
Acad::ErrorStatus | useDefaultTextPosition ()
Acad::ErrorStatus | useSetTextPosition ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbDimension
enum DimInspect {
kShapeRemove = 0, kShapeRound = 1, kShapeAngular = 2, kShapeNone = 4,
kShapeLabel = 0x10, kShapeRate = 0x20
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbdim.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbRotatedDimension Member List

This is the complete list of members for AcDbRotatedDimension, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbRotatedDimension) (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
ACDB_DECLARE_MEMBERS(AcDbDimension) (defined in AcDbDimension) | AcDbDimension |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbDimension() (defined in AcDbDimension) | AcDbDimension | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRotatedDimension() (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
AcDbRotatedDimension(double rotation, const AcGePoint3d &xLine1Point, const AcGePoint3d &xLine2Point, const AcGePoint3d &dimLinePoint, const ACHAR *dimText=NULL, AcDbObjectId dimStyle=AcDbObjectId::kNull) (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockTransform() const (defined in AcDbDimension) | AcDbDimension |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimBlockId() const (defined in AcDbDimension) | AcDbDimension |
dimBlockPosition() const (defined in AcDbDimension) | AcDbDimension |
dimensionStyle() const (defined in AcDbDimension) | AcDbDimension |
dimensionText() const (defined in AcDbDimension) | AcDbDimension |
dimExt1Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimExt2Linetype() const (defined in AcDbDimension) | AcDbDimension |
dimfit() const | AcDbDimension |
DimInspect enum name (defined in AcDbDimension) | AcDbDimension |
dimLineLinetype() const (defined in AcDbDimension) | AcDbDimension |
dimLinePoint() const (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
dimunit() const | AcDbDimension |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevation() const (defined in AcDbDimension) | AcDbDimension |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(AcDbObject *dbObj, Adesk::Boolean bErasing) (defined in AcDbDimension) | AcDbDimension | virtual
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldFromMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
fieldToMText(AcDbMText *pDimMText) (defined in AcDbDimension) | AcDbDimension |
formatMeasurement(ACHAR *MTextContentBuffer, double measurement, ACHAR *dimensionText) (defined in AcDbDimension) | AcDbDimension |
generateLayout() (defined in AcDbDimension) | AcDbDimension |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArrowFirstIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getArrowSecondIsFlipped() const (defined in AcDbDimension) | AcDbDimension |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbRotatedDimension) | AcDbRotatedDimension | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDimstyleData(AcDbDimStyleTableRecord *&pRecord) const (defined in AcDbDimension) | AcDbDimension |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, const AcDbFullSubentPath &subentId, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension |
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbDimension | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbDimension) | AcDbDimension | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalRotation() const (defined in AcDbDimension) | AcDbDimension |
id() const (defined in AcDbObject) | AcDbObject | virtual
inspection() const (defined in AcDbDimension) | AcDbDimension |
inspectionFrame() const (defined in AcDbDimension) | AcDbDimension |
inspectionLabel() const (defined in AcDbDimension) | AcDbDimension |
inspectionRate() const (defined in AcDbDimension) | AcDbDimension |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDynamicDimension() const (defined in AcDbDimension) | AcDbDimension |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHorizontalRefTextRotation() const | AcDbDimension |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbDimension) | AcDbDimension | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUsingDefaultTextPosition() const (defined in AcDbDimension) | AcDbDimension |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
jogSymbolOn() const (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
jogSymbolPosition() const (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kShapeAngular enum value (defined in AcDbDimension) | AcDbDimension |
kShapeLabel enum value (defined in AcDbDimension) | AcDbDimension |
kShapeNone enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRate enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRemove enum value (defined in AcDbDimension) | AcDbDimension |
kShapeRound enum value (defined in AcDbDimension) | AcDbDimension |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
measurement(double &val) (defined in AcDbDimension) | AcDbDimension |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbDimension) | AcDbDimension |
objectClosed(const AcDbObjectId dbObj) (defined in AcDbDimension) | AcDbDimension | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
oblique() const (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbDimension) | AcDbDimension | virtual
recomputeDimBlock(bool forceUpdate=true) (defined in AcDbDimension) | AcDbDimension |
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTextField() (defined in AcDbDimension) | AcDbDimension |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setArrowFirstIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setArrowSecondIsFlipped(bool bIsFlipped) (defined in AcDbDimension) | AcDbDimension |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDimBlockId(const AcDbObjectId &) (defined in AcDbDimension) | AcDbDimension |
setDimBlockPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setDimensionStyle(AcDbObjectId) (defined in AcDbDimension) | AcDbDimension |
setDimensionText(const ACHAR *) (defined in AcDbDimension) | AcDbDimension |
setDimExt1Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimExt2Linetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimfit(int) | AcDbDimension |
setDimLineLinetype(const AcDbObjectId linetype) (defined in AcDbDimension) | AcDbDimension |
setDimLinePoint(const AcGePoint3d &) (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
setDimstyleData(AcDbDimStyleTableRecord *pNewData) (defined in AcDbDimension) | AcDbDimension |
setDimstyleData(AcDbObjectId newDataId) (defined in AcDbDimension) | AcDbDimension |
setDimunit(int) | AcDbDimension |
setDynamicDimension(bool newVal) (defined in AcDbDimension) | AcDbDimension |
setElevation(double) (defined in AcDbDimension) | AcDbDimension |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorizontalRefTextRotation(bool newVal) | AcDbDimension |
setHorizontalRotation(double newVal) (defined in AcDbDimension) | AcDbDimension |
setInspection(bool val) (defined in AcDbDimension) | AcDbDimension |
setInspectionFrame(int frame) (defined in AcDbDimension) | AcDbDimension |
setInspectionLabel(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setInspectionRate(const ACHAR *label) (defined in AcDbDimension) | AcDbDimension |
setJogSymbolOn(bool value) (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
setJogSymbolPosition(const AcGePoint3d &pt) (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbDimension) | AcDbDimension |
setOblique(double) (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbDimension) | AcDbDimension | virtual
setRotation(double) (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
setTextAttachment(AcDbMText::AttachmentPoint eAtt) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingFactor(double dFactor) (defined in AcDbDimension) | AcDbDimension |
setTextLineSpacingStyle(AcDb::LineSpacingStyle eStyle) (defined in AcDbDimension) | AcDbDimension |
setTextPosition(const AcGePoint3d &) (defined in AcDbDimension) | AcDbDimension |
setTextRotation(double) (defined in AcDbDimension) | AcDbDimension |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXLine1Point(const AcGePoint3d &) (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
setXLine2Point(const AcGePoint3d &) (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textAttachment() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingFactor() const (defined in AcDbDimension) | AcDbDimension |
textLineSpacingStyle() const (defined in AcDbDimension) | AcDbDimension |
textPosition() const (defined in AcDbDimension) | AcDbDimension |
textRotation() const (defined in AcDbDimension) | AcDbDimension |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
useDefaultTextPosition() (defined in AcDbDimension) | AcDbDimension |
useSetTextPosition() (defined in AcDbDimension) | AcDbDimension |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xLine1Point() const (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
xLine2Point() const (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbDimension() (defined in AcDbDimension) | AcDbDimension |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRotatedDimension() (defined in AcDbRotatedDimension) | AcDbRotatedDimension |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSection Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbSection Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSection:

Public Types

enum | Height { kHeightAboveSectionLine = 0x1, kHeightBelowSectionLine = 0x2 }
enum | State { kPlane = (0x1 << 0), kBoundary = (0x1 << 1), kVolume = (0x1 << 2) }
enum SubItem {
kNone = 0, kSectionLine = (0x1 << 0), kSectionLineTop = (0x1 << 1), kSectionLineBottom = (0x1 << 2),
kBackLine = (0x1 << 3), kBackLineTop = (0x1 << 4), kBackLineBottom = (0x1 << 5), kVerticalLineTop = (0x1 << 6),
kVerticalLineBottom = (0x1 << 7)
}
- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSection)
ACDB_PORT | AcDbSection (void)
ACDB_PORT | AcDbSection (const AcGePoint3dArray &pts, const AcGeVector3d &verticalDir)
ACDB_PORT | AcDbSection (const AcGePoint3dArray &pts, const AcGeVector3d &verticalDir, const AcGeVector3d &vecViewingDir)
ACDB_PORT Acad::ErrorStatus | addVertex (int nInsertAt, const AcGePoint3d &pt)
ACDB_PORT Acad::ErrorStatus | createJog (const AcGePoint3d &ptOnSection)
virtual ACDB_PORT Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
ACDB_PORT Acad::ErrorStatus | enableLiveSection (bool bEnable)
ACDB_PORT Acad::ErrorStatus | generateSectionGeometry (AcDbEntity *pEnt, AcArray< AcDbEntity * > &intBoundaryEnts, AcArray< AcDbEntity * > &intFillEnts, AcArray< AcDbEntity * > &backgroundEnts, AcArray< AcDbEntity * > &foregroundEnts, AcArray< AcDbEntity * > &curveTangencyEnts) const
ACDB_PORT Acad::ErrorStatus | generateSectionGeometry (const AcArray< AcDbEntity * > &entset, AcArray< AcDbEntity * > &intBoundaryEnts, AcArray< AcDbEntity * > &intFillEnts, AcArray< AcDbEntity * > &backgroundEnts, AcArray< AcDbEntity * > &foregroundEnts, AcArray< AcDbEntity * > &curveTangencyEnts) const
virtual ACDB_PORT Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual ACDB_PORT Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual ACDB_PORT Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
ACDB_PORT const ACHAR * | getName (void) const
ACDB_PORT Acad::ErrorStatus | getName (AcString &sName) const
ACDB_PORT Acad::ErrorStatus | getName (ACHAR *&pszName) const
virtual ACDB_PORT Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
ACDB_PORT AcDbObjectId | getSettings (void) const
ACDB_PORT Acad::ErrorStatus | getSettings (AcDbSectionSettings *&pSettings, AcDb::OpenMode mode) const
ACDB_PORT Acad::ErrorStatus | getVertex (int nIndex, AcGePoint3d &pt) const
ACDB_PORT Acad::ErrorStatus | getVertices (AcGePoint3dArray &pts) const
ACDB_PORT double | height (AcDbSection::Height nHeightType) const
ACDB_PORT bool | hitTest (const AcGePoint3d &ptHit, int *pSegmentIndex, AcGePoint3d *ptOnSegment, AcDbSection::SubItem *pSubItem) const
ACDB_PORT AcCmColor | indicatorFillColor (void) const
ACDB_PORT int | indicatorTransparency (void) const
ACDB_PORT bool | isLiveSectionEnabled (void) const
virtual ACDB_PORT void | list (void) const
virtual ACDB_PORT Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACDB_PORT AcGeVector3d | normal (void) const
ACDB_PORT int | numVertices (void) const
ACDB_PORT Acad::ErrorStatus | plane (AcGeVector3d &uAxis, AcGeVector3d &vAxis) const
ACDB_PORT Acad::ErrorStatus | removeVertex (int nIndex)
ACDB_PORT Acad::ErrorStatus | setHeight (AcDbSection::Height nHeightType, double fHeight)
ACDB_PORT Acad::ErrorStatus | setIndicatorFillColor (const AcCmColor &color)
ACDB_PORT Acad::ErrorStatus | setIndicatorTransparency (int nTransparency)
ACDB_PORT Acad::ErrorStatus | setName (const ACHAR *pszName)
ACDB_PORT Acad::ErrorStatus | setState (AcDbSection::State nState)
ACDB_PORT Acad::ErrorStatus | setVertex (int nIndex, const AcGePoint3d &pt)
ACDB_PORT Acad::ErrorStatus | setVerticalDirection (const AcGeVector3d &dir)
ACDB_PORT Acad::ErrorStatus | setVertices (const AcGePoint3dArray &pts)
ACDB_PORT Acad::ErrorStatus | setViewingDirection (const AcGeVector3d &dir)
ACDB_PORT AcDbSection::State | state (void) const
virtual ACDB_PORT Acad::ErrorStatus | subClose ()
virtual ACDB_PORT Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
ACDB_PORT AcGeVector3d | verticalDirection (void) const
ACDB_PORT AcGeVector3d | viewingDirection (void) const
virtual ACDB_PORT Adesk::Boolean | worldDraw (AcGiWorldDraw *wd)
ACDB_PORT | ~AcDbSection (void)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

ACDB_PORT AcDbSection::AcDbSection ( void )
Warning
Not implemented!
ACDB_PORT AcDbSection::AcDbSection | ( | const AcGePoint3dArray & | pts,
 |  | const AcGeVector3d & | verticalDir
 | ) |  |
Warning
Not implemented!
ACDB_PORT AcDbSection::AcDbSection | ( | const AcGePoint3dArray & | pts,
 |  | const AcGeVector3d & | verticalDir,
 |  | const AcGeVector3d & | vecViewingDir
 | ) |  |
Warning
Not implemented!
ACDB_PORT AcDbSection::~AcDbSection ( void )
Warning
Not implemented!

Member Function Documentation

ACDB_PORT Acad::ErrorStatus AcDbSection::addVertex | ( | int | nInsertAt,
 |  | const AcGePoint3d & | pt
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::createJog ( const AcGePoint3d & ptOnSection )
Warning
Not implemented!
virtual ACDB_PORT Acad::ErrorStatus AcDbSection::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual ACDB_PORT Acad::ErrorStatus AcDbSection::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual ACDB_PORT Acad::ErrorStatus AcDbSection::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual ACDB_PORT Acad::ErrorStatus AcDbSection::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

ACDB_PORT Acad::ErrorStatus AcDbSection::enableLiveSection ( bool bEnable )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::generateSectionGeometry | ( | AcDbEntity * | pEnt,
 |  | AcArray< AcDbEntity * > & | intBoundaryEnts,
 |  | AcArray< AcDbEntity * > & | intFillEnts,
 |  | AcArray< AcDbEntity * > & | backgroundEnts,
 |  | AcArray< AcDbEntity * > & | foregroundEnts,
 |  | AcArray< AcDbEntity * > & | curveTangencyEnts
 | ) |  | const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::generateSectionGeometry | ( | const AcArray< AcDbEntity * > & | entset,
 |  | AcArray< AcDbEntity * > & | intBoundaryEnts,
 |  | AcArray< AcDbEntity * > & | intFillEnts,
 |  | AcArray< AcDbEntity * > & | backgroundEnts,
 |  | AcArray< AcDbEntity * > & | foregroundEnts,
 |  | AcArray< AcDbEntity * > & | curveTangencyEnts
 | ) |  | const
Warning
Not implemented!
virtual ACDB_PORT Acad::ErrorStatus AcDbSection::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual ACDB_PORT Acad::ErrorStatus AcDbSection::getGeomExtents ( AcDbExtents & extents ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual ACDB_PORT Acad::ErrorStatus AcDbSection::getGripPoints | ( | AcDbGripDataPtrArray & | grips,
 |  | const double | curViewUnitSize,
 |  | const int | gripSize,
 |  | const AcGeVector3d & | curViewDir,
 |  | const int | bitflags
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

ACDB_PORT const ACHAR* AcDbSection::getName ( void ) const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::getName ( AcString & sName ) const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::getName ( ACHAR *& pszName ) const
Warning
Not implemented!
virtual ACDB_PORT Acad::ErrorStatus AcDbSection::getOsnapPoints | ( | AcDb::OsnapMode | osnapMode,
 |  | Adesk::GsMarker | gsSelectionMark,
 |  | const AcGePoint3d & | pickPoint,
 |  | const AcGePoint3d & | lastPoint,
 |  | const AcGeMatrix3d & | viewXform,
 |  | AcGePoint3dArray & | snapPoints,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

ACDB_PORT AcDbObjectId AcDbSection::getSettings ( void ) const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::getSettings | ( | AcDbSectionSettings *& | pSettings,
 |  | AcDb::OpenMode | mode
 | ) |  | const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::getVertex | ( | int | nIndex,
 |  | AcGePoint3d & | pt
 | ) |  | const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::getVertices ( AcGePoint3dArray & pts ) const
Warning
Not implemented!
ACDB_PORT double AcDbSection::height ( AcDbSection::Height nHeightType ) const
Warning
Not implemented!
ACDB_PORT bool AcDbSection::hitTest | ( | const AcGePoint3d & | ptHit,
 |  | int * | pSegmentIndex,
 |  | AcGePoint3d * | ptOnSegment,
 |  | AcDbSection::SubItem * | pSubItem
 | ) |  | const
Warning
Not implemented!
ACDB_PORT AcCmColor AcDbSection::indicatorFillColor ( void ) const
Warning
Not implemented!
ACDB_PORT int AcDbSection::indicatorTransparency ( void ) const
Warning
Not implemented!
ACDB_PORT bool AcDbSection::isLiveSectionEnabled ( void ) const
Warning
Not implemented!
virtual ACDB_PORT void AcDbSection::list ( void ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual ACDB_PORT Acad::ErrorStatus AcDbSection::moveGripPointsAt | ( | const AcDbVoidPtrArray & | gripAppData,
 |  | const AcGeVector3d & | offset,
 |  | const int | bitflags
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

ACDB_PORT AcGeVector3d AcDbSection::normal ( void ) const
Warning
Not implemented!
ACDB_PORT int AcDbSection::numVertices ( void ) const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::plane | ( | AcGeVector3d & | uAxis,
 |  | AcGeVector3d & | vAxis
 | ) |  | const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::removeVertex ( int nIndex )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::setHeight | ( | AcDbSection::Height | nHeightType,
 |  | double | fHeight
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::setIndicatorFillColor ( const AcCmColor & color )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::setIndicatorTransparency ( int nTransparency )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::setName ( const ACHAR * pszName )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::setState ( AcDbSection::State nState )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::setVertex | ( | int | nIndex,
 |  | const AcGePoint3d & | pt
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::setVerticalDirection ( const AcGeVector3d & dir )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::setVertices ( const AcGePoint3dArray & pts )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSection::setViewingDirection ( const AcGeVector3d & dir )
Warning
Not implemented!
ACDB_PORT AcDbSection::State AcDbSection::state ( void ) const
Warning
Not implemented!
virtual ACDB_PORT Acad::ErrorStatus AcDbSection::subClose ( )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual ACDB_PORT Acad::ErrorStatus AcDbSection::transformBy ( const AcGeMatrix3d & xform )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

ACDB_PORT AcGeVector3d AcDbSection::verticalDirection ( void ) const
Warning
Not implemented!
ACDB_PORT AcGeVector3d AcDbSection::viewingDirection ( void ) const
Warning
Not implemented!
virtual ACDB_PORT Adesk::Boolean AcDbSection::worldDraw ( AcGiWorldDraw * wd )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

The documentation for this class was generated from the following file:
  • DbSection.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSection Member List

This is the complete list of members for AcDbSection, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSection) (defined in AcDbSection) | AcDbSection |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSection(void) | AcDbSection |
AcDbSection(const AcGePoint3dArray &pts, const AcGeVector3d &verticalDir) | AcDbSection |
AcDbSection(const AcGePoint3dArray &pts, const AcGeVector3d &verticalDir, const AcGeVector3d &vecViewingDir) | AcDbSection |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
addVertex(int nInsertAt, const AcGePoint3d &pt) | AcDbSection |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createJog(const AcGePoint3d &ptOnSection) | AcDbSection |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbSection | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbSection | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbSection | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbSection | virtual
enableLiveSection(bool bEnable) | AcDbSection |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
generateSectionGeometry(AcDbEntity *pEnt, AcArray< AcDbEntity * > &intBoundaryEnts, AcArray< AcDbEntity * > &intFillEnts, AcArray< AcDbEntity * > &backgroundEnts, AcArray< AcDbEntity * > &foregroundEnts, AcArray< AcDbEntity * > &curveTangencyEnts) const | AcDbSection |
generateSectionGeometry(const AcArray< AcDbEntity * > &entset, AcArray< AcDbEntity * > &intBoundaryEnts, AcArray< AcDbEntity * > &intFillEnts, AcArray< AcDbEntity * > &backgroundEnts, AcArray< AcDbEntity * > &foregroundEnts, AcArray< AcDbEntity * > &curveTangencyEnts) const | AcDbSection |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbSection | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const | AcDbSection | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const | AcDbSection | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getName(void) const | AcDbSection |
getName(AcString &sName) const | AcDbSection |
getName(ACHAR *&pszName) const | AcDbSection |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const | AcDbSection | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getSettings(void) const | AcDbSection |
getSettings(AcDbSectionSettings *&pSettings, AcDb::OpenMode mode) const | AcDbSection |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
getVertex(int nIndex, AcGePoint3d &pt) const | AcDbSection |
getVertices(AcGePoint3dArray &pts) const | AcDbSection |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
Height enum name (defined in AcDbSection) | AcDbSection |
height(AcDbSection::Height nHeightType) const | AcDbSection |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
hitTest(const AcGePoint3d &ptHit, int *pSegmentIndex, AcGePoint3d *ptOnSegment, AcDbSection::SubItem *pSubItem) const | AcDbSection |
id() const (defined in AcDbObject) | AcDbObject | virtual
indicatorFillColor(void) const | AcDbSection |
indicatorTransparency(void) const | AcDbSection |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLiveSectionEnabled(void) const | AcDbSection |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kBackLine enum value (defined in AcDbSection) | AcDbSection |
kBackLineBottom enum value (defined in AcDbSection) | AcDbSection |
kBackLineTop enum value (defined in AcDbSection) | AcDbSection |
kBoundary enum value (defined in AcDbSection) | AcDbSection |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHeightAboveSectionLine enum value (defined in AcDbSection) | AcDbSection |
kHeightBelowSectionLine enum value (defined in AcDbSection) | AcDbSection |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kNone enum value (defined in AcDbSection) | AcDbSection |
kPlane enum value (defined in AcDbSection) | AcDbSection |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSectionLine enum value (defined in AcDbSection) | AcDbSection |
kSectionLineBottom enum value (defined in AcDbSection) | AcDbSection |
kSectionLineTop enum value (defined in AcDbSection) | AcDbSection |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kVerticalLineBottom enum value (defined in AcDbSection) | AcDbSection |
kVerticalLineTop enum value (defined in AcDbSection) | AcDbSection |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kVolume enum value (defined in AcDbSection) | AcDbSection |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list(void) const | AcDbSection | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) | AcDbSection | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal(void) const | AcDbSection |
numVertices(void) const | AcDbSection |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plane(AcGeVector3d &uAxis, AcGeVector3d &vAxis) const | AcDbSection |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeVertex(int nIndex) | AcDbSection |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(AcDbSection::Height nHeightType, double fHeight) | AcDbSection |
setIndicatorFillColor(const AcCmColor &color) | AcDbSection |
setIndicatorTransparency(int nTransparency) | AcDbSection |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setName(const ACHAR *pszName) | AcDbSection |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setState(AcDbSection::State nState) | AcDbSection |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVertex(int nIndex, const AcGePoint3d &pt) | AcDbSection |
setVerticalDirection(const AcGeVector3d &dir) | AcDbSection |
setVertices(const AcGePoint3dArray &pts) | AcDbSection |
setViewingDirection(const AcGeVector3d &dir) | AcDbSection |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
State enum name (defined in AcDbSection) | AcDbSection |
state(void) const | AcDbSection |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() | AcDbSection | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
SubItem enum name (defined in AcDbSection) | AcDbSection |
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) | AcDbSection | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
verticalDirection(void) const | AcDbSection |
viewingDirection(void) const | AcDbSection |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *wd) | AcDbSection | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSection(void) | AcDbSection |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSectionManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSectionManager Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSectionManager:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSectionManager)
virtual ACDB_PORT Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | getClassID (CLSID *pClsid) const
ACDB_PORT Acad::ErrorStatus | getLiveSection (AcDbObjectId &id) const
ACDB_PORT Acad::ErrorStatus | getLiveSection (AcDbSection *&pSecPlane, AcDb::OpenMode mode) const
ACDB_PORT Acad::ErrorStatus | getSection (const ACHAR *pszName, AcDbObjectId &id) const
ACDB_PORT Acad::ErrorStatus | getSection (const ACHAR *pszName, AcDbSection *&pSecPlane, AcDb::OpenMode mode) const
ACDB_PORT Acad::ErrorStatus | getUniqueSectionName (const ACHAR *pszBaseName, ACHAR *&pszUniqueName) const
ACDB_PORT Acad::ErrorStatus | newIterator (AcDbSectionManagerIterator *&pIterator) const
ACDB_PORT int | numSections (void) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • DbSectionManager.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSectionManager Member List

This is the complete list of members for AcDbSectionManager, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSectionManager) (defined in AcDbSectionManager) | AcDbSectionManager |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSectionManager(void) (defined in AcDbSectionManager) | AcDbSectionManager |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbSectionManager) | AcDbSectionManager | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbSectionManager) | AcDbSectionManager | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbSectionManager) | AcDbSectionManager | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbSectionManager) | AcDbSectionManager | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbSectionManager) | AcDbSectionManager | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getLiveSection(AcDbObjectId &id) const (defined in AcDbSectionManager) | AcDbSectionManager |
getLiveSection(AcDbSection *&pSecPlane, AcDb::OpenMode mode) const (defined in AcDbSectionManager) | AcDbSectionManager |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getSection(const ACHAR *pszName, AcDbObjectId &id) const (defined in AcDbSectionManager) | AcDbSectionManager |
getSection(const ACHAR *pszName, AcDbSection *&pSecPlane, AcDb::OpenMode mode) const (defined in AcDbSectionManager) | AcDbSectionManager |
getUniqueSectionName(const ACHAR *pszBaseName, ACHAR *&pszUniqueName) const (defined in AcDbSectionManager) | AcDbSectionManager |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbSectionManagerIterator *&pIterator) const (defined in AcDbSectionManager) | AcDbSectionManager |
numSections(void) const (defined in AcDbSectionManager) | AcDbSectionManager |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSectionManager(void) (defined in AcDbSectionManager) | AcDbSectionManager |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSectionManagerIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AcDbSectionManagerIterator Class Reference
AcDb Classes

Public Member Functions

ACDB_PORT bool | done (void) const
ACDB_PORT AcDbObjectId | getSection (void) const
ACDB_PORT Acad::ErrorStatus | getSection (AcDbSection *&pSecPlane, AcDb::OpenMode openMode) const
ACDB_PORT void | start (void)
ACDB_PORT void | step (void)

Protected Member Functions

ACDB_PORT AcDbSectionManagerIterator (AcDbSectionManager *pMgr)

Protected Attributes

friend | AcDbImpSectionManager
void * | mpImpObj
The documentation for this class was generated from the following file:
  • DbSectionManager.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSectionManagerIterator Member List

This is the complete list of members for AcDbSectionManagerIterator, including all inherited members.

AcDbImpSectionManager (defined in AcDbSectionManagerIterator) | AcDbSectionManagerIterator | protected
AcDbSectionManagerIterator(AcDbSectionManager *pMgr) (defined in AcDbSectionManagerIterator) | AcDbSectionManagerIterator | protected
done(void) const (defined in AcDbSectionManagerIterator) | AcDbSectionManagerIterator |
getSection(void) const (defined in AcDbSectionManagerIterator) | AcDbSectionManagerIterator |
getSection(AcDbSection *&pSecPlane, AcDb::OpenMode openMode) const (defined in AcDbSectionManagerIterator) | AcDbSectionManagerIterator |
mpImpObj (defined in AcDbSectionManagerIterator) | AcDbSectionManagerIterator | protected
start(void) (defined in AcDbSectionManagerIterator) | AcDbSectionManagerIterator |
step(void) (defined in AcDbSectionManagerIterator) | AcDbSectionManagerIterator |
~AcDbSectionManagerIterator(void) (defined in AcDbSectionManagerIterator) | AcDbSectionManagerIterator | virtual


ZRX API Reference: AcDbSectionSettings Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbSectionSettings Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSectionSettings:

Public Types

enum Generation {
kSourceAllObjects = (0x1 << 0), kSourceSelectedObjects = (0x1 << 1), kDestinationNewBlock = (0x1 << 4), kDestinationReplaceBlock = (0x1 << 5),
kDestinationFile = (0x1 << 6)
}
enum Geometry {
kIntersectionBoundary = (0x1 << 0), kIntersectionFill = (0x1 << 1), kBackgroundGeometry = (0x1 << 2), kForegroundGeometry = (0x1 << 3),
kCurveTangencyLines = (0x1 << 4)
}
enum SectionType { kLiveSection = (0x1 << 0), k2dSection = (0x1 << 1), k3dSection = (0x1 << 2) }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSectionSettings)
AcDbSectionSettings ()
ACDB_PORT AcCmColor | color (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT
AcDbSectionSettings::SectionType 		currentSectionType (void) const
ACDB_PORT AcDbObjectId | destinationBlock (AcDbSectionSettings::SectionType nSecType) const
ACDB_PORT const ACHAR * | destinationFile (AcDbSectionSettings::SectionType nSecType) const
ACDB_PORT bool | divisionLines (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT int | edgeTransparency (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT int | faceTransparency (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT
AcDbSectionSettings::Generation 		generationOptions (AcDbSectionSettings::SectionType nSecType) const
virtual ACDB_PORT Acad::ErrorStatus | getClassID (CLSID *pClsid) const
ACDB_PORT Acad::ErrorStatus | getHatchPattern (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, AcDbHatch::HatchPatternType &nPatternType, const ACHAR *&pszPatternName) const
ACDB_PORT Acad::ErrorStatus | getSourceObjects (AcDbSectionSettings::SectionType nSecType, AcDbObjectIdArray &ids) const
ACDB_PORT double | hatchAngle (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT double | hatchScale (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT double | hatchSpacing (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT bool | hatchVisibility (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT bool | hiddenLine (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT const ACHAR * | layer (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT const ACHAR * | linetype (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT double | linetypeScale (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT AcDb::LineWeight | lineWeight (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT const ACHAR * | plotStyleName (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
ACDB_PORT Acad::ErrorStatus | reset (void)
ACDB_PORT Acad::ErrorStatus | reset (AcDbSectionSettings::SectionType nSecType)
ACDB_PORT Acad::ErrorStatus | setColor (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, const AcCmColor &color)
ACDB_PORT Acad::ErrorStatus | setCurrentSectionType (AcDbSectionSettings::SectionType nSecType)
ACDB_PORT Acad::ErrorStatus | setDestinationBlock (AcDbSectionSettings::SectionType nSecType, const AcDbObjectId &id)
ACDB_PORT Acad::ErrorStatus | setDestinationFile (AcDbSectionSettings::SectionType nSecType, const ACHAR *pszFileName)
ACDB_PORT Acad::ErrorStatus | setDivisionLines (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, bool bShow)
ACDB_PORT Acad::ErrorStatus | setEdgeTransparency (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, int nTransparency)
ACDB_PORT Acad::ErrorStatus | setFaceTransparency (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, int nTransparency)
ACDB_PORT Acad::ErrorStatus | setGenerationOptions (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Generation nOptions)
ACDB_PORT Acad::ErrorStatus | setHatchAngle (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, double fAngle)
ACDB_PORT Acad::ErrorStatus | setHatchPattern (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, AcDbHatch::HatchPatternType nPatternType, const ACHAR *pszPatternName)
ACDB_PORT Acad::ErrorStatus | setHatchScale (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, double fScale)
ACDB_PORT Acad::ErrorStatus | setHatchSpacing (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, double fSpacing)
ACDB_PORT Acad::ErrorStatus | setHatchVisibility (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, bool bVisible)
ACDB_PORT Acad::ErrorStatus | setHiddenLine (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, bool bHiddenLine)
ACDB_PORT Acad::ErrorStatus | setLayer (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, const ACHAR *pszLayer)
ACDB_PORT Acad::ErrorStatus | setLinetype (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, const ACHAR *pszLinetype)
ACDB_PORT Acad::ErrorStatus | setLinetypeScale (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, double fScale)
ACDB_PORT Acad::ErrorStatus | setLineWeight (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, AcDb::LineWeight nLineWeight)
ACDB_PORT Acad::ErrorStatus | setPlotStyleName (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, const ACHAR *pszPlotStyleName)
ACDB_PORT Acad::ErrorStatus | setSourceObjects (AcDbSectionSettings::SectionType nSecType, const AcDbObjectIdArray &ids)
ACDB_PORT Acad::ErrorStatus | setVisibility (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, bool bVisible)
ACDB_PORT bool | visibility (AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const
~AcDbSectionSettings ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbSectionSettings::AcDbSectionSettings ( )
Warning
Not implemented!
AcDbSectionSettings::~AcDbSectionSettings ( )
Warning
Not implemented!

Member Function Documentation

ACDB_PORT AcCmColor AcDbSectionSettings::color | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT AcDbSectionSettings::SectionType AcDbSectionSettings::currentSectionType ( void ) const
Warning
Not implemented!
ACDB_PORT AcDbObjectId AcDbSectionSettings::destinationBlock ( AcDbSectionSettings::SectionType nSecType ) const
Warning
Not implemented!
ACDB_PORT const ACHAR* AcDbSectionSettings::destinationFile ( AcDbSectionSettings::SectionType nSecType ) const
Warning
Not implemented!
ACDB_PORT bool AcDbSectionSettings::divisionLines | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT int AcDbSectionSettings::edgeTransparency | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT int AcDbSectionSettings::faceTransparency | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT AcDbSectionSettings::Generation AcDbSectionSettings::generationOptions ( AcDbSectionSettings::SectionType nSecType ) const
Warning
Not implemented!
virtual ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::getHatchPattern | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | AcDbHatch::HatchPatternType & | nPatternType,
 |  | const ACHAR *& | pszPatternName
 | ) |  | const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::getSourceObjects | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbObjectIdArray & | ids
 | ) |  | const
Warning
Not implemented!
ACDB_PORT double AcDbSectionSettings::hatchAngle | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT double AcDbSectionSettings::hatchScale | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT double AcDbSectionSettings::hatchSpacing | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT bool AcDbSectionSettings::hatchVisibility | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT bool AcDbSectionSettings::hiddenLine | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT const ACHAR* AcDbSectionSettings::layer | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT const ACHAR* AcDbSectionSettings::linetype | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT double AcDbSectionSettings::linetypeScale | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT AcDb::LineWeight AcDbSectionSettings::lineWeight | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT const ACHAR* AcDbSectionSettings::plotStyleName | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::reset ( void )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::reset ( AcDbSectionSettings::SectionType nSecType )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setColor | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | const AcCmColor & | color
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setCurrentSectionType ( AcDbSectionSettings::SectionType nSecType )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setDestinationBlock | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | const AcDbObjectId & | id
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setDestinationFile | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | const ACHAR * | pszFileName
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setDivisionLines | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | bool | bShow
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setEdgeTransparency | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | int | nTransparency
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setFaceTransparency | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | int | nTransparency
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setGenerationOptions | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Generation | nOptions
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setHatchAngle | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | double | fAngle
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setHatchPattern | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | AcDbHatch::HatchPatternType | nPatternType,
 |  | const ACHAR * | pszPatternName
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setHatchScale | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | double | fScale
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setHatchSpacing | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | double | fSpacing
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setHatchVisibility | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | bool | bVisible
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setHiddenLine | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | bool | bHiddenLine
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setLayer | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | const ACHAR * | pszLayer
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setLinetype | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | const ACHAR * | pszLinetype
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setLinetypeScale | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | double | fScale
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setLineWeight | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | AcDb::LineWeight | nLineWeight
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setPlotStyleName | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | const ACHAR * | pszPlotStyleName
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setSourceObjects | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | const AcDbObjectIdArray & | ids
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus AcDbSectionSettings::setVisibility | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry,
 |  | bool | bVisible
 | ) |  |
Warning
Not implemented!
ACDB_PORT bool AcDbSectionSettings::visibility | ( | AcDbSectionSettings::SectionType | nSecType,
 |  | AcDbSectionSettings::Geometry | nGeometry
 | ) |  | const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • DbSection.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSectionSettings Member List

This is the complete list of members for AcDbSectionSettings, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSectionSettings) (defined in AcDbSectionSettings) | AcDbSectionSettings |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSectionSettings() | AcDbSectionSettings |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
color(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
currentSectionType(void) const | AcDbSectionSettings |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
destinationBlock(AcDbSectionSettings::SectionType nSecType) const | AcDbSectionSettings |
destinationFile(AcDbSectionSettings::SectionType nSecType) const | AcDbSectionSettings |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
divisionLines(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
edgeTransparency(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
faceTransparency(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
Generation enum name (defined in AcDbSectionSettings) | AcDbSectionSettings |
generationOptions(AcDbSectionSettings::SectionType nSecType) const | AcDbSectionSettings |
Geometry enum name (defined in AcDbSectionSettings) | AcDbSectionSettings |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbSectionSettings | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getHatchPattern(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, AcDbHatch::HatchPatternType &nPatternType, const ACHAR *&pszPatternName) const | AcDbSectionSettings |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getSourceObjects(AcDbSectionSettings::SectionType nSecType, AcDbObjectIdArray &ids) const | AcDbSectionSettings |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hatchAngle(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
hatchScale(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
hatchSpacing(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
hatchVisibility(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
hiddenLine(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
k2dSection enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
k3dSection enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kBackgroundGeometry enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kCurveTangencyLines enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kDestinationFile enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kDestinationNewBlock enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kDestinationReplaceBlock enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kForegroundGeometry enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kIntersectionBoundary enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kIntersectionFill enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kLiveSection enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSourceAllObjects enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kSourceSelectedObjects enum value (defined in AcDbSectionSettings) | AcDbSectionSettings |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
linetype(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
linetypeScale(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
lineWeight(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
reset(void) | AcDbSectionSettings |
reset(AcDbSectionSettings::SectionType nSecType) | AcDbSectionSettings |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
SectionType enum name (defined in AcDbSectionSettings) | AcDbSectionSettings |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setColor(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, const AcCmColor &color) | AcDbSectionSettings |
setCurrentSectionType(AcDbSectionSettings::SectionType nSecType) | AcDbSectionSettings |
setDestinationBlock(AcDbSectionSettings::SectionType nSecType, const AcDbObjectId &id) | AcDbSectionSettings |
setDestinationFile(AcDbSectionSettings::SectionType nSecType, const ACHAR *pszFileName) | AcDbSectionSettings |
setDivisionLines(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, bool bShow) | AcDbSectionSettings |
setEdgeTransparency(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, int nTransparency) | AcDbSectionSettings |
setFaceTransparency(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, int nTransparency) | AcDbSectionSettings |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGenerationOptions(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Generation nOptions) | AcDbSectionSettings |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHatchAngle(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, double fAngle) | AcDbSectionSettings |
setHatchPattern(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, AcDbHatch::HatchPatternType nPatternType, const ACHAR *pszPatternName) | AcDbSectionSettings |
setHatchScale(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, double fScale) | AcDbSectionSettings |
setHatchSpacing(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, double fSpacing) | AcDbSectionSettings |
setHatchVisibility(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, bool bVisible) | AcDbSectionSettings |
setHiddenLine(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, bool bHiddenLine) | AcDbSectionSettings |
setLayer(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, const ACHAR *pszLayer) | AcDbSectionSettings |
setLinetype(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, const ACHAR *pszLinetype) | AcDbSectionSettings |
setLinetypeScale(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, double fScale) | AcDbSectionSettings |
setLineWeight(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, AcDb::LineWeight nLineWeight) | AcDbSectionSettings |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, const ACHAR *pszPlotStyleName) | AcDbSectionSettings |
setSourceObjects(AcDbSectionSettings::SectionType nSecType, const AcDbObjectIdArray &ids) | AcDbSectionSettings |
setVisibility(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry, bool bVisible) | AcDbSectionSettings |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility(AcDbSectionSettings::SectionType nSecType, AcDbSectionSettings::Geometry nGeometry) const | AcDbSectionSettings |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSectionSettings() | AcDbSectionSettings |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSelectGrip Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSelectGrip Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSelectGrip:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbSelectGrip)
virtual bool | SelectGrip (const AcDbEntity *pEnt, const AcGiViewportDraw *pVd, const void *pAppData)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbSelectGrip.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSelectGrip Member List

This is the complete list of members for AcDbSelectGrip, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbSelectGrip) (defined in AcDbSelectGrip) | AcDbSelectGrip |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
SelectGrip(const AcDbEntity *pEnt, const AcGiViewportDraw *pVd, const void *pAppData)=0 (defined in AcDbSelectGrip) | AcDbSelectGrip | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSequenceEnd Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSequenceEnd Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSequenceEnd:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSequenceEnd)
virtual bool | castShadows () const
virtual bool | receiveShadows () const
virtual void | setCastShadows (bool newVal)
virtual void | setReceiveShadows (bool newVal)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSequenceEnd Member List

This is the complete list of members for AcDbSequenceEnd, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSequenceEnd) (defined in AcDbSequenceEnd) | AcDbSequenceEnd |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSequenceEnd() (defined in AcDbSequenceEnd) | AcDbSequenceEnd |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbSequenceEnd) | AcDbSequenceEnd | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbSequenceEnd) | AcDbSequenceEnd | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbSequenceEnd) | AcDbSequenceEnd | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbSequenceEnd) | AcDbSequenceEnd | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSequenceEnd() (defined in AcDbSequenceEnd) | AcDbSequenceEnd |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbServices Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbServices Class Reference
AcDb Classes
+ Inheritance diagram for AcDbServices:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbServices)
- Public Member Functions inherited from AcRxService
ACRX_DECLARE_MEMBERS (AcRxService)
void | addDependency ()
DepFuncPtr | dependencyFunctionPtr ()
AcRxObject * | getSysInfo () const
void | removeDependency ()
void | setDependencyFunctionPtr (DepFuncPtr)
void | setSysInfo (AcRxObject *sysInfoObj)
Adesk::Boolean | unloadable () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbServices Member List

This is the complete list of members for AcDbServices, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbServices) (defined in AcDbServices) | AcDbServices |
ACRX_DECLARE_MEMBERS(AcRxService) (defined in AcRxService) | AcRxService |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
AcRxService() (defined in AcRxService) | AcRxService |
addDependency() (defined in AcRxService) | AcRxService |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
dependencyFunctionPtr() (defined in AcRxService) | AcRxService |
desc() (defined in AcRxObject) | AcRxObject | static
getSysInfo() const (defined in AcRxService) | AcRxService |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeDependency() (defined in AcRxService) | AcRxService |
setDependencyFunctionPtr(DepFuncPtr) (defined in AcRxService) | AcRxService |
setSysInfo(AcRxObject *sysInfoObj) (defined in AcRxService) | AcRxService |
unloadable() const (defined in AcRxService) | AcRxService |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~AcRxService() (defined in AcRxService) | AcRxService | virtual


ZRX API Reference: AcDbShape Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbShape Class Reference
AcDb Classes
+ Inheritance diagram for AcDbShape:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbShape)
AcDbShape (const AcGePoint3d &position, double size, double rotation=0, double widthFactor=0)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | name () const
AcGeVector3d | normal () const
double | oblique () const
AcGePoint3d | position () const
double | rotation () const
Acad::ErrorStatus | setName (const ACHAR *)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setOblique (double)
Acad::ErrorStatus | setPosition (const AcGePoint3d &)
Acad::ErrorStatus | setRotation (double)
Acad::ErrorStatus | setShapeIndex (AcDbObjectId id)
Acad::ErrorStatus | setShapeNumber (Adesk::Int16)
Acad::ErrorStatus | setSize (double)
Acad::ErrorStatus | setStyleId (AcDbObjectId id)
Acad::ErrorStatus | setThickness (double)
Acad::ErrorStatus | setWidthFactor (double)
AcDbObjectId | shapeIndex () const
Adesk::Int16 | shapeNumber () const
double | size () const
AcDbObjectId | styleId () const
double | thickness () const
double | widthFactor () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbShape Member List

This is the complete list of members for AcDbShape, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbShape) (defined in AcDbShape) | AcDbShape |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbShape() (defined in AcDbShape) | AcDbShape |
AcDbShape(const AcGePoint3d &position, double size, double rotation=0, double widthFactor=0) (defined in AcDbShape) | AcDbShape |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbShape) | AcDbShape | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbShape) | AcDbShape | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbShape) | AcDbShape | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
name() const (defined in AcDbShape) | AcDbShape |
normal() const (defined in AcDbShape) | AcDbShape |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
oblique() const (defined in AcDbShape) | AcDbShape |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbShape) | AcDbShape |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const (defined in AcDbShape) | AcDbShape |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setName(const ACHAR *) (defined in AcDbShape) | AcDbShape |
setNormal(const AcGeVector3d &) (defined in AcDbShape) | AcDbShape |
setOblique(double) (defined in AcDbShape) | AcDbShape |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbShape) | AcDbShape |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double) (defined in AcDbShape) | AcDbShape |
setShapeIndex(AcDbObjectId id) (defined in AcDbShape) | AcDbShape | inline
setShapeNumber(Adesk::Int16) (defined in AcDbShape) | AcDbShape |
setSize(double) (defined in AcDbShape) | AcDbShape |
setStyleId(AcDbObjectId id) (defined in AcDbShape) | AcDbShape |
setThickness(double) (defined in AcDbShape) | AcDbShape |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWidthFactor(double) (defined in AcDbShape) | AcDbShape |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shapeIndex() const (defined in AcDbShape) | AcDbShape | inline
shapeNumber() const (defined in AcDbShape) | AcDbShape |
size() const (defined in AcDbShape) | AcDbShape |
styleId() const (defined in AcDbShape) | AcDbShape |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thickness() const (defined in AcDbShape) | AcDbShape |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
widthFactor() const (defined in AcDbShape) | AcDbShape |
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbShape() (defined in AcDbShape) | AcDbShape |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSkyBackground Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbSkyBackground Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSkyBackground:

Public Member Functions

AcDbSkyBackground ()
ACRX_DECLARE_MEMBERS (AcDbSkyBackground)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcGiDrawable::DrawableType | drawableType () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setSunId (AcDbObjectId sunId)
AcDbObjectId | sunId (void) const
virtual | ~AcDbSkyBackground ()
- Public Member Functions inherited from AcDbBackground
ACRX_DECLARE_MEMBERS (AcDbBackground)
virtual AcGiDrawable * | drawable ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpSkyBackground

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcDbBackground
AcDbBackground (AcDbImpBackground *pImp)
AcDbImpBackground * | imp () const

Constructor & Destructor Documentation

AcDbSkyBackground::AcDbSkyBackground ( )
Warning
Not implemented!
virtual AcDbSkyBackground::~AcDbSkyBackground ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbSkyBackground::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual AcGiDrawable::DrawableType AcDbSkyBackground::drawableType ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiDrawable.

virtual Acad::ErrorStatus AcDbSkyBackground::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSkyBackground::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSkyBackground::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSkyBackground::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Adesk::UInt32 AcDbSkyBackground::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

Acad::ErrorStatus AcDbSkyBackground::setSunId ( AcDbObjectId sunId )
Warning
Not implemented!
AcDbObjectId AcDbSkyBackground::sunId ( void ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbbackground.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSkyBackground Member List

This is the complete list of members for AcDbSkyBackground, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBackground(AcDbImpBackground *pImp) (defined in AcDbBackground) | AcDbBackground | protected
AcDbImpSkyBackground (defined in AcDbSkyBackground) | AcDbSkyBackground | friend
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSkyBackground() | AcDbSkyBackground |
ACRX_DECLARE_MEMBERS(AcDbSkyBackground) (defined in AcDbSkyBackground) | AcDbSkyBackground |
ACRX_DECLARE_MEMBERS(AcDbBackground) (defined in AcDbBackground) | AcDbBackground |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) | AcDbSkyBackground | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbBackground) | AcDbBackground | virtual
drawableType() const | AcDbSkyBackground | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbSkyBackground | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbSkyBackground | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbSkyBackground | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbSkyBackground | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imp() const (defined in AcDbBackground) | AcDbBackground | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbSkyBackground | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setSunId(AcDbObjectId sunId) | AcDbSkyBackground |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
sunId(void) const | AcDbSkyBackground |
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBackground() (defined in AcDbBackground) | AcDbBackground | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSkyBackground() | AcDbSkyBackground | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSoftOwnershipId Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSoftOwnershipId Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSoftOwnershipId:

Public Member Functions

AcDbSoftOwnershipId (const AcDbObjectId &)
AcDbSoftOwnershipId (const AcDbStub *)
operator AcDbStub * () const
bool | operator!= (const AcDbObjectId &) const
bool | operator!= (const AcDbStub *) const
AcDbSoftOwnershipId & | operator= (const AcDbSoftOwnershipId &)
AcDbSoftOwnershipId & | operator= (const AcDbObjectId &)
AcDbSoftOwnershipId & | operator= (const AcDbStub *)
bool | operator== (const AcDbObjectId &) const
bool | operator== (const AcDbStub *) const
- Public Member Functions inherited from AcDbObjectId
AcDbObjectId (const AcDbStub *)
Adesk::IntDbId | asOldId () const
void | convertToRedirectedId ()
AcDbDatabase * | database () const
AcDbHandle | handle () const
bool | isEffectivelyErased () const
bool | isErased () const
bool | isNull () const
bool | isResident () const
bool | isValid () const
AcDbHandle | nonForwardedHandle () const
bool | objectLeftOnDisk () const
bool | operator< (const AcDbObjectId &) const
bool | operator< (const AcDbStub *) const
bool | operator<= (const AcDbObjectId &) const
bool | operator<= (const AcDbStub *) const
bool | operator> (const AcDbObjectId &) const
bool | operator> (const AcDbStub *) const
bool | operator>= (const AcDbObjectId &) const
bool | operator>= (const AcDbStub *) const
AcDbDatabase * | originalDatabase () const
AcDbObjectId & | setFromOldId (Adesk::IntDbId oldId)
void | setNull ()

Additional Inherited Members

- Static Public Attributes inherited from AcDbObjectId
static ZRX_DB_STATIC_EXPORT
const AcDbObjectId 		kNull
- Protected Attributes inherited from AcDbObjectId
AcDbStub * mId
The documentation for this class was generated from the following file:
  • dbid.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSoftOwnershipId Member List

This is the complete list of members for AcDbSoftOwnershipId, including all inherited members.

AcDbObjectId() (defined in AcDbObjectId) | AcDbObjectId | inline
AcDbObjectId(const AcDbStub *) (defined in AcDbObjectId) | AcDbObjectId | inline
AcDbSoftOwnershipId() (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
AcDbSoftOwnershipId(const AcDbObjectId &) (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
AcDbSoftOwnershipId(const AcDbStub *) (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
asOldId() const (defined in AcDbObjectId) | AcDbObjectId | inline
convertToRedirectedId() (defined in AcDbObjectId) | AcDbObjectId |
database() const (defined in AcDbObjectId) | AcDbObjectId |
handle() const (defined in AcDbObjectId) | AcDbObjectId |
isEffectivelyErased() const (defined in AcDbObjectId) | AcDbObjectId |
isErased() const (defined in AcDbObjectId) | AcDbObjectId |
isNull() const (defined in AcDbObjectId) | AcDbObjectId | inline
isResident() const | AcDbObjectId |
isValid() const (defined in AcDbObjectId) | AcDbObjectId |
kNull (defined in AcDbObjectId) | AcDbObjectId | static
mId (defined in AcDbObjectId) | AcDbObjectId | protected
nonForwardedHandle() const (defined in AcDbObjectId) | AcDbObjectId |
objectLeftOnDisk() const (defined in AcDbObjectId) | AcDbObjectId |
operator AcDbStub *() const (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
operator!=(const AcDbObjectId &) const (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
operator!=(const AcDbStub *) const (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
operator<(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator=(const AcDbSoftOwnershipId &) (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
operator=(const AcDbObjectId &) (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
operator=(const AcDbStub *) (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
operator==(const AcDbObjectId &) const (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
operator==(const AcDbStub *) const (defined in AcDbSoftOwnershipId) | AcDbSoftOwnershipId | inline
operator>(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
originalDatabase() const (defined in AcDbObjectId) | AcDbObjectId |
setFromOldId(Adesk::IntDbId oldId) (defined in AcDbObjectId) | AcDbObjectId | inline
setNull() (defined in AcDbObjectId) | AcDbObjectId | inline


ZRX API Reference: AcDbSoftPointerId Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSoftPointerId Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSoftPointerId:

Public Member Functions

AcDbSoftPointerId (const AcDbObjectId &)
AcDbSoftPointerId (const AcDbStub *)
operator AcDbStub * () const
bool | operator!= (const AcDbObjectId &) const
bool | operator!= (const AcDbStub *) const
AcDbSoftPointerId & | operator= (const AcDbSoftPointerId &)
AcDbSoftPointerId & | operator= (const AcDbObjectId &)
AcDbSoftPointerId & | operator= (const AcDbStub *)
bool | operator== (const AcDbObjectId &) const
bool | operator== (const AcDbStub *) const
- Public Member Functions inherited from AcDbObjectId
AcDbObjectId (const AcDbStub *)
Adesk::IntDbId | asOldId () const
void | convertToRedirectedId ()
AcDbDatabase * | database () const
AcDbHandle | handle () const
bool | isEffectivelyErased () const
bool | isErased () const
bool | isNull () const
bool | isResident () const
bool | isValid () const
AcDbHandle | nonForwardedHandle () const
bool | objectLeftOnDisk () const
bool | operator< (const AcDbObjectId &) const
bool | operator< (const AcDbStub *) const
bool | operator<= (const AcDbObjectId &) const
bool | operator<= (const AcDbStub *) const
bool | operator> (const AcDbObjectId &) const
bool | operator> (const AcDbStub *) const
bool | operator>= (const AcDbObjectId &) const
bool | operator>= (const AcDbStub *) const
AcDbDatabase * | originalDatabase () const
AcDbObjectId & | setFromOldId (Adesk::IntDbId oldId)
void | setNull ()

Additional Inherited Members

- Static Public Attributes inherited from AcDbObjectId
static ZRX_DB_STATIC_EXPORT
const AcDbObjectId 		kNull
- Protected Attributes inherited from AcDbObjectId
AcDbStub * mId
The documentation for this class was generated from the following file:
  • dbid.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSoftPointerId Member List

This is the complete list of members for AcDbSoftPointerId, including all inherited members.

AcDbObjectId() (defined in AcDbObjectId) | AcDbObjectId | inline
AcDbObjectId(const AcDbStub *) (defined in AcDbObjectId) | AcDbObjectId | inline
AcDbSoftPointerId() (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
AcDbSoftPointerId(const AcDbObjectId &) (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
AcDbSoftPointerId(const AcDbStub *) (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
asOldId() const (defined in AcDbObjectId) | AcDbObjectId | inline
convertToRedirectedId() (defined in AcDbObjectId) | AcDbObjectId |
database() const (defined in AcDbObjectId) | AcDbObjectId |
handle() const (defined in AcDbObjectId) | AcDbObjectId |
isEffectivelyErased() const (defined in AcDbObjectId) | AcDbObjectId |
isErased() const (defined in AcDbObjectId) | AcDbObjectId |
isNull() const (defined in AcDbObjectId) | AcDbObjectId | inline
isResident() const | AcDbObjectId |
isValid() const (defined in AcDbObjectId) | AcDbObjectId |
kNull (defined in AcDbObjectId) | AcDbObjectId | static
mId (defined in AcDbObjectId) | AcDbObjectId | protected
nonForwardedHandle() const (defined in AcDbObjectId) | AcDbObjectId |
objectLeftOnDisk() const (defined in AcDbObjectId) | AcDbObjectId |
operator AcDbStub *() const (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
operator!=(const AcDbObjectId &) const (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
operator!=(const AcDbStub *) const (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
operator<(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator<=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator=(const AcDbSoftPointerId &) (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
operator=(const AcDbObjectId &) (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
operator=(const AcDbStub *) (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
operator==(const AcDbObjectId &) const (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
operator==(const AcDbStub *) const (defined in AcDbSoftPointerId) | AcDbSoftPointerId | inline
operator>(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbObjectId &) const (defined in AcDbObjectId) | AcDbObjectId | inline
operator>=(const AcDbStub *) const (defined in AcDbObjectId) | AcDbObjectId | inline
originalDatabase() const (defined in AcDbObjectId) | AcDbObjectId |
setFromOldId(Adesk::IntDbId oldId) (defined in AcDbObjectId) | AcDbObjectId | inline
setNull() (defined in AcDbObjectId) | AcDbObjectId | inline


ZRX API Reference: AcDbSolid Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSolid Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSolid:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSolid)
AcDbSolid (const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2, const AcGePoint3d &pt3)
AcDbSolid (const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getPointAt (Adesk::UInt16 idx, AcGePoint3d &pntRes) const
Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
AcGeVector3d | normal () const
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setPointAt (Adesk::UInt16 idx, const AcGePoint3d &)
Acad::ErrorStatus | setThickness (double)
double | thickness () const
Acad::ErrorStatus | transformBy (const AcGeMatrix3d &pXform)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSolid Member List

This is the complete list of members for AcDbSolid, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSolid) (defined in AcDbSolid) | AcDbSolid |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSolid() (defined in AcDbSolid) | AcDbSolid |
AcDbSolid(const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2, const AcGePoint3d &pt3) (defined in AcDbSolid) | AcDbSolid |
AcDbSolid(const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2) (defined in AcDbSolid) | AcDbSolid |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbSolid) | AcDbSolid | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAt(Adesk::UInt16 idx, AcGePoint3d &pntRes) const (defined in AcDbSolid) | AcDbSolid |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbSolid) | AcDbSolid | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbSolid) | AcDbSolid |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbSolid) | AcDbSolid |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPointAt(Adesk::UInt16 idx, const AcGePoint3d &) (defined in AcDbSolid) | AcDbSolid |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setThickness(double) (defined in AcDbSolid) | AcDbSolid |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thickness() const (defined in AcDbSolid) | AcDbSolid |
transformBy(const AcGeMatrix3d &pXform) (defined in AcDbSolid) | AcDbSolid | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSolid() (defined in AcDbSolid) | AcDbSolid |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSolidBackground Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbSolidBackground Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSolidBackground:

Public Member Functions

AcDbSolidBackground ()
ACRX_DECLARE_MEMBERS (AcDbSolidBackground)
AcCmEntityColor | colorSolid (void) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcGiDrawable::DrawableType | drawableType () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
void | setColorSolid (const AcCmEntityColor &color)
virtual | ~AcDbSolidBackground ()
- Public Member Functions inherited from AcDbBackground
ACRX_DECLARE_MEMBERS (AcDbBackground)
virtual AcGiDrawable * | drawable ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbImpSolidBackground

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcDbBackground
AcDbBackground (AcDbImpBackground *pImp)
AcDbImpBackground * | imp () const

Constructor & Destructor Documentation

AcDbSolidBackground::AcDbSolidBackground ( )
Warning
Not implemented!
virtual AcDbSolidBackground::~AcDbSolidBackground ( )
virtual
Warning
Not implemented!

Member Function Documentation

AcCmEntityColor AcDbSolidBackground::colorSolid ( void ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSolidBackground::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual AcGiDrawable::DrawableType AcDbSolidBackground::drawableType ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiDrawable.

virtual Acad::ErrorStatus AcDbSolidBackground::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSolidBackground::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSolidBackground::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSolidBackground::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Adesk::UInt32 AcDbSolidBackground::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

void AcDbSolidBackground::setColorSolid ( const AcCmEntityColor & color )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbbackground.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSolidBackground Member List

This is the complete list of members for AcDbSolidBackground, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBackground(AcDbImpBackground *pImp) (defined in AcDbBackground) | AcDbBackground | protected
AcDbImpSolidBackground (defined in AcDbSolidBackground) | AcDbSolidBackground | friend
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSolidBackground() | AcDbSolidBackground |
ACRX_DECLARE_MEMBERS(AcDbSolidBackground) (defined in AcDbSolidBackground) | AcDbSolidBackground |
ACRX_DECLARE_MEMBERS(AcDbBackground) (defined in AcDbBackground) | AcDbBackground |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
colorSolid(void) const | AcDbSolidBackground |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *other) | AcDbSolidBackground | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbBackground) | AcDbBackground | virtual
drawableType() const | AcDbSolidBackground | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbSolidBackground | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbSolidBackground | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbSolidBackground | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbSolidBackground | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
imp() const (defined in AcDbBackground) | AcDbBackground | protected
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) | AcDbSolidBackground | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setColorSolid(const AcCmEntityColor &color) | AcDbSolidBackground |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBackground() (defined in AcDbBackground) | AcDbBackground | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSolidBackground() | AcDbSolidBackground | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSpatialFilter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSpatialFilter Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSpatialFilter:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSpatialFilter)
AcDbSpatialFilter (const AcGePoint2dArray &pts, const AcGeVector3d &normal, double elevation, double frontClip, double backClip, Adesk::Boolean enabled)
Adesk::Boolean | clipVolumeIntersectsExtents (const AcDbExtents &ext) const
AcGeMatrix3d & | getClipSpaceToWCSMatrix (AcGeMatrix3d &mat) const
Acad::ErrorStatus | getDefinition (AcGePoint2dArray &pts, AcGeVector3d &normal, double &elevation, double &frontClip, double &backClip, Adesk::Boolean &enabled) const
AcGeMatrix3d & | getOriginalInverseBlockXform (AcGeMatrix3d &mat) const
Acad::ErrorStatus | getVolume (AcGePoint3d &fromPt, AcGePoint3d &toPt, AcGeVector3d &upDir, AcGeVector2d &viewField) const
Adesk::Boolean | hasPerspectiveCamera () const
virtual AcRxClass * | indexClass () const
virtual void | queryBounds (AcDbExtents &ext, const AcDbBlockReference *pRefBlkRef) const
void | queryBounds (AcDbExtents &ext) const
Acad::ErrorStatus | setDefinition (const AcGePoint2dArray &pts, const AcGeVector3d &normal, double elevation, double frontClip, double backClip, Adesk::Boolean enabled)
Acad::ErrorStatus | setPerspectiveCamera (const AcGePoint3d &fromPt)
- Public Member Functions inherited from AcDbFilter
ACDB_DECLARE_MEMBERS (AcDbFilter)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

AcGeMatrix3d& AcDbSpatialFilter::getClipSpaceToWCSMatrix ( AcGeMatrix3d & mat ) const
Warning
Not implemented!
AcGeMatrix3d& AcDbSpatialFilter::getOriginalInverseBlockXform ( AcGeMatrix3d & mat ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbspfilt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSpatialFilter Member List

This is the complete list of members for AcDbSpatialFilter, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSpatialFilter) (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
ACDB_DECLARE_MEMBERS(AcDbFilter) (defined in AcDbFilter) | AcDbFilter |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbFilter() (defined in AcDbFilter) | AcDbFilter |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSpatialFilter() (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
AcDbSpatialFilter(const AcGePoint2dArray &pts, const AcGeVector3d &normal, double elevation, double frontClip, double backClip, Adesk::Boolean enabled) (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clipVolumeIntersectsExtents(const AcDbExtents &ext) const (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getClipSpaceToWCSMatrix(AcGeMatrix3d &mat) const | AcDbSpatialFilter |
getDefinition(AcGePoint2dArray &pts, AcGeVector3d &normal, double &elevation, double &frontClip, double &backClip, Adesk::Boolean &enabled) const (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOriginalInverseBlockXform(AcGeMatrix3d &mat) const | AcDbSpatialFilter |
getVolume(AcGePoint3d &fromPt, AcGePoint3d &toPt, AcGeVector3d &upDir, AcGeVector2d &viewField) const (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasPerspectiveCamera() const (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
indexClass() const (defined in AcDbSpatialFilter) | AcDbSpatialFilter | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryBounds(AcDbExtents &ext, const AcDbBlockReference *pRefBlkRef) const (defined in AcDbSpatialFilter) | AcDbSpatialFilter | virtual
queryBounds(AcDbExtents &ext) const (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDefinition(const AcGePoint2dArray &pts, const AcGeVector3d &normal, double elevation, double frontClip, double backClip, Adesk::Boolean enabled) (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPerspectiveCamera(const AcGePoint3d &fromPt) (defined in AcDbSpatialFilter) | AcDbSpatialFilter |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbFilter() (defined in AcDbFilter) | AcDbFilter | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSpatialFilter() (defined in AcDbSpatialFilter) | AcDbSpatialFilter | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSpatialIndex Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcDbSpatialIndex Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSpatialIndex:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSpatialIndex)
virtual AcDbFilteredBlockIterator * | newIterator (const AcDbFilter *pFilter) const
virtual Acad::ErrorStatus | rebuildFull (AcDbIndexUpdateData *pIdxData)
- Public Member Functions inherited from AcDbIndex
ACDB_DECLARE_MEMBERS (AcDbIndex)
Adesk::Boolean | isUptoDate () const
AcDbDate | lastUpdatedAt () const
AcDbDate | lastUpdatedAtU () const
virtual AcDbObjectId | objectBeingIndexedId () const
void | setLastUpdatedAt (const AcDbDate &time)
void | setLastUpdatedAtU (const AcDbDate &time)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

virtual Acad::ErrorStatus rebuildModified (AcDbBlockChangeIterator *iter)

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbspindx.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSpatialIndex Member List

This is the complete list of members for AcDbSpatialIndex, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSpatialIndex) (defined in AcDbSpatialIndex) | AcDbSpatialIndex |
ACDB_DECLARE_MEMBERS(AcDbIndex) (defined in AcDbIndex) | AcDbIndex |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbIndex() (defined in AcDbIndex) | AcDbIndex |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSpatialIndex() (defined in AcDbSpatialIndex) | AcDbSpatialIndex |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isUptoDate() const (defined in AcDbIndex) | AcDbIndex |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
lastUpdatedAt() const (defined in AcDbIndex) | AcDbIndex |
lastUpdatedAtU() const (defined in AcDbIndex) | AcDbIndex |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(const AcDbFilter *pFilter) const (defined in AcDbSpatialIndex) | AcDbSpatialIndex | virtual
objectBeingIndexedId() const (defined in AcDbIndex) | AcDbIndex | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
rebuildFull(AcDbIndexUpdateData *pIdxData) (defined in AcDbSpatialIndex) | AcDbSpatialIndex | virtual
rebuildModified(AcDbBlockChangeIterator *iter) (defined in AcDbSpatialIndex) | AcDbSpatialIndex | protectedvirtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLastUpdatedAt(const AcDbDate &time) (defined in AcDbIndex) | AcDbIndex |
setLastUpdatedAtU(const AcDbDate &time) (defined in AcDbIndex) | AcDbIndex |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbIndex() (defined in AcDbIndex) | AcDbIndex | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSpatialIndex() (defined in AcDbSpatialIndex) | AcDbSpatialIndex | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSpatialIndexIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSpatialIndexIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSpatialIndexIterator:

Public Member Functions

virtual Acad::ErrorStatus | accepts (AcDbObjectId id, Adesk::Boolean &stat) const
AcDbSpatialIndexIterator (const AcDbSpatialIndex *pIndex, const AcDbSpatialFilter *pFilter)
virtual double | estimatedHitFraction () const
virtual AcDbObjectId | id () const
virtual AcDbObjectId | next ()
virtual Acad::ErrorStatus | seek (AcDbObjectId id)
virtual Acad::ErrorStatus | start ()
- Public Member Functions inherited from AcDbFilteredBlockIterator
virtual Acad::ErrorStatus | addToBuffer (AcDbObjectId id)
virtual Adesk::Boolean | buffersForComposition () const
The documentation for this class was generated from the following file:
  • dbspindx.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSpatialIndexIterator Member List

This is the complete list of members for AcDbSpatialIndexIterator, including all inherited members.

accepts(AcDbObjectId id, Adesk::Boolean &stat) const (defined in AcDbSpatialIndexIterator) | AcDbSpatialIndexIterator | virtual
AcDbFilteredBlockIterator() (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | inline
AcDbSpatialIndexIterator(const AcDbSpatialIndex *pIndex, const AcDbSpatialFilter *pFilter) (defined in AcDbSpatialIndexIterator) | AcDbSpatialIndexIterator |
addToBuffer(AcDbObjectId id) (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | virtual
buffersForComposition() const (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | virtual
estimatedHitFraction() const (defined in AcDbSpatialIndexIterator) | AcDbSpatialIndexIterator | virtual
id() const (defined in AcDbSpatialIndexIterator) | AcDbSpatialIndexIterator | virtual
next() (defined in AcDbSpatialIndexIterator) | AcDbSpatialIndexIterator | virtual
seek(AcDbObjectId id) (defined in AcDbSpatialIndexIterator) | AcDbSpatialIndexIterator | virtual
start() (defined in AcDbSpatialIndexIterator) | AcDbSpatialIndexIterator | virtual
~AcDbFilteredBlockIterator() (defined in AcDbFilteredBlockIterator) | AcDbFilteredBlockIterator | inlinevirtual
~AcDbSpatialIndexIterator() (defined in AcDbSpatialIndexIterator) | AcDbSpatialIndexIterator | virtual


ZRX API Reference: AcDbSpline Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSpline Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSpline:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSpline)
AcDbSpline (const AcGePoint3dArray &points, int order=4, double fitTolerance=0.0)
AcDbSpline (const AcGePoint3dArray &points, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, int order=4, double fitTolerance=0.0)
AcDbSpline (int degree, Adesk::Boolean rational, Adesk::Boolean closed, Adesk::Boolean periodic, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &knots, const AcGeDoubleArray &weights, double controlPtTol=0.0, double knotTol=0.0)
AcDbSpline (const AcGePoint3d &center, const AcGeVector3d &unitNormal, const AcGeVector3d &majorAxis, double radiusRatio, double startAngle=0.0, double endAngle=6.28318530717958647692)
virtual bool | castShadows () const
int | degree () const
Acad::ErrorStatus | elevateDegree (int newDegree)
double | fitTolerance () const
virtual DBCURVE_METHODS
Acad::ErrorStatus 		getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getControlPointAt (int index, AcGePoint3d &point) const
Acad::ErrorStatus | getFitData (AcGePoint3dArray &fitPoints, int &degree, double &fitTolerance, Adesk::Boolean &tangentsExist, AcGeVector3d &startTangent, AcGeVector3d &endTangent) const
Acad::ErrorStatus | getFitPointAt (int index, AcGePoint3d &point) const
Acad::ErrorStatus | getFitTangents (AcGeVector3d &startTangent, AcGeVector3d &endTangent) const
Acad::ErrorStatus | getNurbsData (int &degree, Adesk::Boolean &rational, Adesk::Boolean &closed, Adesk::Boolean &periodic, AcGePoint3dArray &controlPoints, AcGeDoubleArray &knots, AcGeDoubleArray &weights, double &controlPtTol, double &knotTol) const
Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
Adesk::Boolean | hasFitData () const
Acad::ErrorStatus | insertFitPointAt (int index, const AcGePoint3d &point)
Acad::ErrorStatus | insertKnot (double param)
Adesk::Boolean | isNull () const
Adesk::Boolean | isRational () const
int | numControlPoints () const
int | numFitPoints () const
Acad::ErrorStatus | purgeFitData ()
virtual bool | receiveShadows () const
Acad::ErrorStatus | removeFitPointAt (int index)
Acad::ErrorStatus | reverseCurve ()
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setControlPointAt (int index, const AcGePoint3d &point)
Acad::ErrorStatus | setFitData (const AcGePoint3dArray &fitPoints, int degree, double fitTolerance, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent)
Acad::ErrorStatus | setFitPointAt (int index, const AcGePoint3d &point)
Acad::ErrorStatus | setFitTangents (const AcGeVector3d &startTangent, const AcGeVector3d &endTangent)
Acad::ErrorStatus | setFitTol (double tol)
Acad::ErrorStatus | setNurbsData (int degree, Adesk::Boolean rational, Adesk::Boolean closed, Adesk::Boolean periodic, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &knots, const AcGeDoubleArray &weights, double controlPtTol, double knotTol)
virtual void | setReceiveShadows (bool newVal)
Acad::ErrorStatus | setWeightAt (int index, double weight)
Acad::ErrorStatus | toPolyline (AcDbCurve *&pCurve, int precision=10, int *maxSuggestedPrecision=NULL, unsigned int numOfVerticesThreshold=kPlineVerticesThrehold) const
Acad::ErrorStatus | updateFitData ()
double | weightAt (int index) const
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbspline.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSpline Member List

This is the complete list of members for AcDbSpline, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSpline) (defined in AcDbSpline) | AcDbSpline |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSpline() (defined in AcDbSpline) | AcDbSpline |
AcDbSpline(const AcGePoint3dArray &points, int order=4, double fitTolerance=0.0) (defined in AcDbSpline) | AcDbSpline |
AcDbSpline(const AcGePoint3dArray &points, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, int order=4, double fitTolerance=0.0) (defined in AcDbSpline) | AcDbSpline |
AcDbSpline(int degree, Adesk::Boolean rational, Adesk::Boolean closed, Adesk::Boolean periodic, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &knots, const AcGeDoubleArray &weights, double controlPtTol=0.0, double knotTol=0.0) (defined in AcDbSpline) | AcDbSpline |
AcDbSpline(const AcGePoint3d &center, const AcGeVector3d &unitNormal, const AcGeVector3d &majorAxis, double radiusRatio, double startAngle=0.0, double endAngle=6.28318530717958647692) (defined in AcDbSpline) | AcDbSpline |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbSpline) | AcDbSpline | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
degree() const (defined in AcDbSpline) | AcDbSpline |
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
elevateDegree(int newDegree) (defined in AcDbSpline) | AcDbSpline |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fitTolerance() const (defined in AcDbSpline) | AcDbSpline |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbSpline) | AcDbSpline | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getControlPointAt(int index, AcGePoint3d &point) const (defined in AcDbSpline) | AcDbSpline |
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFitData(AcGePoint3dArray &fitPoints, int &degree, double &fitTolerance, Adesk::Boolean &tangentsExist, AcGeVector3d &startTangent, AcGeVector3d &endTangent) const (defined in AcDbSpline) | AcDbSpline |
getFitPointAt(int index, AcGePoint3d &point) const (defined in AcDbSpline) | AcDbSpline |
getFitTangents(AcGeVector3d &startTangent, AcGeVector3d &endTangent) const (defined in AcDbSpline) | AcDbSpline |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getNurbsData(int &degree, Adesk::Boolean &rational, Adesk::Boolean &closed, Adesk::Boolean &periodic, AcGePoint3dArray &controlPoints, AcGeDoubleArray &knots, AcGeDoubleArray &weights, double &controlPtTol, double &knotTol) const (defined in AcDbSpline) | AcDbSpline |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbSpline) | AcDbSpline | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasFitData() const (defined in AcDbSpline) | AcDbSpline |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
insertFitPointAt(int index, const AcGePoint3d &point) (defined in AcDbSpline) | AcDbSpline |
insertKnot(double param) (defined in AcDbSpline) | AcDbSpline |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isNull() const (defined in AcDbSpline) | AcDbSpline |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isRational() const (defined in AcDbSpline) | AcDbSpline |
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
numControlPoints() const (defined in AcDbSpline) | AcDbSpline |
numFitPoints() const (defined in AcDbSpline) | AcDbSpline |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
purgeFitData() (defined in AcDbSpline) | AcDbSpline |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbSpline) | AcDbSpline | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeFitPointAt(int index) (defined in AcDbSpline) | AcDbSpline |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
reverseCurve() (defined in AcDbSpline) | AcDbSpline |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbSpline) | AcDbSpline | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setControlPointAt(int index, const AcGePoint3d &point) (defined in AcDbSpline) | AcDbSpline |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFitData(const AcGePoint3dArray &fitPoints, int degree, double fitTolerance, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent) (defined in AcDbSpline) | AcDbSpline |
setFitPointAt(int index, const AcGePoint3d &point) (defined in AcDbSpline) | AcDbSpline |
setFitTangents(const AcGeVector3d &startTangent, const AcGeVector3d &endTangent) (defined in AcDbSpline) | AcDbSpline |
setFitTol(double tol) (defined in AcDbSpline) | AcDbSpline |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNurbsData(int degree, Adesk::Boolean rational, Adesk::Boolean closed, Adesk::Boolean periodic, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &knots, const AcGeDoubleArray &weights, double controlPtTol, double knotTol) (defined in AcDbSpline) | AcDbSpline |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbSpline) | AcDbSpline | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWeightAt(int index, double weight) (defined in AcDbSpline) | AcDbSpline |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
toPolyline(AcDbCurve *&pCurve, int precision=10, int *maxSuggestedPrecision=NULL, unsigned int numOfVerticesThreshold=kPlineVerticesThrehold) const (defined in AcDbSpline) | AcDbSpline |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
updateFitData() (defined in AcDbSpline) | AcDbSpline |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
weightAt(int index) const (defined in AcDbSpline) | AcDbSpline |
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSpline() (defined in AcDbSpline) | AcDbSpline | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSubentId Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSubentId Class Reference
AcDb Classes

Public Member Functions

AcDbSubentId (AcDb::SubentType type, Adesk::GsMarker index)
AcDbSubentId (AcRxClass *pTypeClass, Adesk::GsMarker index)
Adesk::GsMarker | index () const
bool | operator!= (const AcDbSubentId &id) const
bool | operator== (const AcDbSubentId &id) const
void | setIndex (Adesk::GsMarker)
void | setType (AcDb::SubentType)
void | setTypeClass (AcRxClass *pClass)
AcDb::SubentType | type () const
AcRxClass * | typeClass () const
The documentation for this class was generated from the following file:
  • dbsubeid.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSubentId Member List

This is the complete list of members for AcDbSubentId, including all inherited members.

AcDbSubentId() (defined in AcDbSubentId) | AcDbSubentId | inline
AcDbSubentId(AcDb::SubentType type, Adesk::GsMarker index) (defined in AcDbSubentId) | AcDbSubentId | inline
AcDbSubentId(AcRxClass *pTypeClass, Adesk::GsMarker index) (defined in AcDbSubentId) | AcDbSubentId | inline
index() const (defined in AcDbSubentId) | AcDbSubentId | inline
operator!=(const AcDbSubentId &id) const (defined in AcDbSubentId) | AcDbSubentId | inline
operator==(const AcDbSubentId &id) const (defined in AcDbSubentId) | AcDbSubentId | inline
setIndex(Adesk::GsMarker) (defined in AcDbSubentId) | AcDbSubentId | inline
setType(AcDb::SubentType) (defined in AcDbSubentId) | AcDbSubentId | inline
setTypeClass(AcRxClass *pClass) (defined in AcDbSubentId) | AcDbSubentId | inline
type() const (defined in AcDbSubentId) | AcDbSubentId | inline
typeClass() const (defined in AcDbSubentId) | AcDbSubentId | inline


ZRX API Reference: AcDbSummaryInfoManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSummaryInfoManager Class Reference
AcDb Classes

Public Member Functions

virtual void | addReactor (AcDbSummaryInfoReactor *pReact)=0
virtual void | removeReactor (AcDbSummaryInfoReactor *pReact)=0
The documentation for this class was generated from the following file:
  • summinfo.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSummaryInfoManager Member List

This is the complete list of members for AcDbSummaryInfoManager, including all inherited members.

addReactor(AcDbSummaryInfoReactor *pReact)=0 (defined in AcDbSummaryInfoManager) | AcDbSummaryInfoManager | pure virtual
removeReactor(AcDbSummaryInfoReactor *pReact)=0 (defined in AcDbSummaryInfoManager) | AcDbSummaryInfoManager | pure virtual


ZRX API Reference: AcDbSummaryInfoReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSummaryInfoReactor Class Reference
AcDb Classes

Public Member Functions

virtual void summaryInfoHasChanged (const AcDbDatabase *pDb, const AcDbDatabaseSummaryInfo *pDbProp)
The documentation for this class was generated from the following file:
  • summinfo.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSummaryInfoReactor Member List

This is the complete list of members for AcDbSummaryInfoReactor, including all inherited members.

summaryInfoHasChanged(const AcDbDatabase *pDb, const AcDbDatabaseSummaryInfo *pDbProp) (defined in AcDbSummaryInfoReactor) | AcDbSummaryInfoReactor | inlinevirtual
~AcDbSummaryInfoReactor() (defined in AcDbSummaryInfoReactor) | AcDbSummaryInfoReactor | inlinevirtual


ZRX API Reference: AcDbSun Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSun Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSun:

Public Member Functions

AcDbSun ()
ACRX_DECLARE_MEMBERS (AcDbSun)
virtual double | altitude () const
virtual double | azimuth () const
virtual const AcDbDate & | dateTime () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual AcGiDrawable * | drawable ()
virtual DrawableType | drawableType () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual AcGsNode * | gsNode () const
virtual double | intensity () const
virtual bool | isDayLightSavingsOn () const
virtual bool | isOn () const
virtual Acad::ErrorStatus | setAltitude (double altitude)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setAzimuth (double azimuth)
virtual Acad::ErrorStatus | setDateTime (const AcDbDate &datetime)
virtual Acad::ErrorStatus | setDayLightSavingsOn (bool value)
virtual void | setGsNode (AcGsNode *gsnode)
virtual Acad::ErrorStatus | setIntensity (double intensity)
virtual Acad::ErrorStatus | setOn (bool value)
virtual void | setShadowParameters (const AcGiShadowParameters &params)
Acad::ErrorStatus | setSkyParameters (const AcGiSkyParameters &params)
virtual Acad::ErrorStatus | setSunColor (const AcCmColor &color)
virtual void | setSunDirection (const AcGeVector3d &sundir)
virtual const
AcGiShadowParameters & 		shadowParameters () const
Acad::ErrorStatus | skyParameters (AcGiSkyParameters &params) const
virtual const AcCmColor & | sunColor () const
virtual const AcGeVector3d & | sunDirection () const
~AcDbSun ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Constructor & Destructor Documentation

AcDbSun::AcDbSun ( )
Warning
Not implemented!
AcDbSun::~AcDbSun ( )
Warning
Not implemented!

Member Function Documentation

virtual double AcDbSun::altitude ( ) const
virtual
Warning
Not implemented!
virtual double AcDbSun::azimuth ( ) const
virtual
Warning
Not implemented!
virtual const AcDbDate& AcDbSun::dateTime ( ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSun::decomposeForSave | ( | AcDb::AcDbDwgVersion | ver,
 |  | AcDbObject *& | replaceObj,
 |  | AcDbObjectId & | replaceId,
 |  | Adesk::Boolean & | exchangeXData
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual AcGiDrawable* AcDbSun::drawable ( )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual DrawableType AcDbSun::drawableType ( ) const
inlinevirtual
Warning
Not implemented!

Reimplemented from AcGiDrawable.

virtual Acad::ErrorStatus AcDbSun::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSun::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSun::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSun::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual AcGsNode* AcDbSun::gsNode ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual double AcDbSun::intensity ( ) const
virtual
Warning
Not implemented!
virtual bool AcDbSun::isDayLightSavingsOn ( ) const
virtual
Warning
Not implemented!
virtual bool AcDbSun::isOn ( ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSun::setAltitude ( double altitude )
virtual
Warning
Not implemented!
virtual Adesk::UInt32 AcDbSun::setAttributes ( AcGiDrawableTraits * pTraits )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSun::setAzimuth ( double azimuth )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSun::setDateTime ( const AcDbDate & datetime )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSun::setDayLightSavingsOn ( bool value )
virtual
Warning
Not implemented!
virtual void AcDbSun::setGsNode ( AcGsNode * gsnode )
virtual
Warning
Not implemented!

Reimplemented from AcDbObject.

virtual Acad::ErrorStatus AcDbSun::setIntensity ( double intensity )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSun::setOn ( bool value )
virtual
Warning
Not implemented!
virtual void AcDbSun::setShadowParameters ( const AcGiShadowParameters & params )
virtual
Warning
Not implemented!
Acad::ErrorStatus AcDbSun::setSkyParameters ( const AcGiSkyParameters & params )
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSun::setSunColor ( const AcCmColor & color )
virtual
Warning
Not implemented!
virtual void AcDbSun::setSunDirection ( const AcGeVector3d & sundir )
virtual
Warning
Not implemented!
virtual const AcGiShadowParameters& AcDbSun::shadowParameters ( ) const
virtual
Warning
Not implemented!
Acad::ErrorStatus AcDbSun::skyParameters ( AcGiSkyParameters & params ) const
Warning
Not implemented!
virtual const AcCmColor& AcDbSun::sunColor ( ) const
virtual
Warning
Not implemented!
virtual const AcGeVector3d& AcDbSun::sunDirection ( ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbSun.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSun Member List

This is the complete list of members for AcDbSun, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSun() | AcDbSun |
ACRX_DECLARE_MEMBERS(AcDbSun) (defined in AcDbSun) | AcDbSun |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
altitude() const | AcDbSun | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
azimuth() const | AcDbSun | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
dateTime() const | AcDbSun | virtual
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) | AcDbSun | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() | AcDbSun | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const | AcDbSun | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbSun | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbSun | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbSun | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbSun | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const | AcDbSun | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
intensity() const | AcDbSun | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDayLightSavingsOn() const | AcDbSun | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isOn() const | AcDbSun | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAltitude(double altitude) | AcDbSun | virtual
setAttributes(AcGiDrawableTraits *pTraits) | AcDbSun | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setAzimuth(double azimuth) | AcDbSun | virtual
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDateTime(const AcDbDate &datetime) | AcDbSun | virtual
setDayLightSavingsOn(bool value) | AcDbSun | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *gsnode) | AcDbSun | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setIntensity(double intensity) | AcDbSun | virtual
setOn(bool value) | AcDbSun | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setShadowParameters(const AcGiShadowParameters &params) | AcDbSun | virtual
setSkyParameters(const AcGiSkyParameters &params) | AcDbSun |
setSunColor(const AcCmColor &color) | AcDbSun | virtual
setSunDirection(const AcGeVector3d &sundir) | AcDbSun | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shadowParameters() const | AcDbSun | virtual
skyParameters(AcGiSkyParameters &params) const | AcDbSun |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
sunColor() const | AcDbSun | virtual
sunDirection() const | AcDbSun | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSun() | AcDbSun |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcDbSurface Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSurface:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSurface)
AcDbSurface ()
virtual void * | body () const
virtual Acad::ErrorStatus | convertToRegion (AcArray< AcDbEntity * > &regions)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Acad::ErrorStatus | getArea (double &area) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual AcDbSubentId | internalSubentId (void *ent) const
virtual void * | internalSubentPtr (const AcDbSubentId &id) const
virtual void | list () const
virtual Acad::ErrorStatus | setBody (const void *modelerBody)
virtual Acad::ErrorStatus | setUIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | setVIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | thicken (double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const
virtual Adesk::UInt16 | uIsolineDensity () const
virtual Adesk::UInt16 | vIsolineDensity () const
virtual | ~AcDbSurface ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static Acad::ErrorStatus createFrom (const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface)

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Constructor & Destructor Documentation

AcDbSurface::AcDbSurface ( )
Warning
Not implemented!
virtual AcDbSurface::~AcDbSurface ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual void* AcDbSurface::body ( ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSurface::convertToRegion ( AcArray< AcDbEntity * > & regions )
virtual
Warning
Not implemented!
static Acad::ErrorStatus AcDbSurface::createFrom | ( | const AcDbEntity * | pFromEntity,
 |  | AcDbSurface *& | pNewSurface
 | ) |  |
static
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSurface::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Reimplemented in AcDbRevolvedSurface, AcDbExtrudedSurface, AcDbLoftedSurface, AcDbSweptSurface, and AcDbPlaneSurface.

virtual Acad::ErrorStatus AcDbSurface::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Reimplemented in AcDbRevolvedSurface, AcDbExtrudedSurface, AcDbLoftedSurface, AcDbSweptSurface, and AcDbPlaneSurface.

virtual Acad::ErrorStatus AcDbSurface::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Reimplemented in AcDbRevolvedSurface, AcDbExtrudedSurface, AcDbLoftedSurface, AcDbSweptSurface, and AcDbPlaneSurface.

virtual Acad::ErrorStatus AcDbSurface::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Reimplemented in AcDbRevolvedSurface, AcDbExtrudedSurface, AcDbLoftedSurface, AcDbSweptSurface, and AcDbPlaneSurface.

virtual Acad::ErrorStatus AcDbSurface::getArea ( double & area ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSurface::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Reimplemented in AcDbRevolvedSurface, AcDbExtrudedSurface, AcDbLoftedSurface, AcDbSweptSurface, and AcDbPlaneSurface.

virtual AcDbSubentId AcDbSurface::internalSubentId ( void * ent ) const
virtual
Warning
Not implemented!
virtual void* AcDbSurface::internalSubentPtr ( const AcDbSubentId & id ) const
virtual
Warning
Not implemented!
virtual void AcDbSurface::list ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Reimplemented in AcDbRevolvedSurface, AcDbExtrudedSurface, AcDbLoftedSurface, AcDbSweptSurface, and AcDbPlaneSurface.

virtual Acad::ErrorStatus AcDbSurface::setBody ( const void * modelerBody )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSurface::setUIsolineDensity ( Adesk::UInt16 numIsolines )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSurface::setVIsolineDensity ( Adesk::UInt16 numIsolines )
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSurface::thicken | ( | double | thickness,
 |  | bool | bBothSides,
 |  | AcDb3dSolid *& | pSolid
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Adesk::UInt16 AcDbSurface::uIsolineDensity ( ) const
virtual
Warning
Not implemented!
virtual Adesk::UInt16 AcDbSurface::vIsolineDensity ( ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbsurf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSurface Member List

This is the complete list of members for AcDbSurface, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSurface) (defined in AcDbSurface) | AcDbSurface |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSurface() | AcDbSurface |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
body() const | AcDbSurface | virtual
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToRegion(AcArray< AcDbEntity * > &regions) | AcDbSurface | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createFrom(const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface) | AcDbSurface | static
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbSurface | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbSurface | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbSurface | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbSurface | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &area) const | AcDbSurface | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbSurface | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
internalSubentId(void *ent) const | AcDbSurface | virtual
internalSubentPtr(const AcDbSubentId &id) const | AcDbSurface | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const | AcDbSurface | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBody(const void *modelerBody) | AcDbSurface | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thicken(double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const | AcDbSurface | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
uIsolineDensity() const | AcDbSurface | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
vIsolineDensity() const | AcDbSurface | virtual
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSurface() | AcDbSurface | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSweepOptions Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcDbSweepOptions Class Reference
AcDb Classes

Public Types

enum AlignOption { kNoAlignment, kAlignSweepEntityToPath, kTranslateSweepEntityToPath, kTranslatePathToSweepEntity }
enum MiterOption {
kDefaultMiter, kOldMiter, kNewMiter, kCrimpMiter,
kBendMiter
}

Public Member Functions

AcDbSweepOptions ()
AcDbSweepOptions (const AcDbSweepOptions &src)
AcDbSweepOptions::AlignOption | align () const
double | alignAngle () const
bool | alignStart () const
bool | bank () const
AcGePoint3d | basePoint () const
bool | checkIntersections () const
Acad::ErrorStatus | checkPathCurve (AcDbEntity *pPathEnt, bool displayErrorMessages=false)
Acad::ErrorStatus | checkSweepCurve (AcDbEntity *pSweepEnt, AcDb::Planarity &planarity, AcGePoint3d &pnt, AcGeVector3d &vec, bool &closed, double &approxArcLen, bool displayErrorMessages=false)
double | draftAngle () const
double | endDraftDist () const
bool | getPathEntityTransform (AcGeMatrix3d &mat)
bool | getSweepEntityTransform (AcGeMatrix3d &mat)
AcDbSweepOptions::MiterOption | miterOption () const
AcDbSweepOptions & | operator= (const AcDbSweepOptions &src)
double | scaleFactor () const
void | setAlign (AcDbSweepOptions::AlignOption val)
void | setAlignAngle (double ang)
void | setAlignStart (bool val)
void | setBank (bool val)
void | setBasePoint (AcGePoint3d &pnt)
void | setCheckIntersections (bool val)
void | setDraftAngle (double ang)
void | setEndDraftDist (double val)
void | setMiterOption (AcDbSweepOptions::MiterOption val)
void | setPathEntityTransform (AcGeMatrix3d &mat)
Acad::ErrorStatus | setPathEntityTransform (AcDbEntity *pPathEnt, bool displayErrorMessages=false)
void | setScaleFactor (double val)
void | setStartDraftDist (double val)
void | setSweepEntityTransform (AcGeMatrix3d &mat)
Acad::ErrorStatus | setSweepEntityTransform (AcArray< AcDbEntity * > &sweepEntities, bool displayErrorMessages=false)
void | setTwistAngle (double ang)
void | setTwistRefVec (const AcGeVector3d &vec)
double | startDraftDist () const
double | twistAngle () const
AcGeVector3d | twistRefVec () const
~AcDbSweepOptions ()

Friends

class AcDbImpSweepOptions

Constructor & Destructor Documentation

AcDbSweepOptions::AcDbSweepOptions ( )
Warning
Not implemented!
AcDbSweepOptions::AcDbSweepOptions ( const AcDbSweepOptions & src )
Warning
Not implemented!
AcDbSweepOptions::~AcDbSweepOptions ( )
Warning
Not implemented!

Member Function Documentation

AcDbSweepOptions::AlignOption AcDbSweepOptions::align ( ) const
Warning
Not implemented!
double AcDbSweepOptions::alignAngle ( ) const
Warning
Not implemented!
bool AcDbSweepOptions::alignStart ( ) const
Warning
Not implemented!
bool AcDbSweepOptions::bank ( ) const
Warning
Not implemented!
AcGePoint3d AcDbSweepOptions::basePoint ( ) const
Warning
Not implemented!
bool AcDbSweepOptions::checkIntersections ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbSweepOptions::checkPathCurve | ( | AcDbEntity * | pPathEnt,
 |  | bool | displayErrorMessages = false
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus AcDbSweepOptions::checkSweepCurve | ( | AcDbEntity * | pSweepEnt,
 |  | AcDb::Planarity & | planarity,
 |  | AcGePoint3d & | pnt,
 |  | AcGeVector3d & | vec,
 |  | bool & | closed,
 |  | double & | approxArcLen,
 |  | bool | displayErrorMessages = false
 | ) |  |
Warning
Not implemented!
double AcDbSweepOptions::draftAngle ( ) const
Warning
Not implemented!
double AcDbSweepOptions::endDraftDist ( ) const
Warning
Not implemented!
bool AcDbSweepOptions::getPathEntityTransform ( AcGeMatrix3d & mat )
Warning
Not implemented!
bool AcDbSweepOptions::getSweepEntityTransform ( AcGeMatrix3d & mat )
Warning
Not implemented!
AcDbSweepOptions::MiterOption AcDbSweepOptions::miterOption ( ) const
Warning
Not implemented!
AcDbSweepOptions& AcDbSweepOptions::operator= ( const AcDbSweepOptions & src )
Warning
Not implemented!
double AcDbSweepOptions::scaleFactor ( ) const
Warning
Not implemented!
void AcDbSweepOptions::setAlign ( AcDbSweepOptions::AlignOption val )
Warning
Not implemented!
void AcDbSweepOptions::setAlignAngle ( double ang )
Warning
Not implemented!
void AcDbSweepOptions::setAlignStart ( bool val )
Warning
Not implemented!
void AcDbSweepOptions::setBank ( bool val )
Warning
Not implemented!
void AcDbSweepOptions::setBasePoint ( AcGePoint3d & pnt )
Warning
Not implemented!
void AcDbSweepOptions::setCheckIntersections ( bool val )
Warning
Not implemented!
void AcDbSweepOptions::setDraftAngle ( double ang )
Warning
Not implemented!
void AcDbSweepOptions::setEndDraftDist ( double val )
Warning
Not implemented!
void AcDbSweepOptions::setMiterOption ( AcDbSweepOptions::MiterOption val )
Warning
Not implemented!
void AcDbSweepOptions::setPathEntityTransform ( AcGeMatrix3d & mat )
Warning
Not implemented!
Acad::ErrorStatus AcDbSweepOptions::setPathEntityTransform | ( | AcDbEntity * | pPathEnt,
 |  | bool | displayErrorMessages = false
 | ) |  |
Warning
Not implemented!
void AcDbSweepOptions::setScaleFactor ( double val )
Warning
Not implemented!
void AcDbSweepOptions::setStartDraftDist ( double val )
Warning
Not implemented!
void AcDbSweepOptions::setSweepEntityTransform ( AcGeMatrix3d & mat )
Warning
Not implemented!
Acad::ErrorStatus AcDbSweepOptions::setSweepEntityTransform | ( | AcArray< AcDbEntity * > & | sweepEntities,
 |  | bool | displayErrorMessages = false
 | ) |  |
Warning
Not implemented!
void AcDbSweepOptions::setTwistAngle ( double ang )
Warning
Not implemented!
void AcDbSweepOptions::setTwistRefVec ( const AcGeVector3d & vec )
Warning
Not implemented!
double AcDbSweepOptions::startDraftDist ( ) const
Warning
Not implemented!
double AcDbSweepOptions::twistAngle ( ) const
Warning
Not implemented!
AcGeVector3d AcDbSweepOptions::twistRefVec ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbSweepOptions.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSweepOptions Member List

This is the complete list of members for AcDbSweepOptions, including all inherited members.

AcDbImpSweepOptions (defined in AcDbSweepOptions) | AcDbSweepOptions | friend
AcDbSweepOptions() AcDbSweepOptions
AcDbSweepOptions(const AcDbSweepOptions &src) | AcDbSweepOptions
align() const | AcDbSweepOptions
alignAngle() const | AcDbSweepOptions
AlignOption enum name (defined in AcDbSweepOptions) | AcDbSweepOptions
alignStart() const | AcDbSweepOptions
bank() const | AcDbSweepOptions
basePoint() const | AcDbSweepOptions
checkIntersections() const | AcDbSweepOptions
checkPathCurve(AcDbEntity *pPathEnt, bool displayErrorMessages=false) | AcDbSweepOptions
checkSweepCurve(AcDbEntity *pSweepEnt, AcDb::Planarity &planarity, AcGePoint3d &pnt, AcGeVector3d &vec, bool &closed, double &approxArcLen, bool displayErrorMessages=false) | AcDbSweepOptions
draftAngle() const | AcDbSweepOptions
endDraftDist() const | AcDbSweepOptions
getPathEntityTransform(AcGeMatrix3d &mat) | AcDbSweepOptions
getSweepEntityTransform(AcGeMatrix3d &mat) | AcDbSweepOptions
kAlignSweepEntityToPath enum value (defined in AcDbSweepOptions) | AcDbSweepOptions
kBendMiter enum value (defined in AcDbSweepOptions) | AcDbSweepOptions
kCrimpMiter enum value (defined in AcDbSweepOptions) | AcDbSweepOptions
kDefaultMiter enum value (defined in AcDbSweepOptions) | AcDbSweepOptions
kNewMiter enum value (defined in AcDbSweepOptions) | AcDbSweepOptions
kNoAlignment enum value (defined in AcDbSweepOptions) | AcDbSweepOptions
kOldMiter enum value (defined in AcDbSweepOptions) | AcDbSweepOptions
kTranslatePathToSweepEntity enum value (defined in AcDbSweepOptions) | AcDbSweepOptions
kTranslateSweepEntityToPath enum value (defined in AcDbSweepOptions) | AcDbSweepOptions
MiterOption enum name (defined in AcDbSweepOptions) | AcDbSweepOptions
miterOption() const | AcDbSweepOptions
operator=(const AcDbSweepOptions &src) | AcDbSweepOptions
scaleFactor() const | AcDbSweepOptions
setAlign(AcDbSweepOptions::AlignOption val) | AcDbSweepOptions
setAlignAngle(double ang) | AcDbSweepOptions
setAlignStart(bool val) | AcDbSweepOptions
setBank(bool val) | AcDbSweepOptions
setBasePoint(AcGePoint3d &pnt) | AcDbSweepOptions
setCheckIntersections(bool val) | AcDbSweepOptions
setDraftAngle(double ang) | AcDbSweepOptions
setEndDraftDist(double val) | AcDbSweepOptions
setMiterOption(AcDbSweepOptions::MiterOption val) | AcDbSweepOptions
setPathEntityTransform(AcGeMatrix3d &mat) | AcDbSweepOptions
setPathEntityTransform(AcDbEntity *pPathEnt, bool displayErrorMessages=false) | AcDbSweepOptions
setScaleFactor(double val) | AcDbSweepOptions
setStartDraftDist(double val) | AcDbSweepOptions
setSweepEntityTransform(AcGeMatrix3d &mat) | AcDbSweepOptions
setSweepEntityTransform(AcArray< AcDbEntity * > &sweepEntities, bool displayErrorMessages=false) | AcDbSweepOptions
setTwistAngle(double ang) | AcDbSweepOptions
setTwistRefVec(const AcGeVector3d &vec) | AcDbSweepOptions
startDraftDist() const | AcDbSweepOptions
twistAngle() const | AcDbSweepOptions
twistRefVec() const | AcDbSweepOptions


ZRX API Reference: AcDbSweptSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSweptSurface Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSweptSurface:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSweptSurface)
AcDbSweptSurface ()
virtual Acad::ErrorStatus | createSweptSurface (AcDbEntity *pSweepEnt, AcDbEntity *pPathEnt, AcDbSweepOptions &sweepOptions)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
AcDbEntity * | getPathEntity () const
Acad::ErrorStatus | getPathLength (double &len) const
AcDbEntity * | getSweepEntity () const
void | getSweepOptions (AcDbSweepOptions &sweepOptions) const
virtual bool | isDependent () const
virtual void | list () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
Acad::ErrorStatus | setSweepOptions (const AcDbSweepOptions &sweepOptions)
virtual | ~AcDbSweptSurface ()
- Public Member Functions inherited from AcDbSurface
ACDB_DECLARE_MEMBERS (AcDbSurface)
AcDbSurface ()
virtual void * | body () const
virtual Acad::ErrorStatus | convertToRegion (AcArray< AcDbEntity * > &regions)
virtual Acad::ErrorStatus | getArea (double &area) const
virtual AcDbSubentId | internalSubentId (void *ent) const
virtual void * | internalSubentPtr (const AcDbSubentId &id) const
virtual Acad::ErrorStatus | setBody (const void *modelerBody)
virtual Acad::ErrorStatus | setUIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | setVIsolineDensity (Adesk::UInt16 numIsolines)
virtual Acad::ErrorStatus | thicken (double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const
virtual Adesk::UInt16 | uIsolineDensity () const
virtual Adesk::UInt16 | vIsolineDensity () const
virtual | ~AcDbSurface ()
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcDbSurface
static Acad::ErrorStatus | createFrom (const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface)

Constructor & Destructor Documentation

AcDbSweptSurface::AcDbSweptSurface ( )
Warning
Not implemented!
virtual AcDbSweptSurface::~AcDbSweptSurface ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcDbSweptSurface::createSweptSurface | ( | AcDbEntity * | pSweepEnt,
 |  | AcDbEntity * | pPathEnt,
 |  | AcDbSweepOptions & | sweepOptions
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbSweptSurface::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbSweptSurface::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbSweptSurface::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbSweptSurface::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbSweptSurface::getClassID ( CLSID * pClsid ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbSweptSurface::getGripEntityUCS | ( | const void * | pGripAppData,
 |  | AcGeVector3d & | normalVec,
 |  | AcGePoint3d & | origin,
 |  | AcGeVector3d & | xAxis
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbSweptSurface::getGripPoints | ( | AcGePoint3dArray & | gripPoints,
 |  | AcDbIntArray & | osnapModes,
 |  | AcDbIntArray & | geomIds
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbSweptSurface::getGripPoints | ( | AcDbGripDataPtrArray & | grips,
 |  | const double | curViewUnitSize,
 |  | const int | gripSize,
 |  | const AcGeVector3d & | curViewDir,
 |  | const int | bitflags
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

AcDbEntity* AcDbSweptSurface::getPathEntity ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbSweptSurface::getPathLength ( double & len ) const
Warning
Not implemented!
AcDbEntity* AcDbSweptSurface::getSweepEntity ( ) const
Warning
Not implemented!
void AcDbSweptSurface::getSweepOptions ( AcDbSweepOptions & sweepOptions ) const
Warning
Not implemented!
virtual bool AcDbSweptSurface::isDependent ( ) const
virtual
Warning
Not implemented!
virtual void AcDbSweptSurface::list ( ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbSurface.

virtual Acad::ErrorStatus AcDbSweptSurface::moveGripPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

virtual Acad::ErrorStatus AcDbSweptSurface::moveStretchPointsAt | ( | const AcDbIntArray & | indices,
 |  | const AcGeVector3d & | offset
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from AcDbEntity.

Acad::ErrorStatus AcDbSweptSurface::setSweepOptions ( const AcDbSweepOptions & sweepOptions )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbsweptsurf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSweptSurface Member List

This is the complete list of members for AcDbSweptSurface, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSweptSurface) (defined in AcDbSweptSurface) | AcDbSweptSurface |
ACDB_DECLARE_MEMBERS(AcDbSurface) (defined in AcDbSurface) | AcDbSurface |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSurface() | AcDbSurface |
AcDbSweptSurface() | AcDbSweptSurface |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
body() const | AcDbSurface | virtual
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertToRegion(AcArray< AcDbEntity * > &regions) | AcDbSurface | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createFrom(const AcDbEntity *pFromEntity, AcDbSurface *&pNewSurface) | AcDbSurface | static
createSweptSurface(AcDbEntity *pSweepEnt, AcDbEntity *pPathEnt, AcDbSweepOptions &sweepOptions) | AcDbSweptSurface | virtual
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbSweptSurface | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbSweptSurface | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbSweptSurface | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbSweptSurface | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &area) const | AcDbSurface | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const | AcDbSweptSurface | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const | AcDbSweptSurface | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const | AcDbSweptSurface | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const | AcDbSweptSurface | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPathEntity() const | AcDbSweptSurface |
getPathLength(double &len) const | AcDbSweptSurface |
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSweepEntity() const | AcDbSweptSurface |
getSweepOptions(AcDbSweepOptions &sweepOptions) const | AcDbSweptSurface |
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
internalSubentId(void *ent) const | AcDbSurface | virtual
internalSubentPtr(const AcDbSubentId &id) const | AcDbSurface | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const | AcDbSweptSurface | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const | AcDbSweptSurface | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbSweptSurface | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) | AcDbSweptSurface | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBody(const void *modelerBody) | AcDbSurface | virtual
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setSweepOptions(const AcDbSweepOptions &sweepOptions) | AcDbSweptSurface |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVIsolineDensity(Adesk::UInt16 numIsolines) | AcDbSurface | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thicken(double thickness, bool bBothSides, AcDb3dSolid *&pSolid) const | AcDbSurface | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
uIsolineDensity() const | AcDbSurface | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
vIsolineDensity() const | AcDbSurface | virtual
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSurface() | AcDbSurface | virtual
~AcDbSweptSurface() | AcDbSweptSurface | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSymbolTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbSymbolTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSymbolTable:

Public Types

typedef AcDbSymbolTableRecord RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSymbolTable Member List

This is the complete list of members for AcDbSymbolTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
has(AcDbObjectId id) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbSymbolTable) | AcDbSymbolTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSymbolTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
AcDbSymbolTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSymbolTableIterator:

Public Member Functions

bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Protected Attributes

friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSymbolTableIterator Member List

This is the complete list of members for AcDbSymbolTableIterator, including all inherited members.

AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbSymbolTablePointer< T_OBJECT > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSymbolTablePointer< T_OBJECT > Class Template Reference
AcDb Classes
+ Inheritance diagram for AcDbSymbolTablePointer< T_OBJECT >:

Public Member Functions

AcDbSymbolTablePointer (AcDbObjectId objId, AcDb::OpenMode mode)
AcDbSymbolTablePointer (AcDbDatabase *pDb, AcDb::OpenMode mode)
Acad::ErrorStatus | open (AcDbObjectId objId, AcDb::OpenMode mode)
Acad::ErrorStatus | open (AcDbDatabase *pDb, AcDb::OpenMode mode)
- Public Member Functions inherited from AcDbObjectPointerBase< T_OBJECT >
Acad::ErrorStatus | acquire (T_OBJECT *&pObjToAcquire)
Acad::ErrorStatus | close ()
Acad::ErrorStatus | create ()
const T_OBJECT * | object () const
T_OBJECT * | object ()
Acad::ErrorStatus | open (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | openStatus () const
operator const T_OBJECT * () const
operator T_OBJECT * ()
const T_OBJECT * | operator-> () const
T_OBJECT * | operator-> ()
Acad::ErrorStatus | release (T_OBJECT *&pReleasedObj)

Additional Inherited Members

- Protected Member Functions inherited from AcDbObjectPointerBase< T_OBJECT >
AcDbObjectPointerBase (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased)
- Protected Attributes inherited from AcDbObjectPointerBase< T_OBJECT >
T_OBJECT * | m_ptr
Acad::ErrorStatus | m_status
The documentation for this class was generated from the following file:
  • dbobjptr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSymbolTablePointer< T_OBJECT > Member List

This is the complete list of members for AcDbSymbolTablePointer< T_OBJECT >, including all inherited members.

AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
AcDbObjectPointerBase(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlineprotected
AcDbSymbolTablePointer() (defined in AcDbSymbolTablePointer< T_OBJECT >) | AcDbSymbolTablePointer< T_OBJECT > | inline
AcDbSymbolTablePointer(AcDbObjectId objId, AcDb::OpenMode mode) (defined in AcDbSymbolTablePointer< T_OBJECT >) | AcDbSymbolTablePointer< T_OBJECT > | inline
AcDbSymbolTablePointer(AcDbDatabase *pDb, AcDb::OpenMode mode) (defined in AcDbSymbolTablePointer< T_OBJECT >) | AcDbSymbolTablePointer< T_OBJECT > | inline
acquire(T_OBJECT *&pObjToAcquire) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
close() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
create() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
m_ptr (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
m_status (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
object() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
object() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
open(AcDbObjectId objId, AcDb::OpenMode mode) (defined in AcDbSymbolTablePointer< T_OBJECT >) | AcDbSymbolTablePointer< T_OBJECT > | inline
open(AcDbDatabase *pDb, AcDb::OpenMode mode) (defined in AcDbSymbolTablePointer< T_OBJECT >) | AcDbSymbolTablePointer< T_OBJECT > | inline
open(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
openStatus() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator const T_OBJECT *() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator T_OBJECT *() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
release(T_OBJECT *&pReleasedObj) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
~AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlinevirtual


ZRX API Reference: AcDbSymbolTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbSymbolTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbSymbolTableRecord:

Public Types

typedef AcDbSymbolTable TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSymbolTableRecord Member List

This is the complete list of members for AcDbSymbolTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbSymbolTableRecordPointer< T_OBJECT > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbSymbolTableRecordPointer< T_OBJECT > Class Template Reference
AcDb Classes
+ Inheritance diagram for AcDbSymbolTableRecordPointer< T_OBJECT >:

Public Member Functions

AcDbSymbolTableRecordPointer (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
AcDbSymbolTableRecordPointer (const ACHAR *name, AcDbDatabase *pDb, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | open (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | open (const ACHAR *name, AcDbDatabase *pDb, AcDb::OpenMode mode, bool openErased=false)
- Public Member Functions inherited from AcDbObjectPointerBase< T_OBJECT >
Acad::ErrorStatus | acquire (T_OBJECT *&pObjToAcquire)
Acad::ErrorStatus | close ()
Acad::ErrorStatus | create ()
const T_OBJECT * | object () const
T_OBJECT * | object ()
Acad::ErrorStatus | openStatus () const
operator const T_OBJECT * () const
operator T_OBJECT * ()
const T_OBJECT * | operator-> () const
T_OBJECT * | operator-> ()
Acad::ErrorStatus | release (T_OBJECT *&pReleasedObj)

Additional Inherited Members

- Protected Member Functions inherited from AcDbObjectPointerBase< T_OBJECT >
AcDbObjectPointerBase (AcDbObjectId objId, AcDb::OpenMode mode, bool openErased)
- Protected Attributes inherited from AcDbObjectPointerBase< T_OBJECT >
T_OBJECT * | m_ptr
Acad::ErrorStatus | m_status
The documentation for this class was generated from the following file:
  • dbobjptr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSymbolTableRecordPointer< T_OBJECT > Member List

This is the complete list of members for AcDbSymbolTableRecordPointer< T_OBJECT >, including all inherited members.

AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
AcDbObjectPointerBase(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlineprotected
AcDbSymbolTableRecordPointer() (defined in AcDbSymbolTableRecordPointer< T_OBJECT >) | AcDbSymbolTableRecordPointer< T_OBJECT > | inline
AcDbSymbolTableRecordPointer(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbSymbolTableRecordPointer< T_OBJECT >) | AcDbSymbolTableRecordPointer< T_OBJECT > | inline
AcDbSymbolTableRecordPointer(const ACHAR *name, AcDbDatabase *pDb, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbSymbolTableRecordPointer< T_OBJECT >) | AcDbSymbolTableRecordPointer< T_OBJECT > | inline
acquire(T_OBJECT *&pObjToAcquire) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
close() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
create() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
m_ptr (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
m_status (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | protected
object() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
object() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
open(AcDbObjectId objId, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbSymbolTableRecordPointer< T_OBJECT >) | AcDbSymbolTableRecordPointer< T_OBJECT > | inline
open(const ACHAR *name, AcDbDatabase *pDb, AcDb::OpenMode mode, bool openErased=false) (defined in AcDbSymbolTableRecordPointer< T_OBJECT >) | AcDbSymbolTableRecordPointer< T_OBJECT > | inline
openStatus() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator const T_OBJECT *() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator T_OBJECT *() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() const (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
operator->() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
release(T_OBJECT *&pReleasedObj) (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inline
~AcDbObjectPointerBase() (defined in AcDbObjectPointerBase< T_OBJECT >) | AcDbObjectPointerBase< T_OBJECT > | inlinevirtual


ZRX API Reference: AcDbTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
AcDbTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbTable:

Public Types

enum TableStyleOverrides {
kTitleSuppressed = 1, kHeaderSuppressed = 2, kFlowDirection = 3, kHorzCellMargin = 4,
kVertCellMargin = 5, kTitleRowColor = 6, kHeaderRowColor = 7, kDataRowColor = 8,
kTitleRowFillNone = 9, kHeaderRowFillNone = 10, kDataRowFillNone = 11, kTitleRowFillColor = 12,
kHeaderRowFillColor = 13, kDataRowFillColor = 14, kTitleRowAlignment = 15, kHeaderRowAlignment = 16,
kDataRowAlignment = 17, kTitleRowTextStyle = 18, kHeaderRowTextStyle = 19, kDataRowTextStyle = 20,
kTitleRowTextHeight = 21, kHeaderRowTextHeight = 22, kDataRowTextHeight = 23, kTitleRowDataType = 24,
kHeaderRowDataType = 25, kDataRowDataType = 26, kTitleHorzTopColor = 40, kTitleHorzInsideColor = 41,
kTitleHorzBottomColor = 42, kTitleVertLeftColor = 43, kTitleVertInsideColor = 44, kTitleVertRightColor = 45,
kHeaderHorzTopColor = 46, kHeaderHorzInsideColor = 47, kHeaderHorzBottomColor = 48, kHeaderVertLeftColor = 49,
kHeaderVertInsideColor = 50, kHeaderVertRightColor = 51, kDataHorzTopColor = 52, kDataHorzInsideColor = 53,
kDataHorzBottomColor = 54, kDataVertLeftColor = 55, kDataVertInsideColor = 56, kDataVertRightColor = 57,
kTitleHorzTopLineWeight = 70, kTitleHorzInsideLineWeight = 71, kTitleHorzBottomLineWeight = 72, kTitleVertLeftLineWeight = 73,
kTitleVertInsideLineWeight = 74, kTitleVertRightLineWeight = 75, kHeaderHorzTopLineWeight = 76, kHeaderHorzInsideLineWeight = 77,
kHeaderHorzBottomLineWeight = 78, kHeaderVertLeftLineWeight = 79, kHeaderVertInsideLineWeight = 80, kHeaderVertRightLineWeight = 81,
kDataHorzTopLineWeight = 82, kDataHorzInsideLineWeight = 83, kDataHorzBottomLineWeight = 84, kDataVertLeftLineWeight = 85,
kDataVertInsideLineWeight = 86, kDataVertRightLineWeight = 87, kTitleHorzTopVisibility = 100, kTitleHorzInsideVisibility = 101,
kTitleHorzBottomVisibility = 102, kTitleVertLeftVisibility = 103, kTitleVertInsideVisibility = 104, kTitleVertRightVisibility = 105,
kHeaderHorzTopVisibility = 106, kHeaderHorzInsideVisibility = 107, kHeaderHorzBottomVisibility = 108, kHeaderVertLeftVisibility = 109,
kHeaderVertInsideVisibility = 110, kHeaderVertRightVisibility = 111, kDataHorzTopVisibility = 112, kDataHorzInsideVisibility = 113,
kDataHorzBottomVisibility = 114, kDataVertLeftVisibility = 115, kDataVertInsideVisibility = 116, kDataVertRightVisibility = 117,
kCellAlignment = 130, kCellBackgroundFillNone = 131, kCellBackgroundColor = 132, kCellContentColor = 133,
kCellTextStyle = 134, kCellTextHeight = 135, kCellTopGridColor = 136, kCellRightGridColor = 137,
kCellBottomGridColor = 138, kCellLeftGridColor = 139, kCellTopGridLineWeight = 140, kCellRightGridLineWeight = 141,
kCellBottomGridLineWeight = 142, kCellLeftGridLineWeight = 143, kCellTopVisibility = 144, kCellRightVisibility = 145,
kCellBottomVisibility = 146, kCellLeftVisibility = 147, kCellDataType = 148
}

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbTable)
AcDbTable (const AcDbLinkedTableData *pTable, AcDb::TableCopyOption nCopyOption)
virtual ADESK_DEPRECATED
AcDb::CellAlignment 		alignment (AcDb::RowType type=AcDb::kDataRow) const
virtual AcDb::CellAlignment | alignment (int row, int col) const
virtual AcGePoint3d | attachmentPoint (int row, int col) const
AcGePoint3d | attachmentPoint (int row, int col, int content) const
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
virtual ADESK_DEPRECATED AcCmColor | backgroundColor (AcDb::RowType type=AcDb::kDataRow) const
virtual AcCmColor | backgroundColor (int row, int col) const
virtual ADESK_DEPRECATED double | blockRotation (int row, int col) const
virtual ADESK_DEPRECATED double | blockScale (int row, int col) const
virtual AcDbObjectId | blockTableRecordId (int row, int col) const
AcDbObjectId | blockTableRecordId (int row, int col, int nContent) const
AcDb::TableBreakFlowDirection | breakFlowDirection (void) const
double | breakHeight (int nIndex) const
AcGeVector3d | breakOffset (int nIndex) const
AcDb::TableBreakOption | breakOption (void) const
double | breakSpacing (void) const
bool | canDelete (int nIndex, int nCount, bool bRow) const
bool | canInsert (int nIndex, bool bRow) const
virtual bool | castShadows () const
AcDb::CellState | cellState (int nRow, int nCol) const
const ACHAR * | cellStyle (int nRow, int nCol) const
virtual bool | cellStyleOverrides (int row, int col, AcDbIntArray &overrides) const
virtual AcDb::CellType | cellType (int row, int col) const
void | clearCellOverrides (int row, int column)
virtual void | clearSubSelection ()
virtual ADESK_DEPRECATED void | clearTableStyleOverrides (int options=0)
virtual double | columnWidth (int col) const
virtual ADESK_DEPRECATED AcCmColor | contentColor (AcDb::RowType type=AcDb::kDataRow) const
virtual AcCmColor | contentColor (int row, int col) const
AcCmColor | contentColor (int row, int col, int nContent) const
AcDb::CellContentLayout | contentLayout (int row, int col) const
AcDb::CellContentType | contentType (int nRow, int nCol) const
AcDb::CellContentType | contentType (int nRow, int nCol, int nIndex) const
Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption)
Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRangeOut)
Acad::ErrorStatus | copyFrom (const AcDbTable *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRangeOut)
int | createContent (int nRow, int nCol, int nIndex)
Acad::ErrorStatus | createTemplate (AcDbTableTemplate *&pTemplate, AcDb::TableCopyOption nCopyOption)
AcString | dataFormat (int row, int col) const
AcString | dataFormat (int row, int col, int nContent) const
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		deleteCellContent (int row, int col)
virtual Acad::ErrorStatus | deleteColumns (int col, int nCols=1)
Acad::ErrorStatus | deleteContent (int nRow, int nCol)
Acad::ErrorStatus | deleteContent (int nRow, int nCol, int nIndex)
Acad::ErrorStatus | deleteContent (const AcCellRange &range)
virtual Acad::ErrorStatus | deleteRows (int row, int nRows=1)
virtual AcGeVector3d | direction () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *) const
Acad::ErrorStatus | enableBreak (bool bEnable)
Acad::ErrorStatus | enableMergeAll (int nRow, int nCol, bool bEnable)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual AcDbObjectId | fieldId (int row, int col) const
AcDbObjectId | fieldId (int row, int col, int nContent) const
Acad::ErrorStatus | fill (const AcCellRange &fillRange, const AcCellRange &srcRange, AcDb::TableFillOption nOption)
virtual AcDb::FlowDirection | flowDirection () const
virtual ADESK_DEPRECATED const
ACHAR * 		format (AcDb::RowType type)
const ACHAR * | format (int row, int col) const
virtual Acad::ErrorStatus | generateLayout ()
virtual Acad::ErrorStatus | getBlockAttributeValue (int row, int col, const AcDbObjectId &attdefId, ACHAR *&value) const
Acad::ErrorStatus | getBlockAttributeValue (int row, int col, int nContent, const AcDbObjectId &attdefId, ACHAR *&value) const
virtual Acad::ErrorStatus | getCellExtents (int row, int col, bool isOuterCell, AcGePoint3dArray &pts) const
virtual Acad::ErrorStatus | getCellExtents (int row, int col, double &cellWidth, double &cellHeight, bool bAdjustForMargins) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
const ACHAR * | getColumnName (int nIndex) const
int | getCustomData (int nRow, int nCol) const
Acad::ErrorStatus | getCustomData (int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const
AcDbObjectId | getDataLink (int nRow, int nCol) const
Acad::ErrorStatus | getDataLink (int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const
int | getDataLink (const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const
AcCellRange | getDataLinkRange (int nRow, int nCol) const
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		getDataType (AcValue::DataType &nDataType, AcValue::UnitType &nUnitType, AcDb::RowType type) const
Acad::ErrorStatus | getDataType (int row, int col, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
Acad::ErrorStatus | getDataType (int row, int col, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
AcString | getFormula (int nRow, int nCol, int nContent) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
Acad::ErrorStatus | getGridProperty (int nRow, int nCol, AcDb::GridLineType nGridLineType, AcGridProperty &gridProp) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &, AcDbIntArray &, AcDbIntArray &geomIds) const
Acad::ErrorStatus | getIndicatorSize (double &fWidth, double &fHeight) const
AcDbTableIterator * | getIterator (void) const
AcDbTableIterator * | getIterator (const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const
AcCellRange | getMergeRange (int nRow, int nCol) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
AcDb::CellProperty | getOverride (int nRow, int nCol, int nContent) const
AcDb::GridProperty | getOverride (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubSelection (int &rowMin, int &rowMax, int &colMin, int &colMax) const
AcCellRange | getSubSelection (void) const
AcString | getToolTip (int nRow, int nCol) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&ent) const
virtual ADESK_DEPRECATED AcCmColor | gridColor (AcDb::GridLineType gridlineType, AcDb::RowType type=AcDb::kDataRow) const
virtual AcCmColor | gridColor (int row, int col, AcDb::CellEdgeMask iEdge) const
AcCmColor | gridColor (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
double | gridDoubleLineSpacing (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
AcDb::GridLineStyle | gridLineStyle (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
AcDbObjectId | gridLinetype (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ADESK_DEPRECATED
AcDb::LineWeight 		gridLineWeight (AcDb::GridLineType gridlineType, AcDb::RowType type=AcDb::kDataRow) const
virtual AcDb::LineWeight | gridLineWeight (int row, int col, AcDb::CellEdgeMask iEdge) const
AcDb::LineWeight | gridLineWeight (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ADESK_DEPRECATED
AcDb::Visibility 		gridVisibility (AcDb::GridLineType gridlineType, AcDb::RowType type=AcDb::kDataRow) const
virtual AcDb::Visibility | gridVisibility (int row, int col, AcDb::CellEdgeMask iEdge) const
AcDb::Visibility | gridVisibility (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
bool | hasFormula (int nRow, int nCol, int nContent) const
virtual bool | hasSubSelection () const
virtual double | height () const
virtual bool | hitTest (const AcGePoint3d &wpt, const AcGeVector3d &wviewVec, double wxaper, double wyaper, int &resultRowIndex, int &resultColumnIndex)
bool | hitTest (const AcGePoint3d &wpt, const AcGeVector3d &wviewVec, double wxaper, double wyaper, int &resultRowIndex, int &resultColumnIndex, int &contentIndex, AcDb::TableHitItem &nItem)
virtual ADESK_DEPRECATED double | horzCellMargin () const
virtual Acad::ErrorStatus | insertColumns (int col, double width, int nCols=1)
Acad::ErrorStatus | insertColumnsAndInherit (int col, int nInheritFrom, int nNumCols)
virtual Acad::ErrorStatus | insertRows (int row, double height, int nRows=1)
Acad::ErrorStatus | insertRowsAndInherit (int nIndex, int nInheritFrom, int nNumRows)
virtual ADESK_DEPRECATED bool | isAutoScale (int row, int col) const
bool | isAutoScale (int row, int col, int nContent) const
virtual ADESK_DEPRECATED bool | isBackgroundColorNone (AcDb::RowType type=AcDb::kDataRow) const
virtual bool | isBackgroundColorNone (int row, int col) const
bool | isBreakEnabled (void) const
bool | isContentEditable (int nRow, int nCol) const
bool | isEmpty (int nRow, int nCol) const
bool | isFormatEditable (int nRow, int nCol) const
virtual ADESK_DEPRECATED bool | isHeaderSuppressed () const
bool | isLinked (int nRow, int nCol) const
bool | isMergeAllEnabled (int nRow, int nCol) const
virtual bool | isMergedCell (int row, int col, int *minRow=NULL, int *maxRow=NULL, int *minCol=NULL, int *maxCol=NULL) const
bool | isRegenerateTableSuppressed () const
virtual ADESK_DEPRECATED bool | isTitleSuppressed () const
virtual void | list () const
double | margin (int nRow, int nCol, AcDb::CellMargin nMargin) const
virtual Acad::ErrorStatus | mergeCells (int minRow, int maxRow, int minCol, int maxCol)
virtual double | minimumColumnWidth (int col) const
virtual double | minimumRowHeight (int row) const
virtual double | minimumTableHeight () const
virtual double | minimumTableWidth () const
Acad::ErrorStatus | moveContent (int nRow, int nCol, int nFromIndex, int nToIndex)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &, const AcGeVector3d &)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Adesk::UInt32 | numColumns () const
int | numContents (int nRow, int nCol) const
virtual Adesk::UInt32 | numRows () const
virtual void | objectClosed (const AcDbObjectId objId)
virtual bool | receiveShadows () const
virtual Acad::ErrorStatus | recomputeTableBlock (bool forceUpdate=true)
Acad::ErrorStatus | removeAllOverrides (int nRow, int nCol)
Acad::ErrorStatus | removeDataLink (int nRow, int nCol)
Acad::ErrorStatus | removeDataLink (void)
virtual bool | reselectSubRegion (AcDbFullSubentPathArray &paths) const
Acad::ErrorStatus | resetValue (int row, int col)
double | rotation (void) const
double | rotation (int row, int col, int nContent) const
virtual double | rowHeight (int row) const
virtual ADESK_DEPRECATED
AcDb::RowType 		rowType (int row) const
double | scale (int row, int col, int nContent) const
virtual Acad::ErrorStatus | select (const AcGePoint3d &wpt, const AcGeVector3d &wvwVec, const AcGeVector3d &wvwxVec, double wxaper, double wyaper, bool allowOutside, bool bInPickFirst, int &resultRowIndex, int &resultColumnIndex, AcDbFullSubentPathArray *pPaths=NULL) const
virtual Acad::ErrorStatus | select_next_cell (int dir, int &resultRowIndex, int &resultColumnIndex, AcDbFullSubentPathArray *pPaths=NULL, bool bSupportTextCellOnly=true) const
virtual Acad::ErrorStatus | selectSubRegion (const AcGePoint3d &wpt1, const AcGePoint3d &wpt2, const AcGeVector3d &wvwVec, const AcGeVector3d &wvwxVec, double wxaper, double wyaper, AcDb::SelectType seltype, bool bIncludeCurrentSelection, bool bInPickFirst, int &rowMin, int &rowMax, int &colMin, int &colMax, AcDbFullSubentPathArray *pPaths=NULL) const
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setAlignment (AcDb::CellAlignment align, int rowTypes=AcDb::kAllRows)
virtual Acad::ErrorStatus | setAlignment (int row, int col, AcDb::CellAlignment align)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setAutoScale (int row, int col, bool autoFit)
Acad::ErrorStatus | setAutoScale (int row, int col, int nContent, bool autoFit)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setBackgroundColor (const AcCmColor &color, int rowTypes=AcDb::kAllRows)
virtual Acad::ErrorStatus | setBackgroundColor (int row, int col, const AcCmColor &color)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setBackgroundColorNone (bool value, int rowTypes=AcDb::kAllRows)
virtual Acad::ErrorStatus | setBackgroundColorNone (int row, int col, bool value)
virtual Acad::ErrorStatus | setBlockAttributeValue (int row, int col, const AcDbObjectId &attdefId, const ACHAR *value)
Acad::ErrorStatus | setBlockAttributeValue (int row, int col, int nContent, const AcDbObjectId &attdefId, const ACHAR *value)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setBlockRotation (int row, int col, double rotAng)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setBlockScale (int row, int col, double scale)
virtual Acad::ErrorStatus | setBlockTableRecordId (int row, int col, const AcDbObjectId &blkId, bool autoFit=false)
Acad::ErrorStatus | setBlockTableRecordId (int row, int col, int nContent, const AcDbObjectId &blkId, bool autoFit)
Acad::ErrorStatus | setBreakFlowDirection (AcDb::TableBreakFlowDirection nDir)
Acad::ErrorStatus | setBreakHeight (int nIndex, double fHeight)
Acad::ErrorStatus | setBreakOffset (int nIndex, const AcGeVector3d &vec)
Acad::ErrorStatus | setBreakOption (AcDb::TableBreakOption nOption)
Acad::ErrorStatus | setBreakSpacing (double fSpacing)
virtual void | setCastShadows (bool newVal)
Acad::ErrorStatus | setCellState (int nRow, int nCol, AcDb::CellState nLock)
Acad::ErrorStatus | setCellStyle (int nRow, int nCol, const ACHAR *pszCellStyle)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setCellType (int row, int col, AcDb::CellType type)
Acad::ErrorStatus | setColumnName (int nIndex, const ACHAR *pszName)
virtual Acad::ErrorStatus | setColumnWidth (int col, double width)
virtual Acad::ErrorStatus | setColumnWidth (double width)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setContentColor (const AcCmColor &color, int nRowType=AcDb::kAllRows)
virtual Acad::ErrorStatus | setContentColor (int row, int col, const AcCmColor &color)
Acad::ErrorStatus | setContentColor (int row, int col, int nContent, const AcCmColor &color)
Acad::ErrorStatus | setContentLayout (int row, int col, AcDb::CellContentLayout nLayout)
Acad::ErrorStatus | setCustomData (int nRow, int nCol, int nData)
Acad::ErrorStatus | setCustomData (int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData)
Acad::ErrorStatus | setDataFormat (int row, int col, const ACHAR *pszFormat)
Acad::ErrorStatus | setDataFormat (int row, int col, int nContent, const ACHAR *pszFormat)
Acad::ErrorStatus | setDataLink (int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate)
Acad::ErrorStatus | setDataLink (const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setDataType (AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setDataType (AcValue::DataType nDataType, AcValue::UnitType nUnitType, int nRowTypes)
Acad::ErrorStatus | setDataType (int row, int col, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
Acad::ErrorStatus | setDataType (int row, int col, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual Acad::ErrorStatus | setDirection (const AcGeVector3d &horzVec)
virtual Acad::ErrorStatus | setFieldId (int row, int col, const AcDbObjectId &fieldId)
virtual Acad::ErrorStatus | setFieldId (int row, int col, const AcDbObjectId &fieldId, AcDb::CellOption nFlag)
Acad::ErrorStatus | setFieldId (int row, int col, int nContent, const AcDbObjectId &fieldId, AcDb::CellOption nFlag)
virtual Acad::ErrorStatus | setFlowDirection (AcDb::FlowDirection flow)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setFormat (const ACHAR *pszFormat)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setFormat (const ACHAR *pszFormat, int nRowTypes)
ADESK_DEPRECATED Acad::ErrorStatus | setFormat (int row, int col, const ACHAR *pszFormat)
Acad::ErrorStatus | setFormula (int nRow, int nCol, int nContent, const ACHAR *pszFormula)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setGridColor (const AcCmColor &color, int nBorders, int nRows)
virtual Acad::ErrorStatus | setGridColor (int row, int col, short nEdges, const AcCmColor &color)
Acad::ErrorStatus | setGridColor (int nRow, int nCol, AcDb::GridLineType nGridlineTypes, const AcCmColor &color)
Acad::ErrorStatus | setGridDoubleLineSpacing (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, double fSpacing)
Acad::ErrorStatus | setGridLineStyle (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::GridLineStyle nLineStyle)
Acad::ErrorStatus | setGridLinetype (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcDbObjectId &idLinetype)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setGridLineWeight (AcDb::LineWeight lwt, int nBorders, int nRows)
virtual Acad::ErrorStatus | setGridLineWeight (int row, int col, short nEdges, AcDb::LineWeight value)
Acad::ErrorStatus | setGridLineWeight (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::LineWeight nLineWeight)
Acad::ErrorStatus | setGridProperty (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp)
Acad::ErrorStatus | setGridProperty (const AcCellRange &rangeIn, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setGridVisibility (AcDb::Visibility visible, int nBorders, int nRows)
virtual Acad::ErrorStatus | setGridVisibility (int row, int col, short nEdges, AcDb::Visibility value)
Acad::ErrorStatus | setGridVisibility (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::Visibility nVisibility)
virtual Acad::ErrorStatus | setHeight (double height)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setHorzCellMargin (double gap)
Acad::ErrorStatus | setMargin (int nRow, int nCol, AcDb::CellMargin nMargins, double fMargin)
virtual Acad::ErrorStatus | setNormal (const AcGeVector3d &newVal)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setNumColumns (int nCols)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setNumRows (int nRows)
Acad::ErrorStatus | setOverride (int nRow, int nCol, int nContent, AcDb::CellProperty nOverride)
Acad::ErrorStatus | setOverride (int nRow, int nCol, AcDb::GridLineType nGridLineType, AcDb::GridProperty nOverride)
virtual Acad::ErrorStatus | setPosition (const AcGePoint3d &)
virtual void | setReceiveShadows (bool newVal)
virtual void | setRegen ()
Acad::ErrorStatus | setRotation (double fAngle)
Acad::ErrorStatus | setRotation (int row, int col, int nContent, double fAngle)
virtual Acad::ErrorStatus | setRowHeight (int row, double height)
virtual Acad::ErrorStatus | setRowHeight (double height)
Acad::ErrorStatus | setScale (int row, int col, int nContent, double scale)
Acad::ErrorStatus | setSize (int nRows, int nCols)
virtual Acad::ErrorStatus | setSubSelection (int rowMin, int rowMax, int colMin, int colMax)
Acad::ErrorStatus | setSubSelection (const AcCellRange &range)
virtual Acad::ErrorStatus | setTableStyle (const AcDbObjectId &id)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setTextHeight (double height, int rowTypes=AcDb::kAllRows)
virtual Acad::ErrorStatus | setTextHeight (int row, int col, double height)
Acad::ErrorStatus | setTextHeight (int row, int col, int nContent, double height)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setTextRotation (int row, int col, AcDb::RotationAngle rot)
virtual Acad::ErrorStatus | setTextString (int row, int col, const ACHAR *text)
Acad::ErrorStatus | setTextString (int row, int col, int nContent, const ACHAR *text)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setTextStyle (const AcDbObjectId &id, int rowTypes=AcDb::kAllRows)
virtual Acad::ErrorStatus | setTextStyle (int row, int col, const AcDbObjectId &id)
Acad::ErrorStatus | setTextStyle (int row, int col, int nContent, const AcDbObjectId &id)
Acad::ErrorStatus | setToolTip (int nRow, int nCol, const ACHAR *pszToolTip)
Acad::ErrorStatus | setValue (int row, int col, const AcValue &val)
Acad::ErrorStatus | setValue (int row, int col, LPCTSTR pszText, AcValue::ParseOption nOption)
Acad::ErrorStatus | setValue (int row, int col, int nContent, const AcValue &val)
Acad::ErrorStatus | setValue (int row, int col, int nContent, const AcValue &val, AcValue::ParseOption nOption)
Acad::ErrorStatus | setValue (int row, int col, int nContent, LPCTSTR pszText, AcValue::ParseOption nOption)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setVertCellMargin (double gap)
virtual Acad::ErrorStatus | setWidth (double width)
virtual Acad::ErrorStatus | subClose ()
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		suppressHeaderRow (bool value)
virtual void | suppressInvisibleGrid (bool value)
void | suppressRegenerateTable (bool bSuppress)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		suppressTitleRow (bool value)
virtual AcDbObjectId | tableStyle () const
virtual ADESK_DEPRECATED bool | tableStyleOverrides (AcDbIntArray &overrides) const
virtual ADESK_DEPRECATED double | textHeight (AcDb::RowType type=AcDb::kDataRow) const
virtual double | textHeight (int row, int col) const
double | textHeight (int row, int col, int nContent) const
virtual ADESK_DEPRECATED
AcDb::RotationAngle 		textRotation (int row, int col) const
virtual ACHAR * | textString (int row, int col) const
virtual Acad::ErrorStatus | textString (int row, int col, AcValue::FormatOption nOption, AcString &sText) const
AcString | textString (int row, int col, int nContent) const
Acad::ErrorStatus | textString (int row, int col, int nContent, AcValue::FormatOption nOption, AcString &sText) const
virtual const ACHAR * | textStringConst (int row, int col) const
virtual ADESK_DEPRECATED
AcDbObjectId 		textStyle (AcDb::RowType type=AcDb::kDataRow) const
virtual AcDbObjectId | textStyle (int row, int col) const
AcDbObjectId | textStyle (int row, int col, int nContent) const
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | unmergeCells (int minRow, int maxRow, int minCol, int maxCol)
Acad::ErrorStatus | updateDataLink (int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
Acad::ErrorStatus | updateDataLink (AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
AcValue | value (int row, int col) const
AcValue | value (int row, int col, int nContent) const
AcValue | value (int row, int col, int nContent, AcValue::FormatOption nOption) const
virtual ADESK_DEPRECATED double | vertCellMargin () const
virtual double | width () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *worldDraw)
- Public Member Functions inherited from AcDbBlockReference
ACDB_DECLARE_MEMBERS (AcDbBlockReference)
AcDbBlockReference (const AcGePoint3d &position, AcDbObjectId blockTableRec)
Acad::ErrorStatus | appendAttribute (AcDbAttribute *)
Acad::ErrorStatus | appendAttribute (AcDbObjectId &, AcDbAttribute *)
AcDbObjectIterator * | attributeIterator () const
AcDbObjectId | blockTableRecord () const
AcGeMatrix3d | blockTransform () const
virtual Acad::ErrorStatus | explodeToOwnerSpace () const
Acad::ErrorStatus | geomExtentsBestFit (AcDbExtents &extents, const AcGeMatrix3d &parentXform=AcGeMatrix3d::kIdentity) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const
virtual Adesk::Boolean | isPlanar () const
AcGeMatrix3d | nonAnnotationBlockTransform () const
AcGeScale3d | nonAnnotationScaleFactors () const
AcGeVector3d | normal () const
Acad::ErrorStatus | openAttribute (AcDbAttribute *&, AcDbObjectId, AcDb::OpenMode, bool openErasedOne=false)
Acad::ErrorStatus | openSequenceEnd (AcDbSequenceEnd *&, AcDb::OpenMode)
AcGePoint3d | position () const
AcGeScale3d | scaleFactors () const
virtual Acad::ErrorStatus | setBlockTableRecord (AcDbObjectId)
virtual Acad::ErrorStatus | setBlockTransform (const AcGeMatrix3d &)
virtual Acad::ErrorStatus | setScaleFactors (const AcGeScale3d &scale)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &) const
virtual Adesk::Boolean | treatAsAcDbBlockRefForExplode () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

virtual Acad::ErrorStatus subGetClassID (CLSID *pClsid) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

virtual bool AcDbTable::reselectSubRegion ( AcDbFullSubentPathArray & paths ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbTable::select | ( | const AcGePoint3d & | wpt,
 |  | const AcGeVector3d & | wvwVec,
 |  | const AcGeVector3d & | wvwxVec,
 |  | double | wxaper,
 |  | double | wyaper,
 |  | bool | allowOutside,
 |  | bool | bInPickFirst,
 |  | int & | resultRowIndex,
 |  | int & | resultColumnIndex,
 |  | AcDbFullSubentPathArray * | pPaths = NULL
 | ) |  | const
 virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbTable::select_next_cell | ( | int | dir,
 |  | int & | resultRowIndex,
 |  | int & | resultColumnIndex,
 |  | AcDbFullSubentPathArray * | pPaths = NULL,
 |  | bool | bSupportTextCellOnly = true
 | ) |  | const
 virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbtable.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTable Member List

This is the complete list of members for AcDbTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbTable) (defined in AcDbTable) | AcDbTable |
ACDB_DECLARE_MEMBERS(AcDbBlockReference) (defined in AcDbBlockReference) | AcDbBlockReference |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbBlockReference() (defined in AcDbBlockReference) | AcDbBlockReference |
AcDbBlockReference(const AcGePoint3d &position, AcDbObjectId blockTableRec) (defined in AcDbBlockReference) | AcDbBlockReference |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbTable() (defined in AcDbTable) | AcDbTable |
AcDbTable(const AcDbLinkedTableData *pTable, AcDb::TableCopyOption nCopyOption) (defined in AcDbTable) | AcDbTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
alignment(AcDb::RowType type=AcDb::kDataRow) const (defined in AcDbTable) | AcDbTable | virtual
alignment(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
appendAttribute(AcDbAttribute *) (defined in AcDbBlockReference) | AcDbBlockReference |
appendAttribute(AcDbObjectId &, AcDbAttribute *) (defined in AcDbBlockReference) | AcDbBlockReference |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
attachmentPoint(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
attachmentPoint(int row, int col, int content) const (defined in AcDbTable) | AcDbTable |
attributeIterator() const (defined in AcDbBlockReference) | AcDbBlockReference |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbTable) | AcDbTable | virtual
backgroundColor(AcDb::RowType type=AcDb::kDataRow) const (defined in AcDbTable) | AcDbTable | virtual
backgroundColor(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
blockRotation(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
blockScale(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
blockTableRecord() const (defined in AcDbBlockReference) | AcDbBlockReference |
blockTableRecordId(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
blockTableRecordId(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
blockTransform() const (defined in AcDbBlockReference) | AcDbBlockReference |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
breakFlowDirection(void) const (defined in AcDbTable) | AcDbTable |
breakHeight(int nIndex) const (defined in AcDbTable) | AcDbTable |
breakOffset(int nIndex) const (defined in AcDbTable) | AcDbTable |
breakOption(void) const (defined in AcDbTable) | AcDbTable |
breakSpacing(void) const (defined in AcDbTable) | AcDbTable |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
canDelete(int nIndex, int nCount, bool bRow) const (defined in AcDbTable) | AcDbTable |
canInsert(int nIndex, bool bRow) const (defined in AcDbTable) | AcDbTable |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbTable) | AcDbTable | virtual
cellState(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
cellStyle(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
cellStyleOverrides(int row, int col, AcDbIntArray &overrides) const (defined in AcDbTable) | AcDbTable | virtual
cellType(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
clearCellOverrides(int row, int column) (defined in AcDbTable) | AcDbTable |
clearSubSelection() (defined in AcDbTable) | AcDbTable | virtual
clearTableStyleOverrides(int options=0) (defined in AcDbTable) | AcDbTable | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
columnWidth(int col) const (defined in AcDbTable) | AcDbTable | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contentColor(AcDb::RowType type=AcDb::kDataRow) const (defined in AcDbTable) | AcDbTable | virtual
contentColor(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
contentColor(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
contentLayout(int row, int col) const (defined in AcDbTable) | AcDbTable |
contentType(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
contentType(int nRow, int nCol, int nIndex) const (defined in AcDbTable) | AcDbTable |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption) (defined in AcDbTable) | AcDbTable |
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRangeOut) (defined in AcDbTable) | AcDbTable |
copyFrom(const AcDbTable *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRangeOut) (defined in AcDbTable) | AcDbTable |
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createContent(int nRow, int nCol, int nIndex) (defined in AcDbTable) | AcDbTable |
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createTemplate(AcDbTableTemplate *&pTemplate, AcDb::TableCopyOption nCopyOption) (defined in AcDbTable) | AcDbTable |
database() const (defined in AcDbObject) | AcDbObject |
dataFormat(int row, int col) const (defined in AcDbTable) | AcDbTable |
dataFormat(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteCellContent(int row, int col) (defined in AcDbTable) | AcDbTable | virtual
deleteColumns(int col, int nCols=1) (defined in AcDbTable) | AcDbTable | virtual
deleteContent(int nRow, int nCol) (defined in AcDbTable) | AcDbTable |
deleteContent(int nRow, int nCol, int nIndex) (defined in AcDbTable) | AcDbTable |
deleteContent(const AcCellRange &range) (defined in AcDbTable) | AcDbTable |
deleteRows(int row, int nRows=1) (defined in AcDbTable) | AcDbTable | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
direction() const (defined in AcDbTable) | AcDbTable | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *) (defined in AcDbTable) | AcDbTable | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *) const (defined in AcDbTable) | AcDbTable | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *) (defined in AcDbTable) | AcDbTable | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *) const (defined in AcDbTable) | AcDbTable | virtual
enableBreak(bool bEnable) (defined in AcDbTable) | AcDbTable |
enableMergeAll(int nRow, int nCol, bool bEnable) (defined in AcDbTable) | AcDbTable |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbTable) | AcDbTable | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbTable) | AcDbTable | virtual
explodeToOwnerSpace() const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fieldId(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
fieldId(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
fill(const AcCellRange &fillRange, const AcCellRange &srcRange, AcDb::TableFillOption nOption) (defined in AcDbTable) | AcDbTable |
flowDirection() const (defined in AcDbTable) | AcDbTable | virtual
format(AcDb::RowType type) (defined in AcDbTable) | AcDbTable | virtual
format(int row, int col) const (defined in AcDbTable) | AcDbTable |
generateLayout() (defined in AcDbTable) | AcDbTable | virtual
geomExtentsBestFit(AcDbExtents &extents, const AcGeMatrix3d &parentXform=AcGeMatrix3d::kIdentity) const (defined in AcDbBlockReference) | AcDbBlockReference |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBlockAttributeValue(int row, int col, const AcDbObjectId &attdefId, ACHAR *&value) const (defined in AcDbTable) | AcDbTable | virtual
getBlockAttributeValue(int row, int col, int nContent, const AcDbObjectId &attdefId, ACHAR *&value) const (defined in AcDbTable) | AcDbTable |
getCellExtents(int row, int col, bool isOuterCell, AcGePoint3dArray &pts) const (defined in AcDbTable) | AcDbTable | virtual
getCellExtents(int row, int col, double &cellWidth, double &cellHeight, bool bAdjustForMargins) const (defined in AcDbTable) | AcDbTable | virtual
getClassID(CLSID *pClsid) const (defined in AcDbTable) | AcDbTable | virtual
getColumnName(int nIndex) const (defined in AcDbTable) | AcDbTable |
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getCustomData(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
getCustomData(int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const (defined in AcDbTable) | AcDbTable |
getDataLink(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
getDataLink(int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const (defined in AcDbTable) | AcDbTable |
getDataLink(const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const (defined in AcDbTable) | AcDbTable |
getDataLinkRange(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
getDataType(AcValue::DataType &nDataType, AcValue::UnitType &nUnitType, AcDb::RowType type) const (defined in AcDbTable) | AcDbTable | virtual
getDataType(int row, int col, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbTable) | AcDbTable |
getDataType(int row, int col, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbTable) | AcDbTable |
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFormula(int nRow, int nCol, int nContent) const (defined in AcDbTable) | AcDbTable |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbTable) | AcDbTable | virtual
getGridProperty(int nRow, int nCol, AcDb::GridLineType nGridLineType, AcGridProperty &gridProp) const (defined in AcDbTable) | AcDbTable |
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &, AcDbIntArray &, AcDbIntArray &geomIds) const (defined in AcDbTable) | AcDbTable | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getIndicatorSize(double &fWidth, double &fHeight) const (defined in AcDbTable) | AcDbTable |
getIterator(void) const (defined in AcDbTable) | AcDbTable |
getIterator(const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const (defined in AcDbTable) | AcDbTable |
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getMergeRange(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbTable) | AcDbTable | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOverride(int nRow, int nCol, int nContent) const (defined in AcDbTable) | AcDbTable |
getOverride(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbTable) | AcDbTable |
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbTable) | AcDbTable | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubSelection(int &rowMin, int &rowMax, int &colMin, int &colMax) const (defined in AcDbTable) | AcDbTable | virtual
getSubSelection(void) const (defined in AcDbTable) | AcDbTable |
getToolTip(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&ent) const (defined in AcDbTable) | AcDbTable | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gridColor(AcDb::GridLineType gridlineType, AcDb::RowType type=AcDb::kDataRow) const (defined in AcDbTable) | AcDbTable | virtual
gridColor(int row, int col, AcDb::CellEdgeMask iEdge) const (defined in AcDbTable) | AcDbTable | virtual
gridColor(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbTable) | AcDbTable |
gridDoubleLineSpacing(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbTable) | AcDbTable |
gridLineStyle(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbTable) | AcDbTable |
gridLinetype(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbTable) | AcDbTable |
gridLineWeight(AcDb::GridLineType gridlineType, AcDb::RowType type=AcDb::kDataRow) const (defined in AcDbTable) | AcDbTable | virtual
gridLineWeight(int row, int col, AcDb::CellEdgeMask iEdge) const (defined in AcDbTable) | AcDbTable | virtual
gridLineWeight(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbTable) | AcDbTable |
gridVisibility(AcDb::GridLineType gridlineType, AcDb::RowType type=AcDb::kDataRow) const (defined in AcDbTable) | AcDbTable | virtual
gridVisibility(int row, int col, AcDb::CellEdgeMask iEdge) const (defined in AcDbTable) | AcDbTable | virtual
gridVisibility(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbTable) | AcDbTable |
gripStatus(const AcDb::GripStat status) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasFormula(int nRow, int nCol, int nContent) const (defined in AcDbTable) | AcDbTable |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hasSubSelection() const (defined in AcDbTable) | AcDbTable | virtual
height() const (defined in AcDbTable) | AcDbTable | virtual
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
hitTest(const AcGePoint3d &wpt, const AcGeVector3d &wviewVec, double wxaper, double wyaper, int &resultRowIndex, int &resultColumnIndex) (defined in AcDbTable) | AcDbTable | virtual
hitTest(const AcGePoint3d &wpt, const AcGeVector3d &wviewVec, double wxaper, double wyaper, int &resultRowIndex, int &resultColumnIndex, int &contentIndex, AcDb::TableHitItem &nItem) (defined in AcDbTable) | AcDbTable |
horzCellMargin() const (defined in AcDbTable) | AcDbTable | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
insertColumns(int col, double width, int nCols=1) (defined in AcDbTable) | AcDbTable | virtual
insertColumnsAndInherit(int col, int nInheritFrom, int nNumCols) (defined in AcDbTable) | AcDbTable |
insertRows(int row, double height, int nRows=1) (defined in AcDbTable) | AcDbTable | virtual
insertRowsAndInherit(int nIndex, int nInheritFrom, int nNumRows) (defined in AcDbTable) | AcDbTable |
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isAutoScale(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
isAutoScale(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
isBackgroundColorNone(AcDb::RowType type=AcDb::kDataRow) const (defined in AcDbTable) | AcDbTable | virtual
isBackgroundColorNone(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
isBreakEnabled(void) const (defined in AcDbTable) | AcDbTable |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isContentEditable(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
isEmpty(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFormatEditable(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
isHeaderSuppressed() const (defined in AcDbTable) | AcDbTable | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLinked(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
isMergeAllEnabled(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
isMergedCell(int row, int col, int *minRow=NULL, int *maxRow=NULL, int *minCol=NULL, int *maxCol=NULL) const (defined in AcDbTable) | AcDbTable | virtual
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbBlockReference) | AcDbBlockReference | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isRegenerateTableSuppressed() const (defined in AcDbTable) | AcDbTable |
isTitleSuppressed() const (defined in AcDbTable) | AcDbTable | virtual
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kCellAlignment enum value (defined in AcDbTable) | AcDbTable |
kCellBackgroundColor enum value (defined in AcDbTable) | AcDbTable |
kCellBackgroundFillNone enum value (defined in AcDbTable) | AcDbTable |
kCellBottomGridColor enum value (defined in AcDbTable) | AcDbTable |
kCellBottomGridLineWeight enum value (defined in AcDbTable) | AcDbTable |
kCellBottomVisibility enum value (defined in AcDbTable) | AcDbTable |
kCellContentColor enum value (defined in AcDbTable) | AcDbTable |
kCellDataType enum value (defined in AcDbTable) | AcDbTable |
kCellLeftGridColor enum value (defined in AcDbTable) | AcDbTable |
kCellLeftGridLineWeight enum value (defined in AcDbTable) | AcDbTable |
kCellLeftVisibility enum value (defined in AcDbTable) | AcDbTable |
kCellRightGridColor enum value (defined in AcDbTable) | AcDbTable |
kCellRightGridLineWeight enum value (defined in AcDbTable) | AcDbTable |
kCellRightVisibility enum value (defined in AcDbTable) | AcDbTable |
kCellTextHeight enum value (defined in AcDbTable) | AcDbTable |
kCellTextStyle enum value (defined in AcDbTable) | AcDbTable |
kCellTopGridColor enum value (defined in AcDbTable) | AcDbTable |
kCellTopGridLineWeight enum value (defined in AcDbTable) | AcDbTable |
kCellTopVisibility enum value (defined in AcDbTable) | AcDbTable |
kDataHorzBottomColor enum value (defined in AcDbTable) | AcDbTable |
kDataHorzBottomLineWeight enum value (defined in AcDbTable) | AcDbTable |
kDataHorzBottomVisibility enum value (defined in AcDbTable) | AcDbTable |
kDataHorzInsideColor enum value (defined in AcDbTable) | AcDbTable |
kDataHorzInsideLineWeight enum value (defined in AcDbTable) | AcDbTable |
kDataHorzInsideVisibility enum value (defined in AcDbTable) | AcDbTable |
kDataHorzTopColor enum value (defined in AcDbTable) | AcDbTable |
kDataHorzTopLineWeight enum value (defined in AcDbTable) | AcDbTable |
kDataHorzTopVisibility enum value (defined in AcDbTable) | AcDbTable |
kDataRowAlignment enum value (defined in AcDbTable) | AcDbTable |
kDataRowColor enum value (defined in AcDbTable) | AcDbTable |
kDataRowDataType enum value (defined in AcDbTable) | AcDbTable |
kDataRowFillColor enum value (defined in AcDbTable) | AcDbTable |
kDataRowFillNone enum value (defined in AcDbTable) | AcDbTable |
kDataRowTextHeight enum value (defined in AcDbTable) | AcDbTable |
kDataRowTextStyle enum value (defined in AcDbTable) | AcDbTable |
kDataVertInsideColor enum value (defined in AcDbTable) | AcDbTable |
kDataVertInsideLineWeight enum value (defined in AcDbTable) | AcDbTable |
kDataVertInsideVisibility enum value (defined in AcDbTable) | AcDbTable |
kDataVertLeftColor enum value (defined in AcDbTable) | AcDbTable |
kDataVertLeftLineWeight enum value (defined in AcDbTable) | AcDbTable |
kDataVertLeftVisibility enum value (defined in AcDbTable) | AcDbTable |
kDataVertRightColor enum value (defined in AcDbTable) | AcDbTable |
kDataVertRightLineWeight enum value (defined in AcDbTable) | AcDbTable |
kDataVertRightVisibility enum value (defined in AcDbTable) | AcDbTable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFlowDirection enum value (defined in AcDbTable) | AcDbTable |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHeaderHorzBottomColor enum value (defined in AcDbTable) | AcDbTable |
kHeaderHorzBottomLineWeight enum value (defined in AcDbTable) | AcDbTable |
kHeaderHorzBottomVisibility enum value (defined in AcDbTable) | AcDbTable |
kHeaderHorzInsideColor enum value (defined in AcDbTable) | AcDbTable |
kHeaderHorzInsideLineWeight enum value (defined in AcDbTable) | AcDbTable |
kHeaderHorzInsideVisibility enum value (defined in AcDbTable) | AcDbTable |
kHeaderHorzTopColor enum value (defined in AcDbTable) | AcDbTable |
kHeaderHorzTopLineWeight enum value (defined in AcDbTable) | AcDbTable |
kHeaderHorzTopVisibility enum value (defined in AcDbTable) | AcDbTable |
kHeaderRowAlignment enum value (defined in AcDbTable) | AcDbTable |
kHeaderRowColor enum value (defined in AcDbTable) | AcDbTable |
kHeaderRowDataType enum value (defined in AcDbTable) | AcDbTable |
kHeaderRowFillColor enum value (defined in AcDbTable) | AcDbTable |
kHeaderRowFillNone enum value (defined in AcDbTable) | AcDbTable |
kHeaderRowTextHeight enum value (defined in AcDbTable) | AcDbTable |
kHeaderRowTextStyle enum value (defined in AcDbTable) | AcDbTable |
kHeaderSuppressed enum value (defined in AcDbTable) | AcDbTable |
kHeaderVertInsideColor enum value (defined in AcDbTable) | AcDbTable |
kHeaderVertInsideLineWeight enum value (defined in AcDbTable) | AcDbTable |
kHeaderVertInsideVisibility enum value (defined in AcDbTable) | AcDbTable |
kHeaderVertLeftColor enum value (defined in AcDbTable) | AcDbTable |
kHeaderVertLeftLineWeight enum value (defined in AcDbTable) | AcDbTable |
kHeaderVertLeftVisibility enum value (defined in AcDbTable) | AcDbTable |
kHeaderVertRightColor enum value (defined in AcDbTable) | AcDbTable |
kHeaderVertRightLineWeight enum value (defined in AcDbTable) | AcDbTable |
kHeaderVertRightVisibility enum value (defined in AcDbTable) | AcDbTable |
kHorzCellMargin enum value (defined in AcDbTable) | AcDbTable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kTitleHorzBottomColor enum value (defined in AcDbTable) | AcDbTable |
kTitleHorzBottomLineWeight enum value (defined in AcDbTable) | AcDbTable |
kTitleHorzBottomVisibility enum value (defined in AcDbTable) | AcDbTable |
kTitleHorzInsideColor enum value (defined in AcDbTable) | AcDbTable |
kTitleHorzInsideLineWeight enum value (defined in AcDbTable) | AcDbTable |
kTitleHorzInsideVisibility enum value (defined in AcDbTable) | AcDbTable |
kTitleHorzTopColor enum value (defined in AcDbTable) | AcDbTable |
kTitleHorzTopLineWeight enum value (defined in AcDbTable) | AcDbTable |
kTitleHorzTopVisibility enum value (defined in AcDbTable) | AcDbTable |
kTitleRowAlignment enum value (defined in AcDbTable) | AcDbTable |
kTitleRowColor enum value (defined in AcDbTable) | AcDbTable |
kTitleRowDataType enum value (defined in AcDbTable) | AcDbTable |
kTitleRowFillColor enum value (defined in AcDbTable) | AcDbTable |
kTitleRowFillNone enum value (defined in AcDbTable) | AcDbTable |
kTitleRowTextHeight enum value (defined in AcDbTable) | AcDbTable |
kTitleRowTextStyle enum value (defined in AcDbTable) | AcDbTable |
kTitleSuppressed enum value (defined in AcDbTable) | AcDbTable |
kTitleVertInsideColor enum value (defined in AcDbTable) | AcDbTable |
kTitleVertInsideLineWeight enum value (defined in AcDbTable) | AcDbTable |
kTitleVertInsideVisibility enum value (defined in AcDbTable) | AcDbTable |
kTitleVertLeftColor enum value (defined in AcDbTable) | AcDbTable |
kTitleVertLeftLineWeight enum value (defined in AcDbTable) | AcDbTable |
kTitleVertLeftVisibility enum value (defined in AcDbTable) | AcDbTable |
kTitleVertRightColor enum value (defined in AcDbTable) | AcDbTable |
kTitleVertRightLineWeight enum value (defined in AcDbTable) | AcDbTable |
kTitleVertRightVisibility enum value (defined in AcDbTable) | AcDbTable |
kVertCellMargin enum value (defined in AcDbTable) | AcDbTable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbTable) | AcDbTable | virtual
margin(int nRow, int nCol, AcDb::CellMargin nMargin) const (defined in AcDbTable) | AcDbTable |
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeCells(int minRow, int maxRow, int minCol, int maxCol) (defined in AcDbTable) | AcDbTable | virtual
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
minimumColumnWidth(int col) const (defined in AcDbTable) | AcDbTable | virtual
minimumRowHeight(int row) const (defined in AcDbTable) | AcDbTable | virtual
minimumTableHeight() const (defined in AcDbTable) | AcDbTable | virtual
minimumTableWidth() const (defined in AcDbTable) | AcDbTable | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveContent(int nRow, int nCol, int nFromIndex, int nToIndex) (defined in AcDbTable) | AcDbTable |
moveGripPointsAt(const AcDbIntArray &, const AcGeVector3d &) (defined in AcDbTable) | AcDbTable | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbTable) | AcDbTable | virtual
nonAnnotationBlockTransform() const (defined in AcDbBlockReference) | AcDbBlockReference |
nonAnnotationScaleFactors() const (defined in AcDbBlockReference) | AcDbBlockReference |
normal() const (defined in AcDbBlockReference) | AcDbBlockReference |
numColumns() const (defined in AcDbTable) | AcDbTable | virtual
numContents(int nRow, int nCol) const (defined in AcDbTable) | AcDbTable |
numRows() const (defined in AcDbTable) | AcDbTable | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbTable) | AcDbTable | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openAttribute(AcDbAttribute *&, AcDbObjectId, AcDb::OpenMode, bool openErasedOne=false) (defined in AcDbBlockReference) | AcDbBlockReference |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
openSequenceEnd(AcDbSequenceEnd *&, AcDb::OpenMode) (defined in AcDbBlockReference) | AcDbBlockReference |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbBlockReference) | AcDbBlockReference |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbTable) | AcDbTable | virtual
recomputeTableBlock(bool forceUpdate=true) (defined in AcDbTable) | AcDbTable | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeAllOverrides(int nRow, int nCol) (defined in AcDbTable) | AcDbTable |
removeDataLink(int nRow, int nCol) (defined in AcDbTable) | AcDbTable |
removeDataLink(void) (defined in AcDbTable) | AcDbTable |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
reselectSubRegion(AcDbFullSubentPathArray &paths) const | AcDbTable | virtual
resetValue(int row, int col) (defined in AcDbTable) | AcDbTable |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation(void) const (defined in AcDbTable) | AcDbTable |
rotation(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
rowHeight(int row) const (defined in AcDbTable) | AcDbTable | virtual
rowType(int row) const (defined in AcDbTable) | AcDbTable | virtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
scale(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
scaleFactors() const (defined in AcDbBlockReference) | AcDbBlockReference |
select(const AcGePoint3d &wpt, const AcGeVector3d &wvwVec, const AcGeVector3d &wvwxVec, double wxaper, double wyaper, bool allowOutside, bool bInPickFirst, int &resultRowIndex, int &resultColumnIndex, AcDbFullSubentPathArray *pPaths=NULL) const | AcDbTable | virtual
select_next_cell(int dir, int &resultRowIndex, int &resultColumnIndex, AcDbFullSubentPathArray *pPaths=NULL, bool bSupportTextCellOnly=true) const | AcDbTable | virtual
selectSubRegion(const AcGePoint3d &wpt1, const AcGePoint3d &wpt2, const AcGeVector3d &wvwVec, const AcGeVector3d &wvwxVec, double wxaper, double wyaper, AcDb::SelectType seltype, bool bIncludeCurrentSelection, bool bInPickFirst, int &rowMin, int &rowMax, int &colMin, int &colMax, AcDbFullSubentPathArray *pPaths=NULL) const (defined in AcDbTable) | AcDbTable | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAlignment(AcDb::CellAlignment align, int rowTypes=AcDb::kAllRows) (defined in AcDbTable) | AcDbTable | virtual
setAlignment(int row, int col, AcDb::CellAlignment align) (defined in AcDbTable) | AcDbTable | virtual
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setAutoScale(int row, int col, bool autoFit) (defined in AcDbTable) | AcDbTable | virtual
setAutoScale(int row, int col, int nContent, bool autoFit) (defined in AcDbTable) | AcDbTable |
setBackgroundColor(const AcCmColor &color, int rowTypes=AcDb::kAllRows) (defined in AcDbTable) | AcDbTable | virtual
setBackgroundColor(int row, int col, const AcCmColor &color) (defined in AcDbTable) | AcDbTable | virtual
setBackgroundColorNone(bool value, int rowTypes=AcDb::kAllRows) (defined in AcDbTable) | AcDbTable | virtual
setBackgroundColorNone(int row, int col, bool value) (defined in AcDbTable) | AcDbTable | virtual
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockAttributeValue(int row, int col, const AcDbObjectId &attdefId, const ACHAR *value) (defined in AcDbTable) | AcDbTable | virtual
setBlockAttributeValue(int row, int col, int nContent, const AcDbObjectId &attdefId, const ACHAR *value) (defined in AcDbTable) | AcDbTable |
setBlockRotation(int row, int col, double rotAng) (defined in AcDbTable) | AcDbTable | virtual
setBlockScale(int row, int col, double scale) (defined in AcDbTable) | AcDbTable | virtual
setBlockTableRecord(AcDbObjectId) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setBlockTableRecordId(int row, int col, const AcDbObjectId &blkId, bool autoFit=false) (defined in AcDbTable) | AcDbTable | virtual
setBlockTableRecordId(int row, int col, int nContent, const AcDbObjectId &blkId, bool autoFit) (defined in AcDbTable) | AcDbTable |
setBlockTransform(const AcGeMatrix3d &) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setBreakFlowDirection(AcDb::TableBreakFlowDirection nDir) (defined in AcDbTable) | AcDbTable |
setBreakHeight(int nIndex, double fHeight) (defined in AcDbTable) | AcDbTable |
setBreakOffset(int nIndex, const AcGeVector3d &vec) (defined in AcDbTable) | AcDbTable |
setBreakOption(AcDb::TableBreakOption nOption) (defined in AcDbTable) | AcDbTable |
setBreakSpacing(double fSpacing) (defined in AcDbTable) | AcDbTable |
setCastShadows(bool newVal) (defined in AcDbTable) | AcDbTable | virtual
setCellState(int nRow, int nCol, AcDb::CellState nLock) (defined in AcDbTable) | AcDbTable |
setCellStyle(int nRow, int nCol, const ACHAR *pszCellStyle) (defined in AcDbTable) | AcDbTable |
setCellType(int row, int col, AcDb::CellType type) (defined in AcDbTable) | AcDbTable | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColumnName(int nIndex, const ACHAR *pszName) (defined in AcDbTable) | AcDbTable |
setColumnWidth(int col, double width) (defined in AcDbTable) | AcDbTable | virtual
setColumnWidth(double width) (defined in AcDbTable) | AcDbTable | virtual
setContentColor(const AcCmColor &color, int nRowType=AcDb::kAllRows) (defined in AcDbTable) | AcDbTable | virtual
setContentColor(int row, int col, const AcCmColor &color) (defined in AcDbTable) | AcDbTable | virtual
setContentColor(int row, int col, int nContent, const AcCmColor &color) (defined in AcDbTable) | AcDbTable |
setContentLayout(int row, int col, AcDb::CellContentLayout nLayout) (defined in AcDbTable) | AcDbTable |
setCustomData(int nRow, int nCol, int nData) (defined in AcDbTable) | AcDbTable |
setCustomData(int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData) (defined in AcDbTable) | AcDbTable |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDataFormat(int row, int col, const ACHAR *pszFormat) (defined in AcDbTable) | AcDbTable |
setDataFormat(int row, int col, int nContent, const ACHAR *pszFormat) (defined in AcDbTable) | AcDbTable |
setDataLink(int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbTable) | AcDbTable |
setDataLink(const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbTable) | AcDbTable |
setDataType(AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbTable) | AcDbTable | virtual
setDataType(AcValue::DataType nDataType, AcValue::UnitType nUnitType, int nRowTypes) (defined in AcDbTable) | AcDbTable | virtual
setDataType(int row, int col, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbTable) | AcDbTable |
setDataType(int row, int col, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbTable) | AcDbTable |
setDirection(const AcGeVector3d &horzVec) (defined in AcDbTable) | AcDbTable | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFieldId(int row, int col, const AcDbObjectId &fieldId) (defined in AcDbTable) | AcDbTable | virtual
setFieldId(int row, int col, const AcDbObjectId &fieldId, AcDb::CellOption nFlag) (defined in AcDbTable) | AcDbTable | virtual
setFieldId(int row, int col, int nContent, const AcDbObjectId &fieldId, AcDb::CellOption nFlag) (defined in AcDbTable) | AcDbTable |
setFlowDirection(AcDb::FlowDirection flow) (defined in AcDbTable) | AcDbTable | virtual
setFormat(const ACHAR *pszFormat) (defined in AcDbTable) | AcDbTable | virtual
setFormat(const ACHAR *pszFormat, int nRowTypes) (defined in AcDbTable) | AcDbTable | virtual
setFormat(int row, int col, const ACHAR *pszFormat) (defined in AcDbTable) | AcDbTable |
setFormula(int nRow, int nCol, int nContent, const ACHAR *pszFormula) (defined in AcDbTable) | AcDbTable |
setGridColor(const AcCmColor &color, int nBorders, int nRows) (defined in AcDbTable) | AcDbTable | virtual
setGridColor(int row, int col, short nEdges, const AcCmColor &color) (defined in AcDbTable) | AcDbTable | virtual
setGridColor(int nRow, int nCol, AcDb::GridLineType nGridlineTypes, const AcCmColor &color) (defined in AcDbTable) | AcDbTable |
setGridDoubleLineSpacing(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, double fSpacing) (defined in AcDbTable) | AcDbTable |
setGridLineStyle(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::GridLineStyle nLineStyle) (defined in AcDbTable) | AcDbTable |
setGridLinetype(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcDbObjectId &idLinetype) (defined in AcDbTable) | AcDbTable |
setGridLineWeight(AcDb::LineWeight lwt, int nBorders, int nRows) (defined in AcDbTable) | AcDbTable | virtual
setGridLineWeight(int row, int col, short nEdges, AcDb::LineWeight value) (defined in AcDbTable) | AcDbTable | virtual
setGridLineWeight(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::LineWeight nLineWeight) (defined in AcDbTable) | AcDbTable |
setGridProperty(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp) (defined in AcDbTable) | AcDbTable |
setGridProperty(const AcCellRange &rangeIn, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp) (defined in AcDbTable) | AcDbTable |
setGridVisibility(AcDb::Visibility visible, int nBorders, int nRows) (defined in AcDbTable) | AcDbTable | virtual
setGridVisibility(int row, int col, short nEdges, AcDb::Visibility value) (defined in AcDbTable) | AcDbTable | virtual
setGridVisibility(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::Visibility nVisibility) (defined in AcDbTable) | AcDbTable |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double height) (defined in AcDbTable) | AcDbTable | virtual
setHorzCellMargin(double gap) (defined in AcDbTable) | AcDbTable | virtual
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMargin(int nRow, int nCol, AcDb::CellMargin nMargins, double fMargin) (defined in AcDbTable) | AcDbTable |
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &newVal) (defined in AcDbTable) | AcDbTable | virtual
setNumColumns(int nCols) (defined in AcDbTable) | AcDbTable | virtual
setNumRows(int nRows) (defined in AcDbTable) | AcDbTable | virtual
setOverride(int nRow, int nCol, int nContent, AcDb::CellProperty nOverride) (defined in AcDbTable) | AcDbTable |
setOverride(int nRow, int nCol, AcDb::GridLineType nGridLineType, AcDb::GridProperty nOverride) (defined in AcDbTable) | AcDbTable |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbTable) | AcDbTable | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbTable) | AcDbTable | virtual
setRegen() (defined in AcDbTable) | AcDbTable | virtual
setRotation(double fAngle) (defined in AcDbTable) | AcDbTable | virtual
setRotation(int row, int col, int nContent, double fAngle) (defined in AcDbTable) | AcDbTable |
setRowHeight(int row, double height) (defined in AcDbTable) | AcDbTable | virtual
setRowHeight(double height) (defined in AcDbTable) | AcDbTable | virtual
setScale(int row, int col, int nContent, double scale) (defined in AcDbTable) | AcDbTable |
setScaleFactors(const AcGeScale3d &scale) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
setSize(int nRows, int nCols) (defined in AcDbTable) | AcDbTable |
setSubSelection(int rowMin, int rowMax, int colMin, int colMax) (defined in AcDbTable) | AcDbTable | virtual
setSubSelection(const AcCellRange &range) (defined in AcDbTable) | AcDbTable |
setTableStyle(const AcDbObjectId &id) (defined in AcDbTable) | AcDbTable | virtual
setTextHeight(double height, int rowTypes=AcDb::kAllRows) (defined in AcDbTable) | AcDbTable | virtual
setTextHeight(int row, int col, double height) (defined in AcDbTable) | AcDbTable | virtual
setTextHeight(int row, int col, int nContent, double height) (defined in AcDbTable) | AcDbTable |
setTextRotation(int row, int col, AcDb::RotationAngle rot) (defined in AcDbTable) | AcDbTable | virtual
setTextString(int row, int col, const ACHAR *text) (defined in AcDbTable) | AcDbTable | virtual
setTextString(int row, int col, int nContent, const ACHAR *text) (defined in AcDbTable) | AcDbTable |
setTextStyle(const AcDbObjectId &id, int rowTypes=AcDb::kAllRows) (defined in AcDbTable) | AcDbTable | virtual
setTextStyle(int row, int col, const AcDbObjectId &id) (defined in AcDbTable) | AcDbTable | virtual
setTextStyle(int row, int col, int nContent, const AcDbObjectId &id) (defined in AcDbTable) | AcDbTable |
setToolTip(int nRow, int nCol, const ACHAR *pszToolTip) (defined in AcDbTable) | AcDbTable |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setValue(int row, int col, const AcValue &val) (defined in AcDbTable) | AcDbTable |
setValue(int row, int col, LPCTSTR pszText, AcValue::ParseOption nOption) (defined in AcDbTable) | AcDbTable |
setValue(int row, int col, int nContent, const AcValue &val) (defined in AcDbTable) | AcDbTable |
setValue(int row, int col, int nContent, const AcValue &val, AcValue::ParseOption nOption) (defined in AcDbTable) | AcDbTable |
setValue(int row, int col, int nContent, LPCTSTR pszText, AcValue::ParseOption nOption) (defined in AcDbTable) | AcDbTable |
setVertCellMargin(double gap) (defined in AcDbTable) | AcDbTable | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWidth(double width) (defined in AcDbTable) | AcDbTable | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbTable) | AcDbTable | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subGetClassID(CLSID *pClsid) const (defined in AcDbTable) | AcDbTable | protectedvirtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
suppressHeaderRow(bool value) (defined in AcDbTable) | AcDbTable | virtual
suppressInvisibleGrid(bool value) (defined in AcDbTable) | AcDbTable | virtual
suppressRegenerateTable(bool bSuppress) (defined in AcDbTable) | AcDbTable |
suppressTitleRow(bool value) (defined in AcDbTable) | AcDbTable | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
tableStyle() const (defined in AcDbTable) | AcDbTable | virtual
TableStyleOverrides enum name (defined in AcDbTable) | AcDbTable |
tableStyleOverrides(AcDbIntArray &overrides) const (defined in AcDbTable) | AcDbTable | virtual
textHeight(AcDb::RowType type=AcDb::kDataRow) const (defined in AcDbTable) | AcDbTable | virtual
textHeight(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
textHeight(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
textRotation(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
textString(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
textString(int row, int col, AcValue::FormatOption nOption, AcString &sText) const (defined in AcDbTable) | AcDbTable | virtual
textString(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
textString(int row, int col, int nContent, AcValue::FormatOption nOption, AcString &sText) const (defined in AcDbTable) | AcDbTable |
textStringConst(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
textStyle(AcDb::RowType type=AcDb::kDataRow) const (defined in AcDbTable) | AcDbTable | virtual
textStyle(int row, int col) const (defined in AcDbTable) | AcDbTable | virtual
textStyle(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbTable) | AcDbTable | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
treatAsAcDbBlockRefForExplode() const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &=kNullSubent, const Adesk::Boolean highlightAll=Adesk::kFalse) const (defined in AcDbBlockReference) | AcDbBlockReference | virtual
unmergeCells(int minRow, int maxRow, int minCol, int maxCol) (defined in AcDbTable) | AcDbTable | virtual
updateDataLink(int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbTable) | AcDbTable |
updateDataLink(AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbTable) | AcDbTable |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
value(int row, int col) const (defined in AcDbTable) | AcDbTable |
value(int row, int col, int nContent) const (defined in AcDbTable) | AcDbTable |
value(int row, int col, int nContent, AcValue::FormatOption nOption) const (defined in AcDbTable) | AcDbTable |
vertCellMargin() const (defined in AcDbTable) | AcDbTable | virtual
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbBlockReference) | AcDbBlockReference | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
width() const (defined in AcDbTable) | AcDbTable | virtual
worldDraw(AcGiWorldDraw *worldDraw) (defined in AcDbTable) | AcDbTable | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbBlockReference() (defined in AcDbBlockReference) | AcDbBlockReference |
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbTable() (defined in AcDbTable) | AcDbTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbTableContent Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbTableContent Class Reference
AcDb Classes
+ Inheritance diagram for AcDbTableContent:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbTableContent)
virtual ACDB_PORT const ACHAR * | cellStyle (int nRow, int nCol) const
virtual ACDB_PORT double | columnWidth (int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual ACDB_PORT Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual ACDB_PORT Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
virtual ACDB_PORT double | rowHeight (int nRow) const
virtual ACDB_PORT Acad::ErrorStatus | setCellStyle (int nRow, int nCol, const ACHAR *pszCellStyle)
virtual ACDB_PORT Acad::ErrorStatus | setColumnWidth (int nCol, double fWidth)
virtual ACDB_PORT Acad::ErrorStatus | setRowHeight (int nRow, double fWidth)
virtual ACDB_PORT Acad::ErrorStatus | setTableStyleId (const AcDbObjectId &idTableStyle)
virtual ACDB_PORT AcDbObjectId | tableStyleId (void) const
- Public Member Functions inherited from AcDbFormattedTableData
ACDB_DECLARE_MEMBERS (AcDbFormattedTableData)
virtual ACDB_PORT
AcDb::CellAlignment 		alignment (int nRow, int nCol) const
virtual ACDB_PORT AcCmColor | backgroundColor (int nRow, int nCol) const
virtual ACDB_PORT AcCmColor | contentColor (int nRow, int nCol) const
virtual ACDB_PORT AcCmColor | contentColor (int nRow, int nCol, int nContent) const
virtual ACDB_PORT
AcDb::CellContentLayout 		contentLayout (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | enableMergeAll (int nRow, int nCol, bool bEnable)
virtual ACDB_PORT
AcDb::FlowDirection 		flowDirection (void) const
virtual ACDB_PORT Acad::ErrorStatus | getGridProperty (int nRow, int nCol, AcDb::GridLineType nGridLineType, AcGridProperty &gridProp) const
virtual ACDB_PORT AcCellRange | getMergeRange (int nRow, int nCol) const
virtual ACDB_PORT
AcDb::CellProperty 		getOverride (int nRow, int nCol, int nContent) const
virtual ACDB_PORT
AcDb::GridProperty 		getOverride (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcCmColor | gridColor (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT double | gridDoubleLineSpacing (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT
AcDb::GridLineStyle 		gridLineStyle (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcDbObjectId | gridLinetype (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcDb::LineWeight | gridLineWeight (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcDb::Visibility | gridVisibility (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT int | insertColumnAndInherit (int nIndex, int nInheritFrom, int nNumCols)
virtual ACDB_PORT int | insertRowAndInherit (int nIndex, int nInheritFrom, int nNumRows)
virtual ACDB_PORT bool | isAutoScale (int nRow, int nCol) const
virtual ACDB_PORT bool | isAutoScale (int nRow, int nCol, int nContent) const
virtual ACDB_PORT bool | isFormatEditable (int nRow, int nCol) const
virtual ACDB_PORT bool | isMergeAllEnabled (int nRow, int nCol) const
virtual ACDB_PORT bool | isMerged (int nRow, int nCol) const
virtual ACDB_PORT double | margin (int nRow, int nCol, AcDb::CellMargin nMargin) const
virtual ACDB_PORT Acad::ErrorStatus | merge (const AcCellRange &range)
virtual ACDB_PORT Acad::ErrorStatus | removeAllOverrides (int nRow, int nCol)
virtual ACDB_PORT double | rotation (int nRow, int nCol) const
virtual ACDB_PORT double | rotation (int nRow, int nCol, int nIndex) const
virtual ACDB_PORT double | scale (int nRow, int nCol) const
virtual ACDB_PORT double | scale (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | setAlignment (int nRow, int nCol, AcDb::CellAlignment nAlignment)
virtual ACDB_PORT Acad::ErrorStatus | setAutoScale (int nRow, int nCol, bool bAutoScale)
virtual ACDB_PORT Acad::ErrorStatus | setAutoScale (int nRow, int nCol, int nContent, bool bAutoScale)
virtual ACDB_PORT Acad::ErrorStatus | setBackgroundColor (int nRow, int nCol, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setContentColor (int nRow, int nCol, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setContentColor (int nRow, int nCol, int nContent, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setContentLayout (int nRow, int nCol, AcDb::CellContentLayout nLayout)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, const AcDbObjectId &idField, AcDb::CellOption nFlag)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, int nIndex, const AcDbObjectId &idField, AcDb::CellOption nFlag)
virtual ACDB_PORT Acad::ErrorStatus | setFlowDirection (AcDb::FlowDirection nDir)
virtual ACDB_PORT Acad::ErrorStatus | setGridColor (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setGridDoubleLineSpacing (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, double fSpacing)
virtual ACDB_PORT Acad::ErrorStatus | setGridLineStyle (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::GridLineStyle nLineStyle)
virtual ACDB_PORT Acad::ErrorStatus | setGridLinetype (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcDbObjectId &idLinetype)
virtual ACDB_PORT Acad::ErrorStatus | setGridLineWeight (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::LineWeight nLineWeight)
virtual ACDB_PORT Acad::ErrorStatus | setGridProperty (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp)
virtual ACDB_PORT Acad::ErrorStatus | setGridProperty (const AcCellRange &range, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp)
virtual ACDB_PORT Acad::ErrorStatus | setGridVisibility (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::Visibility nVisibility)
virtual ACDB_PORT Acad::ErrorStatus | setMargin (int nRow, int nCol, AcDb::CellMargin nMargins, double fMargin)
virtual ACDB_PORT Acad::ErrorStatus | setOverride (int nRow, int nCol, int nContent, AcDb::CellProperty nOverride)
virtual ACDB_PORT Acad::ErrorStatus | setOverride (int nRow, int nCol, AcDb::GridLineType nGridLineType, AcDb::GridProperty nOverride)
virtual ACDB_PORT Acad::ErrorStatus | setRotation (int nRow, int nCol, double fRotation)
virtual ACDB_PORT Acad::ErrorStatus | setRotation (int nRow, int nCol, int nContent, double fRotation)
virtual ACDB_PORT Acad::ErrorStatus | setScale (int nRow, int nCol, double fScale)
virtual ACDB_PORT Acad::ErrorStatus | setScale (int nRow, int nCol, int nIndex, double fScale)
virtual ACDB_PORT Acad::ErrorStatus | setTextHeight (int nRow, int nCol, double fTextHeight)
virtual ACDB_PORT Acad::ErrorStatus | setTextHeight (int nRow, int nCol, int nContent, double fTextHeight)
virtual ACDB_PORT Acad::ErrorStatus | setTextStyle (int nRow, int nCol, const AcDbObjectId &idTextStyle)
virtual ACDB_PORT Acad::ErrorStatus | setTextStyle (int nRow, int nCol, int nContent, const AcDbObjectId &idTextStyle)
virtual ACDB_PORT double | textHeight (int nRow, int nCol) const
virtual ACDB_PORT double | textHeight (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcDbObjectId | textStyle (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | textStyle (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | unmerge (const AcCellRange &range)
- Public Member Functions inherited from AcDbLinkedTableData
ACDB_DECLARE_MEMBERS (AcDbLinkedTableData)
virtual ACDB_PORT int | appendColumn (int nNumCols)
virtual ACDB_PORT int | appendRow (int nNumRows)
virtual ACDB_PORT bool | canDelete (int nIndex, int nCount, bool bRow) const
virtual ACDB_PORT bool | canInsert (int nIndex, bool bRow) const
virtual ACDB_PORT AcDb::CellState | cellState (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | clear (void)
virtual ACDB_PORT
AcDb::CellContentType 		contentType (int nRow, int nCol) const
virtual ACDB_PORT
AcDb::CellContentType 		contentType (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRange)
virtual ACDB_PORT int | createContent (int nRow, int nCol, int nIndex)
virtual ACDB_PORT AcString | dataFormat (int nRow, int nCol) const
virtual ACDB_PORT AcString | dataFormat (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | deleteColumn (int nIndex, int nNumColsToDelete)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (int nRow, int nCol, int nContent)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (int nRow, int nCol)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (const AcCellRange &range)
virtual ACDB_PORT Acad::ErrorStatus | deleteRow (int nIndex, int nNumRowsToDelete)
virtual ACDB_PORT Acad::ErrorStatus | evaluateFormula (void)
virtual ACDB_PORT AcString | getBlockAttributeValue (int nRow, int nCol, const AcDbObjectId &idAttDef) const
virtual ACDB_PORT AcString | getBlockAttributeValue (int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef) const
virtual ACDB_PORT AcDbObjectId | getBlockTableRecordId (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | getBlockTableRecordId (int nRow, int nCol, int nContent) const
virtual ACDB_PORT const ACHAR * | getColumnName (int nIndex) const
virtual ACDB_PORT int | getCustomData (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getCustomData (int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const
virtual ACDB_PORT AcDbObjectId | getDataLink (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getDataLink (int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const
virtual ACDB_PORT int | getDataLink (const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const
virtual ACDB_PORT AcCellRange | getDataLinkRange (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getDataType (int nRow, int nCol, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
virtual ACDB_PORT Acad::ErrorStatus | getDataType (int nRow, int nCol, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
virtual ACDB_PORT Acad::ErrorStatus | getField (int nRow, int nCol, int nContent, AcDbField *&pField, AcDb::OpenMode mode) const
virtual ACDB_PORT AcDbObjectId | getFieldId (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | getFieldId (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcString | getFormula (int nRow, int nCol, int nContent) const
ACDB_PORT AcDbTableIterator * | getIterator (void) const
ACDB_PORT AcDbTableIterator * | getIterator (const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol, int nContent, AcValue::FormatOption nOption) const
virtual ACDB_PORT AcString | getToolTip (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getValue (int nRow, int nCol, AcValue &value) const
virtual ACDB_PORT Acad::ErrorStatus | getValue (int nRow, int nCol, int nContent, AcValue::FormatOption nOption, AcValue &value) const
virtual ACDB_PORT bool | hasFormula (int nRow, int nCol, int nContent) const
virtual ACDB_PORT int | insertColumn (int nIndex, int nNumCols)
virtual ACDB_PORT int | insertRow (int nIndex, int nNumRows)
virtual ACDB_PORT bool | isContentEditable (int nRow, int nCol) const
virtual ACDB_PORT bool | isLinked (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | moveContent (int nRow, int nCol, int nFromIndex, int nToIndex)
virtual ACDB_PORT int | numColumns (void) const
virtual ACDB_PORT int | numContents (int nRow, int nCol) const
virtual ACDB_PORT int | numRows (void) const
virtual ACDB_PORT Acad::ErrorStatus | removeDataLink (int nRow, int nCol)
virtual ACDB_PORT Acad::ErrorStatus | removeDataLink (void)
virtual ACDB_PORT Acad::ErrorStatus | setBlockAttributeValue (int nRow, int nCol, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue)
virtual ACDB_PORT Acad::ErrorStatus | setBlockAttributeValue (int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue)
virtual ACDB_PORT Acad::ErrorStatus | setBlockTableRecordId (int nRow, int nCol, const AcDbObjectId &idBTR)
virtual ACDB_PORT Acad::ErrorStatus | setBlockTableRecordId (int nRow, int nCol, int nContent, const AcDbObjectId &idBTR)
virtual ACDB_PORT Acad::ErrorStatus | setCellState (int nRow, int nCol, AcDb::CellState nCellState)
virtual ACDB_PORT Acad::ErrorStatus | setColumnName (int nIndex, const ACHAR *pszName)
virtual ACDB_PORT Acad::ErrorStatus | setCustomData (int nRow, int nCol, int nData)
virtual ACDB_PORT Acad::ErrorStatus | setCustomData (int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData)
virtual ACDB_PORT Acad::ErrorStatus | setDataFormat (int nRow, int nCol, const ACHAR *pszFormat)
virtual ACDB_PORT Acad::ErrorStatus | setDataFormat (int nRow, int nCol, int nContent, const ACHAR *pszFormat)
virtual ACDB_PORT Acad::ErrorStatus | setDataLink (int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate)
virtual ACDB_PORT Acad::ErrorStatus | setDataLink (const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate)
virtual ACDB_PORT Acad::ErrorStatus | setDataType (int nRow, int nCol, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ACDB_PORT Acad::ErrorStatus | setDataType (int nRow, int nCol, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, const AcDbObjectId &idField)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, int nContent, const AcDbObjectId &idField)
virtual ACDB_PORT Acad::ErrorStatus | setFormula (int nRow, int nCol, int nContent, const ACHAR *pszFormula)
virtual ACDB_PORT Acad::ErrorStatus | setSize (int nRows, int nCols)
virtual ACDB_PORT Acad::ErrorStatus | setText (int nRow, int nCol, const ACHAR *pszText)
virtual ACDB_PORT Acad::ErrorStatus | setText (int nRow, int nCol, int nContent, const ACHAR *pszText)
virtual ACDB_PORT Acad::ErrorStatus | setToolTip (int nRow, int nCol, const ACHAR *pszToolTip)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, const AcValue &value)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, int nContent, const AcValue &value)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, int nContent, const AcValue &value, AcValue::ParseOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | updateDataLink (int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | updateDataLink (AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
- Public Member Functions inherited from AcDbLinkedData
ACDB_DECLARE_MEMBERS (AcDbLinkedData)
virtual ACDB_PORT const ACHAR * | description (void) const
virtual ACDB_PORT bool | isEmpty (void) const
virtual ACDB_PORT const ACHAR * | name (void) const
virtual ACDB_PORT Acad::ErrorStatus | setDescription (const ACHAR *pszDescription)
virtual ACDB_PORT Acad::ErrorStatus | setName (const ACHAR *pszName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • DbTableContent.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTableContent Member List

This is the complete list of members for AcDbTableContent, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbTableContent) (defined in AcDbTableContent) | AcDbTableContent |
ACDB_DECLARE_MEMBERS(AcDbFormattedTableData) (defined in AcDbFormattedTableData) | AcDbFormattedTableData |
ACDB_DECLARE_MEMBERS(AcDbLinkedTableData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
ACDB_DECLARE_MEMBERS(AcDbLinkedData) (defined in AcDbLinkedData) | AcDbLinkedData |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbFormattedTableData(void) (defined in AcDbFormattedTableData) | AcDbFormattedTableData |
AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData |
AcDbLinkedTableData(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbTableContent(void) (defined in AcDbTableContent) | AcDbTableContent |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
alignment(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
appendColumn(int nNumCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
appendRow(int nNumRows) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
backgroundColor(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
canDelete(int nIndex, int nCount, bool bRow) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
canInsert(int nIndex, bool bRow) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
cellState(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
cellStyle(int nRow, int nCol) const (defined in AcDbTableContent) | AcDbTableContent | virtual
clear(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
columnWidth(int nCol) const (defined in AcDbTableContent) | AcDbTableContent | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contentColor(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
contentColor(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
contentLayout(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
contentType(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
contentType(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRange) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createContent(int nRow, int nCol, int nIndex) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
dataFormat(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
dataFormat(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteColumn(int nIndex, int nNumColsToDelete) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(int nRow, int nCol, int nContent) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(int nRow, int nCol) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(const AcCellRange &range) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteRow(int nIndex, int nNumRowsToDelete) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbTableContent) | AcDbTableContent | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbTableContent) | AcDbTableContent | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbTableContent) | AcDbTableContent | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbTableContent) | AcDbTableContent | virtual
enableMergeAll(int nRow, int nCol, bool bEnable) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
evaluateFormula(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
flowDirection(void) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBlockAttributeValue(int nRow, int nCol, const AcDbObjectId &idAttDef) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockAttributeValue(int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockTableRecordId(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockTableRecordId(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getColumnName(int nIndex) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getCustomData(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getCustomData(int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLinkRange(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataType(int nRow, int nCol, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataType(int nRow, int nCol, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getField(int nRow, int nCol, int nContent, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldId(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getFieldId(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getFormula(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getGridProperty(int nRow, int nCol, AcDb::GridLineType nGridLineType, AcGridProperty &gridProp) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getIterator(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
getIterator(const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
getMergeRange(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOverride(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getOverride(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getText(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getText(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getText(int nRow, int nCol, int nContent, AcValue::FormatOption nOption) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getToolTip(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getValue(int nRow, int nCol, AcValue &value) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getValue(int nRow, int nCol, int nContent, AcValue::FormatOption nOption, AcValue &value) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gridColor(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridDoubleLineSpacing(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridLineStyle(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridLinetype(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridLineWeight(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridVisibility(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasFormula(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
insertColumn(int nIndex, int nNumCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
insertColumnAndInherit(int nIndex, int nInheritFrom, int nNumCols) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
insertRow(int nIndex, int nNumRows) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
insertRowAndInherit(int nIndex, int nInheritFrom, int nNumRows) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isAutoScale(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isAutoScale(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isCancelling() const (defined in AcDbObject) | AcDbObject |
isContentEditable(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
isEmpty(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFormatEditable(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLinked(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
isMergeAllEnabled(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isMerged(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
margin(int nRow, int nCol, AcDb::CellMargin nMargin) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
merge(const AcCellRange &range) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveContent(int nRow, int nCol, int nFromIndex, int nToIndex) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
name(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
numColumns(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
numContents(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
numRows(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeAllOverrides(int nRow, int nCol) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
removeDataLink(int nRow, int nCol) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
removeDataLink(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
rotation(int nRow, int nCol, int nIndex) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
rowHeight(int nRow) const (defined in AcDbTableContent) | AcDbTableContent | virtual
scale(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
scale(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAlignment(int nRow, int nCol, AcDb::CellAlignment nAlignment) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setAutoScale(int nRow, int nCol, bool bAutoScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setAutoScale(int nRow, int nCol, int nContent, bool bAutoScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setBackgroundColor(int nRow, int nCol, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockAttributeValue(int nRow, int nCol, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockAttributeValue(int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockTableRecordId(int nRow, int nCol, const AcDbObjectId &idBTR) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockTableRecordId(int nRow, int nCol, int nContent, const AcDbObjectId &idBTR) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCellState(int nRow, int nCol, AcDb::CellState nCellState) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCellStyle(int nRow, int nCol, const ACHAR *pszCellStyle) (defined in AcDbTableContent) | AcDbTableContent | virtual
setColumnName(int nIndex, const ACHAR *pszName) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setColumnWidth(int nCol, double fWidth) (defined in AcDbTableContent) | AcDbTableContent | virtual
setContentColor(int nRow, int nCol, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setContentColor(int nRow, int nCol, int nContent, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setContentLayout(int nRow, int nCol, AcDb::CellContentLayout nLayout) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setCustomData(int nRow, int nCol, int nData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCustomData(int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataFormat(int nRow, int nCol, const ACHAR *pszFormat) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataFormat(int nRow, int nCol, int nContent, const ACHAR *pszFormat) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataLink(int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataLink(const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataType(int nRow, int nCol, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataType(int nRow, int nCol, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDescription(const ACHAR *pszDescription) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFieldId(int nRow, int nCol, const AcDbObjectId &idField, AcDb::CellOption nFlag) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setFieldId(int nRow, int nCol, int nIndex, const AcDbObjectId &idField, AcDb::CellOption nFlag) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setFieldId(int nRow, int nCol, const AcDbObjectId &idField) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setFieldId(int nRow, int nCol, int nContent, const AcDbObjectId &idField) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setFlowDirection(AcDb::FlowDirection nDir) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setFormula(int nRow, int nCol, int nContent, const ACHAR *pszFormula) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setGridColor(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridDoubleLineSpacing(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, double fSpacing) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridLineStyle(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::GridLineStyle nLineStyle) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridLinetype(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcDbObjectId &idLinetype) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridLineWeight(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::LineWeight nLineWeight) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridProperty(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridProperty(const AcCellRange &range, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridVisibility(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::Visibility nVisibility) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setMargin(int nRow, int nCol, AcDb::CellMargin nMargins, double fMargin) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setName(const ACHAR *pszName) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setOverride(int nRow, int nCol, int nContent, AcDb::CellProperty nOverride) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setOverride(int nRow, int nCol, AcDb::GridLineType nGridLineType, AcDb::GridProperty nOverride) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setRotation(int nRow, int nCol, double fRotation) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setRotation(int nRow, int nCol, int nContent, double fRotation) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setRowHeight(int nRow, double fWidth) (defined in AcDbTableContent) | AcDbTableContent | virtual
setScale(int nRow, int nCol, double fScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setScale(int nRow, int nCol, int nIndex, double fScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setSize(int nRows, int nCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setTableStyleId(const AcDbObjectId &idTableStyle) (defined in AcDbTableContent) | AcDbTableContent | virtual
setText(int nRow, int nCol, const ACHAR *pszText) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setText(int nRow, int nCol, int nContent, const ACHAR *pszText) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setTextHeight(int nRow, int nCol, double fTextHeight) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setTextHeight(int nRow, int nCol, int nContent, double fTextHeight) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setTextStyle(int nRow, int nCol, const AcDbObjectId &idTextStyle) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setTextStyle(int nRow, int nCol, int nContent, const AcDbObjectId &idTextStyle) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setToolTip(int nRow, int nCol, const ACHAR *pszToolTip) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, const AcValue &value) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, int nContent, const AcValue &value) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, int nContent, const AcValue &value, AcValue::ParseOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
tableStyleId(void) const (defined in AcDbTableContent) | AcDbTableContent | virtual
textHeight(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
textHeight(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
textStyle(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
textStyle(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unmerge(const AcCellRange &range) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
updateDataLink(int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
updateDataLink(AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbFormattedTableData(void) (defined in AcDbFormattedTableData) | AcDbFormattedTableData |
~AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
~AcDbLinkedTableData(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbTableContent(void) (defined in AcDbTableContent) | AcDbTableContent | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
AcDbTableIterator Class Reference
AcDb Classes

Public Member Functions

AcDbTableIterator (const AcDbTable *pTable)
AcDbTableIterator (const AcDbTable *pTable, const AcCellRange *pRange, AcDb::TableIteratorOption nOption)
AcDbTableIterator (const AcDbLinkedTableData *pTable)
AcDbTableIterator (const AcDbLinkedTableData *pTable, const AcCellRange *pRange, AcDb::TableIteratorOption nOption)
AcDbTableIterator (const AcCellRange &range)
AcDbTableIterator (const AcCellRange &range, AcDb::TableIteratorOption nOption)
bool | done (void)
const AcCell & | getCell (void) const
int | getColumn (void) const
int | getRow (void) const
bool | seek (const AcCell &cell)
void | start (void)
void | step (void)
~AcDbTableIterator ()

Protected Attributes

void * mpImpObj

Constructor & Destructor Documentation

AcDbTableIterator::AcDbTableIterator ( const AcDbTable * pTable )
Warning
Not implemented!
AcDbTableIterator::AcDbTableIterator | ( | const AcDbTable * | pTable,
 |  | const AcCellRange * | pRange,
 |  | AcDb::TableIteratorOption | nOption
 | ) |  |
Warning
Not implemented!
AcDbTableIterator::AcDbTableIterator ( const AcDbLinkedTableData * pTable )
Warning
Not implemented!
AcDbTableIterator::AcDbTableIterator | ( | const AcDbLinkedTableData * | pTable,
 |  | const AcCellRange * | pRange,
 |  | AcDb::TableIteratorOption | nOption
 | ) |  |
Warning
Not implemented!
AcDbTableIterator::AcDbTableIterator ( const AcCellRange & range )
Warning
Not implemented!
AcDbTableIterator::AcDbTableIterator | ( | const AcCellRange & | range,
 |  | AcDb::TableIteratorOption | nOption
 | ) |  |
Warning
Not implemented!
AcDbTableIterator::~AcDbTableIterator ( )
Warning
Not implemented!

Member Function Documentation

bool AcDbTableIterator::done ( void )
Warning
Not implemented!
const AcCell& AcDbTableIterator::getCell ( void ) const
Warning
Not implemented!
int AcDbTableIterator::getColumn ( void ) const
Warning
Not implemented!
int AcDbTableIterator::getRow ( void ) const
Warning
Not implemented!
bool AcDbTableIterator::seek ( const AcCell & cell )
Warning
Not implemented!
void AcDbTableIterator::start ( void )
Warning
Not implemented!
void AcDbTableIterator::step ( void )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • DbTableIterator.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTableIterator Member List

This is the complete list of members for AcDbTableIterator, including all inherited members.

AcDbTableIterator(const AcDbTable *pTable) | AcDbTableIterator
AcDbTableIterator(const AcDbTable *pTable, const AcCellRange *pRange, AcDb::TableIteratorOption nOption) | AcDbTableIterator
AcDbTableIterator(const AcDbLinkedTableData *pTable) | AcDbTableIterator
AcDbTableIterator(const AcDbLinkedTableData *pTable, const AcCellRange *pRange, AcDb::TableIteratorOption nOption) | AcDbTableIterator
AcDbTableIterator(const AcCellRange &range) | AcDbTableIterator
AcDbTableIterator(const AcCellRange &range, AcDb::TableIteratorOption nOption) | AcDbTableIterator
AcDbTableIterator(void) (defined in AcDbTableIterator) | AcDbTableIterator | protected
done(void) | AcDbTableIterator
getCell(void) const | AcDbTableIterator
getColumn(void) const | AcDbTableIterator
getRow(void) const | AcDbTableIterator
mpImpObj (defined in AcDbTableIterator) | AcDbTableIterator | protected
seek(const AcCell &cell) | AcDbTableIterator
start(void) | AcDbTableIterator
step(void) | AcDbTableIterator


ZRX API Reference: AcDbTableStyle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbTableStyle Class Reference
AcDb Classes
+ Inheritance diagram for AcDbTableStyle:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbTableStyle)
virtual AcDb::CellAlignment | alignment (AcDb::RowType rowType=AcDb::kDataRow) const
AcDb::CellAlignment | alignment (const ACHAR *pszCellStyle) const
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
virtual AcCmColor | backgroundColor (AcDb::RowType rowType=AcDb::kDataRow) const
AcCmColor | backgroundColor (const ACHAR *pszCellStyle) const
virtual Adesk::UInt32 | bitFlags () const
int | cellClass (const ACHAR *pszCellStyle) const
virtual AcCmColor | color (AcDb::RowType rowType=AcDb::kDataRow) const
AcCmColor | color (const ACHAR *pszCellStyle) const
Acad::ErrorStatus | copyCellStyle (const ACHAR *pszSrcCellStyle, const ACHAR *pszTargetCellStyle)
Acad::ErrorStatus | copyCellStyle (const AcDbTableStyle *pSrc, const ACHAR *pszSrcCellStyle, const ACHAR *pszTargetCellStyle)
const ACHAR * | createCellStyle (void)
Acad::ErrorStatus | createCellStyle (const ACHAR *pszCellStyle)
Acad::ErrorStatus | createCellStyle (const ACHAR *pszCellStyle, const ACHAR *pszFromCellStyle)
Acad::ErrorStatus | deleteCellStyle (const ACHAR *pszCellStyle)
virtual const ACHAR * | description (void) const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | enableMergeAll (bool bEnable, const ACHAR *pszCellStyle)
virtual AcDb::FlowDirection | flowDirection (void) const
virtual ADESK_DEPRECATED const
ACHAR * 		format (void) const
virtual ADESK_DEPRECATED const
ACHAR * 		format (AcDb::RowType rowType) const
const ACHAR * | format (const ACHAR *pszCellStyle) const
int | getCellStyles (AcStringArray &cellstyles) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getDataType (AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		getDataType (AcValue::DataType &nDataType, AcValue::UnitType &nUnitType, AcDb::RowType rowType) const
Acad::ErrorStatus | getDataType (AcValue::DataType &nDataType, AcValue::UnitType &nUnitType, const ACHAR *pszCellStyle) const
Acad::ErrorStatus | getGridProperty (AcGridProperty &gridProp, AcDb::GridLineType nGridLineTypes, const ACHAR *pszCellStyle) const
virtual Acad::ErrorStatus | getName (ACHAR *&pszName) const
AcDbObjectId | getTemplate (void) const
Acad::ErrorStatus | getTemplate (AcDbTableTemplate *&pTemplate, AcDb::OpenMode mode)
Acad::ErrorStatus | getUniqueCellStyleName (const ACHAR *pszBaseName, AcString &sUniqueName) const
virtual AcCmColor | gridColor (AcDb::GridLineType gridLineType, AcDb::RowType rowType=AcDb::kDataRow) const
AcCmColor | gridColor (AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const
double | gridDoubleLineSpacing (AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const
AcDb::GridLineStyle | gridLineStyle (AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const
AcDbObjectId | gridLinetype (AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const
virtual AcDb::LineWeight | gridLineWeight (AcDb::GridLineType gridLineType, AcDb::RowType rowType=AcDb::kDataRow) const
AcDb::LineWeight | gridLineWeight (AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const
virtual AcDb::Visibility | gridVisibility (AcDb::GridLineType gridLineType, AcDb::RowType rowType=AcDb::kDataRow) const
AcDb::Visibility | gridVisibility (AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const
virtual ADESK_DEPRECATED double | horzCellMargin (void) const
virtual ADESK_DEPRECATED bool | isBackgroundColorNone (AcDb::RowType rowType=AcDb::kDataRow) const
bool | isCellStyleInUse (const ACHAR *pszCellStyle) const
virtual ADESK_DEPRECATED bool | isHeaderSuppressed (void) const
bool | isMergeAllEnabled (const ACHAR *pszCellStyle) const
virtual ADESK_DEPRECATED bool | isTitleSuppressed (void) const
double | margin (AcDb::CellMargin nMargin, const ACHAR *pszCellStyle) const
int | numCellStyles (void) const
virtual Acad::ErrorStatus | postTableStyleToDb (AcDbDatabase *pDb, const ACHAR *styleName, AcDbObjectId &tableStyleId)
AcDbObjectId | removeTemplate (void)
Acad::ErrorStatus | renameCellStyle (const ACHAR *pszOldName, const ACHAR *pszNewName)
double | rotation (const ACHAR *pszCellStyle) const
virtual Acad::ErrorStatus | setAlignment (AcDb::CellAlignment alignment, int rowTypes=AcDb::kAllRows)
Acad::ErrorStatus | setAlignment (AcDb::CellAlignment alignment, const ACHAR *pszCellStyle)
virtual Acad::ErrorStatus | setBackgroundColor (const AcCmColor &color, int rowTypes=AcDb::kAllRows)
Acad::ErrorStatus | setBackgroundColor (const AcCmColor &color, const ACHAR *pszCellStyle)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setBackgroundColorNone (bool bValue, int rowTypes=AcDb::kAllRows)
virtual Acad::ErrorStatus | setBitFlags (Adesk::UInt32 flags)
Acad::ErrorStatus | setCellClass (int nClass, const ACHAR *pszCellStyle)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, int rowTypes=AcDb::kAllRows)
Acad::ErrorStatus | setColor (const AcCmColor &color, const ACHAR *pszCellStyle)
virtual Acad::ErrorStatus | setDataType (AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setDataType (AcValue::DataType nDataType, AcValue::UnitType nUnitType, int rowTypes)
Acad::ErrorStatus | setDataType (AcValue::DataType nDataType, AcValue::UnitType nUnitType, const ACHAR *pszCellStyle)
virtual Acad::ErrorStatus | setDescription (const ACHAR *pszDescription)
virtual Acad::ErrorStatus | setFlowDirection (AcDb::FlowDirection flow)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setFormat (const ACHAR *pszFormat)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setFormat (const ACHAR *pszFormat, int rowTypes)
Acad::ErrorStatus | setFormat (const ACHAR *pszFormat, const ACHAR *pszCellStyle)
virtual Acad::ErrorStatus | setGridColor (const AcCmColor color, int gridLineTypes=AcDb::kAllGridLines, int rowTypes=AcDb::kAllRows)
Acad::ErrorStatus | setGridColor (const AcCmColor color, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle)
Acad::ErrorStatus | setGridDoubleLineSpacing (double fSpacing, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle)
Acad::ErrorStatus | setGridLineStyle (AcDb::GridLineStyle nLineStyle, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle)
Acad::ErrorStatus | setGridLinetype (const AcDbObjectId &id, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle)
virtual Acad::ErrorStatus | setGridLineWeight (AcDb::LineWeight lineWeight, int gridLineTypes=AcDb::kAllGridLines, int rowTypes=AcDb::kAllRows)
Acad::ErrorStatus | setGridLineWeight (AcDb::LineWeight lineWeight, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle)
Acad::ErrorStatus | setGridProperty (const AcGridProperty &gridProp, AcDb::GridLineType nGridLineTypes, const ACHAR *pszCellStyle)
virtual Acad::ErrorStatus | setGridVisibility (AcDb::Visibility visible, int gridLineTypes=AcDb::kAllGridLines, int rowTypes=AcDb::kAllRows)
Acad::ErrorStatus | setGridVisibility (AcDb::Visibility visible, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setHorzCellMargin (double dCellMargin)
Acad::ErrorStatus | setMargin (AcDb::CellMargin nMargins, double fMargin, const ACHAR *pszCellStyle)
virtual Acad::ErrorStatus | setName (const ACHAR *pszName)
Acad::ErrorStatus | setRotation (double fRotation, const ACHAR *pszCellStyle)
Acad::ErrorStatus | setTemplate (const AcDbObjectId &templateId, AcDb::MergeCellStyleOption nOption)
Acad::ErrorStatus | setTemplate (AcDbTableTemplate *pTemplate, AcDb::MergeCellStyleOption nOption, AcDbObjectId &templateId)
virtual Acad::ErrorStatus | setTextHeight (double dHeight, int rowTypes=AcDb::kAllRows)
Acad::ErrorStatus | setTextHeight (double dHeight, const ACHAR *pszCellStyle)
virtual Acad::ErrorStatus | setTextStyle (const AcDbObjectId id, int rowTypes=AcDb::kAllRows)
Acad::ErrorStatus | setTextStyle (const AcDbObjectId &id, const ACHAR *pszCellStyle)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		setVertCellMargin (double dCellMargin)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		suppressHeaderRow (bool bValue)
virtual ADESK_DEPRECATED
Acad::ErrorStatus 		suppressTitleRow (bool bValue)
virtual double | textHeight (AcDb::RowType rowType=AcDb::kDataRow) const
double | textHeight (const ACHAR *pszCellStyle) const
virtual AcDbObjectId | textStyle (AcDb::RowType rowType=AcDb::kDataRow) const
AcDbObjectId | textStyle (const ACHAR *pszCellStyle) const
virtual ADESK_DEPRECATED double | vertCellMargin (void) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

int AcDbTableStyle::getCellStyles ( AcStringArray & cellstyles ) const
Warning
Not implemented!
AcDbObjectId AcDbTableStyle::getTemplate ( void ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbTableStyle::getTemplate | ( | AcDbTableTemplate *& | pTemplate,
 |  | AcDb::OpenMode | mode
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbTablestyle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTableStyle Member List

This is the complete list of members for AcDbTableStyle, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbTableStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbTableStyle() (defined in AcDbTableStyle) | AcDbTableStyle |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
alignment(AcDb::RowType rowType=AcDb::kDataRow) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
alignment(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
backgroundColor(AcDb::RowType rowType=AcDb::kDataRow) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
backgroundColor(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
bitFlags() const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
cellClass(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
color(AcDb::RowType rowType=AcDb::kDataRow) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
color(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyCellStyle(const ACHAR *pszSrcCellStyle, const ACHAR *pszTargetCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
copyCellStyle(const AcDbTableStyle *pSrc, const ACHAR *pszSrcCellStyle, const ACHAR *pszTargetCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createCellStyle(void) (defined in AcDbTableStyle) | AcDbTableStyle |
createCellStyle(const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
createCellStyle(const ACHAR *pszCellStyle, const ACHAR *pszFromCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteCellStyle(const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
enableMergeAll(bool bEnable, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
flowDirection(void) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
format(void) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
format(AcDb::RowType rowType) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
format(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getCellStyles(AcStringArray &cellstyles) const | AcDbTableStyle |
getClassID(CLSID *pClsid) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
getDataType(AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
getDataType(AcValue::DataType &nDataType, AcValue::UnitType &nUnitType, AcDb::RowType rowType) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
getDataType(AcValue::DataType &nDataType, AcValue::UnitType &nUnitType, const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGridProperty(AcGridProperty &gridProp, AcDb::GridLineType nGridLineTypes, const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
getName(ACHAR *&pszName) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getTemplate(void) const | AcDbTableStyle |
getTemplate(AcDbTableTemplate *&pTemplate, AcDb::OpenMode mode) | AcDbTableStyle |
getUniqueCellStyleName(const ACHAR *pszBaseName, AcString &sUniqueName) const (defined in AcDbTableStyle) | AcDbTableStyle |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gridColor(AcDb::GridLineType gridLineType, AcDb::RowType rowType=AcDb::kDataRow) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
gridColor(AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
gridDoubleLineSpacing(AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
gridLineStyle(AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
gridLinetype(AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
gridLineWeight(AcDb::GridLineType gridLineType, AcDb::RowType rowType=AcDb::kDataRow) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
gridLineWeight(AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
gridVisibility(AcDb::GridLineType gridLineType, AcDb::RowType rowType=AcDb::kDataRow) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
gridVisibility(AcDb::GridLineType gridLineType, const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
horzCellMargin(void) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isBackgroundColorNone(AcDb::RowType rowType=AcDb::kDataRow) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
isCancelling() const (defined in AcDbObject) | AcDbObject |
isCellStyleInUse(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isHeaderSuppressed(void) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isMergeAllEnabled(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTitleSuppressed(void) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
margin(AcDb::CellMargin nMargin, const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
numCellStyles(void) const (defined in AcDbTableStyle) | AcDbTableStyle |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
postTableStyleToDb(AcDbDatabase *pDb, const ACHAR *styleName, AcDbObjectId &tableStyleId) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeTemplate(void) (defined in AcDbTableStyle) | AcDbTableStyle |
renameCellStyle(const ACHAR *pszOldName, const ACHAR *pszNewName) (defined in AcDbTableStyle) | AcDbTableStyle |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAlignment(AcDb::CellAlignment alignment, int rowTypes=AcDb::kAllRows) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setAlignment(AcDb::CellAlignment alignment, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBackgroundColor(const AcCmColor &color, int rowTypes=AcDb::kAllRows) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setBackgroundColor(const AcCmColor &color, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setBackgroundColorNone(bool bValue, int rowTypes=AcDb::kAllRows) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBitFlags(Adesk::UInt32 flags) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setCellClass(int nClass, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setColor(const AcCmColor &color, int rowTypes=AcDb::kAllRows) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setColor(const AcCmColor &color, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setDataType(AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setDataType(AcValue::DataType nDataType, AcValue::UnitType nUnitType, int rowTypes) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setDataType(AcValue::DataType nDataType, AcValue::UnitType nUnitType, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setDescription(const ACHAR *pszDescription) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFlowDirection(AcDb::FlowDirection flow) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setFormat(const ACHAR *pszFormat) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setFormat(const ACHAR *pszFormat, int rowTypes) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setFormat(const ACHAR *pszFormat, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setGridColor(const AcCmColor color, int gridLineTypes=AcDb::kAllGridLines, int rowTypes=AcDb::kAllRows) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setGridColor(const AcCmColor color, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setGridDoubleLineSpacing(double fSpacing, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setGridLineStyle(AcDb::GridLineStyle nLineStyle, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setGridLinetype(const AcDbObjectId &id, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setGridLineWeight(AcDb::LineWeight lineWeight, int gridLineTypes=AcDb::kAllGridLines, int rowTypes=AcDb::kAllRows) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setGridLineWeight(AcDb::LineWeight lineWeight, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setGridProperty(const AcGridProperty &gridProp, AcDb::GridLineType nGridLineTypes, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setGridVisibility(AcDb::Visibility visible, int gridLineTypes=AcDb::kAllGridLines, int rowTypes=AcDb::kAllRows) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setGridVisibility(AcDb::Visibility visible, AcDb::GridLineType gridLineTypes, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHorzCellMargin(double dCellMargin) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setMargin(AcDb::CellMargin nMargins, double fMargin, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setName(const ACHAR *pszName) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setRotation(double fRotation, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setTemplate(const AcDbObjectId &templateId, AcDb::MergeCellStyleOption nOption) (defined in AcDbTableStyle) | AcDbTableStyle |
setTemplate(AcDbTableTemplate *pTemplate, AcDb::MergeCellStyleOption nOption, AcDbObjectId &templateId) (defined in AcDbTableStyle) | AcDbTableStyle |
setTextHeight(double dHeight, int rowTypes=AcDb::kAllRows) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setTextHeight(double dHeight, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setTextStyle(const AcDbObjectId id, int rowTypes=AcDb::kAllRows) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setTextStyle(const AcDbObjectId &id, const ACHAR *pszCellStyle) (defined in AcDbTableStyle) | AcDbTableStyle |
setVertCellMargin(double dCellMargin) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
suppressHeaderRow(bool bValue) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
suppressTitleRow(bool bValue) (defined in AcDbTableStyle) | AcDbTableStyle | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textHeight(AcDb::RowType rowType=AcDb::kDataRow) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
textHeight(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
textStyle(AcDb::RowType rowType=AcDb::kDataRow) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
textStyle(const ACHAR *pszCellStyle) const (defined in AcDbTableStyle) | AcDbTableStyle |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
vertCellMargin(void) const (defined in AcDbTableStyle) | AcDbTableStyle | virtual
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbTableStyle() (defined in AcDbTableStyle) | AcDbTableStyle | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbTableTemplate Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbTableTemplate Class Reference
AcDb Classes
+ Inheritance diagram for AcDbTableTemplate:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbTableTemplate)
AcDbTableTemplate (const AcDbTable *pTable, AcDb::TableCopyOption nCopyOption)
virtual Acad::ErrorStatus | capture (const AcDbTable *pTable, AcDb::TableCopyOption nCopyOption)
virtual Acad::ErrorStatus | createTable (AcDbTable *&pTable, AcDb::TableCopyOption nCopyOption)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
- Public Member Functions inherited from AcDbTableContent
ACDB_DECLARE_MEMBERS (AcDbTableContent)
virtual ACDB_PORT const ACHAR * | cellStyle (int nRow, int nCol) const
virtual ACDB_PORT double | columnWidth (int nCol) const
virtual ACDB_PORT double | rowHeight (int nRow) const
virtual ACDB_PORT Acad::ErrorStatus | setCellStyle (int nRow, int nCol, const ACHAR *pszCellStyle)
virtual ACDB_PORT Acad::ErrorStatus | setColumnWidth (int nCol, double fWidth)
virtual ACDB_PORT Acad::ErrorStatus | setRowHeight (int nRow, double fWidth)
virtual ACDB_PORT Acad::ErrorStatus | setTableStyleId (const AcDbObjectId &idTableStyle)
virtual ACDB_PORT AcDbObjectId | tableStyleId (void) const
- Public Member Functions inherited from AcDbFormattedTableData
ACDB_DECLARE_MEMBERS (AcDbFormattedTableData)
virtual ACDB_PORT
AcDb::CellAlignment 		alignment (int nRow, int nCol) const
virtual ACDB_PORT AcCmColor | backgroundColor (int nRow, int nCol) const
virtual ACDB_PORT AcCmColor | contentColor (int nRow, int nCol) const
virtual ACDB_PORT AcCmColor | contentColor (int nRow, int nCol, int nContent) const
virtual ACDB_PORT
AcDb::CellContentLayout 		contentLayout (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | enableMergeAll (int nRow, int nCol, bool bEnable)
virtual ACDB_PORT
AcDb::FlowDirection 		flowDirection (void) const
virtual ACDB_PORT Acad::ErrorStatus | getGridProperty (int nRow, int nCol, AcDb::GridLineType nGridLineType, AcGridProperty &gridProp) const
virtual ACDB_PORT AcCellRange | getMergeRange (int nRow, int nCol) const
virtual ACDB_PORT
AcDb::CellProperty 		getOverride (int nRow, int nCol, int nContent) const
virtual ACDB_PORT
AcDb::GridProperty 		getOverride (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcCmColor | gridColor (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT double | gridDoubleLineSpacing (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT
AcDb::GridLineStyle 		gridLineStyle (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcDbObjectId | gridLinetype (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcDb::LineWeight | gridLineWeight (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT AcDb::Visibility | gridVisibility (int nRow, int nCol, AcDb::GridLineType nGridLineType) const
virtual ACDB_PORT int | insertColumnAndInherit (int nIndex, int nInheritFrom, int nNumCols)
virtual ACDB_PORT int | insertRowAndInherit (int nIndex, int nInheritFrom, int nNumRows)
virtual ACDB_PORT bool | isAutoScale (int nRow, int nCol) const
virtual ACDB_PORT bool | isAutoScale (int nRow, int nCol, int nContent) const
virtual ACDB_PORT bool | isFormatEditable (int nRow, int nCol) const
virtual ACDB_PORT bool | isMergeAllEnabled (int nRow, int nCol) const
virtual ACDB_PORT bool | isMerged (int nRow, int nCol) const
virtual ACDB_PORT double | margin (int nRow, int nCol, AcDb::CellMargin nMargin) const
virtual ACDB_PORT Acad::ErrorStatus | merge (const AcCellRange &range)
virtual ACDB_PORT Acad::ErrorStatus | removeAllOverrides (int nRow, int nCol)
virtual ACDB_PORT double | rotation (int nRow, int nCol) const
virtual ACDB_PORT double | rotation (int nRow, int nCol, int nIndex) const
virtual ACDB_PORT double | scale (int nRow, int nCol) const
virtual ACDB_PORT double | scale (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | setAlignment (int nRow, int nCol, AcDb::CellAlignment nAlignment)
virtual ACDB_PORT Acad::ErrorStatus | setAutoScale (int nRow, int nCol, bool bAutoScale)
virtual ACDB_PORT Acad::ErrorStatus | setAutoScale (int nRow, int nCol, int nContent, bool bAutoScale)
virtual ACDB_PORT Acad::ErrorStatus | setBackgroundColor (int nRow, int nCol, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setContentColor (int nRow, int nCol, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setContentColor (int nRow, int nCol, int nContent, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setContentLayout (int nRow, int nCol, AcDb::CellContentLayout nLayout)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, const AcDbObjectId &idField, AcDb::CellOption nFlag)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, int nIndex, const AcDbObjectId &idField, AcDb::CellOption nFlag)
virtual ACDB_PORT Acad::ErrorStatus | setFlowDirection (AcDb::FlowDirection nDir)
virtual ACDB_PORT Acad::ErrorStatus | setGridColor (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcCmColor &color)
virtual ACDB_PORT Acad::ErrorStatus | setGridDoubleLineSpacing (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, double fSpacing)
virtual ACDB_PORT Acad::ErrorStatus | setGridLineStyle (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::GridLineStyle nLineStyle)
virtual ACDB_PORT Acad::ErrorStatus | setGridLinetype (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcDbObjectId &idLinetype)
virtual ACDB_PORT Acad::ErrorStatus | setGridLineWeight (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::LineWeight nLineWeight)
virtual ACDB_PORT Acad::ErrorStatus | setGridProperty (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp)
virtual ACDB_PORT Acad::ErrorStatus | setGridProperty (const AcCellRange &range, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp)
virtual ACDB_PORT Acad::ErrorStatus | setGridVisibility (int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::Visibility nVisibility)
virtual ACDB_PORT Acad::ErrorStatus | setMargin (int nRow, int nCol, AcDb::CellMargin nMargins, double fMargin)
virtual ACDB_PORT Acad::ErrorStatus | setOverride (int nRow, int nCol, int nContent, AcDb::CellProperty nOverride)
virtual ACDB_PORT Acad::ErrorStatus | setOverride (int nRow, int nCol, AcDb::GridLineType nGridLineType, AcDb::GridProperty nOverride)
virtual ACDB_PORT Acad::ErrorStatus | setRotation (int nRow, int nCol, double fRotation)
virtual ACDB_PORT Acad::ErrorStatus | setRotation (int nRow, int nCol, int nContent, double fRotation)
virtual ACDB_PORT Acad::ErrorStatus | setScale (int nRow, int nCol, double fScale)
virtual ACDB_PORT Acad::ErrorStatus | setScale (int nRow, int nCol, int nIndex, double fScale)
virtual ACDB_PORT Acad::ErrorStatus | setTextHeight (int nRow, int nCol, double fTextHeight)
virtual ACDB_PORT Acad::ErrorStatus | setTextHeight (int nRow, int nCol, int nContent, double fTextHeight)
virtual ACDB_PORT Acad::ErrorStatus | setTextStyle (int nRow, int nCol, const AcDbObjectId &idTextStyle)
virtual ACDB_PORT Acad::ErrorStatus | setTextStyle (int nRow, int nCol, int nContent, const AcDbObjectId &idTextStyle)
virtual ACDB_PORT double | textHeight (int nRow, int nCol) const
virtual ACDB_PORT double | textHeight (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcDbObjectId | textStyle (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | textStyle (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | unmerge (const AcCellRange &range)
- Public Member Functions inherited from AcDbLinkedTableData
ACDB_DECLARE_MEMBERS (AcDbLinkedTableData)
virtual ACDB_PORT int | appendColumn (int nNumCols)
virtual ACDB_PORT int | appendRow (int nNumRows)
virtual ACDB_PORT bool | canDelete (int nIndex, int nCount, bool bRow) const
virtual ACDB_PORT bool | canInsert (int nIndex, bool bRow) const
virtual ACDB_PORT AcDb::CellState | cellState (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | clear (void)
virtual ACDB_PORT
AcDb::CellContentType 		contentType (int nRow, int nCol) const
virtual ACDB_PORT
AcDb::CellContentType 		contentType (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | copyFrom (const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRange)
virtual ACDB_PORT int | createContent (int nRow, int nCol, int nIndex)
virtual ACDB_PORT AcString | dataFormat (int nRow, int nCol) const
virtual ACDB_PORT AcString | dataFormat (int nRow, int nCol, int nContent) const
virtual ACDB_PORT Acad::ErrorStatus | deleteColumn (int nIndex, int nNumColsToDelete)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (int nRow, int nCol, int nContent)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (int nRow, int nCol)
virtual ACDB_PORT Acad::ErrorStatus | deleteContent (const AcCellRange &range)
virtual ACDB_PORT Acad::ErrorStatus | deleteRow (int nIndex, int nNumRowsToDelete)
virtual ACDB_PORT Acad::ErrorStatus | evaluateFormula (void)
virtual ACDB_PORT AcString | getBlockAttributeValue (int nRow, int nCol, const AcDbObjectId &idAttDef) const
virtual ACDB_PORT AcString | getBlockAttributeValue (int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef) const
virtual ACDB_PORT AcDbObjectId | getBlockTableRecordId (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | getBlockTableRecordId (int nRow, int nCol, int nContent) const
virtual ACDB_PORT const ACHAR * | getColumnName (int nIndex) const
virtual ACDB_PORT int | getCustomData (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getCustomData (int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const
virtual ACDB_PORT AcDbObjectId | getDataLink (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getDataLink (int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const
virtual ACDB_PORT int | getDataLink (const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const
virtual ACDB_PORT AcCellRange | getDataLinkRange (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getDataType (int nRow, int nCol, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
virtual ACDB_PORT Acad::ErrorStatus | getDataType (int nRow, int nCol, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const
virtual ACDB_PORT Acad::ErrorStatus | getField (int nRow, int nCol, int nContent, AcDbField *&pField, AcDb::OpenMode mode) const
virtual ACDB_PORT AcDbObjectId | getFieldId (int nRow, int nCol) const
virtual ACDB_PORT AcDbObjectId | getFieldId (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcString | getFormula (int nRow, int nCol, int nContent) const
ACDB_PORT AcDbTableIterator * | getIterator (void) const
ACDB_PORT AcDbTableIterator * | getIterator (const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol, int nContent) const
virtual ACDB_PORT AcString | getText (int nRow, int nCol, int nContent, AcValue::FormatOption nOption) const
virtual ACDB_PORT AcString | getToolTip (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | getValue (int nRow, int nCol, AcValue &value) const
virtual ACDB_PORT Acad::ErrorStatus | getValue (int nRow, int nCol, int nContent, AcValue::FormatOption nOption, AcValue &value) const
virtual ACDB_PORT bool | hasFormula (int nRow, int nCol, int nContent) const
virtual ACDB_PORT int | insertColumn (int nIndex, int nNumCols)
virtual ACDB_PORT int | insertRow (int nIndex, int nNumRows)
virtual ACDB_PORT bool | isContentEditable (int nRow, int nCol) const
virtual ACDB_PORT bool | isLinked (int nRow, int nCol) const
virtual ACDB_PORT Acad::ErrorStatus | moveContent (int nRow, int nCol, int nFromIndex, int nToIndex)
virtual ACDB_PORT int | numColumns (void) const
virtual ACDB_PORT int | numContents (int nRow, int nCol) const
virtual ACDB_PORT int | numRows (void) const
virtual ACDB_PORT Acad::ErrorStatus | removeDataLink (int nRow, int nCol)
virtual ACDB_PORT Acad::ErrorStatus | removeDataLink (void)
virtual ACDB_PORT Acad::ErrorStatus | setBlockAttributeValue (int nRow, int nCol, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue)
virtual ACDB_PORT Acad::ErrorStatus | setBlockAttributeValue (int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue)
virtual ACDB_PORT Acad::ErrorStatus | setBlockTableRecordId (int nRow, int nCol, const AcDbObjectId &idBTR)
virtual ACDB_PORT Acad::ErrorStatus | setBlockTableRecordId (int nRow, int nCol, int nContent, const AcDbObjectId &idBTR)
virtual ACDB_PORT Acad::ErrorStatus | setCellState (int nRow, int nCol, AcDb::CellState nCellState)
virtual ACDB_PORT Acad::ErrorStatus | setColumnName (int nIndex, const ACHAR *pszName)
virtual ACDB_PORT Acad::ErrorStatus | setCustomData (int nRow, int nCol, int nData)
virtual ACDB_PORT Acad::ErrorStatus | setCustomData (int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData)
virtual ACDB_PORT Acad::ErrorStatus | setDataFormat (int nRow, int nCol, const ACHAR *pszFormat)
virtual ACDB_PORT Acad::ErrorStatus | setDataFormat (int nRow, int nCol, int nContent, const ACHAR *pszFormat)
virtual ACDB_PORT Acad::ErrorStatus | setDataLink (int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate)
virtual ACDB_PORT Acad::ErrorStatus | setDataLink (const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate)
virtual ACDB_PORT Acad::ErrorStatus | setDataType (int nRow, int nCol, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ACDB_PORT Acad::ErrorStatus | setDataType (int nRow, int nCol, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, const AcDbObjectId &idField)
virtual ACDB_PORT Acad::ErrorStatus | setFieldId (int nRow, int nCol, int nContent, const AcDbObjectId &idField)
virtual ACDB_PORT Acad::ErrorStatus | setFormula (int nRow, int nCol, int nContent, const ACHAR *pszFormula)
virtual ACDB_PORT Acad::ErrorStatus | setSize (int nRows, int nCols)
virtual ACDB_PORT Acad::ErrorStatus | setText (int nRow, int nCol, const ACHAR *pszText)
virtual ACDB_PORT Acad::ErrorStatus | setText (int nRow, int nCol, int nContent, const ACHAR *pszText)
virtual ACDB_PORT Acad::ErrorStatus | setToolTip (int nRow, int nCol, const ACHAR *pszToolTip)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, const AcValue &value)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, int nContent, const AcValue &value)
virtual ACDB_PORT Acad::ErrorStatus | setValue (int nRow, int nCol, int nContent, const AcValue &value, AcValue::ParseOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | updateDataLink (int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
virtual ACDB_PORT Acad::ErrorStatus | updateDataLink (AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption)
- Public Member Functions inherited from AcDbLinkedData
ACDB_DECLARE_MEMBERS (AcDbLinkedData)
virtual ACDB_PORT const ACHAR * | description (void) const
virtual ACDB_PORT bool | isEmpty (void) const
virtual ACDB_PORT const ACHAR * | name (void) const
virtual ACDB_PORT Acad::ErrorStatus | setDescription (const ACHAR *pszDescription)
virtual ACDB_PORT Acad::ErrorStatus | setName (const ACHAR *pszName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

virtual Acad::ErrorStatus AcDbTableTemplate::capture | ( | const AcDbTable * | pTable,
 |  | AcDb::TableCopyOption | nCopyOption
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbTableTemplate::createTable | ( | AcDbTable *& | pTable,
 |  | AcDb::TableCopyOption | nCopyOption
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcDbTableTemplate::dwgInFields ( AcDbDwgFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbTableContent.

virtual Acad::ErrorStatus AcDbTableTemplate::dwgOutFields ( AcDbDwgFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbTableContent.

virtual Acad::ErrorStatus AcDbTableTemplate::dxfInFields ( AcDbDxfFiler * pFiler )
virtual
Warning
Not implemented!

Reimplemented from AcDbTableContent.

virtual Acad::ErrorStatus AcDbTableTemplate::dxfOutFields ( AcDbDxfFiler * pFiler ) const
virtual
Warning
Not implemented!

Reimplemented from AcDbTableContent.

The documentation for this class was generated from the following file:
  • DbTableTemplate.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTableTemplate Member List

This is the complete list of members for AcDbTableTemplate, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbTableTemplate) (defined in AcDbTableTemplate) | AcDbTableTemplate |
ACDB_DECLARE_MEMBERS(AcDbTableContent) (defined in AcDbTableContent) | AcDbTableContent |
ACDB_DECLARE_MEMBERS(AcDbFormattedTableData) (defined in AcDbFormattedTableData) | AcDbFormattedTableData |
ACDB_DECLARE_MEMBERS(AcDbLinkedTableData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
ACDB_DECLARE_MEMBERS(AcDbLinkedData) (defined in AcDbLinkedData) | AcDbLinkedData |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbFormattedTableData(void) (defined in AcDbFormattedTableData) | AcDbFormattedTableData |
AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData |
AcDbLinkedTableData(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbTableContent(void) (defined in AcDbTableContent) | AcDbTableContent |
AcDbTableTemplate(void) (defined in AcDbTableTemplate) | AcDbTableTemplate |
AcDbTableTemplate(const AcDbTable *pTable, AcDb::TableCopyOption nCopyOption) (defined in AcDbTableTemplate) | AcDbTableTemplate |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
alignment(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
appendColumn(int nNumCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
appendRow(int nNumRows) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
backgroundColor(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
canDelete(int nIndex, int nCount, bool bRow) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
canInsert(int nIndex, bool bRow) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
capture(const AcDbTable *pTable, AcDb::TableCopyOption nCopyOption) | AcDbTableTemplate | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
cellState(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
cellStyle(int nRow, int nCol) const (defined in AcDbTableContent) | AcDbTableContent | virtual
clear(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
columnWidth(int nCol) const (defined in AcDbTableContent) | AcDbTableContent | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contentColor(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
contentColor(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
contentLayout(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
contentType(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
contentType(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copyFrom(const AcDbLinkedTableData *pSrc, AcDb::TableCopyOption nOption, const AcCellRange &srcRange, const AcCellRange &targetRange, AcCellRange *pNewTargetRange) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createContent(int nRow, int nCol, int nIndex) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createTable(AcDbTable *&pTable, AcDb::TableCopyOption nCopyOption) | AcDbTableTemplate | virtual
database() const (defined in AcDbObject) | AcDbObject |
dataFormat(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
dataFormat(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteColumn(int nIndex, int nNumColsToDelete) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(int nRow, int nCol, int nContent) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(int nRow, int nCol) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteContent(const AcCellRange &range) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
deleteRow(int nIndex, int nNumRowsToDelete) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) | AcDbTableTemplate | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const | AcDbTableTemplate | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) | AcDbTableTemplate | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const | AcDbTableTemplate | virtual
enableMergeAll(int nRow, int nCol, bool bEnable) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
evaluateFormula(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
flowDirection(void) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getBlockAttributeValue(int nRow, int nCol, const AcDbObjectId &idAttDef) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockAttributeValue(int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockTableRecordId(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getBlockTableRecordId(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getColumnName(int nIndex) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getCustomData(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getCustomData(int nRow, int nCol, const ACHAR *pszKey, AcValue *pData) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(int nRow, int nCol, AcDbDataLink *&pDataLink, AcDb::OpenMode mode) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLink(const AcCellRange *pRange, AcDbObjectIdArray &dataLinkIds) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataLinkRange(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataType(int nRow, int nCol, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getDataType(int nRow, int nCol, int nContent, AcValue::DataType &nDataType, AcValue::UnitType &nUnitType) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getField(int nRow, int nCol, int nContent, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldId(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getFieldId(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getFormula(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getGridProperty(int nRow, int nCol, AcDb::GridLineType nGridLineType, AcGridProperty &gridProp) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getIterator(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
getIterator(const AcCellRange *pRange, AcDb::TableIteratorOption nOption) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData |
getMergeRange(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOverride(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getOverride(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
getText(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getText(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getText(int nRow, int nCol, int nContent, AcValue::FormatOption nOption) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getToolTip(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getValue(int nRow, int nCol, AcValue &value) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
getValue(int nRow, int nCol, int nContent, AcValue::FormatOption nOption, AcValue &value) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gridColor(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridDoubleLineSpacing(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridLineStyle(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridLinetype(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridLineWeight(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gridVisibility(int nRow, int nCol, AcDb::GridLineType nGridLineType) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasFormula(int nRow, int nCol, int nContent) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
insertColumn(int nIndex, int nNumCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
insertColumnAndInherit(int nIndex, int nInheritFrom, int nNumCols) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
insertRow(int nIndex, int nNumRows) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
insertRowAndInherit(int nIndex, int nInheritFrom, int nNumRows) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isAutoScale(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isAutoScale(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isCancelling() const (defined in AcDbObject) | AcDbObject |
isContentEditable(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
isEmpty(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFormatEditable(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLinked(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
isMergeAllEnabled(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isMerged(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
margin(int nRow, int nCol, AcDb::CellMargin nMargin) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
merge(const AcCellRange &range) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveContent(int nRow, int nCol, int nFromIndex, int nToIndex) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
name(void) const (defined in AcDbLinkedData) | AcDbLinkedData | virtual
numColumns(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
numContents(int nRow, int nCol) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
numRows(void) const (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeAllOverrides(int nRow, int nCol) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
removeDataLink(int nRow, int nCol) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
removeDataLink(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
rotation(int nRow, int nCol, int nIndex) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
rowHeight(int nRow) const (defined in AcDbTableContent) | AcDbTableContent | virtual
scale(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
scale(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAlignment(int nRow, int nCol, AcDb::CellAlignment nAlignment) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setAutoScale(int nRow, int nCol, bool bAutoScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setAutoScale(int nRow, int nCol, int nContent, bool bAutoScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setBackgroundColor(int nRow, int nCol, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockAttributeValue(int nRow, int nCol, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockAttributeValue(int nRow, int nCol, int nContent, const AcDbObjectId &idAttDef, const ACHAR *pszAttValue) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockTableRecordId(int nRow, int nCol, const AcDbObjectId &idBTR) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setBlockTableRecordId(int nRow, int nCol, int nContent, const AcDbObjectId &idBTR) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCellState(int nRow, int nCol, AcDb::CellState nCellState) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCellStyle(int nRow, int nCol, const ACHAR *pszCellStyle) (defined in AcDbTableContent) | AcDbTableContent | virtual
setColumnName(int nIndex, const ACHAR *pszName) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setColumnWidth(int nCol, double fWidth) (defined in AcDbTableContent) | AcDbTableContent | virtual
setContentColor(int nRow, int nCol, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setContentColor(int nRow, int nCol, int nContent, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setContentLayout(int nRow, int nCol, AcDb::CellContentLayout nLayout) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setCustomData(int nRow, int nCol, int nData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setCustomData(int nRow, int nCol, const ACHAR *pszKey, const AcValue *pData) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataFormat(int nRow, int nCol, const ACHAR *pszFormat) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataFormat(int nRow, int nCol, int nContent, const ACHAR *pszFormat) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataLink(int nRow, int nCol, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataLink(const AcCellRange &range, const AcDbObjectId &idDataLink, bool bUpdate) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataType(int nRow, int nCol, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDataType(int nRow, int nCol, int nContent, AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setDescription(const ACHAR *pszDescription) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFieldId(int nRow, int nCol, const AcDbObjectId &idField, AcDb::CellOption nFlag) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setFieldId(int nRow, int nCol, int nIndex, const AcDbObjectId &idField, AcDb::CellOption nFlag) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setFieldId(int nRow, int nCol, const AcDbObjectId &idField) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setFieldId(int nRow, int nCol, int nContent, const AcDbObjectId &idField) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setFlowDirection(AcDb::FlowDirection nDir) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setFormula(int nRow, int nCol, int nContent, const ACHAR *pszFormula) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setGridColor(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcCmColor &color) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridDoubleLineSpacing(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, double fSpacing) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridLineStyle(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::GridLineStyle nLineStyle) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridLinetype(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcDbObjectId &idLinetype) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridLineWeight(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::LineWeight nLineWeight) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridProperty(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridProperty(const AcCellRange &range, AcDb::GridLineType nGridLineTypes, const AcGridProperty &gridProp) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGridVisibility(int nRow, int nCol, AcDb::GridLineType nGridLineTypes, AcDb::Visibility nVisibility) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setMargin(int nRow, int nCol, AcDb::CellMargin nMargins, double fMargin) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setName(const ACHAR *pszName) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
setOverride(int nRow, int nCol, int nContent, AcDb::CellProperty nOverride) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setOverride(int nRow, int nCol, AcDb::GridLineType nGridLineType, AcDb::GridProperty nOverride) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setRotation(int nRow, int nCol, double fRotation) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setRotation(int nRow, int nCol, int nContent, double fRotation) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setRowHeight(int nRow, double fWidth) (defined in AcDbTableContent) | AcDbTableContent | virtual
setScale(int nRow, int nCol, double fScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setScale(int nRow, int nCol, int nIndex, double fScale) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setSize(int nRows, int nCols) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setTableStyleId(const AcDbObjectId &idTableStyle) (defined in AcDbTableContent) | AcDbTableContent | virtual
setText(int nRow, int nCol, const ACHAR *pszText) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setText(int nRow, int nCol, int nContent, const ACHAR *pszText) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setTextHeight(int nRow, int nCol, double fTextHeight) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setTextHeight(int nRow, int nCol, int nContent, double fTextHeight) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setTextStyle(int nRow, int nCol, const AcDbObjectId &idTextStyle) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setTextStyle(int nRow, int nCol, int nContent, const AcDbObjectId &idTextStyle) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
setToolTip(int nRow, int nCol, const ACHAR *pszToolTip) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, const AcValue &value) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, int nContent, const AcValue &value) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setValue(int nRow, int nCol, int nContent, const AcValue &value, AcValue::ParseOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
tableStyleId(void) const (defined in AcDbTableContent) | AcDbTableContent | virtual
textHeight(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
textHeight(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
textStyle(int nRow, int nCol) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
textStyle(int nRow, int nCol, int nContent) const (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unmerge(const AcCellRange &range) (defined in AcDbFormattedTableData) | AcDbFormattedTableData | virtual
updateDataLink(int nRow, int nCol, AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
updateDataLink(AcDb::UpdateDirection nDir, AcDb::UpdateOption nOption) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbFormattedTableData(void) (defined in AcDbFormattedTableData) | AcDbFormattedTableData |
~AcDbLinkedData(void) (defined in AcDbLinkedData) | AcDbLinkedData | virtual
~AcDbLinkedTableData(void) (defined in AcDbLinkedTableData) | AcDbLinkedTableData | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbTableContent(void) (defined in AcDbTableContent) | AcDbTableContent | virtual
~AcDbTableTemplate(void) (defined in AcDbTableTemplate) | AcDbTableTemplate | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbText Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbText Class Reference
AcDb Classes
+ Inheritance diagram for AcDbText:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbText)
AcDbText (const AcGePoint3d &position, const ACHAR *text, AcDbObjectId style=AcDbObjectId::kNull, double height=0, double rotation=0)
virtual Acad::ErrorStatus | adjustAlignment (const AcDbDatabase *pDb=NULL)
AcGePoint3d | alignmentPoint () const
virtual bool | castShadows () const
Acad::ErrorStatus | convertFieldToText ()
int | correctSpelling ()
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
double | height () const
AcDb::TextHorzMode | horizontalMode () const
Adesk::Boolean | isDefaultAlignment () const
Adesk::Boolean | isMirroredInX () const
Adesk::Boolean | isMirroredInY () const
virtual Adesk::Boolean | isPlanar () const
Acad::ErrorStatus | mirrorInX (Adesk::Boolean)
Acad::ErrorStatus | mirrorInY (Adesk::Boolean)
AcGeVector3d | normal () const
double | oblique () const
AcGePoint3d | position () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
double | rotation () const
Acad::ErrorStatus | setAlignmentPoint (const AcGePoint3d &)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
Acad::ErrorStatus | setHeight (double)
Acad::ErrorStatus | setHorizontalMode (AcDb::TextHorzMode)
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setOblique (double)
Acad::ErrorStatus | setPosition (const AcGePoint3d &)
Acad::ErrorStatus | setRotation (double)
Acad::ErrorStatus | setTextString (const ACHAR *)
Acad::ErrorStatus | setTextStyle (AcDbObjectId)
Acad::ErrorStatus | setThickness (double)
Acad::ErrorStatus | setVerticalMode (AcDb::TextVertMode)
Acad::ErrorStatus | setWidthFactor (double)
ACHAR * | textString () const
const ACHAR * | textStringConst () const
AcDbObjectId | textStyle () const
double | thickness () const
AcDb::TextVertMode | verticalMode () const
double | widthFactor () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbText Member List

This is the complete list of members for AcDbText, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbText) (defined in AcDbText) | AcDbText |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbText() (defined in AcDbText) | AcDbText |
AcDbText(const AcGePoint3d &position, const ACHAR *text, AcDbObjectId style=AcDbObjectId::kNull, double height=0, double rotation=0) (defined in AcDbText) | AcDbText |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
adjustAlignment(const AcDbDatabase *pDb=NULL) (defined in AcDbText) | AcDbText | virtual
alignmentPoint() const (defined in AcDbText) | AcDbText |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbText) | AcDbText | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertFieldToText() (defined in AcDbText) | AcDbText |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
correctSpelling() (defined in AcDbText) | AcDbText |
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbText) | AcDbText | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbText) | AcDbText | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height() const (defined in AcDbText) | AcDbText |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
horizontalMode() const (defined in AcDbText) | AcDbText |
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDefaultAlignment() const (defined in AcDbText) | AcDbText |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isMirroredInX() const (defined in AcDbText) | AcDbText |
isMirroredInY() const (defined in AcDbText) | AcDbText |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbText) | AcDbText | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
mirrorInX(Adesk::Boolean) (defined in AcDbText) | AcDbText |
mirrorInY(Adesk::Boolean) (defined in AcDbText) | AcDbText |
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbText) | AcDbText |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
oblique() const (defined in AcDbText) | AcDbText |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbText) | AcDbText |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbText) | AcDbText | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbText) | AcDbText | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbText) | AcDbText | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbText) | AcDbText | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const (defined in AcDbText) | AcDbText |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAlignmentPoint(const AcGePoint3d &) (defined in AcDbText) | AcDbText |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbText) | AcDbText | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbText) | AcDbText | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double) (defined in AcDbText) | AcDbText |
setHorizontalMode(AcDb::TextHorzMode) (defined in AcDbText) | AcDbText |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbText) | AcDbText |
setOblique(double) (defined in AcDbText) | AcDbText |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &) (defined in AcDbText) | AcDbText |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double) (defined in AcDbText) | AcDbText |
setTextString(const ACHAR *) (defined in AcDbText) | AcDbText |
setTextStyle(AcDbObjectId) (defined in AcDbText) | AcDbText |
setThickness(double) (defined in AcDbText) | AcDbText |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVerticalMode(AcDb::TextVertMode) (defined in AcDbText) | AcDbText |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setWidthFactor(double) (defined in AcDbText) | AcDbText |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
textString() const (defined in AcDbText) | AcDbText |
textStringConst() const (defined in AcDbText) | AcDbText |
textStyle() const (defined in AcDbText) | AcDbText |
thickness() const (defined in AcDbText) | AcDbText |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
verticalMode() const (defined in AcDbText) | AcDbText |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
widthFactor() const (defined in AcDbText) | AcDbText |
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbText() (defined in AcDbText) | AcDbText |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbTextStyleTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbTextStyleTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbTextStyleTable:

Public Types

typedef AcDbTextStyleTableRecord | RecordType
- Public Types inherited from AcDbSymbolTable
typedef AcDbSymbolTableRecord | RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbTextStyleTable)
Acad::ErrorStatus | add (AcDbTextStyleTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbTextStyleTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbTextStyleTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbTextStyleTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTextStyleTable Member List

This is the complete list of members for AcDbTextStyleTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbTextStyleTable) (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
AcDbTextStyleTable() (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbTextStyleTableRecord *pRecord) (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
add(AcDbObjectId &recordId, AcDbTextStyleTableRecord *pRecord) (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbTextStyleTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbTextStyleTable) | AcDbTextStyleTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
has(AcDbObjectId id) const (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbTextStyleTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbTextStyleTable) | AcDbTextStyleTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcDbTextStyleTable() (defined in AcDbTextStyleTable) | AcDbTextStyleTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbTextStyleTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbTextStyleTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbTextStyleTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbTextStyleTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbTextStyleTableRecord *pRecord)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbTextStyleTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTextStyleTableIterator Member List

This is the complete list of members for AcDbTextStyleTableIterator, including all inherited members.

AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbTextStyleTable (defined in AcDbTextStyleTableIterator) | AcDbTextStyleTableIterator | friend
AcDbTextStyleTableIterator() (defined in AcDbTextStyleTableIterator) | AcDbTextStyleTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbTextStyleTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbTextStyleTableIterator) | AcDbTextStyleTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbTextStyleTableIterator) | AcDbTextStyleTableIterator |
seek(const AcDbTextStyleTableRecord *pRecord) (defined in AcDbTextStyleTableIterator) | AcDbTextStyleTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbTextStyleTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbTextStyleTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbTextStyleTableRecord:

Public Types

typedef AcDbTextStyleTable | TableType
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable | TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbTextStyleTableRecord)
Acad::ErrorStatus | bigFontFileName (ACHAR *&fileName) const
Acad::ErrorStatus | bigFontFileName (const ACHAR *&fileName) const
Acad::ErrorStatus | fileName (ACHAR *&fileName) const
Acad::ErrorStatus | fileName (const ACHAR *&fileName) const
Adesk::UInt8 | flagBits () const
Acad::ErrorStatus | font (ACHAR *&pTypeface, Adesk::Boolean &bold, Adesk::Boolean &italic, int &charset, int &pitchAndFamily) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Adesk::Boolean | isShapeFile () const
Adesk::Boolean | isVertical () const
double | obliquingAngle () const
double | priorSize () const
Acad::ErrorStatus | setBigFontFileName (const ACHAR *fileName)
Acad::ErrorStatus | setFileName (const ACHAR *fileName)
void | setFlagBits (Adesk::UInt8 flagBits)
Acad::ErrorStatus | setFont (const ACHAR *pTypeface, Adesk::Boolean bold, Adesk::Boolean italic, int charset, int pitchAndFamily)
void | setIsShapeFile (Adesk::Boolean shape)
void | setIsVertical (Adesk::Boolean vertical)
Acad::ErrorStatus | setObliquingAngle (double obliquingAngle)
Acad::ErrorStatus | setPriorSize (double priorSize)
Acad::ErrorStatus | setTextSize (double size)
Acad::ErrorStatus | setXScale (double xScale)
double | textSize () const
double | xScale () const
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTextStyleTableRecord Member List

This is the complete list of members for AcDbTextStyleTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbTextStyleTableRecord) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
AcDbTextStyleTableRecord() (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
bigFontFileName(ACHAR *&fileName) const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
bigFontFileName(const ACHAR *&fileName) const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fileName(ACHAR *&fileName) const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
fileName(const ACHAR *&fileName) const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
flagBits() const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
font(ACHAR *&pTypeface, Adesk::Boolean &bold, Adesk::Boolean &italic, int &charset, int &pitchAndFamily) const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isShapeFile() const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isVertical() const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
obliquingAngle() const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
priorSize() const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBigFontFileName(const ACHAR *fileName) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFileName(const ACHAR *fileName) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
setFlagBits(Adesk::UInt8 flagBits) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
setFont(const ACHAR *pTypeface, Adesk::Boolean bold, Adesk::Boolean italic, int charset, int pitchAndFamily) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setIsShapeFile(Adesk::Boolean shape) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
setIsVertical(Adesk::Boolean vertical) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setObliquingAngle(double obliquingAngle) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPriorSize(double priorSize) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
setTextSize(double size) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXScale(double xScale) (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
textSize() const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
xScale() const (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcDbTextStyleTableRecord() (defined in AcDbTextStyleTableRecord) | AcDbTextStyleTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbTrace Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbTrace Class Reference
AcDb Classes
+ Inheritance diagram for AcDbTrace:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbTrace)
AcDbTrace (const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2, const AcGePoint3d &pt3)
virtual bool | castShadows () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
Acad::ErrorStatus | getPointAt (Adesk::UInt16 idx, AcGePoint3d &PntRes) const
virtual Adesk::Boolean | isPlanar () const
AcGeVector3d | normal () const
virtual bool | receiveShadows () const
Acad::ErrorStatus | setNormal (const AcGeVector3d &)
Acad::ErrorStatus | setPointAt (Adesk::UInt16 idx, const AcGePoint3d &)
Acad::ErrorStatus | setThickness (double)
double | thickness () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTrace Member List

This is the complete list of members for AcDbTrace, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbTrace) (defined in AcDbTrace) | AcDbTrace |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbTrace() (defined in AcDbTrace) | AcDbTrace |
AcDbTrace(const AcGePoint3d &pt0, const AcGePoint3d &pt1, const AcGePoint3d &pt2, const AcGePoint3d &pt3) (defined in AcDbTrace) | AcDbTrace |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbTrace) | AcDbTrace | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbTrace) | AcDbTrace | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbTrace) | AcDbTrace | virtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAt(Adesk::UInt16 idx, AcGePoint3d &PntRes) const (defined in AcDbTrace) | AcDbTrace |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbTrace) | AcDbTrace | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const (defined in AcDbTrace) | AcDbTrace |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbTrace) | AcDbTrace | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &) (defined in AcDbTrace) | AcDbTrace |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPointAt(Adesk::UInt16 idx, const AcGePoint3d &) (defined in AcDbTrace) | AcDbTrace |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setThickness(double) (defined in AcDbTrace) | AcDbTrace |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
thickness() const (defined in AcDbTrace) | AcDbTrace |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbTrace() (defined in AcDbTrace) | AcDbTrace |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbTransactionManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbTransactionManager Class Reference
AcDb Classes
+ Inheritance diagram for AcDbTransactionManager:

Public Member Functions

virtual Acad::ErrorStatus | abortTransaction ()=0
ACRX_DECLARE_MEMBERS (AcDbTransactionManager)
virtual Acad::ErrorStatus | addNewlyCreatedDBRObject (AcDbObject *obj, bool add=true)=0
virtual void | addReactor (AcTransactionReactor *reactor)=0
virtual Acad::ErrorStatus | endTransaction ()=0
virtual Acad::ErrorStatus | getAllObjects (AcDbVoidPtrArray &objs)=0
virtual Acad::ErrorStatus | getObject (AcDbObject *&obj, AcDbObjectId id, AcDb::OpenMode mode, bool openErasedObj=false)=0
virtual Acad::ErrorStatus | markObjectPageable (AcDbObject *pObject)=0
virtual int | numActiveTransactions ()=0
virtual Acad::ErrorStatus | queueForGraphicsFlush ()=0
virtual void | removeReactor (AcTransactionReactor *reactor)=0
virtual AcTransaction * | startTransaction ()=0
virtual AcTransaction * | topTransaction ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbtrans.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbTransactionManager Member List

This is the complete list of members for AcDbTransactionManager, including all inherited members.

abortTransaction()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
ACRX_DECLARE_MEMBERS(AcDbTransactionManager) (defined in AcDbTransactionManager) | AcDbTransactionManager |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addNewlyCreatedDBRObject(AcDbObject *obj, bool add=true)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
addReactor(AcTransactionReactor *reactor)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
endTransaction()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
getAllObjects(AcDbVoidPtrArray &objs)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
getObject(AcDbObject *&obj, AcDbObjectId id, AcDb::OpenMode mode, bool openErasedObj=false)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
markObjectPageable(AcDbObject *pObject)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
numActiveTransactions()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
queueForGraphicsFlush()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
removeReactor(AcTransactionReactor *reactor)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
startTransaction()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
topTransaction()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbUCSTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbUCSTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbUCSTable:

Public Types

typedef AcDbUCSTableRecord | RecordType
- Public Types inherited from AcDbSymbolTable
typedef AcDbSymbolTableRecord | RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbUCSTable)
Acad::ErrorStatus | add (AcDbUCSTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbUCSTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbUCSTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbUCSTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbUCSTable Member List

This is the complete list of members for AcDbUCSTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbUCSTable) (defined in AcDbUCSTable) | AcDbUCSTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
AcDbUCSTable() (defined in AcDbUCSTable) | AcDbUCSTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbUCSTableRecord *pRecord) (defined in AcDbUCSTable) | AcDbUCSTable |
add(AcDbObjectId &recordId, AcDbUCSTableRecord *pRecord) (defined in AcDbUCSTable) | AcDbUCSTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbUCSTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbUCSTable) | AcDbUCSTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const (defined in AcDbUCSTable) | AcDbUCSTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbUCSTable) | AcDbUCSTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbUCSTable) | AcDbUCSTable |
has(AcDbObjectId id) const (defined in AcDbUCSTable) | AcDbUCSTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbUCSTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbUCSTable) | AcDbUCSTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbUCSTable) | AcDbUCSTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcDbUCSTable() (defined in AcDbUCSTable) | AcDbUCSTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbUCSTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbUCSTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbUCSTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbUCSTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbUCSTableRecord *pRecord)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbUCSTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbUCSTableIterator Member List

This is the complete list of members for AcDbUCSTableIterator, including all inherited members.

AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbUCSTable (defined in AcDbUCSTableIterator) | AcDbUCSTableIterator | friend
AcDbUCSTableIterator() (defined in AcDbUCSTableIterator) | AcDbUCSTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbUCSTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbUCSTableIterator) | AcDbUCSTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbUCSTableIterator) | AcDbUCSTableIterator |
seek(const AcDbUCSTableRecord *pRecord) (defined in AcDbUCSTableIterator) | AcDbUCSTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbUCSTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbUCSTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbUCSTableRecord:

Public Types

typedef AcDbUCSTable | TableType
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable | TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbUCSTableRecord)
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
AcGePoint3d | origin () const
void | setOrigin (const AcGePoint3d &newOrigin)
Acad::ErrorStatus | setUcsBaseOrigin (const AcGePoint3d &origin, AcDb::OrthographicView view)
void | setXAxis (const AcGeVector3d &xAxis)
void | setYAxis (const AcGeVector3d &yAxis)
AcGePoint3d | ucsBaseOrigin (AcDb::OrthographicView view) const
AcGeVector3d | xAxis () const
AcGeVector3d | yAxis () const
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbUCSTableRecord Member List

This is the complete list of members for AcDbUCSTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbUCSTableRecord) (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
AcDbUCSTableRecord() (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
origin() const (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setOrigin(const AcGePoint3d &newOrigin) (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setUcsBaseOrigin(const AcGePoint3d &origin, AcDb::OrthographicView view) (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
setXAxis(const AcGeVector3d &xAxis) (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setYAxis(const AcGeVector3d &yAxis) (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
ucsBaseOrigin(AcDb::OrthographicView view) const (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xAxis() const (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
yAxis() const (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord |
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcDbUCSTableRecord() (defined in AcDbUCSTableRecord) | AcDbUCSTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbUnderlayDefinition Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcDbUnderlayDefinition Class Reference
AcDb Classes
+ Inheritance diagram for AcDbUnderlayDefinition:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbUnderlayDefinition)
AcDbUnderlayDefinition ()
Acad::ErrorStatus | getActiveFileName (const ACHAR *&file) const
Acad::ErrorStatus | getActiveFileName (AcString &file) const
const ACHAR * | getItemName () const
const ACHAR * | getSourceFileName () const
const AcDbUnderlayItem * | getUnderlayItem () const
bool | isLoaded () const
Acad::ErrorStatus | load (const wchar_t *password)
Acad::ErrorStatus | setItemName (const ACHAR *item)
Acad::ErrorStatus | setSourceFileName (const ACHAR *file)
Acad::ErrorStatus | setUnderlayItem (const ACHAR *sourceFileName, const ACHAR *activeFileName, AcDbUnderlayItem *pItem)
void | unload ()
virtual | ~AcDbUnderlayDefinition ()=0
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static AcString dictionaryKey (const AcRxClass *underlayDefinitionType)

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}

Constructor & Destructor Documentation

AcDbUnderlayDefinition::AcDbUnderlayDefinition ( )
Warning
Not implemented!
virtual AcDbUnderlayDefinition::~AcDbUnderlayDefinition ( )
pure virtual
Warning
Not implemented!

Member Function Documentation

static AcString AcDbUnderlayDefinition::dictionaryKey ( const AcRxClass * underlayDefinitionType )
static
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayDefinition::getActiveFileName ( const ACHAR *& file ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayDefinition::getActiveFileName ( AcString & file ) const
Warning
Not implemented!
const ACHAR* AcDbUnderlayDefinition::getItemName ( ) const
Warning
Not implemented!
const ACHAR* AcDbUnderlayDefinition::getSourceFileName ( ) const
Warning
Not implemented!
const AcDbUnderlayItem* AcDbUnderlayDefinition::getUnderlayItem ( ) const
Warning
Not implemented!
bool AcDbUnderlayDefinition::isLoaded ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayDefinition::load ( const wchar_t * password )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayDefinition::setItemName ( const ACHAR * item )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayDefinition::setSourceFileName ( const ACHAR * file )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayDefinition::setUnderlayItem | ( | const ACHAR * | sourceFileName,
 |  | const ACHAR * | activeFileName,
 |  | AcDbUnderlayItem * | pItem
 | ) |  |
Warning
Not implemented!
void AcDbUnderlayDefinition::unload ( )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbunderlaydef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbUnderlayDefinition Member List

This is the complete list of members for AcDbUnderlayDefinition, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbUnderlayDefinition) (defined in AcDbUnderlayDefinition) | AcDbUnderlayDefinition |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbUnderlayDefinition() | AcDbUnderlayDefinition |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dictionaryKey(const AcRxClass *underlayDefinitionType) | AcDbUnderlayDefinition | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getActiveFileName(const ACHAR *&file) const | AcDbUnderlayDefinition |
getActiveFileName(AcString &file) const | AcDbUnderlayDefinition |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getItemName() const | AcDbUnderlayDefinition |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getSourceFileName() const | AcDbUnderlayDefinition |
getUnderlayItem() const | AcDbUnderlayDefinition |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLoaded() const | AcDbUnderlayDefinition |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
load(const wchar_t *password) | AcDbUnderlayDefinition |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setItemName(const ACHAR *item) | AcDbUnderlayDefinition |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setSourceFileName(const ACHAR *file) | AcDbUnderlayDefinition |
setUnderlayItem(const ACHAR *sourceFileName, const ACHAR *activeFileName, AcDbUnderlayItem *pItem) | AcDbUnderlayDefinition |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unload() | AcDbUnderlayDefinition |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbUnderlayDefinition()=0 | AcDbUnderlayDefinition | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbUnderlayFile Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbUnderlayFile Class Reference
AcDb Classes

Public Member Functions

virtual Acad::ErrorStatus | getItem (int i, AcDbUnderlayItem *&pItem) const =0
virtual Acad::ErrorStatus | getItem (const ACHAR *name, AcDbUnderlayItem *&pItem) const =0
virtual int | getItemCount () const =0
The documentation for this class was generated from the following file:
  • dbunderlayhost.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbUnderlayFile Member List

This is the complete list of members for AcDbUnderlayFile, including all inherited members.

getItem(int i, AcDbUnderlayItem *&pItem) const =0 (defined in AcDbUnderlayFile) | AcDbUnderlayFile | pure virtual
getItem(const ACHAR *name, AcDbUnderlayItem *&pItem) const =0 (defined in AcDbUnderlayFile) | AcDbUnderlayFile | pure virtual
getItemCount() const =0 (defined in AcDbUnderlayFile) | AcDbUnderlayFile | pure virtual
~AcDbUnderlayFile()=0 (defined in AcDbUnderlayFile) | AcDbUnderlayFile | pure virtual


ZRX API Reference: AcDbUnderlayHost Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcDbUnderlayHost Class Reference
AcDb Classes

Public Member Functions

virtual Acad::ErrorStatus getFile (const ACHAR *fullPath, const wchar_t *password, AcDbUnderlayFile *&pFile) const =0

Static Public Member Functions

static void getAdjustedColor (AcGeVector3d &rgbResult, const AcGeVector3d &rgbInputColor, const AcGeVector3d &rgbCurrentBackgroundColor, const AcGeVector3d &hslFadedContrastColor, const AcDbUnderlayDrawContext &drawContext)

Member Function Documentation

static void AcDbUnderlayHost::getAdjustedColor | ( | AcGeVector3d & | rgbResult,
 |  | const AcGeVector3d & | rgbInputColor,
 |  | const AcGeVector3d & | rgbCurrentBackgroundColor,
 |  | const AcGeVector3d & | hslFadedContrastColor,
 |  | const AcDbUnderlayDrawContext & | drawContext
 | ) |  |
static
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbunderlayhost.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbUnderlayHost Member List

This is the complete list of members for AcDbUnderlayHost, including all inherited members.

getAdjustedColor(AcGeVector3d &rgbResult, const AcGeVector3d &rgbInputColor, const AcGeVector3d &rgbCurrentBackgroundColor, const AcGeVector3d &hslFadedContrastColor, const AcDbUnderlayDrawContext &drawContext) | AcDbUnderlayHost | static
getFile(const ACHAR *fullPath, const wchar_t *password, AcDbUnderlayFile *&pFile) const =0 (defined in AcDbUnderlayHost) | AcDbUnderlayHost | pure virtual
~AcDbUnderlayHost()=0 (defined in AcDbUnderlayHost) | AcDbUnderlayHost | protectedpure virtual


ZRX API Reference: AcDbUnderlayItem Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbUnderlayItem Class Reference
AcDb Classes
+ Inheritance diagram for AcDbUnderlayItem:

Public Member Functions

virtual Acad::ErrorStatus | draw (AcGiWorldDraw *pWorldDraw, AcGiViewportDraw *pViewportDraw, const AcDbUnderlayDrawContext &context) const =0
virtual Acad::ErrorStatus | getExtents (AcGePoint2d &min, AcGePoint2d &max) const =0
virtual AcString | getName () const =0
virtual Acad::ErrorStatus | getOsnapPoints (const AcGeMatrix3d &modelToWorld, AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const =0
virtual AcDbEntity * | getSubEntityAtGsMarker (const AcGeMatrix3d &modelToWorld, Adesk::GsMarker gsSelectionMark) const =0
virtual Acad::ErrorStatus | getThumbnail (BITMAPINFO *&thumbnail) const =0
virtual Acad::ErrorStatus | getUnderlayLayer (int idx, AcUnderlayLayer &layer) const
virtual AcDb::UnitsValue | getUnits () const =0
virtual Acad::ErrorStatus | intersectWith (const AcGeMatrix3d &modelToWorld, const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane *projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const =0
virtual AcGeMatrix3d | modelTransform () const =0
virtual Adesk::UInt32 | underlayLayerCount () const
virtual bool | usingPartialContent () const =0
int | version () const
The documentation for this class was generated from the following file:
  • dbunderlayhost.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbUnderlayItem Member List

This is the complete list of members for AcDbUnderlayItem, including all inherited members.

draw(AcGiWorldDraw *pWorldDraw, AcGiViewportDraw *pViewportDraw, const AcDbUnderlayDrawContext &context) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getExtents(AcGePoint2d &min, AcGePoint2d &max) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getName() const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getOsnapPoints(const AcGeMatrix3d &modelToWorld, AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getSubEntityAtGsMarker(const AcGeMatrix3d &modelToWorld, Adesk::GsMarker gsSelectionMark) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getThumbnail(BITMAPINFO *&thumbnail) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
getUnderlayLayer(int idx, AcUnderlayLayer &layer) const (defined in AcDbUnderlayItem) | AcDbUnderlayItem | inlinevirtual
getUnits() const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
intersectWith(const AcGeMatrix3d &modelToWorld, const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane *projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
modelTransform() const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
underlayLayerCount() const (defined in AcDbUnderlayItem) | AcDbUnderlayItem | inlinevirtual
usingPartialContent() const =0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual
version() const (defined in AcDbUnderlayItem) | AcDbUnderlayItem |
~AcDbUnderlayItem()=0 (defined in AcDbUnderlayItem) | AcDbUnderlayItem | pure virtual


ZRX API Reference: AcDbUnderlayReference Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcDbUnderlayReference Class Reference
AcDb Classes
+ Inheritance diagram for AcDbUnderlayReference:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbUnderlayReference)
const AcGePoint2dArray & | clipBoundary () const
Adesk::UInt8 | contrast () const
AcDbObjectId | definitionId () const
Adesk::UInt8 | fade () const
Acad::ErrorStatus | getUnderlayLayer (int index, AcUnderlayLayer &layer) const
bool | isAdjustedForBackground () const
bool | isClipped () const
virtual bool | isContentSnappable () const
virtual bool | isFramePlottable () const
virtual bool | isFrameVisible () const
bool | isMonochrome () const
bool | isOn () const
AcGeVector3d | normal () const
AcGePoint3d | position () const
double | rotation () const
AcGeScale3d | scaleFactors () const
Acad::ErrorStatus | setClipBoundary (const AcGePoint2dArray &clipBoundary)
Acad::ErrorStatus | setContrast (Adesk::UInt8 value)
Acad::ErrorStatus | setDefinitionId (AcDbObjectId id)
Acad::ErrorStatus | setFade (Adesk::UInt8 value)
Acad::ErrorStatus | setIsAdjustedForBackground (bool value)
Acad::ErrorStatus | setIsClipped (bool value)
Acad::ErrorStatus | setIsMonochrome (bool value)
Acad::ErrorStatus | setIsOn (bool value)
Acad::ErrorStatus | setNormal (const AcGeVector3d &normal)
Acad::ErrorStatus | setPosition (const AcGePoint3d &position)
Acad::ErrorStatus | setRotation (double rotation)
Acad::ErrorStatus | setScaleFactors (const AcGeScale3d &scale)
Acad::ErrorStatus | setTransform (const AcGeMatrix3d &transform)
Acad::ErrorStatus | setUnderlayLayer (int index, const AcUnderlayLayer &layer)
AcGeMatrix3d | transform () const
Adesk::UInt32 | underlayLayerCount () const
virtual | ~AcDbUnderlayReference ()=0
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static Adesk::UInt8 | contrastDefault ()
static Adesk::UInt8 | contrastLowerLimit ()
static Adesk::UInt8 | contrastUpperLimit ()
static Adesk::UInt8 | fadeDefault ()
static Adesk::UInt8 | fadeLowerLimit ()
static Adesk::UInt8 | fadeUpperLimit ()

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Constructor & Destructor Documentation

virtual AcDbUnderlayReference::~AcDbUnderlayReference ( )
pure virtual
Warning
Not implemented!

Member Function Documentation

const AcGePoint2dArray& AcDbUnderlayReference::clipBoundary ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbUnderlayReference::contrast ( ) const
Warning
Not implemented!
static Adesk::UInt8 AcDbUnderlayReference::contrastDefault ( )
static
Warning
Not implemented!
static Adesk::UInt8 AcDbUnderlayReference::contrastLowerLimit ( )
static
Warning
Not implemented!
static Adesk::UInt8 AcDbUnderlayReference::contrastUpperLimit ( )
static
Warning
Not implemented!
AcDbObjectId AcDbUnderlayReference::definitionId ( ) const
Warning
Not implemented!
Adesk::UInt8 AcDbUnderlayReference::fade ( ) const
Warning
Not implemented!
static Adesk::UInt8 AcDbUnderlayReference::fadeDefault ( )
static
Warning
Not implemented!
static Adesk::UInt8 AcDbUnderlayReference::fadeLowerLimit ( )
static
Warning
Not implemented!
static Adesk::UInt8 AcDbUnderlayReference::fadeUpperLimit ( )
static
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::getUnderlayLayer | ( | int | index,
 |  | AcUnderlayLayer & | layer
 | ) |  | const
Warning
Not implemented!
bool AcDbUnderlayReference::isAdjustedForBackground ( ) const
Warning
Not implemented!
bool AcDbUnderlayReference::isClipped ( ) const
Warning
Not implemented!
virtual bool AcDbUnderlayReference::isContentSnappable ( ) const
virtual
Warning
Not implemented!
virtual bool AcDbUnderlayReference::isFramePlottable ( ) const
virtual
Warning
Not implemented!
virtual bool AcDbUnderlayReference::isFrameVisible ( ) const
virtual
Warning
Not implemented!
bool AcDbUnderlayReference::isMonochrome ( ) const
Warning
Not implemented!
bool AcDbUnderlayReference::isOn ( ) const
Warning
Not implemented!
AcGeVector3d AcDbUnderlayReference::normal ( ) const
Warning
Not implemented!
AcGePoint3d AcDbUnderlayReference::position ( ) const
Warning
Not implemented!
double AcDbUnderlayReference::rotation ( ) const
Warning
Not implemented!
AcGeScale3d AcDbUnderlayReference::scaleFactors ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setClipBoundary ( const AcGePoint2dArray & clipBoundary )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setContrast ( Adesk::UInt8 value )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setDefinitionId ( AcDbObjectId id )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setFade ( Adesk::UInt8 value )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setIsAdjustedForBackground ( bool value )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setIsClipped ( bool value )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setIsMonochrome ( bool value )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setIsOn ( bool value )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setNormal ( const AcGeVector3d & normal )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setPosition ( const AcGePoint3d & position )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setRotation ( double rotation )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setScaleFactors ( const AcGeScale3d & scale )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setTransform ( const AcGeMatrix3d & transform )
Warning
Not implemented!
Acad::ErrorStatus AcDbUnderlayReference::setUnderlayLayer | ( | int | index,
 |  | const AcUnderlayLayer & | layer
 | ) |  |
Warning
Not implemented!
AcGeMatrix3d AcDbUnderlayReference::transform ( ) const
Warning
Not implemented!
Adesk::UInt32 AcDbUnderlayReference::underlayLayerCount ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbunderlayref.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbUnderlayReference Member List

This is the complete list of members for AcDbUnderlayReference, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbUnderlayReference) (defined in AcDbUnderlayReference) | AcDbUnderlayReference |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clipBoundary() const | AcDbUnderlayReference |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const | AcDbUnderlayReference |
contrastDefault() | AcDbUnderlayReference | static
contrastLowerLimit() | AcDbUnderlayReference | static
contrastUpperLimit() | AcDbUnderlayReference | static
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
definitionId() const | AcDbUnderlayReference |
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fade() const | AcDbUnderlayReference |
fadeDefault() | AcDbUnderlayReference | static
fadeLowerLimit() | AcDbUnderlayReference | static
fadeUpperLimit() | AcDbUnderlayReference | static
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
getUnderlayLayer(int index, AcUnderlayLayer &layer) const | AcDbUnderlayReference |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAdjustedForBackground() const | AcDbUnderlayReference |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClipped() const | AcDbUnderlayReference |
isContentSnappable() const | AcDbUnderlayReference | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFramePlottable() const | AcDbUnderlayReference | virtual
isFrameVisible() const | AcDbUnderlayReference | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isMonochrome() const | AcDbUnderlayReference |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isOn() const | AcDbUnderlayReference |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
normal() const | AcDbUnderlayReference |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const | AcDbUnderlayReference |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
rotation() const | AcDbUnderlayReference |
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
scaleFactors() const | AcDbUnderlayReference |
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setClipBoundary(const AcGePoint2dArray &clipBoundary) | AcDbUnderlayReference |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setContrast(Adesk::UInt8 value) | AcDbUnderlayReference |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDefinitionId(AcDbObjectId id) | AcDbUnderlayReference |
setFade(Adesk::UInt8 value) | AcDbUnderlayReference |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setIsAdjustedForBackground(bool value) | AcDbUnderlayReference |
setIsClipped(bool value) | AcDbUnderlayReference |
setIsMonochrome(bool value) | AcDbUnderlayReference |
setIsOn(bool value) | AcDbUnderlayReference |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setNormal(const AcGeVector3d &normal) | AcDbUnderlayReference |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPosition(const AcGePoint3d &position) | AcDbUnderlayReference |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRotation(double rotation) | AcDbUnderlayReference |
setScaleFactors(const AcGeScale3d &scale) | AcDbUnderlayReference |
setTransform(const AcGeMatrix3d &transform) | AcDbUnderlayReference |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUnderlayLayer(int index, const AcUnderlayLayer &layer) | AcDbUnderlayReference |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transform() const | AcDbUnderlayReference |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
underlayLayerCount() const | AcDbUnderlayReference |
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbUnderlayReference()=0 | AcDbUnderlayReference | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbVertex Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbVertex Class Reference
AcDb Classes
+ Inheritance diagram for AcDbVertex:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbVertex)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbVertex Member List

This is the complete list of members for AcDbVertex, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbVertex) (defined in AcDbVertex) | AcDbVertex |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbVertex() (defined in AcDbVertex) | AcDbVertex |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbEntity) | AcDbEntity | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbVertex() (defined in AcDbVertex) | AcDbVertex | inline
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbViewport Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbViewport Class Reference
AcDb Classes
+ Inheritance diagram for AcDbViewport:

Public Types

enum ShadePlotType {
kAsDisplayed = 0, kWireframe = 1, kHidden = 2, kRendered = 3,
kVisualStyle = 4, kRenderPreset = 5
}
enum StandardScaleType {
kScaleToFit, kCustomScale, k1_1, k1_2,
k1_4, k1_5, k1_8, k1_10,
k1_16, k1_20, k1_30, k1_40,
k1_50, k1_100, k2_1, k4_1,
k8_1, k10_1, k100_1, k1_128in_1ft,
k1_64in_1ft, k1_32in_1ft, k1_16in_1ft, k3_32in_1ft,
k1_8in_1ft, k3_16in_1ft, k1_4in_1ft, k3_8in_1ft,
k1_2in_1ft, k3_4in_1ft, k1in_1ft, k1and1_2in_1ft,
k3in_1ft, k6in_1ft, k1ft_1ft
}
- Public Types inherited from AcDbEntity
enum VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbViewport)
AcCmColor | ambientLightColor () const
AcDbAnnotationScale * | annotationScale () const
double | backClipDistance () const
AcDbObjectId | background () const
double | brightness () const
AcGePoint3d | centerPoint () const
Adesk::UInt16 | circleSides () const
double | contrast () const
virtual void | copied (const AcDbObject *pDbObj, const AcDbObject *pNewObj)
double | customScale () const
AcGiViewportTraits::DefaultLightingType | defaultLightingType () const
Acad::ErrorStatus | effectivePlotStyleSheet (const ACHAR *&)
double | elevation () const
virtual void | erased (const AcDbObject *, Adesk::Boolean)
Acad::ErrorStatus | freezeLayersInViewport (const AcDbObjectIdArray &)
double | frontClipDistance () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getFrozenLayerList (AcDbObjectIdArray &ids) const
Acad::ErrorStatus | getLabelBlock (AcDbObjectId &objId) const
Acad::ErrorStatus | getModelView (AcDbXrefObjectId &xrefObjId) const
Acad::ErrorStatus | getSheetView (AcDbObjectId &objId) const
Acad::ErrorStatus | getUcs (AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis) const
AcGeVector2d | gridIncrement () const
Adesk::UInt16 | gridMajor () const
double | height () const
bool | hiddenLinesRemoved () const
bool | isBackClipOn () const
bool | isDefaultLightingOn () const
bool | isFastZoomOn () const
bool | isFrontClipAtEyeOn () const
bool | isFrontClipOn () const
bool | isGridAdaptive () const
bool | isGridBoundToLimits () const
bool | isGridFollow () const
bool | isGridOn () const
bool | isGridSubdivisionRestricted () const
bool | isLayerFrozenInViewport (const AcDbObjectId &layerId) const
bool | isLocked () const
bool | isNonRectClipOn () const
bool | isOn () const
bool | isPerspectiveOn () const
bool | isSnapIsometric () const
bool | isSnapOn () const
bool | isTransparent () const
bool | isUcsFollowModeOn () const
bool | isUcsIconAtOrigin () const
bool | isUcsIconVisible () const
bool | isUcsOrthographic (AcDb::OrthographicView &view) const
bool | isUcsSavedWithViewport () const
bool | isViewOrthographic (AcDb::OrthographicView &view) const
double | lensLength () const
virtual void | modified (const AcDbObject *)
AcDbObjectId | nonRectClipEntityId () const
Adesk::Int16 | number () const
bool | plotAsRaster () const
Acad::ErrorStatus | plotStyleSheet (ACHAR *&) const
Acad::ErrorStatus | plotStyleSheet (const ACHAR *&) const
bool | plotWireframe () const
AcDbObjectId | previousBackground (AcGiDrawable::DrawableType type=AcGiDrawable::kGeometry) const
Acad::ErrorStatus | removeHiddenLines ()
Acad::ErrorStatus | removeLabelBlock (void)
Acad::ErrorStatus | removeModelView (void)
Acad::ErrorStatus | removeSheetView (void)
AcDbAbstractViewTableRecord::RenderMode | renderMode () const
Acad::ErrorStatus | setAmbientLightColor (const AcCmColor &clr)
Acad::ErrorStatus | setAnnotationScale (const AcDbAnnotationScale *pScaleObj)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *)
Acad::ErrorStatus | setBackClipDistance (double newVal)
Acad::ErrorStatus | setBackClipOff ()
Acad::ErrorStatus | setBackClipOn ()
Acad::ErrorStatus | setBackground (AcDbObjectId backgroundId)
Acad::ErrorStatus | setBrightness (double)
Acad::ErrorStatus | setCenterPoint (const AcGePoint3d &)
Acad::ErrorStatus | setCircleSides (Adesk::UInt16)
Acad::ErrorStatus | setContrast (double)
Acad::ErrorStatus | setCustomScale (double)
Acad::ErrorStatus | setDefaultLightingOn (bool on)
Acad::ErrorStatus | setDefaultLightingType (AcGiViewportTraits::DefaultLightingType typ)
Acad::ErrorStatus | setElevation (double elev)
Acad::ErrorStatus | setFastZoomOff ()
Acad::ErrorStatus | setFastZoomOn ()
Acad::ErrorStatus | setFrontClipAtEyeOff ()
Acad::ErrorStatus | setFrontClipAtEyeOn ()
Acad::ErrorStatus | setFrontClipDistance (double newVal)
Acad::ErrorStatus | setFrontClipOff ()
Acad::ErrorStatus | setFrontClipOn ()
Acad::ErrorStatus | setGridAdaptive (bool bNewVal)
Acad::ErrorStatus | setGridBoundToLimits (bool bNewVal)
Acad::ErrorStatus | setGridFollow (bool bNewVal)
Acad::ErrorStatus | setGridIncrement (const AcGeVector2d &)
Acad::ErrorStatus | setGridMajor (Adesk::UInt16)
Acad::ErrorStatus | setGridOff ()
Acad::ErrorStatus | setGridOn ()
Acad::ErrorStatus | setGridSubdivisionRestricted (bool bNewVal)
Acad::ErrorStatus | setHeight (double)
Acad::ErrorStatus | setLabelBlock (AcDbObjectId objId)
Acad::ErrorStatus | setLensLength (double)
Acad::ErrorStatus | setLocked ()
Acad::ErrorStatus | setModelView (const AcDbXrefObjectId &xrefObjId)
Acad::ErrorStatus | setNonRectClipEntityId (AcDbObjectId)
Acad::ErrorStatus | setNonRectClipOff ()
Acad::ErrorStatus | setNonRectClipOn ()
Acad::ErrorStatus | setOff ()
Acad::ErrorStatus | setOn ()
Acad::ErrorStatus | setOpaque ()
Acad::ErrorStatus | setPerspectiveOff ()
Acad::ErrorStatus | setPerspectiveOn ()
Acad::ErrorStatus | setPlotStyleSheet (const ACHAR *)
Acad::ErrorStatus | setPreviousBackground (AcDbObjectId backgroundId, AcGiDrawable::DrawableType type=AcGiDrawable::kGeometry)
void | setRenderMode (AcDbAbstractViewTableRecord::RenderMode mode)
Acad::ErrorStatus | setShadePlot (const ShadePlotType)
Acad::ErrorStatus | setShadePlot (const ShadePlotType type, const AcDbObjectId shadePlotId)
Acad::ErrorStatus | setSheetView (AcDbObjectId objId)
Acad::ErrorStatus | setSnapAngle (double)
Acad::ErrorStatus | setSnapBasePoint (const AcGePoint2d &)
Acad::ErrorStatus | setSnapIncrement (const AcGeVector2d &)
Acad::ErrorStatus | setSnapIsometric ()
Acad::ErrorStatus | setSnapIsoPair (Adesk::UInt16)
Acad::ErrorStatus | setSnapOff ()
Acad::ErrorStatus | setSnapOn ()
Acad::ErrorStatus | setSnapStandard ()
Acad::ErrorStatus | setStandardScale (const StandardScaleType)
Acad::ErrorStatus | setSun (AcDbObjectId &retId, AcDbObject *pSun)
Acad::ErrorStatus | setToneOperatorParameters (const AcGiToneOperatorParameters &params)
Acad::ErrorStatus | setTransparent ()
Acad::ErrorStatus | setTwistAngle (double)
Acad::ErrorStatus | setUcs (const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis)
Acad::ErrorStatus | setUcs (AcDb::OrthographicView view)
Acad::ErrorStatus | setUcs (const AcDbObjectId &ucsId)
Acad::ErrorStatus | setUcsFollowModeOff ()
Acad::ErrorStatus | setUcsFollowModeOn ()
Acad::ErrorStatus | setUcsIconAtCorner ()
Acad::ErrorStatus | setUcsIconAtOrigin ()
Acad::ErrorStatus | setUcsIconInvisible ()
Acad::ErrorStatus | setUcsIconVisible ()
void | setUcsPerViewport (bool ucsvp)
Acad::ErrorStatus | setUcsToWorld ()
Acad::ErrorStatus | setUnlocked ()
Acad::ErrorStatus | setViewCenter (const AcGePoint2d &pt)
Acad::ErrorStatus | setViewDirection (const AcGeVector3d &)
Acad::ErrorStatus | setViewDirection (AcDb::OrthographicView view)
Acad::ErrorStatus | setViewHeight (double ht)
Acad::ErrorStatus | setViewTarget (const AcGePoint3d &)
Acad::ErrorStatus | setVisualStyle (const AcDbObjectId oidVisualStyle)
Acad::ErrorStatus | setWidth (double)
ShadePlotType | shadePlot () const
AcDbObjectId | shadePlotId () const
Acad::ErrorStatus | showHiddenLines ()
double | snapAngle () const
AcGePoint2d | snapBasePoint () const
AcGeVector2d | snapIncrement () const
Adesk::UInt16 | snapIsoPair () const
StandardScaleType | standardScale () const
virtual void | subObjModified (const AcDbObject *pDbObj, const AcDbObject *pSubObj)
AcDbObjectId | sunId () const
Acad::ErrorStatus | syncModelView (void)
Acad::ErrorStatus | thawAllLayersInViewport ()
Acad::ErrorStatus | thawLayersInViewport (const AcDbObjectIdArray &)
Acad::ErrorStatus | toneOperatorParameters (AcGiToneOperatorParameters &params) const
double | twistAngle () const
AcDbObjectId | ucsName () const
Acad::ErrorStatus | updateDisplay () const
AcGePoint2d | viewCenter () const
AcGeVector3d | viewDirection () const
double | viewHeight () const
AcGePoint3d | viewTarget () const
AcDbObjectId | visualStyle () const
double | width () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbents.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbViewport Member List

This is the complete list of members for AcDbViewport, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbViewport) (defined in AcDbViewport) | AcDbViewport |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbViewport() (defined in AcDbViewport) | AcDbViewport |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
ambientLightColor() const (defined in AcDbViewport) | AcDbViewport |
annotationScale() const (defined in AcDbViewport) | AcDbViewport |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
backClipDistance() const (defined in AcDbViewport) | AcDbViewport |
background() const (defined in AcDbViewport) | AcDbViewport |
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
brightness() const (defined in AcDbViewport) | AcDbViewport |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
centerPoint() const (defined in AcDbViewport) | AcDbViewport |
circleSides() const (defined in AcDbViewport) | AcDbViewport |
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const (defined in AcDbViewport) | AcDbViewport |
copied(const AcDbObject *pDbObj, const AcDbObject *pNewObj) (defined in AcDbViewport) | AcDbViewport | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
customScale() const (defined in AcDbViewport) | AcDbViewport |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
defaultLightingType() const (defined in AcDbViewport) | AcDbViewport |
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
effectivePlotStyleSheet(const ACHAR *&) (defined in AcDbViewport) | AcDbViewport |
elevation() const (defined in AcDbViewport) | AcDbViewport |
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *, Adesk::Boolean) (defined in AcDbViewport) | AcDbViewport | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
freezeLayersInViewport(const AcDbObjectIdArray &) (defined in AcDbViewport) | AcDbViewport |
frontClipDistance() const (defined in AcDbViewport) | AcDbViewport |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbViewport) | AcDbViewport | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFrozenLayerList(AcDbObjectIdArray &ids) const (defined in AcDbViewport) | AcDbViewport |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getLabelBlock(AcDbObjectId &objId) const (defined in AcDbViewport) | AcDbViewport |
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getModelView(AcDbXrefObjectId &xrefObjId) const (defined in AcDbViewport) | AcDbViewport |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getSheetView(AcDbObjectId &objId) const (defined in AcDbViewport) | AcDbViewport |
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
getUcs(AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis) const (defined in AcDbViewport) | AcDbViewport |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gridIncrement() const (defined in AcDbViewport) | AcDbViewport |
gridMajor() const (defined in AcDbViewport) | AcDbViewport |
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height() const (defined in AcDbViewport) | AcDbViewport |
hiddenLinesRemoved() const (defined in AcDbViewport) | AcDbViewport |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isBackClipOn() const (defined in AcDbViewport) | AcDbViewport |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDefaultLightingOn() const (defined in AcDbViewport) | AcDbViewport |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isFastZoomOn() const (defined in AcDbViewport) | AcDbViewport | inline
isFrontClipAtEyeOn() const (defined in AcDbViewport) | AcDbViewport |
isFrontClipOn() const (defined in AcDbViewport) | AcDbViewport |
isGridAdaptive() const (defined in AcDbViewport) | AcDbViewport |
isGridBoundToLimits() const (defined in AcDbViewport) | AcDbViewport |
isGridFollow() const (defined in AcDbViewport) | AcDbViewport |
isGridOn() const (defined in AcDbViewport) | AcDbViewport |
isGridSubdivisionRestricted() const (defined in AcDbViewport) | AcDbViewport |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isLayerFrozenInViewport(const AcDbObjectId &layerId) const (defined in AcDbViewport) | AcDbViewport |
isLocked() const (defined in AcDbViewport) | AcDbViewport |
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNonRectClipOn() const (defined in AcDbViewport) | AcDbViewport |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isOn() const (defined in AcDbViewport) | AcDbViewport |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPerspectiveOn() const (defined in AcDbViewport) | AcDbViewport |
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isSnapIsometric() const (defined in AcDbViewport) | AcDbViewport |
isSnapOn() const (defined in AcDbViewport) | AcDbViewport |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isTransparent() const (defined in AcDbViewport) | AcDbViewport |
isUcsFollowModeOn() const (defined in AcDbViewport) | AcDbViewport |
isUcsIconAtOrigin() const (defined in AcDbViewport) | AcDbViewport |
isUcsIconVisible() const (defined in AcDbViewport) | AcDbViewport |
isUcsOrthographic(AcDb::OrthographicView &view) const (defined in AcDbViewport) | AcDbViewport |
isUcsSavedWithViewport() const (defined in AcDbViewport) | AcDbViewport |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isViewOrthographic(AcDb::OrthographicView &view) const (defined in AcDbViewport) | AcDbViewport |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
k100_1 enum value (defined in AcDbViewport) | AcDbViewport |
k10_1 enum value (defined in AcDbViewport) | AcDbViewport |
k1_1 enum value (defined in AcDbViewport) | AcDbViewport |
k1_10 enum value (defined in AcDbViewport) | AcDbViewport |
k1_100 enum value (defined in AcDbViewport) | AcDbViewport |
k1_128in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k1_16 enum value (defined in AcDbViewport) | AcDbViewport |
k1_16in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k1_2 enum value (defined in AcDbViewport) | AcDbViewport |
k1_20 enum value (defined in AcDbViewport) | AcDbViewport |
k1_2in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k1_30 enum value (defined in AcDbViewport) | AcDbViewport |
k1_32in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k1_4 enum value (defined in AcDbViewport) | AcDbViewport |
k1_40 enum value (defined in AcDbViewport) | AcDbViewport |
k1_4in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k1_5 enum value (defined in AcDbViewport) | AcDbViewport |
k1_50 enum value (defined in AcDbViewport) | AcDbViewport |
k1_64in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k1_8 enum value (defined in AcDbViewport) | AcDbViewport |
k1_8in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k1and1_2in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k1ft_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k1in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k2_1 enum value (defined in AcDbViewport) | AcDbViewport |
k3_16in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k3_32in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k3_4in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k3_8in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k3in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k4_1 enum value (defined in AcDbViewport) | AcDbViewport |
k6in_1ft enum value (defined in AcDbViewport) | AcDbViewport |
k8_1 enum value (defined in AcDbViewport) | AcDbViewport |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kAsDisplayed enum value (defined in AcDbViewport) | AcDbViewport |
kCustomScale enum value (defined in AcDbViewport) | AcDbViewport |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHidden enum value (defined in AcDbViewport) | AcDbViewport |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kRendered enum value (defined in AcDbViewport) | AcDbViewport |
kRenderPreset enum value (defined in AcDbViewport) | AcDbViewport |
kScaleToFit enum value (defined in AcDbViewport) | AcDbViewport |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kVisualStyle enum value (defined in AcDbViewport) | AcDbViewport |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kWireframe enum value (defined in AcDbViewport) | AcDbViewport |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
lensLength() const (defined in AcDbViewport) | AcDbViewport |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *) (defined in AcDbViewport) | AcDbViewport | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
nonRectClipEntityId() const (defined in AcDbViewport) | AcDbViewport |
number() const (defined in AcDbViewport) | AcDbViewport |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotAsRaster() const (defined in AcDbViewport) | AcDbViewport |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
plotStyleSheet(ACHAR *&) const (defined in AcDbViewport) | AcDbViewport |
plotStyleSheet(const ACHAR *&) const (defined in AcDbViewport) | AcDbViewport |
plotWireframe() const (defined in AcDbViewport) | AcDbViewport |
previousBackground(AcGiDrawable::DrawableType type=AcGiDrawable::kGeometry) const (defined in AcDbViewport) | AcDbViewport |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removeHiddenLines() (defined in AcDbViewport) | AcDbViewport |
removeLabelBlock(void) (defined in AcDbViewport) | AcDbViewport |
removeModelView(void) (defined in AcDbViewport) | AcDbViewport |
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
removeSheetView(void) (defined in AcDbViewport) | AcDbViewport |
renderMode() const (defined in AcDbViewport) | AcDbViewport |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAmbientLightColor(const AcCmColor &clr) (defined in AcDbViewport) | AcDbViewport |
setAnnotationScale(const AcDbAnnotationScale *pScaleObj) (defined in AcDbViewport) | AcDbViewport |
setAttributes(AcGiDrawableTraits *) (defined in AcDbViewport) | AcDbViewport | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBackClipDistance(double newVal) (defined in AcDbViewport) | AcDbViewport |
setBackClipOff() (defined in AcDbViewport) | AcDbViewport |
setBackClipOn() (defined in AcDbViewport) | AcDbViewport |
setBackground(AcDbObjectId backgroundId) (defined in AcDbViewport) | AcDbViewport |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBrightness(double) (defined in AcDbViewport) | AcDbViewport |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setCenterPoint(const AcGePoint3d &) (defined in AcDbViewport) | AcDbViewport |
setCircleSides(Adesk::UInt16) (defined in AcDbViewport) | AcDbViewport |
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setContrast(double) (defined in AcDbViewport) | AcDbViewport |
setCustomScale(double) (defined in AcDbViewport) | AcDbViewport |
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDefaultLightingOn(bool on) (defined in AcDbViewport) | AcDbViewport |
setDefaultLightingType(AcGiViewportTraits::DefaultLightingType typ) (defined in AcDbViewport) | AcDbViewport |
setElevation(double elev) (defined in AcDbViewport) | AcDbViewport |
setFastZoomOff() (defined in AcDbViewport) | AcDbViewport | inline
setFastZoomOn() (defined in AcDbViewport) | AcDbViewport | inline
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFrontClipAtEyeOff() (defined in AcDbViewport) | AcDbViewport |
setFrontClipAtEyeOn() (defined in AcDbViewport) | AcDbViewport |
setFrontClipDistance(double newVal) (defined in AcDbViewport) | AcDbViewport |
setFrontClipOff() (defined in AcDbViewport) | AcDbViewport |
setFrontClipOn() (defined in AcDbViewport) | AcDbViewport |
setGridAdaptive(bool bNewVal) (defined in AcDbViewport) | AcDbViewport |
setGridBoundToLimits(bool bNewVal) (defined in AcDbViewport) | AcDbViewport |
setGridFollow(bool bNewVal) (defined in AcDbViewport) | AcDbViewport |
setGridIncrement(const AcGeVector2d &) (defined in AcDbViewport) | AcDbViewport |
setGridMajor(Adesk::UInt16) (defined in AcDbViewport) | AcDbViewport |
setGridOff() (defined in AcDbViewport) | AcDbViewport |
setGridOn() (defined in AcDbViewport) | AcDbViewport |
setGridSubdivisionRestricted(bool bNewVal) (defined in AcDbViewport) | AcDbViewport |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double) (defined in AcDbViewport) | AcDbViewport |
setLabelBlock(AcDbObjectId objId) (defined in AcDbViewport) | AcDbViewport |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLensLength(double) (defined in AcDbViewport) | AcDbViewport |
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLocked() (defined in AcDbViewport) | AcDbViewport |
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setModelView(const AcDbXrefObjectId &xrefObjId) (defined in AcDbViewport) | AcDbViewport |
setNonRectClipEntityId(AcDbObjectId) (defined in AcDbViewport) | AcDbViewport |
setNonRectClipOff() (defined in AcDbViewport) | AcDbViewport |
setNonRectClipOn() (defined in AcDbViewport) | AcDbViewport |
setOff() (defined in AcDbViewport) | AcDbViewport |
setOn() (defined in AcDbViewport) | AcDbViewport |
setOpaque() (defined in AcDbViewport) | AcDbViewport |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPerspectiveOff() (defined in AcDbViewport) | AcDbViewport |
setPerspectiveOn() (defined in AcDbViewport) | AcDbViewport |
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleSheet(const ACHAR *) (defined in AcDbViewport) | AcDbViewport |
setPreviousBackground(AcDbObjectId backgroundId, AcGiDrawable::DrawableType type=AcGiDrawable::kGeometry) (defined in AcDbViewport) | AcDbViewport |
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setRenderMode(AcDbAbstractViewTableRecord::RenderMode mode) (defined in AcDbViewport) | AcDbViewport |
setShadePlot(const ShadePlotType) (defined in AcDbViewport) | AcDbViewport |
setShadePlot(const ShadePlotType type, const AcDbObjectId shadePlotId) (defined in AcDbViewport) | AcDbViewport |
setSheetView(AcDbObjectId objId) (defined in AcDbViewport) | AcDbViewport |
setSnapAngle(double) (defined in AcDbViewport) | AcDbViewport |
setSnapBasePoint(const AcGePoint2d &) (defined in AcDbViewport) | AcDbViewport |
setSnapIncrement(const AcGeVector2d &) (defined in AcDbViewport) | AcDbViewport |
setSnapIsometric() (defined in AcDbViewport) | AcDbViewport |
setSnapIsoPair(Adesk::UInt16) (defined in AcDbViewport) | AcDbViewport |
setSnapOff() (defined in AcDbViewport) | AcDbViewport |
setSnapOn() (defined in AcDbViewport) | AcDbViewport |
setSnapStandard() (defined in AcDbViewport) | AcDbViewport |
setStandardScale(const StandardScaleType) (defined in AcDbViewport) | AcDbViewport |
setSun(AcDbObjectId &retId, AcDbObject *pSun) (defined in AcDbViewport) | AcDbViewport |
setToneOperatorParameters(const AcGiToneOperatorParameters &params) (defined in AcDbViewport) | AcDbViewport |
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparent() (defined in AcDbViewport) | AcDbViewport |
setTwistAngle(double) (defined in AcDbViewport) | AcDbViewport |
setUcs(const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis) (defined in AcDbViewport) | AcDbViewport |
setUcs(AcDb::OrthographicView view) (defined in AcDbViewport) | AcDbViewport |
setUcs(const AcDbObjectId &ucsId) (defined in AcDbViewport) | AcDbViewport |
setUcsFollowModeOff() (defined in AcDbViewport) | AcDbViewport |
setUcsFollowModeOn() (defined in AcDbViewport) | AcDbViewport |
setUcsIconAtCorner() (defined in AcDbViewport) | AcDbViewport |
setUcsIconAtOrigin() (defined in AcDbViewport) | AcDbViewport |
setUcsIconInvisible() (defined in AcDbViewport) | AcDbViewport |
setUcsIconVisible() (defined in AcDbViewport) | AcDbViewport |
setUcsPerViewport(bool ucsvp) (defined in AcDbViewport) | AcDbViewport |
setUcsToWorld() (defined in AcDbViewport) | AcDbViewport |
setUnlocked() (defined in AcDbViewport) | AcDbViewport |
setViewCenter(const AcGePoint2d &pt) (defined in AcDbViewport) | AcDbViewport |
setViewDirection(const AcGeVector3d &) (defined in AcDbViewport) | AcDbViewport |
setViewDirection(AcDb::OrthographicView view) (defined in AcDbViewport) | AcDbViewport |
setViewHeight(double ht) (defined in AcDbViewport) | AcDbViewport |
setViewTarget(const AcGePoint3d &) (defined in AcDbViewport) | AcDbViewport |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisualStyle(const AcDbObjectId oidVisualStyle) (defined in AcDbViewport) | AcDbViewport |
setWidth(double) (defined in AcDbViewport) | AcDbViewport |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
shadePlot() const (defined in AcDbViewport) | AcDbViewport |
shadePlotId() const (defined in AcDbViewport) | AcDbViewport |
ShadePlotType enum name (defined in AcDbViewport) | AcDbViewport |
showHiddenLines() (defined in AcDbViewport) | AcDbViewport |
snapAngle() const (defined in AcDbViewport) | AcDbViewport |
snapBasePoint() const (defined in AcDbViewport) | AcDbViewport |
snapIncrement() const (defined in AcDbViewport) | AcDbViewport |
snapIsoPair() const (defined in AcDbViewport) | AcDbViewport |
standardScale() const (defined in AcDbViewport) | AcDbViewport |
StandardScaleType enum name (defined in AcDbViewport) | AcDbViewport |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *pDbObj, const AcDbObject *pSubObj) (defined in AcDbViewport) | AcDbViewport | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
sunId() const (defined in AcDbViewport) | AcDbViewport |
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
syncModelView(void) (defined in AcDbViewport) | AcDbViewport |
thawAllLayersInViewport() (defined in AcDbViewport) | AcDbViewport |
thawLayersInViewport(const AcDbObjectIdArray &) (defined in AcDbViewport) | AcDbViewport |
toneOperatorParameters(AcGiToneOperatorParameters &params) const (defined in AcDbViewport) | AcDbViewport |
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
twistAngle() const (defined in AcDbViewport) | AcDbViewport |
ucsName() const (defined in AcDbViewport) | AcDbViewport |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
updateDisplay() const (defined in AcDbViewport) | AcDbViewport |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewCenter() const (defined in AcDbViewport) | AcDbViewport |
viewDirection() const (defined in AcDbViewport) | AcDbViewport |
viewHeight() const (defined in AcDbViewport) | AcDbViewport |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
viewTarget() const (defined in AcDbViewport) | AcDbViewport |
visibility() const (defined in AcDbEntity) | AcDbEntity |
visualStyle() const (defined in AcDbViewport) | AcDbViewport |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
width() const (defined in AcDbViewport) | AcDbViewport |
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbViewport) | AcDbViewport | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbViewport() (defined in AcDbViewport) | AcDbViewport |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbViewportTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbViewportTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbViewportTable:

Public Types

typedef AcDbViewportTableRecord RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbViewportTable)
Acad::ErrorStatus | add (AcDbViewportTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbViewportTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbViewportTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbViewportTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbAbstractViewTable
ACDB_DECLARE_MEMBERS (AcDbAbstractViewTable)
Acad::ErrorStatus | add (AcDbAbstractViewTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbAbstractViewTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbAbstractViewTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbAbstractViewTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbViewportTable Member List

This is the complete list of members for AcDbViewportTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbViewportTable) (defined in AcDbViewportTable) | AcDbViewportTable |
ACDB_DECLARE_MEMBERS(AcDbAbstractViewTable) (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbAbstractViewTable() (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
AcDbViewportTable() (defined in AcDbViewportTable) | AcDbViewportTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbViewportTableRecord *pRecord) (defined in AcDbViewportTable) | AcDbViewportTable |
add(AcDbObjectId &recordId, AcDbViewportTableRecord *pRecord) (defined in AcDbViewportTable) | AcDbViewportTable |
add(AcDbAbstractViewTableRecord *pRecord) (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
add(AcDbObjectId &recordId, AcDbAbstractViewTableRecord *pRecord) (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbViewportTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbViewportTable) | AcDbViewportTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRecord=false) const (defined in AcDbViewportTable) | AcDbViewportTable |
getAt(const ACHAR *entryName, AcDbAbstractViewTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbViewportTable) | AcDbViewportTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbViewportTable) | AcDbViewportTable |
has(AcDbObjectId id) const (defined in AcDbViewportTable) | AcDbViewportTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbViewportTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbViewportTable) | AcDbViewportTable |
newIterator(AcDbAbstractViewTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbViewportTable) | AcDbViewportTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbAbstractViewTable() (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcDbViewportTable() (defined in AcDbViewportTable) | AcDbViewportTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbViewportTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbViewportTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbViewportTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbViewportTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbViewportTableRecord *pRecord)
- Public Member Functions inherited from AcDbAbstractViewTableIterator
Acad::ErrorStatus | getRecord (AcDbAbstractViewTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (const AcDbAbstractViewTableRecord *pRecord)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbViewportTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbViewportTableIterator Member List

This is the complete list of members for AcDbViewportTableIterator, including all inherited members.

AcDbAbstractViewTableIterator() (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator | protected
AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbViewportTable (defined in AcDbViewportTableIterator) | AcDbViewportTableIterator | friend
AcDbViewportTableIterator() (defined in AcDbViewportTableIterator) | AcDbViewportTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbViewportTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbViewportTableIterator) | AcDbViewportTableIterator |
getRecord(AcDbAbstractViewTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbViewportTableIterator) | AcDbViewportTableIterator |
seek(const AcDbViewportTableRecord *pRecord) (defined in AcDbViewportTableIterator) | AcDbViewportTableIterator |
seek(const AcDbAbstractViewTableRecord *pRecord) (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbViewportTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbViewportTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbViewportTableRecord:

Public Types

typedef AcDbViewportTable | TableType
- Public Types inherited from AcDbAbstractViewTableRecord
enum RenderMode {
k2DOptimized, kWireframe, kHiddenLine, kFlatShaded,
kGouraudShaded, kFlatShadedWithWireframe, kGouraudShadedWithWireframe
}
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable | TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbViewportTableRecord)
Adesk::UInt16 | circleSides () const
AcGiDrawable * | drawable ()
bool | fastZoomsEnabled () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | gridEnabled () const
AcGePoint2d | gridIncrements () const
Adesk::Int16 | gridMajor () const
AcGsNode * | gsNode () const
AcGsView * | gsView () const
bool | iconAtOrigin () const
bool | iconEnabled () const
bool | isGridAdaptive () const
bool | isGridBoundToLimits () const
bool | isGridFollow () const
bool | isGridSubdivisionRestricted () const
bool | isometricSnapEnabled () const
bool | isUcsSavedWithViewport () const
AcGePoint2d | lowerLeftCorner () const
Adesk::Int16 | number () const
AcDbObjectId | previousBackground (AcGiDrawable::DrawableType type=AcGiDrawable::kGeometry) const
Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBackground (const AcDbObjectId &backgroundId)
void | setCircleSides (Adesk::UInt16 circleSides)
void | setFastZoomsEnabled (bool enabled)
void | setGridAdaptive (bool enabled)
void | setGridBoundToLimits (bool enabled)
void | setGridEnabled (bool enabled)
void | setGridFollow (bool enabled)
void | setGridIncrements (const AcGePoint2d &base)
void | setGridMajor (Adesk::Int16 value)
void | setGridSubdivisionRestricted (bool enabled)
void | setGsNode (AcGsNode *pNode)
void | setGsView (AcGsView *pView)
void | setIconAtOrigin (bool atOrigin)
void | setIconEnabled (bool enabled)
void | setIsometricSnapEnabled (bool enabled)
void | setLowerLeftCorner (const AcGePoint2d &pt)
Acad::ErrorStatus | setPreviousBackground (AcDbObjectId backgroundId, AcGiDrawable::DrawableType type=AcGiDrawable::kGeometry)
void | setSnapAngle (double angle)
void | setSnapBase (const AcGePoint2d &base)
void | setSnapEnabled (bool enabled)
void | setSnapIncrements (const AcGePoint2d &base)
void | setSnapPair (Adesk::Int16 pairType)
void | setUcsFollowMode (bool enabled)
void | setUcsPerViewport (bool ucsvp)
void | setUpperRightCorner (const AcGePoint2d &pt)
double | snapAngle () const
AcGePoint2d | snapBase () const
bool | snapEnabled () const
AcGePoint2d | snapIncrements () const
Adesk::Int16 | snapPair () const
bool | ucsFollowMode () const
AcGePoint2d | upperRightCorner () const
Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
- Public Member Functions inherited from AcDbAbstractViewTableRecord
ACDB_DECLARE_MEMBERS (AcDbAbstractViewTableRecord)
AcCmColor | ambientLightColor () const
double | backClipDistance () const
bool | backClipEnabled () const
const AcDbObjectId & | background () const
AcDbObjectId & background ()
double | brightness () const
AcGePoint2d | centerPoint () const
double | contrast () const
AcGiViewportTraits::DefaultLightingType | defaultLightingType () const
double | elevation () const
bool | frontClipAtEye () const
double | frontClipDistance () const
bool | frontClipEnabled () const
Acad::ErrorStatus | getUcs (AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis) const
double | height () const
bool | isDefaultLightingOn () const
bool | isUcsOrthographic (AcDb::OrthographicView &view) const
bool | isViewOrthographic (AcDb::OrthographicView &view) const
double | lensLength () const
bool | perspectiveEnabled () const
RenderMode | renderMode () const
Acad::ErrorStatus | setAmbientLightColor (const AcCmColor &clr)
void | setBackClipDistance (double distance)
void | setBackClipEnabled (bool enabled)
Acad::ErrorStatus | setBrightness (double)
void | setCenterPoint (const AcGePoint2d &)
Acad::ErrorStatus | setContrast (double)
Acad::ErrorStatus | setDefaultLightingOn (bool on)
Acad::ErrorStatus | setDefaultLightingType (AcGiViewportTraits::DefaultLightingType typ)
Acad::ErrorStatus | setElevation (double elev)
void | setFrontClipAtEye (bool atEye)
void | setFrontClipDistance (double distance)
void | setFrontClipEnabled (bool enabled)
void | setHeight (double height)
void | setLensLength (double length)
void | setPerspectiveEnabled (bool enabled)
void | setRenderMode (RenderMode mode)
Acad::ErrorStatus | setSun (AcDbObjectId &retId, AcDbObject *pSun)
void | setTarget (const AcGePoint3d &target)
Acad::ErrorStatus | setToneOperatorParameters (const AcGiToneOperatorParameters &params)
Acad::ErrorStatus | setUcs (const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis)
Acad::ErrorStatus | setUcs (AcDb::OrthographicView view)
Acad::ErrorStatus | setUcs (const AcDbObjectId &ucsId)
Acad::ErrorStatus | setUcsToWorld ()
void | setViewDirection (const AcGeVector3d &viewDirection)
Acad::ErrorStatus | setViewDirection (AcDb::OrthographicView view)
void | setViewTwist (double angle)
Acad::ErrorStatus | setVisualStyle (const AcDbObjectId &visualStyleId)
void | setWidth (double width)
AcDbObjectId | sunId () const
AcGePoint3d | target () const
Acad::ErrorStatus | toneOperatorParameters (AcGiToneOperatorParameters &params) const
AcDbObjectId | ucsName () const
AcGeVector3d | viewDirection () const
double | viewTwist () const
AcDbObjectId | visualStyle () const
double | width () const
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

Adesk::Int16 AcDbViewportTableRecord::gridMajor ( ) const
Warning
Not implemented!
bool AcDbViewportTableRecord::isGridAdaptive ( ) const
Warning
Not implemented!
bool AcDbViewportTableRecord::isGridBoundToLimits ( ) const
Warning
Not implemented!
bool AcDbViewportTableRecord::isGridFollow ( ) const
Warning
Not implemented!
bool AcDbViewportTableRecord::isGridSubdivisionRestricted ( ) const
Warning
Not implemented!
Adesk::Int16 AcDbViewportTableRecord::number ( ) const
Warning
Not implemented!
void AcDbViewportTableRecord::setGridAdaptive ( bool enabled )
Warning
Not implemented!
void AcDbViewportTableRecord::setGridBoundToLimits ( bool enabled )
Warning
Not implemented!
void AcDbViewportTableRecord::setGridFollow ( bool enabled )
Warning
Not implemented!
void AcDbViewportTableRecord::setGridMajor ( Adesk::Int16 value )
Warning
Not implemented!
void AcDbViewportTableRecord::setGridSubdivisionRestricted ( bool enabled )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbViewportTableRecord Member List

This is the complete list of members for AcDbViewportTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbViewportTableRecord) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
ACDB_DECLARE_MEMBERS(AcDbAbstractViewTableRecord) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbAbstractViewTableRecord() (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
AcDbViewportTableRecord() (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
ambientLightColor() const | AcDbAbstractViewTableRecord |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
backClipDistance() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
backClipEnabled() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
background() const | AcDbAbstractViewTableRecord |
background() | AcDbAbstractViewTableRecord |
brightness() const | AcDbAbstractViewTableRecord |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
centerPoint() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
circleSides() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const | AcDbAbstractViewTableRecord |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
defaultLightingType() const | AcDbAbstractViewTableRecord |
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
elevation() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fastZoomsEnabled() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord | inline
frontClipAtEye() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
frontClipDistance() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
frontClipEnabled() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getUcs(AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis) const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gridEnabled() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
gridIncrements() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
gridMajor() const | AcDbViewportTableRecord |
gsNode() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord | virtual
gsView() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
iconAtOrigin() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
iconEnabled() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDefaultLightingOn() const | AcDbAbstractViewTableRecord |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isGridAdaptive() const | AcDbViewportTableRecord |
isGridBoundToLimits() const | AcDbViewportTableRecord |
isGridFollow() const | AcDbViewportTableRecord |
isGridSubdivisionRestricted() const | AcDbViewportTableRecord |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isometricSnapEnabled() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUcsOrthographic(AcDb::OrthographicView &view) const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
isUcsSavedWithViewport() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isViewOrthographic(AcDb::OrthographicView &view) const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
k2DOptimized enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kFlatShaded enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kFlatShadedWithWireframe enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGouraudShaded enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kGouraudShadedWithWireframe enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHiddenLine enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kWireframe enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
lensLength() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
lowerLeftCorner() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
number() const | AcDbViewportTableRecord |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
perspectiveEnabled() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
previousBackground(AcGiDrawable::DrawableType type=AcGiDrawable::kGeometry) const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RenderMode enum name (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
renderMode() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAmbientLightColor(const AcCmColor &clr) | AcDbAbstractViewTableRecord |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBackClipDistance(double distance) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setBackClipEnabled(bool enabled) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setBackground(const AcDbObjectId &backgroundId) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBrightness(double) | AcDbAbstractViewTableRecord |
setCenterPoint(const AcGePoint2d &) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setCircleSides(Adesk::UInt16 circleSides) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setContrast(double) | AcDbAbstractViewTableRecord |
setDefaultLightingOn(bool on) | AcDbAbstractViewTableRecord |
setDefaultLightingType(AcGiViewportTraits::DefaultLightingType typ) | AcDbAbstractViewTableRecord |
setElevation(double elev) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setFastZoomsEnabled(bool enabled) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord | inline
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFrontClipAtEye(bool atEye) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setFrontClipDistance(double distance) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setFrontClipEnabled(bool enabled) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setGridAdaptive(bool enabled) | AcDbViewportTableRecord |
setGridBoundToLimits(bool enabled) | AcDbViewportTableRecord |
setGridEnabled(bool enabled) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setGridFollow(bool enabled) | AcDbViewportTableRecord |
setGridIncrements(const AcGePoint2d &base) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setGridMajor(Adesk::Int16 value) | AcDbViewportTableRecord |
setGridSubdivisionRestricted(bool enabled) | AcDbViewportTableRecord |
setGsNode(AcGsNode *pNode) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord | virtual
setGsView(AcGsView *pView) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double height) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setIconAtOrigin(bool atOrigin) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setIconEnabled(bool enabled) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setIsometricSnapEnabled(bool enabled) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setLensLength(double length) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setLowerLeftCorner(const AcGePoint2d &pt) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPerspectiveEnabled(bool enabled) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setPreviousBackground(AcDbObjectId backgroundId, AcGiDrawable::DrawableType type=AcGiDrawable::kGeometry) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setRenderMode(RenderMode mode) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setSnapAngle(double angle) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setSnapBase(const AcGePoint2d &base) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setSnapEnabled(bool enabled) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setSnapIncrements(const AcGePoint2d &base) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setSnapPair(Adesk::Int16 pairType) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setSun(AcDbObjectId &retId, AcDbObject *pSun) | AcDbAbstractViewTableRecord |
setTarget(const AcGePoint3d &target) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setToneOperatorParameters(const AcGiToneOperatorParameters &params) | AcDbAbstractViewTableRecord |
setUcs(const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUcs(AcDb::OrthographicView view) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUcs(const AcDbObjectId &ucsId) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUcsFollowMode(bool enabled) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setUcsPerViewport(bool ucsvp) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setUcsToWorld() (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUpperRightCorner(const AcGePoint2d &pt) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
setViewDirection(const AcGeVector3d &viewDirection) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setViewDirection(AcDb::OrthographicView view) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setViewTwist(double angle) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setVisualStyle(const AcDbObjectId &visualStyleId) | AcDbAbstractViewTableRecord |
setWidth(double width) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
snapAngle() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
snapBase() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
snapEnabled() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
snapIncrements() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
snapPair() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
sunId() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
target() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
toneOperatorParameters(AcGiToneOperatorParameters &params) const | AcDbAbstractViewTableRecord |
ucsFollowMode() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
ucsName() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
upperRightCorner() const (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord |
viewDirection() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
viewTwist() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
visualStyle() const | AcDbAbstractViewTableRecord |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
width() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbAbstractViewTableRecord() (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcDbViewportTableRecord() (defined in AcDbViewportTableRecord) | AcDbViewportTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbViewTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbViewTable Class Reference
AcDb Classes
+ Inheritance diagram for AcDbViewTable:

Public Types

typedef AcDbViewTableRecord RecordType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbViewTable)
Acad::ErrorStatus | add (AcDbViewTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbViewTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbViewTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | has (const ACHAR *name) const
bool | has (AcDbObjectId id) const
Acad::ErrorStatus | newIterator (AcDbViewTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbAbstractViewTable
ACDB_DECLARE_MEMBERS (AcDbAbstractViewTable)
Acad::ErrorStatus | add (AcDbAbstractViewTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbAbstractViewTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbAbstractViewTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbAbstractViewTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbSymbolTable
ACDB_DECLARE_MEMBERS (AcDbSymbolTable)
Acad::ErrorStatus | add (AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | add (AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord)
Acad::ErrorStatus | getAt (const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | newIterator (AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbViewTable Member List

This is the complete list of members for AcDbViewTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbViewTable) (defined in AcDbViewTable) | AcDbViewTable |
ACDB_DECLARE_MEMBERS(AcDbAbstractViewTable) (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
ACDB_DECLARE_MEMBERS(AcDbSymbolTable) (defined in AcDbSymbolTable) | AcDbSymbolTable |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbAbstractViewTable() (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable |
AcDbViewTable() (defined in AcDbViewTable) | AcDbViewTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
add(AcDbViewTableRecord *pRecord) (defined in AcDbViewTable) | AcDbViewTable |
add(AcDbObjectId &recordId, AcDbViewTableRecord *pRecord) (defined in AcDbViewTable) | AcDbViewTable |
add(AcDbAbstractViewTableRecord *pRecord) (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
add(AcDbObjectId &recordId, AcDbAbstractViewTableRecord *pRecord) (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
add(AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
add(AcDbObjectId &recordId, AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTable) | AcDbSymbolTable |
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getAt(const ACHAR *entryName, AcDbViewTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbViewTable) | AcDbViewTable |
getAt(const ACHAR *entryName, AcDbObjectId &recordId, bool getErasedRec=false) const (defined in AcDbViewTable) | AcDbViewTable |
getAt(const ACHAR *entryName, AcDbAbstractViewTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
getAt(const ACHAR *entryName, AcDbSymbolTableRecord *&pRec, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbViewTable) | AcDbViewTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
has(const ACHAR *name) const (defined in AcDbViewTable) | AcDbViewTable |
has(AcDbObjectId id) const (defined in AcDbViewTable) | AcDbViewTable |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
newIterator(AcDbViewTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbViewTable) | AcDbViewTable |
newIterator(AcDbAbstractViewTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable |
newIterator(AcDbSymbolTableIterator *&pIterator, bool atBeginning=true, bool skipDeleted=true) const (defined in AcDbSymbolTable) | AcDbSymbolTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
RecordType typedef (defined in AcDbViewTable) | AcDbViewTable |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbAbstractViewTable() (defined in AcDbAbstractViewTable) | AcDbAbstractViewTable | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTable() (defined in AcDbSymbolTable) | AcDbSymbolTable | virtual
~AcDbViewTable() (defined in AcDbViewTable) | AcDbViewTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbViewTableIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbViewTableIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbViewTableIterator:

Public Member Functions

Acad::ErrorStatus | getRecord (AcDbViewTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (AcDbObjectId id)
Acad::ErrorStatus | seek (const AcDbViewTableRecord *pRecord)
- Public Member Functions inherited from AcDbAbstractViewTableIterator
Acad::ErrorStatus | getRecord (AcDbAbstractViewTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | seek (const AcDbAbstractViewTableRecord *pRecord)
- Public Member Functions inherited from AcDbSymbolTableIterator
bool | done () const
Acad::ErrorStatus | getRecord (AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const
Acad::ErrorStatus | getRecordId (AcDbObjectId &id) const
Acad::ErrorStatus | seek (const AcDbSymbolTableRecord *pRecord)
void | start (bool atBeginning=true, bool skipDeleted=true)
void | step (bool forward=true, bool skipDeleted=true)

Friends

class AcDbViewTable

Additional Inherited Members

- Protected Attributes inherited from AcDbSymbolTableIterator
friend | AcDbSymbolTable
void * | mpImp
The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbViewTableIterator Member List

This is the complete list of members for AcDbViewTableIterator, including all inherited members.

AcDbAbstractViewTableIterator() (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator | protected
AcDbSymbolTable (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
AcDbViewTable (defined in AcDbViewTableIterator) | AcDbViewTableIterator | friend
AcDbViewTableIterator() (defined in AcDbViewTableIterator) | AcDbViewTableIterator | protected
done() const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecord(AcDbViewTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbViewTableIterator) | AcDbViewTableIterator |
getRecord(AcDbAbstractViewTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator |
getRecord(AcDbSymbolTableRecord *&pRecord, AcDb::OpenMode openMode, bool openErasedRec=false) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
getRecordId(AcDbObjectId &id) const (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
mpImp (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | protected
seek(AcDbObjectId id) (defined in AcDbViewTableIterator) | AcDbViewTableIterator |
seek(const AcDbViewTableRecord *pRecord) (defined in AcDbViewTableIterator) | AcDbViewTableIterator |
seek(const AcDbAbstractViewTableRecord *pRecord) (defined in AcDbAbstractViewTableIterator) | AcDbAbstractViewTableIterator |
seek(const AcDbSymbolTableRecord *pRecord) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
start(bool atBeginning=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
step(bool forward=true, bool skipDeleted=true) (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator |
~AcDbSymbolTableIterator() (defined in AcDbSymbolTableIterator) | AcDbSymbolTableIterator | virtual


ZRX API Reference: AcDbViewTableRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDbViewTableRecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbViewTableRecord:

Public Types

typedef AcDbViewTable | TableType
- Public Types inherited from AcDbAbstractViewTableRecord
enum RenderMode {
k2DOptimized, kWireframe, kHiddenLine, kFlatShaded,
kGouraudShaded, kFlatShadedWithWireframe, kGouraudShadedWithWireframe
}
- Public Types inherited from AcDbSymbolTableRecord
typedef AcDbSymbolTable | TableType

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbViewTableRecord)
AcDbAnnotationScale * | annotationScale () const
AcDbObjectId | camera () const
Acad::ErrorStatus | disassociateUcsFromView ()
Acad::ErrorStatus | getCategoryName (ACHAR *&categoryName) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getLayerState (ACHAR *&layerStateName) const
Acad::ErrorStatus | getLayout (AcDbObjectId &layoutId) const
bool | isCameraPlottable () const
bool | isPaperspaceView () const
bool | isUcsAssociatedToView () const
bool | isViewAssociatedToViewport () const
AcDbObjectId | liveSection () const
Acad::ErrorStatus | setAnnotationScale (const AcDbAnnotationScale *pScaleObj)
Acad::ErrorStatus | setCamera (AcDbObjectId cameraId)
Acad::ErrorStatus | setCategoryName (const ACHAR *categoryName)
Acad::ErrorStatus | setIsCameraPlottable (bool plottable)
void | setIsPaperspaceView (bool pspace)
Acad::ErrorStatus | setLayerState (const ACHAR *layerStateName)
Acad::ErrorStatus | setLayout (AcDbObjectId layoutId)
Acad::ErrorStatus | setLiveSection (const AcDbObjectId &liveSectionId)
Acad::ErrorStatus | setParametersFromViewport (AcDbObjectId objId)
Acad::ErrorStatus | setSun (AcDbObjectId &retId, AcDbObject *pSun)
Acad::ErrorStatus | setViewAssociatedToViewport (bool bVPflag)
AcDbObjectId | sunId () const
- Public Member Functions inherited from AcDbAbstractViewTableRecord
ACDB_DECLARE_MEMBERS (AcDbAbstractViewTableRecord)
AcCmColor | ambientLightColor () const
double | backClipDistance () const
bool | backClipEnabled () const
const AcDbObjectId & | background () const
AcDbObjectId & background ()
double | brightness () const
AcGePoint2d | centerPoint () const
double | contrast () const
AcGiViewportTraits::DefaultLightingType | defaultLightingType () const
double | elevation () const
bool | frontClipAtEye () const
double | frontClipDistance () const
bool | frontClipEnabled () const
Acad::ErrorStatus | getUcs (AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis) const
double | height () const
bool | isDefaultLightingOn () const
bool | isUcsOrthographic (AcDb::OrthographicView &view) const
bool | isViewOrthographic (AcDb::OrthographicView &view) const
double | lensLength () const
bool | perspectiveEnabled () const
RenderMode | renderMode () const
Acad::ErrorStatus | setAmbientLightColor (const AcCmColor &clr)
void | setBackClipDistance (double distance)
void | setBackClipEnabled (bool enabled)
Acad::ErrorStatus | setBackground (const AcDbObjectId &backgroundId)
Acad::ErrorStatus | setBrightness (double)
void | setCenterPoint (const AcGePoint2d &)
Acad::ErrorStatus | setContrast (double)
Acad::ErrorStatus | setDefaultLightingOn (bool on)
Acad::ErrorStatus | setDefaultLightingType (AcGiViewportTraits::DefaultLightingType typ)
Acad::ErrorStatus | setElevation (double elev)
void | setFrontClipAtEye (bool atEye)
void | setFrontClipDistance (double distance)
void | setFrontClipEnabled (bool enabled)
void | setHeight (double height)
void | setLensLength (double length)
void | setPerspectiveEnabled (bool enabled)
void | setRenderMode (RenderMode mode)
void | setTarget (const AcGePoint3d &target)
Acad::ErrorStatus | setToneOperatorParameters (const AcGiToneOperatorParameters &params)
Acad::ErrorStatus | setUcs (const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis)
Acad::ErrorStatus | setUcs (AcDb::OrthographicView view)
Acad::ErrorStatus | setUcs (const AcDbObjectId &ucsId)
Acad::ErrorStatus | setUcsToWorld ()
void | setViewDirection (const AcGeVector3d &viewDirection)
Acad::ErrorStatus | setViewDirection (AcDb::OrthographicView view)
void | setViewTwist (double angle)
Acad::ErrorStatus | setVisualStyle (const AcDbObjectId &visualStyleId)
void | setWidth (double width)
AcGePoint3d | target () const
Acad::ErrorStatus | toneOperatorParameters (AcGiToneOperatorParameters &params) const
AcDbObjectId | ucsName () const
AcGeVector3d | viewDirection () const
double | viewTwist () const
AcDbObjectId | visualStyle () const
double | width () const
- Public Member Functions inherited from AcDbSymbolTableRecord
ACDB_DECLARE_MEMBERS (AcDbSymbolTableRecord)
Acad::ErrorStatus | getName (ACHAR *&pName) const
Acad::ErrorStatus | getName (AcString &sName) const
Acad::ErrorStatus | getName (const ACHAR *&pName) const
bool | isDependent () const
bool | isResolved () const
Acad::ErrorStatus | setName (const ACHAR *pName)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

AcDbAnnotationScale* AcDbViewTableRecord::annotationScale ( ) const
Warning
Not implemented!
AcDbObjectId AcDbViewTableRecord::camera ( ) const
Warning
Not implemented!
bool AcDbViewTableRecord::isCameraPlottable ( ) const
Warning
Not implemented!
AcDbObjectId AcDbViewTableRecord::liveSection ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcDbViewTableRecord::setAnnotationScale ( const AcDbAnnotationScale * pScaleObj )
Warning
Not implemented!
Acad::ErrorStatus AcDbViewTableRecord::setCamera ( AcDbObjectId cameraId )
Warning
Not implemented!
Acad::ErrorStatus AcDbViewTableRecord::setIsCameraPlottable ( bool plottable )
Warning
Not implemented!
Acad::ErrorStatus AcDbViewTableRecord::setLiveSection ( const AcDbObjectId & liveSectionId )
Warning
Not implemented!
Acad::ErrorStatus AcDbViewTableRecord::setSun | ( | AcDbObjectId & | retId,
 |  | AcDbObject * | pSun
 | ) |  |
Warning
Not implemented!

Reimplemented from AcDbAbstractViewTableRecord.

AcDbObjectId AcDbViewTableRecord::sunId ( ) const
Warning
Not implemented!

Reimplemented from AcDbAbstractViewTableRecord.

The documentation for this class was generated from the following file:
  • dbsymtb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbViewTableRecord Member List

This is the complete list of members for AcDbViewTableRecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbViewTableRecord) (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
ACDB_DECLARE_MEMBERS(AcDbAbstractViewTableRecord) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
ACDB_DECLARE_MEMBERS(AcDbSymbolTableRecord) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbAbstractViewTableRecord() (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
AcDbViewTableRecord() (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
ambientLightColor() const | AcDbAbstractViewTableRecord |
annotationScale() const | AcDbViewTableRecord |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
backClipDistance() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
backClipEnabled() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
background() const | AcDbAbstractViewTableRecord |
background() | AcDbAbstractViewTableRecord |
brightness() const | AcDbAbstractViewTableRecord |
camera() const | AcDbViewTableRecord |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
centerPoint() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const | AcDbAbstractViewTableRecord |
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
defaultLightingType() const | AcDbAbstractViewTableRecord |
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
disassociateUcsFromView() (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbObject) | AcDbObject | virtual
elevation() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
frontClipAtEye() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
frontClipDistance() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
frontClipEnabled() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getCategoryName(ACHAR *&categoryName) const (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
getClassID(CLSID *pClsid) const (defined in AcDbViewTableRecord) | AcDbViewTableRecord | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getLayerState(ACHAR *&layerStateName) const (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
getLayout(AcDbObjectId &layoutId) const (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
getName(ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(AcString &sName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getName(const ACHAR *&pName) const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getUcs(AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis) const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
height() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCameraPlottable() const | AcDbViewTableRecord |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isDefaultLightingOn() const | AcDbAbstractViewTableRecord |
isDependent() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPaperspaceView() const (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isResolved() const (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUcsAssociatedToView() const (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
isUcsOrthographic(AcDb::OrthographicView &view) const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isViewAssociatedToViewport() const (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
isViewOrthographic(AcDb::OrthographicView &view) const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
k2DOptimized enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kFlatShaded enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kFlatShadedWithWireframe enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGouraudShaded enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kGouraudShadedWithWireframe enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kHiddenLine enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kWireframe enum value (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
lensLength() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
liveSection() const | AcDbViewTableRecord |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
perspectiveEnabled() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RenderMode enum name (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
renderMode() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAmbientLightColor(const AcCmColor &clr) | AcDbAbstractViewTableRecord |
setAnnotationScale(const AcDbAnnotationScale *pScaleObj) | AcDbViewTableRecord |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBackClipDistance(double distance) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setBackClipEnabled(bool enabled) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setBackground(const AcDbObjectId &backgroundId) | AcDbAbstractViewTableRecord |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBrightness(double) | AcDbAbstractViewTableRecord |
setCamera(AcDbObjectId cameraId) | AcDbViewTableRecord |
setCategoryName(const ACHAR *categoryName) (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
setCenterPoint(const AcGePoint2d &) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setContrast(double) | AcDbAbstractViewTableRecord |
setDefaultLightingOn(bool on) | AcDbAbstractViewTableRecord |
setDefaultLightingType(AcGiViewportTraits::DefaultLightingType typ) | AcDbAbstractViewTableRecord |
setElevation(double elev) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFrontClipAtEye(bool atEye) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setFrontClipDistance(double distance) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setFrontClipEnabled(bool enabled) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setHeight(double height) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setIsCameraPlottable(bool plottable) | AcDbViewTableRecord |
setIsPaperspaceView(bool pspace) (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
setLayerState(const ACHAR *layerStateName) (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
setLayout(AcDbObjectId layoutId) (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
setLensLength(double length) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setLiveSection(const AcDbObjectId &liveSectionId) | AcDbViewTableRecord |
setName(const ACHAR *pName) (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setParametersFromViewport(AcDbObjectId objId) (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
setPerspectiveEnabled(bool enabled) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setRenderMode(RenderMode mode) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setSun(AcDbObjectId &retId, AcDbObject *pSun) | AcDbViewTableRecord |
setTarget(const AcGePoint3d &target) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setToneOperatorParameters(const AcGiToneOperatorParameters &params) | AcDbAbstractViewTableRecord |
setUcs(const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUcs(AcDb::OrthographicView view) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUcs(const AcDbObjectId &ucsId) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setUcsToWorld() (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setViewAssociatedToViewport(bool bVPflag) (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
setViewDirection(const AcGeVector3d &viewDirection) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setViewDirection(AcDb::OrthographicView view) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setViewTwist(double angle) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setVisualStyle(const AcDbObjectId &visualStyleId) | AcDbAbstractViewTableRecord |
setWidth(double width) (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
sunId() const | AcDbViewTableRecord |
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
TableType typedef (defined in AcDbViewTableRecord) | AcDbViewTableRecord |
target() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
toneOperatorParameters(AcGiToneOperatorParameters &params) const | AcDbAbstractViewTableRecord |
ucsName() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewDirection() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
viewTwist() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
visualStyle() const | AcDbAbstractViewTableRecord |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
width() const (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord |
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbAbstractViewTableRecord() (defined in AcDbAbstractViewTableRecord) | AcDbAbstractViewTableRecord | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSymbolTableRecord() (defined in AcDbSymbolTableRecord) | AcDbSymbolTableRecord | virtual
~AcDbViewTableRecord() (defined in AcDbViewTableRecord) | AcDbViewTableRecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbVisualStyle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbVisualStyle Class Reference
AcDb Classes
+ Inheritance diagram for AcDbVisualStyle:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbVisualStyle)
virtual Acad::ErrorStatus | copyFrom (const AcGiVisualStyle *pSrc)
virtual Acad::ErrorStatus | copyTo (AcGiVisualStyle *pDest) const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
const ACHAR * | description (void) const
ADESK_DEPRECATED const
AcGiDisplayStyle & 		displayStyle () const
virtual AcGiDrawable * | drawable (void)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
ADESK_DEPRECATED const
AcGiEdgeStyle & 		edgeStyle () const
ADESK_DEPRECATED const
AcGiFaceStyle & 		faceStyle () const
virtual AcGsNode * | gsNode (void) const
virtual bool | isInternalUseOnly () const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setDescription (const ACHAR *pDescription)
ADESK_DEPRECATED Acad::ErrorStatus | setDisplayStyle (const AcGiDisplayStyle &displayStyle)
ADESK_DEPRECATED void | setEdgeStyle (const AcGiEdgeStyle &edgeStyle)
ADESK_DEPRECATED void | setFaceStyle (const AcGiFaceStyle &faceStyle)
virtual void | setGsNode (AcGsNode *pNode)
virtual void | setInternalUseOnly (bool bInternalUseOnly)
Acad::ErrorStatus | setTrait (AcGiVisualStyleProperties::Property prop, const AcGiVariant *pVal, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet)
Acad::ErrorStatus | setTrait (AcGiVisualStyleProperties::Property prop, int nVal, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet)
Acad::ErrorStatus | setTrait (AcGiVisualStyleProperties::Property prop, bool bVal, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet)
Acad::ErrorStatus | setTrait (AcGiVisualStyleProperties::Property prop, double dVal, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet)
Acad::ErrorStatus | setTrait (AcGiVisualStyleProperties::Property prop, double red, double green, double blue, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet)
Acad::ErrorStatus | setTrait (AcGiVisualStyleProperties::Property prop, const AcCmColor *pColor, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet)
Acad::ErrorStatus | setTraitFlag (AcGiVisualStyleProperties::Property flagProp, unsigned long flagVal, bool bEnable=true)
Acad::ErrorStatus | setType (AcGiVisualStyle::Type type)
const AcGiVariant & | trait (AcGiVisualStyleProperties::Property prop, AcGiVisualStyleOperations::Operation *pOp=NULL) const
bool | traitFlag (AcGiVisualStyleProperties::Property flagProp, unsigned long flagVal) const
AcGiVisualStyle::Type | type () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbvisualstyle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbVisualStyle Member List

This is the complete list of members for AcDbVisualStyle, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbVisualStyle) (defined in AcDbVisualStyle) | AcDbVisualStyle |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbVisualStyle() (defined in AcDbVisualStyle) | AcDbVisualStyle |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcGiVisualStyle *pSrc) (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
copyTo(AcGiVisualStyle *pDest) const (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
description(void) const (defined in AcDbVisualStyle) | AcDbVisualStyle |
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
displayStyle() const (defined in AcDbVisualStyle) | AcDbVisualStyle |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable(void) (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
edgeStyle() const (defined in AcDbVisualStyle) | AcDbVisualStyle |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
faceStyle() const (defined in AcDbVisualStyle) | AcDbVisualStyle |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbObject) | AcDbObject | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode(void) const (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isInternalUseOnly() const (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setDescription(const ACHAR *pDescription) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setDisplayStyle(const AcGiDisplayStyle &displayStyle) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setEdgeStyle(const AcGiEdgeStyle &edgeStyle) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setFaceStyle(const AcGiFaceStyle &faceStyle) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setInternalUseOnly(bool bInternalUseOnly) (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setTrait(AcGiVisualStyleProperties::Property prop, const AcGiVariant *pVal, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setTrait(AcGiVisualStyleProperties::Property prop, int nVal, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setTrait(AcGiVisualStyleProperties::Property prop, bool bVal, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setTrait(AcGiVisualStyleProperties::Property prop, double dVal, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setTrait(AcGiVisualStyleProperties::Property prop, double red, double green, double blue, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setTrait(AcGiVisualStyleProperties::Property prop, const AcCmColor *pColor, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setTraitFlag(AcGiVisualStyleProperties::Property flagProp, unsigned long flagVal, bool bEnable=true) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setType(AcGiVisualStyle::Type type) (defined in AcDbVisualStyle) | AcDbVisualStyle |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
trait(AcGiVisualStyleProperties::Property prop, AcGiVisualStyleOperations::Operation *pOp=NULL) const (defined in AcDbVisualStyle) | AcDbVisualStyle |
traitFlag(AcGiVisualStyleProperties::Property flagProp, unsigned long flagVal) const (defined in AcDbVisualStyle) | AcDbVisualStyle |
type() const (defined in AcDbVisualStyle) | AcDbVisualStyle |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbVisualStyle() (defined in AcDbVisualStyle) | AcDbVisualStyle | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbWblockCloneFiler Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbWblockCloneFiler Class Reference
AcDb Classes
+ Inheritance diagram for AcDbWblockCloneFiler:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbWblockCloneFiler)
virtual Acad::ErrorStatus | addReferences (AcDbIdRefQueue &)
virtual AcDb::FilerType | filerType () const
virtual bool | getNextHardObject (AcDbObjectId &id)
virtual bool | moreHardObjects () const
virtual bool | usesReferences () const
- Public Member Functions inherited from AcDbDeepCloneFiler
ACRX_DECLARE_MEMBERS (AcDbDeepCloneFiler)
virtual AcDbFilerController & | controller () const
virtual Acad::ErrorStatus | filerStatus () const
virtual bool | getNextOwnedObject (AcDbObjectId &id)
virtual bool | moreOwnedObjects () const
virtual Acad::ErrorStatus | readAcDbHandle (AcDbHandle *)
virtual Acad::ErrorStatus | readAddress (void **)
virtual Acad::ErrorStatus | readBChunk (ads_binary *)
virtual Acad::ErrorStatus | readBool (bool *)
virtual Acad::ErrorStatus | readBoolean (Adesk::Boolean *)
virtual Acad::ErrorStatus | readBytes (void *, Adesk::UInt32)
virtual Acad::ErrorStatus | readDouble (double *)
virtual Acad::ErrorStatus | readHardOwnershipId (AcDbHardOwnershipId *)
virtual Acad::ErrorStatus | readHardPointerId (AcDbHardPointerId *)
virtual Acad::ErrorStatus | readInt16 (Adesk::Int16 *)
virtual Acad::ErrorStatus | readInt32 (Adesk::Int32 *)
virtual Acad::ErrorStatus | readInt64 (Adesk::Int64 *)
virtual Acad::ErrorStatus | readInt8 (Adesk::Int8 *)
virtual Acad::ErrorStatus | readPoint2d (AcGePoint2d *)
virtual Acad::ErrorStatus | readPoint3d (AcGePoint3d *)
virtual Acad::ErrorStatus | readScale3d (AcGeScale3d *)
virtual Acad::ErrorStatus | readSoftOwnershipId (AcDbSoftOwnershipId *)
virtual Acad::ErrorStatus | readSoftPointerId (AcDbSoftPointerId *)
virtual Acad::ErrorStatus | readString (ACHAR **)
virtual Acad::ErrorStatus | readString (AcString &)
virtual Acad::ErrorStatus | readUInt16 (Adesk::UInt16 *)
virtual Acad::ErrorStatus | readUInt32 (Adesk::UInt32 *)
virtual Acad::ErrorStatus | readUInt64 (Adesk::UInt64 *)
virtual Acad::ErrorStatus | readUInt8 (Adesk::UInt8 *)
virtual Acad::ErrorStatus | readVector2d (AcGeVector2d *)
virtual Acad::ErrorStatus | readVector3d (AcGeVector3d *)
virtual void | resetFilerStatus ()
virtual Acad::ErrorStatus | seek (long offset, int method)
virtual void | setFilerStatus (Acad::ErrorStatus)
virtual long | tell () const
virtual Acad::ErrorStatus | writeAcDbHandle (const AcDbHandle &)
virtual Acad::ErrorStatus | writeAddress (const void *)
virtual Acad::ErrorStatus | writeBChunk (const ads_binary &)
virtual Acad::ErrorStatus | writeBool (bool)
virtual Acad::ErrorStatus | writeBoolean (Adesk::Boolean)
virtual Acad::ErrorStatus | writeBytes (const void *, Adesk::UInt32)
virtual Acad::ErrorStatus | writeDouble (double)
virtual Acad::ErrorStatus | writeHardOwnershipId (const AcDbHardOwnershipId &)
virtual Acad::ErrorStatus | writeHardPointerId (const AcDbHardPointerId &)
virtual Acad::ErrorStatus | writeInt16 (Adesk::Int16)
virtual Acad::ErrorStatus | writeInt32 (Adesk::Int32)
virtual Acad::ErrorStatus | writeInt64 (Adesk::Int64)
virtual Acad::ErrorStatus | writeInt8 (Adesk::Int8)
virtual Acad::ErrorStatus | writePoint2d (const AcGePoint2d &)
virtual Acad::ErrorStatus | writePoint3d (const AcGePoint3d &)
virtual Acad::ErrorStatus | writeScale3d (const AcGeScale3d &)
virtual Acad::ErrorStatus | writeSoftOwnershipId (const AcDbSoftOwnershipId &)
virtual Acad::ErrorStatus | writeSoftPointerId (const AcDbSoftPointerId &)
virtual Acad::ErrorStatus | writeString (const ACHAR *)
virtual Acad::ErrorStatus | writeString (const AcString &)
virtual Acad::ErrorStatus | writeUInt16 (Adesk::UInt16)
virtual Acad::ErrorStatus | writeUInt32 (Adesk::UInt32)
virtual Acad::ErrorStatus | writeUInt64 (Adesk::UInt64)
virtual Acad::ErrorStatus | writeUInt8 (Adesk::UInt8)
virtual Acad::ErrorStatus | writeVector2d (const AcGeVector2d &)
virtual Acad::ErrorStatus | writeVector3d (const AcGeVector3d &)
- Public Member Functions inherited from AcDbDwgFiler
ACRX_DECLARE_MEMBERS (AcDbDwgFiler)
virtual Acad::ErrorStatus | dwgVersion (AcDb::AcDbDwgVersion &, AcDb::MaintenanceReleaseVersion &) const
virtual AcDbAuditInfo * | getAuditInfo () const
Acad::ErrorStatus | readChar (Adesk::Int8 *p)
Acad::ErrorStatus | readItem (AcDbHardOwnershipId *)
Acad::ErrorStatus | readItem (AcDbSoftOwnershipId *)
Acad::ErrorStatus | readItem (AcDbHardPointerId *)
Acad::ErrorStatus | readItem (AcDbSoftPointerId *)
Acad::ErrorStatus | readItem (ACHAR **)
Acad::ErrorStatus | readItem (ads_binary *)
Acad::ErrorStatus | readItem (AcDbHandle *)
Acad::ErrorStatus | readItem (Adesk::Int32 *)
Acad::ErrorStatus | readItem (Adesk::Int16 *)
Acad::ErrorStatus | readItem (Adesk::Int8 *)
Acad::ErrorStatus | readItem (Adesk::UInt32 *)
Acad::ErrorStatus | readItem (Adesk::UInt16 *)
Acad::ErrorStatus | readItem (Adesk::UInt8 *)
Acad::ErrorStatus | readItem (Adesk::Boolean *)
Acad::ErrorStatus | readItem (bool *)
Acad::ErrorStatus | readItem (double *)
Acad::ErrorStatus | readItem (AcGePoint2d *)
Acad::ErrorStatus | readItem (AcGePoint3d *)
Acad::ErrorStatus | readItem (AcGeVector2d *)
Acad::ErrorStatus | readItem (AcGeVector3d *)
Acad::ErrorStatus | readItem (AcGeScale3d *)
Acad::ErrorStatus | readItem (void *, Adesk::UInt32)
Acad::ErrorStatus | readItem (void **)
Acad::ErrorStatus | writeChar (Adesk::Int8 c)
Acad::ErrorStatus | writeItem (const AcDbHardOwnershipId &)
Acad::ErrorStatus | writeItem (const AcDbSoftOwnershipId &)
Acad::ErrorStatus | writeItem (const AcDbHardPointerId &)
Acad::ErrorStatus | writeItem (const AcDbSoftPointerId &)
Acad::ErrorStatus | writeItem (const ACHAR *)
Acad::ErrorStatus | writeItem (const ads_binary &)
Acad::ErrorStatus | writeItem (const AcDbHandle &)
Acad::ErrorStatus | writeItem (Adesk::Int32)
Acad::ErrorStatus | writeItem (Adesk::Int16)
Acad::ErrorStatus | writeItem (Adesk::Int8)
Acad::ErrorStatus | writeItem (Adesk::UInt32)
Acad::ErrorStatus | writeItem (Adesk::UInt16)
Acad::ErrorStatus | writeItem (Adesk::UInt8)
Acad::ErrorStatus | writeItem (Adesk::Boolean)
Acad::ErrorStatus | writeItem (bool)
Acad::ErrorStatus | writeItem (double)
Acad::ErrorStatus | writeItem (const AcGePoint2d &)
Acad::ErrorStatus | writeItem (const AcGePoint3d &)
Acad::ErrorStatus | writeItem (const AcGeVector2d &)
Acad::ErrorStatus | writeItem (const AcGeVector3d &)
Acad::ErrorStatus | writeItem (const AcGeScale3d &)
Acad::ErrorStatus | writeItem (const void *, Adesk::UInt32)
Acad::ErrorStatus | writeItem (const void *)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Member Functions inherited from AcDbDeepCloneFiler
AcDbDeepCloneFiler (AcDbSystemInternals *)
The documentation for this class was generated from the following file:
  • dbcfilrs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbWblockCloneFiler Member List

This is the complete list of members for AcDbWblockCloneFiler, including all inherited members.

AcDbDeepCloneFiler() (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler |
AcDbDeepCloneFiler(AcDbSystemInternals *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | protected
AcDbDwgFiler() (defined in AcDbDwgFiler) | AcDbDwgFiler |
AcDbSystemInternals (defined in AcDbWblockCloneFiler) | AcDbWblockCloneFiler | friend
AcDbWblockCloneFiler() (defined in AcDbWblockCloneFiler) | AcDbWblockCloneFiler |
ACRX_DECLARE_MEMBERS(AcDbWblockCloneFiler) (defined in AcDbWblockCloneFiler) | AcDbWblockCloneFiler |
ACRX_DECLARE_MEMBERS(AcDbDeepCloneFiler) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler |
ACRX_DECLARE_MEMBERS(AcDbDwgFiler) (defined in AcDbDwgFiler) | AcDbDwgFiler |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addReferences(AcDbIdRefQueue &) (defined in AcDbWblockCloneFiler) | AcDbWblockCloneFiler | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
controller() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgVersion(AcDb::AcDbDwgVersion &, AcDb::MaintenanceReleaseVersion &) const (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
filerStatus() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
filerType() const (defined in AcDbWblockCloneFiler) | AcDbWblockCloneFiler | virtual
getAuditInfo() const (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
getNextHardObject(AcDbObjectId &id) (defined in AcDbWblockCloneFiler) | AcDbWblockCloneFiler | virtual
getNextOwnedObject(AcDbObjectId &id) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
moreHardObjects() const (defined in AcDbWblockCloneFiler) | AcDbWblockCloneFiler | virtual
moreOwnedObjects() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readAcDbHandle(AcDbHandle *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readAddress(void **) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readBChunk(ads_binary *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readBool(bool *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readBoolean(Adesk::Boolean *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readBytes(void *, Adesk::UInt32) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readChar(Adesk::Int8 *p) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readDouble(double *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readHardOwnershipId(AcDbHardOwnershipId *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readHardPointerId(AcDbHardPointerId *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readInt16(Adesk::Int16 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readInt32(Adesk::Int32 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readInt64(Adesk::Int64 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readInt8(Adesk::Int8 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readItem(AcDbHardOwnershipId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbSoftOwnershipId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbHardPointerId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbSoftPointerId *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(ACHAR **) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(ads_binary *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcDbHandle *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Int32 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Int16 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Int8 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::UInt32 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::UInt16 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::UInt8 *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(Adesk::Boolean *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(bool *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(double *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGePoint2d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGePoint3d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGeVector2d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGeVector3d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(AcGeScale3d *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(void *, Adesk::UInt32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readItem(void **) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
readPoint2d(AcGePoint2d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readPoint3d(AcGePoint3d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readScale3d(AcGeScale3d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readSoftOwnershipId(AcDbSoftOwnershipId *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readSoftPointerId(AcDbSoftPointerId *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readString(ACHAR **) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readString(AcString &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readUInt16(Adesk::UInt16 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readUInt32(Adesk::UInt32 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readUInt64(Adesk::UInt64 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readUInt8(Adesk::UInt8 *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readVector2d(AcGeVector2d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
readVector3d(AcGeVector3d *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
resetFilerStatus() (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
seek(long offset, int method) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
setFilerStatus(Acad::ErrorStatus) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
tell() const (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
usesReferences() const (defined in AcDbWblockCloneFiler) | AcDbWblockCloneFiler | virtual
writeAcDbHandle(const AcDbHandle &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeAddress(const void *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeBChunk(const ads_binary &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeBool(bool) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeBoolean(Adesk::Boolean) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeBytes(const void *, Adesk::UInt32) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeChar(Adesk::Int8 c) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeDouble(double) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeHardOwnershipId(const AcDbHardOwnershipId &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeHardPointerId(const AcDbHardPointerId &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeInt16(Adesk::Int16) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeInt32(Adesk::Int32) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeInt64(Adesk::Int64) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeInt8(Adesk::Int8) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeItem(const AcDbHardOwnershipId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbSoftOwnershipId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbHardPointerId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbSoftPointerId &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const ACHAR *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const ads_binary &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcDbHandle &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Int32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Int16) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Int8) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::UInt32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::UInt16) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::UInt8) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(Adesk::Boolean) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(bool) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(double) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGePoint2d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGePoint3d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGeVector2d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGeVector3d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const AcGeScale3d &) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const void *, Adesk::UInt32) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writeItem(const void *) (defined in AcDbDwgFiler) | AcDbDwgFiler | inline
writePoint2d(const AcGePoint2d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writePoint3d(const AcGePoint3d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeScale3d(const AcGeScale3d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeSoftOwnershipId(const AcDbSoftOwnershipId &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeSoftPointerId(const AcDbSoftPointerId &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeString(const ACHAR *) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeString(const AcString &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeUInt16(Adesk::UInt16) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeUInt32(Adesk::UInt32) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeUInt64(Adesk::UInt64) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeUInt8(Adesk::UInt8) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeVector2d(const AcGeVector2d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
writeVector3d(const AcGeVector3d &) (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbDeepCloneFiler() (defined in AcDbDeepCloneFiler) | AcDbDeepCloneFiler | virtual
~AcDbDwgFiler() (defined in AcDbDwgFiler) | AcDbDwgFiler | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbWipeout Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
AcDbWipeout Class Reference
AcDb Classes
+ Inheritance diagram for AcDbWipeout:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbWipeout)
Acad::ErrorStatus | append (AcDbObjectId &id)
virtual Adesk::Int8 | brightness () const
virtual AcRxObject * | clone () const
virtual Adesk::Int8 | contrast () const
virtual Adesk::Int8 | fade () const
Adesk::Boolean | frame () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
AcGiSentScanLines * | getScanLines (const AcGiRequestScanLines &req) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&ent) const
virtual AcGeVector2d | imageSize (Adesk::Boolean bGetCachedValue=Adesk::kFalse) const
Adesk::Boolean | isClipped () const
virtual Adesk::Boolean | isSetDisplayOpt (ImageDisplayOpt option) const
virtual void | list () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual AcGeVector2d | scale () const
virtual Acad::ErrorStatus | setBrightness (Adesk::Int8 value)
virtual Acad::ErrorStatus | setContrast (Adesk::Int8 value)
virtual void | setDisplayOpt (ImageDisplayOpt option, Adesk::Boolean bValue)
virtual Acad::ErrorStatus | setFade (Adesk::Int8 value)
Adesk::Boolean | setFrame (Adesk::Boolean bFrame)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual void | viewportDraw (AcGiViewportDraw *mode)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbRasterImage
ACRX_DECLARE_MEMBERS (AcDbRasterImage)
virtual bool | castShadows () const
virtual const AcGePoint2dArray & | clipBoundary () const
virtual ClipBoundaryType | clipBoundaryType () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Adesk::Boolean | freeScanLines (AcGiSentScanLines *pSSL) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual void | getOrientation (AcGePoint3d &origin, AcGeVector3d &u, AcGeVector3d &v) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getPixelToModelTransform (AcGeMatrix3d &) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=0) const
virtual Acad::ErrorStatus | getVertices (AcGePoint3dArray &verts) const
virtual AcDbObjectId | imageDefId () const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual AcGePoint3d | position () const
RasterImageImp * | ptrImp () const
virtual AcDbObjectId | reactorId () const
virtual bool | receiveShadows () const
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setClipBoundary (ClipBoundaryType type, const AcGePoint2dArray &)
virtual Acad::ErrorStatus | setClipBoundaryToWholeImage (AcGeVector2d &size=AcGeVector2d(0, 0))
virtual Acad::ErrorStatus | setImageDefId (AcDbObjectId imageId)
virtual Adesk::Boolean | setOrientation (const AcGePoint3d &origin, const AcGeVector3d &uCorner, const AcGeVector3d &vOnPlane)
RasterImageImp * | setPtrImp (RasterImageImp *pImp)
virtual void | setReactorId (AcDbObjectId reactorId)
virtual void | setReceiveShadows (bool newVal)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=Adesk::kFalse, Adesk::Boolean swapExtDict=Adesk::kFalse)
- Public Member Functions inherited from AcDbImage
ACRX_DECLARE_MEMBERS (AcDbImage)
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
ACHAR * | plotStyleName () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
AcDb::Visibility | visibility () const
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static Acad::ErrorStatus | createImageDefinition ()
static Acad::ErrorStatus | fitPointsToImage (AcGePoint2dArray &pointArray, AcGePoint2d &minPoint, double &scale, Adesk::Boolean bFlipY=Adesk::kFalse)
- Static Public Member Functions inherited from AcDbRasterImage
static ClassVersion | classVersion ()

Static Public Attributes

static long mImageData

Additional Inherited Members

- Public Types inherited from AcDbRasterImage
enum | ClipBoundaryType { kInvalid, kRect, kPoly }
enum | ImageDisplayOpt { kShow = 1, kShowUnAligned = 2, kClip = 4, kTransparent = 8 }
The documentation for this class was generated from the following file:
  • dbwipe.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbWipeout Member List

This is the complete list of members for AcDbWipeout, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbRasterImage() (defined in AcDbRasterImage) | AcDbRasterImage |
AcDbWipeout() (defined in AcDbWipeout) | AcDbWipeout |
ACRX_DECLARE_MEMBERS(AcDbWipeout) (defined in AcDbWipeout) | AcDbWipeout |
ACRX_DECLARE_MEMBERS(AcDbRasterImage) (defined in AcDbRasterImage) | AcDbRasterImage |
ACRX_DECLARE_MEMBERS(AcDbImage) (defined in AcDbImage) | AcDbImage |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
append(AcDbObjectId &id) (defined in AcDbWipeout) | AcDbWipeout |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
brightness() const (defined in AcDbWipeout) | AcDbWipeout | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
classVersion() (defined in AcDbRasterImage) | AcDbRasterImage | inlinestatic
clipBoundary() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
ClipBoundaryType enum name (defined in AcDbRasterImage) | AcDbRasterImage |
clipBoundaryType() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
clone() const (defined in AcDbWipeout) | AcDbWipeout | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const (defined in AcDbWipeout) | AcDbWipeout | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
createImageDefinition() (defined in AcDbWipeout) | AcDbWipeout | static
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
fade() const (defined in AcDbWipeout) | AcDbWipeout | virtual
fitPointsToImage(AcGePoint2dArray &pointArray, AcGePoint2d &minPoint, double &scale, Adesk::Boolean bFlipY=Adesk::kFalse) (defined in AcDbWipeout) | AcDbWipeout | static
frame() const (defined in AcDbWipeout) | AcDbWipeout |
freeScanLines(AcGiSentScanLines *pSSL) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbWipeout) | AcDbWipeout | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getGeomExtents(AcDbExtents &extents) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOrientation(AcGePoint3d &origin, AcGeVector3d &u, AcGeVector3d &v) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getPixelToModelTransform(AcGeMatrix3d &) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getScanLines(const AcGiRequestScanLines &req) const (defined in AcDbWipeout) | AcDbWipeout | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=0) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&ent) const (defined in AcDbWipeout) | AcDbWipeout | virtual
getVertices(AcGePoint3dArray &verts) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
imageDefId() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
ImageDisplayOpt enum name (defined in AcDbRasterImage) | AcDbRasterImage |
imageSize(Adesk::Boolean bGetCachedValue=Adesk::kFalse) const (defined in AcDbWipeout) | AcDbWipeout | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
intersectWith(const AcDbEntity *ent, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClipped() const (defined in AcDbWipeout) | AcDbWipeout |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isSetDisplayOpt(ImageDisplayOpt option) const (defined in AcDbWipeout) | AcDbWipeout | virtual
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kClip enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kInvalid enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kPoly enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kRect enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kShow enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kShowUnAligned enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kTransparent enum value (defined in AcDbRasterImage) | AcDbRasterImage |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbWipeout) | AcDbWipeout | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
mImageData (defined in AcDbWipeout) | AcDbWipeout | static
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbWipeout) | AcDbWipeout | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
position() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
ptrImp() const (defined in AcDbRasterImage) | AcDbRasterImage | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactorId() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
scale() const (defined in AcDbWipeout) | AcDbWipeout | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBrightness(Adesk::Int8 value) (defined in AcDbWipeout) | AcDbWipeout | virtual
setCastShadows(bool newVal) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setClipBoundary(ClipBoundaryType type, const AcGePoint2dArray &) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setClipBoundaryToWholeImage(AcGeVector2d &size=AcGeVector2d(0, 0)) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setContrast(Adesk::Int8 value) (defined in AcDbWipeout) | AcDbWipeout | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setDisplayOpt(ImageDisplayOpt option, Adesk::Boolean bValue) (defined in AcDbWipeout) | AcDbWipeout | virtual
setFade(Adesk::Int8 value) (defined in AcDbWipeout) | AcDbWipeout | virtual
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFrame(Adesk::Boolean bFrame) (defined in AcDbWipeout) | AcDbWipeout |
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setImageDefId(AcDbObjectId imageId) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOrientation(const AcGePoint3d &origin, const AcGeVector3d &uCorner, const AcGeVector3d &vOnPlane) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setPtrImp(RasterImageImp *pImp) (defined in AcDbRasterImage) | AcDbRasterImage | inline
setReactorId(AcDbObjectId reactorId) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setReceiveShadows(bool newVal) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbRasterImage) | AcDbRasterImage | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=Adesk::kFalse, Adesk::Boolean swapExtDict=Adesk::kFalse) (defined in AcDbRasterImage) | AcDbRasterImage | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbWipeout) | AcDbWipeout | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbWipeout) | AcDbWipeout | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbWipeout) | AcDbWipeout | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbRasterImage() (defined in AcDbRasterImage) | AcDbRasterImage | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbXline Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbXline Class Reference
AcDb Classes
+ Inheritance diagram for AcDbXline:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbXline)
AcGePoint3d | basePoint () const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
DBCURVE_METHODS Acad::ErrorStatus | getOffsetCurvesGivenPlaneNormal (const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const
void | setBasePoint (const AcGePoint3d &pt)
void | setUnitDir (const AcGeVector3d &vec)
AcGeVector3d | unitDir () const
- Public Member Functions inherited from AcDbCurve
ACDB_DECLARE_MEMBERS (AcDbCurve)
virtual Acad::ErrorStatus | extend (double newParam)
virtual Acad::ErrorStatus | extend (Adesk::Boolean extendStart, const AcGePoint3d &toPoint)
virtual Acad::ErrorStatus | getArea (double &) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getClosestPointTo (const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const
virtual Acad::ErrorStatus | getDistAtParam (double param, double &dist) const
virtual Acad::ErrorStatus | getDistAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getEndParam (double &) const
virtual Acad::ErrorStatus | getEndPoint (AcGePoint3d &) const
virtual Acad::ErrorStatus | getFirstDeriv (double param, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getFirstDeriv (const AcGePoint3d &, AcGeVector3d &firstDeriv) const
virtual Acad::ErrorStatus | getOffsetCurves (double offsetDist, AcDbVoidPtrArray &offsetCurves) const
virtual Acad::ErrorStatus | getOrthoProjectedCurve (const AcGePlane &, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getParamAtDist (double dist, double &param) const
virtual Acad::ErrorStatus | getParamAtPoint (const AcGePoint3d &, double &) const
virtual Acad::ErrorStatus | getPointAtDist (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getPointAtParam (double, AcGePoint3d &) const
virtual Acad::ErrorStatus | getProjectedCurve (const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const
virtual Acad::ErrorStatus | getSecondDeriv (double param, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSecondDeriv (const AcGePoint3d &, AcGeVector3d &secDeriv) const
virtual Acad::ErrorStatus | getSpline (AcDbSpline *&spline) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getSplitCurves (const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const
virtual Acad::ErrorStatus | getStartParam (double &) const
virtual Acad::ErrorStatus | getStartPoint (AcGePoint3d &) const
virtual Adesk::Boolean | isClosed () const
virtual Adesk::Boolean | isPeriodic () const
- Public Member Functions inherited from AcDbEntity
ACDB_DECLARE_MEMBERS (AcDbEntity)
virtual Acad::ErrorStatus | addSubentPaths (const AcDbFullSubentPathArray &newPaths)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
Acad::ErrorStatus | boundingBoxIntersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const
virtual bool | castShadows () const
virtual Adesk::Boolean | cloneMeForDragging ()
virtual AcDb::CollisionType | collisionType () const
AcCmColor | color () const
Adesk::UInt16 | colorIndex () const
virtual Acad::ErrorStatus | deleteSubentPaths (const AcDbFullSubentPathArray &paths)
virtual void | dragStatus (const AcDb::DragStat status)
Acad::ErrorStatus | draw ()
virtual AcGiDrawable * | drawable ()
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
AcCmEntityColor | entityColor () const
virtual Acad::ErrorStatus | explode (AcDbVoidPtrArray &entitySet) const
virtual Acad::ErrorStatus | getCompoundObjectTransform (AcGeMatrix3d &xMat) const
virtual void | getEcs (AcGeMatrix3d &retVal) const
virtual Acad::ErrorStatus | getGeomExtents (AcDbExtents &extents) const
virtual Acad::ErrorStatus | getGripEntityUCS (const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const
virtual Acad::ErrorStatus | getGripPoints (AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getGripPoints (AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const
virtual Acad::ErrorStatus | getGsMarkersAtSubentPath (const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const
virtual Acad::ErrorStatus | getMaterialMapper (AcGiMapper &mapper) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getOsnapPoints (AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const
virtual Acad::ErrorStatus | getPlane (AcGePlane &, AcDb::Planarity &) const
AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &id) const
virtual Acad::ErrorStatus | getStretchPoints (AcGePoint3dArray &stretchPoints) const
virtual Acad::ErrorStatus | getSubentClassId (const AcDbFullSubentPath &path, CLSID *clsId) const
virtual Acad::ErrorStatus | getSubentPathGeomExtents (const AcDbFullSubentPath &path, AcDbExtents &extents) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const
virtual Acad::ErrorStatus | getTransformedCopy (const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const
virtual void | gripStatus (const AcDb::GripStat status)
virtual AcGsNode * | gsNode () const
virtual bool | hideMeForDragging () const
virtual Acad::ErrorStatus | highlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Acad::ErrorStatus | intersectWith (const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const
virtual Adesk::Boolean | isPlanar () const
ACHAR * | layer () const
AcDbObjectId | layerId () const
ACHAR * | linetype () const
AcDbObjectId | linetypeId () const
double | linetypeScale () const
AcDb::LineWeight | lineWeight () const
virtual void | list () const
ACHAR * | material () const
AcDbObjectId | materialId () const
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
virtual Acad::ErrorStatus | moveGripPointsAt (const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | moveStretchPointsAt (const AcDbIntArray &indices, const AcGeVector3d &offset)
ACHAR * | plotStyleName () const
virtual bool | receiveShadows () const
void | recordGraphicsModified (Adesk::Boolean setModified=true)
virtual void | saveAs (AcGiWorldDraw *mode, AcDb::SaveType st)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
virtual void | setCastShadows (bool newVal)
virtual Acad::ErrorStatus | setColor (const AcCmColor &color, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setColorIndex (Adesk::UInt16 color, Adesk::Boolean doSubents=true)
void | setDatabaseDefaults ()
void | setDatabaseDefaults (AcDbDatabase *pDb)
virtual void | setGsNode (AcGsNode *pNode)
virtual Acad::ErrorStatus | setLayer (const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLayer (AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false)
virtual Acad::ErrorStatus | setLinetype (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetype (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLinetypeScale (double newval, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setLineWeight (AcDb::LineWeight newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (const ACHAR *newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterial (AcDbObjectId newVal, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setMaterialMapper (const AcGiMapper &mapper, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (const ACHAR *newName, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setPlotStyleName (AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true)
Acad::ErrorStatus | setPropertiesFrom (const AcDbEntity *pEntity, Adesk::Boolean doSubents=true)
virtual void | setReceiveShadows (bool newVal)
virtual Acad::ErrorStatus | setTransparency (const AcCmTransparency &trans, Adesk::Boolean doSubents=true)
virtual Acad::ErrorStatus | setVisibility (AcDb::Visibility newVal, Adesk::Boolean doSubents=true)
virtual void | subentGripStatus (const AcDb::GripStat status, const AcDbFullSubentPath &subentity)
virtual AcDbEntity * | subentPtr (const AcDbFullSubentPath &id) const
virtual void | subSetDatabaseDefaults (AcDbDatabase *pDb)
virtual Acad::ErrorStatus | transformBy (const AcGeMatrix3d &xform)
virtual Acad::ErrorStatus | transformBy (const AcGeFastTransform &xform)
virtual Acad::ErrorStatus | transformSubentPathsBy (const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform)
AcCmTransparency | transparency () const
virtual Acad::ErrorStatus | unhighlight (const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const
virtual void | viewportDraw (AcGiViewportDraw *mode)
AcDb::Visibility | visibility () const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *mode)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcDbEntity
enum | VisualStyleType { kFullVisualStyle, kFaceVisualStyle, kEdgeVisualStyle }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbxline.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbXline Member List

This is the complete list of members for AcDbXline, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbXline) (defined in AcDbXline) | AcDbXline |
ACDB_DECLARE_MEMBERS(AcDbCurve) (defined in AcDbCurve) | AcDbCurve |
ACDB_DECLARE_MEMBERS(AcDbEntity) (defined in AcDbEntity) | AcDbEntity |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbCurve() (defined in AcDbCurve) | AcDbCurve | protected
AcDbEntity() (defined in AcDbEntity) | AcDbEntity | protected
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbXline() (defined in AcDbXline) | AcDbXline |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
addSubentPaths(const AcDbFullSubentPathArray &newPaths) (defined in AcDbEntity) | AcDbEntity | virtual
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbEntity) | AcDbEntity | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbEntity) | AcDbEntity | virtual
basePoint() const (defined in AcDbXline) | AcDbXline |
blockId() const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
boundingBoxIntersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker, Adesk::GsMarker otherGsMarker) const (defined in AcDbEntity) | AcDbEntity |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
castShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
clone() const (defined in AcDbObject) | AcDbObject | virtual
cloneMeForDragging() (defined in AcDbEntity) | AcDbEntity | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
collisionType() const (defined in AcDbEntity) | AcDbEntity | virtual
color() const (defined in AcDbEntity) | AcDbEntity |
colorIndex() const (defined in AcDbEntity) | AcDbEntity |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
deleteSubentPaths(const AcDbFullSubentPathArray &paths) (defined in AcDbEntity) | AcDbEntity | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
dragStatus(const AcDb::DragStat status) (defined in AcDbEntity) | AcDbEntity | virtual
draw() (defined in AcDbEntity) | AcDbEntity |
drawable() (defined in AcDbEntity) | AcDbEntity | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbEntity) | AcDbEntity | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbEntity) | AcDbEntity | virtual
entityColor() const (defined in AcDbEntity) | AcDbEntity |
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
explode(AcDbVoidPtrArray &entitySet) const (defined in AcDbEntity) | AcDbEntity | virtual
extend(double newParam) (defined in AcDbCurve) | AcDbCurve | virtual
extend(Adesk::Boolean extendStart, const AcGePoint3d &toPoint) (defined in AcDbCurve) | AcDbCurve | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getArea(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbXline) | AcDbXline | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getClosestPointTo(const AcGePoint3d &givenPnt, const AcGeVector3d &direction, AcGePoint3d &pointOnCurve, Adesk::Boolean extend=Adesk::kFalse) const (defined in AcDbCurve) | AcDbCurve | virtual
getCompoundObjectTransform(AcGeMatrix3d &xMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getDistAtParam(double param, double &dist) const (defined in AcDbCurve) | AcDbCurve | virtual
getDistAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEcs(AcGeMatrix3d &retVal) const (defined in AcDbEntity) | AcDbEntity | virtual
getEndParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getEndPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFirstDeriv(double param, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getFirstDeriv(const AcGePoint3d &, AcGeVector3d &firstDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getGeomExtents(AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripEntityUCS(const void *pGripAppData, AcGeVector3d &normalVec, AcGePoint3d &origin, AcGeVector3d &xAxis) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcGePoint3dArray &gripPoints, AcDbIntArray &osnapModes, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPoints(AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGripPointsAtSubentPath(const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) const (defined in AcDbEntity) | AcDbEntity | virtual
getGsMarkersAtSubentPath(const AcDbFullSubentPath &subPath, AcArray< Adesk::GsMarker > &gsMarkers) const (defined in AcDbEntity) | AcDbEntity | virtual
getMaterialMapper(AcGiMapper &mapper) const (defined in AcDbEntity) | AcDbEntity | virtual
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getOffsetCurves(double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbCurve) | AcDbCurve | virtual
getOffsetCurvesGivenPlaneNormal(const AcGeVector3d &normal, double offsetDist, AcDbVoidPtrArray &offsetCurves) const (defined in AcDbXline) | AcDbXline | virtual
getOrthoProjectedCurve(const AcGePlane &, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeMatrix3d &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getOsnapPoints(AcDb::OsnapMode osnapMode, Adesk::GsMarker gsSelectionMark, const AcGePoint3d &pickPoint, const AcGePoint3d &lastPoint, const AcGeFastTransform &viewXform, AcGePoint3dArray &snapPoints, AcDbIntArray &geomIds, const AcGeMatrix3d &insertionMat) const (defined in AcDbEntity) | AcDbEntity | virtual
getParamAtDist(double dist, double &param) const (defined in AcDbCurve) | AcDbCurve | virtual
getParamAtPoint(const AcGePoint3d &, double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPlane(AcGePlane &, AcDb::Planarity &) const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
getPlotStyleNameId(AcDbObjectId &id) const (defined in AcDbEntity) | AcDbEntity |
getPointAtDist(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getPointAtParam(double, AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getProjectedCurve(const AcGePlane &, const AcGeVector3d &projDir, AcDbCurve *&projCrv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(double param, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSecondDeriv(const AcGePoint3d &, AcGeVector3d &secDeriv) const (defined in AcDbCurve) | AcDbCurve | virtual
getSpline(AcDbSpline *&spline) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGeDoubleArray &params, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getSplitCurves(const AcGePoint3dArray &points, AcDbVoidPtrArray &curveSegments) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartParam(double &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStartPoint(AcGePoint3d &) const (defined in AcDbCurve) | AcDbCurve | virtual
getStretchPoints(AcGePoint3dArray &stretchPoints) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentClassId(const AcDbFullSubentPath &path, CLSID *clsId) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathGeomExtents(const AcDbFullSubentPath &path, AcDbExtents &extents) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getSubentPathsAtGsMarker(AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeFastTransform &viewXform, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts=0, AcDbObjectId *entAndInsertStack=NULL) const (defined in AcDbEntity) | AcDbEntity | virtual
getTransformedCopy(const AcGeMatrix3d &xform, AcDbEntity *&pEnt) const (defined in AcDbEntity) | AcDbEntity | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gripStatus(const AcDb::GripStat status) (defined in AcDbEntity) | AcDbEntity | virtual
gsNode() const (defined in AcDbEntity) | AcDbEntity | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
hideMeForDragging() const (defined in AcDbEntity) | AcDbEntity | virtual
highlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
id() const (defined in AcDbObject) | AcDbObject | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
intersectWith(const AcDbEntity *pEnt, AcDb::Intersect intType, const AcGePlane &projPlane, AcGePoint3dArray &points, Adesk::GsMarker thisGsMarker=0, Adesk::GsMarker otherGsMarker=0) const (defined in AcDbEntity) | AcDbEntity | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isClosed() const (defined in AcDbCurve) | AcDbCurve | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPeriodic() const (defined in AcDbCurve) | AcDbCurve | virtual
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isPlanar() const (defined in AcDbEntity) | AcDbEntity | inlinevirtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kEdgeVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFaceVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kFullVisualStyle enum value (defined in AcDbEntity) | AcDbEntity |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
layer() const (defined in AcDbEntity) | AcDbEntity |
layerId() const (defined in AcDbEntity) | AcDbEntity |
linetype() const (defined in AcDbEntity) | AcDbEntity |
linetypeId() const (defined in AcDbEntity) | AcDbEntity |
linetypeScale() const (defined in AcDbEntity) | AcDbEntity |
lineWeight() const (defined in AcDbEntity) | AcDbEntity |
list() const (defined in AcDbEntity) | AcDbEntity | virtual
material() const (defined in AcDbEntity) | AcDbEntity |
materialId() const (defined in AcDbEntity) | AcDbEntity |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveGripPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAt(const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveGripPointsAtSubentPaths(const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcDbEntity) | AcDbEntity | virtual
moveStretchPointsAt(const AcDbIntArray &indices, const AcGeVector3d &offset) (defined in AcDbEntity) | AcDbEntity | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
plotStyleName() const (defined in AcDbEntity) | AcDbEntity |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
receiveShadows() const (defined in AcDbEntity) | AcDbEntity | virtual
recordGraphicsModified(Adesk::Boolean setModified=true) (defined in AcDbEntity) | AcDbEntity |
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
saveAs(AcGiWorldDraw *mode, AcDb::SaveType st) (defined in AcDbEntity) | AcDbEntity | virtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbEntity) | AcDbEntity | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBasePoint(const AcGePoint3d &pt) (defined in AcDbXline) | AcDbXline |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setCastShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setColor(const AcCmColor &color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setColorIndex(Adesk::UInt16 color, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setDatabaseDefaults() (defined in AcDbEntity) | AcDbEntity |
setDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbEntity) | AcDbEntity | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setLayer(const ACHAR *newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLayer(AcDbObjectId newVal, Adesk::Boolean doSubents=true, bool allowHiddenLayer=false) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetype(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLinetypeScale(double newval, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setLineWeight(AcDb::LineWeight newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(const ACHAR *newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterial(AcDbObjectId newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setMaterialMapper(const AcGiMapper &mapper, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setPlotStyleName(const ACHAR *newName, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPlotStyleName(AcDb::PlotStyleNameType, AcDbObjectId newId=AcDbObjectId::kNull, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setPropertiesFrom(const AcDbEntity *pEntity, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity |
setReceiveShadows(bool newVal) (defined in AcDbEntity) | AcDbEntity | virtual
setTransparency(const AcCmTransparency &trans, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setUnitDir(const AcGeVector3d &vec) (defined in AcDbXline) | AcDbXline |
setVisibility(AcDb::Visibility newVal, Adesk::Boolean doSubents=true) (defined in AcDbEntity) | AcDbEntity | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subentGripStatus(const AcDb::GripStat status, const AcDbFullSubentPath &subentity) (defined in AcDbEntity) | AcDbEntity | virtual
subentPtr(const AcDbFullSubentPath &id) const (defined in AcDbEntity) | AcDbEntity | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSetDatabaseDefaults(AcDbDatabase *pDb) (defined in AcDbEntity) | AcDbEntity | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
transformBy(const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformBy(const AcGeFastTransform &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transformSubentPathsBy(const AcDbFullSubentPathArray &paths, const AcGeMatrix3d &xform) (defined in AcDbEntity) | AcDbEntity | virtual
transparency() const (defined in AcDbEntity) | AcDbEntity |
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
unhighlight(const AcDbFullSubentPath &subId=kNullSubent, const Adesk::Boolean highlightAll=false) const (defined in AcDbEntity) | AcDbEntity | virtual
unitDir() const (defined in AcDbXline) | AcDbXline |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
visibility() const (defined in AcDbEntity) | AcDbEntity |
VisualStyleType enum name (defined in AcDbEntity) | AcDbEntity |
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *mode) (defined in AcDbEntity) | AcDbEntity | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbCurve() (defined in AcDbCurve) | AcDbCurve | virtual
~AcDbEntity() (defined in AcDbEntity) | AcDbEntity | inlinevirtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbXline() (defined in AcDbXline) | AcDbXline |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbXObject Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbXObject Class Reference
AcDb Classes
+ Inheritance diagram for AcDbXObject:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbXObject)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler) const
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbmain.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbXObject Member List

This is the complete list of members for AcDbXObject, including all inherited members.

AcDbXObject() (defined in AcDbXObject) | AcDbXObject | protected
ACRX_DECLARE_MEMBERS(AcDbXObject) (defined in AcDbXObject) | AcDbXObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbXObject) | AcDbXObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbXObject) | AcDbXObject |
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcDbXObject) | AcDbXObject | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbXObject) | AcDbXObject |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcDbXObject) | AcDbXObject | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbXObject) | AcDbXObject |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcDbXObject) | AcDbXObject | virtual
dxfOut(AcDbDxfFiler *pFiler) const (defined in AcDbXObject) | AcDbXObject |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcDbXObject) | AcDbXObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbXrecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbXrecord Class Reference
AcDb Classes
+ Inheritance diagram for AcDbXrecord:

Public Member Functions

ACDB_DECLARE_MEMBERS (AcDbXrecord)
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *filer)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *filer) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *filer) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
bool | isXlateReferences () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
Acad::ErrorStatus | rbChain (resbuf **ppRb, AcDbDatabase *auxDb=NULL) const
Acad::ErrorStatus | setFromRbChain (const resbuf &pRb, AcDbDatabase *auxDb=NULL)
virtual void | setMergeStyle (AcDb::DuplicateRecordCloning style)
void | setXlateReferences (bool translate)
virtual Acad::ErrorStatus | subClose ()
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *undoFiler, AcRxClass *classObj)
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • dbxrecrd.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbXrecord Member List

This is the complete list of members for AcDbXrecord, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbXrecord) (defined in AcDbXrecord) | AcDbXrecord |
ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbXrecord() (defined in AcDbXrecord) | AcDbXrecord |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *undoFiler, AcRxClass *classObj) (defined in AcDbObject) | AcDbObject | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbObject) | AcDbObject | virtual
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *filer) (defined in AcDbXrecord) | AcDbXrecord | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *filer) const (defined in AcDbXrecord) | AcDbXrecord | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *filer) (defined in AcDbXrecord) | AcDbXrecord | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *filer) const (defined in AcDbXrecord) | AcDbXrecord | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbXrecord) | AcDbXrecord | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
isXlateReferences() const (defined in AcDbXrecord) | AcDbXrecord |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbXrecord) | AcDbXrecord | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rbChain(resbuf **ppRb, AcDbDatabase *auxDb=NULL) const (defined in AcDbXrecord) | AcDbXrecord |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setFromRbChain(const resbuf &pRb, AcDbDatabase *auxDb=NULL) (defined in AcDbXrecord) | AcDbXrecord |
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setMergeStyle(AcDb::DuplicateRecordCloning style) (defined in AcDbXrecord) | AcDbXrecord | virtual
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
setXlateReferences(bool translate) (defined in AcDbXrecord) | AcDbXrecord |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbXrecord) | AcDbXrecord | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbXrecord() (defined in AcDbXrecord) | AcDbXrecord | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbXrecordIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbXrecordIterator Class Reference
AcDb Classes
+ Inheritance diagram for AcDbXrecordIterator:

Public Member Functions

AcDbXrecordIterator (const AcDbXrecord *pXrecord)
ACRX_DECLARE_MEMBERS (AcDbXrecordIterator)
int | curRestype () const
bool | done () const
Acad::ErrorStatus | getCurResbuf (resbuf &outItem, AcDbDatabase *db) const
Acad::ErrorStatus | next ()
void | start ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class | AcDbImpXrecord
class | AcDbXrecord

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbxrecrd.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbXrecordIterator Member List

This is the complete list of members for AcDbXrecordIterator, including all inherited members.

AcDbImpXrecord (defined in AcDbXrecordIterator) | AcDbXrecordIterator | friend
AcDbXrecord (defined in AcDbXrecordIterator) | AcDbXrecordIterator | friend
AcDbXrecordIterator(const AcDbXrecord *pXrecord) (defined in AcDbXrecordIterator) | AcDbXrecordIterator |
AcDbXrecordIterator() (defined in AcDbXrecordIterator) | AcDbXrecordIterator | inlineprotected
ACRX_DECLARE_MEMBERS(AcDbXrecordIterator) (defined in AcDbXrecordIterator) | AcDbXrecordIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
curRestype() const (defined in AcDbXrecordIterator) | AcDbXrecordIterator |
desc() (defined in AcRxObject) | AcRxObject | static
done() const (defined in AcDbXrecordIterator) | AcDbXrecordIterator |
getCurResbuf(resbuf &outItem, AcDbDatabase *db) const (defined in AcDbXrecordIterator) | AcDbXrecordIterator |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
next() (defined in AcDbXrecordIterator) | AcDbXrecordIterator |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
start() (defined in AcDbXrecordIterator) | AcDbXrecordIterator |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDbXrecordIterator() (defined in AcDbXrecordIterator) | AcDbXrecordIterator | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbXrefGraph Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbXrefGraph Class Reference
AcDb Classes
+ Inheritance diagram for AcDbXrefGraph:

Public Member Functions

AcDbXrefGraph (AcDbXrefGraphNode *pHostDwg=NULL)
virtual Adesk::Boolean | findCycles (AcDbGraphNode *pStart=NULL)
AcDbXrefGraphNode * | hostDwg () const
Adesk::Boolean | markUnresolvedTrees ()
AcDbXrefGraphNode * | xrefNode (const ACHAR *pName) const
AcDbXrefGraphNode * | xrefNode (AcDbObjectId btrId) const
AcDbXrefGraphNode * | xrefNode (const AcDbDatabase *pDb) const
AcDbXrefGraphNode * | xrefNode (int idx) const
- Public Member Functions inherited from AcDbGraph
AcDbGraph (AcDbGraphNode *pRoot=NULL)
Acad::ErrorStatus | addEdge (AcDbGraphNode *pFrom, AcDbGraphNode *pTo)
Acad::ErrorStatus | addNode (AcDbGraphNode *)
Acad::ErrorStatus | breakCycleEdge (AcDbGraphNode *pFrom, AcDbGraphNode *pTo)
void | clearAll (Adesk::UInt8 flags)
Acad::ErrorStatus | delNode (AcDbGraphNode *)
void | getOutgoing (AcDbVoidPtrArray &)
bool | isEmpty () const
AcDbGraphNode * | node (int index) const
int | numNodes () const
void | reset ()
AcDbGraphNode * | rootNode () const
void | setNodeGrowthRate (int rate)

Additional Inherited Members

- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcDbGraph
Acad::ErrorStatus | clearAllCycles ()
The documentation for this class was generated from the following file:
  • xgraph.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbXrefGraph Member List

This is the complete list of members for AcDbXrefGraph, including all inherited members.

AcDbGraph(AcDbGraphNode *pRoot=NULL) (defined in AcDbGraph) | AcDbGraph |
AcDbXrefGraph(AcDbXrefGraphNode *pHostDwg=NULL) (defined in AcDbXrefGraph) | AcDbXrefGraph |
addEdge(AcDbGraphNode *pFrom, AcDbGraphNode *pTo) (defined in AcDbGraph) | AcDbGraph |
addNode(AcDbGraphNode *) (defined in AcDbGraph) | AcDbGraph |
breakCycleEdge(AcDbGraphNode *pFrom, AcDbGraphNode *pTo) (defined in AcDbGraph) | AcDbGraph |
clearAll(Adesk::UInt8 flags) (defined in AcDbGraph) | AcDbGraph |
clearAllCycles() (defined in AcDbGraph) | AcDbGraph | protected
delNode(AcDbGraphNode *) (defined in AcDbGraph) | AcDbGraph |
findCycles(AcDbGraphNode *pStart=NULL) (defined in AcDbXrefGraph) | AcDbXrefGraph | virtual
getOutgoing(AcDbVoidPtrArray &) (defined in AcDbGraph) | AcDbGraph |
hostDwg() const (defined in AcDbXrefGraph) | AcDbXrefGraph | inline
isEmpty() const (defined in AcDbGraph) | AcDbGraph | inline
markUnresolvedTrees() (defined in AcDbXrefGraph) | AcDbXrefGraph |
node(int index) const (defined in AcDbGraph) | AcDbGraph | inline
numNodes() const (defined in AcDbGraph) | AcDbGraph | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
reset() (defined in AcDbGraph) | AcDbGraph |
rootNode() const (defined in AcDbGraph) | AcDbGraph | inline
setNodeGrowthRate(int rate) (defined in AcDbGraph) | AcDbGraph |
xrefNode(const ACHAR *pName) const (defined in AcDbXrefGraph) | AcDbXrefGraph |
xrefNode(AcDbObjectId btrId) const (defined in AcDbXrefGraph) | AcDbXrefGraph |
xrefNode(const AcDbDatabase *pDb) const (defined in AcDbXrefGraph) | AcDbXrefGraph |
xrefNode(int idx) const (defined in AcDbXrefGraph) | AcDbXrefGraph | inline
~AcDbGraph() (defined in AcDbGraph) | AcDbGraph | virtual
~AcDbXrefGraph() (defined in AcDbXrefGraph) | AcDbXrefGraph | virtual


ZRX API Reference: AcDbXrefGraphNode Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbXrefGraphNode Class Reference
AcDb Classes
+ Inheritance diagram for AcDbXrefGraphNode:

Public Member Functions

AcDbXrefGraphNode (const ACHAR *pName=NULL, const AcDbObjectId &btrId=AcDbObjectId::kNull, AcDbDatabase *pDb=NULL, AcDb::XrefStatus status=AcDb::kXrfResolved)
AcDbObjectId | btrId () const
AcDbDatabase * | database () const
bool | isNested () const
const ACHAR * | name () const
void | setBtrId (const AcDbObjectId &id)
void | setDatabase (AcDbDatabase *pDb)
Acad::ErrorStatus | setName (const ACHAR *pName)
void | setxData (void *pXData)
void | setXrefNotificationStatus (AcDb::XrefNotificationStatus stat)
void | setXrefStatus (AcDb::XrefStatus stat)
void * | xData ()
AcDb::XrefNotificationStatus | xrefNotificationStatus () const
Acad::ErrorStatus | xrefReadSubstatus () const
AcDb::XrefStatus | xrefStatus () const
- Public Member Functions inherited from AcDbGraphNode
AcDbGraphNode (void *pData=NULL)
Acad::ErrorStatus | addRefTo (AcDbGraphNode *)
Acad::ErrorStatus | clear (Adesk::UInt8 flags)
AcDbGraphNode * | cycleIn (int) const
AcDbGraphNode * | cycleOut (int) const
void * | data () const
Acad::ErrorStatus | disconnectAll ()
AcDbGraphNode * | in (int) const
bool | isCycleNode () const
bool | isMarkedAs (Adesk::UInt8 flags) const
Acad::ErrorStatus | markAs (Adesk::UInt8 flags)
Acad::ErrorStatus | markTree (Adesk::UInt8 flags, AcDbVoidPtrArray *=NULL)
AcDbGraphNode * | nextCycleNode () const
int | numCycleIn () const
int | numCycleOut () const
int | numIn () const
int | numOut () const
AcDbGraphNode * | out (int) const
AcDbGraph * | owner () const
Acad::ErrorStatus | removeRefTo (AcDbGraphNode *)
void | setData (void *)
void | setEdgeGrowthRate (int outEdgeRate, int inEdgeRate)

Additional Inherited Members

- Public Types inherited from AcDbGraphNode
enum Flags {
kNone = 0x00, kVisited = 0x01, kOutsideRefed = 0x02, kSelected = 0x04,
kInList = 0x08, kListAll = 0x0E, kFirstLevel = 0x10, kUnresTree = 0x20,
kAll = 0x2F
}
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

Acad::ErrorStatus AcDbXrefGraphNode::xrefReadSubstatus ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • xgraph.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbXrefGraphNode Member List

This is the complete list of members for AcDbXrefGraphNode, including all inherited members.

AcDbGraphNode(void *pData=NULL) (defined in AcDbGraphNode) | AcDbGraphNode |
AcDbXrefGraphNode(const ACHAR *pName=NULL, const AcDbObjectId &btrId=AcDbObjectId::kNull, AcDbDatabase *pDb=NULL, AcDb::XrefStatus status=AcDb::kXrfResolved) (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode |
addRefTo(AcDbGraphNode *) (defined in AcDbGraphNode) | AcDbGraphNode |
btrId() const (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
clear(Adesk::UInt8 flags) (defined in AcDbGraphNode) | AcDbGraphNode |
cycleIn(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
cycleOut(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
data() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
database() const (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
disconnectAll() (defined in AcDbGraphNode) | AcDbGraphNode |
Flags enum name (defined in AcDbGraphNode) | AcDbGraphNode |
in(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
isCycleNode() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
isMarkedAs(Adesk::UInt8 flags) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
isNested() const (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
kAll enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kFirstLevel enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kInList enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kListAll enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kNone enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kOutsideRefed enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kSelected enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kUnresTree enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kVisited enum value (defined in AcDbGraphNode) | AcDbGraphNode |
markAs(Adesk::UInt8 flags) (defined in AcDbGraphNode) | AcDbGraphNode |
markTree(Adesk::UInt8 flags, AcDbVoidPtrArray *=NULL) (defined in AcDbGraphNode) | AcDbGraphNode |
name() const (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
nextCycleNode() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numCycleIn() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numCycleOut() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numIn() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numOut() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
out(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
owner() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
removeRefTo(AcDbGraphNode *) (defined in AcDbGraphNode) | AcDbGraphNode |
setBtrId(const AcDbObjectId &id) (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
setData(void *) (defined in AcDbGraphNode) | AcDbGraphNode | inline
setDatabase(AcDbDatabase *pDb) (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
setEdgeGrowthRate(int outEdgeRate, int inEdgeRate) (defined in AcDbGraphNode) | AcDbGraphNode |
setName(const ACHAR *pName) (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode |
setxData(void *pXData) (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
setXrefNotificationStatus(AcDb::XrefNotificationStatus stat) (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
setXrefStatus(AcDb::XrefStatus stat) (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
xData() (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
xrefNotificationStatus() const (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
xrefReadSubstatus() const | AcDbXrefGraphNode |
xrefStatus() const (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | inline
~AcDbGraphNode() (defined in AcDbGraphNode) | AcDbGraphNode | virtual
~AcDbXrefGraphNode() (defined in AcDbXrefGraphNode) | AcDbXrefGraphNode | virtual


ZRX API Reference: AcDbXrefObjectId Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbXrefObjectId Class Reference
AcDb Classes

Public Member Functions

AcDbXrefObjectId (const AcDbXrefObjectId &other)
Acad::ErrorStatus | getLocalId (AcDbObjectId &objId) const
Acad::ErrorStatus | getXrefId (AcDbObjectId &xrefBlkId, AcDbHandle &hObject) const
bool | isNull (void) const
bool | isValid (void) const
bool | isXref (void) const
bool | operator!= (const AcDbXrefObjectId &other) const
AcDbXrefObjectId & | operator= (const AcDbXrefObjectId &other)
bool | operator== (const AcDbXrefObjectId &other) const
Acad::ErrorStatus | resolveObjectId (AcDbObjectId &id) const
Acad::ErrorStatus | serializeFromResbuf (const resbuf *pResBuf, resbuf *&pNextInChain)
Acad::ErrorStatus | serializeToResbuf (resbuf *&pResBuf, resbuf *&pEndOfChain) const
Acad::ErrorStatus | setLocalId (AcDbObjectId objId)
Acad::ErrorStatus | setNull (void)
Acad::ErrorStatus | setXrefId (AcDbObjectId xrefBlkId, const AcDbHandle &hObject)
The documentation for this class was generated from the following file:
  • AcDbXref.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbXrefObjectId Member List

This is the complete list of members for AcDbXrefObjectId, including all inherited members.

AcDbXrefObjectId() (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
AcDbXrefObjectId(const AcDbXrefObjectId &other) (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
getLocalId(AcDbObjectId &objId) const (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
getXrefId(AcDbObjectId &xrefBlkId, AcDbHandle &hObject) const (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
isNull(void) const (defined in AcDbXrefObjectId) | AcDbXrefObjectId | inline
isValid(void) const (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
isXref(void) const (defined in AcDbXrefObjectId) | AcDbXrefObjectId | inline
operator!=(const AcDbXrefObjectId &other) const (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
operator=(const AcDbXrefObjectId &other) (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
operator==(const AcDbXrefObjectId &other) const (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
resolveObjectId(AcDbObjectId &id) const (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
serializeFromResbuf(const resbuf *pResBuf, resbuf *&pNextInChain) (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
serializeToResbuf(resbuf *&pResBuf, resbuf *&pEndOfChain) const (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
setLocalId(AcDbObjectId objId) (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
setNull(void) (defined in AcDbXrefObjectId) | AcDbXrefObjectId |
setXrefId(AcDbObjectId xrefBlkId, const AcDbHandle &hObject) (defined in AcDbXrefObjectId) | AcDbXrefObjectId |


ZRX API Reference: AcGiGlyph Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiGlyph Class Reference
AcDb Classes
+ Inheritance diagram for AcGiGlyph:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiGlyph)
virtual AcGsNode * | gsNode () const
virtual AcDbObjectId | id () const
virtual Adesk::Boolean | isPersistent () const
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *)
virtual void | setGsNode (AcGsNode *)
virtual Acad::ErrorStatus | setLocation (const AcGePoint3d &dcsPoint)=0
virtual void | viewportDraw (AcGiViewportDraw *vportDrawContext)=0
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *)
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbosnap.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiGlyph Member List

This is the complete list of members for AcGiGlyph, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiGlyph) (defined in AcGiGlyph) | AcGiGlyph |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
gsNode() const (defined in AcGiGlyph) | AcGiGlyph | inlinevirtual
id() const (defined in AcGiGlyph) | AcGiGlyph | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isPersistent() const (defined in AcGiGlyph) | AcGiGlyph | inlinevirtual
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAttributes(AcGiDrawableTraits *) (defined in AcGiGlyph) | AcGiGlyph | inlinevirtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setGsNode(AcGsNode *) (defined in AcGiGlyph) | AcGiGlyph | inlinevirtual
setLocation(const AcGePoint3d &dcsPoint)=0 (defined in AcGiGlyph) | AcGiGlyph | pure virtual
viewportDraw(AcGiViewportDraw *vportDrawContext)=0 (defined in AcGiGlyph) | AcGiGlyph | pure virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
worldDraw(AcGiWorldDraw *) (defined in AcGiGlyph) | AcGiGlyph | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiLineAttrUtils Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Static Public Member Functions | List of all members
AcGiLineAttrUtils Class Reference
AcDb Classes

Static Public Member Functions

static AcDb::LineWeight __stdcall | acgiIndexToLineWeight (char index)
static char __stdcall | acgiLineWeightToIndex (AcDb::LineWeight lw)
The documentation for this class was generated from the following file:
  • AcGiLineAttrUtils.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiLineAttrUtils Member List

This is the complete list of members for AcGiLineAttrUtils, including all inherited members.

acgiIndexToLineWeight(char index) (defined in AcGiLineAttrUtils) | AcGiLineAttrUtils | static
acgiLineWeightToIndex(AcDb::LineWeight lw) (defined in AcGiLineAttrUtils) | AcGiLineAttrUtils | static


ZRX API Reference: AcGiStyleAttributes Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
AcGiStyleAttributes Class Reference
AcDb Classes

Public Member Functions

AcGiStyleAttributes (const AcGiStyleAttributes &source)
virtual void | EnsureColorVisibility (AcCmEntityColor &color)=0
AcCmEntityColor & | getColorAttribute ()
const AcCmEntityColor & | getColorAttribute () const
virtual AcGiLineAttributes * | getLineAttribute ()=0
virtual const AcGiLineAttributes * | getLineAttribute () const =0
AcDbObjectId | linetypeObjectId () const
AcDbObjectId | plotStyleNameId () const
void | setColorAttribute (const AcCmEntityColor &color)
virtual void | setLineAttribute (const AcGiLineAttributes *pLineAttributes)=0
void | setLinetypeObjectId (const AcDbObjectId &newId)
void | setPlotStyleName (const AcDbObjectId &newId)

Protected Attributes

AcCmEntityColor | m_colorAttribute
AcDbObjectId | m_idLinetype
AcDbObjectId | m_idPlotstyle
The documentation for this class was generated from the following file:
  • AcGiStyleAttributes.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiStyleAttributes Member List

This is the complete list of members for AcGiStyleAttributes, including all inherited members.

AcGiStyleAttributes() (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inline
AcGiStyleAttributes(const AcGiStyleAttributes &source) (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inline
EnsureColorVisibility(AcCmEntityColor &color)=0 (defined in AcGiStyleAttributes) | AcGiStyleAttributes | pure virtual
getColorAttribute() (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inline
getColorAttribute() const (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inline
getLineAttribute()=0 (defined in AcGiStyleAttributes) | AcGiStyleAttributes | pure virtual
getLineAttribute() const =0 (defined in AcGiStyleAttributes) | AcGiStyleAttributes | pure virtual
linetypeObjectId() const (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inline
m_colorAttribute (defined in AcGiStyleAttributes) | AcGiStyleAttributes | protected
m_idLinetype (defined in AcGiStyleAttributes) | AcGiStyleAttributes | protected
m_idPlotstyle (defined in AcGiStyleAttributes) | AcGiStyleAttributes | protected
plotStyleNameId() const (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inline
setColorAttribute(const AcCmEntityColor &color) (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inline
setLineAttribute(const AcGiLineAttributes *pLineAttributes)=0 (defined in AcGiStyleAttributes) | AcGiStyleAttributes | pure virtual
setLinetypeObjectId(const AcDbObjectId &newId) (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inline
setPlotStyleName(const AcDbObjectId &newId) (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inline
~AcGiStyleAttributes() (defined in AcGiStyleAttributes) | AcGiStyleAttributes | inlinevirtual


ZRX API Reference: AcTransaction Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcTransaction Class Reference
AcDb Classes
+ Inheritance diagram for AcTransaction:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcTransaction)
virtual Acad::ErrorStatus | getAllObjects (AcDbVoidPtrArray &objs)=0
virtual Acad::ErrorStatus | getObject (AcDbObject *&obj, AcDbObjectId objectId, AcDb::OpenMode mode, bool openErasedObject=false)=0
virtual Acad::ErrorStatus | markObjectPageable (AcDbObject *pObject)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbtrans.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTransaction Member List

This is the complete list of members for AcTransaction, including all inherited members.

ACRX_DECLARE_MEMBERS(AcTransaction) (defined in AcTransaction) | AcTransaction |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getAllObjects(AcDbVoidPtrArray &objs)=0 (defined in AcTransaction) | AcTransaction | pure virtual
getObject(AcDbObject *&obj, AcDbObjectId objectId, AcDb::OpenMode mode, bool openErasedObject=false)=0 (defined in AcTransaction) | AcTransaction | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
markObjectPageable(AcDbObject *pObject)=0 (defined in AcTransaction) | AcTransaction | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcTransactionReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcTransactionReactor Class Reference
AcDb Classes
+ Inheritance diagram for AcTransactionReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcTransactionReactor)
virtual void | endCalledOnOutermostTransaction (int &numTransactions, AcDbTransactionManager *transactionManagerPtr)
virtual void | objectIdSwapped (const AcDbObject *pTransResObj, const AcDbObject *pOtherObj, AcDbTransactionManager *transactionManagerPtr)
virtual void | transactionAborted (int &numTransactions, AcDbTransactionManager *transactionManagerPtr)
virtual void | transactionAboutToAbort (int &numTransactions, AcDbTransactionManager *transactionManagerPtr)
virtual void | transactionAboutToEnd (int &numTransactions, AcDbTransactionManager *transactionManagerPtr)
virtual void | transactionAboutToStart (int &numTransactions, AcDbTransactionManager *transactionManagerPtr)
virtual void | transactionEnded (int &numTransactions, AcDbTransactionManager *transactionManagerPtr)
virtual void | transactionStarted (int &numTransactions, AcDbTransactionManager *transactionManagerPtr)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbtrans.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTransactionReactor Member List

This is the complete list of members for AcTransactionReactor, including all inherited members.

ACRX_DECLARE_MEMBERS(AcTransactionReactor) (defined in AcTransactionReactor) | AcTransactionReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
endCalledOnOutermostTransaction(int &numTransactions, AcDbTransactionManager *transactionManagerPtr) (defined in AcTransactionReactor) | AcTransactionReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
objectIdSwapped(const AcDbObject *pTransResObj, const AcDbObject *pOtherObj, AcDbTransactionManager *transactionManagerPtr) (defined in AcTransactionReactor) | AcTransactionReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
transactionAborted(int &numTransactions, AcDbTransactionManager *transactionManagerPtr) (defined in AcTransactionReactor) | AcTransactionReactor | virtual
transactionAboutToAbort(int &numTransactions, AcDbTransactionManager *transactionManagerPtr) (defined in AcTransactionReactor) | AcTransactionReactor | virtual
transactionAboutToEnd(int &numTransactions, AcDbTransactionManager *transactionManagerPtr) (defined in AcTransactionReactor) | AcTransactionReactor | virtual
transactionAboutToStart(int &numTransactions, AcDbTransactionManager *transactionManagerPtr) (defined in AcTransactionReactor) | AcTransactionReactor | virtual
transactionEnded(int &numTransactions, AcDbTransactionManager *transactionManagerPtr) (defined in AcTransactionReactor) | AcTransactionReactor | virtual
transactionStarted(int &numTransactions, AcDbTransactionManager *transactionManagerPtr) (defined in AcTransactionReactor) | AcTransactionReactor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEd Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Macros | Typedefs | Functions
AcEd Classes

Classes

class | AcEdAppGripService
class | AcEdCommand
class | AcEdCommandIterator
class | AcEdCommandStack
class | AcEdInputContextReactor
class | AcEdInputPointFilter
class | AcEdInputPointManager
class | AcEdInputPointMonitor
class | AcEditor
class | AcEditorReactor
class | AcEditorReactor2
class | AcEdJig
class | AcEdSelectionSetService
class | AcEdSolidSubentitySelector
class | AcEdSSGetFilter
class | AcEdSSGetFilter2
class | AcEdSSGetFilter3
class | AcEdSSGetSubSelectFilter
class | AcEdSubSelectFilterService
class | AcEdUIContext

Macros

#define | acedEditor AcEditor::cast(acrxSysRegistry()->at(ACED_EDITOR_OBJ))
#define | acedRegCmds AcEdCommandStack::cast(acrxSysRegistry()->at(ACRX_COMMAND_DOCK))

Typedefs

typedef AcArray< AcDbIntArray,
AcArrayObjectCopyReallocator
< AcDbIntArray > > 		AcDbArrayIntArray
typedef
AcEdSymbolUtilities::Services 		AcEdSymUtilServices

Functions

const AcEdSymUtilServices * | acedSymUtil ()
Acad::ErrorStatus | addSSgetFilterInputContextReactor (AcApDocument *pDoc, AcEdSSGetFilter2 *pFilter)
Acad::ErrorStatus | addSSgetFilterInputContextReactor (AcApDocument *pDoc, AcEdSSGetFilter3 *pFilter)
Acad::ErrorStatus | removeSSgetFilterInputContextReactor (AcApDocument *pDoc, AcEdSSGetFilter2 *pFilter)
Acad::ErrorStatus | removeSSgetFilterInputContextReactor (AcApDocument *pDoc, AcEdSSGetFilter3 *pFilter)

Detailed Description


ZRX API Reference: AcEdAppGripService Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdAppGripService Class Reference
AcEd Classes

Public Member Functions

virtual Acad::ErrorStatus | appGetGripPoints (const AcDbEntity *pEnt, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags)
virtual Acad::ErrorStatus | appGetGripPoints (const AcDbEntity *pEnt, AcGePoint3dArray &pnts, AcDbIntArray &osmodes, AcDbIntArray &ids)
virtual Acad::ErrorStatus | appGripStatus (const AcDbEntity *pEnt, const AcDb::GripStat status)
virtual Acad::ErrorStatus | appMoveGripPointsAt (AcDbEntity *pEnt, const AcDbIntArray &pIndices, const AcGeVector3d &pOffset)
virtual Acad::ErrorStatus | appMoveGripPointsAt (AcDbEntity *pEnt, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
virtual Acad::ErrorStatus | getGripPointsAtSubentPath (const AcDbEntity *pEnt, const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags)
virtual Acad::ErrorStatus | moveGripPointsAtSubentPaths (AcDbEntity *pEnt, const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags)
The documentation for this class was generated from the following file:
  • acedinpt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdAppGripService Member List

This is the complete list of members for AcEdAppGripService, including all inherited members.

appGetGripPoints(const AcDbEntity *pEnt, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) (defined in AcEdAppGripService) | AcEdAppGripService | inlinevirtual
appGetGripPoints(const AcDbEntity *pEnt, AcGePoint3dArray &pnts, AcDbIntArray &osmodes, AcDbIntArray &ids) (defined in AcEdAppGripService) | AcEdAppGripService | inlinevirtual
appGripStatus(const AcDbEntity *pEnt, const AcDb::GripStat status) (defined in AcEdAppGripService) | AcEdAppGripService | inlinevirtual
appMoveGripPointsAt(AcDbEntity *pEnt, const AcDbIntArray &pIndices, const AcGeVector3d &pOffset) (defined in AcEdAppGripService) | AcEdAppGripService | inlinevirtual
appMoveGripPointsAt(AcDbEntity *pEnt, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcEdAppGripService) | AcEdAppGripService | inlinevirtual
getGripPointsAtSubentPath(const AcDbEntity *pEnt, const AcDbFullSubentPath &path, AcDbGripDataPtrArray &grips, const double curViewUnitSize, const int gripSize, const AcGeVector3d &curViewDir, const int bitflags) (defined in AcEdAppGripService) | AcEdAppGripService | inlinevirtual
moveGripPointsAtSubentPaths(AcDbEntity *pEnt, const AcDbFullSubentPathArray &paths, const AcDbVoidPtrArray &gripAppData, const AcGeVector3d &offset, const int bitflags) (defined in AcEdAppGripService) | AcEdAppGripService | inlinevirtual


ZRX API Reference: AcEdCommand Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdCommand Class Reference
AcEd Classes
+ Inheritance diagram for AcEdCommand:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcEdCommand)
virtual void * | commandApp () const =0
virtual Adesk::Int32 | commandFlags () const =0
virtual void | commandUndef (bool undefIt)=0
virtual AcRxFunctionPtr | functionAddr () const =0
virtual void | functionAddr (AcRxFunctionPtr fhdl)=0
virtual int | functionCode () const =0
virtual void | functionCode (int fcode)=0
virtual const ACHAR * | globalName () const =0
virtual const ACHAR * | localName () const =0
virtual const HINSTANCE | resourceHandle () const =0
virtual AcEdUIContext * | UIContext () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • accmd.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdCommand Member List

This is the complete list of members for AcEdCommand, including all inherited members.

ACRX_DECLARE_MEMBERS(AcEdCommand) (defined in AcEdCommand) | AcEdCommand |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
commandApp() const =0 (defined in AcEdCommand) | AcEdCommand | pure virtual
commandFlags() const =0 (defined in AcEdCommand) | AcEdCommand | pure virtual
commandUndef(bool undefIt)=0 (defined in AcEdCommand) | AcEdCommand | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
functionAddr() const =0 (defined in AcEdCommand) | AcEdCommand | pure virtual
functionAddr(AcRxFunctionPtr fhdl)=0 (defined in AcEdCommand) | AcEdCommand | pure virtual
functionCode() const =0 (defined in AcEdCommand) | AcEdCommand | pure virtual
functionCode(int fcode)=0 (defined in AcEdCommand) | AcEdCommand | pure virtual
globalName() const =0 (defined in AcEdCommand) | AcEdCommand | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
localName() const =0 (defined in AcEdCommand) | AcEdCommand | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
resourceHandle() const =0 (defined in AcEdCommand) | AcEdCommand | pure virtual
UIContext() const =0 (defined in AcEdCommand) | AcEdCommand | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEdCommandIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdCommandIterator Class Reference
AcEd Classes
+ Inheritance diagram for AcEdCommandIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcEdCommandIterator)
virtual const AcEdCommand * | command () const =0
virtual const ACHAR * | commandGroup () const =0
virtual bool | done () const =0
virtual bool | next ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • accmd.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdCommandIterator Member List

This is the complete list of members for AcEdCommandIterator, including all inherited members.

ACRX_DECLARE_MEMBERS(AcEdCommandIterator) (defined in AcEdCommandIterator) | AcEdCommandIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
command() const =0 (defined in AcEdCommandIterator) | AcEdCommandIterator | pure virtual
commandGroup() const =0 (defined in AcEdCommandIterator) | AcEdCommandIterator | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const =0 (defined in AcEdCommandIterator) | AcEdCommandIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
next()=0 (defined in AcEdCommandIterator) | AcEdCommandIterator | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEdCommandStack Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdCommandStack Class Reference
AcEd Classes
+ Inheritance diagram for AcEdCommandStack:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcEdCommandStack)
virtual Acad::ErrorStatus | addCommand (const ACHAR *cmdGroupName, const ACHAR *cmdGlobalName, const ACHAR *cmdLocalName, Adesk::Int32 commandFlags, AcRxFunctionPtr FunctionAddr, AcEdUIContext *UIContext=NULL, int fcode=-1, HINSTANCE hResourceHandle=NULL, AcEdCommand **cmdPtrRet=NULL)=0
virtual bool | atPut (const ACHAR *cmdGroupName, AcRxDictionary *&cmdsGlobal, AcRxDictionary *&cmdsLocal)=0
virtual AcEdCommandIterator * | iterator ()=0
virtual AcEdCommand * | lookupCmd (const ACHAR *cmdName, bool globalFlag)=0
virtual AcEdCommand * | lookupCmd (const ACHAR *cmdName, bool globalFlag, bool allGroupsFlag)=0
virtual AcEdCommand * | lookupCmd (const ACHAR *cmdName, bool globalFlag, bool allGroupsFlag, bool skipUndefed)=0
virtual AcEdCommand * | lookupCmd2 (const ACHAR *cmdName, bool globalFlag, bool allGroupsFlag, int skipFlags, bool match=false)=0
virtual AcEdCommand * | lookupGlobalCmd (const ACHAR *cmdName)=0
virtual AcEdCommand * | lookupLocalCmd (const ACHAR *cmdName)=0
virtual Acad::ErrorStatus | popGroupToTop (const ACHAR *cmdGroupName)=0
virtual Acad::ErrorStatus | removeCmd (const ACHAR *cmdGroupName, const ACHAR *cmdGlobalName)=0
virtual Acad::ErrorStatus | removeGroup (const ACHAR *groupName)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • accmd.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdCommandStack Member List

This is the complete list of members for AcEdCommandStack, including all inherited members.

ACRX_DECLARE_MEMBERS(AcEdCommandStack) (defined in AcEdCommandStack) | AcEdCommandStack |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addCommand(const ACHAR *cmdGroupName, const ACHAR *cmdGlobalName, const ACHAR *cmdLocalName, Adesk::Int32 commandFlags, AcRxFunctionPtr FunctionAddr, AcEdUIContext *UIContext=NULL, int fcode=-1, HINSTANCE hResourceHandle=NULL, AcEdCommand **cmdPtrRet=NULL)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
atPut(const ACHAR *cmdGroupName, AcRxDictionary *&cmdsGlobal, AcRxDictionary *&cmdsLocal)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
iterator()=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
lookupCmd(const ACHAR *cmdName, bool globalFlag)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
lookupCmd(const ACHAR *cmdName, bool globalFlag, bool allGroupsFlag)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
lookupCmd(const ACHAR *cmdName, bool globalFlag, bool allGroupsFlag, bool skipUndefed)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
lookupCmd2(const ACHAR *cmdName, bool globalFlag, bool allGroupsFlag, int skipFlags, bool match=false)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
lookupGlobalCmd(const ACHAR *cmdName)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
lookupLocalCmd(const ACHAR *cmdName)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
popGroupToTop(const ACHAR *cmdGroupName)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeCmd(const ACHAR *cmdGroupName, const ACHAR *cmdGlobalName)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
removeGroup(const ACHAR *groupName)=0 (defined in AcEdCommandStack) | AcEdCommandStack | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEdInputContextReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdInputContextReactor Class Reference
AcEd Classes
+ Inheritance diagram for AcEdInputContextReactor:

Public Member Functions

virtual void | beginDragSequence (const ACHAR *promptString)
virtual void | beginEntsel (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetAngle (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetColor (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetCorner (const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetDistance (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetInteger (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetKeyword (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetOrientation (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetPoint (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetReal (const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetScaleFactor (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetString (const ACHAR *promptString, int initGetFlags)
virtual void | beginNentsel (const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginQuiescentState ()
virtual void | beginSSGet (const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask)
virtual void | endDragSequence (Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec)
virtual void | endEntsel (Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword)
virtual void | endGetAngle (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetColor (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetCorner (Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword)
virtual void | endGetDistance (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetInteger (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetKeyword (Acad::PromptStatus returnStatus, const ACHAR *&pKeyword)
virtual void | endGetOrientation (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetPoint (Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword)
virtual void | endGetReal (Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword)
virtual void | endGetScaleFactor (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetString (Acad::PromptStatus returnStatus, ACHAR *pString)
virtual void | endNentsel (Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword)
virtual void | endQuiescentState ()
virtual void | endSSGet (Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss)
The documentation for this class was generated from the following file:
  • acedinpt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdInputContextReactor Member List

This is the complete list of members for AcEdInputContextReactor, including all inherited members.

beginDragSequence(const ACHAR *promptString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginEntsel(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetAngle(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetColor(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetCorner(const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetDistance(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetInteger(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetKeyword(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetOrientation(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetPoint(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetReal(const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetScaleFactor(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetString(const ACHAR *promptString, int initGetFlags) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginNentsel(const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginSSGet(const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endDragSequence(Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endEntsel(Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetAngle(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetColor(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetCorner(Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetDistance(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetInteger(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetKeyword(Acad::PromptStatus returnStatus, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetOrientation(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetPoint(Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetReal(Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetScaleFactor(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetString(Acad::PromptStatus returnStatus, ACHAR *pString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endNentsel(Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endSSGet(Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual


ZRX API Reference: AcEdInputPointFilter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdInputPointFilter Class Reference
AcEd Classes
+ Inheritance diagram for AcEdInputPointFilter:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcEdInputPointFilter)
virtual Acad::ErrorStatus | processInputPoint (bool &changedPoint, AcGePoint3d &newPoint, bool &displayOsnapGlyph, bool &changedTooltipStr, ACHAR *&newTooltipString, bool &retry, AcGiViewportDraw *drawContext, AcApDocument *document, bool pointComputed, int history, const AcGePoint3d &lastPoint, const AcGePoint3d &rawPoint, const AcGePoint3d &grippedPoint, const AcGePoint3d &cartesianSnappedPoint, const AcGePoint3d &osnappedPoint, AcDb::OsnapMask osnapMask, const AcArray< AcDbCustomOsnapMode * > &customOsnapModes, AcDb::OsnapMask osnapOverrides, const AcArray< AcDbCustomOsnapMode * > &customOsnapOverrides, const AcArray< AcDbObjectId > &pickedEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedPickedEntities, const AcArray< Adesk::GsMarker > &gsSelectionMark, const AcArray< AcDbObjectId > &keyPointEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedKeyPointEntities, const AcArray< Adesk::GsMarker > &keyPointGsSelectionMark, const AcArray< AcGeCurve3d * > &alignmentPaths, const AcGePoint3d &computedPoint, const ACHAR *tooltipString)=0
virtual AcEdInputPointFilter * | revokeInputFilter (AcEdInputPointFilter *revokedFilter)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acedinpt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdInputPointFilter Member List

This is the complete list of members for AcEdInputPointFilter, including all inherited members.

ACRX_DECLARE_MEMBERS(AcEdInputPointFilter) (defined in AcEdInputPointFilter) | AcEdInputPointFilter
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
processInputPoint(bool &changedPoint, AcGePoint3d &newPoint, bool &displayOsnapGlyph, bool &changedTooltipStr, ACHAR *&newTooltipString, bool &retry, AcGiViewportDraw *drawContext, AcApDocument *document, bool pointComputed, int history, const AcGePoint3d &lastPoint, const AcGePoint3d &rawPoint, const AcGePoint3d &grippedPoint, const AcGePoint3d &cartesianSnappedPoint, const AcGePoint3d &osnappedPoint, AcDb::OsnapMask osnapMask, const AcArray< AcDbCustomOsnapMode * > &customOsnapModes, AcDb::OsnapMask osnapOverrides, const AcArray< AcDbCustomOsnapMode * > &customOsnapOverrides, const AcArray< AcDbObjectId > &pickedEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedPickedEntities, const AcArray< Adesk::GsMarker > &gsSelectionMark, const AcArray< AcDbObjectId > &keyPointEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedKeyPointEntities, const AcArray< Adesk::GsMarker > &keyPointGsSelectionMark, const AcArray< AcGeCurve3d * > &alignmentPaths, const AcGePoint3d &computedPoint, const ACHAR *tooltipString)=0 (defined in AcEdInputPointFilter) | AcEdInputPointFilter | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject
revokeInputFilter(AcEdInputPointFilter *revokedFilter) (defined in AcEdInputPointFilter) | AcEdInputPointFilter | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEdInputPointManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdInputPointManager Class Reference
AcEd Classes

Public Member Functions

virtual Acad::ErrorStatus | addInputContextReactor (AcEdInputContextReactor *pReactor)=0
virtual Acad::ErrorStatus | addPointMonitor (AcEdInputPointMonitor *pMonitor)=0
virtual Acad::ErrorStatus | addSubSelectFilter (AcEdSubSelectFilter *pSSSubFilter)=0
virtual AcEdInputPointFilter * | currentPointFilter () const =0
virtual Acad::ErrorStatus | disableSystemCursorGraphics ()=0
virtual Acad::ErrorStatus | enableSystemCursorGraphics ()=0
virtual int | forcedPickCount () const =0
virtual int | mouseHasMoved () const =0
virtual Acad::ErrorStatus | registerPointFilter (AcEdInputPointFilter *pFilter)=0
virtual Acad::ErrorStatus | removeInputContextReactor (AcEdInputContextReactor *pReact)=0
virtual Acad::ErrorStatus | removePointMonitor (AcEdInputPointMonitor *pMonitor)=0
virtual Acad::ErrorStatus | removeSubSelectFilter (AcEdSubSelectFilter *pSSSubFilter)=0
virtual Acad::ErrorStatus | revokePointFilter ()=0
virtual int | systemCursorDisableCount () const =0
virtual Acad::ErrorStatus | turnOffForcedPick ()=0
virtual Acad::ErrorStatus | turnOffSubentityWindowSelection ()=0
virtual Acad::ErrorStatus | turnOnForcedPick ()=0
virtual Acad::ErrorStatus | turnOnSubentityWindowSelection ()=0
The documentation for this class was generated from the following file:
  • acedinpt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdInputPointManager Member List

This is the complete list of members for AcEdInputPointManager, including all inherited members.

addInputContextReactor(AcEdInputContextReactor *pReactor)=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
addPointMonitor(AcEdInputPointMonitor *pMonitor)=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
addSubSelectFilter(AcEdSubSelectFilter *pSSSubFilter)=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
currentPointFilter() const =0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
disableSystemCursorGraphics()=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
enableSystemCursorGraphics()=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
forcedPickCount() const =0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
mouseHasMoved() const =0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
registerPointFilter(AcEdInputPointFilter *pFilter)=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
removeInputContextReactor(AcEdInputContextReactor *pReact)=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
removePointMonitor(AcEdInputPointMonitor *pMonitor)=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
removeSubSelectFilter(AcEdSubSelectFilter *pSSSubFilter)=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
revokePointFilter()=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
systemCursorDisableCount() const =0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
turnOffForcedPick()=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
turnOffSubentityWindowSelection()=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
turnOnForcedPick()=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual
turnOnSubentityWindowSelection()=0 (defined in AcEdInputPointManager) | AcEdInputPointManager | pure virtual


ZRX API Reference: AcEdInputPointMonitor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdInputPointMonitor Class Reference
AcEd Classes
+ Inheritance diagram for AcEdInputPointMonitor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcEdInputPointMonitor)
virtual bool | excludeFromOsnapCalculation (const AcArray< AcDbObjectId > &nestedEntity, Adesk::GsMarker gsSelectionMark)
virtual Acad::ErrorStatus | monitorInputPoint (bool &appendToTooltipStr, ACHAR *&additionalTooltipString, AcGiViewportDraw *drawContext, AcApDocument *document, bool pointComputed, int history, const AcGePoint3d &lastPoint, const AcGePoint3d &rawPoint, const AcGePoint3d &grippedPoint, const AcGePoint3d &cartesianSnappedPoint, const AcGePoint3d &osnappedPoint, AcDb::OsnapMask osnapMask, const AcArray< AcDbCustomOsnapMode * > &customOsnapModes, AcDb::OsnapMask osnapOverrides, const AcArray< AcDbCustomOsnapMode * > &customOsnapOverrides, const AcArray< AcDbObjectId > &apertureEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedApertureEntities, const AcArray< Adesk::GsMarker > &gsSelectionMark, const AcArray< AcDbObjectId > &keyPointEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedKeyPointEntities, const AcArray< Adesk::GsMarker > &keyPointGsSelectionMark, const AcArray< AcGeCurve3d * > &alignmentPaths, const AcGePoint3d &computedPoint, const ACHAR *tooltipString)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acedinpt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdInputPointMonitor Member List

This is the complete list of members for AcEdInputPointMonitor, including all inherited members.

ACRX_DECLARE_MEMBERS(AcEdInputPointMonitor) (defined in AcEdInputPointMonitor) | AcEdInputPointMonitor
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
excludeFromOsnapCalculation(const AcArray< AcDbObjectId > &nestedEntity, Adesk::GsMarker gsSelectionMark) (defined in AcEdInputPointMonitor) | AcEdInputPointMonitor | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
monitorInputPoint(bool &appendToTooltipStr, ACHAR *&additionalTooltipString, AcGiViewportDraw *drawContext, AcApDocument *document, bool pointComputed, int history, const AcGePoint3d &lastPoint, const AcGePoint3d &rawPoint, const AcGePoint3d &grippedPoint, const AcGePoint3d &cartesianSnappedPoint, const AcGePoint3d &osnappedPoint, AcDb::OsnapMask osnapMask, const AcArray< AcDbCustomOsnapMode * > &customOsnapModes, AcDb::OsnapMask osnapOverrides, const AcArray< AcDbCustomOsnapMode * > &customOsnapOverrides, const AcArray< AcDbObjectId > &apertureEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedApertureEntities, const AcArray< Adesk::GsMarker > &gsSelectionMark, const AcArray< AcDbObjectId > &keyPointEntities, const AcArray< AcDbObjectIdArray, AcArrayObjectCopyReallocator< AcDbObjectIdArray > > &nestedKeyPointEntities, const AcArray< Adesk::GsMarker > &keyPointGsSelectionMark, const AcArray< AcGeCurve3d * > &alignmentPaths, const AcGePoint3d &computedPoint, const ACHAR *tooltipString)=0 (defined in AcEdInputPointMonitor) | AcEdInputPointMonitor | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEditor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEditor Class Reference
AcEd Classes
+ Inheritance diagram for AcEditor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcEditor)
virtual void | addReactor (AcRxEventReactor *newObj)=0
virtual void | removeReactor (AcRxEventReactor *delObj)=0
- Public Member Functions inherited from AcRxEvent
ACRX_DECLARE_MEMBERS (AcRxEvent)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • aced.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEditor Member List

This is the complete list of members for AcEditor, including all inherited members.

ACRX_DECLARE_MEMBERS(AcEditor) (defined in AcEditor) | AcEditor |
ACRX_DECLARE_MEMBERS(AcRxEvent) (defined in AcRxEvent) | AcRxEvent |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addReactor(AcRxEventReactor *newObj)=0 (defined in AcEditor) | AcEditor | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeReactor(AcRxEventReactor *delObj)=0 (defined in AcEditor) | AcEditor | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEditorReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcEditorReactor Class Reference
AcEd Classes
+ Inheritance diagram for AcEditorReactor:

Public Member Functions

virtual void | abortAttach (AcDbDatabase *pFrom)
virtual void | abortDeepClone (AcDbIdMapping &)
virtual void | abortDxfIn (AcDbDatabase *)
virtual void | abortDxfOut (AcDbDatabase *)
virtual void | abortInsert (AcDbDatabase *pTo)
virtual void | abortRestore (AcDbDatabase *pTo)
virtual void | abortSave (AcDbDatabase *)
virtual void | abortWblock (AcDbDatabase *pTo)
ACRX_DECLARE_MEMBERS (AcEditorReactor)
virtual void | beginAttach (AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom)
virtual ADESK_DEPRECATED void | beginClose (AcDbDatabase *pDwg)
virtual void | beginDeepClone (AcDbDatabase *pTo, AcDbIdMapping &)
virtual void | beginDeepCloneXlation (AcDbIdMapping &, Acad::ErrorStatus *)
virtual void | beginDoubleClick (const AcGePoint3d &clickPoint)
virtual void | beginDwgOpen (ACHAR *filename)
virtual void | beginDxfIn (AcDbDatabase *)
virtual void | beginDxfOut (AcDbDatabase *)
virtual void | beginInsert (AcDbDatabase *pTo, const ACHAR *pBlockName, AcDbDatabase *pFrom)
virtual void | beginInsert (AcDbDatabase *pTo, const AcGeMatrix3d &xform, AcDbDatabase *pFrom)
virtual void | beginQuit ()
virtual void | beginRestore (AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom)
virtual void | beginRightClick (const AcGePoint3d &clickPoint)
virtual void | beginSave (AcDbDatabase *, const ACHAR *pIntendedName)
virtual void | beginWblock (AcDbDatabase *pTo, AcDbDatabase *pFrom, const AcGePoint3d *&insertionPoint)
virtual void | beginWblock (AcDbDatabase *pTo, AcDbDatabase *pFrom, AcDbObjectId blockId)
virtual void | beginWblock (AcDbDatabase *pTo, AcDbDatabase *pFrom)
virtual void | beginWblockObjects (AcDbDatabase *pFrom, AcDbIdMapping &)
virtual void | cmdIUnkModified (const ACHAR *strCommand)
virtual void | comandeered (AcDbDatabase *pTo, AcDbObjectId id, AcDbDatabase *pFrom)
virtual void | commandCancelled (const ACHAR *cmdStr)
virtual void | commandEnded (const ACHAR *cmdStr)
virtual void | commandFailed (const ACHAR *cmdStr)
virtual void | commandWillStart (const ACHAR *cmdStr)
virtual void | databaseConstructed (AcDbDatabase *)
virtual void | databaseToBeDestroyed (AcDbDatabase *)
virtual void | docFrameMovedOrResized (Adesk::LongPtr hwndDocFrame, bool bMoved)
virtual void | dwgFileOpened (AcDbDatabase *, ACHAR *fileName)
virtual void | dxfInComplete (AcDbDatabase *)
virtual void | dxfOutComplete (AcDbDatabase *)
virtual void | endAttach (AcDbDatabase *pTo)
virtual void | endDeepClone (AcDbIdMapping &)
virtual void | endDwgOpen (const ACHAR *filename, AcDbDatabase *pDb)
virtual void | endInsert (AcDbDatabase *pTo)
virtual void | endRestore (AcDbDatabase *pTo)
virtual void | endWblock (AcDbDatabase *pTo)
virtual void | initialDwgFileOpenComplete (AcDbDatabase *pDwg)
virtual void | layoutSwitched (const ACHAR *newLayoutName)
virtual void | lispCancelled ()
virtual void | lispEnded ()
virtual void | lispWillStart (const ACHAR *firstLine)
virtual void | mainFrameMovedOrResized (Adesk::LongPtr hwndMainFrame, bool bMoved)
virtual void | modelessOperationEnded (const ACHAR *contextStr)
virtual void | modelessOperationWillStart (const ACHAR *contextStr)
virtual void | objectsLazyLoaded (const AcDbObjectIdArray &idArray)
virtual void | otherAttach (AcDbDatabase *pTo, AcDbDatabase *pFrom)
virtual void | otherInsert (AcDbDatabase *pTo, AcDbIdMapping &idMap, AcDbDatabase *pFrom)
virtual void | otherWblock (AcDbDatabase *pTo, AcDbIdMapping &, AcDbDatabase *pFrom)
virtual void | partialOpenNotice (AcDbDatabase *pDb)
virtual void | pickfirstModified ()
virtual void | preXrefLockFile (AcDbObjectId btrId)
virtual void | quitAborted ()
virtual void | quitWillStart ()
virtual void | redirected (AcDbObjectId newId, AcDbObjectId oldId)
virtual void | saveComplete (AcDbDatabase *, const ACHAR *pActualName)
virtual void | sysVarChanged (const ACHAR *varName, Adesk::Boolean success)
virtual void | sysVarWillChange (const ACHAR *varName)
virtual void | toolbarBitmapSizeChanged (Adesk::Boolean bLarge)
virtual void | toolbarBitmapSizeWillChange (Adesk::Boolean bLarge)
virtual void | undoSubcommandAuto (int activity, Adesk::Boolean state)
virtual void | undoSubcommandBack (int activity)
virtual void | undoSubcommandBegin (int activity)
virtual void | undoSubcommandControl (int activity, int option)
virtual void | undoSubcommandEnd (int activity)
virtual void | undoSubcommandMark (int activity)
virtual void | undoSubcommandNumber (int activity, int num)
virtual void | unknownCommand (const ACHAR *cmdStr, AcDbVoidPtrArray *al)
virtual void | viewChanged ()
virtual void | wblockNotice (AcDbDatabase *pDb)
virtual void | xrefSubcommandAttachItem (AcDbDatabase *pHost, int activity, const ACHAR *pPath)
virtual void | xrefSubcommandBindItem (AcDbDatabase *pHost, int activity, AcDbObjectId blockId)
virtual void | xrefSubcommandDetachItem (AcDbDatabase *pHost, int activity, AcDbObjectId blockId)
virtual void | xrefSubcommandOverlayItem (AcDbDatabase *pHost, int activity, const ACHAR *pPath)
virtual void | xrefSubcommandPathItem (int activity, AcDbObjectId blockId, const ACHAR *pNewPath)
virtual void | xrefSubcommandReloadItem (AcDbDatabase *pHost, int activity, AcDbObjectId blockId)
virtual Acad::ErrorStatus | xrefSubCommandStart (AcXrefSubCommand subcmd, const AcDbObjectIdArray &btrIds, const ACHAR *const *btrNames, const ACHAR *const *paths)
virtual void | xrefSubcommandUnloadItem (AcDbDatabase *pHost, int activity, AcDbObjectId blockId)
- Public Member Functions inherited from AcRxEventReactor
ACRX_DECLARE_MEMBERS (AcRxEventReactor)
virtual void | preXrefLockFile (AcDbDatabase *pDb, AcDbObjectId btrId)
virtual void | xrefSubCommandAborted (AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths)
virtual void | xrefSubCommandStart (AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths, bool &vetoOp)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

Acad::ErrorStatus veto ()

Friends

class AcEditorImp

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • aced.h


ZRX API Reference: AcEditorReactor2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEditorReactor2 Class Reference
AcEd Classes
+ Inheritance diagram for AcEditorReactor2:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcEditorReactor2)
virtual void | beginDocClose (AcDbDatabase *pDwg)
virtual void | docCloseAborted (AcDbDatabase *pDwg)
virtual void | docCloseWillStart (AcDbDatabase *pDwg)
virtual void | dwgViewResized (Adesk::LongPtr hwndDwgView)
virtual void | layoutToBeSwitched (const ACHAR *oldLayoutName, const ACHAR *newLayoutName)
- Public Member Functions inherited from AcEditorReactor
virtual void | abortAttach (AcDbDatabase *pFrom)
virtual void | abortDeepClone (AcDbIdMapping &)
virtual void | abortDxfIn (AcDbDatabase *)
virtual void | abortDxfOut (AcDbDatabase *)
virtual void | abortInsert (AcDbDatabase *pTo)
virtual void | abortRestore (AcDbDatabase *pTo)
virtual void | abortSave (AcDbDatabase *)
virtual void | abortWblock (AcDbDatabase *pTo)
ACRX_DECLARE_MEMBERS (AcEditorReactor)
virtual void | beginAttach (AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom)
virtual ADESK_DEPRECATED void | beginClose (AcDbDatabase *pDwg)
virtual void | beginDeepClone (AcDbDatabase *pTo, AcDbIdMapping &)
virtual void | beginDeepCloneXlation (AcDbIdMapping &, Acad::ErrorStatus *)
virtual void | beginDoubleClick (const AcGePoint3d &clickPoint)
virtual void | beginDwgOpen (ACHAR *filename)
virtual void | beginDxfIn (AcDbDatabase *)
virtual void | beginDxfOut (AcDbDatabase *)
virtual void | beginInsert (AcDbDatabase *pTo, const ACHAR *pBlockName, AcDbDatabase *pFrom)
virtual void | beginInsert (AcDbDatabase *pTo, const AcGeMatrix3d &xform, AcDbDatabase *pFrom)
virtual void | beginQuit ()
virtual void | beginRestore (AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom)
virtual void | beginRightClick (const AcGePoint3d &clickPoint)
virtual void | beginSave (AcDbDatabase *, const ACHAR *pIntendedName)
virtual void | beginWblock (AcDbDatabase *pTo, AcDbDatabase *pFrom, const AcGePoint3d *&insertionPoint)
virtual void | beginWblock (AcDbDatabase *pTo, AcDbDatabase *pFrom, AcDbObjectId blockId)
virtual void | beginWblock (AcDbDatabase *pTo, AcDbDatabase *pFrom)
virtual void | beginWblockObjects (AcDbDatabase *pFrom, AcDbIdMapping &)
virtual void | cmdIUnkModified (const ACHAR *strCommand)
virtual void | comandeered (AcDbDatabase *pTo, AcDbObjectId id, AcDbDatabase *pFrom)
virtual void | commandCancelled (const ACHAR *cmdStr)
virtual void | commandEnded (const ACHAR *cmdStr)
virtual void | commandFailed (const ACHAR *cmdStr)
virtual void | commandWillStart (const ACHAR *cmdStr)
virtual void | databaseConstructed (AcDbDatabase *)
virtual void | databaseToBeDestroyed (AcDbDatabase *)
virtual void | docFrameMovedOrResized (Adesk::LongPtr hwndDocFrame, bool bMoved)
virtual void | dwgFileOpened (AcDbDatabase *, ACHAR *fileName)
virtual void | dxfInComplete (AcDbDatabase *)
virtual void | dxfOutComplete (AcDbDatabase *)
virtual void | endAttach (AcDbDatabase *pTo)
virtual void | endDeepClone (AcDbIdMapping &)
virtual void | endDwgOpen (const ACHAR *filename, AcDbDatabase *pDb)
virtual void | endInsert (AcDbDatabase *pTo)
virtual void | endRestore (AcDbDatabase *pTo)
virtual void | endWblock (AcDbDatabase *pTo)
virtual void | initialDwgFileOpenComplete (AcDbDatabase *pDwg)
virtual void | layoutSwitched (const ACHAR *newLayoutName)
virtual void | lispCancelled ()
virtual void | lispEnded ()
virtual void | lispWillStart (const ACHAR *firstLine)
virtual void | mainFrameMovedOrResized (Adesk::LongPtr hwndMainFrame, bool bMoved)
virtual void | modelessOperationEnded (const ACHAR *contextStr)
virtual void | modelessOperationWillStart (const ACHAR *contextStr)
virtual void | objectsLazyLoaded (const AcDbObjectIdArray &idArray)
virtual void | otherAttach (AcDbDatabase *pTo, AcDbDatabase *pFrom)
virtual void | otherInsert (AcDbDatabase *pTo, AcDbIdMapping &idMap, AcDbDatabase *pFrom)
virtual void | otherWblock (AcDbDatabase *pTo, AcDbIdMapping &, AcDbDatabase *pFrom)
virtual void | partialOpenNotice (AcDbDatabase *pDb)
virtual void | pickfirstModified ()
virtual void | preXrefLockFile (AcDbObjectId btrId)
virtual void | quitAborted ()
virtual void | quitWillStart ()
virtual void | redirected (AcDbObjectId newId, AcDbObjectId oldId)
virtual void | saveComplete (AcDbDatabase *, const ACHAR *pActualName)
virtual void | sysVarChanged (const ACHAR *varName, Adesk::Boolean success)
virtual void | sysVarWillChange (const ACHAR *varName)
virtual void | toolbarBitmapSizeChanged (Adesk::Boolean bLarge)
virtual void | toolbarBitmapSizeWillChange (Adesk::Boolean bLarge)
virtual void | undoSubcommandAuto (int activity, Adesk::Boolean state)
virtual void | undoSubcommandBack (int activity)
virtual void | undoSubcommandBegin (int activity)
virtual void | undoSubcommandControl (int activity, int option)
virtual void | undoSubcommandEnd (int activity)
virtual void | undoSubcommandMark (int activity)
virtual void | undoSubcommandNumber (int activity, int num)
virtual void | unknownCommand (const ACHAR *cmdStr, AcDbVoidPtrArray *al)
virtual void | viewChanged ()
virtual void | wblockNotice (AcDbDatabase *pDb)
virtual void | xrefSubcommandAttachItem (AcDbDatabase *pHost, int activity, const ACHAR *pPath)
virtual void | xrefSubcommandBindItem (AcDbDatabase *pHost, int activity, AcDbObjectId blockId)
virtual void | xrefSubcommandDetachItem (AcDbDatabase *pHost, int activity, AcDbObjectId blockId)
virtual void | xrefSubcommandOverlayItem (AcDbDatabase *pHost, int activity, const ACHAR *pPath)
virtual void | xrefSubcommandPathItem (int activity, AcDbObjectId blockId, const ACHAR *pNewPath)
virtual void | xrefSubcommandReloadItem (AcDbDatabase *pHost, int activity, AcDbObjectId blockId)
virtual Acad::ErrorStatus | xrefSubCommandStart (AcXrefSubCommand subcmd, const AcDbObjectIdArray &btrIds, const ACHAR *const *btrNames, const ACHAR *const *paths)
virtual void | xrefSubcommandUnloadItem (AcDbDatabase *pHost, int activity, AcDbObjectId blockId)
- Public Member Functions inherited from AcRxEventReactor
ACRX_DECLARE_MEMBERS (AcRxEventReactor)
virtual void | preXrefLockFile (AcDbDatabase *pDb, AcDbObjectId btrId)
virtual void | xrefSubCommandAborted (AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths)
virtual void | xrefSubCommandStart (AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths, bool &vetoOp)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Member Functions inherited from AcEditorReactor
Acad::ErrorStatus | veto ()
The documentation for this class was generated from the following file:
  • aced.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEditorReactor2 Member List

This is the complete list of members for AcEditorReactor2, including all inherited members.

abortAttach(AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortDeepClone(AcDbIdMapping &) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortDxfIn(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortDxfOut(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortInsert(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortRestore(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortSave(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortWblock(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
AcEditorReactor() (defined in AcEditorReactor) | AcEditorReactor | inline
ACRX_DECLARE_MEMBERS(AcEditorReactor2) (defined in AcEditorReactor2) | AcEditorReactor2 |
ACRX_DECLARE_MEMBERS(AcEditorReactor) (defined in AcEditorReactor) | AcEditorReactor |
ACRX_DECLARE_MEMBERS(AcRxEventReactor) (defined in AcRxEventReactor) | AcRxEventReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
beginAttach(AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginClose(AcDbDatabase *pDwg) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDeepClone(AcDbDatabase *pTo, AcDbIdMapping &) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDeepCloneXlation(AcDbIdMapping &, Acad::ErrorStatus *) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDocClose(AcDbDatabase *pDwg) (defined in AcEditorReactor2) | AcEditorReactor2 | inlinevirtual
beginDoubleClick(const AcGePoint3d &clickPoint) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDwgOpen(ACHAR *filename) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDxfIn(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDxfOut(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginInsert(AcDbDatabase *pTo, const ACHAR *pBlockName, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginInsert(AcDbDatabase *pTo, const AcGeMatrix3d &xform, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginQuit() (defined in AcEditorReactor) | AcEditorReactor | virtual
beginRestore(AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginRightClick(const AcGePoint3d &clickPoint) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginSave(AcDbDatabase *, const ACHAR *pIntendedName) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginWblock(AcDbDatabase *pTo, AcDbDatabase *pFrom, const AcGePoint3d *&insertionPoint) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginWblock(AcDbDatabase *pTo, AcDbDatabase *pFrom, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginWblock(AcDbDatabase *pTo, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginWblockObjects(AcDbDatabase *pFrom, AcDbIdMapping &) (defined in AcEditorReactor) | AcEditorReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
cmdIUnkModified(const ACHAR *strCommand) (defined in AcEditorReactor) | AcEditorReactor | virtual
comandeered(AcDbDatabase *pTo, AcDbObjectId id, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
commandCancelled(const ACHAR *cmdStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
commandEnded(const ACHAR *cmdStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
commandFailed(const ACHAR *cmdStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
commandWillStart(const ACHAR *cmdStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
databaseConstructed(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
databaseToBeDestroyed(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
desc() (defined in AcRxObject) | AcRxObject | static
docCloseAborted(AcDbDatabase *pDwg) (defined in AcEditorReactor2) | AcEditorReactor2 | inlinevirtual
docCloseWillStart(AcDbDatabase *pDwg) (defined in AcEditorReactor2) | AcEditorReactor2 | inlinevirtual
docFrameMovedOrResized(Adesk::LongPtr hwndDocFrame, bool bMoved) (defined in AcEditorReactor) | AcEditorReactor | virtual
dwgFileOpened(AcDbDatabase *, ACHAR *fileName) (defined in AcEditorReactor) | AcEditorReactor | virtual
dwgViewResized(Adesk::LongPtr hwndDwgView) (defined in AcEditorReactor2) | AcEditorReactor2 | inlinevirtual
dxfInComplete(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
dxfOutComplete(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
endAttach(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
endDeepClone(AcDbIdMapping &) (defined in AcEditorReactor) | AcEditorReactor | virtual
endDwgOpen(const ACHAR *filename, AcDbDatabase *pDb) (defined in AcEditorReactor) | AcEditorReactor | virtual
endInsert(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
endRestore(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
endWblock(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
initialDwgFileOpenComplete(AcDbDatabase *pDwg) (defined in AcEditorReactor) | AcEditorReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
layoutSwitched(const ACHAR *newLayoutName) (defined in AcEditorReactor) | AcEditorReactor | virtual
layoutToBeSwitched(const ACHAR *oldLayoutName, const ACHAR *newLayoutName) (defined in AcEditorReactor2) | AcEditorReactor2 | inlinevirtual
lispCancelled() (defined in AcEditorReactor) | AcEditorReactor | virtual
lispEnded() (defined in AcEditorReactor) | AcEditorReactor | virtual
lispWillStart(const ACHAR *firstLine) (defined in AcEditorReactor) | AcEditorReactor | virtual
mainFrameMovedOrResized(Adesk::LongPtr hwndMainFrame, bool bMoved) (defined in AcEditorReactor) | AcEditorReactor | virtual
modelessOperationEnded(const ACHAR *contextStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
modelessOperationWillStart(const ACHAR *contextStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
objectsLazyLoaded(const AcDbObjectIdArray &idArray) (defined in AcEditorReactor) | AcEditorReactor | virtual
otherAttach(AcDbDatabase *pTo, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
otherInsert(AcDbDatabase *pTo, AcDbIdMapping &idMap, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
otherWblock(AcDbDatabase *pTo, AcDbIdMapping &, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
partialOpenNotice(AcDbDatabase *pDb) (defined in AcEditorReactor) | AcEditorReactor | virtual
pickfirstModified() (defined in AcEditorReactor) | AcEditorReactor | virtual
preXrefLockFile(AcDbObjectId btrId) (defined in AcEditorReactor) | AcEditorReactor | virtual
preXrefLockFile(AcDbDatabase *pDb, AcDbObjectId btrId) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
quitAborted() (defined in AcEditorReactor) | AcEditorReactor | virtual
quitWillStart() (defined in AcEditorReactor) | AcEditorReactor | virtual
redirected(AcDbObjectId newId, AcDbObjectId oldId) (defined in AcEditorReactor) | AcEditorReactor | virtual
saveComplete(AcDbDatabase *, const ACHAR *pActualName) (defined in AcEditorReactor) | AcEditorReactor | virtual
sysVarChanged(const ACHAR *varName, Adesk::Boolean success) (defined in AcEditorReactor) | AcEditorReactor | virtual
sysVarWillChange(const ACHAR *varName) (defined in AcEditorReactor) | AcEditorReactor | virtual
toolbarBitmapSizeChanged(Adesk::Boolean bLarge) (defined in AcEditorReactor) | AcEditorReactor | virtual
toolbarBitmapSizeWillChange(Adesk::Boolean bLarge) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandAuto(int activity, Adesk::Boolean state) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandBack(int activity) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandBegin(int activity) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandControl(int activity, int option) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandEnd(int activity) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandMark(int activity) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandNumber(int activity, int num) (defined in AcEditorReactor) | AcEditorReactor | virtual
unknownCommand(const ACHAR *cmdStr, AcDbVoidPtrArray *al) (defined in AcEditorReactor) | AcEditorReactor | virtual
veto() (defined in AcEditorReactor) | AcEditorReactor | protected
viewChanged() (defined in AcEditorReactor) | AcEditorReactor | virtual
wblockNotice(AcDbDatabase *pDb) (defined in AcEditorReactor) | AcEditorReactor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xrefSubCommandAborted(AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
xrefSubcommandAttachItem(AcDbDatabase *pHost, int activity, const ACHAR *pPath) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandBindItem(AcDbDatabase *pHost, int activity, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandDetachItem(AcDbDatabase *pHost, int activity, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandOverlayItem(AcDbDatabase *pHost, int activity, const ACHAR *pPath) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandPathItem(int activity, AcDbObjectId blockId, const ACHAR *pNewPath) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandReloadItem(AcDbDatabase *pHost, int activity, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubCommandStart(AcXrefSubCommand subcmd, const AcDbObjectIdArray &btrIds, const ACHAR *const *btrNames, const ACHAR *const *paths) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubCommandStart(AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths, bool &vetoOp) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
xrefSubcommandUnloadItem(AcDbDatabase *pHost, int activity, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEdJig Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcEdJig Class Reference
AcEd Classes
+ Inheritance diagram for AcEdJig:

Public Types

enum CursorType {
kNoSpecialCursor = -1, kCrosshair = 0, kRectCursor, kRubberBand,
kNotRotated, kTargetBox, kRotatedCrosshair, kCrosshairNoRotate,
kInvisible, kEntitySelect, kParallelogram, kEntitySelectNoPersp,
kPkfirstOrGrips, kCrosshairDashed
}
enum DragStatus {
kModeless = -17, kNoChange = -6, kCancel = -4, kOther = -3,
kNull = -1, kNormal = 0, kKW1, kKW2,
kKW3, kKW4, kKW5, kKW6,
kKW7, kKW8, kKW9
}
enum UserInputControls {
kGovernedByOrthoMode = 0x0001, kNullResponseAccepted = 0x0002, kDontEchoCancelForCtrlC = 0x0004, kDontUpdateLastPoint = 0x0008,
kNoDwgLimitsChecking = 0x0010, kNoZeroResponseAccepted = 0x0020, kNoNegativeResponseAccepted = 0x0040, kAccept3dCoordinates = 0x0080,
kAcceptMouseUpAsPoint = 0x0100, kAnyBlankTerminatesInput = 0x0200, kInitialBlankTerminatesInput = 0x0400, kAcceptOtherInputString = 0x0800,
kGovernedByUCSDetect = 0x1000, kNoZDirectionOrtho = 0x2000
}

Public Member Functions

DragStatus | acquireAngle (double &ang)
DragStatus | acquireAngle (double &ang, const AcGePoint3d &basePnt)
DragStatus | acquireDist (double &dist)
DragStatus | acquireDist (double &dist, const AcGePoint3d &basePnt)
DragStatus | acquirePoint (AcGePoint3d &)
DragStatus | acquirePoint (AcGePoint3d &, const AcGePoint3d &basePnt)
DragStatus | acquireString (ACHAR *str)
ACRX_DECLARE_MEMBERS (AcEdJig)
AcDbObjectId | append ()
virtual AcDbDimDataPtrArray * | dimData (const double dimScale)
const ACHAR * | dispPrompt ()
DragStatus | drag ()
virtual AcDbEntity * | entity () const
const ACHAR * | keywordList ()
virtual DragStatus | sampler ()
virtual Acad::ErrorStatus | setDimValue (const AcDbDimData *dimData, const double dimValue)
void | setDispPrompt (const ACHAR *,...)
void | setKeywordList (const ACHAR *)
void | setSpecialCursorType (CursorType)
void | setUserInputControls (AcEdJig::UserInputControls)
AcEdJig::CursorType | specialCursorType ()
virtual Adesk::Boolean | update ()
AcEdJig::UserInputControls | userInputControls ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dbjig.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdJig Member List

This is the complete list of members for AcEdJig, including all inherited members.

AcEdJig() (defined in AcEdJig) | AcEdJig |
acquireAngle(double &ang) (defined in AcEdJig) | AcEdJig |
acquireAngle(double &ang, const AcGePoint3d &basePnt) (defined in AcEdJig) | AcEdJig |
acquireDist(double &dist) (defined in AcEdJig) | AcEdJig |
acquireDist(double &dist, const AcGePoint3d &basePnt) (defined in AcEdJig) | AcEdJig |
acquirePoint(AcGePoint3d &) (defined in AcEdJig) | AcEdJig |
acquirePoint(AcGePoint3d &, const AcGePoint3d &basePnt) (defined in AcEdJig) | AcEdJig |
acquireString(ACHAR *str) (defined in AcEdJig) | AcEdJig |
ACRX_DECLARE_MEMBERS(AcEdJig) (defined in AcEdJig) | AcEdJig |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
append() (defined in AcEdJig) | AcEdJig |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
CursorType enum name (defined in AcEdJig) | AcEdJig |
desc() (defined in AcRxObject) | AcRxObject | static
dimData(const double dimScale) (defined in AcEdJig) | AcEdJig | virtual
dispPrompt() (defined in AcEdJig) | AcEdJig |
drag() (defined in AcEdJig) | AcEdJig |
DragStatus enum name (defined in AcEdJig) | AcEdJig |
entity() const (defined in AcEdJig) | AcEdJig | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAccept3dCoordinates enum value (defined in AcEdJig) | AcEdJig |
kAcceptMouseUpAsPoint enum value (defined in AcEdJig) | AcEdJig |
kAcceptOtherInputString enum value (defined in AcEdJig) | AcEdJig |
kAnyBlankTerminatesInput enum value (defined in AcEdJig) | AcEdJig |
kCancel enum value (defined in AcEdJig) | AcEdJig |
kCrosshair enum value (defined in AcEdJig) | AcEdJig |
kCrosshairDashed enum value (defined in AcEdJig) | AcEdJig |
kCrosshairNoRotate enum value (defined in AcEdJig) | AcEdJig |
kDontEchoCancelForCtrlC enum value (defined in AcEdJig) | AcEdJig |
kDontUpdateLastPoint enum value (defined in AcEdJig) | AcEdJig |
kEntitySelect enum value (defined in AcEdJig) | AcEdJig |
kEntitySelectNoPersp enum value (defined in AcEdJig) | AcEdJig |
keywordList() (defined in AcEdJig) | AcEdJig |
kGovernedByOrthoMode enum value (defined in AcEdJig) | AcEdJig |
kGovernedByUCSDetect enum value (defined in AcEdJig) | AcEdJig |
kInitialBlankTerminatesInput enum value (defined in AcEdJig) | AcEdJig |
kInvisible enum value (defined in AcEdJig) | AcEdJig |
kKW1 enum value (defined in AcEdJig) | AcEdJig |
kKW2 enum value (defined in AcEdJig) | AcEdJig |
kKW3 enum value (defined in AcEdJig) | AcEdJig |
kKW4 enum value (defined in AcEdJig) | AcEdJig |
kKW5 enum value (defined in AcEdJig) | AcEdJig |
kKW6 enum value (defined in AcEdJig) | AcEdJig |
kKW7 enum value (defined in AcEdJig) | AcEdJig |
kKW8 enum value (defined in AcEdJig) | AcEdJig |
kKW9 enum value (defined in AcEdJig) | AcEdJig |
kModeless enum value (defined in AcEdJig) | AcEdJig |
kNoChange enum value (defined in AcEdJig) | AcEdJig |
kNoDwgLimitsChecking enum value (defined in AcEdJig) | AcEdJig |
kNoNegativeResponseAccepted enum value (defined in AcEdJig) | AcEdJig |
kNormal enum value (defined in AcEdJig) | AcEdJig |
kNoSpecialCursor enum value (defined in AcEdJig) | AcEdJig |
kNotRotated enum value (defined in AcEdJig) | AcEdJig |
kNoZDirectionOrtho enum value (defined in AcEdJig) | AcEdJig |
kNoZeroResponseAccepted enum value (defined in AcEdJig) | AcEdJig |
kNull enum value (defined in AcEdJig) | AcEdJig |
kNullResponseAccepted enum value (defined in AcEdJig) | AcEdJig |
kOther enum value (defined in AcEdJig) | AcEdJig |
kParallelogram enum value (defined in AcEdJig) | AcEdJig |
kPkfirstOrGrips enum value (defined in AcEdJig) | AcEdJig |
kRectCursor enum value (defined in AcEdJig) | AcEdJig |
kRotatedCrosshair enum value (defined in AcEdJig) | AcEdJig |
kRubberBand enum value (defined in AcEdJig) | AcEdJig |
kTargetBox enum value (defined in AcEdJig) | AcEdJig |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sampler() (defined in AcEdJig) | AcEdJig | virtual
setDimValue(const AcDbDimData *dimData, const double dimValue) (defined in AcEdJig) | AcEdJig | virtual
setDispPrompt(const ACHAR *,...) (defined in AcEdJig) | AcEdJig |
setKeywordList(const ACHAR *) (defined in AcEdJig) | AcEdJig |
setSpecialCursorType(CursorType) (defined in AcEdJig) | AcEdJig |
setUserInputControls(AcEdJig::UserInputControls) (defined in AcEdJig) | AcEdJig |
specialCursorType() (defined in AcEdJig) | AcEdJig |
update() (defined in AcEdJig) | AcEdJig | virtual
userInputControls() (defined in AcEdJig) | AcEdJig |
UserInputControls enum name (defined in AcEdJig) | AcEdJig |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcEdJig() (defined in AcEdJig) | AcEdJig | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEdSelectionSetService Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdSelectionSetService Class Reference
AcEd Classes

Public Member Functions

virtual Acad::ErrorStatus | add (resbuf *ssnameXList, const AcDbFullSubentPath *pPath=NULL, const AcDbObjectId *pEntselSubent=NULL)=0
virtual Acad::ErrorStatus | addSubentity (resbuf *ssnameXList, const AcDbFullSubentPath &subEntity)=0
virtual Acad::ErrorStatus | highlight (int subSelectionIndex, const AcDbFullSubentPath &path)=0
virtual Acad::ErrorStatus | remove (int index)=0
virtual Acad::ErrorStatus | removeSubentity (int entityIndex, int subEntityIndex)=0
virtual Acad::ErrorStatus | ssNameSubentities (bool bIsSubSelectionIndex, int index, AcDbFullSubentPathArray &subEntities)=0
virtual Acad::ErrorStatus | ssNameSubentityX (bool bIsSubSelectionIndex, int index, int subentityIndex, resbuf *&result)=0
virtual Acad::ErrorStatus | ssNameX (bool bIsSubSelectionIndex, int index, resbuf *&result)=0
The documentation for this class was generated from the following file:
  • acssgetfilter.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdSelectionSetService Member List

This is the complete list of members for AcEdSelectionSetService, including all inherited members.

add(resbuf *ssnameXList, const AcDbFullSubentPath *pPath=NULL, const AcDbObjectId *pEntselSubent=NULL)=0 (defined in AcEdSelectionSetService) | AcEdSelectionSetService | pure virtual
addSubentity(resbuf *ssnameXList, const AcDbFullSubentPath &subEntity)=0 (defined in AcEdSelectionSetService) | AcEdSelectionSetService | pure virtual
highlight(int subSelectionIndex, const AcDbFullSubentPath &path)=0 (defined in AcEdSelectionSetService) | AcEdSelectionSetService | pure virtual
remove(int index)=0 (defined in AcEdSelectionSetService) | AcEdSelectionSetService | pure virtual
removeSubentity(int entityIndex, int subEntityIndex)=0 (defined in AcEdSelectionSetService) | AcEdSelectionSetService | pure virtual
ssNameSubentities(bool bIsSubSelectionIndex, int index, AcDbFullSubentPathArray &subEntities)=0 (defined in AcEdSelectionSetService) | AcEdSelectionSetService | pure virtual
ssNameSubentityX(bool bIsSubSelectionIndex, int index, int subentityIndex, resbuf *&result)=0 (defined in AcEdSelectionSetService) | AcEdSelectionSetService | pure virtual
ssNameX(bool bIsSubSelectionIndex, int index, resbuf *&result)=0 (defined in AcEdSelectionSetService) | AcEdSelectionSetService | pure virtual


ZRX API Reference: AcEdSolidSubentitySelector Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdSolidSubentitySelector Class Reference
AcEd Classes

Public Member Functions

Acad::ErrorStatus selectFaces (AcDbObjectId &selectedSolidId, AcArray< AcDbSubentId * > &faceSet)
The documentation for this class was generated from the following file:
  • acedsel.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdSolidSubentitySelector Member List

This is the complete list of members for AcEdSolidSubentitySelector, including all inherited members.

AcEdSolidSubentitySelector() (defined in AcEdSolidSubentitySelector) | AcEdSolidSubentitySelector
selectFaces(AcDbObjectId &selectedSolidId, AcArray< AcDbSubentId * > &faceSet) (defined in AcEdSolidSubentitySelector) | AcEdSolidSubentitySelector
~AcEdSolidSubentitySelector() (defined in AcEdSolidSubentitySelector) | AcEdSolidSubentitySelector


ZRX API Reference: AcEdSSGetFilter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdSSGetFilter Class Reference
AcEd Classes
+ Inheritance diagram for AcEdSSGetFilter:

Public Member Functions

virtual void | endEntsel (Acad::PromptStatus returnStatus, const AcDbObjectId &pickedEntity, const AcGePoint3d &pickedPoint, AcEdSelectionSetService &service)
virtual void | endSSGet (Acad::PromptStatus returnStatus, int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet)
virtual void | ssgetAddFailed (int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints)
virtual void | ssgetAddFilter (int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet)
virtual void | ssgetRemoveFailed (int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes)
virtual void | ssgetRemoveFilter (int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes)
- Public Member Functions inherited from AcEdInputContextReactor
virtual void | beginDragSequence (const ACHAR *promptString)
virtual void | beginEntsel (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetAngle (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetColor (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetCorner (const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetDistance (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetInteger (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetKeyword (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetOrientation (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetPoint (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetReal (const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetScaleFactor (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetString (const ACHAR *promptString, int initGetFlags)
virtual void | beginNentsel (const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginQuiescentState ()
virtual void | beginSSGet (const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask)
virtual void | endDragSequence (Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec)
virtual void | endEntsel (Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword)
virtual void | endGetAngle (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetColor (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetCorner (Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword)
virtual void | endGetDistance (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetInteger (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetKeyword (Acad::PromptStatus returnStatus, const ACHAR *&pKeyword)
virtual void | endGetOrientation (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetPoint (Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword)
virtual void | endGetReal (Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword)
virtual void | endGetScaleFactor (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetString (Acad::PromptStatus returnStatus, ACHAR *pString)
virtual void | endNentsel (Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword)
virtual void | endQuiescentState ()
virtual void | endSSGet (Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss)
The documentation for this class was generated from the following file:
  • acssgetfilter.h


ZRX API Reference: AcEdSSGetFilter2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdSSGetFilter2 Class Reference
AcEd Classes
+ Inheritance diagram for AcEdSSGetFilter2:

Public Member Functions

virtual void | ssgetRolloverFilter (const AcDbFullSubentPath &subEntityPath, AcDbFullSubentPath &highlightPath)
- Public Member Functions inherited from AcEdSSGetFilter
virtual void | endEntsel (Acad::PromptStatus returnStatus, const AcDbObjectId &pickedEntity, const AcGePoint3d &pickedPoint, AcEdSelectionSetService &service)
virtual void | endSSGet (Acad::PromptStatus returnStatus, int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet)
virtual void | ssgetAddFailed (int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints)
virtual void | ssgetAddFilter (int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet)
virtual void | ssgetRemoveFailed (int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes)
virtual void | ssgetRemoveFilter (int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes)
- Public Member Functions inherited from AcEdInputContextReactor
virtual void | beginDragSequence (const ACHAR *promptString)
virtual void | beginEntsel (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetAngle (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetColor (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetCorner (const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetDistance (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetInteger (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetKeyword (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetOrientation (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetPoint (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetReal (const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetScaleFactor (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetString (const ACHAR *promptString, int initGetFlags)
virtual void | beginNentsel (const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginQuiescentState ()
virtual void | beginSSGet (const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask)
virtual void | endDragSequence (Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec)
virtual void | endEntsel (Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword)
virtual void | endGetAngle (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetColor (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetCorner (Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword)
virtual void | endGetDistance (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetInteger (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetKeyword (Acad::PromptStatus returnStatus, const ACHAR *&pKeyword)
virtual void | endGetOrientation (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetPoint (Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword)
virtual void | endGetReal (Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword)
virtual void | endGetScaleFactor (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetString (Acad::PromptStatus returnStatus, ACHAR *pString)
virtual void | endNentsel (Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword)
virtual void | endQuiescentState ()
virtual void | endSSGet (Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss)
The documentation for this class was generated from the following file:
  • acssgetfilter.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdSSGetFilter2 Member List

This is the complete list of members for AcEdSSGetFilter2, including all inherited members.

beginDragSequence(const ACHAR *promptString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginEntsel(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetAngle(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetColor(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetCorner(const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetDistance(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetInteger(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetKeyword(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetOrientation(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetPoint(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetReal(const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetScaleFactor(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetString(const ACHAR *promptString, int initGetFlags) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginNentsel(const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginSSGet(const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endDragSequence(Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endEntsel(Acad::PromptStatus returnStatus, const AcDbObjectId &pickedEntity, const AcGePoint3d &pickedPoint, AcEdSelectionSetService &service) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
endEntsel(Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetAngle(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetColor(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetCorner(Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetDistance(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetInteger(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetKeyword(Acad::PromptStatus returnStatus, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetOrientation(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetPoint(Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetReal(Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetScaleFactor(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetString(Acad::PromptStatus returnStatus, ACHAR *pString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endNentsel(Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endSSGet(Acad::PromptStatus returnStatus, int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
endSSGet(Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
ssgetAddFailed(int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetAddFilter(int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetRemoveFailed(int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetRemoveFilter(int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetRolloverFilter(const AcDbFullSubentPath &subEntityPath, AcDbFullSubentPath &highlightPath) (defined in AcEdSSGetFilter2) | AcEdSSGetFilter2 | inlinevirtual


ZRX API Reference: AcEdSSGetFilter3 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdSSGetFilter3 Class Reference
AcEd Classes
+ Inheritance diagram for AcEdSSGetFilter3:

Public Member Functions

virtual void | ssgetRolloverFilter (const AcDbFullSubentPath &subEntityPath, AcDbFullSubentPathArray &highlightPaths)
- Public Member Functions inherited from AcEdSSGetFilter
virtual void | endEntsel (Acad::PromptStatus returnStatus, const AcDbObjectId &pickedEntity, const AcGePoint3d &pickedPoint, AcEdSelectionSetService &service)
virtual void | endSSGet (Acad::PromptStatus returnStatus, int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet)
virtual void | ssgetAddFailed (int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints)
virtual void | ssgetAddFilter (int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet)
virtual void | ssgetRemoveFailed (int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes)
virtual void | ssgetRemoveFilter (int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes)
- Public Member Functions inherited from AcEdInputContextReactor
virtual void | beginDragSequence (const ACHAR *promptString)
virtual void | beginEntsel (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetAngle (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetColor (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetCorner (const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetDistance (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetInteger (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetKeyword (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetOrientation (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetPoint (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetReal (const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetScaleFactor (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetString (const ACHAR *promptString, int initGetFlags)
virtual void | beginNentsel (const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginQuiescentState ()
virtual void | beginSSGet (const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask)
virtual void | endDragSequence (Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec)
virtual void | endEntsel (Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword)
virtual void | endGetAngle (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetColor (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetCorner (Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword)
virtual void | endGetDistance (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetInteger (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetKeyword (Acad::PromptStatus returnStatus, const ACHAR *&pKeyword)
virtual void | endGetOrientation (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetPoint (Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword)
virtual void | endGetReal (Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword)
virtual void | endGetScaleFactor (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetString (Acad::PromptStatus returnStatus, ACHAR *pString)
virtual void | endNentsel (Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword)
virtual void | endQuiescentState ()
virtual void | endSSGet (Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss)
The documentation for this class was generated from the following file:
  • acssgetfilter.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdSSGetFilter3 Member List

This is the complete list of members for AcEdSSGetFilter3, including all inherited members.

beginDragSequence(const ACHAR *promptString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginEntsel(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetAngle(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetColor(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetCorner(const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetDistance(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetInteger(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetKeyword(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetOrientation(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetPoint(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetReal(const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetScaleFactor(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetString(const ACHAR *promptString, int initGetFlags) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginNentsel(const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginSSGet(const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endDragSequence(Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endEntsel(Acad::PromptStatus returnStatus, const AcDbObjectId &pickedEntity, const AcGePoint3d &pickedPoint, AcEdSelectionSetService &service) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
endEntsel(Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetAngle(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetColor(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetCorner(Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetDistance(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetInteger(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetKeyword(Acad::PromptStatus returnStatus, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetOrientation(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetPoint(Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetReal(Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetScaleFactor(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetString(Acad::PromptStatus returnStatus, ACHAR *pString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endNentsel(Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endSSGet(Acad::PromptStatus returnStatus, int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
endSSGet(Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
ssgetAddFailed(int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetAddFilter(int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetRemoveFailed(int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetRemoveFilter(int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetRolloverFilter(const AcDbFullSubentPath &subEntityPath, AcDbFullSubentPathArray &highlightPaths) (defined in AcEdSSGetFilter3) | AcEdSSGetFilter3 | inlinevirtual


ZRX API Reference: AcEdSSGetSubSelectFilter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdSSGetSubSelectFilter Class Reference
AcEd Classes
+ Inheritance diagram for AcEdSSGetSubSelectFilter:

Public Member Functions

virtual Acad::ErrorStatus | getSubentPathsAtGsMarker (AcDbEntity *pEnt, bool bAdding, const AcDbFullSubentPathArray &selectedPaths, AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXForm, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts, AcDbObjectId *entAndInsertStack)=0
virtual void | ssgetAddFilter (int ssgetFlags, AcEdSubSelectFilterService &service, const AcDbObjectId &object, const AcDbFullSubentPathArray &selectedPaths, const AcDbFullSubentPathArray &addedPaths)=0
virtual void | ssgetRemoveFilter (int ssgetFlags, AcEdSubSelectFilterService &service, const AcDbObjectId &object, const AcDbFullSubentPathArray &selectedPaths, const AcDbFullSubentPathArray &removedPaths)=0
virtual Acad::ErrorStatus | subSelectClassList (AcArray< AcRxClass * > &classes)=0
- Public Member Functions inherited from AcEdInputContextReactor
virtual void | beginDragSequence (const ACHAR *promptString)
virtual void | beginEntsel (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetAngle (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetColor (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetCorner (const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetDistance (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetInteger (const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetKeyword (const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetOrientation (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetPoint (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetReal (const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetScaleFactor (const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginGetString (const ACHAR *promptString, int initGetFlags)
virtual void | beginNentsel (const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords)
virtual void | beginQuiescentState ()
virtual void | beginSSGet (const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask)
virtual void | endDragSequence (Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec)
virtual void | endEntsel (Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword)
virtual void | endGetAngle (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetColor (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetCorner (Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword)
virtual void | endGetDistance (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetInteger (Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword)
virtual void | endGetKeyword (Acad::PromptStatus returnStatus, const ACHAR *&pKeyword)
virtual void | endGetOrientation (Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword)
virtual void | endGetPoint (Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword)
virtual void | endGetReal (Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword)
virtual void | endGetScaleFactor (Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword)
virtual void | endGetString (Acad::PromptStatus returnStatus, ACHAR *pString)
virtual void | endNentsel (Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword)
virtual void | endQuiescentState ()
virtual void | endSSGet (Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss)
The documentation for this class was generated from the following file:
  • acssgetfilter.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdSSGetSubSelectFilter Member List

This is the complete list of members for AcEdSSGetSubSelectFilter, including all inherited members.

beginDragSequence(const ACHAR *promptString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginEntsel(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetAngle(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetColor(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetCorner(const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetDistance(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetInteger(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetKeyword(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetOrientation(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetPoint(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetReal(const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetScaleFactor(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetString(const ACHAR *promptString, int initGetFlags) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginNentsel(const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginSSGet(const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endDragSequence(Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endEntsel(Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetAngle(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetColor(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetCorner(Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetDistance(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetInteger(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetKeyword(Acad::PromptStatus returnStatus, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetOrientation(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetPoint(Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetReal(Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetScaleFactor(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetString(Acad::PromptStatus returnStatus, ACHAR *pString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endNentsel(Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endSSGet(Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
getSubentPathsAtGsMarker(AcDbEntity *pEnt, bool bAdding, const AcDbFullSubentPathArray &selectedPaths, AcDb::SubentType type, Adesk::GsMarker gsMark, const AcGePoint3d &pickPoint, const AcGeMatrix3d &viewXForm, int &numPaths, AcDbFullSubentPath *&subentPaths, int numInserts, AcDbObjectId *entAndInsertStack)=0 (defined in AcEdSSGetSubSelectFilter) | AcEdSSGetSubSelectFilter | pure virtual
ssgetAddFilter(int ssgetFlags, AcEdSubSelectFilterService &service, const AcDbObjectId &object, const AcDbFullSubentPathArray &selectedPaths, const AcDbFullSubentPathArray &addedPaths)=0 (defined in AcEdSSGetSubSelectFilter) | AcEdSSGetSubSelectFilter | pure virtual
ssgetRemoveFilter(int ssgetFlags, AcEdSubSelectFilterService &service, const AcDbObjectId &object, const AcDbFullSubentPathArray &selectedPaths, const AcDbFullSubentPathArray &removedPaths)=0 (defined in AcEdSSGetSubSelectFilter) | AcEdSSGetSubSelectFilter | pure virtual
subSelectClassList(AcArray< AcRxClass * > &classes)=0 (defined in AcEdSSGetSubSelectFilter) | AcEdSSGetSubSelectFilter | pure virtual


ZRX API Reference: AcEdSubSelectFilterService Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdSubSelectFilterService Class Reference
AcEd Classes

Public Member Functions

virtual Acad::ErrorStatus | add (resbuf *ssnameXList, const AcDbFullSubentPath &path)=0
virtual Acad::ErrorStatus | remove (bool bIsSubSelectionIndex, int index)=0
virtual Acad::ErrorStatus | ssNameX (bool bIsSubSelectionIndex, int index, resbuf *&result)=0
The documentation for this class was generated from the following file:
  • acssgetfilter.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdSubSelectFilterService Member List

This is the complete list of members for AcEdSubSelectFilterService, including all inherited members.

add(resbuf *ssnameXList, const AcDbFullSubentPath &path)=0 (defined in AcEdSubSelectFilterService) | AcEdSubSelectFilterService | pure virtual
remove(bool bIsSubSelectionIndex, int index)=0 (defined in AcEdSubSelectFilterService) | AcEdSubSelectFilterService | pure virtual
ssNameX(bool bIsSubSelectionIndex, int index, resbuf *&result)=0 (defined in AcEdSubSelectFilterService) | AcEdSubSelectFilterService | pure virtual


ZRX API Reference: AcEdUIContext Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdUIContext Class Reference
AcEd Classes
+ Inheritance diagram for AcEdUIContext:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcEdUIContext)
virtual void * | getMenuContext (const AcRxClass *, const AcDbObjectIdArray &)=0
virtual void * | getMenuContext (const AcRxClass *, const AcDbObjectIdArray &, const AcArray< AcDbFullSubentPathArray, AcArrayObjectCopyReallocator< AcDbFullSubentPathArray > > &subentIds)
virtual void | onCommand (Adesk::UInt32)=0
virtual void | OnUpdateMenu ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • aced.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdUIContext Member List

This is the complete list of members for AcEdUIContext, including all inherited members.

ACRX_DECLARE_MEMBERS(AcEdUIContext) (defined in AcEdUIContext) | AcEdUIContext |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getMenuContext(const AcRxClass *, const AcDbObjectIdArray &)=0 (defined in AcEdUIContext) | AcEdUIContext | pure virtual
getMenuContext(const AcRxClass *, const AcDbObjectIdArray &, const AcArray< AcDbFullSubentPathArray, AcArrayObjectCopyReallocator< AcDbFullSubentPathArray > > &subentIds) (defined in AcEdUIContext) | AcEdUIContext | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
onCommand(Adesk::UInt32)=0 (defined in AcEdUIContext) | AcEdUIContext | pure virtual
OnUpdateMenu() (defined in AcEdUIContext) | AcEdUIContext | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcFd Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes
AcFd Classes

Classes

class | AcFdFieldEngine
class | AcFdFieldEvaluator
class | AcFdFieldEvaluatorLoader
class | AcFdFieldReactor
class | AcFdFieldResult
class | AcFdFieldValue
class | CAcFdUiFieldDialog
class | CAcFdUiFieldDialogHook
class | CAcFdUiFieldFormatDialog
class | CAcFdUiFieldFormatList
class | CAcFdUiFieldManager
class | CAcFdUiFieldOptionDialog
class | CAcFdUiFormatDialog
class | CAcFdUiFormatList

Detailed Description


ZRX API Reference: AcFdFieldEngine Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
AcFdFieldEngine Class Reference
AcFd Classes
+ Inheritance diagram for AcFdFieldEngine:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcFdFieldEngine)
ACDB_PORT int | evaluatorLoaderCount (void) const
ACDB_PORT AcFdFieldEvaluator * | findEvaluator (AcDbField *pField, const ACHAR *&pszEvalId)
ACDB_PORT AcFdFieldEvaluator * | getEvaluator (const ACHAR *pszEvalId)
ACDB_PORT
AcFdFieldEvaluatorLoader * 		getEvaluatorLoader (int iIndex)
ACDB_PORT Acad::ErrorStatus | registerEvaluatorLoader (AcFdFieldEvaluatorLoader *pLoader)
ACDB_PORT Acad::ErrorStatus | unregisterEvaluatorLoader (AcFdFieldEvaluatorLoader *pLoader)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Attributes

void * mpImpObj

Friends

class AcFdSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • AcField.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFdFieldEngine Member List

This is the complete list of members for AcFdFieldEngine, including all inherited members.

AcFdFieldEngine() (defined in AcFdFieldEngine) | AcFdFieldEngine |
AcFdSystemInternals (defined in AcFdFieldEngine) | AcFdFieldEngine | friend
ACRX_DECLARE_MEMBERS(AcFdFieldEngine) (defined in AcFdFieldEngine) | AcFdFieldEngine |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
evaluatorLoaderCount(void) const (defined in AcFdFieldEngine) | AcFdFieldEngine |
findEvaluator(AcDbField *pField, const ACHAR *&pszEvalId) (defined in AcFdFieldEngine) | AcFdFieldEngine |
getEvaluator(const ACHAR *pszEvalId) (defined in AcFdFieldEngine) | AcFdFieldEngine |
getEvaluatorLoader(int iIndex) (defined in AcFdFieldEngine) | AcFdFieldEngine |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
mpImpObj (defined in AcFdFieldEngine) | AcFdFieldEngine | protected
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
registerEvaluatorLoader(AcFdFieldEvaluatorLoader *pLoader) (defined in AcFdFieldEngine) | AcFdFieldEngine |
unregisterEvaluatorLoader(AcFdFieldEvaluatorLoader *pLoader) (defined in AcFdFieldEngine) | AcFdFieldEngine |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcFdFieldEngine() (defined in AcFdFieldEngine) | AcFdFieldEngine | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcFdFieldEvaluator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
AcFdFieldEvaluator Class Reference
AcFd Classes
+ Inheritance diagram for AcFdFieldEvaluator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcFdFieldEvaluator)
virtual ACDB_PORT Acad::ErrorStatus | compile (AcDbField *pField, AcDbDatabase *pDb, AcFdFieldResult *pResult)
virtual ACDB_PORT Acad::ErrorStatus | evaluate (AcDbField *pField, int nContext, AcDbDatabase *pDb, AcFdFieldResult *pResult)
virtual ACDB_PORT const ACHAR * | evaluatorId (void) const
virtual ACDB_PORT const ACHAR * | evaluatorId (AcDbField *pField)
virtual ACDB_PORT Acad::ErrorStatus | format (AcDbField *pField, ACHAR *&pszValue)
virtual ACDB_PORT Acad::ErrorStatus | initialize (AcDbField *pField)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcFdFieldEvaluator (void *)

Protected Attributes

void * mpImpObj

Friends

class AcFdSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Member Function Documentation

virtual ACDB_PORT const ACHAR* AcFdFieldEvaluator::evaluatorId ( void ) const
virtual
Warning
Not implemented!
virtual ACDB_PORT const ACHAR* AcFdFieldEvaluator::evaluatorId ( AcDbField * pField )
virtual
Warning
Not implemented!
virtual ACDB_PORT Acad::ErrorStatus AcFdFieldEvaluator::format | ( | AcDbField * | pField,
 |  | ACHAR *& | pszValue
 | ) |  |
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcField.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFdFieldEvaluator Member List

This is the complete list of members for AcFdFieldEvaluator, including all inherited members.

AcFdFieldEvaluator(void) (defined in AcFdFieldEvaluator) | AcFdFieldEvaluator |
AcFdFieldEvaluator(void *) (defined in AcFdFieldEvaluator) | AcFdFieldEvaluator | protected
AcFdSystemInternals (defined in AcFdFieldEvaluator) | AcFdFieldEvaluator | friend
ACRX_DECLARE_MEMBERS(AcFdFieldEvaluator) (defined in AcFdFieldEvaluator) | AcFdFieldEvaluator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
compile(AcDbField *pField, AcDbDatabase *pDb, AcFdFieldResult *pResult) (defined in AcFdFieldEvaluator) | AcFdFieldEvaluator | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
evaluate(AcDbField *pField, int nContext, AcDbDatabase *pDb, AcFdFieldResult *pResult) (defined in AcFdFieldEvaluator) | AcFdFieldEvaluator | virtual
evaluatorId(void) const | AcFdFieldEvaluator | virtual
evaluatorId(AcDbField *pField) | AcFdFieldEvaluator | virtual
format(AcDbField *pField, ACHAR *&pszValue) | AcFdFieldEvaluator | virtual
initialize(AcDbField *pField) (defined in AcFdFieldEvaluator) | AcFdFieldEvaluator | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
mpImpObj (defined in AcFdFieldEvaluator) | AcFdFieldEvaluator | protected
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcFdFieldEvaluator(void) (defined in AcFdFieldEvaluator) | AcFdFieldEvaluator | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcFdFieldEvaluatorLoader Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
AcFdFieldEvaluatorLoader Class Reference
AcFd Classes
+ Inheritance diagram for AcFdFieldEvaluatorLoader:

Public Member Functions

ACDB_PORT | AcFdFieldEvaluatorLoader (void *)
ACRX_DECLARE_MEMBERS (AcFdFieldEvaluatorLoader)
virtual ACDB_PORT
AcFdFieldEvaluator * 		findEvaluator (AcDbField *pField, const ACHAR *&pszEvalId)
virtual ACDB_PORT
AcFdFieldEvaluator * 		getEvaluator (const ACHAR *pszEvalId)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Attributes

void * mpImpObj

Friends

class AcFdSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Member Function Documentation

virtual ACDB_PORT AcFdFieldEvaluator* AcFdFieldEvaluatorLoader::findEvaluator | ( | AcDbField * | pField,
 |  | const ACHAR *& | pszEvalId
 | ) |  |
virtual
Warning
Not implemented!
virtual ACDB_PORT AcFdFieldEvaluator* AcFdFieldEvaluatorLoader::getEvaluator ( const ACHAR * pszEvalId )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcField.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFdFieldEvaluatorLoader Member List

This is the complete list of members for AcFdFieldEvaluatorLoader, including all inherited members.

AcFdFieldEvaluatorLoader(void) (defined in AcFdFieldEvaluatorLoader) | AcFdFieldEvaluatorLoader |
AcFdFieldEvaluatorLoader(void *) (defined in AcFdFieldEvaluatorLoader) | AcFdFieldEvaluatorLoader |
AcFdSystemInternals (defined in AcFdFieldEvaluatorLoader) | AcFdFieldEvaluatorLoader | friend
ACRX_DECLARE_MEMBERS(AcFdFieldEvaluatorLoader) (defined in AcFdFieldEvaluatorLoader) | AcFdFieldEvaluatorLoader |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
findEvaluator(AcDbField *pField, const ACHAR *&pszEvalId) | AcFdFieldEvaluatorLoader | virtual
getEvaluator(const ACHAR *pszEvalId) | AcFdFieldEvaluatorLoader | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
mpImpObj (defined in AcFdFieldEvaluatorLoader) | AcFdFieldEvaluatorLoader | protected
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcFdFieldEvaluatorLoader(void) (defined in AcFdFieldEvaluatorLoader) | AcFdFieldEvaluatorLoader |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcFdFieldReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcFdFieldReactor Class Reference
AcFd Classes
+ Inheritance diagram for AcFdFieldReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcFdFieldReactor)
virtual Acad::ErrorStatus | beginEvaluateFields (int nContext, AcDbDatabase *pDb)
virtual Acad::ErrorStatus | endEvaluateFields (int nContext, AcDbDatabase *pDb)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • AcField.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFdFieldReactor Member List

This is the complete list of members for AcFdFieldReactor, including all inherited members.

ACRX_DECLARE_MEMBERS(AcFdFieldReactor) (defined in AcFdFieldReactor) | AcFdFieldReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
beginEvaluateFields(int nContext, AcDbDatabase *pDb) (defined in AcFdFieldReactor) | AcFdFieldReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
endEvaluateFields(int nContext, AcDbDatabase *pDb) (defined in AcFdFieldReactor) | AcFdFieldReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcFdFieldResult Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcFdFieldResult Class Reference
AcFd Classes
+ Inheritance diagram for AcFdFieldResult:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcFdFieldResult)
virtual ACDB_PORT Acad::ErrorStatus | setEvaluationStatus (int nStatus, int dwErrCode=0, const ACHAR *pszMsg=NULL)
virtual ACDB_PORT Acad::ErrorStatus | setFieldValue (const AcValue *pValue)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Member Function Documentation

virtual ACDB_PORT Acad::ErrorStatus AcFdFieldResult::setEvaluationStatus | ( | int | nStatus,
 |  | int | dwErrCode = 0,
 |  | const ACHAR * | pszMsg = NULL
 | ) |  |
virtual
Warning
Not implemented!
virtual ACDB_PORT Acad::ErrorStatus AcFdFieldResult::setFieldValue ( const AcValue * pValue )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcField.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFdFieldResult Member List

This is the complete list of members for AcFdFieldResult, including all inherited members.

AcFdFieldResult(void) (defined in AcFdFieldResult) | AcFdFieldResult |
ACRX_DECLARE_MEMBERS(AcFdFieldResult) (defined in AcFdFieldResult) | AcFdFieldResult |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setEvaluationStatus(int nStatus, int dwErrCode=0, const ACHAR *pszMsg=NULL) | AcFdFieldResult | virtual
setFieldValue(const AcValue *pValue) | AcFdFieldResult | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcFdFieldValue Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcFdFieldValue Class Reference
AcFd Classes
+ Inheritance diagram for AcFdFieldValue:

Public Member Functions

ACDB_PORT | AcFdFieldValue (AcFdFieldValue::DataType nDataType)
ACDB_PORT | AcFdFieldValue (const AcFdFieldValue &value)
ACDB_PORT | AcFdFieldValue (const ACHAR *pszValue)
ACDB_PORT | AcFdFieldValue (long lValue)
ACDB_PORT | AcFdFieldValue (double fValue)
ACDB_PORT | AcFdFieldValue (const __time64_t &date)
ACDB_PORT | AcFdFieldValue (const SYSTEMTIME &date)
ACDB_PORT | AcFdFieldValue (const AcGePoint2d &pt)
ACDB_PORT | AcFdFieldValue (double x, double y)
ACDB_PORT | AcFdFieldValue (const AcGePoint3d &pt)
ACDB_PORT | AcFdFieldValue (double x, double y, double z)
ACDB_PORT | AcFdFieldValue (const AcDbObjectId &id)
ACDB_PORT | AcFdFieldValue (const resbuf &rb)
ACDB_PORT | AcFdFieldValue (const AcDbEvalVariant &evalVar)
ACDB_PORT | AcFdFieldValue (const VARIANT &var)
ACDB_PORT | AcFdFieldValue (const void *pBuf, DWORD dwBufSize)
ACRX_DECLARE_MEMBERS (AcFdFieldValue)
- Public Member Functions inherited from AcValue
ACRX_DECLARE_MEMBERS (AcValue)
ACDB_PORT | AcValue (AcValue::DataType nDataType)
ACDB_PORT | AcValue (const AcValue &value)
ACDB_PORT | AcValue (const ACHAR *pszValue)
ACDB_PORT | AcValue (long lValue)
ACDB_PORT | AcValue (double fValue)
ACDB_PORT | AcValue (const __time64_t &date)
ACDB_PORT | AcValue (const SYSTEMTIME &date)
ACDB_PORT | AcValue (const AcGePoint2d &pt)
ACDB_PORT | AcValue (double x, double y)
ACDB_PORT | AcValue (const AcGePoint3d &pt)
ACDB_PORT | AcValue (double x, double y, double z)
ACDB_PORT | AcValue (const AcDbObjectId &id)
ACDB_PORT | AcValue (const resbuf &rb)
ACDB_PORT | AcValue (const AcDbEvalVariant &evalVar)
ACDB_PORT | AcValue (const VARIANT &var)
ACDB_PORT | AcValue (const AcCmColor &var)
ACDB_PORT | AcValue (const void *pBuf, DWORD dwBufSize)
ACDB_PORT bool | convertTo (AcValue::DataType nDataType, AcValue::UnitType nUnitType)
ACDB_PORT bool | convertTo (AcValue::DataType nDataType, AcValue::UnitType nUnitType, bool bResetIfIncompatible)
ACDB_PORT AcValue::DataType | dataType (void) const
Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
ACDB_PORT const ACHAR * | format (void) const
ACDB_PORT AcString | format (const ACHAR *pszFormat) const
ACDB_PORT bool | format (ACHAR *&pszValue) const
ACDB_PORT bool | format (const ACHAR *pszFormat, ACHAR *&pszValue) const
ACDB_PORT AcString | format (AcValue::FormatOption nOption)
ACDB_PORT AcString | format (const ACHAR *pszFormat, AcValue::FormatOption nOption)
ACDB_PORT bool | get (const ACHAR *&pszValue) const
ACDB_PORT bool | get (ACHAR *&pszValue) const
ACDB_PORT bool | get (long &lValue) const
ACDB_PORT bool | get (double &fValue) const
ACDB_PORT bool | get (__time64_t &date) const
ACDB_PORT bool | get (SYSTEMTIME &date) const
ACDB_PORT bool | get (AcGePoint2d &pt) const
ACDB_PORT bool | get (double &x, double &y) const
ACDB_PORT bool | get (AcGePoint3d &pt) const
ACDB_PORT bool | get (double &x, double &y, double &z) const
ACDB_PORT bool | get (AcDbObjectId &objId) const
ACDB_PORT bool | get (resbuf **pRb) const
ACDB_PORT bool | get (AcDbEvalVariant &evalVar) const
ACDB_PORT bool | get (VARIANT &var) const
ACDB_PORT bool | get (AcCmColor &clr) const
ACDB_PORT bool | get (void *&pBuf, DWORD &dwBufSize) const
ACDB_PORT const ACHAR * | getFormat (void) const
Adesk::Boolean | isEqualTo (const AcRxObject *pOther) const
ACDB_PORT bool | isValid (void) const
ACDB_PORT | operator __time64_t (void) const
ACDB_PORT | operator AcDbObjectId (void) const
ACDB_PORT | operator AcGePoint2d (void) const
ACDB_PORT | operator AcGePoint3d (void) const
ACDB_PORT | operator const ACHAR * (void) const
ACDB_PORT | operator double (void) const
ACDB_PORT | operator long (void) const
ACDB_PORT bool | operator!= (const AcValue &val) const
ACDB_PORT AcValue & | operator= (const AcValue &value)
ACDB_PORT AcValue & | operator= (const ACHAR *pszValue)
ACDB_PORT AcValue & | operator= (long lValue)
ACDB_PORT AcValue & | operator= (double fValue)
ACDB_PORT AcValue & | operator= (__time64_t date)
ACDB_PORT AcValue & | operator= (const AcGePoint2d &pt)
ACDB_PORT AcValue & | operator= (const AcGePoint3d &pt)
ACDB_PORT AcValue & | operator= (const AcDbObjectId &objId)
ACDB_PORT AcValue & | operator= (const resbuf &rb)
ACDB_PORT AcValue & | operator= (const AcDbEvalVariant &evalVar)
ACDB_PORT AcValue & | operator= (const VARIANT &var)
ACDB_PORT AcValue & | operator= (const AcCmColor &clr)
ACDB_PORT bool | operator== (const AcValue &val) const
ACDB_PORT bool | parse (const ACHAR *pszText, AcValue::DataType nDataType, AcValue::UnitType nUnitType, const ACHAR *pszFormat, AcValue::ParseOption nOption, const AcDbObjectId *pTextStyleId)
ACDB_PORT bool | reset (void)
ACDB_PORT bool | reset (AcValue::DataType nDataType)
ACDB_PORT bool | resetValue (void)
ACDB_PORT bool | set (const AcValue &value)
ACDB_PORT bool | set (const ACHAR *pszValue)
ACDB_PORT bool | set (AcValue::DataType nDataType, const ACHAR *pszValue)
ACDB_PORT bool | set (long lValue)
ACDB_PORT bool | set (double fValue)
ACDB_PORT bool | set (const __time64_t &date)
ACDB_PORT bool | set (const SYSTEMTIME &date)
ACDB_PORT bool | set (const AcGePoint2d &pt)
ACDB_PORT bool | set (double x, double y)
ACDB_PORT bool | set (const AcGePoint3d &pt)
ACDB_PORT bool | set (double x, double y, double z)
ACDB_PORT bool | set (const AcDbObjectId &objId)
ACDB_PORT bool | set (const resbuf &rb)
ACDB_PORT bool | set (const AcDbEvalVariant &evalVar)
ACDB_PORT bool | set (const VARIANT &var)
ACDB_PORT bool | set (const AcCmColor &clr)
ACDB_PORT bool | set (const void *pBuf, DWORD dwBufSize)
ACDB_PORT bool | setFormat (const ACHAR *pszFormat)
ACDB_PORT bool | setUnitType (AcValue::UnitType nUnitType)
ACDB_PORT AcValue::UnitType | unitType (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcValue
enum DataType {
kUnknown = 0, kLong = (0x1 << 0), kDouble = (0x1 << 1), kString = (0x1 << 2),
kDate = (0x1 << 3), kPoint = (0x1 << 4), k3dPoint = (0x1 << 5), kObjectId = (0x1 << 6),
kBuffer = (0x1 << 7), kResbuf = (0x1 << 8), kGeneral = (0x1 << 9), kColor = (0x1 << 10)
}
enum FormatOption {
kFormatOptionNone = 0, kForEditing = (0x1 << 0), kForExpression = (0x1 << 1), kUseMaximumPrecision = (0x1 << 2),
kIgnoreMtextFormat = (0x1 << 3)
}
enum ParseOption {
kParseOptionNone = 0, kSetDefaultFormat = (0x1 << 0), kPreserveMtextFormat = (0x1 << 1), kConvertTextToValue = (0x1 << 2),
kChangeDataType = (0x1 << 3), kParseTextForFieldCode = (0x1 << 4)
}
enum UnitType {
kUnitless = 0, kDistance = (0x1 << 0), kAngle = (0x1 << 1), kArea = (0x1 << 2),
kVolume = (0x1 << 3), kCurrency = (0x1 << 4), kPercentage = (0x1 << 5)
}
- Static Public Member Functions inherited from AcValue
static bool | isValidDataType (const VARIANT &var)
- Protected Attributes inherited from AcValue
void * | mpImpObj

Constructor & Destructor Documentation

ACDB_PORT AcFdFieldValue::AcFdFieldValue ( const __time64_t & date )
Warning
Not implemented!
ACDB_PORT AcFdFieldValue::AcFdFieldValue | ( | double | x,
 |  | double | y
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcField.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFdFieldValue Member List

This is the complete list of members for AcFdFieldValue, including all inherited members.

AcFdFieldValue(void) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(AcFdFieldValue::DataType nDataType) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(const AcFdFieldValue &value) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(const ACHAR *pszValue) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(long lValue) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(double fValue) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(const __time64_t &date) | AcFdFieldValue |
AcFdFieldValue(const SYSTEMTIME &date) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(const AcGePoint2d &pt) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(double x, double y) | AcFdFieldValue |
AcFdFieldValue(const AcGePoint3d &pt) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(double x, double y, double z) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(const AcDbObjectId &id) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(const resbuf &rb) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(const AcDbEvalVariant &evalVar) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(const VARIANT &var) (defined in AcFdFieldValue) | AcFdFieldValue |
AcFdFieldValue(const void *pBuf, DWORD dwBufSize) (defined in AcFdFieldValue) | AcFdFieldValue |
ACRX_DECLARE_MEMBERS(AcFdFieldValue) (defined in AcFdFieldValue) | AcFdFieldValue |
ACRX_DECLARE_MEMBERS(AcValue) (defined in AcValue) | AcValue |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
AcValue(void) (defined in AcValue) | AcValue |
AcValue(AcValue::DataType nDataType) (defined in AcValue) | AcValue |
AcValue(const AcValue &value) (defined in AcValue) | AcValue |
AcValue(const ACHAR *pszValue) (defined in AcValue) | AcValue |
AcValue(long lValue) (defined in AcValue) | AcValue |
AcValue(double fValue) (defined in AcValue) | AcValue |
AcValue(const __time64_t &date) (defined in AcValue) | AcValue |
AcValue(const SYSTEMTIME &date) (defined in AcValue) | AcValue |
AcValue(const AcGePoint2d &pt) (defined in AcValue) | AcValue |
AcValue(double x, double y) (defined in AcValue) | AcValue |
AcValue(const AcGePoint3d &pt) (defined in AcValue) | AcValue |
AcValue(double x, double y, double z) (defined in AcValue) | AcValue |
AcValue(const AcDbObjectId &id) (defined in AcValue) | AcValue |
AcValue(const resbuf &rb) (defined in AcValue) | AcValue |
AcValue(const AcDbEvalVariant &evalVar) (defined in AcValue) | AcValue |
AcValue(const VARIANT &var) (defined in AcValue) | AcValue |
AcValue(const AcCmColor &var) (defined in AcValue) | AcValue |
AcValue(const void *pBuf, DWORD dwBufSize) (defined in AcValue) | AcValue |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertTo(AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcValue) | AcValue |
convertTo(AcValue::DataType nDataType, AcValue::UnitType nUnitType, bool bResetIfIncompatible) (defined in AcValue) | AcValue |
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
dataType(void) const (defined in AcValue) | AcValue |
DataType enum name (defined in AcValue) | AcValue |
desc() (defined in AcRxObject) | AcRxObject | static
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcValue) | AcValue |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcValue) | AcValue |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcValue) | AcValue |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcValue) | AcValue |
format(void) const (defined in AcValue) | AcValue |
format(const ACHAR *pszFormat) const (defined in AcValue) | AcValue |
format(ACHAR *&pszValue) const (defined in AcValue) | AcValue |
format(const ACHAR *pszFormat, ACHAR *&pszValue) const (defined in AcValue) | AcValue |
format(AcValue::FormatOption nOption) (defined in AcValue) | AcValue |
format(const ACHAR *pszFormat, AcValue::FormatOption nOption) (defined in AcValue) | AcValue |
FormatOption enum name (defined in AcValue) | AcValue |
get(const ACHAR *&pszValue) const (defined in AcValue) | AcValue |
get(ACHAR *&pszValue) const (defined in AcValue) | AcValue |
get(long &lValue) const (defined in AcValue) | AcValue |
get(double &fValue) const (defined in AcValue) | AcValue |
get(__time64_t &date) const (defined in AcValue) | AcValue |
get(SYSTEMTIME &date) const (defined in AcValue) | AcValue |
get(AcGePoint2d &pt) const (defined in AcValue) | AcValue |
get(double &x, double &y) const (defined in AcValue) | AcValue |
get(AcGePoint3d &pt) const (defined in AcValue) | AcValue |
get(double &x, double &y, double &z) const (defined in AcValue) | AcValue |
get(AcDbObjectId &objId) const (defined in AcValue) | AcValue |
get(resbuf **pRb) const (defined in AcValue) | AcValue |
get(AcDbEvalVariant &evalVar) const (defined in AcValue) | AcValue |
get(VARIANT &var) const (defined in AcValue) | AcValue |
get(AcCmColor &clr) const (defined in AcValue) | AcValue |
get(void *&pBuf, DWORD &dwBufSize) const (defined in AcValue) | AcValue |
getFormat(void) const (defined in AcValue) | AcValue |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *pOther) const (defined in AcValue) | AcValue | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isValid(void) const (defined in AcValue) | AcValue |
isValidDataType(const VARIANT &var) (defined in AcValue) | AcValue | static
k3dPoint enum value (defined in AcValue) | AcValue |
kAngle enum value (defined in AcValue) | AcValue |
kArea enum value (defined in AcValue) | AcValue |
kBuffer enum value (defined in AcValue) | AcValue |
kChangeDataType enum value (defined in AcValue) | AcValue |
kColor enum value (defined in AcValue) | AcValue |
kConvertTextToValue enum value (defined in AcValue) | AcValue |
kCurrency enum value (defined in AcValue) | AcValue |
kDate enum value (defined in AcValue) | AcValue |
kDistance enum value (defined in AcValue) | AcValue |
kDouble enum value (defined in AcValue) | AcValue |
kForEditing enum value (defined in AcValue) | AcValue |
kForExpression enum value (defined in AcValue) | AcValue |
kFormatOptionNone enum value (defined in AcValue) | AcValue |
kGeneral enum value (defined in AcValue) | AcValue |
kIgnoreMtextFormat enum value (defined in AcValue) | AcValue |
kLong enum value (defined in AcValue) | AcValue |
kObjectId enum value (defined in AcValue) | AcValue |
kParseOptionNone enum value (defined in AcValue) | AcValue |
kParseTextForFieldCode enum value (defined in AcValue) | AcValue |
kPercentage enum value (defined in AcValue) | AcValue |
kPoint enum value (defined in AcValue) | AcValue |
kPreserveMtextFormat enum value (defined in AcValue) | AcValue |
kResbuf enum value (defined in AcValue) | AcValue |
kSetDefaultFormat enum value (defined in AcValue) | AcValue |
kString enum value (defined in AcValue) | AcValue |
kUnitless enum value (defined in AcValue) | AcValue |
kUnknown enum value (defined in AcValue) | AcValue |
kUseMaximumPrecision enum value (defined in AcValue) | AcValue |
kVolume enum value (defined in AcValue) | AcValue |
mpImpObj (defined in AcValue) | AcValue | protected
operator __time64_t(void) const (defined in AcValue) | AcValue |
operator AcDbObjectId(void) const (defined in AcValue) | AcValue |
operator AcGePoint2d(void) const (defined in AcValue) | AcValue |
operator AcGePoint3d(void) const (defined in AcValue) | AcValue |
operator const ACHAR *(void) const (defined in AcValue) | AcValue |
operator double(void) const (defined in AcValue) | AcValue |
operator long(void) const (defined in AcValue) | AcValue |
operator!=(const AcValue &val) const (defined in AcValue) | AcValue |
operator=(const AcValue &value) (defined in AcValue) | AcValue |
operator=(const ACHAR *pszValue) (defined in AcValue) | AcValue |
operator=(long lValue) (defined in AcValue) | AcValue |
operator=(double fValue) (defined in AcValue) | AcValue |
operator=(__time64_t date) (defined in AcValue) | AcValue |
operator=(const AcGePoint2d &pt) (defined in AcValue) | AcValue |
operator=(const AcGePoint3d &pt) (defined in AcValue) | AcValue |
operator=(const AcDbObjectId &objId) (defined in AcValue) | AcValue |
operator=(const resbuf &rb) (defined in AcValue) | AcValue |
operator=(const AcDbEvalVariant &evalVar) (defined in AcValue) | AcValue |
operator=(const VARIANT &var) (defined in AcValue) | AcValue |
operator=(const AcCmColor &clr) (defined in AcValue) | AcValue |
operator==(const AcValue &val) const (defined in AcValue) | AcValue |
parse(const ACHAR *pszText, AcValue::DataType nDataType, AcValue::UnitType nUnitType, const ACHAR *pszFormat, AcValue::ParseOption nOption, const AcDbObjectId *pTextStyleId) (defined in AcValue) | AcValue |
ParseOption enum name (defined in AcValue) | AcValue |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reset(void) (defined in AcValue) | AcValue |
reset(AcValue::DataType nDataType) (defined in AcValue) | AcValue |
resetValue(void) (defined in AcValue) | AcValue |
set(const AcValue &value) (defined in AcValue) | AcValue |
set(const ACHAR *pszValue) (defined in AcValue) | AcValue |
set(AcValue::DataType nDataType, const ACHAR *pszValue) (defined in AcValue) | AcValue |
set(long lValue) (defined in AcValue) | AcValue |
set(double fValue) (defined in AcValue) | AcValue |
set(const __time64_t &date) (defined in AcValue) | AcValue |
set(const SYSTEMTIME &date) (defined in AcValue) | AcValue |
set(const AcGePoint2d &pt) (defined in AcValue) | AcValue |
set(double x, double y) (defined in AcValue) | AcValue |
set(const AcGePoint3d &pt) (defined in AcValue) | AcValue |
set(double x, double y, double z) (defined in AcValue) | AcValue |
set(const AcDbObjectId &objId) (defined in AcValue) | AcValue |
set(const resbuf &rb) (defined in AcValue) | AcValue |
set(const AcDbEvalVariant &evalVar) (defined in AcValue) | AcValue |
set(const VARIANT &var) (defined in AcValue) | AcValue |
set(const AcCmColor &clr) (defined in AcValue) | AcValue |
set(const void *pBuf, DWORD dwBufSize) (defined in AcValue) | AcValue |
setFormat(const ACHAR *pszFormat) (defined in AcValue) | AcValue |
setUnitType(AcValue::UnitType nUnitType) (defined in AcValue) | AcValue |
UnitType enum name (defined in AcValue) | AcValue |
unitType(void) const (defined in AcValue) | AcValue |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~AcValue(void) (defined in AcValue) | AcValue |


ZRX API Reference: CAcFdUiFieldDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAcFdUiFieldDialog Class Reference
AcFd Classes
+ Inheritance diagram for CAcFdUiFieldDialog:

Public Member Functions

void | BeginEditorCommand (void)
CAcFdUiFieldDialog (CWnd *pParent=NULL)
void | CancelEditorCommand (void)
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
INT_PTR | DoModal (AcDbField *&pField, BOOL bEdit, AcDbDatabase *pDb)
BOOL | GetCurrentField (UINT *pFieldId, UINT *pCatId) const
CString | GetFieldCode (void) const
CEdit * | GetFieldCodeEditCtrl (void)
AcDbField * | GetFieldToEdit (void) const
CAcFdUiFieldOptionDialog * | GetOptionDialog (void) const
BOOL | IsFieldCodeDirty (void)
BOOL | SelectField (UINT uFieldId, UINT uCatId)
BOOL | SetFieldCode (LPCTSTR pszExpr)
BOOL | SetFieldCodeReadOnly (BOOL bReadOnly=TRUE)
virtual | ~CAcFdUiFieldDialog ()
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
afx_msg LRESULT | OnBeginFormatExDialog (WPARAM wParam, LPARAM lParam)
virtual void | OnCancel (void)
afx_msg void | OnCbnSelChangeCategoryList (void)
afx_msg void | OnDialogHelp (void)
afx_msg void | OnEnChangeFieldCode (void)
afx_msg LRESULT | OnEndFormatExDialog (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnFormatChanged (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnInitDialog (void)
afx_msg void | OnLbnSelChangeFieldNameList (void)
virtual void | OnOK (void)
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
- Protected Member Functions inherited from CAdUiBaseDialog
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Protected Attributes

void * | mpImpObj
- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Protected Attributes inherited from CAdUiBaseDialog
BOOL | m_bUseTips
ADUI_COMMAND_STATE | m_commandState
CString | m_contextHelpFileName
CString | m_contextHelpFullPathName
CString | m_contextHelpPrefix
HINSTANCE | m_hDialogResource
HICON | m_hIcon
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey

Friends

class AcFdUiSystemInternals

Additional Inherited Members

- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist

Constructor & Destructor Documentation

CAcFdUiFieldDialog::CAcFdUiFieldDialog ( CWnd * pParent = NULL )
Warning
Not implemented!
virtual CAcFdUiFieldDialog::~CAcFdUiFieldDialog ( )
virtual
Warning
Not implemented!

Member Function Documentation

void CAcFdUiFieldDialog::BeginEditorCommand ( void )
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

void CAcFdUiFieldDialog::CancelEditorCommand ( void )
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

void CAcFdUiFieldDialog::CompleteEditorCommand ( BOOL restoreDialogs = TRUE )
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

virtual void CAcFdUiFieldDialog::DoDataExchange ( CDataExchange * pDX )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiDialog.

INT_PTR CAcFdUiFieldDialog::DoModal | ( | AcDbField *& | pField,
 |  | BOOL | bEdit,
 |  | AcDbDatabase * | pDb
 | ) |  |
Warning
Not implemented!
BOOL CAcFdUiFieldDialog::GetCurrentField | ( | UINT * | pFieldId,
 |  | UINT * | pCatId
 | ) |  | const
Warning
Not implemented!
CString CAcFdUiFieldDialog::GetFieldCode ( void ) const
Warning
Not implemented!
CEdit* CAcFdUiFieldDialog::GetFieldCodeEditCtrl ( void )
Warning
Not implemented!
AcDbField* CAcFdUiFieldDialog::GetFieldToEdit ( void ) const
Warning
Not implemented!
CAcFdUiFieldOptionDialog* CAcFdUiFieldDialog::GetOptionDialog ( void ) const
Warning
Not implemented!
BOOL CAcFdUiFieldDialog::IsFieldCodeDirty ( void )
Warning
Not implemented!
afx_msg LRESULT CAcFdUiFieldDialog::OnBeginFormatExDialog | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |
protected
Warning
Not implemented!
virtual void CAcFdUiFieldDialog::OnCancel ( void )
protectedvirtual
Warning
Not implemented!
afx_msg void CAcFdUiFieldDialog::OnCbnSelChangeCategoryList ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFieldDialog::OnDialogHelp ( void )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiDialog.

afx_msg void CAcFdUiFieldDialog::OnEnChangeFieldCode ( void )
protected
Warning
Not implemented!
afx_msg LRESULT CAcFdUiFieldDialog::OnEndFormatExDialog | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |
protected
Warning
Not implemented!
afx_msg LRESULT CAcFdUiFieldDialog::OnFormatChanged | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |
protected
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialog::OnInitDialog ( void )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

afx_msg void CAcFdUiFieldDialog::OnLbnSelChangeFieldNameList ( void )
protected
Warning
Not implemented!
virtual void CAcFdUiFieldDialog::OnOK ( void )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiDialog.

BOOL CAcFdUiFieldDialog::SelectField | ( | UINT | uFieldId,
 |  | UINT | uCatId
 | ) |  |
Warning
Not implemented!
BOOL CAcFdUiFieldDialog::SetFieldCode ( LPCTSTR pszExpr )
Warning
Not implemented!
BOOL CAcFdUiFieldDialog::SetFieldCodeReadOnly ( BOOL bReadOnly = TRUE )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acfduifielddialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcFdUiFieldDialog Member List

This is the complete list of members for CAcFdUiFieldDialog, including all inherited members.

AcFdUiSystemInternals (defined in CAcFdUiFieldDialog) | CAcFdUiFieldDialog | friend
AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand(void) | CAcFdUiFieldDialog |
CAcFdUiFieldDialog(CWnd *pParent=NULL) | CAcFdUiFieldDialog |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CancelEditorCommand(void) | CAcFdUiFieldDialog |
CompleteEditorCommand(BOOL restoreDialogs=TRUE) | CAcFdUiFieldDialog |
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) | CAcFdUiFieldDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal(AcDbField *&pField, BOOL bEdit, AcDbDatabase *pDb) | CAcFdUiFieldDialog |
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetCurrentField(UINT *pFieldId, UINT *pCatId) const | CAcFdUiFieldDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetFieldCode(void) const | CAcFdUiFieldDialog |
GetFieldCodeEditCtrl(void) | CAcFdUiFieldDialog |
GetFieldToEdit(void) const | CAcFdUiFieldDialog |
GetOptionDialog(void) const | CAcFdUiFieldDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAdUiDialog) | CAdUiDialog |
IsFieldCodeDirty(void) | CAcFdUiFieldDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
mpImpObj (defined in CAcFdUiFieldDialog) | CAcFdUiFieldDialog | protected
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnBeginFormatExDialog(WPARAM wParam, LPARAM lParam) | CAcFdUiFieldDialog | protected
OnCancel(void) | CAcFdUiFieldDialog | protectedvirtual
OnCbnSelChangeCategoryList(void) | CAcFdUiFieldDialog | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDialogHelp(void) | CAcFdUiFieldDialog | protectedvirtual
OnEnChangeFieldCode(void) | CAcFdUiFieldDialog | protected
OnEndFormatExDialog(WPARAM wParam, LPARAM lParam) | CAcFdUiFieldDialog | protected
OnFormatChanged(WPARAM wParam, LPARAM lParam) | CAcFdUiFieldDialog | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog(void) | CAcFdUiFieldDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnLbnSelChangeFieldNameList(void) | CAcFdUiFieldDialog | protected
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK(void) | CAcFdUiFieldDialog | protectedvirtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDialog) | CAdUiDialog | protected
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SelectField(UINT uFieldId, UINT uCatId) | CAcFdUiFieldDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetFieldCode(LPCTSTR pszExpr) | CAcFdUiFieldDialog |
SetFieldCodeReadOnly(BOOL bReadOnly=TRUE) | CAcFdUiFieldDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAcFdUiFieldDialog() | CAcFdUiFieldDialog | virtual
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAcFdUiFieldDialogHook Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAcFdUiFieldDialogHook Class Reference
AcFd Classes

Public Member Functions

virtual BOOL | BeginFieldDialog (CAcFdUiFieldDialog *pFieldDlg, AcDbDatabase *pDb, int nContext)
CAcFdUiFieldDialogHook (void)
virtual BOOL | CreateField (UINT uFieldId, AcDbField *&pField)
virtual BOOL | CreateInstance (CAcFdUiFieldDialogHook *&pHook)
virtual BOOL | EndFieldDialog (int nRet)
virtual BOOL | GetCategoryNames (UINT uMinUnusedCatId, CStringArray &catNames, CUIntArray &catIds)
AcDbDatabase * | GetDatabase (void) const
virtual int | GetEvaluatorIds (CStringArray &evalIds)
virtual BOOL | GetFieldNames (UINT uCatId, UINT uMinUnusedFieldId, CStringArray &fieldNames, CUIntArray &fieldIds, BOOL &bSort)
virtual BOOL | GetOptionDialog (UINT uFieldId, CAcFdUiFieldOptionDialog *&pOptionDlg)
virtual CString | GetPreview (LPCTSTR pszFormatType, LPCTSTR pszFormat)
virtual BOOL | OnFieldSelected (UINT uFieldId)
virtual BOOL | SetFieldToEdit (AcDbField *pField)
virtual BOOL | UpdateFieldCode (void)
~CAcFdUiFieldDialogHook (void)

Protected Attributes

void * mpImpObj

Friends

class AcFdUiSystemInternals

Constructor & Destructor Documentation

CAcFdUiFieldDialogHook::CAcFdUiFieldDialogHook ( void )
Warning
Not implemented!
CAcFdUiFieldDialogHook::~CAcFdUiFieldDialogHook ( void )
Warning
Not implemented!

Member Function Documentation

virtual BOOL CAcFdUiFieldDialogHook::BeginFieldDialog | ( | CAcFdUiFieldDialog * | pFieldDlg,
 |  | AcDbDatabase * | pDb,
 |  | int | nContext
 | ) |  |
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialogHook::CreateField | ( | UINT | uFieldId,
 |  | AcDbField *& | pField
 | ) |  |
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialogHook::CreateInstance ( CAcFdUiFieldDialogHook *& pHook )
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialogHook::EndFieldDialog ( int nRet )
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialogHook::GetCategoryNames | ( | UINT | uMinUnusedCatId,
 |  | CStringArray & | catNames,
 |  | CUIntArray & | catIds
 | ) |  |
virtual
Warning
Not implemented!
AcDbDatabase* CAcFdUiFieldDialogHook::GetDatabase ( void ) const
Warning
Not implemented!
virtual int CAcFdUiFieldDialogHook::GetEvaluatorIds ( CStringArray & evalIds )
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialogHook::GetFieldNames | ( | UINT | uCatId,
 |  | UINT | uMinUnusedFieldId,
 |  | CStringArray & | fieldNames,
 |  | CUIntArray & | fieldIds,
 |  | BOOL & | bSort
 | ) |  |
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialogHook::GetOptionDialog | ( | UINT | uFieldId,
 |  | CAcFdUiFieldOptionDialog *& | pOptionDlg
 | ) |  |
virtual
Warning
Not implemented!
virtual CString CAcFdUiFieldDialogHook::GetPreview | ( | LPCTSTR | pszFormatType,
 |  | LPCTSTR | pszFormat
 | ) |  |
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialogHook::OnFieldSelected ( UINT uFieldId )
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialogHook::SetFieldToEdit ( AcDbField * pField )
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldDialogHook::UpdateFieldCode ( void )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acfduifielddialoghook.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcFdUiFieldDialogHook Member List

This is the complete list of members for CAcFdUiFieldDialogHook, including all inherited members.

AcFdUiSystemInternals (defined in CAcFdUiFieldDialogHook) | CAcFdUiFieldDialogHook | friend
BeginFieldDialog(CAcFdUiFieldDialog *pFieldDlg, AcDbDatabase *pDb, int nContext) | CAcFdUiFieldDialogHook | virtual
CAcFdUiFieldDialogHook(void) | CAcFdUiFieldDialogHook |
CreateField(UINT uFieldId, AcDbField *&pField) | CAcFdUiFieldDialogHook | virtual
CreateInstance(CAcFdUiFieldDialogHook *&pHook) | CAcFdUiFieldDialogHook | virtual
EndFieldDialog(int nRet) | CAcFdUiFieldDialogHook | virtual
GetCategoryNames(UINT uMinUnusedCatId, CStringArray &catNames, CUIntArray &catIds) | CAcFdUiFieldDialogHook | virtual
GetDatabase(void) const | CAcFdUiFieldDialogHook |
GetEvaluatorIds(CStringArray &evalIds) | CAcFdUiFieldDialogHook | virtual
GetFieldNames(UINT uCatId, UINT uMinUnusedFieldId, CStringArray &fieldNames, CUIntArray &fieldIds, BOOL &bSort) | CAcFdUiFieldDialogHook | virtual
GetOptionDialog(UINT uFieldId, CAcFdUiFieldOptionDialog *&pOptionDlg) | CAcFdUiFieldDialogHook | virtual
GetPreview(LPCTSTR pszFormatType, LPCTSTR pszFormat) | CAcFdUiFieldDialogHook | virtual
mpImpObj (defined in CAcFdUiFieldDialogHook) | CAcFdUiFieldDialogHook | protected
OnFieldSelected(UINT uFieldId) | CAcFdUiFieldDialogHook | virtual
SetFieldToEdit(AcDbField *pField) | CAcFdUiFieldDialogHook | virtual
UpdateFieldCode(void) | CAcFdUiFieldDialogHook | virtual
~CAcFdUiFieldDialogHook(void) | CAcFdUiFieldDialogHook |


ZRX API Reference: CAcFdUiFieldFormatDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcFdUiFieldFormatDialog Class Reference
AcFd Classes
+ Inheritance diagram for CAcFdUiFieldFormatDialog:

Additional Inherited Members

- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Public Member Functions inherited from CAcFdUiFormatDialog
CAcFdUiFormatDialog (CWnd *pParent, BOOL bNew)
virtual BOOL | Create (CWnd *pParent)
int | GetCurrentFormat (CString &sDisplayName, CString &sFormatString, CString &sVersion) const
CAcFdUiFormatList * | GetFormatList (void)
CString | GetFormatType (void) const
BOOL | SetCurrentFormat (LPCTSTR pszDisplayName, LPCTSTR pszFormatString)
BOOL | SetDialogStyle (int nStyle)
BOOL | SetFormatPreviewLabel (LPCTSTR pszText)
BOOL | SetFormatPreviewReadOnly (BOOL bReadOnly=TRUE)
BOOL | SetFormatPreviewText (LPCTSTR pszPreviewText, const AcValue &fieldValue)
BOOL | SetFormatType (LPCTSTR pszFormatType)
virtual | ~CAcFdUiFormatDialog ()
- Protected Member Functions inherited from CAcFdUiFormatDialog
virtual void | DoDataExchange (CDataExchange *pDX)
afx_msg void | OnBnClickedAdditionalFormat (void)
afx_msg void | OnBnClickedAppendSymbol (void)
afx_msg void | OnBnClickedFilenameOnly (void)
afx_msg void | OnBnClickedFormatEx (void)
afx_msg void | OnBnClickedIncludeExtension (void)
afx_msg void | OnBnClickedPathAndFilename (void)
afx_msg void | OnBnClickedPathOnly (void)
afx_msg void | OnBnClickedPointX (void)
afx_msg void | OnBnClickedPointY (void)
afx_msg void | OnBnClickedPointZ (void)
afx_msg void | OnCbnEditChangeListSeparator (void)
afx_msg void | OnCbnSelChangeCurrencySymbol (void)
afx_msg void | OnCbnSelChangeDecimalSeparator (void)
afx_msg void | OnCbnSelChangeListSeparator (void)
afx_msg void | OnCbnSelChangePrecision (void)
afx_msg void | OnDestroy (void)
afx_msg void | OnEnChangePreview (void)
afx_msg void | OnLbnSelChangeFormatList (void)
afx_msg void | OnLbnSelChangeNegativeNumberList (void)
- Protected Attributes inherited from CAcFdUiFormatDialog
void * | mpImpObj
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist
The documentation for this class was generated from the following file:
  • acfduifieldformatdialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcFdUiFieldFormatDialog Member List

This is the complete list of members for CAcFdUiFieldFormatDialog, including all inherited members.

AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAcFdUiFormatDialog(CWnd *pParent, BOOL bNew) | CAcFdUiFormatDialog |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(CWnd *pParent) | CAcFdUiFormatDialog | virtual
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) | CAcFdUiFormatDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetCurrentFormat(CString &sDisplayName, CString &sFormatString, CString &sVersion) const | CAcFdUiFormatDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetFormatList(void) | CAcFdUiFormatDialog |
GetFormatType(void) const | CAcFdUiFormatDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAdUiDialog) | CAdUiDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
mpImpObj (defined in CAcFdUiFormatDialog) | CAcFdUiFormatDialog | protected
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnBnClickedAdditionalFormat(void) | CAcFdUiFormatDialog | protected
OnBnClickedAppendSymbol(void) | CAcFdUiFormatDialog | protected
OnBnClickedFilenameOnly(void) | CAcFdUiFormatDialog | protected
OnBnClickedFormatEx(void) | CAcFdUiFormatDialog | protected
OnBnClickedIncludeExtension(void) | CAcFdUiFormatDialog | protected
OnBnClickedPathAndFilename(void) | CAcFdUiFormatDialog | protected
OnBnClickedPathOnly(void) | CAcFdUiFormatDialog | protected
OnBnClickedPointX(void) | CAcFdUiFormatDialog | protected
OnBnClickedPointY(void) | CAcFdUiFormatDialog | protected
OnBnClickedPointZ(void) | CAcFdUiFormatDialog | protected
OnCbnEditChangeListSeparator(void) | CAcFdUiFormatDialog | protected
OnCbnSelChangeCurrencySymbol(void) | CAcFdUiFormatDialog | protected
OnCbnSelChangeDecimalSeparator(void) | CAcFdUiFormatDialog | protected
OnCbnSelChangeListSeparator(void) | CAcFdUiFormatDialog | protected
OnCbnSelChangePrecision(void) | CAcFdUiFormatDialog | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDestroy(void) | CAcFdUiFormatDialog | protected
OnDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
OnEnChangePreview(void) | CAcFdUiFormatDialog | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnLbnSelChangeFormatList(void) | CAcFdUiFormatDialog | protected
OnLbnSelChangeNegativeNumberList(void) | CAcFdUiFormatDialog | protected
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDialog) | CAdUiDialog | protected
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetCurrentFormat(LPCTSTR pszDisplayName, LPCTSTR pszFormatString) | CAcFdUiFormatDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogStyle(int nStyle) | CAcFdUiFormatDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetFormatPreviewLabel(LPCTSTR pszText) | CAcFdUiFormatDialog |
SetFormatPreviewReadOnly(BOOL bReadOnly=TRUE) | CAcFdUiFormatDialog |
SetFormatPreviewText(LPCTSTR pszPreviewText, const AcValue &fieldValue) | CAcFdUiFormatDialog |
SetFormatType(LPCTSTR pszFormatType) | CAcFdUiFormatDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAcFdUiFormatDialog() | CAcFdUiFormatDialog | virtual
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAcFdUiFieldFormatList Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcFdUiFieldFormatList Class Reference
AcFd Classes
+ Inheritance diagram for CAcFdUiFieldFormatList:

Additional Inherited Members

- Public Member Functions inherited from CAcFdUiFormatList
CAcFdUiFormatList (void)
int | GetCurrentFormat (CString &sDisplayName, CString &sFormatString) const
CString | GetFormatType (void) const
BOOL | Refresh (void)
BOOL | SetCurrentFormat (LPCTSTR pszDisplayName, LPCTSTR pszFormatString)
BOOL | SetFormatType (LPCTSTR pszFormatType)
void | SetPersistency (BOOL bPersist)
void | SetRootKey (LPCTSTR pszKey)
virtual | ~CAcFdUiFormatList (void)
- Protected Member Functions inherited from CAcFdUiFormatList
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnDestroy (void)
- Protected Attributes inherited from CAcFdUiFormatList
void * | mpImpObj
The documentation for this class was generated from the following file:
  • acfduifieldformatlist.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcFdUiFieldFormatList Member List

This is the complete list of members for CAcFdUiFieldFormatList, including all inherited members.

CAcFdUiFormatList(void) | CAcFdUiFormatList |
CAdUiListBox() (defined in CAdUiListBox) | CAdUiListBox |
CompareItem(LPCOMPAREITEMSTRUCT lpCompareItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
DeleteItem(LPDELETEITEMSTRUCT lpDeleteItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
GetAdUiParent() (defined in CAdUiListBox) | CAdUiListBox |
GetComboBox() (defined in CAdUiListBox) | CAdUiListBox |
GetComboBoxDraw() (defined in CAdUiListBox) | CAdUiListBox |
GetContentExtent(int item, LPCTSTR text, int &width, int &height) (defined in CAdUiListBox) | CAdUiListBox | virtual
GetCurrentFormat(CString &sDisplayName, CString &sFormatString) const | CAcFdUiFormatList |
GetFormatType(void) const | CAcFdUiFormatList |
GetItemAtPoint(CPoint &p) (defined in CAdUiListBox) | CAdUiListBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiListBox) | CAdUiListBox |
IsOwnerDraw() (defined in CAdUiListBox) | CAdUiListBox |
m_aduiParent (defined in CAdUiListBox) | CAdUiListBox | protected
m_bComboBoxDraw (defined in CAdUiListBox) | CAdUiListBox | protected
m_lastMousePoint (defined in CAdUiListBox) | CAdUiListBox | protected
m_pComboBox (defined in CAdUiListBox) | CAdUiListBox | protected
m_tipItem (defined in CAdUiListBox) | CAdUiListBox | protected
m_tipRect (defined in CAdUiListBox) | CAdUiListBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
mpImpObj (defined in CAcFdUiFormatList) | CAcFdUiFormatList | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiListBox) | CAdUiListBox | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcFdUiFormatList) | CAcFdUiFormatList | protected
OnDestroy(void) (defined in CAcFdUiFormatList) | CAcFdUiFormatList | protected
OnDrawTip(CDC &dc) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiListBox) | CAdUiListBox | protected
Refresh(void) | CAcFdUiFormatList |
SetAdUiParent(CWnd *w) (defined in CAdUiListBox) | CAdUiListBox |
SetComboBox(CAdUiComboBox *control) (defined in CAdUiListBox) | CAdUiListBox |
SetComboBoxDraw(BOOL comboBoxDraw) (defined in CAdUiListBox) | CAdUiListBox |
SetCurrentFormat(LPCTSTR pszDisplayName, LPCTSTR pszFormatString) | CAcFdUiFormatList |
SetFormatType(LPCTSTR pszFormatType) | CAcFdUiFormatList |
SetPersistency(BOOL bPersist) | CAcFdUiFormatList |
SetRootKey(LPCTSTR pszKey) | CAcFdUiFormatList |
~CAcFdUiFormatList(void) | CAcFdUiFormatList | virtual
~CAdUiListBox() (defined in CAdUiListBox) | CAdUiListBox | virtual


ZRX API Reference: CAcFdUiFieldManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAcFdUiFieldManager Class Reference
AcFd Classes

Public Member Functions

CAcFdUiFieldManager (void)
int | GetRegisteredDialogHooks (AcFdUiFieldDialogHookArray &hooks)
BOOL | RegisterFieldDialogHook (CAcFdUiFieldDialogHook *pDlgHook)
BOOL | UnregisterFieldDialogHook (const CAcFdUiFieldDialogHook *pDlgHook)
~CAcFdUiFieldManager (void)

Protected Attributes

void * mpImpObj

Friends

class AcFdUiSystemInternals

Constructor & Destructor Documentation

CAcFdUiFieldManager::CAcFdUiFieldManager ( void )
Warning
Not implemented!
CAcFdUiFieldManager::~CAcFdUiFieldManager ( void )
Warning
Not implemented!

Member Function Documentation

int CAcFdUiFieldManager::GetRegisteredDialogHooks ( AcFdUiFieldDialogHookArray & hooks )
Warning
Not implemented!
BOOL CAcFdUiFieldManager::RegisterFieldDialogHook ( CAcFdUiFieldDialogHook * pDlgHook )
Warning
Not implemented!
BOOL CAcFdUiFieldManager::UnregisterFieldDialogHook ( const CAcFdUiFieldDialogHook * pDlgHook )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acfduifieldmanager.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcFdUiFieldManager Member List

This is the complete list of members for CAcFdUiFieldManager, including all inherited members.

AcFdUiSystemInternals (defined in CAcFdUiFieldManager) | CAcFdUiFieldManager | friend
CAcFdUiFieldManager(void) | CAcFdUiFieldManager |
GetRegisteredDialogHooks(AcFdUiFieldDialogHookArray &hooks) | CAcFdUiFieldManager |
mpImpObj (defined in CAcFdUiFieldManager) | CAcFdUiFieldManager | protected
RegisterFieldDialogHook(CAcFdUiFieldDialogHook *pDlgHook) | CAcFdUiFieldManager |
UnregisterFieldDialogHook(const CAcFdUiFieldDialogHook *pDlgHook) | CAcFdUiFieldManager |
~CAcFdUiFieldManager(void) | CAcFdUiFieldManager |


ZRX API Reference: CAcFdUiFieldOptionDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAcFdUiFieldOptionDialog Class Reference
AcFd Classes
+ Inheritance diagram for CAcFdUiFieldOptionDialog:

Public Member Functions

CAcFdUiFieldOptionDialog (CAcFdUiFieldDialogHook *pDialogHook, CAcFdUiFieldDialog *pFieldDlg, UINT nIDTemplate, HINSTANCE hDialogResource=NULL)
virtual BOOL | Create (CWnd *pParent)
virtual BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParent=NULL)
virtual BOOL | Create (UINT nIDTemplate, CWnd *pParent=NULL)
CAcFdUiFieldDialog * | GetFieldDialog (void) const
CAcFdUiFieldDialogHook * | GetFieldDialogHook (void) const
virtual | ~CAcFdUiFieldOptionDialog ()
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
virtual void | OnDialogHelp ()
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
afx_msg LRESULT | OnBeginFormatExDialog (WPARAM wParam, LPARAM lParam)
virtual void | OnCancel (void)
afx_msg LRESULT | OnEndFormatExDialog (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnFieldSelected (UINT uNewFieldId)
afx_msg LRESULT | OnFormatChanged (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnKillActive (void)
virtual void | OnOK (void)
virtual BOOL | OnSetActive (void)
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Protected Attributes

void * | mpImpObj
- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Protected Attributes inherited from CAdUiBaseDialog
BOOL | m_bUseTips
ADUI_COMMAND_STATE | m_commandState
CString | m_contextHelpFileName
CString | m_contextHelpFullPathName
CString | m_contextHelpPrefix
HINSTANCE | m_hDialogResource
HICON | m_hIcon
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey

Friends

class AcFdUiSystemInternals

Additional Inherited Members

- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist

Constructor & Destructor Documentation

CAcFdUiFieldOptionDialog::CAcFdUiFieldOptionDialog | ( | CAcFdUiFieldDialogHook * | pDialogHook,
 |  | CAcFdUiFieldDialog * | pFieldDlg,
 |  | UINT | nIDTemplate,
 |  | HINSTANCE | hDialogResource = NULL
 | ) |  |
Warning
Not implemented!
virtual CAcFdUiFieldOptionDialog::~CAcFdUiFieldOptionDialog ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual BOOL CAcFdUiFieldOptionDialog::Create ( CWnd * pParent )
virtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldOptionDialog::Create | ( | LPCTSTR | lpszTemplateName,
 |  | CWnd * | pParent = NULL
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

virtual BOOL CAcFdUiFieldOptionDialog::Create | ( | UINT | nIDTemplate,
 |  | CWnd * | pParent = NULL
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

virtual void CAcFdUiFieldOptionDialog::DoDataExchange ( CDataExchange * pDX )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiDialog.

CAcFdUiFieldDialog* CAcFdUiFieldOptionDialog::GetFieldDialog ( void ) const
Warning
Not implemented!
CAcFdUiFieldDialogHook* CAcFdUiFieldOptionDialog::GetFieldDialogHook ( void ) const
Warning
Not implemented!
afx_msg LRESULT CAcFdUiFieldOptionDialog::OnBeginFormatExDialog | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |
protected
Warning
Not implemented!
virtual void CAcFdUiFieldOptionDialog::OnCancel ( void )
protectedvirtual
Warning
Not implemented!
afx_msg LRESULT CAcFdUiFieldOptionDialog::OnEndFormatExDialog | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |
protected
Warning
Not implemented!
virtual BOOL CAcFdUiFieldOptionDialog::OnFieldSelected ( UINT uNewFieldId )
protectedvirtual
Warning
Not implemented!
virtual BOOL CAcFdUiFieldOptionDialog::OnKillActive ( void )
protectedvirtual
Warning
Not implemented!
virtual void CAcFdUiFieldOptionDialog::OnOK ( void )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiDialog.

virtual BOOL CAcFdUiFieldOptionDialog::OnSetActive ( void )
protectedvirtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acfduifieldoptiondialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcFdUiFieldOptionDialog Member List

This is the complete list of members for CAcFdUiFieldOptionDialog, including all inherited members.

AcFdUiSystemInternals (defined in CAcFdUiFieldOptionDialog) | CAcFdUiFieldOptionDialog | friend
AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAcFdUiFieldOptionDialog(CAcFdUiFieldDialogHook *pDialogHook, CAcFdUiFieldDialog *pFieldDlg, UINT nIDTemplate, HINSTANCE hDialogResource=NULL) | CAcFdUiFieldOptionDialog |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(CWnd *pParent) | CAcFdUiFieldOptionDialog | virtual
Create(LPCTSTR lpszTemplateName, CWnd *pParent=NULL) | CAcFdUiFieldOptionDialog | virtual
Create(UINT nIDTemplate, CWnd *pParent=NULL) | CAcFdUiFieldOptionDialog | virtual
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) | CAcFdUiFieldOptionDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetFieldDialog(void) const | CAcFdUiFieldOptionDialog |
GetFieldDialogHook(void) const | CAcFdUiFieldOptionDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAdUiDialog) | CAdUiDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
mpImpObj (defined in CAcFdUiFieldOptionDialog) | CAcFdUiFieldOptionDialog | protected
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnBeginFormatExDialog(WPARAM wParam, LPARAM lParam) | CAcFdUiFieldOptionDialog | protected
OnCancel(void) | CAcFdUiFieldOptionDialog | protectedvirtual
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
OnEndFormatExDialog(WPARAM wParam, LPARAM lParam) | CAcFdUiFieldOptionDialog | protected
OnFieldSelected(UINT uNewFieldId) | CAcFdUiFieldOptionDialog | protectedvirtual
OnFormatChanged(WPARAM wParam, LPARAM lParam) (defined in CAcFdUiFieldOptionDialog) | CAcFdUiFieldOptionDialog | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnKillActive(void) | CAcFdUiFieldOptionDialog | protectedvirtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK(void) | CAcFdUiFieldOptionDialog | protectedvirtual
OnSetActive(void) | CAcFdUiFieldOptionDialog | protectedvirtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDialog) | CAdUiDialog | protected
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAcFdUiFieldOptionDialog() | CAcFdUiFieldOptionDialog | virtual
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAcFdUiFormatDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAcFdUiFormatDialog Class Reference
AcFd Classes
+ Inheritance diagram for CAcFdUiFormatDialog:

Public Member Functions

CAcFdUiFormatDialog (CWnd *pParent, BOOL bNew)
virtual BOOL | Create (CWnd *pParent)
int | GetCurrentFormat (CString &sDisplayName, CString &sFormatString, CString &sVersion) const
CAcFdUiFormatList * | GetFormatList (void)
CString | GetFormatType (void) const
BOOL | SetCurrentFormat (LPCTSTR pszDisplayName, LPCTSTR pszFormatString)
BOOL | SetDialogStyle (int nStyle)
BOOL | SetFormatPreviewLabel (LPCTSTR pszText)
BOOL | SetFormatPreviewReadOnly (BOOL bReadOnly=TRUE)
BOOL | SetFormatPreviewText (LPCTSTR pszPreviewText, const AcValue &fieldValue)
BOOL | SetFormatType (LPCTSTR pszFormatType)
virtual | ~CAcFdUiFormatDialog ()
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
virtual void | OnDialogHelp ()
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
afx_msg void | OnBnClickedAdditionalFormat (void)
afx_msg void | OnBnClickedAppendSymbol (void)
afx_msg void | OnBnClickedFilenameOnly (void)
afx_msg void | OnBnClickedFormatEx (void)
afx_msg void | OnBnClickedIncludeExtension (void)
afx_msg void | OnBnClickedPathAndFilename (void)
afx_msg void | OnBnClickedPathOnly (void)
afx_msg void | OnBnClickedPointX (void)
afx_msg void | OnBnClickedPointY (void)
afx_msg void | OnBnClickedPointZ (void)
afx_msg void | OnCbnEditChangeListSeparator (void)
afx_msg void | OnCbnSelChangeCurrencySymbol (void)
afx_msg void | OnCbnSelChangeDecimalSeparator (void)
afx_msg void | OnCbnSelChangeListSeparator (void)
afx_msg void | OnCbnSelChangePrecision (void)
afx_msg void | OnDestroy (void)
afx_msg void | OnEnChangePreview (void)
afx_msg void | OnLbnSelChangeFormatList (void)
afx_msg void | OnLbnSelChangeNegativeNumberList (void)
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
virtual void | OnOK ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Protected Attributes

void * | mpImpObj
- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Protected Attributes inherited from CAdUiBaseDialog
BOOL | m_bUseTips
ADUI_COMMAND_STATE | m_commandState
CString | m_contextHelpFileName
CString | m_contextHelpFullPathName
CString | m_contextHelpPrefix
HINSTANCE | m_hDialogResource
HICON | m_hIcon
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey

Friends

class AcFdUiSystemInternals

Additional Inherited Members

- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist

Constructor & Destructor Documentation

CAcFdUiFormatDialog::CAcFdUiFormatDialog | ( | CWnd * | pParent,
 |  | BOOL | bNew
 | ) |  |
Warning
Not implemented!
virtual CAcFdUiFormatDialog::~CAcFdUiFormatDialog ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual BOOL CAcFdUiFormatDialog::Create ( CWnd * pParent )
virtual
Warning
Not implemented!
virtual void CAcFdUiFormatDialog::DoDataExchange ( CDataExchange * pDX )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiDialog.

int CAcFdUiFormatDialog::GetCurrentFormat | ( | CString & | sDisplayName,
 |  | CString & | sFormatString,
 |  | CString & | sVersion
 | ) |  | const
Warning
Not implemented!
CAcFdUiFormatList* CAcFdUiFormatDialog::GetFormatList ( void )
Warning
Not implemented!
CString CAcFdUiFormatDialog::GetFormatType ( void ) const
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedAdditionalFormat ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedAppendSymbol ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedFilenameOnly ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedFormatEx ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedIncludeExtension ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedPathAndFilename ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedPathOnly ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedPointX ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedPointY ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnBnClickedPointZ ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnCbnEditChangeListSeparator ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnCbnSelChangeCurrencySymbol ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnCbnSelChangeDecimalSeparator ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnCbnSelChangeListSeparator ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnCbnSelChangePrecision ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnDestroy ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnEnChangePreview ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnLbnSelChangeFormatList ( void )
protected
Warning
Not implemented!
afx_msg void CAcFdUiFormatDialog::OnLbnSelChangeNegativeNumberList ( void )
protected
Warning
Not implemented!
BOOL CAcFdUiFormatDialog::SetCurrentFormat | ( | LPCTSTR | pszDisplayName,
 |  | LPCTSTR | pszFormatString
 | ) |  |
Warning
Not implemented!
BOOL CAcFdUiFormatDialog::SetDialogStyle ( int nStyle )
Warning
Not implemented!
BOOL CAcFdUiFormatDialog::SetFormatPreviewLabel ( LPCTSTR pszText )
Warning
Not implemented!
BOOL CAcFdUiFormatDialog::SetFormatPreviewReadOnly ( BOOL bReadOnly = TRUE )
Warning
Not implemented!
BOOL CAcFdUiFormatDialog::SetFormatPreviewText | ( | LPCTSTR | pszPreviewText,
 |  | const AcValue & | fieldValue
 | ) |  |
Warning
Not implemented!
BOOL CAcFdUiFormatDialog::SetFormatType ( LPCTSTR pszFormatType )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcFdUiFormatDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcFdUiFormatDialog Member List

This is the complete list of members for CAcFdUiFormatDialog, including all inherited members.

AcFdUiSystemInternals (defined in CAcFdUiFormatDialog) | CAcFdUiFormatDialog | friend
AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAcFdUiFormatDialog(CWnd *pParent, BOOL bNew) | CAcFdUiFormatDialog |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(CWnd *pParent) | CAcFdUiFormatDialog | virtual
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) | CAcFdUiFormatDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetCurrentFormat(CString &sDisplayName, CString &sFormatString, CString &sVersion) const | CAcFdUiFormatDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetFormatList(void) | CAcFdUiFormatDialog |
GetFormatType(void) const | CAcFdUiFormatDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAdUiDialog) | CAdUiDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
mpImpObj (defined in CAcFdUiFormatDialog) | CAcFdUiFormatDialog | protected
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnBnClickedAdditionalFormat(void) | CAcFdUiFormatDialog | protected
OnBnClickedAppendSymbol(void) | CAcFdUiFormatDialog | protected
OnBnClickedFilenameOnly(void) | CAcFdUiFormatDialog | protected
OnBnClickedFormatEx(void) | CAcFdUiFormatDialog | protected
OnBnClickedIncludeExtension(void) | CAcFdUiFormatDialog | protected
OnBnClickedPathAndFilename(void) | CAcFdUiFormatDialog | protected
OnBnClickedPathOnly(void) | CAcFdUiFormatDialog | protected
OnBnClickedPointX(void) | CAcFdUiFormatDialog | protected
OnBnClickedPointY(void) | CAcFdUiFormatDialog | protected
OnBnClickedPointZ(void) | CAcFdUiFormatDialog | protected
OnCbnEditChangeListSeparator(void) | CAcFdUiFormatDialog | protected
OnCbnSelChangeCurrencySymbol(void) | CAcFdUiFormatDialog | protected
OnCbnSelChangeDecimalSeparator(void) | CAcFdUiFormatDialog | protected
OnCbnSelChangeListSeparator(void) | CAcFdUiFormatDialog | protected
OnCbnSelChangePrecision(void) | CAcFdUiFormatDialog | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDestroy(void) | CAcFdUiFormatDialog | protected
OnDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
OnEnChangePreview(void) | CAcFdUiFormatDialog | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnLbnSelChangeFormatList(void) | CAcFdUiFormatDialog | protected
OnLbnSelChangeNegativeNumberList(void) | CAcFdUiFormatDialog | protected
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDialog) | CAdUiDialog | protected
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetCurrentFormat(LPCTSTR pszDisplayName, LPCTSTR pszFormatString) | CAcFdUiFormatDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogStyle(int nStyle) | CAcFdUiFormatDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetFormatPreviewLabel(LPCTSTR pszText) | CAcFdUiFormatDialog |
SetFormatPreviewReadOnly(BOOL bReadOnly=TRUE) | CAcFdUiFormatDialog |
SetFormatPreviewText(LPCTSTR pszPreviewText, const AcValue &fieldValue) | CAcFdUiFormatDialog |
SetFormatType(LPCTSTR pszFormatType) | CAcFdUiFormatDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAcFdUiFormatDialog() | CAcFdUiFormatDialog | virtual
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAcFdUiFormatList Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAcFdUiFormatList Class Reference
AcFd Classes
+ Inheritance diagram for CAcFdUiFormatList:

Public Member Functions

CAcFdUiFormatList (void)
int | GetCurrentFormat (CString &sDisplayName, CString &sFormatString) const
CString | GetFormatType (void) const
BOOL | Refresh (void)
BOOL | SetCurrentFormat (LPCTSTR pszDisplayName, LPCTSTR pszFormatString)
BOOL | SetFormatType (LPCTSTR pszFormatType)
void | SetPersistency (BOOL bPersist)
void | SetRootKey (LPCTSTR pszKey)
virtual | ~CAcFdUiFormatList (void)
- Public Member Functions inherited from CAdUiListBox
virtual int | CompareItem (LPCOMPAREITEMSTRUCT lpCompareItemStruct)
virtual void | DeleteItem (LPDELETEITEMSTRUCT lpDeleteItemStruct)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
CWnd * | GetAdUiParent ()
CAdUiComboBox * | GetComboBox ()
BOOL | GetComboBoxDraw ()
virtual void | GetContentExtent (int item, LPCTSTR text, int &width, int &height)
int | GetItemAtPoint (CPoint &p)
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsOwnerDraw ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | SetAdUiParent (CWnd *w)
void | SetComboBox (CAdUiComboBox *control)
void | SetComboBoxDraw (BOOL comboBoxDraw)

Protected Member Functions

afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnDestroy (void)
- Protected Member Functions inherited from CAdUiListBox
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)

Protected Attributes

void * | mpImpObj
- Protected Attributes inherited from CAdUiListBox
CWnd * | m_aduiParent
BOOL | m_bComboBoxDraw
CPoint | m_lastMousePoint
CAdUiComboBox * | m_pComboBox
int | m_tipItem
CRect | m_tipRect

Friends

class AcFdUiSystemInternals

Constructor & Destructor Documentation

CAcFdUiFormatList::CAcFdUiFormatList ( void )
Warning
Not implemented!
virtual CAcFdUiFormatList::~CAcFdUiFormatList ( void )
virtual
Warning
Not implemented!

Member Function Documentation

int CAcFdUiFormatList::GetCurrentFormat | ( | CString & | sDisplayName,
 |  | CString & | sFormatString
 | ) |  | const
Warning
Not implemented!
CString CAcFdUiFormatList::GetFormatType ( void ) const
Warning
Not implemented!
BOOL CAcFdUiFormatList::Refresh ( void )
Warning
Not implemented!
BOOL CAcFdUiFormatList::SetCurrentFormat | ( | LPCTSTR | pszDisplayName,
 |  | LPCTSTR | pszFormatString
 | ) |  |
Warning
Not implemented!
BOOL CAcFdUiFormatList::SetFormatType ( LPCTSTR pszFormatType )
Warning
Not implemented!
void CAcFdUiFormatList::SetPersistency ( BOOL bPersist )
Warning
Not implemented!
void CAcFdUiFormatList::SetRootKey ( LPCTSTR pszKey )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcFdUiFormatList.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcFdUiFormatList Member List

This is the complete list of members for CAcFdUiFormatList, including all inherited members.

AcFdUiSystemInternals (defined in CAcFdUiFormatList) | CAcFdUiFormatList | friend
CAcFdUiFormatList(void) | CAcFdUiFormatList |
CAdUiListBox() (defined in CAdUiListBox) | CAdUiListBox |
CompareItem(LPCOMPAREITEMSTRUCT lpCompareItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
DeleteItem(LPDELETEITEMSTRUCT lpDeleteItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
GetAdUiParent() (defined in CAdUiListBox) | CAdUiListBox |
GetComboBox() (defined in CAdUiListBox) | CAdUiListBox |
GetComboBoxDraw() (defined in CAdUiListBox) | CAdUiListBox |
GetContentExtent(int item, LPCTSTR text, int &width, int &height) (defined in CAdUiListBox) | CAdUiListBox | virtual
GetCurrentFormat(CString &sDisplayName, CString &sFormatString) const | CAcFdUiFormatList |
GetFormatType(void) const | CAcFdUiFormatList |
GetItemAtPoint(CPoint &p) (defined in CAdUiListBox) | CAdUiListBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiListBox) | CAdUiListBox |
IsOwnerDraw() (defined in CAdUiListBox) | CAdUiListBox |
m_aduiParent (defined in CAdUiListBox) | CAdUiListBox | protected
m_bComboBoxDraw (defined in CAdUiListBox) | CAdUiListBox | protected
m_lastMousePoint (defined in CAdUiListBox) | CAdUiListBox | protected
m_pComboBox (defined in CAdUiListBox) | CAdUiListBox | protected
m_tipItem (defined in CAdUiListBox) | CAdUiListBox | protected
m_tipRect (defined in CAdUiListBox) | CAdUiListBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
mpImpObj (defined in CAcFdUiFormatList) | CAcFdUiFormatList | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiListBox) | CAdUiListBox | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcFdUiFormatList) | CAcFdUiFormatList | protected
OnDestroy(void) (defined in CAcFdUiFormatList) | CAcFdUiFormatList | protected
OnDrawTip(CDC &dc) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiListBox) | CAdUiListBox | protected
Refresh(void) | CAcFdUiFormatList |
SetAdUiParent(CWnd *w) (defined in CAdUiListBox) | CAdUiListBox |
SetComboBox(CAdUiComboBox *control) (defined in CAdUiListBox) | CAdUiListBox |
SetComboBoxDraw(BOOL comboBoxDraw) (defined in CAdUiListBox) | CAdUiListBox |
SetCurrentFormat(LPCTSTR pszDisplayName, LPCTSTR pszFormatString) | CAcFdUiFormatList |
SetFormatType(LPCTSTR pszFormatType) | CAcFdUiFormatList |
SetPersistency(BOOL bPersist) | CAcFdUiFormatList |
SetRootKey(LPCTSTR pszKey) | CAcFdUiFormatList |
~CAcFdUiFormatList(void) | CAcFdUiFormatList | virtual
~CAdUiListBox() (defined in CAdUiListBox) | CAdUiListBox | virtual


ZRX API Reference: AcGe Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Functions
AcGe Classes

Classes

class | AcGeAugPolyline3d
class | AcGeBoundBlock2d
class | AcGeBoundBlock3d
class | AcGeBoundedPlane
class | AcGeCircArc2d
class | AcGeCircArc3d
class | AcGeClipBoundary2d
class | AcGeCompositeCurve2d
class | AcGeCompositeCurve3d
class | AcGeCone
class | AcGeCubicSplineCurve2d
class | AcGeCubicSplineCurve3d
class | AcGeCurve2d
class | AcGeCurve3d
class | AcGeCurveBoundary
class | AcGeCurveCurveInt2d
class | AcGeCurveCurveInt3d
class | AcGeCurveSurfInt
class | AcGeCylinder
class | AcGeDwgIO
class | AcGeDxfIO
class | AcGeEllipArc2d
class | AcGeEllipArc3d
class | AcGeEntity2d
class | AcGeEntity3d
class | AcGeExternalBoundedSurface
class | AcGeExternalCurve2d
class | AcGeExternalCurve3d
class | AcGeExternalSurface
class | AcGeFileIO
class | AcGeFiler
class | AcGeInterval
class | AcGeKnotVector
class | AcGeLibVersion
class | AcGeLine2d
class | AcGeLine3d
class | AcGeLinearEnt2d
class | AcGeLinearEnt3d
class | AcGeLineSeg2d
class | AcGeLineSeg3d
class | AcGeMatrix2d
class | AcGeMatrix3d
class | AcGeNurbCurve2d
class | AcGeNurbCurve3d
class | AcGeNurbSurface
class | AcGeOffsetCurve2d
class | AcGeOffsetCurve3d
class | AcGeOffsetSurface
class | AcGePlanarEnt
class | AcGePlane
class | AcGePoint2d
class | AcGePoint3d
class | AcGePointEnt2d
class | AcGePointEnt3d
class | AcGePointOnCurve2d
class | AcGePointOnCurve3d
class | AcGePointOnSurface
class | AcGePolyline2d
class | AcGePolyline3d
class | AcGePosition2d
class | AcGePosition3d
class | AcGeRay2d
class | AcGeRay3d
class | AcGeScale2d
class | AcGeScale3d
class | AcGeSphere
class | AcGeSplineEnt2d
class | AcGeSplineEnt3d
class | AcGeSurface
class | AcGeSurfSurfInt
class | AcGeTol
class | AcGeTorus
class | AcGeVector2d
class | AcGeVector3d

Functions

AcGePoint2d::AcGePoint2d (const AcGePoint2d &pnt)
AcGePoint2d::AcGePoint2d (double x, double y)
AcGePoint3d::AcGePoint3d (const AcGePoint3d &pnt)
AcGePoint3d::AcGePoint3d (double x, double y, double z)
AcGeVector2d::AcGeVector2d (const AcGeVector2d &vec)
AcGeVector2d::AcGeVector2d (double x, double y)
AcGeVector3d::AcGeVector3d (const AcGeVector3d &vec)
AcGeVector3d::AcGeVector3d (double x, double y, double z)
const double * | AcGeKnotVector::asArrayPtr () const
double * | AcGeKnotVector::asArrayPtr ()
AcGeVector2d | AcGePoint2d::asVector () const
AcGeVector3d | AcGePoint3d::asVector () const
double | AcGeVector2d::dotProduct (const AcGeVector2d &vec) const
double | AcGeVector3d::dotProduct (const AcGeVector3d &vec) const
virtual AcDbDwgFiler * | AcGeFiler::dwgFiler ()
double | AcGeTol::equalPoint () const
double | AcGeTol::equalVector () const
Adesk::Boolean | AcGeKnotVector::isValid (int) const
double | AcGeVector2d::lengthSqrd () const
double | AcGeVector3d::lengthSqrd () const
AcGeVector2d & | AcGeVector2d::negate ()
AcGeVector3d & | AcGeVector3d::negate ()
AcGeEntity2d * | AcGeEntity3d::newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | AcGeEntity2d::newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | AcGeEntity3d::newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | AcGeEntity3d::newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | AcGeEntity3d::newEntity3d (AcGeImpEntity3d &, int) const
bool | AcGeMatrix2d::operator!= (const AcGeMatrix2d &mat) const
bool | AcGeScale3d::operator!= (const AcGeScale3d &sclVec) const
bool | AcGeMatrix3d::operator!= (const AcGeMatrix3d &mat) const
bool | AcGeScale2d::operator!= (const AcGeScale2d &sclVec) const
bool | AcGePoint2d::operator!= (const AcGePoint2d &pnt) const
bool | AcGePoint3d::operator!= (const AcGePoint3d &pnt) const
bool | AcGeVector2d::operator!= (const AcGeVector2d &vec) const
bool | AcGeVector3d::operator!= (const AcGeVector3d &vec) const
double | AcGeMatrix2d::operator() (unsigned int, unsigned int) const
double & | AcGeMatrix2d::operator() (unsigned int, unsigned int)
double | AcGeMatrix3d::operator() (unsigned int, unsigned int) const
double & | AcGeMatrix3d::operator() (unsigned int, unsigned int)
AcGeVector2d | AcGeVector2d::operator* (double scl) const
AcGePoint2d | AcGePoint2d::operator* (double) const
AcGePoint3d | AcGePoint3d::operator* (double scl) const
AcGeVector3d | AcGeVector3d::operator* (double scl) const
__forceinline AcGePoint2d | operator* (double val, const AcGePoint2d &p)
__forceinline AcGePoint3d | operator* (double val, const AcGePoint3d &p)
AcGeVector2d & | AcGeVector2d::operator*= (double scl)
AcGePoint2d & | AcGePoint2d::operator*= (double scl)
AcGePoint3d & | AcGePoint3d::operator*= (double scl)
AcGeVector3d & | AcGeVector3d::operator*= (double scl)
AcGePoint2d | AcGePoint2d::operator+ (const AcGeVector2d &vec) const
AcGeVector2d | AcGeVector2d::operator+ (const AcGeVector2d &vec) const
AcGePoint3d | AcGePoint3d::operator+ (const AcGeVector3d &vec) const
AcGeVector3d | AcGeVector3d::operator+ (const AcGeVector3d &vec) const
AcGePoint2d & | AcGePoint2d::operator+= (const AcGeVector2d &vec)
AcGeVector2d & | AcGeVector2d::operator+= (const AcGeVector2d &vec)
AcGePoint3d & | AcGePoint3d::operator+= (const AcGeVector3d &vec)
AcGeVector3d & | AcGeVector3d::operator+= (const AcGeVector3d &vec)
AcGeVector2d | AcGeVector2d::operator- (const AcGeVector2d &vec) const
AcGePoint2d | AcGePoint2d::operator- (const AcGeVector2d &vec) const
AcGeVector2d | AcGeVector2d::operator- () const
AcGeVector2d | AcGePoint2d::operator- (const AcGePoint2d &pnt) const
AcGePoint3d | AcGePoint3d::operator- (const AcGeVector3d &vec) const
AcGeVector3d | AcGeVector3d::operator- (const AcGeVector3d &vec) const
AcGeVector3d | AcGePoint3d::operator- (const AcGePoint3d &pnt) const
AcGeVector3d | AcGeVector3d::operator- () const
AcGePoint2d & | AcGePoint2d::operator-= (const AcGeVector2d &vec)
AcGeVector2d & | AcGeVector2d::operator-= (const AcGeVector2d &vec)
AcGePoint3d & | AcGePoint3d::operator-= (const AcGeVector3d &vec)
AcGeVector3d & | AcGeVector3d::operator-= (const AcGeVector3d &vec)
AcGeVector2d | AcGeVector2d::operator/ (double scl) const
AcGePoint2d | AcGePoint2d::operator/ (double scl) const
AcGePoint3d | AcGePoint3d::operator/ (double scl) const
AcGeVector3d | AcGeVector3d::operator/ (double scl) const
AcGePoint2d & | AcGePoint2d::operator/= (double scl)
AcGeVector2d & | AcGeVector2d::operator/= (double scl)
AcGePoint3d & | AcGePoint3d::operator/= (double scl)
AcGeVector3d & | AcGeVector3d::operator/= (double scl)
bool | AcGeMatrix2d::operator== (const AcGeMatrix2d &mat) const
bool | AcGeScale3d::operator== (const AcGeScale3d &sclVec) const
bool | AcGeMatrix3d::operator== (const AcGeMatrix3d &mat) const
bool | AcGeScale2d::operator== (const AcGeScale2d &sclVec) const
bool | AcGePoint2d::operator== (const AcGePoint2d &pnt) const
bool | AcGePoint3d::operator== (const AcGePoint3d &pnt) const
bool | AcGeVector2d::operator== (const AcGeVector2d &vec) const
bool | AcGeVector3d::operator== (const AcGeVector3d &vec) const
double & | AcGeKnotVector::operator[] (int)
const double | AcGeKnotVector::operator[] (int) const
double | AcGeScale3d::operator[] (unsigned int i) const
double | AcGeScale2d::operator[] (unsigned int i) const
double & | AcGeScale3d::operator[] (unsigned int i)
double & | AcGeScale2d::operator[] (unsigned int i)
double | AcGePoint2d::operator[] (unsigned int i) const
double & | AcGePoint2d::operator[] (unsigned int idx)
double | AcGePoint3d::operator[] (unsigned int i) const
double & | AcGePoint3d::operator[] (unsigned int idx)
double | AcGeVector2d::operator[] (unsigned int i) const
double & | AcGeVector2d::operator[] (unsigned int i)
double | AcGeVector3d::operator[] (unsigned int i) const
double & | AcGeVector3d::operator[] (unsigned int i)
AcGeVector2d | AcGeVector2d::perpVector () const
AcGePoint2d & | AcGePoint2d::set (double x, double y)
AcGePoint3d & | AcGePoint3d::set (double x, double y, double z)
AcGeVector2d & | AcGeVector2d::set (double x, double y)
AcGeVector3d & | AcGeVector3d::set (double x, double y, double z)
void | AcGeTol::setEqualPoint (double val)
void | AcGeTol::setEqualVector (double val)
AcGeKnotVector & | AcGeKnotVector::setTolerance (double tol)
AcGeVector2d & | AcGeVector2d::setToProduct (const AcGeVector2d &vec, double scl)
AcGeVector3d & | AcGeVector3d::setToProduct (const AcGeVector3d &vec, double scl)
AcGeVector2d & | AcGeVector2d::setToSum (const AcGeVector2d &vec1, const AcGeVector2d &vec2)
AcGeVector3d & | AcGeVector3d::setToSum (const AcGeVector3d &vec1, const AcGeVector3d &vec2)
double | AcGeKnotVector::tolerance () const

Detailed Description


ZRX API Reference: AcGeAugPolyline3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeAugPolyline3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeAugPolyline3d:

Public Member Functions

AcGeAugPolyline3d (const AcGeAugPolyline3d &apline)
AcGeAugPolyline3d (const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts, const AcGeVector3dArray &vecBundle)
AcGeAugPolyline3d (const AcGePoint3dArray &cntrlPnts, const AcGeVector3dArray &vecBundle)
AcGeAugPolyline3d (const AcGeCurve3d &curve, double fromParam, double toParam, double apprEps)
double | approxTol () const
void | getD1Vectors (AcGeVector3dArray &tangents) const
AcGeVector3d | getD2Vector (int idx) const
void | getD2Vectors (AcGeVector3dArray &d2Vectors) const
AcGePoint3d | getPoint (int idx) const
void | getPoints (AcGePoint3dArray &pnts) const
AcGeVector3d | getVector (int idx) const
AcGeAugPolyline3d & | operator= (const AcGeAugPolyline3d &apline)
AcGeAugPolyline3d & | setApproxTol (double approxTol)
AcGeAugPolyline3d & | setD2Vector (int idx, AcGeVector3d pnt)
AcGeAugPolyline3d & | setPoint (int idx, AcGePoint3d pnt)
AcGeAugPolyline3d & | setVector (int idx, AcGeVector3d pnt)
- Public Member Functions inherited from AcGePolyline3d
AcGePolyline3d (const AcGePolyline3d &src)
AcGePolyline3d (const AcGePoint3dArray &points)
AcGePolyline3d (const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts)
AcGePolyline3d (const AcGeCurve3d &crv, double apprEps)
AcGePoint3d | fitPointAt (int idx) const
int | numFitPoints () const
AcGePolyline3d & | operator= (const AcGePolyline3d &pline)
AcGeSplineEnt3d & | setFitPointAt (int idx, const AcGePoint3d &point)
- Public Member Functions inherited from AcGeSplineEnt3d
int | continuityAtKnot (int idx, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | controlPointAt (int idx) const
int | degree () const
double | endParam () const
AcGePoint3d | endPoint () const
Adesk::Boolean | hasFitData () const
Adesk::Boolean | isRational () const
double | knotAt (int idx) const
const AcGeKnotVector & | knots () const
int | numControlPoints () const
int | numKnots () const
AcGeSplineEnt3d & | operator= (const AcGeSplineEnt3d &spline)
int | order () const
AcGeSplineEnt3d & | setControlPointAt (int idx, const AcGePoint3d &pnt)
AcGeSplineEnt3d & | setKnotAt (int idx, double val)
double | startParam () const
AcGePoint3d | startPoint () const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSplineEnt3d
AcGeSplineEnt3d (const AcGeSplineEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geapln3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeAugPolyline3d Member List

This is the complete list of members for AcGeAugPolyline3d, including all inherited members.

AcGeAugPolyline3d() (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
AcGeAugPolyline3d(const AcGeAugPolyline3d &apline) (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
AcGeAugPolyline3d(const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts, const AcGeVector3dArray &vecBundle) (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
AcGeAugPolyline3d(const AcGePoint3dArray &cntrlPnts, const AcGeVector3dArray &vecBundle) (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
AcGeAugPolyline3d(const AcGeCurve3d &curve, double fromParam, double toParam, double apprEps) (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGePolyline3d() (defined in AcGePolyline3d) | AcGePolyline3d |
AcGePolyline3d(const AcGePolyline3d &src) (defined in AcGePolyline3d) | AcGePolyline3d |
AcGePolyline3d(const AcGePoint3dArray &points) (defined in AcGePolyline3d) | AcGePolyline3d |
AcGePolyline3d(const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts) (defined in AcGePolyline3d) | AcGePolyline3d |
AcGePolyline3d(const AcGeCurve3d &crv, double apprEps) (defined in AcGePolyline3d) | AcGePolyline3d |
AcGeSplineEnt3d() (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
AcGeSplineEnt3d(const AcGeSplineEnt3d &) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
approxTol() const (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
continuityAtKnot(int idx, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
controlPointAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
degree() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
endParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
endPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
fitPointAt(int idx) const (defined in AcGePolyline3d) | AcGePolyline3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getD1Vectors(AcGeVector3dArray &tangents) const (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
getD2Vector(int idx) const (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
getD2Vectors(AcGeVector3dArray &d2Vectors) const (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getPoint(int idx) const (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
getPoints(AcGePoint3dArray &pnts) const (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getVector(int idx) const (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasFitData() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isRational() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
knotAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
knots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numControlPoints() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
numFitPoints() const (defined in AcGePolyline3d) | AcGePolyline3d |
numKnots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeAugPolyline3d &apline) (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
operator=(const AcGePolyline3d &pline) (defined in AcGePolyline3d) | AcGePolyline3d |
operator=(const AcGeSplineEnt3d &spline) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
order() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setApproxTol(double approxTol) (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
setControlPointAt(int idx, const AcGePoint3d &pnt) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
setD2Vector(int idx, AcGeVector3d pnt) (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
setFitPointAt(int idx, const AcGePoint3d &point) (defined in AcGePolyline3d) | AcGePolyline3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
setKnotAt(int idx, double val) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
setPoint(int idx, AcGePoint3d pnt) (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
setVector(int idx, AcGeVector3d pnt) (defined in AcGeAugPolyline3d) | AcGeAugPolyline3d |
startParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
startPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeBoundBlock2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeBoundBlock2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeBoundBlock2d:

Public Member Functions

AcGeBoundBlock2d (const AcGePoint2d &point1, const AcGePoint2d &point2)
AcGeBoundBlock2d (const AcGePoint2d &base, const AcGeVector2d &dir1, const AcGeVector2d &dir2)
AcGeBoundBlock2d (const AcGeBoundBlock2d &block)
Adesk::Boolean | contains (const AcGePoint2d &point) const
AcGeBoundBlock2d & | extend (const AcGePoint2d &point)
void | get (AcGePoint2d &base, AcGeVector2d &dir1, AcGeVector2d &dir2) const
void | getMinMaxPoints (AcGePoint2d &point1, AcGePoint2d &point2) const
Adesk::Boolean | isBox () const
Adesk::Boolean | isDisjoint (const AcGeBoundBlock2d &block) const
AcGeBoundBlock2d & | operator= (const AcGeBoundBlock2d &block)
AcGeBoundBlock2d & | set (const AcGePoint2d &point1, const AcGePoint2d &point2)
AcGeBoundBlock2d & | set (const AcGePoint2d &base, const AcGeVector2d &dir1, const AcGeVector2d &dir2)
AcGeBoundBlock2d & | setToBox (Adesk::Boolean)
AcGeBoundBlock2d & | swell (double distance)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeEntity2d
AcGeEntity2d (const AcGeEntity2d &)
AcGeEntity2d (AcGeImpEntity3d &, int)
AcGeEntity2d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geblok2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeBoundBlock2d Member List

This is the complete list of members for AcGeBoundBlock2d, including all inherited members.

AcGeBoundBlock2d() (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
AcGeBoundBlock2d(const AcGePoint2d &point1, const AcGePoint2d &point2) (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
AcGeBoundBlock2d(const AcGePoint2d &base, const AcGeVector2d &dir1, const AcGeVector2d &dir2) (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
AcGeBoundBlock2d(const AcGeBoundBlock2d &block) (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
contains(const AcGePoint2d &point) const (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
extend(const AcGePoint2d &point) (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
get(AcGePoint2d &base, AcGeVector2d &dir1, AcGeVector2d &dir2) const (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
getMinMaxPoints(AcGePoint2d &point1, AcGePoint2d &point2) const (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
isBox() const (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
isDisjoint(const AcGeBoundBlock2d &block) const (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeBoundBlock2d &block) (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(const AcGePoint2d &point1, const AcGePoint2d &point2) (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
set(const AcGePoint2d &base, const AcGeVector2d &dir1, const AcGeVector2d &dir2) (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
setToBox(Adesk::Boolean) (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
swell(double distance) (defined in AcGeBoundBlock2d) | AcGeBoundBlock2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeBoundBlock3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeBoundBlock3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeBoundBlock3d:

Public Member Functions

AcGeBoundBlock3d (const AcGePoint3d &base, const AcGeVector3d &dir1, const AcGeVector3d &dir2, const AcGeVector3d &dir3)
AcGeBoundBlock3d (const AcGeBoundBlock3d &block)
Adesk::Boolean | contains (const AcGePoint3d &point) const
AcGeBoundBlock3d & | extend (const AcGePoint3d &point)
void | get (AcGePoint3d &base, AcGeVector3d &dir1, AcGeVector3d &dir2, AcGeVector3d &dir3) const
void | getMinMaxPoints (AcGePoint3d &point1, AcGePoint3d &point2) const
Adesk::Boolean | isBox () const
Adesk::Boolean | isDisjoint (const AcGeBoundBlock3d &block) const
AcGeBoundBlock3d & | operator= (const AcGeBoundBlock3d &block)
AcGeBoundBlock3d & | set (const AcGePoint3d &point1, const AcGePoint3d &point2)
AcGeBoundBlock3d & | set (const AcGePoint3d &base, const AcGeVector3d &dir1, const AcGeVector3d &dir2, const AcGeVector3d &dir3)
AcGeBoundBlock3d & | setToBox (Adesk::Boolean)
AcGeBoundBlock3d & | swell (double distance)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geblok3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeBoundBlock3d Member List

This is the complete list of members for AcGeBoundBlock3d, including all inherited members.

AcGeBoundBlock3d() (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
AcGeBoundBlock3d(const AcGePoint3d &base, const AcGeVector3d &dir1, const AcGeVector3d &dir2, const AcGeVector3d &dir3) (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
AcGeBoundBlock3d(const AcGeBoundBlock3d &block) (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
contains(const AcGePoint3d &point) const (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
extend(const AcGePoint3d &point) (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
get(AcGePoint3d &base, AcGeVector3d &dir1, AcGeVector3d &dir2, AcGeVector3d &dir3) const (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
getMinMaxPoints(AcGePoint3d &point1, AcGePoint3d &point2) const (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
isBox() const (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
isDisjoint(const AcGeBoundBlock3d &block) const (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeBoundBlock3d &block) (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGePoint3d &point1, const AcGePoint3d &point2) (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
set(const AcGePoint3d &base, const AcGeVector3d &dir1, const AcGeVector3d &dir2, const AcGeVector3d &dir3) (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
setToBox(Adesk::Boolean) (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
swell(double distance) (defined in AcGeBoundBlock3d) | AcGeBoundBlock3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeBoundedPlane Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeBoundedPlane Class Reference
AcGe Classes
+ Inheritance diagram for AcGeBoundedPlane:

Public Member Functions

AcGeBoundedPlane (const AcGeBoundedPlane &plane)
AcGeBoundedPlane (const AcGePoint3d &origin, const AcGeVector3d &uVec, const AcGeVector3d &vVec)
AcGeBoundedPlane (const AcGePoint3d &p1, const AcGePoint3d &origin, const AcGePoint3d &p2)
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &linEnt, AcGePoint3d &point, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGePlane &plane, AcGeLineSeg3d &results, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGeBoundedPlane &plane, AcGeLineSeg3d &result, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundedPlane & | operator= (const AcGeBoundedPlane &bplane)
AcGeBoundedPlane & | set (const AcGePoint3d &origin, const AcGeVector3d &uVec, const AcGeVector3d &vVec)
AcGeBoundedPlane & | set (const AcGePoint3d &p1, const AcGePoint3d &origin, const AcGePoint3d &p2)
- Public Member Functions inherited from AcGePlanarEnt
AcGePoint3d | closestPointToLinearEnt (const AcGeLinearEnt3d &line, AcGePoint3d &pointOnLine, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointToPlanarEnt (const AcGePlanarEnt &otherPln, AcGePoint3d &pointOnOtherPln, const AcGeTol &tol=AcGeContext::gTol) const
void | get (AcGePoint3d &, AcGeVector3d &uVec, AcGeVector3d &vVec) const
void | get (AcGePoint3d &, AcGePoint3d &origin, AcGePoint3d &) const
void | getCoefficients (double &a, double &b, double &c, double &d) const
void | getCoordSystem (AcGePoint3d &origin, AcGeVector3d &axis1, AcGeVector3d &axis2) const
Adesk::Boolean | isCoplanarTo (const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGePlanarEnt &linEnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeVector3d | normal () const
AcGePlanarEnt & | operator= (const AcGePlanarEnt &src)
AcGePoint3d | pointOnPlane () const
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGePlanarEnt
AcGePlanarEnt (const AcGePlanarEnt &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gebndpln.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeBoundedPlane Member List

This is the complete list of members for AcGeBoundedPlane, including all inherited members.

AcGeBoundedPlane() (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
AcGeBoundedPlane(const AcGeBoundedPlane &plane) (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
AcGeBoundedPlane(const AcGePoint3d &origin, const AcGeVector3d &uVec, const AcGeVector3d &vVec) (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
AcGeBoundedPlane(const AcGePoint3d &p1, const AcGePoint3d &origin, const AcGePoint3d &p2) (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGePlanarEnt() (defined in AcGePlanarEnt) | AcGePlanarEnt | protected
AcGePlanarEnt(const AcGePlanarEnt &) (defined in AcGePlanarEnt) | AcGePlanarEnt | protected
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
closestPointToLinearEnt(const AcGeLinearEnt3d &line, AcGePoint3d &pointOnLine, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
closestPointToPlanarEnt(const AcGePlanarEnt &otherPln, AcGePoint3d &pointOnOtherPln, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
get(AcGePoint3d &, AcGeVector3d &uVec, AcGeVector3d &vVec) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
get(AcGePoint3d &, AcGePoint3d &origin, AcGePoint3d &) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getCoefficients(double &a, double &b, double &c, double &d) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
getCoordSystem(AcGePoint3d &origin, AcGeVector3d &axis1, AcGeVector3d &axis2) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
intersectWith(const AcGeLinearEnt3d &linEnt, AcGePoint3d &point, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
intersectWith(const AcGePlane &plane, AcGeLineSeg3d &results, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
intersectWith(const AcGeBoundedPlane &plane, AcGeLineSeg3d &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isCoplanarTo(const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isParallelTo(const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isParallelTo(const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isPerpendicularTo(const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isPerpendicularTo(const AcGePlanarEnt &linEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
normal() const (defined in AcGePlanarEnt) | AcGePlanarEnt |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeBoundedPlane &bplane) (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
operator=(const AcGePlanarEnt &src) (defined in AcGePlanarEnt) | AcGePlanarEnt |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
pointOnPlane() const (defined in AcGePlanarEnt) | AcGePlanarEnt |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGePoint3d &origin, const AcGeVector3d &uVec, const AcGeVector3d &vVec) (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
set(const AcGePoint3d &p1, const AcGePoint3d &origin, const AcGePoint3d &p2) (defined in AcGeBoundedPlane) | AcGeBoundedPlane |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeCircArc2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCircArc2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCircArc2d:

Public Member Functions

AcGeCircArc2d (const AcGeCircArc2d &arc)
AcGeCircArc2d (const AcGePoint2d &cent, double radius)
AcGeCircArc2d (const AcGePoint2d &cent, double radius, double startAngle, double endAngle, const AcGeVector2d &refVec=AcGeVector2d::kXAxis, Adesk::Boolean isClockWise=Adesk::kFalse)
AcGeCircArc2d (const AcGePoint2d &startPoint, const AcGePoint2d &point, const AcGePoint2d &endPoint)
AcGeCircArc2d (const AcGePoint2d &startPoint, const AcGePoint2d &endPoint, double bulge, Adesk::Boolean bulgeFlag=Adesk::kTrue)
AcGePoint2d | center () const
double | endAng () const
AcGePoint2d | endPoint () const
Adesk::Boolean | intersectWith (const AcGeLinearEnt2d &line, int &intn, AcGePoint2d &p1, AcGePoint2d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGeCircArc2d &arc, int &intn, AcGePoint2d &p1, AcGePoint2d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClockWise () const
Adesk::Boolean | isInside (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCircArc2d & | operator= (const AcGeCircArc2d &arc)
double | radius () const
AcGeVector2d | refVec () const
AcGeCircArc2d & | set (const AcGePoint2d &cent, double radius)
AcGeCircArc2d & | set (const AcGePoint2d &cent, double radius, double ang1, double ang2, const AcGeVector2d &refVec=AcGeVector2d::kXAxis, Adesk::Boolean isClockWise=Adesk::kFalse)
AcGeCircArc2d & | set (const AcGePoint2d &startPoint, const AcGePoint2d &pnt, const AcGePoint2d &endPoint)
AcGeCircArc2d & | set (const AcGePoint2d &startPoint, const AcGePoint2d &pnt, const AcGePoint2d &endPoint, AcGeError &error)
AcGeCircArc2d & | set (const AcGePoint2d &startPoint, const AcGePoint2d &endPoint, double bulge, Adesk::Boolean bulgeFlag=Adesk::kTrue)
AcGeCircArc2d & | set (const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, double radius, double &param1, double &param2, Adesk::Boolean &success)
AcGeCircArc2d & | set (const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeCurve2d &curve3, double &param1, double &param2, double &param3, Adesk::Boolean &success)
AcGeCircArc2d & | setAngles (double startAng, double endAng)
AcGeCircArc2d & | setCenter (const AcGePoint2d &cent)
AcGeCircArc2d & | setRadius (double radius)
AcGeCircArc2d & | setRefVec (const AcGeVector2d &vec)
AcGeCircArc2d & | setToComplement ()
double | startAng () const
AcGePoint2d | startPoint () const
Adesk::Boolean | tangent (const AcGePoint2d &pnt, AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | tangent (const AcGePoint2d &pnt, AcGeLine2d &line, const AcGeTol &tol, AcGeError &error) const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve2d
AcGeCurve2d (const AcGeCurve2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gearc2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCircArc2d Member List

This is the complete list of members for AcGeCircArc2d, including all inherited members.

AcGeCircArc2d() (defined in AcGeCircArc2d) | AcGeCircArc2d |
AcGeCircArc2d(const AcGeCircArc2d &arc) (defined in AcGeCircArc2d) | AcGeCircArc2d |
AcGeCircArc2d(const AcGePoint2d &cent, double radius) (defined in AcGeCircArc2d) | AcGeCircArc2d |
AcGeCircArc2d(const AcGePoint2d &cent, double radius, double startAngle, double endAngle, const AcGeVector2d &refVec=AcGeVector2d::kXAxis, Adesk::Boolean isClockWise=Adesk::kFalse) (defined in AcGeCircArc2d) | AcGeCircArc2d |
AcGeCircArc2d(const AcGePoint2d &startPoint, const AcGePoint2d &point, const AcGePoint2d &endPoint) (defined in AcGeCircArc2d) | AcGeCircArc2d |
AcGeCircArc2d(const AcGePoint2d &startPoint, const AcGePoint2d &endPoint, double bulge, Adesk::Boolean bulgeFlag=Adesk::kTrue) (defined in AcGeCircArc2d) | AcGeCircArc2d |
AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
center() const (defined in AcGeCircArc2d) | AcGeCircArc2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
endAng() const (defined in AcGeCircArc2d) | AcGeCircArc2d |
endPoint() const (defined in AcGeCircArc2d) | AcGeCircArc2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
intersectWith(const AcGeLinearEnt2d &line, int &intn, AcGePoint2d &p1, AcGePoint2d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc2d) | AcGeCircArc2d |
intersectWith(const AcGeCircArc2d &arc, int &intn, AcGePoint2d &p1, AcGePoint2d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc2d) | AcGeCircArc2d |
isClockWise() const (defined in AcGeCircArc2d) | AcGeCircArc2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isInside(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc2d) | AcGeCircArc2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeCircArc2d &arc) (defined in AcGeCircArc2d) | AcGeCircArc2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
radius() const (defined in AcGeCircArc2d) | AcGeCircArc2d |
refVec() const (defined in AcGeCircArc2d) | AcGeCircArc2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(const AcGePoint2d &cent, double radius) (defined in AcGeCircArc2d) | AcGeCircArc2d |
set(const AcGePoint2d &cent, double radius, double ang1, double ang2, const AcGeVector2d &refVec=AcGeVector2d::kXAxis, Adesk::Boolean isClockWise=Adesk::kFalse) (defined in AcGeCircArc2d) | AcGeCircArc2d |
set(const AcGePoint2d &startPoint, const AcGePoint2d &pnt, const AcGePoint2d &endPoint) (defined in AcGeCircArc2d) | AcGeCircArc2d |
set(const AcGePoint2d &startPoint, const AcGePoint2d &pnt, const AcGePoint2d &endPoint, AcGeError &error) (defined in AcGeCircArc2d) | AcGeCircArc2d |
set(const AcGePoint2d &startPoint, const AcGePoint2d &endPoint, double bulge, Adesk::Boolean bulgeFlag=Adesk::kTrue) (defined in AcGeCircArc2d) | AcGeCircArc2d |
set(const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, double radius, double &param1, double &param2, Adesk::Boolean &success) (defined in AcGeCircArc2d) | AcGeCircArc2d |
set(const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeCurve2d &curve3, double &param1, double &param2, double &param3, Adesk::Boolean &success) (defined in AcGeCircArc2d) | AcGeCircArc2d |
setAngles(double startAng, double endAng) (defined in AcGeCircArc2d) | AcGeCircArc2d |
setCenter(const AcGePoint2d &cent) (defined in AcGeCircArc2d) | AcGeCircArc2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
setRadius(double radius) (defined in AcGeCircArc2d) | AcGeCircArc2d |
setRefVec(const AcGeVector2d &vec) (defined in AcGeCircArc2d) | AcGeCircArc2d |
setToComplement() (defined in AcGeCircArc2d) | AcGeCircArc2d |
startAng() const (defined in AcGeCircArc2d) | AcGeCircArc2d |
startPoint() const (defined in AcGeCircArc2d) | AcGeCircArc2d |
tangent(const AcGePoint2d &pnt, AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc2d) | AcGeCircArc2d |
tangent(const AcGePoint2d &pnt, AcGeLine2d &line, const AcGeTol &tol, AcGeError &error) const (defined in AcGeCircArc2d) | AcGeCircArc2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeCircArc3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCircArc3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCircArc3d:

Public Member Functions

AcGeCircArc3d (const AcGeCircArc3d &arc)
AcGeCircArc3d (const AcGePoint3d &cent, const AcGeVector3d &nrm, double radius)
AcGeCircArc3d (const AcGePoint3d &cent, const AcGeVector3d &nrm, const AcGeVector3d &refVec, double radius, double startAngle, double endAngle)
AcGeCircArc3d (const AcGePoint3d &startPoint, const AcGePoint3d &pnt, const AcGePoint3d &endPoint)
AcGePoint3d | center () const
AcGePoint3d | closestPointToPlane (const AcGePlanarEnt &plane, AcGePoint3d &pointOnPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | endAng () const
AcGePoint3d | endPoint () const
void | getPlane (AcGePlane &plane) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &line, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGeCircArc3d &arc, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGePlanarEnt &plane, int &numOfIntersect, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isInside (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeVector3d | normal () const
AcGeCircArc3d & | operator= (const AcGeCircArc3d &arc)
Adesk::Boolean | projIntersectWith (const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, int &numInt, AcGePoint3d &pntOnArc1, AcGePoint3d &pntOnArc2, AcGePoint3d &pntOnLine1, AcGePoint3d &pntOnLine2, const AcGeTol &tol=AcGeContext::gTol) const
double | radius () const
AcGeVector3d | refVec () const
AcGeCircArc3d & | set (const AcGePoint3d &cent, const AcGeVector3d &nrm, double radius)
AcGeCircArc3d & | set (const AcGePoint3d &cent, const AcGeVector3d &nrm, const AcGeVector3d &refVec, double radius, double startAngle, double endAngle)
AcGeCircArc3d & | set (const AcGePoint3d &startPoint, const AcGePoint3d &pnt, const AcGePoint3d &endPoint)
AcGeCircArc3d & | set (const AcGePoint3d &startPoint, const AcGePoint3d &pnt, const AcGePoint3d &endPoint, AcGeError &error)
AcGeCircArc3d & | set (const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, double radius, double &param1, double &param2, Adesk::Boolean &success)
AcGeCircArc3d & | set (const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeCurve3d &curve3, double &param1, double &param2, double &param3, Adesk::Boolean &success)
AcGeCircArc3d & | setAngles (double startAngle, double endAngle)
AcGeCircArc3d & | setAxes (const AcGeVector3d &normal, const AcGeVector3d &refVec)
AcGeCircArc3d & | setCenter (const AcGePoint3d &)
AcGeCircArc3d & | setRadius (double)
double | startAng () const
AcGePoint3d | startPoint () const
Adesk::Boolean | tangent (const AcGePoint3d &pnt, AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | tangent (const AcGePoint3d &pnt, AcGeLine3d &line, const AcGeTol &tol, AcGeError &error) const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve3d
AcGeCurve3d (const AcGeCurve3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gearc3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCircArc3d Member List

This is the complete list of members for AcGeCircArc3d, including all inherited members.

AcGeCircArc3d() (defined in AcGeCircArc3d) | AcGeCircArc3d |
AcGeCircArc3d(const AcGeCircArc3d &arc) (defined in AcGeCircArc3d) | AcGeCircArc3d |
AcGeCircArc3d(const AcGePoint3d &cent, const AcGeVector3d &nrm, double radius) (defined in AcGeCircArc3d) | AcGeCircArc3d |
AcGeCircArc3d(const AcGePoint3d &cent, const AcGeVector3d &nrm, const AcGeVector3d &refVec, double radius, double startAngle, double endAngle) (defined in AcGeCircArc3d) | AcGeCircArc3d |
AcGeCircArc3d(const AcGePoint3d &startPoint, const AcGePoint3d &pnt, const AcGePoint3d &endPoint) (defined in AcGeCircArc3d) | AcGeCircArc3d |
AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
center() const (defined in AcGeCircArc3d) | AcGeCircArc3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointToPlane(const AcGePlanarEnt &plane, AcGePoint3d &pointOnPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc3d) | AcGeCircArc3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
endAng() const (defined in AcGeCircArc3d) | AcGeCircArc3d |
endPoint() const (defined in AcGeCircArc3d) | AcGeCircArc3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getPlane(AcGePlane &plane) const (defined in AcGeCircArc3d) | AcGeCircArc3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
intersectWith(const AcGeLinearEnt3d &line, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc3d) | AcGeCircArc3d |
intersectWith(const AcGeCircArc3d &arc, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc3d) | AcGeCircArc3d |
intersectWith(const AcGePlanarEnt &plane, int &numOfIntersect, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc3d) | AcGeCircArc3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isInside(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc3d) | AcGeCircArc3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
normal() const (defined in AcGeCircArc3d) | AcGeCircArc3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeCircArc3d &arc) (defined in AcGeCircArc3d) | AcGeCircArc3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projIntersectWith(const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, int &numInt, AcGePoint3d &pntOnArc1, AcGePoint3d &pntOnArc2, AcGePoint3d &pntOnLine1, AcGePoint3d &pntOnLine2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc3d) | AcGeCircArc3d |
radius() const (defined in AcGeCircArc3d) | AcGeCircArc3d |
refVec() const (defined in AcGeCircArc3d) | AcGeCircArc3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGePoint3d &cent, const AcGeVector3d &nrm, double radius) (defined in AcGeCircArc3d) | AcGeCircArc3d |
set(const AcGePoint3d &cent, const AcGeVector3d &nrm, const AcGeVector3d &refVec, double radius, double startAngle, double endAngle) (defined in AcGeCircArc3d) | AcGeCircArc3d |
set(const AcGePoint3d &startPoint, const AcGePoint3d &pnt, const AcGePoint3d &endPoint) (defined in AcGeCircArc3d) | AcGeCircArc3d |
set(const AcGePoint3d &startPoint, const AcGePoint3d &pnt, const AcGePoint3d &endPoint, AcGeError &error) (defined in AcGeCircArc3d) | AcGeCircArc3d |
set(const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, double radius, double &param1, double &param2, Adesk::Boolean &success) (defined in AcGeCircArc3d) | AcGeCircArc3d |
set(const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeCurve3d &curve3, double &param1, double &param2, double &param3, Adesk::Boolean &success) (defined in AcGeCircArc3d) | AcGeCircArc3d |
setAngles(double startAngle, double endAngle) (defined in AcGeCircArc3d) | AcGeCircArc3d |
setAxes(const AcGeVector3d &normal, const AcGeVector3d &refVec) (defined in AcGeCircArc3d) | AcGeCircArc3d |
setCenter(const AcGePoint3d &) (defined in AcGeCircArc3d) | AcGeCircArc3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
setRadius(double) (defined in AcGeCircArc3d) | AcGeCircArc3d |
startAng() const (defined in AcGeCircArc3d) | AcGeCircArc3d |
startPoint() const (defined in AcGeCircArc3d) | AcGeCircArc3d |
tangent(const AcGePoint3d &pnt, AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCircArc3d) | AcGeCircArc3d |
tangent(const AcGePoint3d &pnt, AcGeLine3d &line, const AcGeTol &tol, AcGeError &error) const (defined in AcGeCircArc3d) | AcGeCircArc3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeClipBoundary2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeClipBoundary2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeClipBoundary2d:

Public Member Functions

AcGeClipBoundary2d (const AcGePoint2d &cornerA, const AcGePoint2d &cornerB)
AcGeClipBoundary2d (const AcGePoint2dArray &clipBoundary)
AcGeClipBoundary2d (const AcGeClipBoundary2d &src)
AcGe::ClipError | clipPolygon (const AcGePoint2dArray &rawVertices, AcGePoint2dArray &clippedVertices, AcGe::ClipCondition &clipCondition, AcGeIntArray *pClippedSegmentSourceLabel=0) const
AcGe::ClipError | clipPolyline (const AcGePoint2dArray &rawVertices, AcGePoint2dArray &clippedVertices, AcGe::ClipCondition &clipCondition, AcGeIntArray *pClippedSegmentSourceLabel=0) const
AcGeClipBoundary2d & | operator= (const AcGeClipBoundary2d &crvInt)
AcGe::ClipError | set (const AcGePoint2d &cornerA, const AcGePoint2d &cornerB)
AcGe::ClipError | set (const AcGePoint2dArray &clipBoundary)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeEntity2d
AcGeEntity2d (const AcGeEntity2d &)
AcGeEntity2d (AcGeImpEntity3d &, int)
AcGeEntity2d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geclip2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeClipBoundary2d Member List

This is the complete list of members for AcGeClipBoundary2d, including all inherited members.

AcGeClipBoundary2d() (defined in AcGeClipBoundary2d) | AcGeClipBoundary2d |
AcGeClipBoundary2d(const AcGePoint2d &cornerA, const AcGePoint2d &cornerB) (defined in AcGeClipBoundary2d) | AcGeClipBoundary2d |
AcGeClipBoundary2d(const AcGePoint2dArray &clipBoundary) (defined in AcGeClipBoundary2d) | AcGeClipBoundary2d |
AcGeClipBoundary2d(const AcGeClipBoundary2d &src) (defined in AcGeClipBoundary2d) | AcGeClipBoundary2d |
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
clipPolygon(const AcGePoint2dArray &rawVertices, AcGePoint2dArray &clippedVertices, AcGe::ClipCondition &clipCondition, AcGeIntArray *pClippedSegmentSourceLabel=0) const (defined in AcGeClipBoundary2d) | AcGeClipBoundary2d |
clipPolyline(const AcGePoint2dArray &rawVertices, AcGePoint2dArray &clippedVertices, AcGe::ClipCondition &clipCondition, AcGeIntArray *pClippedSegmentSourceLabel=0) const (defined in AcGeClipBoundary2d) | AcGeClipBoundary2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeClipBoundary2d &crvInt) (defined in AcGeClipBoundary2d) | AcGeClipBoundary2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(const AcGePoint2d &cornerA, const AcGePoint2d &cornerB) (defined in AcGeClipBoundary2d) | AcGeClipBoundary2d |
set(const AcGePoint2dArray &clipBoundary) (defined in AcGeClipBoundary2d) | AcGeClipBoundary2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeCompositeCurve2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCompositeCurve2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCompositeCurve2d:

Public Member Functions

AcGeCompositeCurve2d (const AcGeVoidPointerArray &curveList)
AcGeCompositeCurve2d (const AcGeVoidPointerArray &curveList, const AcGeIntArray &isOwnerOfCurves)
AcGeCompositeCurve2d (const AcGeCompositeCurve2d &compCurve)
void | getCurveList (AcGeVoidPointerArray &curveList) const
double | globalToLocalParam (double param, int &crvNum) const
double | localToGlobalParam (double param, int crvNum) const
AcGeCompositeCurve2d & | operator= (const AcGeCompositeCurve2d &compCurve)
AcGeCompositeCurve2d & | setCurveList (const AcGeVoidPointerArray &curveList)
AcGeCompositeCurve2d & | setCurveList (const AcGeVoidPointerArray &curveList, const AcGeIntArray &isOwnerOfCurves)
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve2d
AcGeCurve2d (const AcGeCurve2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecomp2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCompositeCurve2d Member List

This is the complete list of members for AcGeCompositeCurve2d, including all inherited members.

AcGeCompositeCurve2d() (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
AcGeCompositeCurve2d(const AcGeVoidPointerArray &curveList) (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
AcGeCompositeCurve2d(const AcGeVoidPointerArray &curveList, const AcGeIntArray &isOwnerOfCurves) (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
AcGeCompositeCurve2d(const AcGeCompositeCurve2d &compCurve) (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getCurveList(AcGeVoidPointerArray &curveList) const (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
globalToLocalParam(double param, int &crvNum) const (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
localToGlobalParam(double param, int crvNum) const (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeCompositeCurve2d &compCurve) (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
setCurveList(const AcGeVoidPointerArray &curveList) (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
setCurveList(const AcGeVoidPointerArray &curveList, const AcGeIntArray &isOwnerOfCurves) (defined in AcGeCompositeCurve2d) | AcGeCompositeCurve2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeCompositeCurve3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCompositeCurve3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCompositeCurve3d:

Public Member Functions

AcGeCompositeCurve3d (const AcGeVoidPointerArray &curveList)
AcGeCompositeCurve3d (const AcGeVoidPointerArray &curveList, const AcGeIntArray &isOwnerOfCurves)
AcGeCompositeCurve3d (const AcGeCompositeCurve3d &compCurve)
void | getCurveList (AcGeVoidPointerArray &curveList) const
double | globalToLocalParam (double param, int &segNum) const
double | localToGlobalParam (double param, int segNum) const
AcGeCompositeCurve3d & | operator= (const AcGeCompositeCurve3d &compCurve)
AcGeCompositeCurve3d & | setCurveList (const AcGeVoidPointerArray &curveList)
AcGeCompositeCurve3d & | setCurveList (const AcGeVoidPointerArray &curveList, const AcGeIntArray &isOwnerOfCurves)
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve3d
AcGeCurve3d (const AcGeCurve3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecomp3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCompositeCurve3d Member List

This is the complete list of members for AcGeCompositeCurve3d, including all inherited members.

AcGeCompositeCurve3d() (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
AcGeCompositeCurve3d(const AcGeVoidPointerArray &curveList) (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
AcGeCompositeCurve3d(const AcGeVoidPointerArray &curveList, const AcGeIntArray &isOwnerOfCurves) (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
AcGeCompositeCurve3d(const AcGeCompositeCurve3d &compCurve) (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getCurveList(AcGeVoidPointerArray &curveList) const (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
globalToLocalParam(double param, int &segNum) const (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
localToGlobalParam(double param, int segNum) const (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeCompositeCurve3d &compCurve) (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setCurveList(const AcGeVoidPointerArray &curveList) (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
setCurveList(const AcGeVoidPointerArray &curveList, const AcGeIntArray &isOwnerOfCurves) (defined in AcGeCompositeCurve3d) | AcGeCompositeCurve3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeCone Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCone Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCone:

Public Member Functions

AcGeCone (double cosineAngle, double sineAngle, const AcGePoint3d &baseOrigin, double baseRadius, const AcGeVector3d &axisOfSymmetry)
AcGeCone (double cosineAngle, double sineAngle, const AcGePoint3d &baseOrigin, double baseRadius, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, const AcGeInterval &height, double startAngle, double endAngle)
AcGeCone (const AcGeCone &cone)
AcGePoint3d | apex () const
AcGeVector3d | axisOfSymmetry () const
AcGePoint3d | baseCenter () const
double | baseRadius () const
void | getAngles (double &start, double &end) const
void | getHalfAngle (double &cosineAngle, double &sineAngle) const
void | getHeight (AcGeInterval &range) const
double | halfAngle () const
double | heightAt (double u) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &linEnt, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOuterNormal () const
AcGeCone & | operator= (const AcGeCone &cone)
AcGeVector3d | refAxis () const
AcGeCone & | set (double cosineAngle, double sineAngle, const AcGePoint3d &baseCenter, double baseRadius, const AcGeVector3d &axisOfSymmetry)
AcGeCone & | set (double cosineAngle, double sineAngle, const AcGePoint3d &baseCenter, double baseRadius, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, const AcGeInterval &height, double startAngle, double endAngle)
AcGeCone & | setAngles (double startAngle, double endAngle)
AcGeCone & | setBaseRadius (double radius)
AcGeCone & | setHeight (const AcGeInterval &height)
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSurface
AcGeSurface (const AcGeSurface &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecone.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCone Member List

This is the complete list of members for AcGeCone, including all inherited members.

AcGeCone() (defined in AcGeCone) | AcGeCone |
AcGeCone(double cosineAngle, double sineAngle, const AcGePoint3d &baseOrigin, double baseRadius, const AcGeVector3d &axisOfSymmetry) (defined in AcGeCone) | AcGeCone |
AcGeCone(double cosineAngle, double sineAngle, const AcGePoint3d &baseOrigin, double baseRadius, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, const AcGeInterval &height, double startAngle, double endAngle) (defined in AcGeCone) | AcGeCone |
AcGeCone(const AcGeCone &cone) (defined in AcGeCone) | AcGeCone |
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
apex() const (defined in AcGeCone) | AcGeCone |
axisOfSymmetry() const (defined in AcGeCone) | AcGeCone |
baseCenter() const (defined in AcGeCone) | AcGeCone |
baseRadius() const (defined in AcGeCone) | AcGeCone |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
getAngles(double &start, double &end) const (defined in AcGeCone) | AcGeCone |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
getHalfAngle(double &cosineAngle, double &sineAngle) const (defined in AcGeCone) | AcGeCone |
getHeight(AcGeInterval &range) const (defined in AcGeCone) | AcGeCone |
halfAngle() const (defined in AcGeCone) | AcGeCone |
heightAt(double u) const (defined in AcGeCone) | AcGeCone |
intersectWith(const AcGeLinearEnt3d &linEnt, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCone) | AcGeCone |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCone) | AcGeCone |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOuterNormal() const (defined in AcGeCone) | AcGeCone |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeCone &cone) (defined in AcGeCone) | AcGeCone |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
refAxis() const (defined in AcGeCone) | AcGeCone |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(double cosineAngle, double sineAngle, const AcGePoint3d &baseCenter, double baseRadius, const AcGeVector3d &axisOfSymmetry) (defined in AcGeCone) | AcGeCone |
set(double cosineAngle, double sineAngle, const AcGePoint3d &baseCenter, double baseRadius, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, const AcGeInterval &height, double startAngle, double endAngle) (defined in AcGeCone) | AcGeCone |
setAngles(double startAngle, double endAngle) (defined in AcGeCone) | AcGeCone |
setBaseRadius(double radius) (defined in AcGeCone) | AcGeCone |
setHeight(const AcGeInterval &height) (defined in AcGeCone) | AcGeCone |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeCubicSplineCurve2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCubicSplineCurve2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCubicSplineCurve2d:

Public Member Functions

AcGeCubicSplineCurve2d (const AcGeCubicSplineCurve2d &spline)
AcGeCubicSplineCurve2d (const AcGePoint2dArray &fitPnts, const AcGeTol &tol=AcGeContext::gTol)
AcGeCubicSplineCurve2d (const AcGePoint2dArray &fitPnts, const AcGeVector2d &startDeriv, const AcGeVector2d &endDeriv, const AcGeTol &tol=AcGeContext::gTol)
AcGeCubicSplineCurve2d (const AcGeCurve2d &curve, double epsilon=AcGeContext::gTol.equalPoint())
AcGeCubicSplineCurve2d (const AcGeKnotVector &knots, const AcGePoint2dArray &fitPnts, const AcGeVector2dArray &firstDerivs, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeVector2d | firstDerivAt (int idx) const
AcGePoint2d | fitPointAt (int idx) const
int | numFitPoints () const
AcGeCubicSplineCurve2d & | operator= (const AcGeCubicSplineCurve2d &spline)
AcGeCubicSplineCurve2d & | setFirstDerivAt (int idx, const AcGeVector2d &deriv)
AcGeCubicSplineCurve2d & | setFitPointAt (int idx, const AcGePoint2d &point)
- Public Member Functions inherited from AcGeSplineEnt2d
int | continuityAtKnot (int idx, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | controlPointAt (int idx) const
int | degree () const
double | endParam () const
AcGePoint2d | endPoint () const
Adesk::Boolean | hasFitData () const
Adesk::Boolean | isRational () const
double | knotAt (int idx) const
const AcGeKnotVector & | knots () const
int | numControlPoints () const
int | numKnots () const
AcGeSplineEnt2d & | operator= (const AcGeSplineEnt2d &spline)
int | order () const
AcGeSplineEnt2d & | setControlPointAt (int idx, const AcGePoint2d &pnt)
AcGeSplineEnt2d & | setKnotAt (int idx, double val)
double | startParam () const
AcGePoint2d | startPoint () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSplineEnt2d
AcGeSplineEnt2d (const AcGeSplineEnt2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecspl2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCubicSplineCurve2d Member List

This is the complete list of members for AcGeCubicSplineCurve2d, including all inherited members.

AcGeCubicSplineCurve2d() (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
AcGeCubicSplineCurve2d(const AcGeCubicSplineCurve2d &spline) (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
AcGeCubicSplineCurve2d(const AcGePoint2dArray &fitPnts, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
AcGeCubicSplineCurve2d(const AcGePoint2dArray &fitPnts, const AcGeVector2d &startDeriv, const AcGeVector2d &endDeriv, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
AcGeCubicSplineCurve2d(const AcGeCurve2d &curve, double epsilon=AcGeContext::gTol.equalPoint()) (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
AcGeCubicSplineCurve2d(const AcGeKnotVector &knots, const AcGePoint2dArray &fitPnts, const AcGeVector2dArray &firstDerivs, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeSplineEnt2d() (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d | protected
AcGeSplineEnt2d(const AcGeSplineEnt2d &) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
continuityAtKnot(int idx, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
controlPointAt(int idx) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
degree() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
endParam() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
endPoint() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
firstDerivAt(int idx) const (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
fitPointAt(int idx) const (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasFitData() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
isRational() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
knotAt(int idx) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
knots() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
numControlPoints() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
numFitPoints() const (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
numKnots() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeCubicSplineCurve2d &spline) (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
operator=(const AcGeSplineEnt2d &spline) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
order() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
setControlPointAt(int idx, const AcGePoint2d &pnt) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
setFirstDerivAt(int idx, const AcGeVector2d &deriv) (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
setFitPointAt(int idx, const AcGePoint2d &point) (defined in AcGeCubicSplineCurve2d) | AcGeCubicSplineCurve2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
setKnotAt(int idx, double val) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
startParam() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
startPoint() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeCubicSplineCurve3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCubicSplineCurve3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCubicSplineCurve3d:

Public Member Functions

AcGeCubicSplineCurve3d (const AcGeCubicSplineCurve3d &spline)
AcGeCubicSplineCurve3d (const AcGePoint3dArray &fitPnts, const AcGeTol &tol=AcGeContext::gTol)
AcGeCubicSplineCurve3d (const AcGePoint3dArray &fitPnts, const AcGeVector3d &startDeriv, const AcGeVector3d &endDeriv, const AcGeTol &tol=AcGeContext::gTol)
AcGeCubicSplineCurve3d (const AcGeCurve3d &curve, double epsilon=AcGeContext::gTol.equalPoint())
AcGeCubicSplineCurve3d (const AcGeKnotVector &knots, const AcGePoint3dArray &fitPnts, const AcGeVector3dArray &firstDerivs, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeVector3d | firstDerivAt (int idx) const
AcGePoint3d | fitPointAt (int idx) const
int | numFitPoints () const
AcGeCubicSplineCurve3d & | operator= (const AcGeCubicSplineCurve3d &spline)
AcGeCubicSplineCurve3d & | setFirstDerivAt (int idx, const AcGeVector3d &deriv)
AcGeCubicSplineCurve3d & | setFitPointAt (int idx, const AcGePoint3d &point)
- Public Member Functions inherited from AcGeSplineEnt3d
int | continuityAtKnot (int idx, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | controlPointAt (int idx) const
int | degree () const
double | endParam () const
AcGePoint3d | endPoint () const
Adesk::Boolean | hasFitData () const
Adesk::Boolean | isRational () const
double | knotAt (int idx) const
const AcGeKnotVector & | knots () const
int | numControlPoints () const
int | numKnots () const
AcGeSplineEnt3d & | operator= (const AcGeSplineEnt3d &spline)
int | order () const
AcGeSplineEnt3d & | setControlPointAt (int idx, const AcGePoint3d &pnt)
AcGeSplineEnt3d & | setKnotAt (int idx, double val)
double | startParam () const
AcGePoint3d | startPoint () const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSplineEnt3d
AcGeSplineEnt3d (const AcGeSplineEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecspl3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCubicSplineCurve3d Member List

This is the complete list of members for AcGeCubicSplineCurve3d, including all inherited members.

AcGeCubicSplineCurve3d() (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
AcGeCubicSplineCurve3d(const AcGeCubicSplineCurve3d &spline) (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
AcGeCubicSplineCurve3d(const AcGePoint3dArray &fitPnts, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
AcGeCubicSplineCurve3d(const AcGePoint3dArray &fitPnts, const AcGeVector3d &startDeriv, const AcGeVector3d &endDeriv, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
AcGeCubicSplineCurve3d(const AcGeCurve3d &curve, double epsilon=AcGeContext::gTol.equalPoint()) (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
AcGeCubicSplineCurve3d(const AcGeKnotVector &knots, const AcGePoint3dArray &fitPnts, const AcGeVector3dArray &firstDerivs, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeSplineEnt3d() (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
AcGeSplineEnt3d(const AcGeSplineEnt3d &) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
continuityAtKnot(int idx, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
controlPointAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
degree() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
endParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
endPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
firstDerivAt(int idx) const (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
fitPointAt(int idx) const (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasFitData() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isRational() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
knotAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
knots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numControlPoints() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
numFitPoints() const (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
numKnots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeCubicSplineCurve3d &spline) (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
operator=(const AcGeSplineEnt3d &spline) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
order() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setControlPointAt(int idx, const AcGePoint3d &pnt) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
setFirstDerivAt(int idx, const AcGeVector3d &deriv) (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
setFitPointAt(int idx, const AcGePoint3d &point) (defined in AcGeCubicSplineCurve3d) | AcGeCubicSplineCurve3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
setKnotAt(int idx, double val) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
startParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
startPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeCurve2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGeCurve2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCurve2d:

Public Member Functions

Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGeCurve2d (const AcGeCurve2d &)
- Protected Member Functions inherited from AcGeEntity2d
AcGeEntity2d (const AcGeEntity2d &)
AcGeEntity2d (AcGeImpEntity3d &, int)
AcGeEntity2d (AcGeImpEntity3d *)
AcGeEntity2d * newEntity2d (AcGeImpEntity3d *) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecurv2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCurve2d Member List

This is the complete list of members for AcGeCurve2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeCurve3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGeCurve3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCurve3d:

Public Member Functions

Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGeCurve3d (const AcGeCurve3d &)
- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecurv3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCurve3d Member List

This is the complete list of members for AcGeCurve3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeCurveBoundary Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
AcGeCurveBoundary Class Reference
AcGe Classes

Public Member Functions

AcGeCurveBoundary (int numberOfCurves, const AcGeEntity3d *const *crv3d, const AcGeCurve2d *const *crv2d, Adesk::Boolean *orientation3d, Adesk::Boolean *orientation2d, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGeCurveBoundary (const AcGeCurveBoundary &)
void | getContour (int &n, AcGeEntity3d ***crv3d, AcGeCurve2d ***paramGeometry, Adesk::Boolean **orientation3d, Adesk::Boolean **orientation2d) const
Adesk::Boolean | isDegenerate () const
Adesk::Boolean | isDegenerate (AcGePosition3d &degenPoint, AcGeCurve2d **paramCurve) const
Adesk::Boolean | isOwnerOfCurves () const
int | numElements () const
AcGeCurveBoundary & | operator= (const AcGeCurveBoundary &src)
AcGeCurveBoundary & | set (int numElements, const AcGeEntity3d *const *crv3d, const AcGeCurve2d *const *crv2d, Adesk::Boolean *orientation3d, Adesk::Boolean *orientation2d, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGeCurveBoundary & | setToOwnCurves ()

Protected Attributes

int | mDelBnd
AcGeImpCurveBoundary * | mpImpBnd

Friends

class AcGeImpCurveBoundary
The documentation for this class was generated from the following file:
  • gecbndry.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCurveBoundary Member List

This is the complete list of members for AcGeCurveBoundary, including all inherited members.

AcGeCurveBoundary() (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
AcGeCurveBoundary(int numberOfCurves, const AcGeEntity3d *const *crv3d, const AcGeCurve2d *const *crv2d, Adesk::Boolean *orientation3d, Adesk::Boolean *orientation2d, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
AcGeCurveBoundary(const AcGeCurveBoundary &) (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
AcGeImpCurveBoundary (defined in AcGeCurveBoundary) | AcGeCurveBoundary | friend
getContour(int &n, AcGeEntity3d ***crv3d, AcGeCurve2d ***paramGeometry, Adesk::Boolean **orientation3d, Adesk::Boolean **orientation2d) const (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
isDegenerate() const (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
isDegenerate(AcGePosition3d &degenPoint, AcGeCurve2d **paramCurve) const (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
isOwnerOfCurves() const (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
mDelBnd (defined in AcGeCurveBoundary) | AcGeCurveBoundary | protected
mpImpBnd (defined in AcGeCurveBoundary) | AcGeCurveBoundary | protected
numElements() const (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
operator=(const AcGeCurveBoundary &src) (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
set(int numElements, const AcGeEntity3d *const *crv3d, const AcGeCurve2d *const *crv2d, Adesk::Boolean *orientation3d, Adesk::Boolean *orientation2d, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
setToOwnCurves() (defined in AcGeCurveBoundary) | AcGeCurveBoundary |
~AcGeCurveBoundary() (defined in AcGeCurveBoundary) | AcGeCurveBoundary |


ZRX API Reference: AcGeCurveCurveInt2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCurveCurveInt2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCurveCurveInt2d:

Public Member Functions

AcGeCurveCurveInt2d (const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeTol &tol=AcGeContext::gTol)
AcGeCurveCurveInt2d (const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeInterval &range1, const AcGeInterval &range2, const AcGeTol &tol=AcGeContext::gTol)
AcGeCurveCurveInt2d (const AcGeCurveCurveInt2d &src)
void | changeCurveOrder ()
const AcGeCurve2d * | curve1 () const
const AcGeCurve2d * | curve2 () const
void | getIntConfigs (int intNum, AcGe::AcGeXConfig &config1wrt2, AcGe::AcGeXConfig &config2wrt1) const
void | getIntParams (int intNum, double &param1, double &param2) const
void | getIntRanges (AcGeInterval &range1, AcGeInterval &range2) const
void | getOverlapRanges (int overlapNum, AcGeInterval &range1, AcGeInterval &range2) const
void | getPointOnCurve1 (int intNum, AcGePointOnCurve2d &) const
void | getPointOnCurve2 (int intNum, AcGePointOnCurve2d &) const
AcGePoint2d | intPoint (int intNum) const
double | intPointTol (int intNum) const
Adesk::Boolean | isTangential (int intNum) const
Adesk::Boolean | isTransversal (int intNum) const
int | numIntPoints () const
AcGeCurveCurveInt2d & | operator= (const AcGeCurveCurveInt2d &src)
AcGeCurveCurveInt2d & | orderWrt1 ()
AcGeCurveCurveInt2d & | orderWrt2 ()
int | overlapCount () const
Adesk::Boolean | overlapDirection () const
AcGeCurveCurveInt2d & | set (const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeTol &tol=AcGeContext::gTol)
AcGeCurveCurveInt2d & | set (const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeInterval &range1, const AcGeInterval &range2, const AcGeTol &tol=AcGeContext::gTol)
AcGeTol | tolerance () const
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeEntity2d
AcGeEntity2d (const AcGeEntity2d &)
AcGeEntity2d (AcGeImpEntity3d &, int)
AcGeEntity2d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecint2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCurveCurveInt2d Member List

This is the complete list of members for AcGeCurveCurveInt2d, including all inherited members.

AcGeCurveCurveInt2d() (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
AcGeCurveCurveInt2d(const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
AcGeCurveCurveInt2d(const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeInterval &range1, const AcGeInterval &range2, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
AcGeCurveCurveInt2d(const AcGeCurveCurveInt2d &src) (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
changeCurveOrder() (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
curve1() const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
curve2() const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
getIntConfigs(int intNum, AcGe::AcGeXConfig &config1wrt2, AcGe::AcGeXConfig &config2wrt1) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
getIntParams(int intNum, double &param1, double &param2) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
getIntRanges(AcGeInterval &range1, AcGeInterval &range2) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
getOverlapRanges(int overlapNum, AcGeInterval &range1, AcGeInterval &range2) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
getPointOnCurve1(int intNum, AcGePointOnCurve2d &) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
getPointOnCurve2(int intNum, AcGePointOnCurve2d &) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
intPoint(int intNum) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
intPointTol(int intNum) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isTangential(int intNum) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
isTransversal(int intNum) const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
numIntPoints() const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeCurveCurveInt2d &src) (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orderWrt1() (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
orderWrt2() (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
overlapCount() const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
overlapDirection() const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
set(const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, const AcGeInterval &range1, const AcGeInterval &range2, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
tolerance() const (defined in AcGeCurveCurveInt2d) | AcGeCurveCurveInt2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeCurveCurveInt3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCurveCurveInt3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCurveCurveInt3d:

Public Member Functions

AcGeCurveCurveInt3d (const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeVector3d &planeNormal=AcGeVector3d::kIdentity, const AcGeTol &tol=AcGeContext::gTol)
AcGeCurveCurveInt3d (const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeInterval &range1, const AcGeInterval &range2, const AcGeVector3d &planeNormal=AcGeVector3d::kIdentity, const AcGeTol &tol=AcGeContext::gTol)
AcGeCurveCurveInt3d (const AcGeCurveCurveInt3d &src)
void | changeCurveOrder ()
const AcGeCurve3d * | curve1 () const
const AcGeCurve3d * | curve2 () const
void | getIntConfigs (int intNum, AcGe::AcGeXConfig &config1wrt2, AcGe::AcGeXConfig &config2wrt1) const
void | getIntParams (int intNum, double &param1, double &param2) const
void | getIntRanges (AcGeInterval &range1, AcGeInterval &range2) const
void | getOverlapRanges (int overlapNum, AcGeInterval &range1, AcGeInterval &range2) const
void | getPointOnCurve1 (int intNum, AcGePointOnCurve3d &pntOnCrv) const
void | getPointOnCurve2 (int intNum, AcGePointOnCurve3d &pntOnCrv) const
AcGePoint3d | intPoint (int intNum) const
double | intPointTol (int intNum) const
Adesk::Boolean | isTangential (int intNum) const
Adesk::Boolean | isTransversal (int intNum) const
int | numIntPoints () const
AcGeCurveCurveInt3d & | operator= (const AcGeCurveCurveInt3d &src)
AcGeCurveCurveInt3d & | orderWrt1 ()
AcGeCurveCurveInt3d & | orderWrt2 ()
int | overlapCount () const
Adesk::Boolean | overlapDirection () const
AcGeVector3d | planeNormal () const
AcGeCurveCurveInt3d & | set (const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeVector3d &planeNormal=AcGeVector3d::kIdentity, const AcGeTol &tol=AcGeContext::gTol)
AcGeCurveCurveInt3d & | set (const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeInterval &range1, const AcGeInterval &range2, const AcGeVector3d &planeNormal=AcGeVector3d::kIdentity, const AcGeTol &tol=AcGeContext::gTol)
AcGeTol | tolerance () const
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecint3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCurveCurveInt3d Member List

This is the complete list of members for AcGeCurveCurveInt3d, including all inherited members.

AcGeCurveCurveInt3d() (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
AcGeCurveCurveInt3d(const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeVector3d &planeNormal=AcGeVector3d::kIdentity, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
AcGeCurveCurveInt3d(const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeInterval &range1, const AcGeInterval &range2, const AcGeVector3d &planeNormal=AcGeVector3d::kIdentity, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
AcGeCurveCurveInt3d(const AcGeCurveCurveInt3d &src) (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
changeCurveOrder() (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
curve1() const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
curve2() const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
getIntConfigs(int intNum, AcGe::AcGeXConfig &config1wrt2, AcGe::AcGeXConfig &config2wrt1) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
getIntParams(int intNum, double &param1, double &param2) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
getIntRanges(AcGeInterval &range1, AcGeInterval &range2) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
getOverlapRanges(int overlapNum, AcGeInterval &range1, AcGeInterval &range2) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
getPointOnCurve1(int intNum, AcGePointOnCurve3d &pntOnCrv) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
getPointOnCurve2(int intNum, AcGePointOnCurve3d &pntOnCrv) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
intPoint(int intNum) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
intPointTol(int intNum) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isTangential(int intNum) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
isTransversal(int intNum) const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numIntPoints() const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeCurveCurveInt3d &src) (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orderWrt1() (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
orderWrt2() (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
overlapCount() const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
overlapDirection() const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
planeNormal() const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeVector3d &planeNormal=AcGeVector3d::kIdentity, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
set(const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, const AcGeInterval &range1, const AcGeInterval &range2, const AcGeVector3d &planeNormal=AcGeVector3d::kIdentity, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
tolerance() const (defined in AcGeCurveCurveInt3d) | AcGeCurveCurveInt3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeCurveSurfInt Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCurveSurfInt Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCurveSurfInt:

Public Member Functions

AcGeCurveSurfInt (const AcGeCurve3d &crv, const AcGeSurface &srf, const AcGeTol &tol=AcGeContext::gTol)
AcGeCurveSurfInt (const AcGeCurveSurfInt &src)
const AcGeCurve3d * | curve () const
void | getIntConfigs (int intNum, AcGe::csiConfig &lower, AcGe::csiConfig &higher, Adesk::Boolean &smallAngle, AcGeIntersectError &err) const
void | getIntParams (int intNum, double &param1, AcGePoint2d &param2, AcGeIntersectError &err) const
void | getPointOnCurve (int intNum, AcGePointOnCurve3d &, AcGeIntersectError &err) const
void | getPointOnSurface (int intNum, AcGePointOnSurface &, AcGeIntersectError &err) const
AcGePoint3d | intPoint (int intNum, AcGeIntersectError &err) const
int | numIntPoints (AcGeIntersectError &err) const
AcGeCurveSurfInt & | operator= (const AcGeCurveSurfInt &crvInt)
AcGeCurveSurfInt & | set (const AcGeCurve3d &cvr, const AcGeSurface &srf, const AcGeTol &tol=AcGeContext::gTol)
const AcGeSurface * | surface () const
AcGeTol | tolerance () const
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecsint.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCurveSurfInt Member List

This is the complete list of members for AcGeCurveSurfInt, including all inherited members.

AcGeCurveSurfInt() (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
AcGeCurveSurfInt(const AcGeCurve3d &crv, const AcGeSurface &srf, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
AcGeCurveSurfInt(const AcGeCurveSurfInt &src) (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
curve() const (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
getIntConfigs(int intNum, AcGe::csiConfig &lower, AcGe::csiConfig &higher, Adesk::Boolean &smallAngle, AcGeIntersectError &err) const (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
getIntParams(int intNum, double &param1, AcGePoint2d &param2, AcGeIntersectError &err) const (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
getPointOnCurve(int intNum, AcGePointOnCurve3d &, AcGeIntersectError &err) const (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
getPointOnSurface(int intNum, AcGePointOnSurface &, AcGeIntersectError &err) const (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
intPoint(int intNum, AcGeIntersectError &err) const (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numIntPoints(AcGeIntersectError &err) const (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeCurveSurfInt &crvInt) (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGeCurve3d &cvr, const AcGeSurface &srf, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
surface() const (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
tolerance() const (defined in AcGeCurveSurfInt) | AcGeCurveSurfInt |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeCylinder Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeCylinder Class Reference
AcGe Classes
+ Inheritance diagram for AcGeCylinder:

Public Member Functions

AcGeCylinder (double radius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry)
AcGeCylinder (double radius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, const AcGeInterval &height, double startAngle, double endAngle)
AcGeCylinder (const AcGeCylinder &)
AcGeVector3d | axisOfSymmetry () const
void | getAngles (double &start, double &end) const
void | getHeight (AcGeInterval &height) const
double | heightAt (double u) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &linEnt, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOuterNormal () const
AcGeCylinder & | operator= (const AcGeCylinder &cylinder)
AcGePoint3d | origin () const
double | radius () const
AcGeVector3d | refAxis () const
AcGeCylinder & | set (double radius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSym)
AcGeCylinder & | set (double radius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSym, const AcGeVector3d &refAxis, const AcGeInterval &height, double startAngle, double endAngle)
AcGeCylinder & | setAngles (double start, double end)
AcGeCylinder & | setHeight (const AcGeInterval &height)
AcGeCylinder & | setRadius (double radius)
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSurface
AcGeSurface (const AcGeSurface &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gecylndr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeCylinder Member List

This is the complete list of members for AcGeCylinder, including all inherited members.

AcGeCylinder() (defined in AcGeCylinder) | AcGeCylinder |
AcGeCylinder(double radius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry) (defined in AcGeCylinder) | AcGeCylinder |
AcGeCylinder(double radius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, const AcGeInterval &height, double startAngle, double endAngle) (defined in AcGeCylinder) | AcGeCylinder |
AcGeCylinder(const AcGeCylinder &) (defined in AcGeCylinder) | AcGeCylinder |
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
axisOfSymmetry() const (defined in AcGeCylinder) | AcGeCylinder |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
getAngles(double &start, double &end) const (defined in AcGeCylinder) | AcGeCylinder |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
getHeight(AcGeInterval &height) const (defined in AcGeCylinder) | AcGeCylinder |
heightAt(double u) const (defined in AcGeCylinder) | AcGeCylinder |
intersectWith(const AcGeLinearEnt3d &linEnt, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCylinder) | AcGeCylinder |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCylinder) | AcGeCylinder |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOuterNormal() const (defined in AcGeCylinder) | AcGeCylinder |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeCylinder &cylinder) (defined in AcGeCylinder) | AcGeCylinder |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
origin() const (defined in AcGeCylinder) | AcGeCylinder |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
radius() const (defined in AcGeCylinder) | AcGeCylinder |
refAxis() const (defined in AcGeCylinder) | AcGeCylinder |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(double radius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSym) (defined in AcGeCylinder) | AcGeCylinder |
set(double radius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSym, const AcGeVector3d &refAxis, const AcGeInterval &height, double startAngle, double endAngle) (defined in AcGeCylinder) | AcGeCylinder |
setAngles(double start, double end) (defined in AcGeCylinder) | AcGeCylinder |
setHeight(const AcGeInterval &height) (defined in AcGeCylinder) | AcGeCylinder |
setRadius(double radius) (defined in AcGeCylinder) | AcGeCylinder |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeDwgIO Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Static Public Member Functions | Static Public Attributes | List of all members
AcGeDwgIO Class Reference
AcGe Classes

Static Public Member Functions

static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePoint2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeVector2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeMatrix2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeScale2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePoint2dArray &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeVector2dArray &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePoint3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeVector3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeMatrix3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeScale3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePoint3dArray &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeVector3dArray &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeTol &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeInterval &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeKnotVector &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeDoubleArray &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeIntArray &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCurveBoundary &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePosition2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePointOnCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeLine2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeLineSeg2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeRay2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCircArc2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeEllipArc2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeExternalCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCubicSplineCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeNurbCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCompositeCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeOffsetCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePolyline2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePosition3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePointOnCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePointOnSurface &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeLine3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeRay3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeLineSeg3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePlane &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeBoundedPlane &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCircArc3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeEllipArc3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCubicSplineCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCompositeCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeOffsetCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeNurbCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGePolyline3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeAugPolyline3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeExternalCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCone &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCylinder &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeTorus &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeExternalSurface &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeOffsetSurface &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeNurbSurface &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeExternalBoundedSurface &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeSphere &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeBoundBlock2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeBoundBlock3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCurveCurveInt2d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeCurveCurveInt3d &)
static Acad::ErrorStatus | inFields (AcDbDwgFiler *, AcGeEllipCone &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePoint2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeVector2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeMatrix2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeScale2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePoint2dArray &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeVector2dArray &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePoint3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeVector3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeMatrix3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeScale3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePoint3dArray &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeVector3dArray &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeTol &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeInterval &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeKnotVector &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeDoubleArray &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeIntArray &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCurveBoundary &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePosition2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePointOnCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeLine2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeLineSeg2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeRay2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCircArc2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeEllipArc2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeExternalCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCubicSplineCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeNurbCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCompositeCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeOffsetCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePolyline2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePosition3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePointOnCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePointOnSurface &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeLine3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeRay3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeLineSeg3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePlane &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeBoundedPlane &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCircArc3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeEllipArc3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCubicSplineCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeNurbCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCompositeCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeOffsetCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGePolyline3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeAugPolyline3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeExternalCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCone &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCylinder &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeTorus &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeExternalSurface &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeOffsetSurface &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeNurbSurface &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeExternalBoundedSurface &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeSphere &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeBoundBlock2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeBoundBlock3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCurveCurveInt2d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeCurveCurveInt3d &)
static Acad::ErrorStatus | outFields (AcDbDwgFiler *, const AcGeEllipCone &)

Static Public Attributes

static const AcGeLibVersion AcGeDwgIOVersion
The documentation for this class was generated from the following file:
  • gedwgio.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeDwgIO Member List

This is the complete list of members for AcGeDwgIO, including all inherited members.

AcGeDwgIOVersion (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePoint2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeVector2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeMatrix2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeScale2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePoint2dArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeVector2dArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePoint3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeVector3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeMatrix3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeScale3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePoint3dArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeVector3dArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeTol &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeInterval &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeKnotVector &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeDoubleArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeIntArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCurveBoundary &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePosition2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePointOnCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeLine2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeLineSeg2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeRay2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCircArc2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeEllipArc2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeExternalCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCubicSplineCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeNurbCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCompositeCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeOffsetCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePolyline2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePosition3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePointOnCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePointOnSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeLine3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeRay3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeLineSeg3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePlane &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeBoundedPlane &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCircArc3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeEllipArc3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCubicSplineCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCompositeCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeOffsetCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeNurbCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGePolyline3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeAugPolyline3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeExternalCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCone &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCylinder &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeTorus &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeExternalSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeOffsetSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeNurbSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeExternalBoundedSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeSphere &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeBoundBlock2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeBoundBlock3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCurveCurveInt2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeCurveCurveInt3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
inFields(AcDbDwgFiler *, AcGeEllipCone &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePoint2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeVector2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeMatrix2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeScale2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePoint2dArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeVector2dArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePoint3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeVector3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeMatrix3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeScale3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePoint3dArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeVector3dArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeTol &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeInterval &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeKnotVector &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeDoubleArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeIntArray &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCurveBoundary &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePosition2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePointOnCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeLine2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeLineSeg2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeRay2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCircArc2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeEllipArc2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeExternalCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCubicSplineCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeNurbCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCompositeCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeOffsetCurve2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePolyline2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePosition3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePointOnCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePointOnSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeLine3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeRay3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeLineSeg3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePlane &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeBoundedPlane &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCircArc3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeEllipArc3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCubicSplineCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeNurbCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCompositeCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeOffsetCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGePolyline3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeAugPolyline3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeExternalCurve3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCone &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCylinder &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeTorus &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeExternalSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeOffsetSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeNurbSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeExternalBoundedSurface &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeSphere &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeBoundBlock2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeBoundBlock3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCurveCurveInt2d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeCurveCurveInt3d &) (defined in AcGeDwgIO) | AcGeDwgIO | static
outFields(AcDbDwgFiler *, const AcGeEllipCone &) (defined in AcGeDwgIO) | AcGeDwgIO | static


ZRX API Reference: AcGeDxfIO Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Static Public Member Functions | Static Public Attributes | List of all members
AcGeDxfIO Class Reference
AcGe Classes

Static Public Member Functions

static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePoint2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeVector2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeMatrix2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeScale2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePoint2dArray &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeVector2dArray &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePoint3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeVector3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeMatrix3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeScale3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePoint3dArray &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeVector3dArray &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeTol &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeInterval &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeKnotVector &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeDoubleArray &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeIntArray &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCurveBoundary &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePosition2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePointOnCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeLine2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeLineSeg2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeRay2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCircArc2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeEllipArc2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeExternalCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCubicSplineCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeNurbCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCompositeCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeOffsetCurve2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePolyline2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePosition3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePointOnCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePointOnSurface &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeLine3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeRay3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeLineSeg3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePlane &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeBoundedPlane &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCircArc3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeEllipArc3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCubicSplineCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeNurbCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCompositeCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeOffsetCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGePolyline3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeAugPolyline3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeExternalCurve3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCone &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCylinder &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeTorus &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeExternalSurface &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeOffsetSurface &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeNurbSurface &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeExternalBoundedSurface &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeSphere &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeBoundBlock2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeBoundBlock3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCurveCurveInt2d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeCurveCurveInt3d &)
static Acad::ErrorStatus | inFields (AcDbDxfFiler *, AcGeEllipCone &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePoint2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeVector2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeMatrix2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeScale2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePoint2dArray &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeVector2dArray &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePoint3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeVector3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeMatrix3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeScale3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePoint3dArray &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeVector3dArray &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeTol &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeInterval &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeKnotVector &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeDoubleArray &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeIntArray &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCurveBoundary &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePosition2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePointOnCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeLine2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeLineSeg2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeRay2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCircArc2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeEllipArc2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeExternalCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCubicSplineCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeNurbCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCompositeCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeOffsetCurve2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePolyline2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePosition3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePointOnCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePointOnSurface &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeLine3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeRay3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeLineSeg3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePlane &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeBoundedPlane &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCircArc3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeEllipArc3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCubicSplineCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeNurbCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCompositeCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeOffsetCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGePolyline3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeAugPolyline3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeExternalCurve3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCone &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCylinder &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeTorus &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeExternalSurface &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeOffsetSurface &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeNurbSurface &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeExternalBoundedSurface &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeSphere &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeBoundBlock2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeBoundBlock3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCurveCurveInt2d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeCurveCurveInt3d &)
static Acad::ErrorStatus | outFields (AcDbDxfFiler *, const AcGeEllipCone &)

Static Public Attributes

static const AcGeLibVersion AcGeDxfIOVersion
The documentation for this class was generated from the following file:
  • gedxfio.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeDxfIO Member List

This is the complete list of members for AcGeDxfIO, including all inherited members.

AcGeDxfIOVersion (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePoint2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeVector2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeMatrix2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeScale2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePoint2dArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeVector2dArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePoint3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeVector3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeMatrix3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeScale3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePoint3dArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeVector3dArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeTol &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeInterval &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeKnotVector &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeDoubleArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeIntArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCurveBoundary &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePosition2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePointOnCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeLine2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeLineSeg2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeRay2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCircArc2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeEllipArc2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeExternalCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCubicSplineCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeNurbCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCompositeCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeOffsetCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePolyline2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePosition3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePointOnCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePointOnSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeLine3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeRay3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeLineSeg3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePlane &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeBoundedPlane &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCircArc3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeEllipArc3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCubicSplineCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeNurbCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCompositeCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeOffsetCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGePolyline3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeAugPolyline3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeExternalCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCone &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCylinder &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeTorus &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeExternalSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeOffsetSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeNurbSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeExternalBoundedSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeSphere &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeBoundBlock2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeBoundBlock3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCurveCurveInt2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeCurveCurveInt3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
inFields(AcDbDxfFiler *, AcGeEllipCone &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePoint2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeVector2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeMatrix2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeScale2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePoint2dArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeVector2dArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePoint3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeVector3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeMatrix3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeScale3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePoint3dArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeVector3dArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeTol &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeInterval &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeKnotVector &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeDoubleArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeIntArray &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCurveBoundary &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePosition2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePointOnCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeLine2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeLineSeg2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeRay2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCircArc2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeEllipArc2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeExternalCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCubicSplineCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeNurbCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCompositeCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeOffsetCurve2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePolyline2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePosition3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePointOnCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePointOnSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeLine3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeRay3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeLineSeg3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePlane &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeBoundedPlane &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCircArc3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeEllipArc3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCubicSplineCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeNurbCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCompositeCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeOffsetCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGePolyline3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeAugPolyline3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeExternalCurve3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCone &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCylinder &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeTorus &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeExternalSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeOffsetSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeNurbSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeExternalBoundedSurface &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeSphere &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeBoundBlock2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeBoundBlock3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCurveCurveInt2d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeCurveCurveInt3d &) (defined in AcGeDxfIO) | AcGeDxfIO | static
outFields(AcDbDxfFiler *, const AcGeEllipCone &) (defined in AcGeDxfIO) | AcGeDxfIO | static


ZRX API Reference: AcGeEllipArc2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeEllipArc2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeEllipArc2d:

Public Member Functions

AcGeEllipArc2d (const AcGeEllipArc2d &ell)
AcGeEllipArc2d (const AcGeCircArc2d &arc)
AcGeEllipArc2d (const AcGePoint2d &cent, const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis, double majorRadius, double minorRadius)
AcGeEllipArc2d (const AcGePoint2d &cent, const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis, double majorRadius, double minorRadius, double startAngle, double endAngle)
AcGePoint2d | center () const
double | endAng () const
AcGePoint2d | endPoint () const
Adesk::Boolean | intersectWith (const AcGeLinearEnt2d &line, int &intn, AcGePoint2d &p1, AcGePoint2d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCircular (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClockWise () const
Adesk::Boolean | isInside (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeVector2d | majorAxis () const
double | majorRadius () const
AcGeVector2d | minorAxis () const
double | minorRadius () const
AcGeEllipArc2d & | operator= (const AcGeEllipArc2d &ell)
AcGeEllipArc2d & | set (const AcGePoint2d &cent, const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis, double majorRadius, double minorRadius)
AcGeEllipArc2d & | set (const AcGePoint2d &cent, const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis, double majorRadius, double minorRadius, double startAngle, double endAngle)
AcGeEllipArc2d & | set (const AcGeCircArc2d &arc)
AcGeEllipArc2d & | setAngles (double startAngle, double endAngle)
AcGeEllipArc2d & | setAxes (const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis)
AcGeEllipArc2d & | setCenter (const AcGePoint2d &cent)
AcGeEllipArc2d & | setMajorRadius (double rad)
AcGeEllipArc2d & | setMinorRadius (double rad)
double | startAng () const
AcGePoint2d | startPoint () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve2d
AcGeCurve2d (const AcGeCurve2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geell2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeEllipArc2d Member List

This is the complete list of members for AcGeEllipArc2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEllipArc2d() (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
AcGeEllipArc2d(const AcGeEllipArc2d &ell) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
AcGeEllipArc2d(const AcGeCircArc2d &arc) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
AcGeEllipArc2d(const AcGePoint2d &cent, const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis, double majorRadius, double minorRadius) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
AcGeEllipArc2d(const AcGePoint2d &cent, const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis, double majorRadius, double minorRadius, double startAngle, double endAngle) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
center() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
endAng() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
endPoint() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
intersectWith(const AcGeLinearEnt2d &line, int &intn, AcGePoint2d &p1, AcGePoint2d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
isCircular(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
isClockWise() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isInside(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
majorAxis() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
majorRadius() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
minorAxis() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
minorRadius() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeEllipArc2d &ell) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(const AcGePoint2d &cent, const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis, double majorRadius, double minorRadius) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
set(const AcGePoint2d &cent, const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis, double majorRadius, double minorRadius, double startAngle, double endAngle) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
set(const AcGeCircArc2d &arc) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
setAngles(double startAngle, double endAngle) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
setAxes(const AcGeVector2d &majorAxis, const AcGeVector2d &minorAxis) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
setCenter(const AcGePoint2d &cent) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
setMajorRadius(double rad) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
setMinorRadius(double rad) (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
startAng() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
startPoint() const (defined in AcGeEllipArc2d) | AcGeEllipArc2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeEllipArc3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeEllipArc3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeEllipArc3d:

Public Member Functions

AcGeEllipArc3d (const AcGeEllipArc3d &ell)
AcGeEllipArc3d (const AcGeCircArc3d &arc)
AcGeEllipArc3d (const AcGePoint3d &cent, const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis, double majorRadius, double minorRadius)
AcGeEllipArc3d (const AcGePoint3d &cent, const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis, double majorRadius, double minorRadius, double ang1, double ang2)
AcGePoint3d | center () const
AcGePoint3d | closestPointToPlane (const AcGePlanarEnt &plane, AcGePoint3d &pointOnPlane, const AcGeTol &=AcGeContext::gTol) const
double | endAng () const
AcGePoint3d | endPoint () const
void | getPlane (AcGePlane &plane) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &line, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGePlanarEnt &plane, int &numOfIntersect, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCircular (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isInside (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeVector3d | majorAxis () const
double | majorRadius () const
AcGeVector3d | minorAxis () const
double | minorRadius () const
AcGeVector3d | normal () const
AcGeEllipArc3d & | operator= (const AcGeEllipArc3d &ell)
Adesk::Boolean | projIntersectWith (const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, int &numInt, AcGePoint3d &pntOnEllipse1, AcGePoint3d &pntOnEllipse2, AcGePoint3d &pntOnLine1, AcGePoint3d &pntOnLine2, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEllipArc3d & | set (const AcGePoint3d &cent, const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis, double majorRadius, double minorRadius)
AcGeEllipArc3d & | set (const AcGePoint3d &cent, const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis, double majorRadius, double minorRadius, double startAngle, double endAngle)
AcGeEllipArc3d & | set (const AcGeCircArc3d &)
AcGeEllipArc3d & | setAngles (double startAngle, double endAngle)
AcGeEllipArc3d & | setAxes (const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis)
AcGeEllipArc3d & | setCenter (const AcGePoint3d &cent)
AcGeEllipArc3d & | setMajorRadius (double rad)
AcGeEllipArc3d & | setMinorRadius (double rad)
double | startAng () const
AcGePoint3d | startPoint () const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve3d
AcGeCurve3d (const AcGeCurve3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geell3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeEllipArc3d Member List

This is the complete list of members for AcGeEllipArc3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEllipArc3d() (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
AcGeEllipArc3d(const AcGeEllipArc3d &ell) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
AcGeEllipArc3d(const AcGeCircArc3d &arc) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
AcGeEllipArc3d(const AcGePoint3d &cent, const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis, double majorRadius, double minorRadius) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
AcGeEllipArc3d(const AcGePoint3d &cent, const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis, double majorRadius, double minorRadius, double ang1, double ang2) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
center() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointToPlane(const AcGePlanarEnt &plane, AcGePoint3d &pointOnPlane, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
endAng() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
endPoint() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getPlane(AcGePlane &plane) const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
intersectWith(const AcGeLinearEnt3d &line, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
intersectWith(const AcGePlanarEnt &plane, int &numOfIntersect, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
isCircular(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isInside(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
majorAxis() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
majorRadius() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
minorAxis() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
minorRadius() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
normal() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeEllipArc3d &ell) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projIntersectWith(const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, int &numInt, AcGePoint3d &pntOnEllipse1, AcGePoint3d &pntOnEllipse2, AcGePoint3d &pntOnLine1, AcGePoint3d &pntOnLine2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGePoint3d &cent, const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis, double majorRadius, double minorRadius) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
set(const AcGePoint3d &cent, const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis, double majorRadius, double minorRadius, double startAngle, double endAngle) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
set(const AcGeCircArc3d &) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
setAngles(double startAngle, double endAngle) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
setAxes(const AcGeVector3d &majorAxis, const AcGeVector3d &minorAxis) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
setCenter(const AcGePoint3d &cent) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
setMajorRadius(double rad) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
setMinorRadius(double rad) (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
startAng() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
startPoint() const (defined in AcGeEllipArc3d) | AcGeEllipArc3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeEntity2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
AcGeEntity2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeEntity2d:

Public Member Functions

AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGeEntity2d (const AcGeEntity2d &)
AcGeEntity2d (AcGeImpEntity3d &, int)
AcGeEntity2d (AcGeImpEntity3d *)
AcGeEntity2d * newEntity2d (AcGeImpEntity3d *) const

Protected Attributes

int | mDelEnt
AcGeImpEntity3d * | mpImpEnt

Friends

class | AcGeEntity3d
class | AcGeImpEntity3d
The documentation for this class was generated from the following file:
  • geent2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeEntity2d Member List

This is the complete list of members for AcGeEntity2d, including all inherited members.

AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity3d (defined in AcGeEntity2d) | AcGeEntity2d | friend
AcGeImpEntity3d (defined in AcGeEntity2d) | AcGeEntity2d | friend
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeEntity3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
AcGeEntity3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeEntity3d:

Public Member Functions

AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const

Protected Attributes

int | mDelEnt
AcGeImpEntity3d * | mpImpEnt

Friends

class AcGeImpEntity3d
The documentation for this class was generated from the following file:
  • geent3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeEntity3d Member List

This is the complete list of members for AcGeEntity3d, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeImpEntity3d (defined in AcGeEntity3d) | AcGeEntity3d | friend
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeExternalBoundedSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeExternalBoundedSurface Class Reference
AcGe Classes
+ Inheritance diagram for AcGeExternalBoundedSurface:

Public Member Functions

AcGeExternalBoundedSurface (void *surfaceDef, AcGe::ExternalEntityKind surfaceKind, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGeExternalBoundedSurface (const AcGeExternalBoundedSurface &)
AcGe::ExternalEntityKind | externalSurfaceKind () const
void | getBaseSurface (AcGeSurface *&surfaceDef) const
void | getBaseSurface (AcGeExternalSurface &unboundedSurfaceDef) const
void | getContours (int &numContours, AcGeCurveBoundary *&curveBoundaries) const
void | getExternalSurface (void *&surfaceDef) const
Adesk::Boolean | isCone () const
Adesk::Boolean | isCylinder () const
Adesk::Boolean | isDefined () const
Adesk::Boolean | isExternalSurface () const
Adesk::Boolean | isNurbs () const
Adesk::Boolean | isOwnerOfSurface () const
Adesk::Boolean | isPlane () const
Adesk::Boolean | isSphere () const
Adesk::Boolean | isTorus () const
int | numContours () const
AcGeExternalBoundedSurface & | operator= (const AcGeExternalBoundedSurface &)
AcGeExternalBoundedSurface & | set (void *surfaceDef, AcGe::ExternalEntityKind surfaceKind, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGeExternalBoundedSurface & | setToOwnSurface ()
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSurface
AcGeSurface (const AcGeSurface &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gexbndsf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeExternalBoundedSurface Member List

This is the complete list of members for AcGeExternalBoundedSurface, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeExternalBoundedSurface() (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
AcGeExternalBoundedSurface(void *surfaceDef, AcGe::ExternalEntityKind surfaceKind, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
AcGeExternalBoundedSurface(const AcGeExternalBoundedSurface &) (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
externalSurfaceKind() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
getBaseSurface(AcGeSurface *&surfaceDef) const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
getBaseSurface(AcGeExternalSurface &unboundedSurfaceDef) const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getContours(int &numContours, AcGeCurveBoundary *&curveBoundaries) const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
getExternalSurface(void *&surfaceDef) const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isCone() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
isCylinder() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
isDefined() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isExternalSurface() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isNurbs() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOwnerOfSurface() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
isPlane() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
isSphere() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
isTorus() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numContours() const (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeExternalBoundedSurface &) (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(void *surfaceDef, AcGe::ExternalEntityKind surfaceKind, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
setToOwnSurface() (defined in AcGeExternalBoundedSurface) | AcGeExternalBoundedSurface |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeExternalCurve2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeExternalCurve2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeExternalCurve2d:

Public Member Functions

AcGeExternalCurve2d (const AcGeExternalCurve2d &)
AcGeExternalCurve2d (void *curveDef, AcGe::ExternalEntityKind curveKind, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGe::ExternalEntityKind | externalCurveKind () const
void | getExternalCurve (void *&curveDef) const
Adesk::Boolean | isDefined () const
Adesk::Boolean | isNurbCurve () const
Adesk::Boolean | isNurbCurve (AcGeNurbCurve2d &nurbCurve) const
Adesk::Boolean | isOwnerOfCurve () const
AcGeExternalCurve2d & | operator= (const AcGeExternalCurve2d &src)
AcGeExternalCurve2d & | set (void *curveDef, AcGe::ExternalEntityKind curveKind, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGeExternalCurve2d & | setToOwnCurve ()
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve2d
AcGeCurve2d (const AcGeCurve2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geextc2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeExternalCurve2d Member List

This is the complete list of members for AcGeExternalCurve2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeExternalCurve2d() (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
AcGeExternalCurve2d(const AcGeExternalCurve2d &) (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
AcGeExternalCurve2d(void *curveDef, AcGe::ExternalEntityKind curveKind, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
externalCurveKind() const (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getExternalCurve(void *&curveDef) const (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDefined() const (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isNurbCurve() const (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
isNurbCurve(AcGeNurbCurve2d &nurbCurve) const (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOwnerOfCurve() const (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeExternalCurve2d &src) (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(void *curveDef, AcGe::ExternalEntityKind curveKind, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
setToOwnCurve() (defined in AcGeExternalCurve2d) | AcGeExternalCurve2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeExternalCurve3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeExternalCurve3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeExternalCurve3d:

Public Member Functions

AcGeExternalCurve3d (const AcGeExternalCurve3d &src)
AcGeExternalCurve3d (void *curveDef, AcGe::ExternalEntityKind curveKind, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGe::ExternalEntityKind | externalCurveKind () const
void | getExternalCurve (void *&curveDef) const
Adesk::Boolean | isCircArc () const
Adesk::Boolean | isDefined () const
Adesk::Boolean | isEllipArc () const
Adesk::Boolean | isLine () const
Adesk::Boolean | isLineSeg () const
Adesk::Boolean | isNativeCurve (AcGeCurve3d *&nativeCurve) const
Adesk::Boolean | isNurbCurve () const
Adesk::Boolean | isOwnerOfCurve () const
Adesk::Boolean | isRay () const
AcGeExternalCurve3d & | operator= (const AcGeExternalCurve3d &src)
AcGeExternalCurve3d & | set (void *curveDef, AcGe::ExternalEntityKind curveKind, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGeExternalCurve3d & | setToOwnCurve ()
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve3d
AcGeCurve3d (const AcGeCurve3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geextc3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeExternalCurve3d Member List

This is the complete list of members for AcGeExternalCurve3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeExternalCurve3d() (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
AcGeExternalCurve3d(const AcGeExternalCurve3d &src) (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
AcGeExternalCurve3d(void *curveDef, AcGe::ExternalEntityKind curveKind, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
externalCurveKind() const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getExternalCurve(void *&curveDef) const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCircArc() const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDefined() const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEllipArc() const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLine() const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isLineSeg() const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
isNativeCurve(AcGeCurve3d *&nativeCurve) const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
isNurbCurve() const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOwnerOfCurve() const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isRay() const (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeExternalCurve3d &src) (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(void *curveDef, AcGe::ExternalEntityKind curveKind, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
setToOwnCurve() (defined in AcGeExternalCurve3d) | AcGeExternalCurve3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeExternalSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeExternalSurface Class Reference
AcGe Classes
+ Inheritance diagram for AcGeExternalSurface:

Public Member Functions

AcGeExternalSurface (void *surfaceDef, AcGe::ExternalEntityKind surfaceKind, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGeExternalSurface (const AcGeExternalSurface &)
AcGe::ExternalEntityKind | externalSurfaceKind () const
void | getExternalSurface (void *&surfaceDef) const
Adesk::Boolean | isCone () const
Adesk::Boolean | isCylinder () const
Adesk::Boolean | isDefined () const
Adesk::Boolean | isNativeSurface (AcGeSurface *&nativeSurface) const
Adesk::Boolean | isNurbSurface () const
Adesk::Boolean | isOwnerOfSurface () const
Adesk::Boolean | isPlane () const
Adesk::Boolean | isSphere () const
Adesk::Boolean | isTorus () const
AcGeExternalSurface & | operator= (const AcGeExternalSurface &src)
AcGeExternalSurface & | set (void *surfaceDef, AcGe::ExternalEntityKind surfaceKind, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGeExternalSurface & | setToOwnSurface ()
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSurface
AcGeSurface (const AcGeSurface &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geextsf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeExternalSurface Member List

This is the complete list of members for AcGeExternalSurface, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeExternalSurface() (defined in AcGeExternalSurface) | AcGeExternalSurface |
AcGeExternalSurface(void *surfaceDef, AcGe::ExternalEntityKind surfaceKind, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeExternalSurface) | AcGeExternalSurface |
AcGeExternalSurface(const AcGeExternalSurface &) (defined in AcGeExternalSurface) | AcGeExternalSurface |
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
externalSurfaceKind() const (defined in AcGeExternalSurface) | AcGeExternalSurface |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
getExternalSurface(void *&surfaceDef) const (defined in AcGeExternalSurface) | AcGeExternalSurface |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isCone() const (defined in AcGeExternalSurface) | AcGeExternalSurface |
isCylinder() const (defined in AcGeExternalSurface) | AcGeExternalSurface |
isDefined() const (defined in AcGeExternalSurface) | AcGeExternalSurface |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNativeSurface(AcGeSurface *&nativeSurface) const (defined in AcGeExternalSurface) | AcGeExternalSurface |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isNurbSurface() const (defined in AcGeExternalSurface) | AcGeExternalSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOwnerOfSurface() const (defined in AcGeExternalSurface) | AcGeExternalSurface |
isPlane() const (defined in AcGeExternalSurface) | AcGeExternalSurface |
isSphere() const (defined in AcGeExternalSurface) | AcGeExternalSurface |
isTorus() const (defined in AcGeExternalSurface) | AcGeExternalSurface |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeExternalSurface &src) (defined in AcGeExternalSurface) | AcGeExternalSurface |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(void *surfaceDef, AcGe::ExternalEntityKind surfaceKind, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeExternalSurface) | AcGeExternalSurface |
setToOwnSurface() (defined in AcGeExternalSurface) | AcGeExternalSurface |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeFileIO Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Static Public Member Functions | Friends | List of all members
AcGeFileIO Class Reference
AcGe Classes

Static Public Member Functions

static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePoint2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeVector2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeMatrix2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeScale2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePoint2dArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeVector2dArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePoint3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeVector3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeMatrix3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeScale3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePoint3dArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeVector3dArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeTol &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeInterval &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeKnotVector &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeDoubleArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *filer, AcGeIntArray &ent, const AcGeLibVersion &version)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCurveBoundary &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePosition2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePointOnCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeLine2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeLineSeg2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeRay2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCircArc2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeEllipArc2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeExternalCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCubicSplineCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCompositeCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeOffsetCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeNurbCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePolyline2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePosition3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePointOnCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePointOnSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeLine3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeRay3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeLineSeg3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePlane &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeBoundedPlane &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCircArc3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeEllipArc3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCubicSplineCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCompositeCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeOffsetCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeNurbCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGePolyline3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeAugPolyline3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeExternalCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCone &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCylinder &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeTorus &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeExternalSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeOffsetSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeNurbSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeExternalBoundedSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeSphere &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeBoundBlock2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeBoundBlock3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCurveCurveInt2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeCurveCurveInt3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeEllipCone &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | inFields (AcGeFiler *, AcGeLibVersion &)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePoint2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeVector2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeMatrix2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeScale2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePoint2dArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeVector2dArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePoint3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeVector3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeMatrix3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeScale3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePoint3dArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeVector3dArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeTol &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeInterval &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeKnotVector &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeDoubleArray &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *filer, const AcGeIntArray &ent, const AcGeLibVersion &version)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCurveBoundary &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePosition2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePointOnCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeLine2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeLineSeg2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeRay2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCircArc2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeEllipArc2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeExternalCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCubicSplineCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCompositeCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeOffsetCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeNurbCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePolyline2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePosition3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePointOnCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePointOnSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeLine3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeRay3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeLineSeg3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePlane &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeBoundedPlane &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCircArc3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeEllipArc3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCubicSplineCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCompositeCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeOffsetCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeNurbCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGePolyline3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeAugPolyline3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeExternalCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCone &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCylinder &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeTorus &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeExternalSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeOffsetSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeNurbSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeExternalBoundedSurface &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeSphere &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeBoundBlock2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeBoundBlock3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCurveCurveInt2d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeCurveCurveInt3d &, const AcGeLibVersion &=AcGe::gLibVersion)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeLibVersion &)
static Acad::ErrorStatus | outFields (AcGeFiler *, const AcGeEllipCone &, const AcGeLibVersion &=AcGe::gLibVersion)

Friends

class AcGeFileIOX
The documentation for this class was generated from the following file:
  • gefileio.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeFileIO Member List

This is the complete list of members for AcGeFileIO, including all inherited members.

AcGeFileIOX (defined in AcGeFileIO) | AcGeFileIO | friend
inFields(AcGeFiler *, AcGePoint2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeVector2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeMatrix2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeScale2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePoint2dArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeVector2dArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePoint3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeVector3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeMatrix3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeScale3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePoint3dArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeVector3dArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeTol &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeInterval &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeKnotVector &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeDoubleArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *filer, AcGeIntArray &ent, const AcGeLibVersion &version) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCurveBoundary &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePosition2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePointOnCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeLine2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeLineSeg2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeRay2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCircArc2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeEllipArc2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeExternalCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCubicSplineCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCompositeCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeOffsetCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeNurbCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePolyline2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePosition3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePointOnCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePointOnSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeLine3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeRay3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeLineSeg3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePlane &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeBoundedPlane &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCircArc3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeEllipArc3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCubicSplineCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCompositeCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeOffsetCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeNurbCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGePolyline3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeAugPolyline3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeExternalCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCone &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCylinder &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeTorus &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeExternalSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeOffsetSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeNurbSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeExternalBoundedSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeSphere &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeBoundBlock2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeBoundBlock3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCurveCurveInt2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeCurveCurveInt3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeEllipCone &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
inFields(AcGeFiler *, AcGeLibVersion &) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePoint2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeVector2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeMatrix2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeScale2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePoint2dArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeVector2dArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePoint3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeVector3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeMatrix3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeScale3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePoint3dArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeVector3dArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeTol &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeInterval &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeKnotVector &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeDoubleArray &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *filer, const AcGeIntArray &ent, const AcGeLibVersion &version) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCurveBoundary &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePosition2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePointOnCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeLine2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeLineSeg2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeRay2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCircArc2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeEllipArc2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeExternalCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCubicSplineCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCompositeCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeOffsetCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeNurbCurve2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePolyline2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePosition3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePointOnCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePointOnSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeLine3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeRay3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeLineSeg3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePlane &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeBoundedPlane &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCircArc3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeEllipArc3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCubicSplineCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCompositeCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeOffsetCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeNurbCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGePolyline3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeAugPolyline3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeExternalCurve3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCone &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCylinder &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeTorus &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeExternalSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeOffsetSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeNurbSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeExternalBoundedSurface &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeSphere &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeBoundBlock2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeBoundBlock3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCurveCurveInt2d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeCurveCurveInt3d &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeLibVersion &) (defined in AcGeFileIO) | AcGeFileIO | static
outFields(AcGeFiler *, const AcGeEllipCone &, const AcGeLibVersion &=AcGe::gLibVersion) (defined in AcGeFileIO) | AcGeFileIO | static


ZRX API Reference: AcGeFiler Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeFiler Class Reference
AcGe Classes

Public Member Functions

virtual AcDbDwgFiler * | dwgFiler ()
virtual Acad::ErrorStatus | readBool (bool *)=0
virtual Acad::ErrorStatus | readBoolean (Adesk::Boolean *)=0
virtual Acad::ErrorStatus | readBytes (void *, unsigned long)=0
virtual Acad::ErrorStatus | readDouble (double *)=0
virtual Acad::ErrorStatus | readLong (long *)=0
virtual Acad::ErrorStatus | readPoint2d (AcGePoint2d *)=0
virtual Acad::ErrorStatus | readPoint3d (AcGePoint3d *)=0
virtual Acad::ErrorStatus | readShort (short *)=0
virtual Acad::ErrorStatus | readSignedByte (char *)=0
virtual Acad::ErrorStatus | readString (AcString &)=0
virtual Acad::ErrorStatus | readUChar (unsigned char *)=0
virtual Acad::ErrorStatus | readULong (unsigned long *)=0
virtual Acad::ErrorStatus | readUShort (unsigned short *)=0
virtual Acad::ErrorStatus | readVector2d (AcGeVector2d *)=0
virtual Acad::ErrorStatus | readVector3d (AcGeVector3d *)=0
virtual Acad::ErrorStatus | writeBool (bool)=0
virtual Acad::ErrorStatus | writeBoolean (Adesk::Boolean)=0
virtual Acad::ErrorStatus | writeBytes (const void *, unsigned long)=0
virtual Acad::ErrorStatus | writeDouble (double)=0
virtual Acad::ErrorStatus | writeLong (long)=0
virtual Acad::ErrorStatus | writePoint2d (const AcGePoint2d &)=0
virtual Acad::ErrorStatus | writePoint3d (const AcGePoint3d &)=0
virtual Acad::ErrorStatus | writeShort (short)=0
virtual Acad::ErrorStatus | writeSignedByte (char)=0
virtual Acad::ErrorStatus | writeString (const AcString &)=0
virtual Acad::ErrorStatus | writeUChar (unsigned char)=0
virtual Acad::ErrorStatus | writeULong (unsigned long)=0
virtual Acad::ErrorStatus | writeUShort (unsigned short)=0
virtual Acad::ErrorStatus | writeVector2d (const AcGeVector2d &)=0
virtual Acad::ErrorStatus | writeVector3d (const AcGeVector3d &)=0
The documentation for this class was generated from the following file:
  • gefiler.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeFiler Member List

This is the complete list of members for AcGeFiler, including all inherited members.

AcGeFiler() (defined in AcGeFiler) | AcGeFiler | protected
dwgFiler() (defined in AcGeFiler) | AcGeFiler | virtual
readBool(bool *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readBoolean(Adesk::Boolean *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readBytes(void *, unsigned long)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readDouble(double *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readLong(long *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readPoint2d(AcGePoint2d *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readPoint3d(AcGePoint3d *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readShort(short *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readSignedByte(char *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readString(AcString &)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readUChar(unsigned char *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readULong(unsigned long *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readUShort(unsigned short *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readVector2d(AcGeVector2d *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
readVector3d(AcGeVector3d *)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeBool(bool)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeBoolean(Adesk::Boolean)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeBytes(const void *, unsigned long)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeDouble(double)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeLong(long)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writePoint2d(const AcGePoint2d &)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writePoint3d(const AcGePoint3d &)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeShort(short)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeSignedByte(char)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeString(const AcString &)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeUChar(unsigned char)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeULong(unsigned long)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeUShort(unsigned short)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeVector2d(const AcGeVector2d &)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual
writeVector3d(const AcGeVector3d &)=0 (defined in AcGeFiler) | AcGeFiler | pure virtual


ZRX API Reference: AcGeInterval Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
AcGeInterval Class Reference
AcGe Classes

Public Member Functions

AcGeInterval (double tol=1.e-12)
AcGeInterval (const AcGeInterval &src)
AcGeInterval (double lower, double upper, double tol=1.e-12)
AcGeInterval (Adesk::Boolean boundedBelow, double bound, double tol=1.e-12)
Adesk::Boolean | contains (const AcGeInterval &otherInterval) const
Adesk::Boolean | contains (double val) const
double | element () const
void | getBounds (double &lower, double &upper) const
void | getMerge (const AcGeInterval &otherInterval, AcGeInterval &result) const
Adesk::Boolean | intersectWith (const AcGeInterval &otherInterval, AcGeInterval &result) const
Adesk::Boolean | isBounded () const
Adesk::Boolean | isBoundedAbove () const
Adesk::Boolean | isBoundedBelow () const
Adesk::Boolean | isContinuousAtUpper (const AcGeInterval &otherInterval) const
Adesk::Boolean | isDisjoint (const AcGeInterval &otherInterval) const
Adesk::Boolean | isEqualAtLower (const AcGeInterval &otherInterval) const
Adesk::Boolean | isEqualAtLower (double value) const
Adesk::Boolean | isEqualAtUpper (const AcGeInterval &otherInterval) const
Adesk::Boolean | isEqualAtUpper (double value) const
Adesk::Boolean | isOverlapAtUpper (const AcGeInterval &otherInterval, AcGeInterval &overlap) const
Adesk::Boolean | isPeriodicallyOn (double period, double &val)
Adesk::Boolean | isSingleton () const
Adesk::Boolean | isUnBounded () const
double | length () const
double | lowerBound () const
Adesk::Boolean | operator!= (const AcGeInterval &otherInterval) const
Adesk::Boolean | operator< (double val) const
Adesk::Boolean | operator< (const AcGeInterval &otherInterval) const
Adesk::Boolean | operator<= (double val) const
Adesk::Boolean | operator<= (const AcGeInterval &otherInterval) const
AcGeInterval & | operator= (const AcGeInterval &otherInterval)
Adesk::Boolean | operator== (const AcGeInterval &otherInterval) const
Adesk::Boolean | operator> (double val) const
Adesk::Boolean | operator> (const AcGeInterval &otherInterval) const
Adesk::Boolean | operator>= (double val) const
Adesk::Boolean | operator>= (const AcGeInterval &otherInterval) const
AcGeInterval & | set (double lower, double upper)
AcGeInterval & | set (Adesk::Boolean boundedBelow, double bound)
AcGeInterval & | set ()
AcGeInterval & | setLower (double lower)
AcGeInterval & | setTolerance (double tol)
AcGeInterval & | setUpper (double upper)
int | subtract (const AcGeInterval &otherInterval, AcGeInterval &lInterval, AcGeInterval &rInterval) const
double | tolerance () const
double | upperBound () const

Protected Member Functions

AcGeInterval (AcGeImpInterval &, int)

Protected Attributes

AcGeImpInterval * mpImpInt

Friends

class | AcGeImpInterval
GE_DLLEXPIMPORT Adesk::Boolean | operator< (double val, const AcGeInterval &intrvl)
GE_DLLEXPIMPORT Adesk::Boolean | operator<= (double val, const AcGeInterval &intrvl)
GE_DLLEXPIMPORT Adesk::Boolean | operator> (double val, const AcGeInterval &intrvl)
GE_DLLEXPIMPORT Adesk::Boolean | operator>= (double val, const AcGeInterval &intrvl)
The documentation for this class was generated from the following file:
  • geintrvl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeInterval Member List

This is the complete list of members for AcGeInterval, including all inherited members.

AcGeImpInterval (defined in AcGeInterval) | AcGeInterval | friend
AcGeInterval(double tol=1.e-12) (defined in AcGeInterval) | AcGeInterval |
AcGeInterval(const AcGeInterval &src) (defined in AcGeInterval) | AcGeInterval |
AcGeInterval(double lower, double upper, double tol=1.e-12) (defined in AcGeInterval) | AcGeInterval |
AcGeInterval(Adesk::Boolean boundedBelow, double bound, double tol=1.e-12) (defined in AcGeInterval) | AcGeInterval |
AcGeInterval(AcGeImpInterval &, int) (defined in AcGeInterval) | AcGeInterval | protected
contains(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
contains(double val) const (defined in AcGeInterval) | AcGeInterval |
element() const (defined in AcGeInterval) | AcGeInterval |
getBounds(double &lower, double &upper) const (defined in AcGeInterval) | AcGeInterval |
getMerge(const AcGeInterval &otherInterval, AcGeInterval &result) const (defined in AcGeInterval) | AcGeInterval |
intersectWith(const AcGeInterval &otherInterval, AcGeInterval &result) const (defined in AcGeInterval) | AcGeInterval |
isBounded() const (defined in AcGeInterval) | AcGeInterval |
isBoundedAbove() const (defined in AcGeInterval) | AcGeInterval |
isBoundedBelow() const (defined in AcGeInterval) | AcGeInterval |
isContinuousAtUpper(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
isDisjoint(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
isEqualAtLower(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
isEqualAtLower(double value) const (defined in AcGeInterval) | AcGeInterval |
isEqualAtUpper(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
isEqualAtUpper(double value) const (defined in AcGeInterval) | AcGeInterval |
isOverlapAtUpper(const AcGeInterval &otherInterval, AcGeInterval &overlap) const (defined in AcGeInterval) | AcGeInterval |
isPeriodicallyOn(double period, double &val) (defined in AcGeInterval) | AcGeInterval |
isSingleton() const (defined in AcGeInterval) | AcGeInterval |
isUnBounded() const (defined in AcGeInterval) | AcGeInterval |
length() const (defined in AcGeInterval) | AcGeInterval |
lowerBound() const (defined in AcGeInterval) | AcGeInterval |
mpImpInt (defined in AcGeInterval) | AcGeInterval | protected
operator!=(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
operator< (defined in AcGeInterval) | AcGeInterval | friend
operator<(double val) const (defined in AcGeInterval) | AcGeInterval |
operator<(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
operator<= (defined in AcGeInterval) | AcGeInterval | friend
operator<=(double val) const (defined in AcGeInterval) | AcGeInterval |
operator<=(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
operator=(const AcGeInterval &otherInterval) (defined in AcGeInterval) | AcGeInterval |
operator==(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
operator> (defined in AcGeInterval) | AcGeInterval | friend
operator>(double val) const (defined in AcGeInterval) | AcGeInterval |
operator>(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
operator>= (defined in AcGeInterval) | AcGeInterval | friend
operator>=(double val) const (defined in AcGeInterval) | AcGeInterval |
operator>=(const AcGeInterval &otherInterval) const (defined in AcGeInterval) | AcGeInterval |
set(double lower, double upper) (defined in AcGeInterval) | AcGeInterval |
set(Adesk::Boolean boundedBelow, double bound) (defined in AcGeInterval) | AcGeInterval |
set() (defined in AcGeInterval) | AcGeInterval |
setLower(double lower) (defined in AcGeInterval) | AcGeInterval |
setTolerance(double tol) (defined in AcGeInterval) | AcGeInterval |
setUpper(double upper) (defined in AcGeInterval) | AcGeInterval |
subtract(const AcGeInterval &otherInterval, AcGeInterval &lInterval, AcGeInterval &rInterval) const (defined in AcGeInterval) | AcGeInterval |
tolerance() const (defined in AcGeInterval) | AcGeInterval |
upperBound() const (defined in AcGeInterval) | AcGeInterval |
~AcGeInterval() (defined in AcGeInterval) | AcGeInterval |


ZRX API Reference: AcGeKnotVector Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AcGeKnotVector Class Reference
AcGe Classes

Public Member Functions

AcGeKnotVector (double eps=1.e-9)
AcGeKnotVector (int size, int growSize, double eps=1.e-9)
AcGeKnotVector (int size, const double[], double eps=1.e-9)
AcGeKnotVector (int plusMult, const AcGeKnotVector &src)
AcGeKnotVector (const AcGeKnotVector &src)
AcGeKnotVector (const AcGeDoubleArray &src, double eps=1.e-9)
int | append (double val)
AcGeKnotVector & | append (AcGeKnotVector &tail, double knotRatio=0.)
const double * | asArrayPtr () const
double * | asArrayPtr ()
Adesk::Boolean | contains (double param) const
double | endParam () const
void | getDistinctKnots (AcGeDoubleArray &knots) const
int | getInterval (int ord, double par, AcGeInterval &interval) const
int | growLength () const
AcGeKnotVector & | insert (double u)
AcGeKnotVector & | insertAt (int indx, double u, int multiplicity=1)
Adesk::Boolean | isEmpty () const
Adesk::Boolean | isEqualTo (const AcGeKnotVector &other) const
Adesk::Boolean | isOn (double knot) const
int | length () const
int | logicalLength () const
int | multiplicityAt (int i) const
int | numIntervals () const
AcGeKnotVector & | operator= (const AcGeKnotVector &src)
AcGeKnotVector & | operator= (const AcGeDoubleArray &src)
double & | operator[] (int)
const double | operator[] (int) const
int | physicalLength () const
AcGeKnotVector & | removeAt (int)
AcGeKnotVector & | removeSubVector (int startIndex, int endIndex)
AcGeKnotVector & | reverse ()
AcGeKnotVector & | set (int size, const double[], double eps=1.e-9)
AcGeKnotVector & | setGrowLength (int)
AcGeKnotVector & | setLogicalLength (int)
AcGeKnotVector & | setPhysicalLength (int)
AcGeKnotVector & | setRange (double lower, double upper)
AcGeKnotVector & | setTolerance (double tol)
int | split (double par, AcGeKnotVector *pKnot1, int multLast, AcGeKnotVector *pKnot2, int multFirst) const
double | startParam () const
double | tolerance () const

Protected Member Functions

Adesk::Boolean isValid (int) const

Protected Attributes

AcGeDoubleArray | mData
double | mTolerance
The documentation for this class was generated from the following file:
  • gekvec.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeKnotVector Member List

This is the complete list of members for AcGeKnotVector, including all inherited members.

AcGeKnotVector(double eps=1.e-9) (defined in AcGeKnotVector) | AcGeKnotVector |
AcGeKnotVector(int size, int growSize, double eps=1.e-9) (defined in AcGeKnotVector) | AcGeKnotVector |
AcGeKnotVector(int size, const double[], double eps=1.e-9) (defined in AcGeKnotVector) | AcGeKnotVector |
AcGeKnotVector(int plusMult, const AcGeKnotVector &src) (defined in AcGeKnotVector) | AcGeKnotVector |
AcGeKnotVector(const AcGeKnotVector &src) (defined in AcGeKnotVector) | AcGeKnotVector |
AcGeKnotVector(const AcGeDoubleArray &src, double eps=1.e-9) (defined in AcGeKnotVector) | AcGeKnotVector |
append(double val) (defined in AcGeKnotVector) | AcGeKnotVector |
append(AcGeKnotVector &tail, double knotRatio=0.) (defined in AcGeKnotVector) | AcGeKnotVector |
asArrayPtr() const (defined in AcGeKnotVector) | AcGeKnotVector |
asArrayPtr() (defined in AcGeKnotVector) | AcGeKnotVector |
contains(double param) const (defined in AcGeKnotVector) | AcGeKnotVector |
endParam() const (defined in AcGeKnotVector) | AcGeKnotVector |
getDistinctKnots(AcGeDoubleArray &knots) const (defined in AcGeKnotVector) | AcGeKnotVector |
getInterval(int ord, double par, AcGeInterval &interval) const (defined in AcGeKnotVector) | AcGeKnotVector |
growLength() const (defined in AcGeKnotVector) | AcGeKnotVector |
insert(double u) (defined in AcGeKnotVector) | AcGeKnotVector |
insertAt(int indx, double u, int multiplicity=1) (defined in AcGeKnotVector) | AcGeKnotVector |
isEmpty() const (defined in AcGeKnotVector) | AcGeKnotVector |
isEqualTo(const AcGeKnotVector &other) const (defined in AcGeKnotVector) | AcGeKnotVector |
isOn(double knot) const (defined in AcGeKnotVector) | AcGeKnotVector |
isValid(int) const (defined in AcGeKnotVector) | AcGeKnotVector | protected
length() const (defined in AcGeKnotVector) | AcGeKnotVector |
logicalLength() const (defined in AcGeKnotVector) | AcGeKnotVector |
mData (defined in AcGeKnotVector) | AcGeKnotVector | protected
mTolerance (defined in AcGeKnotVector) | AcGeKnotVector | protected
multiplicityAt(int i) const (defined in AcGeKnotVector) | AcGeKnotVector |
numIntervals() const (defined in AcGeKnotVector) | AcGeKnotVector |
operator=(const AcGeKnotVector &src) (defined in AcGeKnotVector) | AcGeKnotVector |
operator=(const AcGeDoubleArray &src) (defined in AcGeKnotVector) | AcGeKnotVector |
operator[](int) (defined in AcGeKnotVector) | AcGeKnotVector |
operator[](int) const (defined in AcGeKnotVector) | AcGeKnotVector |
physicalLength() const (defined in AcGeKnotVector) | AcGeKnotVector |
removeAt(int) (defined in AcGeKnotVector) | AcGeKnotVector |
removeSubVector(int startIndex, int endIndex) (defined in AcGeKnotVector) | AcGeKnotVector |
reverse() (defined in AcGeKnotVector) | AcGeKnotVector |
set(int size, const double[], double eps=1.e-9) (defined in AcGeKnotVector) | AcGeKnotVector |
setGrowLength(int) (defined in AcGeKnotVector) | AcGeKnotVector |
setLogicalLength(int) (defined in AcGeKnotVector) | AcGeKnotVector |
setPhysicalLength(int) (defined in AcGeKnotVector) | AcGeKnotVector |
setRange(double lower, double upper) (defined in AcGeKnotVector) | AcGeKnotVector |
setTolerance(double tol) (defined in AcGeKnotVector) | AcGeKnotVector |
split(double par, AcGeKnotVector *pKnot1, int multLast, AcGeKnotVector *pKnot2, int multFirst) const (defined in AcGeKnotVector) | AcGeKnotVector |
startParam() const (defined in AcGeKnotVector) | AcGeKnotVector |
tolerance() const (defined in AcGeKnotVector) | AcGeKnotVector |
~AcGeKnotVector() (defined in AcGeKnotVector) | AcGeKnotVector |


ZRX API Reference: AcGeLibVersion Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Attributes | List of all members
AcGeLibVersion Class Reference
AcGe Classes

Public Member Functions

AcGeLibVersion (const AcGeLibVersion &)
AcGeLibVersion (Adesk::UInt8 major, Adesk::UInt8 minor, Adesk::UInt8 corrective, Adesk::UInt8 internal_version)
Adesk::UInt8 | correctiveVersion () const
Adesk::UInt8 | majorVersion () const
Adesk::UInt8 | minorVersion () const
Adesk::Boolean | operator!= (const AcGeLibVersion &) const
Adesk::Boolean | operator< (const AcGeLibVersion &) const
Adesk::Boolean | operator<= (const AcGeLibVersion &) const
Adesk::Boolean | operator== (const AcGeLibVersion &) const
Adesk::Boolean | operator> (const AcGeLibVersion &) const
Adesk::Boolean | operator>= (const AcGeLibVersion &) const
Adesk::UInt8 | schemaVersion () const
AcGeLibVersion & | setCorrectiveVersion (Adesk::UInt8 val)
AcGeLibVersion & | setMajorVersion (Adesk::UInt8 val)
AcGeLibVersion & | setMinorVersion (Adesk::UInt8 val)
AcGeLibVersion & | setSchemaVersion (Adesk::UInt8 val)

Static Public Attributes

static const AcGeLibVersion | kRelease0
static const AcGeLibVersion | kReleaseSed
static const AcGeLibVersion | kReleaseTah
The documentation for this class was generated from the following file:
  • gelibver.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeLibVersion Member List

This is the complete list of members for AcGeLibVersion, including all inherited members.

AcGeLibVersion() (defined in AcGeLibVersion) | AcGeLibVersion |
AcGeLibVersion(const AcGeLibVersion &) (defined in AcGeLibVersion) | AcGeLibVersion |
AcGeLibVersion(Adesk::UInt8 major, Adesk::UInt8 minor, Adesk::UInt8 corrective, Adesk::UInt8 internal_version) (defined in AcGeLibVersion) | AcGeLibVersion |
correctiveVersion() const (defined in AcGeLibVersion) | AcGeLibVersion |
kRelease0 (defined in AcGeLibVersion) | AcGeLibVersion | static
kReleaseSed (defined in AcGeLibVersion) | AcGeLibVersion | static
kReleaseTah (defined in AcGeLibVersion) | AcGeLibVersion | static
majorVersion() const (defined in AcGeLibVersion) | AcGeLibVersion |
minorVersion() const (defined in AcGeLibVersion) | AcGeLibVersion |
operator!=(const AcGeLibVersion &) const (defined in AcGeLibVersion) | AcGeLibVersion |
operator<(const AcGeLibVersion &) const (defined in AcGeLibVersion) | AcGeLibVersion |
operator<=(const AcGeLibVersion &) const (defined in AcGeLibVersion) | AcGeLibVersion |
operator==(const AcGeLibVersion &) const (defined in AcGeLibVersion) | AcGeLibVersion |
operator>(const AcGeLibVersion &) const (defined in AcGeLibVersion) | AcGeLibVersion |
operator>=(const AcGeLibVersion &) const (defined in AcGeLibVersion) | AcGeLibVersion |
schemaVersion() const (defined in AcGeLibVersion) | AcGeLibVersion |
setCorrectiveVersion(Adesk::UInt8 val) (defined in AcGeLibVersion) | AcGeLibVersion |
setMajorVersion(Adesk::UInt8 val) (defined in AcGeLibVersion) | AcGeLibVersion |
setMinorVersion(Adesk::UInt8 val) (defined in AcGeLibVersion) | AcGeLibVersion |
setSchemaVersion(Adesk::UInt8 val) (defined in AcGeLibVersion) | AcGeLibVersion |


ZRX API Reference: AcGeLine2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Attributes | List of all members
AcGeLine2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeLine2d:

Public Member Functions

AcGeLine2d (const AcGeLine2d &line)
AcGeLine2d (const AcGePoint2d &pnt, const AcGeVector2d &vec)
AcGeLine2d (const AcGePoint2d &pnt1, const AcGePoint2d &pnt2)
AcGeLine2d & | operator= (const AcGeLine2d &line)
AcGeLine2d & | set (const AcGePoint2d &pnt, const AcGeVector2d &vec)
AcGeLine2d & | set (const AcGePoint2d &pnt1, const AcGePoint2d &pnt2)
- Public Member Functions inherited from AcGeLinearEnt2d
AcGeVector2d | direction () const
void | getLine (AcGeLine2d &line) const
void | getPerpLine (const AcGePoint2d &pnt, AcGeLine2d &perpLine) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt2d &line, AcGePoint2d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isColinearTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
AcGeLinearEnt2d & | operator= (const AcGeLinearEnt2d &line)
Adesk::Boolean | overlap (const AcGeLinearEnt2d &line, AcGeLinearEnt2d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | pointOnLine () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Static Public Attributes

static const AcGeLine2d | kXAxis
static const AcGeLine2d | kYAxis

Additional Inherited Members

- Protected Member Functions inherited from AcGeLinearEnt2d
AcGeLinearEnt2d (const AcGeLinearEnt2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geline2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeLine2d Member List

This is the complete list of members for AcGeLine2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeLine2d() (defined in AcGeLine2d) | AcGeLine2d |
AcGeLine2d(const AcGeLine2d &line) (defined in AcGeLine2d) | AcGeLine2d |
AcGeLine2d(const AcGePoint2d &pnt, const AcGeVector2d &vec) (defined in AcGeLine2d) | AcGeLine2d |
AcGeLine2d(const AcGePoint2d &pnt1, const AcGePoint2d &pnt2) (defined in AcGeLine2d) | AcGeLine2d |
AcGeLinearEnt2d() (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d | protected
AcGeLinearEnt2d(const AcGeLinearEnt2d &) (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
direction() const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLine(AcGeLine2d &line) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getPerpLine(const AcGePoint2d &pnt, AcGeLine2d &perpLine) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
intersectWith(const AcGeLinearEnt2d &line, AcGePoint2d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isColinearTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isParallelTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPerpendicularTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
kXAxis (defined in AcGeLine2d) | AcGeLine2d | static
kYAxis (defined in AcGeLine2d) | AcGeLine2d | static
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeLine2d &line) (defined in AcGeLine2d) | AcGeLine2d |
operator=(const AcGeLinearEnt2d &line) (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
overlap(const AcGeLinearEnt2d &line, AcGeLinearEnt2d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
pointOnLine() const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(const AcGePoint2d &pnt, const AcGeVector2d &vec) (defined in AcGeLine2d) | AcGeLine2d |
set(const AcGePoint2d &pnt1, const AcGePoint2d &pnt2) (defined in AcGeLine2d) | AcGeLine2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeLine3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Attributes | List of all members
AcGeLine3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeLine3d:

Public Member Functions

AcGeLine3d (const AcGeLine3d &line)
AcGeLine3d (const AcGePoint3d &pnt, const AcGeVector3d &vec)
AcGeLine3d (const AcGePoint3d &pnt1, const AcGePoint3d &pnt2)
AcGeLine3d & | operator= (const AcGeLine3d &line)
AcGeLine3d & | set (const AcGePoint3d &pnt, const AcGeVector3d &vec)
AcGeLine3d & | set (const AcGePoint3d &pnt1, const AcGePoint3d &pnt2)
- Public Member Functions inherited from AcGeLinearEnt3d
AcGeVector3d | direction () const
void | getLine (AcGeLine3d &) const
void | getPerpPlane (const AcGePoint3d &pnt, AcGePlane &plane) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &line, AcGePoint3d &intPt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGePlanarEnt &plane, AcGePoint3d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isColinearTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const
AcGeLinearEnt3d & | operator= (const AcGeLinearEnt3d &line)
Adesk::Boolean | overlap (const AcGeLinearEnt3d &line, AcGeLinearEnt3d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | pointOnLine () const
Adesk::Boolean | projIntersectWith (const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, AcGePoint3d &pntOnThisLine, AcGePoint3d &pntOnOtherLine, const AcGeTol &tol=AcGeContext::gTol) const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Static Public Attributes

static const AcGeLine3d | kXAxis
static const AcGeLine3d | kYAxis
static const AcGeLine3d | kZAxis

Additional Inherited Members

- Protected Member Functions inherited from AcGeLinearEnt3d
AcGeLinearEnt3d (const AcGeLinearEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geline3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeLine3d Member List

This is the complete list of members for AcGeLine3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeLine3d() (defined in AcGeLine3d) | AcGeLine3d |
AcGeLine3d(const AcGeLine3d &line) (defined in AcGeLine3d) | AcGeLine3d |
AcGeLine3d(const AcGePoint3d &pnt, const AcGeVector3d &vec) (defined in AcGeLine3d) | AcGeLine3d |
AcGeLine3d(const AcGePoint3d &pnt1, const AcGePoint3d &pnt2) (defined in AcGeLine3d) | AcGeLine3d |
AcGeLinearEnt3d() (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d | protected
AcGeLinearEnt3d(const AcGeLinearEnt3d &) (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
direction() const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLine(AcGeLine3d &) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getPerpPlane(const AcGePoint3d &pnt, AcGePlane &plane) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
intersectWith(const AcGeLinearEnt3d &line, AcGePoint3d &intPt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
intersectWith(const AcGePlanarEnt &plane, AcGePoint3d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isColinearTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(const AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isParallelTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isParallelTo(const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPerpendicularTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPerpendicularTo(const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
kXAxis (defined in AcGeLine3d) | AcGeLine3d | static
kYAxis (defined in AcGeLine3d) | AcGeLine3d | static
kZAxis (defined in AcGeLine3d) | AcGeLine3d | static
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeLine3d &line) (defined in AcGeLine3d) | AcGeLine3d |
operator=(const AcGeLinearEnt3d &line) (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
overlap(const AcGeLinearEnt3d &line, AcGeLinearEnt3d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
pointOnLine() const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projIntersectWith(const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, AcGePoint3d &pntOnThisLine, AcGePoint3d &pntOnOtherLine, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGePoint3d &pnt, const AcGeVector3d &vec) (defined in AcGeLine3d) | AcGeLine3d |
set(const AcGePoint3d &pnt1, const AcGePoint3d &pnt2) (defined in AcGeLine3d) | AcGeLine3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeLinearEnt2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGeLinearEnt2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeLinearEnt2d:

Public Member Functions

AcGeVector2d | direction () const
void | getLine (AcGeLine2d &line) const
void | getPerpLine (const AcGePoint2d &pnt, AcGeLine2d &perpLine) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt2d &line, AcGePoint2d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isColinearTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
AcGeLinearEnt2d & | operator= (const AcGeLinearEnt2d &line)
Adesk::Boolean | overlap (const AcGeLinearEnt2d &line, AcGeLinearEnt2d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | pointOnLine () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGeLinearEnt2d (const AcGeLinearEnt2d &)
- Protected Member Functions inherited from AcGeCurve2d
AcGeCurve2d (const AcGeCurve2d &)
- Protected Member Functions inherited from AcGeEntity2d
AcGeEntity2d (const AcGeEntity2d &)
AcGeEntity2d (AcGeImpEntity3d &, int)
AcGeEntity2d (AcGeImpEntity3d *)
AcGeEntity2d * newEntity2d (AcGeImpEntity3d *) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gelent2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeLinearEnt2d Member List

This is the complete list of members for AcGeLinearEnt2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeLinearEnt2d() (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d | protected
AcGeLinearEnt2d(const AcGeLinearEnt2d &) (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
direction() const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLine(AcGeLine2d &line) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getPerpLine(const AcGePoint2d &pnt, AcGeLine2d &perpLine) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
intersectWith(const AcGeLinearEnt2d &line, AcGePoint2d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isColinearTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isParallelTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPerpendicularTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeLinearEnt2d &line) (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
overlap(const AcGeLinearEnt2d &line, AcGeLinearEnt2d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
pointOnLine() const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeLinearEnt3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGeLinearEnt3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeLinearEnt3d:

Public Member Functions

AcGeVector3d | direction () const
void | getLine (AcGeLine3d &) const
void | getPerpPlane (const AcGePoint3d &pnt, AcGePlane &plane) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &line, AcGePoint3d &intPt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGePlanarEnt &plane, AcGePoint3d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isColinearTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const
AcGeLinearEnt3d & | operator= (const AcGeLinearEnt3d &line)
Adesk::Boolean | overlap (const AcGeLinearEnt3d &line, AcGeLinearEnt3d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | pointOnLine () const
Adesk::Boolean | projIntersectWith (const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, AcGePoint3d &pntOnThisLine, AcGePoint3d &pntOnOtherLine, const AcGeTol &tol=AcGeContext::gTol) const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGeLinearEnt3d (const AcGeLinearEnt3d &)
- Protected Member Functions inherited from AcGeCurve3d
AcGeCurve3d (const AcGeCurve3d &)
- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gelent3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeLinearEnt3d Member List

This is the complete list of members for AcGeLinearEnt3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeLinearEnt3d() (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d | protected
AcGeLinearEnt3d(const AcGeLinearEnt3d &) (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
direction() const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLine(AcGeLine3d &) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getPerpPlane(const AcGePoint3d &pnt, AcGePlane &plane) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
intersectWith(const AcGeLinearEnt3d &line, AcGePoint3d &intPt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
intersectWith(const AcGePlanarEnt &plane, AcGePoint3d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isColinearTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(const AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isParallelTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isParallelTo(const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPerpendicularTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPerpendicularTo(const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeLinearEnt3d &line) (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
overlap(const AcGeLinearEnt3d &line, AcGeLinearEnt3d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
pointOnLine() const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projIntersectWith(const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, AcGePoint3d &pntOnThisLine, AcGePoint3d &pntOnOtherLine, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeLineSeg2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeLineSeg2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeLineSeg2d:

Public Member Functions

AcGeLineSeg2d (const AcGeLineSeg2d &line)
AcGeLineSeg2d (const AcGePoint2d &pnt1, const AcGePoint2d &pnt2)
AcGeLineSeg2d (const AcGePoint2d &pnt, const AcGeVector2d &vec)
AcGePoint2d | baryComb (double blendCoeff) const
AcGePoint2d | endPoint () const
void | getBisector (AcGeLine2d &line) const
double | length () const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGePoint2d | midPoint () const
AcGeLineSeg2d & | operator= (const AcGeLineSeg2d &line)
AcGeLineSeg2d & | set (const AcGePoint2d &pnt, const AcGeVector2d &vec)
AcGeLineSeg2d & | set (const AcGePoint2d &pnt1, const AcGePoint2d &pnt2)
AcGeLineSeg2d & | set (const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, double &param1, double &param2, Adesk::Boolean &success)
AcGeLineSeg2d & | set (const AcGeCurve2d &curve, const AcGePoint2d &point, double &param, Adesk::Boolean &success)
AcGePoint2d | startPoint () const
- Public Member Functions inherited from AcGeLinearEnt2d
AcGeVector2d | direction () const
void | getLine (AcGeLine2d &line) const
void | getPerpLine (const AcGePoint2d &pnt, AcGeLine2d &perpLine) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt2d &line, AcGePoint2d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isColinearTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
AcGeLinearEnt2d & | operator= (const AcGeLinearEnt2d &line)
Adesk::Boolean | overlap (const AcGeLinearEnt2d &line, AcGeLinearEnt2d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | pointOnLine () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeLinearEnt2d
AcGeLinearEnt2d (const AcGeLinearEnt2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gelnsg2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeLineSeg2d Member List

This is the complete list of members for AcGeLineSeg2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeLinearEnt2d() (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d | protected
AcGeLinearEnt2d(const AcGeLinearEnt2d &) (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d | protected
AcGeLineSeg2d() (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
AcGeLineSeg2d(const AcGeLineSeg2d &line) (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
AcGeLineSeg2d(const AcGePoint2d &pnt1, const AcGePoint2d &pnt2) (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
AcGeLineSeg2d(const AcGePoint2d &pnt, const AcGeVector2d &vec) (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
baryComb(double blendCoeff) const (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
direction() const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
endPoint() const (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getBisector(AcGeLine2d &line) const (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLine(AcGeLine2d &line) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getPerpLine(const AcGePoint2d &pnt, AcGeLine2d &perpLine) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
intersectWith(const AcGeLinearEnt2d &line, AcGePoint2d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isColinearTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isParallelTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPerpendicularTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
length() const (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
midPoint() const (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeLineSeg2d &line) (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
operator=(const AcGeLinearEnt2d &line) (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
overlap(const AcGeLinearEnt2d &line, AcGeLinearEnt2d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
pointOnLine() const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(const AcGePoint2d &pnt, const AcGeVector2d &vec) (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
set(const AcGePoint2d &pnt1, const AcGePoint2d &pnt2) (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
set(const AcGeCurve2d &curve1, const AcGeCurve2d &curve2, double &param1, double &param2, Adesk::Boolean &success) (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
set(const AcGeCurve2d &curve, const AcGePoint2d &point, double &param, Adesk::Boolean &success) (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
startPoint() const (defined in AcGeLineSeg2d) | AcGeLineSeg2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeLineSeg3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeLineSeg3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeLineSeg3d:

Public Member Functions

AcGeLineSeg3d (const AcGeLineSeg3d &line)
AcGeLineSeg3d (const AcGePoint3d &pnt, const AcGeVector3d &vec)
AcGeLineSeg3d (const AcGePoint3d &pnt1, const AcGePoint3d &pnt2)
AcGePoint3d | baryComb (double blendCoeff) const
AcGePoint3d | endPoint () const
void | getBisector (AcGePlane &plane) const
double | length () const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGePoint3d | midPoint () const
AcGeLineSeg3d & | operator= (const AcGeLineSeg3d &line)
AcGeLineSeg3d & | set (const AcGePoint3d &pnt, const AcGeVector3d &vec)
AcGeLineSeg3d & | set (const AcGePoint3d &pnt1, const AcGePoint3d &pnt2)
AcGeLineSeg3d & | set (const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, double &param1, double &param2, Adesk::Boolean &success)
AcGeLineSeg3d & | set (const AcGeCurve3d &curve, const AcGePoint3d &point, double &param, Adesk::Boolean &success)
AcGePoint3d | startPoint () const
- Public Member Functions inherited from AcGeLinearEnt3d
AcGeVector3d | direction () const
void | getLine (AcGeLine3d &) const
void | getPerpPlane (const AcGePoint3d &pnt, AcGePlane &plane) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &line, AcGePoint3d &intPt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGePlanarEnt &plane, AcGePoint3d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isColinearTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const
AcGeLinearEnt3d & | operator= (const AcGeLinearEnt3d &line)
Adesk::Boolean | overlap (const AcGeLinearEnt3d &line, AcGeLinearEnt3d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | pointOnLine () const
Adesk::Boolean | projIntersectWith (const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, AcGePoint3d &pntOnThisLine, AcGePoint3d &pntOnOtherLine, const AcGeTol &tol=AcGeContext::gTol) const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeLinearEnt3d
AcGeLinearEnt3d (const AcGeLinearEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gelnsg3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeLineSeg3d Member List

This is the complete list of members for AcGeLineSeg3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeLinearEnt3d() (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d | protected
AcGeLinearEnt3d(const AcGeLinearEnt3d &) (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d | protected
AcGeLineSeg3d() (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
AcGeLineSeg3d(const AcGeLineSeg3d &line) (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
AcGeLineSeg3d(const AcGePoint3d &pnt, const AcGeVector3d &vec) (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
AcGeLineSeg3d(const AcGePoint3d &pnt1, const AcGePoint3d &pnt2) (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
baryComb(double blendCoeff) const (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
direction() const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
endPoint() const (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getBisector(AcGePlane &plane) const (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLine(AcGeLine3d &) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getPerpPlane(const AcGePoint3d &pnt, AcGePlane &plane) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
intersectWith(const AcGeLinearEnt3d &line, AcGePoint3d &intPt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
intersectWith(const AcGePlanarEnt &plane, AcGePoint3d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isColinearTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(const AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isParallelTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isParallelTo(const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPerpendicularTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPerpendicularTo(const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
length() const (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
midPoint() const (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeLineSeg3d &line) (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
operator=(const AcGeLinearEnt3d &line) (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
overlap(const AcGeLinearEnt3d &line, AcGeLinearEnt3d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
pointOnLine() const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projIntersectWith(const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, AcGePoint3d &pntOnThisLine, AcGePoint3d &pntOnOtherLine, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGePoint3d &pnt, const AcGeVector3d &vec) (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
set(const AcGePoint3d &pnt1, const AcGePoint3d &pnt2) (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
set(const AcGeCurve3d &curve1, const AcGeCurve3d &curve2, double &param1, double &param2, Adesk::Boolean &success) (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
set(const AcGeCurve3d &curve, const AcGePoint3d &point, double &param, Adesk::Boolean &success) (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
startPoint() const (defined in AcGeLineSeg3d) | AcGeLineSeg3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeMatrix2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
AcGeMatrix2d Class Reference
AcGe Classes

Public Member Functions

AcGeMatrix2d (const AcGeMatrix2d &src)
double | det () const
void | getCoordSystem (AcGePoint2d &origin, AcGeVector2d &e0, AcGeVector2d &e1) const
AcGeMatrix2d | inverse () const
AcGeMatrix2d & | invert ()
Adesk::Boolean | isConformal (double &scale, double &angle, Adesk::Boolean &isMirror, AcGeVector2d &reflex) const
bool | isEqualTo (const AcGeMatrix2d &mat, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isScaledOrtho (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isSingular (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isUniScaledOrtho (const AcGeTol &tol=AcGeContext::gTol) const
bool | operator!= (const AcGeMatrix2d &mat) const
double | operator() (unsigned int, unsigned int) const
double & | operator() (unsigned int, unsigned int)
AcGeMatrix2d | operator* (const AcGeMatrix2d &mat) const
AcGeMatrix2d & | operator*= (const AcGeMatrix2d &mat)
bool | operator== (const AcGeMatrix2d &mat) const
AcGeMatrix2d & | postMultBy (const AcGeMatrix2d &rightSide)
AcGeMatrix2d & | preMultBy (const AcGeMatrix2d &leftSide)
double | scale (void)
AcGeMatrix2d & | setCoordSystem (const AcGePoint2d &origin, const AcGeVector2d &e0, const AcGeVector2d &e1)
AcGeMatrix2d & | setToAlignCoordSys (const AcGePoint2d &fromOrigin, const AcGeVector2d &fromE0, const AcGeVector2d &fromE1, const AcGePoint2d &toOrigin, const AcGeVector2d &toE0, const AcGeVector2d &toE1)
AcGeMatrix2d & | setToIdentity ()
AcGeMatrix2d & | setToMirroring (const AcGePoint2d &pnt)
AcGeMatrix2d & | setToMirroring (const AcGeLine2d &line)
AcGeMatrix2d & | setToProduct (const AcGeMatrix2d &mat1, const AcGeMatrix2d &mat2)
AcGeMatrix2d & | setToRotation (double angle, const AcGePoint2d &center=AcGePoint2d::kOrigin)
AcGeMatrix2d & | setToScaling (double scaleAll, const AcGePoint2d &center=AcGePoint2d::kOrigin)
AcGeMatrix2d & | setToTranslation (const AcGeVector2d &vec)
AcGeMatrix2d & | setTranslation (const AcGeVector2d &vec)
AcGeVector2d | translation () const
AcGeMatrix2d | transpose () const
AcGeMatrix2d & | transposeIt ()

Static Public Member Functions

static AcGeMatrix2d | alignCoordSys (const AcGePoint2d &fromOrigin, const AcGeVector2d &fromE0, const AcGeVector2d &fromE1, const AcGePoint2d &toOrigin, const AcGeVector2d &toE0, const AcGeVector2d &toE1)
static AcGeMatrix2d | mirroring (const AcGePoint2d &pnt)
static AcGeMatrix2d | mirroring (const AcGeLine2d &line)
static AcGeMatrix2d | rotation (double angle, const AcGePoint2d &center=AcGePoint2d::kOrigin)
static AcGeMatrix2d | scaling (double scaleAll, const AcGePoint2d &center=AcGePoint2d::kOrigin)
static AcGeMatrix2d | translation (const AcGeVector2d &vec)

Public Attributes

double entry [3][3]

Static Public Attributes

static const AcGeMatrix2d kIdentity
The documentation for this class was generated from the following file:
  • gemat2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeMatrix2d Member List

This is the complete list of members for AcGeMatrix2d, including all inherited members.

AcGeMatrix2d() (defined in AcGeMatrix2d) | AcGeMatrix2d |
AcGeMatrix2d(const AcGeMatrix2d &src) (defined in AcGeMatrix2d) | AcGeMatrix2d |
alignCoordSys(const AcGePoint2d &fromOrigin, const AcGeVector2d &fromE0, const AcGeVector2d &fromE1, const AcGePoint2d &toOrigin, const AcGeVector2d &toE0, const AcGeVector2d &toE1) (defined in AcGeMatrix2d) | AcGeMatrix2d | static
det() const (defined in AcGeMatrix2d) | AcGeMatrix2d |
entry (defined in AcGeMatrix2d) | AcGeMatrix2d |
getCoordSystem(AcGePoint2d &origin, AcGeVector2d &e0, AcGeVector2d &e1) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
inverse() const (defined in AcGeMatrix2d) | AcGeMatrix2d |
invert() (defined in AcGeMatrix2d) | AcGeMatrix2d |
isConformal(double &scale, double &angle, Adesk::Boolean &isMirror, AcGeVector2d &reflex) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
isEqualTo(const AcGeMatrix2d &mat, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
isScaledOrtho(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
isSingular(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
isUniScaledOrtho(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
kIdentity (defined in AcGeMatrix2d) | AcGeMatrix2d | static
mirroring(const AcGePoint2d &pnt) (defined in AcGeMatrix2d) | AcGeMatrix2d | static
mirroring(const AcGeLine2d &line) (defined in AcGeMatrix2d) | AcGeMatrix2d | static
operator!=(const AcGeMatrix2d &mat) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
operator()(unsigned int, unsigned int) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
operator()(unsigned int, unsigned int) (defined in AcGeMatrix2d) | AcGeMatrix2d |
operator*(const AcGeMatrix2d &mat) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
operator*=(const AcGeMatrix2d &mat) (defined in AcGeMatrix2d) | AcGeMatrix2d |
operator==(const AcGeMatrix2d &mat) const (defined in AcGeMatrix2d) | AcGeMatrix2d |
postMultBy(const AcGeMatrix2d &rightSide) (defined in AcGeMatrix2d) | AcGeMatrix2d |
preMultBy(const AcGeMatrix2d &leftSide) (defined in AcGeMatrix2d) | AcGeMatrix2d |
rotation(double angle, const AcGePoint2d &center=AcGePoint2d::kOrigin) (defined in AcGeMatrix2d) | AcGeMatrix2d | static
scale(void) (defined in AcGeMatrix2d) | AcGeMatrix2d |
scaling(double scaleAll, const AcGePoint2d &center=AcGePoint2d::kOrigin) (defined in AcGeMatrix2d) | AcGeMatrix2d | static
setCoordSystem(const AcGePoint2d &origin, const AcGeVector2d &e0, const AcGeVector2d &e1) (defined in AcGeMatrix2d) | AcGeMatrix2d |
setToAlignCoordSys(const AcGePoint2d &fromOrigin, const AcGeVector2d &fromE0, const AcGeVector2d &fromE1, const AcGePoint2d &toOrigin, const AcGeVector2d &toE0, const AcGeVector2d &toE1) (defined in AcGeMatrix2d) | AcGeMatrix2d |
setToIdentity() (defined in AcGeMatrix2d) | AcGeMatrix2d |
setToMirroring(const AcGePoint2d &pnt) (defined in AcGeMatrix2d) | AcGeMatrix2d |
setToMirroring(const AcGeLine2d &line) (defined in AcGeMatrix2d) | AcGeMatrix2d |
setToProduct(const AcGeMatrix2d &mat1, const AcGeMatrix2d &mat2) (defined in AcGeMatrix2d) | AcGeMatrix2d |
setToRotation(double angle, const AcGePoint2d &center=AcGePoint2d::kOrigin) (defined in AcGeMatrix2d) | AcGeMatrix2d |
setToScaling(double scaleAll, const AcGePoint2d &center=AcGePoint2d::kOrigin) (defined in AcGeMatrix2d) | AcGeMatrix2d |
setToTranslation(const AcGeVector2d &vec) (defined in AcGeMatrix2d) | AcGeMatrix2d |
setTranslation(const AcGeVector2d &vec) (defined in AcGeMatrix2d) | AcGeMatrix2d |
translation() const (defined in AcGeMatrix2d) | AcGeMatrix2d |
translation(const AcGeVector2d &vec) (defined in AcGeMatrix2d) | AcGeMatrix2d | static
transpose() const (defined in AcGeMatrix2d) | AcGeMatrix2d |
transposeIt() (defined in AcGeMatrix2d) | AcGeMatrix2d |


ZRX API Reference: AcGeMatrix3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
AcGeMatrix3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeMatrix3d:

Public Member Functions

AcGeMatrix3d (const AcGeMatrix3d &src)
AcGeMatrix2d | convertToLocal (AcGeVector3d &normal, double &elev) const
double | det () const
void | getCoordSystem (AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis, AcGeVector3d &zAxis) const
AcGeMatrix3d | inverse () const
Adesk::Boolean | inverse (AcGeMatrix3d &inv, double tol) const
AcGeMatrix3d & | invert ()
bool | isEqualTo (const AcGeMatrix3d &mat, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isScaledOrtho (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isSingular (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isUniScaledOrtho (const AcGeTol &tol=AcGeContext::gTol) const
double | norm () const
bool | operator!= (const AcGeMatrix3d &mat) const
double | operator() (unsigned int, unsigned int) const
double & | operator() (unsigned int, unsigned int)
AcGeMatrix3d | operator* (const AcGeMatrix3d &mat) const
AcGeMatrix3d & | operator*= (const AcGeMatrix3d &mat)
bool | operator== (const AcGeMatrix3d &mat) const
AcGeMatrix3d & | postMultBy (const AcGeMatrix3d &rightSide)
AcGeMatrix3d & | preMultBy (const AcGeMatrix3d &leftSide)
double | scale (void) const
AcGeMatrix3d & | setCoordSystem (const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis, const AcGeVector3d &zAxis)
AcGeMatrix3d & | setToAlignCoordSys (const AcGePoint3d &fromOrigin, const AcGeVector3d &fromXAxis, const AcGeVector3d &fromYAxis, const AcGeVector3d &fromZAxis, const AcGePoint3d &toOrigin, const AcGeVector3d &toXAxis, const AcGeVector3d &toYAxis, const AcGeVector3d &toZAxis)
AcGeMatrix3d & | setToIdentity ()
AcGeMatrix3d & | setToMirroring (const AcGePlane &pln)
AcGeMatrix3d & | setToMirroring (const AcGePoint3d &pnt)
AcGeMatrix3d & | setToMirroring (const AcGeLine3d &line)
AcGeMatrix3d & | setToPlaneToWorld (const AcGeVector3d &normal)
AcGeMatrix3d & | setToPlaneToWorld (const AcGePlane &plane)
AcGeMatrix3d & | setToProduct (const AcGeMatrix3d &mat1, const AcGeMatrix3d &mat2)
AcGeMatrix3d & | setToProjection (const AcGePlane &projectionPlane, const AcGeVector3d &projectDir)
AcGeMatrix3d & | setToRotation (double angle, const AcGeVector3d &axis, const AcGePoint3d &center=AcGePoint3d::kOrigin)
AcGeMatrix3d & | setToScaling (double scaleAll, const AcGePoint3d &center=AcGePoint3d::kOrigin)
AcGeMatrix3d & | setToTranslation (const AcGeVector3d &vec)
AcGeMatrix3d & | setToWorldToPlane (const AcGeVector3d &normal)
AcGeMatrix3d & | setToWorldToPlane (const AcGePlane &plane)
AcGeMatrix3d & | setTranslation (const AcGeVector3d &vec)
AcGeVector3d | translation () const
AcGeMatrix3d | transpose () const
AcGeMatrix3d & | transposeIt ()

Static Public Member Functions

static AcGeMatrix3d | alignCoordSys (const AcGePoint3d &fromOrigin, const AcGeVector3d &fromXAxis, const AcGeVector3d &fromYAxis, const AcGeVector3d &fromZAxis, const AcGePoint3d &toOrigin, const AcGeVector3d &toXAxis, const AcGeVector3d &toYAxis, const AcGeVector3d &toZAxis)
static AcGeMatrix3d | mirroring (const AcGePlane &pln)
static AcGeMatrix3d | mirroring (const AcGePoint3d &pnt)
static AcGeMatrix3d | mirroring (const AcGeLine3d &line)
static AcGeMatrix3d | planeToWorld (const AcGeVector3d &normal)
static AcGeMatrix3d | planeToWorld (const AcGePlane &)
static AcGeMatrix3d | projection (const AcGePlane &projectionPlane, const AcGeVector3d &projectDir)
static AcGeMatrix3d | rotation (double angle, const AcGeVector3d &axis, const AcGePoint3d &center=AcGePoint3d::kOrigin)
static AcGeMatrix3d | scaling (double scaleAll, const AcGePoint3d &center=AcGePoint3d::kOrigin)
static AcGeMatrix3d | translation (const AcGeVector3d &vec)
static AcGeMatrix3d | worldToPlane (const AcGeVector3d &normal)
static AcGeMatrix3d | worldToPlane (const AcGePlane &)

Public Attributes

double entry [4][4]

Static Public Attributes

static const AcGeMatrix3d kIdentity
The documentation for this class was generated from the following file:
  • gemat3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeMatrix3d Member List

This is the complete list of members for AcGeMatrix3d, including all inherited members.

AcGeMatrix3d() (defined in AcGeMatrix3d) | AcGeMatrix3d |
AcGeMatrix3d(const AcGeMatrix3d &src) (defined in AcGeMatrix3d) | AcGeMatrix3d |
alignCoordSys(const AcGePoint3d &fromOrigin, const AcGeVector3d &fromXAxis, const AcGeVector3d &fromYAxis, const AcGeVector3d &fromZAxis, const AcGePoint3d &toOrigin, const AcGeVector3d &toXAxis, const AcGeVector3d &toYAxis, const AcGeVector3d &toZAxis) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
convertToLocal(AcGeVector3d &normal, double &elev) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
det() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
entry (defined in AcGeMatrix3d) | AcGeMatrix3d |
getCoordSystem(AcGePoint3d &origin, AcGeVector3d &xAxis, AcGeVector3d &yAxis, AcGeVector3d &zAxis) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
inverse() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
inverse(AcGeMatrix3d &inv, double tol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
invert() (defined in AcGeMatrix3d) | AcGeMatrix3d |
isEqualTo(const AcGeMatrix3d &mat, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
isScaledOrtho(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
isSingular(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
isUniScaledOrtho(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
kIdentity (defined in AcGeMatrix3d) | AcGeMatrix3d | static
mirroring(const AcGePlane &pln) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
mirroring(const AcGePoint3d &pnt) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
mirroring(const AcGeLine3d &line) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
norm() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator!=(const AcGeMatrix3d &mat) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator()(unsigned int, unsigned int) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator()(unsigned int, unsigned int) (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator*(const AcGeMatrix3d &mat) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator*=(const AcGeMatrix3d &mat) (defined in AcGeMatrix3d) | AcGeMatrix3d |
operator==(const AcGeMatrix3d &mat) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
planeToWorld(const AcGeVector3d &normal) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
planeToWorld(const AcGePlane &) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
postMultBy(const AcGeMatrix3d &rightSide) (defined in AcGeMatrix3d) | AcGeMatrix3d |
preMultBy(const AcGeMatrix3d &leftSide) (defined in AcGeMatrix3d) | AcGeMatrix3d |
projection(const AcGePlane &projectionPlane, const AcGeVector3d &projectDir) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
rotation(double angle, const AcGeVector3d &axis, const AcGePoint3d &center=AcGePoint3d::kOrigin) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
scale(void) const (defined in AcGeMatrix3d) | AcGeMatrix3d |
scaling(double scaleAll, const AcGePoint3d &center=AcGePoint3d::kOrigin) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
setCoordSystem(const AcGePoint3d &origin, const AcGeVector3d &xAxis, const AcGeVector3d &yAxis, const AcGeVector3d &zAxis) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToAlignCoordSys(const AcGePoint3d &fromOrigin, const AcGeVector3d &fromXAxis, const AcGeVector3d &fromYAxis, const AcGeVector3d &fromZAxis, const AcGePoint3d &toOrigin, const AcGeVector3d &toXAxis, const AcGeVector3d &toYAxis, const AcGeVector3d &toZAxis) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToIdentity() (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToMirroring(const AcGePlane &pln) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToMirroring(const AcGePoint3d &pnt) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToMirroring(const AcGeLine3d &line) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToPlaneToWorld(const AcGeVector3d &normal) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToPlaneToWorld(const AcGePlane &plane) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToProduct(const AcGeMatrix3d &mat1, const AcGeMatrix3d &mat2) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToProjection(const AcGePlane &projectionPlane, const AcGeVector3d &projectDir) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToRotation(double angle, const AcGeVector3d &axis, const AcGePoint3d &center=AcGePoint3d::kOrigin) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToScaling(double scaleAll, const AcGePoint3d &center=AcGePoint3d::kOrigin) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToTranslation(const AcGeVector3d &vec) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToWorldToPlane(const AcGeVector3d &normal) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setToWorldToPlane(const AcGePlane &plane) (defined in AcGeMatrix3d) | AcGeMatrix3d |
setTranslation(const AcGeVector3d &vec) (defined in AcGeMatrix3d) | AcGeMatrix3d |
translation() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
translation(const AcGeVector3d &vec) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
transpose() const (defined in AcGeMatrix3d) | AcGeMatrix3d |
transposeIt() (defined in AcGeMatrix3d) | AcGeMatrix3d |
worldToPlane(const AcGeVector3d &normal) (defined in AcGeMatrix3d) | AcGeMatrix3d | static
worldToPlane(const AcGePlane &) (defined in AcGeMatrix3d) | AcGeMatrix3d | static


ZRX API Reference: AcGeNurbCurve2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeNurbCurve2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeNurbCurve2d:

Public Member Functions

AcGeNurbCurve2d (const AcGeNurbCurve2d &src)
AcGeNurbCurve2d (int degree, const AcGeKnotVector &knots, const AcGePoint2dArray &cntrlPnts, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve2d (int degree, const AcGeKnotVector &knots, const AcGePoint2dArray &cntrlPnts, const AcGeDoubleArray &weights, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve2d (int degree, const AcGePolyline2d &fitPolyline, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve2d (const AcGePoint2dArray &fitPoints, const AcGeVector2d &startTangent, const AcGeVector2d &endTangent, Adesk::Boolean startTangentDefined=Adesk::kTrue, Adesk::Boolean endTangentDefined=Adesk::kTrue, const AcGeTol &fitTolerance=AcGeContext::gTol)
AcGeNurbCurve2d (const AcGePoint2dArray &fitPoints, const AcGeTol &fitTolerance=AcGeContext::gTol)
AcGeNurbCurve2d (const AcGePoint2dArray &fitPoints, const AcGeVector2dArray &fitTangents, const AcGeTol &fitTolerance=AcGeContext::gTol, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve2d (const AcGeEllipArc2d &ellipse)
AcGeNurbCurve2d (const AcGeLineSeg2d &linSeg)
Adesk::Boolean | addFitPointAt (int index, const AcGePoint2d &point)
AcGeNurbCurve2d & | addKnot (double newKnot)
Adesk::Boolean | deleteFitPointAt (int index)
AcGeNurbCurve2d & | elevateDegree (int plusDegree)
Adesk::Boolean | evalMode () const
void | getDefinitionData (int &degree, Adesk::Boolean &rational, Adesk::Boolean &periodic, AcGeKnotVector &knots, AcGePoint2dArray &controlPoints, AcGeDoubleArray &weights) const
Adesk::Boolean | getFitData (AcGePoint2dArray &fitPoints, AcGeTol &fitTolerance, Adesk::Boolean &tangentsExist, AcGeVector2d &startTangent, AcGeVector2d &endTangent) const
Adesk::Boolean | getFitPointAt (int index, AcGePoint2d &point) const
Adesk::Boolean | getFitTangents (AcGeVector2d &startTangent, AcGeVector2d &endTangent) const
Adesk::Boolean | getFitTolerance (AcGeTol &fitTolerance) const
Adesk::Boolean | getParamsOfC1Discontinuity (AcGeDoubleArray &params, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getParamsOfG1Discontinuity (AcGeDoubleArray &params, const AcGeTol &tol=AcGeContext::gTol) const
AcGeNurbCurve2d & | hardTrimByParams (double newStartParam, double newEndParam)
AcGeNurbCurve2d & | insertKnot (double newKnot)
Adesk::Boolean | intersectWith (const AcGeLine2d &line2d, AcGePoint2dArray &pnts2d, const AcGeTol &tol=AcGeContext::gTol, AcGeDoubleArray *params=NULL) const
AcGeNurbCurve2d & | joinWith (const AcGeNurbCurve2d &curve)
AcGeNurbCurve2d & | makeClosed ()
AcGeNurbCurve2d & | makeNonPeriodic ()
AcGeNurbCurve2d & | makeOpen ()
AcGeNurbCurve2d & | makePeriodic ()
AcGeNurbCurve2d & | makeRational (double weight=1.0)
int | numFitPoints () const
int | numWeights () const
AcGeNurbCurve2d & | operator= (const AcGeNurbCurve2d &spline)
Adesk::Boolean | purgeFitData ()
void | setDefinitionData (int degree, Adesk::Boolean rational, Adesk::Boolean periodic, const AcGeKnotVector &knots, const AcGePoint2dArray &controlPoints, const AcGeDoubleArray &weights)
AcGeNurbCurve2d & | setEvalMode (Adesk::Boolean evalMode=Adesk::kFalse)
AcGeNurbCurve2d & | setFitData (const AcGePoint2dArray &fitPoints, const AcGeVector2d &startTangent, const AcGeVector2d &endTangent, const AcGeTol &fitTol=AcGeContext::gTol)
AcGeNurbCurve2d & | setFitData (const AcGeKnotVector &fitKnots, const AcGePoint2dArray &fitPoints, const AcGeVector2d &startTangent, const AcGeVector2d &endTangent, const AcGeTol &fitTol=AcGeContext::gTol, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve2d & | setFitData (int degree, const AcGePoint2dArray &fitPoints, const AcGeTol &fitTol=AcGeContext::gTol)
Adesk::Boolean | setFitPointAt (int index, const AcGePoint2d &point)
Adesk::Boolean | setFitTangents (const AcGeVector2d &startTangent, const AcGeVector2d &endTangent)
Adesk::Boolean | setFitTolerance (const AcGeTol &fitTol=AcGeContext::gTol)
AcGeSplineEnt2d & | setWeightAt (int idx, double val)
double | weightAt (int idx) const
- Public Member Functions inherited from AcGeSplineEnt2d
int | continuityAtKnot (int idx, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | controlPointAt (int idx) const
int | degree () const
double | endParam () const
AcGePoint2d | endPoint () const
Adesk::Boolean | hasFitData () const
Adesk::Boolean | isRational () const
double | knotAt (int idx) const
const AcGeKnotVector & | knots () const
int | numControlPoints () const
int | numKnots () const
AcGeSplineEnt2d & | operator= (const AcGeSplineEnt2d &spline)
int | order () const
AcGeSplineEnt2d & | setControlPointAt (int idx, const AcGePoint2d &pnt)
AcGeSplineEnt2d & | setKnotAt (int idx, double val)
double | startParam () const
AcGePoint2d | startPoint () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSplineEnt2d
AcGeSplineEnt2d (const AcGeSplineEnt2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • genurb2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeNurbCurve2d Member List

This is the complete list of members for AcGeNurbCurve2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeNurbCurve2d() (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeNurbCurve2d(const AcGeNurbCurve2d &src) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeNurbCurve2d(int degree, const AcGeKnotVector &knots, const AcGePoint2dArray &cntrlPnts, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeNurbCurve2d(int degree, const AcGeKnotVector &knots, const AcGePoint2dArray &cntrlPnts, const AcGeDoubleArray &weights, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeNurbCurve2d(int degree, const AcGePolyline2d &fitPolyline, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeNurbCurve2d(const AcGePoint2dArray &fitPoints, const AcGeVector2d &startTangent, const AcGeVector2d &endTangent, Adesk::Boolean startTangentDefined=Adesk::kTrue, Adesk::Boolean endTangentDefined=Adesk::kTrue, const AcGeTol &fitTolerance=AcGeContext::gTol) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeNurbCurve2d(const AcGePoint2dArray &fitPoints, const AcGeTol &fitTolerance=AcGeContext::gTol) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeNurbCurve2d(const AcGePoint2dArray &fitPoints, const AcGeVector2dArray &fitTangents, const AcGeTol &fitTolerance=AcGeContext::gTol, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeNurbCurve2d(const AcGeEllipArc2d &ellipse) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeNurbCurve2d(const AcGeLineSeg2d &linSeg) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
AcGeSplineEnt2d() (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d | protected
AcGeSplineEnt2d(const AcGeSplineEnt2d &) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d | protected
addFitPointAt(int index, const AcGePoint2d &point) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
addKnot(double newKnot) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
continuityAtKnot(int idx, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
controlPointAt(int idx) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
degree() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
deleteFitPointAt(int index) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
elevateDegree(int plusDegree) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
endParam() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
endPoint() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
evalMode() const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getDefinitionData(int &degree, Adesk::Boolean &rational, Adesk::Boolean &periodic, AcGeKnotVector &knots, AcGePoint2dArray &controlPoints, AcGeDoubleArray &weights) const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
getFitData(AcGePoint2dArray &fitPoints, AcGeTol &fitTolerance, Adesk::Boolean &tangentsExist, AcGeVector2d &startTangent, AcGeVector2d &endTangent) const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
getFitPointAt(int index, AcGePoint2d &point) const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
getFitTangents(AcGeVector2d &startTangent, AcGeVector2d &endTangent) const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
getFitTolerance(AcGeTol &fitTolerance) const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getParamsOfC1Discontinuity(AcGeDoubleArray &params, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
getParamsOfG1Discontinuity(AcGeDoubleArray &params, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hardTrimByParams(double newStartParam, double newEndParam) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasFitData() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
insertKnot(double newKnot) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
intersectWith(const AcGeLine2d &line2d, AcGePoint2dArray &pnts2d, const AcGeTol &tol=AcGeContext::gTol, AcGeDoubleArray *params=NULL) const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
isRational() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
joinWith(const AcGeNurbCurve2d &curve) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
knotAt(int idx) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
knots() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
makeClosed() (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
makeNonPeriodic() (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
makeOpen() (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
makePeriodic() (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
makeRational(double weight=1.0) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
numControlPoints() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
numFitPoints() const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
numKnots() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
numWeights() const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeNurbCurve2d &spline) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
operator=(const AcGeSplineEnt2d &spline) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
order() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
purgeFitData() (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
setControlPointAt(int idx, const AcGePoint2d &pnt) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
setDefinitionData(int degree, Adesk::Boolean rational, Adesk::Boolean periodic, const AcGeKnotVector &knots, const AcGePoint2dArray &controlPoints, const AcGeDoubleArray &weights) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
setEvalMode(Adesk::Boolean evalMode=Adesk::kFalse) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
setFitData(const AcGePoint2dArray &fitPoints, const AcGeVector2d &startTangent, const AcGeVector2d &endTangent, const AcGeTol &fitTol=AcGeContext::gTol) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
setFitData(const AcGeKnotVector &fitKnots, const AcGePoint2dArray &fitPoints, const AcGeVector2d &startTangent, const AcGeVector2d &endTangent, const AcGeTol &fitTol=AcGeContext::gTol, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
setFitData(int degree, const AcGePoint2dArray &fitPoints, const AcGeTol &fitTol=AcGeContext::gTol) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
setFitPointAt(int index, const AcGePoint2d &point) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
setFitTangents(const AcGeVector2d &startTangent, const AcGeVector2d &endTangent) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
setFitTolerance(const AcGeTol &fitTol=AcGeContext::gTol) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
setKnotAt(int idx, double val) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
setWeightAt(int idx, double val) (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
startParam() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
startPoint() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
weightAt(int idx) const (defined in AcGeNurbCurve2d) | AcGeNurbCurve2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeNurbCurve3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeNurbCurve3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeNurbCurve3d:

Public Member Functions

AcGeNurbCurve3d (const AcGeNurbCurve3d &src)
AcGeNurbCurve3d (int degree, const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve3d (int degree, const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts, const AcGeDoubleArray &weights, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve3d (int degree, const AcGePolyline3d &fitPolyline, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve3d (const AcGePoint3dArray &fitPoints, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, Adesk::Boolean startTangentDefined=Adesk::kTrue, Adesk::Boolean endTangentDefined=Adesk::kTrue, const AcGeTol &fitTolerance=AcGeContext::gTol)
AcGeNurbCurve3d (const AcGePoint3dArray &fitPoints, const AcGeTol &fitTolerance=AcGeContext::gTol)
AcGeNurbCurve3d (const AcGePoint3dArray &fitPoints, const AcGeVector3dArray &fitTangents, const AcGeTol &fitTolerance=AcGeContext::gTol, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve3d (const AcGeEllipArc3d &ellipse)
AcGeNurbCurve3d (const AcGeLineSeg3d &linSeg)
Adesk::Boolean | addFitPointAt (int index, const AcGePoint3d &point)
AcGeNurbCurve3d & | addKnot (double newKnot)
Adesk::Boolean | deleteFitPointAt (int index)
AcGeNurbCurve3d & | elevateDegree (int plusDegree)
Adesk::Boolean | evalMode () const
void | getDefinitionData (int &degree, Adesk::Boolean &rational, Adesk::Boolean &periodic, AcGeKnotVector &knots, AcGePoint3dArray &controlPoints, AcGeDoubleArray &weights) const
Adesk::Boolean | getFitData (AcGePoint3dArray &fitPoints, AcGeTol &fitTolerance, Adesk::Boolean &tangentsExist, AcGeVector3d &startTangent, AcGeVector3d &endTangent) const
Adesk::Boolean | getFitPointAt (int index, AcGePoint3d &point) const
Adesk::Boolean | getFitTangents (AcGeVector3d &startTangent, AcGeVector3d &endTangent) const
Adesk::Boolean | getFitTangents (AcGeVector3d &startTangent, AcGeVector3d &endTangent, Adesk::Boolean &startTangentDefined, Adesk::Boolean &endTangentDefined) const
Adesk::Boolean | getFitTolerance (AcGeTol &fitTolerance) const
Adesk::Boolean | getParamsOfC1Discontinuity (AcGeDoubleArray &params, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getParamsOfG1Discontinuity (AcGeDoubleArray &params, const AcGeTol &tol=AcGeContext::gTol) const
AcGeNurbCurve3d & | hardTrimByParams (double newStartParam, double newEndParam)
AcGeNurbCurve3d & | insertKnot (double newKnot)
AcGeNurbCurve3d & | joinWith (const AcGeNurbCurve3d &curve)
AcGeNurbCurve3d & | makeClosed ()
AcGeNurbCurve3d & | makeNonPeriodic ()
AcGeNurbCurve3d & | makeOpen ()
AcGeNurbCurve3d & | makePeriodic ()
AcGeNurbCurve3d & | makeRational (double weight=1.0)
int | numFitPoints () const
int | numWeights () const
AcGeNurbCurve3d & | operator= (const AcGeNurbCurve3d &spline)
Adesk::Boolean | purgeFitData ()
void | setDefinitionData (int degree, Adesk::Boolean rational, Adesk::Boolean periodic, const AcGeKnotVector &knots, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &weights)
AcGeNurbCurve3d & | setEvalMode (Adesk::Boolean evalMode=Adesk::kFalse)
AcGeNurbCurve3d & | setFitData (const AcGePoint3dArray &fitPoints, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, const AcGeTol &fitTol=AcGeContext::gTol)
AcGeNurbCurve3d & | setFitData (const AcGeKnotVector &fitKnots, const AcGePoint3dArray &fitPoints, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, const AcGeTol &fitTol=AcGeContext::gTol, Adesk::Boolean isPeriodic=Adesk::kFalse)
AcGeNurbCurve3d & | setFitData (int degree, const AcGePoint3dArray &fitPoints, const AcGeTol &fitTol=AcGeContext::gTol)
Adesk::Boolean | setFitPointAt (int index, const AcGePoint3d &point)
Adesk::Boolean | setFitTangents (const AcGeVector3d &startTangent, const AcGeVector3d &endTangent)
Adesk::Boolean | setFitTangents (const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, Adesk::Boolean startTangentDefined, Adesk::Boolean endTangentDefined) const
Adesk::Boolean | setFitTolerance (const AcGeTol &fitTol=AcGeContext::gTol)
AcGeSplineEnt3d & | setWeightAt (int idx, double val)
double | weightAt (int idx) const
- Public Member Functions inherited from AcGeSplineEnt3d
int | continuityAtKnot (int idx, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | controlPointAt (int idx) const
int | degree () const
double | endParam () const
AcGePoint3d | endPoint () const
Adesk::Boolean | hasFitData () const
Adesk::Boolean | isRational () const
double | knotAt (int idx) const
const AcGeKnotVector & | knots () const
int | numControlPoints () const
int | numKnots () const
AcGeSplineEnt3d & | operator= (const AcGeSplineEnt3d &spline)
int | order () const
AcGeSplineEnt3d & | setControlPointAt (int idx, const AcGePoint3d &pnt)
AcGeSplineEnt3d & | setKnotAt (int idx, double val)
double | startParam () const
AcGePoint3d | startPoint () const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSplineEnt3d
AcGeSplineEnt3d (const AcGeSplineEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • genurb3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeNurbCurve3d Member List

This is the complete list of members for AcGeNurbCurve3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeNurbCurve3d() (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeNurbCurve3d(const AcGeNurbCurve3d &src) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeNurbCurve3d(int degree, const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeNurbCurve3d(int degree, const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts, const AcGeDoubleArray &weights, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeNurbCurve3d(int degree, const AcGePolyline3d &fitPolyline, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeNurbCurve3d(const AcGePoint3dArray &fitPoints, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, Adesk::Boolean startTangentDefined=Adesk::kTrue, Adesk::Boolean endTangentDefined=Adesk::kTrue, const AcGeTol &fitTolerance=AcGeContext::gTol) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeNurbCurve3d(const AcGePoint3dArray &fitPoints, const AcGeTol &fitTolerance=AcGeContext::gTol) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeNurbCurve3d(const AcGePoint3dArray &fitPoints, const AcGeVector3dArray &fitTangents, const AcGeTol &fitTolerance=AcGeContext::gTol, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeNurbCurve3d(const AcGeEllipArc3d &ellipse) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeNurbCurve3d(const AcGeLineSeg3d &linSeg) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
AcGeSplineEnt3d() (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
AcGeSplineEnt3d(const AcGeSplineEnt3d &) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
addFitPointAt(int index, const AcGePoint3d &point) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
addKnot(double newKnot) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
continuityAtKnot(int idx, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
controlPointAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
degree() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
deleteFitPointAt(int index) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
elevateDegree(int plusDegree) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
endParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
endPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
evalMode() const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getDefinitionData(int &degree, Adesk::Boolean &rational, Adesk::Boolean &periodic, AcGeKnotVector &knots, AcGePoint3dArray &controlPoints, AcGeDoubleArray &weights) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
getFitData(AcGePoint3dArray &fitPoints, AcGeTol &fitTolerance, Adesk::Boolean &tangentsExist, AcGeVector3d &startTangent, AcGeVector3d &endTangent) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
getFitPointAt(int index, AcGePoint3d &point) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
getFitTangents(AcGeVector3d &startTangent, AcGeVector3d &endTangent) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
getFitTangents(AcGeVector3d &startTangent, AcGeVector3d &endTangent, Adesk::Boolean &startTangentDefined, Adesk::Boolean &endTangentDefined) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
getFitTolerance(AcGeTol &fitTolerance) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getParamsOfC1Discontinuity(AcGeDoubleArray &params, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
getParamsOfG1Discontinuity(AcGeDoubleArray &params, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hardTrimByParams(double newStartParam, double newEndParam) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasFitData() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
insertKnot(double newKnot) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isRational() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
joinWith(const AcGeNurbCurve3d &curve) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
knotAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
knots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
makeClosed() (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
makeNonPeriodic() (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
makeOpen() (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
makePeriodic() (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
makeRational(double weight=1.0) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numControlPoints() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
numFitPoints() const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
numKnots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
numWeights() const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeNurbCurve3d &spline) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
operator=(const AcGeSplineEnt3d &spline) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
order() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
purgeFitData() (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setControlPointAt(int idx, const AcGePoint3d &pnt) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
setDefinitionData(int degree, Adesk::Boolean rational, Adesk::Boolean periodic, const AcGeKnotVector &knots, const AcGePoint3dArray &controlPoints, const AcGeDoubleArray &weights) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
setEvalMode(Adesk::Boolean evalMode=Adesk::kFalse) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
setFitData(const AcGePoint3dArray &fitPoints, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, const AcGeTol &fitTol=AcGeContext::gTol) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
setFitData(const AcGeKnotVector &fitKnots, const AcGePoint3dArray &fitPoints, const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, const AcGeTol &fitTol=AcGeContext::gTol, Adesk::Boolean isPeriodic=Adesk::kFalse) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
setFitData(int degree, const AcGePoint3dArray &fitPoints, const AcGeTol &fitTol=AcGeContext::gTol) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
setFitPointAt(int index, const AcGePoint3d &point) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
setFitTangents(const AcGeVector3d &startTangent, const AcGeVector3d &endTangent) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
setFitTangents(const AcGeVector3d &startTangent, const AcGeVector3d &endTangent, Adesk::Boolean startTangentDefined, Adesk::Boolean endTangentDefined) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
setFitTolerance(const AcGeTol &fitTol=AcGeContext::gTol) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
setKnotAt(int idx, double val) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
setWeightAt(int idx, double val) (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
startParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
startPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
weightAt(int idx) const (defined in AcGeNurbCurve3d) | AcGeNurbCurve3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeNurbSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGeNurbSurface Class Reference
AcGe Classes
+ Inheritance diagram for AcGeNurbSurface:

Public Member Functions

AcGeNurbSurface (int degreeU, int degreeV, int propsInU, int propsInV, int numControlPointsInU, int numControlPointsInV, const AcGePoint3d controlPoints[], const double weights[], const AcGeKnotVector &uKnots, const AcGeKnotVector &vKnots, const AcGeTol &tol=AcGeContext::gTol)
AcGeNurbSurface (const AcGeNurbSurface &nurb)
void | computeUIsoLine (double U, AcGeNurbCurve3d &isoline) const
void | computeVIsoLine (double V, AcGeNurbCurve3d &isoline) const
int | degreeInU () const
int | degreeInV () const
void | getControlPoints (AcGePoint3dArray &points) const
void | getDefinition (int &degreeU, int &degreeV, int &propsInU, int &propsInV, int &numControlPointsInU, int &numControlPointsInV, AcGePoint3dArray &controlPoints, AcGeDoubleArray &weights, AcGeKnotVector &uKnots, AcGeKnotVector &vKnots) const
void | getUKnots (AcGeKnotVector &uKnots) const
void | getVKnots (AcGeKnotVector &vKnots) const
Adesk::Boolean | getWeights (AcGeDoubleArray &weights) const
Adesk::Boolean | isPeriodicInU (double &) const
Adesk::Boolean | isPeriodicInV (double &) const
Adesk::Boolean | isRationalInU () const
Adesk::Boolean | isRationalInV () const
int | loc (int i, int j) const
int | numControlPointsInU () const
int | numControlPointsInV () const
int | numKnotsInU () const
int | numKnotsInV () const
AcGeNurbSurface & | operator= (const AcGeNurbSurface &nurb)
AcGeNurbSurface & | set (int degreeU, int degreeV, int propsInU, int propsInV, int numControlPointsInU, int numControlPointsInV, const AcGePoint3d controlPoints[], const double weights[], const AcGeKnotVector &uKnots, const AcGeKnotVector &vKnots, const AcGeTol &tol=AcGeContext::gTol)
void | setControlPoints (AcGePoint3dArray &points)
void | setdegreeInU (int)
void | setdegreeInV (int)
void | setnumControlPointsInU (int)
void | setnumControlPointsInV (int)
void | setsingularityInU (int)
void | setsingularityInV (int)
void | setUknots (AcGeKnotVector &uKnots)
void | setVknots (AcGeKnotVector &vKnots)
void | setWeights (AcGeDoubleArray &weights)
int | singularityInU () const
int | singularityInV () const
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

void | calculateNURBSProperties ()
- Protected Member Functions inherited from AcGeSurface
AcGeSurface (const AcGeSurface &)
- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • genurbsf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeNurbSurface Member List

This is the complete list of members for AcGeNurbSurface, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeNurbSurface() (defined in AcGeNurbSurface) | AcGeNurbSurface |
AcGeNurbSurface(int degreeU, int degreeV, int propsInU, int propsInV, int numControlPointsInU, int numControlPointsInV, const AcGePoint3d controlPoints[], const double weights[], const AcGeKnotVector &uKnots, const AcGeKnotVector &vKnots, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeNurbSurface) | AcGeNurbSurface |
AcGeNurbSurface(const AcGeNurbSurface &nurb) (defined in AcGeNurbSurface) | AcGeNurbSurface |
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
calculateNURBSProperties() (defined in AcGeNurbSurface) | AcGeNurbSurface | protected
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
computeUIsoLine(double U, AcGeNurbCurve3d &isoline) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
computeVIsoLine(double V, AcGeNurbCurve3d &isoline) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
degreeInU() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
degreeInV() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getControlPoints(AcGePoint3dArray &points) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
getDefinition(int &degreeU, int &degreeV, int &propsInU, int &propsInV, int &numControlPointsInU, int &numControlPointsInV, AcGePoint3dArray &controlPoints, AcGeDoubleArray &weights, AcGeKnotVector &uKnots, AcGeKnotVector &vKnots) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
getUKnots(AcGeKnotVector &uKnots) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
getVKnots(AcGeKnotVector &vKnots) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
getWeights(AcGeDoubleArray &weights) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isPeriodicInU(double &) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
isPeriodicInV(double &) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
isRationalInU() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
isRationalInV() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
loc(int i, int j) const (defined in AcGeNurbSurface) | AcGeNurbSurface |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numControlPointsInU() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
numControlPointsInV() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
numKnotsInU() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
numKnotsInV() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeNurbSurface &nurb) (defined in AcGeNurbSurface) | AcGeNurbSurface |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(int degreeU, int degreeV, int propsInU, int propsInV, int numControlPointsInU, int numControlPointsInV, const AcGePoint3d controlPoints[], const double weights[], const AcGeKnotVector &uKnots, const AcGeKnotVector &vKnots, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setControlPoints(AcGePoint3dArray &points) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setdegreeInU(int) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setdegreeInV(int) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setnumControlPointsInU(int) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setnumControlPointsInV(int) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setsingularityInU(int) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setsingularityInV(int) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setUknots(AcGeKnotVector &uKnots) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setVknots(AcGeKnotVector &vKnots) (defined in AcGeNurbSurface) | AcGeNurbSurface |
setWeights(AcGeDoubleArray &weights) (defined in AcGeNurbSurface) | AcGeNurbSurface |
singularityInU() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
singularityInV() const (defined in AcGeNurbSurface) | AcGeNurbSurface |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeOffsetCurve2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeOffsetCurve2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeOffsetCurve2d:

Public Member Functions

AcGeOffsetCurve2d (const AcGeCurve2d &baseCurve, double offsetDistance)
AcGeOffsetCurve2d (const AcGeOffsetCurve2d &offsetCurve)
const AcGeCurve2d * | curve () const
double | offsetDistance () const
AcGeOffsetCurve2d & | operator= (const AcGeOffsetCurve2d &offsetCurve)
Adesk::Boolean | paramDirection () const
AcGeOffsetCurve2d & | setCurve (const AcGeCurve2d &baseCurve)
AcGeOffsetCurve2d & | setOffsetDistance (double distance)
AcGeMatrix2d | transformation () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve2d
AcGeCurve2d (const AcGeCurve2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geoffc2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeOffsetCurve2d Member List

This is the complete list of members for AcGeOffsetCurve2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeOffsetCurve2d(const AcGeCurve2d &baseCurve, double offsetDistance) (defined in AcGeOffsetCurve2d) | AcGeOffsetCurve2d |
AcGeOffsetCurve2d(const AcGeOffsetCurve2d &offsetCurve) (defined in AcGeOffsetCurve2d) | AcGeOffsetCurve2d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
curve() const (defined in AcGeOffsetCurve2d) | AcGeOffsetCurve2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
offsetDistance() const (defined in AcGeOffsetCurve2d) | AcGeOffsetCurve2d |
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeOffsetCurve2d &offsetCurve) (defined in AcGeOffsetCurve2d) | AcGeOffsetCurve2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramDirection() const (defined in AcGeOffsetCurve2d) | AcGeOffsetCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
setCurve(const AcGeCurve2d &baseCurve) (defined in AcGeOffsetCurve2d) | AcGeOffsetCurve2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
setOffsetDistance(double distance) (defined in AcGeOffsetCurve2d) | AcGeOffsetCurve2d |
transformation() const (defined in AcGeOffsetCurve2d) | AcGeOffsetCurve2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeOffsetCurve3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeOffsetCurve3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeOffsetCurve3d:

Public Member Functions

AcGeOffsetCurve3d (const AcGeCurve3d &baseCurve, const AcGeVector3d &planeNormal, double offsetDistance)
AcGeOffsetCurve3d (const AcGeOffsetCurve3d &offsetCurve)
const AcGeCurve3d * | curve () const
AcGeVector3d | normal () const
double | offsetDistance () const
AcGeOffsetCurve3d & | operator= (const AcGeOffsetCurve3d &offsetCurve)
Adesk::Boolean | paramDirection () const
AcGeOffsetCurve3d & | setCurve (const AcGeCurve3d &baseCurve)
AcGeOffsetCurve3d & | setNormal (const AcGeVector3d &planeNormal)
AcGeOffsetCurve3d & | setOffsetDistance (double offsetDistance)
AcGeMatrix3d | transformation () const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeCurve3d
AcGeCurve3d (const AcGeCurve3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geoffc3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeOffsetCurve3d Member List

This is the complete list of members for AcGeOffsetCurve3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeOffsetCurve3d(const AcGeCurve3d &baseCurve, const AcGeVector3d &planeNormal, double offsetDistance) (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
AcGeOffsetCurve3d(const AcGeOffsetCurve3d &offsetCurve) (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
curve() const (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
normal() const (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
offsetDistance() const (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeOffsetCurve3d &offsetCurve) (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramDirection() const (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setCurve(const AcGeCurve3d &baseCurve) (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
setNormal(const AcGeVector3d &planeNormal) (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
setOffsetDistance(double offsetDistance) (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
transformation() const (defined in AcGeOffsetCurve3d) | AcGeOffsetCurve3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeOffsetSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeOffsetSurface Class Reference
AcGe Classes
+ Inheritance diagram for AcGeOffsetSurface:

Public Member Functions

AcGeOffsetSurface (AcGeSurface *baseSurface, double offsetDist, Adesk::Boolean makeCopy=Adesk::kTrue)
AcGeOffsetSurface (const AcGeOffsetSurface &offset)
void | getConstructionSurface (AcGeSurface *&base) const
Adesk::Boolean | getSurface (AcGeSurface *&) const
Adesk::Boolean | isBoundedPlane () const
Adesk::Boolean | isCone () const
Adesk::Boolean | isCylinder () const
Adesk::Boolean | isPlane () const
Adesk::Boolean | isSphere () const
Adesk::Boolean | isTorus () const
double | offsetDist () const
AcGeOffsetSurface & | operator= (const AcGeOffsetSurface &offset)
AcGeOffsetSurface & | set (AcGeSurface *, double offsetDist, Adesk::Boolean makeCopy=Adesk::kTrue)
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSurface
AcGeSurface (const AcGeSurface &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geoffsf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeOffsetSurface Member List

This is the complete list of members for AcGeOffsetSurface, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeOffsetSurface() (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
AcGeOffsetSurface(AcGeSurface *baseSurface, double offsetDist, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
AcGeOffsetSurface(const AcGeOffsetSurface &offset) (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getConstructionSurface(AcGeSurface *&base) const (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
getSurface(AcGeSurface *&) const (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
isBoundedPlane() const (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isCone() const (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
isCylinder() const (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isPlane() const (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
isSphere() const (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
isTorus() const (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
offsetDist() const (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeOffsetSurface &offset) (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(AcGeSurface *, double offsetDist, Adesk::Boolean makeCopy=Adesk::kTrue) (defined in AcGeOffsetSurface) | AcGeOffsetSurface |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGePlanarEnt Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGePlanarEnt Class Reference
AcGe Classes
+ Inheritance diagram for AcGePlanarEnt:

Public Member Functions

AcGePoint3d | closestPointToLinearEnt (const AcGeLinearEnt3d &line, AcGePoint3d &pointOnLine, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointToPlanarEnt (const AcGePlanarEnt &otherPln, AcGePoint3d &pointOnOtherPln, const AcGeTol &tol=AcGeContext::gTol) const
void | get (AcGePoint3d &, AcGeVector3d &uVec, AcGeVector3d &vVec) const
void | get (AcGePoint3d &, AcGePoint3d &origin, AcGePoint3d &) const
void | getCoefficients (double &a, double &b, double &c, double &d) const
void | getCoordSystem (AcGePoint3d &origin, AcGeVector3d &axis1, AcGeVector3d &axis2) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &linEnt, AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarTo (const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGePlanarEnt &linEnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeVector3d | normal () const
AcGePlanarEnt & | operator= (const AcGePlanarEnt &src)
AcGePoint3d | pointOnPlane () const
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGePlanarEnt (const AcGePlanarEnt &)
- Protected Member Functions inherited from AcGeSurface
AcGeSurface (const AcGeSurface &)
- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geplanar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePlanarEnt Member List

This is the complete list of members for AcGePlanarEnt, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGePlanarEnt() (defined in AcGePlanarEnt) | AcGePlanarEnt | protected
AcGePlanarEnt(const AcGePlanarEnt &) (defined in AcGePlanarEnt) | AcGePlanarEnt | protected
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
closestPointToLinearEnt(const AcGeLinearEnt3d &line, AcGePoint3d &pointOnLine, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
closestPointToPlanarEnt(const AcGePlanarEnt &otherPln, AcGePoint3d &pointOnOtherPln, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
get(AcGePoint3d &, AcGeVector3d &uVec, AcGeVector3d &vVec) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
get(AcGePoint3d &, AcGePoint3d &origin, AcGePoint3d &) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getCoefficients(double &a, double &b, double &c, double &d) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
getCoordSystem(AcGePoint3d &origin, AcGeVector3d &axis1, AcGeVector3d &axis2) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
intersectWith(const AcGeLinearEnt3d &linEnt, AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isCoplanarTo(const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isParallelTo(const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isParallelTo(const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isPerpendicularTo(const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isPerpendicularTo(const AcGePlanarEnt &linEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
normal() const (defined in AcGePlanarEnt) | AcGePlanarEnt |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGePlanarEnt &src) (defined in AcGePlanarEnt) | AcGePlanarEnt |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
pointOnPlane() const (defined in AcGePlanarEnt) | AcGePlanarEnt |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGePlane Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Attributes | List of all members
AcGePlane Class Reference
AcGe Classes
+ Inheritance diagram for AcGePlane:

Public Member Functions

AcGePlane (const AcGePlane &src)
AcGePlane (const AcGePoint3d &origin, const AcGeVector3d &normal)
AcGePlane (const AcGePoint3d &pntU, const AcGePoint3d &or, const AcGePoint3d &pntV)
AcGePlane (const AcGePoint3d &or, const AcGeVector3d &uAxis, const AcGeVector3d &vAxis)
AcGePlane (double a, double b, double c, double d)
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &linEnt, AcGePoint3d &resultPnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGePlane &otherPln, AcGeLine3d &resultLine, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGeBoundedPlane &bndPln, AcGeLineSeg3d &resultLineSeg, const AcGeTol &tol=AcGeContext::gTol) const
AcGePlane & | operator= (const AcGePlane &src)
AcGePlane & | set (const AcGePoint3d &pnt, const AcGeVector3d &normal)
AcGePlane & | set (const AcGePoint3d &pntU, const AcGePoint3d &or, const AcGePoint3d &pntV)
AcGePlane & | set (double a, double b, double c, double d)
AcGePlane & | set (const AcGePoint3d &or, const AcGeVector3d &uAxis, const AcGeVector3d &vAxis)
double | signedDistanceTo (const AcGePoint3d &pnt) const
- Public Member Functions inherited from AcGePlanarEnt
AcGePoint3d | closestPointToLinearEnt (const AcGeLinearEnt3d &line, AcGePoint3d &pointOnLine, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointToPlanarEnt (const AcGePlanarEnt &otherPln, AcGePoint3d &pointOnOtherPln, const AcGeTol &tol=AcGeContext::gTol) const
void | get (AcGePoint3d &, AcGeVector3d &uVec, AcGeVector3d &vVec) const
void | get (AcGePoint3d &, AcGePoint3d &origin, AcGePoint3d &) const
void | getCoefficients (double &a, double &b, double &c, double &d) const
void | getCoordSystem (AcGePoint3d &origin, AcGeVector3d &axis1, AcGeVector3d &axis2) const
Adesk::Boolean | isCoplanarTo (const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGePlanarEnt &linEnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeVector3d | normal () const
AcGePlanarEnt & | operator= (const AcGePlanarEnt &src)
AcGePoint3d | pointOnPlane () const
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Static Public Attributes

static const AcGePlane | kXYPlane
static const AcGePlane | kYZPlane
static const AcGePlane | kZXPlane

Additional Inherited Members

- Protected Member Functions inherited from AcGePlanarEnt
AcGePlanarEnt (const AcGePlanarEnt &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geplane.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePlane Member List

This is the complete list of members for AcGePlane, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGePlanarEnt() (defined in AcGePlanarEnt) | AcGePlanarEnt | protected
AcGePlanarEnt(const AcGePlanarEnt &) (defined in AcGePlanarEnt) | AcGePlanarEnt | protected
AcGePlane() (defined in AcGePlane) | AcGePlane |
AcGePlane(const AcGePlane &src) (defined in AcGePlane) | AcGePlane |
AcGePlane(const AcGePoint3d &origin, const AcGeVector3d &normal) (defined in AcGePlane) | AcGePlane |
AcGePlane(const AcGePoint3d &pntU, const AcGePoint3d &or, const AcGePoint3d &pntV) (defined in AcGePlane) | AcGePlane |
AcGePlane(const AcGePoint3d &or, const AcGeVector3d &uAxis, const AcGeVector3d &vAxis) (defined in AcGePlane) | AcGePlane |
AcGePlane(double a, double b, double c, double d) (defined in AcGePlane) | AcGePlane |
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
closestPointToLinearEnt(const AcGeLinearEnt3d &line, AcGePoint3d &pointOnLine, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
closestPointToPlanarEnt(const AcGePlanarEnt &otherPln, AcGePoint3d &pointOnOtherPln, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
get(AcGePoint3d &, AcGeVector3d &uVec, AcGeVector3d &vVec) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
get(AcGePoint3d &, AcGePoint3d &origin, AcGePoint3d &) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getCoefficients(double &a, double &b, double &c, double &d) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
getCoordSystem(AcGePoint3d &origin, AcGeVector3d &axis1, AcGeVector3d &axis2) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
intersectWith(const AcGeLinearEnt3d &linEnt, AcGePoint3d &resultPnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlane) | AcGePlane |
intersectWith(const AcGePlane &otherPln, AcGeLine3d &resultLine, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlane) | AcGePlane |
intersectWith(const AcGeBoundedPlane &bndPln, AcGeLineSeg3d &resultLineSeg, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlane) | AcGePlane |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isCoplanarTo(const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isParallelTo(const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isParallelTo(const AcGePlanarEnt &otherPlnEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isPerpendicularTo(const AcGeLinearEnt3d &linEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
isPerpendicularTo(const AcGePlanarEnt &linEnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePlanarEnt) | AcGePlanarEnt |
kXYPlane (defined in AcGePlane) | AcGePlane | static
kYZPlane (defined in AcGePlane) | AcGePlane | static
kZXPlane (defined in AcGePlane) | AcGePlane | static
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
normal() const (defined in AcGePlanarEnt) | AcGePlanarEnt |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGePlane &src) (defined in AcGePlane) | AcGePlane |
operator=(const AcGePlanarEnt &src) (defined in AcGePlanarEnt) | AcGePlanarEnt |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
pointOnPlane() const (defined in AcGePlanarEnt) | AcGePlanarEnt |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGePoint3d &pnt, const AcGeVector3d &normal) (defined in AcGePlane) | AcGePlane |
set(const AcGePoint3d &pntU, const AcGePoint3d &or, const AcGePoint3d &pntV) (defined in AcGePlane) | AcGePlane |
set(double a, double b, double c, double d) (defined in AcGePlane) | AcGePlane |
set(const AcGePoint3d &or, const AcGeVector3d &uAxis, const AcGeVector3d &vAxis) (defined in AcGePlane) | AcGePlane |
signedDistanceTo(const AcGePoint3d &pnt) const (defined in AcGePlane) | AcGePlane |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGePoint2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Static Public Attributes | Friends | List of all members
AcGePoint2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePoint2d:

Public Member Functions

AcGePoint2d (const AcGePoint2d &pnt)
AcGePoint2d (double x, double y)
AcGeVector2d | asVector () const
double | distanceTo (const AcGePoint2d &pnt) const
bool | isEqualTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d & | mirror (const AcGeLine2d &line)
bool | operator!= (const AcGePoint2d &pnt) const
AcGePoint2d | operator* (double) const
AcGePoint2d & | operator*= (double scl)
AcGePoint2d | operator+ (const AcGeVector2d &vec) const
AcGePoint2d & | operator+= (const AcGeVector2d &vec)
AcGePoint2d | operator- (const AcGeVector2d &vec) const
AcGeVector2d | operator- (const AcGePoint2d &pnt) const
AcGePoint2d & | operator-= (const AcGeVector2d &vec)
AcGePoint2d | operator/ (double scl) const
AcGePoint2d & | operator/= (double scl)
bool | operator== (const AcGePoint2d &pnt) const
double | operator[] (unsigned int i) const
double & | operator[] (unsigned int idx)
AcGePoint2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGePoint2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGePoint2d & | set (double x, double y)
AcGePoint2d & | setToProduct (const AcGeMatrix2d &mat, const AcGePoint2d &pnt)
AcGePoint2d & | setToSum (const AcGePoint2d &pnt, const AcGeVector2d &vec)
AcGePoint2d & | transformBy (const AcGeMatrix2d &leftSide)

Public Attributes

double | x
double | y

Static Public Attributes

static const AcGePoint2d kOrigin

Friends

GE_DLLEXPIMPORT AcGePoint2d | operator* (const AcGeMatrix2d &mat, const AcGePoint2d &pnt)
AcGePoint2d | operator* (double, const AcGePoint2d &scl)
The documentation for this class was generated from the following file:
  • gepnt2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePoint2d Member List

This is the complete list of members for AcGePoint2d, including all inherited members.

AcGePoint2d() (defined in AcGePoint2d) | AcGePoint2d |
AcGePoint2d(const AcGePoint2d &pnt) (defined in AcGePoint2d) | AcGePoint2d |
AcGePoint2d(double x, double y) (defined in AcGePoint2d) | AcGePoint2d |
asVector() const (defined in AcGePoint2d) | AcGePoint2d |
distanceTo(const AcGePoint2d &pnt) const (defined in AcGePoint2d) | AcGePoint2d |
isEqualTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePoint2d) | AcGePoint2d |
kOrigin (defined in AcGePoint2d) | AcGePoint2d | static
mirror(const AcGeLine2d &line) (defined in AcGePoint2d) | AcGePoint2d |
operator!=(const AcGePoint2d &pnt) const (defined in AcGePoint2d) | AcGePoint2d |
operator* (defined in AcGePoint2d) | AcGePoint2d | friend
operator*(double) const (defined in AcGePoint2d) | AcGePoint2d |
operator* (defined in AcGePoint2d) | AcGePoint2d | friend
operator*=(double scl) (defined in AcGePoint2d) | AcGePoint2d |
operator+(const AcGeVector2d &vec) const (defined in AcGePoint2d) | AcGePoint2d |
operator+=(const AcGeVector2d &vec) (defined in AcGePoint2d) | AcGePoint2d |
operator-(const AcGeVector2d &vec) const (defined in AcGePoint2d) | AcGePoint2d |
operator-(const AcGePoint2d &pnt) const (defined in AcGePoint2d) | AcGePoint2d |
operator-=(const AcGeVector2d &vec) (defined in AcGePoint2d) | AcGePoint2d |
operator/(double scl) const (defined in AcGePoint2d) | AcGePoint2d |
operator/=(double scl) (defined in AcGePoint2d) | AcGePoint2d |
operator==(const AcGePoint2d &pnt) const (defined in AcGePoint2d) | AcGePoint2d |
operator[](unsigned int i) const (defined in AcGePoint2d) | AcGePoint2d |
operator[](unsigned int idx) (defined in AcGePoint2d) | AcGePoint2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGePoint2d) | AcGePoint2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGePoint2d) | AcGePoint2d |
set(double x, double y) (defined in AcGePoint2d) | AcGePoint2d |
setToProduct(const AcGeMatrix2d &mat, const AcGePoint2d &pnt) (defined in AcGePoint2d) | AcGePoint2d |
setToSum(const AcGePoint2d &pnt, const AcGeVector2d &vec) (defined in AcGePoint2d) | AcGePoint2d |
transformBy(const AcGeMatrix2d &leftSide) (defined in AcGePoint2d) | AcGePoint2d |
x (defined in AcGePoint2d) | AcGePoint2d |
y (defined in AcGePoint2d) | AcGePoint2d |


ZRX API Reference: AcGePoint3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Static Public Attributes | Friends | List of all members
AcGePoint3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePoint3d:

Public Member Functions

AcGePoint3d (const AcGePoint3d &pnt)
AcGePoint3d (double x, double y, double z)
AcGePoint3d (const AcGePlanarEnt &pln, const AcGePoint2d &pnt2d)
AcGeVector3d | asVector () const
AcGePoint2d | convert2d (const AcGePlanarEnt &pln) const
double | distanceTo (const AcGePoint3d &pnt) const
bool | isEqualTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d & | mirror (const AcGePlane &pln)
bool | operator!= (const AcGePoint3d &pnt) const
AcGePoint3d | operator* (double scl) const
AcGePoint3d & | operator*= (double scl)
AcGePoint3d | operator+ (const AcGeVector3d &vec) const
AcGePoint3d & | operator+= (const AcGeVector3d &vec)
AcGePoint3d | operator- (const AcGeVector3d &vec) const
AcGeVector3d | operator- (const AcGePoint3d &pnt) const
AcGePoint3d & | operator-= (const AcGeVector3d &vec)
AcGePoint3d | operator/ (double scl) const
AcGePoint3d & | operator/= (double scl)
bool | operator== (const AcGePoint3d &pnt) const
double | operator[] (unsigned int i) const
double & | operator[] (unsigned int idx)
AcGePoint3d | orthoProject (const AcGePlane &pln) const
AcGePoint3d | project (const AcGePlane &pln, const AcGeVector3d &vec) const
AcGePoint3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGePoint3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGePoint3d & | set (double x, double y, double z)
AcGePoint3d & | set (const AcGePlanarEnt &pln, const AcGePoint2d &pnt)
AcGePoint3d & | setToProduct (const AcGeMatrix3d &mat, const AcGePoint3d &pnt)
AcGePoint3d & | setToSum (const AcGePoint3d &pnt, const AcGeVector3d &vec)
AcGePoint3d & | transformBy (const AcGeMatrix3d &leftSide)

Public Attributes

double | x
double | y
double | z

Static Public Attributes

static const AcGePoint3d kOrigin

Friends

GE_DLLEXPIMPORT AcGePoint3d | operator* (const AcGeMatrix3d &mat, const AcGePoint3d &pnt)
AcGePoint3d | operator* (double scl, const AcGePoint3d &pnt)
The documentation for this class was generated from the following file:
  • gepnt3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePoint3d Member List

This is the complete list of members for AcGePoint3d, including all inherited members.

AcGePoint3d() (defined in AcGePoint3d) | AcGePoint3d |
AcGePoint3d(const AcGePoint3d &pnt) (defined in AcGePoint3d) | AcGePoint3d |
AcGePoint3d(double x, double y, double z) (defined in AcGePoint3d) | AcGePoint3d |
AcGePoint3d(const AcGePlanarEnt &pln, const AcGePoint2d &pnt2d) (defined in AcGePoint3d) | AcGePoint3d |
asVector() const (defined in AcGePoint3d) | AcGePoint3d |
convert2d(const AcGePlanarEnt &pln) const (defined in AcGePoint3d) | AcGePoint3d |
distanceTo(const AcGePoint3d &pnt) const (defined in AcGePoint3d) | AcGePoint3d |
isEqualTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePoint3d) | AcGePoint3d |
kOrigin (defined in AcGePoint3d) | AcGePoint3d | static
mirror(const AcGePlane &pln) (defined in AcGePoint3d) | AcGePoint3d |
operator!=(const AcGePoint3d &pnt) const (defined in AcGePoint3d) | AcGePoint3d |
operator* (defined in AcGePoint3d) | AcGePoint3d | friend
operator*(double scl) const (defined in AcGePoint3d) | AcGePoint3d |
operator* (defined in AcGePoint3d) | AcGePoint3d | friend
operator*=(double scl) (defined in AcGePoint3d) | AcGePoint3d |
operator+(const AcGeVector3d &vec) const (defined in AcGePoint3d) | AcGePoint3d |
operator+=(const AcGeVector3d &vec) (defined in AcGePoint3d) | AcGePoint3d |
operator-(const AcGeVector3d &vec) const (defined in AcGePoint3d) | AcGePoint3d |
operator-(const AcGePoint3d &pnt) const (defined in AcGePoint3d) | AcGePoint3d |
operator-=(const AcGeVector3d &vec) (defined in AcGePoint3d) | AcGePoint3d |
operator/(double scl) const (defined in AcGePoint3d) | AcGePoint3d |
operator/=(double scl) (defined in AcGePoint3d) | AcGePoint3d |
operator==(const AcGePoint3d &pnt) const (defined in AcGePoint3d) | AcGePoint3d |
operator[](unsigned int i) const (defined in AcGePoint3d) | AcGePoint3d |
operator[](unsigned int idx) (defined in AcGePoint3d) | AcGePoint3d |
orthoProject(const AcGePlane &pln) const (defined in AcGePoint3d) | AcGePoint3d |
project(const AcGePlane &pln, const AcGeVector3d &vec) const (defined in AcGePoint3d) | AcGePoint3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGePoint3d) | AcGePoint3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGePoint3d) | AcGePoint3d |
set(double x, double y, double z) (defined in AcGePoint3d) | AcGePoint3d |
set(const AcGePlanarEnt &pln, const AcGePoint2d &pnt) (defined in AcGePoint3d) | AcGePoint3d |
setToProduct(const AcGeMatrix3d &mat, const AcGePoint3d &pnt) (defined in AcGePoint3d) | AcGePoint3d |
setToSum(const AcGePoint3d &pnt, const AcGeVector3d &vec) (defined in AcGePoint3d) | AcGePoint3d |
transformBy(const AcGeMatrix3d &leftSide) (defined in AcGePoint3d) | AcGePoint3d |
x (defined in AcGePoint3d) | AcGePoint3d |
y (defined in AcGePoint3d) | AcGePoint3d |
z (defined in AcGePoint3d) | AcGePoint3d |


ZRX API Reference: AcGePointEnt2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGePointEnt2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePointEnt2d:

Public Member Functions

operator AcGePoint2d () const
AcGePointEnt2d & | operator= (const AcGePointEnt2d &pnt)
AcGePoint2d | point2d () const
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGePointEnt2d (const AcGePointEnt2d &)
- Protected Member Functions inherited from AcGeEntity2d
AcGeEntity2d (const AcGeEntity2d &)
AcGeEntity2d (AcGeImpEntity3d &, int)
AcGeEntity2d (AcGeImpEntity3d *)
AcGeEntity2d * newEntity2d (AcGeImpEntity3d *) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gepent2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePointEnt2d Member List

This is the complete list of members for AcGePointEnt2d, including all inherited members.

AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGePointEnt2d() (defined in AcGePointEnt2d) | AcGePointEnt2d | protected
AcGePointEnt2d(const AcGePointEnt2d &) (defined in AcGePointEnt2d) | AcGePointEnt2d | protected
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator AcGePoint2d() const (defined in AcGePointEnt2d) | AcGePointEnt2d |
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGePointEnt2d &pnt) (defined in AcGePointEnt2d) | AcGePointEnt2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
point2d() const (defined in AcGePointEnt2d) | AcGePointEnt2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGePointEnt3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGePointEnt3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePointEnt3d:

Public Member Functions

operator AcGePoint3d () const
AcGePointEnt3d & | operator= (const AcGePointEnt3d &pnt)
AcGePoint3d | point3d () const
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGePointEnt3d (const AcGePointEnt3d &)
- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gepent3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePointEnt3d Member List

This is the complete list of members for AcGePointEnt3d, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGePointEnt3d() (defined in AcGePointEnt3d) | AcGePointEnt3d | protected
AcGePointEnt3d(const AcGePointEnt3d &) (defined in AcGePointEnt3d) | AcGePointEnt3d | protected
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator AcGePoint3d() const (defined in AcGePointEnt3d) | AcGePointEnt3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGePointEnt3d &pnt) (defined in AcGePointEnt3d) | AcGePointEnt3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
point3d() const (defined in AcGePointEnt3d) | AcGePointEnt3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGePointOnCurve2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGePointOnCurve2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePointOnCurve2d:

Public Member Functions

AcGePointOnCurve2d (const AcGeCurve2d &crv)
AcGePointOnCurve2d (const AcGeCurve2d &crv, double param)
AcGePointOnCurve2d (const AcGePointOnCurve2d &src)
Adesk::Boolean | curvature (double &res)
Adesk::Boolean | curvature (double param, double &res)
const AcGeCurve2d * | curve () const
AcGeVector2d | deriv (int order) const
AcGeVector2d | deriv (int order, double param)
AcGeVector2d | deriv (int order, const AcGeCurve2d &crv, double param)
Adesk::Boolean | isSingular (const AcGeTol &tol=AcGeContext::gTol) const
AcGePointOnCurve2d & | operator= (const AcGePointOnCurve2d &src)
double | parameter () const
AcGePoint2d | point () const
AcGePoint2d | point (double param)
AcGePoint2d | point (const AcGeCurve2d &crv, double param)
AcGePointOnCurve2d & | setCurve (const AcGeCurve2d &crv)
AcGePointOnCurve2d & | setParameter (double param)
- Public Member Functions inherited from AcGePointEnt2d
operator AcGePoint2d () const
AcGePointEnt2d & | operator= (const AcGePointEnt2d &pnt)
AcGePoint2d | point2d () const
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGePointEnt2d
AcGePointEnt2d (const AcGePointEnt2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geponc2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePointOnCurve2d Member List

This is the complete list of members for AcGePointOnCurve2d, including all inherited members.

AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGePointEnt2d() (defined in AcGePointEnt2d) | AcGePointEnt2d | protected
AcGePointEnt2d(const AcGePointEnt2d &) (defined in AcGePointEnt2d) | AcGePointEnt2d | protected
AcGePointOnCurve2d() (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
AcGePointOnCurve2d(const AcGeCurve2d &crv) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
AcGePointOnCurve2d(const AcGeCurve2d &crv, double param) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
AcGePointOnCurve2d(const AcGePointOnCurve2d &src) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
curvature(double &res) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
curvature(double param, double &res) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
curve() const (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
deriv(int order) const (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
deriv(int order, double param) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
deriv(int order, const AcGeCurve2d &crv, double param) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isSingular(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator AcGePoint2d() const (defined in AcGePointEnt2d) | AcGePointEnt2d |
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGePointOnCurve2d &src) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
operator=(const AcGePointEnt2d &pnt) (defined in AcGePointEnt2d) | AcGePointEnt2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
parameter() const (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
point() const (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
point(double param) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
point(const AcGeCurve2d &crv, double param) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
point2d() const (defined in AcGePointEnt2d) | AcGePointEnt2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
setCurve(const AcGeCurve2d &crv) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
setParameter(double param) (defined in AcGePointOnCurve2d) | AcGePointOnCurve2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGePointOnCurve3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGePointOnCurve3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePointOnCurve3d:

Public Member Functions

AcGePointOnCurve3d (const AcGeCurve3d &crv)
AcGePointOnCurve3d (const AcGeCurve3d &crv, double param)
AcGePointOnCurve3d (const AcGePointOnCurve3d &src)
Adesk::Boolean | curvature (double &res)
Adesk::Boolean | curvature (double param, double &res)
const AcGeCurve3d * | curve () const
AcGeVector3d | deriv (int order) const
AcGeVector3d | deriv (int order, double param)
AcGeVector3d | deriv (int order, const AcGeCurve3d &crv, double param)
Adesk::Boolean | isSingular (const AcGeTol &tol=AcGeContext::gTol) const
AcGePointOnCurve3d & | operator= (const AcGePointOnCurve3d &src)
double | parameter () const
AcGePoint3d | point () const
AcGePoint3d | point (double param)
AcGePoint3d | point (const AcGeCurve3d &crv, double param)
AcGePointOnCurve3d & | setCurve (const AcGeCurve3d &crv)
AcGePointOnCurve3d & | setParameter (double param)
- Public Member Functions inherited from AcGePointEnt3d
operator AcGePoint3d () const
AcGePointEnt3d & | operator= (const AcGePointEnt3d &pnt)
AcGePoint3d | point3d () const
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGePointEnt3d
AcGePointEnt3d (const AcGePointEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geponc3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePointOnCurve3d Member List

This is the complete list of members for AcGePointOnCurve3d, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGePointEnt3d() (defined in AcGePointEnt3d) | AcGePointEnt3d | protected
AcGePointEnt3d(const AcGePointEnt3d &) (defined in AcGePointEnt3d) | AcGePointEnt3d | protected
AcGePointOnCurve3d() (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
AcGePointOnCurve3d(const AcGeCurve3d &crv) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
AcGePointOnCurve3d(const AcGeCurve3d &crv, double param) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
AcGePointOnCurve3d(const AcGePointOnCurve3d &src) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
curvature(double &res) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
curvature(double param, double &res) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
curve() const (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
deriv(int order) const (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
deriv(int order, double param) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
deriv(int order, const AcGeCurve3d &crv, double param) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isSingular(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator AcGePoint3d() const (defined in AcGePointEnt3d) | AcGePointEnt3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGePointOnCurve3d &src) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
operator=(const AcGePointEnt3d &pnt) (defined in AcGePointEnt3d) | AcGePointEnt3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
parameter() const (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
point() const (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
point(double param) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
point(const AcGeCurve3d &crv, double param) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
point3d() const (defined in AcGePointEnt3d) | AcGePointEnt3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setCurve(const AcGeCurve3d &crv) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
setParameter(double param) (defined in AcGePointOnCurve3d) | AcGePointOnCurve3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGePointOnSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGePointOnSurface Class Reference
AcGe Classes
+ Inheritance diagram for AcGePointOnSurface:

Public Member Functions

AcGePointOnSurface (const AcGeSurface &surf)
AcGePointOnSurface (const AcGeSurface &surf, const AcGePoint2d &param)
AcGePointOnSurface (const AcGePointOnSurface &src)
AcGeVector2d | inverseTangentVector (const AcGeVector3d &vec) const
AcGeVector2d | inverseTangentVector (const AcGeVector3d &vec, const AcGePoint2d &param)
AcGeVector2d | inverseTangentVector (const AcGeVector3d &vec, const AcGeSurface &surf, const AcGePoint2d &param)
AcGeVector3d | mixedPartial () const
AcGeVector3d | mixedPartial (const AcGePoint2d &param)
AcGeVector3d | mixedPartial (const AcGeSurface &surf, const AcGePoint2d &param)
AcGeVector3d | normal () const
AcGeVector3d | normal (const AcGePoint2d &param)
AcGeVector3d | normal (const AcGeSurface &surf, const AcGePoint2d &param)
AcGePointOnSurface & | operator= (const AcGePointOnSurface &src)
AcGePoint2d | parameter () const
AcGePoint3d | point () const
AcGePoint3d | point (const AcGePoint2d &param)
AcGePoint3d | point (const AcGeSurface &surf, const AcGePoint2d &param)
AcGePointOnSurface & | setParameter (const AcGePoint2d &param)
AcGePointOnSurface & | setSurface (const AcGeSurface &surf)
const AcGeSurface * | surface () const
AcGeVector3d | tangentVector (const AcGeVector2d &vec) const
AcGeVector3d | tangentVector (const AcGeVector2d &vec, const AcGePoint2d &param)
AcGeVector3d | tangentVector (const AcGeVector2d &vec, const AcGeSurface &vecSurf, const AcGePoint2d &param)
AcGeVector3d | uDeriv (int order) const
AcGeVector3d | uDeriv (int order, const AcGePoint2d &param)
AcGeVector3d | uDeriv (int order, const AcGeSurface &surf, const AcGePoint2d &param)
AcGeVector3d | vDeriv (int order) const
AcGeVector3d | vDeriv (int order, const AcGePoint2d &param)
AcGeVector3d | vDeriv (int order, const AcGeSurface &surf, const AcGePoint2d &param)
- Public Member Functions inherited from AcGePointEnt3d
operator AcGePoint3d () const
AcGePointEnt3d & | operator= (const AcGePointEnt3d &pnt)
AcGePoint3d | point3d () const
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGePointEnt3d
AcGePointEnt3d (const AcGePointEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geponsrf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePointOnSurface Member List

This is the complete list of members for AcGePointOnSurface, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGePointEnt3d() (defined in AcGePointEnt3d) | AcGePointEnt3d | protected
AcGePointEnt3d(const AcGePointEnt3d &) (defined in AcGePointEnt3d) | AcGePointEnt3d | protected
AcGePointOnSurface() (defined in AcGePointOnSurface) | AcGePointOnSurface |
AcGePointOnSurface(const AcGeSurface &surf) (defined in AcGePointOnSurface) | AcGePointOnSurface |
AcGePointOnSurface(const AcGeSurface &surf, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
AcGePointOnSurface(const AcGePointOnSurface &src) (defined in AcGePointOnSurface) | AcGePointOnSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
inverseTangentVector(const AcGeVector3d &vec) const (defined in AcGePointOnSurface) | AcGePointOnSurface |
inverseTangentVector(const AcGeVector3d &vec, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
inverseTangentVector(const AcGeVector3d &vec, const AcGeSurface &surf, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mixedPartial() const (defined in AcGePointOnSurface) | AcGePointOnSurface |
mixedPartial(const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
mixedPartial(const AcGeSurface &surf, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
normal() const (defined in AcGePointOnSurface) | AcGePointOnSurface |
normal(const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
normal(const AcGeSurface &surf, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
operator AcGePoint3d() const (defined in AcGePointEnt3d) | AcGePointEnt3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGePointOnSurface &src) (defined in AcGePointOnSurface) | AcGePointOnSurface |
operator=(const AcGePointEnt3d &pnt) (defined in AcGePointEnt3d) | AcGePointEnt3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
parameter() const (defined in AcGePointOnSurface) | AcGePointOnSurface |
point() const (defined in AcGePointOnSurface) | AcGePointOnSurface |
point(const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
point(const AcGeSurface &surf, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
point3d() const (defined in AcGePointEnt3d) | AcGePointEnt3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setParameter(const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
setSurface(const AcGeSurface &surf) (defined in AcGePointOnSurface) | AcGePointOnSurface |
surface() const (defined in AcGePointOnSurface) | AcGePointOnSurface |
tangentVector(const AcGeVector2d &vec) const (defined in AcGePointOnSurface) | AcGePointOnSurface |
tangentVector(const AcGeVector2d &vec, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
tangentVector(const AcGeVector2d &vec, const AcGeSurface &vecSurf, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
uDeriv(int order) const (defined in AcGePointOnSurface) | AcGePointOnSurface |
uDeriv(int order, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
uDeriv(int order, const AcGeSurface &surf, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
vDeriv(int order) const (defined in AcGePointOnSurface) | AcGePointOnSurface |
vDeriv(int order, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
vDeriv(int order, const AcGeSurface &surf, const AcGePoint2d &param) (defined in AcGePointOnSurface) | AcGePointOnSurface |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGePolyline2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGePolyline2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePolyline2d:

Public Member Functions

AcGePolyline2d (const AcGePolyline2d &src)
AcGePolyline2d (const AcGePoint2dArray &)
AcGePolyline2d (const AcGeKnotVector &knots, const AcGePoint2dArray &points)
AcGePolyline2d (const AcGeCurve2d &crv, double apprEps)
AcGePoint2d | fitPointAt (int idx) const
int | numFitPoints () const
AcGePolyline2d & | operator= (const AcGePolyline2d &pline)
AcGeSplineEnt2d & | setFitPointAt (int idx, const AcGePoint2d &point)
- Public Member Functions inherited from AcGeSplineEnt2d
int | continuityAtKnot (int idx, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | controlPointAt (int idx) const
int | degree () const
double | endParam () const
AcGePoint2d | endPoint () const
Adesk::Boolean | hasFitData () const
Adesk::Boolean | isRational () const
double | knotAt (int idx) const
const AcGeKnotVector & | knots () const
int | numControlPoints () const
int | numKnots () const
AcGeSplineEnt2d & | operator= (const AcGeSplineEnt2d &spline)
int | order () const
AcGeSplineEnt2d & | setControlPointAt (int idx, const AcGePoint2d &pnt)
AcGeSplineEnt2d & | setKnotAt (int idx, double val)
double | startParam () const
AcGePoint2d | startPoint () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSplineEnt2d
AcGeSplineEnt2d (const AcGeSplineEnt2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geplin2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePolyline2d Member List

This is the complete list of members for AcGePolyline2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGePolyline2d() (defined in AcGePolyline2d) | AcGePolyline2d |
AcGePolyline2d(const AcGePolyline2d &src) (defined in AcGePolyline2d) | AcGePolyline2d |
AcGePolyline2d(const AcGePoint2dArray &) (defined in AcGePolyline2d) | AcGePolyline2d |
AcGePolyline2d(const AcGeKnotVector &knots, const AcGePoint2dArray &points) (defined in AcGePolyline2d) | AcGePolyline2d |
AcGePolyline2d(const AcGeCurve2d &crv, double apprEps) (defined in AcGePolyline2d) | AcGePolyline2d |
AcGeSplineEnt2d() (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d | protected
AcGeSplineEnt2d(const AcGeSplineEnt2d &) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
continuityAtKnot(int idx, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
controlPointAt(int idx) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
degree() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
endParam() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
endPoint() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
fitPointAt(int idx) const (defined in AcGePolyline2d) | AcGePolyline2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasFitData() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
isRational() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
knotAt(int idx) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
knots() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
numControlPoints() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
numFitPoints() const (defined in AcGePolyline2d) | AcGePolyline2d |
numKnots() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGePolyline2d &pline) (defined in AcGePolyline2d) | AcGePolyline2d |
operator=(const AcGeSplineEnt2d &spline) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
order() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
setControlPointAt(int idx, const AcGePoint2d &pnt) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
setFitPointAt(int idx, const AcGePoint2d &point) (defined in AcGePolyline2d) | AcGePolyline2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
setKnotAt(int idx, double val) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
startParam() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
startPoint() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGePolyline3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGePolyline3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePolyline3d:

Public Member Functions

AcGePolyline3d (const AcGePolyline3d &src)
AcGePolyline3d (const AcGePoint3dArray &points)
AcGePolyline3d (const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts)
AcGePolyline3d (const AcGeCurve3d &crv, double apprEps)
AcGePoint3d | fitPointAt (int idx) const
int | numFitPoints () const
AcGePolyline3d & | operator= (const AcGePolyline3d &pline)
AcGeSplineEnt3d & | setFitPointAt (int idx, const AcGePoint3d &point)
- Public Member Functions inherited from AcGeSplineEnt3d
int | continuityAtKnot (int idx, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | controlPointAt (int idx) const
int | degree () const
double | endParam () const
AcGePoint3d | endPoint () const
Adesk::Boolean | hasFitData () const
Adesk::Boolean | isRational () const
double | knotAt (int idx) const
const AcGeKnotVector & | knots () const
int | numControlPoints () const
int | numKnots () const
AcGeSplineEnt3d & | operator= (const AcGeSplineEnt3d &spline)
int | order () const
AcGeSplineEnt3d & | setControlPointAt (int idx, const AcGePoint3d &pnt)
AcGeSplineEnt3d & | setKnotAt (int idx, double val)
double | startParam () const
AcGePoint3d | startPoint () const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSplineEnt3d
AcGeSplineEnt3d (const AcGeSplineEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geplin3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePolyline3d Member List

This is the complete list of members for AcGePolyline3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGePolyline3d() (defined in AcGePolyline3d) | AcGePolyline3d |
AcGePolyline3d(const AcGePolyline3d &src) (defined in AcGePolyline3d) | AcGePolyline3d |
AcGePolyline3d(const AcGePoint3dArray &points) (defined in AcGePolyline3d) | AcGePolyline3d |
AcGePolyline3d(const AcGeKnotVector &knots, const AcGePoint3dArray &cntrlPnts) (defined in AcGePolyline3d) | AcGePolyline3d |
AcGePolyline3d(const AcGeCurve3d &crv, double apprEps) (defined in AcGePolyline3d) | AcGePolyline3d |
AcGeSplineEnt3d() (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
AcGeSplineEnt3d(const AcGeSplineEnt3d &) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
continuityAtKnot(int idx, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
controlPointAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
degree() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
endParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
endPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
fitPointAt(int idx) const (defined in AcGePolyline3d) | AcGePolyline3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasFitData() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isRational() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
knotAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
knots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numControlPoints() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
numFitPoints() const (defined in AcGePolyline3d) | AcGePolyline3d |
numKnots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGePolyline3d &pline) (defined in AcGePolyline3d) | AcGePolyline3d |
operator=(const AcGeSplineEnt3d &spline) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
order() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setControlPointAt(int idx, const AcGePoint3d &pnt) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
setFitPointAt(int idx, const AcGePoint3d &point) (defined in AcGePolyline3d) | AcGePolyline3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
setKnotAt(int idx, double val) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
startParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
startPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGePosition2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGePosition2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePosition2d:

Public Member Functions

AcGePosition2d (const AcGePoint2d &pnt)
AcGePosition2d (double x, double y)
AcGePosition2d (const AcGePosition2d &pos)
AcGePosition2d & | operator= (const AcGePosition2d &pos)
AcGePosition2d & | set (const AcGePoint2d &)
AcGePosition2d & | set (double x, double y)
- Public Member Functions inherited from AcGePointEnt2d
operator AcGePoint2d () const
AcGePointEnt2d & | operator= (const AcGePointEnt2d &pnt)
AcGePoint2d | point2d () const
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGePointEnt2d
AcGePointEnt2d (const AcGePointEnt2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gepos2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePosition2d Member List

This is the complete list of members for AcGePosition2d, including all inherited members.

AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGePointEnt2d() (defined in AcGePointEnt2d) | AcGePointEnt2d | protected
AcGePointEnt2d(const AcGePointEnt2d &) (defined in AcGePointEnt2d) | AcGePointEnt2d | protected
AcGePosition2d() (defined in AcGePosition2d) | AcGePosition2d |
AcGePosition2d(const AcGePoint2d &pnt) (defined in AcGePosition2d) | AcGePosition2d |
AcGePosition2d(double x, double y) (defined in AcGePosition2d) | AcGePosition2d |
AcGePosition2d(const AcGePosition2d &pos) (defined in AcGePosition2d) | AcGePosition2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator AcGePoint2d() const (defined in AcGePointEnt2d) | AcGePointEnt2d |
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGePosition2d &pos) (defined in AcGePosition2d) | AcGePosition2d |
operator=(const AcGePointEnt2d &pnt) (defined in AcGePointEnt2d) | AcGePointEnt2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
point2d() const (defined in AcGePointEnt2d) | AcGePointEnt2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(const AcGePoint2d &) (defined in AcGePosition2d) | AcGePosition2d |
set(double x, double y) (defined in AcGePosition2d) | AcGePosition2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGePosition3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGePosition3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGePosition3d:

Public Member Functions

AcGePosition3d (const AcGePoint3d &pnt)
AcGePosition3d (double x, double y, double z)
AcGePosition3d (const AcGePosition3d &pos)
AcGePosition3d & | operator= (const AcGePosition3d &pos)
AcGePosition3d & | set (const AcGePoint3d &)
AcGePosition3d & | set (double x, double y, double z)
- Public Member Functions inherited from AcGePointEnt3d
operator AcGePoint3d () const
AcGePointEnt3d & | operator= (const AcGePointEnt3d &pnt)
AcGePoint3d | point3d () const
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGePointEnt3d
AcGePointEnt3d (const AcGePointEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gepos3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGePosition3d Member List

This is the complete list of members for AcGePosition3d, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGePointEnt3d() (defined in AcGePointEnt3d) | AcGePointEnt3d | protected
AcGePointEnt3d(const AcGePointEnt3d &) (defined in AcGePointEnt3d) | AcGePointEnt3d | protected
AcGePosition3d() (defined in AcGePosition3d) | AcGePosition3d |
AcGePosition3d(const AcGePoint3d &pnt) (defined in AcGePosition3d) | AcGePosition3d |
AcGePosition3d(double x, double y, double z) (defined in AcGePosition3d) | AcGePosition3d |
AcGePosition3d(const AcGePosition3d &pos) (defined in AcGePosition3d) | AcGePosition3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator AcGePoint3d() const (defined in AcGePointEnt3d) | AcGePointEnt3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGePosition3d &pos) (defined in AcGePosition3d) | AcGePosition3d |
operator=(const AcGePointEnt3d &pnt) (defined in AcGePointEnt3d) | AcGePointEnt3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
point3d() const (defined in AcGePointEnt3d) | AcGePointEnt3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGePoint3d &) (defined in AcGePosition3d) | AcGePosition3d |
set(double x, double y, double z) (defined in AcGePosition3d) | AcGePosition3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeRay2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeRay2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeRay2d:

Public Member Functions

AcGeRay2d (const AcGeRay2d &line)
AcGeRay2d (const AcGePoint2d &pnt, const AcGeVector2d &vec)
AcGeRay2d (const AcGePoint2d &pnt1, const AcGePoint2d &pnt2)
AcGeRay2d & | operator= (const AcGeRay2d &line)
AcGeRay2d & | set (const AcGePoint2d &pnt, const AcGeVector2d &vec)
AcGeRay2d & | set (const AcGePoint2d &pnt1, const AcGePoint2d &pnt2)
- Public Member Functions inherited from AcGeLinearEnt2d
AcGeVector2d | direction () const
void | getLine (AcGeLine2d &line) const
void | getPerpLine (const AcGePoint2d &pnt, AcGeLine2d &perpLine) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt2d &line, AcGePoint2d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isColinearTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const
AcGeLinearEnt2d & | operator= (const AcGeLinearEnt2d &line)
Adesk::Boolean | overlap (const AcGeLinearEnt2d &line, AcGeLinearEnt2d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | pointOnLine () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeLinearEnt2d
AcGeLinearEnt2d (const AcGeLinearEnt2d &)
- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geray2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeRay2d Member List

This is the complete list of members for AcGeRay2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeLinearEnt2d() (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d | protected
AcGeLinearEnt2d(const AcGeLinearEnt2d &) (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d | protected
AcGeRay2d() (defined in AcGeRay2d) | AcGeRay2d |
AcGeRay2d(const AcGeRay2d &line) (defined in AcGeRay2d) | AcGeRay2d |
AcGeRay2d(const AcGePoint2d &pnt, const AcGeVector2d &vec) (defined in AcGeRay2d) | AcGeRay2d |
AcGeRay2d(const AcGePoint2d &pnt1, const AcGePoint2d &pnt2) (defined in AcGeRay2d) | AcGeRay2d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
direction() const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLine(AcGeLine2d &line) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getPerpLine(const AcGePoint2d &pnt, AcGeLine2d &perpLine) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
intersectWith(const AcGeLinearEnt2d &line, AcGePoint2d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isColinearTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isParallelTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPerpendicularTo(const AcGeLinearEnt2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeRay2d &line) (defined in AcGeRay2d) | AcGeRay2d |
operator=(const AcGeLinearEnt2d &line) (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
overlap(const AcGeLinearEnt2d &line, AcGeLinearEnt2d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
pointOnLine() const (defined in AcGeLinearEnt2d) | AcGeLinearEnt2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
set(const AcGePoint2d &pnt, const AcGeVector2d &vec) (defined in AcGeRay2d) | AcGeRay2d |
set(const AcGePoint2d &pnt1, const AcGePoint2d &pnt2) (defined in AcGeRay2d) | AcGeRay2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeRay3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeRay3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeRay3d:

Public Member Functions

AcGeRay3d (const AcGeRay3d &line)
AcGeRay3d (const AcGePoint3d &pnt, const AcGeVector3d &vec)
AcGeRay3d (const AcGePoint3d &pnt1, const AcGePoint3d &pnt2)
AcGeRay3d & | operator= (const AcGeRay3d &line)
AcGeRay3d & | set (const AcGePoint3d &pnt, const AcGeVector3d &vec)
AcGeRay3d & | set (const AcGePoint3d &pnt1, const AcGePoint3d &pnt2)
- Public Member Functions inherited from AcGeLinearEnt3d
AcGeVector3d | direction () const
void | getLine (AcGeLine3d &) const
void | getPerpPlane (const AcGePoint3d &pnt, AcGePlane &plane) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &line, AcGePoint3d &intPt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | intersectWith (const AcGePlanarEnt &plane, AcGePoint3d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isColinearTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const
AcGeLinearEnt3d & | operator= (const AcGeLinearEnt3d &line)
Adesk::Boolean | overlap (const AcGeLinearEnt3d &line, AcGeLinearEnt3d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | pointOnLine () const
Adesk::Boolean | projIntersectWith (const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, AcGePoint3d &pntOnThisLine, AcGePoint3d &pntOnOtherLine, const AcGeTol &tol=AcGeContext::gTol) const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeLinearEnt3d
AcGeLinearEnt3d (const AcGeLinearEnt3d &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • geray3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeRay3d Member List

This is the complete list of members for AcGeRay3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeLinearEnt3d() (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d | protected
AcGeLinearEnt3d(const AcGeLinearEnt3d &) (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d | protected
AcGeRay3d() (defined in AcGeRay3d) | AcGeRay3d |
AcGeRay3d(const AcGeRay3d &line) (defined in AcGeRay3d) | AcGeRay3d |
AcGeRay3d(const AcGePoint3d &pnt, const AcGeVector3d &vec) (defined in AcGeRay3d) | AcGeRay3d |
AcGeRay3d(const AcGePoint3d &pnt1, const AcGePoint3d &pnt2) (defined in AcGeRay3d) | AcGeRay3d |
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
direction() const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLine(AcGeLine3d &) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getPerpPlane(const AcGePoint3d &pnt, AcGePlane &plane) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
intersectWith(const AcGeLinearEnt3d &line, AcGePoint3d &intPt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
intersectWith(const AcGePlanarEnt &plane, AcGePoint3d &intPnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isColinearTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isOn(const AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isParallelTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isParallelTo(const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPerpendicularTo(const AcGeLinearEnt3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPerpendicularTo(const AcGePlanarEnt &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeRay3d &line) (defined in AcGeRay3d) | AcGeRay3d |
operator=(const AcGeLinearEnt3d &line) (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
overlap(const AcGeLinearEnt3d &line, AcGeLinearEnt3d *&overlap, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
pointOnLine() const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projIntersectWith(const AcGeLinearEnt3d &line, const AcGeVector3d &projDir, AcGePoint3d &pntOnThisLine, AcGePoint3d &pntOnOtherLine, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeLinearEnt3d) | AcGeLinearEnt3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGePoint3d &pnt, const AcGeVector3d &vec) (defined in AcGeRay3d) | AcGeRay3d |
set(const AcGePoint3d &pnt1, const AcGePoint3d &pnt2) (defined in AcGeRay3d) | AcGeRay3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeScale2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Static Public Attributes | Friends | List of all members
AcGeScale2d Class Reference
AcGe Classes

Public Member Functions

AcGeScale2d (const AcGeScale2d &src)
AcGeScale2d (double factor)
AcGeScale2d (double xFactor, double yFactor)
AcGeScale2d & | extractScale (const AcGeMatrix2d &mat)
void | getMatrix (AcGeMatrix2d &mat) const
AcGeScale2d | inverse () const
AcGeScale2d & | invert ()
bool | isEqualTo (const AcGeScale2d &scaleVec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isProportional (const AcGeTol &tol=AcGeContext::gTol) const
operator AcGeMatrix2d () const
operator AcGeScale3d () const
bool | operator!= (const AcGeScale2d &sclVec) const
AcGeScale2d | operator* (const AcGeScale2d &sclVec) const
AcGeScale2d | operator* (double s) const
AcGeScale2d & | operator*= (const AcGeScale2d &scl)
AcGeScale2d & | operator*= (double s)
bool | operator== (const AcGeScale2d &sclVec) const
double | operator[] (unsigned int i) const
double & | operator[] (unsigned int i)
AcGeScale2d & | postMultBy (const AcGeScale2d &rightSide)
AcGeScale2d & | preMultBy (const AcGeScale2d &leftSide)
AcGeScale2d & | removeScale (AcGeMatrix2d &mat)
AcGeScale2d & | set (double sc0, double sc1)
AcGeScale2d & | setToProduct (const AcGeScale2d &sclVec1, const AcGeScale2d &sclVec2)
AcGeScale2d & | setToProduct (const AcGeScale2d &sclVec, double s)

Public Attributes

double | sx
double | sy

Static Public Attributes

static const AcGeScale2d kIdentity

Friends

GE_DLLEXPIMPORT AcGeScale2d operator* (double, const AcGeScale2d &scl)
The documentation for this class was generated from the following file:
  • gescl2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeScale2d Member List

This is the complete list of members for AcGeScale2d, including all inherited members.

AcGeScale2d() (defined in AcGeScale2d) | AcGeScale2d |
AcGeScale2d(const AcGeScale2d &src) (defined in AcGeScale2d) | AcGeScale2d |
AcGeScale2d(double factor) (defined in AcGeScale2d) | AcGeScale2d |
AcGeScale2d(double xFactor, double yFactor) (defined in AcGeScale2d) | AcGeScale2d |
extractScale(const AcGeMatrix2d &mat) (defined in AcGeScale2d) | AcGeScale2d |
getMatrix(AcGeMatrix2d &mat) const (defined in AcGeScale2d) | AcGeScale2d |
inverse() const (defined in AcGeScale2d) | AcGeScale2d |
invert() (defined in AcGeScale2d) | AcGeScale2d |
isEqualTo(const AcGeScale2d &scaleVec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeScale2d) | AcGeScale2d |
isProportional(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeScale2d) | AcGeScale2d |
kIdentity (defined in AcGeScale2d) | AcGeScale2d | static
operator AcGeMatrix2d() const (defined in AcGeScale2d) | AcGeScale2d |
operator AcGeScale3d() const (defined in AcGeScale2d) | AcGeScale2d |
operator!=(const AcGeScale2d &sclVec) const (defined in AcGeScale2d) | AcGeScale2d |
operator*(const AcGeScale2d &sclVec) const (defined in AcGeScale2d) | AcGeScale2d |
operator*(double s) const (defined in AcGeScale2d) | AcGeScale2d |
operator* (defined in AcGeScale2d) | AcGeScale2d | friend
operator*=(const AcGeScale2d &scl) (defined in AcGeScale2d) | AcGeScale2d |
operator*=(double s) (defined in AcGeScale2d) | AcGeScale2d |
operator==(const AcGeScale2d &sclVec) const (defined in AcGeScale2d) | AcGeScale2d |
operator[](unsigned int i) const (defined in AcGeScale2d) | AcGeScale2d |
operator[](unsigned int i) (defined in AcGeScale2d) | AcGeScale2d |
postMultBy(const AcGeScale2d &rightSide) (defined in AcGeScale2d) | AcGeScale2d |
preMultBy(const AcGeScale2d &leftSide) (defined in AcGeScale2d) | AcGeScale2d |
removeScale(AcGeMatrix2d &mat) (defined in AcGeScale2d) | AcGeScale2d |
set(double sc0, double sc1) (defined in AcGeScale2d) | AcGeScale2d |
setToProduct(const AcGeScale2d &sclVec1, const AcGeScale2d &sclVec2) (defined in AcGeScale2d) | AcGeScale2d |
setToProduct(const AcGeScale2d &sclVec, double s) (defined in AcGeScale2d) | AcGeScale2d |
sx (defined in AcGeScale2d) | AcGeScale2d |
sy (defined in AcGeScale2d) | AcGeScale2d |


ZRX API Reference: AcGeScale3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Static Public Attributes | Friends | List of all members
AcGeScale3d Class Reference
AcGe Classes

Public Member Functions

AcGeScale3d (const AcGeScale3d &src)
AcGeScale3d (double factor)
AcGeScale3d (double xFact, double yFact, double zFact)
AcGeScale3d & | extractScale (const AcGeMatrix3d &mat)
void | getMatrix (AcGeMatrix3d &mat) const
AcGeScale3d | inverse () const
AcGeScale3d & | invert ()
bool | isEqualTo (const AcGeScale3d &scaleVec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isProportional (const AcGeTol &tol=AcGeContext::gTol) const
operator AcGeMatrix3d () const
bool | operator!= (const AcGeScale3d &sclVec) const
AcGeScale3d | operator* (const AcGeScale3d &sclVec) const
AcGeScale3d | operator* (double s) const
AcGeScale3d & | operator*= (const AcGeScale3d &scl)
AcGeScale3d & | operator*= (double s)
bool | operator== (const AcGeScale3d &sclVec) const
double | operator[] (unsigned int i) const
double & | operator[] (unsigned int i)
AcGeScale3d & | postMultBy (const AcGeScale3d &rightSide)
AcGeScale3d & | preMultBy (const AcGeScale3d &leftSide)
AcGeScale3d & | removeScale (AcGeMatrix3d &mat)
AcGeScale3d & | set (double sc0, double sc1, double sc2)
AcGeScale3d & | setToProduct (const AcGeScale3d &sclVec1, const AcGeScale3d &sclVec2)
AcGeScale3d & | setToProduct (const AcGeScale3d &sclVec, double s)

Public Attributes

double | sx
double | sy
double | sz

Static Public Attributes

static const AcGeScale3d kIdentity

Friends

GE_DLLEXPIMPORT AcGeScale3d operator* (double, const AcGeScale3d &scl)
The documentation for this class was generated from the following file:
  • gescl3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeScale3d Member List

This is the complete list of members for AcGeScale3d, including all inherited members.

AcGeScale3d() (defined in AcGeScale3d) | AcGeScale3d |
AcGeScale3d(const AcGeScale3d &src) (defined in AcGeScale3d) | AcGeScale3d |
AcGeScale3d(double factor) (defined in AcGeScale3d) | AcGeScale3d |
AcGeScale3d(double xFact, double yFact, double zFact) (defined in AcGeScale3d) | AcGeScale3d |
extractScale(const AcGeMatrix3d &mat) (defined in AcGeScale3d) | AcGeScale3d |
getMatrix(AcGeMatrix3d &mat) const (defined in AcGeScale3d) | AcGeScale3d |
inverse() const (defined in AcGeScale3d) | AcGeScale3d |
invert() (defined in AcGeScale3d) | AcGeScale3d |
isEqualTo(const AcGeScale3d &scaleVec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeScale3d) | AcGeScale3d |
isProportional(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeScale3d) | AcGeScale3d |
kIdentity (defined in AcGeScale3d) | AcGeScale3d | static
operator AcGeMatrix3d() const (defined in AcGeScale3d) | AcGeScale3d |
operator!=(const AcGeScale3d &sclVec) const (defined in AcGeScale3d) | AcGeScale3d |
operator*(const AcGeScale3d &sclVec) const (defined in AcGeScale3d) | AcGeScale3d |
operator*(double s) const (defined in AcGeScale3d) | AcGeScale3d |
operator* (defined in AcGeScale3d) | AcGeScale3d | friend
operator*=(const AcGeScale3d &scl) (defined in AcGeScale3d) | AcGeScale3d |
operator*=(double s) (defined in AcGeScale3d) | AcGeScale3d |
operator==(const AcGeScale3d &sclVec) const (defined in AcGeScale3d) | AcGeScale3d |
operator[](unsigned int i) const (defined in AcGeScale3d) | AcGeScale3d |
operator[](unsigned int i) (defined in AcGeScale3d) | AcGeScale3d |
postMultBy(const AcGeScale3d &rightSide) (defined in AcGeScale3d) | AcGeScale3d |
preMultBy(const AcGeScale3d &leftSide) (defined in AcGeScale3d) | AcGeScale3d |
removeScale(AcGeMatrix3d &mat) (defined in AcGeScale3d) | AcGeScale3d |
set(double sc0, double sc1, double sc2) (defined in AcGeScale3d) | AcGeScale3d |
setToProduct(const AcGeScale3d &sclVec1, const AcGeScale3d &sclVec2) (defined in AcGeScale3d) | AcGeScale3d |
setToProduct(const AcGeScale3d &sclVec, double s) (defined in AcGeScale3d) | AcGeScale3d |
sx (defined in AcGeScale3d) | AcGeScale3d |
sy (defined in AcGeScale3d) | AcGeScale3d |
sz (defined in AcGeScale3d) | AcGeScale3d |


ZRX API Reference: AcGeSphere Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeSphere Class Reference
AcGe Classes
+ Inheritance diagram for AcGeSphere:

Public Member Functions

AcGeSphere (double radius, const AcGePoint3d &center)
AcGeSphere (double radius, const AcGePoint3d &center, const AcGeVector3d &northAxis, const AcGeVector3d &refAxis, double startAngleU, double endAngleU, double startAngleV, double endAngleV)
AcGeSphere (const AcGeSphere &sphere)
AcGePoint3d | center () const
void | getAnglesInU (double &start, double &end) const
void | getAnglesInV (double &start, double &end) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOuterNormal () const
AcGeVector3d | northAxis () const
AcGePoint3d | northPole () const
AcGeSphere & | operator= (const AcGeSphere &sphere)
double | radius () const
AcGeVector3d | refAxis () const
AcGeSphere & | set (double radius, const AcGePoint3d &center)
AcGeSphere & | set (double radius, const AcGePoint3d &center, const AcGeVector3d &northAxis, const AcGeVector3d &refAxis, double startAngleU, double endAngleU, double startAngleV, double endAngleV)
AcGeSphere & | setAnglesInU (double start, double end)
AcGeSphere & | setAnglesInV (double start, double end)
AcGeSphere & | setnorthAxis (AcGeVector3d val)
AcGeSphere & | setRadius (double)
AcGeSphere & | setrefAxis (AcGeVector3d val)
AcGePoint3d | southPole () const
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSurface
AcGeSurface (const AcGeSurface &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gesphere.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeSphere Member List

This is the complete list of members for AcGeSphere, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeSphere() (defined in AcGeSphere) | AcGeSphere |
AcGeSphere(double radius, const AcGePoint3d &center) (defined in AcGeSphere) | AcGeSphere |
AcGeSphere(double radius, const AcGePoint3d &center, const AcGeVector3d &northAxis, const AcGeVector3d &refAxis, double startAngleU, double endAngleU, double startAngleV, double endAngleV) (defined in AcGeSphere) | AcGeSphere |
AcGeSphere(const AcGeSphere &sphere) (defined in AcGeSphere) | AcGeSphere |
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
center() const (defined in AcGeSphere) | AcGeSphere |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
getAnglesInU(double &start, double &end) const (defined in AcGeSphere) | AcGeSphere |
getAnglesInV(double &start, double &end) const (defined in AcGeSphere) | AcGeSphere |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
intersectWith(const AcGeLinearEnt3d &, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSphere) | AcGeSphere |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSphere) | AcGeSphere |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOuterNormal() const (defined in AcGeSphere) | AcGeSphere |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
northAxis() const (defined in AcGeSphere) | AcGeSphere |
northPole() const (defined in AcGeSphere) | AcGeSphere |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeSphere &sphere) (defined in AcGeSphere) | AcGeSphere |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
radius() const (defined in AcGeSphere) | AcGeSphere |
refAxis() const (defined in AcGeSphere) | AcGeSphere |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(double radius, const AcGePoint3d &center) (defined in AcGeSphere) | AcGeSphere |
set(double radius, const AcGePoint3d &center, const AcGeVector3d &northAxis, const AcGeVector3d &refAxis, double startAngleU, double endAngleU, double startAngleV, double endAngleV) (defined in AcGeSphere) | AcGeSphere |
setAnglesInU(double start, double end) (defined in AcGeSphere) | AcGeSphere |
setAnglesInV(double start, double end) (defined in AcGeSphere) | AcGeSphere |
setnorthAxis(AcGeVector3d val) (defined in AcGeSphere) | AcGeSphere |
setRadius(double) (defined in AcGeSphere) | AcGeSphere |
setrefAxis(AcGeVector3d val) (defined in AcGeSphere) | AcGeSphere |
southPole() const (defined in AcGeSphere) | AcGeSphere |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeSplineEnt2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGeSplineEnt2d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeSplineEnt2d:

Public Member Functions

int | continuityAtKnot (int idx, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | controlPointAt (int idx) const
int | degree () const
double | endParam () const
AcGePoint2d | endPoint () const
Adesk::Boolean | hasFitData () const
Adesk::Boolean | isRational () const
double | knotAt (int idx) const
const AcGeKnotVector & | knots () const
int | numControlPoints () const
int | numKnots () const
AcGeSplineEnt2d & | operator= (const AcGeSplineEnt2d &spline)
int | order () const
AcGeSplineEnt2d & | setControlPointAt (int idx, const AcGePoint2d &pnt)
AcGeSplineEnt2d & | setKnotAt (int idx, double val)
double | startParam () const
AcGePoint2d | startPoint () const
- Public Member Functions inherited from AcGeCurve2d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock2d | boundBlock () const
AcGeBoundBlock2d | boundBlock (const AcGeInterval &range) const
AcGePoint2d | closestPointTo (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | closestPointTo (const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint2d | evalPoint (double param) const
AcGePoint2d | evalPoint (double param, int numDeriv, AcGeVector2dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const
void | getLocalClosestPoints (const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint2dArray &) const
void | getSplitCurves (double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const
void | getTrimmedOffset (double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint2d &endPoint) const
Adesk::Boolean | hasStartPoint (AcGePoint2d &startPoint) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve2d & | operator= (const AcGeCurve2d &curve)
AcGeBoundBlock2d | orthoBoundBlock () const
AcGeBoundBlock2d | orthoBoundBlock (const AcGeInterval &range) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve2d & | reverseParam ()
AcGeCurve2d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity2d
AcGeEntity2d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity2d & | mirror (const AcGeLine2d &line)
Adesk::Boolean | operator!= (const AcGeEntity2d &entity) const
AcGeEntity2d & | operator= (const AcGeEntity2d &entity)
Adesk::Boolean | operator== (const AcGeEntity2d &entity) const
AcGeEntity2d & | rotateBy (double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | scaleBy (double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin)
AcGeEntity2d & | transformBy (const AcGeMatrix2d &xfm)
AcGeEntity2d & | translateBy (const AcGeVector2d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGeSplineEnt2d (const AcGeSplineEnt2d &)
- Protected Member Functions inherited from AcGeCurve2d
AcGeCurve2d (const AcGeCurve2d &)
- Protected Member Functions inherited from AcGeEntity2d
AcGeEntity2d (const AcGeEntity2d &)
AcGeEntity2d (AcGeImpEntity3d &, int)
AcGeEntity2d (AcGeImpEntity3d *)
AcGeEntity2d * newEntity2d (AcGeImpEntity3d *) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity2d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gesent2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeSplineEnt2d Member List

This is the complete list of members for AcGeSplineEnt2d, including all inherited members.

AcGeCurve2d() (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeCurve2d(const AcGeCurve2d &) (defined in AcGeCurve2d) | AcGeCurve2d | protected
AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(const AcGeEntity2d &) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d &, int) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeEntity2d(AcGeImpEntity3d *) (defined in AcGeEntity2d) | AcGeEntity2d | protected
AcGeSplineEnt2d() (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d | protected
AcGeSplineEnt2d(const AcGeSplineEnt2d &) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
closestPointTo(const AcGeCurve2d &curve2d, AcGePoint2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
continuityAtKnot(int idx, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
controlPointAt(int idx) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
copy() const (defined in AcGeEntity2d) | AcGeEntity2d |
degree() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
distanceTo(const AcGePoint2d &pnt, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
distanceTo(const AcGeCurve2d &, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
endParam() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
endPoint() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
evalPoint(double param) const (defined in AcGeCurve2d) | AcGeCurve2d |
evalPoint(double param, int numDeriv, AcGeVector2dArray &derivArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurve, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getClosestPointTo(const AcGeCurve2d &curve2d, AcGePointOnCurve2d &pntOnThisCrv, AcGePointOnCurve2d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve2d) | AcGeCurve2d |
getInterval(AcGeInterval &intrvl, AcGePoint2d &start, AcGePoint2d &end) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGePoint2d &point, AcGePointOnCurve2d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getLocalClosestPoints(const AcGeCurve2d &otherCurve, AcGePointOnCurve2d &approxPntOnThisCrv, AcGePointOnCurve2d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getNormalPoint(const AcGePoint2d &pnt, AcGePointOnCurve2d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint2dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSamplePoints(int numSample, AcGePoint2dArray &) const (defined in AcGeCurve2d) | AcGeCurve2d |
getSplitCurves(double param, AcGeCurve2d *&piece1, AcGeCurve2d *&piece2) const (defined in AcGeCurve2d) | AcGeCurve2d |
getTrimmedOffset(double distance, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasEndPoint(AcGePoint2d &endPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
hasFitData() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
hasStartPoint(AcGePoint2d &startPoint) const (defined in AcGeCurve2d) | AcGeCurve2d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isDegenerate(AcGeEntity2d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isEqualTo(const AcGeEntity2d &entity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity2d) | AcGeEntity2d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity2d) | AcGeEntity2d |
isLinear(AcGeLine2d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(const AcGePoint2d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
isPeriodic(double &period) const (defined in AcGeCurve2d) | AcGeCurve2d |
isRational() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
knotAt(int idx) const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
knots() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
mDelEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
mirror(const AcGeLine2d &line) (defined in AcGeEntity2d) | AcGeEntity2d |
mpImpEnt (defined in AcGeEntity2d) | AcGeEntity2d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity2d) | AcGeEntity2d | protected
numControlPoints() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
numKnots() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
operator!=(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
operator=(const AcGeSplineEnt2d &spline) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
operator=(const AcGeCurve2d &curve) (defined in AcGeCurve2d) | AcGeCurve2d |
operator=(const AcGeEntity2d &entity) (defined in AcGeEntity2d) | AcGeEntity2d |
operator==(const AcGeEntity2d &entity) const (defined in AcGeEntity2d) | AcGeEntity2d |
order() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
orthoBoundBlock() const (defined in AcGeCurve2d) | AcGeCurve2d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve2d) | AcGeCurve2d |
paramOf(const AcGePoint2d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve2d) | AcGeCurve2d |
reverseParam() (defined in AcGeCurve2d) | AcGeCurve2d |
rotateBy(double angle, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
scaleBy(double scaleFactor, const AcGePoint2d &wrtPoint=AcGePoint2d::kOrigin) (defined in AcGeEntity2d) | AcGeEntity2d |
setControlPointAt(int idx, const AcGePoint2d &pnt) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
setInterval() (defined in AcGeCurve2d) | AcGeCurve2d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve2d) | AcGeCurve2d |
setKnotAt(int idx, double val) (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
startParam() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
startPoint() const (defined in AcGeSplineEnt2d) | AcGeSplineEnt2d |
transformBy(const AcGeMatrix2d &xfm) (defined in AcGeEntity2d) | AcGeEntity2d |
translateBy(const AcGeVector2d &translateVec) (defined in AcGeEntity2d) | AcGeEntity2d |
type() const (defined in AcGeEntity2d) | AcGeEntity2d |
~AcGeEntity2d() (defined in AcGeEntity2d) | AcGeEntity2d |


ZRX API Reference: AcGeSplineEnt3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGeSplineEnt3d Class Reference
AcGe Classes
+ Inheritance diagram for AcGeSplineEnt3d:

Public Member Functions

int | continuityAtKnot (int idx, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | controlPointAt (int idx) const
int | degree () const
double | endParam () const
AcGePoint3d | endPoint () const
Adesk::Boolean | hasFitData () const
Adesk::Boolean | isRational () const
double | knotAt (int idx) const
const AcGeKnotVector & | knots () const
int | numControlPoints () const
int | numKnots () const
AcGeSplineEnt3d & | operator= (const AcGeSplineEnt3d &spline)
int | order () const
AcGeSplineEnt3d & | setControlPointAt (int idx, const AcGePoint3d &pnt)
AcGeSplineEnt3d & | setKnotAt (int idx, double val)
double | startParam () const
AcGePoint3d | startPoint () const
- Public Member Functions inherited from AcGeCurve3d
Adesk::Boolean | area (double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const
AcGeBoundBlock3d | boundBlock () const
AcGeBoundBlock3d | boundBlock (const AcGeInterval &range) const
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | closestPointTo (const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (double param) const
AcGePoint3d | evalPoint (double param, int numDeriv, AcGeVector3dArray &derivArray) const
Adesk::Boolean | explode (AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getClosestPointTo (const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getInterval (AcGeInterval &intrvl) const
void | getInterval (AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const
void | getLocalClosestPoints (const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const
void | getLocalClosestPoints (const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | getNormalPoint (const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getProjClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
void | getSamplePoints (double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray) const
void | getSamplePoints (int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const
void | getSplitCurves (double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const
void | getTrimmedOffset (double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | hasEndPoint (AcGePoint3d &endPnt) const
Adesk::Boolean | hasStartPoint (AcGePoint3d &startPnt) const
Adesk::Boolean | isClosed (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCoplanarWith (const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isDegenerate (AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isLinear (AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (double param, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPeriodic (double &period) const
Adesk::Boolean | isPlanar (AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const
double | length (double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const
AcGeCurve3d & | operator= (const AcGeCurve3d &curve)
AcGeBoundBlock3d | orthoBoundBlock () const
AcGeBoundBlock3d | orthoBoundBlock (const AcGeInterval &range) const
AcGeEntity3d * | orthoProject (const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const
double | paramAtLength (double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const
double | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | projClosestPointTo (const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d * | project (const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const
AcGeCurve3d & | reverseParam ()
AcGeCurve3d & | setInterval ()
Adesk::Boolean | setInterval (const AcGeInterval &intrvl)
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGeSplineEnt3d (const AcGeSplineEnt3d &)
- Protected Member Functions inherited from AcGeCurve3d
AcGeCurve3d (const AcGeCurve3d &)
- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gesent3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeSplineEnt3d Member List

This is the complete list of members for AcGeSplineEnt3d, including all inherited members.

AcGeCurve3d() (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeCurve3d(const AcGeCurve3d &) (defined in AcGeCurve3d) | AcGeCurve3d | protected
AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeSplineEnt3d() (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
AcGeSplineEnt3d(const AcGeSplineEnt3d &) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d | protected
area(double startParam, double endParam, double &value, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
boundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
closestPointTo(const AcGeCurve3d &curve3d, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
continuityAtKnot(int idx, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
controlPointAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
degree() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
distanceTo(const AcGeCurve3d &curve, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
endParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
endPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
evalPoint(double param) const (defined in AcGeCurve3d) | AcGeCurve3d |
evalPoint(double param, int numDeriv, AcGeVector3dArray &derivArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
explode(AcGeVoidPointerArray &explodedCurves, AcGeIntArray &newExplodedCurves, const AcGeInterval *intrvl=NULL) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getClosestPointTo(const AcGeCurve3d &curve3d, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl) const (defined in AcGeCurve3d) | AcGeCurve3d |
getInterval(AcGeInterval &intrvl, AcGePoint3d &start, AcGePoint3d &end) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGePoint3d &point, AcGePointOnCurve3d &approxPnt, const AcGeInterval *nbhd=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getLocalClosestPoints(const AcGeCurve3d &otherCurve, AcGePointOnCurve3d &approxPntOnThisCrv, AcGePointOnCurve3d &approxPntOnOtherCrv, const AcGeInterval *nbhd1=0, const AcGeInterval *nbhd2=0, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getNormalPoint(const AcGePoint3d &pnt, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getProjClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePointOnCurve3d &pntOnThisCrv, AcGePointOnCurve3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(double fromParam, double toParam, double approxEps, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSamplePoints(int numSample, AcGePoint3dArray &pointArray, AcGeDoubleArray &paramArray) const (defined in AcGeCurve3d) | AcGeCurve3d |
getSplitCurves(double param, AcGeCurve3d *&piece1, AcGeCurve3d *&piece2) const (defined in AcGeCurve3d) | AcGeCurve3d |
getTrimmedOffset(double distance, const AcGeVector3d &planeNormal, AcGeVoidPointerArray &offsetCurveList, AcGe::OffsetCrvExtType extensionType=AcGe::kFillet, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasEndPoint(AcGePoint3d &endPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
hasFitData() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
hasStartPoint(AcGePoint3d &startPnt) const (defined in AcGeCurve3d) | AcGeCurve3d |
isClosed(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isCoplanarWith(const AcGeCurve3d &curve3d, AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGe::EntityId &degenerateType, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isDegenerate(AcGeEntity3d *&pConvertedEntity, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLinear(AcGeLine3d &line, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(const AcGePoint3d &pnt, double &param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isOn(double param, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPeriodic(double &period) const (defined in AcGeCurve3d) | AcGeCurve3d |
isPlanar(AcGePlane &plane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
isRational() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
knotAt(int idx) const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
knots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
length(double fromParam, double toParam, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numControlPoints() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
numKnots() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeSplineEnt3d &spline) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
operator=(const AcGeCurve3d &curve) (defined in AcGeCurve3d) | AcGeCurve3d |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
order() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
orthoBoundBlock() const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoBoundBlock(const AcGeInterval &range) const (defined in AcGeCurve3d) | AcGeCurve3d |
orthoProject(const AcGePlane &projectionPlane, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramAtLength(double datumParam, double length, Adesk::Boolean posParamDir=Adesk::kTrue, double tol=AcGeContext::gTol.equalPoint()) const (defined in AcGeCurve3d) | AcGeCurve3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGePoint3d &pnt, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
projClosestPointTo(const AcGeCurve3d &curve3d, const AcGeVector3d &projectDirection, AcGePoint3d &pntOnOtherCrv, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
project(const AcGePlane &projectionPlane, const AcGeVector3d &projectDirection, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeCurve3d) | AcGeCurve3d |
reverseParam() (defined in AcGeCurve3d) | AcGeCurve3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
setControlPointAt(int idx, const AcGePoint3d &pnt) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
setInterval() (defined in AcGeCurve3d) | AcGeCurve3d |
setInterval(const AcGeInterval &intrvl) (defined in AcGeCurve3d) | AcGeCurve3d |
setKnotAt(int idx, double val) (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
startParam() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
startPoint() const (defined in AcGeSplineEnt3d) | AcGeSplineEnt3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeSurface Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGeSurface Class Reference
AcGe Classes
+ Inheritance diagram for AcGeSurface:

Public Member Functions

AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Protected Member Functions

AcGeSurface (const AcGeSurface &)
- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const

Additional Inherited Members

- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gesurf.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeSurface Member List

This is the complete list of members for AcGeSurface, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeSurfSurfInt Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeSurfSurfInt Class Reference
AcGe Classes
+ Inheritance diagram for AcGeSurfSurfInt:

Public Member Functions

AcGeSurfSurfInt (const AcGeSurface &srf1, const AcGeSurface &srf2, const AcGeTol &tol=AcGeContext::gTol)
AcGeSurfSurfInt (const AcGeSurfSurfInt &src)
int | getDimension (int intNum, AcGe::AcGeIntersectError &err) const
void | getIntConfigs (int intNum, AcGe::ssiConfig &surf1Left, AcGe::ssiConfig &surf1Right, AcGe::ssiConfig &surf2Left, AcGe::ssiConfig &surf2Right, AcGe::ssiType &intType, int &dim, AcGe::AcGeIntersectError &err) const
void | getIntPointParams (int intNum, AcGePoint2d &param1, AcGePoint2d &param2, AcGe::AcGeIntersectError &err) const
AcGe::ssiType | getType (int intNum, AcGe::AcGeIntersectError &err) const
AcGeCurve3d * | intCurve (int intNum, Adesk::Boolean isExternal, AcGe::AcGeIntersectError &err) const
AcGeCurve2d * | intParamCurve (int num, Adesk::Boolean isExternal, Adesk::Boolean isFirst, AcGe::AcGeIntersectError &err) const
AcGePoint3d | intPoint (int intNum, AcGe::AcGeIntersectError &err) const
int | numResults (AcGe::AcGeIntersectError &err) const
AcGeSurfSurfInt & | operator= (const AcGeSurfSurfInt &crvInt)
AcGeSurfSurfInt & | set (const AcGeSurface &srf1, const AcGeSurface &srf2, const AcGeTol &tol=AcGeContext::gTol)
const AcGeSurface * | surface1 () const
const AcGeSurface * | surface2 () const
AcGeTol | tolerance () const
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeEntity3d
AcGeEntity3d (const AcGeEntity3d &)
AcGeEntity3d (AcGeImpEntity3d &, int)
AcGeEntity3d (AcGeImpEntity3d *)
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d *) const
AcGeEntity2d * | newEntity2d (AcGeImpEntity3d &, int) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d *) const
AcGeEntity3d * | newEntity3d (AcGeImpEntity3d &, int) const
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • gessint.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeSurfSurfInt Member List

This is the complete list of members for AcGeSurfSurfInt, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeSurfSurfInt() (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
AcGeSurfSurfInt(const AcGeSurface &srf1, const AcGeSurface &srf2, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
AcGeSurfSurfInt(const AcGeSurfSurfInt &src) (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
getDimension(int intNum, AcGe::AcGeIntersectError &err) const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
getIntConfigs(int intNum, AcGe::ssiConfig &surf1Left, AcGe::ssiConfig &surf1Right, AcGe::ssiConfig &surf2Left, AcGe::ssiConfig &surf2Right, AcGe::ssiType &intType, int &dim, AcGe::AcGeIntersectError &err) const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
getIntPointParams(int intNum, AcGePoint2d &param1, AcGePoint2d &param2, AcGe::AcGeIntersectError &err) const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
getType(int intNum, AcGe::AcGeIntersectError &err) const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
intCurve(int intNum, Adesk::Boolean isExternal, AcGe::AcGeIntersectError &err) const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
intParamCurve(int num, Adesk::Boolean isExternal, Adesk::Boolean isFirst, AcGe::AcGeIntersectError &err) const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
intPoint(int intNum, AcGe::AcGeIntersectError &err) const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
numResults(AcGe::AcGeIntersectError &err) const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeSurfSurfInt &crvInt) (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(const AcGeSurface &srf1, const AcGeSurface &srf2, const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
surface1() const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
surface2() const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
tolerance() const (defined in AcGeSurfSurfInt) | AcGeSurfSurfInt |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeTol Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcGeTol Class Reference
AcGe Classes

Public Member Functions

double | equalPoint () const
double | equalVector () const
void | setEqualPoint (double val)
void | setEqualVector (double val)

Friends

class AcGeTolA
The documentation for this class was generated from the following file:
  • getol.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeTol Member List

This is the complete list of members for AcGeTol, including all inherited members.

AcGeTol() (defined in AcGeTol) | AcGeTol |
AcGeTolA (defined in AcGeTol) | AcGeTol | friend
equalPoint() const (defined in AcGeTol) | AcGeTol |
equalVector() const (defined in AcGeTol) | AcGeTol |
setEqualPoint(double val) (defined in AcGeTol) | AcGeTol |
setEqualVector(double val) (defined in AcGeTol) | AcGeTol |


ZRX API Reference: AcGeTorus Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGeTorus Class Reference
AcGe Classes
+ Inheritance diagram for AcGeTorus:

Public Member Functions

AcGeTorus (double majorRadius, double minorRadius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry)
AcGeTorus (double majorRadius, double minorRadius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, double startAngleU, double endAngleU, double startAngleV, double endAngleV)
AcGeTorus (const AcGeTorus &torus)
AcGeVector3d | axisOfSymmetry () const
AcGePoint3d | center () const
void | getAnglesInU (double &start, double &end) const
void | getAnglesInV (double &start, double &end) const
Adesk::Boolean | intersectWith (const AcGeLinearEnt3d &linEnt, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, AcGePoint3d &p3, AcGePoint3d &p4, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isApple () const
Adesk::Boolean | isDegenerate () const
Adesk::Boolean | isDoughnut () const
Adesk::Boolean | isHollow () const
Adesk::Boolean | isLemon () const
Adesk::Boolean | isOuterNormal () const
Adesk::Boolean | isVortex () const
double | majorRadius () const
double | minorRadius () const
AcGeTorus & | operator= (const AcGeTorus &torus)
AcGeVector3d | refAxis () const
AcGeTorus & | set (double majorRadius, double minorRadius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry)
AcGeTorus & | set (double majorRadius, double minorRadius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, double startAngleU, double endAngleU, double startAngleV, double endAngleV)
AcGeTorus & | set (const AcGePoint3d &cent, const AcGeVector3d &nrm, const AcGeVector3d &refVec, double radius, double startAngle, double endAngle)
AcGeTorus & | set (const AcGePoint3d &cent, const AcGeVector3d &nrm, double radius)
AcGeTorus & | setAnglesInU (double start, double end)
AcGeTorus & | setAnglesInV (double start, double end)
AcGeTorus & | setMajorRadius (double radius)
AcGeTorus & | setMinorRadius (double radius)
- Public Member Functions inherited from AcGeSurface
AcGePoint3d | closestPointTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
double | distanceTo (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGePoint3d | evalPoint (const AcGePoint2d &param) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const
AcGePoint3d | evalPoint (const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const
void | getClosestPointTo (const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const
void | getEnvelope (AcGeInterval &intrvlX, AcGeInterval &intrvlY) const
Adesk::Boolean | isClosedInU (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isClosedInV (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isNormalReversed () const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isOn (const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | operator= (const AcGeSurface &otherSurface)
AcGePoint2d | paramOf (const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const
AcGeSurface & | reverseNormal ()
- Public Member Functions inherited from AcGeEntity3d
AcGeEntity3d * | copy () const
Adesk::Boolean | isEqualTo (const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isKindOf (AcGe::EntityId entType) const
AcGeEntity3d & | mirror (const AcGePlane &plane)
Adesk::Boolean | operator!= (const AcGeEntity3d &entity) const
AcGeEntity3d & | operator= (const AcGeEntity3d &entity)
Adesk::Boolean | operator== (const AcGeEntity3d &entity) const
AcGeEntity3d & | rotateBy (double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | scaleBy (double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin)
AcGeEntity3d & | transformBy (const AcGeMatrix3d &xfm)
AcGeEntity3d & | translateBy (const AcGeVector3d &translateVec)
AcGe::EntityId | type () const

Additional Inherited Members

- Protected Member Functions inherited from AcGeSurface
AcGeSurface (const AcGeSurface &)
- Protected Attributes inherited from AcGeEntity3d
int | mDelEnt
AcGeImpEntity3d * | mpImpEnt
The documentation for this class was generated from the following file:
  • getorus.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeTorus Member List

This is the complete list of members for AcGeTorus, including all inherited members.

AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(const AcGeEntity3d &) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d &, int) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeEntity3d(AcGeImpEntity3d *) (defined in AcGeEntity3d) | AcGeEntity3d | protected
AcGeSurface() (defined in AcGeSurface) | AcGeSurface | protected
AcGeSurface(const AcGeSurface &) (defined in AcGeSurface) | AcGeSurface | protected
AcGeTorus() (defined in AcGeTorus) | AcGeTorus |
AcGeTorus(double majorRadius, double minorRadius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry) (defined in AcGeTorus) | AcGeTorus |
AcGeTorus(double majorRadius, double minorRadius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, double startAngleU, double endAngleU, double startAngleV, double endAngleV) (defined in AcGeTorus) | AcGeTorus |
AcGeTorus(const AcGeTorus &torus) (defined in AcGeTorus) | AcGeTorus |
axisOfSymmetry() const (defined in AcGeTorus) | AcGeTorus |
center() const (defined in AcGeTorus) | AcGeTorus |
closestPointTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
copy() const (defined in AcGeEntity3d) | AcGeEntity3d |
distanceTo(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives) const (defined in AcGeSurface) | AcGeSurface |
evalPoint(const AcGePoint2d &param, int derivOrd, AcGeVector3dArray &derivatives, AcGeVector3d &normal) const (defined in AcGeSurface) | AcGeSurface |
getAnglesInU(double &start, double &end) const (defined in AcGeTorus) | AcGeTorus |
getAnglesInV(double &start, double &end) const (defined in AcGeTorus) | AcGeTorus |
getClosestPointTo(const AcGePoint3d &pnt, AcGePointOnSurface &result, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
getEnvelope(AcGeInterval &intrvlX, AcGeInterval &intrvlY) const (defined in AcGeSurface) | AcGeSurface |
intersectWith(const AcGeLinearEnt3d &linEnt, int &intn, AcGePoint3d &p1, AcGePoint3d &p2, AcGePoint3d &p3, AcGePoint3d &p4, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeTorus) | AcGeTorus |
isApple() const (defined in AcGeTorus) | AcGeTorus |
isClosedInU(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isClosedInV(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isDegenerate() const (defined in AcGeTorus) | AcGeTorus |
isDoughnut() const (defined in AcGeTorus) | AcGeTorus |
isEqualTo(const AcGeEntity3d &ent, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeEntity3d) | AcGeEntity3d |
isHollow() const (defined in AcGeTorus) | AcGeTorus |
isKindOf(AcGe::EntityId entType) const (defined in AcGeEntity3d) | AcGeEntity3d |
isLemon() const (defined in AcGeTorus) | AcGeTorus |
isNormalReversed() const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOn(const AcGePoint3d &pnt, AcGePoint2d &paramPoint, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
isOuterNormal() const (defined in AcGeTorus) | AcGeTorus |
isVortex() const (defined in AcGeTorus) | AcGeTorus |
majorRadius() const (defined in AcGeTorus) | AcGeTorus |
mDelEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
minorRadius() const (defined in AcGeTorus) | AcGeTorus |
mirror(const AcGePlane &plane) (defined in AcGeEntity3d) | AcGeEntity3d |
mpImpEnt (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity2d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d *) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
newEntity3d(AcGeImpEntity3d &, int) const (defined in AcGeEntity3d) | AcGeEntity3d | protected
operator!=(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
operator=(const AcGeTorus &torus) (defined in AcGeTorus) | AcGeTorus |
operator=(const AcGeSurface &otherSurface) (defined in AcGeSurface) | AcGeSurface |
operator=(const AcGeEntity3d &entity) (defined in AcGeEntity3d) | AcGeEntity3d |
operator==(const AcGeEntity3d &entity) const (defined in AcGeEntity3d) | AcGeEntity3d |
paramOf(const AcGePoint3d &pnt, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeSurface) | AcGeSurface |
refAxis() const (defined in AcGeTorus) | AcGeTorus |
reverseNormal() (defined in AcGeSurface) | AcGeSurface |
rotateBy(double angle, const AcGeVector3d &vec, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
scaleBy(double scaleFactor, const AcGePoint3d &wrtPoint=AcGePoint3d::kOrigin) (defined in AcGeEntity3d) | AcGeEntity3d |
set(double majorRadius, double minorRadius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry) (defined in AcGeTorus) | AcGeTorus |
set(double majorRadius, double minorRadius, const AcGePoint3d &origin, const AcGeVector3d &axisOfSymmetry, const AcGeVector3d &refAxis, double startAngleU, double endAngleU, double startAngleV, double endAngleV) (defined in AcGeTorus) | AcGeTorus |
set(const AcGePoint3d &cent, const AcGeVector3d &nrm, const AcGeVector3d &refVec, double radius, double startAngle, double endAngle) (defined in AcGeTorus) | AcGeTorus |
set(const AcGePoint3d &cent, const AcGeVector3d &nrm, double radius) (defined in AcGeTorus) | AcGeTorus |
setAnglesInU(double start, double end) (defined in AcGeTorus) | AcGeTorus |
setAnglesInV(double start, double end) (defined in AcGeTorus) | AcGeTorus |
setMajorRadius(double radius) (defined in AcGeTorus) | AcGeTorus |
setMinorRadius(double radius) (defined in AcGeTorus) | AcGeTorus |
transformBy(const AcGeMatrix3d &xfm) (defined in AcGeEntity3d) | AcGeEntity3d |
translateBy(const AcGeVector3d &translateVec) (defined in AcGeEntity3d) | AcGeEntity3d |
type() const (defined in AcGeEntity3d) | AcGeEntity3d |
~AcGeEntity3d() (defined in AcGeEntity3d) | AcGeEntity3d |


ZRX API Reference: AcGeVector2d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Static Public Attributes | Friends | List of all members
AcGeVector2d Class Reference
AcGe Classes

Public Member Functions

AcGeVector2d (const AcGeVector2d &vec)
AcGeVector2d (double x, double y)
double | angle () const
double | angleTo (const AcGeVector2d &vec) const
double | dotProduct (const AcGeVector2d &vec) const
Adesk::Boolean | isCodirectionalTo (const AcGeVector2d &vec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCodirectionalTo (const AcGeVector2d &vec, const AcGeTol &tol, AcGeError &flag) const
bool | isEqualTo (const AcGeVector2d &vec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeVector2d &vec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeVector2d &vec, const AcGeTol &tol, AcGeError &flag) const
Adesk::Boolean | isPerpendicularTo (const AcGeVector2d &vec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeVector2d &vec, const AcGeTol &tol, AcGeError &flag) const
Adesk::Boolean | isUnitLength (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isZeroLength (const AcGeTol &tol=AcGeContext::gTol) const
double | length () const
double | lengthSqrd () const
AcGeVector2d & | mirror (const AcGeVector2d &line)
AcGeVector2d & | negate ()
AcGeVector2d | normal (const AcGeTol &tol=AcGeContext::gTol) const
AcGeVector2d & | normalize (const AcGeTol &tol=AcGeContext::gTol)
AcGeVector2d & | normalize (const AcGeTol &tol, AcGeError &flag)
operator AcGeMatrix2d () const
bool | operator!= (const AcGeVector2d &vec) const
AcGeVector2d | operator* (double scl) const
AcGeVector2d & | operator*= (double scl)
AcGeVector2d | operator+ (const AcGeVector2d &vec) const
AcGeVector2d & | operator+= (const AcGeVector2d &vec)
AcGeVector2d | operator- (const AcGeVector2d &vec) const
AcGeVector2d | operator- () const
AcGeVector2d & | operator-= (const AcGeVector2d &vec)
AcGeVector2d | operator/ (double scl) const
AcGeVector2d & | operator/= (double scl)
bool | operator== (const AcGeVector2d &vec) const
double | operator[] (unsigned int i) const
double & | operator[] (unsigned int i)
AcGeVector2d | perpVector () const
AcGeVector2d & | rotateBy (double angle)
AcGeVector2d & | set (double x, double y)
AcGeVector2d & | setToProduct (const AcGeMatrix2d &mat, const AcGeVector2d &vec)
AcGeVector2d & | setToProduct (const AcGeVector2d &vec, double scl)
AcGeVector2d & | setToSum (const AcGeVector2d &vec1, const AcGeVector2d &vec2)
AcGeVector2d & | transformBy (const AcGeMatrix2d &leftSide)

Public Attributes

double | x
double | y

Static Public Attributes

static const AcGeVector2d | kIdentity
static const AcGeVector2d | kXAxis
static const AcGeVector2d | kYAxis

Friends

GE_DLLEXPIMPORT AcGeVector2d | operator* (const AcGeMatrix2d &mat, const AcGeVector2d &vec)
GE_DLLEXPIMPORT AcGeVector2d | operator* (double scl, const AcGeVector2d &vec)
The documentation for this class was generated from the following file:
  • gevec2d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeVector2d Member List

This is the complete list of members for AcGeVector2d, including all inherited members.

AcGeVector2d() (defined in AcGeVector2d) | AcGeVector2d |
AcGeVector2d(const AcGeVector2d &vec) (defined in AcGeVector2d) | AcGeVector2d |
AcGeVector2d(double x, double y) (defined in AcGeVector2d) | AcGeVector2d |
angle() const (defined in AcGeVector2d) | AcGeVector2d |
angleTo(const AcGeVector2d &vec) const (defined in AcGeVector2d) | AcGeVector2d |
dotProduct(const AcGeVector2d &vec) const (defined in AcGeVector2d) | AcGeVector2d |
isCodirectionalTo(const AcGeVector2d &vec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector2d) | AcGeVector2d |
isCodirectionalTo(const AcGeVector2d &vec, const AcGeTol &tol, AcGeError &flag) const (defined in AcGeVector2d) | AcGeVector2d |
isEqualTo(const AcGeVector2d &vec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector2d) | AcGeVector2d |
isParallelTo(const AcGeVector2d &vec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector2d) | AcGeVector2d |
isParallelTo(const AcGeVector2d &vec, const AcGeTol &tol, AcGeError &flag) const (defined in AcGeVector2d) | AcGeVector2d |
isPerpendicularTo(const AcGeVector2d &vec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector2d) | AcGeVector2d |
isPerpendicularTo(const AcGeVector2d &vec, const AcGeTol &tol, AcGeError &flag) const (defined in AcGeVector2d) | AcGeVector2d |
isUnitLength(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector2d) | AcGeVector2d |
isZeroLength(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector2d) | AcGeVector2d |
kIdentity (defined in AcGeVector2d) | AcGeVector2d | static
kXAxis (defined in AcGeVector2d) | AcGeVector2d | static
kYAxis (defined in AcGeVector2d) | AcGeVector2d | static
length() const (defined in AcGeVector2d) | AcGeVector2d |
lengthSqrd() const (defined in AcGeVector2d) | AcGeVector2d |
mirror(const AcGeVector2d &line) (defined in AcGeVector2d) | AcGeVector2d |
negate() (defined in AcGeVector2d) | AcGeVector2d |
normal(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector2d) | AcGeVector2d |
normalize(const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeVector2d) | AcGeVector2d |
normalize(const AcGeTol &tol, AcGeError &flag) (defined in AcGeVector2d) | AcGeVector2d |
operator AcGeMatrix2d() const (defined in AcGeVector2d) | AcGeVector2d |
operator!=(const AcGeVector2d &vec) const (defined in AcGeVector2d) | AcGeVector2d |
operator* (defined in AcGeVector2d) | AcGeVector2d | friend
operator*(double scl) const (defined in AcGeVector2d) | AcGeVector2d |
operator* (defined in AcGeVector2d) | AcGeVector2d | friend
operator*=(double scl) (defined in AcGeVector2d) | AcGeVector2d |
operator+(const AcGeVector2d &vec) const (defined in AcGeVector2d) | AcGeVector2d |
operator+=(const AcGeVector2d &vec) (defined in AcGeVector2d) | AcGeVector2d |
operator-(const AcGeVector2d &vec) const (defined in AcGeVector2d) | AcGeVector2d |
operator-() const (defined in AcGeVector2d) | AcGeVector2d |
operator-=(const AcGeVector2d &vec) (defined in AcGeVector2d) | AcGeVector2d |
operator/(double scl) const (defined in AcGeVector2d) | AcGeVector2d |
operator/=(double scl) (defined in AcGeVector2d) | AcGeVector2d |
operator==(const AcGeVector2d &vec) const (defined in AcGeVector2d) | AcGeVector2d |
operator[](unsigned int i) const (defined in AcGeVector2d) | AcGeVector2d |
operator[](unsigned int i) (defined in AcGeVector2d) | AcGeVector2d |
perpVector() const (defined in AcGeVector2d) | AcGeVector2d |
rotateBy(double angle) (defined in AcGeVector2d) | AcGeVector2d |
set(double x, double y) (defined in AcGeVector2d) | AcGeVector2d |
setToProduct(const AcGeMatrix2d &mat, const AcGeVector2d &vec) (defined in AcGeVector2d) | AcGeVector2d |
setToProduct(const AcGeVector2d &vec, double scl) (defined in AcGeVector2d) | AcGeVector2d |
setToSum(const AcGeVector2d &vec1, const AcGeVector2d &vec2) (defined in AcGeVector2d) | AcGeVector2d |
transformBy(const AcGeMatrix2d &leftSide) (defined in AcGeVector2d) | AcGeVector2d |
x (defined in AcGeVector2d) | AcGeVector2d |
y (defined in AcGeVector2d) | AcGeVector2d |


ZRX API Reference: AcGeVector3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Static Public Attributes | Friends | List of all members
AcGeVector3d Class Reference
AcGe Classes

Public Member Functions

AcGeVector3d (const AcGeVector3d &vec)
AcGeVector3d (double x, double y, double z)
AcGeVector3d (const AcGePlanarEnt &, const AcGeVector2d &)
double | angleOnPlane (const AcGePlanarEnt &pln) const
double | angleTo (const AcGeVector3d &vec) const
double | angleTo (const AcGeVector3d &vec, const AcGeVector3d &refVec) const
AcGeVector2d | convert2d (const AcGePlanarEnt &pln) const
AcGeVector3d | crossProduct (const AcGeVector3d &vec) const
double | dotProduct (const AcGeVector3d &vec) const
Adesk::Boolean | isCodirectionalTo (const AcGeVector3d &vec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isCodirectionalTo (const AcGeVector3d &vec, const AcGeTol &tol, AcGeError &flag) const
bool | isEqualTo (const AcGeVector3d &vec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeVector3d &vec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isParallelTo (const AcGeVector3d &vec, const AcGeTol &tol, AcGeError &flag) const
Adesk::Boolean | isPerpendicularTo (const AcGeVector3d &vec, const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isPerpendicularTo (const AcGeVector3d &vec, const AcGeTol &tol, AcGeError &flag) const
Adesk::Boolean | isUnitLength (const AcGeTol &tol=AcGeContext::gTol) const
Adesk::Boolean | isZeroLength (const AcGeTol &tol=AcGeContext::gTol) const
unsigned int | largestElement () const
double | length () const
double | lengthSqrd () const
AcGeVector3d & | mirror (const AcGeVector3d &normalToPlane)
AcGeVector3d & | negate ()
AcGeVector3d | normal (const AcGeTol &tol=AcGeContext::gTol) const
AcGeVector3d & | normalize (const AcGeTol &tol=AcGeContext::gTol)
AcGeVector3d & | normalize (const AcGeTol &tol, AcGeError &flag)
operator AcGeMatrix3d () const
bool | operator!= (const AcGeVector3d &vec) const
AcGeVector3d | operator* (double scl) const
AcGeVector3d & | operator*= (double scl)
AcGeVector3d | operator+ (const AcGeVector3d &vec) const
AcGeVector3d & | operator+= (const AcGeVector3d &vec)
AcGeVector3d | operator- (const AcGeVector3d &vec) const
AcGeVector3d | operator- () const
AcGeVector3d & | operator-= (const AcGeVector3d &vec)
AcGeVector3d | operator/ (double scl) const
AcGeVector3d & | operator/= (double scl)
bool | operator== (const AcGeVector3d &vec) const
double | operator[] (unsigned int i) const
double & | operator[] (unsigned int i)
AcGeVector3d | orthoProject (const AcGeVector3d &planeNormal) const
AcGeVector3d | orthoProject (const AcGeVector3d &planeNormal, const AcGeTol &tol, AcGeError &flag) const
AcGeVector3d | perpVector () const
AcGeVector3d | project (const AcGeVector3d &planeNormal, const AcGeVector3d &projectDirection) const
AcGeVector3d | project (const AcGeVector3d &planeNormal, const AcGeVector3d &projectDirection, const AcGeTol &tol, AcGeError &flag) const
AcGeVector3d & | rotateBy (double ang, const AcGeVector3d &axis)
AcGeMatrix3d | rotateTo (const AcGeVector3d &vec, const AcGeVector3d &axis=AcGeVector3d::kIdentity) const
AcGeVector3d & | set (double x, double y, double z)
AcGeVector3d & | set (const AcGePlanarEnt &pln, const AcGeVector2d &vec)
AcGeVector3d & | setToProduct (const AcGeMatrix3d &mat, const AcGeVector3d &vec)
AcGeVector3d & | setToProduct (const AcGeVector3d &vec, double scl)
AcGeVector3d & | setToSum (const AcGeVector3d &vec1, const AcGeVector3d &vec2)
AcGeVector3d & | transformBy (const AcGeMatrix3d &leftSide)

Public Attributes

double | x
double | y
double | z

Static Public Attributes

static const AcGeVector3d | kIdentity
static const AcGeVector3d | kXAxis
static const AcGeVector3d | kYAxis
static const AcGeVector3d | kZAxis

Friends

GE_DLLEXPIMPORT AcGeVector3d | operator* (const AcGeMatrix3d &mat, const AcGeVector3d &vec)
GE_DLLEXPIMPORT AcGeVector3d | operator* (double scl, const AcGeVector3d &vec)
The documentation for this class was generated from the following file:
  • gevec3d.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeVector3d Member List

This is the complete list of members for AcGeVector3d, including all inherited members.

AcGeVector3d() (defined in AcGeVector3d) | AcGeVector3d |
AcGeVector3d(const AcGeVector3d &vec) (defined in AcGeVector3d) | AcGeVector3d |
AcGeVector3d(double x, double y, double z) (defined in AcGeVector3d) | AcGeVector3d |
AcGeVector3d(const AcGePlanarEnt &, const AcGeVector2d &) (defined in AcGeVector3d) | AcGeVector3d |
angleOnPlane(const AcGePlanarEnt &pln) const (defined in AcGeVector3d) | AcGeVector3d |
angleTo(const AcGeVector3d &vec) const (defined in AcGeVector3d) | AcGeVector3d |
angleTo(const AcGeVector3d &vec, const AcGeVector3d &refVec) const (defined in AcGeVector3d) | AcGeVector3d |
convert2d(const AcGePlanarEnt &pln) const (defined in AcGeVector3d) | AcGeVector3d |
crossProduct(const AcGeVector3d &vec) const (defined in AcGeVector3d) | AcGeVector3d |
dotProduct(const AcGeVector3d &vec) const (defined in AcGeVector3d) | AcGeVector3d |
isCodirectionalTo(const AcGeVector3d &vec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector3d) | AcGeVector3d |
isCodirectionalTo(const AcGeVector3d &vec, const AcGeTol &tol, AcGeError &flag) const (defined in AcGeVector3d) | AcGeVector3d |
isEqualTo(const AcGeVector3d &vec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector3d) | AcGeVector3d |
isParallelTo(const AcGeVector3d &vec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector3d) | AcGeVector3d |
isParallelTo(const AcGeVector3d &vec, const AcGeTol &tol, AcGeError &flag) const (defined in AcGeVector3d) | AcGeVector3d |
isPerpendicularTo(const AcGeVector3d &vec, const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector3d) | AcGeVector3d |
isPerpendicularTo(const AcGeVector3d &vec, const AcGeTol &tol, AcGeError &flag) const (defined in AcGeVector3d) | AcGeVector3d |
isUnitLength(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector3d) | AcGeVector3d |
isZeroLength(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector3d) | AcGeVector3d |
kIdentity (defined in AcGeVector3d) | AcGeVector3d | static
kXAxis (defined in AcGeVector3d) | AcGeVector3d | static
kYAxis (defined in AcGeVector3d) | AcGeVector3d | static
kZAxis (defined in AcGeVector3d) | AcGeVector3d | static
largestElement() const (defined in AcGeVector3d) | AcGeVector3d |
length() const (defined in AcGeVector3d) | AcGeVector3d |
lengthSqrd() const (defined in AcGeVector3d) | AcGeVector3d |
mirror(const AcGeVector3d &normalToPlane) (defined in AcGeVector3d) | AcGeVector3d |
negate() (defined in AcGeVector3d) | AcGeVector3d |
normal(const AcGeTol &tol=AcGeContext::gTol) const (defined in AcGeVector3d) | AcGeVector3d |
normalize(const AcGeTol &tol=AcGeContext::gTol) (defined in AcGeVector3d) | AcGeVector3d |
normalize(const AcGeTol &tol, AcGeError &flag) (defined in AcGeVector3d) | AcGeVector3d |
operator AcGeMatrix3d() const (defined in AcGeVector3d) | AcGeVector3d |
operator!=(const AcGeVector3d &vec) const (defined in AcGeVector3d) | AcGeVector3d |
operator* (defined in AcGeVector3d) | AcGeVector3d | friend
operator*(double scl) const (defined in AcGeVector3d) | AcGeVector3d |
operator* (defined in AcGeVector3d) | AcGeVector3d | friend
operator*=(double scl) (defined in AcGeVector3d) | AcGeVector3d |
operator+(const AcGeVector3d &vec) const (defined in AcGeVector3d) | AcGeVector3d |
operator+=(const AcGeVector3d &vec) (defined in AcGeVector3d) | AcGeVector3d |
operator-(const AcGeVector3d &vec) const (defined in AcGeVector3d) | AcGeVector3d |
operator-() const (defined in AcGeVector3d) | AcGeVector3d |
operator-=(const AcGeVector3d &vec) (defined in AcGeVector3d) | AcGeVector3d |
operator/(double scl) const (defined in AcGeVector3d) | AcGeVector3d |
operator/=(double scl) (defined in AcGeVector3d) | AcGeVector3d |
operator==(const AcGeVector3d &vec) const (defined in AcGeVector3d) | AcGeVector3d |
operator[](unsigned int i) const (defined in AcGeVector3d) | AcGeVector3d |
operator[](unsigned int i) (defined in AcGeVector3d) | AcGeVector3d |
orthoProject(const AcGeVector3d &planeNormal) const (defined in AcGeVector3d) | AcGeVector3d |
orthoProject(const AcGeVector3d &planeNormal, const AcGeTol &tol, AcGeError &flag) const (defined in AcGeVector3d) | AcGeVector3d |
perpVector() const (defined in AcGeVector3d) | AcGeVector3d |
project(const AcGeVector3d &planeNormal, const AcGeVector3d &projectDirection) const (defined in AcGeVector3d) | AcGeVector3d |
project(const AcGeVector3d &planeNormal, const AcGeVector3d &projectDirection, const AcGeTol &tol, AcGeError &flag) const (defined in AcGeVector3d) | AcGeVector3d |
rotateBy(double ang, const AcGeVector3d &axis) (defined in AcGeVector3d) | AcGeVector3d |
rotateTo(const AcGeVector3d &vec, const AcGeVector3d &axis=AcGeVector3d::kIdentity) const (defined in AcGeVector3d) | AcGeVector3d |
set(double x, double y, double z) (defined in AcGeVector3d) | AcGeVector3d |
set(const AcGePlanarEnt &pln, const AcGeVector2d &vec) (defined in AcGeVector3d) | AcGeVector3d |
setToProduct(const AcGeMatrix3d &mat, const AcGeVector3d &vec) (defined in AcGeVector3d) | AcGeVector3d |
setToProduct(const AcGeVector3d &vec, double scl) (defined in AcGeVector3d) | AcGeVector3d |
setToSum(const AcGeVector3d &vec1, const AcGeVector3d &vec2) (defined in AcGeVector3d) | AcGeVector3d |
transformBy(const AcGeMatrix3d &leftSide) (defined in AcGeVector3d) | AcGeVector3d |
x (defined in AcGeVector3d) | AcGeVector3d |
y (defined in AcGeVector3d) | AcGeVector3d |
z (defined in AcGeVector3d) | AcGeVector3d |


ZRX API Reference: AcGi Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Macros | Functions
AcGi Classes

Classes

class | AcGiColorRGB
class | AcGiColorRGBA
class | AcGiCommonDraw
class | AcGiContext
class | AcGiContextualColors
class | AcGiContextualColors2
class | AcGiDisplayStyle
class | AcGiDistantLightTraits
class | AcGiDistantLightTraits2
class | AcGiDrawable
class | AcGiDrawableTraits
class | AcGiEdgeData
class | AcGiEdgeStyle
class | AcGiFaceData
class | AcGiFaceStyle
class | AcGiGenericTexture
class | AcGiGeometry
class | AcGiGradientBackgroundTraits
class | AcGiGroundPlaneBackgroundTraits
class | AcGiImageBackgroundTraits
class | AcGiImageFileTexture
class | AcGiImageTexture
class | AcGiLightAttenuation
class | AcGiLightTraits
class | AcGiLineAttributes
class | AcGiLinetypeEngine
class | AcGiMapper
class | AcGiMarbleTexture
class | AcGiMaterialColor
class | AcGiMaterialMap
class | AcGiMaterialTexture
class | AcGiMaterialTraits
class | AcGiMaterialTraits2
class | AcGiMentalRayRenderSettingsTraits
class | AcGiMentalRayRenderSettingsTraits2
class | AcGiNonEntityTraits
class | AcGiPointLightTraits
class | AcGiPointLightTraits2
class | AcGiProceduralTexture
class | AcGiRenderEnvironmentTraits
class | AcGiRenderSettingsTraits
class | AcGiShadowParameters
class | AcGiShadowParameters2
class | AcGiSkyBackgroundTraits
class | AcGiSkyParameters
class | AcGiSolidBackgroundTraits
class | AcGiSpotLightTraits
class | AcGiSpotLightTraits2
class | AcGiStandardLightTraits
class | AcGiSubEntityTraits
class | AcGiTextEngine
class | AcGiTextStyle
class | AcGiToneOperatorParameters
class | AcGiVariant
class | AcGiVertexData
class | AcGiViewport
class | AcGiViewportDraw
class | AcGiViewportGeometry
class | AcGiViewportTraits
class | AcGiViewportTraits2
class | AcGiVisualStyle
class | AcGiVisualStyleTraits
class | AcGiWebLightTraits
class | AcGiWoodTexture
class | AcGiWorldDraw
class | AcGiWorldGeometry
class | AcGsManager

Macros

#define | AcGiSelectionMarkerACADReserveEnd (AcGiSelectionMarkerACADReserveStart + 65535)
#define | AcGiSelectionMarkerACADReserveStart (-2147483647 - 1)
#define | AcGiSelectionMarkerACADSelectionPreviewOff (AcGiSelectionMarkerACADReserveStart + 1)
#define | AcGiSelectionMarkerACADSelectionPreviewOn (AcGiSelectionMarkerACADReserveStart + 2)

Functions

virtual void | AcGiDrawableTraits::addLight (const AcDbObjectId &lightId)
virtual void | AcGiNonEntityTraits::addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | AcGiNonEntityTraits::color (void) const
virtual Adesk::UInt32 | AcGiSubEntityTraits::drawFlags (void) const
virtual Acad::ErrorStatus | AcGiSubEntityTraits::edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcGiFillType | AcGiNonEntityTraits::fillType (void) const
virtual AcDbObjectId | AcGiNonEntityTraits::layerId (void) const
virtual AcDbObjectId | AcGiNonEntityTraits::lineTypeId (void) const
virtual double | AcGiNonEntityTraits::lineTypeScale (void) const
virtual AcDb::LineWeight | AcGiNonEntityTraits::lineWeight (void) const
virtual const AcGiMapper * | AcGiSubEntityTraits::mapper (void) const
virtual AcDbObjectId | AcGiSubEntityTraits::materialId (void) const
virtual AcDbObjectId | AcGiNonEntityTraits::materialId (void) const
AcGiColorRGB | operator* (const AcGiColorRGB &c1, const AcGiColorRGB &c2)
AcGiColorRGB | operator* (const AcGiColorRGB &c, double s)
AcGiColorRGB | operator* (double s, const AcGiColorRGB &c)
AcGiColorRGBA | operator* (const AcGiColorRGBA &c1, const AcGiColorRGBA &c2)
AcGiColorRGBA | operator* (const AcGiColorRGBA &c, double s)
AcGiColorRGBA | operator* (double s, const AcGiColorRGBA &c)
AcGiColorRGB | operator+ (const AcGiColorRGB &c1, const AcGiColorRGB &c2)
AcGiColorRGBA | operator+ (const AcGiColorRGBA &c1, const AcGiColorRGBA &c2)
virtual bool | AcGiMaterialTexture::operator== (const AcGiMaterialTexture &texture) const
virtual bool | AcGiSubEntityTraits::sectionable (void) const
virtual bool | AcGiSubEntityTraits::selectionGeom (void) const
virtual bool | AcGiNonEntityTraits::selectionGeom (void) const
virtual void | AcGiNonEntityTraits::setColor (const Adesk::UInt16 color)
virtual Acad::ErrorStatus | AcGiSubEntityTraits::setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | AcGiSubEntityTraits::setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | AcGiNonEntityTraits::setFillType (const AcGiFillType fillType)
virtual void | AcGiNonEntityTraits::setLayer (const AcDbObjectId layerId)
virtual void | AcGiNonEntityTraits::setLineType (const AcDbObjectId linetypeId)
virtual void | AcGiNonEntityTraits::setLineTypeScale (double dScale)
virtual void | AcGiNonEntityTraits::setLineWeight (const AcDb::LineWeight lw)
virtual void | AcGiSubEntityTraits::setMapper (const AcGiMapper *mapper)
virtual void | AcGiSubEntityTraits::setMaterial (const AcDbObjectId materialId)
virtual void | AcGiNonEntityTraits::setMaterial (const AcDbObjectId matId)
virtual void | AcGiSubEntityTraits::setSectionable (bool bSectionable)
virtual void | AcGiSubEntityTraits::setSelectionGeom (bool bSelectionflag)
virtual void | AcGiNonEntityTraits::setSelectionGeom (bool bSelectionflag)
virtual void | AcGiNonEntityTraits::setSelectionMarker (const Adesk::LongPtr markerId)
virtual Acad::ErrorStatus | AcGiSubEntityTraits::setShadowFlags (ShadowFlags flags)
virtual void | AcGiNonEntityTraits::setThickness (double thickness)
virtual void | AcGiNonEntityTraits::setTrueColor (const AcCmEntityColor &color)
virtual void | AcGiNonEntityTraits::setupForEntity (AcDbEntity *pEntity)
virtual void | AcGiSubEntityTraits::setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | AcGiSubEntityTraits::shadowFlags (void) const
virtual double | AcGiNonEntityTraits::thickness (void) const
virtual AcCmEntityColor | AcGiNonEntityTraits::trueColor (void) const
virtual AcDbObjectId | AcGiSubEntityTraits::visualStyle (void) const

Detailed Description

Function Documentation

void AcGiNonEntityTraits::addLight ( const AcDbObjectId & id )
inlinevirtual
Warning
Not implemented!

Reimplemented from AcGiDrawableTraits.

Adesk::UInt16 AcGiNonEntityTraits::color ( void ) const
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

AcGiFillType AcGiNonEntityTraits::fillType ( void ) const
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

AcDbObjectId AcGiNonEntityTraits::layerId ( void ) const
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

AcDbObjectId AcGiNonEntityTraits::lineTypeId ( void ) const
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

double AcGiNonEntityTraits::lineTypeScale ( void ) const
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

AcDb::LineWeight AcGiNonEntityTraits::lineWeight ( void ) const
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

AcDbObjectId AcGiNonEntityTraits::materialId ( void ) const
inlinevirtual
Warning
Not implemented!

Reimplemented from AcGiSubEntityTraits.

bool AcGiNonEntityTraits::selectionGeom ( void ) const
inlinevirtual
Warning
Not implemented!

Reimplemented from AcGiSubEntityTraits.

void AcGiNonEntityTraits::setColor ( const Adesk::UInt16 color )
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

void AcGiNonEntityTraits::setFillType ( const AcGiFillType fillType )
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

void AcGiNonEntityTraits::setLayer ( const AcDbObjectId layerId )
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

void AcGiNonEntityTraits::setLineType ( const AcDbObjectId linetypeId )
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

void AcGiNonEntityTraits::setLineTypeScale ( double dScale )
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

void AcGiNonEntityTraits::setLineWeight ( const AcDb::LineWeight lw )
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

void AcGiNonEntityTraits::setMaterial ( const AcDbObjectId matId )
inlinevirtual
Warning
Not implemented!

Reimplemented from AcGiSubEntityTraits.

void AcGiNonEntityTraits::setSelectionGeom ( bool bSelectionflag )
inlinevirtual
Warning
Not implemented!

Reimplemented from AcGiSubEntityTraits.

void AcGiNonEntityTraits::setSelectionMarker ( const Adesk::LongPtr markerId )
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

void AcGiNonEntityTraits::setThickness ( double thickness )
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

void AcGiNonEntityTraits::setTrueColor ( const AcCmEntityColor & color )
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

void AcGiNonEntityTraits::setupForEntity ( AcDbEntity * pEntity )
inlinevirtual
Warning
Not implemented!

Reimplemented from AcGiDrawableTraits.

double AcGiNonEntityTraits::thickness ( void ) const
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.

AcCmEntityColor AcGiNonEntityTraits::trueColor ( void ) const
inlinevirtual
Warning
Not implemented!

Implements AcGiSubEntityTraits.


ZRX API Reference: AcGiColorRGB Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
AcGiColorRGB Class Reference
AcGi Classes

Public Member Functions

AcGiColorRGB (double r, double g, double b)

Public Attributes

double | blue
double | green
double | red
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiColorRGB Member List

This is the complete list of members for AcGiColorRGB, including all inherited members.

AcGiColorRGB(void) (defined in AcGiColorRGB) | AcGiColorRGB | inline
AcGiColorRGB(double r, double g, double b) (defined in AcGiColorRGB) | AcGiColorRGB | inline
blue (defined in AcGiColorRGB) | AcGiColorRGB |
green (defined in AcGiColorRGB) | AcGiColorRGB |
red (defined in AcGiColorRGB) | AcGiColorRGB |


ZRX API Reference: AcGiColorRGBA Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
AcGiColorRGBA Class Reference
AcGi Classes

Public Member Functions

AcGiColorRGBA (double r, double g, double b, double a)

Public Attributes

double | alpha
double | blue
double | green
double | red
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiColorRGBA Member List

This is the complete list of members for AcGiColorRGBA, including all inherited members.

AcGiColorRGBA(void) (defined in AcGiColorRGBA) | AcGiColorRGBA | inline
AcGiColorRGBA(double r, double g, double b, double a) (defined in AcGiColorRGBA) | AcGiColorRGBA | inline
alpha (defined in AcGiColorRGBA) | AcGiColorRGBA |
blue (defined in AcGiColorRGBA) | AcGiColorRGBA |
green (defined in AcGiColorRGBA) | AcGiColorRGBA |
red (defined in AcGiColorRGBA) | AcGiColorRGBA |


ZRX API Reference: AcGiCommonDraw Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiCommonDraw Class Reference
AcGi Classes
+ Inheritance diagram for AcGiCommonDraw:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiCommonDraw)
virtual AcGiContext * | context ()=0
virtual double | deviation (const AcGiDeviationType, const AcGePoint3d &) const =0
virtual Adesk::Boolean | isDragging () const =0
virtual Adesk::UInt32 | numberOfIsolines () const =0
virtual AcGiGeometry * | rawGeometry () const =0
virtual Adesk::Boolean | regenAbort () const =0
virtual AcGiRegenType | regenType () const =0
virtual bool | secondaryCall () const
virtual AcGiSubEntityTraits & | subEntityTraits () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiCommonDraw Member List

This is the complete list of members for AcGiCommonDraw, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiCommonDraw) (defined in AcGiCommonDraw) | AcGiCommonDraw |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
context()=0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
deviation(const AcGiDeviationType, const AcGePoint3d &) const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isDragging() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
numberOfIsolines() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rawGeometry() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
regenAbort() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
regenType() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
secondaryCall() const (defined in AcGiCommonDraw) | AcGiCommonDraw | inlinevirtual
subEntityTraits() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiContext Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcGiContext Class Reference
AcGi Classes
+ Inheritance diagram for AcGiContext:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiContext)
virtual AcDb::LineWeight | byBlockLineWeight () const
virtual AcDbObjectId | byBlockMaterialId () const
virtual AcDbObjectId | byBlockPlotStyleNameId () const
virtual AcDbDatabase * | database () const =0
virtual void | disableFastMoveDrag () const
virtual AcCmEntityColor | effectiveColor () const
virtual const AcGiContextImp * | getConstImpPtr () const
virtual AcGiContextImp * | getImpPtr ()
virtual bool | isBoundaryClipping () const =0
virtual bool | isNesting () const
virtual Adesk::Boolean | isPlotGeneration () const =0
virtual Adesk::Boolean | isPsOut () const =0
virtual bool | supportsOwnerDraw ()
virtual bool | supportsTrueTypeText ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

virtual void | bypassHiddenLineRemoval ()
virtual int | drawTrueTypeText (const ACHAR *, double, int, bool, const TextParams &, unsigned int)
virtual int | getTrueTypeBoundingBox (AcGePoint3d const &location, const wchar_t *text, int length, TextParams const *tp, AcGePoint3d *bbox, float *char_widths)
virtual int | getTrueTypeTextExtents (ACHAR const *, unsigned int, double, int, int, int, short, short, double, double, AcGePoint2d &, AcGePoint2d &)
virtual Adesk::LongPtr | loadTrueTypeFont (const ACHAR *, bool, bool, int, int, FontInfo &)
virtual int | restoreTrueTypeTransform ()
virtual int | setTextStyle (int)
virtual int | setTrueTypeTransform (const AcGePoint3d &, const AcGeVector3d &, double, double, double, bool, bool)
virtual AcGiWorldSegmentCallback | wSegTaker () const

Friends

class | AcDbImpText
class | AcGiTextHook
class | CShFont

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiContext Member List

This is the complete list of members for AcGiContext, including all inherited members.

AcDbImpText (defined in AcGiContext) | AcGiContext | friend
AcGiTextHook (defined in AcGiContext) | AcGiContext | friend
ACRX_DECLARE_MEMBERS(AcGiContext) (defined in AcGiContext) | AcGiContext |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
byBlockLineWeight() const (defined in AcGiContext) | AcGiContext | inlinevirtual
byBlockMaterialId() const (defined in AcGiContext) | AcGiContext | inlinevirtual
byBlockPlotStyleNameId() const (defined in AcGiContext) | AcGiContext | inlinevirtual
bypassHiddenLineRemoval() (defined in AcGiContext) | AcGiContext | inlineprotectedvirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
CShFont (defined in AcGiContext) | AcGiContext | friend
database() const =0 (defined in AcGiContext) | AcGiContext | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableFastMoveDrag() const (defined in AcGiContext) | AcGiContext | inlinevirtual
drawTrueTypeText(const ACHAR *, double, int, bool, const TextParams &, unsigned int) (defined in AcGiContext) | AcGiContext | inlineprotectedvirtual
effectiveColor() const (defined in AcGiContext) | AcGiContext | inlinevirtual
getConstImpPtr() const (defined in AcGiContext) | AcGiContext | inlinevirtual
getImpPtr() (defined in AcGiContext) | AcGiContext | inlinevirtual
getTrueTypeBoundingBox(AcGePoint3d const &location, const wchar_t *text, int length, TextParams const *tp, AcGePoint3d *bbox, float *char_widths) (defined in AcGiContext) | AcGiContext | inlineprotectedvirtual
getTrueTypeTextExtents(ACHAR const *, unsigned int, double, int, int, int, short, short, double, double, AcGePoint2d &, AcGePoint2d &) (defined in AcGiContext) | AcGiContext | inlineprotectedvirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isBoundaryClipping() const =0 (defined in AcGiContext) | AcGiContext | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isNesting() const (defined in AcGiContext) | AcGiContext | inlinevirtual
isPlotGeneration() const =0 (defined in AcGiContext) | AcGiContext | pure virtual
isPsOut() const =0 (defined in AcGiContext) | AcGiContext | pure virtual
loadTrueTypeFont(const ACHAR *, bool, bool, int, int, FontInfo &) (defined in AcGiContext) | AcGiContext | inlineprotectedvirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
restoreTrueTypeTransform() (defined in AcGiContext) | AcGiContext | inlineprotectedvirtual
setTextStyle(int) (defined in AcGiContext) | AcGiContext | protectedvirtual
setTrueTypeTransform(const AcGePoint3d &, const AcGeVector3d &, double, double, double, bool, bool) (defined in AcGiContext) | AcGiContext | inlineprotectedvirtual
supportsOwnerDraw() (defined in AcGiContext) | AcGiContext | inlinevirtual
supportsTrueTypeText() (defined in AcGiContext) | AcGiContext | inlinevirtual
wSegTaker() const (defined in AcGiContext) | AcGiContext | inlineprotectedvirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiContextualColors Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiContextualColors Class Reference
AcGi Classes
+ Inheritance diagram for AcGiContextualColors:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiContextualColors)
virtual Adesk::UInt32 | cameraClipping () const =0
virtual Adesk::UInt32 | cameraFrustrum () const =0
virtual Adesk::UInt32 | cameraGlyphs () const =0
virtual bool | flagsSet (Adesk::UInt32 flg) const =0
virtual Adesk::UInt32 | gridAxisLines () const =0
virtual int | gridAxisLineTintXYZ () const =0
virtual Adesk::UInt32 | gridMajorLines () const =0
virtual int | gridMajorLineTintXYZ () const =0
virtual Adesk::UInt32 | gridMinorLines () const =0
virtual int | gridMinorLineTintXYZ () const =0
virtual Adesk::UInt32 | lightEndLimit () const =0
virtual Adesk::UInt32 | lightFalloff () const =0
virtual Adesk::UInt32 | lightGlyphs () const =0
virtual Adesk::UInt32 | lightHotspot () const =0
virtual Adesk::UInt32 | lightStartLimit () const =0
virtual void | setContextFlags (Adesk::UInt32 flg, bool set=true)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: AcGiContextualColors2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiContextualColors2 Class Reference
AcGi Classes
+ Inheritance diagram for AcGiContextualColors2:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiContextualColors2)
virtual AcCmColor | lightDistanceColor (void) const =0
virtual AcCmColor | lightShapeColor (void) const =0
virtual AcCmColor | webMeshColor (void) const =0
virtual AcCmColor | webMeshMissingColor (void) const =0
- Public Member Functions inherited from AcGiContextualColors
ACRX_DECLARE_MEMBERS (AcGiContextualColors)
virtual Adesk::UInt32 | cameraClipping () const =0
virtual Adesk::UInt32 | cameraFrustrum () const =0
virtual Adesk::UInt32 | cameraGlyphs () const =0
virtual bool | flagsSet (Adesk::UInt32 flg) const =0
virtual Adesk::UInt32 | gridAxisLines () const =0
virtual int | gridAxisLineTintXYZ () const =0
virtual Adesk::UInt32 | gridMajorLines () const =0
virtual int | gridMajorLineTintXYZ () const =0
virtual Adesk::UInt32 | gridMinorLines () const =0
virtual int | gridMinorLineTintXYZ () const =0
virtual Adesk::UInt32 | lightEndLimit () const =0
virtual Adesk::UInt32 | lightFalloff () const =0
virtual Adesk::UInt32 | lightGlyphs () const =0
virtual Adesk::UInt32 | lightHotspot () const =0
virtual Adesk::UInt32 | lightStartLimit () const =0
virtual void | setContextFlags (Adesk::UInt32 flg, bool set=true)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiContextualColors2 Member List

This is the complete list of members for AcGiContextualColors2, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiContextualColors2) (defined in AcGiContextualColors2) | AcGiContextualColors2 |
ACRX_DECLARE_MEMBERS(AcGiContextualColors) (defined in AcGiContextualColors) | AcGiContextualColors |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cameraClipping() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
cameraFrustrum() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
cameraGlyphs() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
flagsSet(Adesk::UInt32 flg) const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridAxisLines() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridAxisLineTintXYZ() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridMajorLines() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridMajorLineTintXYZ() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridMinorLines() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridMinorLineTintXYZ() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
lightDistanceColor(void) const =0 (defined in AcGiContextualColors2) | AcGiContextualColors2 | pure virtual
lightEndLimit() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
lightFalloff() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
lightGlyphs() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
lightHotspot() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
lightShapeColor(void) const =0 (defined in AcGiContextualColors2) | AcGiContextualColors2 | pure virtual
lightStartLimit() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setContextFlags(Adesk::UInt32 flg, bool set=true)=0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
webMeshColor(void) const =0 (defined in AcGiContextualColors2) | AcGiContextualColors2 | pure virtual
webMeshMissingColor(void) const =0 (defined in AcGiContextualColors2) | AcGiContextualColors2 | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiDisplayStyle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiDisplayStyle Class Reference
AcGi Classes
+ Inheritance diagram for AcGiDisplayStyle:

Public Types

enum DisplaySettings {
kNone = 0, kBackgrounds = 1, kLighting = 2, kMaterials = 4,
kTextures = 8
}
enum ShadowType { kShadowsNone, kShadowsGroundPlane, kShadowsFull, kShadowsFullAndGround }

Public Member Functions

AcGiDisplayStyle (void)
AcGiDisplayStyle (const AcGiDisplayStyle &style)
ACRX_DECLARE_MEMBERS (AcGiDisplayStyle)
virtual double | brightness (void) const
virtual unsigned long | displaySettings (void) const
virtual bool | isDisplaySettingsFlagSet (DisplaySettings flag) const
virtual AcGiDisplayStyle & | operator= (const AcGiDisplayStyle &style)
virtual bool | operator== (const AcGiDisplayStyle &style) const
virtual void | set (const AcGiDisplayStyle &style)
virtual void | setBrightness (double value)
virtual void | setDisplaySettings (unsigned long nSettings)
virtual void | setDisplaySettingsFlag (DisplaySettings flag, bool bEnable)
virtual void | setShadowType (ShadowType type)
virtual ShadowType | shadowType (void) const
virtual | ~AcGiDisplayStyle (void)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiDisplayStyle::AcGiDisplayStyle ( void )
Warning
Not implemented!
AcGiDisplayStyle::AcGiDisplayStyle ( const AcGiDisplayStyle & style )
Warning
Not implemented!
virtual AcGiDisplayStyle::~AcGiDisplayStyle ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual double AcGiDisplayStyle::brightness ( void ) const
virtual
Warning
Not implemented!
virtual unsigned long AcGiDisplayStyle::displaySettings ( void ) const
virtual
Warning
Not implemented!
virtual bool AcGiDisplayStyle::isDisplaySettingsFlagSet ( DisplaySettings flag ) const
virtual
Warning
Not implemented!
virtual AcGiDisplayStyle& AcGiDisplayStyle::operator= ( const AcGiDisplayStyle & style )
virtual
Warning
Not implemented!
virtual bool AcGiDisplayStyle::operator== ( const AcGiDisplayStyle & style ) const
virtual
Warning
Not implemented!
virtual void AcGiDisplayStyle::set ( const AcGiDisplayStyle & style )
virtual
Warning
Not implemented!
virtual void AcGiDisplayStyle::setBrightness ( double value )
virtual
Warning
Not implemented!
virtual void AcGiDisplayStyle::setDisplaySettings ( unsigned long nSettings )
virtual
Warning
Not implemented!
virtual void AcGiDisplayStyle::setDisplaySettingsFlag | ( | DisplaySettings | flag,
 |  | bool | bEnable
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiDisplayStyle::setShadowType ( ShadowType type )
virtual
Warning
Not implemented!
virtual ShadowType AcGiDisplayStyle::shadowType ( void ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgivisualstyle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiDisplayStyle Member List

This is the complete list of members for AcGiDisplayStyle, including all inherited members.

AcGiDisplayStyle(void) | AcGiDisplayStyle |
AcGiDisplayStyle(const AcGiDisplayStyle &style) | AcGiDisplayStyle |
ACRX_DECLARE_MEMBERS(AcGiDisplayStyle) (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
brightness(void) const | AcGiDisplayStyle | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
displaySettings(void) const | AcGiDisplayStyle | virtual
DisplaySettings enum name (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isDisplaySettingsFlagSet(DisplaySettings flag) const | AcGiDisplayStyle | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kBackgrounds enum value (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
kLighting enum value (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
kMaterials enum value (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
kNone enum value (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
kShadowsFull enum value (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
kShadowsFullAndGround enum value (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
kShadowsGroundPlane enum value (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
kShadowsNone enum value (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
kTextures enum value (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
operator=(const AcGiDisplayStyle &style) | AcGiDisplayStyle | virtual
operator==(const AcGiDisplayStyle &style) const | AcGiDisplayStyle | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
set(const AcGiDisplayStyle &style) | AcGiDisplayStyle | virtual
setBrightness(double value) | AcGiDisplayStyle | virtual
setDisplaySettings(unsigned long nSettings) | AcGiDisplayStyle | virtual
setDisplaySettingsFlag(DisplaySettings flag, bool bEnable) | AcGiDisplayStyle | virtual
setShadowType(ShadowType type) | AcGiDisplayStyle | virtual
ShadowType enum name (defined in AcGiDisplayStyle) | AcGiDisplayStyle |
shadowType(void) const | AcGiDisplayStyle | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiDisplayStyle(void) | AcGiDisplayStyle | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiDistantLightTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiDistantLightTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiDistantLightTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiDistantLightTraits)
virtual bool | isSunlight () const =0
virtual AcGeVector3d | lightDirection () const =0
virtual void | setIsSunlight (bool isSunlight)=0
virtual void | setLightDirection (const AcGeVector3d &vec)=0
- Public Member Functions inherited from AcGiStandardLightTraits
ACRX_DECLARE_MEMBERS (AcGiStandardLightTraits)
virtual double | intensity () const =0
virtual AcCmColor | lightColor () const =0
virtual void | setIntensity (double inten)=0
virtual void | setLightColor (const AcCmColor &color)=0
virtual void | setShadowParameters (const AcGiShadowParameters &params)=0
virtual void | shadowParameters (AcGiShadowParameters &params) const =0
- Public Member Functions inherited from AcGiLightTraits
ACRX_DECLARE_MEMBERS (AcGiLightTraits)
virtual bool | isOn () const =0
virtual void | setOn (bool on)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: AcGiDistantLightTraits2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiDistantLightTraits2 Class Reference
AcGi Classes
+ Inheritance diagram for AcGiDistantLightTraits2:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiDistantLightTraits2)
virtual void | lampColor (AcGiColorRGB &rgbColor) const =0
virtual double | physicalIntensity () const =0
virtual void | setLampColor (const AcGiColorRGB &rgbColor)=0
virtual void | setPhysicalIntensity (double physicalIntensity)=0
virtual void | setShadowParameters (const AcGiShadowParameters2 &params)=0
virtual void | setSkyParameters (const AcGiSkyParameters &params)=0
virtual void | shadowParameters (AcGiShadowParameters2 &params) const =0
virtual void | skyParameters (AcGiSkyParameters &params) const =0
- Public Member Functions inherited from AcGiDistantLightTraits
ACRX_DECLARE_MEMBERS (AcGiDistantLightTraits)
virtual bool | isSunlight () const =0
virtual AcGeVector3d | lightDirection () const =0
virtual void | setIsSunlight (bool isSunlight)=0
virtual void | setLightDirection (const AcGeVector3d &vec)=0
- Public Member Functions inherited from AcGiStandardLightTraits
ACRX_DECLARE_MEMBERS (AcGiStandardLightTraits)
virtual double | intensity () const =0
virtual AcCmColor | lightColor () const =0
virtual void | setIntensity (double inten)=0
virtual void | setLightColor (const AcCmColor &color)=0
virtual void | setShadowParameters (const AcGiShadowParameters &params)=0
virtual void | shadowParameters (AcGiShadowParameters &params) const =0
- Public Member Functions inherited from AcGiLightTraits
ACRX_DECLARE_MEMBERS (AcGiLightTraits)
virtual bool | isOn () const =0
virtual void | setOn (bool on)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiDistantLightTraits2 Member List

This is the complete list of members for AcGiDistantLightTraits2, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiDistantLightTraits2) (defined in AcGiDistantLightTraits2) | AcGiDistantLightTraits2 |
ACRX_DECLARE_MEMBERS(AcGiDistantLightTraits) (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits |
ACRX_DECLARE_MEMBERS(AcGiStandardLightTraits) (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits |
ACRX_DECLARE_MEMBERS(AcGiLightTraits) (defined in AcGiLightTraits) | AcGiLightTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
intensity() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOn() const =0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
isSunlight() const =0 (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits | pure virtual
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
lampColor(AcGiColorRGB &rgbColor) const =0 (defined in AcGiDistantLightTraits2) | AcGiDistantLightTraits2 | pure virtual
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightColor() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
lightDirection() const =0 (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
physicalIntensity() const =0 (defined in AcGiDistantLightTraits2) | AcGiDistantLightTraits2 | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setIntensity(double inten)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setIsSunlight(bool isSunlight)=0 (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits | pure virtual
setLampColor(const AcGiColorRGB &rgbColor)=0 (defined in AcGiDistantLightTraits2) | AcGiDistantLightTraits2 | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightColor(const AcCmColor &color)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLightDirection(const AcGeVector3d &vec)=0 (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setOn(bool on)=0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
setPhysicalIntensity(double physicalIntensity)=0 (defined in AcGiDistantLightTraits2) | AcGiDistantLightTraits2 | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowParameters(const AcGiShadowParameters2 &params)=0 (defined in AcGiDistantLightTraits2) | AcGiDistantLightTraits2 | pure virtual
setShadowParameters(const AcGiShadowParameters &params)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setSkyParameters(const AcGiSkyParameters &params)=0 (defined in AcGiDistantLightTraits2) | AcGiDistantLightTraits2 | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowParameters(AcGiShadowParameters2 &params) const =0 (defined in AcGiDistantLightTraits2) | AcGiDistantLightTraits2 | pure virtual
shadowParameters(AcGiShadowParameters &params) const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
skyParameters(AcGiSkyParameters &params) const =0 (defined in AcGiDistantLightTraits2) | AcGiDistantLightTraits2 | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiDrawable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiDrawable Class Reference
AcGi Classes
+ Inheritance diagram for AcGiDrawable:

Public Types

enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual AcGsNode * | gsNode (void) const =0
virtual AcDbObjectId | id (void) const =0
virtual Adesk::Boolean | isPersistent (void) const =0
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *traits)=0
virtual void | setGsNode (AcGsNode *gsnode)=0
virtual void | viewportDraw (AcGiViewportDraw *vd)=0
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *wd)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • drawable.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiDrawable Member List

This is the complete list of members for AcGiDrawable, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
gsNode(void) const =0 (defined in AcGiDrawable) | AcGiDrawable | pure virtual
id(void) const =0 (defined in AcGiDrawable) | AcGiDrawable | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isPersistent(void) const =0 (defined in AcGiDrawable) | AcGiDrawable | pure virtual
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAttributes(AcGiDrawableTraits *traits)=0 (defined in AcGiDrawable) | AcGiDrawable | pure virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setGsNode(AcGsNode *gsnode)=0 (defined in AcGiDrawable) | AcGiDrawable | pure virtual
viewportDraw(AcGiViewportDraw *vd)=0 (defined in AcGiDrawable) | AcGiDrawable | pure virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
worldDraw(AcGiWorldDraw *wd)=0 (defined in AcGiDrawable) | AcGiDrawable | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiDrawableTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Types | Protected Member Functions | Friends | List of all members
AcGiDrawableTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiDrawableTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
virtual void | addLight (const AcDbObjectId &lightId)
virtual void | setupForEntity (AcDbEntity *pEntity)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt16 | color (void) const =0
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcGiFillType | fillType (void) const =0
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual AcDbObjectId | layerId (void) const =0
virtual AcDbObjectId | lineTypeId (void) const =0
virtual double | lineTypeScale (void) const =0
virtual AcDb::LineWeight | lineWeight (void) const =0
virtual const AcGiMapper * | mapper (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | sectionable (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)=0
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setFillType (const AcGiFillType)=0
virtual void | setLayer (const AcDbObjectId layerId)=0
virtual void | setLineType (const AcDbObjectId linetypeId)=0
virtual void | setLineTypeScale (double dScale=1.0)=0
virtual void | setLineWeight (const AcDb::LineWeight lw)=0
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setMaterial (const AcDbObjectId materialId)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)=0
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setThickness (double dThickness)=0
virtual void | setTrueColor (const AcCmEntityColor &color)=0
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual double | thickness (void) const =0
virtual AcCmEntityColor | trueColor (void) const =0
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Types

enum LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }

Protected Member Functions

virtual void setLayerFlags (Adesk::UInt8 flags)

Friends

class AcDbLayerTableRecord

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiDrawableTraits Member List

This is the complete list of members for AcGiDrawableTraits, including all inherited members.

AcDbLayerTableRecord (defined in AcGiDrawableTraits) | AcGiDrawableTraits | friend
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &lightId) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeScale(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineWeight(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLayer(const AcDbObjectId layerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineTypeScale(double dScale=1.0)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineWeight(const AcDb::LineWeight lw)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId materialId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double dThickness)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setTrueColor(const AcCmEntityColor &color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setupForEntity(AcDbEntity *pEntity) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | virtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
thickness(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
trueColor(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiEdgeData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiEdgeData Class Reference
AcGi Classes
+ Inheritance diagram for AcGiEdgeData:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiEdgeData)
virtual short * | colors () const
virtual AcDbObjectId * | layerIds () const
virtual AcDbObjectId * | linetypeIds () const
virtual Adesk::LongPtr * | selectionMarkers () const
virtual void | setColors (const short *colors)
virtual void | setLayers (const AcDbObjectId *layers)
virtual void | setLineTypes (const AcDbObjectId *linetypes)
virtual void | setSelectionMarkers (const Adesk::LongPtr *pSelectionMarkers)
virtual void | setTrueColors (const AcCmEntityColor *colors)
virtual void | setVisibility (const Adesk::UInt8 *pVisibility)
virtual AcCmEntityColor * | trueColors () const
virtual Adesk::UInt8 * | visibility () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiEdgeData Member List

This is the complete list of members for AcGiEdgeData, including all inherited members.

AcGiEdgeData() (defined in AcGiEdgeData) | AcGiEdgeData |
ACRX_DECLARE_MEMBERS(AcGiEdgeData) (defined in AcGiEdgeData) | AcGiEdgeData |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
colors() const (defined in AcGiEdgeData) | AcGiEdgeData | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
layerIds() const (defined in AcGiEdgeData) | AcGiEdgeData | virtual
linetypeIds() const (defined in AcGiEdgeData) | AcGiEdgeData | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
selectionMarkers() const (defined in AcGiEdgeData) | AcGiEdgeData | virtual
setColors(const short *colors) (defined in AcGiEdgeData) | AcGiEdgeData | virtual
setLayers(const AcDbObjectId *layers) (defined in AcGiEdgeData) | AcGiEdgeData | virtual
setLineTypes(const AcDbObjectId *linetypes) (defined in AcGiEdgeData) | AcGiEdgeData | virtual
setSelectionMarkers(const Adesk::LongPtr *pSelectionMarkers) (defined in AcGiEdgeData) | AcGiEdgeData | virtual
setTrueColors(const AcCmEntityColor *colors) (defined in AcGiEdgeData) | AcGiEdgeData | virtual
setVisibility(const Adesk::UInt8 *pVisibility) (defined in AcGiEdgeData) | AcGiEdgeData | virtual
trueColors() const (defined in AcGiEdgeData) | AcGiEdgeData | virtual
visibility() const (defined in AcGiEdgeData) | AcGiEdgeData | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiEdgeData() (defined in AcGiEdgeData) | AcGiEdgeData |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiEdgeStyle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiEdgeStyle Class Reference
AcGi Classes
+ Inheritance diagram for AcGiEdgeStyle:

Public Types

enum | EdgeModel { kNoEdges, kIsolines, kFacetEdges }
enum EdgeModifier {
kNoEdgeModifiers = 0, kOverhang = 1, kJitter = 2, kWidth = 4,
kColor = 8, kHaloGap = 16, kAlwaysOnTop = 64, kOpacity = 128,
kWiggle = 0x100, kTexture = 0x200
}
enum EdgeStyle {
kNoEdgeStyle = 0, kVisible = 1, kSilhouette = 2, kObscured = 4,
kIntersection = 8
}
enum | EdgeStyleApply { kDefault, kAll }
enum | JitterAmount { kJitterLow = 1, kJitterMedium, kJitterHigh }
enum Linetype {
kSolid = 1, kDashed, kDotted, kShortDash,
kMediumDash, kLongDash, kDoubleShortDash, kDoubleMediumDash,
kDoubleLongDash, kMediumLongDash, kSparseDot
}
enum | WiggleAmount { kWiggleLow = 1, kWiggleMedium = 2, kWiggleHigh = 3 }

Public Member Functions

AcGiEdgeStyle (void)
AcGiEdgeStyle (const AcGiEdgeStyle &style)
ACRX_DECLARE_MEMBERS (AcGiEdgeStyle)
virtual double | creaseAngle (void) const
virtual const AcCmColor & | edgeColor (void) const
virtual AcCmColor & | edgeColor (void)
virtual EdgeModel | edgeModel (void) const
virtual unsigned long | edgeModifiers (void) const
virtual EdgeStyleApply | edgeStyleApply (void) const
virtual unsigned long | edgeStyles (void) const
virtual int | edgeWidth (void) const
virtual int | haloGap (void) const
virtual bool | hidePrecision (void) const
virtual const AcCmColor & | intersectionColor (void) const
virtual AcCmColor & | intersectionColor (void)
virtual Linetype | intersectionLinetype (void) const
virtual bool | isEdgeModifierFlagSet (EdgeModifier flag) const
virtual bool | isEdgeStyleFlagSet (EdgeStyle flag) const
virtual unsigned short | isolines (void) const
virtual JitterAmount | jitterAmount (void) const
virtual const AcCmColor & | obscuredColor (void) const
virtual AcCmColor & | obscuredColor (void)
virtual Linetype | obscuredLinetype (void) const
virtual double | opacityLevel (void) const
virtual AcGiEdgeStyle & | operator= (const AcGiEdgeStyle &style)
virtual bool | operator== (const AcGiEdgeStyle &style) const
virtual int | overhangAmount (void) const
virtual void | set (const AcGiEdgeStyle &style)
virtual void | setCreaseAngle (double nAngle)
virtual void | setEdgeColor (const AcCmColor &color, bool bEnableModifier)
virtual void | setEdgeModel (EdgeModel model)
virtual void | setEdgeModifierFlag (EdgeModifier flag, bool bEnable)
virtual void | setEdgeModifiers (unsigned long nModifiers)
virtual void | setEdgeStyleApply (EdgeStyleApply apply)
virtual void | setEdgeStyleFlag (EdgeStyle flag, bool bEnable)
virtual void | setEdgeStyles (unsigned long nStyles)
virtual void | setEdgeWidth (int nWidth, bool bEnableModifier)
virtual void | setHaloGap (int nHaloGap, bool bEnableModifier)
virtual void | setHidePrecision (bool bHidePrecision)
virtual void | setIntersectionColor (const AcCmColor &color)
virtual void | setIntersectionLinetype (Linetype ltype)
virtual void | setIsolines (unsigned short nIsolines)
virtual void | setJitterAmount (JitterAmount amount, bool bEnableModifier)
virtual void | setObscuredColor (const AcCmColor &color)
virtual void | setObscuredLinetype (Linetype ltype)
virtual void | setOpacityLevel (double nLevel, bool bEnableModifier)
virtual void | setOverhangAmount (int nAmount, bool bEnableModifier)
virtual void | setSilhouetteColor (const AcCmColor &color)
virtual void | setSilhouetteWidth (short nWidth)
virtual void | setWiggleAmount (WiggleAmount amount, bool bEnableModifier)
virtual const AcCmColor & | silhouetteColor (void) const
virtual AcCmColor & | silhouetteColor (void)
virtual short | silhouetteWidth (void) const
virtual WiggleAmount | wiggleAmount () const
virtual | ~AcGiEdgeStyle (void)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiEdgeStyle::AcGiEdgeStyle ( void )
Warning
Not implemented!
AcGiEdgeStyle::AcGiEdgeStyle ( const AcGiEdgeStyle & style )
Warning
Not implemented!
virtual AcGiEdgeStyle::~AcGiEdgeStyle ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual double AcGiEdgeStyle::creaseAngle ( void ) const
virtual
Warning
Not implemented!
virtual const AcCmColor& AcGiEdgeStyle::edgeColor ( void ) const
virtual
Warning
Not implemented!
virtual AcCmColor& AcGiEdgeStyle::edgeColor ( void )
virtual
Warning
Not implemented!
virtual EdgeModel AcGiEdgeStyle::edgeModel ( void ) const
virtual
Warning
Not implemented!
virtual unsigned long AcGiEdgeStyle::edgeModifiers ( void ) const
virtual
Warning
Not implemented!
virtual EdgeStyleApply AcGiEdgeStyle::edgeStyleApply ( void ) const
virtual
Warning
Not implemented!
virtual unsigned long AcGiEdgeStyle::edgeStyles ( void ) const
virtual
Warning
Not implemented!
virtual int AcGiEdgeStyle::edgeWidth ( void ) const
virtual
Warning
Not implemented!
virtual int AcGiEdgeStyle::haloGap ( void ) const
virtual
Warning
Not implemented!
virtual bool AcGiEdgeStyle::hidePrecision ( void ) const
virtual
Warning
Not implemented!
virtual const AcCmColor& AcGiEdgeStyle::intersectionColor ( void ) const
virtual
Warning
Not implemented!
virtual AcCmColor& AcGiEdgeStyle::intersectionColor ( void )
virtual
Warning
Not implemented!
virtual Linetype AcGiEdgeStyle::intersectionLinetype ( void ) const
virtual
Warning
Not implemented!
virtual bool AcGiEdgeStyle::isEdgeModifierFlagSet ( EdgeModifier flag ) const
virtual
Warning
Not implemented!
virtual bool AcGiEdgeStyle::isEdgeStyleFlagSet ( EdgeStyle flag ) const
virtual
Warning
Not implemented!
virtual unsigned short AcGiEdgeStyle::isolines ( void ) const
virtual
Warning
Not implemented!
virtual JitterAmount AcGiEdgeStyle::jitterAmount ( void ) const
virtual
Warning
Not implemented!
virtual const AcCmColor& AcGiEdgeStyle::obscuredColor ( void ) const
virtual
Warning
Not implemented!
virtual AcCmColor& AcGiEdgeStyle::obscuredColor ( void )
virtual
Warning
Not implemented!
virtual Linetype AcGiEdgeStyle::obscuredLinetype ( void ) const
virtual
Warning
Not implemented!
virtual double AcGiEdgeStyle::opacityLevel ( void ) const
virtual
Warning
Not implemented!
virtual AcGiEdgeStyle& AcGiEdgeStyle::operator= ( const AcGiEdgeStyle & style )
virtual
Warning
Not implemented!
virtual bool AcGiEdgeStyle::operator== ( const AcGiEdgeStyle & style ) const
virtual
Warning
Not implemented!
virtual int AcGiEdgeStyle::overhangAmount ( void ) const
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::set ( const AcGiEdgeStyle & style )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setCreaseAngle ( double nAngle )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setEdgeColor | ( | const AcCmColor & | color,
 |  | bool | bEnableModifier
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setEdgeModel ( EdgeModel model )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setEdgeModifierFlag | ( | EdgeModifier | flag,
 |  | bool | bEnable
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setEdgeModifiers ( unsigned long nModifiers )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setEdgeStyleApply ( EdgeStyleApply apply )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setEdgeStyleFlag | ( | EdgeStyle | flag,
 |  | bool | bEnable
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setEdgeStyles ( unsigned long nStyles )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setEdgeWidth | ( | int | nWidth,
 |  | bool | bEnableModifier
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setHaloGap | ( | int | nHaloGap,
 |  | bool | bEnableModifier
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setHidePrecision ( bool bHidePrecision )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setIntersectionColor ( const AcCmColor & color )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setIntersectionLinetype ( Linetype ltype )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setIsolines ( unsigned short nIsolines )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setJitterAmount | ( | JitterAmount | amount,
 |  | bool | bEnableModifier
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setObscuredColor ( const AcCmColor & color )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setObscuredLinetype ( Linetype ltype )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setOpacityLevel | ( | double | nLevel,
 |  | bool | bEnableModifier
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setOverhangAmount | ( | int | nAmount,
 |  | bool | bEnableModifier
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setSilhouetteColor ( const AcCmColor & color )
virtual
Warning
Not implemented!
virtual void AcGiEdgeStyle::setSilhouetteWidth ( short nWidth )
virtual
Warning
Not implemented!
virtual const AcCmColor& AcGiEdgeStyle::silhouetteColor ( void ) const
virtual
Warning
Not implemented!
virtual AcCmColor& AcGiEdgeStyle::silhouetteColor ( void )
virtual
Warning
Not implemented!
virtual short AcGiEdgeStyle::silhouetteWidth ( void ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgivisualstyle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiEdgeStyle Member List

This is the complete list of members for AcGiEdgeStyle, including all inherited members.

AcGiEdgeStyle(void) | AcGiEdgeStyle |
AcGiEdgeStyle(const AcGiEdgeStyle &style) | AcGiEdgeStyle |
ACRX_DECLARE_MEMBERS(AcGiEdgeStyle) (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
creaseAngle(void) const | AcGiEdgeStyle | virtual
desc() (defined in AcRxObject) | AcRxObject | static
edgeColor(void) const | AcGiEdgeStyle | virtual
edgeColor(void) | AcGiEdgeStyle | virtual
EdgeModel enum name (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
edgeModel(void) const | AcGiEdgeStyle | virtual
EdgeModifier enum name (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
edgeModifiers(void) const | AcGiEdgeStyle | virtual
EdgeStyle enum name (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
edgeStyleApply(void) const | AcGiEdgeStyle | virtual
EdgeStyleApply enum name (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
edgeStyles(void) const | AcGiEdgeStyle | virtual
edgeWidth(void) const | AcGiEdgeStyle | virtual
haloGap(void) const | AcGiEdgeStyle | virtual
hidePrecision(void) const | AcGiEdgeStyle | virtual
intersectionColor(void) const | AcGiEdgeStyle | virtual
intersectionColor(void) | AcGiEdgeStyle | virtual
intersectionLinetype(void) const | AcGiEdgeStyle | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEdgeModifierFlagSet(EdgeModifier flag) const | AcGiEdgeStyle | virtual
isEdgeStyleFlagSet(EdgeStyle flag) const | AcGiEdgeStyle | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isolines(void) const | AcGiEdgeStyle | virtual
JitterAmount enum name (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
jitterAmount(void) const | AcGiEdgeStyle | virtual
kAll enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kAlwaysOnTop enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kColor enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kDashed enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kDefault enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kDotted enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kDoubleLongDash enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kDoubleMediumDash enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kDoubleShortDash enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kFacetEdges enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kHaloGap enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kIntersection enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kIsolines enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kJitter enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kJitterHigh enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kJitterLow enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kJitterMedium enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kLongDash enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kMediumDash enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kMediumLongDash enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kNoEdgeModifiers enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kNoEdges enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kNoEdgeStyle enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kObscured enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kOpacity enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kOverhang enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kShortDash enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kSilhouette enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kSolid enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kSparseDot enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kTexture enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kVisible enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kWidth enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kWiggle enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kWiggleHigh enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kWiggleLow enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
kWiggleMedium enum value (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
Linetype enum name (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
obscuredColor(void) const | AcGiEdgeStyle | virtual
obscuredColor(void) | AcGiEdgeStyle | virtual
obscuredLinetype(void) const | AcGiEdgeStyle | virtual
opacityLevel(void) const | AcGiEdgeStyle | virtual
operator=(const AcGiEdgeStyle &style) | AcGiEdgeStyle | virtual
operator==(const AcGiEdgeStyle &style) const | AcGiEdgeStyle | virtual
overhangAmount(void) const | AcGiEdgeStyle | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
set(const AcGiEdgeStyle &style) | AcGiEdgeStyle | virtual
setCreaseAngle(double nAngle) | AcGiEdgeStyle | virtual
setEdgeColor(const AcCmColor &color, bool bEnableModifier) | AcGiEdgeStyle | virtual
setEdgeModel(EdgeModel model) | AcGiEdgeStyle | virtual
setEdgeModifierFlag(EdgeModifier flag, bool bEnable) | AcGiEdgeStyle | virtual
setEdgeModifiers(unsigned long nModifiers) | AcGiEdgeStyle | virtual
setEdgeStyleApply(EdgeStyleApply apply) | AcGiEdgeStyle | virtual
setEdgeStyleFlag(EdgeStyle flag, bool bEnable) | AcGiEdgeStyle | virtual
setEdgeStyles(unsigned long nStyles) | AcGiEdgeStyle | virtual
setEdgeWidth(int nWidth, bool bEnableModifier) | AcGiEdgeStyle | virtual
setHaloGap(int nHaloGap, bool bEnableModifier) | AcGiEdgeStyle | virtual
setHidePrecision(bool bHidePrecision) | AcGiEdgeStyle | virtual
setIntersectionColor(const AcCmColor &color) | AcGiEdgeStyle | virtual
setIntersectionLinetype(Linetype ltype) | AcGiEdgeStyle | virtual
setIsolines(unsigned short nIsolines) | AcGiEdgeStyle | virtual
setJitterAmount(JitterAmount amount, bool bEnableModifier) | AcGiEdgeStyle | virtual
setObscuredColor(const AcCmColor &color) | AcGiEdgeStyle | virtual
setObscuredLinetype(Linetype ltype) | AcGiEdgeStyle | virtual
setOpacityLevel(double nLevel, bool bEnableModifier) | AcGiEdgeStyle | virtual
setOverhangAmount(int nAmount, bool bEnableModifier) | AcGiEdgeStyle | virtual
setSilhouetteColor(const AcCmColor &color) | AcGiEdgeStyle | virtual
setSilhouetteWidth(short nWidth) | AcGiEdgeStyle | virtual
setWiggleAmount(WiggleAmount amount, bool bEnableModifier) (defined in AcGiEdgeStyle) | AcGiEdgeStyle | virtual
silhouetteColor(void) const | AcGiEdgeStyle | virtual
silhouetteColor(void) | AcGiEdgeStyle | virtual
silhouetteWidth(void) const | AcGiEdgeStyle | virtual
wiggleAmount() const (defined in AcGiEdgeStyle) | AcGiEdgeStyle | virtual
WiggleAmount enum name (defined in AcGiEdgeStyle) | AcGiEdgeStyle |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiEdgeStyle(void) | AcGiEdgeStyle | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiFaceData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiFaceData Class Reference
AcGi Classes
+ Inheritance diagram for AcGiFaceData:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiFaceData)
virtual short * | colors () const
virtual AcDbObjectId * | layerIds () const
virtual AcGiMapper * | mappers () const
virtual AcDbObjectId * | materials () const
virtual AcGeVector3d * | normals () const
virtual Adesk::LongPtr * | selectionMarkers () const
virtual void | setColors (const short *colors)
virtual void | setLayers (const AcDbObjectId *layers)
virtual void | setMappers (const AcGiMapper *mappers)
virtual void | setMaterials (const AcDbObjectId *materials)
virtual void | setNormals (const AcGeVector3d *pNormals)
virtual void | setSelectionMarkers (const Adesk::LongPtr *pSelectionMarkers)
virtual void | setTrueColors (const AcCmEntityColor *colors)
virtual void | setVisibility (const Adesk::UInt8 *vis)
virtual AcCmEntityColor * | trueColors () const
virtual Adesk::UInt8 * | visibility () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Member Function Documentation

virtual AcGiMapper* AcGiFaceData::mappers ( ) const
virtual
Warning
Not implemented!
virtual AcDbObjectId* AcGiFaceData::materials ( ) const
virtual
Warning
Not implemented!
virtual void AcGiFaceData::setMappers ( const AcGiMapper * mappers )
virtual
Warning
Not implemented!
virtual void AcGiFaceData::setMaterials ( const AcDbObjectId * materials )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiFaceData Member List

This is the complete list of members for AcGiFaceData, including all inherited members.

AcGiFaceData() (defined in AcGiFaceData) | AcGiFaceData |
ACRX_DECLARE_MEMBERS(AcGiFaceData) (defined in AcGiFaceData) | AcGiFaceData |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
colors() const (defined in AcGiFaceData) | AcGiFaceData | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
layerIds() const (defined in AcGiFaceData) | AcGiFaceData | virtual
mappers() const | AcGiFaceData | virtual
materials() const | AcGiFaceData | virtual
normals() const (defined in AcGiFaceData) | AcGiFaceData | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
selectionMarkers() const (defined in AcGiFaceData) | AcGiFaceData | virtual
setColors(const short *colors) (defined in AcGiFaceData) | AcGiFaceData | virtual
setLayers(const AcDbObjectId *layers) (defined in AcGiFaceData) | AcGiFaceData | virtual
setMappers(const AcGiMapper *mappers) | AcGiFaceData | virtual
setMaterials(const AcDbObjectId *materials) | AcGiFaceData | virtual
setNormals(const AcGeVector3d *pNormals) (defined in AcGiFaceData) | AcGiFaceData | virtual
setSelectionMarkers(const Adesk::LongPtr *pSelectionMarkers) (defined in AcGiFaceData) | AcGiFaceData | virtual
setTrueColors(const AcCmEntityColor *colors) (defined in AcGiFaceData) | AcGiFaceData | virtual
setVisibility(const Adesk::UInt8 *vis) (defined in AcGiFaceData) | AcGiFaceData | virtual
trueColors() const (defined in AcGiFaceData) | AcGiFaceData | virtual
visibility() const (defined in AcGiFaceData) | AcGiFaceData | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiFaceData() (defined in AcGiFaceData) | AcGiFaceData |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiFaceStyle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiFaceStyle Class Reference
AcGi Classes
+ Inheritance diagram for AcGiFaceStyle:

Public Types

enum FaceColorMode {
kNoColorMode, kObjectColor, kBackgroundColor, kMono,
kTint, kDesaturate
}
enum | FaceModifier { kNoFaceModifiers = 0, kOpacity = 1, kSpecular = 2 }
enum | LightingModel { kInvisible, kConstant, kPhong, kGooch }
enum | LightingQuality { kNoLighting, kPerFaceLighting, kPerVertexLighting, kPerPixelLighting }

Public Member Functions

AcGiFaceStyle (void)
AcGiFaceStyle (const AcGiFaceStyle &style)
ACRX_DECLARE_MEMBERS (AcGiFaceStyle)
virtual FaceColorMode | faceColorMode (void) const
virtual unsigned long | faceModifiers (void) const
virtual bool | isFaceModifierFlagSet (FaceModifier flag) const
virtual LightingModel | lightingModel (void) const
virtual LightingQuality | lightingQuality (void) const
virtual const AcCmColor & | monoColor (void) const
virtual AcCmColor & | monoColor (void)
virtual double | opacityLevel (void) const
virtual AcGiFaceStyle & | operator= (const AcGiFaceStyle &style)
virtual bool | operator== (const AcGiFaceStyle &style) const
virtual void | set (const AcGiFaceStyle &style)
virtual void | setFaceColorMode (FaceColorMode mode)
virtual void | setFaceModifierFlag (FaceModifier flag, bool bEnable)
virtual void | setFaceModifiers (unsigned long nModifiers)
virtual void | setLightingModel (LightingModel lightingModel)
virtual void | setLightingQuality (LightingQuality lightingQuality)
virtual void | setMonoColor (const AcCmColor &color, bool bEnableMode)
virtual void | setOpacityLevel (double nLevel, bool bEnableModifier)
virtual void | setSpecularAmount (double nAmount, bool bEnableModifier)
virtual double | specularAmount (void) const
virtual | ~AcGiFaceStyle (void)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiFaceStyle::AcGiFaceStyle ( void )
Warning
Not implemented!
AcGiFaceStyle::AcGiFaceStyle ( const AcGiFaceStyle & style )
Warning
Not implemented!
virtual AcGiFaceStyle::~AcGiFaceStyle ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual FaceColorMode AcGiFaceStyle::faceColorMode ( void ) const
virtual
Warning
Not implemented!
virtual unsigned long AcGiFaceStyle::faceModifiers ( void ) const
virtual
Warning
Not implemented!
virtual bool AcGiFaceStyle::isFaceModifierFlagSet ( FaceModifier flag ) const
virtual
Warning
Not implemented!
virtual LightingModel AcGiFaceStyle::lightingModel ( void ) const
virtual
Warning
Not implemented!
virtual LightingQuality AcGiFaceStyle::lightingQuality ( void ) const
virtual
Warning
Not implemented!
virtual const AcCmColor& AcGiFaceStyle::monoColor ( void ) const
virtual
Warning
Not implemented!
virtual AcCmColor& AcGiFaceStyle::monoColor ( void )
virtual
Warning
Not implemented!
virtual double AcGiFaceStyle::opacityLevel ( void ) const
virtual
Warning
Not implemented!
virtual AcGiFaceStyle& AcGiFaceStyle::operator= ( const AcGiFaceStyle & style )
virtual
Warning
Not implemented!
virtual bool AcGiFaceStyle::operator== ( const AcGiFaceStyle & style ) const
virtual
Warning
Not implemented!
virtual void AcGiFaceStyle::set ( const AcGiFaceStyle & style )
virtual
Warning
Not implemented!
virtual void AcGiFaceStyle::setFaceColorMode ( FaceColorMode mode )
virtual
Warning
Not implemented!
virtual void AcGiFaceStyle::setFaceModifierFlag | ( | FaceModifier | flag,
 |  | bool | bEnable
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiFaceStyle::setFaceModifiers ( unsigned long nModifiers )
virtual
Warning
Not implemented!
virtual void AcGiFaceStyle::setLightingModel ( LightingModel lightingModel )
virtual
Warning
Not implemented!
virtual void AcGiFaceStyle::setLightingQuality ( LightingQuality lightingQuality )
virtual
Warning
Not implemented!
virtual void AcGiFaceStyle::setMonoColor | ( | const AcCmColor & | color,
 |  | bool | bEnableMode
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiFaceStyle::setOpacityLevel | ( | double | nLevel,
 |  | bool | bEnableModifier
 | ) |  |
virtual
Warning
Not implemented!
virtual void AcGiFaceStyle::setSpecularAmount | ( | double | nAmount,
 |  | bool | bEnableModifier
 | ) |  |
virtual
Warning
Not implemented!
virtual double AcGiFaceStyle::specularAmount ( void ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgivisualstyle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiFaceStyle Member List

This is the complete list of members for AcGiFaceStyle, including all inherited members.

AcGiFaceStyle(void) | AcGiFaceStyle |
AcGiFaceStyle(const AcGiFaceStyle &style) | AcGiFaceStyle |
ACRX_DECLARE_MEMBERS(AcGiFaceStyle) (defined in AcGiFaceStyle) | AcGiFaceStyle |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
faceColorMode(void) const | AcGiFaceStyle | virtual
FaceColorMode enum name (defined in AcGiFaceStyle) | AcGiFaceStyle |
FaceModifier enum name (defined in AcGiFaceStyle) | AcGiFaceStyle |
faceModifiers(void) const | AcGiFaceStyle | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isFaceModifierFlagSet(FaceModifier flag) const | AcGiFaceStyle | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kBackgroundColor enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kConstant enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kDesaturate enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kGooch enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kInvisible enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kMono enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kNoColorMode enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kNoFaceModifiers enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kNoLighting enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kObjectColor enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kOpacity enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kPerFaceLighting enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kPerPixelLighting enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kPerVertexLighting enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kPhong enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kSpecular enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
kTint enum value (defined in AcGiFaceStyle) | AcGiFaceStyle |
LightingModel enum name (defined in AcGiFaceStyle) | AcGiFaceStyle |
lightingModel(void) const | AcGiFaceStyle | virtual
LightingQuality enum name (defined in AcGiFaceStyle) | AcGiFaceStyle |
lightingQuality(void) const | AcGiFaceStyle | virtual
monoColor(void) const | AcGiFaceStyle | virtual
monoColor(void) | AcGiFaceStyle | virtual
opacityLevel(void) const | AcGiFaceStyle | virtual
operator=(const AcGiFaceStyle &style) | AcGiFaceStyle | virtual
operator==(const AcGiFaceStyle &style) const | AcGiFaceStyle | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
set(const AcGiFaceStyle &style) | AcGiFaceStyle | virtual
setFaceColorMode(FaceColorMode mode) | AcGiFaceStyle | virtual
setFaceModifierFlag(FaceModifier flag, bool bEnable) | AcGiFaceStyle | virtual
setFaceModifiers(unsigned long nModifiers) | AcGiFaceStyle | virtual
setLightingModel(LightingModel lightingModel) | AcGiFaceStyle | virtual
setLightingQuality(LightingQuality lightingQuality) | AcGiFaceStyle | virtual
setMonoColor(const AcCmColor &color, bool bEnableMode) | AcGiFaceStyle | virtual
setOpacityLevel(double nLevel, bool bEnableModifier) | AcGiFaceStyle | virtual
setSpecularAmount(double nAmount, bool bEnableModifier) | AcGiFaceStyle | virtual
specularAmount(void) const | AcGiFaceStyle | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiFaceStyle(void) | AcGiFaceStyle | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiGenericTexture Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
AcGiGenericTexture Class Reference
AcGi Classes
+ Inheritance diagram for AcGiGenericTexture:

Public Member Functions

AcGiGenericTexture (void)
AcGiGenericTexture (const AcGiGenericTexture &texture)
ACRX_DECLARE_MEMBERS (AcGiGenericTexture)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
AcGiVariant | definition (void) const
void | definition (AcGiVariant *&pDefinition)
AcGiGenericTexture & | operator= (const AcGiGenericTexture &texture)
virtual bool | operator== (const AcGiMaterialTexture &texture) const
void | setDefinition (const AcGiVariant &definition)
virtual | ~AcGiGenericTexture (void)
- Public Member Functions inherited from AcGiProceduralTexture
ACRX_DECLARE_MEMBERS (AcGiProceduralTexture)
- Public Member Functions inherited from AcGiMaterialTexture
ACRX_DECLARE_MEMBERS (AcGiMaterialTexture)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Attributes

AcGiVariant m_definition

Additional Inherited Members

- Public Types inherited from AcGiProceduralTexture
enum | Type { kWood = 0, kMarble, kGeneric }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiGenericTexture::AcGiGenericTexture ( void )
Warning
Not implemented!
virtual AcGiGenericTexture::~AcGiGenericTexture ( void )
virtual
Warning
Not implemented!
AcGiGenericTexture::AcGiGenericTexture ( const AcGiGenericTexture & texture )
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcGiGenericTexture::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcRxObject.

AcGiVariant AcGiGenericTexture::definition ( void ) const
Warning
Not implemented!
void AcGiGenericTexture::definition ( AcGiVariant *& pDefinition )
Warning
Not implemented!
AcGiGenericTexture& AcGiGenericTexture::operator= ( const AcGiGenericTexture & texture )
Warning
Not implemented!
virtual bool AcGiGenericTexture::operator== ( const AcGiMaterialTexture & texture ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiMaterialTexture.

void AcGiGenericTexture::setDefinition ( const AcGiVariant & definition )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiGenericTexture Member List

This is the complete list of members for AcGiGenericTexture, including all inherited members.

AcGiGenericTexture(void) | AcGiGenericTexture |
AcGiGenericTexture(const AcGiGenericTexture &texture) | AcGiGenericTexture |
ACRX_DECLARE_MEMBERS(AcGiGenericTexture) (defined in AcGiGenericTexture) | AcGiGenericTexture |
ACRX_DECLARE_MEMBERS(AcGiProceduralTexture) (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
ACRX_DECLARE_MEMBERS(AcGiMaterialTexture) (defined in AcGiMaterialTexture) | AcGiMaterialTexture |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) | AcGiGenericTexture | virtual
definition(void) const | AcGiGenericTexture |
definition(AcGiVariant *&pDefinition) | AcGiGenericTexture |
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kGeneric enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
kMarble enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
kWood enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
m_definition (defined in AcGiGenericTexture) | AcGiGenericTexture | protected
operator=(const AcGiGenericTexture &texture) | AcGiGenericTexture |
operator==(const AcGiMaterialTexture &texture) const | AcGiGenericTexture | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setDefinition(const AcGiVariant &definition) | AcGiGenericTexture |
Type enum name (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiGenericTexture(void) | AcGiGenericTexture | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiGeometry Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiGeometry Class Reference
AcGi Classes
+ Inheritance diagram for AcGiGeometry:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiGeometry)
virtual Adesk::Boolean | circle (const AcGePoint3d &center, const double radius, const AcGeVector3d &normal) const =0
virtual Adesk::Boolean | circle (const AcGePoint3d &, const AcGePoint3d &, const AcGePoint3d &) const =0
virtual Adesk::Boolean | circularArc (const AcGePoint3d &center, const double radius, const AcGeVector3d &normal, const AcGeVector3d &startVector, const double sweepAngle, const AcGiArcType arcType=kAcGiArcSimple) const =0
virtual Adesk::Boolean | circularArc (const AcGePoint3d &start, const AcGePoint3d &point, const AcGePoint3d &end, const AcGiArcType arcType=kAcGiArcSimple) const =0
virtual Adesk::Boolean | draw (AcGiDrawable *) const =0
virtual void | getModelToWorldTransform (AcGeMatrix3d &) const =0
virtual void | getWorldToModelTransform (AcGeMatrix3d &) const =0
virtual Adesk::Boolean | mesh (const Adesk::UInt32 rows, const Adesk::UInt32 columns, const AcGePoint3d *pVertexList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const bool bAutoGenerateNormals=true) const =0
virtual Adesk::Boolean | pline (const AcDbPolyline &lwBuf, Adesk::UInt32 fromIndex=0, Adesk::UInt32 numSegs=0) const =0
virtual Adesk::Boolean | polygon (const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList) const =0
virtual Adesk::Boolean | polyline (const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, Adesk::LongPtr lBaseSubEntMarker=-1) const =0
virtual Adesk::Boolean | polypoint (const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, const Adesk::LongPtr *pSubEntMarkers=NULL) const
virtual void | popClipBoundary ()=0
virtual Adesk::Boolean | popModelTransform ()=0
virtual Adesk::Boolean | pushClipBoundary (AcGiClipBoundary *pBoundary)=0
virtual Adesk::Boolean | pushModelTransform (const AcGeVector3d &vNormal)=0
virtual Adesk::Boolean | pushModelTransform (const AcGeMatrix3d &xMat)=0
virtual Adesk::Boolean | ray (const AcGePoint3d &, const AcGePoint3d &) const =0
virtual Adesk::Boolean | shell (const Adesk::UInt32 nbVertex, const AcGePoint3d *pVertexList, const Adesk::UInt32 faceListSize, const Adesk::Int32 *pFaceList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const struct resbuf *pResBuf=NULL, const bool bAutoGenerateNormals=true) const =0
virtual Adesk::Boolean | text (const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const double height, const double width, const double oblique, const ACHAR *pMsg) const =0
virtual Adesk::Boolean | text (const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const ACHAR *pMsg, const Adesk::Int32 length, const Adesk::Boolean raw, const AcGiTextStyle &pTextStyle) const =0
virtual Adesk::Boolean | worldLine (const AcGePoint3d pnts[2])
virtual Adesk::Boolean | xline (const AcGePoint3d &, const AcGePoint3d &) const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiGeometry Member List

This is the complete list of members for AcGiGeometry, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiGeometry) (defined in AcGiGeometry) | AcGiGeometry |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
circle(const AcGePoint3d &center, const double radius, const AcGeVector3d &normal) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
circle(const AcGePoint3d &, const AcGePoint3d &, const AcGePoint3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
circularArc(const AcGePoint3d &center, const double radius, const AcGeVector3d &normal, const AcGeVector3d &startVector, const double sweepAngle, const AcGiArcType arcType=kAcGiArcSimple) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
circularArc(const AcGePoint3d &start, const AcGePoint3d &point, const AcGePoint3d &end, const AcGiArcType arcType=kAcGiArcSimple) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
draw(AcGiDrawable *) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
getModelToWorldTransform(AcGeMatrix3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
getWorldToModelTransform(AcGeMatrix3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
mesh(const Adesk::UInt32 rows, const Adesk::UInt32 columns, const AcGePoint3d *pVertexList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const bool bAutoGenerateNormals=true) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pline(const AcDbPolyline &lwBuf, Adesk::UInt32 fromIndex=0, Adesk::UInt32 numSegs=0) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
polygon(const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
polyline(const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, Adesk::LongPtr lBaseSubEntMarker=-1) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
polypoint(const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, const Adesk::LongPtr *pSubEntMarkers=NULL) const (defined in AcGiGeometry) | AcGiGeometry | inlinevirtual
popClipBoundary()=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
popModelTransform()=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pushClipBoundary(AcGiClipBoundary *pBoundary)=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pushModelTransform(const AcGeVector3d &vNormal)=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pushModelTransform(const AcGeMatrix3d &xMat)=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
ray(const AcGePoint3d &, const AcGePoint3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
shell(const Adesk::UInt32 nbVertex, const AcGePoint3d *pVertexList, const Adesk::UInt32 faceListSize, const Adesk::Int32 *pFaceList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const struct resbuf *pResBuf=NULL, const bool bAutoGenerateNormals=true) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
text(const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const double height, const double width, const double oblique, const ACHAR *pMsg) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
text(const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const ACHAR *pMsg, const Adesk::Int32 length, const Adesk::Boolean raw, const AcGiTextStyle &pTextStyle) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
worldLine(const AcGePoint3d pnts[2]) (defined in AcGiGeometry) | AcGiGeometry | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xline(const AcGePoint3d &, const AcGePoint3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiGradientBackgroundTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiGradientBackgroundTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiGradientBackgroundTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiGradientBackgroundTraits)
virtual AcCmEntityColor | colorBottom (void) const =0
virtual AcCmEntityColor | colorMiddle (void) const =0
virtual AcCmEntityColor | colorTop (void) const =0
virtual double | height (void) const =0
virtual double | horizon (void) const =0
virtual double | rotation (void) const =0
virtual void | setColorBottom (const AcCmEntityColor &color)=0
virtual void | setColorMiddle (const AcCmEntityColor &color)=0
virtual void | setColorTop (const AcCmEntityColor &color)=0
virtual void | setHeight (double height)=0
virtual void | setHorizon (double horizon)=0
virtual void | setRotation (double rotation)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiGradientBackgroundTraits Member List

This is the complete list of members for AcGiGradientBackgroundTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiGradientBackgroundTraits) (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
colorBottom(void) const =0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
colorMiddle(void) const =0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
colorTop(void) const =0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
height(void) const =0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
horizon(void) const =0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rotation(void) const =0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setColorBottom(const AcCmEntityColor &color)=0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
setColorMiddle(const AcCmEntityColor &color)=0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
setColorTop(const AcCmEntityColor &color)=0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setHeight(double height)=0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
setHorizon(double horizon)=0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setRotation(double rotation)=0 (defined in AcGiGradientBackgroundTraits) | AcGiGradientBackgroundTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiGroundPlaneBackgroundTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiGroundPlaneBackgroundTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiGroundPlaneBackgroundTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiGroundPlaneBackgroundTraits)
virtual AcCmEntityColor | colorGroundPlaneFar (void) const =0
virtual AcCmEntityColor | colorGroundPlaneNear (void) const =0
virtual AcCmEntityColor | colorSkyHorizon (void) const =0
virtual AcCmEntityColor | colorSkyZenith (void) const =0
virtual AcCmEntityColor | colorUndergroundAzimuth (void) const =0
virtual AcCmEntityColor | colorUndergroundHorizon (void) const =0
virtual void | setColorGroundPlaneFar (const AcCmEntityColor &color)=0
virtual void | setColorGroundPlaneNear (const AcCmEntityColor &color)=0
virtual void | setColorSkyHorizon (const AcCmEntityColor &color)=0
virtual void | setColorSkyZenith (const AcCmEntityColor &color)=0
virtual void | setColorUndergroundAzimuth (const AcCmEntityColor &color)=0
virtual void | setColorUndergroundHorizon (const AcCmEntityColor &color)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiGroundPlaneBackgroundTraits Member List

This is the complete list of members for AcGiGroundPlaneBackgroundTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiGroundPlaneBackgroundTraits) (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
colorGroundPlaneFar(void) const =0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
colorGroundPlaneNear(void) const =0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
colorSkyHorizon(void) const =0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
colorSkyZenith(void) const =0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
colorUndergroundAzimuth(void) const =0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
colorUndergroundHorizon(void) const =0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setColorGroundPlaneFar(const AcCmEntityColor &color)=0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
setColorGroundPlaneNear(const AcCmEntityColor &color)=0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
setColorSkyHorizon(const AcCmEntityColor &color)=0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
setColorSkyZenith(const AcCmEntityColor &color)=0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
setColorUndergroundAzimuth(const AcCmEntityColor &color)=0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
setColorUndergroundHorizon(const AcCmEntityColor &color)=0 (defined in AcGiGroundPlaneBackgroundTraits) | AcGiGroundPlaneBackgroundTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiImageBackgroundTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiImageBackgroundTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiImageBackgroundTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiImageBackgroundTraits)
virtual bool | fitToScreen (void) const =0
virtual const ACHAR * | imageFilename (void) const =0
virtual bool | maintainAspectRatio (void) const =0
virtual void | setFitToScreen (bool bFitToScreen)=0
virtual void | setImageFilename (const ACHAR *filename)=0
virtual void | setMaintainAspectRatio (bool bMaintainAspectRatio)=0
virtual void | setUseTiling (bool bUseTiling)=0
virtual void | setXOffset (double xOffset)=0
virtual void | setXScale (double xScale)=0
virtual void | setYOffset (double yOffset)=0
virtual void | setYScale (double yScale)=0
virtual bool | useTiling (void) const =0
virtual double | xOffset (void) const =0
virtual double | xScale (void) const =0
virtual double | yOffset (void) const =0
virtual double | yScale (void) const =0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiImageBackgroundTraits Member List

This is the complete list of members for AcGiImageBackgroundTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiImageBackgroundTraits) (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
fitToScreen(void) const =0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
imageFilename(void) const =0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
maintainAspectRatio(void) const =0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setFitToScreen(bool bFitToScreen)=0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
setImageFilename(const ACHAR *filename)=0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMaintainAspectRatio(bool bMaintainAspectRatio)=0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setUseTiling(bool bUseTiling)=0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setXOffset(double xOffset)=0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
setXScale(double xScale)=0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
setYOffset(double yOffset)=0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
setYScale(double yScale)=0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
useTiling(void) const =0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xOffset(void) const =0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
xScale(void) const =0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
yOffset(void) const =0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
yScale(void) const =0 (defined in AcGiImageBackgroundTraits) | AcGiImageBackgroundTraits | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiImageFileTexture Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcGiImageFileTexture Class Reference
AcGi Classes
+ Inheritance diagram for AcGiImageFileTexture:

Public Member Functions

AcGiImageFileTexture (void)
AcGiImageFileTexture (const AcGiImageFileTexture &texture)
ACRX_DECLARE_MEMBERS (AcGiImageFileTexture)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
AcGiImageFileTexture & | operator= (const AcGiImageFileTexture &texture)
virtual bool | operator== (const AcGiMaterialTexture &texture) const
virtual void | setSourceFileName (const ACHAR *fileName)
virtual const ACHAR * | sourceFileName (void) const
virtual | ~AcGiImageFileTexture (void)
- Public Member Functions inherited from AcGiImageTexture
ACRX_DECLARE_MEMBERS (AcGiImageTexture)
- Public Member Functions inherited from AcGiMaterialTexture
ACRX_DECLARE_MEMBERS (AcGiMaterialTexture)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcGiImpImageFileTexture

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiImageFileTexture::AcGiImageFileTexture ( void )
Warning
Not implemented!
virtual AcGiImageFileTexture::~AcGiImageFileTexture ( void )
virtual
Warning
Not implemented!
AcGiImageFileTexture::AcGiImageFileTexture ( const AcGiImageFileTexture & texture )
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcGiImageFileTexture::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcRxObject.

AcGiImageFileTexture& AcGiImageFileTexture::operator= ( const AcGiImageFileTexture & texture )
Warning
Not implemented!
virtual bool AcGiImageFileTexture::operator== ( const AcGiMaterialTexture & texture ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiMaterialTexture.

virtual void AcGiImageFileTexture::setSourceFileName ( const ACHAR * fileName )
virtual
Warning
Not implemented!
virtual const ACHAR* AcGiImageFileTexture::sourceFileName ( void ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiImageFileTexture Member List

This is the complete list of members for AcGiImageFileTexture, including all inherited members.

AcGiImageFileTexture(void) | AcGiImageFileTexture |
AcGiImageFileTexture(const AcGiImageFileTexture &texture) | AcGiImageFileTexture |
AcGiImpImageFileTexture (defined in AcGiImageFileTexture) | AcGiImageFileTexture | friend
ACRX_DECLARE_MEMBERS(AcGiImageFileTexture) (defined in AcGiImageFileTexture) | AcGiImageFileTexture |
ACRX_DECLARE_MEMBERS(AcGiImageTexture) (defined in AcGiImageTexture) | AcGiImageTexture |
ACRX_DECLARE_MEMBERS(AcGiMaterialTexture) (defined in AcGiMaterialTexture) | AcGiMaterialTexture |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) | AcGiImageFileTexture | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
operator=(const AcGiImageFileTexture &texture) | AcGiImageFileTexture |
operator==(const AcGiMaterialTexture &texture) const | AcGiImageFileTexture | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setSourceFileName(const ACHAR *fileName) | AcGiImageFileTexture | virtual
sourceFileName(void) const | AcGiImageFileTexture | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiImageFileTexture(void) | AcGiImageFileTexture | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiImageTexture Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiImageTexture Class Reference
AcGi Classes
+ Inheritance diagram for AcGiImageTexture:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiImageTexture)
- Public Member Functions inherited from AcGiMaterialTexture
ACRX_DECLARE_MEMBERS (AcGiMaterialTexture)
virtual bool | operator== (const AcGiMaterialTexture &texture) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiImageTexture Member List

This is the complete list of members for AcGiImageTexture, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiImageTexture) (defined in AcGiImageTexture) | AcGiImageTexture |
ACRX_DECLARE_MEMBERS(AcGiMaterialTexture) (defined in AcGiMaterialTexture) | AcGiMaterialTexture |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
operator==(const AcGiMaterialTexture &texture) const (defined in AcGiMaterialTexture) | AcGiMaterialTexture | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiLightAttenuation Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiLightAttenuation Class Reference
AcGi Classes
+ Inheritance diagram for AcGiLightAttenuation:

Public Types

enum AttenuationType { kNone = 0, kInverseLinear, kInverseSquare }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiLightAttenuation)
virtual AttenuationType | attenuationType () const
virtual double | endLimit () const
bool | operator== (const AcGiLightAttenuation &atten) const
virtual void | setAttenuationType (AttenuationType typ)
virtual void | setLimits (double startlim, double endlim)
virtual void | setUseLimits (bool on)
virtual double | startLimit () const
virtual bool | useLimits () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiLightAttenuation Member List

This is the complete list of members for AcGiLightAttenuation, including all inherited members.

AcGiLightAttenuation() (defined in AcGiLightAttenuation) | AcGiLightAttenuation |
ACRX_DECLARE_MEMBERS(AcGiLightAttenuation) (defined in AcGiLightAttenuation) | AcGiLightAttenuation |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
AttenuationType enum name (defined in AcGiLightAttenuation) | AcGiLightAttenuation |
attenuationType() const (defined in AcGiLightAttenuation) | AcGiLightAttenuation | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
endLimit() const (defined in AcGiLightAttenuation) | AcGiLightAttenuation | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kInverseLinear enum value (defined in AcGiLightAttenuation) | AcGiLightAttenuation |
kInverseSquare enum value (defined in AcGiLightAttenuation) | AcGiLightAttenuation |
kNone enum value (defined in AcGiLightAttenuation) | AcGiLightAttenuation |
operator==(const AcGiLightAttenuation &atten) const (defined in AcGiLightAttenuation) | AcGiLightAttenuation |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setAttenuationType(AttenuationType typ) (defined in AcGiLightAttenuation) | AcGiLightAttenuation | virtual
setLimits(double startlim, double endlim) (defined in AcGiLightAttenuation) | AcGiLightAttenuation | virtual
setUseLimits(bool on) (defined in AcGiLightAttenuation) | AcGiLightAttenuation | virtual
startLimit() const (defined in AcGiLightAttenuation) | AcGiLightAttenuation | virtual
useLimits() const (defined in AcGiLightAttenuation) | AcGiLightAttenuation | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiLightAttenuation() (defined in AcGiLightAttenuation) | AcGiLightAttenuation | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiLightTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiLightTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiLightTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiLightTraits)
virtual bool | isOn () const =0
virtual void | setOn (bool on)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiLightTraits Member List

This is the complete list of members for AcGiLightTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiLightTraits) (defined in AcGiLightTraits) | AcGiLightTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOn() const =0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setOn(bool on)=0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiLineAttributes Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiLineAttributes Class Reference
AcGi Classes

Public Member Functions

virtual AcGiLineAttributes * | clone () const =0
virtual AcGiLineEndStyle | getEndstyle () const =0
virtual AcGiLineFillStyle | getFillstyle () const =0
virtual AcGiLineJoinStyle | getJoinstyle () const =0
virtual AcGiLineType | getLinetype () const =0
virtual AcDb::LineWeight | getLineweight () const =0
virtual bool | hasCustomLineweight () const =0
virtual bool | isLinetypeAdaptive () const =0
virtual bool | isLineWeightByLayer () const =0
virtual bool | isLineweightDefault () const =0
virtual void | setCustomLineweight (bool isCustomLineweight)=0
virtual void | setEndstyle (AcGiLineEndStyle endstyle)=0
virtual void | setFillstyle (AcGiLineFillStyle fillstyle)=0
virtual void | setJoinstyle (AcGiLineJoinStyle joinstyle)=0
virtual void | setLinetype (AcGiLineType linetype)=0
virtual void | setLinetypeAdaptive (bool isAdaptive)=0
virtual void | setLineweight (AcDb::LineWeight lweight)=0
virtual void | setLineWeightByLayer (bool isLineweightByLayer)=0
virtual void | setLineweightDefault ()=0
The documentation for this class was generated from the following file:
  • AcGiLineAttributes.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiLineAttributes Member List

This is the complete list of members for AcGiLineAttributes, including all inherited members.

clone() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
getEndstyle() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
getFillstyle() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
getJoinstyle() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
getLinetype() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
getLineweight() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
hasCustomLineweight() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
isLinetypeAdaptive() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
isLineWeightByLayer() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
isLineweightDefault() const =0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
setCustomLineweight(bool isCustomLineweight)=0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
setEndstyle(AcGiLineEndStyle endstyle)=0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
setFillstyle(AcGiLineFillStyle fillstyle)=0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
setJoinstyle(AcGiLineJoinStyle joinstyle)=0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
setLinetype(AcGiLineType linetype)=0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
setLinetypeAdaptive(bool isAdaptive)=0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
setLineweight(AcDb::LineWeight lweight)=0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
setLineWeightByLayer(bool isLineweightByLayer)=0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
setLineweightDefault()=0 (defined in AcGiLineAttributes) | AcGiLineAttributes | pure virtual
~AcGiLineAttributes() (defined in AcGiLineAttributes) | AcGiLineAttributes | inlinevirtual


ZRX API Reference: AcGiLinetypeEngine Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiLinetypeEngine Class Reference
AcGi Classes
+ Inheritance diagram for AcGiLinetypeEngine:

Public Member Functions

AcGiLinetypeEngine ()
ACRX_DECLARE_MEMBERS (AcGiLinetypeEngine)
virtual Acad::ErrorStatus | tessellate (bool bIsArc, bool bIsCircle, const Adesk::UInt32 nPoints, const AcGePoint3d *pVertexList, AcGiWorldDraw *pWorldDraw, const AcDbObjectId linetypeId, double linetypeScale, const AcGeVector3d *pNormal)
virtual Acad::ErrorStatus | tessellate (bool bIsArc, bool bIsCircle, const Adesk::UInt32 nPoints, const AcGePoint3d *pVertexList, AcGiViewportDraw *pViewportDraw, const AcDbObjectId linetypeId, double linetypeScale, const AcGeVector3d *pNormal)
virtual Acad::ErrorStatus | tessellate (const AcGeCircArc3d &arcSeg, const AcGeMatrix3d &ecsMat, double startWidth, double endWidth, AcGiCommonDraw *pDraw, const AcDbObjectId linetypeId, double linetypeScale, double thick)
virtual Acad::ErrorStatus | tessellate (const AcGeLineSeg3d &lineSeg, const AcGeMatrix3d &ecsMat, double startWidth, double endWidth, AcGiCommonDraw *pDraw, const AcDbObjectId linetypeId, double linetypeScale)
virtual | ~AcGiLinetypeEngine ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiLinetypeEngine::AcGiLinetypeEngine ( )
Warning
Not implemented!
virtual AcGiLinetypeEngine::~AcGiLinetypeEngine ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcGiLinetypeEngine::tessellate | ( | bool | bIsArc,
 |  | bool | bIsCircle,
 |  | const Adesk::UInt32 | nPoints,
 |  | const AcGePoint3d * | pVertexList,
 |  | AcGiWorldDraw * | pWorldDraw,
 |  | const AcDbObjectId | linetypeId,
 |  | double | linetypeScale,
 |  | const AcGeVector3d * | pNormal
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcGiLinetypeEngine::tessellate | ( | bool | bIsArc,
 |  | bool | bIsCircle,
 |  | const Adesk::UInt32 | nPoints,
 |  | const AcGePoint3d * | pVertexList,
 |  | AcGiViewportDraw * | pViewportDraw,
 |  | const AcDbObjectId | linetypeId,
 |  | double | linetypeScale,
 |  | const AcGeVector3d * | pNormal
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcGiLinetypeEngine::tessellate | ( | const AcGeCircArc3d & | arcSeg,
 |  | const AcGeMatrix3d & | ecsMat,
 |  | double | startWidth,
 |  | double | endWidth,
 |  | AcGiCommonDraw * | pDraw,
 |  | const AcDbObjectId | linetypeId,
 |  | double | linetypeScale,
 |  | double | thick
 | ) |  |
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcGiLinetypeEngine::tessellate | ( | const AcGeLineSeg3d & | lineSeg,
 |  | const AcGeMatrix3d & | ecsMat,
 |  | double | startWidth,
 |  | double | endWidth,
 |  | AcGiCommonDraw * | pDraw,
 |  | const AcDbObjectId | linetypeId,
 |  | double | linetypeScale
 | ) |  |
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • linetypeengine.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiLinetypeEngine Member List

This is the complete list of members for AcGiLinetypeEngine, including all inherited members.

AcGiLinetypeEngine() | AcGiLinetypeEngine |
ACRX_DECLARE_MEMBERS(AcGiLinetypeEngine) (defined in AcGiLinetypeEngine) | AcGiLinetypeEngine |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
tessellate(bool bIsArc, bool bIsCircle, const Adesk::UInt32 nPoints, const AcGePoint3d *pVertexList, AcGiWorldDraw *pWorldDraw, const AcDbObjectId linetypeId, double linetypeScale, const AcGeVector3d *pNormal) | AcGiLinetypeEngine | virtual
tessellate(bool bIsArc, bool bIsCircle, const Adesk::UInt32 nPoints, const AcGePoint3d *pVertexList, AcGiViewportDraw *pViewportDraw, const AcDbObjectId linetypeId, double linetypeScale, const AcGeVector3d *pNormal) | AcGiLinetypeEngine | virtual
tessellate(const AcGeCircArc3d &arcSeg, const AcGeMatrix3d &ecsMat, double startWidth, double endWidth, AcGiCommonDraw *pDraw, const AcDbObjectId linetypeId, double linetypeScale, double thick) | AcGiLinetypeEngine | virtual
tessellate(const AcGeLineSeg3d &lineSeg, const AcGeMatrix3d &ecsMat, double startWidth, double endWidth, AcGiCommonDraw *pDraw, const AcDbObjectId linetypeId, double linetypeScale) | AcGiLinetypeEngine | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiLinetypeEngine() | AcGiLinetypeEngine | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiMapper Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Attributes | List of all members
AcGiMapper Class Reference
AcGi Classes
+ Inheritance diagram for AcGiMapper:

Public Types

enum AutoTransform { kInheritAutoTransform = 0x0, kNone = 0x1, kObject = 0x2, kModel = 0x4 }
enum Projection {
kInheritProjection = 0, kPlanar, kBox, kCylinder,
kSphere
}
enum Tiling {
kInheritTiling = 0, kTile, kCrop, kClamp,
kMirror
}

Public Member Functions

AcGiMapper (const AcGiMapper &mapper)
ACRX_DECLARE_MEMBERS (AcGiMapper)
virtual AutoTransform | autoTransform (void) const
bool | operator!= (const AcGiMapper &mapper) const
AcGiMapper & | operator= (const AcGiMapper &mapper)
bool | operator== (const AcGiMapper &mapper) const
virtual Projection | projection (void) const
virtual void | set (const AcGiMapper &mapper)
virtual void | setAutoTransform (AutoTransform autoTransform)
virtual void | setProjection (Projection projection)
virtual ADESK_DEPRECATED void | setTiling (Tiling tiling)
virtual void | setTransform (const AcGeMatrix3d &transform)
void | setUTiling (Tiling tiling)
void | setVTiling (Tiling tiling)
virtual ADESK_DEPRECATED Tiling | tiling (void) const
virtual const AcGeMatrix3d & | transform (void) const
Tiling | uTiling (void) const
Tiling | vTiling (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Attributes

static ACGIMAT_IMPEXP const
AcGiMapper 		kIdentity

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiMapper Member List

This is the complete list of members for AcGiMapper, including all inherited members.

AcGiMapper(void) (defined in AcGiMapper) | AcGiMapper |
AcGiMapper(const AcGiMapper &mapper) (defined in AcGiMapper) | AcGiMapper |
ACRX_DECLARE_MEMBERS(AcGiMapper) (defined in AcGiMapper) | AcGiMapper |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
autoTransform(void) const (defined in AcGiMapper) | AcGiMapper | virtual
AutoTransform enum name (defined in AcGiMapper) | AcGiMapper |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kBox enum value (defined in AcGiMapper) | AcGiMapper |
kClamp enum value (defined in AcGiMapper) | AcGiMapper |
kCrop enum value (defined in AcGiMapper) | AcGiMapper |
kCylinder enum value (defined in AcGiMapper) | AcGiMapper |
kIdentity (defined in AcGiMapper) | AcGiMapper | static
kInheritAutoTransform enum value (defined in AcGiMapper) | AcGiMapper |
kInheritProjection enum value (defined in AcGiMapper) | AcGiMapper |
kInheritTiling enum value (defined in AcGiMapper) | AcGiMapper |
kMirror enum value (defined in AcGiMapper) | AcGiMapper |
kModel enum value (defined in AcGiMapper) | AcGiMapper |
kNone enum value (defined in AcGiMapper) | AcGiMapper |
kObject enum value (defined in AcGiMapper) | AcGiMapper |
kPlanar enum value (defined in AcGiMapper) | AcGiMapper |
kSphere enum value (defined in AcGiMapper) | AcGiMapper |
kTile enum value (defined in AcGiMapper) | AcGiMapper |
operator!=(const AcGiMapper &mapper) const (defined in AcGiMapper) | AcGiMapper | inline
operator=(const AcGiMapper &mapper) (defined in AcGiMapper) | AcGiMapper |
operator==(const AcGiMapper &mapper) const (defined in AcGiMapper) | AcGiMapper |
Projection enum name (defined in AcGiMapper) | AcGiMapper |
projection(void) const (defined in AcGiMapper) | AcGiMapper | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
set(const AcGiMapper &mapper) (defined in AcGiMapper) | AcGiMapper | virtual
setAutoTransform(AutoTransform autoTransform) (defined in AcGiMapper) | AcGiMapper | virtual
setProjection(Projection projection) (defined in AcGiMapper) | AcGiMapper | virtual
setTiling(Tiling tiling) (defined in AcGiMapper) | AcGiMapper | virtual
setTransform(const AcGeMatrix3d &transform) (defined in AcGiMapper) | AcGiMapper | virtual
setUTiling(Tiling tiling) (defined in AcGiMapper) | AcGiMapper |
setVTiling(Tiling tiling) (defined in AcGiMapper) | AcGiMapper |
tiling(void) const (defined in AcGiMapper) | AcGiMapper | virtual
Tiling enum name (defined in AcGiMapper) | AcGiMapper |
transform(void) const (defined in AcGiMapper) | AcGiMapper | virtual
uTiling(void) const (defined in AcGiMapper) | AcGiMapper |
vTiling(void) const (defined in AcGiMapper) | AcGiMapper |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiMapper(void) (defined in AcGiMapper) | AcGiMapper | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiMarbleTexture Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcGiMarbleTexture Class Reference
AcGi Classes
+ Inheritance diagram for AcGiMarbleTexture:

Public Member Functions

AcGiMarbleTexture (void)
AcGiMarbleTexture (const AcGiMarbleTexture &texture)
ACRX_DECLARE_MEMBERS (AcGiMarbleTexture)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
AcGiMarbleTexture & | operator= (const AcGiMarbleTexture &texture)
virtual bool | operator== (const AcGiMaterialTexture &texture) const
virtual void | setStoneColor (const AcGiMaterialColor &stoneColor)
virtual void | setVeinColor (const AcGiMaterialColor &veinColor)
virtual void | setVeinSpacing (double veinSpacing)
virtual void | setVeinWidth (double veinWidth)
virtual const AcGiMaterialColor & | stoneColor (void) const
virtual const AcGiMaterialColor & | veinColor (void) const
virtual double | veinSpacing (void) const
virtual double | veinWidth (void) const
virtual | ~AcGiMarbleTexture (void)
- Public Member Functions inherited from AcGiProceduralTexture
ACRX_DECLARE_MEMBERS (AcGiProceduralTexture)
- Public Member Functions inherited from AcGiMaterialTexture
ACRX_DECLARE_MEMBERS (AcGiMaterialTexture)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcGiImpMarbleTexture

Additional Inherited Members

- Public Types inherited from AcGiProceduralTexture
enum | Type { kWood = 0, kMarble, kGeneric }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiMarbleTexture::AcGiMarbleTexture ( void )
Warning
Not implemented!
virtual AcGiMarbleTexture::~AcGiMarbleTexture ( void )
virtual
Warning
Not implemented!
AcGiMarbleTexture::AcGiMarbleTexture ( const AcGiMarbleTexture & texture )
Warning
Not implemented!

Member Function Documentation

virtual Acad::ErrorStatus AcGiMarbleTexture::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcRxObject.

AcGiMarbleTexture& AcGiMarbleTexture::operator= ( const AcGiMarbleTexture & texture )
Warning
Not implemented!
virtual bool AcGiMarbleTexture::operator== ( const AcGiMaterialTexture & texture ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiMaterialTexture.

virtual void AcGiMarbleTexture::setStoneColor ( const AcGiMaterialColor & stoneColor )
virtual
Warning
Not implemented!
virtual void AcGiMarbleTexture::setVeinColor ( const AcGiMaterialColor & veinColor )
virtual
Warning
Not implemented!
virtual void AcGiMarbleTexture::setVeinSpacing ( double veinSpacing )
virtual
Warning
Not implemented!
virtual void AcGiMarbleTexture::setVeinWidth ( double veinWidth )
virtual
Warning
Not implemented!
virtual const AcGiMaterialColor& AcGiMarbleTexture::stoneColor ( void ) const
virtual
Warning
Not implemented!
virtual const AcGiMaterialColor& AcGiMarbleTexture::veinColor ( void ) const
virtual
Warning
Not implemented!
virtual double AcGiMarbleTexture::veinSpacing ( void ) const
virtual
Warning
Not implemented!
virtual double AcGiMarbleTexture::veinWidth ( void ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiMarbleTexture Member List

This is the complete list of members for AcGiMarbleTexture, including all inherited members.

AcGiImpMarbleTexture (defined in AcGiMarbleTexture) | AcGiMarbleTexture | friend
AcGiMarbleTexture(void) | AcGiMarbleTexture |
AcGiMarbleTexture(const AcGiMarbleTexture &texture) | AcGiMarbleTexture |
ACRX_DECLARE_MEMBERS(AcGiMarbleTexture) (defined in AcGiMarbleTexture) | AcGiMarbleTexture |
ACRX_DECLARE_MEMBERS(AcGiProceduralTexture) (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
ACRX_DECLARE_MEMBERS(AcGiMaterialTexture) (defined in AcGiMaterialTexture) | AcGiMaterialTexture |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) | AcGiMarbleTexture | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kGeneric enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
kMarble enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
kWood enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
operator=(const AcGiMarbleTexture &texture) | AcGiMarbleTexture |
operator==(const AcGiMaterialTexture &texture) const | AcGiMarbleTexture | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setStoneColor(const AcGiMaterialColor &stoneColor) | AcGiMarbleTexture | virtual
setVeinColor(const AcGiMaterialColor &veinColor) | AcGiMarbleTexture | virtual
setVeinSpacing(double veinSpacing) | AcGiMarbleTexture | virtual
setVeinWidth(double veinWidth) | AcGiMarbleTexture | virtual
stoneColor(void) const | AcGiMarbleTexture | virtual
Type enum name (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
veinColor(void) const | AcGiMarbleTexture | virtual
veinSpacing(void) const | AcGiMarbleTexture | virtual
veinWidth(void) const | AcGiMarbleTexture | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiMarbleTexture(void) | AcGiMarbleTexture | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiMaterialColor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Attributes | List of all members
AcGiMaterialColor Class Reference
AcGi Classes
+ Inheritance diagram for AcGiMaterialColor:

Public Types

enum Method { kInherit = 0, kOverride }

Public Member Functions

AcGiMaterialColor (const AcGiMaterialColor &matColor)
ACRX_DECLARE_MEMBERS (AcGiMaterialColor)
virtual const AcCmEntityColor & | color (void) const
virtual double | factor (void) const
virtual Method | method (void) const
AcGiMaterialColor & | operator= (const AcGiMaterialColor &matColor)
bool | operator== (const AcGiMaterialColor &matColor) const
virtual void | set (const AcGiMaterialColor &matColor)
virtual void | setColor (const AcCmEntityColor &color)
virtual void | setFactor (double dFactor)
virtual void | setMethod (Method method)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Attributes

static ACGIMAT_IMPEXP const
AcGiMaterialColor 		kNull

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiMaterialColor Member List

This is the complete list of members for AcGiMaterialColor, including all inherited members.

AcGiMaterialColor(void) (defined in AcGiMaterialColor) | AcGiMaterialColor |
AcGiMaterialColor(const AcGiMaterialColor &matColor) (defined in AcGiMaterialColor) | AcGiMaterialColor |
ACRX_DECLARE_MEMBERS(AcGiMaterialColor) (defined in AcGiMaterialColor) | AcGiMaterialColor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const (defined in AcGiMaterialColor) | AcGiMaterialColor | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
factor(void) const (defined in AcGiMaterialColor) | AcGiMaterialColor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kInherit enum value (defined in AcGiMaterialColor) | AcGiMaterialColor |
kNull (defined in AcGiMaterialColor) | AcGiMaterialColor | static
kOverride enum value (defined in AcGiMaterialColor) | AcGiMaterialColor |
Method enum name (defined in AcGiMaterialColor) | AcGiMaterialColor |
method(void) const (defined in AcGiMaterialColor) | AcGiMaterialColor | virtual
operator=(const AcGiMaterialColor &matColor) (defined in AcGiMaterialColor) | AcGiMaterialColor |
operator==(const AcGiMaterialColor &matColor) const (defined in AcGiMaterialColor) | AcGiMaterialColor |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
set(const AcGiMaterialColor &matColor) (defined in AcGiMaterialColor) | AcGiMaterialColor | virtual
setColor(const AcCmEntityColor &color) (defined in AcGiMaterialColor) | AcGiMaterialColor | virtual
setFactor(double dFactor) (defined in AcGiMaterialColor) | AcGiMaterialColor | virtual
setMethod(Method method) (defined in AcGiMaterialColor) | AcGiMaterialColor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiMaterialColor(void) (defined in AcGiMaterialColor) | AcGiMaterialColor | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiMaterialMap Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Attributes | List of all members
AcGiMaterialMap Class Reference
AcGi Classes
+ Inheritance diagram for AcGiMaterialMap:

Public Types

enum | Filter { kFilterDefault = 0, kFilterNone }
enum | Source { kScene = 0, kFile, kProcedural }

Public Member Functions

AcGiMaterialMap (const AcGiMaterialMap &matMap)
ACRX_DECLARE_MEMBERS (AcGiMaterialMap)
virtual double | blendFactor (void) const
ACGIMAT_IMPEXP Filter | filter (void) const
virtual const AcGiMapper & | mapper (void) const
AcGiMaterialMap & | operator= (const AcGiMaterialMap &matMap)
bool | operator== (const AcGiMaterialMap &matMap) const
virtual void | set (const AcGiMaterialMap &matMap)
virtual void | setBlendFactor (double blendFactor)
ACGIMAT_IMPEXP Acad::ErrorStatus | setFilter (Filter filter)
virtual void | setMapper (const AcGiMapper &mapper)
virtual void | setSource (Source source)
virtual ADESK_DEPRECATED void | setSourceFileName (const ACHAR *fileName)
virtual void | setTexture (const AcGiMaterialTexture *pTexture)
virtual Source | source (void) const
virtual ADESK_DEPRECATED const
ACHAR * 		sourceFileName (void) const
virtual const AcGiMaterialTexture * | texture (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Attributes

static ACGIMAT_IMPEXP const
AcGiMaterialMap 		kNull

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiMaterialMap Member List

This is the complete list of members for AcGiMaterialMap, including all inherited members.

AcGiMaterialMap(void) (defined in AcGiMaterialMap) | AcGiMaterialMap |
AcGiMaterialMap(const AcGiMaterialMap &matMap) (defined in AcGiMaterialMap) | AcGiMaterialMap |
ACRX_DECLARE_MEMBERS(AcGiMaterialMap) (defined in AcGiMaterialMap) | AcGiMaterialMap |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
blendFactor(void) const (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
Filter enum name (defined in AcGiMaterialMap) | AcGiMaterialMap |
filter(void) const (defined in AcGiMaterialMap) | AcGiMaterialMap |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kFile enum value (defined in AcGiMaterialMap) | AcGiMaterialMap |
kFilterDefault enum value (defined in AcGiMaterialMap) | AcGiMaterialMap |
kFilterNone enum value (defined in AcGiMaterialMap) | AcGiMaterialMap |
kNull (defined in AcGiMaterialMap) | AcGiMaterialMap | static
kProcedural enum value (defined in AcGiMaterialMap) | AcGiMaterialMap |
kScene enum value (defined in AcGiMaterialMap) | AcGiMaterialMap |
mapper(void) const (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
operator=(const AcGiMaterialMap &matMap) (defined in AcGiMaterialMap) | AcGiMaterialMap |
operator==(const AcGiMaterialMap &matMap) const (defined in AcGiMaterialMap) | AcGiMaterialMap |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
set(const AcGiMaterialMap &matMap) (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
setBlendFactor(double blendFactor) (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
setFilter(Filter filter) (defined in AcGiMaterialMap) | AcGiMaterialMap |
setMapper(const AcGiMapper &mapper) (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
setSource(Source source) (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
setSourceFileName(const ACHAR *fileName) (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
setTexture(const AcGiMaterialTexture *pTexture) (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
Source enum name (defined in AcGiMaterialMap) | AcGiMaterialMap |
source(void) const (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
sourceFileName(void) const (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
texture(void) const (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiMaterialMap(void) (defined in AcGiMaterialMap) | AcGiMaterialMap | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiMaterialTexture Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiMaterialTexture Class Reference
AcGi Classes
+ Inheritance diagram for AcGiMaterialTexture:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiMaterialTexture)
virtual bool | operator== (const AcGiMaterialTexture &texture) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiMaterialTexture Member List

This is the complete list of members for AcGiMaterialTexture, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiMaterialTexture) (defined in AcGiMaterialTexture) | AcGiMaterialTexture |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
operator==(const AcGiMaterialTexture &texture) const (defined in AcGiMaterialTexture) | AcGiMaterialTexture | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiMaterialTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiMaterialTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiMaterialTraits:

Public Types

enum ChannelFlags {
kNone = 0x00000, kUseDiffuse = 0x00001, kUseSpecular = 0x00002, kUseReflection = 0x00004,
kUseOpacity = 0x00008, kUseBump = 0x00010, kUseRefraction = 0x00020, kUseNormalMap = 0x00040,
kUseAll
}
enum | IlluminationModel { kBlinnShader = 0, kMetalShader }
enum | Mode { kRealistic = 0, kAdvanced }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiMaterialTraits)
virtual void | ambient (AcGiMaterialColor &color) const =0
virtual void | bump (AcGiMaterialMap &map) const =0
virtual ChannelFlags | channelFlags () const =0
virtual void | diffuse (AcGiMaterialColor &color, AcGiMaterialMap &map) const =0
virtual IlluminationModel | illuminationModel () const =0
virtual Mode | mode () const =0
virtual void | opacity (double &dPercentage, AcGiMaterialMap &map) const =0
virtual void | reflection (AcGiMaterialMap &map) const =0
virtual double | reflectivity () const =0
virtual void | refraction (double &dIndex, AcGiMaterialMap &map) const =0
virtual double | selfIllumination () const =0
virtual void | setAmbient (const AcGiMaterialColor &color)=0
virtual void | setBump (const AcGiMaterialMap &map)=0
virtual void | setChannelFlags (ChannelFlags flags)=0
virtual void | setDiffuse (const AcGiMaterialColor &color, const AcGiMaterialMap &map)=0
virtual void | setIlluminationModel (IlluminationModel model)=0
virtual void | setMode (Mode value)=0
virtual void | setOpacity (double dPercentage, const AcGiMaterialMap &map)=0
virtual void | setReflection (const AcGiMaterialMap &map)=0
virtual void | setReflectivity (double value)=0
virtual void | setRefraction (double dIndex, const AcGiMaterialMap &map)=0
virtual void | setSelfIllumination (double value)=0
virtual void | setSpecular (const AcGiMaterialColor &color, const AcGiMaterialMap &map, double dGloss)=0
virtual void | setTranslucence (double value)=0
virtual void | specular (AcGiMaterialColor &color, AcGiMaterialMap &map, double &dGloss) const =0
virtual double | translucence () const =0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: AcGiMaterialTraits2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiMaterialTraits2 Class Reference
AcGi Classes
+ Inheritance diagram for AcGiMaterialTraits2:

Public Types

enum | FinalGatherMode { kFinalGatherNone, kFinalGatherCast, kFinalGatherReceive, kFinalGatherCastAndReceive }
enum | GlobalIlluminationMode { kGlobalIlluminationNone, kGlobalIlluminationCast, kGlobalIlluminationReceive, kGlobalIlluminationCastAndReceive }
enum | LuminanceMode { kSelfIllumination = 0, kLuminance }
enum | NormalMapMethod { kTangentSpace }
- Public Types inherited from AcGiMaterialTraits
enum ChannelFlags {
kNone = 0x00000, kUseDiffuse = 0x00001, kUseSpecular = 0x00002, kUseReflection = 0x00004,
kUseOpacity = 0x00008, kUseBump = 0x00010, kUseRefraction = 0x00020, kUseNormalMap = 0x00040,
kUseAll
}
enum | IlluminationModel { kBlinnShader = 0, kMetalShader }
enum | Mode { kRealistic = 0, kAdvanced }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiMaterialTraits2)
virtual double | colorBleedScale () const =0
virtual FinalGatherMode | finalGather () const =0
virtual GlobalIlluminationMode | globalIllumination () const =0
virtual double | indirectBumpScale () const =0
virtual double | luminance () const =0
virtual LuminanceMode | luminanceMode () const =0
virtual void | normalMap (AcGiMaterialMap &map, NormalMapMethod &method, double &strength) const =0
virtual double | reflectanceScale () const =0
virtual void | setColorBleedScale (double value)=0
virtual void | setFinalGather (FinalGatherMode mode)=0
virtual void | setGlobalIllumination (GlobalIlluminationMode mode)=0
virtual void | setIndirectBumpScale (double value)=0
virtual void | setLuminance (double value)=0
virtual void | setLuminanceMode (LuminanceMode value)=0
virtual void | setNormalMap (const AcGiMaterialMap &map, NormalMapMethod method, double strength)=0
virtual void | setReflectanceScale (double value)=0
virtual void | setTransmittanceScale (double value)=0
virtual void | setTwoSided (bool value)=0
virtual double | transmittanceScale () const =0
virtual bool | twoSided () const =0
- Public Member Functions inherited from AcGiMaterialTraits
ACRX_DECLARE_MEMBERS (AcGiMaterialTraits)
virtual void | ambient (AcGiMaterialColor &color) const =0
virtual void | bump (AcGiMaterialMap &map) const =0
virtual ChannelFlags | channelFlags () const =0
virtual void | diffuse (AcGiMaterialColor &color, AcGiMaterialMap &map) const =0
virtual IlluminationModel | illuminationModel () const =0
virtual Mode | mode () const =0
virtual void | opacity (double &dPercentage, AcGiMaterialMap &map) const =0
virtual void | reflection (AcGiMaterialMap &map) const =0
virtual double | reflectivity () const =0
virtual void | refraction (double &dIndex, AcGiMaterialMap &map) const =0
virtual double | selfIllumination () const =0
virtual void | setAmbient (const AcGiMaterialColor &color)=0
virtual void | setBump (const AcGiMaterialMap &map)=0
virtual void | setChannelFlags (ChannelFlags flags)=0
virtual void | setDiffuse (const AcGiMaterialColor &color, const AcGiMaterialMap &map)=0
virtual void | setIlluminationModel (IlluminationModel model)=0
virtual void | setMode (Mode value)=0
virtual void | setOpacity (double dPercentage, const AcGiMaterialMap &map)=0
virtual void | setReflection (const AcGiMaterialMap &map)=0
virtual void | setReflectivity (double value)=0
virtual void | setRefraction (double dIndex, const AcGiMaterialMap &map)=0
virtual void | setSelfIllumination (double value)=0
virtual void | setSpecular (const AcGiMaterialColor &color, const AcGiMaterialMap &map, double dGloss)=0
virtual void | setTranslucence (double value)=0
virtual void | specular (AcGiMaterialColor &color, AcGiMaterialMap &map, double &dGloss) const =0
virtual double | translucence () const =0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiMaterialTraits2 Member List

This is the complete list of members for AcGiMaterialTraits2, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiMaterialTraits2) (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
ACRX_DECLARE_MEMBERS(AcGiMaterialTraits) (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
ambient(AcGiMaterialColor &color) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
bump(AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
ChannelFlags enum name (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
channelFlags() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
colorBleedScale() const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
diffuse(AcGiMaterialColor &color, AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
finalGather() const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
FinalGatherMode enum name (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
globalIllumination() const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
GlobalIlluminationMode enum name (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
IlluminationModel enum name (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
illuminationModel() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
indirectBumpScale() const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAdvanced enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kBlinnShader enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFinalGatherCast enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kFinalGatherCastAndReceive enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kFinalGatherNone enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kFinalGatherReceive enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kGlobalIlluminationCast enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kGlobalIlluminationCastAndReceive enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kGlobalIlluminationNone enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kGlobalIlluminationReceive enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kLuminance enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kMetalShader enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kRealistic enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kSelfIllumination enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kTangentSpace enum value (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
kUseAll enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseBump enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseDiffuse enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseNormalMap enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseOpacity enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseReflection enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseRefraction enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseSpecular enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
luminance() const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
luminanceMode() const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
LuminanceMode enum name (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
Mode enum name (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
mode() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
normalMap(AcGiMaterialMap &map, NormalMapMethod &method, double &strength) const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
NormalMapMethod enum name (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 |
opacity(double &dPercentage, AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reflectanceScale() const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
reflection(AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
reflectivity() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
refraction(double &dIndex, AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
selfIllumination() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setAmbient(const AcGiMaterialColor &color)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setBump(const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setChannelFlags(ChannelFlags flags)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setColorBleedScale(double value)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setDiffuse(const AcGiMaterialColor &color, const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setFinalGather(FinalGatherMode mode)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setGlobalIllumination(GlobalIlluminationMode mode)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setIlluminationModel(IlluminationModel model)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setIndirectBumpScale(double value)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setLuminance(double value)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setLuminanceMode(LuminanceMode value)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setMode(Mode value)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setNormalMap(const AcGiMaterialMap &map, NormalMapMethod method, double strength)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setOpacity(double dPercentage, const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setReflectanceScale(double value)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setReflection(const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setReflectivity(double value)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setRefraction(double dIndex, const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setSelfIllumination(double value)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSpecular(const AcGiMaterialColor &color, const AcGiMaterialMap &map, double dGloss)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTranslucence(double value)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setTransmittanceScale(double value)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setTwoSided(bool value)=0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
specular(AcGiMaterialColor &color, AcGiMaterialMap &map, double &dGloss) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
translucence() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
transmittanceScale() const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
twoSided() const =0 (defined in AcGiMaterialTraits2) | AcGiMaterialTraits2 | pure virtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiMentalRayRenderSettingsTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiMentalRayRenderSettingsTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiMentalRayRenderSettingsTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiMentalRayRenderSettingsTraits)
virtual AcGiMrDiagnosticBSPMode | diagnosticBSPMode () const =0
virtual void | diagnosticGridMode (AcGiMrDiagnosticGridMode &mode, float &fSize) const =0
virtual AcGiMrDiagnosticMode | diagnosticMode () const =0
virtual AcGiMrDiagnosticPhotonMode | diagnosticPhotonMode () const =0
virtual float | energyMultiplier () const =0
virtual bool | exportMIEnabled () const =0
virtual const ACHAR * | exportMIFileName () const =0
virtual int | fgRayCount () const =0
virtual void | fgSampleRadius (double &min, double &max) const =0
virtual void | fgSampleRadiusState (bool &bMin, bool &bMax, bool &bPixels)=0
virtual bool | finalGatheringEnabled () const =0
virtual int | giPhotonsPerLight () const =0
virtual int | giSampleCount () const =0
virtual double | giSampleRadius () const =0
virtual bool | giSampleRadiusEnabled () const =0
virtual bool | globalIlluminationEnabled () const =0
virtual double | lightLuminanceScale () const =0
virtual int | memoryLimit () const =0
virtual void | photonTraceDepth (int &reflection, int &refraction, int &sum) const =0
virtual const void * | progressMonitor (void) const =0
virtual void | rayTraceDepth (int &reflection, int &refraction, int &sum) const =0
virtual bool | rayTraceEnabled () const =0
virtual void | sampling (int &min, int &max) const =0
virtual void | samplingContrastColor (float &r, float &g, float &b, float &a) const =0
virtual void | SamplingFilter (AcGiMrFilter &filter, double &width, double &height) const =0
virtual void | setDiagnosticBSPMode (AcGiMrDiagnosticBSPMode mode)=0
virtual void | setDiagnosticGridMode (AcGiMrDiagnosticGridMode mode, float fSize)=0
virtual void | setDiagnosticMode (AcGiMrDiagnosticMode mode)=0
virtual void | setDiagnosticPhotonMode (AcGiMrDiagnosticPhotonMode mode)=0
virtual void | setEnergyMultiplier (float fScale)=0
virtual void | setExportMIEnabled (bool enabled)=0
virtual void | setExportMIFileName (const ACHAR *miName)=0
virtual void | setFGRadiusState (bool bMin, bool bMax, bool bPixels)=0
virtual void | setFGRayCount (int num)=0
virtual void | setFGSampleRadius (double min, double max)=0
virtual void | setFinalGatheringEnabled (bool enabled)=0
virtual void | setGIPhotonsPerLight (int num)=0
virtual void | setGISampleCount (int num)=0
virtual void | setGISampleRadius (double radius)=0
virtual void | setGISampleRadiusEnabled (bool enabled)=0
virtual void | setGlobalIlluminationEnabled (bool enabled)=0
virtual void | setLightLuminanceScale (double luminance)=0
virtual void | setMemoryLimit (int limit)=0
virtual void | setPhotonTraceDepth (int reflection, int refraction, int sum)=0
virtual void | setProgressMonitor (void *pMonitor)=0
virtual void | setRayTraceDepth (int reflection, int refraction, int sum)=0
virtual void | setRayTraceEnabled (bool enabled)=0
virtual void | setSampling (int min, int max)=0
virtual void | setSamplingContrastColor (float r, float g, float b, float a)=0
virtual void | setSamplingFilter (AcGiMrFilter filter, double width, double height)=0
virtual void | setShadowMapEnabled (bool enabled)=0
virtual void | setShadowMode (AcGiMrShadowMode mode)=0
virtual void | setTileOrder (AcGiMrTileOrder order)=0
virtual void | setTileSize (int size)=0
virtual bool | shadowMapEnabled () const =0
virtual AcGiMrShadowMode | shadowMode () const =0
virtual AcGiMrTileOrder | tileOrder () const =0
virtual int | tileSize () const =0
- Public Member Functions inherited from AcGiRenderSettingsTraits
ACRX_DECLARE_MEMBERS (AcGiRenderSettingsTraits)
virtual bool | backFacesEnabled () const =0
virtual bool | diagnosticBackgroundEnabled () const =0
virtual bool | materialEnabled () const =0
virtual double | modelScaleFactor (void) const =0
virtual void | setBackFacesEnabled (bool enabled)=0
virtual void | setDiagnosticBackgroundEnabled (bool enabled)=0
virtual void | setMaterialEnabled (bool enabled)=0
virtual void | setModelScaleFactor (double scaleFactor)=0
virtual void | setShadowsEnabled (bool enabled)=0
virtual void | setTextureSampling (bool enabled)=0
virtual bool | shadowsEnabled () const =0
virtual bool | textureSampling () const =0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: AcGiMentalRayRenderSettingsTraits2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiMentalRayRenderSettingsTraits2 Class Reference
AcGi Classes
+ Inheritance diagram for AcGiMentalRayRenderSettingsTraits2:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiMentalRayRenderSettingsTraits2)
virtual AcGiMrExposureType | exposureType () const =0
virtual AcGiMrFinalGatheringMode | finalGatheringMode () const =0
virtual void | setExposureType (AcGiMrExposureType type)=0
virtual void | setFinalGatheringMode (AcGiMrFinalGatheringMode mode)=0
virtual void | setShadowSamplingMultiplier (double multiplier)=0
virtual double | shadowSamplingMultiplier () const =0
- Public Member Functions inherited from AcGiMentalRayRenderSettingsTraits
ACRX_DECLARE_MEMBERS (AcGiMentalRayRenderSettingsTraits)
virtual AcGiMrDiagnosticBSPMode | diagnosticBSPMode () const =0
virtual void | diagnosticGridMode (AcGiMrDiagnosticGridMode &mode, float &fSize) const =0
virtual AcGiMrDiagnosticMode | diagnosticMode () const =0
virtual AcGiMrDiagnosticPhotonMode | diagnosticPhotonMode () const =0
virtual float | energyMultiplier () const =0
virtual bool | exportMIEnabled () const =0
virtual const ACHAR * | exportMIFileName () const =0
virtual int | fgRayCount () const =0
virtual void | fgSampleRadius (double &min, double &max) const =0
virtual void | fgSampleRadiusState (bool &bMin, bool &bMax, bool &bPixels)=0
virtual bool | finalGatheringEnabled () const =0
virtual int | giPhotonsPerLight () const =0
virtual int | giSampleCount () const =0
virtual double | giSampleRadius () const =0
virtual bool | giSampleRadiusEnabled () const =0
virtual bool | globalIlluminationEnabled () const =0
virtual double | lightLuminanceScale () const =0
virtual int | memoryLimit () const =0
virtual void | photonTraceDepth (int &reflection, int &refraction, int &sum) const =0
virtual const void * | progressMonitor (void) const =0
virtual void | rayTraceDepth (int &reflection, int &refraction, int &sum) const =0
virtual bool | rayTraceEnabled () const =0
virtual void | sampling (int &min, int &max) const =0
virtual void | samplingContrastColor (float &r, float &g, float &b, float &a) const =0
virtual void | SamplingFilter (AcGiMrFilter &filter, double &width, double &height) const =0
virtual void | setDiagnosticBSPMode (AcGiMrDiagnosticBSPMode mode)=0
virtual void | setDiagnosticGridMode (AcGiMrDiagnosticGridMode mode, float fSize)=0
virtual void | setDiagnosticMode (AcGiMrDiagnosticMode mode)=0
virtual void | setDiagnosticPhotonMode (AcGiMrDiagnosticPhotonMode mode)=0
virtual void | setEnergyMultiplier (float fScale)=0
virtual void | setExportMIEnabled (bool enabled)=0
virtual void | setExportMIFileName (const ACHAR *miName)=0
virtual void | setFGRadiusState (bool bMin, bool bMax, bool bPixels)=0
virtual void | setFGRayCount (int num)=0
virtual void | setFGSampleRadius (double min, double max)=0
virtual void | setFinalGatheringEnabled (bool enabled)=0
virtual void | setGIPhotonsPerLight (int num)=0
virtual void | setGISampleCount (int num)=0
virtual void | setGISampleRadius (double radius)=0
virtual void | setGISampleRadiusEnabled (bool enabled)=0
virtual void | setGlobalIlluminationEnabled (bool enabled)=0
virtual void | setLightLuminanceScale (double luminance)=0
virtual void | setMemoryLimit (int limit)=0
virtual void | setPhotonTraceDepth (int reflection, int refraction, int sum)=0
virtual void | setProgressMonitor (void *pMonitor)=0
virtual void | setRayTraceDepth (int reflection, int refraction, int sum)=0
virtual void | setRayTraceEnabled (bool enabled)=0
virtual void | setSampling (int min, int max)=0
virtual void | setSamplingContrastColor (float r, float g, float b, float a)=0
virtual void | setSamplingFilter (AcGiMrFilter filter, double width, double height)=0
virtual void | setShadowMapEnabled (bool enabled)=0
virtual void | setShadowMode (AcGiMrShadowMode mode)=0
virtual void | setTileOrder (AcGiMrTileOrder order)=0
virtual void | setTileSize (int size)=0
virtual bool | shadowMapEnabled () const =0
virtual AcGiMrShadowMode | shadowMode () const =0
virtual AcGiMrTileOrder | tileOrder () const =0
virtual int | tileSize () const =0
- Public Member Functions inherited from AcGiRenderSettingsTraits
ACRX_DECLARE_MEMBERS (AcGiRenderSettingsTraits)
virtual bool | backFacesEnabled () const =0
virtual bool | diagnosticBackgroundEnabled () const =0
virtual bool | materialEnabled () const =0
virtual double | modelScaleFactor (void) const =0
virtual void | setBackFacesEnabled (bool enabled)=0
virtual void | setDiagnosticBackgroundEnabled (bool enabled)=0
virtual void | setMaterialEnabled (bool enabled)=0
virtual void | setModelScaleFactor (double scaleFactor)=0
virtual void | setShadowsEnabled (bool enabled)=0
virtual void | setTextureSampling (bool enabled)=0
virtual bool | shadowsEnabled () const =0
virtual bool | textureSampling () const =0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiMentalRayRenderSettingsTraits2 Member List

This is the complete list of members for AcGiMentalRayRenderSettingsTraits2, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiMentalRayRenderSettingsTraits2) (defined in AcGiMentalRayRenderSettingsTraits2) | AcGiMentalRayRenderSettingsTraits2 |
ACRX_DECLARE_MEMBERS(AcGiMentalRayRenderSettingsTraits) (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits |
ACRX_DECLARE_MEMBERS(AcGiRenderSettingsTraits) (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
backFacesEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
diagnosticBackgroundEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
diagnosticBSPMode() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
diagnosticGridMode(AcGiMrDiagnosticGridMode &mode, float &fSize) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
diagnosticMode() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
diagnosticPhotonMode() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
energyMultiplier() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
exportMIEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
exportMIFileName() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
exposureType() const =0 (defined in AcGiMentalRayRenderSettingsTraits2) | AcGiMentalRayRenderSettingsTraits2 | pure virtual
fgRayCount() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
fgSampleRadius(double &min, double &max) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
fgSampleRadiusState(bool &bMin, bool &bMax, bool &bPixels)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
finalGatheringEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
finalGatheringMode() const =0 (defined in AcGiMentalRayRenderSettingsTraits2) | AcGiMentalRayRenderSettingsTraits2 | pure virtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
giPhotonsPerLight() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
giSampleCount() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
giSampleRadius() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
giSampleRadiusEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
globalIlluminationEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightLuminanceScale() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
memoryLimit() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
modelScaleFactor(void) const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
photonTraceDepth(int &reflection, int &refraction, int &sum) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
progressMonitor(void) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rayTraceDepth(int &reflection, int &refraction, int &sum) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
rayTraceEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
sampling(int &min, int &max) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
samplingContrastColor(float &r, float &g, float &b, float &a) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
SamplingFilter(AcGiMrFilter &filter, double &width, double &height) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setBackFacesEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDiagnosticBackgroundEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setDiagnosticBSPMode(AcGiMrDiagnosticBSPMode mode)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setDiagnosticGridMode(AcGiMrDiagnosticGridMode mode, float fSize)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setDiagnosticMode(AcGiMrDiagnosticMode mode)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setDiagnosticPhotonMode(AcGiMrDiagnosticPhotonMode mode)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEnergyMultiplier(float fScale)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setExportMIEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setExportMIFileName(const ACHAR *miName)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setExposureType(AcGiMrExposureType type)=0 (defined in AcGiMentalRayRenderSettingsTraits2) | AcGiMentalRayRenderSettingsTraits2 | pure virtual
setFGRadiusState(bool bMin, bool bMax, bool bPixels)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setFGRayCount(int num)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setFGSampleRadius(double min, double max)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setFinalGatheringEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setFinalGatheringMode(AcGiMrFinalGatheringMode mode)=0 (defined in AcGiMentalRayRenderSettingsTraits2) | AcGiMentalRayRenderSettingsTraits2 | pure virtual
setGIPhotonsPerLight(int num)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setGISampleCount(int num)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setGISampleRadius(double radius)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setGISampleRadiusEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setGlobalIlluminationEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightLuminanceScale(double luminance)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setMaterialEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setMemoryLimit(int limit)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setModelScaleFactor(double scaleFactor)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setPhotonTraceDepth(int reflection, int refraction, int sum)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setProgressMonitor(void *pMonitor)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setRayTraceDepth(int reflection, int refraction, int sum)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setRayTraceEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setSampling(int min, int max)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setSamplingContrastColor(float r, float g, float b, float a)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setSamplingFilter(AcGiMrFilter filter, double width, double height)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowMapEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setShadowMode(AcGiMrShadowMode mode)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setShadowSamplingMultiplier(double multiplier)=0 (defined in AcGiMentalRayRenderSettingsTraits2) | AcGiMentalRayRenderSettingsTraits2 | pure virtual
setShadowsEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setTextureSampling(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTileOrder(AcGiMrTileOrder order)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setTileSize(int size)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowMapEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
shadowMode() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
shadowSamplingMultiplier() const =0 (defined in AcGiMentalRayRenderSettingsTraits2) | AcGiMentalRayRenderSettingsTraits2 | pure virtual
shadowsEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
textureSampling() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
tileOrder() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
tileSize() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiNonEntityTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiNonEntityTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiNonEntityTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiNonEntityTraits Member List

This is the complete list of members for AcGiNonEntityTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiPointLightTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiPointLightTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiPointLightTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiPointLightTraits)
virtual void | lightAttenuation (AcGiLightAttenuation &atten) const =0
virtual AcGePoint3d | position () const =0
virtual void | setAttenuation (const AcGiLightAttenuation &atten)=0
virtual void | setPosition (const AcGePoint3d &pos)=0
- Public Member Functions inherited from AcGiStandardLightTraits
ACRX_DECLARE_MEMBERS (AcGiStandardLightTraits)
virtual double | intensity () const =0
virtual AcCmColor | lightColor () const =0
virtual void | setIntensity (double inten)=0
virtual void | setLightColor (const AcCmColor &color)=0
virtual void | setShadowParameters (const AcGiShadowParameters &params)=0
virtual void | shadowParameters (AcGiShadowParameters &params) const =0
- Public Member Functions inherited from AcGiLightTraits
ACRX_DECLARE_MEMBERS (AcGiLightTraits)
virtual bool | isOn () const =0
virtual void | setOn (bool on)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: AcGiPointLightTraits2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiPointLightTraits2 Class Reference
AcGi Classes
+ Inheritance diagram for AcGiPointLightTraits2:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiPointLightTraits2)
virtual bool | hasTarget (void) const =0
virtual void | lampColor (AcGiColorRGB &rgbColor) const =0
virtual double | physicalIntensity () const =0
virtual void | setHasTarget (bool bHasTarget)=0
virtual void | setLampColor (const AcGiColorRGB &rgbColor)=0
virtual void | setPhysicalIntensity (double physicalIntensity)=0
virtual void | setShadowParameters (const AcGiShadowParameters2 &params)=0
virtual void | setTargetLocation (const AcGePoint3d &loc)=0
virtual void | shadowParameters (AcGiShadowParameters2 &params) const =0
virtual AcGePoint3d | targetLocation () const =0
- Public Member Functions inherited from AcGiPointLightTraits
ACRX_DECLARE_MEMBERS (AcGiPointLightTraits)
virtual void | lightAttenuation (AcGiLightAttenuation &atten) const =0
virtual AcGePoint3d | position () const =0
virtual void | setAttenuation (const AcGiLightAttenuation &atten)=0
virtual void | setPosition (const AcGePoint3d &pos)=0
- Public Member Functions inherited from AcGiStandardLightTraits
ACRX_DECLARE_MEMBERS (AcGiStandardLightTraits)
virtual double | intensity () const =0
virtual AcCmColor | lightColor () const =0
virtual void | setIntensity (double inten)=0
virtual void | setLightColor (const AcCmColor &color)=0
virtual void | setShadowParameters (const AcGiShadowParameters &params)=0
virtual void | shadowParameters (AcGiShadowParameters &params) const =0
- Public Member Functions inherited from AcGiLightTraits
ACRX_DECLARE_MEMBERS (AcGiLightTraits)
virtual bool | isOn () const =0
virtual void | setOn (bool on)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiPointLightTraits2 Member List

This is the complete list of members for AcGiPointLightTraits2, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiPointLightTraits2) (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 |
ACRX_DECLARE_MEMBERS(AcGiPointLightTraits) (defined in AcGiPointLightTraits) | AcGiPointLightTraits |
ACRX_DECLARE_MEMBERS(AcGiStandardLightTraits) (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits |
ACRX_DECLARE_MEMBERS(AcGiLightTraits) (defined in AcGiLightTraits) | AcGiLightTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
hasTarget(void) const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
intensity() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOn() const =0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
lampColor(AcGiColorRGB &rgbColor) const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightAttenuation(AcGiLightAttenuation &atten) const =0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
lightColor() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
physicalIntensity() const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
position() const =0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setAttenuation(const AcGiLightAttenuation &atten)=0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setHasTarget(bool bHasTarget)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setIntensity(double inten)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLampColor(const AcGiColorRGB &rgbColor)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightColor(const AcCmColor &color)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setOn(bool on)=0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
setPhysicalIntensity(double physicalIntensity)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPosition(const AcGePoint3d &pos)=0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowParameters(const AcGiShadowParameters2 &params)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setShadowParameters(const AcGiShadowParameters &params)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setTargetLocation(const AcGePoint3d &loc)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowParameters(AcGiShadowParameters2 &params) const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
shadowParameters(AcGiShadowParameters &params) const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
targetLocation() const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiProceduralTexture Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiProceduralTexture Class Reference
AcGi Classes
+ Inheritance diagram for AcGiProceduralTexture:

Public Types

enum Type { kWood = 0, kMarble, kGeneric }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiProceduralTexture)
- Public Member Functions inherited from AcGiMaterialTexture
ACRX_DECLARE_MEMBERS (AcGiMaterialTexture)
virtual bool | operator== (const AcGiMaterialTexture &texture) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiProceduralTexture Member List

This is the complete list of members for AcGiProceduralTexture, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiProceduralTexture) (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
ACRX_DECLARE_MEMBERS(AcGiMaterialTexture) (defined in AcGiMaterialTexture) | AcGiMaterialTexture |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kGeneric enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
kMarble enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
kWood enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
operator==(const AcGiMaterialTexture &texture) const (defined in AcGiMaterialTexture) | AcGiMaterialTexture | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
Type enum name (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiRenderEnvironmentTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiRenderEnvironmentTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiRenderEnvironmentTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiRenderEnvironmentTraits)
virtual bool | enable (void) const =0
virtual AcGiMaterialTexture * | environmentMap (void) const =0
virtual double | farDistance (void) const =0
virtual double | farPercentage (void) const =0
virtual AcCmEntityColor | fogColor (void) const =0
virtual bool | isBackground (void) const =0
virtual double | nearDistance (void) const =0
virtual double | nearPercentage (void) const =0
virtual void | setEnable (const bool bEnable)=0
virtual void | setEnvironmentMap (const AcGiMaterialTexture *map)=0
virtual void | setFarDistance (const double farDist)=0
virtual void | setFarPercentage (const double farPct)=0
virtual void | setFogColor (const AcCmEntityColor &color)=0
virtual void | setIsBackground (const bool bEnable)=0
virtual void | setNearDistance (const double nearDist)=0
virtual void | setNearPercentage (const double nearPct)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiRenderEnvironmentTraits Member List

This is the complete list of members for AcGiRenderEnvironmentTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiRenderEnvironmentTraits) (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
enable(void) const =0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
environmentMap(void) const =0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
farDistance(void) const =0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
farPercentage(void) const =0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
fogColor(void) const =0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isBackground(void) const =0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
nearDistance(void) const =0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
nearPercentage(void) const =0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEnable(const bool bEnable)=0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
setEnvironmentMap(const AcGiMaterialTexture *map)=0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
setFarDistance(const double farDist)=0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
setFarPercentage(const double farPct)=0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setFogColor(const AcCmEntityColor &color)=0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
setIsBackground(const bool bEnable)=0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setNearDistance(const double nearDist)=0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
setNearPercentage(const double nearPct)=0 (defined in AcGiRenderEnvironmentTraits) | AcGiRenderEnvironmentTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiRenderSettingsTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiRenderSettingsTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiRenderSettingsTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiRenderSettingsTraits)
virtual bool | backFacesEnabled () const =0
virtual bool | diagnosticBackgroundEnabled () const =0
virtual bool | materialEnabled () const =0
virtual double | modelScaleFactor (void) const =0
virtual void | setBackFacesEnabled (bool enabled)=0
virtual void | setDiagnosticBackgroundEnabled (bool enabled)=0
virtual void | setMaterialEnabled (bool enabled)=0
virtual void | setModelScaleFactor (double scaleFactor)=0
virtual void | setShadowsEnabled (bool enabled)=0
virtual void | setTextureSampling (bool enabled)=0
virtual bool | shadowsEnabled () const =0
virtual bool | textureSampling () const =0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiRenderSettingsTraits Member List

This is the complete list of members for AcGiRenderSettingsTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiRenderSettingsTraits) (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
backFacesEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
diagnosticBackgroundEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
modelScaleFactor(void) const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setBackFacesEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDiagnosticBackgroundEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setMaterialEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setModelScaleFactor(double scaleFactor)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowsEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setTextureSampling(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowsEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
textureSampling() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiShadowParameters Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiShadowParameters Class Reference
AcGi Classes
+ Inheritance diagram for AcGiShadowParameters:

Public Types

enum ShadowType { kShadowsRayTraced = 0, kShadowMaps, kAreaSampled }

Public Member Functions

AcGiShadowParameters ()
ACRX_DECLARE_MEMBERS (AcGiShadowParameters)
bool | operator== (const AcGiShadowParameters &params) const
virtual bool | setShadowMapSize (Adesk::UInt16 sz)
virtual bool | setShadowMapSoftness (Adesk::UInt8 soft)
virtual void | setShadowsOn (bool on)
virtual void | setShadowType (ShadowType typ)
virtual Adesk::UInt16 | shadowMapSize () const
virtual Adesk::UInt8 | shadowMapSoftness () const
virtual bool | shadowsOn () const
virtual ShadowType | shadowType () const
virtual | ~AcGiShadowParameters ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiShadowParameters::AcGiShadowParameters ( )
Warning
Not implemented!
virtual AcGiShadowParameters::~AcGiShadowParameters ( )
virtual
Warning
Not implemented!

Member Function Documentation

bool AcGiShadowParameters::operator== ( const AcGiShadowParameters & params ) const
Warning
Not implemented!
virtual bool AcGiShadowParameters::setShadowMapSize ( Adesk::UInt16 sz )
virtual
Warning
Not implemented!
virtual bool AcGiShadowParameters::setShadowMapSoftness ( Adesk::UInt8 soft )
virtual
Warning
Not implemented!
virtual void AcGiShadowParameters::setShadowsOn ( bool on )
virtual
Warning
Not implemented!
virtual void AcGiShadowParameters::setShadowType ( ShadowType typ )
virtual
Warning
Not implemented!
virtual Adesk::UInt16 AcGiShadowParameters::shadowMapSize ( ) const
virtual
Warning
Not implemented!
virtual Adesk::UInt8 AcGiShadowParameters::shadowMapSoftness ( ) const
virtual
Warning
Not implemented!
virtual bool AcGiShadowParameters::shadowsOn ( ) const
virtual
Warning
Not implemented!
virtual ShadowType AcGiShadowParameters::shadowType ( ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: AcGiShadowParameters2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Attributes | List of all members
AcGiShadowParameters2 Class Reference
AcGi Classes
+ Inheritance diagram for AcGiShadowParameters2:

Public Types

enum ExtendedLightShape {
kLinear = 0, kRectangle, kDisk, kCylinder,
kSphere
}
- Public Types inherited from AcGiShadowParameters
enum ShadowType { kShadowsRayTraced = 0, kShadowMaps, kAreaSampled }

Public Member Functions

AcGiShadowParameters2 (void)
AcGiShadowParameters2 (const AcGiShadowParameters &params)
ACRX_DECLARE_MEMBERS (AcGiShadowParameters2)
virtual double | extendedLightLength () const
virtual double | extendedLightRadius () const
virtual ExtendedLightShape | extendedLightShape () const
virtual double | extendedLightWidth () const
bool | operator== (const AcGiShadowParameters2 &params) const
virtual bool | setExtendedLightLength (double length)
virtual bool | setExtendedLightRadius (double radius)
virtual bool | setExtendedLightShape (ExtendedLightShape shape)
virtual bool | setExtendedLightWidth (double width)
virtual bool | setShadowSamples (Adesk::UInt16 samples)
virtual void | setShapeVisibility (bool visible)
virtual Adesk::UInt16 | shadowSamples () const
virtual bool | shapeVisibility () const
virtual | ~AcGiShadowParameters2 (void)
- Public Member Functions inherited from AcGiShadowParameters
AcGiShadowParameters ()
ACRX_DECLARE_MEMBERS (AcGiShadowParameters)
bool | operator== (const AcGiShadowParameters &params) const
virtual bool | setShadowMapSize (Adesk::UInt16 sz)
virtual bool | setShadowMapSoftness (Adesk::UInt8 soft)
virtual void | setShadowsOn (bool on)
virtual void | setShadowType (ShadowType typ)
virtual Adesk::UInt16 | shadowMapSize () const
virtual Adesk::UInt8 | shadowMapSoftness () const
virtual bool | shadowsOn () const
virtual ShadowType | shadowType () const
virtual | ~AcGiShadowParameters ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Attributes

bool | mbShapeVisibility
double | mExtLightLength
double | mExtLightRadius
ExtendedLightShape | mExtLightShape
double | mExtLightWidth
Adesk::UInt16 | mShadowSamples

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiShadowParameters2::AcGiShadowParameters2 ( void )
Warning
Not implemented!
AcGiShadowParameters2::AcGiShadowParameters2 ( const AcGiShadowParameters & params )
explicit
Warning
Not implemented!
virtual AcGiShadowParameters2::~AcGiShadowParameters2 ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual double AcGiShadowParameters2::extendedLightLength ( ) const
virtual
Warning
Not implemented!
virtual double AcGiShadowParameters2::extendedLightRadius ( ) const
virtual
Warning
Not implemented!
virtual ExtendedLightShape AcGiShadowParameters2::extendedLightShape ( ) const
virtual
Warning
Not implemented!
virtual double AcGiShadowParameters2::extendedLightWidth ( ) const
virtual
Warning
Not implemented!
bool AcGiShadowParameters2::operator== ( const AcGiShadowParameters2 & params ) const
Warning
Not implemented!
virtual bool AcGiShadowParameters2::setExtendedLightLength ( double length )
virtual
Warning
Not implemented!
virtual bool AcGiShadowParameters2::setExtendedLightRadius ( double radius )
virtual
Warning
Not implemented!
virtual bool AcGiShadowParameters2::setExtendedLightShape ( ExtendedLightShape shape )
virtual
Warning
Not implemented!
virtual bool AcGiShadowParameters2::setExtendedLightWidth ( double width )
virtual
Warning
Not implemented!
virtual bool AcGiShadowParameters2::setShadowSamples ( Adesk::UInt16 samples )
virtual
Warning
Not implemented!
virtual void AcGiShadowParameters2::setShapeVisibility ( bool visible )
virtual
Warning
Not implemented!
virtual Adesk::UInt16 AcGiShadowParameters2::shadowSamples ( ) const
virtual
Warning
Not implemented!
virtual bool AcGiShadowParameters2::shapeVisibility ( ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiShadowParameters2 Member List

This is the complete list of members for AcGiShadowParameters2, including all inherited members.

AcGiShadowParameters() | AcGiShadowParameters |
AcGiShadowParameters2(void) | AcGiShadowParameters2 |
AcGiShadowParameters2(const AcGiShadowParameters &params) | AcGiShadowParameters2 | explicit
ACRX_DECLARE_MEMBERS(AcGiShadowParameters2) (defined in AcGiShadowParameters2) | AcGiShadowParameters2 |
ACRX_DECLARE_MEMBERS(AcGiShadowParameters) (defined in AcGiShadowParameters) | AcGiShadowParameters |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
extendedLightLength() const | AcGiShadowParameters2 | virtual
extendedLightRadius() const | AcGiShadowParameters2 | virtual
extendedLightShape() const | AcGiShadowParameters2 | virtual
ExtendedLightShape enum name (defined in AcGiShadowParameters2) | AcGiShadowParameters2 |
extendedLightWidth() const | AcGiShadowParameters2 | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAreaSampled enum value (defined in AcGiShadowParameters) | AcGiShadowParameters |
kCylinder enum value (defined in AcGiShadowParameters2) | AcGiShadowParameters2 |
kDisk enum value (defined in AcGiShadowParameters2) | AcGiShadowParameters2 |
kLinear enum value (defined in AcGiShadowParameters2) | AcGiShadowParameters2 |
kRectangle enum value (defined in AcGiShadowParameters2) | AcGiShadowParameters2 |
kShadowMaps enum value (defined in AcGiShadowParameters) | AcGiShadowParameters |
kShadowsRayTraced enum value (defined in AcGiShadowParameters) | AcGiShadowParameters |
kSphere enum value (defined in AcGiShadowParameters2) | AcGiShadowParameters2 |
mbShapeVisibility (defined in AcGiShadowParameters2) | AcGiShadowParameters2 | protected
mExtLightLength (defined in AcGiShadowParameters2) | AcGiShadowParameters2 | protected
mExtLightRadius (defined in AcGiShadowParameters2) | AcGiShadowParameters2 | protected
mExtLightShape (defined in AcGiShadowParameters2) | AcGiShadowParameters2 | protected
mExtLightWidth (defined in AcGiShadowParameters2) | AcGiShadowParameters2 | protected
mShadowSamples (defined in AcGiShadowParameters2) | AcGiShadowParameters2 | protected
operator==(const AcGiShadowParameters2 &params) const | AcGiShadowParameters2 |
AcGiShadowParameters::operator==(const AcGiShadowParameters &params) const | AcGiShadowParameters |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setExtendedLightLength(double length) | AcGiShadowParameters2 | virtual
setExtendedLightRadius(double radius) | AcGiShadowParameters2 | virtual
setExtendedLightShape(ExtendedLightShape shape) | AcGiShadowParameters2 | virtual
setExtendedLightWidth(double width) | AcGiShadowParameters2 | virtual
setShadowMapSize(Adesk::UInt16 sz) | AcGiShadowParameters | virtual
setShadowMapSoftness(Adesk::UInt8 soft) | AcGiShadowParameters | virtual
setShadowSamples(Adesk::UInt16 samples) | AcGiShadowParameters2 | virtual
setShadowsOn(bool on) | AcGiShadowParameters | virtual
setShadowType(ShadowType typ) | AcGiShadowParameters | virtual
setShapeVisibility(bool visible) | AcGiShadowParameters2 | virtual
shadowMapSize() const | AcGiShadowParameters | virtual
shadowMapSoftness() const | AcGiShadowParameters | virtual
shadowSamples() const | AcGiShadowParameters2 | virtual
shadowsOn() const | AcGiShadowParameters | virtual
ShadowType enum name (defined in AcGiShadowParameters) | AcGiShadowParameters |
shadowType() const | AcGiShadowParameters | virtual
shapeVisibility() const | AcGiShadowParameters2 | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiShadowParameters() | AcGiShadowParameters | virtual
~AcGiShadowParameters2(void) | AcGiShadowParameters2 | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiSkyBackgroundTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiSkyBackgroundTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiSkyBackgroundTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiSkyBackgroundTraits)
virtual void | setSkyParameters (const AcGiSkyParameters &params)=0
virtual void | skyParameters (AcGiSkyParameters &params) const =0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiSkyBackgroundTraits Member List

This is the complete list of members for AcGiSkyBackgroundTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiSkyBackgroundTraits) (defined in AcGiSkyBackgroundTraits) | AcGiSkyBackgroundTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSkyParameters(const AcGiSkyParameters &params)=0 (defined in AcGiSkyBackgroundTraits) | AcGiSkyBackgroundTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
skyParameters(AcGiSkyParameters &params) const =0 (defined in AcGiSkyBackgroundTraits) | AcGiSkyBackgroundTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiSkyParameters Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcGiSkyParameters Class Reference
AcGi Classes
+ Inheritance diagram for AcGiSkyParameters:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiSkyParameters)
bool | aerialPerspective () const
double | diskIntensity () const
double | diskScale () const
double | glowIntensity () const
AcCmColor | groundColor () const
double | haze () const
double | horizonBlur () const
double | horizonHeight () const
bool | illumination () const
double | intensityFactor () const
AcCmColor | nightColor () const
bool | operator== (const AcGiSkyParameters &params) const
double | redBlueShift (void) const
double | saturation (void) const
void | setAerialPerspective (bool apply)
bool | setDiskIntensity (double intensity)
bool | setDiskScale (double scale)
bool | setGlowIntensity (double intensity)
void | setGroundColor (const AcCmColor &color)
bool | setHaze (double haze)
bool | setHorizonBlur (double blur)
bool | setHorizonHeight (double height)
void | setIllumination (bool enable)
bool | setIntensityFactor (double intensity)
void | setNightColor (const AcCmColor &color)
bool | setRedBlueShift (double redBlueShift)
bool | setSaturation (double saturation)
bool | setSolarDiskSamples (Adesk::UInt16 samples)
bool | setSunDirection (const AcGeVector3d &sundir)
bool | setVisibilityDistance (double distance)
Adesk::UInt16 | solarDiskSamples () const
const AcGeVector3d & | sunDirection () const
double | visibilityDistance () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

virtual bool | aerialPerspectiveImp () const
virtual double | diskIntensityImp () const
virtual double | diskScaleImp () const
virtual double | glowIntensityImp () const
virtual AcCmColor | groundColorImp () const
virtual double | hazeImp (void) const
virtual double | horizonBlurImp () const
virtual double | horizonHeightImp (void) const
virtual bool | illuminationImp (void) const
virtual double | intensityFactorImp () const
virtual AcCmColor | nightColorImp () const
virtual double | redBlueShiftImp (void) const
virtual double | saturationImp (void) const
virtual void | setAerialPerspectiveImp (bool apply)
virtual bool | setDiskIntensityImp (double intensity)
virtual bool | setDiskScaleImp (double scale)
virtual bool | setGlowIntensityImp (double intensity)
virtual void | setGroundColorImp (const AcCmColor &color)
virtual bool | setHazeImp (double haze)
virtual bool | setHorizonBlurImp (double blur)
virtual bool | setHorizonHeightImp (double height)
virtual void | setIlluminationImp (bool enable)
virtual bool | setIntensityFactorImp (double intensity)
virtual void | setNightColorImp (const AcCmColor &color)
virtual bool | setRedBlueShiftImp (double redBlueShift)
virtual bool | setSaturationImp (double saturation)
virtual bool | setSolarDiskSamplesImp (Adesk::UInt16 samples)
virtual bool | setSunDirectionImp (const AcGeVector3d &sundir)
virtual bool | setVisibilityDistanceImp (double distance)
virtual Adesk::UInt16 | solarDiskSamplesImp (void) const
virtual const AcGeVector3d & | sunDirectionImp (void) const
virtual double | visibilityDistanceImp () const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiSkyParameters Member List

This is the complete list of members for AcGiSkyParameters, including all inherited members.

AcGiSkyParameters() (defined in AcGiSkyParameters) | AcGiSkyParameters |
ACRX_DECLARE_MEMBERS(AcGiSkyParameters) (defined in AcGiSkyParameters) | AcGiSkyParameters |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
aerialPerspective() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
aerialPerspectiveImp() const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
diskIntensity() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
diskIntensityImp() const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
diskScale() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
diskScaleImp() const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
glowIntensity() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
glowIntensityImp() const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
groundColor() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
groundColorImp() const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
haze() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
hazeImp(void) const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
horizonBlur() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
horizonBlurImp() const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
horizonHeight() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
horizonHeightImp(void) const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
illumination() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
illuminationImp(void) const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
intensityFactor() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
intensityFactorImp() const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
nightColor() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
nightColorImp() const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
operator==(const AcGiSkyParameters &params) const (defined in AcGiSkyParameters) | AcGiSkyParameters |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
redBlueShift(void) const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
redBlueShiftImp(void) const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
saturation(void) const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
saturationImp(void) const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setAerialPerspective(bool apply) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setAerialPerspectiveImp(bool apply) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setDiskIntensity(double intensity) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setDiskIntensityImp(double intensity) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setDiskScale(double scale) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setDiskScaleImp(double scale) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setGlowIntensity(double intensity) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setGlowIntensityImp(double intensity) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setGroundColor(const AcCmColor &color) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setGroundColorImp(const AcCmColor &color) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setHaze(double haze) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setHazeImp(double haze) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setHorizonBlur(double blur) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setHorizonBlurImp(double blur) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setHorizonHeight(double height) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setHorizonHeightImp(double height) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setIllumination(bool enable) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setIlluminationImp(bool enable) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setIntensityFactor(double intensity) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setIntensityFactorImp(double intensity) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setNightColor(const AcCmColor &color) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setNightColorImp(const AcCmColor &color) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setRedBlueShift(double redBlueShift) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setRedBlueShiftImp(double redBlueShift) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setSaturation(double saturation) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setSaturationImp(double saturation) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setSolarDiskSamples(Adesk::UInt16 samples) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setSolarDiskSamplesImp(Adesk::UInt16 samples) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setSunDirection(const AcGeVector3d &sundir) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setSunDirectionImp(const AcGeVector3d &sundir) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
setVisibilityDistance(double distance) (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
setVisibilityDistanceImp(double distance) (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
solarDiskSamples() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
solarDiskSamplesImp(void) const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
sunDirection() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
sunDirectionImp(void) const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
visibilityDistance() const (defined in AcGiSkyParameters) | AcGiSkyParameters | inline
visibilityDistanceImp() const (defined in AcGiSkyParameters) | AcGiSkyParameters | protectedvirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiSkyParameters() (defined in AcGiSkyParameters) | AcGiSkyParameters | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiSolidBackgroundTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiSolidBackgroundTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiSolidBackgroundTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiSolidBackgroundTraits)
virtual AcCmEntityColor | colorSolid (void) const =0
virtual void | setColorSolid (const AcCmEntityColor &color)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiSolidBackgroundTraits Member List

This is the complete list of members for AcGiSolidBackgroundTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiSolidBackgroundTraits) (defined in AcGiSolidBackgroundTraits) | AcGiSolidBackgroundTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
colorSolid(void) const =0 (defined in AcGiSolidBackgroundTraits) | AcGiSolidBackgroundTraits | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setColorSolid(const AcCmEntityColor &color)=0 (defined in AcGiSolidBackgroundTraits) | AcGiSolidBackgroundTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiSpotLightTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiSpotLightTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiSpotLightTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiSpotLightTraits)
virtual double | falloff () const =0
virtual double | hotspot () const =0
virtual void | lightAttenuation (AcGiLightAttenuation &atten) const =0
virtual AcGePoint3d | position () const =0
virtual void | setAttenuation (const AcGiLightAttenuation &atten)=0
virtual bool | setHotspotAndFalloff (double hotspot, double falloff)=0
virtual void | setPosition (const AcGePoint3d &pos)=0
virtual void | setTargetLocation (const AcGePoint3d &loc)=0
virtual AcGePoint3d | targetLocation () const =0
- Public Member Functions inherited from AcGiStandardLightTraits
ACRX_DECLARE_MEMBERS (AcGiStandardLightTraits)
virtual double | intensity () const =0
virtual AcCmColor | lightColor () const =0
virtual void | setIntensity (double inten)=0
virtual void | setLightColor (const AcCmColor &color)=0
virtual void | setShadowParameters (const AcGiShadowParameters &params)=0
virtual void | shadowParameters (AcGiShadowParameters &params) const =0
- Public Member Functions inherited from AcGiLightTraits
ACRX_DECLARE_MEMBERS (AcGiLightTraits)
virtual bool | isOn () const =0
virtual void | setOn (bool on)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: AcGiSpotLightTraits2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiSpotLightTraits2 Class Reference
AcGi Classes
+ Inheritance diagram for AcGiSpotLightTraits2:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiSpotLightTraits2)
virtual void | lampColor (AcGiColorRGB &rgbColor) const =0
virtual double | physicalIntensity () const =0
virtual void | setLampColor (const AcGiColorRGB &rgbColor)=0
virtual void | setPhysicalIntensity (double physicalIntensity)=0
virtual void | setShadowParameters (const AcGiShadowParameters2 &params)=0
virtual void | shadowParameters (AcGiShadowParameters2 &params) const =0
- Public Member Functions inherited from AcGiSpotLightTraits
ACRX_DECLARE_MEMBERS (AcGiSpotLightTraits)
virtual double | falloff () const =0
virtual double | hotspot () const =0
virtual void | lightAttenuation (AcGiLightAttenuation &atten) const =0
virtual AcGePoint3d | position () const =0
virtual void | setAttenuation (const AcGiLightAttenuation &atten)=0
virtual bool | setHotspotAndFalloff (double hotspot, double falloff)=0
virtual void | setPosition (const AcGePoint3d &pos)=0
virtual void | setTargetLocation (const AcGePoint3d &loc)=0
virtual AcGePoint3d | targetLocation () const =0
- Public Member Functions inherited from AcGiStandardLightTraits
ACRX_DECLARE_MEMBERS (AcGiStandardLightTraits)
virtual double | intensity () const =0
virtual AcCmColor | lightColor () const =0
virtual void | setIntensity (double inten)=0
virtual void | setLightColor (const AcCmColor &color)=0
virtual void | setShadowParameters (const AcGiShadowParameters &params)=0
virtual void | shadowParameters (AcGiShadowParameters &params) const =0
- Public Member Functions inherited from AcGiLightTraits
ACRX_DECLARE_MEMBERS (AcGiLightTraits)
virtual bool | isOn () const =0
virtual void | setOn (bool on)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiSpotLightTraits2 Member List

This is the complete list of members for AcGiSpotLightTraits2, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiSpotLightTraits2) (defined in AcGiSpotLightTraits2) | AcGiSpotLightTraits2 |
ACRX_DECLARE_MEMBERS(AcGiSpotLightTraits) (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits |
ACRX_DECLARE_MEMBERS(AcGiStandardLightTraits) (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits |
ACRX_DECLARE_MEMBERS(AcGiLightTraits) (defined in AcGiLightTraits) | AcGiLightTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
falloff() const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
hotspot() const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
intensity() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOn() const =0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
lampColor(AcGiColorRGB &rgbColor) const =0 (defined in AcGiSpotLightTraits2) | AcGiSpotLightTraits2 | pure virtual
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightAttenuation(AcGiLightAttenuation &atten) const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
lightColor() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
physicalIntensity() const =0 (defined in AcGiSpotLightTraits2) | AcGiSpotLightTraits2 | pure virtual
position() const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setAttenuation(const AcGiLightAttenuation &atten)=0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setHotspotAndFalloff(double hotspot, double falloff)=0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
setIntensity(double inten)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLampColor(const AcGiColorRGB &rgbColor)=0 (defined in AcGiSpotLightTraits2) | AcGiSpotLightTraits2 | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightColor(const AcCmColor &color)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setOn(bool on)=0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
setPhysicalIntensity(double physicalIntensity)=0 (defined in AcGiSpotLightTraits2) | AcGiSpotLightTraits2 | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPosition(const AcGePoint3d &pos)=0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowParameters(const AcGiShadowParameters2 &params)=0 (defined in AcGiSpotLightTraits2) | AcGiSpotLightTraits2 | pure virtual
setShadowParameters(const AcGiShadowParameters &params)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setTargetLocation(const AcGePoint3d &loc)=0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowParameters(AcGiShadowParameters2 &params) const =0 (defined in AcGiSpotLightTraits2) | AcGiSpotLightTraits2 | pure virtual
shadowParameters(AcGiShadowParameters &params) const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
targetLocation() const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiStandardLightTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiStandardLightTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiStandardLightTraits:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiStandardLightTraits)
virtual double | intensity () const =0
virtual AcCmColor | lightColor () const =0
virtual void | setIntensity (double inten)=0
virtual void | setLightColor (const AcCmColor &color)=0
virtual void | setShadowParameters (const AcGiShadowParameters &params)=0
virtual void | shadowParameters (AcGiShadowParameters &params) const =0
- Public Member Functions inherited from AcGiLightTraits
ACRX_DECLARE_MEMBERS (AcGiLightTraits)
virtual bool | isOn () const =0
virtual void | setOn (bool on)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiStandardLightTraits Member List

This is the complete list of members for AcGiStandardLightTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiStandardLightTraits) (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits |
ACRX_DECLARE_MEMBERS(AcGiLightTraits) (defined in AcGiLightTraits) | AcGiLightTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
intensity() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOn() const =0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightColor() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setIntensity(double inten)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightColor(const AcCmColor &color)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setOn(bool on)=0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowParameters(const AcGiShadowParameters &params)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowParameters(AcGiShadowParameters &params) const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiSubEntityTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiSubEntityTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiSubEntityTraits:

Public Types

enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt16 | color (void) const =0
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcGiFillType | fillType (void) const =0
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual AcDbObjectId | layerId (void) const =0
virtual AcDbObjectId | lineTypeId (void) const =0
virtual double | lineTypeScale (void) const =0
virtual AcDb::LineWeight | lineWeight (void) const =0
virtual const AcGiMapper * | mapper (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | sectionable (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)=0
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setFillType (const AcGiFillType)=0
virtual void | setLayer (const AcDbObjectId layerId)=0
virtual void | setLineType (const AcDbObjectId linetypeId)=0
virtual void | setLineTypeScale (double dScale=1.0)=0
virtual void | setLineWeight (const AcDb::LineWeight lw)=0
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setMaterial (const AcDbObjectId materialId)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)=0
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setThickness (double dThickness)=0
virtual void | setTrueColor (const AcCmEntityColor &color)=0
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual double | thickness (void) const =0
virtual AcCmEntityColor | trueColor (void) const =0
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiSubEntityTraits Member List

This is the complete list of members for AcGiSubEntityTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
layerId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeScale(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineWeight(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLayer(const AcDbObjectId layerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineType(const AcDbObjectId linetypeId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineTypeScale(double dScale=1.0)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineWeight(const AcDb::LineWeight lw)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId materialId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double dThickness)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setTrueColor(const AcCmEntityColor &color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
thickness(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
trueColor(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiTextEngine Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcGiTextEngine Class Reference
AcGi Classes

Public Member Functions

virtual void | getExtents (AcGiTextStyle &ts, ACHAR const *pStr, int nLength, bool bPenUp, bool bRaw, AcGePoint2d &extents)=0
virtual void | tessellate (AcGiTextStyle &ts, ACHAR const *pStr, int nLength, bool bRaw, double deviation, void *pVoid, PolylineCallback pPolylineCallback)=0
virtual void | tessellate (AcGiTextStyle &ts, ACHAR const *pString, int nLength, bool bRaw, void *pVoid, UnicodeCallback pUnicodeCallback, PolylineCallback pPolylineCallback)=0

Static Public Member Functions

static AcGiTextEngine * create ()
The documentation for this class was generated from the following file:
  • textengine.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiTextEngine Member List

This is the complete list of members for AcGiTextEngine, including all inherited members.

create() (defined in AcGiTextEngine) | AcGiTextEngine | static
getExtents(AcGiTextStyle &ts, ACHAR const *pStr, int nLength, bool bPenUp, bool bRaw, AcGePoint2d &extents)=0 (defined in AcGiTextEngine) | AcGiTextEngine | pure virtual
tessellate(AcGiTextStyle &ts, ACHAR const *pStr, int nLength, bool bRaw, double deviation, void *pVoid, PolylineCallback pPolylineCallback)=0 (defined in AcGiTextEngine) | AcGiTextEngine | pure virtual
tessellate(AcGiTextStyle &ts, ACHAR const *pString, int nLength, bool bRaw, void *pVoid, UnicodeCallback pUnicodeCallback, PolylineCallback pPolylineCallback)=0 (defined in AcGiTextEngine) | AcGiTextEngine | pure virtual
~AcGiTextEngine() (defined in AcGiTextEngine) | AcGiTextEngine | inlinevirtual


ZRX API Reference: AcGiTextStyle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiTextStyle Class Reference
AcGi Classes
+ Inheritance diagram for AcGiTextStyle:

Public Member Functions

AcGiTextStyle (const ACHAR *fontName, const ACHAR *bigFontName, const double textSize, const double xScale, const double obliqueAngle, const double trPercent, const Adesk::Boolean isBackward, const Adesk::Boolean isUpsideDown, const Adesk::Boolean isVertical, const Adesk::Boolean isOverlined, const Adesk::Boolean isUnderlined, const Adesk::Boolean isStrikethrough=false, const ACHAR *styleName=NULL)
ACRX_DECLARE_MEMBERS (AcGiTextStyle)
virtual const ACHAR * | bigFontFileName () const
virtual AcGePoint2d | extents (const ACHAR *pStr, const Adesk::Boolean penups, const int len, const Adesk::Boolean raw, AcGiWorldDraw *ctxt=NULL) const
virtual Acad::ErrorStatus | extentsBox (const ACHAR *pStr, const Adesk::Boolean penups, const int len, const Adesk::Boolean raw, AcGePoint2d &extMin, AcGePoint2d &extMax, AcGiWorldDraw *ctxt=NULL) const
virtual const ACHAR * | fileName () const
virtual Acad::ErrorStatus | font (ACHAR *&pTypeface, Adesk::Boolean &bold, Adesk::Boolean &italic, int &charset, int &pitchAndFamily) const
virtual Adesk::Boolean | isBackward () const
virtual Adesk::Boolean | isOverlined () const
virtual Adesk::Boolean | isStrikethrough () const
virtual Adesk::Boolean | isUnderlined () const
virtual Adesk::Boolean | isUpsideDown () const
virtual Adesk::Boolean | isVertical () const
virtual int | loadStyleRec () const
virtual double | obliquingAngle () const
virtual bool | preLoaded () const
virtual void | setBackward (const Adesk::Boolean isBackward)
virtual void | setBigFontFileName (const ACHAR *bigFontFileName)
virtual void | setFileName (const ACHAR *fontName)
virtual Acad::ErrorStatus | setFont (const ACHAR *pTypeface, Adesk::Boolean bold, Adesk::Boolean italic, int charset, int pitchAndFamily)
virtual void | setObliquingAngle (const double obliquingAngle)
virtual void | setOverlined (const Adesk::Boolean isOverlined)
virtual void | setPreLoaded (bool)
virtual Acad::ErrorStatus | setStyleName (const ACHAR *)
virtual void | setTextSize (const double size)
virtual void | setTrackingPercent (const double trPercent)
virtual void | setTrackKerning (double trackPercent) const
virtual void | setUnderlined (const Adesk::Boolean isUnderlined)
virtual void | setUpsideDown (const Adesk::Boolean isUpsideDown)
virtual void | setVertical (const Adesk::Boolean isVertical)
virtual void | setXScale (const double xScale)
virtual const ACHAR * | styleName () const
virtual double | textSize () const
virtual double | trackingPercent () const
virtual double | xScale () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiTextStyle Member List

This is the complete list of members for AcGiTextStyle, including all inherited members.

AcGiTextStyle() (defined in AcGiTextStyle) | AcGiTextStyle |
AcGiTextStyle(const ACHAR *fontName, const ACHAR *bigFontName, const double textSize, const double xScale, const double obliqueAngle, const double trPercent, const Adesk::Boolean isBackward, const Adesk::Boolean isUpsideDown, const Adesk::Boolean isVertical, const Adesk::Boolean isOverlined, const Adesk::Boolean isUnderlined, const Adesk::Boolean isStrikethrough=false, const ACHAR *styleName=NULL) (defined in AcGiTextStyle) | AcGiTextStyle |
ACRX_DECLARE_MEMBERS(AcGiTextStyle) (defined in AcGiTextStyle) | AcGiTextStyle |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
bigFontFileName() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
extents(const ACHAR *pStr, const Adesk::Boolean penups, const int len, const Adesk::Boolean raw, AcGiWorldDraw *ctxt=NULL) const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
extentsBox(const ACHAR *pStr, const Adesk::Boolean penups, const int len, const Adesk::Boolean raw, AcGePoint2d &extMin, AcGePoint2d &extMax, AcGiWorldDraw *ctxt=NULL) const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
fileName() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
font(ACHAR *&pTypeface, Adesk::Boolean &bold, Adesk::Boolean &italic, int &charset, int &pitchAndFamily) const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isBackward() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOverlined() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
isStrikethrough() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
isUnderlined() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
isUpsideDown() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
isVertical() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
loadStyleRec() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
obliquingAngle() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
preLoaded() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setBackward(const Adesk::Boolean isBackward) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setBigFontFileName(const ACHAR *bigFontFileName) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setFileName(const ACHAR *fontName) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setFont(const ACHAR *pTypeface, Adesk::Boolean bold, Adesk::Boolean italic, int charset, int pitchAndFamily) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setObliquingAngle(const double obliquingAngle) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setOverlined(const Adesk::Boolean isOverlined) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setPreLoaded(bool) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setStyleName(const ACHAR *) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setTextSize(const double size) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setTrackingPercent(const double trPercent) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setTrackKerning(double trackPercent) const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setUnderlined(const Adesk::Boolean isUnderlined) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setUpsideDown(const Adesk::Boolean isUpsideDown) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setVertical(const Adesk::Boolean isVertical) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
setXScale(const double xScale) (defined in AcGiTextStyle) | AcGiTextStyle | virtual
styleName() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
textSize() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
trackingPercent() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xScale() const (defined in AcGiTextStyle) | AcGiTextStyle | virtual
~AcGiTextStyle() (defined in AcGiTextStyle) | AcGiTextStyle |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiToneOperatorParameters Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiToneOperatorParameters Class Reference
AcGi Classes
+ Inheritance diagram for AcGiToneOperatorParameters:

Public Types

enum ExteriorDaylightMode { kDaylightOff = 0, kDaylightOn, kDaylightAuto }

Public Member Functions

AcGiToneOperatorParameters ()
ACRX_DECLARE_MEMBERS (AcGiToneOperatorParameters)
virtual double | brightness () const
virtual bool | chromaticAdaptation () const
virtual bool | colorDifferentiation () const
virtual double | contrast () const
virtual ExteriorDaylightMode | exteriorDaylight () const
virtual bool | isActive () const
virtual double | midTones () const
bool | operator== (const AcGiToneOperatorParameters &params) const
virtual bool | processBackground () const
virtual bool | setBrightness (double brightness)
virtual void | setChromaticAdaptation (bool enable)
virtual void | setColorDifferentiation (bool enable)
virtual bool | setContrast (double contrast)
virtual bool | setExteriorDaylight (ExteriorDaylightMode mode)
virtual void | setIsActive (bool active)
virtual bool | setMidTones (double midTones)
virtual void | setProcessBackground (bool processBG)
virtual void | setWhiteColor (const AcCmColor &color)
virtual AcCmColor | whiteColor () const
virtual | ~AcGiToneOperatorParameters ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiToneOperatorParameters::AcGiToneOperatorParameters ( )
Warning
Not implemented!
virtual AcGiToneOperatorParameters::~AcGiToneOperatorParameters ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual double AcGiToneOperatorParameters::brightness ( ) const
virtual
Warning
Not implemented!
virtual bool AcGiToneOperatorParameters::chromaticAdaptation ( ) const
virtual
Warning
Not implemented!
virtual bool AcGiToneOperatorParameters::colorDifferentiation ( ) const
virtual
Warning
Not implemented!
virtual double AcGiToneOperatorParameters::contrast ( ) const
virtual
Warning
Not implemented!
virtual ExteriorDaylightMode AcGiToneOperatorParameters::exteriorDaylight ( ) const
virtual
Warning
Not implemented!
virtual bool AcGiToneOperatorParameters::isActive ( ) const
virtual
Warning
Not implemented!
virtual double AcGiToneOperatorParameters::midTones ( ) const
virtual
Warning
Not implemented!
bool AcGiToneOperatorParameters::operator== ( const AcGiToneOperatorParameters & params ) const
Warning
Not implemented!
virtual bool AcGiToneOperatorParameters::processBackground ( ) const
virtual
Warning
Not implemented!
virtual bool AcGiToneOperatorParameters::setBrightness ( double brightness )
virtual
Warning
Not implemented!
virtual void AcGiToneOperatorParameters::setChromaticAdaptation ( bool enable )
virtual
Warning
Not implemented!
virtual void AcGiToneOperatorParameters::setColorDifferentiation ( bool enable )
virtual
Warning
Not implemented!
virtual bool AcGiToneOperatorParameters::setContrast ( double contrast )
virtual
Warning
Not implemented!
virtual bool AcGiToneOperatorParameters::setExteriorDaylight ( ExteriorDaylightMode mode )
virtual
Warning
Not implemented!
virtual void AcGiToneOperatorParameters::setIsActive ( bool active )
virtual
Warning
Not implemented!
virtual bool AcGiToneOperatorParameters::setMidTones ( double midTones )
virtual
Warning
Not implemented!
virtual void AcGiToneOperatorParameters::setProcessBackground ( bool processBG )
virtual
Warning
Not implemented!
virtual void AcGiToneOperatorParameters::setWhiteColor ( const AcCmColor & color )
virtual
Warning
Not implemented!
virtual AcCmColor AcGiToneOperatorParameters::whiteColor ( ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcGiEnvironment.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiToneOperatorParameters Member List

This is the complete list of members for AcGiToneOperatorParameters, including all inherited members.

AcGiToneOperatorParameters() | AcGiToneOperatorParameters |
ACRX_DECLARE_MEMBERS(AcGiToneOperatorParameters) (defined in AcGiToneOperatorParameters) | AcGiToneOperatorParameters |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
brightness() const | AcGiToneOperatorParameters | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
chromaticAdaptation() const | AcGiToneOperatorParameters | virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
colorDifferentiation() const | AcGiToneOperatorParameters | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const | AcGiToneOperatorParameters | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
exteriorDaylight() const | AcGiToneOperatorParameters | virtual
ExteriorDaylightMode enum name (defined in AcGiToneOperatorParameters) | AcGiToneOperatorParameters |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isActive() const | AcGiToneOperatorParameters | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDaylightAuto enum value (defined in AcGiToneOperatorParameters) | AcGiToneOperatorParameters |
kDaylightOff enum value (defined in AcGiToneOperatorParameters) | AcGiToneOperatorParameters |
kDaylightOn enum value (defined in AcGiToneOperatorParameters) | AcGiToneOperatorParameters |
midTones() const | AcGiToneOperatorParameters | virtual
operator==(const AcGiToneOperatorParameters &params) const | AcGiToneOperatorParameters |
processBackground() const | AcGiToneOperatorParameters | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setBrightness(double brightness) | AcGiToneOperatorParameters | virtual
setChromaticAdaptation(bool enable) | AcGiToneOperatorParameters | virtual
setColorDifferentiation(bool enable) | AcGiToneOperatorParameters | virtual
setContrast(double contrast) | AcGiToneOperatorParameters | virtual
setExteriorDaylight(ExteriorDaylightMode mode) | AcGiToneOperatorParameters | virtual
setIsActive(bool active) | AcGiToneOperatorParameters | virtual
setMidTones(double midTones) | AcGiToneOperatorParameters | virtual
setProcessBackground(bool processBG) | AcGiToneOperatorParameters | virtual
setWhiteColor(const AcCmColor &color) | AcGiToneOperatorParameters | virtual
whiteColor() const | AcGiToneOperatorParameters | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiToneOperatorParameters() | AcGiToneOperatorParameters | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiVariant Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Classes | Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcGiVariant Class Reference
AcGi Classes
+ Inheritance diagram for AcGiVariant:

Classes

class EnumType

Public Types

enum VariantType {
kUndefined = 0, kBoolean, kInt, kDouble,
kColor, kString, kTable
}

Public Member Functions

AcGiVariant (void)
AcGiVariant (const AcGiVariant &value)
AcGiVariant (bool)
AcGiVariant (long)
AcGiVariant (double)
AcGiVariant (const AcCmColor &)
AcGiVariant (const ACHAR *)
ACRX_DECLARE_MEMBERS (AcGiVariant)
bool | asBoolean () const
ACDB_PORT char | asChar () const
AcCmColor | asColor () const
double | asDouble () const
ACDB_PORT EnumType | asEnum () const
ACDB_PORT float | asFloat () const
int | asInt () const
ACDB_PORT long | asLong () const
ACDB_PORT short | asShort () const
AcString | asString () const
ACDB_PORT unsigned char | asUchar () const
ACDB_PORT unsigned int | asUint () const
ACDB_PORT unsigned long | asUlong () const
ACDB_PORT unsigned short | asUshort () const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
void | deleteElem (ACHAR *const)
Acad::ErrorStatus | getElem (ACHAR *const, AcGiVariant &value) const
const AcGiVariant * | getElem (ACHAR *const) const
Acad::ErrorStatus | getElemAt (const int, ACHAR *&, AcGiVariant &) const
AcGiVariant * | getElemAt (const int, ACHAR *&) const
int | getElemCount () const
AcGiVariant & | operator= (const AcGiVariant &value)
virtual bool | operator== (const AcGiVariant &value) const
void | set (bool)
void | set (long)
void | set (double)
void | set (const AcCmColor &)
void | set (const ACHAR *)
void | setElem (ACHAR *const, const AcGiVariant &)
VariantType | type () const
virtual | ~AcGiVariant (void)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static bool | isEquivalent (AcGiVariant *, AcGiVariant *)
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiVariant::AcGiVariant ( void )
Warning
Not implemented!
virtual AcGiVariant::~AcGiVariant ( void )
virtual
Warning
Not implemented!
AcGiVariant::AcGiVariant ( const AcGiVariant & value )
Warning
Not implemented!
AcGiVariant::AcGiVariant ( bool )
Warning
Not implemented!
AcGiVariant::AcGiVariant ( long )
Warning
Not implemented!
AcGiVariant::AcGiVariant ( double )
Warning
Not implemented!
AcGiVariant::AcGiVariant ( const AcCmColor & )
Warning
Not implemented!
AcGiVariant::AcGiVariant ( const ACHAR * )
Warning
Not implemented!

Member Function Documentation

bool AcGiVariant::asBoolean ( ) const
Warning
Not implemented!
ACDB_PORT char AcGiVariant::asChar ( ) const
Warning
Not implemented!
AcCmColor AcGiVariant::asColor ( ) const
Warning
Not implemented!
double AcGiVariant::asDouble ( ) const
Warning
Not implemented!
ACDB_PORT EnumType AcGiVariant::asEnum ( ) const
Warning
Not implemented!
ACDB_PORT float AcGiVariant::asFloat ( ) const
Warning
Not implemented!
int AcGiVariant::asInt ( ) const
Warning
Not implemented!
ACDB_PORT long AcGiVariant::asLong ( ) const
Warning
Not implemented!
ACDB_PORT short AcGiVariant::asShort ( ) const
Warning
Not implemented!
AcString AcGiVariant::asString ( ) const
Warning
Not implemented!
ACDB_PORT unsigned char AcGiVariant::asUchar ( ) const
Warning
Not implemented!
ACDB_PORT unsigned int AcGiVariant::asUint ( ) const
Warning
Not implemented!
ACDB_PORT unsigned long AcGiVariant::asUlong ( ) const
Warning
Not implemented!
ACDB_PORT unsigned short AcGiVariant::asUshort ( ) const
Warning
Not implemented!
virtual Acad::ErrorStatus AcGiVariant::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcRxObject.

void AcGiVariant::deleteElem ( ACHAR * const )
Warning
Not implemented!
Acad::ErrorStatus AcGiVariant::getElem | ( | ACHAR * | const,
 |  | AcGiVariant & | value
 | ) |  | const
Warning
Not implemented!
const AcGiVariant* AcGiVariant::getElem ( ACHAR * const ) const
Warning
Not implemented!
Acad::ErrorStatus AcGiVariant::getElemAt | ( | const int | ,
 |  | ACHAR *& | ,
 |  | AcGiVariant & |
 | ) |  | const
Warning
Not implemented!
AcGiVariant* AcGiVariant::getElemAt | ( | const int | ,
 |  | ACHAR *& |
 | ) |  | const
Warning
Not implemented!
int AcGiVariant::getElemCount ( ) const
Warning
Not implemented!
static bool AcGiVariant::isEquivalent | ( | AcGiVariant * | ,
 |  | AcGiVariant * |
 | ) |  |
static
Warning
Not implemented!
AcGiVariant& AcGiVariant::operator= ( const AcGiVariant & value )
Warning
Not implemented!
virtual bool AcGiVariant::operator== ( const AcGiVariant & value ) const
virtual
Warning
Not implemented!
void AcGiVariant::set ( bool )
Warning
Not implemented!
void AcGiVariant::set ( long )
Warning
Not implemented!
void AcGiVariant::set ( double )
Warning
Not implemented!
void AcGiVariant::set ( const AcCmColor & )
Warning
Not implemented!
void AcGiVariant::set ( const ACHAR * )
Warning
Not implemented!
void AcGiVariant::setElem | ( | ACHAR * | const,
 |  | const AcGiVariant & |
 | ) |  |
Warning
Not implemented!
VariantType AcGiVariant::type ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiVariant Member List

This is the complete list of members for AcGiVariant, including all inherited members.

AcGiVariant(void) | AcGiVariant |
AcGiVariant(const AcGiVariant &value) | AcGiVariant |
AcGiVariant(bool) | AcGiVariant |
AcGiVariant(long) | AcGiVariant |
AcGiVariant(double) | AcGiVariant |
AcGiVariant(const AcCmColor &) | AcGiVariant |
AcGiVariant(const ACHAR *) | AcGiVariant |
ACRX_DECLARE_MEMBERS(AcGiVariant) (defined in AcGiVariant) | AcGiVariant |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
asBoolean() const | AcGiVariant |
asChar() const | AcGiVariant |
asColor() const | AcGiVariant |
asDouble() const | AcGiVariant |
asEnum() const | AcGiVariant |
asFloat() const | AcGiVariant |
asInt() const | AcGiVariant |
asLong() const | AcGiVariant |
asShort() const | AcGiVariant |
asString() const | AcGiVariant |
asUchar() const | AcGiVariant |
asUint() const | AcGiVariant |
asUlong() const | AcGiVariant |
asUshort() const | AcGiVariant |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) | AcGiVariant | virtual
deleteElem(ACHAR *const) | AcGiVariant |
desc() (defined in AcRxObject) | AcRxObject | static
getElem(ACHAR *const, AcGiVariant &value) const | AcGiVariant |
getElem(ACHAR *const) const | AcGiVariant |
getElemAt(const int, ACHAR *&, AcGiVariant &) const | AcGiVariant |
getElemAt(const int, ACHAR *&) const | AcGiVariant |
getElemCount() const | AcGiVariant |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isEquivalent(AcGiVariant *, AcGiVariant *) | AcGiVariant | static
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kBoolean enum value (defined in AcGiVariant) | AcGiVariant |
kColor enum value (defined in AcGiVariant) | AcGiVariant |
kDouble enum value (defined in AcGiVariant) | AcGiVariant |
kInt enum value (defined in AcGiVariant) | AcGiVariant |
kString enum value (defined in AcGiVariant) | AcGiVariant |
kTable enum value (defined in AcGiVariant) | AcGiVariant |
kUndefined enum value (defined in AcGiVariant) | AcGiVariant |
operator=(const AcGiVariant &value) | AcGiVariant |
operator==(const AcGiVariant &value) const | AcGiVariant | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
set(bool) | AcGiVariant |
set(long) | AcGiVariant |
set(double) | AcGiVariant |
set(const AcCmColor &) | AcGiVariant |
set(const ACHAR *) | AcGiVariant |
setElem(ACHAR *const, const AcGiVariant &) | AcGiVariant |
type() const | AcGiVariant |
VariantType enum name (defined in AcGiVariant) | AcGiVariant |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiVariant(void) | AcGiVariant | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiVertexData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiVertexData Class Reference
AcGi Classes
+ Inheritance diagram for AcGiVertexData:

Public Types

enum MapChael { kAllChaels, kMapChaels }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiVertexData)
AcGePoint3d * | mappingCoords (MapChael mapChael) const
virtual AcGeVector3d * | normals () const
virtual AcGiOrientationType | orientationFlag () const
void | setMappingCoords (MapChael mapChael, const AcGePoint3d *pCoords)
virtual void | setNormals (const AcGeVector3d *pNormals)
virtual void | setOrientationFlag (const AcGiOrientationType oflag)
virtual void | setTrueColors (const AcCmEntityColor *colors)
virtual AcCmEntityColor * | trueColors () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiVertexData Member List

This is the complete list of members for AcGiVertexData, including all inherited members.

AcGiVertexData() (defined in AcGiVertexData) | AcGiVertexData |
ACRX_DECLARE_MEMBERS(AcGiVertexData) (defined in AcGiVertexData) | AcGiVertexData |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAllChaels enum value (defined in AcGiVertexData) | AcGiVertexData |
kMapChaels enum value (defined in AcGiVertexData) | AcGiVertexData |
MapChael enum name (defined in AcGiVertexData) | AcGiVertexData |
mappingCoords(MapChael mapChael) const (defined in AcGiVertexData) | AcGiVertexData |
normals() const (defined in AcGiVertexData) | AcGiVertexData | virtual
orientationFlag() const (defined in AcGiVertexData) | AcGiVertexData | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setMappingCoords(MapChael mapChael, const AcGePoint3d *pCoords) (defined in AcGiVertexData) | AcGiVertexData |
setNormals(const AcGeVector3d *pNormals) (defined in AcGiVertexData) | AcGiVertexData | virtual
setOrientationFlag(const AcGiOrientationType oflag) (defined in AcGiVertexData) | AcGiVertexData | virtual
setTrueColors(const AcCmEntityColor *colors) (defined in AcGiVertexData) | AcGiVertexData | virtual
trueColors() const (defined in AcGiVertexData) | AcGiVertexData | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiVertexData() (defined in AcGiVertexData) | AcGiVertexData |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiViewport Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiViewport Class Reference
AcGi Classes
+ Inheritance diagram for AcGiViewport:

Public Member Functions

virtual Adesk::Int16 | acadWindowId () const =0
ACRX_DECLARE_MEMBERS (AcGiViewport)
virtual const
AcGiContextualColors * 		contextualColors () const
virtual Adesk::Boolean | doInversePerspective (AcGePoint3d &) const =0
virtual Adesk::Boolean | doPerspective (AcGePoint3d &) const =0
virtual void | getCameraLocation (AcGePoint3d &location) const =0
virtual void | getCameraTarget (AcGePoint3d &target) const =0
virtual void | getCameraUpVector (AcGeVector3d &upVector) const =0
virtual void | getEyeToModelTransform (AcGeMatrix3d &) const =0
virtual void | getEyeToWorldTransform (AcGeMatrix3d &) const =0
virtual Adesk::Boolean | getFrontAndBackClipValues (Adesk::Boolean &clip_front, Adesk::Boolean &clip_back, double &front, double &back) const =0
virtual void | getModelToEyeTransform (AcGeMatrix3d &) const =0
virtual void | getNumPixelsInUnitSquare (const AcGePoint3d &givenWorldpt, AcGePoint2d &pixelArea, bool includePerspective=true) const =0
virtual void | getViewportDcCorners (AcGePoint2d &lower_left, AcGePoint2d &upper_right) const =0
virtual void | getWorldToEyeTransform (AcGeMatrix3d &) const =0
virtual Adesk::Boolean | isPerspective () const =0
virtual Adesk::Boolean | layerVisible (const AcDbObjectId &idLayer) const
virtual double | linetypeGenerationCriteria () const =0
virtual double | linetypeScaleMultiplier () const =0
virtual AcGeVector3d | viewDir () const
virtual Adesk::ULongPtr | viewportId () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiViewport Member List

This is the complete list of members for AcGiViewport, including all inherited members.

acadWindowId() const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
ACRX_DECLARE_MEMBERS(AcGiViewport) (defined in AcGiViewport) | AcGiViewport |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contextualColors() const (defined in AcGiViewport) | AcGiViewport | inlinevirtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
doInversePerspective(AcGePoint3d &) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
doPerspective(AcGePoint3d &) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getCameraLocation(AcGePoint3d &location) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getCameraTarget(AcGePoint3d &target) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getCameraUpVector(AcGeVector3d &upVector) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getEyeToModelTransform(AcGeMatrix3d &) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getEyeToWorldTransform(AcGeMatrix3d &) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getFrontAndBackClipValues(Adesk::Boolean &clip_front, Adesk::Boolean &clip_back, double &front, double &back) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getModelToEyeTransform(AcGeMatrix3d &) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getNumPixelsInUnitSquare(const AcGePoint3d &givenWorldpt, AcGePoint2d &pixelArea, bool includePerspective=true) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getViewportDcCorners(AcGePoint2d &lower_left, AcGePoint2d &upper_right) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
getWorldToEyeTransform(AcGeMatrix3d &) const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isPerspective() const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
layerVisible(const AcDbObjectId &idLayer) const (defined in AcGiViewport) | AcGiViewport | inlinevirtual
linetypeGenerationCriteria() const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
linetypeScaleMultiplier() const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
viewDir() const (defined in AcGiViewport) | AcGiViewport | inlinevirtual
viewportId() const =0 (defined in AcGiViewport) | AcGiViewport | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiViewportDraw Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiViewportDraw Class Reference
AcGi Classes
+ Inheritance diagram for AcGiViewportDraw:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiViewportDraw)
virtual AcGiViewportGeometry & | geometry () const =0
virtual Adesk::Boolean | isValidId (const Adesk::ULongPtr acgiId) const =0
virtual Adesk::UInt32 | sequenceNumber () const =0
virtual AcGiViewport & | viewport () const =0
virtual AcDbObjectId | viewportObjectId () const =0
- Public Member Functions inherited from AcGiCommonDraw
ACRX_DECLARE_MEMBERS (AcGiCommonDraw)
virtual AcGiContext * | context ()=0
virtual double | deviation (const AcGiDeviationType, const AcGePoint3d &) const =0
virtual Adesk::Boolean | isDragging () const =0
virtual Adesk::UInt32 | numberOfIsolines () const =0
virtual AcGiGeometry * | rawGeometry () const =0
virtual Adesk::Boolean | regenAbort () const =0
virtual AcGiRegenType | regenType () const =0
virtual bool | secondaryCall () const
virtual AcGiSubEntityTraits & | subEntityTraits () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiViewportDraw Member List

This is the complete list of members for AcGiViewportDraw, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiViewportDraw) (defined in AcGiViewportDraw) | AcGiViewportDraw |
ACRX_DECLARE_MEMBERS(AcGiCommonDraw) (defined in AcGiCommonDraw) | AcGiCommonDraw |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
context()=0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
deviation(const AcGiDeviationType, const AcGePoint3d &) const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
geometry() const =0 (defined in AcGiViewportDraw) | AcGiViewportDraw | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isDragging() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isValidId(const Adesk::ULongPtr acgiId) const =0 (defined in AcGiViewportDraw) | AcGiViewportDraw | pure virtual
numberOfIsolines() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rawGeometry() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
regenAbort() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
regenType() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
secondaryCall() const (defined in AcGiCommonDraw) | AcGiCommonDraw | inlinevirtual
sequenceNumber() const =0 (defined in AcGiViewportDraw) | AcGiViewportDraw | pure virtual
subEntityTraits() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
viewport() const =0 (defined in AcGiViewportDraw) | AcGiViewportDraw | pure virtual
viewportObjectId() const =0 (defined in AcGiViewportDraw) | AcGiViewportDraw | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiViewportGeometry Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiViewportGeometry Class Reference
AcGi Classes
+ Inheritance diagram for AcGiViewportGeometry:

Public Types

enum ImageSource { kFromDwg, kFromOleObject, kFromRender }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiViewportGeometry)
virtual Adesk::Boolean | ownerDraw3d (AcGePoint3d &minBounds, AcGePoint3d &maxBounds, OwnerDraw3d *pOwnerDraw) const
virtual Adesk::Boolean | ownerDrawDc (long vpnumber, long left, long top, long right, long bottom, const OwnerDraw *pOwnerDraw) const =0
virtual Adesk::Boolean | polygonDc (const Adesk::UInt32 nbPoints, const AcGePoint3d *pPoints) const =0
virtual Adesk::Boolean | polygonEye (const Adesk::UInt32 nbPoints, const AcGePoint3d *pPoints) const =0
virtual Adesk::Boolean | polylineDc (const Adesk::UInt32 nbPoints, const AcGePoint3d *pPoints) const =0
virtual Adesk::Boolean | polylineEye (const Adesk::UInt32 nbPoints, const AcGePoint3d *pPoints) const =0
virtual Adesk::Boolean | rasterImageDc (const AcGePoint3d &origin, const AcGeVector3d &u, const AcGeVector3d &v, const AcGeMatrix2d &pixelToDc, AcDbObjectId entityId, AcGiImageOrg imageOrg, Adesk::UInt32 imageWidth, Adesk::UInt32 imageHeight, Adesk::Int16 imageColorDepth, Adesk::Boolean transparency, ImageSource source, const AcGeVector3d &unrotatedU, const AcGiImageOrg origionalImageOrg, const AcGeMatrix2d &unrotatedPixelToDc, const Adesk::UInt32 unrotatedImageWidth, const Adesk::UInt32 unrotatedImageHeight) const =0
- Public Member Functions inherited from AcGiGeometry
ACRX_DECLARE_MEMBERS (AcGiGeometry)
virtual Adesk::Boolean | circle (const AcGePoint3d &center, const double radius, const AcGeVector3d &normal) const =0
virtual Adesk::Boolean | circle (const AcGePoint3d &, const AcGePoint3d &, const AcGePoint3d &) const =0
virtual Adesk::Boolean | circularArc (const AcGePoint3d &center, const double radius, const AcGeVector3d &normal, const AcGeVector3d &startVector, const double sweepAngle, const AcGiArcType arcType=kAcGiArcSimple) const =0
virtual Adesk::Boolean | circularArc (const AcGePoint3d &start, const AcGePoint3d &point, const AcGePoint3d &end, const AcGiArcType arcType=kAcGiArcSimple) const =0
virtual Adesk::Boolean | draw (AcGiDrawable *) const =0
virtual void | getModelToWorldTransform (AcGeMatrix3d &) const =0
virtual void | getWorldToModelTransform (AcGeMatrix3d &) const =0
virtual Adesk::Boolean | mesh (const Adesk::UInt32 rows, const Adesk::UInt32 columns, const AcGePoint3d *pVertexList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const bool bAutoGenerateNormals=true) const =0
virtual Adesk::Boolean | pline (const AcDbPolyline &lwBuf, Adesk::UInt32 fromIndex=0, Adesk::UInt32 numSegs=0) const =0
virtual Adesk::Boolean | polygon (const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList) const =0
virtual Adesk::Boolean | polyline (const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, Adesk::LongPtr lBaseSubEntMarker=-1) const =0
virtual Adesk::Boolean | polypoint (const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, const Adesk::LongPtr *pSubEntMarkers=NULL) const
virtual void | popClipBoundary ()=0
virtual Adesk::Boolean | popModelTransform ()=0
virtual Adesk::Boolean | pushClipBoundary (AcGiClipBoundary *pBoundary)=0
virtual Adesk::Boolean | pushModelTransform (const AcGeVector3d &vNormal)=0
virtual Adesk::Boolean | pushModelTransform (const AcGeMatrix3d &xMat)=0
virtual Adesk::Boolean | ray (const AcGePoint3d &, const AcGePoint3d &) const =0
virtual Adesk::Boolean | shell (const Adesk::UInt32 nbVertex, const AcGePoint3d *pVertexList, const Adesk::UInt32 faceListSize, const Adesk::Int32 *pFaceList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const struct resbuf *pResBuf=NULL, const bool bAutoGenerateNormals=true) const =0
virtual Adesk::Boolean | text (const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const double height, const double width, const double oblique, const ACHAR *pMsg) const =0
virtual Adesk::Boolean | text (const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const ACHAR *pMsg, const Adesk::Int32 length, const Adesk::Boolean raw, const AcGiTextStyle &pTextStyle) const =0
virtual Adesk::Boolean | worldLine (const AcGePoint3d pnts[2])
virtual Adesk::Boolean | xline (const AcGePoint3d &, const AcGePoint3d &) const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiViewportGeometry Member List

This is the complete list of members for AcGiViewportGeometry, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiViewportGeometry) (defined in AcGiViewportGeometry) | AcGiViewportGeometry |
ACRX_DECLARE_MEMBERS(AcGiGeometry) (defined in AcGiGeometry) | AcGiGeometry |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
circle(const AcGePoint3d &center, const double radius, const AcGeVector3d &normal) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
circle(const AcGePoint3d &, const AcGePoint3d &, const AcGePoint3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
circularArc(const AcGePoint3d &center, const double radius, const AcGeVector3d &normal, const AcGeVector3d &startVector, const double sweepAngle, const AcGiArcType arcType=kAcGiArcSimple) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
circularArc(const AcGePoint3d &start, const AcGePoint3d &point, const AcGePoint3d &end, const AcGiArcType arcType=kAcGiArcSimple) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
draw(AcGiDrawable *) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
getModelToWorldTransform(AcGeMatrix3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
getWorldToModelTransform(AcGeMatrix3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
ImageSource enum name (defined in AcGiViewportGeometry) | AcGiViewportGeometry |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kFromDwg enum value (defined in AcGiViewportGeometry) | AcGiViewportGeometry |
kFromOleObject enum value (defined in AcGiViewportGeometry) | AcGiViewportGeometry |
kFromRender enum value (defined in AcGiViewportGeometry) | AcGiViewportGeometry |
mesh(const Adesk::UInt32 rows, const Adesk::UInt32 columns, const AcGePoint3d *pVertexList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const bool bAutoGenerateNormals=true) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
ownerDraw3d(AcGePoint3d &minBounds, AcGePoint3d &maxBounds, OwnerDraw3d *pOwnerDraw) const (defined in AcGiViewportGeometry) | AcGiViewportGeometry | inlinevirtual
ownerDrawDc(long vpnumber, long left, long top, long right, long bottom, const OwnerDraw *pOwnerDraw) const =0 (defined in AcGiViewportGeometry) | AcGiViewportGeometry | pure virtual
pline(const AcDbPolyline &lwBuf, Adesk::UInt32 fromIndex=0, Adesk::UInt32 numSegs=0) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
polygon(const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
polygonDc(const Adesk::UInt32 nbPoints, const AcGePoint3d *pPoints) const =0 (defined in AcGiViewportGeometry) | AcGiViewportGeometry | pure virtual
polygonEye(const Adesk::UInt32 nbPoints, const AcGePoint3d *pPoints) const =0 (defined in AcGiViewportGeometry) | AcGiViewportGeometry | pure virtual
polyline(const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, Adesk::LongPtr lBaseSubEntMarker=-1) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
polylineDc(const Adesk::UInt32 nbPoints, const AcGePoint3d *pPoints) const =0 (defined in AcGiViewportGeometry) | AcGiViewportGeometry | pure virtual
polylineEye(const Adesk::UInt32 nbPoints, const AcGePoint3d *pPoints) const =0 (defined in AcGiViewportGeometry) | AcGiViewportGeometry | pure virtual
polypoint(const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, const Adesk::LongPtr *pSubEntMarkers=NULL) const (defined in AcGiGeometry) | AcGiGeometry | inlinevirtual
popClipBoundary()=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
popModelTransform()=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pushClipBoundary(AcGiClipBoundary *pBoundary)=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pushModelTransform(const AcGeVector3d &vNormal)=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pushModelTransform(const AcGeMatrix3d &xMat)=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rasterImageDc(const AcGePoint3d &origin, const AcGeVector3d &u, const AcGeVector3d &v, const AcGeMatrix2d &pixelToDc, AcDbObjectId entityId, AcGiImageOrg imageOrg, Adesk::UInt32 imageWidth, Adesk::UInt32 imageHeight, Adesk::Int16 imageColorDepth, Adesk::Boolean transparency, ImageSource source, const AcGeVector3d &unrotatedU, const AcGiImageOrg origionalImageOrg, const AcGeMatrix2d &unrotatedPixelToDc, const Adesk::UInt32 unrotatedImageWidth, const Adesk::UInt32 unrotatedImageHeight) const =0 (defined in AcGiViewportGeometry) | AcGiViewportGeometry | pure virtual
ray(const AcGePoint3d &, const AcGePoint3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
shell(const Adesk::UInt32 nbVertex, const AcGePoint3d *pVertexList, const Adesk::UInt32 faceListSize, const Adesk::Int32 *pFaceList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const struct resbuf *pResBuf=NULL, const bool bAutoGenerateNormals=true) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
text(const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const double height, const double width, const double oblique, const ACHAR *pMsg) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
text(const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const ACHAR *pMsg, const Adesk::Int32 length, const Adesk::Boolean raw, const AcGiTextStyle &pTextStyle) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
worldLine(const AcGePoint3d pnts[2]) (defined in AcGiGeometry) | AcGiGeometry | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xline(const AcGePoint3d &, const AcGePoint3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiViewportTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiViewportTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiViewportTraits:

Public Types

enum DefaultLightingType { kOneDistantLight = 0, kTwoDistantLights, kBackLighting }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiViewportTraits)
virtual AcCmColor | ambientLightColor () const =0
virtual AcDbObjectId | background () const =0
virtual double | brightness () const =0
virtual double | contrast () const =0
virtual DefaultLightingType | defaultLightingType () const =0
virtual bool | isDefaultLightingOn () const =0
virtual AcDbObjectId | renderEnvironment () const =0
virtual AcDbObjectId | renderSettings () const =0
virtual void | setAmbientLightColor (const AcCmColor &clr)=0
virtual void | setBackground (const AcDbObjectId backgroundId)=0
virtual void | setBrightness (double brightness)=0
virtual void | setContrast (double contrast)=0
virtual void | setDefaultLightingOn (bool on)=0
virtual void | setDefaultLightingType (DefaultLightingType typ)=0
virtual void | setRenderEnvironment (const AcDbObjectId renderEnvId)=0
virtual void | setRenderSettings (const AcDbObjectId renderSettingsId)=0
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
virtual void | addLight (const AcDbObjectId &lightId)
virtual void | setupForEntity (AcDbEntity *pEntity)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt16 | color (void) const =0
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcGiFillType | fillType (void) const =0
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual AcDbObjectId | layerId (void) const =0
virtual AcDbObjectId | lineTypeId (void) const =0
virtual double | lineTypeScale (void) const =0
virtual AcDb::LineWeight | lineWeight (void) const =0
virtual const AcGiMapper * | mapper (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | sectionable (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)=0
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setFillType (const AcGiFillType)=0
virtual void | setLayer (const AcDbObjectId layerId)=0
virtual void | setLineType (const AcDbObjectId linetypeId)=0
virtual void | setLineTypeScale (double dScale=1.0)=0
virtual void | setLineWeight (const AcDb::LineWeight lw)=0
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setMaterial (const AcDbObjectId materialId)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)=0
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setThickness (double dThickness)=0
virtual void | setTrueColor (const AcCmEntityColor &color)=0
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual double | thickness (void) const =0
virtual AcCmEntityColor | trueColor (void) const =0
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • acgiviewport.h


ZRX API Reference: AcGiViewportTraits2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiViewportTraits2 Class Reference
AcGi Classes
+ Inheritance diagram for AcGiViewportTraits2:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiViewportTraits2)
virtual void | setToneOperatorParameters (const AcGiToneOperatorParameters &params)=0
virtual void | toneOperatorParameters (AcGiToneOperatorParameters &params) const =0
- Public Member Functions inherited from AcGiViewportTraits
ACRX_DECLARE_MEMBERS (AcGiViewportTraits)
virtual AcCmColor | ambientLightColor () const =0
virtual AcDbObjectId | background () const =0
virtual double | brightness () const =0
virtual double | contrast () const =0
virtual DefaultLightingType | defaultLightingType () const =0
virtual bool | isDefaultLightingOn () const =0
virtual AcDbObjectId | renderEnvironment () const =0
virtual AcDbObjectId | renderSettings () const =0
virtual void | setAmbientLightColor (const AcCmColor &clr)=0
virtual void | setBackground (const AcDbObjectId backgroundId)=0
virtual void | setBrightness (double brightness)=0
virtual void | setContrast (double contrast)=0
virtual void | setDefaultLightingOn (bool on)=0
virtual void | setDefaultLightingType (DefaultLightingType typ)=0
virtual void | setRenderEnvironment (const AcDbObjectId renderEnvId)=0
virtual void | setRenderSettings (const AcDbObjectId renderSettingsId)=0
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
virtual void | addLight (const AcDbObjectId &lightId)
virtual void | setupForEntity (AcDbEntity *pEntity)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt16 | color (void) const =0
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcGiFillType | fillType (void) const =0
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual AcDbObjectId | layerId (void) const =0
virtual AcDbObjectId | lineTypeId (void) const =0
virtual double | lineTypeScale (void) const =0
virtual AcDb::LineWeight | lineWeight (void) const =0
virtual const AcGiMapper * | mapper (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | sectionable (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)=0
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setFillType (const AcGiFillType)=0
virtual void | setLayer (const AcDbObjectId layerId)=0
virtual void | setLineType (const AcDbObjectId linetypeId)=0
virtual void | setLineTypeScale (double dScale=1.0)=0
virtual void | setLineWeight (const AcDb::LineWeight lw)=0
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setMaterial (const AcDbObjectId materialId)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)=0
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setThickness (double dThickness)=0
virtual void | setTrueColor (const AcCmEntityColor &color)=0
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual double | thickness (void) const =0
virtual AcCmEntityColor | trueColor (void) const =0
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiViewportTraits
enum | DefaultLightingType { kOneDistantLight = 0, kTwoDistantLights, kBackLighting }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • acgiviewport.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiViewportTraits2 Member List

This is the complete list of members for AcGiViewportTraits2, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiViewportTraits2) (defined in AcGiViewportTraits2) | AcGiViewportTraits2 |
ACRX_DECLARE_MEMBERS(AcGiViewportTraits) (defined in AcGiViewportTraits) | AcGiViewportTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &lightId) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlinevirtual
ambientLightColor() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
background() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
brightness() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
DefaultLightingType enum name (defined in AcGiViewportTraits) | AcGiViewportTraits |
defaultLightingType() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isDefaultLightingOn() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kBackLighting enum value (defined in AcGiViewportTraits) | AcGiViewportTraits |
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOneDistantLight enum value (defined in AcGiViewportTraits) | AcGiViewportTraits |
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kTwoDistantLights enum value (defined in AcGiViewportTraits) | AcGiViewportTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeScale(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineWeight(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
renderEnvironment() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
renderSettings() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setAmbientLightColor(const AcCmColor &clr)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setBackground(const AcDbObjectId backgroundId)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setBrightness(double brightness)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setColor(const Adesk::UInt16 color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setContrast(double contrast)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setDefaultLightingOn(bool on)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setDefaultLightingType(DefaultLightingType typ)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLayer(const AcDbObjectId layerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineTypeScale(double dScale=1.0)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineWeight(const AcDb::LineWeight lw)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId materialId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setRenderEnvironment(const AcDbObjectId renderEnvId)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setRenderSettings(const AcDbObjectId renderSettingsId)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double dThickness)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setToneOperatorParameters(const AcGiToneOperatorParameters &params)=0 (defined in AcGiViewportTraits2) | AcGiViewportTraits2 | pure virtual
setTrueColor(const AcCmEntityColor &color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setupForEntity(AcDbEntity *pEntity) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | virtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
thickness(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
toneOperatorParameters(AcGiToneOperatorParameters &params) const =0 (defined in AcGiViewportTraits2) | AcGiViewportTraits2 | pure virtual
trueColor(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiVisualStyle Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | Friends | List of all members
AcGiVisualStyle Class Reference
AcGi Classes
+ Inheritance diagram for AcGiVisualStyle:

Public Types

typedef
AcGiVisualStyleOperations::Operation 		Operation
typedef
AcGiVisualStyleProperties::Property 		Property
enum Type {
kFlat, kFlatWithEdges, kGouraud, kGouraudWithEdges,
k2DWireframe, k3DWireframe, kHidden, kBasic,
kRealistic, kConceptual, kCustom, kDim,
kBrighten, kThicken, kLinePattern, kFacePattern,
kColorChange, kFaceOnly, kEdgeOnly, kDisplayOnly,
kJitterOff, kOverhangOff, kEdgeColorOff, kEmptyStyle
}

Public Member Functions

AcGiVisualStyle (void)
AcGiVisualStyle (Type type)
AcGiVisualStyle (const AcGiVisualStyle &visualStyle)
ACRX_DECLARE_MEMBERS (AcGiVisualStyle)
ADESK_DEPRECATED void | configureForType (Type type)
ADESK_DEPRECATED AcGiDisplayStyle & | displayStyle (void)
ADESK_DEPRECATED const
AcGiDisplayStyle & 		displayStyle (void) const
ADESK_DEPRECATED AcGiEdgeStyle & | edgeStyle (void)
ADESK_DEPRECATED const
AcGiEdgeStyle & 		edgeStyle (void) const
ADESK_DEPRECATED AcGiFaceStyle & | faceStyle (void)
ADESK_DEPRECATED const
AcGiFaceStyle & 		faceStyle (void) const
virtual ACDB_PORT Operation | operation (Property prop) const
AcGiVisualStyle & | operator= (const AcGiVisualStyle &visualStyle)
bool | operator== (const AcGiVisualStyle &visualStyle) const
ADESK_DEPRECATED void | setDisplayStyle (const AcGiDisplayStyle &style)
ADESK_DEPRECATED void | setEdgeStyle (const AcGiEdgeStyle &style)
ADESK_DEPRECATED void | setFaceStyle (const AcGiFaceStyle &style)
virtual ACDB_PORT bool | setTrait (Property prop, Operation op)
virtual ACDB_PORT bool | setTrait (Property prop, const AcGiVariant *pVal, Operation op=AcGiVisualStyleOperations::kSet)
virtual ACDB_PORT bool | setTrait (Property prop, int nVal, Operation op=AcGiVisualStyleOperations::kSet)
virtual ACDB_PORT bool | setTrait (Property prop, bool bVal, Operation op=AcGiVisualStyleOperations::kSet)
virtual ACDB_PORT bool | setTrait (Property prop, double dVal, Operation op=AcGiVisualStyleOperations::kSet)
virtual ACDB_PORT bool | setTrait (Property prop, double red, double green, double blue, Operation op=AcGiVisualStyleOperations::kSet)
virtual ACDB_PORT bool | setTrait (Property prop, const AcCmColor *pColor, Operation op=AcGiVisualStyleOperations::kSet)
virtual ACDB_PORT bool | setTrait (AcGiVisualStyleProperties::Property prop, const AcString *pStr, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet)
virtual ACDB_PORT bool | setTraitFlag (Property flagProp, unsigned long flagVal, bool bEnable=true)
ACDB_PORT bool | setType (Type type)
virtual ACDB_PORT const
AcGiVariant & 		trait (Property prop, Operation *pOp=NULL) const
virtual ACDB_PORT bool | traitFlag (Property flagProp, unsigned long flagVal) const
ACDB_PORT Type | type (void) const
~AcGiVisualStyle (void)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static ACDB_PORT
AcGiVariant::VariantType 		propertyType (Property prop)
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Friends

class AcDbImpVisualStyle

Constructor & Destructor Documentation

AcGiVisualStyle::AcGiVisualStyle ( void )
Warning
Not implemented!
AcGiVisualStyle::AcGiVisualStyle ( Type type )
Warning
Not implemented!
AcGiVisualStyle::AcGiVisualStyle ( const AcGiVisualStyle & visualStyle )
Warning
Not implemented!
AcGiVisualStyle::~AcGiVisualStyle ( void )
Warning
Not implemented!

Member Function Documentation

ADESK_DEPRECATED void AcGiVisualStyle::configureForType ( Type type )
Warning
Not implemented!
ADESK_DEPRECATED AcGiDisplayStyle& AcGiVisualStyle::displayStyle ( void )
Warning
Not implemented!
ADESK_DEPRECATED const AcGiDisplayStyle& AcGiVisualStyle::displayStyle ( void ) const
Warning
Not implemented!
ADESK_DEPRECATED AcGiEdgeStyle& AcGiVisualStyle::edgeStyle ( void )
Warning
Not implemented!
ADESK_DEPRECATED const AcGiEdgeStyle& AcGiVisualStyle::edgeStyle ( void ) const
Warning
Not implemented!
ADESK_DEPRECATED AcGiFaceStyle& AcGiVisualStyle::faceStyle ( void )
Warning
Not implemented!
ADESK_DEPRECATED const AcGiFaceStyle& AcGiVisualStyle::faceStyle ( void ) const
Warning
Not implemented!
virtual ACDB_PORT Operation AcGiVisualStyle::operation ( Property prop ) const
virtual
Warning
Not implemented!
AcGiVisualStyle& AcGiVisualStyle::operator= ( const AcGiVisualStyle & visualStyle )
Warning
Not implemented!
bool AcGiVisualStyle::operator== ( const AcGiVisualStyle & visualStyle ) const
Warning
Not implemented!
static ACDB_PORT AcGiVariant::VariantType AcGiVisualStyle::propertyType ( Property prop )
static
Warning
Not implemented!
ADESK_DEPRECATED void AcGiVisualStyle::setDisplayStyle ( const AcGiDisplayStyle & style )
Warning
Not implemented!
ADESK_DEPRECATED void AcGiVisualStyle::setEdgeStyle ( const AcGiEdgeStyle & style )
Warning
Not implemented!
ADESK_DEPRECATED void AcGiVisualStyle::setFaceStyle ( const AcGiFaceStyle & style )
Warning
Not implemented!
virtual ACDB_PORT bool AcGiVisualStyle::setTrait | ( | Property | prop,
 |  | Operation | op
 | ) |  |
virtual
Warning
Not implemented!
virtual ACDB_PORT bool AcGiVisualStyle::setTrait | ( | Property | prop,
 |  | const AcGiVariant * | pVal,
 |  | Operation | op = AcGiVisualStyleOperations::kSet
 | ) |  |
virtual
Warning
Not implemented!
virtual ACDB_PORT bool AcGiVisualStyle::setTrait | ( | Property | prop,
 |  | int | nVal,
 |  | Operation | op = AcGiVisualStyleOperations::kSet
 | ) |  |
virtual
Warning
Not implemented!
virtual ACDB_PORT bool AcGiVisualStyle::setTrait | ( | Property | prop,
 |  | bool | bVal,
 |  | Operation | op = AcGiVisualStyleOperations::kSet
 | ) |  |
virtual
Warning
Not implemented!
virtual ACDB_PORT bool AcGiVisualStyle::setTrait | ( | Property | prop,
 |  | double | dVal,
 |  | Operation | op = AcGiVisualStyleOperations::kSet
 | ) |  |
virtual
Warning
Not implemented!
virtual ACDB_PORT bool AcGiVisualStyle::setTrait | ( | Property | prop,
 |  | double | red,
 |  | double | green,
 |  | double | blue,
 |  | Operation | op = AcGiVisualStyleOperations::kSet
 | ) |  |
virtual
Warning
Not implemented!
virtual ACDB_PORT bool AcGiVisualStyle::setTrait | ( | Property | prop,
 |  | const AcCmColor * | pColor,
 |  | Operation | op = AcGiVisualStyleOperations::kSet
 | ) |  |
virtual
Warning
Not implemented!
virtual ACDB_PORT bool AcGiVisualStyle::setTraitFlag | ( | Property | flagProp,
 |  | unsigned long | flagVal,
 |  | bool | bEnable = true
 | ) |  |
virtual
Warning
Not implemented!
ACDB_PORT bool AcGiVisualStyle::setType ( Type type )
Warning
Not implemented!
virtual ACDB_PORT const AcGiVariant& AcGiVisualStyle::trait | ( | Property | prop,
 |  | Operation * | pOp = NULL
 | ) |  | const
 virtual
Warning
Not implemented!
virtual ACDB_PORT bool AcGiVisualStyle::traitFlag | ( | Property | flagProp,
 |  | unsigned long | flagVal
 | ) |  | const
 virtual
Warning
Not implemented!
ACDB_PORT Type AcGiVisualStyle::type ( void ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgivisualstyle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiVisualStyle Member List

This is the complete list of members for AcGiVisualStyle, including all inherited members.

AcDbImpVisualStyle (defined in AcGiVisualStyle) | AcGiVisualStyle | friend
AcGiVisualStyle(void) | AcGiVisualStyle |
AcGiVisualStyle(Type type) | AcGiVisualStyle |
AcGiVisualStyle(const AcGiVisualStyle &visualStyle) | AcGiVisualStyle |
ACRX_DECLARE_MEMBERS(AcGiVisualStyle) (defined in AcGiVisualStyle) | AcGiVisualStyle |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
configureForType(Type type) | AcGiVisualStyle |
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
displayStyle(void) | AcGiVisualStyle |
displayStyle(void) const | AcGiVisualStyle |
edgeStyle(void) | AcGiVisualStyle |
edgeStyle(void) const | AcGiVisualStyle |
faceStyle(void) | AcGiVisualStyle |
faceStyle(void) const | AcGiVisualStyle |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
k2DWireframe enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
k3DWireframe enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kBasic enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kBrighten enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kColorChange enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kConceptual enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kCustom enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kDim enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kDisplayOnly enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kEdgeColorOff enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kEdgeOnly enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kEmptyStyle enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kFaceOnly enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kFacePattern enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kFlat enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kFlatWithEdges enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kGouraud enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kGouraudWithEdges enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kHidden enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kJitterOff enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kLinePattern enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kOverhangOff enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kRealistic enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
kThicken enum value (defined in AcGiVisualStyle) | AcGiVisualStyle |
operation(Property prop) const | AcGiVisualStyle | virtual
Operation typedef (defined in AcGiVisualStyle) | AcGiVisualStyle |
operator=(const AcGiVisualStyle &visualStyle) | AcGiVisualStyle |
operator==(const AcGiVisualStyle &visualStyle) const | AcGiVisualStyle |
Property typedef (defined in AcGiVisualStyle) | AcGiVisualStyle |
propertyType(Property prop) | AcGiVisualStyle | static
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setDisplayStyle(const AcGiDisplayStyle &style) | AcGiVisualStyle |
setEdgeStyle(const AcGiEdgeStyle &style) | AcGiVisualStyle |
setFaceStyle(const AcGiFaceStyle &style) | AcGiVisualStyle |
setTrait(Property prop, Operation op) | AcGiVisualStyle | virtual
setTrait(Property prop, const AcGiVariant *pVal, Operation op=AcGiVisualStyleOperations::kSet) | AcGiVisualStyle | virtual
setTrait(Property prop, int nVal, Operation op=AcGiVisualStyleOperations::kSet) | AcGiVisualStyle | virtual
setTrait(Property prop, bool bVal, Operation op=AcGiVisualStyleOperations::kSet) | AcGiVisualStyle | virtual
setTrait(Property prop, double dVal, Operation op=AcGiVisualStyleOperations::kSet) | AcGiVisualStyle | virtual
setTrait(Property prop, double red, double green, double blue, Operation op=AcGiVisualStyleOperations::kSet) | AcGiVisualStyle | virtual
setTrait(Property prop, const AcCmColor *pColor, Operation op=AcGiVisualStyleOperations::kSet) | AcGiVisualStyle | virtual
setTrait(AcGiVisualStyleProperties::Property prop, const AcString *pStr, AcGiVisualStyleOperations::Operation op=AcGiVisualStyleOperations::kSet) (defined in AcGiVisualStyle) | AcGiVisualStyle | virtual
setTraitFlag(Property flagProp, unsigned long flagVal, bool bEnable=true) | AcGiVisualStyle | virtual
setType(Type type) | AcGiVisualStyle |
trait(Property prop, Operation *pOp=NULL) const | AcGiVisualStyle | virtual
traitFlag(Property flagProp, unsigned long flagVal) const | AcGiVisualStyle | virtual
type(void) const | AcGiVisualStyle |
Type enum name (defined in AcGiVisualStyle) | AcGiVisualStyle |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiVisualStyle(void) | AcGiVisualStyle |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiVisualStyleTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiVisualStyleTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiVisualStyleTraits:

Public Member Functions

virtual const AcGiVisualStyle & | acgiVisualStyle (void) const =0
ACRX_DECLARE_MEMBERS (AcGiVisualStyleTraits)
virtual void | setAcGiVisualStyle (const AcGiVisualStyle &visualStyle)=0
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
virtual void | addLight (const AcDbObjectId &lightId)
virtual void | setupForEntity (AcDbEntity *pEntity)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt16 | color (void) const =0
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcGiFillType | fillType (void) const =0
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual AcDbObjectId | layerId (void) const =0
virtual AcDbObjectId | lineTypeId (void) const =0
virtual double | lineTypeScale (void) const =0
virtual AcDb::LineWeight | lineWeight (void) const =0
virtual const AcGiMapper * | mapper (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | sectionable (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)=0
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setFillType (const AcGiFillType)=0
virtual void | setLayer (const AcDbObjectId layerId)=0
virtual void | setLineType (const AcDbObjectId linetypeId)=0
virtual void | setLineTypeScale (double dScale=1.0)=0
virtual void | setLineWeight (const AcDb::LineWeight lw)=0
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setMaterial (const AcDbObjectId materialId)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)=0
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setThickness (double dThickness)=0
virtual void | setTrueColor (const AcCmEntityColor &color)=0
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual double | thickness (void) const =0
virtual AcCmEntityColor | trueColor (void) const =0
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcGiSubEntityTraits
enum | DrawFlags { kNoDrawFlags = 0, kDrawBackfaces = 1, kDrawHatchGroup = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotCast = 0x01, kShadowsDoesNotReceive = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • acgivisualstyle.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiVisualStyleTraits Member List

This is the complete list of members for AcGiVisualStyleTraits, including all inherited members.

acgiVisualStyle(void) const =0 (defined in AcGiVisualStyleTraits) | AcGiVisualStyleTraits | pure virtual
ACRX_DECLARE_MEMBERS(AcGiVisualStyleTraits) (defined in AcGiVisualStyleTraits) | AcGiVisualStyleTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &lightId) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeScale(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineWeight(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setAcGiVisualStyle(const AcGiVisualStyle &visualStyle)=0 (defined in AcGiVisualStyleTraits) | AcGiVisualStyleTraits | pure virtual
setColor(const Adesk::UInt16 color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLayer(const AcDbObjectId layerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineTypeScale(double dScale=1.0)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineWeight(const AcDb::LineWeight lw)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId materialId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double dThickness)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setTrueColor(const AcCmEntityColor &color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setupForEntity(AcDbEntity *pEntity) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | virtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
thickness(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
trueColor(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiWebLightTraits Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGiWebLightTraits Class Reference
AcGi Classes
+ Inheritance diagram for AcGiWebLightTraits:

Public Types

enum | WebFileType { kTypeC = 1, kTypeB = 2, kTypeA = 3 }
enum | WebSymmetry { kNoSymmetry = 0, kSingleSymmetry = 1, kDoubleSymmetry = 2, kAxialSymmetry = 3 }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiWebLightTraits)
virtual void | setWebFile (const ACHAR *webFile)=0
virtual void | setWebFileType (WebFileType type)=0
virtual void | setWebFlux (double flux) const =0
virtual void | setWebHorzAng90to270 (bool bIs90to270)=0
virtual void | setWebRotation (AcGeVector3d rotation)=0
virtual void | setWebSymmetry (WebSymmetry symmetry)=0
virtual void | webFile (AcString &webFile) const =0
virtual WebFileType | webFileType (void) const =0
virtual double | webFlux () const =0
virtual bool | webHorzAng90to270 (void) const =0
virtual void | webRotation (AcGeVector3d &rotation) const =0
virtual WebSymmetry | webSymmetry (void) const =0
- Public Member Functions inherited from AcGiPointLightTraits2
ACRX_DECLARE_MEMBERS (AcGiPointLightTraits2)
virtual bool | hasTarget (void) const =0
virtual void | lampColor (AcGiColorRGB &rgbColor) const =0
virtual double | physicalIntensity () const =0
virtual void | setHasTarget (bool bHasTarget)=0
virtual void | setLampColor (const AcGiColorRGB &rgbColor)=0
virtual void | setPhysicalIntensity (double physicalIntensity)=0
virtual void | setShadowParameters (const AcGiShadowParameters2 &params)=0
virtual void | setTargetLocation (const AcGePoint3d &loc)=0
virtual void | shadowParameters (AcGiShadowParameters2 &params) const =0
virtual AcGePoint3d | targetLocation () const =0
- Public Member Functions inherited from AcGiPointLightTraits
ACRX_DECLARE_MEMBERS (AcGiPointLightTraits)
virtual void | lightAttenuation (AcGiLightAttenuation &atten) const =0
virtual AcGePoint3d | position () const =0
virtual void | setAttenuation (const AcGiLightAttenuation &atten)=0
virtual void | setPosition (const AcGePoint3d &pos)=0
- Public Member Functions inherited from AcGiStandardLightTraits
ACRX_DECLARE_MEMBERS (AcGiStandardLightTraits)
virtual double | intensity () const =0
virtual AcCmColor | lightColor () const =0
virtual void | setIntensity (double inten)=0
virtual void | setLightColor (const AcCmColor &color)=0
virtual void | setShadowParameters (const AcGiShadowParameters &params)=0
virtual void | shadowParameters (AcGiShadowParameters &params) const =0
- Public Member Functions inherited from AcGiLightTraits
ACRX_DECLARE_MEMBERS (AcGiLightTraits)
virtual bool | isOn () const =0
virtual void | setOn (bool on)=0
- Public Member Functions inherited from AcGiNonEntityTraits
ACRX_DECLARE_MEMBERS (AcGiNonEntityTraits)
virtual void | addLight (const AcDbObjectId &id)
virtual Adesk::UInt16 | color (void) const
virtual AcGiFillType | fillType (void) const
virtual AcDbObjectId | layerId (void) const
virtual AcDbObjectId | lineTypeId (void) const
virtual double | lineTypeScale (void) const
virtual AcDb::LineWeight | lineWeight (void) const
virtual AcDbObjectId | materialId (void) const
virtual bool | selectionGeom (void) const
virtual void | setColor (const Adesk::UInt16 color)
virtual void | setFillType (const AcGiFillType fillType)
virtual void | setLayer (const AcDbObjectId layerId)
virtual void | setLineType (const AcDbObjectId linetypeId)
virtual void | setLineTypeScale (double dScale)
virtual void | setLineWeight (const AcDb::LineWeight lw)
virtual void | setMaterial (const AcDbObjectId matId)
virtual void | setSelectionGeom (bool bSelectionflag)
virtual void | setSelectionMarker (const Adesk::LongPtr markerId)
virtual void | setThickness (double thickness)
virtual void | setTrueColor (const AcCmEntityColor &color)
virtual void | setupForEntity (AcDbEntity *pEntity)
virtual double | thickness (void) const
virtual AcCmEntityColor | trueColor (void) const
- Public Member Functions inherited from AcGiDrawableTraits
ACRX_DECLARE_MEMBERS (AcGiDrawableTraits)
- Public Member Functions inherited from AcGiSubEntityTraits
ACRX_DECLARE_MEMBERS (AcGiSubEntityTraits)
virtual Adesk::UInt32 | drawFlags (void) const
virtual Acad::ErrorStatus | edgeStyleOverride (AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const
virtual AcDb::PlotStyleNameType | getPlotStyleNameId (AcDbObjectId &idResult) const
virtual const AcGiMapper * | mapper (void) const
virtual bool | sectionable (void) const
virtual Acad::ErrorStatus | setDrawFlags (Adesk::UInt32 flags)
virtual Acad::ErrorStatus | setEdgeStyleOverride (AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle)
virtual void | setMapper (const AcGiMapper *mapper)
virtual void | setPlotStyleName (AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull)
virtual void | setSectionable (bool bSectionable)
virtual Acad::ErrorStatus | setShadowFlags (ShadowFlags flags)
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)
virtual ShadowFlags | shadowFlags (void) const
virtual AcDbObjectId | visualStyle (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Protected Types inherited from AcGiDrawableTraits
enum | LayerFlags { kNone = 0x00, kOff = 0x01, kFrozen = 0x02, kZero = 0x04 }
- Protected Member Functions inherited from AcGiDrawableTraits
virtual void | setLayerFlags (Adesk::UInt8 flags)
The documentation for this class was generated from the following file:
  • AcGiLightTraits.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiWebLightTraits Member List

This is the complete list of members for AcGiWebLightTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiWebLightTraits) (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
ACRX_DECLARE_MEMBERS(AcGiPointLightTraits2) (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 |
ACRX_DECLARE_MEMBERS(AcGiPointLightTraits) (defined in AcGiPointLightTraits) | AcGiPointLightTraits |
ACRX_DECLARE_MEMBERS(AcGiStandardLightTraits) (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits |
ACRX_DECLARE_MEMBERS(AcGiLightTraits) (defined in AcGiLightTraits) | AcGiLightTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
hasTarget(void) const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
intensity() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOn() const =0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
kAxialSymmetry enum value (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
kDoubleSymmetry enum value (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoSymmetry enum value (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kSingleSymmetry enum value (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
kTypeA enum value (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
kTypeB enum value (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
kTypeC enum value (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
lampColor(AcGiColorRGB &rgbColor) const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightAttenuation(AcGiLightAttenuation &atten) const =0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
lightColor() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
physicalIntensity() const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
position() const =0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setAttenuation(const AcGiLightAttenuation &atten)=0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setHasTarget(bool bHasTarget)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setIntensity(double inten)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLampColor(const AcGiColorRGB &rgbColor)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightColor(const AcCmColor &color)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setOn(bool on)=0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
setPhysicalIntensity(double physicalIntensity)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPosition(const AcGePoint3d &pos)=0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowParameters(const AcGiShadowParameters2 &params)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setShadowParameters(const AcGiShadowParameters &params)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setTargetLocation(const AcGePoint3d &loc)=0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setWebFile(const ACHAR *webFile)=0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
setWebFileType(WebFileType type)=0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
setWebFlux(double flux) const =0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
setWebHorzAng90to270(bool bIs90to270)=0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
setWebRotation(AcGeVector3d rotation)=0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
setWebSymmetry(WebSymmetry symmetry)=0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowParameters(AcGiShadowParameters2 &params) const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
shadowParameters(AcGiShadowParameters &params) const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
targetLocation() const =0 (defined in AcGiPointLightTraits2) | AcGiPointLightTraits2 | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
webFile(AcString &webFile) const =0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
WebFileType enum name (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
webFileType(void) const =0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
webFlux() const =0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
webHorzAng90to270(void) const =0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
webRotation(AcGeVector3d &rotation) const =0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
webSymmetry(void) const =0 (defined in AcGiWebLightTraits) | AcGiWebLightTraits | pure virtual
WebSymmetry enum name (defined in AcGiWebLightTraits) | AcGiWebLightTraits |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiWoodTexture Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcGiWoodTexture Class Reference
AcGi Classes
+ Inheritance diagram for AcGiWoodTexture:

Public Member Functions

AcGiWoodTexture (void)
AcGiWoodTexture (const AcGiWoodTexture &texture)
ACRX_DECLARE_MEMBERS (AcGiWoodTexture)
virtual double | axialNoise (void) const
virtual const AcGiMaterialColor & | color1 (void) const
virtual const AcGiMaterialColor & | color2 (void) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual double | grainThickness (void) const
AcGiWoodTexture & | operator= (const AcGiWoodTexture &texture)
virtual bool | operator== (const AcGiMaterialTexture &texture) const
virtual double | radialNoise (void) const
virtual void | setAxialNoise (double axialNoise)
virtual void | setColor1 (const AcGiMaterialColor &woodColor1)
virtual void | setColor2 (const AcGiMaterialColor &woodColor2)
virtual void | setGrainThickness (double grainThickness)
virtual void | setRadialNoise (double radialNoise)
virtual | ~AcGiWoodTexture (void)
- Public Member Functions inherited from AcGiProceduralTexture
ACRX_DECLARE_MEMBERS (AcGiProceduralTexture)
- Public Member Functions inherited from AcGiMaterialTexture
ACRX_DECLARE_MEMBERS (AcGiMaterialTexture)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcGiImpWoodTexture

Additional Inherited Members

- Public Types inherited from AcGiProceduralTexture
enum | Type { kWood = 0, kMarble, kGeneric }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Constructor & Destructor Documentation

AcGiWoodTexture::AcGiWoodTexture ( void )
Warning
Not implemented!
virtual AcGiWoodTexture::~AcGiWoodTexture ( void )
virtual
Warning
Not implemented!
AcGiWoodTexture::AcGiWoodTexture ( const AcGiWoodTexture & texture )
Warning
Not implemented!

Member Function Documentation

virtual double AcGiWoodTexture::axialNoise ( void ) const
virtual
Warning
Not implemented!
virtual const AcGiMaterialColor& AcGiWoodTexture::color1 ( void ) const
virtual
Warning
Not implemented!
virtual const AcGiMaterialColor& AcGiWoodTexture::color2 ( void ) const
virtual
Warning
Not implemented!
virtual Acad::ErrorStatus AcGiWoodTexture::copyFrom ( const AcRxObject * other )
virtual
Warning
Not implemented!

Reimplemented from AcRxObject.

virtual double AcGiWoodTexture::grainThickness ( void ) const
virtual
Warning
Not implemented!
AcGiWoodTexture& AcGiWoodTexture::operator= ( const AcGiWoodTexture & texture )
Warning
Not implemented!
virtual bool AcGiWoodTexture::operator== ( const AcGiMaterialTexture & texture ) const
virtual
Warning
Not implemented!

Reimplemented from AcGiMaterialTexture.

virtual double AcGiWoodTexture::radialNoise ( void ) const
virtual
Warning
Not implemented!
virtual void AcGiWoodTexture::setAxialNoise ( double axialNoise )
virtual
Warning
Not implemented!
virtual void AcGiWoodTexture::setColor1 ( const AcGiMaterialColor & woodColor1 )
virtual
Warning
Not implemented!
virtual void AcGiWoodTexture::setColor2 ( const AcGiMaterialColor & woodColor2 )
virtual
Warning
Not implemented!
virtual void AcGiWoodTexture::setGrainThickness ( double grainThickness )
virtual
Warning
Not implemented!
virtual void AcGiWoodTexture::setRadialNoise ( double radialNoise )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acgimaterial.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiWoodTexture Member List

This is the complete list of members for AcGiWoodTexture, including all inherited members.

AcGiImpWoodTexture (defined in AcGiWoodTexture) | AcGiWoodTexture | friend
AcGiWoodTexture(void) | AcGiWoodTexture |
AcGiWoodTexture(const AcGiWoodTexture &texture) | AcGiWoodTexture |
ACRX_DECLARE_MEMBERS(AcGiWoodTexture) (defined in AcGiWoodTexture) | AcGiWoodTexture |
ACRX_DECLARE_MEMBERS(AcGiProceduralTexture) (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
ACRX_DECLARE_MEMBERS(AcGiMaterialTexture) (defined in AcGiMaterialTexture) | AcGiMaterialTexture |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
axialNoise(void) const | AcGiWoodTexture | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color1(void) const | AcGiWoodTexture | virtual
color2(void) const | AcGiWoodTexture | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) | AcGiWoodTexture | virtual
desc() (defined in AcRxObject) | AcRxObject | static
grainThickness(void) const | AcGiWoodTexture | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kGeneric enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
kMarble enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
kWood enum value (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
operator=(const AcGiWoodTexture &texture) | AcGiWoodTexture |
operator==(const AcGiMaterialTexture &texture) const | AcGiWoodTexture | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
radialNoise(void) const | AcGiWoodTexture | virtual
setAxialNoise(double axialNoise) | AcGiWoodTexture | virtual
setColor1(const AcGiMaterialColor &woodColor1) | AcGiWoodTexture | virtual
setColor2(const AcGiMaterialColor &woodColor2) | AcGiWoodTexture | virtual
setGrainThickness(double grainThickness) | AcGiWoodTexture | virtual
setRadialNoise(double radialNoise) | AcGiWoodTexture | virtual
Type enum name (defined in AcGiProceduralTexture) | AcGiProceduralTexture |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiWoodTexture(void) | AcGiWoodTexture | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiWorldDraw Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiWorldDraw Class Reference
AcGi Classes
+ Inheritance diagram for AcGiWorldDraw:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiWorldDraw)
virtual AcGiWorldGeometry & | geometry () const =0
- Public Member Functions inherited from AcGiCommonDraw
ACRX_DECLARE_MEMBERS (AcGiCommonDraw)
virtual AcGiContext * | context ()=0
virtual double | deviation (const AcGiDeviationType, const AcGePoint3d &) const =0
virtual Adesk::Boolean | isDragging () const =0
virtual Adesk::UInt32 | numberOfIsolines () const =0
virtual AcGiGeometry * | rawGeometry () const =0
virtual Adesk::Boolean | regenAbort () const =0
virtual AcGiRegenType | regenType () const =0
virtual bool | secondaryCall () const
virtual AcGiSubEntityTraits & | subEntityTraits () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiWorldDraw Member List

This is the complete list of members for AcGiWorldDraw, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiWorldDraw) (defined in AcGiWorldDraw) | AcGiWorldDraw |
ACRX_DECLARE_MEMBERS(AcGiCommonDraw) (defined in AcGiCommonDraw) | AcGiCommonDraw |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
context()=0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
deviation(const AcGiDeviationType, const AcGePoint3d &) const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
geometry() const =0 (defined in AcGiWorldDraw) | AcGiWorldDraw | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isDragging() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
numberOfIsolines() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rawGeometry() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
regenAbort() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
regenType() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
secondaryCall() const (defined in AcGiCommonDraw) | AcGiCommonDraw | inlinevirtual
subEntityTraits() const =0 (defined in AcGiCommonDraw) | AcGiCommonDraw | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGiWorldGeometry Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGiWorldGeometry Class Reference
AcGi Classes
+ Inheritance diagram for AcGiWorldGeometry:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcGiWorldGeometry)
virtual void | setExtents (AcGePoint3d *pNewExtents) const =0
virtual void | startAttributesSegment ()
- Public Member Functions inherited from AcGiGeometry
ACRX_DECLARE_MEMBERS (AcGiGeometry)
virtual Adesk::Boolean | circle (const AcGePoint3d &center, const double radius, const AcGeVector3d &normal) const =0
virtual Adesk::Boolean | circle (const AcGePoint3d &, const AcGePoint3d &, const AcGePoint3d &) const =0
virtual Adesk::Boolean | circularArc (const AcGePoint3d &center, const double radius, const AcGeVector3d &normal, const AcGeVector3d &startVector, const double sweepAngle, const AcGiArcType arcType=kAcGiArcSimple) const =0
virtual Adesk::Boolean | circularArc (const AcGePoint3d &start, const AcGePoint3d &point, const AcGePoint3d &end, const AcGiArcType arcType=kAcGiArcSimple) const =0
virtual Adesk::Boolean | draw (AcGiDrawable *) const =0
virtual void | getModelToWorldTransform (AcGeMatrix3d &) const =0
virtual void | getWorldToModelTransform (AcGeMatrix3d &) const =0
virtual Adesk::Boolean | mesh (const Adesk::UInt32 rows, const Adesk::UInt32 columns, const AcGePoint3d *pVertexList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const bool bAutoGenerateNormals=true) const =0
virtual Adesk::Boolean | pline (const AcDbPolyline &lwBuf, Adesk::UInt32 fromIndex=0, Adesk::UInt32 numSegs=0) const =0
virtual Adesk::Boolean | polygon (const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList) const =0
virtual Adesk::Boolean | polyline (const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, Adesk::LongPtr lBaseSubEntMarker=-1) const =0
virtual Adesk::Boolean | polypoint (const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, const Adesk::LongPtr *pSubEntMarkers=NULL) const
virtual void | popClipBoundary ()=0
virtual Adesk::Boolean | popModelTransform ()=0
virtual Adesk::Boolean | pushClipBoundary (AcGiClipBoundary *pBoundary)=0
virtual Adesk::Boolean | pushModelTransform (const AcGeVector3d &vNormal)=0
virtual Adesk::Boolean | pushModelTransform (const AcGeMatrix3d &xMat)=0
virtual Adesk::Boolean | ray (const AcGePoint3d &, const AcGePoint3d &) const =0
virtual Adesk::Boolean | shell (const Adesk::UInt32 nbVertex, const AcGePoint3d *pVertexList, const Adesk::UInt32 faceListSize, const Adesk::Int32 *pFaceList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const struct resbuf *pResBuf=NULL, const bool bAutoGenerateNormals=true) const =0
virtual Adesk::Boolean | text (const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const double height, const double width, const double oblique, const ACHAR *pMsg) const =0
virtual Adesk::Boolean | text (const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const ACHAR *pMsg, const Adesk::Int32 length, const Adesk::Boolean raw, const AcGiTextStyle &pTextStyle) const =0
virtual Adesk::Boolean | worldLine (const AcGePoint3d pnts[2])
virtual Adesk::Boolean | xline (const AcGePoint3d &, const AcGePoint3d &) const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiWorldGeometry Member List

This is the complete list of members for AcGiWorldGeometry, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiWorldGeometry) (defined in AcGiWorldGeometry) | AcGiWorldGeometry |
ACRX_DECLARE_MEMBERS(AcGiGeometry) (defined in AcGiGeometry) | AcGiGeometry |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
circle(const AcGePoint3d &center, const double radius, const AcGeVector3d &normal) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
circle(const AcGePoint3d &, const AcGePoint3d &, const AcGePoint3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
circularArc(const AcGePoint3d &center, const double radius, const AcGeVector3d &normal, const AcGeVector3d &startVector, const double sweepAngle, const AcGiArcType arcType=kAcGiArcSimple) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
circularArc(const AcGePoint3d &start, const AcGePoint3d &point, const AcGePoint3d &end, const AcGiArcType arcType=kAcGiArcSimple) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
draw(AcGiDrawable *) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
getModelToWorldTransform(AcGeMatrix3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
getWorldToModelTransform(AcGeMatrix3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
mesh(const Adesk::UInt32 rows, const Adesk::UInt32 columns, const AcGePoint3d *pVertexList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const bool bAutoGenerateNormals=true) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pline(const AcDbPolyline &lwBuf, Adesk::UInt32 fromIndex=0, Adesk::UInt32 numSegs=0) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
polygon(const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
polyline(const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, Adesk::LongPtr lBaseSubEntMarker=-1) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
polypoint(const Adesk::UInt32 nbPoints, const AcGePoint3d *pVertexList, const AcGeVector3d *pNormal=NULL, const Adesk::LongPtr *pSubEntMarkers=NULL) const (defined in AcGiGeometry) | AcGiGeometry | inlinevirtual
popClipBoundary()=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
popModelTransform()=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pushClipBoundary(AcGiClipBoundary *pBoundary)=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pushModelTransform(const AcGeVector3d &vNormal)=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
pushModelTransform(const AcGeMatrix3d &xMat)=0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
ray(const AcGePoint3d &, const AcGePoint3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
setExtents(AcGePoint3d *pNewExtents) const =0 (defined in AcGiWorldGeometry) | AcGiWorldGeometry | pure virtual
shell(const Adesk::UInt32 nbVertex, const AcGePoint3d *pVertexList, const Adesk::UInt32 faceListSize, const Adesk::Int32 *pFaceList, const AcGiEdgeData *pEdgeData=NULL, const AcGiFaceData *pFaceData=NULL, const AcGiVertexData *pVertexData=NULL, const struct resbuf *pResBuf=NULL, const bool bAutoGenerateNormals=true) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
startAttributesSegment() (defined in AcGiWorldGeometry) | AcGiWorldGeometry | inlinevirtual
text(const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const double height, const double width, const double oblique, const ACHAR *pMsg) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
text(const AcGePoint3d &position, const AcGeVector3d &normal, const AcGeVector3d &direction, const ACHAR *pMsg, const Adesk::Int32 length, const Adesk::Boolean raw, const AcGiTextStyle &pTextStyle) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
worldLine(const AcGePoint3d pnts[2]) (defined in AcGiGeometry) | AcGiGeometry | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xline(const AcGePoint3d &, const AcGePoint3d &) const =0 (defined in AcGiGeometry) | AcGiGeometry | pure virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcGsManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGsManager Class Reference
AcGi Classes

Public Member Functions

virtual AcGsDevice * | createAutoCADDevice (HWND hWnd)=0
virtual AcGsModel * | createAutoCADModel (void)=0
virtual AcGsDevice * | createAutoCADOffScreenDevice ()=0
virtual AcGsView * | createAutoCADView (AcGiDrawable *drawable)=0
virtual AcGsView * | createAutoCADViewport (AcDbViewportTableRecord *vp)=0
virtual void | destroyAutoCADDevice (AcGsDevice *device)=0
virtual void | destroyAutoCADModel (AcGsModel *model)=0
virtual void | destroyAutoCADView (AcGsView *view)=0
virtual AcGsModel * | getDBModel (void)=0
virtual AcGsClassFactory * | getGSClassFactory (void)=0
virtual AcGsDevice * | getGUIDevice (void)=0
The documentation for this class was generated from the following file:
  • AcGsManager.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsManager Member List

This is the complete list of members for AcGsManager, including all inherited members.

AcGsManager(void) (defined in AcGsManager) | AcGsManager | inline
createAutoCADDevice(HWND hWnd)=0 (defined in AcGsManager) | AcGsManager | pure virtual
createAutoCADModel(void)=0 (defined in AcGsManager) | AcGsManager | pure virtual
createAutoCADOffScreenDevice()=0 (defined in AcGsManager) | AcGsManager | pure virtual
createAutoCADView(AcGiDrawable *drawable)=0 (defined in AcGsManager) | AcGsManager | pure virtual
createAutoCADViewport(AcDbViewportTableRecord *vp)=0 (defined in AcGsManager) | AcGsManager | pure virtual
destroyAutoCADDevice(AcGsDevice *device)=0 (defined in AcGsManager) | AcGsManager | pure virtual
destroyAutoCADModel(AcGsModel *model)=0 (defined in AcGsManager) | AcGsManager | pure virtual
destroyAutoCADView(AcGsView *view)=0 (defined in AcGsManager) | AcGsManager | pure virtual
getDBModel(void)=0 (defined in AcGsManager) | AcGsManager | pure virtual
getGSClassFactory(void)=0 (defined in AcGsManager) | AcGsManager | pure virtual
getGUIDevice(void)=0 (defined in AcGsManager) | AcGsManager | pure virtual
~AcGsManager(void) (defined in AcGsManager) | AcGsManager | inlinevirtual


ZRX API Reference: AcGs Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes
AcGs Classes

Classes

class | AcGs2DViewLimitManager
class | AcGsRenderProgressMonitor
class | AcGsScreenShot

Detailed Description


ZRX API Reference: AcGs2DViewLimitManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGs2DViewLimitManager Class Reference
AcGs Classes

Public Member Functions

virtual bool testView (AcGePoint3d const &target, double dFieldHeight)=0
The documentation for this class was generated from the following file:
  • acgs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGs2DViewLimitManager Member List

This is the complete list of members for AcGs2DViewLimitManager, including all inherited members.

testView(AcGePoint3d const &target, double dFieldHeight)=0 (defined in AcGs2DViewLimitManager) | AcGs2DViewLimitManager | pure virtual
~AcGs2DViewLimitManager(void) (defined in AcGs2DViewLimitManager) | AcGs2DViewLimitManager | inlinevirtual


ZRX API Reference: AcGsRenderProgressMonitor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGsRenderProgressMonitor Class Reference
AcGs Classes

Public Types

enum Phase { kTranslation, kPhotonEmission, kFinalGather, kRender }

Public Member Functions

virtual bool | OnProgress (Phase ePhase, float fProgress)=0
virtual void | OnTile (int x, int y, int w, int h, const BYTE *pPixels)=0
virtual void | SetStatistics (const AcGsRenderStatistics *pStats)=0
virtual bool | ShouldReuseDatabase ()
The documentation for this class was generated from the following file:
  • acgsRender.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsRenderProgressMonitor Member List

This is the complete list of members for AcGsRenderProgressMonitor, including all inherited members.

kFinalGather enum value (defined in AcGsRenderProgressMonitor) | AcGsRenderProgressMonitor |
kPhotonEmission enum value (defined in AcGsRenderProgressMonitor) | AcGsRenderProgressMonitor |
kRender enum value (defined in AcGsRenderProgressMonitor) | AcGsRenderProgressMonitor |
kTranslation enum value (defined in AcGsRenderProgressMonitor) | AcGsRenderProgressMonitor |
OnProgress(Phase ePhase, float fProgress)=0 (defined in AcGsRenderProgressMonitor) | AcGsRenderProgressMonitor | pure virtual
OnTile(int x, int y, int w, int h, const BYTE *pPixels)=0 (defined in AcGsRenderProgressMonitor) | AcGsRenderProgressMonitor | pure virtual
Phase enum name (defined in AcGsRenderProgressMonitor) | AcGsRenderProgressMonitor |
SetStatistics(const AcGsRenderStatistics *pStats)=0 (defined in AcGsRenderProgressMonitor) | AcGsRenderProgressMonitor | pure virtual
ShouldReuseDatabase() (defined in AcGsRenderProgressMonitor) | AcGsRenderProgressMonitor | inlinevirtual


ZRX API Reference: AcGsScreenShot Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGsScreenShot Class Reference
AcGs Classes

Public Member Functions

virtual Adesk::Boolean | getColorMap (int index, Adesk::UInt8 &red, Adesk::UInt8 &green, Adesk::UInt8 &blue) const =0
virtual void const * | getScanline (int offsetFromLeft, int offsetFromTop) const =0
virtual Adesk::Boolean | getSize (int &width, int &height, int &depth) const =0
void | operator delete (void *p)
void * | operator new (size_t size)
void * | operator new (size_t size, const char *, int)
The documentation for this class was generated from the following file:
  • acgs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsScreenShot Member List

This is the complete list of members for AcGsScreenShot, including all inherited members.

AcGsScreenShot() (defined in AcGsScreenShot) | AcGsScreenShot |
getColorMap(int index, Adesk::UInt8 &red, Adesk::UInt8 &green, Adesk::UInt8 &blue) const =0 (defined in AcGsScreenShot) | AcGsScreenShot | pure virtual
getScanline(int offsetFromLeft, int offsetFromTop) const =0 (defined in AcGsScreenShot) | AcGsScreenShot | pure virtual
getSize(int &width, int &height, int &depth) const =0 (defined in AcGsScreenShot) | AcGsScreenShot | pure virtual
operator delete(void *p) (defined in AcGsScreenShot) | AcGsScreenShot |
operator new(size_t size) (defined in AcGsScreenShot) | AcGsScreenShot |
operator new(size_t size, const char *, int) (defined in AcGsScreenShot) | AcGsScreenShot | inline
~AcGsScreenShot()=0 (defined in AcGsScreenShot) | AcGsScreenShot | pure virtual


ZRX API Reference: AcLy Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Typedefs
AcLy Classes

Classes

class | AcLyAndExpr
class | AcLyBoolExpr
class | AcLyLayerFilter
class | AcLyLayerFilterManager
class | AcLyLayerGroup
class | AcLyRelExpr

Typedefs

typedef struct _IMAGELIST * HIMAGELIST

Detailed Description


ZRX API Reference: AcLyAndExpr Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcLyAndExpr Class Reference
AcLy Classes

Public Member Functions

virtual const AcArray
< AcLyRelExpr * > & 		getRelExprs () const =0
The documentation for this class was generated from the following file:
  • acly.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcLyAndExpr Member List

This is the complete list of members for AcLyAndExpr, including all inherited members.

getRelExprs() const =0 (defined in AcLyAndExpr) | AcLyAndExpr | pure virtual
~AcLyAndExpr() (defined in AcLyAndExpr) | AcLyAndExpr | inlinevirtual


ZRX API Reference: AcLyBoolExpr Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcLyBoolExpr Class Reference
AcLy Classes

Public Member Functions

virtual const AcArray
< AcLyAndExpr * > & 		getAndExprs () const =0
The documentation for this class was generated from the following file:
  • acly.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcLyBoolExpr Member List

This is the complete list of members for AcLyBoolExpr, including all inherited members.

getAndExprs() const =0 (defined in AcLyBoolExpr) | AcLyBoolExpr | pure virtual
~AcLyBoolExpr() (defined in AcLyBoolExpr) | AcLyBoolExpr | inlinevirtual


ZRX API Reference: AcLyLayerFilter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Friends | List of all members
AcLyLayerFilter Class Reference
AcLy Classes
+ Inheritance diagram for AcLyLayerFilter:

Public Types

enum DialogResult { kOk = 0, kCancel = 1, kUseDefault = 2 }

Public Member Functions

ACRX_DECLARE_MEMBERS (AcLyLayerFilter)
virtual Acad::ErrorStatus | addNested (AcLyLayerFilter *filter)
virtual bool | allowDelete () const
virtual bool | allowNested () const
virtual bool | allowRename () const
virtual bool | compareTo (const AcLyLayerFilter *pOther) const
virtual bool | dynamicallyGenerated () const
virtual bool | filter (AcDbLayerTableRecord *layer) const
virtual const ACHAR * | filterExpression () const
virtual const AcLyBoolExpr * | filterExpressionTree () const
virtual Acad::ErrorStatus | generateNested ()
virtual Acad::ErrorStatus | getImages (HIMAGELIST &imageList, Adesk::UInt32 &normalImage, Adesk::UInt32 &selected) const
virtual const AcArray
< AcLyLayerFilter * > & 		getNestedFilters () const
virtual bool | isIdFilter () const
virtual bool | isProxy () const
virtual const ACHAR * | name () const
virtual AcLyLayerFilter * | parent () const
virtual Acad::ErrorStatus | readFrom (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | removeNested (AcLyLayerFilter *filter)
virtual Acad::ErrorStatus | setFilterExpression (const ACHAR *expr)
virtual Acad::ErrorStatus | setName (const ACHAR *)
virtual DialogResult | showEditor ()
virtual Acad::ErrorStatus | writeTo (AcDbDxfFiler *pFiler) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcLyLayerFilter (AcLySystemInternals *)

Friends

class AcLySystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • acly.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcLyLayerFilter Member List

This is the complete list of members for AcLyLayerFilter, including all inherited members.

AcLyLayerFilter() (defined in AcLyLayerFilter) | AcLyLayerFilter |
AcLyLayerFilter(AcLySystemInternals *) (defined in AcLyLayerFilter) | AcLyLayerFilter | protected
AcLySystemInternals (defined in AcLyLayerFilter) | AcLyLayerFilter | friend
ACRX_DECLARE_MEMBERS(AcLyLayerFilter) (defined in AcLyLayerFilter) | AcLyLayerFilter |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addNested(AcLyLayerFilter *filter) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
allowDelete() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
allowNested() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
allowRename() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
compareTo(const AcLyLayerFilter *pOther) const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DialogResult enum name (defined in AcLyLayerFilter) | AcLyLayerFilter |
dynamicallyGenerated() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
filter(AcDbLayerTableRecord *layer) const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
filterExpression() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
filterExpressionTree() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
generateNested() (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
getImages(HIMAGELIST &imageList, Adesk::UInt32 &normalImage, Adesk::UInt32 &selected) const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
getNestedFilters() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isIdFilter() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isProxy() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
kCancel enum value (defined in AcLyLayerFilter) | AcLyLayerFilter |
kOk enum value (defined in AcLyLayerFilter) | AcLyLayerFilter |
kUseDefault enum value (defined in AcLyLayerFilter) | AcLyLayerFilter |
name() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
parent() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readFrom(AcDbDxfFiler *filer) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
removeNested(AcLyLayerFilter *filter) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
setFilterExpression(const ACHAR *expr) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
setName(const ACHAR *) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
showEditor() (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
writeTo(AcDbDxfFiler *pFiler) const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcLyLayerFilter() (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcLyLayerFilterManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcLyLayerFilterManager Class Reference
AcLy Classes

Public Member Functions

virtual Acad::ErrorStatus | getFilters (AcLyLayerFilter *&pRoot, AcLyLayerFilter *&pCurrent)=0
virtual Acad::ErrorStatus | setFilters (const AcLyLayerFilter *pRoot, const AcLyLayerFilter *pCurrent)=0
The documentation for this class was generated from the following file:
  • acly.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcLyLayerFilterManager Member List

This is the complete list of members for AcLyLayerFilterManager, including all inherited members.

getFilters(AcLyLayerFilter *&pRoot, AcLyLayerFilter *&pCurrent)=0 (defined in AcLyLayerFilterManager) | AcLyLayerFilterManager | pure virtual
setFilters(const AcLyLayerFilter *pRoot, const AcLyLayerFilter *pCurrent)=0 (defined in AcLyLayerFilterManager) | AcLyLayerFilterManager | pure virtual


ZRX API Reference: AcLyLayerGroup Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcLyLayerGroup Class Reference
AcLy Classes
+ Inheritance diagram for AcLyLayerGroup:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcLyLayerGroup)
virtual Acad::ErrorStatus | addLayerId (const AcDbObjectId &id)
virtual const AcDbObjectIdArray & | layerIds () const
virtual Acad::ErrorStatus | removeLayerId (const AcDbObjectId &id)
- Public Member Functions inherited from AcLyLayerFilter
ACRX_DECLARE_MEMBERS (AcLyLayerFilter)
virtual Acad::ErrorStatus | addNested (AcLyLayerFilter *filter)
virtual bool | allowDelete () const
virtual bool | allowNested () const
virtual bool | allowRename () const
virtual bool | compareTo (const AcLyLayerFilter *pOther) const
virtual bool | dynamicallyGenerated () const
virtual bool | filter (AcDbLayerTableRecord *layer) const
virtual const ACHAR * | filterExpression () const
virtual const AcLyBoolExpr * | filterExpressionTree () const
virtual Acad::ErrorStatus | generateNested ()
virtual Acad::ErrorStatus | getImages (HIMAGELIST &imageList, Adesk::UInt32 &normalImage, Adesk::UInt32 &selected) const
virtual const AcArray
< AcLyLayerFilter * > & 		getNestedFilters () const
virtual bool | isIdFilter () const
virtual bool | isProxy () const
virtual const ACHAR * | name () const
virtual AcLyLayerFilter * | parent () const
virtual Acad::ErrorStatus | readFrom (AcDbDxfFiler *filer)
virtual Acad::ErrorStatus | removeNested (AcLyLayerFilter *filter)
virtual Acad::ErrorStatus | setFilterExpression (const ACHAR *expr)
virtual Acad::ErrorStatus | setName (const ACHAR *)
virtual DialogResult | showEditor ()
virtual Acad::ErrorStatus | writeTo (AcDbDxfFiler *pFiler) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcLyLayerGroup (AcLySystemInternals *)
- Protected Member Functions inherited from AcLyLayerFilter
AcLyLayerFilter (AcLySystemInternals *)

Additional Inherited Members

- Public Types inherited from AcLyLayerFilter
enum | DialogResult { kOk = 0, kCancel = 1, kUseDefault = 2 }
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • acly.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcLyLayerGroup Member List

This is the complete list of members for AcLyLayerGroup, including all inherited members.

AcLyLayerFilter() (defined in AcLyLayerFilter) | AcLyLayerFilter |
AcLyLayerFilter(AcLySystemInternals *) (defined in AcLyLayerFilter) | AcLyLayerFilter | protected
AcLyLayerGroup() (defined in AcLyLayerGroup) | AcLyLayerGroup |
AcLyLayerGroup(AcLySystemInternals *) (defined in AcLyLayerGroup) | AcLyLayerGroup | protected
ACRX_DECLARE_MEMBERS(AcLyLayerGroup) (defined in AcLyLayerGroup) | AcLyLayerGroup |
ACRX_DECLARE_MEMBERS(AcLyLayerFilter) (defined in AcLyLayerFilter) | AcLyLayerFilter |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLayerId(const AcDbObjectId &id) (defined in AcLyLayerGroup) | AcLyLayerGroup | virtual
addNested(AcLyLayerFilter *filter) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
allowDelete() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
allowNested() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
allowRename() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
compareTo(const AcLyLayerFilter *pOther) const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
DialogResult enum name (defined in AcLyLayerFilter) | AcLyLayerFilter |
dynamicallyGenerated() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
filter(AcDbLayerTableRecord *layer) const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
filterExpression() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
filterExpressionTree() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
generateNested() (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
getImages(HIMAGELIST &imageList, Adesk::UInt32 &normalImage, Adesk::UInt32 &selected) const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
getNestedFilters() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isIdFilter() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isProxy() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
kCancel enum value (defined in AcLyLayerFilter) | AcLyLayerFilter |
kOk enum value (defined in AcLyLayerFilter) | AcLyLayerFilter |
kUseDefault enum value (defined in AcLyLayerFilter) | AcLyLayerFilter |
layerIds() const (defined in AcLyLayerGroup) | AcLyLayerGroup | virtual
name() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
parent() const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readFrom(AcDbDxfFiler *filer) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
removeLayerId(const AcDbObjectId &id) (defined in AcLyLayerGroup) | AcLyLayerGroup | virtual
removeNested(AcLyLayerFilter *filter) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
setFilterExpression(const ACHAR *expr) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
setName(const ACHAR *) (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
showEditor() (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
writeTo(AcDbDxfFiler *pFiler) const (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcLyLayerFilter() (defined in AcLyLayerFilter) | AcLyLayerFilter | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcLyRelExpr Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcLyRelExpr Class Reference
AcLy Classes

Public Member Functions

virtual const ACHAR * | getConstant () const =0
virtual const ACHAR * | getVariable () const =0
The documentation for this class was generated from the following file:
  • acly.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcLyRelExpr Member List

This is the complete list of members for AcLyRelExpr, including all inherited members.

getConstant() const =0 (defined in AcLyRelExpr) | AcLyRelExpr | pure virtual
getVariable() const =0 (defined in AcLyRelExpr) | AcLyRelExpr | pure virtual


ZRX API Reference: AcPl Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Typedefs
AcPl Classes

Classes

class | AcPlDSDData
class | AcPlDSDEntry
class | AcPlHostAppServices
class | AcPlObject
class | AcPlPlotConfig
class | AcPlPlotConfigInfo
class | AcPlPlotConfigManager
class | AcPlPlotEngine
class | AcPlPlotErrorHandler
class | AcPlPlotErrorHandlerLock
class | AcPlPlotFactory
class | AcPlPlotInfo
class | AcPlPlotInfoValidator
class | AcPlPlotLogger
class | AcPlPlotLoggingErrorHandler
class | AcPlPlotPageInfo
class | AcPlPlotProgress
class | AcPlPlotProgressDialog
class | AcPlPlotReactor
class | AcPlPlotReactorMgr

Typedefs

typedef void(* ACPLPLTPRGHELPPROC )(AcPlPlotProgressDialog *pZcPlPlotProgressDialog)

Detailed Description


ZRX API Reference: AcPlDSDData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPlDSDData Class Reference
AcPl Classes
+ Inheritance diagram for AcPlDSDData:

Public Member Functions

ACPL_PORT | AcPlDSDData (const AcPlDSDData &src)
ACPL_PORT const ACHAR * | categoryName () const
ACPL_PORT const ACHAR * | destinationName () const
ACPL_PORT AcPlDSDEntry & | DSDEntryAt (int idx)
ACPL_PORT const AcPl3dDwfOptions & | get3dDwfOptions () const
ACPL_PORT void | getDSDEntries (AcPlDSDEntries &val) const
ACPL_PORT void | getUnrecognizedData (AcArray< ACHAR * > &sectionArray, AcArray< ACHAR * > &dataArray) const
ACPL_PORT bool | includeLayerInfo () const
ACPL_PORT bool | isHomogeneous () const
ACPL_PORT bool | isSheetSet () const
ACPL_PORT const ACHAR * | logFilePath () const
ACPL_PORT unsigned int | majorVersion () const
ACPL_PORT unsigned int | minorVersion () const
ACPL_PORT unsigned int | noOfCopies () const
ACPL_PORT int | numberOfDSDEntries () const
ACPL_PORT AcPlDSDData & | operator= (const AcPlDSDData &src)
ACPL_PORT const ACHAR * | password () const
ACPL_PORT bool | plotStampOn () const
ACPL_PORT const ACHAR * | projectPath () const
ACPL_PORT bool | promptForDwfName () const
ACPL_PORT bool | promptForPassword () const
ACPL_PORT bool | pwdProtectPublishedDWF () const
ACPL_PORT bool | readDSD (const ACHAR *pName)
ACPL_PORT const ACHAR * | selectionSetName () const
ACPL_PORT void | set3dDwfOptions (const AcPl3dDwfOptions &val)
ACPL_PORT void | setCategoryName (const ACHAR *pCategoryName)
ACPL_PORT void | setDestinationName (const ACHAR *pVal)
ACPL_PORT void | setDSDEntries (const AcPlDSDEntries &val)
ACPL_PORT void | setIncludeLayerInfo (bool bOn)
ACPL_PORT void | setIsHomogeneous (bool bHomogeneous)
ACPL_PORT void | setIsSheetSet (bool bSheetSet)
ACPL_PORT void | setLogFilePath (const ACHAR *pLogFilePath)
ACPL_PORT void | setMajorVersion (unsigned int majorVersion)
ACPL_PORT void | setMinorVersion (unsigned int minorVersion)
ACPL_PORT void | setNoOfCopies (unsigned int copies)
ACPL_PORT void | setPassword (const ACHAR *pVal)
ACPL_PORT void | setPlotStampOn (bool bOn)
ACPL_PORT void | setProjectPath (const ACHAR *pVal)
ACPL_PORT void | setPromptForDwfName (bool bPromptForDwfName)
ACPL_PORT void | setPromptForPassword (bool bPromptForPassword)
ACPL_PORT void | setPwdProtectPublishedDWF (bool bPwdProtectPublishedDWF)
ACPL_PORT void | setSelectionSetName (const ACHAR *pSelSetName)
ACPL_PORT void | setSheetSetName (const ACHAR *pSheetSetName)
ACPL_PORT void | setSheetType (AcPlDSDEntry::SheetType val)
ACPL_PORT void | setUnrecognizedData (const AcArray< ACHAR * > &sectionArray, const AcArray< ACHAR * > &dataArray)
ACPL_PORT void | setUnrecognizedData (const ACHAR *pSectionName, const ACHAR *pSectionData)
ACPL_PORT const ACHAR * | sheetSetName () const
ACPL_PORT AcPlDSDEntry::SheetType | sheetType () const
ACPL_PORT bool | writeDSD (const ACHAR *pName)
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcPlObject
AcPlObject (AcPlSystemInternals *)
The documentation for this class was generated from the following file:
  • acpldsddata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlDSDData Member List

This is the complete list of members for AcPlDSDData, including all inherited members.

AcPlDSDData() (defined in AcPlDSDData) | AcPlDSDData |
AcPlDSDData(const AcPlDSDData &src) (defined in AcPlDSDData) | AcPlDSDData |
AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
categoryName() const (defined in AcPlDSDData) | AcPlDSDData |
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
destinationName() const (defined in AcPlDSDData) | AcPlDSDData |
DSDEntryAt(int idx) (defined in AcPlDSDData) | AcPlDSDData |
get3dDwfOptions() const (defined in AcPlDSDData) | AcPlDSDData |
getDSDEntries(AcPlDSDEntries &val) const (defined in AcPlDSDData) | AcPlDSDData |
getUnrecognizedData(AcArray< ACHAR * > &sectionArray, AcArray< ACHAR * > &dataArray) const (defined in AcPlDSDData) | AcPlDSDData |
includeLayerInfo() const (defined in AcPlDSDData) | AcPlDSDData |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isHomogeneous() const (defined in AcPlDSDData) | AcPlDSDData |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isSheetSet() const (defined in AcPlDSDData) | AcPlDSDData |
logFilePath() const (defined in AcPlDSDData) | AcPlDSDData |
majorVersion() const (defined in AcPlDSDData) | AcPlDSDData |
minorVersion() const (defined in AcPlDSDData) | AcPlDSDData |
noOfCopies() const (defined in AcPlDSDData) | AcPlDSDData |
numberOfDSDEntries() const (defined in AcPlDSDData) | AcPlDSDData |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator=(const AcPlDSDData &src) (defined in AcPlDSDData) | AcPlDSDData |
password() const (defined in AcPlDSDData) | AcPlDSDData |
plotStampOn() const (defined in AcPlDSDData) | AcPlDSDData |
projectPath() const (defined in AcPlDSDData) | AcPlDSDData |
promptForDwfName() const (defined in AcPlDSDData) | AcPlDSDData |
promptForPassword() const (defined in AcPlDSDData) | AcPlDSDData |
pwdProtectPublishedDWF() const (defined in AcPlDSDData) | AcPlDSDData |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readDSD(const ACHAR *pName) (defined in AcPlDSDData) | AcPlDSDData |
selectionSetName() const (defined in AcPlDSDData) | AcPlDSDData |
set3dDwfOptions(const AcPl3dDwfOptions &val) (defined in AcPlDSDData) | AcPlDSDData |
setCategoryName(const ACHAR *pCategoryName) (defined in AcPlDSDData) | AcPlDSDData |
setDestinationName(const ACHAR *pVal) (defined in AcPlDSDData) | AcPlDSDData |
setDSDEntries(const AcPlDSDEntries &val) (defined in AcPlDSDData) | AcPlDSDData |
setIncludeLayerInfo(bool bOn) (defined in AcPlDSDData) | AcPlDSDData |
setIsHomogeneous(bool bHomogeneous) (defined in AcPlDSDData) | AcPlDSDData |
setIsSheetSet(bool bSheetSet) (defined in AcPlDSDData) | AcPlDSDData |
setLogFilePath(const ACHAR *pLogFilePath) (defined in AcPlDSDData) | AcPlDSDData |
setMajorVersion(unsigned int majorVersion) (defined in AcPlDSDData) | AcPlDSDData |
setMinorVersion(unsigned int minorVersion) (defined in AcPlDSDData) | AcPlDSDData |
setNoOfCopies(unsigned int copies) (defined in AcPlDSDData) | AcPlDSDData |
setPassword(const ACHAR *pVal) (defined in AcPlDSDData) | AcPlDSDData |
setPlotStampOn(bool bOn) (defined in AcPlDSDData) | AcPlDSDData |
setProjectPath(const ACHAR *pVal) (defined in AcPlDSDData) | AcPlDSDData |
setPromptForDwfName(bool bPromptForDwfName) (defined in AcPlDSDData) | AcPlDSDData |
setPromptForPassword(bool bPromptForPassword) (defined in AcPlDSDData) | AcPlDSDData |
setPwdProtectPublishedDWF(bool bPwdProtectPublishedDWF) (defined in AcPlDSDData) | AcPlDSDData |
setSelectionSetName(const ACHAR *pSelSetName) (defined in AcPlDSDData) | AcPlDSDData |
setSheetSetName(const ACHAR *pSheetSetName) (defined in AcPlDSDData) | AcPlDSDData |
setSheetType(AcPlDSDEntry::SheetType val) (defined in AcPlDSDData) | AcPlDSDData |
setUnrecognizedData(const AcArray< ACHAR * > &sectionArray, const AcArray< ACHAR * > &dataArray) (defined in AcPlDSDData) | AcPlDSDData |
setUnrecognizedData(const ACHAR *pSectionName, const ACHAR *pSectionData) (defined in AcPlDSDData) | AcPlDSDData |
sheetSetName() const (defined in AcPlDSDData) | AcPlDSDData |
sheetType() const (defined in AcPlDSDData) | AcPlDSDData |
writeDSD(const ACHAR *pName) (defined in AcPlDSDData) | AcPlDSDData |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlDSDData() (defined in AcPlDSDData) | AcPlDSDData | virtual
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlDSDEntry Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcPlDSDEntry Class Reference
AcPl Classes
+ Inheritance diagram for AcPlDSDEntry:

Public Types

enum SheetType {
kSingleDWF = 0, kMultiDWF = 1, kOriginalDevice = 2, kSingleDWFx = 3,
kMultiDWFx = 4, kSinglePDF = 5, kMultiPDF = 6
}

Public Member Functions

ACPL_PORT | AcPlDSDEntry (const AcPlDSDEntry &src)
ACPL_PORT const ACHAR * | dwgName () const
ACPL_PORT bool | has3dDwfSetup () const
ACPL_PORT const ACHAR * | layout () const
ACPL_PORT const ACHAR * | NPS () const
ACPL_PORT const ACHAR * | NPSSourceDWG () const
ACPL_PORT AcPlDSDEntry & | operator= (const AcPlDSDEntry &src)
ACPL_PORT void | setDwgName (const ACHAR *pName)
ACPL_PORT void | setHas3dDwfSetup (bool b3dDwfSetup)
ACPL_PORT void | setLayout (const ACHAR *pLayoutName)
ACPL_PORT void | setNPS (const ACHAR *pNPSName)
ACPL_PORT void | setNPSSourceDWG (const ACHAR *pNPWDWGName)
ACPL_PORT void | setTitle (const ACHAR *pTitle)
ACPL_PORT const ACHAR * | title () const
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcPlObject
AcPlObject (AcPlSystemInternals *)
The documentation for this class was generated from the following file:
  • acpldsdentry.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlDSDEntry Member List

This is the complete list of members for AcPlDSDEntry, including all inherited members.

AcPlDSDEntry() (defined in AcPlDSDEntry) | AcPlDSDEntry |
AcPlDSDEntry(const AcPlDSDEntry &src) (defined in AcPlDSDEntry) | AcPlDSDEntry |
AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgName() const (defined in AcPlDSDEntry) | AcPlDSDEntry |
has3dDwfSetup() const (defined in AcPlDSDEntry) | AcPlDSDEntry |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kMultiDWF enum value (defined in AcPlDSDEntry) | AcPlDSDEntry |
kMultiDWFx enum value (defined in AcPlDSDEntry) | AcPlDSDEntry |
kMultiPDF enum value (defined in AcPlDSDEntry) | AcPlDSDEntry |
kOriginalDevice enum value (defined in AcPlDSDEntry) | AcPlDSDEntry |
kSingleDWF enum value (defined in AcPlDSDEntry) | AcPlDSDEntry |
kSingleDWFx enum value (defined in AcPlDSDEntry) | AcPlDSDEntry |
kSinglePDF enum value (defined in AcPlDSDEntry) | AcPlDSDEntry |
layout() const (defined in AcPlDSDEntry) | AcPlDSDEntry |
NPS() const (defined in AcPlDSDEntry) | AcPlDSDEntry |
NPSSourceDWG() const (defined in AcPlDSDEntry) | AcPlDSDEntry |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator=(const AcPlDSDEntry &src) (defined in AcPlDSDEntry) | AcPlDSDEntry |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setDwgName(const ACHAR *pName) (defined in AcPlDSDEntry) | AcPlDSDEntry |
setHas3dDwfSetup(bool b3dDwfSetup) (defined in AcPlDSDEntry) | AcPlDSDEntry |
setLayout(const ACHAR *pLayoutName) (defined in AcPlDSDEntry) | AcPlDSDEntry |
setNPS(const ACHAR *pNPSName) (defined in AcPlDSDEntry) | AcPlDSDEntry |
setNPSSourceDWG(const ACHAR *pNPWDWGName) (defined in AcPlDSDEntry) | AcPlDSDEntry |
setTitle(const ACHAR *pTitle) (defined in AcPlDSDEntry) | AcPlDSDEntry |
SheetType enum name (defined in AcPlDSDEntry) | AcPlDSDEntry |
title() const (defined in AcPlDSDEntry) | AcPlDSDEntry |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlDSDEntry() (defined in AcPlDSDEntry) | AcPlDSDEntry | virtual
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlHostAppServices Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcPlHostAppServices Class Reference
AcPl Classes

Public Types

enum PlotStatus {
kSheetIdxAndName = -5, kDisableCancelSheet = -4, kDwfFilePlotted = -3, kPlottingMsg = -2,
kNoPlotYet = -1, kPlotStart = 0, kViewPlotLog = 1, kPlotSuccessful = 2,
kPlotHadErrors = 3, kPlotHadSystemError = 4
}

Public Member Functions

virtual const
ZwcadPlotInternalServices * 		acadInternalServices ()=0
virtual AcPlPlotLogger * | getPlotLogger (void)=0
virtual void | updatePlotJobStatus (enum AcPlHostAppServices::PlotStatus nStatus, const ACHAR *szPlotMsg)=0
The documentation for this class was generated from the following file:
  • acplhostappservices.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlHostAppServices Member List

This is the complete list of members for AcPlHostAppServices, including all inherited members.

acadInternalServices()=0 (defined in AcPlHostAppServices) | AcPlHostAppServices | pure virtual
getPlotLogger(void)=0 (defined in AcPlHostAppServices) | AcPlHostAppServices | pure virtual
kDisableCancelSheet enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
kDwfFilePlotted enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
kNoPlotYet enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
kPlotHadErrors enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
kPlotHadSystemError enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
kPlotStart enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
kPlotSuccessful enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
kPlottingMsg enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
kSheetIdxAndName enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
kViewPlotLog enum value (defined in AcPlHostAppServices) | AcPlHostAppServices |
PlotStatus enum name (defined in AcPlHostAppServices) | AcPlHostAppServices |
updatePlotJobStatus(enum AcPlHostAppServices::PlotStatus nStatus, const ACHAR *szPlotMsg)=0 (defined in AcPlHostAppServices) | AcPlHostAppServices | pure virtual


ZRX API Reference: AcPlObject Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcPlObject Class Reference
AcPl Classes
+ Inheritance diagram for AcPlObject:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcPlObject (AcPlSystemInternals *)

Friends

class AcPlSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • acplobject.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlObject Member List

This is the complete list of members for AcPlObject, including all inherited members.

AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
AcPlSystemInternals (defined in AcPlObject) | AcPlObject | friend
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotConfig Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Friends | List of all members
AcPlPlotConfig Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotConfig:

Public Types

enum PlotToFileCapability { kNoPlotToFile = 0, kPlotToFileAllowed = 1, kMustPlotToFile = 2 }

Public Member Functions

virtual ACPL_PORT Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
virtual ACPL_PORT const ACHAR * | deviceName () const
virtual ACPL_PORT unsigned long | deviceType () const
virtual ACPL_PORT const ACHAR * | fullPath () const
virtual ACPL_PORT void | getCanonicalMediaNameList (AcArray< ACHAR * > &mediaList) const
virtual ACPL_PORT Acad::ErrorStatus | getDefaultFileExtension (const ACHAR *&pDefaultExtension) const
virtual ACPL_PORT void | getDescriptionFields (ACHAR *&pDriverName, ACHAR *&pLocationName, ACHAR *&pComment, ACHAR *&pPortName, ACHAR *&pServerName, ACHAR *&pTagLine) const
virtual ACPL_PORT void | getLocalMediaName (const ACHAR *pCanonicalMediaName, ACHAR *&pLocalMediaName) const
virtual ACPL_PORT void | getMediaBounds (const ACHAR *pCanonicalMediaName, AcGePoint2d &pageSize, AcGeBoundBlock2d &printableArea) const
virtual ACPL_PORT unsigned long | isCustomPossible (double width, double height, bool bIsDimensional, bool bIsSheet, int dpi, const ACHAR *pPC3Dir) const
virtual ACPL_PORT bool | isPlotToFile () const
virtual ACPL_PORT Acad::ErrorStatus | makeCustomMediaFromSizeDesc (HT_Media_Size *pSize, HT_Media_Description *pDesc, bool bSameDriver, bool bSavePC3, const ACHAR *pSourceEntry, const ACHAR *pSourceName, ACHAR *&pCanonicalSizeName, ACHAR *&pLocalizedSizeName, ACHAR *&pPMPPath, ACHAR *&pPC3Path, int dpi, double &scaleFactor)
virtual ACPL_PORT bool | matchMediaSize (double page_x, double page_y, double printable_w, double printable_h, AcDbLayout::PlotPaperUnits units, bool bIsSheet, int dpi, const ACHAR *pTargetCanonicalName, ACHAR *&pNearestSizeName, ACHAR *&pLocalizedName, double &scaleFactor)
virtual ACPL_PORT unsigned int | maxDeviceDPI () const
virtual ACPL_PORT HT_Plot_Config * | plotConfig () const
virtual ACPL_PORT
PlotToFileCapability 		plotToFileCapability () const
virtual ACPL_PORT void | refreshMediaNameList ()
virtual ACPL_PORT bool | saveToPC3 (const ACHAR *pPC3Name)
virtual ACPL_PORT Acad::ErrorStatus | setPlotToFile (bool bPlotToFile)
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

AcPlPlotConfig (HT_Plot_Config *pConfig, const ACHAR *pDevName, const ACHAR *pFullPath, unsigned long nDevType)
AcPlPlotConfig (const AcPlPlotConfig *pOther)
- Protected Member Functions inherited from AcPlObject
AcPlObject (AcPlSystemInternals *)

Friends

class | AcPlPlotConfigManagerImp
class | AcPlPlotInfoImp
class | AcPlPlotInfoValidatorImp

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • acplplotconfig.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotConfig Member List

This is the complete list of members for AcPlPlotConfig, including all inherited members.

AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
AcPlPlotConfig(HT_Plot_Config *pConfig, const ACHAR *pDevName, const ACHAR *pFullPath, unsigned long nDevType) (defined in AcPlPlotConfig) | AcPlPlotConfig | protected
AcPlPlotConfig(const AcPlPlotConfig *pOther) (defined in AcPlPlotConfig) | AcPlPlotConfig | protected
AcPlPlotConfigManagerImp (defined in AcPlPlotConfig) | AcPlPlotConfig | friend
AcPlPlotInfoImp (defined in AcPlPlotConfig) | AcPlPlotConfig | friend
AcPlPlotInfoValidatorImp (defined in AcPlPlotConfig) | AcPlPlotConfig | friend
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
desc() (defined in AcRxObject) | AcRxObject | static
deviceName() const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
deviceType() const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
fullPath() const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
getCanonicalMediaNameList(AcArray< ACHAR * > &mediaList) const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
getDefaultFileExtension(const ACHAR *&pDefaultExtension) const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
getDescriptionFields(ACHAR *&pDriverName, ACHAR *&pLocationName, ACHAR *&pComment, ACHAR *&pPortName, ACHAR *&pServerName, ACHAR *&pTagLine) const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
getLocalMediaName(const ACHAR *pCanonicalMediaName, ACHAR *&pLocalMediaName) const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
getMediaBounds(const ACHAR *pCanonicalMediaName, AcGePoint2d &pageSize, AcGeBoundBlock2d &printableArea) const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isCustomPossible(double width, double height, bool bIsDimensional, bool bIsSheet, int dpi, const ACHAR *pPC3Dir) const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isPlotToFile() const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
kMustPlotToFile enum value (defined in AcPlPlotConfig) | AcPlPlotConfig |
kNoPlotToFile enum value (defined in AcPlPlotConfig) | AcPlPlotConfig |
kPlotToFileAllowed enum value (defined in AcPlPlotConfig) | AcPlPlotConfig |
makeCustomMediaFromSizeDesc(HT_Media_Size *pSize, HT_Media_Description *pDesc, bool bSameDriver, bool bSavePC3, const ACHAR *pSourceEntry, const ACHAR *pSourceName, ACHAR *&pCanonicalSizeName, ACHAR *&pLocalizedSizeName, ACHAR *&pPMPPath, ACHAR *&pPC3Path, int dpi, double &scaleFactor) (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
matchMediaSize(double page_x, double page_y, double printable_w, double printable_h, AcDbLayout::PlotPaperUnits units, bool bIsSheet, int dpi, const ACHAR *pTargetCanonicalName, ACHAR *&pNearestSizeName, ACHAR *&pLocalizedName, double &scaleFactor) (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
maxDeviceDPI() const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
plotConfig() const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
PlotToFileCapability enum name (defined in AcPlPlotConfig) | AcPlPlotConfig |
plotToFileCapability() const (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
refreshMediaNameList() (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
saveToPC3(const ACHAR *pPC3Name) (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
setPlotToFile(bool bPlotToFile) (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcPlPlotConfig() (defined in AcPlPlotConfig) | AcPlPlotConfig | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotConfigInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPlPlotConfigInfo Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotConfigInfo:

Public Member Functions

ACPL_DECLARE_MEMBERS (AcPlPlotConfigInfo)
ACPL_PORT | AcPlPlotConfigInfo (const ACHAR *pDevName, const ACHAR *pFullPath, DeviceType devType)
ACPL_PORT | AcPlPlotConfigInfo (const AcPlPlotConfigInfo &copy)
ACPL_PORT Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
ACPL_PORT const ACHAR * | deviceName () const
ACPL_PORT DeviceType | deviceType () const
ACPL_PORT const ACHAR * | fullPath () const
ACPL_PORT const
AcPlPlotConfigInfo & 		operator= (const AcPlPlotConfigInfo &src)
ACPL_PORT void | setDeviceName (const ACHAR *pDevName)
ACPL_PORT void | setDeviceType (DeviceType devType)
ACPL_PORT void | setFullPath (const ACHAR *pPath)
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcPlObject
AcPlObject (AcPlSystemInternals *)
The documentation for this class was generated from the following file:
  • acplplotconfigmgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotConfigInfo Member List

This is the complete list of members for AcPlPlotConfigInfo, including all inherited members.

ACPL_DECLARE_MEMBERS(AcPlPlotConfigInfo) (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
AcPlPlotConfigInfo() (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
AcPlPlotConfigInfo(const ACHAR *pDevName, const ACHAR *pFullPath, DeviceType devType) (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
AcPlPlotConfigInfo(const AcPlPlotConfigInfo &copy) (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo | virtual
desc() (defined in AcRxObject) | AcRxObject | static
deviceName() const (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
deviceType() const (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
fullPath() const (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator=(const AcPlPlotConfigInfo &src) (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setDeviceName(const ACHAR *pDevName) (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
setDeviceType(DeviceType devType) (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
setFullPath(const ACHAR *pPath) (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcPlPlotConfigInfo() (defined in AcPlPlotConfigInfo) | AcPlPlotConfigInfo | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotConfigManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcPlPlotConfigManager Class Reference
AcPl Classes

Public Types

enum RefreshCode {
kAll, kRefreshDevicesList, kRefreshStyleList, kRefreshSystemDevicesList,
kRefreshPC3DevicesList
}
enum StdConfigs {
kNoneDevice, kDefaultWindowsSysPrinter, kDWF6ePlot, kDWFePlotOptForPlotting,
kDWFePlotOptForViewing, kPublishToWebDWF, kPublishToWebJPG, kPublishToWebPNG,
kDWFxePlot, kPublishToWebDWFx, kPDFePlot
}
enum StyTypes {
kUndefined = 0, kRegular = 0x01, kTranslation = 0x02, kColorDep = 0x04,
kAllTypes = 0x07
}

Public Member Functions

virtual HT_Error_Handler * | acadErrorHandler ()
virtual HT_Error_Handler * | errorHandler ()
virtual Acad::ErrorStatus | getCurrentConfig (AcPlPlotConfig *&pConfig)
virtual bool | getDevicesList (AcArray< AcPlPlotConfigInfo, AcArrayObjectCopyReallocator< AcPlPlotConfigInfo > > &deviceList)
virtual const ACHAR * | getStdConfigName (StdConfigs stdConfig)
virtual bool | getStyleList (AcArray< ACHAR * > &list, long styType=kAllTypes)
virtual void | refreshList (RefreshCode refreshCode=kAll)
virtual Acad::ErrorStatus | setCurrentConfig (AcPlPlotConfig *&pConfig, const ACHAR *pDeviceName)
virtual
HT_Thin_Plot_Config_Manager * 		thinPltCfgMgr ()
The documentation for this class was generated from the following file:
  • acplplotconfigmgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotConfigManager Member List

This is the complete list of members for AcPlPlotConfigManager, including all inherited members.

acadErrorHandler() (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager | virtual
errorHandler() (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager | virtual
getCurrentConfig(AcPlPlotConfig *&pConfig) (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager | virtual
getDevicesList(AcArray< AcPlPlotConfigInfo, AcArrayObjectCopyReallocator< AcPlPlotConfigInfo > > &deviceList) (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager | virtual
getStdConfigName(StdConfigs stdConfig) (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager | virtual
getStyleList(AcArray< ACHAR * > &list, long styType=kAllTypes) (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager | virtual
kAll enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kAllTypes enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kColorDep enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kDefaultWindowsSysPrinter enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kDWF6ePlot enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kDWFePlotOptForPlotting enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kDWFePlotOptForViewing enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kDWFxePlot enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kNoneDevice enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kPDFePlot enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kPublishToWebDWF enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kPublishToWebDWFx enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kPublishToWebJPG enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kPublishToWebPNG enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kRefreshDevicesList enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kRefreshPC3DevicesList enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kRefreshStyleList enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kRefreshSystemDevicesList enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kRegular enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kTranslation enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
kUndefined enum value (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
RefreshCode enum name (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
refreshList(RefreshCode refreshCode=kAll) (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager | virtual
setCurrentConfig(AcPlPlotConfig *&pConfig, const ACHAR *pDeviceName) (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager | virtual
StdConfigs enum name (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
StyTypes enum name (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager |
thinPltCfgMgr() (defined in AcPlPlotConfigManager) | AcPlPlotConfigManager | virtual


ZRX API Reference: AcPlPlotEngine Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPlPlotEngine Class Reference
AcPl Classes

Public Member Functions

virtual Acad::ErrorStatus | beginDocument (AcPlPlotInfo &plotInfo, const ACHAR *pDocname, void *pParams=NULL, long nCopies=1, bool bPlotToFile=false, const ACHAR *pFileName=NULL)
virtual Acad::ErrorStatus | beginGenerateGraphics (void *pParams=NULL)
virtual Acad::ErrorStatus | beginGenerateGraphics (AcViewport *&pViewport, void *pParams=NULL)
virtual Acad::ErrorStatus | beginPage (AcPlPlotPageInfo &pageInfo, AcPlPlotInfo &plotInfo, bool bLastPage, void *pParams=NULL)
virtual Acad::ErrorStatus | beginPlot (AcPlPlotProgress *pPlotProgress, void *pParams=NULL)
virtual void | destroy ()
virtual Acad::ErrorStatus | endDocument (void *pParams=NULL)
virtual Acad::ErrorStatus | endGenerateGraphics (void *pParams=NULL)
virtual Acad::ErrorStatus | endPage (void *pParams=NULL)
virtual Acad::ErrorStatus | endPlot (void *pParams=NULL)
virtual bool | isBackgroundPackaging () const
The documentation for this class was generated from the following file:
  • acplplotengine.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotEngine Member List

This is the complete list of members for AcPlPlotEngine, including all inherited members.

beginDocument(AcPlPlotInfo &plotInfo, const ACHAR *pDocname, void *pParams=NULL, long nCopies=1, bool bPlotToFile=false, const ACHAR *pFileName=NULL) (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
beginGenerateGraphics(void *pParams=NULL) (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
beginGenerateGraphics(AcViewport *&pViewport, void *pParams=NULL) (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
beginPage(AcPlPlotPageInfo &pageInfo, AcPlPlotInfo &plotInfo, bool bLastPage, void *pParams=NULL) (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
beginPlot(AcPlPlotProgress *pPlotProgress, void *pParams=NULL) (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
destroy() (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
endDocument(void *pParams=NULL) (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
endGenerateGraphics(void *pParams=NULL) (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
endPage(void *pParams=NULL) (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
endPlot(void *pParams=NULL) (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual
isBackgroundPackaging() const (defined in AcPlPlotEngine) | AcPlPlotEngine | virtual


ZRX API Reference: AcPlPlotErrorHandler Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
AcPlPlotErrorHandler Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotErrorHandler:

Public Types

enum ErrorResult { kAbort, kRetry, kIgnore }
enum Handler {
kInfo, kWarning, kError, kARI,
kSevere, kTerminal, kNone
}

Public Member Functions

ACPL_DECLARE_MEMBERS (AcPlPlotErrorHandler)
virtual ACPL_PORT ErrorResult | ariError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT const ACHAR * | ariTitle () const
virtual ACPL_PORT ErrorResult | error (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT const ACHAR * | errorTitle () const
ACPL_PORT void | getCompanyString (ACHAR *&pCompanyString) const
ACPL_PORT void | getProductString (ACHAR *&pProductString) const
ACPL_PORT void | getProgramString (ACHAR *&pProgramString) const
virtual ACPL_PORT void | info (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT void | infoMessage (const ACHAR *pMessage)
virtual ACPL_PORT const ACHAR * | infoTitle () const
virtual ACPL_PORT void | logMessage (const ACHAR *pTitle, const ACHAR *pMsg)
virtual ACPL_PORT bool | logMode () const
virtual ACPL_PORT int | messageBox (const ACHAR *pText, const ACHAR *pCaption, unsigned int uType, int defaultReturn)
virtual ACPL_PORT bool | quietMode () const
virtual ACPL_PORT bool | setLogHandle (const ACHAR *pFilePathName)
virtual ACPL_PORT void | setLogMode (bool bLog)
virtual ACPL_PORT void | setQuietMode (bool bQuiet)
virtual ACPL_PORT void | severeError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT const ACHAR * | severeTitle () const
virtual ACPL_PORT bool | takeResponsibility (Handler kind)
virtual ACPL_PORT void | terminalError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT const ACHAR * | terminalTitle () const
virtual ACPL_PORT ErrorResult | warning (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT const ACHAR * | warningTitle () const
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

ACPL_PORT ErrorResult | appARIError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT ErrorResult | appError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT void | appInfo (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT void | appInfoMessage (const ACHAR *pMessage)
ACPL_PORT void | appLogMessage (const ACHAR *pTitle, const ACHAR *pMsg)
ACPL_PORT int | appMessageBox (const ACHAR *pText, const ACHAR *pCaption, unsigned int uType, int defaultReturn)
ACPL_PORT bool | appSetLogHandle (const ACHAR *pFilePathName)
ACPL_PORT void | appSevereError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT void | appTerminalError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT ErrorResult | appWarning (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
- Protected Member Functions inherited from AcPlObject
AcPlObject (AcPlSystemInternals *)

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • acplploterrorhandler.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotErrorHandler Member List

This is the complete list of members for AcPlPlotErrorHandler, including all inherited members.

ACPL_DECLARE_MEMBERS(AcPlPlotErrorHandler) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
AcPlPlotErrorHandler() (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
appARIError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appInfo(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appInfoMessage(const ACHAR *pMessage) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appLogMessage(const ACHAR *pTitle, const ACHAR *pMsg) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appMessageBox(const ACHAR *pText, const ACHAR *pCaption, unsigned int uType, int defaultReturn) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appSetLogHandle(const ACHAR *pFilePathName) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appSevereError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appTerminalError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appWarning(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
ariError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
ariTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
error(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
ErrorResult enum name (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
errorTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
getCompanyString(ACHAR *&pCompanyString) const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
getProductString(ACHAR *&pProductString) const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
getProgramString(ACHAR *&pProgramString) const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
Handler enum name (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
info(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
infoMessage(const ACHAR *pMessage) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
infoTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAbort enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kARI enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kError enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kIgnore enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kInfo enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kNone enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kRetry enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kSevere enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kTerminal enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kWarning enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
logMessage(const ACHAR *pTitle, const ACHAR *pMsg) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
logMode() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
messageBox(const ACHAR *pText, const ACHAR *pCaption, unsigned int uType, int defaultReturn) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
quietMode() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
setLogHandle(const ACHAR *pFilePathName) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
setLogMode(bool bLog) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
setQuietMode(bool bQuiet) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
severeError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
severeTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
takeResponsibility(Handler kind) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
terminalError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
terminalTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
warning(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
warningTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcPlPlotErrorHandler() (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotErrorHandlerLock Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcPlPlotErrorHandlerLock Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotErrorHandlerLock:

Public Types

enum LockStatus { kLocked, kUnLocked }

Public Member Functions

ACPL_PORT | AcPlPlotErrorHandlerLock (AcPlPlotErrorHandler *pAppErrHandler, const ACHAR *pAppName)
ACPL_PORT const ACHAR * | appName () const
ACPL_PORT void | getErrorHandler (AcPlPlotErrorHandler *&pAppErrHandler) const
ACPL_PORT bool | lock (AcPlPlotErrorHandler *pAppErrHandler, const ACHAR *pAppName)
ACPL_PORT LockStatus | status () const
ACPL_PORT bool | unLock (AcPlPlotErrorHandler *pAppErrHandler)
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcPlObject
AcPlObject (AcPlSystemInternals *)
The documentation for this class was generated from the following file:
  • acplploterrorhandlerlock.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotErrorHandlerLock Member List

This is the complete list of members for AcPlPlotErrorHandlerLock, including all inherited members.

AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
AcPlPlotErrorHandlerLock() (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
AcPlPlotErrorHandlerLock(AcPlPlotErrorHandler *pAppErrHandler, const ACHAR *pAppName) (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
appName() const (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getErrorHandler(AcPlPlotErrorHandler *&pAppErrHandler) const (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kLocked enum value (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
kUnLocked enum value (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
lock(AcPlPlotErrorHandler *pAppErrHandler, const ACHAR *pAppName) (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
LockStatus enum name (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
status() const (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
unLock(AcPlPlotErrorHandler *pAppErrHandler) (defined in AcPlPlotErrorHandlerLock) | AcPlPlotErrorHandlerLock |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotFactory Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Static Public Member Functions | List of all members
AcPlPlotFactory Class Reference
AcPl Classes

Public Types

enum PreviewEngineFlags { kShowPlot = 0x0001, kShowNextSheet = 0x0002, kShowPreviousSheet = 0x0004 }

Static Public Member Functions

static ACPL_PORT Acad::ErrorStatus | createPreviewEngine (AcPlPlotEngine *&pPreview, long nPreviewFlags=kShowPlot)
static ACPL_PORT Acad::ErrorStatus | createPublishEngine (AcPlPlotEngine *&pEngine)
The documentation for this class was generated from the following file:
  • acplplotfactory.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotFactory Member List

This is the complete list of members for AcPlPlotFactory, including all inherited members.

createPreviewEngine(AcPlPlotEngine *&pPreview, long nPreviewFlags=kShowPlot) (defined in AcPlPlotFactory) | AcPlPlotFactory | static
createPublishEngine(AcPlPlotEngine *&pEngine) (defined in AcPlPlotFactory) | AcPlPlotFactory | static
kShowNextSheet enum value (defined in AcPlPlotFactory) | AcPlPlotFactory |
kShowPlot enum value (defined in AcPlPlotFactory) | AcPlPlotFactory |
kShowPreviousSheet enum value (defined in AcPlPlotFactory) | AcPlPlotFactory |
PreviewEngineFlags enum name (defined in AcPlPlotFactory) | AcPlPlotFactory |


ZRX API Reference: AcPlPlotInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcPlPlotInfo Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotInfo:

Public Types

enum MergeStatus {
kNoChanges = 0x00000000, kPlotCfgName = 0x00000001, kPlotPaperMargins = 0x00000002, kPlotPaperSize = 0x00000004,
kCanonicalMediaName = 0x00000008, kPlotOrigin = 0x00000010, kPlotPaperUnits = 0x00000020, kPlotViewportBorders = 0x00000040,
kPlotPlotStyles = 0x00000080, kShowPlotStyles = 0x00000100, kPlotRotation = 0x00000200, kPlotCentered = 0x00000400,
kPlotHidden = 0x00000800, kShadePlot = 0x00001000, kShadePlotResLevel = 0x00002000, kShadePlotCustomDPI = 0x00004000,
kPlotType = 0x00008000, kPlotWindowArea = 0x00010000, kPlotViewName = 0x00020000, kScale = 0x00040000,
kCurrentStlyeSheet = 0x00080000, kScaleLineWeights = 0x00100000, kPrintLineWeights = 0x00200000, kDrawViewportsFirst = 0x00400000
}

Public Member Functions

ACPL_DECLARE_MEMBERS (AcPlPlotInfo)
ACPL_PORT Acad::ErrorStatus | copyFrom (const AcRxObject *pOther)
ACPL_PORT const AcPlPlotConfig * | deviceOverride () const
ACPL_PORT bool | isCompatibleDocument (const AcPlPlotInfo *pOtherInfo) const
ACPL_PORT bool | isValidated () const
ACPL_PORT AcDbObjectId | layout () const
ACPL_PORT unsigned long | mergeStatus () const
ACPL_PORT const AcDbPlotSettings * | overrideSettings () const
ACPL_PORT void | setDeviceOverride (const AcPlPlotConfig *pconf)
ACPL_PORT void | setLayout (AcDbObjectId &layoutId)
ACPL_PORT void | setOverrideSettings (const AcDbPlotSettings *pOverrides)
ACPL_PORT void | setValidatedConfig (const AcPlPlotConfig *pConfig)
ACPL_PORT Acad::ErrorStatus | setValidatedSettings (const AcDbPlotSettings *pValidatedSettings)
ACPL_PORT const AcPlPlotConfig * | validatedConfig () const
ACPL_PORT const AcDbPlotSettings * | validatedSettings () const
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcPlObject
AcPlObject (AcPlSystemInternals *)
The documentation for this class was generated from the following file:
  • acplplotinfo.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotInfo Member List

This is the complete list of members for AcPlPlotInfo, including all inherited members.

ACPL_DECLARE_MEMBERS(AcPlPlotInfo) (defined in AcPlPlotInfo) | AcPlPlotInfo |
AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
AcPlPlotInfo() (defined in AcPlPlotInfo) | AcPlPlotInfo |
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *pOther) (defined in AcPlPlotInfo) | AcPlPlotInfo | virtual
desc() (defined in AcRxObject) | AcRxObject | static
deviceOverride() const (defined in AcPlPlotInfo) | AcPlPlotInfo |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isCompatibleDocument(const AcPlPlotInfo *pOtherInfo) const (defined in AcPlPlotInfo) | AcPlPlotInfo |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isValidated() const (defined in AcPlPlotInfo) | AcPlPlotInfo |
kCanonicalMediaName enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kCurrentStlyeSheet enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kDrawViewportsFirst enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kNoChanges enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotCentered enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotCfgName enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotHidden enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotOrigin enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotPaperMargins enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotPaperSize enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotPaperUnits enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotPlotStyles enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotRotation enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotType enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotViewName enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotViewportBorders enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPlotWindowArea enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kPrintLineWeights enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kScale enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kScaleLineWeights enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kShadePlot enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kShadePlotCustomDPI enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kShadePlotResLevel enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
kShowPlotStyles enum value (defined in AcPlPlotInfo) | AcPlPlotInfo |
layout() const (defined in AcPlPlotInfo) | AcPlPlotInfo |
MergeStatus enum name (defined in AcPlPlotInfo) | AcPlPlotInfo |
mergeStatus() const (defined in AcPlPlotInfo) | AcPlPlotInfo |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
overrideSettings() const (defined in AcPlPlotInfo) | AcPlPlotInfo |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setDeviceOverride(const AcPlPlotConfig *pconf) (defined in AcPlPlotInfo) | AcPlPlotInfo |
setLayout(AcDbObjectId &layoutId) (defined in AcPlPlotInfo) | AcPlPlotInfo |
setOverrideSettings(const AcDbPlotSettings *pOverrides) (defined in AcPlPlotInfo) | AcPlPlotInfo |
setValidatedConfig(const AcPlPlotConfig *pConfig) (defined in AcPlPlotInfo) | AcPlPlotInfo |
setValidatedSettings(const AcDbPlotSettings *pValidatedSettings) (defined in AcPlPlotInfo) | AcPlPlotInfo |
validatedConfig() const (defined in AcPlPlotInfo) | AcPlPlotInfo |
validatedSettings() const (defined in AcPlPlotInfo) | AcPlPlotInfo |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcPlPlotInfo() (defined in AcPlPlotInfo) | AcPlPlotInfo | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotInfoValidator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Attributes | List of all members
AcPlPlotInfoValidator Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotInfoValidator:

Public Types

enum eCustomSizeResult {
ePossible = 0x0000, eMustCreatePC3 = 0x0001, eRotationRequired = 0x0002, ePC3DirReadOnly = 0x0004,
ePMPDirReadOnly = 0x0008, ePMPDirMissing = 0x0010, eUnknownErrPMPDir = 0x0020, ePC3FileReadOnly = 0x0040,
eSizeTooBig = 0x0080, eException = 0x0100, eUnknownErrPC3File = 0x0200, eUnknownErrPMPFile = 0x0400,
ePMPFileReadOnly = 0x0800, eWidthAndHeightMustBePositive = 0x1000, eDeviceLoadFailed = 0x2000
}
enum MatchingPolicy { kMatchDisabled = 1, kMatchEnabled, kMatchEnabledCustom, kMatchEnabledTmpCustom }

Public Member Functions

ACPL_DECLARE_MEMBERS (AcPlPlotInfoValidator)
ACPL_PORT unsigned int | dimensionalWeight () const
virtual ACPL_PORT unsigned long | isCustomPossible (AcPlPlotInfo &info) const
ACPL_PORT MatchingPolicy | matchingPolicy () const
ACPL_PORT unsigned int | mediaBoundsWeight () const
ACPL_PORT unsigned int | mediaGroupWeight () const
ACPL_PORT unsigned int | mediaMatchingThreshold () const
ACPL_PORT unsigned int | printableBoundsWeight () const
ACPL_PORT void | setDimensionalWeight (unsigned int weight=DEFAULT_DIMENSIONAL_WEIGHT)
ACPL_PORT void | setMediaBoundsWeight (unsigned int weight=DEFAULT_MEDIA_BOUNDS_WEIGHT)
ACPL_PORT void | setMediaGroupWeight (unsigned int weight=DEFAULT_MEDIA_GROUP_WEIGHT)
ACPL_PORT void | setMediaMatchingPolicy (MatchingPolicy policy)
ACPL_PORT void | setMediaMatchingThreshold (unsigned int threshold=DEFAULT_THRESHOLD)
ACPL_PORT void | setPrintableBoundsWeight (unsigned int weight=DEFAULT_PRINTABLE_BOUNDS_WEIGHT)
ACPL_PORT void | setSheetDimensionalWeight (unsigned int weight=DEFAULT_SHEET_DIMENSIONAL_WEIGHT)
ACPL_PORT void | setSheetMediaGroupWeight (unsigned int weight=DEFAULT_SHEET_MEDIA_GROUP_WEIGHT)
ACPL_PORT unsigned int | sheetDimensionalWeight () const
ACPL_PORT unsigned int | sheetMediaGroupWeight () const
virtual ACPL_PORT Acad::ErrorStatus | validate (AcPlPlotInfo &info)
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Attributes

unsigned int | m_dimensionalWeight
MatchingPolicy | m_matchingPolicy
unsigned int | m_matchingThreshold
unsigned int | m_mediaBoundsWeight
unsigned int | m_mediaGroupWeight
unsigned int | m_printableBoundsWeight
unsigned int | m_sheetDimensionalWeight
unsigned int | m_sheetMediaGroupWeight

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcPlObject
AcPlObject (AcPlSystemInternals *)
The documentation for this class was generated from the following file:
  • acplplotinfovalidator.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotInfoValidator Member List

This is the complete list of members for AcPlPlotInfoValidator, including all inherited members.

ACPL_DECLARE_MEMBERS(AcPlPlotInfoValidator) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
AcPlPlotInfoValidator() (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dimensionalWeight() const (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eCustomSizeResult enum name (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eDeviceLoadFailed enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eException enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eMustCreatePC3 enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
ePC3DirReadOnly enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
ePC3FileReadOnly enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
ePMPDirMissing enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
ePMPDirReadOnly enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
ePMPFileReadOnly enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
ePossible enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eRotationRequired enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eSizeTooBig enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eUnknownErrPC3File enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eUnknownErrPMPDir enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eUnknownErrPMPFile enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
eWidthAndHeightMustBePositive enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isCustomPossible(AcPlPlotInfo &info) const (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kMatchDisabled enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
kMatchEnabled enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
kMatchEnabledCustom enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
kMatchEnabledTmpCustom enum value (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
m_dimensionalWeight (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | protected
m_matchingPolicy (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | protected
m_matchingThreshold (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | protected
m_mediaBoundsWeight (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | protected
m_mediaGroupWeight (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | protected
m_printableBoundsWeight (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | protected
m_sheetDimensionalWeight (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | protected
m_sheetMediaGroupWeight (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | protected
matchingPolicy() const (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
MatchingPolicy enum name (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
mediaBoundsWeight() const (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
mediaGroupWeight() const (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
mediaMatchingThreshold() const (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
printableBoundsWeight() const (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setDimensionalWeight(unsigned int weight=DEFAULT_DIMENSIONAL_WEIGHT) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
setMediaBoundsWeight(unsigned int weight=DEFAULT_MEDIA_BOUNDS_WEIGHT) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
setMediaGroupWeight(unsigned int weight=DEFAULT_MEDIA_GROUP_WEIGHT) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
setMediaMatchingPolicy(MatchingPolicy policy) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
setMediaMatchingThreshold(unsigned int threshold=DEFAULT_THRESHOLD) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
setPrintableBoundsWeight(unsigned int weight=DEFAULT_PRINTABLE_BOUNDS_WEIGHT) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
setSheetDimensionalWeight(unsigned int weight=DEFAULT_SHEET_DIMENSIONAL_WEIGHT) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
setSheetMediaGroupWeight(unsigned int weight=DEFAULT_SHEET_MEDIA_GROUP_WEIGHT) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
sheetDimensionalWeight() const (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
sheetMediaGroupWeight() const (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator |
validate(AcPlPlotInfo &info) (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcPlPlotInfoValidator() (defined in AcPlPlotInfoValidator) | AcPlPlotInfoValidator | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotLogger Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPlPlotLogger Class Reference
AcPl Classes

Public Member Functions

virtual Acad::ErrorStatus | endJob (void)=0
virtual Acad::ErrorStatus | endSheet (void)=0
virtual bool | errorHasHappenedInJob (void) const =0
virtual bool | errorHasHappenedInSheet (void) const =0
virtual Acad::ErrorStatus | logARIError (const ACHAR *pErrorString)=0
virtual Acad::ErrorStatus | logError (const ACHAR *pErrorString)=0
virtual Acad::ErrorStatus | logInformation (const ACHAR *pMessageString)=0
virtual Acad::ErrorStatus | logMessage (const ACHAR *pMessageString)=0
virtual Acad::ErrorStatus | logSevereError (const ACHAR *pErrorString)=0
virtual Acad::ErrorStatus | logTerminalError (const ACHAR *pErrorString)=0
virtual Acad::ErrorStatus | logWarning (const ACHAR *pWarningString)=0
virtual Acad::ErrorStatus | startJob (void)=0
virtual Acad::ErrorStatus | startSheet (void)=0
virtual bool | warningHasHappenedInJob (void) const =0
virtual bool | warningHasHappenedInSheet (void) const =0
The documentation for this class was generated from the following file:
  • acplplotlogger.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotLogger Member List

This is the complete list of members for AcPlPlotLogger, including all inherited members.

AcPlPlotLogger() (defined in AcPlPlotLogger) | AcPlPlotLogger | inline
endJob(void)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
endSheet(void)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
errorHasHappenedInJob(void) const =0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
errorHasHappenedInSheet(void) const =0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
logARIError(const ACHAR *pErrorString)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
logError(const ACHAR *pErrorString)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
logInformation(const ACHAR *pMessageString)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
logMessage(const ACHAR *pMessageString)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
logSevereError(const ACHAR *pErrorString)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
logTerminalError(const ACHAR *pErrorString)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
logWarning(const ACHAR *pWarningString)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
startJob(void)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
startSheet(void)=0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
warningHasHappenedInJob(void) const =0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
warningHasHappenedInSheet(void) const =0 (defined in AcPlPlotLogger) | AcPlPlotLogger | pure virtual
~AcPlPlotLogger() (defined in AcPlPlotLogger) | AcPlPlotLogger | inlinevirtual


ZRX API Reference: AcPlPlotLoggingErrorHandler Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPlPlotLoggingErrorHandler Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotLoggingErrorHandler:

Public Member Functions

ACPL_DECLARE_MEMBERS (AcPlPlotLoggingErrorHandler)
ACPL_PORT | AcPlPlotLoggingErrorHandler (AcPlPlotLogger *)
virtual ACPL_PORT ErrorResult | ariError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT ErrorResult | error (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT void | info (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT void | infoMessage (const ACHAR *pMessage)
virtual ACPL_PORT void | logMessage (const ACHAR *pTitle, const ACHAR *pMsg)
virtual ACPL_PORT int | messageBox (const ACHAR *pText, const ACHAR *pCaption, unsigned int uType, int defaultReturn)
virtual ACPL_PORT void | severeError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT void | terminalError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
virtual ACPL_PORT ErrorResult | warning (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
- Public Member Functions inherited from AcPlPlotErrorHandler
ACPL_DECLARE_MEMBERS (AcPlPlotErrorHandler)
virtual ACPL_PORT const ACHAR * | ariTitle () const
virtual ACPL_PORT const ACHAR * | errorTitle () const
ACPL_PORT void | getCompanyString (ACHAR *&pCompanyString) const
ACPL_PORT void | getProductString (ACHAR *&pProductString) const
ACPL_PORT void | getProgramString (ACHAR *&pProgramString) const
virtual ACPL_PORT const ACHAR * | infoTitle () const
virtual ACPL_PORT bool | logMode () const
virtual ACPL_PORT bool | quietMode () const
virtual ACPL_PORT bool | setLogHandle (const ACHAR *pFilePathName)
virtual ACPL_PORT void | setLogMode (bool bLog)
virtual ACPL_PORT void | setQuietMode (bool bQuiet)
virtual ACPL_PORT const ACHAR * | severeTitle () const
virtual ACPL_PORT bool | takeResponsibility (Handler kind)
virtual ACPL_PORT const ACHAR * | terminalTitle () const
virtual ACPL_PORT const ACHAR * | warningTitle () const
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Public Types inherited from AcPlPlotErrorHandler
enum | ErrorResult { kAbort, kRetry, kIgnore }
enum Handler {
kInfo, kWarning, kError, kARI,
kSevere, kTerminal, kNone
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcPlPlotErrorHandler
ACPL_PORT ErrorResult | appARIError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT ErrorResult | appError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT void | appInfo (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT void | appInfoMessage (const ACHAR *pMessage)
ACPL_PORT void | appLogMessage (const ACHAR *pTitle, const ACHAR *pMsg)
ACPL_PORT int | appMessageBox (const ACHAR *pText, const ACHAR *pCaption, unsigned int uType, int defaultReturn)
ACPL_PORT bool | appSetLogHandle (const ACHAR *pFilePathName)
ACPL_PORT void | appSevereError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT void | appTerminalError (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
ACPL_PORT ErrorResult | appWarning (ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision)
The documentation for this class was generated from the following file:
  • acplplotloggingerrorhandler.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotLoggingErrorHandler Member List

This is the complete list of members for AcPlPlotLoggingErrorHandler, including all inherited members.

ACPL_DECLARE_MEMBERS(AcPlPlotLoggingErrorHandler) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler |
ACPL_DECLARE_MEMBERS(AcPlPlotErrorHandler) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
AcPlPlotErrorHandler() (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
AcPlPlotLoggingErrorHandler() (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler |
AcPlPlotLoggingErrorHandler(AcPlPlotLogger *) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler |
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
appARIError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appInfo(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appInfoMessage(const ACHAR *pMessage) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appLogMessage(const ACHAR *pTitle, const ACHAR *pMsg) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appMessageBox(const ACHAR *pText, const ACHAR *pCaption, unsigned int uType, int defaultReturn) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appSetLogHandle(const ACHAR *pFilePathName) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appSevereError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appTerminalError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
appWarning(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | protected
ariError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
ariTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
error(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
ErrorResult enum name (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
errorTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
getCompanyString(ACHAR *&pCompanyString) const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
getProductString(ACHAR *&pProductString) const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
getProgramString(ACHAR *&pProgramString) const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
Handler enum name (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
info(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
infoMessage(const ACHAR *pMessage) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
infoTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAbort enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kARI enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kError enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kIgnore enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kInfo enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kNone enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kRetry enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kSevere enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kTerminal enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
kWarning enum value (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
logMessage(const ACHAR *pTitle, const ACHAR *pMsg) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
logMode() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
messageBox(const ACHAR *pText, const ACHAR *pCaption, unsigned int uType, int defaultReturn) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
quietMode() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
setLogHandle(const ACHAR *pFilePathName) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
setLogMode(bool bLog) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
setQuietMode(bool bQuiet) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
severeError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
severeTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
takeResponsibility(Handler kind) (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
terminalError(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
terminalTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
warning(ULONG_PTR category, const unsigned int specific, const ACHAR *pLocation, const ACHAR *pContextData, const ACHAR *pRevision) (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
warningTitle() const (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcPlPlotErrorHandler() (defined in AcPlPlotErrorHandler) | AcPlPlotErrorHandler |
~AcPlPlotLoggingErrorHandler() (defined in AcPlPlotLoggingErrorHandler) | AcPlPlotLoggingErrorHandler | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotPageInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPlPlotPageInfo Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotPageInfo:

Public Member Functions

ACPL_PORT long | entityCount () const
ACPL_PORT long | gradientCount () const
ACPL_PORT long | oleObjectCount () const
ACPL_PORT long | rasterCount () const
ACPL_PORT long | shadedViewportType () const
- Public Member Functions inherited from AcPlObject
ACRX_DECLARE_MEMBERS (AcPlObject)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcPlObject
AcPlObject (AcPlSystemInternals *)
The documentation for this class was generated from the following file:
  • acplplotengine.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotPageInfo Member List

This is the complete list of members for AcPlPlotPageInfo, including all inherited members.

AcPlObject() (defined in AcPlObject) | AcPlObject | protected
AcPlObject(AcPlSystemInternals *) (defined in AcPlObject) | AcPlObject | protected
AcPlPlotPageInfo() (defined in AcPlPlotPageInfo) | AcPlPlotPageInfo |
ACRX_DECLARE_MEMBERS(AcPlObject) (defined in AcPlObject) | AcPlObject |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
entityCount() const (defined in AcPlPlotPageInfo) | AcPlPlotPageInfo |
gradientCount() const (defined in AcPlPlotPageInfo) | AcPlPlotPageInfo |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
oleObjectCount() const (defined in AcPlPlotPageInfo) | AcPlPlotPageInfo |
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rasterCount() const (defined in AcPlPlotPageInfo) | AcPlPlotPageInfo |
shadedViewportType() const (defined in AcPlPlotPageInfo) | AcPlPlotPageInfo |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlObject() (defined in AcPlObject) | AcPlObject | virtual
~AcPlPlotPageInfo() (defined in AcPlPlotPageInfo) | AcPlPlotPageInfo | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotProgress Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcPlPlotProgress Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotProgress:

Public Types

enum PlotCancelStatus { kPlotContinue, kPlotCanceledByCaller, kPlotCanceledByCancelAllButton, kPlotCancelStatusCount }
enum SheetCancelStatus {
kSheetContinue, kSheetCanceledByCancelButton, kSheetCanceledByCancelAllButton, kSheetCanceledByCaller,
kSheetCancelStatusCount
}

Public Member Functions

virtual void | getPlotProgressRange (int &nLower, int &nUpper) const =0
virtual void | getSheetProgressRange (int &nLower, int &nUpper) const =0
virtual bool | getStatusMsgString (ACHAR *&pMsg) const =0
virtual void | heartbeat (void)=0
virtual bool | isPlotCancelled () const =0
virtual bool | isSheetCancelled () const =0
virtual bool | isVisible () const =0
virtual PlotCancelStatus | plotCancelStatus () const =0
virtual int | plotProgressPos () const =0
virtual bool | setIsVisible (bool bVisible)=0
virtual void | setPlotCancelStatus (PlotCancelStatus Cancel)=0
virtual void | setPlotProgressPos (int nPos)=0
virtual void | setPlotProgressRange (int nLower, int nUpper)=0
virtual void | setSheetCancelStatus (SheetCancelStatus Cancel)=0
virtual void | setSheetProgressPos (int nPos)=0
virtual void | setSheetProgressRange (int nLower, int nUpper)=0
virtual bool | setStatusMsgString (const ACHAR *pMsg)=0
virtual SheetCancelStatus | sheetCancelStatus () const =0
virtual int | sheetProgressPos () const =0
The documentation for this class was generated from the following file:
  • acplplotprogress.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotProgress Member List

This is the complete list of members for AcPlPlotProgress, including all inherited members.

getPlotProgressRange(int &nLower, int &nUpper) const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
getSheetProgressRange(int &nLower, int &nUpper) const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
getStatusMsgString(ACHAR *&pMsg) const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
heartbeat(void)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
isPlotCancelled() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
isSheetCancelled() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
isVisible() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
kPlotCanceledByCaller enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kPlotCanceledByCancelAllButton enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kPlotCancelStatusCount enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kPlotContinue enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetCanceledByCaller enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetCanceledByCancelAllButton enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetCanceledByCancelButton enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetCancelStatusCount enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetContinue enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
PlotCancelStatus enum name (defined in AcPlPlotProgress) | AcPlPlotProgress |
plotCancelStatus() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
plotProgressPos() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setIsVisible(bool bVisible)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setPlotCancelStatus(PlotCancelStatus Cancel)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setPlotProgressPos(int nPos)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setPlotProgressRange(int nLower, int nUpper)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setSheetCancelStatus(SheetCancelStatus Cancel)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setSheetProgressPos(int nPos)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setSheetProgressRange(int nLower, int nUpper)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setStatusMsgString(const ACHAR *pMsg)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
SheetCancelStatus enum name (defined in AcPlPlotProgress) | AcPlPlotProgress |
sheetCancelStatus() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
sheetProgressPos() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual


ZRX API Reference: AcPlPlotProgressDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcPlPlotProgressDialog Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotProgressDialog:

Public Types

enum PlotMSGIndex {
kDialogTitle, kSheetName, kSheetNameToolTip, kStatus,
kSheetProgressCaption, kSheetSetProgressCaption, kMsgCancelling, kMsgCancellingCurrent,
kCancelSheetBtnMsg, kCancelJobBtnMsg, kMsgCount
}
- Public Types inherited from AcPlPlotProgress
enum PlotCancelStatus { kPlotContinue, kPlotCanceledByCaller, kPlotCanceledByCancelAllButton, kPlotCancelStatusCount }
enum SheetCancelStatus {
kSheetContinue, kSheetCanceledByCancelButton, kSheetCanceledByCancelAllButton, kSheetCanceledByCaller,
kSheetCancelStatusCount
}

Public Member Functions

virtual void | destroy ()=0
virtual bool | getPlotMsgString (PlotMSGIndex index, ACHAR *&pMsg) const =0
virtual bool | isSingleSheetPlot () const =0
virtual bool | onBeginPlot ()=0
virtual bool | onBeginSheet ()=0
virtual bool | onEndPlot ()=0
virtual bool | onEndSheet ()=0
virtual bool | setPlotMsgString (PlotMSGIndex index, const ACHAR *pMsg)=0
- Public Member Functions inherited from AcPlPlotProgress
virtual void | getPlotProgressRange (int &nLower, int &nUpper) const =0
virtual void | getSheetProgressRange (int &nLower, int &nUpper) const =0
virtual bool | getStatusMsgString (ACHAR *&pMsg) const =0
virtual void | heartbeat (void)=0
virtual bool | isPlotCancelled () const =0
virtual bool | isSheetCancelled () const =0
virtual bool | isVisible () const =0
virtual PlotCancelStatus | plotCancelStatus () const =0
virtual int | plotProgressPos () const =0
virtual bool | setIsVisible (bool bVisible)=0
virtual void | setPlotCancelStatus (PlotCancelStatus Cancel)=0
virtual void | setPlotProgressPos (int nPos)=0
virtual void | setPlotProgressRange (int nLower, int nUpper)=0
virtual void | setSheetCancelStatus (SheetCancelStatus Cancel)=0
virtual void | setSheetProgressPos (int nPos)=0
virtual void | setSheetProgressRange (int nLower, int nUpper)=0
virtual bool | setStatusMsgString (const ACHAR *pMsg)=0
virtual SheetCancelStatus | sheetCancelStatus () const =0
virtual int | sheetProgressPos () const =0
The documentation for this class was generated from the following file:
  • acplplotprogress.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotProgressDialog Member List

This is the complete list of members for AcPlPlotProgressDialog, including all inherited members.

destroy()=0 (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog | pure virtual
getPlotMsgString(PlotMSGIndex index, ACHAR *&pMsg) const =0 (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog | pure virtual
getPlotProgressRange(int &nLower, int &nUpper) const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
getSheetProgressRange(int &nLower, int &nUpper) const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
getStatusMsgString(ACHAR *&pMsg) const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
heartbeat(void)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
isPlotCancelled() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
isSheetCancelled() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
isSingleSheetPlot() const =0 (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog | pure virtual
isVisible() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
kCancelJobBtnMsg enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kCancelSheetBtnMsg enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kDialogTitle enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kMsgCancelling enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kMsgCancellingCurrent enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kMsgCount enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kPlotCanceledByCaller enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kPlotCanceledByCancelAllButton enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kPlotCancelStatusCount enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kPlotContinue enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetCanceledByCaller enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetCanceledByCancelAllButton enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetCanceledByCancelButton enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetCancelStatusCount enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetContinue enum value (defined in AcPlPlotProgress) | AcPlPlotProgress |
kSheetName enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kSheetNameToolTip enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kSheetProgressCaption enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kSheetSetProgressCaption enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
kStatus enum value (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
onBeginPlot()=0 (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog | pure virtual
onBeginSheet()=0 (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog | pure virtual
onEndPlot()=0 (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog | pure virtual
onEndSheet()=0 (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog | pure virtual
plotCancelStatus() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
PlotCancelStatus enum name (defined in AcPlPlotProgress) | AcPlPlotProgress |
PlotMSGIndex enum name (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog |
plotProgressPos() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setIsVisible(bool bVisible)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setPlotCancelStatus(PlotCancelStatus Cancel)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setPlotMsgString(PlotMSGIndex index, const ACHAR *pMsg)=0 (defined in AcPlPlotProgressDialog) | AcPlPlotProgressDialog | pure virtual
setPlotProgressPos(int nPos)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setPlotProgressRange(int nLower, int nUpper)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setSheetCancelStatus(SheetCancelStatus Cancel)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setSheetProgressPos(int nPos)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setSheetProgressRange(int nLower, int nUpper)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
setStatusMsgString(const ACHAR *pMsg)=0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
SheetCancelStatus enum name (defined in AcPlPlotProgress) | AcPlPlotProgress |
sheetCancelStatus() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual
sheetProgressPos() const =0 (defined in AcPlPlotProgress) | AcPlPlotProgress | pure virtual


ZRX API Reference: AcPlPlotReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcPlPlotReactor Class Reference
AcPl Classes
+ Inheritance diagram for AcPlPlotReactor:

Public Types

enum PlotType { kPlot, kPreview, kBackgroundPackaging, kBackgroundPlot }

Public Member Functions

virtual ACPL_PORT void | beginDocument (AcPlPlotInfo &plotInfo, const ACHAR *pDocname, long nCopies=1, bool bPlotToFile=false, const ACHAR *pFilename=NULL)
virtual ACPL_PORT void | beginPage (AcPlPlotPageInfo &pageInfo, AcPlPlotInfo &plotInfo, bool bLastPage)
virtual ACPL_PORT void | beginPlot (AcPlPlotProgress *pPlotProgress, PlotType type)
virtual ACPL_PORT void | endDocument (AcPlPlotProgress::PlotCancelStatus status)
virtual ACPL_PORT void | endPage (AcPlPlotProgress::SheetCancelStatus status)
virtual ACPL_PORT void | endPlot (AcPlPlotProgress::PlotCancelStatus status)
virtual ACPL_PORT void | pageCancelled ()
virtual ACPL_PORT void | plotCancelled ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acplplotreactor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotReactor Member List

This is the complete list of members for AcPlPlotReactor, including all inherited members.

AcPlPlotReactor() (defined in AcPlPlotReactor) | AcPlPlotReactor | protected
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
beginDocument(AcPlPlotInfo &plotInfo, const ACHAR *pDocname, long nCopies=1, bool bPlotToFile=false, const ACHAR *pFilename=NULL) (defined in AcPlPlotReactor) | AcPlPlotReactor | virtual
beginPage(AcPlPlotPageInfo &pageInfo, AcPlPlotInfo &plotInfo, bool bLastPage) (defined in AcPlPlotReactor) | AcPlPlotReactor | virtual
beginPlot(AcPlPlotProgress *pPlotProgress, PlotType type) (defined in AcPlPlotReactor) | AcPlPlotReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
endDocument(AcPlPlotProgress::PlotCancelStatus status) (defined in AcPlPlotReactor) | AcPlPlotReactor | virtual
endPage(AcPlPlotProgress::SheetCancelStatus status) (defined in AcPlPlotReactor) | AcPlPlotReactor | virtual
endPlot(AcPlPlotProgress::PlotCancelStatus status) (defined in AcPlPlotReactor) | AcPlPlotReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kBackgroundPackaging enum value (defined in AcPlPlotReactor) | AcPlPlotReactor |
kBackgroundPlot enum value (defined in AcPlPlotReactor) | AcPlPlotReactor |
kPlot enum value (defined in AcPlPlotReactor) | AcPlPlotReactor |
kPreview enum value (defined in AcPlPlotReactor) | AcPlPlotReactor |
pageCancelled() (defined in AcPlPlotReactor) | AcPlPlotReactor | virtual
plotCancelled() (defined in AcPlPlotReactor) | AcPlPlotReactor | virtual
PlotType enum name (defined in AcPlPlotReactor) | AcPlPlotReactor |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPlPlotReactor() (defined in AcPlPlotReactor) | AcPlPlotReactor | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPlPlotReactorMgr Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPlPlotReactorMgr Class Reference
AcPl Classes

Public Member Functions

ACPL_PORT void | addReactor (AcPlPlotReactor *pReactor)
ACPL_PORT void | removeReactor (AcPlPlotReactor *pReactor)
The documentation for this class was generated from the following file:
  • acplplotreactormgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPlPlotReactorMgr Member List

This is the complete list of members for AcPlPlotReactorMgr, including all inherited members.

addReactor(AcPlPlotReactor *pReactor) (defined in AcPlPlotReactorMgr) | AcPlPlotReactorMgr
removeReactor(AcPlPlotReactor *pReactor) (defined in AcPlPlotReactorMgr) | AcPlPlotReactorMgr


ZRX API Reference: AcRx Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Macros | Functions
AcRx Classes

Classes

class | AcRxArxApp
class | AcRxDbxApp
class | AcRxDynPropManager

Macros

#define | IMPLEMENT_ARX_ENTRYPOINT(classname) IMPLEMENT_ARX_ENTRYPOINT_STD(classname)
#define | IMPLEMENT_ARX_ENTRYPOINT_CLR(classname) IMPLEMENT_ARX_ENTRYPOINT_STD(classname)
#define | IMPLEMENT_ARX_ENTRYPOINT_STD(classname)

Functions

AcRxDbxApp * acrxGetApp ()

Detailed Description

Macro Definition Documentation

#define IMPLEMENT_ARX_ENTRYPOINT_STD ( classname )
Value:
HINSTANCE _hdllInstance =NULL ; \
class classname entryPointObject ; \
AcRxDbxApp *acrxGetApp () { return (&entryPointObject) ; } \
extern "C" AcRx::AppRetCode __declspec(dllexport) acrxEntryPoint (AcRx::AppMsgCode msg, void *pkt) { \
return (entryPointObject.acrxEntryPoint (msg, pkt)) ; \
}


ZRX API Reference: AcRxArxApp Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxArxApp Class Reference
AcRx Classes
+ Inheritance diagram for AcRxArxApp:

Public Member Functions

virtual AcRx::AppRetCode | On_kInitAppMsg (void *pkt)
virtual AcRx::AppRetCode | On_kInvkSubrMsg (void *pkt)
virtual AcRx::AppRetCode | On_kLoadDwgMsg (void *pkt)
virtual AcRx::AppRetCode | On_kUnloadAppMsg (void *pkt)
virtual AcRx::AppRetCode | On_kUnloadDwgMsg (void *pkt)
- Public Member Functions inherited from AcRxDbxApp
AcRx::AppRetCode | acrxEntryPoint (AcRx::AppMsgCode msg, void *pkt)
HINSTANCE & | GetModuleInstance ()
virtual AcRx::AppRetCode | On_kCfgMsg (void *pkt)
virtual AcRx::AppRetCode | On_kDependencyMsg (void *pkt)
virtual AcRx::AppRetCode | On_kEndDialogMsg (void *pkt)
virtual AcRx::AppRetCode | On_kEndMsg (void *pkt)
virtual AcRx::AppRetCode | On_kInitDialogMsg (void *pkt)
virtual AcRx::AppRetCode | On_kNoDependencyMsg (void *pkt)
virtual AcRx::AppRetCode | On_kNullMsg (void *pkt)
virtual AcRx::AppRetCode | On_kOleUnloadAppMsg (void *pkt)
virtual AcRx::AppRetCode | On_kPreQuitMsg (void *pkt)
virtual AcRx::AppRetCode | On_kQuitMsg (void *pkt)
virtual AcRx::AppRetCode | On_kSaveMsg (void *pkt)
virtual void | RegisterServerComponents ()=0

Additional Inherited Members

- Protected Attributes inherited from AcRxDbxApp
bool | m_bMDIAware
bool | m_bUnlocked
HINSTANCE | m_hdllInstance
The documentation for this class was generated from the following file:
  • arxEntryPoint.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxArxApp Member List

This is the complete list of members for AcRxArxApp, including all inherited members.

AcRxArxApp() (defined in AcRxArxApp) | AcRxArxApp | inline
AcRxDbxApp() (defined in AcRxDbxApp) | AcRxDbxApp | inline
acrxEntryPoint(AcRx::AppMsgCode msg, void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inline
GetModuleInstance() (defined in AcRxDbxApp) | AcRxDbxApp | inline
m_bMDIAware (defined in AcRxDbxApp) | AcRxDbxApp | protected
m_bUnlocked (defined in AcRxDbxApp) | AcRxDbxApp | protected
m_hdllInstance (defined in AcRxDbxApp) | AcRxDbxApp | protected
On_kCfgMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kDependencyMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kEndDialogMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kEndMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kInitAppMsg(void *pkt) (defined in AcRxArxApp) | AcRxArxApp | inlinevirtual
On_kInitDialogMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kInvkSubrMsg(void *pkt) (defined in AcRxArxApp) | AcRxArxApp | inlinevirtual
On_kLoadDwgMsg(void *pkt) (defined in AcRxArxApp) | AcRxArxApp | inlinevirtual
On_kNoDependencyMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kNullMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kOleUnloadAppMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kPreQuitMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kQuitMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kSaveMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kUnloadAppMsg(void *pkt) (defined in AcRxArxApp) | AcRxArxApp | inlinevirtual
On_kUnloadDwgMsg(void *pkt) (defined in AcRxArxApp) | AcRxArxApp | inlinevirtual
RegisterServerComponents()=0 (defined in AcRxDbxApp) | AcRxDbxApp | pure virtual


ZRX API Reference: AcRxDbxApp Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
AcRxDbxApp Class Reference
AcRx Classes
+ Inheritance diagram for AcRxDbxApp:

Public Member Functions

AcRx::AppRetCode | acrxEntryPoint (AcRx::AppMsgCode msg, void *pkt)
HINSTANCE & | GetModuleInstance ()
virtual AcRx::AppRetCode | On_kCfgMsg (void *pkt)
virtual AcRx::AppRetCode | On_kDependencyMsg (void *pkt)
virtual AcRx::AppRetCode | On_kEndDialogMsg (void *pkt)
virtual AcRx::AppRetCode | On_kEndMsg (void *pkt)
virtual AcRx::AppRetCode | On_kInitAppMsg (void *pkt)
virtual AcRx::AppRetCode | On_kInitDialogMsg (void *pkt)
virtual AcRx::AppRetCode | On_kInvkSubrMsg (void *pkt)
virtual AcRx::AppRetCode | On_kLoadDwgMsg (void *pkt)
virtual AcRx::AppRetCode | On_kNoDependencyMsg (void *pkt)
virtual AcRx::AppRetCode | On_kNullMsg (void *pkt)
virtual AcRx::AppRetCode | On_kOleUnloadAppMsg (void *pkt)
virtual AcRx::AppRetCode | On_kPreQuitMsg (void *pkt)
virtual AcRx::AppRetCode | On_kQuitMsg (void *pkt)
virtual AcRx::AppRetCode | On_kSaveMsg (void *pkt)
virtual AcRx::AppRetCode | On_kUnloadAppMsg (void *pkt)
virtual AcRx::AppRetCode | On_kUnloadDwgMsg (void *pkt)
virtual void | RegisterServerComponents ()=0

Protected Attributes

bool | m_bMDIAware
bool | m_bUnlocked
HINSTANCE | m_hdllInstance
The documentation for this class was generated from the following file:
  • dbxEntryPoint.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxDbxApp Member List

This is the complete list of members for AcRxDbxApp, including all inherited members.

AcRxDbxApp() (defined in AcRxDbxApp) | AcRxDbxApp | inline
acrxEntryPoint(AcRx::AppMsgCode msg, void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inline
GetModuleInstance() (defined in AcRxDbxApp) | AcRxDbxApp | inline
m_bMDIAware (defined in AcRxDbxApp) | AcRxDbxApp | protected
m_bUnlocked (defined in AcRxDbxApp) | AcRxDbxApp | protected
m_hdllInstance (defined in AcRxDbxApp) | AcRxDbxApp | protected
On_kCfgMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kDependencyMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kEndDialogMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kEndMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kInitAppMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kInitDialogMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kInvkSubrMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kLoadDwgMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kNoDependencyMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kNullMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kOleUnloadAppMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kPreQuitMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kQuitMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kSaveMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kUnloadAppMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
On_kUnloadDwgMsg(void *pkt) (defined in AcRxDbxApp) | AcRxDbxApp | inlinevirtual
RegisterServerComponents()=0 (defined in AcRxDbxApp) | AcRxDbxApp | pure virtual


ZRX API Reference: AcRxDynPropManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
AcRxDynPropManager Class Reference
AcRx Classes
The documentation for this class was generated from the following file:
  • dynpropmgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxDynPropManager Member List

This is the complete list of members for AcRxDynPropManager, including all inherited members.

AcRxDynPropManager() (defined in AcRxDynPropManager) | AcRxDynPropManager | inline
~AcRxDynPropManager() (defined in AcRxDynPropManager) | AcRxDynPropManager | inlinevirtual


ZRX API Reference: AcTransaction Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Functions
AcTransaction Classes

Classes

class AcTransactionManager

Functions

AcTransactionManager * acTransactionManagerPtr ()

Detailed Description


ZRX API Reference: AcTransactionManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcTransactionManager Class Reference
AcTransaction Classes
+ Inheritance diagram for AcTransactionManager:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcTransactionManager)
virtual Acad::ErrorStatus | enableGraphicsFlush (bool doEnable)=0
virtual void | flushGraphics ()=0
- Public Member Functions inherited from AcDbTransactionManager
virtual Acad::ErrorStatus | abortTransaction ()=0
ACRX_DECLARE_MEMBERS (AcDbTransactionManager)
virtual Acad::ErrorStatus | addNewlyCreatedDBRObject (AcDbObject *obj, bool add=true)=0
virtual void | addReactor (AcTransactionReactor *reactor)=0
virtual Acad::ErrorStatus | endTransaction ()=0
virtual Acad::ErrorStatus | getAllObjects (AcDbVoidPtrArray &objs)=0
virtual Acad::ErrorStatus | getObject (AcDbObject *&obj, AcDbObjectId id, AcDb::OpenMode mode, bool openErasedObj=false)=0
virtual Acad::ErrorStatus | markObjectPageable (AcDbObject *pObject)=0
virtual int | numActiveTransactions ()=0
virtual int | numOpenedObjects ()=0
virtual Acad::ErrorStatus | queueForGraphicsFlush ()=0
virtual void | removeReactor (AcTransactionReactor *reactor)=0
virtual AcTransaction * | startTransaction ()=0
virtual AcTransaction * | topTransaction ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • actrans.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTransactionManager Member List

This is the complete list of members for AcTransactionManager, including all inherited members.

abortTransaction()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
ACRX_DECLARE_MEMBERS(AcTransactionManager) (defined in AcTransactionManager) | AcTransactionManager |
ACRX_DECLARE_MEMBERS(AcDbTransactionManager) (defined in AcDbTransactionManager) | AcDbTransactionManager |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addNewlyCreatedDBRObject(AcDbObject *obj, bool add=true)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
addReactor(AcTransactionReactor *reactor)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
enableGraphicsFlush(bool doEnable)=0 (defined in AcTransactionManager) | AcTransactionManager | pure virtual
endTransaction()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
flushGraphics()=0 (defined in AcTransactionManager) | AcTransactionManager | pure virtual
getAllObjects(AcDbVoidPtrArray &objs)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
getObject(AcDbObject *&obj, AcDbObjectId id, AcDb::OpenMode mode, bool openErasedObj=false)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
markObjectPageable(AcDbObject *pObject)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
numActiveTransactions()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
queueForGraphicsFlush()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
removeReactor(AcTransactionReactor *reactor)=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
startTransaction()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
topTransaction()=0 (defined in AcDbTransactionManager) | AcDbTransactionManager | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcTrayItem Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Typedefs
AcTrayItem Classes

Classes

class | AcTrayItem
class | AcTrayItemAnimationControl
For internal use only. More...
class | AcTrayItemBubbleWindowControl

Typedefs

typedef void * | AcTrayItemBubbleWindowCallbackData
typedef void(* | AcTrayItemBubbleWindowCallbackFunc )(void *, int)

Detailed Description


ZRX API Reference: AcTrayItem Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcTrayItem Class Reference
AcTrayItem Classes
+ Inheritance diagram for AcTrayItem:

Public Member Functions

virtual BOOL | CloseAllBubbleWindows ()
AcTrayItemAnimationControl * | GetAnimationControl () const
virtual
AcTrayItemBubbleWindowControl * 		GetBubbleWindowControl () const
virtual HICON | GetIcon () const
BOOL | PlayAnimation (AcTrayItemAnimationControl *pAnimationControl)
virtual BOOL | SetIcon (HICON hIcon)
virtual BOOL | ShowBubbleWindow (AcTrayItemBubbleWindowControl *pBubbleWindowControl)
void | StopAnimation ()
- Public Member Functions inherited from AcStatusBarItem
virtual BOOL | ClientToScreen (LPPOINT lpPoint)
virtual BOOL | ClientToScreen (LPRECT lpRect)
virtual BOOL | ContentChanged () const
virtual UINT | DisplayContextMenu (CMenu &menu, CPoint point)
virtual void | Enable (BOOL bValue)
virtual void * | GetInternalData (BOOL bForDocSwitch=TRUE) const
virtual BOOL | GetToolTipText (CString &strText) const
virtual BOOL | IsEnabled ()
virtual BOOL | IsVisible ()
virtual void | OnDelete ()
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
virtual void | OnLButtonDown (UINT nFlags, CPoint point)
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
virtual BOOL | QueryToolTipText (CString &strText) const
virtual BOOL | ScreenToClient (LPPOINT lpPoint)
virtual BOOL | ScreenToClient (LPRECT lpRect)
virtual void | SetContentChanged (BOOL bChanged)
virtual void | SetInternalData (void *pData, BOOL bForDocSwitch=FALSE)
virtual BOOL | SetToolTipText (const CString &strText)
virtual void | SetVisibilityChanged (BOOL bChanged)
virtual void | SetVisible (BOOL bIsVisible)
virtual BOOL | ShowTraySettingsDialog ()
virtual BOOL | VisibilityChanged () const

Member Function Documentation

AcTrayItemAnimationControl* AcTrayItem::GetAnimationControl ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acStatusBar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTrayItem Member List

This is the complete list of members for AcTrayItem, including all inherited members.

AcStatusBarItem() (defined in AcStatusBarItem) | AcStatusBarItem |
AcTrayItem() (defined in AcTrayItem) | AcTrayItem |
ClientToScreen(LPPOINT lpPoint) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ClientToScreen(LPRECT lpRect) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
CloseAllBubbleWindows() (defined in AcTrayItem) | AcTrayItem | virtual
ContentChanged() const (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
DisplayContextMenu(CMenu &menu, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
Enable(BOOL bValue) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
GetAnimationControl() const | AcTrayItem |
GetBubbleWindowControl() const (defined in AcTrayItem) | AcTrayItem | virtual
GetIcon() const (defined in AcTrayItem) | AcTrayItem | virtual
GetInternalData(BOOL bForDocSwitch=TRUE) const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
GetToolTipText(CString &strText) const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
IsEnabled() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
IsVisible() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnDelete() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnLButtonDown(UINT nFlags, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
PlayAnimation(AcTrayItemAnimationControl *pAnimationControl) (defined in AcTrayItem) | AcTrayItem |
QueryToolTipText(CString &strText) const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ScreenToClient(LPPOINT lpPoint) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ScreenToClient(LPRECT lpRect) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetContentChanged(BOOL bChanged) (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
SetIcon(HICON hIcon) (defined in AcTrayItem) | AcTrayItem | virtual
SetInternalData(void *pData, BOOL bForDocSwitch=FALSE) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetToolTipText(const CString &strText) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetVisibilityChanged(BOOL bChanged) (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
SetVisible(BOOL bIsVisible) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ShowBubbleWindow(AcTrayItemBubbleWindowControl *pBubbleWindowControl) (defined in AcTrayItem) | AcTrayItem | virtual
ShowTraySettingsDialog() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
StopAnimation() (defined in AcTrayItem) | AcTrayItem |
VisibilityChanged() const (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
~AcStatusBarItem() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
~AcTrayItem() (defined in AcTrayItem) | AcTrayItem | virtual


ZRX API Reference: AcTrayItemAnimationControl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcTrayItemAnimationControl Class Reference
AcTrayItem Classes

For internal use only. More...

#include <acStatusBar.h>

Public Types

enum { ANIMATION_ERROR_NO_CREATE, ANIMATION_ERROR_NO_ICONS, ANIMATION_KILLED, ANIMATION_FINISHED }

Public Member Functions

AcTrayItemAnimationControl ()
For internal use only.
AcTrayItemAnimationControl (const CString &strGIFFile)
For internal use only.
AcTrayItemAnimationControl (HBITMAP hBitmap)
For internal use only.
HBITMAP | GetBitmap () const
AcTrayItemAnimationCallbackData | GetCallbackData () const
AcTrayItemAnimationCallbackFunc | GetCallbackFunc () const
int | GetDuration () const
const CString & | GetGIFFile () const
void | GetGIFResourceData (HGLOBAL &hGlobal, DWORD &dwSize) const
HICON | GetNewIcon () const
void | SetBitmap (HBITMAP hBitmap)
void | SetCallback (AcTrayItemAnimationCallbackFunc pCallbackFunc, AcTrayItemAnimationCallbackData pCallbackData)
void | SetDuration (int nDurationInSeconds)
void | SetGIFFile (const CString &strGIFFile)
void | SetGIFResourceData (HGLOBAL hGlobal, DWORD dwSize)
void | SetNewIcon (HICON hNewIcon)
~AcTrayItemAnimationControl ()
For internal use only.

Detailed Description

For internal use only.

Constructor & Destructor Documentation

AcTrayItemAnimationControl::AcTrayItemAnimationControl ( )

For internal use only.

AcTrayItemAnimationControl::AcTrayItemAnimationControl ( const CString & strGIFFile )

For internal use only.

AcTrayItemAnimationControl::AcTrayItemAnimationControl ( HBITMAP hBitmap )

For internal use only.

AcTrayItemAnimationControl::~AcTrayItemAnimationControl ( )

For internal use only.

The documentation for this class was generated from the following file:
  • acStatusBar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTrayItemAnimationControl Member List

This is the complete list of members for AcTrayItemAnimationControl, including all inherited members.

AcTrayItemAnimationControl() AcTrayItemAnimationControl
AcTrayItemAnimationControl(const CString &strGIFFile) | AcTrayItemAnimationControl
AcTrayItemAnimationControl(HBITMAP hBitmap) | AcTrayItemAnimationControl
ANIMATION_ERROR_NO_CREATE enum value (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl
ANIMATION_ERROR_NO_ICONS enum value (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl
ANIMATION_FINISHED enum value (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl
ANIMATION_KILLED enum value (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl
GetBitmap() const (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
GetCallbackData() const (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
GetCallbackFunc() const (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
GetDuration() const (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
GetGIFFile() const (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
GetGIFResourceData(HGLOBAL &hGlobal, DWORD &dwSize) const (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
GetNewIcon() const (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
SetBitmap(HBITMAP hBitmap) (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
SetCallback(AcTrayItemAnimationCallbackFunc pCallbackFunc, AcTrayItemAnimationCallbackData pCallbackData) (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
SetDuration(int nDurationInSeconds) (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
SetGIFFile(const CString &strGIFFile) (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
SetGIFResourceData(HGLOBAL hGlobal, DWORD dwSize) (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline
SetNewIcon(HICON hNewIcon) (defined in AcTrayItemAnimationControl) | AcTrayItemAnimationControl | inline


ZRX API Reference: AcTrayItemBubbleWindowControl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcTrayItemBubbleWindowControl Class Reference
AcTrayItem Classes

Public Types

enum { BUBBLE_WINDOW_ICON_NONE, BUBBLE_WINDOW_ICON_INFORMATION, BUBBLE_WINDOW_ICON_CRITICAL, BUBBLE_WINDOW_ICON_WARNING }
enum {
BUBBLE_WINDOW_ERROR_NO_CREATE, BUBBLE_WINDOW_ERROR_NO_ICONS, BUBBLE_WINDOW_ERROR_NO_NOTIFICATIONS, BUBBLE_WINDOW_CLOSE,
BUBBLE_WINDOW_TIME_OUT, BUBBLE_WINDOW_HYPERLINK_CLICK, BUBBLE_WINDOW_DOCUMENT_DEACTIVATED
}

Public Member Functions

AcTrayItemBubbleWindowControl (const CString &strTitle, const CString &strText, const CString &strHyperText=_T(""), const CString &strHyperLink=_T(""), const CString &strText2=_T(""))
AcTrayItemBubbleWindowCallbackData | GetCallbackData () const
AcTrayItemBubbleWindowCallbackFunc | GetCallbackFunc () const
const CString & | GetHyperLink () const
const CString & | GetHyperText () const
int | GetIconType () const
const CString & | GetText () const
const CString & | GetText2 () const
const CString & | GetTitle () const
void | SetCallback (AcTrayItemBubbleWindowCallbackFunc pCallbackFunc, AcTrayItemBubbleWindowCallbackData pCallbackData=0)
void | SetHyperLink (const CString &strHyperLink)
void | SetHyperText (const CString &strHyperText)
void | SetIconType (int nIconType)
void | SetText (const CString &strText)
void | SetText2 (const CString &strText2)
void | SetTitle (const CString &strTitle)
The documentation for this class was generated from the following file:
  • acStatusBar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTrayItemBubbleWindowControl Member List

This is the complete list of members for AcTrayItemBubbleWindowControl, including all inherited members.

AcTrayItemBubbleWindowControl() (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
AcTrayItemBubbleWindowControl(const CString &strTitle, const CString &strText, const CString &strHyperText=_T(""), const CString &strHyperLink=_T(""), const CString &strText2=_T("")) (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_CLOSE enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_DOCUMENT_DEACTIVATED enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_ERROR_NO_CREATE enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_ERROR_NO_ICONS enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_ERROR_NO_NOTIFICATIONS enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_HYPERLINK_CLICK enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_ICON_CRITICAL enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_ICON_INFORMATION enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_ICON_NONE enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_ICON_WARNING enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
BUBBLE_WINDOW_TIME_OUT enum value (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |
GetCallbackData() const (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
GetCallbackFunc() const (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
GetHyperLink() const (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
GetHyperText() const (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
GetIconType() const (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
GetText() const (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
GetText2() const (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
GetTitle() const (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
SetCallback(AcTrayItemBubbleWindowCallbackFunc pCallbackFunc, AcTrayItemBubbleWindowCallbackData pCallbackData=0) (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
SetHyperLink(const CString &strHyperLink) (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
SetHyperText(const CString &strHyperText) (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
SetIconType(int nIconType) (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
SetText(const CString &strText) (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
SetText2(const CString &strText2) (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
SetTitle(const CString &strTitle) (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl | inline
~AcTrayItemBubbleWindowControl() (defined in AcTrayItemBubbleWindowControl) | AcTrayItemBubbleWindowControl |


ZRX API Reference: AcDMM Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Typedefs | Functions
AcDMM Classes

Classes

class | AcDMMEntityReactorInfo
class | AcDMMEPlotProperties
class | AcDMMEPlotProperty
class | AcDMMNode
class | AcDMMReactor
class | AcDMMResourceInfo
class | AcDMMSheetReactorInfo
class | AcDMMWideString
class | AcDMMXMLAttribute

Typedefs

typedef std::vector
< AcDMMEPlotProperty > 		AcDMMEPlotPropertyVec
typedef std::vector
< AcDMMResourceInfo > 		AcDMMResourceVec
typedef std::vector
< AcDMMWideString > 		AcDMMStringVec
typedef std::vector
< AcDMMXMLAttribute > 		AcDMMXMLAttributeVec
typedef void(__cdecl * | ACGLOBADDDMMREACTOR )(AcDMMReactor *pReactor)
typedef void(__cdecl * | ACGLOBREMOVEDMMREACTOR )(AcDMMReactor *pReactor)

Functions

AcDMMWideString::AcDMMWideString (const AcDMMWideString &ws)
AcDMMWideString::AcDMMWideString (PCWIDESTR pwsz)
void | AcGlobalAddDMMReactor (AcDMMReactor *pReactor)
void | AcGlobalRemoveDMMReactor (AcDMMReactor *pReactor)
void | AcDMMWideString::Empty ()
unsigned | AcDMMWideString::GetLength () const
bool | AcDMMWideString::IsEmpty () const
virtual void | AcDMMReactor::OnBeginEntity (AcDMMEntityReactorInfo *pInfo)
virtual void | AcDMMReactor::OnBeginSheet (AcDMMSheetReactorInfo *pInfo)
virtual void | AcDMMReactor::OnEndEntity (AcDMMEntityReactorInfo *pInfo)
virtual void | AcDMMReactor::OnEndSheet (AcDMMSheetReactorInfo *pInfo)
AcDMMWideString::operator PCWIDESTR () const
AcDMMWideString | operator+ (const AcDMMWideString &wsLeft, wchar_t wch)
AcDMMWideString | operator+ (wchar_t wch, const AcDMMWideString &wsRight)
AcDMMWideString | operator+ (const AcDMMWideString &wsLeft, const AcDMMWideString &wsRight)
const AcDMMWideString & | AcDMMWideString::operator+= (AcDMMWideString ws)
const AcDMMWideString & | AcDMMWideString::operator= (const AcDMMWideString &ws)
const AcDMMWideString & | AcDMMWideString::operator= (PCWIDESTR pwsz)

Detailed Description

Function Documentation

void AcGlobalAddDMMReactor ( AcDMMReactor * pReactor )
Warning
Not implemented!
void AcGlobalRemoveDMMReactor ( AcDMMReactor * pReactor )
Warning
Not implemented!


ZRX API Reference: AcDMMEntityReactorInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDMMEntityReactorInfo Class Reference
AcDMM Classes

Public Member Functions

virtual bool | add3DDwfProperty (const wchar_t *category, const wchar_t *name, const wchar_t *value)=0
virtual bool | AddNodeToMap (AcDbObjectId Id, AcDbObjectIdArray objIds, int nodeId)=0
virtual bool | AddProperties (const AcDMMEPlotProperties *props)=0
virtual bool | AddPropertiesIds (AcDMMStringVec *IdVec, AcDMMNode &node)=0
virtual void | cancelTheJob ()=0
virtual AcDbObjectId | effectiveBlockLayerId () const =0
virtual AcDbEntity * | entity () const =0
virtual void | flush ()=0
virtual bool | GetCurrentEntityNode (AcDMMNode &node, AcDbObjectIdArray objIds) const =0
virtual const AcDbObjectIdArray & | getEntityBlockRefPath ()=0
virtual bool | GetEntityNode (AcDbObjectId id, AcDbObjectIdArray objIds, int &nodeId) const =0
virtual const AcArray< long > & | getGraphicIDs ()=0
virtual int | GetNextAvailableNodeId () const =0
virtual const AcDMMNode * | GetNode (int nodeId) const =0
virtual AcPlPlotLogger * | GetPlotLogger ()=0
virtual bool | isCancelled () const =0
virtual bool | SetCurrentNode (int nodeId, AcDbObjectIdArray objIds)=0
virtual bool | SetNodeName (int nodeNumber, const wchar_t *name)=0
virtual const wchar_t * | UniqueEntityId ()=0
The documentation for this class was generated from the following file:
  • acdmmapi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDMMEntityReactorInfo Member List

This is the complete list of members for AcDMMEntityReactorInfo, including all inherited members.

AcDMMEntityReactorInfo() (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | inlineprotected
add3DDwfProperty(const wchar_t *category, const wchar_t *name, const wchar_t *value)=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
AddNodeToMap(AcDbObjectId Id, AcDbObjectIdArray objIds, int nodeId)=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
AddProperties(const AcDMMEPlotProperties *props)=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
AddPropertiesIds(AcDMMStringVec *IdVec, AcDMMNode &node)=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
cancelTheJob()=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
effectiveBlockLayerId() const =0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
entity() const =0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
flush()=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
GetCurrentEntityNode(AcDMMNode &node, AcDbObjectIdArray objIds) const =0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
getEntityBlockRefPath()=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
GetEntityNode(AcDbObjectId id, AcDbObjectIdArray objIds, int &nodeId) const =0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
getGraphicIDs()=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
GetNextAvailableNodeId() const =0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
GetNode(int nodeId) const =0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
GetPlotLogger()=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
isCancelled() const =0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
SetCurrentNode(int nodeId, AcDbObjectIdArray objIds)=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
SetNodeName(int nodeNumber, const wchar_t *name)=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
UniqueEntityId()=0 (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | pure virtual
~AcDMMEntityReactorInfo() (defined in AcDMMEntityReactorInfo) | AcDMMEntityReactorInfo | inline


ZRX API Reference: AcDMMEPlotProperties Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDMMEPlotProperties Class Reference
AcDMM Classes

Public Member Functions

AcDMMEPlotProperties (const AcDMMEPlotProperties &src)
void | AddProperty (const AcDMMEPlotProperty *property)
void | AddProperty (wchar_t *name, wchar_t *value)
const wchar_t * | GetId () const
const AcDMMEPlotPropertyVec & | GetProperties () const
const AcDMMEPlotProperty * | GetProperty (unsigned long index) const
const AcDMMStringVec * | GetRefs () const
AcDMMEPlotProperties & | operator= (const AcDMMEPlotProperties &src)
void | SetId (const wchar_t *id)
void | SetRefs (const AcDMMStringVec &refs)
The documentation for this class was generated from the following file:
  • acdmmeplotproperties.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDMMEPlotProperties Member List

This is the complete list of members for AcDMMEPlotProperties, including all inherited members.

AcDMMEPlotProperties() (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
AcDMMEPlotProperties(const AcDMMEPlotProperties &src) (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
AddProperty(const AcDMMEPlotProperty *property) (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
AddProperty(wchar_t *name, wchar_t *value) (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
GetId() const (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
GetProperties() const (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
GetProperty(unsigned long index) const (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
GetRefs() const (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
operator=(const AcDMMEPlotProperties &src) (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
SetId(const wchar_t *id) (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
SetRefs(const AcDMMStringVec &refs) (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline
~AcDMMEPlotProperties() (defined in AcDMMEPlotProperties) | AcDMMEPlotProperties | inline


ZRX API Reference: AcDMMEPlotProperty Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDMMEPlotProperty Class Reference
AcDMM Classes

Public Member Functions

AcDMMEPlotProperty (const wchar_t *name, const wchar_t *value)
AcDMMEPlotProperty (const AcDMMEPlotProperty &src)
void | AddXMLAttribute (const AcDMMXMLAttribute *attrib)
void | AddXMLAttribute (const wchar_t *ns, const wchar_t *nsUrl, const wchar_t *attName, const wchar_t *attValue)
const wchar_t * | GetCategory () const
const wchar_t * | GetName () const
const wchar_t * | GetType () const
const wchar_t * | GetUnits () const
const wchar_t * | GetValue () const
const AcDMMXMLAttributeVec & | GetXMLAttributes () const
AcDMMEPlotProperty & | operator= (const AcDMMEPlotProperty &src)
void | SetCategory (const wchar_t *category)
void | SetName (const wchar_t *name)
void | SetType (const wchar_t *type)
void | SetUnits (const wchar_t *units)
void | SetValue (const wchar_t *value)
The documentation for this class was generated from the following file:
  • acdmmeplotproperty.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDMMEPlotProperty Member List

This is the complete list of members for AcDMMEPlotProperty, including all inherited members.

AcDMMEPlotProperty() (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
AcDMMEPlotProperty(const wchar_t *name, const wchar_t *value) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
AcDMMEPlotProperty(const AcDMMEPlotProperty &src) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
AddXMLAttribute(const AcDMMXMLAttribute *attrib) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
AddXMLAttribute(const wchar_t *ns, const wchar_t *nsUrl, const wchar_t *attName, const wchar_t *attValue) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
GetCategory() const (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
GetName() const (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
GetType() const (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
GetUnits() const (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
GetValue() const (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
GetXMLAttributes() const (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
operator=(const AcDMMEPlotProperty &src) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
SetCategory(const wchar_t *category) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
SetName(const wchar_t *name) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
SetType(const wchar_t *type) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
SetUnits(const wchar_t *units) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
SetValue(const wchar_t *value) (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline
~AcDMMEPlotProperty() (defined in AcDMMEPlotProperty) | AcDMMEPlotProperty | inline


ZRX API Reference: AcDMMNode Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDMMNode Class Reference
AcDMM Classes

Public Member Functions

AcDMMNode (int number, wchar_t *name)
AcDMMNode (const AcDMMNode &src)
const wchar_t * | nodeName ()
int | nodeNumber ()
AcDMMNode & | operator= (const AcDMMNode &src)
void | SetNodeName (const wchar_t *name)
void | SetNodeNumber (int number)
The documentation for this class was generated from the following file:
  • acdmmutils.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDMMNode Member List

This is the complete list of members for AcDMMNode, including all inherited members.

AcDMMNode() (defined in AcDMMNode) | AcDMMNode | inline
AcDMMNode(int number, wchar_t *name) (defined in AcDMMNode) | AcDMMNode | inline
AcDMMNode(const AcDMMNode &src) (defined in AcDMMNode) | AcDMMNode | inline
nodeName() (defined in AcDMMNode) | AcDMMNode | inline
nodeNumber() (defined in AcDMMNode) | AcDMMNode | inline
operator=(const AcDMMNode &src) (defined in AcDMMNode) | AcDMMNode | inline
SetNodeName(const wchar_t *name) (defined in AcDMMNode) | AcDMMNode | inline
SetNodeNumber(int number) (defined in AcDMMNode) | AcDMMNode | inline
~AcDMMNode() (defined in AcDMMNode) | AcDMMNode | inline


ZRX API Reference: AcDMMReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDMMReactor Class Reference
AcDMM Classes
+ Inheritance diagram for AcDMMReactor:

Public Member Functions

virtual void | OnBeginEntity (AcDMMEntityReactorInfo *pInfo)
virtual void | OnBeginSheet (AcDMMSheetReactorInfo *pInfo)
virtual void | OnEndEntity (AcDMMEntityReactorInfo *pInfo)
virtual void | OnEndSheet (AcDMMSheetReactorInfo *pInfo)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acdmmapi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDMMReactor Member List

This is the complete list of members for AcDMMReactor, including all inherited members.

AcDMMReactor() (defined in AcDMMReactor) | AcDMMReactor | inlineprotected
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
OnBeginEntity(AcDMMEntityReactorInfo *pInfo) (defined in AcDMMReactor) | AcDMMReactor | inlinevirtual
OnBeginSheet(AcDMMSheetReactorInfo *pInfo) (defined in AcDMMReactor) | AcDMMReactor | inlinevirtual
OnEndEntity(AcDMMEntityReactorInfo *pInfo) (defined in AcDMMReactor) | AcDMMReactor | inlinevirtual
OnEndSheet(AcDMMSheetReactorInfo *pInfo) (defined in AcDMMReactor) | AcDMMReactor | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcDMMReactor() (defined in AcDMMReactor) | AcDMMReactor | inlinevirtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDMMResourceInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDMMResourceInfo Class Reference
AcDMM Classes

Public Member Functions

AcDMMResourceInfo (const wchar_t *role, const wchar_t *mime, const wchar_t *path)
AcDMMResourceInfo (const AcDMMResourceInfo &src)
const wchar_t * | GetMime ()
const wchar_t * | GetPath ()
const wchar_t * | GetRole ()
AcDMMResourceInfo & | operator= (const AcDMMResourceInfo &src)
void | SetMime (wchar_t *mime)
void | SetPath (wchar_t *path)
void | SetRole (wchar_t *role)
The documentation for this class was generated from the following file:
  • acdmmutils.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDMMResourceInfo Member List

This is the complete list of members for AcDMMResourceInfo, including all inherited members.

AcDMMResourceInfo() (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
AcDMMResourceInfo(const wchar_t *role, const wchar_t *mime, const wchar_t *path) (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
AcDMMResourceInfo(const AcDMMResourceInfo &src) (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
GetMime() (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
GetPath() (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
GetRole() (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
operator=(const AcDMMResourceInfo &src) (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
SetMime(wchar_t *mime) (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
SetPath(wchar_t *path) (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
SetRole(wchar_t *role) (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline
~AcDMMResourceInfo() (defined in AcDMMResourceInfo) | AcDMMResourceInfo | inline


ZRX API Reference: AcDMMSheetReactorInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcDMMSheetReactorInfo Class Reference
AcDMM Classes

Public Types

enum PlotArea {
kDisplay = 0, kExtents = 1, kLimits = 2, kView,
kWindow, kLayout
}
enum | PlotMediaUnits { kInches, kMillimeters, kPixels }
enum | PlotRotation { k0degrees, k90degrees, k180degrees, k270degrees }

Public Member Functions

virtual void | AddPageProperties (AcDMMEPlotPropertyVec props)=0
virtual void | AddPageResources (AcDMMResourceVec resources)=0
virtual bool | areLinesHidden () const =0
virtual bool | arePlottingLineWeights () const =0
virtual bool | areScalingLineWeights () const =0
virtual const TCHAR * | canonicalMediaName () const =0
virtual const TCHAR * | configuration () const =0
virtual AcDbDatabase * | database () const =0
virtual double | displayMaxX () const =0
virtual double | displayMaxY () const =0
virtual double | displayMinX () const =0
virtual double | displayMinY () const =0
virtual double | drawingScale () const =0
virtual double | effectivePlotOffsetX () const =0
virtual int | effectivePlotOffsetXdevice () const =0
virtual double | effectivePlotOffsetY () const =0
virtual int | effectivePlotOffsetYdevice () const =0
virtual Ac3dDwfNavTreeNode * | get3dDwfNavigationTreeNode ()=0
virtual AcPlPlotLogger * | GetPlotLogger ()=0
virtual bool | isModelLayout () const =0
virtual bool | isPlotJobCancelled () const =0
virtual bool | isScaleSpecified () const =0
virtual double | layoutBoundsMaxX () const =0
virtual double | layoutBoundsMaxY () const =0
virtual double | layoutBoundsMinX () const =0
virtual double | layoutBoundsMinY () const =0
virtual double | layoutMarginMaxX () const =0
virtual double | layoutMarginMaxY () const =0
virtual double | layoutMarginMinX () const =0
virtual double | layoutMarginMinY () const =0
virtual double | maxBoundsX () const =0
virtual double | maxBoundsY () const =0
virtual double | originX () const =0
virtual double | originY () const =0
virtual double | paperScale () const =0
virtual PlotArea | plotArea () const =0
virtual double | plotBoundsMaxX () const =0
virtual double | plotBoundsMaxY () const =0
virtual double | plotBoundsMinX () const =0
virtual double | plotBoundsMinY () const =0
virtual AcDbObjectId | plotLayoutId () const =0
virtual PlotMediaUnits | plotMediaUnits () const =0
virtual PlotRotation | plotRotation () const =0
virtual const TCHAR * | plotToFileName () const =0
virtual const TCHAR * | plotToFilePath () const =0
virtual double | plotWindowMaxX () const =0
virtual double | plotWindowMaxY () const =0
virtual double | plotWindowMinX () const =0
virtual double | plotWindowMinY () const =0
virtual double | printableBoundsX () const =0
virtual double | printableBoundsY () const =0
virtual bool | publishingTo3DDwf () const =0
virtual bool | set3dDwfNavigationTreeNode (const Ac3dDwfNavTreeNode *root)=0
virtual double | stepsPerInch () const =0
virtual const ACHAR * | UniqueLayoutId ()=0
virtual const TCHAR * | viewPlotted () const =0
The documentation for this class was generated from the following file:
  • acdmmapi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDMMSheetReactorInfo Member List

This is the complete list of members for AcDMMSheetReactorInfo, including all inherited members.

AcDMMSheetReactorInfo() (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | inlineprotected
AddPageProperties(AcDMMEPlotPropertyVec props)=0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
AddPageResources(AcDMMResourceVec resources)=0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
areLinesHidden() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
arePlottingLineWeights() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
areScalingLineWeights() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
canonicalMediaName() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
configuration() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
database() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
displayMaxX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
displayMaxY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
displayMinX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
displayMinY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
drawingScale() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
effectivePlotOffsetX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
effectivePlotOffsetXdevice() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
effectivePlotOffsetY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
effectivePlotOffsetYdevice() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
get3dDwfNavigationTreeNode()=0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
GetPlotLogger()=0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
isModelLayout() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
isPlotJobCancelled() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
isScaleSpecified() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
k0degrees enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
k180degrees enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
k270degrees enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
k90degrees enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
kDisplay enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
kExtents enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
kInches enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
kLayout enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
kLimits enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
kMillimeters enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
kPixels enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
kView enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
kWindow enum value (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
layoutBoundsMaxX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
layoutBoundsMaxY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
layoutBoundsMinX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
layoutBoundsMinY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
layoutMarginMaxX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
layoutMarginMaxY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
layoutMarginMinX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
layoutMarginMinY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
maxBoundsX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
maxBoundsY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
originX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
originY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
paperScale() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
PlotArea enum name (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
plotArea() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotBoundsMaxX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotBoundsMaxY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotBoundsMinX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotBoundsMinY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotLayoutId() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
PlotMediaUnits enum name (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
plotMediaUnits() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotRotation() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
PlotRotation enum name (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo |
plotToFileName() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotToFilePath() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotWindowMaxX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotWindowMaxY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotWindowMinX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
plotWindowMinY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
printableBoundsX() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
printableBoundsY() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
publishingTo3DDwf() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
set3dDwfNavigationTreeNode(const Ac3dDwfNavTreeNode *root)=0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
stepsPerInch() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
UniqueLayoutId()=0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
viewPlotted() const =0 (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | pure virtual
~AcDMMSheetReactorInfo() (defined in AcDMMSheetReactorInfo) | AcDMMSheetReactorInfo | inlinevirtual


ZRX API Reference: AcDMMWideString Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDMMWideString Class Reference
AcDMM Classes

Public Member Functions

AcDMMWideString (const AcDMMWideString &ws)
AcDMMWideString (PCWIDESTR pwsz)
void | Empty ()
unsigned | GetLength () const
bool | IsEmpty () const
operator PCWIDESTR () const
const AcDMMWideString & | operator+= (AcDMMWideString ws)
const AcDMMWideString & | operator= (const AcDMMWideString &ws)
const AcDMMWideString & | operator= (PCWIDESTR pwsz)

Friends

AcDMMWideString | operator+ (const AcDMMWideString &wsLeft, wchar_t wch)
AcDMMWideString | operator+ (wchar_t wch, const AcDMMWideString &wsRight)
AcDMMWideString | operator+ (const AcDMMWideString &wsLeft, const AcDMMWideString &wsRight)
The documentation for this class was generated from the following file:
  • acdmmutils.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDMMWideString Member List

This is the complete list of members for AcDMMWideString, including all inherited members.

AcDMMWideString() (defined in AcDMMWideString) | AcDMMWideString | inline
AcDMMWideString(const AcDMMWideString &ws) (defined in AcDMMWideString) | AcDMMWideString | inline
AcDMMWideString(PCWIDESTR pwsz) (defined in AcDMMWideString) | AcDMMWideString | inline
Empty() (defined in AcDMMWideString) | AcDMMWideString | inline
GetLength() const (defined in AcDMMWideString) | AcDMMWideString | inline
IsEmpty() const (defined in AcDMMWideString) | AcDMMWideString | inline
operator PCWIDESTR() const (defined in AcDMMWideString) | AcDMMWideString | inline
operator+ (defined in AcDMMWideString) | AcDMMWideString | friend
operator+ (defined in AcDMMWideString) | AcDMMWideString | friend
operator+ (defined in AcDMMWideString) | AcDMMWideString | friend
operator+=(AcDMMWideString ws) (defined in AcDMMWideString) | AcDMMWideString | inline
operator=(const AcDMMWideString &ws) (defined in AcDMMWideString) | AcDMMWideString | inline
operator=(PCWIDESTR pwsz) (defined in AcDMMWideString) | AcDMMWideString | inline
~AcDMMWideString() (defined in AcDMMWideString) | AcDMMWideString | inlinevirtual


ZRX API Reference: AcDMMXMLAttribute Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDMMXMLAttribute Class Reference
AcDMM Classes

Public Member Functions

AcDMMXMLAttribute (const wchar_t *ns, const wchar_t *nsUrl, const wchar_t *attName, const wchar_t *attValue)
AcDMMXMLAttribute (const AcDMMXMLAttribute &src)
const wchar_t * | GetAttributeName () const
const wchar_t * | GetAttributeValue () const
const wchar_t * | GetNamespace () const
const wchar_t * | GetNamespaceUrl () const
const AcDMMXMLAttribute & | operator= (const AcDMMXMLAttribute &src)
void | SetAttributeName (const wchar_t *attName)
void | SetAttributeValue (const wchar_t *attValue)
void | SetNamespace (const wchar_t *ns)
void | SetNamespaceUrl (const wchar_t *nsUrl)
The documentation for this class was generated from the following file:
  • acdmmeplotproperty.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDMMXMLAttribute Member List

This is the complete list of members for AcDMMXMLAttribute, including all inherited members.

AcDMMXMLAttribute() (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
AcDMMXMLAttribute(const wchar_t *ns, const wchar_t *nsUrl, const wchar_t *attName, const wchar_t *attValue) (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
AcDMMXMLAttribute(const AcDMMXMLAttribute &src) (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
GetAttributeName() const (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
GetAttributeValue() const (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
GetNamespace() const (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
GetNamespaceUrl() const (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
operator=(const AcDMMXMLAttribute &src) (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
SetAttributeName(const wchar_t *attName) (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
SetAttributeValue(const wchar_t *attValue) (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
SetNamespace(const wchar_t *ns) (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
SetNamespaceUrl(const wchar_t *nsUrl) (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline
~AcDMMXMLAttribute() (defined in AcDMMXMLAttribute) | AcDMMXMLAttribute | inline


ZRX API Reference: Global Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Macros | Typedefs | Enumerations | Functions
Global Functions

Macros

#define | acdbRestoreAcisEntityFromDwgFiler acdbAcisRestoreEntityFromDwgFiler
#define | acdbSaveAcisEntityToDwgFiler acdbAcisSaveEntityToDwgFiler
#define | acdbTransactionManager acdbTransactionManagerPtr()
#define | acDocManager acDocManagerPtr()
#define | acedGetIDispatch ZwcadGetIDispatch
#define | acedServices AcEdServices::cast(acrxServiceDictionary->at(ACED_SERVICES))
#define | acProfileManager acProfileManagerPtr()
#define | actrTransactionManager acTransactionManagerPtr()
#define | DISABLE_CSTRING_PLUS_ACSTRING 1
#define | HELP_CONTENTS 0x0003L
#define | HELP_HELPONHELP 0x0004L
#define | HELP_PARTIALKEY 0x0105L

Typedefs

typedef
AcDbSymbolUtilities::Services 		AcDbSymUtilServices
typedef void(WINAPI * | AcEdColorDialogCallbackFunction )(void *pCallbackData, const AcCmColor &newColor)
typedef double | acedDwgPoint [3]
typedef BOOL(* | AcedFilterWinMsgFn )(MSG *)
typedef void(* | AcedOnIdleMsgFn )()
typedef void(* | AcedWatchWinMsgFn )(const MSG *)
typedef void(* | acgsCustomUpdateMethod )(void *pParm, int left, int right, int bottom, int top)
typedef HRESULT | ADUI_LOADFN (IUnknown **ppZdUiRootNode)
typedef HRESULT | ADUI_SAVEFN (IUnknown *pZdUiRootNode)
typedef AcArray
< AcFdFieldReactor * > 		FieldReactors

Enumerations

enum AcEdDrawOrderCmdType {
kDrawOrderNone = 0, kDrawOrderBottom, kDrawOrderTop, kDrawOrderBelow,
kDrawOrderAbove
}
enum path_category { DRIVE_TYPE, UNC_TYPE, ROOT_TYPE, RELATIVE_TYPE }
enum path_type {
NO_PATH = 0, NEW_PATH, WC_PATH, FILE_PATH,
DIR_PATH, DEV_PATH
}
enum PathErr {
PATH_NOERR = 0, PATH_INVALID, PATH_BADOP, PATH_REFUSED,
PATH_ERR
}

Functions

void | acad__assert (const ACHAR *, const ACHAR *, int)
size_t | acad__msize (void *p)
ACHAR * | acad__strdup (const ACHAR *p)
void * | acad_calloc (size_t num, size_t size)
void | acad_free (void *p)
void * | acad_malloc (size_t size)
void * | acad_realloc (void *p, size_t size)
const ACHAR * | acadErrorStatusText (Acad::ErrorStatus)
AcDbDatabase * | AcApGetDatabase (CView *pView)
HRESULT AXAUTOEXP | AcAxArrayPolar (AcDbObjectId &objId, LPDISPATCH pAppDisp, int numObjs, double fillAngle, VARIANT basePoint, VARIANT *pArrayObjs)
HRESULT AXAUTOEXP | AcAxArrayPolar (AcAxObjectRef &objRef, LPDISPATCH pAppDisp, int numObjs, double fillAngle, VARIANT basePoint, VARIANT *pArrayObjs)
HRESULT AXAUTOEXP | AcAxArrayRectangular (AcDbObjectId &objId, LPDISPATCH pAppDisp, int numRows, int numCols, int numLvls, double disRows, double disCols, double disLvls, VARIANT *pArrayObjs)
HRESULT AXAUTOEXP | AcAxArrayRectangular (AcAxObjectRef &objRef, LPDISPATCH pAppDisp, int numRows, int numCols, int numLvls, double disRows, double disCols, double disLvls, VARIANT *pArrayObjs)
HRESULT AXAUTOEXP | AcAxCopy (AcDbObjectId &objId, LPDISPATCH pAppDisp, LPDISPATCH *pCopyObj, AcDbObjectId ownerId=AcDbObjectId::kNull)
HRESULT AXAUTOEXP | AcAxCopy (AcAxObjectRef &objRef, LPDISPATCH pAppDisp, LPDISPATCH *pCopyObj, AcDbObjectId ownerId=AcDbObjectId::kNull)
HRESULT AXAUTOEXP | AcAxEnableShadowDisplay (AcDbObjectId &objId, bool *pEnabled)
HRESULT AXAUTOEXP | AcAxEnableShadowDisplay (AcAxObjectRef &objRef, bool *pEnabled)
HRESULT AXAUTOEXP | AcAxErase (AcDbObjectId &objId)
HRESULT AXAUTOEXP | AcAxErase (AcAxObjectRef &objRef)
HRESULT AXAUTOEXP | AcAxGetBoundingBox (AcDbObjectId &objId, VARIANT *minPoint, VARIANT *maxPoint)
HRESULT AXAUTOEXP | AcAxGetBoundingBox (AcAxObjectRef &objRef, VARIANT *minPoint, VARIANT *maxPoint)
HRESULT AXAUTOEXP | AcAxGetColor (AcDbObjectId &objId, AcColor *pColor)
HRESULT AXAUTOEXP | AcAxGetColor (AcAxObjectRef &objRef, AcColor *pColor)
HRESULT AXAUTOEXP | AcAxGetDatabase (AcDbDatabase *pDb, LPDISPATCH pAppDisp, LPDISPATCH *pDisp)
HRESULT AXAUTOEXP | AcAxGetExtensionDictionary (AcDbObjectId &objId, LPDISPATCH pAppDisp, IAcadDictionary **pExtDictionary)
HRESULT AXAUTOEXP | AcAxGetExtensionDictionary (AcAxObjectRef &objRef, LPDISPATCH pAppDisp, IAcadDictionary **pExtDictionary)
HRESULT AXAUTOEXP | AcAxGetHandle (AcDbObjectId &objId, BSTR *pHandle)
HRESULT AXAUTOEXP | AcAxGetHandle (AcAxObjectRef &objRef, BSTR *pHandle)
HRESULT AXAUTOEXP | AcAxGetHyperlinks (AcDbObjectId &objId, LPDISPATCH pAppDisp, IAcadHyperlinks **pHyperlinks)
HRESULT AXAUTOEXP | AcAxGetHyperlinks (AcAxObjectRef &objRef, LPDISPATCH pAppDisp, IAcadHyperlinks **pHyperlinks)
HRESULT AXAUTOEXP | AcAxGetIUnknownOfObject (LPUNKNOWN *ppUnk, AcDbObjectId &objId, LPDISPATCH pApp)
HRESULT AXAUTOEXP | AcAxGetIUnknownOfObject (LPUNKNOWN *ppUnk, AcDbObject *pObj, LPDISPATCH pApp)
HRESULT AXAUTOEXP | AcAxGetLayer (AcDbObjectId &objId, BSTR *pLayer)
HRESULT AXAUTOEXP | AcAxGetLayer (AcAxObjectRef &objRef, BSTR *pLayer)
HRESULT AXAUTOEXP | AcAxGetLinetype (AcDbObjectId &objId, BSTR *pLinetype)
HRESULT AXAUTOEXP | AcAxGetLinetype (AcAxObjectRef &objRef, BSTR *pLinetype)
HRESULT AXAUTOEXP | AcAxGetLinetypeScale (AcDbObjectId &objId, double *pLinetypeScale)
HRESULT AXAUTOEXP | AcAxGetLinetypeScale (AcAxObjectRef &objRef, double *pLinetypeScale)
HRESULT AXAUTOEXP | AcAxGetLineWeight (AcDbObjectId &objId, ACAD_LWEIGHT *lineWeight)
HRESULT AXAUTOEXP | AcAxGetLineWeight (AcAxObjectRef &objRef, ACAD_LWEIGHT *lineWeight)
HRESULT AXAUTOEXP | AcAxGetMaterial (AcDbObjectId &objId, BSTR *pMaterial)
HRESULT AXAUTOEXP | AcAxGetMaterial (AcAxObjectRef &objRef, BSTR *pMaterial)
HRESULT AXAUTOEXP | AcAxGetObjectName (AcDbObjectId &objId, BSTR *pName)
HRESULT AXAUTOEXP | AcAxGetObjectName (AcAxObjectRef &objRef, BSTR *pName)
HRESULT AXAUTOEXP | AcAxGetOwnerId (AcDbObjectId &objId, Adesk::IntDbId *pOwnerId)
HRESULT AXAUTOEXP | AcAxGetOwnerId (AcAxObjectRef &objRef, Adesk::IntDbId *pOwnerId)
HRESULT AXAUTOEXP | AcAxGetPlotStyleName (AcDbObjectId &objId, BSTR *plotStyleName)
HRESULT AXAUTOEXP | AcAxGetPlotStyleName (AcAxObjectRef &objRef, BSTR *plotStyleName)
HRESULT AXAUTOEXP | AcAxGetShadowDisplay (AcDbObjectId &objId, AcShadowDisplayType *pShadowDisplay)
HRESULT AXAUTOEXP | AcAxGetShadowDisplay (AcAxObjectRef &objRef, AcShadowDisplayType *pShadowDisplay)
HRESULT AXAUTOEXP | AcAxGetTrueColor (AcDbObjectId &objId, IAcadAcCmColor **pColor)
HRESULT AXAUTOEXP | AcAxGetTrueColor (AcAxObjectRef &objRef, IAcadAcCmColor **pColor)
HRESULT AXAUTOEXP | AcAxGetVisible (AcDbObjectId &objId, VARIANT_BOOL *pVisible)
HRESULT AXAUTOEXP | AcAxGetVisible (AcAxObjectRef &objRef, VARIANT_BOOL *pVisible)
HRESULT AXAUTOEXP | AcAxGetXData (AcDbObjectId &objId, BSTR bstrName, VARIANT *type, VARIANT *data)
HRESULT AXAUTOEXP | AcAxGetXData (AcAxObjectRef &objRef, BSTR bstrName, VARIANT *type, VARIANT *data)
HRESULT AXAUTOEXP | AcAxHasExtensionDictionary (AcDbObjectId &objId, VARIANT_BOOL *bHasDictionary)
HRESULT AXAUTOEXP | AcAxHasExtensionDictionary (AcAxObjectRef &objRef, VARIANT_BOOL *bHasDictionary)
HRESULT AXAUTOEXP | AcAxHighlight (AcDbObjectId &objId, VARIANT_BOOL bHighlight)
HRESULT AXAUTOEXP | AcAxHighlight (AcAxObjectRef &objRef, VARIANT_BOOL bHighlight)
HRESULT AXAUTOEXP | AcAxIntersectWith (AcDbObjectId &objId, LPDISPATCH pEntity, AcExtendOption option, VARIANT *intPoints)
HRESULT AXAUTOEXP | AcAxIntersectWith (AcAxObjectRef &objRef, LPDISPATCH pEntity, AcExtendOption option, VARIANT *intPoints)
HRESULT AXAUTOEXP | AcAxMirror (AcDbObjectId &objId, LPDISPATCH pAppDisp, VARIANT point1, VARIANT point2, LPDISPATCH *pMirrorObj)
HRESULT AXAUTOEXP | AcAxMirror (AcAxObjectRef &objRef, LPDISPATCH pAppDisp, VARIANT point1, VARIANT point2, LPDISPATCH *pMirrorObj)
HRESULT AXAUTOEXP | AcAxMirror3D (AcDbObjectId &objId, LPDISPATCH pAppDisp, VARIANT point1, VARIANT point2, VARIANT point3, LPDISPATCH *pMirrorObj)
HRESULT AXAUTOEXP | AcAxMirror3D (AcAxObjectRef &objRef, LPDISPATCH pAppDisp, VARIANT point1, VARIANT point2, VARIANT point3, LPDISPATCH *pMirrorObj)
HRESULT AXAUTOEXP | AcAxMove (AcDbObjectId &objId, VARIANT fromPoint, VARIANT toPoint)
HRESULT AXAUTOEXP | AcAxMove (AcAxObjectRef &objRef, VARIANT fromPoint, VARIANT toPoint)
HRESULT AXAUTOEXP | AcAxPutColor (AcDbObjectId &objId, AcColor color)
HRESULT AXAUTOEXP | AcAxPutColor (AcAxObjectRef &objRef, AcColor color)
HRESULT AXAUTOEXP | AcAxPutLayer (AcDbObjectId &objId, BSTR layer)
HRESULT AXAUTOEXP | AcAxPutLayer (AcAxObjectRef &objRef, BSTR layer)
HRESULT AXAUTOEXP | AcAxPutLinetype (AcDbObjectId &objId, BSTR linetype)
HRESULT AXAUTOEXP | AcAxPutLinetype (AcAxObjectRef &objRef, BSTR linetype)
HRESULT AXAUTOEXP | AcAxPutLinetypeScale (AcDbObjectId &objId, double linetypeScale)
HRESULT AXAUTOEXP | AcAxPutLinetypeScale (AcAxObjectRef &objRef, double linetypeScale)
HRESULT AXAUTOEXP | AcAxPutLineWeight (AcDbObjectId &objId, ACAD_LWEIGHT lineWeight)
HRESULT AXAUTOEXP | AcAxPutLineWeight (AcAxObjectRef &objRef, ACAD_LWEIGHT lineWeight)
HRESULT AXAUTOEXP | AcAxPutMaterial (AcDbObjectId &objId, BSTR material)
HRESULT AXAUTOEXP | AcAxPutMaterial (AcAxObjectRef &objRef, BSTR material)
HRESULT AXAUTOEXP | AcAxPutPlotStyleName (AcDbObjectId &objId, BSTR plotStyleName)
HRESULT AXAUTOEXP | AcAxPutPlotStyleName (AcAxObjectRef &objRef, BSTR plotStyleName)
HRESULT AXAUTOEXP | AcAxPutShadowDisplay (AcDbObjectId &objId, AcShadowDisplayType shadowDisplay)
HRESULT AXAUTOEXP | AcAxPutShadowDisplay (AcAxObjectRef &objRef, AcShadowDisplayType shadowDisplay)
HRESULT AXAUTOEXP | AcAxPutTrueColor (AcDbObjectId &objId, IAcadAcCmColor *color)
HRESULT AXAUTOEXP | AcAxPutTrueColor (AcAxObjectRef &objRef, IAcadAcCmColor *color)
HRESULT AXAUTOEXP | AcAxPutVisible (AcDbObjectId &objId, VARIANT_BOOL visible)
HRESULT AXAUTOEXP | AcAxPutVisible (AcAxObjectRef &objRef, VARIANT_BOOL visible)
HRESULT AXAUTOEXP | AcAxRotate (AcDbObjectId &objId, VARIANT basePoint, double rotationAngle)
HRESULT AXAUTOEXP | AcAxRotate (AcAxObjectRef &objRef, VARIANT basePoint, double rotationAngle)
HRESULT AXAUTOEXP | AcAxRotate3D (AcDbObjectId &objId, VARIANT point1, VARIANT point2, double rotationAngle)
HRESULT AXAUTOEXP | AcAxRotate3D (AcAxObjectRef &objRef, VARIANT point1, VARIANT point2, double rotationAngle)
HRESULT AXAUTOEXP | AcAxScaleEntity (AcDbObjectId &objId, VARIANT basePoint, double scaleFactor)
HRESULT AXAUTOEXP | AcAxScaleEntity (AcAxObjectRef &objRef, VARIANT basePoint, double scaleFactor)
HRESULT AXAUTOEXP | AcAxSetXData (AcDbObjectId &objId, VARIANT type, VARIANT data)
HRESULT AXAUTOEXP | AcAxSetXData (AcAxObjectRef &objRef, VARIANT type, VARIANT data)
HRESULT AXAUTOEXP | AcAxTransformBy (AcDbObjectId &objId, VARIANT transMatrix)
HRESULT AXAUTOEXP | AcAxTransformBy (AcAxObjectRef &objRef, VARIANT transMatrix)
HRESULT AXAUTOEXP | AcAxUpdate (AcDbObjectId &objId)
HRESULT AXAUTOEXP | AcAxUpdate (AcAxObjectRef &objRef)
void | acByteSwap (wchar_t &wch)
Acad::ErrorStatus | accmGetColorFromACIName (AcCmColor &clr, const ACHAR *pInput)
Acad::ErrorStatus | accmGetColorFromColorBookName (AcCmColor &clr, const ACHAR *pBookName, const ACHAR *pColorName)
Acad::ErrorStatus | accmGetColorFromRGBName (AcCmColor &clr, const ACHAR *pInput)
void | accmGetLocalizedColorNames (const ACHAR *colors[9])
void | acdbAcisDeleteModelerBulletins (void)
Adesk::Boolean | acdbAcisGetDeleteBulletins ()
Acad::ErrorStatus | acdbAcisRestoreEntityFromDwgFiler (AcDbDwgFiler *filer, ENTITY *&ent)
Acad::ErrorStatus | acdbAcisRestoreEntityFromDxfFiler (AcDbDxfFiler *filer, ENTITY *&ent)
Acad::ErrorStatus | acdbAcisSaveEntityToDwgFiler (AcDbDwgFiler *filer, ENTITY *ent)
Acad::ErrorStatus | acdbAcisSaveEntityToDxfFiler (AcDbDxfFiler *filer, ENTITY *ent)
void | acdbAcisSetDeleteBulletins (Adesk::Boolean onOff)
AcDbVoidPtrArray * | acdbActiveDatabaseArray ()
Acad::ErrorStatus | acdbAddFieldReactor (AcFdFieldReactor *pReactor)
void * | acdbAlloc (size_t)
int | acdbAngToF (const ACHAR *str, int unit, ads_real *v)
int | acdbAngToS (ads_real v, int unit, int prec, ACHAR *str)
Acad::ErrorStatus | acdbAttachXref (AcDbDatabase *pHostDb, const ACHAR *pFilename, const ACHAR *pBlockName, AcDbObjectId &xrefBlkId)
Acad::ErrorStatus | acdbBindXrefs (AcDbDatabase *pHostDb, const AcDbObjectIdArray &xrefBlkIds, const bool bInsertBind, const bool bAllowUnresolved=false, const bool bQuiet=true)
bool | acdbCanonicalToSystemRange (int eUnits, const AcString &strIn, AcString &strOut)
Acad::ErrorStatus | acdbCleanUp ()
Acad::ErrorStatus | acdbClearSetupForLayouts (unsigned int contextHandle)
ACDB_PORT Acad::ErrorStatus | acdbConvertFieldsToText (AcDbDatabase *pDb, const AcStringArray *pEvalIds, AcFd::ConvertFieldToText nOption)
ACDB_PORT Acad::ErrorStatus | acdbConvertFieldsToText (const AcDbObjectIdArray &objIds, const AcStringArray *pEvalIds, AcFd::ConvertFieldToText nOption)
ACDB_PORT void | acdbConvertHslToRgb (const AcGeVector3d &hsl, AcGeVector3d &rgb)
ACDB_PORT void | acdbConvertRgbToHsl (const AcGeVector3d &rgb, AcGeVector3d &hsl)
Acad::ErrorStatus | acdbCopyLayout (const ACHAR *copyname, const ACHAR *newname, AcDbDatabase *pDb=NULL)
Acad::ErrorStatus | acdbCreateViewByViewport (AcDbDatabase *pDb, AcDbObjectId viewportId, const ACHAR *name, const ACHAR *categoryName, AcDbObjectId labelBlockId, AcDbObjectId &view)
AcDbCustomOsnapManager * | acdbCustomOsnapManager ()
Acad::ErrorStatus | acdbDeleteLayout (const ACHAR *delname, AcDbDatabase *pDb=NULL)
Acad::ErrorStatus | acdbDetachXref (AcDbDatabase *pHostDb, const AcDbObjectId &xrefBlkId)
int | acdbDictAdd (const ads_name dictname, const ACHAR *symname, const ads_name newobj)
struct resbuf * | acdbDictNext (const ads_name dict, int rewind)
int | acdbDictRemove (const ads_name dictname, const ACHAR *symname)
int | acdbDictRename (const ads_name dictname, const ACHAR *oldsym, const ACHAR *newsym)
struct resbuf * | acdbDictSearch (const ads_name dict, const ACHAR *sym, int setnext)
bool | acdbDisplayPreviewFromDwg (const ACHAR *pszDwgfilename, void *pPreviewWnd, const Adesk::UInt32 *pBgColor=NULL)
int | acdbDisToF (const ACHAR *str, int unit, ads_real *v)
Acad::ErrorStatus | acdbDoSetupForLayouts (AcDbDatabase *pDatabase, unsigned int &contextHandle)
bool ADESK_STDCALL | acdbDwkFileExists (const ACHAR *pszFileName)
Acad::ErrorStatus | acdbDxfOutAs2000 (AcDbDatabase *pDb, const ACHAR *fileName, const int precision=16)
Acad::ErrorStatus | acdbDxfOutAs2004 (AcDbDatabase *pDb, const ACHAR *fileName, const int precision=16)
Acad::ErrorStatus | acdbDxfOutAsR12 (AcDbDatabase *pDb, const ACHAR *fileName, const int precision=16)
bool | acdbEcs2Ucs (ads_point p, ads_point q, ads_point norm, bool vec)
bool | acdbEcs2Wcs (ads_point p, ads_point q, ads_point norm, bool vec)
int | acdbEntDel (const ads_name ent)
struct resbuf * | acdbEntGet (const ads_name ent)
struct resbuf * | acdbEntGetX (const ads_name ent, const struct resbuf *args)
int | acdbEntLast (ads_name result)
int | acdbEntMake (const struct resbuf *ent)
int | acdbEntMakeX (const struct resbuf *entm, ads_name result)
int | acdbEntMod (const struct resbuf *ent)
int | acdbEntNext (const ads_name ent, ads_name result)
int | acdbEntUpd (const ads_name ent)
ACDB_PORT Acad::ErrorStatus | acdbEvaluateFields (const AcDbObjectId &objId, int nContext, const ACHAR *pszPropName=NULL, AcDbDatabase *pDb=NULL, AcFd::EvalFields nEvalFlag=AcFd::kEvalRecursive, int *pNumFound=NULL, int *pNumEvaluated=NULL)
ACDB_PORT Acad::ErrorStatus | acdbEvaluateFields (const AcDbObjectId &objId, int nContext, const AcDbObjectIdArray *pFieldsToEvaluate, const ACHAR *pszEvaluatorId, AcDbDatabase *pDb, AcFd::EvalFields nEvalFlag, int *pNumFound, int *pNumEvaluated)
ACDB_PORT Acad::ErrorStatus | acdbEvaluateFields (const AcDbObjectIdArray &objIds, int nContext, const ACHAR *pszPropName=NULL, AcDbDatabase *pDb=NULL, AcFd::EvalFields nEvalFlag=AcFd::kEvalRecursive, int *pNumFound=NULL, int *pNumEvaluated=NULL)
ACDB_PORT Acad::ErrorStatus | acdbEvaluateFields (const AcDbObjectIdArray &objIds, int nContext, const AcDbObjectIdArray *pFieldsToEvaluate, const ACHAR *pszEvaluatorId, AcDbDatabase *pDb, AcFd::EvalFields nEvalFlag, int *pNumFound, int *pNumEvaluated)
void | acdbFail (const ACHAR *str)
ACDB_PORT bool | acdbFindField (const ACHAR *pszText, int iSearchFrom, int &nStartPos, int &nEndPos)
Acad::ErrorStatus | acdbForceTextAdjust (const AcDbObjectIdArray &objIds)
void | acdbFree (void *)
void | acdbFreeResBufContents (resbuf *pField)
Acad::ErrorStatus | acdbGetAdsName (ads_name &objName, AcDbObjectId objId)
bool | acdbGetArcLengthSymbolPlacement (AcDbObject *pObj, int &nValue)
ACDB_PORT AcDbUnderlayHost * | acdbGetCurrentDgnDocHost ()
ACDB_PORT AcDbUnderlayHost * | acdbGetCurrentDgnHost ()
ACDB_PORT AcDbUnderlayHost * | acdbGetCurrentDwfHost ()
AcDbObjectId | acdbGetCurVportId (AcDbDatabase *pDb)
AcDbObjectId | acdbGetCurVportTableRecordId (AcDbDatabase *pDb)
bool | acdbGetDimAngExtOn (AcDbObject *pObj, int &dimExtFlag)
Acad::ErrorStatus | acdbGetDimAssocId (AcDbObjectId dimId, AcDbObjectId &dimAssocId)
Acad::ErrorStatus | acdbGetDimAssocIds (AcDbObjectId entId, AcDbObjectIdArray &dimAssocIds)
bool | acdbGetDimBreakSize (AcDbObject *pObj, double &dimBreakSize)
bool | acdbGetDimExt1Linetype (AcDbObject *pObj, AcDbObjectId &oidValue)
bool | acdbGetDimExt2Linetype (AcDbObject *pObj, AcDbObjectId &oidValue)
bool | acdbGetDimExtensionLength (AcDbObject *pObj, double &fValue)
bool | acdbGetDimFlipArrow (AcDbObject *pObj, int &nValue)
bool | acdbGetDimFlipArrowWhich (AcDbObject *pObj, int &nValue)
bool | acdbGetDimJogSymbolPosition (AcDbObject *pObj, int &dimJagFlag, AcGePoint3d &pos)
bool | acdbGetDimJogSymbolSize (AcDbObject *pObj, int &dimJagFlag, double &dimJagSize)
bool | acdbGetDimLineLinetype (AcDbObject *pObj, AcDbObjectId &oidValue)
bool | acdbGetDimTextBackground (AcDbObject *pObj, int &bgFlag, AcCmColor &bgColor)
bool | acdbGetDimTolAlign (AcDbObject *pObj, int &dimTolAlignFlag)
AcDbObjectId | acdbGetDynDimStyleId (AcDbDatabase *pDb=NULL)
bool | acdbGetExemptCheckFlag (AcDbObject *pObj, int &bitFlags)
Acad::ErrorStatus | acdbGetExtnames (bool &value, AcDbDatabase *pDb)
ACDB_PORT AcFdFieldEngine * | acdbGetFieldEngine (void)
ACDB_PORT bool | acdbGetFieldMarkers (const ACHAR *&pszPrefix, const ACHAR *&pszSuffix)
bool | acdbGetFixedLengthExtLineEnabled (AcDbObject *pObj, int &nValue)
Acad::ErrorStatus | acdbGetHostDwgXrefGraph (AcDbDatabase *pHostDb, AcDbXrefGraph &graph, Adesk::Boolean includeGhosts=Adesk::kFalse)
bool | acdbGetLargeRadDimJogAngle (AcDbObject *pObj, double &fJogAngle)
Acad::ErrorStatus SCENEDLLIMPEXP | acdbGetMotionPathDictionary (AcDbDatabase *pDb, AcDbDictionary *&pDict, AcDb::OpenMode mode, bool createIfNonExist)
Acad::ErrorStatus SCENEDLLIMPEXP | acdbGetMotionPathDictionary (AcDbDatabase *pDb, AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus SCENEDLLIMPEXP | acdbGetNamedPathDictionary (AcDbDatabase *pDb, AcDbDictionary *&pDict, AcDb::OpenMode mode, bool createIfNonExist)
Acad::ErrorStatus SCENEDLLIMPEXP | acdbGetNamedPathDictionary (AcDbDatabase *pDb, AcDbDictionary *&pDict, AcDb::OpenMode mode)
Acad::ErrorStatus | acdbGetObjectId (AcDbObjectId &objId, const ads_name objName)
bool | acdbGetPreviewBitmapFromDwg (const ACHAR *pszDwgfilename, HBITMAP *pPreviewBmp, HPALETTE *pRetPal)
Acad::ErrorStatus | acdbGetProxyInfo (AcDbObject *pObj, ACHAR *&dxfName, ACHAR *&className, ACHAR *&appName)
bool | acdbGetRadialExtensionAngles (AcDbObject *pObj, int &dimExtFlag, double &dimExtAng1, double &dimExtAng2)
const ACHAR * | acdbGetReservedString (AcDb::reservedStringEnumType reservedType, bool bGetLocalized=true)
Acad::ErrorStatus | acdbGetThumbnailBitmapFromDxfFile (const ACHAR *filename, void *&pBitmap)
Acad::ErrorStatus | acdbGetUnitsConversion (AcDb::UnitsValue from, AcDb::UnitsValue to, double &conversionFactor)
AcDbObjectId acdbGetViewportVisualStyle ()
AcDb::DwgDataType | acdbGroupCodeToType (AcDb::DxfCode pCode)
int | acdbHandEnt (const ACHAR *handle, ads_name entres)
ACDB_PORT bool | acdbHasFields (const ACHAR *pszText)
AcDbHostApplicationServices * | acdbHostApplicationServices ()
int | acdbHostAppMinorVersion ()
int | acdbInters (const ads_point from1, const ads_point to1, const ads_point from2, const ads_point to2, int teston, ads_point result)
bool | acdbIsCustomObject (const AcDbObjectId &id)
bool | acdbIsInLongTransaction (AcDbObjectId id)
Adesk::Boolean | acdbIsModelerStarted ()
bool | acdbIsPersistentReactor (void *pSomething)
bool | acdbIsReservedString (const ACHAR *strString, AcDb::reservedStringEnumType reservedType)
bool | acdbIsTransSpatial (const AcDbFullSubentPath &idPath)
Acad::ErrorStatus | acdbLoadLineTypeFile (const ACHAR *ltname, const ACHAR *fname, AcDbDatabase *pDb)
Acad::ErrorStatus | acdbLoadMlineStyleFile (const ACHAR *sname, const ACHAR *fname)
ACDB_PORT Acad::ErrorStatus | acdbMakeFieldCode (const ACHAR *pszFieldExpr, ACHAR *&pszFieldCode)
ACDB_PORT Acad::ErrorStatus | acdbMakeFieldCode (const ACHAR *pszFieldExpr, ACHAR *&pszFieldCode, const ACHAR *pszEvalId, const ACHAR *pszFormat, const AcHyperlink *pHyperlink)
void | acdbModelerEnd ()
void | acdbModelerStart ()
int | acdbNamedObjDict (ads_name result)
Acad::ErrorStatus | acdbOleGetOriginalSelectedFontName (const AcDbOle2Frame *pOleEnt, ACHAR *&fontName)
Acad::ErrorStatus | acdbOleGetOriginalSelectedFontPointSize (const AcDbOle2Frame *pOleEnt, int &pointSize)
Acad::ErrorStatus | acdbOleGetOriginalSelectedTextSizeInAcadUnits (const AcDbOle2Frame *pOleEnt, double &sizeInZcadUnits)
Acad::ErrorStatus | acdbOleGetOriginalWidthHeight (const AcDbOle2Frame *pOleEnt, double &width, double &height)
Acad::ErrorStatus | acdbOleGetRotationMatrix (const AcDbOle2Frame *pOleEnt, AcGeMatrix3d &rotMat)
Acad::ErrorStatus | acdbOleGetSelectedFontName (const AcDbOle2Frame *pOleEnt, ACHAR *&fontName)
Acad::ErrorStatus | acdbOleGetSelectedFontPointSize (const AcDbOle2Frame *pOleEnt, int &pointSize)
Acad::ErrorStatus | acdbOleGetSelectedTextSizeInAcadUnits (const AcDbOle2Frame *pOleEnt, double &sizeInZcadUnits)
Acad::ErrorStatus | acdbOleHitTest (const AcDbOle2Frame *pOleEnt, const AcGePoint3d &wvpt, const AcGeVector3d &wvwdir)
Acad::ErrorStatus | acdbOleSetOriginalSelectedFontName (const AcDbOle2Frame *pOleEnt, const ACHAR *fontName)
Acad::ErrorStatus | acdbOleSetOriginalSelectedFontPointSize (const AcDbOle2Frame *pOleEnt, const int pointSize)
Acad::ErrorStatus | acdbOleSetOriginalSelectedTextSizeInAcadUnits (const AcDbOle2Frame *pOleEnt, const double sizeInZcadUnits)
Acad::ErrorStatus | acdbOleSetOriginalWidthHeight (const AcDbOle2Frame *pOleEnt, const double width, const double height)
Acad::ErrorStatus | acdbOleSetSelectedFontName (const AcDbOle2Frame *pOleEnt, const ACHAR *fontName)
Acad::ErrorStatus | acdbOleSetSelectedFontPointSize (const AcDbOle2Frame *pOleEnt, const int pointSize)
Acad::ErrorStatus | acdbOleSetSelectedTextSizeInAcadUnits (const AcDbOle2Frame *pOleEnt, const double sizeInZcadUnits)
Acad::ErrorStatus | acdbOpenAcDbEntity (AcDbEntity *&pEnt, AcDbObjectId id, AcDb::OpenMode mode, bool openErasedEntity=false)
Acad::ErrorStatus | acdbOpenAcDbObject (AcDbObject *&pObj, AcDbObjectId id, AcDb::OpenMode mode, bool openErasedObject=false)
Acad::ErrorStatus ADESK_STDCALL | acdbOpenAcDbObject (AcDbObject *&pObj, AcDbObjectId id, AcDb::OpenMode mode, const AcRxClass *pClass, bool openErasedObject=false)
template<class T_OBJECT >
Acad::ErrorStatus | acdbOpenObject (T_OBJECT *&pObj, AcDbObjectId id, AcDb::OpenMode mode, bool openErased=false)
Acad::ErrorStatus | acdbOpenObject (AcDbObject *&pObj, AcDbObjectId id, AcDb::OpenMode mode)
Acad::ErrorStatus | acdbOpenObject (AcDbEntity *&pEnt, AcDbObjectId id, AcDb::OpenMode mode)
Acad::ErrorStatus | acdbOpenObject (AcDbObject *&pObj, AcDbObjectId id, AcDb::OpenMode mode, bool openErased)
Acad::ErrorStatus | acdbOpenObject (AcDbEntity *&pEnt, AcDbObjectId id, AcDb::OpenMode mode, bool openErased)
const ACHAR * | acdbOriginalXrefFullPathFor (const AcDbDatabase *)
Acad::ErrorStatus | acdbOverlayXref (AcDbDatabase *pHostDb, const ACHAR *pFilename, const ACHAR *pBlockName, AcDbObjectId &xrefBlkId)
AcDbObjectId | acdbPersistentReactorObjectId (void *pSomething)
Acad::ErrorStatus | acdbPostDimAssoc (AcDbObjectId dimId, AcDbDimAssoc *pDimAssoc, AcDbObjectId &dimAssocId, bool isActive=true)
int ADESK_STDCALL | acdbQueueForRegen (const AcDbObjectId *pIdArray, int nNumIds)
int | acdbRawAngToF (const ACHAR *str, int unit, ads_real *v)
int | acdbRawAngToS (ads_real v, int unit, int prec, ACHAR *str)
void * | acdbRealloc (void *, size_t)
int | acdbRegApp (const ACHAR *appname)
void | acdbReleaseHostDwg (AcDbDatabase *pHostDb)
Acad::ErrorStatus | acdbReloadXrefs (AcDbDatabase *pHostDb, const AcDbObjectIdArray &xrefBlkIds, bool bQuiet=true)
Acad::ErrorStatus | acdbRemoveFieldReactor (AcFdFieldReactor *pReactor)
Acad::ErrorStatus | acdbRenameLayout (const ACHAR *oldname, const ACHAR *newname, AcDbDatabase *pDb=NULL)
Acad::ErrorStatus | acdbResolveCurrentXRefs (AcDbDatabase *pHostDb, bool useThreadEngine=true, bool doNewOnly=false)
Acad::ErrorStatus | acdbResurrectMeNow (const AcDbObjectId &id)
int | acdbRToS (ads_real val, int unit, int prec, ACHAR *str)
Acad::ErrorStatus | acdbSaveAs2000 (AcDbDatabase *pDb, const ACHAR *fileName)
Acad::ErrorStatus | acdbSaveAs2004 (AcDbDatabase *pDb, const ACHAR *fileName)
Acad::ErrorStatus | acdbSaveAsR14 (AcDbDatabase *pDb, const ACHAR *fileName)
Acad::ErrorStatus | acdbSendInitialDwgFileOpenComplete (AcDbDatabase *pDb)
AcDbServices * | acdbServices ()
Adesk::Boolean | acdbSetAcisDwgVer (int version)
bool | acdbSetArcLengthSymbolPlacement (AcDbObject *pObj, int nValue, bool autoClearOverride=true)
Acad::ErrorStatus | acdbSetBreak3dQueueForRegen (bool)
ACDB_PORT AcDbUnderlayHost * | acdbSetCurrentDgnDocHost (AcDbUnderlayHost *pHost)
ACDB_PORT AcDbUnderlayHost * | acdbSetCurrentDgnHost (AcDbUnderlayHost *pHost)
ACDB_PORT AcDbUnderlayHost * | acdbSetCurrentDwfHost (AcDbUnderlayHost *pHost)
AcGiContext * | acdbSetDefaultAcGiContext (AcGiContext *)
bool | acdbSetDimAngExtOn (AcDbObject *pObj, int dimExtFlag)
bool | acdbSetDimBreakSize (AcDbObject *pObj, double dimBreakSize, bool autoClearOverride=true)
bool | acdbSetDimExt1Linetype (AcDbObject *pObj, AcDbObjectId oidValue, bool autoClearOverride=true)
bool | acdbSetDimExt2Linetype (AcDbObject *pObj, AcDbObjectId oidValue, bool autoClearOverride=true)
bool | acdbSetDimExtensionLength (AcDbObject *pObj, double fValue, bool autoClearOverride=true)
bool | acdbSetDimFlipArrow (AcDbObject *pObj, int nValue, bool autoClearOverride=true)
bool | acdbSetDimFlipArrowWhich (AcDbObject *pObj, int nValue, bool autoClearOverride=true)
bool | acdbSetDimJogSymbolPosition (AcDbObject *pObj, int &dimJagFlag, const AcGePoint3d &pos, bool autoClearOverride=true)
bool | acdbSetDimJogSymbolSize (AcDbObject *pObj, int dimJagFlag, const double dimJagSize, bool autoClearOverride=true)
bool | acdbSetDimLineLinetype (AcDbObject *pObj, AcDbObjectId oidValue, bool autoClearOverride=true)
bool | acdbSetDimTextBackground (AcDbObject *pObj, int bgFlag, AcCmColor *pBgColor, bool autoClearOverride=true)
bool | acdbSetDimTolAlign (AcDbObject *pObj, int dimTolAlignFlag, bool autoClearOverride=true)
bool | acdbSetExemptCheckFlag (AcDbObject *pObj, int bitFlags)
Acad::ErrorStatus | acdbSetExtnames (AcDbDatabase *pDb, bool value)
bool | acdbSetFixedLengthExtLineEnabled (AcDbObject *pObj, int nValue, bool autoClearOverride=true)
Acad::ErrorStatus | acdbSetHostApplicationServices (AcDbHostApplicationServices *pServices)
bool | acdbSetLargeRadDimJogAngle (AcDbObject *pObj, double fJogAngle, bool autoClearOverride=true)
bool | acdbSetRadialExtensionAngles (AcDbObject *pObj, int dimExtFlag, double dimExtAng1, double dimExtAng2)
Acad::ErrorStatus | acdbSetReferenced (AcDbObjectId objId)
Acad::ErrorStatus | acdbSetViewportVisualStyle (AcDbObjectId visualStyleId)
int | acdbSNValid (const ACHAR *tbstr, int pipetest)
AcDbSummaryInfoManager
*ADESK_STDCALL 		acdbSummaryInfoManager ()
const AcDbSymUtilServices * | acdbSymUtil ()
bool | acdbSystemRangeToCanonical (int eUnits, const AcString &strIn, AcString &strOut)
struct resbuf * | acdbTblNext (const ACHAR *tblname, int rewind)
int | acdbTblObjName (const ACHAR *tblname, const ACHAR *sym, ads_name result)
struct resbuf * | acdbTblSearch (const ACHAR *tblname, const ACHAR *sym, int setnext)
bool | acdbTextFind (AcDbDatabase *pDatabase, AcDbObjectIdArray &resultSet, const ACHAR *findString, const ACHAR *replaceString=NULL, Adesk::UInt8 searchOptions=AC_SRCH_DEFAULT, const AcDbObjectIdArray &selSet=0)
AcDbTransactionManager * | acdbTransactionManagerPtr ()
void | acdbTriggerAcadOctTreeReclassification ()
bool | acdbUcs2Ecs (ads_point p, ads_point q, ads_point norm, bool vec)
bool | acdbUcs2Wcs (ads_point p, ads_point q, bool vec)
bool | acdbUcsMatrix (AcGeMatrix3d &mat, AcDbDatabase *pDb=NULL)
Acad::ErrorStatus | acdbUnloadXrefs (AcDbDatabase *pHostDb, const AcDbObjectIdArray &xrefBlkIds, const bool bQuiet=true)
Acad::ErrorStatus | acdbUpdateAllDimensions (AcDbDatabase *pDb)
Acad::ErrorStatus | acdbUpdateDimension (AcDbObjectId dimId)
Acad::ErrorStatus | acdbValidateSetup (long lcid)
bool | acdbWcs2Ecs (ads_point p, ads_point q, ads_point norm, bool vec)
bool | acdbWcs2Ucs (ads_point p, ads_point q, bool vec)
Acad::ErrorStatus | acdbXBindXrefs (AcDbDatabase *pHostDb, const AcDbObjectIdArray xrefSymbolIds, const bool bInsertBind, const bool bQuiet=true)
int | acdbXdRoom (const ads_name ent, long *result)
int | acdbXdSize (const struct resbuf *rb, long *result)
const ACHAR * | acdbXlateReservedString (const ACHAR *strSource, bool bGetLocalized=true)
int | acdbXStrCase (ACHAR *str)
ACHAR * | acdbXStrSave (ACHAR *pSource, ACHAR **pDest)
AcApDocManager * | acDocManagerPtr ()
AcDbObjectId | acedActiveViewportId ()
Adesk::Boolean | acedAddDefaultContextMenu (AcEdUIContext *pContext, const void *appId, const ACHAR *appName=NULL)
BOOL | acedAddDropTarget (COleDropTarget *pTarget)
Adesk::Boolean | acedAddObjectContextMenu (const AcRxClass *pClass, AcEdUIContext *pContext, const void *appId)
int | acedAlert (const ACHAR *str)
int | acedArxLoad (const ACHAR *app)
struct resbuf * | acedArxLoaded (void)
int | acedArxUnload (const ACHAR *app)
Adesk::Boolean | acedClearOLELock (int handle)
int | acedCmd (const struct resbuf *rbp)
int | acedCmdLookup (const ACHAR *cmdStr, int globalLookup, AcEdCommandStruc *retStruc, int skipUndef=FALSE)
int | acedCmdLookup2 (const ACHAR *cmdStr, int globalLookup, AcEdCommandStruc *retStruc, int sf=ACRX_CMD_DEFUN)
int | acedCmdUndefine (const ACHAR *cmdStr, int undefIt)
int | acedCommand (int rtype,...)
Acad::ErrorStatus | acedConvertEntityToHatch (AcDbHatch *pHatch, AcDbEntity *&pEnt, bool transferId)
void | acedCoordFromPixelToWorld (const CPoint &ptIn, acedDwgPoint ptOut)
BOOL | acedCoordFromPixelToWorld (int windnum, CPoint ptIn, acedDwgPoint ptOut)
BOOL | acedCoordFromWorldToPixel (int windnum, const acedDwgPoint ptIn, CPoint &ptOut)
Acad::ErrorStatus | acedCreateEnhancedViewportOnDrop (const ACHAR *filename, const ACHAR *viewName, const AcGePoint2d location, double scale, AcDbObjectId labelBlockId, AcDbObjectId &sheetViewId, AcDbObjectId &viewportId)
Acad::ErrorStatus | acedCreateEnhancedViewportOnDropDWG (const ACHAR *filename, AcDbExtents *extents, const AcGePoint2d location, double scale, AcDbObjectId labelBlockId, AcDbObjectId &sheetViewId, AcDbObjectId &viewportId)
Adesk::Boolean | acedCreateInternetShortcut (const ACHAR *szURL, const ACHAR *szShortcutPath)
Adesk::Boolean | acedCreateShortcut (void *pvHwndParent, const ACHAR *szLinkPath, const ACHAR *szObjectPath, const ACHAR *szDesc)
Acad::ErrorStatus | acedCreateViewportByView (AcDbDatabase *pDb, const AcDbObjectId &view, const AcGePoint2d &location, double scale, AcDbObjectId &viewportId)
int | acedDefun (const ACHAR *sname, short funcno)
void | acedDisableDefaultARXExceptionHandler (Adesk::Boolean disable=Adesk::kTrue)
int | acedDragGen (const ads_name ss, const ACHAR *pmt, int cursor, int(*scnf)(ads_point pt, ads_matrix mt), ads_point p)
BOOL | acedDrawingStatusBarsVisible ()
Acad::ErrorStatus | acedDrawOrderInherit (AcDbObjectId parent, AcDbObjectIdArray &childArray, AcEdDrawOrderCmdType cmd)
int | acedEatCommandThroat (void)
int | acedEditMTextInteractive (AcDbMText *pMText, bool useNewUI=false, bool allowTabs=false)
void | acedEditToleranceInteractive (AcDbFcf *pTol)
BOOL | acedEndOverrideDropTarget (COleDropTarget *pTarget)
int | acedEntSel (const ACHAR *str, ads_name entres, ads_point ptres)
int | acedFindFile (const ACHAR *fname, ACHAR *result)
int | acedFNSplit (const ACHAR *pathToSplit, ACHAR *prebuf, ACHAR *namebuf, ACHAR *extbuf)
CDocument * | acedGetAcadDoc ()
CWnd * | acedGetAcadDockCmdLine ()
CView * | acedGetAcadDwgView ()
CMDIFrameWnd * | acedGetAcadFrame ()
HINSTANCE | acedGetAcadResourceInstance ()
CWnd * | acedGetAcadTextCmdLine ()
CWinApp * | acedGetAcadWinApp ()
int | acedGetAngle (const ads_point pt, const ACHAR *prompt, ads_real *result)
AcApStatusBar * | acedGetApplicationStatusBar ()
ACHAR * | acedGetAppName ()
struct resbuf * | acedGetArgs (void)
int | acedGetCfg (const ACHAR *sym, ACHAR *var, int len)
BOOL | acedGetChildFrameSettings (AcChildFrmSettings *pChildFrmSettings, CMDIChildWnd *pWnd)
LPCTSTR | acedGetCMBaseAlias (AcadContextMenuMode mode)
int | acedGetCName (const ACHAR *cmd, ACHAR **result)
Acad::ErrorStatus | acedGetCommandForDocument (AcApDocument *pDoc, ACHAR *&pGlobalCmdName)
int | acedGetCorner (const ads_point pt, const ACHAR *prompt, ads_point result)
BOOL | acedGetCurrentColors (AcColorSettings *pColorSettings)
BOOL | acedGetCurrentColorsEx (AcColorSettings *pColorSettings, AcColorSettingsEx *pColorSettingsEx)
Acad::ErrorStatus | acedGetCurrentSelectionSet (AcDbObjectIdArray &sset)
Acad::ErrorStatus | acedGetCurrentUCS (AcGeMatrix3d &mat)
AcDbObjectId | acedGetCurViewportObjectId ()
int | acedGetDist (const ads_point pt, const ACHAR *prompt, ads_real *result)
int | acedGetEnv (const ACHAR *sym, ACHAR *var)
int | acedGetFileD (const ACHAR *title, const ACHAR *defawlt, const ACHAR *ext, int flags, struct resbuf *result)
int | acedGetFileNavDialog (const ACHAR *title, const ACHAR *defawlt, const ACHAR *ext, const ACHAR *dlgname, int flags, struct resbuf **result)
int | acedGetFullInput (ACHAR *&pStr)
int | acedGetFullKword (const ACHAR *pString, ACHAR *&pStr)
int | acedGetFullString (int cronly, const ACHAR *pString, ACHAR *&pResult)
Acad::ErrorStatus | acedGetFullSubentPathsForCurrentSelection (const AcDbObjectId &selectedObject, AcDbFullSubentPathArray &selectedSubentities)
int | acedGetFunCode (void)
IDispatch * | acedGetIDispatch (BOOL bAddRef)
int | acedGetInput (ACHAR *str)
int | acedGetInt (const ACHAR *prompt, int *result)
BOOL | acedGetIUnknownForCurrentCommand (LPUNKNOWN &pUnk)
int | acedGetKword (const ACHAR *prompt, ACHAR *result)
HMENU | acedGetMenu (LPCTSTR pszAlias)
int | acedGetOrient (const ads_point pt, const ACHAR *prompt, ads_real *result)
int | acedGetPoint (const ads_point pt, const ACHAR *prompt, ads_point result)
int | acedGetReal (const ACHAR *prompt, ads_real *result)
const CString & | acedGetRegistryCompany ()
unsigned long | acedGetRGB (int color)
int | acedGetString (int cronly, const ACHAR *prompt, ACHAR *result)
int | acedGetStringB (int cronly, const ACHAR *prompt, ACHAR *result, int bufsize)
int | acedGetSym (const ACHAR *sname, struct resbuf **value)
BOOL | acedGetSystemColors (AcColorSettings *pColorSettings)
BOOL | acedGetSystemColorsEx (AcColorSettings *pColorSettings, AcColorSettingsEx *pColorSettingsEx)
const AcString * | acedGetUnitsValueString (AcDb::UnitsValue units)
Adesk::Boolean | acedGetUserFavoritesDir (ACHAR *szFavoritesDir)
int | acedGetVar (const ACHAR *sym, struct resbuf *result)
int | acedGetWinNum (int ptx, int pty)
int | acedGraphScr (void)
int | acedGrDraw (const ads_point from, const ads_point to, int color, int hl)
int | acedGrRead (int track, int *type, struct resbuf *result)
int | acedGrText (int box, const ACHAR *text, int hl)
int | acedGrVecs (const struct resbuf *vlist, ads_matrix mat)
int | acedHelp (const ACHAR *szFilename, const ACHAR *szTopic, int iCmd)
Adesk::Boolean | acedInitDialog (Adesk::Boolean useDialog=Adesk::kTrue)
int | acedInitGet (int val, const ACHAR *kwl)
int | acedInvoke (const struct resbuf *args, struct resbuf **result)
int | acedIsDragging (void)
BOOL | acedIsInputPending ()
Adesk::Boolean | acedIsMenuGroupLoaded (const ACHAR *pszGroupName)
bool | acedIsUpdateDisplayPaused (void)
bool | acedLoadPartialMenu (const TCHAR *pszMenuFile)
int | acedMenuCmd (const ACHAR *str)
Acad::ErrorStatus | acedMspace ()
int | acedNEntSel (const ACHAR *str, ads_name entres, ads_point ptres, ads_point xformres[4], struct resbuf **refstkres)
int | acedNEntSelP (const ACHAR *str, ads_name entres, ads_point ptres, int pickflag, ads_matrix xformres, struct resbuf **refstkres)
int | acedNumberOfViewports ()
int | acedOsnap (const ads_point pt, const ACHAR *mode, ads_point result)
int | acedPopCommandDirectory (const ACHAR *cmdDirName)
void | acedPostCommandPrompt ()
int | acedPrompt (const ACHAR *str)
Acad::ErrorStatus | acedPspace ()
int | acedPutSym (const ACHAR *sname, struct resbuf *value)
int | acedRedraw (const ads_name ent, int mode)
int | acedRegFunc (int(*fhdl)(void), int fcode)
BOOL | acedRegisterCustomDropTarget (IDropTarget *pItarget)
BOOL | acedRegisterExtendedTab (LPCTSTR szAppName, LPCTSTR szDialogName)
BOOL | acedRegisterFilterWinMsg (const AcedFilterWinMsgFn pfn)
Acad::ErrorStatus | acedRegisterGripService (AcApDocument *pDoc, AcEdAppGripService *pSvc)
BOOL | acedRegisterOnIdleWinMsg (const AcedOnIdleMsgFn pfn)
BOOL | acedRegisterStatusBarMenuItem (AcStatusBarMenuItem *pItem, AcStatusBarMenuItem::AcStatusBarType nType)
BOOL | acedRegisterWatchWinMsg (const AcedWatchWinMsgFn pfn)
Adesk::Boolean | acedRemoveDefaultContextMenu (AcEdUIContext *pContext)
BOOL | acedRemoveDropTarget (COleDropTarget *pTarget)
BOOL | acedRemoveFilterWinMsg (const AcedFilterWinMsgFn pfn)
Acad::ErrorStatus | acedRemoveGripService (AcApDocument *pDoc, AcEdAppGripService *pSvc)
Adesk::Boolean | acedRemoveObjectContextMenu (const AcRxClass *pClass, AcEdUIContext *pContext)
BOOL | acedRemoveOnIdleWinMsg (const AcedOnIdleMsgFn pfn)
BOOL | acedRemoveWatchWinMsg (const AcedWatchWinMsgFn pfn)
Adesk::Boolean | acedResolveInternetShortcut (const ACHAR *szLinkFile, ACHAR *szUrl)
Adesk::Boolean | acedResolveShortcut (void *pvHwndParent, const ACHAR *szLinkPath, ACHAR *szObjectPath)
Acad::ErrorStatus | acedRestoreCurrentView (const AcDbObjectId &namedViewId)
Acad::ErrorStatus | acedRestorePreviousUCS ()
void | acedRestoreStatusBar ()
int | acedRetInt (int ival)
int | acedRetList (const struct resbuf *rbuf)
int | acedRetName (const ads_name aname, int type)
int | acedRetNil (void)
int | acedRetPoint (const ads_point pt)
int | acedRetReal (ads_real rval)
int | acedRetStr (const ACHAR *s)
int | acedRetT (void)
int | acedRetVal (const struct resbuf *rbuf)
int | acedRetVoid (void)
BOOL | acedRevokeCustomDropTarget ()
void | acedSendModelessOperationEnded (const ACHAR *strContext)
void | acedSendModelessOperationStart (const ACHAR *strContext)
int | acedSetCfg (const ACHAR *sym, const ACHAR *val)
BOOL | acedSetChildFrameSettings (AcChildFrmSettings *pChildFrmSettings, CMDIChildWnd *pWnd)
bool | acedSetCMBaseAlias (LPCTSTR strAlias, AcadContextMenuMode mode)
Adesk::Boolean | acedSetColorDialog (int &nColor, Adesk::Boolean bAllowMetaColor, int nCurLayerColor)
Adesk::Boolean | acedSetColorDialogTrueColor (AcCmColor &color, Adesk::Boolean bAllowMetaColor, const AcCmColor &curLayerColor, AcCm::DialogTabs tabs=(AcCm::DialogTabs)(AcCm::kACITab|AcCm::kTrueColorTab|AcCm::kColorBookTab))
Adesk::Boolean | acedSetColorDialogTrueColorWithCallback (AcCmColor &color, Adesk::Boolean bAllowMetaColor, const AcCmColor &curLayerColor, AcCm::DialogTabs tabs=(AcCm::DialogTabs)(AcCm::kACITab|AcCm::kTrueColorTab|AcCm::kColorBookTab), AcEdColorDialogCallbackFunction callback=NULL, void *pCallbackData=NULL)
Adesk::Boolean | acedSetColorPrompt (ACHAR *promptString, AcCmColor &color, Adesk::Boolean bAllowMetaColor)
BOOL | acedSetCurrentColors (AcColorSettings *pColorSettings)
BOOL | acedSetCurrentColorsEx (AcColorSettings *pColorSettings, AcColorSettingsEx *pColorSettingsEx)
Acad::ErrorStatus | acedSetCurrentUCS (const AcGeMatrix3d &mat)
Acad::ErrorStatus | acedSetCurrentView (AcDbViewTableRecord *pVwRec, AcDbViewport *pVP)
Acad::ErrorStatus | acedSetCurrentVPort (int vpnumber)
Acad::ErrorStatus | acedSetCurrentVPort (const AcDbViewport *pVp)
int | acedSetEnv (const ACHAR *sym, const ACHAR *val)
int | acedSetFunHelp (const ACHAR *pszFunctionName, const ACHAR *pszHelpfile, const ACHAR *pszTopic, int iCmd)
BOOL | acedSetIUnknownForCurrentCommand (const LPUNKNOWN)
Adesk::Boolean | acedSetOLELock (int handle, int flags=0)
BOOL | acedSetStatusBarPaneID (AcPane *pPane, AcStatusBarMenuItem::AcStatusBarType nType, int nID)
int | acedSetStatusBarProgressMeter (const ACHAR *pszLabel, int nMinPos, int nMaxPos)
int | acedSetStatusBarProgressMeterPos (int nPos)
int | acedSetVar (const ACHAR *sym, const struct resbuf *val)
int | acedSetView (const struct resbuf *view, int vport)
BOOL | acedShowDrawingStatusBars (BOOL bShow=TRUE)
int | acedSSAdd (const ads_name ename, const ads_name sname, ads_name result)
int | acedSSDel (const ads_name ename, const ads_name ss)
int | acedSSFree (const ads_name sname)
int | acedSSGet (const ACHAR *str, const void *pt1, const void *pt2, const struct resbuf *filter, ads_name ss)
int | acedSSGetFirst (struct resbuf **gset, struct resbuf **pset)
int | acedSSGetKwordCallbackPtr (struct resbuf *(**pFunc)(const ACHAR *))
int | acedSSGetOtherCallbackPtr (struct resbuf *(**pFunc)(const ACHAR *))
int | acedSSLength (const ads_name sname, long *len)
int | acedSSMemb (const ads_name ename, const ads_name ss)
int | acedSSName (const ads_name ss, long i, ads_name entres)
int | acedSSNameX (struct resbuf **rbpp, const ads_name ss, const long i)
int | acedSSNameXEx (struct resbuf **rbpp, const ads_name ss, const long i, unsigned int flags=0)
int | acedSSSetFirst (const ads_name pset, const ads_name unused)
int | acedSSSetKwordCallbackPtr (struct resbuf *(*pFunc)(const ACHAR *))
int | acedSSSetOtherCallbackPtr (struct resbuf *(*pFunc)(const ACHAR *))
int | acedSSSetSubentTypes (const AcArray< AcDb::SubentType > &types)
int | acedSSSubentAdd (const AcDbFullSubentPath &subentity, const ads_name sname, ads_name result)
int | acedSSSubentDel (const AcDbFullSubentPath &subentity, const ads_name ss)
int | acedSSSubentLength (const ads_name sname, long index, long *len)
int | acedSSSubentMemb (const AcDbFullSubentPath &subentity, const ads_name ss)
int | acedSSSubentName (const ads_name ss, long entIndex, long subentIndex, AcDbFullSubentPath &subentity)
int | acedSSSubentNameX (struct resbuf **rbpp, const ads_name ss, const long entIndex, const long subentIndex, unsigned int flags)
BOOL | acedStartOverrideDropTarget (COleDropTarget *pTarget)
Acad::ErrorStatus | acedSyncFileOpen (const ACHAR *pszFileToOpen, const wchar_t *wszPassword=NULL)
int | acedTablet (const struct resbuf *args, struct resbuf **result)
int | acedTextBox (const struct resbuf *args, ads_point pt1, ads_point pt2)
int | acedTextPage (void)
int | acedTextScr (void)
Acad::ErrorStatus | acedTraceBoundary (const AcGePoint3d &seedPoint, bool detectIslands, AcDbVoidPtrArray &resultingBoundarySet)
int | acedTrans (const ads_point pt, const struct resbuf *from, const struct resbuf *to, int disp, ads_point result)
int | acedUndef (const ACHAR *sname, short funcno)
bool | acedUnloadPartialMenu (const TCHAR *pszMenuFile)
BOOL | acedUnregisterStatusBarMenuItem (AcStatusBarMenuItem *pItem, AcStatusBarMenuItem::AcStatusBarType nType)
int | acedUpdate (int vport, ads_point p1, ads_point p2)
void | acedUpdateDisplay ()
void | acedUpdateDisplayPause (bool bEnable)
int | acedUsrBrk (void)
AcDbObjectId | acedViewportIdFromNumber (int nVpNum)
Acad::ErrorStatus | acedVPLayer (const AcDbObjectId &vpId, const AcDbObjectIdArray &layerIds, AcDb::VpFreezeOps operation)
int | acedVports (struct resbuf **vlist)
Acad::ErrorStatus | acedVports2VportTableRecords ()
Acad::ErrorStatus | acedVportTableRecords2Vports ()
int | acedXformSS (const ads_name ssname, ads_matrix genmat)
Acad::ErrorStatus | acedXrefAttach (const ACHAR *XrefPathname, const ACHAR *XrefBlockname, AcDbObjectId *pXrefBTRid=NULL, AcDbObjectId *pXrefRefid=NULL, const AcGePoint3d *pXrefInsertPt=NULL, const AcGeScale3d *pXrefScale=NULL, const double *pXrefRotateAngle=NULL, const bool bQuiet=true, AcDbDatabase *pHostDb=NULL, const wchar_t *wszPassword=NULL)
Acad::ErrorStatus | acedXrefBind (const ACHAR *XrefBlockname, const bool bInsertBind=false, const bool bQuiet=true, AcDbDatabase *pHostDb=NULL)
Acad::ErrorStatus | acedXrefCreateBlockname (const ACHAR *XrefPathname, ACHAR *&XrefBlockname)
Acad::ErrorStatus | acedXrefDetach (const ACHAR *XrefBlockname, const bool bQuiet=true, AcDbDatabase *pHostDb=NULL)
Acad::ErrorStatus | acedXrefOverlay (const ACHAR *XrefPathname, const ACHAR *XrefBlockname, AcDbObjectId *pXrefBTRid=NULL, AcDbObjectId *pXrefRefid=NULL, const AcGePoint3d *pXrefInsertPt=NULL, const AcGeScale3d *pXrefScale=NULL, const double *pXrefRotateAngle=NULL, const bool bQuiet=true, AcDbDatabase *pHostDb=NULL, const wchar_t *wszPassword=NULL)
Acad::ErrorStatus | acedXrefReload (const ACHAR *XrefBlockname, const bool bQuiet=true, AcDbDatabase *pHostDb=NULL)
Acad::ErrorStatus | acedXrefReload (const AcDbObjectIdArray &XrefBTRids, bool bQuiet=true, AcDbDatabase *pHostDb=NULL)
Acad::ErrorStatus | acedXrefResolve (AcDbDatabase *pHostDb, const bool bQuiet=true)
Acad::ErrorStatus | acedXrefUnload (const ACHAR *XrefBlockname, const bool bQuiet=true, AcDbDatabase *pHostDb=NULL)
Acad::ErrorStatus | acedXrefXBind (const AcDbObjectIdArray symbolIds, const bool bQuiet=true, AcDbDatabase *pHostDb=NULL)
ACFD_PORT BOOL | AcFdExtractData (AcDbField *pField, ACHAR *&pszSheetSetFile, ACHAR *&pszSheetSetId, ACHAR *&pszCompName, ACHAR *&pszCompId, ACHAR *&pszPropName)
ACFD_PORT BOOL | AcFdExtractData (AcDbField *pField, AcDbObjectId &objId, ACHAR *&pszPropName)
ACFD_PORT BOOL | AcFdMakeFieldCode (const AcDbObjectId &objId, AcDbEvalNodeId blockParamId, const ACHAR *pszPropOrCoectionName, AcFdEval::ObjectFieldOption nOption, const ACHAR *pszFormat, AcHyperlink *pHyperlink, ACHAR *&pszFieldCode)
ACFD_PORT BOOL | AcFdMakeFieldCode (IZcSmDatabase *pSmDb, IZcSmSheetSet *pSmSheetSet, IZcSmComponent *pSmComp, const ACHAR *pszCompName, const ACHAR *pszPropName, AcFdEval::SheetSetFieldOption nOption, const ACHAR *pszFormat, ACHAR *&pszFieldCode)
ACFD_PORT BOOL | AcFdMakeFieldCode (const AcDbObjectId &tableId, const AcDbObjectId &targetTableId, AcFdEval::ExpressionFieldOption nOption, const AcCellRangeArray &cellRanges, const ACHAR *pszFormat, AcHyperlink *pHyperlink, ACHAR *&pszFieldCode)
ACFDUI_PORT CAcFdUiFieldManager * | AcFdUiGetFieldManager (void)
ACFDUI_PORT int | AcFdUiInvokeFieldDialog (AcDbField *&pNewField, BOOL bEdit, AcDbDatabase *pDb, CWnd *pParent=NULL)
std::locale | AcFStream_curLocale ()
int | AcFStream_wideToMulti (const wchar_t *pSrc, int nSrcSize, char *pDest, int nDestSize)
bool | acgiIsValidClipBoundary (const AcGePoint2dArray &pts)
AcGs2DViewLimitManager * | acgsCreate2DViewLimitManager (int viewportNumber)
void | acgsDestroy2DViewLimitManager (AcGs2DViewLimitManager *pLimitManager)
Adesk::Boolean | acgsDisplayImage (int viewportNumber, long originLeft, long originTop, int imageWidth, int imageHeight, void const *imageData, int hasTransparency)
Adesk::Boolean | acgsGetDisplayInfo (int &drawingWidth, int &drawingHeight, int &aspectWidth, int &aspectHeight)
AcGsManager * | acgsGetGsManager (CView *pView=NULL)
AcGsView * | acgsGetGsView (int viewportNumber, bool bCreateIfNone)
Adesk::UInt16 | acgsGetHighlightColor (void)
AcGs::LinePattern | acgsGetHighlightLinePattern (void)
Adesk::UInt16 | acgsGetHighlightLineWeight (void)
Adesk::Boolean | acgsGetLensLength (int viewportNumber, double &lensLength)
Adesk::Boolean | acgsGetOrthoViewParameters (int viewportNumber, AcDb::OrthographicView view, AcGeVector3d *pViewDir, AcGeVector3d *pUpVector)
AcGsScreenShot * | acgsGetScreenShot (int viewportNumber)
Adesk::Boolean | acgsGetViewParameters (int viewportNumber, AcGsView *pView)
Adesk::Boolean | acgsGetViewportInfo (int viewportNumber, int &left, int &bottom, int &right, int &top)
void | acgsRedrawShortTermGraphics (short minx, short miny, short maxx, short maxy)
Adesk::Boolean | acgsRemoveAnonymousGraphics (int viewportNumber)
Adesk::Boolean | acgsSetCustomUpdateMethod (acgsCustomUpdateMethod custom_update_method, void *pParm)
void | acgsSetHighlightColor (Adesk::UInt16 colorIndex)
void | acgsSetHighlightLinePattern (AcGs::LinePattern pattern)
void | acgsSetHighlightLineWeight (Adesk::UInt16 weight)
Adesk::Boolean | acgsSetLensLength (int viewportNumber, const double &lensLength)
Adesk::Boolean | acgsSetView2D (int viewportNumber)
Adesk::Boolean | acgsSetViewParameters (int viewportNumber, const AcGsView *pView, bool bRegenRequired, bool bRescaleRequired, bool bSyncRequired=false)
void | acgsSetViewportRenderFlag (int viewportNumber)
void | acgsWriteViewToUndoController (int viewportNumber)
AcLyLayerFilterManager * | aclyGetLayerFilterManager (AcDbDatabase *pDb)
ACPL_PORT
AcPlPlotProgressDialog
*__stdcall 		acplCreatePlotProgressDialog (HWND hParent, bool bPreview=false, int nSheets=1, ACPLPLTPRGHELPPROC hlpProc=NULL, bool bShowCancelSheetButton=true)
ACPL_PORT AcPlHostAppServices * | AcPlGetHostAppServices ()
ACPL_PORT
AcPlPlotConfigManager
*__stdcall 		acplPlotConfigManagerPtr ()
ACPL_PORT AcPlPlotReactorMgr
*__stdcall 		acplPlotReactorMgrPtr ()
ACPL_PORT ProcessPlotState
__stdcall 		acplProcessPlotState ()
void | acplPublishExecute (AcPlDSDData dsdDataObj, AcPlPlotConfig *pConfig, bool bShowPlotProgress)
ACPL_PORT Acad::ErrorStatus | AcPlSetHostAppServices (AcPlHostAppServices *pHostServices)
AcApProfileManager * | acProfileManagerPtr ()
bool | acReadAnsiCharFromCFile (CFile *pCFile, wchar_t &wch, AdCharFormatter *pChFmtr)
bool | acReadCIFFromCFile (CFile *pCFile, wchar_t &wch)
bool | acReadUtf16CharFromCFile (CFile *pCFile, wchar_t &wch, AdCharFormatter *pChFmtr)
bool | acReadUtf8CharFromCFile (CFile *pCFile, wchar_t &wch, AdCharFormatter *pChFmtr)
void | acrx_abort (const ACHAR *format,...)
bool ADESK_STDCALL | acrxAppIsLoaded (const ACHAR *pAppName)
bool | acrxApplicationIsLocked (const ACHAR *modulename)
void * | acrxGetServiceSymbolAddr (const ACHAR *serviceName, const ACHAR *symbol)
bool | acrxIsAppMDIAware (const ACHAR *moduleName)
bool | acrxLoadApp (const ACHAR *appname, bool asCmd=false)
void * | acrxLoadedApps ()
bool | acrxLoadModule (const ACHAR *moduleName, bool printit, bool asCmd=false)
bool | acrxLockApplication (void *appId)
const ACHAR * | acrxObjectDBXRegistryKey ()
const ACHAR * | acrxProductKey ()
unsigned long | acrxProductLCID ()
AcadApp::ErrorStatus | acrxRegisterApp (AcadApp::LoadReasons alr, const ACHAR *logicalName, bool bDwgU=false)
bool | acrxRegisterAppMDIAware (void *appId)
bool | acrxRegisterAppNotMDIAware (void *appId)
void * | acrxRegisterService (const ACHAR *serviceName)
bool | acrxServiceIsRegistered (const ACHAR *serviceName)
bool | acrxUnloadApp (const ACHAR *appName, bool asCmd=false)
bool | acrxUnloadModule (const ACHAR *moduleName, bool asCmd=false)
bool | acrxUnlockApplication (void *appId)
AcadApp::ErrorStatus | acrxUnregisterApp (const ACHAR *logicalname, bool bDwgU=false)
AcString::AcString (const CStringW &csw)
ads_real | acutAngle (const ads_point pt1, const ads_point pt2)
void | acutAssertMessage (const ACHAR *condition, const ACHAR *filename, int lineNumber, const ACHAR *status)
struct resbuf * | acutBuildList (int rtype,...)
int | acutCvUnit (ads_real value, const ACHAR *oldunit, const ACHAR *newunit, ads_real *result)
void | acutDelBuffer (void *&pBuffer)
void | acutDelBuffer (char *&pString)
void | acutDelString (char *&pString)
void | acutDelString (wchar_t *&pString)
ads_real | acutDistance (const ads_point pt1, const ads_point pt2)
int | acutIsAlNum (int c)
int | acutIsAlpha (int c)
int | acutIsCntrl (int c)
int | acutIsDigit (int c)
int | acutIsGraph (int c)
int | acutIsLower (int c)
int | acutIsPrint (int c)
int | acutIsPunct (int c)
int | acutIsSpace (int c)
int | acutIsUpper (int c)
int | acutIsXDigit (int c)
Acad::ErrorStatus | acutNewBuffer (void *&pOutput, size_t size)
Acad::ErrorStatus | acutNewBuffer (char *&pOutput, size_t size)
struct resbuf * | acutNewRb (int v)
Acad::ErrorStatus | acutNewString (ACHAR *&pOutput, int nNumChars)
Acad::ErrorStatus | acutNewString (const ACHAR *pInput, ACHAR *&pOutput)
void | acutPolar (const ads_point pt, ads_real angle, ads_real dist, ads_point ptres)
int | acutPrintf (const ACHAR *format,...)
int | acutRelRb (struct resbuf *rb)
bool | acutSplitString (size_t &numLeftBytes, const ACHAR *&pRight, const ACHAR *source, unsigned int delimiter)
int | acutSPrintf (ACHAR *buffer, const ACHAR *format,...)
int | acutToLower (int c)
int | acutToUpper (int c)
void | acutTrimWhiteSpace (ACHAR *pStr)
Acad::ErrorStatus | acutUpdString (const ACHAR *pInput, ACHAR *&pOutput)
int | acutWcMatch (const ACHAR *string, const ACHAR *pattern)
bool | acutWcMatchEx (const ACHAR *string, const ACHAR *pattern, bool ignoreCase)
size_t | acutXStrLength (const ACHAR *str)
Acad::ErrorStatus | acutXStrNormalize (ACHAR *&pStr, bool preserveCase)
Acad::ErrorStatus | acutXStrUppercase (ACHAR *&pStr)
void | acWriteWCharToCFile (wchar_t wch, CFile *pFile, unsigned nFmt, bool bUseCIF)
Acad::ErrorStatus | addSSgetFilterInputContextReactor (AcApDocument *pDoc, AcEdSSGetFilter *pFilter)
Acad::ErrorStatus | addSSgetFilterInputContextReactor (AcApDocument *pDoc, AcEdSSGetSubSelectFilter *pFilter)
int | ads_action_tile (ads_hdlg hdlg, const ACHAR *key, CLIENTFUNC tilefunc)
int | ads_add_list (const ACHAR *item)
int | ads_client_data_tile (ads_hdlg hdlg, const ACHAR *key, void *clientdata)
int | ads_dimensions_tile (ads_hdlg hdlg, const ACHAR *key, short *cx, short *cy)
int | ads_done_dialog (ads_hdlg hdlg, int status)
int | ads_done_positioned_dialog (ads_hdlg hdlg, int status, int *x_result, int *y_result)
int | ads_end_image (void)
int | ads_end_list (void)
int | ads_fill_image (short x1, short y1, short x2, short y2, short color)
int | ads_get_attr (ads_hdlg hdlg, const ACHAR *key, ACHAR *attr, ACHAR *value, int len)
int | ads_get_attr_string (ads_htile tile, ACHAR *attr, ACHAR *value, int len)
int | ads_get_tile (ads_hdlg hdlg, const ACHAR *key, ACHAR *value, int maxlen)
int | ads_load_dialog (const ACHAR *dclfile, int *dcl_id)
int | ads_mode_tile (ads_hdlg hdlg, const ACHAR *key, short mode)
int | ads_new_dialog (const ACHAR *dlgname, int dcl_id, CLIENTFUNC def_callback, ads_hdlg *hdlg)
int | ads_new_positioned_dialog (const ACHAR *dlgname, int dcl_id, CLIENTFUNC def_callback, int x, int y, ads_hdlg *hdlg)
int | ads_queueexpr (ACHAR *pchString)
int | ads_set_tile (ads_hdlg hdlg, const ACHAR *key, const ACHAR *value)
int | ads_slide_image (short x1, short y1, short x2, short y2, const ACHAR *slnam)
int | ads_start_dialog (ads_hdlg hdlg, int *status)
int | ads_start_image (ads_hdlg hdlg, const ACHAR *key)
int | ads_start_list (ads_hdlg hdlg, const ACHAR *key, short operation, short index)
int | ads_term_dialog (void)
int | ads_unload_dialog (int dcl_id)
int | ads_vector_image (short x1, short y1, short x2, short y2, short color)
int ADUI_PORT | AdUiAlertDialog (LPCTSTR captionText, LPCTSTR msg0Text, LPCTSTR button0Text, LPCTSTR button1Text, UINT defButton=0)
int ADUI_PORT | AdUiDataValidationLevel ()
void ADUI_PORT | AdUiEnableDockControlBars (BOOL bEnable, CStringArray *pToolIds=NULL)
For internal use only.
void ADUI_PORT | AdUiEnableDocking (CFrameWnd *pFrame, DWORD dwDockStyle, ADUI_LOADFN *pLoadFcn, ADUI_SAVEFN *pSaveFcn)
BOOL ADUI_PORT | AdUiFindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
ADUI_PORT CRuntimeClass * | AdUiGetRegisteredPaletteSetFloatingFrameClass (void)
CAdUiThemeManager ADUI_PORT * | AdUiGetThemeManager ()
void ADUI_PORT | AdUiHideBalloonTip (CWnd *control)
const UINT ADUI_PORT | AdUiMessage ()
ADUI_NOTIFY ADUI_PORT | AdUiNotification (WPARAM wp)
ADUI_REPLY ADUI_PORT | AdUiNotify (CWnd &w, UINT id, ADUI_NOTIFY n, DWORD_PTR lParam)
ADUI_REPLY ADUI_PORT | AdUiNotify (CWnd *w, UINT id, ADUI_NOTIFY n, DWORD_PTR lParam)
UINT ADUI_PORT | AdUiNotifyId (WPARAM wp)
BOOL ADUI_PORT | AdUiPostNotify (CWnd &w, UINT id, ADUI_NOTIFY n, DWORD_PTR lParam)
BOOL ADUI_PORT | AdUiPostNotify (CWnd *w, UINT id, ADUI_NOTIFY n, DWORD_PTR lParam)
bool ADUI_PORT | AdUiRegisterDockingTool (LPCTSTR lpszToolName, LPCTSTR lpszCommand, UINT nToolbarID)
ADUI_PORT void | AdUiRegisterFloatingFrameClassAddress (CRuntimeClass **pClass)
ADUI_PORT void | AdUiRegisterPaletteSetFloatingFrameClass (CRuntimeClass *pClass)
bool ADUI_PORT | AdUiRegisterTool (LPCTSTR lpszToolName, LPCTSTR lpszCommand, CLSID *pID)
void ADUI_PORT | AdUiSaveDockingToolPositions ()
ADUI_PORT CRuntimeClass * | AdUiSetFloatingFrameClass (CRuntimeClass *pNewClass)
BOOL ADUI_PORT | AdUiShowBalloonTip (CWnd *owner, CWnd *control, LPCTSTR text, BOOL beep)
BOOL ADUI_PORT | AdUiShowBalloonTip (CWnd *owner, CWnd *control, CRect &rect, LPCTSTR text, BOOL beep)
void ADUI_PORT | AdUiShowDockControlBars (bool bShow)
void ADUI_PORT | AdUiSubstituteShellFont (CWnd &dlg, CFont &font)
double * | asDblArray (const AcGePoint2d &pnt)
double * | asDblArray (const AcGeVector2d &vec)
double * | asDblArray (const AcGePoint3d &pnt)
double * | asDblArray (const AcGeVector3d &vec)
AcGePoint2d & | asPnt2d (const double *pnt)
AcGePoint3d & | asPnt3d (const double *pnt)
AcGeVector2d & | asVec2d (const double *vec)
AcGeVector3d & | asVec3d (const double *vec)
bool | c4ObjIdGreaterThanOrEqual (Adesk::ULongPtr lhs, Adesk::ULongPtr rhs)
bool | c4ObjIdIsEqualTo (Adesk::ULongPtr lhs, Adesk::ULongPtr rhs)
bool | c4ObjIdIsGreaterThan (Adesk::ULongPtr lhs, Adesk::ULongPtr rhs)
bool | c4ObjIdIsLessThan (Adesk::ULongPtr lhs, Adesk::ULongPtr rhs)
bool | c4ObjIdLessThanOrEqual (Adesk::ULongPtr lhs, Adesk::ULongPtr rhs)
bool | c4ObjIdNotEqualTo (Adesk::ULongPtr lhs, Adesk::ULongPtr rhs)
bool | c5ObjIdGreaterThanOrEqual (const AcDbStub *lhs, const AcDbStub *rhs)
bool | c5ObjIdIsEqualTo (const AcDbStub *lhs, const AcDbStub *rhs)
bool | c5ObjIdIsGreaterThan (const AcDbStub *lhs, const AcDbStub *rhs)
bool | c5ObjIdIsLessThan (const AcDbStub *lhs, const AcDbStub *rhs)
bool | c5ObjIdLessThanOrEqual (const AcDbStub *lhs, const AcDbStub *rhs)
bool ADUI_PORT | CanStealFocusFromDockedWindow ()
int | AcString::compare (const CStringW &csw) const
int | AcString::compareNoCase (const CStringW &csw) const
const wchar_t * | AcString::constPtr () const
CAcGradientThumbnailEngine * | createGradientThumbnailEngine ()
AcApDocument * | curDoc ()
void | delBuffer (char *&pString)
void | deleteAcDbSummaryInfoManager ()
void | delString (ACHAR *&pString)
bool | duplicateSelectionsAllowed (AcApDocument *pDoc)
Acad::ErrorStatus | fromAcDbTextStyle (AcGiTextStyle &, const AcDbObjectId &AcDbStyleId)
Acad::ErrorStatus | fromAcDbTextStyle (AcGiTextStyle &, const ACHAR *AcDbStyleName)
AdHostImageAppServices * | getAdHostImageAppServices ()
Acad::ErrorStatus SCENEDLLIMPEXP | getBackgroundDictionary (AcDbDatabase *pDb, AcDbDictionary *&pDict, AcDb::OpenMode mode, bool createIfNonExist)
Acad::ErrorStatus SCENEDLLIMPEXP | getBackgroundDictionary (AcDbDatabase *pDb, AcDbDictionary *&pDict, AcDb::OpenMode mode)
void ADUI_PORT | GetSystemVirtualScreen (RECT &rect)
Acad::ErrorStatus | getTableStyleNameFromDbById (const AcDbObjectId &objId, ACHAR *&pName)
void | initAcDbSummaryInfoManager ()
void ADUI_PORT | InitAdUiDLL ()
const ACHAR * | AcString::kACharPtr () const
const wchar_t * | AcString::kTCharPtr () const
int | AcString::match (const CStringW &csw) const
int | AcString::matchNoCase (const CStringW &csw) const
AcString | AcString::mid (int nStart, int nNumChars) const
Acad::ErrorStatus | newBuffer (char *&pOutput, size_t size)
Acad::ErrorStatus | newString (const ACHAR *pInput, ACHAR *&pOutput)
Acad::ErrorStatus | newString (ACHAR *&pOutput, int nNumChars)
AcString::operator const char * () const
AcString::operator const wchar_t * () const
bool | AcString::operator!= (wchar_t wch) const
bool | AcString::operator!= (const char *psz) const
bool | AcString::operator!= (const wchar_t *pwsz) const
bool | AcString::operator!= (const AcString &acs) const
bool | AcString::operator!= (const CStringW &) const
bool | operator!= (wchar_t wch, const AcString &acs)
bool | operator!= (const char *psz, const AcString &acs)
bool | operator!= (const wchar_t *pwsz, const AcString &acs)
bool | operator!= (const CStringW &csw, const AcString &acs)
AcString | AcString::operator+ (char ch) const
AcString | AcString::operator+ (wchar_t wch) const
AcString | AcString::operator+ (const char *psz) const
AcString | AcString::operator+ (const wchar_t *pwsz) const
AcString | AcString::operator+ (const AcString &acs) const
AcString | operator+ (wchar_t wch, const AcString &acs)
AcString | operator+ (const char *psz, const AcString &acs)
AcString | operator+ (const wchar_t *pwsz, const AcString &acs)
AcString & | AcString::operator+= (char ch)
AcString & | AcString::operator+= (wchar_t wch)
AcString & | AcString::operator+= (const char *psz)
AcString & | AcString::operator+= (const wchar_t *pwsz)
AcString & | AcString::operator+= (const AcString &acs)
AcString & | AcString::operator+= (const CStringW &csw)
bool | AcString::operator< (wchar_t wch) const
bool | AcString::operator< (const char *psz) const
bool | AcString::operator< (const wchar_t *pwsz) const
bool | AcString::operator< (const AcString &acs) const
bool | AcString::operator< (const CStringW &) const
bool | operator< (wchar_t wch, const AcString &acs)
bool | operator< (const char *psz, const AcString &acs)
bool | operator< (const wchar_t *pwsz, const AcString &acs)
bool | operator< (const CStringW &csw, const AcString &acs)
bool | AcString::operator<= (const wchar_t wch) const
bool | AcString::operator<= (const char *psz) const
bool | AcString::operator<= (const wchar_t *pwsz) const
bool | AcString::operator<= (const AcString &acs) const
bool | AcString::operator<= (const CStringW &) const
bool | operator<= (wchar_t wch, const AcString &acs)
bool | operator<= (const char *psz, const AcString &acs)
bool | operator<= (const wchar_t *pwsz, const AcString &acs)
bool | operator<= (const CStringW &csw, const AcString &acs)
AcString & | AcString::operator= (char ch)
AcString & | AcString::operator= (wchar_t wch)
AcString & | AcString::operator= (const char *psz)
AcString & | AcString::operator= (const wchar_t *pwsz)
AcString & | AcString::operator= (const AcString &acs)
AcString & | AcString::operator= (const AcDbHandle &h)
AcString & | AcString::operator= (const CStringW &csw)
bool | AcString::operator== (wchar_t wch) const
bool | AcString::operator== (const char *psz) const
bool | AcString::operator== (const wchar_t *pwsz) const
bool | AcString::operator== (const AcString &acs) const
bool | AcString::operator== (const CStringW &) const
bool | operator== (wchar_t wch, const AcString &acs)
bool | operator== (const char *psz, const AcString &acs)
bool | operator== (const wchar_t *pwsz, const AcString &acs)
bool | operator== (const CStringW &csw, const AcString &acs)
bool | AcString::operator> (wchar_t wch) const
bool | AcString::operator> (const char *psz) const
bool | AcString::operator> (const wchar_t *pwsz) const
bool | AcString::operator> (const AcString &acs) const
bool | AcString::operator> (const CStringW &) const
bool | operator> (wchar_t wch, const AcString &acs)
bool | operator> (const char *psz, const AcString &acs)
bool | operator> (const wchar_t *pwsz, const AcString &acs)
bool | operator> (const CStringW &csw, const AcString &acs)
bool | AcString::operator>= (wchar_t wch) const
bool | AcString::operator>= (const char *psz) const
bool | AcString::operator>= (const wchar_t *pwsz) const
bool | AcString::operator>= (const AcString &acs) const
bool | AcString::operator>= (const CStringW &) const
bool | operator>= (wchar_t wch, const AcString &acs)
bool | operator>= (const char *psz, const AcString &acs)
bool | operator>= (const wchar_t *pwsz, const AcString &acs)
bool | operator>= (const CStringW &csw, const AcString &acs)
HRESULT AXAUTOEXP | RaiseAcAXException (REFGUID iid, HRESULT hRes, DWORD dwException,...)
HRESULT AXAUTOEXP | RaiseArxException (REFGUID iid, HRESULT hRes, Acad::ErrorStatus es)
Acad::ErrorStatus | removeSSgetFilterInputContextReactor (AcApDocument *pDoc, AcEdSSGetFilter *pFilter)
Acad::ErrorStatus | removeSSgetFilterInputContextReactor (AcApDocument *pDoc, AcEdSSGetSubSelectFilter *pFilter)
Acad::ErrorStatus | setAllowDuplicateSelection (AcApDocument *pDoc, boolean flag)
virtual Acad::ErrorStatus | setDimarcsym (int v)
virtual Acad::ErrorStatus | setDimfxlen (double v)
virtual Acad::ErrorStatus | setDimfxlenOn (bool v)
virtual Acad::ErrorStatus | setDimjogang (double v)
virtual Acad::ErrorStatus | setDimltex1 (AcDbObjectId v)
virtual Acad::ErrorStatus | setDimltex2 (AcDbObjectId v)
virtual Acad::ErrorStatus | setDimltype (AcDbObjectId v)
virtual Acad::ErrorStatus | setDimtfill (int v)
virtual Acad::ErrorStatus | setDimtfillclr (const AcCmColor &v)
unsigned | AcString::tcharLength () const
Acad::ErrorStatus | toAcDbTextStyle (AcGiTextStyle &)
Acad::ErrorStatus | toAcDbTextStyle (AcGiTextStyle &, AcDbObjectId &AcDbStyleId)
Acad::ErrorStatus | toAcDbTextStyle (const AcDbObjectId AcDbStyleId, AcGiTextStyle &)
Acad::ErrorStatus | toAcDbTextStyle (AcGiTextStyle &, const ACHAR *AcDbStyleName)
Acad::ErrorStatus | toAcDbTextStyle (AcGiTextStyle &, const ACHAR *AcDbStyleName, AcDbObjectId &AcDbStyleId)
void | ucsNormalVector (AcGeVector3d &ucsNormalVec)
AcGeVector3d ucsXDir ()
AcGeVector3d ucsYDir ()
Acad::ErrorStatus | updString (const ACHAR *pInput, ACHAR *&pOutput)

Detailed Description

Function Documentation

HRESULT AXAUTOEXP AcAxEnableShadowDisplay | ( | AcDbObjectId & | objId,
 |  | bool * | pEnabled
 | ) |  |
Warning
Not implemented!
HRESULT AXAUTOEXP AcAxEnableShadowDisplay | ( | AcAxObjectRef & | objRef,
 |  | bool * | pEnabled
 | ) |  |
Warning
Not implemented!
HRESULT AXAUTOEXP AcAxGetMaterial | ( | AcDbObjectId & | objId,
 |  | BSTR * | pMaterial
 | ) |  |
Warning
Not implemented!
HRESULT AXAUTOEXP AcAxGetMaterial | ( | AcAxObjectRef & | objRef,
 |  | BSTR * | pMaterial
 | ) |  |
Warning
Not implemented!
HRESULT AXAUTOEXP AcAxGetShadowDisplay | ( | AcDbObjectId & | objId,
 |  | AcShadowDisplayType * | pShadowDisplay
 | ) |  |
Warning
Not implemented!
HRESULT AXAUTOEXP AcAxGetShadowDisplay | ( | AcAxObjectRef & | objRef,
 |  | AcShadowDisplayType * | pShadowDisplay
 | ) |  |
Warning
Not implemented!
HRESULT AXAUTOEXP AcAxPutMaterial | ( | AcDbObjectId & | objId,
 |  | BSTR | material
 | ) |  |
Warning
Not implemented!
HRESULT AXAUTOEXP AcAxPutMaterial | ( | AcAxObjectRef & | objRef,
 |  | BSTR | material
 | ) |  |
Warning
Not implemented!
HRESULT AXAUTOEXP AcAxPutShadowDisplay | ( | AcDbObjectId & | objId,
 |  | AcShadowDisplayType | shadowDisplay
 | ) |  |
Warning
Not implemented!
HRESULT AXAUTOEXP AcAxPutShadowDisplay | ( | AcAxObjectRef & | objRef,
 |  | AcShadowDisplayType | shadowDisplay
 | ) |  |
Warning
Not implemented!
void acByteSwap ( wchar_t & wch )
inline
Warning
Not implemented!
Acad::ErrorStatus acdbBindXrefs | ( | AcDbDatabase * | pHostDb,
 |  | const AcDbObjectIdArray & | xrefBlkIds,
 |  | const bool | bInsertBind,
 |  | const bool | bAllowUnresolved = false,
 |  | const bool | bQuiet = true
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus acdbConvertFieldsToText | ( | AcDbDatabase * | pDb,
 |  | const AcStringArray * | pEvalIds,
 |  | AcFd::ConvertFieldToText | nOption
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus acdbConvertFieldsToText | ( | const AcDbObjectIdArray & | objIds,
 |  | const AcStringArray * | pEvalIds,
 |  | AcFd::ConvertFieldToText | nOption
 | ) |  |
Warning
Not implemented!
ACDB_PORT void acdbConvertHslToRgb | ( | const AcGeVector3d & | hsl,
 |  | AcGeVector3d & | rgb
 | ) |  |
Warning
Not implemented!
ACDB_PORT void acdbConvertRgbToHsl | ( | const AcGeVector3d & | rgb,
 |  | AcGeVector3d & | hsl
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acdbCopyLayout | ( | const ACHAR * | copyname,
 |  | const ACHAR * | newname,
 |  | AcDbDatabase * | pDb = NULL
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acdbDeleteLayout | ( | const ACHAR * | delname,
 |  | AcDbDatabase * | pDb = NULL
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acdbDxfOutAs2004 | ( | AcDbDatabase * | pDb,
 |  | const ACHAR * | fileName,
 |  | const int | precision = 16
 | ) |  |
Warning
Not implemented!
bool acdbGetArcLengthSymbolPlacement | ( | AcDbObject * | pObj,
 |  | int & | nValue
 | ) |  |
Warning
Not implemented!
ACDB_PORT AcDbUnderlayHost* acdbGetCurrentDgnDocHost ( )
Warning
Not implemented!
ACDB_PORT AcDbUnderlayHost* acdbGetCurrentDgnHost ( )
Warning
Not implemented!
ACDB_PORT AcDbUnderlayHost* acdbGetCurrentDwfHost ( )
Warning
Not implemented!
AcDbObjectId acdbGetCurVportTableRecordId ( AcDbDatabase * pDb )
Warning
Not implemented!
bool acdbGetDimBreakSize | ( | AcDbObject * | pObj,
 |  | double & | dimBreakSize
 | ) |  |
Warning
Not implemented!
bool acdbGetDimExt1Linetype | ( | AcDbObject * | pObj,
 |  | AcDbObjectId & | oidValue
 | ) |  |
Warning
Not implemented!
bool acdbGetDimExt2Linetype | ( | AcDbObject * | pObj,
 |  | AcDbObjectId & | oidValue
 | ) |  |
Warning
Not implemented!
bool acdbGetDimExtensionLength | ( | AcDbObject * | pObj,
 |  | double & | fValue
 | ) |  |
Warning
Not implemented!
bool acdbGetDimFlipArrow | ( | AcDbObject * | pObj,
 |  | int & | nValue
 | ) |  |
Warning
Not implemented!
bool acdbGetDimFlipArrowWhich | ( | AcDbObject * | pObj,
 |  | int & | nValue
 | ) |  |
Warning
Not implemented!
bool acdbGetDimJogSymbolSize | ( | AcDbObject * | pObj,
 |  | int & | dimJagFlag,
 |  | double & | dimJagSize
 | ) |  |
Warning
Not implemented!
bool acdbGetDimLineLinetype | ( | AcDbObject * | pObj,
 |  | AcDbObjectId & | oidValue
 | ) |  |
Warning
Not implemented!
bool acdbGetDimTolAlign | ( | AcDbObject * | pObj,
 |  | int & | dimTolAlignFlag
 | ) |  |
Warning
Not implemented!
bool acdbGetExemptCheckFlag | ( | AcDbObject * | pObj,
 |  | int & | bitFlags
 | ) |  |
Warning
Not implemented!
bool acdbGetFixedLengthExtLineEnabled | ( | AcDbObject * | pObj,
 |  | int & | nValue
 | ) |  |
Warning
Not implemented!
bool acdbGetLargeRadDimJogAngle | ( | AcDbObject * | pObj,
 |  | double & | fJogAngle
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus SCENEDLLIMPEXP acdbGetMotionPathDictionary | ( | AcDbDatabase * | pDb,
 |  | AcDbDictionary *& | pDict,
 |  | AcDb::OpenMode | mode,
 |  | bool | createIfNonExist
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus SCENEDLLIMPEXP acdbGetMotionPathDictionary | ( | AcDbDatabase * | pDb,
 |  | AcDbDictionary *& | pDict,
 |  | AcDb::OpenMode | mode
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus SCENEDLLIMPEXP acdbGetNamedPathDictionary | ( | AcDbDatabase * | pDb,
 |  | AcDbDictionary *& | pDict,
 |  | AcDb::OpenMode | mode,
 |  | bool | createIfNonExist
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus SCENEDLLIMPEXP acdbGetNamedPathDictionary | ( | AcDbDatabase * | pDb,
 |  | AcDbDictionary *& | pDict,
 |  | AcDb::OpenMode | mode
 | ) |  |
Warning
Not implemented!
AcDbObjectId acdbGetViewportVisualStyle ( )
Warning
Not implemented!
bool acdbIsInLongTransaction ( AcDbObjectId id )
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus acdbMakeFieldCode | ( | const ACHAR * | pszFieldExpr,
 |  | ACHAR *& | pszFieldCode
 | ) |  |
Warning
Not implemented!
ACDB_PORT Acad::ErrorStatus acdbMakeFieldCode | ( | const ACHAR * | pszFieldExpr,
 |  | ACHAR *& | pszFieldCode,
 |  | const ACHAR * | pszEvalId,
 |  | const ACHAR * | pszFormat,
 |  | const AcHyperlink * | pHyperlink
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acdbReloadXrefs | ( | AcDbDatabase * | pHostDb,
 |  | const AcDbObjectIdArray & | xrefBlkIds,
 |  | bool | bQuiet = true
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acdbRenameLayout | ( | const ACHAR * | oldname,
 |  | const ACHAR * | newname,
 |  | AcDbDatabase * | pDb = NULL
 | ) |  |
Warning
Not implemented!
bool acdbSetArcLengthSymbolPlacement | ( | AcDbObject * | pObj,
 |  | int | nValue,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acdbSetBreak3dQueueForRegen ( bool )
Warning
Not implemented!
ACDB_PORT AcDbUnderlayHost* acdbSetCurrentDgnDocHost ( AcDbUnderlayHost * pHost )
Warning
Not implemented!
ACDB_PORT AcDbUnderlayHost* acdbSetCurrentDgnHost ( AcDbUnderlayHost * pHost )
Warning
Not implemented!
ACDB_PORT AcDbUnderlayHost* acdbSetCurrentDwfHost ( AcDbUnderlayHost * pHost )
Warning
Not implemented!
bool acdbSetDimBreakSize | ( | AcDbObject * | pObj,
 |  | double | dimBreakSize,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetDimExt1Linetype | ( | AcDbObject * | pObj,
 |  | AcDbObjectId | oidValue,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetDimExt2Linetype | ( | AcDbObject * | pObj,
 |  | AcDbObjectId | oidValue,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetDimExtensionLength | ( | AcDbObject * | pObj,
 |  | double | fValue,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetDimFlipArrow | ( | AcDbObject * | pObj,
 |  | int | nValue,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetDimFlipArrowWhich | ( | AcDbObject * | pObj,
 |  | int | nValue,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetDimJogSymbolSize | ( | AcDbObject * | pObj,
 |  | int | dimJagFlag,
 |  | const double | dimJagSize,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetDimLineLinetype | ( | AcDbObject * | pObj,
 |  | AcDbObjectId | oidValue,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetDimTolAlign | ( | AcDbObject * | pObj,
 |  | int | dimTolAlignFlag,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetExemptCheckFlag | ( | AcDbObject * | pObj,
 |  | int | bitFlags
 | ) |  |
Warning
Not implemented!
bool acdbSetFixedLengthExtLineEnabled | ( | AcDbObject * | pObj,
 |  | int | nValue,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
bool acdbSetLargeRadDimJogAngle | ( | AcDbObject * | pObj,
 |  | double | fJogAngle,
 |  | bool | autoClearOverride = true
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acdbSetViewportVisualStyle ( AcDbObjectId visualStyleId )
Warning
Not implemented!
bool acdbSystemRangeToCanonical | ( | int | eUnits,
 |  | const AcString & | strIn,
 |  | AcString & | strOut
 | ) |  |
Warning
Not implemented!
void acdbTriggerAcadOctTreeReclassification ( )
Warning
Not implemented!
Acad::ErrorStatus acdbUnloadXrefs | ( | AcDbDatabase * | pHostDb,
 |  | const AcDbObjectIdArray & | xrefBlkIds,
 |  | const bool | bQuiet = true
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acdbUpdateAllDimensions ( AcDbDatabase * pDb )
Warning
Not implemented!
Acad::ErrorStatus acdbXBindXrefs | ( | AcDbDatabase * | pHostDb,
 |  | const AcDbObjectIdArray | xrefSymbolIds,
 |  | const bool | bInsertBind,
 |  | const bool | bQuiet = true
 | ) |  |
Warning
Not implemented!
int acedCmdLookup2 | ( | const ACHAR * | cmdStr,
 |  | int | globalLookup,
 |  | AcEdCommandStruc * | retStruc,
 |  | int | sf = ACRX_CMD_DEFUN
 | ) |  |
Warning
Not implemented!
Adesk::Boolean acedCreateInternetShortcut | ( | const ACHAR * | szURL,
 |  | const ACHAR * | szShortcutPath
 | ) |  |
Warning
Not implemented!
Adesk::Boolean acedCreateShortcut | ( | void * | pvHwndParent,
 |  | const ACHAR * | szLinkPath,
 |  | const ACHAR * | szObjectPath,
 |  | const ACHAR * | szDesc
 | ) |  |
Warning
Not implemented!
int acedEatCommandThroat ( void )
Warning
Not implemented!
BOOL acedGetChildFrameSettings | ( | AcChildFrmSettings * | pChildFrmSettings,
 |  | CMDIChildWnd * | pWnd
 | ) |  |
Warning
Not implemented!
BOOL acedGetCurrentColorsEx | ( | AcColorSettings * | pColorSettings,
 |  | AcColorSettingsEx * | pColorSettingsEx
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acedGetFullSubentPathsForCurrentSelection | ( | const AcDbObjectId & | selectedObject,
 |  | AcDbFullSubentPathArray & | selectedSubentities
 | ) |  |
Warning
Not implemented!
IDispatch* acedGetIDispatch ( BOOL bAddRef )
Warning
Not implemented!
HMENU acedGetMenu ( LPCTSTR pszAlias )
Warning
Not implemented!
BOOL acedGetSystemColors ( AcColorSettings * pColorSettings )
Warning
Not implemented!
BOOL acedGetSystemColorsEx | ( | AcColorSettings * | pColorSettings,
 |  | AcColorSettingsEx * | pColorSettingsEx
 | ) |  |
Warning
Not implemented!
Adesk::Boolean acedGetUserFavoritesDir ( ACHAR * szFavoritesDir )
Warning
Not implemented!
int acedNumberOfViewports ( )
Warning
Not implemented!
Acad::ErrorStatus acedRegisterGripService | ( | AcApDocument * | pDoc,
 |  | AcEdAppGripService * | pSvc
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acedRemoveGripService | ( | AcApDocument * | pDoc,
 |  | AcEdAppGripService * | pSvc
 | ) |  |
Warning
Not implemented!
Adesk::Boolean acedResolveInternetShortcut | ( | const ACHAR * | szLinkFile,
 |  | ACHAR * | szUrl
 | ) |  |
Warning
Not implemented!
Adesk::Boolean acedResolveShortcut | ( | void * | pvHwndParent,
 |  | const ACHAR * | szLinkPath,
 |  | ACHAR * | szObjectPath
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus acedRestoreCurrentView ( const AcDbObjectId & namedViewId )
Warning
Not implemented!
BOOL acedSetChildFrameSettings | ( | AcChildFrmSettings * | pChildFrmSettings,
 |  | CMDIChildWnd * | pWnd
 | ) |  |
Warning
Not implemented!
Adesk::Boolean acedSetColorDialogTrueColorWithCallback | ( | AcCmColor & | color,
 |  | Adesk::Boolean | bAllowMetaColor,
 |  | const AcCmColor & | curLayerColor,
 |  | AcCm::DialogTabs | tabs = (AcCm::DialogTabs)(AcCm::kACITab|AcCm::kTrueColorTab|AcCm::kColorBookTab),
 |  | AcEdColorDialogCallbackFunction | callback = NULL,
 |  | void * | pCallbackData = NULL
 | ) |  |
Warning
Not implemented!
BOOL acedSetCurrentColorsEx | ( | AcColorSettings * | pColorSettings,
 |  | AcColorSettingsEx * | pColorSettingsEx
 | ) |  |
Warning
Not implemented!
int acedSSSetSubentTypes ( const AcArray< AcDb::SubentType > & types )
Warning
Not implemented!
int acedSSSubentAdd | ( | const AcDbFullSubentPath & | subentity,
 |  | const ads_name | sname,
 |  | ads_name | result
 | ) |  |
Warning
Not implemented!
int acedSSSubentDel | ( | const AcDbFullSubentPath & | subentity,
 |  | const ads_name | ss
 | ) |  |
Warning
Not implemented!
int acedSSSubentLength | ( | const ads_name | sname,
 |  | long | index,
 |  | long * | len
 | ) |  |
Warning
Not implemented!
int acedSSSubentMemb | ( | const AcDbFullSubentPath & | subentity,
 |  | const ads_name | ss
 | ) |  |
Warning
Not implemented!
int acedSSSubentName | ( | const ads_name | ss,
 |  | long | entIndex,
 |  | long | subentIndex,
 |  | AcDbFullSubentPath & | subentity
 | ) |  |
Warning
Not implemented!
int acedSSSubentNameX | ( | struct resbuf ** | rbpp,
 |  | const ads_name | ss,
 |  | const long | entIndex,
 |  | const long | subentIndex,
 |  | unsigned int | flags
 | ) |  |
Warning
Not implemented!
AcDbObjectId acedViewportIdFromNumber ( int nVpNum )
Warning
Not implemented!
ACFD_PORT BOOL AcFdExtractData | ( | AcDbField * | pField,
 |  | ACHAR *& | pszSheetSetFile,
 |  | ACHAR *& | pszSheetSetId,
 |  | ACHAR *& | pszCompName,
 |  | ACHAR *& | pszCompId,
 |  | ACHAR *& | pszPropName
 | ) |  |
Warning
Not implemented!
ACFD_PORT BOOL AcFdExtractData | ( | AcDbField * | pField,
 |  | AcDbObjectId & | objId,
 |  | ACHAR *& | pszPropName
 | ) |  |
Warning
Not implemented!
ACFD_PORT BOOL AcFdMakeFieldCode | ( | const AcDbObjectId & | objId,
 |  | AcDbEvalNodeId | blockParamId,
 |  | const ACHAR * | pszPropOrCoectionName,
 |  | AcFdEval::ObjectFieldOption | nOption,
 |  | const ACHAR * | pszFormat,
 |  | AcHyperlink * | pHyperlink,
 |  | ACHAR *& | pszFieldCode
 | ) |  |
Warning
Not implemented!
ACFD_PORT BOOL AcFdMakeFieldCode | ( | IZcSmDatabase * | pSmDb,
 |  | IZcSmSheetSet * | pSmSheetSet,
 |  | IZcSmComponent * | pSmComp,
 |  | const ACHAR * | pszCompName,
 |  | const ACHAR * | pszPropName,
 |  | AcFdEval::SheetSetFieldOption | nOption,
 |  | const ACHAR * | pszFormat,
 |  | ACHAR *& | pszFieldCode
 | ) |  |
Warning
Not implemented!
ACFD_PORT BOOL AcFdMakeFieldCode | ( | const AcDbObjectId & | tableId,
 |  | const AcDbObjectId & | targetTableId,
 |  | AcFdEval::ExpressionFieldOption | nOption,
 |  | const AcCellRangeArray & | cellRanges,
 |  | const ACHAR * | pszFormat,
 |  | AcHyperlink * | pHyperlink,
 |  | ACHAR *& | pszFieldCode
 | ) |  |
Warning
Not implemented!
ACFDUI_PORT CAcFdUiFieldManager* AcFdUiGetFieldManager ( void )
Warning
Not implemented!
bool acgiIsValidClipBoundary ( const AcGePoint2dArray & pts )
Warning
Not implemented!
Adesk::Boolean acgsDisplayImage | ( | int | viewportNumber,
 |  | long | originLeft,
 |  | long | originTop,
 |  | int | imageWidth,
 |  | int | imageHeight,
 |  | void const * | imageData,
 |  | int | hasTransparency
 | ) |  |
Warning
Not implemented!
Adesk::Boolean acgsGetDisplayInfo | ( | int & | drawingWidth,
 |  | int & | drawingHeight,
 |  | int & | aspectWidth,
 |  | int & | aspectHeight
 | ) |  |
Warning
Not implemented!
bool acReadAnsiCharFromCFile | ( | CFile * | pCFile,
 |  | wchar_t & | wch,
 |  | AdCharFormatter * | pChFmtr
 | ) |  |
inline
Warning
Not implemented!
bool acReadCIFFromCFile | ( | CFile * | pCFile,
 |  | wchar_t & | wch
 | ) |  |
inline
Warning
Not implemented!
bool acReadUtf16CharFromCFile | ( | CFile * | pCFile,
 |  | wchar_t & | wch,
 |  | AdCharFormatter * | pChFmtr
 | ) |  |
inline
Warning
Not implemented!
bool acReadUtf8CharFromCFile | ( | CFile * | pCFile,
 |  | wchar_t & | wch,
 |  | AdCharFormatter * | pChFmtr
 | ) |  |
inline
Warning
Not implemented!
bool acrxApplicationIsLocked ( const ACHAR * modulename )
Warning
Not implemented!
bool acrxIsAppMDIAware ( const ACHAR * moduleName )
Warning
Not implemented!
void acWriteWCharToCFile | ( | wchar_t | wch,
 |  | CFile * | pFile,
 |  | unsigned | nFmt,
 |  | bool | bUseCIF
 | ) |  |
Warning
Not implemented!
void ADUI_PORT AdUiEnableDockControlBars | ( | BOOL | bEnable,
 |  | CStringArray * | pToolIds = NULL
 | ) |  |

For internal use only.

const wchar_t * AcString::constPtr ( ) const
inline
Warning
Not implemented!
void deleteAcDbSummaryInfoManager ( )
inline
Warning
Not implemented!
AdHostImageAppServices* getAdHostImageAppServices ( )
Warning
Not implemented!
Acad::ErrorStatus SCENEDLLIMPEXP getBackgroundDictionary | ( | AcDbDatabase * | pDb,
 |  | AcDbDictionary *& | pDict,
 |  | AcDb::OpenMode | mode,
 |  | bool | createIfNonExist
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus SCENEDLLIMPEXP getBackgroundDictionary | ( | AcDbDatabase * | pDb,
 |  | AcDbDictionary *& | pDict,
 |  | AcDb::OpenMode | mode
 | ) |  |
Warning
Not implemented!
Acad::ErrorStatus getTableStyleNameFromDbById | ( | const AcDbObjectId & | objId,
 |  | ACHAR *& | pName
 | ) |  |
Warning
Not implemented!
void initAcDbSummaryInfoManager ( )
inline
Warning
Not implemented!
bool operator!= | ( | wchar_t | wch,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator!= | ( | const CStringW & | csw,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
AcString operator+ | ( | wchar_t | wch,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
AcString operator+ | ( | const wchar_t * | pwsz,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator< | ( | wchar_t | wch,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator< | ( | const wchar_t * | pwsz,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator< | ( | const CStringW & | csw,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator<= | ( | wchar_t | wch,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator<= | ( | const wchar_t * | pwsz,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator<= | ( | const CStringW & | csw,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator== | ( | wchar_t | wch,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator== | ( | const wchar_t * | pwsz,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator== | ( | const CStringW & | csw,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator> | ( | wchar_t | wch,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator> | ( | const wchar_t * | pwsz,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator> | ( | const CStringW & | csw,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator>= | ( | wchar_t | wch,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator>= | ( | const wchar_t * | pwsz,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
bool operator>= | ( | const CStringW & | csw,
 |  | const AcString & | acs
 | ) |  |
inline
Warning
Not implemented!
Acad::ErrorStatus removeSSgetFilterInputContextReactor | ( | AcApDocument * | pDoc,
 |  | AcEdSSGetFilter * | pFilter
 | ) |  |
Warning
Not implemented!
void ucsNormalVector ( AcGeVector3d & ucsNormalVec )
Warning
Not implemented!
AcGeVector3d ucsXDir ( )
Warning
Not implemented!
AcGeVector3d ucsYDir ( )
Warning
Not implemented!


ZRX API Reference: Macros Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Macros
Macros Classes

Macros

#define | GET_OPM_COMMAND_PROPERTY_MANAGER(pCommandName) GET_OPMEXTENSION_CREATE_PROTOCOL()->CreateOPMCommandProtocol(pCommandName)->GetPropertyManager()
#define | GET_OPMEXTENSION_CREATE_PROTOCOL() OPMPropertyExtensionFactory::cast(AcDbDatabase::desc()->queryX(OPMPropertyExtensionFactory::desc()))
#define | GET_OPMPROPERTY_MANAGER(pAcRxClass) GET_OPMEXTENSION_CREATE_PROTOCOL()->CreateOPMObjectProtocol(pAcRxClass)->GetPropertyManager()

Detailed Description


ZRX API Reference: MFC Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Macros | Enumerations | Functions | Variables
MFC Classes

Classes

class | CAcExtensionModule
class | CAcModuleResourceOverride
class | CAcUiAngleComboBox
class | CAcUiAngleEdit
class | CAcUiArrowHeadComboBox
class | CAcUiBitmapButton
class | CAcUiBitmapStatic
class | CAcUiColorComboBox
class | CAcUiComboBox
class | CAcUiDialog
class | CAcUiDialogBar
class | CAcUiDialogWorksheet
class | CAcUiDockControlBar
class | CAcUiDockFrame
class | CAcUiDropSite
class | CAcUiEdit
class | CAcUiFileDialog
class | CAcUiLineTypeComboBox
class | CAcUiLineWeightComboBox
class | CAcUiLTypeRecord
class | CAcUiMRUComboBox
class | CAcUiMRUListBox
class | CAcUiNavDialog
class | CAcUiNumericComboBox
class | CAcUiNumericEdit
class | CAcUiOwnerDrawButton
class | CAcUiPaletteSetDockFrame
class | CAcUiPathname
class | CAcUiPickButton
class | CAcUiPlotStyleNamesComboBox
class | CAcUiPlotStyleTablesComboBox
class | CAcUiPredefBlockComboBox
class | CAcUiSelectButton
class | CAcUiString
class | CAcUiStringComboBox
class | CAcUiStringEdit
class | CAcUiStringExp
class | CAcUiSymbolComboBox
class | CAcUiSymbolEdit
class | CAcUiTab
class | CAcUiTabChildDialog
class | CAcUiTabMainDialog
class | CAcUiToolButton
class | CAcUiTrueColorComboBox
class | CAdUiBalloonTip
class | CAdUiBaseDialog
class | CAdUiBitmapButton
class | CAdUiBitmapStatic
class | CAdUiCDFSVolumeDescriptor
class | CAdUiComboBox
class | CAdUiCoupledGroupCtrl
class | CAdUiDialog
class | CAdUiDialogBar
class | CAdUiDialogWorksheet
class | CAdUiDockControlBar
class | CAdUiDockFrame
class | CAdUiDrawTipText
class | CAdUiDropSite
class | CAdUiDropTarget
class | CAdUiEdit
class | CAdUiFATVolumeDescriptor
class | CAdUiFileDialog
class | CAdUiGroupCtrl
class | CAdUiHeaderCtrl
class | CAdUiHPFSVolumeDescriptor
class | CAdUiListBox
class | CAdUiListCtrl
class | CAdUiNOFSVolumeDescriptor
class | CAdUiNTFSVolumeDescriptor
class | CAdUiODButtonThemeModReactor
class | CAdUiOwnerDrawButton
class | CAdUiPalette
class | CAdUiPaletteSet
class | CAdUiPaletteSetDockFrame
class | CAdUiPathname
class | CAdUiRegistryAccess
class | CAdUiRegistryDeleteAccess
class | CAdUiRegistryWriteAccess
class | CAdUiTab
class | CAdUiTabChildDialog
class | CAdUiTabExtensionManager
class | CAdUiTabMainDialog
class | CAdUiTextTip
class | CAdUiTheme
class | CAdUiThemeManager
class | CAdUiThemeMgrReactor
class | CAdUiThemeModifiedReactor
class | CAdUiTipWindow
class | CAdUiToolButton
class | CAdUiTrackButton
class | CAdUiUFSVolumeDescriptor
class | CAdUiVFATVolumeDescriptor
class | CAdUiVolumeDescriptor
class | CNavArray< T >
class | CNavData
class | CNavDataArray
class | CNavDialog
class | CNavDropSource
class | CNavFilter
class | CNavFilterArray
class | CNavListCtrl

Macros

#define | AC_DECLARE_EXTENSION_MODULE(exm) extern CAcExtensionModule exm;
#define | AC_IMPLEMENT_EXTENSION_MODULE(exm)
#define | ACUI_MAX_COMBOBOX_MRU 6
#define | ACUI_MAX_TRUECOLOR_COMBOBOX_MRU 16
#define | ACUI_TRUECOLOR_COMBOBOX_TABLE_SIZE ACUI_MAX_TRUECOLOR_COMBOBOX_MRU + 9

Enumerations

enum ACUI_MRU_CARGO {
kAcUiMRUCargo_Last = -106, kAcUiMRUCargo_Option2 = -105, kAcUiMRUCargo_Option1 = -104, kAcUiMRUCargo_Other2 = -103,
kAcUiMRUCargo_Other1 = -102, kAcUiMRUCargo_None = -101
}

Functions

T * | CNavArray< T >::AddData ()
BOOL | CAcExtensionModule::Attached ()
BOOL | CAcExtensionModule::AttachInstance (HINSTANCE hInst)
CAcModuleResourceOverride::CAcModuleResourceOverride (HINSTANCE hInst)
CAdUiPathname::CAdUiPathname (const CAdUiPathname &)
CNavArray< T >::CNavArray ()
HINSTANCE | CAcExtensionModule::DefaultResourceInstance ()
void | CAcExtensionModule::DetachInstance ()
void | CAcUiLineTypeComboBox::forceSelectOther (BOOL isOther2)
int | CNavArray< T >::GetCount ()
T * | CNavArray< T >::GetData (INT_PTR index)
bool | CAcUiLineTypeComboBox::getDbReload ()
int | CAcUiLineTypeComboBox::getLastSelection ()
bool | CAdUiGroupCtrl::GetMinimized () const
AcDbObjectId | CAcUiLineTypeComboBox::getOIDCurSel ()
AcDbObjectId | CAcUiLineTypeComboBox::getOIDSel (int sel)
path_type | CAdUiPathname::GetPathType (void) const
const CAdUiVolumeDescriptor * | CAdUiPathname::GetVolumeDescriptor (void) const
BOOL | CAdUiPathname::HadPrefix (void) const
BOOL | CAcUiLTypeRecord::isDependent ()
BOOL | CAdUiPathname::IsEmpty (void) const
BOOL | CNavArray< T >::IsIndexValid (INT_PTR index)
bool | CAcUiLineTypeComboBox::isOtherSelected ()
BOOL | CAdUiPathname::IsPath (void) const
CString & | CAcUiLTypeRecord::ltypeName ()
HINSTANCE | CAcExtensionModule::ModuleResourceInstance ()
virtual T * | CNavArray< T >::NewData ()
AcDbObjectId | CAcUiLTypeRecord::objectId ()
const CAcUiPathname & | CAcUiPathname::operator= (const CAcUiPathname &pathSrc)
const CAcUiPathname & | CAcUiPathname::operator= (const CAcUiPathname *pathSrc)
const CAdUiPathname & | CAdUiPathname::operator= (const CAdUiPathname &pathSrc)
const CAdUiPathname & | CAdUiPathname::operator= (const CAdUiPathname *pathSrc)
void | CNavArray< T >::RemoveAllData ()
void | CNavArray< T >::RemoveData (INT_PTR index)
void | CAcUiLineTypeComboBox::setCurSelByOID (const AcDbObjectId &oidCurSel)
void | CAcUiLineTypeComboBox::setDbReload (bool bReload)
void | CAcUiLTypeRecord::setIsDependent (BOOL bValue)
void | CAcUiLTypeRecord::setLTypeName (CString sName)
virtual void | CAdUiGroupCtrl::SetMinimized (bool bMinimized)
void | CAcUiLTypeRecord::setObjectId (AcDbObjectId id)
BOOL | CAdUiPathname::WasAbsolute (void) const
BOOL | CAdUiPathname::WasRoot (void) const
virtual | CNavArray< T >::~CNavArray ()

Variables

class ACUI_PORT | CAcUiMRUComboBox
class ACUI_PORT | CAcUiMRUListBox

Detailed Description

Macro Definition Documentation

#define AC_IMPLEMENT_EXTENSION_MODULE ( exm )
Value:
CAcExtensionModule exm; \
CAcExtensionModule& CAcModuleResourceOverride::m_extensionModule = exm;

Function Documentation

template<class T >
T * CNavArray< T >::AddData ( )
Warning
Not implemented!
template<class T >
CNavArray< T >::CNavArray ( )
Warning
Not implemented!
template<class T >
int CNavArray< T >::GetCount ( )
Warning
Not implemented!
template<class T >
T * CNavArray< T >::GetData ( INT_PTR index )
Warning
Not implemented!
template<class T >
BOOL CNavArray< T >::IsIndexValid ( INT_PTR index )
Warning
Not implemented!
template<class T >
T * CNavArray< T >::NewData ( )
protectedvirtual
Warning
Not implemented!
template<class T >
void CNavArray< T >::RemoveAllData ( )
Warning
Not implemented!
void CAdUiGroupCtrl::SetMinimized ( bool bMinimized )
inlinevirtual
Warning
Not implemented!
template<class T >
CNavArray< T >::~CNavArray ( )
virtual
Warning
Not implemented!


ZRX API Reference: CAcExtensionModule Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
CAcExtensionModule Class Reference
MFC Classes

Public Member Functions

BOOL | Attached ()
BOOL | AttachInstance (HINSTANCE hInst)
HINSTANCE | DefaultResourceInstance ()
void | DetachInstance ()
HINSTANCE | ModuleResourceInstance ()

Protected Attributes

BOOL | m_bAttached
HINSTANCE | m_hDefaultResource
HINSTANCE | m_hModuleResource
AFX_EXTENSION_MODULE | m_module
The documentation for this class was generated from the following file:
  • AcExtensionModule.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcExtensionModule Member List

This is the complete list of members for CAcExtensionModule, including all inherited members.

Attached() (defined in CAcExtensionModule) | CAcExtensionModule | inline
AttachInstance(HINSTANCE hInst) (defined in CAcExtensionModule) | CAcExtensionModule | inline
CAcExtensionModule() (defined in CAcExtensionModule) | CAcExtensionModule | inline
DefaultResourceInstance() (defined in CAcExtensionModule) | CAcExtensionModule | inline
DetachInstance() (defined in CAcExtensionModule) | CAcExtensionModule | inline
m_bAttached (defined in CAcExtensionModule) | CAcExtensionModule | protected
m_hDefaultResource (defined in CAcExtensionModule) | CAcExtensionModule | protected
m_hModuleResource (defined in CAcExtensionModule) | CAcExtensionModule | protected
m_module (defined in CAcExtensionModule) | CAcExtensionModule | protected
ModuleResourceInstance() (defined in CAcExtensionModule) | CAcExtensionModule | inline
~CAcExtensionModule() (defined in CAcExtensionModule) | CAcExtensionModule | inline


ZRX API Reference: CAcModuleResourceOverride Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcModuleResourceOverride Class Reference
MFC Classes

Public Member Functions

CAcModuleResourceOverride (HINSTANCE hInst)
The documentation for this class was generated from the following file:
  • AcExtensionModule.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcModuleResourceOverride Member List

This is the complete list of members for CAcModuleResourceOverride, including all inherited members.

CAcModuleResourceOverride() (defined in CAcModuleResourceOverride) | CAcModuleResourceOverride | inline
CAcModuleResourceOverride(HINSTANCE hInst) (defined in CAcModuleResourceOverride) | CAcModuleResourceOverride | inline
~CAcModuleResourceOverride() (defined in CAcModuleResourceOverride) | CAcModuleResourceOverride | inline


ZRX API Reference: CAcUiAngleComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiAngleComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiAngleComboBox:

Additional Inherited Members

- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Protected Member Functions inherited from CAdUiComboBox
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
afx_msg LRESULT | OnGetToolTipText (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
- Protected Attributes inherited from CAdUiComboBox
CWnd * | m_aduiParent
BOOL | m_bAutoDeleteEBox: 1
BOOL | m_bAutoDeleteLBox: 1
BOOL | m_bSubclassedControls: 1
CPoint | m_lastMousePoint
CAdUiEdit * | m_pComboEBox
CAdUiListBox * | m_pComboLBox
CString | m_sToolTipText
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiAngleComboBox Member List

This is the complete list of members for CAcUiAngleComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiAngleComboBox() (defined in CAcUiAngleComboBox) | CAcUiAngleComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox | virtual
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
~CAcUiAngleComboBox() (defined in CAcUiAngleComboBox) | CAcUiAngleComboBox | virtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiAngleEdit Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcUiAngleEdit Class Reference
MFC Classes
+ Inheritance diagram for CAcUiAngleEdit:

Public Member Functions

virtual void | SetStyleMask (DWORD mask)
- Public Member Functions inherited from CAcUiEdit
void | Convert ()
BOOL | ConvertData (CString &x)
BOOL | HasChanged ()
void | SetDirty ()
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiEdit
CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsStyleMaskSet (DWORD)
void | SetAdUiParent (CWnd *w)

Additional Inherited Members

- Public Attributes inherited from CAcUiEdit
BOOL | m_bChanged
BOOL | m_bTouch
CString | m_csMsg
double | m_dMaxValue
double | m_dMinValue
- Protected Member Functions inherited from CAcUiEdit
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg BOOL | OnChange ()
afx_msg void | OnErrSpace ()
afx_msg void | OnKillFocus (CWnd *pNewWnd)
- Protected Attributes inherited from CAdUiEdit
CWnd * | m_aduiParent
CPoint | m_lastMousePoint
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiEdit.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiAngleEdit Member List

This is the complete list of members for CAcUiAngleEdit, including all inherited members.

CAcUiAngleEdit() (defined in CAcUiAngleEdit) | CAcUiAngleEdit |
CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit |
CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit |
Convert() (defined in CAcUiEdit) | CAcUiEdit |
ConvertData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAcUiEdit) | CAcUiEdit | protectedvirtual
GetAdUiParent() (defined in CAdUiEdit) | CAdUiEdit |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit | virtual
GetStyleMask() (defined in CAdUiEdit) | CAdUiEdit |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit |
HasChanged() (defined in CAcUiEdit) | CAcUiEdit |
IsStyleMaskSet(DWORD) (defined in CAdUiEdit) | CAdUiEdit |
m_aduiParent (defined in CAdUiEdit) | CAdUiEdit | protected
m_bChanged (defined in CAcUiEdit) | CAcUiEdit |
m_bTouch (defined in CAcUiEdit) | CAcUiEdit |
m_csMsg (defined in CAcUiEdit) | CAcUiEdit |
m_dMaxValue (defined in CAcUiEdit) | CAcUiEdit |
m_dMinValue (defined in CAcUiEdit) | CAcUiEdit |
m_lastMousePoint (defined in CAdUiEdit) | CAdUiEdit | protected
m_styleMask (defined in CAdUiEdit) | CAdUiEdit |
m_tipRect (defined in CAdUiEdit) | CAdUiEdit | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiEdit) | CAdUiEdit | protected
OnChange() (defined in CAcUiEdit) | CAcUiEdit | protected
OnDrawTip(CDC &dc) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnErrSpace() (defined in CAcUiEdit) | CAcUiEdit | protected
OnGetTipRect(CRect &r) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAcUiEdit) | CAcUiEdit | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiEdit) | CAdUiEdit | protected
SetAdUiParent(CWnd *w) (defined in CAdUiEdit) | CAdUiEdit |
SetDirty() (defined in CAcUiEdit) | CAcUiEdit |
SetRange(double vMin, double vMax) (defined in CAcUiEdit) | CAcUiEdit |
SetStyleMask(DWORD mask) (defined in CAcUiAngleEdit) | CAcUiAngleEdit | virtual
Validate() (defined in CAcUiEdit) | CAcUiEdit |
ValidateData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
~CAcUiAngleEdit() (defined in CAcUiAngleEdit) | CAcUiAngleEdit | virtual
~CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit | virtual
~CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit | virtual


ZRX API Reference: CAcUiArrowHeadComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAcUiArrowHeadComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiArrowHeadComboBox:

Public Member Functions

int | AddArrowHeadToMRU (LPCTSTR name)
BOOL | GetUseOrigin2 ()
void | SetUseOrigin2 (BOOL use)
- Public Member Functions inherited from CAcUiMRUComboBox
void | AddItems ()
int | AddItemToList (LPCTSTR name, INT_PTR cargo)
int | AddItemToMRU (LPCTSTR name, int cargo)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual int | ExtraWidth ()
int | FindItemByCargo (INT_PTR cargo)
int | GetCargoOption1 ()
int | GetCargoOption2 ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
INT_PTR | GetCurrentItemCargo ()
INT_PTR | GetItemCargo (int item)
virtual BOOL | GetItemColors (DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor)
LOGPALETTE * | GetLogPalette ()
HPALETTE | GetPalette ()
BOOL | GetUseByBlock ()
BOOL | GetUseByLayer ()
BOOL | GetUseOption1 ()
BOOL | GetUseOption2 ()
BOOL | GetUseOther ()
BOOL | GetUseOther1 ()
BOOL | GetUseOther2 ()
BOOL | GetUseWindows ()
virtual int | ImageWidth ()
int | InsertItemInList (int index, LPCTSTR name, INT_PTR cargo)
int | ItemHeight ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | RecalcHeight ()
void | RemoveItemFromMRU (int cargo)
void | SetCargoOption1 (int cargo)
void | SetCargoOption2 (int cargo)
void | SetLastSelection (int sel)
void | SetLogPalette (LOGPALETTE *logPalette)
void | SetPalette (HPALETTE hPalette)
void | SetUseByBlock (BOOL use)
void | SetUseByLayer (BOOL use)
void | SetUseOption1 (BOOL use)
void | SetUseOption2 (BOOL use)
void | SetUseOther (BOOL use)
void | SetUseOther1 (BOOL use)
void | SetUseOther2 (BOOL use)
void | SetUseWindows (BOOL use)
- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

virtual int | CalcItemHeight ()
virtual void | DrawItemImage (CDC &dc, CRect &r, INT_PTR cargo)
virtual BOOL | GetOtherName (BOOL isOther2, CString &name)
virtual void | OnAddItems ()
virtual void | OnComboBoxInit ()
- Protected Member Functions inherited from CAcUiMRUComboBox
void | CreateAndSelectPalette (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc)
void | DrawItemImageFromCargo (CDC *dc, CRect &r, int i)
void | DrawTextAndFocusRect (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor)
BOOL | FindCargoInMRU (int cargo)
int | GenerateCargoFromMRU (int seed)
virtual BOOL | GetOptionName (BOOL isOption2, CString &name)
afx_msg BOOL | OnCloseUp ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnDropDown ()
virtual BOOL | OnGetTipRect (CRect &r)
virtual BOOL | OnSelectOther (BOOL isOther2, int curSel, int &newSel)
afx_msg BOOL | OnSelEndOk ()
virtual void | PreSubclassWindow ()
void | ResetAndRestorePalette (CDC *dc, int savedState)
void | SelectOther (BOOL isOther2)
void | SetupForImageDraw (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor)
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam)

Additional Inherited Members

- Protected Attributes inherited from CAcUiMRUComboBox
BOOL | m_bIsDynamicCreation: 1
BOOL | m_bOther1Selected: 1
BOOL | m_bOther2Selected: 1
BOOL | m_bUseOption1: 1
BOOL | m_bUseOption2: 1
BOOL | m_bUseOther1: 1
BOOL | m_bUseOther2: 1
int | m_cargoOption1
int | m_cargoOption2
HPALETTE | m_hPalette
int | m_itemHeight
int | m_lastSelection
LOGPALETTE * | m_logPalette
int | m_mruCargo [ACUI_MAX_COMBOBOX_MRU]
int | m_mruLen
CString | m_mruName [ACUI_MAX_COMBOBOX_MRU]
CPalette * | m_pOldPalette
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiArrowHeadComboBox Member List

This is the complete list of members for CAcUiArrowHeadComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
AddArrowHeadToMRU(LPCTSTR name) (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox |
AddItems() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToList(LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToMRU(LPCTSTR name, int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAcUiArrowHeadComboBox() (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
CalcItemHeight() (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox | protectedvirtual
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
CreateAndSelectPalette(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
DrawItemImage(CDC &dc, CRect &r, INT_PTR cargo) (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox | protectedvirtual
DrawItemImageFromCargo(CDC *dc, CRect &r, int i) | CAcUiMRUComboBox | protected
DrawTextAndFocusRect(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
ExtraWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
FindCargoInMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
FindItemByCargo(INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GenerateCargoFromMRU(int seed) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetCargoOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCargoOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetCurrentItemCargo() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetItemCargo(int item) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetItemColors(DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLogPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetOptionName(BOOL isOption2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetOtherName(BOOL isOther2, CString &name) (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox | protectedvirtual
GetPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
GetUseByBlock() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseByLayer() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOrigin2() (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox |
GetUseOther() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseWindows() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ImageWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
InsertItemInList(int index, LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
ItemHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bIsDynamicCreation (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther1Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther2Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bUseOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_hPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_itemHeight (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastSelection (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_logPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruCargo (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruLen (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruName (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pOldPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
OnAddItems() (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox | protectedvirtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCloseUp() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnComboBoxInit() (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox | protectedvirtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDropDown() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnGetTipRect(CRect &r) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnSelectOther(BOOL isOther2, int curSel, int &newSel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnSelEndOk() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
PreSubclassWindow() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
RecalcHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
RemoveItemFromMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ResetAndRestorePalette(CDC *dc, int savedState) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SelectOther(BOOL isOther2) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetCargoOption1(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetCargoOption2(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLastSelection(int sel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLogPalette(LOGPALETTE *logPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetPalette(HPALETTE hPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
SetupForImageDraw(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetUseByBlock(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseByLayer(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOrigin2(BOOL use) (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox |
SetUseOther(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseWindows(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
WindowProc(UINT message, WPARAM wParam, LPARAM lParam) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
~CAcUiArrowHeadComboBox() (defined in CAcUiArrowHeadComboBox) | CAcUiArrowHeadComboBox | virtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiBitmapButton Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiBitmapButton Class Reference
MFC Classes
+ Inheritance diagram for CAcUiBitmapButton:

Additional Inherited Members

- Public Member Functions inherited from CAdUiBitmapButton
BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Protected Member Functions inherited from CAdUiBitmapButton
void | CalcBitmapSize ()
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
BOOL | LoadBitmap (LPCTSTR strResId)
BOOL | LoadBitmapResource (LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst)
virtual BOOL | OnAutoLoad ()
virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
virtual BOOL | OnReload (LPCTSTR strResId)
- Protected Attributes inherited from CAdUiBitmapButton
BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • acuiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiBitmapButton Member List

This is the complete list of members for CAcUiBitmapButton, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAcUiBitmapButton() (defined in CAcUiBitmapButton) | CAcUiBitmapButton |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAcUiBitmapButton() (defined in CAcUiBitmapButton) | CAcUiBitmapButton | virtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAcUiBitmapStatic Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiBitmapStatic Class Reference
MFC Classes
+ Inheritance diagram for CAcUiBitmapStatic:

Additional Inherited Members

- Public Member Functions inherited from CAdUiBitmapButton
BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Protected Member Functions inherited from CAdUiBitmapButton
void | CalcBitmapSize ()
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
BOOL | LoadBitmap (LPCTSTR strResId)
BOOL | LoadBitmapResource (LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst)
virtual BOOL | OnAutoLoad ()
virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
virtual BOOL | OnReload (LPCTSTR strResId)
- Protected Attributes inherited from CAdUiBitmapButton
BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • acuiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiBitmapStatic Member List

This is the complete list of members for CAcUiBitmapStatic, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAcUiBitmapStatic() (defined in CAcUiBitmapStatic) | CAcUiBitmapStatic |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiBitmapStatic() (defined in CAdUiBitmapStatic) | CAdUiBitmapStatic |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAcUiBitmapStatic() (defined in CAcUiBitmapStatic) | CAcUiBitmapStatic | virtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiBitmapStatic() (defined in CAdUiBitmapStatic) | CAdUiBitmapStatic | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAcUiColorComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAcUiColorComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiColorComboBox:

Public Member Functions

int | AddColorToMRU (int colorIndex)
int | FindItemByColorIndex (int colorIndex)
int | GetBlockColorIndex ()
virtual COLORREF | GetColorFromIndex (int colorIndex)
virtual int | GetColorIndex (COLORREF color)
int | GetCurrentItemColorIndex ()
virtual int | GetCurrentLayerColorIndex ()
int | GetItemColorIndex (int item)
virtual COLORREF | LookupColor (int colorIndex, LOGPALETTE *logPalette)
void | SetBlockColorIndex (int colorIndex)
- Public Member Functions inherited from CAcUiMRUComboBox
void | AddItems ()
int | AddItemToList (LPCTSTR name, INT_PTR cargo)
int | AddItemToMRU (LPCTSTR name, int cargo)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual int | ExtraWidth ()
int | FindItemByCargo (INT_PTR cargo)
int | GetCargoOption1 ()
int | GetCargoOption2 ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
INT_PTR | GetCurrentItemCargo ()
INT_PTR | GetItemCargo (int item)
virtual BOOL | GetItemColors (DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor)
LOGPALETTE * | GetLogPalette ()
HPALETTE | GetPalette ()
BOOL | GetUseByBlock ()
BOOL | GetUseByLayer ()
BOOL | GetUseOption1 ()
BOOL | GetUseOption2 ()
BOOL | GetUseOther ()
BOOL | GetUseOther1 ()
BOOL | GetUseOther2 ()
BOOL | GetUseWindows ()
virtual int | ImageWidth ()
int | InsertItemInList (int index, LPCTSTR name, INT_PTR cargo)
int | ItemHeight ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | RecalcHeight ()
void | RemoveItemFromMRU (int cargo)
void | SetCargoOption1 (int cargo)
void | SetCargoOption2 (int cargo)
void | SetLastSelection (int sel)
void | SetLogPalette (LOGPALETTE *logPalette)
void | SetPalette (HPALETTE hPalette)
void | SetUseByBlock (BOOL use)
void | SetUseByLayer (BOOL use)
void | SetUseOption1 (BOOL use)
void | SetUseOption2 (BOOL use)
void | SetUseOther (BOOL use)
void | SetUseOther1 (BOOL use)
void | SetUseOther2 (BOOL use)
void | SetUseWindows (BOOL use)
- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

virtual void | DrawItemImage (CDC &dc, CRect &r, INT_PTR cargo)
virtual BOOL | GetOtherColorIndex (int defaultColorIndex, int layerColorIndex, BOOL enableMetaColors, int &colorIndex)
virtual BOOL | GetOtherName (BOOL isOther2, CString &name)
virtual BOOL | GetWindowsColor (COLORREF &color)
virtual void | OnAddItems ()
virtual BOOL | OnSelectOther (BOOL isOther2, int curSel, int &newSel)
void | RGBFill (CDC &dc, CRect &rFill)
- Protected Member Functions inherited from CAcUiMRUComboBox
virtual int | CalcItemHeight ()
void | CreateAndSelectPalette (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc)
void | DrawItemImageFromCargo (CDC *dc, CRect &r, int i)
void | DrawTextAndFocusRect (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor)
BOOL | FindCargoInMRU (int cargo)
int | GenerateCargoFromMRU (int seed)
virtual BOOL | GetOptionName (BOOL isOption2, CString &name)
afx_msg BOOL | OnCloseUp ()
virtual void | OnComboBoxInit ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnDropDown ()
virtual BOOL | OnGetTipRect (CRect &r)
afx_msg BOOL | OnSelEndOk ()
virtual void | PreSubclassWindow ()
void | ResetAndRestorePalette (CDC *dc, int savedState)
void | SelectOther (BOOL isOther2)
void | SetupForImageDraw (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor)
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam)

Protected Attributes

int | m_blockColorIndex
- Protected Attributes inherited from CAcUiMRUComboBox
BOOL | m_bIsDynamicCreation: 1
BOOL | m_bOther1Selected: 1
BOOL | m_bOther2Selected: 1
BOOL | m_bUseOption1: 1
BOOL | m_bUseOption2: 1
BOOL | m_bUseOther1: 1
BOOL | m_bUseOther2: 1
int | m_cargoOption1
int | m_cargoOption2
HPALETTE | m_hPalette
int | m_itemHeight
int | m_lastSelection
LOGPALETTE * | m_logPalette
int | m_mruCargo [ACUI_MAX_COMBOBOX_MRU]
int | m_mruLen
CString | m_mruName [ACUI_MAX_COMBOBOX_MRU]
CPalette * | m_pOldPalette
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiColorComboBox Member List

This is the complete list of members for CAcUiColorComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
AddColorToMRU(int colorIndex) (defined in CAcUiColorComboBox) | CAcUiColorComboBox |
AddItems() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToList(LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToMRU(LPCTSTR name, int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAcUiColorComboBox() (defined in CAcUiColorComboBox) | CAcUiColorComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
CalcItemHeight() | CAcUiMRUComboBox | protectedvirtual
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
CreateAndSelectPalette(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
DrawItemImage(CDC &dc, CRect &r, INT_PTR cargo) (defined in CAcUiColorComboBox) | CAcUiColorComboBox | protectedvirtual
DrawItemImageFromCargo(CDC *dc, CRect &r, int i) | CAcUiMRUComboBox | protected
DrawTextAndFocusRect(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
ExtraWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
FindCargoInMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
FindItemByCargo(INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
FindItemByColorIndex(int colorIndex) (defined in CAcUiColorComboBox) | CAcUiColorComboBox |
GenerateCargoFromMRU(int seed) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetBlockColorIndex() (defined in CAcUiColorComboBox) | CAcUiColorComboBox |
GetCargoOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCargoOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetColorFromIndex(int colorIndex) (defined in CAcUiColorComboBox) | CAcUiColorComboBox | virtual
GetColorIndex(COLORREF color) (defined in CAcUiColorComboBox) | CAcUiColorComboBox | virtual
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetCurrentItemCargo() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCurrentItemColorIndex() (defined in CAcUiColorComboBox) | CAcUiColorComboBox |
GetCurrentLayerColorIndex() (defined in CAcUiColorComboBox) | CAcUiColorComboBox | virtual
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetItemCargo(int item) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetItemColorIndex(int item) (defined in CAcUiColorComboBox) | CAcUiColorComboBox |
GetItemColors(DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLogPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetOptionName(BOOL isOption2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetOtherColorIndex(int defaultColorIndex, int layerColorIndex, BOOL enableMetaColors, int &colorIndex) (defined in CAcUiColorComboBox) | CAcUiColorComboBox | protectedvirtual
GetOtherName(BOOL isOther2, CString &name) (defined in CAcUiColorComboBox) | CAcUiColorComboBox | protectedvirtual
GetPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
GetUseByBlock() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseByLayer() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseWindows() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetWindowsColor(COLORREF &color) (defined in CAcUiColorComboBox) | CAcUiColorComboBox | protectedvirtual
ImageWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
InsertItemInList(int index, LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
ItemHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
LookupColor(int colorIndex, LOGPALETTE *logPalette) (defined in CAcUiColorComboBox) | CAcUiColorComboBox | virtual
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bIsDynamicCreation (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_blockColorIndex (defined in CAcUiColorComboBox) | CAcUiColorComboBox | protected
m_bOther1Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther2Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bUseOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_hPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_itemHeight (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastSelection (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_logPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruCargo (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruLen (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruName (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pOldPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
OnAddItems() (defined in CAcUiColorComboBox) | CAcUiColorComboBox | protectedvirtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCloseUp() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnComboBoxInit() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDropDown() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnGetTipRect(CRect &r) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnSelectOther(BOOL isOther2, int curSel, int &newSel) (defined in CAcUiColorComboBox) | CAcUiColorComboBox | protectedvirtual
OnSelEndOk() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
PreSubclassWindow() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
RecalcHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
RemoveItemFromMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ResetAndRestorePalette(CDC *dc, int savedState) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
RGBFill(CDC &dc, CRect &rFill) (defined in CAcUiColorComboBox) | CAcUiColorComboBox | protected
SelectOther(BOOL isOther2) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetBlockColorIndex(int colorIndex) (defined in CAcUiColorComboBox) | CAcUiColorComboBox |
SetCargoOption1(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetCargoOption2(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLastSelection(int sel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLogPalette(LOGPALETTE *logPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetPalette(HPALETTE hPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
SetupForImageDraw(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetUseByBlock(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseByLayer(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseWindows(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
WindowProc(UINT message, WPARAM wParam, LPARAM lParam) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
~CAcUiColorComboBox() (defined in CAcUiColorComboBox) | CAcUiColorComboBox | virtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcUiComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiComboBox:

Public Member Functions

CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Additional Inherited Members

- Protected Member Functions inherited from CAdUiComboBox
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
afx_msg LRESULT | OnGetToolTipText (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
- Protected Attributes inherited from CAdUiComboBox
CWnd * | m_aduiParent
BOOL | m_bAutoDeleteEBox: 1
BOOL | m_bAutoDeleteLBox: 1
BOOL | m_bSubclassedControls: 1
CPoint | m_lastMousePoint
CAdUiEdit * | m_pComboEBox
CAdUiListBox * | m_pComboLBox
CString | m_sToolTipText
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiComboBox Member List

This is the complete list of members for CAcUiComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox | virtual
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
CAcUiDialog Class Reference
MFC Classes
+ Inheritance diagram for CAcUiDialog:

Public Types

enum | { IDD = 0 }
- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Public Types inherited from CAdUiBaseDialog
enum | { IDD = 0 }

Public Member Functions

virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAcUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual int | IsMultiDocumentActivationEnabled ()
virtual void | OnDialogHelp ()
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
virtual void | OnCancel ()
virtual void | OnOK ()
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Additional Inherited Members

- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist
The documentation for this class was generated from the following file:
  • acuiDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiDialog Member List

This is the complete list of members for CAcUiDialog, including all inherited members.

AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAcUiDialog) | CAcUiDialog | virtual
AppResourceInstance() (defined in CAcUiDialog) | CAcUiDialog | virtual
AppRootKey() (defined in CAcUiDialog) | CAcUiDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAcUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAcUiDialog) | CAcUiDialog |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAcUiDialog) | CAcUiDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAcUiDialog) | CAcUiDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAcUiDialog) | CAcUiDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAcUiDialog) | CAcUiDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAcUiDialog) | CAcUiDialog |
IsMultiDocumentActivationEnabled() (defined in CAcUiDialog) | CAcUiDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnCancel() (defined in CAcUiDialog) | CAcUiDialog | protectedvirtual
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDialogHelp() (defined in CAcUiDialog) | CAcUiDialog | virtual
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAcUiDialog) | CAcUiDialog | protectedvirtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDialog) | CAdUiDialog | protected
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAcUiDialog() (defined in CAcUiDialog) | CAcUiDialog | virtual
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAcUiDialogBar Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
CAcUiDialogBar Class Reference
MFC Classes
+ Inheritance diagram for CAcUiDialogBar:

Public Types

enum | { IDD = 0 }
- Public Types inherited from CAdUiDialogBar
enum | { IDD = 0 }

Public Member Functions

virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
- Public Member Functions inherited from CAdUiDialogBar
BOOL | GetUseTips ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetUseTips (BOOL useTips)

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
- Protected Member Functions inherited from CAdUiDialogBar
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg int | OnCreate (LPCREATESTRUCT lpcs)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()

Additional Inherited Members

- Protected Attributes inherited from CAdUiDialogBar
BOOL | m_bUseTips
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey
The documentation for this class was generated from the following file:
  • acuiDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiDialogBar Member List

This is the complete list of members for CAcUiDialogBar, including all inherited members.

AppMainWindow() (defined in CAcUiDialogBar) | CAcUiDialogBar | virtual
AppResourceInstance() (defined in CAcUiDialogBar) | CAcUiDialogBar | virtual
AppRootKey() (defined in CAcUiDialogBar) | CAcUiDialogBar | virtual
CAcUiDialogBar() (defined in CAcUiDialogBar) | CAcUiDialogBar |
CAdUiDialogBar() (defined in CAdUiDialogBar) | CAdUiDialogBar |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAcUiDialogBar) | CAcUiDialogBar | protectedvirtual
GetUseTips() (defined in CAdUiDialogBar) | CAdUiDialogBar |
IDD enum value (defined in CAcUiDialogBar) | CAcUiDialogBar |
m_bUseTips (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
m_pTextTip (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
m_pToolTip (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
m_rootKey (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnCreate(LPCREATESTRUCT lpcs) (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
PostNcDestroy() (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiDialogBar) | CAdUiDialogBar | virtual
SetUseTips(BOOL useTips) (defined in CAdUiDialogBar) | CAdUiDialogBar |
~CAcUiDialogBar() (defined in CAcUiDialogBar) | CAcUiDialogBar | virtual
~CAdUiDialogBar() (defined in CAdUiDialogBar) | CAdUiDialogBar | virtual


ZRX API Reference: CAcUiDialogWorksheet Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
CAcUiDialogWorksheet Class Reference
MFC Classes
+ Inheritance diagram for CAcUiDialogWorksheet:

Public Types

enum { IDD = 0 }

Public Member Functions

CAcUiDialogWorksheet (UINT ID, CWnd *pParent=NULL, HINSTANCE hResInst=NULL)
- Public Member Functions inherited from CAdUiDialogWorksheet
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
virtual BOOL | DestroyWindow ()
CAdUiTheme * | GetTheme () const
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetDraw (const CAdUiWorksheetDraw *pDraw)
CAdUiTheme * | SetTheme (CAdUiTheme *pTheme)
virtual void | ThemeModified (AdUiThemeElement element)
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
virtual void | OnDialogHelp ()
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg void | OnDrawItem (int nIDCtl, LPDRAWITEMSTRUCT lpDrawItemStruct)
afx_msg BOOL | OnEraseBkgnd (CDC *pDC)
virtual BOOL | OnInitDialog ()
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnLButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnMouseMove (UINT nHitTest, CPoint point)
afx_msg BOOL | OnNcActivate (BOOL bActive)
afx_msg UINT | OnNcHitTest (CPoint point)
afx_msg void | OnNcLButtonDown (UINT nHitTest, CPoint point)
afx_msg void | OnNcLButtonUp (UINT nHitTest, CPoint point)
afx_msg void | OnNcMouseMove (UINT nHitTest, CPoint point)
afx_msg void | OnNcPaint ()
afx_msg void | OnPaint ()
afx_msg HCURSOR | OnQueryDragIcon ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg void | OnSysColorChange ()
afx_msg void | OnSysCommand (UINT nID, LPARAM lParam)
- Protected Member Functions inherited from CAdUiDialogWorksheet
CAdUiDialogWorksheet (UINT ID, CWnd *pParent=NULL, HINSTANCE hResInst=NULL)
CAdUiDialogWorksheet (UINT ID, const CAdUiWorksheetDraw &draw, CWnd *pParent=NULL, HINSTANCE hResInst=NULL)
afx_msg void | OnClose ()
afx_msg void | OnDestroy ()
afx_msg void | OnGetMinMaxInfo (MINMAXINFO *lpMMI)
afx_msg void | OnIconEraseBkgnd (CDC *pDC)
afx_msg void | OnKillFocus (CWnd *pNewWnd)
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnMButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnMeasureItem (int nIDCtl, LPMEASUREITEMSTRUCT lpMeasureItemStruct)
afx_msg void | OnMoving (UINT nSide, LPRECT lpRect)
afx_msg void | OnNcCalcSize (BOOL bCalcValidRects, NCCALCSIZE_PARAMS *lpncsp)
afx_msg BOOL | OnNcCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnNcDestroy ()
afx_msg void | OnNcLButtonDblClk (UINT nHitTest, CPoint point)
afx_msg void | OnNcMButtonDblClk (UINT nHitTest, CPoint point)
afx_msg void | OnNcMButtonDown (UINT nHitTest, CPoint point)
afx_msg void | OnNcMButtonUp (UINT nHitTest, CPoint point)
afx_msg void | OnNcRButtonDblClk (UINT nHitTest, CPoint point)
afx_msg void | OnNcRButtonDown (UINT nHitTest, CPoint point)
afx_msg void | OnNcRButtonUp (UINT nHitTest, CPoint point)
afx_msg void | OnRButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnRButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnRButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg void | OnSizing (UINT nSide, LPRECT lpRect)
afx_msg void | OnStyleChanged (int nStyleType, LPSTYLESTRUCT lpStyleStruct)
afx_msg void | OnStyleChanging (int nStyleType, LPSTYLESTRUCT lpStyleStruct)
virtual void | PostNcDestroy ()
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
virtual void | OnOK ()
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)

Additional Inherited Members

- Static Public Member Functions inherited from CAdUiDialogWorksheet
static CAdUiWorksheetDraw * | SetDefaultDraw (CAdUiWorksheetDraw *pDraw)
- Protected Attributes inherited from CAdUiDialogWorksheet
HICON | m_hIcon
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist
The documentation for this class was generated from the following file:
  • acuiDialogWorksheet.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiDialogWorksheet Member List

This is the complete list of members for CAcUiDialogWorksheet, including all inherited members.

AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAcUiDialogWorksheet(UINT ID, CWnd *pParent=NULL, HINSTANCE hResInst=NULL) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CAdUiDialogWorksheet(UINT ID, CWnd *pParent=NULL, HINSTANCE hResInst=NULL) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
CAdUiDialogWorksheet(UINT ID, const CAdUiWorksheetDraw &draw, CWnd *pParent=NULL, HINSTANCE hResInst=NULL) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
DestroyWindow() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetTheme() const (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnClose() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnDestroy() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
OnDrawItem(int nIDCtl, LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnEraseBkgnd(CDC *pDC) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnGetMinMaxInfo(MINMAXINFO *lpMMI) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnIconEraseBkgnd(CDC *pDC) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnInitDialog() (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protectedvirtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnLButtonDown(UINT nFlags, CPoint point) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnLButtonUp(UINT nFlags, CPoint point) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnMButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMButtonDown(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMButtonUp(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMeasureItem(int nIDCtl, LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMouseMove(UINT nHitTest, CPoint point) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnMoving(UINT nSide, LPRECT lpRect) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcActivate(BOOL bActive) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS *lpncsp) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcDestroy() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcHitTest(CPoint point) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnNcLButtonDblClk(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcLButtonDown(UINT nHitTest, CPoint point) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnNcLButtonUp(UINT nHitTest, CPoint point) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnNcMButtonDblClk(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcMButtonDown(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcMButtonUp(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcMouseMove(UINT nHitTest, CPoint point) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnNcPaint() (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnNcRButtonDblClk(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcRButtonDown(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcRButtonUp(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnPaint() (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnQueryDragIcon() (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnRButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnRButtonDown(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnRButtonUp(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnSize(UINT nType, int cx, int cy) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnSizing(UINT nSide, LPRECT lpRect) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnStyleChanged(int nStyleType, LPSTYLESTRUCT lpStyleStruct) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnStyleChanging(int nStyleType, LPSTYLESTRUCT lpStyleStruct) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnSysColorChange() (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
OnSysCommand(UINT nID, LPARAM lParam) (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet | protected
PostNcDestroy() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDefaultDraw(CAdUiWorksheetDraw *pDraw) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | static
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetDraw(const CAdUiWorksheetDraw *pDraw) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ThemeModified(AdUiThemeElement element) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAcUiDialogWorksheet() (defined in CAcUiDialogWorksheet) | CAcUiDialogWorksheet |
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual
~CAdUiDialogWorksheet() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual


ZRX API Reference: CAcUiDockControlBar Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Protected Member Functions | List of all members
CAcUiDockControlBar Class Reference
MFC Classes
+ Inheritance diagram for CAcUiDockControlBar:

Protected Member Functions

virtual bool | CanFrameworkTakeFocus ()
- Protected Member Functions inherited from CAdUiDockControlBar
virtual BOOL | AddCustomMenuItems (LPARAM hMenu)
bool | CloseButtonVisible ()
virtual BOOL | CreateControlBar (LPCREATESTRUCT lpCreateStruct)
virtual void | GetFloatingMinSize (long *pnMinWidth, long *pnMinHeight)
void | GetUsedRect (CRect &rect)
afx_msg void | OnAllowDock ()
afx_msg void | OnAnchor ()
afx_msg void | OnAnchorLeft ()
afx_msg void | OnAnchorRight ()
virtual bool | OnClosing ()
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
afx_msg void | OnContextMenu (CWnd *pWnd, CPoint point)
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnEraseBkgnd (CDC *pDC)
afx_msg void | OnHideBar ()
afx_msg void | OnPaint ()
virtual void | OnUserSizing (UINT nSide, LPRECT pRect)
afx_msg void | OnWindowPosChanged (WINDOWPOS FAR *lpwndpos)
virtual void | PaintControlBar (CDC *pDC)
void | ShowCloseButton (bool bShow)
virtual void | SizeChanged (CRect *lpRect, BOOL bFloating, int flags)

Additional Inherited Members

- Public Member Functions inherited from CAdUiDockControlBar
bool | AdjustVertDockedBarHeight (int nHeight)
bool | AllowDockingMenuItemState ()
bool | Anchored ()
CAdUiDockControlBar (int nStyle=ADUI_DOCK_CS_STDMOUSECLICKS)
virtual CSize | CalcFixedLayout (BOOL bStretch, BOOL bHorz)
BOOL | Create (CWnd *pParent, LPCTSTR lpszTitle, UINT nID, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, const RECT &rect=CFrameWnd::rectDefault)
BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
void | DockControlBar (UINT nOrientation, RECT *pRect)
void | EnableDocking (DWORD dwDockStyle)
DWORD | GetDockStyle ()
void | GetFloatingRect (CRect *pFloatingPos)
void | GetPersistedDockingRect (CRect *pDockRect)
void | GetPersistedFloatingRect (CRect *pFloatRect)
CLSID * | GetToolID ()
void | InitFloatingPosition (CRect *pSizeFloating)
BOOL | IsFloating ()
virtual BOOL | Load (IUnknown *pUnk)
void | RestoreControlBar (UINT nPreferredOrientation=AFX_IDW_DOCKBAR_LEFT, CRect *pSizeFloating=NULL)
virtual BOOL | Save (IUnknown *pUnk)
void | SetAllowDockingMenuItemState (bool bState)
void | SetToolID (CLSID *pCLSID)
void | TileInRow ()
- Static Public Member Functions inherited from CAdUiDockControlBar
static bool | GetToolsRestartMode ()
static void | SetToolsRestartMode (bool bMode)
- Protected Types inherited from CAdUiDockControlBar
enum | { btnWidth = 12, btnHeight = 12, idCloseBtn = 10001, idPinBtn = 10002 }
The documentation for this class was generated from the following file:
  • acuiDock.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiDockControlBar Member List

This is the complete list of members for CAcUiDockControlBar, including all inherited members.

AddCustomMenuItems(LPARAM hMenu) | CAdUiDockControlBar | protectedvirtual
AdjustVertDockedBarHeight(int nHeight) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
AllowDockingMenuItemState() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
Anchored() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
btnHeight enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
btnWidth enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
CAcUiDockControlBar() (defined in CAcUiDockControlBar) | CAcUiDockControlBar | inline
CAdUiDockControlBar(int nStyle=ADUI_DOCK_CS_STDMOUSECLICKS) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
CalcFixedLayout(BOOL bStretch, BOOL bHorz) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
CanFrameworkTakeFocus() (defined in CAcUiDockControlBar) | CAcUiDockControlBar | protectedvirtual
CloseButtonVisible() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotected
Create(CWnd *pParent, LPCTSTR lpszTitle, UINT nID, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, const RECT &rect=CFrameWnd::rectDefault) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
CreateControlBar(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
DockControlBar(UINT nOrientation, RECT *pRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
EnableDocking(DWORD dwDockStyle) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetDockStyle() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
GetFloatingMinSize(long *pnMinWidth, long *pnMinHeight) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
GetFloatingRect(CRect *pFloatingPos) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetPersistedDockingRect(CRect *pDockRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetPersistedFloatingRect(CRect *pFloatRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetToolID() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
GetToolsRestartMode() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | static
GetUsedRect(CRect &rect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
idCloseBtn enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
idPinBtn enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
InitFloatingPosition(CRect *pSizeFloating) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
IsFloating() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
Load(IUnknown *pUnk) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
OnAllowDock() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnAnchor() | CAdUiDockControlBar | protected
OnAnchorLeft() | CAdUiDockControlBar | protected
OnAnchorRight() | CAdUiDockControlBar | protected
OnClosing() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
OnCommand(WPARAM wParam, LPARAM lParam) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
OnContextMenu(CWnd *pWnd, CPoint point) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnEraseBkgnd(CDC *pDC) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnHideBar() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnPaint() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnUserSizing(UINT nSide, LPRECT pRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotectedvirtual
OnWindowPosChanged(WINDOWPOS FAR *lpwndpos) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
PaintControlBar(CDC *pDC) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
RestoreControlBar(UINT nPreferredOrientation=AFX_IDW_DOCKBAR_LEFT, CRect *pSizeFloating=NULL) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
Save(IUnknown *pUnk) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
SetAllowDockingMenuItemState(bool bState) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
SetToolID(CLSID *pCLSID) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
SetToolsRestartMode(bool bMode) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | static
ShowCloseButton(bool bShow) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotected
SizeChanged(CRect *lpRect, BOOL bFloating, int flags) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotectedvirtual
TileInRow() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
~CAdUiDockControlBar() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual


ZRX API Reference: CAcUiDockFrame Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Protected Member Functions | List of all members
CAcUiDockFrame Class Reference
MFC Classes
+ Inheritance diagram for CAcUiDockFrame:

Protected Member Functions

afx_msg LRESULT | OnACADKeepFocus (WPARAM wParam, LPARAM lParam)
- Protected Member Functions inherited from CAdUiDockFrame
bool | CanAutoCADTakeFocus ()
bool | CanFrameworkTakeFocus ()
void | ForceChildRepaint ()
afx_msg void | OnClose ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
afx_msg int | OnMouseActivate (CWnd *pDesktopWnd, UINT nHitTest, UINT message)
afx_msg UINT | OnNcHitTest (CPoint point)
afx_msg void | OnNcLButtonDown (UINT nHitTest, CPoint pt)
afx_msg void | OnPaint ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg void | OnSizing (UINT nSide, LPRECT pRect)
afx_msg void | OnWindowPosChanging (WINDOWPOS *lpwndpos)
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Additional Inherited Members

- Public Types inherited from CAdUiDockFrame
enum | ContainedBarType { Unknown, Standard, AdskBar }
- Public Member Functions inherited from CAdUiDockFrame
enum ContainedBarType | GetContainedBarType ()
- Protected Attributes inherited from CAdUiDockFrame
bool | m_bZOrderChanged
enum ContainedBarType | m_nContainedBarType
The documentation for this class was generated from the following file:
  • acuiDock.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiDockFrame Member List

This is the complete list of members for CAcUiDockFrame, including all inherited members.

AdskBar enum value (defined in CAdUiDockFrame) | CAdUiDockFrame |
CAcUiDockFrame() (defined in CAcUiDockFrame) | CAcUiDockFrame |
CAdUiDockFrame() (defined in CAdUiDockFrame) | CAdUiDockFrame |
CanAutoCADTakeFocus() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
CanFrameworkTakeFocus() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
ContainedBarType enum name (defined in CAdUiDockFrame) | CAdUiDockFrame |
ForceChildRepaint() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
GetContainedBarType() (defined in CAdUiDockFrame) | CAdUiDockFrame |
m_bZOrderChanged (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
m_nContainedBarType (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnACADKeepFocus(WPARAM wParam, LPARAM lParam) (defined in CAcUiDockFrame) | CAcUiDockFrame | protected
OnClose() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnMouseActivate(CWnd *pDesktopWnd, UINT nHitTest, UINT message) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnNcHitTest(CPoint point) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnNcLButtonDown(UINT nHitTest, CPoint pt) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnPaint() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnSizing(UINT nSide, LPRECT pRect) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnWindowPosChanging(WINDOWPOS *lpwndpos) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiDockFrame) | CAdUiDockFrame | protectedvirtual
Standard enum value (defined in CAdUiDockFrame) | CAdUiDockFrame |
Unknown enum value (defined in CAdUiDockFrame) | CAdUiDockFrame |
~CAcUiDockFrame() (defined in CAcUiDockFrame) | CAcUiDockFrame | virtual


ZRX API Reference: CAcUiDropSite Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiDropSite Class Reference
MFC Classes
+ Inheritance diagram for CAcUiDropSite:

Additional Inherited Members

- Public Member Functions inherited from CAdUiBitmapButton
BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Protected Member Functions inherited from CAdUiBitmapButton
void | CalcBitmapSize ()
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
BOOL | LoadBitmap (LPCTSTR strResId)
BOOL | LoadBitmapResource (LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst)
virtual BOOL | OnAutoLoad ()
virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
virtual BOOL | OnReload (LPCTSTR strResId)
- Protected Attributes inherited from CAdUiBitmapButton
BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • acuiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiDropSite Member List

This is the complete list of members for CAcUiDropSite, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAcUiDropSite() (defined in CAcUiDropSite) | CAcUiDropSite |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiBitmapStatic() (defined in CAdUiBitmapStatic) | CAdUiBitmapStatic |
CAdUiDropSite() (defined in CAdUiDropSite) | CAdUiDropSite |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAcUiDropSite() (defined in CAcUiDropSite) | CAcUiDropSite | virtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiBitmapStatic() (defined in CAdUiBitmapStatic) | CAdUiBitmapStatic | virtual
~CAdUiDropSite() (defined in CAdUiDropSite) | CAdUiDropSite | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAcUiEdit Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | List of all members
CAcUiEdit Class Reference
MFC Classes
+ Inheritance diagram for CAcUiEdit:

Public Member Functions

void | Convert ()
BOOL | ConvertData (CString &x)
BOOL | HasChanged ()
void | SetDirty ()
void | SetRange (double vMin, double vMax)
virtual void | SetStyleMask (DWORD mask)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiEdit
CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsStyleMaskSet (DWORD)
void | SetAdUiParent (CWnd *w)

Public Attributes

BOOL | m_bChanged
BOOL | m_bTouch
CString | m_csMsg
double | m_dMaxValue
double | m_dMinValue
- Public Attributes inherited from CAdUiEdit
DWORD | m_styleMask

Protected Member Functions

virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg BOOL | OnChange ()
afx_msg void | OnErrSpace ()
afx_msg void | OnKillFocus (CWnd *pNewWnd)
- Protected Member Functions inherited from CAdUiEdit
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)

Additional Inherited Members

- Protected Attributes inherited from CAdUiEdit
CWnd * | m_aduiParent
CPoint | m_lastMousePoint
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiEdit.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiEdit Member List

This is the complete list of members for CAcUiEdit, including all inherited members.

CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit |
CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit |
Convert() (defined in CAcUiEdit) | CAcUiEdit |
ConvertData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAcUiEdit) | CAcUiEdit | protectedvirtual
GetAdUiParent() (defined in CAdUiEdit) | CAdUiEdit |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit | virtual
GetStyleMask() (defined in CAdUiEdit) | CAdUiEdit |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit |
HasChanged() (defined in CAcUiEdit) | CAcUiEdit |
IsStyleMaskSet(DWORD) (defined in CAdUiEdit) | CAdUiEdit |
m_aduiParent (defined in CAdUiEdit) | CAdUiEdit | protected
m_bChanged (defined in CAcUiEdit) | CAcUiEdit |
m_bTouch (defined in CAcUiEdit) | CAcUiEdit |
m_csMsg (defined in CAcUiEdit) | CAcUiEdit |
m_dMaxValue (defined in CAcUiEdit) | CAcUiEdit |
m_dMinValue (defined in CAcUiEdit) | CAcUiEdit |
m_lastMousePoint (defined in CAdUiEdit) | CAdUiEdit | protected
m_styleMask (defined in CAdUiEdit) | CAdUiEdit |
m_tipRect (defined in CAdUiEdit) | CAdUiEdit | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiEdit) | CAdUiEdit | protected
OnChange() (defined in CAcUiEdit) | CAcUiEdit | protected
OnDrawTip(CDC &dc) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnErrSpace() (defined in CAcUiEdit) | CAcUiEdit | protected
OnGetTipRect(CRect &r) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAcUiEdit) | CAcUiEdit | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiEdit) | CAdUiEdit | protected
SetAdUiParent(CWnd *w) (defined in CAdUiEdit) | CAdUiEdit |
SetDirty() (defined in CAcUiEdit) | CAcUiEdit |
SetRange(double vMin, double vMax) (defined in CAcUiEdit) | CAcUiEdit |
SetStyleMask(DWORD mask) (defined in CAcUiEdit) | CAcUiEdit | virtual
Validate() (defined in CAcUiEdit) | CAcUiEdit |
ValidateData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
~CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit | virtual
~CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit | virtual


ZRX API Reference: CAcUiFileDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
CAcUiFileDialog Class Reference
MFC Classes
+ Inheritance diagram for CAcUiFileDialog:

Public Types

enum | { IDD = 0 }
- Public Types inherited from CAdUiFileDialog
enum | { IDD = 0 }

Public Member Functions

virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAcUiFileDialog (BOOL bOpenFileDialog, LPCTSTR lpszDefExt=NULL, LPCTSTR lpszFileName=NULL, DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT, LPCTSTR lpszFilter=NULL, CWnd *pParentWnd=NULL)
virtual void | EnableFloatingWindows (BOOL allow)
- Public Member Functions inherited from CAdUiFileDialog
CAdUiFileDialog (BOOL bOpenFileDialog, LPCTSTR lpszDefExt=NULL, LPCTSTR lpszFileName=NULL, DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT, LPCTSTR lpszFilter=NULL, CWnd *pParentWnd=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
void | GetDialogHelpTag (CString &tag)
HICON | GetDialogIcon ()
void | GetDialogName (CString &name)
BOOL | GetUseTips ()
virtual void | OnDialogHelp ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogIcon (HICON hIcon)
void | SetDialogName (LPCTSTR name)
void | SetUseTips (BOOL useTips)

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
virtual void | OnCancel ()
virtual void | OnOK ()
- Protected Member Functions inherited from CAdUiFileDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Additional Inherited Members

- Protected Attributes inherited from CAdUiFileDialog
BOOL | m_bUseTips
ADUI_COMMAND_STATE | m_commandState
CString | m_contextHelpFileName
CString | m_contextHelpFullPathName
CString | m_contextHelpPrefix
HINSTANCE | m_hDialogResource
HICON | m_hIcon
CWnd * | m_pParent
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey
The documentation for this class was generated from the following file:
  • acuiDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiFileDialog Member List

This is the complete list of members for CAcUiFileDialog, including all inherited members.

AppMainWindow() (defined in CAcUiFileDialog) | CAcUiFileDialog | virtual
AppResourceInstance() (defined in CAcUiFileDialog) | CAcUiFileDialog | virtual
AppRootKey() (defined in CAcUiFileDialog) | CAcUiFileDialog | virtual
BeginEditorCommand() (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
CAcUiFileDialog(BOOL bOpenFileDialog, LPCTSTR lpszDefExt=NULL, LPCTSTR lpszFileName=NULL, DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT, LPCTSTR lpszFilter=NULL, CWnd *pParentWnd=NULL) (defined in CAcUiFileDialog) | CAcUiFileDialog |
CAdUiFileDialog(BOOL bOpenFileDialog, LPCTSTR lpszDefExt=NULL, LPCTSTR lpszFileName=NULL, DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT, LPCTSTR lpszFilter=NULL, CWnd *pParentWnd=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiFileDialog) | CAdUiFileDialog |
CancelEditorCommand() (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAcUiFileDialog) | CAcUiFileDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
DoModal() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
EditorCommandCancelled() (defined in CAdUiFileDialog) | CAdUiFileDialog |
EnableFloatingWindows(BOOL allow) (defined in CAcUiFileDialog) | CAcUiFileDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
GetContextHelpFileName() (defined in CAdUiFileDialog) | CAdUiFileDialog |
GetContextHelpFullPathName() (defined in CAdUiFileDialog) | CAdUiFileDialog |
GetContextHelpPrefix() (defined in CAdUiFileDialog) | CAdUiFileDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiFileDialog) | CAdUiFileDialog | inline
GetDialogIcon() (defined in CAdUiFileDialog) | CAdUiFileDialog |
GetDialogName(CString &name) (defined in CAdUiFileDialog) | CAdUiFileDialog | inline
GetUseTips() (defined in CAdUiFileDialog) | CAdUiFileDialog |
IDD enum value (defined in CAcUiFileDialog) | CAcUiFileDialog |
m_bUseTips (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_commandState (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_contextHelpFileName (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_contextHelpFullPathName (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_contextHelpPrefix (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_hDialogResource (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_hIcon (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_pParent (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_pTextTip (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_pToolTip (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_rootKey (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnCancel() (defined in CAcUiFileDialog) | CAcUiFileDialog | protectedvirtual
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnDialogHelp() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnInitDialog() (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnOK() (defined in CAcUiFileDialog) | CAcUiFileDialog | protectedvirtual
PostNcDestroy() (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiFileDialog) | CAdUiFileDialog | inline
SetDialogIcon(HICON hIcon) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetUseTips(BOOL useTips) (defined in CAdUiFileDialog) | CAdUiFileDialog |
~CAcUiFileDialog() (defined in CAcUiFileDialog) | CAcUiFileDialog | virtual
~CAdUiFileDialog() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual


ZRX API Reference: CAcUiLineTypeComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAcUiLineTypeComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiLineTypeComboBox:

Public Member Functions

void | AddItems ()
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
void | emptyLTypeLocalList ()
void | forceSelectOther (BOOL isOther2)
bool | getDbReload ()
int | getLastSelection ()
AcDbObjectId | getOIDCurSel ()
AcDbObjectId | getOIDSel (int sel)
bool | isOtherSelected ()
virtual void | OnComboBoxInit ()
void | setCurSelByOID (const AcDbObjectId &oidCurSel)
void | setDbReload (bool bReload)
- Public Member Functions inherited from CAcUiMRUComboBox
int | AddItemToList (LPCTSTR name, INT_PTR cargo)
int | AddItemToMRU (LPCTSTR name, int cargo)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
virtual int | ExtraWidth ()
int | FindItemByCargo (INT_PTR cargo)
int | GetCargoOption1 ()
int | GetCargoOption2 ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
INT_PTR | GetCurrentItemCargo ()
virtual BOOL | GetItemColors (DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor)
LOGPALETTE * | GetLogPalette ()
HPALETTE | GetPalette ()
BOOL | GetUseByBlock ()
BOOL | GetUseByLayer ()
BOOL | GetUseOption1 ()
BOOL | GetUseOption2 ()
BOOL | GetUseOther ()
BOOL | GetUseOther1 ()
BOOL | GetUseOther2 ()
BOOL | GetUseWindows ()
int | InsertItemInList (int index, LPCTSTR name, INT_PTR cargo)
int | ItemHeight ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | RecalcHeight ()
void | RemoveItemFromMRU (int cargo)
void | SetCargoOption1 (int cargo)
void | SetCargoOption2 (int cargo)
void | SetLastSelection (int sel)
void | SetLogPalette (LOGPALETTE *logPalette)
void | SetPalette (HPALETTE hPalette)
void | SetUseByBlock (BOOL use)
void | SetUseByLayer (BOOL use)
void | SetUseOption1 (BOOL use)
void | SetUseOption2 (BOOL use)
void | SetUseOther (BOOL use)
void | SetUseOther1 (BOOL use)
void | SetUseOther2 (BOOL use)
void | SetUseWindows (BOOL use)
- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

int | AddLTypeToControl (CAcUiLTypeRecord *pLTypeRecord)
CAcUiLTypeRecord * | CreateLTRecord (CString &cstrLTName, AcDbObjectId &oidLT)
virtual void | DrawItemImage (CDC &dc, CRect &r, INT_PTR cargo)
int | FindItemByCargo (AcDbObjectId cargo)
INT_PTR | GetItemCargo (int item)
AcDbDatabase * | getLTLocalMapDB ()
virtual int | ImageWidth ()
void | LoadContentsFromDatabase ()
virtual void | OnAddItems ()
virtual BOOL | OnSelectOther (BOOL isOther2, int curSel, int &newSel)
void | setLTLocalMapDB (AcDbDatabase *pDb)
void | ShowLTypes (bool bForceReloadDB=false)
- Protected Member Functions inherited from CAcUiMRUComboBox
virtual int | CalcItemHeight ()
void | CreateAndSelectPalette (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc)
void | DrawItemImageFromCargo (CDC *dc, CRect &r, int i)
void | DrawTextAndFocusRect (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor)
BOOL | FindCargoInMRU (int cargo)
int | GenerateCargoFromMRU (int seed)
virtual BOOL | GetOptionName (BOOL isOption2, CString &name)
virtual BOOL | GetOtherName (BOOL isOther2, CString &name)
afx_msg BOOL | OnCloseUp ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnDropDown ()
virtual BOOL | OnGetTipRect (CRect &r)
afx_msg BOOL | OnSelEndOk ()
virtual void | PreSubclassWindow ()
void | ResetAndRestorePalette (CDC *dc, int savedState)
void | SelectOther (BOOL isOther2)
void | SetupForImageDraw (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor)
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam)

Protected Attributes

bool | m_bDbReload
CObList | m_LTypeLocalList
AcDbDatabase * | m_pLTLocalMapDB
- Protected Attributes inherited from CAcUiMRUComboBox
BOOL | m_bIsDynamicCreation: 1
BOOL | m_bOther1Selected: 1
BOOL | m_bOther2Selected: 1
BOOL | m_bUseOption1: 1
BOOL | m_bUseOption2: 1
BOOL | m_bUseOther1: 1
BOOL | m_bUseOther2: 1
int | m_cargoOption1
int | m_cargoOption2
HPALETTE | m_hPalette
int | m_itemHeight
int | m_lastSelection
LOGPALETTE * | m_logPalette
int | m_mruCargo [ACUI_MAX_COMBOBOX_MRU]
int | m_mruLen
CString | m_mruName [ACUI_MAX_COMBOBOX_MRU]
CPalette * | m_pOldPalette
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiLineTypeComboBox Member List

This is the complete list of members for CAcUiLineTypeComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
AddItems() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox |
AddItemToList(LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToMRU(LPCTSTR name, int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddLTypeToControl(CAcUiLTypeRecord *pLTypeRecord) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiLineTypeComboBox() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox |
CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
CalcItemHeight() | CAcUiMRUComboBox | protectedvirtual
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
CreateAndSelectPalette(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
CreateLTRecord(CString &cstrLTName, AcDbObjectId &oidLT) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | virtual
DrawItemImage(CDC &dc, CRect &r, INT_PTR cargo) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protectedvirtual
DrawItemImageFromCargo(CDC *dc, CRect &r, int i) | CAcUiMRUComboBox | protected
DrawTextAndFocusRect(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
emptyLTypeLocalList() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox |
ExtraWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
FindCargoInMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
FindItemByCargo(AcDbObjectId cargo) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
FindItemByCargo(INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
forceSelectOther(BOOL isOther2) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | inline
GenerateCargoFromMRU(int seed) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetCargoOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCargoOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetCurrentItemCargo() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
getDbReload() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | inline
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetItemCargo(int item) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
GetItemColors(DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
getLastSelection() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | inline
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLogPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
getLTLocalMapDB() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
getOIDCurSel() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | inline
getOIDSel(int sel) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | inline
GetOptionName(BOOL isOption2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetOtherName(BOOL isOther2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
GetUseByBlock() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseByLayer() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseWindows() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ImageWidth() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protectedvirtual
InsertItemInList(int index, LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
isOtherSelected() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | inline
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
ItemHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
LoadContentsFromDatabase() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bDbReload (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
m_bIsDynamicCreation (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther1Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther2Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bUseOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_hPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_itemHeight (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastSelection (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_logPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_LTypeLocalList (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
m_mruCargo (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruLen (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruName (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pLTLocalMapDB (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
m_pOldPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
OnAddItems() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protectedvirtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCloseUp() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnComboBoxInit() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | virtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDropDown() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnGetTipRect(CRect &r) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnSelectOther(BOOL isOther2, int curSel, int &newSel) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protectedvirtual
OnSelEndOk() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
PreSubclassWindow() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
RecalcHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
RemoveItemFromMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ResetAndRestorePalette(CDC *dc, int savedState) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SelectOther(BOOL isOther2) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetCargoOption1(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetCargoOption2(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
setCurSelByOID(const AcDbObjectId &oidCurSel) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | inline
setDbReload(bool bReload) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | inline
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLastSelection(int sel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLogPalette(LOGPALETTE *logPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
setLTLocalMapDB(AcDbDatabase *pDb) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
SetPalette(HPALETTE hPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
SetupForImageDraw(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetUseByBlock(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseByLayer(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseWindows(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ShowLTypes(bool bForceReloadDB=false) (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | protected
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
WindowProc(UINT message, WPARAM wParam, LPARAM lParam) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiLineTypeComboBox() (defined in CAcUiLineTypeComboBox) | CAcUiLineTypeComboBox | virtual
~CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiLineWeightComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAcUiLineWeightComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiLineWeightComboBox:

Public Member Functions

int | FindItemByLineWeight (int lw)
int | GetCurrentItemLineWeight ()
int | GetCurrentLayerLineWeight ()
int | GetItemLineWeight (int item)
double | GetLineWeightScale ()
virtual int | ImageWidth ()
void | SetLineWeightScale (double scale)
void | SetUseDefault (BOOL b)
- Public Member Functions inherited from CAcUiMRUComboBox
void | AddItems ()
int | AddItemToList (LPCTSTR name, INT_PTR cargo)
int | AddItemToMRU (LPCTSTR name, int cargo)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual int | ExtraWidth ()
int | FindItemByCargo (INT_PTR cargo)
int | GetCargoOption1 ()
int | GetCargoOption2 ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
INT_PTR | GetCurrentItemCargo ()
INT_PTR | GetItemCargo (int item)
virtual BOOL | GetItemColors (DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor)
LOGPALETTE * | GetLogPalette ()
HPALETTE | GetPalette ()
BOOL | GetUseByBlock ()
BOOL | GetUseByLayer ()
BOOL | GetUseOption1 ()
BOOL | GetUseOption2 ()
BOOL | GetUseOther ()
BOOL | GetUseOther1 ()
BOOL | GetUseOther2 ()
BOOL | GetUseWindows ()
int | InsertItemInList (int index, LPCTSTR name, INT_PTR cargo)
int | ItemHeight ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | RecalcHeight ()
void | RemoveItemFromMRU (int cargo)
void | SetCargoOption1 (int cargo)
void | SetCargoOption2 (int cargo)
void | SetLastSelection (int sel)
void | SetLogPalette (LOGPALETTE *logPalette)
void | SetPalette (HPALETTE hPalette)
void | SetUseByBlock (BOOL use)
void | SetUseByLayer (BOOL use)
void | SetUseOption1 (BOOL use)
void | SetUseOption2 (BOOL use)
void | SetUseOther (BOOL use)
void | SetUseOther1 (BOOL use)
void | SetUseOther2 (BOOL use)
void | SetUseWindows (BOOL use)
- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

virtual void | DrawItemImage (CDC &dc, CRect &r, INT_PTR cargo)
virtual void | OnAddItems ()
- Protected Member Functions inherited from CAcUiMRUComboBox
virtual int | CalcItemHeight ()
void | CreateAndSelectPalette (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc)
void | DrawItemImageFromCargo (CDC *dc, CRect &r, int i)
void | DrawTextAndFocusRect (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor)
BOOL | FindCargoInMRU (int cargo)
int | GenerateCargoFromMRU (int seed)
virtual BOOL | GetOptionName (BOOL isOption2, CString &name)
virtual BOOL | GetOtherName (BOOL isOther2, CString &name)
afx_msg BOOL | OnCloseUp ()
virtual void | OnComboBoxInit ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnDropDown ()
virtual BOOL | OnGetTipRect (CRect &r)
virtual BOOL | OnSelectOther (BOOL isOther2, int curSel, int &newSel)
afx_msg BOOL | OnSelEndOk ()
virtual void | PreSubclassWindow ()
void | ResetAndRestorePalette (CDC *dc, int savedState)
void | SelectOther (BOOL isOther2)
void | SetupForImageDraw (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor)
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam)

Protected Attributes

double | m_lineWeightScale
- Protected Attributes inherited from CAcUiMRUComboBox
BOOL | m_bIsDynamicCreation: 1
BOOL | m_bOther1Selected: 1
BOOL | m_bOther2Selected: 1
BOOL | m_bUseOption1: 1
BOOL | m_bUseOption2: 1
BOOL | m_bUseOther1: 1
BOOL | m_bUseOther2: 1
int | m_cargoOption1
int | m_cargoOption2
HPALETTE | m_hPalette
int | m_itemHeight
int | m_lastSelection
LOGPALETTE * | m_logPalette
int | m_mruCargo [ACUI_MAX_COMBOBOX_MRU]
int | m_mruLen
CString | m_mruName [ACUI_MAX_COMBOBOX_MRU]
CPalette * | m_pOldPalette
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiLineWeightComboBox Member List

This is the complete list of members for CAcUiLineWeightComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
AddItems() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToList(LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToMRU(LPCTSTR name, int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiLineWeightComboBox() (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox |
CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
CalcItemHeight() | CAcUiMRUComboBox | protectedvirtual
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
CreateAndSelectPalette(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
DrawItemImage(CDC &dc, CRect &r, INT_PTR cargo) (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox | protectedvirtual
DrawItemImageFromCargo(CDC *dc, CRect &r, int i) | CAcUiMRUComboBox | protected
DrawTextAndFocusRect(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
ExtraWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
FindCargoInMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
FindItemByCargo(INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
FindItemByLineWeight(int lw) (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox |
GenerateCargoFromMRU(int seed) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetCargoOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCargoOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetCurrentItemCargo() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCurrentItemLineWeight() (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox |
GetCurrentLayerLineWeight() (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox |
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetItemCargo(int item) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetItemColors(DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetItemLineWeight(int item) (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox |
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetLineWeightScale() (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLogPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetOptionName(BOOL isOption2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetOtherName(BOOL isOther2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
GetUseByBlock() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseByLayer() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseWindows() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ImageWidth() (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox | virtual
InsertItemInList(int index, LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
ItemHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bIsDynamicCreation (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther1Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther2Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bUseOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_hPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_itemHeight (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastSelection (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lineWeightScale (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox | protected
m_logPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruCargo (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruLen (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruName (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pOldPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
OnAddItems() (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox | protectedvirtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCloseUp() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnComboBoxInit() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDropDown() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnGetTipRect(CRect &r) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnSelectOther(BOOL isOther2, int curSel, int &newSel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnSelEndOk() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
PreSubclassWindow() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
RecalcHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
RemoveItemFromMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ResetAndRestorePalette(CDC *dc, int savedState) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SelectOther(BOOL isOther2) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetCargoOption1(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetCargoOption2(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLastSelection(int sel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetLineWeightScale(double scale) (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLogPalette(LOGPALETTE *logPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetPalette(HPALETTE hPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
SetupForImageDraw(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetUseByBlock(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseByLayer(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseDefault(BOOL b) (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox |
SetUseOption1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseWindows(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
WindowProc(UINT message, WPARAM wParam, LPARAM lParam) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiLineWeightComboBox() (defined in CAcUiLineWeightComboBox) | CAcUiLineWeightComboBox | virtual
~CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiLTypeRecord Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcUiLTypeRecord Class Reference
MFC Classes

Public Member Functions

BOOL | isDependent ()
CString & | ltypeName ()
AcDbObjectId | objectId ()
void | setIsDependent (BOOL bValue)
void | setLTypeName (CString sName)
void | setObjectId (AcDbObjectId id)
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiLTypeRecord Member List

This is the complete list of members for CAcUiLTypeRecord, including all inherited members.

isDependent() (defined in CAcUiLTypeRecord) | CAcUiLTypeRecord | inline
ltypeName() (defined in CAcUiLTypeRecord) | CAcUiLTypeRecord | inline
objectId() (defined in CAcUiLTypeRecord) | CAcUiLTypeRecord | inline
setIsDependent(BOOL bValue) (defined in CAcUiLTypeRecord) | CAcUiLTypeRecord | inline
setLTypeName(CString sName) (defined in CAcUiLTypeRecord) | CAcUiLTypeRecord | inline
setObjectId(AcDbObjectId id) (defined in CAcUiLTypeRecord) | CAcUiLTypeRecord | inline


ZRX API Reference: CAcUiMRUComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAcUiMRUComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiMRUComboBox:

Public Member Functions

void | AddItems ()
int | AddItemToList (LPCTSTR name, INT_PTR cargo)
int | AddItemToMRU (LPCTSTR name, int cargo)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual int | ExtraWidth ()
int | FindItemByCargo (INT_PTR cargo)
int | GetCargoOption1 ()
int | GetCargoOption2 ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
INT_PTR | GetCurrentItemCargo ()
INT_PTR | GetItemCargo (int item)
virtual BOOL | GetItemColors (DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor)
LOGPALETTE * | GetLogPalette ()
HPALETTE | GetPalette ()
BOOL | GetUseByBlock ()
BOOL | GetUseByLayer ()
BOOL | GetUseOption1 ()
BOOL | GetUseOption2 ()
BOOL | GetUseOther ()
BOOL | GetUseOther1 ()
BOOL | GetUseOther2 ()
BOOL | GetUseWindows ()
virtual int | ImageWidth ()
int | InsertItemInList (int index, LPCTSTR name, INT_PTR cargo)
int | ItemHeight ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | RecalcHeight ()
void | RemoveItemFromMRU (int cargo)
void | SetCargoOption1 (int cargo)
void | SetCargoOption2 (int cargo)
void | SetLastSelection (int sel)
void | SetLogPalette (LOGPALETTE *logPalette)
void | SetPalette (HPALETTE hPalette)
void | SetUseByBlock (BOOL use)
void | SetUseByLayer (BOOL use)
void | SetUseOption1 (BOOL use)
void | SetUseOption2 (BOOL use)
void | SetUseOther (BOOL use)
void | SetUseOther1 (BOOL use)
void | SetUseOther2 (BOOL use)
void | SetUseWindows (BOOL use)
- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

virtual int | CalcItemHeight ()
void | CreateAndSelectPalette (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc)
virtual void | DrawItemImage (CDC &dc, CRect &r, INT_PTR cargo)
void | DrawItemImageFromCargo (CDC *dc, CRect &r, int i)
void | DrawTextAndFocusRect (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor)
BOOL | FindCargoInMRU (int cargo)
int | GenerateCargoFromMRU (int seed)
virtual BOOL | GetOptionName (BOOL isOption2, CString &name)
virtual BOOL | GetOtherName (BOOL isOther2, CString &name)
virtual void | OnAddItems ()
afx_msg BOOL | OnCloseUp ()
virtual void | OnComboBoxInit ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnDropDown ()
virtual BOOL | OnGetTipRect (CRect &r)
virtual BOOL | OnSelectOther (BOOL isOther2, int curSel, int &newSel)
afx_msg BOOL | OnSelEndOk ()
virtual void | PreSubclassWindow ()
void | ResetAndRestorePalette (CDC *dc, int savedState)
void | SelectOther (BOOL isOther2)
void | SetupForImageDraw (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor)
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam)

Protected Attributes

BOOL | m_bIsDynamicCreation: 1
BOOL | m_bOther1Selected: 1
BOOL | m_bOther2Selected: 1
BOOL | m_bUseOption1: 1
BOOL | m_bUseOption2: 1
BOOL | m_bUseOther1: 1
BOOL | m_bUseOther2: 1
int | m_cargoOption1
int | m_cargoOption2
HPALETTE | m_hPalette
int | m_itemHeight
int | m_lastSelection
LOGPALETTE * | m_logPalette
int | m_mruCargo [ACUI_MAX_COMBOBOX_MRU]
int | m_mruLen
CString | m_mruName [ACUI_MAX_COMBOBOX_MRU]
CPalette * | m_pOldPalette

Member Function Documentation

virtual int CAcUiMRUComboBox::CalcItemHeight ( )
protectedvirtual
Warning
Not implemented!
virtual void CAcUiMRUComboBox::DrawItemImage | ( | CDC & | dc,
 |  | CRect & | r,
 |  | INT_PTR | cargo
 | ) |  |
protectedvirtual
Warning
Not implemented!
void CAcUiMRUComboBox::DrawItemImageFromCargo | ( | CDC * | dc,
 |  | CRect & | r,
 |  | int | i
 | ) |  |
protected
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiMRUComboBox Member List

This is the complete list of members for CAcUiMRUComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
AddItems() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToList(LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToMRU(LPCTSTR name, int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
CalcItemHeight() | CAcUiMRUComboBox | protectedvirtual
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
CreateAndSelectPalette(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
DrawItemImage(CDC &dc, CRect &r, INT_PTR cargo) | CAcUiMRUComboBox | protectedvirtual
DrawItemImageFromCargo(CDC *dc, CRect &r, int i) | CAcUiMRUComboBox | protected
DrawTextAndFocusRect(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
ExtraWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
FindCargoInMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
FindItemByCargo(INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GenerateCargoFromMRU(int seed) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetCargoOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCargoOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetCurrentItemCargo() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetItemCargo(int item) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetItemColors(DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLogPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetOptionName(BOOL isOption2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetOtherName(BOOL isOther2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
GetUseByBlock() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseByLayer() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseWindows() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ImageWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
InsertItemInList(int index, LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
ItemHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bIsDynamicCreation (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther1Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther2Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bUseOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_hPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_itemHeight (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastSelection (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_logPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruCargo (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruLen (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruName (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pOldPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
OnAddItems() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCloseUp() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnComboBoxInit() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDropDown() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnGetTipRect(CRect &r) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnSelectOther(BOOL isOther2, int curSel, int &newSel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnSelEndOk() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
PreSubclassWindow() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
RecalcHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
RemoveItemFromMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ResetAndRestorePalette(CDC *dc, int savedState) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SelectOther(BOOL isOther2) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetCargoOption1(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetCargoOption2(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLastSelection(int sel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLogPalette(LOGPALETTE *logPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetPalette(HPALETTE hPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
SetupForImageDraw(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetUseByBlock(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseByLayer(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseWindows(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
WindowProc(UINT message, WPARAM wParam, LPARAM lParam) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiMRUListBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAcUiMRUListBox Class Reference
MFC Classes

Public Member Functions

virtual void GetContentExtent (int item, LPCTSTR text, int &width, int &height)

Protected Member Functions

int | ExtraWidth ()
CAcUiMRUComboBox * | MRUComboBox ()
virtual BOOL | OnGetTipRect (CRect &r)

Member Function Documentation

virtual BOOL CAcUiMRUListBox::OnGetTipRect ( CRect & r )
protectedvirtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiMRUListBox Member List

This is the complete list of members for CAcUiMRUListBox, including all inherited members.

CAcUiMRUListBox() (defined in CAcUiMRUListBox) | CAcUiMRUListBox |
ExtraWidth() (defined in CAcUiMRUListBox) | CAcUiMRUListBox | protected
GetContentExtent(int item, LPCTSTR text, int &width, int &height) (defined in CAcUiMRUListBox) | CAcUiMRUListBox | virtual
MRUComboBox() (defined in CAcUiMRUListBox) | CAcUiMRUListBox | protected
OnGetTipRect(CRect &r) | CAcUiMRUListBox | protectedvirtual
~CAcUiMRUListBox() (defined in CAcUiMRUListBox) | CAcUiMRUListBox | virtual


ZRX API Reference: CAcUiNavDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAcUiNavDialog Class Reference
MFC Classes
+ Inheritance diagram for CAcUiNavDialog:

Public Member Functions

virtual BOOL | BeginDownloadFiles (CStringArray &strURLs, CDWordArray &dwActionCodes)
CAcUiNavDialog (CNavDataArray &dataArray, CNavFilterArray &filterArray, UINT idd=0, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
void | ConvertFlagsToState (int nFlags)
virtual void | DisplaySearchError (LPCTSTR sBase)
virtual BOOL | FindInSearchPath (LPCTSTR sBase, CString *pFullPath)
virtual void | GetDefaultBrowserStartURL (CString &strStartPage)
virtual DWORD | GetDownloadActionCodes (CString &strURL)
BOOL | GetInitialViewButtonChecked ()
AcUiOpenNoTemplateFlag | GetOpenNoTemplateSelection ()
BOOL | GetPreviewPresent ()
BOOL | GetPreviewVisible ()
virtual BOOL | GetProductName (CString &strProduct)
virtual BOOL | GetRecentDirectory (CString &strRecent)
short | GetUpdateThumbnailOverride ()
virtual BOOL | LaunchBrowserDialog (CString &strSelectedURL, LPCTSTR strDialogCaption, LPCTSTR strOk, LPCTSTR strStartPage)
virtual void | OnDialogHelp ()
virtual void | OnDialogHelp (LPCTSTR pTag)
virtual void | OnDoLocate ()
virtual BOOL | OnInitDialog ()
virtual void | OnPaintPreview (LPCTSTR strFullPath, CWnd *previewWnd)
void | SetPreviewPresent (BOOL preview)
void | SetPreviewVisible (BOOL visible)
- Public Member Functions inherited from CNavDialog
void | AddDataToHistory ()
void | BrowseCurrentObject ()
CNavDialog (CNavDataArray &dataArray, CNavFilterArray &filterArray, UINT idd=0, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | GetAcceptAnyFileExtension ()
virtual BOOL | GetAllDialogsData (const CString &cValueName, CString &cValue)
virtual BOOL | GetAllDialogsData (const CString &cValueName, DWORD &data)
BOOL | GetConfirmReplace ()
BOOL | GetCreatingFile ()
CNavFilter * | GetCurrentFileExtension (CString &strExt)
void | GetCurrentFolderForPersistence (CString &strFolder)
CNavDataArray & GetDataArray ()
LPCTSTR | GetDefaultFileExtension ()
int | GetDefaultFilterIndex ()
LPCTSTR | GetDefaultInitialFolder ()
LPCTSTR | GetDialogCaption ()
CNavFilterArray & GetFilterArray ()
int | GetFilterIndex ()
CNavListCtrl * GetFolderListCtrl ()
BOOL | GetFoldersOnly ()
int | GetForceFilterIndex ()
LPCTSTR | GetForceInitialFolder ()
UINT | GetIDD ()
void * | GetImpObject () const
LPCTSTR | GetInitialFileName ()
DWORD | GetInitialFilterIndex ()
BOOL | GetMultiSelectAllowed ()
BOOL | GetNoExtraExtensions ()
BOOL | GetNoExtraExtensionsInPlaces ()
BOOL | GetNoFTP ()
BOOL | GetNoPlacesList ()
BOOL | GetNoURLFileTransfer ()
BOOL | GetNoURLsAllowed ()
void | GetOkButtonText (CString &strOk, BOOL bIncludeAccel=TRUE)
BOOL | GetPersonalFolderPath (CString &strPersonal)
BOOL | GetReadOnlyAllowed ()
BOOL | GetReadOnlyHidden ()
BOOL | GetReadOnlySpecified ()
void | GetSingleDataFullPath (CString &strFullPath)
int | GetToolsMenuItemPosition (NavToolsMenuItem itemFlag)
UINT | GetToolsMenuItemsPresent ()
BOOL | GetUseRegExtensionFlags ()
UINT | GetViewMode ()
int | InsertUserItemInPlaces (int index, LPCTSTR sFullPath, LPCTSTR sText)
virtual void | LocateFile ()
BOOL | NavigateToFolder (LPCTSTR sFolder)
void | SetAcceptAnyFileExtension (BOOL any)
virtual BOOL | SetAllDialogsData (const CString &cValueName, CString &cValue)
virtual BOOL | SetAllDialogsData (const CString &cValueName, DWORD dwValue)
void | SetConfirmReplace (BOOL confirm)
void | SetCreatingFile (BOOL create)
void | SetDefaultFileExtension (LPCTSTR ext)
void | SetDefaultFilterIndex (int index)
void | SetDefaultInitialFolder (LPCTSTR folder)
void | SetDialogCaption (LPCTSTR caption)
void | SetFilterIndex (int index)
void | SetFolderComboCurSel (int i)
void | SetFolderListCtrl (CNavListCtrl *folderListCtrl)
void | SetFoldersOnly (BOOL foldersOnly)
void | SetForceFilterIndex (int index)
void | SetForceInitialFolder (LPCTSTR folder)
void | SetInitialFileName (LPCTSTR name)
void | SetMultiSelectAllowed (BOOL allow)
void | SetNoExtraExtensions (BOOL noExtraExtensions)
void | SetNoExtraExtensionsInPlaces (BOOL noExtraExtensions)
void | SetNoFTP (BOOL noFTP)
void | SetNoURLFileTransfer (BOOL noTransfer)
void | SetNoURLsAllowed (BOOL noURLs)
void | SetOkButtonMenuExists (BOOL bExists)
void | SetOkButtonText (LPCTSTR text)
void | SetReadOnlyAllowed (BOOL allow)
void | SetReadOnlyHidden (BOOL hidden)
void | SetReadOnlySpecified (BOOL readOnly)
void | SetToolsMenuItemsPresent (UINT flag)
void | SetUseRegExtensionFlags (BOOL bUse)
void | SetViewMode (UINT viewMode)
void | TrimWhiteSpace (CString &strName, BOOL bAll)
virtual | ~CNavDialog ()
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

void | Do3DDwfOptionsDialog ()
virtual BOOL | GetOptionsState ()
void | InitPreviewState ()
virtual void | OnCancel ()
afx_msg void | OnDestroy ()
virtual void | OnFileNameChange ()
virtual BOOL | OnFileNameOK ()
virtual void | OnFilterChange ()
virtual void | OnFolderItemChange ()
afx_msg void | OnOpenMenuPartialOpen ()
afx_msg void | OnOpenMenuPartialOpenReadOnly ()
afx_msg void | OnOpenNoTemplateImperial ()
afx_msg void | OnOpenNoTemplateMetric ()
afx_msg void | OnToolsMenuOptions ()
afx_msg void | OnToolsMenuSecurity ()
afx_msg void | OnUpdateThumbnailCheck ()
virtual void | OnURLDownloadSuccess (CString &strURL)
afx_msg void | OnViewsMenuPreview ()
virtual void | PrepareOkMenu (CMenu *pMenu)
virtual void | PrepareToolsMenu (CMenu *pMenu)
virtual void | PrepareViewsMenu (CMenu *pMenu)
- Protected Member Functions inherited from CNavDialog
virtual OkHandlerErr | CombineDataTextWithFolderName (CNavData *data, CString &strResult)
virtual void | DoDataExchange (CDataExchange *pDX)
virtual BOOL | OnCmdMsg (UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo)
afx_msg void | OnContextMenu (CWnd *, CPoint)
virtual void | OnDoFind ()
virtual void | OnFileNameSelectionChange ()
virtual void | OnFolderChange ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)
afx_msg void | OnKickIdle ()
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual void | OnOK ()
afx_msg void | OnSysColorChange ()
virtual BOOL | OnUrlOK ()
virtual OkHandlerErr | PreprocessData (CNavDataArray &array)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
virtual void | Refresh ()
virtual BOOL | ReportURLTransferStatus (CDWordArray &dwErrorArray, CStringArray &strURLs, CStringArray &strLocals)
virtual BOOL | UpdateFileExtension (CString &strName, BOOL bCanUseCurrentExtension)
virtual void | UpdateUIState ()
virtual BOOL | VerifyURLSave ()
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Additional Inherited Members

- Public Types inherited from CNavDialog
enum | { IDD = 0 }
- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist

Member Function Documentation

afx_msg void CAcUiNavDialog::OnToolsMenuOptions ( )
protected
Warning
Not implemented!
void CAcUiNavDialog::SetPreviewVisible ( BOOL visible )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acuiNavDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiNavDialog Member List

This is the complete list of members for CAcUiNavDialog, including all inherited members.

AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AddDataToHistory() | CNavDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginDownloadFiles(CStringArray &strURLs, CDWordArray &dwActionCodes) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
BrowseCurrentObject() | CNavDialog |
CAcUiNavDialog(CNavDataArray &dataArray, CNavFilterArray &filterArray, UINT idd=0, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAcUiNavDialog) | CAcUiNavDialog |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CNavDialog(CNavDataArray &dataArray, CNavFilterArray &filterArray, UINT idd=0, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) | CNavDialog |
CombineDataTextWithFolderName(CNavData *data, CString &strResult) | CNavDialog | protectedvirtual
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
ConvertFlagsToState(int nFlags) (defined in CAcUiNavDialog) | CAcUiNavDialog |
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplaySearchError(LPCTSTR sBase) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
Do3DDwfOptionsDialog() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) | CNavDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
FindInSearchPath(LPCTSTR sBase, CString *pFullPath) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetAcceptAnyFileExtension() | CNavDialog |
GetAllDialogsData(const CString &cValueName, CString &cValue) | CNavDialog | virtual
GetAllDialogsData(const CString &cValueName, DWORD &data) | CNavDialog | virtual
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetConfirmReplace() | CNavDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCreatingFile() | CNavDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetCurrentFileExtension(CString &strExt) | CNavDialog |
GetCurrentFolderForPersistence(CString &strFolder) | CNavDialog |
GetDataArray() | CNavDialog |
GetDefaultBrowserStartURL(CString &strStartPage) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
GetDefaultFileExtension() | CNavDialog |
GetDefaultFilterIndex() | CNavDialog |
GetDefaultInitialFolder() | CNavDialog |
GetDialogCaption() | CNavDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetDownloadActionCodes(CString &strURL) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetFilterArray() | CNavDialog |
GetFilterIndex() | CNavDialog |
GetFolderListCtrl() | CNavDialog |
GetFoldersOnly() | CNavDialog |
GetForceFilterIndex() | CNavDialog |
GetForceInitialFolder() | CNavDialog |
GetIDD() | CNavDialog |
GetImpObject() const | CNavDialog |
GetInitialFileName() | CNavDialog |
GetInitialFilterIndex() | CNavDialog |
GetInitialViewButtonChecked() (defined in CAcUiNavDialog) | CAcUiNavDialog |
GetMultiSelectAllowed() | CNavDialog |
GetNoExtraExtensions() | CNavDialog |
GetNoExtraExtensionsInPlaces() | CNavDialog |
GetNoFTP() | CNavDialog |
GetNoPlacesList() | CNavDialog |
GetNoURLFileTransfer() | CNavDialog |
GetNoURLsAllowed() | CNavDialog |
GetOkButtonText(CString &strOk, BOOL bIncludeAccel=TRUE) | CNavDialog |
GetOpenNoTemplateSelection() (defined in CAcUiNavDialog) | CAcUiNavDialog |
GetOptionsState() (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
GetPersonalFolderPath(CString &strPersonal) | CNavDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetPreviewPresent() (defined in CAcUiNavDialog) | CAcUiNavDialog |
GetPreviewVisible() (defined in CAcUiNavDialog) | CAcUiNavDialog |
GetProductName(CString &strProduct) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
GetReadOnlyAllowed() | CNavDialog |
GetReadOnlyHidden() | CNavDialog |
GetReadOnlySpecified() | CNavDialog |
GetRecentDirectory(CString &strRecent) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
GetSingleDataFullPath(CString &strFullPath) | CNavDialog |
GetToolsMenuItemPosition(NavToolsMenuItem itemFlag) | CNavDialog |
GetToolsMenuItemsPresent() | CNavDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUpdateThumbnailOverride() (defined in CAcUiNavDialog) | CAcUiNavDialog |
GetUseRegExtensionFlags() | CNavDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetViewMode() | CNavDialog |
IDD enum value (defined in CNavDialog) | CNavDialog |
InitPreviewState() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
InsertUserItemInPlaces(int index, LPCTSTR sFullPath, LPCTSTR sText) | CNavDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LaunchBrowserDialog(CString &strSelectedURL, LPCTSTR strDialogCaption, LPCTSTR strOk, LPCTSTR strStartPage) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
LocateFile() | CNavDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
NavigateToFolder(LPCTSTR sFolder) | CNavDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnCancel() (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
OnCmdMsg(UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo) | CNavDialog | protectedvirtual
OnContextMenu(CWnd *, CPoint) | CNavDialog | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDestroy() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
OnDialogHelp() (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
OnDialogHelp(LPCTSTR pTag) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
OnDoFind() | CNavDialog | protectedvirtual
OnDoLocate() (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
OnFileNameChange() (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
OnFileNameOK() (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
OnFileNameSelectionChange() | CNavDialog | protectedvirtual
OnFilterChange() (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
OnFolderChange() | CNavDialog | protectedvirtual
OnFolderItemChange() (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *pHelpInfo) | CNavDialog | protected
OnInitDialog() (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnKickIdle() | CNavDialog | protected
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) | CNavDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) | CNavDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() | CNavDialog | protectedvirtual
OnOpenMenuPartialOpen() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
OnOpenMenuPartialOpenReadOnly() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
OnOpenNoTemplateImperial() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
OnOpenNoTemplateMetric() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
OnPaintPreview(LPCTSTR strFullPath, CWnd *previewWnd) (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDialog) | CAdUiDialog | protected
OnSysColorChange() | CNavDialog | protected
OnToolsMenuOptions() | CAcUiNavDialog | protected
OnToolsMenuSecurity() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
OnUpdateThumbnailCheck() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
OnURLDownloadSuccess(CString &strURL) (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
OnUrlOK() | CNavDialog | protectedvirtual
OnViewsMenuPreview() (defined in CAcUiNavDialog) | CAcUiNavDialog | protected
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PrepareOkMenu(CMenu *pMenu) (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
PrepareToolsMenu(CMenu *pMenu) (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
PrepareViewsMenu(CMenu *pMenu) (defined in CAcUiNavDialog) | CAcUiNavDialog | protectedvirtual
PreprocessData(CNavDataArray &array) | CNavDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) | CNavDialog | protectedvirtual
Refresh() | CNavDialog | protectedvirtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
ReportURLTransferStatus(CDWordArray &dwErrorArray, CStringArray &strURLs, CStringArray &strLocals) | CNavDialog | protectedvirtual
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAcceptAnyFileExtension(BOOL any) | CNavDialog |
SetAllDialogsData(const CString &cValueName, CString &cValue) | CNavDialog | virtual
SetAllDialogsData(const CString &cValueName, DWORD dwValue) | CNavDialog | virtual
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetConfirmReplace(BOOL confirm) | CNavDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetCreatingFile(BOOL create) | CNavDialog |
SetDefaultFileExtension(LPCTSTR ext) | CNavDialog |
SetDefaultFilterIndex(int index) | CNavDialog |
SetDefaultInitialFolder(LPCTSTR folder) | CNavDialog |
SetDialogCaption(LPCTSTR caption) | CNavDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetFilterIndex(int index) | CNavDialog |
SetFolderComboCurSel(int i) | CNavDialog |
SetFolderListCtrl(CNavListCtrl *folderListCtrl) | CNavDialog |
SetFoldersOnly(BOOL foldersOnly) | CNavDialog |
SetForceFilterIndex(int index) | CNavDialog |
SetForceInitialFolder(LPCTSTR folder) | CNavDialog |
SetInitialFileName(LPCTSTR name) | CNavDialog |
SetMultiSelectAllowed(BOOL allow) | CNavDialog |
SetNoExtraExtensions(BOOL noExtraExtensions) | CNavDialog |
SetNoExtraExtensionsInPlaces(BOOL noExtraExtensions) | CNavDialog |
SetNoFTP(BOOL noFTP) | CNavDialog |
SetNoURLFileTransfer(BOOL noTransfer) | CNavDialog |
SetNoURLsAllowed(BOOL noURLs) | CNavDialog |
SetOkButtonMenuExists(BOOL bExists) | CNavDialog |
SetOkButtonText(LPCTSTR text) | CNavDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetPreviewPresent(BOOL preview) (defined in CAcUiNavDialog) | CAcUiNavDialog |
SetPreviewVisible(BOOL visible) | CAcUiNavDialog |
SetReadOnlyAllowed(BOOL allow) | CNavDialog |
SetReadOnlyHidden(BOOL hidden) | CNavDialog |
SetReadOnlySpecified(BOOL readOnly) | CNavDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetToolsMenuItemsPresent(UINT flag) | CNavDialog |
SetUseRegExtensionFlags(BOOL bUse) | CNavDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetViewMode(UINT viewMode) | CNavDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
TrimWhiteSpace(CString &strName, BOOL bAll) | CNavDialog |
UpdateFileExtension(CString &strName, BOOL bCanUseCurrentExtension) | CNavDialog | protectedvirtual
UpdateUIState() | CNavDialog | protectedvirtual
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
VerifyURLSave() | CNavDialog | protectedvirtual
~CAcUiNavDialog() (defined in CAcUiNavDialog) | CAcUiNavDialog | virtual
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual
~CNavDialog() | CNavDialog | virtual


ZRX API Reference: CAcUiNumericComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiNumericComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiNumericComboBox:

Additional Inherited Members

- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Protected Member Functions inherited from CAdUiComboBox
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
afx_msg LRESULT | OnGetToolTipText (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
- Protected Attributes inherited from CAdUiComboBox
CWnd * | m_aduiParent
BOOL | m_bAutoDeleteEBox: 1
BOOL | m_bAutoDeleteLBox: 1
BOOL | m_bSubclassedControls: 1
CPoint | m_lastMousePoint
CAdUiEdit * | m_pComboEBox
CAdUiListBox * | m_pComboLBox
CString | m_sToolTipText
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiNumericComboBox Member List

This is the complete list of members for CAcUiNumericComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiNumericComboBox() (defined in CAcUiNumericComboBox) | CAcUiNumericComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox | virtual
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiNumericComboBox() (defined in CAcUiNumericComboBox) | CAcUiNumericComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiNumericEdit Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcUiNumericEdit Class Reference
MFC Classes
+ Inheritance diagram for CAcUiNumericEdit:

Public Member Functions

virtual void | SetStyleMask (DWORD mask)
- Public Member Functions inherited from CAcUiEdit
void | Convert ()
BOOL | ConvertData (CString &x)
BOOL | HasChanged ()
void | SetDirty ()
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiEdit
CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsStyleMaskSet (DWORD)
void | SetAdUiParent (CWnd *w)

Additional Inherited Members

- Public Attributes inherited from CAcUiEdit
BOOL | m_bChanged
BOOL | m_bTouch
CString | m_csMsg
double | m_dMaxValue
double | m_dMinValue
- Protected Member Functions inherited from CAcUiEdit
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg BOOL | OnChange ()
afx_msg void | OnErrSpace ()
afx_msg void | OnKillFocus (CWnd *pNewWnd)
- Protected Attributes inherited from CAdUiEdit
CWnd * | m_aduiParent
CPoint | m_lastMousePoint
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiEdit.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiNumericEdit Member List

This is the complete list of members for CAcUiNumericEdit, including all inherited members.

CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit |
CAcUiNumericEdit() (defined in CAcUiNumericEdit) | CAcUiNumericEdit |
CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit |
Convert() (defined in CAcUiEdit) | CAcUiEdit |
ConvertData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAcUiEdit) | CAcUiEdit | protectedvirtual
GetAdUiParent() (defined in CAdUiEdit) | CAdUiEdit |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit | virtual
GetStyleMask() (defined in CAdUiEdit) | CAdUiEdit |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit |
HasChanged() (defined in CAcUiEdit) | CAcUiEdit |
IsStyleMaskSet(DWORD) (defined in CAdUiEdit) | CAdUiEdit |
m_aduiParent (defined in CAdUiEdit) | CAdUiEdit | protected
m_bChanged (defined in CAcUiEdit) | CAcUiEdit |
m_bTouch (defined in CAcUiEdit) | CAcUiEdit |
m_csMsg (defined in CAcUiEdit) | CAcUiEdit |
m_dMaxValue (defined in CAcUiEdit) | CAcUiEdit |
m_dMinValue (defined in CAcUiEdit) | CAcUiEdit |
m_lastMousePoint (defined in CAdUiEdit) | CAdUiEdit | protected
m_styleMask (defined in CAdUiEdit) | CAdUiEdit |
m_tipRect (defined in CAdUiEdit) | CAdUiEdit | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiEdit) | CAdUiEdit | protected
OnChange() (defined in CAcUiEdit) | CAcUiEdit | protected
OnDrawTip(CDC &dc) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnErrSpace() (defined in CAcUiEdit) | CAcUiEdit | protected
OnGetTipRect(CRect &r) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAcUiEdit) | CAcUiEdit | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiEdit) | CAdUiEdit | protected
SetAdUiParent(CWnd *w) (defined in CAdUiEdit) | CAdUiEdit |
SetDirty() (defined in CAcUiEdit) | CAcUiEdit |
SetRange(double vMin, double vMax) (defined in CAcUiEdit) | CAcUiEdit |
SetStyleMask(DWORD mask) (defined in CAcUiNumericEdit) | CAcUiNumericEdit | virtual
Validate() (defined in CAcUiEdit) | CAcUiEdit |
ValidateData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
~CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit | virtual
~CAcUiNumericEdit() (defined in CAcUiNumericEdit) | CAcUiNumericEdit | virtual
~CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit | virtual


ZRX API Reference: CAcUiOwnerDrawButton Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiOwnerDrawButton Class Reference
MFC Classes
+ Inheritance diagram for CAcUiOwnerDrawButton:

Additional Inherited Members

- Public Member Functions inherited from CAdUiOwnerDrawButton
BOOL | AutoLoad ()
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
CWnd * | GetAdUiParent ()
BOOL | GetEnableDragDrop ()
BOOL | GetEnableFastDraw ()
BOOL | GetEnablePointedAt ()
BOOL | GetIsStatic ()
BOOL | GetIsToolButton ()
virtual void | PreSubclassWindow ()
BOOL | Reload (LPCTSTR strResId)
void | SetAdUiParent (CWnd *w)
void | SetEnableDragDrop (BOOL allow)
void | SetEnableFastDraw (BOOL allow)
void | SetEnablePointedAt (BOOL allow)
void | SetIsStatic (BOOL isStatic)
void | SetIsToolButton (BOOL isToolButton)
virtual CAdUiTheme * | SetTheme (CAdUiTheme *pTheme)
virtual void | SetTracking (BOOL b)
- Protected Member Functions inherited from CAdUiOwnerDrawButton
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual void | DrawBorder (CDC *pDC, CRect &r, COLORREF cr)
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
virtual void | DrawHotBorder ()
virtual void | DrawPushButtonBorder (CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected)
virtual void | DrawToolButtonBorder (CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused)
void | DrawTransparentBitmap (CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled)
BOOL | GetIsPointedAt ()
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnAutoLoad ()
afx_msg void | OnDestroy ()
virtual void | OnDragDrop (HDROP hDropInfo)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
afx_msg void | OnDropFiles (HDROP hDropInfo)
afx_msg UINT | OnGetDlgCode ()
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnKillFocus (CWnd *pNewWnd)
afx_msg LRESULT | OnMouseLeave (WPARAM, LPARAM)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
afx_msg void | OnNcDestroy ()
virtual void | OnPointedAt (BOOL isPointedAt)
virtual BOOL | OnReload (LPCTSTR strResId)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg LRESULT | OnThemeChanged (WPARAM wParam, LPARAM lParam)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
void | SetIsPointedAt (BOOL isPointedAt)
void | StartTimer (DWORD ms=50)
void | StopTimer ()
virtual void | ThemeModified (AdUiThemeElement element)
- Protected Attributes inherited from CAdUiOwnerDrawButton
CWnd * | m_aduiParent
BOOL | m_bEnableDragDrop: 1
BOOL | m_bEnableFastDraw: 1
BOOL | m_bEnablePointedAt: 1
BOOL | m_bIsPointedAt: 1
BOOL | m_bIsStatic: 1
BOOL | m_bIsToolButton: 1
BOOL | m_bIsTrackButton: 1
BOOL | m_bMouseHover
CPoint | m_lastMousePoint
int | m_nPartId
int | m_nStateId
CAdUiTheme * | m_pTheme
UINT_PTR | m_timerId
CRect | m_tipRect
UINT | m_uEdge
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • acuiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiOwnerDrawButton Member List

This is the complete list of members for CAcUiOwnerDrawButton, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAcUiOwnerDrawButton() (defined in CAcUiOwnerDrawButton) | CAcUiOwnerDrawButton |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAcUiOwnerDrawButton() (defined in CAcUiOwnerDrawButton) | CAcUiOwnerDrawButton | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAcUiPaletteSetDockFrame Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Protected Member Functions | List of all members
CAcUiPaletteSetDockFrame Class Reference
MFC Classes
+ Inheritance diagram for CAcUiPaletteSetDockFrame:

Protected Member Functions

afx_msg LRESULT | OnACADKeepFocus (WPARAM wParam, LPARAM lParam)
- Protected Member Functions inherited from CAdUiPaletteSetDockFrame
bool | CanAutoCADTakeFocus ()
bool | CanFrameworkTakeFocus ()
void | ForceChildRepaint ()
CAdUiPaletteSet * | GetPaletteSet ()
BOOL | HitTest (CPoint pt, UINT &nFlag, DWORD &dwData)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg void | OnClose ()
afx_msg void | OnContextMenu (CWnd *pWnd, CPoint pos)
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnDestroy ()
afx_msg LRESULT | OnDisplayChange (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDragEnter (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDragLeave (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDragOver (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDragScroll (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDrop (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDropEx (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnEnterSizeMove (WPARAM, LPARAM)
afx_msg BOOL | OnEraseBkgnd (CDC *pDC)
afx_msg LRESULT | OnExitSizeMove (WPARAM, LPARAM)
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
afx_msg void | OnLButtonDown (UINT nHitTest, CPoint pt)
afx_msg int | OnMouseActivate (CWnd *pDesktopWnd, UINT nHitTest, UINT message)
afx_msg void | OnMouseMove (UINT nHitTest, CPoint pt)
afx_msg BOOL | OnNcActivate (BOOL bActive)
afx_msg LRESULT | OnNcCalcSize (WPARAM wParam, LPARAM lParam)
afx_msg UINT | OnNcHitTest (CPoint point)
afx_msg void | OnNcLButtonDown (UINT nHitTest, CPoint pt)
afx_msg void | OnNcLButtonUp (UINT nHitTest, CPoint pt)
afx_msg void | OnNcMouseMove (UINT nHitTest, CPoint pt)
afx_msg void | OnNcPaint ()
afx_msg void | OnNcRButtonDown (UINT nHitTest, CPoint pt)
afx_msg void | OnNcRButtonUp (UINT nHitTest, CPoint pt)
afx_msg void | OnPaint ()
afx_msg BOOL | OnSetCursor (CWnd *pwnd, UINT nHitTest, UINT msg)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg void | OnSettingChange (UINT uFlags, LPCTSTR lpszSection)
afx_msg void | OnShowWindow (BOOL bShow, UINT nStatus)
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg void | OnSizing (UINT nSide, LPRECT pRect)
afx_msg void | OnTimer (UINT_PTR nIdEvent)
afx_msg void | OnWindowPosChanging (WINDOWPOS *lpwndpos)
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)
virtual BOOL | PreTranslateMessage (MSG *msg)

Additional Inherited Members

- Public Types inherited from CAdUiPaletteSetDockFrame
enum | AdUiTitleBarLocation { kLeft = 0, kRight }
enum | ContainedBarType { Unknown, Standard, AdskBar }
- Public Member Functions inherited from CAdUiPaletteSetDockFrame
virtual void | CalcWindowRect (LPRECT lpClientRect, UINT nAdjustType=adjustBorder)
virtual BOOL | Create (CWnd *pParent, DWORD dwBarStyle)
enum ContainedBarType | GetContainedBarType ()
void | SetAutoRollup (BOOL bSet)
void | SetTitleBarLocation (CAdUiPaletteSetDockFrame::AdUiTitleBarLocation)
CAdUiPaletteSetDockFrame::AdUiTitleBarLocation | TitleBarLocation ()
- Protected Attributes inherited from CAdUiPaletteSetDockFrame
bool | m_bZOrderChanged
enum ContainedBarType | m_nContainedBarType
The documentation for this class was generated from the following file:
  • acuiDock.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiPaletteSetDockFrame Member List

This is the complete list of members for CAcUiPaletteSetDockFrame, including all inherited members.

AdskBar enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
AdUiTitleBarLocation enum name (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
CAcUiPaletteSetDockFrame() (defined in CAcUiPaletteSetDockFrame) | CAcUiPaletteSetDockFrame |
CAdUiPaletteSetDockFrame() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
CalcWindowRect(LPRECT lpClientRect, UINT nAdjustType=adjustBorder) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | virtual
CanAutoCADTakeFocus() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
CanFrameworkTakeFocus() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
ContainedBarType enum name (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
Create(CWnd *pParent, DWORD dwBarStyle) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | virtual
ForceChildRepaint() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
GetContainedBarType() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
GetPaletteSet() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
HitTest(CPoint pt, UINT &nFlag, DWORD &dwData) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
kLeft enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
kRight enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
m_bZOrderChanged (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
m_nContainedBarType (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnACADKeepFocus(WPARAM wParam, LPARAM lParam) (defined in CAcUiPaletteSetDockFrame) | CAcUiPaletteSetDockFrame | protected
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnClose() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnContextMenu(CWnd *pWnd, CPoint pos) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnDestroy() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnDisplayChange(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnDragEnter(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDragLeave(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDragOver(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDragScroll(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDrop(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDropEx(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnEnterSizeMove(WPARAM, LPARAM) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnEraseBkgnd(CDC *pDC) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnExitSizeMove(WPARAM, LPARAM) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnLButtonDown(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnMouseActivate(CWnd *pDesktopWnd, UINT nHitTest, UINT message) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnMouseMove(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcActivate(BOOL bActive) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcCalcSize(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcHitTest(CPoint point) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcLButtonDown(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcLButtonUp(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcMouseMove(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcPaint() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcRButtonDown(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcRButtonUp(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnPaint() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSetCursor(CWnd *pwnd, UINT nHitTest, UINT msg) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSettingChange(UINT uFlags, LPCTSTR lpszSection) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnShowWindow(BOOL bShow, UINT nStatus) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSize(UINT nType, int cx, int cy) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSizing(UINT nSide, LPRECT pRect) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnTimer(UINT_PTR nIdEvent) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnWindowPosChanging(WINDOWPOS *lpwndpos) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
PreTranslateMessage(MSG *msg) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
SetAutoRollup(BOOL bSet) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
SetTitleBarLocation(CAdUiPaletteSetDockFrame::AdUiTitleBarLocation) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
Standard enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
TitleBarLocation() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
Unknown enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
~CAcUiPaletteSetDockFrame() (defined in CAcUiPaletteSetDockFrame) | CAcUiPaletteSetDockFrame | virtual
~CAdUiPaletteSetDockFrame() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | virtual


ZRX API Reference: CAcUiPathname Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAcUiPathname Class Reference
MFC Classes
+ Inheritance diagram for CAcUiPathname:

Public Member Functions

CAcUiPathname (const CAcUiPathname &)
BOOL | Open (AFILE **fdp, const TCHAR *openmode)
const CAcUiPathname & | operator= (const CAcUiPathname &pathSrc)
const CAcUiPathname & | operator= (const CAcUiPathname *pathSrc)
virtual PathErr | Parse (LPCTSTR, const BOOL wildcard_ok=FALSE)
int | Status (void)
- Public Member Functions inherited from CAdUiPathname
PathErr | AddExtensionAlways (LPCTSTR)
PathErr | AddExtensionIfNoMatch (LPCTSTR)
PathErr | Append (LPCTSTR)
PathErr | AppendComponent (LPCTSTR)
PathErr | AppendSlash (void)
void | BaseToLower (void)
void | BaseToUpper (void)
CAdUiPathname (const CAdUiPathname &)
void | Empty (void)
BOOL | Exists (void)
void | GetBasename (CString &) const
void | GetDisplayName (CString &strResult, int maxchars) const
void | GetExtension (CString &) const
void | GetFilename (CString &) const
BOOL | GetFullPath (CString &) const
BOOL | GetFullPath (LPTSTR) const
void | GetFullUNCPath (CString &) const
void | GetParent (CAdUiPathname &) const
LPCTSTR | GetPathString (void) const
path_type | GetPathType (void) const
BOOL | GetUniqueName (CAdUiPathname &, BOOL alwaysMangle=FALSE) const
const CAdUiVolumeDescriptor * | GetVolumeDescriptor (void) const
BOOL | HadPrefix (void) const
BOOL | IsEmpty (void) const
BOOL | IsPath (void) const
BOOL | Open (FILE **fdp, const ACHAR *openmode)
BOOL | Open (CFile &fp, UINT openflags)
BOOL | OpenReadOnly (HANDLE &rFileHandle)
BOOL | OpenWriteOnly (HANDLE &rFileHandle)
const CAdUiPathname & | operator= (const CAdUiPathname &pathSrc)
const CAdUiPathname & | operator= (const CAdUiPathname *pathSrc)
BOOL | ParseAndOSFind (LPCTSTR)
PathErr | ParseRelative (LPCTSTR name, const CAdUiPathname *relpath, const BOOL wildcard_ok=FALSE)
BOOL | PathMatch (const CAdUiPathname *) const
BOOL | PathMatch (LPCTSTR) const
BOOL | Remove (void)
void | RemoveExtensionAlways (void)
void | RemoveExtensionIfMatch (LPCTSTR)
void | RemoveSpaces (void)
BOOL | Rename (const ACHAR *newname)
PathErr | ReplaceExtensionAlways (LPCTSTR)
PathErr | ReplaceExtensionIfNoMatch (LPCTSTR)
PathErr | Trim (void)
PathErr | TrimComponent (void)
PathErr | TrimSlash (void)
BOOL | VerifyExtension (LPCTSTR extlist) const
BOOL | WasAbsolute (void) const
BOOL | WasRoot (void) const

Protected Member Functions

virtual void | AssignCopy (const CAcUiPathname &)
- Protected Member Functions inherited from CAdUiPathname
virtual void | AssignCopy (const CAdUiPathname &)
const CAdUiVolumeDescriptor * | FindVolumeDescriptor (const CString &vol_name) const
FS_TYPE | GetFileSystem (CString &vol_name) const
ACHAR | GetSeparator (void) const
BOOL | IsDeviceName (const CString &str) const
const CAdUiVolumeDescriptor * | NewVolDescriptor (const CString &vol_name) const

Additional Inherited Members

- Static Protected Member Functions inherited from CAdUiPathname
static ACHAR | GetLastCharacter (const CString &)
static void | Unquote (CString &)
- Protected Attributes inherited from CAdUiPathname
BOOL | m_had_prefix
path_category | m_path_cat
CString * | m_pathbuffer
const CAdUiVolumeDescriptor * | m_pvolume
CString * | m_relpath
ACHAR | m_separator
path_type | m_this_type

Member Function Documentation

BOOL CAcUiPathname::Open | ( | AFILE ** | fdp,
 |  | const TCHAR * | openmode
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acuipathname.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiPathname Member List

This is the complete list of members for CAcUiPathname, including all inherited members.

AddExtensionAlways(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
AddExtensionIfNoMatch(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
Append(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
AppendComponent(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
AppendSlash(void) (defined in CAdUiPathname) | CAdUiPathname |
AssignCopy(const CAcUiPathname &) (defined in CAcUiPathname) | CAcUiPathname | protectedvirtual
AssignCopy(const CAdUiPathname &) (defined in CAdUiPathname) | CAdUiPathname | protectedvirtual
BaseToLower(void) (defined in CAdUiPathname) | CAdUiPathname |
BaseToUpper(void) (defined in CAdUiPathname) | CAdUiPathname |
CAcUiPathname(void) (defined in CAcUiPathname) | CAcUiPathname |
CAcUiPathname(const CAcUiPathname &) (defined in CAcUiPathname) | CAcUiPathname |
CAdUiPathname(void) (defined in CAdUiPathname) | CAdUiPathname |
CAdUiPathname(const CAdUiPathname &) (defined in CAdUiPathname) | CAdUiPathname | inline
Empty(void) (defined in CAdUiPathname) | CAdUiPathname |
Exists(void) (defined in CAdUiPathname) | CAdUiPathname |
FindVolumeDescriptor(const CString &vol_name) const (defined in CAdUiPathname) | CAdUiPathname | protected
GetBasename(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetDisplayName(CString &strResult, int maxchars) const (defined in CAdUiPathname) | CAdUiPathname |
GetExtension(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetFilename(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetFileSystem(CString &vol_name) const (defined in CAdUiPathname) | CAdUiPathname | protected
GetFullPath(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetFullPath(LPTSTR) const (defined in CAdUiPathname) | CAdUiPathname |
GetFullUNCPath(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetLastCharacter(const CString &) | CAdUiPathname | protectedstatic
GetParent(CAdUiPathname &) const (defined in CAdUiPathname) | CAdUiPathname |
GetPathString(void) const (defined in CAdUiPathname) | CAdUiPathname |
GetPathType(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
GetSeparator(void) const (defined in CAdUiPathname) | CAdUiPathname | protected
GetUniqueName(CAdUiPathname &, BOOL alwaysMangle=FALSE) const (defined in CAdUiPathname) | CAdUiPathname |
GetVolumeDescriptor(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
HadPrefix(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
IsDeviceName(const CString &str) const (defined in CAdUiPathname) | CAdUiPathname | inlineprotected
IsEmpty(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
IsPath(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
m_had_prefix (defined in CAdUiPathname) | CAdUiPathname | protected
m_path_cat (defined in CAdUiPathname) | CAdUiPathname | protected
m_pathbuffer (defined in CAdUiPathname) | CAdUiPathname | protected
m_pvolume (defined in CAdUiPathname) | CAdUiPathname | protected
m_relpath (defined in CAdUiPathname) | CAdUiPathname | protected
m_separator (defined in CAdUiPathname) | CAdUiPathname | protected
m_this_type (defined in CAdUiPathname) | CAdUiPathname | protected
NewVolDescriptor(const CString &vol_name) const (defined in CAdUiPathname) | CAdUiPathname | protected
Open(AFILE **fdp, const TCHAR *openmode) | CAcUiPathname |
Open(FILE **fdp, const ACHAR *openmode) (defined in CAdUiPathname) | CAdUiPathname |
Open(CFile &fp, UINT openflags) (defined in CAdUiPathname) | CAdUiPathname |
OpenReadOnly(HANDLE &rFileHandle) (defined in CAdUiPathname) | CAdUiPathname |
OpenWriteOnly(HANDLE &rFileHandle) (defined in CAdUiPathname) | CAdUiPathname |
operator=(const CAcUiPathname &pathSrc) (defined in CAcUiPathname) | CAcUiPathname | inline
operator=(const CAcUiPathname *pathSrc) (defined in CAcUiPathname) | CAcUiPathname | inline
operator=(const CAdUiPathname &pathSrc) (defined in CAdUiPathname) | CAdUiPathname | inline
operator=(const CAdUiPathname *pathSrc) (defined in CAdUiPathname) | CAdUiPathname | inline
Parse(LPCTSTR, const BOOL wildcard_ok=FALSE) (defined in CAcUiPathname) | CAcUiPathname | virtual
ParseAndOSFind(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
ParseRelative(LPCTSTR name, const CAdUiPathname *relpath, const BOOL wildcard_ok=FALSE) (defined in CAdUiPathname) | CAdUiPathname |
PathMatch(const CAdUiPathname *) const (defined in CAdUiPathname) | CAdUiPathname |
PathMatch(LPCTSTR) const (defined in CAdUiPathname) | CAdUiPathname |
Remove(void) (defined in CAdUiPathname) | CAdUiPathname |
RemoveExtensionAlways(void) | CAdUiPathname |
RemoveExtensionIfMatch(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
RemoveSpaces(void) (defined in CAdUiPathname) | CAdUiPathname |
Rename(const ACHAR *newname) (defined in CAdUiPathname) | CAdUiPathname |
ReplaceExtensionAlways(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
ReplaceExtensionIfNoMatch(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
Status(void) (defined in CAcUiPathname) | CAcUiPathname |
Trim(void) (defined in CAdUiPathname) | CAdUiPathname |
TrimComponent(void) (defined in CAdUiPathname) | CAdUiPathname |
TrimSlash(void) (defined in CAdUiPathname) | CAdUiPathname |
Unquote(CString &) (defined in CAdUiPathname) | CAdUiPathname | protectedstatic
VerifyExtension(LPCTSTR extlist) const (defined in CAdUiPathname) | CAdUiPathname |
WasAbsolute(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
WasRoot(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
~CAcUiPathname(void) (defined in CAcUiPathname) | CAcUiPathname |
~CAdUiPathname(void) (defined in CAdUiPathname) | CAdUiPathname |


ZRX API Reference: CAcUiPickButton Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Protected Member Functions | List of all members
CAcUiPickButton Class Reference
MFC Classes
+ Inheritance diagram for CAcUiPickButton:

Protected Member Functions

virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
- Protected Member Functions inherited from CAdUiBitmapButton
void | CalcBitmapSize ()
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
BOOL | LoadBitmap (LPCTSTR strResId)
BOOL | LoadBitmapResource (LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst)
virtual BOOL | OnAutoLoad ()
virtual BOOL | OnReload (LPCTSTR strResId)
- Protected Member Functions inherited from CAdUiOwnerDrawButton
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual void | DrawBorder (CDC *pDC, CRect &r, COLORREF cr)
virtual void | DrawHotBorder ()
virtual void | DrawPushButtonBorder (CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected)
virtual void | DrawToolButtonBorder (CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused)
void | DrawTransparentBitmap (CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled)
BOOL | GetIsPointedAt ()
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnDestroy ()
virtual void | OnDragDrop (HDROP hDropInfo)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
afx_msg void | OnDropFiles (HDROP hDropInfo)
afx_msg UINT | OnGetDlgCode ()
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnKillFocus (CWnd *pNewWnd)
afx_msg LRESULT | OnMouseLeave (WPARAM, LPARAM)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
afx_msg void | OnNcDestroy ()
virtual void | OnPointedAt (BOOL isPointedAt)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg LRESULT | OnThemeChanged (WPARAM wParam, LPARAM lParam)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
void | SetIsPointedAt (BOOL isPointedAt)
void | StartTimer (DWORD ms=50)
void | StopTimer ()
virtual void | ThemeModified (AdUiThemeElement element)

Additional Inherited Members

- Public Member Functions inherited from CAdUiBitmapButton
BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Protected Attributes inherited from CAdUiBitmapButton
BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • acuiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiPickButton Member List

This is the complete list of members for CAcUiPickButton, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAcUiPickButton() (defined in CAcUiPickButton) | CAcUiPickButton |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAcUiPickButton) | CAcUiPickButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAcUiPickButton() (defined in CAcUiPickButton) | CAcUiPickButton | virtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAcUiPlotStyleNamesComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAcUiPlotStyleNamesComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiPlotStyleNamesComboBox:

Public Member Functions

virtual int | ImageWidth ()
void | OtherRunsCurrentPlotStyle ()
void | OtherRunsDefault ()
void | OtherRunsSelectPlotStyle ()
void | SetAllowByLayerByBlock (BOOL bAllow)
void | SetColorDependentMode ()
void | SetNamedMode ()
- Public Member Functions inherited from CAcUiMRUComboBox
void | AddItems ()
int | AddItemToList (LPCTSTR name, INT_PTR cargo)
int | AddItemToMRU (LPCTSTR name, int cargo)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual int | ExtraWidth ()
int | FindItemByCargo (INT_PTR cargo)
int | GetCargoOption1 ()
int | GetCargoOption2 ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
INT_PTR | GetCurrentItemCargo ()
INT_PTR | GetItemCargo (int item)
virtual BOOL | GetItemColors (DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor)
LOGPALETTE * | GetLogPalette ()
HPALETTE | GetPalette ()
BOOL | GetUseByBlock ()
BOOL | GetUseByLayer ()
BOOL | GetUseOption1 ()
BOOL | GetUseOption2 ()
BOOL | GetUseOther ()
BOOL | GetUseOther1 ()
BOOL | GetUseOther2 ()
BOOL | GetUseWindows ()
int | InsertItemInList (int index, LPCTSTR name, INT_PTR cargo)
int | ItemHeight ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | RecalcHeight ()
void | RemoveItemFromMRU (int cargo)
void | SetCargoOption1 (int cargo)
void | SetCargoOption2 (int cargo)
void | SetLastSelection (int sel)
void | SetLogPalette (LOGPALETTE *logPalette)
void | SetPalette (HPALETTE hPalette)
void | SetUseByBlock (BOOL use)
void | SetUseByLayer (BOOL use)
void | SetUseOption1 (BOOL use)
void | SetUseOption2 (BOOL use)
void | SetUseOther (BOOL use)
void | SetUseOther1 (BOOL use)
void | SetUseOther2 (BOOL use)
void | SetUseWindows (BOOL use)
- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

virtual void | OnAddItems ()
virtual void | OnComboBoxInit ()
virtual BOOL | OnSelectOther (BOOL isOther2, int curSel, int &newSel)
- Protected Member Functions inherited from CAcUiMRUComboBox
virtual int | CalcItemHeight ()
void | CreateAndSelectPalette (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc)
virtual void | DrawItemImage (CDC &dc, CRect &r, INT_PTR cargo)
void | DrawItemImageFromCargo (CDC *dc, CRect &r, int i)
void | DrawTextAndFocusRect (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor)
BOOL | FindCargoInMRU (int cargo)
int | GenerateCargoFromMRU (int seed)
virtual BOOL | GetOptionName (BOOL isOption2, CString &name)
virtual BOOL | GetOtherName (BOOL isOther2, CString &name)
afx_msg BOOL | OnCloseUp ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnDropDown ()
virtual BOOL | OnGetTipRect (CRect &r)
afx_msg BOOL | OnSelEndOk ()
virtual void | PreSubclassWindow ()
void | ResetAndRestorePalette (CDC *dc, int savedState)
void | SelectOther (BOOL isOther2)
void | SetupForImageDraw (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor)
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam)

Additional Inherited Members

- Protected Attributes inherited from CAcUiMRUComboBox
BOOL | m_bIsDynamicCreation: 1
BOOL | m_bOther1Selected: 1
BOOL | m_bOther2Selected: 1
BOOL | m_bUseOption1: 1
BOOL | m_bUseOption2: 1
BOOL | m_bUseOther1: 1
BOOL | m_bUseOther2: 1
int | m_cargoOption1
int | m_cargoOption2
HPALETTE | m_hPalette
int | m_itemHeight
int | m_lastSelection
LOGPALETTE * | m_logPalette
int | m_mruCargo [ACUI_MAX_COMBOBOX_MRU]
int | m_mruLen
CString | m_mruName [ACUI_MAX_COMBOBOX_MRU]
CPalette * | m_pOldPalette
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiPlotStyleNamesComboBox Member List

This is the complete list of members for CAcUiPlotStyleNamesComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
AddItems() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToList(LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToMRU(LPCTSTR name, int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAcUiPlotStyleNamesComboBox() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
CalcItemHeight() | CAcUiMRUComboBox | protectedvirtual
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
CreateAndSelectPalette(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
DrawItemImage(CDC &dc, CRect &r, INT_PTR cargo) | CAcUiMRUComboBox | protectedvirtual
DrawItemImageFromCargo(CDC *dc, CRect &r, int i) | CAcUiMRUComboBox | protected
DrawTextAndFocusRect(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
ExtraWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
FindCargoInMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
FindItemByCargo(INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GenerateCargoFromMRU(int seed) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetCargoOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCargoOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetCurrentItemCargo() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetItemCargo(int item) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetItemColors(DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLogPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetOptionName(BOOL isOption2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetOtherName(BOOL isOther2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
GetUseByBlock() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseByLayer() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseWindows() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ImageWidth() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox | virtual
InsertItemInList(int index, LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
ItemHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bIsDynamicCreation (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther1Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther2Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bUseOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_hPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_itemHeight (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastSelection (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_logPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruCargo (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruLen (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruName (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pOldPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
OnAddItems() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox | protectedvirtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCloseUp() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnComboBoxInit() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox | protectedvirtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDropDown() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnGetTipRect(CRect &r) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnSelectOther(BOOL isOther2, int curSel, int &newSel) (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox | protectedvirtual
OnSelEndOk() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OtherRunsCurrentPlotStyle() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox | inline
OtherRunsDefault() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox | inline
OtherRunsSelectPlotStyle() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox | inline
PreSubclassWindow() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
RecalcHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
RemoveItemFromMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ResetAndRestorePalette(CDC *dc, int savedState) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SelectOther(BOOL isOther2) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetAllowByLayerByBlock(BOOL bAllow) (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox | inline
SetCargoOption1(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetCargoOption2(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetColorDependentMode() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLastSelection(int sel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLogPalette(LOGPALETTE *logPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetNamedMode() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox |
SetPalette(HPALETTE hPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
SetupForImageDraw(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetUseByBlock(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseByLayer(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseWindows(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
WindowProc(UINT message, WPARAM wParam, LPARAM lParam) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
~CAcUiPlotStyleNamesComboBox() (defined in CAcUiPlotStyleNamesComboBox) | CAcUiPlotStyleNamesComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiPlotStyleTablesComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAcUiPlotStyleTablesComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiPlotStyleTablesComboBox:

Public Member Functions

int | AddItemToList (LPCTSTR name, INT_PTR cargo)
int | AddMissingStyleTable (LPCTSTR fullFileName)
CAcUiPlotStyleTablesComboBox (BOOL bInitialize)
void | GetLBText (int nIndex, CString &rString) const
virtual int | ImageWidth ()
bool | IsMissing (int index)
void | SetFileType (bool currentDrawing, bool named)
- Public Member Functions inherited from CAcUiMRUComboBox
void | AddItems ()
int | AddItemToMRU (LPCTSTR name, int cargo)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual int | ExtraWidth ()
int | FindItemByCargo (INT_PTR cargo)
int | GetCargoOption1 ()
int | GetCargoOption2 ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
INT_PTR | GetCurrentItemCargo ()
INT_PTR | GetItemCargo (int item)
virtual BOOL | GetItemColors (DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor)
LOGPALETTE * | GetLogPalette ()
HPALETTE | GetPalette ()
BOOL | GetUseByBlock ()
BOOL | GetUseByLayer ()
BOOL | GetUseOption1 ()
BOOL | GetUseOption2 ()
BOOL | GetUseOther ()
BOOL | GetUseOther1 ()
BOOL | GetUseOther2 ()
BOOL | GetUseWindows ()
int | InsertItemInList (int index, LPCTSTR name, INT_PTR cargo)
int | ItemHeight ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | RecalcHeight ()
void | RemoveItemFromMRU (int cargo)
void | SetCargoOption1 (int cargo)
void | SetCargoOption2 (int cargo)
void | SetLastSelection (int sel)
void | SetLogPalette (LOGPALETTE *logPalette)
void | SetPalette (HPALETTE hPalette)
void | SetUseByBlock (BOOL use)
void | SetUseByLayer (BOOL use)
void | SetUseOption1 (BOOL use)
void | SetUseOption2 (BOOL use)
void | SetUseOther (BOOL use)
void | SetUseOther1 (BOOL use)
void | SetUseOther2 (BOOL use)
void | SetUseWindows (BOOL use)
- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

virtual int | CalcItemHeight ()
virtual void | DrawItemImage (CDC &dc, CRect &r, INT_PTR cargo)
virtual void | OnAddItems ()
virtual void | OnComboBoxInit ()
afx_msg BOOL | OnDropDown ()
- Protected Member Functions inherited from CAcUiMRUComboBox
void | CreateAndSelectPalette (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc)
void | DrawItemImageFromCargo (CDC *dc, CRect &r, int i)
void | DrawTextAndFocusRect (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor)
BOOL | FindCargoInMRU (int cargo)
int | GenerateCargoFromMRU (int seed)
virtual BOOL | GetOptionName (BOOL isOption2, CString &name)
virtual BOOL | GetOtherName (BOOL isOther2, CString &name)
afx_msg BOOL | OnCloseUp ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
virtual BOOL | OnGetTipRect (CRect &r)
virtual BOOL | OnSelectOther (BOOL isOther2, int curSel, int &newSel)
afx_msg BOOL | OnSelEndOk ()
virtual void | PreSubclassWindow ()
void | ResetAndRestorePalette (CDC *dc, int savedState)
void | SelectOther (BOOL isOther2)
void | SetupForImageDraw (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor)
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam)

Additional Inherited Members

- Protected Attributes inherited from CAcUiMRUComboBox
BOOL | m_bIsDynamicCreation: 1
BOOL | m_bOther1Selected: 1
BOOL | m_bOther2Selected: 1
BOOL | m_bUseOption1: 1
BOOL | m_bUseOption2: 1
BOOL | m_bUseOther1: 1
BOOL | m_bUseOther2: 1
int | m_cargoOption1
int | m_cargoOption2
HPALETTE | m_hPalette
int | m_itemHeight
int | m_lastSelection
LOGPALETTE * | m_logPalette
int | m_mruCargo [ACUI_MAX_COMBOBOX_MRU]
int | m_mruLen
CString | m_mruName [ACUI_MAX_COMBOBOX_MRU]
CPalette * | m_pOldPalette
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiPlotStyleTablesComboBox Member List

This is the complete list of members for CAcUiPlotStyleTablesComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
AddItems() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToList(LPCTSTR name, INT_PTR cargo) (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox |
AddItemToMRU(LPCTSTR name, int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddMissingStyleTable(LPCTSTR fullFileName) (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAcUiPlotStyleTablesComboBox() (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox |
CAcUiPlotStyleTablesComboBox(BOOL bInitialize) (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
CalcItemHeight() (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox | protectedvirtual
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
CreateAndSelectPalette(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
DrawItemImage(CDC &dc, CRect &r, INT_PTR cargo) (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox | protectedvirtual
DrawItemImageFromCargo(CDC *dc, CRect &r, int i) | CAcUiMRUComboBox | protected
DrawTextAndFocusRect(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
ExtraWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
FindCargoInMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
FindItemByCargo(INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GenerateCargoFromMRU(int seed) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetCargoOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCargoOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetCurrentItemCargo() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetItemCargo(int item) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetItemColors(DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetLBText(int nIndex, CString &rString) const (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLogPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetOptionName(BOOL isOption2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetOtherName(BOOL isOther2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
GetUseByBlock() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseByLayer() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseWindows() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ImageWidth() (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox | virtual
InsertItemInList(int index, LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
IsMissing(int index) (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
ItemHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bIsDynamicCreation (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther1Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther2Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bUseOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_hPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_itemHeight (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastSelection (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_logPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruCargo (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruLen (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruName (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pOldPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
OnAddItems() (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox | protectedvirtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCloseUp() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnComboBoxInit() (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox | protectedvirtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDropDown() (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox | protected
OnGetTipRect(CRect &r) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnSelectOther(BOOL isOther2, int curSel, int &newSel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnSelEndOk() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
PreSubclassWindow() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
RecalcHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
RemoveItemFromMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ResetAndRestorePalette(CDC *dc, int savedState) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SelectOther(BOOL isOther2) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetCargoOption1(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetCargoOption2(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetFileType(bool currentDrawing, bool named) (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox |
SetLastSelection(int sel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLogPalette(LOGPALETTE *logPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetPalette(HPALETTE hPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
SetupForImageDraw(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetUseByBlock(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseByLayer(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseWindows(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
WindowProc(UINT message, WPARAM wParam, LPARAM lParam) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
~CAcUiPlotStyleTablesComboBox() (defined in CAcUiPlotStyleTablesComboBox) | CAcUiPlotStyleTablesComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiPredefBlockComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAcUiPredefBlockComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiPredefBlockComboBox:

Public Member Functions

int | AddPredefBlockToMRU (LPCTSTR name)
- Public Member Functions inherited from CAcUiMRUComboBox
void | AddItems ()
int | AddItemToList (LPCTSTR name, INT_PTR cargo)
int | AddItemToMRU (LPCTSTR name, int cargo)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual int | ExtraWidth ()
int | FindItemByCargo (INT_PTR cargo)
int | GetCargoOption1 ()
int | GetCargoOption2 ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
INT_PTR | GetCurrentItemCargo ()
INT_PTR | GetItemCargo (int item)
virtual BOOL | GetItemColors (DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor)
LOGPALETTE * | GetLogPalette ()
HPALETTE | GetPalette ()
BOOL | GetUseByBlock ()
BOOL | GetUseByLayer ()
BOOL | GetUseOption1 ()
BOOL | GetUseOption2 ()
BOOL | GetUseOther ()
BOOL | GetUseOther1 ()
BOOL | GetUseOther2 ()
BOOL | GetUseWindows ()
virtual int | ImageWidth ()
int | InsertItemInList (int index, LPCTSTR name, INT_PTR cargo)
int | ItemHeight ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | RecalcHeight ()
void | RemoveItemFromMRU (int cargo)
void | SetCargoOption1 (int cargo)
void | SetCargoOption2 (int cargo)
void | SetLastSelection (int sel)
void | SetLogPalette (LOGPALETTE *logPalette)
void | SetPalette (HPALETTE hPalette)
void | SetUseByBlock (BOOL use)
void | SetUseByLayer (BOOL use)
void | SetUseOption1 (BOOL use)
void | SetUseOption2 (BOOL use)
void | SetUseOther (BOOL use)
void | SetUseOther1 (BOOL use)
void | SetUseOther2 (BOOL use)
void | SetUseWindows (BOOL use)
- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

virtual int | CalcItemHeight ()
virtual void | DrawItemImage (CDC &dc, CRect &r, INT_PTR cargo)
virtual BOOL | GetOtherName (BOOL isOther2, CString &name)
virtual void | OnAddItems ()
virtual void | OnComboBoxInit ()
- Protected Member Functions inherited from CAcUiMRUComboBox
void | CreateAndSelectPalette (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc)
void | DrawItemImageFromCargo (CDC *dc, CRect &r, int i)
void | DrawTextAndFocusRect (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor)
BOOL | FindCargoInMRU (int cargo)
int | GenerateCargoFromMRU (int seed)
virtual BOOL | GetOptionName (BOOL isOption2, CString &name)
afx_msg BOOL | OnCloseUp ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnDropDown ()
virtual BOOL | OnGetTipRect (CRect &r)
virtual BOOL | OnSelectOther (BOOL isOther2, int curSel, int &newSel)
afx_msg BOOL | OnSelEndOk ()
virtual void | PreSubclassWindow ()
void | ResetAndRestorePalette (CDC *dc, int savedState)
void | SelectOther (BOOL isOther2)
void | SetupForImageDraw (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor)
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam)

Additional Inherited Members

- Protected Attributes inherited from CAcUiMRUComboBox
BOOL | m_bIsDynamicCreation: 1
BOOL | m_bOther1Selected: 1
BOOL | m_bOther2Selected: 1
BOOL | m_bUseOption1: 1
BOOL | m_bUseOption2: 1
BOOL | m_bUseOther1: 1
BOOL | m_bUseOther2: 1
int | m_cargoOption1
int | m_cargoOption2
HPALETTE | m_hPalette
int | m_itemHeight
int | m_lastSelection
LOGPALETTE * | m_logPalette
int | m_mruCargo [ACUI_MAX_COMBOBOX_MRU]
int | m_mruLen
CString | m_mruName [ACUI_MAX_COMBOBOX_MRU]
CPalette * | m_pOldPalette
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiPredefBlockComboBox Member List

This is the complete list of members for CAcUiPredefBlockComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
AddItems() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToList(LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToMRU(LPCTSTR name, int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddPredefBlockToMRU(LPCTSTR name) (defined in CAcUiPredefBlockComboBox) | CAcUiPredefBlockComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAcUiPredefBlockComboBox() (defined in CAcUiPredefBlockComboBox) | CAcUiPredefBlockComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
CalcItemHeight() (defined in CAcUiPredefBlockComboBox) | CAcUiPredefBlockComboBox | protectedvirtual
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
CreateAndSelectPalette(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
DrawItemImage(CDC &dc, CRect &r, INT_PTR cargo) (defined in CAcUiPredefBlockComboBox) | CAcUiPredefBlockComboBox | protectedvirtual
DrawItemImageFromCargo(CDC *dc, CRect &r, int i) | CAcUiMRUComboBox | protected
DrawTextAndFocusRect(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
ExtraWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
FindCargoInMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
FindItemByCargo(INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GenerateCargoFromMRU(int seed) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetCargoOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCargoOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetCurrentItemCargo() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetItemCargo(int item) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetItemColors(DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLogPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetOptionName(BOOL isOption2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetOtherName(BOOL isOther2, CString &name) (defined in CAcUiPredefBlockComboBox) | CAcUiPredefBlockComboBox | protectedvirtual
GetPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
GetUseByBlock() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseByLayer() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseWindows() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ImageWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
InsertItemInList(int index, LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
ItemHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bIsDynamicCreation (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther1Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther2Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bUseOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_hPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_itemHeight (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastSelection (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_logPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruCargo (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruLen (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruName (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pOldPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
OnAddItems() (defined in CAcUiPredefBlockComboBox) | CAcUiPredefBlockComboBox | protectedvirtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCloseUp() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnComboBoxInit() (defined in CAcUiPredefBlockComboBox) | CAcUiPredefBlockComboBox | protectedvirtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDropDown() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnGetTipRect(CRect &r) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnSelectOther(BOOL isOther2, int curSel, int &newSel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnSelEndOk() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
PreSubclassWindow() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
RecalcHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
RemoveItemFromMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ResetAndRestorePalette(CDC *dc, int savedState) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SelectOther(BOOL isOther2) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetCargoOption1(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetCargoOption2(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLastSelection(int sel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLogPalette(LOGPALETTE *logPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetPalette(HPALETTE hPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
SetupForImageDraw(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetUseByBlock(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseByLayer(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseWindows(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
WindowProc(UINT message, WPARAM wParam, LPARAM lParam) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
~CAcUiPredefBlockComboBox() (defined in CAcUiPredefBlockComboBox) | CAcUiPredefBlockComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiSelectButton Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiSelectButton Class Reference
MFC Classes
+ Inheritance diagram for CAcUiSelectButton:

Additional Inherited Members

- Public Member Functions inherited from CAdUiBitmapButton
BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Protected Member Functions inherited from CAcUiPickButton
virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
- Protected Attributes inherited from CAdUiBitmapButton
BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • acuiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiSelectButton Member List

This is the complete list of members for CAcUiSelectButton, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAcUiPickButton() (defined in CAcUiPickButton) | CAcUiPickButton |
CAcUiSelectButton() (defined in CAcUiSelectButton) | CAcUiSelectButton |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAcUiPickButton) | CAcUiPickButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAcUiPickButton() (defined in CAcUiPickButton) | CAcUiPickButton | virtual
~CAcUiSelectButton() (defined in CAcUiSelectButton) | CAcUiSelectButton | virtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAcUiString Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcUiString Class Reference
MFC Classes
+ Inheritance diagram for CAcUiString:

Public Member Functions

ADUI_PORT | CAcUiString (const CString &stringSrc)
ADUI_PORT | CAcUiString (ACHAR ch, int nRepeat=1)
ADUI_PORT | CAcUiString (LPCTSTR psz)
ADUI_PORT | CAcUiString (LPCTSTR pch, int nLength)
ADUI_PORT | CAcUiString (UINT nStringResourceID)
ADUI_PORT void | ConvertFromMenuExecString ()
ADUI_PORT void | ConvertMenuExecString ()
ADUI_PORT CString | CreateEllipsedString (CDC *pDC, CString OriginalString, UINT width)
ADUI_PORT void | ExpandTabs (int nTabSize=8)
ADUI_PORT void | FixFileName ()
ADUI_PORT void | GetCurrentWorkingDirectory ()
ADUI_PORT BOOL | IsAlphabetic (int nIndex) const
ADUI_PORT BOOL | IsAlphanumeric (int nIndex) const
ADUI_PORT BOOL | IsBlank (int nIndex) const
ADUI_PORT BOOL | IsHexNumeric (int nIndex) const
ADUI_PORT BOOL | IsLowercase (int nIndex) const
ADUI_PORT BOOL | IsNumeric (int nIndex) const
ADUI_PORT BOOL | IsPunctuation (int nIndex) const
ADUI_PORT BOOL | IsTab (int nIndex) const
ADUI_PORT BOOL | IsUppercase (int nIndex) const
ADUI_PORT BOOL | IsWhiteSpace (int nIndex) const
ADUI_PORT void | MakeCharLower (int nIndex)
ADUI_PORT void | MakeCharUpper (int nIndex)
ADUI_PORT void | ReplaceCharWithChar (ACHAR chFrom, ACHAR chTo)
ADUI_PORT void | ShortenString (CDC *pDC, CString OriginalString, UINT width)
ADUI_PORT void | StripDiesel ()
ADUI_PORT void | StripMnemonic ()
ADUI_PORT void | StripPrecedingBlanks ()
ADUI_PORT void | StripPrecedingCharacters (ACHAR cChar)
ADUI_PORT void | StripTrailingBlanks ()
ADUI_PORT void | StripTrailingCharacters (ACHAR cChar)
ADUI_PORT void | WrapLine (CAcUiString &strRest, int nWrapAt)
ADUI_PORT void | WrapLine (CStringList &strListWrapped, int nWrapAt)

Constructor & Destructor Documentation

ADUI_PORT CAcUiString::CAcUiString | ( | ACHAR | ch,
 |  | int | nRepeat = 1
 | ) |  |
Warning
Not implemented!

Member Function Documentation

ADUI_PORT void CAcUiString::MakeCharUpper ( int nIndex )
Warning
Not implemented!
ADUI_PORT void CAcUiString::StripMnemonic ( )
Warning
Not implemented!
ADUI_PORT void CAcUiString::StripPrecedingCharacters ( ACHAR cChar )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acuistring.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiString Member List

This is the complete list of members for CAcUiString, including all inherited members.

CAcUiString() (defined in CAcUiString) | CAcUiString
CAcUiString(const CString &stringSrc) (defined in CAcUiString) | CAcUiString
CAcUiString(ACHAR ch, int nRepeat=1) | CAcUiString
CAcUiString(LPCTSTR psz) (defined in CAcUiString) | CAcUiString
CAcUiString(LPCTSTR pch, int nLength) (defined in CAcUiString) | CAcUiString
CAcUiString(UINT nStringResourceID) (defined in CAcUiString) | CAcUiString
ConvertFromMenuExecString() (defined in CAcUiString) | CAcUiString
ConvertMenuExecString() (defined in CAcUiString) | CAcUiString
CreateEllipsedString(CDC *pDC, CString OriginalString, UINT width) (defined in CAcUiString) | CAcUiString
ExpandTabs(int nTabSize=8) (defined in CAcUiString) | CAcUiString
FixFileName() (defined in CAcUiString) | CAcUiString
GetCurrentWorkingDirectory() (defined in CAcUiString) | CAcUiString
IsAlphabetic(int nIndex) const (defined in CAcUiString) | CAcUiString
IsAlphanumeric(int nIndex) const (defined in CAcUiString) | CAcUiString
IsBlank(int nIndex) const (defined in CAcUiString) | CAcUiString
IsHexNumeric(int nIndex) const (defined in CAcUiString) | CAcUiString
IsLowercase(int nIndex) const (defined in CAcUiString) | CAcUiString
IsNumeric(int nIndex) const (defined in CAcUiString) | CAcUiString
IsPunctuation(int nIndex) const (defined in CAcUiString) | CAcUiString
IsTab(int nIndex) const (defined in CAcUiString) | CAcUiString
IsUppercase(int nIndex) const (defined in CAcUiString) | CAcUiString
IsWhiteSpace(int nIndex) const (defined in CAcUiString) | CAcUiString
MakeCharLower(int nIndex) (defined in CAcUiString) | CAcUiString
MakeCharUpper(int nIndex) | CAcUiString
ReplaceCharWithChar(ACHAR chFrom, ACHAR chTo) (defined in CAcUiString) | CAcUiString
ShortenString(CDC *pDC, CString OriginalString, UINT width) (defined in CAcUiString) | CAcUiString
StripDiesel() (defined in CAcUiString) | CAcUiString
StripMnemonic() | CAcUiString
StripPrecedingBlanks() (defined in CAcUiString) | CAcUiString
StripPrecedingCharacters(ACHAR cChar) | CAcUiString
StripTrailingBlanks() (defined in CAcUiString) | CAcUiString
StripTrailingCharacters(ACHAR cChar) (defined in CAcUiString) | CAcUiString
WrapLine(CAcUiString &strRest, int nWrapAt) (defined in CAcUiString) | CAcUiString
WrapLine(CStringList &strListWrapped, int nWrapAt) (defined in CAcUiString) | CAcUiString


ZRX API Reference: CAcUiStringComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiStringComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiStringComboBox:

Additional Inherited Members

- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Protected Member Functions inherited from CAdUiComboBox
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
afx_msg LRESULT | OnGetToolTipText (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
- Protected Attributes inherited from CAdUiComboBox
CWnd * | m_aduiParent
BOOL | m_bAutoDeleteEBox: 1
BOOL | m_bAutoDeleteLBox: 1
BOOL | m_bSubclassedControls: 1
CPoint | m_lastMousePoint
CAdUiEdit * | m_pComboEBox
CAdUiListBox * | m_pComboLBox
CString | m_sToolTipText
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiStringComboBox Member List

This is the complete list of members for CAcUiStringComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiStringComboBox() (defined in CAcUiStringComboBox) | CAcUiStringComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox | virtual
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiStringComboBox() (defined in CAcUiStringComboBox) | CAcUiStringComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiStringEdit Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcUiStringEdit Class Reference
MFC Classes
+ Inheritance diagram for CAcUiStringEdit:

Public Member Functions

virtual void | SetStyleMask (DWORD mask)
- Public Member Functions inherited from CAcUiEdit
void | Convert ()
BOOL | ConvertData (CString &x)
BOOL | HasChanged ()
void | SetDirty ()
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiEdit
CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsStyleMaskSet (DWORD)
void | SetAdUiParent (CWnd *w)

Additional Inherited Members

- Public Attributes inherited from CAcUiEdit
BOOL | m_bChanged
BOOL | m_bTouch
CString | m_csMsg
double | m_dMaxValue
double | m_dMinValue
- Protected Member Functions inherited from CAcUiEdit
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg BOOL | OnChange ()
afx_msg void | OnErrSpace ()
afx_msg void | OnKillFocus (CWnd *pNewWnd)
- Protected Attributes inherited from CAdUiEdit
CWnd * | m_aduiParent
CPoint | m_lastMousePoint
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiEdit.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiStringEdit Member List

This is the complete list of members for CAcUiStringEdit, including all inherited members.

CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit |
CAcUiStringEdit() (defined in CAcUiStringEdit) | CAcUiStringEdit |
CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit |
Convert() (defined in CAcUiEdit) | CAcUiEdit |
ConvertData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAcUiEdit) | CAcUiEdit | protectedvirtual
GetAdUiParent() (defined in CAdUiEdit) | CAdUiEdit |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit | virtual
GetStyleMask() (defined in CAdUiEdit) | CAdUiEdit |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit |
HasChanged() (defined in CAcUiEdit) | CAcUiEdit |
IsStyleMaskSet(DWORD) (defined in CAdUiEdit) | CAdUiEdit |
m_aduiParent (defined in CAdUiEdit) | CAdUiEdit | protected
m_bChanged (defined in CAcUiEdit) | CAcUiEdit |
m_bTouch (defined in CAcUiEdit) | CAcUiEdit |
m_csMsg (defined in CAcUiEdit) | CAcUiEdit |
m_dMaxValue (defined in CAcUiEdit) | CAcUiEdit |
m_dMinValue (defined in CAcUiEdit) | CAcUiEdit |
m_lastMousePoint (defined in CAdUiEdit) | CAdUiEdit | protected
m_styleMask (defined in CAdUiEdit) | CAdUiEdit |
m_tipRect (defined in CAdUiEdit) | CAdUiEdit | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiEdit) | CAdUiEdit | protected
OnChange() (defined in CAcUiEdit) | CAcUiEdit | protected
OnDrawTip(CDC &dc) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnErrSpace() (defined in CAcUiEdit) | CAcUiEdit | protected
OnGetTipRect(CRect &r) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAcUiEdit) | CAcUiEdit | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiEdit) | CAdUiEdit | protected
SetAdUiParent(CWnd *w) (defined in CAdUiEdit) | CAdUiEdit |
SetDirty() (defined in CAcUiEdit) | CAcUiEdit |
SetRange(double vMin, double vMax) (defined in CAcUiEdit) | CAcUiEdit |
SetStyleMask(DWORD mask) (defined in CAcUiStringEdit) | CAcUiStringEdit | virtual
Validate() (defined in CAcUiEdit) | CAcUiEdit |
ValidateData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
~CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit | virtual
~CAcUiStringEdit() (defined in CAcUiStringEdit) | CAcUiStringEdit | virtual
~CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit | virtual


ZRX API Reference: CAcUiStringExp Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcUiStringExp Class Reference
MFC Classes
+ Inheritance diagram for CAcUiStringExp:

Public Member Functions

ADUI_PORT | CAcUiStringExp (const CString &stringSrc)
ADUI_PORT | CAcUiStringExp (ACHAR ch, int nRepeat=1)
ADUI_PORT | CAcUiStringExp (LPCTSTR psz)
ADUI_PORT | CAcUiStringExp (LPCTSTR pch, int nLength)
ADUI_PORT | CAcUiStringExp (UINT nStringResourceID)
virtual ADUI_PORT BOOL | LoadString (UINT nID)
ADUI_PORT void | ReplaceProductMacroStrings ()
- Public Member Functions inherited from CAcUiString
ADUI_PORT | CAcUiString (const CString &stringSrc)
ADUI_PORT | CAcUiString (ACHAR ch, int nRepeat=1)
ADUI_PORT | CAcUiString (LPCTSTR psz)
ADUI_PORT | CAcUiString (LPCTSTR pch, int nLength)
ADUI_PORT | CAcUiString (UINT nStringResourceID)
ADUI_PORT void | ConvertFromMenuExecString ()
ADUI_PORT void | ConvertMenuExecString ()
ADUI_PORT CString | CreateEllipsedString (CDC *pDC, CString OriginalString, UINT width)
ADUI_PORT void | ExpandTabs (int nTabSize=8)
ADUI_PORT void | FixFileName ()
ADUI_PORT void | GetCurrentWorkingDirectory ()
ADUI_PORT BOOL | IsAlphabetic (int nIndex) const
ADUI_PORT BOOL | IsAlphanumeric (int nIndex) const
ADUI_PORT BOOL | IsBlank (int nIndex) const
ADUI_PORT BOOL | IsHexNumeric (int nIndex) const
ADUI_PORT BOOL | IsLowercase (int nIndex) const
ADUI_PORT BOOL | IsNumeric (int nIndex) const
ADUI_PORT BOOL | IsPunctuation (int nIndex) const
ADUI_PORT BOOL | IsTab (int nIndex) const
ADUI_PORT BOOL | IsUppercase (int nIndex) const
ADUI_PORT BOOL | IsWhiteSpace (int nIndex) const
ADUI_PORT void | MakeCharLower (int nIndex)
ADUI_PORT void | MakeCharUpper (int nIndex)
ADUI_PORT void | ReplaceCharWithChar (ACHAR chFrom, ACHAR chTo)
ADUI_PORT void | ShortenString (CDC *pDC, CString OriginalString, UINT width)
ADUI_PORT void | StripDiesel ()
ADUI_PORT void | StripMnemonic ()
ADUI_PORT void | StripPrecedingBlanks ()
ADUI_PORT void | StripPrecedingCharacters (ACHAR cChar)
ADUI_PORT void | StripTrailingBlanks ()
ADUI_PORT void | StripTrailingCharacters (ACHAR cChar)
ADUI_PORT void | WrapLine (CAcUiString &strRest, int nWrapAt)
ADUI_PORT void | WrapLine (CStringList &strListWrapped, int nWrapAt)

Constructor & Destructor Documentation

ADUI_PORT CAcUiStringExp::CAcUiStringExp | ( | ACHAR | ch,
 |  | int | nRepeat = 1
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • acuistring.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiStringExp Member List

This is the complete list of members for CAcUiStringExp, including all inherited members.

CAcUiString() (defined in CAcUiString) | CAcUiString |
CAcUiString(const CString &stringSrc) (defined in CAcUiString) | CAcUiString |
CAcUiString(ACHAR ch, int nRepeat=1) | CAcUiString |
CAcUiString(LPCTSTR psz) (defined in CAcUiString) | CAcUiString |
CAcUiString(LPCTSTR pch, int nLength) (defined in CAcUiString) | CAcUiString |
CAcUiString(UINT nStringResourceID) (defined in CAcUiString) | CAcUiString |
CAcUiStringExp() (defined in CAcUiStringExp) | CAcUiStringExp |
CAcUiStringExp(const CString &stringSrc) (defined in CAcUiStringExp) | CAcUiStringExp |
CAcUiStringExp(ACHAR ch, int nRepeat=1) | CAcUiStringExp |
CAcUiStringExp(LPCTSTR psz) (defined in CAcUiStringExp) | CAcUiStringExp |
CAcUiStringExp(LPCTSTR pch, int nLength) (defined in CAcUiStringExp) | CAcUiStringExp |
CAcUiStringExp(UINT nStringResourceID) (defined in CAcUiStringExp) | CAcUiStringExp |
ConvertFromMenuExecString() (defined in CAcUiString) | CAcUiString |
ConvertMenuExecString() (defined in CAcUiString) | CAcUiString |
CreateEllipsedString(CDC *pDC, CString OriginalString, UINT width) (defined in CAcUiString) | CAcUiString |
ExpandTabs(int nTabSize=8) (defined in CAcUiString) | CAcUiString |
FixFileName() (defined in CAcUiString) | CAcUiString |
GetCurrentWorkingDirectory() (defined in CAcUiString) | CAcUiString |
IsAlphabetic(int nIndex) const (defined in CAcUiString) | CAcUiString |
IsAlphanumeric(int nIndex) const (defined in CAcUiString) | CAcUiString |
IsBlank(int nIndex) const (defined in CAcUiString) | CAcUiString |
IsHexNumeric(int nIndex) const (defined in CAcUiString) | CAcUiString |
IsLowercase(int nIndex) const (defined in CAcUiString) | CAcUiString |
IsNumeric(int nIndex) const (defined in CAcUiString) | CAcUiString |
IsPunctuation(int nIndex) const (defined in CAcUiString) | CAcUiString |
IsTab(int nIndex) const (defined in CAcUiString) | CAcUiString |
IsUppercase(int nIndex) const (defined in CAcUiString) | CAcUiString |
IsWhiteSpace(int nIndex) const (defined in CAcUiString) | CAcUiString |
LoadString(UINT nID) (defined in CAcUiStringExp) | CAcUiStringExp | virtual
MakeCharLower(int nIndex) (defined in CAcUiString) | CAcUiString |
MakeCharUpper(int nIndex) | CAcUiString |
ReplaceCharWithChar(ACHAR chFrom, ACHAR chTo) (defined in CAcUiString) | CAcUiString |
ReplaceProductMacroStrings() (defined in CAcUiStringExp) | CAcUiStringExp |
ShortenString(CDC *pDC, CString OriginalString, UINT width) (defined in CAcUiString) | CAcUiString |
StripDiesel() (defined in CAcUiString) | CAcUiString |
StripMnemonic() | CAcUiString |
StripPrecedingBlanks() (defined in CAcUiString) | CAcUiString |
StripPrecedingCharacters(ACHAR cChar) | CAcUiString |
StripTrailingBlanks() (defined in CAcUiString) | CAcUiString |
StripTrailingCharacters(ACHAR cChar) (defined in CAcUiString) | CAcUiString |
WrapLine(CAcUiString &strRest, int nWrapAt) (defined in CAcUiString) | CAcUiString |
WrapLine(CStringList &strListWrapped, int nWrapAt) (defined in CAcUiString) | CAcUiString |


ZRX API Reference: CAcUiSymbolComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiSymbolComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiSymbolComboBox:

Additional Inherited Members

- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Protected Member Functions inherited from CAdUiComboBox
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
afx_msg LRESULT | OnGetToolTipText (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
- Protected Attributes inherited from CAdUiComboBox
CWnd * | m_aduiParent
BOOL | m_bAutoDeleteEBox: 1
BOOL | m_bAutoDeleteLBox: 1
BOOL | m_bSubclassedControls: 1
CPoint | m_lastMousePoint
CAdUiEdit * | m_pComboEBox
CAdUiListBox * | m_pComboLBox
CString | m_sToolTipText
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiSymbolComboBox Member List

This is the complete list of members for CAcUiSymbolComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiSymbolComboBox() (defined in CAcUiSymbolComboBox) | CAcUiSymbolComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox | virtual
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiSymbolComboBox() (defined in CAcUiSymbolComboBox) | CAcUiSymbolComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAcUiSymbolEdit Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcUiSymbolEdit Class Reference
MFC Classes
+ Inheritance diagram for CAcUiSymbolEdit:

Public Member Functions

virtual void | SetStyleMask (DWORD mask)
- Public Member Functions inherited from CAcUiEdit
void | Convert ()
BOOL | ConvertData (CString &x)
BOOL | HasChanged ()
void | SetDirty ()
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiEdit
CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsStyleMaskSet (DWORD)
void | SetAdUiParent (CWnd *w)

Additional Inherited Members

- Public Attributes inherited from CAcUiEdit
BOOL | m_bChanged
BOOL | m_bTouch
CString | m_csMsg
double | m_dMaxValue
double | m_dMinValue
- Protected Member Functions inherited from CAcUiEdit
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg BOOL | OnChange ()
afx_msg void | OnErrSpace ()
afx_msg void | OnKillFocus (CWnd *pNewWnd)
- Protected Attributes inherited from CAdUiEdit
CWnd * | m_aduiParent
CPoint | m_lastMousePoint
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • acuiEdit.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiSymbolEdit Member List

This is the complete list of members for CAcUiSymbolEdit, including all inherited members.

CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit |
CAcUiSymbolEdit() (defined in CAcUiSymbolEdit) | CAcUiSymbolEdit |
CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit |
Convert() (defined in CAcUiEdit) | CAcUiEdit |
ConvertData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAcUiEdit) | CAcUiEdit | protectedvirtual
GetAdUiParent() (defined in CAdUiEdit) | CAdUiEdit |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit | virtual
GetStyleMask() (defined in CAdUiEdit) | CAdUiEdit |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit |
HasChanged() (defined in CAcUiEdit) | CAcUiEdit |
IsStyleMaskSet(DWORD) (defined in CAdUiEdit) | CAdUiEdit |
m_aduiParent (defined in CAdUiEdit) | CAdUiEdit | protected
m_bChanged (defined in CAcUiEdit) | CAcUiEdit |
m_bTouch (defined in CAcUiEdit) | CAcUiEdit |
m_csMsg (defined in CAcUiEdit) | CAcUiEdit |
m_dMaxValue (defined in CAcUiEdit) | CAcUiEdit |
m_dMinValue (defined in CAcUiEdit) | CAcUiEdit |
m_lastMousePoint (defined in CAdUiEdit) | CAdUiEdit | protected
m_styleMask (defined in CAdUiEdit) | CAdUiEdit |
m_tipRect (defined in CAdUiEdit) | CAdUiEdit | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiEdit) | CAdUiEdit | protected
OnChange() (defined in CAcUiEdit) | CAcUiEdit | protected
OnDrawTip(CDC &dc) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnErrSpace() (defined in CAcUiEdit) | CAcUiEdit | protected
OnGetTipRect(CRect &r) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAcUiEdit) | CAcUiEdit | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiEdit) | CAdUiEdit | protected
SetAdUiParent(CWnd *w) (defined in CAdUiEdit) | CAdUiEdit |
SetDirty() (defined in CAcUiEdit) | CAcUiEdit |
SetRange(double vMin, double vMax) (defined in CAcUiEdit) | CAcUiEdit |
SetStyleMask(DWORD mask) (defined in CAcUiSymbolEdit) | CAcUiSymbolEdit | virtual
Validate() (defined in CAcUiEdit) | CAcUiEdit |
ValidateData(CString &x) (defined in CAcUiEdit) | CAcUiEdit |
~CAcUiEdit() (defined in CAcUiEdit) | CAcUiEdit | virtual
~CAcUiSymbolEdit() (defined in CAcUiSymbolEdit) | CAcUiSymbolEdit | virtual
~CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit | virtual


ZRX API Reference: CAcUiTab Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiTab Class Reference
MFC Classes
+ Inheritance diagram for CAcUiTab:

Additional Inherited Members

- Public Member Functions inherited from CAdUiTab
BOOL | AddTab (int iPos, CString const &sTabname, UINT uTemplateID, CAdUiTabChildDialog *pDialog)
BOOL | AddTab (int iPos, UINT uTabStringID, UINT uTemplateID, CAdUiTabChildDialog *pDialog)
BOOL | DeleteItem (int iPos)
BOOL | DestroyTab (int iPos, BOOL bUpdateData=FALSE)
BOOL | DisplayData ()
BOOL | ExchangeData (BOOL bSaveAndValidate)
int | GetActiveTab ()
CAdUiTabChildDialog * | GetDialogPointer (int iPos)
CAdUiTabMainDialog * | GetMainDialog ()
int | GetTabIndex (CAdUiTabChildDialog *pDialog)
BOOL | IsDirty ()
BOOL | RemoveTab (int iPos)
int | SetActiveTab (int iPos)
void | SetApplyButtonID (UINT uID)
void | SetChildFocus ()
void | SetDirty (BOOL bDirty=TRUE)
void | SetValidationInfo (CDataExchange *pDX)
BOOL | ValidateData ()
- Protected Member Functions inherited from CAdUiTab
afx_msg BOOL | OnSelChange (NMHDR *pNMHDR, LRESULT *pResult)
afx_msg BOOL | OnSelChanging (NMHDR *pNMHDR, LRESULT *pResult)
virtual void | PreSubclassWindow ()
The documentation for this class was generated from the following file:
  • acuitabctrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiTab Member List

This is the complete list of members for CAcUiTab, including all inherited members.

AddTab(int iPos, CString const &sTabname, UINT uTemplateID, CAdUiTabChildDialog *pDialog) (defined in CAdUiTab) | CAdUiTab |
AddTab(int iPos, UINT uTabStringID, UINT uTemplateID, CAdUiTabChildDialog *pDialog) (defined in CAdUiTab) | CAdUiTab |
CAcUiTab() (defined in CAcUiTab) | CAcUiTab |
CAdUiTab() (defined in CAdUiTab) | CAdUiTab |
DeleteItem(int iPos) (defined in CAdUiTab) | CAdUiTab |
DestroyTab(int iPos, BOOL bUpdateData=FALSE) (defined in CAdUiTab) | CAdUiTab |
DisplayData() (defined in CAdUiTab) | CAdUiTab |
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiTab) | CAdUiTab |
GetActiveTab() (defined in CAdUiTab) | CAdUiTab |
GetDialogPointer(int iPos) (defined in CAdUiTab) | CAdUiTab |
GetMainDialog() (defined in CAdUiTab) | CAdUiTab |
GetTabIndex(CAdUiTabChildDialog *pDialog) (defined in CAdUiTab) | CAdUiTab |
IsDirty() (defined in CAdUiTab) | CAdUiTab |
OnSelChange(NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiTab) | CAdUiTab | protected
OnSelChanging(NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiTab) | CAdUiTab | protected
PreSubclassWindow() (defined in CAdUiTab) | CAdUiTab | protectedvirtual
RemoveTab(int iPos) (defined in CAdUiTab) | CAdUiTab |
SetActiveTab(int iPos) (defined in CAdUiTab) | CAdUiTab |
SetApplyButtonID(UINT uID) (defined in CAdUiTab) | CAdUiTab |
SetChildFocus() (defined in CAdUiTab) | CAdUiTab |
SetDirty(BOOL bDirty=TRUE) (defined in CAdUiTab) | CAdUiTab |
SetValidationInfo(CDataExchange *pDX) (defined in CAdUiTab) | CAdUiTab |
ValidateData() (defined in CAdUiTab) | CAdUiTab |
~CAcUiTab() (defined in CAcUiTab) | CAcUiTab | virtual
~CAdUiTab() (defined in CAdUiTab) | CAdUiTab | virtual


ZRX API Reference: CAcUiTabChildDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
CAcUiTabChildDialog Class Reference
MFC Classes
+ Inheritance diagram for CAcUiTabChildDialog:

Public Types

enum | { IDD = 0 }
- Public Types inherited from CAdUiTabChildDialog
enum | { IDD = 0 }
- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Public Types inherited from CAdUiBaseDialog
enum | { IDD = 0 }

Public Member Functions

virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAcUiTabChildDialog (CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual void | EnableFloatingWindows (BOOL allow)
virtual void | OnDialogHelp ()
virtual BOOL | OnMainDialogHelp ()
- Public Member Functions inherited from CAdUiTabChildDialog
CAdUiTabChildDialog (CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
CAdUiTab * | GetAcadTabPointer ()
CAdUiTabMainDialog * | GetMainDialog ()
int | GetTabIndex ()
BOOL | IsDirty ()
virtual void | OnMainDialogApply ()
virtual void | OnMainDialogCancel ()
virtual void | OnMainDialogOK ()
virtual void | OnTabActivation (BOOL bActivate)
virtual BOOL | OnTabChanging ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetAcadTabChildFocus (HWND hWndFocus)
void | SetDirty (BOOL bDirty=TRUE)
void | SetValidationInfo (CDataExchange *pDX)
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
- Protected Member Functions inherited from CAdUiTabChildDialog
virtual void | OnCancel ()
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
virtual void | OnOK ()
afx_msg LRESULT | OnResizePage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnSize (UINT nType, int cx, int cy)
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Additional Inherited Members

- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist
The documentation for this class was generated from the following file:
  • acuiDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiTabChildDialog Member List

This is the complete list of members for CAcUiTabChildDialog, including all inherited members.

AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog | virtual
AppResourceInstance() (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog | virtual
AppRootKey() (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAcUiTabChildDialog(CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CAdUiTabChildDialog(CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetAcadTabPointer() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetMainDialog() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetTabIndex() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog |
IsDirty() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnCancel() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protectedvirtual
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDialogHelp() (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog | virtual
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protectedvirtual
OnMainDialogApply() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
OnMainDialogCancel() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
OnMainDialogHelp() (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog | virtual
OnMainDialogOK() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protectedvirtual
OnResizePage(WPARAM wParam, LPARAM lParam) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protected
OnSize(UINT nType, int cx, int cy) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protected
OnTabActivation(BOOL bActivate) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
OnTabChanging() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAcadTabChildFocus(HWND hWndFocus) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetDirty(BOOL bDirty=TRUE) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetValidationInfo(CDataExchange *pDX) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAcUiTabChildDialog() (defined in CAcUiTabChildDialog) | CAcUiTabChildDialog | virtual
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAcUiTabMainDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | List of all members
CAcUiTabMainDialog Class Reference
MFC Classes
+ Inheritance diagram for CAcUiTabMainDialog:

Public Types

enum | { IDD = 0 }
- Public Types inherited from CAdUiTabMainDialog
enum | { IDD = 0 }
- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Public Types inherited from CAdUiBaseDialog
enum | { IDD = 0 }

Public Member Functions

virtual BOOL | AddApplicationTabs (LPCTSTR pszAppName)
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAcUiTabMainDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual int | IsMultiDocumentActivationEnabled ()
virtual void | OnDialogHelp ()
- Public Member Functions inherited from CAdUiTabMainDialog
int | AddExtendedTabs ()
BOOL | AddTab (int iPos, LPCTSTR tabName, UINT uTemplateID, CAdUiTabChildDialog *pDialog)
BOOL | AddTab (int iPos, UINT uTabStringID, UINT uTemplateID, CAdUiTabChildDialog *pDialog)
CAdUiTabMainDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
int | GetDefaultButton ()
int | GetInitialRequestedTabIndex ()
LPCTSTR | GetInitialTabIndex ()
CAdUiTab * | GetTabControl ()
int | GetTabIndex (CAdUiTabChildDialog *pDialog)
CAdUiTabExtensionManager * | GetXtabPointer ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | RemoveTab (int iPos)
void | SetDefaultButton (int nIdDefaultButton)
void | SetInitialTabIndex (LPCTSTR strTabIndex)
void | UpdateDefaultButton (HWND hFocusBefore, HWND hFocusAfter)
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
virtual void | OnCancel ()
virtual void | OnOK ()
- Protected Member Functions inherited from CAdUiTabMainDialog
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
void | RaiseApplyEvent ()
void | SetAcadTabPointer (CAdUiTab *pAcadTab)
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Additional Inherited Members

- Protected Attributes inherited from CAdUiTabMainDialog
CAdUiTabExtensionManager | m_xtabManager
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist
The documentation for this class was generated from the following file:
  • acuiDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiTabMainDialog Member List

This is the complete list of members for CAcUiTabMainDialog, including all inherited members.

AddApplicationTabs(LPCTSTR pszAppName) (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | virtual
AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AddExtendedTabs() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
AddTab(int iPos, LPCTSTR tabName, UINT uTemplateID, CAdUiTabChildDialog *pDialog) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
AddTab(int iPos, UINT uTabStringID, UINT uTemplateID, CAdUiTabChildDialog *pDialog) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
AppMainWindow() (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | virtual
AppResourceInstance() (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | virtual
AppRootKey() (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAcUiTabMainDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CAdUiTabMainDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetDefaultButton() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetInitialRequestedTabIndex() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
GetInitialTabIndex() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | inline
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetTabControl() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
GetTabIndex(CAdUiTabChildDialog *pDialog) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetXtabPointer() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
IDD enum value (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog |
IsMultiDocumentActivationEnabled() (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
m_xtabManager (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnCancel() (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | protectedvirtual
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDialogHelp() (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | virtual
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protectedvirtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | protectedvirtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protected
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | virtual
RaiseApplyEvent() | CAdUiTabMainDialog | protected
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
RemoveTab(int iPos) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAcadTabPointer(CAdUiTab *pAcadTab) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protected
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDefaultButton(int nIdDefaultButton) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetInitialTabIndex(LPCTSTR strTabIndex) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | inline
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
UpdateDefaultButton(HWND hFocusBefore, HWND hFocusAfter) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAcUiTabMainDialog() (defined in CAcUiTabMainDialog) | CAcUiTabMainDialog | virtual
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAcUiToolButton Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAcUiToolButton Class Reference
MFC Classes
+ Inheritance diagram for CAcUiToolButton:

Additional Inherited Members

- Public Member Functions inherited from CAdUiBitmapButton
BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Protected Member Functions inherited from CAdUiBitmapButton
void | CalcBitmapSize ()
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
BOOL | LoadBitmap (LPCTSTR strResId)
BOOL | LoadBitmapResource (LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst)
virtual BOOL | OnAutoLoad ()
virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
virtual BOOL | OnReload (LPCTSTR strResId)
- Protected Attributes inherited from CAdUiBitmapButton
BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • acuiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiToolButton Member List

This is the complete list of members for CAcUiToolButton, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAcUiToolButton() (defined in CAcUiToolButton) | CAcUiToolButton |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAdUiToolButton() (defined in CAdUiToolButton) | CAdUiToolButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAcUiToolButton() (defined in CAcUiToolButton) | CAcUiToolButton | virtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
~CAdUiToolButton() (defined in CAdUiToolButton) | CAdUiToolButton | virtual


ZRX API Reference: CAcUiTrueColorComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAcUiTrueColorComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAcUiTrueColorComboBox:

Public Types

enum ColorTableIndex {
kCargoOption1 = 0, kCargoOption2 = 1, kCargoStockItem1 = 2, kCargoStockItem2 = 3,
kCargoStockItem3 = 4, kCargoStockItem4 = 5, kCargoStockItem5 = 6, kCargoStockItem6 = 7,
kCargoStockItem7 = 8, kIndexOfFirstMRUItem = 9, kCargoOther1 = -1, kCargoOther2 = -2,
kLastIndex = ACUI_TRUECOLOR_COMBOBOX_TABLE_SIZE-1
}

Public Member Functions

int | AddColorToMRU (const AcCmColor &color)
void | AddItems ()
int | AddItemToList (LPCTSTR name, int index, INT_PTR cargo)
int | AddItemToMRU (LPCTSTR name, int cargo)
int | FindItemByColor (const AcCmColor &color)
const AcCmColor & | GetBlockColor ()
DWORD | getColorByCargo (int cargo)
DWORD | getColorData (AcCmColor color)
virtual COLORREF | GetColorFromIndex (int colorIndex)
int | GetColorIndex (COLORREF color)
void | GetCurrentItemColor (AcCmColor &color)
void | SetBlockColor (const AcCmColor &color)
- Public Member Functions inherited from CAcUiMRUComboBox
int | AddItemToList (LPCTSTR name, INT_PTR cargo)
virtual BOOL | Create (DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual int | ExtraWidth ()
int | FindItemByCargo (INT_PTR cargo)
int | GetCargoOption1 ()
int | GetCargoOption2 ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
INT_PTR | GetCurrentItemCargo ()
INT_PTR | GetItemCargo (int item)
virtual BOOL | GetItemColors (DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor)
LOGPALETTE * | GetLogPalette ()
HPALETTE | GetPalette ()
BOOL | GetUseByBlock ()
BOOL | GetUseByLayer ()
BOOL | GetUseOption1 ()
BOOL | GetUseOption2 ()
BOOL | GetUseOther ()
BOOL | GetUseOther1 ()
BOOL | GetUseOther2 ()
BOOL | GetUseWindows ()
virtual int | ImageWidth ()
int | InsertItemInList (int index, LPCTSTR name, INT_PTR cargo)
int | ItemHeight ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | RecalcHeight ()
void | RemoveItemFromMRU (int cargo)
void | SetCargoOption1 (int cargo)
void | SetCargoOption2 (int cargo)
void | SetLastSelection (int sel)
void | SetLogPalette (LOGPALETTE *logPalette)
void | SetPalette (HPALETTE hPalette)
void | SetUseByBlock (BOOL use)
void | SetUseByLayer (BOOL use)
void | SetUseOption1 (BOOL use)
void | SetUseOption2 (BOOL use)
void | SetUseOther (BOOL use)
void | SetUseOther1 (BOOL use)
void | SetUseOther2 (BOOL use)
void | SetUseWindows (BOOL use)
- Public Member Functions inherited from CAcUiComboBox
CAcUiEdit * | AcUiEditBox ()
void | Convert ()
BOOL | ConvertData (CString &x)
void | SetRange (double vMin, double vMax)
BOOL | Validate ()
ACUI_ERROR_CODE | ValidateData (CString &x)
- Public Member Functions inherited from CAdUiComboBox
CWnd * | GetAdUiParent ()
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

virtual void | DrawItemImage (CDC &dc, CRect &r, INT_PTR cargo)
bool | GetCurrentLayerColor (AcCmColor &color)
BOOL | GetOtherColor (AcCmColor &defaultColor, const AcCmColor &layerColor, BOOL enableMetaColors)
virtual BOOL | GetOtherName (BOOL isOther2, CString &name)
BOOL | GetWindowsColor (AcCmColor &color)
void | initAcCmColorTable (void)
virtual COLORREF | LookupColor (int colorIndex, LOGPALETTE *logPalette)
virtual void | OnAddItems ()
afx_msg void | OnDrawItem (int nIDCtl, LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual BOOL | OnSelectOther (BOOL isOther2, int curSel, int &newSel)
void | RGBFill (CDC &dc, CRect &rFill)
- Protected Member Functions inherited from CAcUiMRUComboBox
virtual int | CalcItemHeight ()
void | CreateAndSelectPalette (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc)
void | DrawItemImageFromCargo (CDC *dc, CRect &r, int i)
void | DrawTextAndFocusRect (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor)
BOOL | FindCargoInMRU (int cargo)
int | GenerateCargoFromMRU (int seed)
virtual BOOL | GetOptionName (BOOL isOption2, CString &name)
afx_msg BOOL | OnCloseUp ()
virtual void | OnComboBoxInit ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnDropDown ()
virtual BOOL | OnGetTipRect (CRect &r)
afx_msg BOOL | OnSelEndOk ()
virtual void | PreSubclassWindow ()
void | ResetAndRestorePalette (CDC *dc, int savedState)
void | SelectOther (BOOL isOther2)
void | SetupForImageDraw (LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor)
virtual LRESULT | WindowProc (UINT message, WPARAM wParam, LPARAM lParam)

Protected Attributes

AcCmColor * | m_AcCmColorTable [ACUI_TRUECOLOR_COMBOBOX_TABLE_SIZE]
AcCmColor | m_blockColor
int | m_cargoOther1
int | m_cargoOther2
int | m_nextAcCmColorTableIndex
- Protected Attributes inherited from CAcUiMRUComboBox
BOOL | m_bIsDynamicCreation: 1
BOOL | m_bOther1Selected: 1
BOOL | m_bOther2Selected: 1
BOOL | m_bUseOption1: 1
BOOL | m_bUseOption2: 1
BOOL | m_bUseOther1: 1
BOOL | m_bUseOther2: 1
int | m_cargoOption1
int | m_cargoOption2
HPALETTE | m_hPalette
int | m_itemHeight
int | m_lastSelection
LOGPALETTE * | m_logPalette
int | m_mruCargo [ACUI_MAX_COMBOBOX_MRU]
int | m_mruLen
CString | m_mruName [ACUI_MAX_COMBOBOX_MRU]
CPalette * | m_pOldPalette
The documentation for this class was generated from the following file:
  • acuiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcUiTrueColorComboBox Member List

This is the complete list of members for CAcUiTrueColorComboBox, including all inherited members.

AcUiEditBox() (defined in CAcUiComboBox) | CAcUiComboBox |
AddColorToMRU(const AcCmColor &color) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
AddItems() (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
AddItemToList(LPCTSTR name, int index, INT_PTR cargo) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
AddItemToList(LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
AddItemToMRU(LPCTSTR name, int cargo) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox |
CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
CAcUiTrueColorComboBox() (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
CalcItemHeight() | CAcUiMRUComboBox | protectedvirtual
ColorTableIndex enum name (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
Convert() (defined in CAcUiComboBox) | CAcUiComboBox |
ConvertData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
CreateAndSelectPalette(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
DrawItemImage(CDC &dc, CRect &r, INT_PTR cargo) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protectedvirtual
DrawItemImageFromCargo(CDC *dc, CRect &r, int i) | CAcUiMRUComboBox | protected
DrawTextAndFocusRect(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, int i, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
ExtraWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
FindCargoInMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
FindItemByCargo(INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
FindItemByColor(const AcCmColor &color) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
GenerateCargoFromMRU(int seed) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetBlockColor() (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
GetCargoOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCargoOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
getColorByCargo(int cargo) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
getColorData(AcCmColor color) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
GetColorFromIndex(int colorIndex) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | virtual
GetColorIndex(COLORREF color) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetCurrentItemCargo() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetCurrentItemColor(AcCmColor &color) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
GetCurrentLayerColor(AcCmColor &color) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetItemCargo(int item) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetItemColors(DRAWITEMSTRUCT &dis, COLORREF &fgColor, COLORREF &bgColor, COLORREF &fillColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLogPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetOptionName(BOOL isOption2, CString &name) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
GetOtherColor(AcCmColor &defaultColor, const AcCmColor &layerColor, BOOL enableMetaColors) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
GetOtherName(BOOL isOther2, CString &name) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protectedvirtual
GetPalette() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
GetUseByBlock() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseByLayer() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOption2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther1() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseOther2() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetUseWindows() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
GetWindowsColor(AcCmColor &color) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
ImageWidth() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
initAcCmColorTable(void) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
InsertItemInList(int index, LPCTSTR name, INT_PTR cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
ItemHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
kCargoOption1 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoOption2 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoOther1 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoOther2 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoStockItem1 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoStockItem2 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoStockItem3 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoStockItem4 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoStockItem5 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoStockItem6 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kCargoStockItem7 enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kIndexOfFirstMRUItem enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
kLastIndex enum value (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
LookupColor(int colorIndex, LOGPALETTE *logPalette) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protectedvirtual
m_AcCmColorTable (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bIsDynamicCreation (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_blockColor (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
m_bOther1Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bOther2Selected (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bUseOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_bUseOther2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption1 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOption2 (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_cargoOther1 (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
m_cargoOther2 (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
m_hPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_itemHeight (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastSelection (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_logPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruCargo (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruLen (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_mruName (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_nextAcCmColorTableIndex (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pOldPalette (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
OnAddItems() (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protectedvirtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCloseUp() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnComboBoxInit() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawItem(int nIDCtl, LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDropDown() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
OnGetTipRect(CRect &r) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnSelectOther(BOOL isOther2, int curSel, int &newSel) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protectedvirtual
OnSelEndOk() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
PreSubclassWindow() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
RecalcHeight() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
RemoveItemFromMRU(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
ResetAndRestorePalette(CDC *dc, int savedState) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
RGBFill(CDC &dc, CRect &rFill) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | protected
SelectOther(BOOL isOther2) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetBlockColor(const AcCmColor &color) (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox |
SetCargoOption1(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetCargoOption2(int cargo) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLastSelection(int sel) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetLogPalette(LOGPALETTE *logPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetPalette(HPALETTE hPalette) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetRange(double vMin, double vMax) (defined in CAcUiComboBox) | CAcUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
SetupForImageDraw(LPDRAWITEMSTRUCT lpDrawItemStruct, CDC *dc, CRect &rItem, CRect &rImage, COLORREF &fgColor, COLORREF &bgColor) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protected
SetUseByBlock(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseByLayer(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOption2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther1(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseOther2(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
SetUseWindows(BOOL use) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox |
Validate() (defined in CAcUiComboBox) | CAcUiComboBox |
ValidateData(CString &x) (defined in CAcUiComboBox) | CAcUiComboBox |
WindowProc(UINT message, WPARAM wParam, LPARAM lParam) (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | protectedvirtual
~CAcUiComboBox() (defined in CAcUiComboBox) | CAcUiComboBox | virtual
~CAcUiMRUComboBox() (defined in CAcUiMRUComboBox) | CAcUiMRUComboBox | virtual
~CAcUiTrueColorComboBox() (defined in CAcUiTrueColorComboBox) | CAcUiTrueColorComboBox | virtual
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAdUiBalloonTip Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiBalloonTip Class Reference
MFC Classes
+ Inheritance diagram for CAdUiBalloonTip:

Public Member Functions

virtual void | Hide ()
virtual void | Show ()
- Public Member Functions inherited from CAdUiTipWindow
virtual BOOL | Create (CWnd *owner)
CWnd * | GetControl ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | GetUseText ()
CWnd * | Owner ()
void | SetControl (CWnd *control)
void | SetUseText (BOOL useText)

Protected Member Functions

virtual void | DrawBorder (CDC &dc, CRect &rExterior, CRect &rInterior)
virtual void | DrawContent (CDC &dc, CRect &rInterior)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
- Protected Member Functions inherited from CAdUiTipWindow
afx_msg void | OnActivateApp (BOOL bActive, DWORD hTask)
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnNcDestroy ()
afx_msg void | OnPaint ()
afx_msg void | OnRButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnRButtonDown (UINT nFlags, CPoint point)
void | StartTimer (DWORD ms=50)
void | StopTimer ()

Protected Attributes

CPoint | m_initialCursorPos
- Protected Attributes inherited from CAdUiTipWindow
BOOL | m_bUseText
CWnd * | m_control
CWnd * | m_owner
UINT_PTR | m_timerId

Additional Inherited Members

- Static Protected Attributes inherited from CAdUiTipWindow
static LPCTSTR | m_className
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • aduiTextTip.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiBalloonTip Member List

This is the complete list of members for CAdUiBalloonTip, including all inherited members.

CAdUiBalloonTip() (defined in CAdUiBalloonTip) | CAdUiBalloonTip |
CAdUiTipWindow() (defined in CAdUiTipWindow) | CAdUiTipWindow |
Create(CWnd *owner) (defined in CAdUiTipWindow) | CAdUiTipWindow | virtual
DrawBorder(CDC &dc, CRect &rExterior, CRect &rInterior) (defined in CAdUiBalloonTip) | CAdUiBalloonTip | protectedvirtual
DrawContent(CDC &dc, CRect &rInterior) (defined in CAdUiBalloonTip) | CAdUiBalloonTip | protectedvirtual
GetControl() (defined in CAdUiTipWindow) | CAdUiTipWindow |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiTipWindow) | CAdUiTipWindow |
GetUseText() (defined in CAdUiTipWindow) | CAdUiTipWindow |
Hide() (defined in CAdUiBalloonTip) | CAdUiBalloonTip | virtual
m_bUseText (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
m_className (defined in CAdUiTipWindow) | CAdUiTipWindow | protectedstatic
m_control (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
m_initialCursorPos (defined in CAdUiBalloonTip) | CAdUiBalloonTip | protected
m_owner (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
m_timerEvent (defined in CAdUiTipWindow) | CAdUiTipWindow | protectedstatic
m_timerId (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnActivateApp(BOOL bActive, DWORD hTask) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnLButtonDown(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnMButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnMButtonDown(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnNcDestroy() (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnPaint() (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnRButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnRButtonDown(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiBalloonTip) | CAdUiBalloonTip | protected
Owner() (defined in CAdUiTipWindow) | CAdUiTipWindow |
SetControl(CWnd *control) (defined in CAdUiTipWindow) | CAdUiTipWindow |
SetUseText(BOOL useText) (defined in CAdUiTipWindow) | CAdUiTipWindow |
Show() (defined in CAdUiBalloonTip) | CAdUiBalloonTip | virtual
StartTimer(DWORD ms=50) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
StopTimer() (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
~CAdUiBalloonTip() (defined in CAdUiBalloonTip) | CAdUiBalloonTip | virtual
~CAdUiTipWindow() (defined in CAdUiTipWindow) | CAdUiTipWindow | virtual


ZRX API Reference: CAdUiBaseDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | Friends | List of all members
CAdUiBaseDialog Class Reference
MFC Classes
+ Inheritance diagram for CAdUiBaseDialog:

Public Types

enum { IDD = 0 }

Public Member Functions

virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual BOOL | DoDialogHelp ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual void | DoDataExchange (CDataExchange *pDX)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Protected Attributes

BOOL | m_bUseTips
ADUI_COMMAND_STATE | m_commandState
CString | m_contextHelpFileName
CString | m_contextHelpFullPathName
CString | m_contextHelpPrefix
HINSTANCE | m_hDialogResource
HICON | m_hIcon
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey

Static Protected Attributes

static CAdUiAssist * m_pUIAssist

Friends

class CAdUiAssist
The documentation for this class was generated from the following file:
  • aduiBaseDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiBaseDialog Member List

This is the complete list of members for CAdUiBaseDialog, including all inherited members.

AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAdUiAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | friend
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual


ZRX API Reference: CAdUiBitmapButton Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiBitmapButton Class Reference
MFC Classes
+ Inheritance diagram for CAdUiBitmapButton:

Public Member Functions

BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Public Member Functions inherited from CAdUiOwnerDrawButton
BOOL | AutoLoad ()
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
CWnd * | GetAdUiParent ()
BOOL | GetEnableDragDrop ()
BOOL | GetEnableFastDraw ()
BOOL | GetEnablePointedAt ()
BOOL | GetIsStatic ()
BOOL | GetIsToolButton ()
virtual void | PreSubclassWindow ()
BOOL | Reload (LPCTSTR strResId)
void | SetAdUiParent (CWnd *w)
void | SetEnableDragDrop (BOOL allow)
void | SetEnableFastDraw (BOOL allow)
void | SetEnablePointedAt (BOOL allow)
void | SetIsStatic (BOOL isStatic)
void | SetIsToolButton (BOOL isToolButton)
virtual CAdUiTheme * | SetTheme (CAdUiTheme *pTheme)
virtual void | SetTracking (BOOL b)

Protected Member Functions

void | CalcBitmapSize ()
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
BOOL | LoadBitmap (LPCTSTR strResId)
BOOL | LoadBitmapResource (LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst)
virtual BOOL | OnAutoLoad ()
virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
virtual BOOL | OnReload (LPCTSTR strResId)
- Protected Member Functions inherited from CAdUiOwnerDrawButton
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual void | DrawBorder (CDC *pDC, CRect &r, COLORREF cr)
virtual void | DrawHotBorder ()
virtual void | DrawPushButtonBorder (CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected)
virtual void | DrawToolButtonBorder (CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused)
void | DrawTransparentBitmap (CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled)
BOOL | GetIsPointedAt ()
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnDestroy ()
virtual void | OnDragDrop (HDROP hDropInfo)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
afx_msg void | OnDropFiles (HDROP hDropInfo)
afx_msg UINT | OnGetDlgCode ()
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnKillFocus (CWnd *pNewWnd)
afx_msg LRESULT | OnMouseLeave (WPARAM, LPARAM)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
afx_msg void | OnNcDestroy ()
virtual void | OnPointedAt (BOOL isPointedAt)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg LRESULT | OnThemeChanged (WPARAM wParam, LPARAM lParam)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
void | SetIsPointedAt (BOOL isPointedAt)
void | StartTimer (DWORD ms=50)
void | StopTimer ()
virtual void | ThemeModified (AdUiThemeElement element)

Protected Attributes

BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Protected Attributes inherited from CAdUiOwnerDrawButton
CWnd * | m_aduiParent
BOOL | m_bEnableDragDrop: 1
BOOL | m_bEnableFastDraw: 1
BOOL | m_bEnablePointedAt: 1
BOOL | m_bIsPointedAt: 1
BOOL | m_bIsStatic: 1
BOOL | m_bIsToolButton: 1
BOOL | m_bIsTrackButton: 1
BOOL | m_bMouseHover
CPoint | m_lastMousePoint
int | m_nPartId
int | m_nStateId
CAdUiTheme * | m_pTheme
UINT_PTR | m_timerId
CRect | m_tipRect
UINT | m_uEdge

Additional Inherited Members

- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR m_timerEvent
The documentation for this class was generated from the following file:
  • aduiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiBitmapButton Member List

This is the complete list of members for CAdUiBitmapButton, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAdUiBitmapStatic Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAdUiBitmapStatic Class Reference
MFC Classes
+ Inheritance diagram for CAdUiBitmapStatic:

Additional Inherited Members

- Public Member Functions inherited from CAdUiBitmapButton
BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Protected Member Functions inherited from CAdUiBitmapButton
void | CalcBitmapSize ()
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
BOOL | LoadBitmap (LPCTSTR strResId)
BOOL | LoadBitmapResource (LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst)
virtual BOOL | OnAutoLoad ()
virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
virtual BOOL | OnReload (LPCTSTR strResId)
- Protected Attributes inherited from CAdUiBitmapButton
BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • aduiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiBitmapStatic Member List

This is the complete list of members for CAdUiBitmapStatic, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiBitmapStatic() (defined in CAdUiBitmapStatic) | CAdUiBitmapStatic |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiBitmapStatic() (defined in CAdUiBitmapStatic) | CAdUiBitmapStatic | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAdUiCDFSVolumeDescriptor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiCDFSVolumeDescriptor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiCDFSVolumeDescriptor:

Public Member Functions

CAdUiCDFSVolumeDescriptor (const CString &)
BOOL | ValidateFilename (const CString *, const BOOL wildcard_ok=false) const
BOOL | ValidateSegment (const CString *, const BOOL wildcard_ok=false) const
- Public Member Functions inherited from CAdUiVolumeDescriptor
virtual BOOL | AllowsCaseSensitiveLookup (void) const
CAdUiVolumeDescriptor (const CString &)
virtual BOOL | CheckReadOnly () const
virtual const CString * | GetLocalName () const
virtual LONG | GetVolFreeSpace () const
virtual BOOL | IsCaseSensitive (void) const
BOOL | IsRemote () const
BOOL | IsRemovable () const
virtual BOOL | PreservesCase (void) const
virtual void | VolCase (CString &) const
virtual BOOL | VolMatch (const ACHAR *a, const CString *b) const
virtual BOOL | VolMatch (const CString *a, const CString *b) const
virtual BOOL | VolumeValid () const
virtual BOOL | WillFit (DWORD) const

Additional Inherited Members

- Protected Types inherited from CAdUiVolumeDescriptor
typedef unsigned | flagbits
- Protected Member Functions inherited from CAdUiVolumeDescriptor
int | Find (const CString &str, UINT ch) const
void | GetConnectionName (void)
int | IsControl (int c) const
- Protected Attributes inherited from CAdUiVolumeDescriptor
BOOL | m_amodeMultiByte
CString * | m_connection_name
flagbits | m_d_caseSensitive: 1
flagbits | m_d_cdrom: 1
flagbits | m_d_fixed: 1
flagbits | m_d_ramdisk: 1
flagbits | m_d_readonly: 1
flagbits | m_d_remote: 1
flagbits | m_d_removable: 1
const ACHAR * | m_doubleslash
DWORD | m_fsflags
int | m_max_component_size
int | m_max_path_length
FS_TYPE | m_vol_fs_type
CString * | m_vol_label
CString * | m_vol_localname
DWORD | m_vol_serial
ACHAR | m_vol_slash
The documentation for this class was generated from the following file:
  • aduiVolumeDescriptor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiCDFSVolumeDescriptor Member List

This is the complete list of members for CAdUiCDFSVolumeDescriptor, including all inherited members.

AllowsCaseSensitiveLookup(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
CAdUiCDFSVolumeDescriptor(const CString &) (defined in CAdUiCDFSVolumeDescriptor) | CAdUiCDFSVolumeDescriptor |
CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CAdUiVolumeDescriptor(const CString &) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CheckReadOnly() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
Find(const CString &str, UINT ch) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
flagbits typedef (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetConnectionName(void) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetLocalName() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
GetVolFreeSpace() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsCaseSensitive(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsControl(int c) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
IsRemote() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
IsRemovable() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
m_amodeMultiByte (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_connection_name (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_caseSensitive (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_cdrom (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_fixed (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_ramdisk (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_readonly (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_remote (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_removable (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_doubleslash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_fsflags (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_component_size (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_path_length (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_fs_type (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_label (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_localname (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_serial (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_slash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
PreservesCase(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
ValidateFilename(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiCDFSVolumeDescriptor) | CAdUiCDFSVolumeDescriptor | virtual
ValidateSegment(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiCDFSVolumeDescriptor) | CAdUiCDFSVolumeDescriptor | virtual
VolCase(CString &) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolMatch(const ACHAR *a, const CString *b) const | CAdUiVolumeDescriptor | virtual
VolMatch(const CString *a, const CString *b) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolumeValid() const | CAdUiVolumeDescriptor | virtual
WillFit(DWORD) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
~CAdUiCDFSVolumeDescriptor() (defined in CAdUiCDFSVolumeDescriptor) | CAdUiCDFSVolumeDescriptor | inline
~CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual


ZRX API Reference: CAdUiComboBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiComboBox Class Reference
MFC Classes
+ Inheritance diagram for CAdUiComboBox:

Public Member Functions

CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
CAdUiEdit * | GetEditBox ()
void | GetLBString (int nIndex, CString &rString)
CAdUiListBox * | GetListBox ()
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
CString | GetToolTipText (void) const
BOOL | IsOwnerDraw ()
BOOL | IsStatic ()
BOOL | IsStyleMaskSet (DWORD mask)
void | SetAdUiParent (CWnd *w)
void | SetEditBox (CAdUiEdit *control, BOOL autoDelete)
void | SetListBox (CAdUiListBox *control, BOOL autoDelete)
void | SetStyleMask (DWORD mask)
BOOL | SetToolTipText (const CString &sText)

Protected Member Functions

virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
afx_msg LRESULT | OnGetToolTipText (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)

Protected Attributes

CWnd * | m_aduiParent
BOOL | m_bAutoDeleteEBox: 1
BOOL | m_bAutoDeleteLBox: 1
BOOL | m_bSubclassedControls: 1
CPoint | m_lastMousePoint
CAdUiEdit * | m_pComboEBox
CAdUiListBox * | m_pComboLBox
CString | m_sToolTipText
CRect | m_tipRect

Member Function Documentation

void CAdUiComboBox::SetStyleMask ( DWORD mask )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aduiComboBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiComboBox Member List

This is the complete list of members for CAdUiComboBox, including all inherited members.

CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
GetAdUiParent() (defined in CAdUiComboBox) | CAdUiComboBox |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox | virtual
GetEditBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetLBString(int nIndex, CString &rString) (defined in CAdUiComboBox) | CAdUiComboBox |
GetListBox() (defined in CAdUiComboBox) | CAdUiComboBox |
GetStyleMask() (defined in CAdUiComboBox) | CAdUiComboBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiComboBox) | CAdUiComboBox |
GetToolTipText(void) const (defined in CAdUiComboBox) | CAdUiComboBox |
IsOwnerDraw() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStatic() (defined in CAdUiComboBox) | CAdUiComboBox |
IsStyleMaskSet(DWORD mask) (defined in CAdUiComboBox) | CAdUiComboBox |
m_aduiParent (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bAutoDeleteLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_bSubclassedControls (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_lastMousePoint (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboEBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_pComboLBox (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_sToolTipText (defined in CAdUiComboBox) | CAdUiComboBox | protected
m_tipRect (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnGetToolTipText(WPARAM wParam, LPARAM lParam) (defined in CAdUiComboBox) | CAdUiComboBox | protected
OnHitTipRect(CPoint &p) (defined in CAdUiComboBox) | CAdUiComboBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiComboBox) | CAdUiComboBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiComboBox) | CAdUiComboBox |
SetEditBox(CAdUiEdit *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetListBox(CAdUiListBox *control, BOOL autoDelete) (defined in CAdUiComboBox) | CAdUiComboBox |
SetStyleMask(DWORD mask) | CAdUiComboBox |
SetToolTipText(const CString &sText) (defined in CAdUiComboBox) | CAdUiComboBox |
~CAdUiComboBox() (defined in CAdUiComboBox) | CAdUiComboBox | virtual


ZRX API Reference: CAdUiCoupledGroupCtrl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiCoupledGroupCtrl Class Reference
MFC Classes

Public Member Functions

virtual void | AddCouple (CAdUiGroupCtrl *pAdUiTopWnd, CAdUiGroupCtrl *pAdUiBottomWnd)
virtual void | AddCouple (CWnd *pWndTop, CWnd *pWndBottom)
virtual void | AddCouple (CAdUiGroupCtrl *pAdUiTopWnd, CWnd *pWndBottom)
virtual void | AddCouple (CWnd *pWndTop, CAdUiGroupCtrl *pAdUiBottomWnd)
CAdUiCoupledGroupCtrl ()
bool | GetSplitterEnabled ()
double | GetTopToWholeRatio () const
virtual void | MinMaxOneChild (CWnd *pWnd, bool bMinimized)
void | SetSplitterEnabled (bool bSplitterEnabled)
void | SetTheme (CAdUiTheme *pTheme)
void | SetTopToWholeRatio (double topToWholeRatio)
virtual | ~CAdUiCoupledGroupCtrl ()

Protected Member Functions

bool | IsAnyCtrlMinimizedOrIconic ()
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint)
afx_msg void | OnLButtonUp (UINT nFlags, CPoint)
afx_msg void | OnMouseMove (UINT nFlags, CPoint)
afx_msg void | OnPaint ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
void | ResizeChildren (int cx, int cy)
bool | ValidateCtrls ()

Protected Attributes

bool | m_bDragging
CBrush | m_bkBrush
bool | m_bSplitterEnabled
COLORREF | m_crNCBackground
COLORREF | m_crSplitter
CAdUiGroupCtrl * | m_pAdUiBottomWnd
CAdUiGroupCtrl * | m_pAdUiTopWnd
CWnd * | m_pBottomWnd
CPoint | m_ptLast
CWnd * | m_pTopWnd
CRect | m_rtSpace
double | m_topToWholeRatio

Constructor & Destructor Documentation

CAdUiCoupledGroupCtrl::CAdUiCoupledGroupCtrl ( )
Warning
Not implemented!
virtual CAdUiCoupledGroupCtrl::~CAdUiCoupledGroupCtrl ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual void CAdUiCoupledGroupCtrl::AddCouple | ( | CAdUiGroupCtrl * | pAdUiTopWnd,
 |  | CAdUiGroupCtrl * | pAdUiBottomWnd
 | ) |  |
virtual
Warning
Not implemented!
virtual void CAdUiCoupledGroupCtrl::AddCouple | ( | CWnd * | pWndTop,
 |  | CWnd * | pWndBottom
 | ) |  |
virtual
Warning
Not implemented!
virtual void CAdUiCoupledGroupCtrl::AddCouple | ( | CAdUiGroupCtrl * | pAdUiTopWnd,
 |  | CWnd * | pWndBottom
 | ) |  |
virtual
Warning
Not implemented!
virtual void CAdUiCoupledGroupCtrl::AddCouple | ( | CWnd * | pWndTop,
 |  | CAdUiGroupCtrl * | pAdUiBottomWnd
 | ) |  |
virtual
Warning
Not implemented!
bool CAdUiCoupledGroupCtrl::IsAnyCtrlMinimizedOrIconic ( )
protected
Warning
Not implemented!
virtual void CAdUiCoupledGroupCtrl::MinMaxOneChild | ( | CWnd * | pWnd,
 |  | bool | bMinimized
 | ) |  |
virtual
Warning
Not implemented!
afx_msg HBRUSH CAdUiCoupledGroupCtrl::OnCtlColor | ( | CDC * | pDC,
 |  | CWnd * | pWnd,
 |  | UINT | nCtlColor
 | ) |  |
protected
Warning
Not implemented!
afx_msg void CAdUiCoupledGroupCtrl::OnLButtonDown | ( | UINT | nFlags,
 |  | CPoint |
 | ) |  |
protected
Warning
Not implemented!
afx_msg void CAdUiCoupledGroupCtrl::OnLButtonUp | ( | UINT | nFlags,
 |  | CPoint |
 | ) |  |
protected
Warning
Not implemented!
afx_msg void CAdUiCoupledGroupCtrl::OnMouseMove | ( | UINT | nFlags,
 |  | CPoint |
 | ) |  |
protected
Warning
Not implemented!
afx_msg void CAdUiCoupledGroupCtrl::OnPaint ( )
protected
Warning
Not implemented!
afx_msg void CAdUiCoupledGroupCtrl::OnSize | ( | UINT | nType,
 |  | int | cx,
 |  | int | cy
 | ) |  |
protected
Warning
Not implemented!
void CAdUiCoupledGroupCtrl::ResizeChildren | ( | int | cx,
 |  | int | cy
 | ) |  |
protected
Warning
Not implemented!
void CAdUiCoupledGroupCtrl::SetTheme ( CAdUiTheme * pTheme )
Warning
Not implemented!
bool CAdUiCoupledGroupCtrl::ValidateCtrls ( )
protected
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aduiCoupledGroupCtrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiCoupledGroupCtrl Member List

This is the complete list of members for CAdUiCoupledGroupCtrl, including all inherited members.

AddCouple(CAdUiGroupCtrl *pAdUiTopWnd, CAdUiGroupCtrl *pAdUiBottomWnd) | CAdUiCoupledGroupCtrl | virtual
AddCouple(CWnd *pWndTop, CWnd *pWndBottom) | CAdUiCoupledGroupCtrl | virtual
AddCouple(CAdUiGroupCtrl *pAdUiTopWnd, CWnd *pWndBottom) | CAdUiCoupledGroupCtrl | virtual
AddCouple(CWnd *pWndTop, CAdUiGroupCtrl *pAdUiBottomWnd) | CAdUiCoupledGroupCtrl | virtual
CAdUiCoupledGroupCtrl() | CAdUiCoupledGroupCtrl |
GetSplitterEnabled() (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | inline
GetTopToWholeRatio() const (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | inline
IsAnyCtrlMinimizedOrIconic() | CAdUiCoupledGroupCtrl | protected
m_bDragging (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_bkBrush (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_bSplitterEnabled (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_crNCBackground (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_crSplitter (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_pAdUiBottomWnd (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_pAdUiTopWnd (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_pBottomWnd (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_ptLast (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_pTopWnd (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_rtSpace (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
m_topToWholeRatio (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | protected
MinMaxOneChild(CWnd *pWnd, bool bMinimized) | CAdUiCoupledGroupCtrl | virtual
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) | CAdUiCoupledGroupCtrl | protected
OnLButtonDown(UINT nFlags, CPoint) | CAdUiCoupledGroupCtrl | protected
OnLButtonUp(UINT nFlags, CPoint) | CAdUiCoupledGroupCtrl | protected
OnMouseMove(UINT nFlags, CPoint) | CAdUiCoupledGroupCtrl | protected
OnPaint() | CAdUiCoupledGroupCtrl | protected
OnSize(UINT nType, int cx, int cy) | CAdUiCoupledGroupCtrl | protected
ResizeChildren(int cx, int cy) | CAdUiCoupledGroupCtrl | protected
SetSplitterEnabled(bool bSplitterEnabled) (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl | inline
SetTheme(CAdUiTheme *pTheme) | CAdUiCoupledGroupCtrl |
SetTopToWholeRatio(double topToWholeRatio) (defined in CAdUiCoupledGroupCtrl) | CAdUiCoupledGroupCtrl |
ValidateCtrls() | CAdUiCoupledGroupCtrl | protected
~CAdUiCoupledGroupCtrl() | CAdUiCoupledGroupCtrl | virtual


ZRX API Reference: CAdUiDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiDialog Class Reference
MFC Classes
+ Inheritance diagram for CAdUiDialog:

Public Types

enum | { IDD = 0 }
- Public Types inherited from CAdUiBaseDialog
enum | { IDD = 0 }

Public Member Functions

BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
virtual void | OnDialogHelp ()
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
virtual void | OnOK ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Protected Attributes

BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Protected Attributes inherited from CAdUiBaseDialog
BOOL | m_bUseTips
ADUI_COMMAND_STATE | m_commandState
CString | m_contextHelpFileName
CString | m_contextHelpFullPathName
CString | m_contextHelpPrefix
HINSTANCE | m_hDialogResource
HICON | m_hIcon
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey

Additional Inherited Members

- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * m_pUIAssist
The documentation for this class was generated from the following file:
  • aduiDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiDialog Member List

This is the complete list of members for CAdUiDialog, including all inherited members.

AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAdUiDialog) | CAdUiDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDialog) | CAdUiDialog | protected
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAdUiDialogBar Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiDialogBar Class Reference
MFC Classes
+ Inheritance diagram for CAdUiDialogBar:

Public Types

enum { IDD = 0 }

Public Member Functions

virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
BOOL | GetUseTips ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetUseTips (BOOL useTips)

Protected Member Functions

virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual void | DoDataExchange (CDataExchange *pDX)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg int | OnCreate (LPCREATESTRUCT lpcs)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()

Protected Attributes

BOOL | m_bUseTips
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey
The documentation for this class was generated from the following file:
  • aduiDialogBar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiDialogBar Member List

This is the complete list of members for CAdUiDialogBar, including all inherited members.

AppMainWindow() (defined in CAdUiDialogBar) | CAdUiDialogBar | virtual
AppResourceInstance() (defined in CAdUiDialogBar) | CAdUiDialogBar | virtual
AppRootKey() (defined in CAdUiDialogBar) | CAdUiDialogBar | virtual
CAdUiDialogBar() (defined in CAdUiDialogBar) | CAdUiDialogBar |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
GetUseTips() (defined in CAdUiDialogBar) | CAdUiDialogBar |
IDD enum value (defined in CAdUiDialogBar) | CAdUiDialogBar |
m_bUseTips (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
m_pTextTip (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
m_pToolTip (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
m_rootKey (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnCreate(LPCREATESTRUCT lpcs) (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiDialogBar) | CAdUiDialogBar | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
PostNcDestroy() (defined in CAdUiDialogBar) | CAdUiDialogBar | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiDialogBar) | CAdUiDialogBar | virtual
SetUseTips(BOOL useTips) (defined in CAdUiDialogBar) | CAdUiDialogBar |
~CAdUiDialogBar() (defined in CAdUiDialogBar) | CAdUiDialogBar | virtual


ZRX API Reference: CAdUiDialogWorksheet Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAdUiDialogWorksheet Class Reference
MFC Classes
+ Inheritance diagram for CAdUiDialogWorksheet:

Public Member Functions

virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
virtual BOOL | CreateEx (DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
virtual BOOL | DestroyWindow ()
CAdUiTheme * | GetTheme () const
virtual BOOL | OnInitDialog ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetDraw (const CAdUiWorksheetDraw *pDraw)
CAdUiTheme * | SetTheme (CAdUiTheme *pTheme)
virtual void | ThemeModified (AdUiThemeElement element)
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
virtual void | OnDialogHelp ()
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Static Public Member Functions

static CAdUiWorksheetDraw * SetDefaultDraw (CAdUiWorksheetDraw *pDraw)

Protected Member Functions

CAdUiDialogWorksheet (UINT ID, CWnd *pParent=NULL, HINSTANCE hResInst=NULL)
CAdUiDialogWorksheet (UINT ID, const CAdUiWorksheetDraw &draw, CWnd *pParent=NULL, HINSTANCE hResInst=NULL)
virtual void | DoDataExchange (CDataExchange *pDX)
afx_msg void | OnClose ()
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg void | OnDestroy ()
afx_msg void | OnDrawItem (int nIDCtl, LPDRAWITEMSTRUCT lpDrawItemStruct)
afx_msg BOOL | OnEraseBkgnd (CDC *pDC)
afx_msg void | OnGetMinMaxInfo (MINMAXINFO *lpMMI)
afx_msg void | OnIconEraseBkgnd (CDC *pDC)
afx_msg void | OnKillFocus (CWnd *pNewWnd)
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnLButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnMButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnMeasureItem (int nIDCtl, LPMEASUREITEMSTRUCT lpMeasureItemStruct)
afx_msg void | OnMouseMove (UINT nHitTest, CPoint point)
afx_msg void | OnMoving (UINT nSide, LPRECT lpRect)
afx_msg BOOL | OnNcActivate (BOOL bActive)
afx_msg void | OnNcCalcSize (BOOL bCalcValidRects, NCCALCSIZE_PARAMS *lpncsp)
afx_msg BOOL | OnNcCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnNcDestroy ()
afx_msg UINT | OnNcHitTest (CPoint point)
afx_msg void | OnNcLButtonDblClk (UINT nHitTest, CPoint point)
afx_msg void | OnNcLButtonDown (UINT nHitTest, CPoint point)
afx_msg void | OnNcLButtonUp (UINT nHitTest, CPoint point)
afx_msg void | OnNcMButtonDblClk (UINT nHitTest, CPoint point)
afx_msg void | OnNcMButtonDown (UINT nHitTest, CPoint point)
afx_msg void | OnNcMButtonUp (UINT nHitTest, CPoint point)
afx_msg void | OnNcMouseMove (UINT nHitTest, CPoint point)
afx_msg void | OnNcPaint ()
afx_msg void | OnNcRButtonDblClk (UINT nHitTest, CPoint point)
afx_msg void | OnNcRButtonDown (UINT nHitTest, CPoint point)
afx_msg void | OnNcRButtonUp (UINT nHitTest, CPoint point)
afx_msg void | OnPaint ()
afx_msg HCURSOR | OnQueryDragIcon ()
afx_msg void | OnRButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnRButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnRButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg void | OnSizing (UINT nSide, LPRECT lpRect)
afx_msg void | OnStyleChanged (int nStyleType, LPSTYLESTRUCT lpStyleStruct)
afx_msg void | OnStyleChanging (int nStyleType, LPSTYLESTRUCT lpStyleStruct)
virtual void | PostNcDestroy ()
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
virtual void | OnOK ()
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)

Protected Attributes

HICON | m_hIcon
- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Protected Attributes inherited from CAdUiBaseDialog
BOOL | m_bUseTips
ADUI_COMMAND_STATE | m_commandState
CString | m_contextHelpFileName
CString | m_contextHelpFullPathName
CString | m_contextHelpPrefix
HINSTANCE | m_hDialogResource
HICON | m_hIcon
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey

Friends

class CAdUiWorksheetThemeModReactor

Additional Inherited Members

- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist
The documentation for this class was generated from the following file:
  • aduiDialogWorksheet.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiDialogWorksheet Member List

This is the complete list of members for CAdUiDialogWorksheet, including all inherited members.

AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CAdUiDialogWorksheet(UINT ID, CWnd *pParent=NULL, HINSTANCE hResInst=NULL) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
CAdUiDialogWorksheet(UINT ID, const CAdUiWorksheetDraw &draw, CWnd *pParent=NULL, HINSTANCE hResInst=NULL) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
CAdUiWorksheetThemeModReactor (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | friend
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
DestroyWindow() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetTheme() const (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAdUiDialog) | CAdUiDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnClose() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnDestroy() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
OnDrawItem(int nIDCtl, LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnEraseBkgnd(CDC *pDC) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnGetMinMaxInfo(MINMAXINFO *lpMMI) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnIconEraseBkgnd(CDC *pDC) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnInitDialog() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnLButtonDown(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnLButtonUp(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMButtonDown(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMButtonUp(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMeasureItem(int nIDCtl, LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMouseMove(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnMoving(UINT nSide, LPRECT lpRect) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcActivate(BOOL bActive) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS *lpncsp) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcDestroy() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcHitTest(CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcLButtonDblClk(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcLButtonDown(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcLButtonUp(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcMButtonDblClk(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcMButtonDown(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcMButtonUp(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcMouseMove(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcPaint() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcRButtonDblClk(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcRButtonDown(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNcRButtonUp(UINT nHitTest, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnPaint() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnQueryDragIcon() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnRButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnRButtonDown(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnRButtonUp(UINT nFlags, CPoint point) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnSizing(UINT nSide, LPRECT lpRect) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnStyleChanged(int nStyleType, LPSTYLESTRUCT lpStyleStruct) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
OnStyleChanging(int nStyleType, LPSTYLESTRUCT lpStyleStruct) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protected
PostNcDestroy() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDefaultDraw(CAdUiWorksheetDraw *pDraw) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | static
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetDraw(const CAdUiWorksheetDraw *pDraw) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ThemeModified(AdUiThemeElement element) (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual
~CAdUiDialogWorksheet() (defined in CAdUiDialogWorksheet) | CAdUiDialogWorksheet | virtual


ZRX API Reference: CAdUiDockControlBar Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Types | Protected Member Functions | Friends | List of all members
CAdUiDockControlBar Class Reference
MFC Classes
+ Inheritance diagram for CAdUiDockControlBar:

Public Member Functions

bool | AdjustVertDockedBarHeight (int nHeight)
bool | AllowDockingMenuItemState ()
bool | Anchored ()
CAdUiDockControlBar (int nStyle=ADUI_DOCK_CS_STDMOUSECLICKS)
virtual CSize | CalcFixedLayout (BOOL bStretch, BOOL bHorz)
virtual bool | CanFrameworkTakeFocus ()
BOOL | Create (CWnd *pParent, LPCTSTR lpszTitle, UINT nID, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, const RECT &rect=CFrameWnd::rectDefault)
BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
void | DockControlBar (UINT nOrientation, RECT *pRect)
void | EnableDocking (DWORD dwDockStyle)
DWORD | GetDockStyle ()
void | GetFloatingRect (CRect *pFloatingPos)
void | GetPersistedDockingRect (CRect *pDockRect)
void | GetPersistedFloatingRect (CRect *pFloatRect)
CLSID * | GetToolID ()
void | InitFloatingPosition (CRect *pSizeFloating)
BOOL | IsFloating ()
virtual BOOL | Load (IUnknown *pUnk)
void | RestoreControlBar (UINT nPreferredOrientation=AFX_IDW_DOCKBAR_LEFT, CRect *pSizeFloating=NULL)
virtual BOOL | Save (IUnknown *pUnk)
void | SetAllowDockingMenuItemState (bool bState)
void | SetToolID (CLSID *pCLSID)
void | TileInRow ()

Static Public Member Functions

static bool | GetToolsRestartMode ()
static void | SetToolsRestartMode (bool bMode)

Protected Types

enum { btnWidth = 12, btnHeight = 12, idCloseBtn = 10001, idPinBtn = 10002 }

Protected Member Functions

virtual BOOL | AddCustomMenuItems (LPARAM hMenu)
bool | CloseButtonVisible ()
virtual BOOL | CreateControlBar (LPCREATESTRUCT lpCreateStruct)
virtual void | GetFloatingMinSize (long *pnMinWidth, long *pnMinHeight)
void | GetUsedRect (CRect &rect)
afx_msg void | OnAllowDock ()
afx_msg void | OnAnchor ()
afx_msg void | OnAnchorLeft ()
afx_msg void | OnAnchorRight ()
virtual bool | OnClosing ()
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
afx_msg void | OnContextMenu (CWnd *pWnd, CPoint point)
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg BOOL | OnEraseBkgnd (CDC *pDC)
afx_msg void | OnHideBar ()
afx_msg void | OnPaint ()
virtual void | OnUserSizing (UINT nSide, LPRECT pRect)
afx_msg void | OnWindowPosChanged (WINDOWPOS FAR *lpwndpos)
virtual void | PaintControlBar (CDC *pDC)
void | ShowCloseButton (bool bShow)
virtual void | SizeChanged (CRect *lpRect, BOOL bFloating, int flags)

Friends

class | CAdUiDockBar
class | CAdUiDockBarMutator
class | CAdUiDockDragContext
class | CAdUiDockFrame
class | CAdUiImpPaletteSet
class | CAdUiPaletteSetDockFrame

Member Function Documentation

virtual BOOL CAdUiDockControlBar::AddCustomMenuItems ( LPARAM hMenu )
protectedvirtual
Warning
Not implemented!
afx_msg void CAdUiDockControlBar::OnAnchor ( )
protected
Warning
Not implemented!
afx_msg void CAdUiDockControlBar::OnAnchorLeft ( )
protected
Warning
Not implemented!
afx_msg void CAdUiDockControlBar::OnAnchorRight ( )
protected
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aduiDock.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiDockControlBar Member List

This is the complete list of members for CAdUiDockControlBar, including all inherited members.

AddCustomMenuItems(LPARAM hMenu) | CAdUiDockControlBar | protectedvirtual
AdjustVertDockedBarHeight(int nHeight) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
AllowDockingMenuItemState() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
Anchored() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
btnHeight enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
btnWidth enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
CAdUiDockBar (defined in CAdUiDockControlBar) | CAdUiDockControlBar | friend
CAdUiDockBarMutator (defined in CAdUiDockControlBar) | CAdUiDockControlBar | friend
CAdUiDockControlBar(int nStyle=ADUI_DOCK_CS_STDMOUSECLICKS) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
CAdUiDockDragContext (defined in CAdUiDockControlBar) | CAdUiDockControlBar | friend
CAdUiDockFrame (defined in CAdUiDockControlBar) | CAdUiDockControlBar | friend
CAdUiImpPaletteSet (defined in CAdUiDockControlBar) | CAdUiDockControlBar | friend
CAdUiPaletteSetDockFrame (defined in CAdUiDockControlBar) | CAdUiDockControlBar | friend
CalcFixedLayout(BOOL bStretch, BOOL bHorz) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
CanFrameworkTakeFocus() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlinevirtual
CloseButtonVisible() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotected
Create(CWnd *pParent, LPCTSTR lpszTitle, UINT nID, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, const RECT &rect=CFrameWnd::rectDefault) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
CreateControlBar(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
DockControlBar(UINT nOrientation, RECT *pRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
EnableDocking(DWORD dwDockStyle) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetDockStyle() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
GetFloatingMinSize(long *pnMinWidth, long *pnMinHeight) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
GetFloatingRect(CRect *pFloatingPos) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetPersistedDockingRect(CRect *pDockRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetPersistedFloatingRect(CRect *pFloatRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetToolID() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
GetToolsRestartMode() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | static
GetUsedRect(CRect &rect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
idCloseBtn enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
idPinBtn enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
InitFloatingPosition(CRect *pSizeFloating) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
IsFloating() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
Load(IUnknown *pUnk) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
OnAllowDock() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnAnchor() | CAdUiDockControlBar | protected
OnAnchorLeft() | CAdUiDockControlBar | protected
OnAnchorRight() | CAdUiDockControlBar | protected
OnClosing() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
OnCommand(WPARAM wParam, LPARAM lParam) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
OnContextMenu(CWnd *pWnd, CPoint point) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnEraseBkgnd(CDC *pDC) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnHideBar() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnPaint() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnUserSizing(UINT nSide, LPRECT pRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotectedvirtual
OnWindowPosChanged(WINDOWPOS FAR *lpwndpos) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
PaintControlBar(CDC *pDC) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
RestoreControlBar(UINT nPreferredOrientation=AFX_IDW_DOCKBAR_LEFT, CRect *pSizeFloating=NULL) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
Save(IUnknown *pUnk) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
SetAllowDockingMenuItemState(bool bState) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
SetToolID(CLSID *pCLSID) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
SetToolsRestartMode(bool bMode) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | static
ShowCloseButton(bool bShow) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotected
SizeChanged(CRect *lpRect, BOOL bFloating, int flags) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotectedvirtual
TileInRow() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
~CAdUiDockControlBar() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual


ZRX API Reference: CAdUiDockFrame Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiDockFrame Class Reference
MFC Classes
+ Inheritance diagram for CAdUiDockFrame:

Public Types

enum ContainedBarType { Unknown, Standard, AdskBar }

Public Member Functions

enum ContainedBarType GetContainedBarType ()

Protected Member Functions

bool | CanAutoCADTakeFocus ()
bool | CanFrameworkTakeFocus ()
void | ForceChildRepaint ()
afx_msg void | OnClose ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
afx_msg int | OnMouseActivate (CWnd *pDesktopWnd, UINT nHitTest, UINT message)
afx_msg UINT | OnNcHitTest (CPoint point)
afx_msg void | OnNcLButtonDown (UINT nHitTest, CPoint pt)
afx_msg void | OnPaint ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg void | OnSizing (UINT nSide, LPRECT pRect)
afx_msg void | OnWindowPosChanging (WINDOWPOS *lpwndpos)
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Protected Attributes

bool | m_bZOrderChanged
enum ContainedBarType | m_nContainedBarType
The documentation for this class was generated from the following file:
  • aduiDock.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiDockFrame Member List

This is the complete list of members for CAdUiDockFrame, including all inherited members.

AdskBar enum value (defined in CAdUiDockFrame) | CAdUiDockFrame |
CAdUiDockFrame() (defined in CAdUiDockFrame) | CAdUiDockFrame |
CanAutoCADTakeFocus() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
CanFrameworkTakeFocus() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
ContainedBarType enum name (defined in CAdUiDockFrame) | CAdUiDockFrame |
ForceChildRepaint() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
GetContainedBarType() (defined in CAdUiDockFrame) | CAdUiDockFrame |
m_bZOrderChanged (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
m_nContainedBarType (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnClose() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnMouseActivate(CWnd *pDesktopWnd, UINT nHitTest, UINT message) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnNcHitTest(CPoint point) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnNcLButtonDown(UINT nHitTest, CPoint pt) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnPaint() (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnSizing(UINT nSide, LPRECT pRect) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
OnWindowPosChanging(WINDOWPOS *lpwndpos) (defined in CAdUiDockFrame) | CAdUiDockFrame | protected
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiDockFrame) | CAdUiDockFrame | protectedvirtual
Standard enum value (defined in CAdUiDockFrame) | CAdUiDockFrame |
Unknown enum value (defined in CAdUiDockFrame) | CAdUiDockFrame |


ZRX API Reference: CAdUiDrawTipText Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
CAdUiDrawTipText Class Reference
MFC Classes

Public Member Functions

CAdUiDrawTipText (CDC &dc, CRect &rect, CString &text)

Public Attributes

CDC & | m_dc
CRect & | m_rect
CString & | m_text
The documentation for this class was generated from the following file:
  • aduiMessage.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiDrawTipText Member List

This is the complete list of members for CAdUiDrawTipText, including all inherited members.

CAdUiDrawTipText(CDC &dc, CRect &rect, CString &text) (defined in CAdUiDrawTipText) | CAdUiDrawTipText
m_dc (defined in CAdUiDrawTipText) | CAdUiDrawTipText
m_rect (defined in CAdUiDrawTipText) | CAdUiDrawTipText
m_text (defined in CAdUiDrawTipText) | CAdUiDrawTipText


ZRX API Reference: CAdUiDropSite Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAdUiDropSite Class Reference
MFC Classes
+ Inheritance diagram for CAdUiDropSite:

Additional Inherited Members

- Public Member Functions inherited from CAdUiBitmapButton
BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Protected Member Functions inherited from CAdUiBitmapButton
void | CalcBitmapSize ()
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
BOOL | LoadBitmap (LPCTSTR strResId)
BOOL | LoadBitmapResource (LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst)
virtual BOOL | OnAutoLoad ()
virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
virtual BOOL | OnReload (LPCTSTR strResId)
- Protected Attributes inherited from CAdUiBitmapButton
BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • aduiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiDropSite Member List

This is the complete list of members for CAdUiDropSite, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiBitmapStatic() (defined in CAdUiBitmapStatic) | CAdUiBitmapStatic |
CAdUiDropSite() (defined in CAdUiDropSite) | CAdUiDropSite |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiBitmapStatic() (defined in CAdUiBitmapStatic) | CAdUiBitmapStatic | virtual
~CAdUiDropSite() (defined in CAdUiDropSite) | CAdUiDropSite | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAdUiDropTarget Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiDropTarget Class Reference
MFC Classes

Public Member Functions

CAdUiDropTarget (int nId)
BOOL SetTargetWindowForMessages (CWnd *pWnd)

Protected Member Functions

virtual DROPEFFECT | OnDragEnter (CWnd *pWnd, COleDataObject *pDataObject, DWORD dwKeyState, CPoint point)
virtual void | OnDragLeave (CWnd *pWnd)
virtual DROPEFFECT | OnDragOver (CWnd *pWnd, COleDataObject *pDataObject, DWORD dwKeyState, CPoint point)
virtual DROPEFFECT | OnDragScroll (CWnd *pWnd, DWORD dwKeyState, CPoint point)
virtual BOOL | OnDrop (CWnd *pWnd, COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point)
virtual DROPEFFECT | OnDropEx (CWnd *pWnd, COleDataObject *pDataObject, DROPEFFECT dropDefault, DROPEFFECT dropList, CPoint point)

Protected Attributes

DWORD | mdwKeyState
int | mnId
CWnd * | mpTargetWnd

Member Function Documentation

BOOL CAdUiDropTarget::SetTargetWindowForMessages ( CWnd * pWnd )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aduiDropTarget.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiDropTarget Member List

This is the complete list of members for CAdUiDropTarget, including all inherited members.

CAdUiDropTarget() (defined in CAdUiDropTarget) | CAdUiDropTarget |
CAdUiDropTarget(int nId) (defined in CAdUiDropTarget) | CAdUiDropTarget |
mdwKeyState (defined in CAdUiDropTarget) | CAdUiDropTarget | protected
mnId (defined in CAdUiDropTarget) | CAdUiDropTarget | protected
mpTargetWnd (defined in CAdUiDropTarget) | CAdUiDropTarget | protected
OnDragEnter(CWnd *pWnd, COleDataObject *pDataObject, DWORD dwKeyState, CPoint point) (defined in CAdUiDropTarget) | CAdUiDropTarget | protectedvirtual
OnDragLeave(CWnd *pWnd) (defined in CAdUiDropTarget) | CAdUiDropTarget | protectedvirtual
OnDragOver(CWnd *pWnd, COleDataObject *pDataObject, DWORD dwKeyState, CPoint point) (defined in CAdUiDropTarget) | CAdUiDropTarget | protectedvirtual
OnDragScroll(CWnd *pWnd, DWORD dwKeyState, CPoint point) (defined in CAdUiDropTarget) | CAdUiDropTarget | protectedvirtual
OnDrop(CWnd *pWnd, COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point) (defined in CAdUiDropTarget) | CAdUiDropTarget | protectedvirtual
OnDropEx(CWnd *pWnd, COleDataObject *pDataObject, DROPEFFECT dropDefault, DROPEFFECT dropList, CPoint point) (defined in CAdUiDropTarget) | CAdUiDropTarget | protectedvirtual
SetTargetWindowForMessages(CWnd *pWnd) | CAdUiDropTarget |
~CAdUiDropTarget() (defined in CAdUiDropTarget) | CAdUiDropTarget |


ZRX API Reference: CAdUiEdit Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CAdUiEdit Class Reference
MFC Classes
+ Inheritance diagram for CAdUiEdit:

Public Member Functions

CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (LPCTSTR text, int &width, int &height)
DWORD | GetStyleMask ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsStyleMaskSet (DWORD)
void | SetAdUiParent (CWnd *w)
virtual void | SetStyleMask (DWORD)

Public Attributes

DWORD m_styleMask

Protected Member Functions

virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)

Protected Attributes

CWnd * | m_aduiParent
CPoint | m_lastMousePoint
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • aduiEdit.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiEdit Member List

This is the complete list of members for CAdUiEdit, including all inherited members.

CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
GetAdUiParent() (defined in CAdUiEdit) | CAdUiEdit |
GetContentExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit | virtual
GetStyleMask() (defined in CAdUiEdit) | CAdUiEdit |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiEdit) | CAdUiEdit |
IsStyleMaskSet(DWORD) (defined in CAdUiEdit) | CAdUiEdit |
m_aduiParent (defined in CAdUiEdit) | CAdUiEdit | protected
m_lastMousePoint (defined in CAdUiEdit) | CAdUiEdit | protected
m_styleMask (defined in CAdUiEdit) | CAdUiEdit |
m_tipRect (defined in CAdUiEdit) | CAdUiEdit | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiEdit) | CAdUiEdit | protected
OnDrawTip(CDC &dc) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiEdit) | CAdUiEdit | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiEdit) | CAdUiEdit | protected
SetAdUiParent(CWnd *w) (defined in CAdUiEdit) | CAdUiEdit |
SetStyleMask(DWORD) (defined in CAdUiEdit) | CAdUiEdit | virtual
~CAdUiEdit() (defined in CAdUiEdit) | CAdUiEdit | virtual


ZRX API Reference: CAdUiFATVolumeDescriptor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
CAdUiFATVolumeDescriptor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiFATVolumeDescriptor:

Public Member Functions

CAdUiFATVolumeDescriptor (const CString &)
BOOL | ValidateFilename (const CString *, const BOOL wildcard_ok=false) const
BOOL | ValidateSegment (const CString *, const BOOL wildcard_ok=false) const
- Public Member Functions inherited from CAdUiVolumeDescriptor
virtual BOOL | AllowsCaseSensitiveLookup (void) const
CAdUiVolumeDescriptor (const CString &)
virtual BOOL | CheckReadOnly () const
virtual const CString * | GetLocalName () const
virtual LONG | GetVolFreeSpace () const
virtual BOOL | IsCaseSensitive (void) const
BOOL | IsRemote () const
BOOL | IsRemovable () const
virtual BOOL | PreservesCase (void) const
virtual void | VolCase (CString &) const
virtual BOOL | VolMatch (const ACHAR *a, const CString *b) const
virtual BOOL | VolMatch (const CString *a, const CString *b) const
virtual BOOL | VolumeValid () const
virtual BOOL | WillFit (DWORD) const

Protected Attributes

int | m_segc
- Protected Attributes inherited from CAdUiVolumeDescriptor
BOOL | m_amodeMultiByte
CString * | m_connection_name
flagbits | m_d_caseSensitive: 1
flagbits | m_d_cdrom: 1
flagbits | m_d_fixed: 1
flagbits | m_d_ramdisk: 1
flagbits | m_d_readonly: 1
flagbits | m_d_remote: 1
flagbits | m_d_removable: 1
const ACHAR * | m_doubleslash
DWORD | m_fsflags
int | m_max_component_size
int | m_max_path_length
FS_TYPE | m_vol_fs_type
CString * | m_vol_label
CString * | m_vol_localname
DWORD | m_vol_serial
ACHAR | m_vol_slash

Additional Inherited Members

- Protected Types inherited from CAdUiVolumeDescriptor
typedef unsigned | flagbits
- Protected Member Functions inherited from CAdUiVolumeDescriptor
int | Find (const CString &str, UINT ch) const
void | GetConnectionName (void)
int | IsControl (int c) const
The documentation for this class was generated from the following file:
  • aduiVolumeDescriptor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiFATVolumeDescriptor Member List

This is the complete list of members for CAdUiFATVolumeDescriptor, including all inherited members.

AllowsCaseSensitiveLookup(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
CAdUiFATVolumeDescriptor(const CString &) (defined in CAdUiFATVolumeDescriptor) | CAdUiFATVolumeDescriptor |
CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CAdUiVolumeDescriptor(const CString &) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CheckReadOnly() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
Find(const CString &str, UINT ch) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
flagbits typedef (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetConnectionName(void) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetLocalName() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
GetVolFreeSpace() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsCaseSensitive(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsControl(int c) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
IsRemote() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
IsRemovable() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
m_amodeMultiByte (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_connection_name (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_caseSensitive (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_cdrom (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_fixed (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_ramdisk (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_readonly (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_remote (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_removable (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_doubleslash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_fsflags (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_component_size (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_path_length (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_segc (defined in CAdUiFATVolumeDescriptor) | CAdUiFATVolumeDescriptor | protected
m_vol_fs_type (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_label (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_localname (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_serial (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_slash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
PreservesCase(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
ValidateFilename(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiFATVolumeDescriptor) | CAdUiFATVolumeDescriptor | virtual
ValidateSegment(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiFATVolumeDescriptor) | CAdUiFATVolumeDescriptor | virtual
VolCase(CString &) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolMatch(const ACHAR *a, const CString *b) const | CAdUiVolumeDescriptor | virtual
VolMatch(const CString *a, const CString *b) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolumeValid() const | CAdUiVolumeDescriptor | virtual
WillFit(DWORD) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
~CAdUiFATVolumeDescriptor() (defined in CAdUiFATVolumeDescriptor) | CAdUiFATVolumeDescriptor | inline
~CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual


ZRX API Reference: CAdUiFileDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiFileDialog Class Reference
MFC Classes
+ Inheritance diagram for CAdUiFileDialog:

Public Types

enum { IDD = 0 }

Public Member Functions

virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiFileDialog (BOOL bOpenFileDialog, LPCTSTR lpszDefExt=NULL, LPCTSTR lpszFileName=NULL, DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT, LPCTSTR lpszFilter=NULL, CWnd *pParentWnd=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
void | GetDialogHelpTag (CString &tag)
HICON | GetDialogIcon ()
void | GetDialogName (CString &name)
BOOL | GetUseTips ()
virtual void | OnDialogHelp ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogIcon (HICON hIcon)
void | SetDialogName (LPCTSTR name)
void | SetUseTips (BOOL useTips)

Protected Member Functions

void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual void | DoDataExchange (CDataExchange *pDX)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Protected Attributes

BOOL | m_bUseTips
ADUI_COMMAND_STATE | m_commandState
CString | m_contextHelpFileName
CString | m_contextHelpFullPathName
CString | m_contextHelpPrefix
HINSTANCE | m_hDialogResource
HICON | m_hIcon
CWnd * | m_pParent
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey
The documentation for this class was generated from the following file:
  • aduiFileDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiFileDialog Member List

This is the complete list of members for CAdUiFileDialog, including all inherited members.

AppMainWindow() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
AppResourceInstance() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
AppRootKey() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
BeginEditorCommand() (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
CAdUiFileDialog(BOOL bOpenFileDialog, LPCTSTR lpszDefExt=NULL, LPCTSTR lpszFileName=NULL, DWORD dwFlags=OFN_HIDEREADONLY|OFN_OVERWRITEPROMPT, LPCTSTR lpszFilter=NULL, CWnd *pParentWnd=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiFileDialog) | CAdUiFileDialog |
CancelEditorCommand() (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
DoModal() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
EditorCommandCancelled() (defined in CAdUiFileDialog) | CAdUiFileDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
GetContextHelpFileName() (defined in CAdUiFileDialog) | CAdUiFileDialog |
GetContextHelpFullPathName() (defined in CAdUiFileDialog) | CAdUiFileDialog |
GetContextHelpPrefix() (defined in CAdUiFileDialog) | CAdUiFileDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiFileDialog) | CAdUiFileDialog | inline
GetDialogIcon() (defined in CAdUiFileDialog) | CAdUiFileDialog |
GetDialogName(CString &name) (defined in CAdUiFileDialog) | CAdUiFileDialog | inline
GetUseTips() (defined in CAdUiFileDialog) | CAdUiFileDialog |
IDD enum value (defined in CAdUiFileDialog) | CAdUiFileDialog |
m_bUseTips (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_commandState (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_contextHelpFileName (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_contextHelpFullPathName (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_contextHelpPrefix (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_hDialogResource (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_hIcon (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_pParent (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_pTextTip (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_pToolTip (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
m_rootKey (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnDialogHelp() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnInitDialog() (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiFileDialog) | CAdUiFileDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
PostNcDestroy() (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiFileDialog) | CAdUiFileDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiFileDialog) | CAdUiFileDialog | inline
SetDialogIcon(HICON hIcon) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiFileDialog) | CAdUiFileDialog |
SetUseTips(BOOL useTips) (defined in CAdUiFileDialog) | CAdUiFileDialog |
~CAdUiFileDialog() (defined in CAdUiFileDialog) | CAdUiFileDialog | virtual


ZRX API Reference: CAdUiGroupCtrl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CAdUiGroupCtrl Class Reference
MFC Classes

Public Member Functions

virtual bool | AddBmpBtnToHeader (LPCTSTR pszResName, AdUiBmpBtnFcnPtr fcnPtr, DWORD &dwCookie, LPCTSTR pszToolTip)
virtual bool | AddBmpBtnToHeader (CBitmap *pBmp, AdUiBmpBtnFcnPtr fcnPtr, DWORD &dwCookie, LPCTSTR pszToolTip)
virtual bool | AddWnd (CWnd *pWnd, LPCTSTR pszTitle, CBitmap *pBMP=NULL)
virtual bool | AddWnd (CWnd *pWnd, LPCTSTR pszTitle, LPCTSTR pszResName)
bool | GetActive ()
int | GetHeaderHeight ()
bool | GetHideGroupHeader ()
bool | GetMinimized () const
int | GetSelIndex ()
DWORD | GetStyle ()
virtual void | ModGroupStyle (DWORD styleRemove, DWORD styleAdd)
virtual bool | RemoveBmpBtnFromHeader (DWORD dwCookie)
void | SetActive (bool bActive)
virtual void | SetFont (CFont *pFont)
virtual void | SetFont (CFont *pFont, BOOL bRedraw)
void | SetHeaderHeight (int nHeight)
void | SetHideGroupHeader (bool bHide)
virtual void | SetMinimized (bool bMinimized)
void | SetSelIndex (int nSelIndex)
void | SetStyle (DWORD nStyle)
virtual void | SetTheme (CAdUiTheme *pTheme)
void | SetTitle (LPCTSTR pszTitle)
virtual bool | ShowWnd (CWnd *pWnd)

Protected Member Functions

virtual void | DeselectGroupHeader ()
virtual void | DrawGroupContent (CDC *pDC)
virtual void | DrawGroupHeader (CDC *pDC)
void | OnChevronClicked ()
afx_msg HBRUSH | OnCtlColor (CDC *, CWnd *, UINT)
afx_msg BOOL | OnEraseBkgnd (CDC *)
afx_msg void | OnKillFocus (CWnd *pNewWnd)
afx_msg void | OnNcCalcSize (BOOL bCalcValidRects, NCCALCSIZE_PARAMS *) afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct)
afx_msg UINT | OnNcHitTest (CPoint point)
afx_msg void | OnNcLButtonDblClk (UINT nHitTest, CPoint)
afx_msg void | OnNcLButtonDown (UINT nHitTest, CPoint)
afx_msg void | OnNcPaint ()
afx_msg void | OnPaint ()
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg void | OnSize (UINT nType, int cx, int cy)
virtual BOOL | PreTranslateMessage (MSG *pMsg)

Protected Attributes

bool | m_bActive
CBrush | m_bgBrush
bool | m_bHideGroupHeader
bool | m_bMinimized
ADUIHEADERBTNLIST | m_bmpBtnList
COLORREF | m_crButtonBorderNormal
COLORREF | m_crButtonBorderSelected1
COLORREF | m_crButtonBorderSelected2
COLORREF | m_crButtonFillNormal
COLORREF | m_crButtonFillSelected
COLORREF | m_crGroupBorder
COLORREF | m_crHeaderActive
COLORREF | m_crHeaderInactive
COLORREF | m_crNCBackground
COLORREF | m_crTitleText
CString | m_csTitle
DWORD | m_dwBtnId
ADUIGROUPCTRLDATALIST | m_groupList
int | m_nHeaderHeight
int | m_nRestoreHeight
int | m_nSelIndex
DWORD | m_nStyle
CToolTipCtrl | m_ToolTip

Static Protected Attributes

static LOGFONT m_lf

Member Function Documentation

virtual bool CAdUiGroupCtrl::AddBmpBtnToHeader | ( | LPCTSTR | pszResName,
 |  | AdUiBmpBtnFcnPtr | fcnPtr,
 |  | DWORD & | dwCookie,
 |  | LPCTSTR | pszToolTip
 | ) |  |
virtual
Warning
Not implemented!
virtual bool CAdUiGroupCtrl::AddBmpBtnToHeader | ( | CBitmap * | pBmp,
 |  | AdUiBmpBtnFcnPtr | fcnPtr,
 |  | DWORD & | dwCookie,
 |  | LPCTSTR | pszToolTip
 | ) |  |
virtual
Warning
Not implemented!
virtual bool CAdUiGroupCtrl::AddWnd | ( | CWnd * | pWnd,
 |  | LPCTSTR | pszTitle,
 |  | CBitmap * | pBMP = NULL
 | ) |  |
virtual
Warning
Not implemented!
virtual bool CAdUiGroupCtrl::AddWnd | ( | CWnd * | pWnd,
 |  | LPCTSTR | pszTitle,
 |  | LPCTSTR | pszResName
 | ) |  |
virtual
Warning
Not implemented!
virtual void CAdUiGroupCtrl::DeselectGroupHeader ( )
inlineprotectedvirtual
Warning
Not implemented!
virtual void CAdUiGroupCtrl::DrawGroupContent ( CDC * pDC )
protectedvirtual
Warning
Not implemented!
virtual void CAdUiGroupCtrl::DrawGroupHeader ( CDC * pDC )
protectedvirtual
Warning
Not implemented!
int CAdUiGroupCtrl::GetSelIndex ( )
Warning
Not implemented!
virtual void CAdUiGroupCtrl::ModGroupStyle | ( | DWORD | styleRemove,
 |  | DWORD | styleAdd
 | ) |  |
virtual
Warning
Not implemented!
void CAdUiGroupCtrl::OnChevronClicked ( )
protected
Warning
Not implemented!
afx_msg HBRUSH CAdUiGroupCtrl::OnCtlColor | ( | CDC * | ,
 |  | CWnd * | ,
 |  | UINT |
 | ) |  |
protected
Warning
Not implemented!
afx_msg void CAdUiGroupCtrl::OnKillFocus ( CWnd * pNewWnd )
protected
Warning
Not implemented!
afx_msg void CAdUiGroupCtrl::OnNcCalcSize | ( | BOOL | bCalcValidRects,
 |  | NCCALCSIZE_PARAMS * |
 | ) |  |
protected
Warning
Not implemented!
Not implemented!
afx_msg UINT CAdUiGroupCtrl::OnNcHitTest ( CPoint point )
protected
Warning
Not implemented!
afx_msg void CAdUiGroupCtrl::OnNcLButtonDblClk | ( | UINT | nHitTest,
 |  | CPoint |
 | ) |  |
protected
Warning
Not implemented!
afx_msg void CAdUiGroupCtrl::OnNcLButtonDown | ( | UINT | nHitTest,
 |  | CPoint |
 | ) |  |
protected
Warning
Not implemented!
afx_msg void CAdUiGroupCtrl::OnNcPaint ( )
protected
Warning
Not implemented!
afx_msg void CAdUiGroupCtrl::OnPaint ( )
protected
Warning
Not implemented!
afx_msg void CAdUiGroupCtrl::OnSetFocus ( CWnd * pOldWnd )
protected
Warning
Not implemented!
afx_msg void CAdUiGroupCtrl::OnSize | ( | UINT | nType,
 |  | int | cx,
 |  | int | cy
 | ) |  |
protected
Warning
Not implemented!
virtual BOOL CAdUiGroupCtrl::PreTranslateMessage ( MSG * pMsg )
protectedvirtual
Warning
Not implemented!
virtual bool CAdUiGroupCtrl::RemoveBmpBtnFromHeader ( DWORD dwCookie )
virtual
Warning
Not implemented!
void CAdUiGroupCtrl::SetActive ( bool bActive )
Warning
Not implemented!
virtual void CAdUiGroupCtrl::SetFont ( CFont * pFont )
virtual
Warning
Not implemented!
virtual void CAdUiGroupCtrl::SetFont | ( | CFont * | pFont,
 |  | BOOL | bRedraw
 | ) |  |
virtual
Warning
Not implemented!
void CAdUiGroupCtrl::SetSelIndex ( int nSelIndex )
Warning
Not implemented!
virtual void CAdUiGroupCtrl::SetTheme ( CAdUiTheme * pTheme )
virtual
Warning
Not implemented!
virtual bool CAdUiGroupCtrl::ShowWnd ( CWnd * pWnd )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aduiGroupCtrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiGroupCtrl Member List

This is the complete list of members for CAdUiGroupCtrl, including all inherited members.

AddBmpBtnToHeader(LPCTSTR pszResName, AdUiBmpBtnFcnPtr fcnPtr, DWORD &dwCookie, LPCTSTR pszToolTip) | CAdUiGroupCtrl | virtual
AddBmpBtnToHeader(CBitmap *pBmp, AdUiBmpBtnFcnPtr fcnPtr, DWORD &dwCookie, LPCTSTR pszToolTip) | CAdUiGroupCtrl | virtual
AddWnd(CWnd *pWnd, LPCTSTR pszTitle, CBitmap *pBMP=NULL) | CAdUiGroupCtrl | virtual
AddWnd(CWnd *pWnd, LPCTSTR pszTitle, LPCTSTR pszResName) | CAdUiGroupCtrl | virtual
CAdUiGroupCtrl() (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl |
DeselectGroupHeader() | CAdUiGroupCtrl | inlineprotectedvirtual
DrawGroupContent(CDC *pDC) | CAdUiGroupCtrl | protectedvirtual
DrawGroupHeader(CDC *pDC) | CAdUiGroupCtrl | protectedvirtual
GetActive() (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inline
GetHeaderHeight() (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inline
GetHideGroupHeader() (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inline
GetMinimized() const (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inline
GetSelIndex() | CAdUiGroupCtrl |
GetStyle() (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inline
m_bActive (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_bgBrush (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_bHideGroupHeader (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_bMinimized (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_bmpBtnList (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crButtonBorderNormal (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crButtonBorderSelected1 (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crButtonBorderSelected2 (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crButtonFillNormal (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crButtonFillSelected (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crGroupBorder (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crHeaderActive (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crHeaderInactive (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crNCBackground (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_crTitleText (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_csTitle (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_dwBtnId (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_groupList (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_lf (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protectedstatic
m_nHeaderHeight (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_nRestoreHeight (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_nSelIndex (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_nStyle (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
m_ToolTip (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | protected
ModGroupStyle(DWORD styleRemove, DWORD styleAdd) | CAdUiGroupCtrl | virtual
OnChevronClicked() | CAdUiGroupCtrl | protected
OnCtlColor(CDC *, CWnd *, UINT) | CAdUiGroupCtrl | protected
OnEraseBkgnd(CDC *) (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inlineprotected
OnKillFocus(CWnd *pNewWnd) | CAdUiGroupCtrl | protected
OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS *) afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct) | CAdUiGroupCtrl | protected
OnNcHitTest(CPoint point) | CAdUiGroupCtrl | protected
OnNcLButtonDblClk(UINT nHitTest, CPoint) | CAdUiGroupCtrl | protected
OnNcLButtonDown(UINT nHitTest, CPoint) | CAdUiGroupCtrl | protected
OnNcPaint() | CAdUiGroupCtrl | protected
OnPaint() | CAdUiGroupCtrl | protected
OnSetFocus(CWnd *pOldWnd) | CAdUiGroupCtrl | protected
OnSize(UINT nType, int cx, int cy) | CAdUiGroupCtrl | protected
PreTranslateMessage(MSG *pMsg) | CAdUiGroupCtrl | protectedvirtual
RemoveBmpBtnFromHeader(DWORD dwCookie) | CAdUiGroupCtrl | virtual
SetActive(bool bActive) | CAdUiGroupCtrl |
SetFont(CFont *pFont) | CAdUiGroupCtrl | virtual
SetFont(CFont *pFont, BOOL bRedraw) | CAdUiGroupCtrl | virtual
SetHeaderHeight(int nHeight) (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inline
SetHideGroupHeader(bool bHide) (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inline
SetMinimized(bool bMinimized) | CAdUiGroupCtrl | inlinevirtual
SetSelIndex(int nSelIndex) | CAdUiGroupCtrl |
SetStyle(DWORD nStyle) (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inline
SetTheme(CAdUiTheme *pTheme) | CAdUiGroupCtrl | virtual
SetTitle(LPCTSTR pszTitle) (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | inline
ShowWnd(CWnd *pWnd) | CAdUiGroupCtrl | virtual
~CAdUiGroupCtrl() (defined in CAdUiGroupCtrl) | CAdUiGroupCtrl | virtual


ZRX API Reference: CAdUiHeaderCtrl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiHeaderCtrl Class Reference
MFC Classes

Public Member Functions

CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (int item, LPCTSTR text, int &width, int &height)
int | GetItemAtPoint (CPoint &p)
BOOL | GetItemRect (int idx, CRect &rItem)
BOOL | GetText (int idx, CString &text)
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsOwnerDraw (int idx)
void | SetAdUiParent (CWnd *w)

Protected Member Functions

virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)

Protected Attributes

CWnd * | m_aduiParent
CPoint | m_lastMousePoint
int | m_tipItem
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • aduiHeaderCtrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiHeaderCtrl Member List

This is the complete list of members for CAdUiHeaderCtrl, including all inherited members.

CAdUiHeaderCtrl() (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protectedvirtual
GetAdUiParent() (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl |
GetContentExtent(int item, LPCTSTR text, int &width, int &height) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | virtual
GetItemAtPoint(CPoint &p) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl |
GetItemRect(int idx, CRect &rItem) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl |
GetText(int idx, CString &text) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl |
IsOwnerDraw(int idx) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl |
m_aduiParent (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protected
m_lastMousePoint (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protected
m_tipItem (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protected
m_tipRect (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protected
OnDrawTip(CDC &dc) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | protected
SetAdUiParent(CWnd *w) (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl |
~CAdUiHeaderCtrl() (defined in CAdUiHeaderCtrl) | CAdUiHeaderCtrl | virtual


ZRX API Reference: CAdUiHPFSVolumeDescriptor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiHPFSVolumeDescriptor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiHPFSVolumeDescriptor:

Public Member Functions

CAdUiHPFSVolumeDescriptor (const CString &)
BOOL | ValidateFilename (const CString *, const BOOL wildcard_ok=false) const
BOOL | ValidateSegment (const CString *, const BOOL wildcard_ok=false) const
- Public Member Functions inherited from CAdUiVolumeDescriptor
virtual BOOL | AllowsCaseSensitiveLookup (void) const
CAdUiVolumeDescriptor (const CString &)
virtual BOOL | CheckReadOnly () const
virtual const CString * | GetLocalName () const
virtual LONG | GetVolFreeSpace () const
virtual BOOL | IsCaseSensitive (void) const
BOOL | IsRemote () const
BOOL | IsRemovable () const
virtual BOOL | PreservesCase (void) const
virtual void | VolCase (CString &) const
virtual BOOL | VolMatch (const ACHAR *a, const CString *b) const
virtual BOOL | VolMatch (const CString *a, const CString *b) const
virtual BOOL | VolumeValid () const
virtual BOOL | WillFit (DWORD) const

Additional Inherited Members

- Protected Types inherited from CAdUiVolumeDescriptor
typedef unsigned | flagbits
- Protected Member Functions inherited from CAdUiVolumeDescriptor
int | Find (const CString &str, UINT ch) const
void | GetConnectionName (void)
int | IsControl (int c) const
- Protected Attributes inherited from CAdUiVolumeDescriptor
BOOL | m_amodeMultiByte
CString * | m_connection_name
flagbits | m_d_caseSensitive: 1
flagbits | m_d_cdrom: 1
flagbits | m_d_fixed: 1
flagbits | m_d_ramdisk: 1
flagbits | m_d_readonly: 1
flagbits | m_d_remote: 1
flagbits | m_d_removable: 1
const ACHAR * | m_doubleslash
DWORD | m_fsflags
int | m_max_component_size
int | m_max_path_length
FS_TYPE | m_vol_fs_type
CString * | m_vol_label
CString * | m_vol_localname
DWORD | m_vol_serial
ACHAR | m_vol_slash
The documentation for this class was generated from the following file:
  • aduiVolumeDescriptor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiHPFSVolumeDescriptor Member List

This is the complete list of members for CAdUiHPFSVolumeDescriptor, including all inherited members.

AllowsCaseSensitiveLookup(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
CAdUiHPFSVolumeDescriptor(const CString &) (defined in CAdUiHPFSVolumeDescriptor) | CAdUiHPFSVolumeDescriptor |
CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CAdUiVolumeDescriptor(const CString &) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CheckReadOnly() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
Find(const CString &str, UINT ch) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
flagbits typedef (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetConnectionName(void) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetLocalName() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
GetVolFreeSpace() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsCaseSensitive(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsControl(int c) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
IsRemote() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
IsRemovable() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
m_amodeMultiByte (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_connection_name (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_caseSensitive (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_cdrom (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_fixed (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_ramdisk (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_readonly (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_remote (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_removable (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_doubleslash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_fsflags (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_component_size (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_path_length (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_fs_type (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_label (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_localname (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_serial (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_slash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
PreservesCase(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
ValidateFilename(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiHPFSVolumeDescriptor) | CAdUiHPFSVolumeDescriptor | virtual
ValidateSegment(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiHPFSVolumeDescriptor) | CAdUiHPFSVolumeDescriptor | virtual
VolCase(CString &) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolMatch(const ACHAR *a, const CString *b) const | CAdUiVolumeDescriptor | virtual
VolMatch(const CString *a, const CString *b) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolumeValid() const | CAdUiVolumeDescriptor | virtual
WillFit(DWORD) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
~CAdUiHPFSVolumeDescriptor() (defined in CAdUiHPFSVolumeDescriptor) | CAdUiHPFSVolumeDescriptor | inline
~CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual


ZRX API Reference: CAdUiListBox Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiListBox Class Reference
MFC Classes
+ Inheritance diagram for CAdUiListBox:

Public Member Functions

virtual int | CompareItem (LPCOMPAREITEMSTRUCT lpCompareItemStruct)
virtual void | DeleteItem (LPDELETEITEMSTRUCT lpDeleteItemStruct)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
CWnd * | GetAdUiParent ()
CAdUiComboBox * | GetComboBox ()
BOOL | GetComboBoxDraw ()
virtual void | GetContentExtent (int item, LPCTSTR text, int &width, int &height)
int | GetItemAtPoint (CPoint &p)
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsOwnerDraw ()
virtual void | MeasureItem (LPMEASUREITEMSTRUCT lpMeasureItemStruct)
void | SetAdUiParent (CWnd *w)
void | SetComboBox (CAdUiComboBox *control)
void | SetComboBoxDraw (BOOL comboBoxDraw)

Protected Member Functions

virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnDestroy ()
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)

Protected Attributes

CWnd * | m_aduiParent
BOOL | m_bComboBoxDraw
CPoint | m_lastMousePoint
CAdUiComboBox * | m_pComboBox
int | m_tipItem
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • aduiListBox.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiListBox Member List

This is the complete list of members for CAdUiListBox, including all inherited members.

CAdUiListBox() (defined in CAdUiListBox) | CAdUiListBox |
CompareItem(LPCOMPAREITEMSTRUCT lpCompareItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
DeleteItem(LPDELETEITEMSTRUCT lpDeleteItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
GetAdUiParent() (defined in CAdUiListBox) | CAdUiListBox |
GetComboBox() (defined in CAdUiListBox) | CAdUiListBox |
GetComboBoxDraw() (defined in CAdUiListBox) | CAdUiListBox |
GetContentExtent(int item, LPCTSTR text, int &width, int &height) (defined in CAdUiListBox) | CAdUiListBox | virtual
GetItemAtPoint(CPoint &p) (defined in CAdUiListBox) | CAdUiListBox |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiListBox) | CAdUiListBox |
IsOwnerDraw() (defined in CAdUiListBox) | CAdUiListBox |
m_aduiParent (defined in CAdUiListBox) | CAdUiListBox | protected
m_bComboBoxDraw (defined in CAdUiListBox) | CAdUiListBox | protected
m_lastMousePoint (defined in CAdUiListBox) | CAdUiListBox | protected
m_pComboBox (defined in CAdUiListBox) | CAdUiListBox | protected
m_tipItem (defined in CAdUiListBox) | CAdUiListBox | protected
m_tipRect (defined in CAdUiListBox) | CAdUiListBox | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) (defined in CAdUiListBox) | CAdUiListBox | virtual
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiListBox) | CAdUiListBox | protected
OnDestroy() (defined in CAdUiListBox) | CAdUiListBox | protected
OnDrawTip(CDC &dc) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiListBox) | CAdUiListBox | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiListBox) | CAdUiListBox | protected
SetAdUiParent(CWnd *w) (defined in CAdUiListBox) | CAdUiListBox |
SetComboBox(CAdUiComboBox *control) (defined in CAdUiListBox) | CAdUiListBox |
SetComboBoxDraw(BOOL comboBoxDraw) (defined in CAdUiListBox) | CAdUiListBox |
~CAdUiListBox() (defined in CAdUiListBox) | CAdUiListBox | virtual


ZRX API Reference: CAdUiListCtrl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
CAdUiListCtrl Class Reference
MFC Classes
+ Inheritance diagram for CAdUiListCtrl:

Public Member Functions

int | ColumnCount ()
CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (int item, int index, LPCTSTR text, int &width, int &height)
BOOL | GetItemAtPoint (CPoint &p, int &item, int &index)
BOOL | GetSubItemRect (int item, int index, CRect &rect)
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsOwnerDraw ()
void | SetAdUiParent (CWnd *w)

Public Attributes

CAdUiHeaderCtrl m_headerCtrl

Protected Member Functions

virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
virtual void | PreSubclassWindow ()

Protected Attributes

CWnd * | m_aduiParent
CPoint | m_lastMousePoint
int | m_tipIndex
int | m_tipItem
CRect | m_tipRect
The documentation for this class was generated from the following file:
  • aduiListCtrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiListCtrl Member List

This is the complete list of members for CAdUiListCtrl, including all inherited members.

CAdUiListCtrl() (defined in CAdUiListCtrl) | CAdUiListCtrl |
ColumnCount() (defined in CAdUiListCtrl) | CAdUiListCtrl |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
GetAdUiParent() (defined in CAdUiListCtrl) | CAdUiListCtrl |
GetContentExtent(int item, int index, LPCTSTR text, int &width, int &height) (defined in CAdUiListCtrl) | CAdUiListCtrl | virtual
GetItemAtPoint(CPoint &p, int &item, int &index) (defined in CAdUiListCtrl) | CAdUiListCtrl |
GetSubItemRect(int item, int index, CRect &rect) (defined in CAdUiListCtrl) | CAdUiListCtrl |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiListCtrl) | CAdUiListCtrl |
IsOwnerDraw() (defined in CAdUiListCtrl) | CAdUiListCtrl |
m_aduiParent (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
m_headerCtrl (defined in CAdUiListCtrl) | CAdUiListCtrl |
m_lastMousePoint (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
m_tipIndex (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
m_tipItem (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
m_tipRect (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
OnDrawTip(CDC &dc) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
PreSubclassWindow() (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
SetAdUiParent(CWnd *w) (defined in CAdUiListCtrl) | CAdUiListCtrl |
~CAdUiListCtrl() (defined in CAdUiListCtrl) | CAdUiListCtrl | virtual


ZRX API Reference: CAdUiNOFSVolumeDescriptor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiNOFSVolumeDescriptor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiNOFSVolumeDescriptor:

Public Member Functions

CAdUiNOFSVolumeDescriptor (const CString &)
BOOL | ValidateFilename (const CString *, const BOOL wildcard_ok=false) const
BOOL | ValidateSegment (const CString *, const BOOL wildcard_ok=false) const
- Public Member Functions inherited from CAdUiVolumeDescriptor
virtual BOOL | AllowsCaseSensitiveLookup (void) const
CAdUiVolumeDescriptor (const CString &)
virtual BOOL | CheckReadOnly () const
virtual const CString * | GetLocalName () const
virtual LONG | GetVolFreeSpace () const
virtual BOOL | IsCaseSensitive (void) const
BOOL | IsRemote () const
BOOL | IsRemovable () const
virtual BOOL | PreservesCase (void) const
virtual void | VolCase (CString &) const
virtual BOOL | VolMatch (const ACHAR *a, const CString *b) const
virtual BOOL | VolMatch (const CString *a, const CString *b) const
virtual BOOL | VolumeValid () const
virtual BOOL | WillFit (DWORD) const

Additional Inherited Members

- Protected Types inherited from CAdUiVolumeDescriptor
typedef unsigned | flagbits
- Protected Member Functions inherited from CAdUiVolumeDescriptor
int | Find (const CString &str, UINT ch) const
void | GetConnectionName (void)
int | IsControl (int c) const
- Protected Attributes inherited from CAdUiVolumeDescriptor
BOOL | m_amodeMultiByte
CString * | m_connection_name
flagbits | m_d_caseSensitive: 1
flagbits | m_d_cdrom: 1
flagbits | m_d_fixed: 1
flagbits | m_d_ramdisk: 1
flagbits | m_d_readonly: 1
flagbits | m_d_remote: 1
flagbits | m_d_removable: 1
const ACHAR * | m_doubleslash
DWORD | m_fsflags
int | m_max_component_size
int | m_max_path_length
FS_TYPE | m_vol_fs_type
CString * | m_vol_label
CString * | m_vol_localname
DWORD | m_vol_serial
ACHAR | m_vol_slash
The documentation for this class was generated from the following file:
  • aduiVolumeDescriptor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiNOFSVolumeDescriptor Member List

This is the complete list of members for CAdUiNOFSVolumeDescriptor, including all inherited members.

AllowsCaseSensitiveLookup(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
CAdUiNOFSVolumeDescriptor(const CString &) (defined in CAdUiNOFSVolumeDescriptor) | CAdUiNOFSVolumeDescriptor |
CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CAdUiVolumeDescriptor(const CString &) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CheckReadOnly() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
Find(const CString &str, UINT ch) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
flagbits typedef (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetConnectionName(void) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetLocalName() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
GetVolFreeSpace() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsCaseSensitive(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsControl(int c) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
IsRemote() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
IsRemovable() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
m_amodeMultiByte (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_connection_name (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_caseSensitive (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_cdrom (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_fixed (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_ramdisk (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_readonly (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_remote (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_removable (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_doubleslash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_fsflags (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_component_size (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_path_length (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_fs_type (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_label (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_localname (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_serial (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_slash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
PreservesCase(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
ValidateFilename(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiNOFSVolumeDescriptor) | CAdUiNOFSVolumeDescriptor | virtual
ValidateSegment(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiNOFSVolumeDescriptor) | CAdUiNOFSVolumeDescriptor | virtual
VolCase(CString &) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolMatch(const ACHAR *a, const CString *b) const | CAdUiVolumeDescriptor | virtual
VolMatch(const CString *a, const CString *b) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolumeValid() const | CAdUiVolumeDescriptor | virtual
WillFit(DWORD) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
~CAdUiNOFSVolumeDescriptor() (defined in CAdUiNOFSVolumeDescriptor) | CAdUiNOFSVolumeDescriptor | inline
~CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual


ZRX API Reference: CAdUiNTFSVolumeDescriptor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiNTFSVolumeDescriptor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiNTFSVolumeDescriptor:

Public Member Functions

CAdUiNTFSVolumeDescriptor (const CString &)
BOOL | ValidateFilename (const CString *, const BOOL wildcard_ok=false) const
BOOL | ValidateSegment (const CString *, const BOOL wildcard_ok=false) const
- Public Member Functions inherited from CAdUiVolumeDescriptor
virtual BOOL | AllowsCaseSensitiveLookup (void) const
CAdUiVolumeDescriptor (const CString &)
virtual BOOL | CheckReadOnly () const
virtual const CString * | GetLocalName () const
virtual LONG | GetVolFreeSpace () const
virtual BOOL | IsCaseSensitive (void) const
BOOL | IsRemote () const
BOOL | IsRemovable () const
virtual BOOL | PreservesCase (void) const
virtual void | VolCase (CString &) const
virtual BOOL | VolMatch (const ACHAR *a, const CString *b) const
virtual BOOL | VolMatch (const CString *a, const CString *b) const
virtual BOOL | VolumeValid () const
virtual BOOL | WillFit (DWORD) const

Additional Inherited Members

- Protected Types inherited from CAdUiVolumeDescriptor
typedef unsigned | flagbits
- Protected Member Functions inherited from CAdUiVolumeDescriptor
int | Find (const CString &str, UINT ch) const
void | GetConnectionName (void)
int | IsControl (int c) const
- Protected Attributes inherited from CAdUiVolumeDescriptor
BOOL | m_amodeMultiByte
CString * | m_connection_name
flagbits | m_d_caseSensitive: 1
flagbits | m_d_cdrom: 1
flagbits | m_d_fixed: 1
flagbits | m_d_ramdisk: 1
flagbits | m_d_readonly: 1
flagbits | m_d_remote: 1
flagbits | m_d_removable: 1
const ACHAR * | m_doubleslash
DWORD | m_fsflags
int | m_max_component_size
int | m_max_path_length
FS_TYPE | m_vol_fs_type
CString * | m_vol_label
CString * | m_vol_localname
DWORD | m_vol_serial
ACHAR | m_vol_slash
The documentation for this class was generated from the following file:
  • aduiVolumeDescriptor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiNTFSVolumeDescriptor Member List

This is the complete list of members for CAdUiNTFSVolumeDescriptor, including all inherited members.

AllowsCaseSensitiveLookup(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
CAdUiNTFSVolumeDescriptor(const CString &) (defined in CAdUiNTFSVolumeDescriptor) | CAdUiNTFSVolumeDescriptor |
CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CAdUiVolumeDescriptor(const CString &) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CheckReadOnly() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
Find(const CString &str, UINT ch) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
flagbits typedef (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetConnectionName(void) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetLocalName() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
GetVolFreeSpace() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsCaseSensitive(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsControl(int c) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
IsRemote() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
IsRemovable() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
m_amodeMultiByte (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_connection_name (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_caseSensitive (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_cdrom (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_fixed (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_ramdisk (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_readonly (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_remote (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_removable (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_doubleslash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_fsflags (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_component_size (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_path_length (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_fs_type (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_label (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_localname (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_serial (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_slash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
PreservesCase(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
ValidateFilename(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiNTFSVolumeDescriptor) | CAdUiNTFSVolumeDescriptor | virtual
ValidateSegment(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiNTFSVolumeDescriptor) | CAdUiNTFSVolumeDescriptor | virtual
VolCase(CString &) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolMatch(const ACHAR *a, const CString *b) const | CAdUiVolumeDescriptor | virtual
VolMatch(const CString *a, const CString *b) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolumeValid() const | CAdUiVolumeDescriptor | virtual
WillFit(DWORD) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
~CAdUiNTFSVolumeDescriptor() (defined in CAdUiNTFSVolumeDescriptor) | CAdUiNTFSVolumeDescriptor | inline
~CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual


ZRX API Reference: CAdUiODButtonThemeModReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiODButtonThemeModReactor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiODButtonThemeModReactor:

Public Member Functions

CAdUiODButtonThemeModReactor (CAdUiOwnerDrawButton *pBtn)
virtual void ThemeModified (const CAdUiTheme *pTheme, AdUiThemeElement element)

Constructor & Destructor Documentation

CAdUiODButtonThemeModReactor::CAdUiODButtonThemeModReactor ( CAdUiOwnerDrawButton * pBtn )
Warning
Not implemented!

Member Function Documentation

virtual void CAdUiODButtonThemeModReactor::ThemeModified | ( | const CAdUiTheme * | pTheme,
 |  | AdUiThemeElement | element
 | ) |  |
virtual
Warning
Not implemented!

Implements CAdUiThemeModifiedReactor.

The documentation for this class was generated from the following file:
  • aduiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiODButtonThemeModReactor Member List

This is the complete list of members for CAdUiODButtonThemeModReactor, including all inherited members.

CAdUiODButtonThemeModReactor(CAdUiOwnerDrawButton *pBtn) | CAdUiODButtonThemeModReactor |
ThemeModified(const CAdUiTheme *pTheme, AdUiThemeElement element) | CAdUiODButtonThemeModReactor | virtual


ZRX API Reference: CAdUiOwnerDrawButton Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | Friends | List of all members
CAdUiOwnerDrawButton Class Reference
MFC Classes
+ Inheritance diagram for CAdUiOwnerDrawButton:

Public Member Functions

BOOL | AutoLoad ()
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
CWnd * | GetAdUiParent ()
BOOL | GetEnableDragDrop ()
BOOL | GetEnableFastDraw ()
BOOL | GetEnablePointedAt ()
BOOL | GetIsStatic ()
BOOL | GetIsToolButton ()
virtual void | PreSubclassWindow ()
BOOL | Reload (LPCTSTR strResId)
void | SetAdUiParent (CWnd *w)
void | SetEnableDragDrop (BOOL allow)
void | SetEnableFastDraw (BOOL allow)
void | SetEnablePointedAt (BOOL allow)
void | SetIsStatic (BOOL isStatic)
void | SetIsToolButton (BOOL isToolButton)
virtual CAdUiTheme * | SetTheme (CAdUiTheme *pTheme)
virtual void | SetTracking (BOOL b)

Protected Member Functions

virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual void | DrawBorder (CDC *pDC, CRect &r, COLORREF cr)
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
virtual void | DrawHotBorder ()
virtual void | DrawPushButtonBorder (CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected)
virtual void | DrawToolButtonBorder (CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused)
void | DrawTransparentBitmap (CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled)
BOOL | GetIsPointedAt ()
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnAutoLoad ()
afx_msg void | OnDestroy ()
virtual void | OnDragDrop (HDROP hDropInfo)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
afx_msg void | OnDropFiles (HDROP hDropInfo)
afx_msg UINT | OnGetDlgCode ()
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnKillFocus (CWnd *pNewWnd)
afx_msg LRESULT | OnMouseLeave (WPARAM, LPARAM)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
afx_msg void | OnNcDestroy ()
virtual void | OnPointedAt (BOOL isPointedAt)
virtual BOOL | OnReload (LPCTSTR strResId)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg LRESULT | OnThemeChanged (WPARAM wParam, LPARAM lParam)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
void | SetIsPointedAt (BOOL isPointedAt)
void | StartTimer (DWORD ms=50)
void | StopTimer ()
virtual void | ThemeModified (AdUiThemeElement element)

Protected Attributes

CWnd * | m_aduiParent
BOOL | m_bEnableDragDrop: 1
BOOL | m_bEnableFastDraw: 1
BOOL | m_bEnablePointedAt: 1
BOOL | m_bIsPointedAt: 1
BOOL | m_bIsStatic: 1
BOOL | m_bIsToolButton: 1
BOOL | m_bIsTrackButton: 1
BOOL | m_bMouseHover
CPoint | m_lastMousePoint
int | m_nPartId
int | m_nStateId
CAdUiTheme * | m_pTheme
UINT_PTR | m_timerId
CRect | m_tipRect
UINT | m_uEdge

Static Protected Attributes

static const UINT_PTR m_timerEvent

Friends

class CAdUiODButtonThemeModReactor
The documentation for this class was generated from the following file:
  • aduiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiOwnerDrawButton Member List

This is the complete list of members for CAdUiOwnerDrawButton, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAdUiODButtonThemeModReactor (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | friend
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual


ZRX API Reference: CAdUiPalette Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
CAdUiPalette Class Reference
MFC Classes
+ Inheritance diagram for CAdUiPalette:

Public Member Functions

virtual bool | CanFrameworkTakeFocus ()
BOOL | Create (DWORD dwStyle, LPCTSTR pszName, CAdUiPaletteSet *pParent, DWORD dwPaletteStyle=0)
virtual BOOL | Create (CAdUiPaletteSet *pParent)
virtual void | EditName (CPoint &ptLoc)
virtual void | EditName ()
BOOL | EditNameStyle ()
virtual CString | GetClassName ()
virtual BOOL | GetMaximumSize (CSize &size)
virtual BOOL | GetMinimumSize (CSize &size)
CString | GetName ()
CAdUiPaletteSet * | GetPaletteSet ()
DWORD | GetPaletteStyle ()
virtual BOOL | Load (IUnknown *pUnk)
virtual BOOL | NameEditValidation (CEdit *pEdit)
virtual BOOL | OnKillActive ()
virtual void | OnSetActive ()
virtual BOOL | Save (IUnknown *pUnk)
void | SetName (CString strName)
void | SetPaletteSet (CAdUiPaletteSet *pSet)
void | SetPaletteStyle (DWORD dwStyle)

Static Public Member Functions

static bool PaletteNameEditInProgress ()

Protected Member Functions

afx_msg LRESULT | OnBeginNameEdit (WPARAM, LPARAM)
afx_msg LRESULT | OnEndNameEdit (WPARAM, LPARAM)
afx_msg BOOL | OnEraseBkgnd (CDC *pdc)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint pt)
afx_msg BOOL | OnSetCursor (CWnd *pwnd, UINT nHitTest, UINT msg)
The documentation for this class was generated from the following file:
  • aduipalette.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiPalette Member List

This is the complete list of members for CAdUiPalette, including all inherited members.

CAdUiPalette() (defined in CAdUiPalette) | CAdUiPalette |
CanFrameworkTakeFocus() (defined in CAdUiPalette) | CAdUiPalette | virtual
Create(DWORD dwStyle, LPCTSTR pszName, CAdUiPaletteSet *pParent, DWORD dwPaletteStyle=0) (defined in CAdUiPalette) | CAdUiPalette |
Create(CAdUiPaletteSet *pParent) (defined in CAdUiPalette) | CAdUiPalette | virtual
EditName(CPoint &ptLoc) (defined in CAdUiPalette) | CAdUiPalette | virtual
EditName() (defined in CAdUiPalette) | CAdUiPalette | virtual
EditNameStyle() (defined in CAdUiPalette) | CAdUiPalette | inline
GetClassName() (defined in CAdUiPalette) | CAdUiPalette | virtual
GetMaximumSize(CSize &size) (defined in CAdUiPalette) | CAdUiPalette | virtual
GetMinimumSize(CSize &size) (defined in CAdUiPalette) | CAdUiPalette | virtual
GetName() (defined in CAdUiPalette) | CAdUiPalette |
GetPaletteSet() (defined in CAdUiPalette) | CAdUiPalette | inline
GetPaletteStyle() (defined in CAdUiPalette) | CAdUiPalette |
Load(IUnknown *pUnk) (defined in CAdUiPalette) | CAdUiPalette | virtual
NameEditValidation(CEdit *pEdit) (defined in CAdUiPalette) | CAdUiPalette | virtual
OnBeginNameEdit(WPARAM, LPARAM) (defined in CAdUiPalette) | CAdUiPalette | protected
OnEndNameEdit(WPARAM, LPARAM) (defined in CAdUiPalette) | CAdUiPalette | protected
OnEraseBkgnd(CDC *pdc) (defined in CAdUiPalette) | CAdUiPalette | protected
OnKillActive() (defined in CAdUiPalette) | CAdUiPalette | virtual
OnLButtonDown(UINT nFlags, CPoint pt) (defined in CAdUiPalette) | CAdUiPalette | protected
OnSetActive() (defined in CAdUiPalette) | CAdUiPalette | virtual
OnSetCursor(CWnd *pwnd, UINT nHitTest, UINT msg) (defined in CAdUiPalette) | CAdUiPalette | protected
PaletteNameEditInProgress() (defined in CAdUiPalette) | CAdUiPalette | inlinestatic
Save(IUnknown *pUnk) (defined in CAdUiPalette) | CAdUiPalette | virtual
SetName(CString strName) (defined in CAdUiPalette) | CAdUiPalette |
SetPaletteSet(CAdUiPaletteSet *pSet) (defined in CAdUiPalette) | CAdUiPalette |
SetPaletteStyle(DWORD dwStyle) (defined in CAdUiPalette) | CAdUiPalette |
~CAdUiPalette() (defined in CAdUiPalette) | CAdUiPalette | virtual


ZRX API Reference: CAdUiPaletteSet Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAdUiPaletteSet Class Reference
MFC Classes
+ Inheritance diagram for CAdUiPaletteSet:

Public Types

enum AdUiTitleBarLocation { kLeft = 0, kRight }

Public Member Functions

int | AddPalette (CAdUiPalette *pPalette)
BOOL | AutoRollupStyle ()
CAdUiPaletteSet (int nStyle=0)
BOOL | CloseButtonStyle ()
BOOL | Create (LPCTSTR strTitle, DWORD dwStyle, const RECT &rect, CWnd *pwndParent, DWORD dwPaletteSetStyle=PSS_PROPERTIES_MENU|PSS_AUTO_ROLLUP|PSS_CLOSE_BUTTON|PSS_SNAP)
BOOL | EditNameStyle ()
void | EnableDocking (DWORD dwDockStyle)
CAdUiPalette * | GetActivePalette ()
int | GetActivePaletteTabIndex ()
BOOL | GetAutoRollup ()
void | GetFullRect (CRect &rect)
CString | GetName ()
BOOL | GetNonClientSize (CSize &size)
int | GetOpacity () const
CAdUiPalette * | GetPalette (int nIndex)
int | GetPaletteCount ()
DWORD | GetPaletteSetStyle ()
int | GetTabIndex (CAdUiPalette *pPalette)
CAdUiTheme * | GetTheme ()
CFont * | GetWindowFont ()
int | InsertPalette (int iIndex, CAdUiPalette *pPalette)
virtual BOOL | Load (IUnknown *pUnk)
virtual BOOL | NameEditValidation (CEdit *pEdit)
void | OnTogglePin ()
virtual BOOL | PreTranslateMessage (MSG *msg)
BOOL | PropertiesMenuStyle ()
BOOL | RemovePalette (CAdUiPalette *pPalette)
BOOL | RemovePalette (int nPaletteIndex)
BOOL | RolledUp ()
void | RollOut (bool bDelay=false)
void | RollUp ()
virtual BOOL | Save (IUnknown *pUnk)
BOOL | SetActivePalette (CAdUiPalette *pPalette)
BOOL | SetActivePalette (int nPaletteIndex)
bool | SetAllowTransparency (CString key, bool bDefault)
BOOL | SetAutoRollup (BOOL bSet=TRUE)
BOOL | SetName (LPCTSTR pszName)
BOOL | SetOpacity (int nOpacity)
void | SetPaletteSetStyle (DWORD dwStyle)
CAdUiTheme * | SetTheme (CAdUiTheme *pTheme)
void | SetTitleBarLocation (AdUiTitleBarLocation loc)
BOOL | SinglePaletteTabStyle ()
BOOL | SnapStyle ()
AdUiTitleBarLocation | TitleBarLocation ()
virtual void | TitleBarLocationUpdated (AdUiTitleBarLocation newLoc)
void | UpdateTabs ()
BOOL | UseSinglePaletteTabNameStyle ()
- Public Member Functions inherited from CAdUiDockControlBar
bool | AdjustVertDockedBarHeight (int nHeight)
bool | AllowDockingMenuItemState ()
bool | Anchored ()
CAdUiDockControlBar (int nStyle=ADUI_DOCK_CS_STDMOUSECLICKS)
virtual CSize | CalcFixedLayout (BOOL bStretch, BOOL bHorz)
BOOL | Create (CWnd *pParent, LPCTSTR lpszTitle, UINT nID, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, const RECT &rect=CFrameWnd::rectDefault)
BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
void | DockControlBar (UINT nOrientation, RECT *pRect)
DWORD | GetDockStyle ()
void | GetFloatingRect (CRect *pFloatingPos)
void | GetPersistedDockingRect (CRect *pDockRect)
void | GetPersistedFloatingRect (CRect *pFloatRect)
CLSID * | GetToolID ()
void | InitFloatingPosition (CRect *pSizeFloating)
BOOL | IsFloating ()
void | RestoreControlBar (UINT nPreferredOrientation=AFX_IDW_DOCKBAR_LEFT, CRect *pSizeFloating=NULL)
void | SetAllowDockingMenuItemState (bool bState)
void | SetToolID (CLSID *pCLSID)
void | TileInRow ()

Static Public Member Functions

static UINT | GetGlobalTransparency ()
static bool | SetGlobalTransparency (UINT flag)
- Static Public Member Functions inherited from CAdUiDockControlBar
static bool | GetToolsRestartMode ()
static void | SetToolsRestartMode (bool bMode)

Protected Member Functions

virtual BOOL | AddContextMenuItems (CMenu *pMenu, int nHitFlag, int nRightClkTab=0)
virtual void | AutoRollupChanged (BOOL bAutoRollupIsOn)
virtual bool | CanFrameworkTakeFocus ()
virtual void | EditName ()
afx_msg void | EditPaletteName ()
void | GetAdjustedClientRect (CRect &rect)
virtual int | GetBottomReservedHeight ()
virtual void | GetMaximumSize (CSize &size)
virtual void | GetMinimumSize (CSize &size)
virtual int | GetTopReservedHeight ()
BOOL | HitTest (CPoint pt, UINT &nFlag, DWORD &dwData)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnBeginNameEdit (WPARAM, LPARAM)
virtual void | OnContextMenu (CWnd *pWnd, CPoint pos)
afx_msg int | OnCreate (LPCREATESTRUCT lpCs)
afx_msg LRESULT | OnEndNameEdit (WPARAM, LPARAM)
afx_msg BOOL | OnEraseBkgnd (CDC *pdc)
afx_msg LRESULT | OnFloatStatus (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetPaletteCount (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetPaletteName (WPARAM wParam, LPARAM lParam)
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint pt)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint pt)
afx_msg void | OnLButtonUp (UINT nFlags, CPoint pt)
afx_msg void | OnMenuClose ()
afx_msg void | OnMenuMove ()
afx_msg void | OnMenuSize ()
afx_msg void | OnMouseMove (UINT nFlags, CPoint pt)
afx_msg LRESULT | OnNcCalcSize (WPARAM wParam, LPARAM lParam)
afx_msg UINT | OnNcHitTest (CPoint point)
afx_msg void | OnNcPaint ()
afx_msg void | OnOptionTranslucency ()
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg LRESULT | OnSetPaletteActive (WPARAM wParam, LPARAM lParam)
afx_msg void | OnSize (UINT nType, int cx, int cy)
virtual void | OnTabDrag (CPtrArray &arrayPalettes)
afx_msg void | OnWindowPosChanging (WINDOWPOS *lpwndpos)
virtual void | PaletteActivated (CAdUiPalette *pActivated, CAdUiPalette *pDeactivated)
virtual void | PaletteAdded (CAdUiPalette *pPalette)
virtual void | PaletteRemoved (CAdUiPalette *pPalette)
virtual void | ThemeModified (AdUiThemeElement element)
- Protected Member Functions inherited from CAdUiDockControlBar
virtual BOOL | AddCustomMenuItems (LPARAM hMenu)
bool | CloseButtonVisible ()
virtual BOOL | CreateControlBar (LPCREATESTRUCT lpCreateStruct)
virtual void | GetFloatingMinSize (long *pnMinWidth, long *pnMinHeight)
void | GetUsedRect (CRect &rect)
afx_msg void | OnAllowDock ()
afx_msg void | OnAnchor ()
afx_msg void | OnAnchorLeft ()
afx_msg void | OnAnchorRight ()
virtual bool | OnClosing ()
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
afx_msg void | OnHideBar ()
afx_msg void | OnPaint ()
virtual void | OnUserSizing (UINT nSide, LPRECT pRect)
afx_msg void | OnWindowPosChanged (WINDOWPOS FAR *lpwndpos)
virtual void | PaintControlBar (CDC *pDC)
void | ShowCloseButton (bool bShow)
virtual void | SizeChanged (CRect *lpRect, BOOL bFloating, int flags)

Protected Attributes

CAdUiImpPaletteSet * m_pImpPS

Friends

class | CAdUiAnchorBar
class | CAdUiDockDragContext
class | CAdUiImpPaletteSet
class | CAdUiPalette
class | CAdUiPaletteSetDockFrame

Additional Inherited Members

- Protected Types inherited from CAdUiDockControlBar
enum { btnWidth = 12, btnHeight = 12, idCloseBtn = 10001, idPinBtn = 10002 }

Member Function Documentation

BOOL CAdUiPaletteSet::GetNonClientSize ( CSize & size )
Warning
Not implemented!
afx_msg LRESULT CAdUiPaletteSet::OnGetPaletteCount | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |
protected
Warning
Not implemented!
afx_msg LRESULT CAdUiPaletteSet::OnGetPaletteName | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |
protected
Warning
Not implemented!
afx_msg UINT CAdUiPaletteSet::OnNcHitTest ( CPoint point )
protected
Warning
Not implemented!
afx_msg LRESULT CAdUiPaletteSet::OnSetPaletteActive | ( | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |
protected
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aduipaletteset.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiPaletteSet Member List

This is the complete list of members for CAdUiPaletteSet, including all inherited members.

AddContextMenuItems(CMenu *pMenu, int nHitFlag, int nRightClkTab=0) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
AddCustomMenuItems(LPARAM hMenu) | CAdUiDockControlBar | protectedvirtual
AddPalette(CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
AdjustVertDockedBarHeight(int nHeight) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
AdUiTitleBarLocation enum name (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
AllowDockingMenuItemState() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
Anchored() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
AutoRollupChanged(BOOL bAutoRollupIsOn) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | inlineprotectedvirtual
AutoRollupStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
btnHeight enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
btnWidth enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
CAdUiAnchorBar (defined in CAdUiPaletteSet) | CAdUiPaletteSet | friend
CAdUiDockControlBar(int nStyle=ADUI_DOCK_CS_STDMOUSECLICKS) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
CAdUiDockDragContext (defined in CAdUiPaletteSet) | CAdUiPaletteSet | friend
CAdUiImpPaletteSet (defined in CAdUiPaletteSet) | CAdUiPaletteSet | friend
CAdUiPalette (defined in CAdUiPaletteSet) | CAdUiPaletteSet | friend
CAdUiPaletteSet(int nStyle=0) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
CAdUiPaletteSetDockFrame (defined in CAdUiPaletteSet) | CAdUiPaletteSet | friend
CalcFixedLayout(BOOL bStretch, BOOL bHorz) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
CanFrameworkTakeFocus() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
CloseButtonStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
CloseButtonVisible() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotected
Create(LPCTSTR strTitle, DWORD dwStyle, const RECT &rect, CWnd *pwndParent, DWORD dwPaletteSetStyle=PSS_PROPERTIES_MENU|PSS_AUTO_ROLLUP|PSS_CLOSE_BUTTON|PSS_SNAP) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
Create(CWnd *pParent, LPCTSTR lpszTitle, UINT nID, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, const RECT &rect=CFrameWnd::rectDefault) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
CreateControlBar(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
DockControlBar(UINT nOrientation, RECT *pRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
EditName() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
EditNameStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
EditPaletteName() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
EnableDocking(DWORD dwDockStyle) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetActivePalette() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetActivePaletteTabIndex() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetAdjustedClientRect(CRect &rect) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
GetAutoRollup() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetBottomReservedHeight() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
GetDockStyle() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
GetFloatingMinSize(long *pnMinWidth, long *pnMinHeight) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
GetFloatingRect(CRect *pFloatingPos) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetFullRect(CRect &rect) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetGlobalTransparency() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | static
GetMaximumSize(CSize &size) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
GetMinimumSize(CSize &size) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
GetName() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetNonClientSize(CSize &size) | CAdUiPaletteSet |
GetOpacity() const (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetPalette(int nIndex) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetPaletteCount() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetPaletteSetStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetPersistedDockingRect(CRect *pDockRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetPersistedFloatingRect(CRect *pFloatRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetTabIndex(CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetTheme() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetToolID() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
GetToolsRestartMode() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | static
GetTopReservedHeight() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
GetUsedRect(CRect &rect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
GetWindowFont() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
HitTest(CPoint pt, UINT &nFlag, DWORD &dwData) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
idCloseBtn enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
idPinBtn enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
InitFloatingPosition(CRect *pSizeFloating) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
InsertPalette(int iIndex, CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
IsFloating() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
kLeft enum value (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
kRight enum value (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
Load(IUnknown *pUnk) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | virtual
m_pImpPS (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
NameEditValidation(CEdit *pEdit) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | virtual
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnAllowDock() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnAnchor() | CAdUiDockControlBar | protected
OnAnchorLeft() | CAdUiDockControlBar | protected
OnAnchorRight() | CAdUiDockControlBar | protected
OnBeginNameEdit(WPARAM, LPARAM) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnClosing() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
OnCommand(WPARAM wParam, LPARAM lParam) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
OnContextMenu(CWnd *pWnd, CPoint pos) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
OnCreate(LPCREATESTRUCT lpCs) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnEndNameEdit(WPARAM, LPARAM) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnEraseBkgnd(CDC *pdc) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnFloatStatus(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnGetPaletteCount(WPARAM wParam, LPARAM lParam) | CAdUiPaletteSet | protected
OnGetPaletteName(WPARAM wParam, LPARAM lParam) | CAdUiPaletteSet | protected
OnHideBar() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnLButtonDblClk(UINT nFlags, CPoint pt) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnLButtonDown(UINT nFlags, CPoint pt) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnLButtonUp(UINT nFlags, CPoint pt) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnMenuClose() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnMenuMove() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnMenuSize() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnMouseMove(UINT nFlags, CPoint pt) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnNcCalcSize(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnNcHitTest(CPoint point) | CAdUiPaletteSet | protected
OnNcPaint() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnOptionTranslucency() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnPaint() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnSetPaletteActive(WPARAM wParam, LPARAM lParam) | CAdUiPaletteSet | protected
OnSize(UINT nType, int cx, int cy) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnTabDrag(CPtrArray &arrayPalettes) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
OnTogglePin() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
OnUserSizing(UINT nSide, LPRECT pRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotectedvirtual
OnWindowPosChanged(WINDOWPOS FAR *lpwndpos) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnWindowPosChanging(WINDOWPOS *lpwndpos) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
PaintControlBar(CDC *pDC) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
PaletteActivated(CAdUiPalette *pActivated, CAdUiPalette *pDeactivated) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | inlineprotectedvirtual
PaletteAdded(CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | inlineprotectedvirtual
PaletteRemoved(CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | inlineprotectedvirtual
PreTranslateMessage(MSG *msg) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | virtual
PropertiesMenuStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
RemovePalette(CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
RemovePalette(int nPaletteIndex) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
RestoreControlBar(UINT nPreferredOrientation=AFX_IDW_DOCKBAR_LEFT, CRect *pSizeFloating=NULL) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
RolledUp() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
RollOut(bool bDelay=false) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
RollUp() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
Save(IUnknown *pUnk) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | virtual
SetActivePalette(CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetActivePalette(int nPaletteIndex) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetAllowDockingMenuItemState(bool bState) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
SetAllowTransparency(CString key, bool bDefault) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetAutoRollup(BOOL bSet=TRUE) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetGlobalTransparency(UINT flag) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | static
SetName(LPCTSTR pszName) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetOpacity(int nOpacity) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetPaletteSetStyle(DWORD dwStyle) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetTitleBarLocation(AdUiTitleBarLocation loc) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetToolID(CLSID *pCLSID) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
SetToolsRestartMode(bool bMode) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | static
ShowCloseButton(bool bShow) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotected
SinglePaletteTabStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SizeChanged(CRect *lpRect, BOOL bFloating, int flags) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotectedvirtual
SnapStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
ThemeModified(AdUiThemeElement element) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
TileInRow() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
TitleBarLocation() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
TitleBarLocationUpdated(AdUiTitleBarLocation newLoc) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | inlinevirtual
UpdateTabs() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
UseSinglePaletteTabNameStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
~CAdUiDockControlBar() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
~CAdUiPaletteSet() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | virtual


ZRX API Reference: CAdUiPaletteSetDockFrame Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAdUiPaletteSetDockFrame Class Reference
MFC Classes
+ Inheritance diagram for CAdUiPaletteSetDockFrame:

Public Types

enum | AdUiTitleBarLocation { kLeft = 0, kRight }
enum | ContainedBarType { Unknown, Standard, AdskBar }

Public Member Functions

virtual void | CalcWindowRect (LPRECT lpClientRect, UINT nAdjustType=adjustBorder)
virtual BOOL | Create (CWnd *pParent, DWORD dwBarStyle)
enum ContainedBarType | GetContainedBarType ()
void | SetAutoRollup (BOOL bSet)
void | SetTitleBarLocation (CAdUiPaletteSetDockFrame::AdUiTitleBarLocation)
CAdUiPaletteSetDockFrame::AdUiTitleBarLocation | TitleBarLocation ()

Protected Member Functions

bool | CanAutoCADTakeFocus ()
bool | CanFrameworkTakeFocus ()
void | ForceChildRepaint ()
CAdUiPaletteSet * | GetPaletteSet ()
BOOL | HitTest (CPoint pt, UINT &nFlag, DWORD &dwData)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg void | OnClose ()
afx_msg void | OnContextMenu (CWnd *pWnd, CPoint pos)
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnDestroy ()
afx_msg LRESULT | OnDisplayChange (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDragEnter (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDragLeave (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDragOver (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDragScroll (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDrop (WPARAM wParam, LPARAM lParam)
virtual LRESULT | OnDropEx (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnEnterSizeMove (WPARAM, LPARAM)
afx_msg BOOL | OnEraseBkgnd (CDC *pDC)
afx_msg LRESULT | OnExitSizeMove (WPARAM, LPARAM)
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
afx_msg void | OnLButtonDown (UINT nHitTest, CPoint pt)
afx_msg int | OnMouseActivate (CWnd *pDesktopWnd, UINT nHitTest, UINT message)
afx_msg void | OnMouseMove (UINT nHitTest, CPoint pt)
afx_msg BOOL | OnNcActivate (BOOL bActive)
afx_msg LRESULT | OnNcCalcSize (WPARAM wParam, LPARAM lParam)
afx_msg UINT | OnNcHitTest (CPoint point)
afx_msg void | OnNcLButtonDown (UINT nHitTest, CPoint pt)
afx_msg void | OnNcLButtonUp (UINT nHitTest, CPoint pt)
afx_msg void | OnNcMouseMove (UINT nHitTest, CPoint pt)
afx_msg void | OnNcPaint ()
afx_msg void | OnNcRButtonDown (UINT nHitTest, CPoint pt)
afx_msg void | OnNcRButtonUp (UINT nHitTest, CPoint pt)
afx_msg void | OnPaint ()
afx_msg BOOL | OnSetCursor (CWnd *pwnd, UINT nHitTest, UINT msg)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg void | OnSettingChange (UINT uFlags, LPCTSTR lpszSection)
afx_msg void | OnShowWindow (BOOL bShow, UINT nStatus)
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg void | OnSizing (UINT nSide, LPRECT pRect)
afx_msg void | OnTimer (UINT_PTR nIdEvent)
afx_msg void | OnWindowPosChanging (WINDOWPOS *lpwndpos)
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)
virtual BOOL | PreTranslateMessage (MSG *msg)

Protected Attributes

bool | m_bZOrderChanged
enum ContainedBarType | m_nContainedBarType

Friends

class | CAdUiAnchorBar
class | CAdUiDockBarMutator
class | CAdUiDockDragContext
class | CAdUiImpPaletteSet
The documentation for this class was generated from the following file:
  • aduiDock.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiPaletteSetDockFrame Member List

This is the complete list of members for CAdUiPaletteSetDockFrame, including all inherited members.

AdskBar enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
AdUiTitleBarLocation enum name (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
CAdUiAnchorBar (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | friend
CAdUiDockBarMutator (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | friend
CAdUiDockDragContext (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | friend
CAdUiImpPaletteSet (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | friend
CAdUiPaletteSetDockFrame() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
CalcWindowRect(LPRECT lpClientRect, UINT nAdjustType=adjustBorder) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | virtual
CanAutoCADTakeFocus() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
CanFrameworkTakeFocus() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
ContainedBarType enum name (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
Create(CWnd *pParent, DWORD dwBarStyle) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | virtual
ForceChildRepaint() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
GetContainedBarType() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
GetPaletteSet() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
HitTest(CPoint pt, UINT &nFlag, DWORD &dwData) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
kLeft enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
kRight enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
m_bZOrderChanged (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
m_nContainedBarType (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnClose() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnContextMenu(CWnd *pWnd, CPoint pos) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnDestroy() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnDisplayChange(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnDragEnter(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDragLeave(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDragOver(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDragScroll(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDrop(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnDropEx(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
OnEnterSizeMove(WPARAM, LPARAM) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnEraseBkgnd(CDC *pDC) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnExitSizeMove(WPARAM, LPARAM) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnLButtonDown(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnMouseActivate(CWnd *pDesktopWnd, UINT nHitTest, UINT message) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnMouseMove(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcActivate(BOOL bActive) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcCalcSize(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcHitTest(CPoint point) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcLButtonDown(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcLButtonUp(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcMouseMove(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcPaint() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcRButtonDown(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnNcRButtonUp(UINT nHitTest, CPoint pt) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnPaint() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSetCursor(CWnd *pwnd, UINT nHitTest, UINT msg) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSettingChange(UINT uFlags, LPCTSTR lpszSection) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnShowWindow(BOOL bShow, UINT nStatus) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSize(UINT nType, int cx, int cy) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnSizing(UINT nSide, LPRECT pRect) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnTimer(UINT_PTR nIdEvent) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
OnWindowPosChanging(WINDOWPOS *lpwndpos) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protected
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
PreTranslateMessage(MSG *msg) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | protectedvirtual
SetAutoRollup(BOOL bSet) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
SetTitleBarLocation(CAdUiPaletteSetDockFrame::AdUiTitleBarLocation) (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
Standard enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
TitleBarLocation() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
Unknown enum value (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame |
~CAdUiPaletteSetDockFrame() (defined in CAdUiPaletteSetDockFrame) | CAdUiPaletteSetDockFrame | virtual


ZRX API Reference: CAdUiPathname Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Static Protected Member Functions | Protected Attributes | List of all members
CAdUiPathname Class Reference
MFC Classes
+ Inheritance diagram for CAdUiPathname:

Public Member Functions

PathErr | AddExtensionAlways (LPCTSTR)
PathErr | AddExtensionIfNoMatch (LPCTSTR)
PathErr | Append (LPCTSTR)
PathErr | AppendComponent (LPCTSTR)
PathErr | AppendSlash (void)
void | BaseToLower (void)
void | BaseToUpper (void)
CAdUiPathname (const CAdUiPathname &)
void | Empty (void)
BOOL | Exists (void)
void | GetBasename (CString &) const
void | GetDisplayName (CString &strResult, int maxchars) const
void | GetExtension (CString &) const
void | GetFilename (CString &) const
BOOL | GetFullPath (CString &) const
BOOL | GetFullPath (LPTSTR) const
void | GetFullUNCPath (CString &) const
void | GetParent (CAdUiPathname &) const
LPCTSTR | GetPathString (void) const
path_type | GetPathType (void) const
BOOL | GetUniqueName (CAdUiPathname &, BOOL alwaysMangle=FALSE) const
const CAdUiVolumeDescriptor * | GetVolumeDescriptor (void) const
BOOL | HadPrefix (void) const
BOOL | IsEmpty (void) const
BOOL | IsPath (void) const
BOOL | Open (FILE **fdp, const ACHAR *openmode)
BOOL | Open (CFile &fp, UINT openflags)
BOOL | OpenReadOnly (HANDLE &rFileHandle)
BOOL | OpenWriteOnly (HANDLE &rFileHandle)
const CAdUiPathname & | operator= (const CAdUiPathname &pathSrc)
const CAdUiPathname & | operator= (const CAdUiPathname *pathSrc)
virtual PathErr | Parse (LPCTSTR, const BOOL wildcard_ok=FALSE)
BOOL | ParseAndOSFind (LPCTSTR)
PathErr | ParseRelative (LPCTSTR name, const CAdUiPathname *relpath, const BOOL wildcard_ok=FALSE)
BOOL | PathMatch (const CAdUiPathname *) const
BOOL | PathMatch (LPCTSTR) const
BOOL | Remove (void)
void | RemoveExtensionAlways (void)
void | RemoveExtensionIfMatch (LPCTSTR)
void | RemoveSpaces (void)
BOOL | Rename (const ACHAR *newname)
PathErr | ReplaceExtensionAlways (LPCTSTR)
PathErr | ReplaceExtensionIfNoMatch (LPCTSTR)
PathErr | Trim (void)
PathErr | TrimComponent (void)
PathErr | TrimSlash (void)
BOOL | VerifyExtension (LPCTSTR extlist) const
BOOL | WasAbsolute (void) const
BOOL | WasRoot (void) const

Protected Member Functions

virtual void | AssignCopy (const CAdUiPathname &)
const CAdUiVolumeDescriptor * | FindVolumeDescriptor (const CString &vol_name) const
FS_TYPE | GetFileSystem (CString &vol_name) const
ACHAR | GetSeparator (void) const
BOOL | IsDeviceName (const CString &str) const
const CAdUiVolumeDescriptor * | NewVolDescriptor (const CString &vol_name) const

Static Protected Member Functions

static ACHAR | GetLastCharacter (const CString &)
static void | Unquote (CString &)

Protected Attributes

BOOL | m_had_prefix
path_category | m_path_cat
CString * | m_pathbuffer
const CAdUiVolumeDescriptor * | m_pvolume
CString * | m_relpath
ACHAR | m_separator
path_type | m_this_type

Member Function Documentation

static ACHAR CAdUiPathname::GetLastCharacter ( const CString & )
staticprotected
Warning
Not implemented!
void CAdUiPathname::RemoveExtensionAlways ( void )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aduiPathname.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiPathname Member List

This is the complete list of members for CAdUiPathname, including all inherited members.

AddExtensionAlways(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
AddExtensionIfNoMatch(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
Append(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
AppendComponent(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
AppendSlash(void) (defined in CAdUiPathname) | CAdUiPathname |
AssignCopy(const CAdUiPathname &) (defined in CAdUiPathname) | CAdUiPathname | protectedvirtual
BaseToLower(void) (defined in CAdUiPathname) | CAdUiPathname |
BaseToUpper(void) (defined in CAdUiPathname) | CAdUiPathname |
CAdUiPathname(void) (defined in CAdUiPathname) | CAdUiPathname |
CAdUiPathname(const CAdUiPathname &) (defined in CAdUiPathname) | CAdUiPathname | inline
Empty(void) (defined in CAdUiPathname) | CAdUiPathname |
Exists(void) (defined in CAdUiPathname) | CAdUiPathname |
FindVolumeDescriptor(const CString &vol_name) const (defined in CAdUiPathname) | CAdUiPathname | protected
GetBasename(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetDisplayName(CString &strResult, int maxchars) const (defined in CAdUiPathname) | CAdUiPathname |
GetExtension(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetFilename(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetFileSystem(CString &vol_name) const (defined in CAdUiPathname) | CAdUiPathname | protected
GetFullPath(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetFullPath(LPTSTR) const (defined in CAdUiPathname) | CAdUiPathname |
GetFullUNCPath(CString &) const (defined in CAdUiPathname) | CAdUiPathname |
GetLastCharacter(const CString &) | CAdUiPathname | protectedstatic
GetParent(CAdUiPathname &) const (defined in CAdUiPathname) | CAdUiPathname |
GetPathString(void) const (defined in CAdUiPathname) | CAdUiPathname |
GetPathType(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
GetSeparator(void) const (defined in CAdUiPathname) | CAdUiPathname | protected
GetUniqueName(CAdUiPathname &, BOOL alwaysMangle=FALSE) const (defined in CAdUiPathname) | CAdUiPathname |
GetVolumeDescriptor(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
HadPrefix(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
IsDeviceName(const CString &str) const (defined in CAdUiPathname) | CAdUiPathname | inlineprotected
IsEmpty(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
IsPath(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
m_had_prefix (defined in CAdUiPathname) | CAdUiPathname | protected
m_path_cat (defined in CAdUiPathname) | CAdUiPathname | protected
m_pathbuffer (defined in CAdUiPathname) | CAdUiPathname | protected
m_pvolume (defined in CAdUiPathname) | CAdUiPathname | protected
m_relpath (defined in CAdUiPathname) | CAdUiPathname | protected
m_separator (defined in CAdUiPathname) | CAdUiPathname | protected
m_this_type (defined in CAdUiPathname) | CAdUiPathname | protected
NewVolDescriptor(const CString &vol_name) const (defined in CAdUiPathname) | CAdUiPathname | protected
Open(FILE **fdp, const ACHAR *openmode) (defined in CAdUiPathname) | CAdUiPathname |
Open(CFile &fp, UINT openflags) (defined in CAdUiPathname) | CAdUiPathname |
OpenReadOnly(HANDLE &rFileHandle) (defined in CAdUiPathname) | CAdUiPathname |
OpenWriteOnly(HANDLE &rFileHandle) (defined in CAdUiPathname) | CAdUiPathname |
operator=(const CAdUiPathname &pathSrc) (defined in CAdUiPathname) | CAdUiPathname | inline
operator=(const CAdUiPathname *pathSrc) (defined in CAdUiPathname) | CAdUiPathname | inline
Parse(LPCTSTR, const BOOL wildcard_ok=FALSE) (defined in CAdUiPathname) | CAdUiPathname | virtual
ParseAndOSFind(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
ParseRelative(LPCTSTR name, const CAdUiPathname *relpath, const BOOL wildcard_ok=FALSE) (defined in CAdUiPathname) | CAdUiPathname |
PathMatch(const CAdUiPathname *) const (defined in CAdUiPathname) | CAdUiPathname |
PathMatch(LPCTSTR) const (defined in CAdUiPathname) | CAdUiPathname |
Remove(void) (defined in CAdUiPathname) | CAdUiPathname |
RemoveExtensionAlways(void) | CAdUiPathname |
RemoveExtensionIfMatch(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
RemoveSpaces(void) (defined in CAdUiPathname) | CAdUiPathname |
Rename(const ACHAR *newname) (defined in CAdUiPathname) | CAdUiPathname |
ReplaceExtensionAlways(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
ReplaceExtensionIfNoMatch(LPCTSTR) (defined in CAdUiPathname) | CAdUiPathname |
Trim(void) (defined in CAdUiPathname) | CAdUiPathname |
TrimComponent(void) (defined in CAdUiPathname) | CAdUiPathname |
TrimSlash(void) (defined in CAdUiPathname) | CAdUiPathname |
Unquote(CString &) (defined in CAdUiPathname) | CAdUiPathname | protectedstatic
VerifyExtension(LPCTSTR extlist) const (defined in CAdUiPathname) | CAdUiPathname |
WasAbsolute(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
WasRoot(void) const (defined in CAdUiPathname) | CAdUiPathname | inline
~CAdUiPathname(void) (defined in CAdUiPathname) | CAdUiPathname |


ZRX API Reference: CAdUiRegistryAccess Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAdUiRegistryAccess Class Reference
MFC Classes
+ Inheritance diagram for CAdUiRegistryAccess:

Public Member Functions

CAdUiRegistryAccess (HKEY hKey, const CString &sSubkey)
virtual void | Close ()
BOOL | EnumKeyNames (DWORD dwEntryIndex, CString &sKeyName)
BOOL | EnumValueNames (DWORD dwEntryIndex, CString &sValueName, LPDWORD lpdwType=NULL)
DWORD | GetDWord (const CString &sValueName)
CString | GetString (const CString &sValueName)
BOOL | IsOpen ()
virtual BOOL | Open (HKEY hKey, const CString &sSubkey)
operator HKEY () const
DWORD | ValueType (const CString &sValueName, LPDWORD lpdwSize=NULL)

Protected Member Functions

void CommonConstruction ()

Protected Attributes

HKEY | m_hKey
CString | m_sSubkey
The documentation for this class was generated from the following file:
  • aduiRegistryAccess.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiRegistryAccess Member List

This is the complete list of members for CAdUiRegistryAccess, including all inherited members.

CAdUiRegistryAccess() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
CAdUiRegistryAccess(HKEY hKey, const CString &sSubkey) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
Close() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | virtual
CommonConstruction() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | protected
EnumKeyNames(DWORD dwEntryIndex, CString &sKeyName) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
EnumValueNames(DWORD dwEntryIndex, CString &sValueName, LPDWORD lpdwType=NULL) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
GetDWord(const CString &sValueName) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
GetString(const CString &sValueName) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
IsOpen() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
m_hKey (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | protected
m_sSubkey (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | protected
Open(HKEY hKey, const CString &sSubkey) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | virtual
operator HKEY() const (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
ValueType(const CString &sValueName, LPDWORD lpdwSize=NULL) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
~CAdUiRegistryAccess() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | virtual


ZRX API Reference: CAdUiRegistryDeleteAccess Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiRegistryDeleteAccess Class Reference
MFC Classes
+ Inheritance diagram for CAdUiRegistryDeleteAccess:

Public Member Functions

CAdUiRegistryDeleteAccess (HKEY hKey, const CString &sSubkey)
BOOL | DeleteAllKeys ()
BOOL | DeleteAllValues ()
BOOL | DeleteKey (const CString &sKeyName)
BOOL | DeleteKeyAndSubkeys (const CString &sKeyName)
BOOL | DeleteValue (const CString &sValueName)
- Public Member Functions inherited from CAdUiRegistryWriteAccess
CAdUiRegistryWriteAccess (HKEY hKey, const CString &sSubkey)
virtual BOOL | Open (HKEY hKey, const CString &sSubkey)
BOOL | SetDWord (const CString &sValueName, DWORD dwValue)
BOOL | SetString (const CString &sValueName, const CString &sValue)
- Public Member Functions inherited from CAdUiRegistryAccess
CAdUiRegistryAccess (HKEY hKey, const CString &sSubkey)
virtual void | Close ()
BOOL | EnumKeyNames (DWORD dwEntryIndex, CString &sKeyName)
BOOL | EnumValueNames (DWORD dwEntryIndex, CString &sValueName, LPDWORD lpdwType=NULL)
DWORD | GetDWord (const CString &sValueName)
CString | GetString (const CString &sValueName)
BOOL | IsOpen ()
operator HKEY () const
DWORD | ValueType (const CString &sValueName, LPDWORD lpdwSize=NULL)

Additional Inherited Members

- Protected Member Functions inherited from CAdUiRegistryAccess
void | CommonConstruction ()
- Protected Attributes inherited from CAdUiRegistryAccess
HKEY | m_hKey
CString | m_sSubkey
The documentation for this class was generated from the following file:
  • aduiRegistryAccess.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiRegistryDeleteAccess Member List

This is the complete list of members for CAdUiRegistryDeleteAccess, including all inherited members.

CAdUiRegistryAccess() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
CAdUiRegistryAccess(HKEY hKey, const CString &sSubkey) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
CAdUiRegistryDeleteAccess() (defined in CAdUiRegistryDeleteAccess) | CAdUiRegistryDeleteAccess |
CAdUiRegistryDeleteAccess(HKEY hKey, const CString &sSubkey) (defined in CAdUiRegistryDeleteAccess) | CAdUiRegistryDeleteAccess |
CAdUiRegistryWriteAccess() (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess |
CAdUiRegistryWriteAccess(HKEY hKey, const CString &sSubkey) (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess |
Close() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | virtual
CommonConstruction() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | protected
DeleteAllKeys() (defined in CAdUiRegistryDeleteAccess) | CAdUiRegistryDeleteAccess |
DeleteAllValues() (defined in CAdUiRegistryDeleteAccess) | CAdUiRegistryDeleteAccess |
DeleteKey(const CString &sKeyName) (defined in CAdUiRegistryDeleteAccess) | CAdUiRegistryDeleteAccess |
DeleteKeyAndSubkeys(const CString &sKeyName) (defined in CAdUiRegistryDeleteAccess) | CAdUiRegistryDeleteAccess |
DeleteValue(const CString &sValueName) (defined in CAdUiRegistryDeleteAccess) | CAdUiRegistryDeleteAccess |
EnumKeyNames(DWORD dwEntryIndex, CString &sKeyName) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
EnumValueNames(DWORD dwEntryIndex, CString &sValueName, LPDWORD lpdwType=NULL) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
GetDWord(const CString &sValueName) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
GetString(const CString &sValueName) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
IsOpen() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
m_hKey (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | protected
m_sSubkey (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | protected
Open(HKEY hKey, const CString &sSubkey) (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess | virtual
operator HKEY() const (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
SetDWord(const CString &sValueName, DWORD dwValue) (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess |
SetString(const CString &sValueName, const CString &sValue) (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess |
ValueType(const CString &sValueName, LPDWORD lpdwSize=NULL) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
~CAdUiRegistryAccess() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | virtual
~CAdUiRegistryDeleteAccess() (defined in CAdUiRegistryDeleteAccess) | CAdUiRegistryDeleteAccess | virtual
~CAdUiRegistryWriteAccess() (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess | virtual


ZRX API Reference: CAdUiRegistryWriteAccess Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiRegistryWriteAccess Class Reference
MFC Classes
+ Inheritance diagram for CAdUiRegistryWriteAccess:

Public Member Functions

CAdUiRegistryWriteAccess (HKEY hKey, const CString &sSubkey)
virtual BOOL | Open (HKEY hKey, const CString &sSubkey)
BOOL | SetDWord (const CString &sValueName, DWORD dwValue)
BOOL | SetString (const CString &sValueName, const CString &sValue)
- Public Member Functions inherited from CAdUiRegistryAccess
CAdUiRegistryAccess (HKEY hKey, const CString &sSubkey)
virtual void | Close ()
BOOL | EnumKeyNames (DWORD dwEntryIndex, CString &sKeyName)
BOOL | EnumValueNames (DWORD dwEntryIndex, CString &sValueName, LPDWORD lpdwType=NULL)
DWORD | GetDWord (const CString &sValueName)
CString | GetString (const CString &sValueName)
BOOL | IsOpen ()
operator HKEY () const
DWORD | ValueType (const CString &sValueName, LPDWORD lpdwSize=NULL)

Additional Inherited Members

- Protected Member Functions inherited from CAdUiRegistryAccess
void | CommonConstruction ()
- Protected Attributes inherited from CAdUiRegistryAccess
HKEY | m_hKey
CString | m_sSubkey
The documentation for this class was generated from the following file:
  • aduiRegistryAccess.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiRegistryWriteAccess Member List

This is the complete list of members for CAdUiRegistryWriteAccess, including all inherited members.

CAdUiRegistryAccess() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
CAdUiRegistryAccess(HKEY hKey, const CString &sSubkey) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
CAdUiRegistryWriteAccess() (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess |
CAdUiRegistryWriteAccess(HKEY hKey, const CString &sSubkey) (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess |
Close() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | virtual
CommonConstruction() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | protected
EnumKeyNames(DWORD dwEntryIndex, CString &sKeyName) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
EnumValueNames(DWORD dwEntryIndex, CString &sValueName, LPDWORD lpdwType=NULL) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
GetDWord(const CString &sValueName) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
GetString(const CString &sValueName) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
IsOpen() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
m_hKey (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | protected
m_sSubkey (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | protected
Open(HKEY hKey, const CString &sSubkey) (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess | virtual
operator HKEY() const (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
SetDWord(const CString &sValueName, DWORD dwValue) (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess |
SetString(const CString &sValueName, const CString &sValue) (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess |
ValueType(const CString &sValueName, LPDWORD lpdwSize=NULL) (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess |
~CAdUiRegistryAccess() (defined in CAdUiRegistryAccess) | CAdUiRegistryAccess | virtual
~CAdUiRegistryWriteAccess() (defined in CAdUiRegistryWriteAccess) | CAdUiRegistryWriteAccess | virtual


ZRX API Reference: CAdUiTab Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
CAdUiTab Class Reference
MFC Classes
+ Inheritance diagram for CAdUiTab:

Public Member Functions

BOOL | AddTab (int iPos, CString const &sTabname, UINT uTemplateID, CAdUiTabChildDialog *pDialog)
BOOL | AddTab (int iPos, UINT uTabStringID, UINT uTemplateID, CAdUiTabChildDialog *pDialog)
BOOL | DeleteItem (int iPos)
BOOL | DestroyTab (int iPos, BOOL bUpdateData=FALSE)
BOOL | DisplayData ()
BOOL | ExchangeData (BOOL bSaveAndValidate)
int | GetActiveTab ()
CAdUiTabChildDialog * | GetDialogPointer (int iPos)
CAdUiTabMainDialog * | GetMainDialog ()
int | GetTabIndex (CAdUiTabChildDialog *pDialog)
BOOL | IsDirty ()
BOOL | RemoveTab (int iPos)
int | SetActiveTab (int iPos)
void | SetApplyButtonID (UINT uID)
void | SetChildFocus ()
void | SetDirty (BOOL bDirty=TRUE)
void | SetValidationInfo (CDataExchange *pDX)
BOOL | ValidateData ()

Protected Member Functions

afx_msg BOOL | OnSelChange (NMHDR *pNMHDR, LRESULT *pResult)
afx_msg BOOL | OnSelChanging (NMHDR *pNMHDR, LRESULT *pResult)
virtual void | PreSubclassWindow ()

Friends

class | CAdUiTabChildDialog
class | CAdUiTabMainDialog
The documentation for this class was generated from the following file:
  • aduiTabCtrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiTab Member List

This is the complete list of members for CAdUiTab, including all inherited members.

AddTab(int iPos, CString const &sTabname, UINT uTemplateID, CAdUiTabChildDialog *pDialog) (defined in CAdUiTab) | CAdUiTab |
AddTab(int iPos, UINT uTabStringID, UINT uTemplateID, CAdUiTabChildDialog *pDialog) (defined in CAdUiTab) | CAdUiTab |
CAdUiTab() (defined in CAdUiTab) | CAdUiTab |
CAdUiTabChildDialog (defined in CAdUiTab) | CAdUiTab | friend
CAdUiTabMainDialog (defined in CAdUiTab) | CAdUiTab | friend
DeleteItem(int iPos) (defined in CAdUiTab) | CAdUiTab |
DestroyTab(int iPos, BOOL bUpdateData=FALSE) (defined in CAdUiTab) | CAdUiTab |
DisplayData() (defined in CAdUiTab) | CAdUiTab |
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiTab) | CAdUiTab |
GetActiveTab() (defined in CAdUiTab) | CAdUiTab |
GetDialogPointer(int iPos) (defined in CAdUiTab) | CAdUiTab |
GetMainDialog() (defined in CAdUiTab) | CAdUiTab |
GetTabIndex(CAdUiTabChildDialog *pDialog) (defined in CAdUiTab) | CAdUiTab |
IsDirty() (defined in CAdUiTab) | CAdUiTab |
OnSelChange(NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiTab) | CAdUiTab | protected
OnSelChanging(NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiTab) | CAdUiTab | protected
PreSubclassWindow() (defined in CAdUiTab) | CAdUiTab | protectedvirtual
RemoveTab(int iPos) (defined in CAdUiTab) | CAdUiTab |
SetActiveTab(int iPos) (defined in CAdUiTab) | CAdUiTab |
SetApplyButtonID(UINT uID) (defined in CAdUiTab) | CAdUiTab |
SetChildFocus() (defined in CAdUiTab) | CAdUiTab |
SetDirty(BOOL bDirty=TRUE) (defined in CAdUiTab) | CAdUiTab |
SetValidationInfo(CDataExchange *pDX) (defined in CAdUiTab) | CAdUiTab |
ValidateData() (defined in CAdUiTab) | CAdUiTab |
~CAdUiTab() (defined in CAdUiTab) | CAdUiTab | virtual


ZRX API Reference: CAdUiTabChildDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Friends | List of all members
CAdUiTabChildDialog Class Reference
MFC Classes
+ Inheritance diagram for CAdUiTabChildDialog:

Public Types

enum | { IDD = 0 }
- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Public Types inherited from CAdUiBaseDialog
enum | { IDD = 0 }

Public Member Functions

CAdUiTabChildDialog (CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
CAdUiTab * | GetAcadTabPointer ()
CAdUiTabMainDialog * | GetMainDialog ()
int | GetTabIndex ()
BOOL | IsDirty ()
virtual void | OnMainDialogApply ()
virtual void | OnMainDialogCancel ()
virtual BOOL | OnMainDialogHelp ()
virtual void | OnMainDialogOK ()
virtual void | OnTabActivation (BOOL bActivate)
virtual BOOL | OnTabChanging ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
void | SetAcadTabChildFocus (HWND hWndFocus)
void | SetDirty (BOOL bDirty=TRUE)
void | SetValidationInfo (CDataExchange *pDX)
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
virtual void | OnDialogHelp ()
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
virtual void | OnCancel ()
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
virtual void | OnOK ()
afx_msg LRESULT | OnResizePage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnSize (UINT nType, int cx, int cy)
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Friends

class CAdUiTab

Additional Inherited Members

- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist
The documentation for this class was generated from the following file:
  • aduiTabChildDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiTabChildDialog Member List

This is the complete list of members for CAdUiTabChildDialog, including all inherited members.

AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CAdUiTab (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | friend
CAdUiTabChildDialog(CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetAcadTabPointer() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetMainDialog() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetTabIndex() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
IDD enum value (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
IsDirty() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnCancel() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protectedvirtual
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protectedvirtual
OnMainDialogApply() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
OnMainDialogCancel() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
OnMainDialogHelp() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
OnMainDialogOK() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protectedvirtual
OnResizePage(WPARAM wParam, LPARAM lParam) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protected
OnSize(UINT nType, int cx, int cy) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | protected
OnTabActivation(BOOL bActivate) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
OnTabChanging() (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog | virtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAcadTabChildFocus(HWND hWndFocus) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetDirty(BOOL bDirty=TRUE) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetValidationInfo(CDataExchange *pDX) (defined in CAdUiTabChildDialog) | CAdUiTabChildDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAdUiTabExtensionManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiTabExtensionManager Class Reference
MFC Classes

Public Member Functions

int | AddExtendedTabs ()
virtual BOOL | AddTab (HINSTANCE hInstRes, UINT uTemplateID, LPCTSTR pszTabName, CAdUiTabChildDialog *pDialog)
virtual LPCTSTR | GetDialogName ()
CAdUiTab * | GetTabControl () const
void | Initialize (CAdUiTab *pTabCtrl, CAdUiTabMainDialog *pDlg)
The documentation for this class was generated from the following file:
  • aduiTabExtension.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiTabExtensionManager Member List

This is the complete list of members for CAdUiTabExtensionManager, including all inherited members.

AddExtendedTabs() (defined in CAdUiTabExtensionManager) | CAdUiTabExtensionManager |
AddTab(HINSTANCE hInstRes, UINT uTemplateID, LPCTSTR pszTabName, CAdUiTabChildDialog *pDialog) (defined in CAdUiTabExtensionManager) | CAdUiTabExtensionManager | virtual
CAdUiTabExtensionManager() (defined in CAdUiTabExtensionManager) | CAdUiTabExtensionManager |
GetDialogName() (defined in CAdUiTabExtensionManager) | CAdUiTabExtensionManager | virtual
GetTabControl() const (defined in CAdUiTabExtensionManager) | CAdUiTabExtensionManager | inline
Initialize(CAdUiTab *pTabCtrl, CAdUiTabMainDialog *pDlg) (defined in CAdUiTabExtensionManager) | CAdUiTabExtensionManager |
~CAdUiTabExtensionManager() (defined in CAdUiTabExtensionManager) | CAdUiTabExtensionManager | virtual


ZRX API Reference: CAdUiTabMainDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAdUiTabMainDialog Class Reference
MFC Classes
+ Inheritance diagram for CAdUiTabMainDialog:

Public Types

enum | { IDD = 0 }
- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Public Types inherited from CAdUiBaseDialog
enum | { IDD = 0 }

Public Member Functions

virtual BOOL | AddApplicationTabs (LPCTSTR pszAppName)
int | AddExtendedTabs ()
BOOL | AddTab (int iPos, LPCTSTR tabName, UINT uTemplateID, CAdUiTabChildDialog *pDialog)
BOOL | AddTab (int iPos, UINT uTabStringID, UINT uTemplateID, CAdUiTabChildDialog *pDialog)
CAdUiTabMainDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
int | GetDefaultButton ()
int | GetInitialRequestedTabIndex ()
LPCTSTR | GetInitialTabIndex ()
CAdUiTab * | GetTabControl ()
int | GetTabIndex (CAdUiTabChildDialog *pDialog)
CAdUiTabExtensionManager * | GetXtabPointer ()
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | RemoveTab (int iPos)
void | SetDefaultButton (int nIdDefaultButton)
void | SetInitialTabIndex (LPCTSTR strTabIndex)
void | UpdateDefaultButton (HWND hFocusBefore, HWND hFocusAfter)
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
virtual void | OnDialogHelp ()
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual void | DoDataExchange (CDataExchange *pDX)
virtual void | OnCancel ()
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
virtual void | OnOK ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
void | RaiseApplyEvent ()
void | SetAcadTabPointer (CAdUiTab *pAcadTab)
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnHelpInfo (HELPINFO *lpHelpInfo)
virtual BOOL | OnInitDialog ()
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Protected Attributes

CAdUiTabExtensionManager | m_xtabManager
- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Protected Attributes inherited from CAdUiBaseDialog
BOOL | m_bUseTips
ADUI_COMMAND_STATE | m_commandState
CString | m_contextHelpFileName
CString | m_contextHelpFullPathName
CString | m_contextHelpPrefix
HINSTANCE | m_hDialogResource
HICON | m_hIcon
CAdUiTextTip * | m_pTextTip
CToolTipCtrl * | m_pToolTip
CString | m_rootKey

Friends

class CAdUiTab

Additional Inherited Members

- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * m_pUIAssist

Member Function Documentation

void CAdUiTabMainDialog::RaiseApplyEvent ( )
protected
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aduiTabMainDialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiTabMainDialog Member List

This is the complete list of members for CAdUiTabMainDialog, including all inherited members.

AddApplicationTabs(LPCTSTR pszAppName) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | virtual
AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AddExtendedTabs() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
AddTab(int iPos, LPCTSTR tabName, UINT uTemplateID, CAdUiTabChildDialog *pDialog) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
AddTab(int iPos, UINT uTabStringID, UINT uTemplateID, CAdUiTabChildDialog *pDialog) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CAdUiTab (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | friend
CAdUiTabMainDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetDefaultButton() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetInitialRequestedTabIndex() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
GetInitialTabIndex() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | inline
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetTabControl() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
GetTabIndex(CAdUiTabChildDialog *pDialog) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetXtabPointer() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
IDD enum value (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
m_xtabManager (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnCancel() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protectedvirtual
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *lpHelpInfo) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnInitDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protectedvirtual
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protectedvirtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protected
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | virtual
RaiseApplyEvent() | CAdUiTabMainDialog | protected
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
RemoveTab(int iPos) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAcadTabPointer(CAdUiTab *pAcadTab) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | protected
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetDefaultButton(int nIdDefaultButton) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetInitialTabIndex(LPCTSTR strTabIndex) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog | inline
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
UpdateDefaultButton(HWND hFocusBefore, HWND hFocusAfter) (defined in CAdUiTabMainDialog) | CAdUiTabMainDialog |
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual


ZRX API Reference: CAdUiTextTip Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAdUiTextTip Class Reference
MFC Classes
+ Inheritance diagram for CAdUiTextTip:

Public Member Functions

virtual void | Hide ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)
void | Update (CWnd *control, BOOL useText)
void | UpdateIfNecessary (CWnd *control, BOOL useText)
- Public Member Functions inherited from CAdUiTipWindow
virtual BOOL | Create (CWnd *owner)
CWnd * | GetControl ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | GetUseText ()
CWnd * | Owner ()
void | SetControl (CWnd *control)
void | SetUseText (BOOL useText)
virtual void | Show ()

Protected Member Functions

virtual void | DrawBorder (CDC &dc, CRect &rExterior, CRect &rInterior)
virtual void | DrawContent (CDC &dc, CRect &rInterior)
- Protected Member Functions inherited from CAdUiTipWindow
afx_msg void | OnActivateApp (BOOL bActive, DWORD hTask)
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnNcDestroy ()
afx_msg void | OnPaint ()
afx_msg void | OnRButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnRButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
void | StartTimer (DWORD ms=50)
void | StopTimer ()

Additional Inherited Members

- Protected Attributes inherited from CAdUiTipWindow
BOOL | m_bUseText
CWnd * | m_control
CWnd * | m_owner
UINT_PTR | m_timerId
- Static Protected Attributes inherited from CAdUiTipWindow
static LPCTSTR | m_className
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • aduiTextTip.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiTextTip Member List

This is the complete list of members for CAdUiTextTip, including all inherited members.

CAdUiTextTip() (defined in CAdUiTextTip) | CAdUiTextTip |
CAdUiTipWindow() (defined in CAdUiTipWindow) | CAdUiTipWindow |
Create(CWnd *owner) (defined in CAdUiTipWindow) | CAdUiTipWindow | virtual
DrawBorder(CDC &dc, CRect &rExterior, CRect &rInterior) (defined in CAdUiTextTip) | CAdUiTextTip | protectedvirtual
DrawContent(CDC &dc, CRect &rInterior) (defined in CAdUiTextTip) | CAdUiTextTip | protectedvirtual
GetControl() (defined in CAdUiTipWindow) | CAdUiTipWindow |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiTipWindow) | CAdUiTipWindow |
GetUseText() (defined in CAdUiTipWindow) | CAdUiTipWindow |
Hide() (defined in CAdUiTextTip) | CAdUiTextTip | virtual
m_bUseText (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
m_className (defined in CAdUiTipWindow) | CAdUiTipWindow | protectedstatic
m_control (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
m_owner (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
m_timerEvent (defined in CAdUiTipWindow) | CAdUiTipWindow | protectedstatic
m_timerId (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnActivateApp(BOOL bActive, DWORD hTask) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnLButtonDown(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnMButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnMButtonDown(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnNcDestroy() (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnPaint() (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnRButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnRButtonDown(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
Owner() (defined in CAdUiTipWindow) | CAdUiTipWindow |
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiTextTip) | CAdUiTextTip | virtual
SetControl(CWnd *control) (defined in CAdUiTipWindow) | CAdUiTipWindow |
SetUseText(BOOL useText) (defined in CAdUiTipWindow) | CAdUiTipWindow |
Show() (defined in CAdUiTipWindow) | CAdUiTipWindow | virtual
StartTimer(DWORD ms=50) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
StopTimer() (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
Update(CWnd *control, BOOL useText) (defined in CAdUiTextTip) | CAdUiTextTip |
UpdateIfNecessary(CWnd *control, BOOL useText) (defined in CAdUiTextTip) | CAdUiTextTip |
~CAdUiTextTip() (defined in CAdUiTextTip) | CAdUiTextTip | virtual
~CAdUiTipWindow() (defined in CAdUiTipWindow) | CAdUiTipWindow | virtual


ZRX API Reference: CAdUiTheme Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAdUiTheme Class Reference
MFC Classes

Public Member Functions

COLORREF | GetColor (AdUiThemeElement nDisplayElement) const
BOOL | GetData (int nElement, DWORD &dwData) const
BOOL | GetData (int nElement, CString &sData) const
void * | GetDataPtr (int nElement) const
BOOL | GetFont (AdUiThemeElement nDisplayElement, LOGFONT *plf) const
BOOL | GetFont (AdUiThemeElement nDisplayElement, CFont *&pFont) const
void | IncrementRefCount ()
CAdUiTheme & | operator= (const CAdUiTheme *pTheme)
BOOL | RegisterReactor (CAdUiThemeModifiedReactor *pReactor)
void | ResumeModifiedNotifications ()
void | SendModifiedNotification () const
BOOL | SetColor (AdUiThemeElement nDisplayElement, COLORREF crColor)
void | SetData (int nElement, const DWORD &dwData)
void | SetData (int nElement, const CString &sData)
void | SetDataPtr (int nElement, void *pData)
BOOL | SetFont (AdUiThemeElement nDisplayElement, LOGFONT *plf=NULL)
void | SuspendModifiedNotifications ()
BOOL | UnregisterReactor (CAdUiThemeModifiedReactor *pReactor)

Friends

class CAdUiThemeManager
The documentation for this class was generated from the following file:
  • aduitheme.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiTheme Member List

This is the complete list of members for CAdUiTheme, including all inherited members.

CAdUiThemeManager (defined in CAdUiTheme) | CAdUiTheme | friend
GetColor(AdUiThemeElement nDisplayElement) const (defined in CAdUiTheme) | CAdUiTheme |
GetData(int nElement, DWORD &dwData) const (defined in CAdUiTheme) | CAdUiTheme |
GetData(int nElement, CString &sData) const (defined in CAdUiTheme) | CAdUiTheme |
GetDataPtr(int nElement) const (defined in CAdUiTheme) | CAdUiTheme |
GetFont(AdUiThemeElement nDisplayElement, LOGFONT *plf) const (defined in CAdUiTheme) | CAdUiTheme |
GetFont(AdUiThemeElement nDisplayElement, CFont *&pFont) const (defined in CAdUiTheme) | CAdUiTheme |
IncrementRefCount() (defined in CAdUiTheme) | CAdUiTheme | inline
operator=(const CAdUiTheme *pTheme) (defined in CAdUiTheme) | CAdUiTheme |
RegisterReactor(CAdUiThemeModifiedReactor *pReactor) (defined in CAdUiTheme) | CAdUiTheme |
ResumeModifiedNotifications() (defined in CAdUiTheme) | CAdUiTheme |
SendModifiedNotification() const (defined in CAdUiTheme) | CAdUiTheme |
SetColor(AdUiThemeElement nDisplayElement, COLORREF crColor) (defined in CAdUiTheme) | CAdUiTheme |
SetData(int nElement, const DWORD &dwData) (defined in CAdUiTheme) | CAdUiTheme |
SetData(int nElement, const CString &sData) (defined in CAdUiTheme) | CAdUiTheme |
SetDataPtr(int nElement, void *pData) (defined in CAdUiTheme) | CAdUiTheme |
SetFont(AdUiThemeElement nDisplayElement, LOGFONT *plf=NULL) (defined in CAdUiTheme) | CAdUiTheme |
SuspendModifiedNotifications() (defined in CAdUiTheme) | CAdUiTheme | inline
UnregisterReactor(CAdUiThemeModifiedReactor *pReactor) (defined in CAdUiTheme) | CAdUiTheme |


ZRX API Reference: CAdUiThemeManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAdUiThemeManager Class Reference
MFC Classes

Public Member Functions

CAdUiTheme * | GetTheme (const ACHAR *pThemeName)
BOOL | HasTheme (const ACHAR *pThemeName) const
BOOL | ReleaseTheme (CAdUiTheme *pTheme)
void | SystemColorChanged ()

Friends

class CAdUiThemeMgrReactor
The documentation for this class was generated from the following file:
  • aduithememanager.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiThemeManager Member List

This is the complete list of members for CAdUiThemeManager, including all inherited members.

CAdUiThemeManager() (defined in CAdUiThemeManager) | CAdUiThemeManager |
CAdUiThemeMgrReactor (defined in CAdUiThemeManager) | CAdUiThemeManager | friend
GetTheme(const ACHAR *pThemeName) (defined in CAdUiThemeManager) | CAdUiThemeManager |
HasTheme(const ACHAR *pThemeName) const (defined in CAdUiThemeManager) | CAdUiThemeManager |
ReleaseTheme(CAdUiTheme *pTheme) (defined in CAdUiThemeManager) | CAdUiThemeManager |
SystemColorChanged() (defined in CAdUiThemeManager) | CAdUiThemeManager |
~CAdUiThemeManager() (defined in CAdUiThemeManager) | CAdUiThemeManager |


ZRX API Reference: CAdUiThemeMgrReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiThemeMgrReactor Class Reference
MFC Classes

Public Member Functions

virtual void | SystemColorChanged ()=0
virtual void | ThemeAdded (const CString &strThemeName)=0
virtual void | ThemeRemoved (const CString &strThemeName)=0
The documentation for this class was generated from the following file:
  • aduithememanager.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiThemeMgrReactor Member List

This is the complete list of members for CAdUiThemeMgrReactor, including all inherited members.

CAdUiThemeMgrReactor() (defined in CAdUiThemeMgrReactor) | CAdUiThemeMgrReactor |
SystemColorChanged()=0 (defined in CAdUiThemeMgrReactor) | CAdUiThemeMgrReactor | pure virtual
ThemeAdded(const CString &strThemeName)=0 (defined in CAdUiThemeMgrReactor) | CAdUiThemeMgrReactor | pure virtual
ThemeRemoved(const CString &strThemeName)=0 (defined in CAdUiThemeMgrReactor) | CAdUiThemeMgrReactor | pure virtual
~CAdUiThemeMgrReactor() (defined in CAdUiThemeMgrReactor) | CAdUiThemeMgrReactor |


ZRX API Reference: CAdUiThemeModifiedReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiThemeModifiedReactor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiThemeModifiedReactor:

Public Member Functions

virtual void ThemeModified (const CAdUiTheme *pTheme, AdUiThemeElement element)=0
The documentation for this class was generated from the following file:
  • aduitheme.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiThemeModifiedReactor Member List

This is the complete list of members for CAdUiThemeModifiedReactor, including all inherited members.

ThemeModified(const CAdUiTheme *pTheme, AdUiThemeElement element)=0 (defined in CAdUiThemeModifiedReactor) CAdUiThemeModifiedReactor pure virtual


ZRX API Reference: CAdUiTipWindow Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
CAdUiTipWindow Class Reference
MFC Classes
+ Inheritance diagram for CAdUiTipWindow:

Public Member Functions

virtual BOOL | Create (CWnd *owner)
CWnd * | GetControl ()
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | GetUseText ()
virtual void | Hide ()
CWnd * | Owner ()
void | SetControl (CWnd *control)
void | SetUseText (BOOL useText)
virtual void | Show ()

Protected Member Functions

virtual void | DrawBorder (CDC &dc, CRect &rExterior, CRect &rInterior)
virtual void | DrawContent (CDC &dc, CRect &rInterior)
afx_msg void | OnActivateApp (BOOL bActive, DWORD hTask)
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnNcDestroy ()
afx_msg void | OnPaint ()
afx_msg void | OnRButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnRButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
void | StartTimer (DWORD ms=50)
void | StopTimer ()

Protected Attributes

BOOL | m_bUseText
CWnd * | m_control
CWnd * | m_owner
UINT_PTR | m_timerId

Static Protected Attributes

static LPCTSTR | m_className
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • aduiTextTip.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiTipWindow Member List

This is the complete list of members for CAdUiTipWindow, including all inherited members.

CAdUiTipWindow() (defined in CAdUiTipWindow) | CAdUiTipWindow |
Create(CWnd *owner) (defined in CAdUiTipWindow) | CAdUiTipWindow | virtual
DrawBorder(CDC &dc, CRect &rExterior, CRect &rInterior) (defined in CAdUiTipWindow) | CAdUiTipWindow | protectedvirtual
DrawContent(CDC &dc, CRect &rInterior) (defined in CAdUiTipWindow) | CAdUiTipWindow | protectedvirtual
GetControl() (defined in CAdUiTipWindow) | CAdUiTipWindow |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiTipWindow) | CAdUiTipWindow |
GetUseText() (defined in CAdUiTipWindow) | CAdUiTipWindow |
Hide() (defined in CAdUiTipWindow) | CAdUiTipWindow | virtual
m_bUseText (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
m_className (defined in CAdUiTipWindow) | CAdUiTipWindow | protectedstatic
m_control (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
m_owner (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
m_timerEvent (defined in CAdUiTipWindow) | CAdUiTipWindow | protectedstatic
m_timerId (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnActivateApp(BOOL bActive, DWORD hTask) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnLButtonDown(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnMButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnMButtonDown(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnNcDestroy() (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnPaint() (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnRButtonDblClk(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnRButtonDown(UINT nFlags, CPoint point) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
Owner() (defined in CAdUiTipWindow) | CAdUiTipWindow |
SetControl(CWnd *control) (defined in CAdUiTipWindow) | CAdUiTipWindow |
SetUseText(BOOL useText) (defined in CAdUiTipWindow) | CAdUiTipWindow |
Show() (defined in CAdUiTipWindow) | CAdUiTipWindow | virtual
StartTimer(DWORD ms=50) (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
StopTimer() (defined in CAdUiTipWindow) | CAdUiTipWindow | protected
~CAdUiTipWindow() (defined in CAdUiTipWindow) | CAdUiTipWindow | virtual


ZRX API Reference: CAdUiToolButton Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
CAdUiToolButton Class Reference
MFC Classes
+ Inheritance diagram for CAdUiToolButton:

Additional Inherited Members

- Public Member Functions inherited from CAdUiBitmapButton
BOOL | GetAutoSizeToBitmap ()
void | SetAutoSizeToBitmap (BOOL autoSizeToBitmap)
void | SetBitmapOffsets (int nBorderOffset, int nFocusRectOffset)
void | SizeToBitmap ()
- Protected Member Functions inherited from CAdUiBitmapButton
void | CalcBitmapSize ()
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
BOOL | LoadBitmap (LPCTSTR strResId)
BOOL | LoadBitmapResource (LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst)
virtual BOOL | OnAutoLoad ()
virtual BOOL | OnLoadBitmap (LPCTSTR strResId)
virtual BOOL | OnReload (LPCTSTR strResId)
- Protected Attributes inherited from CAdUiBitmapButton
BOOL | m_bAutoSizeToBitmap
CBitmap | m_bmp
int | m_bmpHeight
CString | m_bmpResId
int | m_bmpWidth
int | m_bmpX
int | m_bmpY
int | m_focusRectOffset
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • aduiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiToolButton Member List

This is the complete list of members for CAdUiToolButton, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAdUiToolButton() (defined in CAdUiToolButton) | CAdUiToolButton |
CalcBitmapSize() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
DrawHotBorder() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetAutoSizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
LoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
LoadBitmapResource(LPCTSTR strResId, CBitmap &bmp, HINSTANCE hInst) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bAutoSizeToBitmap (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bmp (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpHeight (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpResId (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpWidth (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpX (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_bmpY (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_focusRectOffset (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnLoadBitmap(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiBitmapButton) | CAdUiBitmapButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAutoSizeToBitmap(BOOL autoSizeToBitmap) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetBitmapOffsets(int nBorderOffset, int nFocusRectOffset) (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
SetTracking(BOOL b) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | inlinevirtual
SizeToBitmap() (defined in CAdUiBitmapButton) | CAdUiBitmapButton |
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAdUiBitmapButton() (defined in CAdUiBitmapButton) | CAdUiBitmapButton | virtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
~CAdUiToolButton() (defined in CAdUiToolButton) | CAdUiToolButton | virtual


ZRX API Reference: CAdUiTrackButton Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
CAdUiTrackButton Class Reference
MFC Classes
+ Inheritance diagram for CAdUiTrackButton:

Public Member Functions

CAdUiTrackButton (const CAdUiTrackButtonDraw &pDraw)
virtual void | DrawItem (LPDRAWITEMSTRUCT lpDrawItemStruct)
virtual CAdUiTheme * | GetTheme () const
CAdUiTrackButtonDraw * | SetDraw (CAdUiTrackButtonDraw *pDraw)
virtual CAdUiTheme * | SetTheme (CAdUiTheme *pTheme)
virtual void | SetTracking (BOOL b)
- Public Member Functions inherited from CAdUiOwnerDrawButton
BOOL | AutoLoad ()
CWnd * | GetAdUiParent ()
BOOL | GetEnableDragDrop ()
BOOL | GetEnableFastDraw ()
BOOL | GetEnablePointedAt ()
BOOL | GetIsStatic ()
BOOL | GetIsToolButton ()
virtual void | PreSubclassWindow ()
BOOL | Reload (LPCTSTR strResId)
void | SetAdUiParent (CWnd *w)
void | SetEnableDragDrop (BOOL allow)
void | SetEnableFastDraw (BOOL allow)
void | SetEnablePointedAt (BOOL allow)
void | SetIsStatic (BOOL isStatic)
void | SetIsToolButton (BOOL isToolButton)

Static Public Member Functions

static CAdUiTrackButtonDraw * SetDefaultDraw (CAdUiTrackButtonDraw *pDraw)

Protected Member Functions

virtual void | DrawBorder (CDC *pDC, CRect &r, COLORREF cr)
virtual void | DrawButton (CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused)
virtual void | DrawHotBorder ()
virtual void | DrawPushButtonBorder (CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected)
virtual void | DrawToolButtonBorder (CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
afx_msg void | OnNcPaint ()
afx_msg void | OnPaint ()
virtual void | releaseDraw ()
- Protected Member Functions inherited from CAdUiOwnerDrawButton
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
void | DrawTransparentBitmap (CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled)
BOOL | GetIsPointedAt ()
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
virtual BOOL | OnAutoLoad ()
afx_msg void | OnDestroy ()
virtual void | OnDragDrop (HDROP hDropInfo)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
afx_msg void | OnDropFiles (HDROP hDropInfo)
afx_msg UINT | OnGetDlgCode ()
virtual BOOL | OnGetTipRect (CRect &r)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnKillFocus (CWnd *pNewWnd)
afx_msg LRESULT | OnMouseLeave (WPARAM, LPARAM)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
afx_msg void | OnNcDestroy ()
virtual void | OnPointedAt (BOOL isPointedAt)
virtual BOOL | OnReload (LPCTSTR strResId)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg LRESULT | OnThemeChanged (WPARAM wParam, LPARAM lParam)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
void | SetIsPointedAt (BOOL isPointedAt)
void | StartTimer (DWORD ms=50)
void | StopTimer ()
virtual void | ThemeModified (AdUiThemeElement element)

Additional Inherited Members

- Protected Attributes inherited from CAdUiOwnerDrawButton
CWnd * | m_aduiParent
BOOL | m_bEnableDragDrop: 1
BOOL | m_bEnableFastDraw: 1
BOOL | m_bEnablePointedAt: 1
BOOL | m_bIsPointedAt: 1
BOOL | m_bIsStatic: 1
BOOL | m_bIsToolButton: 1
BOOL | m_bIsTrackButton: 1
BOOL | m_bMouseHover
CPoint | m_lastMousePoint
int | m_nPartId
int | m_nStateId
CAdUiTheme * | m_pTheme
UINT_PTR | m_timerId
CRect | m_tipRect
UINT | m_uEdge
- Static Protected Attributes inherited from CAdUiOwnerDrawButton
static const UINT_PTR | m_timerEvent
The documentation for this class was generated from the following file:
  • aduiButton.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiTrackButton Member List

This is the complete list of members for CAdUiTrackButton, including all inherited members.

AutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
CAdUiTrackButton() (defined in CAdUiTrackButton) | CAdUiTrackButton |
CAdUiTrackButton(const CAdUiTrackButtonDraw &pDraw) (defined in CAdUiTrackButton) | CAdUiTrackButton |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
DrawBorder(CDC *pDC, CRect &r, COLORREF cr) (defined in CAdUiTrackButton) | CAdUiTrackButton | protectedvirtual
DrawButton(CDC &dc, int w, int h, BOOL isDefault, BOOL isDisabled, BOOL isSelected, BOOL isFocused) (defined in CAdUiTrackButton) | CAdUiTrackButton | protectedvirtual
DrawHotBorder() (defined in CAdUiTrackButton) | CAdUiTrackButton | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) (defined in CAdUiTrackButton) | CAdUiTrackButton | virtual
DrawPushButtonBorder(CDC &dc, CRect &rButton, BOOL isDefault, BOOL isSelected) (defined in CAdUiTrackButton) | CAdUiTrackButton | protectedvirtual
DrawToolButtonBorder(CDC &dc, CRect &rButton, BOOL isSelected, BOOL isFocused) (defined in CAdUiTrackButton) | CAdUiTrackButton | protectedvirtual
DrawTransparentBitmap(CDC &dc, CBitmap &bmp, int x, int y, int w, int h, BOOL isDisabled) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetAdUiParent() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableDragDrop() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnableFastDraw() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetEnablePointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsPointedAt() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
GetIsStatic() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetIsToolButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
GetTheme() const (defined in CAdUiTrackButton) | CAdUiTrackButton | virtual
m_aduiParent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableDragDrop (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnableFastDraw (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bEnablePointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsPointedAt (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsStatic (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsToolButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bIsTrackButton (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_bMouseHover (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_lastMousePoint (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nPartId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_nStateId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_pTheme (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_timerEvent (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedstatic
m_timerId (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_tipRect (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
m_uEdge (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnAutoLoad() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnDragDrop(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTip(CDC &dc) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnDropFiles(HDROP hDropInfo) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetDlgCode() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnGetTipRect(CRect &r) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiTrackButton) | CAdUiTrackButton | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnHitTipRect(CPoint &p) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnKillFocus(CWnd *pNewWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseLeave(WPARAM, LPARAM) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcDestroy() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnNcPaint() (defined in CAdUiTrackButton) | CAdUiTrackButton | protected
OnPaint() (defined in CAdUiTrackButton) | CAdUiTrackButton | protected
OnPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnReload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnThemeChanged(WPARAM wParam, LPARAM lParam) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
PreSubclassWindow() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
releaseDraw() (defined in CAdUiTrackButton) | CAdUiTrackButton | protectedvirtual
Reload(LPCTSTR strResId) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetAdUiParent(CWnd *w) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetDefaultDraw(CAdUiTrackButtonDraw *pDraw) (defined in CAdUiTrackButton) | CAdUiTrackButton | static
SetDraw(CAdUiTrackButtonDraw *pDraw) (defined in CAdUiTrackButton) | CAdUiTrackButton |
SetEnableDragDrop(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnableFastDraw(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetEnablePointedAt(BOOL allow) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsPointedAt(BOOL isPointedAt) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
SetIsStatic(BOOL isStatic) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetIsToolButton(BOOL isToolButton) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiTrackButton) | CAdUiTrackButton | virtual
SetTracking(BOOL b) (defined in CAdUiTrackButton) | CAdUiTrackButton | virtual
StartTimer(DWORD ms=50) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
StopTimer() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protected
ThemeModified(AdUiThemeElement element) (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | protectedvirtual
~CAdUiOwnerDrawButton() (defined in CAdUiOwnerDrawButton) | CAdUiOwnerDrawButton | virtual
~CAdUiTrackButton() (defined in CAdUiTrackButton) | CAdUiTrackButton | virtual


ZRX API Reference: CAdUiUFSVolumeDescriptor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiUFSVolumeDescriptor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiUFSVolumeDescriptor:

Public Member Functions

CAdUiUFSVolumeDescriptor (const CString &)
BOOL | ValidateFilename (const CString *, const BOOL wildcard_ok=false) const
BOOL | ValidateSegment (const CString *, const BOOL wildcard_ok=false) const
- Public Member Functions inherited from CAdUiVolumeDescriptor
virtual BOOL | AllowsCaseSensitiveLookup (void) const
CAdUiVolumeDescriptor (const CString &)
virtual BOOL | CheckReadOnly () const
virtual const CString * | GetLocalName () const
virtual LONG | GetVolFreeSpace () const
virtual BOOL | IsCaseSensitive (void) const
BOOL | IsRemote () const
BOOL | IsRemovable () const
virtual BOOL | PreservesCase (void) const
virtual void | VolCase (CString &) const
virtual BOOL | VolMatch (const ACHAR *a, const CString *b) const
virtual BOOL | VolMatch (const CString *a, const CString *b) const
virtual BOOL | VolumeValid () const
virtual BOOL | WillFit (DWORD) const

Additional Inherited Members

- Protected Types inherited from CAdUiVolumeDescriptor
typedef unsigned | flagbits
- Protected Member Functions inherited from CAdUiVolumeDescriptor
int | Find (const CString &str, UINT ch) const
void | GetConnectionName (void)
int | IsControl (int c) const
- Protected Attributes inherited from CAdUiVolumeDescriptor
BOOL | m_amodeMultiByte
CString * | m_connection_name
flagbits | m_d_caseSensitive: 1
flagbits | m_d_cdrom: 1
flagbits | m_d_fixed: 1
flagbits | m_d_ramdisk: 1
flagbits | m_d_readonly: 1
flagbits | m_d_remote: 1
flagbits | m_d_removable: 1
const ACHAR * | m_doubleslash
DWORD | m_fsflags
int | m_max_component_size
int | m_max_path_length
FS_TYPE | m_vol_fs_type
CString * | m_vol_label
CString * | m_vol_localname
DWORD | m_vol_serial
ACHAR | m_vol_slash
The documentation for this class was generated from the following file:
  • aduiVolumeDescriptor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiUFSVolumeDescriptor Member List

This is the complete list of members for CAdUiUFSVolumeDescriptor, including all inherited members.

AllowsCaseSensitiveLookup(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
CAdUiUFSVolumeDescriptor(const CString &) (defined in CAdUiUFSVolumeDescriptor) | CAdUiUFSVolumeDescriptor |
CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CAdUiVolumeDescriptor(const CString &) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CheckReadOnly() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
Find(const CString &str, UINT ch) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
flagbits typedef (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetConnectionName(void) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetLocalName() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
GetVolFreeSpace() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsCaseSensitive(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsControl(int c) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
IsRemote() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
IsRemovable() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
m_amodeMultiByte (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_connection_name (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_caseSensitive (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_cdrom (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_fixed (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_ramdisk (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_readonly (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_remote (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_removable (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_doubleslash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_fsflags (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_component_size (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_path_length (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_fs_type (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_label (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_localname (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_serial (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_slash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
PreservesCase(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
ValidateFilename(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiUFSVolumeDescriptor) | CAdUiUFSVolumeDescriptor | virtual
ValidateSegment(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiUFSVolumeDescriptor) | CAdUiUFSVolumeDescriptor | virtual
VolCase(CString &) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolMatch(const ACHAR *a, const CString *b) const | CAdUiVolumeDescriptor | virtual
VolMatch(const CString *a, const CString *b) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolumeValid() const | CAdUiVolumeDescriptor | virtual
WillFit(DWORD) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
~CAdUiUFSVolumeDescriptor() (defined in CAdUiUFSVolumeDescriptor) | CAdUiUFSVolumeDescriptor | inline
~CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual


ZRX API Reference: CAdUiVFATVolumeDescriptor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAdUiVFATVolumeDescriptor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiVFATVolumeDescriptor:

Public Member Functions

CAdUiVFATVolumeDescriptor (const CString &)
BOOL | ValidateFilename (const CString *, const BOOL wildcard_ok=false) const
BOOL | ValidateSegment (const CString *, const BOOL wildcard_ok=false) const
- Public Member Functions inherited from CAdUiVolumeDescriptor
virtual BOOL | AllowsCaseSensitiveLookup (void) const
CAdUiVolumeDescriptor (const CString &)
virtual BOOL | CheckReadOnly () const
virtual const CString * | GetLocalName () const
virtual LONG | GetVolFreeSpace () const
virtual BOOL | IsCaseSensitive (void) const
BOOL | IsRemote () const
BOOL | IsRemovable () const
virtual BOOL | PreservesCase (void) const
virtual void | VolCase (CString &) const
virtual BOOL | VolMatch (const ACHAR *a, const CString *b) const
virtual BOOL | VolMatch (const CString *a, const CString *b) const
virtual BOOL | VolumeValid () const
virtual BOOL | WillFit (DWORD) const

Additional Inherited Members

- Protected Types inherited from CAdUiVolumeDescriptor
typedef unsigned | flagbits
- Protected Member Functions inherited from CAdUiVolumeDescriptor
int | Find (const CString &str, UINT ch) const
void | GetConnectionName (void)
int | IsControl (int c) const
- Protected Attributes inherited from CAdUiVolumeDescriptor
BOOL | m_amodeMultiByte
CString * | m_connection_name
flagbits | m_d_caseSensitive: 1
flagbits | m_d_cdrom: 1
flagbits | m_d_fixed: 1
flagbits | m_d_ramdisk: 1
flagbits | m_d_readonly: 1
flagbits | m_d_remote: 1
flagbits | m_d_removable: 1
const ACHAR * | m_doubleslash
DWORD | m_fsflags
int | m_max_component_size
int | m_max_path_length
FS_TYPE | m_vol_fs_type
CString * | m_vol_label
CString * | m_vol_localname
DWORD | m_vol_serial
ACHAR | m_vol_slash
The documentation for this class was generated from the following file:
  • aduiVolumeDescriptor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiVFATVolumeDescriptor Member List

This is the complete list of members for CAdUiVFATVolumeDescriptor, including all inherited members.

AllowsCaseSensitiveLookup(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
CAdUiVFATVolumeDescriptor(const CString &) (defined in CAdUiVFATVolumeDescriptor) | CAdUiVFATVolumeDescriptor |
CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CAdUiVolumeDescriptor(const CString &) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CheckReadOnly() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
Find(const CString &str, UINT ch) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
flagbits typedef (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetConnectionName(void) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetLocalName() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
GetVolFreeSpace() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsCaseSensitive(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsControl(int c) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
IsRemote() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
IsRemovable() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
m_amodeMultiByte (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_connection_name (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_caseSensitive (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_cdrom (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_fixed (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_ramdisk (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_readonly (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_remote (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_removable (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_doubleslash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_fsflags (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_component_size (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_path_length (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_fs_type (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_label (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_localname (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_serial (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_slash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
PreservesCase(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
ValidateFilename(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiVFATVolumeDescriptor) | CAdUiVFATVolumeDescriptor | virtual
ValidateSegment(const CString *, const BOOL wildcard_ok=false) const (defined in CAdUiVFATVolumeDescriptor) | CAdUiVFATVolumeDescriptor | virtual
VolCase(CString &) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolMatch(const ACHAR *a, const CString *b) const | CAdUiVolumeDescriptor | virtual
VolMatch(const CString *a, const CString *b) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolumeValid() const | CAdUiVolumeDescriptor | virtual
WillFit(DWORD) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
~CAdUiVFATVolumeDescriptor() (defined in CAdUiVFATVolumeDescriptor) | CAdUiVFATVolumeDescriptor | inline
~CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual


ZRX API Reference: CAdUiVolumeDescriptor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | Friends | List of all members
CAdUiVolumeDescriptor Class Reference
MFC Classes
+ Inheritance diagram for CAdUiVolumeDescriptor:

Public Member Functions

virtual BOOL | AllowsCaseSensitiveLookup (void) const
CAdUiVolumeDescriptor (const CString &)
virtual BOOL | CheckReadOnly () const
virtual const CString * | GetLocalName () const
virtual LONG | GetVolFreeSpace () const
virtual BOOL | IsCaseSensitive (void) const
BOOL | IsRemote () const
BOOL | IsRemovable () const
virtual BOOL | PreservesCase (void) const
virtual BOOL | ValidateFilename (const CString *, const BOOL wildcard_ok=false) const =0
virtual BOOL | ValidateSegment (const CString *, const BOOL wildcard_ok=false) const =0
virtual void | VolCase (CString &) const
virtual BOOL | VolMatch (const ACHAR *a, const CString *b) const
virtual BOOL | VolMatch (const CString *a, const CString *b) const
virtual BOOL | VolumeValid () const
virtual BOOL | WillFit (DWORD) const

Protected Types

typedef unsigned flagbits

Protected Member Functions

int | Find (const CString &str, UINT ch) const
void | GetConnectionName (void)
int | IsControl (int c) const

Protected Attributes

BOOL | m_amodeMultiByte
CString * | m_connection_name
flagbits | m_d_caseSensitive: 1
flagbits | m_d_cdrom: 1
flagbits | m_d_fixed: 1
flagbits | m_d_ramdisk: 1
flagbits | m_d_readonly: 1
flagbits | m_d_remote: 1
flagbits | m_d_removable: 1
const ACHAR * | m_doubleslash
DWORD | m_fsflags
int | m_max_component_size
int | m_max_path_length
FS_TYPE | m_vol_fs_type
CString * | m_vol_label
CString * | m_vol_localname
DWORD | m_vol_serial
ACHAR | m_vol_slash

Friends

class CAdUiPathname

Member Function Documentation

virtual BOOL CAdUiVolumeDescriptor::VolMatch | ( | const ACHAR * | a,
 |  | const CString * | b
 | ) |  | const
 virtual
Warning
Not implemented!
virtual BOOL CAdUiVolumeDescriptor::VolumeValid ( ) const
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aduiVolumeDescriptor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAdUiVolumeDescriptor Member List

This is the complete list of members for CAdUiVolumeDescriptor, including all inherited members.

AllowsCaseSensitiveLookup(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
CAdUiPathname (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | friend
CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CAdUiVolumeDescriptor(const CString &) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor |
CheckReadOnly() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
Find(const CString &str, UINT ch) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
flagbits typedef (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetConnectionName(void) (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
GetLocalName() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inlinevirtual
GetVolFreeSpace() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsCaseSensitive(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
IsControl(int c) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
IsRemote() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
IsRemovable() const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | inline
m_amodeMultiByte (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_connection_name (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_caseSensitive (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_cdrom (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_fixed (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_ramdisk (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_readonly (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_remote (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_d_removable (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_doubleslash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_fsflags (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_component_size (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_max_path_length (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_fs_type (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_label (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_localname (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_serial (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
m_vol_slash (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | protected
PreservesCase(void) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
ValidateFilename(const CString *, const BOOL wildcard_ok=false) const =0 (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | pure virtual
ValidateSegment(const CString *, const BOOL wildcard_ok=false) const =0 (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | pure virtual
VolCase(CString &) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolMatch(const ACHAR *a, const CString *b) const | CAdUiVolumeDescriptor | virtual
VolMatch(const CString *a, const CString *b) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
VolumeValid() const | CAdUiVolumeDescriptor | virtual
WillFit(DWORD) const (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual
~CAdUiVolumeDescriptor() (defined in CAdUiVolumeDescriptor) | CAdUiVolumeDescriptor | virtual


ZRX API Reference: CNavArray< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CNavArray< T > Class Template Reference
MFC Classes
+ Inheritance diagram for CNavArray< T >:

Public Member Functions

T * | AddData ()
CNavArray ()
int | GetCount ()
T * | GetData (INT_PTR index)
BOOL | IsIndexValid (INT_PTR index)
void | RemoveAllData ()
void | RemoveData (INT_PTR index)
virtual | ~CNavArray ()

Protected Member Functions

virtual T * NewData ()
The documentation for this class was generated from the following file:
  • ANavArray.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CNavArray< T > Member List

This is the complete list of members for CNavArray< T >, including all inherited members.

AddData() | CNavArray< T > |
CNavArray() | CNavArray< T > |
GetCount() | CNavArray< T > |
GetData(INT_PTR index) | CNavArray< T > |
IsIndexValid(INT_PTR index) | CNavArray< T > |
NewData() | CNavArray< T > | protectedvirtual
RemoveAllData() | CNavArray< T > |
RemoveData(INT_PTR index) (defined in CNavArray< T >) | CNavArray< T > |
~CNavArray() | CNavArray< T > | virtual


ZRX API Reference: CNavData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
CNavData Class Reference
MFC Classes

Public Member Functions

CNavData ()
NAV_DATA_TYPE | GetDataType ()
LPCTSTR | GetExtensionName ()
LPITEMIDLIST | GetID ()
LPCTSTR | GetPassword ()
CNavPathname * | GetPathname ()
LPCTSTR | GetText ()
LPCTSTR | GetTextInFolder ()
BOOL | GetURL (CString &strURL)
void * | GetUserData ()
LPCTSTR | GetUserName ()
BOOL | IsExtension ()
BOOL | IsRemote ()
void | SetDataType (NAV_DATA_TYPE dataType)
void | SetExtensionName (LPCTSTR name)
void | SetID (LPITEMIDLIST id)
void | SetPassword (LPCTSTR password)
void | SetPathname (CNavPathname *pathname)
void | SetText (LPCTSTR text)
void | SetTextInFolder (LPCTSTR text)
void * | SetUserData (void *data)
void | SetUserName (LPCTSTR name)
virtual | ~CNavData ()

Protected Attributes

NAV_DATA_TYPE | m_dataType
CString | m_extensionName
LPITEMIDLIST | m_id
CString | m_password
CNavPathname * | m_pathname
CString | m_text
CString | m_textInFolder
void * | m_userData
CString | m_userName

Constructor & Destructor Documentation

CNavData::CNavData ( )
Warning
Not implemented!
virtual CNavData::~CNavData ( )
virtual
Warning
Not implemented!

Member Function Documentation

NAV_DATA_TYPE CNavData::GetDataType ( )
Warning
Not implemented!
LPCTSTR CNavData::GetExtensionName ( )
Warning
Not implemented!
LPITEMIDLIST CNavData::GetID ( )
Warning
Not implemented!
LPCTSTR CNavData::GetPassword ( )
Warning
Not implemented!
CNavPathname* CNavData::GetPathname ( )
Warning
Not implemented!
LPCTSTR CNavData::GetText ( )
Warning
Not implemented!
LPCTSTR CNavData::GetTextInFolder ( )
Warning
Not implemented!
BOOL CNavData::GetURL ( CString & strURL )
Warning
Not implemented!
void* CNavData::GetUserData ( )
Warning
Not implemented!
LPCTSTR CNavData::GetUserName ( )
Warning
Not implemented!
BOOL CNavData::IsExtension ( )
Warning
Not implemented!
BOOL CNavData::IsRemote ( )
Warning
Not implemented!
void CNavData::SetDataType ( NAV_DATA_TYPE dataType )
Warning
Not implemented!
void CNavData::SetExtensionName ( LPCTSTR name )
Warning
Not implemented!
void CNavData::SetID ( LPITEMIDLIST id )
Warning
Not implemented!
void CNavData::SetPassword ( LPCTSTR password )
Warning
Not implemented!
void CNavData::SetPathname ( CNavPathname * pathname )
Warning
Not implemented!
void CNavData::SetText ( LPCTSTR text )
Warning
Not implemented!
void CNavData::SetTextInFolder ( LPCTSTR text )
Warning
Not implemented!
void* CNavData::SetUserData ( void * data )
Warning
Not implemented!
void CNavData::SetUserName ( LPCTSTR name )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • anavdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CNavData Member List

This is the complete list of members for CNavData, including all inherited members.

CNavData() | CNavData |
GetDataType() | CNavData |
GetExtensionName() | CNavData |
GetID() | CNavData |
GetPassword() | CNavData |
GetPathname() | CNavData |
GetText() | CNavData |
GetTextInFolder() | CNavData |
GetURL(CString &strURL) | CNavData |
GetUserData() | CNavData |
GetUserName() | CNavData |
IsExtension() | CNavData |
IsRemote() | CNavData |
m_dataType (defined in CNavData) | CNavData | protected
m_extensionName (defined in CNavData) | CNavData | protected
m_id (defined in CNavData) | CNavData | protected
m_password (defined in CNavData) | CNavData | protected
m_pathname (defined in CNavData) | CNavData | protected
m_text (defined in CNavData) | CNavData | protected
m_textInFolder (defined in CNavData) | CNavData | protected
m_userData (defined in CNavData) | CNavData | protected
m_userName (defined in CNavData) | CNavData | protected
SetDataType(NAV_DATA_TYPE dataType) | CNavData |
SetExtensionName(LPCTSTR name) | CNavData |
SetID(LPITEMIDLIST id) | CNavData |
SetPassword(LPCTSTR password) | CNavData |
SetPathname(CNavPathname *pathname) | CNavData |
SetText(LPCTSTR text) | CNavData |
SetTextInFolder(LPCTSTR text) | CNavData |
SetUserData(void *data) | CNavData |
SetUserName(LPCTSTR name) | CNavData |
~CNavData() | CNavData | virtual


ZRX API Reference: CNavDataArray Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CNavDataArray Class Reference
MFC Classes
+ Inheritance diagram for CNavDataArray:

Public Member Functions

CNavDataArray ()
virtual | ~CNavDataArray ()
- Public Member Functions inherited from CNavArray< CNavData >
CNavData * AddData ()
CNavArray ()
int | GetCount ()
CNavData * | GetData (INT_PTR index)
BOOL | IsIndexValid (INT_PTR index)
void | RemoveAllData ()
void | RemoveData (INT_PTR index)
virtual | ~CNavArray ()

Additional Inherited Members

- Protected Member Functions inherited from CNavArray< CNavData >
virtual CNavData * NewData ()

Constructor & Destructor Documentation

CNavDataArray::CNavDataArray ( )
Warning
Not implemented!
virtual CNavDataArray::~CNavDataArray ( )
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • anavdataarray.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CNavDataArray Member List

This is the complete list of members for CNavDataArray, including all inherited members.

AddData() | CNavArray< CNavData > |
CNavArray() | CNavArray< CNavData > |
CNavDataArray() | CNavDataArray |
GetCount() | CNavArray< CNavData > |
GetData(INT_PTR index) | CNavArray< CNavData > |
IsIndexValid(INT_PTR index) | CNavArray< CNavData > |
NewData() | CNavArray< CNavData > | protectedvirtual
RemoveAllData() | CNavArray< CNavData > |
RemoveData(INT_PTR index) (defined in CNavArray< CNavData >) | CNavArray< CNavData > |
~CNavArray() | CNavArray< CNavData > | virtual
~CNavDataArray() | CNavDataArray | virtual


ZRX API Reference: CNavDialog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Friends | List of all members
CNavDialog Class Reference
MFC Classes
+ Inheritance diagram for CNavDialog:

Public Types

enum | { IDD = 0 }
- Public Types inherited from CAdUiDialog
enum | { IDD = 0 }
- Public Types inherited from CAdUiBaseDialog
enum | { IDD = 0 }

Public Member Functions

void | AddDataToHistory ()
virtual BOOL | BeginDownloadFiles (CStringArray &strURLs, CDWordArray &dwActionCodes)
void | BrowseCurrentObject ()
CNavDialog (CNavDataArray &dataArray, CNavFilterArray &filterArray, UINT idd=0, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | GetAcceptAnyFileExtension ()
virtual BOOL | GetAllDialogsData (const CString &cValueName, CString &cValue)
virtual BOOL | GetAllDialogsData (const CString &cValueName, DWORD &data)
BOOL | GetConfirmReplace ()
BOOL | GetCreatingFile ()
CNavFilter * | GetCurrentFileExtension (CString &strExt)
void | GetCurrentFolderForPersistence (CString &strFolder)
CNavDataArray & GetDataArray ()
LPCTSTR | GetDefaultFileExtension ()
int | GetDefaultFilterIndex ()
LPCTSTR | GetDefaultInitialFolder ()
LPCTSTR | GetDialogCaption ()
virtual DWORD | GetDownloadActionCodes (CString &strURL)
CNavFilterArray & GetFilterArray ()
int | GetFilterIndex ()
CNavListCtrl * GetFolderListCtrl ()
BOOL | GetFoldersOnly ()
int | GetForceFilterIndex ()
LPCTSTR | GetForceInitialFolder ()
UINT | GetIDD ()
void * | GetImpObject () const
LPCTSTR | GetInitialFileName ()
DWORD | GetInitialFilterIndex ()
BOOL | GetMultiSelectAllowed ()
BOOL | GetNoExtraExtensions ()
BOOL | GetNoExtraExtensionsInPlaces ()
BOOL | GetNoFTP ()
BOOL | GetNoPlacesList ()
BOOL | GetNoURLFileTransfer ()
BOOL | GetNoURLsAllowed ()
void | GetOkButtonText (CString &strOk, BOOL bIncludeAccel=TRUE)
BOOL | GetPersonalFolderPath (CString &strPersonal)
virtual BOOL | GetProductName (CString &strProduct)
BOOL | GetReadOnlyAllowed ()
BOOL | GetReadOnlyHidden ()
BOOL | GetReadOnlySpecified ()
void | GetSingleDataFullPath (CString &strFullPath)
int | GetToolsMenuItemPosition (NavToolsMenuItem itemFlag)
UINT | GetToolsMenuItemsPresent ()
BOOL | GetUseRegExtensionFlags ()
UINT | GetViewMode ()
int | InsertUserItemInPlaces (int index, LPCTSTR sFullPath, LPCTSTR sText)
virtual void | LocateFile ()
BOOL | NavigateToFolder (LPCTSTR sFolder)
virtual void | OnDialogHelp ()
virtual void | OnDialogHelp (LPCTSTR pHelpTag)
void | SetAcceptAnyFileExtension (BOOL any)
virtual BOOL | SetAllDialogsData (const CString &cValueName, CString &cValue)
virtual BOOL | SetAllDialogsData (const CString &cValueName, DWORD dwValue)
void | SetConfirmReplace (BOOL confirm)
void | SetCreatingFile (BOOL create)
void | SetDefaultFileExtension (LPCTSTR ext)
void | SetDefaultFilterIndex (int index)
void | SetDefaultInitialFolder (LPCTSTR folder)
void | SetDialogCaption (LPCTSTR caption)
void | SetFilterIndex (int index)
void | SetFolderComboCurSel (int i)
void | SetFolderListCtrl (CNavListCtrl *folderListCtrl)
void | SetFoldersOnly (BOOL foldersOnly)
void | SetForceFilterIndex (int index)
void | SetForceInitialFolder (LPCTSTR folder)
void | SetInitialFileName (LPCTSTR name)
void | SetMultiSelectAllowed (BOOL allow)
void | SetNoExtraExtensions (BOOL noExtraExtensions)
void | SetNoExtraExtensionsInPlaces (BOOL noExtraExtensions)
void | SetNoFTP (BOOL noFTP)
void | SetNoURLFileTransfer (BOOL noTransfer)
void | SetNoURLsAllowed (BOOL noURLs)
void | SetOkButtonMenuExists (BOOL bExists)
void | SetOkButtonText (LPCTSTR text)
void | SetReadOnlyAllowed (BOOL allow)
void | SetReadOnlyHidden (BOOL hidden)
void | SetReadOnlySpecified (BOOL readOnly)
void | SetToolsMenuItemsPresent (UINT flag)
void | SetUseRegExtensionFlags (BOOL bUse)
void | SetViewMode (UINT viewMode)
void | TrimWhiteSpace (CString &strName, BOOL bAll)
virtual | ~CNavDialog ()
- Public Member Functions inherited from CAdUiDialog
BOOL | AddControl (CWnd *pControl)
BOOL | AutoLoadControl (CWnd *pControl)
CAdUiDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
virtual BOOL | DoDialogHelp ()
BOOL | ForceControlRepaint (CWnd *pControl, BOOL bForce)
BOOL | ForceControlResize (CWnd *pControl, LPRECT prect)
BOOL | GetColumnSizes (CListCtrl *pList)
CSize * | GetCurrentDelta ()
BOOL | GetDialogData (LPCTSTR valueName, CString &data)
BOOL | GetDialogData (LPCTSTR valueName, DWORD &data)
void | GetDialogHelpTag (CString &tag)
BOOL | GetDialogKey (CString &key)
BOOL | GetDialogName (CString &name)
void | GetElasticMinMaxInfo (MINMAXINFO &mmi)
LPVOID | GetElasticPointer ()
BOOL | GetPixelData (CRect &r)
void | LockDialogHeight ()
void | LockDialogWidth ()
BOOL | MoveControlX (UINT id, LONG lMovePct)
BOOL | MoveControlXY (UINT id, LONG lMoveXPct, LONG lMoveYPct)
BOOL | MoveControlY (UINT id, LONG lMovePct)
BOOL | ReloadControl (CWnd *pControl, LPCTSTR lpResString)
BOOL | RemoveControl (CWnd *pControl)
BOOL | SaveColumnSizes (CListCtrl *pList)
BOOL | SetControlProperty (PDLGCTLINFO lp, DWORD numElements)
BOOL | SetDialogData (LPCTSTR valueName, LPCTSTR data)
BOOL | SetDialogData (LPCTSTR valueName, DWORD data)
void | SetDialogHelpTag (LPCTSTR tag)
void | SetDialogMaxExtents (int width, int height)
void | SetDialogMinExtents (int width, int height)
void | SetDialogName (LPCTSTR name)
void | SetElasticSize (CSize &size, BOOL bRefreshDialog)
void | SetPersistency (BOOL bFlag)
void | SetRootKey (LPCTSTR key)
void | SetTabSize (LPARAM lParam, BOOL bRefreshDialog)
BOOL | StorePixelData ()
BOOL | StretchControlX (UINT id, LONG lStretchPct)
BOOL | StretchControlXY (UINT id, LONG lStretchXPct, LONG lStretchYPct)
BOOL | StretchControlY (UINT id, LONG lStretchPct)
- Public Member Functions inherited from CAdUiBaseDialog
virtual CWnd * | AppMainWindow ()
virtual HINSTANCE | AppResourceInstance ()
virtual LPCTSTR | AppRootKey ()
CAdUiBaseDialog (UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL)
BOOL | Create (LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL)
BOOL | Create (UINT nIDTemplate, CWnd *pParentWnd=NULL)
BOOL | DisplayData ()
virtual INT_PTR | DoModal ()
BOOL | EditorCommandCancelled ()
virtual void | EnableFloatingWindows (BOOL allow)
virtual int | EnableMultiDocumentActivation (BOOL bEnable)
virtual BOOL | ExchangeData (BOOL bSaveAndValidate)
LPCTSTR | GetContextHelpFileName ()
LPCTSTR | GetContextHelpFullPathName ()
LPCTSTR | GetContextHelpPrefix ()
HICON | GetDialogIcon ()
CToolTipCtrl * | GetToolTipCtrl ()
BOOL | GetUseTips ()
virtual int | IsMultiDocumentActivationEnabled ()
void | SetAppRootKey (LPCTSTR key)
void | SetContextHelpFileName (LPCTSTR pFileName)
void | SetContextHelpFullPathName (LPCTSTR pFullPathName)
void | SetContextHelpPrefix (LPCTSTR pPrefix)
void | SetDialogIcon (HICON hIcon)
void | SetUseTips (BOOL useTips)
BOOL | ValidateData ()

Protected Member Functions

virtual OkHandlerErr | CombineDataTextWithFolderName (CNavData *data, CString &strResult)
virtual void | DisplaySearchError (LPCTSTR sBase)
virtual void | DoDataExchange (CDataExchange *pDX)
virtual BOOL | FindInSearchPath (LPCTSTR sBase, CString *pFullPath)
virtual void | GetDefaultBrowserStartURL (CString &strStartPage)
virtual BOOL | GetRecentDirectory (CString &strRecent)
virtual BOOL | LaunchBrowserDialog (CString &strSelectedURL, LPCTSTR strDialogCaption, LPCTSTR strOk, LPCTSTR strStartPage)
virtual void | OnCancel ()
virtual BOOL | OnCmdMsg (UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo)
afx_msg void | OnContextMenu (CWnd *, CPoint)
afx_msg void | OnDestroy ()
virtual void | OnDoFind ()
virtual void | OnDoLocate ()
virtual void | OnFileNameChange ()
virtual BOOL | OnFileNameOK ()
virtual void | OnFileNameSelectionChange ()
virtual void | OnFilterChange ()
virtual void | OnFolderChange ()
virtual void | OnFolderItemChange ()
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)
virtual BOOL | OnInitDialog ()
afx_msg void | OnKickIdle ()
virtual ADUI_REPLY | OnNotifyControlChange (UINT controlId, LPARAM lParam)
virtual ADUI_REPLY | OnNotifyGeneric (UINT controlId, LPARAM lParam)
virtual void | OnOK ()
afx_msg void | OnSysColorChange ()
virtual void | OnURLDownloadSuccess (CString &strURL)
virtual BOOL | OnUrlOK ()
virtual void | PrepareOkMenu (CMenu *pMenu)
virtual void | PrepareToolsMenu (CMenu *pMenu)
virtual void | PrepareViewsMenu (CMenu *pMenu)
virtual OkHandlerErr | PreprocessData (CNavDataArray &array)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
virtual void | Refresh ()
virtual BOOL | ReportURLTransferStatus (CDWordArray &dwErrorArray, CStringArray &strURLs, CStringArray &strLocals)
virtual BOOL | UpdateFileExtension (CString &strName, BOOL bCanUseCurrentExtension)
virtual void | UpdateUIState ()
virtual BOOL | VerifyURLSave ()
- Protected Member Functions inherited from CAdUiDialog
afx_msg void | OnGetMinMaxInfo (MINMAXINFO FAR *lpMMI)
virtual void | OnInitDialogBegin ()
virtual void | OnInitDialogFinish ()
afx_msg void | OnSize (UINT nType, int cx, int cy)
- Protected Member Functions inherited from CAdUiBaseDialog
void | BeginEditorCommand ()
void | CancelEditorCommand ()
void | CompleteEditorCommand (BOOL restoreDialogs=TRUE)
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
virtual BOOL | FindContextHelpFullPath (LPCTSTR fileName, CString &fullPath)
void | MakeDialogsVisible (BOOL visible)
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
afx_msg void | OnAdUiTimer (UINT_PTR nIDEvent)
afx_msg HBRUSH | OnCtlColor (CDC *pDC, CWnd *pWnd, UINT nCtlColor)
afx_msg BOOL | OnNotify_ToolTipText (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
virtual ADUI_REPLY | OnNotifyControlValid (UINT controlId, BOOL isValid)
virtual ADUI_REPLY | OnNotifyUpdateTip (CWnd *control)
virtual void | PostNcDestroy ()
virtual BOOL | PreCreateWindow (CREATESTRUCT &cs)

Friends

class CNavDialogImp

Additional Inherited Members

- Protected Attributes inherited from CAdUiDialog
BOOL | m_bEnableElasticMessageMap
UINT | m_templateid
- Static Protected Attributes inherited from CAdUiBaseDialog
static CAdUiAssist * | m_pUIAssist

Constructor & Destructor Documentation

CNavDialog::CNavDialog | ( | CNavDataArray & | dataArray,
 |  | CNavFilterArray & | filterArray,
 |  | UINT | idd = 0,
 |  | CWnd * | pParent = NULL,
 |  | HINSTANCE | hDialogResource = NULL
 | ) |  |
Warning
Not implemented!
virtual CNavDialog::~CNavDialog ( )
virtual
Warning
Not implemented!

Member Function Documentation

void CNavDialog::AddDataToHistory ( )
Warning
Not implemented!
virtual BOOL CNavDialog::BeginDownloadFiles | ( | CStringArray & | strURLs,
 |  | CDWordArray & | dwActionCodes
 | ) |  |
virtual
Warning
Not implemented!
void CNavDialog::BrowseCurrentObject ( )
Warning
Not implemented!
virtual OkHandlerErr CNavDialog::CombineDataTextWithFolderName | ( | CNavData * | data,
 |  | CString & | strResult
 | ) |  |
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::DisplaySearchError ( LPCTSTR sBase )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::DoDataExchange ( CDataExchange * pDX )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiDialog.

virtual BOOL CNavDialog::FindInSearchPath | ( | LPCTSTR | sBase,
 |  | CString * | pFullPath
 | ) |  |
protectedvirtual
Warning
Not implemented!
BOOL CNavDialog::GetAcceptAnyFileExtension ( )
Warning
Not implemented!
virtual BOOL CNavDialog::GetAllDialogsData | ( | const CString & | cValueName,
 |  | CString & | cValue
 | ) |  |
virtual
Warning
Not implemented!
virtual BOOL CNavDialog::GetAllDialogsData | ( | const CString & | cValueName,
 |  | DWORD & | data
 | ) |  |
virtual
Warning
Not implemented!
BOOL CNavDialog::GetConfirmReplace ( )
Warning
Not implemented!
BOOL CNavDialog::GetCreatingFile ( )
Warning
Not implemented!
CNavFilter* CNavDialog::GetCurrentFileExtension ( CString & strExt )
Warning
Not implemented!
void CNavDialog::GetCurrentFolderForPersistence ( CString & strFolder )
Warning
Not implemented!
CNavDataArray& CNavDialog::GetDataArray ( )
Warning
Not implemented!
virtual void CNavDialog::GetDefaultBrowserStartURL ( CString & strStartPage )
protectedvirtual
Warning
Not implemented!
LPCTSTR CNavDialog::GetDefaultFileExtension ( )
Warning
Not implemented!
int CNavDialog::GetDefaultFilterIndex ( )
Warning
Not implemented!
LPCTSTR CNavDialog::GetDefaultInitialFolder ( )
Warning
Not implemented!
LPCTSTR CNavDialog::GetDialogCaption ( )
Warning
Not implemented!
virtual DWORD CNavDialog::GetDownloadActionCodes ( CString & strURL )
virtual
Warning
Not implemented!
CNavFilterArray& CNavDialog::GetFilterArray ( )
Warning
Not implemented!
int CNavDialog::GetFilterIndex ( )
Warning
Not implemented!
CNavListCtrl* CNavDialog::GetFolderListCtrl ( )
Warning
Not implemented!
BOOL CNavDialog::GetFoldersOnly ( )
Warning
Not implemented!
int CNavDialog::GetForceFilterIndex ( )
Warning
Not implemented!
LPCTSTR CNavDialog::GetForceInitialFolder ( )
Warning
Not implemented!
UINT CNavDialog::GetIDD ( )
Warning
Not implemented!
void* CNavDialog::GetImpObject ( ) const
Warning
Not implemented!
LPCTSTR CNavDialog::GetInitialFileName ( )
Warning
Not implemented!
DWORD CNavDialog::GetInitialFilterIndex ( )
Warning
Not implemented!
BOOL CNavDialog::GetMultiSelectAllowed ( )
Warning
Not implemented!
BOOL CNavDialog::GetNoExtraExtensions ( )
Warning
Not implemented!
BOOL CNavDialog::GetNoExtraExtensionsInPlaces ( )
Warning
Not implemented!
BOOL CNavDialog::GetNoFTP ( )
Warning
Not implemented!
BOOL CNavDialog::GetNoPlacesList ( )
Warning
Not implemented!
BOOL CNavDialog::GetNoURLFileTransfer ( )
Warning
Not implemented!
BOOL CNavDialog::GetNoURLsAllowed ( )
Warning
Not implemented!
void CNavDialog::GetOkButtonText | ( | CString & | strOk,
 |  | BOOL | bIncludeAccel = TRUE
 | ) |  |
Warning
Not implemented!
BOOL CNavDialog::GetPersonalFolderPath ( CString & strPersonal )
Warning
Not implemented!
virtual BOOL CNavDialog::GetProductName ( CString & strProduct )
virtual
Warning
Not implemented!
BOOL CNavDialog::GetReadOnlyAllowed ( )
Warning
Not implemented!
BOOL CNavDialog::GetReadOnlyHidden ( )
Warning
Not implemented!
BOOL CNavDialog::GetReadOnlySpecified ( )
Warning
Not implemented!
virtual BOOL CNavDialog::GetRecentDirectory ( CString & strRecent )
protectedvirtual
Warning
Not implemented!
void CNavDialog::GetSingleDataFullPath ( CString & strFullPath )
Warning
Not implemented!
int CNavDialog::GetToolsMenuItemPosition ( NavToolsMenuItem itemFlag )
Warning
Not implemented!
UINT CNavDialog::GetToolsMenuItemsPresent ( )
Warning
Not implemented!
BOOL CNavDialog::GetUseRegExtensionFlags ( )
Warning
Not implemented!
UINT CNavDialog::GetViewMode ( )
Warning
Not implemented!
int CNavDialog::InsertUserItemInPlaces | ( | int | index,
 |  | LPCTSTR | sFullPath,
 |  | LPCTSTR | sText
 | ) |  |
Warning
Not implemented!
virtual BOOL CNavDialog::LaunchBrowserDialog | ( | CString & | strSelectedURL,
 |  | LPCTSTR | strDialogCaption,
 |  | LPCTSTR | strOk,
 |  | LPCTSTR | strStartPage
 | ) |  |
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::LocateFile ( )
virtual
Warning
Not implemented!
BOOL CNavDialog::NavigateToFolder ( LPCTSTR sFolder )
Warning
Not implemented!
virtual void CNavDialog::OnCancel ( )
protectedvirtual
Warning
Not implemented!
virtual BOOL CNavDialog::OnCmdMsg | ( | UINT | nID,
 |  | int | nCode,
 |  | void * | pExtra,
 |  | AFX_CMDHANDLERINFO * | pHandlerInfo
 | ) |  |
protectedvirtual
Warning
Not implemented!
afx_msg void CNavDialog::OnContextMenu | ( | CWnd * | ,
 |  | CPoint |
 | ) |  |
protected
Warning
Not implemented!
afx_msg void CNavDialog::OnDestroy ( )
protected
Warning
Not implemented!
virtual void CNavDialog::OnDialogHelp ( )
virtual
Warning
Not implemented!

Reimplemented from CAdUiDialog.

virtual void CNavDialog::OnDialogHelp ( LPCTSTR pHelpTag )
virtual
Warning
Not implemented!
virtual void CNavDialog::OnDoFind ( )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::OnDoLocate ( )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::OnFileNameChange ( )
protectedvirtual
Warning
Not implemented!
virtual BOOL CNavDialog::OnFileNameOK ( )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::OnFileNameSelectionChange ( )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::OnFilterChange ( )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::OnFolderChange ( )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::OnFolderItemChange ( )
protectedvirtual
Warning
Not implemented!
afx_msg BOOL CNavDialog::OnHelpInfo ( HELPINFO * pHelpInfo )
protected
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

virtual BOOL CNavDialog::OnInitDialog ( )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

afx_msg void CNavDialog::OnKickIdle ( )
protected
Warning
Not implemented!
virtual ADUI_REPLY CNavDialog::OnNotifyControlChange | ( | UINT | controlId,
 |  | LPARAM | lParam
 | ) |  |
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

virtual ADUI_REPLY CNavDialog::OnNotifyGeneric | ( | UINT | controlId,
 |  | LPARAM | lParam
 | ) |  |
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

virtual void CNavDialog::OnOK ( )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiDialog.

afx_msg void CNavDialog::OnSysColorChange ( )
protected
Warning
Not implemented!
virtual void CNavDialog::OnURLDownloadSuccess ( CString & strURL )
protectedvirtual
Warning
Not implemented!
virtual BOOL CNavDialog::OnUrlOK ( )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::PrepareOkMenu ( CMenu * pMenu )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::PrepareToolsMenu ( CMenu * pMenu )
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::PrepareViewsMenu ( CMenu * pMenu )
protectedvirtual
Warning
Not implemented!
virtual OkHandlerErr CNavDialog::PreprocessData ( CNavDataArray & array )
protectedvirtual
Warning
Not implemented!
virtual BOOL CNavDialog::PreTranslateMessage ( MSG * pMsg )
protectedvirtual
Warning
Not implemented!

Reimplemented from CAdUiBaseDialog.

virtual void CNavDialog::Refresh ( )
protectedvirtual
Warning
Not implemented!
virtual BOOL CNavDialog::ReportURLTransferStatus | ( | CDWordArray & | dwErrorArray,
 |  | CStringArray & | strURLs,
 |  | CStringArray & | strLocals
 | ) |  |
protectedvirtual
Warning
Not implemented!
void CNavDialog::SetAcceptAnyFileExtension ( BOOL any )
Warning
Not implemented!
virtual BOOL CNavDialog::SetAllDialogsData | ( | const CString & | cValueName,
 |  | CString & | cValue
 | ) |  |
virtual
Warning
Not implemented!
virtual BOOL CNavDialog::SetAllDialogsData | ( | const CString & | cValueName,
 |  | DWORD | dwValue
 | ) |  |
virtual
Warning
Not implemented!
void CNavDialog::SetConfirmReplace ( BOOL confirm )
Warning
Not implemented!
void CNavDialog::SetCreatingFile ( BOOL create )
Warning
Not implemented!
void CNavDialog::SetDefaultFileExtension ( LPCTSTR ext )
Warning
Not implemented!
void CNavDialog::SetDefaultFilterIndex ( int index )
Warning
Not implemented!
void CNavDialog::SetDefaultInitialFolder ( LPCTSTR folder )
Warning
Not implemented!
void CNavDialog::SetDialogCaption ( LPCTSTR caption )
Warning
Not implemented!
void CNavDialog::SetFilterIndex ( int index )
Warning
Not implemented!
void CNavDialog::SetFolderComboCurSel ( int i )
Warning
Not implemented!
void CNavDialog::SetFolderListCtrl ( CNavListCtrl * folderListCtrl )
Warning
Not implemented!
void CNavDialog::SetFoldersOnly ( BOOL foldersOnly )
Warning
Not implemented!
void CNavDialog::SetForceFilterIndex ( int index )
Warning
Not implemented!
void CNavDialog::SetForceInitialFolder ( LPCTSTR folder )
Warning
Not implemented!
void CNavDialog::SetInitialFileName ( LPCTSTR name )
Warning
Not implemented!
void CNavDialog::SetMultiSelectAllowed ( BOOL allow )
Warning
Not implemented!
void CNavDialog::SetNoExtraExtensions ( BOOL noExtraExtensions )
Warning
Not implemented!
void CNavDialog::SetNoExtraExtensionsInPlaces ( BOOL noExtraExtensions )
Warning
Not implemented!
void CNavDialog::SetNoFTP ( BOOL noFTP )
Warning
Not implemented!
void CNavDialog::SetNoURLFileTransfer ( BOOL noTransfer )
Warning
Not implemented!
void CNavDialog::SetNoURLsAllowed ( BOOL noURLs )
Warning
Not implemented!
void CNavDialog::SetOkButtonMenuExists ( BOOL bExists )
Warning
Not implemented!
void CNavDialog::SetOkButtonText ( LPCTSTR text )
Warning
Not implemented!
void CNavDialog::SetReadOnlyAllowed ( BOOL allow )
Warning
Not implemented!
void CNavDialog::SetReadOnlyHidden ( BOOL hidden )
Warning
Not implemented!
void CNavDialog::SetReadOnlySpecified ( BOOL readOnly )
Warning
Not implemented!
void CNavDialog::SetToolsMenuItemsPresent ( UINT flag )
Warning
Not implemented!
void CNavDialog::SetUseRegExtensionFlags ( BOOL bUse )
Warning
Not implemented!
void CNavDialog::SetViewMode ( UINT viewMode )
Warning
Not implemented!
void CNavDialog::TrimWhiteSpace | ( | CString & | strName,
 |  | BOOL | bAll
 | ) |  |
Warning
Not implemented!
virtual BOOL CNavDialog::UpdateFileExtension | ( | CString & | strName,
 |  | BOOL | bCanUseCurrentExtension
 | ) |  |
protectedvirtual
Warning
Not implemented!
virtual void CNavDialog::UpdateUIState ( )
protectedvirtual
Warning
Not implemented!
virtual BOOL CNavDialog::VerifyURLSave ( )
protectedvirtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • anavdialog.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CNavDialog Member List

This is the complete list of members for CNavDialog, including all inherited members.

AddControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
AddDataToHistory() | CNavDialog |
AppMainWindow() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppResourceInstance() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AppRootKey() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
AutoLoadControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
BeginDownloadFiles(CStringArray &strURLs, CDWordArray &dwActionCodes) | CNavDialog | virtual
BeginEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
BrowseCurrentObject() | CNavDialog |
CAdUiBaseDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
CAdUiDialog(UINT idd, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) (defined in CAdUiDialog) | CAdUiDialog |
CancelEditorCommand() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
CNavDialog(CNavDataArray &dataArray, CNavFilterArray &filterArray, UINT idd=0, CWnd *pParent=NULL, HINSTANCE hDialogResource=NULL) | CNavDialog |
CNavDialogImp (defined in CNavDialog) | CNavDialog | friend
CombineDataTextWithFolderName(CNavData *data, CString &strResult) | CNavDialog | protectedvirtual
CompleteEditorCommand(BOOL restoreDialogs=TRUE) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
Create(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
Create(UINT nIDTemplate, CWnd *pParentWnd=NULL) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplayData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
DisplaySearchError(LPCTSTR sBase) | CNavDialog | protectedvirtual
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
DoDataExchange(CDataExchange *pDX) | CNavDialog | protectedvirtual
DoDialogHelp() (defined in CAdUiDialog) | CAdUiDialog | virtual
DoModal() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EditorCommandCancelled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
EnableFloatingWindows(BOOL allow) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
EnableMultiDocumentActivation(BOOL bEnable) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
ExchangeData(BOOL bSaveAndValidate) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
FindContextHelpFullPath(LPCTSTR fileName, CString &fullPath) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
FindInSearchPath(LPCTSTR sBase, CString *pFullPath) | CNavDialog | protectedvirtual
ForceControlRepaint(CWnd *pControl, BOOL bForce) (defined in CAdUiDialog) | CAdUiDialog |
ForceControlResize(CWnd *pControl, LPRECT prect) (defined in CAdUiDialog) | CAdUiDialog |
GetAcceptAnyFileExtension() | CNavDialog |
GetAllDialogsData(const CString &cValueName, CString &cValue) | CNavDialog | virtual
GetAllDialogsData(const CString &cValueName, DWORD &data) | CNavDialog | virtual
GetColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
GetConfirmReplace() | CNavDialog |
GetContextHelpFileName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpFullPathName() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetContextHelpPrefix() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetCreatingFile() | CNavDialog |
GetCurrentDelta() (defined in CAdUiDialog) | CAdUiDialog |
GetCurrentFileExtension(CString &strExt) | CNavDialog |
GetCurrentFolderForPersistence(CString &strFolder) | CNavDialog |
GetDataArray() | CNavDialog |
GetDefaultBrowserStartURL(CString &strStartPage) | CNavDialog | protectedvirtual
GetDefaultFileExtension() | CNavDialog |
GetDefaultFilterIndex() | CNavDialog |
GetDefaultInitialFolder() | CNavDialog |
GetDialogCaption() | CNavDialog |
GetDialogData(LPCTSTR valueName, CString &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogData(LPCTSTR valueName, DWORD &data) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogHelpTag(CString &tag) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogIcon() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetDialogKey(CString &key) (defined in CAdUiDialog) | CAdUiDialog |
GetDialogName(CString &name) (defined in CAdUiDialog) | CAdUiDialog |
GetDownloadActionCodes(CString &strURL) | CNavDialog | virtual
GetElasticMinMaxInfo(MINMAXINFO &mmi) (defined in CAdUiDialog) | CAdUiDialog |
GetElasticPointer() (defined in CAdUiDialog) | CAdUiDialog |
GetFilterArray() | CNavDialog |
GetFilterIndex() | CNavDialog |
GetFolderListCtrl() | CNavDialog |
GetFoldersOnly() | CNavDialog |
GetForceFilterIndex() | CNavDialog |
GetForceInitialFolder() | CNavDialog |
GetIDD() | CNavDialog |
GetImpObject() const | CNavDialog |
GetInitialFileName() | CNavDialog |
GetInitialFilterIndex() | CNavDialog |
GetMultiSelectAllowed() | CNavDialog |
GetNoExtraExtensions() | CNavDialog |
GetNoExtraExtensionsInPlaces() | CNavDialog |
GetNoFTP() | CNavDialog |
GetNoPlacesList() | CNavDialog |
GetNoURLFileTransfer() | CNavDialog |
GetNoURLsAllowed() | CNavDialog |
GetOkButtonText(CString &strOk, BOOL bIncludeAccel=TRUE) | CNavDialog |
GetPersonalFolderPath(CString &strPersonal) | CNavDialog |
GetPixelData(CRect &r) (defined in CAdUiDialog) | CAdUiDialog |
GetProductName(CString &strProduct) | CNavDialog | virtual
GetReadOnlyAllowed() | CNavDialog |
GetReadOnlyHidden() | CNavDialog |
GetReadOnlySpecified() | CNavDialog |
GetRecentDirectory(CString &strRecent) | CNavDialog | protectedvirtual
GetSingleDataFullPath(CString &strFullPath) | CNavDialog |
GetToolsMenuItemPosition(NavToolsMenuItem itemFlag) | CNavDialog |
GetToolsMenuItemsPresent() | CNavDialog |
GetToolTipCtrl() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetUseRegExtensionFlags() | CNavDialog |
GetUseTips() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
GetViewMode() | CNavDialog |
IDD enum value (defined in CNavDialog) | CNavDialog |
InsertUserItemInPlaces(int index, LPCTSTR sFullPath, LPCTSTR sText) | CNavDialog |
IsMultiDocumentActivationEnabled() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
LaunchBrowserDialog(CString &strSelectedURL, LPCTSTR strDialogCaption, LPCTSTR strOk, LPCTSTR strStartPage) | CNavDialog | protectedvirtual
LocateFile() | CNavDialog | virtual
LockDialogHeight() (defined in CAdUiDialog) | CAdUiDialog |
LockDialogWidth() (defined in CAdUiDialog) | CAdUiDialog |
m_bEnableElasticMessageMap (defined in CAdUiDialog) | CAdUiDialog | protected
m_bUseTips (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_commandState (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFileName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpFullPathName (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_contextHelpPrefix (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hDialogResource (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_hIcon (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pTextTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pToolTip (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_pUIAssist (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedstatic
m_rootKey (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
m_templateid (defined in CAdUiDialog) | CAdUiDialog | protected
MakeDialogsVisible(BOOL visible) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
MoveControlX(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlXY(UINT id, LONG lMoveXPct, LONG lMoveYPct) (defined in CAdUiDialog) | CAdUiDialog |
MoveControlY(UINT id, LONG lMovePct) (defined in CAdUiDialog) | CAdUiDialog |
NavigateToFolder(LPCTSTR sFolder) | CNavDialog |
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnAdUiTimer(UINT_PTR nIDEvent) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnCancel() | CNavDialog | protectedvirtual
OnCmdMsg(UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo) | CNavDialog | protectedvirtual
OnContextMenu(CWnd *, CPoint) | CNavDialog | protected
OnCtlColor(CDC *pDC, CWnd *pWnd, UINT nCtlColor) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnDestroy() | CNavDialog | protected
OnDialogHelp() | CNavDialog | virtual
OnDialogHelp(LPCTSTR pHelpTag) | CNavDialog | virtual
OnDoFind() | CNavDialog | protectedvirtual
OnDoLocate() | CNavDialog | protectedvirtual
OnFileNameChange() | CNavDialog | protectedvirtual
OnFileNameOK() | CNavDialog | protectedvirtual
OnFileNameSelectionChange() | CNavDialog | protectedvirtual
OnFilterChange() | CNavDialog | protectedvirtual
OnFolderChange() | CNavDialog | protectedvirtual
OnFolderItemChange() | CNavDialog | protectedvirtual
OnGetMinMaxInfo(MINMAXINFO FAR *lpMMI) (defined in CAdUiDialog) | CAdUiDialog | protected
OnHelpInfo(HELPINFO *pHelpInfo) | CNavDialog | protected
OnInitDialog() | CNavDialog | protectedvirtual
OnInitDialogBegin() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnInitDialogFinish() (defined in CAdUiDialog) | CAdUiDialog | protectedvirtual
OnKickIdle() | CNavDialog | protected
OnNotify_ToolTipText(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protected
OnNotifyControlChange(UINT controlId, LPARAM lParam) | CNavDialog | protectedvirtual
OnNotifyControlValid(UINT controlId, BOOL isValid) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnNotifyGeneric(UINT controlId, LPARAM lParam) | CNavDialog | protectedvirtual
OnNotifyUpdateTip(CWnd *control) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
OnOK() | CNavDialog | protectedvirtual
OnSize(UINT nType, int cx, int cy) (defined in CAdUiDialog) | CAdUiDialog | protected
OnSysColorChange() | CNavDialog | protected
OnURLDownloadSuccess(CString &strURL) | CNavDialog | protectedvirtual
OnUrlOK() | CNavDialog | protectedvirtual
PostNcDestroy() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PreCreateWindow(CREATESTRUCT &cs) (defined in CAdUiBaseDialog) | CAdUiBaseDialog | protectedvirtual
PrepareOkMenu(CMenu *pMenu) | CNavDialog | protectedvirtual
PrepareToolsMenu(CMenu *pMenu) | CNavDialog | protectedvirtual
PrepareViewsMenu(CMenu *pMenu) | CNavDialog | protectedvirtual
PreprocessData(CNavDataArray &array) | CNavDialog | protectedvirtual
PreTranslateMessage(MSG *pMsg) | CNavDialog | protectedvirtual
Refresh() | CNavDialog | protectedvirtual
ReloadControl(CWnd *pControl, LPCTSTR lpResString) (defined in CAdUiDialog) | CAdUiDialog |
RemoveControl(CWnd *pControl) (defined in CAdUiDialog) | CAdUiDialog |
ReportURLTransferStatus(CDWordArray &dwErrorArray, CStringArray &strURLs, CStringArray &strLocals) | CNavDialog | protectedvirtual
SaveColumnSizes(CListCtrl *pList) (defined in CAdUiDialog) | CAdUiDialog |
SetAcceptAnyFileExtension(BOOL any) | CNavDialog |
SetAllDialogsData(const CString &cValueName, CString &cValue) | CNavDialog | virtual
SetAllDialogsData(const CString &cValueName, DWORD dwValue) | CNavDialog | virtual
SetAppRootKey(LPCTSTR key) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetConfirmReplace(BOOL confirm) | CNavDialog |
SetContextHelpFileName(LPCTSTR pFileName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpFullPathName(LPCTSTR pFullPathName) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetContextHelpPrefix(LPCTSTR pPrefix) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetControlProperty(PDLGCTLINFO lp, DWORD numElements) (defined in CAdUiDialog) | CAdUiDialog |
SetCreatingFile(BOOL create) | CNavDialog |
SetDefaultFileExtension(LPCTSTR ext) | CNavDialog |
SetDefaultFilterIndex(int index) | CNavDialog |
SetDefaultInitialFolder(LPCTSTR folder) | CNavDialog |
SetDialogCaption(LPCTSTR caption) | CNavDialog |
SetDialogData(LPCTSTR valueName, LPCTSTR data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogData(LPCTSTR valueName, DWORD data) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogHelpTag(LPCTSTR tag) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogIcon(HICON hIcon) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetDialogMaxExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogMinExtents(int width, int height) (defined in CAdUiDialog) | CAdUiDialog |
SetDialogName(LPCTSTR name) (defined in CAdUiDialog) | CAdUiDialog |
SetElasticSize(CSize &size, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetFilterIndex(int index) | CNavDialog |
SetFolderComboCurSel(int i) | CNavDialog |
SetFolderListCtrl(CNavListCtrl *folderListCtrl) | CNavDialog |
SetFoldersOnly(BOOL foldersOnly) | CNavDialog |
SetForceFilterIndex(int index) | CNavDialog |
SetForceInitialFolder(LPCTSTR folder) | CNavDialog |
SetInitialFileName(LPCTSTR name) | CNavDialog |
SetMultiSelectAllowed(BOOL allow) | CNavDialog |
SetNoExtraExtensions(BOOL noExtraExtensions) | CNavDialog |
SetNoExtraExtensionsInPlaces(BOOL noExtraExtensions) | CNavDialog |
SetNoFTP(BOOL noFTP) | CNavDialog |
SetNoURLFileTransfer(BOOL noTransfer) | CNavDialog |
SetNoURLsAllowed(BOOL noURLs) | CNavDialog |
SetOkButtonMenuExists(BOOL bExists) | CNavDialog |
SetOkButtonText(LPCTSTR text) | CNavDialog |
SetPersistency(BOOL bFlag) (defined in CAdUiDialog) | CAdUiDialog |
SetReadOnlyAllowed(BOOL allow) | CNavDialog |
SetReadOnlyHidden(BOOL hidden) | CNavDialog |
SetReadOnlySpecified(BOOL readOnly) | CNavDialog |
SetRootKey(LPCTSTR key) (defined in CAdUiDialog) | CAdUiDialog |
SetTabSize(LPARAM lParam, BOOL bRefreshDialog) (defined in CAdUiDialog) | CAdUiDialog |
SetToolsMenuItemsPresent(UINT flag) | CNavDialog |
SetUseRegExtensionFlags(BOOL bUse) | CNavDialog |
SetUseTips(BOOL useTips) (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
SetViewMode(UINT viewMode) | CNavDialog |
StorePixelData() (defined in CAdUiDialog) | CAdUiDialog |
StretchControlX(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlXY(UINT id, LONG lStretchXPct, LONG lStretchYPct) (defined in CAdUiDialog) | CAdUiDialog |
StretchControlY(UINT id, LONG lStretchPct) (defined in CAdUiDialog) | CAdUiDialog |
TrimWhiteSpace(CString &strName, BOOL bAll) | CNavDialog |
UpdateFileExtension(CString &strName, BOOL bCanUseCurrentExtension) | CNavDialog | protectedvirtual
UpdateUIState() | CNavDialog | protectedvirtual
ValidateData() (defined in CAdUiBaseDialog) | CAdUiBaseDialog |
VerifyURLSave() | CNavDialog | protectedvirtual
~CAdUiBaseDialog() (defined in CAdUiBaseDialog) | CAdUiBaseDialog | virtual
~CAdUiDialog() (defined in CAdUiDialog) | CAdUiDialog | virtual
~CNavDialog() | CNavDialog | virtual


ZRX API Reference: CNavDropSource Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
CNavDropSource Class Reference
MFC Classes

Public Member Functions

CNavDropSource ()
SCODE GiveFeedback (DROPEFFECT dropEffect)

Public Attributes

CNavListCtrl * m_pListCtrl

Constructor & Destructor Documentation

CNavDropSource::CNavDropSource ( )
Warning
Not implemented!

Member Function Documentation

SCODE CNavDropSource::GiveFeedback ( DROPEFFECT dropEffect )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • anavlistctrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CNavDropSource Member List

This is the complete list of members for CNavDropSource, including all inherited members.

CNavDropSource() | CNavDropSource
GiveFeedback(DROPEFFECT dropEffect) | CNavDropSource
m_pListCtrl (defined in CNavDropSource) | CNavDropSource


ZRX API Reference: CNavFilter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
CNavFilter Class Reference
MFC Classes

Public Member Functions

CNavFilter ()
int | Find (LPCTSTR str)
int | GetCount ()
LPCTSTR | GetDescription ()
void | GetFullDescription (CString &desc)
INT_PTR | GetTagIndex ()
BOOL | IsAllowed (LPCTSTR fileName)
void | SetDescription (LPCTSTR desc)
LPTSTR | SetFrom (LPTSTR str, BOOL bUseFullDescrition=FALSE)
void | SetFullDescription (LPCTSTR desc)
void | SetTagIndex (INT_PTR tagIndex)
virtual | ~CNavFilter ()

Protected Attributes

CString | m_description
INT_PTR | m_tagIndex

Constructor & Destructor Documentation

CNavFilter::CNavFilter ( )
Warning
Not implemented!
virtual CNavFilter::~CNavFilter ( )
virtual
Warning
Not implemented!

Member Function Documentation

int CNavFilter::Find ( LPCTSTR str )
Warning
Not implemented!
int CNavFilter::GetCount ( )
Warning
Not implemented!
LPCTSTR CNavFilter::GetDescription ( )
Warning
Not implemented!
void CNavFilter::GetFullDescription ( CString & desc )
Warning
Not implemented!
INT_PTR CNavFilter::GetTagIndex ( )
Warning
Not implemented!
BOOL CNavFilter::IsAllowed ( LPCTSTR fileName )
Warning
Not implemented!
void CNavFilter::SetDescription ( LPCTSTR desc )
Warning
Not implemented!
LPTSTR CNavFilter::SetFrom | ( | LPTSTR | str,
 |  | BOOL | bUseFullDescrition = FALSE
 | ) |  |
Warning
Not implemented!
void CNavFilter::SetFullDescription ( LPCTSTR desc )
Warning
Not implemented!
void CNavFilter::SetTagIndex ( INT_PTR tagIndex )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • anavfilter.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CNavFilter Member List

This is the complete list of members for CNavFilter, including all inherited members.

CNavFilter() | CNavFilter |
Find(LPCTSTR str) | CNavFilter |
GetCount() | CNavFilter |
GetDescription() | CNavFilter |
GetFullDescription(CString &desc) | CNavFilter |
GetTagIndex() | CNavFilter |
IsAllowed(LPCTSTR fileName) | CNavFilter |
m_description (defined in CNavFilter) | CNavFilter | protected
m_tagIndex (defined in CNavFilter) | CNavFilter | protected
SetDescription(LPCTSTR desc) | CNavFilter |
SetFrom(LPTSTR str, BOOL bUseFullDescrition=FALSE) | CNavFilter |
SetFullDescription(LPCTSTR desc) | CNavFilter |
SetTagIndex(INT_PTR tagIndex) | CNavFilter |
~CNavFilter() | CNavFilter | virtual


ZRX API Reference: CNavFilterArray Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CNavFilterArray Class Reference
MFC Classes
+ Inheritance diagram for CNavFilterArray:

Public Member Functions

CNavFilterArray ()
int | Find (LPCTSTR str)
int | FindExact (LPCTSTR str)
void | SetFrom (LPCTSTR str, BOOL bUseFullDescrition=FALSE)
virtual | ~CNavFilterArray ()
- Public Member Functions inherited from CNavArray< CNavFilter >
CNavFilter * AddData ()
CNavArray ()
int | GetCount ()
CNavFilter * | GetData (INT_PTR index)
BOOL | IsIndexValid (INT_PTR index)
void | RemoveAllData ()
void | RemoveData (INT_PTR index)
virtual | ~CNavArray ()

Additional Inherited Members

- Protected Member Functions inherited from CNavArray< CNavFilter >
virtual CNavFilter * NewData ()

Constructor & Destructor Documentation

CNavFilterArray::CNavFilterArray ( )
Warning
Not implemented!
virtual CNavFilterArray::~CNavFilterArray ( )
virtual
Warning
Not implemented!

Member Function Documentation

int CNavFilterArray::Find ( LPCTSTR str )
Warning
Not implemented!
int CNavFilterArray::FindExact ( LPCTSTR str )
Warning
Not implemented!
void CNavFilterArray::SetFrom | ( | LPCTSTR | str,
 |  | BOOL | bUseFullDescrition = FALSE
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • anavfilterarray.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CNavFilterArray Member List

This is the complete list of members for CNavFilterArray, including all inherited members.

AddData() | CNavArray< CNavFilter > |
CNavArray() | CNavArray< CNavFilter > |
CNavFilterArray() | CNavFilterArray |
Find(LPCTSTR str) | CNavFilterArray |
FindExact(LPCTSTR str) | CNavFilterArray |
GetCount() | CNavArray< CNavFilter > |
GetData(INT_PTR index) | CNavArray< CNavFilter > |
IsIndexValid(INT_PTR index) | CNavArray< CNavFilter > |
NewData() | CNavArray< CNavFilter > | protectedvirtual
RemoveAllData() | CNavArray< CNavFilter > |
RemoveData(INT_PTR index) (defined in CNavArray< CNavFilter >) | CNavArray< CNavFilter > |
SetFrom(LPCTSTR str, BOOL bUseFullDescrition=FALSE) | CNavFilterArray |
~CNavArray() | CNavArray< CNavFilter > | virtual
~CNavFilterArray() | CNavFilterArray | virtual


ZRX API Reference: CNavListCtrl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CNavListCtrl Class Reference
MFC Classes
+ Inheritance diagram for CNavListCtrl:

Public Member Functions

CNavListCtrl ()
- Public Member Functions inherited from CAdUiListCtrl
int | ColumnCount ()
CWnd * | GetAdUiParent ()
virtual void | GetContentExtent (int item, int index, LPCTSTR text, int &width, int &height)
BOOL | GetItemAtPoint (CPoint &p, int &item, int &index)
BOOL | GetSubItemRect (int item, int index, CRect &rect)
void | GetTextExtent (LPCTSTR text, int &width, int &height)
BOOL | IsOwnerDraw ()
void | SetAdUiParent (CWnd *w)

Protected Member Functions

afx_msg void | OnBeginDrag (NMHDR *pNMHDR, LRESULT *pResult)
afx_msg LRESULT | OnHandleDrag (UINT_PTR pDataSource, LPARAM nSelectedItem)
- Protected Member Functions inherited from CAdUiListCtrl
virtual ADUI_REPLY | DoAdUiMessage (ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam)
afx_msg LRESULT | OnAdUiMessage (WPARAM wParam, LPARAM lParam)
virtual void | OnDrawTip (CDC &dc)
virtual BOOL | OnDrawTipText (CAdUiDrawTipText &dtt)
virtual BOOL | OnGetTipRect (CRect &r)
virtual ADUI_REPLY | OnGetTipSupport (CPoint &p)
virtual BOOL | OnGetTipText (CString &text)
virtual BOOL | OnHitTipRect (CPoint &p)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
virtual void | PreSubclassWindow ()

Protected Attributes

CNavDropSource | m_dropSource
CImageList * | m_pDragImage
- Protected Attributes inherited from CAdUiListCtrl
CWnd * | m_aduiParent
CPoint | m_lastMousePoint
int | m_tipIndex
int | m_tipItem
CRect | m_tipRect

Additional Inherited Members

- Public Attributes inherited from CAdUiListCtrl
CAdUiHeaderCtrl m_headerCtrl

Constructor & Destructor Documentation

CNavListCtrl::CNavListCtrl ( )
Warning
Not implemented!

Member Function Documentation

afx_msg void CNavListCtrl::OnBeginDrag | ( | NMHDR * | pNMHDR,
 |  | LRESULT * | pResult
 | ) |  |
protected
Warning
Not implemented!
afx_msg LRESULT CNavListCtrl::OnHandleDrag | ( | UINT_PTR | pDataSource,
 |  | LPARAM | nSelectedItem
 | ) |  |
protected
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • anavlistctrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CNavListCtrl Member List

This is the complete list of members for CNavListCtrl, including all inherited members.

CAdUiListCtrl() (defined in CAdUiListCtrl) | CAdUiListCtrl |
CNavListCtrl() | CNavListCtrl |
ColumnCount() (defined in CAdUiListCtrl) | CAdUiListCtrl |
DoAdUiMessage(ADUI_NOTIFY notifyCode, UINT controlId, LPARAM lParam) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
GetAdUiParent() (defined in CAdUiListCtrl) | CAdUiListCtrl |
GetContentExtent(int item, int index, LPCTSTR text, int &width, int &height) (defined in CAdUiListCtrl) | CAdUiListCtrl | virtual
GetItemAtPoint(CPoint &p, int &item, int &index) (defined in CAdUiListCtrl) | CAdUiListCtrl |
GetSubItemRect(int item, int index, CRect &rect) (defined in CAdUiListCtrl) | CAdUiListCtrl |
GetTextExtent(LPCTSTR text, int &width, int &height) (defined in CAdUiListCtrl) | CAdUiListCtrl |
IsOwnerDraw() (defined in CAdUiListCtrl) | CAdUiListCtrl |
m_aduiParent (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
m_dropSource (defined in CNavListCtrl) | CNavListCtrl | protected
m_headerCtrl (defined in CAdUiListCtrl) | CAdUiListCtrl |
m_lastMousePoint (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
m_pDragImage (defined in CNavListCtrl) | CNavListCtrl | protected
m_tipIndex (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
m_tipItem (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
m_tipRect (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
OnAdUiMessage(WPARAM wParam, LPARAM lParam) (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
OnBeginDrag(NMHDR *pNMHDR, LRESULT *pResult) | CNavListCtrl | protected
OnDrawTip(CDC &dc) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnDrawTipText(CAdUiDrawTipText &dtt) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnGetTipRect(CRect &r) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnGetTipSupport(CPoint &p) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnGetTipText(CString &text) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnHandleDrag(UINT_PTR pDataSource, LPARAM nSelectedItem) | CNavListCtrl | protected
OnHitTipRect(CPoint &p) (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) (defined in CAdUiListCtrl) | CAdUiListCtrl | protected
PreSubclassWindow() (defined in CAdUiListCtrl) | CAdUiListCtrl | protectedvirtual
SetAdUiParent(CWnd *w) (defined in CAdUiListCtrl) | CAdUiListCtrl |
~CAdUiListCtrl() (defined in CAdUiListCtrl) | CAdUiListCtrl | virtual


ZRX API Reference: Misc Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Macros | Typedefs | Functions
Misc Classes

Classes

class | AcadAppInfo
class | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >
class | AcArray< T, R >
class | AcArrayMemCopyReallocator< T >
class | AcArrayObjectCopyReallocator< T >
class | AcCFile
class | AcCStdioFile
class | AcFILE
class | AcFileDependencyInfo
class | AcFileDependencyManager
class | AcHeapOperators
class | AcIfstream
class | AcLispAppInfo
class | AcOfstream
class | AcOutputBufMgr
class | AcPane
class | AcStatusBarItem
class | AcStatusBarMenuItem
class | AcString
class | AcUnderlayLayer
class | AcValue
class | AdCharFormatter
class | AsdkPromptBase< T, TCLSIDWrapper >
class | CAcGradientThumbnailEngine
class | CAseApiObj
class | CAseAppl
class | CAseLink
class | CAseLinkPath
class | CAseLinkSel
class | CAsiAppl
class | CAsiApproxNum
class | CAsiBinary
class | CAsiBlob
class | CAsiChar
class | CAsiColumn
class | CAsiCsr
class | CAsiCsrInfSchema
class | CAsiCsrRegTable
class | CAsiCsrTable
class | CAsiData
class | CAsiDate
class | CAsiDatetime
class | CAsiDecimal
class | CAsiDouble
class | CAsiDT
class | CAsiEnumerator
class | CAsiExactNum
class | CAsiException
class | CAsiExceptionHandler
class | CAsiExecStm
class | CAsiFloat
class | CAsiHostBuffer
class | CAsiIdent
class | CAsiInt
class | CAsiInterval
class | CAsiIQualifier
class | CAsiIRow
class | CAsiList
class | CAsiNum
class | CAsiNumeric
class | CAsiObject
class | CAsiParameter
class | CAsiReal
class | CAsiRow
class | CAsiSession
class | CAsiSmallInt
class | CAsiSQLObject
class | CAsiStm
class | CAsiTACond
class | CAsiTCCond
class | CAsiTime
class | CAsiTimeStamp
class | CAsiUcChar
class | CAsiUcStr
class | CAsiYM
class | CProxy_AcadObjectEvents< T >
class | CProxy_PropertyNotifySink< T >
class | CRectangle3d
class | IAcadBaseDatabaseImpl< pclsid >
class | IAcadBaseObject2Impl< T, pclsid >
class | IAcadBaseObjectImpl< T, pclsid >
class | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >
class | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >
class | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >
class | IAcadShadowDisplayImpl< C >
struct | ListItem
class | OwnerDraw3d
class | RxADSAppTableEntryType

Macros

#define | ACSB_COMMAND (1<<4)
#define | ACSB_NOBORDERS (1<<0)
#define | ACSB_NORMAL (1<<3)
#define | ACSB_POPOUT (1<<1)
#define | ACSB_POPUP (1<<5)
#define | ACSB_STRETCH (1<<2)
#define | BEGIN_PROMPT_MAP(CLASSNAME)
#define | DEFINE_SAMPLER(CURSORTYPE, USERINPUTCONTROLS)
#define | END_PROMPT_MAP
#define | INTERFACE IAcadBaseObject
#define | INTERFACE IAcadAcCmColorAccess
#define | INTERFACE IAcadBaseSubEntity
#define | lowMemBail() AC_ARRAY_ASSERT(false)
#define | PROMPT_ENTRY(szDesc, dispId, promptType, defaultValueId, promptId, bJigThisProperty) { szDesc, dispId, promptType, 1, 0, 0, defaultValueId, promptId, bJigThisProperty },
#define | PROMPT_ENTRY_INITGET(szDesc, dispId, promptType, initget, keywordsId, defaultValueId, promptId, bJigThisProperty) { szDesc, dispId, promptType, 1, initget, keywordsId, defaultValueId, promptId, bJigThisProperty },
#define | PROMPT_ENTRY_SYMBOL(szDesc, dispId, defaultValueId, promptId, bJigThisProperty) { szDesc, dispId, RTSTR, 0, 0, 0, defaultValueId, promptId, bJigThisProperty },

Typedefs

typedef ULONG_PTR | ASILISTPOS
typedef IAcadAcCmColorAccess * | LPACADACCMCOLORACCESS
typedef IAcadBaseDatabase * | LPACADBASEDATABASE
typedef IAcadBaseObject * | LPACADBASEOBJECT
typedef IAcadBaseObject2 * | LPACADBASEOBJECT2
typedef IAcadBaseSubEntity * | LPACADSUBENTITY
typedef IMetaColorSuppressor * | LPMETACOLORSUPPRESSOR
typedef IRetrieveApplication * | LPRETRIEVEAPPLICATION

Functions

class | __declspec (novtable) AdHostImageAppServices
AcArray< T, R >::AcArray (int initPhysicalLength=0, int initGrowLength=8)
AcArray< T, R >::AcArray (const AcArray< T, R > &)
AcCFile::AcCFile (HANDLE hFile)
AcCFile::AcCFile (LPCTSTR lpszFileName, UINT nOpenFlags)
unsigned | acCheckCFileCharFormat (CFile *pCFile)
AcCStdioFile::AcCStdioFile (FILE *pOpenStream)
AcCStdioFile::AcCStdioFile (LPCTSTR lpszFileName, UINT nOpenFlags)
class | AcIfstream::AcIfstream (const ACHAR *pName)
class | AcOfstream::AcOfstream (const ACHAR *pName)
void | acWriteWCharToCFile (wchar_t wch, CFile *pFile, const AdCharFormatter &charFmt)
int | AcArray< T, R >::append (const T &value)
AcArray< T, R > & | AcArray< T, R >::append (const AcArray< T, R > &array)
const T * | AcArray< T, R >::asArrayPtr () const
T * | AcArray< T, R >::asArrayPtr ()
EAsiBoolean | AsiAllocateDSEnumerator (CAsiAppl *pAppl, const GUID *guidEnum, const CAsiUcStr &pDS, CAsiEnumerator **pEnum)
void | AsiExceptionThrow (CAsiException *)
EAsiBoolean | AsiGetDSEnumerator (CAsiAppl *pAppl, const GUID *guidEnum, const CAsiUcStr &pDS, GUID *guidDsEnum)
const T & | AcArray< T, R >::at (int index) const
T & | AcArray< T, R >::at (int index)
void | AcFILE::attach (FILE *pFILE)
bool | AcOutputBufMgr::attachBuffer (void *pBuffer, unsigned nBufSize)
bool | AcCFile::attachBuffer (void *pBuffer, unsigned nBufSize)
bool | AcCStdioFile::attachBuffer (void *pBuffer, unsigned nBufSize)
unsigned | AcOutputBufMgr::byteCount () const
bool | AcArray< T, R >::contains (const T &value, int start=0) const
interface | DECLSPEC_UUID ("4A54E06B-820B-42FC-BAE1-91100E6DF2AD") IAcadBaseObject
interface | DECLSPEC_UUID ("F6ABC0A4-748A-4BC0-A6B0-7D25D7001390") IAcadBaseObject2
interface | DECLSPEC_UUID ("810D2E0F-D7F9-4E3A-8C85-601B9A66E6A0") IRetrieveApplication
interface | DECLSPEC_UUID ("9CC45791-9DF5-48DB-B28F-12BA4E509225") IAcadBaseDatabase
interface | DECLSPEC_UUID ("9E2C8E3C-D8A6-4917-81EE-AF88133C1DEB") IMetaColorSuppressor
interface | DECLSPEC_UUID ("4B363B98-F861-41D9-9FF1-A9D47EA7CA63") IAcadAcCmColorAccess
interface | DECLSPEC_UUID ("B374D885-EECE-4138-8C82-3FB20C538788") IAcadBaseSubEntity
DEFINE_GUID (IID_IAcadBaseObject2, 0xf6abc0a4, 0x748a, 0x4bc0, 0xa6, 0xb0, 0x7d, 0x25, 0xd7, 0x00, 0x13, 0x90)
DEFINE_GUID (IID_IRetrieveApplication, 0x810d2e0f, 0xd7f9, 0x4e3a, 0x8c, 0x85, 0x60, 0x1b, 0x9a, 0x66, 0xe6, 0xa0)
DEFINE_GUID (IID_IAcadBaseDatabase, 0x9cc45791, 0x9df5, 0x48db, 0xb2, 0x8f, 0x12, 0xba, 0x4e, 0x50, 0x92, 0x25)
DEFINE_GUID (IID_IIMetaColorSuppressor, 0x9e2c8e3c, 0xd8a6, 0x4917, 0x81, 0xee, 0xaf, 0x88, 0x13, 0x3c, 0x1d, 0xeb)
DEFINE_GUID (IID_IAcadAcCmColorAccess, 0x4b363b98, 0xf861, 0x41d9, 0x9f, 0xf1, 0xa9, 0xd4, 0x7e, 0xa7, 0xca, 0x63)
DEFINE_GUID (IID_IAcadBaseSubEntity, 0xb374d885, 0xeece, 0x4138, 0x8c, 0x82, 0x3f, 0xb2, 0xc, 0x53, 0x87, 0x88)
FILE * | AcFILE::detach ()
bool | AcOutputBufMgr::detachBuffer ()
bool | AcCFile::detachBuffer ()
bool | AcCStdioFile::detachBuffer ()
int | AcFILE::fclose ()
int | AcFILE::fgetc ()
TCHAR * | AcFILE::fgets (TCHAR *pBuf, int nChars)
bool | AcArray< T, R >::find (const T &value, int &foundAt, int start=0) const
int | AcArray< T, R >::find (const T &value) const
int | AcArray< T, R >::findFrom (const T &value, int start) const
T & | AcArray< T, R >::first ()
const T & | AcArray< T, R >::first () const
bool | AcCFile::flushBytes ()
bool | AcCStdioFile::flushBytes ()
FILE * | AcFILE::fopen (const TCHAR *pName, const TCHAR *pMode)
int | AcFILE::fprintf (const TCHAR *pFmtStr,...)
int | AcFILE::fputc (TCHAR c)
int | AcFILE::fputs (const TCHAR *pStr)
int | AcFILE::fscanf (const TCHAR *pFmtStr,...)
FILE * | AcFILE::fsopen (const TCHAR *pName, const TCHAR *pMode, int shflag)
int | AcArray< T, R >::growLength () const
bool | AcOutputBufMgr::hasBuffer () const
bool | AcCFile::hasBuffer () const
bool | AcCStdioFile::hasBuffer () const
AcArray< T, R > & | AcArray< T, R >::insertAt (int index, const T &value)
bool | AcArray< T, R >::isEmpty () const
bool | AcArray< T, R >::isValid (int) const
T & | AcArray< T, R >::last ()
const T & | AcArray< T, R >::last () const
int | AcArray< T, R >::length () const
int | AcArray< T, R >::logicalLength () const
void | AcIfstream::open (const wchar_t *pName)
void | AcIfstream::open (const wchar_t *pName, ios_base::openmode nMode)
void | AcOfstream::open (const wchar_t *pName)
void | AcOfstream::open (const wchar_t *pName, ios_base::openmode nMode)
AcArray< T, R > & | AcArray< T, R >::operator= (const AcArray< T, R > &)
bool | AcArray< T, R >::operator== (const AcArray< T, R > &) const
T & | AcArray< T, R >::operator[] (int)
const T & | AcArray< T, R >::operator[] (int) const
int | AcArray< T, R >::physicalLength () const
void * | AcOutputBufMgr::pointer () const
virtual UINT | AcCFile::Read (void *lpBuf, UINT nCount)
virtual UINT | AcCFile::Read (LPTSTR lpBuf, UINT nCount)
bool | AcFILE::readBOM ()
bool | AcCFile::readBOM ()
bool | AcCStdioFile::readBOM ()
virtual LPTSTR | AcCStdioFile::ReadString (LPTSTR lpsz, UINT nMax)
virtual BOOL | AcCStdioFile::ReadString (CString &rString)
bool | AcArray< T, R >::remove (const T &value, int start=0)
AcArray< T, R > & | AcArray< T, R >::removeAll ()
AcArray< T, R > & | AcArray< T, R >::removeAt (int index)
AcArray< T, R > & | AcArray< T, R >::removeFirst ()
AcArray< T, R > & | AcArray< T, R >::removeLast ()
AcArray< T, R > & | AcArray< T, R >::removeSubArray (int startIndex, int endIndex)
void * | AcOutputBufMgr::requestBytes (unsigned nBytesNeeded)
bool | AcOutputBufMgr::reset ()
AcArray< T, R > & | AcArray< T, R >::reverse ()
AcArray< T, R > & | AcArray< T, R >::setAll (const T &value)
AcArray< T, R > & | AcArray< T, R >::setAt (int index, const T &value)
AcArray< T, R > & | AcArray< T, R >::setGrowLength (int)
AcArray< T, R > & | AcArray< T, R >::setLogicalLength (int)
AcArray< T, R > & | AcArray< T, R >::setPhysicalLength (int)
AcArray< T, R > & | AcArray< T, R >::swap (int i1, int i2)
unsigned | AcOutputBufMgr::takeBytes (unsigned nBytesUsed)
int | AcFILE::ungetc (TCHAR c)
int | AcFILE::vfprintf (const TCHAR *pFmtStr, va_list va)
virtual void | AcCFile::Write (const void *lpBuf, UINT nCount)
virtual void | AcCFile::Write (LPCTSTR pString, UINT nCount)
virtual void | AcCFile::Write (LPCTSTR pString)
bool | AcFILE::writeBOM ()
bool | AcCFile::writeBOM ()
bool | AcCStdioFile::writeBOM ()
virtual void | AcCStdioFile::WriteString (LPCTSTR lpsz)

Detailed Description

Macro Definition Documentation

#define DEFINE_SAMPLER | ( | CURSORTYPE,
 |  | USERINPUTCONTROLS
 | ) |
Value:
virtual void initSampler () { \
m_jigCursorType =CURSORTYPE ; \
m_jigUserInputControls =USERINPUTCONTROLS ; \
}
#define END_PROMPT_MAP
Value:
{ NULL, 0, 0, 0, 0, 0, 0, false, false, VT_EMPTY } \
} ; \
return (pPromptMap) ; \
}

Function Documentation

void AcFILE::attach ( FILE * pFILE )
inline
Warning
Not implemented!
template<class T, class R >
bool AcArray< T, R >::find | ( | const T & | value,
 |  | int & | foundAt,
 |  | int | start = 0
 | ) |  | const
Warning
Not implemented!
template<class T, class R >
int AcArray< T, R >::find ( const T & value ) const
Warning
Not implemented!
template<class T, class R >
int AcArray< T, R >::findFrom | ( | const T & | value,
 |  | int | start
 | ) |  | const
Warning
Not implemented!
template<class T , class R >
T & AcArray< T, R >::first ( )
inline
Warning
Not implemented!
template<class T , class R >
const T & AcArray< T, R >::first ( ) const
inline
Warning
Not implemented!
template<class T , class R >
int AcArray< T, R >::growLength ( ) const
inline
Warning
Not implemented!
template<class T, class R >
AcArray< T, R > & AcArray< T, R >::insertAt | ( | int | index,
 |  | const T & | value
 | ) |  |
Warning
Not implemented!
template<class T , class R >
bool AcArray< T, R >::isEmpty ( ) const
inline
Warning
Not implemented!
template<class T , class R >
T & AcArray< T, R >::last ( )
inline
Warning
Not implemented!
template<class T , class R >
const T & AcArray< T, R >::last ( ) const
inline
Warning
Not implemented!
template<class T , class R >
int AcArray< T, R >::length ( ) const
inline
Warning
Not implemented!
template<class T , class R >
int AcArray< T, R >::logicalLength ( ) const
inline
Warning
Not implemented!
template<class T, class R>
AcArray< T, R > & AcArray< T, R >::operator= ( const AcArray< T, R > & src )
Warning
Not implemented!
template<class T, class R>
bool AcArray< T, R >::operator== ( const AcArray< T, R > & cpr ) const
Warning
Not implemented!
template<class T , class R >
T & AcArray< T, R >::operator[] ( int i )
inline
Warning
Not implemented!
template<class T , class R >
const T & AcArray< T, R >::operator[] ( int i ) const
inline
Warning
Not implemented!
template<class T , class R >
int AcArray< T, R >::physicalLength ( ) const
inline
Warning
Not implemented!
template<class T, class R >
bool AcArray< T, R >::remove | ( | const T & | value,
 |  | int | start = 0
 | ) |  |
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::removeAll ( )
inline
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::removeAt ( int index )
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::removeFirst ( )
inline
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::removeLast ( )
inline
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::removeSubArray | ( | int | startIndex,
 |  | int | endIndex
 | ) |  |
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::reverse ( )
Warning
Not implemented!
template<class T, class R >
AcArray< T, R > & AcArray< T, R >::setAll ( const T & value )
Warning
Not implemented!
template<class T, class R >
AcArray< T, R > & AcArray< T, R >::setAt | ( | int | index,
 |  | const T & | value
 | ) |  |
inline
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::setGrowLength ( int glen )
inline
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::setLogicalLength ( int n )
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::setPhysicalLength ( int n )
Warning
Not implemented!
template<class T , class R >
AcArray< T, R > & AcArray< T, R >::swap | ( | int | i1,
 |  | int | i2
 | ) |  |
Warning
Not implemented!


ZRX API Reference: AcadAppInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcadAppInfo Class Reference
Misc Classes
+ Inheritance diagram for AcadAppInfo:

Public Types

enum | CmdStatus { kNoAction = 0, kRetry = 1, kShowMsg = 2, kNoModule = 3 }
typedef AcadAppInfo::CmdStatus(* | LoaderFunPtr )(void *)

Public Member Functions

ACRX_DECLARE_MEMBERS (AcadAppInfo)
const ACHAR * | appDesc () const
bool | appImplements (const ACHAR *) const
const ACHAR * | appName () const
AcadApp::ErrorStatus | delFromRegistry (bool bObjDbx=false)
AcadApp::LoadReasons | loadReason ()
bool | managed () const
const ACHAR * | moduleName () const
AcadApp::ErrorStatus | readFromRegistry ()
AcadAppInfo::CmdStatus | runAppLoader ()
void | setAppDesc (const ACHAR *)
void | setAppLoader (LoaderFunPtr)
void | setAppName (const ACHAR *)
void | setLoadReason (AcadApp::LoadReasons)
void | setManaged (bool bManaged)
void | setModuleName (const ACHAR *)
AcadApp::ErrorStatus | status () const
AcadApp::ErrorStatus | writeCommandNameToRegistry (const ACHAR *globalCmdName, const ACHAR *localCmdName)
AcadApp::ErrorStatus | writeGroupNameToRegistry (const ACHAR *group)
AcadApp::ErrorStatus | writeToRegistry (bool bObjDbx=false, bool skipHKLM=false)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Member Function Documentation

const ACHAR* AcadAppInfo::appDesc ( ) const
Warning
Not implemented!
bool AcadAppInfo::appImplements ( const ACHAR * ) const
Warning
Not implemented!
const ACHAR* AcadAppInfo::appName ( ) const
Warning
Not implemented!
const ACHAR* AcadAppInfo::moduleName ( ) const
Warning
Not implemented!
void AcadAppInfo::setAppDesc ( const ACHAR * )
Warning
Not implemented!
void AcadAppInfo::setAppName ( const ACHAR * )
Warning
Not implemented!
void AcadAppInfo::setModuleName ( const ACHAR * )
Warning
Not implemented!
AcadApp::ErrorStatus AcadAppInfo::writeCommandNameToRegistry | ( | const ACHAR * | globalCmdName,
 |  | const ACHAR * | localCmdName
 | ) |  |
Warning
Not implemented!
AcadApp::ErrorStatus AcadAppInfo::writeGroupNameToRegistry ( const ACHAR * group )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • appinfo.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcadAppInfo Member List

This is the complete list of members for AcadAppInfo, including all inherited members.

AcadAppInfo() (defined in AcadAppInfo) | AcadAppInfo |
ACRX_DECLARE_MEMBERS(AcadAppInfo) (defined in AcadAppInfo) | AcadAppInfo |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
appDesc() const | AcadAppInfo |
appImplements(const ACHAR *) const | AcadAppInfo |
appName() const | AcadAppInfo |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
CmdStatus enum name (defined in AcadAppInfo) | AcadAppInfo |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
delFromRegistry(bool bObjDbx=false) (defined in AcadAppInfo) | AcadAppInfo |
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kNoAction enum value (defined in AcadAppInfo) | AcadAppInfo |
kNoModule enum value (defined in AcadAppInfo) | AcadAppInfo |
kRetry enum value (defined in AcadAppInfo) | AcadAppInfo |
kShowMsg enum value (defined in AcadAppInfo) | AcadAppInfo |
LoaderFunPtr typedef (defined in AcadAppInfo) | AcadAppInfo |
loadReason() (defined in AcadAppInfo) | AcadAppInfo |
managed() const (defined in AcadAppInfo) | AcadAppInfo |
moduleName() const | AcadAppInfo |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
readFromRegistry() (defined in AcadAppInfo) | AcadAppInfo |
runAppLoader() (defined in AcadAppInfo) | AcadAppInfo |
setAppDesc(const ACHAR *) | AcadAppInfo |
setAppLoader(LoaderFunPtr) (defined in AcadAppInfo) | AcadAppInfo |
setAppName(const ACHAR *) | AcadAppInfo |
setLoadReason(AcadApp::LoadReasons) (defined in AcadAppInfo) | AcadAppInfo |
setManaged(bool bManaged) (defined in AcadAppInfo) | AcadAppInfo |
setModuleName(const ACHAR *) | AcadAppInfo |
status() const (defined in AcadAppInfo) | AcadAppInfo |
writeCommandNameToRegistry(const ACHAR *globalCmdName, const ACHAR *localCmdName) | AcadAppInfo |
writeGroupNameToRegistry(const ACHAR *group) | AcadAppInfo |
writeToRegistry(bool bObjDbx=false, bool skipHKLM=false) (defined in AcadAppInfo) | AcadAppInfo |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcadAppInfo() (defined in AcadAppInfo) | AcadAppInfo | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Static Public Member Functions | Public Attributes | Protected Attributes | List of all members
AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > Class Template Reference
Misc Classes

Classes

struct TOOL_MAP_ENTRY

Public Member Functions

BOOL | AddChildNode (MSXML::IXMLDOMNode *pNode, LPCWSTR pszChildNodeName, short nNodeType, MSXML::IXMLDOMNode **ppChild)
STDMETHOD() | BeginEdit ()
STDMETHOD() | BeginMultipleEdit (VARIANT tools, VARIANT stockToolIds)
AcTcTool * | CreateCommandToolATC (AcTcPackage *pPalette, LPWSTR szToolName, LPCWSTR szBitmapName, LPWSTR macroString)
AcTcTool * | CreateFlyoutToolATC (AcTcPackage *pPalette, AcTcPackage *pShapePackage, LPCWSTR szToolNameOverride=NULL)
AcTcPalette * | CreatePaletteATC (AcTcCatalog *pCatalog, LPWSTR szPaletteName)
AcTcPackage * | CreateShapeCatalogATC (LPWSTR szShapeName)
AcTcCatalog * | CreateStockToolATC (LPWSTR szCatalogName)
STDMETHOD() | CreateTool (IUnknown **ppTool)
AcTcTool * | CreateToolATC (AcTcPackage *pPalette, LPCWSTR szToolNameOverride=NULL, LPCWSTR szToolImageOverride=NULL, BOOL bImageFile=FALSE)
STDMETHOD() | Customize (int nContextFlag, DWORD_PTR hMenu, UINT idCmdFirst, UINT idCmdLast, GUID *pPaletteId, DWORD *pFlag)
STDMETHOD() | DoModal (BSTR *propValueString, AcDbObjectIdArray *ObjectIdArray)
STDMETHOD() | DragEnter (IDataObject __RPC_FAR *pDataObj, DWORD grfKeyState, POINTL pt, DWORD __RPC_FAR *pdwEffect)
STDMETHOD() | DragLeave (void)
STDMETHOD() | DragOver (DWORD grfKeyState, POINTL pt, DWORD __RPC_FAR *pdwEffect)
STDMETHOD() | Drop (IDataObject __RPC_FAR *pDataObj, DWORD grfKeyState, POINTL pt, DWORD __RPC_FAR *pdwEffect)
STDMETHOD() | dropCallback (AcDbEntity *pEntity)
STDMETHOD() | Dropped (BSTR bstrUrl)
STDMETHOD() | Edit (IUnknown *pProp, LONG_PTR hWndParent, VARIANT_BOOL *pRet)
STDMETHOD() | Editable (DISPID dispID, BOOL __RPC_FAR *bEditable)
STDMETHOD() | EndEdit (VARIANT_BOOL bEditCancelled)
STDMETHOD() | EndMultipleEdit (VARIANT tools, VARIANT stockToolIds, VARIANT_BOOL bEditCancelled)
STDMETHOD() | Execute (LONG_PTR lFlag, DWORD_PTR hWnd, DWORD point, DWORD dwKeyState)
STDMETHOD() | executeCallback ()
STDMETHOD() | get_Color (VARIANT *pVar)
STDMETHOD() | get_EditMode (long *pVal)
STDMETHOD() | get_Flyout (BSTR *pVar)
STDMETHOD() | get_Layer (BSTR *pVal)
BOOL | GetAttribute (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, MSXML::IXMLDOMAttribute **ppChild)
BOOL | GetAttributeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, VARIANT &var)
BOOL | GetAttributeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, long &lValue)
BOOL | GetAttributeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, LPWSTR pszValue)
BOOL | GetAttributeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, short &sValue)
BOOL | GetAttributeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, double &fValue)
BOOL | GetChildNode (MSXML::IXMLDOMNode *pNode, LPCWSTR pszNodeName, MSXML::IXMLDOMNode **ppChild)
BOOL | GetChildNodeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszNodeName, LPWSTR pszValue)
BOOL | GetClipInfo (COleDataObject *pDataObject, ClipboardInfo *pClipboardInfo)
STDMETHOD() | GetCommandString (UINT idCmd, BSTR *pbstrHelpText)
STDMETHOD() | GetContextMenu (INT_PTR nContextFlag, DWORD_PTR hMenu, UINT idCmdFirst, UINT idCmdLast, DWORD_PTR *pFlag)
AcTcPackage * | GetCustomShapePackage (AcTcCatalog *pCatalog, LPCWSTR szPackageName)
AcTcPackage * | GetCustomShapePackage (AcTcCatalog *pCatalog, GUID szPackageID)
STDMETHOD() | GetData (VARIANT *pObjUnkArray, VARIANT *pDynUnkArray)
STDMETHOD() | GetDisplayName (DISPID dispID, BSTR *propName)
STDMETHOD() | GetDisplayString (DISPID dispID, BSTR *pbstr)
STDMETHOD() | GetDragDropContextInfo (IUnknown *pIUnknown, BSTR *pbstrText, DWORD *pFlag)
STDMETHOD() | GetDropTarget (IUnknown **ppDropTarget)
STDMETHOD() | GetEllipsisBitMap (VARIANT varId, IUnknown __RPC_FAR *__RPC_FAR *pBitMap)
BOOL | GetFlyoutTool (AcTcTool *&pFlyoutTool)
STDMETHOD() | GetMenuHelp (UINT idCmd, BSTR *pbstrHelpText)
STDMETHOD() | GetPredefinedStrings (DISPID dispID, CALPOLESTR *pcaStringsOut, CADWORD *pcaCookiesOut)
STDMETHOD() | GetPredefinedValue (DISPID dispID, DWORD dwCookie, VARIANT *pVarOut)
virtual HRESULT | GetPropertyTypeInfo ()
STDMETHOD() | GetPropHelpProc (VARIANT varId, LONG __RPC_FAR *pHelpProc)
STDMETHOD() | GetStockTool (IUnknown **ppToolClass)
IAcadToolProperties * | GetThisToolsProperties ()
STDMETHOD() | GetToolProperties (IUnknown **pToolProp)
HRESULT | GetToolProperty (int index, VARIANT &vValue)
BOOL | GetUnknownArrays (int nCount, IUnknown **pObjUnkArray, VARIANT *pStatUnkArray, VARIANT *pDynPMUnkArrays)
STDMETHOD() | GetUnspecifiedString (VARIANT, BSTR *str)
BOOL | GuidFromString (LPWSTR pszGuid, GUID &id)
STDMETHOD() | InvokeCommand (UINT idCmd, DWORD_PTR hWnd)
STDMETHOD() | InvokeMenuCommand (UINT idCmd, GUID *pPaletteId, DWORD_PTR hWnd, DWORD *pFlag)
STDMETHOD() | IsUnspecifiedAllowed (VARIANT varId, VARIANT_BOOL *pVal)
STDMETHOD() | IsValueUnspecified (VARIANT varId, VARIANT_BOOL *pVal)
STDMETHOD() | Load (IUnknown *pXmlElement)
STDMETHOD() | LoadFromFlyout (IUnknown *pXmlElement)
virtual BOOL | LoadPropertyValue (MSXML::IXMLDOMNode *pNode, int index)
STDMETHOD() | MapPropertyToPage (DISPID dispID, CLSID *pCLSID)
STDMETHOD() | MultipleEdit (VARIANT tools, VARIANT stockToolIds, LONG_PTR hWndParent, VARIANT_BOOL *pRet)
STDMETHOD() | New ()
STDMETHOD() | put_Color (VARIANT pVar)
STDMETHOD() | put_Flyout (BSTR var)
STDMETHOD() | put_Layer (BSTR newVal)
HRESULT | PutToolProperty (int index, VARIANT vValue)
STDMETHOD() | Refreshed (BSTR bstrUrl)
BOOL | RemoveChildren (MSXML::IXMLDOMNode *pNode)
STDMETHOD() | Save (IUnknown *pXmlElement)
virtual BOOL | SavePropertyValue (MSXML::IXMLDOMNode *pNode, int index)
BOOL | SetAttributeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, double fValue)
BOOL | SetAttributeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, long lValue)
BOOL | SetAttributeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, VARIANT &var)
BOOL | SetAttributeValue (MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, LPWSTR pszValue)
STDMETHOD() | SetEditorWindow (LONG_PTR hWndEditor, IUnknown *pPropInspector)
STDMETHOD() | SetFlyoutTools (VARIANT *pFlyoutToolIds)
STDMETHOD() | SetToolProperties (IUnknown *pProp)
STDMETHOD() | SetUnspecified (VARIANT varId, VARIANT_BOOL bIsUnspecified)
STDMETHOD() | ShowProperty (DISPID dispID, BOOL *pShow)
CComBSTR | StringFromGuid (const GUID &id)
STDMETHOD() | UpdateImage (void)
STDMETHOD() | ValidateEditChanges ()

Static Public Member Functions

static PER_PROP_DISP_ENTRY * GetPerPropDisplayArray ()

Public Attributes

DISPID | dispColor
DISPID | dispFlyout
DISPID | dispLayer
bool | m_bFlyout
AcCmColor | m_Color
GUID | m_CurrentShapeId
GUID | m_FlyoutPackageId
WCHAR | m_FlyoutTools [64]
HWND | m_hWndEditWindow
CComPtr< IAcadToolProperties > | m_pToolProp
WCHAR | m_szLayer [512]

Protected Attributes

BOOL | m_bColorUnspecified
BOOL | m_bLayerUnspecified
HWND | m_hPreviewWnd
AcArray< TOOL_MAP_ENTRY > | m_ToolMap
CLIPFORMAT | mcfAutoCAD
The documentation for this class was generated from the following file:
  • AcadToolImpl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > Member List

This is the complete list of members for AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >, including all inherited members.

AcadToolImpl() (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
AddChildNode(MSXML::IXMLDOMNode *pNode, LPCWSTR pszChildNodeName, short nNodeType, MSXML::IXMLDOMNode **ppChild) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
BeginEdit() (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
BeginMultipleEdit(VARIANT tools, VARIANT stockToolIds) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
CreateCommandToolATC(AcTcPackage *pPalette, LPWSTR szToolName, LPCWSTR szBitmapName, LPWSTR macroString) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
CreateFlyoutToolATC(AcTcPackage *pPalette, AcTcPackage *pShapePackage, LPCWSTR szToolNameOverride=NULL) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
CreatePaletteATC(AcTcCatalog *pCatalog, LPWSTR szPaletteName) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
CreateShapeCatalogATC(LPWSTR szShapeName) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
CreateStockToolATC(LPWSTR szCatalogName) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
CreateTool(IUnknown **ppTool) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
CreateToolATC(AcTcPackage *pPalette, LPCWSTR szToolNameOverride=NULL, LPCWSTR szToolImageOverride=NULL, BOOL bImageFile=FALSE) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
Customize(int nContextFlag, DWORD_PTR hMenu, UINT idCmdFirst, UINT idCmdLast, GUID *pPaletteId, DWORD *pFlag) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
dispColor (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
dispFlyout (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
dispLayer (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
DoModal(BSTR *propValueString, AcDbObjectIdArray *ObjectIdArray) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
DragEnter(IDataObject __RPC_FAR *pDataObj, DWORD grfKeyState, POINTL pt, DWORD __RPC_FAR *pdwEffect) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
DragLeave(void) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
DragOver(DWORD grfKeyState, POINTL pt, DWORD __RPC_FAR *pdwEffect) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
Drop(IDataObject __RPC_FAR *pDataObj, DWORD grfKeyState, POINTL pt, DWORD __RPC_FAR *pdwEffect) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
dropCallback(AcDbEntity *pEntity) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
Dropped(BSTR bstrUrl) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
Edit(IUnknown *pProp, LONG_PTR hWndParent, VARIANT_BOOL *pRet) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
Editable(DISPID dispID, BOOL __RPC_FAR *bEditable) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
EndEdit(VARIANT_BOOL bEditCancelled) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
EndMultipleEdit(VARIANT tools, VARIANT stockToolIds, VARIANT_BOOL bEditCancelled) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
Execute(LONG_PTR lFlag, DWORD_PTR hWnd, DWORD point, DWORD dwKeyState) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
executeCallback() (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
get_Color(VARIANT *pVar) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
get_EditMode(long *pVal) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
get_Flyout(BSTR *pVar) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
get_Layer(BSTR *pVal) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetAttribute(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, MSXML::IXMLDOMAttribute **ppChild) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetAttributeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, VARIANT &var) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetAttributeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, long &lValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetAttributeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, LPWSTR pszValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetAttributeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, short &sValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetAttributeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, double &fValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetChildNode(MSXML::IXMLDOMNode *pNode, LPCWSTR pszNodeName, MSXML::IXMLDOMNode **ppChild) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetChildNodeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszNodeName, LPWSTR pszValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetClipInfo(COleDataObject *pDataObject, ClipboardInfo *pClipboardInfo) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetCommandString(UINT idCmd, BSTR *pbstrHelpText) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetContextMenu(INT_PTR nContextFlag, DWORD_PTR hMenu, UINT idCmdFirst, UINT idCmdLast, DWORD_PTR *pFlag) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetCustomShapePackage(AcTcCatalog *pCatalog, LPCWSTR szPackageName) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetCustomShapePackage(AcTcCatalog *pCatalog, GUID szPackageID) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetData(VARIANT *pObjUnkArray, VARIANT *pDynUnkArray) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetDisplayName(DISPID dispID, BSTR *propName) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetDisplayString(DISPID dispID, BSTR *pbstr) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetDragDropContextInfo(IUnknown *pIUnknown, BSTR *pbstrText, DWORD *pFlag) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetDropTarget(IUnknown **ppDropTarget) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetEllipsisBitMap(VARIANT varId, IUnknown __RPC_FAR *__RPC_FAR *pBitMap) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetFlyoutTool(AcTcTool *&pFlyoutTool) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetMenuHelp(UINT idCmd, BSTR *pbstrHelpText) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetPerPropDisplayArray() (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inlinestatic
GetPredefinedStrings(DISPID dispID, CALPOLESTR *pcaStringsOut, CADWORD *pcaCookiesOut) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetPredefinedValue(DISPID dispID, DWORD dwCookie, VARIANT *pVarOut) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetPropertyTypeInfo() (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inlinevirtual
GetPropHelpProc(VARIANT varId, LONG __RPC_FAR *pHelpProc) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetStockTool(IUnknown **ppToolClass) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetThisToolsProperties() (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetToolProperties(IUnknown **pToolProp) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetToolProperty(int index, VARIANT &vValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetUnknownArrays(int nCount, IUnknown **pObjUnkArray, VARIANT *pStatUnkArray, VARIANT *pDynPMUnkArrays) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GetUnspecifiedString(VARIANT, BSTR *str) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
GuidFromString(LPWSTR pszGuid, GUID &id) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
InvokeCommand(UINT idCmd, DWORD_PTR hWnd) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
InvokeMenuCommand(UINT idCmd, GUID *pPaletteId, DWORD_PTR hWnd, DWORD *pFlag) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
IsUnspecifiedAllowed(VARIANT varId, VARIANT_BOOL *pVal) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
IsValueUnspecified(VARIANT varId, VARIANT_BOOL *pVal) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
Load(IUnknown *pXmlElement) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
LoadFromFlyout(IUnknown *pXmlElement) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
LoadPropertyValue(MSXML::IXMLDOMNode *pNode, int index) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inlinevirtual
m_bColorUnspecified (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | protected
m_bFlyout (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
m_bLayerUnspecified (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | protected
m_Color (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
m_CurrentShapeId (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
m_FlyoutPackageId (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
m_FlyoutTools (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
m_hPreviewWnd (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | protected
m_hWndEditWindow (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
m_pToolProp (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
m_szLayer (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
m_ToolMap (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | protected
MapPropertyToPage(DISPID dispID, CLSID *pCLSID) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
mcfAutoCAD (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | protected
MultipleEdit(VARIANT tools, VARIANT stockToolIds, LONG_PTR hWndParent, VARIANT_BOOL *pRet) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
New() (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
put_Color(VARIANT pVar) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
put_Flyout(BSTR var) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
put_Layer(BSTR newVal) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
PutToolProperty(int index, VARIANT vValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
Refreshed(BSTR bstrUrl) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
RemoveChildren(MSXML::IXMLDOMNode *pNode) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
Save(IUnknown *pXmlElement) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
SavePropertyValue(MSXML::IXMLDOMNode *pNode, int index) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inlinevirtual
SetAttributeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, double fValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
SetAttributeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, long lValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
SetAttributeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, VARIANT &var) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
SetAttributeValue(MSXML::IXMLDOMNode *pNode, LPCWSTR pszAttName, LPWSTR pszValue) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
SetEditorWindow(LONG_PTR hWndEditor, IUnknown *pPropInspector) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
SetFlyoutTools(VARIANT *pFlyoutToolIds) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
SetToolProperties(IUnknown *pProp) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
SetUnspecified(VARIANT varId, VARIANT_BOOL bIsUnspecified) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
ShowProperty(DISPID dispID, BOOL *pShow) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
StringFromGuid(const GUID &id) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
UpdateImage(void) (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
ValidateEditChanges() (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline
~AcadToolImpl() (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > | inline


ZRX API Reference: AcArray< T, R > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AcArray< T, R > Class Template Reference
Misc Classes
+ Inheritance diagram for AcArray< T, R >:

Public Member Functions

AcArray (int initPhysicalLength=0, int initGrowLength=8)
AcArray (const AcArray< T, R > &)
int | append (const T &value)
AcArray< T, R > & | append (const AcArray< T, R > &array)
const T * | asArrayPtr () const
T * | asArrayPtr ()
const T & | at (int index) const
T & | at (int index)
bool | contains (const T &value, int start=0) const
bool | find (const T &value, int &foundAt, int start=0) const
int | find (const T &value) const
int | findFrom (const T &value, int start) const
T & | first ()
const T & | first () const
int | growLength () const
AcArray< T, R > & | insertAt (int index, const T &value)
bool | isEmpty () const
T & | last ()
const T & | last () const
int | length () const
int | logicalLength () const
AcArray< T, R > & | operator= (const AcArray< T, R > &)
bool | operator== (const AcArray< T, R > &) const
T & | operator[] (int)
const T & | operator[] (int) const
int | physicalLength () const
bool | remove (const T &value, int start=0)
AcArray< T, R > & | removeAll ()
AcArray< T, R > & | removeAt (int index)
AcArray< T, R > & | removeFirst ()
AcArray< T, R > & | removeLast ()
AcArray< T, R > & | removeSubArray (int startIndex, int endIndex)
AcArray< T, R > & | reverse ()
AcArray< T, R > & | setAll (const T &value)
AcArray< T, R > & | setAt (int index, const T &value)
AcArray< T, R > & | setGrowLength (int)
AcArray< T, R > & | setLogicalLength (int)
AcArray< T, R > & | setPhysicalLength (int)
AcArray< T, R > & | swap (int i1, int i2)

Protected Member Functions

bool isValid (int) const

Protected Attributes

int | mGrowLen
int | mLogicalLen
T * | mpArray
int | mPhysicalLen
The documentation for this class was generated from the following file:
  • acarray.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcArray< T, R > Member List

This is the complete list of members for AcArray< T, R >, including all inherited members.

AcArray(int initPhysicalLength=0, int initGrowLength=8) (defined in AcArray< T, R >) | AcArray< T, R > |
AcArray(const AcArray< T, R > &) (defined in AcArray< T, R >) | AcArray< T, R > |
append(const T &value) (defined in AcArray< T, R >) | AcArray< T, R > | inline
append(const AcArray< T, R > &array) (defined in AcArray< T, R >) | AcArray< T, R > |
asArrayPtr() const (defined in AcArray< T, R >) | AcArray< T, R > | inline
asArrayPtr() (defined in AcArray< T, R >) | AcArray< T, R > | inline
at(int index) const (defined in AcArray< T, R >) | AcArray< T, R > | inline
at(int index) (defined in AcArray< T, R >) | AcArray< T, R > | inline
contains(const T &value, int start=0) const (defined in AcArray< T, R >) | AcArray< T, R > | inline
find(const T &value, int &foundAt, int start=0) const | AcArray< T, R > |
find(const T &value) const | AcArray< T, R > |
findFrom(const T &value, int start) const | AcArray< T, R > |
first() | AcArray< T, R > | inline
first() const | AcArray< T, R > | inline
growLength() const | AcArray< T, R > | inline
insertAt(int index, const T &value) | AcArray< T, R > |
isEmpty() const | AcArray< T, R > | inline
isValid(int) const (defined in AcArray< T, R >) | AcArray< T, R > | inlineprotected
last() | AcArray< T, R > | inline
last() const | AcArray< T, R > | inline
length() const | AcArray< T, R > | inline
logicalLength() const | AcArray< T, R > | inline
mGrowLen (defined in AcArray< T, R >) | AcArray< T, R > | protected
mLogicalLen (defined in AcArray< T, R >) | AcArray< T, R > | protected
mpArray (defined in AcArray< T, R >) | AcArray< T, R > | protected
mPhysicalLen (defined in AcArray< T, R >) | AcArray< T, R > | protected
operator=(const AcArray< T, R > &) | AcArray< T, R > |
operator==(const AcArray< T, R > &) const | AcArray< T, R > |
operator[](int) | AcArray< T, R > | inline
operator[](int) const | AcArray< T, R > | inline
physicalLength() const | AcArray< T, R > | inline
remove(const T &value, int start=0) | AcArray< T, R > |
removeAll() | AcArray< T, R > | inline
removeAt(int index) | AcArray< T, R > |
removeFirst() | AcArray< T, R > | inline
removeLast() | AcArray< T, R > | inline
removeSubArray(int startIndex, int endIndex) | AcArray< T, R > |
reverse() | AcArray< T, R > |
setAll(const T &value) | AcArray< T, R > |
setAt(int index, const T &value) | AcArray< T, R > | inline
setGrowLength(int) | AcArray< T, R > | inline
setLogicalLength(int) | AcArray< T, R > |
setPhysicalLength(int) | AcArray< T, R > |
swap(int i1, int i2) | AcArray< T, R > |
~AcArray() (defined in AcArray< T, R >) | AcArray< T, R > |


ZRX API Reference: AcArrayMemCopyReallocator< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Static Public Member Functions | List of all members
AcArrayMemCopyReallocator< T > Class Template Reference
Misc Classes

Static Public Member Functions

static void reallocateArray (T *pCopy, const T *pSource, int nCount)
The documentation for this class was generated from the following file:
  • acarray.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcArrayMemCopyReallocator< T > Member List

This is the complete list of members for AcArrayMemCopyReallocator< T >, including all inherited members.

reallocateArray(T *pCopy, const T *pSource, int nCount) (defined in AcArrayMemCopyReallocator< T >) AcArrayMemCopyReallocator< T > inlinestatic


ZRX API Reference: AcArrayObjectCopyReallocator< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Static Public Member Functions | List of all members
AcArrayObjectCopyReallocator< T > Class Template Reference
Misc Classes

Static Public Member Functions

static void reallocateArray (T *pCopy, const T *pSource, int nCount)
The documentation for this class was generated from the following file:
  • acarray.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcArrayObjectCopyReallocator< T > Member List

This is the complete list of members for AcArrayObjectCopyReallocator< T >, including all inherited members.

reallocateArray(T *pCopy, const T *pSource, int nCount) (defined in AcArrayObjectCopyReallocator< T >) AcArrayObjectCopyReallocator< T > inlinestatic


ZRX API Reference: AcCFile Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcCFile Class Reference
Misc Classes

Public Member Functions

AcCFile (HANDLE hFile)
AcCFile (LPCTSTR lpszFileName, UINT nOpenFlags)
bool | attachBuffer (void *pBuffer, unsigned nBufSize)
bool | detachBuffer ()
bool | flushBytes ()
unsigned | getCharFormat () const
bool | getExpandLF () const
bool | getUseCIF () const
bool | hasBuffer () const
virtual UINT | Read (void *lpBuf, UINT nCount)
virtual UINT | Read (LPTSTR lpBuf, UINT nCount)
bool | readBOM ()
unsigned | setCharFormat (unsigned nFmt)
bool | setExpandLF (bool bExpandLF)
bool | setUseCIF (bool bUseCIF)
virtual void | Write (const void *lpBuf, UINT nCount)
virtual void | Write (LPCTSTR pString, UINT nCount)
virtual void | Write (LPCTSTR pString)
bool | writeBOM ()
The documentation for this class was generated from the following file:
  • AcCFileWrappers.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCFile Member List

This is the complete list of members for AcCFile, including all inherited members.

AcCFile() (defined in AcCFile) | AcCFile | inline
AcCFile(HANDLE hFile) (defined in AcCFile) | AcCFile | inline
AcCFile(LPCTSTR lpszFileName, UINT nOpenFlags) (defined in AcCFile) | AcCFile | inline
attachBuffer(void *pBuffer, unsigned nBufSize) (defined in AcCFile) | AcCFile | inline
detachBuffer() (defined in AcCFile) | AcCFile | inline
flushBytes() (defined in AcCFile) | AcCFile | inline
getCharFormat() const (defined in AcCFile) | AcCFile | inline
getExpandLF() const (defined in AcCFile) | AcCFile | inline
getUseCIF() const (defined in AcCFile) | AcCFile | inline
hasBuffer() const (defined in AcCFile) | AcCFile | inline
Read(void *lpBuf, UINT nCount) (defined in AcCFile) | AcCFile | inlinevirtual
Read(LPTSTR lpBuf, UINT nCount) (defined in AcCFile) | AcCFile | inlinevirtual
readBOM() (defined in AcCFile) | AcCFile | inline
setCharFormat(unsigned nFmt) (defined in AcCFile) | AcCFile | inline
setExpandLF(bool bExpandLF) (defined in AcCFile) | AcCFile | inline
setUseCIF(bool bUseCIF) (defined in AcCFile) | AcCFile | inline
Write(const void *lpBuf, UINT nCount) (defined in AcCFile) | AcCFile | inlinevirtual
Write(LPCTSTR pString, UINT nCount) (defined in AcCFile) | AcCFile | inlinevirtual
Write(LPCTSTR pString) (defined in AcCFile) | AcCFile | inlinevirtual
writeBOM() (defined in AcCFile) | AcCFile | inline
~AcCFile() (defined in AcCFile) | AcCFile | inlinevirtual


ZRX API Reference: AcCStdioFile Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcCStdioFile Class Reference
Misc Classes

Public Member Functions

AcCStdioFile (FILE *pOpenStream)
AcCStdioFile (LPCTSTR lpszFileName, UINT nOpenFlags)
bool | attachBuffer (void *pBuffer, unsigned nBufSize)
bool | detachBuffer ()
bool | flushBytes ()
unsigned | getCharFormat () const
bool | getExpandLF () const
bool | getUseCIF () const
bool | hasBuffer () const
bool | readBOM ()
virtual LPTSTR | ReadString (LPTSTR lpsz, UINT nMax)
virtual BOOL | ReadString (CString &rString)
unsigned | setCharFormat (unsigned nFmt)
bool | setExpandLF (bool bExpandLF)
bool | setUseCIF (bool bUseCIF)
bool | writeBOM ()
virtual void | WriteString (LPCTSTR lpsz)
The documentation for this class was generated from the following file:
  • AcCFileWrappers.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCStdioFile Member List

This is the complete list of members for AcCStdioFile, including all inherited members.

AcCStdioFile() (defined in AcCStdioFile) | AcCStdioFile | inline
AcCStdioFile(FILE *pOpenStream) (defined in AcCStdioFile) | AcCStdioFile | inline
AcCStdioFile(LPCTSTR lpszFileName, UINT nOpenFlags) (defined in AcCStdioFile) | AcCStdioFile | inline
attachBuffer(void *pBuffer, unsigned nBufSize) (defined in AcCStdioFile) | AcCStdioFile | inline
detachBuffer() (defined in AcCStdioFile) | AcCStdioFile | inline
flushBytes() (defined in AcCStdioFile) | AcCStdioFile | inline
getCharFormat() const (defined in AcCStdioFile) | AcCStdioFile | inline
getExpandLF() const (defined in AcCStdioFile) | AcCStdioFile | inline
getUseCIF() const (defined in AcCStdioFile) | AcCStdioFile | inline
hasBuffer() const (defined in AcCStdioFile) | AcCStdioFile | inline
readBOM() (defined in AcCStdioFile) | AcCStdioFile | inline
ReadString(LPTSTR lpsz, UINT nMax) (defined in AcCStdioFile) | AcCStdioFile | inlinevirtual
ReadString(CString &rString) (defined in AcCStdioFile) | AcCStdioFile | inlinevirtual
setCharFormat(unsigned nFmt) (defined in AcCStdioFile) | AcCStdioFile | inline
setExpandLF(bool bExpandLF) (defined in AcCStdioFile) | AcCStdioFile | inline
setUseCIF(bool bUseCIF) (defined in AcCStdioFile) | AcCStdioFile | inline
writeBOM() (defined in AcCStdioFile) | AcCStdioFile | inline
WriteString(LPCTSTR lpsz) (defined in AcCStdioFile) | AcCStdioFile | inlinevirtual
~AcCStdioFile() (defined in AcCStdioFile) | AcCStdioFile | inlinevirtual


ZRX API Reference: AcFILE Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcFILE Class Reference
Misc Classes

Public Member Functions

AcFILE (FILE *pFILE)
void | attach (FILE *pFILE)
FILE * | detach ()
int | fclose ()
int | fgetc ()
TCHAR * | fgets (TCHAR *pBuf, int nChars)
FILE * | fopen (const TCHAR *pName, const TCHAR *pMode)
int | fprintf (const TCHAR *pFmtStr,...)
int | fputc (TCHAR c)
int | fputs (const TCHAR *pStr)
int | fscanf (const TCHAR *pFmtStr,...)
FILE * | fsopen (const TCHAR *pName, const TCHAR *pMode, int shflag)
unsigned | getCharFormat () const
bool | getExpandLF () const
bool | getUseCIF () const
bool | isOpen () const
FILE * | pFILE () const
bool | readBOM ()
unsigned | setCharFormat (unsigned nFmt)
bool | setExpandLF (bool bExpandLF)
bool | setUseCIF (bool bUseCIF)
int | ungetc (TCHAR c)
int | vfprintf (const TCHAR *pFmtStr, va_list va)
bool | writeBOM ()
The documentation for this class was generated from the following file:
  • AcCrtFileWrappers.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFILE Member List

This is the complete list of members for AcFILE, including all inherited members.

AcFILE() (defined in AcFILE) | AcFILE | inline
AcFILE(FILE *pFILE) (defined in AcFILE) | AcFILE | inline
attach(FILE *pFILE) | AcFILE | inline
detach() (defined in AcFILE) | AcFILE | inline
fclose() (defined in AcFILE) | AcFILE | inline
fgetc() (defined in AcFILE) | AcFILE | inline
fgets(TCHAR *pBuf, int nChars) (defined in AcFILE) | AcFILE | inline
fopen(const TCHAR *pName, const TCHAR *pMode) (defined in AcFILE) | AcFILE | inline
fprintf(const TCHAR *pFmtStr,...) (defined in AcFILE) | AcFILE | inline
fputc(TCHAR c) (defined in AcFILE) | AcFILE | inline
fputs(const TCHAR *pStr) (defined in AcFILE) | AcFILE | inline
fscanf(const TCHAR *pFmtStr,...) (defined in AcFILE) | AcFILE | inline
fsopen(const TCHAR *pName, const TCHAR *pMode, int shflag) (defined in AcFILE) | AcFILE | inline
getCharFormat() const (defined in AcFILE) | AcFILE | inline
getExpandLF() const (defined in AcFILE) | AcFILE | inline
getUseCIF() const (defined in AcFILE) | AcFILE | inline
isOpen() const (defined in AcFILE) | AcFILE | inline
pFILE() const (defined in AcFILE) | AcFILE | inline
readBOM() (defined in AcFILE) | AcFILE | inline
setCharFormat(unsigned nFmt) (defined in AcFILE) | AcFILE | inline
setExpandLF(bool bExpandLF) (defined in AcFILE) | AcFILE | inline
setUseCIF(bool bUseCIF) (defined in AcFILE) | AcFILE | inline
ungetc(TCHAR c) (defined in AcFILE) | AcFILE | inline
vfprintf(const TCHAR *pFmtStr, va_list va) (defined in AcFILE) | AcFILE | inline
writeBOM() (defined in AcFILE) | AcFILE | inline
~AcFILE() (defined in AcFILE) | AcFILE | inline


ZRX API Reference: AcFileDependencyInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcFileDependencyInfo Class Reference
Misc Classes

Public Attributes

bool | mAffectsGraphics
long | mFileSize
long | mIndex
bool | mIsModified
const ACHAR * | mpFeature
const ACHAR * | mpFileName
const ACHAR * | mpFingerprintGuid
const ACHAR * | mpFoundPath
const ACHAR * | mpFullFileName
const ACHAR * | mpVersionGuid
long | mReferenceCount
long | mTimeStamp
The documentation for this class was generated from the following file:
  • AcFileDepMgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFileDependencyInfo Member List

This is the complete list of members for AcFileDependencyInfo, including all inherited members.

mAffectsGraphics (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mFileSize (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mIndex (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mIsModified (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mpFeature (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mpFileName (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mpFingerprintGuid (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mpFoundPath (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mpFullFileName (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mpVersionGuid (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mReferenceCount (defined in AcFileDependencyInfo) | AcFileDependencyInfo
mTimeStamp (defined in AcFileDependencyInfo) | AcFileDependencyInfo


ZRX API Reference: AcFileDependencyManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcFileDependencyManager Class Reference
Misc Classes

Public Member Functions

virtual long | countEntries ()=0
virtual long | createEntry (const ACHAR *feature, const ACHAR *fullFileName, const bool affectsGraphics=false, const bool noIncrement=false)=0
virtual Acad::ErrorStatus | eraseEntry (const ACHAR *feature, const ACHAR *fullFileName, const bool forceRemove=false)=0
virtual Acad::ErrorStatus | eraseEntry (const long index, const bool forceRemove=false)=0
virtual Acad::ErrorStatus | getEntry (const ACHAR *feature, const ACHAR *fullFileName, AcFileDependencyInfo *&fileInfo, const bool useCachedInfo=false)=0
virtual Acad::ErrorStatus | getEntry (const long index, AcFileDependencyInfo *&fileInfo, const bool useCachedInfo=false)=0
virtual void | iteratorInitialize (const ACHAR *feature=NULL, const bool modifiedOnly=false, const bool affectsGraphicsOnly=false, const bool walkXRefTree=false)=0
virtual long | iteratorNext ()=0
virtual Acad::ErrorStatus | updateEntry (const ACHAR *feature, const ACHAR *fullFileName)=0
virtual Acad::ErrorStatus | updateEntry (const long index)=0
The documentation for this class was generated from the following file:
  • AcFileDepMgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFileDependencyManager Member List

This is the complete list of members for AcFileDependencyManager, including all inherited members.

countEntries()=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
createEntry(const ACHAR *feature, const ACHAR *fullFileName, const bool affectsGraphics=false, const bool noIncrement=false)=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
eraseEntry(const ACHAR *feature, const ACHAR *fullFileName, const bool forceRemove=false)=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
eraseEntry(const long index, const bool forceRemove=false)=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
getEntry(const ACHAR *feature, const ACHAR *fullFileName, AcFileDependencyInfo *&fileInfo, const bool useCachedInfo=false)=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
getEntry(const long index, AcFileDependencyInfo *&fileInfo, const bool useCachedInfo=false)=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
iteratorInitialize(const ACHAR *feature=NULL, const bool modifiedOnly=false, const bool affectsGraphicsOnly=false, const bool walkXRefTree=false)=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
iteratorNext()=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
updateEntry(const ACHAR *feature, const ACHAR *fullFileName)=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
updateEntry(const long index)=0 (defined in AcFileDependencyManager) | AcFileDependencyManager | pure virtual
~AcFileDependencyManager() (defined in AcFileDependencyManager) | AcFileDependencyManager | inlinevirtual


ZRX API Reference: AcHeapOperators Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Static Public Member Functions | List of all members
AcHeapOperators Class Reference
Misc Classes
+ Inheritance diagram for AcHeapOperators:

Static Public Member Functions

static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • AcHeapOpers.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcHeapOperators Member List

This is the complete list of members for AcHeapOperators, including all inherited members.

operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic


ZRX API Reference: AcIfstream Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcIfstream Class Reference
Misc Classes

Public Member Functions

class | AcIfstream (const ACHAR *pName)
void | open (const wchar_t *pName)
void | open (const wchar_t *pName, ios_base::openmode nMode)
The documentation for this class was generated from the following file:
  • AcFStream.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcIfstream Member List

This is the complete list of members for AcIfstream, including all inherited members.

AcIfstream() (defined in AcIfstream) | AcIfstream | inline
AcIfstream(const ACHAR *pName) (defined in AcIfstream) | AcIfstream | inline
open(const wchar_t *pName) (defined in AcIfstream) | AcIfstream | inline
open(const wchar_t *pName, ios_base::openmode nMode) (defined in AcIfstream) | AcIfstream | inline


ZRX API Reference: AcLispAppInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcLispAppInfo Class Reference
Misc Classes

Public Attributes

ACHAR | appFileName [_MAX_PATH]
bool | bUnloadable
The documentation for this class was generated from the following file:
  • acdocman.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcLispAppInfo Member List

This is the complete list of members for AcLispAppInfo, including all inherited members.

appFileName (defined in AcLispAppInfo) | AcLispAppInfo
bUnloadable (defined in AcLispAppInfo) | AcLispAppInfo


ZRX API Reference: AcOfstream Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcOfstream Class Reference
Misc Classes

Public Member Functions

class | AcOfstream (const ACHAR *pName)
void | open (const wchar_t *pName)
void | open (const wchar_t *pName, ios_base::openmode nMode)
The documentation for this class was generated from the following file:
  • AcFStream.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcOfstream Member List

This is the complete list of members for AcOfstream, including all inherited members.

AcOfstream() (defined in AcOfstream) | AcOfstream | inline
AcOfstream(const ACHAR *pName) (defined in AcOfstream) | AcOfstream | inline
open(const wchar_t *pName) (defined in AcOfstream) | AcOfstream | inline
open(const wchar_t *pName, ios_base::openmode nMode) (defined in AcOfstream) | AcOfstream | inline


ZRX API Reference: AcOutputBufMgr Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcOutputBufMgr Class Reference
Misc Classes

Public Member Functions

bool | attachBuffer (void *pBuffer, unsigned nBufSize)
unsigned | byteCount () const
bool | detachBuffer ()
bool | hasBuffer () const
void * | pointer () const
void * | requestBytes (unsigned nBytesNeeded)
bool | reset ()
unsigned | takeBytes (unsigned nBytesUsed)
The documentation for this class was generated from the following file:
  • AcCFileWrappers.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcOutputBufMgr Member List

This is the complete list of members for AcOutputBufMgr, including all inherited members.

AcOutputBufMgr() (defined in AcOutputBufMgr) | AcOutputBufMgr | inline
attachBuffer(void *pBuffer, unsigned nBufSize) (defined in AcOutputBufMgr) | AcOutputBufMgr | inline
byteCount() const (defined in AcOutputBufMgr) | AcOutputBufMgr | inline
detachBuffer() (defined in AcOutputBufMgr) | AcOutputBufMgr | inline
hasBuffer() const (defined in AcOutputBufMgr) | AcOutputBufMgr | inline
pointer() const (defined in AcOutputBufMgr) | AcOutputBufMgr | inline
requestBytes(unsigned nBytesNeeded) (defined in AcOutputBufMgr) | AcOutputBufMgr | inline
reset() (defined in AcOutputBufMgr) | AcOutputBufMgr | inline
takeBytes(unsigned nBytesUsed) (defined in AcOutputBufMgr) | AcOutputBufMgr | inline
~AcOutputBufMgr() (defined in AcOutputBufMgr) | AcOutputBufMgr | inline


ZRX API Reference: AcPane Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPane Class Reference
Misc Classes
+ Inheritance diagram for AcPane:

Public Member Functions

virtual UINT | DisplayPopupPaneMenu (CMenu &menu)
virtual HICON | GetIcon () const
virtual int | GetMaxWidth ()
virtual int | GetMinWidth ()
virtual int | GetStyle () const
virtual BOOL | GetText (CString &strText) const
virtual BOOL | SetIcon (HICON hIcon)
virtual BOOL | SetMaxWidth (int cxWidth)
virtual BOOL | SetMinWidth (int cxWidth)
virtual BOOL | SetStyle (int nStyle)
virtual BOOL | SetText (const CString &strText)
- Public Member Functions inherited from AcStatusBarItem
virtual BOOL | ClientToScreen (LPPOINT lpPoint)
virtual BOOL | ClientToScreen (LPRECT lpRect)
virtual BOOL | ContentChanged () const
virtual UINT | DisplayContextMenu (CMenu &menu, CPoint point)
virtual void | Enable (BOOL bValue)
virtual void * | GetInternalData (BOOL bForDocSwitch=TRUE) const
virtual BOOL | GetToolTipText (CString &strText) const
virtual BOOL | IsEnabled ()
virtual BOOL | IsVisible ()
virtual void | OnDelete ()
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
virtual void | OnLButtonDown (UINT nFlags, CPoint point)
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
virtual BOOL | QueryToolTipText (CString &strText) const
virtual BOOL | ScreenToClient (LPPOINT lpPoint)
virtual BOOL | ScreenToClient (LPRECT lpRect)
virtual void | SetContentChanged (BOOL bChanged)
virtual void | SetInternalData (void *pData, BOOL bForDocSwitch=FALSE)
virtual BOOL | SetToolTipText (const CString &strText)
virtual void | SetVisibilityChanged (BOOL bChanged)
virtual void | SetVisible (BOOL bIsVisible)
virtual BOOL | ShowTraySettingsDialog ()
virtual BOOL | VisibilityChanged () const

Member Function Documentation

virtual BOOL AcPane::SetIcon ( HICON hIcon )
virtual
Warning
Not implemented!

Reimplemented from AcStatusBarItem.

The documentation for this class was generated from the following file:
  • acStatusBar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPane Member List

This is the complete list of members for AcPane, including all inherited members.

AcPane() (defined in AcPane) | AcPane |
AcStatusBarItem() (defined in AcStatusBarItem) | AcStatusBarItem |
ClientToScreen(LPPOINT lpPoint) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ClientToScreen(LPRECT lpRect) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ContentChanged() const (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
DisplayContextMenu(CMenu &menu, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
DisplayPopupPaneMenu(CMenu &menu) (defined in AcPane) | AcPane | virtual
Enable(BOOL bValue) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
GetIcon() const (defined in AcPane) | AcPane | virtual
GetInternalData(BOOL bForDocSwitch=TRUE) const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
GetMaxWidth() (defined in AcPane) | AcPane | virtual
GetMinWidth() (defined in AcPane) | AcPane | virtual
GetStyle() const (defined in AcPane) | AcPane | virtual
GetText(CString &strText) const (defined in AcPane) | AcPane | virtual
GetToolTipText(CString &strText) const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
IsEnabled() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
IsVisible() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnDelete() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnLButtonDown(UINT nFlags, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
QueryToolTipText(CString &strText) const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ScreenToClient(LPPOINT lpPoint) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ScreenToClient(LPRECT lpRect) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetContentChanged(BOOL bChanged) (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
SetIcon(HICON hIcon) | AcPane | virtual
SetInternalData(void *pData, BOOL bForDocSwitch=FALSE) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetMaxWidth(int cxWidth) (defined in AcPane) | AcPane | virtual
SetMinWidth(int cxWidth) (defined in AcPane) | AcPane | virtual
SetStyle(int nStyle) (defined in AcPane) | AcPane | virtual
SetText(const CString &strText) (defined in AcPane) | AcPane | virtual
SetToolTipText(const CString &strText) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetVisibilityChanged(BOOL bChanged) (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
SetVisible(BOOL bIsVisible) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ShowTraySettingsDialog() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
VisibilityChanged() const (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
~AcPane() (defined in AcPane) | AcPane | virtual
~AcStatusBarItem() (defined in AcStatusBarItem) | AcStatusBarItem | virtual


ZRX API Reference: AcStatusBarItem Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcStatusBarItem Class Reference
Misc Classes
+ Inheritance diagram for AcStatusBarItem:

Public Member Functions

virtual BOOL | ClientToScreen (LPPOINT lpPoint)
virtual BOOL | ClientToScreen (LPRECT lpRect)
virtual BOOL | ContentChanged () const
virtual UINT | DisplayContextMenu (CMenu &menu, CPoint point)
virtual void | Enable (BOOL bValue)
virtual HICON | GetIcon () const
virtual void * | GetInternalData (BOOL bForDocSwitch=TRUE) const
virtual BOOL | GetToolTipText (CString &strText) const
virtual BOOL | IsEnabled ()
virtual BOOL | IsVisible ()
virtual void | OnDelete ()
virtual void | OnLButtonDblClk (UINT nFlags, CPoint point)
virtual void | OnLButtonDown (UINT nFlags, CPoint point)
virtual void | OnRButtonDown (UINT nFlags, CPoint point)
virtual BOOL | QueryToolTipText (CString &strText) const
virtual BOOL | ScreenToClient (LPPOINT lpPoint)
virtual BOOL | ScreenToClient (LPRECT lpRect)
virtual void | SetContentChanged (BOOL bChanged)
virtual BOOL | SetIcon (HICON hIcon)
virtual void | SetInternalData (void *pData, BOOL bForDocSwitch=FALSE)
virtual BOOL | SetToolTipText (const CString &strText)
virtual void | SetVisibilityChanged (BOOL bChanged)
virtual void | SetVisible (BOOL bIsVisible)
virtual BOOL | ShowTraySettingsDialog ()
virtual BOOL | VisibilityChanged () const
The documentation for this class was generated from the following file:
  • acStatusBar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcStatusBarItem Member List

This is the complete list of members for AcStatusBarItem, including all inherited members.

AcStatusBarItem() (defined in AcStatusBarItem) | AcStatusBarItem |
ClientToScreen(LPPOINT lpPoint) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ClientToScreen(LPRECT lpRect) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ContentChanged() const (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
DisplayContextMenu(CMenu &menu, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
Enable(BOOL bValue) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
GetIcon() const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
GetInternalData(BOOL bForDocSwitch=TRUE) const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
GetToolTipText(CString &strText) const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
IsEnabled() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
IsVisible() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnDelete() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnLButtonDown(UINT nFlags, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
QueryToolTipText(CString &strText) const (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ScreenToClient(LPPOINT lpPoint) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ScreenToClient(LPRECT lpRect) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetContentChanged(BOOL bChanged) (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
SetIcon(HICON hIcon) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetInternalData(void *pData, BOOL bForDocSwitch=FALSE) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetToolTipText(const CString &strText) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
SetVisibilityChanged(BOOL bChanged) (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
SetVisible(BOOL bIsVisible) (defined in AcStatusBarItem) | AcStatusBarItem | virtual
ShowTraySettingsDialog() (defined in AcStatusBarItem) | AcStatusBarItem | virtual
VisibilityChanged() const (defined in AcStatusBarItem) | AcStatusBarItem | inlinevirtual
~AcStatusBarItem() (defined in AcStatusBarItem) | AcStatusBarItem | virtual


ZRX API Reference: AcStatusBarMenuItem Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcStatusBarMenuItem Class Reference
Misc Classes

Public Types

enum AcStatusBarType { kApplicationStatusBar = 0, kDrawingStatusBar = 1 }

Public Member Functions

virtual BOOL | CustomizeMenu (AcStatusBarType nType, CMenu *pMenu, UINT nStartCmdId, UINT nEndCmdId)
virtual BOOL | InvokeMenuCommand (AcStatusBarType nType, UINT nCmdId)
The documentation for this class was generated from the following file:
  • acStatusBar.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcStatusBarMenuItem Member List

This is the complete list of members for AcStatusBarMenuItem, including all inherited members.

AcStatusBarMenuItem() (defined in AcStatusBarMenuItem) | AcStatusBarMenuItem |
AcStatusBarType enum name (defined in AcStatusBarMenuItem) | AcStatusBarMenuItem |
CustomizeMenu(AcStatusBarType nType, CMenu *pMenu, UINT nStartCmdId, UINT nEndCmdId) (defined in AcStatusBarMenuItem) | AcStatusBarMenuItem | virtual
InvokeMenuCommand(AcStatusBarType nType, UINT nCmdId) (defined in AcStatusBarMenuItem) | AcStatusBarMenuItem | virtual
kApplicationStatusBar enum value (defined in AcStatusBarMenuItem) | AcStatusBarMenuItem |
kDrawingStatusBar enum value (defined in AcStatusBarMenuItem) | AcStatusBarMenuItem |
~AcStatusBarMenuItem() (defined in AcStatusBarMenuItem) | AcStatusBarMenuItem | virtual


ZRX API Reference: AcString Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Friends | List of all members
AcString Class Reference
Misc Classes
+ Inheritance diagram for AcString:

Public Types

enum { kAppRes = 0x0001, kSigned = 0x0002, kUnSigned = 0x0003, kHex = 0x0004 }
enum {
kParseZero = 0, kParseMinus1 = 0x01, kParseAssert = 0x02, kParseExcept = 0x04,
kParseNoEmpty = 0x08, kParseDefault = (kParseAssert | kParseZero)
}

Public Member Functions

AcString (char ch)
AcString (wchar_t wch)
AcString (const char *psz)
AcString (const wchar_t *pwsz)
AcString (const AcString &acs)
AcString (int nCtorFlags, unsigned nArg)
AcString (const AcDbHandle &h)
AcString (const CStringW &csw)
AcString & | append (char ch)
AcString & | append (wchar_t wch)
AcString & | append (const char *psz)
AcString & | append (const wchar_t *pwsz)
AcString & | append (const AcString &acs)
AcDbHandle | asAcDbHandle (int nFlags=kParseDefault) const
int | asDeci (int nFlags=kParseDefault) const
__int64 | asDeci64 (int nFlags=kParseDefault) const
int | asHex (int nFlags=kParseDefault) const
__int64 | asHex64 (int nFlags=kParseDefault) const
AcString & | assign (char ch)
AcString & | assign (wchar_t wch)
AcString & | assign (const char *psz)
AcString & | assign (const wchar_t *pwsz)
AcString & | assign (const AcString &acs)
AcString & | assign (const AcDbHandle &h)
unsigned int | asUDeci (int nFlags=kParseDefault) const
unsigned __int64 | asUDeci64 (int nFlags=kParseDefault) const
unsigned int | asUHex (int nFlags=kParseDefault) const
unsigned __int64 | asUHex64 (int nFlags=kParseDefault) const
int | compare (wchar_t wch) const
int | compare (const char *psz) const
int | compare (const wchar_t *pwsz) const
int | compare (const AcString &acs) const
int | compare (const CStringW &csw) const
int | compareNoCase (wchar_t wch) const
int | compareNoCase (const char *psz) const
int | compareNoCase (const wchar_t *pwsz) const
int | compareNoCase (const AcString &acs) const
int | compareNoCase (const CStringW &csw) const
AcString | concat (char ch) const
AcString | concat (wchar_t wch) const
AcString | concat (const char *psz) const
AcString | concat (const wchar_t *pwsz) const
AcString | concat (const AcString &acs) const
const wchar_t * | constPtr () const
int | find (ACHAR ch) const
int | find (const ACHAR *psz) const
int | find (const AcString &acs) const
int | findOneOf (const ACHAR *psz) const
int | findOneOfRev (const ACHAR *psz) const
int | findRev (ACHAR ch) const
int | findRev (const ACHAR *psz) const
int | findRev (const AcString &acs) const
void | format (const ACHAR *pszFmt,...)
void | formatV (const ACHAR *pszFmt, va_list args)
bool | isAscii () const
bool | isEmpty () const
const ACHAR * | kACharPtr () const
const char * | kszPtr () const
const wchar_t * | kTCharPtr () const
const wchar_t * | kwszPtr () const
unsigned | length () const
bool | loadString (unsigned nId)
int | match (const char *psz) const
int | match (const wchar_t *pwsz) const
int | match (const AcString &acs) const
int | match (const CStringW &csw) const
int | matchNoCase (const char *psz) const
int | matchNoCase (const wchar_t *pwsz) const
int | matchNoCase (const AcString &acs) const
int | matchNoCase (const CStringW &csw) const
AcString | mid (int nStart, int nNumChars) const
operator const char * () const
operator const wchar_t * () const
bool | operator!= (wchar_t wch) const
bool | operator!= (const char *psz) const
bool | operator!= (const wchar_t *pwsz) const
bool | operator!= (const AcString &acs) const
bool | operator!= (const CStringW &) const
AcString | operator+ (char ch) const
AcString | operator+ (wchar_t wch) const
AcString | operator+ (const char *psz) const
AcString | operator+ (const wchar_t *pwsz) const
AcString | operator+ (const AcString &acs) const
AcString & | operator+= (char ch)
AcString & | operator+= (wchar_t wch)
AcString & | operator+= (const char *psz)
AcString & | operator+= (const wchar_t *pwsz)
AcString & | operator+= (const AcString &acs)
AcString & | operator+= (const CStringW &csw)
bool | operator< (wchar_t wch) const
bool | operator< (const char *psz) const
bool | operator< (const wchar_t *pwsz) const
bool | operator< (const AcString &acs) const
bool | operator< (const CStringW &) const
bool | operator<= (const char ch) const
bool | operator<= (const wchar_t wch) const
bool | operator<= (const char *psz) const
bool | operator<= (const wchar_t *pwsz) const
bool | operator<= (const AcString &acs) const
bool | operator<= (const CStringW &) const
AcString & | operator= (char ch)
AcString & | operator= (wchar_t wch)
AcString & | operator= (const char *psz)
AcString & | operator= (const wchar_t *pwsz)
AcString & | operator= (const AcString &acs)
AcString & | operator= (const AcDbHandle &h)
AcString & | operator= (const CStringW &csw)
bool | operator== (wchar_t wch) const
bool | operator== (const char *psz) const
bool | operator== (const wchar_t *pwsz) const
bool | operator== (const AcString &acs) const
bool | operator== (const CStringW &) const
bool | operator> (wchar_t wch) const
bool | operator> (const char *psz) const
bool | operator> (const wchar_t *pwsz) const
bool | operator> (const AcString &acs) const
bool | operator> (const CStringW &) const
bool | operator>= (wchar_t wch) const
bool | operator>= (const char *psz) const
bool | operator>= (const wchar_t *pwsz) const
bool | operator>= (const AcString &acs) const
bool | operator>= (const CStringW &) const
AcString | precat (ACHAR ch) const
AcString | precat (const char *psz) const
AcString | precat (const wchar_t *psz) const
AcString & | setEmpty ()
AcString | substr (int numChars) const
AcString | substr (int nStart, int nNumChars) const
AcString | substrRev (int numChars) const
unsigned | tcharLength () const

Friends

class AcStringImp

Additional Inherited Members

- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)

Member Function Documentation

AcString AcString::concat ( wchar_t wch ) const
Warning
Not implemented!
AcString AcString::concat ( const wchar_t * pwsz ) const
Warning
Not implemented!
int AcString::find ( const ACHAR * psz ) const
Warning
Not implemented!
int AcString::find ( const AcString & acs ) const
Warning
Not implemented!
int AcString::findOneOf ( const ACHAR * psz ) const
Warning
Not implemented!
void AcString::formatV | ( | const ACHAR * | pszFmt,
 |  | va_list | args
 | ) |  |
Warning
Not implemented!
AcString AcString::precat ( const wchar_t * psz ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • AcString.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcString Member List

This is the complete list of members for AcString, including all inherited members.

AcString() (defined in AcString) | AcString |
AcString(char ch) (defined in AcString) | AcString |
AcString(wchar_t wch) (defined in AcString) | AcString |
AcString(const char *psz) (defined in AcString) | AcString |
AcString(const wchar_t *pwsz) (defined in AcString) | AcString |
AcString(const AcString &acs) (defined in AcString) | AcString |
AcString(int nCtorFlags, unsigned nArg) (defined in AcString) | AcString |
AcString(const AcDbHandle &h) (defined in AcString) | AcString |
AcString(const CStringW &csw) (defined in AcString) | AcString | inline
AcStringImp (defined in AcString) | AcString | friend
append(char ch) (defined in AcString) | AcString |
append(wchar_t wch) (defined in AcString) | AcString |
append(const char *psz) (defined in AcString) | AcString |
append(const wchar_t *pwsz) (defined in AcString) | AcString |
append(const AcString &acs) (defined in AcString) | AcString |
asAcDbHandle(int nFlags=kParseDefault) const (defined in AcString) | AcString |
asDeci(int nFlags=kParseDefault) const (defined in AcString) | AcString |
asDeci64(int nFlags=kParseDefault) const (defined in AcString) | AcString |
asHex(int nFlags=kParseDefault) const (defined in AcString) | AcString |
asHex64(int nFlags=kParseDefault) const (defined in AcString) | AcString |
assign(char ch) (defined in AcString) | AcString |
assign(wchar_t wch) (defined in AcString) | AcString |
assign(const char *psz) (defined in AcString) | AcString |
assign(const wchar_t *pwsz) (defined in AcString) | AcString |
assign(const AcString &acs) (defined in AcString) | AcString |
assign(const AcDbHandle &h) (defined in AcString) | AcString |
asUDeci(int nFlags=kParseDefault) const (defined in AcString) | AcString |
asUDeci64(int nFlags=kParseDefault) const (defined in AcString) | AcString |
asUHex(int nFlags=kParseDefault) const (defined in AcString) | AcString |
asUHex64(int nFlags=kParseDefault) const (defined in AcString) | AcString |
compare(wchar_t wch) const (defined in AcString) | AcString |
compare(const char *psz) const (defined in AcString) | AcString |
compare(const wchar_t *pwsz) const (defined in AcString) | AcString |
compare(const AcString &acs) const (defined in AcString) | AcString |
compare(const CStringW &csw) const (defined in AcString) | AcString | inline
compareNoCase(wchar_t wch) const (defined in AcString) | AcString |
compareNoCase(const char *psz) const (defined in AcString) | AcString |
compareNoCase(const wchar_t *pwsz) const (defined in AcString) | AcString |
compareNoCase(const AcString &acs) const (defined in AcString) | AcString |
compareNoCase(const CStringW &csw) const (defined in AcString) | AcString | inline
concat(char ch) const (defined in AcString) | AcString |
concat(wchar_t wch) const | AcString |
concat(const char *psz) const (defined in AcString) | AcString |
concat(const wchar_t *pwsz) const | AcString |
concat(const AcString &acs) const (defined in AcString) | AcString |
constPtr() const | AcString | inline
find(ACHAR ch) const (defined in AcString) | AcString |
find(const ACHAR *psz) const | AcString |
find(const AcString &acs) const | AcString |
findOneOf(const ACHAR *psz) const | AcString |
findOneOfRev(const ACHAR *psz) const (defined in AcString) | AcString |
findRev(ACHAR ch) const (defined in AcString) | AcString |
findRev(const ACHAR *psz) const (defined in AcString) | AcString |
findRev(const AcString &acs) const (defined in AcString) | AcString |
format(const ACHAR *pszFmt,...) (defined in AcString) | AcString |
formatV(const ACHAR *pszFmt, va_list args) | AcString |
isAscii() const (defined in AcString) | AcString |
isEmpty() const (defined in AcString) | AcString |
kACharPtr() const (defined in AcString) | AcString | inline
kAppRes enum value (defined in AcString) | AcString |
kHex enum value (defined in AcString) | AcString |
kParseAssert enum value (defined in AcString) | AcString |
kParseDefault enum value (defined in AcString) | AcString |
kParseExcept enum value (defined in AcString) | AcString |
kParseMinus1 enum value (defined in AcString) | AcString |
kParseNoEmpty enum value (defined in AcString) | AcString |
kParseZero enum value (defined in AcString) | AcString |
kSigned enum value (defined in AcString) | AcString |
kszPtr() const (defined in AcString) | AcString |
kTCharPtr() const (defined in AcString) | AcString | inline
kUnSigned enum value (defined in AcString) | AcString |
kwszPtr() const (defined in AcString) | AcString |
length() const (defined in AcString) | AcString |
loadString(unsigned nId) (defined in AcString) | AcString |
match(const char *psz) const (defined in AcString) | AcString |
match(const wchar_t *pwsz) const (defined in AcString) | AcString |
match(const AcString &acs) const (defined in AcString) | AcString |
match(const CStringW &csw) const (defined in AcString) | AcString | inline
matchNoCase(const char *psz) const (defined in AcString) | AcString |
matchNoCase(const wchar_t *pwsz) const (defined in AcString) | AcString |
matchNoCase(const AcString &acs) const (defined in AcString) | AcString |
matchNoCase(const CStringW &csw) const (defined in AcString) | AcString | inline
mid(int nStart, int nNumChars) const (defined in AcString) | AcString | inline
mnPad1 (defined in AcString) | AcString |
mnPad2 (defined in AcString) | AcString |
mpPtrAndData (defined in AcString) | AcString |
mpszData (defined in AcString) | AcString |
mpwszData (defined in AcString) | AcString |
mszStr (defined in AcString) | AcString |
mwszStr (defined in AcString) | AcString |
operator const char *() const (defined in AcString) | AcString | inline
operator const wchar_t *() const (defined in AcString) | AcString | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator!=(wchar_t wch) const (defined in AcString) | AcString | inline
operator!=(const char *psz) const (defined in AcString) | AcString | inline
operator!=(const wchar_t *pwsz) const (defined in AcString) | AcString | inline
operator!=(const AcString &acs) const (defined in AcString) | AcString | inline
operator!=(const CStringW &) const (defined in AcString) | AcString | inline
operator+(char ch) const (defined in AcString) | AcString | inline
operator+(wchar_t wch) const (defined in AcString) | AcString | inline
operator+(const char *psz) const (defined in AcString) | AcString | inline
operator+(const wchar_t *pwsz) const (defined in AcString) | AcString | inline
operator+(const AcString &acs) const (defined in AcString) | AcString | inline
operator+=(char ch) (defined in AcString) | AcString | inline
operator+=(wchar_t wch) (defined in AcString) | AcString | inline
operator+=(const char *psz) (defined in AcString) | AcString | inline
operator+=(const wchar_t *pwsz) (defined in AcString) | AcString | inline
operator+=(const AcString &acs) (defined in AcString) | AcString | inline
operator+=(const CStringW &csw) (defined in AcString) | AcString | inline
operator<(wchar_t wch) const (defined in AcString) | AcString | inline
operator<(const char *psz) const (defined in AcString) | AcString | inline
operator<(const wchar_t *pwsz) const (defined in AcString) | AcString | inline
operator<(const AcString &acs) const (defined in AcString) | AcString | inline
operator<(const CStringW &) const (defined in AcString) | AcString | inline
operator<=(const char ch) const (defined in AcString) | AcString |
operator<=(const wchar_t wch) const (defined in AcString) | AcString | inline
operator<=(const char *psz) const (defined in AcString) | AcString | inline
operator<=(const wchar_t *pwsz) const (defined in AcString) | AcString | inline
operator<=(const AcString &acs) const (defined in AcString) | AcString | inline
operator<=(const CStringW &) const (defined in AcString) | AcString | inline
operator=(char ch) (defined in AcString) | AcString | inline
operator=(wchar_t wch) (defined in AcString) | AcString | inline
operator=(const char *psz) (defined in AcString) | AcString | inline
operator=(const wchar_t *pwsz) (defined in AcString) | AcString | inline
operator=(const AcString &acs) (defined in AcString) | AcString | inline
operator=(const AcDbHandle &h) (defined in AcString) | AcString | inline
operator=(const CStringW &csw) (defined in AcString) | AcString | inline
operator==(wchar_t wch) const (defined in AcString) | AcString | inline
operator==(const char *psz) const (defined in AcString) | AcString | inline
operator==(const wchar_t *pwsz) const (defined in AcString) | AcString | inline
operator==(const AcString &acs) const (defined in AcString) | AcString | inline
operator==(const CStringW &) const (defined in AcString) | AcString | inline
operator>(wchar_t wch) const (defined in AcString) | AcString | inline
operator>(const char *psz) const (defined in AcString) | AcString | inline
operator>(const wchar_t *pwsz) const (defined in AcString) | AcString | inline
operator>(const AcString &acs) const (defined in AcString) | AcString | inline
operator>(const CStringW &) const (defined in AcString) | AcString | inline
operator>=(wchar_t wch) const (defined in AcString) | AcString | inline
operator>=(const char *psz) const (defined in AcString) | AcString | inline
operator>=(const wchar_t *pwsz) const (defined in AcString) | AcString | inline
operator>=(const AcString &acs) const (defined in AcString) | AcString | inline
operator>=(const CStringW &) const (defined in AcString) | AcString | inline
precat(ACHAR ch) const (defined in AcString) | AcString |
precat(const char *psz) const (defined in AcString) | AcString |
precat(const wchar_t *psz) const | AcString |
setEmpty() (defined in AcString) | AcString |
substr(int numChars) const (defined in AcString) | AcString |
substr(int nStart, int nNumChars) const (defined in AcString) | AcString |
substrRev(int numChars) const (defined in AcString) | AcString |
tcharLength() const (defined in AcString) | AcString | inline
~AcString() (defined in AcString) | AcString |


ZRX API Reference: AcUnderlayLayer Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcUnderlayLayer Class Reference
Misc Classes

Public Types

enum State { kOff = 0, kOn = 1 }

Public Member Functions

AcUnderlayLayer ()
AcString | name () const
Acad::ErrorStatus | setName (const AcString &name)
Acad::ErrorStatus | setState (State state)
State | state () const
~AcUnderlayLayer ()

Constructor & Destructor Documentation

AcUnderlayLayer::AcUnderlayLayer ( )
Warning
Not implemented!
AcUnderlayLayer::~AcUnderlayLayer ( )
Warning
Not implemented!

Member Function Documentation

AcString AcUnderlayLayer::name ( ) const
Warning
Not implemented!
Acad::ErrorStatus AcUnderlayLayer::setName ( const AcString & name )
Warning
Not implemented!
Acad::ErrorStatus AcUnderlayLayer::setState ( State state )
Warning
Not implemented!
State AcUnderlayLayer::state ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • dbunderlayhost.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcUnderlayLayer Member List

This is the complete list of members for AcUnderlayLayer, including all inherited members.

AcUnderlayLayer() AcUnderlayLayer
kOff enum value (defined in AcUnderlayLayer) | AcUnderlayLayer
kOn enum value (defined in AcUnderlayLayer) | AcUnderlayLayer
name() const | AcUnderlayLayer
setName(const AcString &name) | AcUnderlayLayer
setState(State state) | AcUnderlayLayer
State enum name (defined in AcUnderlayLayer) | AcUnderlayLayer
state() const | AcUnderlayLayer


ZRX API Reference: AcValue Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | Protected Attributes | Friends | List of all members
AcValue Class Reference
Misc Classes
+ Inheritance diagram for AcValue:

Public Types

enum DataType {
kUnknown = 0, kLong = (0x1 << 0), kDouble = (0x1 << 1), kString = (0x1 << 2),
kDate = (0x1 << 3), kPoint = (0x1 << 4), k3dPoint = (0x1 << 5), kObjectId = (0x1 << 6),
kBuffer = (0x1 << 7), kResbuf = (0x1 << 8), kGeneral = (0x1 << 9), kColor = (0x1 << 10)
}
enum FormatOption {
kFormatOptionNone = 0, kForEditing = (0x1 << 0), kForExpression = (0x1 << 1), kUseMaximumPrecision = (0x1 << 2),
kIgnoreMtextFormat = (0x1 << 3)
}
enum ParseOption {
kParseOptionNone = 0, kSetDefaultFormat = (0x1 << 0), kPreserveMtextFormat = (0x1 << 1), kConvertTextToValue = (0x1 << 2),
kChangeDataType = (0x1 << 3), kParseTextForFieldCode = (0x1 << 4)
}
enum UnitType {
kUnitless = 0, kDistance = (0x1 << 0), kAngle = (0x1 << 1), kArea = (0x1 << 2),
kVolume = (0x1 << 3), kCurrency = (0x1 << 4), kPercentage = (0x1 << 5)
}

Public Member Functions

ACRX_DECLARE_MEMBERS (AcValue)
ACDB_PORT | AcValue (AcValue::DataType nDataType)
ACDB_PORT | AcValue (const AcValue &value)
ACDB_PORT | AcValue (const ACHAR *pszValue)
ACDB_PORT | AcValue (long lValue)
ACDB_PORT | AcValue (double fValue)
ACDB_PORT | AcValue (const __time64_t &date)
ACDB_PORT | AcValue (const SYSTEMTIME &date)
ACDB_PORT | AcValue (const AcGePoint2d &pt)
ACDB_PORT | AcValue (double x, double y)
ACDB_PORT | AcValue (const AcGePoint3d &pt)
ACDB_PORT | AcValue (double x, double y, double z)
ACDB_PORT | AcValue (const AcDbObjectId &id)
ACDB_PORT | AcValue (const resbuf &rb)
ACDB_PORT | AcValue (const AcDbEvalVariant &evalVar)
ACDB_PORT | AcValue (const VARIANT &var)
ACDB_PORT | AcValue (const AcCmColor &var)
ACDB_PORT | AcValue (const void *pBuf, DWORD dwBufSize)
ACDB_PORT bool | convertTo (AcValue::DataType nDataType, AcValue::UnitType nUnitType)
ACDB_PORT bool | convertTo (AcValue::DataType nDataType, AcValue::UnitType nUnitType, bool bResetIfIncompatible)
ACDB_PORT AcValue::DataType | dataType (void) const
Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *pFiler) const
ACDB_PORT const ACHAR * | format (void) const
ACDB_PORT AcString | format (const ACHAR *pszFormat) const
ACDB_PORT bool | format (ACHAR *&pszValue) const
ACDB_PORT bool | format (const ACHAR *pszFormat, ACHAR *&pszValue) const
ACDB_PORT AcString | format (AcValue::FormatOption nOption)
ACDB_PORT AcString | format (const ACHAR *pszFormat, AcValue::FormatOption nOption)
ACDB_PORT bool | get (const ACHAR *&pszValue) const
ACDB_PORT bool | get (ACHAR *&pszValue) const
ACDB_PORT bool | get (long &lValue) const
ACDB_PORT bool | get (double &fValue) const
ACDB_PORT bool | get (__time64_t &date) const
ACDB_PORT bool | get (SYSTEMTIME &date) const
ACDB_PORT bool | get (AcGePoint2d &pt) const
ACDB_PORT bool | get (double &x, double &y) const
ACDB_PORT bool | get (AcGePoint3d &pt) const
ACDB_PORT bool | get (double &x, double &y, double &z) const
ACDB_PORT bool | get (AcDbObjectId &objId) const
ACDB_PORT bool | get (resbuf **pRb) const
ACDB_PORT bool | get (AcDbEvalVariant &evalVar) const
ACDB_PORT bool | get (VARIANT &var) const
ACDB_PORT bool | get (AcCmColor &clr) const
ACDB_PORT bool | get (void *&pBuf, DWORD &dwBufSize) const
ACDB_PORT const ACHAR * | getFormat (void) const
Adesk::Boolean | isEqualTo (const AcRxObject *pOther) const
ACDB_PORT bool | isValid (void) const
ACDB_PORT | operator __time64_t (void) const
ACDB_PORT | operator AcDbObjectId (void) const
ACDB_PORT | operator AcGePoint2d (void) const
ACDB_PORT | operator AcGePoint3d (void) const
ACDB_PORT | operator const ACHAR * (void) const
ACDB_PORT | operator double (void) const
ACDB_PORT | operator long (void) const
ACDB_PORT bool | operator!= (const AcValue &val) const
ACDB_PORT AcValue & | operator= (const AcValue &value)
ACDB_PORT AcValue & | operator= (const ACHAR *pszValue)
ACDB_PORT AcValue & | operator= (long lValue)
ACDB_PORT AcValue & | operator= (double fValue)
ACDB_PORT AcValue & | operator= (__time64_t date)
ACDB_PORT AcValue & | operator= (const AcGePoint2d &pt)
ACDB_PORT AcValue & | operator= (const AcGePoint3d &pt)
ACDB_PORT AcValue & | operator= (const AcDbObjectId &objId)
ACDB_PORT AcValue & | operator= (const resbuf &rb)
ACDB_PORT AcValue & | operator= (const AcDbEvalVariant &evalVar)
ACDB_PORT AcValue & | operator= (const VARIANT &var)
ACDB_PORT AcValue & | operator= (const AcCmColor &clr)
ACDB_PORT bool | operator== (const AcValue &val) const
ACDB_PORT bool | parse (const ACHAR *pszText, AcValue::DataType nDataType, AcValue::UnitType nUnitType, const ACHAR *pszFormat, AcValue::ParseOption nOption, const AcDbObjectId *pTextStyleId)
ACDB_PORT bool | reset (void)
ACDB_PORT bool | reset (AcValue::DataType nDataType)
ACDB_PORT bool | resetValue (void)
ACDB_PORT bool | set (const AcValue &value)
ACDB_PORT bool | set (const ACHAR *pszValue)
ACDB_PORT bool | set (AcValue::DataType nDataType, const ACHAR *pszValue)
ACDB_PORT bool | set (long lValue)
ACDB_PORT bool | set (double fValue)
ACDB_PORT bool | set (const __time64_t &date)
ACDB_PORT bool | set (const SYSTEMTIME &date)
ACDB_PORT bool | set (const AcGePoint2d &pt)
ACDB_PORT bool | set (double x, double y)
ACDB_PORT bool | set (const AcGePoint3d &pt)
ACDB_PORT bool | set (double x, double y, double z)
ACDB_PORT bool | set (const AcDbObjectId &objId)
ACDB_PORT bool | set (const resbuf &rb)
ACDB_PORT bool | set (const AcDbEvalVariant &evalVar)
ACDB_PORT bool | set (const VARIANT &var)
ACDB_PORT bool | set (const AcCmColor &clr)
ACDB_PORT bool | set (const void *pBuf, DWORD dwBufSize)
ACDB_PORT bool | setFormat (const ACHAR *pszFormat)
ACDB_PORT bool | setUnitType (AcValue::UnitType nUnitType)
ACDB_PORT AcValue::UnitType | unitType (void) const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static bool | isValidDataType (const VARIANT &var)
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()

Protected Attributes

void * mpImpObj

Friends

class AcSystemInternals
The documentation for this class was generated from the following file:
  • AcValue.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcValue Member List

This is the complete list of members for AcValue, including all inherited members.

ACRX_DECLARE_MEMBERS(AcValue) (defined in AcValue) | AcValue |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
AcSystemInternals (defined in AcValue) | AcValue | friend
AcValue(void) (defined in AcValue) | AcValue |
AcValue(AcValue::DataType nDataType) (defined in AcValue) | AcValue |
AcValue(const AcValue &value) (defined in AcValue) | AcValue |
AcValue(const ACHAR *pszValue) (defined in AcValue) | AcValue |
AcValue(long lValue) (defined in AcValue) | AcValue |
AcValue(double fValue) (defined in AcValue) | AcValue |
AcValue(const __time64_t &date) (defined in AcValue) | AcValue |
AcValue(const SYSTEMTIME &date) (defined in AcValue) | AcValue |
AcValue(const AcGePoint2d &pt) (defined in AcValue) | AcValue |
AcValue(double x, double y) (defined in AcValue) | AcValue |
AcValue(const AcGePoint3d &pt) (defined in AcValue) | AcValue |
AcValue(double x, double y, double z) (defined in AcValue) | AcValue |
AcValue(const AcDbObjectId &id) (defined in AcValue) | AcValue |
AcValue(const resbuf &rb) (defined in AcValue) | AcValue |
AcValue(const AcDbEvalVariant &evalVar) (defined in AcValue) | AcValue |
AcValue(const VARIANT &var) (defined in AcValue) | AcValue |
AcValue(const AcCmColor &var) (defined in AcValue) | AcValue |
AcValue(const void *pBuf, DWORD dwBufSize) (defined in AcValue) | AcValue |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
convertTo(AcValue::DataType nDataType, AcValue::UnitType nUnitType) (defined in AcValue) | AcValue |
convertTo(AcValue::DataType nDataType, AcValue::UnitType nUnitType, bool bResetIfIncompatible) (defined in AcValue) | AcValue |
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
dataType(void) const (defined in AcValue) | AcValue |
DataType enum name (defined in AcValue) | AcValue |
desc() (defined in AcRxObject) | AcRxObject | static
dwgInFields(AcDbDwgFiler *pFiler) (defined in AcValue) | AcValue |
dwgOutFields(AcDbDwgFiler *pFiler) const (defined in AcValue) | AcValue |
dxfInFields(AcDbDxfFiler *pFiler) (defined in AcValue) | AcValue |
dxfOutFields(AcDbDxfFiler *pFiler) const (defined in AcValue) | AcValue |
format(void) const (defined in AcValue) | AcValue |
format(const ACHAR *pszFormat) const (defined in AcValue) | AcValue |
format(ACHAR *&pszValue) const (defined in AcValue) | AcValue |
format(const ACHAR *pszFormat, ACHAR *&pszValue) const (defined in AcValue) | AcValue |
format(AcValue::FormatOption nOption) (defined in AcValue) | AcValue |
format(const ACHAR *pszFormat, AcValue::FormatOption nOption) (defined in AcValue) | AcValue |
FormatOption enum name (defined in AcValue) | AcValue |
get(const ACHAR *&pszValue) const (defined in AcValue) | AcValue |
get(ACHAR *&pszValue) const (defined in AcValue) | AcValue |
get(long &lValue) const (defined in AcValue) | AcValue |
get(double &fValue) const (defined in AcValue) | AcValue |
get(__time64_t &date) const (defined in AcValue) | AcValue |
get(SYSTEMTIME &date) const (defined in AcValue) | AcValue |
get(AcGePoint2d &pt) const (defined in AcValue) | AcValue |
get(double &x, double &y) const (defined in AcValue) | AcValue |
get(AcGePoint3d &pt) const (defined in AcValue) | AcValue |
get(double &x, double &y, double &z) const (defined in AcValue) | AcValue |
get(AcDbObjectId &objId) const (defined in AcValue) | AcValue |
get(resbuf **pRb) const (defined in AcValue) | AcValue |
get(AcDbEvalVariant &evalVar) const (defined in AcValue) | AcValue |
get(VARIANT &var) const (defined in AcValue) | AcValue |
get(AcCmColor &clr) const (defined in AcValue) | AcValue |
get(void *&pBuf, DWORD &dwBufSize) const (defined in AcValue) | AcValue |
getFormat(void) const (defined in AcValue) | AcValue |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *pOther) const (defined in AcValue) | AcValue | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isValid(void) const (defined in AcValue) | AcValue |
isValidDataType(const VARIANT &var) (defined in AcValue) | AcValue | static
k3dPoint enum value (defined in AcValue) | AcValue |
kAngle enum value (defined in AcValue) | AcValue |
kArea enum value (defined in AcValue) | AcValue |
kBuffer enum value (defined in AcValue) | AcValue |
kChangeDataType enum value (defined in AcValue) | AcValue |
kColor enum value (defined in AcValue) | AcValue |
kConvertTextToValue enum value (defined in AcValue) | AcValue |
kCurrency enum value (defined in AcValue) | AcValue |
kDate enum value (defined in AcValue) | AcValue |
kDistance enum value (defined in AcValue) | AcValue |
kDouble enum value (defined in AcValue) | AcValue |
kForEditing enum value (defined in AcValue) | AcValue |
kForExpression enum value (defined in AcValue) | AcValue |
kFormatOptionNone enum value (defined in AcValue) | AcValue |
kGeneral enum value (defined in AcValue) | AcValue |
kIgnoreMtextFormat enum value (defined in AcValue) | AcValue |
kLong enum value (defined in AcValue) | AcValue |
kObjectId enum value (defined in AcValue) | AcValue |
kParseOptionNone enum value (defined in AcValue) | AcValue |
kParseTextForFieldCode enum value (defined in AcValue) | AcValue |
kPercentage enum value (defined in AcValue) | AcValue |
kPoint enum value (defined in AcValue) | AcValue |
kPreserveMtextFormat enum value (defined in AcValue) | AcValue |
kResbuf enum value (defined in AcValue) | AcValue |
kSetDefaultFormat enum value (defined in AcValue) | AcValue |
kString enum value (defined in AcValue) | AcValue |
kUnitless enum value (defined in AcValue) | AcValue |
kUnknown enum value (defined in AcValue) | AcValue |
kUseMaximumPrecision enum value (defined in AcValue) | AcValue |
kVolume enum value (defined in AcValue) | AcValue |
mpImpObj (defined in AcValue) | AcValue | protected
operator __time64_t(void) const (defined in AcValue) | AcValue |
operator AcDbObjectId(void) const (defined in AcValue) | AcValue |
operator AcGePoint2d(void) const (defined in AcValue) | AcValue |
operator AcGePoint3d(void) const (defined in AcValue) | AcValue |
operator const ACHAR *(void) const (defined in AcValue) | AcValue |
operator double(void) const (defined in AcValue) | AcValue |
operator long(void) const (defined in AcValue) | AcValue |
operator!=(const AcValue &val) const (defined in AcValue) | AcValue |
operator=(const AcValue &value) (defined in AcValue) | AcValue |
operator=(const ACHAR *pszValue) (defined in AcValue) | AcValue |
operator=(long lValue) (defined in AcValue) | AcValue |
operator=(double fValue) (defined in AcValue) | AcValue |
operator=(__time64_t date) (defined in AcValue) | AcValue |
operator=(const AcGePoint2d &pt) (defined in AcValue) | AcValue |
operator=(const AcGePoint3d &pt) (defined in AcValue) | AcValue |
operator=(const AcDbObjectId &objId) (defined in AcValue) | AcValue |
operator=(const resbuf &rb) (defined in AcValue) | AcValue |
operator=(const AcDbEvalVariant &evalVar) (defined in AcValue) | AcValue |
operator=(const VARIANT &var) (defined in AcValue) | AcValue |
operator=(const AcCmColor &clr) (defined in AcValue) | AcValue |
operator==(const AcValue &val) const (defined in AcValue) | AcValue |
parse(const ACHAR *pszText, AcValue::DataType nDataType, AcValue::UnitType nUnitType, const ACHAR *pszFormat, AcValue::ParseOption nOption, const AcDbObjectId *pTextStyleId) (defined in AcValue) | AcValue |
ParseOption enum name (defined in AcValue) | AcValue |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reset(void) (defined in AcValue) | AcValue |
reset(AcValue::DataType nDataType) (defined in AcValue) | AcValue |
resetValue(void) (defined in AcValue) | AcValue |
set(const AcValue &value) (defined in AcValue) | AcValue |
set(const ACHAR *pszValue) (defined in AcValue) | AcValue |
set(AcValue::DataType nDataType, const ACHAR *pszValue) (defined in AcValue) | AcValue |
set(long lValue) (defined in AcValue) | AcValue |
set(double fValue) (defined in AcValue) | AcValue |
set(const __time64_t &date) (defined in AcValue) | AcValue |
set(const SYSTEMTIME &date) (defined in AcValue) | AcValue |
set(const AcGePoint2d &pt) (defined in AcValue) | AcValue |
set(double x, double y) (defined in AcValue) | AcValue |
set(const AcGePoint3d &pt) (defined in AcValue) | AcValue |
set(double x, double y, double z) (defined in AcValue) | AcValue |
set(const AcDbObjectId &objId) (defined in AcValue) | AcValue |
set(const resbuf &rb) (defined in AcValue) | AcValue |
set(const AcDbEvalVariant &evalVar) (defined in AcValue) | AcValue |
set(const VARIANT &var) (defined in AcValue) | AcValue |
set(const AcCmColor &clr) (defined in AcValue) | AcValue |
set(const void *pBuf, DWORD dwBufSize) (defined in AcValue) | AcValue |
setFormat(const ACHAR *pszFormat) (defined in AcValue) | AcValue |
setUnitType(AcValue::UnitType nUnitType) (defined in AcValue) | AcValue |
UnitType enum name (defined in AcValue) | AcValue |
unitType(void) const (defined in AcValue) | AcValue |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~AcValue(void) (defined in AcValue) | AcValue |


ZRX API Reference: AdCharFormatter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AdCharFormatter Class Reference
Misc Classes

Public Types

enum {
kUnknown = 0, kAnsi, kUtf8, kUtf16LE,
kUtf16BE, kUtf32LE, kUtf32BE
}
enum { kNoBestFitFlag = 0x0400, kCIFLen = 7, kMIFLen = 8 }

Public Member Functions

AdCharFormatter (unsigned nFormat, bool bUseCIF, bool bExpandLF)
bool | getExpandLF () const
unsigned | getFormat () const
bool | getUseCIF () const
bool | setExpandLF (bool bExpandLF)
unsigned | setFormat (unsigned nFormat)
bool | setUseCIF (bool bUseCIF)
unsigned | wcharToBytes (wchar_t wch, char *pDestBuf, unsigned nDestBufSize) const

Static Public Member Functions

static int | getBOM (unsigned &nBom, unsigned nFmt)
template<class ChType >
static unsigned | getMIFCodePage (ChType ch)
template<class ChType >
static bool | isCIFString (const ChType *pSrcBuf)
template<class ChType >
static bool | isCIFString (const ChType *pSrcBuf, unsigned nSrcBufSize)
template<class ChType >
static bool | isHex (ChType ch)
template<class ChType >
static bool | isHex (ChType ch, unsigned &uVal)
template<class ChType >
static bool | isMIFString (const ChType *pSrcBuf)
template<class ChType >
static bool | isMIFString (const ChType *pSrcBuf, unsigned nSrcBufSize)
static int | isNativeToCodePage (wchar_t wch, unsigned nCodePage, char *pChNative=NULL)
static unsigned | lookupBOM (unsigned nBom)
static unsigned char | MIFIndexFromWinCodePage (unsigned nCodePage)
template<class ChType >
static bool | parseCIF (const ChType *pSrcBuf, wchar_t &wch)
template<class ChType >
static bool | parseMIF (const ChType *pSrcBuf, wchar_t &wch)
template<class ChType >
static void | putCIF (wchar_t wch, ChType *pDest)
template<class ChType >
static bool | putMIF (wchar_t wch, ChType *pMbOut, unsigned nWinCodePage)
static int | wcharFromCIFMIF (const wchar_t *szSrc, wchar_t *szDst, int cchDstSize)
static int | wcharNonNativeToCIF (const wchar_t *szSrc, wchar_t *szDst, int cchDstSize)
static int | wcharNonNativeToRTF (unsigned nCodePage, const wchar_t *szSrc, int cchSrcLen, char *szDst, int *pcbDstSize)
static unsigned | wcharToAnsiOrUtf8 (wchar_t wch, char *pDestBuf, unsigned nDestBufSize, bool bToAnsi, bool bUseCIF, bool bExpandLF)
static unsigned | wcharToUtf16 (wchar_t wch, char *pDestBuf, unsigned nDestBufSize, bool bLittleEndian, bool bExpandLF)
static unsigned | wcsLength (const wchar_t *pStr)
static unsigned | winCodePageFromMIFIndex (unsigned nIdx)
The documentation for this class was generated from the following file:
  • AdCharFmt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AdCharFormatter Member List

This is the complete list of members for AdCharFormatter, including all inherited members.

AdCharFormatter(unsigned nFormat, bool bUseCIF, bool bExpandLF) (defined in AdCharFormatter) | AdCharFormatter | inline
AdCharFormatter() (defined in AdCharFormatter) | AdCharFormatter | inline
getBOM(unsigned &nBom, unsigned nFmt) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
getExpandLF() const (defined in AdCharFormatter) | AdCharFormatter | inline
getFormat() const (defined in AdCharFormatter) | AdCharFormatter | inline
getMIFCodePage(ChType ch) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
getUseCIF() const (defined in AdCharFormatter) | AdCharFormatter | inline
isCIFString(const ChType *pSrcBuf) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
isCIFString(const ChType *pSrcBuf, unsigned nSrcBufSize) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
isHex(ChType ch) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
isHex(ChType ch, unsigned &uVal) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
isMIFString(const ChType *pSrcBuf) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
isMIFString(const ChType *pSrcBuf, unsigned nSrcBufSize) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
isNativeToCodePage(wchar_t wch, unsigned nCodePage, char *pChNative=NULL) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
kAnsi enum value (defined in AdCharFormatter) | AdCharFormatter |
kCIFLen enum value (defined in AdCharFormatter) | AdCharFormatter |
kMIFLen enum value (defined in AdCharFormatter) | AdCharFormatter |
kNoBestFitFlag enum value (defined in AdCharFormatter) | AdCharFormatter |
kUnknown enum value (defined in AdCharFormatter) | AdCharFormatter |
kUtf16BE enum value (defined in AdCharFormatter) | AdCharFormatter |
kUtf16LE enum value (defined in AdCharFormatter) | AdCharFormatter |
kUtf32BE enum value (defined in AdCharFormatter) | AdCharFormatter |
kUtf32LE enum value (defined in AdCharFormatter) | AdCharFormatter |
kUtf8 enum value (defined in AdCharFormatter) | AdCharFormatter |
lookupBOM(unsigned nBom) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
MIFIndexFromWinCodePage(unsigned nCodePage) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
parseCIF(const ChType *pSrcBuf, wchar_t &wch) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
parseMIF(const ChType *pSrcBuf, wchar_t &wch) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
putCIF(wchar_t wch, ChType *pDest) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
putMIF(wchar_t wch, ChType *pMbOut, unsigned nWinCodePage) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
setExpandLF(bool bExpandLF) (defined in AdCharFormatter) | AdCharFormatter | inline
setFormat(unsigned nFormat) (defined in AdCharFormatter) | AdCharFormatter | inline
setUseCIF(bool bUseCIF) (defined in AdCharFormatter) | AdCharFormatter | inline
wcharFromCIFMIF(const wchar_t *szSrc, wchar_t *szDst, int cchDstSize) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
wcharNonNativeToCIF(const wchar_t *szSrc, wchar_t *szDst, int cchDstSize) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
wcharNonNativeToRTF(unsigned nCodePage, const wchar_t *szSrc, int cchSrcLen, char *szDst, int *pcbDstSize) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
wcharToAnsiOrUtf8(wchar_t wch, char *pDestBuf, unsigned nDestBufSize, bool bToAnsi, bool bUseCIF, bool bExpandLF) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
wcharToBytes(wchar_t wch, char *pDestBuf, unsigned nDestBufSize) const (defined in AdCharFormatter) | AdCharFormatter | inline
wcharToUtf16(wchar_t wch, char *pDestBuf, unsigned nDestBufSize, bool bLittleEndian, bool bExpandLF) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
wcsLength(const wchar_t *pStr) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic
winCodePageFromMIFIndex(unsigned nIdx) (defined in AdCharFormatter) | AdCharFormatter | inlinestatic


ZRX API Reference: AsdkPromptBase< T, TCLSIDWrapper > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AsdkPromptBase< T, TCLSIDWrapper > Class Template Reference
Misc Classes
+ Inheritance diagram for AsdkPromptBase< T, TCLSIDWrapper >:

Public Member Functions

virtual AcDbObjectId | promptLoop ()
- Public Member Functions inherited from AcEdJig
DragStatus | acquireAngle (double &ang)
DragStatus | acquireAngle (double &ang, const AcGePoint3d &basePnt)
DragStatus | acquireDist (double &dist)
DragStatus | acquireDist (double &dist, const AcGePoint3d &basePnt)
DragStatus | acquirePoint (AcGePoint3d &)
DragStatus | acquirePoint (AcGePoint3d &, const AcGePoint3d &basePnt)
DragStatus | acquireString (ACHAR *str)
ACRX_DECLARE_MEMBERS (AcEdJig)
AcDbObjectId | append ()
virtual AcDbDimDataPtrArray * | dimData (const double dimScale)
const ACHAR * | dispPrompt ()
DragStatus | drag ()
const ACHAR * | keywordList ()
virtual Acad::ErrorStatus | setDimValue (const AcDbDimData *dimData, const double dimValue)
void | setDispPrompt (const ACHAR *,...)
void | setKeywordList (const ACHAR *)
void | setSpecialCursorType (CursorType)
void | setUserInputControls (AcEdJig::UserInputControls)
AcEdJig::CursorType | specialCursorType ()
AcEdJig::UserInputControls | userInputControls ()
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

LPCWSTR | BuildPromptString (int index)
virtual void | constructorCallback ()
virtual bool | defaultValueCallback (int index, LPWSTR szDefaultVal)
virtual AcDbEntity * | entity () const
HRESULT | FinalConstruct ()
void | FinalRelease ()
virtual PROMPT_MAP_ENTRY * | GetPromptMap ()=0
int | GetPromptMapSize ()
HRESULT | GetPropertyTypeInfo ()
virtual HINSTANCE | GetResourceInstance ()=0
virtual void | initSampler ()=0
virtual bool | keywordCallback (int index, TCHAR *kword, void *value)
int | LoadString (UINT uID, LPWSTR szString, int nBufferMax=255)
STDMETHODIMP | OnChanged (DISPID dispId)
STDMETHODIMP | OnRequestEdit (DISPID dispID)
virtual int | promptCallback (int index)
virtual VARTYPE | propertyTypeCallback (int index, VARTYPE varType)
HRESULT | PutProperty (int index)
virtual AcEdJig::DragStatus | sampler ()
virtual AcEdJig::DragStatus | samplerCallback (int index, bool &compareChange)
void | SetDocument (AcApDocument *pDoc)
virtual void | setProperty (int index, VARIANT &var, long val)
virtual void | setProperty (int index, VARIANT &var, short val)
virtual void | setProperty (int index, VARIANT &var, double val)
virtual void | setProperty (int index, VARIANT &var, float val)
virtual void | setProperty (int index, VARIANT &var, TCHAR *val)
virtual void | setProperty (int index, VARIANT &var, AcGePoint3d &val)
virtual void | setProperty (int index, VARIANT &var, AcGePoint2d &val)
void | setPropertyDefault (int i)
virtual void | setPropertyDefaults (int index=-1)
virtual Adesk::Boolean | update ()
virtual bool | updateCallback (int index)

Protected Attributes

double | m_angle
CLSID | m_CLSID_ObjectWrapper
volatile LONG | m_cRef
AcGePoint3d | m_cursor3dPos
double | m_cursorAngle
double | m_cursorDist
AcGePoint2d | m_cursorPos
DWORD | m_dConnectionID
double | m_dist
AcEdJig::CursorType | m_jigCursorType
AcEdJig::UserInputControls | m_jigUserInputControls
CComQIPtr< IAcadBaseObject2 > | m_pBaseObj
CComPtr< IConnectionPoint > | m_pConPt
AcDbDatabase * | m_pDb
AcDbObject * | m_pDbrObject
AcApDocument * | m_pDoc
AcGePoint2d | m_pos
AcGePoint3d | m_pos3d
CComPtr< T > | m_pWrapperObject
TCHAR * | m_szCursorString
TCHAR * | m_szString

Additional Inherited Members

- Public Types inherited from AcEdJig
enum CursorType {
kNoSpecialCursor = -1, kCrosshair = 0, kRectCursor, kRubberBand,
kNotRotated, kTargetBox, kRotatedCrosshair, kCrosshairNoRotate,
kInvisible, kEntitySelect, kParallelogram, kEntitySelectNoPersp,
kPkfirstOrGrips, kCrosshairDashed
}
enum DragStatus {
kModeless = -17, kNoChange = -6, kCancel = -4, kOther = -3,
kNull = -1, kNormal = 0, kKW1, kKW2,
kKW3, kKW4, kKW5, kKW6,
kKW7, kKW8, kKW9
}
enum UserInputControls {
kGovernedByOrthoMode = 0x0001, kNullResponseAccepted = 0x0002, kDontEchoCancelForCtrlC = 0x0004, kDontUpdateLastPoint = 0x0008,
kNoDwgLimitsChecking = 0x0010, kNoZeroResponseAccepted = 0x0020, kNoNegativeResponseAccepted = 0x0040, kAccept3dCoordinates = 0x0080,
kAcceptMouseUpAsPoint = 0x0100, kAnyBlankTerminatesInput = 0x0200, kInitialBlankTerminatesInput = 0x0400, kAcceptOtherInputString = 0x0800,
kGovernedByUCSDetect = 0x1000, kNoZDirectionOrtho = 0x2000
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • AsdkPromptBase.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AsdkPromptBase< T, TCLSIDWrapper > Member List

This is the complete list of members for AsdkPromptBase< T, TCLSIDWrapper >, including all inherited members.

AcEdJig() (defined in AcEdJig) | AcEdJig |
acquireAngle(double &ang) (defined in AcEdJig) | AcEdJig |
acquireAngle(double &ang, const AcGePoint3d &basePnt) (defined in AcEdJig) | AcEdJig |
acquireDist(double &dist) (defined in AcEdJig) | AcEdJig |
acquireDist(double &dist, const AcGePoint3d &basePnt) (defined in AcEdJig) | AcEdJig |
acquirePoint(AcGePoint3d &) (defined in AcEdJig) | AcEdJig |
acquirePoint(AcGePoint3d &, const AcGePoint3d &basePnt) (defined in AcEdJig) | AcEdJig |
acquireString(ACHAR *str) (defined in AcEdJig) | AcEdJig |
ACRX_DECLARE_MEMBERS(AcEdJig) (defined in AcEdJig) | AcEdJig |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
append() (defined in AcEdJig) | AcEdJig |
AsdkPromptBase() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
BuildPromptString(int index) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
constructorCallback() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
CursorType enum name (defined in AcEdJig) | AcEdJig |
defaultValueCallback(int index, LPWSTR szDefaultVal) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
desc() (defined in AcRxObject) | AcRxObject | static
dimData(const double dimScale) (defined in AcEdJig) | AcEdJig | virtual
dispPrompt() (defined in AcEdJig) | AcEdJig |
drag() (defined in AcEdJig) | AcEdJig |
DragStatus enum name (defined in AcEdJig) | AcEdJig |
entity() const (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
FinalConstruct() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
FinalRelease() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
GetPromptMap()=0 (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protectedpure virtual
GetPromptMapSize() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
GetPropertyTypeInfo() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
GetResourceInstance()=0 (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protectedpure virtual
initSampler()=0 (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protectedpure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAccept3dCoordinates enum value (defined in AcEdJig) | AcEdJig |
kAcceptMouseUpAsPoint enum value (defined in AcEdJig) | AcEdJig |
kAcceptOtherInputString enum value (defined in AcEdJig) | AcEdJig |
kAnyBlankTerminatesInput enum value (defined in AcEdJig) | AcEdJig |
kCancel enum value (defined in AcEdJig) | AcEdJig |
kCrosshair enum value (defined in AcEdJig) | AcEdJig |
kCrosshairDashed enum value (defined in AcEdJig) | AcEdJig |
kCrosshairNoRotate enum value (defined in AcEdJig) | AcEdJig |
kDontEchoCancelForCtrlC enum value (defined in AcEdJig) | AcEdJig |
kDontUpdateLastPoint enum value (defined in AcEdJig) | AcEdJig |
kEntitySelect enum value (defined in AcEdJig) | AcEdJig |
kEntitySelectNoPersp enum value (defined in AcEdJig) | AcEdJig |
keywordCallback(int index, TCHAR *kword, void *value) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
keywordList() (defined in AcEdJig) | AcEdJig |
kGovernedByOrthoMode enum value (defined in AcEdJig) | AcEdJig |
kGovernedByUCSDetect enum value (defined in AcEdJig) | AcEdJig |
kInitialBlankTerminatesInput enum value (defined in AcEdJig) | AcEdJig |
kInvisible enum value (defined in AcEdJig) | AcEdJig |
kKW1 enum value (defined in AcEdJig) | AcEdJig |
kKW2 enum value (defined in AcEdJig) | AcEdJig |
kKW3 enum value (defined in AcEdJig) | AcEdJig |
kKW4 enum value (defined in AcEdJig) | AcEdJig |
kKW5 enum value (defined in AcEdJig) | AcEdJig |
kKW6 enum value (defined in AcEdJig) | AcEdJig |
kKW7 enum value (defined in AcEdJig) | AcEdJig |
kKW8 enum value (defined in AcEdJig) | AcEdJig |
kKW9 enum value (defined in AcEdJig) | AcEdJig |
kModeless enum value (defined in AcEdJig) | AcEdJig |
kNoChange enum value (defined in AcEdJig) | AcEdJig |
kNoDwgLimitsChecking enum value (defined in AcEdJig) | AcEdJig |
kNoNegativeResponseAccepted enum value (defined in AcEdJig) | AcEdJig |
kNormal enum value (defined in AcEdJig) | AcEdJig |
kNoSpecialCursor enum value (defined in AcEdJig) | AcEdJig |
kNotRotated enum value (defined in AcEdJig) | AcEdJig |
kNoZDirectionOrtho enum value (defined in AcEdJig) | AcEdJig |
kNoZeroResponseAccepted enum value (defined in AcEdJig) | AcEdJig |
kNull enum value (defined in AcEdJig) | AcEdJig |
kNullResponseAccepted enum value (defined in AcEdJig) | AcEdJig |
kOther enum value (defined in AcEdJig) | AcEdJig |
kParallelogram enum value (defined in AcEdJig) | AcEdJig |
kPkfirstOrGrips enum value (defined in AcEdJig) | AcEdJig |
kRectCursor enum value (defined in AcEdJig) | AcEdJig |
kRotatedCrosshair enum value (defined in AcEdJig) | AcEdJig |
kRubberBand enum value (defined in AcEdJig) | AcEdJig |
kTargetBox enum value (defined in AcEdJig) | AcEdJig |
LoadString(UINT uID, LPWSTR szString, int nBufferMax=255) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
m_angle (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_CLSID_ObjectWrapper (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_cRef (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_cursor3dPos (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_cursorAngle (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_cursorDist (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_cursorPos (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_dConnectionID (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_dist (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_jigCursorType (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_jigUserInputControls (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_pBaseObj (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_pConPt (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_pDb (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_pDbrObject (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_pDoc (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_pos (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_pos3d (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_pWrapperObject (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_szCursorString (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
m_szString (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | protected
OnChanged(DISPID dispId) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
OnRequestEdit(DISPID dispID) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
promptCallback(int index) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
promptLoop() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlinevirtual
propertyTypeCallback(int index, VARTYPE varType) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
PutProperty(int index) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sampler() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
samplerCallback(int index, bool &compareChange) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
setDimValue(const AcDbDimData *dimData, const double dimValue) (defined in AcEdJig) | AcEdJig | virtual
setDispPrompt(const ACHAR *,...) (defined in AcEdJig) | AcEdJig |
SetDocument(AcApDocument *pDoc) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
setKeywordList(const ACHAR *) (defined in AcEdJig) | AcEdJig |
setProperty(int index, VARIANT &var, long val) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
setProperty(int index, VARIANT &var, short val) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
setProperty(int index, VARIANT &var, double val) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
setProperty(int index, VARIANT &var, float val) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
setProperty(int index, VARIANT &var, TCHAR *val) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
setProperty(int index, VARIANT &var, AcGePoint3d &val) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
setProperty(int index, VARIANT &var, AcGePoint2d &val) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
setPropertyDefault(int i) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotected
setPropertyDefaults(int index=-1) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
setSpecialCursorType(CursorType) (defined in AcEdJig) | AcEdJig |
setUserInputControls(AcEdJig::UserInputControls) (defined in AcEdJig) | AcEdJig |
specialCursorType() (defined in AcEdJig) | AcEdJig |
update() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
updateCallback(int index) (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual
userInputControls() (defined in AcEdJig) | AcEdJig |
UserInputControls enum name (defined in AcEdJig) | AcEdJig |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcEdJig() (defined in AcEdJig) | AcEdJig | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~AsdkPromptBase() (defined in AsdkPromptBase< T, TCLSIDWrapper >) | AsdkPromptBase< T, TCLSIDWrapper > | inlineprotectedvirtual


ZRX API Reference: CAcGradientThumbnailEngine Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAcGradientThumbnailEngine Class Reference
Misc Classes

Public Member Functions

virtual Acad::ErrorStatus | gradientThumbnailsDrawBitmap (int gradientNumber, HDC hDC, int xPos, int yPos)=0
virtual Acad::ErrorStatus | gradientThumbnailsRender (void)=0
virtual Acad::ErrorStatus | gradientThumbnailsSetRotation (double angle)=0
virtual Acad::ErrorStatus | gradientThumbnailsSetShift (bool bShifted)=0
virtual Acad::ErrorStatus | gradientThumbnailsSetStartColor (AcCmEntityColor startColor)=0
virtual Acad::ErrorStatus | gradientThumbnailsSetStopColor (AcCmEntityColor stopColor)=0
The documentation for this class was generated from the following file:
  • AcGradThumbEng.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcGradientThumbnailEngine Member List

This is the complete list of members for CAcGradientThumbnailEngine, including all inherited members.

gradientThumbnailsDrawBitmap(int gradientNumber, HDC hDC, int xPos, int yPos)=0 (defined in CAcGradientThumbnailEngine) | CAcGradientThumbnailEngine | pure virtual
gradientThumbnailsRender(void)=0 (defined in CAcGradientThumbnailEngine) | CAcGradientThumbnailEngine | pure virtual
gradientThumbnailsSetRotation(double angle)=0 (defined in CAcGradientThumbnailEngine) | CAcGradientThumbnailEngine | pure virtual
gradientThumbnailsSetShift(bool bShifted)=0 (defined in CAcGradientThumbnailEngine) | CAcGradientThumbnailEngine | pure virtual
gradientThumbnailsSetStartColor(AcCmEntityColor startColor)=0 (defined in CAcGradientThumbnailEngine) | CAcGradientThumbnailEngine | pure virtual
gradientThumbnailsSetStopColor(AcCmEntityColor stopColor)=0 (defined in CAcGradientThumbnailEngine) | CAcGradientThumbnailEngine | pure virtual
~CAcGradientThumbnailEngine() (defined in CAcGradientThumbnailEngine) | CAcGradientThumbnailEngine | inlinevirtual


ZRX API Reference: CAseApiObj Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAseApiObj Class Reference
Misc Classes
+ Inheritance diagram for CAseApiObj:

Public Member Functions

void | appThrow () const
CAseApiObj (CAseApiObj *pObj)
CAseApiObj (CAseApiObj &Obj)
virtual CAseApiObj * | clone () const =0
virtual EAsiBoolean | copyFrom (const CAseApiObj *pObj)
EAsiBoolean | errClear ()
int | errCode (int ErrNum) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, int *pIntValue) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const
const ACHAR * | errDiagParNameCode (int ParNum, int *pParCode, int *pIsStr) const
EAseErrDsc | errDsc (int ErrNum) const
const CAsiException * | errGet () const
EAsiBoolean | errInitAsi (CAsiException *pErr)
EAsiBoolean | errInitAsi (CAsiSQLObject *pSQLObj)
EAsiBoolean | errInitAsi (CAsiSQLObject &sqlObj)
EAsiBoolean | errMsg (int ErrNum, ACHAR *pBuf, int BufLen) const
int | errQty () const
virtual EAsiBoolean | init ()
virtual EAseApiClassId | isA () const =0
virtual EAsiBoolean | isInit () const
virtual CAseApiObj & | operator= (const CAseApiObj &Obj)
virtual int | operator== (const CAseApiObj *pObj) const =0
virtual int | operator== (const CAseApiObj &Obj) const =0
const ACHAR * | version () const
virtual | ~CAseApiObj ()

Protected Member Functions

struct resbuf * | allocAttr (EAseLinkAttr attr, const ACHAR *pStr=NULL) const
struct resbuf * | copyBuf (const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const
struct resbuf * | delAttrPtr (struct resbuf *bufptr, struct resbuf *pAttr) const
void | freeStr (struct resbuf *pBuf) const
CAseAppl * | getAppl () const
struct resbuf * | getAttrPtr (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getAttrType (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getLast (const struct resbuf *bufptr) const
EAsiBoolean | isDiffChar () const
struct resbuf * | nextAttr (const struct resbuf *bufptr) const
EAsiBoolean | parseLisp (struct resbuf *bufptr)
EAsiBoolean | setAttrPtr (struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const

Protected Attributes

void * mpErr

Friends

class | CAseApiErr
class | CAseAppl

Constructor & Destructor Documentation

CAseApiObj::CAseApiObj ( CAseApiObj * pObj )
Warning
Not implemented!
CAseApiObj::CAseApiObj ( CAseApiObj & Obj )
Warning
Not implemented!
virtual CAseApiObj::~CAseApiObj ( )
virtual
Warning
Not implemented!

Member Function Documentation

struct resbuf* CAseApiObj::allocAttr | ( | EAseLinkAttr | attr,
 |  | const ACHAR * | pStr = NULL
 | ) |  | const
 readprotected
Warning
Not implemented!
void CAseApiObj::appThrow ( ) const
Warning
Not implemented!
struct resbuf* CAseApiObj::copyBuf | ( | const struct resbuf * | bufptr,
 |  | const struct resbuf * | pBorder = NULL
 | ) |  | const
 readprotected
Warning
Not implemented!
virtual EAsiBoolean CAseApiObj::copyFrom ( const CAseApiObj * pObj )
virtual
Warning
Not implemented!

Reimplemented in CAseLinkSel, CAseLink, CAseLinkPath, and CAseAppl.

struct resbuf* CAseApiObj::delAttrPtr | ( | struct resbuf * | bufptr,
 |  | struct resbuf * | pAttr
 | ) |  | const
 readprotected
Warning
Not implemented!
EAsiBoolean CAseApiObj::errClear ( )
Warning
Not implemented!
int CAseApiObj::errCode ( int ErrNum ) const
Warning
Not implemented!
EAsiBoolean CAseApiObj::errDiagPar | ( | int | ErrNum,
 |  | int | ParCode,
 |  | int * | pIntValue
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAseApiObj::errDiagPar | ( | int | ErrNum,
 |  | int | ParCode,
 |  | ACHAR * | pStrValue,
 |  | int | BufLen
 | ) |  | const
Warning
Not implemented!
const ACHAR* CAseApiObj::errDiagParNameCode | ( | int | ParNum,
 |  | int * | pParCode,
 |  | int * | pIsStr
 | ) |  | const
Warning
Not implemented!
EAseErrDsc CAseApiObj::errDsc ( int ErrNum ) const
Warning
Not implemented!
const CAsiException* CAseApiObj::errGet ( ) const
Warning
Not implemented!
EAsiBoolean CAseApiObj::errInitAsi ( CAsiException * pErr )
Warning
Not implemented!
EAsiBoolean CAseApiObj::errInitAsi ( CAsiSQLObject * pSQLObj )
Warning
Not implemented!
EAsiBoolean CAseApiObj::errInitAsi ( CAsiSQLObject & sqlObj )
Warning
Not implemented!
EAsiBoolean CAseApiObj::errMsg | ( | int | ErrNum,
 |  | ACHAR * | pBuf,
 |  | int | BufLen
 | ) |  | const
Warning
Not implemented!
int CAseApiObj::errQty ( ) const
Warning
Not implemented!
void CAseApiObj::freeStr ( struct resbuf * pBuf ) const
protected
Warning
Not implemented!
CAseAppl* CAseApiObj::getAppl ( ) const
protected
Warning
Not implemented!
struct resbuf* CAseApiObj::getAttrPtr | ( | const struct resbuf * | bufptr,
 |  | EAseLinkAttr | lattr
 | ) |  | const
 readprotected
Warning
Not implemented!
struct resbuf* CAseApiObj::getAttrType | ( | const struct resbuf * | bufptr,
 |  | EAseLinkAttr | lattr
 | ) |  | const
 readprotected
Warning
Not implemented!
struct resbuf* CAseApiObj::getLast ( const struct resbuf * bufptr ) const
readprotected
Warning
Not implemented!
virtual EAsiBoolean CAseApiObj::init ( )
virtual
Warning
Not implemented!

Reimplemented in CAseLinkSel, CAseLink, CAseLinkPath, and CAseAppl.

EAsiBoolean CAseApiObj::isDiffChar ( ) const
protected
Warning
Not implemented!
virtual EAsiBoolean CAseApiObj::isInit ( ) const
virtual
Warning
Not implemented!

Reimplemented in CAseLinkSel, CAseLink, CAseLinkPath, and CAseAppl.

struct resbuf* CAseApiObj::nextAttr ( const struct resbuf * bufptr ) const
readprotected
Warning
Not implemented!
virtual CAseApiObj& CAseApiObj::operator= ( const CAseApiObj & Obj )
virtual
Warning
Not implemented!

Reimplemented in CAseLinkSel, CAseLink, CAseLinkPath, and CAseAppl.

EAsiBoolean CAseApiObj::parseLisp ( struct resbuf * bufptr )
protected
Warning
Not implemented!
EAsiBoolean CAseApiObj::setAttrPtr | ( | struct resbuf * | bufptr,
 |  | EAseLinkAttr | LinkAttr,
 |  | struct resbuf * | pAttrValue
 | ) |  | const
 protected
Warning
Not implemented!
const ACHAR* CAseApiObj::version ( ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aseclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAseApiObj Member List

This is the complete list of members for CAseApiObj, including all inherited members.

allocAttr(EAseLinkAttr attr, const ACHAR *pStr=NULL) const | CAseApiObj | protected
appThrow() const | CAseApiObj |
CAseApiErr (defined in CAseApiObj) | CAseApiObj | friend
CAseApiObj(CAseApiObj *pObj) | CAseApiObj |
CAseApiObj(CAseApiObj &Obj) | CAseApiObj |
CAseAppl (defined in CAseApiObj) | CAseApiObj | friend
clone() const =0 (defined in CAseApiObj) | CAseApiObj | pure virtual
copyBuf(const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const | CAseApiObj | protected
copyFrom(const CAseApiObj *pObj) | CAseApiObj | virtual
delAttrPtr(struct resbuf *bufptr, struct resbuf *pAttr) const | CAseApiObj | protected
errClear() | CAseApiObj |
errCode(int ErrNum) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, int *pIntValue) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const | CAseApiObj |
errDiagParNameCode(int ParNum, int *pParCode, int *pIsStr) const | CAseApiObj |
errDsc(int ErrNum) const | CAseApiObj |
errGet() const | CAseApiObj |
errInitAsi(CAsiException *pErr) | CAseApiObj |
errInitAsi(CAsiSQLObject *pSQLObj) | CAseApiObj |
errInitAsi(CAsiSQLObject &sqlObj) | CAseApiObj |
errMsg(int ErrNum, ACHAR *pBuf, int BufLen) const | CAseApiObj |
errQty() const | CAseApiObj |
freeStr(struct resbuf *pBuf) const | CAseApiObj | protected
getAppl() const | CAseApiObj | protected
getAttrPtr(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getAttrType(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getLast(const struct resbuf *bufptr) const | CAseApiObj | protected
init() | CAseApiObj | virtual
isA() const =0 (defined in CAseApiObj) | CAseApiObj | pure virtual
isDiffChar() const | CAseApiObj | protected
isInit() const | CAseApiObj | virtual
mpErr (defined in CAseApiObj) | CAseApiObj | protected
nextAttr(const struct resbuf *bufptr) const | CAseApiObj | protected
operator=(const CAseApiObj &Obj) | CAseApiObj | virtual
operator==(const CAseApiObj *pObj) const =0 (defined in CAseApiObj) | CAseApiObj | pure virtual
operator==(const CAseApiObj &Obj) const =0 (defined in CAseApiObj) | CAseApiObj | pure virtual
parseLisp(struct resbuf *bufptr) | CAseApiObj | protected
setAttrPtr(struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const | CAseApiObj | protected
version() const | CAseApiObj |
~CAseApiObj() | CAseApiObj | virtual


ZRX API Reference: CAseAppl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAseAppl Class Reference
Misc Classes
+ Inheritance diagram for CAseAppl:

Public Types

enum ETransactionMode { kTransAutomatic = 0, kTransUserManaged }

Public Member Functions

EAsiBoolean | abortAseTransaction ()
EAsiBoolean | beginAseTransaction ()
CAseAppl (CAseApiObj *pObj=NULL)
CAseAppl (CAseApiObj &Obj)
EAsiBoolean | clearAseErr ()
virtual CAseApiObj * | clone () const
EAsiBoolean | closeDwg (AcDbDatabase *pDwg=WORKINGDWG())
EAsiBoolean | commitAseTransaction ()
CAsiSession * | connectAse (CAsiAppl *pAppl, const TCHAR *pEnvName, const ACHAR *pUserName=NULL, const ACHAR *pPassWord=NULL, EAsiBoolean fPrompt=kAsiFalse)
virtual EAsiBoolean | copyFrom (const CAseApiObj *pObj)
EAsiBoolean | createIndex (AcDbDatabase *pDwg=WORKINGDWG())
LPCTSTR | getAcadDsPath ()
EAsiBoolean | getAseErr ()
ETransactionMode | getAseTransactionMode ()
virtual EAsiBoolean | init ()
virtual EAseApiClassId | isA () const
EAsiBoolean | isDwgLazyOpened (AcDbDatabase *pDwg=WORKINGDWG())
EAsiBoolean | isDwgOpened (AcDbDatabase *pDwg=WORKINGDWG())
EAsiBoolean | isIndexExist (AcDbDatabase *pDwg=NULL)
EAsiBoolean | isIndexUpToDate (AcDbDatabase *pDwg=WORKINGDWG())
virtual EAsiBoolean | isInit () const
EAsiBoolean | loadLinks (AcDbEntity *pObj)
EAsiBoolean | loadLinks (AcDbObjectId objId)
EAsiBoolean | openDwg (AcDbDatabase *pDwg=WORKINGDWG())
EAsiBoolean | openLazyDwg (AcDbDatabase *pDwg=WORKINGDWG())
virtual CAseApiObj & | operator= (const CAseApiObj &Obj)
virtual int | operator== (const CAseApiObj *pObj) const
virtual int | operator== (const CAseApiObj &Obj) const
EAsiBoolean | removeIndex (AcDbDatabase *pDwg=WORKINGDWG())
void | setAseTransactionMode (ETransactionMode eMode)
int | setIndexSaveMode (int mode)
EAsiBoolean | swapBTRIds (AcDbObjectId blockId, AcDbObjectId otherId, AcDbDatabase *pDwg=WORKINGDWG())
EAsiBoolean | swapEntIds (AcDbObjectId objectId, AcDbObjectId otherId, AcDbDatabase *pDwg=WORKINGDWG())
void | term ()
EAsiBoolean | translateDataSource (DatasourceTranslationCode xCode, unsigned int buflen, const ACHAR *szFromEnv, const ACHAR *szFromCat, const ACHAR *szFromSchema, const ACHAR *szFromTable, const ACHAR *szFromLpn, ACHAR *szToEnv, ACHAR *szToCat, ACHAR *szToSchema, ACHAR *szToTable, ACHAR *szToLpn)
virtual | ~CAseAppl ()
- Public Member Functions inherited from CAseApiObj
void | appThrow () const
CAseApiObj (CAseApiObj *pObj)
CAseApiObj (CAseApiObj &Obj)
EAsiBoolean | errClear ()
int | errCode (int ErrNum) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, int *pIntValue) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const
const ACHAR * | errDiagParNameCode (int ParNum, int *pParCode, int *pIsStr) const
EAseErrDsc | errDsc (int ErrNum) const
const CAsiException * | errGet () const
EAsiBoolean | errInitAsi (CAsiException *pErr)
EAsiBoolean | errInitAsi (CAsiSQLObject *pSQLObj)
EAsiBoolean | errInitAsi (CAsiSQLObject &sqlObj)
EAsiBoolean | errMsg (int ErrNum, ACHAR *pBuf, int BufLen) const
int | errQty () const
const ACHAR * | version () const
virtual | ~CAseApiObj ()

Protected Member Functions

EAsiBoolean | addObj (const CAseApiObj *pObj)
struct resbuf * | ase_fromAse (struct resbuf *pBuf)
struct resbuf * | ase_invoke (int funCode, struct resbuf *pParms, void *pErr, void *pAse)
EAsiBoolean | ase_toAse (struct resbuf *pBuf)
struct resbuf * | aseiCallAse (int funCode, struct resbuf *pParms, void *pErr, void *pAcDbDatabase=NULL, EAsiBoolean needFullOpen=kAsiFalse)
EAsiBoolean | mapErrFromAse (void *pAse, void *pErr)
EAsiBoolean | remObj (const CAseApiObj *pObj)
- Protected Member Functions inherited from CAseApiObj
struct resbuf * | allocAttr (EAseLinkAttr attr, const ACHAR *pStr=NULL) const
struct resbuf * | copyBuf (const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const
struct resbuf * | delAttrPtr (struct resbuf *bufptr, struct resbuf *pAttr) const
void | freeStr (struct resbuf *pBuf) const
CAseAppl * | getAppl () const
struct resbuf * | getAttrPtr (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getAttrType (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getLast (const struct resbuf *bufptr) const
EAsiBoolean | isDiffChar () const
struct resbuf * | nextAttr (const struct resbuf *bufptr) const
EAsiBoolean | parseLisp (struct resbuf *bufptr)
EAsiBoolean | setAttrPtr (struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const

Protected Attributes

ETransactionMode | meTransMode
EAsiBoolean | mIsDiffChar
TCHAR * | mpDefChar
void * | mpObjs
void * | mpRes
TCHAR * | mpVersion
- Protected Attributes inherited from CAseApiObj
void * | mpErr

Friends

class | CAseApiErr
class | CAseApiObj
class | CAseLink
class | CAseLinkPath
class | CAseLinkSel

Constructor & Destructor Documentation

CAseAppl::CAseAppl ( CAseApiObj * pObj = NULL )
Warning
Not implemented!
CAseAppl::CAseAppl ( CAseApiObj & Obj )
Warning
Not implemented!
virtual CAseAppl::~CAseAppl ( )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAseAppl::abortAseTransaction ( )
Warning
Not implemented!
EAsiBoolean CAseAppl::addObj ( const CAseApiObj * pObj )
protected
Warning
Not implemented!
struct resbuf* CAseAppl::ase_fromAse ( struct resbuf * pBuf )
readprotected
Warning
Not implemented!
struct resbuf* CAseAppl::ase_invoke | ( | int | funCode,
 |  | struct resbuf * | pParms,
 |  | void * | pErr,
 |  | void * | pAse
 | ) |  |
readprotected
Warning
Not implemented!
EAsiBoolean CAseAppl::ase_toAse ( struct resbuf * pBuf )
protected
Warning
Not implemented!
struct resbuf* CAseAppl::aseiCallAse | ( | int | funCode,
 |  | struct resbuf * | pParms,
 |  | void * | pErr,
 |  | void * | pAcDbDatabase = NULL,
 |  | EAsiBoolean | needFullOpen = kAsiFalse
 | ) |  |
readprotected
Warning
Not implemented!
EAsiBoolean CAseAppl::beginAseTransaction ( )
Warning
Not implemented!
EAsiBoolean CAseAppl::clearAseErr ( )
Warning
Not implemented!
virtual CAseApiObj* CAseAppl::clone ( ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

EAsiBoolean CAseAppl::closeDwg ( AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
EAsiBoolean CAseAppl::commitAseTransaction ( )
Warning
Not implemented!
CAsiSession* CAseAppl::connectAse | ( | CAsiAppl * | pAppl,
 |  | const TCHAR * | pEnvName,
 |  | const ACHAR * | pUserName = NULL,
 |  | const ACHAR * | pPassWord = NULL,
 |  | EAsiBoolean | fPrompt = kAsiFalse
 | ) |  |
Warning
Not implemented!
virtual EAsiBoolean CAseAppl::copyFrom ( const CAseApiObj * pObj )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseAppl::createIndex ( AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
LPCTSTR CAseAppl::getAcadDsPath ( )
Warning
Not implemented!
EAsiBoolean CAseAppl::getAseErr ( )
Warning
Not implemented!
ETransactionMode CAseAppl::getAseTransactionMode ( )
Warning
Not implemented!
virtual EAsiBoolean CAseAppl::init ( )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

virtual EAseApiClassId CAseAppl::isA ( ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

EAsiBoolean CAseAppl::isDwgLazyOpened ( AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
EAsiBoolean CAseAppl::isDwgOpened ( AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
EAsiBoolean CAseAppl::isIndexExist ( AcDbDatabase * pDwg = NULL )
Warning
Not implemented!
EAsiBoolean CAseAppl::isIndexUpToDate ( AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
virtual EAsiBoolean CAseAppl::isInit ( ) const
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseAppl::loadLinks ( AcDbEntity * pObj )
Warning
Not implemented!
EAsiBoolean CAseAppl::loadLinks ( AcDbObjectId objId )
Warning
Not implemented!
EAsiBoolean CAseAppl::mapErrFromAse | ( | void * | pAse,
 |  | void * | pErr
 | ) |  |
protected
Warning
Not implemented!
EAsiBoolean CAseAppl::openDwg ( AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
EAsiBoolean CAseAppl::openLazyDwg ( AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
virtual CAseApiObj& CAseAppl::operator= ( const CAseApiObj & Obj )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

virtual int CAseAppl::operator== ( const CAseApiObj * pObj ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

virtual int CAseAppl::operator== ( const CAseApiObj & Obj ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

EAsiBoolean CAseAppl::remObj ( const CAseApiObj * pObj )
protected
Warning
Not implemented!
EAsiBoolean CAseAppl::removeIndex ( AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
void CAseAppl::setAseTransactionMode ( ETransactionMode eMode )
Warning
Not implemented!
int CAseAppl::setIndexSaveMode ( int mode )
Warning
Not implemented!
EAsiBoolean CAseAppl::swapBTRIds | ( | AcDbObjectId | blockId,
 |  | AcDbObjectId | otherId,
 |  | AcDbDatabase * | pDwg = WORKINGDWG()
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseAppl::swapEntIds | ( | AcDbObjectId | objectId,
 |  | AcDbObjectId | otherId,
 |  | AcDbDatabase * | pDwg = WORKINGDWG()
 | ) |  |
Warning
Not implemented!
void CAseAppl::term ( )
Warning
Not implemented!
EAsiBoolean CAseAppl::translateDataSource | ( | DatasourceTranslationCode | xCode,
 |  | unsigned int | buflen,
 |  | const ACHAR * | szFromEnv,
 |  | const ACHAR * | szFromCat,
 |  | const ACHAR * | szFromSchema,
 |  | const ACHAR * | szFromTable,
 |  | const ACHAR * | szFromLpn,
 |  | ACHAR * | szToEnv,
 |  | ACHAR * | szToCat,
 |  | ACHAR * | szToSchema,
 |  | ACHAR * | szToTable,
 |  | ACHAR * | szToLpn
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aseclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAseAppl Member List

This is the complete list of members for CAseAppl, including all inherited members.

abortAseTransaction() | CAseAppl |
addObj(const CAseApiObj *pObj) | CAseAppl | protected
allocAttr(EAseLinkAttr attr, const ACHAR *pStr=NULL) const | CAseApiObj | protected
appThrow() const | CAseApiObj |
ase_fromAse(struct resbuf *pBuf) | CAseAppl | protected
ase_invoke(int funCode, struct resbuf *pParms, void *pErr, void *pAse) | CAseAppl | protected
ase_toAse(struct resbuf *pBuf) | CAseAppl | protected
aseiCallAse(int funCode, struct resbuf *pParms, void *pErr, void *pAcDbDatabase=NULL, EAsiBoolean needFullOpen=kAsiFalse) | CAseAppl | protected
beginAseTransaction() | CAseAppl |
CAseApiErr (defined in CAseAppl) | CAseAppl | friend
CAseApiObj (defined in CAseAppl) | CAseAppl | friend
CAseApiObj::CAseApiObj(CAseApiObj *pObj) | CAseApiObj |
CAseApiObj::CAseApiObj(CAseApiObj &Obj) | CAseApiObj |
CAseAppl(CAseApiObj *pObj=NULL) | CAseAppl |
CAseAppl(CAseApiObj &Obj) | CAseAppl |
CAseLink (defined in CAseAppl) | CAseAppl | friend
CAseLinkPath (defined in CAseAppl) | CAseAppl | friend
CAseLinkSel (defined in CAseAppl) | CAseAppl | friend
clearAseErr() | CAseAppl |
clone() const | CAseAppl | virtual
closeDwg(AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
commitAseTransaction() | CAseAppl |
connectAse(CAsiAppl *pAppl, const TCHAR *pEnvName, const ACHAR *pUserName=NULL, const ACHAR *pPassWord=NULL, EAsiBoolean fPrompt=kAsiFalse) | CAseAppl |
copyBuf(const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const | CAseApiObj | protected
copyFrom(const CAseApiObj *pObj) | CAseAppl | virtual
createIndex(AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
delAttrPtr(struct resbuf *bufptr, struct resbuf *pAttr) const | CAseApiObj | protected
errClear() | CAseApiObj |
errCode(int ErrNum) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, int *pIntValue) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const | CAseApiObj |
errDiagParNameCode(int ParNum, int *pParCode, int *pIsStr) const | CAseApiObj |
errDsc(int ErrNum) const | CAseApiObj |
errGet() const | CAseApiObj |
errInitAsi(CAsiException *pErr) | CAseApiObj |
errInitAsi(CAsiSQLObject *pSQLObj) | CAseApiObj |
errInitAsi(CAsiSQLObject &sqlObj) | CAseApiObj |
errMsg(int ErrNum, ACHAR *pBuf, int BufLen) const | CAseApiObj |
errQty() const | CAseApiObj |
ETransactionMode enum name (defined in CAseAppl) | CAseAppl |
freeStr(struct resbuf *pBuf) const | CAseApiObj | protected
getAcadDsPath() | CAseAppl |
getAppl() const | CAseApiObj | protected
getAseErr() | CAseAppl |
getAseTransactionMode() | CAseAppl |
getAttrPtr(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getAttrType(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getLast(const struct resbuf *bufptr) const | CAseApiObj | protected
init() | CAseAppl | virtual
isA() const | CAseAppl | virtual
isDiffChar() const | CAseApiObj | protected
isDwgLazyOpened(AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
isDwgOpened(AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
isIndexExist(AcDbDatabase *pDwg=NULL) | CAseAppl |
isIndexUpToDate(AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
isInit() const | CAseAppl | virtual
kTransAutomatic enum value (defined in CAseAppl) | CAseAppl |
kTransUserManaged enum value (defined in CAseAppl) | CAseAppl |
loadLinks(AcDbEntity *pObj) | CAseAppl |
loadLinks(AcDbObjectId objId) | CAseAppl |
mapErrFromAse(void *pAse, void *pErr) | CAseAppl | protected
meTransMode (defined in CAseAppl) | CAseAppl | protected
mIsDiffChar (defined in CAseAppl) | CAseAppl | protected
mpDefChar (defined in CAseAppl) | CAseAppl | protected
mpErr (defined in CAseApiObj) | CAseApiObj | protected
mpObjs (defined in CAseAppl) | CAseAppl | protected
mpRes (defined in CAseAppl) | CAseAppl | protected
mpVersion (defined in CAseAppl) | CAseAppl | protected
nextAttr(const struct resbuf *bufptr) const | CAseApiObj | protected
openDwg(AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
openLazyDwg(AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
operator=(const CAseApiObj &Obj) | CAseAppl | virtual
operator==(const CAseApiObj *pObj) const | CAseAppl | virtual
operator==(const CAseApiObj &Obj) const | CAseAppl | virtual
parseLisp(struct resbuf *bufptr) | CAseApiObj | protected
remObj(const CAseApiObj *pObj) | CAseAppl | protected
removeIndex(AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
setAseTransactionMode(ETransactionMode eMode) | CAseAppl |
setAttrPtr(struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const | CAseApiObj | protected
setIndexSaveMode(int mode) | CAseAppl |
swapBTRIds(AcDbObjectId blockId, AcDbObjectId otherId, AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
swapEntIds(AcDbObjectId objectId, AcDbObjectId otherId, AcDbDatabase *pDwg=WORKINGDWG()) | CAseAppl |
term() | CAseAppl |
translateDataSource(DatasourceTranslationCode xCode, unsigned int buflen, const ACHAR *szFromEnv, const ACHAR *szFromCat, const ACHAR *szFromSchema, const ACHAR *szFromTable, const ACHAR *szFromLpn, ACHAR *szToEnv, ACHAR *szToCat, ACHAR *szToSchema, ACHAR *szToTable, ACHAR *szToLpn) | CAseAppl |
version() const | CAseApiObj |
~CAseApiObj() | CAseApiObj | virtual
~CAseAppl() | CAseAppl | virtual


ZRX API Reference: CAseLink Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAseLink Class Reference
Misc Classes
+ Inheritance diagram for CAseLink:

Public Member Functions

CAseLink (CAseApiObj *pObj)
CAseLink (CAseApiObj &Obj)
virtual CAseApiObj * | clone () const
virtual EAsiBoolean | copyFrom (const CAseApiObj *pObj)
EAsiBoolean | create ()
struct resbuf * | getAttr (EAseLinkAttr LinkAttr) const
EAsiBoolean | getDACols (CAsiRow **pCols) const
EAsiBoolean | getDACols (CAsiColumn **pCols[], int *pColQty) const
const AcDbDatabase * | getDwg () const
EAsiBoolean | getEntity (ads_name EntName) const
LinkID | getId () const
EAsiBoolean | getKey (CAsiRow *pKeyValue) const
EAsiBoolean | getKey (CAsiRow &KeyValue) const
EAsiBoolean | getKey (CAsiColumn *pKeyValue[], int ColQty) const
EAsiBoolean | getName (ACHAR *pBuf, int len) const
int | getNameSize () const
EAseLinkType | getType () const
EAsiBoolean | getXName (ACHAR *pBuf, int len) const
virtual EAsiBoolean | init ()
EAsiBoolean | initDA (const ACHAR *pName, const CAsiRow *pKeyValue, const CAsiRow *pDACols, const struct resbuf *pDAParms)
EAsiBoolean | initDA (const ACHAR *pName, const CAsiRow &KeyValue, const CAsiRow &DACols, const struct resbuf *pDAParms)
EAsiBoolean | initDA (const ACHAR *pName, const CAsiColumn *pKeyValue[], int ColQty, const CAsiColumn *pDACols[], int DAColQty, const struct resbuf *pDAParms)
EAsiBoolean | initEnt (const ACHAR *pName, const CAsiRow *pKeyValue, ads_name EntName)
EAsiBoolean | initEnt (const ACHAR *pName, const CAsiRow &KeyValue, ads_name EntName)
EAsiBoolean | initEnt (const ACHAR *pName, const CAsiColumn *pKeyValue[], int ColQty, ads_name EntName)
EAsiBoolean | initId (LinkID linkId)
EAsiBoolean | initType (EAseLinkType lType)
virtual EAseApiClassId | isA () const
virtual EAsiBoolean | isInit () const
EAsiBoolean | isUpdatable () const
virtual CAseApiObj & | operator= (const CAseApiObj &Obj)
virtual int | operator== (const CAseApiObj *pObj) const
virtual int | operator== (const CAseApiObj &Obj) const
EAsiBoolean | remove ()
EAsiBoolean | setAttr (EAseLinkAttr LinkAttr, const struct resbuf *pAttrValue)
EAsiBoolean | setDACols (const CAsiRow *pCols)
EAsiBoolean | setDACols (const CAsiRow &Cols)
EAsiBoolean | setDACols (CAsiColumn *pCols[], int ColQty)
EAsiBoolean | setDAParms (const struct resbuf *pParms)
EAsiBoolean | setDAValues (const CAsiRow *pDAValues)
EAsiBoolean | setDAValues (const CAsiRow &DAValues)
EAsiBoolean | setDAValues (CAsiColumn *pCols[], int ColQty)
EAsiBoolean | setDwg (const AcDbDatabase *pDwg=WORKINGDWG())
EAsiBoolean | setEntity (ads_name EntName)
EAsiBoolean | setKey (const CAsiRow *pKeyValue)
EAsiBoolean | setKey (const CAsiRow &KeyValue)
EAsiBoolean | setKey (const CAsiColumn *pKeyValue[], int ColQty)
EAsiBoolean | setName (const ACHAR *pName)
EAsiBoolean | update ()
virtual | ~CAseLink ()
- Public Member Functions inherited from CAseApiObj
void | appThrow () const
CAseApiObj (CAseApiObj *pObj)
CAseApiObj (CAseApiObj &Obj)
EAsiBoolean | errClear ()
int | errCode (int ErrNum) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, int *pIntValue) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const
const ACHAR * | errDiagParNameCode (int ParNum, int *pParCode, int *pIsStr) const
EAseErrDsc | errDsc (int ErrNum) const
const CAsiException * | errGet () const
EAsiBoolean | errInitAsi (CAsiException *pErr)
EAsiBoolean | errInitAsi (CAsiSQLObject *pSQLObj)
EAsiBoolean | errInitAsi (CAsiSQLObject &sqlObj)
EAsiBoolean | errMsg (int ErrNum, ACHAR *pBuf, int BufLen) const
int | errQty () const
const ACHAR * | version () const
virtual | ~CAseApiObj ()

Additional Inherited Members

- Protected Member Functions inherited from CAseApiObj
struct resbuf * | allocAttr (EAseLinkAttr attr, const ACHAR *pStr=NULL) const
struct resbuf * | copyBuf (const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const
struct resbuf * | delAttrPtr (struct resbuf *bufptr, struct resbuf *pAttr) const
void | freeStr (struct resbuf *pBuf) const
CAseAppl * | getAppl () const
struct resbuf * | getAttrPtr (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getAttrType (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getLast (const struct resbuf *bufptr) const
EAsiBoolean | isDiffChar () const
struct resbuf * | nextAttr (const struct resbuf *bufptr) const
EAsiBoolean | parseLisp (struct resbuf *bufptr)
EAsiBoolean | setAttrPtr (struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const
- Protected Attributes inherited from CAseApiObj
void * | mpErr

Constructor & Destructor Documentation

CAseLink::CAseLink ( CAseApiObj * pObj )
Warning
Not implemented!
CAseLink::CAseLink ( CAseApiObj & Obj )
Warning
Not implemented!
virtual CAseLink::~CAseLink ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual CAseApiObj* CAseLink::clone ( ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

virtual EAsiBoolean CAseLink::copyFrom ( const CAseApiObj * pObj )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseLink::create ( )
Warning
Not implemented!
struct resbuf* CAseLink::getAttr ( EAseLinkAttr LinkAttr ) const
read
Warning
Not implemented!
EAsiBoolean CAseLink::getDACols ( CAsiRow ** pCols ) const
Warning
Not implemented!
EAsiBoolean CAseLink::getDACols | ( | CAsiColumn ** | pCols[],
 |  | int * | pColQty
 | ) |  | const
Warning
Not implemented!
const AcDbDatabase* CAseLink::getDwg ( ) const
Warning
Not implemented!
EAsiBoolean CAseLink::getEntity ( ads_name EntName ) const
Warning
Not implemented!
LinkID CAseLink::getId ( ) const
Warning
Not implemented!
EAsiBoolean CAseLink::getKey ( CAsiRow * pKeyValue ) const
Warning
Not implemented!
EAsiBoolean CAseLink::getKey ( CAsiRow & KeyValue ) const
Warning
Not implemented!
EAsiBoolean CAseLink::getKey | ( | CAsiColumn * | pKeyValue[],
 |  | int | ColQty
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAseLink::getName | ( | ACHAR * | pBuf,
 |  | int | len
 | ) |  | const
Warning
Not implemented!
int CAseLink::getNameSize ( ) const
Warning
Not implemented!
EAseLinkType CAseLink::getType ( ) const
Warning
Not implemented!
EAsiBoolean CAseLink::getXName | ( | ACHAR * | pBuf,
 |  | int | len
 | ) |  | const
Warning
Not implemented!
virtual EAsiBoolean CAseLink::init ( )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseLink::initDA | ( | const ACHAR * | pName,
 |  | const CAsiRow * | pKeyValue,
 |  | const CAsiRow * | pDACols,
 |  | const struct resbuf * | pDAParms
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::initDA | ( | const ACHAR * | pName,
 |  | const CAsiRow & | KeyValue,
 |  | const CAsiRow & | DACols,
 |  | const struct resbuf * | pDAParms
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::initDA | ( | const ACHAR * | pName,
 |  | const CAsiColumn * | pKeyValue[],
 |  | int | ColQty,
 |  | const CAsiColumn * | pDACols[],
 |  | int | DAColQty,
 |  | const struct resbuf * | pDAParms
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::initEnt | ( | const ACHAR * | pName,
 |  | const CAsiRow * | pKeyValue,
 |  | ads_name | EntName
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::initEnt | ( | const ACHAR * | pName,
 |  | const CAsiRow & | KeyValue,
 |  | ads_name | EntName
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::initEnt | ( | const ACHAR * | pName,
 |  | const CAsiColumn * | pKeyValue[],
 |  | int | ColQty,
 |  | ads_name | EntName
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::initId ( LinkID linkId )
Warning
Not implemented!
EAsiBoolean CAseLink::initType ( EAseLinkType lType )
Warning
Not implemented!
virtual EAseApiClassId CAseLink::isA ( ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

virtual EAsiBoolean CAseLink::isInit ( ) const
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseLink::isUpdatable ( ) const
Warning
Not implemented!
virtual CAseApiObj& CAseLink::operator= ( const CAseApiObj & Obj )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

virtual int CAseLink::operator== ( const CAseApiObj * pObj ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

virtual int CAseLink::operator== ( const CAseApiObj & Obj ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

EAsiBoolean CAseLink::remove ( )
Warning
Not implemented!
EAsiBoolean CAseLink::setAttr | ( | EAseLinkAttr | LinkAttr,
 |  | const struct resbuf * | pAttrValue
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::setDACols ( const CAsiRow * pCols )
Warning
Not implemented!
EAsiBoolean CAseLink::setDACols ( const CAsiRow & Cols )
Warning
Not implemented!
EAsiBoolean CAseLink::setDACols | ( | CAsiColumn * | pCols[],
 |  | int | ColQty
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::setDAParms ( const struct resbuf * pParms )
Warning
Not implemented!
EAsiBoolean CAseLink::setDAValues ( const CAsiRow * pDAValues )
Warning
Not implemented!
EAsiBoolean CAseLink::setDAValues ( const CAsiRow & DAValues )
Warning
Not implemented!
EAsiBoolean CAseLink::setDAValues | ( | CAsiColumn * | pCols[],
 |  | int | ColQty
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::setDwg ( const AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
EAsiBoolean CAseLink::setEntity ( ads_name EntName )
Warning
Not implemented!
EAsiBoolean CAseLink::setKey ( const CAsiRow * pKeyValue )
Warning
Not implemented!
EAsiBoolean CAseLink::setKey ( const CAsiRow & KeyValue )
Warning
Not implemented!
EAsiBoolean CAseLink::setKey | ( | const CAsiColumn * | pKeyValue[],
 |  | int | ColQty
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLink::setName ( const ACHAR * pName )
Warning
Not implemented!
EAsiBoolean CAseLink::update ( )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aseclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAseLink Member List

This is the complete list of members for CAseLink, including all inherited members.

allocAttr(EAseLinkAttr attr, const ACHAR *pStr=NULL) const | CAseApiObj | protected
appThrow() const | CAseApiObj |
CAseApiObj(CAseApiObj *pObj) | CAseApiObj |
CAseApiObj(CAseApiObj &Obj) | CAseApiObj |
CAseLink(CAseApiObj *pObj) | CAseLink |
CAseLink(CAseApiObj &Obj) | CAseLink |
clone() const | CAseLink | virtual
copyBuf(const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const | CAseApiObj | protected
copyFrom(const CAseApiObj *pObj) | CAseLink | virtual
create() | CAseLink |
delAttrPtr(struct resbuf *bufptr, struct resbuf *pAttr) const | CAseApiObj | protected
errClear() | CAseApiObj |
errCode(int ErrNum) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, int *pIntValue) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const | CAseApiObj |
errDiagParNameCode(int ParNum, int *pParCode, int *pIsStr) const | CAseApiObj |
errDsc(int ErrNum) const | CAseApiObj |
errGet() const | CAseApiObj |
errInitAsi(CAsiException *pErr) | CAseApiObj |
errInitAsi(CAsiSQLObject *pSQLObj) | CAseApiObj |
errInitAsi(CAsiSQLObject &sqlObj) | CAseApiObj |
errMsg(int ErrNum, ACHAR *pBuf, int BufLen) const | CAseApiObj |
errQty() const | CAseApiObj |
freeStr(struct resbuf *pBuf) const | CAseApiObj | protected
getAppl() const | CAseApiObj | protected
getAttr(EAseLinkAttr LinkAttr) const | CAseLink |
getAttrPtr(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getAttrType(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getDACols(CAsiRow **pCols) const | CAseLink |
getDACols(CAsiColumn **pCols[], int *pColQty) const | CAseLink |
getDwg() const | CAseLink |
getEntity(ads_name EntName) const | CAseLink |
getId() const | CAseLink |
getKey(CAsiRow *pKeyValue) const | CAseLink |
getKey(CAsiRow &KeyValue) const | CAseLink |
getKey(CAsiColumn *pKeyValue[], int ColQty) const | CAseLink |
getLast(const struct resbuf *bufptr) const | CAseApiObj | protected
getName(ACHAR *pBuf, int len) const | CAseLink |
getNameSize() const | CAseLink |
getType() const | CAseLink |
getXName(ACHAR *pBuf, int len) const | CAseLink |
init() | CAseLink | virtual
initDA(const ACHAR *pName, const CAsiRow *pKeyValue, const CAsiRow *pDACols, const struct resbuf *pDAParms) | CAseLink |
initDA(const ACHAR *pName, const CAsiRow &KeyValue, const CAsiRow &DACols, const struct resbuf *pDAParms) | CAseLink |
initDA(const ACHAR *pName, const CAsiColumn *pKeyValue[], int ColQty, const CAsiColumn *pDACols[], int DAColQty, const struct resbuf *pDAParms) | CAseLink |
initEnt(const ACHAR *pName, const CAsiRow *pKeyValue, ads_name EntName) | CAseLink |
initEnt(const ACHAR *pName, const CAsiRow &KeyValue, ads_name EntName) | CAseLink |
initEnt(const ACHAR *pName, const CAsiColumn *pKeyValue[], int ColQty, ads_name EntName) | CAseLink |
initId(LinkID linkId) | CAseLink |
initType(EAseLinkType lType) | CAseLink |
isA() const | CAseLink | virtual
isDiffChar() const | CAseApiObj | protected
isInit() const | CAseLink | virtual
isUpdatable() const | CAseLink |
mpErr (defined in CAseApiObj) | CAseApiObj | protected
nextAttr(const struct resbuf *bufptr) const | CAseApiObj | protected
operator=(const CAseApiObj &Obj) | CAseLink | virtual
operator==(const CAseApiObj *pObj) const | CAseLink | virtual
operator==(const CAseApiObj &Obj) const | CAseLink | virtual
parseLisp(struct resbuf *bufptr) | CAseApiObj | protected
remove() | CAseLink |
setAttr(EAseLinkAttr LinkAttr, const struct resbuf *pAttrValue) | CAseLink |
setAttrPtr(struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const | CAseApiObj | protected
setDACols(const CAsiRow *pCols) | CAseLink |
setDACols(const CAsiRow &Cols) | CAseLink |
setDACols(CAsiColumn *pCols[], int ColQty) | CAseLink |
setDAParms(const struct resbuf *pParms) | CAseLink |
setDAValues(const CAsiRow *pDAValues) | CAseLink |
setDAValues(const CAsiRow &DAValues) | CAseLink |
setDAValues(CAsiColumn *pCols[], int ColQty) | CAseLink |
setDwg(const AcDbDatabase *pDwg=WORKINGDWG()) | CAseLink |
setEntity(ads_name EntName) | CAseLink |
setKey(const CAsiRow *pKeyValue) | CAseLink |
setKey(const CAsiRow &KeyValue) | CAseLink |
setKey(const CAsiColumn *pKeyValue[], int ColQty) | CAseLink |
setName(const ACHAR *pName) | CAseLink |
update() | CAseLink |
version() const | CAseApiObj |
~CAseApiObj() | CAseApiObj | virtual
~CAseLink() | CAseLink | virtual


ZRX API Reference: CAseLinkPath Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
CAseLinkPath Class Reference
Misc Classes
+ Inheritance diagram for CAseLinkPath:

Public Member Functions

EAsiBoolean | addRow (const CAsiRow *pValue) const
EAsiBoolean | addRow (const CAsiColumn *pValue[], int numValues) const
EAsiBoolean | allocCursor (const CAsiRow *pKeyDsc, const CAsiRow *pRow, long *pCursorNum) const
CAseLinkPath (CAseApiObj *pObj)
CAseLinkPath (CAseApiObj &Obj)
EAsiBoolean | checkOp (ulong status) const
virtual CAseApiObj * | clone () const
int | cmpName (const ACHAR *pName, EAseDoNameCode NameCode=kAseLpnCode) const
int | cmpName (const CAseLinkPath *pLinkPath, EAseDoNameCode NameCode=kAseLpnCode) const
EAsiBoolean | connectAse (const ACHAR *pUsername=NULL, const ACHAR *pPassword=NULL, EAsiBoolean fPrompt=kAsiFalse)
EAsiBoolean | connectAseIniString (const ACHAR *pIniString)
virtual EAsiBoolean | copyFrom (const CAseApiObj *pObj)
EAsiBoolean | create (const CAsiRow *pKeyDsc)
EAsiBoolean | create (const CAsiRow &KeyDsc)
EAsiBoolean | create (const CAsiColumn *pKeyDsc[], int ColQty)
EAsiBoolean | createTable (const CAsiRow *pCols)
EAsiBoolean | createTable (const CAsiColumn *pCols[], int colNum)
EAsiBoolean | delCursor (long cursorNum) const
EAsiBoolean | delRow (const CAsiRow *pValue, long *pRowsQty=NULL) const
EAsiBoolean | delRow (const CAsiColumn *pValue[], int numKeys, long *pRowsQty=NULL) const
EAsiBoolean | disconnectAse ()
EAsiBoolean | dropTable ()
EAsiBoolean | erase ()
EAsiBoolean | getCursorRow (long cursorNum, const CAsiRow *pKeyValue, CAsiRow *pRow) const
const AcDbDatabase * | getDwg () const
EAsiBoolean | getKeyDsc (CAsiRow **pKeyDsc) const
EAsiBoolean | getKeyDsc (CAsiColumn **pKeyDsc[], int *pColQty) const
struct resbuf * | getLinkNames () const
EAsiBoolean | getName (ACHAR *pBuf, int BufLen, EAseDoNameCode NameCode=kAseLpnCode) const
int | getNameSize (EAseDoNameCode NameCode=kAseLpnCode) const
EAseDoNameCode | getPathCode () const
struct resbuf * | getPaths (int Status) const
EAsiBoolean | getRow (const CAsiRow *pKeyValue, CAsiRow *pRowBuffer) const
int | getStatus () const
EAsiBoolean | getTableDsc (CAsiRow **pColumns) const
EAsiBoolean | getTableDsc (CAsiColumn **pKeyDsc[], int *pColQty) const
virtual EAsiBoolean | init ()
EAsiBoolean | initCurrent ()
EAsiBoolean | initName (const ACHAR *pName)
EAsiBoolean | initPath (const ACHAR *pPath)
virtual EAseApiClassId | isA () const
virtual EAsiBoolean | isInit () const
EAsiBoolean | isUpdatable () const
virtual CAseApiObj & | operator= (const CAseApiObj &Obj)
virtual int | operator== (const CAseApiObj *pObj) const
virtual int | operator== (const CAseApiObj &Obj) const
EAsiBoolean | reInit ()
EAsiBoolean | rename (const ACHAR *pLinkPathName)
EAsiBoolean | setCurrent () const
EAsiBoolean | setDwg (const AcDbDatabase *pDwg=WORKINGDWG())
EAsiBoolean | setName (const ACHAR *pName, EAseDoNameCode NameCode=kAseLpnCode)
EAsiBoolean | updRow (const CAsiRow *pKey, const CAsiRow *pValue, long *pRowsQty=NULL) const
EAsiBoolean | updRow (const CAsiColumn *pKey[], int numKeys, const CAsiColumn *pValue[], int numValues, long *pRowsQty=NULL) const
virtual | ~CAseLinkPath ()
- Public Member Functions inherited from CAseApiObj
void | appThrow () const
CAseApiObj (CAseApiObj *pObj)
CAseApiObj (CAseApiObj &Obj)
EAsiBoolean | errClear ()
int | errCode (int ErrNum) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, int *pIntValue) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const
const ACHAR * | errDiagParNameCode (int ParNum, int *pParCode, int *pIsStr) const
EAseErrDsc | errDsc (int ErrNum) const
const CAsiException * | errGet () const
EAsiBoolean | errInitAsi (CAsiException *pErr)
EAsiBoolean | errInitAsi (CAsiSQLObject *pSQLObj)
EAsiBoolean | errInitAsi (CAsiSQLObject &sqlObj)
EAsiBoolean | errMsg (int ErrNum, ACHAR *pBuf, int BufLen) const
int | errQty () const
const ACHAR * | version () const
virtual | ~CAseApiObj ()

Protected Attributes

void * | mpDwg
void * | mpPath
- Protected Attributes inherited from CAseApiObj
void * | mpErr

Additional Inherited Members

- Protected Member Functions inherited from CAseApiObj
struct resbuf * | allocAttr (EAseLinkAttr attr, const ACHAR *pStr=NULL) const
struct resbuf * | copyBuf (const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const
struct resbuf * | delAttrPtr (struct resbuf *bufptr, struct resbuf *pAttr) const
void | freeStr (struct resbuf *pBuf) const
CAseAppl * | getAppl () const
struct resbuf * | getAttrPtr (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getAttrType (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getLast (const struct resbuf *bufptr) const
EAsiBoolean | isDiffChar () const
struct resbuf * | nextAttr (const struct resbuf *bufptr) const
EAsiBoolean | parseLisp (struct resbuf *bufptr)
EAsiBoolean | setAttrPtr (struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const

Constructor & Destructor Documentation

CAseLinkPath::CAseLinkPath ( CAseApiObj * pObj )
Warning
Not implemented!
CAseLinkPath::CAseLinkPath ( CAseApiObj & Obj )
Warning
Not implemented!
virtual CAseLinkPath::~CAseLinkPath ( )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAseLinkPath::addRow ( const CAsiRow * pValue ) const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::addRow | ( | const CAsiColumn * | pValue[],
 |  | int | numValues
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::allocCursor | ( | const CAsiRow * | pKeyDsc,
 |  | const CAsiRow * | pRow,
 |  | long * | pCursorNum
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::checkOp ( ulong status ) const
Warning
Not implemented!
virtual CAseApiObj* CAseLinkPath::clone ( ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

int CAseLinkPath::cmpName | ( | const ACHAR * | pName,
 |  | EAseDoNameCode | NameCode = kAseLpnCode
 | ) |  | const
Warning
Not implemented!
int CAseLinkPath::cmpName | ( | const CAseLinkPath * | pLinkPath,
 |  | EAseDoNameCode | NameCode = kAseLpnCode
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::connectAse | ( | const ACHAR * | pUsername = NULL,
 |  | const ACHAR * | pPassword = NULL,
 |  | EAsiBoolean | fPrompt = kAsiFalse
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkPath::connectAseIniString ( const ACHAR * pIniString )
Warning
Not implemented!
virtual EAsiBoolean CAseLinkPath::copyFrom ( const CAseApiObj * pObj )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseLinkPath::create ( const CAsiRow * pKeyDsc )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::create ( const CAsiRow & KeyDsc )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::create | ( | const CAsiColumn * | pKeyDsc[],
 |  | int | ColQty
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkPath::createTable ( const CAsiRow * pCols )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::createTable | ( | const CAsiColumn * | pCols[],
 |  | int | colNum
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkPath::delCursor ( long cursorNum ) const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::delRow | ( | const CAsiRow * | pValue,
 |  | long * | pRowsQty = NULL
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::delRow | ( | const CAsiColumn * | pValue[],
 |  | int | numKeys,
 |  | long * | pRowsQty = NULL
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::disconnectAse ( )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::dropTable ( )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::erase ( )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::getCursorRow | ( | long | cursorNum,
 |  | const CAsiRow * | pKeyValue,
 |  | CAsiRow * | pRow
 | ) |  | const
Warning
Not implemented!
const AcDbDatabase* CAseLinkPath::getDwg ( ) const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::getKeyDsc ( CAsiRow ** pKeyDsc ) const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::getKeyDsc | ( | CAsiColumn ** | pKeyDsc[],
 |  | int * | pColQty
 | ) |  | const
Warning
Not implemented!
struct resbuf* CAseLinkPath::getLinkNames ( ) const
read
Warning
Not implemented!
EAsiBoolean CAseLinkPath::getName | ( | ACHAR * | pBuf,
 |  | int | BufLen,
 |  | EAseDoNameCode | NameCode = kAseLpnCode
 | ) |  | const
Warning
Not implemented!
int CAseLinkPath::getNameSize ( EAseDoNameCode NameCode = kAseLpnCode ) const
Warning
Not implemented!
EAseDoNameCode CAseLinkPath::getPathCode ( ) const
Warning
Not implemented!
struct resbuf* CAseLinkPath::getPaths ( int Status ) const
read
Warning
Not implemented!
EAsiBoolean CAseLinkPath::getRow | ( | const CAsiRow * | pKeyValue,
 |  | CAsiRow * | pRowBuffer
 | ) |  | const
Warning
Not implemented!
int CAseLinkPath::getStatus ( ) const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::getTableDsc ( CAsiRow ** pColumns ) const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::getTableDsc | ( | CAsiColumn ** | pKeyDsc[],
 |  | int * | pColQty
 | ) |  | const
Warning
Not implemented!
virtual EAsiBoolean CAseLinkPath::init ( )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseLinkPath::initCurrent ( )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::initName ( const ACHAR * pName )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::initPath ( const ACHAR * pPath )
Warning
Not implemented!
virtual EAseApiClassId CAseLinkPath::isA ( ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

virtual EAsiBoolean CAseLinkPath::isInit ( ) const
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseLinkPath::isUpdatable ( ) const
Warning
Not implemented!
virtual CAseApiObj& CAseLinkPath::operator= ( const CAseApiObj & Obj )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

virtual int CAseLinkPath::operator== ( const CAseApiObj * pObj ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

virtual int CAseLinkPath::operator== ( const CAseApiObj & Obj ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

EAsiBoolean CAseLinkPath::reInit ( )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::rename ( const ACHAR * pLinkPathName )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::setCurrent ( ) const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::setDwg ( const AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
EAsiBoolean CAseLinkPath::setName | ( | const ACHAR * | pName,
 |  | EAseDoNameCode | NameCode = kAseLpnCode
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkPath::updRow | ( | const CAsiRow * | pKey,
 |  | const CAsiRow * | pValue,
 |  | long * | pRowsQty = NULL
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAseLinkPath::updRow | ( | const CAsiColumn * | pKey[],
 |  | int | numKeys,
 |  | const CAsiColumn * | pValue[],
 |  | int | numValues,
 |  | long * | pRowsQty = NULL
 | ) |  | const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aseclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAseLinkPath Member List

This is the complete list of members for CAseLinkPath, including all inherited members.

addRow(const CAsiRow *pValue) const | CAseLinkPath |
addRow(const CAsiColumn *pValue[], int numValues) const | CAseLinkPath |
allocAttr(EAseLinkAttr attr, const ACHAR *pStr=NULL) const | CAseApiObj | protected
allocCursor(const CAsiRow *pKeyDsc, const CAsiRow *pRow, long *pCursorNum) const | CAseLinkPath |
appThrow() const | CAseApiObj |
CAseApiObj(CAseApiObj *pObj) | CAseApiObj |
CAseApiObj(CAseApiObj &Obj) | CAseApiObj |
CAseLinkPath(CAseApiObj *pObj) | CAseLinkPath |
CAseLinkPath(CAseApiObj &Obj) | CAseLinkPath |
checkOp(ulong status) const | CAseLinkPath |
clone() const | CAseLinkPath | virtual
cmpName(const ACHAR *pName, EAseDoNameCode NameCode=kAseLpnCode) const | CAseLinkPath |
cmpName(const CAseLinkPath *pLinkPath, EAseDoNameCode NameCode=kAseLpnCode) const | CAseLinkPath |
connectAse(const ACHAR *pUsername=NULL, const ACHAR *pPassword=NULL, EAsiBoolean fPrompt=kAsiFalse) | CAseLinkPath |
connectAseIniString(const ACHAR *pIniString) | CAseLinkPath |
copyBuf(const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const | CAseApiObj | protected
copyFrom(const CAseApiObj *pObj) | CAseLinkPath | virtual
create(const CAsiRow *pKeyDsc) | CAseLinkPath |
create(const CAsiRow &KeyDsc) | CAseLinkPath |
create(const CAsiColumn *pKeyDsc[], int ColQty) | CAseLinkPath |
createTable(const CAsiRow *pCols) | CAseLinkPath |
createTable(const CAsiColumn *pCols[], int colNum) | CAseLinkPath |
delAttrPtr(struct resbuf *bufptr, struct resbuf *pAttr) const | CAseApiObj | protected
delCursor(long cursorNum) const | CAseLinkPath |
delRow(const CAsiRow *pValue, long *pRowsQty=NULL) const | CAseLinkPath |
delRow(const CAsiColumn *pValue[], int numKeys, long *pRowsQty=NULL) const | CAseLinkPath |
disconnectAse() | CAseLinkPath |
dropTable() | CAseLinkPath |
erase() | CAseLinkPath |
errClear() | CAseApiObj |
errCode(int ErrNum) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, int *pIntValue) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const | CAseApiObj |
errDiagParNameCode(int ParNum, int *pParCode, int *pIsStr) const | CAseApiObj |
errDsc(int ErrNum) const | CAseApiObj |
errGet() const | CAseApiObj |
errInitAsi(CAsiException *pErr) | CAseApiObj |
errInitAsi(CAsiSQLObject *pSQLObj) | CAseApiObj |
errInitAsi(CAsiSQLObject &sqlObj) | CAseApiObj |
errMsg(int ErrNum, ACHAR *pBuf, int BufLen) const | CAseApiObj |
errQty() const | CAseApiObj |
freeStr(struct resbuf *pBuf) const | CAseApiObj | protected
getAppl() const | CAseApiObj | protected
getAttrPtr(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getAttrType(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getCursorRow(long cursorNum, const CAsiRow *pKeyValue, CAsiRow *pRow) const | CAseLinkPath |
getDwg() const | CAseLinkPath |
getKeyDsc(CAsiRow **pKeyDsc) const | CAseLinkPath |
getKeyDsc(CAsiColumn **pKeyDsc[], int *pColQty) const | CAseLinkPath |
getLast(const struct resbuf *bufptr) const | CAseApiObj | protected
getLinkNames() const | CAseLinkPath |
getName(ACHAR *pBuf, int BufLen, EAseDoNameCode NameCode=kAseLpnCode) const | CAseLinkPath |
getNameSize(EAseDoNameCode NameCode=kAseLpnCode) const | CAseLinkPath |
getPathCode() const | CAseLinkPath |
getPaths(int Status) const | CAseLinkPath |
getRow(const CAsiRow *pKeyValue, CAsiRow *pRowBuffer) const | CAseLinkPath |
getStatus() const | CAseLinkPath |
getTableDsc(CAsiRow **pColumns) const | CAseLinkPath |
getTableDsc(CAsiColumn **pKeyDsc[], int *pColQty) const | CAseLinkPath |
init() | CAseLinkPath | virtual
initCurrent() | CAseLinkPath |
initName(const ACHAR *pName) | CAseLinkPath |
initPath(const ACHAR *pPath) | CAseLinkPath |
isA() const | CAseLinkPath | virtual
isDiffChar() const | CAseApiObj | protected
isInit() const | CAseLinkPath | virtual
isUpdatable() const | CAseLinkPath |
mpDwg (defined in CAseLinkPath) | CAseLinkPath | protected
mpErr (defined in CAseApiObj) | CAseApiObj | protected
mpPath (defined in CAseLinkPath) | CAseLinkPath | protected
nextAttr(const struct resbuf *bufptr) const | CAseApiObj | protected
operator=(const CAseApiObj &Obj) | CAseLinkPath | virtual
operator==(const CAseApiObj *pObj) const | CAseLinkPath | virtual
operator==(const CAseApiObj &Obj) const | CAseLinkPath | virtual
parseLisp(struct resbuf *bufptr) | CAseApiObj | protected
reInit() | CAseLinkPath |
rename(const ACHAR *pLinkPathName) | CAseLinkPath |
setAttrPtr(struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const | CAseApiObj | protected
setCurrent() const | CAseLinkPath |
setDwg(const AcDbDatabase *pDwg=WORKINGDWG()) | CAseLinkPath |
setName(const ACHAR *pName, EAseDoNameCode NameCode=kAseLpnCode) | CAseLinkPath |
updRow(const CAsiRow *pKey, const CAsiRow *pValue, long *pRowsQty=NULL) const | CAseLinkPath |
updRow(const CAsiColumn *pKey[], int numKeys, const CAsiColumn *pValue[], int numValues, long *pRowsQty=NULL) const | CAseLinkPath |
version() const | CAseApiObj |
~CAseApiObj() | CAseApiObj | virtual
~CAseLinkPath() | CAseLinkPath | virtual


ZRX API Reference: CAseLinkSel Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CAseLinkSel Class Reference
Misc Classes
+ Inheritance diagram for CAseLinkSel:

Public Member Functions

EAsiBoolean | addId (LinkID linkId)
CAseLinkSel (CAseApiObj *pObj)
CAseLinkSel (CAseApiObj &Obj)
virtual CAseApiObj * | clone () const
virtual EAsiBoolean | copyFrom (const CAseApiObj *pObj)
EAsiBoolean | delId (long ItemNum)
EAsiBoolean | erase ()
const AcDbDatabase * | getDwg () const
EAsiBoolean | getEntSel (ads_name EntSelName) const
LinkID | getId (long ItemNum) const
int | getIdArray (AcDbObjectIdArray *pLinkedEntities) const
EAsiBoolean | getLinkEnt (long ItemNum, ads_name ename)
EAsiBoolean | getLinkEnt (long ItemNum, AcDbObjectId *pId)
EAsiBoolean | getLinkKey (long ItemNum, CAsiRow *pKeyValue)
EAsiBoolean | getLinkName (long ItemNum, TCHAR *pNameBuf, int nameBufLen) const
struct resbuf * | getLinkNames () const
long | getQty () const
struct resbuf * | getXNames () const
virtual EAsiBoolean | init ()
EAsiBoolean | initEnt (ads_name EntName, EAseLinkType LinkType=kAseUnknownLinkType)
virtual EAsiBoolean | initFilter (struct resbuf *pLinkFilter, EAsiBoolean needFullOpen=kAsiFalse)
EAsiBoolean | initLp (const ACHAR *pName, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLp (const CAseLinkPath *pLinkPath, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLp (const CAseLinkPath &LinkPath, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpCond (const ACHAR *pName, const ACHAR *pTextCondition, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpCond (const CAseLinkPath *pLinkPath, const ACHAR *pTextCondition, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpCond (const CAseLinkPath &LinkPath, const ACHAR *pTextCondition, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpEnt (const ACHAR *pName, ads_name EntName, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpEnt (const CAseLinkPath *pLinkPath, ads_name EntName, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpEnt (const CAseLinkPath &LinkPath, ads_name EntName, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpKey (const ACHAR *pName, const CAsiRow *pKeyValue, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpKey (const ACHAR *pName, const CAsiRow &KeyValue, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpKey (const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpKey (const CAseLinkPath &LinkPath, const CAsiRow &KeyValue, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpKey (const ACHAR *pName, const CAsiColumn *pKeyValue[], int ColQty, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpKey (const CAseLinkPath *pLinkPath, const CAsiColumn *pKeyValue[], int ColQty, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpSel (const ACHAR *pName, ads_name EntSelName, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpSel (const CAseLinkPath *pLinkPath, ads_name EntSelName, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initLpSel (const CAseLinkPath &LinkPath, ads_name EntSelName, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initPartialKey (const ACHAR *pName, const CAsiRow *pKeyValue, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initPartialKey (const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initSel (ads_name EntSelName, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | initType (EAseLinkType LinkType)
EAsiBoolean | initXName (const ACHAR *pXName, EAseLinkType LinkType=kAseUnknownLinkType)
EAsiBoolean | intersect (const CAseLinkSel *pSel)
EAsiBoolean | intersect (const CAseLinkSel &Sel)
EAsiBoolean | intersectEnt (ads_name EntName)
virtual EAsiBoolean | intersectFilter (const struct resbuf *pLinkFilter)
EAsiBoolean | intersectLp (const ACHAR *pName)
EAsiBoolean | intersectLp (const CAseLinkPath *pLinkPath)
EAsiBoolean | intersectLp (const CAseLinkPath &LinkPath)
EAsiBoolean | intersectLpCond (const ACHAR *pName, const ACHAR *pTextCondition)
EAsiBoolean | intersectLpCond (const CAseLinkPath *pLinkPath, const ACHAR *pTextCondition)
EAsiBoolean | intersectLpCond (const CAseLinkPath &LinkPath, const ACHAR *pTextCondition)
EAsiBoolean | intersectLpKey (const ACHAR *pName, const CAsiRow *pKeyValue)
EAsiBoolean | intersectLpKey (const ACHAR *pName, const CAsiRow &KeyValue)
EAsiBoolean | intersectLpKey (const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue)
EAsiBoolean | intersectLpKey (const CAseLinkPath &LinkPath, const CAsiRow &KeyValue)
EAsiBoolean | intersectLpKey (const ACHAR *pName, const CAsiColumn *pKeyValue[], int ColQty)
EAsiBoolean | intersectLpKey (const CAseLinkPath *pLinkPath, const CAsiColumn *pKeyValue[], int ColQty)
EAsiBoolean | intersectPartialKey (const ACHAR *pName, const CAsiRow *pKeyValue)
EAsiBoolean | intersectPartialKey (const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue)
EAsiBoolean | intersectSel (ads_name EntSelName)
EAsiBoolean | intersectType (EAseLinkType LinkType)
EAsiBoolean | intersectXName (const ACHAR *pXName)
virtual EAseApiClassId | isA () const
virtual EAsiBoolean | isInit () const
EAsiBoolean | isUpdatable () const
long | membId (LinkID linkId) const
virtual CAseApiObj & | operator= (const CAseApiObj &Obj)
virtual int | operator== (const CAseApiObj *pObj) const
virtual int | operator== (const CAseApiObj &Obj) const
EAsiBoolean | setDwg (const AcDbDatabase *pDwg=WORKINGDWG())
EAsiBoolean | subtract (const CAseLinkSel *pSel)
EAsiBoolean | subtract (const CAseLinkSel &Sel)
EAsiBoolean | unite (const CAseLinkSel *pSel)
EAsiBoolean | unite (const CAseLinkSel &Sel)
virtual | ~CAseLinkSel ()
- Public Member Functions inherited from CAseApiObj
void | appThrow () const
CAseApiObj (CAseApiObj *pObj)
CAseApiObj (CAseApiObj &Obj)
EAsiBoolean | errClear ()
int | errCode (int ErrNum) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, int *pIntValue) const
EAsiBoolean | errDiagPar (int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const
const ACHAR * | errDiagParNameCode (int ParNum, int *pParCode, int *pIsStr) const
EAseErrDsc | errDsc (int ErrNum) const
const CAsiException * | errGet () const
EAsiBoolean | errInitAsi (CAsiException *pErr)
EAsiBoolean | errInitAsi (CAsiSQLObject *pSQLObj)
EAsiBoolean | errInitAsi (CAsiSQLObject &sqlObj)
EAsiBoolean | errMsg (int ErrNum, ACHAR *pBuf, int BufLen) const
int | errQty () const
const ACHAR * | version () const
virtual | ~CAseApiObj ()

Protected Member Functions

void | freeSel ()
struct resbuf * | makeFilter (EAseLinkType LinkType, const ACHAR *pXName, ads_name EntName, ads_name EntSelName, const ACHAR *pName, const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue, const ACHAR *pTextCondition, const CAsiRow *pParKeyValue=NULL)
- Protected Member Functions inherited from CAseApiObj
struct resbuf * | allocAttr (EAseLinkAttr attr, const ACHAR *pStr=NULL) const
struct resbuf * | copyBuf (const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const
struct resbuf * | delAttrPtr (struct resbuf *bufptr, struct resbuf *pAttr) const
void | freeStr (struct resbuf *pBuf) const
CAseAppl * | getAppl () const
struct resbuf * | getAttrPtr (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getAttrType (const struct resbuf *bufptr, EAseLinkAttr lattr) const
struct resbuf * | getLast (const struct resbuf *bufptr) const
EAsiBoolean | isDiffChar () const
struct resbuf * | nextAttr (const struct resbuf *bufptr) const
EAsiBoolean | parseLisp (struct resbuf *bufptr)
EAsiBoolean | setAttrPtr (struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const

Protected Attributes

void * | mpDwg
LinkSelID | mSelId
- Protected Attributes inherited from CAseApiObj
void * | mpErr

Constructor & Destructor Documentation

CAseLinkSel::CAseLinkSel ( CAseApiObj * pObj )
Warning
Not implemented!
CAseLinkSel::CAseLinkSel ( CAseApiObj & Obj )
Warning
Not implemented!
virtual CAseLinkSel::~CAseLinkSel ( )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAseLinkSel::addId ( LinkID linkId )
Warning
Not implemented!
virtual CAseApiObj* CAseLinkSel::clone ( ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

virtual EAsiBoolean CAseLinkSel::copyFrom ( const CAseApiObj * pObj )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseLinkSel::delId ( long ItemNum )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::erase ( )
Warning
Not implemented!
void CAseLinkSel::freeSel ( )
protected
Warning
Not implemented!
const AcDbDatabase* CAseLinkSel::getDwg ( ) const
Warning
Not implemented!
EAsiBoolean CAseLinkSel::getEntSel ( ads_name EntSelName ) const
Warning
Not implemented!
LinkID CAseLinkSel::getId ( long ItemNum ) const
Warning
Not implemented!
int CAseLinkSel::getIdArray ( AcDbObjectIdArray * pLinkedEntities ) const
Warning
Not implemented!
EAsiBoolean CAseLinkSel::getLinkEnt | ( | long | ItemNum,
 |  | ads_name | ename
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::getLinkEnt | ( | long | ItemNum,
 |  | AcDbObjectId * | pId
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::getLinkKey | ( | long | ItemNum,
 |  | CAsiRow * | pKeyValue
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::getLinkName | ( | long | ItemNum,
 |  | TCHAR * | pNameBuf,
 |  | int | nameBufLen
 | ) |  | const
Warning
Not implemented!
struct resbuf* CAseLinkSel::getLinkNames ( ) const
read
Warning
Not implemented!
long CAseLinkSel::getQty ( ) const
Warning
Not implemented!
struct resbuf* CAseLinkSel::getXNames ( ) const
read
Warning
Not implemented!
virtual EAsiBoolean CAseLinkSel::init ( )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseLinkSel::initEnt | ( | ads_name | EntName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
virtual EAsiBoolean CAseLinkSel::initFilter | ( | struct resbuf * | pLinkFilter,
 |  | EAsiBoolean | needFullOpen = kAsiFalse
 | ) |  |
virtual
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLp | ( | const ACHAR * | pName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLp | ( | const CAseLinkPath * | pLinkPath,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLp | ( | const CAseLinkPath & | LinkPath,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpCond | ( | const ACHAR * | pName,
 |  | const ACHAR * | pTextCondition,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpCond | ( | const CAseLinkPath * | pLinkPath,
 |  | const ACHAR * | pTextCondition,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpCond | ( | const CAseLinkPath & | LinkPath,
 |  | const ACHAR * | pTextCondition,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpEnt | ( | const ACHAR * | pName,
 |  | ads_name | EntName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpEnt | ( | const CAseLinkPath * | pLinkPath,
 |  | ads_name | EntName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpEnt | ( | const CAseLinkPath & | LinkPath,
 |  | ads_name | EntName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpKey | ( | const ACHAR * | pName,
 |  | const CAsiRow * | pKeyValue,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpKey | ( | const ACHAR * | pName,
 |  | const CAsiRow & | KeyValue,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpKey | ( | const CAseLinkPath * | pLinkPath,
 |  | const CAsiRow * | pKeyValue,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpKey | ( | const CAseLinkPath & | LinkPath,
 |  | const CAsiRow & | KeyValue,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpKey | ( | const ACHAR * | pName,
 |  | const CAsiColumn * | pKeyValue[],
 |  | int | ColQty,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpKey | ( | const CAseLinkPath * | pLinkPath,
 |  | const CAsiColumn * | pKeyValue[],
 |  | int | ColQty,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpSel | ( | const ACHAR * | pName,
 |  | ads_name | EntSelName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpSel | ( | const CAseLinkPath * | pLinkPath,
 |  | ads_name | EntSelName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initLpSel | ( | const CAseLinkPath & | LinkPath,
 |  | ads_name | EntSelName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initPartialKey | ( | const ACHAR * | pName,
 |  | const CAsiRow * | pKeyValue,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initPartialKey | ( | const CAseLinkPath * | pLinkPath,
 |  | const CAsiRow * | pKeyValue,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initSel | ( | ads_name | EntSelName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initType ( EAseLinkType LinkType )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::initXName | ( | const ACHAR * | pXName,
 |  | EAseLinkType | LinkType = kAseUnknownLinkType
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersect ( const CAseLinkSel * pSel )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersect ( const CAseLinkSel & Sel )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectEnt ( ads_name EntName )
Warning
Not implemented!
virtual EAsiBoolean CAseLinkSel::intersectFilter ( const struct resbuf * pLinkFilter )
virtual
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLp ( const ACHAR * pName )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLp ( const CAseLinkPath * pLinkPath )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLp ( const CAseLinkPath & LinkPath )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLpCond | ( | const ACHAR * | pName,
 |  | const ACHAR * | pTextCondition
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLpCond | ( | const CAseLinkPath * | pLinkPath,
 |  | const ACHAR * | pTextCondition
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLpCond | ( | const CAseLinkPath & | LinkPath,
 |  | const ACHAR * | pTextCondition
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLpKey | ( | const ACHAR * | pName,
 |  | const CAsiRow * | pKeyValue
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLpKey | ( | const ACHAR * | pName,
 |  | const CAsiRow & | KeyValue
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLpKey | ( | const CAseLinkPath * | pLinkPath,
 |  | const CAsiRow * | pKeyValue
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLpKey | ( | const CAseLinkPath & | LinkPath,
 |  | const CAsiRow & | KeyValue
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLpKey | ( | const ACHAR * | pName,
 |  | const CAsiColumn * | pKeyValue[],
 |  | int | ColQty
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectLpKey | ( | const CAseLinkPath * | pLinkPath,
 |  | const CAsiColumn * | pKeyValue[],
 |  | int | ColQty
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectPartialKey | ( | const ACHAR * | pName,
 |  | const CAsiRow * | pKeyValue
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectPartialKey | ( | const CAseLinkPath * | pLinkPath,
 |  | const CAsiRow * | pKeyValue
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectSel ( ads_name EntSelName )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectType ( EAseLinkType LinkType )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::intersectXName ( const ACHAR * pXName )
Warning
Not implemented!
virtual EAseApiClassId CAseLinkSel::isA ( ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

virtual EAsiBoolean CAseLinkSel::isInit ( ) const
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

EAsiBoolean CAseLinkSel::isUpdatable ( ) const
Warning
Not implemented!
struct resbuf* CAseLinkSel::makeFilter | ( | EAseLinkType | LinkType,
 |  | const ACHAR * | pXName,
 |  | ads_name | EntName,
 |  | ads_name | EntSelName,
 |  | const ACHAR * | pName,
 |  | const CAseLinkPath * | pLinkPath,
 |  | const CAsiRow * | pKeyValue,
 |  | const ACHAR * | pTextCondition,
 |  | const CAsiRow * | pParKeyValue = NULL
 | ) |  |
readprotected
Warning
Not implemented!
long CAseLinkSel::membId ( LinkID linkId ) const
Warning
Not implemented!
virtual CAseApiObj& CAseLinkSel::operator= ( const CAseApiObj & Obj )
virtual
Warning
Not implemented!

Reimplemented from CAseApiObj.

virtual int CAseLinkSel::operator== ( const CAseApiObj * pObj ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

virtual int CAseLinkSel::operator== ( const CAseApiObj & Obj ) const
virtual
Warning
Not implemented!

Implements CAseApiObj.

EAsiBoolean CAseLinkSel::setDwg ( const AcDbDatabase * pDwg = WORKINGDWG() )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::subtract ( const CAseLinkSel * pSel )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::subtract ( const CAseLinkSel & Sel )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::unite ( const CAseLinkSel * pSel )
Warning
Not implemented!
EAsiBoolean CAseLinkSel::unite ( const CAseLinkSel & Sel )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • aseclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAseLinkSel Member List

This is the complete list of members for CAseLinkSel, including all inherited members.

addId(LinkID linkId) | CAseLinkSel |
allocAttr(EAseLinkAttr attr, const ACHAR *pStr=NULL) const | CAseApiObj | protected
appThrow() const | CAseApiObj |
CAseApiObj(CAseApiObj *pObj) | CAseApiObj |
CAseApiObj(CAseApiObj &Obj) | CAseApiObj |
CAseLinkSel(CAseApiObj *pObj) | CAseLinkSel |
CAseLinkSel(CAseApiObj &Obj) | CAseLinkSel |
clone() const | CAseLinkSel | virtual
copyBuf(const struct resbuf *bufptr, const struct resbuf *pBorder=NULL) const | CAseApiObj | protected
copyFrom(const CAseApiObj *pObj) | CAseLinkSel | virtual
delAttrPtr(struct resbuf *bufptr, struct resbuf *pAttr) const | CAseApiObj | protected
delId(long ItemNum) | CAseLinkSel |
erase() | CAseLinkSel |
errClear() | CAseApiObj |
errCode(int ErrNum) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, int *pIntValue) const | CAseApiObj |
errDiagPar(int ErrNum, int ParCode, ACHAR *pStrValue, int BufLen) const | CAseApiObj |
errDiagParNameCode(int ParNum, int *pParCode, int *pIsStr) const | CAseApiObj |
errDsc(int ErrNum) const | CAseApiObj |
errGet() const | CAseApiObj |
errInitAsi(CAsiException *pErr) | CAseApiObj |
errInitAsi(CAsiSQLObject *pSQLObj) | CAseApiObj |
errInitAsi(CAsiSQLObject &sqlObj) | CAseApiObj |
errMsg(int ErrNum, ACHAR *pBuf, int BufLen) const | CAseApiObj |
errQty() const | CAseApiObj |
freeSel() | CAseLinkSel | protected
freeStr(struct resbuf *pBuf) const | CAseApiObj | protected
getAppl() const | CAseApiObj | protected
getAttrPtr(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getAttrType(const struct resbuf *bufptr, EAseLinkAttr lattr) const | CAseApiObj | protected
getDwg() const | CAseLinkSel |
getEntSel(ads_name EntSelName) const | CAseLinkSel |
getId(long ItemNum) const | CAseLinkSel |
getIdArray(AcDbObjectIdArray *pLinkedEntities) const | CAseLinkSel |
getLast(const struct resbuf *bufptr) const | CAseApiObj | protected
getLinkEnt(long ItemNum, ads_name ename) | CAseLinkSel |
getLinkEnt(long ItemNum, AcDbObjectId *pId) | CAseLinkSel |
getLinkKey(long ItemNum, CAsiRow *pKeyValue) | CAseLinkSel |
getLinkName(long ItemNum, TCHAR *pNameBuf, int nameBufLen) const | CAseLinkSel |
getLinkNames() const | CAseLinkSel |
getQty() const | CAseLinkSel |
getXNames() const | CAseLinkSel |
init() | CAseLinkSel | virtual
initEnt(ads_name EntName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initFilter(struct resbuf *pLinkFilter, EAsiBoolean needFullOpen=kAsiFalse) | CAseLinkSel | virtual
initLp(const ACHAR *pName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLp(const CAseLinkPath *pLinkPath, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLp(const CAseLinkPath &LinkPath, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpCond(const ACHAR *pName, const ACHAR *pTextCondition, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpCond(const CAseLinkPath *pLinkPath, const ACHAR *pTextCondition, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpCond(const CAseLinkPath &LinkPath, const ACHAR *pTextCondition, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpEnt(const ACHAR *pName, ads_name EntName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpEnt(const CAseLinkPath *pLinkPath, ads_name EntName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpEnt(const CAseLinkPath &LinkPath, ads_name EntName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpKey(const ACHAR *pName, const CAsiRow *pKeyValue, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpKey(const ACHAR *pName, const CAsiRow &KeyValue, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpKey(const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpKey(const CAseLinkPath &LinkPath, const CAsiRow &KeyValue, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpKey(const ACHAR *pName, const CAsiColumn *pKeyValue[], int ColQty, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpKey(const CAseLinkPath *pLinkPath, const CAsiColumn *pKeyValue[], int ColQty, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpSel(const ACHAR *pName, ads_name EntSelName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpSel(const CAseLinkPath *pLinkPath, ads_name EntSelName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initLpSel(const CAseLinkPath &LinkPath, ads_name EntSelName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initPartialKey(const ACHAR *pName, const CAsiRow *pKeyValue, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initPartialKey(const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initSel(ads_name EntSelName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
initType(EAseLinkType LinkType) | CAseLinkSel |
initXName(const ACHAR *pXName, EAseLinkType LinkType=kAseUnknownLinkType) | CAseLinkSel |
intersect(const CAseLinkSel *pSel) | CAseLinkSel |
intersect(const CAseLinkSel &Sel) | CAseLinkSel |
intersectEnt(ads_name EntName) | CAseLinkSel |
intersectFilter(const struct resbuf *pLinkFilter) | CAseLinkSel | virtual
intersectLp(const ACHAR *pName) | CAseLinkSel |
intersectLp(const CAseLinkPath *pLinkPath) | CAseLinkSel |
intersectLp(const CAseLinkPath &LinkPath) | CAseLinkSel |
intersectLpCond(const ACHAR *pName, const ACHAR *pTextCondition) | CAseLinkSel |
intersectLpCond(const CAseLinkPath *pLinkPath, const ACHAR *pTextCondition) | CAseLinkSel |
intersectLpCond(const CAseLinkPath &LinkPath, const ACHAR *pTextCondition) | CAseLinkSel |
intersectLpKey(const ACHAR *pName, const CAsiRow *pKeyValue) | CAseLinkSel |
intersectLpKey(const ACHAR *pName, const CAsiRow &KeyValue) | CAseLinkSel |
intersectLpKey(const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue) | CAseLinkSel |
intersectLpKey(const CAseLinkPath &LinkPath, const CAsiRow &KeyValue) | CAseLinkSel |
intersectLpKey(const ACHAR *pName, const CAsiColumn *pKeyValue[], int ColQty) | CAseLinkSel |
intersectLpKey(const CAseLinkPath *pLinkPath, const CAsiColumn *pKeyValue[], int ColQty) | CAseLinkSel |
intersectPartialKey(const ACHAR *pName, const CAsiRow *pKeyValue) | CAseLinkSel |
intersectPartialKey(const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue) | CAseLinkSel |
intersectSel(ads_name EntSelName) | CAseLinkSel |
intersectType(EAseLinkType LinkType) | CAseLinkSel |
intersectXName(const ACHAR *pXName) | CAseLinkSel |
isA() const | CAseLinkSel | virtual
isDiffChar() const | CAseApiObj | protected
isInit() const | CAseLinkSel | virtual
isUpdatable() const | CAseLinkSel |
makeFilter(EAseLinkType LinkType, const ACHAR *pXName, ads_name EntName, ads_name EntSelName, const ACHAR *pName, const CAseLinkPath *pLinkPath, const CAsiRow *pKeyValue, const ACHAR *pTextCondition, const CAsiRow *pParKeyValue=NULL) | CAseLinkSel | protected
membId(LinkID linkId) const | CAseLinkSel |
mpDwg (defined in CAseLinkSel) | CAseLinkSel | protected
mpErr (defined in CAseApiObj) | CAseApiObj | protected
mSelId (defined in CAseLinkSel) | CAseLinkSel | protected
nextAttr(const struct resbuf *bufptr) const | CAseApiObj | protected
operator=(const CAseApiObj &Obj) | CAseLinkSel | virtual
operator==(const CAseApiObj *pObj) const | CAseLinkSel | virtual
operator==(const CAseApiObj &Obj) const | CAseLinkSel | virtual
parseLisp(struct resbuf *bufptr) | CAseApiObj | protected
setAttrPtr(struct resbuf *bufptr, EAseLinkAttr LinkAttr, struct resbuf *pAttrValue) const | CAseApiObj | protected
setDwg(const AcDbDatabase *pDwg=WORKINGDWG()) | CAseLinkSel |
subtract(const CAseLinkSel *pSel) | CAseLinkSel |
subtract(const CAseLinkSel &Sel) | CAseLinkSel |
unite(const CAseLinkSel *pSel) | CAseLinkSel |
unite(const CAseLinkSel &Sel) | CAseLinkSel |
version() const | CAseApiObj |
~CAseApiObj() | CAseApiObj | virtual
~CAseLinkSel() | CAseLinkSel | virtual


ZRX API Reference: CAsiAppl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
CAsiAppl Class Reference
Misc Classes
+ Inheritance diagram for CAsiAppl:

Public Member Functions

EAsiBoolean | Abort (void)
CAsiAppl ()
EAsiBoolean | DisconnectAll (void)
EAsiBoolean | Init (void)
EAsiBoolean | Term (void)
virtual | ~CAsiAppl ()
- Public Member Functions inherited from CAsiSQLObject
EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
virtual EAsiBoolean | IsRowset (void) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

EAsiBoolean | addConnection (CAsiSession *)
EAsiBoolean | removeConnection (CAsiSession *)
- Protected Member Functions inherited from CAsiSQLObject
CAsiSQLObject ()
virtual EAsiBoolean | flushCond (void)
void | InheritStatusInfo (const CAsiSQLObject &)
EAsiBoolean | InitErrorInfo (HRESULT, IUnknown *, GUID)
EAsiBoolean | isInit (void) const
virtual EAsiBoolean | pushCond (void)
virtual EAsiBoolean | pushErr (EAsiError)
virtual EAsiBoolean | pushHResult (HRESULT)
void | ReleaseErrorInfo ()
virtual EAsiBoolean | setDiagPar (EAsiDiag, integer)
virtual EAsiBoolean | setDiagPar (EAsiDiag, const CAsiUcStr &)
virtual EAsiBoolean | setErr (EAsiError)
virtual EAsiBoolean | setErrMsg (const CAsiUcStr &)
virtual EAsiBoolean | setSQLSTATE (const char *)

Friends

class | CAsiCsr
class | CAsiEnumerator
class | CAsiSession

Additional Inherited Members

- Protected Attributes inherited from CAsiSQLObject
EAsiBoolean | m_CSP
EAsiStatement | m_eStmType
HRESULT | m_HResult
LONG_PTR | m_lRowCount
CAsiDSProperties * | m_pDSProperties
IErrorInfo * | m_pIErrorInfo

Constructor & Destructor Documentation

CAsiAppl::CAsiAppl ( )
Warning
Not implemented!
virtual CAsiAppl::~CAsiAppl ( )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAsiAppl::Abort ( void )
Warning
Not implemented!
EAsiBoolean CAsiAppl::addConnection ( CAsiSession * )
protected
Warning
Not implemented!
EAsiBoolean CAsiAppl::DisconnectAll ( void )
Warning
Not implemented!
EAsiBoolean CAsiAppl::Init ( void )
Warning
Not implemented!
EAsiBoolean CAsiAppl::removeConnection ( CAsiSession * )
protected
Warning
Not implemented!
EAsiBoolean CAsiAppl::Term ( void )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiAppl Member List

This is the complete list of members for CAsiAppl, including all inherited members.

Abort(void) | CAsiAppl |
addConnection(CAsiSession *) | CAsiAppl | protected
CAsiAppl() | CAsiAppl |
CAsiCsr (defined in CAsiAppl) | CAsiAppl | friend
CAsiEnumerator (defined in CAsiAppl) | CAsiAppl | friend
CAsiObject(void) | CAsiObject |
CAsiSession (defined in CAsiAppl) | CAsiAppl | friend
CAsiSQLObject() | CAsiSQLObject | protected
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
CondQty(void) const | CAsiSQLObject | virtual
DBMS(CAsiUcStr *) const | CAsiSQLObject |
DisconnectAll(void) | CAsiAppl |
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
duplicate(void) const | CAsiObject | virtual
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiSQLObject | virtual
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
Init(void) | CAsiAppl |
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiSQLObject | virtual
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_lRowCount (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
ReleaseErrorInfo() | CAsiSQLObject | protected
removeConnection(CAsiSession *) | CAsiAppl | protected
RowCount(void) const | CAsiSQLObject |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
Term(void) | CAsiAppl |
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Version(void) const | CAsiSQLObject |
~CAsiAppl() | CAsiAppl | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual


ZRX API Reference: CAsiApproxNum Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAsiApproxNum Class Reference
Misc Classes
+ Inheritance diagram for CAsiApproxNum:

Public Member Functions

virtual EAsiBoolean | is_approxnumeric (void) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual | ~CAsiApproxNum ()
- Public Member Functions inherited from CAsiNum
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual integer | intValue (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual uint | Precision (void) const
virtual real | realValue (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual CAsiObject * | duplicate (void) const =0
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual uint | ReturnLength (void) const
virtual void | setNull (void)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const =0
virtual EAsiBoolean | SQLType (CAsiUcStr *) const =0
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual EAsiDataType | Type (void) const =0
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Member Functions inherited from CAsiNum
CAsiNum ()
- Protected Attributes inherited from CAsiNum
uint | precision
uint | scale

Constructor & Destructor Documentation

virtual CAsiApproxNum::~CAsiApproxNum ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual EAsiBoolean CAsiApproxNum::is_approxnumeric ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator!= ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator< ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator<= ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator== ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator> ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiApproxNum::operator>= ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiApproxNum Member List

This is the complete list of members for CAsiApproxNum, including all inherited members.

CAsiApproxNum() (defined in CAsiApproxNum) | CAsiApproxNum | protected
CAsiData(void) | CAsiData |
CAsiNum() | CAsiNum | protected
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const | CAsiNum | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiNum | virtual
checkMul(const CAsiData *) const | CAsiNum | virtual
checkSet(const CAsiData *) const | CAsiData | virtual
checkSub(const CAsiData *) const | CAsiNum | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const =0 | CAsiData | pure virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const | CAsiData | virtual
getValue(integer *) const | CAsiData | virtual
getValue(smallint *) const | CAsiData | virtual
getValue(char *, uint) const | CAsiData | virtual
getValue(CAsiUcStr *) const | CAsiData | virtual
getValue(char *, uint, uint *) const | CAsiData | virtual
getValue(AsiUcStr, uint) const | CAsiData | virtual
getValue(CAsiData &) const | CAsiData | virtual
getValue(DECIMAL *) const | CAsiData | virtual
getValue(DB_NUMERIC *) const | CAsiData | virtual
getValue(DBDATE *) const | CAsiData | virtual
getValue(DBTIME *) const | CAsiData | virtual
getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const | CAsiNum | virtual
is_approxnumeric(void) const | CAsiApproxNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const | CAsiData | virtual
isGreaterThan(const CAsiData &) const | CAsiData | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const | CAsiData | virtual
MapAsiToParamInfo(DBPARAMINFO *) const | CAsiData | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator!=(const CAsiInt &) const | CAsiApproxNum | virtual
operator!=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator!=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator!=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator!=(const CAsiReal &) const | CAsiApproxNum | virtual
operator!=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator!=(const smallint) const | CAsiApproxNum | virtual
operator!=(const integer) const | CAsiApproxNum | virtual
operator!=(const real) const | CAsiApproxNum | virtual
operator!=(const int) const | CAsiApproxNum | virtual
operator<(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator<(const CAsiInt &) const | CAsiApproxNum | virtual
operator<(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator<(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator<(const CAsiFloat &) const | CAsiApproxNum | virtual
operator<(const CAsiReal &) const | CAsiApproxNum | virtual
operator<(const CAsiDouble &) const | CAsiApproxNum | virtual
operator<(const smallint) const | CAsiApproxNum | virtual
operator<(const integer) const | CAsiApproxNum | virtual
operator<(const real) const | CAsiApproxNum | virtual
operator<(const int) const | CAsiApproxNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator<=(const CAsiInt &) const | CAsiApproxNum | virtual
operator<=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator<=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator<=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator<=(const CAsiReal &) const | CAsiApproxNum | virtual
operator<=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator<=(const smallint) const | CAsiApproxNum | virtual
operator<=(const integer) const | CAsiApproxNum | virtual
operator<=(const real) const | CAsiApproxNum | virtual
operator<=(const int) const | CAsiApproxNum | virtual
operator==(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator==(const CAsiInt &) const | CAsiApproxNum | virtual
operator==(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator==(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator==(const CAsiFloat &) const | CAsiApproxNum | virtual
operator==(const CAsiReal &) const | CAsiApproxNum | virtual
operator==(const CAsiDouble &) const | CAsiApproxNum | virtual
operator==(const smallint) const | CAsiApproxNum | virtual
operator==(const integer) const | CAsiApproxNum | virtual
operator==(const real) const | CAsiApproxNum | virtual
operator==(const int) const | CAsiApproxNum | virtual
operator>(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator>(const CAsiInt &) const | CAsiApproxNum | virtual
operator>(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator>(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator>(const CAsiFloat &) const | CAsiApproxNum | virtual
operator>(const CAsiReal &) const | CAsiApproxNum | virtual
operator>(const CAsiDouble &) const | CAsiApproxNum | virtual
operator>(const smallint) const | CAsiApproxNum | virtual
operator>(const integer) const | CAsiApproxNum | virtual
operator>(const real) const | CAsiApproxNum | virtual
operator>(const int) const | CAsiApproxNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator>=(const CAsiInt &) const | CAsiApproxNum | virtual
operator>=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator>=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator>=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator>=(const CAsiReal &) const | CAsiApproxNum | virtual
operator>=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator>=(const smallint) const | CAsiApproxNum | virtual
operator>=(const integer) const | CAsiApproxNum | virtual
operator>=(const real) const | CAsiApproxNum | virtual
operator>=(const int) const | CAsiApproxNum | virtual
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
precision (defined in CAsiNum) | CAsiNum | protected
Precision(void) const | CAsiNum | virtual
realValue(void) const | CAsiNum | virtual
ReturnLength(void) const | CAsiData | virtual
Scale(void) const | CAsiNum | virtual
scale (defined in CAsiNum) | CAsiNum | protected
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const =0 | CAsiData | pure virtual
SQLType(CAsiUcStr *) const =0 | CAsiData | pure virtual
storeValue(real) | CAsiData | virtual
storeValue(integer) | CAsiData | virtual
storeValue(smallint) | CAsiData | virtual
storeValue(char *, uint) | CAsiData | virtual
storeValue(const CAsiUcStr &) | CAsiData | virtual
storeValue(char *, uint, uint *) | CAsiData | virtual
storeValue(const CAsiData &) | CAsiData | virtual
storeValue(const AsiUcStr) | CAsiData | virtual
storeValue(const DECIMAL &) | CAsiData | virtual
storeValue(const DB_NUMERIC *) | CAsiData | virtual
storeValue(const DBDATE *) | CAsiData | virtual
storeValue(const DBTIME *) | CAsiData | virtual
storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const =0 | CAsiData | pure virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiApproxNum() | CAsiApproxNum | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiBinary Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiBinary Class Reference
Misc Classes
+ Inheritance diagram for CAsiBinary:

Public Member Functions

CAsiBinary (uint)
CAsiBinary (const CAsiBinary &)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
EAsiBoolean | getBinValue (char *, uint, uint *) const
EAsiBoolean | getBinValue (CAsiUcStr *) const
EAsiBoolean | getHexValue (char *, uint, uint *) const
EAsiBoolean | getHexValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual uint | Length (void) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
int | operator!= (const CAsiBinary &) const
CAsiBinary | operator+ (const CAsiBinary &) const
int | operator< (const CAsiBinary &) const
int | operator<= (const CAsiBinary &) const
CAsiBinary & | operator= (const CAsiBinary &)
int | operator== (const CAsiBinary &) const
int | operator> (const CAsiBinary &) const
int | operator>= (const CAsiBinary &) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual uint | ReturnLength (void) const
void | setVarying (void)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
EAsiBoolean | storeBinValue (char *, uint, uint *)
EAsiBoolean | storeBinValue (const CAsiUcStr &)
EAsiBoolean | storeHexValue (char *, uint, uint *)
EAsiBoolean | storeHexValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const AsiUcStr)
CAsiBinary | Substring (uint)
CAsiBinary | Substring (uint, uint)
virtual EAsiDataType | Type (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

class CAsiTempTable

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiBinary Member List

This is the complete list of members for CAsiBinary, including all inherited members.

CAsiBinary() (defined in CAsiBinary) | CAsiBinary |
CAsiBinary(uint) (defined in CAsiBinary) | CAsiBinary |
CAsiBinary(const CAsiBinary &) (defined in CAsiBinary) | CAsiBinary |
CAsiData(void) | CAsiData |
CAsiObject(void) | CAsiObject |
CAsiTempTable (defined in CAsiBinary) | CAsiBinary | friend
checkAdd(const CAsiData *) const | CAsiData | virtual
checkCat(const CAsiData *) const (defined in CAsiBinary) | CAsiBinary | virtual
checkDiv(const CAsiData *) const | CAsiData | virtual
checkMul(const CAsiData *) const | CAsiData | virtual
checkSet(const CAsiData *) const (defined in CAsiBinary) | CAsiBinary | virtual
checkSub(const CAsiData *) const | CAsiData | virtual
Clear(void) (defined in CAsiBinary) | CAsiBinary | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiBinary) | CAsiBinary | virtual
FracSecPrec(void) const | CAsiData | virtual
getBinValue(char *, uint, uint *) const (defined in CAsiBinary) | CAsiBinary |
getBinValue(CAsiUcStr *) const (defined in CAsiBinary) | CAsiBinary |
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getHexValue(char *, uint, uint *) const (defined in CAsiBinary) | CAsiBinary |
getHexValue(CAsiUcStr *) const (defined in CAsiBinary) | CAsiBinary |
getValue(char *, uint) const (defined in CAsiBinary) | CAsiBinary | virtual
getValue(char *, uint, uint *) const (defined in CAsiBinary) | CAsiBinary | virtual
getValue(real *) const (defined in CAsiBinary) | CAsiBinary | virtual
getValue(integer *) const (defined in CAsiBinary) | CAsiBinary | virtual
getValue(smallint *) const (defined in CAsiBinary) | CAsiBinary | virtual
getValue(CAsiUcStr *) const (defined in CAsiBinary) | CAsiBinary | virtual
getValue(AsiUcStr, uint) const (defined in CAsiBinary) | CAsiBinary | virtual
getValue(CAsiData &) const (defined in CAsiBinary) | CAsiBinary | virtual
CAsiData::getValue(DECIMAL *) const | CAsiData | virtual
CAsiData::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiData::getValue(DBDATE *) const | CAsiData | virtual
CAsiData::getValue(DBTIME *) const | CAsiData | virtual
CAsiData::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const (defined in CAsiBinary) | CAsiBinary | virtual
is_castable(const CAsiData *) const (defined in CAsiBinary) | CAsiBinary | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const (defined in CAsiBinary) | CAsiBinary | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const (defined in CAsiBinary) | CAsiBinary | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiBinary) | CAsiBinary | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiBinary) | CAsiBinary | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const (defined in CAsiBinary) | CAsiBinary | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiBinary) | CAsiBinary | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiBinary) | CAsiBinary | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiBinary &) const (defined in CAsiBinary) | CAsiBinary |
operator+(const CAsiBinary &) const (defined in CAsiBinary) | CAsiBinary |
operator<(const CAsiBinary &) const (defined in CAsiBinary) | CAsiBinary |
operator<=(const CAsiBinary &) const (defined in CAsiBinary) | CAsiBinary |
operator=(const CAsiBinary &) (defined in CAsiBinary) | CAsiBinary |
operator==(const CAsiBinary &) const (defined in CAsiBinary) | CAsiBinary |
operator>(const CAsiBinary &) const (defined in CAsiBinary) | CAsiBinary |
operator>=(const CAsiBinary &) const (defined in CAsiBinary) | CAsiBinary |
packSize(void) const (defined in CAsiBinary) | CAsiBinary | virtual
packTo(CAsiObjPack *) const (defined in CAsiBinary) | CAsiBinary | virtual
packValueSize(void) const (defined in CAsiBinary) | CAsiBinary | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiBinary) | CAsiBinary | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const (defined in CAsiBinary) | CAsiBinary | virtual
Scale(void) const | CAsiData | virtual
setNull(void) | CAsiData | virtual
setVarying(void) (defined in CAsiBinary) | CAsiBinary |
SQLLiteral(CAsiUcStr *) const (defined in CAsiBinary) | CAsiBinary | virtual
SQLType(CAsiUcStr *) const (defined in CAsiBinary) | CAsiBinary | virtual
storeBinValue(char *, uint, uint *) (defined in CAsiBinary) | CAsiBinary |
storeBinValue(const CAsiUcStr &) (defined in CAsiBinary) | CAsiBinary |
storeHexValue(char *, uint, uint *) (defined in CAsiBinary) | CAsiBinary |
storeHexValue(const CAsiUcStr &) (defined in CAsiBinary) | CAsiBinary |
storeValue(char *, uint) (defined in CAsiBinary) | CAsiBinary | virtual
storeValue(char *, uint, uint *) (defined in CAsiBinary) | CAsiBinary | virtual
storeValue(const CAsiData &) (defined in CAsiBinary) | CAsiBinary | virtual
storeValue(real) (defined in CAsiBinary) | CAsiBinary | virtual
storeValue(integer) (defined in CAsiBinary) | CAsiBinary | virtual
storeValue(smallint) (defined in CAsiBinary) | CAsiBinary | virtual
storeValue(const CAsiUcStr &) (defined in CAsiBinary) | CAsiBinary | virtual
storeValue(const AsiUcStr) (defined in CAsiBinary) | CAsiBinary | virtual
CAsiData::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiData::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiData::storeValue(const DBDATE *) | CAsiData | virtual
CAsiData::storeValue(const DBTIME *) | CAsiData | virtual
CAsiData::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
Substring(uint) (defined in CAsiBinary) | CAsiBinary |
Substring(uint, uint) (defined in CAsiBinary) | CAsiBinary |
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiBinary) | CAsiBinary | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiBinary) | CAsiBinary | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiBinary) | CAsiBinary | virtual
~CAsiBinary() (defined in CAsiBinary) | CAsiBinary | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiBlob Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
CAsiBlob Class Reference
Misc Classes
+ Inheritance diagram for CAsiBlob:

Public Types

enum EBlobFormat {
kUnk = 0, kHex, kDec, kChr,
kOct, kBin
}
enum EBlobType {
kUnknown = 0, kBlob, kIPersist, kNonIPersist,
kADT
}

Public Member Functions

CAsiBlob (const CAsiBlob &)
virtual void | Clear ()
virtual CAsiObject * | duplicate () const
EAsiBoolean | get (IUnknown **)
EBlobType | GetType () const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual uint | Length () const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize () const
virtual unsigned long | packValueTo (CAsiObjPack *) const
HRESULT | Read (void *, ulong, ulong *)
HRESULT | ReadHead ()
virtual uint | ReturnLength () const
EAsiBoolean | set (IUnknown *)
void | SetFormat (EBlobFormat)
void | SetPrintLen (int)
void | SetType (EBlobType)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiDataType | Type () const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
HRESULT | Write (void *, ulong, ulong *)
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiBlob Member List

This is the complete list of members for CAsiBlob, including all inherited members.

CAsiBlob() (defined in CAsiBlob) | CAsiBlob |
CAsiBlob(const CAsiBlob &) (defined in CAsiBlob) | CAsiBlob |
CAsiData(void) | CAsiData |
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const | CAsiData | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiData | virtual
checkMul(const CAsiData *) const | CAsiData | virtual
checkSet(const CAsiData *) const | CAsiData | virtual
checkSub(const CAsiData *) const | CAsiData | virtual
Clear() (defined in CAsiBlob) | CAsiBlob | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate() const (defined in CAsiBlob) | CAsiBlob | virtual
EBlobFormat enum name (defined in CAsiBlob) | CAsiBlob |
EBlobType enum name (defined in CAsiBlob) | CAsiBlob |
FracSecPrec(void) const | CAsiData | virtual
get(IUnknown **) (defined in CAsiBlob) | CAsiBlob |
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
GetType() const (defined in CAsiBlob) | CAsiBlob |
getValue(real *) const (defined in CAsiBlob) | CAsiBlob | virtual
getValue(integer *) const (defined in CAsiBlob) | CAsiBlob | virtual
getValue(smallint *) const (defined in CAsiBlob) | CAsiBlob | virtual
getValue(char *, uint) const (defined in CAsiBlob) | CAsiBlob | virtual
getValue(CAsiUcStr *) const (defined in CAsiBlob) | CAsiBlob | virtual
getValue(CAsiData &) const (defined in CAsiBlob) | CAsiBlob | virtual
CAsiData::getValue(char *, uint, uint *) const | CAsiData | virtual
CAsiData::getValue(AsiUcStr, uint) const | CAsiData | virtual
CAsiData::getValue(DECIMAL *) const | CAsiData | virtual
CAsiData::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiData::getValue(DBDATE *) const | CAsiData | virtual
CAsiData::getValue(DBTIME *) const | CAsiData | virtual
CAsiData::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiData | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiData | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const | CAsiData | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const | CAsiData | virtual
isGreaterThan(const CAsiData &) const | CAsiData | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
kADT enum value (defined in CAsiBlob) | CAsiBlob |
kBin enum value (defined in CAsiBlob) | CAsiBlob |
kBlob enum value (defined in CAsiBlob) | CAsiBlob |
kChr enum value (defined in CAsiBlob) | CAsiBlob |
kDec enum value (defined in CAsiBlob) | CAsiBlob |
kHex enum value (defined in CAsiBlob) | CAsiBlob |
kIPersist enum value (defined in CAsiBlob) | CAsiBlob |
kNonIPersist enum value (defined in CAsiBlob) | CAsiBlob |
kOct enum value (defined in CAsiBlob) | CAsiBlob |
kUnk enum value (defined in CAsiBlob) | CAsiBlob |
kUnknown enum value (defined in CAsiBlob) | CAsiBlob |
LeadFieldPrec(void) const | CAsiData | virtual
Length() const (defined in CAsiBlob) | CAsiBlob | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiBlob) | CAsiBlob | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiBlob) | CAsiBlob | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const (defined in CAsiBlob) | CAsiBlob | virtual
packTo(CAsiObjPack *) const (defined in CAsiBlob) | CAsiBlob | virtual
packValueSize() const (defined in CAsiBlob) | CAsiBlob | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiBlob) | CAsiBlob | virtual
Precision(void) const | CAsiData | virtual
Read(void *, ulong, ulong *) (defined in CAsiBlob) | CAsiBlob |
ReadHead() (defined in CAsiBlob) | CAsiBlob |
ReturnLength() const (defined in CAsiBlob) | CAsiBlob | virtual
Scale(void) const | CAsiData | virtual
set(IUnknown *) (defined in CAsiBlob) | CAsiBlob |
SetFormat(EBlobFormat) (defined in CAsiBlob) | CAsiBlob |
setNull(void) | CAsiData | virtual
SetPrintLen(int) (defined in CAsiBlob) | CAsiBlob |
SetType(EBlobType) (defined in CAsiBlob) | CAsiBlob |
SQLLiteral(CAsiUcStr *) const (defined in CAsiBlob) | CAsiBlob | virtual
SQLType(CAsiUcStr *) const (defined in CAsiBlob) | CAsiBlob | virtual
storeValue(real) (defined in CAsiBlob) | CAsiBlob | virtual
storeValue(integer) (defined in CAsiBlob) | CAsiBlob | virtual
storeValue(smallint) (defined in CAsiBlob) | CAsiBlob | virtual
storeValue(char *, uint) (defined in CAsiBlob) | CAsiBlob | virtual
storeValue(const CAsiUcStr &) (defined in CAsiBlob) | CAsiBlob | virtual
storeValue(const CAsiData &) (defined in CAsiBlob) | CAsiBlob | virtual
storeValue(char *, uint, uint *) (defined in CAsiBlob) | CAsiBlob | virtual
CAsiData::storeValue(const AsiUcStr) | CAsiData | virtual
CAsiData::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiData::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiData::storeValue(const DBDATE *) | CAsiData | virtual
CAsiData::storeValue(const DBTIME *) | CAsiData | virtual
CAsiData::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type() const (defined in CAsiBlob) | CAsiBlob | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiBlob) | CAsiBlob | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiBlob) | CAsiBlob | virtual
Write(void *, ulong, ulong *) (defined in CAsiBlob) | CAsiBlob |
~CAsiBlob() (defined in CAsiBlob) | CAsiBlob | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiChar Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiChar Class Reference
Misc Classes
+ Inheritance diagram for CAsiChar:

Public Member Functions

uint | ByteSize (void) const
CAsiChar (uint)
CAsiChar (const CAsiChar &)
AsiUcIdCCT | CharSetIdent (void) const
const CAsiUcStr & | CharSetName (void) const
const CAsiUcStr & | charValue (void) const
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual void | Clear (void)
EAsiCAttr | Coercibility (void) const
AsiUcIdCLT | CollIdent (void) const
const CAsiUcStr & | CollName (void) const
virtual CAsiObject * | duplicate (void) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
EAsiBoolean | getValue (GUID *) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
EAsiBoolean | is_national (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual uint | Length (void) const
EAsiBoolean | Like (const CAsiChar &, const CAsiChar &) const
CAsiChar | Lower (void) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
int | operator!= (const CAsiChar &) const
int | operator!= (const CAsiUcStr &) const
CAsiChar | operator+ (const CAsiChar &) const
CAsiChar | operator+ (const CAsiUcStr &) const
int | operator< (const CAsiChar &) const
int | operator< (const CAsiUcStr &) const
int | operator<= (const CAsiChar &) const
int | operator<= (const CAsiUcStr &) const
CAsiChar & | operator= (const CAsiChar &)
CAsiChar & | operator= (const CAsiUcStr &)
int | operator== (const CAsiChar &) const
int | operator== (const CAsiUcStr &) const
int | operator> (const CAsiChar &) const
int | operator> (const CAsiUcStr &) const
int | operator>= (const CAsiChar &) const
int | operator>= (const CAsiUcStr &) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
CAsiNumeric | Position (const CAsiChar &) const
virtual uint | ReturnLength (void) const
void | setCharSet (const CAsiUcStr &)
void | setCoerc (EAsiCAttr)
void | setCollIdent (AsiUcIdCLT)
void | setCollName (const CAsiUcStr &)
void | setDefCharSet (void)
void | setNational (void)
void | setVarying (void)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
EAsiBoolean | storeValue (char *, uint, AsiUcIdCCT)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const AsiUcStr)
EAsiBoolean | storeValue (GUID *)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
CAsiChar | Substring (uint) const
CAsiChar | Substring (uint, uint) const
CAsiChar | Trim (EAsiTrimSpec, const CAsiChar &) const
virtual EAsiDataType | Type (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
CAsiChar | Upper (void) const
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

class | CAsiTempTable
int DLLScope | operator!= (const CAsiUcStr &, const CAsiChar &)
int DLLScope | operator< (const CAsiUcStr &, const CAsiChar &)
int DLLScope | operator<= (const CAsiUcStr &, const CAsiChar &)
int DLLScope | operator== (const CAsiUcStr &, const CAsiChar &)
int DLLScope | operator> (const CAsiUcStr &, const CAsiChar &)
int DLLScope | operator>= (const CAsiUcStr &, const CAsiChar &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiChar Member List

This is the complete list of members for CAsiChar, including all inherited members.

ByteSize(void) const (defined in CAsiChar) | CAsiChar |
CAsiChar() (defined in CAsiChar) | CAsiChar |
CAsiChar(uint) (defined in CAsiChar) | CAsiChar |
CAsiChar(const CAsiChar &) (defined in CAsiChar) | CAsiChar |
CAsiData(void) | CAsiData |
CAsiObject(void) | CAsiObject |
CAsiTempTable (defined in CAsiChar) | CAsiChar | friend
CharSetIdent(void) const (defined in CAsiChar) | CAsiChar |
CharSetName(void) const (defined in CAsiChar) | CAsiChar |
charValue(void) const (defined in CAsiChar) | CAsiChar |
checkAdd(const CAsiData *) const | CAsiData | virtual
checkCat(const CAsiData *) const (defined in CAsiChar) | CAsiChar | virtual
checkDiv(const CAsiData *) const | CAsiData | virtual
checkMul(const CAsiData *) const | CAsiData | virtual
checkSet(const CAsiData *) const (defined in CAsiChar) | CAsiChar | virtual
checkSub(const CAsiData *) const | CAsiData | virtual
Clear(void) (defined in CAsiChar) | CAsiChar | virtual
Coercibility(void) const (defined in CAsiChar) | CAsiChar |
CollIdent(void) const (defined in CAsiChar) | CAsiChar |
CollName(void) const (defined in CAsiChar) | CAsiChar |
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiChar) | CAsiChar | virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const (defined in CAsiChar) | CAsiChar | virtual
getValue(integer *) const (defined in CAsiChar) | CAsiChar | virtual
getValue(smallint *) const (defined in CAsiChar) | CAsiChar | virtual
getValue(char *, uint) const (defined in CAsiChar) | CAsiChar | virtual
getValue(CAsiUcStr *) const (defined in CAsiChar) | CAsiChar | virtual
getValue(char *, uint, uint *) const (defined in CAsiChar) | CAsiChar | virtual
getValue(AsiUcStr, uint) const (defined in CAsiChar) | CAsiChar | virtual
getValue(CAsiData &) const (defined in CAsiChar) | CAsiChar | virtual
getValue(GUID *) const (defined in CAsiChar) | CAsiChar |
CAsiData::getValue(DECIMAL *) const | CAsiData | virtual
CAsiData::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiData::getValue(DBDATE *) const | CAsiData | virtual
CAsiData::getValue(DBTIME *) const | CAsiData | virtual
CAsiData::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const (defined in CAsiChar) | CAsiChar | virtual
is_character(void) const (defined in CAsiChar) | CAsiChar | virtual
is_comparable(const CAsiData *) const (defined in CAsiChar) | CAsiChar | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_national(void) const (defined in CAsiChar) | CAsiChar |
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const (defined in CAsiChar) | CAsiChar | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiChar) | CAsiChar | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiChar) | CAsiChar | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const (defined in CAsiChar) | CAsiChar | virtual
Like(const CAsiChar &, const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
Lower(void) const (defined in CAsiChar) | CAsiChar |
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiChar) | CAsiChar | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiChar) | CAsiChar | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
operator!=(const CAsiUcStr &) const (defined in CAsiChar) | CAsiChar |
operator!= (defined in CAsiChar) | CAsiChar | friend
operator+(const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
operator+(const CAsiUcStr &) const (defined in CAsiChar) | CAsiChar |
operator<(const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
operator<(const CAsiUcStr &) const (defined in CAsiChar) | CAsiChar |
operator< (defined in CAsiChar) | CAsiChar | friend
operator<=(const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
operator<=(const CAsiUcStr &) const (defined in CAsiChar) | CAsiChar |
operator<= (defined in CAsiChar) | CAsiChar | friend
operator=(const CAsiChar &) (defined in CAsiChar) | CAsiChar |
operator=(const CAsiUcStr &) (defined in CAsiChar) | CAsiChar |
operator==(const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
operator==(const CAsiUcStr &) const (defined in CAsiChar) | CAsiChar |
operator== (defined in CAsiChar) | CAsiChar | friend
operator>(const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
operator>(const CAsiUcStr &) const (defined in CAsiChar) | CAsiChar |
operator> (defined in CAsiChar) | CAsiChar | friend
operator>=(const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
operator>=(const CAsiUcStr &) const (defined in CAsiChar) | CAsiChar |
operator>= (defined in CAsiChar) | CAsiChar | friend
packSize(void) const (defined in CAsiChar) | CAsiChar | virtual
packTo(CAsiObjPack *) const (defined in CAsiChar) | CAsiChar | virtual
packValueSize(void) const (defined in CAsiChar) | CAsiChar | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiChar) | CAsiChar | virtual
Position(const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
Precision(void) const | CAsiData | virtual
ReturnLength(void) const (defined in CAsiChar) | CAsiChar | virtual
Scale(void) const | CAsiData | virtual
setCharSet(const CAsiUcStr &) (defined in CAsiChar) | CAsiChar |
setCoerc(EAsiCAttr) (defined in CAsiChar) | CAsiChar |
setCollIdent(AsiUcIdCLT) (defined in CAsiChar) | CAsiChar |
setCollName(const CAsiUcStr &) (defined in CAsiChar) | CAsiChar |
setDefCharSet(void) (defined in CAsiChar) | CAsiChar |
setNational(void) (defined in CAsiChar) | CAsiChar |
setNull(void) | CAsiData | virtual
setVarying(void) (defined in CAsiChar) | CAsiChar |
SQLLiteral(CAsiUcStr *) const (defined in CAsiChar) | CAsiChar | virtual
SQLType(CAsiUcStr *) const (defined in CAsiChar) | CAsiChar | virtual
storeValue(real) (defined in CAsiChar) | CAsiChar | virtual
storeValue(integer) (defined in CAsiChar) | CAsiChar | virtual
storeValue(smallint) (defined in CAsiChar) | CAsiChar | virtual
storeValue(char *, uint) (defined in CAsiChar) | CAsiChar | virtual
storeValue(char *, uint, AsiUcIdCCT) (defined in CAsiChar) | CAsiChar |
storeValue(const CAsiUcStr &) (defined in CAsiChar) | CAsiChar | virtual
storeValue(const CAsiData &) (defined in CAsiChar) | CAsiChar | virtual
storeValue(const AsiUcStr) (defined in CAsiChar) | CAsiChar | virtual
storeValue(GUID *) (defined in CAsiChar) | CAsiChar |
storeValue(char *, uint, uint *) (defined in CAsiChar) | CAsiChar | virtual
CAsiData::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiData::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiData::storeValue(const DBDATE *) | CAsiData | virtual
CAsiData::storeValue(const DBTIME *) | CAsiData | virtual
CAsiData::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
Substring(uint) const (defined in CAsiChar) | CAsiChar |
Substring(uint, uint) const (defined in CAsiChar) | CAsiChar |
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Trim(EAsiTrimSpec, const CAsiChar &) const (defined in CAsiChar) | CAsiChar |
Type(void) const (defined in CAsiChar) | CAsiChar | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiChar) | CAsiChar | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiChar) | CAsiChar | virtual
Upper(void) const (defined in CAsiChar) | CAsiChar |
~CAsiChar() (defined in CAsiChar) | CAsiChar | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiColumn Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
CAsiColumn Class Reference
Misc Classes
+ Inheritance diagram for CAsiColumn:

Public Member Functions

CAsiColumn (const CAsiIdent &)
CAsiColumn (const CAsiIdent &, const CAsiSmallInt &)
CAsiColumn (const CAsiIdent &, const CAsiInt &)
CAsiColumn (const CAsiIdent &, const CAsiNumeric &)
CAsiColumn (const CAsiIdent &, const CAsiDecimal &)
CAsiColumn (const CAsiIdent &, const CAsiFloat &)
CAsiColumn (const CAsiIdent &, const CAsiReal &)
CAsiColumn (const CAsiIdent &, const CAsiDouble &)
CAsiColumn (const CAsiIdent &, const CAsiChar &)
CAsiColumn (const CAsiIdent &, const CAsiBinary &)
CAsiColumn (const CAsiIdent &, const CAsiDate &)
CAsiColumn (const CAsiIdent &, const CAsiTime &)
CAsiColumn (const CAsiIdent &, const CAsiTimeStamp &)
CAsiColumn (const CAsiIdent &, const CAsiYM &)
CAsiColumn (const CAsiIdent &, const CAsiDT &)
CAsiColumn (const CAsiIdent &, const CAsiIdent &)
CAsiColumn (const CAsiIdent &, CAsiData *)
CAsiColumn (const CAsiColumn &)
CAsiColumn (const DBCOLUMNINFO *)
virtual void | Clear (void)
const CAsiUcStr * | Collation (void) const
unsigned long | ColumnFlags (void) const
const DBCOLUMNINFO & | ColumnInfo (void) const
CAsiData * | Default (void) const
const CAsiIdent & | Domain (void) const
virtual CAsiObject * | duplicate (void) const
CAsiData * | getData (void) const
EAsiBoolean | IsBookmark (void) const
const CAsiIdent & | Name (void) const
EAsiBoolean | Native (void) const
EAsiBoolean | Nullable (void) const
uint | Offset (void) const
CAsiColumn & | operator= (const CAsiColumn &)
CAsiColumn & | operator= (CAsiData *)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
void | setCollation (const CAsiUcStr &)
void | setDataDsc (CAsiData *)
void | setDefault (CAsiData *)
void | setDomain (const CAsiIdent &)
void | setName (const CAsiIdent &)
void | setNative (EAsiBoolean)
void | setNullable (EAsiBoolean)
void | setOffset (uint)
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Protected Attributes

unsigned long | m_dwColFlags
EAsiBoolean | m_fNative
EAsiBoolean | m_fNullable
CAsiIdent | m_idDomain
CAsiIdent | m_idName
CAsiData * | m_pData
CAsiData * | m_pDefval
DBCOLUMNINFO | m_sColumnInfo
uint | m_uiOffset
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiColumn Member List

This is the complete list of members for CAsiColumn, including all inherited members.

CAsiColumn(void) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiSmallInt &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiInt &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiNumeric &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiDecimal &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiFloat &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiReal &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiDouble &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiChar &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiBinary &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiDate &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiTime &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiTimeStamp &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiYM &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiDT &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, const CAsiIdent &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiIdent &, CAsiData *) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const CAsiColumn &) (defined in CAsiColumn) | CAsiColumn |
CAsiColumn(const DBCOLUMNINFO *) (defined in CAsiColumn) | CAsiColumn |
CAsiObject(void) | CAsiObject |
Clear(void) (defined in CAsiColumn) | CAsiColumn | virtual
Collation(void) const (defined in CAsiColumn) | CAsiColumn |
ColumnFlags(void) const (defined in CAsiColumn) | CAsiColumn |
ColumnInfo(void) const (defined in CAsiColumn) | CAsiColumn |
Default(void) const (defined in CAsiColumn) | CAsiColumn |
Domain(void) const (defined in CAsiColumn) | CAsiColumn |
duplicate(void) const (defined in CAsiColumn) | CAsiColumn | virtual
getData(void) const (defined in CAsiColumn) | CAsiColumn |
IsBookmark(void) const (defined in CAsiColumn) | CAsiColumn |
m_dwColFlags (defined in CAsiColumn) | CAsiColumn | protected
m_fNative (defined in CAsiColumn) | CAsiColumn | protected
m_fNullable (defined in CAsiColumn) | CAsiColumn | protected
m_idDomain (defined in CAsiColumn) | CAsiColumn | protected
m_idName (defined in CAsiColumn) | CAsiColumn | protected
m_pData (defined in CAsiColumn) | CAsiColumn | protected
m_pDefval (defined in CAsiColumn) | CAsiColumn | protected
m_sColumnInfo (defined in CAsiColumn) | CAsiColumn | protected
m_uiOffset (defined in CAsiColumn) | CAsiColumn | protected
Name(void) const (defined in CAsiColumn) | CAsiColumn |
Native(void) const (defined in CAsiColumn) | CAsiColumn |
Nullable(void) const (defined in CAsiColumn) | CAsiColumn |
Offset(void) const (defined in CAsiColumn) | CAsiColumn |
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator=(const CAsiColumn &) (defined in CAsiColumn) | CAsiColumn |
operator=(CAsiData *) (defined in CAsiColumn) | CAsiColumn |
packSize(void) const (defined in CAsiColumn) | CAsiColumn | virtual
packTo(CAsiObjPack *) const (defined in CAsiColumn) | CAsiColumn | virtual
packValueSize(void) const (defined in CAsiColumn) | CAsiColumn | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiColumn) | CAsiColumn | virtual
setCollation(const CAsiUcStr &) (defined in CAsiColumn) | CAsiColumn |
setDataDsc(CAsiData *) (defined in CAsiColumn) | CAsiColumn |
setDefault(CAsiData *) (defined in CAsiColumn) | CAsiColumn |
setDomain(const CAsiIdent &) (defined in CAsiColumn) | CAsiColumn |
setName(const CAsiIdent &) (defined in CAsiColumn) | CAsiColumn |
setNative(EAsiBoolean) (defined in CAsiColumn) | CAsiColumn |
setNullable(EAsiBoolean) (defined in CAsiColumn) | CAsiColumn |
setOffset(uint) (defined in CAsiColumn) | CAsiColumn |
unpackFrom(CAsiObjPack *) (defined in CAsiColumn) | CAsiColumn | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiColumn) | CAsiColumn | virtual
~CAsiColumn() (defined in CAsiColumn) | CAsiColumn | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiCsr Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAsiCsr Class Reference
Misc Classes
+ Inheritance diagram for CAsiCsr:

Public Member Functions

EAsiBoolean | Allocate (CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse)
virtual EAsiBoolean | Bind (int, CAsiData *)
virtual EAsiBoolean | Bind (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Bind (const CAsiIdent &, CAsiData *)
virtual EAsiBoolean | Bind (const CAsiIdent &, void *, short *, int, EAsiHostType)
EAsiBoolean | Cancel (void)
CAsiCsr (void)
virtual EAsiBoolean | CheckCCondition (CAsiData **)
virtual EAsiBoolean | Close (void)
virtual CAsiColumn * | ColDsc (int) const
virtual int | ColQty (void) const
virtual EAsiBoolean | Cvl (int, CAsiData *)
virtual EAsiBoolean | Cvl (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Delete (void)
virtual EAsiBoolean | Fetch (void)
virtual EAsiBoolean | FetchAbsolute (long)
virtual EAsiBoolean | FetchFirst (void)
virtual EAsiBoolean | FetchLast (void)
virtual EAsiBoolean | FetchPrior (void)
virtual EAsiBoolean | FetchRelative (long)
CAsiRow * | getCurrentRow (void)
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
virtual EAsiBoolean | Insert (const CAsiRow &)
virtual EAsiBoolean | Insert (void)
virtual EAsiBoolean | is_insensitive (void) const
virtual EAsiBoolean | is_insertable (void) const
virtual EAsiBoolean | is_open (void) const
virtual EAsiBoolean | is_scrollable (void) const
virtual EAsiBoolean | is_updatable (void) const
virtual EAsiBoolean | IsRowset (void) const
virtual EAsiBoolean | Open (void)
virtual CAsiParameter * | ParamDsc (int) const
virtual int | ParamQty (void) const
virtual EAsiCurPos | position (void) const
virtual EAsiBoolean | Sob (int, CAsiData *)
virtual EAsiBoolean | Sob (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Update (const CAsiRow &)
virtual | ~CAsiCsr (void)
- Public Member Functions inherited from CAsiStm
CAsiStm (void)
void | SetSession (CAsiSession *)
virtual | ~CAsiStm (void)
- Public Member Functions inherited from CAsiSQLObject
EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

EAsiBoolean | DoChangeErrors (HRESULT hr, ULONG, DBBINDING *)
EAsiBoolean | GetColValue (int, CAsiData *)
EAsiBoolean | InitAccessor (ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &, ULONG *, DBBINDING **, HACCESSOR *, EAsiBoolean)
EAsiBoolean | InitOutputBind ()
EAsiBoolean | InsertRow (ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &)
EAsiBoolean | MakeCursorProp (DBPROPSET *pRowsetPropSet)
EAsiBoolean | QueryCursorProp (void)
EAsiBoolean | ReadData (void)
EAsiBoolean | SobValues (void)
EAsiBoolean | StoreValueFromDBType (CAsiData *, DBTYPE, void *)
EAsiBoolean | Svl (int)
EAsiBoolean | UpdateRow (ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &)
- Protected Member Functions inherited from CAsiStm
EAsiBoolean | CvlInt (int, CAsiData *) const
EAsiBoolean | InitColsDsc ()
EAsiBoolean | pInput (void)
- Protected Member Functions inherited from CAsiSQLObject
CAsiSQLObject ()
virtual EAsiBoolean | flushCond (void)
void | InheritStatusInfo (const CAsiSQLObject &)
EAsiBoolean | InitErrorInfo (HRESULT, IUnknown *, GUID)
EAsiBoolean | isInit (void) const
virtual EAsiBoolean | pushCond (void)
virtual EAsiBoolean | pushErr (EAsiError)
virtual EAsiBoolean | pushHResult (HRESULT)
void | ReleaseErrorInfo ()
virtual EAsiBoolean | setDiagPar (EAsiDiag, integer)
virtual EAsiBoolean | setDiagPar (EAsiDiag, const CAsiUcStr &)
virtual EAsiBoolean | setErr (EAsiError)
virtual EAsiBoolean | setErrMsg (const CAsiUcStr &)
virtual EAsiBoolean | setSQLSTATE (const char *)

Protected Attributes

CAsiIdent | m_CsrName
EAsiCurPos | m_CsrPos
DWORD | m_dwOffset
EAsiBoolean | m_fBlkStorObj
EAsiBoolean | m_fBLOBExpected
EAsiBoolean | m_fDataRead
EAsiBoolean | m_fIns
EAsiBoolean | m_fIsOpen
EAsiBoolean | m_fOwnInserts
EAsiBoolean | m_fOwnUpdates
EAsiBoolean | m_fUpd
HACCESSOR | m_hAccessor
int | m_iNumBind
DWORD | m_lCurrRow
DWORD | m_lRowCount
CAsiExecStm * | m_pCursorSpec
BYTE * | m_pData
IAccessor * | m_pIAccessor
IDataConvert * | m_pIDataConvert
IRowset * | m_pIRowset
IRowsetChange * | m_pIRowsetChange
IRowsetLocate * | m_pIRowsetLocate
IUnknown * | m_pIUnknown
CAsiTCCond * | m_pTCCond
DBBINDING * | m_rgBind
HROW * | m_rghRows
EAsiCurScr | m_ScrFlag
EAsiCurSns | m_SnsFlag
ULONG_PTR | m_ulColumns
ULONG | m_ulCurrentRowNo
ULONG | m_ulMaxRowNo
ULONG | m_ulRows
- Protected Attributes inherited from CAsiStm
ULONG_PTR | m_lColNumber
CAsiRow * | m_pAsiRow
DBCOLUMNINFO * | m_pColumnInfo
CAsiBinding * | m_pInput
CAsiBinding * | m_pOutput
CAsiSession * | m_pSession
OLECHAR * | m_pStringBuff
- Protected Attributes inherited from CAsiSQLObject
EAsiBoolean | m_CSP
EAsiStatement | m_eStmType
HRESULT | m_HResult
LONG_PTR | m_lRowCount
CAsiDSProperties * | m_pDSProperties
IErrorInfo * | m_pIErrorInfo

Friends

class CAsiExecStm

Constructor & Destructor Documentation

CAsiCsr::CAsiCsr ( void )
Warning
Not implemented!
virtual CAsiCsr::~CAsiCsr ( void )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAsiCsr::Allocate | ( | CAsiExecStm * | csrspec,
 |  | const CAsiIdent & | csrname,
 |  | EAsiCurScr | sc = kAsiNonScroll,
 |  | EAsiCurSns | sn = kAsiSnsUndef,
 |  | EAsiBoolean | upd = kAsiUnknown,
 |  | EAsiBoolean | fIns = kAsiFalse
 | ) |  |
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::Bind | ( | int | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiBoolean CAsiCsr::Bind | ( | int | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiBoolean CAsiCsr::Bind | ( | const CAsiIdent & | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiBoolean CAsiCsr::Bind | ( | const CAsiIdent & | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

EAsiBoolean CAsiCsr::Cancel ( void )
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::CheckCCondition ( CAsiData ** )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::Close ( void )
virtual
Warning
Not implemented!

Reimplemented in CAsiCsrTable.

virtual CAsiColumn* CAsiCsr::ColDsc ( int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

Reimplemented in CAsiCsrTable.

virtual int CAsiCsr::ColQty ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

Reimplemented in CAsiCsrTable.

virtual EAsiBoolean CAsiCsr::Cvl | ( | int | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

Reimplemented in CAsiCsrTable.

virtual EAsiBoolean CAsiCsr::Cvl | ( | int | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

Reimplemented in CAsiCsrTable.

virtual EAsiBoolean CAsiCsr::Delete ( void )
virtual
Warning
Not implemented!
EAsiBoolean CAsiCsr::DoChangeErrors | ( | HRESULT | hr,
 |  | ULONG | ,
 |  | DBBINDING * |
 | ) |  |
protected
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::Fetch ( void )
virtual
Warning
Not implemented!

Reimplemented in CAsiEnumerator.

virtual EAsiBoolean CAsiCsr::FetchAbsolute ( long )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::FetchFirst ( void )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::FetchLast ( void )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::FetchPrior ( void )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::FetchRelative ( long )
virtual
Warning
Not implemented!
EAsiBoolean CAsiCsr::GetColValue | ( | int | ,
 |  | CAsiData * |
 | ) |  |
protected
Warning
Not implemented!
CAsiRow* CAsiCsr::getCurrentRow ( void )
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::GetStatus | ( | EAsiStatInfo | ,
 |  | ULONG_PTR * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiSQLObject.

EAsiBoolean CAsiCsr::InitAccessor | ( | ULONG_PTR | ,
 |  | DBCOLUMNINFO * | ,
 |  | const CAsiRow & | ,
 |  | ULONG * | ,
 |  | DBBINDING ** | ,
 |  | HACCESSOR * | ,
 |  | EAsiBoolean |
 | ) |  |
protected
Warning
Not implemented!
EAsiBoolean CAsiCsr::InitOutputBind ( )
protected
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::Insert ( const CAsiRow & )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::Insert ( void )
virtual
Warning
Not implemented!
EAsiBoolean CAsiCsr::InsertRow | ( | ULONG_PTR | ,
 |  | DBCOLUMNINFO * | ,
 |  | const CAsiRow & |
 | ) |  |
protected
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::is_insensitive ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::is_insertable ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::is_open ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::is_scrollable ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::is_updatable ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::IsRowset ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiSQLObject.

EAsiBoolean CAsiCsr::MakeCursorProp ( DBPROPSET * pRowsetPropSet )
protected
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::Open ( void )
virtual
Warning
Not implemented!

Reimplemented in CAsiCsrTable.

virtual CAsiParameter* CAsiCsr::ParamDsc ( int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual int CAsiCsr::ParamQty ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiCurPos CAsiCsr::position ( void ) const
virtual
Warning
Not implemented!
EAsiBoolean CAsiCsr::QueryCursorProp ( void )
protected
Warning
Not implemented!
EAsiBoolean CAsiCsr::ReadData ( void )
protected
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::Sob | ( | int | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiBoolean CAsiCsr::Sob | ( | int | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

EAsiBoolean CAsiCsr::SobValues ( void )
protected
Warning
Not implemented!
EAsiBoolean CAsiCsr::StoreValueFromDBType | ( | CAsiData * | ,
 |  | DBTYPE | ,
 |  | void * |
 | ) |  |
protected
Warning
Not implemented!
EAsiBoolean CAsiCsr::Svl ( int )
protected
Warning
Not implemented!
virtual EAsiBoolean CAsiCsr::Update ( const CAsiRow & )
virtual
Warning
Not implemented!

Reimplemented in CAsiCsrTable.

EAsiBoolean CAsiCsr::UpdateRow | ( | ULONG_PTR | ,
 |  | DBCOLUMNINFO * | ,
 |  | const CAsiRow & |
 | ) |  |
protected
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiCsr Member List

This is the complete list of members for CAsiCsr, including all inherited members.

Allocate(CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse) | CAsiCsr |
Bind(int, CAsiData *) | CAsiCsr | virtual
Bind(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Bind(const CAsiIdent &, CAsiData *) | CAsiCsr | virtual
Bind(const CAsiIdent &, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Cancel(void) | CAsiCsr |
CAsiCsr(void) | CAsiCsr |
CAsiExecStm (defined in CAsiCsr) | CAsiCsr | friend
CAsiObject(void) | CAsiObject |
CAsiSQLObject() | CAsiSQLObject | protected
CAsiStm(void) | CAsiStm |
CheckCCondition(CAsiData **) | CAsiCsr | virtual
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
Close(void) | CAsiCsr | virtual
ColDsc(int) const | CAsiCsr | virtual
ColQty(void) const | CAsiCsr | virtual
CondQty(void) const | CAsiSQLObject | virtual
Cvl(int, CAsiData *) | CAsiCsr | virtual
Cvl(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
CvlInt(int, CAsiData *) const | CAsiStm | protected
DBMS(CAsiUcStr *) const | CAsiSQLObject |
Delete(void) | CAsiCsr | virtual
DoChangeErrors(HRESULT hr, ULONG, DBBINDING *) | CAsiCsr | protected
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
Fetch(void) | CAsiCsr | virtual
FetchAbsolute(long) | CAsiCsr | virtual
FetchFirst(void) | CAsiCsr | virtual
FetchLast(void) | CAsiCsr | virtual
FetchPrior(void) | CAsiCsr | virtual
FetchRelative(long) | CAsiCsr | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
GetColValue(int, CAsiData *) | CAsiCsr | protected
getCurrentRow(void) | CAsiCsr |
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiCsr | virtual
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
InitAccessor(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &, ULONG *, DBBINDING **, HACCESSOR *, EAsiBoolean) | CAsiCsr | protected
InitColsDsc() | CAsiStm | protected
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
InitOutputBind() | CAsiCsr | protected
Insert(const CAsiRow &) | CAsiCsr | virtual
Insert(void) | CAsiCsr | virtual
InsertRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
is_insensitive(void) const | CAsiCsr | virtual
is_insertable(void) const | CAsiCsr | virtual
is_open(void) const | CAsiCsr | virtual
is_scrollable(void) const | CAsiCsr | virtual
is_updatable(void) const | CAsiCsr | virtual
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiCsr | virtual
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_CsrName (defined in CAsiCsr) | CAsiCsr | protected
m_CsrPos (defined in CAsiCsr) | CAsiCsr | protected
m_dwOffset (defined in CAsiCsr) | CAsiCsr | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_fBlkStorObj (defined in CAsiCsr) | CAsiCsr | protected
m_fBLOBExpected (defined in CAsiCsr) | CAsiCsr | protected
m_fDataRead (defined in CAsiCsr) | CAsiCsr | protected
m_fIns (defined in CAsiCsr) | CAsiCsr | protected
m_fIsOpen (defined in CAsiCsr) | CAsiCsr | protected
m_fOwnInserts (defined in CAsiCsr) | CAsiCsr | protected
m_fOwnUpdates (defined in CAsiCsr) | CAsiCsr | protected
m_fUpd (defined in CAsiCsr) | CAsiCsr | protected
m_hAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_iNumBind (defined in CAsiCsr) | CAsiCsr | protected
m_lColNumber (defined in CAsiStm) | CAsiStm | protected
m_lCurrRow (defined in CAsiCsr) | CAsiCsr | protected
m_lRowCount (defined in CAsiCsr) | CAsiCsr | protected
m_pAsiRow (defined in CAsiStm) | CAsiStm | protected
m_pColumnInfo (defined in CAsiStm) | CAsiStm | protected
m_pCursorSpec (defined in CAsiCsr) | CAsiCsr | protected
m_pData (defined in CAsiCsr) | CAsiCsr | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pIAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_pIDataConvert (defined in CAsiCsr) | CAsiCsr | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pInput (defined in CAsiStm) | CAsiStm | protected
m_pIRowset (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetChange (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetLocate (defined in CAsiCsr) | CAsiCsr | protected
m_pIUnknown (defined in CAsiCsr) | CAsiCsr | protected
m_pOutput (defined in CAsiStm) | CAsiStm | protected
m_pSession (defined in CAsiStm) | CAsiStm | protected
m_pStringBuff (defined in CAsiStm) | CAsiStm | protected
m_pTCCond (defined in CAsiCsr) | CAsiCsr | protected
m_rgBind (defined in CAsiCsr) | CAsiCsr | protected
m_rghRows (defined in CAsiCsr) | CAsiCsr | protected
m_ScrFlag (defined in CAsiCsr) | CAsiCsr | protected
m_SnsFlag (defined in CAsiCsr) | CAsiCsr | protected
m_ulColumns (defined in CAsiCsr) | CAsiCsr | protected
m_ulCurrentRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulMaxRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulRows (defined in CAsiCsr) | CAsiCsr | protected
MakeCursorProp(DBPROPSET *pRowsetPropSet) | CAsiCsr | protected
Open(void) | CAsiCsr | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
ParamDsc(int) const | CAsiCsr | virtual
ParamQty(void) const | CAsiCsr | virtual
pInput(void) | CAsiStm | protected
position(void) const | CAsiCsr | virtual
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
QueryCursorProp(void) | CAsiCsr | protected
ReadData(void) | CAsiCsr | protected
ReleaseErrorInfo() | CAsiSQLObject | protected
RowCount(void) const | CAsiSQLObject |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
SetSession(CAsiSession *) | CAsiStm |
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
Sob(int, CAsiData *) | CAsiCsr | virtual
Sob(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
SobValues(void) | CAsiCsr | protected
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
StoreValueFromDBType(CAsiData *, DBTYPE, void *) | CAsiCsr | protected
Svl(int) | CAsiCsr | protected
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Update(const CAsiRow &) | CAsiCsr | virtual
UpdateRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
Version(void) const | CAsiSQLObject |
~CAsiCsr(void) | CAsiCsr | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual
~CAsiStm(void) | CAsiStm | virtual


ZRX API Reference: CAsiCsrInfSchema Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
CAsiCsrInfSchema Class Reference
Misc Classes
+ Inheritance diagram for CAsiCsrInfSchema:

Public Member Functions

EAsiBoolean | Allocate (CAsiSession *ses, EAsiInfSchTab ischema, EAsiCurScr sc=kAsiNonScroll)
CAsiCsrInfSchema (void)
virtual | ~CAsiCsrInfSchema (void)
- Public Member Functions inherited from CAsiCsrTable
CAsiCsrTable (void)
virtual EAsiBoolean | Close (void)
virtual CAsiColumn * | ColDsc (int) const
virtual int | ColQty (void) const
virtual EAsiBoolean | Cvl (int, CAsiData *)
virtual EAsiBoolean | Cvl (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Open (void)
virtual EAsiBoolean | SetFilter (CAsiTCCond *)
virtual EAsiBoolean | SetOrder ()
virtual EAsiBoolean | Update (const CAsiRow &)
virtual | ~CAsiCsrTable (void)
- Public Member Functions inherited from CAsiCsr
EAsiBoolean | Allocate (CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse)
virtual EAsiBoolean | Bind (int, CAsiData *)
virtual EAsiBoolean | Bind (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Bind (const CAsiIdent &, CAsiData *)
virtual EAsiBoolean | Bind (const CAsiIdent &, void *, short *, int, EAsiHostType)
EAsiBoolean | Cancel (void)
CAsiCsr (void)
virtual EAsiBoolean | CheckCCondition (CAsiData **)
virtual EAsiBoolean | Delete (void)
virtual EAsiBoolean | Fetch (void)
virtual EAsiBoolean | FetchAbsolute (long)
virtual EAsiBoolean | FetchFirst (void)
virtual EAsiBoolean | FetchLast (void)
virtual EAsiBoolean | FetchPrior (void)
virtual EAsiBoolean | FetchRelative (long)
CAsiRow * | getCurrentRow (void)
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
virtual EAsiBoolean | Insert (const CAsiRow &)
virtual EAsiBoolean | Insert (void)
virtual EAsiBoolean | is_insensitive (void) const
virtual EAsiBoolean | is_insertable (void) const
virtual EAsiBoolean | is_open (void) const
virtual EAsiBoolean | is_scrollable (void) const
virtual EAsiBoolean | is_updatable (void) const
virtual EAsiBoolean | IsRowset (void) const
virtual CAsiParameter * | ParamDsc (int) const
virtual int | ParamQty (void) const
virtual EAsiCurPos | position (void) const
virtual EAsiBoolean | Sob (int, CAsiData *)
virtual EAsiBoolean | Sob (int, void *, short *, int, EAsiHostType)
virtual | ~CAsiCsr (void)
- Public Member Functions inherited from CAsiStm
CAsiStm (void)
void | SetSession (CAsiSession *)
virtual | ~CAsiStm (void)
- Public Member Functions inherited from CAsiSQLObject
EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Attributes

EAsiInfSchTab m_istType

Additional Inherited Members

- Protected Member Functions inherited from CAsiCsrTable
void DeallocCsr (void)

Constructor & Destructor Documentation

CAsiCsrInfSchema::CAsiCsrInfSchema ( void )
Warning
Not implemented!
virtual CAsiCsrInfSchema::~CAsiCsrInfSchema ( void )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAsiCsrInfSchema::Allocate | ( | CAsiSession * | ses,
 |  | EAsiInfSchTab | ischema,
 |  | EAsiCurScr | sc = kAsiNonScroll
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiCsrInfSchema Member List

This is the complete list of members for CAsiCsrInfSchema, including all inherited members.

Allocate(CAsiSession *ses, EAsiInfSchTab ischema, EAsiCurScr sc=kAsiNonScroll) | CAsiCsrInfSchema |
CAsiCsrTable::Allocate(CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse) | CAsiCsr |
Bind(int, CAsiData *) | CAsiCsr | virtual
Bind(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Bind(const CAsiIdent &, CAsiData *) | CAsiCsr | virtual
Bind(const CAsiIdent &, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Cancel(void) | CAsiCsr |
CAsiCsr(void) | CAsiCsr |
CAsiCsrInfSchema(void) | CAsiCsrInfSchema |
CAsiCsrTable(void) | CAsiCsrTable |
CAsiObject(void) | CAsiObject |
CAsiSQLObject() | CAsiSQLObject | protected
CAsiStm(void) | CAsiStm |
CheckCCondition(CAsiData **) | CAsiCsr | virtual
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
Close(void) | CAsiCsrTable | virtual
ColDsc(int) const | CAsiCsrTable | virtual
ColQty(void) const | CAsiCsrTable | virtual
CondQty(void) const | CAsiSQLObject | virtual
Cvl(int, CAsiData *) | CAsiCsrTable | virtual
Cvl(int, void *, short *, int, EAsiHostType) | CAsiCsrTable | virtual
CvlInt(int, CAsiData *) const | CAsiStm | protected
DBMS(CAsiUcStr *) const | CAsiSQLObject |
DeallocCsr(void) | CAsiCsrTable | protected
Delete(void) | CAsiCsr | virtual
DoChangeErrors(HRESULT hr, ULONG, DBBINDING *) | CAsiCsr | protected
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
Fetch(void) | CAsiCsr | virtual
FetchAbsolute(long) | CAsiCsr | virtual
FetchFirst(void) | CAsiCsr | virtual
FetchLast(void) | CAsiCsr | virtual
FetchPrior(void) | CAsiCsr | virtual
FetchRelative(long) | CAsiCsr | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
GetColValue(int, CAsiData *) | CAsiCsr | protected
getCurrentRow(void) | CAsiCsr |
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiCsr | virtual
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
InitAccessor(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &, ULONG *, DBBINDING **, HACCESSOR *, EAsiBoolean) | CAsiCsr | protected
InitColsDsc() | CAsiStm | protected
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
InitOutputBind() | CAsiCsr | protected
Insert(const CAsiRow &) | CAsiCsr | virtual
Insert(void) | CAsiCsr | virtual
InsertRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
is_insensitive(void) const | CAsiCsr | virtual
is_insertable(void) const | CAsiCsr | virtual
is_open(void) const | CAsiCsr | virtual
is_scrollable(void) const | CAsiCsr | virtual
is_updatable(void) const | CAsiCsr | virtual
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiCsr | virtual
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_CsrName (defined in CAsiCsr) | CAsiCsr | protected
m_CsrPos (defined in CAsiCsr) | CAsiCsr | protected
m_dwOffset (defined in CAsiCsr) | CAsiCsr | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_fBlkStorObj (defined in CAsiCsr) | CAsiCsr | protected
m_fBLOBExpected (defined in CAsiCsr) | CAsiCsr | protected
m_fDataRead (defined in CAsiCsr) | CAsiCsr | protected
m_fIns (defined in CAsiCsr) | CAsiCsr | protected
m_fIsOpen (defined in CAsiCsr) | CAsiCsr | protected
m_fOwnInserts (defined in CAsiCsr) | CAsiCsr | protected
m_fOwnUpdates (defined in CAsiCsr) | CAsiCsr | protected
m_fUpd (defined in CAsiCsr) | CAsiCsr | protected
m_hAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_iNumBind (defined in CAsiCsr) | CAsiCsr | protected
m_istType (defined in CAsiCsrInfSchema) | CAsiCsrInfSchema | protected
m_lColNumber (defined in CAsiStm) | CAsiStm | protected
m_lCurrRow (defined in CAsiCsr) | CAsiCsr | protected
m_lRowCount (defined in CAsiCsr) | CAsiCsr | protected
m_pAsiRow (defined in CAsiStm) | CAsiStm | protected
m_pColumnInfo (defined in CAsiStm) | CAsiStm | protected
m_pCursorSpec (defined in CAsiCsr) | CAsiCsr | protected
m_pData (defined in CAsiCsr) | CAsiCsr | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pIAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_pIDataConvert (defined in CAsiCsr) | CAsiCsr | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pInput (defined in CAsiStm) | CAsiStm | protected
m_pIRowset (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetChange (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetLocate (defined in CAsiCsr) | CAsiCsr | protected
m_pIUnknown (defined in CAsiCsr) | CAsiCsr | protected
m_pOutput (defined in CAsiStm) | CAsiStm | protected
m_pSession (defined in CAsiStm) | CAsiStm | protected
m_pStringBuff (defined in CAsiStm) | CAsiStm | protected
m_pTCCond (defined in CAsiCsr) | CAsiCsr | protected
m_rgBind (defined in CAsiCsr) | CAsiCsr | protected
m_rghRows (defined in CAsiCsr) | CAsiCsr | protected
m_ScrFlag (defined in CAsiCsr) | CAsiCsr | protected
m_SnsFlag (defined in CAsiCsr) | CAsiCsr | protected
m_ulColumns (defined in CAsiCsr) | CAsiCsr | protected
m_ulCurrentRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulMaxRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulRows (defined in CAsiCsr) | CAsiCsr | protected
MakeCursorProp(DBPROPSET *pRowsetPropSet) | CAsiCsr | protected
Open(void) | CAsiCsrTable | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
ParamDsc(int) const | CAsiCsr | virtual
ParamQty(void) const | CAsiCsr | virtual
pInput(void) | CAsiStm | protected
position(void) const | CAsiCsr | virtual
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
QueryCursorProp(void) | CAsiCsr | protected
ReadData(void) | CAsiCsr | protected
ReleaseErrorInfo() | CAsiSQLObject | protected
RowCount(void) const | CAsiSQLObject |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
SetFilter(CAsiTCCond *) | CAsiCsrTable | virtual
SetOrder() | CAsiCsrTable | virtual
SetSession(CAsiSession *) | CAsiStm |
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
Sob(int, CAsiData *) | CAsiCsr | virtual
Sob(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
SobValues(void) | CAsiCsr | protected
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
StoreValueFromDBType(CAsiData *, DBTYPE, void *) | CAsiCsr | protected
Svl(int) | CAsiCsr | protected
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Update(const CAsiRow &) | CAsiCsrTable | virtual
UpdateRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
Version(void) const | CAsiSQLObject |
~CAsiCsr(void) | CAsiCsr | virtual
~CAsiCsrInfSchema(void) | CAsiCsrInfSchema | virtual
~CAsiCsrTable(void) | CAsiCsrTable | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual
~CAsiStm(void) | CAsiStm | virtual


ZRX API Reference: CAsiCsrRegTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
CAsiCsrRegTable Class Reference
Misc Classes
+ Inheritance diagram for CAsiCsrRegTable:

Public Member Functions

EAsiBoolean | Allocate (CAsiSession *ses, const CAsiUcStr &catalog, const CAsiUcStr &schema, const CAsiUcStr &table, EAsiCurScr sc=kAsiNonScroll, EAsiBoolean upd=kAsiUnknown)
CAsiCsrRegTable (void)
virtual | ~CAsiCsrRegTable (void)
- Public Member Functions inherited from CAsiCsrTable
CAsiCsrTable (void)
virtual EAsiBoolean | Close (void)
virtual CAsiColumn * | ColDsc (int) const
virtual int | ColQty (void) const
virtual EAsiBoolean | Cvl (int, CAsiData *)
virtual EAsiBoolean | Cvl (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Open (void)
virtual EAsiBoolean | SetFilter (CAsiTCCond *)
virtual EAsiBoolean | SetOrder ()
virtual EAsiBoolean | Update (const CAsiRow &)
virtual | ~CAsiCsrTable (void)
- Public Member Functions inherited from CAsiCsr
EAsiBoolean | Allocate (CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse)
virtual EAsiBoolean | Bind (int, CAsiData *)
virtual EAsiBoolean | Bind (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Bind (const CAsiIdent &, CAsiData *)
virtual EAsiBoolean | Bind (const CAsiIdent &, void *, short *, int, EAsiHostType)
EAsiBoolean | Cancel (void)
CAsiCsr (void)
virtual EAsiBoolean | CheckCCondition (CAsiData **)
virtual EAsiBoolean | Delete (void)
virtual EAsiBoolean | Fetch (void)
virtual EAsiBoolean | FetchAbsolute (long)
virtual EAsiBoolean | FetchFirst (void)
virtual EAsiBoolean | FetchLast (void)
virtual EAsiBoolean | FetchPrior (void)
virtual EAsiBoolean | FetchRelative (long)
CAsiRow * | getCurrentRow (void)
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
virtual EAsiBoolean | Insert (const CAsiRow &)
virtual EAsiBoolean | Insert (void)
virtual EAsiBoolean | is_insensitive (void) const
virtual EAsiBoolean | is_insertable (void) const
virtual EAsiBoolean | is_open (void) const
virtual EAsiBoolean | is_scrollable (void) const
virtual EAsiBoolean | is_updatable (void) const
virtual EAsiBoolean | IsRowset (void) const
virtual CAsiParameter * | ParamDsc (int) const
virtual int | ParamQty (void) const
virtual EAsiCurPos | position (void) const
virtual EAsiBoolean | Sob (int, CAsiData *)
virtual EAsiBoolean | Sob (int, void *, short *, int, EAsiHostType)
virtual | ~CAsiCsr (void)
- Public Member Functions inherited from CAsiStm
CAsiStm (void)
void | SetSession (CAsiSession *)
virtual | ~CAsiStm (void)
- Public Member Functions inherited from CAsiSQLObject
EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Attributes

CAsiUcStr | m_pCatalog
CAsiUcStr | m_pName
CAsiUcStr | m_pSchema

Additional Inherited Members

- Protected Member Functions inherited from CAsiCsrTable
void DeallocCsr (void)

Constructor & Destructor Documentation

CAsiCsrRegTable::CAsiCsrRegTable ( void )
Warning
Not implemented!
virtual CAsiCsrRegTable::~CAsiCsrRegTable ( void )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAsiCsrRegTable::Allocate | ( | CAsiSession * | ses,
 |  | const CAsiUcStr & | catalog,
 |  | const CAsiUcStr & | schema,
 |  | const CAsiUcStr & | table,
 |  | EAsiCurScr | sc = kAsiNonScroll,
 |  | EAsiBoolean | upd = kAsiUnknown
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiCsrRegTable Member List

This is the complete list of members for CAsiCsrRegTable, including all inherited members.

Allocate(CAsiSession *ses, const CAsiUcStr &catalog, const CAsiUcStr &schema, const CAsiUcStr &table, EAsiCurScr sc=kAsiNonScroll, EAsiBoolean upd=kAsiUnknown) | CAsiCsrRegTable |
CAsiCsrTable::Allocate(CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse) | CAsiCsr |
Bind(int, CAsiData *) | CAsiCsr | virtual
Bind(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Bind(const CAsiIdent &, CAsiData *) | CAsiCsr | virtual
Bind(const CAsiIdent &, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Cancel(void) | CAsiCsr |
CAsiCsr(void) | CAsiCsr |
CAsiCsrRegTable(void) | CAsiCsrRegTable |
CAsiCsrTable(void) | CAsiCsrTable |
CAsiObject(void) | CAsiObject |
CAsiSQLObject() | CAsiSQLObject | protected
CAsiStm(void) | CAsiStm |
CheckCCondition(CAsiData **) | CAsiCsr | virtual
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
Close(void) | CAsiCsrTable | virtual
ColDsc(int) const | CAsiCsrTable | virtual
ColQty(void) const | CAsiCsrTable | virtual
CondQty(void) const | CAsiSQLObject | virtual
Cvl(int, CAsiData *) | CAsiCsrTable | virtual
Cvl(int, void *, short *, int, EAsiHostType) | CAsiCsrTable | virtual
CvlInt(int, CAsiData *) const | CAsiStm | protected
DBMS(CAsiUcStr *) const | CAsiSQLObject |
DeallocCsr(void) | CAsiCsrTable | protected
Delete(void) | CAsiCsr | virtual
DoChangeErrors(HRESULT hr, ULONG, DBBINDING *) | CAsiCsr | protected
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
Fetch(void) | CAsiCsr | virtual
FetchAbsolute(long) | CAsiCsr | virtual
FetchFirst(void) | CAsiCsr | virtual
FetchLast(void) | CAsiCsr | virtual
FetchPrior(void) | CAsiCsr | virtual
FetchRelative(long) | CAsiCsr | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
GetColValue(int, CAsiData *) | CAsiCsr | protected
getCurrentRow(void) | CAsiCsr |
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiCsr | virtual
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
InitAccessor(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &, ULONG *, DBBINDING **, HACCESSOR *, EAsiBoolean) | CAsiCsr | protected
InitColsDsc() | CAsiStm | protected
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
InitOutputBind() | CAsiCsr | protected
Insert(const CAsiRow &) | CAsiCsr | virtual
Insert(void) | CAsiCsr | virtual
InsertRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
is_insensitive(void) const | CAsiCsr | virtual
is_insertable(void) const | CAsiCsr | virtual
is_open(void) const | CAsiCsr | virtual
is_scrollable(void) const | CAsiCsr | virtual
is_updatable(void) const | CAsiCsr | virtual
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiCsr | virtual
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_CsrName (defined in CAsiCsr) | CAsiCsr | protected
m_CsrPos (defined in CAsiCsr) | CAsiCsr | protected
m_dwOffset (defined in CAsiCsr) | CAsiCsr | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_fBlkStorObj (defined in CAsiCsr) | CAsiCsr | protected
m_fBLOBExpected (defined in CAsiCsr) | CAsiCsr | protected
m_fDataRead (defined in CAsiCsr) | CAsiCsr | protected
m_fIns (defined in CAsiCsr) | CAsiCsr | protected
m_fIsOpen (defined in CAsiCsr) | CAsiCsr | protected
m_fOwnInserts (defined in CAsiCsr) | CAsiCsr | protected
m_fOwnUpdates (defined in CAsiCsr) | CAsiCsr | protected
m_fUpd (defined in CAsiCsr) | CAsiCsr | protected
m_hAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_iNumBind (defined in CAsiCsr) | CAsiCsr | protected
m_lColNumber (defined in CAsiStm) | CAsiStm | protected
m_lCurrRow (defined in CAsiCsr) | CAsiCsr | protected
m_lRowCount (defined in CAsiCsr) | CAsiCsr | protected
m_pAsiRow (defined in CAsiStm) | CAsiStm | protected
m_pCatalog (defined in CAsiCsrRegTable) | CAsiCsrRegTable | protected
m_pColumnInfo (defined in CAsiStm) | CAsiStm | protected
m_pCursorSpec (defined in CAsiCsr) | CAsiCsr | protected
m_pData (defined in CAsiCsr) | CAsiCsr | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pIAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_pIDataConvert (defined in CAsiCsr) | CAsiCsr | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pInput (defined in CAsiStm) | CAsiStm | protected
m_pIRowset (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetChange (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetLocate (defined in CAsiCsr) | CAsiCsr | protected
m_pIUnknown (defined in CAsiCsr) | CAsiCsr | protected
m_pName (defined in CAsiCsrRegTable) | CAsiCsrRegTable | protected
m_pOutput (defined in CAsiStm) | CAsiStm | protected
m_pSchema (defined in CAsiCsrRegTable) | CAsiCsrRegTable | protected
m_pSession (defined in CAsiStm) | CAsiStm | protected
m_pStringBuff (defined in CAsiStm) | CAsiStm | protected
m_pTCCond (defined in CAsiCsr) | CAsiCsr | protected
m_rgBind (defined in CAsiCsr) | CAsiCsr | protected
m_rghRows (defined in CAsiCsr) | CAsiCsr | protected
m_ScrFlag (defined in CAsiCsr) | CAsiCsr | protected
m_SnsFlag (defined in CAsiCsr) | CAsiCsr | protected
m_ulColumns (defined in CAsiCsr) | CAsiCsr | protected
m_ulCurrentRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulMaxRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulRows (defined in CAsiCsr) | CAsiCsr | protected
MakeCursorProp(DBPROPSET *pRowsetPropSet) | CAsiCsr | protected
Open(void) | CAsiCsrTable | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
ParamDsc(int) const | CAsiCsr | virtual
ParamQty(void) const | CAsiCsr | virtual
pInput(void) | CAsiStm | protected
position(void) const | CAsiCsr | virtual
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
QueryCursorProp(void) | CAsiCsr | protected
ReadData(void) | CAsiCsr | protected
ReleaseErrorInfo() | CAsiSQLObject | protected
RowCount(void) const | CAsiSQLObject |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
SetFilter(CAsiTCCond *) | CAsiCsrTable | virtual
SetOrder() | CAsiCsrTable | virtual
SetSession(CAsiSession *) | CAsiStm |
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
Sob(int, CAsiData *) | CAsiCsr | virtual
Sob(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
SobValues(void) | CAsiCsr | protected
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
StoreValueFromDBType(CAsiData *, DBTYPE, void *) | CAsiCsr | protected
Svl(int) | CAsiCsr | protected
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Update(const CAsiRow &) | CAsiCsrTable | virtual
UpdateRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
Version(void) const | CAsiSQLObject |
~CAsiCsr(void) | CAsiCsr | virtual
~CAsiCsrRegTable(void) | CAsiCsrRegTable | virtual
~CAsiCsrTable(void) | CAsiCsrTable | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual
~CAsiStm(void) | CAsiStm | virtual


ZRX API Reference: CAsiCsrTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAsiCsrTable Class Reference
Misc Classes
+ Inheritance diagram for CAsiCsrTable:

Public Member Functions

CAsiCsrTable (void)
virtual EAsiBoolean | Close (void)
virtual CAsiColumn * | ColDsc (int) const
virtual int | ColQty (void) const
virtual EAsiBoolean | Cvl (int, CAsiData *)
virtual EAsiBoolean | Cvl (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Open (void)
virtual EAsiBoolean | SetFilter (CAsiTCCond *)
virtual EAsiBoolean | SetOrder ()
virtual EAsiBoolean | Update (const CAsiRow &)
virtual | ~CAsiCsrTable (void)
- Public Member Functions inherited from CAsiCsr
EAsiBoolean | Allocate (CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse)
virtual EAsiBoolean | Bind (int, CAsiData *)
virtual EAsiBoolean | Bind (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Bind (const CAsiIdent &, CAsiData *)
virtual EAsiBoolean | Bind (const CAsiIdent &, void *, short *, int, EAsiHostType)
EAsiBoolean | Cancel (void)
CAsiCsr (void)
virtual EAsiBoolean | CheckCCondition (CAsiData **)
virtual EAsiBoolean | Delete (void)
virtual EAsiBoolean | Fetch (void)
virtual EAsiBoolean | FetchAbsolute (long)
virtual EAsiBoolean | FetchFirst (void)
virtual EAsiBoolean | FetchLast (void)
virtual EAsiBoolean | FetchPrior (void)
virtual EAsiBoolean | FetchRelative (long)
CAsiRow * | getCurrentRow (void)
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
virtual EAsiBoolean | Insert (const CAsiRow &)
virtual EAsiBoolean | Insert (void)
virtual EAsiBoolean | is_insensitive (void) const
virtual EAsiBoolean | is_insertable (void) const
virtual EAsiBoolean | is_open (void) const
virtual EAsiBoolean | is_scrollable (void) const
virtual EAsiBoolean | is_updatable (void) const
virtual EAsiBoolean | IsRowset (void) const
virtual CAsiParameter * | ParamDsc (int) const
virtual int | ParamQty (void) const
virtual EAsiCurPos | position (void) const
virtual EAsiBoolean | Sob (int, CAsiData *)
virtual EAsiBoolean | Sob (int, void *, short *, int, EAsiHostType)
virtual | ~CAsiCsr (void)
- Public Member Functions inherited from CAsiStm
CAsiStm (void)
void | SetSession (CAsiSession *)
virtual | ~CAsiStm (void)
- Public Member Functions inherited from CAsiSQLObject
EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

void | DeallocCsr (void)
- Protected Member Functions inherited from CAsiCsr
EAsiBoolean | DoChangeErrors (HRESULT hr, ULONG, DBBINDING *)
EAsiBoolean | GetColValue (int, CAsiData *)
EAsiBoolean | InitAccessor (ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &, ULONG *, DBBINDING **, HACCESSOR *, EAsiBoolean)
EAsiBoolean | InitOutputBind ()
EAsiBoolean | InsertRow (ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &)
EAsiBoolean | MakeCursorProp (DBPROPSET *pRowsetPropSet)
EAsiBoolean | QueryCursorProp (void)
EAsiBoolean | ReadData (void)
EAsiBoolean | SobValues (void)
EAsiBoolean | StoreValueFromDBType (CAsiData *, DBTYPE, void *)
EAsiBoolean | Svl (int)
EAsiBoolean | UpdateRow (ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &)
- Protected Member Functions inherited from CAsiStm
EAsiBoolean | CvlInt (int, CAsiData *) const
EAsiBoolean | InitColsDsc ()
EAsiBoolean | pInput (void)
- Protected Member Functions inherited from CAsiSQLObject
CAsiSQLObject ()
virtual EAsiBoolean | flushCond (void)
void | InheritStatusInfo (const CAsiSQLObject &)
EAsiBoolean | InitErrorInfo (HRESULT, IUnknown *, GUID)
EAsiBoolean | isInit (void) const
virtual EAsiBoolean | pushCond (void)
virtual EAsiBoolean | pushErr (EAsiError)
virtual EAsiBoolean | pushHResult (HRESULT)
void | ReleaseErrorInfo ()
virtual EAsiBoolean | setDiagPar (EAsiDiag, integer)
virtual EAsiBoolean | setDiagPar (EAsiDiag, const CAsiUcStr &)
virtual EAsiBoolean | setErr (EAsiError)
virtual EAsiBoolean | setErrMsg (const CAsiUcStr &)
virtual EAsiBoolean | setSQLSTATE (const char *)

Additional Inherited Members

- Protected Attributes inherited from CAsiCsr
CAsiIdent | m_CsrName
EAsiCurPos | m_CsrPos
DWORD | m_dwOffset
EAsiBoolean | m_fBlkStorObj
EAsiBoolean | m_fBLOBExpected
EAsiBoolean | m_fDataRead
EAsiBoolean | m_fIns
EAsiBoolean | m_fIsOpen
EAsiBoolean | m_fOwnInserts
EAsiBoolean | m_fOwnUpdates
EAsiBoolean | m_fUpd
HACCESSOR | m_hAccessor
int | m_iNumBind
DWORD | m_lCurrRow
DWORD | m_lRowCount
CAsiExecStm * | m_pCursorSpec
BYTE * | m_pData
IAccessor * | m_pIAccessor
IDataConvert * | m_pIDataConvert
IRowset * | m_pIRowset
IRowsetChange * | m_pIRowsetChange
IRowsetLocate * | m_pIRowsetLocate
IUnknown * | m_pIUnknown
CAsiTCCond * | m_pTCCond
DBBINDING * | m_rgBind
HROW * | m_rghRows
EAsiCurScr | m_ScrFlag
EAsiCurSns | m_SnsFlag
ULONG_PTR | m_ulColumns
ULONG | m_ulCurrentRowNo
ULONG | m_ulMaxRowNo
ULONG | m_ulRows

Constructor & Destructor Documentation

CAsiCsrTable::CAsiCsrTable ( void )
Warning
Not implemented!
virtual CAsiCsrTable::~CAsiCsrTable ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual EAsiBoolean CAsiCsrTable::Close ( void )
virtual
Warning
Not implemented!

Reimplemented from CAsiCsr.

virtual CAsiColumn* CAsiCsrTable::ColDsc ( int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiCsr.

virtual int CAsiCsrTable::ColQty ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiCsr.

virtual EAsiBoolean CAsiCsrTable::Cvl | ( | int | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiCsr.

virtual EAsiBoolean CAsiCsrTable::Cvl | ( | int | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiCsr.

void CAsiCsrTable::DeallocCsr ( void )
protected
Warning
Not implemented!
virtual EAsiBoolean CAsiCsrTable::Open ( void )
virtual
Warning
Not implemented!

Reimplemented from CAsiCsr.

virtual EAsiBoolean CAsiCsrTable::SetFilter ( CAsiTCCond * )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsrTable::SetOrder ( )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiCsrTable::Update ( const CAsiRow & )
virtual
Warning
Not implemented!

Reimplemented from CAsiCsr.

The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiCsrTable Member List

This is the complete list of members for CAsiCsrTable, including all inherited members.

Allocate(CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse) | CAsiCsr |
Bind(int, CAsiData *) | CAsiCsr | virtual
Bind(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Bind(const CAsiIdent &, CAsiData *) | CAsiCsr | virtual
Bind(const CAsiIdent &, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Cancel(void) | CAsiCsr |
CAsiCsr(void) | CAsiCsr |
CAsiCsrTable(void) | CAsiCsrTable |
CAsiObject(void) | CAsiObject |
CAsiSQLObject() | CAsiSQLObject | protected
CAsiStm(void) | CAsiStm |
CheckCCondition(CAsiData **) | CAsiCsr | virtual
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
Close(void) | CAsiCsrTable | virtual
ColDsc(int) const | CAsiCsrTable | virtual
ColQty(void) const | CAsiCsrTable | virtual
CondQty(void) const | CAsiSQLObject | virtual
Cvl(int, CAsiData *) | CAsiCsrTable | virtual
Cvl(int, void *, short *, int, EAsiHostType) | CAsiCsrTable | virtual
CvlInt(int, CAsiData *) const | CAsiStm | protected
DBMS(CAsiUcStr *) const | CAsiSQLObject |
DeallocCsr(void) | CAsiCsrTable | protected
Delete(void) | CAsiCsr | virtual
DoChangeErrors(HRESULT hr, ULONG, DBBINDING *) | CAsiCsr | protected
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
Fetch(void) | CAsiCsr | virtual
FetchAbsolute(long) | CAsiCsr | virtual
FetchFirst(void) | CAsiCsr | virtual
FetchLast(void) | CAsiCsr | virtual
FetchPrior(void) | CAsiCsr | virtual
FetchRelative(long) | CAsiCsr | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
GetColValue(int, CAsiData *) | CAsiCsr | protected
getCurrentRow(void) | CAsiCsr |
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiCsr | virtual
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
InitAccessor(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &, ULONG *, DBBINDING **, HACCESSOR *, EAsiBoolean) | CAsiCsr | protected
InitColsDsc() | CAsiStm | protected
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
InitOutputBind() | CAsiCsr | protected
Insert(const CAsiRow &) | CAsiCsr | virtual
Insert(void) | CAsiCsr | virtual
InsertRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
is_insensitive(void) const | CAsiCsr | virtual
is_insertable(void) const | CAsiCsr | virtual
is_open(void) const | CAsiCsr | virtual
is_scrollable(void) const | CAsiCsr | virtual
is_updatable(void) const | CAsiCsr | virtual
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiCsr | virtual
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_CsrName (defined in CAsiCsr) | CAsiCsr | protected
m_CsrPos (defined in CAsiCsr) | CAsiCsr | protected
m_dwOffset (defined in CAsiCsr) | CAsiCsr | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_fBlkStorObj (defined in CAsiCsr) | CAsiCsr | protected
m_fBLOBExpected (defined in CAsiCsr) | CAsiCsr | protected
m_fDataRead (defined in CAsiCsr) | CAsiCsr | protected
m_fIns (defined in CAsiCsr) | CAsiCsr | protected
m_fIsOpen (defined in CAsiCsr) | CAsiCsr | protected
m_fOwnInserts (defined in CAsiCsr) | CAsiCsr | protected
m_fOwnUpdates (defined in CAsiCsr) | CAsiCsr | protected
m_fUpd (defined in CAsiCsr) | CAsiCsr | protected
m_hAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_iNumBind (defined in CAsiCsr) | CAsiCsr | protected
m_lColNumber (defined in CAsiStm) | CAsiStm | protected
m_lCurrRow (defined in CAsiCsr) | CAsiCsr | protected
m_lRowCount (defined in CAsiCsr) | CAsiCsr | protected
m_pAsiRow (defined in CAsiStm) | CAsiStm | protected
m_pColumnInfo (defined in CAsiStm) | CAsiStm | protected
m_pCursorSpec (defined in CAsiCsr) | CAsiCsr | protected
m_pData (defined in CAsiCsr) | CAsiCsr | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pIAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_pIDataConvert (defined in CAsiCsr) | CAsiCsr | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pInput (defined in CAsiStm) | CAsiStm | protected
m_pIRowset (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetChange (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetLocate (defined in CAsiCsr) | CAsiCsr | protected
m_pIUnknown (defined in CAsiCsr) | CAsiCsr | protected
m_pOutput (defined in CAsiStm) | CAsiStm | protected
m_pSession (defined in CAsiStm) | CAsiStm | protected
m_pStringBuff (defined in CAsiStm) | CAsiStm | protected
m_pTCCond (defined in CAsiCsr) | CAsiCsr | protected
m_rgBind (defined in CAsiCsr) | CAsiCsr | protected
m_rghRows (defined in CAsiCsr) | CAsiCsr | protected
m_ScrFlag (defined in CAsiCsr) | CAsiCsr | protected
m_SnsFlag (defined in CAsiCsr) | CAsiCsr | protected
m_ulColumns (defined in CAsiCsr) | CAsiCsr | protected
m_ulCurrentRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulMaxRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulRows (defined in CAsiCsr) | CAsiCsr | protected
MakeCursorProp(DBPROPSET *pRowsetPropSet) | CAsiCsr | protected
Open(void) | CAsiCsrTable | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
ParamDsc(int) const | CAsiCsr | virtual
ParamQty(void) const | CAsiCsr | virtual
pInput(void) | CAsiStm | protected
position(void) const | CAsiCsr | virtual
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
QueryCursorProp(void) | CAsiCsr | protected
ReadData(void) | CAsiCsr | protected
ReleaseErrorInfo() | CAsiSQLObject | protected
RowCount(void) const | CAsiSQLObject |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
SetFilter(CAsiTCCond *) | CAsiCsrTable | virtual
SetOrder() | CAsiCsrTable | virtual
SetSession(CAsiSession *) | CAsiStm |
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
Sob(int, CAsiData *) | CAsiCsr | virtual
Sob(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
SobValues(void) | CAsiCsr | protected
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
StoreValueFromDBType(CAsiData *, DBTYPE, void *) | CAsiCsr | protected
Svl(int) | CAsiCsr | protected
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Update(const CAsiRow &) | CAsiCsrTable | virtual
UpdateRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
Version(void) const | CAsiSQLObject |
~CAsiCsr(void) | CAsiCsr | virtual
~CAsiCsrTable(void) | CAsiCsrTable | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual
~CAsiStm(void) | CAsiStm | virtual


ZRX API Reference: CAsiData Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Attributes | Friends | List of all members
CAsiData Class Reference
Misc Classes
+ Inheritance diagram for CAsiData:

Public Member Functions

CAsiData (void)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual CAsiObject * | duplicate (void) const =0
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual uint | Precision (void) const
virtual uint | ReturnLength (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const =0
virtual EAsiBoolean | SQLType (CAsiUcStr *) const =0
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual EAsiDataType | Type (void) const =0
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Static Public Member Functions

static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)

Protected Attributes

EAsiBoolean isnull

Friends

class CAsiColumn

Constructor & Destructor Documentation

CAsiData::CAsiData ( void )
Warning
Not implemented!
virtual CAsiData::~CAsiData ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual CAsiData* CAsiData::checkAdd ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt, CAsiExactNum, and CAsiNum.

virtual CAsiData* CAsiData::checkCat ( const CAsiData * ) const
virtual
Warning
Not implemented!
virtual CAsiData* CAsiData::checkDiv ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt, and CAsiNum.

virtual CAsiData* CAsiData::checkMul ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt, and CAsiNum.

virtual CAsiData* CAsiData::checkSet ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual CAsiData* CAsiData::checkSub ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt, and CAsiNum.

virtual void CAsiData::Clear ( void )
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

virtual EAsiDTType CAsiData::DateTimeType ( void ) const
virtual
Warning
Not implemented!
virtual CAsiObject* CAsiData::duplicate ( void ) const
pure virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

Implemented in CAsiSmallInt.

virtual uint CAsiData::FracSecPrec ( void ) const
virtual
Warning
Not implemented!
virtual CAsiImplDefFunc* CAsiData::getFuncDsc | ( | const CAsiIdent & | ,
 |  | const CAsiRow & |
 | ) |  | const
 virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::getValue ( real * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::getValue ( integer * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::getValue ( smallint * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::getValue | ( | char * | ,
 |  | uint |
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::getValue ( CAsiUcStr * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::getValue | ( | char * | ,
 |  | uint | ,
 |  | uint * |
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::getValue | ( | AsiUcStr | ,
 |  | uint |
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::getValue ( CAsiData & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::getValue ( DECIMAL * ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::getValue ( DB_NUMERIC * ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::getValue ( DBDATE * ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::getValue ( DBTIME * ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::getValue ( DBTIMESTAMP * ) const
virtual
Warning
Not implemented!
virtual int CAsiData::ImplDataType ( void ) const
virtual
Warning
Not implemented!
virtual EAsiIType CAsiData::IntervalType ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::is_approxnumeric ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiNum.

virtual EAsiBoolean CAsiData::is_binary ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::is_castable ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiNum.

virtual EAsiBoolean CAsiData::is_character ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::is_comparable ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiNum.

virtual EAsiBoolean CAsiData::is_datetime ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::is_dtinterval ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::is_exactnumeric ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiExactNum, and CAsiNum.

virtual EAsiBoolean CAsiData::is_implement ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::is_interval ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::is_numeric ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiNum.

virtual EAsiBoolean CAsiData::is_storable ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiNum.

virtual EAsiBoolean CAsiData::is_yminterval ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::isEqualTo ( const CAsiData & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::isGreaterThan ( const CAsiData & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::isNull ( void ) const
virtual
Warning
Not implemented!
virtual uint CAsiData::LeadFieldPrec ( void ) const
virtual
Warning
Not implemented!
virtual uint CAsiData::Length ( void ) const
virtual
Warning
Not implemented!
virtual DBCOLUMNINFO* CAsiData::MapAsiToColumnInfo ( DBCOLUMNINFO * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual DBPARAMINFO* CAsiData::MapAsiToParamInfo ( DBPARAMINFO * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

static CAsiData* CAsiData::MapColumnInfoToAsi ( DBCOLUMNINFO * pColumnInfo )
static
Warning
Not implemented!
static CAsiData* CAsiData::MapParamInfoToAsi ( DBPARAMINFO * pParamInfo )
static
Warning
Not implemented!
virtual uint CAsiData::Precision ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiNum.

virtual uint CAsiData::ReturnLength ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual uint CAsiData::Scale ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiNum.

virtual void CAsiData::setNull ( void )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::SQLLiteral ( CAsiUcStr * ) const
pure virtual
Warning
Not implemented!

Implemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::SQLType ( CAsiUcStr * ) const
pure virtual
Warning
Not implemented!

Implemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::storeValue ( real )
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::storeValue ( integer )
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::storeValue ( smallint )
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::storeValue | ( | char * | ,
 |  | uint |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::storeValue ( const CAsiUcStr & )
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::storeValue | ( | char * | ,
 |  | uint | ,
 |  | uint * |
 | ) |  |
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::storeValue ( const CAsiData & )
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::storeValue ( const AsiUcStr )
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiData::storeValue ( const DECIMAL & )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::storeValue ( const DB_NUMERIC * )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::storeValue ( const DBDATE * )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::storeValue ( const DBTIME * )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiData::storeValue ( const DBTIMESTAMP * )
virtual
Warning
Not implemented!
virtual uint CAsiData::TimePrec ( void ) const
virtual
Warning
Not implemented!
virtual uint CAsiData::TimeStampPrec ( void ) const
virtual
Warning
Not implemented!
virtual EAsiDataType CAsiData::Type ( void ) const
pure virtual
Warning
Not implemented!

Implemented in CAsiSmallInt.

The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiData Member List

This is the complete list of members for CAsiData, including all inherited members.

CAsiColumn (defined in CAsiData) | CAsiData | friend
CAsiData(void) | CAsiData |
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const | CAsiData | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiData | virtual
checkMul(const CAsiData *) const | CAsiData | virtual
checkSet(const CAsiData *) const | CAsiData | virtual
checkSub(const CAsiData *) const | CAsiData | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const =0 | CAsiData | pure virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const | CAsiData | virtual
getValue(integer *) const | CAsiData | virtual
getValue(smallint *) const | CAsiData | virtual
getValue(char *, uint) const | CAsiData | virtual
getValue(CAsiUcStr *) const | CAsiData | virtual
getValue(char *, uint, uint *) const | CAsiData | virtual
getValue(AsiUcStr, uint) const | CAsiData | virtual
getValue(CAsiData &) const | CAsiData | virtual
getValue(DECIMAL *) const | CAsiData | virtual
getValue(DB_NUMERIC *) const | CAsiData | virtual
getValue(DBDATE *) const | CAsiData | virtual
getValue(DBTIME *) const | CAsiData | virtual
getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiData | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiData | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const | CAsiData | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const | CAsiData | virtual
isGreaterThan(const CAsiData &) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const | CAsiData | virtual
MapAsiToParamInfo(DBPARAMINFO *) const | CAsiData | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const | CAsiData | virtual
Scale(void) const | CAsiData | virtual
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const =0 | CAsiData | pure virtual
SQLType(CAsiUcStr *) const =0 | CAsiData | pure virtual
storeValue(real) | CAsiData | virtual
storeValue(integer) | CAsiData | virtual
storeValue(smallint) | CAsiData | virtual
storeValue(char *, uint) | CAsiData | virtual
storeValue(const CAsiUcStr &) | CAsiData | virtual
storeValue(char *, uint, uint *) | CAsiData | virtual
storeValue(const CAsiData &) | CAsiData | virtual
storeValue(const AsiUcStr) | CAsiData | virtual
storeValue(const DECIMAL &) | CAsiData | virtual
storeValue(const DB_NUMERIC *) | CAsiData | virtual
storeValue(const DBDATE *) | CAsiData | virtual
storeValue(const DBTIME *) | CAsiData | virtual
storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const =0 | CAsiData | pure virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiDate Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAsiDate Class Reference
Misc Classes
+ Inheritance diagram for CAsiDate:

Public Member Functions

CAsiDate (const CAsiDate &)
virtual EAsiDTType | DateTimeType (void) const
virtual ushort | Day (void) const
CAsiDT | DTDiff (const CAsiDate &, const CAsiDT &) const
virtual CAsiObject * | duplicate (void) const
EAsiBoolean | get (ASI_DTDATE *) const
EAsiBoolean | get (DBDATE *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DATE *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual ushort | Hour (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual ushort | Minute (void) const
virtual ushort | Month (void) const
int | operator!= (const CAsiDate &) const
CAsiDate | operator+ (const CAsiYM &) const
CAsiDate | operator+ (const CAsiDT &) const
CAsiDate | operator- (const CAsiYM &) const
CAsiDate | operator- (const CAsiDT &) const
int | operator< (const CAsiDate &) const
int | operator<= (const CAsiDate &) const
CAsiDate & | operator= (const CAsiDate &)
int | operator== (const CAsiDate &) const
int | operator> (const CAsiDate &) const
int | operator>= (const CAsiDate &) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual uint | ReturnLength (void) const
virtual double | Second (void) const
EAsiBoolean | set (ASI_DTDATE *)
EAsiBoolean | set (const DBDATE *)
EAsiBoolean | set (ushort, ushort, ushort)
EAsiBoolean | setDay (ushort)
EAsiBoolean | setMonth (ushort)
EAsiBoolean | setYear (ushort)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (DATE)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual ushort | Year (void) const
CAsiYM | YMDiff (const CAsiDate &, const CAsiYM &) const
- Public Member Functions inherited from CAsiDatetime
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiDataType | Type (void) const
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual void | Clear (void)
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Protected Attributes

ushort | day
ulong | month

Friends

class | CAsiTempTable
class | CAsiTimeStamp
CAsiDate DLLScope | operator+ (const CAsiYM &, const CAsiDate &)
CAsiDate DLLScope | operator+ (const CAsiDT &, const CAsiDate &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiDate Member List

This is the complete list of members for CAsiDate, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDate() (defined in CAsiDate) | CAsiDate |
CAsiDate(const CAsiDate &) (defined in CAsiDate) | CAsiDate |
CAsiDatetime() (defined in CAsiDatetime) | CAsiDatetime |
CAsiObject(void) | CAsiObject |
CAsiTempTable (defined in CAsiDate) | CAsiDate | friend
CAsiTimeStamp (defined in CAsiDate) | CAsiDate | friend
checkAdd(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiData | virtual
checkMul(const CAsiData *) const | CAsiData | virtual
checkSet(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
checkSub(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const (defined in CAsiDate) | CAsiDate | virtual
day (defined in CAsiDate) | CAsiDate | protected
Day(void) const (defined in CAsiDate) | CAsiDate | virtual
DTDiff(const CAsiDate &, const CAsiDT &) const (defined in CAsiDate) | CAsiDate |
duplicate(void) const (defined in CAsiDate) | CAsiDate | virtual
FracSecPrec(void) const | CAsiData | virtual
get(ASI_DTDATE *) const (defined in CAsiDate) | CAsiDate |
get(DBDATE *) const (defined in CAsiDate) | CAsiDate |
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(char *, uint) const (defined in CAsiDate) | CAsiDate | virtual
getValue(CAsiUcStr *) const (defined in CAsiDate) | CAsiDate | virtual
getValue(DBDATE *) const (defined in CAsiDate) | CAsiDate | virtual
getValue(DATE *) const (defined in CAsiDate) | CAsiDate | virtual
getValue(integer *) const (defined in CAsiDate) | CAsiDate | virtual
getValue(smallint *) const (defined in CAsiDate) | CAsiDate | virtual
getValue(char *, uint, uint *) const (defined in CAsiDate) | CAsiDate | virtual
getValue(AsiUcStr, uint) const (defined in CAsiDate) | CAsiDate | virtual
getValue(CAsiData &) const (defined in CAsiDate) | CAsiDate | virtual
CAsiDatetime::getValue(real *) const | CAsiData | virtual
CAsiDatetime::getValue(DECIMAL *) const | CAsiData | virtual
CAsiDatetime::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiDatetime::getValue(DBTIME *) const | CAsiData | virtual
CAsiDatetime::getValue(DBTIMESTAMP *) const | CAsiData | virtual
Hour(void) const (defined in CAsiDate) | CAsiDate | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const (defined in CAsiDate) | CAsiDate | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
is_datetime(void) const (defined in CAsiDatetime) | CAsiDatetime | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const (defined in CAsiDate) | CAsiDate | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiDate) | CAsiDate | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiDate) | CAsiDate | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiDate) | CAsiDate | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiDate) | CAsiDate | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
Minute(void) const (defined in CAsiDate) | CAsiDate | virtual
Month(void) const (defined in CAsiDate) | CAsiDate | virtual
month (defined in CAsiDate) | CAsiDate | protected
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiDate &) const (defined in CAsiDate) | CAsiDate |
operator+(const CAsiYM &) const (defined in CAsiDate) | CAsiDate |
operator+(const CAsiDT &) const (defined in CAsiDate) | CAsiDate |
operator+ (defined in CAsiDate) | CAsiDate | friend
operator+ (defined in CAsiDate) | CAsiDate | friend
operator-(const CAsiYM &) const (defined in CAsiDate) | CAsiDate |
operator-(const CAsiDT &) const (defined in CAsiDate) | CAsiDate |
operator<(const CAsiDate &) const (defined in CAsiDate) | CAsiDate |
operator<=(const CAsiDate &) const (defined in CAsiDate) | CAsiDate |
operator=(const CAsiDate &) (defined in CAsiDate) | CAsiDate |
operator==(const CAsiDate &) const (defined in CAsiDate) | CAsiDate |
operator>(const CAsiDate &) const (defined in CAsiDate) | CAsiDate |
operator>=(const CAsiDate &) const (defined in CAsiDate) | CAsiDate |
packSize(void) const (defined in CAsiDate) | CAsiDate | virtual
packTo(CAsiObjPack *) const (defined in CAsiDate) | CAsiDate | virtual
packValueSize(void) const (defined in CAsiDate) | CAsiDate | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiDate) | CAsiDate | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const (defined in CAsiDate) | CAsiDate | virtual
Scale(void) const | CAsiData | virtual
Second(void) const (defined in CAsiDate) | CAsiDate | virtual
set(ASI_DTDATE *) (defined in CAsiDate) | CAsiDate |
set(const DBDATE *) (defined in CAsiDate) | CAsiDate |
set(ushort, ushort, ushort) (defined in CAsiDate) | CAsiDate |
setDay(ushort) (defined in CAsiDate) | CAsiDate |
setMonth(ushort) (defined in CAsiDate) | CAsiDate |
setNull(void) | CAsiData | virtual
setYear(ushort) (defined in CAsiDate) | CAsiDate |
SQLLiteral(CAsiUcStr *) const (defined in CAsiDate) | CAsiDate | virtual
SQLType(CAsiUcStr *) const (defined in CAsiDate) | CAsiDate | virtual
storeValue(char *, uint) (defined in CAsiDate) | CAsiDate | virtual
storeValue(const CAsiUcStr &) (defined in CAsiDate) | CAsiDate | virtual
storeValue(const CAsiData &) (defined in CAsiDate) | CAsiDate | virtual
storeValue(const DBDATE *) (defined in CAsiDate) | CAsiDate | virtual
storeValue(DATE) (defined in CAsiDate) | CAsiDate | virtual
storeValue(integer) (defined in CAsiDate) | CAsiDate | virtual
storeValue(smallint) (defined in CAsiDate) | CAsiDate | virtual
storeValue(char *, uint, uint *) (defined in CAsiDate) | CAsiDate | virtual
storeValue(const AsiUcStr) (defined in CAsiDate) | CAsiDate | virtual
CAsiDatetime::storeValue(real) | CAsiData | virtual
CAsiDatetime::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiDatetime::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiDatetime::storeValue(const DBTIME *) | CAsiData | virtual
CAsiDatetime::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiDatetime) | CAsiDatetime | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiDate) | CAsiDate | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiDate) | CAsiDate | virtual
Year(void) const (defined in CAsiDate) | CAsiDate | virtual
YMDiff(const CAsiDate &, const CAsiYM &) const (defined in CAsiDate) | CAsiDate |
~CAsiData(void) | CAsiData | virtual
~CAsiDate(void) (defined in CAsiDate) | CAsiDate | virtual
~CAsiDatetime() (defined in CAsiDatetime) | CAsiDatetime | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiDatetime Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAsiDatetime Class Reference
Misc Classes
+ Inheritance diagram for CAsiDatetime:

Public Member Functions

virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual ushort | Day (void) const =0
virtual ushort | Hour (void) const =0
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_datetime (void) const
virtual ushort | Minute (void) const =0
virtual ushort | Month (void) const =0
virtual double | Second (void) const =0
virtual EAsiDataType | Type (void) const
virtual ushort | Year (void) const =0
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual CAsiObject * | duplicate (void) const =0
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual uint | Precision (void) const
virtual uint | ReturnLength (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const =0
virtual EAsiBoolean | SQLType (CAsiUcStr *) const =0
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiDatetime Member List

This is the complete list of members for CAsiDatetime, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDatetime() (defined in CAsiDatetime) | CAsiDatetime |
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiData | virtual
checkMul(const CAsiData *) const | CAsiData | virtual
checkSet(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
checkSub(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
Day(void) const =0 (defined in CAsiDatetime) | CAsiDatetime | pure virtual
duplicate(void) const =0 | CAsiData | pure virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const | CAsiData | virtual
getValue(integer *) const | CAsiData | virtual
getValue(smallint *) const | CAsiData | virtual
getValue(char *, uint) const | CAsiData | virtual
getValue(CAsiUcStr *) const | CAsiData | virtual
getValue(char *, uint, uint *) const | CAsiData | virtual
getValue(AsiUcStr, uint) const | CAsiData | virtual
getValue(CAsiData &) const | CAsiData | virtual
getValue(DECIMAL *) const | CAsiData | virtual
getValue(DB_NUMERIC *) const | CAsiData | virtual
getValue(DBDATE *) const | CAsiData | virtual
getValue(DBTIME *) const | CAsiData | virtual
getValue(DBTIMESTAMP *) const | CAsiData | virtual
Hour(void) const =0 (defined in CAsiDatetime) | CAsiDatetime | pure virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiData | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
is_datetime(void) const (defined in CAsiDatetime) | CAsiDatetime | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const | CAsiData | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const | CAsiData | virtual
isGreaterThan(const CAsiData &) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const | CAsiData | virtual
MapAsiToParamInfo(DBPARAMINFO *) const | CAsiData | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
Minute(void) const =0 (defined in CAsiDatetime) | CAsiDatetime | pure virtual
Month(void) const =0 (defined in CAsiDatetime) | CAsiDatetime | pure virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const | CAsiData | virtual
Scale(void) const | CAsiData | virtual
Second(void) const =0 (defined in CAsiDatetime) | CAsiDatetime | pure virtual
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const =0 | CAsiData | pure virtual
SQLType(CAsiUcStr *) const =0 | CAsiData | pure virtual
storeValue(real) | CAsiData | virtual
storeValue(integer) | CAsiData | virtual
storeValue(smallint) | CAsiData | virtual
storeValue(char *, uint) | CAsiData | virtual
storeValue(const CAsiUcStr &) | CAsiData | virtual
storeValue(char *, uint, uint *) | CAsiData | virtual
storeValue(const CAsiData &) | CAsiData | virtual
storeValue(const AsiUcStr) | CAsiData | virtual
storeValue(const DECIMAL &) | CAsiData | virtual
storeValue(const DB_NUMERIC *) | CAsiData | virtual
storeValue(const DBDATE *) | CAsiData | virtual
storeValue(const DBTIME *) | CAsiData | virtual
storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiDatetime) | CAsiDatetime | virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Year(void) const =0 (defined in CAsiDatetime) | CAsiDatetime | pure virtual
~CAsiData(void) | CAsiData | virtual
~CAsiDatetime() (defined in CAsiDatetime) | CAsiDatetime | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiDecimal Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiDecimal Class Reference
Misc Classes
+ Inheritance diagram for CAsiDecimal:

Public Member Functions

CAsiDecimal (uint, uint)
CAsiDecimal (uint)
CAsiDecimal (const CAsiDecimal &)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual CAsiObject * | duplicate (void) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (LARGE_INTEGER *) const
virtual EAsiBoolean | getValue (ULARGE_INTEGER *) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual integer | intValue (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
CAsiDouble | operator* (const CAsiSmallInt &) const
CAsiDouble | operator* (const CAsiInt &) const
CAsiDouble | operator* (const CAsiNumeric &) const
CAsiDouble | operator* (const CAsiDecimal &) const
CAsiDouble | operator* (const smallint) const
CAsiDouble | operator* (const integer) const
CAsiDouble | operator* (const real) const
CAsiDouble | operator* (const int) const
CAsiDecimal & | operator*= (const CAsiSmallInt &)
CAsiDecimal & | operator*= (const CAsiInt &)
CAsiDecimal & | operator*= (const CAsiNumeric &)
CAsiDecimal & | operator*= (const CAsiDecimal &)
CAsiDecimal & | operator*= (const CAsiFloat &)
CAsiDecimal & | operator*= (const CAsiReal &)
CAsiDecimal & | operator*= (const CAsiDouble &)
CAsiDecimal & | operator*= (const smallint)
CAsiDecimal & | operator*= (const integer)
CAsiDecimal & | operator*= (const real)
CAsiDecimal & | operator*= (const int)
CAsiDouble | operator+ (const CAsiSmallInt &) const
CAsiDouble | operator+ (const CAsiInt &) const
CAsiDouble | operator+ (const CAsiNumeric &) const
CAsiDouble | operator+ (const CAsiDecimal &) const
CAsiDouble | operator+ (const smallint) const
CAsiDouble | operator+ (const integer) const
CAsiDouble | operator+ (const real) const
CAsiDouble | operator+ (const int) const
CAsiDecimal & | operator++ (void)
CAsiDecimal & | operator+= (const CAsiSmallInt &)
CAsiDecimal & | operator+= (const CAsiInt &)
CAsiDecimal & | operator+= (const CAsiNumeric &)
CAsiDecimal & | operator+= (const CAsiDecimal &)
CAsiDecimal & | operator+= (const CAsiFloat &)
CAsiDecimal & | operator+= (const CAsiReal &)
CAsiDecimal & | operator+= (const CAsiDouble &)
CAsiDecimal & | operator+= (const smallint)
CAsiDecimal & | operator+= (const integer)
CAsiDecimal & | operator+= (const real)
CAsiDecimal & | operator+= (const int)
CAsiDouble | operator- (const CAsiSmallInt &) const
CAsiDouble | operator- (const CAsiInt &) const
CAsiDouble | operator- (const CAsiNumeric &) const
CAsiDouble | operator- (const CAsiDecimal &) const
CAsiDouble | operator- (const smallint) const
CAsiDouble | operator- (const integer) const
CAsiDouble | operator- (const real) const
CAsiDouble | operator- (const int) const
CAsiDecimal & | operator- (void)
CAsiDecimal & | operator-- (void)
CAsiDecimal & | operator-= (const CAsiSmallInt &)
CAsiDecimal & | operator-= (const CAsiInt &)
CAsiDecimal & | operator-= (const CAsiNumeric &)
CAsiDecimal & | operator-= (const CAsiDecimal &)
CAsiDecimal & | operator-= (const CAsiFloat &)
CAsiDecimal & | operator-= (const CAsiReal &)
CAsiDecimal & | operator-= (const CAsiDouble &)
CAsiDecimal & | operator-= (const smallint)
CAsiDecimal & | operator-= (const integer)
CAsiDecimal & | operator-= (const real)
CAsiDecimal & | operator-= (const int)
CAsiDouble | operator/ (const CAsiSmallInt &) const
CAsiDouble | operator/ (const CAsiInt &) const
CAsiDouble | operator/ (const CAsiNumeric &) const
CAsiDouble | operator/ (const CAsiDecimal &) const
CAsiDouble | operator/ (const smallint) const
CAsiDouble | operator/ (const integer) const
CAsiDouble | operator/ (const real) const
CAsiDouble | operator/ (const int) const
CAsiDecimal & | operator/= (const CAsiSmallInt &)
CAsiDecimal & | operator/= (const CAsiInt &)
CAsiDecimal & | operator/= (const CAsiNumeric &)
CAsiDecimal & | operator/= (const CAsiDecimal &)
CAsiDecimal & | operator/= (const CAsiFloat &)
CAsiDecimal & | operator/= (const CAsiReal &)
CAsiDecimal & | operator/= (const CAsiDouble &)
CAsiDecimal & | operator/= (const smallint)
CAsiDecimal & | operator/= (const integer)
CAsiDecimal & | operator/= (const real)
CAsiDecimal & | operator/= (const int)
CAsiDecimal & | operator= (const CAsiSmallInt &)
CAsiDecimal & | operator= (const CAsiInt &)
CAsiDecimal & | operator= (const CAsiNumeric &)
CAsiDecimal & | operator= (const CAsiDecimal &)
CAsiDecimal & | operator= (const CAsiFloat &)
CAsiDecimal & | operator= (const CAsiReal &)
CAsiDecimal & | operator= (const CAsiDouble &)
CAsiDecimal & | operator= (const smallint)
CAsiDecimal & | operator= (const integer)
CAsiDecimal & | operator= (const real)
CAsiDecimal & | operator= (const int)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual real | realValue (void) const
virtual uint | ReturnLength (void) const
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (LARGE_INTEGER)
virtual EAsiBoolean | storeValue (ULARGE_INTEGER)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiDataType | Type (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiExactNum
virtual EAsiBoolean | is_exactnumeric (void) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual | ~CAsiExactNum ()
- Public Member Functions inherited from CAsiNum
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

class | CAsiNumeric
CAsiDouble DLLScope | operator* (const CAsiSmallInt &, const CAsiDecimal &)
CAsiDouble DLLScope | operator* (const CAsiInt &, const CAsiDecimal &)
CAsiDouble DLLScope | operator* (const CAsiNumeric &, const CAsiDecimal &)
CAsiDouble DLLScope | operator* (const smallint, const CAsiDecimal &)
CAsiDouble DLLScope | operator* (const integer, const CAsiDecimal &)
CAsiDouble DLLScope | operator* (const real, const CAsiDecimal &)
CAsiDouble DLLScope | operator* (const int, const CAsiDecimal &)
CAsiDouble DLLScope | operator+ (const CAsiSmallInt &, const CAsiDecimal &)
CAsiDouble DLLScope | operator+ (const CAsiInt &, const CAsiDecimal &)
CAsiDouble DLLScope | operator+ (const CAsiNumeric &, const CAsiDecimal &)
CAsiDouble DLLScope | operator+ (const smallint, const CAsiDecimal &)
CAsiDouble DLLScope | operator+ (const integer, const CAsiDecimal &)
CAsiDouble DLLScope | operator+ (const real, const CAsiDecimal &)
CAsiDouble | operator+ (const int, const CAsiDecimal &)
CAsiDouble DLLScope | operator- (const CAsiSmallInt &, const CAsiDecimal &)
CAsiDouble DLLScope | operator- (const CAsiInt &, const CAsiDecimal &)
CAsiDouble DLLScope | operator- (const CAsiNumeric &, const CAsiDecimal &)
CAsiDouble DLLScope | operator- (const smallint, const CAsiDecimal &)
CAsiDouble DLLScope | operator- (const integer, const CAsiDecimal &)
CAsiDouble DLLScope | operator- (const real, const CAsiDecimal &)
CAsiDouble DLLScope | operator- (const int, const CAsiDecimal &)
CAsiDouble DLLScope | operator/ (const CAsiSmallInt &, const CAsiDecimal &)
CAsiDouble DLLScope | operator/ (const CAsiInt &, const CAsiDecimal &)
CAsiDouble DLLScope | operator/ (const CAsiNumeric &, const CAsiDecimal &)
CAsiDouble DLLScope | operator/ (const smallint, const CAsiDecimal &)
CAsiDouble DLLScope | operator/ (const integer, const CAsiDecimal &)
CAsiDouble DLLScope | operator/ (const real, const CAsiDecimal &)
CAsiDouble DLLScope | operator/ (const int, const CAsiDecimal &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Member Functions inherited from CAsiExactNum
CAsiExactNum ()
int | cmpeqlan (const CAsiNum *) const
int | cmpeqlen (const CAsiExactNum *) const
int | cmpeqlenC (const real) const
int | cmpgtean (const CAsiNum *) const
int | cmpgteen (const CAsiExactNum *) const
int | cmpgteenC (const real) const
int | cmpgtran (const CAsiNum *) const
int | cmpgtren (const CAsiExactNum *) const
int | cmpgtrenC (const real) const
int | cmpltean (const CAsiNum *) const
int | cmplteen (const CAsiExactNum *) const
int | cmplteenC (const real) const
int | cmpltran (const CAsiNum *) const
int | cmpltren (const CAsiExactNum *) const
int | cmpltrenC (const real) const
int | cmpneqan (const CAsiNum *) const
int | cmpneqen (const CAsiExactNum *) const
int | cmpneqenC (const real) const
- Protected Attributes inherited from CAsiNum
uint | precision
uint | scale
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiDecimal Member List

This is the complete list of members for CAsiDecimal, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDecimal(uint, uint) (defined in CAsiDecimal) | CAsiDecimal |
CAsiDecimal(uint) (defined in CAsiDecimal) | CAsiDecimal |
CAsiDecimal(const CAsiDecimal &) (defined in CAsiDecimal) | CAsiDecimal |
CAsiDecimal(void) (defined in CAsiDecimal) | CAsiDecimal |
CAsiExactNum() | CAsiExactNum | protected
CAsiNum() | CAsiNum | protected
CAsiNumeric (defined in CAsiDecimal) | CAsiDecimal | friend
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
checkMul(const CAsiData *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
checkSet(const CAsiData *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
checkSub(const CAsiData *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
Clear(void) | CAsiData | virtual
cmpeqlan(const CAsiNum *) const | CAsiExactNum | protected
cmpeqlen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpeqlenC(const real) const | CAsiExactNum | protected
cmpgtean(const CAsiNum *) const | CAsiExactNum | protected
cmpgteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgteenC(const real) const | CAsiExactNum | protected
cmpgtran(const CAsiNum *) const | CAsiExactNum | protected
cmpgtren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgtrenC(const real) const | CAsiExactNum | protected
cmpltean(const CAsiNum *) const | CAsiExactNum | protected
cmplteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmplteenC(const real) const | CAsiExactNum | protected
cmpltran(const CAsiNum *) const | CAsiExactNum | protected
cmpltren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpltrenC(const real) const | CAsiExactNum | protected
cmpneqan(const CAsiNum *) const | CAsiExactNum | protected
cmpneqen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpneqenC(const real) const | CAsiExactNum | protected
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiDecimal) | CAsiDecimal | virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(integer *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(smallint *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(char *, uint) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(CAsiUcStr *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(LARGE_INTEGER *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(ULARGE_INTEGER *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(DECIMAL *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(char *, uint, uint *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(AsiUcStr, uint) const (defined in CAsiDecimal) | CAsiDecimal | virtual
getValue(CAsiData &) const (defined in CAsiDecimal) | CAsiDecimal | virtual
CAsiExactNum::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiExactNum::getValue(DBDATE *) const | CAsiData | virtual
CAsiExactNum::getValue(DBTIME *) const | CAsiData | virtual
CAsiExactNum::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const (defined in CAsiDecimal) | CAsiDecimal | virtual
is_approxnumeric(void) const | CAsiNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiExactNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiDecimal) | CAsiDecimal | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiDecimal) | CAsiDecimal | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator!=(const CAsiInt &) const | CAsiExactNum | virtual
operator!=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator!=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator!=(const CAsiFloat &) const | CAsiExactNum | virtual
operator!=(const CAsiReal &) const | CAsiExactNum | virtual
operator!=(const CAsiDouble &) const | CAsiExactNum | virtual
operator!=(const smallint) const | CAsiExactNum | virtual
operator!=(const integer) const | CAsiExactNum | virtual
operator!=(const real) const | CAsiExactNum | virtual
operator!=(const int) const | CAsiExactNum | virtual
operator*(const CAsiSmallInt &) const (defined in CAsiDecimal) | CAsiDecimal |
operator*(const CAsiInt &) const (defined in CAsiDecimal) | CAsiDecimal |
operator*(const CAsiNumeric &) const (defined in CAsiDecimal) | CAsiDecimal |
operator*(const CAsiDecimal &) const (defined in CAsiDecimal) | CAsiDecimal |
operator* (defined in CAsiDecimal) | CAsiDecimal | friend
operator* (defined in CAsiDecimal) | CAsiDecimal | friend
operator* (defined in CAsiDecimal) | CAsiDecimal | friend
operator*(const smallint) const (defined in CAsiDecimal) | CAsiDecimal |
operator*(const integer) const (defined in CAsiDecimal) | CAsiDecimal |
operator*(const real) const (defined in CAsiDecimal) | CAsiDecimal |
operator* (defined in CAsiDecimal) | CAsiDecimal | friend
operator* (defined in CAsiDecimal) | CAsiDecimal | friend
operator* (defined in CAsiDecimal) | CAsiDecimal | friend
operator*(const int) const (defined in CAsiDecimal) | CAsiDecimal |
operator* (defined in CAsiDecimal) | CAsiDecimal | friend
operator*=(const CAsiSmallInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const CAsiInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const CAsiNumeric &) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const CAsiDecimal &) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const CAsiFloat &) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const CAsiReal &) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const CAsiDouble &) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const smallint) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const integer) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const real) (defined in CAsiDecimal) | CAsiDecimal |
operator*=(const int) (defined in CAsiDecimal) | CAsiDecimal |
operator+(const CAsiSmallInt &) const (defined in CAsiDecimal) | CAsiDecimal |
operator+(const CAsiInt &) const (defined in CAsiDecimal) | CAsiDecimal |
operator+(const CAsiNumeric &) const (defined in CAsiDecimal) | CAsiDecimal |
operator+(const CAsiDecimal &) const (defined in CAsiDecimal) | CAsiDecimal |
operator+ (defined in CAsiDecimal) | CAsiDecimal | friend
operator+ (defined in CAsiDecimal) | CAsiDecimal | friend
operator+ (defined in CAsiDecimal) | CAsiDecimal | friend
operator+(const smallint) const (defined in CAsiDecimal) | CAsiDecimal |
operator+(const integer) const (defined in CAsiDecimal) | CAsiDecimal |
operator+(const real) const (defined in CAsiDecimal) | CAsiDecimal |
operator+ (defined in CAsiDecimal) | CAsiDecimal | friend
operator+ (defined in CAsiDecimal) | CAsiDecimal | friend
operator+ (defined in CAsiDecimal) | CAsiDecimal | friend
operator+(const int) const (defined in CAsiDecimal) | CAsiDecimal |
operator+ (defined in CAsiDecimal) | CAsiDecimal | friend
operator++(void) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const CAsiSmallInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const CAsiInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const CAsiNumeric &) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const CAsiDecimal &) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const CAsiFloat &) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const CAsiReal &) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const CAsiDouble &) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const smallint) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const integer) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const real) (defined in CAsiDecimal) | CAsiDecimal |
operator+=(const int) (defined in CAsiDecimal) | CAsiDecimal |
operator-(const CAsiSmallInt &) const (defined in CAsiDecimal) | CAsiDecimal |
operator-(const CAsiInt &) const (defined in CAsiDecimal) | CAsiDecimal |
operator-(const CAsiNumeric &) const (defined in CAsiDecimal) | CAsiDecimal |
operator-(const CAsiDecimal &) const (defined in CAsiDecimal) | CAsiDecimal |
operator- (defined in CAsiDecimal) | CAsiDecimal | friend
operator- (defined in CAsiDecimal) | CAsiDecimal | friend
operator- (defined in CAsiDecimal) | CAsiDecimal | friend
operator-(const smallint) const (defined in CAsiDecimal) | CAsiDecimal |
operator-(const integer) const (defined in CAsiDecimal) | CAsiDecimal |
operator-(const real) const (defined in CAsiDecimal) | CAsiDecimal |
operator- (defined in CAsiDecimal) | CAsiDecimal | friend
operator- (defined in CAsiDecimal) | CAsiDecimal | friend
operator- (defined in CAsiDecimal) | CAsiDecimal | friend
operator-(const int) const (defined in CAsiDecimal) | CAsiDecimal |
operator- (defined in CAsiDecimal) | CAsiDecimal | friend
operator-(void) (defined in CAsiDecimal) | CAsiDecimal |
operator--(void) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const CAsiSmallInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const CAsiInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const CAsiNumeric &) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const CAsiDecimal &) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const CAsiFloat &) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const CAsiReal &) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const CAsiDouble &) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const smallint) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const integer) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const real) (defined in CAsiDecimal) | CAsiDecimal |
operator-=(const int) (defined in CAsiDecimal) | CAsiDecimal |
operator/(const CAsiSmallInt &) const (defined in CAsiDecimal) | CAsiDecimal |
operator/(const CAsiInt &) const (defined in CAsiDecimal) | CAsiDecimal |
operator/(const CAsiNumeric &) const (defined in CAsiDecimal) | CAsiDecimal |
operator/(const CAsiDecimal &) const (defined in CAsiDecimal) | CAsiDecimal |
operator/ (defined in CAsiDecimal) | CAsiDecimal | friend
operator/ (defined in CAsiDecimal) | CAsiDecimal | friend
operator/ (defined in CAsiDecimal) | CAsiDecimal | friend
operator/(const smallint) const (defined in CAsiDecimal) | CAsiDecimal |
operator/(const integer) const (defined in CAsiDecimal) | CAsiDecimal |
operator/(const real) const (defined in CAsiDecimal) | CAsiDecimal |
operator/ (defined in CAsiDecimal) | CAsiDecimal | friend
operator/ (defined in CAsiDecimal) | CAsiDecimal | friend
operator/ (defined in CAsiDecimal) | CAsiDecimal | friend
operator/(const int) const (defined in CAsiDecimal) | CAsiDecimal |
operator/ (defined in CAsiDecimal) | CAsiDecimal | friend
operator/=(const CAsiSmallInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const CAsiInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const CAsiNumeric &) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const CAsiDecimal &) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const CAsiFloat &) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const CAsiReal &) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const CAsiDouble &) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const smallint) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const integer) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const real) (defined in CAsiDecimal) | CAsiDecimal |
operator/=(const int) (defined in CAsiDecimal) | CAsiDecimal |
operator<(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<(const CAsiInt &) const | CAsiExactNum | virtual
operator<(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<(const CAsiFloat &) const | CAsiExactNum | virtual
operator<(const CAsiReal &) const | CAsiExactNum | virtual
operator<(const CAsiDouble &) const | CAsiExactNum | virtual
operator<(const smallint) const | CAsiExactNum | virtual
operator<(const integer) const | CAsiExactNum | virtual
operator<(const real) const | CAsiExactNum | virtual
operator<(const int) const | CAsiExactNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<=(const CAsiInt &) const | CAsiExactNum | virtual
operator<=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<=(const CAsiFloat &) const | CAsiExactNum | virtual
operator<=(const CAsiReal &) const | CAsiExactNum | virtual
operator<=(const CAsiDouble &) const | CAsiExactNum | virtual
operator<=(const smallint) const | CAsiExactNum | virtual
operator<=(const integer) const | CAsiExactNum | virtual
operator<=(const real) const | CAsiExactNum | virtual
operator<=(const int) const | CAsiExactNum | virtual
operator=(const CAsiSmallInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const CAsiInt &) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const CAsiNumeric &) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const CAsiDecimal &) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const CAsiFloat &) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const CAsiReal &) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const CAsiDouble &) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const smallint) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const integer) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const real) (defined in CAsiDecimal) | CAsiDecimal |
operator=(const int) (defined in CAsiDecimal) | CAsiDecimal |
operator==(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator==(const CAsiInt &) const | CAsiExactNum | virtual
operator==(const CAsiNumeric &) const | CAsiExactNum | virtual
operator==(const CAsiDecimal &) const | CAsiExactNum | virtual
operator==(const CAsiFloat &) const | CAsiExactNum | virtual
operator==(const CAsiReal &) const | CAsiExactNum | virtual
operator==(const CAsiDouble &) const | CAsiExactNum | virtual
operator==(const smallint) const | CAsiExactNum | virtual
operator==(const integer) const | CAsiExactNum | virtual
operator==(const real) const | CAsiExactNum | virtual
operator==(const int) const | CAsiExactNum | virtual
operator>(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>(const CAsiInt &) const | CAsiExactNum | virtual
operator>(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>(const CAsiFloat &) const | CAsiExactNum | virtual
operator>(const CAsiReal &) const | CAsiExactNum | virtual
operator>(const CAsiDouble &) const | CAsiExactNum | virtual
operator>(const smallint) const | CAsiExactNum | virtual
operator>(const integer) const | CAsiExactNum | virtual
operator>(const real) const | CAsiExactNum | virtual
operator>(const int) const | CAsiExactNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>=(const CAsiInt &) const | CAsiExactNum | virtual
operator>=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>=(const CAsiFloat &) const | CAsiExactNum | virtual
operator>=(const CAsiReal &) const | CAsiExactNum | virtual
operator>=(const CAsiDouble &) const | CAsiExactNum | virtual
operator>=(const smallint) const | CAsiExactNum | virtual
operator>=(const integer) const | CAsiExactNum | virtual
operator>=(const real) const | CAsiExactNum | virtual
operator>=(const int) const | CAsiExactNum | virtual
packSize(void) const (defined in CAsiDecimal) | CAsiDecimal | virtual
packTo(CAsiObjPack *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
packValueSize(void) const (defined in CAsiDecimal) | CAsiDecimal | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
Precision(void) const | CAsiNum | virtual
precision (defined in CAsiNum) | CAsiNum | protected
realValue(void) const (defined in CAsiDecimal) | CAsiDecimal | virtual
ReturnLength(void) const (defined in CAsiDecimal) | CAsiDecimal | virtual
scale (defined in CAsiNum) | CAsiNum | protected
Scale(void) const | CAsiNum | virtual
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
SQLType(CAsiUcStr *) const (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(real) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(integer) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(smallint) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(char *, uint) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(const CAsiUcStr &) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(const CAsiData &) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(LARGE_INTEGER) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(ULARGE_INTEGER) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(const DECIMAL &) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(char *, uint, uint *) (defined in CAsiDecimal) | CAsiDecimal | virtual
storeValue(const AsiUcStr) (defined in CAsiDecimal) | CAsiDecimal | virtual
CAsiExactNum::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBDATE *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBTIME *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiDecimal) | CAsiDecimal | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiDecimal) | CAsiDecimal | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiDecimal) | CAsiDecimal | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiDecimal(void) (defined in CAsiDecimal) | CAsiDecimal | virtual
~CAsiExactNum() | CAsiExactNum | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiDouble Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiDouble Class Reference
Misc Classes
+ Inheritance diagram for CAsiDouble:

Public Member Functions

CAsiDouble (const CAsiDouble &)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual CAsiObject * | duplicate (void) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual integer | intValue (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
CAsiDouble | operator* (const CAsiSmallInt &) const
CAsiDouble | operator* (const CAsiInt &) const
CAsiDouble | operator* (const CAsiNumeric &) const
CAsiDouble | operator* (const CAsiDecimal &) const
CAsiDouble | operator* (const CAsiFloat &) const
CAsiDouble | operator* (const CAsiReal &) const
CAsiDouble | operator* (const CAsiDouble &) const
CAsiDouble | operator* (const smallint) const
CAsiDouble | operator* (const integer) const
CAsiDouble | operator* (const real) const
CAsiDouble | operator* (const int) const
CAsiDouble & | operator*= (const CAsiSmallInt &)
CAsiDouble & | operator*= (const CAsiInt &)
CAsiDouble & | operator*= (const CAsiNumeric &)
CAsiDouble & | operator*= (const CAsiDecimal &)
CAsiDouble & | operator*= (const CAsiFloat &)
CAsiDouble & | operator*= (const CAsiReal &)
CAsiDouble & | operator*= (const CAsiDouble &)
CAsiDouble & | operator*= (const smallint)
CAsiDouble & | operator*= (const integer)
CAsiDouble & | operator*= (const real)
CAsiDouble & | operator*= (const int)
CAsiDouble | operator+ (const CAsiSmallInt &) const
CAsiDouble | operator+ (const CAsiInt &) const
CAsiDouble | operator+ (const CAsiNumeric &) const
CAsiDouble | operator+ (const CAsiDecimal &) const
CAsiDouble | operator+ (const CAsiFloat &) const
CAsiDouble | operator+ (const CAsiReal &) const
CAsiDouble | operator+ (const CAsiDouble &) const
CAsiDouble | operator+ (const smallint) const
CAsiDouble | operator+ (const integer) const
CAsiDouble | operator+ (const real) const
CAsiDouble | operator+ (const int) const
CAsiDouble & | operator++ (void)
CAsiDouble & | operator+= (const CAsiSmallInt &)
CAsiDouble & | operator+= (const CAsiInt &)
CAsiDouble & | operator+= (const CAsiNumeric &)
CAsiDouble & | operator+= (const CAsiDecimal &)
CAsiDouble & | operator+= (const CAsiFloat &)
CAsiDouble & | operator+= (const CAsiReal &)
CAsiDouble & | operator+= (const CAsiDouble &)
CAsiDouble & | operator+= (const smallint)
CAsiDouble & | operator+= (const integer)
CAsiDouble & | operator+= (const real)
CAsiDouble & | operator+= (const int)
CAsiDouble | operator- (const CAsiSmallInt &) const
CAsiDouble | operator- (const CAsiInt &) const
CAsiDouble | operator- (const CAsiNumeric &) const
CAsiDouble | operator- (const CAsiDecimal &) const
CAsiDouble | operator- (const CAsiFloat &) const
CAsiDouble | operator- (const CAsiReal &) const
CAsiDouble | operator- (const CAsiDouble &) const
CAsiDouble | operator- (const smallint) const
CAsiDouble | operator- (const integer) const
CAsiDouble | operator- (const real) const
CAsiDouble | operator- (const int) const
CAsiDouble & | operator- (void)
CAsiDouble & | operator-- (void)
CAsiDouble & | operator-= (const CAsiSmallInt &)
CAsiDouble & | operator-= (const CAsiInt &)
CAsiDouble & | operator-= (const CAsiNumeric &)
CAsiDouble & | operator-= (const CAsiDecimal &)
CAsiDouble & | operator-= (const CAsiFloat &)
CAsiDouble & | operator-= (const CAsiReal &)
CAsiDouble & | operator-= (const CAsiDouble &)
CAsiDouble & | operator-= (const smallint)
CAsiDouble & | operator-= (const integer)
CAsiDouble & | operator-= (const real)
CAsiDouble & | operator-= (const int)
CAsiDouble | operator/ (const CAsiSmallInt &) const
CAsiDouble | operator/ (const CAsiInt &) const
CAsiDouble | operator/ (const CAsiNumeric &) const
CAsiDouble | operator/ (const CAsiDecimal &) const
CAsiDouble | operator/ (const CAsiFloat &) const
CAsiDouble | operator/ (const CAsiReal &) const
CAsiDouble | operator/ (const CAsiDouble &) const
CAsiDouble | operator/ (const smallint) const
CAsiDouble | operator/ (const integer) const
CAsiDouble | operator/ (const real) const
CAsiDouble | operator/ (const int) const
CAsiDouble & | operator/= (const CAsiSmallInt &)
CAsiDouble & | operator/= (const CAsiInt &)
CAsiDouble & | operator/= (const CAsiNumeric &)
CAsiDouble & | operator/= (const CAsiDecimal &)
CAsiDouble & | operator/= (const CAsiFloat &)
CAsiDouble & | operator/= (const CAsiReal &)
CAsiDouble & | operator/= (const CAsiDouble &)
CAsiDouble & | operator/= (const smallint)
CAsiDouble & | operator/= (const integer)
CAsiDouble & | operator/= (const real)
CAsiDouble & | operator/= (const int)
CAsiDouble & | operator= (const CAsiSmallInt &)
CAsiDouble & | operator= (const CAsiInt &)
CAsiDouble & | operator= (const CAsiNumeric &)
CAsiDouble & | operator= (const CAsiDecimal &)
CAsiDouble & | operator= (const CAsiFloat &)
CAsiDouble & | operator= (const CAsiReal &)
CAsiDouble & | operator= (const CAsiDouble &)
CAsiDouble & | operator= (const smallint)
CAsiDouble & | operator= (const integer)
CAsiDouble & | operator= (const real)
CAsiDouble & | operator= (const int)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual real | realValue (void) const
virtual uint | ReturnLength (void) const
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiDataType | Type (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiApproxNum
virtual EAsiBoolean | is_approxnumeric (void) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual | ~CAsiApproxNum ()
- Public Member Functions inherited from CAsiNum
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

CAsiDouble DLLScope | operator* (const CAsiSmallInt &, const CAsiDouble &)
CAsiDouble DLLScope | operator* (const CAsiInt &, const CAsiDouble &)
CAsiDouble DLLScope | operator* (const CAsiNumeric &, const CAsiDouble &)
CAsiDouble DLLScope | operator* (const CAsiDecimal &, const CAsiDouble &)
CAsiDouble DLLScope | operator* (const CAsiFloat &, const CAsiDouble &)
CAsiDouble DLLScope | operator* (const CAsiReal &, const CAsiDouble &)
CAsiDouble DLLScope | operator* (const smallint, const CAsiDouble &)
CAsiDouble DLLScope | operator* (const integer, const CAsiDouble &)
CAsiDouble DLLScope | operator* (const real, const CAsiDouble &)
CAsiDouble DLLScope | operator* (const int, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const CAsiSmallInt &, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const CAsiInt &, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const CAsiNumeric &, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const CAsiDecimal &, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const CAsiFloat &, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const CAsiReal &, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const smallint, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const integer, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const real, const CAsiDouble &)
CAsiDouble DLLScope | operator+ (const int, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const CAsiSmallInt &, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const CAsiInt &, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const CAsiNumeric &, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const CAsiDecimal &, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const CAsiFloat &, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const CAsiReal &, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const smallint, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const integer, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const real, const CAsiDouble &)
CAsiDouble DLLScope | operator- (const int, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const CAsiSmallInt &, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const CAsiInt &, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const CAsiNumeric &, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const CAsiDecimal &, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const CAsiFloat &, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const CAsiReal &, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const smallint, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const integer, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const real, const CAsiDouble &)
CAsiDouble DLLScope | operator/ (const int, const CAsiDouble &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Member Functions inherited from CAsiNum
CAsiNum ()
- Protected Attributes inherited from CAsiNum
uint | precision
uint | scale
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiDouble Member List

This is the complete list of members for CAsiDouble, including all inherited members.

CAsiApproxNum() (defined in CAsiApproxNum) | CAsiApproxNum | protected
CAsiData(void) | CAsiData |
CAsiDouble(void) (defined in CAsiDouble) | CAsiDouble |
CAsiDouble(const CAsiDouble &) (defined in CAsiDouble) | CAsiDouble |
CAsiNum() | CAsiNum | protected
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const (defined in CAsiDouble) | CAsiDouble | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const (defined in CAsiDouble) | CAsiDouble | virtual
checkMul(const CAsiData *) const (defined in CAsiDouble) | CAsiDouble | virtual
checkSet(const CAsiData *) const (defined in CAsiDouble) | CAsiDouble | virtual
checkSub(const CAsiData *) const (defined in CAsiDouble) | CAsiDouble | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiDouble) | CAsiDouble | virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const (defined in CAsiDouble) | CAsiDouble | virtual
getValue(integer *) const (defined in CAsiDouble) | CAsiDouble | virtual
getValue(smallint *) const (defined in CAsiDouble) | CAsiDouble | virtual
getValue(char *, uint) const (defined in CAsiDouble) | CAsiDouble | virtual
getValue(CAsiUcStr *) const (defined in CAsiDouble) | CAsiDouble | virtual
getValue(char *, uint, uint *) const (defined in CAsiDouble) | CAsiDouble | virtual
getValue(AsiUcStr, uint) const (defined in CAsiDouble) | CAsiDouble | virtual
getValue(CAsiData &) const (defined in CAsiDouble) | CAsiDouble | virtual
CAsiApproxNum::getValue(DECIMAL *) const | CAsiData | virtual
CAsiApproxNum::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiApproxNum::getValue(DBDATE *) const | CAsiData | virtual
CAsiApproxNum::getValue(DBTIME *) const | CAsiData | virtual
CAsiApproxNum::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const (defined in CAsiDouble) | CAsiDouble | virtual
is_approxnumeric(void) const | CAsiApproxNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiDouble) | CAsiDouble | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiDouble) | CAsiDouble | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiDouble) | CAsiDouble | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiDouble) | CAsiDouble | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator!=(const CAsiInt &) const | CAsiApproxNum | virtual
operator!=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator!=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator!=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator!=(const CAsiReal &) const | CAsiApproxNum | virtual
operator!=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator!=(const smallint) const | CAsiApproxNum | virtual
operator!=(const integer) const | CAsiApproxNum | virtual
operator!=(const real) const | CAsiApproxNum | virtual
operator!=(const int) const | CAsiApproxNum | virtual
operator*(const CAsiSmallInt &) const (defined in CAsiDouble) | CAsiDouble |
operator*(const CAsiInt &) const (defined in CAsiDouble) | CAsiDouble |
operator*(const CAsiNumeric &) const (defined in CAsiDouble) | CAsiDouble |
operator*(const CAsiDecimal &) const (defined in CAsiDouble) | CAsiDouble |
operator*(const CAsiFloat &) const (defined in CAsiDouble) | CAsiDouble |
operator*(const CAsiReal &) const (defined in CAsiDouble) | CAsiDouble |
operator*(const CAsiDouble &) const (defined in CAsiDouble) | CAsiDouble |
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator*(const smallint) const (defined in CAsiDouble) | CAsiDouble |
operator*(const integer) const (defined in CAsiDouble) | CAsiDouble |
operator*(const real) const (defined in CAsiDouble) | CAsiDouble |
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator*(const int) const (defined in CAsiDouble) | CAsiDouble |
operator* (defined in CAsiDouble) | CAsiDouble | friend
operator*=(const CAsiSmallInt &) (defined in CAsiDouble) | CAsiDouble |
operator*=(const CAsiInt &) (defined in CAsiDouble) | CAsiDouble |
operator*=(const CAsiNumeric &) (defined in CAsiDouble) | CAsiDouble |
operator*=(const CAsiDecimal &) (defined in CAsiDouble) | CAsiDouble |
operator*=(const CAsiFloat &) (defined in CAsiDouble) | CAsiDouble |
operator*=(const CAsiReal &) (defined in CAsiDouble) | CAsiDouble |
operator*=(const CAsiDouble &) (defined in CAsiDouble) | CAsiDouble |
operator*=(const smallint) (defined in CAsiDouble) | CAsiDouble |
operator*=(const integer) (defined in CAsiDouble) | CAsiDouble |
operator*=(const real) (defined in CAsiDouble) | CAsiDouble |
operator*=(const int) (defined in CAsiDouble) | CAsiDouble |
operator+(const CAsiSmallInt &) const (defined in CAsiDouble) | CAsiDouble |
operator+(const CAsiInt &) const (defined in CAsiDouble) | CAsiDouble |
operator+(const CAsiNumeric &) const (defined in CAsiDouble) | CAsiDouble |
operator+(const CAsiDecimal &) const (defined in CAsiDouble) | CAsiDouble |
operator+(const CAsiFloat &) const (defined in CAsiDouble) | CAsiDouble |
operator+(const CAsiReal &) const (defined in CAsiDouble) | CAsiDouble |
operator+(const CAsiDouble &) const (defined in CAsiDouble) | CAsiDouble |
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator+(const smallint) const (defined in CAsiDouble) | CAsiDouble |
operator+(const integer) const (defined in CAsiDouble) | CAsiDouble |
operator+(const real) const (defined in CAsiDouble) | CAsiDouble |
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator+(const int) const (defined in CAsiDouble) | CAsiDouble |
operator+ (defined in CAsiDouble) | CAsiDouble | friend
operator++(void) (defined in CAsiDouble) | CAsiDouble |
operator+=(const CAsiSmallInt &) (defined in CAsiDouble) | CAsiDouble |
operator+=(const CAsiInt &) (defined in CAsiDouble) | CAsiDouble |
operator+=(const CAsiNumeric &) (defined in CAsiDouble) | CAsiDouble |
operator+=(const CAsiDecimal &) (defined in CAsiDouble) | CAsiDouble |
operator+=(const CAsiFloat &) (defined in CAsiDouble) | CAsiDouble |
operator+=(const CAsiReal &) (defined in CAsiDouble) | CAsiDouble |
operator+=(const CAsiDouble &) (defined in CAsiDouble) | CAsiDouble |
operator+=(const smallint) (defined in CAsiDouble) | CAsiDouble |
operator+=(const integer) (defined in CAsiDouble) | CAsiDouble |
operator+=(const real) (defined in CAsiDouble) | CAsiDouble |
operator+=(const int) (defined in CAsiDouble) | CAsiDouble |
operator-(const CAsiSmallInt &) const (defined in CAsiDouble) | CAsiDouble |
operator-(const CAsiInt &) const (defined in CAsiDouble) | CAsiDouble |
operator-(const CAsiNumeric &) const (defined in CAsiDouble) | CAsiDouble |
operator-(const CAsiDecimal &) const (defined in CAsiDouble) | CAsiDouble |
operator-(const CAsiFloat &) const (defined in CAsiDouble) | CAsiDouble |
operator-(const CAsiReal &) const (defined in CAsiDouble) | CAsiDouble |
operator-(const CAsiDouble &) const (defined in CAsiDouble) | CAsiDouble |
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator-(const smallint) const (defined in CAsiDouble) | CAsiDouble |
operator-(const integer) const (defined in CAsiDouble) | CAsiDouble |
operator-(const real) const (defined in CAsiDouble) | CAsiDouble |
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator-(const int) const (defined in CAsiDouble) | CAsiDouble |
operator- (defined in CAsiDouble) | CAsiDouble | friend
operator-(void) (defined in CAsiDouble) | CAsiDouble |
operator--(void) (defined in CAsiDouble) | CAsiDouble |
operator-=(const CAsiSmallInt &) (defined in CAsiDouble) | CAsiDouble |
operator-=(const CAsiInt &) (defined in CAsiDouble) | CAsiDouble |
operator-=(const CAsiNumeric &) (defined in CAsiDouble) | CAsiDouble |
operator-=(const CAsiDecimal &) (defined in CAsiDouble) | CAsiDouble |
operator-=(const CAsiFloat &) (defined in CAsiDouble) | CAsiDouble |
operator-=(const CAsiReal &) (defined in CAsiDouble) | CAsiDouble |
operator-=(const CAsiDouble &) (defined in CAsiDouble) | CAsiDouble |
operator-=(const smallint) (defined in CAsiDouble) | CAsiDouble |
operator-=(const integer) (defined in CAsiDouble) | CAsiDouble |
operator-=(const real) (defined in CAsiDouble) | CAsiDouble |
operator-=(const int) (defined in CAsiDouble) | CAsiDouble |
operator/(const CAsiSmallInt &) const (defined in CAsiDouble) | CAsiDouble |
operator/(const CAsiInt &) const (defined in CAsiDouble) | CAsiDouble |
operator/(const CAsiNumeric &) const (defined in CAsiDouble) | CAsiDouble |
operator/(const CAsiDecimal &) const (defined in CAsiDouble) | CAsiDouble |
operator/(const CAsiFloat &) const (defined in CAsiDouble) | CAsiDouble |
operator/(const CAsiReal &) const (defined in CAsiDouble) | CAsiDouble |
operator/(const CAsiDouble &) const (defined in CAsiDouble) | CAsiDouble |
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/(const smallint) const (defined in CAsiDouble) | CAsiDouble |
operator/(const integer) const (defined in CAsiDouble) | CAsiDouble |
operator/(const real) const (defined in CAsiDouble) | CAsiDouble |
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/(const int) const (defined in CAsiDouble) | CAsiDouble |
operator/ (defined in CAsiDouble) | CAsiDouble | friend
operator/=(const CAsiSmallInt &) (defined in CAsiDouble) | CAsiDouble |
operator/=(const CAsiInt &) (defined in CAsiDouble) | CAsiDouble |
operator/=(const CAsiNumeric &) (defined in CAsiDouble) | CAsiDouble |
operator/=(const CAsiDecimal &) (defined in CAsiDouble) | CAsiDouble |
operator/=(const CAsiFloat &) (defined in CAsiDouble) | CAsiDouble |
operator/=(const CAsiReal &) (defined in CAsiDouble) | CAsiDouble |
operator/=(const CAsiDouble &) (defined in CAsiDouble) | CAsiDouble |
operator/=(const smallint) (defined in CAsiDouble) | CAsiDouble |
operator/=(const integer) (defined in CAsiDouble) | CAsiDouble |
operator/=(const real) (defined in CAsiDouble) | CAsiDouble |
operator/=(const int) (defined in CAsiDouble) | CAsiDouble |
operator<(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator<(const CAsiInt &) const | CAsiApproxNum | virtual
operator<(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator<(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator<(const CAsiFloat &) const | CAsiApproxNum | virtual
operator<(const CAsiReal &) const | CAsiApproxNum | virtual
operator<(const CAsiDouble &) const | CAsiApproxNum | virtual
operator<(const smallint) const | CAsiApproxNum | virtual
operator<(const integer) const | CAsiApproxNum | virtual
operator<(const real) const | CAsiApproxNum | virtual
operator<(const int) const | CAsiApproxNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator<=(const CAsiInt &) const | CAsiApproxNum | virtual
operator<=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator<=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator<=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator<=(const CAsiReal &) const | CAsiApproxNum | virtual
operator<=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator<=(const smallint) const | CAsiApproxNum | virtual
operator<=(const integer) const | CAsiApproxNum | virtual
operator<=(const real) const | CAsiApproxNum | virtual
operator<=(const int) const | CAsiApproxNum | virtual
operator=(const CAsiSmallInt &) (defined in CAsiDouble) | CAsiDouble |
operator=(const CAsiInt &) (defined in CAsiDouble) | CAsiDouble |
operator=(const CAsiNumeric &) (defined in CAsiDouble) | CAsiDouble |
operator=(const CAsiDecimal &) (defined in CAsiDouble) | CAsiDouble |
operator=(const CAsiFloat &) (defined in CAsiDouble) | CAsiDouble |
operator=(const CAsiReal &) (defined in CAsiDouble) | CAsiDouble |
operator=(const CAsiDouble &) (defined in CAsiDouble) | CAsiDouble |
operator=(const smallint) (defined in CAsiDouble) | CAsiDouble |
operator=(const integer) (defined in CAsiDouble) | CAsiDouble |
operator=(const real) (defined in CAsiDouble) | CAsiDouble |
operator=(const int) (defined in CAsiDouble) | CAsiDouble |
operator==(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator==(const CAsiInt &) const | CAsiApproxNum | virtual
operator==(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator==(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator==(const CAsiFloat &) const | CAsiApproxNum | virtual
operator==(const CAsiReal &) const | CAsiApproxNum | virtual
operator==(const CAsiDouble &) const | CAsiApproxNum | virtual
operator==(const smallint) const | CAsiApproxNum | virtual
operator==(const integer) const | CAsiApproxNum | virtual
operator==(const real) const | CAsiApproxNum | virtual
operator==(const int) const | CAsiApproxNum | virtual
operator>(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator>(const CAsiInt &) const | CAsiApproxNum | virtual
operator>(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator>(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator>(const CAsiFloat &) const | CAsiApproxNum | virtual
operator>(const CAsiReal &) const | CAsiApproxNum | virtual
operator>(const CAsiDouble &) const | CAsiApproxNum | virtual
operator>(const smallint) const | CAsiApproxNum | virtual
operator>(const integer) const | CAsiApproxNum | virtual
operator>(const real) const | CAsiApproxNum | virtual
operator>(const int) const | CAsiApproxNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator>=(const CAsiInt &) const | CAsiApproxNum | virtual
operator>=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator>=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator>=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator>=(const CAsiReal &) const | CAsiApproxNum | virtual
operator>=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator>=(const smallint) const | CAsiApproxNum | virtual
operator>=(const integer) const | CAsiApproxNum | virtual
operator>=(const real) const | CAsiApproxNum | virtual
operator>=(const int) const | CAsiApproxNum | virtual
packSize(void) const (defined in CAsiDouble) | CAsiDouble | virtual
packTo(CAsiObjPack *) const (defined in CAsiDouble) | CAsiDouble | virtual
packValueSize(void) const (defined in CAsiDouble) | CAsiDouble | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiDouble) | CAsiDouble | virtual
precision (defined in CAsiNum) | CAsiNum | protected
Precision(void) const | CAsiNum | virtual
realValue(void) const (defined in CAsiDouble) | CAsiDouble | virtual
ReturnLength(void) const (defined in CAsiDouble) | CAsiDouble | virtual
scale (defined in CAsiNum) | CAsiNum | protected
Scale(void) const | CAsiNum | virtual
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const (defined in CAsiDouble) | CAsiDouble | virtual
SQLType(CAsiUcStr *) const (defined in CAsiDouble) | CAsiDouble | virtual
storeValue(real) (defined in CAsiDouble) | CAsiDouble | virtual
storeValue(integer) (defined in CAsiDouble) | CAsiDouble | virtual
storeValue(smallint) (defined in CAsiDouble) | CAsiDouble | virtual
storeValue(char *, uint) (defined in CAsiDouble) | CAsiDouble | virtual
storeValue(const CAsiUcStr &) (defined in CAsiDouble) | CAsiDouble | virtual
storeValue(const CAsiData &) (defined in CAsiDouble) | CAsiDouble | virtual
storeValue(char *, uint, uint *) (defined in CAsiDouble) | CAsiDouble | virtual
storeValue(const AsiUcStr) (defined in CAsiDouble) | CAsiDouble | virtual
CAsiApproxNum::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiApproxNum::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiApproxNum::storeValue(const DBDATE *) | CAsiData | virtual
CAsiApproxNum::storeValue(const DBTIME *) | CAsiData | virtual
CAsiApproxNum::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiDouble) | CAsiDouble | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiDouble) | CAsiDouble | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiDouble) | CAsiDouble | virtual
~CAsiApproxNum() | CAsiApproxNum | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiDouble(void) (defined in CAsiDouble) | CAsiDouble | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiDT Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAsiDT Class Reference
Misc Classes
+ Inheritance diagram for CAsiDT:

Public Member Functions

CAsiDT (EAsiIType)
CAsiDT (EAsiIType, uint)
CAsiDT (EAsiIType, uint, uint)
CAsiDT (const CAsiDT &)
virtual CAsiObject * | duplicate (void) const
EAsiBoolean | get (ASI_IDAY *) const
EAsiBoolean | get (ASI_IHOUR *) const
EAsiBoolean | get (ASI_IMINUTE *) const
EAsiBoolean | get (ASI_ISECOND *) const
EAsiBoolean | get (ASI_IDAYTOHOUR *) const
EAsiBoolean | get (ASI_IDAYTOMINUTE *) const
EAsiBoolean | get (ASI_IDAYTOSECOND *) const
EAsiBoolean | get (ASI_IHOURTOMINUTE *) const
EAsiBoolean | get (ASI_IHOURTOSECOND *) const
EAsiBoolean | get (ASI_IMINUTETOSECOND *) const
EAsiBoolean | get (EAsiBoolean *, uint *, uint *, uint *, double *) const
EAsiBoolean | getDays (uint *) const
EAsiBoolean | getHours (uint *) const
EAsiBoolean | getMinutes (uint *) const
EAsiBoolean | getSeconds (double *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
int | operator!= (const CAsiDT &) const
CAsiDT | operator* (const CAsiSmallInt &) const
CAsiDT | operator* (const CAsiInt &) const
CAsiDT | operator* (const CAsiNumeric &) const
CAsiDT | operator* (const CAsiDecimal &) const
CAsiDT | operator* (integer) const
CAsiDT | operator+ (const CAsiDT &) const
CAsiDT | operator- (const CAsiDT &) const
CAsiDT & | operator- (void)
CAsiDT | operator/ (const CAsiSmallInt &) const
CAsiDT | operator/ (const CAsiInt &) const
CAsiDT | operator/ (const CAsiNumeric &) const
CAsiDT | operator/ (const CAsiDecimal &) const
CAsiDT | operator/ (integer) const
int | operator< (const CAsiDT &) const
int | operator<= (const CAsiDT &) const
CAsiDT & | operator= (const CAsiDT &)
CAsiDT & | operator= (const CAsiSmallInt &)
CAsiDT & | operator= (const CAsiInt &)
CAsiDT & | operator= (const CAsiNumeric &)
CAsiDT & | operator= (const CAsiDecimal &)
CAsiDT & | operator= (integer)
int | operator== (const CAsiDT &) const
int | operator> (const CAsiDT &) const
int | operator>= (const CAsiDT &) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
EAsiBoolean | set (ASI_IDAY *)
EAsiBoolean | set (ASI_IHOUR *)
EAsiBoolean | set (ASI_IMINUTE *)
EAsiBoolean | set (ASI_ISECOND *)
EAsiBoolean | set (ASI_IDAYTOHOUR *)
EAsiBoolean | set (ASI_IDAYTOMINUTE *)
EAsiBoolean | set (ASI_IDAYTOSECOND *)
EAsiBoolean | set (ASI_IHOURTOMINUTE *)
EAsiBoolean | set (ASI_IHOURTOSECOND *)
EAsiBoolean | set (ASI_IMINUTETOSECOND *)
EAsiBoolean | set (EAsiBoolean, uint, uint, uint, double)
EAsiBoolean | setDays (uint)
EAsiBoolean | setHours (uint)
virtual EAsiBoolean | setIType (EAsiIType)
EAsiBoolean | setMinutes (uint)
EAsiBoolean | setSeconds (double)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiInterval
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
void | setSign (EAsiBoolean)
EAsiBoolean | Sign (void) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
- Public Member Functions inherited from CAsiIQualifier
CAsiIQualifier (EAsiIType)
CAsiIQualifier (EAsiIType, uint)
CAsiIQualifier (EAsiIType, uint, uint)
CAsiIQualifier (const CAsiIQualifier &)
virtual uint | FracSecPrec (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_interval (void) const
EAsiBoolean | is_moreaccurate (const CAsiIQualifier *) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | is_yminterval (void) const
virtual uint | LeadFieldPrec (void) const
CAsiIQualifier & | operator= (const CAsiIQualifier &)
virtual uint | ReturnLength (void) const
void | setFracSecPrec (uint)
void | setLeadFieldPrec (uint)
virtual EAsiDataType | Type (void) const
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | Length (void) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Protected Attributes

double | ivalue
- Protected Attributes inherited from CAsiInterval
EAsiBoolean | sign
- Protected Attributes inherited from CAsiIQualifier
uint | fsp
EAsiIType | itype
uint | lfp
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull

Friends

class | CAsiDate
class | CAsiTempTable
class | CAsiTime
class | CAsiTimeStamp
CAsiDT DLLScope | operator* (const CAsiSmallInt &, const CAsiDT &)
CAsiDT DLLScope | operator* (const CAsiInt &, const CAsiDT &)
CAsiDT DLLScope | operator* (const CAsiNumeric &, const CAsiDT &)
CAsiDT DLLScope | operator* (const CAsiDecimal &, const CAsiDT &)
CAsiDT DLLScope | operator* (integer, const CAsiDT &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiDT Member List

This is the complete list of members for CAsiDT, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDate (defined in CAsiDT) | CAsiDT | friend
CAsiDT(void) (defined in CAsiDT) | CAsiDT |
CAsiDT(EAsiIType) (defined in CAsiDT) | CAsiDT |
CAsiDT(EAsiIType, uint) (defined in CAsiDT) | CAsiDT |
CAsiDT(EAsiIType, uint, uint) (defined in CAsiDT) | CAsiDT |
CAsiDT(const CAsiDT &) (defined in CAsiDT) | CAsiDT |
CAsiInterval(void) (defined in CAsiInterval) | CAsiInterval |
CAsiIQualifier(void) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType, uint) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType, uint, uint) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(const CAsiIQualifier &) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiObject(void) | CAsiObject |
CAsiTempTable (defined in CAsiDT) | CAsiDT | friend
CAsiTime (defined in CAsiDT) | CAsiDT | friend
CAsiTimeStamp (defined in CAsiDT) | CAsiDT | friend
checkAdd(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkMul(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkSet(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkSub(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiDT) | CAsiDT | virtual
FracSecPrec(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
fsp (defined in CAsiIQualifier) | CAsiIQualifier | protected
get(ASI_IDAY *) const (defined in CAsiDT) | CAsiDT |
get(ASI_IHOUR *) const (defined in CAsiDT) | CAsiDT |
get(ASI_IMINUTE *) const (defined in CAsiDT) | CAsiDT |
get(ASI_ISECOND *) const (defined in CAsiDT) | CAsiDT |
get(ASI_IDAYTOHOUR *) const (defined in CAsiDT) | CAsiDT |
get(ASI_IDAYTOMINUTE *) const (defined in CAsiDT) | CAsiDT |
get(ASI_IDAYTOSECOND *) const (defined in CAsiDT) | CAsiDT |
get(ASI_IHOURTOMINUTE *) const (defined in CAsiDT) | CAsiDT |
get(ASI_IHOURTOSECOND *) const (defined in CAsiDT) | CAsiDT |
get(ASI_IMINUTETOSECOND *) const (defined in CAsiDT) | CAsiDT |
get(EAsiBoolean *, uint *, uint *, uint *, double *) const (defined in CAsiDT) | CAsiDT |
getDays(uint *) const (defined in CAsiDT) | CAsiDT |
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getHours(uint *) const (defined in CAsiDT) | CAsiDT |
getMinutes(uint *) const (defined in CAsiDT) | CAsiDT |
getSeconds(double *) const (defined in CAsiDT) | CAsiDT |
getValue(integer *) const (defined in CAsiDT) | CAsiDT | virtual
getValue(smallint *) const (defined in CAsiDT) | CAsiDT | virtual
getValue(char *, uint) const (defined in CAsiDT) | CAsiDT | virtual
getValue(CAsiUcStr *) const (defined in CAsiDT) | CAsiDT | virtual
getValue(real *) const (defined in CAsiDT) | CAsiDT | virtual
getValue(char *, uint, uint *) const (defined in CAsiDT) | CAsiDT | virtual
getValue(AsiUcStr, uint) const (defined in CAsiDT) | CAsiDT | virtual
getValue(CAsiData &) const (defined in CAsiDT) | CAsiDT | virtual
CAsiInterval::getValue(DECIMAL *) const | CAsiData | virtual
CAsiInterval::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiInterval::getValue(DBDATE *) const | CAsiData | virtual
CAsiInterval::getValue(DBTIME *) const | CAsiData | virtual
CAsiInterval::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const (defined in CAsiDT) | CAsiDT | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_moreaccurate(const CAsiIQualifier *) const (defined in CAsiIQualifier) | CAsiIQualifier |
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_yminterval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
isEqualTo(const CAsiData &) const (defined in CAsiDT) | CAsiDT | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiDT) | CAsiDT | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
itype (defined in CAsiIQualifier) | CAsiIQualifier | protected
ivalue (defined in CAsiDT) | CAsiDT | protected
LeadFieldPrec(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
Length(void) const | CAsiData | virtual
lfp (defined in CAsiIQualifier) | CAsiIQualifier | protected
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiDT) | CAsiDT | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiDT) | CAsiDT | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiDT &) const (defined in CAsiDT) | CAsiDT |
operator*(const CAsiSmallInt &) const (defined in CAsiDT) | CAsiDT |
operator*(const CAsiInt &) const (defined in CAsiDT) | CAsiDT |
operator*(const CAsiNumeric &) const (defined in CAsiDT) | CAsiDT |
operator*(const CAsiDecimal &) const (defined in CAsiDT) | CAsiDT |
operator*(integer) const (defined in CAsiDT) | CAsiDT |
operator* (defined in CAsiDT) | CAsiDT | friend
operator* (defined in CAsiDT) | CAsiDT | friend
operator* (defined in CAsiDT) | CAsiDT | friend
operator* (defined in CAsiDT) | CAsiDT | friend
operator* (defined in CAsiDT) | CAsiDT | friend
operator+(const CAsiDT &) const (defined in CAsiDT) | CAsiDT |
operator-(const CAsiDT &) const (defined in CAsiDT) | CAsiDT |
operator-(void) (defined in CAsiDT) | CAsiDT |
operator/(const CAsiSmallInt &) const (defined in CAsiDT) | CAsiDT |
operator/(const CAsiInt &) const (defined in CAsiDT) | CAsiDT |
operator/(const CAsiNumeric &) const (defined in CAsiDT) | CAsiDT |
operator/(const CAsiDecimal &) const (defined in CAsiDT) | CAsiDT |
operator/(integer) const (defined in CAsiDT) | CAsiDT |
operator<(const CAsiDT &) const (defined in CAsiDT) | CAsiDT |
operator<=(const CAsiDT &) const (defined in CAsiDT) | CAsiDT |
operator=(const CAsiDT &) (defined in CAsiDT) | CAsiDT |
operator=(const CAsiSmallInt &) (defined in CAsiDT) | CAsiDT |
operator=(const CAsiInt &) (defined in CAsiDT) | CAsiDT |
operator=(const CAsiNumeric &) (defined in CAsiDT) | CAsiDT |
operator=(const CAsiDecimal &) (defined in CAsiDT) | CAsiDT |
operator=(integer) (defined in CAsiDT) | CAsiDT |
operator=(const CAsiIQualifier &) (defined in CAsiIQualifier) | CAsiIQualifier |
operator==(const CAsiDT &) const (defined in CAsiDT) | CAsiDT |
operator>(const CAsiDT &) const (defined in CAsiDT) | CAsiDT |
operator>=(const CAsiDT &) const (defined in CAsiDT) | CAsiDT |
packSize(void) const (defined in CAsiDT) | CAsiDT | virtual
packTo(CAsiObjPack *) const (defined in CAsiDT) | CAsiDT | virtual
packValueSize(void) const (defined in CAsiDT) | CAsiDT | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiDT) | CAsiDT | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
Scale(void) const | CAsiData | virtual
set(ASI_IDAY *) (defined in CAsiDT) | CAsiDT |
set(ASI_IHOUR *) (defined in CAsiDT) | CAsiDT |
set(ASI_IMINUTE *) (defined in CAsiDT) | CAsiDT |
set(ASI_ISECOND *) (defined in CAsiDT) | CAsiDT |
set(ASI_IDAYTOHOUR *) (defined in CAsiDT) | CAsiDT |
set(ASI_IDAYTOMINUTE *) (defined in CAsiDT) | CAsiDT |
set(ASI_IDAYTOSECOND *) (defined in CAsiDT) | CAsiDT |
set(ASI_IHOURTOMINUTE *) (defined in CAsiDT) | CAsiDT |
set(ASI_IHOURTOSECOND *) (defined in CAsiDT) | CAsiDT |
set(ASI_IMINUTETOSECOND *) (defined in CAsiDT) | CAsiDT |
set(EAsiBoolean, uint, uint, uint, double) (defined in CAsiDT) | CAsiDT |
setDays(uint) (defined in CAsiDT) | CAsiDT |
setFracSecPrec(uint) (defined in CAsiIQualifier) | CAsiIQualifier |
setHours(uint) (defined in CAsiDT) | CAsiDT |
setIType(EAsiIType) (defined in CAsiDT) | CAsiDT | virtual
setLeadFieldPrec(uint) (defined in CAsiIQualifier) | CAsiIQualifier |
setMinutes(uint) (defined in CAsiDT) | CAsiDT |
setNull(void) | CAsiData | virtual
setSeconds(double) (defined in CAsiDT) | CAsiDT |
setSign(EAsiBoolean) (defined in CAsiInterval) | CAsiInterval |
Sign(void) const (defined in CAsiInterval) | CAsiInterval |
sign (defined in CAsiInterval) | CAsiInterval | protected
SQLLiteral(CAsiUcStr *) const (defined in CAsiDT) | CAsiDT | virtual
SQLType(CAsiUcStr *) const (defined in CAsiInterval) | CAsiInterval | virtual
storeValue(integer) (defined in CAsiDT) | CAsiDT | virtual
storeValue(smallint) (defined in CAsiDT) | CAsiDT | virtual
storeValue(char *, uint) (defined in CAsiDT) | CAsiDT | virtual
storeValue(const CAsiUcStr &) (defined in CAsiDT) | CAsiDT | virtual
storeValue(const CAsiData &) (defined in CAsiDT) | CAsiDT | virtual
storeValue(real) (defined in CAsiDT) | CAsiDT | virtual
storeValue(char *, uint, uint *) (defined in CAsiDT) | CAsiDT | virtual
storeValue(const AsiUcStr) (defined in CAsiDT) | CAsiDT | virtual
CAsiInterval::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiInterval::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiInterval::storeValue(const DBDATE *) | CAsiData | virtual
CAsiInterval::storeValue(const DBTIME *) | CAsiData | virtual
CAsiInterval::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiDT) | CAsiDT | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiDT) | CAsiDT | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiDT(void) (defined in CAsiDT) | CAsiDT | virtual
~CAsiInterval(void) (defined in CAsiInterval) | CAsiInterval | virtual
~CAsiIQualifier(void) (defined in CAsiIQualifier) | CAsiIQualifier | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiEnumerator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
CAsiEnumerator Class Reference
Misc Classes
+ Inheritance diagram for CAsiEnumerator:

Public Member Functions

EAsiBoolean | Allocate (CAsiAppl *)
EAsiBoolean | Allocate (CAsiAppl *, CLSID &clsidEnum)
CAsiEnumerator (void)
virtual EAsiBoolean | Fetch (void)
void | SetFilter (EAsiDataSourceType dst, const CAsiUcStr &pName, EAsiBoolean isParent=kAsiUnknown)
virtual | ~CAsiEnumerator (void)
- Public Member Functions inherited from CAsiCsrTable
CAsiCsrTable (void)
virtual EAsiBoolean | Close (void)
virtual CAsiColumn * | ColDsc (int) const
virtual int | ColQty (void) const
virtual EAsiBoolean | Cvl (int, CAsiData *)
virtual EAsiBoolean | Cvl (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Open (void)
virtual EAsiBoolean | SetFilter (CAsiTCCond *)
virtual EAsiBoolean | SetOrder ()
virtual EAsiBoolean | Update (const CAsiRow &)
virtual | ~CAsiCsrTable (void)
- Public Member Functions inherited from CAsiCsr
EAsiBoolean | Allocate (CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse)
virtual EAsiBoolean | Bind (int, CAsiData *)
virtual EAsiBoolean | Bind (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Bind (const CAsiIdent &, CAsiData *)
virtual EAsiBoolean | Bind (const CAsiIdent &, void *, short *, int, EAsiHostType)
EAsiBoolean | Cancel (void)
CAsiCsr (void)
virtual EAsiBoolean | CheckCCondition (CAsiData **)
virtual EAsiBoolean | Delete (void)
virtual EAsiBoolean | FetchAbsolute (long)
virtual EAsiBoolean | FetchFirst (void)
virtual EAsiBoolean | FetchLast (void)
virtual EAsiBoolean | FetchPrior (void)
virtual EAsiBoolean | FetchRelative (long)
CAsiRow * | getCurrentRow (void)
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
virtual EAsiBoolean | Insert (const CAsiRow &)
virtual EAsiBoolean | Insert (void)
virtual EAsiBoolean | is_insensitive (void) const
virtual EAsiBoolean | is_insertable (void) const
virtual EAsiBoolean | is_open (void) const
virtual EAsiBoolean | is_scrollable (void) const
virtual EAsiBoolean | is_updatable (void) const
virtual EAsiBoolean | IsRowset (void) const
virtual CAsiParameter * | ParamDsc (int) const
virtual int | ParamQty (void) const
virtual EAsiCurPos | position (void) const
virtual EAsiBoolean | Sob (int, CAsiData *)
virtual EAsiBoolean | Sob (int, void *, short *, int, EAsiHostType)
virtual | ~CAsiCsr (void)
- Public Member Functions inherited from CAsiStm
CAsiStm (void)
void | SetSession (CAsiSession *)
virtual | ~CAsiStm (void)
- Public Member Functions inherited from CAsiSQLObject
EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Attributes

CLSID | m_clsidEnum
EAsiDataSourceType | m_eDsType
EAsiBoolean | m_fIsParent
CAsiUcStr | m_pName

Additional Inherited Members

- Protected Member Functions inherited from CAsiCsrTable
void DeallocCsr (void)

Constructor & Destructor Documentation

CAsiEnumerator::CAsiEnumerator ( void )
Warning
Not implemented!
virtual CAsiEnumerator::~CAsiEnumerator ( void )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAsiEnumerator::Allocate ( CAsiAppl * )
Warning
Not implemented!
EAsiBoolean CAsiEnumerator::Allocate | ( | CAsiAppl * | ,
 |  | CLSID & | clsidEnum
 | ) |  |
Warning
Not implemented!
virtual EAsiBoolean CAsiEnumerator::Fetch ( void )
virtual
Warning
Not implemented!

Reimplemented from CAsiCsr.

void CAsiEnumerator::SetFilter | ( | EAsiDataSourceType | dst,
 |  | const CAsiUcStr & | pName,
 |  | EAsiBoolean | isParent = kAsiUnknown
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiEnumerator Member List

This is the complete list of members for CAsiEnumerator, including all inherited members.

Allocate(CAsiAppl *) | CAsiEnumerator |
Allocate(CAsiAppl *, CLSID &clsidEnum) | CAsiEnumerator |
CAsiCsrTable::Allocate(CAsiExecStm *csrspec, const CAsiIdent &csrname, EAsiCurScr sc=kAsiNonScroll, EAsiCurSns sn=kAsiSnsUndef, EAsiBoolean upd=kAsiUnknown, EAsiBoolean fIns=kAsiFalse) | CAsiCsr |
Bind(int, CAsiData *) | CAsiCsr | virtual
Bind(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Bind(const CAsiIdent &, CAsiData *) | CAsiCsr | virtual
Bind(const CAsiIdent &, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
Cancel(void) | CAsiCsr |
CAsiCsr(void) | CAsiCsr |
CAsiCsrTable(void) | CAsiCsrTable |
CAsiEnumerator(void) | CAsiEnumerator |
CAsiObject(void) | CAsiObject |
CAsiSQLObject() | CAsiSQLObject | protected
CAsiStm(void) | CAsiStm |
CheckCCondition(CAsiData **) | CAsiCsr | virtual
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
Close(void) | CAsiCsrTable | virtual
ColDsc(int) const | CAsiCsrTable | virtual
ColQty(void) const | CAsiCsrTable | virtual
CondQty(void) const | CAsiSQLObject | virtual
Cvl(int, CAsiData *) | CAsiCsrTable | virtual
Cvl(int, void *, short *, int, EAsiHostType) | CAsiCsrTable | virtual
CvlInt(int, CAsiData *) const | CAsiStm | protected
DBMS(CAsiUcStr *) const | CAsiSQLObject |
DeallocCsr(void) | CAsiCsrTable | protected
Delete(void) | CAsiCsr | virtual
DoChangeErrors(HRESULT hr, ULONG, DBBINDING *) | CAsiCsr | protected
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
Fetch(void) | CAsiEnumerator | virtual
FetchAbsolute(long) | CAsiCsr | virtual
FetchFirst(void) | CAsiCsr | virtual
FetchLast(void) | CAsiCsr | virtual
FetchPrior(void) | CAsiCsr | virtual
FetchRelative(long) | CAsiCsr | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
GetColValue(int, CAsiData *) | CAsiCsr | protected
getCurrentRow(void) | CAsiCsr |
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiCsr | virtual
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
InitAccessor(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &, ULONG *, DBBINDING **, HACCESSOR *, EAsiBoolean) | CAsiCsr | protected
InitColsDsc() | CAsiStm | protected
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
InitOutputBind() | CAsiCsr | protected
Insert(const CAsiRow &) | CAsiCsr | virtual
Insert(void) | CAsiCsr | virtual
InsertRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
is_insensitive(void) const | CAsiCsr | virtual
is_insertable(void) const | CAsiCsr | virtual
is_open(void) const | CAsiCsr | virtual
is_scrollable(void) const | CAsiCsr | virtual
is_updatable(void) const | CAsiCsr | virtual
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiCsr | virtual
m_clsidEnum (defined in CAsiEnumerator) | CAsiEnumerator | protected
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_CsrName (defined in CAsiCsr) | CAsiCsr | protected
m_CsrPos (defined in CAsiCsr) | CAsiCsr | protected
m_dwOffset (defined in CAsiCsr) | CAsiCsr | protected
m_eDsType (defined in CAsiEnumerator) | CAsiEnumerator | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_fBlkStorObj (defined in CAsiCsr) | CAsiCsr | protected
m_fBLOBExpected (defined in CAsiCsr) | CAsiCsr | protected
m_fDataRead (defined in CAsiCsr) | CAsiCsr | protected
m_fIns (defined in CAsiCsr) | CAsiCsr | protected
m_fIsOpen (defined in CAsiCsr) | CAsiCsr | protected
m_fIsParent (defined in CAsiEnumerator) | CAsiEnumerator | protected
m_fOwnInserts (defined in CAsiCsr) | CAsiCsr | protected
m_fOwnUpdates (defined in CAsiCsr) | CAsiCsr | protected
m_fUpd (defined in CAsiCsr) | CAsiCsr | protected
m_hAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_iNumBind (defined in CAsiCsr) | CAsiCsr | protected
m_lColNumber (defined in CAsiStm) | CAsiStm | protected
m_lCurrRow (defined in CAsiCsr) | CAsiCsr | protected
m_lRowCount (defined in CAsiCsr) | CAsiCsr | protected
m_pAsiRow (defined in CAsiStm) | CAsiStm | protected
m_pColumnInfo (defined in CAsiStm) | CAsiStm | protected
m_pCursorSpec (defined in CAsiCsr) | CAsiCsr | protected
m_pData (defined in CAsiCsr) | CAsiCsr | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pIAccessor (defined in CAsiCsr) | CAsiCsr | protected
m_pIDataConvert (defined in CAsiCsr) | CAsiCsr | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pInput (defined in CAsiStm) | CAsiStm | protected
m_pIRowset (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetChange (defined in CAsiCsr) | CAsiCsr | protected
m_pIRowsetLocate (defined in CAsiCsr) | CAsiCsr | protected
m_pIUnknown (defined in CAsiCsr) | CAsiCsr | protected
m_pName (defined in CAsiEnumerator) | CAsiEnumerator | protected
m_pOutput (defined in CAsiStm) | CAsiStm | protected
m_pSession (defined in CAsiStm) | CAsiStm | protected
m_pStringBuff (defined in CAsiStm) | CAsiStm | protected
m_pTCCond (defined in CAsiCsr) | CAsiCsr | protected
m_rgBind (defined in CAsiCsr) | CAsiCsr | protected
m_rghRows (defined in CAsiCsr) | CAsiCsr | protected
m_ScrFlag (defined in CAsiCsr) | CAsiCsr | protected
m_SnsFlag (defined in CAsiCsr) | CAsiCsr | protected
m_ulColumns (defined in CAsiCsr) | CAsiCsr | protected
m_ulCurrentRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulMaxRowNo (defined in CAsiCsr) | CAsiCsr | protected
m_ulRows (defined in CAsiCsr) | CAsiCsr | protected
MakeCursorProp(DBPROPSET *pRowsetPropSet) | CAsiCsr | protected
Open(void) | CAsiCsrTable | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
ParamDsc(int) const | CAsiCsr | virtual
ParamQty(void) const | CAsiCsr | virtual
pInput(void) | CAsiStm | protected
position(void) const | CAsiCsr | virtual
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
QueryCursorProp(void) | CAsiCsr | protected
ReadData(void) | CAsiCsr | protected
ReleaseErrorInfo() | CAsiSQLObject | protected
RowCount(void) const | CAsiSQLObject |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
SetFilter(EAsiDataSourceType dst, const CAsiUcStr &pName, EAsiBoolean isParent=kAsiUnknown) | CAsiEnumerator |
CAsiCsrTable::SetFilter(CAsiTCCond *) | CAsiCsrTable | virtual
SetOrder() | CAsiCsrTable | virtual
SetSession(CAsiSession *) | CAsiStm |
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
Sob(int, CAsiData *) | CAsiCsr | virtual
Sob(int, void *, short *, int, EAsiHostType) | CAsiCsr | virtual
SobValues(void) | CAsiCsr | protected
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
StoreValueFromDBType(CAsiData *, DBTYPE, void *) | CAsiCsr | protected
Svl(int) | CAsiCsr | protected
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Update(const CAsiRow &) | CAsiCsrTable | virtual
UpdateRow(ULONG_PTR, DBCOLUMNINFO *, const CAsiRow &) | CAsiCsr | protected
Version(void) const | CAsiSQLObject |
~CAsiCsr(void) | CAsiCsr | virtual
~CAsiCsrTable(void) | CAsiCsrTable | virtual
~CAsiEnumerator(void) | CAsiEnumerator | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual
~CAsiStm(void) | CAsiStm | virtual


ZRX API Reference: CAsiExactNum Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
CAsiExactNum Class Reference
Misc Classes
+ Inheritance diagram for CAsiExactNum:

Public Member Functions

CAsiData * | checkAdd (const CAsiData *) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual | ~CAsiExactNum ()
- Public Member Functions inherited from CAsiNum
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual integer | intValue (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual uint | Precision (void) const
virtual real | realValue (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual CAsiObject * | duplicate (void) const =0
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual uint | ReturnLength (void) const
virtual void | setNull (void)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const =0
virtual EAsiBoolean | SQLType (CAsiUcStr *) const =0
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual EAsiDataType | Type (void) const =0
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

CAsiExactNum ()
int | cmpeqlan (const CAsiNum *) const
int | cmpeqlen (const CAsiExactNum *) const
int | cmpeqlenC (const real) const
int | cmpgtean (const CAsiNum *) const
int | cmpgteen (const CAsiExactNum *) const
int | cmpgteenC (const real) const
int | cmpgtran (const CAsiNum *) const
int | cmpgtren (const CAsiExactNum *) const
int | cmpgtrenC (const real) const
int | cmpltean (const CAsiNum *) const
int | cmplteen (const CAsiExactNum *) const
int | cmplteenC (const real) const
int | cmpltran (const CAsiNum *) const
int | cmpltren (const CAsiExactNum *) const
int | cmpltrenC (const real) const
int | cmpneqan (const CAsiNum *) const
int | cmpneqen (const CAsiExactNum *) const
int | cmpneqenC (const real) const
- Protected Member Functions inherited from CAsiNum
CAsiNum ()

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Attributes inherited from CAsiNum
uint | precision
uint | scale

Constructor & Destructor Documentation

CAsiExactNum::CAsiExactNum ( )
protected
Warning
Not implemented!
virtual CAsiExactNum::~CAsiExactNum ( )
virtual
Warning
Not implemented!

Member Function Documentation

CAsiData* CAsiExactNum::checkAdd ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

Reimplemented in CAsiSmallInt.

int CAsiExactNum::cmpeqlan ( const CAsiNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpeqlen ( const CAsiExactNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpeqlenC ( const real ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpgtean ( const CAsiNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpgteen ( const CAsiExactNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpgteenC ( const real ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpgtran ( const CAsiNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpgtren ( const CAsiExactNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpgtrenC ( const real ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpltean ( const CAsiNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmplteen ( const CAsiExactNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmplteenC ( const real ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpltran ( const CAsiNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpltren ( const CAsiExactNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpltrenC ( const real ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpneqan ( const CAsiNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpneqen ( const CAsiExactNum * ) const
protected
Warning
Not implemented!
int CAsiExactNum::cmpneqenC ( const real ) const
protected
Warning
Not implemented!
virtual EAsiBoolean CAsiExactNum::is_exactnumeric ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator!= ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator< ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator<= ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator== ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator> ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const real ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual int CAsiExactNum::operator>= ( const int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiExactNum Member List

This is the complete list of members for CAsiExactNum, including all inherited members.

CAsiData(void) | CAsiData |
CAsiExactNum() | CAsiExactNum | protected
CAsiNum() | CAsiNum | protected
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const | CAsiExactNum | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiNum | virtual
checkMul(const CAsiData *) const | CAsiNum | virtual
checkSet(const CAsiData *) const | CAsiData | virtual
checkSub(const CAsiData *) const | CAsiNum | virtual
Clear(void) | CAsiData | virtual
cmpeqlan(const CAsiNum *) const | CAsiExactNum | protected
cmpeqlen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpeqlenC(const real) const | CAsiExactNum | protected
cmpgtean(const CAsiNum *) const | CAsiExactNum | protected
cmpgteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgteenC(const real) const | CAsiExactNum | protected
cmpgtran(const CAsiNum *) const | CAsiExactNum | protected
cmpgtren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgtrenC(const real) const | CAsiExactNum | protected
cmpltean(const CAsiNum *) const | CAsiExactNum | protected
cmplteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmplteenC(const real) const | CAsiExactNum | protected
cmpltran(const CAsiNum *) const | CAsiExactNum | protected
cmpltren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpltrenC(const real) const | CAsiExactNum | protected
cmpneqan(const CAsiNum *) const | CAsiExactNum | protected
cmpneqen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpneqenC(const real) const | CAsiExactNum | protected
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const =0 | CAsiData | pure virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const | CAsiData | virtual
getValue(integer *) const | CAsiData | virtual
getValue(smallint *) const | CAsiData | virtual
getValue(char *, uint) const | CAsiData | virtual
getValue(CAsiUcStr *) const | CAsiData | virtual
getValue(char *, uint, uint *) const | CAsiData | virtual
getValue(AsiUcStr, uint) const | CAsiData | virtual
getValue(CAsiData &) const | CAsiData | virtual
getValue(DECIMAL *) const | CAsiData | virtual
getValue(DB_NUMERIC *) const | CAsiData | virtual
getValue(DBDATE *) const | CAsiData | virtual
getValue(DBTIME *) const | CAsiData | virtual
getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const | CAsiNum | virtual
is_approxnumeric(void) const | CAsiNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiExactNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const | CAsiData | virtual
isGreaterThan(const CAsiData &) const | CAsiData | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const | CAsiData | virtual
MapAsiToParamInfo(DBPARAMINFO *) const | CAsiData | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator!=(const CAsiInt &) const | CAsiExactNum | virtual
operator!=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator!=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator!=(const CAsiFloat &) const | CAsiExactNum | virtual
operator!=(const CAsiReal &) const | CAsiExactNum | virtual
operator!=(const CAsiDouble &) const | CAsiExactNum | virtual
operator!=(const smallint) const | CAsiExactNum | virtual
operator!=(const integer) const | CAsiExactNum | virtual
operator!=(const real) const | CAsiExactNum | virtual
operator!=(const int) const | CAsiExactNum | virtual
operator<(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<(const CAsiInt &) const | CAsiExactNum | virtual
operator<(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<(const CAsiFloat &) const | CAsiExactNum | virtual
operator<(const CAsiReal &) const | CAsiExactNum | virtual
operator<(const CAsiDouble &) const | CAsiExactNum | virtual
operator<(const smallint) const | CAsiExactNum | virtual
operator<(const integer) const | CAsiExactNum | virtual
operator<(const real) const | CAsiExactNum | virtual
operator<(const int) const | CAsiExactNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<=(const CAsiInt &) const | CAsiExactNum | virtual
operator<=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<=(const CAsiFloat &) const | CAsiExactNum | virtual
operator<=(const CAsiReal &) const | CAsiExactNum | virtual
operator<=(const CAsiDouble &) const | CAsiExactNum | virtual
operator<=(const smallint) const | CAsiExactNum | virtual
operator<=(const integer) const | CAsiExactNum | virtual
operator<=(const real) const | CAsiExactNum | virtual
operator<=(const int) const | CAsiExactNum | virtual
operator==(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator==(const CAsiInt &) const | CAsiExactNum | virtual
operator==(const CAsiNumeric &) const | CAsiExactNum | virtual
operator==(const CAsiDecimal &) const | CAsiExactNum | virtual
operator==(const CAsiFloat &) const | CAsiExactNum | virtual
operator==(const CAsiReal &) const | CAsiExactNum | virtual
operator==(const CAsiDouble &) const | CAsiExactNum | virtual
operator==(const smallint) const | CAsiExactNum | virtual
operator==(const integer) const | CAsiExactNum | virtual
operator==(const real) const | CAsiExactNum | virtual
operator==(const int) const | CAsiExactNum | virtual
operator>(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>(const CAsiInt &) const | CAsiExactNum | virtual
operator>(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>(const CAsiFloat &) const | CAsiExactNum | virtual
operator>(const CAsiReal &) const | CAsiExactNum | virtual
operator>(const CAsiDouble &) const | CAsiExactNum | virtual
operator>(const smallint) const | CAsiExactNum | virtual
operator>(const integer) const | CAsiExactNum | virtual
operator>(const real) const | CAsiExactNum | virtual
operator>(const int) const | CAsiExactNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>=(const CAsiInt &) const | CAsiExactNum | virtual
operator>=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>=(const CAsiFloat &) const | CAsiExactNum | virtual
operator>=(const CAsiReal &) const | CAsiExactNum | virtual
operator>=(const CAsiDouble &) const | CAsiExactNum | virtual
operator>=(const smallint) const | CAsiExactNum | virtual
operator>=(const integer) const | CAsiExactNum | virtual
operator>=(const real) const | CAsiExactNum | virtual
operator>=(const int) const | CAsiExactNum | virtual
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
Precision(void) const | CAsiNum | virtual
precision (defined in CAsiNum) | CAsiNum | protected
realValue(void) const | CAsiNum | virtual
ReturnLength(void) const | CAsiData | virtual
scale (defined in CAsiNum) | CAsiNum | protected
Scale(void) const | CAsiNum | virtual
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const =0 | CAsiData | pure virtual
SQLType(CAsiUcStr *) const =0 | CAsiData | pure virtual
storeValue(real) | CAsiData | virtual
storeValue(integer) | CAsiData | virtual
storeValue(smallint) | CAsiData | virtual
storeValue(char *, uint) | CAsiData | virtual
storeValue(const CAsiUcStr &) | CAsiData | virtual
storeValue(char *, uint, uint *) | CAsiData | virtual
storeValue(const CAsiData &) | CAsiData | virtual
storeValue(const AsiUcStr) | CAsiData | virtual
storeValue(const DECIMAL &) | CAsiData | virtual
storeValue(const DB_NUMERIC *) | CAsiData | virtual
storeValue(const DBDATE *) | CAsiData | virtual
storeValue(const DBTIME *) | CAsiData | virtual
storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const =0 | CAsiData | pure virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiExactNum() | CAsiExactNum | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiException Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiException Class Reference
Misc Classes
+ Inheritance diagram for CAsiException:

Public Member Functions

CAsiException (void)
int | CondQty (void) const
virtual CAsiObject * | duplicate (void) const
AsiError | Err (int d=0) const
CAsiUcStr * | ErrMsg (int d=0) const
int | ErrPosition (void) const
EAsiBoolean | flushCond (void)
void * | getDiagData (void) const
EAsiBoolean | getDiagPar (int, AsiDiag, integer *) const
EAsiBoolean | getDiagPar (int, AsiDiag, CAsiUcStr *) const
EAsiBoolean | pushCond (void)
EAsiBoolean | setDiagPar (AsiDiag, integer)
EAsiBoolean | setDiagPar (AsiDiag, const CAsiUcStr &)
EAsiBoolean | setErr (AsiError)
EAsiBoolean | setErrMsg (const CAsiUcStr &)
void | setErrPosition (int)
EAsiBoolean | setSQLSTATE (const char *)
char * | SQLSTATE (int d=0) const
virtual | ~CAsiException (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Friends

class CAsiSQLObject

Constructor & Destructor Documentation

CAsiException::CAsiException ( void )
Warning
Not implemented!
virtual CAsiException::~CAsiException ( void )
virtual
Warning
Not implemented!

Member Function Documentation

int CAsiException::CondQty ( void ) const
Warning
Not implemented!
virtual CAsiObject* CAsiException::duplicate ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

AsiError CAsiException::Err ( int d = 0 ) const
Warning
Not implemented!
CAsiUcStr* CAsiException::ErrMsg ( int d = 0 ) const
Warning
Not implemented!
int CAsiException::ErrPosition ( void ) const
Warning
Not implemented!
EAsiBoolean CAsiException::flushCond ( void )
Warning
Not implemented!
void* CAsiException::getDiagData ( void ) const
Warning
Not implemented!
EAsiBoolean CAsiException::getDiagPar | ( | int | ,
 |  | AsiDiag | ,
 |  | integer * |
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAsiException::getDiagPar | ( | int | ,
 |  | AsiDiag | ,
 |  | CAsiUcStr * |
 | ) |  | const
Warning
Not implemented!
EAsiBoolean CAsiException::pushCond ( void )
Warning
Not implemented!
EAsiBoolean CAsiException::setDiagPar | ( | AsiDiag | ,
 |  | integer |
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAsiException::setDiagPar | ( | AsiDiag | ,
 |  | const CAsiUcStr & |
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAsiException::setErr ( AsiError )
Warning
Not implemented!
EAsiBoolean CAsiException::setErrMsg ( const CAsiUcStr & )
Warning
Not implemented!
void CAsiException::setErrPosition ( int )
Warning
Not implemented!
EAsiBoolean CAsiException::setSQLSTATE ( const char * )
Warning
Not implemented!
char* CAsiException::SQLSTATE ( int d = 0 ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiException Member List

This is the complete list of members for CAsiException, including all inherited members.

CAsiException(void) | CAsiException |
CAsiObject(void) | CAsiObject |
CAsiSQLObject (defined in CAsiException) | CAsiException | friend
Clear(void) | CAsiObject | virtual
CondQty(void) const | CAsiException |
duplicate(void) const | CAsiException | virtual
Err(int d=0) const | CAsiException |
ErrMsg(int d=0) const | CAsiException |
ErrPosition(void) const | CAsiException |
flushCond(void) | CAsiException |
getDiagData(void) const | CAsiException |
getDiagPar(int, AsiDiag, integer *) const | CAsiException |
getDiagPar(int, AsiDiag, CAsiUcStr *) const | CAsiException |
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
pushCond(void) | CAsiException |
setDiagPar(AsiDiag, integer) | CAsiException |
setDiagPar(AsiDiag, const CAsiUcStr &) | CAsiException |
setErr(AsiError) | CAsiException |
setErrMsg(const CAsiUcStr &) | CAsiException |
setErrPosition(int) | CAsiException |
setSQLSTATE(const char *) | CAsiException |
SQLSTATE(int d=0) const | CAsiException |
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiException(void) | CAsiException | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiExceptionHandler Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
CAsiExceptionHandler Class Reference
Misc Classes

Public Member Functions

CAsiExceptionHandler (void)
~CAsiExceptionHandler (void)

Public Attributes

CAsiException * | pException
CAsiExceptionHandler * | pPrevHandler
EAsiBoolean | wasThrown

Constructor & Destructor Documentation

CAsiExceptionHandler::CAsiExceptionHandler ( void )
Warning
Not implemented!
CAsiExceptionHandler::~CAsiExceptionHandler ( void )
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiExceptionHandler Member List

This is the complete list of members for CAsiExceptionHandler, including all inherited members.

CAsiExceptionHandler(void) | CAsiExceptionHandler
pException (defined in CAsiExceptionHandler) | CAsiExceptionHandler
pPrevHandler (defined in CAsiExceptionHandler) | CAsiExceptionHandler
wasThrown (defined in CAsiExceptionHandler) | CAsiExceptionHandler
~CAsiExceptionHandler(void) | CAsiExceptionHandler


ZRX API Reference: CAsiExecStm Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAsiExecStm Class Reference
Misc Classes
+ Inheritance diagram for CAsiExecStm:

Public Member Functions

virtual EAsiBoolean | Bind (int, CAsiData *)
virtual EAsiBoolean | Bind (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Bind (const CAsiIdent &, CAsiData *)
virtual EAsiBoolean | Bind (const CAsiIdent &, void *, short *, int, EAsiHostType)
EAsiBoolean | Cancel (void)
CAsiExecStm (void)
virtual CAsiColumn * | ColDsc (int) const
virtual int | ColQty (void) const
virtual EAsiBoolean | Deallocate (void)
virtual EAsiBoolean | Execute (void)
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
virtual EAsiBoolean | ImmediateExecute (CAsiSession *, const CAsiUcStr &, EAsiBoolean trans=kAsiTrue)
virtual EAsiBoolean | IsRowset (void) const
virtual CAsiParameter * | ParamDsc (int) const
virtual int | ParamQty (void) const
virtual EAsiBoolean | Prepare (CAsiSession *, const CAsiUcStr &, EAsiBoolean trans=kAsiTrue)
virtual | ~CAsiExecStm (void)
- Public Member Functions inherited from CAsiStm
CAsiStm (void)
virtual EAsiBoolean | Cvl (int, CAsiData *)
virtual EAsiBoolean | Cvl (int, void *, short *, int, EAsiHostType)
void | SetSession (CAsiSession *)
virtual EAsiBoolean | Sob (int, CAsiData *)
virtual EAsiBoolean | Sob (int, void *, short *, int, EAsiHostType)
virtual | ~CAsiStm (void)
- Public Member Functions inherited from CAsiSQLObject
EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Attributes

ULONG | m_lParNumber
CAsiList * | m_pCsrs
ICommandText * | m_pICommand
DBPARAMINFO * | m_pParamInfo
OLECHAR * | m_pStringBuffParam
- Protected Attributes inherited from CAsiStm
ULONG_PTR | m_lColNumber
CAsiRow * | m_pAsiRow
DBCOLUMNINFO * | m_pColumnInfo
CAsiBinding * | m_pInput
CAsiBinding * | m_pOutput
CAsiSession * | m_pSession
OLECHAR * | m_pStringBuff
- Protected Attributes inherited from CAsiSQLObject
EAsiBoolean | m_CSP
EAsiStatement | m_eStmType
HRESULT | m_HResult
LONG_PTR | m_lRowCount
CAsiDSProperties * | m_pDSProperties
IErrorInfo * | m_pIErrorInfo

Friends

class | CAsiCsr
class | CAsiSession

Additional Inherited Members

- Protected Member Functions inherited from CAsiStm
EAsiBoolean | CvlInt (int, CAsiData *) const
EAsiBoolean | InitColsDsc ()
EAsiBoolean | pInput (void)

Constructor & Destructor Documentation

CAsiExecStm::CAsiExecStm ( void )
Warning
Not implemented!
virtual CAsiExecStm::~CAsiExecStm ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual EAsiBoolean CAsiExecStm::Bind | ( | int | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiBoolean CAsiExecStm::Bind | ( | int | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiBoolean CAsiExecStm::Bind | ( | const CAsiIdent & | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiBoolean CAsiExecStm::Bind | ( | const CAsiIdent & | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

EAsiBoolean CAsiExecStm::Cancel ( void )
Warning
Not implemented!
virtual CAsiColumn* CAsiExecStm::ColDsc ( int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual int CAsiExecStm::ColQty ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiBoolean CAsiExecStm::Deallocate ( void )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiExecStm::Execute ( void )
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiExecStm::GetStatus | ( | EAsiStatInfo | ,
 |  | ULONG_PTR * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiSQLObject.

virtual EAsiBoolean CAsiExecStm::ImmediateExecute | ( | CAsiSession * | ,
 |  | const CAsiUcStr & | ,
 |  | EAsiBoolean | trans = kAsiTrue
 | ) |  |
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiExecStm::IsRowset ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiSQLObject.

virtual CAsiParameter* CAsiExecStm::ParamDsc ( int ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual int CAsiExecStm::ParamQty ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiStm.

virtual EAsiBoolean CAsiExecStm::Prepare | ( | CAsiSession * | ,
 |  | const CAsiUcStr & | ,
 |  | EAsiBoolean | trans = kAsiTrue
 | ) |  |
virtual
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiExecStm Member List

This is the complete list of members for CAsiExecStm, including all inherited members.

Bind(int, CAsiData *) | CAsiExecStm | virtual
Bind(int, void *, short *, int, EAsiHostType) | CAsiExecStm | virtual
Bind(const CAsiIdent &, CAsiData *) | CAsiExecStm | virtual
Bind(const CAsiIdent &, void *, short *, int, EAsiHostType) | CAsiExecStm | virtual
Cancel(void) | CAsiExecStm |
CAsiCsr (defined in CAsiExecStm) | CAsiExecStm | friend
CAsiExecStm(void) | CAsiExecStm |
CAsiObject(void) | CAsiObject |
CAsiSession (defined in CAsiExecStm) | CAsiExecStm | friend
CAsiSQLObject() | CAsiSQLObject | protected
CAsiStm(void) | CAsiStm |
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
ColDsc(int) const | CAsiExecStm | virtual
ColQty(void) const | CAsiExecStm | virtual
CondQty(void) const | CAsiSQLObject | virtual
Cvl(int, CAsiData *) | CAsiStm | virtual
Cvl(int, void *, short *, int, EAsiHostType) | CAsiStm | virtual
CvlInt(int, CAsiData *) const | CAsiStm | protected
DBMS(CAsiUcStr *) const | CAsiSQLObject |
Deallocate(void) | CAsiExecStm | virtual
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
Execute(void) | CAsiExecStm | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiExecStm | virtual
ImmediateExecute(CAsiSession *, const CAsiUcStr &, EAsiBoolean trans=kAsiTrue) | CAsiExecStm | virtual
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
InitColsDsc() | CAsiStm | protected
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiExecStm | virtual
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_lColNumber (defined in CAsiStm) | CAsiStm | protected
m_lParNumber (defined in CAsiExecStm) | CAsiExecStm | protected
m_lRowCount (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pAsiRow (defined in CAsiStm) | CAsiStm | protected
m_pColumnInfo (defined in CAsiStm) | CAsiStm | protected
m_pCsrs (defined in CAsiExecStm) | CAsiExecStm | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pICommand (defined in CAsiExecStm) | CAsiExecStm | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pInput (defined in CAsiStm) | CAsiStm | protected
m_pOutput (defined in CAsiStm) | CAsiStm | protected
m_pParamInfo (defined in CAsiExecStm) | CAsiExecStm | protected
m_pSession (defined in CAsiStm) | CAsiStm | protected
m_pStringBuff (defined in CAsiStm) | CAsiStm | protected
m_pStringBuffParam (defined in CAsiExecStm) | CAsiExecStm | protected
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
ParamDsc(int) const | CAsiExecStm | virtual
ParamQty(void) const | CAsiExecStm | virtual
pInput(void) | CAsiStm | protected
Prepare(CAsiSession *, const CAsiUcStr &, EAsiBoolean trans=kAsiTrue) | CAsiExecStm | virtual
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
ReleaseErrorInfo() | CAsiSQLObject | protected
RowCount(void) const | CAsiSQLObject |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
SetSession(CAsiSession *) | CAsiStm |
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
Sob(int, CAsiData *) | CAsiStm | virtual
Sob(int, void *, short *, int, EAsiHostType) | CAsiStm | virtual
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Version(void) const | CAsiSQLObject |
~CAsiExecStm(void) | CAsiExecStm | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual
~CAsiStm(void) | CAsiStm | virtual


ZRX API Reference: CAsiFloat Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiFloat Class Reference
Misc Classes
+ Inheritance diagram for CAsiFloat:

Public Member Functions

CAsiFloat (uint)
CAsiFloat (const CAsiFloat &)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual CAsiObject * | duplicate (void) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual integer | intValue (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
CAsiFloat | operator* (const CAsiSmallInt &) const
CAsiFloat | operator* (const CAsiInt &) const
CAsiFloat | operator* (const CAsiNumeric &) const
CAsiFloat | operator* (const CAsiDecimal &) const
CAsiFloat | operator* (const CAsiFloat &) const
CAsiFloat | operator* (const smallint) const
CAsiFloat | operator* (const integer) const
CAsiFloat | operator* (const real) const
CAsiFloat | operator* (const int) const
CAsiFloat & | operator*= (const CAsiSmallInt &)
CAsiFloat & | operator*= (const CAsiInt &)
CAsiFloat & | operator*= (const CAsiNumeric &)
CAsiFloat & | operator*= (const CAsiDecimal &)
CAsiFloat & | operator*= (const CAsiFloat &)
CAsiFloat & | operator*= (const CAsiReal &)
CAsiFloat & | operator*= (const CAsiDouble &)
CAsiFloat & | operator*= (const smallint)
CAsiFloat & | operator*= (const integer)
CAsiFloat & | operator*= (const real)
CAsiFloat & | operator*= (const int)
CAsiFloat | operator+ (const CAsiSmallInt &) const
CAsiFloat | operator+ (const CAsiInt &) const
CAsiFloat | operator+ (const CAsiNumeric &) const
CAsiFloat | operator+ (const CAsiDecimal &) const
CAsiFloat | operator+ (const CAsiFloat &) const
CAsiFloat | operator+ (const smallint) const
CAsiFloat | operator+ (const integer) const
CAsiFloat | operator+ (const real) const
CAsiFloat | operator+ (const int) const
CAsiFloat & | operator++ (void)
CAsiFloat & | operator+= (const CAsiSmallInt &)
CAsiFloat & | operator+= (const CAsiInt &)
CAsiFloat & | operator+= (const CAsiNumeric &)
CAsiFloat & | operator+= (const CAsiDecimal &)
CAsiFloat & | operator+= (const CAsiFloat &)
CAsiFloat & | operator+= (const CAsiReal &)
CAsiFloat & | operator+= (const CAsiDouble &)
CAsiFloat & | operator+= (const smallint)
CAsiFloat & | operator+= (const integer)
CAsiFloat & | operator+= (const real)
CAsiFloat & | operator+= (const int)
CAsiFloat | operator- (const CAsiSmallInt &) const
CAsiFloat | operator- (const CAsiInt &) const
CAsiFloat | operator- (const CAsiNumeric &) const
CAsiFloat | operator- (const CAsiDecimal &) const
CAsiFloat | operator- (const CAsiFloat &) const
CAsiFloat | operator- (const smallint) const
CAsiFloat | operator- (const integer) const
CAsiFloat | operator- (const real) const
CAsiFloat | operator- (const int) const
CAsiFloat & | operator- (void)
CAsiFloat & | operator-- (void)
CAsiFloat & | operator-= (const CAsiSmallInt &)
CAsiFloat & | operator-= (const CAsiInt &)
CAsiFloat & | operator-= (const CAsiNumeric &)
CAsiFloat & | operator-= (const CAsiDecimal &)
CAsiFloat & | operator-= (const CAsiFloat &)
CAsiFloat & | operator-= (const CAsiReal &)
CAsiFloat & | operator-= (const CAsiDouble &)
CAsiFloat & | operator-= (const smallint)
CAsiFloat & | operator-= (const integer)
CAsiFloat & | operator-= (const real)
CAsiFloat & | operator-= (const int)
CAsiFloat | operator/ (const CAsiSmallInt &) const
CAsiFloat | operator/ (const CAsiInt &) const
CAsiFloat | operator/ (const CAsiNumeric &) const
CAsiFloat | operator/ (const CAsiDecimal &) const
CAsiFloat | operator/ (const CAsiFloat &) const
CAsiFloat | operator/ (const smallint) const
CAsiFloat | operator/ (const integer) const
CAsiFloat | operator/ (const real) const
CAsiFloat | operator/ (const int) const
CAsiFloat & | operator/= (const CAsiSmallInt &)
CAsiFloat & | operator/= (const CAsiInt &)
CAsiFloat & | operator/= (const CAsiNumeric &)
CAsiFloat & | operator/= (const CAsiDecimal &)
CAsiFloat & | operator/= (const CAsiFloat &)
CAsiFloat & | operator/= (const CAsiReal &)
CAsiFloat & | operator/= (const CAsiDouble &)
CAsiFloat & | operator/= (const smallint)
CAsiFloat & | operator/= (const integer)
CAsiFloat & | operator/= (const real)
CAsiFloat & | operator/= (const int)
CAsiFloat & | operator= (const CAsiSmallInt &)
CAsiFloat & | operator= (const CAsiInt &)
CAsiFloat & | operator= (const CAsiNumeric &)
CAsiFloat & | operator= (const CAsiDecimal &)
CAsiFloat & | operator= (const CAsiFloat &)
CAsiFloat & | operator= (const CAsiReal &)
CAsiFloat & | operator= (const CAsiDouble &)
CAsiFloat & | operator= (const smallint)
CAsiFloat & | operator= (const integer)
CAsiFloat & | operator= (const real)
CAsiFloat & | operator= (const int)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual real | realValue (void) const
virtual uint | ReturnLength (void) const
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiDataType | Type (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiApproxNum
virtual EAsiBoolean | is_approxnumeric (void) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual | ~CAsiApproxNum ()
- Public Member Functions inherited from CAsiNum
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

CAsiFloat DLLScope | operator* (const CAsiSmallInt &, const CAsiFloat &)
CAsiFloat DLLScope | operator* (const CAsiInt &, const CAsiFloat &)
CAsiFloat DLLScope | operator* (const CAsiNumeric &, const CAsiFloat &)
CAsiFloat DLLScope | operator* (const CAsiDecimal &, const CAsiFloat &)
CAsiFloat DLLScope | operator* (const smallint, const CAsiFloat &)
CAsiFloat DLLScope | operator* (const integer, const CAsiFloat &)
CAsiFloat DLLScope | operator* (const real, const CAsiFloat &)
CAsiFloat DLLScope | operator* (const int, const CAsiFloat &)
CAsiFloat DLLScope | operator+ (const CAsiSmallInt &, const CAsiFloat &)
CAsiFloat DLLScope | operator+ (const CAsiInt &, const CAsiFloat &)
CAsiFloat DLLScope | operator+ (const CAsiNumeric &, const CAsiFloat &)
CAsiFloat DLLScope | operator+ (const CAsiDecimal &, const CAsiFloat &)
CAsiFloat DLLScope | operator+ (const smallint, const CAsiFloat &)
CAsiFloat DLLScope | operator+ (const integer, const CAsiFloat &)
CAsiFloat DLLScope | operator+ (const real, const CAsiFloat &)
CAsiFloat DLLScope | operator+ (const int, const CAsiFloat &)
CAsiFloat DLLScope | operator- (const CAsiSmallInt &, const CAsiFloat &)
CAsiFloat DLLScope | operator- (const CAsiInt &, const CAsiFloat &)
CAsiFloat DLLScope | operator- (const CAsiNumeric &, const CAsiFloat &)
CAsiFloat DLLScope | operator- (const CAsiDecimal &, const CAsiFloat &)
CAsiFloat DLLScope | operator- (const smallint, const CAsiFloat &)
CAsiFloat DLLScope | operator- (const integer, const CAsiFloat &)
CAsiFloat DLLScope | operator- (const real, const CAsiFloat &)
CAsiFloat DLLScope | operator- (const int, const CAsiFloat &)
CAsiFloat DLLScope | operator/ (const CAsiSmallInt &, const CAsiFloat &)
CAsiFloat DLLScope | operator/ (const CAsiInt &, const CAsiFloat &)
CAsiFloat DLLScope | operator/ (const CAsiNumeric &, const CAsiFloat &)
CAsiFloat DLLScope | operator/ (const CAsiDecimal &, const CAsiFloat &)
CAsiFloat DLLScope | operator/ (const smallint, const CAsiFloat &)
CAsiFloat DLLScope | operator/ (const integer, const CAsiFloat &)
CAsiFloat DLLScope | operator/ (const real, const CAsiFloat &)
CAsiFloat DLLScope | operator/ (const int, const CAsiFloat &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Member Functions inherited from CAsiNum
CAsiNum ()
- Protected Attributes inherited from CAsiNum
uint | precision
uint | scale
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiFloat Member List

This is the complete list of members for CAsiFloat, including all inherited members.

CAsiApproxNum() (defined in CAsiApproxNum) | CAsiApproxNum | protected
CAsiData(void) | CAsiData |
CAsiFloat(void) (defined in CAsiFloat) | CAsiFloat |
CAsiFloat(uint) (defined in CAsiFloat) | CAsiFloat |
CAsiFloat(const CAsiFloat &) (defined in CAsiFloat) | CAsiFloat |
CAsiNum() | CAsiNum | protected
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const (defined in CAsiFloat) | CAsiFloat | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const (defined in CAsiFloat) | CAsiFloat | virtual
checkMul(const CAsiData *) const (defined in CAsiFloat) | CAsiFloat | virtual
checkSet(const CAsiData *) const (defined in CAsiFloat) | CAsiFloat | virtual
checkSub(const CAsiData *) const (defined in CAsiFloat) | CAsiFloat | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiFloat) | CAsiFloat | virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const (defined in CAsiFloat) | CAsiFloat | virtual
getValue(integer *) const (defined in CAsiFloat) | CAsiFloat | virtual
getValue(smallint *) const (defined in CAsiFloat) | CAsiFloat | virtual
getValue(char *, uint) const (defined in CAsiFloat) | CAsiFloat | virtual
getValue(CAsiUcStr *) const (defined in CAsiFloat) | CAsiFloat | virtual
getValue(char *, uint, uint *) const (defined in CAsiFloat) | CAsiFloat | virtual
getValue(AsiUcStr, uint) const (defined in CAsiFloat) | CAsiFloat | virtual
getValue(CAsiData &) const (defined in CAsiFloat) | CAsiFloat | virtual
CAsiApproxNum::getValue(DECIMAL *) const | CAsiData | virtual
CAsiApproxNum::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiApproxNum::getValue(DBDATE *) const | CAsiData | virtual
CAsiApproxNum::getValue(DBTIME *) const | CAsiData | virtual
CAsiApproxNum::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const (defined in CAsiFloat) | CAsiFloat | virtual
is_approxnumeric(void) const | CAsiApproxNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiFloat) | CAsiFloat | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiFloat) | CAsiFloat | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiFloat) | CAsiFloat | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiFloat) | CAsiFloat | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator!=(const CAsiInt &) const | CAsiApproxNum | virtual
operator!=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator!=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator!=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator!=(const CAsiReal &) const | CAsiApproxNum | virtual
operator!=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator!=(const smallint) const | CAsiApproxNum | virtual
operator!=(const integer) const | CAsiApproxNum | virtual
operator!=(const real) const | CAsiApproxNum | virtual
operator!=(const int) const | CAsiApproxNum | virtual
operator*(const CAsiSmallInt &) const (defined in CAsiFloat) | CAsiFloat |
operator*(const CAsiInt &) const (defined in CAsiFloat) | CAsiFloat |
operator*(const CAsiNumeric &) const (defined in CAsiFloat) | CAsiFloat |
operator*(const CAsiDecimal &) const (defined in CAsiFloat) | CAsiFloat |
operator*(const CAsiFloat &) const (defined in CAsiFloat) | CAsiFloat |
operator* (defined in CAsiFloat) | CAsiFloat | friend
operator* (defined in CAsiFloat) | CAsiFloat | friend
operator* (defined in CAsiFloat) | CAsiFloat | friend
operator* (defined in CAsiFloat) | CAsiFloat | friend
operator*(const smallint) const (defined in CAsiFloat) | CAsiFloat |
operator*(const integer) const (defined in CAsiFloat) | CAsiFloat |
operator*(const real) const (defined in CAsiFloat) | CAsiFloat |
operator* (defined in CAsiFloat) | CAsiFloat | friend
operator* (defined in CAsiFloat) | CAsiFloat | friend
operator* (defined in CAsiFloat) | CAsiFloat | friend
operator*(const int) const (defined in CAsiFloat) | CAsiFloat |
operator* (defined in CAsiFloat) | CAsiFloat | friend
operator*=(const CAsiSmallInt &) (defined in CAsiFloat) | CAsiFloat |
operator*=(const CAsiInt &) (defined in CAsiFloat) | CAsiFloat |
operator*=(const CAsiNumeric &) (defined in CAsiFloat) | CAsiFloat |
operator*=(const CAsiDecimal &) (defined in CAsiFloat) | CAsiFloat |
operator*=(const CAsiFloat &) (defined in CAsiFloat) | CAsiFloat |
operator*=(const CAsiReal &) (defined in CAsiFloat) | CAsiFloat |
operator*=(const CAsiDouble &) (defined in CAsiFloat) | CAsiFloat |
operator*=(const smallint) (defined in CAsiFloat) | CAsiFloat |
operator*=(const integer) (defined in CAsiFloat) | CAsiFloat |
operator*=(const real) (defined in CAsiFloat) | CAsiFloat |
operator*=(const int) (defined in CAsiFloat) | CAsiFloat |
operator+(const CAsiSmallInt &) const (defined in CAsiFloat) | CAsiFloat |
operator+(const CAsiInt &) const (defined in CAsiFloat) | CAsiFloat |
operator+(const CAsiNumeric &) const (defined in CAsiFloat) | CAsiFloat |
operator+(const CAsiDecimal &) const (defined in CAsiFloat) | CAsiFloat |
operator+(const CAsiFloat &) const (defined in CAsiFloat) | CAsiFloat |
operator+ (defined in CAsiFloat) | CAsiFloat | friend
operator+ (defined in CAsiFloat) | CAsiFloat | friend
operator+ (defined in CAsiFloat) | CAsiFloat | friend
operator+ (defined in CAsiFloat) | CAsiFloat | friend
operator+(const smallint) const (defined in CAsiFloat) | CAsiFloat |
operator+(const integer) const (defined in CAsiFloat) | CAsiFloat |
operator+(const real) const (defined in CAsiFloat) | CAsiFloat |
operator+ (defined in CAsiFloat) | CAsiFloat | friend
operator+ (defined in CAsiFloat) | CAsiFloat | friend
operator+ (defined in CAsiFloat) | CAsiFloat | friend
operator+(const int) const (defined in CAsiFloat) | CAsiFloat |
operator+ (defined in CAsiFloat) | CAsiFloat | friend
operator++(void) (defined in CAsiFloat) | CAsiFloat |
operator+=(const CAsiSmallInt &) (defined in CAsiFloat) | CAsiFloat |
operator+=(const CAsiInt &) (defined in CAsiFloat) | CAsiFloat |
operator+=(const CAsiNumeric &) (defined in CAsiFloat) | CAsiFloat |
operator+=(const CAsiDecimal &) (defined in CAsiFloat) | CAsiFloat |
operator+=(const CAsiFloat &) (defined in CAsiFloat) | CAsiFloat |
operator+=(const CAsiReal &) (defined in CAsiFloat) | CAsiFloat |
operator+=(const CAsiDouble &) (defined in CAsiFloat) | CAsiFloat |
operator+=(const smallint) (defined in CAsiFloat) | CAsiFloat |
operator+=(const integer) (defined in CAsiFloat) | CAsiFloat |
operator+=(const real) (defined in CAsiFloat) | CAsiFloat |
operator+=(const int) (defined in CAsiFloat) | CAsiFloat |
operator-(const CAsiSmallInt &) const (defined in CAsiFloat) | CAsiFloat |
operator-(const CAsiInt &) const (defined in CAsiFloat) | CAsiFloat |
operator-(const CAsiNumeric &) const (defined in CAsiFloat) | CAsiFloat |
operator-(const CAsiDecimal &) const (defined in CAsiFloat) | CAsiFloat |
operator-(const CAsiFloat &) const (defined in CAsiFloat) | CAsiFloat |
operator- (defined in CAsiFloat) | CAsiFloat | friend
operator- (defined in CAsiFloat) | CAsiFloat | friend
operator- (defined in CAsiFloat) | CAsiFloat | friend
operator- (defined in CAsiFloat) | CAsiFloat | friend
operator-(const smallint) const (defined in CAsiFloat) | CAsiFloat |
operator-(const integer) const (defined in CAsiFloat) | CAsiFloat |
operator-(const real) const (defined in CAsiFloat) | CAsiFloat |
operator- (defined in CAsiFloat) | CAsiFloat | friend
operator- (defined in CAsiFloat) | CAsiFloat | friend
operator- (defined in CAsiFloat) | CAsiFloat | friend
operator-(const int) const (defined in CAsiFloat) | CAsiFloat |
operator- (defined in CAsiFloat) | CAsiFloat | friend
operator-(void) (defined in CAsiFloat) | CAsiFloat |
operator--(void) (defined in CAsiFloat) | CAsiFloat |
operator-=(const CAsiSmallInt &) (defined in CAsiFloat) | CAsiFloat |
operator-=(const CAsiInt &) (defined in CAsiFloat) | CAsiFloat |
operator-=(const CAsiNumeric &) (defined in CAsiFloat) | CAsiFloat |
operator-=(const CAsiDecimal &) (defined in CAsiFloat) | CAsiFloat |
operator-=(const CAsiFloat &) (defined in CAsiFloat) | CAsiFloat |
operator-=(const CAsiReal &) (defined in CAsiFloat) | CAsiFloat |
operator-=(const CAsiDouble &) (defined in CAsiFloat) | CAsiFloat |
operator-=(const smallint) (defined in CAsiFloat) | CAsiFloat |
operator-=(const integer) (defined in CAsiFloat) | CAsiFloat |
operator-=(const real) (defined in CAsiFloat) | CAsiFloat |
operator-=(const int) (defined in CAsiFloat) | CAsiFloat |
operator/(const CAsiSmallInt &) const (defined in CAsiFloat) | CAsiFloat |
operator/(const CAsiInt &) const (defined in CAsiFloat) | CAsiFloat |
operator/(const CAsiNumeric &) const (defined in CAsiFloat) | CAsiFloat |
operator/(const CAsiDecimal &) const (defined in CAsiFloat) | CAsiFloat |
operator/(const CAsiFloat &) const (defined in CAsiFloat) | CAsiFloat |
operator/ (defined in CAsiFloat) | CAsiFloat | friend
operator/ (defined in CAsiFloat) | CAsiFloat | friend
operator/ (defined in CAsiFloat) | CAsiFloat | friend
operator/ (defined in CAsiFloat) | CAsiFloat | friend
operator/(const smallint) const (defined in CAsiFloat) | CAsiFloat |
operator/(const integer) const (defined in CAsiFloat) | CAsiFloat |
operator/(const real) const (defined in CAsiFloat) | CAsiFloat |
operator/ (defined in CAsiFloat) | CAsiFloat | friend
operator/ (defined in CAsiFloat) | CAsiFloat | friend
operator/ (defined in CAsiFloat) | CAsiFloat | friend
operator/(const int) const (defined in CAsiFloat) | CAsiFloat |
operator/ (defined in CAsiFloat) | CAsiFloat | friend
operator/=(const CAsiSmallInt &) (defined in CAsiFloat) | CAsiFloat |
operator/=(const CAsiInt &) (defined in CAsiFloat) | CAsiFloat |
operator/=(const CAsiNumeric &) (defined in CAsiFloat) | CAsiFloat |
operator/=(const CAsiDecimal &) (defined in CAsiFloat) | CAsiFloat |
operator/=(const CAsiFloat &) (defined in CAsiFloat) | CAsiFloat |
operator/=(const CAsiReal &) (defined in CAsiFloat) | CAsiFloat |
operator/=(const CAsiDouble &) (defined in CAsiFloat) | CAsiFloat |
operator/=(const smallint) (defined in CAsiFloat) | CAsiFloat |
operator/=(const integer) (defined in CAsiFloat) | CAsiFloat |
operator/=(const real) (defined in CAsiFloat) | CAsiFloat |
operator/=(const int) (defined in CAsiFloat) | CAsiFloat |
operator<(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator<(const CAsiInt &) const | CAsiApproxNum | virtual
operator<(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator<(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator<(const CAsiFloat &) const | CAsiApproxNum | virtual
operator<(const CAsiReal &) const | CAsiApproxNum | virtual
operator<(const CAsiDouble &) const | CAsiApproxNum | virtual
operator<(const smallint) const | CAsiApproxNum | virtual
operator<(const integer) const | CAsiApproxNum | virtual
operator<(const real) const | CAsiApproxNum | virtual
operator<(const int) const | CAsiApproxNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator<=(const CAsiInt &) const | CAsiApproxNum | virtual
operator<=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator<=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator<=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator<=(const CAsiReal &) const | CAsiApproxNum | virtual
operator<=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator<=(const smallint) const | CAsiApproxNum | virtual
operator<=(const integer) const | CAsiApproxNum | virtual
operator<=(const real) const | CAsiApproxNum | virtual
operator<=(const int) const | CAsiApproxNum | virtual
operator=(const CAsiSmallInt &) (defined in CAsiFloat) | CAsiFloat |
operator=(const CAsiInt &) (defined in CAsiFloat) | CAsiFloat |
operator=(const CAsiNumeric &) (defined in CAsiFloat) | CAsiFloat |
operator=(const CAsiDecimal &) (defined in CAsiFloat) | CAsiFloat |
operator=(const CAsiFloat &) (defined in CAsiFloat) | CAsiFloat |
operator=(const CAsiReal &) (defined in CAsiFloat) | CAsiFloat |
operator=(const CAsiDouble &) (defined in CAsiFloat) | CAsiFloat |
operator=(const smallint) (defined in CAsiFloat) | CAsiFloat |
operator=(const integer) (defined in CAsiFloat) | CAsiFloat |
operator=(const real) (defined in CAsiFloat) | CAsiFloat |
operator=(const int) (defined in CAsiFloat) | CAsiFloat |
operator==(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator==(const CAsiInt &) const | CAsiApproxNum | virtual
operator==(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator==(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator==(const CAsiFloat &) const | CAsiApproxNum | virtual
operator==(const CAsiReal &) const | CAsiApproxNum | virtual
operator==(const CAsiDouble &) const | CAsiApproxNum | virtual
operator==(const smallint) const | CAsiApproxNum | virtual
operator==(const integer) const | CAsiApproxNum | virtual
operator==(const real) const | CAsiApproxNum | virtual
operator==(const int) const | CAsiApproxNum | virtual
operator>(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator>(const CAsiInt &) const | CAsiApproxNum | virtual
operator>(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator>(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator>(const CAsiFloat &) const | CAsiApproxNum | virtual
operator>(const CAsiReal &) const | CAsiApproxNum | virtual
operator>(const CAsiDouble &) const | CAsiApproxNum | virtual
operator>(const smallint) const | CAsiApproxNum | virtual
operator>(const integer) const | CAsiApproxNum | virtual
operator>(const real) const | CAsiApproxNum | virtual
operator>(const int) const | CAsiApproxNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator>=(const CAsiInt &) const | CAsiApproxNum | virtual
operator>=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator>=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator>=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator>=(const CAsiReal &) const | CAsiApproxNum | virtual
operator>=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator>=(const smallint) const | CAsiApproxNum | virtual
operator>=(const integer) const | CAsiApproxNum | virtual
operator>=(const real) const | CAsiApproxNum | virtual
operator>=(const int) const | CAsiApproxNum | virtual
packSize(void) const (defined in CAsiFloat) | CAsiFloat | virtual
packTo(CAsiObjPack *) const (defined in CAsiFloat) | CAsiFloat | virtual
packValueSize(void) const (defined in CAsiFloat) | CAsiFloat | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiFloat) | CAsiFloat | virtual
precision (defined in CAsiNum) | CAsiNum | protected
Precision(void) const | CAsiNum | virtual
realValue(void) const (defined in CAsiFloat) | CAsiFloat | virtual
ReturnLength(void) const (defined in CAsiFloat) | CAsiFloat | virtual
scale (defined in CAsiNum) | CAsiNum | protected
Scale(void) const | CAsiNum | virtual
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const (defined in CAsiFloat) | CAsiFloat | virtual
SQLType(CAsiUcStr *) const (defined in CAsiFloat) | CAsiFloat | virtual
storeValue(real) (defined in CAsiFloat) | CAsiFloat | virtual
storeValue(integer) (defined in CAsiFloat) | CAsiFloat | virtual
storeValue(smallint) (defined in CAsiFloat) | CAsiFloat | virtual
storeValue(char *, uint) (defined in CAsiFloat) | CAsiFloat | virtual
storeValue(const CAsiUcStr &) (defined in CAsiFloat) | CAsiFloat | virtual
storeValue(const CAsiData &) (defined in CAsiFloat) | CAsiFloat | virtual
storeValue(char *, uint, uint *) (defined in CAsiFloat) | CAsiFloat | virtual
storeValue(const AsiUcStr) (defined in CAsiFloat) | CAsiFloat | virtual
CAsiApproxNum::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiApproxNum::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiApproxNum::storeValue(const DBDATE *) | CAsiData | virtual
CAsiApproxNum::storeValue(const DBTIME *) | CAsiData | virtual
CAsiApproxNum::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiFloat) | CAsiFloat | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiFloat) | CAsiFloat | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiFloat) | CAsiFloat | virtual
~CAsiApproxNum() | CAsiApproxNum | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiFloat(void) (defined in CAsiFloat) | CAsiFloat | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiHostBuffer Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAsiHostBuffer Class Reference
Misc Classes
+ Inheritance diagram for CAsiHostBuffer:

Public Member Functions

virtual EAsiBoolean | getBind (CAsiData **) const
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

virtual EAsiBoolean setBind (CAsiData *)

Protected Attributes

CAsiData * pData

Friends

class | CAsiCsr
class | CAsiStm
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiHostBuffer Member List

This is the complete list of members for CAsiHostBuffer, including all inherited members.

CAsiCsr (defined in CAsiHostBuffer) | CAsiHostBuffer | friend
CAsiHostBuffer() (defined in CAsiHostBuffer) | CAsiHostBuffer |
CAsiObject(void) | CAsiObject |
CAsiStm (defined in CAsiHostBuffer) | CAsiHostBuffer | friend
Clear(void) | CAsiObject | virtual
duplicate(void) const | CAsiObject | virtual
getBind(CAsiData **) const (defined in CAsiHostBuffer) | CAsiHostBuffer | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
pData (defined in CAsiHostBuffer) | CAsiHostBuffer | protected
setBind(CAsiData *) (defined in CAsiHostBuffer) | CAsiHostBuffer | protectedvirtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiHostBuffer() (defined in CAsiHostBuffer) | CAsiHostBuffer | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiIdent Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAsiIdent Class Reference
Misc Classes
+ Inheritance diagram for CAsiIdent:

Public Member Functions

const CAsiUcStr & | Body (void) const
CAsiIdent (void)
CAsiIdent (const char *)
CAsiIdent (const AsiUcStr)
CAsiIdent (const CAsiUcStr &)
CAsiIdent (const CAsiUcStr &, const CAsiUcStr &)
CAsiIdent (const CAsiIdent &)
const CAsiUcStr & | CharSet (void) const
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
EAsiBoolean | isDelimited (void) const
int | Length (void) const
CAsiIdent & | operator= (const CAsiIdent &)
CAsiIdent & | operator= (const CAsiUcStr &)
int | operator== (const CAsiIdent &) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
void | set (EAsiBoolean, const CAsiUcStr &, const CAsiUcStr &)
void | setBody (const CAsiUcStr &, EAsiBoolean fParse=kAsiTrue)
void | setCharSet (const CAsiUcStr &)
void | setDelimited (EAsiBoolean)
void | setDelimited (void)
void | ToString (CAsiUcStr *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual | ~CAsiIdent (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Constructor & Destructor Documentation

CAsiIdent::CAsiIdent ( void )
Warning
Not implemented!
CAsiIdent::CAsiIdent ( const char * )
Warning
Not implemented!
CAsiIdent::CAsiIdent ( const AsiUcStr )
Warning
Not implemented!
CAsiIdent::CAsiIdent ( const CAsiUcStr & )
Warning
Not implemented!
CAsiIdent::CAsiIdent | ( | const CAsiUcStr & | ,
 |  | const CAsiUcStr & |
 | ) |  |
Warning
Not implemented!
CAsiIdent::CAsiIdent ( const CAsiIdent & )
Warning
Not implemented!
virtual CAsiIdent::~CAsiIdent ( void )
virtual
Warning
Not implemented!

Member Function Documentation

const CAsiUcStr& CAsiIdent::Body ( void ) const
Warning
Not implemented!
const CAsiUcStr& CAsiIdent::CharSet ( void ) const
Warning
Not implemented!
virtual void CAsiIdent::Clear ( void )
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

virtual CAsiObject* CAsiIdent::duplicate ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

EAsiBoolean CAsiIdent::isDelimited ( void ) const
Warning
Not implemented!
int CAsiIdent::Length ( void ) const
Warning
Not implemented!
CAsiIdent& CAsiIdent::operator= ( const CAsiIdent & )
Warning
Not implemented!
CAsiIdent& CAsiIdent::operator= ( const CAsiUcStr & )
Warning
Not implemented!
int CAsiIdent::operator== ( const CAsiIdent & ) const
Warning
Not implemented!
virtual unsigned long CAsiIdent::packSize ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

virtual unsigned long CAsiIdent::packTo ( CAsiObjPack * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

void CAsiIdent::set | ( | EAsiBoolean | ,
 |  | const CAsiUcStr & | ,
 |  | const CAsiUcStr & |
 | ) |  |
Warning
Not implemented!
void CAsiIdent::setBody | ( | const CAsiUcStr & | ,
 |  | EAsiBoolean | fParse = kAsiTrue
 | ) |  |
Warning
Not implemented!
void CAsiIdent::setCharSet ( const CAsiUcStr & )
Warning
Not implemented!
void CAsiIdent::setDelimited ( EAsiBoolean )
Warning
Not implemented!
void CAsiIdent::setDelimited ( void )
Warning
Not implemented!
void CAsiIdent::ToString ( CAsiUcStr * ) const
Warning
Not implemented!
virtual EAsiBoolean CAsiIdent::unpackFrom ( CAsiObjPack * )
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiIdent Member List

This is the complete list of members for CAsiIdent, including all inherited members.

Body(void) const | CAsiIdent |
CAsiIdent(void) | CAsiIdent |
CAsiIdent(const char *) | CAsiIdent |
CAsiIdent(const AsiUcStr) | CAsiIdent |
CAsiIdent(const CAsiUcStr &) | CAsiIdent |
CAsiIdent(const CAsiUcStr &, const CAsiUcStr &) | CAsiIdent |
CAsiIdent(const CAsiIdent &) | CAsiIdent |
CAsiObject(void) | CAsiObject |
CharSet(void) const | CAsiIdent |
Clear(void) | CAsiIdent | virtual
duplicate(void) const | CAsiIdent | virtual
isDelimited(void) const | CAsiIdent |
Length(void) const | CAsiIdent |
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator=(const CAsiIdent &) | CAsiIdent |
operator=(const CAsiUcStr &) | CAsiIdent |
operator==(const CAsiIdent &) const | CAsiIdent |
packSize(void) const | CAsiIdent | virtual
packTo(CAsiObjPack *) const | CAsiIdent | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
set(EAsiBoolean, const CAsiUcStr &, const CAsiUcStr &) | CAsiIdent |
setBody(const CAsiUcStr &, EAsiBoolean fParse=kAsiTrue) | CAsiIdent |
setCharSet(const CAsiUcStr &) | CAsiIdent |
setDelimited(EAsiBoolean) | CAsiIdent |
setDelimited(void) | CAsiIdent |
ToString(CAsiUcStr *) const | CAsiIdent |
unpackFrom(CAsiObjPack *) | CAsiIdent | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiIdent(void) | CAsiIdent | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiInt Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiInt Class Reference
Misc Classes
+ Inheritance diagram for CAsiInt:

Public Member Functions

CAsiInt (const CAsiInt &)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual CAsiObject * | duplicate (void) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual integer | intValue (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
CAsiDouble | operator* (const CAsiSmallInt &) const
CAsiDouble | operator* (const CAsiInt &) const
CAsiDouble | operator* (const smallint) const
CAsiDouble | operator* (const integer) const
CAsiDouble | operator* (const real) const
CAsiDouble | operator* (const int) const
CAsiInt & | operator*= (const CAsiSmallInt &)
CAsiInt & | operator*= (const CAsiInt &)
CAsiInt & | operator*= (const CAsiNumeric &)
CAsiInt & | operator*= (const CAsiDecimal &)
CAsiInt & | operator*= (const CAsiFloat &)
CAsiInt & | operator*= (const CAsiReal &)
CAsiInt & | operator*= (const CAsiDouble &)
CAsiInt & | operator*= (const smallint)
CAsiInt & | operator*= (const integer)
CAsiInt & | operator*= (const real)
CAsiInt & | operator*= (const int)
CAsiDouble | operator+ (const CAsiSmallInt &) const
CAsiDouble | operator+ (const CAsiInt &) const
CAsiDouble | operator+ (const smallint) const
CAsiDouble | operator+ (const integer) const
CAsiDouble | operator+ (const real) const
CAsiDouble | operator+ (const int) const
CAsiInt & | operator++ (void)
CAsiInt & | operator+= (const CAsiSmallInt &)
CAsiInt & | operator+= (const CAsiInt &)
CAsiInt & | operator+= (const CAsiNumeric &)
CAsiInt & | operator+= (const CAsiDecimal &)
CAsiInt & | operator+= (const CAsiFloat &)
CAsiInt & | operator+= (const CAsiReal &)
CAsiInt & | operator+= (const CAsiDouble &)
CAsiInt & | operator+= (const smallint)
CAsiInt & | operator+= (const integer)
CAsiInt & | operator+= (const real)
CAsiInt & | operator+= (const int)
CAsiDouble | operator- (const CAsiSmallInt &) const
CAsiDouble | operator- (const CAsiInt &) const
CAsiDouble | operator- (const smallint) const
CAsiDouble | operator- (const integer) const
CAsiDouble | operator- (const real) const
CAsiDouble | operator- (const int) const
CAsiInt & | operator- (void)
CAsiInt & | operator-- (void)
CAsiInt & | operator-= (const CAsiSmallInt &)
CAsiInt & | operator-= (const CAsiInt &)
CAsiInt & | operator-= (const CAsiNumeric &)
CAsiInt & | operator-= (const CAsiDecimal &)
CAsiInt & | operator-= (const CAsiFloat &)
CAsiInt & | operator-= (const CAsiReal &)
CAsiInt & | operator-= (const CAsiDouble &)
CAsiInt & | operator-= (const smallint)
CAsiInt & | operator-= (const integer)
CAsiInt & | operator-= (const real)
CAsiInt & | operator-= (const int)
CAsiDouble | operator/ (const CAsiSmallInt &) const
CAsiDouble | operator/ (const CAsiInt &) const
CAsiDouble | operator/ (const smallint) const
CAsiDouble | operator/ (const integer) const
CAsiDouble | operator/ (const real) const
CAsiDouble | operator/ (const int) const
CAsiInt & | operator/= (const CAsiSmallInt &)
CAsiInt & | operator/= (const CAsiInt &)
CAsiInt & | operator/= (const CAsiNumeric &)
CAsiInt & | operator/= (const CAsiDecimal &)
CAsiInt & | operator/= (const CAsiFloat &)
CAsiInt & | operator/= (const CAsiReal &)
CAsiInt & | operator/= (const CAsiDouble &)
CAsiInt & | operator/= (const smallint)
CAsiInt & | operator/= (const integer)
CAsiInt & | operator/= (const real)
CAsiInt & | operator/= (const int)
CAsiInt & | operator= (const CAsiSmallInt &)
CAsiInt & | operator= (const CAsiInt &)
CAsiInt & | operator= (const CAsiNumeric &)
CAsiInt & | operator= (const CAsiDecimal &)
CAsiInt & | operator= (const CAsiFloat &)
CAsiInt & | operator= (const CAsiReal &)
CAsiInt & | operator= (const CAsiDouble &)
CAsiInt & | operator= (const smallint)
CAsiInt & | operator= (const integer)
CAsiInt & | operator= (const real)
CAsiInt & | operator= (const int)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual real | realValue (void) const
virtual uint | ReturnLength (void) const
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiDataType | Type (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiExactNum
virtual EAsiBoolean | is_exactnumeric (void) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual | ~CAsiExactNum ()
- Public Member Functions inherited from CAsiNum
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

CAsiDouble DLLScope | operator* (const CAsiSmallInt &, const CAsiInt &)
CAsiDouble DLLScope | operator* (const smallint, const CAsiInt &)
CAsiDouble DLLScope | operator* (const integer, const CAsiInt &)
CAsiDouble DLLScope | operator* (const real, const CAsiInt &)
CAsiDouble DLLScope | operator* (const int, const CAsiInt &)
CAsiDouble DLLScope | operator+ (const CAsiSmallInt &, const CAsiInt &)
CAsiDouble DLLScope | operator+ (const smallint, const CAsiInt &)
CAsiDouble DLLScope | operator+ (const integer, const CAsiInt &)
CAsiDouble DLLScope | operator+ (const real, const CAsiInt &)
CAsiDouble DLLScope | operator+ (const int, const CAsiInt &)
CAsiDouble DLLScope | operator- (const CAsiSmallInt &, const CAsiInt &)
CAsiDouble DLLScope | operator- (const smallint, const CAsiInt &)
CAsiDouble DLLScope | operator- (const integer, const CAsiInt &)
CAsiDouble DLLScope | operator- (const real, const CAsiInt &)
CAsiDouble DLLScope | operator- (const int, const CAsiInt &)
CAsiDouble DLLScope | operator/ (const CAsiSmallInt &, const CAsiInt &)
CAsiDouble DLLScope | operator/ (const smallint, const CAsiInt &)
CAsiDouble DLLScope | operator/ (const integer, const CAsiInt &)
CAsiDouble DLLScope | operator/ (const real, const CAsiInt &)
CAsiDouble DLLScope | operator/ (const int, const CAsiInt &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Member Functions inherited from CAsiExactNum
CAsiExactNum ()
int | cmpeqlan (const CAsiNum *) const
int | cmpeqlen (const CAsiExactNum *) const
int | cmpeqlenC (const real) const
int | cmpgtean (const CAsiNum *) const
int | cmpgteen (const CAsiExactNum *) const
int | cmpgteenC (const real) const
int | cmpgtran (const CAsiNum *) const
int | cmpgtren (const CAsiExactNum *) const
int | cmpgtrenC (const real) const
int | cmpltean (const CAsiNum *) const
int | cmplteen (const CAsiExactNum *) const
int | cmplteenC (const real) const
int | cmpltran (const CAsiNum *) const
int | cmpltren (const CAsiExactNum *) const
int | cmpltrenC (const real) const
int | cmpneqan (const CAsiNum *) const
int | cmpneqen (const CAsiExactNum *) const
int | cmpneqenC (const real) const
- Protected Attributes inherited from CAsiNum
uint | precision
uint | scale
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiInt Member List

This is the complete list of members for CAsiInt, including all inherited members.

CAsiData(void) | CAsiData |
CAsiExactNum() | CAsiExactNum | protected
CAsiInt() (defined in CAsiInt) | CAsiInt |
CAsiInt(const CAsiInt &) (defined in CAsiInt) | CAsiInt |
CAsiNum() | CAsiNum | protected
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const (defined in CAsiInt) | CAsiInt | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const (defined in CAsiInt) | CAsiInt | virtual
checkMul(const CAsiData *) const (defined in CAsiInt) | CAsiInt | virtual
checkSet(const CAsiData *) const (defined in CAsiInt) | CAsiInt | virtual
checkSub(const CAsiData *) const (defined in CAsiInt) | CAsiInt | virtual
Clear(void) | CAsiData | virtual
cmpeqlan(const CAsiNum *) const | CAsiExactNum | protected
cmpeqlen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpeqlenC(const real) const | CAsiExactNum | protected
cmpgtean(const CAsiNum *) const | CAsiExactNum | protected
cmpgteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgteenC(const real) const | CAsiExactNum | protected
cmpgtran(const CAsiNum *) const | CAsiExactNum | protected
cmpgtren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgtrenC(const real) const | CAsiExactNum | protected
cmpltean(const CAsiNum *) const | CAsiExactNum | protected
cmplteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmplteenC(const real) const | CAsiExactNum | protected
cmpltran(const CAsiNum *) const | CAsiExactNum | protected
cmpltren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpltrenC(const real) const | CAsiExactNum | protected
cmpneqan(const CAsiNum *) const | CAsiExactNum | protected
cmpneqen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpneqenC(const real) const | CAsiExactNum | protected
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiInt) | CAsiInt | virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const (defined in CAsiInt) | CAsiInt | virtual
getValue(integer *) const (defined in CAsiInt) | CAsiInt | virtual
getValue(smallint *) const (defined in CAsiInt) | CAsiInt | virtual
getValue(char *, uint) const (defined in CAsiInt) | CAsiInt | virtual
getValue(CAsiUcStr *) const (defined in CAsiInt) | CAsiInt | virtual
getValue(char *, uint, uint *) const (defined in CAsiInt) | CAsiInt | virtual
getValue(AsiUcStr, uint) const (defined in CAsiInt) | CAsiInt | virtual
getValue(CAsiData &) const (defined in CAsiInt) | CAsiInt | virtual
CAsiExactNum::getValue(DECIMAL *) const | CAsiData | virtual
CAsiExactNum::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiExactNum::getValue(DBDATE *) const | CAsiData | virtual
CAsiExactNum::getValue(DBTIME *) const | CAsiData | virtual
CAsiExactNum::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const (defined in CAsiInt) | CAsiInt | virtual
is_approxnumeric(void) const | CAsiNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiExactNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiInt) | CAsiInt | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiInt) | CAsiInt | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiInt) | CAsiInt | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiInt) | CAsiInt | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator!=(const CAsiInt &) const | CAsiExactNum | virtual
operator!=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator!=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator!=(const CAsiFloat &) const | CAsiExactNum | virtual
operator!=(const CAsiReal &) const | CAsiExactNum | virtual
operator!=(const CAsiDouble &) const | CAsiExactNum | virtual
operator!=(const smallint) const | CAsiExactNum | virtual
operator!=(const integer) const | CAsiExactNum | virtual
operator!=(const real) const | CAsiExactNum | virtual
operator!=(const int) const | CAsiExactNum | virtual
operator*(const CAsiSmallInt &) const (defined in CAsiInt) | CAsiInt |
operator* (defined in CAsiInt) | CAsiInt | friend
operator*(const CAsiInt &) const (defined in CAsiInt) | CAsiInt |
operator*(const smallint) const (defined in CAsiInt) | CAsiInt |
operator* (defined in CAsiInt) | CAsiInt | friend
operator*(const integer) const (defined in CAsiInt) | CAsiInt |
operator* (defined in CAsiInt) | CAsiInt | friend
operator*(const real) const (defined in CAsiInt) | CAsiInt |
operator* (defined in CAsiInt) | CAsiInt | friend
operator*(const int) const (defined in CAsiInt) | CAsiInt |
operator* (defined in CAsiInt) | CAsiInt | friend
operator*=(const CAsiSmallInt &) (defined in CAsiInt) | CAsiInt |
operator*=(const CAsiInt &) (defined in CAsiInt) | CAsiInt |
operator*=(const CAsiNumeric &) (defined in CAsiInt) | CAsiInt |
operator*=(const CAsiDecimal &) (defined in CAsiInt) | CAsiInt |
operator*=(const CAsiFloat &) (defined in CAsiInt) | CAsiInt |
operator*=(const CAsiReal &) (defined in CAsiInt) | CAsiInt |
operator*=(const CAsiDouble &) (defined in CAsiInt) | CAsiInt |
operator*=(const smallint) (defined in CAsiInt) | CAsiInt |
operator*=(const integer) (defined in CAsiInt) | CAsiInt |
operator*=(const real) (defined in CAsiInt) | CAsiInt |
operator*=(const int) (defined in CAsiInt) | CAsiInt |
operator+(const CAsiSmallInt &) const (defined in CAsiInt) | CAsiInt |
operator+ (defined in CAsiInt) | CAsiInt | friend
operator+(const CAsiInt &) const (defined in CAsiInt) | CAsiInt |
operator+(const smallint) const (defined in CAsiInt) | CAsiInt |
operator+ (defined in CAsiInt) | CAsiInt | friend
operator+(const integer) const (defined in CAsiInt) | CAsiInt |
operator+ (defined in CAsiInt) | CAsiInt | friend
operator+(const real) const (defined in CAsiInt) | CAsiInt |
operator+ (defined in CAsiInt) | CAsiInt | friend
operator+(const int) const (defined in CAsiInt) | CAsiInt |
operator+ (defined in CAsiInt) | CAsiInt | friend
operator++(void) (defined in CAsiInt) | CAsiInt |
operator+=(const CAsiSmallInt &) (defined in CAsiInt) | CAsiInt |
operator+=(const CAsiInt &) (defined in CAsiInt) | CAsiInt |
operator+=(const CAsiNumeric &) (defined in CAsiInt) | CAsiInt |
operator+=(const CAsiDecimal &) (defined in CAsiInt) | CAsiInt |
operator+=(const CAsiFloat &) (defined in CAsiInt) | CAsiInt |
operator+=(const CAsiReal &) (defined in CAsiInt) | CAsiInt |
operator+=(const CAsiDouble &) (defined in CAsiInt) | CAsiInt |
operator+=(const smallint) (defined in CAsiInt) | CAsiInt |
operator+=(const integer) (defined in CAsiInt) | CAsiInt |
operator+=(const real) (defined in CAsiInt) | CAsiInt |
operator+=(const int) (defined in CAsiInt) | CAsiInt |
operator-(const CAsiSmallInt &) const (defined in CAsiInt) | CAsiInt |
operator- (defined in CAsiInt) | CAsiInt | friend
operator-(const CAsiInt &) const (defined in CAsiInt) | CAsiInt |
operator-(const smallint) const (defined in CAsiInt) | CAsiInt |
operator- (defined in CAsiInt) | CAsiInt | friend
operator-(const integer) const (defined in CAsiInt) | CAsiInt |
operator- (defined in CAsiInt) | CAsiInt | friend
operator-(const real) const (defined in CAsiInt) | CAsiInt |
operator- (defined in CAsiInt) | CAsiInt | friend
operator-(const int) const (defined in CAsiInt) | CAsiInt |
operator- (defined in CAsiInt) | CAsiInt | friend
operator-(void) (defined in CAsiInt) | CAsiInt |
operator--(void) (defined in CAsiInt) | CAsiInt |
operator-=(const CAsiSmallInt &) (defined in CAsiInt) | CAsiInt |
operator-=(const CAsiInt &) (defined in CAsiInt) | CAsiInt |
operator-=(const CAsiNumeric &) (defined in CAsiInt) | CAsiInt |
operator-=(const CAsiDecimal &) (defined in CAsiInt) | CAsiInt |
operator-=(const CAsiFloat &) (defined in CAsiInt) | CAsiInt |
operator-=(const CAsiReal &) (defined in CAsiInt) | CAsiInt |
operator-=(const CAsiDouble &) (defined in CAsiInt) | CAsiInt |
operator-=(const smallint) (defined in CAsiInt) | CAsiInt |
operator-=(const integer) (defined in CAsiInt) | CAsiInt |
operator-=(const real) (defined in CAsiInt) | CAsiInt |
operator-=(const int) (defined in CAsiInt) | CAsiInt |
operator/(const CAsiSmallInt &) const (defined in CAsiInt) | CAsiInt |
operator/ (defined in CAsiInt) | CAsiInt | friend
operator/(const CAsiInt &) const (defined in CAsiInt) | CAsiInt |
operator/(const smallint) const (defined in CAsiInt) | CAsiInt |
operator/ (defined in CAsiInt) | CAsiInt | friend
operator/(const integer) const (defined in CAsiInt) | CAsiInt |
operator/ (defined in CAsiInt) | CAsiInt | friend
operator/(const real) const (defined in CAsiInt) | CAsiInt |
operator/ (defined in CAsiInt) | CAsiInt | friend
operator/(const int) const (defined in CAsiInt) | CAsiInt |
operator/ (defined in CAsiInt) | CAsiInt | friend
operator/=(const CAsiSmallInt &) (defined in CAsiInt) | CAsiInt |
operator/=(const CAsiInt &) (defined in CAsiInt) | CAsiInt |
operator/=(const CAsiNumeric &) (defined in CAsiInt) | CAsiInt |
operator/=(const CAsiDecimal &) (defined in CAsiInt) | CAsiInt |
operator/=(const CAsiFloat &) (defined in CAsiInt) | CAsiInt |
operator/=(const CAsiReal &) (defined in CAsiInt) | CAsiInt |
operator/=(const CAsiDouble &) (defined in CAsiInt) | CAsiInt |
operator/=(const smallint) (defined in CAsiInt) | CAsiInt |
operator/=(const integer) (defined in CAsiInt) | CAsiInt |
operator/=(const real) (defined in CAsiInt) | CAsiInt |
operator/=(const int) (defined in CAsiInt) | CAsiInt |
operator<(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<(const CAsiInt &) const | CAsiExactNum | virtual
operator<(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<(const CAsiFloat &) const | CAsiExactNum | virtual
operator<(const CAsiReal &) const | CAsiExactNum | virtual
operator<(const CAsiDouble &) const | CAsiExactNum | virtual
operator<(const smallint) const | CAsiExactNum | virtual
operator<(const integer) const | CAsiExactNum | virtual
operator<(const real) const | CAsiExactNum | virtual
operator<(const int) const | CAsiExactNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<=(const CAsiInt &) const | CAsiExactNum | virtual
operator<=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<=(const CAsiFloat &) const | CAsiExactNum | virtual
operator<=(const CAsiReal &) const | CAsiExactNum | virtual
operator<=(const CAsiDouble &) const | CAsiExactNum | virtual
operator<=(const smallint) const | CAsiExactNum | virtual
operator<=(const integer) const | CAsiExactNum | virtual
operator<=(const real) const | CAsiExactNum | virtual
operator<=(const int) const | CAsiExactNum | virtual
operator=(const CAsiSmallInt &) (defined in CAsiInt) | CAsiInt |
operator=(const CAsiInt &) (defined in CAsiInt) | CAsiInt |
operator=(const CAsiNumeric &) (defined in CAsiInt) | CAsiInt |
operator=(const CAsiDecimal &) (defined in CAsiInt) | CAsiInt |
operator=(const CAsiFloat &) (defined in CAsiInt) | CAsiInt |
operator=(const CAsiReal &) (defined in CAsiInt) | CAsiInt |
operator=(const CAsiDouble &) (defined in CAsiInt) | CAsiInt |
operator=(const smallint) (defined in CAsiInt) | CAsiInt |
operator=(const integer) (defined in CAsiInt) | CAsiInt |
operator=(const real) (defined in CAsiInt) | CAsiInt |
operator=(const int) (defined in CAsiInt) | CAsiInt |
operator==(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator==(const CAsiInt &) const | CAsiExactNum | virtual
operator==(const CAsiNumeric &) const | CAsiExactNum | virtual
operator==(const CAsiDecimal &) const | CAsiExactNum | virtual
operator==(const CAsiFloat &) const | CAsiExactNum | virtual
operator==(const CAsiReal &) const | CAsiExactNum | virtual
operator==(const CAsiDouble &) const | CAsiExactNum | virtual
operator==(const smallint) const | CAsiExactNum | virtual
operator==(const integer) const | CAsiExactNum | virtual
operator==(const real) const | CAsiExactNum | virtual
operator==(const int) const | CAsiExactNum | virtual
operator>(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>(const CAsiInt &) const | CAsiExactNum | virtual
operator>(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>(const CAsiFloat &) const | CAsiExactNum | virtual
operator>(const CAsiReal &) const | CAsiExactNum | virtual
operator>(const CAsiDouble &) const | CAsiExactNum | virtual
operator>(const smallint) const | CAsiExactNum | virtual
operator>(const integer) const | CAsiExactNum | virtual
operator>(const real) const | CAsiExactNum | virtual
operator>(const int) const | CAsiExactNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>=(const CAsiInt &) const | CAsiExactNum | virtual
operator>=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>=(const CAsiFloat &) const | CAsiExactNum | virtual
operator>=(const CAsiReal &) const | CAsiExactNum | virtual
operator>=(const CAsiDouble &) const | CAsiExactNum | virtual
operator>=(const smallint) const | CAsiExactNum | virtual
operator>=(const integer) const | CAsiExactNum | virtual
operator>=(const real) const | CAsiExactNum | virtual
operator>=(const int) const | CAsiExactNum | virtual
packSize(void) const (defined in CAsiInt) | CAsiInt | virtual
packTo(CAsiObjPack *) const (defined in CAsiInt) | CAsiInt | virtual
packValueSize(void) const (defined in CAsiInt) | CAsiInt | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiInt) | CAsiInt | virtual
precision (defined in CAsiNum) | CAsiNum | protected
Precision(void) const | CAsiNum | virtual
realValue(void) const (defined in CAsiInt) | CAsiInt | virtual
ReturnLength(void) const (defined in CAsiInt) | CAsiInt | virtual
scale (defined in CAsiNum) | CAsiNum | protected
Scale(void) const | CAsiNum | virtual
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const (defined in CAsiInt) | CAsiInt | virtual
SQLType(CAsiUcStr *) const (defined in CAsiInt) | CAsiInt | virtual
storeValue(real) (defined in CAsiInt) | CAsiInt | virtual
storeValue(integer) (defined in CAsiInt) | CAsiInt | virtual
storeValue(smallint) (defined in CAsiInt) | CAsiInt | virtual
storeValue(char *, uint) (defined in CAsiInt) | CAsiInt | virtual
storeValue(const CAsiUcStr &) (defined in CAsiInt) | CAsiInt | virtual
storeValue(const CAsiData &) (defined in CAsiInt) | CAsiInt | virtual
storeValue(char *, uint, uint *) (defined in CAsiInt) | CAsiInt | virtual
storeValue(const AsiUcStr) (defined in CAsiInt) | CAsiInt | virtual
CAsiExactNum::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiExactNum::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBDATE *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBTIME *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiInt) | CAsiInt | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiInt) | CAsiInt | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiInt) | CAsiInt | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiExactNum() | CAsiExactNum | virtual
~CAsiInt() (defined in CAsiInt) | CAsiInt | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiInterval Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAsiInterval Class Reference
Misc Classes
+ Inheritance diagram for CAsiInterval:

Public Member Functions

virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
void | setSign (EAsiBoolean)
EAsiBoolean | Sign (void) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
- Public Member Functions inherited from CAsiIQualifier
CAsiIQualifier (EAsiIType)
CAsiIQualifier (EAsiIType, uint)
CAsiIQualifier (EAsiIType, uint, uint)
CAsiIQualifier (const CAsiIQualifier &)
virtual CAsiObject * | duplicate (void) const
virtual uint | FracSecPrec (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_interval (void) const
EAsiBoolean | is_moreaccurate (const CAsiIQualifier *) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | is_yminterval (void) const
virtual uint | LeadFieldPrec (void) const
CAsiIQualifier & | operator= (const CAsiIQualifier &)
virtual uint | ReturnLength (void) const
void | setFracSecPrec (uint)
virtual EAsiBoolean | setIType (EAsiIType)
void | setLeadFieldPrec (uint)
virtual EAsiDataType | Type (void) const
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual EAsiBoolean | isNull (void) const
virtual uint | Length (void) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const =0
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Attributes

EAsiBoolean | sign
- Protected Attributes inherited from CAsiIQualifier
uint | fsp
EAsiIType | itype
uint | lfp
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull

Friends

class | CAsiDate
class | CAsiTime
class | CAsiTimeStamp

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiInterval Member List

This is the complete list of members for CAsiInterval, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDate (defined in CAsiInterval) | CAsiInterval | friend
CAsiInterval(void) (defined in CAsiInterval) | CAsiInterval |
CAsiIQualifier(void) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType, uint) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType, uint, uint) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(const CAsiIQualifier &) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiObject(void) | CAsiObject |
CAsiTime (defined in CAsiInterval) | CAsiInterval | friend
CAsiTimeStamp (defined in CAsiInterval) | CAsiInterval | friend
checkAdd(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkMul(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkSet(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkSub(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
FracSecPrec(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
fsp (defined in CAsiIQualifier) | CAsiIQualifier | protected
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const | CAsiData | virtual
getValue(integer *) const | CAsiData | virtual
getValue(smallint *) const | CAsiData | virtual
getValue(char *, uint) const | CAsiData | virtual
getValue(CAsiUcStr *) const | CAsiData | virtual
getValue(char *, uint, uint *) const | CAsiData | virtual
getValue(AsiUcStr, uint) const | CAsiData | virtual
getValue(CAsiData &) const | CAsiData | virtual
getValue(DECIMAL *) const | CAsiData | virtual
getValue(DB_NUMERIC *) const | CAsiData | virtual
getValue(DBDATE *) const | CAsiData | virtual
getValue(DBTIME *) const | CAsiData | virtual
getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiData | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_moreaccurate(const CAsiIQualifier *) const (defined in CAsiIQualifier) | CAsiIQualifier |
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_yminterval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
isEqualTo(const CAsiData &) const | CAsiData | virtual
isGreaterThan(const CAsiData &) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
itype (defined in CAsiIQualifier) | CAsiIQualifier | protected
LeadFieldPrec(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
Length(void) const | CAsiData | virtual
lfp (defined in CAsiIQualifier) | CAsiIQualifier | protected
MapAsiToColumnInfo(DBCOLUMNINFO *) const | CAsiData | virtual
MapAsiToParamInfo(DBPARAMINFO *) const | CAsiData | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator=(const CAsiIQualifier &) (defined in CAsiIQualifier) | CAsiIQualifier |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
Scale(void) const | CAsiData | virtual
setFracSecPrec(uint) (defined in CAsiIQualifier) | CAsiIQualifier |
setIType(EAsiIType) (defined in CAsiIQualifier) | CAsiIQualifier | virtual
setLeadFieldPrec(uint) (defined in CAsiIQualifier) | CAsiIQualifier |
setNull(void) | CAsiData | virtual
setSign(EAsiBoolean) (defined in CAsiInterval) | CAsiInterval |
sign (defined in CAsiInterval) | CAsiInterval | protected
Sign(void) const (defined in CAsiInterval) | CAsiInterval |
SQLType(CAsiUcStr *) const (defined in CAsiInterval) | CAsiInterval | virtual
storeValue(real) | CAsiData | virtual
storeValue(integer) | CAsiData | virtual
storeValue(smallint) | CAsiData | virtual
storeValue(char *, uint) | CAsiData | virtual
storeValue(const CAsiUcStr &) | CAsiData | virtual
storeValue(char *, uint, uint *) | CAsiData | virtual
storeValue(const CAsiData &) | CAsiData | virtual
storeValue(const AsiUcStr) | CAsiData | virtual
storeValue(const DECIMAL &) | CAsiData | virtual
storeValue(const DB_NUMERIC *) | CAsiData | virtual
storeValue(const DBDATE *) | CAsiData | virtual
storeValue(const DBTIME *) | CAsiData | virtual
storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiInterval(void) (defined in CAsiInterval) | CAsiInterval | virtual
~CAsiIQualifier(void) (defined in CAsiIQualifier) | CAsiIQualifier | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiIQualifier Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAsiIQualifier Class Reference
Misc Classes
+ Inheritance diagram for CAsiIQualifier:

Public Member Functions

CAsiIQualifier (EAsiIType)
CAsiIQualifier (EAsiIType, uint)
CAsiIQualifier (EAsiIType, uint, uint)
CAsiIQualifier (const CAsiIQualifier &)
virtual CAsiObject * | duplicate (void) const
virtual uint | FracSecPrec (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_interval (void) const
EAsiBoolean | is_moreaccurate (const CAsiIQualifier *) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | is_yminterval (void) const
virtual uint | LeadFieldPrec (void) const
CAsiIQualifier & | operator= (const CAsiIQualifier &)
virtual uint | ReturnLength (void) const
void | setFracSecPrec (uint)
virtual EAsiBoolean | setIType (EAsiIType)
void | setLeadFieldPrec (uint)
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiDataType | Type (void) const
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual EAsiBoolean | isNull (void) const
virtual uint | Length (void) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const =0
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Attributes

uint | fsp
EAsiIType | itype
uint | lfp
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull

Friends

class | CAsiDatetime
class | CAsiInterval

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiIQualifier Member List

This is the complete list of members for CAsiIQualifier, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDatetime (defined in CAsiIQualifier) | CAsiIQualifier | friend
CAsiInterval (defined in CAsiIQualifier) | CAsiIQualifier | friend
CAsiIQualifier(void) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType, uint) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType, uint, uint) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(const CAsiIQualifier &) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const | CAsiData | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiData | virtual
checkMul(const CAsiData *) const | CAsiData | virtual
checkSet(const CAsiData *) const | CAsiData | virtual
checkSub(const CAsiData *) const | CAsiData | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
FracSecPrec(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
fsp (defined in CAsiIQualifier) | CAsiIQualifier | protected
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const | CAsiData | virtual
getValue(integer *) const | CAsiData | virtual
getValue(smallint *) const | CAsiData | virtual
getValue(char *, uint) const | CAsiData | virtual
getValue(CAsiUcStr *) const | CAsiData | virtual
getValue(char *, uint, uint *) const | CAsiData | virtual
getValue(AsiUcStr, uint) const | CAsiData | virtual
getValue(CAsiData &) const | CAsiData | virtual
getValue(DECIMAL *) const | CAsiData | virtual
getValue(DB_NUMERIC *) const | CAsiData | virtual
getValue(DBDATE *) const | CAsiData | virtual
getValue(DBTIME *) const | CAsiData | virtual
getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiData | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_moreaccurate(const CAsiIQualifier *) const (defined in CAsiIQualifier) | CAsiIQualifier |
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_yminterval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
isEqualTo(const CAsiData &) const | CAsiData | virtual
isGreaterThan(const CAsiData &) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
itype (defined in CAsiIQualifier) | CAsiIQualifier | protected
LeadFieldPrec(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
Length(void) const | CAsiData | virtual
lfp (defined in CAsiIQualifier) | CAsiIQualifier | protected
MapAsiToColumnInfo(DBCOLUMNINFO *) const | CAsiData | virtual
MapAsiToParamInfo(DBPARAMINFO *) const | CAsiData | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator=(const CAsiIQualifier &) (defined in CAsiIQualifier) | CAsiIQualifier |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
Scale(void) const | CAsiData | virtual
setFracSecPrec(uint) (defined in CAsiIQualifier) | CAsiIQualifier |
setIType(EAsiIType) (defined in CAsiIQualifier) | CAsiIQualifier | virtual
setLeadFieldPrec(uint) (defined in CAsiIQualifier) | CAsiIQualifier |
setNull(void) | CAsiData | virtual
SQLType(CAsiUcStr *) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
storeValue(real) | CAsiData | virtual
storeValue(integer) | CAsiData | virtual
storeValue(smallint) | CAsiData | virtual
storeValue(char *, uint) | CAsiData | virtual
storeValue(const CAsiUcStr &) | CAsiData | virtual
storeValue(char *, uint, uint *) | CAsiData | virtual
storeValue(const CAsiData &) | CAsiData | virtual
storeValue(const AsiUcStr) | CAsiData | virtual
storeValue(const DECIMAL &) | CAsiData | virtual
storeValue(const DB_NUMERIC *) | CAsiData | virtual
storeValue(const DBDATE *) | CAsiData | virtual
storeValue(const DBTIME *) | CAsiData | virtual
storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiIQualifier(void) (defined in CAsiIQualifier) | CAsiIQualifier | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiIRow Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAsiIRow Class Reference
Misc Classes
+ Inheritance diagram for CAsiIRow:

Public Member Functions

CAsiIRow (const int)
CAsiIRow (const CAsiIRow &)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
CAsiData * | operator[] (const int item) const
int | Quantity (void) const
EAsiBoolean | setItem (int, CAsiData *)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiIRow Member List

This is the complete list of members for CAsiIRow, including all inherited members.

CAsiIRow(void) (defined in CAsiIRow) | CAsiIRow |
CAsiIRow(const int) (defined in CAsiIRow) | CAsiIRow |
CAsiIRow(const CAsiIRow &) (defined in CAsiIRow) | CAsiIRow |
CAsiObject(void) | CAsiObject |
Clear(void) (defined in CAsiIRow) | CAsiIRow | virtual
duplicate(void) const (defined in CAsiIRow) | CAsiIRow | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator[](const int item) const (defined in CAsiIRow) | CAsiIRow |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
Quantity(void) const (defined in CAsiIRow) | CAsiIRow |
setItem(int, CAsiData *) (defined in CAsiIRow) | CAsiIRow |
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiIRow(void) (defined in CAsiIRow) | CAsiIRow | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiList Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAsiList Class Reference
Misc Classes
+ Inheritance diagram for CAsiList:

Public Member Functions

EAsiBoolean | addFirst (CAsiObject *)
EAsiBoolean | addLast (CAsiObject *)
virtual void | Clear (void)
EAsiBoolean | del (CAsiObject *)
EAsiBoolean | del (int)
EAsiBoolean | delFirst (void)
EAsiBoolean | delLast (void)
EAsiBoolean | delTail (int)
EAsiBoolean | detach (CAsiObject *)
EAsiBoolean | detach (int)
void | detachAll (void)
EAsiBoolean | detachFirst (void)
EAsiBoolean | detachLast (void)
EAsiBoolean | detachTail (int)
virtual CAsiObject * | duplicate () const
CAsiObject * | first (void)
CAsiObject * | getAt (ASILISTPOS) const
CAsiObject * | getCurrent (void) const
CAsiObject * | last (void)
CAsiObject * | next (void)
CAsiObject * | next (ASILISTPOS)
CAsiObject * | operator[] (int)
EAsiBoolean | overwrite (int, CAsiObject *)
ASILISTPOS | position (void) const
int | qnty (void) const
EAsiBoolean | replace (int, CAsiObject *)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiList Member List

This is the complete list of members for CAsiList, including all inherited members.

addFirst(CAsiObject *) (defined in CAsiList) | CAsiList |
addLast(CAsiObject *) (defined in CAsiList) | CAsiList |
CAsiList() (defined in CAsiList) | CAsiList |
CAsiObject(void) | CAsiObject |
Clear(void) (defined in CAsiList) | CAsiList | virtual
del(CAsiObject *) (defined in CAsiList) | CAsiList |
del(int) (defined in CAsiList) | CAsiList |
delFirst(void) (defined in CAsiList) | CAsiList |
delLast(void) (defined in CAsiList) | CAsiList |
delTail(int) (defined in CAsiList) | CAsiList |
detach(CAsiObject *) (defined in CAsiList) | CAsiList |
detach(int) (defined in CAsiList) | CAsiList |
detachAll(void) (defined in CAsiList) | CAsiList |
detachFirst(void) (defined in CAsiList) | CAsiList |
detachLast(void) (defined in CAsiList) | CAsiList |
detachTail(int) (defined in CAsiList) | CAsiList |
duplicate() const (defined in CAsiList) | CAsiList | virtual
first(void) (defined in CAsiList) | CAsiList |
getAt(ASILISTPOS) const (defined in CAsiList) | CAsiList |
getCurrent(void) const (defined in CAsiList) | CAsiList |
last(void) (defined in CAsiList) | CAsiList |
next(void) (defined in CAsiList) | CAsiList |
next(ASILISTPOS) (defined in CAsiList) | CAsiList |
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator[](int) (defined in CAsiList) | CAsiList |
overwrite(int, CAsiObject *) (defined in CAsiList) | CAsiList |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
position(void) const (defined in CAsiList) | CAsiList |
qnty(void) const (defined in CAsiList) | CAsiList |
replace(int, CAsiObject *) (defined in CAsiList) | CAsiList |
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiList() (defined in CAsiList) | CAsiList | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiNum Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAsiNum Class Reference
Misc Classes
+ Inheritance diagram for CAsiNum:

Public Member Functions

virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual integer | intValue (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual uint | Precision (void) const
virtual real | realValue (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual CAsiObject * | duplicate (void) const =0
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual uint | ReturnLength (void) const
virtual void | setNull (void)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const =0
virtual EAsiBoolean | SQLType (CAsiUcStr *) const =0
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual EAsiDataType | Type (void) const =0
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

CAsiNum ()

Protected Attributes

uint | precision
uint | scale
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull

Friends

class CAsiLex

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)

Constructor & Destructor Documentation

CAsiNum::CAsiNum ( )
protected
Warning
Not implemented!
virtual CAsiNum::~CAsiNum ( )
virtual
Warning
Not implemented!

Member Function Documentation

virtual CAsiData* CAsiNum::checkAdd ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

Reimplemented in CAsiSmallInt, and CAsiExactNum.

virtual CAsiData* CAsiNum::checkDiv ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

Reimplemented in CAsiSmallInt.

virtual CAsiData* CAsiNum::checkMul ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

Reimplemented in CAsiSmallInt.

virtual CAsiData* CAsiNum::checkSub ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

Reimplemented in CAsiSmallInt.

virtual integer CAsiNum::intValue ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiNum::is_approxnumeric ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

Reimplemented in CAsiApproxNum.

virtual EAsiBoolean CAsiNum::is_castable ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiNum::is_comparable ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiNum::is_exactnumeric ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

Reimplemented in CAsiExactNum.

virtual EAsiBoolean CAsiNum::is_numeric ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiNum::is_storable ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual int CAsiNum::operator!= ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const real ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator!= ( const int ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const real ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator< ( const int ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const real ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator<= ( const int ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const real ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator== ( const int ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const real ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator> ( const int ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const CAsiSmallInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const CAsiInt & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const CAsiNumeric & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const CAsiDecimal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const CAsiFloat & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const CAsiReal & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const CAsiDouble & ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const smallint ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const integer ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const real ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual int CAsiNum::operator>= ( const int ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiApproxNum, and CAsiExactNum.

virtual uint CAsiNum::Precision ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual real CAsiNum::realValue ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual uint CAsiNum::Scale ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiNum Member List

This is the complete list of members for CAsiNum, including all inherited members.

CAsiData(void) | CAsiData |
CAsiLex (defined in CAsiNum) | CAsiNum | friend
CAsiNum() | CAsiNum | protected
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const | CAsiNum | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiNum | virtual
checkMul(const CAsiData *) const | CAsiNum | virtual
checkSet(const CAsiData *) const | CAsiData | virtual
checkSub(const CAsiData *) const | CAsiNum | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const =0 | CAsiData | pure virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const | CAsiData | virtual
getValue(integer *) const | CAsiData | virtual
getValue(smallint *) const | CAsiData | virtual
getValue(char *, uint) const | CAsiData | virtual
getValue(CAsiUcStr *) const | CAsiData | virtual
getValue(char *, uint, uint *) const | CAsiData | virtual
getValue(AsiUcStr, uint) const | CAsiData | virtual
getValue(CAsiData &) const | CAsiData | virtual
getValue(DECIMAL *) const | CAsiData | virtual
getValue(DB_NUMERIC *) const | CAsiData | virtual
getValue(DBDATE *) const | CAsiData | virtual
getValue(DBTIME *) const | CAsiData | virtual
getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const | CAsiNum | virtual
is_approxnumeric(void) const | CAsiNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const | CAsiData | virtual
isGreaterThan(const CAsiData &) const | CAsiData | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const | CAsiData | virtual
MapAsiToParamInfo(DBPARAMINFO *) const | CAsiData | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiNum | virtual
operator!=(const CAsiInt &) const | CAsiNum | virtual
operator!=(const CAsiNumeric &) const | CAsiNum | virtual
operator!=(const CAsiDecimal &) const | CAsiNum | virtual
operator!=(const CAsiFloat &) const | CAsiNum | virtual
operator!=(const CAsiReal &) const | CAsiNum | virtual
operator!=(const CAsiDouble &) const | CAsiNum | virtual
operator!=(const smallint) const | CAsiNum | virtual
operator!=(const integer) const | CAsiNum | virtual
operator!=(const real) const | CAsiNum | virtual
operator!=(const int) const | CAsiNum | virtual
operator<(const CAsiSmallInt &) const | CAsiNum | virtual
operator<(const CAsiInt &) const | CAsiNum | virtual
operator<(const CAsiNumeric &) const | CAsiNum | virtual
operator<(const CAsiDecimal &) const | CAsiNum | virtual
operator<(const CAsiFloat &) const | CAsiNum | virtual
operator<(const CAsiReal &) const | CAsiNum | virtual
operator<(const CAsiDouble &) const | CAsiNum | virtual
operator<(const smallint) const | CAsiNum | virtual
operator<(const integer) const | CAsiNum | virtual
operator<(const real) const | CAsiNum | virtual
operator<(const int) const | CAsiNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiNum | virtual
operator<=(const CAsiInt &) const | CAsiNum | virtual
operator<=(const CAsiNumeric &) const | CAsiNum | virtual
operator<=(const CAsiDecimal &) const | CAsiNum | virtual
operator<=(const CAsiFloat &) const | CAsiNum | virtual
operator<=(const CAsiReal &) const | CAsiNum | virtual
operator<=(const CAsiDouble &) const | CAsiNum | virtual
operator<=(const smallint) const | CAsiNum | virtual
operator<=(const integer) const | CAsiNum | virtual
operator<=(const real) const | CAsiNum | virtual
operator<=(const int) const | CAsiNum | virtual
operator==(const CAsiSmallInt &) const | CAsiNum | virtual
operator==(const CAsiInt &) const | CAsiNum | virtual
operator==(const CAsiNumeric &) const | CAsiNum | virtual
operator==(const CAsiDecimal &) const | CAsiNum | virtual
operator==(const CAsiFloat &) const | CAsiNum | virtual
operator==(const CAsiReal &) const | CAsiNum | virtual
operator==(const CAsiDouble &) const | CAsiNum | virtual
operator==(const smallint) const | CAsiNum | virtual
operator==(const integer) const | CAsiNum | virtual
operator==(const real) const | CAsiNum | virtual
operator==(const int) const | CAsiNum | virtual
operator>(const CAsiSmallInt &) const | CAsiNum | virtual
operator>(const CAsiInt &) const | CAsiNum | virtual
operator>(const CAsiNumeric &) const | CAsiNum | virtual
operator>(const CAsiDecimal &) const | CAsiNum | virtual
operator>(const CAsiFloat &) const | CAsiNum | virtual
operator>(const CAsiReal &) const | CAsiNum | virtual
operator>(const CAsiDouble &) const | CAsiNum | virtual
operator>(const smallint) const | CAsiNum | virtual
operator>(const integer) const | CAsiNum | virtual
operator>(const real) const | CAsiNum | virtual
operator>(const int) const | CAsiNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiNum | virtual
operator>=(const CAsiInt &) const | CAsiNum | virtual
operator>=(const CAsiNumeric &) const | CAsiNum | virtual
operator>=(const CAsiDecimal &) const | CAsiNum | virtual
operator>=(const CAsiFloat &) const | CAsiNum | virtual
operator>=(const CAsiReal &) const | CAsiNum | virtual
operator>=(const CAsiDouble &) const | CAsiNum | virtual
operator>=(const smallint) const | CAsiNum | virtual
operator>=(const integer) const | CAsiNum | virtual
operator>=(const real) const | CAsiNum | virtual
operator>=(const int) const | CAsiNum | virtual
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
precision (defined in CAsiNum) | CAsiNum | protected
Precision(void) const | CAsiNum | virtual
realValue(void) const | CAsiNum | virtual
ReturnLength(void) const | CAsiData | virtual
scale (defined in CAsiNum) | CAsiNum | protected
Scale(void) const | CAsiNum | virtual
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const =0 | CAsiData | pure virtual
SQLType(CAsiUcStr *) const =0 | CAsiData | pure virtual
storeValue(real) | CAsiData | virtual
storeValue(integer) | CAsiData | virtual
storeValue(smallint) | CAsiData | virtual
storeValue(char *, uint) | CAsiData | virtual
storeValue(const CAsiUcStr &) | CAsiData | virtual
storeValue(char *, uint, uint *) | CAsiData | virtual
storeValue(const CAsiData &) | CAsiData | virtual
storeValue(const AsiUcStr) | CAsiData | virtual
storeValue(const DECIMAL &) | CAsiData | virtual
storeValue(const DB_NUMERIC *) | CAsiData | virtual
storeValue(const DBDATE *) | CAsiData | virtual
storeValue(const DBTIME *) | CAsiData | virtual
storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const =0 | CAsiData | pure virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiNumeric Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiNumeric Class Reference
Misc Classes
+ Inheritance diagram for CAsiNumeric:

Public Member Functions

CAsiNumeric (uint, uint)
CAsiNumeric (uint)
CAsiNumeric (const CAsiNumeric &)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual CAsiObject * | duplicate (void) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual integer | intValue (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
CAsiDouble | operator* (const CAsiSmallInt &) const
CAsiDouble | operator* (const CAsiInt &) const
CAsiDouble | operator* (const CAsiNumeric &) const
CAsiDouble | operator* (const smallint) const
CAsiDouble | operator* (const integer) const
CAsiDouble | operator* (const real) const
CAsiDouble | operator* (const int) const
CAsiNumeric & | operator*= (const CAsiSmallInt &)
CAsiNumeric & | operator*= (const CAsiInt &)
CAsiNumeric & | operator*= (const CAsiNumeric &)
CAsiNumeric & | operator*= (const CAsiDecimal &)
CAsiNumeric & | operator*= (const CAsiFloat &)
CAsiNumeric & | operator*= (const CAsiReal &)
CAsiNumeric & | operator*= (const CAsiDouble &)
CAsiNumeric & | operator*= (const smallint)
CAsiNumeric & | operator*= (const integer)
CAsiNumeric & | operator*= (const real)
CAsiNumeric & | operator*= (const int)
CAsiDouble | operator+ (const CAsiSmallInt &) const
CAsiDouble | operator+ (const CAsiInt &) const
CAsiDouble | operator+ (const CAsiNumeric &) const
CAsiDouble | operator+ (const smallint) const
CAsiDouble | operator+ (const integer) const
CAsiDouble | operator+ (const real) const
CAsiDouble | operator+ (const int) const
CAsiNumeric & | operator++ (void)
CAsiNumeric & | operator+= (const CAsiSmallInt &)
CAsiNumeric & | operator+= (const CAsiInt &)
CAsiNumeric & | operator+= (const CAsiNumeric &)
CAsiNumeric & | operator+= (const CAsiDecimal &)
CAsiNumeric & | operator+= (const CAsiFloat &)
CAsiNumeric & | operator+= (const CAsiReal &)
CAsiNumeric & | operator+= (const CAsiDouble &)
CAsiNumeric & | operator+= (const smallint)
CAsiNumeric & | operator+= (const integer)
CAsiNumeric & | operator+= (const real)
CAsiNumeric & | operator+= (const int)
CAsiDouble | operator- (const CAsiSmallInt &) const
CAsiDouble | operator- (const CAsiInt &) const
CAsiDouble | operator- (const CAsiNumeric &) const
CAsiDouble | operator- (const smallint) const
CAsiDouble | operator- (const integer) const
CAsiDouble | operator- (const real) const
CAsiDouble | operator- (const int) const
CAsiNumeric & | operator- (void)
CAsiNumeric & | operator-- (void)
CAsiNumeric & | operator-= (const CAsiSmallInt &)
CAsiNumeric & | operator-= (const CAsiInt &)
CAsiNumeric & | operator-= (const CAsiNumeric &)
CAsiNumeric & | operator-= (const CAsiDecimal &)
CAsiNumeric & | operator-= (const CAsiFloat &)
CAsiNumeric & | operator-= (const CAsiReal &)
CAsiNumeric & | operator-= (const CAsiDouble &)
CAsiNumeric & | operator-= (const smallint)
CAsiNumeric & | operator-= (const integer)
CAsiNumeric & | operator-= (const real)
CAsiNumeric & | operator-= (const int)
CAsiDouble | operator/ (const CAsiSmallInt &) const
CAsiDouble | operator/ (const CAsiInt &) const
CAsiDouble | operator/ (const CAsiNumeric &) const
CAsiDouble | operator/ (const smallint) const
CAsiDouble | operator/ (const integer) const
CAsiDouble | operator/ (const real) const
CAsiDouble | operator/ (const int) const
CAsiNumeric & | operator/= (const CAsiSmallInt &)
CAsiNumeric & | operator/= (const CAsiInt &)
CAsiNumeric & | operator/= (const CAsiNumeric &)
CAsiNumeric & | operator/= (const CAsiDecimal &)
CAsiNumeric & | operator/= (const CAsiFloat &)
CAsiNumeric & | operator/= (const CAsiReal &)
CAsiNumeric & | operator/= (const CAsiDouble &)
CAsiNumeric & | operator/= (const smallint)
CAsiNumeric & | operator/= (const integer)
CAsiNumeric & | operator/= (const real)
CAsiNumeric & | operator/= (const int)
CAsiNumeric & | operator= (const CAsiSmallInt &)
CAsiNumeric & | operator= (const CAsiInt &)
CAsiNumeric & | operator= (const CAsiNumeric &)
CAsiNumeric & | operator= (const CAsiDecimal &)
CAsiNumeric & | operator= (const CAsiFloat &)
CAsiNumeric & | operator= (const CAsiReal &)
CAsiNumeric & | operator= (const CAsiDouble &)
CAsiNumeric & | operator= (const smallint)
CAsiNumeric & | operator= (const integer)
CAsiNumeric & | operator= (const real)
CAsiNumeric & | operator= (const int)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual real | realValue (void) const
virtual uint | ReturnLength (void) const
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiDataType | Type (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiExactNum
virtual EAsiBoolean | is_exactnumeric (void) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual | ~CAsiExactNum ()
- Public Member Functions inherited from CAsiNum
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

class | CAsiDecimal
CAsiDouble DLLScope | operator* (const CAsiSmallInt &, const CAsiNumeric &)
CAsiDouble DLLScope | operator* (const CAsiInt &, const CAsiNumeric &)
CAsiDouble DLLScope | operator* (const smallint, const CAsiNumeric &)
CAsiDouble DLLScope | operator* (const integer, const CAsiNumeric &)
CAsiDouble DLLScope | operator* (const real, const CAsiNumeric &)
CAsiDouble DLLScope | operator* (const int, const CAsiNumeric &)
CAsiDouble DLLScope | operator+ (const CAsiSmallInt &, const CAsiNumeric &)
CAsiDouble DLLScope | operator+ (const CAsiInt &, const CAsiNumeric &)
CAsiDouble DLLScope | operator+ (const smallint, const CAsiNumeric &)
CAsiDouble DLLScope | operator+ (const integer, const CAsiNumeric &)
CAsiDouble DLLScope | operator+ (const real, const CAsiNumeric &)
CAsiDouble DLLScope | operator+ (const int, const CAsiNumeric &)
CAsiDouble DLLScope | operator- (const CAsiSmallInt &, const CAsiNumeric &)
CAsiDouble DLLScope | operator- (const CAsiInt &, const CAsiNumeric &)
CAsiDouble DLLScope | operator- (const smallint, const CAsiNumeric &)
CAsiDouble DLLScope | operator- (const integer, const CAsiNumeric &)
CAsiDouble DLLScope | operator- (const real, const CAsiNumeric &)
CAsiDouble DLLScope | operator- (const int, const CAsiNumeric &)
CAsiDouble DLLScope | operator/ (const CAsiSmallInt &, const CAsiNumeric &)
CAsiDouble DLLScope | operator/ (const CAsiInt &, const CAsiNumeric &)
CAsiDouble DLLScope | operator/ (const smallint, const CAsiNumeric &)
CAsiDouble DLLScope | operator/ (const integer, const CAsiNumeric &)
CAsiDouble DLLScope | operator/ (const real, const CAsiNumeric &)
CAsiDouble DLLScope | operator/ (const int, const CAsiNumeric &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Member Functions inherited from CAsiExactNum
CAsiExactNum ()
int | cmpeqlan (const CAsiNum *) const
int | cmpeqlen (const CAsiExactNum *) const
int | cmpeqlenC (const real) const
int | cmpgtean (const CAsiNum *) const
int | cmpgteen (const CAsiExactNum *) const
int | cmpgteenC (const real) const
int | cmpgtran (const CAsiNum *) const
int | cmpgtren (const CAsiExactNum *) const
int | cmpgtrenC (const real) const
int | cmpltean (const CAsiNum *) const
int | cmplteen (const CAsiExactNum *) const
int | cmplteenC (const real) const
int | cmpltran (const CAsiNum *) const
int | cmpltren (const CAsiExactNum *) const
int | cmpltrenC (const real) const
int | cmpneqan (const CAsiNum *) const
int | cmpneqen (const CAsiExactNum *) const
int | cmpneqenC (const real) const
- Protected Attributes inherited from CAsiNum
uint | precision
uint | scale
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiNumeric Member List

This is the complete list of members for CAsiNumeric, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDecimal (defined in CAsiNumeric) | CAsiNumeric | friend
CAsiExactNum() | CAsiExactNum | protected
CAsiNum() | CAsiNum | protected
CAsiNumeric(uint, uint) (defined in CAsiNumeric) | CAsiNumeric |
CAsiNumeric(uint) (defined in CAsiNumeric) | CAsiNumeric |
CAsiNumeric(const CAsiNumeric &) (defined in CAsiNumeric) | CAsiNumeric |
CAsiNumeric(void) (defined in CAsiNumeric) | CAsiNumeric |
CAsiObject(void) | CAsiObject |
checkAdd(const CAsiData *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
checkMul(const CAsiData *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
checkSet(const CAsiData *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
checkSub(const CAsiData *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
Clear(void) | CAsiData | virtual
cmpeqlan(const CAsiNum *) const | CAsiExactNum | protected
cmpeqlen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpeqlenC(const real) const | CAsiExactNum | protected
cmpgtean(const CAsiNum *) const | CAsiExactNum | protected
cmpgteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgteenC(const real) const | CAsiExactNum | protected
cmpgtran(const CAsiNum *) const | CAsiExactNum | protected
cmpgtren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgtrenC(const real) const | CAsiExactNum | protected
cmpltean(const CAsiNum *) const | CAsiExactNum | protected
cmplteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmplteenC(const real) const | CAsiExactNum | protected
cmpltran(const CAsiNum *) const | CAsiExactNum | protected
cmpltren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpltrenC(const real) const | CAsiExactNum | protected
cmpneqan(const CAsiNum *) const | CAsiExactNum | protected
cmpneqen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpneqenC(const real) const | CAsiExactNum | protected
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiNumeric) | CAsiNumeric | virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
getValue(integer *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
getValue(smallint *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
getValue(char *, uint) const (defined in CAsiNumeric) | CAsiNumeric | virtual
getValue(CAsiUcStr *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
getValue(DB_NUMERIC *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
getValue(char *, uint, uint *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
getValue(AsiUcStr, uint) const (defined in CAsiNumeric) | CAsiNumeric | virtual
getValue(CAsiData &) const (defined in CAsiNumeric) | CAsiNumeric | virtual
CAsiExactNum::getValue(DECIMAL *) const | CAsiData | virtual
CAsiExactNum::getValue(DBDATE *) const | CAsiData | virtual
CAsiExactNum::getValue(DBTIME *) const | CAsiData | virtual
CAsiExactNum::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const (defined in CAsiNumeric) | CAsiNumeric | virtual
is_approxnumeric(void) const | CAsiNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiExactNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiNumeric) | CAsiNumeric | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiNumeric) | CAsiNumeric | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator!=(const CAsiInt &) const | CAsiExactNum | virtual
operator!=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator!=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator!=(const CAsiFloat &) const | CAsiExactNum | virtual
operator!=(const CAsiReal &) const | CAsiExactNum | virtual
operator!=(const CAsiDouble &) const | CAsiExactNum | virtual
operator!=(const smallint) const | CAsiExactNum | virtual
operator!=(const integer) const | CAsiExactNum | virtual
operator!=(const real) const | CAsiExactNum | virtual
operator!=(const int) const | CAsiExactNum | virtual
operator*(const CAsiSmallInt &) const (defined in CAsiNumeric) | CAsiNumeric |
operator*(const CAsiInt &) const (defined in CAsiNumeric) | CAsiNumeric |
operator*(const CAsiNumeric &) const (defined in CAsiNumeric) | CAsiNumeric |
operator* (defined in CAsiNumeric) | CAsiNumeric | friend
operator* (defined in CAsiNumeric) | CAsiNumeric | friend
operator*(const smallint) const (defined in CAsiNumeric) | CAsiNumeric |
operator*(const integer) const (defined in CAsiNumeric) | CAsiNumeric |
operator*(const real) const (defined in CAsiNumeric) | CAsiNumeric |
operator*(const int) const (defined in CAsiNumeric) | CAsiNumeric |
operator* (defined in CAsiNumeric) | CAsiNumeric | friend
operator* (defined in CAsiNumeric) | CAsiNumeric | friend
operator* (defined in CAsiNumeric) | CAsiNumeric | friend
operator* (defined in CAsiNumeric) | CAsiNumeric | friend
operator*=(const CAsiSmallInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const CAsiInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const CAsiNumeric &) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const CAsiDecimal &) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const CAsiFloat &) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const CAsiReal &) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const CAsiDouble &) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const smallint) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const integer) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const real) (defined in CAsiNumeric) | CAsiNumeric |
operator*=(const int) (defined in CAsiNumeric) | CAsiNumeric |
operator+(const CAsiSmallInt &) const (defined in CAsiNumeric) | CAsiNumeric |
operator+(const CAsiInt &) const (defined in CAsiNumeric) | CAsiNumeric |
operator+(const CAsiNumeric &) const (defined in CAsiNumeric) | CAsiNumeric |
operator+ (defined in CAsiNumeric) | CAsiNumeric | friend
operator+ (defined in CAsiNumeric) | CAsiNumeric | friend
operator+(const smallint) const (defined in CAsiNumeric) | CAsiNumeric |
operator+(const integer) const (defined in CAsiNumeric) | CAsiNumeric |
operator+(const real) const (defined in CAsiNumeric) | CAsiNumeric |
operator+(const int) const (defined in CAsiNumeric) | CAsiNumeric |
operator+ (defined in CAsiNumeric) | CAsiNumeric | friend
operator+ (defined in CAsiNumeric) | CAsiNumeric | friend
operator+ (defined in CAsiNumeric) | CAsiNumeric | friend
operator+ (defined in CAsiNumeric) | CAsiNumeric | friend
operator++(void) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const CAsiSmallInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const CAsiInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const CAsiNumeric &) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const CAsiDecimal &) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const CAsiFloat &) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const CAsiReal &) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const CAsiDouble &) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const smallint) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const integer) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const real) (defined in CAsiNumeric) | CAsiNumeric |
operator+=(const int) (defined in CAsiNumeric) | CAsiNumeric |
operator-(const CAsiSmallInt &) const (defined in CAsiNumeric) | CAsiNumeric |
operator-(const CAsiInt &) const (defined in CAsiNumeric) | CAsiNumeric |
operator-(const CAsiNumeric &) const (defined in CAsiNumeric) | CAsiNumeric |
operator- (defined in CAsiNumeric) | CAsiNumeric | friend
operator- (defined in CAsiNumeric) | CAsiNumeric | friend
operator-(const smallint) const (defined in CAsiNumeric) | CAsiNumeric |
operator-(const integer) const (defined in CAsiNumeric) | CAsiNumeric |
operator-(const real) const (defined in CAsiNumeric) | CAsiNumeric |
operator-(const int) const (defined in CAsiNumeric) | CAsiNumeric |
operator- (defined in CAsiNumeric) | CAsiNumeric | friend
operator- (defined in CAsiNumeric) | CAsiNumeric | friend
operator- (defined in CAsiNumeric) | CAsiNumeric | friend
operator- (defined in CAsiNumeric) | CAsiNumeric | friend
operator-(void) (defined in CAsiNumeric) | CAsiNumeric |
operator--(void) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const CAsiSmallInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const CAsiInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const CAsiNumeric &) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const CAsiDecimal &) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const CAsiFloat &) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const CAsiReal &) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const CAsiDouble &) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const smallint) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const integer) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const real) (defined in CAsiNumeric) | CAsiNumeric |
operator-=(const int) (defined in CAsiNumeric) | CAsiNumeric |
operator/(const CAsiSmallInt &) const (defined in CAsiNumeric) | CAsiNumeric |
operator/(const CAsiInt &) const (defined in CAsiNumeric) | CAsiNumeric |
operator/(const CAsiNumeric &) const (defined in CAsiNumeric) | CAsiNumeric |
operator/ (defined in CAsiNumeric) | CAsiNumeric | friend
operator/ (defined in CAsiNumeric) | CAsiNumeric | friend
operator/(const smallint) const (defined in CAsiNumeric) | CAsiNumeric |
operator/(const integer) const (defined in CAsiNumeric) | CAsiNumeric |
operator/(const real) const (defined in CAsiNumeric) | CAsiNumeric |
operator/(const int) const (defined in CAsiNumeric) | CAsiNumeric |
operator/ (defined in CAsiNumeric) | CAsiNumeric | friend
operator/ (defined in CAsiNumeric) | CAsiNumeric | friend
operator/ (defined in CAsiNumeric) | CAsiNumeric | friend
operator/ (defined in CAsiNumeric) | CAsiNumeric | friend
operator/=(const CAsiSmallInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const CAsiInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const CAsiNumeric &) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const CAsiDecimal &) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const CAsiFloat &) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const CAsiReal &) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const CAsiDouble &) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const smallint) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const integer) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const real) (defined in CAsiNumeric) | CAsiNumeric |
operator/=(const int) (defined in CAsiNumeric) | CAsiNumeric |
operator<(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<(const CAsiInt &) const | CAsiExactNum | virtual
operator<(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<(const CAsiFloat &) const | CAsiExactNum | virtual
operator<(const CAsiReal &) const | CAsiExactNum | virtual
operator<(const CAsiDouble &) const | CAsiExactNum | virtual
operator<(const smallint) const | CAsiExactNum | virtual
operator<(const integer) const | CAsiExactNum | virtual
operator<(const real) const | CAsiExactNum | virtual
operator<(const int) const | CAsiExactNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<=(const CAsiInt &) const | CAsiExactNum | virtual
operator<=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<=(const CAsiFloat &) const | CAsiExactNum | virtual
operator<=(const CAsiReal &) const | CAsiExactNum | virtual
operator<=(const CAsiDouble &) const | CAsiExactNum | virtual
operator<=(const smallint) const | CAsiExactNum | virtual
operator<=(const integer) const | CAsiExactNum | virtual
operator<=(const real) const | CAsiExactNum | virtual
operator<=(const int) const | CAsiExactNum | virtual
operator=(const CAsiSmallInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const CAsiInt &) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const CAsiNumeric &) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const CAsiDecimal &) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const CAsiFloat &) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const CAsiReal &) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const CAsiDouble &) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const smallint) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const integer) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const real) (defined in CAsiNumeric) | CAsiNumeric |
operator=(const int) (defined in CAsiNumeric) | CAsiNumeric |
operator==(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator==(const CAsiInt &) const | CAsiExactNum | virtual
operator==(const CAsiNumeric &) const | CAsiExactNum | virtual
operator==(const CAsiDecimal &) const | CAsiExactNum | virtual
operator==(const CAsiFloat &) const | CAsiExactNum | virtual
operator==(const CAsiReal &) const | CAsiExactNum | virtual
operator==(const CAsiDouble &) const | CAsiExactNum | virtual
operator==(const smallint) const | CAsiExactNum | virtual
operator==(const integer) const | CAsiExactNum | virtual
operator==(const real) const | CAsiExactNum | virtual
operator==(const int) const | CAsiExactNum | virtual
operator>(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>(const CAsiInt &) const | CAsiExactNum | virtual
operator>(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>(const CAsiFloat &) const | CAsiExactNum | virtual
operator>(const CAsiReal &) const | CAsiExactNum | virtual
operator>(const CAsiDouble &) const | CAsiExactNum | virtual
operator>(const smallint) const | CAsiExactNum | virtual
operator>(const integer) const | CAsiExactNum | virtual
operator>(const real) const | CAsiExactNum | virtual
operator>(const int) const | CAsiExactNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>=(const CAsiInt &) const | CAsiExactNum | virtual
operator>=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>=(const CAsiFloat &) const | CAsiExactNum | virtual
operator>=(const CAsiReal &) const | CAsiExactNum | virtual
operator>=(const CAsiDouble &) const | CAsiExactNum | virtual
operator>=(const smallint) const | CAsiExactNum | virtual
operator>=(const integer) const | CAsiExactNum | virtual
operator>=(const real) const | CAsiExactNum | virtual
operator>=(const int) const | CAsiExactNum | virtual
packSize(void) const (defined in CAsiNumeric) | CAsiNumeric | virtual
packTo(CAsiObjPack *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
packValueSize(void) const (defined in CAsiNumeric) | CAsiNumeric | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
Precision(void) const | CAsiNum | virtual
precision (defined in CAsiNum) | CAsiNum | protected
realValue(void) const (defined in CAsiNumeric) | CAsiNumeric | virtual
ReturnLength(void) const (defined in CAsiNumeric) | CAsiNumeric | virtual
Scale(void) const | CAsiNum | virtual
scale (defined in CAsiNum) | CAsiNum | protected
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
SQLType(CAsiUcStr *) const (defined in CAsiNumeric) | CAsiNumeric | virtual
storeValue(real) (defined in CAsiNumeric) | CAsiNumeric | virtual
storeValue(integer) (defined in CAsiNumeric) | CAsiNumeric | virtual
storeValue(smallint) (defined in CAsiNumeric) | CAsiNumeric | virtual
storeValue(char *, uint) (defined in CAsiNumeric) | CAsiNumeric | virtual
storeValue(const CAsiUcStr &) (defined in CAsiNumeric) | CAsiNumeric | virtual
storeValue(const CAsiData &) (defined in CAsiNumeric) | CAsiNumeric | virtual
storeValue(const DB_NUMERIC *) (defined in CAsiNumeric) | CAsiNumeric | virtual
storeValue(char *, uint, uint *) (defined in CAsiNumeric) | CAsiNumeric | virtual
storeValue(const AsiUcStr) (defined in CAsiNumeric) | CAsiNumeric | virtual
CAsiExactNum::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiExactNum::storeValue(const DBDATE *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBTIME *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiNumeric) | CAsiNumeric | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiNumeric) | CAsiNumeric | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiNumeric) | CAsiNumeric | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiExactNum() | CAsiExactNum | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiNumeric(void) (defined in CAsiNumeric) | CAsiNumeric | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiObject Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAsiObject Class Reference
Misc Classes
+ Inheritance diagram for CAsiObject:

Public Member Functions

CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Constructor & Destructor Documentation

CAsiObject::CAsiObject ( void )
Warning
Not implemented!
virtual CAsiObject::~CAsiObject ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual void CAsiObject::Clear ( void )
virtual
Warning
Not implemented!

Reimplemented in CAsiData, and CAsiIdent.

virtual CAsiObject* CAsiObject::duplicate ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt, CAsiTACond, CAsiData, CAsiIdent, and CAsiException.

void CAsiObject::operator delete ( void * )
Warning
Not implemented!
void* CAsiObject::operator new ( size_t )
Warning
Not implemented!
virtual unsigned long CAsiObject::packSize ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt, and CAsiIdent.

virtual unsigned long CAsiObject::packTo ( CAsiObjPack * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt, and CAsiIdent.

virtual unsigned long CAsiObject::packValueSize ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual unsigned long CAsiObject::packValueTo ( CAsiObjPack * ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

virtual EAsiBoolean CAsiObject::unpackFrom ( CAsiObjPack * )
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt, and CAsiIdent.

virtual EAsiBoolean CAsiObject::unpackValueFrom ( CAsiObjPack * )
virtual
Warning
Not implemented!

Reimplemented in CAsiSmallInt.

The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiObject Member List

This is the complete list of members for CAsiObject, including all inherited members.

CAsiObject(void) | CAsiObject |
Clear(void) | CAsiObject | virtual
duplicate(void) const | CAsiObject | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiObject(void) | CAsiObject | virtual


ZRX API Reference: CAsiParameter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
CAsiParameter Class Reference
Misc Classes
+ Inheritance diagram for CAsiParameter:

Public Member Functions

CAsiParameter (const DBPARAMINFO *)
CAsiData * | Dsc (void) const
EAsiBoolean | isNullable (void) const
const CAsiIdent & | Name (void) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
void | setDsc (CAsiData *)
void | setName (const CAsiIdent &)
void | setNullable (EAsiBoolean)
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiHostBuffer
virtual EAsiBoolean | getBind (CAsiData **) const
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

virtual EAsiBoolean setBind (CAsiData *)

Friends

class | CAsiDDAParams
class | CAsiEmulCursor
class | CAsiEmulTable
class | CAsiHostLink
class | CAsiInterDBCursor
class | CAsiParser
class | CAsiStm

Additional Inherited Members

- Protected Attributes inherited from CAsiHostBuffer
CAsiData * pData
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiParameter Member List

This is the complete list of members for CAsiParameter, including all inherited members.

CAsiDDAParams (defined in CAsiParameter) | CAsiParameter | friend
CAsiEmulCursor (defined in CAsiParameter) | CAsiParameter | friend
CAsiEmulTable (defined in CAsiParameter) | CAsiParameter | friend
CAsiHostBuffer() (defined in CAsiHostBuffer) | CAsiHostBuffer |
CAsiHostLink (defined in CAsiParameter) | CAsiParameter | friend
CAsiInterDBCursor (defined in CAsiParameter) | CAsiParameter | friend
CAsiObject(void) | CAsiObject |
CAsiParameter() (defined in CAsiParameter) | CAsiParameter |
CAsiParameter(const DBPARAMINFO *) (defined in CAsiParameter) | CAsiParameter |
CAsiParser (defined in CAsiParameter) | CAsiParameter | friend
CAsiStm (defined in CAsiParameter) | CAsiParameter | friend
Dsc(void) const (defined in CAsiParameter) | CAsiParameter |
getBind(CAsiData **) const (defined in CAsiHostBuffer) | CAsiHostBuffer | virtual
isNullable(void) const (defined in CAsiParameter) | CAsiParameter |
Name(void) const (defined in CAsiParameter) | CAsiParameter |
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const (defined in CAsiParameter) | CAsiParameter | virtual
packTo(CAsiObjPack *) const (defined in CAsiParameter) | CAsiParameter | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
pData (defined in CAsiHostBuffer) | CAsiHostBuffer | protected
setBind(CAsiData *) (defined in CAsiParameter) | CAsiParameter | protectedvirtual
setDsc(CAsiData *) (defined in CAsiParameter) | CAsiParameter |
setName(const CAsiIdent &) (defined in CAsiParameter) | CAsiParameter |
setNullable(EAsiBoolean) (defined in CAsiParameter) | CAsiParameter |
unpackFrom(CAsiObjPack *) (defined in CAsiParameter) | CAsiParameter | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiHostBuffer() (defined in CAsiHostBuffer) | CAsiHostBuffer | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiParameter() (defined in CAsiParameter) | CAsiParameter | virtual


ZRX API Reference: CAsiReal Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiReal Class Reference
Misc Classes
+ Inheritance diagram for CAsiReal:

Public Member Functions

CAsiReal (const CAsiReal &)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual CAsiObject * | duplicate (void) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual integer | intValue (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
CAsiReal | operator* (const CAsiSmallInt &) const
CAsiReal | operator* (const CAsiInt &) const
CAsiReal | operator* (const CAsiNumeric &) const
CAsiReal | operator* (const CAsiDecimal &) const
CAsiReal | operator* (const CAsiFloat &) const
CAsiReal | operator* (const CAsiReal &) const
CAsiReal | operator* (const smallint) const
CAsiReal | operator* (const integer) const
CAsiReal | operator* (const real) const
CAsiReal | operator* (const int) const
CAsiReal & | operator*= (const CAsiSmallInt &)
CAsiReal & | operator*= (const CAsiInt &)
CAsiReal & | operator*= (const CAsiNumeric &)
CAsiReal & | operator*= (const CAsiDecimal &)
CAsiReal & | operator*= (const CAsiFloat &)
CAsiReal & | operator*= (const CAsiReal &)
CAsiReal & | operator*= (const CAsiDouble &)
CAsiReal & | operator*= (const smallint)
CAsiReal & | operator*= (const integer)
CAsiReal & | operator*= (const real)
CAsiReal & | operator*= (const int)
CAsiReal | operator+ (const CAsiSmallInt &) const
CAsiReal | operator+ (const CAsiInt &) const
CAsiReal | operator+ (const CAsiNumeric &) const
CAsiReal | operator+ (const CAsiDecimal &) const
CAsiReal | operator+ (const CAsiFloat &) const
CAsiReal | operator+ (const CAsiReal &) const
CAsiReal | operator+ (const smallint) const
CAsiReal | operator+ (const integer) const
CAsiReal | operator+ (const real) const
CAsiReal | operator+ (const int) const
CAsiReal & | operator++ (void)
CAsiReal & | operator+= (const CAsiSmallInt &)
CAsiReal & | operator+= (const CAsiInt &)
CAsiReal & | operator+= (const CAsiNumeric &)
CAsiReal & | operator+= (const CAsiDecimal &)
CAsiReal & | operator+= (const CAsiFloat &)
CAsiReal & | operator+= (const CAsiReal &)
CAsiReal & | operator+= (const CAsiDouble &)
CAsiReal & | operator+= (const smallint)
CAsiReal & | operator+= (const integer)
CAsiReal & | operator+= (const real)
CAsiReal & | operator+= (const int)
CAsiReal | operator- (const CAsiSmallInt &) const
CAsiReal | operator- (const CAsiInt &) const
CAsiReal | operator- (const CAsiNumeric &) const
CAsiReal | operator- (const CAsiDecimal &) const
CAsiReal | operator- (const CAsiFloat &) const
CAsiReal | operator- (const CAsiReal &) const
CAsiReal | operator- (const smallint) const
CAsiReal | operator- (const integer) const
CAsiReal | operator- (const real) const
CAsiReal | operator- (const int) const
CAsiReal & | operator- (void)
CAsiReal & | operator-- (void)
CAsiReal & | operator-= (const CAsiSmallInt &)
CAsiReal & | operator-= (const CAsiInt &)
CAsiReal & | operator-= (const CAsiNumeric &)
CAsiReal & | operator-= (const CAsiDecimal &)
CAsiReal & | operator-= (const CAsiFloat &)
CAsiReal & | operator-= (const CAsiReal &)
CAsiReal & | operator-= (const CAsiDouble &)
CAsiReal & | operator-= (const smallint)
CAsiReal & | operator-= (const integer)
CAsiReal & | operator-= (const real)
CAsiReal & | operator-= (const int)
CAsiReal | operator/ (const CAsiSmallInt &) const
CAsiReal | operator/ (const CAsiInt &) const
CAsiReal | operator/ (const CAsiNumeric &) const
CAsiReal | operator/ (const CAsiDecimal &) const
CAsiReal | operator/ (const CAsiFloat &) const
CAsiReal | operator/ (const CAsiReal &) const
CAsiReal | operator/ (const smallint) const
CAsiReal | operator/ (const integer) const
CAsiReal | operator/ (const real) const
CAsiReal | operator/ (const int) const
CAsiReal & | operator/= (const CAsiSmallInt &)
CAsiReal & | operator/= (const CAsiInt &)
CAsiReal & | operator/= (const CAsiNumeric &)
CAsiReal & | operator/= (const CAsiDecimal &)
CAsiReal & | operator/= (const CAsiFloat &)
CAsiReal & | operator/= (const CAsiReal &)
CAsiReal & | operator/= (const CAsiDouble &)
CAsiReal & | operator/= (const smallint)
CAsiReal & | operator/= (const integer)
CAsiReal & | operator/= (const real)
CAsiReal & | operator/= (const int)
CAsiReal & | operator= (const CAsiSmallInt &)
CAsiReal & | operator= (const CAsiInt &)
CAsiReal & | operator= (const CAsiNumeric &)
CAsiReal & | operator= (const CAsiDecimal &)
CAsiReal & | operator= (const CAsiFloat &)
CAsiReal & | operator= (const CAsiReal &)
CAsiReal & | operator= (const CAsiDouble &)
CAsiReal & | operator= (const smallint)
CAsiReal & | operator= (const integer)
CAsiReal & | operator= (const real)
CAsiReal & | operator= (const int)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual real | realValue (void) const
virtual uint | ReturnLength (void) const
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiDataType | Type (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiApproxNum
virtual EAsiBoolean | is_approxnumeric (void) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual | ~CAsiApproxNum ()
- Public Member Functions inherited from CAsiNum
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

CAsiReal DLLScope | operator* (const CAsiSmallInt &, const CAsiReal &)
CAsiReal DLLScope | operator* (const CAsiInt &, const CAsiReal &)
CAsiReal DLLScope | operator* (const CAsiNumeric &, const CAsiReal &)
CAsiReal DLLScope | operator* (const CAsiDecimal &, const CAsiReal &)
CAsiReal DLLScope | operator* (const CAsiFloat &, const CAsiReal &)
CAsiReal DLLScope | operator* (const smallint, const CAsiReal &)
CAsiReal DLLScope | operator* (const integer, const CAsiReal &)
CAsiReal DLLScope | operator* (const real, const CAsiReal &)
CAsiReal DLLScope | operator* (const int, const CAsiReal &)
CAsiReal DLLScope | operator+ (const CAsiSmallInt &, const CAsiReal &)
CAsiReal DLLScope | operator+ (const CAsiInt &, const CAsiReal &)
CAsiReal DLLScope | operator+ (const CAsiNumeric &, const CAsiReal &)
CAsiReal DLLScope | operator+ (const CAsiDecimal &, const CAsiReal &)
CAsiReal DLLScope | operator+ (const CAsiFloat &, const CAsiReal &)
CAsiReal DLLScope | operator+ (const smallint, const CAsiReal &)
CAsiReal DLLScope | operator+ (const integer, const CAsiReal &)
CAsiReal DLLScope | operator+ (const real, const CAsiReal &)
CAsiReal DLLScope | operator+ (const int, const CAsiReal &)
CAsiReal DLLScope | operator- (const CAsiSmallInt &, const CAsiReal &)
CAsiReal DLLScope | operator- (const CAsiInt &, const CAsiReal &)
CAsiReal DLLScope | operator- (const CAsiNumeric &, const CAsiReal &)
CAsiReal DLLScope | operator- (const CAsiDecimal &, const CAsiReal &)
CAsiReal DLLScope | operator- (const CAsiFloat &, const CAsiReal &)
CAsiReal DLLScope | operator- (const smallint, const CAsiReal &)
CAsiReal DLLScope | operator- (const integer, const CAsiReal &)
CAsiReal DLLScope | operator- (const real, const CAsiReal &)
CAsiReal DLLScope | operator- (const int, const CAsiReal &)
CAsiReal DLLScope | operator/ (const CAsiSmallInt &, const CAsiReal &)
CAsiReal DLLScope | operator/ (const CAsiInt &, const CAsiReal &)
CAsiReal DLLScope | operator/ (const CAsiNumeric &, const CAsiReal &)
CAsiReal DLLScope | operator/ (const CAsiDecimal &, const CAsiReal &)
CAsiReal DLLScope | operator/ (const CAsiFloat &, const CAsiReal &)
CAsiReal DLLScope | operator/ (const smallint, const CAsiReal &)
CAsiReal DLLScope | operator/ (const integer, const CAsiReal &)
CAsiReal DLLScope | operator/ (const real, const CAsiReal &)
CAsiReal DLLScope | operator/ (const int, const CAsiReal &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Member Functions inherited from CAsiNum
CAsiNum ()
- Protected Attributes inherited from CAsiNum
uint | precision
uint | scale
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiReal Member List

This is the complete list of members for CAsiReal, including all inherited members.

CAsiApproxNum() (defined in CAsiApproxNum) | CAsiApproxNum | protected
CAsiData(void) | CAsiData |
CAsiNum() | CAsiNum | protected
CAsiObject(void) | CAsiObject |
CAsiReal(void) (defined in CAsiReal) | CAsiReal |
CAsiReal(const CAsiReal &) (defined in CAsiReal) | CAsiReal |
checkAdd(const CAsiData *) const (defined in CAsiReal) | CAsiReal | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const (defined in CAsiReal) | CAsiReal | virtual
checkMul(const CAsiData *) const (defined in CAsiReal) | CAsiReal | virtual
checkSet(const CAsiData *) const (defined in CAsiReal) | CAsiReal | virtual
checkSub(const CAsiData *) const (defined in CAsiReal) | CAsiReal | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiReal) | CAsiReal | virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const (defined in CAsiReal) | CAsiReal | virtual
getValue(integer *) const (defined in CAsiReal) | CAsiReal | virtual
getValue(smallint *) const (defined in CAsiReal) | CAsiReal | virtual
getValue(char *, uint) const (defined in CAsiReal) | CAsiReal | virtual
getValue(CAsiUcStr *) const (defined in CAsiReal) | CAsiReal | virtual
getValue(char *, uint, uint *) const (defined in CAsiReal) | CAsiReal | virtual
getValue(AsiUcStr, uint) const (defined in CAsiReal) | CAsiReal | virtual
getValue(CAsiData &) const (defined in CAsiReal) | CAsiReal | virtual
CAsiApproxNum::getValue(DECIMAL *) const | CAsiData | virtual
CAsiApproxNum::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiApproxNum::getValue(DBDATE *) const | CAsiData | virtual
CAsiApproxNum::getValue(DBTIME *) const | CAsiData | virtual
CAsiApproxNum::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const (defined in CAsiReal) | CAsiReal | virtual
is_approxnumeric(void) const | CAsiApproxNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiReal) | CAsiReal | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiReal) | CAsiReal | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiReal) | CAsiReal | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiReal) | CAsiReal | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator!=(const CAsiInt &) const | CAsiApproxNum | virtual
operator!=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator!=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator!=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator!=(const CAsiReal &) const | CAsiApproxNum | virtual
operator!=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator!=(const smallint) const | CAsiApproxNum | virtual
operator!=(const integer) const | CAsiApproxNum | virtual
operator!=(const real) const | CAsiApproxNum | virtual
operator!=(const int) const | CAsiApproxNum | virtual
operator*(const CAsiSmallInt &) const (defined in CAsiReal) | CAsiReal |
operator*(const CAsiInt &) const (defined in CAsiReal) | CAsiReal |
operator*(const CAsiNumeric &) const (defined in CAsiReal) | CAsiReal |
operator*(const CAsiDecimal &) const (defined in CAsiReal) | CAsiReal |
operator*(const CAsiFloat &) const (defined in CAsiReal) | CAsiReal |
operator*(const CAsiReal &) const (defined in CAsiReal) | CAsiReal |
operator* (defined in CAsiReal) | CAsiReal | friend
operator* (defined in CAsiReal) | CAsiReal | friend
operator* (defined in CAsiReal) | CAsiReal | friend
operator* (defined in CAsiReal) | CAsiReal | friend
operator* (defined in CAsiReal) | CAsiReal | friend
operator*(const smallint) const (defined in CAsiReal) | CAsiReal |
operator*(const integer) const (defined in CAsiReal) | CAsiReal |
operator*(const real) const (defined in CAsiReal) | CAsiReal |
operator* (defined in CAsiReal) | CAsiReal | friend
operator* (defined in CAsiReal) | CAsiReal | friend
operator* (defined in CAsiReal) | CAsiReal | friend
operator*(const int) const (defined in CAsiReal) | CAsiReal |
operator* (defined in CAsiReal) | CAsiReal | friend
operator*=(const CAsiSmallInt &) (defined in CAsiReal) | CAsiReal |
operator*=(const CAsiInt &) (defined in CAsiReal) | CAsiReal |
operator*=(const CAsiNumeric &) (defined in CAsiReal) | CAsiReal |
operator*=(const CAsiDecimal &) (defined in CAsiReal) | CAsiReal |
operator*=(const CAsiFloat &) (defined in CAsiReal) | CAsiReal |
operator*=(const CAsiReal &) (defined in CAsiReal) | CAsiReal |
operator*=(const CAsiDouble &) (defined in CAsiReal) | CAsiReal |
operator*=(const smallint) (defined in CAsiReal) | CAsiReal |
operator*=(const integer) (defined in CAsiReal) | CAsiReal |
operator*=(const real) (defined in CAsiReal) | CAsiReal |
operator*=(const int) (defined in CAsiReal) | CAsiReal |
operator+(const CAsiSmallInt &) const (defined in CAsiReal) | CAsiReal |
operator+(const CAsiInt &) const (defined in CAsiReal) | CAsiReal |
operator+(const CAsiNumeric &) const (defined in CAsiReal) | CAsiReal |
operator+(const CAsiDecimal &) const (defined in CAsiReal) | CAsiReal |
operator+(const CAsiFloat &) const (defined in CAsiReal) | CAsiReal |
operator+(const CAsiReal &) const (defined in CAsiReal) | CAsiReal |
operator+ (defined in CAsiReal) | CAsiReal | friend
operator+ (defined in CAsiReal) | CAsiReal | friend
operator+ (defined in CAsiReal) | CAsiReal | friend
operator+ (defined in CAsiReal) | CAsiReal | friend
operator+ (defined in CAsiReal) | CAsiReal | friend
operator+(const smallint) const (defined in CAsiReal) | CAsiReal |
operator+(const integer) const (defined in CAsiReal) | CAsiReal |
operator+(const real) const (defined in CAsiReal) | CAsiReal |
operator+ (defined in CAsiReal) | CAsiReal | friend
operator+ (defined in CAsiReal) | CAsiReal | friend
operator+ (defined in CAsiReal) | CAsiReal | friend
operator+(const int) const (defined in CAsiReal) | CAsiReal |
operator+ (defined in CAsiReal) | CAsiReal | friend
operator++(void) (defined in CAsiReal) | CAsiReal |
operator+=(const CAsiSmallInt &) (defined in CAsiReal) | CAsiReal |
operator+=(const CAsiInt &) (defined in CAsiReal) | CAsiReal |
operator+=(const CAsiNumeric &) (defined in CAsiReal) | CAsiReal |
operator+=(const CAsiDecimal &) (defined in CAsiReal) | CAsiReal |
operator+=(const CAsiFloat &) (defined in CAsiReal) | CAsiReal |
operator+=(const CAsiReal &) (defined in CAsiReal) | CAsiReal |
operator+=(const CAsiDouble &) (defined in CAsiReal) | CAsiReal |
operator+=(const smallint) (defined in CAsiReal) | CAsiReal |
operator+=(const integer) (defined in CAsiReal) | CAsiReal |
operator+=(const real) (defined in CAsiReal) | CAsiReal |
operator+=(const int) (defined in CAsiReal) | CAsiReal |
operator-(const CAsiSmallInt &) const (defined in CAsiReal) | CAsiReal |
operator-(const CAsiInt &) const (defined in CAsiReal) | CAsiReal |
operator-(const CAsiNumeric &) const (defined in CAsiReal) | CAsiReal |
operator-(const CAsiDecimal &) const (defined in CAsiReal) | CAsiReal |
operator-(const CAsiFloat &) const (defined in CAsiReal) | CAsiReal |
operator-(const CAsiReal &) const (defined in CAsiReal) | CAsiReal |
operator- (defined in CAsiReal) | CAsiReal | friend
operator- (defined in CAsiReal) | CAsiReal | friend
operator- (defined in CAsiReal) | CAsiReal | friend
operator- (defined in CAsiReal) | CAsiReal | friend
operator- (defined in CAsiReal) | CAsiReal | friend
operator-(const smallint) const (defined in CAsiReal) | CAsiReal |
operator-(const integer) const (defined in CAsiReal) | CAsiReal |
operator-(const real) const (defined in CAsiReal) | CAsiReal |
operator- (defined in CAsiReal) | CAsiReal | friend
operator- (defined in CAsiReal) | CAsiReal | friend
operator- (defined in CAsiReal) | CAsiReal | friend
operator-(const int) const (defined in CAsiReal) | CAsiReal |
operator- (defined in CAsiReal) | CAsiReal | friend
operator-(void) (defined in CAsiReal) | CAsiReal |
operator--(void) (defined in CAsiReal) | CAsiReal |
operator-=(const CAsiSmallInt &) (defined in CAsiReal) | CAsiReal |
operator-=(const CAsiInt &) (defined in CAsiReal) | CAsiReal |
operator-=(const CAsiNumeric &) (defined in CAsiReal) | CAsiReal |
operator-=(const CAsiDecimal &) (defined in CAsiReal) | CAsiReal |
operator-=(const CAsiFloat &) (defined in CAsiReal) | CAsiReal |
operator-=(const CAsiReal &) (defined in CAsiReal) | CAsiReal |
operator-=(const CAsiDouble &) (defined in CAsiReal) | CAsiReal |
operator-=(const smallint) (defined in CAsiReal) | CAsiReal |
operator-=(const integer) (defined in CAsiReal) | CAsiReal |
operator-=(const real) (defined in CAsiReal) | CAsiReal |
operator-=(const int) (defined in CAsiReal) | CAsiReal |
operator/(const CAsiSmallInt &) const (defined in CAsiReal) | CAsiReal |
operator/(const CAsiInt &) const (defined in CAsiReal) | CAsiReal |
operator/(const CAsiNumeric &) const (defined in CAsiReal) | CAsiReal |
operator/(const CAsiDecimal &) const (defined in CAsiReal) | CAsiReal |
operator/(const CAsiFloat &) const (defined in CAsiReal) | CAsiReal |
operator/(const CAsiReal &) const (defined in CAsiReal) | CAsiReal |
operator/ (defined in CAsiReal) | CAsiReal | friend
operator/ (defined in CAsiReal) | CAsiReal | friend
operator/ (defined in CAsiReal) | CAsiReal | friend
operator/ (defined in CAsiReal) | CAsiReal | friend
operator/ (defined in CAsiReal) | CAsiReal | friend
operator/(const smallint) const (defined in CAsiReal) | CAsiReal |
operator/(const integer) const (defined in CAsiReal) | CAsiReal |
operator/(const real) const (defined in CAsiReal) | CAsiReal |
operator/ (defined in CAsiReal) | CAsiReal | friend
operator/ (defined in CAsiReal) | CAsiReal | friend
operator/ (defined in CAsiReal) | CAsiReal | friend
operator/(const int) const (defined in CAsiReal) | CAsiReal |
operator/ (defined in CAsiReal) | CAsiReal | friend
operator/=(const CAsiSmallInt &) (defined in CAsiReal) | CAsiReal |
operator/=(const CAsiInt &) (defined in CAsiReal) | CAsiReal |
operator/=(const CAsiNumeric &) (defined in CAsiReal) | CAsiReal |
operator/=(const CAsiDecimal &) (defined in CAsiReal) | CAsiReal |
operator/=(const CAsiFloat &) (defined in CAsiReal) | CAsiReal |
operator/=(const CAsiReal &) (defined in CAsiReal) | CAsiReal |
operator/=(const CAsiDouble &) (defined in CAsiReal) | CAsiReal |
operator/=(const smallint) (defined in CAsiReal) | CAsiReal |
operator/=(const integer) (defined in CAsiReal) | CAsiReal |
operator/=(const real) (defined in CAsiReal) | CAsiReal |
operator/=(const int) (defined in CAsiReal) | CAsiReal |
operator<(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator<(const CAsiInt &) const | CAsiApproxNum | virtual
operator<(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator<(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator<(const CAsiFloat &) const | CAsiApproxNum | virtual
operator<(const CAsiReal &) const | CAsiApproxNum | virtual
operator<(const CAsiDouble &) const | CAsiApproxNum | virtual
operator<(const smallint) const | CAsiApproxNum | virtual
operator<(const integer) const | CAsiApproxNum | virtual
operator<(const real) const | CAsiApproxNum | virtual
operator<(const int) const | CAsiApproxNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator<=(const CAsiInt &) const | CAsiApproxNum | virtual
operator<=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator<=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator<=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator<=(const CAsiReal &) const | CAsiApproxNum | virtual
operator<=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator<=(const smallint) const | CAsiApproxNum | virtual
operator<=(const integer) const | CAsiApproxNum | virtual
operator<=(const real) const | CAsiApproxNum | virtual
operator<=(const int) const | CAsiApproxNum | virtual
operator=(const CAsiSmallInt &) (defined in CAsiReal) | CAsiReal |
operator=(const CAsiInt &) (defined in CAsiReal) | CAsiReal |
operator=(const CAsiNumeric &) (defined in CAsiReal) | CAsiReal |
operator=(const CAsiDecimal &) (defined in CAsiReal) | CAsiReal |
operator=(const CAsiFloat &) (defined in CAsiReal) | CAsiReal |
operator=(const CAsiReal &) (defined in CAsiReal) | CAsiReal |
operator=(const CAsiDouble &) (defined in CAsiReal) | CAsiReal |
operator=(const smallint) (defined in CAsiReal) | CAsiReal |
operator=(const integer) (defined in CAsiReal) | CAsiReal |
operator=(const real) (defined in CAsiReal) | CAsiReal |
operator=(const int) (defined in CAsiReal) | CAsiReal |
operator==(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator==(const CAsiInt &) const | CAsiApproxNum | virtual
operator==(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator==(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator==(const CAsiFloat &) const | CAsiApproxNum | virtual
operator==(const CAsiReal &) const | CAsiApproxNum | virtual
operator==(const CAsiDouble &) const | CAsiApproxNum | virtual
operator==(const smallint) const | CAsiApproxNum | virtual
operator==(const integer) const | CAsiApproxNum | virtual
operator==(const real) const | CAsiApproxNum | virtual
operator==(const int) const | CAsiApproxNum | virtual
operator>(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator>(const CAsiInt &) const | CAsiApproxNum | virtual
operator>(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator>(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator>(const CAsiFloat &) const | CAsiApproxNum | virtual
operator>(const CAsiReal &) const | CAsiApproxNum | virtual
operator>(const CAsiDouble &) const | CAsiApproxNum | virtual
operator>(const smallint) const | CAsiApproxNum | virtual
operator>(const integer) const | CAsiApproxNum | virtual
operator>(const real) const | CAsiApproxNum | virtual
operator>(const int) const | CAsiApproxNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiApproxNum | virtual
operator>=(const CAsiInt &) const | CAsiApproxNum | virtual
operator>=(const CAsiNumeric &) const | CAsiApproxNum | virtual
operator>=(const CAsiDecimal &) const | CAsiApproxNum | virtual
operator>=(const CAsiFloat &) const | CAsiApproxNum | virtual
operator>=(const CAsiReal &) const | CAsiApproxNum | virtual
operator>=(const CAsiDouble &) const | CAsiApproxNum | virtual
operator>=(const smallint) const | CAsiApproxNum | virtual
operator>=(const integer) const | CAsiApproxNum | virtual
operator>=(const real) const | CAsiApproxNum | virtual
operator>=(const int) const | CAsiApproxNum | virtual
packSize(void) const (defined in CAsiReal) | CAsiReal | virtual
packTo(CAsiObjPack *) const (defined in CAsiReal) | CAsiReal | virtual
packValueSize(void) const (defined in CAsiReal) | CAsiReal | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiReal) | CAsiReal | virtual
precision (defined in CAsiNum) | CAsiNum | protected
Precision(void) const | CAsiNum | virtual
realValue(void) const (defined in CAsiReal) | CAsiReal | virtual
ReturnLength(void) const (defined in CAsiReal) | CAsiReal | virtual
Scale(void) const | CAsiNum | virtual
scale (defined in CAsiNum) | CAsiNum | protected
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const (defined in CAsiReal) | CAsiReal | virtual
SQLType(CAsiUcStr *) const (defined in CAsiReal) | CAsiReal | virtual
storeValue(real) (defined in CAsiReal) | CAsiReal | virtual
storeValue(integer) (defined in CAsiReal) | CAsiReal | virtual
storeValue(smallint) (defined in CAsiReal) | CAsiReal | virtual
storeValue(char *, uint) (defined in CAsiReal) | CAsiReal | virtual
storeValue(const CAsiUcStr &) (defined in CAsiReal) | CAsiReal | virtual
storeValue(const CAsiData &) (defined in CAsiReal) | CAsiReal | virtual
storeValue(char *, uint, uint *) (defined in CAsiReal) | CAsiReal | virtual
storeValue(const AsiUcStr) (defined in CAsiReal) | CAsiReal | virtual
CAsiApproxNum::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiApproxNum::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiApproxNum::storeValue(const DBDATE *) | CAsiData | virtual
CAsiApproxNum::storeValue(const DBTIME *) | CAsiData | virtual
CAsiApproxNum::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiReal) | CAsiReal | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiReal) | CAsiReal | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiReal) | CAsiReal | virtual
~CAsiApproxNum() | CAsiApproxNum | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiReal(void) (defined in CAsiReal) | CAsiReal | virtual


ZRX API Reference: CAsiRow Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAsiRow Class Reference
Misc Classes
+ Inheritance diagram for CAsiRow:

Public Member Functions

CAsiRow (int ColNum)
CAsiRow (const CAsiRow &)
virtual void | Clear (void)
int | ColNum (void) const
virtual CAsiObject * | duplicate (void) const
int | findCol (const CAsiIdent &) const
EAsiBoolean | isDistinct (void) const
CAsiColumn & | operator[] (int) const
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiRow Member List

This is the complete list of members for CAsiRow, including all inherited members.

CAsiObject(void) | CAsiObject |
CAsiRow(int ColNum) (defined in CAsiRow) | CAsiRow |
CAsiRow(const CAsiRow &) (defined in CAsiRow) | CAsiRow |
Clear(void) (defined in CAsiRow) | CAsiRow | virtual
ColNum(void) const (defined in CAsiRow) | CAsiRow |
duplicate(void) const (defined in CAsiRow) | CAsiRow | virtual
findCol(const CAsiIdent &) const (defined in CAsiRow) | CAsiRow |
isDistinct(void) const (defined in CAsiRow) | CAsiRow |
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator[](int) const (defined in CAsiRow) | CAsiRow |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiRow() (defined in CAsiRow) | CAsiRow | virtual


ZRX API Reference: CAsiSession Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
CAsiSession Class Reference
Misc Classes
+ Inheritance diagram for CAsiSession:

Public Member Functions

CAsiSession (CAsiAppl *)
EAsiBoolean | Commit (void)
EAsiBoolean | Connect (const CAsiUcStr &LinkFile, const CAsiUcStr &Username, const CAsiUcStr &Password, EAsiBoolean fPrompt=kAsiFalse)
EAsiBoolean | ConnectIniString (const CAsiUcStr &IniString)
EAsiBoolean | DeferrConstr (CAsiIdent *cnst=0)
EAsiBoolean | Disconnect (void)
EAsiBoolean | GetConnectionString (CAsiUcStr *)
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
EAsiBoolean | ImmConstr (CAsiIdent *cnst=0)
const CAsiUcStr & | Name (void) const
EAsiBoolean | Rollback (void)
EAsiBoolean | SetAuthor (const CAsiUcStr &)
EAsiBoolean | SetCatalog (const CAsiUcStr &)
EAsiBoolean | SetNames (const CAsiUcStr &)
EAsiBoolean | SetSchema (const CAsiUcStr &)
EAsiBoolean | SetTimeZone (const CAsiDT &)
EAsiBoolean | SetTimeZone (void)
EAsiBoolean | SetTrans (EAsiTILevel, EAsiTMode, uint dSize=64)
virtual | ~CAsiSession ()
- Public Member Functions inherited from CAsiSQLObject
EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
virtual EAsiBoolean | IsRowset (void) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

EAsiBoolean | Disconnect (CAsiObject *)
EAsiBoolean | GetCatalog (CAsiUcStr *)
- Protected Member Functions inherited from CAsiSQLObject
CAsiSQLObject ()
virtual EAsiBoolean | flushCond (void)
void | InheritStatusInfo (const CAsiSQLObject &)
EAsiBoolean | InitErrorInfo (HRESULT, IUnknown *, GUID)
EAsiBoolean | isInit (void) const
virtual EAsiBoolean | pushCond (void)
virtual EAsiBoolean | pushErr (EAsiError)
virtual EAsiBoolean | pushHResult (HRESULT)
void | ReleaseErrorInfo ()
virtual EAsiBoolean | setDiagPar (EAsiDiag, integer)
virtual EAsiBoolean | setDiagPar (EAsiDiag, const CAsiUcStr &)
virtual EAsiBoolean | setErr (EAsiError)
virtual EAsiBoolean | setErrMsg (const CAsiUcStr &)
virtual EAsiBoolean | setSQLSTATE (const char *)

Friends

class | CAsiAppl
class | CAsiCsr
class | CAsiCsrInfSchema
class | CAsiCsrRegTable
class | CAsiCsrTable
class | CAsiExecStm
class | CAsiStm

Additional Inherited Members

- Protected Attributes inherited from CAsiSQLObject
EAsiBoolean | m_CSP
EAsiStatement | m_eStmType
HRESULT | m_HResult
LONG_PTR | m_lRowCount
CAsiDSProperties * | m_pDSProperties
IErrorInfo * | m_pIErrorInfo

Constructor & Destructor Documentation

CAsiSession::CAsiSession ( CAsiAppl * )
Warning
Not implemented!
virtual CAsiSession::~CAsiSession ( )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAsiSession::Commit ( void )
Warning
Not implemented!
EAsiBoolean CAsiSession::Connect | ( | const CAsiUcStr & | LinkFile,
 |  | const CAsiUcStr & | Username,
 |  | const CAsiUcStr & | Password,
 |  | EAsiBoolean | fPrompt = kAsiFalse
 | ) |  |
Warning
Not implemented!
EAsiBoolean CAsiSession::ConnectIniString ( const CAsiUcStr & IniString )
Warning
Not implemented!
EAsiBoolean CAsiSession::DeferrConstr ( CAsiIdent * cnst = 0 )
Warning
Not implemented!
EAsiBoolean CAsiSession::Disconnect ( void )
Warning
Not implemented!
EAsiBoolean CAsiSession::Disconnect ( CAsiObject * )
protected
Warning
Not implemented!
EAsiBoolean CAsiSession::GetCatalog ( CAsiUcStr * )
protected
Warning
Not implemented!
EAsiBoolean CAsiSession::GetConnectionString ( CAsiUcStr * )
Warning
Not implemented!
virtual EAsiBoolean CAsiSession::GetStatus | ( | EAsiStatInfo | ,
 |  | ULONG_PTR * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiSQLObject.

EAsiBoolean CAsiSession::ImmConstr ( CAsiIdent * cnst = 0 )
Warning
Not implemented!
const CAsiUcStr& CAsiSession::Name ( void ) const
Warning
Not implemented!
EAsiBoolean CAsiSession::Rollback ( void )
Warning
Not implemented!
EAsiBoolean CAsiSession::SetAuthor ( const CAsiUcStr & )
Warning
Not implemented!
EAsiBoolean CAsiSession::SetCatalog ( const CAsiUcStr & )
Warning
Not implemented!
EAsiBoolean CAsiSession::SetNames ( const CAsiUcStr & )
Warning
Not implemented!
EAsiBoolean CAsiSession::SetSchema ( const CAsiUcStr & )
Warning
Not implemented!
EAsiBoolean CAsiSession::SetTimeZone ( const CAsiDT & )
Warning
Not implemented!
EAsiBoolean CAsiSession::SetTimeZone ( void )
Warning
Not implemented!
EAsiBoolean CAsiSession::SetTrans | ( | EAsiTILevel | ,
 |  | EAsiTMode | ,
 |  | uint | dSize = 64
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiSession Member List

This is the complete list of members for CAsiSession, including all inherited members.

CAsiAppl (defined in CAsiSession) | CAsiSession | friend
CAsiCsr (defined in CAsiSession) | CAsiSession | friend
CAsiCsrInfSchema (defined in CAsiSession) | CAsiSession | friend
CAsiCsrRegTable (defined in CAsiSession) | CAsiSession | friend
CAsiCsrTable (defined in CAsiSession) | CAsiSession | friend
CAsiExecStm (defined in CAsiSession) | CAsiSession | friend
CAsiObject(void) | CAsiObject |
CAsiSession(CAsiAppl *) | CAsiSession |
CAsiSQLObject() | CAsiSQLObject | protected
CAsiStm (defined in CAsiSession) | CAsiSession | friend
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
Commit(void) | CAsiSession |
CondQty(void) const | CAsiSQLObject | virtual
Connect(const CAsiUcStr &LinkFile, const CAsiUcStr &Username, const CAsiUcStr &Password, EAsiBoolean fPrompt=kAsiFalse) | CAsiSession |
ConnectIniString(const CAsiUcStr &IniString) | CAsiSession |
DBMS(CAsiUcStr *) const | CAsiSQLObject |
DeferrConstr(CAsiIdent *cnst=0) | CAsiSession |
Disconnect(void) | CAsiSession |
Disconnect(CAsiObject *) | CAsiSession | protected
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
GetCatalog(CAsiUcStr *) | CAsiSession | protected
GetConnectionString(CAsiUcStr *) | CAsiSession |
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiSession | virtual
ImmConstr(CAsiIdent *cnst=0) | CAsiSession |
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiSQLObject | virtual
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_lRowCount (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
Name(void) const | CAsiSession |
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
ReleaseErrorInfo() | CAsiSQLObject | protected
Rollback(void) | CAsiSession |
RowCount(void) const | CAsiSQLObject |
SetAuthor(const CAsiUcStr &) | CAsiSession |
SetCatalog(const CAsiUcStr &) | CAsiSession |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
SetNames(const CAsiUcStr &) | CAsiSession |
SetSchema(const CAsiUcStr &) | CAsiSession |
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
SetTimeZone(const CAsiDT &) | CAsiSession |
SetTimeZone(void) | CAsiSession |
SetTrans(EAsiTILevel, EAsiTMode, uint dSize=64) | CAsiSession |
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Version(void) const | CAsiSQLObject |
~CAsiObject(void) | CAsiObject | virtual
~CAsiSession() | CAsiSession | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual


ZRX API Reference: CAsiSmallInt Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiSmallInt Class Reference
Misc Classes
+ Inheritance diagram for CAsiSmallInt:

Public Member Functions

CAsiSmallInt (void)
CAsiSmallInt (const CAsiSmallInt &)
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual CAsiObject * | duplicate (void) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual integer | intValue (void) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
CAsiDouble | operator* (const CAsiSmallInt &) const
CAsiDouble | operator* (const smallint) const
CAsiDouble | operator* (const integer) const
CAsiDouble | operator* (const real) const
CAsiDouble | operator* (const int) const
CAsiSmallInt & | operator*= (const CAsiSmallInt &)
CAsiSmallInt & | operator*= (const CAsiInt &)
CAsiSmallInt & | operator*= (const CAsiNumeric &)
CAsiSmallInt & | operator*= (const CAsiDecimal &)
CAsiSmallInt & | operator*= (const CAsiFloat &)
CAsiSmallInt & | operator*= (const CAsiReal &)
CAsiSmallInt & | operator*= (const CAsiDouble &)
CAsiSmallInt & | operator*= (const smallint)
CAsiSmallInt & | operator*= (const integer)
CAsiSmallInt & | operator*= (const real)
CAsiSmallInt & | operator*= (const int)
CAsiDouble | operator+ (const CAsiSmallInt &) const
CAsiDouble | operator+ (const smallint) const
CAsiDouble | operator+ (const integer) const
CAsiDouble | operator+ (const real) const
CAsiDouble | operator+ (const int) const
CAsiSmallInt & | operator++ (void)
CAsiSmallInt & | operator+= (const CAsiSmallInt &)
CAsiSmallInt & | operator+= (const CAsiInt &)
CAsiSmallInt & | operator+= (const CAsiNumeric &)
CAsiSmallInt & | operator+= (const CAsiDecimal &)
CAsiSmallInt & | operator+= (const CAsiFloat &)
CAsiSmallInt & | operator+= (const CAsiReal &)
CAsiSmallInt & | operator+= (const CAsiDouble &)
CAsiSmallInt & | operator+= (const smallint)
CAsiSmallInt & | operator+= (const integer)
CAsiSmallInt & | operator+= (const real)
CAsiSmallInt & | operator+= (const int)
CAsiDouble | operator- (const CAsiSmallInt &) const
CAsiDouble | operator- (const smallint) const
CAsiDouble | operator- (const integer) const
CAsiDouble | operator- (const real) const
CAsiDouble | operator- (const int) const
CAsiSmallInt & | operator- (void)
CAsiSmallInt & | operator-- (void)
CAsiSmallInt & | operator-= (const CAsiSmallInt &)
CAsiSmallInt & | operator-= (const CAsiInt &)
CAsiSmallInt & | operator-= (const CAsiNumeric &)
CAsiSmallInt & | operator-= (const CAsiDecimal &)
CAsiSmallInt & | operator-= (const CAsiFloat &)
CAsiSmallInt & | operator-= (const CAsiReal &)
CAsiSmallInt & | operator-= (const CAsiDouble &)
CAsiSmallInt & | operator-= (const smallint)
CAsiSmallInt & | operator-= (const integer)
CAsiSmallInt & | operator-= (const real)
CAsiSmallInt & | operator-= (const int)
CAsiDouble | operator/ (const CAsiSmallInt &) const
CAsiDouble | operator/ (const smallint) const
CAsiDouble | operator/ (const integer) const
CAsiDouble | operator/ (const real) const
CAsiDouble | operator/ (const int) const
CAsiSmallInt & | operator/= (const CAsiSmallInt &)
CAsiSmallInt & | operator/= (const CAsiInt &)
CAsiSmallInt & | operator/= (const CAsiNumeric &)
CAsiSmallInt & | operator/= (const CAsiDecimal &)
CAsiSmallInt & | operator/= (const CAsiFloat &)
CAsiSmallInt & | operator/= (const CAsiReal &)
CAsiSmallInt & | operator/= (const CAsiDouble &)
CAsiSmallInt & | operator/= (const smallint)
CAsiSmallInt & | operator/= (const integer)
CAsiSmallInt & | operator/= (const real)
CAsiSmallInt & | operator/= (const int)
CAsiSmallInt & | operator= (const CAsiSmallInt &)
CAsiSmallInt & | operator= (const CAsiInt &)
CAsiSmallInt & | operator= (const CAsiNumeric &)
CAsiSmallInt & | operator= (const CAsiDecimal &)
CAsiSmallInt & | operator= (const CAsiFloat &)
CAsiSmallInt & | operator= (const CAsiReal &)
CAsiSmallInt & | operator= (const CAsiDouble &)
CAsiSmallInt & | operator= (const smallint)
CAsiSmallInt & | operator= (const integer)
CAsiSmallInt & | operator= (const real)
CAsiSmallInt & | operator= (const int)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual real | realValue (void) const
virtual uint | ReturnLength (void) const
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiDataType | Type (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiSmallInt (void)
- Public Member Functions inherited from CAsiExactNum
virtual EAsiBoolean | is_exactnumeric (void) const
virtual int | operator!= (const CAsiSmallInt &) const
virtual int | operator!= (const CAsiInt &) const
virtual int | operator!= (const CAsiNumeric &) const
virtual int | operator!= (const CAsiDecimal &) const
virtual int | operator!= (const CAsiFloat &) const
virtual int | operator!= (const CAsiReal &) const
virtual int | operator!= (const CAsiDouble &) const
virtual int | operator!= (const smallint) const
virtual int | operator!= (const integer) const
virtual int | operator!= (const real) const
virtual int | operator!= (const int) const
virtual int | operator< (const CAsiSmallInt &) const
virtual int | operator< (const CAsiInt &) const
virtual int | operator< (const CAsiNumeric &) const
virtual int | operator< (const CAsiDecimal &) const
virtual int | operator< (const CAsiFloat &) const
virtual int | operator< (const CAsiReal &) const
virtual int | operator< (const CAsiDouble &) const
virtual int | operator< (const smallint) const
virtual int | operator< (const integer) const
virtual int | operator< (const real) const
virtual int | operator< (const int) const
virtual int | operator<= (const CAsiSmallInt &) const
virtual int | operator<= (const CAsiInt &) const
virtual int | operator<= (const CAsiNumeric &) const
virtual int | operator<= (const CAsiDecimal &) const
virtual int | operator<= (const CAsiFloat &) const
virtual int | operator<= (const CAsiReal &) const
virtual int | operator<= (const CAsiDouble &) const
virtual int | operator<= (const smallint) const
virtual int | operator<= (const integer) const
virtual int | operator<= (const real) const
virtual int | operator<= (const int) const
virtual int | operator== (const CAsiSmallInt &) const
virtual int | operator== (const CAsiInt &) const
virtual int | operator== (const CAsiNumeric &) const
virtual int | operator== (const CAsiDecimal &) const
virtual int | operator== (const CAsiFloat &) const
virtual int | operator== (const CAsiReal &) const
virtual int | operator== (const CAsiDouble &) const
virtual int | operator== (const smallint) const
virtual int | operator== (const integer) const
virtual int | operator== (const real) const
virtual int | operator== (const int) const
virtual int | operator> (const CAsiSmallInt &) const
virtual int | operator> (const CAsiInt &) const
virtual int | operator> (const CAsiNumeric &) const
virtual int | operator> (const CAsiDecimal &) const
virtual int | operator> (const CAsiFloat &) const
virtual int | operator> (const CAsiReal &) const
virtual int | operator> (const CAsiDouble &) const
virtual int | operator> (const smallint) const
virtual int | operator> (const integer) const
virtual int | operator> (const real) const
virtual int | operator> (const int) const
virtual int | operator>= (const CAsiSmallInt &) const
virtual int | operator>= (const CAsiInt &) const
virtual int | operator>= (const CAsiNumeric &) const
virtual int | operator>= (const CAsiDecimal &) const
virtual int | operator>= (const CAsiFloat &) const
virtual int | operator>= (const CAsiReal &) const
virtual int | operator>= (const CAsiDouble &) const
virtual int | operator>= (const smallint) const
virtual int | operator>= (const integer) const
virtual int | operator>= (const real) const
virtual int | operator>= (const int) const
virtual | ~CAsiExactNum ()
- Public Member Functions inherited from CAsiNum
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual | ~CAsiNum ()
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

CAsiDouble DLLScope | operator* (const smallint, const CAsiSmallInt &)
CAsiDouble DLLScope | operator* (const integer, const CAsiSmallInt &)
CAsiDouble DLLScope | operator* (const real, const CAsiSmallInt &)
CAsiDouble DLLScope | operator* (const int, const CAsiSmallInt &)
CAsiDouble DLLScope | operator+ (const smallint, const CAsiSmallInt &)
CAsiDouble DLLScope | operator+ (const integer, const CAsiSmallInt &)
CAsiDouble DLLScope | operator+ (const real, const CAsiSmallInt &)
CAsiDouble DLLScope | operator+ (const int, const CAsiSmallInt &)
CAsiDouble DLLScope | operator- (const smallint, const CAsiSmallInt &)
CAsiDouble DLLScope | operator- (const integer, const CAsiSmallInt &)
CAsiDouble DLLScope | operator- (const real, const CAsiSmallInt &)
CAsiDouble DLLScope | operator- (const int, const CAsiSmallInt &)
CAsiDouble DLLScope | operator/ (const smallint, const CAsiSmallInt &)
CAsiDouble DLLScope | operator/ (const integer, const CAsiSmallInt &)
CAsiDouble DLLScope | operator/ (const real, const CAsiSmallInt &)
CAsiDouble DLLScope | operator/ (const int, const CAsiSmallInt &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Member Functions inherited from CAsiExactNum
CAsiExactNum ()
int | cmpeqlan (const CAsiNum *) const
int | cmpeqlen (const CAsiExactNum *) const
int | cmpeqlenC (const real) const
int | cmpgtean (const CAsiNum *) const
int | cmpgteen (const CAsiExactNum *) const
int | cmpgteenC (const real) const
int | cmpgtran (const CAsiNum *) const
int | cmpgtren (const CAsiExactNum *) const
int | cmpgtrenC (const real) const
int | cmpltean (const CAsiNum *) const
int | cmplteen (const CAsiExactNum *) const
int | cmplteenC (const real) const
int | cmpltran (const CAsiNum *) const
int | cmpltren (const CAsiExactNum *) const
int | cmpltrenC (const real) const
int | cmpneqan (const CAsiNum *) const
int | cmpneqen (const CAsiExactNum *) const
int | cmpneqenC (const real) const
- Protected Attributes inherited from CAsiNum
uint | precision
uint | scale

Constructor & Destructor Documentation

CAsiSmallInt::CAsiSmallInt ( void )
Warning
Not implemented!
CAsiSmallInt::CAsiSmallInt ( const CAsiSmallInt & )
Warning
Not implemented!
virtual CAsiSmallInt::~CAsiSmallInt ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual CAsiData* CAsiSmallInt::checkAdd ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiExactNum.

virtual CAsiData* CAsiSmallInt::checkDiv ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual CAsiData* CAsiSmallInt::checkMul ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual CAsiData* CAsiSmallInt::checkSet ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual CAsiData* CAsiSmallInt::checkSub ( const CAsiData * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual CAsiObject* CAsiSmallInt::duplicate ( void ) const
virtual
Warning
Not implemented!

Implements CAsiData.

virtual EAsiBoolean CAsiSmallInt::getValue ( real * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::getValue ( integer * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::getValue ( smallint * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::getValue | ( | char * | ,
 |  | uint |
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::getValue ( CAsiUcStr * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::getValue | ( | char * | ,
 |  | uint | ,
 |  | uint * |
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::getValue | ( | AsiUcStr | ,
 |  | uint |
 | ) |  | const
 virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::getValue ( CAsiData & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual integer CAsiSmallInt::intValue ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual EAsiBoolean CAsiSmallInt::isEqualTo ( const CAsiData & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::isGreaterThan ( const CAsiData & ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual DBCOLUMNINFO* CAsiSmallInt::MapAsiToColumnInfo ( DBCOLUMNINFO * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual DBPARAMINFO* CAsiSmallInt::MapAsiToParamInfo ( DBPARAMINFO * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

CAsiDouble CAsiSmallInt::operator* ( const CAsiSmallInt & ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator* ( const smallint ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator* ( const integer ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator* ( const real ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator* ( const int ) const
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const CAsiSmallInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const CAsiInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const CAsiNumeric & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const CAsiDecimal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const CAsiFloat & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const CAsiReal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const CAsiDouble & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const smallint )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const integer )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const real )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator*= ( const int )
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator+ ( const CAsiSmallInt & ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator+ ( const smallint ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator+ ( const integer ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator+ ( const real ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator+ ( const int ) const
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator++ ( void )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const CAsiSmallInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const CAsiInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const CAsiNumeric & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const CAsiDecimal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const CAsiFloat & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const CAsiReal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const CAsiDouble & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const smallint )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const integer )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const real )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator+= ( const int )
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator- ( const CAsiSmallInt & ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator- ( const smallint ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator- ( const integer ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator- ( const real ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator- ( const int ) const
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator- ( void )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-- ( void )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const CAsiSmallInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const CAsiInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const CAsiNumeric & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const CAsiDecimal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const CAsiFloat & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const CAsiReal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const CAsiDouble & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const smallint )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const integer )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const real )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator-= ( const int )
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator/ ( const CAsiSmallInt & ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator/ ( const smallint ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator/ ( const integer ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator/ ( const real ) const
Warning
Not implemented!
CAsiDouble CAsiSmallInt::operator/ ( const int ) const
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const CAsiSmallInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const CAsiInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const CAsiNumeric & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const CAsiDecimal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const CAsiFloat & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const CAsiReal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const CAsiDouble & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const smallint )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const integer )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const real )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator/= ( const int )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const CAsiSmallInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const CAsiInt & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const CAsiNumeric & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const CAsiDecimal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const CAsiFloat & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const CAsiReal & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const CAsiDouble & )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const smallint )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const integer )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const real )
Warning
Not implemented!
CAsiSmallInt& CAsiSmallInt::operator= ( const int )
Warning
Not implemented!
virtual unsigned long CAsiSmallInt::packSize ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

virtual unsigned long CAsiSmallInt::packTo ( CAsiObjPack * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

virtual unsigned long CAsiSmallInt::packValueSize ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

virtual unsigned long CAsiSmallInt::packValueTo ( CAsiObjPack * ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

virtual real CAsiSmallInt::realValue ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiNum.

virtual uint CAsiSmallInt::ReturnLength ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::SQLLiteral ( CAsiUcStr * ) const
virtual
Warning
Not implemented!

Implements CAsiData.

virtual EAsiBoolean CAsiSmallInt::SQLType ( CAsiUcStr * ) const
virtual
Warning
Not implemented!

Implements CAsiData.

virtual EAsiBoolean CAsiSmallInt::storeValue ( real )
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::storeValue ( integer )
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::storeValue ( smallint )
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::storeValue | ( | char * | ,
 |  | uint |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::storeValue ( const CAsiUcStr & )
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::storeValue ( const CAsiData & )
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiBoolean CAsiSmallInt::storeValue ( const AsiUcStr )
virtual
Warning
Not implemented!

Reimplemented from CAsiData.

virtual EAsiDataType CAsiSmallInt::Type ( void ) const
virtual
Warning
Not implemented!

Implements CAsiData.

virtual EAsiBoolean CAsiSmallInt::unpackFrom ( CAsiObjPack * )
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

virtual EAsiBoolean CAsiSmallInt::unpackValueFrom ( CAsiObjPack * )
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

Friends And Related Function Documentation

CAsiDouble DLLScope operator* | ( | const smallint | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator* | ( | const integer | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator* | ( | const real | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator* | ( | const int | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator+ | ( | const smallint | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator+ | ( | const integer | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator+ | ( | const real | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator+ | ( | const int | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator- | ( | const smallint | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator- | ( | const integer | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator- | ( | const real | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator- | ( | const int | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator/ | ( | const smallint | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator/ | ( | const integer | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator/ | ( | const real | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
CAsiDouble DLLScope operator/ | ( | const int | ,
 |  | const CAsiSmallInt & |
 | ) |  |
friend
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiSmallInt Member List

This is the complete list of members for CAsiSmallInt, including all inherited members.

CAsiData(void) | CAsiData |
CAsiExactNum() | CAsiExactNum | protected
CAsiNum() | CAsiNum | protected
CAsiObject(void) | CAsiObject |
CAsiSmallInt(void) | CAsiSmallInt |
CAsiSmallInt(const CAsiSmallInt &) | CAsiSmallInt |
checkAdd(const CAsiData *) const | CAsiSmallInt | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiSmallInt | virtual
checkMul(const CAsiData *) const | CAsiSmallInt | virtual
checkSet(const CAsiData *) const | CAsiSmallInt | virtual
checkSub(const CAsiData *) const | CAsiSmallInt | virtual
Clear(void) | CAsiData | virtual
cmpeqlan(const CAsiNum *) const | CAsiExactNum | protected
cmpeqlen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpeqlenC(const real) const | CAsiExactNum | protected
cmpgtean(const CAsiNum *) const | CAsiExactNum | protected
cmpgteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgteenC(const real) const | CAsiExactNum | protected
cmpgtran(const CAsiNum *) const | CAsiExactNum | protected
cmpgtren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpgtrenC(const real) const | CAsiExactNum | protected
cmpltean(const CAsiNum *) const | CAsiExactNum | protected
cmplteen(const CAsiExactNum *) const | CAsiExactNum | protected
cmplteenC(const real) const | CAsiExactNum | protected
cmpltran(const CAsiNum *) const | CAsiExactNum | protected
cmpltren(const CAsiExactNum *) const | CAsiExactNum | protected
cmpltrenC(const real) const | CAsiExactNum | protected
cmpneqan(const CAsiNum *) const | CAsiExactNum | protected
cmpneqen(const CAsiExactNum *) const | CAsiExactNum | protected
cmpneqenC(const real) const | CAsiExactNum | protected
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const | CAsiSmallInt | virtual
FracSecPrec(void) const | CAsiData | virtual
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(real *) const | CAsiSmallInt | virtual
getValue(integer *) const | CAsiSmallInt | virtual
getValue(smallint *) const | CAsiSmallInt | virtual
getValue(char *, uint) const | CAsiSmallInt | virtual
getValue(CAsiUcStr *) const | CAsiSmallInt | virtual
getValue(char *, uint, uint *) const | CAsiSmallInt | virtual
getValue(AsiUcStr, uint) const | CAsiSmallInt | virtual
getValue(CAsiData &) const | CAsiSmallInt | virtual
CAsiExactNum::getValue(DECIMAL *) const | CAsiData | virtual
CAsiExactNum::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiExactNum::getValue(DBDATE *) const | CAsiData | virtual
CAsiExactNum::getValue(DBTIME *) const | CAsiData | virtual
CAsiExactNum::getValue(DBTIMESTAMP *) const | CAsiData | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
intValue(void) const | CAsiSmallInt | virtual
is_approxnumeric(void) const | CAsiNum | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const | CAsiNum | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const | CAsiNum | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiExactNum | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiNum | virtual
is_storable(const CAsiData *) const | CAsiNum | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const | CAsiSmallInt | virtual
isGreaterThan(const CAsiData &) const | CAsiSmallInt | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const | CAsiSmallInt | virtual
MapAsiToParamInfo(DBPARAMINFO *) const | CAsiSmallInt | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator!=(const CAsiInt &) const | CAsiExactNum | virtual
operator!=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator!=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator!=(const CAsiFloat &) const | CAsiExactNum | virtual
operator!=(const CAsiReal &) const | CAsiExactNum | virtual
operator!=(const CAsiDouble &) const | CAsiExactNum | virtual
operator!=(const smallint) const | CAsiExactNum | virtual
operator!=(const integer) const | CAsiExactNum | virtual
operator!=(const real) const | CAsiExactNum | virtual
operator!=(const int) const | CAsiExactNum | virtual
operator*(const CAsiSmallInt &) const | CAsiSmallInt |
operator*(const smallint) const | CAsiSmallInt |
operator*(const integer) const | CAsiSmallInt |
operator*(const real) const | CAsiSmallInt |
operator*(const int) const | CAsiSmallInt |
operator*(const smallint, const CAsiSmallInt &) | CAsiSmallInt | friend
operator*(const integer, const CAsiSmallInt &) | CAsiSmallInt | friend
operator*(const real, const CAsiSmallInt &) | CAsiSmallInt | friend
operator*(const int, const CAsiSmallInt &) | CAsiSmallInt | friend
operator*=(const CAsiSmallInt &) | CAsiSmallInt |
operator*=(const CAsiInt &) | CAsiSmallInt |
operator*=(const CAsiNumeric &) | CAsiSmallInt |
operator*=(const CAsiDecimal &) | CAsiSmallInt |
operator*=(const CAsiFloat &) | CAsiSmallInt |
operator*=(const CAsiReal &) | CAsiSmallInt |
operator*=(const CAsiDouble &) | CAsiSmallInt |
operator*=(const smallint) | CAsiSmallInt |
operator*=(const integer) | CAsiSmallInt |
operator*=(const real) | CAsiSmallInt |
operator*=(const int) | CAsiSmallInt |
operator+(const CAsiSmallInt &) const | CAsiSmallInt |
operator+(const smallint) const | CAsiSmallInt |
operator+(const integer) const | CAsiSmallInt |
operator+(const real) const | CAsiSmallInt |
operator+(const int) const | CAsiSmallInt |
operator+(const smallint, const CAsiSmallInt &) | CAsiSmallInt | friend
operator+(const integer, const CAsiSmallInt &) | CAsiSmallInt | friend
operator+(const real, const CAsiSmallInt &) | CAsiSmallInt | friend
operator+(const int, const CAsiSmallInt &) | CAsiSmallInt | friend
operator++(void) | CAsiSmallInt |
operator+=(const CAsiSmallInt &) | CAsiSmallInt |
operator+=(const CAsiInt &) | CAsiSmallInt |
operator+=(const CAsiNumeric &) | CAsiSmallInt |
operator+=(const CAsiDecimal &) | CAsiSmallInt |
operator+=(const CAsiFloat &) | CAsiSmallInt |
operator+=(const CAsiReal &) | CAsiSmallInt |
operator+=(const CAsiDouble &) | CAsiSmallInt |
operator+=(const smallint) | CAsiSmallInt |
operator+=(const integer) | CAsiSmallInt |
operator+=(const real) | CAsiSmallInt |
operator+=(const int) | CAsiSmallInt |
operator-(const CAsiSmallInt &) const | CAsiSmallInt |
operator-(const smallint) const | CAsiSmallInt |
operator-(const integer) const | CAsiSmallInt |
operator-(const real) const | CAsiSmallInt |
operator-(const int) const | CAsiSmallInt |
operator-(const smallint, const CAsiSmallInt &) | CAsiSmallInt | friend
operator-(const integer, const CAsiSmallInt &) | CAsiSmallInt | friend
operator-(const real, const CAsiSmallInt &) | CAsiSmallInt | friend
operator-(const int, const CAsiSmallInt &) | CAsiSmallInt | friend
operator-(void) | CAsiSmallInt |
operator--(void) | CAsiSmallInt |
operator-=(const CAsiSmallInt &) | CAsiSmallInt |
operator-=(const CAsiInt &) | CAsiSmallInt |
operator-=(const CAsiNumeric &) | CAsiSmallInt |
operator-=(const CAsiDecimal &) | CAsiSmallInt |
operator-=(const CAsiFloat &) | CAsiSmallInt |
operator-=(const CAsiReal &) | CAsiSmallInt |
operator-=(const CAsiDouble &) | CAsiSmallInt |
operator-=(const smallint) | CAsiSmallInt |
operator-=(const integer) | CAsiSmallInt |
operator-=(const real) | CAsiSmallInt |
operator-=(const int) | CAsiSmallInt |
operator/(const CAsiSmallInt &) const | CAsiSmallInt |
operator/(const smallint) const | CAsiSmallInt |
operator/(const integer) const | CAsiSmallInt |
operator/(const real) const | CAsiSmallInt |
operator/(const int) const | CAsiSmallInt |
operator/(const smallint, const CAsiSmallInt &) | CAsiSmallInt | friend
operator/(const integer, const CAsiSmallInt &) | CAsiSmallInt | friend
operator/(const real, const CAsiSmallInt &) | CAsiSmallInt | friend
operator/(const int, const CAsiSmallInt &) | CAsiSmallInt | friend
operator/=(const CAsiSmallInt &) | CAsiSmallInt |
operator/=(const CAsiInt &) | CAsiSmallInt |
operator/=(const CAsiNumeric &) | CAsiSmallInt |
operator/=(const CAsiDecimal &) | CAsiSmallInt |
operator/=(const CAsiFloat &) | CAsiSmallInt |
operator/=(const CAsiReal &) | CAsiSmallInt |
operator/=(const CAsiDouble &) | CAsiSmallInt |
operator/=(const smallint) | CAsiSmallInt |
operator/=(const integer) | CAsiSmallInt |
operator/=(const real) | CAsiSmallInt |
operator/=(const int) | CAsiSmallInt |
operator<(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<(const CAsiInt &) const | CAsiExactNum | virtual
operator<(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<(const CAsiFloat &) const | CAsiExactNum | virtual
operator<(const CAsiReal &) const | CAsiExactNum | virtual
operator<(const CAsiDouble &) const | CAsiExactNum | virtual
operator<(const smallint) const | CAsiExactNum | virtual
operator<(const integer) const | CAsiExactNum | virtual
operator<(const real) const | CAsiExactNum | virtual
operator<(const int) const | CAsiExactNum | virtual
operator<=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator<=(const CAsiInt &) const | CAsiExactNum | virtual
operator<=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator<=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator<=(const CAsiFloat &) const | CAsiExactNum | virtual
operator<=(const CAsiReal &) const | CAsiExactNum | virtual
operator<=(const CAsiDouble &) const | CAsiExactNum | virtual
operator<=(const smallint) const | CAsiExactNum | virtual
operator<=(const integer) const | CAsiExactNum | virtual
operator<=(const real) const | CAsiExactNum | virtual
operator<=(const int) const | CAsiExactNum | virtual
operator=(const CAsiSmallInt &) | CAsiSmallInt |
operator=(const CAsiInt &) | CAsiSmallInt |
operator=(const CAsiNumeric &) | CAsiSmallInt |
operator=(const CAsiDecimal &) | CAsiSmallInt |
operator=(const CAsiFloat &) | CAsiSmallInt |
operator=(const CAsiReal &) | CAsiSmallInt |
operator=(const CAsiDouble &) | CAsiSmallInt |
operator=(const smallint) | CAsiSmallInt |
operator=(const integer) | CAsiSmallInt |
operator=(const real) | CAsiSmallInt |
operator=(const int) | CAsiSmallInt |
operator==(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator==(const CAsiInt &) const | CAsiExactNum | virtual
operator==(const CAsiNumeric &) const | CAsiExactNum | virtual
operator==(const CAsiDecimal &) const | CAsiExactNum | virtual
operator==(const CAsiFloat &) const | CAsiExactNum | virtual
operator==(const CAsiReal &) const | CAsiExactNum | virtual
operator==(const CAsiDouble &) const | CAsiExactNum | virtual
operator==(const smallint) const | CAsiExactNum | virtual
operator==(const integer) const | CAsiExactNum | virtual
operator==(const real) const | CAsiExactNum | virtual
operator==(const int) const | CAsiExactNum | virtual
operator>(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>(const CAsiInt &) const | CAsiExactNum | virtual
operator>(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>(const CAsiFloat &) const | CAsiExactNum | virtual
operator>(const CAsiReal &) const | CAsiExactNum | virtual
operator>(const CAsiDouble &) const | CAsiExactNum | virtual
operator>(const smallint) const | CAsiExactNum | virtual
operator>(const integer) const | CAsiExactNum | virtual
operator>(const real) const | CAsiExactNum | virtual
operator>(const int) const | CAsiExactNum | virtual
operator>=(const CAsiSmallInt &) const | CAsiExactNum | virtual
operator>=(const CAsiInt &) const | CAsiExactNum | virtual
operator>=(const CAsiNumeric &) const | CAsiExactNum | virtual
operator>=(const CAsiDecimal &) const | CAsiExactNum | virtual
operator>=(const CAsiFloat &) const | CAsiExactNum | virtual
operator>=(const CAsiReal &) const | CAsiExactNum | virtual
operator>=(const CAsiDouble &) const | CAsiExactNum | virtual
operator>=(const smallint) const | CAsiExactNum | virtual
operator>=(const integer) const | CAsiExactNum | virtual
operator>=(const real) const | CAsiExactNum | virtual
operator>=(const int) const | CAsiExactNum | virtual
packSize(void) const | CAsiSmallInt | virtual
packTo(CAsiObjPack *) const | CAsiSmallInt | virtual
packValueSize(void) const | CAsiSmallInt | virtual
packValueTo(CAsiObjPack *) const | CAsiSmallInt | virtual
precision (defined in CAsiNum) | CAsiNum | protected
Precision(void) const | CAsiNum | virtual
realValue(void) const | CAsiSmallInt | virtual
ReturnLength(void) const | CAsiSmallInt | virtual
Scale(void) const | CAsiNum | virtual
scale (defined in CAsiNum) | CAsiNum | protected
setNull(void) | CAsiData | virtual
SQLLiteral(CAsiUcStr *) const | CAsiSmallInt | virtual
SQLType(CAsiUcStr *) const | CAsiSmallInt | virtual
storeValue(real) | CAsiSmallInt | virtual
storeValue(integer) | CAsiSmallInt | virtual
storeValue(smallint) | CAsiSmallInt | virtual
storeValue(char *, uint) | CAsiSmallInt | virtual
storeValue(const CAsiUcStr &) | CAsiSmallInt | virtual
storeValue(const CAsiData &) | CAsiSmallInt | virtual
storeValue(char *, uint, uint *) (defined in CAsiSmallInt) | CAsiSmallInt | virtual
storeValue(const AsiUcStr) | CAsiSmallInt | virtual
CAsiExactNum::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiExactNum::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBDATE *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBTIME *) | CAsiData | virtual
CAsiExactNum::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const | CAsiSmallInt | virtual
unpackFrom(CAsiObjPack *) | CAsiSmallInt | virtual
unpackValueFrom(CAsiObjPack *) | CAsiSmallInt | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiExactNum() | CAsiExactNum | virtual
~CAsiNum() | CAsiNum | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiSmallInt(void) | CAsiSmallInt | virtual


ZRX API Reference: CAsiSQLObject Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAsiSQLObject Class Reference
Misc Classes
+ Inheritance diagram for CAsiSQLObject:

Public Member Functions

EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
virtual EAsiBoolean | IsRowset (void) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

CAsiSQLObject ()
virtual EAsiBoolean | flushCond (void)
void | InheritStatusInfo (const CAsiSQLObject &)
EAsiBoolean | InitErrorInfo (HRESULT, IUnknown *, GUID)
EAsiBoolean | isInit (void) const
virtual EAsiBoolean | pushCond (void)
virtual EAsiBoolean | pushErr (EAsiError)
virtual EAsiBoolean | pushHResult (HRESULT)
void | ReleaseErrorInfo ()
virtual EAsiBoolean | setDiagPar (EAsiDiag, integer)
virtual EAsiBoolean | setDiagPar (EAsiDiag, const CAsiUcStr &)
virtual EAsiBoolean | setErr (EAsiError)
virtual EAsiBoolean | setErrMsg (const CAsiUcStr &)
virtual EAsiBoolean | setSQLSTATE (const char *)

Protected Attributes

EAsiBoolean | m_CSP
EAsiStatement | m_eStmType
HRESULT | m_HResult
LONG_PTR | m_lRowCount
CAsiDSProperties * | m_pDSProperties
IErrorInfo * | m_pIErrorInfo

Friends

class | CAsiBinding
class | CAsiCsr
class | CAsiExecStm

Constructor & Destructor Documentation

CAsiSQLObject::CAsiSQLObject ( )
protected
Warning
Not implemented!
virtual CAsiSQLObject::~CAsiSQLObject ( )
virtual
Warning
Not implemented!

Member Function Documentation

EAsiBoolean CAsiSQLObject::CheckOp ( ulong )
Warning
Not implemented!
virtual int CAsiSQLObject::CondQty ( void ) const
virtual
Warning
Not implemented!
EAsiBoolean CAsiSQLObject::DBMS ( CAsiUcStr * ) const
Warning
Not implemented!
EAsiBoolean CAsiSQLObject::DrvMessage ( CAsiUcStr * ) const
Warning
Not implemented!
virtual EAsiError CAsiSQLObject::Err ( int d = 0 ) const
virtual
Warning
Not implemented!
virtual CAsiUcStr* CAsiSQLObject::ErrMsg ( int d = 0 )
virtual
Warning
Not implemented!
virtual int CAsiSQLObject::ErrPosition ( void ) const
virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::flushCond ( void )
protectedvirtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::getDiagPar | ( | int | d,
 |  | EAsiDiag | ,
 |  | integer * |
 | ) |  | const
 virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::getDiagPar | ( | int | d,
 |  | EAsiDiag | ,
 |  | CAsiUcStr * |
 | ) |  | const
 virtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::GetStatus | ( | EAsiStatInfo | ,
 |  | ULONG_PTR * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr, CAsiExecStm, and CAsiSession.

void CAsiSQLObject::InheritStatusInfo ( const CAsiSQLObject & )
protected
Warning
Not implemented!
EAsiBoolean CAsiSQLObject::InitErrorInfo | ( | HRESULT | ,
 |  | IUnknown * | ,
 |  | GUID |
 | ) |  |
protected
Warning
Not implemented!
EAsiBoolean CAsiSQLObject::isInit ( void ) const
protected
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::IsRowset ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr, and CAsiExecStm.

virtual EAsiBoolean CAsiSQLObject::pushCond ( void )
protectedvirtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::pushErr ( EAsiError )
protectedvirtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::pushHResult ( HRESULT )
protectedvirtual
Warning
Not implemented!
void CAsiSQLObject::ReleaseErrorInfo ( )
protected
Warning
Not implemented!
LONG_PTR CAsiSQLObject::RowCount ( void ) const
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::setDiagPar | ( | EAsiDiag | ,
 |  | integer |
 | ) |  |
protectedvirtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::setDiagPar | ( | EAsiDiag | ,
 |  | const CAsiUcStr & |
 | ) |  |
protectedvirtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::setErr ( EAsiError )
protectedvirtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::setErrMsg ( const CAsiUcStr & )
protectedvirtual
Warning
Not implemented!
virtual EAsiBoolean CAsiSQLObject::setSQLSTATE ( const char * )
protectedvirtual
Warning
Not implemented!
EAsiBoolean CAsiSQLObject::SQLObject ( CAsiUcStr * ) const
Warning
Not implemented!
virtual char* CAsiSQLObject::SQLSTATE ( int d = 0 )
virtual
Warning
Not implemented!
EAsiStatement CAsiSQLObject::StmType ( void ) const
Warning
Not implemented!
const char* CAsiSQLObject::Version ( void ) const
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiSQLObject Member List

This is the complete list of members for CAsiSQLObject, including all inherited members.

CAsiBinding (defined in CAsiSQLObject) | CAsiSQLObject | friend
CAsiCsr (defined in CAsiSQLObject) | CAsiSQLObject | friend
CAsiExecStm (defined in CAsiSQLObject) | CAsiSQLObject | friend
CAsiObject(void) | CAsiObject |
CAsiSQLObject() | CAsiSQLObject | protected
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
CondQty(void) const | CAsiSQLObject | virtual
DBMS(CAsiUcStr *) const | CAsiSQLObject |
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
duplicate(void) const | CAsiObject | virtual
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiSQLObject | virtual
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiSQLObject | virtual
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_lRowCount (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
ReleaseErrorInfo() | CAsiSQLObject | protected
RowCount(void) const | CAsiSQLObject |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Version(void) const | CAsiSQLObject |
~CAsiObject(void) | CAsiObject | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual


ZRX API Reference: CAsiStm Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAsiStm Class Reference
Misc Classes
+ Inheritance diagram for CAsiStm:

Public Member Functions

virtual EAsiBoolean | Bind (int, CAsiData *)
virtual EAsiBoolean | Bind (int, void *, short *, int, EAsiHostType)
virtual EAsiBoolean | Bind (const CAsiIdent &, CAsiData *)
virtual EAsiBoolean | Bind (const CAsiIdent &, void *, short *, int, EAsiHostType)
CAsiStm (void)
virtual CAsiColumn * | ColDsc (int) const
virtual int | ColQty (void) const
virtual EAsiBoolean | Cvl (int, CAsiData *)
virtual EAsiBoolean | Cvl (int, void *, short *, int, EAsiHostType)
virtual CAsiParameter * | ParamDsc (int) const
virtual int | ParamQty (void) const
void | SetSession (CAsiSession *)
virtual EAsiBoolean | Sob (int, CAsiData *)
virtual EAsiBoolean | Sob (int, void *, short *, int, EAsiHostType)
virtual | ~CAsiStm (void)
- Public Member Functions inherited from CAsiSQLObject
EAsiBoolean | CheckOp (ulong)
virtual int | CondQty (void) const
EAsiBoolean | DBMS (CAsiUcStr *) const
EAsiBoolean | DrvMessage (CAsiUcStr *) const
virtual EAsiError | Err (int d=0) const
virtual CAsiUcStr * | ErrMsg (int d=0)
virtual int | ErrPosition (void) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, integer *) const
virtual EAsiBoolean | getDiagPar (int d, EAsiDiag, CAsiUcStr *) const
virtual EAsiBoolean | GetStatus (EAsiStatInfo, ULONG_PTR *)
virtual EAsiBoolean | IsRowset (void) const
LONG_PTR | RowCount (void) const
EAsiBoolean | SQLObject (CAsiUcStr *) const
virtual char * | SQLSTATE (int d=0)
EAsiStatement | StmType (void) const
const char * | Version (void) const
virtual | ~CAsiSQLObject ()
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
virtual CAsiObject * | duplicate (void) const
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Protected Member Functions

EAsiBoolean | CvlInt (int, CAsiData *) const
EAsiBoolean | InitColsDsc ()
EAsiBoolean | pInput (void)
- Protected Member Functions inherited from CAsiSQLObject
CAsiSQLObject ()
virtual EAsiBoolean | flushCond (void)
void | InheritStatusInfo (const CAsiSQLObject &)
EAsiBoolean | InitErrorInfo (HRESULT, IUnknown *, GUID)
EAsiBoolean | isInit (void) const
virtual EAsiBoolean | pushCond (void)
virtual EAsiBoolean | pushErr (EAsiError)
virtual EAsiBoolean | pushHResult (HRESULT)
void | ReleaseErrorInfo ()
virtual EAsiBoolean | setDiagPar (EAsiDiag, integer)
virtual EAsiBoolean | setDiagPar (EAsiDiag, const CAsiUcStr &)
virtual EAsiBoolean | setErr (EAsiError)
virtual EAsiBoolean | setErrMsg (const CAsiUcStr &)
virtual EAsiBoolean | setSQLSTATE (const char *)

Protected Attributes

ULONG_PTR | m_lColNumber
CAsiRow * | m_pAsiRow
DBCOLUMNINFO * | m_pColumnInfo
CAsiBinding * | m_pInput
CAsiBinding * | m_pOutput
CAsiSession * | m_pSession
OLECHAR * | m_pStringBuff
- Protected Attributes inherited from CAsiSQLObject
EAsiBoolean | m_CSP
EAsiStatement | m_eStmType
HRESULT | m_HResult
LONG_PTR | m_lRowCount
CAsiDSProperties * | m_pDSProperties
IErrorInfo * | m_pIErrorInfo

Friends

class CAsiSession

Constructor & Destructor Documentation

CAsiStm::CAsiStm ( void )
Warning
Not implemented!
virtual CAsiStm::~CAsiStm ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual EAsiBoolean CAsiStm::Bind | ( | int | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr, and CAsiExecStm.

virtual EAsiBoolean CAsiStm::Bind | ( | int | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr, and CAsiExecStm.

virtual EAsiBoolean CAsiStm::Bind | ( | const CAsiIdent & | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr, and CAsiExecStm.

virtual EAsiBoolean CAsiStm::Bind | ( | const CAsiIdent & | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr, and CAsiExecStm.

virtual CAsiColumn* CAsiStm::ColDsc ( int ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiCsrTable, CAsiCsr, and CAsiExecStm.

virtual int CAsiStm::ColQty ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiCsrTable, CAsiCsr, and CAsiExecStm.

virtual EAsiBoolean CAsiStm::Cvl | ( | int | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiCsrTable, and CAsiCsr.

virtual EAsiBoolean CAsiStm::Cvl | ( | int | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiCsrTable, and CAsiCsr.

EAsiBoolean CAsiStm::CvlInt | ( | int | ,
 |  | CAsiData * |
 | ) |  | const
 protected
Warning
Not implemented!
EAsiBoolean CAsiStm::InitColsDsc ( )
protected
Warning
Not implemented!
virtual CAsiParameter* CAsiStm::ParamDsc ( int ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr, and CAsiExecStm.

virtual int CAsiStm::ParamQty ( void ) const
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr, and CAsiExecStm.

EAsiBoolean CAsiStm::pInput ( void )
protected
Warning
Not implemented!
void CAsiStm::SetSession ( CAsiSession * )
Warning
Not implemented!
virtual EAsiBoolean CAsiStm::Sob | ( | int | ,
 |  | CAsiData * |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr.

virtual EAsiBoolean CAsiStm::Sob | ( | int | ,
 |  | void * | ,
 |  | short * | ,
 |  | int | ,
 |  | EAsiHostType |
 | ) |  |
virtual
Warning
Not implemented!

Reimplemented in CAsiCsr.

The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiStm Member List

This is the complete list of members for CAsiStm, including all inherited members.

Bind(int, CAsiData *) | CAsiStm | virtual
Bind(int, void *, short *, int, EAsiHostType) | CAsiStm | virtual
Bind(const CAsiIdent &, CAsiData *) | CAsiStm | virtual
Bind(const CAsiIdent &, void *, short *, int, EAsiHostType) | CAsiStm | virtual
CAsiObject(void) | CAsiObject |
CAsiSession (defined in CAsiStm) | CAsiStm | friend
CAsiSQLObject() | CAsiSQLObject | protected
CAsiStm(void) | CAsiStm |
CheckOp(ulong) | CAsiSQLObject |
Clear(void) | CAsiObject | virtual
ColDsc(int) const | CAsiStm | virtual
ColQty(void) const | CAsiStm | virtual
CondQty(void) const | CAsiSQLObject | virtual
Cvl(int, CAsiData *) | CAsiStm | virtual
Cvl(int, void *, short *, int, EAsiHostType) | CAsiStm | virtual
CvlInt(int, CAsiData *) const | CAsiStm | protected
DBMS(CAsiUcStr *) const | CAsiSQLObject |
DrvMessage(CAsiUcStr *) const | CAsiSQLObject |
duplicate(void) const | CAsiObject | virtual
Err(int d=0) const | CAsiSQLObject | virtual
ErrMsg(int d=0) | CAsiSQLObject | virtual
ErrPosition(void) const | CAsiSQLObject | virtual
flushCond(void) | CAsiSQLObject | protectedvirtual
getDiagPar(int d, EAsiDiag, integer *) const | CAsiSQLObject | virtual
getDiagPar(int d, EAsiDiag, CAsiUcStr *) const | CAsiSQLObject | virtual
GetStatus(EAsiStatInfo, ULONG_PTR *) | CAsiSQLObject | virtual
InheritStatusInfo(const CAsiSQLObject &) | CAsiSQLObject | protected
InitColsDsc() | CAsiStm | protected
InitErrorInfo(HRESULT, IUnknown *, GUID) | CAsiSQLObject | protected
isInit(void) const | CAsiSQLObject | protected
IsRowset(void) const | CAsiSQLObject | virtual
m_CSP (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_eStmType (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_HResult (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_lColNumber (defined in CAsiStm) | CAsiStm | protected
m_lRowCount (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pAsiRow (defined in CAsiStm) | CAsiStm | protected
m_pColumnInfo (defined in CAsiStm) | CAsiStm | protected
m_pDSProperties (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pIErrorInfo (defined in CAsiSQLObject) | CAsiSQLObject | protected
m_pInput (defined in CAsiStm) | CAsiStm | protected
m_pOutput (defined in CAsiStm) | CAsiStm | protected
m_pSession (defined in CAsiStm) | CAsiStm | protected
m_pStringBuff (defined in CAsiStm) | CAsiStm | protected
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
ParamDsc(int) const | CAsiStm | virtual
ParamQty(void) const | CAsiStm | virtual
pInput(void) | CAsiStm | protected
pushCond(void) | CAsiSQLObject | protectedvirtual
pushErr(EAsiError) | CAsiSQLObject | protectedvirtual
pushHResult(HRESULT) | CAsiSQLObject | protectedvirtual
ReleaseErrorInfo() | CAsiSQLObject | protected
RowCount(void) const | CAsiSQLObject |
setDiagPar(EAsiDiag, integer) | CAsiSQLObject | protectedvirtual
setDiagPar(EAsiDiag, const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
setErr(EAsiError) | CAsiSQLObject | protectedvirtual
setErrMsg(const CAsiUcStr &) | CAsiSQLObject | protectedvirtual
SetSession(CAsiSession *) | CAsiStm |
setSQLSTATE(const char *) | CAsiSQLObject | protectedvirtual
Sob(int, CAsiData *) | CAsiStm | virtual
Sob(int, void *, short *, int, EAsiHostType) | CAsiStm | virtual
SQLObject(CAsiUcStr *) const | CAsiSQLObject |
SQLSTATE(int d=0) | CAsiSQLObject | virtual
StmType(void) const | CAsiSQLObject |
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
Version(void) const | CAsiSQLObject |
~CAsiObject(void) | CAsiObject | virtual
~CAsiSQLObject() | CAsiSQLObject | virtual
~CAsiStm(void) | CAsiStm | virtual


ZRX API Reference: CAsiTACond Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Friends | List of all members
CAsiTACond Class Reference
Misc Classes
+ Inheritance diagram for CAsiTACond:

Public Member Functions

CAsiTACond (void)
CAsiTACond (const CAsiTACond &)
virtual CAsiObject * | duplicate (void) const
virtual | ~CAsiTACond (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)

Public Attributes

int | m_cColnum
EAsiCompType | m_CompOp
CAsiData * | m_pData

Friends

class CAsiTCCond

Constructor & Destructor Documentation

CAsiTACond::CAsiTACond ( void )
Warning
Not implemented!
CAsiTACond::CAsiTACond ( const CAsiTACond & )
Warning
Not implemented!
virtual CAsiTACond::~CAsiTACond ( void )
virtual
Warning
Not implemented!

Member Function Documentation

virtual CAsiObject* CAsiTACond::duplicate ( void ) const
virtual
Warning
Not implemented!

Reimplemented from CAsiObject.

The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiTACond Member List

This is the complete list of members for CAsiTACond, including all inherited members.

CAsiObject(void) | CAsiObject |
CAsiTACond(void) | CAsiTACond |
CAsiTACond(const CAsiTACond &) | CAsiTACond |
CAsiTCCond (defined in CAsiTACond) | CAsiTACond | friend
Clear(void) | CAsiObject | virtual
duplicate(void) const | CAsiTACond | virtual
m_cColnum (defined in CAsiTACond) | CAsiTACond |
m_CompOp (defined in CAsiTACond) | CAsiTACond |
m_pData (defined in CAsiTACond) | CAsiTACond |
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiTACond(void) | CAsiTACond | virtual


ZRX API Reference: CAsiTCCond Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CAsiTCCond Class Reference
Misc Classes
+ Inheritance diagram for CAsiTCCond:

Public Member Functions

void | Append (const CAsiTACond &)
CAsiTCCond (int)
CAsiTCCond (const CAsiTCCond &)
int | Count (void) const
virtual CAsiObject * | duplicate (void) const
CAsiTACond & | operator[] (int)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
virtual void | Clear (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual | ~CAsiObject (void)
The documentation for this class was generated from the following file:
  • asiclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiTCCond Member List

This is the complete list of members for CAsiTCCond, including all inherited members.

Append(const CAsiTACond &) (defined in CAsiTCCond) | CAsiTCCond |
CAsiObject(void) | CAsiObject |
CAsiTCCond(void) (defined in CAsiTCCond) | CAsiTCCond |
CAsiTCCond(int) (defined in CAsiTCCond) | CAsiTCCond |
CAsiTCCond(const CAsiTCCond &) (defined in CAsiTCCond) | CAsiTCCond |
Clear(void) | CAsiObject | virtual
Count(void) const (defined in CAsiTCCond) | CAsiTCCond |
duplicate(void) const (defined in CAsiTCCond) | CAsiTCCond | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator[](int) (defined in CAsiTCCond) | CAsiTCCond |
packSize(void) const | CAsiObject | virtual
packTo(CAsiObjPack *) const | CAsiObject | virtual
packValueSize(void) const | CAsiObject | virtual
packValueTo(CAsiObjPack *) const | CAsiObject | virtual
unpackFrom(CAsiObjPack *) | CAsiObject | virtual
unpackValueFrom(CAsiObjPack *) | CAsiObject | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiTCCond(void) (defined in CAsiTCCond) | CAsiTCCond | virtual


ZRX API Reference: CAsiTime Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiTime Class Reference
Misc Classes
+ Inheritance diagram for CAsiTime:

Public Member Functions

CAsiTime (const CAsiDT &)
CAsiTime (uint)
CAsiTime (uint, const CAsiDT &)
CAsiTime (const CAsiTime &)
virtual EAsiDTType | DateTimeType (void) const
virtual ushort | Day (void) const
CAsiDT | DTDiff (const CAsiTime &, const CAsiDT &) const
virtual CAsiObject * | duplicate (void) const
EAsiBoolean | get (ASI_DTTIME *) const
EAsiBoolean | get (DBTIME *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual ushort | Hour (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual ushort | Minute (void) const
virtual ushort | Month (void) const
int | operator!= (const CAsiTime &) const
CAsiTime | operator+ (const CAsiDT &) const
CAsiTime | operator- (const CAsiDT &) const
int | operator< (const CAsiTime &) const
int | operator<= (const CAsiTime &) const
CAsiTime & | operator= (const CAsiTime &)
int | operator== (const CAsiTime &) const
int | operator> (const CAsiTime &) const
int | operator>= (const CAsiTime &) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual uint | ReturnLength (void) const
virtual double | Second (void) const
EAsiBoolean | set (ASI_DTTIME *)
EAsiBoolean | set (const DBTIME *)
EAsiBoolean | set (ushort, ushort, double)
EAsiBoolean | setHour (ushort)
EAsiBoolean | setMinute (ushort)
EAsiBoolean | setSecond (double)
EAsiBoolean | setTimeZone (const CAsiDT &)
void | setWithTimeZone (EAsiBoolean f=kAsiTrue)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual uint | TimePrec (void) const
const CAsiDT & | TimeZone (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual ushort | Year (void) const
- Public Member Functions inherited from CAsiDatetime
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiDataType | Type (void) const
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual void | Clear (void)
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

class | CAsiTempTable
class | CAsiTimeStamp
CAsiTime DLLScope | operator+ (const CAsiDT &, const CAsiTime &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiTime Member List

This is the complete list of members for CAsiTime, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDatetime() (defined in CAsiDatetime) | CAsiDatetime |
CAsiObject(void) | CAsiObject |
CAsiTempTable (defined in CAsiTime) | CAsiTime | friend
CAsiTime(void) (defined in CAsiTime) | CAsiTime |
CAsiTime(const CAsiDT &) (defined in CAsiTime) | CAsiTime |
CAsiTime(uint) (defined in CAsiTime) | CAsiTime |
CAsiTime(uint, const CAsiDT &) (defined in CAsiTime) | CAsiTime |
CAsiTime(const CAsiTime &) (defined in CAsiTime) | CAsiTime |
CAsiTimeStamp (defined in CAsiTime) | CAsiTime | friend
checkAdd(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiData | virtual
checkMul(const CAsiData *) const | CAsiData | virtual
checkSet(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
checkSub(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const (defined in CAsiTime) | CAsiTime | virtual
Day(void) const (defined in CAsiTime) | CAsiTime | inlinevirtual
DTDiff(const CAsiTime &, const CAsiDT &) const (defined in CAsiTime) | CAsiTime |
duplicate(void) const (defined in CAsiTime) | CAsiTime | virtual
FracSecPrec(void) const | CAsiData | virtual
get(ASI_DTTIME *) const (defined in CAsiTime) | CAsiTime |
get(DBTIME *) const (defined in CAsiTime) | CAsiTime |
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(char *, uint) const (defined in CAsiTime) | CAsiTime | virtual
getValue(CAsiUcStr *) const (defined in CAsiTime) | CAsiTime | virtual
getValue(DBTIME *) const (defined in CAsiTime) | CAsiTime | virtual
getValue(real *) const (defined in CAsiTime) | CAsiTime | virtual
getValue(integer *) const (defined in CAsiTime) | CAsiTime | virtual
getValue(smallint *) const (defined in CAsiTime) | CAsiTime | virtual
getValue(char *, uint, uint *) const (defined in CAsiTime) | CAsiTime | virtual
getValue(AsiUcStr, uint) const (defined in CAsiTime) | CAsiTime | virtual
getValue(CAsiData &) const (defined in CAsiTime) | CAsiTime | virtual
CAsiDatetime::getValue(DECIMAL *) const | CAsiData | virtual
CAsiDatetime::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiDatetime::getValue(DBDATE *) const | CAsiData | virtual
CAsiDatetime::getValue(DBTIMESTAMP *) const | CAsiData | virtual
Hour(void) const (defined in CAsiTime) | CAsiTime | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const (defined in CAsiTime) | CAsiTime | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
is_datetime(void) const (defined in CAsiDatetime) | CAsiDatetime | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const (defined in CAsiTime) | CAsiTime | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiTime) | CAsiTime | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiTime) | CAsiTime | virtual
isNull(void) const | CAsiData | virtual
isnull (defined in CAsiData) | CAsiData | protected
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiTime) | CAsiTime | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiTime) | CAsiTime | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
Minute(void) const (defined in CAsiTime) | CAsiTime | virtual
Month(void) const (defined in CAsiTime) | CAsiTime | inlinevirtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiTime &) const (defined in CAsiTime) | CAsiTime |
operator+(const CAsiDT &) const (defined in CAsiTime) | CAsiTime |
operator+ (defined in CAsiTime) | CAsiTime | friend
operator-(const CAsiDT &) const (defined in CAsiTime) | CAsiTime |
operator<(const CAsiTime &) const (defined in CAsiTime) | CAsiTime |
operator<=(const CAsiTime &) const (defined in CAsiTime) | CAsiTime |
operator=(const CAsiTime &) (defined in CAsiTime) | CAsiTime |
operator==(const CAsiTime &) const (defined in CAsiTime) | CAsiTime |
operator>(const CAsiTime &) const (defined in CAsiTime) | CAsiTime |
operator>=(const CAsiTime &) const (defined in CAsiTime) | CAsiTime |
packSize(void) const (defined in CAsiTime) | CAsiTime | virtual
packTo(CAsiObjPack *) const (defined in CAsiTime) | CAsiTime | virtual
packValueSize(void) const (defined in CAsiTime) | CAsiTime | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiTime) | CAsiTime | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const (defined in CAsiTime) | CAsiTime | virtual
Scale(void) const | CAsiData | virtual
Second(void) const (defined in CAsiTime) | CAsiTime | virtual
set(ASI_DTTIME *) (defined in CAsiTime) | CAsiTime |
set(const DBTIME *) (defined in CAsiTime) | CAsiTime |
set(ushort, ushort, double) (defined in CAsiTime) | CAsiTime |
setHour(ushort) (defined in CAsiTime) | CAsiTime |
setMinute(ushort) (defined in CAsiTime) | CAsiTime |
setNull(void) | CAsiData | virtual
setSecond(double) (defined in CAsiTime) | CAsiTime |
setTimeZone(const CAsiDT &) (defined in CAsiTime) | CAsiTime |
setWithTimeZone(EAsiBoolean f=kAsiTrue) (defined in CAsiTime) | CAsiTime |
SQLLiteral(CAsiUcStr *) const (defined in CAsiTime) | CAsiTime | virtual
SQLType(CAsiUcStr *) const (defined in CAsiTime) | CAsiTime | virtual
storeValue(char *, uint) (defined in CAsiTime) | CAsiTime | virtual
storeValue(const CAsiUcStr &) (defined in CAsiTime) | CAsiTime | virtual
storeValue(const CAsiData &) (defined in CAsiTime) | CAsiTime | virtual
storeValue(const DBTIME *) (defined in CAsiTime) | CAsiTime | virtual
storeValue(real) (defined in CAsiTime) | CAsiTime | virtual
storeValue(integer) (defined in CAsiTime) | CAsiTime | virtual
storeValue(smallint) (defined in CAsiTime) | CAsiTime | virtual
storeValue(char *, uint, uint *) (defined in CAsiTime) | CAsiTime | virtual
storeValue(const AsiUcStr) (defined in CAsiTime) | CAsiTime | virtual
CAsiDatetime::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiDatetime::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiDatetime::storeValue(const DBDATE *) | CAsiData | virtual
CAsiDatetime::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const (defined in CAsiTime) | CAsiTime | virtual
TimeStampPrec(void) const | CAsiData | virtual
TimeZone(void) const (defined in CAsiTime) | CAsiTime |
Type(void) const (defined in CAsiDatetime) | CAsiDatetime | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiTime) | CAsiTime | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiTime) | CAsiTime | virtual
Year(void) const (defined in CAsiTime) | CAsiTime | inlinevirtual
~CAsiData(void) | CAsiData | virtual
~CAsiDatetime() (defined in CAsiDatetime) | CAsiDatetime | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiTime(void) (defined in CAsiTime) | CAsiTime | virtual


ZRX API Reference: CAsiTimeStamp Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiTimeStamp Class Reference
Misc Classes
+ Inheritance diagram for CAsiTimeStamp:

Public Member Functions

CAsiTimeStamp (uint)
CAsiTimeStamp (const CAsiDT &)
CAsiTimeStamp (uint, const CAsiDT &)
CAsiTimeStamp (const CAsiTimeStamp &)
virtual EAsiDTType | DateTimeType (void) const
virtual ushort | Day (void) const
CAsiDT | DTDiff (const CAsiTimeStamp &, const CAsiDT &) const
virtual CAsiObject * | duplicate (void) const
EAsiBoolean | get (ASI_DTTIMESTAMP *) const
EAsiBoolean | get (DBTIMESTAMP *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
virtual ushort | Hour (void) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
virtual ushort | Minute (void) const
virtual ushort | Month (void) const
int | operator!= (const CAsiTimeStamp &) const
CAsiTimeStamp | operator+ (const CAsiYM &) const
CAsiTimeStamp | operator+ (const CAsiDT &) const
CAsiTimeStamp | operator- (const CAsiYM &) const
CAsiTimeStamp | operator- (const CAsiDT &) const
int | operator< (const CAsiTimeStamp &) const
int | operator<= (const CAsiTimeStamp &) const
CAsiTimeStamp & | operator= (const CAsiTimeStamp &)
CAsiTimeStamp & | operator= (const CAsiDate &)
CAsiTimeStamp & | operator= (const CAsiTime &)
int | operator== (const CAsiTimeStamp &) const
int | operator> (const CAsiTimeStamp &) const
int | operator>= (const CAsiTimeStamp &) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
virtual uint | ReturnLength (void) const
virtual double | Second (void) const
EAsiBoolean | set (ASI_DTTIMESTAMP *)
EAsiBoolean | set (const DBTIMESTAMP *)
EAsiBoolean | set (const CAsiDate &, const CAsiTime &)
EAsiBoolean | set (ushort, ushort, ushort, ushort, ushort, double)
EAsiBoolean | setDay (ushort)
EAsiBoolean | setHour (ushort)
EAsiBoolean | setMinute (ushort)
EAsiBoolean | setMonth (ushort)
virtual void | setNull (void)
EAsiBoolean | setSecond (double)
EAsiBoolean | setTimeZone (const CAsiDT &)
void | setWithTimeZone (EAsiBoolean f=kAsiTrue)
EAsiBoolean | setYear (ushort)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual uint | TimeStampPrec (void) const
const CAsiDT & | TimeZone (void) const
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
virtual ushort | Year (void) const
CAsiYM | YMDiff (const CAsiTimeStamp &, const CAsiYM &) const
- Public Member Functions inherited from CAsiDatetime
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiDataType | Type (void) const
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual void | Clear (void)
virtual uint | FracSecPrec (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual int | ImplDataType (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_interval (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | is_yminterval (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | LeadFieldPrec (void) const
virtual uint | Length (void) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual uint | TimePrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Friends

class | CAsiDate
class | CAsiTempTable
class | CAsiTime
CAsiTimeStamp DLLScope | operator+ (const CAsiYM &, CAsiTimeStamp &)
CAsiTimeStamp DLLScope | operator+ (const CAsiDT &, CAsiTimeStamp &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiTimeStamp Member List

This is the complete list of members for CAsiTimeStamp, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDate (defined in CAsiTimeStamp) | CAsiTimeStamp | friend
CAsiDatetime() (defined in CAsiDatetime) | CAsiDatetime |
CAsiObject(void) | CAsiObject |
CAsiTempTable (defined in CAsiTimeStamp) | CAsiTimeStamp | friend
CAsiTime (defined in CAsiTimeStamp) | CAsiTimeStamp | friend
CAsiTimeStamp() (defined in CAsiTimeStamp) | CAsiTimeStamp |
CAsiTimeStamp(uint) (defined in CAsiTimeStamp) | CAsiTimeStamp |
CAsiTimeStamp(const CAsiDT &) (defined in CAsiTimeStamp) | CAsiTimeStamp |
CAsiTimeStamp(uint, const CAsiDT &) (defined in CAsiTimeStamp) | CAsiTimeStamp |
CAsiTimeStamp(const CAsiTimeStamp &) (defined in CAsiTimeStamp) | CAsiTimeStamp |
checkAdd(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const | CAsiData | virtual
checkMul(const CAsiData *) const | CAsiData | virtual
checkSet(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
checkSub(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
Day(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
DTDiff(const CAsiTimeStamp &, const CAsiDT &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
duplicate(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
FracSecPrec(void) const | CAsiData | virtual
get(ASI_DTTIMESTAMP *) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
get(DBTIMESTAMP *) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getValue(char *, uint) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
getValue(CAsiUcStr *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
getValue(DBTIMESTAMP *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
getValue(real *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
getValue(integer *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
getValue(smallint *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
getValue(char *, uint, uint *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
getValue(AsiUcStr, uint) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
getValue(CAsiData &) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
CAsiDatetime::getValue(DECIMAL *) const | CAsiData | virtual
CAsiDatetime::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiDatetime::getValue(DBDATE *) const | CAsiData | virtual
CAsiDatetime::getValue(DBTIME *) const | CAsiData | virtual
Hour(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const | CAsiData | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const (defined in CAsiDatetime) | CAsiDatetime | virtual
is_datetime(void) const (defined in CAsiDatetime) | CAsiDatetime | virtual
is_dtinterval(void) const | CAsiData | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const | CAsiData | virtual
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
is_yminterval(void) const | CAsiData | virtual
isEqualTo(const CAsiData &) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
LeadFieldPrec(void) const | CAsiData | virtual
Length(void) const | CAsiData | virtual
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
Minute(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
Month(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiTimeStamp &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator+(const CAsiYM &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator+(const CAsiDT &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator+ (defined in CAsiTimeStamp) | CAsiTimeStamp | friend
operator+ (defined in CAsiTimeStamp) | CAsiTimeStamp | friend
operator-(const CAsiYM &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator-(const CAsiDT &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator<(const CAsiTimeStamp &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator<=(const CAsiTimeStamp &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator=(const CAsiTimeStamp &) (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator=(const CAsiDate &) (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator=(const CAsiTime &) (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator==(const CAsiTimeStamp &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator>(const CAsiTimeStamp &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
operator>=(const CAsiTimeStamp &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
packSize(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
packTo(CAsiObjPack *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
packValueSize(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
Scale(void) const | CAsiData | virtual
Second(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
set(ASI_DTTIMESTAMP *) (defined in CAsiTimeStamp) | CAsiTimeStamp |
set(const DBTIMESTAMP *) (defined in CAsiTimeStamp) | CAsiTimeStamp |
set(const CAsiDate &, const CAsiTime &) (defined in CAsiTimeStamp) | CAsiTimeStamp |
set(ushort, ushort, ushort, ushort, ushort, double) (defined in CAsiTimeStamp) | CAsiTimeStamp |
setDay(ushort) (defined in CAsiTimeStamp) | CAsiTimeStamp |
setHour(ushort) (defined in CAsiTimeStamp) | CAsiTimeStamp |
setMinute(ushort) (defined in CAsiTimeStamp) | CAsiTimeStamp |
setMonth(ushort) (defined in CAsiTimeStamp) | CAsiTimeStamp |
setNull(void) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
setSecond(double) (defined in CAsiTimeStamp) | CAsiTimeStamp |
setTimeZone(const CAsiDT &) (defined in CAsiTimeStamp) | CAsiTimeStamp |
setWithTimeZone(EAsiBoolean f=kAsiTrue) (defined in CAsiTimeStamp) | CAsiTimeStamp |
setYear(ushort) (defined in CAsiTimeStamp) | CAsiTimeStamp |
SQLLiteral(CAsiUcStr *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
SQLType(CAsiUcStr *) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
storeValue(char *, uint) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
storeValue(const CAsiUcStr &) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
storeValue(const CAsiData &) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
storeValue(const DBTIMESTAMP *) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
storeValue(real) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
storeValue(integer) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
storeValue(smallint) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
storeValue(char *, uint, uint *) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
storeValue(const AsiUcStr) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
CAsiDatetime::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiDatetime::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiDatetime::storeValue(const DBDATE *) | CAsiData | virtual
CAsiDatetime::storeValue(const DBTIME *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
TimeZone(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
Type(void) const (defined in CAsiDatetime) | CAsiDatetime | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
Year(void) const (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual
YMDiff(const CAsiTimeStamp &, const CAsiYM &) const (defined in CAsiTimeStamp) | CAsiTimeStamp |
~CAsiData(void) | CAsiData | virtual
~CAsiDatetime() (defined in CAsiDatetime) | CAsiDatetime | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiTimeStamp(void) (defined in CAsiTimeStamp) | CAsiTimeStamp | virtual


ZRX API Reference: CAsiUcChar Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Friends | List of all members
CAsiUcChar Class Reference
Misc Classes

Public Member Functions

int | Comp (int) const
int | Comp (int, AsiUcIdCCT) const
int | Comp (int, AsiUcNmCCT) const
int | Comp (AsiUcChar) const
int | Comp (CAsiUcChar *) const
int | Comp (const CAsiUcChar &) const
int | Compi (int) const
int | Compi (int, AsiUcIdCCT) const
int | Compi (int, AsiUcNmCCT) const
int | Compi (AsiUcChar) const
int | Compi (CAsiUcChar *) const
int | Compi (const CAsiUcChar &) const
int | getChar (void) const
int | getChar (AsiUcIdCCT) const
int | getChar (AsiUcNmCCT) const
AsiUcChar | getUcChar (void) const
int | isAlnum (void) const
int | isAlpha (void) const
int | isCntrl (void) const
int | isDigit (void) const
int | isGraph (void) const
int | isLower (void) const
int | isPrint (void) const
int | isPunct (void) const
int | isSpace (void) const
int | isUpper (void) const
int | isXdigit (void) const
CAsiUcChar | Lower (void) const
void | operator delete (void *)
void * | operator new (size_t)
CAsiUcChar & | operator= (const char)
CAsiUcChar & | operator= (const AsiUcChar)
CAsiUcChar & | operator= (const CAsiUcChar &)
void | setChar (int, AsiUcIdCCT)
void | setChar (int, AsiUcNmCCT)
void | setChar (AsiUcChar)
void | setLower (void)
void | setUpper (void)
CAsiUcChar | Upper (void) const

Public Attributes

AsiUcChar Symbol

Friends

DLLScope int | operator!= (const CAsiUcChar &, const char)
DLLScope int | operator!= (const char, const CAsiUcChar &)
DLLScope int | operator!= (const CAsiUcChar &, const AsiUcChar)
DLLScope int | operator!= (const AsiUcChar, const CAsiUcChar &)
DLLScope int | operator!= (const CAsiUcChar &, const CAsiUcChar &)
DLLScope int | operator< (const CAsiUcChar &, const char)
DLLScope int | operator< (const char, const CAsiUcChar &)
DLLScope int | operator< (const CAsiUcChar &, const AsiUcChar)
DLLScope int | operator< (const AsiUcChar, const CAsiUcChar &)
DLLScope int | operator< (const CAsiUcChar &, const CAsiUcChar &)
DLLScope int | operator<= (const CAsiUcChar &, const char)
DLLScope int | operator<= (const char, const CAsiUcChar &)
DLLScope int | operator<= (const CAsiUcChar &, const AsiUcChar)
DLLScope int | operator<= (const AsiUcChar, const CAsiUcChar &)
DLLScope int | operator<= (const CAsiUcChar &, const CAsiUcChar &)
DLLScope int | operator== (const CAsiUcChar &, const char)
DLLScope int | operator== (const char, const CAsiUcChar &)
DLLScope int | operator== (const CAsiUcChar &, const AsiUcChar)
DLLScope int | operator== (const AsiUcChar, const CAsiUcChar &)
DLLScope int | operator== (const CAsiUcChar &, const CAsiUcChar &)
DLLScope int | operator> (const CAsiUcChar &, const char)
DLLScope int | operator> (const char, const CAsiUcChar &)
DLLScope int | operator> (const CAsiUcChar &, const AsiUcChar)
DLLScope int | operator> (const AsiUcChar, const CAsiUcChar &)
DLLScope int | operator> (const CAsiUcChar &, const CAsiUcChar &)
DLLScope int | operator>= (const CAsiUcChar &, const char)
DLLScope int | operator>= (const char, const CAsiUcChar &)
DLLScope int | operator>= (const CAsiUcChar &, const AsiUcChar)
DLLScope int | operator>= (const AsiUcChar, const CAsiUcChar &)
DLLScope int | operator>= (const CAsiUcChar &, const CAsiUcChar &)
The documentation for this class was generated from the following file:
  • asiucode.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiUcChar Member List

This is the complete list of members for CAsiUcChar, including all inherited members.

Comp(int) const (defined in CAsiUcChar) | CAsiUcChar |
Comp(int, AsiUcIdCCT) const (defined in CAsiUcChar) | CAsiUcChar |
Comp(int, AsiUcNmCCT) const (defined in CAsiUcChar) | CAsiUcChar |
Comp(AsiUcChar) const (defined in CAsiUcChar) | CAsiUcChar |
Comp(CAsiUcChar *) const (defined in CAsiUcChar) | CAsiUcChar |
Comp(const CAsiUcChar &) const (defined in CAsiUcChar) | CAsiUcChar |
Compi(int) const (defined in CAsiUcChar) | CAsiUcChar |
Compi(int, AsiUcIdCCT) const (defined in CAsiUcChar) | CAsiUcChar |
Compi(int, AsiUcNmCCT) const (defined in CAsiUcChar) | CAsiUcChar |
Compi(AsiUcChar) const (defined in CAsiUcChar) | CAsiUcChar |
Compi(CAsiUcChar *) const (defined in CAsiUcChar) | CAsiUcChar |
Compi(const CAsiUcChar &) const (defined in CAsiUcChar) | CAsiUcChar |
getChar(void) const (defined in CAsiUcChar) | CAsiUcChar |
getChar(AsiUcIdCCT) const (defined in CAsiUcChar) | CAsiUcChar |
getChar(AsiUcNmCCT) const (defined in CAsiUcChar) | CAsiUcChar |
getUcChar(void) const (defined in CAsiUcChar) | CAsiUcChar |
isAlnum(void) const (defined in CAsiUcChar) | CAsiUcChar |
isAlpha(void) const (defined in CAsiUcChar) | CAsiUcChar |
isCntrl(void) const (defined in CAsiUcChar) | CAsiUcChar |
isDigit(void) const (defined in CAsiUcChar) | CAsiUcChar |
isGraph(void) const (defined in CAsiUcChar) | CAsiUcChar |
isLower(void) const (defined in CAsiUcChar) | CAsiUcChar |
isPrint(void) const (defined in CAsiUcChar) | CAsiUcChar |
isPunct(void) const (defined in CAsiUcChar) | CAsiUcChar |
isSpace(void) const (defined in CAsiUcChar) | CAsiUcChar |
isUpper(void) const (defined in CAsiUcChar) | CAsiUcChar |
isXdigit(void) const (defined in CAsiUcChar) | CAsiUcChar |
Lower(void) const (defined in CAsiUcChar) | CAsiUcChar |
operator delete(void *) (defined in CAsiUcChar) | CAsiUcChar |
operator new(size_t) (defined in CAsiUcChar) | CAsiUcChar |
operator!= (defined in CAsiUcChar) | CAsiUcChar | friend
operator!= (defined in CAsiUcChar) | CAsiUcChar | friend
operator!= (defined in CAsiUcChar) | CAsiUcChar | friend
operator!= (defined in CAsiUcChar) | CAsiUcChar | friend
operator!= (defined in CAsiUcChar) | CAsiUcChar | friend
operator< (defined in CAsiUcChar) | CAsiUcChar | friend
operator< (defined in CAsiUcChar) | CAsiUcChar | friend
operator< (defined in CAsiUcChar) | CAsiUcChar | friend
operator< (defined in CAsiUcChar) | CAsiUcChar | friend
operator< (defined in CAsiUcChar) | CAsiUcChar | friend
operator<= (defined in CAsiUcChar) | CAsiUcChar | friend
operator<= (defined in CAsiUcChar) | CAsiUcChar | friend
operator<= (defined in CAsiUcChar) | CAsiUcChar | friend
operator<= (defined in CAsiUcChar) | CAsiUcChar | friend
operator<= (defined in CAsiUcChar) | CAsiUcChar | friend
operator=(const char) (defined in CAsiUcChar) | CAsiUcChar |
operator=(const AsiUcChar) (defined in CAsiUcChar) | CAsiUcChar |
operator=(const CAsiUcChar &) (defined in CAsiUcChar) | CAsiUcChar |
operator== (defined in CAsiUcChar) | CAsiUcChar | friend
operator== (defined in CAsiUcChar) | CAsiUcChar | friend
operator== (defined in CAsiUcChar) | CAsiUcChar | friend
operator== (defined in CAsiUcChar) | CAsiUcChar | friend
operator== (defined in CAsiUcChar) | CAsiUcChar | friend
operator> (defined in CAsiUcChar) | CAsiUcChar | friend
operator> (defined in CAsiUcChar) | CAsiUcChar | friend
operator> (defined in CAsiUcChar) | CAsiUcChar | friend
operator> (defined in CAsiUcChar) | CAsiUcChar | friend
operator> (defined in CAsiUcChar) | CAsiUcChar | friend
operator>= (defined in CAsiUcChar) | CAsiUcChar | friend
operator>= (defined in CAsiUcChar) | CAsiUcChar | friend
operator>= (defined in CAsiUcChar) | CAsiUcChar | friend
operator>= (defined in CAsiUcChar) | CAsiUcChar | friend
operator>= (defined in CAsiUcChar) | CAsiUcChar | friend
setChar(int, AsiUcIdCCT) (defined in CAsiUcChar) | CAsiUcChar |
setChar(int, AsiUcNmCCT) (defined in CAsiUcChar) | CAsiUcChar |
setChar(AsiUcChar) (defined in CAsiUcChar) | CAsiUcChar |
setLower(void) (defined in CAsiUcChar) | CAsiUcChar |
setUpper(void) (defined in CAsiUcChar) | CAsiUcChar |
Symbol (defined in CAsiUcChar) | CAsiUcChar |
Upper(void) const (defined in CAsiUcChar) | CAsiUcChar |


ZRX API Reference: CAsiUcStr Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
CAsiUcStr Class Reference
Misc Classes

Public Member Functions

void | Append (const char *)
void | Append (const char *, AsiUcNmCCT)
void | Append (const char *, AsiUcIdCCT)
void | Append (const wchar_t *, AsiUcNmCCT)
void | Append (const wchar_t *, AsiUcIdCCT)
void | Append (const AsiUcStr)
void | Append (const CAsiUcStr &)
void | Append (const CAsiUcStr *)
void | Append (const char *, int)
void | Append (const char *, int, AsiUcNmCCT)
void | Append (const char *, int, AsiUcIdCCT)
void | Append (const wchar_t *, int, AsiUcNmCCT)
void | Append (const wchar_t *, int, AsiUcIdCCT)
void | Append (const AsiUcStr, int)
void | Append (const CAsiUcStr &, int)
void | Append (const CAsiUcStr *, int)
void | Append (int)
void | Append (int, AsiUcNmCCT)
void | Append (int, AsiUcIdCCT)
void | Append (AsiUcChar)
void | Append (const CAsiUcChar &)
void | Append (const CAsiUcChar *)
double | Atof (void) const
int | Atoi (void) const
long | Atol (void) const
CAsiUcStr ()
CAsiUcStr (const char *, AsiUcNmCCT)
CAsiUcStr (const char *, AsiUcIdCCT)
CAsiUcStr (const char *)
CAsiUcStr (AsiCUcStr)
CAsiUcStr (const CAsiUcStr &)
CAsiUcStr (const CAsiUcStr *)
int | Chlen (void) const
int | Chlen (AsiUcNmCCT) const
int | Chlen (AsiUcIdCCT) const
int | ChlenChk (void) const
int | ChlenChk (AsiUcNmCCT) const
int | ChlenChk (AsiUcIdCCT) const
void | Clear (void)
int | Comp (const char *) const
int | Comp (const char *, AsiUcNmCCT) const
int | Comp (const char *, AsiUcIdCCT) const
int | Comp (const AsiUcStr) const
int | Comp (const CAsiUcStr &) const
int | Comp (const CAsiUcStr *) const
int | Comp (const char *, int) const
int | Comp (const char *, int, AsiUcNmCCT) const
int | Comp (const char *, int, AsiUcIdCCT) const
int | Comp (const AsiUcStr, int) const
int | Comp (const CAsiUcStr &, int) const
int | Comp (const CAsiUcStr *, int) const
int | Compi (const char *) const
int | Compi (const char *, AsiUcNmCCT) const
int | Compi (const char *, AsiUcIdCCT) const
int | Compi (const wchar_t *, AsiUcNmCCT) const
int | Compi (const wchar_t *, AsiUcIdCCT) const
int | Compi (const AsiUcStr) const
int | Compi (const CAsiUcStr &) const
int | Compi (const CAsiUcStr *) const
int | Compi (const char *, int) const
int | Compi (const char *, int, AsiUcNmCCT) const
int | Compi (const char *, int, AsiUcIdCCT) const
int | Compi (const wchar_t *, int, AsiUcNmCCT) const
int | Compi (const wchar_t *, int, AsiUcIdCCT) const
int | Compi (const AsiUcStr, int) const
int | Compi (const CAsiUcStr &, int) const
int | Compi (const CAsiUcStr *, int) const
void | Copy (const char *)
void | Copy (const char *, AsiUcNmCCT)
void | Copy (const char *, AsiUcIdCCT)
void | Copy (const wchar_t *)
void | Copy (const wchar_t *, AsiUcNmCCT)
void | Copy (const wchar_t *, AsiUcIdCCT)
void | Copy (const AsiUcStr)
void | Copy (const CAsiUcStr &)
void | Copy (const CAsiUcStr *)
void | Copy (const char *, int)
void | Copy (const char *, int, AsiUcNmCCT)
void | Copy (const char *, int, AsiUcIdCCT)
void | Copy (const wchar_t *, int, AsiUcNmCCT)
void | Copy (const wchar_t *, int, AsiUcIdCCT)
void | Copy (const AsiUcStr, int)
void | Copy (const CAsiUcStr &, int)
void | Copy (const CAsiUcStr *, int)
int | FindFirst (const char *) const
int | FindFirst (const char *, AsiUcNmCCT) const
int | FindFirst (const char *, AsiUcIdCCT) const
int | FindFirst (const AsiUcStr) const
int | FindFirst (const CAsiUcStr &) const
int | FindFirst (const CAsiUcStr *) const
int | FindFirst (int) const
int | FindFirst (int, AsiUcNmCCT) const
int | FindFirst (int, AsiUcIdCCT) const
int | FindFirst (AsiUcChar) const
int | FindFirst (const CAsiUcChar &) const
int | FindFirst (const CAsiUcChar *) const
int | FindLast (const char *) const
int | FindLast (const char *, AsiUcNmCCT) const
int | FindLast (const char *, AsiUcIdCCT) const
int | FindLast (const AsiUcStr) const
int | FindLast (const CAsiUcStr &) const
int | FindLast (const CAsiUcStr *) const
int | FindLast (int) const
int | FindLast (int, AsiUcNmCCT) const
int | FindLast (int, AsiUcIdCCT) const
int | FindLast (AsiUcChar) const
int | FindLast (const CAsiUcChar &) const
int | FindLast (const CAsiUcChar *) const
char * | getToChar (char *, int) const
char * | getToChar (char *, int, AsiUcNmCCT) const
char * | getToChar (char *, int, AsiUcIdCCT) const
wchar_t * | getToChar (wchar_t *, int) const
wchar_t * | getToChar (wchar_t *, int, AsiUcNmCCT) const
wchar_t * | getToChar (wchar_t *, int, AsiUcIdCCT) const
char * | getToCharChk (char *, int) const
char * | getToCharChk (char *, int, AsiUcNmCCT) const
char * | getToCharChk (char *, int, AsiUcIdCCT) const
AsiUcStr | getToUcChar (AsiUcStr, int) const
int | Length (void) const
int | MultibyteLen () const
int | MultibyteLen (AsiUcNmCCT) const
int | MultibyteLen (AsiUcIdCCT) const
void | operator delete (void *)
void * | operator new (size_t)
CAsiUcStr & | operator= (const char *)
CAsiUcStr & | operator= (const AsiUcStr)
CAsiUcStr & | operator= (const CAsiUcStr &)
CAsiUcStr & | operator= (const CAsiUcStr *)
const CAsiUcChar & | operator[] (int) const
int | Size (void) const
int | Sprintf (const AsiUcStr,...)
double | Strtod (int *) const
long | Strtol (int *, int) const
void | toLower (void)
void | toUpper (void)
const AsiUcStr | UcStr (void) const
void | Update (int, int)
void | Update (int, int, AsiUcNmCCT)
void | Update (int, int, AsiUcIdCCT)
void | Update (int, AsiUcChar)
void | Update (int, const CAsiUcChar &)
void | Update (int, const CAsiUcChar *)
~CAsiUcStr ()

Friends

int DLLScope | operator!= (const CAsiUcStr &, const char *)
int DLLScope | operator!= (const char *, const CAsiUcStr &)
int DLLScope | operator!= (const CAsiUcStr &, const CAsiUcStr &)
int DLLScope | operator!= (const CAsiUcStr *, const CAsiUcStr &)
int DLLScope | operator!= (const AsiUcStr, const CAsiUcStr &)
int DLLScope | operator!= (const CAsiUcStr &, const CAsiUcStr *)
int DLLScope | operator!= (const CAsiUcStr &, const AsiUcStr)
int DLLScope | operator< (const CAsiUcStr &, const char *)
int DLLScope | operator< (const char *, const CAsiUcStr &)
int DLLScope | operator< (const CAsiUcStr &, const CAsiUcStr &)
int DLLScope | operator< (const CAsiUcStr *, const CAsiUcStr &)
int DLLScope | operator< (const AsiUcStr, const CAsiUcStr &)
int DLLScope | operator< (const CAsiUcStr &, const CAsiUcStr *)
int DLLScope | operator< (const CAsiUcStr &, const AsiUcStr)
int DLLScope | operator<= (const CAsiUcStr &, const char *)
int DLLScope | operator<= (const char *, const CAsiUcStr &)
int DLLScope | operator<= (const CAsiUcStr &, const CAsiUcStr &)
int DLLScope | operator<= (const CAsiUcStr *, const CAsiUcStr &)
int DLLScope | operator<= (const AsiUcStr, const CAsiUcStr &)
int DLLScope | operator<= (const CAsiUcStr &, const CAsiUcStr *)
int DLLScope | operator<= (const CAsiUcStr &, const AsiUcStr)
int DLLScope | operator== (const CAsiUcStr &, const char *)
int DLLScope | operator== (const char *, const CAsiUcStr &)
int DLLScope | operator== (const CAsiUcStr &, const CAsiUcStr &)
int DLLScope | operator== (const CAsiUcStr *, const CAsiUcStr &)
int DLLScope | operator== (const AsiUcStr, const CAsiUcStr &)
int DLLScope | operator== (const CAsiUcStr &, const CAsiUcStr *)
int DLLScope | operator== (const CAsiUcStr &, const AsiUcStr)
int DLLScope | operator> (const CAsiUcStr &, const char *)
int DLLScope | operator> (const char *, const CAsiUcStr &)
int DLLScope | operator> (const CAsiUcStr &, const CAsiUcStr &)
int DLLScope | operator> (const CAsiUcStr *, const CAsiUcStr &)
int DLLScope | operator> (const AsiUcStr, const CAsiUcStr &)
int DLLScope | operator> (const CAsiUcStr &, const CAsiUcStr *)
int DLLScope | operator> (const CAsiUcStr &, const AsiUcStr)
int DLLScope | operator>= (const CAsiUcStr &, const char *)
int DLLScope | operator>= (const char *, const CAsiUcStr &)
int DLLScope | operator>= (const CAsiUcStr &, const CAsiUcStr &)
int DLLScope | operator>= (const CAsiUcStr *, const CAsiUcStr &)
int DLLScope | operator>= (const AsiUcStr, const CAsiUcStr &)
int DLLScope | operator>= (const CAsiUcStr &, const CAsiUcStr *)
int DLLScope | operator>= (const CAsiUcStr &, const AsiUcStr)

Constructor & Destructor Documentation

CAsiUcStr::CAsiUcStr ( )
Warning
Not implemented!
CAsiUcStr::CAsiUcStr | ( | const char * | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
CAsiUcStr::CAsiUcStr | ( | const char * | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
CAsiUcStr::CAsiUcStr ( const char * )
Warning
Not implemented!
CAsiUcStr::CAsiUcStr ( AsiCUcStr )
Warning
Not implemented!
CAsiUcStr::CAsiUcStr ( const CAsiUcStr & )
Warning
Not implemented!
CAsiUcStr::CAsiUcStr ( const CAsiUcStr * )
Warning
Not implemented!
CAsiUcStr::~CAsiUcStr ( )
Warning
Not implemented!

Member Function Documentation

void CAsiUcStr::Append ( const char * )
Warning
Not implemented!
void CAsiUcStr::Append | ( | const char * | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const char * | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const wchar_t * | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const wchar_t * | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append ( const AsiUcStr )
Warning
Not implemented!
void CAsiUcStr::Append ( const CAsiUcStr & )
Warning
Not implemented!
void CAsiUcStr::Append ( const CAsiUcStr * )
Warning
Not implemented!
void CAsiUcStr::Append | ( | const char * | ,
 |  | int |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const char * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const char * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const wchar_t * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const wchar_t * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const AsiUcStr | ,
 |  | int |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const CAsiUcStr & | ,
 |  | int |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | const CAsiUcStr * | ,
 |  | int |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append ( int )
Warning
Not implemented!
void CAsiUcStr::Append | ( | int | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append | ( | int | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Append ( AsiUcChar )
Warning
Not implemented!
void CAsiUcStr::Append ( const CAsiUcChar & )
Warning
Not implemented!
void CAsiUcStr::Append ( const CAsiUcChar * )
Warning
Not implemented!
double CAsiUcStr::Atof ( void ) const
Warning
Not implemented!
int CAsiUcStr::Atoi ( void ) const
Warning
Not implemented!
long CAsiUcStr::Atol ( void ) const
Warning
Not implemented!
int CAsiUcStr::Chlen ( void ) const
Warning
Not implemented!
int CAsiUcStr::Chlen ( AsiUcNmCCT ) const
Warning
Not implemented!
int CAsiUcStr::Chlen ( AsiUcIdCCT ) const
Warning
Not implemented!
int CAsiUcStr::ChlenChk ( void ) const
Warning
Not implemented!
int CAsiUcStr::ChlenChk ( AsiUcNmCCT ) const
Warning
Not implemented!
int CAsiUcStr::ChlenChk ( AsiUcIdCCT ) const
Warning
Not implemented!
void CAsiUcStr::Clear ( void )
Warning
Not implemented!
int CAsiUcStr::Comp ( const char * ) const
Warning
Not implemented!
int CAsiUcStr::Comp | ( | const char * | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Comp | ( | const char * | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Comp ( const AsiUcStr ) const
Warning
Not implemented!
int CAsiUcStr::Comp ( const CAsiUcStr & ) const
Warning
Not implemented!
int CAsiUcStr::Comp ( const CAsiUcStr * ) const
Warning
Not implemented!
int CAsiUcStr::Comp | ( | const char * | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Comp | ( | const char * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Comp | ( | const char * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Comp | ( | const AsiUcStr | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Comp | ( | const CAsiUcStr & | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Comp | ( | const CAsiUcStr * | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi ( const char * ) const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const char * | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const char * | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const wchar_t * | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const wchar_t * | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi ( const AsiUcStr ) const
Warning
Not implemented!
int CAsiUcStr::Compi ( const CAsiUcStr & ) const
Warning
Not implemented!
int CAsiUcStr::Compi ( const CAsiUcStr * ) const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const char * | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const char * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const char * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const wchar_t * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const wchar_t * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const AsiUcStr | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const CAsiUcStr & | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Compi | ( | const CAsiUcStr * | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
void CAsiUcStr::Copy ( const char * )
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const char * | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const char * | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy ( const wchar_t * )
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const wchar_t * | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const wchar_t * | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy ( const AsiUcStr )
Warning
Not implemented!
void CAsiUcStr::Copy ( const CAsiUcStr & )
Warning
Not implemented!
void CAsiUcStr::Copy ( const CAsiUcStr * )
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const char * | ,
 |  | int |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const char * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const char * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const wchar_t * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const wchar_t * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const AsiUcStr | ,
 |  | int |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const CAsiUcStr & | ,
 |  | int |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Copy | ( | const CAsiUcStr * | ,
 |  | int |
 | ) |  |
Warning
Not implemented!
int CAsiUcStr::FindFirst ( const char * ) const
Warning
Not implemented!
int CAsiUcStr::FindFirst | ( | const char * | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::FindFirst | ( | const char * | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::FindFirst ( const AsiUcStr ) const
Warning
Not implemented!
int CAsiUcStr::FindFirst ( const CAsiUcStr & ) const
Warning
Not implemented!
int CAsiUcStr::FindFirst ( const CAsiUcStr * ) const
Warning
Not implemented!
int CAsiUcStr::FindFirst ( int ) const
Warning
Not implemented!
int CAsiUcStr::FindFirst | ( | int | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::FindFirst | ( | int | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::FindFirst ( AsiUcChar ) const
Warning
Not implemented!
int CAsiUcStr::FindFirst ( const CAsiUcChar & ) const
Warning
Not implemented!
int CAsiUcStr::FindFirst ( const CAsiUcChar * ) const
Warning
Not implemented!
int CAsiUcStr::FindLast ( const char * ) const
Warning
Not implemented!
int CAsiUcStr::FindLast | ( | const char * | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::FindLast | ( | const char * | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::FindLast ( const AsiUcStr ) const
Warning
Not implemented!
int CAsiUcStr::FindLast ( const CAsiUcStr & ) const
Warning
Not implemented!
int CAsiUcStr::FindLast ( const CAsiUcStr * ) const
Warning
Not implemented!
int CAsiUcStr::FindLast ( int ) const
Warning
Not implemented!
int CAsiUcStr::FindLast | ( | int | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::FindLast | ( | int | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::FindLast ( AsiUcChar ) const
Warning
Not implemented!
int CAsiUcStr::FindLast ( const CAsiUcChar & ) const
Warning
Not implemented!
int CAsiUcStr::FindLast ( const CAsiUcChar * ) const
Warning
Not implemented!
char* CAsiUcStr::getToChar | ( | char * | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
char* CAsiUcStr::getToChar | ( | char * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
char* CAsiUcStr::getToChar | ( | char * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
wchar_t* CAsiUcStr::getToChar | ( | wchar_t * | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
wchar_t* CAsiUcStr::getToChar | ( | wchar_t * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
wchar_t* CAsiUcStr::getToChar | ( | wchar_t * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
char* CAsiUcStr::getToCharChk | ( | char * | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
char* CAsiUcStr::getToCharChk | ( | char * | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  | const
Warning
Not implemented!
char* CAsiUcStr::getToCharChk | ( | char * | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  | const
Warning
Not implemented!
AsiUcStr CAsiUcStr::getToUcChar | ( | AsiUcStr | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
int CAsiUcStr::Length ( void ) const
Warning
Not implemented!
int CAsiUcStr::MultibyteLen ( ) const
Warning
Not implemented!
int CAsiUcStr::MultibyteLen ( AsiUcNmCCT ) const
Warning
Not implemented!
int CAsiUcStr::MultibyteLen ( AsiUcIdCCT ) const
Warning
Not implemented!
CAsiUcStr& CAsiUcStr::operator= ( const char * )
Warning
Not implemented!
CAsiUcStr& CAsiUcStr::operator= ( const AsiUcStr )
Warning
Not implemented!
CAsiUcStr& CAsiUcStr::operator= ( const CAsiUcStr & )
Warning
Not implemented!
CAsiUcStr& CAsiUcStr::operator= ( const CAsiUcStr * )
Warning
Not implemented!
const CAsiUcChar& CAsiUcStr::operator[] ( int ) const
Warning
Not implemented!
int CAsiUcStr::Size ( void ) const
Warning
Not implemented!
int CAsiUcStr::Sprintf | ( | const AsiUcStr | ,
 |  |  | ...
 | ) |  |
Warning
Not implemented!
double CAsiUcStr::Strtod ( int * ) const
Warning
Not implemented!
long CAsiUcStr::Strtol | ( | int * | ,
 |  | int |
 | ) |  | const
Warning
Not implemented!
void CAsiUcStr::toLower ( void )
Warning
Not implemented!
void CAsiUcStr::toUpper ( void )
Warning
Not implemented!
const AsiUcStr CAsiUcStr::UcStr ( void ) const
Warning
Not implemented!
void CAsiUcStr::Update | ( | int | ,
 |  | int |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Update | ( | int | ,
 |  | int | ,
 |  | AsiUcNmCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Update | ( | int | ,
 |  | int | ,
 |  | AsiUcIdCCT |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Update | ( | int | ,
 |  | AsiUcChar |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Update | ( | int | ,
 |  | const CAsiUcChar & |
 | ) |  |
Warning
Not implemented!
void CAsiUcStr::Update | ( | int | ,
 |  | const CAsiUcChar * |
 | ) |  |
Warning
Not implemented!
The documentation for this class was generated from the following file:
  • asiucode.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiUcStr Member List

This is the complete list of members for CAsiUcStr, including all inherited members.

Append(const char *) | CAsiUcStr
Append(const char *, AsiUcNmCCT) | CAsiUcStr
Append(const char *, AsiUcIdCCT) | CAsiUcStr
Append(const wchar_t *, AsiUcNmCCT) | CAsiUcStr
Append(const wchar_t *, AsiUcIdCCT) | CAsiUcStr
Append(const AsiUcStr) | CAsiUcStr
Append(const CAsiUcStr &) | CAsiUcStr
Append(const CAsiUcStr *) | CAsiUcStr
Append(const char *, int) | CAsiUcStr
Append(const char *, int, AsiUcNmCCT) | CAsiUcStr
Append(const char *, int, AsiUcIdCCT) | CAsiUcStr
Append(const wchar_t *, int, AsiUcNmCCT) | CAsiUcStr
Append(const wchar_t *, int, AsiUcIdCCT) | CAsiUcStr
Append(const AsiUcStr, int) | CAsiUcStr
Append(const CAsiUcStr &, int) | CAsiUcStr
Append(const CAsiUcStr *, int) | CAsiUcStr
Append(int) | CAsiUcStr
Append(int, AsiUcNmCCT) | CAsiUcStr
Append(int, AsiUcIdCCT) | CAsiUcStr
Append(AsiUcChar) | CAsiUcStr
Append(const CAsiUcChar &) | CAsiUcStr
Append(const CAsiUcChar *) | CAsiUcStr
Atof(void) const | CAsiUcStr
Atoi(void) const | CAsiUcStr
Atol(void) const | CAsiUcStr
CAsiUcStr() CAsiUcStr
CAsiUcStr(const char *, AsiUcNmCCT) | CAsiUcStr
CAsiUcStr(const char *, AsiUcIdCCT) | CAsiUcStr
CAsiUcStr(const char *) | CAsiUcStr
CAsiUcStr(AsiCUcStr) | CAsiUcStr
CAsiUcStr(const CAsiUcStr &) | CAsiUcStr
CAsiUcStr(const CAsiUcStr *) | CAsiUcStr
Chlen(void) const | CAsiUcStr
Chlen(AsiUcNmCCT) const | CAsiUcStr
Chlen(AsiUcIdCCT) const | CAsiUcStr
ChlenChk(void) const | CAsiUcStr
ChlenChk(AsiUcNmCCT) const | CAsiUcStr
ChlenChk(AsiUcIdCCT) const | CAsiUcStr
Clear(void) | CAsiUcStr
Comp(const char *) const | CAsiUcStr
Comp(const char *, AsiUcNmCCT) const | CAsiUcStr
Comp(const char *, AsiUcIdCCT) const | CAsiUcStr
Comp(const AsiUcStr) const | CAsiUcStr
Comp(const CAsiUcStr &) const | CAsiUcStr
Comp(const CAsiUcStr *) const | CAsiUcStr
Comp(const char *, int) const | CAsiUcStr
Comp(const char *, int, AsiUcNmCCT) const | CAsiUcStr
Comp(const char *, int, AsiUcIdCCT) const | CAsiUcStr
Comp(const AsiUcStr, int) const | CAsiUcStr
Comp(const CAsiUcStr &, int) const | CAsiUcStr
Comp(const CAsiUcStr *, int) const | CAsiUcStr
Compi(const char *) const | CAsiUcStr
Compi(const char *, AsiUcNmCCT) const | CAsiUcStr
Compi(const char *, AsiUcIdCCT) const | CAsiUcStr
Compi(const wchar_t *, AsiUcNmCCT) const | CAsiUcStr
Compi(const wchar_t *, AsiUcIdCCT) const | CAsiUcStr
Compi(const AsiUcStr) const | CAsiUcStr
Compi(const CAsiUcStr &) const | CAsiUcStr
Compi(const CAsiUcStr *) const | CAsiUcStr
Compi(const char *, int) const | CAsiUcStr
Compi(const char *, int, AsiUcNmCCT) const | CAsiUcStr
Compi(const char *, int, AsiUcIdCCT) const | CAsiUcStr
Compi(const wchar_t *, int, AsiUcNmCCT) const | CAsiUcStr
Compi(const wchar_t *, int, AsiUcIdCCT) const | CAsiUcStr
Compi(const AsiUcStr, int) const | CAsiUcStr
Compi(const CAsiUcStr &, int) const | CAsiUcStr
Compi(const CAsiUcStr *, int) const | CAsiUcStr
Copy(const char *) | CAsiUcStr
Copy(const char *, AsiUcNmCCT) | CAsiUcStr
Copy(const char *, AsiUcIdCCT) | CAsiUcStr
Copy(const wchar_t *) | CAsiUcStr
Copy(const wchar_t *, AsiUcNmCCT) | CAsiUcStr
Copy(const wchar_t *, AsiUcIdCCT) | CAsiUcStr
Copy(const AsiUcStr) | CAsiUcStr
Copy(const CAsiUcStr &) | CAsiUcStr
Copy(const CAsiUcStr *) | CAsiUcStr
Copy(const char *, int) | CAsiUcStr
Copy(const char *, int, AsiUcNmCCT) | CAsiUcStr
Copy(const char *, int, AsiUcIdCCT) | CAsiUcStr
Copy(const wchar_t *, int, AsiUcNmCCT) | CAsiUcStr
Copy(const wchar_t *, int, AsiUcIdCCT) | CAsiUcStr
Copy(const AsiUcStr, int) | CAsiUcStr
Copy(const CAsiUcStr &, int) | CAsiUcStr
Copy(const CAsiUcStr *, int) | CAsiUcStr
FindFirst(const char *) const | CAsiUcStr
FindFirst(const char *, AsiUcNmCCT) const | CAsiUcStr
FindFirst(const char *, AsiUcIdCCT) const | CAsiUcStr
FindFirst(const AsiUcStr) const | CAsiUcStr
FindFirst(const CAsiUcStr &) const | CAsiUcStr
FindFirst(const CAsiUcStr *) const | CAsiUcStr
FindFirst(int) const | CAsiUcStr
FindFirst(int, AsiUcNmCCT) const | CAsiUcStr
FindFirst(int, AsiUcIdCCT) const | CAsiUcStr
FindFirst(AsiUcChar) const | CAsiUcStr
FindFirst(const CAsiUcChar &) const | CAsiUcStr
FindFirst(const CAsiUcChar *) const | CAsiUcStr
FindLast(const char *) const | CAsiUcStr
FindLast(const char *, AsiUcNmCCT) const | CAsiUcStr
FindLast(const char *, AsiUcIdCCT) const | CAsiUcStr
FindLast(const AsiUcStr) const | CAsiUcStr
FindLast(const CAsiUcStr &) const | CAsiUcStr
FindLast(const CAsiUcStr *) const | CAsiUcStr
FindLast(int) const | CAsiUcStr
FindLast(int, AsiUcNmCCT) const | CAsiUcStr
FindLast(int, AsiUcIdCCT) const | CAsiUcStr
FindLast(AsiUcChar) const | CAsiUcStr
FindLast(const CAsiUcChar &) const | CAsiUcStr
FindLast(const CAsiUcChar *) const | CAsiUcStr
getToChar(char *, int) const | CAsiUcStr
getToChar(char *, int, AsiUcNmCCT) const | CAsiUcStr
getToChar(char *, int, AsiUcIdCCT) const | CAsiUcStr
getToChar(wchar_t *, int) const | CAsiUcStr
getToChar(wchar_t *, int, AsiUcNmCCT) const | CAsiUcStr
getToChar(wchar_t *, int, AsiUcIdCCT) const | CAsiUcStr
getToCharChk(char *, int) const | CAsiUcStr
getToCharChk(char *, int, AsiUcNmCCT) const | CAsiUcStr
getToCharChk(char *, int, AsiUcIdCCT) const | CAsiUcStr
getToUcChar(AsiUcStr, int) const | CAsiUcStr
Length(void) const | CAsiUcStr
MultibyteLen() const | CAsiUcStr
MultibyteLen(AsiUcNmCCT) const | CAsiUcStr
MultibyteLen(AsiUcIdCCT) const | CAsiUcStr
operator delete(void *) (defined in CAsiUcStr) | CAsiUcStr
operator new(size_t) (defined in CAsiUcStr) | CAsiUcStr
operator!= (defined in CAsiUcStr) | CAsiUcStr | friend
operator!= (defined in CAsiUcStr) | CAsiUcStr | friend
operator!= (defined in CAsiUcStr) | CAsiUcStr | friend
operator!= (defined in CAsiUcStr) | CAsiUcStr | friend
operator!= (defined in CAsiUcStr) | CAsiUcStr | friend
operator!= (defined in CAsiUcStr) | CAsiUcStr | friend
operator!= (defined in CAsiUcStr) | CAsiUcStr | friend
operator< (defined in CAsiUcStr) | CAsiUcStr | friend
operator< (defined in CAsiUcStr) | CAsiUcStr | friend
operator< (defined in CAsiUcStr) | CAsiUcStr | friend
operator< (defined in CAsiUcStr) | CAsiUcStr | friend
operator< (defined in CAsiUcStr) | CAsiUcStr | friend
operator< (defined in CAsiUcStr) | CAsiUcStr | friend
operator< (defined in CAsiUcStr) | CAsiUcStr | friend
operator<= (defined in CAsiUcStr) | CAsiUcStr | friend
operator<= (defined in CAsiUcStr) | CAsiUcStr | friend
operator<= (defined in CAsiUcStr) | CAsiUcStr | friend
operator<= (defined in CAsiUcStr) | CAsiUcStr | friend
operator<= (defined in CAsiUcStr) | CAsiUcStr | friend
operator<= (defined in CAsiUcStr) | CAsiUcStr | friend
operator<= (defined in CAsiUcStr) | CAsiUcStr | friend
operator=(const char *) | CAsiUcStr
operator=(const AsiUcStr) | CAsiUcStr
operator=(const CAsiUcStr &) | CAsiUcStr
operator=(const CAsiUcStr *) | CAsiUcStr
operator== (defined in CAsiUcStr) | CAsiUcStr | friend
operator== (defined in CAsiUcStr) | CAsiUcStr | friend
operator== (defined in CAsiUcStr) | CAsiUcStr | friend
operator== (defined in CAsiUcStr) | CAsiUcStr | friend
operator== (defined in CAsiUcStr) | CAsiUcStr | friend
operator== (defined in CAsiUcStr) | CAsiUcStr | friend
operator== (defined in CAsiUcStr) | CAsiUcStr | friend
operator> (defined in CAsiUcStr) | CAsiUcStr | friend
operator> (defined in CAsiUcStr) | CAsiUcStr | friend
operator> (defined in CAsiUcStr) | CAsiUcStr | friend
operator> (defined in CAsiUcStr) | CAsiUcStr | friend
operator> (defined in CAsiUcStr) | CAsiUcStr | friend
operator> (defined in CAsiUcStr) | CAsiUcStr | friend
operator> (defined in CAsiUcStr) | CAsiUcStr | friend
operator>= (defined in CAsiUcStr) | CAsiUcStr | friend
operator>= (defined in CAsiUcStr) | CAsiUcStr | friend
operator>= (defined in CAsiUcStr) | CAsiUcStr | friend
operator>= (defined in CAsiUcStr) | CAsiUcStr | friend
operator>= (defined in CAsiUcStr) | CAsiUcStr | friend
operator>= (defined in CAsiUcStr) | CAsiUcStr | friend
operator>= (defined in CAsiUcStr) | CAsiUcStr | friend
operator[](int) const | CAsiUcStr
Size(void) const | CAsiUcStr
Sprintf(const AsiUcStr,...) | CAsiUcStr
Strtod(int *) const | CAsiUcStr
Strtol(int *, int) const | CAsiUcStr
toLower(void) | CAsiUcStr
toUpper(void) | CAsiUcStr
UcStr(void) const | CAsiUcStr
Update(int, int) | CAsiUcStr
Update(int, int, AsiUcNmCCT) | CAsiUcStr
Update(int, int, AsiUcIdCCT) | CAsiUcStr
Update(int, AsiUcChar) | CAsiUcStr
Update(int, const CAsiUcChar &) | CAsiUcStr
Update(int, const CAsiUcChar *) | CAsiUcStr


ZRX API Reference: CAsiYM Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAsiYM Class Reference
Misc Classes
+ Inheritance diagram for CAsiYM:

Public Member Functions

CAsiYM (EAsiIType)
CAsiYM (EAsiIType, uint)
CAsiYM (const CAsiYM &)
virtual CAsiObject * | duplicate (void) const
EAsiBoolean | get (ASI_IYEAR *) const
EAsiBoolean | get (ASI_IYEARTOMONTH *) const
EAsiBoolean | get (ASI_IMONTH *) const
EAsiBoolean | get (EAsiBoolean *, uint *, uint *) const
EAsiBoolean | getMonths (uint *) const
virtual EAsiBoolean | getValue (integer *) const
virtual EAsiBoolean | getValue (smallint *) const
virtual EAsiBoolean | getValue (char *, uint) const
virtual EAsiBoolean | getValue (CAsiUcStr *) const
virtual EAsiBoolean | getValue (real *) const
virtual EAsiBoolean | getValue (char *, uint, uint *) const
virtual EAsiBoolean | getValue (AsiUcStr, uint) const
virtual EAsiBoolean | getValue (CAsiData &) const
EAsiBoolean | getYears (uint *) const
virtual EAsiBoolean | is_castable (const CAsiData *) const
virtual EAsiBoolean | isEqualTo (const CAsiData &) const
virtual EAsiBoolean | isGreaterThan (const CAsiData &) const
virtual DBCOLUMNINFO * | MapAsiToColumnInfo (DBCOLUMNINFO *) const
virtual DBPARAMINFO * | MapAsiToParamInfo (DBPARAMINFO *) const
int | operator!= (const CAsiYM &) const
CAsiYM | operator* (const CAsiSmallInt &) const
CAsiYM | operator* (const CAsiInt &) const
CAsiYM | operator* (const CAsiNumeric &) const
CAsiYM | operator* (const CAsiDecimal &) const
CAsiYM | operator* (integer) const
CAsiYM | operator+ (const CAsiYM &) const
CAsiYM | operator- (const CAsiYM &) const
CAsiYM & | operator- (void)
CAsiYM | operator/ (const CAsiSmallInt &) const
CAsiYM | operator/ (const CAsiInt &) const
CAsiYM | operator/ (const CAsiNumeric &) const
CAsiYM | operator/ (const CAsiDecimal &) const
CAsiYM | operator/ (integer) const
int | operator< (const CAsiYM &) const
int | operator<= (const CAsiYM &) const
CAsiYM & | operator= (const CAsiYM &)
CAsiYM & | operator= (const CAsiSmallInt &)
CAsiYM & | operator= (const CAsiInt &)
CAsiYM & | operator= (const CAsiNumeric &)
CAsiYM & | operator= (const CAsiDecimal &)
CAsiYM & | operator= (integer)
int | operator== (const CAsiYM &) const
int | operator> (const CAsiYM &) const
int | operator>= (const CAsiYM &) const
virtual unsigned long | packSize (void) const
virtual unsigned long | packTo (CAsiObjPack *) const
virtual unsigned long | packValueSize (void) const
virtual unsigned long | packValueTo (CAsiObjPack *) const
EAsiBoolean | set (ASI_IYEAR *)
EAsiBoolean | set (ASI_IYEARTOMONTH *)
EAsiBoolean | set (ASI_IMONTH *)
EAsiBoolean | set (EAsiBoolean, uint, uint)
virtual EAsiBoolean | setIType (EAsiIType)
EAsiBoolean | setMonths (uint)
EAsiBoolean | setYears (uint)
virtual EAsiBoolean | SQLLiteral (CAsiUcStr *) const
virtual EAsiBoolean | storeValue (integer)
virtual EAsiBoolean | storeValue (smallint)
virtual EAsiBoolean | storeValue (char *, uint)
virtual EAsiBoolean | storeValue (const CAsiUcStr &)
virtual EAsiBoolean | storeValue (const CAsiData &)
virtual EAsiBoolean | storeValue (real)
virtual EAsiBoolean | storeValue (char *, uint, uint *)
virtual EAsiBoolean | storeValue (const AsiUcStr)
virtual EAsiBoolean | unpackFrom (CAsiObjPack *)
virtual EAsiBoolean | unpackValueFrom (CAsiObjPack *)
- Public Member Functions inherited from CAsiInterval
virtual CAsiData * | checkAdd (const CAsiData *) const
virtual CAsiData * | checkDiv (const CAsiData *) const
virtual CAsiData * | checkMul (const CAsiData *) const
virtual CAsiData * | checkSet (const CAsiData *) const
virtual CAsiData * | checkSub (const CAsiData *) const
void | setSign (EAsiBoolean)
EAsiBoolean | Sign (void) const
virtual EAsiBoolean | SQLType (CAsiUcStr *) const
- Public Member Functions inherited from CAsiIQualifier
CAsiIQualifier (EAsiIType)
CAsiIQualifier (EAsiIType, uint)
CAsiIQualifier (EAsiIType, uint, uint)
CAsiIQualifier (const CAsiIQualifier &)
virtual uint | FracSecPrec (void) const
virtual EAsiIType | IntervalType (void) const
virtual EAsiBoolean | is_comparable (const CAsiData *) const
virtual EAsiBoolean | is_dtinterval (void) const
virtual EAsiBoolean | is_interval (void) const
EAsiBoolean | is_moreaccurate (const CAsiIQualifier *) const
virtual EAsiBoolean | is_storable (const CAsiData *) const
virtual EAsiBoolean | is_yminterval (void) const
virtual uint | LeadFieldPrec (void) const
CAsiIQualifier & | operator= (const CAsiIQualifier &)
virtual uint | ReturnLength (void) const
void | setFracSecPrec (uint)
void | setLeadFieldPrec (uint)
virtual EAsiDataType | Type (void) const
- Public Member Functions inherited from CAsiData
CAsiData (void)
virtual CAsiData * | checkCat (const CAsiData *) const
virtual void | Clear (void)
virtual EAsiDTType | DateTimeType (void) const
virtual CAsiImplDefFunc * | getFuncDsc (const CAsiIdent &, const CAsiRow &) const
virtual EAsiBoolean | getValue (DECIMAL *) const
virtual EAsiBoolean | getValue (DB_NUMERIC *) const
virtual EAsiBoolean | getValue (DBDATE *) const
virtual EAsiBoolean | getValue (DBTIME *) const
virtual EAsiBoolean | getValue (DBTIMESTAMP *) const
virtual int | ImplDataType (void) const
virtual EAsiBoolean | is_approxnumeric (void) const
virtual EAsiBoolean | is_binary (void) const
virtual EAsiBoolean | is_character (void) const
virtual EAsiBoolean | is_datetime (void) const
virtual EAsiBoolean | is_exactnumeric (void) const
virtual EAsiBoolean | is_implement (void) const
virtual EAsiBoolean | is_numeric (void) const
virtual EAsiBoolean | isNull (void) const
virtual uint | Length (void) const
virtual uint | Precision (void) const
virtual uint | Scale (void) const
virtual void | setNull (void)
virtual EAsiBoolean | storeValue (const DECIMAL &)
virtual EAsiBoolean | storeValue (const DB_NUMERIC *)
virtual EAsiBoolean | storeValue (const DBDATE *)
virtual EAsiBoolean | storeValue (const DBTIME *)
virtual EAsiBoolean | storeValue (const DBTIMESTAMP *)
virtual uint | TimePrec (void) const
virtual uint | TimeStampPrec (void) const
virtual | ~CAsiData (void)
- Public Member Functions inherited from CAsiObject
CAsiObject (void)
void | operator delete (void *)
void * | operator new (size_t)
virtual | ~CAsiObject (void)

Protected Attributes

ulong | ivalue
- Protected Attributes inherited from CAsiInterval
EAsiBoolean | sign
- Protected Attributes inherited from CAsiIQualifier
uint | fsp
EAsiIType | itype
uint | lfp
- Protected Attributes inherited from CAsiData
EAsiBoolean | isnull

Friends

class | CAsiDate
class | CAsiTempTable
class | CAsiTime
class | CAsiTimeStamp
CAsiYM DLLScope | operator* (const CAsiSmallInt &, const CAsiYM &)
CAsiYM DLLScope | operator* (const CAsiInt &, const CAsiYM &)
CAsiYM DLLScope | operator* (const CAsiNumeric &, const CAsiYM &)
CAsiYM DLLScope | operator* (const CAsiDecimal &, const CAsiYM &)
CAsiYM DLLScope | operator* (integer, const CAsiYM &)
CAsiDate DLLScope | operator+ (const CAsiYM &, const CAsiDate &)

Additional Inherited Members

- Static Public Member Functions inherited from CAsiData
static CAsiData * | MapColumnInfoToAsi (DBCOLUMNINFO *pColumnInfo)
static CAsiData * | MapParamInfoToAsi (DBPARAMINFO *pParamInfo)
The documentation for this class was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAsiYM Member List

This is the complete list of members for CAsiYM, including all inherited members.

CAsiData(void) | CAsiData |
CAsiDate (defined in CAsiYM) | CAsiYM | friend
CAsiInterval(void) (defined in CAsiInterval) | CAsiInterval |
CAsiIQualifier(void) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType, uint) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(EAsiIType, uint, uint) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiIQualifier(const CAsiIQualifier &) (defined in CAsiIQualifier) | CAsiIQualifier |
CAsiObject(void) | CAsiObject |
CAsiTempTable (defined in CAsiYM) | CAsiYM | friend
CAsiTime (defined in CAsiYM) | CAsiYM | friend
CAsiTimeStamp (defined in CAsiYM) | CAsiYM | friend
CAsiYM(void) (defined in CAsiYM) | CAsiYM |
CAsiYM(EAsiIType) (defined in CAsiYM) | CAsiYM |
CAsiYM(EAsiIType, uint) (defined in CAsiYM) | CAsiYM |
CAsiYM(const CAsiYM &) (defined in CAsiYM) | CAsiYM |
checkAdd(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkCat(const CAsiData *) const | CAsiData | virtual
checkDiv(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkMul(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkSet(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
checkSub(const CAsiData *) const (defined in CAsiInterval) | CAsiInterval | virtual
Clear(void) | CAsiData | virtual
DateTimeType(void) const | CAsiData | virtual
duplicate(void) const (defined in CAsiYM) | CAsiYM | virtual
FracSecPrec(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
fsp (defined in CAsiIQualifier) | CAsiIQualifier | protected
get(ASI_IYEAR *) const (defined in CAsiYM) | CAsiYM |
get(ASI_IYEARTOMONTH *) const (defined in CAsiYM) | CAsiYM |
get(ASI_IMONTH *) const (defined in CAsiYM) | CAsiYM |
get(EAsiBoolean *, uint *, uint *) const (defined in CAsiYM) | CAsiYM |
getFuncDsc(const CAsiIdent &, const CAsiRow &) const | CAsiData | virtual
getMonths(uint *) const (defined in CAsiYM) | CAsiYM |
getValue(integer *) const (defined in CAsiYM) | CAsiYM | virtual
getValue(smallint *) const (defined in CAsiYM) | CAsiYM | virtual
getValue(char *, uint) const (defined in CAsiYM) | CAsiYM | virtual
getValue(CAsiUcStr *) const (defined in CAsiYM) | CAsiYM | virtual
getValue(real *) const (defined in CAsiYM) | CAsiYM | virtual
getValue(char *, uint, uint *) const (defined in CAsiYM) | CAsiYM | virtual
getValue(AsiUcStr, uint) const (defined in CAsiYM) | CAsiYM | virtual
getValue(CAsiData &) const (defined in CAsiYM) | CAsiYM | virtual
CAsiInterval::getValue(DECIMAL *) const | CAsiData | virtual
CAsiInterval::getValue(DB_NUMERIC *) const | CAsiData | virtual
CAsiInterval::getValue(DBDATE *) const | CAsiData | virtual
CAsiInterval::getValue(DBTIME *) const | CAsiData | virtual
CAsiInterval::getValue(DBTIMESTAMP *) const | CAsiData | virtual
getYears(uint *) const (defined in CAsiYM) | CAsiYM |
ImplDataType(void) const | CAsiData | virtual
IntervalType(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_approxnumeric(void) const | CAsiData | virtual
is_binary(void) const | CAsiData | virtual
is_castable(const CAsiData *) const (defined in CAsiYM) | CAsiYM | virtual
is_character(void) const | CAsiData | virtual
is_comparable(const CAsiData *) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_datetime(void) const | CAsiData | virtual
is_dtinterval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_exactnumeric(void) const | CAsiData | virtual
is_implement(void) const | CAsiData | virtual
is_interval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_moreaccurate(const CAsiIQualifier *) const (defined in CAsiIQualifier) | CAsiIQualifier |
is_numeric(void) const | CAsiData | virtual
is_storable(const CAsiData *) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
is_yminterval(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
isEqualTo(const CAsiData &) const (defined in CAsiYM) | CAsiYM | virtual
isGreaterThan(const CAsiData &) const (defined in CAsiYM) | CAsiYM | virtual
isnull (defined in CAsiData) | CAsiData | protected
isNull(void) const | CAsiData | virtual
itype (defined in CAsiIQualifier) | CAsiIQualifier | protected
ivalue (defined in CAsiYM) | CAsiYM | protected
LeadFieldPrec(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
Length(void) const | CAsiData | virtual
lfp (defined in CAsiIQualifier) | CAsiIQualifier | protected
MapAsiToColumnInfo(DBCOLUMNINFO *) const (defined in CAsiYM) | CAsiYM | virtual
MapAsiToParamInfo(DBPARAMINFO *) const (defined in CAsiYM) | CAsiYM | virtual
MapColumnInfoToAsi(DBCOLUMNINFO *pColumnInfo) | CAsiData | static
MapParamInfoToAsi(DBPARAMINFO *pParamInfo) | CAsiData | static
operator delete(void *) | CAsiObject |
operator new(size_t) | CAsiObject |
operator!=(const CAsiYM &) const (defined in CAsiYM) | CAsiYM |
operator*(const CAsiSmallInt &) const (defined in CAsiYM) | CAsiYM |
operator*(const CAsiInt &) const (defined in CAsiYM) | CAsiYM |
operator*(const CAsiNumeric &) const (defined in CAsiYM) | CAsiYM |
operator*(const CAsiDecimal &) const (defined in CAsiYM) | CAsiYM |
operator*(integer) const (defined in CAsiYM) | CAsiYM |
operator* (defined in CAsiYM) | CAsiYM | friend
operator* (defined in CAsiYM) | CAsiYM | friend
operator* (defined in CAsiYM) | CAsiYM | friend
operator* (defined in CAsiYM) | CAsiYM | friend
operator* (defined in CAsiYM) | CAsiYM | friend
operator+(const CAsiYM &) const (defined in CAsiYM) | CAsiYM |
operator+ (defined in CAsiYM) | CAsiYM | friend
operator-(const CAsiYM &) const (defined in CAsiYM) | CAsiYM |
operator-(void) (defined in CAsiYM) | CAsiYM |
operator/(const CAsiSmallInt &) const (defined in CAsiYM) | CAsiYM |
operator/(const CAsiInt &) const (defined in CAsiYM) | CAsiYM |
operator/(const CAsiNumeric &) const (defined in CAsiYM) | CAsiYM |
operator/(const CAsiDecimal &) const (defined in CAsiYM) | CAsiYM |
operator/(integer) const (defined in CAsiYM) | CAsiYM |
operator<(const CAsiYM &) const (defined in CAsiYM) | CAsiYM |
operator<=(const CAsiYM &) const (defined in CAsiYM) | CAsiYM |
operator=(const CAsiYM &) (defined in CAsiYM) | CAsiYM |
operator=(const CAsiSmallInt &) (defined in CAsiYM) | CAsiYM |
operator=(const CAsiInt &) (defined in CAsiYM) | CAsiYM |
operator=(const CAsiNumeric &) (defined in CAsiYM) | CAsiYM |
operator=(const CAsiDecimal &) (defined in CAsiYM) | CAsiYM |
operator=(integer) (defined in CAsiYM) | CAsiYM |
operator=(const CAsiIQualifier &) (defined in CAsiIQualifier) | CAsiIQualifier |
operator==(const CAsiYM &) const (defined in CAsiYM) | CAsiYM |
operator>(const CAsiYM &) const (defined in CAsiYM) | CAsiYM |
operator>=(const CAsiYM &) const (defined in CAsiYM) | CAsiYM |
packSize(void) const (defined in CAsiYM) | CAsiYM | virtual
packTo(CAsiObjPack *) const (defined in CAsiYM) | CAsiYM | virtual
packValueSize(void) const (defined in CAsiYM) | CAsiYM | virtual
packValueTo(CAsiObjPack *) const (defined in CAsiYM) | CAsiYM | virtual
Precision(void) const | CAsiData | virtual
ReturnLength(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
Scale(void) const | CAsiData | virtual
set(ASI_IYEAR *) (defined in CAsiYM) | CAsiYM |
set(ASI_IYEARTOMONTH *) (defined in CAsiYM) | CAsiYM |
set(ASI_IMONTH *) (defined in CAsiYM) | CAsiYM |
set(EAsiBoolean, uint, uint) (defined in CAsiYM) | CAsiYM |
setFracSecPrec(uint) (defined in CAsiIQualifier) | CAsiIQualifier |
setIType(EAsiIType) (defined in CAsiYM) | CAsiYM | virtual
setLeadFieldPrec(uint) (defined in CAsiIQualifier) | CAsiIQualifier |
setMonths(uint) (defined in CAsiYM) | CAsiYM |
setNull(void) | CAsiData | virtual
setSign(EAsiBoolean) (defined in CAsiInterval) | CAsiInterval |
setYears(uint) (defined in CAsiYM) | CAsiYM |
Sign(void) const (defined in CAsiInterval) | CAsiInterval |
sign (defined in CAsiInterval) | CAsiInterval | protected
SQLLiteral(CAsiUcStr *) const (defined in CAsiYM) | CAsiYM | virtual
SQLType(CAsiUcStr *) const (defined in CAsiInterval) | CAsiInterval | virtual
storeValue(integer) (defined in CAsiYM) | CAsiYM | virtual
storeValue(smallint) (defined in CAsiYM) | CAsiYM | virtual
storeValue(char *, uint) (defined in CAsiYM) | CAsiYM | virtual
storeValue(const CAsiUcStr &) (defined in CAsiYM) | CAsiYM | virtual
storeValue(const CAsiData &) (defined in CAsiYM) | CAsiYM | virtual
storeValue(real) (defined in CAsiYM) | CAsiYM | virtual
storeValue(char *, uint, uint *) (defined in CAsiYM) | CAsiYM | virtual
storeValue(const AsiUcStr) (defined in CAsiYM) | CAsiYM | virtual
CAsiInterval::storeValue(const DECIMAL &) | CAsiData | virtual
CAsiInterval::storeValue(const DB_NUMERIC *) | CAsiData | virtual
CAsiInterval::storeValue(const DBDATE *) | CAsiData | virtual
CAsiInterval::storeValue(const DBTIME *) | CAsiData | virtual
CAsiInterval::storeValue(const DBTIMESTAMP *) | CAsiData | virtual
TimePrec(void) const | CAsiData | virtual
TimeStampPrec(void) const | CAsiData | virtual
Type(void) const (defined in CAsiIQualifier) | CAsiIQualifier | virtual
unpackFrom(CAsiObjPack *) (defined in CAsiYM) | CAsiYM | virtual
unpackValueFrom(CAsiObjPack *) (defined in CAsiYM) | CAsiYM | virtual
~CAsiData(void) | CAsiData | virtual
~CAsiInterval(void) (defined in CAsiInterval) | CAsiInterval | virtual
~CAsiIQualifier(void) (defined in CAsiIQualifier) | CAsiIQualifier | virtual
~CAsiObject(void) | CAsiObject | virtual
~CAsiYM(void) (defined in CAsiYM) | CAsiYM | virtual


ZRX API Reference: CProxy_AcadObjectEvents< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CProxy_AcadObjectEvents< T > Class Template Reference
Misc Classes
+ Inheritance diagram for CProxy_AcadObjectEvents< T >:

Public Member Functions

void Fire_Modified ()
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CProxy_AcadObjectEvents< T > Member List

This is the complete list of members for CProxy_AcadObjectEvents< T >, including all inherited members.

Fire_Modified() (defined in CProxy_AcadObjectEvents< T >) CProxy_AcadObjectEvents< T > inline


ZRX API Reference: CProxy_PropertyNotifySink< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CProxy_PropertyNotifySink< T > Class Template Reference
Misc Classes
+ Inheritance diagram for CProxy_PropertyNotifySink< T >:

Public Member Functions

void | Fire_OnChanged ()
void | Fire_OnChanged (DISPID dispId)
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CProxy_PropertyNotifySink< T > Member List

This is the complete list of members for CProxy_PropertyNotifySink< T >, including all inherited members.

Fire_OnChanged() (defined in CProxy_PropertyNotifySink< T >) | CProxy_PropertyNotifySink< T > | inline
Fire_OnChanged(DISPID dispId) (defined in CProxy_PropertyNotifySink< T >) | CProxy_PropertyNotifySink< T > | inline


ZRX API Reference: CRectangle3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
CRectangle3d Class Reference
Misc Classes

Public Attributes

AcGePoint3d | lowLeft
AcGePoint3d | lowRight
AcGePoint3d | upLeft
AcGePoint3d | upRight
The documentation for this class was generated from the following file:
  • dbole.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CRectangle3d Member List

This is the complete list of members for CRectangle3d, including all inherited members.

lowLeft (defined in CRectangle3d) | CRectangle3d
lowRight (defined in CRectangle3d) | CRectangle3d
upLeft (defined in CRectangle3d) | CRectangle3d
upRight (defined in CRectangle3d) | CRectangle3d


ZRX API Reference: IAcadBaseDatabaseImpl< pclsid > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
IAcadBaseDatabaseImpl< pclsid > Class Template Reference
Misc Classes

Public Member Functions

STDMETHOD() | GetClassID (CLSID &clsid)
STDMETHOD() | GetDatabase (AcDbDatabase **pDb)
STDMETHOD() | SetDatabase (AcDbDatabase *&pDb)

Protected Attributes

AcDbDatabase * m_Database
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcadBaseDatabaseImpl< pclsid > Member List

This is the complete list of members for IAcadBaseDatabaseImpl< pclsid >, including all inherited members.

GetClassID(CLSID &clsid) (defined in IAcadBaseDatabaseImpl< pclsid >) | IAcadBaseDatabaseImpl< pclsid > | inline
GetDatabase(AcDbDatabase **pDb) (defined in IAcadBaseDatabaseImpl< pclsid >) | IAcadBaseDatabaseImpl< pclsid > | inline
IAcadBaseDatabaseImpl() (defined in IAcadBaseDatabaseImpl< pclsid >) | IAcadBaseDatabaseImpl< pclsid > | inline
m_Database (defined in IAcadBaseDatabaseImpl< pclsid >) | IAcadBaseDatabaseImpl< pclsid > | protected
SetDatabase(AcDbDatabase *&pDb) (defined in IAcadBaseDatabaseImpl< pclsid >) | IAcadBaseDatabaseImpl< pclsid > | inline


ZRX API Reference: IAcadBaseObject2Impl< T, pclsid > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
IAcadBaseObject2Impl< T, pclsid > Class Template Reference
Misc Classes
+ Inheritance diagram for IAcadBaseObject2Impl< T, pclsid >:

Public Member Functions

STDMETHOD() | AddToDb (AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
STDMETHOD() | CreateObject (AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
STDMETHOD() | ForceDbResident (VARIANT_BOOL *forceDbResident)
STDMETHOD() | GetObject (AcDbObject *&pObj)
STDMETHOD() | ObjectExists (VARIANT_BOOL *objectExists)
STDMETHOD() | OnModified (DISPID dispId=DISPID_UNKNOWN)
STDMETHOD() | SetObject (AcDbObject *&pObj)
- Public Member Functions inherited from IAcadBaseObjectImpl< T, pclsid >
STDMETHOD() | Clone (AcDbObjectId, LPUNKNOWN *)
virtual HRESULT | CreateNewObject (AcDbObjectId &objId, AcDbObjectId &ownerId, ACHAR *keyName)=0
STDMETHOD() | GetClassID (CLSID &clsid)
STDMETHOD() | GetObjectId (AcDbObjectId *objId)
STDMETHOD() | NullObjectId (void)
STDMETHOD() | OnModified (void)
STDMETHOD() | SetObjectId (AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
- Public Member Functions inherited from CProxy_AcadObjectEvents< T >
void | Fire_Modified ()
- Public Member Functions inherited from CProxy_PropertyNotifySink< T >
void | Fire_OnChanged ()
void | Fire_OnChanged (DISPID dispId)

Protected Member Functions

void | Fire_Notification (DISPID dispId=DISPID_UNKNOWN)
virtual void | ObjectIdModified ()
STDMETHOD() | releaseReference ()

Protected Attributes

AcAxObjectRef | m_objRef
- Protected Attributes inherited from IAcadBaseObjectImpl< T, pclsid >
AcDbObjectId | m_objId
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcadBaseObject2Impl< T, pclsid > Member List

This is the complete list of members for IAcadBaseObject2Impl< T, pclsid >, including all inherited members.

AddToDb(AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inline
Clone(AcDbObjectId, LPUNKNOWN *) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
CreateNewObject(AcDbObjectId &objId, AcDbObjectId &ownerId, ACHAR *keyName)=0 (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | pure virtual
CreateObject(AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inline
Fire_Modified() (defined in CProxy_AcadObjectEvents< T >) | CProxy_AcadObjectEvents< T > | inline
Fire_Notification(DISPID dispId=DISPID_UNKNOWN) (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inlineprotected
Fire_OnChanged() (defined in CProxy_PropertyNotifySink< T >) | CProxy_PropertyNotifySink< T > | inline
Fire_OnChanged(DISPID dispId) (defined in CProxy_PropertyNotifySink< T >) | CProxy_PropertyNotifySink< T > | inline
ForceDbResident(VARIANT_BOOL *forceDbResident) (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inline
GetClassID(CLSID &clsid) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
GetObject(AcDbObject *&pObj) (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inline
GetObjectId(AcDbObjectId *objId) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
IAcadBaseObject2Impl() (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inline
IAcadBaseObjectImpl() (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
m_objId (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | protected
m_objRef (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | protected
NullObjectId(void) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
ObjectExists(VARIANT_BOOL *objectExists) (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inline
ObjectIdModified() (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inlineprotectedvirtual
OnModified(DISPID dispId=DISPID_UNKNOWN) (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inline
OnModified(void) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
releaseReference() (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inlineprotected
SetObject(AcDbObject *&pObj) (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inline
SetObjectId(AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
~IAcadBaseObject2Impl() (defined in IAcadBaseObject2Impl< T, pclsid >) | IAcadBaseObject2Impl< T, pclsid > | inlinevirtual
~IAcadBaseObjectImpl() (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inlinevirtual


ZRX API Reference: IAcadBaseObjectImpl< T, pclsid > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
IAcadBaseObjectImpl< T, pclsid > Class Template Reference
Misc Classes
+ Inheritance diagram for IAcadBaseObjectImpl< T, pclsid >:

Public Member Functions

STDMETHOD() | Clone (AcDbObjectId, LPUNKNOWN *)
virtual HRESULT | CreateNewObject (AcDbObjectId &objId, AcDbObjectId &ownerId, ACHAR *keyName)=0
STDMETHOD() | GetClassID (CLSID &clsid)
STDMETHOD() | GetObjectId (AcDbObjectId *objId)
STDMETHOD() | NullObjectId (void)
STDMETHOD() | OnModified (void)
STDMETHOD() | SetObjectId (AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
- Public Member Functions inherited from CProxy_AcadObjectEvents< T >
void | Fire_Modified ()
- Public Member Functions inherited from CProxy_PropertyNotifySink< T >
void | Fire_OnChanged ()
void | Fire_OnChanged (DISPID dispId)

Protected Member Functions

virtual void ObjectIdModified ()

Protected Attributes

AcDbObjectId m_objId
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcadBaseObjectImpl< T, pclsid > Member List

This is the complete list of members for IAcadBaseObjectImpl< T, pclsid >, including all inherited members.

Clone(AcDbObjectId, LPUNKNOWN *) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
CreateNewObject(AcDbObjectId &objId, AcDbObjectId &ownerId, ACHAR *keyName)=0 (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | pure virtual
Fire_Modified() (defined in CProxy_AcadObjectEvents< T >) | CProxy_AcadObjectEvents< T > | inline
Fire_OnChanged() (defined in CProxy_PropertyNotifySink< T >) | CProxy_PropertyNotifySink< T > | inline
Fire_OnChanged(DISPID dispId) (defined in CProxy_PropertyNotifySink< T >) | CProxy_PropertyNotifySink< T > | inline
GetClassID(CLSID &clsid) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
GetObjectId(AcDbObjectId *objId) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
IAcadBaseObjectImpl() (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
m_objId (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | protected
NullObjectId(void) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
ObjectIdModified() (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inlineprotectedvirtual
OnModified(void) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
SetObjectId(AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inline
~IAcadBaseObjectImpl() (defined in IAcadBaseObjectImpl< T, pclsid >) | IAcadBaseObjectImpl< T, pclsid > | inlinevirtual


ZRX API Reference: IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > Class Template Reference
Misc Classes
+ Inheritance diagram for IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >:

Public Member Functions

STDMETHODIMP | get_Color (IAcadAcCmColor **pColor)
STDMETHODIMP | get_Hyperlinks (IAcadHyperlinks **pHyperlinks)
STDMETHODIMP | get_Layer (BSTR *pVal)
STDMETHODIMP | get_Linetype (BSTR *pVal)
STDMETHODIMP | get_LinetypeScale (double *pVal)
STDMETHODIMP | get_Lineweight (ACAD_LWEIGHT *lineweight)
STDMETHOD() | get_ObjectName (BSTR *pVal)
STDMETHODIMP | get_PlotStyleName (BSTR *plotStyleName)
STDMETHOD() | GetClassID (CLSID &clsid)
STDMETHOD() | GetFullSubEntPath (AcDbFullSubentPath *subentPath)
STDMETHOD() | OnModified ()
STDMETHOD() | SetFullSubEntPath (AcDbFullSubentPath &subentPath)
- Public Member Functions inherited from IRetrieveApplicationImpl
STDMETHOD() | GetApplicationObject (LPDISPATCH *pApp)
STDMETHOD() | SetApplicationObject (LPDISPATCH pApp)
- Public Member Functions inherited from CProxy_AcadObjectEvents< C >
void | Fire_Modified ()
- Public Member Functions inherited from CProxy_PropertyNotifySink< C >
void | Fire_OnChanged ()
void | Fire_OnChanged (DISPID dispId)

Protected Member Functions

STDMETHODIMP parentObjectId (AcDbObjectId &objID)

Protected Attributes

AcDbObjectId | m_objId
AcDbFullSubentPath | m_subentPath
- Protected Attributes inherited from IRetrieveApplicationImpl
LPDISPATCH | m_App
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > Member List

This is the complete list of members for IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >, including all inherited members.

Fire_Modified() (defined in CProxy_AcadObjectEvents< C >) | CProxy_AcadObjectEvents< C > | inline
Fire_OnChanged() (defined in CProxy_PropertyNotifySink< C >) | CProxy_PropertyNotifySink< C > | inline
Fire_OnChanged(DISPID dispId) (defined in CProxy_PropertyNotifySink< C >) | CProxy_PropertyNotifySink< C > | inline
get_Color(IAcadAcCmColor **pColor) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Hyperlinks(IAcadHyperlinks **pHyperlinks) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Layer(BSTR *pVal) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Linetype(BSTR *pVal) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_LinetypeScale(double *pVal) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Lineweight(ACAD_LWEIGHT *lineweight) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_ObjectName(BSTR *pVal) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_PlotStyleName(BSTR *plotStyleName) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
GetApplicationObject(LPDISPATCH *pApp) (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
GetClassID(CLSID &clsid) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
GetFullSubEntPath(AcDbFullSubentPath *subentPath) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
IAcadBaseSubEntityImpl() (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
IRetrieveApplicationImpl() (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
m_App (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | protected
m_objId (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | protected
m_subentPath (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | protected
OnModified() (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
parentObjectId(AcDbObjectId &objID) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inlineprotected
SetApplicationObject(LPDISPATCH pApp) (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
SetFullSubEntPath(AcDbFullSubentPath &subentPath) (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
~IAcadBaseSubEntityImpl() (defined in IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inlinevirtual
~IRetrieveApplicationImpl() (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inlinevirtual


ZRX API Reference: IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > Class Template Reference
Misc Classes
+ Inheritance diagram for IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >:

Public Member Functions

STDMETHODIMP | ArrayPolar (int numObjs, double fillAngle, VARIANT basePoint, VARIANT *pArrayObjs)
STDMETHODIMP | ArrayRectangular (int numRows, int numCols, int numLvls, double disRows, double disCols, double disLvls, VARIANT *pArrayObjs)
STDMETHODIMP | Copy (LPDISPATCH *pCopyObj)
STDMETHODIMP | get_Color (AcColor *pVal)
STDMETHOD() | get_EntityName (BSTR *pVal)
STDMETHOD() | get_EntityType (long *)
STDMETHODIMP | get_Hyperlinks (IAcadHyperlinks **pHyperlinks)
STDMETHODIMP | get_Layer (BSTR *pVal)
STDMETHODIMP | get_Linetype (BSTR *pVal)
STDMETHODIMP | get_LinetypeScale (double *pVal)
STDMETHODIMP | get_Lineweight (ACAD_LWEIGHT *lineweight)
STDMETHODIMP | get_Material (BSTR *pVal)
STDMETHODIMP | get_PlotStyleName (BSTR *plotStyleName)
STDMETHODIMP | get_TrueColor (IAcadAcCmColor **pColor)
STDMETHODIMP | get_Visible (VARIANT_BOOL *pVal)
STDMETHODIMP | GetBoundingBox (VARIANT *minPoint, VARIANT *maxPoint)
STDMETHODIMP | Highlight (VARIANT_BOOL bFlag)
STDMETHODIMP | IntersectWith (LPDISPATCH pEntity, AcExtendOption option, VARIANT *intPoints)
STDMETHODIMP | Mirror (VARIANT point1, VARIANT point2, LPDISPATCH *pMirrorObj)
STDMETHODIMP | Mirror3D (VARIANT point1, VARIANT point2, VARIANT point3, LPDISPATCH *pMirrorObj)
STDMETHODIMP | Move (VARIANT fromPoint, VARIANT toPoint)
STDMETHODIMP | put_Color (AcColor newVal)
STDMETHODIMP | put_Layer (BSTR newVal)
STDMETHODIMP | put_Linetype (BSTR newVal)
STDMETHODIMP | put_LinetypeScale (double newVal)
STDMETHODIMP | put_Lineweight (ACAD_LWEIGHT lineweight)
STDMETHODIMP | put_Material (BSTR newVal)
STDMETHODIMP | put_PlotStyleName (BSTR plotStyleName)
STDMETHODIMP | put_TrueColor (IAcadAcCmColor *color)
STDMETHODIMP | put_Visible (VARIANT_BOOL newVal)
STDMETHODIMP | Rotate (VARIANT basePoint, double rotationAngle)
STDMETHODIMP | Rotate3D (VARIANT point1, VARIANT point2, double rotationAngle)
STDMETHODIMP | ScaleEntity (VARIANT basePoint, double scaleFactor)
STDMETHODIMP | TransformBy (VARIANT transMatrix)
STDMETHODIMP | Update ()
- Public Member Functions inherited from IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >
STDMETHOD() | Delete ()
STDMETHOD() | Erase ()
STDMETHOD() | get_Application (LPDISPATCH *pVal)
STDMETHOD() | get_Database (IAcadDatabase **pDatabase)
STDMETHOD() | get_Document (LPDISPATCH *pDocument)
STDMETHOD() | get_Handle (BSTR *pVal)
STDMETHOD() | get_HasExtensionDictionary (VARIANT_BOOL *bHasDictionary)
STDMETHOD() | get_ObjectID (Adesk::IntDbId *pVal)
STDMETHOD() | get_ObjectName (BSTR *pVal)
STDMETHOD() | get_OwnerID (Adesk::IntDbId *pVal)
STDMETHOD() | GetExtensionDictionary (IAcadDictionary **pExtDictionary)
STDMETHOD() | GetXData (BSTR bstrName, VARIANT *type, VARIANT *data)
STDMETHOD() | SetXData (VARIANT type, VARIANT data)
- Public Member Functions inherited from IAcadBaseObject2Impl< C, pclsid >
STDMETHOD() | AddToDb (AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
STDMETHOD() | CreateObject (AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
STDMETHOD() | ForceDbResident (VARIANT_BOOL *forceDbResident)
STDMETHOD() | GetObject (AcDbObject *&pObj)
STDMETHOD() | ObjectExists (VARIANT_BOOL *objectExists)
STDMETHOD() | OnModified (DISPID dispId=DISPID_UNKNOWN)
STDMETHOD() | SetObject (AcDbObject *&pObj)
- Public Member Functions inherited from IAcadBaseObjectImpl< C, pclsid >
STDMETHOD() | Clone (AcDbObjectId, LPUNKNOWN *)
virtual HRESULT | CreateNewObject (AcDbObjectId &objId, AcDbObjectId &ownerId, ACHAR *keyName)=0
STDMETHOD() | GetClassID (CLSID &clsid)
STDMETHOD() | GetObjectId (AcDbObjectId *objId)
STDMETHOD() | NullObjectId (void)
STDMETHOD() | OnModified (void)
STDMETHOD() | SetObjectId (AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
- Public Member Functions inherited from CProxy_AcadObjectEvents< C >
void | Fire_Modified ()
- Public Member Functions inherited from CProxy_PropertyNotifySink< C >
void | Fire_OnChanged ()
void | Fire_OnChanged (DISPID dispId)
- Public Member Functions inherited from IRetrieveApplicationImpl
STDMETHOD() | GetApplicationObject (LPDISPATCH *pApp)
STDMETHOD() | SetApplicationObject (LPDISPATCH pApp)

Additional Inherited Members

- Protected Member Functions inherited from IAcadBaseObject2Impl< C, pclsid >
void | Fire_Notification (DISPID dispId=DISPID_UNKNOWN)
virtual void | ObjectIdModified ()
STDMETHOD() | releaseReference ()
- Protected Attributes inherited from IAcadBaseObject2Impl< C, pclsid >
AcAxObjectRef | m_objRef
- Protected Attributes inherited from IRetrieveApplicationImpl
LPDISPATCH | m_App
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > Member List

This is the complete list of members for IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >, including all inherited members.

AddToDb(AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
ArrayPolar(int numObjs, double fillAngle, VARIANT basePoint, VARIANT *pArrayObjs) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
ArrayRectangular(int numRows, int numCols, int numLvls, double disRows, double disCols, double disLvls, VARIANT *pArrayObjs) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Clone(AcDbObjectId, LPUNKNOWN *) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
Copy(LPDISPATCH *pCopyObj) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
CreateNewObject(AcDbObjectId &objId, AcDbObjectId &ownerId, ACHAR *keyName)=0 (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | pure virtual
CreateObject(AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
Delete() (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Erase() (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Fire_Modified() (defined in CProxy_AcadObjectEvents< C >) | CProxy_AcadObjectEvents< C > | inline
Fire_Notification(DISPID dispId=DISPID_UNKNOWN) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inlineprotected
Fire_OnChanged() (defined in CProxy_PropertyNotifySink< C >) | CProxy_PropertyNotifySink< C > | inline
Fire_OnChanged(DISPID dispId) (defined in CProxy_PropertyNotifySink< C >) | CProxy_PropertyNotifySink< C > | inline
ForceDbResident(VARIANT_BOOL *forceDbResident) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
get_Application(LPDISPATCH *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Color(AcColor *pVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Database(IAcadDatabase **pDatabase) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Document(LPDISPATCH *pDocument) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_EntityName(BSTR *pVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_EntityType(long *) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Handle(BSTR *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_HasExtensionDictionary(VARIANT_BOOL *bHasDictionary) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Hyperlinks(IAcadHyperlinks **pHyperlinks) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Layer(BSTR *pVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Linetype(BSTR *pVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_LinetypeScale(double *pVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Lineweight(ACAD_LWEIGHT *lineweight) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Material(BSTR *pVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_ObjectID(Adesk::IntDbId *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_ObjectName(BSTR *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_OwnerID(Adesk::IntDbId *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_PlotStyleName(BSTR *plotStyleName) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_TrueColor(IAcadAcCmColor **pColor) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Visible(VARIANT_BOOL *pVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
GetApplicationObject(LPDISPATCH *pApp) (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
GetBoundingBox(VARIANT *minPoint, VARIANT *maxPoint) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
GetClassID(CLSID &clsid) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
GetExtensionDictionary(IAcadDictionary **pExtDictionary) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
GetObject(AcDbObject *&pObj) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
GetObjectId(AcDbObjectId *objId) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
GetXData(BSTR bstrName, VARIANT *type, VARIANT *data) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Highlight(VARIANT_BOOL bFlag) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
IAcadBaseObject2Impl() (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
IAcadBaseObjectImpl() (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
IAcadObjectDispatchImpl() (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
IntersectWith(LPDISPATCH pEntity, AcExtendOption option, VARIANT *intPoints) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
IRetrieveApplicationImpl() (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
m_App (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | protected
m_objId (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | protected
m_objRef (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | protected
Mirror(VARIANT point1, VARIANT point2, LPDISPATCH *pMirrorObj) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Mirror3D(VARIANT point1, VARIANT point2, VARIANT point3, LPDISPATCH *pMirrorObj) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Move(VARIANT fromPoint, VARIANT toPoint) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
NullObjectId(void) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
ObjectExists(VARIANT_BOOL *objectExists) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
ObjectIdModified() (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inlineprotectedvirtual
OnModified(DISPID dispId=DISPID_UNKNOWN) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
OnModified(void) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
put_Color(AcColor newVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
put_Layer(BSTR newVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
put_Linetype(BSTR newVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
put_LinetypeScale(double newVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
put_Lineweight(ACAD_LWEIGHT lineweight) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
put_Material(BSTR newVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
put_PlotStyleName(BSTR plotStyleName) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
put_TrueColor(IAcadAcCmColor *color) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
put_Visible(VARIANT_BOOL newVal) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
releaseReference() (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inlineprotected
Rotate(VARIANT basePoint, double rotationAngle) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Rotate3D(VARIANT point1, VARIANT point2, double rotationAngle) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
ScaleEntity(VARIANT basePoint, double scaleFactor) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
SetApplicationObject(LPDISPATCH pApp) (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
SetObject(AcDbObject *&pObj) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
SetObjectId(AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
SetXData(VARIANT type, VARIANT data) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
TransformBy(VARIANT transMatrix) (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Update() (defined in IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
~IAcadBaseObject2Impl() (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inlinevirtual
~IAcadBaseObjectImpl() (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inlinevirtual
~IAcadObjectDispatchImpl() (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inlinevirtual
~IRetrieveApplicationImpl() (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inlinevirtual


ZRX API Reference: IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > Class Template Reference
Misc Classes
+ Inheritance diagram for IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >:

Public Member Functions

STDMETHOD() | Delete ()
STDMETHOD() | Erase ()
STDMETHOD() | get_Application (LPDISPATCH *pVal)
STDMETHOD() | get_Database (IAcadDatabase **pDatabase)
STDMETHOD() | get_Document (LPDISPATCH *pDocument)
STDMETHOD() | get_Handle (BSTR *pVal)
STDMETHOD() | get_HasExtensionDictionary (VARIANT_BOOL *bHasDictionary)
STDMETHOD() | get_ObjectID (Adesk::IntDbId *pVal)
STDMETHOD() | get_ObjectName (BSTR *pVal)
STDMETHOD() | get_OwnerID (Adesk::IntDbId *pVal)
STDMETHOD() | GetExtensionDictionary (IAcadDictionary **pExtDictionary)
STDMETHOD() | GetXData (BSTR bstrName, VARIANT *type, VARIANT *data)
STDMETHOD() | SetXData (VARIANT type, VARIANT data)
- Public Member Functions inherited from IAcadBaseObject2Impl< C, pclsid >
STDMETHOD() | AddToDb (AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
STDMETHOD() | CreateObject (AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
STDMETHOD() | ForceDbResident (VARIANT_BOOL *forceDbResident)
STDMETHOD() | GetObject (AcDbObject *&pObj)
STDMETHOD() | ObjectExists (VARIANT_BOOL *objectExists)
STDMETHOD() | OnModified (DISPID dispId=DISPID_UNKNOWN)
STDMETHOD() | SetObject (AcDbObject *&pObj)
- Public Member Functions inherited from IAcadBaseObjectImpl< C, pclsid >
STDMETHOD() | Clone (AcDbObjectId, LPUNKNOWN *)
virtual HRESULT | CreateNewObject (AcDbObjectId &objId, AcDbObjectId &ownerId, ACHAR *keyName)=0
STDMETHOD() | GetClassID (CLSID &clsid)
STDMETHOD() | GetObjectId (AcDbObjectId *objId)
STDMETHOD() | NullObjectId (void)
STDMETHOD() | OnModified (void)
STDMETHOD() | SetObjectId (AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL)
- Public Member Functions inherited from CProxy_AcadObjectEvents< C >
void | Fire_Modified ()
- Public Member Functions inherited from CProxy_PropertyNotifySink< C >
void | Fire_OnChanged ()
void | Fire_OnChanged (DISPID dispId)
- Public Member Functions inherited from IRetrieveApplicationImpl
STDMETHOD() | GetApplicationObject (LPDISPATCH *pApp)
STDMETHOD() | SetApplicationObject (LPDISPATCH pApp)

Additional Inherited Members

- Protected Member Functions inherited from IAcadBaseObject2Impl< C, pclsid >
void | Fire_Notification (DISPID dispId=DISPID_UNKNOWN)
virtual void | ObjectIdModified ()
STDMETHOD() | releaseReference ()
- Protected Attributes inherited from IAcadBaseObject2Impl< C, pclsid >
AcAxObjectRef | m_objRef
- Protected Attributes inherited from IRetrieveApplicationImpl
LPDISPATCH | m_App
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > Member List

This is the complete list of members for IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >, including all inherited members.

AddToDb(AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
Clone(AcDbObjectId, LPUNKNOWN *) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
CreateNewObject(AcDbObjectId &objId, AcDbObjectId &ownerId, ACHAR *keyName)=0 (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | pure virtual
CreateObject(AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
Delete() (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Erase() (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
Fire_Modified() (defined in CProxy_AcadObjectEvents< C >) | CProxy_AcadObjectEvents< C > | inline
Fire_Notification(DISPID dispId=DISPID_UNKNOWN) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inlineprotected
Fire_OnChanged() (defined in CProxy_PropertyNotifySink< C >) | CProxy_PropertyNotifySink< C > | inline
Fire_OnChanged(DISPID dispId) (defined in CProxy_PropertyNotifySink< C >) | CProxy_PropertyNotifySink< C > | inline
ForceDbResident(VARIANT_BOOL *forceDbResident) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
get_Application(LPDISPATCH *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Database(IAcadDatabase **pDatabase) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Document(LPDISPATCH *pDocument) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_Handle(BSTR *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_HasExtensionDictionary(VARIANT_BOOL *bHasDictionary) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_ObjectID(Adesk::IntDbId *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_ObjectName(BSTR *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
get_OwnerID(Adesk::IntDbId *pVal) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
GetApplicationObject(LPDISPATCH *pApp) (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
GetClassID(CLSID &clsid) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
GetExtensionDictionary(IAcadDictionary **pExtDictionary) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
GetObject(AcDbObject *&pObj) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
GetObjectId(AcDbObjectId *objId) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
GetXData(BSTR bstrName, VARIANT *type, VARIANT *data) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
IAcadBaseObject2Impl() (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
IAcadBaseObjectImpl() (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
IAcadObjectDispatchImpl() (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
IRetrieveApplicationImpl() (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
m_App (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | protected
m_objId (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | protected
m_objRef (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | protected
NullObjectId(void) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
ObjectExists(VARIANT_BOOL *objectExists) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
ObjectIdModified() (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inlineprotectedvirtual
OnModified(DISPID dispId=DISPID_UNKNOWN) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
OnModified(void) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
releaseReference() (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inlineprotected
SetApplicationObject(LPDISPATCH pApp) (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
SetObject(AcDbObject *&pObj) (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inline
SetObjectId(AcDbObjectId &objId, AcDbObjectId ownerId=AcDbObjectId::kNull, ACHAR *keyName=NULL) (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inline
SetXData(VARIANT type, VARIANT data) (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inline
~IAcadBaseObject2Impl() (defined in IAcadBaseObject2Impl< C, pclsid >) | IAcadBaseObject2Impl< C, pclsid > | inlinevirtual
~IAcadBaseObjectImpl() (defined in IAcadBaseObjectImpl< C, pclsid >) | IAcadBaseObjectImpl< C, pclsid > | inlinevirtual
~IAcadObjectDispatchImpl() (defined in IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass >) | IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > | inlinevirtual
~IRetrieveApplicationImpl() (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inlinevirtual


ZRX API Reference: IAcadShadowDisplayImpl< C > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
IAcadShadowDisplayImpl< C > Class Template Reference
Misc Classes

Public Member Functions

STDMETHODIMP | get_EnableShadowDisplay (BOOL *bEnabled)
STDMETHODIMP | get_ShadowDisplay (AcShadowDisplayType *pShadowDisplay)
STDMETHODIMP | put_ShadowDisplay (AcShadowDisplayType shadowDisplay)
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcadShadowDisplayImpl< C > Member List

This is the complete list of members for IAcadShadowDisplayImpl< C >, including all inherited members.

get_EnableShadowDisplay(BOOL *bEnabled) (defined in IAcadShadowDisplayImpl< C >) | IAcadShadowDisplayImpl< C > | inline
get_ShadowDisplay(AcShadowDisplayType *pShadowDisplay) (defined in IAcadShadowDisplayImpl< C >) | IAcadShadowDisplayImpl< C > | inline
put_ShadowDisplay(AcShadowDisplayType shadowDisplay) (defined in IAcadShadowDisplayImpl< C >) | IAcadShadowDisplayImpl< C > | inline


ZRX API Reference: ListItem Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
ListItem Struct Reference
Misc Classes

Public Attributes

CAsiObject * | item
struct ListItem * | next
The documentation for this struct was generated from the following file:
  • asisdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
ListItem Member List

This is the complete list of members for ListItem, including all inherited members.

item (defined in ListItem) | ListItem
next (defined in ListItem) | ListItem


ZRX API Reference: OwnerDraw3d Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
List of all members
OwnerDraw3d Class Reference
Misc Classes
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
OwnerDraw3d Member List

This is the complete list of members for OwnerDraw3d, including all inherited members.

~OwnerDraw3d(void) (defined in OwnerDraw3d) OwnerDraw3d inlinevirtual


ZRX API Reference: RxADSAppTableEntryType Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
RxADSAppTableEntryType Class Reference
Misc Classes

Public Attributes

struct resbuf * | ads_argl
int | ads_fcode
FunHandList * | ads_fhdl
int | ads_invkcnt
resbuf * | ads_ret
int | ads_rettype
LONG_PTR | apphandle
ACHAR * | appname
int | lflag
AcRxGenHand * | modhandle
The documentation for this class was generated from the following file:
  • adsrxdef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
RxADSAppTableEntryType Member List

This is the complete list of members for RxADSAppTableEntryType, including all inherited members.

ads_argl (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType
ads_fcode (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType
ads_fhdl (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType
ads_invkcnt (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType
ads_ret (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType
ads_rettype (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType
apphandle (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType
appname (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType
lflag (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType
modhandle (defined in RxADSAppTableEntryType) | RxADSAppTableEntryType


ZRX API Reference: OPM Classes

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Macros | Typedefs | Functions | Variables
OPM Classes

Classes

class | IAcPiCategorizePropertiesImpl< T >
class | IAcPiPropCommandButtonsImpl< T >
class | IAcPiPropertyDisplayImpl< T >
class | IOPMPropertyExtensionImpl< T >
class | IOPMPropertyExtensionImpl2< T >
class | IRetrieveApplicationImpl
class | OPMPerInstancePropertyExtension
class | OPMPerInstancePropertyExtensionFactory
class | OPMPerInstancePropertySources
class | OPMPropertyExtension
class | OPMPropertyExtensionFactory

Macros

#define | __ACPILib_LIBRARY_DEFINED__
#define | __IAcPeButtonEditCtrl_INTERFACE_DEFINED__
#define | __IAcPeButtonPicture_INTERFACE_DEFINED__
#define | __IAcPeCalculatorCtrl_INTERFACE_DEFINED__
#define | __IAcPeColorCtrl_INTERFACE_DEFINED__
#define | __IAcPeNoPickVariantRW_INTERFACE_DEFINED__
#define | __IAcPeNumericEditor_INTERFACE_DEFINED__
#define | __IAcPePick2PointsCtrl_INTERFACE_DEFINED__
#define | __IAcPeSpinCtrl_INTERFACE_DEFINED__
#define | __IAcPeVariantCtrl_INTERFACE_DEFINED__
#define | __IAcPiCategorizeProperties_INTERFACE_DEFINED__
#define | __IAcPiCommandButton2_INTERFACE_DEFINED__
#define | __IAcPiCommandButton_INTERFACE_DEFINED__
#define | __IAcPiPropCommandButtons_INTERFACE_DEFINED__
#define | __IAcPiPropertyDisplay_INTERFACE_DEFINED__
#define | __IAcPiPropertyEditControl_INTERFACE_DEFINED__
#define | __IAcPiPropertyEditEventsSink_INTERFACE_DEFINED__
#define | __IAcPiPropertyInspector_INTERFACE_DEFINED__
#define | __IAcPiPropertyInspectorEventsSink_INTERFACE_DEFINED__
#define | __IAcPiPropertyInspectorInputEventSink_INTERFACE_DEFINED__
#define | __IAcPiPropertyUnspecified_INTERFACE_DEFINED__
#define | CLSID_PropertyEditorACADNumeric CLSID_AcPePropertyEditorACADNumeric
#define | CLSID_PropertyEditorAttributeValue CLSID_AcPePropertyEditorAttributeValue
#define | CLSID_PropertyEditorBool CLSID_AcPePropertyEditorBool
#define | CLSID_PropertyEditorColor CLSID_AcPePropertyEditorColor
#define | CLSID_PropertyEditorDimArrowHead CLSID_AcPePropertyEditorDimArrowHead
#define | CLSID_PropertyEditorDimStyle CLSID_AcPePropertyEditorDimStyle
#define | CLSID_PropertyEditorEditButton CLSID_AcPePropertyEditorEditButton
#define | CLSID_PropertyEditorEllipseEndAngle CLSID_AcPePropertyEditorEllipseEndAngle
#define | CLSID_PropertyEditorEllipses CLSID_AcPePropertyEditorEllipses
#define | CLSID_PropertyEditorEllipsesHyperlinks CLSID_AcPePropertyEditorEllipsesHyperlinks
#define | CLSID_PropertyEditorEllipsisHatchPatternType CLSID_AcPePropertyEditorEllipsisHatchPatternType
#define | CLSID_PropertyEditorEnum CLSID_AcPePropertyEditorEnum
#define | CLSID_PropertyEditorGradientPattern CLSID_AcPePropertyEditorGradientPattern
#define | CLSID_PropertyEditorHatchEnum CLSID_AcPePropertyEditorHatchEnum
#define | CLSID_PropertyEditorHatchISOPenWidth CLSID_AcPePropertyEditorHatchISOPenWidth
#define | CLSID_PropertyEditorHatchPatternName CLSID_AcPePropertyEditorHatchPatternName
#define | CLSID_PropertyEditorLayer CLSID_AcPePropertyEditorLayer
#define | CLSID_PropertyEditorLightIntensity CLSID_AcPePropertyEditorLightIntensity
#define | CLSID_PropertyEditorLightLampColor CLSID_AcPePropertyEditorLightLampColor
#define | CLSID_PropertyEditorLightWebPreview CLSID_AcPePropertyEditorLightWebPreview
#define | CLSID_PropertyEditorLType CLSID_AcPePropertyEditorLType
#define | CLSID_PropertyEditorLWeight CLSID_AcPePropertyEditorLWeight
#define | CLSID_PropertyEditorMaterial CLSID_AcPePropertyEditorMaterial
#define | CLSID_PropertyEditorMLeaderStyle CLSID_AcPePropertyEditorMLeaderStyle
#define | CLSID_PropertyEditorMTextDir CLSID_AcPePropertyEditorMTextDir
#define | CLSID_PropertyEditorMTextStyle CLSID_AcPePropertyEditorMTextStyle
#define | CLSID_PropertyEditorNoPickVariant CLSID_AcPePropertyEditorNoPickVariant
#define | CLSID_PropertyEditorNumeric CLSID_AcPePropertyEditorNumeric
#define | CLSID_PropertyEditorNumericArea CLSID_AcPePropertyEditorNumericArea
#define | CLSID_PropertyEditorPlotStyleName CLSID_AcPePropertyEditorPlotStyleName
#define | CLSID_PropertyEditorPlotStyleTable CLSID_AcPePropertyEditorPlotStyleTable
#define | CLSID_PropertyEditorPredefBlock CLSID_AcPePropertyEditorPredefBlock
#define | CLSID_PropertyEditorPwdText CLSID_AcPePropertyEditorPwdText
#define | CLSID_PropertyEditorRasterImageHeight CLSID_AcPePropertyEditorRasterImageHeight
#define | CLSID_PropertyEditorRasterImageWidth CLSID_AcPePropertyEditorRasterImageWidth
#define | CLSID_PropertyEditorSpin CLSID_AcPePropertyEditorSpin
#define | CLSID_PropertyEditorTableStyle CLSID_AcPePropertyEditorTableStyle
#define | CLSID_PropertyEditorText CLSID_AcPePropertyEditorText
#define | CLSID_PropertyEditorTextJustify CLSID_AcPePropertyEditorTextJustify
#define | CLSID_PropertyEditorTextStyle CLSID_AcPePropertyEditorTextStyle
#define | CLSID_PropertyEditorVariant CLSID_AcPePropertyEditorVariant
#define | CLSID_PropertyEditorVisualStyle CLSID_AcPePropertyEditorVisualStyle
#define | CLSID_PropertyInspector CLSID_AcPiPropertyInspector
#define | GET_OPM_PERINSTANCE_CREATE_PROTOCOL() OPMPerInstancePropertyExtensionFactory::cast(AcDbDatabase::desc()->queryX(OPMPerInstancePropertyExtensionFactory::desc()))
#define | GET_OPM_PERINSTANCE_EXTENSION_PROTOCOL(pAcRxClass) GET_OPM_PERINSTANCE_CREATE_PROTOCOL()->CreateOPMPerInstancePropertyExtension(pAcRxClass)
#define | GET_OPM_PERINSTANCE_PROPERTY_SOURCES() OPMPerInstancePropertySources::cast(AcDbDatabase::desc()->queryX(OPMPerInstancePropertySources::desc()))
#define | ICategorizeProperties2 IAcPiCategorizeProperties
#define | ICategorizeProperties2Impl IAcPiCategorizePropertiesImpl
#define | ICommandButton IAcPiCommandButton
#define | IID_ICategorizeProperties2 IID_IAcPiCategorizeProperties
#define | IID_ICommandButton IID_IAcPiCommandButton
#define | IID_IPerPropertyDisplay IID_IAcPiPropertyDisplay
#define | IID_IPropCommandButtons IID_IAcPiPropCommandButtons
#define | IID_IPropEditUIEventsSink IID_IAcPiPropertyEditEventsSink
#define | IID_IPropertyEditControl IID_IAcPiPropertyEditControl
#define | IID_IPropertyInspector IID_IAcPiPropertyInspector
#define | IID_IPropertyInspectorInputEventSink IID_IAcPiPropertyInspectorInputEventSink
#define | IID_IPropertyInspectorSink IID_IAcPiPropertyInspectorEventsSink
#define | IID_IPropertyUnspecified IID_IAcPiPropertyUnspecified
#define | INTERFACE ICategorizeProperties
#define | IPerPropertyDisplay IAcPiPropertyDisplay
#define | IPerPropertyDisplayImpl IAcPiPropertyDisplayImpl
#define | IPropCommandButtons IAcPiPropCommandButtons
#define | IPropCommandButtonsImpl IAcPiPropCommandButtonsImpl
#define | IPropEditUIEventsSink IAcPiPropertyEditEventsSink
#define | IPropertyEditControl IAcPiPropertyEditControl
#define | IPropertyInspector IAcPiPropertyInspector
#define | IPropertyInspectorInputEventSink IAcPiPropertyInspectorInputEventSink
#define | IPropertyInspectorSink IAcPiPropertyInspectorEventsSink
#define | IPropertyUnspecified IAcPiPropertyUnspecified

Typedefs

typedef ICategorizeProperties FAR * | LPCATEGORIZEPROPERTIES
typedef IDynamicDialogProperty
FAR * 		LPDYNAMICDIALOGPROPERTY
typedef IDynamicEnumProperty FAR * | LPDYNAMICENUMPROPERTY
typedef IDynamicProperty FAR * | LPDYNAMICPROPERTY
typedef IDynamicProperty2 FAR * | LPDYNAMICPROPERTY2
typedef IDynamicPropertyNotify
FAR * 		LPDYNAMICPROPERTYNOTIFY
typedef
IDynamicPropertyNotify2 FAR * 		LPDYNAMICPROPERTYNOTIFY2
typedef IPropertyManager FAR * | LPPROPERTYMANAGER
typedef IPropertyManager2 FAR * | LPPROPERTYMANAGER2

Functions

interface | DECLSPEC_UUID ("6DC29A56-F5B9-4ED1-B7B9-DE76C24720FA") ICategorizeProperties
interface | DECLSPEC_UUID ("70C4624A-0C5E-4241-9AAC-CE261118C52C") IDynamicPropertyNotify
interface | DECLSPEC_UUID ("2CA92AC3-6AF3-4A48-A1E3-8B95A7F153CC") IDynamicPropertyNotify2
interface | DECLSPEC_UUID ("B8DBE00A-A0A9-4882-9FE0-9F4EDC3D935F") IDynamicProperty
interface | DECLSPEC_UUID ("5AC6977F-5FCF-4295-93F7-93422352AB9D") IDynamicProperty2
interface | DECLSPEC_UUID ("B1887CE8-1127-42C6-9FD1-A5500724D751") IDynamicEnumProperty
interface | DECLSPEC_UUID ("38E4A655-1518-4135-9328-57D258470A43") IDynamicDialogProperty
interface | DECLSPEC_UUID ("F6BB2E86-A442-40F5-9747-751DBD6D8145") IPropertyManager2
interface | DECLSPEC_UUID ("284905CA-17B8-42C6-8CEE-D8EAD4DB59AC") IPropertySource
typedef | DECLSPEC_UUID ("7EC97F7A-1407-4DE2-9A00-D774F0A4B947") enum AcPeNumericType
DEFINE_GUID (IID_IDynamicPropertyNotify, 0x70c4624a, 0x0c5e, 0x4241, 0x9a, 0xac, 0xce, 0x26, 0x11, 0x18, 0xc5, 0x2c)
DEFINE_GUID (IID_IDynamicPropertyNotify2, 0x2ca92ac3, 0x6af3, 0x4a48, 0xa1, 0xe3, 0x8b, 0x95, 0xa7, 0xf1, 0x53, 0xcc)
DEFINE_GUID (IID_IDynamicProperty, 0xb8dbe00a, 0xa0a9, 0x4882, 0x9f, 0xe0, 0x9f, 0x4e, 0xdc, 0x3d, 0x93, 0x5f)
DEFINE_GUID (IID_IDynamicProperty2, 0x5ac6977f, 0x5fcf, 0x4295, 0x93, 0xf7, 0x93, 0x42, 0x23, 0x52, 0xab, 0x9d)
DEFINE_GUID (IID_IDynamicEnumProperty, 0xb1887ce8, 0x1127, 0x42c6, 0x9f, 0xd1, 0xa5, 0x50, 0x07, 0x24, 0xd7, 0x51)
DEFINE_GUID (IID_IDynamicDialogProperty, 0x38e4a655, 0x1518, 0x4135, 0x93, 0x28, 0x57, 0xd2, 0x58, 0x47, 0x0a, 0x43)
DEFINE_GUID (IID_IPropertyManager, 0xb8dbe00a, 0xa0a9, 0x4882, 0x9f, 0xe0, 0x9f, 0x4e, 0xdc, 0x3d, 0x93, 0x5f)
DEFINE_GUID (IID_IPropertyManager2, 0xf6bb2e86, 0xa442, 0x40f5, 0x97, 0x47, 0x75, 0x1d, 0xbd, 0x6d, 0x81, 0x45)
DEFINE_GUID (IID_IPropertySource, 0x284905ca, 0x17b8, 0x42c6, 0x8c, 0xee, 0xd8, 0xea, 0xd4, 0xdb, 0x59, 0xac)
virtual HRESULT STDMETHODCALLTYPE | Execute (VARIANT Objects)=0
virtual HRESULT STDMETHODCALLTYPE | get_BackColor (OLE_COLOR *pclr)=0
virtual HRESULT STDMETHODCALLTYPE | get_BoldFont (IUnknown **pIFont)=0
virtual HRESULT STDMETHODCALLTYPE | get_ButtonStyle (long *style)=0
virtual HRESULT STDMETHODCALLTYPE | get_Checked (VARIANT_BOOL *bChecked)=0
virtual HRESULT STDMETHODCALLTYPE | get_DefaultPicture (IUnknown **pIPicture)=0
virtual HRESULT STDMETHODCALLTYPE | get_DelayRefresh (VARIANT_BOOL *pbDelayRefresh)=0
virtual HRESULT STDMETHODCALLTYPE | get_DisabledPicture (IUnknown **pIPicture)=0
virtual HRESULT STDMETHODCALLTYPE | get_Enabled (VARIANT_BOOL *bEnabled)=0
virtual HRESULT STDMETHODCALLTYPE | get_EnabledPicture (IUnknown **pPicture)=0
virtual HRESULT STDMETHODCALLTYPE | get_Font (IUnknown **pIFont)=0
virtual HRESULT STDMETHODCALLTYPE | get_ForeColor (OLE_COLOR *pclr)=0
virtual HRESULT STDMETHODCALLTYPE | get_KeepFocus (VARIANT_BOOL *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_ReadOnlyBackColor (OLE_COLOR *pclr)=0
virtual HRESULT STDMETHODCALLTYPE | get_ReadOnlyForeColor (OLE_COLOR *pclr)=0
virtual HRESULT STDMETHODCALLTYPE | get_Style (DWORD *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | get_UncheckedPicture (IUnknown **pPicture)=0
virtual HRESULT STDMETHODCALLTYPE | GetCategoryDescription (int CatID, LCID lCid, BSTR *pCategoryDescription)=0
virtual HRESULT STDMETHODCALLTYPE | GetCategoryName (int CatID, LCID lCid, BSTR *pCategoryName)=0
virtual HRESULT STDMETHODCALLTYPE | GetCategoryWeight (int CatID, long *pCategoryWeight)=0
virtual HRESULT STDMETHODCALLTYPE | GetColor (AcPiColorIndex __MIDL_0011, OLE_COLOR *pColor)=0
virtual HRESULT STDMETHODCALLTYPE | GetCommandButtons (int CatID, VARIANT *pCatCmdBtns)=0
virtual HRESULT STDMETHODCALLTYPE | GetParentCategory (int CatID, int *pParentCatID)=0
virtual HRESULT STDMETHODCALLTYPE | GetPersistence (IUnknown *pINode)=0
virtual HRESULT STDMETHODCALLTYPE | GetPropertyControl (VARIANT var, IUnknown **ppUnk)=0
virtual HRESULT STDMETHODCALLTYPE | GetPropertyIcon (VARIANT Id, IUnknown **pIcon)=0
virtual HRESULT STDMETHODCALLTYPE | GetPropertyWeight (VARIANT Id, long *pPropertyWeight)=0
virtual HRESULT STDMETHODCALLTYPE | GetPropTextColor (VARIANT Id, OLE_COLOR *pTextColor)=0
virtual HRESULT STDMETHODCALLTYPE | GetUniqueID (BSTR *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | GetUnspecifiedString (VARIANT varId, BSTR *pVal)=0
HRESULT STDMETHODCALLTYPE | IAcPeButtonEditCtrl_get_DefaultPicture_Proxy (IAcPeButtonEditCtrl *This, IUnknown **pIPicture)
void __RPC_STUB | IAcPeButtonEditCtrl_get_DefaultPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeButtonEditCtrl_get_DisabledPicture_Proxy (IAcPeButtonEditCtrl *This, IUnknown **pIPicture)
void __RPC_STUB | IAcPeButtonEditCtrl_get_DisabledPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeButtonEditCtrl_put_DefaultPicture_Proxy (IAcPeButtonEditCtrl *This, IUnknown *pIPicture)
void __RPC_STUB | IAcPeButtonEditCtrl_put_DefaultPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeButtonEditCtrl_put_DisabledPicture_Proxy (IAcPeButtonEditCtrl *This, IUnknown *pIPicture)
void __RPC_STUB | IAcPeButtonEditCtrl_put_DisabledPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeButtonPicture_get_DefaultPicture_Proxy (IAcPeButtonPicture *This, IUnknown **pIPicture)
void __RPC_STUB | IAcPeButtonPicture_get_DefaultPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeButtonPicture_get_DisabledPicture_Proxy (IAcPeButtonPicture *This, IUnknown **pIPicture)
void __RPC_STUB | IAcPeButtonPicture_get_DisabledPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeButtonPicture_put_DefaultPicture_Proxy (IAcPeButtonPicture *This, IUnknown *pIPicture)
void __RPC_STUB | IAcPeButtonPicture_put_DefaultPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeButtonPicture_put_DisabledPicture_Proxy (IAcPeButtonPicture *This, IUnknown *pIPicture)
void __RPC_STUB | IAcPeButtonPicture_put_DisabledPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeCalculatorCtrl_SetCalculatorMode_Proxy (IAcPeCalculatorCtrl *This, VARIANT_BOOL mode)
void __RPC_STUB | IAcPeCalculatorCtrl_SetCalculatorMode_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeColorCtrl_SetNoMetaColor_Proxy (IAcPeColorCtrl *This, VARIANT_BOOL bNoMetaColors)
void __RPC_STUB | IAcPeColorCtrl_SetNoMetaColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeNoPickVariantRW_SetAlwaysRW_Proxy (IAcPeNoPickVariantRW *This, VARIANT_BOOL bIsAlwaysRW)
void __RPC_STUB | IAcPeNoPickVariantRW_SetAlwaysRW_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeNumericEditor_SetNumericDataType_Proxy (IAcPeNumericEditor *This, enum AcPeNumericType dataType)
void __RPC_STUB | IAcPeNumericEditor_SetNumericDataType_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPePick2PointsCtrl_SetPrompts_Proxy (IAcPePick2PointsCtrl *This, BSTR prompt1, BSTR prompt2)
void __RPC_STUB | IAcPePick2PointsCtrl_SetPrompts_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeSpinCtrl_SetControls_Proxy (IAcPeSpinCtrl *This, VARIANT varControlsIUnkArray)
void __RPC_STUB | IAcPeSpinCtrl_SetControls_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeVariantCtrl_SetDwCookies_Proxy (IAcPeVariantCtrl *This, VARIANT cookieArray)
void __RPC_STUB | IAcPeVariantCtrl_SetDwCookies_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeVariantCtrl_SetElementCount_Proxy (IAcPeVariantCtrl *This, DWORD elemCount)
void __RPC_STUB | IAcPeVariantCtrl_SetElementCount_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPeVariantCtrl_SetGroupOffset_Proxy (IAcPeVariantCtrl *This, DWORD dwOffset)
void __RPC_STUB | IAcPeVariantCtrl_SetGroupOffset_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChannelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCategorizeProperties_GetCategoryDescription_Proxy (IAcPiCategorizeProperties *This, int CatID, LCID lCid, BSTR *pCategoryDescription)
void __RPC_STUB | IAcPiCategorizeProperties_GetCategoryDescription_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCategorizeProperties_GetCategoryName_Proxy (IAcPiCategorizeProperties *This, int CatID, LCID lCid, BSTR *pCategoryName)
void __RPC_STUB | IAcPiCategorizeProperties_GetCategoryName_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCategorizeProperties_GetCategoryWeight_Proxy (IAcPiCategorizeProperties *This, int CatID, long *pCategoryWeight)
void __RPC_STUB | IAcPiCategorizeProperties_GetCategoryWeight_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCategorizeProperties_GetCommandButtons_Proxy (IAcPiCategorizeProperties *This, int CatID, VARIANT *pCatCmdBtns)
void __RPC_STUB | IAcPiCategorizeProperties_GetCommandButtons_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCategorizeProperties_GetParentCategory_Proxy (IAcPiCategorizeProperties *This, int CatID, int *pParentCatID)
void __RPC_STUB | IAcPiCategorizeProperties_GetParentCategory_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCategorizeProperties_GetUniqueID_Proxy (IAcPiCategorizeProperties *This, BSTR *pVal)
void __RPC_STUB | IAcPiCategorizeProperties_GetUniqueID_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCategorizeProperties_MapPropertyToCategory_Proxy (IAcPiCategorizeProperties *This, DISPID dispID, int *pCatID)
void __RPC_STUB | IAcPiCategorizeProperties_MapPropertyToCategory_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton2_get_CheckedPicture_Proxy (IAcPiCommandButton2 *This, IUnknown **pPicture)
void __RPC_STUB | IAcPiCommandButton2_get_CheckedPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton2_get_UncheckedPicture_Proxy (IAcPiCommandButton2 *This, IUnknown **pPicture)
void __RPC_STUB | IAcPiCommandButton2_get_UncheckedPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton_Execute_Proxy (IAcPiCommandButton *This, VARIANT Objects)
void __RPC_STUB | IAcPiCommandButton_Execute_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton_get_ButtonStyle_Proxy (IAcPiCommandButton *This, long *style)
void __RPC_STUB | IAcPiCommandButton_get_ButtonStyle_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton_get_Checked_Proxy (IAcPiCommandButton *This, VARIANT_BOOL *bChecked)
void __RPC_STUB | IAcPiCommandButton_get_Checked_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton_get_DisabledPicture_Proxy (IAcPiCommandButton *This, IUnknown **pPicture)
void __RPC_STUB | IAcPiCommandButton_get_DisabledPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton_get_Enabled_Proxy (IAcPiCommandButton *This, VARIANT_BOOL *bEnabled)
void __RPC_STUB | IAcPiCommandButton_get_Enabled_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton_get_EnabledPicture_Proxy (IAcPiCommandButton *This, IUnknown **pPicture)
void __RPC_STUB | IAcPiCommandButton_get_EnabledPicture_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton_GetName_Proxy (IAcPiCommandButton *This, LCID lcid, BSTR *name)
void __RPC_STUB | IAcPiCommandButton_GetName_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton_put_Checked_Proxy (IAcPiCommandButton *This, VARIANT_BOOL bChecked)
void __RPC_STUB | IAcPiCommandButton_put_Checked_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiCommandButton_put_Enabled_Proxy (IAcPiCommandButton *This, VARIANT_BOOL bEnabled)
void __RPC_STUB | IAcPiCommandButton_put_Enabled_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropCommandButtons_GetButtons_Proxy (IAcPiPropCommandButtons *This, VARIANT *pButtons)
void __RPC_STUB | IAcPiPropCommandButtons_GetButtons_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyDisplay_GetCustomPropertyCtrl_Proxy (IAcPiPropertyDisplay *This, VARIANT Id, LCID lcid, BSTR *pProgId)
void __RPC_STUB | IAcPiPropertyDisplay_GetCustomPropertyCtrl_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyDisplay_GetPropertyIcon_Proxy (IAcPiPropertyDisplay *This, VARIANT Id, IUnknown **pIcon)
void __RPC_STUB | IAcPiPropertyDisplay_GetPropertyIcon_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyDisplay_GetPropertyWeight_Proxy (IAcPiPropertyDisplay *This, VARIANT Id, long *pPropertyWeight)
void __RPC_STUB | IAcPiPropertyDisplay_GetPropertyWeight_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyDisplay_GetPropTextColor_Proxy (IAcPiPropertyDisplay *This, VARIANT Id, OLE_COLOR *pTextColor)
void __RPC_STUB | IAcPiPropertyDisplay_GetPropTextColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyDisplay_IsFullView_Proxy (IAcPiPropertyDisplay *This, VARIANT Id, VARIANT_BOOL *pbVisible, DWORD *pIntegralHeight)
void __RPC_STUB | IAcPiPropertyDisplay_IsFullView_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_get_BackColor_Proxy (IAcPiPropertyEditControl *This, OLE_COLOR *pclr)
void __RPC_STUB | IAcPiPropertyEditControl_get_BackColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_get_Font_Proxy (IAcPiPropertyEditControl *This, IUnknown **pIFont)
void __RPC_STUB | IAcPiPropertyEditControl_get_Font_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_get_ForeColor_Proxy (IAcPiPropertyEditControl *This, OLE_COLOR *pclr)
void __RPC_STUB | IAcPiPropertyEditControl_get_ForeColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_get_KeepFocus_Proxy (IAcPiPropertyEditControl *This, VARIANT_BOOL *pVal)
void __RPC_STUB | IAcPiPropertyEditControl_get_KeepFocus_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_get_ReadOnlyBackColor_Proxy (IAcPiPropertyEditControl *This, OLE_COLOR *pclr)
void __RPC_STUB | IAcPiPropertyEditControl_get_ReadOnlyBackColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_get_ReadOnlyForeColor_Proxy (IAcPiPropertyEditControl *This, OLE_COLOR *pclr)
void __RPC_STUB | IAcPiPropertyEditControl_get_ReadOnlyForeColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_InitEditControl_Proxy (IAcPiPropertyEditControl *This, LPVARIANT pVarObjDispArray, LPVARIANT pVarDynPropArray, LPVARIANT pDispidArray, VARIANT_BOOL bReadOnly)
void __RPC_STUB | IAcPiPropertyEditControl_InitEditControl_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_put_BackColor_Proxy (IAcPiPropertyEditControl *This, OLE_COLOR clr)
void __RPC_STUB | IAcPiPropertyEditControl_put_BackColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_put_Font_Proxy (IAcPiPropertyEditControl *This, IUnknown *pIFont)
void __RPC_STUB | IAcPiPropertyEditControl_put_Font_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_put_ForeColor_Proxy (IAcPiPropertyEditControl *This, OLE_COLOR clr)
void __RPC_STUB | IAcPiPropertyEditControl_put_ForeColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_put_ReadOnlyBackColor_Proxy (IAcPiPropertyEditControl *This, OLE_COLOR clr)
void __RPC_STUB | IAcPiPropertyEditControl_put_ReadOnlyBackColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_put_ReadOnlyForeColor_Proxy (IAcPiPropertyEditControl *This, OLE_COLOR clr)
void __RPC_STUB | IAcPiPropertyEditControl_put_ReadOnlyForeColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditControl_Refresh_Proxy (IAcPiPropertyEditControl *This, DWORD dwFlags)
void __RPC_STUB | IAcPiPropertyEditControl_Refresh_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditEventsSink_OnBeginPropertyUpdate_Proxy (IAcPiPropertyEditEventsSink *This)
void __RPC_STUB | IAcPiPropertyEditEventsSink_OnBeginPropertyUpdate_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditEventsSink_OnClick_Proxy (IAcPiPropertyEditEventsSink *This)
void __RPC_STUB | IAcPiPropertyEditEventsSink_OnClick_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditEventsSink_OnDblClick_Proxy (IAcPiPropertyEditEventsSink *This)
void __RPC_STUB | IAcPiPropertyEditEventsSink_OnDblClick_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditEventsSink_OnEndPropertyUpdate_Proxy (IAcPiPropertyEditEventsSink *This)
void __RPC_STUB | IAcPiPropertyEditEventsSink_OnEndPropertyUpdate_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditEventsSink_OnKeyDown_Proxy (IAcPiPropertyEditEventsSink *This, LONG_PTR pnChar, LONG_PTR keyData)
void __RPC_STUB | IAcPiPropertyEditEventsSink_OnKeyDown_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditEventsSink_OnKeyUp_Proxy (IAcPiPropertyEditEventsSink *This, LONG_PTR pnChar, LONG_PTR keyData)
void __RPC_STUB | IAcPiPropertyEditEventsSink_OnKeyUp_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditEventsSink_OnMButtonDown_Proxy (IAcPiPropertyEditEventsSink *This, WPARAM wParam, LPARAM lParam)
void __RPC_STUB | IAcPiPropertyEditEventsSink_OnMButtonDown_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyEditEventsSink_OnRButtonDown_Proxy (IAcPiPropertyEditEventsSink *This, WPARAM wParam, LPARAM lParam)
void __RPC_STUB | IAcPiPropertyEditEventsSink_OnRButtonDown_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_get_BoldFont_Proxy (IAcPiPropertyInspector *This, IUnknown **pIFont)
void __RPC_STUB | IAcPiPropertyInspector_get_BoldFont_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_get_DelayRefresh_Proxy (IAcPiPropertyInspector *This, VARIANT_BOOL *pbDelayRefresh)
void __RPC_STUB | IAcPiPropertyInspector_get_DelayRefresh_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_get_Font_Proxy (IAcPiPropertyInspector *This, IUnknown **pIFont)
void __RPC_STUB | IAcPiPropertyInspector_get_Font_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_get_KeepFocus_Proxy (IAcPiPropertyInspector *This, VARIANT_BOOL *pVal)
void __RPC_STUB | IAcPiPropertyInspector_get_KeepFocus_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_get_Style_Proxy (IAcPiPropertyInspector *This, DWORD *pVal)
void __RPC_STUB | IAcPiPropertyInspector_get_Style_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_GetColor_Proxy (IAcPiPropertyInspector *This, AcPiColorIndex __MIDL_0011, OLE_COLOR *pColor)
void __RPC_STUB | IAcPiPropertyInspector_GetColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_GetPersistence_Proxy (IAcPiPropertyInspector *This, IUnknown *pINode)
void __RPC_STUB | IAcPiPropertyInspector_GetPersistence_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_put_BoldFont_Proxy (IAcPiPropertyInspector *This, IUnknown *pIFont)
void __RPC_STUB | IAcPiPropertyInspector_put_BoldFont_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_put_DelayRefresh_Proxy (IAcPiPropertyInspector *This, VARIANT_BOOL bDelayRefresh)
void __RPC_STUB | IAcPiPropertyInspector_put_DelayRefresh_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_put_Font_Proxy (IAcPiPropertyInspector *This, IUnknown *pIFont)
void __RPC_STUB | IAcPiPropertyInspector_put_Font_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_put_Style_Proxy (IAcPiPropertyInspector *This, DWORD newVal)
void __RPC_STUB | IAcPiPropertyInspector_put_Style_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_Reset_Proxy (IAcPiPropertyInspector *This, VARIANT *pObjUnkArray, VARIANT *pDynUnkArray, DWORD dwFlags)
void __RPC_STUB | IAcPiPropertyInspector_Reset_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_SetColor_Proxy (IAcPiPropertyInspector *This, AcPiColorIndex index, OLE_COLOR color)
void __RPC_STUB | IAcPiPropertyInspector_SetColor_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspector_SetPersistence_Proxy (IAcPiPropertyInspector *This, IUnknown *pINode)
void __RPC_STUB | IAcPiPropertyInspector_SetPersistence_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspectorEventsSink_GetPropertyControl_Proxy (IAcPiPropertyInspectorEventsSink *This, VARIANT var, IUnknown **ppUnk)
void __RPC_STUB | IAcPiPropertyInspectorEventsSink_GetPropertyControl_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspectorEventsSink_Rebuild_Proxy (IAcPiPropertyInspectorEventsSink *This, DWORD dwFlags)
void __RPC_STUB | IAcPiPropertyInspectorEventsSink_Rebuild_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspectorEventsSink_RefreshControl_Proxy (IAcPiPropertyInspectorEventsSink *This, VARIANT var, DWORD dwFlags)
void __RPC_STUB | IAcPiPropertyInspectorEventsSink_RefreshControl_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspectorInputEventSink_OnContextMenuCommand_Proxy (IAcPiPropertyInspectorInputEventSink *This, int cmdId)
void __RPC_STUB | IAcPiPropertyInspectorInputEventSink_OnContextMenuCommand_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspectorInputEventSink_OnKeyDown_Proxy (IAcPiPropertyInspectorInputEventSink *This, long pnChar, long keyData)
void __RPC_STUB | IAcPiPropertyInspectorInputEventSink_OnKeyDown_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyInspectorInputEventSink_OnPopulateContextMenu_Proxy (IAcPiPropertyInspectorInputEventSink *This, VARIANT *flagArray, VARIANT *idArray, VARIANT *szItemArray)
void __RPC_STUB | IAcPiPropertyInspectorInputEventSink_OnPopulateContextMenu_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyUnspecified_GetUnspecifiedString_Proxy (IAcPiPropertyUnspecified *This, VARIANT varId, BSTR *pVal)
void __RPC_STUB | IAcPiPropertyUnspecified_GetUnspecifiedString_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyUnspecified_IsUnspecifiedAllowed_Proxy (IAcPiPropertyUnspecified *This, VARIANT varId, VARIANT_BOOL *pVal)
void __RPC_STUB | IAcPiPropertyUnspecified_IsUnspecifiedAllowed_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyUnspecified_IsValueUnspecified_Proxy (IAcPiPropertyUnspecified *This, VARIANT varId, VARIANT_BOOL *pVal)
void __RPC_STUB | IAcPiPropertyUnspecified_IsValueUnspecified_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
HRESULT STDMETHODCALLTYPE | IAcPiPropertyUnspecified_SetUnspecified_Proxy (IAcPiPropertyUnspecified *This, VARIANT varId, VARIANT_BOOL bIsUnspecified)
void __RPC_STUB | IAcPiPropertyUnspecified_SetUnspecified_Stub (IRpcStubBuffer *This, IRpcChannelBuffer *_pRpcChaelBuffer, PRPC_MESSAGE _pRpcMessage, DWORD *_pdwStubPhase)
virtual HRESULT STDMETHODCALLTYPE | IsFullView (VARIANT Id, VARIANT_BOOL *pbVisible, DWORD *pIntegralHeight)=0
virtual HRESULT STDMETHODCALLTYPE | IsUnspecifiedAllowed (VARIANT varId, VARIANT_BOOL *pVal)=0
virtual HRESULT STDMETHODCALLTYPE | OnBeginPropertyUpdate (void)=0
virtual HRESULT STDMETHODCALLTYPE | OnContextMenuCommand (int cmdId)=0
virtual HRESULT STDMETHODCALLTYPE | OnDblClick (void)=0
virtual HRESULT STDMETHODCALLTYPE | OnEndPropertyUpdate (void)=0
virtual HRESULT STDMETHODCALLTYPE | OnKeyDown (LONG_PTR pnChar, LONG_PTR keyData)=0
virtual HRESULT STDMETHODCALLTYPE | OnKeyUp (LONG_PTR pnChar, LONG_PTR keyData)=0
virtual HRESULT STDMETHODCALLTYPE | OnMButtonDown (WPARAM wParam, LPARAM lParam)=0
virtual HRESULT STDMETHODCALLTYPE | OnPopulateContextMenu (VARIANT *flagArray, VARIANT *idArray, VARIANT *szItemArray)=0
virtual HRESULT STDMETHODCALLTYPE | OnRButtonDown (WPARAM wParam, LPARAM lParam)=0
virtual HRESULT STDMETHODCALLTYPE | put_BackColor (OLE_COLOR clr)=0
virtual HRESULT STDMETHODCALLTYPE | put_BoldFont (IUnknown *pIFont)=0
virtual HRESULT STDMETHODCALLTYPE | put_Checked (VARIANT_BOOL bChecked)=0
virtual HRESULT STDMETHODCALLTYPE | put_DelayRefresh (VARIANT_BOOL bDelayRefresh)=0
virtual HRESULT STDMETHODCALLTYPE | put_DisabledPicture (IUnknown *pIPicture)=0
virtual HRESULT STDMETHODCALLTYPE | put_Enabled (VARIANT_BOOL bEnabled)=0
virtual HRESULT STDMETHODCALLTYPE | put_Font (IUnknown *pIFont)=0
virtual HRESULT STDMETHODCALLTYPE | put_ForeColor (OLE_COLOR clr)=0
virtual HRESULT STDMETHODCALLTYPE | put_ReadOnlyBackColor (OLE_COLOR clr)=0
virtual HRESULT STDMETHODCALLTYPE | put_ReadOnlyForeColor (OLE_COLOR clr)=0
virtual HRESULT STDMETHODCALLTYPE | put_Style (DWORD newVal)=0
virtual HRESULT STDMETHODCALLTYPE | Refresh (DWORD dwFlags)=0
virtual HRESULT STDMETHODCALLTYPE | RefreshControl (VARIANT var, DWORD dwFlags)=0
virtual HRESULT STDMETHODCALLTYPE | SetColor (AcPiColorIndex index, OLE_COLOR color)=0
virtual HRESULT STDMETHODCALLTYPE | SetElementCount (DWORD elemCount)=0
virtual HRESULT STDMETHODCALLTYPE | SetGroupOffset (DWORD dwOffset)=0
virtual HRESULT STDMETHODCALLTYPE | SetPersistence (IUnknown *pINode)=0
virtual HRESULT STDMETHODCALLTYPE | SetUnspecified (VARIANT varId, VARIANT_BOOL bIsUnspecified)=0

Variables

RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0000_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0000_v0_0_s_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0001_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0001_v0_0_s_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0002_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0002_v0_0_s_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0003_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0003_v0_0_s_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0004_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0004_v0_0_s_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0005_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0005_v0_0_s_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0006_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0006_v0_0_s_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0007_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0007_v0_0_s_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0008_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0008_v0_0_s_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0009_v0_0_c_ifspec
RPC_IF_HANDLE | __MIDL_itf_ZcPi_0000_0009_v0_0_s_ifspec
IAcPiPropertyInspector | __pad0__
IAcPeNumericEditor | __pad0__
IAcPiPropertyInspectorInputEventSink | __pad10__
IAcPiPropertyEditControl | __pad1__
IAcPeVariantCtrl | __pad1__
IAcPiPropertyEditEventsSink | __pad2__
IAcPeColorCtrl | __pad2__
IAcPeSpinCtrl | __pad3__
IAcPiPropertyUnspecified | __pad3__
IAcPeNoPickVariantRW | __pad4__
IAcPiPropertyDisplay | __pad4__
IAcPeButtonEditCtrl | __pad5__
IAcPiCategorizeProperties | __pad5__
IAcPeButtonPicture | __pad6__
IAcPiPropCommandButtons | __pad6__
IAcPePick2PointsCtrl | __pad7__
IAcPiCommandButton | __pad7__
IAcPeCalculatorCtrl | __pad8__
IAcPiCommandButton2 | __pad8__
IAcPiPropertyInspectorEventsSink | __pad9__
AcPeNumericType
AcPiColorIndex
IAcPiPropertyEditControl
LPVARIANT LPVARIANT
VARIANT_BOOL 		bReadOnly = 0
EXTERN_C const CLSID | CLSID_AcPiPropertyInspector
const int | DISPID_DYNAMIC = -23
IAcPiPropertyInspector VARIANT
DWORD 		dwFlags = 0
EXTERN_C const IID | IID_IAcPeButtonEditCtrl
EXTERN_C const IID | IID_IAcPeButtonPicture
EXTERN_C const IID | IID_IAcPeCalculatorCtrl
EXTERN_C const IID | IID_IAcPeColorCtrl
EXTERN_C const IID | IID_IAcPeNoPickVariantRW
EXTERN_C const IID | IID_IAcPeNumericEditor
EXTERN_C const IID | IID_IAcPePick2PointsCtrl
EXTERN_C const IID | IID_IAcPeSpinCtrl
EXTERN_C const IID | IID_IAcPeVariantCtrl
EXTERN_C const IID | IID_IAcPiCategorizeProperties
EXTERN_C const IID | IID_IAcPiCommandButton
EXTERN_C const IID | IID_IAcPiCommandButton2
EXTERN_C const IID | IID_IAcPiPropCommandButtons
EXTERN_C const IID | IID_IAcPiPropertyDisplay
EXTERN_C const IID | IID_IAcPiPropertyEditControl
EXTERN_C const IID | IID_IAcPiPropertyEditEventsSink
EXTERN_C const IID | IID_IAcPiPropertyInspector
EXTERN_C const IID | IID_IAcPiPropertyInspectorEventsSink
EXTERN_C const IID | IID_IAcPiPropertyInspectorInputEventSink
EXTERN_C const IID | IID_IAcPiPropertyUnspecified
IAcPiPropertyInspectorInputEventSink
long 		keyData = 0
IAcPiPropertyDisplay LCID | lcid
EXTERN_C const IID | LIBID_ACPEXCTLLib
EXTERN_C const IID | LIBID_ACPILib
IAcPiCommandButton BSTR * | name = 0
IAcPiCategorizeProperties int * | pCatID = 0
IAcPiPropertyEditControl
LPVARIANT LPVARIANT 		pDispidArray
IAcPiPropertyInspector VARIANT * | pDynUnkArray
IAcPiPropertyDisplay LCID BSTR * | pProgId = 0
IAcPePick2PointsCtrl BSTR | prompt2 = 0
IAcPiPropertyUnspecified
VARIANT_BOOL * 		pVal = 0
IAcPiPropertyEditControl LPVARIANT | pVarDynPropArray

Detailed Description


ZRX API Reference: IAcPiCategorizePropertiesImpl< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
IAcPiCategorizePropertiesImpl< T > Class Template Reference
OPM Classes

Public Member Functions

STDMETHODIMP | GetCategoryDescription (PROPCAT propcat, LCID lcid, BSTR *pbstrDesc)
STDMETHODIMP | GetCategoryName (PROPCAT propcat, LCID lcid, BSTR *pbstrName)
CATEGORY_VECTOR & | GetCategoryVector ()
STDMETHODIMP | GetCategoryWeight (PROPCAT CatID, long *pCategoryWeight)
CATCMDBTN_VECTOR & | GetCmdBtnVector ()
STDMETHODIMP | GetCommandButtons (PROPCAT CatID, VARIANT *pCatCmdBtns)
STDMETHODIMP | GetParentCategory (PROPCAT CatID, PROPCAT *pParentCatID)
virtual HINSTANCE | GetResourceInstance ()=0
bool | IsDefaultCategoryEntry (CATEGORY_ENTRY in)
bool | IsDefaultCmdBtnEntry (CATCMDBTN_ENTRY in)
STDMETHODIMP | MapPropertyToCategory (DISPID dispid, PROPCAT *ppropcat)

Public Attributes

CATCMDBTN_VECTOR | m_CatCmdBtnVector
CATEGORY_VECTOR | m_CategoryVector
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcPiCategorizePropertiesImpl< T > Member List

This is the complete list of members for IAcPiCategorizePropertiesImpl< T >, including all inherited members.

GetCategoryDescription(PROPCAT propcat, LCID lcid, BSTR *pbstrDesc) (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
GetCategoryName(PROPCAT propcat, LCID lcid, BSTR *pbstrName) (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
GetCategoryVector() (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
GetCategoryWeight(PROPCAT CatID, long *pCategoryWeight) (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
GetCmdBtnVector() (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
GetCommandButtons(PROPCAT CatID, VARIANT *pCatCmdBtns) (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
GetParentCategory(PROPCAT CatID, PROPCAT *pParentCatID) (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
GetResourceInstance()=0 (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | pure virtual
IAcPiCategorizePropertiesImpl() (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
IsDefaultCategoryEntry(CATEGORY_ENTRY in) (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
IsDefaultCmdBtnEntry(CATCMDBTN_ENTRY in) (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
m_CatCmdBtnVector (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > |
m_CategoryVector (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > |
MapPropertyToCategory(DISPID dispid, PROPCAT *ppropcat) (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inline
~IAcPiCategorizePropertiesImpl() (defined in IAcPiCategorizePropertiesImpl< T >) | IAcPiCategorizePropertiesImpl< T > | inlinevirtual


ZRX API Reference: IAcPiPropCommandButtonsImpl< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
IAcPiPropCommandButtonsImpl< T > Class Template Reference
OPM Classes

Public Member Functions

STDMETHODIMP | GetButtons (VARIANT *pCmdBtns)
CMDBTN_VECTOR & | GetCmdBtnVector ()
virtual HINSTANCE | GetResourceInstance ()=0
bool | IsDefaultCmdBtnEntry (CMDBTN_ENTRY in)

Public Attributes

CMDBTN_VECTOR m_CmdBtnVector
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcPiPropCommandButtonsImpl< T > Member List

This is the complete list of members for IAcPiPropCommandButtonsImpl< T >, including all inherited members.

GetButtons(VARIANT *pCmdBtns) (defined in IAcPiPropCommandButtonsImpl< T >) | IAcPiPropCommandButtonsImpl< T > | inline
GetCmdBtnVector() (defined in IAcPiPropCommandButtonsImpl< T >) | IAcPiPropCommandButtonsImpl< T > | inline
GetResourceInstance()=0 (defined in IAcPiPropCommandButtonsImpl< T >) | IAcPiPropCommandButtonsImpl< T > | pure virtual
IAcPiPropCommandButtonsImpl() (defined in IAcPiPropCommandButtonsImpl< T >) | IAcPiPropCommandButtonsImpl< T > | inline
IsDefaultCmdBtnEntry(CMDBTN_ENTRY in) (defined in IAcPiPropCommandButtonsImpl< T >) | IAcPiPropCommandButtonsImpl< T > | inline
m_CmdBtnVector (defined in IAcPiPropCommandButtonsImpl< T >) | IAcPiPropCommandButtonsImpl< T > |
~IAcPiPropCommandButtonsImpl() (defined in IAcPiPropCommandButtonsImpl< T >) | IAcPiPropCommandButtonsImpl< T > | inlinevirtual


ZRX API Reference: IAcPiPropertyDisplayImpl< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
IAcPiPropertyDisplayImpl< T > Class Template Reference
OPM Classes

Public Member Functions

STDMETHODIMP | GetCustomPropertyCtrl (VARIANT Id, LCID lcid, BSTR *psProgId)
PROP_DISP_VECTOR & | GetPerPropDisplayVector ()
STDMETHODIMP | GetPropertyIcon (VARIANT Id, IUnknown **ppIcon)
STDMETHODIMP | GetPropertyWeight (VARIANT Id, long *pPropertyWeight)
STDMETHODIMP | GetPropTextColor (VARIANT Id, OLE_COLOR *pTextColor)
virtual HINSTANCE | GetResourceInstance ()=0
bool | IsDefaultPerPropDispEntry (PER_PROP_DISP_ENTRY in)
STDMETHODIMP | IsFullView (VARIANT Id, VARIANT_BOOL *pbVisible, DWORD *pIntegralHeight)

Public Attributes

PROP_DISP_VECTOR m_PropDispVector
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcPiPropertyDisplayImpl< T > Member List

This is the complete list of members for IAcPiPropertyDisplayImpl< T >, including all inherited members.

GetCustomPropertyCtrl(VARIANT Id, LCID lcid, BSTR *psProgId) (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | inline
GetPerPropDisplayVector() (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | inline
GetPropertyIcon(VARIANT Id, IUnknown **ppIcon) (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | inline
GetPropertyWeight(VARIANT Id, long *pPropertyWeight) (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | inline
GetPropTextColor(VARIANT Id, OLE_COLOR *pTextColor) (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | inline
GetResourceInstance()=0 (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | pure virtual
IAcPiPropertyDisplayImpl() (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | inline
IsDefaultPerPropDispEntry(PER_PROP_DISP_ENTRY in) (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | inline
IsFullView(VARIANT Id, VARIANT_BOOL *pbVisible, DWORD *pIntegralHeight) (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | inline
m_PropDispVector (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > |
~IAcPiPropertyDisplayImpl() (defined in IAcPiPropertyDisplayImpl< T >) | IAcPiPropertyDisplayImpl< T > | inlinevirtual


ZRX API Reference: IOPMPropertyExtensionImpl< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
IOPMPropertyExtensionImpl< T > Class Template Reference
OPM Classes

Public Member Functions

STDMETHODIMP | Editable (DISPID dispID, BOOL __RPC_FAR *bEditable)
STDMETHODIMP | GetCategoryName (PROPCAT propcat, LCID lcid, BSTR *pbstrName)
STDMETHODIMP | GetDisplayName (DISPID dispID, BSTR *pBstr)
STDMETHODIMP | GetDisplayString (DISPID dispID, BSTR *pBstr)
STDMETHODIMP | GetPredefinedStrings (DISPID dispID, CALPOLESTR *pCaStringsOut, CADWORD *pCaCookiesOut)
STDMETHODIMP | GetPredefinedValue (DISPID dispID, DWORD dwCookie, VARIANT *pVarOut)
virtual HINSTANCE | GetResourceInstance ()=0
STDMETHODIMP | MapPropertyToCategory (DISPID dispid, PROPCAT *ppropcat)
STDMETHODIMP | MapPropertyToPage (DISPID dispID, CLSID *pClsid)
STDMETHODIMP | ShowProperty (DISPID dispID, BOOL *pShow)
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: IOPMPropertyExtensionImpl2< T > Class Template Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
IOPMPropertyExtensionImpl2< T > Class Template Reference
OPM Classes

Public Member Functions

STDMETHODIMP | Editable (DISPID dispID, BOOL __RPC_FAR *bEditable)
STDMETHODIMP | GetDisplayName (DISPID dispID, BSTR *pBstr)
STDMETHODIMP | GetDisplayString (DISPID dispID, BSTR *pBstr)
STDMETHODIMP | GetPredefinedStrings (DISPID dispID, CALPOLESTR *pCaStringsOut, CADWORD *pCaCookiesOut)
STDMETHODIMP | GetPredefinedValue (DISPID dispID, DWORD dwCookie, VARIANT *pVarOut)
virtual HINSTANCE | GetResourceInstance ()=0
STDMETHODIMP | MapPropertyToPage (DISPID dispID, CLSID *pClsid)
STDMETHODIMP | ShowProperty (DISPID dispID, BOOL *pShow)
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IOPMPropertyExtensionImpl2< T > Member List

This is the complete list of members for IOPMPropertyExtensionImpl2< T >, including all inherited members.

Editable(DISPID dispID, BOOL __RPC_FAR *bEditable) (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | inline
GetDisplayName(DISPID dispID, BSTR *pBstr) (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | inline
GetDisplayString(DISPID dispID, BSTR *pBstr) (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | inline
GetPredefinedStrings(DISPID dispID, CALPOLESTR *pCaStringsOut, CADWORD *pCaCookiesOut) (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | inline
GetPredefinedValue(DISPID dispID, DWORD dwCookie, VARIANT *pVarOut) (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | inline
GetResourceInstance()=0 (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | pure virtual
IOPMPropertyExtensionImpl2() (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | inline
MapPropertyToPage(DISPID dispID, CLSID *pClsid) (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | inline
ShowProperty(DISPID dispID, BOOL *pShow) (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | inline
~IOPMPropertyExtensionImpl2() (defined in IOPMPropertyExtensionImpl2< T >) | IOPMPropertyExtensionImpl2< T > | inlinevirtual


ZRX API Reference: IRetrieveApplicationImpl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
IRetrieveApplicationImpl Class Reference
OPM Classes
+ Inheritance diagram for IRetrieveApplicationImpl:

Public Member Functions

STDMETHOD() | GetApplicationObject (LPDISPATCH *pApp)
STDMETHOD() | SetApplicationObject (LPDISPATCH pApp)

Protected Attributes

LPDISPATCH m_App
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IRetrieveApplicationImpl Member List

This is the complete list of members for IRetrieveApplicationImpl, including all inherited members.

GetApplicationObject(LPDISPATCH *pApp) (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
IRetrieveApplicationImpl() (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
m_App (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | protected
SetApplicationObject(LPDISPATCH pApp) (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inline
~IRetrieveApplicationImpl() (defined in IRetrieveApplicationImpl) | IRetrieveApplicationImpl | inlinevirtual


ZRX API Reference: OPMPerInstancePropertyExtension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
OPMPerInstancePropertyExtension Class Reference
OPM Classes
+ Inheritance diagram for OPMPerInstancePropertyExtension:

Public Member Functions

ACRX_DECLARE_MEMBERS (OPMPerInstancePropertyExtension)
virtual bool | AddObjectPropertySourceName (const BSTR *pName)=0
virtual bool | GetObjectPropertySourceNames (VARIANT *pNames)=0
virtual bool | RemoveObjectPropertySourceName (const BSTR *pName)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dynprops.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
OPMPerInstancePropertyExtension Member List

This is the complete list of members for OPMPerInstancePropertyExtension, including all inherited members.

ACRX_DECLARE_MEMBERS(OPMPerInstancePropertyExtension) (defined in OPMPerInstancePropertyExtension) | OPMPerInstancePropertyExtension |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
AddObjectPropertySourceName(const BSTR *pName)=0 (defined in OPMPerInstancePropertyExtension) | OPMPerInstancePropertyExtension | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
GetObjectPropertySourceNames(VARIANT *pNames)=0 (defined in OPMPerInstancePropertyExtension) | OPMPerInstancePropertyExtension | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
RemoveObjectPropertySourceName(const BSTR *pName)=0 (defined in OPMPerInstancePropertyExtension) | OPMPerInstancePropertyExtension | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~OPMPerInstancePropertyExtension() (defined in OPMPerInstancePropertyExtension) | OPMPerInstancePropertyExtension | inlinevirtual


ZRX API Reference: OPMPerInstancePropertyExtensionFactory Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
OPMPerInstancePropertyExtensionFactory Class Reference
OPM Classes
+ Inheritance diagram for OPMPerInstancePropertyExtensionFactory:

Public Member Functions

ACRX_DECLARE_MEMBERS (OPMPerInstancePropertyExtensionFactory)
virtual
OPMPerInstancePropertyExtension * 		CreateOPMPerInstancePropertyExtension (AcRxClass *pClass)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dynprops.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
OPMPerInstancePropertyExtensionFactory Member List

This is the complete list of members for OPMPerInstancePropertyExtensionFactory, including all inherited members.

ACRX_DECLARE_MEMBERS(OPMPerInstancePropertyExtensionFactory) (defined in OPMPerInstancePropertyExtensionFactory) | OPMPerInstancePropertyExtensionFactory |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
CreateOPMPerInstancePropertyExtension(AcRxClass *pClass)=0 (defined in OPMPerInstancePropertyExtensionFactory) | OPMPerInstancePropertyExtensionFactory | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~OPMPerInstancePropertyExtensionFactory() (defined in OPMPerInstancePropertyExtensionFactory) | OPMPerInstancePropertyExtensionFactory | inlinevirtual


ZRX API Reference: OPMPerInstancePropertySources Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
OPMPerInstancePropertySources Class Reference
OPM Classes
+ Inheritance diagram for OPMPerInstancePropertySources:

Public Member Functions

ACRX_DECLARE_MEMBERS (OPMPerInstancePropertySources)
virtual IPropertySource * | GetPropertySourceAt (const BSTR *pName)=0
virtual bool | GetPropertySourceNames (VARIANT *pNames)=0
virtual bool | RemovePropertySourceAt (const BSTR *pName)=0
virtual bool | SetPropertySourceAt (const BSTR *pName, IPropertySource *pSource)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dynprops.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
OPMPerInstancePropertySources Member List

This is the complete list of members for OPMPerInstancePropertySources, including all inherited members.

ACRX_DECLARE_MEMBERS(OPMPerInstancePropertySources) (defined in OPMPerInstancePropertySources) | OPMPerInstancePropertySources |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
GetPropertySourceAt(const BSTR *pName)=0 (defined in OPMPerInstancePropertySources) | OPMPerInstancePropertySources | pure virtual
GetPropertySourceNames(VARIANT *pNames)=0 (defined in OPMPerInstancePropertySources) | OPMPerInstancePropertySources | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
RemovePropertySourceAt(const BSTR *pName)=0 (defined in OPMPerInstancePropertySources) | OPMPerInstancePropertySources | pure virtual
SetPropertySourceAt(const BSTR *pName, IPropertySource *pSource)=0 (defined in OPMPerInstancePropertySources) | OPMPerInstancePropertySources | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~OPMPerInstancePropertySources() (defined in OPMPerInstancePropertySources) | OPMPerInstancePropertySources | inlinevirtual


ZRX API Reference: OPMPropertyExtension Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
OPMPropertyExtension Class Reference
OPM Classes
+ Inheritance diagram for OPMPropertyExtension:

Public Member Functions

ACRX_DECLARE_MEMBERS (OPMPropertyExtension)
virtual IPropertyManager * | GetPropertyManager ()=0
virtual void | SetPropertyManager (IPropertyManager *pPropManager)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dynprops.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
OPMPropertyExtension Member List

This is the complete list of members for OPMPropertyExtension, including all inherited members.

ACRX_DECLARE_MEMBERS(OPMPropertyExtension) (defined in OPMPropertyExtension) | OPMPropertyExtension |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
GetPropertyManager()=0 (defined in OPMPropertyExtension) | OPMPropertyExtension | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
SetPropertyManager(IPropertyManager *pPropManager)=0 (defined in OPMPropertyExtension) | OPMPropertyExtension | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~OPMPropertyExtension() (defined in OPMPropertyExtension) | OPMPropertyExtension | inlinevirtual


ZRX API Reference: OPMPropertyExtensionFactory Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
OPMPropertyExtensionFactory Class Reference
OPM Classes
+ Inheritance diagram for OPMPropertyExtensionFactory:

Public Member Functions

ACRX_DECLARE_MEMBERS (OPMPropertyExtensionFactory)
virtual OPMPropertyExtension * | CreateOPMCommandProtocol (const ACHAR *pGlobalCommand, LONG lReserved=NULL)=0
virtual OPMPropertyExtension * | CreateOPMObjectProtocol (AcRxClass *pClass, LONG lReserved=NULL)=0
virtual BOOL | GetOPMManager (const ACHAR *pGlobalCommand, IPropertyManager **pManager)=0
virtual LONG | GetPropertyClassArray (AcRxClass *pClass, IDynamicProperty **pPropertyArray)=0
virtual LONG | GetPropertyClassArray (AcRxClass *pClass, IUnknown **pPropertyArray)=0
virtual BOOL | GetPropertyCount (AcRxClass *pClass, LONG *pPropCount)=0
virtual BOOL | GetPropertyCountEx (AcRxClass *pClass, LONG *pPropCount)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • dynprops.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
OPMPropertyExtensionFactory Member List

This is the complete list of members for OPMPropertyExtensionFactory, including all inherited members.

ACRX_DECLARE_MEMBERS(OPMPropertyExtensionFactory) (defined in OPMPropertyExtensionFactory) | OPMPropertyExtensionFactory |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
CreateOPMCommandProtocol(const ACHAR *pGlobalCommand, LONG lReserved=NULL)=0 (defined in OPMPropertyExtensionFactory) | OPMPropertyExtensionFactory | pure virtual
CreateOPMObjectProtocol(AcRxClass *pClass, LONG lReserved=NULL)=0 (defined in OPMPropertyExtensionFactory) | OPMPropertyExtensionFactory | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
GetOPMManager(const ACHAR *pGlobalCommand, IPropertyManager **pManager)=0 (defined in OPMPropertyExtensionFactory) | OPMPropertyExtensionFactory | pure virtual
GetPropertyClassArray(AcRxClass *pClass, IDynamicProperty **pPropertyArray)=0 (defined in OPMPropertyExtensionFactory) | OPMPropertyExtensionFactory | pure virtual
GetPropertyClassArray(AcRxClass *pClass, IUnknown **pPropertyArray)=0 (defined in OPMPropertyExtensionFactory) | OPMPropertyExtensionFactory | pure virtual
GetPropertyCount(AcRxClass *pClass, LONG *pPropCount)=0 (defined in OPMPropertyExtensionFactory) | OPMPropertyExtensionFactory | pure virtual
GetPropertyCountEx(AcRxClass *pClass, LONG *pPropCount)=0 (defined in OPMPropertyExtensionFactory) | OPMPropertyExtensionFactory | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~OPMPropertyExtensionFactory() (defined in OPMPropertyExtensionFactory) | OPMPropertyExtensionFactory | inlinevirtual


ZRX API Reference: Structs

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Classes | Typedefs | Enumerations | Variables
Structs

Classes

struct | _OPM_DYNPROP_ENTRY
struct | Acad
struct | AcAp
struct | AcColorSettings
struct | AcColorSettingsEx
struct | AcDb
struct | AcDbMTextFragment
struct | AcDbUnderlayDrawContext
struct | AcEdCommandStruc
struct | AcFd
struct | AcGe
struct | AcGeContext
struct | AcGiClipBoundary
struct | AcGiRequestScanLines
struct | AcGiSentScanLines
struct | AcGridProperty
struct | AcGs
struct | AcGsRenderStatistics
struct | AcHyperlink
struct | AcPl3dDwfOptions
struct | ACPL_PREVIEWENDPLOT
struct | AcUt
struct | Adesk
struct | ads_binary
union | ads_u_val
struct | Mline
struct | PER_FLYOUT_ENTRY
struct | PER_PROP_DISP_ENTRY2
struct | PROMPT_MAP_ENTRY
struct | resbuf
struct | SecurityParams
struct | SignatureInfo
struct | tagADUI_DRAGDATA
struct | tagChildFrmSettings
struct | tagClipboardInfo

Typedefs

typedef struct tagChildFrmSettings | AcChildFrmSettings
typedef struct AcFd | AcFd
typedef struct AcHyperlink | AcHyperlink
typedef struct tagADUI_DRAGDATA | ADUI_DRAGDATA
typedef struct tagClipboardInfo | ClipboardInfo
typedef struct tagADUI_DRAGDATA * | PADUI_DRAGDATA

Enumerations

enum | { SECURITYPARAMS_ENCRYPT_DATA = 0x00000001, SECURITYPARAMS_ENCRYPT_PROPS = 0x00000002, SECURITYPARAMS_SIGN_DATA = 0x00000010, SECURITYPARAMS_ADD_TIMESTAMP = 0x00000020 }
enum | { SECURITYPARAMS_ALGID_RC4 = 0x00006801 }
enum | { eGood, eBad }
enum | AcGeIntersectError { kXXOk, kXXIndexOutOfRange, kXXWrongDimensionAtIndex, kXXUnknown }
enum AcGeXConfig {
kNotDefined = 1 << 0, kUnknown = 1 << 1, kLeftRight = 1 << 2, kRightLeft = 1 << 3,
kLeftLeft = 1 << 4, kRightRight = 1 << 5, kPointLeft = 1 << 6, kPointRight = 1 << 7,
kLeftOverlap = 1 << 8, kOverlapLeft = 1 << 9, kRightOverlap = 1 << 10, kOverlapRight = 1 << 11,
kOverlapStart = 1 << 12, kOverlapEnd = 1 << 13, kOverlapOverlap = 1 << 14
}
enum | BooleanType { kUnion, kSubtract, kCommon }
enum ClipCondition {
kInvalid, kAllSegmentsInside, kSegmentsIntersect, kAllSegmentsOutsideZeroWinds,
kAllSegmentsOutsideOddWinds, kAllSegmentsOutsideEvenWinds
}
enum | ClipError { eOk, eInvalidClipBoundary, eNotInitialized }
enum csiConfig {
kXUnknown, kXOut, kXIn, kXTanOut,
kXTanIn, kXCoincident, kXCoincidentUnbounded
}
enum | eClipInfoFlags { kbDragGeometry = 0x01 }
enum eExpandedClipDataTypes {
kDcPlotStyles = 1, kDcXrefs = 2, kDcLayouts = 3, kDcBlocks = 4,
kDcLayers = 5, kDcDrawings = 6, kDcLinetypes = 7, kDcTextStyles = 8,
kDcDimStyles = 9, kDcBlocksWithAttdef = 10, kDcHatches = 11, kTpXrefs = 12,
kTpImages = 13, kTpTable = 14, kDcTableStyles = 15
}
enum EntityId {
kEntity2d, kEntity3d, kPointEnt2d, kPointEnt3d,
kPosition2d, kPosition3d, kPointOnCurve2d, kPointOnCurve3d,
kPointOnSurface, kBoundedPlane, kCircArc2d, kCircArc3d,
kConic2d, kConic3d, kCurve2d, kCurve3d,
kEllipArc2d, kEllipArc3d, kLine2d, kLine3d,
kLinearEnt2d, kLinearEnt3d, kLineSeg2d, kLineSeg3d,
kPlanarEnt, kPlane, kRay2d, kRay3d,
kSurface, kSphere, kCylinder, kTorus,
kCone, kSplineEnt2d, kPolyline2d, kAugPolyline2d,
kNurbCurve2d, kDSpline2d, kCubicSplineCurve2d, kSplineEnt3d,
kPolyline3d, kAugPolyline3d, kNurbCurve3d, kDSpline3d,
kCubicSplineCurve3d, kTrimmedCrv2d, kCompositeCrv2d, kCompositeCrv3d,
kExternalSurface, kNurbSurface, kTrimmedSurface, kOffsetSurface,
kEnvelope2d, kCurveBoundedSurface, kExternalCurve3d, kExternalCurve2d,
kSurfaceCurve2dTo3d, kSurfaceCurve3dTo2d, kExternalBoundedSurface, kCurveCurveInt2d,
kCurveCurveInt3d, kBoundBlock2d, kBoundBlock3d, kOffsetCurve2d,
kOffsetCurve3d, kPolynomCurve3d, kBezierCurve3d, kObject,
kFitData3d, kHatch, kTrimmedCurve2d, kTrimmedCurve3d,
kCurveSampleData, kEllipCone, kEllipCylinder, kIntervalBoundBlock,
kClipBoundary2d, kExternalObject, kCurveSurfaceInt, kSurfaceSurfaceInt,
kHelix
}
enum ErrorCondition {
kOk, k0This, k0Arg1, k0Arg2,
kPerpendicularArg1Arg2, kEqualArg1Arg2, kEqualArg1Arg3, kEqualArg2Arg3,
kLinearlyDependentArg1Arg2Arg3, kArg1TooBig, kArg1OnThis, kArg1InsideThis
}
enum | eXrefType { kXrefTypeAttach = 1, kXrefTypeOverlay = 2 }
enum | ExternalEntityKind { kAcisEntity = 0, kExternalEntityUndefined }
enum KnotParameterization {
kChord = 0, kSqrtChord, kUniform, kCustomParameterization = 15,
kNotDefinedKnotParam = 16
}
enum NurbSurfaceProperties {
kOpen = 0x01, kClosed = 0x02, kPeriodic = 0x04, kRational = 0x08,
kNoPoles = 0x10, kPoleAtMin = 0x20, kPoleAtMax = 0x40, kPoleAtBoth = 0x80
}
enum | OffsetCrvExtType { kFillet, kChamfer, kExtend }
enum | PointContainment { kInside, kOutside, kOnBoundary }
enum SelectorType {
SELECT_TYPE_FREE = 0, SELECT_TYPE_PICK, SELECT_TYPE_WPOLY, SELECT_TYPE_CPOLY,
SELECT_TYPE_FENCE, SELECT_TYPE_SUBENTITY, SELECT_TYPE_BAG, SELECT_TYPE_LAST,
SELECT_TYPE_LEAF, SELECT_TYPE_GROUP, SELECT_TYPE_PASTE, SELECT_TYPE_HATCHASC,
SELECT_TYPE_NRVP, SELECT_TYPE_OCCLASS
}
enum | ssiConfig { kSSIUnknown, kSSIOut, kSSIIn, kSSICoincident }
enum | ssiType { kSSITransverse, kSSITangent, kSSIAntiTangent }

Variables

static const AcGeLibVersion | AcGe::gLibVersion
const int | nBlockFileSize = 260

Detailed Description


ZRX API Reference: _OPM_DYNPROP_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
_OPM_DYNPROP_ENTRY Struct Reference
Structs

Public Attributes

AcRxClass * | pClass
const CLSID * | pclsid
_ATL_CREATORFUNC * | pfnCreateInstance
IDynamicProperty * | pProp
IPropertySource * | pPropSrc
const ACHAR * | strCmd
The documentation for this struct was generated from the following file:
  • dynpropmgr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
_OPM_DYNPROP_ENTRY Member List

This is the complete list of members for _OPM_DYNPROP_ENTRY, including all inherited members.

pClass (defined in _OPM_DYNPROP_ENTRY) | _OPM_DYNPROP_ENTRY
pclsid (defined in _OPM_DYNPROP_ENTRY) | _OPM_DYNPROP_ENTRY
pfnCreateInstance (defined in _OPM_DYNPROP_ENTRY) | _OPM_DYNPROP_ENTRY
pProp (defined in _OPM_DYNPROP_ENTRY) | _OPM_DYNPROP_ENTRY
pPropSrc (defined in _OPM_DYNPROP_ENTRY) | _OPM_DYNPROP_ENTRY
strCmd (defined in _OPM_DYNPROP_ENTRY) | _OPM_DYNPROP_ENTRY


ZRX API Reference: Acad Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
Acad Struct Reference
Structs

Public Types

enum ErrorStatus {
eOk = 0, eNotImplementedYet = 1, eNotApplicable = 2, eInvalidInput = 3,
eAmbiguousInput = 4, eAmbiguousOutput = 5, eOutOfMemory = 6, eBufferTooSmall = 7,
eInvalidOpenState = 8, eEntityInInactiveLayout = 9, eHandleExists = 10, eNullHandle = 11,
eBrokenHandle = 12, eUnknownHandle = 13, eHandleInUse = 14, eNullObjectPointer = 15,
eNullObjectId = 16, eNullBlockName = 17, eContainerNotEmpty = 18, eNullEntityPointer = 20,
eIllegalEntityType = 21, eKeyNotFound = 22, eDuplicateKey = 23, eInvalidIndex = 24,
eDuplicateIndex = 25, eAlreadyInDb = 26, eOutOfDisk = 27, eDeletedEntry = 28,
eNegativeValueNotAllowed = 29, eInvalidExtents = 30, eInvalidAdsName = 31, eInvalidSymbolTableName = 32,
eInvalidKey = 33, eWrongObjectType = 34, eWrongDatabase = 35, eObjectToBeDeleted = 36,
eInvalidDwgVersion = 37, eAnonymousEntry = 38, eIllegalReplacement = 39, eEndOfObject = 40,
eEndOfFile = 41, eIsReading = 42, eIsWriting = 43, eNotOpenForRead = 44,
eNotOpenForWrite = 45, eNotThatKindOfClass = 46, eInvalidBlockName = 47, eMissingDxfField = 48,
eDuplicateDxfField = 49, eInvalidDxfCode = 50, eInvalidResBuf = 51, eBadDxfSequence = 52,
eFilerError = 53, eVertexAfterFace = 54, eInvalidFaceVertexIndex = 55, eInvalidMeshVertexIndex = 56,
eOtherObjectsBusy = 57, eMustFirstAddBlockToDb = 58, eCannotNestBlockDefs = 59, eDwgRecoveredOK = 60,
eDwgNotRecoverable = 61, eDxfPartiallyRead = 62, eDxfReadAborted = 63, eDxbPartiallyRead = 64,
eDwgCRCDoesNotMatch = 65, eDwgSentinelDoesNotMatch = 66, eDwgObjectImproperlyRead = 67, eNoInputFiler = 68,
eDwgNeedsAFullSave = 69, eDxbReadAborted = 70, eFileLockedByACAD = 71, eFileAccessErr = 72,
eFileSystemErr = 73, eFileInternalErr = 74, eFileTooManyOpen = 75, eFileNotFound = 76,
eDwkLockFileFound = 77, eWasErased = 80, ePermanentlyErased = 81, eWasOpenForRead = 82,
eWasOpenForWrite = 83, eWasOpenForUndo = 84, eWasNotifying = 85, eWasOpenForNotify = 86,
eOnLockedLayer = 87, eMustOpenThruOwner = 88, eSubentitiesStillOpen = 89, eAtMaxReaders = 90,
eIsWriteProtected = 91, eIsXRefObject = 92, eNotAnEntity = 93, eHadMultipleReaders = 94,
eDuplicateRecordName = 95, eXRefDependent = 96, eSelfReference = 97, eMissingSymbolTable = 98,
eMissingSymbolTableRec = 99, eWasNotOpenForWrite = 100, eCloseWasNotifying = 101, eCloseModifyAborted = 102,
eClosePartialFailure = 103, eCloseFailObjectDamaged = 104, eCannotBeErasedByCaller = 105, eCannotBeResurrected = 106,
eWasNotErased = 107, eInsertAfter = 110, eFixedAllErrors = 120, eLeftErrorsUnfixed = 122,
eUnrecoverableErrors = 123, eNoDatabase = 124, eXdataSizeExceeded = 125, eRegappIdNotFound = 126,
eRepeatEntity = 127, eRecordNotInTable = 128, eIteratorDone = 129, eNullIterator = 130,
eNotInBlock = 131, eOwnerNotInDatabase = 132, eOwnerNotOpenForRead = 133, eOwnerNotOpenForWrite = 134,
eExplodeBeforeTransform = 135, eCannotScaleNonUniformly = 136, eNotInDatabase = 137, eNotCurrentDatabase = 138,
eIsAnEntity = 139, eCannotChangeActiveViewport = 140, eNotInPaperspace = 141, eCommandWasInProgress = 142,
eGeneralModelingFailure = 150, eOutOfRange = 151, eNonCoplanarGeometry = 152, eDegenerateGeometry = 153,
eInvalidAxis = 154, ePointNotOnEntity = 155, eSingularPoint = 156, eInvalidOffset = 157,
eNonPlanarEntity = 158, eCannotExplodeEntity = 159, eStringTooLong = 160, eInvalidSymTableFlag = 161,
eUndefinedLineType = 162, eInvalidTextStyle = 163, eTooFewLineTypeElements = 164, eTooManyLineTypeElements = 165,
eExcessiveItemCount = 166, eIgnoredLinetypeRedef = 167, eBadUCS = 168, eBadPaperspaceView = 169,
eSomeInputDataLeftUnread = 170, eNoInternalSpace = 171, eInvalidDimStyle = 172, eInvalidLayer = 173,
eUserBreak = 180, eUserUnloaded = 181, eDwgNeedsRecovery = 190, eDeleteEntity = 191,
eInvalidFix = 192, eFSMError = 193, eBadLayerName = 200, eLayerGroupCodeMissing = 201,
eBadColorIndex = 202, eBadLinetypeName = 203, eBadLinetypeScale = 204, eBadVisibilityValue = 205,
eProperClassSeparatorExpected = 206, eBadLineWeightValue = 207, eBadColor = 208, eBadMaterialName = 209,
ePagerError = 210, eOutOfPagerMemory = 211, ePagerWriteError = 212, eWasNotForwarding = 213,
eInvalidIdMap = 220, eInvalidOwnerObject = 221, eOwnerNotSet = 222, eWrongSubentityType = 230,
eTooManyVertices = 231, eTooFewVertices = 232, eNoActiveTransactions = 250, eNotTopTransaction = 251,
eTransactionOpenWhileCommandEnded = 252, eInProcessOfCommitting = 253, eNotNewlyCreated = 254, eLongTransReferenceError = 255,
eNoWorkSet = 256, eAlreadyInGroup = 260, eNotInGroup = 261, eInvalidREFIID = 290,
eInvalidNormal = 291, eInvalidStyle = 292, eCannotRestoreFromAcisFile = 300, eMakeMeProxy = 301,
eNLSFileNotAvailable = 302, eNotAllowedForThisProxy = 303, eNotClonedPrimaryProxy = 304, eNotSupportedInDwgApi = 310,
ePolyWidthLost = 311, eNullExtents = 312, eExplodeAgain = 313, eBadDwgHeader = 314,
eLockViolation = 320, eLockConflict = 321, eDatabaseObjectsOpen = 322, eLockChangeInProgress = 323,
eVetoed = 325, eNoDocument = 330, eNotFromThisDocument = 331, eLISPActive = 332,
eTargetDocNotQuiescent = 333, eDocumentSwitchDisabled = 334, eInvalidContext = 335, eCreateFailed = 337,
eCreateInvalidName = 338, eSetFailed = 340, eDelDoesNotExist = 342, eDelIsModelSpace = 343,
eDelLastLayout = 344, eDelUnableToSetCurrent = 345, eDelUnableToFind = 346, eRenameDoesNotExist = 348,
eRenameIsModelSpace = 349, eRenameInvalidLayoutName = 350, eRenameLayoutAlreadyExists = 351, eRenameInvalidName = 352,
eCopyDoesNotExist = 354, eCopyIsModelSpace = 355, eCopyFailed = 356, eCopyInvalidName = 357,
eCopyNameExists = 358, eProfileDoesNotExist = 359, eInvalidFileExtension = 360, eInvalidProfileName = 361,
eFileExists = 362, eProfileIsInUse = 363, eCantOpenFile = 364, eNoFileName = 365,
eRegistryAccessError = 366, eRegistryCreateError = 367, eBadDxfFile = 368, eUnknownDxfFileFormat = 369,
eMissingDxfSection = 370, eInvalidDxfSectionName = 371, eNotDxfHeaderGroupCode = 372, eUndefinedDxfGroupCode = 373,
eNotInitializedYet = 374, eInvalidDxf2dPoint = 375, eInvalidDxf3dPoint = 376, eBadlyNestedAppData = 378,
eIncompleteBlockDefinition = 379, eIncompleteComplexObject = 380, eBlockDefInEntitySection = 381, eNoBlockBegin = 382,
eDuplicateLayerName = 383, eBadPlotStyleName = 384, eDuplicateBlockName = 385, eBadPlotStyleType = 386,
eBadPlotStyleNameHandle = 387, eUndefineShapeName = 388, eDuplicateBlockDefinition = 389, eMissingBlockName = 390,
eBinaryDataSizeExceeded = 391, eObjectIsReferenced = 392, eNoThumbnailBitmap = 393, eGuidNoAddress = 394,
eMustBe0to2 = 395, eMustBe0to3 = 396, eMustBe0to4 = 397, eMustBe0to5 = 398,
eMustBe0to8 = 399, eMustBe1to8 = 400, eMustBe1to15 = 401, eMustBePositive = 402,
eMustBeNonNegative = 403, eMustBeNonZero = 404, eMustBe1to6 = 405, eNoPlotStyleTranslationTable = 406,
ePlotStyleInColorDependentMode = 407, eMaxLayouts = 408, eNoClassId = 409, eUndoOperationNotAvailable = 410,
eUndoNoGroupBegin = 411, eHatchTooDense = 420, eOpenFileCancelled = 430, eNotHandled = 431,
eMakeMeProxyAndResurrect = 432, eFileSharingViolation = 433, eUnsupportedFileFormat = 434, eObsoleteFileFormat = 435,
eFileMissingSections = 436, eRepeatedDwgRead = 437, eWrongCellType = 440, eCannotChangeColumnType = 441,
eRowsMustMatchColumns = 442, eNullNodeId = 450, eNoNodeActive = 451, eGraphContainsProxies = 452,
eDwgShareDemandLoad = 500, eDwgShareReadAccess = 501, eDwgShareWriteAccess = 502, eLoadFailed = 503,
eDeviceNotFound = 504, eNoCurrentConfig = 505, eNullPtr = 506, eNoLayout = 507,
eIncompatiblePlotSettings = 508, eNonePlotDevice = 509, eNoMatchingMedia = 510, eInvalidView = 511,
eInvalidWindowArea = 512, eInvalidPlotArea = 513, eCustomSizeNotPossible = 514, ePageCancelled = 515,
ePlotCancelled = 516, eInvalidEngineState = 517, ePlotAlreadyStarted = 518, eNoErrorHandler = 519,
eInvalidPlotInfo = 520, eNumberOfCopiesNotSupported = 521, eLayoutNotCurrent = 522, eGraphicsNotGenerated = 523,
eCannotPlotToFile = 524, eMustPlotToFile = 525, eNotMultiPageCapable = 526, eBackgroundPlotInProgress = 527,
eNotShownInPropertyPalette = 528, eSubSelectionSetEmpty = 550, eNoIntersections = 551, eEmbeddedIntersections = 552,
eNoOverride = 570, eNoStoredOverrides = 571, eUnableToRetrieveOverrides = 572, eUnableToStoreOverrides = 573,
eUnableToRemoveOverrides = 574, eNoStoredReconcileStatus = 580, eUnableToStoreReconcileStatus = 581, eInvalidObjectId = 600,
eInvalidXrefObjectId = 601, eNoViewAssociation = 602, eNoLabelBlock = 603, eUnableToSetViewAssociation = 604,
eUnableToGetViewAssociation = 605, eUnableToSetLabelBlock = 606, eUnableToGetLabelBlock = 607, eUnableToRemoveAssociation = 608,
eUnableToSyncModelView = 609, eDataLinkAdapterNotFound = 650, eDataLinkInvalidAdapterId = 651, eDataLinkNotFound = 652,
eDataLinkBadConnectionString = 653, eDataLinkNotUpdatedYet = 654, eDataLinkSourceNotFound = 655, eDataLinkConnectionFailed = 656,
eDataLinkSourceUpdateNotAllowed = 657, eDataLinkSourceIsWriteProtected = 658, eDataLinkExcelNotFound = 659, eDataLinkOtherError = 660,
eXrefReloaded = 700, eSecInitializationFailure = 1001, eSecErrorReadingFile = 1002, eSecErrorWritingFile = 1003,
eSecInvalidDigitalID = 1101, eSecErrorGeneratingTimestamp = 1102, eSecErrorComputingSignature = 1103, eSecErrorWritingSignature = 1104,
eSecErrorEncryptingData = 1201, eSecErrorCipherNotSupported = 1202, eSecErrorDecryptingData = 1203, eNoAcDbHostApplication = 1300,
eNoUnderlayHost = 1301, eInetBase = 20000, eInetOk = eInetBase, eInetInCache,
eInetFileNotFound, eInetBadPath, eInetTooManyOpenFiles, eInetFileAccessDenied,
eInetInvalidFileHandle, eInetDirectoryFull, eInetHardwareError, eInetSharingViolation,
eInetDiskFull, eInetFileGenericError, eInetValidURL, eInetNotAnURL,
eInetNoWinInet, eInetOldWinInet, eInetNoAcadInet, eInetNotImplemented,
eInetProtocolNotSupported, eInetCreateInternetSessionFailed, eInetInternetSessionConnectFailed, eInetInternetSessionOpenFailed,
eInetInvalidAccessType, eInetFileOpenFailed, eInetHttpOpenRequestFailed, eInetUserCancelledTransfer,
eInetHttpBadRequest, eInetHttpAccessDenied, eInetHttpPaymentRequired, eInetHttpRequestForbidden,
eInetHttpObjectNotFound, eInetHttpBadMethod, eInetHttpNoAcceptableResponse, eInetHttpProxyAuthorizationRequired,
eInetHttpTimedOut, eInetHttpConflict, eInetHttpResourceGone, eInetHttpLengthRequired,
eInetHttpPreconditionFailure, eInetHttpRequestTooLarge, eInetHttpUriTooLong, eInetHttpUnsupportedMedia,
eInetHttpServerError, eInetHttpNotSupported, eInetHttpBadGateway, eInetHttpServiceUnavailable,
eInetHttpGatewayTimeout, eInetHttpVersionNotSupported, eInetInternetError, eInetGenericException,
eInetUnknownError, eAlreadyActive, eAlreadyInactive, eGraphEdgeNotFound,
eGraphNodeNotFound, eGraphNodeAlreadyExists, eGraphEdgeAlreadyExists, eGraphCyclesFound,
eAlreadyHasRepresentation, eNoRepresentation, eFailedToSetEdgeChamfers, eNoConnectedBlendSet,
eFailedToBlend, eFailedToSetEdgeRounds, eFailedToSetVertexRounds, eVSNotFound,
eVSTrue, eVSFalse, eVSAlreadyExists, eVSOneOffCreated,
eVSAPIOnlyValues, eVSIsInUse, eVSIsAcadDefault, eEmptyOperand,
eNoEntitiesFromPersistentIds, eFailedCurveCheck, eMaxNodes
}
enum PointHistory {
eTablet = 0x0001, eNotDigitizer = 0x0002, eLastPt = 0x0004, eGripped = 0x008,
eCartSnapped = 0x0010, eOrtho = 0x0020, eCyclingPt = 0x0040, eOsnapped = 0x0080,
ePolarAngle = 0x0100, eAligned = 0x0400, eAppFiltered = 0x0800, eForcedPick = 0x1000,
ePickMask = 0xE000, eDidNotPick = 0x0000, eUsedPickBox = 0x2000, eUsedOsnapBox = 0x4000,
ePickAborted = 0x8000, eXPending = 0x10000, eYPending = 0x20000, eZPending = 0x40000,
eCoordPending, eFromKeyboard, eNotInteractive
}
enum PromptStatus {
eNone = 5000, eNormal = 5100, eError = -5001, eCancel = -5002,
eRejected = -5003, eFailed = -5004, eKeyword = -5005, eDirect = -5999
}
The documentation for this struct was generated from the following file:
  • acadstrc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Acad Member List

This is the complete list of members for Acad, including all inherited members.

eAligned enum value (defined in Acad) | Acad
eAlreadyActive enum value (defined in Acad) | Acad
eAlreadyHasRepresentation enum value (defined in Acad) | Acad
eAlreadyInactive enum value (defined in Acad) | Acad
eAlreadyInDb enum value (defined in Acad) | Acad
eAlreadyInGroup enum value (defined in Acad) | Acad
eAmbiguousInput enum value (defined in Acad) | Acad
eAmbiguousOutput enum value (defined in Acad) | Acad
eAnonymousEntry enum value (defined in Acad) | Acad
eAppFiltered enum value (defined in Acad) | Acad
eAtMaxReaders enum value (defined in Acad) | Acad
eBackgroundPlotInProgress enum value (defined in Acad) | Acad
eBadColor enum value (defined in Acad) | Acad
eBadColorIndex enum value (defined in Acad) | Acad
eBadDwgHeader enum value (defined in Acad) | Acad
eBadDxfFile enum value (defined in Acad) | Acad
eBadDxfSequence enum value (defined in Acad) | Acad
eBadLayerName enum value (defined in Acad) | Acad
eBadLinetypeName enum value (defined in Acad) | Acad
eBadLinetypeScale enum value (defined in Acad) | Acad
eBadLineWeightValue enum value (defined in Acad) | Acad
eBadlyNestedAppData enum value (defined in Acad) | Acad
eBadMaterialName enum value (defined in Acad) | Acad
eBadPaperspaceView enum value (defined in Acad) | Acad
eBadPlotStyleName enum value (defined in Acad) | Acad
eBadPlotStyleNameHandle enum value (defined in Acad) | Acad
eBadPlotStyleType enum value (defined in Acad) | Acad
eBadUCS enum value (defined in Acad) | Acad
eBadVisibilityValue enum value (defined in Acad) | Acad
eBinaryDataSizeExceeded enum value (defined in Acad) | Acad
eBlockDefInEntitySection enum value (defined in Acad) | Acad
eBrokenHandle enum value (defined in Acad) | Acad
eBufferTooSmall enum value (defined in Acad) | Acad
eCancel enum value (defined in Acad) | Acad
eCannotBeErasedByCaller enum value (defined in Acad) | Acad
eCannotBeResurrected enum value (defined in Acad) | Acad
eCannotChangeActiveViewport enum value (defined in Acad) | Acad
eCannotChangeColumnType enum value (defined in Acad) | Acad
eCannotExplodeEntity enum value (defined in Acad) | Acad
eCannotNestBlockDefs enum value (defined in Acad) | Acad
eCannotPlotToFile enum value (defined in Acad) | Acad
eCannotRestoreFromAcisFile enum value (defined in Acad) | Acad
eCannotScaleNonUniformly enum value (defined in Acad) | Acad
eCantOpenFile enum value (defined in Acad) | Acad
eCartSnapped enum value (defined in Acad) | Acad
eCloseFailObjectDamaged enum value (defined in Acad) | Acad
eCloseModifyAborted enum value (defined in Acad) | Acad
eClosePartialFailure enum value (defined in Acad) | Acad
eCloseWasNotifying enum value (defined in Acad) | Acad
eCommandWasInProgress enum value (defined in Acad) | Acad
eContainerNotEmpty enum value (defined in Acad) | Acad
eCoordPending enum value (defined in Acad) | Acad
eCopyDoesNotExist enum value (defined in Acad) | Acad
eCopyFailed enum value (defined in Acad) | Acad
eCopyInvalidName enum value (defined in Acad) | Acad
eCopyIsModelSpace enum value (defined in Acad) | Acad
eCopyNameExists enum value (defined in Acad) | Acad
eCreateFailed enum value (defined in Acad) | Acad
eCreateInvalidName enum value (defined in Acad) | Acad
eCustomSizeNotPossible enum value (defined in Acad) | Acad
eCyclingPt enum value (defined in Acad) | Acad
eDatabaseObjectsOpen enum value (defined in Acad) | Acad
eDataLinkAdapterNotFound enum value (defined in Acad) | Acad
eDataLinkBadConnectionString enum value (defined in Acad) | Acad
eDataLinkConnectionFailed enum value (defined in Acad) | Acad
eDataLinkExcelNotFound enum value (defined in Acad) | Acad
eDataLinkInvalidAdapterId enum value (defined in Acad) | Acad
eDataLinkNotFound enum value (defined in Acad) | Acad
eDataLinkNotUpdatedYet enum value (defined in Acad) | Acad
eDataLinkOtherError enum value (defined in Acad) | Acad
eDataLinkSourceIsWriteProtected enum value (defined in Acad) | Acad
eDataLinkSourceNotFound enum value (defined in Acad) | Acad
eDataLinkSourceUpdateNotAllowed enum value (defined in Acad) | Acad
eDegenerateGeometry enum value (defined in Acad) | Acad
eDelDoesNotExist enum value (defined in Acad) | Acad
eDeletedEntry enum value (defined in Acad) | Acad
eDeleteEntity enum value (defined in Acad) | Acad
eDelIsModelSpace enum value (defined in Acad) | Acad
eDelLastLayout enum value (defined in Acad) | Acad
eDelUnableToFind enum value (defined in Acad) | Acad
eDelUnableToSetCurrent enum value (defined in Acad) | Acad
eDeviceNotFound enum value (defined in Acad) | Acad
eDidNotPick enum value (defined in Acad) | Acad
eDirect enum value (defined in Acad) | Acad
eDocumentSwitchDisabled enum value (defined in Acad) | Acad
eDuplicateBlockDefinition enum value (defined in Acad) | Acad
eDuplicateBlockName enum value (defined in Acad) | Acad
eDuplicateDxfField enum value (defined in Acad) | Acad
eDuplicateIndex enum value (defined in Acad) | Acad
eDuplicateKey enum value (defined in Acad) | Acad
eDuplicateLayerName enum value (defined in Acad) | Acad
eDuplicateRecordName enum value (defined in Acad) | Acad
eDwgCRCDoesNotMatch enum value (defined in Acad) | Acad
eDwgNeedsAFullSave enum value (defined in Acad) | Acad
eDwgNeedsRecovery enum value (defined in Acad) | Acad
eDwgNotRecoverable enum value (defined in Acad) | Acad
eDwgObjectImproperlyRead enum value (defined in Acad) | Acad
eDwgRecoveredOK enum value (defined in Acad) | Acad
eDwgSentinelDoesNotMatch enum value (defined in Acad) | Acad
eDwgShareDemandLoad enum value (defined in Acad) | Acad
eDwgShareReadAccess enum value (defined in Acad) | Acad
eDwgShareWriteAccess enum value (defined in Acad) | Acad
eDwkLockFileFound enum value (defined in Acad) | Acad
eDxbPartiallyRead enum value (defined in Acad) | Acad
eDxbReadAborted enum value (defined in Acad) | Acad
eDxfPartiallyRead enum value (defined in Acad) | Acad
eDxfReadAborted enum value (defined in Acad) | Acad
eEmbeddedIntersections enum value (defined in Acad) | Acad
eEmptyOperand enum value (defined in Acad) | Acad
eEndOfFile enum value (defined in Acad) | Acad
eEndOfObject enum value (defined in Acad) | Acad
eEntityInInactiveLayout enum value (defined in Acad) | Acad
eError enum value (defined in Acad) | Acad
eExcessiveItemCount enum value (defined in Acad) | Acad
eExplodeAgain enum value (defined in Acad) | Acad
eExplodeBeforeTransform enum value (defined in Acad) | Acad
eFailed enum value (defined in Acad) | Acad
eFailedCurveCheck enum value (defined in Acad) | Acad
eFailedToBlend enum value (defined in Acad) | Acad
eFailedToSetEdgeChamfers enum value (defined in Acad) | Acad
eFailedToSetEdgeRounds enum value (defined in Acad) | Acad
eFailedToSetVertexRounds enum value (defined in Acad) | Acad
eFileAccessErr enum value (defined in Acad) | Acad
eFileExists enum value (defined in Acad) | Acad
eFileInternalErr enum value (defined in Acad) | Acad
eFileLockedByACAD enum value (defined in Acad) | Acad
eFileMissingSections enum value (defined in Acad) | Acad
eFileNotFound enum value (defined in Acad) | Acad
eFilerError enum value (defined in Acad) | Acad
eFileSharingViolation enum value (defined in Acad) | Acad
eFileSystemErr enum value (defined in Acad) | Acad
eFileTooManyOpen enum value (defined in Acad) | Acad
eFixedAllErrors enum value (defined in Acad) | Acad
eForcedPick enum value (defined in Acad) | Acad
eFromKeyboard enum value (defined in Acad) | Acad
eFSMError enum value (defined in Acad) | Acad
eGeneralModelingFailure enum value (defined in Acad) | Acad
eGraphContainsProxies enum value (defined in Acad) | Acad
eGraphCyclesFound enum value (defined in Acad) | Acad
eGraphEdgeAlreadyExists enum value (defined in Acad) | Acad
eGraphEdgeNotFound enum value (defined in Acad) | Acad
eGraphicsNotGenerated enum value (defined in Acad) | Acad
eGraphNodeAlreadyExists enum value (defined in Acad) | Acad
eGraphNodeNotFound enum value (defined in Acad) | Acad
eGripped enum value (defined in Acad) | Acad
eGuidNoAddress enum value (defined in Acad) | Acad
eHadMultipleReaders enum value (defined in Acad) | Acad
eHandleExists enum value (defined in Acad) | Acad
eHandleInUse enum value (defined in Acad) | Acad
eHatchTooDense enum value (defined in Acad) | Acad
eIgnoredLinetypeRedef enum value (defined in Acad) | Acad
eIllegalEntityType enum value (defined in Acad) | Acad
eIllegalReplacement enum value (defined in Acad) | Acad
eIncompatiblePlotSettings enum value (defined in Acad) | Acad
eIncompleteBlockDefinition enum value (defined in Acad) | Acad
eIncompleteComplexObject enum value (defined in Acad) | Acad
eInetBadPath enum value (defined in Acad) | Acad
eInetBase enum value (defined in Acad) | Acad
eInetCreateInternetSessionFailed enum value (defined in Acad) | Acad
eInetDirectoryFull enum value (defined in Acad) | Acad
eInetDiskFull enum value (defined in Acad) | Acad
eInetFileAccessDenied enum value (defined in Acad) | Acad
eInetFileGenericError enum value (defined in Acad) | Acad
eInetFileNotFound enum value (defined in Acad) | Acad
eInetFileOpenFailed enum value (defined in Acad) | Acad
eInetGenericException enum value (defined in Acad) | Acad
eInetHardwareError enum value (defined in Acad) | Acad
eInetHttpAccessDenied enum value (defined in Acad) | Acad
eInetHttpBadGateway enum value (defined in Acad) | Acad
eInetHttpBadMethod enum value (defined in Acad) | Acad
eInetHttpBadRequest enum value (defined in Acad) | Acad
eInetHttpConflict enum value (defined in Acad) | Acad
eInetHttpGatewayTimeout enum value (defined in Acad) | Acad
eInetHttpLengthRequired enum value (defined in Acad) | Acad
eInetHttpNoAcceptableResponse enum value (defined in Acad) | Acad
eInetHttpNotSupported enum value (defined in Acad) | Acad
eInetHttpObjectNotFound enum value (defined in Acad) | Acad
eInetHttpOpenRequestFailed enum value (defined in Acad) | Acad
eInetHttpPaymentRequired enum value (defined in Acad) | Acad
eInetHttpPreconditionFailure enum value (defined in Acad) | Acad
eInetHttpProxyAuthorizationRequired enum value (defined in Acad) | Acad
eInetHttpRequestForbidden enum value (defined in Acad) | Acad
eInetHttpRequestTooLarge enum value (defined in Acad) | Acad
eInetHttpResourceGone enum value (defined in Acad) | Acad
eInetHttpServerError enum value (defined in Acad) | Acad
eInetHttpServiceUnavailable enum value (defined in Acad) | Acad
eInetHttpTimedOut enum value (defined in Acad) | Acad
eInetHttpUnsupportedMedia enum value (defined in Acad) | Acad
eInetHttpUriTooLong enum value (defined in Acad) | Acad
eInetHttpVersionNotSupported enum value (defined in Acad) | Acad
eInetInCache enum value (defined in Acad) | Acad
eInetInternetError enum value (defined in Acad) | Acad
eInetInternetSessionConnectFailed enum value (defined in Acad) | Acad
eInetInternetSessionOpenFailed enum value (defined in Acad) | Acad
eInetInvalidAccessType enum value (defined in Acad) | Acad
eInetInvalidFileHandle enum value (defined in Acad) | Acad
eInetNoAcadInet enum value (defined in Acad) | Acad
eInetNotAnURL enum value (defined in Acad) | Acad
eInetNotImplemented enum value (defined in Acad) | Acad
eInetNoWinInet enum value (defined in Acad) | Acad
eInetOk enum value (defined in Acad) | Acad
eInetOldWinInet enum value (defined in Acad) | Acad
eInetProtocolNotSupported enum value (defined in Acad) | Acad
eInetSharingViolation enum value (defined in Acad) | Acad
eInetTooManyOpenFiles enum value (defined in Acad) | Acad
eInetUnknownError enum value (defined in Acad) | Acad
eInetUserCancelledTransfer enum value (defined in Acad) | Acad
eInetValidURL enum value (defined in Acad) | Acad
eInProcessOfCommitting enum value (defined in Acad) | Acad
eInsertAfter enum value (defined in Acad) | Acad
eInvalidAdsName enum value (defined in Acad) | Acad
eInvalidAxis enum value (defined in Acad) | Acad
eInvalidBlockName enum value (defined in Acad) | Acad
eInvalidContext enum value (defined in Acad) | Acad
eInvalidDimStyle enum value (defined in Acad) | Acad
eInvalidDwgVersion enum value (defined in Acad) | Acad
eInvalidDxf2dPoint enum value (defined in Acad) | Acad
eInvalidDxf3dPoint enum value (defined in Acad) | Acad
eInvalidDxfCode enum value (defined in Acad) | Acad
eInvalidDxfSectionName enum value (defined in Acad) | Acad
eInvalidEngineState enum value (defined in Acad) | Acad
eInvalidExtents enum value (defined in Acad) | Acad
eInvalidFaceVertexIndex enum value (defined in Acad) | Acad
eInvalidFileExtension enum value (defined in Acad) | Acad
eInvalidFix enum value (defined in Acad) | Acad
eInvalidIdMap enum value (defined in Acad) | Acad
eInvalidIndex enum value (defined in Acad) | Acad
eInvalidInput enum value (defined in Acad) | Acad
eInvalidKey enum value (defined in Acad) | Acad
eInvalidLayer enum value (defined in Acad) | Acad
eInvalidMeshVertexIndex enum value (defined in Acad) | Acad
eInvalidNormal enum value (defined in Acad) | Acad
eInvalidObjectId enum value (defined in Acad) | Acad
eInvalidOffset enum value (defined in Acad) | Acad
eInvalidOpenState enum value (defined in Acad) | Acad
eInvalidOwnerObject enum value (defined in Acad) | Acad
eInvalidPlotArea enum value (defined in Acad) | Acad
eInvalidPlotInfo enum value (defined in Acad) | Acad
eInvalidProfileName enum value (defined in Acad) | Acad
eInvalidREFIID enum value (defined in Acad) | Acad
eInvalidResBuf enum value (defined in Acad) | Acad
eInvalidStyle enum value (defined in Acad) | Acad
eInvalidSymbolTableName enum value (defined in Acad) | Acad
eInvalidSymTableFlag enum value (defined in Acad) | Acad
eInvalidTextStyle enum value (defined in Acad) | Acad
eInvalidView enum value (defined in Acad) | Acad
eInvalidWindowArea enum value (defined in Acad) | Acad
eInvalidXrefObjectId enum value (defined in Acad) | Acad
eIsAnEntity enum value (defined in Acad) | Acad
eIsReading enum value (defined in Acad) | Acad
eIsWriteProtected enum value (defined in Acad) | Acad
eIsWriting enum value (defined in Acad) | Acad
eIsXRefObject enum value (defined in Acad) | Acad
eIteratorDone enum value (defined in Acad) | Acad
eKeyNotFound enum value (defined in Acad) | Acad
eKeyword enum value (defined in Acad) | Acad
eLastPt enum value (defined in Acad) | Acad
eLayerGroupCodeMissing enum value (defined in Acad) | Acad
eLayoutNotCurrent enum value (defined in Acad) | Acad
eLeftErrorsUnfixed enum value (defined in Acad) | Acad
eLISPActive enum value (defined in Acad) | Acad
eLoadFailed enum value (defined in Acad) | Acad
eLockChangeInProgress enum value (defined in Acad) | Acad
eLockConflict enum value (defined in Acad) | Acad
eLockViolation enum value (defined in Acad) | Acad
eLongTransReferenceError enum value (defined in Acad) | Acad
eMakeMeProxy enum value (defined in Acad) | Acad
eMakeMeProxyAndResurrect enum value (defined in Acad) | Acad
eMaxLayouts enum value (defined in Acad) | Acad
eMaxNodes enum value (defined in Acad) | Acad
eMissingBlockName enum value (defined in Acad) | Acad
eMissingDxfField enum value (defined in Acad) | Acad
eMissingDxfSection enum value (defined in Acad) | Acad
eMissingSymbolTable enum value (defined in Acad) | Acad
eMissingSymbolTableRec enum value (defined in Acad) | Acad
eMustBe0to2 enum value (defined in Acad) | Acad
eMustBe0to3 enum value (defined in Acad) | Acad
eMustBe0to4 enum value (defined in Acad) | Acad
eMustBe0to5 enum value (defined in Acad) | Acad
eMustBe0to8 enum value (defined in Acad) | Acad
eMustBe1to15 enum value (defined in Acad) | Acad
eMustBe1to6 enum value (defined in Acad) | Acad
eMustBe1to8 enum value (defined in Acad) | Acad
eMustBeNonNegative enum value (defined in Acad) | Acad
eMustBeNonZero enum value (defined in Acad) | Acad
eMustBePositive enum value (defined in Acad) | Acad
eMustFirstAddBlockToDb enum value (defined in Acad) | Acad
eMustOpenThruOwner enum value (defined in Acad) | Acad
eMustPlotToFile enum value (defined in Acad) | Acad
eNegativeValueNotAllowed enum value (defined in Acad) | Acad
eNLSFileNotAvailable enum value (defined in Acad) | Acad
eNoAcDbHostApplication enum value (defined in Acad) | Acad
eNoActiveTransactions enum value (defined in Acad) | Acad
eNoBlockBegin enum value (defined in Acad) | Acad
eNoClassId enum value (defined in Acad) | Acad
eNoConnectedBlendSet enum value (defined in Acad) | Acad
eNoCurrentConfig enum value (defined in Acad) | Acad
eNoDatabase enum value (defined in Acad) | Acad
eNoDocument enum value (defined in Acad) | Acad
eNoEntitiesFromPersistentIds enum value (defined in Acad) | Acad
eNoErrorHandler enum value (defined in Acad) | Acad
eNoFileName enum value (defined in Acad) | Acad
eNoInputFiler enum value (defined in Acad) | Acad
eNoInternalSpace enum value (defined in Acad) | Acad
eNoIntersections enum value (defined in Acad) | Acad
eNoLabelBlock enum value (defined in Acad) | Acad
eNoLayout enum value (defined in Acad) | Acad
eNoMatchingMedia enum value (defined in Acad) | Acad
eNonCoplanarGeometry enum value (defined in Acad) | Acad
eNone enum value (defined in Acad) | Acad
eNonePlotDevice enum value (defined in Acad) | Acad
eNoNodeActive enum value (defined in Acad) | Acad
eNonPlanarEntity enum value (defined in Acad) | Acad
eNoOverride enum value (defined in Acad) | Acad
eNoPlotStyleTranslationTable enum value (defined in Acad) | Acad
eNoRepresentation enum value (defined in Acad) | Acad
eNormal enum value (defined in Acad) | Acad
eNoStoredOverrides enum value (defined in Acad) | Acad
eNoStoredReconcileStatus enum value (defined in Acad) | Acad
eNotAllowedForThisProxy enum value (defined in Acad) | Acad
eNotAnEntity enum value (defined in Acad) | Acad
eNotApplicable enum value (defined in Acad) | Acad
eNotClonedPrimaryProxy enum value (defined in Acad) | Acad
eNotCurrentDatabase enum value (defined in Acad) | Acad
eNotDigitizer enum value (defined in Acad) | Acad
eNotDxfHeaderGroupCode enum value (defined in Acad) | Acad
eNotFromThisDocument enum value (defined in Acad) | Acad
eNotHandled enum value (defined in Acad) | Acad
eNoThumbnailBitmap enum value (defined in Acad) | Acad
eNotImplementedYet enum value (defined in Acad) | Acad
eNotInBlock enum value (defined in Acad) | Acad
eNotInDatabase enum value (defined in Acad) | Acad
eNotInGroup enum value (defined in Acad) | Acad
eNotInitializedYet enum value (defined in Acad) | Acad
eNotInPaperspace enum value (defined in Acad) | Acad
eNotInteractive enum value (defined in Acad) | Acad
eNotMultiPageCapable enum value (defined in Acad) | Acad
eNotNewlyCreated enum value (defined in Acad) | Acad
eNotOpenForRead enum value (defined in Acad) | Acad
eNotOpenForWrite enum value (defined in Acad) | Acad
eNotShownInPropertyPalette enum value (defined in Acad) | Acad
eNotSupportedInDwgApi enum value (defined in Acad) | Acad
eNotThatKindOfClass enum value (defined in Acad) | Acad
eNotTopTransaction enum value (defined in Acad) | Acad
eNoUnderlayHost enum value (defined in Acad) | Acad
eNoViewAssociation enum value (defined in Acad) | Acad
eNoWorkSet enum value (defined in Acad) | Acad
eNullBlockName enum value (defined in Acad) | Acad
eNullEntityPointer enum value (defined in Acad) | Acad
eNullExtents enum value (defined in Acad) | Acad
eNullHandle enum value (defined in Acad) | Acad
eNullIterator enum value (defined in Acad) | Acad
eNullNodeId enum value (defined in Acad) | Acad
eNullObjectId enum value (defined in Acad) | Acad
eNullObjectPointer enum value (defined in Acad) | Acad
eNullPtr enum value (defined in Acad) | Acad
eNumberOfCopiesNotSupported enum value (defined in Acad) | Acad
eObjectIsReferenced enum value (defined in Acad) | Acad
eObjectToBeDeleted enum value (defined in Acad) | Acad
eObsoleteFileFormat enum value (defined in Acad) | Acad
eOk enum value (defined in Acad) | Acad
eOnLockedLayer enum value (defined in Acad) | Acad
eOpenFileCancelled enum value (defined in Acad) | Acad
eOrtho enum value (defined in Acad) | Acad
eOsnapped enum value (defined in Acad) | Acad
eOtherObjectsBusy enum value (defined in Acad) | Acad
eOutOfDisk enum value (defined in Acad) | Acad
eOutOfMemory enum value (defined in Acad) | Acad
eOutOfPagerMemory enum value (defined in Acad) | Acad
eOutOfRange enum value (defined in Acad) | Acad
eOwnerNotInDatabase enum value (defined in Acad) | Acad
eOwnerNotOpenForRead enum value (defined in Acad) | Acad
eOwnerNotOpenForWrite enum value (defined in Acad) | Acad
eOwnerNotSet enum value (defined in Acad) | Acad
ePageCancelled enum value (defined in Acad) | Acad
ePagerError enum value (defined in Acad) | Acad
ePagerWriteError enum value (defined in Acad) | Acad
ePermanentlyErased enum value (defined in Acad) | Acad
ePickAborted enum value (defined in Acad) | Acad
ePickMask enum value (defined in Acad) | Acad
ePlotAlreadyStarted enum value (defined in Acad) | Acad
ePlotCancelled enum value (defined in Acad) | Acad
ePlotStyleInColorDependentMode enum value (defined in Acad) | Acad
ePointNotOnEntity enum value (defined in Acad) | Acad
ePolarAngle enum value (defined in Acad) | Acad
ePolyWidthLost enum value (defined in Acad) | Acad
eProfileDoesNotExist enum value (defined in Acad) | Acad
eProfileIsInUse enum value (defined in Acad) | Acad
eProperClassSeparatorExpected enum value (defined in Acad) | Acad
eRecordNotInTable enum value (defined in Acad) | Acad
eRegappIdNotFound enum value (defined in Acad) | Acad
eRegistryAccessError enum value (defined in Acad) | Acad
eRegistryCreateError enum value (defined in Acad) | Acad
eRejected enum value (defined in Acad) | Acad
eRenameDoesNotExist enum value (defined in Acad) | Acad
eRenameInvalidLayoutName enum value (defined in Acad) | Acad
eRenameInvalidName enum value (defined in Acad) | Acad
eRenameIsModelSpace enum value (defined in Acad) | Acad
eRenameLayoutAlreadyExists enum value (defined in Acad) | Acad
eRepeatedDwgRead enum value (defined in Acad) | Acad
eRepeatEntity enum value (defined in Acad) | Acad
eRowsMustMatchColumns enum value (defined in Acad) | Acad
ErrorStatus enum name (defined in Acad) | Acad
eSecErrorCipherNotSupported enum value (defined in Acad) | Acad
eSecErrorComputingSignature enum value (defined in Acad) | Acad
eSecErrorDecryptingData enum value (defined in Acad) | Acad
eSecErrorEncryptingData enum value (defined in Acad) | Acad
eSecErrorGeneratingTimestamp enum value (defined in Acad) | Acad
eSecErrorReadingFile enum value (defined in Acad) | Acad
eSecErrorWritingFile enum value (defined in Acad) | Acad
eSecErrorWritingSignature enum value (defined in Acad) | Acad
eSecInitializationFailure enum value (defined in Acad) | Acad
eSecInvalidDigitalID enum value (defined in Acad) | Acad
eSelfReference enum value (defined in Acad) | Acad
eSetFailed enum value (defined in Acad) | Acad
eSingularPoint enum value (defined in Acad) | Acad
eSomeInputDataLeftUnread enum value (defined in Acad) | Acad
eStringTooLong enum value (defined in Acad) | Acad
eSubentitiesStillOpen enum value (defined in Acad) | Acad
eSubSelectionSetEmpty enum value (defined in Acad) | Acad
eTablet enum value (defined in Acad) | Acad
eTargetDocNotQuiescent enum value (defined in Acad) | Acad
eTooFewLineTypeElements enum value (defined in Acad) | Acad
eTooFewVertices enum value (defined in Acad) | Acad
eTooManyLineTypeElements enum value (defined in Acad) | Acad
eTooManyVertices enum value (defined in Acad) | Acad
eTransactionOpenWhileCommandEnded enum value (defined in Acad) | Acad
eUnableToGetLabelBlock enum value (defined in Acad) | Acad
eUnableToGetViewAssociation enum value (defined in Acad) | Acad
eUnableToRemoveAssociation enum value (defined in Acad) | Acad
eUnableToRemoveOverrides enum value (defined in Acad) | Acad
eUnableToRetrieveOverrides enum value (defined in Acad) | Acad
eUnableToSetLabelBlock enum value (defined in Acad) | Acad
eUnableToSetViewAssociation enum value (defined in Acad) | Acad
eUnableToStoreOverrides enum value (defined in Acad) | Acad
eUnableToStoreReconcileStatus enum value (defined in Acad) | Acad
eUnableToSyncModelView enum value (defined in Acad) | Acad
eUndefinedDxfGroupCode enum value (defined in Acad) | Acad
eUndefinedLineType enum value (defined in Acad) | Acad
eUndefineShapeName enum value (defined in Acad) | Acad
eUndoNoGroupBegin enum value (defined in Acad) | Acad
eUndoOperationNotAvailable enum value (defined in Acad) | Acad
eUnknownDxfFileFormat enum value (defined in Acad) | Acad
eUnknownHandle enum value (defined in Acad) | Acad
eUnrecoverableErrors enum value (defined in Acad) | Acad
eUnsupportedFileFormat enum value (defined in Acad) | Acad
eUsedOsnapBox enum value (defined in Acad) | Acad
eUsedPickBox enum value (defined in Acad) | Acad
eUserBreak enum value (defined in Acad) | Acad
eUserUnloaded enum value (defined in Acad) | Acad
eVertexAfterFace enum value (defined in Acad) | Acad
eVetoed enum value (defined in Acad) | Acad
eVSAlreadyExists enum value (defined in Acad) | Acad
eVSAPIOnlyValues enum value (defined in Acad) | Acad
eVSFalse enum value (defined in Acad) | Acad
eVSIsAcadDefault enum value (defined in Acad) | Acad
eVSIsInUse enum value (defined in Acad) | Acad
eVSNotFound enum value (defined in Acad) | Acad
eVSOneOffCreated enum value (defined in Acad) | Acad
eVSTrue enum value (defined in Acad) | Acad
eWasErased enum value (defined in Acad) | Acad
eWasNotErased enum value (defined in Acad) | Acad
eWasNotForwarding enum value (defined in Acad) | Acad
eWasNotifying enum value (defined in Acad) | Acad
eWasNotOpenForWrite enum value (defined in Acad) | Acad
eWasOpenForNotify enum value (defined in Acad) | Acad
eWasOpenForRead enum value (defined in Acad) | Acad
eWasOpenForUndo enum value (defined in Acad) | Acad
eWasOpenForWrite enum value (defined in Acad) | Acad
eWrongCellType enum value (defined in Acad) | Acad
eWrongDatabase enum value (defined in Acad) | Acad
eWrongObjectType enum value (defined in Acad) | Acad
eWrongSubentityType enum value (defined in Acad) | Acad
eXdataSizeExceeded enum value (defined in Acad) | Acad
eXPending enum value (defined in Acad) | Acad
eXRefDependent enum value (defined in Acad) | Acad
eXrefReloaded enum value (defined in Acad) | Acad
eYPending enum value (defined in Acad) | Acad
eZPending enum value (defined in Acad) | Acad
PointHistory enum name (defined in Acad) | Acad
PromptStatus enum name (defined in Acad) | Acad


ZRX API Reference: AcAp Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
AcAp Struct Reference
Structs

Public Types

enum DocLockMode {
kNone = 0x00, kAutoWrite = 0x01, kNotLocked = 0x02, kWrite = 0x04,
kProtectedAutoWrite = 0x14, kRead = 0x20, kXWrite = 0x40
}
The documentation for this struct was generated from the following file:
  • acdocman.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcAp Member List

This is the complete list of members for AcAp, including all inherited members.

DocLockMode enum name (defined in AcAp) | AcAp
kAutoWrite enum value (defined in AcAp) | AcAp
kNone enum value (defined in AcAp) | AcAp
kNotLocked enum value (defined in AcAp) | AcAp
kProtectedAutoWrite enum value (defined in AcAp) | AcAp
kRead enum value (defined in AcAp) | AcAp
kWrite enum value (defined in AcAp) | AcAp
kXWrite enum value (defined in AcAp) | AcAp


ZRX API Reference: AcColorSettings Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcColorSettings Struct Reference
Structs

Public Attributes

DWORD | dwAutoTrackingVecColor
DWORD | dwBEditASnapMarkerColor
DWORD | dwBEditATrackVecColor
DWORD | dwBEditBkColor
DWORD | dwBEditCrossHairColor
DWORD | dwBEditDftingTooltipBkColor
DWORD | dwBEditDftingTooltipColor
DWORD | dwBEditLightEndLimit
DWORD | dwBEditLightFalloff
DWORD | dwBEditLightGlyphs
DWORD | dwBEditLightHotspot
DWORD | dwBEditLightStartLimit
DWORD | dwCmdLineBkColor
DWORD | dwCmdLineForeColor
DWORD | dwEarthGradientAzimuthColor
DWORD | dwEarthGradientHorizonColor
DWORD | dwGfxLayoutBkColor
DWORD | dwGfxModelBkColor
DWORD | dwGroundGradientHorizonColor
DWORD | dwGroundGradientOriginColor
DWORD | dwLayoutASnapMarkerColor
DWORD | dwLayoutATrackVecColor
DWORD | dwLayoutCameraClipping
DWORD | dwLayoutCameraFrustrum
DWORD | dwLayoutCameraGlyphs
DWORD | dwLayoutCrossHairColor
DWORD | dwLayoutDftingTooltipBkColor
DWORD | dwLayoutDftingTooltipColor
DWORD | dwLayoutLightEndLimit
DWORD | dwLayoutLightFalloff
DWORD | dwLayoutLightGlyphs
DWORD | dwLayoutLightHotspot
DWORD | dwLayoutLightStartLimit
DWORD | dwModelASnapMarkerColor
DWORD | dwModelCameraClipping
DWORD | dwModelCameraFrustrum
DWORD | dwModelCameraGlyphs
DWORD | dwModelCrossHairColor
DWORD | dwModelDftingTooltipBkColor
DWORD | dwModelDftingTooltipColor
DWORD | dwModelLightEndLimit
DWORD | dwModelLightFalloff
DWORD | dwModelLightGlyphs
DWORD | dwModelLightHotspot
DWORD | dwModelLightStartLimit
DWORD | dwParallelASnapMarkerColor
DWORD | dwParallelATrackVecColor
DWORD | dwParallelBkColor
DWORD | dwParallelCameraClipping
DWORD | dwParallelCameraFrustrum
DWORD | dwParallelCameraGlyphs
DWORD | dwParallelCrossHairColor
DWORD | dwParallelDftingTooltipBkColor
DWORD | dwParallelDftingTooltipColor
DWORD | dwParallelGridAxisLines
DWORD | dwParallelGridMajorLines
DWORD | dwParallelGridMinorLines
DWORD | dwParallelLightEndLimit
DWORD | dwParallelLightFalloff
DWORD | dwParallelLightGlyphs
DWORD | dwParallelLightHotspot
DWORD | dwParallelLightStartLimit
DWORD | dwPerspectiveASnapMarkerColor
DWORD | dwPerspectiveATrackVecColor
DWORD | dwPerspectiveCameraClipping
DWORD | dwPerspectiveCameraFrustrum
DWORD | dwPerspectiveCameraGlyphs
DWORD | dwPerspectiveCrossHairColor
DWORD | dwPerspectiveDftingTooltipBkColor
DWORD | dwPerspectiveDftingTooltipColor
DWORD | dwPerspectiveGridAxisLines
DWORD | dwPerspectiveGridMajorLines
DWORD | dwPerspectiveGridMinorLines
DWORD | dwPerspectiveLightEndLimit
DWORD | dwPerspectiveLightFalloff
DWORD | dwPerspectiveLightGlyphs
DWORD | dwPerspectiveLightHotspot
DWORD | dwPerspectiveLightStartLimit
DWORD | dwPlotPrevBkColor
DWORD | dwSkyGradientHorizonColor
DWORD | dwSkyGradientZenithColor
DWORD | dwTextBkColor
DWORD | dwTextForeColor
int | nBEditATrackVecUseTintXYZ
int | nBEditCrossHairUseTintXYZ
int | nBEditDftingTooltipBkUseTintXYZ
int | nLayoutATrackVecUseTintXYZ
int | nLayoutCrosshairUseTintXYZ
int | nLayoutDftingTooltipBkUseTintXYZ
int | nModelATrackVecUseTintXYZ
int | nModelCrosshairUseTintXYZ
int | nModelDftingTooltipBkUseTintXYZ
int | nParallelATrackVecUseTintXYZ
int | nParallelCrosshairUseTintXYZ
int | nParallelDftingTooltipBkUseTintXYZ
int | nParallelGridAxisLineTintXYZ
int | nParallelGridMajorLineTintXYZ
int | nParallelGridMinorLineTintXYZ
int | nPerspectiveATrackVecUseTintXYZ
int | nPerspectiveCrosshairUseTintXYZ
int | nPerspectiveDftingTooltipBkUseTintXYZ
int | nPerspectiveGridAxisLineTintXYZ
int | nPerspectiveGridMajorLineTintXYZ
int | nPerspectiveGridMinorLineTintXYZ
The documentation for this struct was generated from the following file:
  • rxmfcapi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcColorSettings Member List

This is the complete list of members for AcColorSettings, including all inherited members.

dwAutoTrackingVecColor (defined in AcColorSettings) | AcColorSettings
dwBEditASnapMarkerColor (defined in AcColorSettings) | AcColorSettings
dwBEditATrackVecColor (defined in AcColorSettings) | AcColorSettings
dwBEditBkColor (defined in AcColorSettings) | AcColorSettings
dwBEditCrossHairColor (defined in AcColorSettings) | AcColorSettings
dwBEditDftingTooltipBkColor (defined in AcColorSettings) | AcColorSettings
dwBEditDftingTooltipColor (defined in AcColorSettings) | AcColorSettings
dwBEditLightEndLimit (defined in AcColorSettings) | AcColorSettings
dwBEditLightFalloff (defined in AcColorSettings) | AcColorSettings
dwBEditLightGlyphs (defined in AcColorSettings) | AcColorSettings
dwBEditLightHotspot (defined in AcColorSettings) | AcColorSettings
dwBEditLightStartLimit (defined in AcColorSettings) | AcColorSettings
dwCmdLineBkColor (defined in AcColorSettings) | AcColorSettings
dwCmdLineForeColor (defined in AcColorSettings) | AcColorSettings
dwEarthGradientAzimuthColor (defined in AcColorSettings) | AcColorSettings
dwEarthGradientHorizonColor (defined in AcColorSettings) | AcColorSettings
dwGfxLayoutBkColor (defined in AcColorSettings) | AcColorSettings
dwGfxModelBkColor (defined in AcColorSettings) | AcColorSettings
dwGroundGradientHorizonColor (defined in AcColorSettings) | AcColorSettings
dwGroundGradientOriginColor (defined in AcColorSettings) | AcColorSettings
dwLayoutASnapMarkerColor (defined in AcColorSettings) | AcColorSettings
dwLayoutATrackVecColor (defined in AcColorSettings) | AcColorSettings
dwLayoutCameraClipping (defined in AcColorSettings) | AcColorSettings
dwLayoutCameraFrustrum (defined in AcColorSettings) | AcColorSettings
dwLayoutCameraGlyphs (defined in AcColorSettings) | AcColorSettings
dwLayoutCrossHairColor (defined in AcColorSettings) | AcColorSettings
dwLayoutDftingTooltipBkColor (defined in AcColorSettings) | AcColorSettings
dwLayoutDftingTooltipColor (defined in AcColorSettings) | AcColorSettings
dwLayoutLightEndLimit (defined in AcColorSettings) | AcColorSettings
dwLayoutLightFalloff (defined in AcColorSettings) | AcColorSettings
dwLayoutLightGlyphs (defined in AcColorSettings) | AcColorSettings
dwLayoutLightHotspot (defined in AcColorSettings) | AcColorSettings
dwLayoutLightStartLimit (defined in AcColorSettings) | AcColorSettings
dwModelASnapMarkerColor (defined in AcColorSettings) | AcColorSettings
dwModelCameraClipping (defined in AcColorSettings) | AcColorSettings
dwModelCameraFrustrum (defined in AcColorSettings) | AcColorSettings
dwModelCameraGlyphs (defined in AcColorSettings) | AcColorSettings
dwModelCrossHairColor (defined in AcColorSettings) | AcColorSettings
dwModelDftingTooltipBkColor (defined in AcColorSettings) | AcColorSettings
dwModelDftingTooltipColor (defined in AcColorSettings) | AcColorSettings
dwModelLightEndLimit (defined in AcColorSettings) | AcColorSettings
dwModelLightFalloff (defined in AcColorSettings) | AcColorSettings
dwModelLightGlyphs (defined in AcColorSettings) | AcColorSettings
dwModelLightHotspot (defined in AcColorSettings) | AcColorSettings
dwModelLightStartLimit (defined in AcColorSettings) | AcColorSettings
dwParallelASnapMarkerColor (defined in AcColorSettings) | AcColorSettings
dwParallelATrackVecColor (defined in AcColorSettings) | AcColorSettings
dwParallelBkColor (defined in AcColorSettings) | AcColorSettings
dwParallelCameraClipping (defined in AcColorSettings) | AcColorSettings
dwParallelCameraFrustrum (defined in AcColorSettings) | AcColorSettings
dwParallelCameraGlyphs (defined in AcColorSettings) | AcColorSettings
dwParallelCrossHairColor (defined in AcColorSettings) | AcColorSettings
dwParallelDftingTooltipBkColor (defined in AcColorSettings) | AcColorSettings
dwParallelDftingTooltipColor (defined in AcColorSettings) | AcColorSettings
dwParallelGridAxisLines (defined in AcColorSettings) | AcColorSettings
dwParallelGridMajorLines (defined in AcColorSettings) | AcColorSettings
dwParallelGridMinorLines (defined in AcColorSettings) | AcColorSettings
dwParallelLightEndLimit (defined in AcColorSettings) | AcColorSettings
dwParallelLightFalloff (defined in AcColorSettings) | AcColorSettings
dwParallelLightGlyphs (defined in AcColorSettings) | AcColorSettings
dwParallelLightHotspot (defined in AcColorSettings) | AcColorSettings
dwParallelLightStartLimit (defined in AcColorSettings) | AcColorSettings
dwPerspectiveASnapMarkerColor (defined in AcColorSettings) | AcColorSettings
dwPerspectiveATrackVecColor (defined in AcColorSettings) | AcColorSettings
dwPerspectiveCameraClipping (defined in AcColorSettings) | AcColorSettings
dwPerspectiveCameraFrustrum (defined in AcColorSettings) | AcColorSettings
dwPerspectiveCameraGlyphs (defined in AcColorSettings) | AcColorSettings
dwPerspectiveCrossHairColor (defined in AcColorSettings) | AcColorSettings
dwPerspectiveDftingTooltipBkColor (defined in AcColorSettings) | AcColorSettings
dwPerspectiveDftingTooltipColor (defined in AcColorSettings) | AcColorSettings
dwPerspectiveGridAxisLines (defined in AcColorSettings) | AcColorSettings
dwPerspectiveGridMajorLines (defined in AcColorSettings) | AcColorSettings
dwPerspectiveGridMinorLines (defined in AcColorSettings) | AcColorSettings
dwPerspectiveLightEndLimit (defined in AcColorSettings) | AcColorSettings
dwPerspectiveLightFalloff (defined in AcColorSettings) | AcColorSettings
dwPerspectiveLightGlyphs (defined in AcColorSettings) | AcColorSettings
dwPerspectiveLightHotspot (defined in AcColorSettings) | AcColorSettings
dwPerspectiveLightStartLimit (defined in AcColorSettings) | AcColorSettings
dwPlotPrevBkColor (defined in AcColorSettings) | AcColorSettings
dwSkyGradientHorizonColor (defined in AcColorSettings) | AcColorSettings
dwSkyGradientZenithColor (defined in AcColorSettings) | AcColorSettings
dwTextBkColor (defined in AcColorSettings) | AcColorSettings
dwTextForeColor (defined in AcColorSettings) | AcColorSettings
nBEditATrackVecUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nBEditCrossHairUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nBEditDftingTooltipBkUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nLayoutATrackVecUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nLayoutCrosshairUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nLayoutDftingTooltipBkUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nModelATrackVecUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nModelCrosshairUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nModelDftingTooltipBkUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nParallelATrackVecUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nParallelCrosshairUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nParallelDftingTooltipBkUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nParallelGridAxisLineTintXYZ (defined in AcColorSettings) | AcColorSettings
nParallelGridMajorLineTintXYZ (defined in AcColorSettings) | AcColorSettings
nParallelGridMinorLineTintXYZ (defined in AcColorSettings) | AcColorSettings
nPerspectiveATrackVecUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nPerspectiveCrosshairUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nPerspectiveDftingTooltipBkUseTintXYZ (defined in AcColorSettings) | AcColorSettings
nPerspectiveGridAxisLineTintXYZ (defined in AcColorSettings) | AcColorSettings
nPerspectiveGridMajorLineTintXYZ (defined in AcColorSettings) | AcColorSettings
nPerspectiveGridMinorLineTintXYZ (defined in AcColorSettings) | AcColorSettings


ZRX API Reference: AcColorSettingsEx Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcColorSettingsEx Struct Reference
Structs

Public Attributes

DWORD | dwBEditLightWeb
DWORD | dwBEditLightWebLuxAtDist
DWORD | dwBEditLightWebMissingFile
DWORD | dwBEditLightWebShape
DWORD | dwLayoutLightWeb
DWORD | dwLayoutLightWebLuxAtDist
DWORD | dwLayoutLightWebMissingFile
DWORD | dwLayoutLightWebShape
DWORD | dwModelLightWeb
DWORD | dwModelLightWebLuxAtDist
DWORD | dwModelLightWebMissingFile
DWORD | dwModelLightWebShape
DWORD | dwParallelLightWeb
DWORD | dwParallelLightWebLuxAtDist
DWORD | dwParallelLightWebMissingFile
DWORD | dwParallelLightWebShape
DWORD | dwPerspectiveLightWeb
DWORD | dwPerspectiveLightWebLuxAtDist
DWORD | dwPerspectiveLightWebMissingFile
DWORD | dwPerspectiveLightWebShape
The documentation for this struct was generated from the following file:
  • rxmfcapi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcColorSettingsEx Member List

This is the complete list of members for AcColorSettingsEx, including all inherited members.

dwBEditLightWeb (defined in AcColorSettingsEx) | AcColorSettingsEx
dwBEditLightWebLuxAtDist (defined in AcColorSettingsEx) | AcColorSettingsEx
dwBEditLightWebMissingFile (defined in AcColorSettingsEx) | AcColorSettingsEx
dwBEditLightWebShape (defined in AcColorSettingsEx) | AcColorSettingsEx
dwLayoutLightWeb (defined in AcColorSettingsEx) | AcColorSettingsEx
dwLayoutLightWebLuxAtDist (defined in AcColorSettingsEx) | AcColorSettingsEx
dwLayoutLightWebMissingFile (defined in AcColorSettingsEx) | AcColorSettingsEx
dwLayoutLightWebShape (defined in AcColorSettingsEx) | AcColorSettingsEx
dwModelLightWeb (defined in AcColorSettingsEx) | AcColorSettingsEx
dwModelLightWebLuxAtDist (defined in AcColorSettingsEx) | AcColorSettingsEx
dwModelLightWebMissingFile (defined in AcColorSettingsEx) | AcColorSettingsEx
dwModelLightWebShape (defined in AcColorSettingsEx) | AcColorSettingsEx
dwParallelLightWeb (defined in AcColorSettingsEx) | AcColorSettingsEx
dwParallelLightWebLuxAtDist (defined in AcColorSettingsEx) | AcColorSettingsEx
dwParallelLightWebMissingFile (defined in AcColorSettingsEx) | AcColorSettingsEx
dwParallelLightWebShape (defined in AcColorSettingsEx) | AcColorSettingsEx
dwPerspectiveLightWeb (defined in AcColorSettingsEx) | AcColorSettingsEx
dwPerspectiveLightWebLuxAtDist (defined in AcColorSettingsEx) | AcColorSettingsEx
dwPerspectiveLightWebMissingFile (defined in AcColorSettingsEx) | AcColorSettingsEx
dwPerspectiveLightWebShape (defined in AcColorSettingsEx) | AcColorSettingsEx


ZRX API Reference: AcDb Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
AcDb Struct Reference
Structs

Public Types

enum {
kDxfInvalid = -9999, kDxfXDictionary = -6, kDxfPReactors = -5, kDxfOperator = -4,
kDxfXDataStart = -3, kDxfHeaderId = -2, kDxfFirstEntId = -2, kDxfEnd = -1,
kDxfStart = 0, kDxfText = 1, kDxfXRefPath = 1, kDxfShapeName = 2,
kDxfBlockName = 2, kDxfAttributeTag = 2, kDxfSymbolTableName = 2, kDxfMstyleName = 2,
kDxfSymTableRecName = 2, kDxfAttributePrompt = 3, kDxfDimStyleName = 3, kDxfLinetypeProse = 3,
kDxfTextFontFile = 3, kDxfDescription = 3, kDxfDimPostStr = 3, kDxfTextBigFontFile = 4,
kDxfDimAPostStr = 4, kDxfCLShapeName = 4, kDxfSymTableRecComments = 4, kDxfHandle = 5,
kDxfDimBlk = 5, kDxfDimBlk1 = 6, kDxfLinetypeName = 6, kDxfDimBlk2 = 7,
kDxfTextStyleName = 7, kDxfLayerName = 8, kDxfCLShapeText = 9, kDxfXCoord = 10,
kDxfYCoord = 20, kDxfZCoord = 30, kDxfElevation = 38, kDxfThickness = 39,
kDxfReal = 40, kDxfViewportHeight = 40, kDxfTxtSize = 40, kDxfTxtStyleXScale = 41,
kDxfViewWidth = 41, kDxfViewportAspect = 41, kDxfTxtStylePSize = 42, kDxfViewLensLength = 42,
kDxfViewFrontClip = 43, kDxfViewBackClip = 44, kDxfShapeXOffset = 44, kDxfShapeYOffset = 45,
kDxfViewHeight = 45, kDxfShapeScale = 46, kDxfPixelScale = 47, kDxfLinetypeScale = 48,
kDxfDashLength = 49, kDxfMlineOffset = 49, kDxfLinetypeElement = 49, kDxfAngle = 50,
kDxfViewportSnapAngle = 50, kDxfViewportTwist = 51, kDxfVisibility = 60, kDxfViewportGridDisplay = 60,
kDxfLayerLinetype = 61, kDxfViewportGridMajor = 61, kDxfColor = 62, kDxfHasSubentities = 66,
kDxfViewportVisibility = 67, kDxfViewportActive = 68, kDxfViewportNumber = 69, kDxfInt16 = 70,
kDxfViewMode = 71, kDxfCircleSides = 72, kDxfViewportZoom = 73, kDxfViewportIcon = 74,
kDxfViewportSnap = 75, kDxfViewportGrid = 76, kDxfViewportSnapStyle = 77, kDxfViewportSnapPair = 78,
kDxfRegAppFlags = 71, kDxfTxtStyleFlags = 71, kDxfLinetypeAlign = 72, kDxfLinetypePDC = 73,
kDxfInt32 = 90, kDxfVertexIdentifier = 91, kDxfSubclass = 100, kDxfEmbeddedObjectStart = 101,
kDxfControlString = 102, kDxfDimVarHandle = 105, kDxfUCSOrg = 110, kDxfUCSOriX = 111,
kDxfUCSOriY = 112, kDxfXReal = 140, kDxfViewBrightness = 141, kDxfViewContrast = 142,
kDxfInt64 = 160, kDxfXInt16 = 170, kDxfNormalX = 210, kDxfNormalY = 220,
kDxfNormalZ = 230, kDxfXXInt16 = 270, kDxfInt8 = 280, kDxfRenderMode = 281,
kDxfDefaultLightingType = 282, kDxfShadowFlags = 284, kDxfBool = 290, kDxfDefaultLightingOn = 292,
kDxfXTextString = 300, kDxfBinaryChunk = 310, kDxfArbHandle = 320, kDxfSoftPointerId = 330,
kDxfViewBackgroundId = 332, kDxfShadePlotId = 333, kDxfLiveSectionId = 334, kDxfLiveSectionName = 309,
kDxfHardPointerId = 340, kDxfObjVisualStyleId = 345, kDxfVpVisualStyleId = 346, kDxfMaterialId = 347,
kDxfVisualStyleId = 348, kDxfDragVisualStyleId = 349, kDxfSoftOwnershipId = 350, kDxfHardOwnershipId = 360,
kDxfSunId = 361, kDxfLineWeight = 370, kDxfPlotStyleNameType = 380, kDxfPlotStyleNameId = 390,
kDxfXXXInt16 = 400, kDxfLayoutName = 410, kDxfColorRGB = 420, kDxfColorName = 430,
kDxfAlpha = 440, kDxfGradientObjType = 450, kDxfGradientPatType = 451, kDxfGradientTintType = 452,
kDxfGradientColCount = 453, kDxfGradientAngle = 460, kDxfGradientShift = 461, kDxfGradientTintVal = 462,
kDxfGradientColVal = 463, kDxfGradientName = 470, kDxfFaceStyleId = 480, kDxfEdgeStyleId = 481,
kDxfComment = 999, kDxfXdAsciiString = 1000, kDxfRegAppName = 1001, kDxfXdControlString = 1002,
kDxfXdLayerName = 1003, kDxfXdBinaryChunk = 1004, kDxfXdHandle = 1005, kDxfXdXCoord = 1010,
kDxfXdYCoord = 1020, kDxfXdZCoord = 1030, kDxfXdWorldXCoord = 1011, kDxfXdWorldYCoord = 1021,
kDxfXdWorldZCoord = 1031, kDxfXdWorldXDisp = 1012, kDxfXdWorldYDisp = 1022, kDxfXdWorldZDisp = 1032,
kDxfXdWorldXDir = 1013, kDxfXdWorldYDir = 1023, kDxfXdWorldZDir = 1033, kDxfXdReal = 1040,
kDxfXdDist = 1041, kDxfXdScale = 1042, kDxfXdInteger16 = 1070, kDxfXdInteger32 = 1071
}
enum {
kNullSubentType = 0, kFaceSubentType = 1, kEdgeSubentType = 2, kVertexSubentType = 3,
kMlineSubentCache = 4, kClassSubentType = 5
}
enum | { kNoGeom = 0 }
enum AcDbDwgVersion {
kDHL_MC0_0 = 0, kDHL_AC1_2 = 1, kDHL_AC1_40 = 2, kDHL_AC1_50 = 3,
kDHL_AC2_20 = 4, kDHL_AC2_10 = 5, kDHL_AC2_21 = 6, kDHL_AC2_22 = 7,
kDHL_1001 = 8, kDHL_1002 = 9, kDHL_1003 = 10, kDHL_1004 = 11,
kDHL_1005 = 12, kDHL_1006 = 13, kDHL_1007 = 14, kDHL_1008 = 15,
kDHL_1009 = 16, kDHL_1010 = 17, kDHL_1011 = 18, kDHL_1012 = 19,
kDHL_1013 = 20, kDHL_1014 = 21, kDHL_1500 = 22, kDHL_1015 = 23,
kDHL_1800a = 24, kDHL_1800 = 25, kDHL_2100a = 26, kDHL_1021 = 27,
kDHL_2400a = 28, kDHL_1024 = 29, kDHL_2700a = 30, kDHL_1027 = 31,
vAC025 = kDHL_1002, vAC026 = kDHL_1003, vAC09 = kDHL_1004, vAC10 = kDHL_1006,
vAC12 = kDHL_1009, vAC13 = kDHL_1012, vAC14beta = kDHL_1013, vAC14 = kDHL_1014,
vAC15 = kDHL_1015, vAC18 = kDHL_1800, vAC21 = kDHL_1021, vAC24 = kDHL_1024,
vAC27 = kDHL_1027, kDHL_Newest = kDHL_1027, kDHL_CURRENT = kDHL_Newest, kDHL_Unknown = 32766,
kDHL_Max = 32767
}
enum | BoolOperType { kBoolUnite = 0, kBoolIntersect = 1, kBoolSubtract = 2 }
enum CellAlignment {
kTopLeft = 1, kTopCenter = 2, kTopRight = 3, kMiddleLeft = 4,
kMiddleCenter = 5, kMiddleRight = 6, kBottomLeft = 7, kBottomCenter = 8,
kBottomRight = 9
}
enum | CellClass { kCellClassNone = 0, kCellClassLabel = 0x1, kCellClassData = 0x2 }
enum | CellContentLayout { kCellContentLayoutFlow = 0x1, kCellContentLayoutStackedHorizontal = 0x2, kCellContentLayoutStackedVertical = 0x4 }
enum | CellContentType { kCellContentTypeUnknown = 0, kCellContentTypeValue = 0x1, kCellContentTypeField = 0x2, kCellContentTypeBlock = 0x4 }
enum | CellEdgeMask { kTopMask = 1, kRightMask = 2, kBottomMask = 4, kLeftMask = 8 }
enum CellMargin {
kCellMarginTop = 0x1, kCellMarginLeft = 0x2, kCellMarginBottom = 0x4, kCellMarginRight = 0x8,
kCellMarginHorzSpacing = 0x10, kCellMarginVertSpacing = 0x20
}
enum | CellOption { kCellOptionNone = 0, kInheritCellFormat = 0x1 }
enum CellProperty {
kCellPropInvalid = 0, kCellPropDataType = 0x1, kCellPropDataFormat = 0x2, kCellPropRotation = 0x4,
kCellPropScale = 0x8, kCellPropAlignment = 0x10, kCellPropContentColor = 0x20, kCellPropTextStyle = 0x40,
kCellPropTextHeight = 0x80, kCellPropAutoScale = 0x100, kCellPropBackgroundColor = 0x200, kCellPropMarginLeft = 0x400,
kCellPropMarginTop = 0x800, kCellPropMarginRight = 0x1000, kCellPropMarginBottom = 0x2000, kCellPropMarginHorzSpacing = 0x20000,
kCellPropMarginVertSpacing = 0x40000, kCellPropContentLayout = 0x4000, kCellPropMergeAll = 0x8000, kCellPropFlowDirBtoT = 0x10000,
kCellPropDataTypeAndFormat = (kCellPropDataType | kCellPropDataFormat), kCellPropContent, kCellPropBitProperties = (kCellPropAutoScale | kCellPropMergeAll | kCellPropFlowDirBtoT), kCellPropAll
}
enum CellState {
kCellStateNone = 0, kCellStateContentLocked = 0x1, kCellStateContentReadOnly = 0x2, kCellStateLinked = 0x4,
kCellStateContentModifiedAfterUpdate = 0x8, kCellStateFormatLocked = 0x10, kCellStateFormatReadOnly = 0x20, kCellStateFormatModifiedAfterUpdate = 0x40,
kAllCellStates
}
enum | CellType { kUnknownCell = 0, kTextCell = 1, kBlockCell = 2, kMultipleContentCell = 3 }
enum | CollisionType { kCollisionTypeNone = 0, kCollisionTypeSolid = 1 }
enum | CoordAxis { kX = 0, kY = 1, kZ = 2 }
enum CoordSystem {
kWorldCS = 0, kUserCS = 1, kCurDisplayCS = 2, kPaperDisplayCS = 3,
kEntityCS = 4
}
enum DataLinkGetSourceContext {
kDataLinkGetSourceContextUnknown = 0, kDataLinkGetSourceContextEtransmit = 1, kDataLinkGetSourceContextXrefManager = 2, kDataLinkGetSourceContextFileWatcher = 3,
kDataLinkGetSourceContextOther = 4, kDataLinkGetSourceContextOrignalPath = (0x1 << 8)
}
enum DataLinkOption {
kDataLinkOptionNone = 0, kDataLinkOptionAnonymous = 0x1, kDataLinkOptionPersistCache = 0x2, kDataLinkOptionDisableInLT = 0x4,
kDataLinkHasCutomData = 0x8
}
enum DeepCloneType {
kDcCopy = 0, kDcExplode = 1, kDcBlock = 2, kDcXrefBind = 3,
kDcSymTableMerge = 4, kDcInsert = 6, kDcWblock = 7, kDcObjects = 8,
kDcXrefInsert = 9, kDcInsertCopy = 10, kDcWblkObjects = 11
}
enum | DimArrowFlags { kFirstArrow = 0x00, kSecondArrow = 0x01 }
enum | DimblkFlags { kDimblk = 0, kDimblk1, kDimblk2, kDimLdrBlk }
enum | DragStat { kDragStart = 0, kDragEnd = 1, kDragAbort = 2 }
enum | DrawOrderFlags { kDrawOrderInPlaceEditOn = 0x01, kDrawOrderInheritanceOn = 0x02 }
enum DuplicateRecordCloning {
kDrcNotApplicable = 0, kDrcIgnore = 1, kDrcReplace = 2, kDrcXrefMangleName = 3,
kDrcMangleName = 4, kDrcUnmangleName = 5
}
enum DwgDataType {
kDwgNull = 0, kDwgReal = 1, kDwgInt32 = 2, kDwgInt16 = 3,
kDwgInt8 = 4, kDwgText = 5, kDwgBChunk = 6, kDwgHandle = 7,
kDwgHardOwnershipId = 8, kDwgSoftOwnershipId = 9, kDwgHardPointerId = 10, kDwgSoftPointerId = 11,
kDwg3Real = 12, kDwgInt64 = 13, kDwgNotRecognized = 19
}
typedef Adesk::Int16 | DxfCode
enum | EdgeIndex { kMEdge1 = 0, kMEdge2 = 1, kMEdge3 = 2, kMEdge4 = 3 }
enum | EndCaps { kEndCapNone = 0, kEndCapRound = 1, kEndCapAngle = 2, kEndCapSquare = 3 }
enum | EnhancedBlockEvalType { kInitialization = 1, kForUpdate = 2, kForRefresh = 3 }
enum | FilerSeekType { kSeekFromStart = 0, kSeekFromCurrent = 1, kSeekFromEnd = 2 }
enum FilerType {
kFileFiler = 0, kCopyFiler = 1, kUndoFiler = 2, kBagFiler = 3,
kIdXlateFiler = 4, kPageFiler = 5, kDeepCloneFiler = 6, kIdFiler = 7,
kPurgeFiler = 8, kWblockCloneFiler = 9
}
enum | FileType { kDwg = 0, kDxf = 1, kDxb = 2, kUnknown = -1 }
enum | FlowDirection { kTtoB = 0, kBtoT = 1 }
typedef Adesk::UInt32 | GeomId
enum GeomType {
kInvalidGeom = 0, kPointGeom, kLineGeom, kCircleGeom,
kPlaneGeom
}
enum | GridLineStyle { kGridLineStyleSingle = 1, kGridLineStyleDouble = 2 }
enum GridLineType {
kInvalidGridLine = 0, kHorzTop = 1, kHorzInside = 2, kHorzBottom = 4,
kVertLeft = 8, kVertInside = 0x10, kVertRight = 0x20, kHorzGridLineTypes = kHorzTop | kHorzBottom | kHorzInside,
kVertGridLineTypes = kVertLeft | kVertRight | kVertInside, kOuterGridLineTypes = kHorzTop | kHorzBottom | kVertLeft | kVertRight, kInnerGridLineTypes = kHorzInside | kVertInside, kAllGridLineTypes = kOuterGridLineTypes | kInnerGridLineTypes
}
enum | GridLineTypes { kAllGridLines = kAllGridLineTypes }
enum GridProperty {
kGridPropInvalid = 0, kGridPropLineStyle = 0x1, kGridPropLineWeight = 0x2, kGridPropLinetype = 0x4,
kGridPropColor = 0x8, kGridPropVisibility = 0x10, kGridPropDoubleLineSpacing = 0x20, kGridPropAll
}
enum | GripStat { kGripsDone = 0, kGripsToBeDeleted = 1, kDimDataToBeDeleted = 2 }
enum GroupOperType {
kNoOp = 0, kAdd = 1, kRemove = 2, kRename = 3,
kOrdered = 4, kGrpDesc = 5, kSelect = 6, kCreate = 7,
kPrepend = 8, kInsert = 9, kGrpFlags = 10
}
enum | IndexCreation { kNoIndex = 0, kIndexByLayer = 1, kIndexSpatially = 2 }
enum | Intersect { kOnBothOperands = 0, kExtendThis = 1, kExtendArg = 2, kExtendBoth = 3 }
enum | JoinStyle { kJnStylNone = 0, kJnStylRound = 1, kJnStylAngle = 2, kJnStylFlat = 3 }
enum | LayerEvaluation { kNoNewLayerEvaluation = 0, kEvalNewXrefLayers = 1, kEvalAllNewLayers = 2 }
enum | LightingUnits { kLightingUnitsGeneric = 0, kLightingUnitsAmerican = 1, kLightingUnitsInternational = 2 }
enum | LineSpacingStyle { kAtLeast = 1, kExactly = 2 }
enum LineWeight {
kLnWt000 = 0, kLnWt005 = 5, kLnWt009 = 9, kLnWt013 = 13,
kLnWt015 = 15, kLnWt018 = 18, kLnWt020 = 20, kLnWt025 = 25,
kLnWt030 = 30, kLnWt035 = 35, kLnWt040 = 40, kLnWt050 = 50,
kLnWt053 = 53, kLnWt060 = 60, kLnWt070 = 70, kLnWt080 = 80,
kLnWt090 = 90, kLnWt100 = 100, kLnWt106 = 106, kLnWt120 = 120,
kLnWt140 = 140, kLnWt158 = 158, kLnWt200 = 200, kLnWt211 = 211,
kLnWtByLayer = -1, kLnWtByBlock = -2, kLnWtByLwDefault = -3
}
enum LoftNormalsType {
kLoftRuled = 0, kLoftSmooth = 1, kLoftFirstNormal = 2, kLoftLastNormal = 3,
kLoftEndsNormal = 4, kLoftAllNormal = 5, kLoftUseDraftAngles = 6
}
enum LoftParamType {
kLoftNoParam = 0x00, kLoftNoTwist = 0x01, kLoftAlignDirection = 0x02, kLoftSimplify = 0x04,
kLoftClose = 0x08, kLoftDefault = kLoftNoTwist | kLoftAlignDirection | kLoftSimplify
}
enum MaintenanceReleaseVersion {
kMRelease0 = 0, kMRelease1 = 1, kMRelease2 = 2, kMRelease3 = 3,
kMRelease4 = 4, kMRelease5 = 5, kMRelease6 = 6, kMRelease7 = 7,
kMRelease8 = 8, kMRelease9 = 9, kMRelease10 = 10, kMRelease11 = 11,
kMRelease12 = 12, kMRelease13 = 13, kMRelease14 = 14, kMRelease15 = 15,
kMRelease16 = 16, kMRelease17 = 17, kMRelease18 = 18, kMRelease19 = 19,
kMRelease20 = 20, kMRelease21 = 21, kMRelease22 = 22, kMRelease23 = 23,
kMRelease24 = 24, kMRelease25 = 25, kMRelease26 = 26, kMRelease27 = 27,
kMRelease28 = 28, kMRelease29 = 29, kMRelease30 = 30, kMRelease31 = 31,
kMRelease32 = 32, kMRelease33 = 33, kMRelease34 = 34, kMRelease35 = 35,
kMRelease36 = 36, kMRelease37 = 37, kMRelease38 = 38, kMRelease39 = 39,
kMRelease40 = 40, kMRelease41 = 41, kMReleaseFirstValid1500 = kMRelease41, kMRelease42 = 42,
kMRelease43 = 43, kMRelease44 = 44, kMRelease45 = 45, kMRelease46 = 46,
kMRelease47 = 47, kMRelease48 = 48, kMRelease49 = 49, kMRelease50 = 50,
kMRelease51 = 51, kMRelease52 = 52, kMRelease53 = 53, kMRelease54 = 54,
kMRelease55 = 55, kMRelease56 = 56, kMRelease57 = 57, kMRelease58 = 58,
kMRelease59 = 59, kMRelease60 = 60, kMRelease61 = 61, kMRelease62 = 62,
kMRelease63 = 63, kMRelease64 = 64, kMRelease65 = 65, kMRelease66 = 66,
kMRelease67 = 67, kMRelease68 = 68, kMRelease69 = 69, kMRelease70 = 70,
kMRelease71 = 71, kMRelease72 = 72, kMRelease73 = 73, kMRelease74 = 74,
kMRelease75 = 75, kMRelease76 = 76, kMRelease100 = 100, kMRelease101 = 101,
kMRelease102 = 102, kMRelease103 = 103, kMRelease104 = 104, kMRelease105 = 105,
kMRelease106 = 106, kMRelease107 = 107, kMRelease108 = 108, kMRelease109 = 109,
kMRelease110 = 110, kMRelease111 = 111, kMRelease112 = 112, kMRelease113 = 113,
kMRelease114 = 114, kMReleaseNewest = kMRelease8, kMRelease2010Newest = kMRelease109, kMReleaseCurrent = kMReleaseNewest,
kMReleaseUnknown = 126, kMReleaseMax = 127
}
enum | MeasurementValue { kEnglish = 0, kMetric = 1 }
enum MergeCellStyleOption {
kMergeCellStyleNone = 0, kMergeCellStyleCopyDuplicates = 0x1, kMergeCellStyleOverwriteDuplicates = 0x2, kMergeCellStyleConvertDuplicatesToOverrides = 0x4,
kMergeCellStyleIgnoreNewStyles = 0x8
}
enum NewLayerNotification {
kNoNewLayerNotification = 0, kNotifyOnPlot = 1, kNotifyOnOpen = 2, kNotifyOnXrefAttachAndReload = 4,
kNotifyOnLayerStateRestore = 8, kNotifyOnSave = 16, kNotifyOnInsert = 32
}
enum | OpenMode { kForRead = 0, kForWrite = 1, kForNotify = 2 }
enum OrthographicView {
kNonOrthoView = 0, kTopView = 1, kBottomView = 2, kFrontView = 3,
kBackView = 4, kLeftView = 5, kRightView = 6
}
enum OsnapMask {
kOsMaskEnd = 1, kOsMaskMid = 2, kOsMaskCen = 4, kOsMaskNode = 8,
kOsMaskQuad = 0x10, kOsMaskInt = 0x20, kOsMaskIns = 0x40, kOsMaskPerp = 0x80,
kOsMaskTan = 0x100, kOsMaskNear = 0x200, kOsMaskQuick = 0x400, kOsMaskApint = 0x800,
kOsMaskImmediate = 0x10000, kOsMaskAllowTan = 0x20000, kOsMaskDisablePerp = 0x40000, kOsMaskRelCartesian = 0x80000,
kOsMaskRelPolar = 0x100000, kOsMaskNoneOverride = 0x200000
}
enum OsnapMode {
kOsModeEnd = 1, kOsModeMid = 2, kOsModeCen = 3, kOsModeNode = 4,
kOsModeQuad = 5, kOsModeIns = 7, kOsModePerp = 8, kOsModeTan = 9,
kOsModeNear = 10
}
enum | PathOption { kNoPath = 1, kRelativePath = 2, kAbsolutePath = 3, kPathAndFile = 4 }
enum | Planarity { kNonPlanar = 0, kPlanar = 1, kLinear = 2 }
enum | PlotStyleNameType { kPlotStyleNameByLayer = 0, kPlotStyleNameByBlock = 1, kPlotStyleNameIsDictDefault = 2, kPlotStyleNameById = 3 }
enum | PointIndex { kMPoint1 = 0, kMPoint2 = 1, kMPoint3 = 2, kMPoint4 = 3 }
enum | Poly2dType { k2dSimplePoly = 0, k2dFitCurvePoly = 1, k2dQuadSplinePoly = 2, k2dCubicSplinePoly = 3 }
enum | Poly3dType { k3dSimplePoly = 0, k3dQuadSplinePoly = 1, k3dCubicSplinePoly = 2 }
enum | PolyMeshType { kSimpleMesh = 0, kQuadSurfaceMesh = 5, kCubicSurfaceMesh = 6, kBezierSurfaceMesh = 8 }
enum | ReferenceType { kSoftPointerRef = 0, kHardPointerRef = 1, kSoftOwnershipRef = 2, kHardOwnershipRef = 3 }
enum reservedStringEnumType {
kByLayer = 0, kByBlock = 1, kNone = 2, kContinuous = 3,
kStandard = 4, kNormal = 5, kDefPoints = 6, kDefault = 7,
kMissing = 8, kByColor = 9, kModel = 10, kGlobal = 11,
kVS2DWireframe = 12, kVS3DWireframe = 13, kVS3DHidden = 14, kVSRealistic = 15,
kVSConceptual = 16, kTitle = 17, kHeader = 18, kData = 19,
kReservedStringCount
}
enum RotationAngle {
kDegreesUnknown = -1, kDegrees000 = 0, kDegrees090 = 1, kDegrees180 = 2,
kDegrees270 = 3
}
enum RowType {
kUnknownRow = 0, kDataRow = 1, kTitleRow = 2, kHeaderRow = 4,
kAllRowTypes = kDataRow | kTitleRow | kHeaderRow
}
enum | RowTypes { kAllRows = kDataRow | kTitleRow | kHeaderRow }
enum | SaveImagesMode { kNeverSave = 0, kAlwaysSave = 1 }
enum SaveType {
kNoSave = 0, kR12Save, kR13Save, kR14Save,
k2000Save, k2004Save, k2007Save, k2010Save,
k2013Save
}
enum | SelectType { kWindow = 1, kCrossing = 2 }
enum | ShadowFlags { kShadowsCastAndReceive = 0x00, kShadowsDoesNotReceive = 0x01, kShadowsDoesNotCast = 0x02, kShadowsIgnore = kShadowsDoesNotCast | kShadowsDoesNotReceive }
enum | ShowImagesMode { kNeverShow = 0, kAlwaysShow = 1, kBoundingBoxShow = 2 }
enum | SliceModelType { kKeepBothSides = 0x01, kUseCurrentColor = 0x02 }
enum SortEntsFlags {
kSortEntsSelection = 0x01, kSortEntsOsnap = 0x02, kSortEntsRedraw = 0x04, kSortEntsSlide = 0x08,
kSortEntsRegen = 0x10, kSortEntsPlot = 0x20, kSortEntsPsout = 0x40
}
enum SpaceValueType {
kUndefined, kStubPtr, kEndOfFile, kBackwardBranch,
kForwardBranch, kDetour
}
typedef Adesk::UInt32 | SubentType
enum | TableBreakFlowDirection { kTableBreakFlowRight = 0x1, kTableBreakFlowDownOrUp = 0x2, kTableBreakFlowLeft = 0x4 }
enum TableBreakOption {
kTableBreakNone = 0, kTableBreakEnableBreaking = 0x1, kTableBreakRepeatTopLabels = 0x2, kTableBreakRepeatBottomLabels = 0x4,
kTableBreakAllowManualPositions = 0x8, kTableBreakAllowManualHeights = 0x10
}
enum TableCopyOption {
kTableCopyNone = 0, kTableCopyExpandOrContractTable = 0x1, kTableCopySkipContent = 0x2, kTableCopySkipValue = 0x4,
kTableCopySkipField = 0x8, kTableCopySkipFormula = 0x10, kTableCopySkipBlock = 0x20, kTableCopySkipDataLink = 0x40,
kTableCopySkipLabelCell = 0x80, kTableCopySkipDataCell = 0x100, kTableCopySkipFormat = 0x200, kTableCopySkipCellStyle = 0x400,
kTableCopyConvertFormatToOverrides = 0x800, kTableCopySkipCellState = 0x1000, kTableCopySkipContentFormat = 0x2000, kTableCopySkipDissimilarContentFormat = 0x4000,
kTableCopySkipGeometry = 0x8000, kTableCopySkipMerges = 0x10000, kTableCopyFillTarget = 0x20000, kTableCopyOverwriteReadOnlyContent = 0x40000,
kTableCopyOverwriteReadOnlyFormat = 0x80000, kTableCopyOverwriteContentModifiedAfterUpdate = 0x100000, kTableCopyOverwriteFormatModifiedAfterUpdate = 0x200000, kTableCopyOnlyContentModifiedAfterUpdate = 0x400000,
kTableCopyOnlyFormatModifiedAfterUpdate = 0x800000, kTableCopyRowHeight = 0x1000000, kTableCopyColumnWidth = 0x2000000, kTableCopyFullCellState = 0x4000000,
kTableCopyForRountrip = 0x8000000, kTableCopyConvertFieldToValue = 0x10000000, kTableCopySkipFieldTranslation = 0x20000000
}
enum TableFillOption {
kTableFillNone = 0, kTableFillRow = 0x1, kTableFillReverse = 0x2, kTableFillGenerateSeries = 0x4,
kTableFillCopyContent = 0x8, kTableFillCopyFormat = 0x10, kTableFillOverwriteReadOnlyContent = 0x20, kTableFillOverwriteReadOnlyFormat = 0x40
}
enum TableHitItem {
kTableHitNone = 0, kTableHitCell = 0x1, kTableHitRowIndicator = 0x2, kTableHitColumnIndicator = 0x4,
kTableHitGridLine = 0x8
}
enum TableIteratorOption {
kTableIteratorNone = 0, kTableIteratorIterateSelection = 0x1, kTableIteratorIterateRows = 0x2, kTableIteratorIterateColumns = 0x4,
kTableIteratorIterateDataLinks = 0x80, kTableIteratorReverseOrder = 0x8, kTableIteratorSkipReadOnlyContent = 0x10, kTableIteratorSkipReadOnlyFormat = 0x20,
kTableIteratorSkipMerged = 0x40
}
enum TableStyleFlags {
kHorzInsideLineFirst = 0x1, kHorzInsideLineSecond = 0x2, kHorzInsideLineThird = 0x4, kTableStyleModified = 0x8,
kTableStyleDataTypeModified = 0x10
}
enum TextHorzMode {
kTextLeft = 0, kTextCenter = 1, kTextRight = 2, kTextAlign = 3,
kTextMid = 4, kTextFit = 5
}
enum | TextVertMode { kTextBase = 0, kTextBottom = 1, kTextVertMid = 2, kTextTop = 3 }
enum TimeZone {
kInternationalDateLine = -12000, kMidwayIsland = -11000, kHawaii = -10000, kAlaska = -9000,
kPacific = -8000, kMountain = -7000, kArizona = -7001, kMazatlan = -7002,
kCentral = -6000, kCentralAmerica = -6001, kMexicoCity = -6002, kSaskatchewan = -6003,
kEastern = -5000, kIndiana = -5001, kBogota = -5002, kAtlanticCanada = -4000,
kCaracas = -4001, kSantiago = -4002, kNewfoundland = -3300, kBrasilia = -3000,
kBuenosAires = -3001, kGreenland = -3002, kMidAtlantic = -2000, kAzores = -1000,
kCapeVerde = -1001, kUTC = 0, kGMT = 1, kMonrovia = 2,
kBerlin = 1000, kParis = 1001, kPrague = 1002, kSarajevo = 1003,
kWestCentralAfrica = 1004, kAthens = 2000, kEasternEurope = 2001, kCairo = 2002,
kHarare = 2003, kHelsinki = 2004, kJerusalem = 2005, kMoscow = 3000,
kRiyadh = 3001, kBaghdad = 3002, kEastAfrica = 3003, kTehran = 3300,
kAbuDhabi = 4000, kCaucasus = 4001, kKabul = 4300, kEkaterinburg = 5000,
kIslamabad = 5001, kKolkata = 5300, kKathmandu = 5450, kAlmaty = 6000,
kDhaka = 6001, kSriLanka = 6002, kRangoon = 6300, kBangkok = 7000,
kKrasnoyarsk = 7001, kBeijing = 8000, kSingapore = 8001, kTaipei = 8002,
kIrkutsk = 8003, kPerth = 8004, kTokyo = 9000, kSeoul = 9001,
kYakutsk = 9002, kAdelaide = 9300, kDarwin = 9301, kSydney = 10000,
kGuam = 10001, kBrisbane = 10002, kHobart = 10003, kVladivostock = 10004,
kMagadan = 11000, kWellington = 12000, kFiji = 12001, kTonga = 13000
}
enum UnitsValue {
kUnitsUndefined = 0, kUnitsInches = 1, kUnitsFeet = 2, kUnitsMiles = 3,
kUnitsMillimeters = 4, kUnitsCentimeters = 5, kUnitsMeters = 6, kUnitsKilometers = 7,
kUnitsMicroinches = 8, kUnitsMils = 9, kUnitsYards = 10, kUnitsAngstroms = 11,
kUnitsNanometers = 12, kUnitsMicrons = 13, kUnitsDecimeters = 14, kUnitsDekameters = 15,
kUnitsHectometers = 16, kUnitsGigameters = 17, kUnitsAstronomical = 18, kUnitsLightYears = 19,
kUnitsParsecs = 20, kUnitsMax = kUnitsParsecs
}
enum | UpdateDirection { kUpdateDirSourceToData = 0x1, kUpdateDirDataToSource = 0x2 }
enum UpdateOption {
kUpdateOptionNone = 0, kUpdateOptionSkipFormat = 0x20000, kUpdateOptionUpdateRowHeight = 0x40000, kUpdateOptionUpdateColumnWidth = 0x80000,
kUpdateOptionAllowSourceUpdate = 0x100000, kUpdateOptionForceFullSourceUpdate = 0x200000, kUpdateOptionOverwriteContentModifiedAfterUpdate = 0x400000, kUpdateOptionOverwriteFormatModifiedAfterUpdate = 0x800000,
kUpdateOptionForPreview = 0x1000000, kUpdateOptionIncludeXrefs = 0x2000000, kSkipFormatAfterFirstUpdate = 0x4000000
}
enum UpdateThumbnailFlags {
kUpdateModelViews = 0x01, kUpdateSheetViews = 0x02, kUpdateSheets = 0x04, kUpdateWhenAccessed = 0x08,
kUpdateWhenSaving = 0x10
}
enum | Vertex2dType { k2dVertex = 0, k2dSplineCtlVertex = 1, k2dSplineFitVertex = 2, k2dCurveFitVertex = 3 }
enum | Vertex3dType { k3dSimpleVertex = 0, k3dControlVertex = 1, k3dFitVertex = 2 }
enum | Visibility { kInvisible = 1, kVisible = 0 }
enum | VpFreezeOps { kFreeze = 0, kThaw, kReset }
enum XrefNotificationStatus {
kXrfNotifyNone = 0, kXrfNotifyResolvedMatch = 1, kXrfNotifyResolvedElsewhere = 2, kXrfNotifyResolvedWithUpdate = 3,
kXrfNotifyResolvedUpdateAvailable = 4
}
enum XrefStatus {
kXrfNotAnXref = 0, kXrfResolved = 1, kXrfUnloaded = 2, kXrfUnreferenced = 3,
kXrfFileNotFound = 4, kXrfUnresolved = 5
}
The documentation for this struct was generated from the following file:
  • acdb.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDb Member List

This is the complete list of members for AcDb, including all inherited members.

AcDbDwgVersion enum name (defined in AcDb) | AcDb
BoolOperType enum name (defined in AcDb) | AcDb
CellAlignment enum name (defined in AcDb) | AcDb
CellClass enum name (defined in AcDb) | AcDb
CellContentLayout enum name (defined in AcDb) | AcDb
CellContentType enum name (defined in AcDb) | AcDb
CellEdgeMask enum name (defined in AcDb) | AcDb
CellMargin enum name (defined in AcDb) | AcDb
CellOption enum name (defined in AcDb) | AcDb
CellProperty enum name (defined in AcDb) | AcDb
CellState enum name (defined in AcDb) | AcDb
CellType enum name (defined in AcDb) | AcDb
CollisionType enum name (defined in AcDb) | AcDb
CoordAxis enum name (defined in AcDb) | AcDb
CoordSystem enum name (defined in AcDb) | AcDb
DataLinkGetSourceContext enum name (defined in AcDb) | AcDb
DataLinkOption enum name (defined in AcDb) | AcDb
DeepCloneType enum name (defined in AcDb) | AcDb
DimArrowFlags enum name (defined in AcDb) | AcDb
DimblkFlags enum name (defined in AcDb) | AcDb
DragStat enum name (defined in AcDb) | AcDb
DrawOrderFlags enum name (defined in AcDb) | AcDb
DuplicateRecordCloning enum name (defined in AcDb) | AcDb
DwgDataType enum name (defined in AcDb) | AcDb
DxfCode typedef (defined in AcDb) | AcDb
EdgeIndex enum name (defined in AcDb) | AcDb
EndCaps enum name (defined in AcDb) | AcDb
EnhancedBlockEvalType enum name (defined in AcDb) | AcDb
FilerSeekType enum name (defined in AcDb) | AcDb
FilerType enum name (defined in AcDb) | AcDb
FileType enum name (defined in AcDb) | AcDb
FlowDirection enum name (defined in AcDb) | AcDb
GeomId typedef (defined in AcDb) | AcDb
GeomType enum name (defined in AcDb) | AcDb
GridLineStyle enum name (defined in AcDb) | AcDb
GridLineType enum name (defined in AcDb) | AcDb
GridLineTypes enum name (defined in AcDb) | AcDb
GridProperty enum name (defined in AcDb) | AcDb
GripStat enum name (defined in AcDb) | AcDb
GroupOperType enum name (defined in AcDb) | AcDb
IndexCreation enum name (defined in AcDb) | AcDb
Intersect enum name (defined in AcDb) | AcDb
JoinStyle enum name (defined in AcDb) | AcDb
k2000Save enum value (defined in AcDb) | AcDb
k2004Save enum value (defined in AcDb) | AcDb
k2007Save enum value (defined in AcDb) | AcDb
k2010Save enum value (defined in AcDb) | AcDb
k2013Save enum value (defined in AcDb) | AcDb
k2dCubicSplinePoly enum value (defined in AcDb) | AcDb
k2dCurveFitVertex enum value (defined in AcDb) | AcDb
k2dFitCurvePoly enum value (defined in AcDb) | AcDb
k2dQuadSplinePoly enum value (defined in AcDb) | AcDb
k2dSimplePoly enum value (defined in AcDb) | AcDb
k2dSplineCtlVertex enum value (defined in AcDb) | AcDb
k2dSplineFitVertex enum value (defined in AcDb) | AcDb
k2dVertex enum value (defined in AcDb) | AcDb
k3dControlVertex enum value (defined in AcDb) | AcDb
k3dCubicSplinePoly enum value (defined in AcDb) | AcDb
k3dFitVertex enum value (defined in AcDb) | AcDb
k3dQuadSplinePoly enum value (defined in AcDb) | AcDb
k3dSimplePoly enum value (defined in AcDb) | AcDb
k3dSimpleVertex enum value (defined in AcDb) | AcDb
kAbsolutePath enum value (defined in AcDb) | AcDb
kAbuDhabi enum value (defined in AcDb) | AcDb
kAdd enum value (defined in AcDb) | AcDb
kAdelaide enum value (defined in AcDb) | AcDb
kAlaska enum value (defined in AcDb) | AcDb
kAllCellStates enum value (defined in AcDb) | AcDb
kAllGridLines enum value (defined in AcDb) | AcDb
kAllGridLineTypes enum value (defined in AcDb) | AcDb
kAllRows enum value (defined in AcDb) | AcDb
kAllRowTypes enum value (defined in AcDb) | AcDb
kAlmaty enum value (defined in AcDb) | AcDb
kAlwaysSave enum value (defined in AcDb) | AcDb
kAlwaysShow enum value (defined in AcDb) | AcDb
kArizona enum value (defined in AcDb) | AcDb
kAthens enum value (defined in AcDb) | AcDb
kAtlanticCanada enum value (defined in AcDb) | AcDb
kAtLeast enum value (defined in AcDb) | AcDb
kAzores enum value (defined in AcDb) | AcDb
kBackView enum value (defined in AcDb) | AcDb
kBackwardBranch enum value (defined in AcDb) | AcDb
kBagFiler enum value (defined in AcDb) | AcDb
kBaghdad enum value (defined in AcDb) | AcDb
kBangkok enum value (defined in AcDb) | AcDb
kBeijing enum value (defined in AcDb) | AcDb
kBerlin enum value (defined in AcDb) | AcDb
kBezierSurfaceMesh enum value (defined in AcDb) | AcDb
kBlockCell enum value (defined in AcDb) | AcDb
kBogota enum value (defined in AcDb) | AcDb
kBoolIntersect enum value (defined in AcDb) | AcDb
kBoolSubtract enum value (defined in AcDb) | AcDb
kBoolUnite enum value (defined in AcDb) | AcDb
kBottomCenter enum value (defined in AcDb) | AcDb
kBottomLeft enum value (defined in AcDb) | AcDb
kBottomMask enum value (defined in AcDb) | AcDb
kBottomRight enum value (defined in AcDb) | AcDb
kBottomView enum value (defined in AcDb) | AcDb
kBoundingBoxShow enum value (defined in AcDb) | AcDb
kBrasilia enum value (defined in AcDb) | AcDb
kBrisbane enum value (defined in AcDb) | AcDb
kBtoT enum value (defined in AcDb) | AcDb
kBuenosAires enum value (defined in AcDb) | AcDb
kByBlock enum value (defined in AcDb) | AcDb
kByColor enum value (defined in AcDb) | AcDb
kByLayer enum value (defined in AcDb) | AcDb
kCairo enum value (defined in AcDb) | AcDb
kCapeVerde enum value (defined in AcDb) | AcDb
kCaracas enum value (defined in AcDb) | AcDb
kCaucasus enum value (defined in AcDb) | AcDb
kCellClassData enum value (defined in AcDb) | AcDb
kCellClassLabel enum value (defined in AcDb) | AcDb
kCellClassNone enum value (defined in AcDb) | AcDb
kCellContentLayoutFlow enum value (defined in AcDb) | AcDb
kCellContentLayoutStackedHorizontal enum value (defined in AcDb) | AcDb
kCellContentLayoutStackedVertical enum value (defined in AcDb) | AcDb
kCellContentTypeBlock enum value (defined in AcDb) | AcDb
kCellContentTypeField enum value (defined in AcDb) | AcDb
kCellContentTypeUnknown enum value (defined in AcDb) | AcDb
kCellContentTypeValue enum value (defined in AcDb) | AcDb
kCellMarginBottom enum value (defined in AcDb) | AcDb
kCellMarginHorzSpacing enum value (defined in AcDb) | AcDb
kCellMarginLeft enum value (defined in AcDb) | AcDb
kCellMarginRight enum value (defined in AcDb) | AcDb
kCellMarginTop enum value (defined in AcDb) | AcDb
kCellMarginVertSpacing enum value (defined in AcDb) | AcDb
kCellOptionNone enum value (defined in AcDb) | AcDb
kCellPropAlignment enum value (defined in AcDb) | AcDb
kCellPropAll enum value (defined in AcDb) | AcDb
kCellPropAutoScale enum value (defined in AcDb) | AcDb
kCellPropBackgroundColor enum value (defined in AcDb) | AcDb
kCellPropBitProperties enum value (defined in AcDb) | AcDb
kCellPropContent enum value (defined in AcDb) | AcDb
kCellPropContentColor enum value (defined in AcDb) | AcDb
kCellPropContentLayout enum value (defined in AcDb) | AcDb
kCellPropDataFormat enum value (defined in AcDb) | AcDb
kCellPropDataType enum value (defined in AcDb) | AcDb
kCellPropDataTypeAndFormat enum value (defined in AcDb) | AcDb
kCellPropFlowDirBtoT enum value (defined in AcDb) | AcDb
kCellPropInvalid enum value (defined in AcDb) | AcDb
kCellPropMarginBottom enum value (defined in AcDb) | AcDb
kCellPropMarginHorzSpacing enum value (defined in AcDb) | AcDb
kCellPropMarginLeft enum value (defined in AcDb) | AcDb
kCellPropMarginRight enum value (defined in AcDb) | AcDb
kCellPropMarginTop enum value (defined in AcDb) | AcDb
kCellPropMarginVertSpacing enum value (defined in AcDb) | AcDb
kCellPropMergeAll enum value (defined in AcDb) | AcDb
kCellPropRotation enum value (defined in AcDb) | AcDb
kCellPropScale enum value (defined in AcDb) | AcDb
kCellPropTextHeight enum value (defined in AcDb) | AcDb
kCellPropTextStyle enum value (defined in AcDb) | AcDb
kCellStateContentLocked enum value (defined in AcDb) | AcDb
kCellStateContentModifiedAfterUpdate enum value (defined in AcDb) | AcDb
kCellStateContentReadOnly enum value (defined in AcDb) | AcDb
kCellStateFormatLocked enum value (defined in AcDb) | AcDb
kCellStateFormatModifiedAfterUpdate enum value (defined in AcDb) | AcDb
kCellStateFormatReadOnly enum value (defined in AcDb) | AcDb
kCellStateLinked enum value (defined in AcDb) | AcDb
kCellStateNone enum value (defined in AcDb) | AcDb
kCentral enum value (defined in AcDb) | AcDb
kCentralAmerica enum value (defined in AcDb) | AcDb
kCircleGeom enum value (defined in AcDb) | AcDb
kClassSubentType enum value (defined in AcDb) | AcDb
kCollisionTypeNone enum value (defined in AcDb) | AcDb
kCollisionTypeSolid enum value (defined in AcDb) | AcDb
kContinuous enum value (defined in AcDb) | AcDb
kCopyFiler enum value (defined in AcDb) | AcDb
kCreate enum value (defined in AcDb) | AcDb
kCrossing enum value (defined in AcDb) | AcDb
kCubicSurfaceMesh enum value (defined in AcDb) | AcDb
kCurDisplayCS enum value (defined in AcDb) | AcDb
kDarwin enum value (defined in AcDb) | AcDb
kData enum value (defined in AcDb) | AcDb
kDataLinkGetSourceContextEtransmit enum value (defined in AcDb) | AcDb
kDataLinkGetSourceContextFileWatcher enum value (defined in AcDb) | AcDb
kDataLinkGetSourceContextOrignalPath enum value (defined in AcDb) | AcDb
kDataLinkGetSourceContextOther enum value (defined in AcDb) | AcDb
kDataLinkGetSourceContextUnknown enum value (defined in AcDb) | AcDb
kDataLinkGetSourceContextXrefManager enum value (defined in AcDb) | AcDb
kDataLinkHasCutomData enum value (defined in AcDb) | AcDb
kDataLinkOptionAnonymous enum value (defined in AcDb) | AcDb
kDataLinkOptionDisableInLT enum value (defined in AcDb) | AcDb
kDataLinkOptionNone enum value (defined in AcDb) | AcDb
kDataLinkOptionPersistCache enum value (defined in AcDb) | AcDb
kDataRow enum value (defined in AcDb) | AcDb
kDcBlock enum value (defined in AcDb) | AcDb
kDcCopy enum value (defined in AcDb) | AcDb
kDcExplode enum value (defined in AcDb) | AcDb
kDcInsert enum value (defined in AcDb) | AcDb
kDcInsertCopy enum value (defined in AcDb) | AcDb
kDcObjects enum value (defined in AcDb) | AcDb
kDcSymTableMerge enum value (defined in AcDb) | AcDb
kDcWblkObjects enum value (defined in AcDb) | AcDb
kDcWblock enum value (defined in AcDb) | AcDb
kDcXrefBind enum value (defined in AcDb) | AcDb
kDcXrefInsert enum value (defined in AcDb) | AcDb
kDeepCloneFiler enum value (defined in AcDb) | AcDb
kDefault enum value (defined in AcDb) | AcDb
kDefPoints enum value (defined in AcDb) | AcDb
kDegrees000 enum value (defined in AcDb) | AcDb
kDegrees090 enum value (defined in AcDb) | AcDb
kDegrees180 enum value (defined in AcDb) | AcDb
kDegrees270 enum value (defined in AcDb) | AcDb
kDegreesUnknown enum value (defined in AcDb) | AcDb
kDetour enum value (defined in AcDb) | AcDb
kDhaka enum value (defined in AcDb) | AcDb
kDHL_1001 enum value (defined in AcDb) | AcDb
kDHL_1002 enum value (defined in AcDb) | AcDb
kDHL_1003 enum value (defined in AcDb) | AcDb
kDHL_1004 enum value (defined in AcDb) | AcDb
kDHL_1005 enum value (defined in AcDb) | AcDb
kDHL_1006 enum value (defined in AcDb) | AcDb
kDHL_1007 enum value (defined in AcDb) | AcDb
kDHL_1008 enum value (defined in AcDb) | AcDb
kDHL_1009 enum value (defined in AcDb) | AcDb
kDHL_1010 enum value (defined in AcDb) | AcDb
kDHL_1011 enum value (defined in AcDb) | AcDb
kDHL_1012 enum value (defined in AcDb) | AcDb
kDHL_1013 enum value (defined in AcDb) | AcDb
kDHL_1014 enum value (defined in AcDb) | AcDb
kDHL_1015 enum value (defined in AcDb) | AcDb
kDHL_1021 enum value (defined in AcDb) | AcDb
kDHL_1024 enum value (defined in AcDb) | AcDb
kDHL_1027 enum value (defined in AcDb) | AcDb
kDHL_1500 enum value (defined in AcDb) | AcDb
kDHL_1800 enum value (defined in AcDb) | AcDb
kDHL_1800a enum value (defined in AcDb) | AcDb
kDHL_2100a enum value (defined in AcDb) | AcDb
kDHL_2400a enum value (defined in AcDb) | AcDb
kDHL_2700a enum value (defined in AcDb) | AcDb
kDHL_AC1_2 enum value (defined in AcDb) | AcDb
kDHL_AC1_40 enum value (defined in AcDb) | AcDb
kDHL_AC1_50 enum value (defined in AcDb) | AcDb
kDHL_AC2_10 enum value (defined in AcDb) | AcDb
kDHL_AC2_20 enum value (defined in AcDb) | AcDb
kDHL_AC2_21 enum value (defined in AcDb) | AcDb
kDHL_AC2_22 enum value (defined in AcDb) | AcDb
kDHL_CURRENT enum value (defined in AcDb) | AcDb
kDHL_Max enum value (defined in AcDb) | AcDb
kDHL_MC0_0 enum value (defined in AcDb) | AcDb
kDHL_Newest enum value (defined in AcDb) | AcDb
kDHL_Unknown enum value (defined in AcDb) | AcDb
kDimblk enum value (defined in AcDb) | AcDb
kDimblk1 enum value (defined in AcDb) | AcDb
kDimblk2 enum value (defined in AcDb) | AcDb
kDimDataToBeDeleted enum value (defined in AcDb) | AcDb
kDimLdrBlk enum value (defined in AcDb) | AcDb
kDragAbort enum value (defined in AcDb) | AcDb
kDragEnd enum value (defined in AcDb) | AcDb
kDragStart enum value (defined in AcDb) | AcDb
kDrawOrderInheritanceOn enum value (defined in AcDb) | AcDb
kDrawOrderInPlaceEditOn enum value (defined in AcDb) | AcDb
kDrcIgnore enum value (defined in AcDb) | AcDb
kDrcMangleName enum value (defined in AcDb) | AcDb
kDrcNotApplicable enum value (defined in AcDb) | AcDb
kDrcReplace enum value (defined in AcDb) | AcDb
kDrcUnmangleName enum value (defined in AcDb) | AcDb
kDrcXrefMangleName enum value (defined in AcDb) | AcDb
kDwg enum value (defined in AcDb) | AcDb
kDwg3Real enum value (defined in AcDb) | AcDb
kDwgBChunk enum value (defined in AcDb) | AcDb
kDwgHandle enum value (defined in AcDb) | AcDb
kDwgHardOwnershipId enum value (defined in AcDb) | AcDb
kDwgHardPointerId enum value (defined in AcDb) | AcDb
kDwgInt16 enum value (defined in AcDb) | AcDb
kDwgInt32 enum value (defined in AcDb) | AcDb
kDwgInt64 enum value (defined in AcDb) | AcDb
kDwgInt8 enum value (defined in AcDb) | AcDb
kDwgNotRecognized enum value (defined in AcDb) | AcDb
kDwgNull enum value (defined in AcDb) | AcDb
kDwgReal enum value (defined in AcDb) | AcDb
kDwgSoftOwnershipId enum value (defined in AcDb) | AcDb
kDwgSoftPointerId enum value (defined in AcDb) | AcDb
kDwgText enum value (defined in AcDb) | AcDb
kDxb enum value (defined in AcDb) | AcDb
kDxf enum value (defined in AcDb) | AcDb
kDxfAlpha enum value (defined in AcDb) | AcDb
kDxfAngle enum value (defined in AcDb) | AcDb
kDxfArbHandle enum value (defined in AcDb) | AcDb
kDxfAttributePrompt enum value (defined in AcDb) | AcDb
kDxfAttributeTag enum value (defined in AcDb) | AcDb
kDxfBinaryChunk enum value (defined in AcDb) | AcDb
kDxfBlockName enum value (defined in AcDb) | AcDb
kDxfBool enum value (defined in AcDb) | AcDb
kDxfCircleSides enum value (defined in AcDb) | AcDb
kDxfCLShapeName enum value (defined in AcDb) | AcDb
kDxfCLShapeText enum value (defined in AcDb) | AcDb
kDxfColor enum value (defined in AcDb) | AcDb
kDxfColorName enum value (defined in AcDb) | AcDb
kDxfColorRGB enum value (defined in AcDb) | AcDb
kDxfComment enum value (defined in AcDb) | AcDb
kDxfControlString enum value (defined in AcDb) | AcDb
kDxfDashLength enum value (defined in AcDb) | AcDb
kDxfDefaultLightingOn enum value (defined in AcDb) | AcDb
kDxfDefaultLightingType enum value (defined in AcDb) | AcDb
kDxfDescription enum value (defined in AcDb) | AcDb
kDxfDimAPostStr enum value (defined in AcDb) | AcDb
kDxfDimBlk enum value (defined in AcDb) | AcDb
kDxfDimBlk1 enum value (defined in AcDb) | AcDb
kDxfDimBlk2 enum value (defined in AcDb) | AcDb
kDxfDimPostStr enum value (defined in AcDb) | AcDb
kDxfDimStyleName enum value (defined in AcDb) | AcDb
kDxfDimVarHandle enum value (defined in AcDb) | AcDb
kDxfDragVisualStyleId enum value (defined in AcDb) | AcDb
kDxfEdgeStyleId enum value (defined in AcDb) | AcDb
kDxfElevation enum value (defined in AcDb) | AcDb
kDxfEmbeddedObjectStart enum value (defined in AcDb) | AcDb
kDxfEnd enum value (defined in AcDb) | AcDb
kDxfFaceStyleId enum value (defined in AcDb) | AcDb
kDxfFirstEntId enum value (defined in AcDb) | AcDb
kDxfGradientAngle enum value (defined in AcDb) | AcDb
kDxfGradientColCount enum value (defined in AcDb) | AcDb
kDxfGradientColVal enum value (defined in AcDb) | AcDb
kDxfGradientName enum value (defined in AcDb) | AcDb
kDxfGradientObjType enum value (defined in AcDb) | AcDb
kDxfGradientPatType enum value (defined in AcDb) | AcDb
kDxfGradientShift enum value (defined in AcDb) | AcDb
kDxfGradientTintType enum value (defined in AcDb) | AcDb
kDxfGradientTintVal enum value (defined in AcDb) | AcDb
kDxfHandle enum value (defined in AcDb) | AcDb
kDxfHardOwnershipId enum value (defined in AcDb) | AcDb
kDxfHardPointerId enum value (defined in AcDb) | AcDb
kDxfHasSubentities enum value (defined in AcDb) | AcDb
kDxfHeaderId enum value (defined in AcDb) | AcDb
kDxfInt16 enum value (defined in AcDb) | AcDb
kDxfInt32 enum value (defined in AcDb) | AcDb
kDxfInt64 enum value (defined in AcDb) | AcDb
kDxfInt8 enum value (defined in AcDb) | AcDb
kDxfInvalid enum value (defined in AcDb) | AcDb
kDxfLayerLinetype enum value (defined in AcDb) | AcDb
kDxfLayerName enum value (defined in AcDb) | AcDb
kDxfLayoutName enum value (defined in AcDb) | AcDb
kDxfLinetypeAlign enum value (defined in AcDb) | AcDb
kDxfLinetypeElement enum value (defined in AcDb) | AcDb
kDxfLinetypeName enum value (defined in AcDb) | AcDb
kDxfLinetypePDC enum value (defined in AcDb) | AcDb
kDxfLinetypeProse enum value (defined in AcDb) | AcDb
kDxfLinetypeScale enum value (defined in AcDb) | AcDb
kDxfLineWeight enum value (defined in AcDb) | AcDb
kDxfLiveSectionId enum value (defined in AcDb) | AcDb
kDxfLiveSectionName enum value (defined in AcDb) | AcDb
kDxfMaterialId enum value (defined in AcDb) | AcDb
kDxfMlineOffset enum value (defined in AcDb) | AcDb
kDxfMstyleName enum value (defined in AcDb) | AcDb
kDxfNormalX enum value (defined in AcDb) | AcDb
kDxfNormalY enum value (defined in AcDb) | AcDb
kDxfNormalZ enum value (defined in AcDb) | AcDb
kDxfObjVisualStyleId enum value (defined in AcDb) | AcDb
kDxfOperator enum value (defined in AcDb) | AcDb
kDxfPixelScale enum value (defined in AcDb) | AcDb
kDxfPlotStyleNameId enum value (defined in AcDb) | AcDb
kDxfPlotStyleNameType enum value (defined in AcDb) | AcDb
kDxfPReactors enum value (defined in AcDb) | AcDb
kDxfReal enum value (defined in AcDb) | AcDb
kDxfRegAppFlags enum value (defined in AcDb) | AcDb
kDxfRegAppName enum value (defined in AcDb) | AcDb
kDxfRenderMode enum value (defined in AcDb) | AcDb
kDxfShadePlotId enum value (defined in AcDb) | AcDb
kDxfShadowFlags enum value (defined in AcDb) | AcDb
kDxfShapeName enum value (defined in AcDb) | AcDb
kDxfShapeScale enum value (defined in AcDb) | AcDb
kDxfShapeXOffset enum value (defined in AcDb) | AcDb
kDxfShapeYOffset enum value (defined in AcDb) | AcDb
kDxfSoftOwnershipId enum value (defined in AcDb) | AcDb
kDxfSoftPointerId enum value (defined in AcDb) | AcDb
kDxfStart enum value (defined in AcDb) | AcDb
kDxfSubclass enum value (defined in AcDb) | AcDb
kDxfSunId enum value (defined in AcDb) | AcDb
kDxfSymbolTableName enum value (defined in AcDb) | AcDb
kDxfSymTableRecComments enum value (defined in AcDb) | AcDb
kDxfSymTableRecName enum value (defined in AcDb) | AcDb
kDxfText enum value (defined in AcDb) | AcDb
kDxfTextBigFontFile enum value (defined in AcDb) | AcDb
kDxfTextFontFile enum value (defined in AcDb) | AcDb
kDxfTextStyleName enum value (defined in AcDb) | AcDb
kDxfThickness enum value (defined in AcDb) | AcDb
kDxfTxtSize enum value (defined in AcDb) | AcDb
kDxfTxtStyleFlags enum value (defined in AcDb) | AcDb
kDxfTxtStylePSize enum value (defined in AcDb) | AcDb
kDxfTxtStyleXScale enum value (defined in AcDb) | AcDb
kDxfUCSOrg enum value (defined in AcDb) | AcDb
kDxfUCSOriX enum value (defined in AcDb) | AcDb
kDxfUCSOriY enum value (defined in AcDb) | AcDb
kDxfVertexIdentifier enum value (defined in AcDb) | AcDb
kDxfViewBackClip enum value (defined in AcDb) | AcDb
kDxfViewBackgroundId enum value (defined in AcDb) | AcDb
kDxfViewBrightness enum value (defined in AcDb) | AcDb
kDxfViewContrast enum value (defined in AcDb) | AcDb
kDxfViewFrontClip enum value (defined in AcDb) | AcDb
kDxfViewHeight enum value (defined in AcDb) | AcDb
kDxfViewLensLength enum value (defined in AcDb) | AcDb
kDxfViewMode enum value (defined in AcDb) | AcDb
kDxfViewportActive enum value (defined in AcDb) | AcDb
kDxfViewportAspect enum value (defined in AcDb) | AcDb
kDxfViewportGrid enum value (defined in AcDb) | AcDb
kDxfViewportGridDisplay enum value (defined in AcDb) | AcDb
kDxfViewportGridMajor enum value (defined in AcDb) | AcDb
kDxfViewportHeight enum value (defined in AcDb) | AcDb
kDxfViewportIcon enum value (defined in AcDb) | AcDb
kDxfViewportNumber enum value (defined in AcDb) | AcDb
kDxfViewportSnap enum value (defined in AcDb) | AcDb
kDxfViewportSnapAngle enum value (defined in AcDb) | AcDb
kDxfViewportSnapPair enum value (defined in AcDb) | AcDb
kDxfViewportSnapStyle enum value (defined in AcDb) | AcDb
kDxfViewportTwist enum value (defined in AcDb) | AcDb
kDxfViewportVisibility enum value (defined in AcDb) | AcDb
kDxfViewportZoom enum value (defined in AcDb) | AcDb
kDxfViewWidth enum value (defined in AcDb) | AcDb
kDxfVisibility enum value (defined in AcDb) | AcDb
kDxfVisualStyleId enum value (defined in AcDb) | AcDb
kDxfVpVisualStyleId enum value (defined in AcDb) | AcDb
kDxfXCoord enum value (defined in AcDb) | AcDb
kDxfXdAsciiString enum value (defined in AcDb) | AcDb
kDxfXDataStart enum value (defined in AcDb) | AcDb
kDxfXdBinaryChunk enum value (defined in AcDb) | AcDb
kDxfXdControlString enum value (defined in AcDb) | AcDb
kDxfXdDist enum value (defined in AcDb) | AcDb
kDxfXdHandle enum value (defined in AcDb) | AcDb
kDxfXDictionary enum value (defined in AcDb) | AcDb
kDxfXdInteger16 enum value (defined in AcDb) | AcDb
kDxfXdInteger32 enum value (defined in AcDb) | AcDb
kDxfXdLayerName enum value (defined in AcDb) | AcDb
kDxfXdReal enum value (defined in AcDb) | AcDb
kDxfXdScale enum value (defined in AcDb) | AcDb
kDxfXdWorldXCoord enum value (defined in AcDb) | AcDb
kDxfXdWorldXDir enum value (defined in AcDb) | AcDb
kDxfXdWorldXDisp enum value (defined in AcDb) | AcDb
kDxfXdWorldYCoord enum value (defined in AcDb) | AcDb
kDxfXdWorldYDir enum value (defined in AcDb) | AcDb
kDxfXdWorldYDisp enum value (defined in AcDb) | AcDb
kDxfXdWorldZCoord enum value (defined in AcDb) | AcDb
kDxfXdWorldZDir enum value (defined in AcDb) | AcDb
kDxfXdWorldZDisp enum value (defined in AcDb) | AcDb
kDxfXdXCoord enum value (defined in AcDb) | AcDb
kDxfXdYCoord enum value (defined in AcDb) | AcDb
kDxfXdZCoord enum value (defined in AcDb) | AcDb
kDxfXInt16 enum value (defined in AcDb) | AcDb
kDxfXReal enum value (defined in AcDb) | AcDb
kDxfXRefPath enum value (defined in AcDb) | AcDb
kDxfXTextString enum value (defined in AcDb) | AcDb
kDxfXXInt16 enum value (defined in AcDb) | AcDb
kDxfXXXInt16 enum value (defined in AcDb) | AcDb
kDxfYCoord enum value (defined in AcDb) | AcDb
kDxfZCoord enum value (defined in AcDb) | AcDb
kEastAfrica enum value (defined in AcDb) | AcDb
kEastern enum value (defined in AcDb) | AcDb
kEasternEurope enum value (defined in AcDb) | AcDb
kEdgeSubentType enum value (defined in AcDb) | AcDb
kEkaterinburg enum value (defined in AcDb) | AcDb
kEndCapAngle enum value (defined in AcDb) | AcDb
kEndCapNone enum value (defined in AcDb) | AcDb
kEndCapRound enum value (defined in AcDb) | AcDb
kEndCapSquare enum value (defined in AcDb) | AcDb
kEndOfFile enum value (defined in AcDb) | AcDb
kEnglish enum value (defined in AcDb) | AcDb
kEntityCS enum value (defined in AcDb) | AcDb
kEvalAllNewLayers enum value (defined in AcDb) | AcDb
kEvalNewXrefLayers enum value (defined in AcDb) | AcDb
kExactly enum value (defined in AcDb) | AcDb
kExtendArg enum value (defined in AcDb) | AcDb
kExtendBoth enum value (defined in AcDb) | AcDb
kExtendThis enum value (defined in AcDb) | AcDb
kFaceSubentType enum value (defined in AcDb) | AcDb
kFiji enum value (defined in AcDb) | AcDb
kFileFiler enum value (defined in AcDb) | AcDb
kFirstArrow enum value (defined in AcDb) | AcDb
kForNotify enum value (defined in AcDb) | AcDb
kForRead enum value (defined in AcDb) | AcDb
kForRefresh enum value (defined in AcDb) | AcDb
kForUpdate enum value (defined in AcDb) | AcDb
kForwardBranch enum value (defined in AcDb) | AcDb
kForWrite enum value (defined in AcDb) | AcDb
kFreeze enum value (defined in AcDb) | AcDb
kFrontView enum value (defined in AcDb) | AcDb
kGlobal enum value (defined in AcDb) | AcDb
kGMT enum value (defined in AcDb) | AcDb
kGreenland enum value (defined in AcDb) | AcDb
kGridLineStyleDouble enum value (defined in AcDb) | AcDb
kGridLineStyleSingle enum value (defined in AcDb) | AcDb
kGridPropAll enum value (defined in AcDb) | AcDb
kGridPropColor enum value (defined in AcDb) | AcDb
kGridPropDoubleLineSpacing enum value (defined in AcDb) | AcDb
kGridPropInvalid enum value (defined in AcDb) | AcDb
kGridPropLineStyle enum value (defined in AcDb) | AcDb
kGridPropLinetype enum value (defined in AcDb) | AcDb
kGridPropLineWeight enum value (defined in AcDb) | AcDb
kGridPropVisibility enum value (defined in AcDb) | AcDb
kGripsDone enum value (defined in AcDb) | AcDb
kGripsToBeDeleted enum value (defined in AcDb) | AcDb
kGrpDesc enum value (defined in AcDb) | AcDb
kGrpFlags enum value (defined in AcDb) | AcDb
kGuam enum value (defined in AcDb) | AcDb
kHarare enum value (defined in AcDb) | AcDb
kHardOwnershipRef enum value (defined in AcDb) | AcDb
kHardPointerRef enum value (defined in AcDb) | AcDb
kHawaii enum value (defined in AcDb) | AcDb
kHeader enum value (defined in AcDb) | AcDb
kHeaderRow enum value (defined in AcDb) | AcDb
kHelsinki enum value (defined in AcDb) | AcDb
kHobart enum value (defined in AcDb) | AcDb
kHorzBottom enum value (defined in AcDb) | AcDb
kHorzGridLineTypes enum value (defined in AcDb) | AcDb
kHorzInside enum value (defined in AcDb) | AcDb
kHorzInsideLineFirst enum value (defined in AcDb) | AcDb
kHorzInsideLineSecond enum value (defined in AcDb) | AcDb
kHorzInsideLineThird enum value (defined in AcDb) | AcDb
kHorzTop enum value (defined in AcDb) | AcDb
kIdFiler enum value (defined in AcDb) | AcDb
kIdXlateFiler enum value (defined in AcDb) | AcDb
kIndexByLayer enum value (defined in AcDb) | AcDb
kIndexSpatially enum value (defined in AcDb) | AcDb
kIndiana enum value (defined in AcDb) | AcDb
kInheritCellFormat enum value (defined in AcDb) | AcDb
kInitialization enum value (defined in AcDb) | AcDb
kInnerGridLineTypes enum value (defined in AcDb) | AcDb
kInsert enum value (defined in AcDb) | AcDb
kInternationalDateLine enum value (defined in AcDb) | AcDb
kInvalidGeom enum value (defined in AcDb) | AcDb
kInvalidGridLine enum value (defined in AcDb) | AcDb
kInvisible enum value (defined in AcDb) | AcDb
kIrkutsk enum value (defined in AcDb) | AcDb
kIslamabad enum value (defined in AcDb) | AcDb
kJerusalem enum value (defined in AcDb) | AcDb
kJnStylAngle enum value (defined in AcDb) | AcDb
kJnStylFlat enum value (defined in AcDb) | AcDb
kJnStylNone enum value (defined in AcDb) | AcDb
kJnStylRound enum value (defined in AcDb) | AcDb
kKabul enum value (defined in AcDb) | AcDb
kKathmandu enum value (defined in AcDb) | AcDb
kKeepBothSides enum value (defined in AcDb) | AcDb
kKolkata enum value (defined in AcDb) | AcDb
kKrasnoyarsk enum value (defined in AcDb) | AcDb
kLeftMask enum value (defined in AcDb) | AcDb
kLeftView enum value (defined in AcDb) | AcDb
kLightingUnitsAmerican enum value (defined in AcDb) | AcDb
kLightingUnitsGeneric enum value (defined in AcDb) | AcDb
kLightingUnitsInternational enum value (defined in AcDb) | AcDb
kLinear enum value (defined in AcDb) | AcDb
kLineGeom enum value (defined in AcDb) | AcDb
kLnWt000 enum value (defined in AcDb) | AcDb
kLnWt005 enum value (defined in AcDb) | AcDb
kLnWt009 enum value (defined in AcDb) | AcDb
kLnWt013 enum value (defined in AcDb) | AcDb
kLnWt015 enum value (defined in AcDb) | AcDb
kLnWt018 enum value (defined in AcDb) | AcDb
kLnWt020 enum value (defined in AcDb) | AcDb
kLnWt025 enum value (defined in AcDb) | AcDb
kLnWt030 enum value (defined in AcDb) | AcDb
kLnWt035 enum value (defined in AcDb) | AcDb
kLnWt040 enum value (defined in AcDb) | AcDb
kLnWt050 enum value (defined in AcDb) | AcDb
kLnWt053 enum value (defined in AcDb) | AcDb
kLnWt060 enum value (defined in AcDb) | AcDb
kLnWt070 enum value (defined in AcDb) | AcDb
kLnWt080 enum value (defined in AcDb) | AcDb
kLnWt090 enum value (defined in AcDb) | AcDb
kLnWt100 enum value (defined in AcDb) | AcDb
kLnWt106 enum value (defined in AcDb) | AcDb
kLnWt120 enum value (defined in AcDb) | AcDb
kLnWt140 enum value (defined in AcDb) | AcDb
kLnWt158 enum value (defined in AcDb) | AcDb
kLnWt200 enum value (defined in AcDb) | AcDb
kLnWt211 enum value (defined in AcDb) | AcDb
kLnWtByBlock enum value (defined in AcDb) | AcDb
kLnWtByLayer enum value (defined in AcDb) | AcDb
kLnWtByLwDefault enum value (defined in AcDb) | AcDb
kLoftAlignDirection enum value (defined in AcDb) | AcDb
kLoftAllNormal enum value (defined in AcDb) | AcDb
kLoftClose enum value (defined in AcDb) | AcDb
kLoftDefault enum value (defined in AcDb) | AcDb
kLoftEndsNormal enum value (defined in AcDb) | AcDb
kLoftFirstNormal enum value (defined in AcDb) | AcDb
kLoftLastNormal enum value (defined in AcDb) | AcDb
kLoftNoParam enum value (defined in AcDb) | AcDb
kLoftNoTwist enum value (defined in AcDb) | AcDb
kLoftRuled enum value (defined in AcDb) | AcDb
kLoftSimplify enum value (defined in AcDb) | AcDb
kLoftSmooth enum value (defined in AcDb) | AcDb
kLoftUseDraftAngles enum value (defined in AcDb) | AcDb
kMagadan enum value (defined in AcDb) | AcDb
kMazatlan enum value (defined in AcDb) | AcDb
kMEdge1 enum value (defined in AcDb) | AcDb
kMEdge2 enum value (defined in AcDb) | AcDb
kMEdge3 enum value (defined in AcDb) | AcDb
kMEdge4 enum value (defined in AcDb) | AcDb
kMergeCellStyleConvertDuplicatesToOverrides enum value (defined in AcDb) | AcDb
kMergeCellStyleCopyDuplicates enum value (defined in AcDb) | AcDb
kMergeCellStyleIgnoreNewStyles enum value (defined in AcDb) | AcDb
kMergeCellStyleNone enum value (defined in AcDb) | AcDb
kMergeCellStyleOverwriteDuplicates enum value (defined in AcDb) | AcDb
kMetric enum value (defined in AcDb) | AcDb
kMexicoCity enum value (defined in AcDb) | AcDb
kMidAtlantic enum value (defined in AcDb) | AcDb
kMiddleCenter enum value (defined in AcDb) | AcDb
kMiddleLeft enum value (defined in AcDb) | AcDb
kMiddleRight enum value (defined in AcDb) | AcDb
kMidwayIsland enum value (defined in AcDb) | AcDb
kMissing enum value (defined in AcDb) | AcDb
kMlineSubentCache enum value (defined in AcDb) | AcDb
kModel enum value (defined in AcDb) | AcDb
kMonrovia enum value (defined in AcDb) | AcDb
kMoscow enum value (defined in AcDb) | AcDb
kMountain enum value (defined in AcDb) | AcDb
kMPoint1 enum value (defined in AcDb) | AcDb
kMPoint2 enum value (defined in AcDb) | AcDb
kMPoint3 enum value (defined in AcDb) | AcDb
kMPoint4 enum value (defined in AcDb) | AcDb
kMRelease0 enum value (defined in AcDb) | AcDb
kMRelease1 enum value (defined in AcDb) | AcDb
kMRelease10 enum value (defined in AcDb) | AcDb
kMRelease100 enum value (defined in AcDb) | AcDb
kMRelease101 enum value (defined in AcDb) | AcDb
kMRelease102 enum value (defined in AcDb) | AcDb
kMRelease103 enum value (defined in AcDb) | AcDb
kMRelease104 enum value (defined in AcDb) | AcDb
kMRelease105 enum value (defined in AcDb) | AcDb
kMRelease106 enum value (defined in AcDb) | AcDb
kMRelease107 enum value (defined in AcDb) | AcDb
kMRelease108 enum value (defined in AcDb) | AcDb
kMRelease109 enum value (defined in AcDb) | AcDb
kMRelease11 enum value (defined in AcDb) | AcDb
kMRelease110 enum value (defined in AcDb) | AcDb
kMRelease111 enum value (defined in AcDb) | AcDb
kMRelease112 enum value (defined in AcDb) | AcDb
kMRelease113 enum value (defined in AcDb) | AcDb
kMRelease114 enum value (defined in AcDb) | AcDb
kMRelease12 enum value (defined in AcDb) | AcDb
kMRelease13 enum value (defined in AcDb) | AcDb
kMRelease14 enum value (defined in AcDb) | AcDb
kMRelease15 enum value (defined in AcDb) | AcDb
kMRelease16 enum value (defined in AcDb) | AcDb
kMRelease17 enum value (defined in AcDb) | AcDb
kMRelease18 enum value (defined in AcDb) | AcDb
kMRelease19 enum value (defined in AcDb) | AcDb
kMRelease2 enum value (defined in AcDb) | AcDb
kMRelease20 enum value (defined in AcDb) | AcDb
kMRelease2010Newest enum value (defined in AcDb) | AcDb
kMRelease21 enum value (defined in AcDb) | AcDb
kMRelease22 enum value (defined in AcDb) | AcDb
kMRelease23 enum value (defined in AcDb) | AcDb
kMRelease24 enum value (defined in AcDb) | AcDb
kMRelease25 enum value (defined in AcDb) | AcDb
kMRelease26 enum value (defined in AcDb) | AcDb
kMRelease27 enum value (defined in AcDb) | AcDb
kMRelease28 enum value (defined in AcDb) | AcDb
kMRelease29 enum value (defined in AcDb) | AcDb
kMRelease3 enum value (defined in AcDb) | AcDb
kMRelease30 enum value (defined in AcDb) | AcDb
kMRelease31 enum value (defined in AcDb) | AcDb
kMRelease32 enum value (defined in AcDb) | AcDb
kMRelease33 enum value (defined in AcDb) | AcDb
kMRelease34 enum value (defined in AcDb) | AcDb
kMRelease35 enum value (defined in AcDb) | AcDb
kMRelease36 enum value (defined in AcDb) | AcDb
kMRelease37 enum value (defined in AcDb) | AcDb
kMRelease38 enum value (defined in AcDb) | AcDb
kMRelease39 enum value (defined in AcDb) | AcDb
kMRelease4 enum value (defined in AcDb) | AcDb
kMRelease40 enum value (defined in AcDb) | AcDb
kMRelease41 enum value (defined in AcDb) | AcDb
kMRelease42 enum value (defined in AcDb) | AcDb
kMRelease43 enum value (defined in AcDb) | AcDb
kMRelease44 enum value (defined in AcDb) | AcDb
kMRelease45 enum value (defined in AcDb) | AcDb
kMRelease46 enum value (defined in AcDb) | AcDb
kMRelease47 enum value (defined in AcDb) | AcDb
kMRelease48 enum value (defined in AcDb) | AcDb
kMRelease49 enum value (defined in AcDb) | AcDb
kMRelease5 enum value (defined in AcDb) | AcDb
kMRelease50 enum value (defined in AcDb) | AcDb
kMRelease51 enum value (defined in AcDb) | AcDb
kMRelease52 enum value (defined in AcDb) | AcDb
kMRelease53 enum value (defined in AcDb) | AcDb
kMRelease54 enum value (defined in AcDb) | AcDb
kMRelease55 enum value (defined in AcDb) | AcDb
kMRelease56 enum value (defined in AcDb) | AcDb
kMRelease57 enum value (defined in AcDb) | AcDb
kMRelease58 enum value (defined in AcDb) | AcDb
kMRelease59 enum value (defined in AcDb) | AcDb
kMRelease6 enum value (defined in AcDb) | AcDb
kMRelease60 enum value (defined in AcDb) | AcDb
kMRelease61 enum value (defined in AcDb) | AcDb
kMRelease62 enum value (defined in AcDb) | AcDb
kMRelease63 enum value (defined in AcDb) | AcDb
kMRelease64 enum value (defined in AcDb) | AcDb
kMRelease65 enum value (defined in AcDb) | AcDb
kMRelease66 enum value (defined in AcDb) | AcDb
kMRelease67 enum value (defined in AcDb) | AcDb
kMRelease68 enum value (defined in AcDb) | AcDb
kMRelease69 enum value (defined in AcDb) | AcDb
kMRelease7 enum value (defined in AcDb) | AcDb
kMRelease70 enum value (defined in AcDb) | AcDb
kMRelease71 enum value (defined in AcDb) | AcDb
kMRelease72 enum value (defined in AcDb) | AcDb
kMRelease73 enum value (defined in AcDb) | AcDb
kMRelease74 enum value (defined in AcDb) | AcDb
kMRelease75 enum value (defined in AcDb) | AcDb
kMRelease76 enum value (defined in AcDb) | AcDb
kMRelease8 enum value (defined in AcDb) | AcDb
kMRelease9 enum value (defined in AcDb) | AcDb
kMReleaseCurrent enum value (defined in AcDb) | AcDb
kMReleaseFirstValid1500 enum value (defined in AcDb) | AcDb
kMReleaseMax enum value (defined in AcDb) | AcDb
kMReleaseNewest enum value (defined in AcDb) | AcDb
kMReleaseUnknown enum value (defined in AcDb) | AcDb
kMultipleContentCell enum value (defined in AcDb) | AcDb
kNeverSave enum value (defined in AcDb) | AcDb
kNeverShow enum value (defined in AcDb) | AcDb
kNewfoundland enum value (defined in AcDb) | AcDb
kNoGeom enum value (defined in AcDb) | AcDb
kNoIndex enum value (defined in AcDb) | AcDb
kNone enum value (defined in AcDb) | AcDb
kNoNewLayerEvaluation enum value (defined in AcDb) | AcDb
kNoNewLayerNotification enum value (defined in AcDb) | AcDb
kNonOrthoView enum value (defined in AcDb) | AcDb
kNonPlanar enum value (defined in AcDb) | AcDb
kNoOp enum value (defined in AcDb) | AcDb
kNoPath enum value (defined in AcDb) | AcDb
kNormal enum value (defined in AcDb) | AcDb
kNoSave enum value (defined in AcDb) | AcDb
kNotifyOnInsert enum value (defined in AcDb) | AcDb
kNotifyOnLayerStateRestore enum value (defined in AcDb) | AcDb
kNotifyOnOpen enum value (defined in AcDb) | AcDb
kNotifyOnPlot enum value (defined in AcDb) | AcDb
kNotifyOnSave enum value (defined in AcDb) | AcDb
kNotifyOnXrefAttachAndReload enum value (defined in AcDb) | AcDb
kNullSubentType enum value (defined in AcDb) | AcDb
kOnBothOperands enum value (defined in AcDb) | AcDb
kOrdered enum value (defined in AcDb) | AcDb
kOsMaskAllowTan enum value (defined in AcDb) | AcDb
kOsMaskApint enum value (defined in AcDb) | AcDb
kOsMaskCen enum value (defined in AcDb) | AcDb
kOsMaskDisablePerp enum value (defined in AcDb) | AcDb
kOsMaskEnd enum value (defined in AcDb) | AcDb
kOsMaskImmediate enum value (defined in AcDb) | AcDb
kOsMaskIns enum value (defined in AcDb) | AcDb
kOsMaskInt enum value (defined in AcDb) | AcDb
kOsMaskMid enum value (defined in AcDb) | AcDb
kOsMaskNear enum value (defined in AcDb) | AcDb
kOsMaskNode enum value (defined in AcDb) | AcDb
kOsMaskNoneOverride enum value (defined in AcDb) | AcDb
kOsMaskPerp enum value (defined in AcDb) | AcDb
kOsMaskQuad enum value (defined in AcDb) | AcDb
kOsMaskQuick enum value (defined in AcDb) | AcDb
kOsMaskRelCartesian enum value (defined in AcDb) | AcDb
kOsMaskRelPolar enum value (defined in AcDb) | AcDb
kOsMaskTan enum value (defined in AcDb) | AcDb
kOsModeCen enum value (defined in AcDb) | AcDb
kOsModeEnd enum value (defined in AcDb) | AcDb
kOsModeIns enum value (defined in AcDb) | AcDb
kOsModeMid enum value (defined in AcDb) | AcDb
kOsModeNear enum value (defined in AcDb) | AcDb
kOsModeNode enum value (defined in AcDb) | AcDb
kOsModePerp enum value (defined in AcDb) | AcDb
kOsModeQuad enum value (defined in AcDb) | AcDb
kOsModeTan enum value (defined in AcDb) | AcDb
kOuterGridLineTypes enum value (defined in AcDb) | AcDb
kPacific enum value (defined in AcDb) | AcDb
kPageFiler enum value (defined in AcDb) | AcDb
kPaperDisplayCS enum value (defined in AcDb) | AcDb
kParis enum value (defined in AcDb) | AcDb
kPathAndFile enum value (defined in AcDb) | AcDb
kPerth enum value (defined in AcDb) | AcDb
kPlanar enum value (defined in AcDb) | AcDb
kPlaneGeom enum value (defined in AcDb) | AcDb
kPlotStyleNameByBlock enum value (defined in AcDb) | AcDb
kPlotStyleNameById enum value (defined in AcDb) | AcDb
kPlotStyleNameByLayer enum value (defined in AcDb) | AcDb
kPlotStyleNameIsDictDefault enum value (defined in AcDb) | AcDb
kPointGeom enum value (defined in AcDb) | AcDb
kPrague enum value (defined in AcDb) | AcDb
kPrepend enum value (defined in AcDb) | AcDb
kPurgeFiler enum value (defined in AcDb) | AcDb
kQuadSurfaceMesh enum value (defined in AcDb) | AcDb
kR12Save enum value (defined in AcDb) | AcDb
kR13Save enum value (defined in AcDb) | AcDb
kR14Save enum value (defined in AcDb) | AcDb
kRangoon enum value (defined in AcDb) | AcDb
kRelativePath enum value (defined in AcDb) | AcDb
kRemove enum value (defined in AcDb) | AcDb
kRename enum value (defined in AcDb) | AcDb
kReservedStringCount enum value (defined in AcDb) | AcDb
kReset enum value (defined in AcDb) | AcDb
kRightMask enum value (defined in AcDb) | AcDb
kRightView enum value (defined in AcDb) | AcDb
kRiyadh enum value (defined in AcDb) | AcDb
kSantiago enum value (defined in AcDb) | AcDb
kSarajevo enum value (defined in AcDb) | AcDb
kSaskatchewan enum value (defined in AcDb) | AcDb
kSecondArrow enum value (defined in AcDb) | AcDb
kSeekFromCurrent enum value (defined in AcDb) | AcDb
kSeekFromEnd enum value (defined in AcDb) | AcDb
kSeekFromStart enum value (defined in AcDb) | AcDb
kSelect enum value (defined in AcDb) | AcDb
kSeoul enum value (defined in AcDb) | AcDb
kShadowsCastAndReceive enum value (defined in AcDb) | AcDb
kShadowsDoesNotCast enum value (defined in AcDb) | AcDb
kShadowsDoesNotReceive enum value (defined in AcDb) | AcDb
kShadowsIgnore enum value (defined in AcDb) | AcDb
kSimpleMesh enum value (defined in AcDb) | AcDb
kSingapore enum value (defined in AcDb) | AcDb
kSkipFormatAfterFirstUpdate enum value (defined in AcDb) | AcDb
kSoftOwnershipRef enum value (defined in AcDb) | AcDb
kSoftPointerRef enum value (defined in AcDb) | AcDb
kSortEntsOsnap enum value (defined in AcDb) | AcDb
kSortEntsPlot enum value (defined in AcDb) | AcDb
kSortEntsPsout enum value (defined in AcDb) | AcDb
kSortEntsRedraw enum value (defined in AcDb) | AcDb
kSortEntsRegen enum value (defined in AcDb) | AcDb
kSortEntsSelection enum value (defined in AcDb) | AcDb
kSortEntsSlide enum value (defined in AcDb) | AcDb
kSriLanka enum value (defined in AcDb) | AcDb
kStandard enum value (defined in AcDb) | AcDb
kStubPtr enum value (defined in AcDb) | AcDb
kSydney enum value (defined in AcDb) | AcDb
kTableBreakAllowManualHeights enum value (defined in AcDb) | AcDb
kTableBreakAllowManualPositions enum value (defined in AcDb) | AcDb
kTableBreakEnableBreaking enum value (defined in AcDb) | AcDb
kTableBreakFlowDownOrUp enum value (defined in AcDb) | AcDb
kTableBreakFlowLeft enum value (defined in AcDb) | AcDb
kTableBreakFlowRight enum value (defined in AcDb) | AcDb
kTableBreakNone enum value (defined in AcDb) | AcDb
kTableBreakRepeatBottomLabels enum value (defined in AcDb) | AcDb
kTableBreakRepeatTopLabels enum value (defined in AcDb) | AcDb
kTableCopyColumnWidth enum value (defined in AcDb) | AcDb
kTableCopyConvertFieldToValue enum value (defined in AcDb) | AcDb
kTableCopyConvertFormatToOverrides enum value (defined in AcDb) | AcDb
kTableCopyExpandOrContractTable enum value (defined in AcDb) | AcDb
kTableCopyFillTarget enum value (defined in AcDb) | AcDb
kTableCopyForRountrip enum value (defined in AcDb) | AcDb
kTableCopyFullCellState enum value (defined in AcDb) | AcDb
kTableCopyNone enum value (defined in AcDb) | AcDb
kTableCopyOnlyContentModifiedAfterUpdate enum value (defined in AcDb) | AcDb
kTableCopyOnlyFormatModifiedAfterUpdate enum value (defined in AcDb) | AcDb
kTableCopyOverwriteContentModifiedAfterUpdate enum value (defined in AcDb) | AcDb
kTableCopyOverwriteFormatModifiedAfterUpdate enum value (defined in AcDb) | AcDb
kTableCopyOverwriteReadOnlyContent enum value (defined in AcDb) | AcDb
kTableCopyOverwriteReadOnlyFormat enum value (defined in AcDb) | AcDb
kTableCopyRowHeight enum value (defined in AcDb) | AcDb
kTableCopySkipBlock enum value (defined in AcDb) | AcDb
kTableCopySkipCellState enum value (defined in AcDb) | AcDb
kTableCopySkipCellStyle enum value (defined in AcDb) | AcDb
kTableCopySkipContent enum value (defined in AcDb) | AcDb
kTableCopySkipContentFormat enum value (defined in AcDb) | AcDb
kTableCopySkipDataCell enum value (defined in AcDb) | AcDb
kTableCopySkipDataLink enum value (defined in AcDb) | AcDb
kTableCopySkipDissimilarContentFormat enum value (defined in AcDb) | AcDb
kTableCopySkipField enum value (defined in AcDb) | AcDb
kTableCopySkipFieldTranslation enum value (defined in AcDb) | AcDb
kTableCopySkipFormat enum value (defined in AcDb) | AcDb
kTableCopySkipFormula enum value (defined in AcDb) | AcDb
kTableCopySkipGeometry enum value (defined in AcDb) | AcDb
kTableCopySkipLabelCell enum value (defined in AcDb) | AcDb
kTableCopySkipMerges enum value (defined in AcDb) | AcDb
kTableCopySkipValue enum value (defined in AcDb) | AcDb
kTableFillCopyContent enum value (defined in AcDb) | AcDb
kTableFillCopyFormat enum value (defined in AcDb) | AcDb
kTableFillGenerateSeries enum value (defined in AcDb) | AcDb
kTableFillNone enum value (defined in AcDb) | AcDb
kTableFillOverwriteReadOnlyContent enum value (defined in AcDb) | AcDb
kTableFillOverwriteReadOnlyFormat enum value (defined in AcDb) | AcDb
kTableFillReverse enum value (defined in AcDb) | AcDb
kTableFillRow enum value (defined in AcDb) | AcDb
kTableHitCell enum value (defined in AcDb) | AcDb
kTableHitColumnIndicator enum value (defined in AcDb) | AcDb
kTableHitGridLine enum value (defined in AcDb) | AcDb
kTableHitNone enum value (defined in AcDb) | AcDb
kTableHitRowIndicator enum value (defined in AcDb) | AcDb
kTableIteratorIterateColumns enum value (defined in AcDb) | AcDb
kTableIteratorIterateDataLinks enum value (defined in AcDb) | AcDb
kTableIteratorIterateRows enum value (defined in AcDb) | AcDb
kTableIteratorIterateSelection enum value (defined in AcDb) | AcDb
kTableIteratorNone enum value (defined in AcDb) | AcDb
kTableIteratorReverseOrder enum value (defined in AcDb) | AcDb
kTableIteratorSkipMerged enum value (defined in AcDb) | AcDb
kTableIteratorSkipReadOnlyContent enum value (defined in AcDb) | AcDb
kTableIteratorSkipReadOnlyFormat enum value (defined in AcDb) | AcDb
kTableStyleDataTypeModified enum value (defined in AcDb) | AcDb
kTableStyleModified enum value (defined in AcDb) | AcDb
kTaipei enum value (defined in AcDb) | AcDb
kTehran enum value (defined in AcDb) | AcDb
kTextAlign enum value (defined in AcDb) | AcDb
kTextBase enum value (defined in AcDb) | AcDb
kTextBottom enum value (defined in AcDb) | AcDb
kTextCell enum value (defined in AcDb) | AcDb
kTextCenter enum value (defined in AcDb) | AcDb
kTextFit enum value (defined in AcDb) | AcDb
kTextLeft enum value (defined in AcDb) | AcDb
kTextMid enum value (defined in AcDb) | AcDb
kTextRight enum value (defined in AcDb) | AcDb
kTextTop enum value (defined in AcDb) | AcDb
kTextVertMid enum value (defined in AcDb) | AcDb
kThaw enum value (defined in AcDb) | AcDb
kTitle enum value (defined in AcDb) | AcDb
kTitleRow enum value (defined in AcDb) | AcDb
kTokyo enum value (defined in AcDb) | AcDb
kTonga enum value (defined in AcDb) | AcDb
kTopCenter enum value (defined in AcDb) | AcDb
kTopLeft enum value (defined in AcDb) | AcDb
kTopMask enum value (defined in AcDb) | AcDb
kTopRight enum value (defined in AcDb) | AcDb
kTopView enum value (defined in AcDb) | AcDb
kTtoB enum value (defined in AcDb) | AcDb
kUndefined enum value (defined in AcDb) | AcDb
kUndoFiler enum value (defined in AcDb) | AcDb
kUnitsAngstroms enum value (defined in AcDb) | AcDb
kUnitsAstronomical enum value (defined in AcDb) | AcDb
kUnitsCentimeters enum value (defined in AcDb) | AcDb
kUnitsDecimeters enum value (defined in AcDb) | AcDb
kUnitsDekameters enum value (defined in AcDb) | AcDb
kUnitsFeet enum value (defined in AcDb) | AcDb
kUnitsGigameters enum value (defined in AcDb) | AcDb
kUnitsHectometers enum value (defined in AcDb) | AcDb
kUnitsInches enum value (defined in AcDb) | AcDb
kUnitsKilometers enum value (defined in AcDb) | AcDb
kUnitsLightYears enum value (defined in AcDb) | AcDb
kUnitsMax enum value (defined in AcDb) | AcDb
kUnitsMeters enum value (defined in AcDb) | AcDb
kUnitsMicroinches enum value (defined in AcDb) | AcDb
kUnitsMicrons enum value (defined in AcDb) | AcDb
kUnitsMiles enum value (defined in AcDb) | AcDb
kUnitsMillimeters enum value (defined in AcDb) | AcDb
kUnitsMils enum value (defined in AcDb) | AcDb
kUnitsNanometers enum value (defined in AcDb) | AcDb
kUnitsParsecs enum value (defined in AcDb) | AcDb
kUnitsUndefined enum value (defined in AcDb) | AcDb
kUnitsYards enum value (defined in AcDb) | AcDb
kUnknown enum value (defined in AcDb) | AcDb
kUnknownCell enum value (defined in AcDb) | AcDb
kUnknownRow enum value (defined in AcDb) | AcDb
kUpdateDirDataToSource enum value (defined in AcDb) | AcDb
kUpdateDirSourceToData enum value (defined in AcDb) | AcDb
kUpdateModelViews enum value (defined in AcDb) | AcDb
kUpdateOptionAllowSourceUpdate enum value (defined in AcDb) | AcDb
kUpdateOptionForceFullSourceUpdate enum value (defined in AcDb) | AcDb
kUpdateOptionForPreview enum value (defined in AcDb) | AcDb
kUpdateOptionIncludeXrefs enum value (defined in AcDb) | AcDb
kUpdateOptionNone enum value (defined in AcDb) | AcDb
kUpdateOptionOverwriteContentModifiedAfterUpdate enum value (defined in AcDb) | AcDb
kUpdateOptionOverwriteFormatModifiedAfterUpdate enum value (defined in AcDb) | AcDb
kUpdateOptionSkipFormat enum value (defined in AcDb) | AcDb
kUpdateOptionUpdateColumnWidth enum value (defined in AcDb) | AcDb
kUpdateOptionUpdateRowHeight enum value (defined in AcDb) | AcDb
kUpdateSheets enum value (defined in AcDb) | AcDb
kUpdateSheetViews enum value (defined in AcDb) | AcDb
kUpdateWhenAccessed enum value (defined in AcDb) | AcDb
kUpdateWhenSaving enum value (defined in AcDb) | AcDb
kUseCurrentColor enum value (defined in AcDb) | AcDb
kUserCS enum value (defined in AcDb) | AcDb
kUTC enum value (defined in AcDb) | AcDb
kVertexSubentType enum value (defined in AcDb) | AcDb
kVertGridLineTypes enum value (defined in AcDb) | AcDb
kVertInside enum value (defined in AcDb) | AcDb
kVertLeft enum value (defined in AcDb) | AcDb
kVertRight enum value (defined in AcDb) | AcDb
kVisible enum value (defined in AcDb) | AcDb
kVladivostock enum value (defined in AcDb) | AcDb
kVS2DWireframe enum value (defined in AcDb) | AcDb
kVS3DHidden enum value (defined in AcDb) | AcDb
kVS3DWireframe enum value (defined in AcDb) | AcDb
kVSConceptual enum value (defined in AcDb) | AcDb
kVSRealistic enum value (defined in AcDb) | AcDb
kWblockCloneFiler enum value (defined in AcDb) | AcDb
kWellington enum value (defined in AcDb) | AcDb
kWestCentralAfrica enum value (defined in AcDb) | AcDb
kWindow enum value (defined in AcDb) | AcDb
kWorldCS enum value (defined in AcDb) | AcDb
kX enum value (defined in AcDb) | AcDb
kXrfFileNotFound enum value (defined in AcDb) | AcDb
kXrfNotAnXref enum value (defined in AcDb) | AcDb
kXrfNotifyNone enum value (defined in AcDb) | AcDb
kXrfNotifyResolvedElsewhere enum value (defined in AcDb) | AcDb
kXrfNotifyResolvedMatch enum value (defined in AcDb) | AcDb
kXrfNotifyResolvedUpdateAvailable enum value (defined in AcDb) | AcDb
kXrfNotifyResolvedWithUpdate enum value (defined in AcDb) | AcDb
kXrfResolved enum value (defined in AcDb) | AcDb
kXrfUnloaded enum value (defined in AcDb) | AcDb
kXrfUnreferenced enum value (defined in AcDb) | AcDb
kXrfUnresolved enum value (defined in AcDb) | AcDb
kY enum value (defined in AcDb) | AcDb
kYakutsk enum value (defined in AcDb) | AcDb
kZ enum value (defined in AcDb) | AcDb
LayerEvaluation enum name (defined in AcDb) | AcDb
LightingUnits enum name (defined in AcDb) | AcDb
LineSpacingStyle enum name (defined in AcDb) | AcDb
LineWeight enum name (defined in AcDb) | AcDb
LoftNormalsType enum name (defined in AcDb) | AcDb
LoftParamType enum name (defined in AcDb) | AcDb
MaintenanceReleaseVersion enum name (defined in AcDb) | AcDb
MeasurementValue enum name (defined in AcDb) | AcDb
MergeCellStyleOption enum name (defined in AcDb) | AcDb
NewLayerNotification enum name (defined in AcDb) | AcDb
OpenMode enum name (defined in AcDb) | AcDb
OrthographicView enum name (defined in AcDb) | AcDb
OsnapMask enum name (defined in AcDb) | AcDb
OsnapMode enum name (defined in AcDb) | AcDb
PathOption enum name (defined in AcDb) | AcDb
Planarity enum name (defined in AcDb) | AcDb
PlotStyleNameType enum name (defined in AcDb) | AcDb
PointIndex enum name (defined in AcDb) | AcDb
Poly2dType enum name (defined in AcDb) | AcDb
Poly3dType enum name (defined in AcDb) | AcDb
PolyMeshType enum name (defined in AcDb) | AcDb
ReferenceType enum name (defined in AcDb) | AcDb
reservedStringEnumType enum name (defined in AcDb) | AcDb
RotationAngle enum name (defined in AcDb) | AcDb
RowType enum name (defined in AcDb) | AcDb
RowTypes enum name (defined in AcDb) | AcDb
SaveImagesMode enum name (defined in AcDb) | AcDb
SaveType enum name (defined in AcDb) | AcDb
SelectType enum name (defined in AcDb) | AcDb
ShadowFlags enum name (defined in AcDb) | AcDb
ShowImagesMode enum name (defined in AcDb) | AcDb
SliceModelType enum name (defined in AcDb) | AcDb
SortEntsFlags enum name (defined in AcDb) | AcDb
SpaceValueType enum name (defined in AcDb) | AcDb
SubentType typedef (defined in AcDb) | AcDb
TableBreakFlowDirection enum name (defined in AcDb) | AcDb
TableBreakOption enum name (defined in AcDb) | AcDb
TableCopyOption enum name (defined in AcDb) | AcDb
TableFillOption enum name (defined in AcDb) | AcDb
TableHitItem enum name (defined in AcDb) | AcDb
TableIteratorOption enum name (defined in AcDb) | AcDb
TableStyleFlags enum name (defined in AcDb) | AcDb
TextHorzMode enum name (defined in AcDb) | AcDb
TextVertMode enum name (defined in AcDb) | AcDb
TimeZone enum name (defined in AcDb) | AcDb
UnitsValue enum name (defined in AcDb) | AcDb
UpdateDirection enum name (defined in AcDb) | AcDb
UpdateOption enum name (defined in AcDb) | AcDb
UpdateThumbnailFlags enum name (defined in AcDb) | AcDb
vAC025 enum value (defined in AcDb) | AcDb
vAC026 enum value (defined in AcDb) | AcDb
vAC09 enum value (defined in AcDb) | AcDb
vAC10 enum value (defined in AcDb) | AcDb
vAC12 enum value (defined in AcDb) | AcDb
vAC13 enum value (defined in AcDb) | AcDb
vAC14 enum value (defined in AcDb) | AcDb
vAC14beta enum value (defined in AcDb) | AcDb
vAC15 enum value (defined in AcDb) | AcDb
vAC18 enum value (defined in AcDb) | AcDb
vAC21 enum value (defined in AcDb) | AcDb
vAC24 enum value (defined in AcDb) | AcDb
vAC27 enum value (defined in AcDb) | AcDb
Vertex2dType enum name (defined in AcDb) | AcDb
Vertex3dType enum name (defined in AcDb) | AcDb
Visibility enum name (defined in AcDb) | AcDb
VpFreezeOps enum name (defined in AcDb) | AcDb
XrefNotificationStatus enum name (defined in AcDb) | AcDb
XrefStatus enum name (defined in AcDb) | AcDb


ZRX API Reference: AcDbMTextFragment Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcDbMTextFragment Struct Reference
Structs

Public Attributes

ACHAR * | bigfont
bool | bold
double | capsHeight
AcCmEntityColor | color
AcGeVector3d | direction
AcGePoint2d | extents
ACHAR * | font
ACHAR * | fontname
bool | italic
bool | lineBreak
AcGePoint3d | location
AcGeVector3d | normal
double | obliqueAngle
unsigned | overlined:1
AcGePoint3d | overPoints [2]
unsigned | stackBottom:1
unsigned | stackTop:1
AcGePoint3d | strikePoints [2]
unsigned | strikethrough:1
ACHAR * | text
double | trackingFactor
unsigned | underlined:1
AcGePoint3d | underPoints [2]
double | widthFactor
The documentation for this struct was generated from the following file:
  • dbmtext.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbMTextFragment Member List

This is the complete list of members for AcDbMTextFragment, including all inherited members.

bigfont (defined in AcDbMTextFragment) | AcDbMTextFragment
bold (defined in AcDbMTextFragment) | AcDbMTextFragment
capsHeight (defined in AcDbMTextFragment) | AcDbMTextFragment
color (defined in AcDbMTextFragment) | AcDbMTextFragment
direction (defined in AcDbMTextFragment) | AcDbMTextFragment
extents (defined in AcDbMTextFragment) | AcDbMTextFragment
font (defined in AcDbMTextFragment) | AcDbMTextFragment
fontname (defined in AcDbMTextFragment) | AcDbMTextFragment
italic (defined in AcDbMTextFragment) | AcDbMTextFragment
lineBreak (defined in AcDbMTextFragment) | AcDbMTextFragment
location (defined in AcDbMTextFragment) | AcDbMTextFragment
normal (defined in AcDbMTextFragment) | AcDbMTextFragment
obliqueAngle (defined in AcDbMTextFragment) | AcDbMTextFragment
overlined (defined in AcDbMTextFragment) | AcDbMTextFragment
overPoints (defined in AcDbMTextFragment) | AcDbMTextFragment
stackBottom (defined in AcDbMTextFragment) | AcDbMTextFragment
stackTop (defined in AcDbMTextFragment) | AcDbMTextFragment
strikePoints (defined in AcDbMTextFragment) | AcDbMTextFragment
strikethrough (defined in AcDbMTextFragment) | AcDbMTextFragment
text (defined in AcDbMTextFragment) | AcDbMTextFragment
trackingFactor (defined in AcDbMTextFragment) | AcDbMTextFragment
underlined (defined in AcDbMTextFragment) | AcDbMTextFragment
underPoints (defined in AcDbMTextFragment) | AcDbMTextFragment
widthFactor (defined in AcDbMTextFragment) | AcDbMTextFragment


ZRX API Reference: AcDbUnderlayDrawContext Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcDbUnderlayDrawContext Struct Reference
Structs

Public Attributes

bool | adjustColorForBackground
Adesk::UInt8 | contrast
Adesk::UInt8 | fade
bool | monochrome
AcUnderlayLayer ** | pLayers
The documentation for this struct was generated from the following file:
  • dbunderlayhost.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbUnderlayDrawContext Member List

This is the complete list of members for AcDbUnderlayDrawContext, including all inherited members.

adjustColorForBackground (defined in AcDbUnderlayDrawContext) | AcDbUnderlayDrawContext
contrast (defined in AcDbUnderlayDrawContext) | AcDbUnderlayDrawContext
fade (defined in AcDbUnderlayDrawContext) | AcDbUnderlayDrawContext
monochrome (defined in AcDbUnderlayDrawContext) | AcDbUnderlayDrawContext
pLayers (defined in AcDbUnderlayDrawContext) | AcDbUnderlayDrawContext


ZRX API Reference: AcEdCommandStruc Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcEdCommandStruc Struct Reference
Structs

Public Attributes

void * | app
AcEdCommand * | cmd
AcRxFunctionPtr | fcnAddr
long | flags
HINSTANCE | hResHandle
The documentation for this struct was generated from the following file:
  • accmd.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdCommandStruc Member List

This is the complete list of members for AcEdCommandStruc, including all inherited members.

app (defined in AcEdCommandStruc) | AcEdCommandStruc
cmd (defined in AcEdCommandStruc) | AcEdCommandStruc
fcnAddr (defined in AcEdCommandStruc) | AcEdCommandStruc
flags (defined in AcEdCommandStruc) | AcEdCommandStruc
hResHandle (defined in AcEdCommandStruc) | AcEdCommandStruc


ZRX API Reference: AcFd Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
AcFd Struct Reference
Structs

Public Types

enum | ConvertFieldToText { kConvertFieldToTextNone = 0, kEvaluateBeforeConversion = (0x1 << 0), kExcludeEvaluatorsInList = (0x1 << 1), kIgnoreEvaluatorVersion = (0x1 << 2) }
enum | EvalFields { kEvalRecursive = (0x1 << 0) }
The documentation for this struct was generated from the following file:
  • DbField.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcFd Member List

This is the complete list of members for AcFd, including all inherited members.

ConvertFieldToText enum name (defined in AcFd) | AcFd
EvalFields enum name (defined in AcFd) | AcFd
kConvertFieldToTextNone enum value (defined in AcFd) | AcFd
kEvalRecursive enum value (defined in AcFd) | AcFd
kEvaluateBeforeConversion enum value (defined in AcFd) | AcFd
kExcludeEvaluatorsInList enum value (defined in AcFd) | AcFd
kIgnoreEvaluatorVersion enum value (defined in AcFd) | AcFd


ZRX API Reference: AcGe Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Static Public Attributes | List of all members
AcGe Struct Reference
Structs

Public Types

enum | { eGood, eBad }
enum | AcGeIntersectError { kXXOk, kXXIndexOutOfRange, kXXWrongDimensionAtIndex, kXXUnknown }
enum AcGeXConfig {
kNotDefined = 1 << 0, kUnknown = 1 << 1, kLeftRight = 1 << 2, kRightLeft = 1 << 3,
kLeftLeft = 1 << 4, kRightRight = 1 << 5, kPointLeft = 1 << 6, kPointRight = 1 << 7,
kLeftOverlap = 1 << 8, kOverlapLeft = 1 << 9, kRightOverlap = 1 << 10, kOverlapRight = 1 << 11,
kOverlapStart = 1 << 12, kOverlapEnd = 1 << 13, kOverlapOverlap = 1 << 14
}
enum | BooleanType { kUnion, kSubtract, kCommon }
enum ClipCondition {
kInvalid, kAllSegmentsInside, kSegmentsIntersect, kAllSegmentsOutsideZeroWinds,
kAllSegmentsOutsideOddWinds, kAllSegmentsOutsideEvenWinds
}
enum | ClipError { eOk, eInvalidClipBoundary, eNotInitialized }
enum csiConfig {
kXUnknown, kXOut, kXIn, kXTanOut,
kXTanIn, kXCoincident, kXCoincidentUnbounded
}
enum EntityId {
kEntity2d, kEntity3d, kPointEnt2d, kPointEnt3d,
kPosition2d, kPosition3d, kPointOnCurve2d, kPointOnCurve3d,
kPointOnSurface, kBoundedPlane, kCircArc2d, kCircArc3d,
kConic2d, kConic3d, kCurve2d, kCurve3d,
kEllipArc2d, kEllipArc3d, kLine2d, kLine3d,
kLinearEnt2d, kLinearEnt3d, kLineSeg2d, kLineSeg3d,
kPlanarEnt, kPlane, kRay2d, kRay3d,
kSurface, kSphere, kCylinder, kTorus,
kCone, kSplineEnt2d, kPolyline2d, kAugPolyline2d,
kNurbCurve2d, kDSpline2d, kCubicSplineCurve2d, kSplineEnt3d,
kPolyline3d, kAugPolyline3d, kNurbCurve3d, kDSpline3d,
kCubicSplineCurve3d, kTrimmedCrv2d, kCompositeCrv2d, kCompositeCrv3d,
kExternalSurface, kNurbSurface, kTrimmedSurface, kOffsetSurface,
kEnvelope2d, kCurveBoundedSurface, kExternalCurve3d, kExternalCurve2d,
kSurfaceCurve2dTo3d, kSurfaceCurve3dTo2d, kExternalBoundedSurface, kCurveCurveInt2d,
kCurveCurveInt3d, kBoundBlock2d, kBoundBlock3d, kOffsetCurve2d,
kOffsetCurve3d, kPolynomCurve3d, kBezierCurve3d, kObject,
kFitData3d, kHatch, kTrimmedCurve2d, kTrimmedCurve3d,
kCurveSampleData, kEllipCone, kEllipCylinder, kIntervalBoundBlock,
kClipBoundary2d, kExternalObject, kCurveSurfaceInt, kSurfaceSurfaceInt,
kHelix
}
enum ErrorCondition {
kOk, k0This, k0Arg1, k0Arg2,
kPerpendicularArg1Arg2, kEqualArg1Arg2, kEqualArg1Arg3, kEqualArg2Arg3,
kLinearlyDependentArg1Arg2Arg3, kArg1TooBig, kArg1OnThis, kArg1InsideThis
}
enum | ExternalEntityKind { kAcisEntity = 0, kExternalEntityUndefined }
enum KnotParameterization {
kChord = 0, kSqrtChord, kUniform, kCustomParameterization = 15,
kNotDefinedKnotParam = 16
}
enum NurbSurfaceProperties {
kOpen = 0x01, kClosed = 0x02, kPeriodic = 0x04, kRational = 0x08,
kNoPoles = 0x10, kPoleAtMin = 0x20, kPoleAtMax = 0x40, kPoleAtBoth = 0x80
}
enum | OffsetCrvExtType { kFillet, kChamfer, kExtend }
enum | PointContainment { kInside, kOutside, kOnBoundary }
enum | ssiConfig { kSSIUnknown, kSSIOut, kSSIIn, kSSICoincident }
enum | ssiType { kSSITransverse, kSSITangent, kSSIAntiTangent }

Static Public Attributes

static const AcGeLibVersion gLibVersion
The documentation for this struct was generated from the following file:
  • gegblge.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGe Member List

This is the complete list of members for AcGe, including all inherited members.

AcGeIntersectError enum name (defined in AcGe) | AcGe |
AcGeXConfig enum name (defined in AcGe) | AcGe |
BooleanType enum name (defined in AcGe) | AcGe |
ClipCondition enum name (defined in AcGe) | AcGe |
ClipError enum name (defined in AcGe) | AcGe |
csiConfig enum name (defined in AcGe) | AcGe |
eBad enum value (defined in AcGe) | AcGe |
eGood enum value (defined in AcGe) | AcGe |
eInvalidClipBoundary enum value (defined in AcGe) | AcGe |
eNotInitialized enum value (defined in AcGe) | AcGe |
EntityId enum name (defined in AcGe) | AcGe |
eOk enum value (defined in AcGe) | AcGe |
ErrorCondition enum name (defined in AcGe) | AcGe |
ExternalEntityKind enum name (defined in AcGe) | AcGe |
gLibVersion (defined in AcGe) | AcGe | static
k0Arg1 enum value (defined in AcGe) | AcGe |
k0Arg2 enum value (defined in AcGe) | AcGe |
k0This enum value (defined in AcGe) | AcGe |
kAcisEntity enum value (defined in AcGe) | AcGe |
kAllSegmentsInside enum value (defined in AcGe) | AcGe |
kAllSegmentsOutsideEvenWinds enum value (defined in AcGe) | AcGe |
kAllSegmentsOutsideOddWinds enum value (defined in AcGe) | AcGe |
kAllSegmentsOutsideZeroWinds enum value (defined in AcGe) | AcGe |
kArg1InsideThis enum value (defined in AcGe) | AcGe |
kArg1OnThis enum value (defined in AcGe) | AcGe |
kArg1TooBig enum value (defined in AcGe) | AcGe |
kAugPolyline2d enum value (defined in AcGe) | AcGe |
kAugPolyline3d enum value (defined in AcGe) | AcGe |
kBezierCurve3d enum value (defined in AcGe) | AcGe |
kBoundBlock2d enum value (defined in AcGe) | AcGe |
kBoundBlock3d enum value (defined in AcGe) | AcGe |
kBoundedPlane enum value (defined in AcGe) | AcGe |
kChamfer enum value (defined in AcGe) | AcGe |
kChord enum value (defined in AcGe) | AcGe |
kCircArc2d enum value (defined in AcGe) | AcGe |
kCircArc3d enum value (defined in AcGe) | AcGe |
kClipBoundary2d enum value (defined in AcGe) | AcGe |
kClosed enum value (defined in AcGe) | AcGe |
kCommon enum value (defined in AcGe) | AcGe |
kCompositeCrv2d enum value (defined in AcGe) | AcGe |
kCompositeCrv3d enum value (defined in AcGe) | AcGe |
kCone enum value (defined in AcGe) | AcGe |
kConic2d enum value (defined in AcGe) | AcGe |
kConic3d enum value (defined in AcGe) | AcGe |
kCubicSplineCurve2d enum value (defined in AcGe) | AcGe |
kCubicSplineCurve3d enum value (defined in AcGe) | AcGe |
kCurve2d enum value (defined in AcGe) | AcGe |
kCurve3d enum value (defined in AcGe) | AcGe |
kCurveBoundedSurface enum value (defined in AcGe) | AcGe |
kCurveCurveInt2d enum value (defined in AcGe) | AcGe |
kCurveCurveInt3d enum value (defined in AcGe) | AcGe |
kCurveSampleData enum value (defined in AcGe) | AcGe |
kCurveSurfaceInt enum value (defined in AcGe) | AcGe |
kCustomParameterization enum value (defined in AcGe) | AcGe |
kCylinder enum value (defined in AcGe) | AcGe |
kDSpline2d enum value (defined in AcGe) | AcGe |
kDSpline3d enum value (defined in AcGe) | AcGe |
kEllipArc2d enum value (defined in AcGe) | AcGe |
kEllipArc3d enum value (defined in AcGe) | AcGe |
kEllipCone enum value (defined in AcGe) | AcGe |
kEllipCylinder enum value (defined in AcGe) | AcGe |
kEntity2d enum value (defined in AcGe) | AcGe |
kEntity3d enum value (defined in AcGe) | AcGe |
kEnvelope2d enum value (defined in AcGe) | AcGe |
kEqualArg1Arg2 enum value (defined in AcGe) | AcGe |
kEqualArg1Arg3 enum value (defined in AcGe) | AcGe |
kEqualArg2Arg3 enum value (defined in AcGe) | AcGe |
kExtend enum value (defined in AcGe) | AcGe |
kExternalBoundedSurface enum value (defined in AcGe) | AcGe |
kExternalCurve2d enum value (defined in AcGe) | AcGe |
kExternalCurve3d enum value (defined in AcGe) | AcGe |
kExternalEntityUndefined enum value (defined in AcGe) | AcGe |
kExternalObject enum value (defined in AcGe) | AcGe |
kExternalSurface enum value (defined in AcGe) | AcGe |
kFillet enum value (defined in AcGe) | AcGe |
kFitData3d enum value (defined in AcGe) | AcGe |
kHatch enum value (defined in AcGe) | AcGe |
kHelix enum value (defined in AcGe) | AcGe |
kInside enum value (defined in AcGe) | AcGe |
kIntervalBoundBlock enum value (defined in AcGe) | AcGe |
kInvalid enum value (defined in AcGe) | AcGe |
kLeftLeft enum value (defined in AcGe) | AcGe |
kLeftOverlap enum value (defined in AcGe) | AcGe |
kLeftRight enum value (defined in AcGe) | AcGe |
kLine2d enum value (defined in AcGe) | AcGe |
kLine3d enum value (defined in AcGe) | AcGe |
kLinearEnt2d enum value (defined in AcGe) | AcGe |
kLinearEnt3d enum value (defined in AcGe) | AcGe |
kLinearlyDependentArg1Arg2Arg3 enum value (defined in AcGe) | AcGe |
kLineSeg2d enum value (defined in AcGe) | AcGe |
kLineSeg3d enum value (defined in AcGe) | AcGe |
kNoPoles enum value (defined in AcGe) | AcGe |
kNotDefined enum value (defined in AcGe) | AcGe |
kNotDefinedKnotParam enum value (defined in AcGe) | AcGe |
KnotParameterization enum name (defined in AcGe) | AcGe |
kNurbCurve2d enum value (defined in AcGe) | AcGe |
kNurbCurve3d enum value (defined in AcGe) | AcGe |
kNurbSurface enum value (defined in AcGe) | AcGe |
kObject enum value (defined in AcGe) | AcGe |
kOffsetCurve2d enum value (defined in AcGe) | AcGe |
kOffsetCurve3d enum value (defined in AcGe) | AcGe |
kOffsetSurface enum value (defined in AcGe) | AcGe |
kOk enum value (defined in AcGe) | AcGe |
kOnBoundary enum value (defined in AcGe) | AcGe |
kOpen enum value (defined in AcGe) | AcGe |
kOutside enum value (defined in AcGe) | AcGe |
kOverlapEnd enum value (defined in AcGe) | AcGe |
kOverlapLeft enum value (defined in AcGe) | AcGe |
kOverlapOverlap enum value (defined in AcGe) | AcGe |
kOverlapRight enum value (defined in AcGe) | AcGe |
kOverlapStart enum value (defined in AcGe) | AcGe |
kPeriodic enum value (defined in AcGe) | AcGe |
kPerpendicularArg1Arg2 enum value (defined in AcGe) | AcGe |
kPlanarEnt enum value (defined in AcGe) | AcGe |
kPlane enum value (defined in AcGe) | AcGe |
kPointEnt2d enum value (defined in AcGe) | AcGe |
kPointEnt3d enum value (defined in AcGe) | AcGe |
kPointLeft enum value (defined in AcGe) | AcGe |
kPointOnCurve2d enum value (defined in AcGe) | AcGe |
kPointOnCurve3d enum value (defined in AcGe) | AcGe |
kPointOnSurface enum value (defined in AcGe) | AcGe |
kPointRight enum value (defined in AcGe) | AcGe |
kPoleAtBoth enum value (defined in AcGe) | AcGe |
kPoleAtMax enum value (defined in AcGe) | AcGe |
kPoleAtMin enum value (defined in AcGe) | AcGe |
kPolyline2d enum value (defined in AcGe) | AcGe |
kPolyline3d enum value (defined in AcGe) | AcGe |
kPolynomCurve3d enum value (defined in AcGe) | AcGe |
kPosition2d enum value (defined in AcGe) | AcGe |
kPosition3d enum value (defined in AcGe) | AcGe |
kRational enum value (defined in AcGe) | AcGe |
kRay2d enum value (defined in AcGe) | AcGe |
kRay3d enum value (defined in AcGe) | AcGe |
kRightLeft enum value (defined in AcGe) | AcGe |
kRightOverlap enum value (defined in AcGe) | AcGe |
kRightRight enum value (defined in AcGe) | AcGe |
kSegmentsIntersect enum value (defined in AcGe) | AcGe |
kSphere enum value (defined in AcGe) | AcGe |
kSplineEnt2d enum value (defined in AcGe) | AcGe |
kSplineEnt3d enum value (defined in AcGe) | AcGe |
kSqrtChord enum value (defined in AcGe) | AcGe |
kSSIAntiTangent enum value (defined in AcGe) | AcGe |
kSSICoincident enum value (defined in AcGe) | AcGe |
kSSIIn enum value (defined in AcGe) | AcGe |
kSSIOut enum value (defined in AcGe) | AcGe |
kSSITangent enum value (defined in AcGe) | AcGe |
kSSITransverse enum value (defined in AcGe) | AcGe |
kSSIUnknown enum value (defined in AcGe) | AcGe |
kSubtract enum value (defined in AcGe) | AcGe |
kSurface enum value (defined in AcGe) | AcGe |
kSurfaceCurve2dTo3d enum value (defined in AcGe) | AcGe |
kSurfaceCurve3dTo2d enum value (defined in AcGe) | AcGe |
kSurfaceSurfaceInt enum value (defined in AcGe) | AcGe |
kTorus enum value (defined in AcGe) | AcGe |
kTrimmedCrv2d enum value (defined in AcGe) | AcGe |
kTrimmedCurve2d enum value (defined in AcGe) | AcGe |
kTrimmedCurve3d enum value (defined in AcGe) | AcGe |
kTrimmedSurface enum value (defined in AcGe) | AcGe |
kUniform enum value (defined in AcGe) | AcGe |
kUnion enum value (defined in AcGe) | AcGe |
kUnknown enum value (defined in AcGe) | AcGe |
kXCoincident enum value (defined in AcGe) | AcGe |
kXCoincidentUnbounded enum value (defined in AcGe) | AcGe |
kXIn enum value (defined in AcGe) | AcGe |
kXOut enum value (defined in AcGe) | AcGe |
kXTanIn enum value (defined in AcGe) | AcGe |
kXTanOut enum value (defined in AcGe) | AcGe |
kXUnknown enum value (defined in AcGe) | AcGe |
kXXIndexOutOfRange enum value (defined in AcGe) | AcGe |
kXXOk enum value (defined in AcGe) | AcGe |
kXXUnknown enum value (defined in AcGe) | AcGe |
kXXWrongDimensionAtIndex enum value (defined in AcGe) | AcGe |
NurbSurfaceProperties enum name (defined in AcGe) | AcGe |
OffsetCrvExtType enum name (defined in AcGe) | AcGe |
PointContainment enum name (defined in AcGe) | AcGe |
ssiConfig enum name (defined in AcGe) | AcGe |
ssiType enum name (defined in AcGe) | AcGe |


ZRX API Reference: AcGeContext Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Static Public Attributes | List of all members
AcGeContext Struct Reference
Structs

Static Public Attributes

static void *(* | gAllocMem )(size_t)
static void(* | gAssertFunc )(const ACHAR *condition, const ACHAR *filename, int lineNumber, const ACHAR *status)
static void(* | gErrorFunc )()
static void(* | gFreeMem )(void *)
static void(* | gOrthoVector )(const AcGeVector3d &, AcGeVector3d &)
static AcGeTol | gTol
The documentation for this struct was generated from the following file:
  • gegbl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGeContext Member List

This is the complete list of members for AcGeContext, including all inherited members.

gAllocMem (defined in AcGeContext) | AcGeContext | static
gAssertFunc (defined in AcGeContext) | AcGeContext | static
gErrorFunc (defined in AcGeContext) | AcGeContext | static
gFreeMem (defined in AcGeContext) | AcGeContext | static
gOrthoVector (defined in AcGeContext) | AcGeContext | static
gTol (defined in AcGeContext) | AcGeContext | static


ZRX API Reference: AcGiClipBoundary Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcGiClipBoundary Struct Reference
Structs

Public Attributes

AcGePoint2dArray | m_aptPoints
Adesk::Boolean | m_bClippingBack
Adesk::Boolean | m_bClippingFront
Adesk::Boolean | m_bDrawBoundary
double | m_dBackClipZ
double | m_dFrontClipZ
AcGePoint3d | m_ptPoint
AcGeVector3d | m_vNormal
AcGeMatrix3d | m_xInverseBlockRefXForm
AcGeMatrix3d | m_xToClipSpace
The documentation for this struct was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiClipBoundary Member List

This is the complete list of members for AcGiClipBoundary, including all inherited members.

m_aptPoints (defined in AcGiClipBoundary) | AcGiClipBoundary
m_bClippingBack (defined in AcGiClipBoundary) | AcGiClipBoundary
m_bClippingFront (defined in AcGiClipBoundary) | AcGiClipBoundary
m_bDrawBoundary (defined in AcGiClipBoundary) | AcGiClipBoundary
m_dBackClipZ (defined in AcGiClipBoundary) | AcGiClipBoundary
m_dFrontClipZ (defined in AcGiClipBoundary) | AcGiClipBoundary
m_ptPoint (defined in AcGiClipBoundary) | AcGiClipBoundary
m_vNormal (defined in AcGiClipBoundary) | AcGiClipBoundary
m_xInverseBlockRefXForm (defined in AcGiClipBoundary) | AcGiClipBoundary
m_xToClipSpace (defined in AcGiClipBoundary) | AcGiClipBoundary


ZRX API Reference: AcGiRequestScanLines Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Attributes | List of all members
AcGiRequestScanLines Struct Reference
Structs

Public Types

enum | IEColorSystem { kBitonal, kCMY, kCMYK, kRGB }
enum | IEDitherMethod { kIEAnyPalette, kCustomDithering, kCustomDitheringMethod }
enum | ImagePaletteType { kFromDevice, kFromIeWholeImage }

Public Attributes

union {
Adesk::Int16 mBackgroundIndex
Adesk::Int8 mBackgroundRGB [3]
} mBackgroundColor
Adesk::Int16 | mColorDepth
union {
Adesk::Int16 mEntityIndex
Adesk::Int8 mEntityRGB [3]
} mEntityColor
AcGiImageOrg | mImageOrg
AcGiImageOrient | mImageOrient
Adesk::Int16 | mIsDisplay
AcGePoint2d | mLowerLeft
Adesk::Int32 | mLowerRightPt [2]
Adesk::UInt32 | mnContours
short | mnThisChunk
short | mnTotalChunks
Adesk::Int32 | mNumRows
Adesk::Int32 | mOrigin [2]
Adesk::Int32 | mPaletteIncarnation
ImagePaletteType | mPaletteType
Adesk::Int32 const * | mpBoundaryPoints
Adesk::Int32 const * | mpCounts
void * | mpDataBuffer
void * | mpImageId
Adesk::UInt32 | mPixelMaxX
Adesk::UInt32 | mPixelMaxY
Adesk::UInt32 | mPixelMinX
Adesk::UInt32 | mPixelMinY
AcGeMatrix2d | mPixelToDc
Adesk::Int8 * | mpPalette
double | mRasterRatio
AcGiRotationFilterType | mRotationFilterType
Adesk::Int32 | mRowWidth
AcGiScaleFilterType | mScaleFilterType
AcGiScaleType | mScalingType
union {
Adesk::Int16 mTransparentIndex
Adesk::Int8 mTransparentRGB [3]
} mTransparentColor
Adesk::Int32 | mUpperLeftPt [2]
AcGePoint2d | mUpperRight
Adesk::Int16 | mWindowId
The documentation for this struct was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiRequestScanLines Member List

This is the complete list of members for AcGiRequestScanLines, including all inherited members.

AcGiRequestScanLines() (defined in AcGiRequestScanLines) | AcGiRequestScanLines | inline
IEColorSystem enum name (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
IEDitherMethod enum name (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
ImagePaletteType enum name (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
kBitonal enum value (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
kCMY enum value (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
kCMYK enum value (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
kCustomDithering enum value (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
kCustomDitheringMethod enum value (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
kFromDevice enum value (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
kFromIeWholeImage enum value (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
kIEAnyPalette enum value (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
kRGB enum value (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mBackgroundColor (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mBackgroundIndex (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mBackgroundRGB (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mColorDepth (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mEntityColor (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mEntityIndex (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mEntityRGB (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mImageOrg (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mImageOrient (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mIsDisplay (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mLowerLeft (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mLowerRightPt (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mnContours (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mnThisChunk (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mnTotalChunks (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mNumRows (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mOrigin (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mPaletteIncarnation (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mPaletteType (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mpBoundaryPoints (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mpCounts (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mpDataBuffer (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mpImageId (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mPixelMaxX (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mPixelMaxY (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mPixelMinX (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mPixelMinY (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mPixelToDc (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mpPalette (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mRasterRatio (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mRotationFilterType (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mRowWidth (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mScaleFilterType (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mScalingType (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mTransparentColor (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mTransparentIndex (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mTransparentRGB (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mUpperLeftPt (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mUpperRight (defined in AcGiRequestScanLines) | AcGiRequestScanLines |
mWindowId (defined in AcGiRequestScanLines) | AcGiRequestScanLines |


ZRX API Reference: AcGiSentScanLines Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Attributes | List of all members
AcGiSentScanLines Struct Reference
Structs

Public Types

enum IsmRequestStatus {
eOk, eInvalidInput, eInvalidColorDepth, eInvalidPixelRequest,
eInvalidDeliveryMethod, eNoValidCompressors, eInsufficientMemory
}

Public Attributes

Adesk::UInt32 | mBytes
Adesk::Int16 | mHasFailed
Adesk::Int16 | mIsCancelled
void * | mpImageId
Adesk::Int8 * | mpPixelBuffer
IsmRequestStatus | mRequestStatus
Adesk::UInt32 | mRowBytes
The documentation for this struct was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiSentScanLines Member List

This is the complete list of members for AcGiSentScanLines, including all inherited members.

eInsufficientMemory enum value (defined in AcGiSentScanLines) | AcGiSentScanLines
eInvalidColorDepth enum value (defined in AcGiSentScanLines) | AcGiSentScanLines
eInvalidDeliveryMethod enum value (defined in AcGiSentScanLines) | AcGiSentScanLines
eInvalidInput enum value (defined in AcGiSentScanLines) | AcGiSentScanLines
eInvalidPixelRequest enum value (defined in AcGiSentScanLines) | AcGiSentScanLines
eNoValidCompressors enum value (defined in AcGiSentScanLines) | AcGiSentScanLines
eOk enum value (defined in AcGiSentScanLines) | AcGiSentScanLines
IsmRequestStatus enum name (defined in AcGiSentScanLines) | AcGiSentScanLines
mBytes (defined in AcGiSentScanLines) | AcGiSentScanLines
mHasFailed (defined in AcGiSentScanLines) | AcGiSentScanLines
mIsCancelled (defined in AcGiSentScanLines) | AcGiSentScanLines
mpImageId (defined in AcGiSentScanLines) | AcGiSentScanLines
mpPixelBuffer (defined in AcGiSentScanLines) | AcGiSentScanLines
mRequestStatus (defined in AcGiSentScanLines) | AcGiSentScanLines
mRowBytes (defined in AcGiSentScanLines) | AcGiSentScanLines


ZRX API Reference: AcGridProperty Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcGridProperty Struct Reference
Structs

Public Attributes

AcCmColor | mColor
double | mfDoubleLineSpacing
AcDbHardPointerId | mLinetype
AcDb::GridLineStyle | mnLineStyle
AcDb::LineWeight | mnLineWeight
AcDb::GridProperty | mnPropMask
AcDb::Visibility | mnVisibility
The documentation for this struct was generated from the following file:
  • DbFormattedTableData.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGridProperty Member List

This is the complete list of members for AcGridProperty, including all inherited members.

mColor (defined in AcGridProperty) | AcGridProperty
mfDoubleLineSpacing (defined in AcGridProperty) | AcGridProperty
mLinetype (defined in AcGridProperty) | AcGridProperty
mnLineStyle (defined in AcGridProperty) | AcGridProperty
mnLineWeight (defined in AcGridProperty) | AcGridProperty
mnPropMask (defined in AcGridProperty) | AcGridProperty
mnVisibility (defined in AcGridProperty) | AcGridProperty


ZRX API Reference: AcGs Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
AcGs Struct Reference
Structs

Public Types

enum LinePattern {
eSolid = 0, eDashed = 1, eDotted = 2, eDashDot = 3,
eShortDash = 4, eMediumDash = 5, eLongDash = 6, eDoubleShortDash = 7,
eDoubleMediumDash = 8, eDoubleLongDash = 9, eMediumLongDash = 10, eMediumDashShortDashShortDash = 11,
eLongDashShortDash = 12, eLongDashDotDot = 13, eLongDashDot = 14, eMediumDashDotShortDashDot = 15,
eSparseDot = 16, eDefaultLinePattern = eDotted
}
The documentation for this struct was generated from the following file:
  • acgs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGs Member List

This is the complete list of members for AcGs, including all inherited members.

eDashDot enum value (defined in AcGs) | AcGs
eDashed enum value (defined in AcGs) | AcGs
eDefaultLinePattern enum value (defined in AcGs) | AcGs
eDotted enum value (defined in AcGs) | AcGs
eDoubleLongDash enum value (defined in AcGs) | AcGs
eDoubleMediumDash enum value (defined in AcGs) | AcGs
eDoubleShortDash enum value (defined in AcGs) | AcGs
eLongDash enum value (defined in AcGs) | AcGs
eLongDashDot enum value (defined in AcGs) | AcGs
eLongDashDotDot enum value (defined in AcGs) | AcGs
eLongDashShortDash enum value (defined in AcGs) | AcGs
eMediumDash enum value (defined in AcGs) | AcGs
eMediumDashDotShortDashDot enum value (defined in AcGs) | AcGs
eMediumDashShortDashShortDash enum value (defined in AcGs) | AcGs
eMediumLongDash enum value (defined in AcGs) | AcGs
eShortDash enum value (defined in AcGs) | AcGs
eSolid enum value (defined in AcGs) | AcGs
eSparseDot enum value (defined in AcGs) | AcGs
LinePattern enum name (defined in AcGs) | AcGs


ZRX API Reference: AcGsRenderStatistics Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcGsRenderStatistics Struct Reference
Structs

Public Attributes

float | fRenderTime
size_t | iLightCount
size_t | iMaterialCount
size_t | iMemory
size_t | iTriangleCount
The documentation for this struct was generated from the following file:
  • acgsRender.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsRenderStatistics Member List

This is the complete list of members for AcGsRenderStatistics, including all inherited members.

fRenderTime (defined in AcGsRenderStatistics) | AcGsRenderStatistics
iLightCount (defined in AcGsRenderStatistics) | AcGsRenderStatistics
iMaterialCount (defined in AcGsRenderStatistics) | AcGsRenderStatistics
iMemory (defined in AcGsRenderStatistics) | AcGsRenderStatistics
iTriangleCount (defined in AcGsRenderStatistics) | AcGsRenderStatistics


ZRX API Reference: AcHyperlink Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcHyperlink Struct Reference
Structs

Public Attributes

long | mlFlag
AcString | msDescription
AcString | msSubLocation
AcString | msUrl
The documentation for this struct was generated from the following file:
  • DbField.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcHyperlink Member List

This is the complete list of members for AcHyperlink, including all inherited members.

mlFlag (defined in AcHyperlink) | AcHyperlink
msDescription (defined in AcHyperlink) | AcHyperlink
msSubLocation (defined in AcHyperlink) | AcHyperlink
msUrl (defined in AcHyperlink) | AcHyperlink


ZRX API Reference: AcPl3dDwfOptions Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcPl3dDwfOptions Struct Reference
Structs

Public Attributes

bool | bGroupByXrefHierarchy
bool | bPublishWithMaterials
The documentation for this struct was generated from the following file:
  • acpldsddata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPl3dDwfOptions Member List

This is the complete list of members for AcPl3dDwfOptions, including all inherited members.

bGroupByXrefHierarchy (defined in AcPl3dDwfOptions) | AcPl3dDwfOptions
bPublishWithMaterials (defined in AcPl3dDwfOptions) | AcPl3dDwfOptions


ZRX API Reference: ACPL_PREVIEWENDPLOT Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
ACPL_PREVIEWENDPLOT Struct Reference
Structs

Public Attributes

PreviewStatus nStatus
The documentation for this struct was generated from the following file:
  • acplplotengine.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
ACPL_PREVIEWENDPLOT Member List

This is the complete list of members for ACPL_PREVIEWENDPLOT, including all inherited members.

nStatus (defined in ACPL_PREVIEWENDPLOT) ACPL_PREVIEWENDPLOT


ZRX API Reference: AcUt Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
AcUt Struct Reference
Structs

Public Types

enum QFormatBitFlags {
kSuppressZeroFeet = 0x100, kSuppressZeroInches = 0x200, kSuppressLeadingZero = 0x400, kSuppressTrailingZero = 0x800,
kIgnoreUnitMode = 0x1000, kUseAltUnits = 0x2000
}
The documentation for this struct was generated from the following file:
  • acut.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcUt Member List

This is the complete list of members for AcUt, including all inherited members.

kIgnoreUnitMode enum value (defined in AcUt) | AcUt
kSuppressLeadingZero enum value (defined in AcUt) | AcUt
kSuppressTrailingZero enum value (defined in AcUt) | AcUt
kSuppressZeroFeet enum value (defined in AcUt) | AcUt
kSuppressZeroInches enum value (defined in AcUt) | AcUt
kUseAltUnits enum value (defined in AcUt) | AcUt
QFormatBitFlags enum name (defined in AcUt) | AcUt


ZRX API Reference: Adesk Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
Adesk Struct Reference
Structs

Public Types

enum | { kFalse = 0, kTrue = 1 }
typedef int | Boolean
typedef IntPtr | GsMarker
typedef short | Int16
typedef long | Int32
typedef __int64 | Int64
typedef char | Int8
typedef LongPtr | IntDbId
typedef __w64 int | IntPtr
typedef __w64 long | LongPtr
typedef unsigned char | uchar
typedef unsigned int | uint
typedef unsigned short | UInt16
typedef unsigned long | UInt32
typedef unsigned __int64 | UInt64
typedef unsigned char | UInt8
typedef __w64 unsigned int | UIntPtr
typedef unsigned long | ulong
typedef __w64 unsigned long | ULongPtr
typedef unsigned short | ushort
The documentation for this struct was generated from the following file:
  • adesk.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Adesk Member List

This is the complete list of members for Adesk, including all inherited members.

Boolean typedef (defined in Adesk) | Adesk
GsMarker typedef (defined in Adesk) | Adesk
Int16 typedef (defined in Adesk) | Adesk
Int32 typedef (defined in Adesk) | Adesk
Int64 typedef (defined in Adesk) | Adesk
Int8 typedef (defined in Adesk) | Adesk
IntDbId typedef (defined in Adesk) | Adesk
IntPtr typedef (defined in Adesk) | Adesk
kFalse enum value (defined in Adesk) | Adesk
kTrue enum value (defined in Adesk) | Adesk
LongPtr typedef (defined in Adesk) | Adesk
uchar typedef (defined in Adesk) | Adesk
uint typedef (defined in Adesk) | Adesk
UInt16 typedef (defined in Adesk) | Adesk
UInt32 typedef (defined in Adesk) | Adesk
UInt64 typedef (defined in Adesk) | Adesk
UInt8 typedef (defined in Adesk) | Adesk
UIntPtr typedef (defined in Adesk) | Adesk
ulong typedef (defined in Adesk) | Adesk
ULongPtr typedef (defined in Adesk) | Adesk
ushort typedef (defined in Adesk) | Adesk


ZRX API Reference: ads_binary Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
ads_binary Struct Reference
Structs

Public Attributes

char * | buf
short | clen
The documentation for this struct was generated from the following file:
  • adsdef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
ads_binary Member List

This is the complete list of members for ads_binary, including all inherited members.

buf (defined in ads_binary) | ads_binary
clen (defined in ads_binary) | ads_binary


ZRX API Reference: ads_u_val Union Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
ads_u_val Union Reference
Structs

Public Attributes

unsigned char | ihandle [8]
__int64 | mnInt64
__w64 long | mnLongPtr
struct ads_binary | rbinary
short | rint
__w64 long | rlname [2]
long | rlong
ads_real | rpoint [3]
ads_real | rreal
ACHAR * | rstring
The documentation for this union was generated from the following file:
  • adsdef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
ads_u_val Member List

This is the complete list of members for ads_u_val, including all inherited members.

ihandle (defined in ads_u_val) | ads_u_val
mnInt64 (defined in ads_u_val) | ads_u_val
mnLongPtr (defined in ads_u_val) | ads_u_val
rbinary (defined in ads_u_val) | ads_u_val
rint (defined in ads_u_val) | ads_u_val
rlname (defined in ads_u_val) | ads_u_val
rlong (defined in ads_u_val) | ads_u_val
rpoint (defined in ads_u_val) | ads_u_val
rreal (defined in ads_u_val) | ads_u_val
rstring (defined in ads_u_val) | ads_u_val


ZRX API Reference: Mline Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
Mline Struct Reference
Structs

Public Types

enum | { kTop = 0, kZero = 1, kBottom = 2 }
enum | { kOpen = 0, kClosed = 1, kMerged = 2 }
typedef Adesk::Int8 | MlineJustification
The documentation for this struct was generated from the following file:
  • dbmline.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Mline Member List

This is the complete list of members for Mline, including all inherited members.

kBottom enum value (defined in Mline) | Mline
kClosed enum value (defined in Mline) | Mline
kMerged enum value (defined in Mline) | Mline
kOpen enum value (defined in Mline) | Mline
kTop enum value (defined in Mline) | Mline
kZero enum value (defined in Mline) | Mline
MlineJustification typedef (defined in Mline) | Mline


ZRX API Reference: PER_FLYOUT_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
PER_FLYOUT_ENTRY Struct Reference
Structs

Public Attributes

DISPID dispid
The documentation for this struct was generated from the following file:
  • AcadToolImpl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
PER_FLYOUT_ENTRY Member List

This is the complete list of members for PER_FLYOUT_ENTRY, including all inherited members.

dispid (defined in PER_FLYOUT_ENTRY) PER_FLYOUT_ENTRY


ZRX API Reference: PER_PROP_DISP_ENTRY2 Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
PER_PROP_DISP_ENTRY2 Struct Reference
Structs

Public Attributes

bool | m_bFullView
DISPID | m_dispid
DWORD | m_dwIntegralHeight
LPCWSTR | m_lpEllipsisBmpRes
LPCWSTR | m_lpLeftIconRes
UINT | m_nEllipsisBmpType
UINT | m_nLeftIconType
long | m_nWeight
LPCWSTR | m_ProgID
COLORREF | m_TextColor
The documentation for this struct was generated from the following file:
  • AcadToolImpl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
PER_PROP_DISP_ENTRY2 Member List

This is the complete list of members for PER_PROP_DISP_ENTRY2, including all inherited members.

m_bFullView (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2
m_dispid (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2
m_dwIntegralHeight (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2
m_lpEllipsisBmpRes (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2
m_lpLeftIconRes (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2
m_nEllipsisBmpType (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2
m_nLeftIconType (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2
m_nWeight (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2
m_ProgID (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2
m_TextColor (defined in PER_PROP_DISP_ENTRY2) | PER_PROP_DISP_ENTRY2


ZRX API Reference: PROMPT_MAP_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
PROMPT_MAP_ENTRY Struct Reference
Structs

Public Attributes

bool | m_bGotThisProperty
bool | m_bJigThisProperty
int | m_cronly
DISPID | m_dispId
UINT | m_nDefaultValue
int | m_nInitget
UINT | m_nKeywords
UINT | m_nPrompt
VARTYPE | m_paramType
int | m_promptType
LPCWSTR | m_szDesc
VARIANT | m_vValue
The documentation for this struct was generated from the following file:
  • AsdkPromptBase.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
PROMPT_MAP_ENTRY Member List

This is the complete list of members for PROMPT_MAP_ENTRY, including all inherited members.

m_bGotThisProperty (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_bJigThisProperty (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_cronly (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_dispId (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_nDefaultValue (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_nInitget (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_nKeywords (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_nPrompt (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_paramType (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_promptType (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_szDesc (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY
m_vValue (defined in PROMPT_MAP_ENTRY) | PROMPT_MAP_ENTRY


ZRX API Reference: resbuf Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
resbuf Struct Reference
Structs
+ Inheritance diagram for resbuf:

Public Attributes

struct resbuf * | rbnext
short | restype
union ads_u_val | resval
The documentation for this struct was generated from the following file:
  • adsdef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
resbuf Member List

This is the complete list of members for resbuf, including all inherited members.

rbnext (defined in resbuf) | resbuf
restype (defined in resbuf) | resbuf
resval (defined in resbuf) | resbuf


ZRX API Reference: SecurityParams Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
SecurityParams Struct Reference
Structs

Public Attributes

unsigned long | cbSize
unsigned long | ulAlgId
unsigned long | ulFlags
unsigned long | ulKeyLength
unsigned long | ulProvType
wchar_t * | wszCertIssuer
wchar_t * | wszCertSerialNum
wchar_t * | wszCertSubject
wchar_t * | wszComment
wchar_t * | wszPassword
wchar_t * | wszProvName
wchar_t * | wszTimeServer
The documentation for this struct was generated from the following file:
  • dbsecurity.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
SecurityParams Member List

This is the complete list of members for SecurityParams, including all inherited members.

cbSize (defined in SecurityParams) | SecurityParams
ulAlgId (defined in SecurityParams) | SecurityParams
ulFlags (defined in SecurityParams) | SecurityParams
ulKeyLength (defined in SecurityParams) | SecurityParams
ulProvType (defined in SecurityParams) | SecurityParams
wszCertIssuer (defined in SecurityParams) | SecurityParams
wszCertSerialNum (defined in SecurityParams) | SecurityParams
wszCertSubject (defined in SecurityParams) | SecurityParams
wszComment (defined in SecurityParams) | SecurityParams
wszPassword (defined in SecurityParams) | SecurityParams
wszProvName (defined in SecurityParams) | SecurityParams
wszTimeServer (defined in SecurityParams) | SecurityParams


ZRX API Reference: SignatureInfo Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
SignatureInfo Struct Reference
Structs

Public Attributes

unsigned long | cbSize
AcDbDate * | pTimeCertNotAfter
AcDbDate * | pTimeCertNotBefore
AcDbDate * | pTimestamp
unsigned long | ulFlags
wchar_t * | wszCertIssuer
wchar_t * | wszCertSerialNum
wchar_t * | wszCertSubject
wchar_t * | wszComment
wchar_t * | wszSubjectEMail
wchar_t * | wszTimeServer
wchar_t * | wszX500
The documentation for this struct was generated from the following file:
  • dbsecurity.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
SignatureInfo Member List

This is the complete list of members for SignatureInfo, including all inherited members.

cbSize (defined in SignatureInfo) | SignatureInfo
pTimeCertNotAfter (defined in SignatureInfo) | SignatureInfo
pTimeCertNotBefore (defined in SignatureInfo) | SignatureInfo
pTimestamp (defined in SignatureInfo) | SignatureInfo
ulFlags (defined in SignatureInfo) | SignatureInfo
wszCertIssuer (defined in SignatureInfo) | SignatureInfo
wszCertSerialNum (defined in SignatureInfo) | SignatureInfo
wszCertSubject (defined in SignatureInfo) | SignatureInfo
wszComment (defined in SignatureInfo) | SignatureInfo
wszSubjectEMail (defined in SignatureInfo) | SignatureInfo
wszTimeServer (defined in SignatureInfo) | SignatureInfo
wszX500 (defined in SignatureInfo) | SignatureInfo


ZRX API Reference: tagADUI_DRAGDATA Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
tagADUI_DRAGDATA Struct Reference
Structs

Public Attributes

DROPEFFECT | mDropEffect
DROPEFFECT | mDropList
DWORD | mdwKeyState
COleDataObject * | mpDataObject
POINTL | mPoint
CWnd * | mpWnd
The documentation for this struct was generated from the following file:
  • aduiDropTarget.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
tagADUI_DRAGDATA Member List

This is the complete list of members for tagADUI_DRAGDATA, including all inherited members.

mDropEffect (defined in tagADUI_DRAGDATA) | tagADUI_DRAGDATA
mDropList (defined in tagADUI_DRAGDATA) | tagADUI_DRAGDATA
mdwKeyState (defined in tagADUI_DRAGDATA) | tagADUI_DRAGDATA
mpDataObject (defined in tagADUI_DRAGDATA) | tagADUI_DRAGDATA
mPoint (defined in tagADUI_DRAGDATA) | tagADUI_DRAGDATA
mpWnd (defined in tagADUI_DRAGDATA) | tagADUI_DRAGDATA


ZRX API Reference: tagChildFrmSettings Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
tagChildFrmSettings Struct Reference
Structs

Public Attributes

bool | m_bIsBedit
bool | m_bShowLayoutBar
bool | m_bShowScrollBar
AcColorSettings | m_ColorSettings
CDialogBar * | m_pDialogBar
The documentation for this struct was generated from the following file:
  • rxmfcapi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
tagChildFrmSettings Member List

This is the complete list of members for tagChildFrmSettings, including all inherited members.

m_bIsBedit (defined in tagChildFrmSettings) | tagChildFrmSettings
m_bShowLayoutBar (defined in tagChildFrmSettings) | tagChildFrmSettings
m_bShowScrollBar (defined in tagChildFrmSettings) | tagChildFrmSettings
m_ColorSettings (defined in tagChildFrmSettings) | tagChildFrmSettings
m_pDialogBar (defined in tagChildFrmSettings) | tagChildFrmSettings


ZRX API Reference: tagClipboardInfo Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
tagClipboardInfo Struct Reference
Structs

Public Attributes

ACHAR | chData [1]
AcGePoint3d | dptInsert
DWORD | m_dwThreadId
void * | mpView
int | nFlags
int | nLen
int | nType
RECT | rectGDI
ACHAR | szSignature [4]
ACHAR | szSourceFile [nBlockFileSize]
ACHAR | szTempFile [nBlockFileSize]
The documentation for this struct was generated from the following file:
  • clipdata.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
tagClipboardInfo Member List

This is the complete list of members for tagClipboardInfo, including all inherited members.

chData (defined in tagClipboardInfo) | tagClipboardInfo
dptInsert (defined in tagClipboardInfo) | tagClipboardInfo
m_dwThreadId (defined in tagClipboardInfo) | tagClipboardInfo
mpView (defined in tagClipboardInfo) | tagClipboardInfo
nFlags (defined in tagClipboardInfo) | tagClipboardInfo
nLen (defined in tagClipboardInfo) | tagClipboardInfo
nType (defined in tagClipboardInfo) | tagClipboardInfo
rectGDI (defined in tagClipboardInfo) | tagClipboardInfo
szSignature (defined in tagClipboardInfo) | tagClipboardInfo
szSourceFile (defined in tagClipboardInfo) | tagClipboardInfo
szTempFile (defined in tagClipboardInfo) | tagClipboardInfo


ZRX API Reference: Global Enums

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
Macros | Enumerations
Global Enums

Macros

#define kAcGiSaveWorldDrawForR12 kAcGiForExplode

Enumerations

enum AcadContextMenuMode {
kDefault = 0, kEdit, kCommand, kHotGrip,
kOsnap
}
enum | AcGiArcType { kAcGiArcSimple = 0, kAcGiArcSector, kAcGiArcChord }
enum AcGiAttributeFlags {
kNothing = 0x00, kColor = 0x01, kLine = 0x02, kLineType = 0x04,
kPlotStyle = 0x08, kEverything = 0x0F
}
enum AcGiColorIntensity {
kAcGiMinColorIntensity = 0x0, kAcGiColorIntensity1 = 0x1, kAcGiColorIntensity2 = 0x2, kAcGiColorIntensity3 = 0x3,
kAcGiColorIntensity4 = 0x4, kAcGiColorIntensity5 = 0x5, kAcGiColorIntensity6 = 0x6, kAcGiMaxColorIntensity = 0x7
}
enum AcGiDeviationType {
kAcGiMaxDevForCircle = 0, kAcGiMaxDevForCurve, kAcGiMaxDevForBoundary, kAcGiMaxDevForIsoline,
kAcGiMaxDevForFacet
}
enum | AcGiEdgeStyleMaskValues { kAcGiNoEdgeStyleMask = 0, kAcGiJitterMask = 1, kAcGiOverhangMask = 2, kAcGiEdgeColorMask = 4 }
enum | AcGiFillType { kAcGiFillAlways = 1, kAcGiFillNever }
enum AcGiImageOrg {
kAcGiBitonal, kAcGiPalette, kAcGiGray, kAcGiRGBA,
kAcGiBGRA, kAcGiARGB, kAcGiABGR, kAcGiBGR,
kAcGiRGB
}
enum AcGiImageOrient {
kAcGiXLeftToRightTopFirst, kAcGiXLeftToRightBottomFirst, kAcGiXRightToLeftTopFirst, kAcGiXRightToLeftBottomFirst,
kAcGiYTopToBottomLeftFirst, kAcGiYTopToBottomRightFirst, kAcGiYBottomToTopLeftFirst, kAcGiYBottomToTopRightFirst
}
enum | AcGiLineEndStyle { kButtCap = 0x00, kSquareCap = 0x01, kRoundCap = 0x02, kDiamondCap = 0x03 }
enum AcGiLineFillStyle {
kFillStyleSolid = 0x00, kCheckerboard = 0x01, kCrosshatch = 0x02, kDiamonds = 0x03,
kHorizontal_Bars = 0x04, kSlant_Left = 0x05, kSlant_Right = 0x06, kSquare_Dots = 0x07,
kVertical_Bars = 0x08, kUser_Defined = 0x09
}
enum | AcGiLineJoinStyle { kMiterJoin = 0x00, kBevelJoin = 0x01, kRoundJoin = 0x02, kDiamondJoin = 0x03 }
enum AcGiLineType {
kLineTypeSolid = 0x00, kDashed = 0x01, kDotted = 0x02, kDash_Dot = 0x03,
kShort_Dash = 0x04, kMedium_Dash = 0x05, kLong_Dash = 0x06, kShort_Dash_X2 = 0x07,
kMedium_Dash_X2 = 0x08, kLong_Dash_X2 = 0x09, kMedium_Long_Dash = 0x0A, kMedium_Dash_Short_Dash_Short_Dash = 0x0B,
kLong_Dash_Short_Dash = 0x0C, kLong_Dash_Dot_Dot = 0x0D, kLong_Dash_Dot = 0x0E, kMedium_Dash_Dot_Short_Dash_Dot = 0x0F,
kSparse_Dot = 0x10, kISO_Dash = 0x11, kISO_Dash_Space = 0x12, kISO_Long_Dash_Dot = 0x13,
kISO_Long_Dash_Double_Dot = 0x14, kISO_Long_Dash_Triple_Dot = 0x15, kISO_Dot = 0x16, kISO_Long_Dash_Short_Dash = 0x17,
kISO_Long_Dash_Double_Short_Dash = 0x18, kISO_Dash_Dot = 0x19, kISO_Double_Dash_Dot = 0x1A, kISO_Dash_Double_Dot = 0x1B,
kISO_Double_Dash_Double_Dot = 0x1C, kISO_Dash_Triple_Dot = 0x1D, kISO_Double_Dash_Triple_Dot = 0x1E, kLineTypeNone = 0x1F
}
enum | AcGiMrDiagnosticBSPMode { krDepth = 0, krSize }
enum | AcGiMrDiagnosticGridMode { krObject = 0, krWorld, krCamera }
enum AcGiMrDiagnosticMode {
krOff = 0, krGrid, krPhoton, krSamples,
krBSP
}
enum | AcGiMrDiagnosticPhotonMode { krDensity = 0, krIrradiance }
enum | AcGiMrExposureType { krAutomatic = 0, krLogarithmic }
enum AcGiMrFilter {
krBox = 0, krTriangle, krGauss, krMitchell,
krLanczos
}
enum | AcGiMrFinalGatheringMode { krFinalGatherOff = 0, krFinalGatherOn, krFinalGatherAuto }
enum | AcGiMrShadowMode { krSimple = 0, krSorted, krSegments }
enum AcGiMrTileOrder {
krHilbert = 0, krSpiral, krLeftToRight, krRightToLeft,
krTopToBottom, krBottomToTop
}
enum | AcGiOrientationType { kAcGiCounterClockwise = -1, kAcGiNoOrientation = 0, kAcGiClockwise = 1 }
enum AcGiRegenType {
eZcGiRegenTypeInvalid = 0, kAcGiStandardDisplay = 2, kAcGiHideOrShadeCommand, kAcGiRenderCommand,
kAcGiShadedDisplay = kAcGiRenderCommand, kAcGiForExplode, kAcGiSaveWorldDrawForProxy
}
enum | AcGiRotationFilterType { kDefaultRotationFilter, kInterpolatedRotationFilter, kNearestRotationFilter }
enum AcGiScaleFilterType {
kDefaultScaleFilter, kNearestScaleFilter, kBellScaleFilter, kMitchellScaleFilter,
kTriangleScaleFilter, kCubicScaleFilter, kBsplineScaleFilter, kLanczos3ScaleFilter
}
enum | AcGiScaleType { kDefaultScale, kRelativeScale, kUnTransformedScale }
enum | AcGiVisibility { kAcGiInvisible = 0, kAcGiVisible, kAcGiSilhouette }
enum ACUI_ERROR_CODE {
kAcUiError_None, kAcUiError_Blank, kAcUiError_Symbol, kAcUiError_Numeric,
kAcUiError_Angle, kAcUiError_Zero, kAcUiError_Negative, kAcUiError_Range
}
enum | AcUiOpenNoTemplateFlag { acUiOpenNoTemplateNone = 0x0000, acUiOpenNoTemplateImperail = 0x0001, acUiOpenNoTemplateMetric = 0x0002 }
enum | ADUI_COMMAND_STATE { kAdUiCommand_Cancelled = -1, kAdUiCommand_Completed, kAdUiCommand_Begun }
enum ADUI_NOTIFY {
kAdUiNotify_Nothing, kAdUiNotify_Generic, kAdUiNotify_AppMainWindow, kAdUiNotify_AppResourceInstance,
kAdUiNotify_AutoLoad, kAdUiNotify_Reload, kAdUiNotify_GetTipSupport, kAdUiNotify_GetTipText,
kAdUiNotify_GetTipRect, kAdUiNotify_HitTipRect, kAdUiNotify_DrawTip, kAdUiNotify_DrawTipText,
kAdUiNotify_UpdateTip, kAdUiNotify_HideWindow, kAdUiNotify_ShowWindow, kAdUiNotify_RestoreFocus,
kAdUiNotify_Change, kAdUiNotify_NotValid, kAdUiNotify_Valid, kAdUiNotify_Validate,
kAdUiNotify_CommandState
}
enum ADUI_REPLY {
kAdUiReply_Nothing, kAdUiReply_Ok, kAdUiReply_NotValid, kAdUiReply_Valid,
kAdUiReply_TextTip, kAdUiReply_ToolTip, kAdUiReply_DrawTip
}
enum | DeviceType { kSystemPrinter = 0, kPC3File = 1, kOneOffConfig = 2, kUninitialized = -1 }
enum NAV_DATA_TYPE {
kNavUnknown, kNavShellItem, kNavURL, kNavUNC,
kNavExtension, kNavWebFolders
}
enum | NavInetTransferActions { NAV_INET_IGNORE_CACHE = 0x1, NAV_INET_STOP_ON_ERROR = 0x2, NAV_INET_KEEP_CACHE = 0x4 }
enum NavToolsMenuItem {
NAV_TOOLS_ITEM_FIND = 0x1, NAV_TOOLS_ITEM_LOCATE = 0x2, NAV_TOOLS_ITEM_FTPMODIFY = 0x4, NAV_TOOLS_ITEM_SIMPLESTORAGE = 0x8,
NAV_TOOLS_ITEM_ADDCURRENT = 0x10, NAV_TOOLS_ITEM_ADDFAVORITES = 0x20
}
enum | OkHandlerErr { NAV_OKHANDLER_SUCCESS = 0, NAV_OKHANDLER_NONFILESYSTEM, NAV_OKHANDLER_FAILURE }
enum PreviewStatus {
kNormal = 0, kPlot, kCancel, kNext,
kPrevious
}
enum | ProcessPlotState { kNotPlotting = 0, kForegroundPlotting, kBackgroundPlotting }
enum | undoSubcommandActivities { kNone = 0, kOne = 1, kAll = 2 }
enum xrefSubcommandActivities {
kStart = 0, kStartItem = 2, kEndItem = 3, kEnd = 4,
kWillAbort = 5, kAborted = 6, kStartXBindBlock = 7, kStartXBindSymbol = 8
}

Detailed Description


ZRX API Reference: Class List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
o N AcDbSymbolUtilities |
| \ C Services |
o N AcEdSymbolUtilities |
| \ C Services |
o C _ADSSYMBOL_ENTRY |
o C _ARXCOMMAND_ENTRY |
o C _DBX_REGISTER_OBJECT_ENTRY |
o C _dlgControlTag |
o C _IID |
o C _OPM_DYNPROP_ENTRY |
o C Ac3dDwfNavTreeNode |
o C Acad |
o C ACAD_OPMPROPMAP_ENTRY |
o C AcadApp |
o C AcadAppInfo |
o C AcadToolImpl |
| \ C TOOL_MAP_ENTRY |
o C AcAp |
o C AcApDataManager |
o C AcApDocManager |
| \ C DocOpenParams |
o C AcApDocManagerReactor |
o C AcApDocument |
o C AcApDocumentIterator |
o C AcApLayoutManager |
o C AcApLongTransactionManager |
o C AcApLongTransactionReactor |
o C AcApProfileManager |
o C AcApProfileManagerReactor |
o C AcApProfileStorage |
o C AcApStatusBar |
o C AcArray |
o C AcArrayMemCopyReallocator |
o C AcArrayObjectCopyReallocator |
o C AcAxDocLock |
o C AcAxMatrix3d |
o C AcAxObjectRef |
o C AcAxObjectRefPtr |
o C AcAxOleLinkManager |
o C AcAxPoint2d |
o C AcAxPoint2dArray |
o C AcAxPoint3d |
o C AcAxPoint3dArray |
o C AcCell |
o C AcCellRange |
o C AcCFile |
o C AcCmColor |
o C AcCmColorBase |
o C AcCmComplexColor |
o C AcCmDialogColor |
o C AcCmEntityColor |
| \ C RGBM |
o C AcCmTransparency |
o C AcColorSettings |
o C AcColorSettingsEx |
o C AcCStdioFile |
o C AcDb |
o C AcDb2dPolyline |
o C AcDb2dVertex |
o C AcDb2LineAngularDimension |
o C AcDb3dPolyline |
o C AcDb3dPolylineVertex |
o C AcDb3dSolid |
o C AcDb3PointAngularDimension |
o C AcDbAbstractViewTable |
o C AcDbAbstractViewTableIterator |
o C AcDbAbstractViewTableRecord |
o C AcDbAlignedDimension |
o C AcDbAlignment |
o C AcDbAnnotationScale |
o C AcDbAnnotativeObjectPE |
o C AcDbAppEntityGrips |
o C AcDbAppSystemVariables |
o C AcDbArc |
o C AcDbArcDimension |
o C AcDbAttribute |
o C AcDbAttributeDefinition |
o C AcDbAuditInfo |
o C AcDbAuditRecreatePE |
o C AcDbBackground |
o C AcDbBlockBegin |
o C AcDbBlockChangeIterator |
o C AcDbBlockEnd |
o C AcDbBlockInsertionPoints |
o C AcDbBlockReference |
o C AcDbBlockReferenceIdIterator |
o C AcDbBlockTable |
o C AcDbBlockTableIterator |
o C AcDbBlockTableRecord |
o C AcDbBlockTableRecordIterator |
o C AcDbBody |
o C AcDbBreakData |
o C AcDbBreakPointRef |
o C AcDbCamera |
o C AcDbCircle |
o C AcDbClassIterator |
o C AcDbColor |
o C AcDbCompositeFilteredBlockIterator |
o C AcDbCurve |
o C AcDbCurvePath |
o C AcDbCustomOsnapInfo |
o C AcDbCustomOsnapManager |
o C AcDbCustomOsnapMode |
o C AcDbDatabase |
o C AcDbDatabaseReactor |
o C AcDbDatabaseSummaryInfo |
o C AcDbDataCell |
o C AcDbDataColumn |
o C AcDbDataLink |
o C AcDbDataLinkManager |
o C AcDbDataTable |
o C AcDbDate |
o C AcDbDeepCloneFiler |
o C AcDbDgnDefinition |
o C AcDbDgnReference |
o C AcDbDgnUnderlayItem |
o C AcDbDiametricDimension |
o C AcDbDictionary |
o C AcDbDictionaryIterator |
o C AcDbDictionaryWithDefault |
o C AcDbDimAssoc |
o C AcDbDimData |
o C AcDbDimension |
o C AcDbDimStyleTable |
o C AcDbDimStyleTableIterator |
o C AcDbDimStyleTableRecord |
o C AcDbDoubleClickEdit |
o C AcDbDwfDefinition |
o C AcDbDwfReference |
o C AcDbDwgFiler |
o C AcDbDxfFiler |
o C AcDbDynamicUCSPE |
o C AcDbDynBlockReference |
o C AcDbDynBlockReferenceProperty |
o C AcDbEllipse |
o C AcDbEntity |
o C AcDbEntityHyperlinkPE |
o C AcDbEntityReactor |
o C AcDbEvalConnectable |
o C AcDbEvalContext |
o C AcDbEvalContextIterator |
o C AcDbEvalContextPair |
o C AcDbEvalEdgeInfo |
o C AcDbEvalExpr |
o C AcDbEvalGraph |
o C AcDbEvalIdMap |
o C AcDbEvalVariant |
o C AcDbExtents |
o C AcDbExtrudedSurface |
o C AcDbFace |
o C AcDbFaceRecord |
o C AcDbFcf |
o C AcDbField |
o C AcDbFilter |
o C AcDbFilteredBlockIterator |
o C AcDbFormattedTableData |
o C AcDbFrame |
o C AcDbFullSubentPath |
o C AcDbGradientBackground |
o C AcDbGraph |
o C AcDbGraphNode |
o C AcDbGraphStack |
o C AcDbGripData |
o C AcDbGroundPlaneBackground |
o C AcDbGroup |
o C AcDbGroupIterator |
o C AcDbHandle |
o C AcDbHardOwnershipId |
o C AcDbHardPointerId |
o C AcDbHatch |
o C AcDbHelix |
o C AcDbHostApplicationProgressMeter |
o C AcDbHostApplicationServices |
o C AcDbHyperlink |
o C AcDbHyperlinkCollection |
o C AcDbIdMapping |
o C AcDbIdMappingIter |
o C AcDbIdPair |
o C AcDbImage |
o C AcDbImageBackground |
o C AcDbIndex |
o C AcDbIndexUpdateData |
o C AcDbIndexUpdateDataIterator |
o C AcDbInterferencePE |
o C AcDbLayerFilter |
o C AcDbLayerIndex |
o C AcDbLayerIndexIterator |
o C AcDbLayerStateManager |
o C AcDbLayerStateManagerReactor |
o C AcDbLayerTable |
o C AcDbLayerTableIterator |
o C AcDbLayerTableRecord |
o C AcDbLayout |
o C AcDbLayoutManager |
o C AcDbLayoutManagerReactor |
o C AcDbLeader |
o C AcDbLight |
o C AcDbLine |
o C AcDbLinetypeTable |
o C AcDbLinetypeTableIterator |
o C AcDbLinetypeTableRecord |
o C AcDbLinkedData |
o C AcDbLinkedTableData |
o C AcDbLoftedSurface |
o C AcDbLoftOptions |
o C AcDbLongTransaction |
o C AcDbLongTransWorkSetIterator |
o C AcDbMatchProperties |
o C AcDbMaterial |
o C AcDbMentalRayRenderSettings |
o C AcDbMInsertBlock |
o C AcDbMLeader |
o C AcDbMLeaderStyle |
o C AcDbMline |
o C AcDbMlineStyle |
o C AcDbMotionPath |
o C AcDbMPolygon |
o C AcDbMPolygonCrossing |
o C AcDbMPolygonCrossingArray |
o C AcDbMpolygonLoops |
o C AcDbMPolygonNode |
o C AcDbMText |
o C AcDbMTextFragment |
o C AcDbNamedPath |
o C AcDbObject |
o C AcDbObjectContext |
o C AcDbObjectContextCollection |
o C AcDbObjectContextCollectionIterator |
o C AcDbObjectContextInterface |
o C AcDbObjectContextManager |
o C AcDbObjectId |
o C AcDbObjectIdGraph |
o C AcDbObjectIdGraphNode |
o C AcDbObjectIterator |
o C AcDbObjectPointer |
o C AcDbObjectPointerBase |
o C AcDbObjectReactor |
o C AcDbOle2Frame |
o C AcDbOleFrame |
o C AcDbOrdinateDimension |
o C AcDbOsnapPointRef |
o C AcDbPaperOrientationPE |
o C AcDbPasswordedFile |
o C AcDbPlaceHolder |
o C AcDbPlaneSurface |
o C AcDbPlotSettings |
o C AcDbPlotSettingsValidator |
o C AcDbPoint |
o C AcDbPointPath |
o C AcDbPointRef |
o C AcDbPolyFaceMesh |
o C AcDbPolyFaceMeshVertex |
o C AcDbPolygonMesh |
o C AcDbPolygonMeshVertex |
o C AcDbPolyline |
o C AcDbProxyEntity |
o C AcDbProxyObject |
o C AcDbR13ObjectId |
o C AcDbRadialDimension |
o C AcDbRadialDimensionLarge |
o C AcDbRasterImage |
o C AcDbRasterImageDef |
o C AcDbRasterImageDefFileAccessReactor |
o C AcDbRasterImageDefReactor |
o C AcDbRasterImageDefTransReactor |
o C AcDbRasterVariables |
o C AcDbRay |
o C AcDbRecover |
o C AcDbRecoverCallBack |
o C AcDbRegAppTable |
o C AcDbRegAppTableIterator |
o C AcDbRegAppTableRecord |
o C AcDbRegion |
o C AcDbRenderEnvironment |
o C AcDbRenderGlobal |
o C AcDbRenderSettings |
o C AcDbRevolvedSurface |
o C AcDbRevolveOptions |
o C AcDbRotatedDimension |
o C AcDbSection |
o C AcDbSectionManager |
o C AcDbSectionManagerIterator |
o C AcDbSectionSettings |
o C AcDbSelectGrip |
o C AcDbSequenceEnd |
o C AcDbServices |
o C AcDbShape |
o C AcDbSkyBackground |
o C AcDbSoftOwnershipId |
o C AcDbSoftPointerId |
o C AcDbSolid |
o C AcDbSolidBackground |
o C AcDbSortentsTable |
o C AcDbSpatialFilter |
o C AcDbSpatialIndex |
o C AcDbSpatialIndexIterator |
o C AcDbSpline |
o C AcDbSubentId |
o C AcDbSummaryInfoManager |
o C AcDbSummaryInfoReactor |
o C AcDbSun |
o C AcDbSurface |
o C AcDbSweepOptions |
o C AcDbSweptSurface |
o C AcDbSymbolTable |
o C AcDbSymbolTableIterator |
o C AcDbSymbolTablePointer |
o C AcDbSymbolTableRecord |
o C AcDbSymbolTableRecordPointer |
o C AcDbTable |
o C AcDbTableContent |
o C AcDbTableIterator |
o C AcDbTableStyle |
o C AcDbTableTemplate |
o C AcDbText |
o C AcDbTextStyleTable |
o C AcDbTextStyleTableIterator |
o C AcDbTextStyleTableRecord |
o C AcDbTrace |
o C AcDbTransactionManager |
o C AcDbUCSTable |
o C AcDbUCSTableIterator |
o C AcDbUCSTableRecord |
o C AcDbUnderlayDefinition |
o C AcDbUnderlayDrawContext |
o C AcDbUnderlayFile |
o C AcDbUnderlayHost |
o C AcDbUnderlayItem |
o C AcDbUnderlayReference |
o C AcDbVertex |
o C AcDbViewport |
o C AcDbViewportTable |
o C AcDbViewportTableIterator |
o C AcDbViewportTableRecord |
o C AcDbViewTable |
o C AcDbViewTableIterator |
o C AcDbViewTableRecord |
o C AcDbVisualStyle |
o C AcDbWblockCloneFiler |
o C AcDbWipeout |
o C AcDbXline |
o C AcDbXObject |
o C AcDbXrecord |
o C AcDbXrecordIterator |
o C AcDbXrefGraph |
o C AcDbXrefGraphNode |
o C AcDbXrefObjectId |
o C AcDMMEntityReactorInfo |
o C AcDMMEPlotProperties |
o C AcDMMEPlotProperty |
o C AcDMMNode |
o C AcDMMReactor |
o C AcDMMResourceInfo |
o C AcDMMSheetReactorInfo |
o C AcDMMWideString |
o C AcDMMXMLAttribute |
o C AcEdAppGripService |
o C AcEdCommand |
o C AcEdCommandIterator |
o C AcEdCommandStack |
o C AcEdCommandStruc |
o C AcEdInputContextReactor |
o C AcEdInputPointFilter |
o C AcEdInputPointManager |
o C AcEdInputPointMonitor |
o C AcEditor |
o C AcEditorReactor |
o C AcEditorReactor2 |
o C AcEdJig |
o C AcEdSelectionSetService |
o C AcEdServices |
o C AcEdSolidSubentitySelector |
o C AcEdSSGetFilter |
o C AcEdSSGetFilter2 |
o C AcEdSSGetFilter3 |
o C AcEdSSGetSubSelectFilter |
o C AcEdSubSelectFilter |
o C AcEdSubSelectFilterService |
o C AcEdUIContext |
o C AcEdXrefFileLock |
o C AcFd |
o C AcFdFieldEngine |
o C AcFdFieldEvaluator |
o C AcFdFieldEvaluatorLoader |
o C AcFdFieldReactor |
o C AcFdFieldResult |
o C AcFdFieldValue |
o C AcFILE |
o C AcFileDependencyInfo |
o C AcFileDependencyManager |
o C AcGe |
o C AcGeAugPolyline3d |
o C AcGeBoundBlock2d |
o C AcGeBoundBlock3d |
o C AcGeBoundedPlane |
o C AcGeCircArc2d |
o C AcGeCircArc3d |
o C AcGeClipBoundary2d |
o C AcGeCompositeCurve2d |
o C AcGeCompositeCurve3d |
o C AcGeCone |
o C AcGeContext |
o C AcGeCubicSplineCurve2d |
o C AcGeCubicSplineCurve3d |
o C AcGeCurve2d |
o C AcGeCurve3d |
o C AcGeCurveBoundary |
o C AcGeCurveCurveInt2d |
o C AcGeCurveCurveInt3d |
o C AcGeCurveSurfInt |
o C AcGeCylinder |
o C AcGeDwgIO |
o C AcGeDxfIO |
o C AcGeEllipArc2d |
o C AcGeEllipArc3d |
o C AcGeEntity2d |
o C AcGeEntity3d |
o C AcGeExternalBoundedSurface |
o C AcGeExternalCurve2d |
o C AcGeExternalCurve3d |
o C AcGeExternalSurface |
o C AcGeFileIO |
o C AcGeFiler |
o C AcGeInterval |
o C AcGeKnotVector |
o C AcGeLibVersion |
o C AcGeLine2d |
o C AcGeLine3d |
o C AcGeLinearEnt2d |
o C AcGeLinearEnt3d |
o C AcGeLineSeg2d |
o C AcGeLineSeg3d |
o C AcGeMatrix2d |
o C AcGeMatrix3d |
o C AcGeNurbCurve2d |
o C AcGeNurbCurve3d |
o C AcGeNurbSurface |
o C AcGeOffsetCurve2d |
o C AcGeOffsetCurve3d |
o C AcGeOffsetSurface |
o C AcGePlanarEnt |
o C AcGePlane |
o C AcGePoint2d |
o C AcGePoint3d |
o C AcGePointEnt2d |
o C AcGePointEnt3d |
o C AcGePointOnCurve2d |
o C AcGePointOnCurve3d |
o C AcGePointOnSurface |
o C AcGePolyline2d |
o C AcGePolyline3d |
o C AcGePosition2d |
o C AcGePosition3d |
o C AcGeRay2d |
o C AcGeRay3d |
o C AcGeScale2d |
o C AcGeScale3d |
o C AcGeSphere |
o C AcGeSplineEnt2d |
o C AcGeSplineEnt3d |
o C AcGeSurface |
o C AcGeSurfSurfInt |
o C AcGeTol |
o C AcGeTorus |
o C AcGeVector2d |
o C AcGeVector3d |
o C AcGiClipBoundary |
o C AcGiColorRGB |
o C AcGiColorRGBA |
o C AcGiCommonDraw |
o C AcGiContext |
o C AcGiContextualColors |
o C AcGiContextualColors2 |
o C AcGiDisplayStyle |
o C AcGiDistantLightTraits |
o C AcGiDistantLightTraits2 |
o C AcGiDrawable |
o C AcGiDrawableTraits |
o C AcGiEdgeData |
o C AcGiEdgeStyle |
o C AcGiFaceData |
o C AcGiFaceStyle |
o C AcGiGenericTexture |
o C AcGiGeometry |
o C AcGiGlyph |
o C AcGiGradientBackgroundTraits |
o C AcGiGroundPlaneBackgroundTraits |
o C AcGiImageBackgroundTraits |
o C AcGiImageFileTexture |
o C AcGiImageTexture |
o C AcGiLightAttenuation |
o C AcGiLightTraits |
o C AcGiLineAttributes |
o C AcGiLineAttrUtils |
o C AcGiLinetypeEngine |
o C AcGiMapper |
o C AcGiMarbleTexture |
o C AcGiMaterialColor |
o C AcGiMaterialMap |
o C AcGiMaterialTexture |
o C AcGiMaterialTraits |
o C AcGiMaterialTraits2 |
o C AcGiMentalRayRenderSettingsTraits |
o C AcGiMentalRayRenderSettingsTraits2 |
o C AcGiNonEntityTraits |
o C AcGiPointLightTraits |
o C AcGiPointLightTraits2 |
o C AcGiProceduralTexture |
o C AcGiRenderEnvironmentTraits |
o C AcGiRenderSettingsTraits |
o C AcGiRequestScanLines |
o C AcGiSentScanLines |
o C AcGiShadowParameters |
o C AcGiShadowParameters2 |
o C AcGiSkyBackgroundTraits |
o C AcGiSkyParameters |
o C AcGiSolidBackgroundTraits |
o C AcGiSpotLightTraits |
o C AcGiSpotLightTraits2 |
o C AcGiStandardLightTraits |
o C AcGiStyleAttributes |
o C AcGiSubEntityTraits |
o C AcGiTextEngine |
o C AcGiTextStyle |
o C AcGiToneOperatorParameters |
o C AcGiVariant |
| \ C EnumType |
o C AcGiVertexData |
o C AcGiViewport |
o C AcGiViewportDraw |
o C AcGiViewportGeometry |
o C AcGiViewportTraits |
o C AcGiViewportTraits2 |
o C AcGiVisualStyle |
o C AcGiVisualStyleTraits |
o C AcGiWebLightTraits |
o C AcGiWoodTexture |
o C AcGiWorldDraw |
o C AcGiWorldGeometry |
o C AcGridProperty |
o C AcGs |
o C AcGs2DViewLimitManager |
o C AcGsClassFactory |
o C AcGsClientViewInfo |
o C AcGsColor |
o C AcGsConfig |
o C AcGsDCPoint |
o C AcGsDCRect |
o C AcGsDevice |
o C AcGsManager |
o C AcGsModel |
o C AcGsNode |
o C AcGsReactor |
o C AcGsRenderProgressMonitor |
o C AcGsRenderStatistics |
o C AcGsScreenShot |
o C AcGsView |
o C AcHeapOperators |
o C AcHyperlink |
o C AcIfstream |
o C AcLispAppInfo |
o C AcLyAndExpr |
o C AcLyBoolExpr |
o C AcLyLayerFilter |
o C AcLyLayerFilterManager |
o C AcLyLayerGroup |
o C AcLyRelExpr |
o C AcNameValuePair |
o C AcOfstream |
o C AcOutputBufMgr |
o C AcPane |
o C AcPl3dDwfOptions |
o C ACPL_PREVIEWENDPLOT |
o C AcPlDSDData |
o C AcPlDSDEntry |
o C AcPlHostAppServices |
o C AcPlObject |
o C AcPlPlotConfig |
o C AcPlPlotConfigInfo |
o C AcPlPlotConfigManager |
o C AcPlPlotEngine |
o C AcPlPlotErrorHandler |
o C AcPlPlotErrorHandlerLock |
o C AcPlPlotFactory |
o C AcPlPlotInfo |
o C AcPlPlotInfoValidator |
o C AcPlPlotLogger |
o C AcPlPlotLoggingErrorHandler |
o C AcPlPlotPageInfo |
o C AcPlPlotProgress |
o C AcPlPlotProgressDialog |
o C AcPlPlotReactor |
o C AcPlPlotReactorMgr |
o C AcPublishAggregationInfo |
o C AcPublishBeforeJobInfo |
o C AcPublishBeginJobInfo |
o C AcPublishReactor |
o C AcPublishReactorInfo |
o C AcPublishSheetInfo |
o C AcPublishUIReactor |
o C AcPublishUIReactorInfo |
o C AcRx |
o C AcRxArxApp |
o C AcRxDbxApp |
o C AcRxDictionary |
o C AcRxDictionaryIterator |
o C AcRxDLinkerReactor |
o C AcRxDynamicLinker |
o C AcRxDynPropManager |
o C AcRxEvent |
o C AcRxEventReactor |
o C AcRxIterator |
o C AcRxKernel |
o C AcRxObject |
o C AcRxProtocolReactor |
o C AcRxProtocolReactorIterator |
o C AcRxProtocolReactorList |
o C AcRxProtocolReactorListIterator |
o C AcRxProtocolReactorManager |
o C AcRxProtocolReactorManagerFactory |
o C AcRxService |
o C AcStatusBarItem |
o C AcStatusBarMenuItem |
o C AcString |
o C ACTC_IMAGE_INFO |
o C ACTC_TARGET_PRODUCT_INFO |
o C AcTcCatalog |
o C AcTcCatalogItem |
o C AcTcCatalogItemReactor |
o C AcTcCatalogSet |
o C AcTcCategory |
o C AcTcImage |
o C AcTcImageList |
o C AcTcManager |
o C AcTcPackage |
o C AcTcPalette |
o C AcTcScheme |
o C AcTcStockTool |
o C AcTcTool |
o C ACTCUI_DRAG_HEADER |
o C AcTransaction |
o C AcTransactionManager |
o C AcTransactionReactor |
o C AcTrayItem |
o C AcTrayItemAnimationControl | For internal use only
o C AcTrayItemBubbleWindowControl |
o C AcUnderlayLayer |
o C AcUt |
o C AcValue |
o C AdCharFormatter |
o C Adesk |
o C ads_binary |
o C ads_callback_packet |
o C ads_u_val |
o C AdUiBmpBtnData |
o C AdUiGroupCtrlData |
o C AsdkPromptBase |
o C asi_date |
o C asi_day |
o C asi_daytohour |
o C asi_daytominute |
o C asi_daytosecond |
o C asi_hour |
o C asi_hourtominute |
o C asi_hourtosecond |
o C asi_minute |
o C asi_minuteitosecond |
o C asi_month |
o C asi_second |
o C asi_time |
o C asi_timestamp |
o C asi_year |
o C asi_yeartomonth |
o C CAcExtensionModule |
o C CAcFdUiFieldDialog |
o C CAcFdUiFieldDialogHook |
o C CAcFdUiFieldFormatDialog |
o C CAcFdUiFieldFormatList |
o C CAcFdUiFieldManager |
o C CAcFdUiFieldOptionDialog |
o C CAcFdUiFormatDialog |
o C CAcFdUiFormatList |
o C CAcGradientThumbnailEngine |
o C CAcModuleResourceOverride |
o C CAcTcUiCatalogView |
o C CAcTcUiCatalogViewItem |
o C CAcTcUiManager |
o C CAcTcUiPaletteView |
o C CAcTcUiScheme |
o C CAcTcUiToolPalette |
o C CAcTcUiToolPaletteGroup |
o C CAcTcUiToolPaletteSet |
o C CAcUiAngleComboBox |
o C CAcUiAngleEdit |
o C CAcUiArrowHeadComboBox |
o C CAcUiBitmapButton |
o C CAcUiBitmapStatic |
o C CAcUiColorComboBox |
o C CAcUiComboBox |
o C CAcUiDialog |
o C CAcUiDialogBar |
o C CAcUiDialogWorksheet |
o C CAcUiDockControlBar |
o C CAcUiDockFrame |
o C CAcUiDropSite |
o C CAcUiEdit |
o C CAcUiFileDialog |
o C CAcUiLineTypeComboBox |
o C CAcUiLineWeightComboBox |
o C CAcUiLTypeRecord |
o C CAcUiMRUComboBox |
o C CAcUiMRUListBox |
o C CAcUiNavDialog |
o C CAcUiNumericComboBox |
o C CAcUiNumericEdit |
o C CAcUiOwnerDrawButton |
o C CAcUiPaletteSetDockFrame |
o C CAcUiPathname |
o C CAcUiPickButton |
o C CAcUiPlotStyleNamesComboBox |
o C CAcUiPlotStyleTablesComboBox |
o C CAcUiPredefBlockComboBox |
o C CAcUiSelectButton |
o C CAcUiString |
o C CAcUiStringComboBox |
o C CAcUiStringEdit |
o C CAcUiStringExp |
o C CAcUiSymbolComboBox |
o C CAcUiSymbolEdit |
o C CAcUiTab |
o C CAcUiTabChildDialog |
o C CAcUiTabMainDialog |
o C CAcUiToolButton |
o C CAcUiTrueColorComboBox |
o C CAdUiBalloonTip |
o C CAdUiBaseDialog |
o C CAdUiBitmapButton |
o C CAdUiBitmapStatic |
o C CAdUiCDFSVolumeDescriptor |
o C CAdUiComboBox |
o C CAdUiCoupledGroupCtrl |
o C CAdUiDialog |
o C CAdUiDialogBar |
o C CAdUiDialogWorksheet |
o C CAdUiDockControlBar |
o C CAdUiDockFrame |
o C CAdUiDrawTipText |
o C CAdUiDropSite |
o C CAdUiDropTarget |
o C CAdUiEdit |
o C CAdUiFATVolumeDescriptor |
o C CAdUiFileDialog |
o C CAdUiGroupCtrl |
o C CAdUiHeaderCtrl |
o C CAdUiHPFSVolumeDescriptor |
o C CAdUiListBox |
o C CAdUiListCtrl |
o C CAdUiNOFSVolumeDescriptor |
o C CAdUiNTFSVolumeDescriptor |
o C CAdUiODButtonThemeModReactor |
o C CAdUiOwnerDrawButton |
o C CAdUiPalette |
o C CAdUiPaletteSet |
o C CAdUiPaletteSetDockFrame |
o C CAdUiPathname |
o C CAdUiRegistryAccess |
o C CAdUiRegistryDeleteAccess |
o C CAdUiRegistryWriteAccess |
o C CAdUiTab |
o C CAdUiTabChildDialog |
o C CAdUiTabExtensionManager |
o C CAdUiTabMainDialog |
o C CAdUiTextTip |
o C CAdUiTheme |
o C CAdUiThemeManager |
o C CAdUiThemeMgrReactor |
o C CAdUiThemeModifiedReactor |
o C CAdUiTipWindow |
o C CAdUiToolButton |
o C CAdUiTrackButton |
o C CAdUiUFSVolumeDescriptor |
o C CAdUiVFATVolumeDescriptor |
o C CAdUiVolumeDescriptor |
o C CAseApiObj |
o C CAseAppl |
o C CAseLink |
o C CAseLinkPath |
o C CAseLinkSel |
o C CAsiAppl |
o C CAsiApproxNum |
o C CAsiBinary |
o C CAsiBlob |
o C CAsiChar |
o C CAsiColumn |
o C CAsiCsr |
o C CAsiCsrInfSchema |
o C CAsiCsrRegTable |
o C CAsiCsrTable |
o C CAsiData |
o C CAsiDate |
o C CAsiDatetime |
o C CAsiDecimal |
o C CAsiDouble |
o C CAsiDT |
o C CAsiEnumerator |
o C CAsiExactNum |
o C CAsiException |
o C CAsiExceptionHandler |
o C CAsiExecStm |
o C CAsiFloat |
o C CAsiHostBuffer |
o C CAsiIdent |
o C CAsiInt |
o C CAsiInterval |
o C CAsiIQualifier |
o C CAsiIRow |
o C CAsiList |
o C CAsiNum |
o C CAsiNumeric |
o C CAsiObject |
o C CAsiParameter |
o C CAsiReal |
o C CAsiRow |
o C CAsiSession |
o C CAsiSmallInt |
o C CAsiSQLObject |
o C CAsiStm |
o C CAsiTACond |
o C CAsiTCCond |
o C CAsiTime |
o C CAsiTimeStamp |
o C CAsiUcChar |
o C CAsiUcStr |
o C CAsiYM |
o C CATCMDBTN_ENTRY |
o C CATEGORY_ENTRY |
o C CMDBTN_ENTRY |
o C CNavArray |
o C CNavData |
o C CNavDataArray |
o C CNavDialog |
o C CNavDropSource |
o C CNavFilter |
o C CNavFilterArray |
o C CNavListCtrl |
o C CProxy_AcadObjectEvents |
o C CProxy_PropertyNotifySink |
o C CRectangle3d |
o C CTypedPtrArray |
o C e2f_ent |
o C e2f_hdr |
o C e2f_layer |
o C e2f_xform |
o C fchnd |
o C IAcadBaseDatabaseImpl |
o C IAcadBaseObject |
o C IAcadBaseObject2 |
o C IAcadBaseObject2Impl |
o C IAcadBaseObjectImpl |
o C IAcadBaseSubEntityImpl |
o C IAcadEntityDispatchImpl |
o C IAcadObjectDispatchImpl |
o C IAcadShadowDisplayImpl |
o C IAcPiCategorizePropertiesImpl |
o C IAcPiPropCommandButtonsImpl |
o C IAcPiPropertyDisplayImpl |
o C IConnectionPointContainerImpl |
o C IConnectionPointImpl |
o C IOPMPropertyExtensionImpl |
o C IOPMPropertyExtensionImpl2 |
o C IRetrieveApplicationImpl |
o C ListItem |
o C Mline |
o C OPMPerInstancePropertyExtension |
o C OPMPerInstancePropertyExtensionFactory |
o C OPMPerInstancePropertySources |
o C OPMPropertyExtension |
o C OPMPropertyExtensionFactory |
o C OwnerDraw3d |
o C PER_FLYOUT_ENTRY |
o C PER_PROP_DISP_ENTRY |
o C PER_PROP_DISP_ENTRY2 |
o C PROMPT_MAP_ENTRY |
o C resbuf |
o C RxADSAppTableEntryType |
o C scn_cmesh |
o C scn_cvrt |
o C scn_node |
o C scn_pmsh |
o C scn_vrtc |
o C SecurityParams |
o C SignatureInfo |
o C tagADUI_DRAGDATA |
o C tagChildFrmSettings |
o C tagClipboardInfo |
o C tagOPMDWORD |
\ C tagOPMLPOLESTR |


ZRX API Reference: AcDbSymbolUtilities::Services Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcDbSymbolUtilities
  • Services
Public Types | Public Member Functions | List of all members
AcDbSymbolUtilities::Services Class Reference

Public Types

enum { kCurrentVersion = ACDBSYMUTIL_SERVICES_CURRENT_VERSION }

Public Member Functions

virtual AcDbObjectId | blockModelSpaceId (AcDbDatabase *pDb) const =0
virtual const ACHAR * | blockModelSpaceName () const =0
virtual AcDbObjectId | blockPaperSpaceId (AcDbDatabase *pDb) const =0
virtual const ACHAR * | blockPaperSpaceName () const =0
virtual int | compareSymbolName (const ACHAR *thisName, const ACHAR *otherName) const =0
virtual bool | compatibilityMode (AcDbDatabase *pDb) const =0
virtual Acad::ErrorStatus | getBlockNameFromInsertPathName (ACHAR *&pBlockName, const ACHAR *pathName) const =0
virtual Acad::ErrorStatus | getInsertPathNameFromBlockName (ACHAR *&pPathName, const ACHAR *blockName) const =0
virtual bool | getMaxSymbolNameLength (size_t &maxLength, size_t &maxSize, bool isNewName, bool compatibilityMode) const =0
virtual Acad::ErrorStatus | getPathNameFromSymbolName (ACHAR *&pPathName, const ACHAR *symbolName, const ACHAR *extensions) const =0
virtual Acad::ErrorStatus | getSymbolNameFromPathName (ACHAR *&pSymbolName, const ACHAR *pathName, const ACHAR *extensions) const =0
virtual bool | hasVerticalBar (const ACHAR *name) const =0
virtual bool | isBlockLayoutName (const ACHAR *name) const =0
virtual bool | isBlockModelSpaceName (const ACHAR *name) const =0
virtual bool | isBlockPaperSpaceName (const ACHAR *name) const =0
virtual bool | isLayerDefpointsName (const ACHAR *name) const =0
virtual bool | isLayerZeroName (const ACHAR *name) const =0
virtual bool | isLinetypeByBlockName (const ACHAR *name) const =0
virtual bool | isLinetypeByLayerName (const ACHAR *name) const =0
virtual bool | isLinetypeContinuousName (const ACHAR *name) const =0
virtual bool | isRegAppAcadName (const ACHAR *name) const =0
virtual bool | isTextStyleStandardName (const ACHAR *name) const =0
virtual bool | isViewportActiveName (const ACHAR *name) const =0
virtual AcDbObjectId | layerDefpointsId (AcDbDatabase *pDb) const =0
virtual const ACHAR * | layerDefpointsName () const =0
virtual AcDbObjectId | layerZeroId (AcDbDatabase *pDb) const =0
virtual const ACHAR * | layerZeroName () const =0
virtual AcDbObjectId | linetypeByBlockId (AcDbDatabase *pDb) const =0
virtual const ACHAR * | linetypeByBlockName () const =0
virtual AcDbObjectId | linetypeByLayerId (AcDbDatabase *pDb) const =0
virtual const ACHAR * | linetypeByLayerName () const =0
virtual AcDbObjectId | linetypeContinuousId (AcDbDatabase *pDb) const =0
virtual const ACHAR * | linetypeContinuousName () const =0
virtual Acad::ErrorStatus | makeDependentName (ACHAR *&pNewName, const ACHAR *dwgName, const ACHAR *symbolName) const =0
virtual Acad::ErrorStatus | preValidateSymbolName (ACHAR *&pSymbolName, bool preserveCase) const =0
virtual AcDbObjectId | regAppAcadId (AcDbDatabase *pDb) const =0
virtual const ACHAR * | regAppAcadName () const =0
virtual Acad::ErrorStatus | repairPreExtendedSymbolName (ACHAR *&pNewName, const ACHAR *oldName, bool allowVerticalBar) const =0
virtual Acad::ErrorStatus | repairSymbolName (ACHAR *&pNewName, const ACHAR *oldName, bool allowVerticalBar) const =0
virtual bool | splitDependentName (size_t &numLeftBytes, const ACHAR *&pRight, const ACHAR *symbolName) const =0
virtual AcDbObjectId | textStyleStandardId (AcDbDatabase *pDb) const =0
virtual const ACHAR * | textStyleStandardName () const =0
virtual Acad::ErrorStatus | validateCompatibleSymbolName (const ACHAR *name, bool isNewName, bool allowVerticalBar, bool compatibilityMode) const =0
virtual Acad::ErrorStatus | validatePreExtendedSymbolName (const ACHAR *name, bool allowVerticalBar) const =0
virtual Acad::ErrorStatus | validateSymbolName (const ACHAR *name, bool allowVerticalBar) const =0
virtual int | version () const =0
virtual const ACHAR * | viewportActiveName () const =0
The documentation for this class was generated from the following file:
  • dbsymutl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcDbSymbolUtilities
  • Services
AcDbSymbolUtilities::Services Member List

This is the complete list of members for AcDbSymbolUtilities::Services, including all inherited members.

blockModelSpaceId(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
blockModelSpaceName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
blockPaperSpaceId(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
blockPaperSpaceName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
compareSymbolName(const ACHAR *thisName, const ACHAR *otherName) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
compatibilityMode(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
getBlockNameFromInsertPathName(ACHAR *&pBlockName, const ACHAR *pathName) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
getInsertPathNameFromBlockName(ACHAR *&pPathName, const ACHAR *blockName) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
getMaxSymbolNameLength(size_t &maxLength, size_t &maxSize, bool isNewName, bool compatibilityMode) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
getPathNameFromSymbolName(ACHAR *&pPathName, const ACHAR *symbolName, const ACHAR *extensions) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
getSymbolNameFromPathName(ACHAR *&pSymbolName, const ACHAR *pathName, const ACHAR *extensions) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
hasVerticalBar(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isBlockLayoutName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isBlockModelSpaceName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isBlockPaperSpaceName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isLayerDefpointsName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isLayerZeroName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isLinetypeByBlockName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isLinetypeByLayerName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isLinetypeContinuousName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isRegAppAcadName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isTextStyleStandardName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
isViewportActiveName(const ACHAR *name) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
kCurrentVersion enum value (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services |
layerDefpointsId(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
layerDefpointsName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
layerZeroId(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
layerZeroName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
linetypeByBlockId(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
linetypeByBlockName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
linetypeByLayerId(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
linetypeByLayerName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
linetypeContinuousId(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
linetypeContinuousName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
makeDependentName(ACHAR *&pNewName, const ACHAR *dwgName, const ACHAR *symbolName) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
preValidateSymbolName(ACHAR *&pSymbolName, bool preserveCase) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
regAppAcadId(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
regAppAcadName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
repairPreExtendedSymbolName(ACHAR *&pNewName, const ACHAR *oldName, bool allowVerticalBar) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
repairSymbolName(ACHAR *&pNewName, const ACHAR *oldName, bool allowVerticalBar) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
splitDependentName(size_t &numLeftBytes, const ACHAR *&pRight, const ACHAR *symbolName) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
textStyleStandardId(AcDbDatabase *pDb) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
textStyleStandardName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
validateCompatibleSymbolName(const ACHAR *name, bool isNewName, bool allowVerticalBar, bool compatibilityMode) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
validatePreExtendedSymbolName(const ACHAR *name, bool allowVerticalBar) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
validateSymbolName(const ACHAR *name, bool allowVerticalBar) const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
version() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual
viewportActiveName() const =0 (defined in AcDbSymbolUtilities::Services) | AcDbSymbolUtilities::Services | pure virtual


ZRX API Reference: AcEdSymbolUtilities::Services Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcEdSymbolUtilities
  • Services
Public Types | Public Member Functions | List of all members
AcEdSymbolUtilities::Services Class Reference

Public Types

enum { kCurrentVersion = ACEDSYMUTIL_SERVICES_CURRENT_VERSION }

Public Member Functions

virtual Acad::PromptStatus | getCompatibleSymbolString (ACHAR *&pResponse, const ACHAR *prompt, AcDbDatabase *pDb) const =0
virtual Acad::PromptStatus | getSymbolString (ACHAR *&pResponse, const ACHAR *prompt, bool onlyCrEndsInput, bool preserveCase) const =0
virtual unsigned | version () const =0
The documentation for this class was generated from the following file:
  • acsymutl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcEdSymbolUtilities
  • Services
AcEdSymbolUtilities::Services Member List

This is the complete list of members for AcEdSymbolUtilities::Services, including all inherited members.

getCompatibleSymbolString(ACHAR *&pResponse, const ACHAR *prompt, AcDbDatabase *pDb) const =0 (defined in AcEdSymbolUtilities::Services) | AcEdSymbolUtilities::Services | pure virtual
getSymbolString(ACHAR *&pResponse, const ACHAR *prompt, bool onlyCrEndsInput, bool preserveCase) const =0 (defined in AcEdSymbolUtilities::Services) | AcEdSymbolUtilities::Services | pure virtual
kCurrentVersion enum value (defined in AcEdSymbolUtilities::Services) | AcEdSymbolUtilities::Services |
version() const =0 (defined in AcEdSymbolUtilities::Services) | AcEdSymbolUtilities::Services | pure virtual


ZRX API Reference: _ADSSYMBOL_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
_ADSSYMBOL_ENTRY Struct Reference

Public Attributes

bool | bRegFunc
int(* | fptr )()
UINT | nameID
const ACHAR * | pszName
The documentation for this struct was generated from the following file:
  • arxEntryPoint.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
_ADSSYMBOL_ENTRY Member List

This is the complete list of members for _ADSSYMBOL_ENTRY, including all inherited members.

bRegFunc (defined in _ADSSYMBOL_ENTRY) | _ADSSYMBOL_ENTRY
fptr (defined in _ADSSYMBOL_ENTRY) | _ADSSYMBOL_ENTRY
nameID (defined in _ADSSYMBOL_ENTRY) | _ADSSYMBOL_ENTRY
pszName (defined in _ADSSYMBOL_ENTRY) | _ADSSYMBOL_ENTRY


ZRX API Reference: _ARXCOMMAND_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
_ARXCOMMAND_ENTRY Struct Reference

Public Attributes

Adesk::Int32 | commandFlags
UINT | localNameID
AcRxFunctionPtr | pCmdFct
const ACHAR * | pszCmdGlobalName
const ACHAR * | pszCmdGroupName
const ACHAR * | pszCmdLocalName
AcEdUIContext * | pUIContext
The documentation for this struct was generated from the following file:
  • arxEntryPoint.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
_ARXCOMMAND_ENTRY Member List

This is the complete list of members for _ARXCOMMAND_ENTRY, including all inherited members.

commandFlags (defined in _ARXCOMMAND_ENTRY) | _ARXCOMMAND_ENTRY
localNameID (defined in _ARXCOMMAND_ENTRY) | _ARXCOMMAND_ENTRY
pCmdFct (defined in _ARXCOMMAND_ENTRY) | _ARXCOMMAND_ENTRY
pszCmdGlobalName (defined in _ARXCOMMAND_ENTRY) | _ARXCOMMAND_ENTRY
pszCmdGroupName (defined in _ARXCOMMAND_ENTRY) | _ARXCOMMAND_ENTRY
pszCmdLocalName (defined in _ARXCOMMAND_ENTRY) | _ARXCOMMAND_ENTRY
pUIContext (defined in _ARXCOMMAND_ENTRY) | _ARXCOMMAND_ENTRY


ZRX API Reference: _DBX_REGISTER_OBJECT_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
_DBX_REGISTER_OBJECT_ENTRY Struct Reference

Public Attributes

bool | bRegistered
AcRxClass *(* | desc )()
void(* | rxInit )()
The documentation for this struct was generated from the following file:
  • dbxEntryPoint.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
_DBX_REGISTER_OBJECT_ENTRY Member List

This is the complete list of members for _DBX_REGISTER_OBJECT_ENTRY, including all inherited members.

bRegistered (defined in _DBX_REGISTER_OBJECT_ENTRY) | _DBX_REGISTER_OBJECT_ENTRY
desc (defined in _DBX_REGISTER_OBJECT_ENTRY) | _DBX_REGISTER_OBJECT_ENTRY
rxInit (defined in _DBX_REGISTER_OBJECT_ENTRY) | _DBX_REGISTER_OBJECT_ENTRY


ZRX API Reference: _dlgControlTag Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
_dlgControlTag Struct Reference

Public Attributes

DWORD | flags
DWORD | id
DWORD | pct
The documentation for this struct was generated from the following file:
  • adui.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
_dlgControlTag Member List

This is the complete list of members for _dlgControlTag, including all inherited members.

flags (defined in _dlgControlTag) | _dlgControlTag
id (defined in _dlgControlTag) | _dlgControlTag
pct (defined in _dlgControlTag) | _dlgControlTag


ZRX API Reference: _IID Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
_IID Struct Reference

Public Attributes

unsigned char | c [8]
unsigned short | s1
unsigned short | s2
unsigned long | x
The documentation for this struct was generated from the following files:
  • acadi_i.c
  • acpexctl_i.c
  • acpi_i.c
  • axdb_i.c


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
_IID Member List

This is the complete list of members for _IID, including all inherited members.

c (defined in _IID) | _IID
s1 (defined in _IID) | _IID
s2 (defined in _IID) | _IID
x (defined in _IID) | _IID


ZRX API Reference: Ac3dDwfNavTreeNode Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
Ac3dDwfNavTreeNode Class Reference
+ Inheritance diagram for Ac3dDwfNavTreeNode:

Public Member Functions

virtual bool | addChild (const Ac3dDwfNavTreeNode *node)=0
virtual const AcArray< const
Ac3dDwfNavTreeNode * > & 		children () const =0
virtual const AcString & | displayName () const =0
virtual bool | isBlock () const =0
virtual bool | isGroup () const =0
virtual const AcArray< long > & | keys () const =0
virtual int | nDescendants () const =0
virtual bool | removeChild (const Ac3dDwfNavTreeNode *node)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • Ac3dDwfNavTree.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Ac3dDwfNavTreeNode Member List

This is the complete list of members for Ac3dDwfNavTreeNode, including all inherited members.

AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addChild(const Ac3dDwfNavTreeNode *node)=0 (defined in Ac3dDwfNavTreeNode) | Ac3dDwfNavTreeNode | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
children() const =0 (defined in Ac3dDwfNavTreeNode) | Ac3dDwfNavTreeNode | pure virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
displayName() const =0 (defined in Ac3dDwfNavTreeNode) | Ac3dDwfNavTreeNode | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isBlock() const =0 (defined in Ac3dDwfNavTreeNode) | Ac3dDwfNavTreeNode | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isGroup() const =0 (defined in Ac3dDwfNavTreeNode) | Ac3dDwfNavTreeNode | pure virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
keys() const =0 (defined in Ac3dDwfNavTreeNode) | Ac3dDwfNavTreeNode | pure virtual
nDescendants() const =0 (defined in Ac3dDwfNavTreeNode) | Ac3dDwfNavTreeNode | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeChild(const Ac3dDwfNavTreeNode *node)=0 (defined in Ac3dDwfNavTreeNode) | Ac3dDwfNavTreeNode | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: ACAD_OPMPROPMAP_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
ACAD_OPMPROPMAP_ENTRY Struct Reference

Public Attributes

PROPCAT | catid
DISPID | dispid
bool | editable
unsigned short | grouping
UINT | nCatNameID
UINT | nDescID
UINT | nElementStrID
UINT | nPredefinedStrID
const CLSID * | pclsidOther
const CLSID * | pclsidPropPage
const IID * | piidDispatch
const ACHAR * | predefinedValues
LPCOLESTR | szEllipsesTxt
The documentation for this struct was generated from the following file:
  • opmimp.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
ACAD_OPMPROPMAP_ENTRY Member List

This is the complete list of members for ACAD_OPMPROPMAP_ENTRY, including all inherited members.

catid (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
dispid (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
editable (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
grouping (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
nCatNameID (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
nDescID (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
nElementStrID (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
nPredefinedStrID (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
pclsidOther (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
pclsidPropPage (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
piidDispatch (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
predefinedValues (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY
szEllipsesTxt (defined in ACAD_OPMPROPMAP_ENTRY) | ACAD_OPMPROPMAP_ENTRY


ZRX API Reference: AcadApp Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
AcadApp Struct Reference

Public Types

enum ErrorStatus {
eOk = 0, eInvalidKey = 1, eInvalidSubKey = 2, eKeyNotFound = 3,
eOutOfMemory = 4, eInvalidValue = 5, eValueNotFound = 6, eKeyExists = 7,
eRegAccessDenied = 8, eRejected = 9, eUnknownError = 10
}
enum LoadReasons {
kOnProxyDetection = 0x01, kOnAutoCADStartup = 0x02, kOnCommandInvocation = 0x04, kOnLoadRequest = 0x08,
kLoadDisabled = 0x10, kTransparentlyLoadable = 0x20, kOnIdleLoad = 0x40
}
The documentation for this struct was generated from the following file:
  • rxdlinkr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcadApp Member List

This is the complete list of members for AcadApp, including all inherited members.

eInvalidKey enum value (defined in AcadApp) | AcadApp
eInvalidSubKey enum value (defined in AcadApp) | AcadApp
eInvalidValue enum value (defined in AcadApp) | AcadApp
eKeyExists enum value (defined in AcadApp) | AcadApp
eKeyNotFound enum value (defined in AcadApp) | AcadApp
eOk enum value (defined in AcadApp) | AcadApp
eOutOfMemory enum value (defined in AcadApp) | AcadApp
eRegAccessDenied enum value (defined in AcadApp) | AcadApp
eRejected enum value (defined in AcadApp) | AcadApp
ErrorStatus enum name (defined in AcadApp) | AcadApp
eUnknownError enum value (defined in AcadApp) | AcadApp
eValueNotFound enum value (defined in AcadApp) | AcadApp
kLoadDisabled enum value (defined in AcadApp) | AcadApp
kOnAutoCADStartup enum value (defined in AcadApp) | AcadApp
kOnCommandInvocation enum value (defined in AcadApp) | AcadApp
kOnIdleLoad enum value (defined in AcadApp) | AcadApp
kOnLoadRequest enum value (defined in AcadApp) | AcadApp
kOnProxyDetection enum value (defined in AcadApp) | AcadApp
kTransparentlyLoadable enum value (defined in AcadApp) | AcadApp
LoadReasons enum name (defined in AcadApp) | AcadApp


ZRX API Reference: AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >::TOOL_MAP_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcadToolImpl
  • TOOL_MAP_ENTRY
Public Attributes | List of all members
AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >::TOOL_MAP_ENTRY Struct Reference

Public Attributes

DISPID | dispId
WCHAR | szDesc [512]
The documentation for this struct was generated from the following file:
  • AcadToolImpl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcadToolImpl
  • TOOL_MAP_ENTRY
AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >::TOOL_MAP_ENTRY Member List

This is the complete list of members for AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >::TOOL_MAP_ENTRY, including all inherited members.

dispId (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >::TOOL_MAP_ENTRY) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >::TOOL_MAP_ENTRY
szDesc (defined in AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >::TOOL_MAP_ENTRY) | AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >::TOOL_MAP_ENTRY


ZRX API Reference: AcApDocManager::DocOpenParams Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcApDocManager
  • DocOpenParams
Public Types | Public Attributes | List of all members
AcApDocManager::DocOpenParams Struct Reference

Public Types

enum {
kDisallowReadOnly = 0x01, kRequireReadOnly = 0x02, kFileNameArgIsUnicode = 0x04, kViewNameArgIsUnicode = 0x08,
kUseUIOnErrors = 0x10
}
enum {
kUnknown = 0, kDefaultView = 1, kLayoutName = 2, kViewName = 3,
kLayoutHandle = 4, kViewHandle = 5, kViewWorldCoords = 6
}

Public Attributes

union {
const ACHAR * mpszFileName
const wchar_t * mpwszFileName
};
union {
const double * mpCoords
const ACHAR * mpszViewName
const wchar_t * mpwszViewName
};
int | mnFlags
BYTE | mnInitialViewType
int | mnUnused
void * | mpUnused
const wchar_t * | mpwszPassword
The documentation for this struct was generated from the following file:
  • acdocman.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcApDocManager
  • DocOpenParams
AcApDocManager::DocOpenParams Member List

This is the complete list of members for AcApDocManager::DocOpenParams, including all inherited members.

kDefaultView enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kDisallowReadOnly enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kFileNameArgIsUnicode enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kLayoutHandle enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kLayoutName enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kRequireReadOnly enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kUnknown enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kUseUIOnErrors enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kViewHandle enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kViewName enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kViewNameArgIsUnicode enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
kViewWorldCoords enum value (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mnFlags (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mnInitialViewType (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mnUnused (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mpCoords (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mpszFileName (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mpszViewName (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mpUnused (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mpwszFileName (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mpwszPassword (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams
mpwszViewName (defined in AcApDocManager::DocOpenParams) | AcApDocManager::DocOpenParams


ZRX API Reference: AcApLongTransactionManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcApLongTransactionManager Class Reference
+ Inheritance diagram for AcApLongTransactionManager:

Public Member Functions

virtual Acad::ErrorStatus | abortLongTransaction (AcDbObjectId transId, bool keepObjs=false)=0
ACRX_DECLARE_MEMBERS (AcApLongTransactionManager)
virtual Acad::ErrorStatus | addClassFilter (AcRxClass *)=0
virtual void | addReactor (AcApLongTransactionReactor *)=0
virtual Acad::ErrorStatus | checkIn (AcDbObjectId transId, AcDbIdMapping &errorMap, bool keepObjs=false)=0
virtual Acad::ErrorStatus | checkOut (AcDbObjectId &transId, AcDbObjectIdArray &objList, AcDbObjectId toBlock, AcDbIdMapping &errorMap, AcDbObjectId lockBlkRef=AcDbObjectId::kNull)=0
virtual AcDbObjectId | currentLongTransactionFor (const AcApDocument *pDoc) const =0
virtual bool | isFiltered (AcRxClass *) const =0
virtual void | removeReactor (AcApLongTransactionReactor *)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • lngtrans.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApLongTransactionManager Member List

This is the complete list of members for AcApLongTransactionManager, including all inherited members.

abortLongTransaction(AcDbObjectId transId, bool keepObjs=false)=0 (defined in AcApLongTransactionManager) | AcApLongTransactionManager | pure virtual
ACRX_DECLARE_MEMBERS(AcApLongTransactionManager) (defined in AcApLongTransactionManager) | AcApLongTransactionManager |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addClassFilter(AcRxClass *)=0 (defined in AcApLongTransactionManager) | AcApLongTransactionManager | pure virtual
addReactor(AcApLongTransactionReactor *)=0 (defined in AcApLongTransactionManager) | AcApLongTransactionManager | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
checkIn(AcDbObjectId transId, AcDbIdMapping &errorMap, bool keepObjs=false)=0 (defined in AcApLongTransactionManager) | AcApLongTransactionManager | pure virtual
checkOut(AcDbObjectId &transId, AcDbObjectIdArray &objList, AcDbObjectId toBlock, AcDbIdMapping &errorMap, AcDbObjectId lockBlkRef=AcDbObjectId::kNull)=0 (defined in AcApLongTransactionManager) | AcApLongTransactionManager | pure virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
currentLongTransactionFor(const AcApDocument *pDoc) const =0 (defined in AcApLongTransactionManager) | AcApLongTransactionManager | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isFiltered(AcRxClass *) const =0 (defined in AcApLongTransactionManager) | AcApLongTransactionManager | pure virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeReactor(AcApLongTransactionReactor *)=0 (defined in AcApLongTransactionManager) | AcApLongTransactionManager | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcApLongTransactionReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcApLongTransactionReactor Class Reference
+ Inheritance diagram for AcApLongTransactionReactor:

Public Member Functions

virtual void | abortLongTransaction (AcDbLongTransaction &)
ACRX_DECLARE_MEMBERS (AcApLongTransactionReactor)
virtual void | beginCheckIn (AcDbLongTransaction &)
virtual void | beginCheckOut (AcDbLongTransaction &, AcDbObjectIdArray &originList)
virtual void | endCheckIn (AcDbLongTransaction &)
virtual void | endCheckOut (AcDbLongTransaction &)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Protected Member Functions

Acad::ErrorStatus veto ()

Friends

class AcApImpLongTransactionManager

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • lngtrans.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcApLongTransactionReactor Member List

This is the complete list of members for AcApLongTransactionReactor, including all inherited members.

abortLongTransaction(AcDbLongTransaction &) (defined in AcApLongTransactionReactor) | AcApLongTransactionReactor | virtual
AcApImpLongTransactionManager (defined in AcApLongTransactionReactor) | AcApLongTransactionReactor | friend
ACRX_DECLARE_MEMBERS(AcApLongTransactionReactor) (defined in AcApLongTransactionReactor) | AcApLongTransactionReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
beginCheckIn(AcDbLongTransaction &) (defined in AcApLongTransactionReactor) | AcApLongTransactionReactor | virtual
beginCheckOut(AcDbLongTransaction &, AcDbObjectIdArray &originList) (defined in AcApLongTransactionReactor) | AcApLongTransactionReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
endCheckIn(AcDbLongTransaction &) (defined in AcApLongTransactionReactor) | AcApLongTransactionReactor | virtual
endCheckOut(AcDbLongTransaction &) (defined in AcApLongTransactionReactor) | AcApLongTransactionReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
veto() (defined in AcApLongTransactionReactor) | AcApLongTransactionReactor | protected
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcCell Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcCell Struct Reference

Public Attributes

int | mnColumn
int | mnRow
The documentation for this struct was generated from the following file:
  • AcCell.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCell Member List

This is the complete list of members for AcCell, including all inherited members.

mnColumn (defined in AcCell) | AcCell
mnRow (defined in AcCell) | AcCell


ZRX API Reference: AcCellRange Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
AcCellRange Struct Reference

Public Member Functions

bool | operator!= (const AcCellRange &range) const
bool | operator== (const AcCellRange &range) const

Public Attributes

int | mnBottomRow
int | mnLeftColumn
int | mnRightColumn
int | mnTopRow
The documentation for this struct was generated from the following file:
  • AcCell.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcCellRange Member List

This is the complete list of members for AcCellRange, including all inherited members.

AcCellRange() (defined in AcCellRange) | AcCellRange | inline
mnBottomRow (defined in AcCellRange) | AcCellRange |
mnLeftColumn (defined in AcCellRange) | AcCellRange |
mnRightColumn (defined in AcCellRange) | AcCellRange |
mnTopRow (defined in AcCellRange) | AcCellRange |
operator!=(const AcCellRange &range) const (defined in AcCellRange) | AcCellRange | inline
operator==(const AcCellRange &range) const (defined in AcCellRange) | AcCellRange | inline


ZRX API Reference: AcCmEntityColor::RGBM Union Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcCmEntityColor
  • RGBM
Public Attributes | List of all members
AcCmEntityColor::RGBM Union Reference

Public Attributes

struct {
Adesk::UInt8 blue
Adesk::UInt8 colorMethod
Adesk::UInt8 green
Adesk::UInt8 red
};
Adesk::Int16 | indirect
Adesk::UInt32 | whole
The documentation for this union was generated from the following file:
  • dbcolor.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcCmEntityColor
  • RGBM
AcCmEntityColor::RGBM Member List

This is the complete list of members for AcCmEntityColor::RGBM, including all inherited members.

blue (defined in AcCmEntityColor::RGBM) | AcCmEntityColor::RGBM
colorMethod (defined in AcCmEntityColor::RGBM) | AcCmEntityColor::RGBM
green (defined in AcCmEntityColor::RGBM) | AcCmEntityColor::RGBM
indirect (defined in AcCmEntityColor::RGBM) | AcCmEntityColor::RGBM
red (defined in AcCmEntityColor::RGBM) | AcCmEntityColor::RGBM
whole (defined in AcCmEntityColor::RGBM) | AcCmEntityColor::RGBM


ZRX API Reference: AcDbClassIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | List of all members
AcDbClassIterator Class Reference

Public Types

enum { kAllClasses = 0x01, kCustomClasses = 0x02, kProxyClasses = 0x04 }

Public Member Functions

virtual const ACHAR * | appName () const =0
virtual void | detach ()=0
virtual bool | done () const =0
virtual const ACHAR * | dxfName () const =0
virtual bool | isEntity () const =0
virtual bool | isProxy () const =0
virtual const ACHAR * | name () const =0
virtual bool | next ()=0
virtual Adesk::UInt32 | numInstances () const =0
virtual Acad::ErrorStatus | start (AcDbDatabase *pDb, int nFlags)=0

Static Public Member Functions

static void ADESK_STDCALL deleteIterator (AcDbClassIterator *pIter)
static AcDbClassIterator
*ADESK_STDCALL 		newIterator ()
The documentation for this class was generated from the following file:
  • AcDbClassIter.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbClassIterator Member List

This is the complete list of members for AcDbClassIterator, including all inherited members.

AcDbClassIterator() (defined in AcDbClassIterator) | AcDbClassIterator | protected
appName() const =0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
deleteIterator(AcDbClassIterator *pIter) (defined in AcDbClassIterator) | AcDbClassIterator | static
detach()=0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
done() const =0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
dxfName() const =0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
isEntity() const =0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
isProxy() const =0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
kAllClasses enum value (defined in AcDbClassIterator) | AcDbClassIterator |
kCustomClasses enum value (defined in AcDbClassIterator) | AcDbClassIterator |
kProxyClasses enum value (defined in AcDbClassIterator) | AcDbClassIterator |
name() const =0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
newIterator() (defined in AcDbClassIterator) | AcDbClassIterator | static
next()=0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
numInstances() const =0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
start(AcDbDatabase *pDb, int nFlags)=0 (defined in AcDbClassIterator) | AcDbClassIterator | pure virtual
~AcDbClassIterator() (defined in AcDbClassIterator) | AcDbClassIterator | protected


ZRX API Reference: AcDbDoubleClickEdit Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbDoubleClickEdit Class Reference
+ Inheritance diagram for AcDbDoubleClickEdit:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbDoubleClickEdit)
virtual void | finishEdit (void)=0
virtual void | startEdit (AcDbEntity *pEnt, AcGePoint3d pt)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • AcDblClkEdit.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbDoubleClickEdit Member List

This is the complete list of members for AcDbDoubleClickEdit, including all inherited members.

ACRX_DECLARE_MEMBERS(AcDbDoubleClickEdit) (defined in AcDbDoubleClickEdit) | AcDbDoubleClickEdit |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
finishEdit(void)=0 (defined in AcDbDoubleClickEdit) | AcDbDoubleClickEdit | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
startEdit(AcDbEntity *pEnt, AcGePoint3d pt)=0 (defined in AcDbDoubleClickEdit) | AcDbDoubleClickEdit | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcDbObjectIdGraph Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbObjectIdGraph Class Reference
+ Inheritance diagram for AcDbObjectIdGraph:

Public Member Functions

Acad::ErrorStatus | addNode (AcDbObjectIdGraphNode *)
Acad::ErrorStatus | delNode (AcDbObjectIdGraphNode *)
AcDbObjectIdGraphNode * | findNode (const AcDbObjectId) const
AcDbObjectIdGraphNode * | idNode (int idx) const
- Public Member Functions inherited from AcDbGraph
AcDbGraph (AcDbGraphNode *pRoot=NULL)
Acad::ErrorStatus | addEdge (AcDbGraphNode *pFrom, AcDbGraphNode *pTo)
Acad::ErrorStatus | addNode (AcDbGraphNode *)
Acad::ErrorStatus | breakCycleEdge (AcDbGraphNode *pFrom, AcDbGraphNode *pTo)
void | clearAll (Adesk::UInt8 flags)
Acad::ErrorStatus | delNode (AcDbGraphNode *)
virtual Adesk::Boolean | findCycles (AcDbGraphNode *pStart=NULL)
void | getOutgoing (AcDbVoidPtrArray &)
bool | isEmpty () const
AcDbGraphNode * | node (int index) const
int | numNodes () const
void | reset ()
AcDbGraphNode * | rootNode () const
void | setNodeGrowthRate (int rate)

Additional Inherited Members

- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
- Protected Member Functions inherited from AcDbGraph
Acad::ErrorStatus | clearAllCycles ()
The documentation for this class was generated from the following file:
  • idgraph.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectIdGraph Member List

This is the complete list of members for AcDbObjectIdGraph, including all inherited members.

AcDbGraph(AcDbGraphNode *pRoot=NULL) (defined in AcDbGraph) | AcDbGraph |
AcDbObjectIdGraph() (defined in AcDbObjectIdGraph) | AcDbObjectIdGraph |
addEdge(AcDbGraphNode *pFrom, AcDbGraphNode *pTo) (defined in AcDbGraph) | AcDbGraph |
addNode(AcDbObjectIdGraphNode *) (defined in AcDbObjectIdGraph) | AcDbObjectIdGraph |
addNode(AcDbGraphNode *) (defined in AcDbGraph) | AcDbGraph |
breakCycleEdge(AcDbGraphNode *pFrom, AcDbGraphNode *pTo) (defined in AcDbGraph) | AcDbGraph |
clearAll(Adesk::UInt8 flags) (defined in AcDbGraph) | AcDbGraph |
clearAllCycles() (defined in AcDbGraph) | AcDbGraph | protected
delNode(AcDbObjectIdGraphNode *) (defined in AcDbObjectIdGraph) | AcDbObjectIdGraph |
delNode(AcDbGraphNode *) (defined in AcDbGraph) | AcDbGraph |
findCycles(AcDbGraphNode *pStart=NULL) (defined in AcDbGraph) | AcDbGraph | virtual
findNode(const AcDbObjectId) const (defined in AcDbObjectIdGraph) | AcDbObjectIdGraph |
getOutgoing(AcDbVoidPtrArray &) (defined in AcDbGraph) | AcDbGraph |
idNode(int idx) const (defined in AcDbObjectIdGraph) | AcDbObjectIdGraph | inline
isEmpty() const (defined in AcDbGraph) | AcDbGraph | inline
node(int index) const (defined in AcDbGraph) | AcDbGraph | inline
numNodes() const (defined in AcDbGraph) | AcDbGraph | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
reset() (defined in AcDbGraph) | AcDbGraph |
rootNode() const (defined in AcDbGraph) | AcDbGraph | inline
setNodeGrowthRate(int rate) (defined in AcDbGraph) | AcDbGraph |
~AcDbGraph() (defined in AcDbGraph) | AcDbGraph | virtual
~AcDbObjectIdGraph() (defined in AcDbObjectIdGraph) | AcDbObjectIdGraph | virtual


ZRX API Reference: AcDbObjectIdGraphNode Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcDbObjectIdGraphNode Class Reference
+ Inheritance diagram for AcDbObjectIdGraphNode:

Public Member Functions

AcDbObjectIdGraphNode (const AcDbObjectId id)
AcDbObjectId | id () const
- Public Member Functions inherited from AcDbGraphNode
AcDbGraphNode (void *pData=NULL)
Acad::ErrorStatus | addRefTo (AcDbGraphNode *)
Acad::ErrorStatus | clear (Adesk::UInt8 flags)
AcDbGraphNode * | cycleIn (int) const
AcDbGraphNode * | cycleOut (int) const
void * | data () const
Acad::ErrorStatus | disconnectAll ()
AcDbGraphNode * | in (int) const
bool | isCycleNode () const
bool | isMarkedAs (Adesk::UInt8 flags) const
Acad::ErrorStatus | markAs (Adesk::UInt8 flags)
Acad::ErrorStatus | markTree (Adesk::UInt8 flags, AcDbVoidPtrArray *=NULL)
AcDbGraphNode * | nextCycleNode () const
int | numCycleIn () const
int | numCycleOut () const
int | numIn () const
int | numOut () const
AcDbGraphNode * | out (int) const
AcDbGraph * | owner () const
Acad::ErrorStatus | removeRefTo (AcDbGraphNode *)
void | setData (void *)
void | setEdgeGrowthRate (int outEdgeRate, int inEdgeRate)

Additional Inherited Members

- Public Types inherited from AcDbGraphNode
enum Flags {
kNone = 0x00, kVisited = 0x01, kOutsideRefed = 0x02, kSelected = 0x04,
kInList = 0x08, kListAll = 0x0E, kFirstLevel = 0x10, kUnresTree = 0x20,
kAll = 0x2F
}
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • idgraph.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbObjectIdGraphNode Member List

This is the complete list of members for AcDbObjectIdGraphNode, including all inherited members.

AcDbGraphNode(void *pData=NULL) (defined in AcDbGraphNode) | AcDbGraphNode |
AcDbObjectIdGraphNode(const AcDbObjectId id) (defined in AcDbObjectIdGraphNode) | AcDbObjectIdGraphNode |
addRefTo(AcDbGraphNode *) (defined in AcDbGraphNode) | AcDbGraphNode |
clear(Adesk::UInt8 flags) (defined in AcDbGraphNode) | AcDbGraphNode |
cycleIn(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
cycleOut(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
data() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
disconnectAll() (defined in AcDbGraphNode) | AcDbGraphNode |
Flags enum name (defined in AcDbGraphNode) | AcDbGraphNode |
id() const (defined in AcDbObjectIdGraphNode) | AcDbObjectIdGraphNode | inline
in(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
isCycleNode() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
isMarkedAs(Adesk::UInt8 flags) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
kAll enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kFirstLevel enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kInList enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kListAll enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kNone enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kOutsideRefed enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kSelected enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kUnresTree enum value (defined in AcDbGraphNode) | AcDbGraphNode |
kVisited enum value (defined in AcDbGraphNode) | AcDbGraphNode |
markAs(Adesk::UInt8 flags) (defined in AcDbGraphNode) | AcDbGraphNode |
markTree(Adesk::UInt8 flags, AcDbVoidPtrArray *=NULL) (defined in AcDbGraphNode) | AcDbGraphNode |
nextCycleNode() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numCycleIn() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numCycleOut() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numIn() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
numOut() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
out(int) const (defined in AcDbGraphNode) | AcDbGraphNode | inline
owner() const (defined in AcDbGraphNode) | AcDbGraphNode | inline
removeRefTo(AcDbGraphNode *) (defined in AcDbGraphNode) | AcDbGraphNode |
setData(void *) (defined in AcDbGraphNode) | AcDbGraphNode | inline
setEdgeGrowthRate(int outEdgeRate, int inEdgeRate) (defined in AcDbGraphNode) | AcDbGraphNode |
~AcDbGraphNode() (defined in AcDbGraphNode) | AcDbGraphNode | virtual
~AcDbObjectIdGraphNode() (defined in AcDbObjectIdGraphNode) | AcDbObjectIdGraphNode | virtual


ZRX API Reference: AcDbSortentsTable Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
AcDbSortentsTable Class Reference
+ Inheritance diagram for AcDbSortentsTable:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcDbSortentsTable)
virtual Acad::ErrorStatus | applyPartialUndo (AcDbDwgFiler *, AcRxClass *)
virtual Acad::ErrorStatus | audit (AcDbAuditInfo *pAuditInfo)
AcDbObjectId | blockId () const
virtual Acad::ErrorStatus | dwgInFields (AcDbDwgFiler *)
virtual Acad::ErrorStatus | dwgOutFields (AcDbDwgFiler *) const
virtual Acad::ErrorStatus | dxfInFields (AcDbDxfFiler *)
virtual Acad::ErrorStatus | dxfOutFields (AcDbDxfFiler *) const
Acad::ErrorStatus | firstEntityIsDrawnBeforeSecond (AcDbObjectId first, AcDbObjectId second, bool &result) const
virtual Acad::ErrorStatus | getClassID (CLSID *pClsid) const
Acad::ErrorStatus | getFullDrawOrder (AcDbObjectIdArray &ents, Adesk::UInt8 honorSortentsMask=0) const
Acad::ErrorStatus | getRelativeDrawOrder (AcDbObjectIdArray &ar, Adesk::UInt8 honorSortentsMask=0) const
void | getSortHandle (AcDbObjectId id, AcDbHandle &h) const
Acad::ErrorStatus | moveAbove (const AcDbObjectIdArray &ar, AcDbObjectId target)
Acad::ErrorStatus | moveBelow (const AcDbObjectIdArray &ar, AcDbObjectId target)
Acad::ErrorStatus | moveToBottom (const AcDbObjectIdArray &ar)
Acad::ErrorStatus | moveToTop (const AcDbObjectIdArray &ar)
Acad::ErrorStatus | remove (AcDbObjectId)
Acad::ErrorStatus | setBlockId (AcDbObjectId)
Acad::ErrorStatus | setRelativeDrawOrder (const AcDbObjectIdArray &ar)
Adesk::Boolean | sortAs (AcDbObjectId, AcDbHandle &) const
Acad::ErrorStatus | swapOrder (AcDbObjectId, AcDbObjectId)
- Public Member Functions inherited from AcDbObject
ACDB_DECLARE_MEMBERS (AcDbObject)
virtual void | addPersistentReactor (AcDbObjectId objId)
void | addReactor (AcDbObjectReactor *newObj) const
void | assertNotifyEnabled () const
void | assertReadEnabled () const
void | assertWriteEnabled (Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true)
Acad::ErrorStatus | cancel ()
virtual void | cancelled (const AcDbObject *dbObj)
virtual AcRxObject * | clone () const
Acad::ErrorStatus | close ()
Acad::ErrorStatus | closeAndPage (Adesk::Boolean onlyWhenClean=true)
virtual void | copied (const AcDbObject *dbObj, const AcDbObject *newObj)
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *pSrc)
Acad::ErrorStatus | createExtensionDictionary ()
AcDbDatabase * | database () const
virtual Acad::ErrorStatus | decomposeForSave (AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData)
virtual Acad::ErrorStatus | deepClone (AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
void | disableUndoRecording (Adesk::Boolean disable)
Acad::ErrorStatus | downgradeOpen ()
Acad::ErrorStatus | downgradeToNotify (Adesk::Boolean wasWritable)
virtual AcGiDrawable * | drawable ()
Acad::ErrorStatus | dwgIn (AcDbDwgFiler *pFiler)
Acad::ErrorStatus | dwgOut (AcDbDwgFiler *pFiler) const
Acad::ErrorStatus | dxfIn (AcDbDxfFiler *pFiler)
Acad::ErrorStatus | dxfOut (AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const
Acad::ErrorStatus | erase (Adesk::Boolean erasing=true)
virtual void | erased (const AcDbObject *dbObj, Adesk::Boolean pErasing=true)
AcDbObjectId | extensionDictionary () const
void | getAcDbHandle (AcDbHandle &handle) const
Acad::ErrorStatus | getBinaryData (const ACHAR *key, long &size, char *&data) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbObjectId &fieldId) const
Acad::ErrorStatus | getField (const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const
AcDbObjectId | getFieldDictionary (void) const
Acad::ErrorStatus | getFieldDictionary (AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const
Acad::ErrorStatus | getObjectBirthVersion (AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual Acad::ErrorStatus | getObjectSaveVersion (const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer)
virtual void | goodbye (const AcDbObject *dbObj)
virtual AcGsNode * | gsNode () const
Acad::ErrorStatus | handOverTo (AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true)
bool | hasFields (void) const
bool | hasPersistentReactor (AcDbObjectId objId) const
bool | hasSaveVersionOverride ()
virtual AcDbObjectId | id () const
Adesk::Boolean | isAcDbObjectIdsInFlux () const
Adesk::Boolean | isAProxy () const
Adesk::Boolean | isCancelling () const
Adesk::Boolean | isErased () const
Adesk::Boolean | isEraseStatusToggled () const
Adesk::Boolean | isModified () const
Adesk::Boolean | isModifiedGraphics () const
Adesk::Boolean | isModifiedXData () const
Adesk::Boolean | isNewObject () const
Adesk::Boolean | isNotifyEnabled () const
Adesk::Boolean | isNotifying () const
virtual Adesk::Boolean | isPersistent () const
Adesk::Boolean | isReadEnabled () const
Adesk::Boolean | isReallyClosing () const
Adesk::Boolean | isTransactionResident () const
Adesk::Boolean | isUndoing () const
Adesk::Boolean | isWriteEnabled () const
virtual
AcDb::DuplicateRecordCloning 		mergeStyle () const
virtual void | modified (const AcDbObject *dbObj)
virtual void | modifiedGraphics (const AcDbEntity *dbEnt)
virtual void | modifiedXData (const AcDbObject *dbObj)
virtual void | modifyUndone (const AcDbObject *dbObj)
virtual void | objectClosed (const AcDbObjectId objId)
AcDbObjectId | objectId () const
virtual void | openedForModify (const AcDbObject *dbObj)
AcDbObjectId | ownerId () const
AcDbVoidPtrArray * | reactors ()
const AcDbVoidPtrArray * | reactors () const
virtual void | reappended (const AcDbObject *dbObj)
virtual void | recvPropagateModify (const AcDbObject *subObj)
Acad::ErrorStatus | releaseExtensionDictionary ()
virtual Acad::ErrorStatus | removeField (AcDbObjectId fieldId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName, AcDbObjectId &returnId)
virtual Acad::ErrorStatus | removeField (const ACHAR *pszPropName)
virtual Acad::ErrorStatus | removePersistentReactor (AcDbObjectId objId)
void | removeReactor (AcDbObjectReactor *newObj) const
void | setAcDbObjectIdsInFlux ()
virtual Adesk::UInt32 | setAttributes (AcGiDrawableTraits *pTraits)
Acad::ErrorStatus | setBinaryData (const ACHAR *key, long size, const char *data)
virtual Acad::ErrorStatus | setField (const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId)
virtual void | setGsNode (AcGsNode *pNode)
void | setHasSaveVersionOverride (bool bSetIt)
virtual Acad::ErrorStatus | setOwnerId (AcDbObjectId objId)
virtual Acad::ErrorStatus | setXData (const resbuf *xdata)
virtual Acad::ErrorStatus | subCancel ()
virtual Acad::ErrorStatus | subClose ()
virtual Acad::ErrorStatus | subErase (Adesk::Boolean erasing)
virtual Acad::ErrorStatus | subHandOverTo (AcDbObject *newObject)
virtual void | subObjModified (const AcDbObject *dbObj, const AcDbObject *subObj)
virtual Acad::ErrorStatus | subOpen (AcDb::OpenMode mode)
virtual Acad::ErrorStatus | subSwapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
Acad::ErrorStatus | swapIdWith (AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false)
virtual Acad::ErrorStatus | swapReferences (const AcDbIdMapping &idMap)
virtual void | unappended (const AcDbObject *dbObj)
AcDbDwgFiler * | undoFiler ()
Acad::ErrorStatus | upgradeFromNotify (Adesk::Boolean &wasWritable)
Acad::ErrorStatus | upgradeOpen ()
virtual void | viewportDraw (AcGiViewportDraw *pVd)
virtual Acad::ErrorStatus | wblockClone (AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const
virtual Adesk::Boolean | worldDraw (AcGiWorldDraw *pWd)
virtual resbuf * | xData (const ACHAR *regappName=NULL) const
Acad::ErrorStatus | xDataTransformBy (const AcGeMatrix3d &xform)
virtual void | xmitPropagateModify () const
- Public Member Functions inherited from AcGiDrawable
ACRX_DECLARE_MEMBERS (AcGiDrawable)
virtual DrawableType | drawableType () const
virtual Adesk::Boolean | RolloverHit (Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset)
virtual Adesk::UInt32 | viewportDrawLogicalFlags (AcGiViewportDraw *vd)
- Public Member Functions inherited from AcRxObject
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Friends

class AcDbSystemInternals

Additional Inherited Members

- Public Types inherited from AcGiDrawable
enum DrawableType {
kGeometry = 0, kDistantLight, kPointLight, kSpotLight,
kAmbientLight, kSolidBackground, kGradientBackground, kImageBackground,
kGroundPlaneBackground, kViewport, kWebLight, kSkyBackground
}
enum SetAttributesFlags {
kDrawableNone = 0, kDrawableIsAnEntity = 1, kDrawableUsesNesting = 2, kDrawableIsCompoundObject = 4,
kDrawableViewIndependentViewportDraw = 8, kDrawableIsInvisible = 16, kDrawableHasAttributes = 32, kDrawableRegenTypeDependantGeometry = 64,
kDrawableIsDimension = (kDrawableIsAnEntity + kDrawableIsCompoundObject + 128), kDrawableRegenDraw = 256, kDrawableStandardDisplaySingleLOD = 512, kDrawableShadedDisplaySingleLOD = 1024,
kDrawableViewDependentViewportDraw = 2048, kDrawableBlockDependentViewportDraw = 4096
}
- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
- Static Public Member Functions inherited from AcHeapOperators
static void | operator delete (void *p)
static void | operator delete (void *p, const char *pFName, int nLine)
static void | operator delete[] (void *p)
static void | operator delete[] (void *p, const char *pFName, int nLine)
static void * | operator new (size_t size)
static void * | operator new (size_t size, const char *pFName, int nLine)
static void * | operator new[] (size_t size)
static void * | operator new[] (size_t size, const char *pFName, int nLine)
The documentation for this class was generated from the following file:
  • sorttab.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcDbSortentsTable Member List

This is the complete list of members for AcDbSortentsTable, including all inherited members.

ACDB_DECLARE_MEMBERS(AcDbObject) (defined in AcDbObject) | AcDbObject |
AcDbObject() (defined in AcDbObject) | AcDbObject | protected
AcDbSortentsTable() (defined in AcDbSortentsTable) | AcDbSortentsTable |
AcDbSystemInternals (defined in AcDbSortentsTable) | AcDbSortentsTable | friend
ACRX_DECLARE_MEMBERS(AcDbSortentsTable) (defined in AcDbSortentsTable) | AcDbSortentsTable |
ACRX_DECLARE_MEMBERS(AcGiDrawable) (defined in AcGiDrawable) | AcGiDrawable |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addPersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
addReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
applyPartialUndo(AcDbDwgFiler *, AcRxClass *) (defined in AcDbSortentsTable) | AcDbSortentsTable | virtual
assertNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
assertReadEnabled() const (defined in AcDbObject) | AcDbObject |
assertWriteEnabled(Adesk::Boolean autoUndo=true, Adesk::Boolean recordModified=true) (defined in AcDbObject) | AcDbObject |
audit(AcDbAuditInfo *pAuditInfo) (defined in AcDbSortentsTable) | AcDbSortentsTable | virtual
blockId() const (defined in AcDbSortentsTable) | AcDbSortentsTable |
cancel() (defined in AcDbObject) | AcDbObject |
cancelled(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcDbObject) | AcDbObject | virtual
close() (defined in AcDbObject) | AcDbObject |
closeAndPage(Adesk::Boolean onlyWhenClean=true) (defined in AcDbObject) | AcDbObject |
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copied(const AcDbObject *dbObj, const AcDbObject *newObj) (defined in AcDbObject) | AcDbObject | virtual
copyFrom(const AcRxObject *pSrc) (defined in AcDbObject) | AcDbObject | virtual
createExtensionDictionary() (defined in AcDbObject) | AcDbObject |
database() const (defined in AcDbObject) | AcDbObject |
decomposeForSave(AcDb::AcDbDwgVersion ver, AcDbObject *&replaceObj, AcDbObjectId &replaceId, Adesk::Boolean &exchangeXData) (defined in AcDbObject) | AcDbObject | virtual
deepClone(AcDbObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
disableUndoRecording(Adesk::Boolean disable) (defined in AcDbObject) | AcDbObject |
downgradeOpen() (defined in AcDbObject) | AcDbObject |
downgradeToNotify(Adesk::Boolean wasWritable) (defined in AcDbObject) | AcDbObject |
drawable() (defined in AcDbObject) | AcDbObject | virtual
DrawableType enum name (defined in AcGiDrawable) | AcGiDrawable |
drawableType() const (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
dwgIn(AcDbDwgFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dwgInFields(AcDbDwgFiler *) (defined in AcDbSortentsTable) | AcDbSortentsTable | virtual
dwgOut(AcDbDwgFiler *pFiler) const (defined in AcDbObject) | AcDbObject |
dwgOutFields(AcDbDwgFiler *) const (defined in AcDbSortentsTable) | AcDbSortentsTable | virtual
dxfIn(AcDbDxfFiler *pFiler) (defined in AcDbObject) | AcDbObject |
dxfInFields(AcDbDxfFiler *) (defined in AcDbSortentsTable) | AcDbSortentsTable | virtual
dxfOut(AcDbDxfFiler *pFiler, Adesk::Boolean allXdFlag, Adesk::uchar *regAppTable) const (defined in AcDbObject) | AcDbObject |
dxfOutFields(AcDbDxfFiler *) const (defined in AcDbSortentsTable) | AcDbSortentsTable | virtual
erase(Adesk::Boolean erasing=true) (defined in AcDbObject) | AcDbObject |
erased(const AcDbObject *dbObj, Adesk::Boolean pErasing=true) (defined in AcDbObject) | AcDbObject | virtual
extensionDictionary() const (defined in AcDbObject) | AcDbObject |
firstEntityIsDrawnBeforeSecond(AcDbObjectId first, AcDbObjectId second, bool &result) const (defined in AcDbSortentsTable) | AcDbSortentsTable |
getAcDbHandle(AcDbHandle &handle) const (defined in AcDbObject) | AcDbObject |
getBinaryData(const ACHAR *key, long &size, char *&data) const (defined in AcDbObject) | AcDbObject |
getClassID(CLSID *pClsid) const (defined in AcDbSortentsTable) | AcDbSortentsTable | virtual
getField(const ACHAR *pszPropName, AcDbObjectId &fieldId) const (defined in AcDbObject) | AcDbObject |
getField(const ACHAR *pszPropName, AcDbField *&pField, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(void) const (defined in AcDbObject) | AcDbObject |
getFieldDictionary(AcDbDictionary *&pFieldDict, AcDb::OpenMode mode) const (defined in AcDbObject) | AcDbObject |
getFullDrawOrder(AcDbObjectIdArray &ents, Adesk::UInt8 honorSortentsMask=0) const (defined in AcDbSortentsTable) | AcDbSortentsTable |
getObjectBirthVersion(AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject |
getObjectSaveVersion(const AcDbDwgFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getObjectSaveVersion(const AcDbDxfFiler *pFiler, AcDb::AcDbDwgVersion &ver, AcDb::MaintenanceReleaseVersion &maintVer) (defined in AcDbObject) | AcDbObject | virtual
getRelativeDrawOrder(AcDbObjectIdArray &ar, Adesk::UInt8 honorSortentsMask=0) const (defined in AcDbSortentsTable) | AcDbSortentsTable |
getSortHandle(AcDbObjectId id, AcDbHandle &h) const (defined in AcDbSortentsTable) | AcDbSortentsTable |
goodbye(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
gsNode() const (defined in AcDbObject) | AcDbObject | virtual
handOverTo(AcDbObject *newObject, Adesk::Boolean keepXData=true, Adesk::Boolean keepExtDict=true) (defined in AcDbObject) | AcDbObject |
hasFields(void) const (defined in AcDbObject) | AcDbObject |
hasPersistentReactor(AcDbObjectId objId) const (defined in AcDbObject) | AcDbObject |
hasSaveVersionOverride() (defined in AcDbObject) | AcDbObject |
id() const (defined in AcDbObject) | AcDbObject | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAcDbObjectIdsInFlux() const (defined in AcDbObject) | AcDbObject |
isAProxy() const (defined in AcDbObject) | AcDbObject |
isCancelling() const (defined in AcDbObject) | AcDbObject |
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isErased() const (defined in AcDbObject) | AcDbObject |
isEraseStatusToggled() const (defined in AcDbObject) | AcDbObject |
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isModified() const (defined in AcDbObject) | AcDbObject |
isModifiedGraphics() const (defined in AcDbObject) | AcDbObject |
isModifiedXData() const (defined in AcDbObject) | AcDbObject |
isNewObject() const (defined in AcDbObject) | AcDbObject |
isNotifyEnabled() const (defined in AcDbObject) | AcDbObject |
isNotifying() const (defined in AcDbObject) | AcDbObject |
isPersistent() const (defined in AcDbObject) | AcDbObject | virtual
isReadEnabled() const (defined in AcDbObject) | AcDbObject |
isReallyClosing() const (defined in AcDbObject) | AcDbObject |
isTransactionResident() const (defined in AcDbObject) | AcDbObject |
isUndoing() const (defined in AcDbObject) | AcDbObject |
isWriteEnabled() const (defined in AcDbObject) | AcDbObject |
kAmbientLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDistantLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableBlockDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableHasAttributes enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsAnEntity enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsCompoundObject enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsDimension enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableIsInvisible enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableNone enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableRegenTypeDependantGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableShadedDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableStandardDisplaySingleLOD enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableUsesNesting enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewDependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kDrawableViewIndependentViewportDraw enum value (defined in AcGiDrawable) | AcGiDrawable |
kGeometry enum value (defined in AcGiDrawable) | AcGiDrawable |
kGradientBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kGroundPlaneBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kImageBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kPointLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kSkyBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSolidBackground enum value (defined in AcGiDrawable) | AcGiDrawable |
kSpotLight enum value (defined in AcGiDrawable) | AcGiDrawable |
kViewport enum value (defined in AcGiDrawable) | AcGiDrawable |
kWebLight enum value (defined in AcGiDrawable) | AcGiDrawable |
mergeStyle() const (defined in AcDbObject) | AcDbObject | virtual
modified(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifiedGraphics(const AcDbEntity *dbEnt) (defined in AcDbObject) | AcDbObject | virtual
modifiedXData(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
modifyUndone(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
moveAbove(const AcDbObjectIdArray &ar, AcDbObjectId target) (defined in AcDbSortentsTable) | AcDbSortentsTable |
moveBelow(const AcDbObjectIdArray &ar, AcDbObjectId target) (defined in AcDbSortentsTable) | AcDbSortentsTable |
moveToBottom(const AcDbObjectIdArray &ar) (defined in AcDbSortentsTable) | AcDbSortentsTable |
moveToTop(const AcDbObjectIdArray &ar) (defined in AcDbSortentsTable) | AcDbSortentsTable |
objectClosed(const AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
objectId() const (defined in AcDbObject) | AcDbObject |
openedForModify(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
operator delete(void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete(void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator delete[](void *p, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new(size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
operator new[](size_t size, const char *pFName, int nLine) (defined in AcHeapOperators) | AcHeapOperators | inlinestatic
ownerId() const (defined in AcDbObject) | AcDbObject |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactors() (defined in AcDbObject) | AcDbObject |
reactors() const (defined in AcDbObject) | AcDbObject |
reappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
recvPropagateModify(const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
releaseExtensionDictionary() (defined in AcDbObject) | AcDbObject |
remove(AcDbObjectId) (defined in AcDbSortentsTable) | AcDbSortentsTable |
removeField(AcDbObjectId fieldId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName, AcDbObjectId &returnId) (defined in AcDbObject) | AcDbObject | virtual
removeField(const ACHAR *pszPropName) (defined in AcDbObject) | AcDbObject | virtual
removePersistentReactor(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
removeReactor(AcDbObjectReactor *newObj) const (defined in AcDbObject) | AcDbObject |
RolloverHit(Adesk::ULongPtr nSubentId, Adesk::ULongPtr nMouseFlags, Adesk::Boolean bReset) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
setAcDbObjectIdsInFlux() (defined in AcDbObject) | AcDbObject |
setAttributes(AcGiDrawableTraits *pTraits) (defined in AcDbObject) | AcDbObject | virtual
SetAttributesFlags enum name (defined in AcGiDrawable) | AcGiDrawable |
setBinaryData(const ACHAR *key, long size, const char *data) (defined in AcDbObject) | AcDbObject |
setBlockId(AcDbObjectId) (defined in AcDbSortentsTable) | AcDbSortentsTable |
setField(const ACHAR *pszPropName, AcDbField *pField, AcDbObjectId &fieldId) (defined in AcDbObject) | AcDbObject | virtual
setGsNode(AcGsNode *pNode) (defined in AcDbObject) | AcDbObject | virtual
setHasSaveVersionOverride(bool bSetIt) (defined in AcDbObject) | AcDbObject |
setOwnerId(AcDbObjectId objId) (defined in AcDbObject) | AcDbObject | virtual
setRelativeDrawOrder(const AcDbObjectIdArray &ar) (defined in AcDbSortentsTable) | AcDbSortentsTable |
setXData(const resbuf *xdata) (defined in AcDbObject) | AcDbObject | virtual
sortAs(AcDbObjectId, AcDbHandle &) const (defined in AcDbSortentsTable) | AcDbSortentsTable |
subCancel() (defined in AcDbObject) | AcDbObject | virtual
subClose() (defined in AcDbObject) | AcDbObject | virtual
subErase(Adesk::Boolean erasing) (defined in AcDbObject) | AcDbObject | virtual
subHandOverTo(AcDbObject *newObject) (defined in AcDbObject) | AcDbObject | virtual
subObjModified(const AcDbObject *dbObj, const AcDbObject *subObj) (defined in AcDbObject) | AcDbObject | virtual
subOpen(AcDb::OpenMode mode) (defined in AcDbObject) | AcDbObject | virtual
subSwapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject | virtual
swapIdWith(AcDbObjectId otherId, Adesk::Boolean swapXdata=false, Adesk::Boolean swapExtDict=false) (defined in AcDbObject) | AcDbObject |
swapOrder(AcDbObjectId, AcDbObjectId) (defined in AcDbSortentsTable) | AcDbSortentsTable |
swapReferences(const AcDbIdMapping &idMap) (defined in AcDbObject) | AcDbObject | virtual
unappended(const AcDbObject *dbObj) (defined in AcDbObject) | AcDbObject | virtual
undoFiler() (defined in AcDbObject) | AcDbObject |
upgradeFromNotify(Adesk::Boolean &wasWritable) (defined in AcDbObject) | AcDbObject |
upgradeOpen() (defined in AcDbObject) | AcDbObject |
viewportDraw(AcGiViewportDraw *pVd) (defined in AcDbObject) | AcDbObject | virtual
viewportDrawLogicalFlags(AcGiViewportDraw *vd) (defined in AcGiDrawable) | AcGiDrawable | inlinevirtual
wblockClone(AcRxObject *pOwnerObject, AcDbObject *&pClonedObject, AcDbIdMapping &idMap, Adesk::Boolean isPrimary=true) const (defined in AcDbObject) | AcDbObject | virtual
worldDraw(AcGiWorldDraw *pWd) (defined in AcDbObject) | AcDbObject | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xData(const ACHAR *regappName=NULL) const (defined in AcDbObject) | AcDbObject | virtual
xDataTransformBy(const AcGeMatrix3d &xform) (defined in AcDbObject) | AcDbObject |
xmitPropagateModify() const (defined in AcDbObject) | AcDbObject | virtual
~AcDbObject() (defined in AcDbObject) | AcDbObject | virtual
~AcDbSortentsTable() (defined in AcDbSortentsTable) | AcDbSortentsTable | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcEdServices Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdServices Class Reference
+ Inheritance diagram for AcEdServices:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcEdServices)
virtual AcEdCommand * | newAcEdCommand (AcRxFunctionPtr cmdFcnAddr, Adesk::Int32 cmdFlags) const =0
- Public Member Functions inherited from AcRxService
ACRX_DECLARE_MEMBERS (AcRxService)
void | addDependency ()
DepFuncPtr | dependencyFunctionPtr ()
AcRxObject * | getSysInfo () const
void | removeDependency ()
void | setDependencyFunctionPtr (DepFuncPtr)
void | setSysInfo (AcRxObject *sysInfoObj)
Adesk::Boolean | unloadable () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • aced.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdServices Member List

This is the complete list of members for AcEdServices, including all inherited members.

ACRX_DECLARE_MEMBERS(AcEdServices) (defined in AcEdServices) | AcEdServices |
ACRX_DECLARE_MEMBERS(AcRxService) (defined in AcRxService) | AcRxService |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
AcRxService() (defined in AcRxService) | AcRxService |
addDependency() (defined in AcRxService) | AcRxService |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
dependencyFunctionPtr() (defined in AcRxService) | AcRxService |
desc() (defined in AcRxObject) | AcRxObject | static
getSysInfo() const (defined in AcRxService) | AcRxService |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
newAcEdCommand(AcRxFunctionPtr cmdFcnAddr, Adesk::Int32 cmdFlags) const =0 (defined in AcEdServices) | AcEdServices | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeDependency() (defined in AcRxService) | AcRxService |
setDependencyFunctionPtr(DepFuncPtr) (defined in AcRxService) | AcRxService |
setSysInfo(AcRxObject *sysInfoObj) (defined in AcRxService) | AcRxService |
unloadable() const (defined in AcRxService) | AcRxService |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~AcRxService() (defined in AcRxService) | AcRxService | virtual


ZRX API Reference: AcEdSubSelectFilter Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcEdSubSelectFilter Class Reference

Public Types

enum SubSelectStatus { kSubSelectionNone = 0, kSubSelectionAugment, kSubSelectionExclusive, kSubSelectAll }

Public Member Functions

virtual bool | cancelAllSubSelect ()
virtual bool | cancelSubSelect (AcDbEntity *pEnt)
virtual bool | isSubSelected (AcDbEntity *pEnt) const
virtual bool | onKey (unsigned long wMsg, unsigned int nChar, unsigned int rptCnt, unsigned int flags)
virtual bool | reSubSelectEntity (AcDbEntity *pEnt, AcDbFullSubentPathArray &paths)
virtual bool | selectEntity (const AcGePoint3d &wvpt, const AcGeVector3d &wvwdir, const AcGeVector3d &wvwxdir, double wxaper, double wyaper, long flags, const AcGiViewport *pCurVp, AcDbEntity *pEnt) const
virtual Acad::ErrorStatus | subSelectClassList (AcArray< AcRxClass * > &clsIds)
virtual SubSelectStatus | subSelectEntity (const AcGePoint3d &wpt1, const AcGePoint3d &wpt2, const AcGeVector3d &wvwdir, const AcGeVector3d &wvwxdir, double wxaper, double wyaper, AcDb::SelectType seltype, bool bAugment, bool bIsInPickfirstSet, bool bEvery, const AcGiViewport *pCurVP, AcDbEntity *pEnt, AcDbFullSubentPathArray &paths)
virtual SubSelectStatus | subSelectEntity (const resbuf *pResbuf, bool bAugment, bool bIsInPickfirstSet, bool bEvery, const AcGiViewport *pCurVP, AcDbEntity *pEnt, AcDbFullSubentPathArray &paths)
The documentation for this class was generated from the following file:
  • subselect.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdSubSelectFilter Member List

This is the complete list of members for AcEdSubSelectFilter, including all inherited members.

cancelAllSubSelect() (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter | inlinevirtual
cancelSubSelect(AcDbEntity *pEnt) (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter | inlinevirtual
isSubSelected(AcDbEntity *pEnt) const (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter | inlinevirtual
kSubSelectAll enum value (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter |
kSubSelectionAugment enum value (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter |
kSubSelectionExclusive enum value (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter |
kSubSelectionNone enum value (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter |
onKey(unsigned long wMsg, unsigned int nChar, unsigned int rptCnt, unsigned int flags) (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter | inlinevirtual
reSubSelectEntity(AcDbEntity *pEnt, AcDbFullSubentPathArray &paths) (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter | inlinevirtual
selectEntity(const AcGePoint3d &wvpt, const AcGeVector3d &wvwdir, const AcGeVector3d &wvwxdir, double wxaper, double wyaper, long flags, const AcGiViewport *pCurVp, AcDbEntity *pEnt) const (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter | inlinevirtual
subSelectClassList(AcArray< AcRxClass * > &clsIds) (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter | inlinevirtual
subSelectEntity(const AcGePoint3d &wpt1, const AcGePoint3d &wpt2, const AcGeVector3d &wvwdir, const AcGeVector3d &wvwxdir, double wxaper, double wyaper, AcDb::SelectType seltype, bool bAugment, bool bIsInPickfirstSet, bool bEvery, const AcGiViewport *pCurVP, AcDbEntity *pEnt, AcDbFullSubentPathArray &paths) (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter | inlinevirtual
subSelectEntity(const resbuf *pResbuf, bool bAugment, bool bIsInPickfirstSet, bool bEvery, const AcGiViewport *pCurVP, AcDbEntity *pEnt, AcDbFullSubentPathArray &paths) (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter | inlinevirtual
SubSelectStatus enum name (defined in AcEdSubSelectFilter) | AcEdSubSelectFilter |


ZRX API Reference: AcEdXrefFileLock Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcEdXrefFileLock Class Reference

Public Member Functions

Acad::ErrorStatus | consistencyCheck (int &retstatus, const AcDbObjectId &selectedBTRid, AcDbObjectIdArray &outofSyncBTRids)
Acad::ErrorStatus | consistencyCheck (int &retstatus, const AcDbObjectId &selectedBTRid)
Acad::ErrorStatus | consistencyChecklocal (int &retstatus, const AcDbObjectId &selectedBTRid)
int | getlockxloadctlType () const
AcDbObjectIdArray | getoutofSyncIdArray () const
Acad::ErrorStatus | lockFile (int &retstatus, const AcDbObjectId &selectedBTRid)
Acad::ErrorStatus | releaseFile (int &retstatus, bool bSkipSaveback=false, bool bReload=true)
Acad::ErrorStatus | reloadFile (int &retstatus, const AcDbObjectIdArray &BTRids, const int xldctltype=-1)
Acad::ErrorStatus | reloadFile (int &retstatus, const int xldctltype=-1)
void | setInternalTNmgmt (bool bTNmgmt)
Acad::ErrorStatus | xloadctlType (int &retstatus, const AcDbObjectId &selectedBTRid)
The documentation for this class was generated from the following file:
  • xreflock.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdXrefFileLock Member List

This is the complete list of members for AcEdXrefFileLock, including all inherited members.

AcEdXrefFileLock() (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
consistencyCheck(int &retstatus, const AcDbObjectId &selectedBTRid, AcDbObjectIdArray &outofSyncBTRids) (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
consistencyCheck(int &retstatus, const AcDbObjectId &selectedBTRid) (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
consistencyChecklocal(int &retstatus, const AcDbObjectId &selectedBTRid) (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
getlockxloadctlType() const (defined in AcEdXrefFileLock) | AcEdXrefFileLock | inline
getoutofSyncIdArray() const (defined in AcEdXrefFileLock) | AcEdXrefFileLock | inline
lockFile(int &retstatus, const AcDbObjectId &selectedBTRid) (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
releaseFile(int &retstatus, bool bSkipSaveback=false, bool bReload=true) (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
reloadFile(int &retstatus, const AcDbObjectIdArray &BTRids, const int xldctltype=-1) (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
reloadFile(int &retstatus, const int xldctltype=-1) (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
setInternalTNmgmt(bool bTNmgmt) (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
xloadctlType(int &retstatus, const AcDbObjectId &selectedBTRid) (defined in AcEdXrefFileLock) | AcEdXrefFileLock |
~AcEdXrefFileLock() (defined in AcEdXrefFileLock) | AcEdXrefFileLock |


ZRX API Reference: AcGiVariant::EnumType Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcGiVariant
  • EnumType
Public Member Functions | Protected Attributes | List of all members
AcGiVariant::EnumType Class Reference

Public Member Functions

EnumType (int value)
template<typename T >
operator T ()
template<typename T >
bool | operator!= (T right) const
template<typename T >
bool | operator== (T right) const

Protected Attributes

int m_value
The documentation for this class was generated from the following file:
  • acgi.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • AcGiVariant
  • EnumType
AcGiVariant::EnumType Member List

This is the complete list of members for AcGiVariant::EnumType, including all inherited members.

EnumType(int value) (defined in AcGiVariant::EnumType) | AcGiVariant::EnumType | inlineexplicit
m_value (defined in AcGiVariant::EnumType) | AcGiVariant::EnumType | protected
operator T() (defined in AcGiVariant::EnumType) | AcGiVariant::EnumType | inline
operator!=(T right) const (defined in AcGiVariant::EnumType) | AcGiVariant::EnumType | inline
operator==(T right) const (defined in AcGiVariant::EnumType) | AcGiVariant::EnumType | inline


ZRX API Reference: AcGsClassFactory Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGsClassFactory Class Reference

Public Member Functions

virtual void | addReactor (AcGsReactor *pReactor)=0
virtual AcGsDevice * | createDevice (AcGsWindowingSystemID id, GS::DeviceType deviceType=GS::kScreenDevice)=0
virtual AcGsModel * | createModel (AcGsModel::RenderType, LONG_PTR databaseId, AcGsGetInterfaceFunc, AcGsReleaseInterfaceFunc)=0
virtual AcGsDevice * | createOffScreenDevice (void)=0
virtual AcGsView * | createView (const AcGsClientViewInfo *pInfo=NULL, bool bEnableLayerVisibilityPerView=false)=0
virtual void | deleteDevice (AcGsDevice *device)=0
virtual void | deleteModel (AcGsModel *model)=0
virtual void | deleteView (AcGsView *view)=0
virtual AcGsConfig * | getConfig (void)=0
virtual void | releaseConfig (AcGsConfig *config)=0
virtual void | removeReactor (AcGsReactor *pReactor)=0
The documentation for this class was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsClassFactory Member List

This is the complete list of members for AcGsClassFactory, including all inherited members.

addReactor(AcGsReactor *pReactor)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
createDevice(AcGsWindowingSystemID id, GS::DeviceType deviceType=GS::kScreenDevice)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
createModel(AcGsModel::RenderType, LONG_PTR databaseId, AcGsGetInterfaceFunc, AcGsReleaseInterfaceFunc)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
createOffScreenDevice(void)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
createView(const AcGsClientViewInfo *pInfo=NULL, bool bEnableLayerVisibilityPerView=false)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
deleteDevice(AcGsDevice *device)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
deleteModel(AcGsModel *model)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
deleteView(AcGsView *view)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
getConfig(void)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
releaseConfig(AcGsConfig *config)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
removeReactor(AcGsReactor *pReactor)=0 (defined in AcGsClassFactory) | AcGsClassFactory | pure virtual
~AcGsClassFactory(void) (defined in AcGsClassFactory) | AcGsClassFactory | inlinevirtual


ZRX API Reference: AcGsClientViewInfo Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcGsClientViewInfo Struct Reference

Public Attributes

LONG_PTR | acadWindowId
AcGiContextualColors * | contextColors
LONG_PTR | viewportId
LONG_PTR | viewportObjectId
The documentation for this struct was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsClientViewInfo Member List

This is the complete list of members for AcGsClientViewInfo, including all inherited members.

acadWindowId (defined in AcGsClientViewInfo) | AcGsClientViewInfo |
AcGsClientViewInfo() (defined in AcGsClientViewInfo) | AcGsClientViewInfo | inline
contextColors (defined in AcGsClientViewInfo) | AcGsClientViewInfo |
viewportId (defined in AcGsClientViewInfo) | AcGsClientViewInfo |
viewportObjectId (defined in AcGsClientViewInfo) | AcGsClientViewInfo |


ZRX API Reference: AcGsColor Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AcGsColor Struct Reference

Public Attributes

unsigned char | m_blue
unsigned char | m_filler
unsigned char | m_green
unsigned char | m_red
The documentation for this struct was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsColor Member List

This is the complete list of members for AcGsColor, including all inherited members.

m_blue (defined in AcGsColor) | AcGsColor
m_filler (defined in AcGsColor) | AcGsColor
m_green (defined in AcGsColor) | AcGsColor
m_red (defined in AcGsColor) | AcGsColor


ZRX API Reference: AcGsConfig Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGsConfig Class Reference

Public Types

enum DegradationChannel {
kViewportDraw, kLineAntialias, kLighting, kTransparencyQuality,
kShadowsFull, kTransparency, kDiscardBackfaces, kShadowsGround,
kEdgeStyles, kFacetEdges, kFastSilhouette, kTextures,
kMaterials, kLightingQuality, kBackgrounds, kIntersectEdges,
kFaceted, kWireframe, kDegradationChannels
}
enum | Handedness { kLeft, kRight }
enum HardwareFeature {
kHwAcceleration, kHwGeometryAccel, kHwAntiAliasing, kHwGooch,
kHwShadows, kHwTextureCompression, kHwFeatures
}
enum | Quality { kLowQuality, kMediumQuality, kHighQuality }

Public Member Functions

virtual bool | adaptiveDegradation (void)=0
virtual bool | cacheViewportDrawGeometry () const =0
virtual bool | canDegradeChannel (DegradationChannel channel)=0
virtual bool | configure (const ACHAR *pszConfigInfo, bool bShowDialog)=0
virtual void | currentDisplayDriver (ACHAR *pszPath, int nPathStrLen, ACHAR *pszDriver, int nDriverStrLen, bool &bHardwareAccelerated)=0
virtual int | curveTessellationTol (void)=0
virtual void | defaultHardwareAcceleratedDriver (ACHAR *pszPath, int nPathStrLen, ACHAR *pszDriver, int nDriverStrLen)=0
virtual int | degradationChainPosition (DegradationChannel channel)=0
virtual DegradationChannel | degradationChannelAt (int position)=0
virtual bool | discardBackFaces (void)=0
virtual void | driverName (ACHAR *pszPath, int nStrLen) const =0
virtual void | driverPath (ACHAR *pszPath, int nStrLen) const =0
virtual int | driverRevision (void) const =0
virtual int | driverVersion (void) const =0
virtual bool | dynamicTessellation (void)=0
virtual int | frameRate (void)=0
virtual Handedness | handedness (void) const =0
virtual void | hardwareAcceleratedDriver (ACHAR *pszPath, int nPathStrLen, ACHAR *pszDriver, int nDriverStrLen)=0
virtual void | hardwareAcceleratedDrivers (ACHAR *pszPath, int nPathStrLen, ACHAR **pszDrivers, int nDrivers)=0
virtual bool | isFeatureAvailable (HardwareFeature feature)=0
virtual bool | isFeatureEnabled (HardwareFeature feature)=0
virtual bool | isFeatureRecommended (HardwareFeature feature)=0
virtual int | maxLODs (void)=0
virtual int | numHardwareAcceleratedDrivers (void)=0
virtual bool | redrawOnWindowExpose (void)=0
virtual bool | saveSettings (void)=0
virtual void | setAdaptiveDegradation (bool bAdaptiveDegradation)=0
virtual void | setCacheViewportDrawGeometry (bool bCacheViewportGeometry)=0
virtual void | setCanDegradeChannel (DegradationChannel channel, bool bDegrade)=0
virtual GS::ErrorStatus | setCurveTessellationTol (int curveTessellationTol)=0
virtual void | setDiscardBackFaces (bool bDiscardBackFaces)=0
virtual void | setDriverPath (const ACHAR *pszPath)=0
virtual void | setDynamicTessellation (bool bDynamicTessellation)=0
virtual void | setFeatureEnabled (HardwareFeature feature, bool bEnable=true)=0
virtual GS::ErrorStatus | setFrameRate (int nFramesPerSecond)=0
virtual void | setHandedness (Handedness)=0
virtual void | setHardwareAcceleratedDriver (const ACHAR *pszPath, const ACHAR *pszDriver)=0
virtual GS::ErrorStatus | setMaxLODs (int nLevels)=0
virtual void | setRedrawOnWindowExpose (bool bRedrawWindowExpose)=0
virtual GS::ErrorStatus | setSurfaceTessellationTol (int surfaceTessellationTol)=0
virtual void | setTransparency (Quality quality)=0
virtual void | setUseDisplayLists (bool bUseDisplayLists)=0
virtual void | setUseHalfPixelDeviation (bool bUseHalfPixelDeviation)=0
virtual void | shiftDegradationChainPosition (DegradationChannel channel, bool bShiftDown)=0
virtual int | surfaceTessellationTol (void)=0
virtual Quality | transparency (void)=0
virtual bool | useDisplayLists (void)=0
virtual bool | useHalfPixelDeviation (void)=0
The documentation for this class was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsConfig Member List

This is the complete list of members for AcGsConfig, including all inherited members.

adaptiveDegradation(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
cacheViewportDrawGeometry() const =0 (defined in AcGsConfig) | AcGsConfig | pure virtual
canDegradeChannel(DegradationChannel channel)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
configure(const ACHAR *pszConfigInfo, bool bShowDialog)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
currentDisplayDriver(ACHAR *pszPath, int nPathStrLen, ACHAR *pszDriver, int nDriverStrLen, bool &bHardwareAccelerated)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
curveTessellationTol(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
defaultHardwareAcceleratedDriver(ACHAR *pszPath, int nPathStrLen, ACHAR *pszDriver, int nDriverStrLen)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
degradationChainPosition(DegradationChannel channel)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
DegradationChannel enum name (defined in AcGsConfig) | AcGsConfig |
degradationChannelAt(int position)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
discardBackFaces(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
driverName(ACHAR *pszPath, int nStrLen) const =0 (defined in AcGsConfig) | AcGsConfig | pure virtual
driverPath(ACHAR *pszPath, int nStrLen) const =0 (defined in AcGsConfig) | AcGsConfig | pure virtual
driverRevision(void) const =0 (defined in AcGsConfig) | AcGsConfig | pure virtual
driverVersion(void) const =0 (defined in AcGsConfig) | AcGsConfig | pure virtual
dynamicTessellation(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
frameRate(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
handedness(void) const =0 (defined in AcGsConfig) | AcGsConfig | pure virtual
Handedness enum name (defined in AcGsConfig) | AcGsConfig |
hardwareAcceleratedDriver(ACHAR *pszPath, int nPathStrLen, ACHAR *pszDriver, int nDriverStrLen)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
hardwareAcceleratedDrivers(ACHAR *pszPath, int nPathStrLen, ACHAR **pszDrivers, int nDrivers)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
HardwareFeature enum name (defined in AcGsConfig) | AcGsConfig |
isFeatureAvailable(HardwareFeature feature)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
isFeatureEnabled(HardwareFeature feature)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
isFeatureRecommended(HardwareFeature feature)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
kBackgrounds enum value (defined in AcGsConfig) | AcGsConfig |
kDegradationChannels enum value (defined in AcGsConfig) | AcGsConfig |
kDiscardBackfaces enum value (defined in AcGsConfig) | AcGsConfig |
kEdgeStyles enum value (defined in AcGsConfig) | AcGsConfig |
kFaceted enum value (defined in AcGsConfig) | AcGsConfig |
kFacetEdges enum value (defined in AcGsConfig) | AcGsConfig |
kFastSilhouette enum value (defined in AcGsConfig) | AcGsConfig |
kHighQuality enum value (defined in AcGsConfig) | AcGsConfig |
kHwAcceleration enum value (defined in AcGsConfig) | AcGsConfig |
kHwAntiAliasing enum value (defined in AcGsConfig) | AcGsConfig |
kHwFeatures enum value (defined in AcGsConfig) | AcGsConfig |
kHwGeometryAccel enum value (defined in AcGsConfig) | AcGsConfig |
kHwGooch enum value (defined in AcGsConfig) | AcGsConfig |
kHwShadows enum value (defined in AcGsConfig) | AcGsConfig |
kHwTextureCompression enum value (defined in AcGsConfig) | AcGsConfig |
kIntersectEdges enum value (defined in AcGsConfig) | AcGsConfig |
kLeft enum value (defined in AcGsConfig) | AcGsConfig |
kLighting enum value (defined in AcGsConfig) | AcGsConfig |
kLightingQuality enum value (defined in AcGsConfig) | AcGsConfig |
kLineAntialias enum value (defined in AcGsConfig) | AcGsConfig |
kLowQuality enum value (defined in AcGsConfig) | AcGsConfig |
kMaterials enum value (defined in AcGsConfig) | AcGsConfig |
kMediumQuality enum value (defined in AcGsConfig) | AcGsConfig |
kRight enum value (defined in AcGsConfig) | AcGsConfig |
kShadowsFull enum value (defined in AcGsConfig) | AcGsConfig |
kShadowsGround enum value (defined in AcGsConfig) | AcGsConfig |
kTextures enum value (defined in AcGsConfig) | AcGsConfig |
kTransparency enum value (defined in AcGsConfig) | AcGsConfig |
kTransparencyQuality enum value (defined in AcGsConfig) | AcGsConfig |
kViewportDraw enum value (defined in AcGsConfig) | AcGsConfig |
kWireframe enum value (defined in AcGsConfig) | AcGsConfig |
maxLODs(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
numHardwareAcceleratedDrivers(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
Quality enum name (defined in AcGsConfig) | AcGsConfig |
redrawOnWindowExpose(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
saveSettings(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setAdaptiveDegradation(bool bAdaptiveDegradation)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setCacheViewportDrawGeometry(bool bCacheViewportGeometry)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setCanDegradeChannel(DegradationChannel channel, bool bDegrade)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setCurveTessellationTol(int curveTessellationTol)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setDiscardBackFaces(bool bDiscardBackFaces)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setDriverPath(const ACHAR *pszPath)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setDynamicTessellation(bool bDynamicTessellation)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setFeatureEnabled(HardwareFeature feature, bool bEnable=true)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setFrameRate(int nFramesPerSecond)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setHandedness(Handedness)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setHardwareAcceleratedDriver(const ACHAR *pszPath, const ACHAR *pszDriver)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setMaxLODs(int nLevels)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setRedrawOnWindowExpose(bool bRedrawWindowExpose)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setSurfaceTessellationTol(int surfaceTessellationTol)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setTransparency(Quality quality)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setUseDisplayLists(bool bUseDisplayLists)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
setUseHalfPixelDeviation(bool bUseHalfPixelDeviation)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
shiftDegradationChainPosition(DegradationChannel channel, bool bShiftDown)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
surfaceTessellationTol(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
transparency(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
useDisplayLists(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
useHalfPixelDeviation(void)=0 (defined in AcGsConfig) | AcGsConfig | pure virtual
~AcGsConfig(void) (defined in AcGsConfig) | AcGsConfig | inlinevirtual


ZRX API Reference: AcGsDCPoint Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes | List of all members
AcGsDCPoint Class Reference

Public Types

enum | MaxFlag { Maximum }
enum | MinFlag { Minimum }

Public Member Functions

AcGsDCPoint (long xin, long yin)
AcGsDCPoint (MaxFlag)
AcGsDCPoint (MinFlag)
bool | operator!= (AcGsDCPoint const &r) const
void | operator= (MaxFlag)
void | operator= (MinFlag)
void | operator= (AcGsDCPoint const &r)
bool | operator== (AcGsDCPoint const &r) const

Public Attributes

long | x
long | y
The documentation for this class was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsDCPoint Member List

This is the complete list of members for AcGsDCPoint, including all inherited members.

AcGsDCPoint(void) (defined in AcGsDCPoint) | AcGsDCPoint | inline
AcGsDCPoint(long xin, long yin) (defined in AcGsDCPoint) | AcGsDCPoint | inline
AcGsDCPoint(MaxFlag) (defined in AcGsDCPoint) | AcGsDCPoint | inline
AcGsDCPoint(MinFlag) (defined in AcGsDCPoint) | AcGsDCPoint | inline
MaxFlag enum name (defined in AcGsDCPoint) | AcGsDCPoint |
Maximum enum value (defined in AcGsDCPoint) | AcGsDCPoint |
MinFlag enum name (defined in AcGsDCPoint) | AcGsDCPoint |
Minimum enum value (defined in AcGsDCPoint) | AcGsDCPoint |
operator!=(AcGsDCPoint const &r) const (defined in AcGsDCPoint) | AcGsDCPoint | inline
operator=(MaxFlag) (defined in AcGsDCPoint) | AcGsDCPoint | inline
operator=(MinFlag) (defined in AcGsDCPoint) | AcGsDCPoint | inline
operator=(AcGsDCPoint const &r) (defined in AcGsDCPoint) | AcGsDCPoint | inline
operator==(AcGsDCPoint const &r) const (defined in AcGsDCPoint) | AcGsDCPoint | inline
x (defined in AcGsDCPoint) | AcGsDCPoint |
y (defined in AcGsDCPoint) | AcGsDCPoint |


ZRX API Reference: AcGsDCRect Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes | List of all members
AcGsDCRect Class Reference

Public Types

enum NullFlag { Null }

Public Member Functions

AcGsDCRect (AcGsDCPoint const &min, AcGsDCPoint const &max)
AcGsDCRect (long l, long r, long b, long t)
AcGsDCRect (NullFlag)
bool | is_null (void) const
bool | operator!= (AcGsDCRect const &rightside) const
void | operator&= (AcGsDCRect const &rightside)
AcGsDCRect & | operator= (AcGsDCRect const &other)
bool | operator== (AcGsDCRect const &rightside) const
void | operator|= (AcGsDCRect const &rightside)
void | set_null (void)
bool | within (AcGsDCRect const &rightside) const

Public Attributes

AcGsDCPoint | m_max
AcGsDCPoint | m_min
The documentation for this class was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsDCRect Member List

This is the complete list of members for AcGsDCRect, including all inherited members.

AcGsDCRect(void) (defined in AcGsDCRect) | AcGsDCRect | inline
AcGsDCRect(AcGsDCPoint const &min, AcGsDCPoint const &max) (defined in AcGsDCRect) | AcGsDCRect | inline
AcGsDCRect(long l, long r, long b, long t) (defined in AcGsDCRect) | AcGsDCRect | inline
AcGsDCRect(NullFlag) (defined in AcGsDCRect) | AcGsDCRect | inline
is_null(void) const (defined in AcGsDCRect) | AcGsDCRect | inline
m_max (defined in AcGsDCRect) | AcGsDCRect |
m_min (defined in AcGsDCRect) | AcGsDCRect |
Null enum value (defined in AcGsDCRect) | AcGsDCRect |
NullFlag enum name (defined in AcGsDCRect) | AcGsDCRect |
operator!=(AcGsDCRect const &rightside) const (defined in AcGsDCRect) | AcGsDCRect | inline
operator&=(AcGsDCRect const &rightside) (defined in AcGsDCRect) | AcGsDCRect | inline
operator=(AcGsDCRect const &other) (defined in AcGsDCRect) | AcGsDCRect | inline
operator==(AcGsDCRect const &rightside) const (defined in AcGsDCRect) | AcGsDCRect | inline
operator|=(AcGsDCRect const &rightside) (defined in AcGsDCRect) | AcGsDCRect | inline
set_null(void) (defined in AcGsDCRect) | AcGsDCRect | inline
within(AcGsDCRect const &rightside) const (defined in AcGsDCRect) | AcGsDCRect | inline


ZRX API Reference: AcGsDevice Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGsDevice Class Reference

Public Types

enum RendererType {
kDefault, kSoftware, kSoftwareNewViewsOnly, kFullRender,
kSelectionRender
}

Public Member Functions

virtual bool | add (AcGsView *view)=0
virtual bool | erase (AcGsView *view)=0
virtual void | eraseAll (void)=0
virtual AcGsColor | getBackgroundColor (void)=0
virtual RendererType | getDeviceRenderer (void)=0
virtual void | getSnapShot (Atil::Image *pOutput, AcGsDCPoint const &offset)=0
virtual void | invalidate (void)=0
virtual void | invalidate (const AcGsDCRect &rect)=0
virtual bool | isValid (void) const =0
virtual void | onDisplayChange (int nBitsPerPixel, int nXRes, int nYRes)=0
virtual void | onRealizeBackgroundPalette (void)=0
virtual void | onRealizeForegroundPalette (void)=0
virtual void | onSize (int width, int height)=0
virtual bool | setBackgroundColor (AcGsColor color)=0
virtual void | setDeviceRenderer (RendererType type)=0
virtual void | setLogicalPalette (const AcGsColor *palette, int nCount)=0
virtual void | setPhysicalPalette (const AcGsColor *palette, int nCount)=0
virtual void | update (AcGsDCRect *pUpdatedRect=NULL)=0
The documentation for this class was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsDevice Member List

This is the complete list of members for AcGsDevice, including all inherited members.

add(AcGsView *view)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
erase(AcGsView *view)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
eraseAll(void)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
getBackgroundColor(void)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
getDeviceRenderer(void)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
getSnapShot(Atil::Image *pOutput, AcGsDCPoint const &offset)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
invalidate(void)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
invalidate(const AcGsDCRect &rect)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
isValid(void) const =0 (defined in AcGsDevice) | AcGsDevice | pure virtual
kDefault enum value (defined in AcGsDevice) | AcGsDevice |
kFullRender enum value (defined in AcGsDevice) | AcGsDevice |
kSelectionRender enum value (defined in AcGsDevice) | AcGsDevice |
kSoftware enum value (defined in AcGsDevice) | AcGsDevice |
kSoftwareNewViewsOnly enum value (defined in AcGsDevice) | AcGsDevice |
onDisplayChange(int nBitsPerPixel, int nXRes, int nYRes)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
onRealizeBackgroundPalette(void)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
onRealizeForegroundPalette(void)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
onSize(int width, int height)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
RendererType enum name (defined in AcGsDevice) | AcGsDevice |
setBackgroundColor(AcGsColor color)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
setDeviceRenderer(RendererType type)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
setLogicalPalette(const AcGsColor *palette, int nCount)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
setPhysicalPalette(const AcGsColor *palette, int nCount)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
update(AcGsDCRect *pUpdatedRect=NULL)=0 (defined in AcGsDevice) | AcGsDevice | pure virtual
~AcGsDevice(void) (defined in AcGsDevice) | AcGsDevice | inlinevirtual


ZRX API Reference: AcGsModel Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGsModel Class Reference

Public Types

enum InvalidationHint {
kInvalidateNone, kInvalidateIsolines, kInvalidateViewportCache, kInvalidateAll,
kInvalidateAllStatic, kInvalidateFacets, kInvalidateFills, kInvalidateLinetypes,
kInvalidateMaterials, kInvalidateLayers
}
enum RenderType {
kMain, kSprite, kDirect, kHighlight,
kHighlightSelection, kCount
}

Public Member Functions

virtual bool | addSceneGraphRoot (AcGiDrawable *pRoot)=0
virtual AcDbObjectId | background (void) const =0
virtual void | enableLinetypes (bool bEnable)=0
virtual bool | eraseSceneGraphRoot (AcGiDrawable *pRoot)=0
virtual void | invalidate (InvalidationHint hint)=0
virtual bool | isSectioningEnabled (void) const =0
virtual bool | linetypesEnabled (void) const =0
virtual void | onAdded (AcGiDrawable *pAdded, AcGiDrawable *pParent)=0
virtual void | onAdded (AcGiDrawable *pAdded, LONG_PTR parentID)=0
virtual void | onErased (AcGiDrawable *pErased, AcGiDrawable *pParent)=0
virtual void | onErased (AcGiDrawable *pErased, LONG_PTR parentID)=0
virtual void | onModified (AcGiDrawable *pModified, AcGiDrawable *pParent)=0
virtual void | onModified (AcGiDrawable *pModified, LONG_PTR parentID)=0
virtual void | onPaletteModified (void)=0
virtual RenderType | renderType (void)=0
virtual void | setBackground (const AcDbObjectId backgroundId)=0
virtual void | setEnableSectioning (bool enable)=0
virtual void | setExtents (const AcGePoint3d &, const AcGePoint3d &)=0
virtual void | setRenderModeOverride (AcGsView::RenderMode mode=AcGsView::kNone)=0
virtual bool | setSectioning (const AcGePoint3dArray &pts, const AcGeVector3d &upVector)=0
virtual bool | setSectioning (const AcGePoint3dArray &pts, const AcGeVector3d &upVector, double top, double bottom)=0
virtual void | setSectioningVisualStyle (const AcDbObjectId visualStyleId)=0
virtual void | setShadowPlaneLocation (double planeLocationZ)=0
virtual void | setTransform (const AcGeMatrix3d &)=0
virtual void | setViewClippingOverride (bool bOverride)=0
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)=0
virtual void | setVisualStyle (const AcGiVisualStyle &visualStyle)=0
virtual double | shadowPlaneLocation (void) const =0
virtual AcGeMatrix3d | transform (void) const =0
virtual AcDbObjectId | visualStyle (void) const =0
virtual bool | visualStyle (AcGiVisualStyle &visualStyle) const =0
The documentation for this class was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsModel Member List

This is the complete list of members for AcGsModel, including all inherited members.

addSceneGraphRoot(AcGiDrawable *pRoot)=0 (defined in AcGsModel) | AcGsModel | pure virtual
background(void) const =0 (defined in AcGsModel) | AcGsModel | pure virtual
enableLinetypes(bool bEnable)=0 (defined in AcGsModel) | AcGsModel | pure virtual
eraseSceneGraphRoot(AcGiDrawable *pRoot)=0 (defined in AcGsModel) | AcGsModel | pure virtual
invalidate(InvalidationHint hint)=0 (defined in AcGsModel) | AcGsModel | pure virtual
InvalidationHint enum name (defined in AcGsModel) | AcGsModel |
isSectioningEnabled(void) const =0 (defined in AcGsModel) | AcGsModel | pure virtual
kCount enum value (defined in AcGsModel) | AcGsModel |
kDirect enum value (defined in AcGsModel) | AcGsModel |
kHighlight enum value (defined in AcGsModel) | AcGsModel |
kHighlightSelection enum value (defined in AcGsModel) | AcGsModel |
kInvalidateAll enum value (defined in AcGsModel) | AcGsModel |
kInvalidateAllStatic enum value (defined in AcGsModel) | AcGsModel |
kInvalidateFacets enum value (defined in AcGsModel) | AcGsModel |
kInvalidateFills enum value (defined in AcGsModel) | AcGsModel |
kInvalidateIsolines enum value (defined in AcGsModel) | AcGsModel |
kInvalidateLayers enum value (defined in AcGsModel) | AcGsModel |
kInvalidateLinetypes enum value (defined in AcGsModel) | AcGsModel |
kInvalidateMaterials enum value (defined in AcGsModel) | AcGsModel |
kInvalidateNone enum value (defined in AcGsModel) | AcGsModel |
kInvalidateViewportCache enum value (defined in AcGsModel) | AcGsModel |
kMain enum value (defined in AcGsModel) | AcGsModel |
kSprite enum value (defined in AcGsModel) | AcGsModel |
linetypesEnabled(void) const =0 (defined in AcGsModel) | AcGsModel | pure virtual
onAdded(AcGiDrawable *pAdded, AcGiDrawable *pParent)=0 (defined in AcGsModel) | AcGsModel | pure virtual
onAdded(AcGiDrawable *pAdded, LONG_PTR parentID)=0 (defined in AcGsModel) | AcGsModel | pure virtual
onErased(AcGiDrawable *pErased, AcGiDrawable *pParent)=0 (defined in AcGsModel) | AcGsModel | pure virtual
onErased(AcGiDrawable *pErased, LONG_PTR parentID)=0 (defined in AcGsModel) | AcGsModel | pure virtual
onModified(AcGiDrawable *pModified, AcGiDrawable *pParent)=0 (defined in AcGsModel) | AcGsModel | pure virtual
onModified(AcGiDrawable *pModified, LONG_PTR parentID)=0 (defined in AcGsModel) | AcGsModel | pure virtual
onPaletteModified(void)=0 (defined in AcGsModel) | AcGsModel | pure virtual
RenderType enum name (defined in AcGsModel) | AcGsModel |
renderType(void)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setBackground(const AcDbObjectId backgroundId)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setEnableSectioning(bool enable)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setExtents(const AcGePoint3d &, const AcGePoint3d &)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setRenderModeOverride(AcGsView::RenderMode mode=AcGsView::kNone)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setSectioning(const AcGePoint3dArray &pts, const AcGeVector3d &upVector)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setSectioning(const AcGePoint3dArray &pts, const AcGeVector3d &upVector, double top, double bottom)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setSectioningVisualStyle(const AcDbObjectId visualStyleId)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setShadowPlaneLocation(double planeLocationZ)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setTransform(const AcGeMatrix3d &)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setViewClippingOverride(bool bOverride)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setVisualStyle(const AcDbObjectId visualStyleId)=0 (defined in AcGsModel) | AcGsModel | pure virtual
setVisualStyle(const AcGiVisualStyle &visualStyle)=0 (defined in AcGsModel) | AcGsModel | pure virtual
shadowPlaneLocation(void) const =0 (defined in AcGsModel) | AcGsModel | pure virtual
transform(void) const =0 (defined in AcGsModel) | AcGsModel | pure virtual
visualStyle(void) const =0 (defined in AcGsModel) | AcGsModel | pure virtual
visualStyle(AcGiVisualStyle &visualStyle) const =0 (defined in AcGsModel) | AcGsModel | pure virtual
~AcGsModel(void) (defined in AcGsModel) | AcGsModel | inlinevirtual


ZRX API Reference: AcGsNode Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGsNode Class Reference

Public Member Functions

virtual AcGiDrawable * | drawable (void) const =0
virtual void | setDrawableNull (void)=0
The documentation for this class was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsNode Member List

This is the complete list of members for AcGsNode, including all inherited members.

drawable(void) const =0 (defined in AcGsNode) | AcGsNode | pure virtual
setDrawableNull(void)=0 (defined in AcGsNode) | AcGsNode | pure virtual


ZRX API Reference: AcGsReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcGsReactor Class Reference

Public Member Functions

virtual void | configWasModified (void)
virtual void | gsToBeUnloaded (AcGsClassFactory *pClassFactory)
virtual void | viewToBeDestroyed (AcGsView *pView)
virtual void | viewWasCreated (AcGsView *pView)
The documentation for this class was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsReactor Member List

This is the complete list of members for AcGsReactor, including all inherited members.

AcGsReactor(void) (defined in AcGsReactor) | AcGsReactor | inline
configWasModified(void) (defined in AcGsReactor) | AcGsReactor | inlinevirtual
gsToBeUnloaded(AcGsClassFactory *pClassFactory) (defined in AcGsReactor) | AcGsReactor | inlinevirtual
viewToBeDestroyed(AcGsView *pView) (defined in AcGsReactor) | AcGsReactor | inlinevirtual
viewWasCreated(AcGsView *pView) (defined in AcGsReactor) | AcGsReactor | inlinevirtual
~AcGsReactor(void) (defined in AcGsReactor) | AcGsReactor | inlinevirtual


ZRX API Reference: AcGsView Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | List of all members
AcGsView Class Reference

Public Types

enum | DefaultLightingType { kOneLight, kTwoLights, kBackLight }
enum | Projection { kParallel, kPerspective }
enum RenderMode {
k2DOptimized, kBoundingBox, kWireframe, kHiddenLine,
kFlatShaded, kGouraudShaded, kFlatShadedWithWireframe, kGouraudShadedWithWireframe,
kCount, kNone = kCount
}
enum SelectionMode {
kWindow, kCrossing, kFence, kWPoly,
kCPoly
}

Public Member Functions

virtual bool | add (AcGiDrawable *drawable, AcGsModel *model)=0
virtual double | backClip (void) const =0
virtual AcDbObjectId | background (void) const =0
virtual void | beginInteractivity (double fFrameRateInHz)=0
virtual void | clearFrozenLayers (void)=0
virtual AcGsView * | clone (bool bCloneViewParameters=true, bool bCloneGeometry=false)=0
virtual void | dolly (const AcGeVector3d &vector)=0
virtual void | dolly (double x, double y, double z)=0
virtual void | enableDefaultLighting (bool bEnable, DefaultLightingType type=kTwoLights)=0
virtual void | enableStereo (bool bEnable)=0
virtual void | endInteractivity (void)=0
virtual bool | erase (AcGiDrawable *drawable)=0
virtual void | eraseAll (void)=0
virtual bool | exceededBounds (void)=0
virtual bool | extentsInView (const AcGePoint3d &minPoint, const AcGePoint3d &maxPoint)=0
virtual double | fieldHeight (void) const =0
virtual double | fieldWidth (void) const =0
virtual void | flush (void)=0
virtual void | freezeLayer (LONG_PTR layerID)=0
virtual double | frontClip (void) const =0
virtual AcGsDevice * | getDevice (void) const =0
virtual void | getNumPixelsInUnitSquare (const AcGePoint3d &givenWorldpt, AcGePoint2d &pixelArea, bool includePerspective=true) const =0
virtual void | getSnapShot (Atil::Image *pOutput, AcGsDCPoint const &offset)=0
virtual void | getStereoParameters (double &magnitude, double &parallax) const =0
virtual void | getViewport (AcGePoint2d &lowerLeft, AcGePoint2d &upperRight) const =0
virtual void | getViewport (AcGsDCRect &screen_rect) const =0
virtual void | getViewportBorderProperties (AcGsColor &color, int &weight) const =0
virtual void | hide (void)=0
virtual void | invalidate (void)=0
virtual void | invalidate (const AcGsDCRect &rect)=0
virtual void | invalidateCachedViewportGeometry (void)=0
virtual bool | isBackClipped (void) const =0
virtual bool | isFrontClipped (void) const =0
virtual bool | isPerspective (void) const =0
virtual bool | isStereoEnabled (void) const =0
virtual bool | isValid (void) const =0
virtual bool | isViewportBorderVisible (void) const =0
virtual bool | isVisible (void)=0
virtual int | maximumUpgrade (void)=0
virtual int | minimumDegrade (void)=0
virtual RenderMode | mode (void) const =0
virtual AcGeMatrix3d | objectToDeviceMatrix (void) const =0
virtual void | orbit (double x, double y)=0
virtual void | pan (double x, double y)=0
virtual bool | pointInView (const AcGePoint3d &pnt)=0
virtual AcGePoint3d | position (void) const =0
virtual AcGeMatrix3d | projectionMatrix (void) const =0
virtual void | removeViewportClipRegion (void)=0
virtual bool | RenderToImage (Atil::Image *pOutput, AcGiDrawable *pSettings, void *pProgressMonitor, const AcGsDCRect &rectScreen, bool bReuseScene=false)=0
virtual void | roll (double angle)=0
virtual AcGeMatrix3d | screenMatrix (void) const =0
virtual void | setBackClip (double distance)=0
virtual void | setBackground (const AcDbObjectId backgroundId)=0
virtual void | setEnableBackClip (bool enable)=0
virtual void | setEnableFrontClip (bool enable)=0
virtual void | setFrontClip (double distance)=0
virtual void | setMaximumUpgrade (int step)=0
virtual void | setMinimumDegrade (int step)=0
virtual void | setMode (RenderMode mode)=0
virtual void | setStereoParameters (double magnitude, double parallax)=0
virtual void | setView (const AcGePoint3d &position, const AcGePoint3d &target, const AcGeVector3d &upVector, double fieldWidth, double fieldHeight, Projection projection=kParallel)=0
virtual void | setViewport (const AcGePoint2d &lowerLeft, const AcGePoint2d &upperRight)=0
virtual void | setViewport (const AcGsDCRect &screen_rect)=0
virtual void | setViewportBorderProperties (AcGsColor const &color, int weight)=0
virtual void | setViewportBorderVisibility (bool bVisible)=0
virtual void | setViewportClipRegion (int contours, int const *counts, AcGsDCPoint const *points)=0
virtual void | setVisualStyle (const AcDbObjectId visualStyleId)=0
virtual void | setVisualStyle (const AcGiVisualStyle &visualStyle)=0
virtual void | show (void)=0
virtual AcGePoint3d | target (void) const =0
virtual void | thawLayer (LONG_PTR layerID)=0
virtual void | update (void)=0
virtual AcGeVector3d | upVector (void) const =0
virtual AcGeMatrix3d | viewingMatrix (void) const =0
virtual AcDbObjectId | visualStyle (void) const =0
virtual bool | visualStyle (AcGiVisualStyle &visualStyle) const =0
virtual AcGeMatrix3d | worldToDeviceMatrix (void) const =0
virtual void | zoom (double factor)=0
virtual void | zoomExtents (const AcGePoint3d &minPoint, const AcGePoint3d &maxPoint)=0
virtual void | zoomWindow (const AcGePoint2d &lowerLeft, const AcGePoint2d &upperRight)=0
The documentation for this class was generated from the following file:
  • gs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGsView Member List

This is the complete list of members for AcGsView, including all inherited members.

add(AcGiDrawable *drawable, AcGsModel *model)=0 (defined in AcGsView) | AcGsView | pure virtual
backClip(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
background(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
beginInteractivity(double fFrameRateInHz)=0 (defined in AcGsView) | AcGsView | pure virtual
clearFrozenLayers(void)=0 (defined in AcGsView) | AcGsView | pure virtual
clone(bool bCloneViewParameters=true, bool bCloneGeometry=false)=0 (defined in AcGsView) | AcGsView | pure virtual
DefaultLightingType enum name (defined in AcGsView) | AcGsView |
dolly(const AcGeVector3d &vector)=0 (defined in AcGsView) | AcGsView | pure virtual
dolly(double x, double y, double z)=0 (defined in AcGsView) | AcGsView | pure virtual
enableDefaultLighting(bool bEnable, DefaultLightingType type=kTwoLights)=0 (defined in AcGsView) | AcGsView | pure virtual
enableStereo(bool bEnable)=0 (defined in AcGsView) | AcGsView | pure virtual
endInteractivity(void)=0 (defined in AcGsView) | AcGsView | pure virtual
erase(AcGiDrawable *drawable)=0 (defined in AcGsView) | AcGsView | pure virtual
eraseAll(void)=0 (defined in AcGsView) | AcGsView | pure virtual
exceededBounds(void)=0 (defined in AcGsView) | AcGsView | pure virtual
extentsInView(const AcGePoint3d &minPoint, const AcGePoint3d &maxPoint)=0 (defined in AcGsView) | AcGsView | pure virtual
fieldHeight(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
fieldWidth(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
flush(void)=0 (defined in AcGsView) | AcGsView | pure virtual
freezeLayer(LONG_PTR layerID)=0 (defined in AcGsView) | AcGsView | pure virtual
frontClip(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
getDevice(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
getNumPixelsInUnitSquare(const AcGePoint3d &givenWorldpt, AcGePoint2d &pixelArea, bool includePerspective=true) const =0 (defined in AcGsView) | AcGsView | pure virtual
getSnapShot(Atil::Image *pOutput, AcGsDCPoint const &offset)=0 (defined in AcGsView) | AcGsView | pure virtual
getStereoParameters(double &magnitude, double &parallax) const =0 (defined in AcGsView) | AcGsView | pure virtual
getViewport(AcGePoint2d &lowerLeft, AcGePoint2d &upperRight) const =0 (defined in AcGsView) | AcGsView | pure virtual
getViewport(AcGsDCRect &screen_rect) const =0 (defined in AcGsView) | AcGsView | pure virtual
getViewportBorderProperties(AcGsColor &color, int &weight) const =0 (defined in AcGsView) | AcGsView | pure virtual
hide(void)=0 (defined in AcGsView) | AcGsView | pure virtual
invalidate(void)=0 (defined in AcGsView) | AcGsView | pure virtual
invalidate(const AcGsDCRect &rect)=0 (defined in AcGsView) | AcGsView | pure virtual
invalidateCachedViewportGeometry(void)=0 (defined in AcGsView) | AcGsView | pure virtual
isBackClipped(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
isFrontClipped(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
isPerspective(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
isStereoEnabled(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
isValid(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
isViewportBorderVisible(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
isVisible(void)=0 (defined in AcGsView) | AcGsView | pure virtual
k2DOptimized enum value (defined in AcGsView) | AcGsView |
kBackLight enum value (defined in AcGsView) | AcGsView |
kBoundingBox enum value (defined in AcGsView) | AcGsView |
kCount enum value (defined in AcGsView) | AcGsView |
kCPoly enum value (defined in AcGsView) | AcGsView |
kCrossing enum value (defined in AcGsView) | AcGsView |
kFence enum value (defined in AcGsView) | AcGsView |
kFlatShaded enum value (defined in AcGsView) | AcGsView |
kFlatShadedWithWireframe enum value (defined in AcGsView) | AcGsView |
kGouraudShaded enum value (defined in AcGsView) | AcGsView |
kGouraudShadedWithWireframe enum value (defined in AcGsView) | AcGsView |
kHiddenLine enum value (defined in AcGsView) | AcGsView |
kNone enum value (defined in AcGsView) | AcGsView |
kOneLight enum value (defined in AcGsView) | AcGsView |
kParallel enum value (defined in AcGsView) | AcGsView |
kPerspective enum value (defined in AcGsView) | AcGsView |
kTwoLights enum value (defined in AcGsView) | AcGsView |
kWindow enum value (defined in AcGsView) | AcGsView |
kWireframe enum value (defined in AcGsView) | AcGsView |
kWPoly enum value (defined in AcGsView) | AcGsView |
maximumUpgrade(void)=0 (defined in AcGsView) | AcGsView | pure virtual
minimumDegrade(void)=0 (defined in AcGsView) | AcGsView | pure virtual
mode(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
objectToDeviceMatrix(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
orbit(double x, double y)=0 (defined in AcGsView) | AcGsView | pure virtual
pan(double x, double y)=0 (defined in AcGsView) | AcGsView | pure virtual
pointInView(const AcGePoint3d &pnt)=0 (defined in AcGsView) | AcGsView | pure virtual
position(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
Projection enum name (defined in AcGsView) | AcGsView |
projectionMatrix(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
removeViewportClipRegion(void)=0 (defined in AcGsView) | AcGsView | pure virtual
RenderMode enum name (defined in AcGsView) | AcGsView |
RenderToImage(Atil::Image *pOutput, AcGiDrawable *pSettings, void *pProgressMonitor, const AcGsDCRect &rectScreen, bool bReuseScene=false)=0 (defined in AcGsView) | AcGsView | pure virtual
roll(double angle)=0 (defined in AcGsView) | AcGsView | pure virtual
screenMatrix(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
SelectionMode enum name (defined in AcGsView) | AcGsView |
setBackClip(double distance)=0 (defined in AcGsView) | AcGsView | pure virtual
setBackground(const AcDbObjectId backgroundId)=0 (defined in AcGsView) | AcGsView | pure virtual
setEnableBackClip(bool enable)=0 (defined in AcGsView) | AcGsView | pure virtual
setEnableFrontClip(bool enable)=0 (defined in AcGsView) | AcGsView | pure virtual
setFrontClip(double distance)=0 (defined in AcGsView) | AcGsView | pure virtual
setMaximumUpgrade(int step)=0 (defined in AcGsView) | AcGsView | pure virtual
setMinimumDegrade(int step)=0 (defined in AcGsView) | AcGsView | pure virtual
setMode(RenderMode mode)=0 (defined in AcGsView) | AcGsView | pure virtual
setStereoParameters(double magnitude, double parallax)=0 (defined in AcGsView) | AcGsView | pure virtual
setView(const AcGePoint3d &position, const AcGePoint3d &target, const AcGeVector3d &upVector, double fieldWidth, double fieldHeight, Projection projection=kParallel)=0 (defined in AcGsView) | AcGsView | pure virtual
setViewport(const AcGePoint2d &lowerLeft, const AcGePoint2d &upperRight)=0 (defined in AcGsView) | AcGsView | pure virtual
setViewport(const AcGsDCRect &screen_rect)=0 (defined in AcGsView) | AcGsView | pure virtual
setViewportBorderProperties(AcGsColor const &color, int weight)=0 (defined in AcGsView) | AcGsView | pure virtual
setViewportBorderVisibility(bool bVisible)=0 (defined in AcGsView) | AcGsView | pure virtual
setViewportClipRegion(int contours, int const *counts, AcGsDCPoint const *points)=0 (defined in AcGsView) | AcGsView | pure virtual
setVisualStyle(const AcDbObjectId visualStyleId)=0 (defined in AcGsView) | AcGsView | pure virtual
setVisualStyle(const AcGiVisualStyle &visualStyle)=0 (defined in AcGsView) | AcGsView | pure virtual
show(void)=0 (defined in AcGsView) | AcGsView | pure virtual
target(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
thawLayer(LONG_PTR layerID)=0 (defined in AcGsView) | AcGsView | pure virtual
update(void)=0 (defined in AcGsView) | AcGsView | pure virtual
upVector(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
viewingMatrix(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
visualStyle(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
visualStyle(AcGiVisualStyle &visualStyle) const =0 (defined in AcGsView) | AcGsView | pure virtual
worldToDeviceMatrix(void) const =0 (defined in AcGsView) | AcGsView | pure virtual
zoom(double factor)=0 (defined in AcGsView) | AcGsView | pure virtual
zoomExtents(const AcGePoint3d &minPoint, const AcGePoint3d &maxPoint)=0 (defined in AcGsView) | AcGsView | pure virtual
zoomWindow(const AcGePoint2d &lowerLeft, const AcGePoint2d &upperRight)=0 (defined in AcGsView) | AcGsView | pure virtual
~AcGsView(void) (defined in AcGsView) | AcGsView | inlinevirtual


ZRX API Reference: AcNameValuePair Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcNameValuePair Class Reference

Public Member Functions

AcNameValuePair (const ACHAR *name, const ACHAR *value)
AcNameValuePair (const AcNameValuePair &src)
const ACHAR * | name () const
AcNameValuePair & | operator= (const AcNameValuePair &src)
void | setName (const ACHAR *name)
void | setValue (const ACHAR *value)
const ACHAR * | value () const
The documentation for this class was generated from the following file:
  • AcPublishReactors.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcNameValuePair Member List

This is the complete list of members for AcNameValuePair, including all inherited members.

AcNameValuePair() (defined in AcNameValuePair) | AcNameValuePair | inline
AcNameValuePair(const ACHAR *name, const ACHAR *value) (defined in AcNameValuePair) | AcNameValuePair | inline
AcNameValuePair(const AcNameValuePair &src) (defined in AcNameValuePair) | AcNameValuePair | inline
name() const (defined in AcNameValuePair) | AcNameValuePair | inline
operator=(const AcNameValuePair &src) (defined in AcNameValuePair) | AcNameValuePair | inline
setName(const ACHAR *name) (defined in AcNameValuePair) | AcNameValuePair | inline
setValue(const ACHAR *value) (defined in AcNameValuePair) | AcNameValuePair | inline
value() const (defined in AcNameValuePair) | AcNameValuePair | inline
~AcNameValuePair() (defined in AcNameValuePair) | AcNameValuePair | inline


ZRX API Reference: AcPublishAggregationInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPublishAggregationInfo Class Reference

Public Member Functions

virtual void | AddGlobalProperties (AcDMMEPlotPropertyVec props)=0
virtual void | AddGlobalResources (AcDMMResourceVec resources)=0
virtual const ACHAR * | dwfFileName ()=0
virtual const ACHAR * | dwfPassword ()=0
virtual AcPlPlotLogger * | GetPlotLogger ()=0
The documentation for this class was generated from the following file:
  • AcPublishReactors.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPublishAggregationInfo Member List

This is the complete list of members for AcPublishAggregationInfo, including all inherited members.

AcPublishAggregationInfo() (defined in AcPublishAggregationInfo) | AcPublishAggregationInfo | inline
AddGlobalProperties(AcDMMEPlotPropertyVec props)=0 (defined in AcPublishAggregationInfo) | AcPublishAggregationInfo | pure virtual
AddGlobalResources(AcDMMResourceVec resources)=0 (defined in AcPublishAggregationInfo) | AcPublishAggregationInfo | pure virtual
dwfFileName()=0 (defined in AcPublishAggregationInfo) | AcPublishAggregationInfo | pure virtual
dwfPassword()=0 (defined in AcPublishAggregationInfo) | AcPublishAggregationInfo | pure virtual
GetPlotLogger()=0 (defined in AcPublishAggregationInfo) | AcPublishAggregationInfo | pure virtual
~AcPublishAggregationInfo() (defined in AcPublishAggregationInfo) | AcPublishAggregationInfo | inlinevirtual


ZRX API Reference: AcPublishBeforeJobInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPublishBeforeJobInfo Class Reference

Public Member Functions

virtual const AcPlDSDData * | GetDSDData ()=0
virtual const AcNameValuePairVec | GetPrivateData (const ACHAR *sectionName)=0
virtual bool | JobWillPublishInBackground ()=0
virtual bool | WritePrivateSection (const ACHAR *sectionName, const AcNameValuePairVec nameValuePairVec)=0
The documentation for this class was generated from the following file:
  • AcPublishReactors.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPublishBeforeJobInfo Member List

This is the complete list of members for AcPublishBeforeJobInfo, including all inherited members.

AcPublishBeforeJobInfo() (defined in AcPublishBeforeJobInfo) | AcPublishBeforeJobInfo | inline
GetDSDData()=0 (defined in AcPublishBeforeJobInfo) | AcPublishBeforeJobInfo | pure virtual
GetPrivateData(const ACHAR *sectionName)=0 (defined in AcPublishBeforeJobInfo) | AcPublishBeforeJobInfo | pure virtual
JobWillPublishInBackground()=0 (defined in AcPublishBeforeJobInfo) | AcPublishBeforeJobInfo | pure virtual
WritePrivateSection(const ACHAR *sectionName, const AcNameValuePairVec nameValuePairVec)=0 (defined in AcPublishBeforeJobInfo) | AcPublishBeforeJobInfo | pure virtual
~AcPublishBeforeJobInfo() (defined in AcPublishBeforeJobInfo) | AcPublishBeforeJobInfo | inlinevirtual


ZRX API Reference: AcPublishBeginJobInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPublishBeginJobInfo Class Reference

Public Member Functions

virtual const AcPlDSDData * | GetDSDData ()=0
virtual AcPlPlotLogger * | GetPlotLogger ()=0
virtual const AcNameValuePairVec | GetPrivateData (const ACHAR *sectionName)=0
virtual bool | JobWillPublishInBackground ()=0
virtual bool | WritePrivateSection (const ACHAR *sectionName, const AcNameValuePairVec nameValuePairVec)=0
The documentation for this class was generated from the following file:
  • AcPublishReactors.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPublishBeginJobInfo Member List

This is the complete list of members for AcPublishBeginJobInfo, including all inherited members.

AcPublishBeginJobInfo() (defined in AcPublishBeginJobInfo) | AcPublishBeginJobInfo | inline
GetDSDData()=0 (defined in AcPublishBeginJobInfo) | AcPublishBeginJobInfo | pure virtual
GetPlotLogger()=0 (defined in AcPublishBeginJobInfo) | AcPublishBeginJobInfo | pure virtual
GetPrivateData(const ACHAR *sectionName)=0 (defined in AcPublishBeginJobInfo) | AcPublishBeginJobInfo | pure virtual
JobWillPublishInBackground()=0 (defined in AcPublishBeginJobInfo) | AcPublishBeginJobInfo | pure virtual
WritePrivateSection(const ACHAR *sectionName, const AcNameValuePairVec nameValuePairVec)=0 (defined in AcPublishBeginJobInfo) | AcPublishBeginJobInfo | pure virtual
~AcPublishBeginJobInfo() (defined in AcPublishBeginJobInfo) | AcPublishBeginJobInfo | inlinevirtual


ZRX API Reference: AcPublishReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPublishReactor Class Reference
+ Inheritance diagram for AcPublishReactor:

Public Member Functions

virtual void | OnAboutToBeginBackgroundPublishing (AcPublishBeforeJobInfo *pInfo)
virtual void | OnAboutToBeginPublishing (AcPublishBeginJobInfo *pInfo)
virtual void | OnAboutToEndPublishing (AcPublishReactorInfo *pInfo)
virtual void | OnAboutToMoveFile (AcPublishReactorInfo *pInfo)
virtual void | OnBeginAggregation (AcPublishAggregationInfo *pInfo)
virtual void | OnBeginPublishingSheet (AcPublishSheetInfo *pInfo)
virtual void | OnCancelledOrFailedPublishing (AcPublishReactorInfo *pInfo)
virtual void | OnEndPublish (AcPublishReactorInfo *pInfo)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • AcPublishReactors.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPublishReactor Member List

This is the complete list of members for AcPublishReactor, including all inherited members.

AcPublishReactor() (defined in AcPublishReactor) | AcPublishReactor | inlineprotected
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
OnAboutToBeginBackgroundPublishing(AcPublishBeforeJobInfo *pInfo) (defined in AcPublishReactor) | AcPublishReactor | inlinevirtual
OnAboutToBeginPublishing(AcPublishBeginJobInfo *pInfo) (defined in AcPublishReactor) | AcPublishReactor | inlinevirtual
OnAboutToEndPublishing(AcPublishReactorInfo *pInfo) (defined in AcPublishReactor) | AcPublishReactor | inlinevirtual
OnAboutToMoveFile(AcPublishReactorInfo *pInfo) (defined in AcPublishReactor) | AcPublishReactor | inlinevirtual
OnBeginAggregation(AcPublishAggregationInfo *pInfo) (defined in AcPublishReactor) | AcPublishReactor | inlinevirtual
OnBeginPublishingSheet(AcPublishSheetInfo *pInfo) (defined in AcPublishReactor) | AcPublishReactor | inlinevirtual
OnCancelledOrFailedPublishing(AcPublishReactorInfo *pInfo) (defined in AcPublishReactor) | AcPublishReactor | inlinevirtual
OnEndPublish(AcPublishReactorInfo *pInfo) (defined in AcPublishReactor) | AcPublishReactor | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPublishReactor() (defined in AcPublishReactor) | AcPublishReactor | inlinevirtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPublishReactorInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPublishReactorInfo Class Reference

Public Member Functions

virtual const ACHAR * | dwfFileName ()=0
virtual const ACHAR * | dwfPassword ()=0
virtual bool | isMultiSheetDwf ()=0
virtual const ACHAR * | tempDwfFileName ()=0
The documentation for this class was generated from the following file:
  • AcPublishReactors.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPublishReactorInfo Member List

This is the complete list of members for AcPublishReactorInfo, including all inherited members.

AcPublishReactorInfo() (defined in AcPublishReactorInfo) | AcPublishReactorInfo | inline
dwfFileName()=0 (defined in AcPublishReactorInfo) | AcPublishReactorInfo | pure virtual
dwfPassword()=0 (defined in AcPublishReactorInfo) | AcPublishReactorInfo | pure virtual
isMultiSheetDwf()=0 (defined in AcPublishReactorInfo) | AcPublishReactorInfo | pure virtual
tempDwfFileName()=0 (defined in AcPublishReactorInfo) | AcPublishReactorInfo | pure virtual
~AcPublishReactorInfo() (defined in AcPublishReactorInfo) | AcPublishReactorInfo | inlinevirtual


ZRX API Reference: AcPublishSheetInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPublishSheetInfo Class Reference

Public Member Functions

virtual const AcPlDSDEntry * | GetDSDEntry ()=0
virtual AcPlPlotLogger * | GetPlotLogger ()=0
virtual const ACHAR * | GetUniqueId ()=0
The documentation for this class was generated from the following file:
  • AcPublishReactors.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPublishSheetInfo Member List

This is the complete list of members for AcPublishSheetInfo, including all inherited members.

AcPublishSheetInfo() (defined in AcPublishSheetInfo) | AcPublishSheetInfo | inline
GetDSDEntry()=0 (defined in AcPublishSheetInfo) | AcPublishSheetInfo | pure virtual
GetPlotLogger()=0 (defined in AcPublishSheetInfo) | AcPublishSheetInfo | pure virtual
GetUniqueId()=0 (defined in AcPublishSheetInfo) | AcPublishSheetInfo | pure virtual
~AcPublishSheetInfo() (defined in AcPublishSheetInfo) | AcPublishSheetInfo | inlinevirtual


ZRX API Reference: AcPublishUIReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPublishUIReactor Class Reference
+ Inheritance diagram for AcPublishUIReactor:

Public Member Functions

virtual void | OnInitPublishOptionsDialog (IUnknown **pUnk, AcPublishUIReactorInfo *pInfo)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • acpublishuireactors.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPublishUIReactor Member List

This is the complete list of members for AcPublishUIReactor, including all inherited members.

AcPublishUIReactor() (defined in AcPublishUIReactor) | AcPublishUIReactor | inlineprotected
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
OnInitPublishOptionsDialog(IUnknown **pUnk, AcPublishUIReactorInfo *pInfo) (defined in AcPublishUIReactor) | AcPublishUIReactor | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcPublishUIReactor() (defined in AcPublishUIReactor) | AcPublishUIReactor | inlinevirtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcPublishUIReactorInfo Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcPublishUIReactorInfo Class Reference

Public Member Functions

virtual const AcPlDSDData * | GetDSDData ()=0
virtual const AcNameValuePairVec | GetPrivateData (const ACHAR *sectionName)=0
virtual bool | JobWillPublishInBackground ()=0
virtual bool | WritePrivateSection (const ACHAR *sectionName, const AcNameValuePairVec nameValuePairVec)=0
The documentation for this class was generated from the following file:
  • acpublishuireactors.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcPublishUIReactorInfo Member List

This is the complete list of members for AcPublishUIReactorInfo, including all inherited members.

AcPublishUIReactorInfo() (defined in AcPublishUIReactorInfo) | AcPublishUIReactorInfo | inline
GetDSDData()=0 (defined in AcPublishUIReactorInfo) | AcPublishUIReactorInfo | pure virtual
GetPrivateData(const ACHAR *sectionName)=0 (defined in AcPublishUIReactorInfo) | AcPublishUIReactorInfo | pure virtual
JobWillPublishInBackground()=0 (defined in AcPublishUIReactorInfo) | AcPublishUIReactorInfo | pure virtual
WritePrivateSection(const ACHAR *sectionName, const AcNameValuePairVec nameValuePairVec)=0 (defined in AcPublishUIReactorInfo) | AcPublishUIReactorInfo | pure virtual
~AcPublishUIReactorInfo() (defined in AcPublishUIReactorInfo) | AcPublishUIReactorInfo | inlinevirtual


ZRX API Reference: AcRx Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | List of all members
AcRx Struct Reference

Public Types

enum AppMsgCode {
kNullMsg = 0, kInitAppMsg = 1, kUnloadAppMsg = 2, kLoadDwgMsg = 3,
kUnloadDwgMsg = 4, kInvkSubrMsg = 5, kCfgMsg = 6, kEndMsg = 7,
kQuitMsg = 8, kSaveMsg = 9, kDependencyMsg = 10, kNoDependencyMsg = 11,
kOleUnloadAppMsg = 12, kPreQuitMsg = 13, kInitDialogMsg = 14, kEndDialogMsg = 15,
kSuspendMsg = 16
}
enum | AppRetCode { kRetOK = 0, kRetError = 3 }
enum | DictIterType { kDictSorted = 0, kDictCollated = 1 }
typedef void(* | FcnPtr )()
enum | Ordering { kLessThan = -1, kEqual = 0, kGreaterThan = 1, kNotOrderable = 2 }
The documentation for this struct was generated from the following file:
  • rxdefs.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRx Member List

This is the complete list of members for AcRx, including all inherited members.

AppMsgCode enum name (defined in AcRx) | AcRx
AppRetCode enum name (defined in AcRx) | AcRx
DictIterType enum name (defined in AcRx) | AcRx
FcnPtr typedef (defined in AcRx) | AcRx
kCfgMsg enum value (defined in AcRx) | AcRx
kDependencyMsg enum value (defined in AcRx) | AcRx
kDictCollated enum value (defined in AcRx) | AcRx
kDictSorted enum value (defined in AcRx) | AcRx
kEndDialogMsg enum value (defined in AcRx) | AcRx
kEndMsg enum value (defined in AcRx) | AcRx
kEqual enum value (defined in AcRx) | AcRx
kGreaterThan enum value (defined in AcRx) | AcRx
kInitAppMsg enum value (defined in AcRx) | AcRx
kInitDialogMsg enum value (defined in AcRx) | AcRx
kInvkSubrMsg enum value (defined in AcRx) | AcRx
kLessThan enum value (defined in AcRx) | AcRx
kLoadDwgMsg enum value (defined in AcRx) | AcRx
kNoDependencyMsg enum value (defined in AcRx) | AcRx
kNotOrderable enum value (defined in AcRx) | AcRx
kNullMsg enum value (defined in AcRx) | AcRx
kOleUnloadAppMsg enum value (defined in AcRx) | AcRx
kPreQuitMsg enum value (defined in AcRx) | AcRx
kQuitMsg enum value (defined in AcRx) | AcRx
kRetError enum value (defined in AcRx) | AcRx
kRetOK enum value (defined in AcRx) | AcRx
kSaveMsg enum value (defined in AcRx) | AcRx
kSuspendMsg enum value (defined in AcRx) | AcRx
kUnloadAppMsg enum value (defined in AcRx) | AcRx
kUnloadDwgMsg enum value (defined in AcRx) | AcRx
Ordering enum name (defined in AcRx) | AcRx


ZRX API Reference: AcRxDictionary Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxDictionary Class Reference
+ Inheritance diagram for AcRxDictionary:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxDictionary)
virtual AcRxObject * | at (const ACHAR *key) const =0
virtual AcRxObject * | at (Adesk::UInt32 id) const =0
virtual Adesk::Boolean | atKeyAndIdPut (const ACHAR *newKey, Adesk::UInt32 id, AcRxObject *pObject)=0
AcRxObject * | atPut (const ACHAR *key, AcRxObject *pObject)
virtual AcRxObject * | atPut (const ACHAR *key, AcRxObject *pObject, Adesk::UInt32 &retId)=0
virtual AcRxObject * | atPut (Adesk::UInt32 id, AcRxObject *pObject)=0
virtual Adesk::Boolean | deletesObjects () const =0
virtual Adesk::Boolean | has (const ACHAR *entryName) const =0
virtual Adesk::Boolean | has (Adesk::UInt32 id) const =0
virtual Adesk::UInt32 | idAt (const ACHAR *key) const =0
virtual Adesk::Boolean | isCaseSensitive () const =0
virtual Adesk::Boolean | isSorted () const =0
virtual const ACHAR * | keyAt (Adesk::UInt32 id) const =0
virtual AcRxDictionaryIterator * | newIterator (AcRx::DictIterType type=AcRx::kDictSorted)=0
virtual Adesk::UInt32 | numEntries () const =0
virtual AcRxObject * | remove (const ACHAR *key)=0
virtual AcRxObject * | remove (Adesk::UInt32 id)=0
virtual Adesk::Boolean | resetKey (const ACHAR *oldKey, const ACHAR *newKey)=0
virtual Adesk::Boolean | resetKey (Adesk::UInt32 id, const ACHAR *newKey)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxdict.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxDictionary Member List

This is the complete list of members for AcRxDictionary, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxDictionary) (defined in AcRxDictionary) | AcRxDictionary |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
at(const ACHAR *key) const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
at(Adesk::UInt32 id) const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
atKeyAndIdPut(const ACHAR *newKey, Adesk::UInt32 id, AcRxObject *pObject)=0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
atPut(const ACHAR *key, AcRxObject *pObject) (defined in AcRxDictionary) | AcRxDictionary | inline
atPut(const ACHAR *key, AcRxObject *pObject, Adesk::UInt32 &retId)=0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
atPut(Adesk::UInt32 id, AcRxObject *pObject)=0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
deletesObjects() const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
has(const ACHAR *entryName) const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
has(Adesk::UInt32 id) const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
idAt(const ACHAR *key) const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isCaseSensitive() const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isSorted() const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
keyAt(Adesk::UInt32 id) const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
newIterator(AcRx::DictIterType type=AcRx::kDictSorted)=0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
numEntries() const =0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
remove(const ACHAR *key)=0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
remove(Adesk::UInt32 id)=0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
resetKey(const ACHAR *oldKey, const ACHAR *newKey)=0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
resetKey(Adesk::UInt32 id, const ACHAR *newKey)=0 (defined in AcRxDictionary) | AcRxDictionary | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxDictionaryIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxDictionaryIterator Class Reference
+ Inheritance diagram for AcRxDictionaryIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxDictionaryIterator)
virtual Adesk::UInt32 | id () const =0
virtual const ACHAR * | key () const =0
virtual AcRxObject * | object () const =0
- Public Member Functions inherited from AcRxIterator
ACRX_DECLARE_MEMBERS (AcRxIterator)
virtual Adesk::Boolean | done () const =0
virtual Adesk::Boolean | next ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxditer.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxDictionaryIterator Member List

This is the complete list of members for AcRxDictionaryIterator, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxDictionaryIterator) (defined in AcRxDictionaryIterator) | AcRxDictionaryIterator |
ACRX_DECLARE_MEMBERS(AcRxIterator) (defined in AcRxIterator) | AcRxIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const =0 (defined in AcRxIterator) | AcRxIterator | pure virtual
id() const =0 (defined in AcRxDictionaryIterator) | AcRxDictionaryIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
key() const =0 (defined in AcRxDictionaryIterator) | AcRxDictionaryIterator | pure virtual
next()=0 (defined in AcRxIterator) | AcRxIterator | pure virtual
object() const =0 (defined in AcRxDictionaryIterator) | AcRxDictionaryIterator | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxDLinkerReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxDLinkerReactor Class Reference
+ Inheritance diagram for AcRxDLinkerReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxDLinkerReactor)
virtual void | rxAppLoadAborted (const ACHAR *moduleName)
virtual void | rxAppLoaded (const ACHAR *moduleName)
virtual void | rxAppUnloadAborted (const ACHAR *moduleName)
virtual void | rxAppUnloaded (const ACHAR *moduleName)
virtual void | rxAppWillBeLoaded (const ACHAR *moduleName)
virtual void | rxAppWillBeUnloaded (const ACHAR *moduleName)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxdlinkr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxDLinkerReactor Member List

This is the complete list of members for AcRxDLinkerReactor, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxDLinkerReactor) (defined in AcRxDLinkerReactor) | AcRxDLinkerReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rxAppLoadAborted(const ACHAR *moduleName) (defined in AcRxDLinkerReactor) | AcRxDLinkerReactor | virtual
rxAppLoaded(const ACHAR *moduleName) (defined in AcRxDLinkerReactor) | AcRxDLinkerReactor | virtual
rxAppUnloadAborted(const ACHAR *moduleName) (defined in AcRxDLinkerReactor) | AcRxDLinkerReactor | virtual
rxAppUnloaded(const ACHAR *moduleName) (defined in AcRxDLinkerReactor) | AcRxDLinkerReactor | virtual
rxAppWillBeLoaded(const ACHAR *moduleName) (defined in AcRxDLinkerReactor) | AcRxDLinkerReactor | virtual
rxAppWillBeUnloaded(const ACHAR *moduleName) (defined in AcRxDLinkerReactor) | AcRxDLinkerReactor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxDynamicLinker Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxDynamicLinker Class Reference
+ Inheritance diagram for AcRxDynamicLinker:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxDynamicLinker)
virtual void | addReactor (AcRxDLinkerReactor *newReactor)=0
virtual void * | getSymbolAddress (const ACHAR *serviceName, const char *symbol) const =0
virtual bool | initListedModules (const ACHAR *fileName)=0
virtual bool | isAppBusy (const ACHAR *modulename) const =0
virtual bool | isApplicationLocked (const ACHAR *modulename) const =0
virtual bool | isAppMDIAware (const ACHAR *modulename) const =0
virtual bool | loadApp (const ACHAR *appName, AcadApp::LoadReasons al, bool printit, bool asCmd=false)=0
virtual bool | loadModule (const ACHAR *fileName, bool printit, bool asCmd=false)=0
virtual bool | lockApplication (void *appId) const =0
virtual const ACHAR * | ProductKey () const =0
virtual Adesk::UInt32 | ProductLcid () const =0
virtual bool | registerAppMDIAware (void *appId) const =0
virtual bool | registerAppNotMDIAware (void *appId) const =0
virtual AcRxObject * | registerService (const ACHAR *serviceName, AcRxService *serviceObj)=0
virtual void | removeReactor (AcRxDLinkerReactor *oldReactor)=0
virtual void | setAppBusy (const ACHAR *modulename, bool bBusyFlag) const =0
virtual bool | unloadApp (const ACHAR *appName, bool asCmd=false)=0
virtual bool | unloadModule (const ACHAR *fileName, bool asCmd=false)=0
virtual bool | unlockApplication (void *appId) const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxdlinkr.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxDynamicLinker Member List

This is the complete list of members for AcRxDynamicLinker, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxDynamicLinker) (defined in AcRxDynamicLinker) | AcRxDynamicLinker |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addReactor(AcRxDLinkerReactor *newReactor)=0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
getSymbolAddress(const ACHAR *serviceName, const char *symbol) const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
initListedModules(const ACHAR *fileName)=0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isAppBusy(const ACHAR *modulename) const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
isApplicationLocked(const ACHAR *modulename) const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
isAppMDIAware(const ACHAR *modulename) const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
loadApp(const ACHAR *appName, AcadApp::LoadReasons al, bool printit, bool asCmd=false)=0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
loadModule(const ACHAR *fileName, bool printit, bool asCmd=false)=0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
lockApplication(void *appId) const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
ProductKey() const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
ProductLcid() const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
registerAppMDIAware(void *appId) const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
registerAppNotMDIAware(void *appId) const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
registerService(const ACHAR *serviceName, AcRxService *serviceObj)=0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
removeReactor(AcRxDLinkerReactor *oldReactor)=0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
setAppBusy(const ACHAR *modulename, bool bBusyFlag) const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
unloadApp(const ACHAR *appName, bool asCmd=false)=0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
unloadModule(const ACHAR *fileName, bool asCmd=false)=0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
unlockApplication(void *appId) const =0 (defined in AcRxDynamicLinker) | AcRxDynamicLinker | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxEvent Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxEvent Class Reference
+ Inheritance diagram for AcRxEvent:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxEvent)
virtual void | addReactor (AcRxEventReactor *newObj)=0
virtual void | removeReactor (AcRxEventReactor *delObj)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxevent.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxEvent Member List

This is the complete list of members for AcRxEvent, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxEvent) (defined in AcRxEvent) | AcRxEvent |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addReactor(AcRxEventReactor *newObj)=0 (defined in AcRxEvent) | AcRxEvent | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeReactor(AcRxEventReactor *delObj)=0 (defined in AcRxEvent) | AcRxEvent | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxEventReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxEventReactor Class Reference
+ Inheritance diagram for AcRxEventReactor:

Public Member Functions

virtual void | abortAttach (AcDbDatabase *pFrom)
virtual void | abortDeepClone (AcDbIdMapping &)
virtual void | abortDxfIn (AcDbDatabase *)
virtual void | abortDxfOut (AcDbDatabase *)
virtual void | abortInsert (AcDbDatabase *pTo)
virtual void | abortRestore (AcDbDatabase *pTo)
virtual void | abortSave (AcDbDatabase *)
virtual void | abortWblock (AcDbDatabase *pTo)
ACRX_DECLARE_MEMBERS (AcRxEventReactor)
virtual void | beginAttach (AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom)
virtual void | beginDeepClone (AcDbDatabase *pTo, AcDbIdMapping &)
virtual void | beginDeepCloneXlation (AcDbIdMapping &, Acad::ErrorStatus *)
virtual void | beginDxfIn (AcDbDatabase *)
virtual void | beginDxfOut (AcDbDatabase *)
virtual void | beginInsert (AcDbDatabase *pTo, const ACHAR *pBlockName, AcDbDatabase *pFrom)
virtual void | beginInsert (AcDbDatabase *pTo, const AcGeMatrix3d &xform, AcDbDatabase *pFrom)
virtual void | beginRestore (AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom)
virtual void | beginSave (AcDbDatabase *, const ACHAR *pIntendedName)
virtual void | beginWblock (AcDbDatabase *pTo, AcDbDatabase *pFrom, const AcGePoint3d *&insertionPoint)
virtual void | beginWblock (AcDbDatabase *pTo, AcDbDatabase *pFrom, AcDbObjectId blockId)
virtual void | beginWblock (AcDbDatabase *pTo, AcDbDatabase *pFrom)
virtual void | beginWblockObjects (AcDbDatabase *, AcDbIdMapping &)
virtual void | comandeered (AcDbDatabase *pTo, AcDbObjectId id, AcDbDatabase *pFrom)
virtual void | databaseConstructed (AcDbDatabase *)
virtual void | databaseToBeDestroyed (AcDbDatabase *)
virtual void | dwgFileOpened (AcDbDatabase *, ACHAR *fileName)
virtual void | dxfInComplete (AcDbDatabase *)
virtual void | dxfOutComplete (AcDbDatabase *)
virtual void | endAttach (AcDbDatabase *pTo)
virtual void | endDeepClone (AcDbIdMapping &)
virtual void | endInsert (AcDbDatabase *pTo)
virtual void | endRestore (AcDbDatabase *pTo)
virtual void | endWblock (AcDbDatabase *pTo)
virtual void | initialDwgFileOpenComplete (AcDbDatabase *)
virtual void | otherAttach (AcDbDatabase *pTo, AcDbDatabase *pFrom)
virtual void | otherInsert (AcDbDatabase *pTo, AcDbIdMapping &idMap, AcDbDatabase *pFrom)
virtual void | otherWblock (AcDbDatabase *pTo, AcDbIdMapping &, AcDbDatabase *pFrom)
virtual void | partialOpenNotice (AcDbDatabase *pDb)
virtual void | preXrefLockFile (AcDbDatabase *pDb, AcDbObjectId btrId)
virtual void | redirected (AcDbObjectId newId, AcDbObjectId oldId)
virtual void | saveComplete (AcDbDatabase *, const ACHAR *pActualName)
virtual void | wblockNotice (AcDbDatabase *pDb)
virtual void | xrefSubCommandAborted (AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths)
virtual void | xrefSubCommandStart (AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths, bool &vetoOp)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxevent.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxEventReactor Member List

This is the complete list of members for AcRxEventReactor, including all inherited members.

abortAttach(AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
abortDeepClone(AcDbIdMapping &) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
abortDxfIn(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
abortDxfOut(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
abortInsert(AcDbDatabase *pTo) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
abortRestore(AcDbDatabase *pTo) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
abortSave(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
abortWblock(AcDbDatabase *pTo) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
ACRX_DECLARE_MEMBERS(AcRxEventReactor) (defined in AcRxEventReactor) | AcRxEventReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
beginAttach(AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginDeepClone(AcDbDatabase *pTo, AcDbIdMapping &) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginDeepCloneXlation(AcDbIdMapping &, Acad::ErrorStatus *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginDxfIn(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginDxfOut(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginInsert(AcDbDatabase *pTo, const ACHAR *pBlockName, AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginInsert(AcDbDatabase *pTo, const AcGeMatrix3d &xform, AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginRestore(AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginSave(AcDbDatabase *, const ACHAR *pIntendedName) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginWblock(AcDbDatabase *pTo, AcDbDatabase *pFrom, const AcGePoint3d *&insertionPoint) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginWblock(AcDbDatabase *pTo, AcDbDatabase *pFrom, AcDbObjectId blockId) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginWblock(AcDbDatabase *pTo, AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
beginWblockObjects(AcDbDatabase *, AcDbIdMapping &) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comandeered(AcDbDatabase *pTo, AcDbObjectId id, AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
databaseConstructed(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
databaseToBeDestroyed(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
desc() (defined in AcRxObject) | AcRxObject | static
dwgFileOpened(AcDbDatabase *, ACHAR *fileName) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
dxfInComplete(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
dxfOutComplete(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
endAttach(AcDbDatabase *pTo) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
endDeepClone(AcDbIdMapping &) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
endInsert(AcDbDatabase *pTo) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
endRestore(AcDbDatabase *pTo) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
endWblock(AcDbDatabase *pTo) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
initialDwgFileOpenComplete(AcDbDatabase *) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
otherAttach(AcDbDatabase *pTo, AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
otherInsert(AcDbDatabase *pTo, AcDbIdMapping &idMap, AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
otherWblock(AcDbDatabase *pTo, AcDbIdMapping &, AcDbDatabase *pFrom) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
partialOpenNotice(AcDbDatabase *pDb) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
preXrefLockFile(AcDbDatabase *pDb, AcDbObjectId btrId) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
redirected(AcDbObjectId newId, AcDbObjectId oldId) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
saveComplete(AcDbDatabase *, const ACHAR *pActualName) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
wblockNotice(AcDbDatabase *pDb) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xrefSubCommandAborted(AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
xrefSubCommandStart(AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths, bool &vetoOp) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxIterator Class Reference
+ Inheritance diagram for AcRxIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxIterator)
virtual Adesk::Boolean | done () const =0
virtual Adesk::Boolean | next ()=0
virtual AcRxObject * | object () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxiter.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxIterator Member List

This is the complete list of members for AcRxIterator, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxIterator) (defined in AcRxIterator) | AcRxIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const =0 (defined in AcRxIterator) | AcRxIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
next()=0 (defined in AcRxIterator) | AcRxIterator | pure virtual
object() const =0 (defined in AcRxIterator) | AcRxIterator | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxKernel Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxKernel Class Reference
+ Inheritance diagram for AcRxKernel:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxKernel)
virtual AcRxDictionary * | newAcRxDictionary (Adesk::Boolean sorted=Adesk::kTrue, Adesk::Boolean ignoreCase=Adesk::kFalse)=0
virtual AcRxDictionary * | newAcRxDictionary (unsigned long length, Adesk::Boolean delObjects, Adesk::Boolean sorted=Adesk::kTrue, Adesk::Boolean ignoreCase=Adesk::kFalse)=0
virtual AcRxDictionary * | newAcRxDictionary (const AcRxClass *filter)=0
- Public Member Functions inherited from AcRxService
ACRX_DECLARE_MEMBERS (AcRxService)
void | addDependency ()
DepFuncPtr | dependencyFunctionPtr ()
AcRxObject * | getSysInfo () const
void | removeDependency ()
void | setDependencyFunctionPtr (DepFuncPtr)
void | setSysInfo (AcRxObject *sysInfoObj)
Adesk::Boolean | unloadable () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxkernel.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxKernel Member List

This is the complete list of members for AcRxKernel, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxKernel) (defined in AcRxKernel) | AcRxKernel |
ACRX_DECLARE_MEMBERS(AcRxService) (defined in AcRxService) | AcRxService |
AcRxKernel() (defined in AcRxKernel) | AcRxKernel |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
AcRxService() (defined in AcRxService) | AcRxService |
addDependency() (defined in AcRxService) | AcRxService |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
dependencyFunctionPtr() (defined in AcRxService) | AcRxService |
desc() (defined in AcRxObject) | AcRxObject | static
getSysInfo() const (defined in AcRxService) | AcRxService |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
newAcRxDictionary(Adesk::Boolean sorted=Adesk::kTrue, Adesk::Boolean ignoreCase=Adesk::kFalse)=0 (defined in AcRxKernel) | AcRxKernel | pure virtual
newAcRxDictionary(unsigned long length, Adesk::Boolean delObjects, Adesk::Boolean sorted=Adesk::kTrue, Adesk::Boolean ignoreCase=Adesk::kFalse)=0 (defined in AcRxKernel) | AcRxKernel | pure virtual
newAcRxDictionary(const AcRxClass *filter)=0 (defined in AcRxKernel) | AcRxKernel | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeDependency() (defined in AcRxService) | AcRxService |
setDependencyFunctionPtr(DepFuncPtr) (defined in AcRxService) | AcRxService |
setSysInfo(AcRxObject *sysInfoObj) (defined in AcRxService) | AcRxService |
unloadable() const (defined in AcRxService) | AcRxService |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxKernel() (defined in AcRxKernel) | AcRxKernel | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~AcRxService() (defined in AcRxService) | AcRxService | virtual


ZRX API Reference: AcRxObject Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | List of all members
AcRxObject Class Reference

Inherited by Ac3dDwfNavTreeNode, AcadAppInfo, AcApDocManager, AcApDocManagerReactor, AcApDocument, AcApDocumentIterator, AcApLongTransactionManager, AcApLongTransactionReactor, AcDbAlignment, AcDbAnnotativeObjectPE, AcDbAuditRecreatePE, AcDbCustomOsnapInfo, AcDbDatabase, AcDbDatabaseReactor, AcDbDatabaseSummaryInfo, AcDbDataCell, AcDbDataColumn, AcDbDataLinkManager, AcDbDictionaryIterator, AcDbDoubleClickEdit, AcDbDwgFiler, AcDbDxfFiler, AcDbDynamicUCSPE, AcDbEntityHyperlinkPE, AcDbEvalContext, AcDbEvalContextIterator, AcDbEvalVariant, AcDbGroupIterator, AcDbHostApplicationServices, AcDbIdMapping, AcDbIdMappingIter, AcDbInterferencePE, AcDbLayerStateManager, AcDbLayerStateManagerReactor, AcDbLayoutManager, AcDbLayoutManagerReactor, AcDbLongTransWorkSetIterator, AcDbMatchProperties, AcDbObjectContext, AcDbObjectContextCollection, AcDbObjectContextCollectionIterator, AcDbObjectContextInterface, AcDbObjectContextManager, AcDbObjectIterator, AcDbObjectReactor, AcDbPaperOrientationPE, AcDbPointRef, AcDbSelectGrip, AcDbTransactionManager, AcDbXObject, AcDbXrecordIterator, AcDMMReactor, AcEdCommand, AcEdCommandIterator, AcEdCommandStack, AcEdInputPointFilter, AcEdInputPointMonitor, AcEdJig, AcEdUIContext, AcFdFieldEngine, AcFdFieldEvaluator, AcFdFieldEvaluatorLoader, AcFdFieldReactor, AcFdFieldResult, AcGiCommonDraw, AcGiContext, AcGiContextualColors, AcGiDisplayStyle, AcGiDrawable, AcGiEdgeData, AcGiEdgeStyle, AcGiFaceData, AcGiFaceStyle, AcGiGeometry, AcGiLightAttenuation, AcGiLinetypeEngine, AcGiMapper, AcGiMaterialColor, AcGiMaterialMap, AcGiMaterialTexture, AcGiShadowParameters, AcGiSkyParameters, AcGiSubEntityTraits, AcGiTextStyle, AcGiToneOperatorParameters, AcGiVariant, AcGiVertexData, AcGiViewport, AcGiVisualStyle, AcLyLayerFilter, AcPlObject, AcPlPlotReactor, AcPublishReactor, AcPublishUIReactor, AcRxDictionary, AcRxDLinkerReactor, AcRxDynamicLinker, AcRxEvent, AcRxEventReactor, AcRxIterator, AcRxProtocolReactor, AcRxProtocolReactorIterator, AcRxProtocolReactorList, AcRxProtocolReactorListIterator, AcRxProtocolReactorManager, AcRxService, AcTransaction, AcTransactionReactor, AcValue, OPMPerInstancePropertyExtension, OPMPerInstancePropertyExtensionFactory, OPMPerInstancePropertySources, OPMPropertyExtension, and OPMPropertyExtensionFactory.

Public Member Functions

virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Static Public Member Functions

static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following files:
  • rxobject.h
  • rxclass.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxObject Member List

This is the complete list of members for AcRxObject, including all inherited members.

AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxProtocolReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxProtocolReactor Class Reference
+ Inheritance diagram for AcRxProtocolReactor:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxProtocolReactor)
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxprotevnt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxProtocolReactor Member List

This is the complete list of members for AcRxProtocolReactor, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxProtocolReactor) (defined in AcRxProtocolReactor) | AcRxProtocolReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxProtocolReactorIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxProtocolReactorIterator Class Reference
+ Inheritance diagram for AcRxProtocolReactorIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxProtocolReactorIterator)
virtual bool | done () const =0
virtual bool | next ()=0
virtual AcRxProtocolReactor * | object () const =0
virtual AcRxClass * | reactorClass () const =0
virtual void | start ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxprotevnt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxProtocolReactorIterator Member List

This is the complete list of members for AcRxProtocolReactorIterator, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxProtocolReactorIterator) (defined in AcRxProtocolReactorIterator) | AcRxProtocolReactorIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const =0 (defined in AcRxProtocolReactorIterator) | AcRxProtocolReactorIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
next()=0 (defined in AcRxProtocolReactorIterator) | AcRxProtocolReactorIterator | pure virtual
object() const =0 (defined in AcRxProtocolReactorIterator) | AcRxProtocolReactorIterator | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactorClass() const =0 (defined in AcRxProtocolReactorIterator) | AcRxProtocolReactorIterator | pure virtual
start()=0 (defined in AcRxProtocolReactorIterator) | AcRxProtocolReactorIterator | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxProtocolReactorList Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxProtocolReactorList Class Reference
+ Inheritance diagram for AcRxProtocolReactorList:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxProtocolReactorList)
virtual Acad::ErrorStatus | addReactor (AcRxProtocolReactor *pReactor)=0
virtual
AcRxProtocolReactorIterator * 		newIterator () const =0
virtual AcRxClass * | reactorClass () const =0
virtual void | removeReactor (AcRxProtocolReactor *pReactor)=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxprotevnt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxProtocolReactorList Member List

This is the complete list of members for AcRxProtocolReactorList, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxProtocolReactorList) (defined in AcRxProtocolReactorList) | AcRxProtocolReactorList |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addReactor(AcRxProtocolReactor *pReactor)=0 (defined in AcRxProtocolReactorList) | AcRxProtocolReactorList | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
newIterator() const =0 (defined in AcRxProtocolReactorList) | AcRxProtocolReactorList | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reactorClass() const =0 (defined in AcRxProtocolReactorList) | AcRxProtocolReactorList | pure virtual
removeReactor(AcRxProtocolReactor *pReactor)=0 (defined in AcRxProtocolReactorList) | AcRxProtocolReactorList | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxProtocolReactorListIterator Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxProtocolReactorListIterator Class Reference
+ Inheritance diagram for AcRxProtocolReactorListIterator:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxProtocolReactorListIterator)
virtual bool | done () const =0
virtual bool | next ()=0
virtual AcRxProtocolReactorList * | object () const =0
virtual void | start ()=0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxprotevnt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxProtocolReactorListIterator Member List

This is the complete list of members for AcRxProtocolReactorListIterator, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxProtocolReactorListIterator) (defined in AcRxProtocolReactorListIterator) | AcRxProtocolReactorListIterator |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
done() const =0 (defined in AcRxProtocolReactorListIterator) | AcRxProtocolReactorListIterator | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
next()=0 (defined in AcRxProtocolReactorListIterator) | AcRxProtocolReactorListIterator | pure virtual
object() const =0 (defined in AcRxProtocolReactorListIterator) | AcRxProtocolReactorListIterator | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
start()=0 (defined in AcRxProtocolReactorListIterator) | AcRxProtocolReactorListIterator | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxProtocolReactorManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxProtocolReactorManager Class Reference
+ Inheritance diagram for AcRxProtocolReactorManager:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxProtocolReactorManager)
virtual AcRxProtocolReactorList * | createReactorList (AcRxClass *pReactorClass)=0
virtual
AcRxProtocolReactorListIterator * 		newIterator () const =0
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxprotevnt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxProtocolReactorManager Member List

This is the complete list of members for AcRxProtocolReactorManager, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxProtocolReactorManager) (defined in AcRxProtocolReactorManager) | AcRxProtocolReactorManager |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
createReactorList(AcRxClass *pReactorClass)=0 (defined in AcRxProtocolReactorManager) | AcRxProtocolReactorManager | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
newIterator() const =0 (defined in AcRxProtocolReactorManager) | AcRxProtocolReactorManager | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: AcRxProtocolReactorManagerFactory Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxProtocolReactorManagerFactory Class Reference
+ Inheritance diagram for AcRxProtocolReactorManagerFactory:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxProtocolReactorManagerFactory)
virtual
AcRxProtocolReactorManager * 		createReactorManager (AcRxClass *pRxClass) const =0
- Public Member Functions inherited from AcRxService
ACRX_DECLARE_MEMBERS (AcRxService)
void | addDependency ()
DepFuncPtr | dependencyFunctionPtr ()
AcRxObject * | getSysInfo () const
void | removeDependency ()
void | setDependencyFunctionPtr (DepFuncPtr)
void | setSysInfo (AcRxObject *sysInfoObj)
Adesk::Boolean | unloadable () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxprotevnt.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxProtocolReactorManagerFactory Member List

This is the complete list of members for AcRxProtocolReactorManagerFactory, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxProtocolReactorManagerFactory) (defined in AcRxProtocolReactorManagerFactory) | AcRxProtocolReactorManagerFactory |
ACRX_DECLARE_MEMBERS(AcRxService) (defined in AcRxService) | AcRxService |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
AcRxService() (defined in AcRxService) | AcRxService |
addDependency() (defined in AcRxService) | AcRxService |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
createReactorManager(AcRxClass *pRxClass) const =0 (defined in AcRxProtocolReactorManagerFactory) | AcRxProtocolReactorManagerFactory | pure virtual
dependencyFunctionPtr() (defined in AcRxService) | AcRxService |
desc() (defined in AcRxObject) | AcRxObject | static
getSysInfo() const (defined in AcRxService) | AcRxService |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeDependency() (defined in AcRxService) | AcRxService |
setDependencyFunctionPtr(DepFuncPtr) (defined in AcRxService) | AcRxService |
setSysInfo(AcRxObject *sysInfoObj) (defined in AcRxService) | AcRxService |
unloadable() const (defined in AcRxService) | AcRxService |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~AcRxService() (defined in AcRxService) | AcRxService | virtual


ZRX API Reference: AcRxService Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AcRxService Class Reference
+ Inheritance diagram for AcRxService:

Public Member Functions

ACRX_DECLARE_MEMBERS (AcRxService)
void | addDependency ()
DepFuncPtr | dependencyFunctionPtr ()
AcRxObject * | getSysInfo () const
void | removeDependency ()
void | setDependencyFunctionPtr (DepFuncPtr)
void | setSysInfo (AcRxObject *sysInfoObj)
Adesk::Boolean | unloadable () const
- Public Member Functions inherited from AcRxObject
virtual AcRxObject * | clone () const
virtual AcRx::Ordering | comparedTo (const AcRxObject *other) const
virtual Acad::ErrorStatus | copyFrom (const AcRxObject *other)
virtual AcRxClass * | isA () const
virtual Adesk::Boolean | isEqualTo (const AcRxObject *other) const
bool | isKindOf (const AcRxClass *aClass) const
AcRxObject * | queryX (const AcRxClass *protocolClass) const
AcRxObject * | x (const AcRxClass *protocolClass) const

Additional Inherited Members

- Static Public Member Functions inherited from AcRxObject
static AcRxObject * | cast (const AcRxObject *inPtr)
static AcRxClass * | desc ()
The documentation for this class was generated from the following file:
  • rxsrvice.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcRxService Member List

This is the complete list of members for AcRxService, including all inherited members.

ACRX_DECLARE_MEMBERS(AcRxService) (defined in AcRxService) | AcRxService |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
AcRxService() (defined in AcRxService) | AcRxService |
addDependency() (defined in AcRxService) | AcRxService |
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
dependencyFunctionPtr() (defined in AcRxService) | AcRxService |
desc() (defined in AcRxObject) | AcRxObject | static
getSysInfo() const (defined in AcRxService) | AcRxService |
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
removeDependency() (defined in AcRxService) | AcRxService |
setDependencyFunctionPtr(DepFuncPtr) (defined in AcRxService) | AcRxService |
setSysInfo(AcRxObject *sysInfoObj) (defined in AcRxService) | AcRxService |
unloadable() const (defined in AcRxService) | AcRxService |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual
~AcRxService() (defined in AcRxService) | AcRxService | virtual


ZRX API Reference: ACTC_IMAGE_INFO Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
ACTC_IMAGE_INFO Struct Reference

Public Attributes

SIZE | mSize
ACHAR | mszResourceName [MAX_PATH]
ACHAR | mszSourceFile [MAX_PATH]
The documentation for this struct was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
ACTC_IMAGE_INFO Member List

This is the complete list of members for ACTC_IMAGE_INFO, including all inherited members.

mSize (defined in ACTC_IMAGE_INFO) | ACTC_IMAGE_INFO
mszResourceName (defined in ACTC_IMAGE_INFO) | ACTC_IMAGE_INFO
mszSourceFile (defined in ACTC_IMAGE_INFO) | ACTC_IMAGE_INFO


ZRX API Reference: ACTC_TARGET_PRODUCT_INFO Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
ACTC_TARGET_PRODUCT_INFO Struct Reference

Public Attributes

DWORD | mdwMaxVersion
DWORD | mdwMinVersion
ACHAR | mszLocaleIds [ACTC_MAX_LOCALE]
ACHAR | mszProductName [ACTC_MAX_PRODUCT_NAME]
The documentation for this struct was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
ACTC_TARGET_PRODUCT_INFO Member List

This is the complete list of members for ACTC_TARGET_PRODUCT_INFO, including all inherited members.

mdwMaxVersion (defined in ACTC_TARGET_PRODUCT_INFO) | ACTC_TARGET_PRODUCT_INFO
mdwMinVersion (defined in ACTC_TARGET_PRODUCT_INFO) | ACTC_TARGET_PRODUCT_INFO
mszLocaleIds (defined in ACTC_TARGET_PRODUCT_INFO) | ACTC_TARGET_PRODUCT_INFO
mszProductName (defined in ACTC_TARGET_PRODUCT_INFO) | ACTC_TARGET_PRODUCT_INFO


ZRX API Reference: AcTcCatalog Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcTcCatalog Class Reference
+ Inheritance diagram for AcTcCatalog:

Public Member Functions

AcTcCatalog (const AcTcCatalog &srcItem)
- Public Member Functions inherited from AcTcCategory
AcTcCategory (const AcTcCategory &srcItem)
- Public Member Functions inherited from AcTcCatalogItem
INT_PTR | AddChild (AcTcCatalogItem *pNewItem)
BOOL | AddReactor (AcTcCatalogItemReactor *pReactor)
INT_PTR | AddTargetProduct (const ACTC_TARGET_PRODUCT_INFO *pProductInfo)
BOOL | CanRefresh (void) const
virtual BOOL | Clone (BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const
virtual BOOL | CopyFrom (const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE)
BOOL | DeleteAllChildren (void)
BOOL | DeleteChild (AcTcCatalogItem *pItem)
BOOL | DeleteImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteLinkFile (BOOL bRecursive=FALSE)
BOOL | DeleteOverlayImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteTargetProduct (int iIndex)
BOOL | DetachChild (AcTcCatalogItem *pItem)
virtual BOOL | Download (LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL)
virtual AcTcCatalogItem * | FindInChildren (const GUID &id, BOOL bRecursive=TRUE)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName, BOOL bRecursive)
AcTc::AccessRight | GetAccessRight (void) const
BOOL | GetAutoRefresh (void) const
AcTcCatalogItem * | GetChild (INT_PTR iIndex) const
INT_PTR | GetChildCount (void) const
INT_PTR | GetChildCount (CatalogItemType nType) const
BOOL | GetCustomData (IUnknown **ppCustomData)
int | GetDescription (LPTSTR pszString, int cchSize) const
BOOL | GetHelpInfo (LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const
BOOL | GetID (GUID *pId) const
AcTcImage * | GetImage (const SIZE *pSize)
INT_PTR | GetImageFilePath (INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const
AcTcImageList * | GetImageList (void) const
int | GetKeywords (LPTSTR pszString, int cchSize) const
int | GetLinkFilePath (LPTSTR pszString, int cchSize) const
int | GetLinkUrl (LPTSTR pszString, int cchSize) const
int | GetLocalFile (LPTSTR pszString, int cchSize) const
int | GetName (LPTSTR pszString, int cchSize) const
AcTcCatalogItem * | GetNextChild (int iIndex, CatalogItemType nType) const
AcTc::ItemOption | GetOption (void) const
AcTcImage * | GetOverlayImage (void) const
INT_PTR | GetOverlayImageFilePath (LPTSTR pszString, size_t cchSize) const
BOOL | GetOverlayImageInfo (ACTC_IMAGE_INFO *pImageInfo) const
AcTcCatalogItem * | GetParent (void) const
int | GetParentDocumentDescription (LPTSTR pszString, int cchSize) const
int | GetParentDocumentName (LPTSTR pszString, int cchSize) const
int | GetParentDocumentUrl (LPTSTR pszString, int cchSize) const
int | GetPublisherCountry (LPTSTR pszString, int cchSize) const
int | GetPublisherDescription (LPTSTR pszString, int cchSize) const
int | GetPublisherEmail (LPTSTR pszString, int cchSize) const
int | GetPublisherName (LPTSTR pszString, int cchSize) const
int | GetPublisherUrl (LPTSTR pszString, int cchSize) const
int | GetReferencePath (LPTSTR pszString, int cchSize, int nFlag) const
BOOL | GetRefresh (void) const
AcTcCatalogItem * | GetRoot (void) const
AcTcScheme * | GetScheme (void) const
BOOL | GetSourceID (GUID *pId) const
int | GetSourceUrl (LPTSTR pszString, int cchSize) const
virtual int | GetTagName (LPTSTR pszString, int cchSize) const
BOOL | GetTargetProduct (INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const
INT_PTR | GetTargetProductCount (void) const
BOOL | GetTime (time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const
int | GetToolTipText (LPTSTR pszString, int cchSize) const
virtual CatalogItemType | GetType (void) const
virtual int | GetTypeString (LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const
int | GetUrl (LPTSTR pszString, int cchSize) const
int | GetXml (LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | HasChildren (void) const
INT_PTR | InsertChild (INT_PTR iIndex, AcTcCatalogItem *pNewItem)
BOOL | IsLink (void) const
BOOL | IsLinkLoaded (void) const
BOOL | IsReadOnly (void) const
BOOL | IsRoot (void) const
virtual BOOL | IsValidChild (const CatalogItemType nType) const
BOOL | IsValidForProduct (LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0)
BOOL | Load (LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IStream *pStream, DWORD dwLoadOption=kLoadLinks)
BOOL | LoadLink (void)
virtual AcTcCatalogItem & | operator= (const AcTcCatalogItem &srcItem)
virtual BOOL | Refresh (DWORD dwRefreshFlag=kRefreshAll)
BOOL | RemoveReactor (AcTcCatalogItemReactor *pReactor)
virtual BOOL | Reset (void)
BOOL | Save (LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | SetAccessRight (AcTc::AccessRight nAccessRight)
BOOL | SetAutoRefresh (BOOL bAutoRefresh)
BOOL | SetDescription (LPCTSTR pszString)
BOOL | SetHelpInfo (LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData)
BOOL | SetID (const GUID *pId)
BOOL | SetItemOrder (AcTcCatalogItem **pItems, INT_PTR nNumItems)
BOOL | SetKeywords (LPCTSTR pszString)
BOOL | SetLinkUrl (LPCTSTR pszString)
BOOL | SetName (LPCTSTR pszString)
BOOL | SetNewID (BOOL bRecursive=FALSE)
BOOL | SetOption (AcTc::ItemOption nOption)
BOOL | SetOverlayImage (const AcTcImage *pImage)
BOOL | SetOverlayImageInfo (const ACTC_IMAGE_INFO *pImageInfo)
BOOL | SetParent (AcTcCatalogItem *pParent)
BOOL | SetParentDocumentDescription (LPCTSTR pszString)
BOOL | SetParentDocumentName (LPCTSTR pszString)
BOOL | SetParentDocumentUrl (LPCTSTR pszString)
BOOL | SetPublisherCountry (LPCTSTR pszString)
BOOL | SetPublisherDescription (LPCTSTR pszString)
BOOL | SetPublisherEmail (LPCTSTR pszString)
BOOL | SetPublisherName (LPCTSTR pszString)
BOOL | SetPublisherUrl (LPCTSTR pszString)
BOOL | SetReferencePath (LPCTSTR pszString, int nFlag)
BOOL | SetRefresh (BOOL bRefresh)
BOOL | SetSourceID (const GUID *pId)
BOOL | SetSourceUrl (LPCTSTR pszString)
BOOL | SetTime (const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed)
BOOL | SetToolTipText (LPCTSTR pszString)
BOOL | Sort (int nSortOption, BOOL bRecursive)

Protected Member Functions

AcTcCatalog (AcTcSystemInternals *)
- Protected Member Functions inherited from AcTcCategory
AcTcCategory (AcTcSystemInternals *)
- Protected Member Functions inherited from AcTcCatalogItem
AcTcCatalogItem (AcTcSystemInternals *)
virtual AcTcCatalogItem * CreateObject (void) const

Additional Inherited Members

- Static Public Member Functions inherited from AcTcCatalogItem
static AcTcCatalogItem * | FromFile (LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks)
static CatalogItemType | GetType (LPCTSTR pszFile)
- Protected Attributes inherited from AcTcCatalogItem
void * | mpImpObj
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcCatalog Member List

This is the complete list of members for AcTcCatalog, including all inherited members.

AcTcCatalog() (defined in AcTcCatalog) | AcTcCatalog |
AcTcCatalog(const AcTcCatalog &srcItem) (defined in AcTcCatalog) | AcTcCatalog |
AcTcCatalog(AcTcSystemInternals *) (defined in AcTcCatalog) | AcTcCatalog | protected
AcTcCatalogItem(AcTcSystemInternals *) (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
AcTcCategory() (defined in AcTcCategory) | AcTcCategory |
AcTcCategory(const AcTcCategory &srcItem) (defined in AcTcCategory) | AcTcCategory |
AcTcCategory(AcTcSystemInternals *) (defined in AcTcCategory) | AcTcCategory | protected
AddChild(AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddTargetProduct(const ACTC_TARGET_PRODUCT_INFO *pProductInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
CanRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
Clone(BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CopyFrom(const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CreateObject(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | protectedvirtual
DeleteAllChildren(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteLinkFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteOverlayImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteTargetProduct(int iIndex) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DetachChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Download(LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(const GUID &id, BOOL bRecursive=TRUE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(LPCTSTR pszName) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FindInChildren(LPCTSTR pszName, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FromFile(LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetAccessRight(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetAutoRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChild(INT_PTR iIndex) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetCustomData(IUnknown **ppCustomData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetHelpInfo(LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImage(const SIZE *pSize) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageFilePath(INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageList(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetKeywords(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkFilePath(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLocalFile(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetNextChild(int iIndex, CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOption(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImage(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageFilePath(LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageInfo(ACTC_IMAGE_INFO *pImageInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParent(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherCountry(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherEmail(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetReferencePath(LPTSTR pszString, int cchSize, int nFlag) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetScheme(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTagName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTargetProduct(INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTargetProductCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTime(time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetToolTipText(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetType(LPCTSTR pszFile) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetType(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTypeString(LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetXml(LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
HasChildren(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
InsertChild(INT_PTR iIndex, AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLink(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLinkLoaded(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsReadOnly(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsValidChild(const CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
IsValidForProduct(LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Load(IStream *pStream, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
LoadLink(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
mpImpObj (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
operator=(const AcTcCatalogItem &srcItem) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Refresh(DWORD dwRefreshFlag=kRefreshAll) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
RemoveReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Reset(void) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Save(IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
SetAccessRight(AcTc::AccessRight nAccessRight) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetAutoRefresh(BOOL bAutoRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetHelpInfo(LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetItemOrder(AcTcCatalogItem **pItems, INT_PTR nNumItems) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetKeywords(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetLinkUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetNewID(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOption(AcTc::ItemOption nOption) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImage(const AcTcImage *pImage) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImageInfo(const ACTC_IMAGE_INFO *pImageInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParent(AcTcCatalogItem *pParent) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherCountry(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherEmail(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetReferencePath(LPCTSTR pszString, int nFlag) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetRefresh(BOOL bRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetTime(const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetToolTipText(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Sort(int nSortOption, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
~AcTcCatalog() (defined in AcTcCatalog) | AcTcCatalog | virtual
~AcTcCatalogItem() (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
~AcTcCategory() (defined in AcTcCategory) | AcTcCategory | virtual


ZRX API Reference: AcTcCatalogItem Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
AcTcCatalogItem Class Reference
+ Inheritance diagram for AcTcCatalogItem:

Public Member Functions

INT_PTR | AddChild (AcTcCatalogItem *pNewItem)
BOOL | AddReactor (AcTcCatalogItemReactor *pReactor)
INT_PTR | AddTargetProduct (const ACTC_TARGET_PRODUCT_INFO *pProductInfo)
BOOL | CanRefresh (void) const
virtual BOOL | Clone (BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const
virtual BOOL | CopyFrom (const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE)
BOOL | DeleteAllChildren (void)
BOOL | DeleteChild (AcTcCatalogItem *pItem)
BOOL | DeleteImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteLinkFile (BOOL bRecursive=FALSE)
BOOL | DeleteOverlayImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteTargetProduct (int iIndex)
BOOL | DetachChild (AcTcCatalogItem *pItem)
virtual BOOL | Download (LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL)
virtual AcTcCatalogItem * | FindInChildren (const GUID &id, BOOL bRecursive=TRUE)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName, BOOL bRecursive)
AcTc::AccessRight | GetAccessRight (void) const
BOOL | GetAutoRefresh (void) const
AcTcCatalogItem * | GetChild (INT_PTR iIndex) const
INT_PTR | GetChildCount (void) const
INT_PTR | GetChildCount (CatalogItemType nType) const
BOOL | GetCustomData (IUnknown **ppCustomData)
int | GetDescription (LPTSTR pszString, int cchSize) const
BOOL | GetHelpInfo (LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const
BOOL | GetID (GUID *pId) const
AcTcImage * | GetImage (const SIZE *pSize)
INT_PTR | GetImageFilePath (INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const
AcTcImageList * | GetImageList (void) const
int | GetKeywords (LPTSTR pszString, int cchSize) const
int | GetLinkFilePath (LPTSTR pszString, int cchSize) const
int | GetLinkUrl (LPTSTR pszString, int cchSize) const
int | GetLocalFile (LPTSTR pszString, int cchSize) const
int | GetName (LPTSTR pszString, int cchSize) const
AcTcCatalogItem * | GetNextChild (int iIndex, CatalogItemType nType) const
AcTc::ItemOption | GetOption (void) const
AcTcImage * | GetOverlayImage (void) const
INT_PTR | GetOverlayImageFilePath (LPTSTR pszString, size_t cchSize) const
BOOL | GetOverlayImageInfo (ACTC_IMAGE_INFO *pImageInfo) const
AcTcCatalogItem * | GetParent (void) const
int | GetParentDocumentDescription (LPTSTR pszString, int cchSize) const
int | GetParentDocumentName (LPTSTR pszString, int cchSize) const
int | GetParentDocumentUrl (LPTSTR pszString, int cchSize) const
int | GetPublisherCountry (LPTSTR pszString, int cchSize) const
int | GetPublisherDescription (LPTSTR pszString, int cchSize) const
int | GetPublisherEmail (LPTSTR pszString, int cchSize) const
int | GetPublisherName (LPTSTR pszString, int cchSize) const
int | GetPublisherUrl (LPTSTR pszString, int cchSize) const
int | GetReferencePath (LPTSTR pszString, int cchSize, int nFlag) const
BOOL | GetRefresh (void) const
AcTcCatalogItem * | GetRoot (void) const
AcTcScheme * | GetScheme (void) const
BOOL | GetSourceID (GUID *pId) const
int | GetSourceUrl (LPTSTR pszString, int cchSize) const
virtual int | GetTagName (LPTSTR pszString, int cchSize) const
BOOL | GetTargetProduct (INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const
INT_PTR | GetTargetProductCount (void) const
BOOL | GetTime (time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const
int | GetToolTipText (LPTSTR pszString, int cchSize) const
virtual CatalogItemType | GetType (void) const
virtual int | GetTypeString (LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const
int | GetUrl (LPTSTR pszString, int cchSize) const
int | GetXml (LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | HasChildren (void) const
INT_PTR | InsertChild (INT_PTR iIndex, AcTcCatalogItem *pNewItem)
BOOL | IsLink (void) const
BOOL | IsLinkLoaded (void) const
BOOL | IsReadOnly (void) const
BOOL | IsRoot (void) const
virtual BOOL | IsValidChild (const CatalogItemType nType) const
BOOL | IsValidForProduct (LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0)
BOOL | Load (LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IStream *pStream, DWORD dwLoadOption=kLoadLinks)
BOOL | LoadLink (void)
virtual AcTcCatalogItem & | operator= (const AcTcCatalogItem &srcItem)
virtual BOOL | Refresh (DWORD dwRefreshFlag=kRefreshAll)
BOOL | RemoveReactor (AcTcCatalogItemReactor *pReactor)
virtual BOOL | Reset (void)
BOOL | Save (LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | SetAccessRight (AcTc::AccessRight nAccessRight)
BOOL | SetAutoRefresh (BOOL bAutoRefresh)
BOOL | SetDescription (LPCTSTR pszString)
BOOL | SetHelpInfo (LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData)
BOOL | SetID (const GUID *pId)
BOOL | SetItemOrder (AcTcCatalogItem **pItems, INT_PTR nNumItems)
BOOL | SetKeywords (LPCTSTR pszString)
BOOL | SetLinkUrl (LPCTSTR pszString)
BOOL | SetName (LPCTSTR pszString)
BOOL | SetNewID (BOOL bRecursive=FALSE)
BOOL | SetOption (AcTc::ItemOption nOption)
BOOL | SetOverlayImage (const AcTcImage *pImage)
BOOL | SetOverlayImageInfo (const ACTC_IMAGE_INFO *pImageInfo)
BOOL | SetParent (AcTcCatalogItem *pParent)
BOOL | SetParentDocumentDescription (LPCTSTR pszString)
BOOL | SetParentDocumentName (LPCTSTR pszString)
BOOL | SetParentDocumentUrl (LPCTSTR pszString)
BOOL | SetPublisherCountry (LPCTSTR pszString)
BOOL | SetPublisherDescription (LPCTSTR pszString)
BOOL | SetPublisherEmail (LPCTSTR pszString)
BOOL | SetPublisherName (LPCTSTR pszString)
BOOL | SetPublisherUrl (LPCTSTR pszString)
BOOL | SetReferencePath (LPCTSTR pszString, int nFlag)
BOOL | SetRefresh (BOOL bRefresh)
BOOL | SetSourceID (const GUID *pId)
BOOL | SetSourceUrl (LPCTSTR pszString)
BOOL | SetTime (const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed)
BOOL | SetToolTipText (LPCTSTR pszString)
BOOL | Sort (int nSortOption, BOOL bRecursive)

Static Public Member Functions

static AcTcCatalogItem * | FromFile (LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks)
static CatalogItemType | GetType (LPCTSTR pszFile)

Protected Member Functions

AcTcCatalogItem (AcTcSystemInternals *)
virtual AcTcCatalogItem * CreateObject (void) const

Protected Attributes

void * mpImpObj

Friends

class AcTcSystemInternals
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcCatalogItem Member List

This is the complete list of members for AcTcCatalogItem, including all inherited members.

AcTcCatalogItem(AcTcSystemInternals *) (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
AcTcSystemInternals (defined in AcTcCatalogItem) | AcTcCatalogItem | friend
AddChild(AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddTargetProduct(const ACTC_TARGET_PRODUCT_INFO *pProductInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
CanRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
Clone(BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CopyFrom(const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CreateObject(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | protectedvirtual
DeleteAllChildren(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteLinkFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteOverlayImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteTargetProduct(int iIndex) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DetachChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Download(LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(const GUID &id, BOOL bRecursive=TRUE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(LPCTSTR pszName) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FindInChildren(LPCTSTR pszName, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FromFile(LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetAccessRight(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetAutoRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChild(INT_PTR iIndex) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetCustomData(IUnknown **ppCustomData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetHelpInfo(LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImage(const SIZE *pSize) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageFilePath(INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageList(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetKeywords(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkFilePath(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLocalFile(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetNextChild(int iIndex, CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOption(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImage(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageFilePath(LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageInfo(ACTC_IMAGE_INFO *pImageInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParent(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherCountry(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherEmail(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetReferencePath(LPTSTR pszString, int cchSize, int nFlag) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetScheme(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTagName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTargetProduct(INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTargetProductCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTime(time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetToolTipText(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetType(LPCTSTR pszFile) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetType(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTypeString(LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetXml(LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
HasChildren(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
InsertChild(INT_PTR iIndex, AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLink(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLinkLoaded(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsReadOnly(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsValidChild(const CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
IsValidForProduct(LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Load(IStream *pStream, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
LoadLink(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
mpImpObj (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
operator=(const AcTcCatalogItem &srcItem) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Refresh(DWORD dwRefreshFlag=kRefreshAll) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
RemoveReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Reset(void) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Save(IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
SetAccessRight(AcTc::AccessRight nAccessRight) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetAutoRefresh(BOOL bAutoRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetHelpInfo(LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetItemOrder(AcTcCatalogItem **pItems, INT_PTR nNumItems) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetKeywords(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetLinkUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetNewID(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOption(AcTc::ItemOption nOption) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImage(const AcTcImage *pImage) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImageInfo(const ACTC_IMAGE_INFO *pImageInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParent(AcTcCatalogItem *pParent) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherCountry(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherEmail(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetReferencePath(LPCTSTR pszString, int nFlag) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetRefresh(BOOL bRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetTime(const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetToolTipText(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Sort(int nSortOption, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
~AcTcCatalogItem() (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual


ZRX API Reference: AcTcCatalogItemReactor Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
AcTcCatalogItemReactor Class Reference

Public Member Functions

virtual void | ChildAdded (AcTcCatalogItem *pChild)
virtual void | ChildDeleted (AcTcCatalogItem *pChild)
virtual void | ChildDetached (AcTcCatalogItem *pChild)
BOOL | Enable (BOOL bEnable)
BOOL | IsEnabled (void) const

Protected Attributes

void * mpImpObj

Friends

class AcTcSystemInternals
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcCatalogItemReactor Member List

This is the complete list of members for AcTcCatalogItemReactor, including all inherited members.

AcTcCatalogItemReactor() (defined in AcTcCatalogItemReactor) | AcTcCatalogItemReactor | protected
AcTcSystemInternals (defined in AcTcCatalogItemReactor) | AcTcCatalogItemReactor | friend
ChildAdded(AcTcCatalogItem *pChild) (defined in AcTcCatalogItemReactor) | AcTcCatalogItemReactor | virtual
ChildDeleted(AcTcCatalogItem *pChild) (defined in AcTcCatalogItemReactor) | AcTcCatalogItemReactor | virtual
ChildDetached(AcTcCatalogItem *pChild) (defined in AcTcCatalogItemReactor) | AcTcCatalogItemReactor | virtual
Enable(BOOL bEnable) (defined in AcTcCatalogItemReactor) | AcTcCatalogItemReactor |
IsEnabled(void) const (defined in AcTcCatalogItemReactor) | AcTcCatalogItemReactor |
mpImpObj (defined in AcTcCatalogItemReactor) | AcTcCatalogItemReactor | protected
~AcTcCatalogItemReactor(void) (defined in AcTcCatalogItemReactor) | AcTcCatalogItemReactor | virtual


ZRX API Reference: AcTcCatalogSet Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
AcTcCatalogSet Class Reference

Public Member Functions

INT_PTR | AddCatalog (AcTcCatalogItem *pCatalog)
AcTcCatalogItem * | FindItem (const GUID &id) const
AcTcCatalogItem * | GetCatalog (int nIndex) const
INT_PTR | GetCatalogCount (void) const
int | GetCatalogPath (LPTSTR pszString, int cchSize) const
AcTcScheme * | GetScheme (void) const
INT_PTR | InsertCatalog (INT_PTR nIndex, AcTcCatalogItem *pCatalog)
BOOL | LoadCatalogs (void)
BOOL | LoadCatalogs (DWORD dwLoadOption)
AcTcCatalogItem * | RemoveCatalog (int nIndex)
BOOL | SaveCatalogs (void)
BOOL | SaveCatalogs (DWORD dwSaveOption)
BOOL | SetCatalogPath (LPCTSTR pszPath)
BOOL | UnloadCatalogs (void)

Protected Member Functions

AcTcCatalogSet (DWORD dwCatalogType)

Protected Attributes

void * mpImpObj

Friends

class AcTcSystemInternals
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcCatalogSet Member List

This is the complete list of members for AcTcCatalogSet, including all inherited members.

AcTcCatalogSet(DWORD dwCatalogType) (defined in AcTcCatalogSet) | AcTcCatalogSet | protected
AcTcSystemInternals (defined in AcTcCatalogSet) | AcTcCatalogSet | friend
AddCatalog(AcTcCatalogItem *pCatalog) (defined in AcTcCatalogSet) | AcTcCatalogSet |
FindItem(const GUID &id) const (defined in AcTcCatalogSet) | AcTcCatalogSet |
GetCatalog(int nIndex) const (defined in AcTcCatalogSet) | AcTcCatalogSet |
GetCatalogCount(void) const (defined in AcTcCatalogSet) | AcTcCatalogSet |
GetCatalogPath(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogSet) | AcTcCatalogSet |
GetScheme(void) const (defined in AcTcCatalogSet) | AcTcCatalogSet |
InsertCatalog(INT_PTR nIndex, AcTcCatalogItem *pCatalog) (defined in AcTcCatalogSet) | AcTcCatalogSet |
LoadCatalogs(void) (defined in AcTcCatalogSet) | AcTcCatalogSet |
LoadCatalogs(DWORD dwLoadOption) (defined in AcTcCatalogSet) | AcTcCatalogSet |
mpImpObj (defined in AcTcCatalogSet) | AcTcCatalogSet | protected
RemoveCatalog(int nIndex) (defined in AcTcCatalogSet) | AcTcCatalogSet |
SaveCatalogs(void) (defined in AcTcCatalogSet) | AcTcCatalogSet |
SaveCatalogs(DWORD dwSaveOption) (defined in AcTcCatalogSet) | AcTcCatalogSet |
SetCatalogPath(LPCTSTR pszPath) (defined in AcTcCatalogSet) | AcTcCatalogSet |
UnloadCatalogs(void) (defined in AcTcCatalogSet) | AcTcCatalogSet |
~AcTcCatalogSet() (defined in AcTcCatalogSet) | AcTcCatalogSet | virtual


ZRX API Reference: AcTcCategory Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcTcCategory Class Reference
+ Inheritance diagram for AcTcCategory:

Public Member Functions

AcTcCategory (const AcTcCategory &srcItem)
- Public Member Functions inherited from AcTcCatalogItem
INT_PTR | AddChild (AcTcCatalogItem *pNewItem)
BOOL | AddReactor (AcTcCatalogItemReactor *pReactor)
INT_PTR | AddTargetProduct (const ACTC_TARGET_PRODUCT_INFO *pProductInfo)
BOOL | CanRefresh (void) const
virtual BOOL | Clone (BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const
virtual BOOL | CopyFrom (const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE)
BOOL | DeleteAllChildren (void)
BOOL | DeleteChild (AcTcCatalogItem *pItem)
BOOL | DeleteImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteLinkFile (BOOL bRecursive=FALSE)
BOOL | DeleteOverlayImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteTargetProduct (int iIndex)
BOOL | DetachChild (AcTcCatalogItem *pItem)
virtual BOOL | Download (LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL)
virtual AcTcCatalogItem * | FindInChildren (const GUID &id, BOOL bRecursive=TRUE)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName, BOOL bRecursive)
AcTc::AccessRight | GetAccessRight (void) const
BOOL | GetAutoRefresh (void) const
AcTcCatalogItem * | GetChild (INT_PTR iIndex) const
INT_PTR | GetChildCount (void) const
INT_PTR | GetChildCount (CatalogItemType nType) const
BOOL | GetCustomData (IUnknown **ppCustomData)
int | GetDescription (LPTSTR pszString, int cchSize) const
BOOL | GetHelpInfo (LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const
BOOL | GetID (GUID *pId) const
AcTcImage * | GetImage (const SIZE *pSize)
INT_PTR | GetImageFilePath (INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const
AcTcImageList * | GetImageList (void) const
int | GetKeywords (LPTSTR pszString, int cchSize) const
int | GetLinkFilePath (LPTSTR pszString, int cchSize) const
int | GetLinkUrl (LPTSTR pszString, int cchSize) const
int | GetLocalFile (LPTSTR pszString, int cchSize) const
int | GetName (LPTSTR pszString, int cchSize) const
AcTcCatalogItem * | GetNextChild (int iIndex, CatalogItemType nType) const
AcTc::ItemOption | GetOption (void) const
AcTcImage * | GetOverlayImage (void) const
INT_PTR | GetOverlayImageFilePath (LPTSTR pszString, size_t cchSize) const
BOOL | GetOverlayImageInfo (ACTC_IMAGE_INFO *pImageInfo) const
AcTcCatalogItem * | GetParent (void) const
int | GetParentDocumentDescription (LPTSTR pszString, int cchSize) const
int | GetParentDocumentName (LPTSTR pszString, int cchSize) const
int | GetParentDocumentUrl (LPTSTR pszString, int cchSize) const
int | GetPublisherCountry (LPTSTR pszString, int cchSize) const
int | GetPublisherDescription (LPTSTR pszString, int cchSize) const
int | GetPublisherEmail (LPTSTR pszString, int cchSize) const
int | GetPublisherName (LPTSTR pszString, int cchSize) const
int | GetPublisherUrl (LPTSTR pszString, int cchSize) const
int | GetReferencePath (LPTSTR pszString, int cchSize, int nFlag) const
BOOL | GetRefresh (void) const
AcTcCatalogItem * | GetRoot (void) const
AcTcScheme * | GetScheme (void) const
BOOL | GetSourceID (GUID *pId) const
int | GetSourceUrl (LPTSTR pszString, int cchSize) const
virtual int | GetTagName (LPTSTR pszString, int cchSize) const
BOOL | GetTargetProduct (INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const
INT_PTR | GetTargetProductCount (void) const
BOOL | GetTime (time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const
int | GetToolTipText (LPTSTR pszString, int cchSize) const
virtual CatalogItemType | GetType (void) const
virtual int | GetTypeString (LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const
int | GetUrl (LPTSTR pszString, int cchSize) const
int | GetXml (LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | HasChildren (void) const
INT_PTR | InsertChild (INT_PTR iIndex, AcTcCatalogItem *pNewItem)
BOOL | IsLink (void) const
BOOL | IsLinkLoaded (void) const
BOOL | IsReadOnly (void) const
BOOL | IsRoot (void) const
virtual BOOL | IsValidChild (const CatalogItemType nType) const
BOOL | IsValidForProduct (LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0)
BOOL | Load (LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IStream *pStream, DWORD dwLoadOption=kLoadLinks)
BOOL | LoadLink (void)
virtual AcTcCatalogItem & | operator= (const AcTcCatalogItem &srcItem)
virtual BOOL | Refresh (DWORD dwRefreshFlag=kRefreshAll)
BOOL | RemoveReactor (AcTcCatalogItemReactor *pReactor)
virtual BOOL | Reset (void)
BOOL | Save (LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | SetAccessRight (AcTc::AccessRight nAccessRight)
BOOL | SetAutoRefresh (BOOL bAutoRefresh)
BOOL | SetDescription (LPCTSTR pszString)
BOOL | SetHelpInfo (LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData)
BOOL | SetID (const GUID *pId)
BOOL | SetItemOrder (AcTcCatalogItem **pItems, INT_PTR nNumItems)
BOOL | SetKeywords (LPCTSTR pszString)
BOOL | SetLinkUrl (LPCTSTR pszString)
BOOL | SetName (LPCTSTR pszString)
BOOL | SetNewID (BOOL bRecursive=FALSE)
BOOL | SetOption (AcTc::ItemOption nOption)
BOOL | SetOverlayImage (const AcTcImage *pImage)
BOOL | SetOverlayImageInfo (const ACTC_IMAGE_INFO *pImageInfo)
BOOL | SetParent (AcTcCatalogItem *pParent)
BOOL | SetParentDocumentDescription (LPCTSTR pszString)
BOOL | SetParentDocumentName (LPCTSTR pszString)
BOOL | SetParentDocumentUrl (LPCTSTR pszString)
BOOL | SetPublisherCountry (LPCTSTR pszString)
BOOL | SetPublisherDescription (LPCTSTR pszString)
BOOL | SetPublisherEmail (LPCTSTR pszString)
BOOL | SetPublisherName (LPCTSTR pszString)
BOOL | SetPublisherUrl (LPCTSTR pszString)
BOOL | SetReferencePath (LPCTSTR pszString, int nFlag)
BOOL | SetRefresh (BOOL bRefresh)
BOOL | SetSourceID (const GUID *pId)
BOOL | SetSourceUrl (LPCTSTR pszString)
BOOL | SetTime (const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed)
BOOL | SetToolTipText (LPCTSTR pszString)
BOOL | Sort (int nSortOption, BOOL bRecursive)

Protected Member Functions

AcTcCategory (AcTcSystemInternals *)
- Protected Member Functions inherited from AcTcCatalogItem
AcTcCatalogItem (AcTcSystemInternals *)
virtual AcTcCatalogItem * CreateObject (void) const

Additional Inherited Members

- Static Public Member Functions inherited from AcTcCatalogItem
static AcTcCatalogItem * | FromFile (LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks)
static CatalogItemType | GetType (LPCTSTR pszFile)
- Protected Attributes inherited from AcTcCatalogItem
void * | mpImpObj
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcCategory Member List

This is the complete list of members for AcTcCategory, including all inherited members.

AcTcCatalogItem(AcTcSystemInternals *) (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
AcTcCategory() (defined in AcTcCategory) | AcTcCategory |
AcTcCategory(const AcTcCategory &srcItem) (defined in AcTcCategory) | AcTcCategory |
AcTcCategory(AcTcSystemInternals *) (defined in AcTcCategory) | AcTcCategory | protected
AddChild(AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddTargetProduct(const ACTC_TARGET_PRODUCT_INFO *pProductInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
CanRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
Clone(BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CopyFrom(const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CreateObject(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | protectedvirtual
DeleteAllChildren(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteLinkFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteOverlayImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteTargetProduct(int iIndex) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DetachChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Download(LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(const GUID &id, BOOL bRecursive=TRUE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(LPCTSTR pszName) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FindInChildren(LPCTSTR pszName, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FromFile(LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetAccessRight(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetAutoRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChild(INT_PTR iIndex) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetCustomData(IUnknown **ppCustomData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetHelpInfo(LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImage(const SIZE *pSize) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageFilePath(INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageList(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetKeywords(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkFilePath(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLocalFile(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetNextChild(int iIndex, CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOption(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImage(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageFilePath(LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageInfo(ACTC_IMAGE_INFO *pImageInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParent(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherCountry(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherEmail(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetReferencePath(LPTSTR pszString, int cchSize, int nFlag) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetScheme(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTagName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTargetProduct(INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTargetProductCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTime(time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetToolTipText(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetType(LPCTSTR pszFile) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetType(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTypeString(LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetXml(LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
HasChildren(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
InsertChild(INT_PTR iIndex, AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLink(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLinkLoaded(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsReadOnly(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsValidChild(const CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
IsValidForProduct(LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Load(IStream *pStream, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
LoadLink(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
mpImpObj (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
operator=(const AcTcCatalogItem &srcItem) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Refresh(DWORD dwRefreshFlag=kRefreshAll) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
RemoveReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Reset(void) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Save(IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
SetAccessRight(AcTc::AccessRight nAccessRight) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetAutoRefresh(BOOL bAutoRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetHelpInfo(LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetItemOrder(AcTcCatalogItem **pItems, INT_PTR nNumItems) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetKeywords(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetLinkUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetNewID(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOption(AcTc::ItemOption nOption) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImage(const AcTcImage *pImage) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImageInfo(const ACTC_IMAGE_INFO *pImageInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParent(AcTcCatalogItem *pParent) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherCountry(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherEmail(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetReferencePath(LPCTSTR pszString, int nFlag) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetRefresh(BOOL bRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetTime(const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetToolTipText(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Sort(int nSortOption, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
~AcTcCatalogItem() (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
~AcTcCategory() (defined in AcTcCategory) | AcTcCategory | virtual


ZRX API Reference: AcTcImage Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
AcTcImage Class Reference

Public Member Functions

AcTcImage (const AcTcImage &srcImage)
BOOL | ConvertTo (AcTc::ImageType nToImageType, BOOL bTransparent)
BOOL | GetHBITMAP (COLORREF cBackGroundColor, HBITMAP &hBitmap)
BOOL | GetHICON (HICON &hIcon)
AcTc::ImageType | GetSaveType (void) const
BOOL | GetSize (LPSIZE pSize) const
AcTc::ImageType | GetType (void) const
BOOL | IsImageLoaded (void) const
BOOL | Load (LPCTSTR pszFile)
BOOL | Load (HBITMAP hBitmap)
BOOL | Load (IStream *pStream)
AcTcImage & | operator= (const AcTcImage &zcTcImage)
BOOL | Render (HDC hDC, int xPos, int yPos, int nWidth, int nHeight, UINT nStyle=ACTC_IMAGE_NORMAL, BOOL bTransparentBitmap=TRUE)
BOOL | Save (LPCTSTR pszFile)
BOOL | Save (LPCTSTR sFileName, AcTc::ImageType nSaveAsType)
BOOL | Save (IStream *pStream)
BOOL | SetSaveType (AcTc::ImageType nSaveType)

Protected Attributes

void * mpImpObj

Friends

class AcTcSystemInternals
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcImage Member List

This is the complete list of members for AcTcImage, including all inherited members.

AcTcImage() (defined in AcTcImage) | AcTcImage |
AcTcImage(const AcTcImage &srcImage) (defined in AcTcImage) | AcTcImage |
AcTcSystemInternals (defined in AcTcImage) | AcTcImage | friend
ConvertTo(AcTc::ImageType nToImageType, BOOL bTransparent) (defined in AcTcImage) | AcTcImage |
GetHBITMAP(COLORREF cBackGroundColor, HBITMAP &hBitmap) (defined in AcTcImage) | AcTcImage |
GetHICON(HICON &hIcon) (defined in AcTcImage) | AcTcImage |
GetSaveType(void) const (defined in AcTcImage) | AcTcImage |
GetSize(LPSIZE pSize) const (defined in AcTcImage) | AcTcImage |
GetType(void) const (defined in AcTcImage) | AcTcImage |
IsImageLoaded(void) const (defined in AcTcImage) | AcTcImage |
Load(LPCTSTR pszFile) (defined in AcTcImage) | AcTcImage |
Load(HBITMAP hBitmap) (defined in AcTcImage) | AcTcImage |
Load(IStream *pStream) (defined in AcTcImage) | AcTcImage |
mpImpObj (defined in AcTcImage) | AcTcImage | protected
operator=(const AcTcImage &zcTcImage) (defined in AcTcImage) | AcTcImage |
Render(HDC hDC, int xPos, int yPos, int nWidth, int nHeight, UINT nStyle=ACTC_IMAGE_NORMAL, BOOL bTransparentBitmap=TRUE) (defined in AcTcImage) | AcTcImage |
Save(LPCTSTR pszFile) (defined in AcTcImage) | AcTcImage |
Save(LPCTSTR sFileName, AcTc::ImageType nSaveAsType) (defined in AcTcImage) | AcTcImage |
Save(IStream *pStream) (defined in AcTcImage) | AcTcImage |
SetSaveType(AcTc::ImageType nSaveType) (defined in AcTcImage) | AcTcImage |
~AcTcImage() (defined in AcTcImage) | AcTcImage | virtual


ZRX API Reference: AcTcImageList Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
AcTcImageList Class Reference

Public Member Functions

INT_PTR | Add (const AcTcImage *pImage)
INT_PTR | Add (const ACTC_IMAGE_INFO *pImageInfo)
BOOL | Delete (INT_PTR iIndex)
BOOL | DeleteAllImages (void)
AcTcImage * | GetImage (INT_PTR iIndex)
INT_PTR | GetImageCount (void) const
INT_PTR | GetImageIndex (const SIZE *pSize, BOOL bExactMatch=FALSE)
BOOL | GetImageInfo (INT_PTR iIndex, ACTC_IMAGE_INFO *pImageInfo) const
AcTc::ImageOption | GetOption (void) const
BOOL | LoadImage (INT_PTR iIndex)
AcTcImageList & | operator= (const AcTcImageList &zcTcImageList)
INT_PTR | SetImage (INT_PTR iIndex, const AcTcImage *pImage)
BOOL | SetImageInfo (INT_PTR iIndex, const ACTC_IMAGE_INFO *pImageInfo)
BOOL | SetOption (AcTc::ImageOption nOption)
INT_PTR | UpdateImage (const AcTcImage *pImage)

Protected Member Functions

AcTcImageList (AcTcCatalogItem *pCatalogItem)

Protected Attributes

void * mpImpObj

Friends

class AcTcSystemInternals
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcImageList Member List

This is the complete list of members for AcTcImageList, including all inherited members.

AcTcImageList(AcTcCatalogItem *pCatalogItem) (defined in AcTcImageList) | AcTcImageList | protected
AcTcSystemInternals (defined in AcTcImageList) | AcTcImageList | friend
Add(const AcTcImage *pImage) (defined in AcTcImageList) | AcTcImageList |
Add(const ACTC_IMAGE_INFO *pImageInfo) (defined in AcTcImageList) | AcTcImageList |
Delete(INT_PTR iIndex) (defined in AcTcImageList) | AcTcImageList |
DeleteAllImages(void) (defined in AcTcImageList) | AcTcImageList |
GetImage(INT_PTR iIndex) (defined in AcTcImageList) | AcTcImageList |
GetImageCount(void) const (defined in AcTcImageList) | AcTcImageList |
GetImageIndex(const SIZE *pSize, BOOL bExactMatch=FALSE) (defined in AcTcImageList) | AcTcImageList |
GetImageInfo(INT_PTR iIndex, ACTC_IMAGE_INFO *pImageInfo) const (defined in AcTcImageList) | AcTcImageList |
GetOption(void) const (defined in AcTcImageList) | AcTcImageList |
LoadImage(INT_PTR iIndex) (defined in AcTcImageList) | AcTcImageList |
mpImpObj (defined in AcTcImageList) | AcTcImageList | protected
operator=(const AcTcImageList &zcTcImageList) (defined in AcTcImageList) | AcTcImageList |
SetImage(INT_PTR iIndex, const AcTcImage *pImage) (defined in AcTcImageList) | AcTcImageList |
SetImageInfo(INT_PTR iIndex, const ACTC_IMAGE_INFO *pImageInfo) (defined in AcTcImageList) | AcTcImageList |
SetOption(AcTc::ImageOption nOption) (defined in AcTcImageList) | AcTcImageList |
UpdateImage(const AcTcImage *pImage) (defined in AcTcImageList) | AcTcImageList |
~AcTcImageList() (defined in AcTcImageList) | AcTcImageList | virtual


ZRX API Reference: AcTcManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
AcTcManager Class Reference

Public Member Functions

INT_PTR | AddCatalog (AcTcCatalogItem *pCatalogItem)
INT_PTR | AddScheme (AcTcScheme *pScheme)
INT_PTR | AddStockToolCatalog (AcTcCatalogItem *pCatalogItem)
AcTcCatalogItem * | FindItem (const GUID &id) const
AcTcStockTool * | FindStockTool (const GUID &id) const
AcTcCatalogItem * | GetCatalog (int nIndex) const
INT_PTR | GetCatalogCount (void) const
int | GetCatalogPath (LPTSTR pszString, int cchSize) const
AcTcScheme * | GetScheme (int nIndex) const
AcTcScheme * | GetScheme (LPCTSTR pszSchemeName) const
INT_PTR | GetSchemeCount (void) const
AcTcCatalogItem * | GetShapeCatalog (void)
int | GetShapeCatalogFile (LPTSTR pszString, int cchSize) const
AcTcCatalogItem * | GetShapePackage (LPCTSTR lpszName=NULL) const
AcTcCatalogItem * | GetStockToolCatalog (int nIndex) const
INT_PTR | GetStockToolCatalogCount (void) const
int | GetStockToolCatalogPath (LPTSTR pszString, int cchSize) const
INT_PTR | InsertStockToolCatalog (INT_PTR nIndex, AcTcCatalogItem *pCatalog)
BOOL | LoadCatalogs (DWORD dwCatalogType=kCatalog|kStockToolCatalog, DWORD dwLoadOption=kLoadLinks)
BOOL | RemoveScheme (AcTcScheme *pScheme)
AcTcCatalogItem * | RemoveStockToolCatalog (int nIndex)
BOOL | SaveCatalogs (DWORD dwCatalogType=kCatalog|kStockToolCatalog, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | SetCatalogPath (LPCTSTR pszPath)
BOOL | SetShapeCatalogFile (LPCTSTR pszFile)
BOOL | SetStockToolCatalogPath (LPCTSTR pszPath)
BOOL | UnloadCatalogs (DWORD dwCatalogType=kCatalog|kStockToolCatalog)

Protected Attributes

void * mpImpObj

Friends

class AcTcSystemInternals
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcManager Member List

This is the complete list of members for AcTcManager, including all inherited members.

AcTcManager() (defined in AcTcManager) | AcTcManager |
AcTcSystemInternals (defined in AcTcManager) | AcTcManager | friend
AddCatalog(AcTcCatalogItem *pCatalogItem) (defined in AcTcManager) | AcTcManager |
AddScheme(AcTcScheme *pScheme) (defined in AcTcManager) | AcTcManager |
AddStockToolCatalog(AcTcCatalogItem *pCatalogItem) (defined in AcTcManager) | AcTcManager |
FindItem(const GUID &id) const (defined in AcTcManager) | AcTcManager |
FindStockTool(const GUID &id) const (defined in AcTcManager) | AcTcManager |
GetCatalog(int nIndex) const (defined in AcTcManager) | AcTcManager |
GetCatalogCount(void) const (defined in AcTcManager) | AcTcManager |
GetCatalogPath(LPTSTR pszString, int cchSize) const (defined in AcTcManager) | AcTcManager |
GetScheme(int nIndex) const (defined in AcTcManager) | AcTcManager |
GetScheme(LPCTSTR pszSchemeName) const (defined in AcTcManager) | AcTcManager |
GetSchemeCount(void) const (defined in AcTcManager) | AcTcManager |
GetShapeCatalog(void) (defined in AcTcManager) | AcTcManager |
GetShapeCatalogFile(LPTSTR pszString, int cchSize) const (defined in AcTcManager) | AcTcManager |
GetShapePackage(LPCTSTR lpszName=NULL) const (defined in AcTcManager) | AcTcManager |
GetStockToolCatalog(int nIndex) const (defined in AcTcManager) | AcTcManager |
GetStockToolCatalogCount(void) const (defined in AcTcManager) | AcTcManager |
GetStockToolCatalogPath(LPTSTR pszString, int cchSize) const (defined in AcTcManager) | AcTcManager |
InsertStockToolCatalog(INT_PTR nIndex, AcTcCatalogItem *pCatalog) (defined in AcTcManager) | AcTcManager |
LoadCatalogs(DWORD dwCatalogType=kCatalog|kStockToolCatalog, DWORD dwLoadOption=kLoadLinks) (defined in AcTcManager) | AcTcManager |
mpImpObj (defined in AcTcManager) | AcTcManager | protected
RemoveScheme(AcTcScheme *pScheme) (defined in AcTcManager) | AcTcManager |
RemoveStockToolCatalog(int nIndex) (defined in AcTcManager) | AcTcManager |
SaveCatalogs(DWORD dwCatalogType=kCatalog|kStockToolCatalog, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcManager) | AcTcManager |
SetCatalogPath(LPCTSTR pszPath) (defined in AcTcManager) | AcTcManager |
SetShapeCatalogFile(LPCTSTR pszFile) (defined in AcTcManager) | AcTcManager |
SetStockToolCatalogPath(LPCTSTR pszPath) (defined in AcTcManager) | AcTcManager |
UnloadCatalogs(DWORD dwCatalogType=kCatalog|kStockToolCatalog) (defined in AcTcManager) | AcTcManager |
~AcTcManager() (defined in AcTcManager) | AcTcManager | virtual


ZRX API Reference: AcTcPackage Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcTcPackage Class Reference
+ Inheritance diagram for AcTcPackage:

Public Member Functions

AcTcPackage (const AcTcPackage &srcItem)
- Public Member Functions inherited from AcTcCatalogItem
INT_PTR | AddChild (AcTcCatalogItem *pNewItem)
BOOL | AddReactor (AcTcCatalogItemReactor *pReactor)
INT_PTR | AddTargetProduct (const ACTC_TARGET_PRODUCT_INFO *pProductInfo)
BOOL | CanRefresh (void) const
virtual BOOL | Clone (BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const
virtual BOOL | CopyFrom (const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE)
BOOL | DeleteAllChildren (void)
BOOL | DeleteChild (AcTcCatalogItem *pItem)
BOOL | DeleteImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteLinkFile (BOOL bRecursive=FALSE)
BOOL | DeleteOverlayImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteTargetProduct (int iIndex)
BOOL | DetachChild (AcTcCatalogItem *pItem)
virtual BOOL | Download (LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL)
virtual AcTcCatalogItem * | FindInChildren (const GUID &id, BOOL bRecursive=TRUE)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName, BOOL bRecursive)
AcTc::AccessRight | GetAccessRight (void) const
BOOL | GetAutoRefresh (void) const
AcTcCatalogItem * | GetChild (INT_PTR iIndex) const
INT_PTR | GetChildCount (void) const
INT_PTR | GetChildCount (CatalogItemType nType) const
BOOL | GetCustomData (IUnknown **ppCustomData)
int | GetDescription (LPTSTR pszString, int cchSize) const
BOOL | GetHelpInfo (LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const
BOOL | GetID (GUID *pId) const
AcTcImage * | GetImage (const SIZE *pSize)
INT_PTR | GetImageFilePath (INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const
AcTcImageList * | GetImageList (void) const
int | GetKeywords (LPTSTR pszString, int cchSize) const
int | GetLinkFilePath (LPTSTR pszString, int cchSize) const
int | GetLinkUrl (LPTSTR pszString, int cchSize) const
int | GetLocalFile (LPTSTR pszString, int cchSize) const
int | GetName (LPTSTR pszString, int cchSize) const
AcTcCatalogItem * | GetNextChild (int iIndex, CatalogItemType nType) const
AcTc::ItemOption | GetOption (void) const
AcTcImage * | GetOverlayImage (void) const
INT_PTR | GetOverlayImageFilePath (LPTSTR pszString, size_t cchSize) const
BOOL | GetOverlayImageInfo (ACTC_IMAGE_INFO *pImageInfo) const
AcTcCatalogItem * | GetParent (void) const
int | GetParentDocumentDescription (LPTSTR pszString, int cchSize) const
int | GetParentDocumentName (LPTSTR pszString, int cchSize) const
int | GetParentDocumentUrl (LPTSTR pszString, int cchSize) const
int | GetPublisherCountry (LPTSTR pszString, int cchSize) const
int | GetPublisherDescription (LPTSTR pszString, int cchSize) const
int | GetPublisherEmail (LPTSTR pszString, int cchSize) const
int | GetPublisherName (LPTSTR pszString, int cchSize) const
int | GetPublisherUrl (LPTSTR pszString, int cchSize) const
int | GetReferencePath (LPTSTR pszString, int cchSize, int nFlag) const
BOOL | GetRefresh (void) const
AcTcCatalogItem * | GetRoot (void) const
AcTcScheme * | GetScheme (void) const
BOOL | GetSourceID (GUID *pId) const
int | GetSourceUrl (LPTSTR pszString, int cchSize) const
virtual int | GetTagName (LPTSTR pszString, int cchSize) const
BOOL | GetTargetProduct (INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const
INT_PTR | GetTargetProductCount (void) const
BOOL | GetTime (time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const
int | GetToolTipText (LPTSTR pszString, int cchSize) const
virtual CatalogItemType | GetType (void) const
virtual int | GetTypeString (LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const
int | GetUrl (LPTSTR pszString, int cchSize) const
int | GetXml (LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | HasChildren (void) const
INT_PTR | InsertChild (INT_PTR iIndex, AcTcCatalogItem *pNewItem)
BOOL | IsLink (void) const
BOOL | IsLinkLoaded (void) const
BOOL | IsReadOnly (void) const
BOOL | IsRoot (void) const
virtual BOOL | IsValidChild (const CatalogItemType nType) const
BOOL | IsValidForProduct (LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0)
BOOL | Load (LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IStream *pStream, DWORD dwLoadOption=kLoadLinks)
BOOL | LoadLink (void)
virtual AcTcCatalogItem & | operator= (const AcTcCatalogItem &srcItem)
virtual BOOL | Refresh (DWORD dwRefreshFlag=kRefreshAll)
BOOL | RemoveReactor (AcTcCatalogItemReactor *pReactor)
virtual BOOL | Reset (void)
BOOL | Save (LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | SetAccessRight (AcTc::AccessRight nAccessRight)
BOOL | SetAutoRefresh (BOOL bAutoRefresh)
BOOL | SetDescription (LPCTSTR pszString)
BOOL | SetHelpInfo (LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData)
BOOL | SetID (const GUID *pId)
BOOL | SetItemOrder (AcTcCatalogItem **pItems, INT_PTR nNumItems)
BOOL | SetKeywords (LPCTSTR pszString)
BOOL | SetLinkUrl (LPCTSTR pszString)
BOOL | SetName (LPCTSTR pszString)
BOOL | SetNewID (BOOL bRecursive=FALSE)
BOOL | SetOption (AcTc::ItemOption nOption)
BOOL | SetOverlayImage (const AcTcImage *pImage)
BOOL | SetOverlayImageInfo (const ACTC_IMAGE_INFO *pImageInfo)
BOOL | SetParent (AcTcCatalogItem *pParent)
BOOL | SetParentDocumentDescription (LPCTSTR pszString)
BOOL | SetParentDocumentName (LPCTSTR pszString)
BOOL | SetParentDocumentUrl (LPCTSTR pszString)
BOOL | SetPublisherCountry (LPCTSTR pszString)
BOOL | SetPublisherDescription (LPCTSTR pszString)
BOOL | SetPublisherEmail (LPCTSTR pszString)
BOOL | SetPublisherName (LPCTSTR pszString)
BOOL | SetPublisherUrl (LPCTSTR pszString)
BOOL | SetReferencePath (LPCTSTR pszString, int nFlag)
BOOL | SetRefresh (BOOL bRefresh)
BOOL | SetSourceID (const GUID *pId)
BOOL | SetSourceUrl (LPCTSTR pszString)
BOOL | SetTime (const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed)
BOOL | SetToolTipText (LPCTSTR pszString)
BOOL | Sort (int nSortOption, BOOL bRecursive)

Protected Member Functions

AcTcPackage (AcTcSystemInternals *)
- Protected Member Functions inherited from AcTcCatalogItem
AcTcCatalogItem (AcTcSystemInternals *)
virtual AcTcCatalogItem * CreateObject (void) const

Additional Inherited Members

- Static Public Member Functions inherited from AcTcCatalogItem
static AcTcCatalogItem * | FromFile (LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks)
static CatalogItemType | GetType (LPCTSTR pszFile)
- Protected Attributes inherited from AcTcCatalogItem
void * | mpImpObj
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcPackage Member List

This is the complete list of members for AcTcPackage, including all inherited members.

AcTcCatalogItem(AcTcSystemInternals *) (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
AcTcPackage() (defined in AcTcPackage) | AcTcPackage |
AcTcPackage(const AcTcPackage &srcItem) (defined in AcTcPackage) | AcTcPackage |
AcTcPackage(AcTcSystemInternals *) (defined in AcTcPackage) | AcTcPackage | protected
AddChild(AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddTargetProduct(const ACTC_TARGET_PRODUCT_INFO *pProductInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
CanRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
Clone(BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CopyFrom(const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CreateObject(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | protectedvirtual
DeleteAllChildren(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteLinkFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteOverlayImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteTargetProduct(int iIndex) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DetachChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Download(LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(const GUID &id, BOOL bRecursive=TRUE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(LPCTSTR pszName) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FindInChildren(LPCTSTR pszName, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FromFile(LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetAccessRight(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetAutoRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChild(INT_PTR iIndex) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetCustomData(IUnknown **ppCustomData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetHelpInfo(LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImage(const SIZE *pSize) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageFilePath(INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageList(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetKeywords(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkFilePath(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLocalFile(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetNextChild(int iIndex, CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOption(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImage(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageFilePath(LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageInfo(ACTC_IMAGE_INFO *pImageInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParent(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherCountry(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherEmail(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetReferencePath(LPTSTR pszString, int cchSize, int nFlag) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetScheme(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTagName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTargetProduct(INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTargetProductCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTime(time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetToolTipText(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetType(LPCTSTR pszFile) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetType(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTypeString(LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetXml(LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
HasChildren(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
InsertChild(INT_PTR iIndex, AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLink(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLinkLoaded(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsReadOnly(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsValidChild(const CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
IsValidForProduct(LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Load(IStream *pStream, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
LoadLink(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
mpImpObj (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
operator=(const AcTcCatalogItem &srcItem) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Refresh(DWORD dwRefreshFlag=kRefreshAll) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
RemoveReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Reset(void) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Save(IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
SetAccessRight(AcTc::AccessRight nAccessRight) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetAutoRefresh(BOOL bAutoRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetHelpInfo(LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetItemOrder(AcTcCatalogItem **pItems, INT_PTR nNumItems) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetKeywords(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetLinkUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetNewID(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOption(AcTc::ItemOption nOption) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImage(const AcTcImage *pImage) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImageInfo(const ACTC_IMAGE_INFO *pImageInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParent(AcTcCatalogItem *pParent) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherCountry(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherEmail(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetReferencePath(LPCTSTR pszString, int nFlag) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetRefresh(BOOL bRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetTime(const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetToolTipText(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Sort(int nSortOption, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
~AcTcCatalogItem() (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
~AcTcPackage() (defined in AcTcPackage) | AcTcPackage | virtual


ZRX API Reference: AcTcPalette Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcTcPalette Class Reference
+ Inheritance diagram for AcTcPalette:

Public Member Functions

AcTcPalette (const AcTcPalette &srcItem)
- Public Member Functions inherited from AcTcPackage
AcTcPackage (const AcTcPackage &srcItem)
- Public Member Functions inherited from AcTcCatalogItem
INT_PTR | AddChild (AcTcCatalogItem *pNewItem)
BOOL | AddReactor (AcTcCatalogItemReactor *pReactor)
INT_PTR | AddTargetProduct (const ACTC_TARGET_PRODUCT_INFO *pProductInfo)
BOOL | CanRefresh (void) const
virtual BOOL | Clone (BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const
virtual BOOL | CopyFrom (const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE)
BOOL | DeleteAllChildren (void)
BOOL | DeleteChild (AcTcCatalogItem *pItem)
BOOL | DeleteImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteLinkFile (BOOL bRecursive=FALSE)
BOOL | DeleteOverlayImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteTargetProduct (int iIndex)
BOOL | DetachChild (AcTcCatalogItem *pItem)
virtual BOOL | Download (LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL)
virtual AcTcCatalogItem * | FindInChildren (const GUID &id, BOOL bRecursive=TRUE)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName, BOOL bRecursive)
AcTc::AccessRight | GetAccessRight (void) const
BOOL | GetAutoRefresh (void) const
AcTcCatalogItem * | GetChild (INT_PTR iIndex) const
INT_PTR | GetChildCount (void) const
INT_PTR | GetChildCount (CatalogItemType nType) const
BOOL | GetCustomData (IUnknown **ppCustomData)
int | GetDescription (LPTSTR pszString, int cchSize) const
BOOL | GetHelpInfo (LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const
BOOL | GetID (GUID *pId) const
AcTcImage * | GetImage (const SIZE *pSize)
INT_PTR | GetImageFilePath (INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const
AcTcImageList * | GetImageList (void) const
int | GetKeywords (LPTSTR pszString, int cchSize) const
int | GetLinkFilePath (LPTSTR pszString, int cchSize) const
int | GetLinkUrl (LPTSTR pszString, int cchSize) const
int | GetLocalFile (LPTSTR pszString, int cchSize) const
int | GetName (LPTSTR pszString, int cchSize) const
AcTcCatalogItem * | GetNextChild (int iIndex, CatalogItemType nType) const
AcTc::ItemOption | GetOption (void) const
AcTcImage * | GetOverlayImage (void) const
INT_PTR | GetOverlayImageFilePath (LPTSTR pszString, size_t cchSize) const
BOOL | GetOverlayImageInfo (ACTC_IMAGE_INFO *pImageInfo) const
AcTcCatalogItem * | GetParent (void) const
int | GetParentDocumentDescription (LPTSTR pszString, int cchSize) const
int | GetParentDocumentName (LPTSTR pszString, int cchSize) const
int | GetParentDocumentUrl (LPTSTR pszString, int cchSize) const
int | GetPublisherCountry (LPTSTR pszString, int cchSize) const
int | GetPublisherDescription (LPTSTR pszString, int cchSize) const
int | GetPublisherEmail (LPTSTR pszString, int cchSize) const
int | GetPublisherName (LPTSTR pszString, int cchSize) const
int | GetPublisherUrl (LPTSTR pszString, int cchSize) const
int | GetReferencePath (LPTSTR pszString, int cchSize, int nFlag) const
BOOL | GetRefresh (void) const
AcTcCatalogItem * | GetRoot (void) const
AcTcScheme * | GetScheme (void) const
BOOL | GetSourceID (GUID *pId) const
int | GetSourceUrl (LPTSTR pszString, int cchSize) const
virtual int | GetTagName (LPTSTR pszString, int cchSize) const
BOOL | GetTargetProduct (INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const
INT_PTR | GetTargetProductCount (void) const
BOOL | GetTime (time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const
int | GetToolTipText (LPTSTR pszString, int cchSize) const
virtual CatalogItemType | GetType (void) const
virtual int | GetTypeString (LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const
int | GetUrl (LPTSTR pszString, int cchSize) const
int | GetXml (LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | HasChildren (void) const
INT_PTR | InsertChild (INT_PTR iIndex, AcTcCatalogItem *pNewItem)
BOOL | IsLink (void) const
BOOL | IsLinkLoaded (void) const
BOOL | IsReadOnly (void) const
BOOL | IsRoot (void) const
virtual BOOL | IsValidChild (const CatalogItemType nType) const
BOOL | IsValidForProduct (LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0)
BOOL | Load (LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IStream *pStream, DWORD dwLoadOption=kLoadLinks)
BOOL | LoadLink (void)
virtual AcTcCatalogItem & | operator= (const AcTcCatalogItem &srcItem)
virtual BOOL | Refresh (DWORD dwRefreshFlag=kRefreshAll)
BOOL | RemoveReactor (AcTcCatalogItemReactor *pReactor)
virtual BOOL | Reset (void)
BOOL | Save (LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | SetAccessRight (AcTc::AccessRight nAccessRight)
BOOL | SetAutoRefresh (BOOL bAutoRefresh)
BOOL | SetDescription (LPCTSTR pszString)
BOOL | SetHelpInfo (LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData)
BOOL | SetID (const GUID *pId)
BOOL | SetItemOrder (AcTcCatalogItem **pItems, INT_PTR nNumItems)
BOOL | SetKeywords (LPCTSTR pszString)
BOOL | SetLinkUrl (LPCTSTR pszString)
BOOL | SetName (LPCTSTR pszString)
BOOL | SetNewID (BOOL bRecursive=FALSE)
BOOL | SetOption (AcTc::ItemOption nOption)
BOOL | SetOverlayImage (const AcTcImage *pImage)
BOOL | SetOverlayImageInfo (const ACTC_IMAGE_INFO *pImageInfo)
BOOL | SetParent (AcTcCatalogItem *pParent)
BOOL | SetParentDocumentDescription (LPCTSTR pszString)
BOOL | SetParentDocumentName (LPCTSTR pszString)
BOOL | SetParentDocumentUrl (LPCTSTR pszString)
BOOL | SetPublisherCountry (LPCTSTR pszString)
BOOL | SetPublisherDescription (LPCTSTR pszString)
BOOL | SetPublisherEmail (LPCTSTR pszString)
BOOL | SetPublisherName (LPCTSTR pszString)
BOOL | SetPublisherUrl (LPCTSTR pszString)
BOOL | SetReferencePath (LPCTSTR pszString, int nFlag)
BOOL | SetRefresh (BOOL bRefresh)
BOOL | SetSourceID (const GUID *pId)
BOOL | SetSourceUrl (LPCTSTR pszString)
BOOL | SetTime (const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed)
BOOL | SetToolTipText (LPCTSTR pszString)
BOOL | Sort (int nSortOption, BOOL bRecursive)

Protected Member Functions

AcTcPalette (AcTcSystemInternals *)
- Protected Member Functions inherited from AcTcPackage
AcTcPackage (AcTcSystemInternals *)
- Protected Member Functions inherited from AcTcCatalogItem
AcTcCatalogItem (AcTcSystemInternals *)
virtual AcTcCatalogItem * CreateObject (void) const

Additional Inherited Members

- Static Public Member Functions inherited from AcTcCatalogItem
static AcTcCatalogItem * | FromFile (LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks)
static CatalogItemType | GetType (LPCTSTR pszFile)
- Protected Attributes inherited from AcTcCatalogItem
void * | mpImpObj
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcPalette Member List

This is the complete list of members for AcTcPalette, including all inherited members.

AcTcCatalogItem(AcTcSystemInternals *) (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
AcTcPackage() (defined in AcTcPackage) | AcTcPackage |
AcTcPackage(const AcTcPackage &srcItem) (defined in AcTcPackage) | AcTcPackage |
AcTcPackage(AcTcSystemInternals *) (defined in AcTcPackage) | AcTcPackage | protected
AcTcPalette() (defined in AcTcPalette) | AcTcPalette |
AcTcPalette(const AcTcPalette &srcItem) (defined in AcTcPalette) | AcTcPalette |
AcTcPalette(AcTcSystemInternals *) (defined in AcTcPalette) | AcTcPalette | protected
AddChild(AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddTargetProduct(const ACTC_TARGET_PRODUCT_INFO *pProductInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
CanRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
Clone(BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CopyFrom(const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CreateObject(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | protectedvirtual
DeleteAllChildren(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteLinkFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteOverlayImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteTargetProduct(int iIndex) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DetachChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Download(LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(const GUID &id, BOOL bRecursive=TRUE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(LPCTSTR pszName) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FindInChildren(LPCTSTR pszName, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FromFile(LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetAccessRight(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetAutoRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChild(INT_PTR iIndex) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetCustomData(IUnknown **ppCustomData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetHelpInfo(LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImage(const SIZE *pSize) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageFilePath(INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageList(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetKeywords(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkFilePath(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLocalFile(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetNextChild(int iIndex, CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOption(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImage(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageFilePath(LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageInfo(ACTC_IMAGE_INFO *pImageInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParent(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherCountry(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherEmail(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetReferencePath(LPTSTR pszString, int cchSize, int nFlag) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetScheme(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTagName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTargetProduct(INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTargetProductCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTime(time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetToolTipText(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetType(LPCTSTR pszFile) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetType(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTypeString(LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetXml(LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
HasChildren(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
InsertChild(INT_PTR iIndex, AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLink(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLinkLoaded(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsReadOnly(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsValidChild(const CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
IsValidForProduct(LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Load(IStream *pStream, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
LoadLink(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
mpImpObj (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
operator=(const AcTcCatalogItem &srcItem) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Refresh(DWORD dwRefreshFlag=kRefreshAll) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
RemoveReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Reset(void) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Save(IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
SetAccessRight(AcTc::AccessRight nAccessRight) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetAutoRefresh(BOOL bAutoRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetHelpInfo(LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetItemOrder(AcTcCatalogItem **pItems, INT_PTR nNumItems) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetKeywords(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetLinkUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetNewID(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOption(AcTc::ItemOption nOption) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImage(const AcTcImage *pImage) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImageInfo(const ACTC_IMAGE_INFO *pImageInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParent(AcTcCatalogItem *pParent) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherCountry(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherEmail(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetReferencePath(LPCTSTR pszString, int nFlag) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetRefresh(BOOL bRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetTime(const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetToolTipText(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Sort(int nSortOption, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
~AcTcCatalogItem() (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
~AcTcPackage() (defined in AcTcPackage) | AcTcPackage | virtual
~AcTcPalette() (defined in AcTcPalette) | AcTcPalette | virtual


ZRX API Reference: AcTcScheme Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
AcTcScheme Class Reference

Public Member Functions

AcTcScheme (LPCTSTR pszSchemeName)
AcTcCatalogItem * | FindItem (const GUID &id) const
AcTcCatalogItem * | FindItem (const GUID &id, DWORD dwCatalogType) const
AcTcCatalogSet * | GetCatalogSet (DWORD dwCatalogType) const
int | GetName (LPTSTR pszString, int cchSize) const
BOOL | LoadCatalogs (void)
BOOL | LoadCatalogs (DWORD dwCatalogType, DWORD dwLoadOption)
BOOL | SaveCatalogs (void)
BOOL | SaveCatalogs (DWORD dwCatalogType, DWORD dwSaveOption)
BOOL | SetName (LPCTSTR pszString)
BOOL | UnloadCatalogs (void)
BOOL | UnloadCatalogs (DWORD dwCatalogType)

Protected Attributes

void * mpImpObj

Friends

class AcTcSystemInternals
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcScheme Member List

This is the complete list of members for AcTcScheme, including all inherited members.

AcTcScheme(LPCTSTR pszSchemeName) (defined in AcTcScheme) | AcTcScheme |
AcTcSystemInternals (defined in AcTcScheme) | AcTcScheme | friend
FindItem(const GUID &id) const (defined in AcTcScheme) | AcTcScheme |
FindItem(const GUID &id, DWORD dwCatalogType) const (defined in AcTcScheme) | AcTcScheme |
GetCatalogSet(DWORD dwCatalogType) const (defined in AcTcScheme) | AcTcScheme |
GetName(LPTSTR pszString, int cchSize) const (defined in AcTcScheme) | AcTcScheme |
LoadCatalogs(void) (defined in AcTcScheme) | AcTcScheme |
LoadCatalogs(DWORD dwCatalogType, DWORD dwLoadOption) (defined in AcTcScheme) | AcTcScheme |
mpImpObj (defined in AcTcScheme) | AcTcScheme | protected
SaveCatalogs(void) (defined in AcTcScheme) | AcTcScheme |
SaveCatalogs(DWORD dwCatalogType, DWORD dwSaveOption) (defined in AcTcScheme) | AcTcScheme |
SetName(LPCTSTR pszString) (defined in AcTcScheme) | AcTcScheme |
UnloadCatalogs(void) (defined in AcTcScheme) | AcTcScheme |
UnloadCatalogs(DWORD dwCatalogType) (defined in AcTcScheme) | AcTcScheme |
~AcTcScheme() (defined in AcTcScheme) | AcTcScheme | virtual


ZRX API Reference: AcTcStockTool Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Friends | List of all members
AcTcStockTool Class Reference
+ Inheritance diagram for AcTcStockTool:

Public Member Functions

AcTcStockTool (const AcTcStockTool &srcItem)
BOOL | CreateAcadStockTool (IUnknown **ppStockTool)
BOOL | CreateAcadTool (IUnknown **ppUnknown)
AcTcTool * | CreateTool (BOOL bSetDefaults=TRUE)
BOOL | GetComClassID (CLSID &clsid) const
int | GetModuleFileName (LPTSTR pszString, int cchSize) const
int | GetModuleInstallArguments (LPTSTR pszString, int cchSize) const
int | GetModuleInstallUrl (LPTSTR pszString, int cchSize) const
BOOL | SetComClassID (const CLSID &clsid)
BOOL | SetModuleFileName (LPCTSTR pszString)
BOOL | SetModuleInstallArguments (LPCTSTR pszString)
BOOL | SetModuleInstallUrl (LPCTSTR pszString)
- Public Member Functions inherited from AcTcCatalogItem
INT_PTR | AddChild (AcTcCatalogItem *pNewItem)
BOOL | AddReactor (AcTcCatalogItemReactor *pReactor)
INT_PTR | AddTargetProduct (const ACTC_TARGET_PRODUCT_INFO *pProductInfo)
BOOL | CanRefresh (void) const
virtual BOOL | Clone (BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const
virtual BOOL | CopyFrom (const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE)
BOOL | DeleteAllChildren (void)
BOOL | DeleteChild (AcTcCatalogItem *pItem)
BOOL | DeleteImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteLinkFile (BOOL bRecursive=FALSE)
BOOL | DeleteOverlayImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteTargetProduct (int iIndex)
BOOL | DetachChild (AcTcCatalogItem *pItem)
virtual BOOL | Download (LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL)
virtual AcTcCatalogItem * | FindInChildren (const GUID &id, BOOL bRecursive=TRUE)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName, BOOL bRecursive)
AcTc::AccessRight | GetAccessRight (void) const
BOOL | GetAutoRefresh (void) const
AcTcCatalogItem * | GetChild (INT_PTR iIndex) const
INT_PTR | GetChildCount (void) const
INT_PTR | GetChildCount (CatalogItemType nType) const
BOOL | GetCustomData (IUnknown **ppCustomData)
int | GetDescription (LPTSTR pszString, int cchSize) const
BOOL | GetHelpInfo (LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const
BOOL | GetID (GUID *pId) const
AcTcImage * | GetImage (const SIZE *pSize)
INT_PTR | GetImageFilePath (INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const
AcTcImageList * | GetImageList (void) const
int | GetKeywords (LPTSTR pszString, int cchSize) const
int | GetLinkFilePath (LPTSTR pszString, int cchSize) const
int | GetLinkUrl (LPTSTR pszString, int cchSize) const
int | GetLocalFile (LPTSTR pszString, int cchSize) const
int | GetName (LPTSTR pszString, int cchSize) const
AcTcCatalogItem * | GetNextChild (int iIndex, CatalogItemType nType) const
AcTc::ItemOption | GetOption (void) const
AcTcImage * | GetOverlayImage (void) const
INT_PTR | GetOverlayImageFilePath (LPTSTR pszString, size_t cchSize) const
BOOL | GetOverlayImageInfo (ACTC_IMAGE_INFO *pImageInfo) const
AcTcCatalogItem * | GetParent (void) const
int | GetParentDocumentDescription (LPTSTR pszString, int cchSize) const
int | GetParentDocumentName (LPTSTR pszString, int cchSize) const
int | GetParentDocumentUrl (LPTSTR pszString, int cchSize) const
int | GetPublisherCountry (LPTSTR pszString, int cchSize) const
int | GetPublisherDescription (LPTSTR pszString, int cchSize) const
int | GetPublisherEmail (LPTSTR pszString, int cchSize) const
int | GetPublisherName (LPTSTR pszString, int cchSize) const
int | GetPublisherUrl (LPTSTR pszString, int cchSize) const
int | GetReferencePath (LPTSTR pszString, int cchSize, int nFlag) const
BOOL | GetRefresh (void) const
AcTcCatalogItem * | GetRoot (void) const
AcTcScheme * | GetScheme (void) const
BOOL | GetSourceID (GUID *pId) const
int | GetSourceUrl (LPTSTR pszString, int cchSize) const
virtual int | GetTagName (LPTSTR pszString, int cchSize) const
BOOL | GetTargetProduct (INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const
INT_PTR | GetTargetProductCount (void) const
BOOL | GetTime (time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const
int | GetToolTipText (LPTSTR pszString, int cchSize) const
virtual CatalogItemType | GetType (void) const
virtual int | GetTypeString (LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const
int | GetUrl (LPTSTR pszString, int cchSize) const
int | GetXml (LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | HasChildren (void) const
INT_PTR | InsertChild (INT_PTR iIndex, AcTcCatalogItem *pNewItem)
BOOL | IsLink (void) const
BOOL | IsLinkLoaded (void) const
BOOL | IsReadOnly (void) const
BOOL | IsRoot (void) const
virtual BOOL | IsValidChild (const CatalogItemType nType) const
BOOL | IsValidForProduct (LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0)
BOOL | Load (LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IStream *pStream, DWORD dwLoadOption=kLoadLinks)
BOOL | LoadLink (void)
virtual AcTcCatalogItem & | operator= (const AcTcCatalogItem &srcItem)
virtual BOOL | Refresh (DWORD dwRefreshFlag=kRefreshAll)
BOOL | RemoveReactor (AcTcCatalogItemReactor *pReactor)
virtual BOOL | Reset (void)
BOOL | Save (LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | SetAccessRight (AcTc::AccessRight nAccessRight)
BOOL | SetAutoRefresh (BOOL bAutoRefresh)
BOOL | SetDescription (LPCTSTR pszString)
BOOL | SetHelpInfo (LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData)
BOOL | SetID (const GUID *pId)
BOOL | SetItemOrder (AcTcCatalogItem **pItems, INT_PTR nNumItems)
BOOL | SetKeywords (LPCTSTR pszString)
BOOL | SetLinkUrl (LPCTSTR pszString)
BOOL | SetName (LPCTSTR pszString)
BOOL | SetNewID (BOOL bRecursive=FALSE)
BOOL | SetOption (AcTc::ItemOption nOption)
BOOL | SetOverlayImage (const AcTcImage *pImage)
BOOL | SetOverlayImageInfo (const ACTC_IMAGE_INFO *pImageInfo)
BOOL | SetParent (AcTcCatalogItem *pParent)
BOOL | SetParentDocumentDescription (LPCTSTR pszString)
BOOL | SetParentDocumentName (LPCTSTR pszString)
BOOL | SetParentDocumentUrl (LPCTSTR pszString)
BOOL | SetPublisherCountry (LPCTSTR pszString)
BOOL | SetPublisherDescription (LPCTSTR pszString)
BOOL | SetPublisherEmail (LPCTSTR pszString)
BOOL | SetPublisherName (LPCTSTR pszString)
BOOL | SetPublisherUrl (LPCTSTR pszString)
BOOL | SetReferencePath (LPCTSTR pszString, int nFlag)
BOOL | SetRefresh (BOOL bRefresh)
BOOL | SetSourceID (const GUID *pId)
BOOL | SetSourceUrl (LPCTSTR pszString)
BOOL | SetTime (const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed)
BOOL | SetToolTipText (LPCTSTR pszString)
BOOL | Sort (int nSortOption, BOOL bRecursive)

Protected Member Functions

AcTcStockTool (AcTcSystemInternals *)
- Protected Member Functions inherited from AcTcCatalogItem
AcTcCatalogItem (AcTcSystemInternals *)
virtual AcTcCatalogItem * CreateObject (void) const

Friends

class AcTcSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from AcTcCatalogItem
static AcTcCatalogItem * | FromFile (LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks)
static CatalogItemType | GetType (LPCTSTR pszFile)
- Protected Attributes inherited from AcTcCatalogItem
void * | mpImpObj
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcStockTool Member List

This is the complete list of members for AcTcStockTool, including all inherited members.

AcTcCatalogItem(AcTcSystemInternals *) (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
AcTcStockTool() (defined in AcTcStockTool) | AcTcStockTool |
AcTcStockTool(const AcTcStockTool &srcItem) (defined in AcTcStockTool) | AcTcStockTool |
AcTcStockTool(AcTcSystemInternals *) (defined in AcTcStockTool) | AcTcStockTool | protected
AcTcSystemInternals (defined in AcTcStockTool) | AcTcStockTool | friend
AddChild(AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddTargetProduct(const ACTC_TARGET_PRODUCT_INFO *pProductInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
CanRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
Clone(BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CopyFrom(const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CreateAcadStockTool(IUnknown **ppStockTool) (defined in AcTcStockTool) | AcTcStockTool |
CreateAcadTool(IUnknown **ppUnknown) (defined in AcTcStockTool) | AcTcStockTool |
CreateObject(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | protectedvirtual
CreateTool(BOOL bSetDefaults=TRUE) (defined in AcTcStockTool) | AcTcStockTool |
DeleteAllChildren(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteLinkFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteOverlayImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteTargetProduct(int iIndex) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DetachChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Download(LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(const GUID &id, BOOL bRecursive=TRUE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(LPCTSTR pszName) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FindInChildren(LPCTSTR pszName, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FromFile(LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetAccessRight(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetAutoRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChild(INT_PTR iIndex) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetComClassID(CLSID &clsid) const (defined in AcTcStockTool) | AcTcStockTool |
GetCustomData(IUnknown **ppCustomData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetHelpInfo(LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImage(const SIZE *pSize) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageFilePath(INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageList(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetKeywords(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkFilePath(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLocalFile(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetModuleFileName(LPTSTR pszString, int cchSize) const (defined in AcTcStockTool) | AcTcStockTool |
GetModuleInstallArguments(LPTSTR pszString, int cchSize) const (defined in AcTcStockTool) | AcTcStockTool |
GetModuleInstallUrl(LPTSTR pszString, int cchSize) const (defined in AcTcStockTool) | AcTcStockTool |
GetName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetNextChild(int iIndex, CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOption(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImage(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageFilePath(LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageInfo(ACTC_IMAGE_INFO *pImageInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParent(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherCountry(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherEmail(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetReferencePath(LPTSTR pszString, int cchSize, int nFlag) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetScheme(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTagName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTargetProduct(INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTargetProductCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTime(time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetToolTipText(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetType(LPCTSTR pszFile) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetType(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTypeString(LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetXml(LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
HasChildren(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
InsertChild(INT_PTR iIndex, AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLink(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLinkLoaded(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsReadOnly(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsValidChild(const CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
IsValidForProduct(LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Load(IStream *pStream, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
LoadLink(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
mpImpObj (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
operator=(const AcTcCatalogItem &srcItem) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Refresh(DWORD dwRefreshFlag=kRefreshAll) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
RemoveReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Reset(void) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Save(IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
SetAccessRight(AcTc::AccessRight nAccessRight) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetAutoRefresh(BOOL bAutoRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetComClassID(const CLSID &clsid) (defined in AcTcStockTool) | AcTcStockTool |
SetDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetHelpInfo(LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetItemOrder(AcTcCatalogItem **pItems, INT_PTR nNumItems) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetKeywords(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetLinkUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetModuleFileName(LPCTSTR pszString) (defined in AcTcStockTool) | AcTcStockTool |
SetModuleInstallArguments(LPCTSTR pszString) (defined in AcTcStockTool) | AcTcStockTool |
SetModuleInstallUrl(LPCTSTR pszString) (defined in AcTcStockTool) | AcTcStockTool |
SetName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetNewID(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOption(AcTc::ItemOption nOption) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImage(const AcTcImage *pImage) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImageInfo(const ACTC_IMAGE_INFO *pImageInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParent(AcTcCatalogItem *pParent) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherCountry(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherEmail(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetReferencePath(LPCTSTR pszString, int nFlag) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetRefresh(BOOL bRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetTime(const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetToolTipText(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Sort(int nSortOption, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
~AcTcCatalogItem() (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
~AcTcStockTool() (defined in AcTcStockTool) | AcTcStockTool | virtual


ZRX API Reference: AcTcTool Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
AcTcTool Class Reference
+ Inheritance diagram for AcTcTool:

Public Member Functions

AcTcTool (const AcTcTool &srcItem)
BOOL | CreateAcadTool (IUnknown **ppTool, BOOL bLoadData=TRUE)
BOOL | EnableFlyout (BOOL bUseFlyout)
virtual BOOL | Execute (int nFlag, HWND hWnd, POINT point, DWORD dwKeyState)
BOOL | GetActiveShapes (AcTcCatalogItem **pItems, INT_PTR &nNumItems)
AcTcTool * | GetCurrentShape (void) const
AcTcCatalogItem * | GetShapePackage (void) const
AcTcStockTool * | GetStockTool (void) const
int | GetStockToolFileUrl (LPTSTR pszString, int cchSize) const
BOOL | GetStockToolID (GUID *pId) const
BOOL | GetToolData (IUnknown **ppUnknown)
ToolType | GetToolType (void) const
BOOL | IsFlyoutEnabled (void) const
BOOL | SetActiveShapes (AcTcCatalogItem **pItems, int nNumItems)
BOOL | SetCurrentShape (AcTcTool *pTool)
BOOL | SetCurrentShape (const GUID &id)
BOOL | SetShapePackage (AcTcCatalogItem *pPackage)
BOOL | SetStockToolFileUrl (LPCTSTR pszString)
BOOL | SetStockToolID (const GUID *pId)
BOOL | SetToolType (ToolType nToolType)
- Public Member Functions inherited from AcTcCatalogItem
INT_PTR | AddChild (AcTcCatalogItem *pNewItem)
BOOL | AddReactor (AcTcCatalogItemReactor *pReactor)
INT_PTR | AddTargetProduct (const ACTC_TARGET_PRODUCT_INFO *pProductInfo)
BOOL | CanRefresh (void) const
virtual BOOL | Clone (BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const
virtual BOOL | CopyFrom (const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE)
BOOL | DeleteAllChildren (void)
BOOL | DeleteChild (AcTcCatalogItem *pItem)
BOOL | DeleteImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteLinkFile (BOOL bRecursive=FALSE)
BOOL | DeleteOverlayImageFile (BOOL bRecursive=FALSE)
BOOL | DeleteTargetProduct (int iIndex)
BOOL | DetachChild (AcTcCatalogItem *pItem)
virtual BOOL | Download (LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL)
virtual AcTcCatalogItem * | FindInChildren (const GUID &id, BOOL bRecursive=TRUE)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName)
AcTcCatalogItem * | FindInChildren (LPCTSTR pszName, BOOL bRecursive)
AcTc::AccessRight | GetAccessRight (void) const
BOOL | GetAutoRefresh (void) const
AcTcCatalogItem * | GetChild (INT_PTR iIndex) const
INT_PTR | GetChildCount (void) const
INT_PTR | GetChildCount (CatalogItemType nType) const
BOOL | GetCustomData (IUnknown **ppCustomData)
int | GetDescription (LPTSTR pszString, int cchSize) const
BOOL | GetHelpInfo (LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const
BOOL | GetID (GUID *pId) const
AcTcImage * | GetImage (const SIZE *pSize)
INT_PTR | GetImageFilePath (INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const
AcTcImageList * | GetImageList (void) const
int | GetKeywords (LPTSTR pszString, int cchSize) const
int | GetLinkFilePath (LPTSTR pszString, int cchSize) const
int | GetLinkUrl (LPTSTR pszString, int cchSize) const
int | GetLocalFile (LPTSTR pszString, int cchSize) const
int | GetName (LPTSTR pszString, int cchSize) const
AcTcCatalogItem * | GetNextChild (int iIndex, CatalogItemType nType) const
AcTc::ItemOption | GetOption (void) const
AcTcImage * | GetOverlayImage (void) const
INT_PTR | GetOverlayImageFilePath (LPTSTR pszString, size_t cchSize) const
BOOL | GetOverlayImageInfo (ACTC_IMAGE_INFO *pImageInfo) const
AcTcCatalogItem * | GetParent (void) const
int | GetParentDocumentDescription (LPTSTR pszString, int cchSize) const
int | GetParentDocumentName (LPTSTR pszString, int cchSize) const
int | GetParentDocumentUrl (LPTSTR pszString, int cchSize) const
int | GetPublisherCountry (LPTSTR pszString, int cchSize) const
int | GetPublisherDescription (LPTSTR pszString, int cchSize) const
int | GetPublisherEmail (LPTSTR pszString, int cchSize) const
int | GetPublisherName (LPTSTR pszString, int cchSize) const
int | GetPublisherUrl (LPTSTR pszString, int cchSize) const
int | GetReferencePath (LPTSTR pszString, int cchSize, int nFlag) const
BOOL | GetRefresh (void) const
AcTcCatalogItem * | GetRoot (void) const
AcTcScheme * | GetScheme (void) const
BOOL | GetSourceID (GUID *pId) const
int | GetSourceUrl (LPTSTR pszString, int cchSize) const
virtual int | GetTagName (LPTSTR pszString, int cchSize) const
BOOL | GetTargetProduct (INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const
INT_PTR | GetTargetProductCount (void) const
BOOL | GetTime (time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const
int | GetToolTipText (LPTSTR pszString, int cchSize) const
virtual CatalogItemType | GetType (void) const
virtual int | GetTypeString (LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const
int | GetUrl (LPTSTR pszString, int cchSize) const
int | GetXml (LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | HasChildren (void) const
INT_PTR | InsertChild (INT_PTR iIndex, AcTcCatalogItem *pNewItem)
BOOL | IsLink (void) const
BOOL | IsLinkLoaded (void) const
BOOL | IsReadOnly (void) const
BOOL | IsRoot (void) const
virtual BOOL | IsValidChild (const CatalogItemType nType) const
BOOL | IsValidForProduct (LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0)
BOOL | Load (LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks)
virtual BOOL | Load (IStream *pStream, DWORD dwLoadOption=kLoadLinks)
BOOL | LoadLink (void)
virtual AcTcCatalogItem & | operator= (const AcTcCatalogItem &srcItem)
virtual BOOL | Refresh (DWORD dwRefreshFlag=kRefreshAll)
BOOL | RemoveReactor (AcTcCatalogItemReactor *pReactor)
virtual BOOL | Reset (void)
BOOL | Save (LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks)
virtual BOOL | Save (IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks)
BOOL | SetAccessRight (AcTc::AccessRight nAccessRight)
BOOL | SetAutoRefresh (BOOL bAutoRefresh)
BOOL | SetDescription (LPCTSTR pszString)
BOOL | SetHelpInfo (LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData)
BOOL | SetID (const GUID *pId)
BOOL | SetItemOrder (AcTcCatalogItem **pItems, INT_PTR nNumItems)
BOOL | SetKeywords (LPCTSTR pszString)
BOOL | SetLinkUrl (LPCTSTR pszString)
BOOL | SetName (LPCTSTR pszString)
BOOL | SetNewID (BOOL bRecursive=FALSE)
BOOL | SetOption (AcTc::ItemOption nOption)
BOOL | SetOverlayImage (const AcTcImage *pImage)
BOOL | SetOverlayImageInfo (const ACTC_IMAGE_INFO *pImageInfo)
BOOL | SetParent (AcTcCatalogItem *pParent)
BOOL | SetParentDocumentDescription (LPCTSTR pszString)
BOOL | SetParentDocumentName (LPCTSTR pszString)
BOOL | SetParentDocumentUrl (LPCTSTR pszString)
BOOL | SetPublisherCountry (LPCTSTR pszString)
BOOL | SetPublisherDescription (LPCTSTR pszString)
BOOL | SetPublisherEmail (LPCTSTR pszString)
BOOL | SetPublisherName (LPCTSTR pszString)
BOOL | SetPublisherUrl (LPCTSTR pszString)
BOOL | SetReferencePath (LPCTSTR pszString, int nFlag)
BOOL | SetRefresh (BOOL bRefresh)
BOOL | SetSourceID (const GUID *pId)
BOOL | SetSourceUrl (LPCTSTR pszString)
BOOL | SetTime (const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed)
BOOL | SetToolTipText (LPCTSTR pszString)
BOOL | Sort (int nSortOption, BOOL bRecursive)

Protected Member Functions

AcTcTool (AcTcSystemInternals *)
- Protected Member Functions inherited from AcTcCatalogItem
AcTcCatalogItem (AcTcSystemInternals *)
virtual AcTcCatalogItem * CreateObject (void) const

Additional Inherited Members

- Static Public Member Functions inherited from AcTcCatalogItem
static AcTcCatalogItem * | FromFile (LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks)
static CatalogItemType | GetType (LPCTSTR pszFile)
- Protected Attributes inherited from AcTcCatalogItem
void * | mpImpObj
The documentation for this class was generated from the following file:
  • actc.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcTcTool Member List

This is the complete list of members for AcTcTool, including all inherited members.

AcTcCatalogItem(AcTcSystemInternals *) (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
AcTcTool() (defined in AcTcTool) | AcTcTool |
AcTcTool(const AcTcTool &srcItem) (defined in AcTcTool) | AcTcTool |
AcTcTool(AcTcSystemInternals *) (defined in AcTcTool) | AcTcTool | protected
AddChild(AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
AddTargetProduct(const ACTC_TARGET_PRODUCT_INFO *pProductInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
CanRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
Clone(BOOL bDeep, AcTcCatalogItem *&pClone, BOOL bCopyId=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CopyFrom(const AcTcCatalogItem *pSrcItem, BOOL bCopyId=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
CreateAcadTool(IUnknown **ppTool, BOOL bLoadData=TRUE) (defined in AcTcTool) | AcTcTool |
CreateObject(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | protectedvirtual
DeleteAllChildren(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteLinkFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteOverlayImageFile(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DeleteTargetProduct(int iIndex) (defined in AcTcCatalogItem) | AcTcCatalogItem |
DetachChild(AcTcCatalogItem *pItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Download(LPCTSTR pszUrl, DWORD dwDownloadFlag=kDownloadAll, LPCTSTR pszDownloadPath=NULL) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
EnableFlyout(BOOL bUseFlyout) (defined in AcTcTool) | AcTcTool |
Execute(int nFlag, HWND hWnd, POINT point, DWORD dwKeyState) (defined in AcTcTool) | AcTcTool | virtual
FindInChildren(const GUID &id, BOOL bRecursive=TRUE) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
FindInChildren(LPCTSTR pszName) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FindInChildren(LPCTSTR pszName, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
FromFile(LPCTSTR pszFile, BOOL bLoad=FALSE, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetAccessRight(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetActiveShapes(AcTcCatalogItem **pItems, INT_PTR &nNumItems) (defined in AcTcTool) | AcTcTool |
GetAutoRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChild(INT_PTR iIndex) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetChildCount(CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetCurrentShape(void) const (defined in AcTcTool) | AcTcTool |
GetCustomData(IUnknown **ppCustomData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetHelpInfo(LPTSTR pszFile, LPTSTR pszCommand, LPTSTR pszData) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImage(const SIZE *pSize) (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageFilePath(INT_PTR iIndex, LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetImageList(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetKeywords(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkFilePath(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLinkUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetLocalFile(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetNextChild(int iIndex, CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOption(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImage(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageFilePath(LPTSTR pszString, size_t cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetOverlayImageInfo(ACTC_IMAGE_INFO *pImageInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParent(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetParentDocumentUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherCountry(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherDescription(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherEmail(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetPublisherUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetReferencePath(LPTSTR pszString, int cchSize, int nFlag) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRefresh(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetScheme(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetShapePackage(void) const (defined in AcTcTool) | AcTcTool |
GetSourceID(GUID *pId) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetSourceUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetStockTool(void) const (defined in AcTcTool) | AcTcTool |
GetStockToolFileUrl(LPTSTR pszString, int cchSize) const (defined in AcTcTool) | AcTcTool |
GetStockToolID(GUID *pId) const (defined in AcTcTool) | AcTcTool |
GetTagName(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTargetProduct(INT_PTR iIndex, ACTC_TARGET_PRODUCT_INFO *pProductInfo) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTargetProductCount(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetTime(time_t *pCreated, time_t *pLastModified, time_t *pLastRefreshed) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetToolData(IUnknown **ppUnknown) (defined in AcTcTool) | AcTcTool |
GetToolTipText(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetToolType(void) const (defined in AcTcTool) | AcTcTool |
GetType(LPCTSTR pszFile) (defined in AcTcCatalogItem) | AcTcCatalogItem | static
GetType(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetTypeString(LPTSTR pszString, int cchSize, BOOL bLocalized=FALSE, BOOL bPluralForm=FALSE) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
GetUrl(LPTSTR pszString, int cchSize) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
GetXml(LPTSTR pszString, int cchSize, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
HasChildren(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
InsertChild(INT_PTR iIndex, AcTcCatalogItem *pNewItem) (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsFlyoutEnabled(void) const (defined in AcTcTool) | AcTcTool |
IsLink(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsLinkLoaded(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsReadOnly(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsRoot(void) const (defined in AcTcCatalogItem) | AcTcCatalogItem |
IsValidChild(const CatalogItemType nType) const (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
IsValidForProduct(LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId=0) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(LPCTSTR pszUrl, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Load(IUnknown *pUnknown, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Load(IStream *pStream, DWORD dwLoadOption=kLoadLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
LoadLink(void) (defined in AcTcCatalogItem) | AcTcCatalogItem |
mpImpObj (defined in AcTcCatalogItem) | AcTcCatalogItem | protected
operator=(const AcTcCatalogItem &srcItem) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Refresh(DWORD dwRefreshFlag=kRefreshAll) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
RemoveReactor(AcTcCatalogItemReactor *pReactor) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Reset(void) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(LPCTSTR pszUrl, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem |
Save(IUnknown *pUnknown, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
Save(IStream *pStream, DWORD dwSaveOption=kSaveLinksAsLinks) (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
SetAccessRight(AcTc::AccessRight nAccessRight) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetActiveShapes(AcTcCatalogItem **pItems, int nNumItems) (defined in AcTcTool) | AcTcTool |
SetAutoRefresh(BOOL bAutoRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetCurrentShape(AcTcTool *pTool) (defined in AcTcTool) | AcTcTool |
SetCurrentShape(const GUID &id) (defined in AcTcTool) | AcTcTool |
SetDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetHelpInfo(LPCTSTR pszFile, LPCTSTR pszCommand, LPCTSTR pszData) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetItemOrder(AcTcCatalogItem **pItems, INT_PTR nNumItems) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetKeywords(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetLinkUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetNewID(BOOL bRecursive=FALSE) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOption(AcTc::ItemOption nOption) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImage(const AcTcImage *pImage) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetOverlayImageInfo(const ACTC_IMAGE_INFO *pImageInfo) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParent(AcTcCatalogItem *pParent) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetParentDocumentUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherCountry(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherDescription(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherEmail(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherName(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetPublisherUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetReferencePath(LPCTSTR pszString, int nFlag) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetRefresh(BOOL bRefresh) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetShapePackage(AcTcCatalogItem *pPackage) (defined in AcTcTool) | AcTcTool |
SetSourceID(const GUID *pId) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetSourceUrl(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetStockToolFileUrl(LPCTSTR pszString) (defined in AcTcTool) | AcTcTool |
SetStockToolID(const GUID *pId) (defined in AcTcTool) | AcTcTool |
SetTime(const time_t *pCreated, const time_t *pLastModified, const time_t *pLastRefreshed) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetToolTipText(LPCTSTR pszString) (defined in AcTcCatalogItem) | AcTcCatalogItem |
SetToolType(ToolType nToolType) (defined in AcTcTool) | AcTcTool |
Sort(int nSortOption, BOOL bRecursive) (defined in AcTcCatalogItem) | AcTcCatalogItem |
~AcTcCatalogItem() (defined in AcTcCatalogItem) | AcTcCatalogItem | virtual
~AcTcTool() (defined in AcTcTool) | AcTcTool | virtual


ZRX API Reference: ACTCUI_DRAG_HEADER Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
ACTCUI_DRAG_HEADER Struct Reference

Public Attributes

BOOL | mbAutoCADSource
BOOL | mbReadOnlySource
CLIPFORMAT | mcfClipFormat
DWORD | mdwDragFormat
DWORD | mdwItemTypes
DWORD | mdwSourceProcessId
int | mnCount
int | mnStockTools
GUID | mParentId
GUID | mRootId
The documentation for this struct was generated from the following file:
  • actcui.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
ACTCUI_DRAG_HEADER Member List

This is the complete list of members for ACTCUI_DRAG_HEADER, including all inherited members.

mbAutoCADSource (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER
mbReadOnlySource (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER
mcfClipFormat (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER
mdwDragFormat (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER
mdwItemTypes (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER
mdwSourceProcessId (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER
mnCount (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER
mnStockTools (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER
mParentId (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER
mRootId (defined in ACTCUI_DRAG_HEADER) | ACTCUI_DRAG_HEADER


ZRX API Reference: ads_callback_packet Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
ads_callback_packet Struct Reference

Public Attributes

void * | client_data
ads_hdlg | dialog
int | reason
ads_htile | tile
ACHAR * | value
long | x
long | y
The documentation for this struct was generated from the following file:
  • adsdlg.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
ads_callback_packet Member List

This is the complete list of members for ads_callback_packet, including all inherited members.

client_data (defined in ads_callback_packet) | ads_callback_packet
dialog (defined in ads_callback_packet) | ads_callback_packet
reason (defined in ads_callback_packet) | ads_callback_packet
tile (defined in ads_callback_packet) | ads_callback_packet
value (defined in ads_callback_packet) | ads_callback_packet
x (defined in ads_callback_packet) | ads_callback_packet
y (defined in ads_callback_packet) | ads_callback_packet


ZRX API Reference: AdUiBmpBtnData Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AdUiBmpBtnData Struct Reference

Public Attributes

DWORD | dwCookie
AdUiBmpBtnFcnPtr | fcnPtr
CBitmap * | pBmp
CString | tooltip
The documentation for this struct was generated from the following file:
  • aduiGroupCtrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AdUiBmpBtnData Member List

This is the complete list of members for AdUiBmpBtnData, including all inherited members.

AdUiBmpBtnData() (defined in AdUiBmpBtnData) | AdUiBmpBtnData | inline
dwCookie (defined in AdUiBmpBtnData) | AdUiBmpBtnData |
fcnPtr (defined in AdUiBmpBtnData) | AdUiBmpBtnData |
pBmp (defined in AdUiBmpBtnData) | AdUiBmpBtnData |
tooltip (defined in AdUiBmpBtnData) | AdUiBmpBtnData |


ZRX API Reference: AdUiGroupCtrlData Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AdUiGroupCtrlData Struct Reference

Public Attributes

DWORD | dwBtnCookie
int | nWndIndex
CWnd * | pWnd
CString | title
The documentation for this struct was generated from the following file:
  • aduiGroupCtrl.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AdUiGroupCtrlData Member List

This is the complete list of members for AdUiGroupCtrlData, including all inherited members.

AdUiGroupCtrlData() (defined in AdUiGroupCtrlData) | AdUiGroupCtrlData | inline
dwBtnCookie (defined in AdUiGroupCtrlData) | AdUiGroupCtrlData |
nWndIndex (defined in AdUiGroupCtrlData) | AdUiGroupCtrlData |
pWnd (defined in AdUiGroupCtrlData) | AdUiGroupCtrlData |
title (defined in AdUiGroupCtrlData) | AdUiGroupCtrlData |


ZRX API Reference: asi_date Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_date Struct Reference

Public Attributes

ushort | day
ushort | month
short | pad
ushort | year
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_date Member List

This is the complete list of members for asi_date, including all inherited members.

day (defined in asi_date) | asi_date
month (defined in asi_date) | asi_date
pad (defined in asi_date) | asi_date
year (defined in asi_date) | asi_date


ZRX API Reference: asi_day Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_day Struct Reference

Public Attributes

ulong | days
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_day Member List

This is the complete list of members for asi_day, including all inherited members.

days (defined in asi_day) | asi_day
sign (defined in asi_day) | asi_day


ZRX API Reference: asi_daytohour Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_daytohour Struct Reference

Public Attributes

ulong | days
ulong | hours
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_daytohour Member List

This is the complete list of members for asi_daytohour, including all inherited members.

days (defined in asi_daytohour) | asi_daytohour
hours (defined in asi_daytohour) | asi_daytohour
sign (defined in asi_daytohour) | asi_daytohour


ZRX API Reference: asi_daytominute Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_daytominute Struct Reference

Public Attributes

ulong | days
ulong | hours
ulong | minutes
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_daytominute Member List

This is the complete list of members for asi_daytominute, including all inherited members.

days (defined in asi_daytominute) | asi_daytominute
hours (defined in asi_daytominute) | asi_daytominute
minutes (defined in asi_daytominute) | asi_daytominute
sign (defined in asi_daytominute) | asi_daytominute


ZRX API Reference: asi_daytosecond Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_daytosecond Struct Reference

Public Attributes

ulong | days
ulong | hours
ulong | minutes
double | seconds
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_daytosecond Member List

This is the complete list of members for asi_daytosecond, including all inherited members.

days (defined in asi_daytosecond) | asi_daytosecond
hours (defined in asi_daytosecond) | asi_daytosecond
minutes (defined in asi_daytosecond) | asi_daytosecond
seconds (defined in asi_daytosecond) | asi_daytosecond
sign (defined in asi_daytosecond) | asi_daytosecond


ZRX API Reference: asi_hour Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_hour Struct Reference

Public Attributes

ulong | hours
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_hour Member List

This is the complete list of members for asi_hour, including all inherited members.

hours (defined in asi_hour) | asi_hour
sign (defined in asi_hour) | asi_hour


ZRX API Reference: asi_hourtominute Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_hourtominute Struct Reference

Public Attributes

ulong | hours
ulong | minutes
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_hourtominute Member List

This is the complete list of members for asi_hourtominute, including all inherited members.

hours (defined in asi_hourtominute) | asi_hourtominute
minutes (defined in asi_hourtominute) | asi_hourtominute
sign (defined in asi_hourtominute) | asi_hourtominute


ZRX API Reference: asi_hourtosecond Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_hourtosecond Struct Reference

Public Attributes

ulong | hours
ulong | minutes
double | seconds
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_hourtosecond Member List

This is the complete list of members for asi_hourtosecond, including all inherited members.

hours (defined in asi_hourtosecond) | asi_hourtosecond
minutes (defined in asi_hourtosecond) | asi_hourtosecond
seconds (defined in asi_hourtosecond) | asi_hourtosecond
sign (defined in asi_hourtosecond) | asi_hourtosecond


ZRX API Reference: asi_minute Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_minute Struct Reference

Public Attributes

ulong | minutes
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_minute Member List

This is the complete list of members for asi_minute, including all inherited members.

minutes (defined in asi_minute) | asi_minute
sign (defined in asi_minute) | asi_minute


ZRX API Reference: asi_minuteitosecond Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_minuteitosecond Struct Reference

Public Attributes

ulong | minutes
double | seconds
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_minuteitosecond Member List

This is the complete list of members for asi_minuteitosecond, including all inherited members.

minutes (defined in asi_minuteitosecond) | asi_minuteitosecond
seconds (defined in asi_minuteitosecond) | asi_minuteitosecond
sign (defined in asi_minuteitosecond) | asi_minuteitosecond


ZRX API Reference: asi_month Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_month Struct Reference

Public Attributes

ulong | months
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_month Member List

This is the complete list of members for asi_month, including all inherited members.

months (defined in asi_month) | asi_month
sign (defined in asi_month) | asi_month


ZRX API Reference: asi_second Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_second Struct Reference

Public Attributes

double | seconds
long | sign
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_second Member List

This is the complete list of members for asi_second, including all inherited members.

seconds (defined in asi_second) | asi_second
sign (defined in asi_second) | asi_second


ZRX API Reference: asi_time Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_time Struct Reference

Public Attributes

ushort | hour
ushort | minute
double | second
ASI_IHOURTOMINUTE | timezone
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_time Member List

This is the complete list of members for asi_time, including all inherited members.

hour (defined in asi_time) | asi_time
minute (defined in asi_time) | asi_time
second (defined in asi_time) | asi_time
timezone (defined in asi_time) | asi_time


ZRX API Reference: asi_timestamp Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_timestamp Struct Reference

Public Attributes

ASI_DTDATE | date
ASI_DTTIME | time
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_timestamp Member List

This is the complete list of members for asi_timestamp, including all inherited members.

date (defined in asi_timestamp) | asi_timestamp
time (defined in asi_timestamp) | asi_timestamp


ZRX API Reference: asi_year Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_year Struct Reference

Public Attributes

long | sign
ulong | years
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_year Member List

This is the complete list of members for asi_year, including all inherited members.

sign (defined in asi_year) | asi_year
years (defined in asi_year) | asi_year


ZRX API Reference: asi_yeartomonth Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
asi_yeartomonth Struct Reference

Public Attributes

ulong | months
long | sign
ulong | years
The documentation for this struct was generated from the following file:
  • asiconst.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
asi_yeartomonth Member List

This is the complete list of members for asi_yeartomonth, including all inherited members.

months (defined in asi_yeartomonth) | asi_yeartomonth
sign (defined in asi_yeartomonth) | asi_yeartomonth
years (defined in asi_yeartomonth) | asi_yeartomonth


ZRX API Reference: CAcTcUiCatalogView Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAcTcUiCatalogView Class Reference
+ Inheritance diagram for CAcTcUiCatalogView:

Public Member Functions

CAcTcUiCatalogView (AcTcCatalogItem *pCatalogItem)
virtual BOOL | CanPaste (IDataObject *pDataObject)
virtual BOOL | Copy (const CAcTcUiCatalogViewItemArray &itemsCopied, IDataObject *pDataObject)
BOOL | Create (DWORD dwWndStyle, DWORD dwCatalogViewStyle, const RECT &rect, CWnd *pParent, UINT nID=ACTCUI_IDW_CATALOGVIEW)
CEdit * | EditLabel (int nIndex)
BOOL | EndLabelEdit (BOOL bCancel=FALSE)
BOOL | EnsureVisible (int nIndex, BOOL bPartialOk)
AcTcCatalogItem * | GetCatalogItem (void) const
DWORD | GetCatalogViewStyle (void) const
int | GetColumnsInPage (void) const
CAcTcUiCatalogViewItem * | GetCurrentItem (void) const
DWORD | GetDragDropOption (void) const
POSITION | GetFirstSelectedItemPosition (void) const
int | GetFirstVisibleItemIndex (BOOL bPartialOk=TRUE) const
BOOL | GetImageSize (LPSIZE lpSize) const
BOOL | GetInsertMark (int &nIndex, BOOL &bAfter) const
CAcTcUiCatalogViewItem * | GetItem (int iIndex) const
int | GetItemCount (void) const
DWORD | GetItemData (int iIndex) const
CAcTcUiCatalogViewItem * | GetItemFromPoint (const CPoint &pt)
int | GetItemIndex (CAcTcUiCatalogViewItem *pItem) const
BOOL | GetItemOrder (AcTcCatalogItemArray &items) const
BOOL | GetItemRect (int iIndex, LPRECT lpRect, int nCode) const
int | GetLastVisibleItemIndex (BOOL bPartialOk=TRUE) const
virtual BOOL | GetMinimumSize (CSize &size)
CAcTcUiCatalogViewItem * | GetNextSelectedItem (POSITION &pos) const
int | GetOverlayImageAlignment (void) const
BOOL | GetOverlayImageSize (LPSIZE lpSize) const
int | GetRowsInPage (BOOL bIncludePartialRows) const
CAcTcUiScheme * | GetScheme (void) const
int | GetSelectedCount (void) const
CAcTcUiCatalogViewItem * | GetSelectedItem (void) const
BOOL | GetViewRect (LPRECT lpRect) const
int | HitTest (const CPoint &pt, UINT *pHitFlags) const
BOOL | IsLabelEditing (void) const
BOOL | Load (IUnknown *pUnk)
virtual BOOL | Paste (IDataObject *pDataObject, int iIndex=-1, AcTcCatalogItemArray *pNewTools=NULL)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | ResetItemOrder (void)
BOOL | Save (IUnknown *pUnk)
BOOL | Scroll (CSize sizeScroll)
BOOL | SelectItem (int nIndex, BOOL bSelect=TRUE)
BOOL | SelectItemRange (int nStartIndex, int nEndIndex, BOOL bSelect=TRUE)
BOOL | SetCatalogItem (AcTcCatalogItem *pCatalogItem)
BOOL | SetCatalogViewStyle (DWORD dwStyle)
BOOL | SetDragDropOption (DWORD dwOption)
BOOL | SetImageSize (const SIZE &size)
BOOL | SetInsertMark (int nIndex, BOOL bAfter=FALSE)
BOOL | SetItemData (int iIndex, DWORD dwData)
BOOL | SetItemOrder (const AcTcCatalogItemArray &items)
BOOL | SetOverlayImageAlignment (int nAlignment)
BOOL | SetOverlayImageSize (const SIZE &size)
BOOL | Sort (int nSortOption)
BOOL | Update (BOOL bRedraw=TRUE)

Protected Member Functions

virtual BOOL | AddContextMenuItems (CMenu *pMenu, int nHitFlag)
CAcTcUiCatalogView (AcTcUiSystemInternals *)
virtual DROPEFFECT | DragEnter (ADUI_DRAGDATA *pDragData)
virtual void | DragLeave (ADUI_DRAGDATA *pDragData)
virtual DROPEFFECT | DragOver (ADUI_DRAGDATA *pDragData)
virtual DROPEFFECT | Drop (ADUI_DRAGDATA *pDragData)
virtual DROPEFFECT | DropEx (ADUI_DRAGDATA *pDragData)
afx_msg void | OnAddSeparator ()
afx_msg void | OnAddText ()
afx_msg void | OnAllowDocking ()
afx_msg void | OnAutoHide ()
virtual LONG | OnBeginAcadDrop (BOOL *pCancelDrop)
afx_msg LRESULT | OnBeginAcadDrop (WPARAM wParam, LPARAM lParam)
virtual void | OnBeginDrag (const CAcTcUiCatalogViewItemArray &itemsDragged, IDataObject *pDataObject, DWORD dwKeyState)
afx_msg LRESULT | OnBeginLabelEdit (WPARAM wParam, LPARAM lParam)
afx_msg void | OnCatalogItemCopy ()
afx_msg void | OnCatalogItemCut ()
afx_msg void | OnCatalogItemHelp ()
afx_msg void | OnCatalogItemInstallTool ()
afx_msg void | OnCatalogItemPaste ()
afx_msg void | OnCatalogItemProperties ()
afx_msg void | OnCatalogItemRefresh ()
afx_msg void | OnCatalogItemRemove ()
afx_msg void | OnCatalogItemRename ()
afx_msg void | OnCatalogParentProperties ()
afx_msg void | OnCatalogParentRefresh ()
afx_msg void | OnCatalogParentRename ()
afx_msg LRESULT | OnChildAdded (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnChildDeleted (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnChildDetached (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnCloseShapePalette (WPARAM wParam, LPARAM lParam)
afx_msg void | OnContextMenu (CWnd *pWnd, CPoint pos)
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnCustomize ()
afx_msg void | OnCustomizeCUI ()
afx_msg void | OnDestroy ()
afx_msg LRESULT | OnDragEnter (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragEnterToolbarItem (WPARAM wParam, LPARAM lParam)
virtual HRESULT | OnDragInProgress (DROPEFFECT dropEffect)
afx_msg LRESULT | OnDragLeave (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragLeaveToolbarItem (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragOver (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragOverToolbarItem (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragScroll (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDrop (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDropEx (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDropToolbarItem (WPARAM wParam, LPARAM lParam)
virtual LONG | OnEndAcadDrop (BOOL bSuccess)
afx_msg LRESULT | OnEndAcadDrop (WPARAM wParam, LPARAM lParam)
virtual void | OnEndDrag (DROPEFFECT dropEffect)
afx_msg LRESULT | OnEndLabelEdit (WPARAM wParam, LPARAM lParam)
afx_msg UINT | OnGetDlgCode ()
afx_msg LRESULT | OnGetItemCount (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetItemRect (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetItemTextLen (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetText (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGiveFeedback (WPARAM wParam, LPARAM lParam)
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)
virtual void | OnItemCopy (void)
virtual void | OnItemCut (void)
virtual void | OnItemHelp (void)
virtual void | OnItemInstallTool (void)
virtual void | OnItemPaste (void)
virtual void | OnItemProperties (void)
virtual void | OnItemRefresh (void)
virtual void | OnItemRemove (void)
virtual void | OnItemRename (void)
afx_msg void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
virtual void | OnLButtonClicked (UINT nFlags, CPoint point)
virtual void | OnLButtonDblClicked (UINT nFlags, CPoint point)
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnLButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnMButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
afx_msg BOOL | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
afx_msg void | OnNewPalette ()
afx_msg void | OnPaint ()
afx_msg void | OnRButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnRButtonUp (UINT nFlags, CPoint point)
afx_msg LRESULT | OnRenderData (WPARAM wParam, LPARAM lParam)
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg void | OnSortByName ()
afx_msg void | OnSortByType ()
afx_msg void | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
BOOL | OnToolTipGetDispInfo (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
afx_msg void | OnTransparency ()
afx_msg void | OnViewButton ()
afx_msg void | OnViewOptions ()
afx_msg void | OnVScroll (UINT nSBCode, UINT nPos, CScrollBar *pScrollBar)

Protected Attributes

void * mpImpObj

Friends

class AcTcUiSystemInternals
The documentation for this class was generated from the following file:
  • actcuicatalogview.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcTcUiCatalogView Member List

This is the complete list of members for CAcTcUiCatalogView, including all inherited members.

AcTcUiSystemInternals (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | friend
AddContextMenuItems(CMenu *pMenu, int nHitFlag) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
CAcTcUiCatalogView() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
CAcTcUiCatalogView(AcTcCatalogItem *pCatalogItem) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
CAcTcUiCatalogView(AcTcUiSystemInternals *) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
CanPaste(IDataObject *pDataObject) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
Copy(const CAcTcUiCatalogViewItemArray &itemsCopied, IDataObject *pDataObject) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
Create(DWORD dwWndStyle, DWORD dwCatalogViewStyle, const RECT &rect, CWnd *pParent, UINT nID=ACTCUI_IDW_CATALOGVIEW) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
DragEnter(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
DragLeave(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
DragOver(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
Drop(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
DropEx(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
EditLabel(int nIndex) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
EndLabelEdit(BOOL bCancel=FALSE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
EnsureVisible(int nIndex, BOOL bPartialOk) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetCatalogItem(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetCatalogViewStyle(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetColumnsInPage(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetCurrentItem(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetDragDropOption(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetFirstSelectedItemPosition(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetFirstVisibleItemIndex(BOOL bPartialOk=TRUE) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetImageSize(LPSIZE lpSize) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetInsertMark(int &nIndex, BOOL &bAfter) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItem(int iIndex) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemCount(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemData(int iIndex) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemFromPoint(const CPoint &pt) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemIndex(CAcTcUiCatalogViewItem *pItem) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemOrder(AcTcCatalogItemArray &items) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemRect(int iIndex, LPRECT lpRect, int nCode) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetLastVisibleItemIndex(BOOL bPartialOk=TRUE) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetMinimumSize(CSize &size) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
GetNextSelectedItem(POSITION &pos) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetOverlayImageAlignment(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetOverlayImageSize(LPSIZE lpSize) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetRowsInPage(BOOL bIncludePartialRows) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetScheme(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetSelectedCount(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetSelectedItem(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetViewRect(LPRECT lpRect) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
HitTest(const CPoint &pt, UINT *pHitFlags) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
IsLabelEditing(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Load(IUnknown *pUnk) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
mpImpObj (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnAddSeparator() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnAddText() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnAllowDocking() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnAutoHide() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnBeginAcadDrop(BOOL *pCancelDrop) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnBeginAcadDrop(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnBeginDrag(const CAcTcUiCatalogViewItemArray &itemsDragged, IDataObject *pDataObject, DWORD dwKeyState) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnBeginLabelEdit(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemCopy() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemCut() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemHelp() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemInstallTool() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemPaste() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemProperties() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemRefresh() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemRemove() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemRename() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogParentProperties() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogParentRefresh() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogParentRename() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnChildAdded(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnChildDeleted(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnChildDetached(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCloseShapePalette(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnContextMenu(CWnd *pWnd, CPoint pos) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCustomize() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCustomizeCUI() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDestroy() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragEnter(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragEnterToolbarItem(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragInProgress(DROPEFFECT dropEffect) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnDragLeave(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragLeaveToolbarItem(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragOver(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragOverToolbarItem(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragScroll(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDrop(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDropEx(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDropToolbarItem(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnEndAcadDrop(BOOL bSuccess) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnEndAcadDrop(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnEndDrag(DROPEFFECT dropEffect) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnEndLabelEdit(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetDlgCode() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetItemCount(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetItemRect(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetItemTextLen(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetText(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGiveFeedback(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnHelpInfo(HELPINFO *pHelpInfo) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnItemCopy(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemCut(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemHelp(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemInstallTool(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemPaste(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemProperties(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemRefresh(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemRemove(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemRename(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnLButtonClicked(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnLButtonDblClicked(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnLButtonDown(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnLButtonUp(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnMButtonDown(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnMButtonUp(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnNewPalette() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnPaint() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnRButtonDown(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnRButtonUp(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnRenderData(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnSize(UINT nType, int cx, int cy) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnSortByName() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnSortByType() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnToolTipGetDispInfo(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnTransparency() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnViewButton() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnViewOptions() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnVScroll(UINT nSBCode, UINT nPos, CScrollBar *pScrollBar) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
Paste(IDataObject *pDataObject, int iIndex=-1, AcTcCatalogItemArray *pNewTools=NULL) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
PreTranslateMessage(MSG *pMsg) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
ResetItemOrder(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Save(IUnknown *pUnk) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Scroll(CSize sizeScroll) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SelectItem(int nIndex, BOOL bSelect=TRUE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SelectItemRange(int nStartIndex, int nEndIndex, BOOL bSelect=TRUE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetCatalogItem(AcTcCatalogItem *pCatalogItem) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetCatalogViewStyle(DWORD dwStyle) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetDragDropOption(DWORD dwOption) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetImageSize(const SIZE &size) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetInsertMark(int nIndex, BOOL bAfter=FALSE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetItemData(int iIndex, DWORD dwData) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetItemOrder(const AcTcCatalogItemArray &items) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetOverlayImageAlignment(int nAlignment) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetOverlayImageSize(const SIZE &size) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Sort(int nSortOption) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Update(BOOL bRedraw=TRUE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
~CAcTcUiCatalogView() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual


ZRX API Reference: CAcTcUiCatalogViewItem Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAcTcUiCatalogViewItem Class Reference

Public Member Functions

AcTcCatalogItem * | GetCatalogItem (void) const
DWORD | GetData (void) const
BOOL | GetPosition (LPPOINT lpPoint) const
BOOL | GetRect (LPRECT lpRect, int nCode) const
DWORD | GetState (void) const
DWORD | GetStyle (void) const
BOOL | Halo (BOOL bHalo=TRUE)
BOOL | Highlight (BOOL bHighlight=TRUE)
BOOL | Render (BOOL bEraseBackground=FALSE)
BOOL | Render (CDC *pDC, int x, int y)
BOOL | Select (BOOL bSelect=TRUE)
BOOL | SetCatalogItem (AcTcCatalogItem *pCatalogItem)
BOOL | SetData (DWORD dwData)
BOOL | SetState (DWORD dwState)

Protected Member Functions

CAcTcUiCatalogViewItem (CAcTcUiCatalogView *pCatalogView)
CAcTcUiCatalogViewItem (CAcTcUiCatalogView *pCatalogView, AcTcCatalogItem *pCatalogItem, const CSize &sizeImage, DWORD dwStyle=ACTCUI_CVISTYLE_PUSHBUTTON)

Protected Attributes

void * mpImpObj

Friends

class | AcTcUiSystemInternals
class | CAcTcUiImpCatalogView
The documentation for this class was generated from the following file:
  • actcuicatalogviewitem.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcTcUiCatalogViewItem Member List

This is the complete list of members for CAcTcUiCatalogViewItem, including all inherited members.

AcTcUiSystemInternals (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem | friend
CAcTcUiCatalogViewItem(CAcTcUiCatalogView *pCatalogView) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem | protected
CAcTcUiCatalogViewItem(CAcTcUiCatalogView *pCatalogView, AcTcCatalogItem *pCatalogItem, const CSize &sizeImage, DWORD dwStyle=ACTCUI_CVISTYLE_PUSHBUTTON) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem | protected
CAcTcUiImpCatalogView (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem | friend
GetCatalogItem(void) const (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
GetData(void) const (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
GetPosition(LPPOINT lpPoint) const (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
GetRect(LPRECT lpRect, int nCode) const (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
GetState(void) const (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
GetStyle(void) const (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
Halo(BOOL bHalo=TRUE) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
Highlight(BOOL bHighlight=TRUE) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
mpImpObj (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem | protected
Render(BOOL bEraseBackground=FALSE) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
Render(CDC *pDC, int x, int y) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
Select(BOOL bSelect=TRUE) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
SetCatalogItem(AcTcCatalogItem *pCatalogItem) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
SetData(DWORD dwData) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
SetState(DWORD dwState) (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem |
~CAcTcUiCatalogViewItem() (defined in CAcTcUiCatalogViewItem) | CAcTcUiCatalogViewItem | virtual


ZRX API Reference: CAcTcUiManager Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAcTcUiManager Class Reference

Public Member Functions

int | AddScheme (CAcTcUiScheme *pUiScheme)
int | AddToolFilter (LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId)
CAcTcUiToolPalette * | CreatePalette (LPCTSTR pszPalName=NULL, DWORD dwFlags=0)
BOOL | DeleteToolFilter (int iIndex)
BOOL | Export (LPCTSTR pszFile, const AcTcUiToolPaletteArray *palettes=NULL)
BOOL | FindPalette (const AcTcCatalogItem *pItem, CAcTcUiToolPalette **ppToolPalette) const
BOOL | FindPalette (const GUID &itemId, CAcTcUiToolPalette **ppToolPalette) const
HWND | GetApplicationWindow (void)
COleDropTarget * | GetDropTarget (void)
CAcTcUiScheme * | GetScheme (LPCTSTR pszName) const
CAcTcUiScheme * | GetScheme (int nIndex)
int | GetSchemeCount (void)
BOOL | GetToolFilter (int iIndex, LPTSTR pszProductName, int *pMajorVersion, int *pMinorVersion, DWORD *pLocaleId) const
int | GetToolFilterCount (void) const
CAcTcUiToolPaletteSet * | GetToolPaletteWindow (void)
BOOL | Import (LPCTSTR pszFile)
BOOL | IsToolPaletteWindowVisible (void) const
BOOL | Load (IUnknown *pUnknown)
BOOL | RemoveScheme (CAcTcUiScheme *pUiScheme)
BOOL | Save (IUnknown *pUnknown)
BOOL | SetApplicationWindow (HWND hWndApp)
BOOL | ShowToolPaletteWindow (BOOL bShow=TRUE)

Protected Attributes

void * mpImpObj

Friends

class AcTcUiSystemInternals
The documentation for this class was generated from the following file:
  • actcuimanager.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcTcUiManager Member List

This is the complete list of members for CAcTcUiManager, including all inherited members.

AcTcUiSystemInternals (defined in CAcTcUiManager) | CAcTcUiManager | friend
AddScheme(CAcTcUiScheme *pUiScheme) (defined in CAcTcUiManager) | CAcTcUiManager |
AddToolFilter(LPCTSTR pszProductName, int nMajorVersion, int nMinorVersion, DWORD dwLocaleId) (defined in CAcTcUiManager) | CAcTcUiManager |
CAcTcUiManager() (defined in CAcTcUiManager) | CAcTcUiManager |
CreatePalette(LPCTSTR pszPalName=NULL, DWORD dwFlags=0) (defined in CAcTcUiManager) | CAcTcUiManager |
DeleteToolFilter(int iIndex) (defined in CAcTcUiManager) | CAcTcUiManager |
Export(LPCTSTR pszFile, const AcTcUiToolPaletteArray *palettes=NULL) (defined in CAcTcUiManager) | CAcTcUiManager |
FindPalette(const AcTcCatalogItem *pItem, CAcTcUiToolPalette **ppToolPalette) const (defined in CAcTcUiManager) | CAcTcUiManager |
FindPalette(const GUID &itemId, CAcTcUiToolPalette **ppToolPalette) const (defined in CAcTcUiManager) | CAcTcUiManager |
GetApplicationWindow(void) (defined in CAcTcUiManager) | CAcTcUiManager |
GetDropTarget(void) (defined in CAcTcUiManager) | CAcTcUiManager |
GetScheme(LPCTSTR pszName) const (defined in CAcTcUiManager) | CAcTcUiManager |
GetScheme(int nIndex) (defined in CAcTcUiManager) | CAcTcUiManager |
GetSchemeCount(void) (defined in CAcTcUiManager) | CAcTcUiManager |
GetToolFilter(int iIndex, LPTSTR pszProductName, int *pMajorVersion, int *pMinorVersion, DWORD *pLocaleId) const (defined in CAcTcUiManager) | CAcTcUiManager |
GetToolFilterCount(void) const (defined in CAcTcUiManager) | CAcTcUiManager |
GetToolPaletteWindow(void) (defined in CAcTcUiManager) | CAcTcUiManager |
Import(LPCTSTR pszFile) (defined in CAcTcUiManager) | CAcTcUiManager |
IsToolPaletteWindowVisible(void) const (defined in CAcTcUiManager) | CAcTcUiManager |
Load(IUnknown *pUnknown) (defined in CAcTcUiManager) | CAcTcUiManager |
mpImpObj (defined in CAcTcUiManager) | CAcTcUiManager | protected
RemoveScheme(CAcTcUiScheme *pUiScheme) (defined in CAcTcUiManager) | CAcTcUiManager |
Save(IUnknown *pUnknown) (defined in CAcTcUiManager) | CAcTcUiManager |
SetApplicationWindow(HWND hWndApp) (defined in CAcTcUiManager) | CAcTcUiManager |
ShowToolPaletteWindow(BOOL bShow=TRUE) (defined in CAcTcUiManager) | CAcTcUiManager |
~CAcTcUiManager() (defined in CAcTcUiManager) | CAcTcUiManager | virtual


ZRX API Reference: CAcTcUiPaletteView Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Protected Member Functions | List of all members
CAcTcUiPaletteView Class Reference
+ Inheritance diagram for CAcTcUiPaletteView:

Protected Member Functions

CAcTcUiPaletteView (AcTcUiSystemInternals *)
virtual DROPEFFECT | DragEnter (ADUI_DRAGDATA *pDragData)
virtual void | DragLeave (ADUI_DRAGDATA *pDragData)
virtual DROPEFFECT | DragOver (ADUI_DRAGDATA *pDragData)
virtual DROPEFFECT | Drop (ADUI_DRAGDATA *pDragData)
virtual DROPEFFECT | DropEx (ADUI_DRAGDATA *pDragData)
afx_msg void | OnCatalogItemRemoveImage ()
afx_msg void | OnCatalogItemSpecifyImage ()
afx_msg void | OnCatalogItemUpdateImage ()
afx_msg void | OnInvokeCommand (UINT nID)
afx_msg void | OnKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
afx_msg void | OnPaletteRemove ()
afx_msg void | OnSysKeyDown (UINT nChar, UINT nRepCnt, UINT nFlags)
- Protected Member Functions inherited from CAcTcUiCatalogView
virtual BOOL | AddContextMenuItems (CMenu *pMenu, int nHitFlag)
CAcTcUiCatalogView (AcTcUiSystemInternals *)
afx_msg void | OnAddSeparator ()
afx_msg void | OnAddText ()
afx_msg void | OnAllowDocking ()
afx_msg void | OnAutoHide ()
virtual LONG | OnBeginAcadDrop (BOOL *pCancelDrop)
afx_msg LRESULT | OnBeginAcadDrop (WPARAM wParam, LPARAM lParam)
virtual void | OnBeginDrag (const CAcTcUiCatalogViewItemArray &itemsDragged, IDataObject *pDataObject, DWORD dwKeyState)
afx_msg LRESULT | OnBeginLabelEdit (WPARAM wParam, LPARAM lParam)
afx_msg void | OnCatalogItemCopy ()
afx_msg void | OnCatalogItemCut ()
afx_msg void | OnCatalogItemHelp ()
afx_msg void | OnCatalogItemInstallTool ()
afx_msg void | OnCatalogItemPaste ()
afx_msg void | OnCatalogItemProperties ()
afx_msg void | OnCatalogItemRefresh ()
afx_msg void | OnCatalogItemRemove ()
afx_msg void | OnCatalogItemRename ()
afx_msg void | OnCatalogParentProperties ()
afx_msg void | OnCatalogParentRefresh ()
afx_msg void | OnCatalogParentRename ()
afx_msg LRESULT | OnChildAdded (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnChildDeleted (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnChildDetached (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnCloseShapePalette (WPARAM wParam, LPARAM lParam)
afx_msg void | OnContextMenu (CWnd *pWnd, CPoint pos)
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg void | OnCustomize ()
afx_msg void | OnCustomizeCUI ()
afx_msg void | OnDestroy ()
afx_msg LRESULT | OnDragEnter (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragEnterToolbarItem (WPARAM wParam, LPARAM lParam)
virtual HRESULT | OnDragInProgress (DROPEFFECT dropEffect)
afx_msg LRESULT | OnDragLeave (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragLeaveToolbarItem (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragOver (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragOverToolbarItem (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragScroll (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDrop (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDropEx (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDropToolbarItem (WPARAM wParam, LPARAM lParam)
virtual LONG | OnEndAcadDrop (BOOL bSuccess)
afx_msg LRESULT | OnEndAcadDrop (WPARAM wParam, LPARAM lParam)
virtual void | OnEndDrag (DROPEFFECT dropEffect)
afx_msg LRESULT | OnEndLabelEdit (WPARAM wParam, LPARAM lParam)
afx_msg UINT | OnGetDlgCode ()
afx_msg LRESULT | OnGetItemCount (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetItemRect (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetItemTextLen (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetText (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGiveFeedback (WPARAM wParam, LPARAM lParam)
afx_msg BOOL | OnHelpInfo (HELPINFO *pHelpInfo)
virtual void | OnItemCopy (void)
virtual void | OnItemCut (void)
virtual void | OnItemHelp (void)
virtual void | OnItemInstallTool (void)
virtual void | OnItemPaste (void)
virtual void | OnItemProperties (void)
virtual void | OnItemRefresh (void)
virtual void | OnItemRemove (void)
virtual void | OnItemRename (void)
virtual void | OnLButtonClicked (UINT nFlags, CPoint point)
virtual void | OnLButtonDblClicked (UINT nFlags, CPoint point)
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint point)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnLButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnMButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnMButtonUp (UINT nFlags, CPoint point)
afx_msg void | OnMouseMove (UINT nFlags, CPoint point)
afx_msg BOOL | OnMouseWheel (UINT nFlags, short zDelta, CPoint pt)
afx_msg void | OnNewPalette ()
afx_msg void | OnPaint ()
afx_msg void | OnRButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnRButtonUp (UINT nFlags, CPoint point)
afx_msg LRESULT | OnRenderData (WPARAM wParam, LPARAM lParam)
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg void | OnSortByName ()
afx_msg void | OnSortByType ()
afx_msg void | OnTimer (UINT_PTR nIDEvent)
BOOL | OnToolTipGetDispInfo (UINT id, NMHDR *pNMHDR, LRESULT *pResult)
afx_msg void | OnTransparency ()
afx_msg void | OnViewButton ()
afx_msg void | OnViewOptions ()
afx_msg void | OnVScroll (UINT nSBCode, UINT nPos, CScrollBar *pScrollBar)

Additional Inherited Members

- Public Member Functions inherited from CAcTcUiCatalogView
CAcTcUiCatalogView (AcTcCatalogItem *pCatalogItem)
virtual BOOL | CanPaste (IDataObject *pDataObject)
virtual BOOL | Copy (const CAcTcUiCatalogViewItemArray &itemsCopied, IDataObject *pDataObject)
BOOL | Create (DWORD dwWndStyle, DWORD dwCatalogViewStyle, const RECT &rect, CWnd *pParent, UINT nID=ACTCUI_IDW_CATALOGVIEW)
CEdit * | EditLabel (int nIndex)
BOOL | EndLabelEdit (BOOL bCancel=FALSE)
BOOL | EnsureVisible (int nIndex, BOOL bPartialOk)
AcTcCatalogItem * | GetCatalogItem (void) const
DWORD | GetCatalogViewStyle (void) const
int | GetColumnsInPage (void) const
CAcTcUiCatalogViewItem * | GetCurrentItem (void) const
DWORD | GetDragDropOption (void) const
POSITION | GetFirstSelectedItemPosition (void) const
int | GetFirstVisibleItemIndex (BOOL bPartialOk=TRUE) const
BOOL | GetImageSize (LPSIZE lpSize) const
BOOL | GetInsertMark (int &nIndex, BOOL &bAfter) const
CAcTcUiCatalogViewItem * | GetItem (int iIndex) const
int | GetItemCount (void) const
DWORD | GetItemData (int iIndex) const
CAcTcUiCatalogViewItem * | GetItemFromPoint (const CPoint &pt)
int | GetItemIndex (CAcTcUiCatalogViewItem *pItem) const
BOOL | GetItemOrder (AcTcCatalogItemArray &items) const
BOOL | GetItemRect (int iIndex, LPRECT lpRect, int nCode) const
int | GetLastVisibleItemIndex (BOOL bPartialOk=TRUE) const
virtual BOOL | GetMinimumSize (CSize &size)
CAcTcUiCatalogViewItem * | GetNextSelectedItem (POSITION &pos) const
int | GetOverlayImageAlignment (void) const
BOOL | GetOverlayImageSize (LPSIZE lpSize) const
int | GetRowsInPage (BOOL bIncludePartialRows) const
CAcTcUiScheme * | GetScheme (void) const
int | GetSelectedCount (void) const
CAcTcUiCatalogViewItem * | GetSelectedItem (void) const
BOOL | GetViewRect (LPRECT lpRect) const
int | HitTest (const CPoint &pt, UINT *pHitFlags) const
BOOL | IsLabelEditing (void) const
BOOL | Load (IUnknown *pUnk)
virtual BOOL | Paste (IDataObject *pDataObject, int iIndex=-1, AcTcCatalogItemArray *pNewTools=NULL)
virtual BOOL | PreTranslateMessage (MSG *pMsg)
BOOL | ResetItemOrder (void)
BOOL | Save (IUnknown *pUnk)
BOOL | Scroll (CSize sizeScroll)
BOOL | SelectItem (int nIndex, BOOL bSelect=TRUE)
BOOL | SelectItemRange (int nStartIndex, int nEndIndex, BOOL bSelect=TRUE)
BOOL | SetCatalogItem (AcTcCatalogItem *pCatalogItem)
BOOL | SetCatalogViewStyle (DWORD dwStyle)
BOOL | SetDragDropOption (DWORD dwOption)
BOOL | SetImageSize (const SIZE &size)
BOOL | SetInsertMark (int nIndex, BOOL bAfter=FALSE)
BOOL | SetItemData (int iIndex, DWORD dwData)
BOOL | SetItemOrder (const AcTcCatalogItemArray &items)
BOOL | SetOverlayImageAlignment (int nAlignment)
BOOL | SetOverlayImageSize (const SIZE &size)
BOOL | Sort (int nSortOption)
BOOL | Update (BOOL bRedraw=TRUE)
- Protected Attributes inherited from CAcTcUiCatalogView
void * | mpImpObj
The documentation for this class was generated from the following file:
  • actcuipaletteview.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcTcUiPaletteView Member List

This is the complete list of members for CAcTcUiPaletteView, including all inherited members.

AddContextMenuItems(CMenu *pMenu, int nHitFlag) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
CAcTcUiCatalogView() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
CAcTcUiCatalogView(AcTcCatalogItem *pCatalogItem) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
CAcTcUiCatalogView(AcTcUiSystemInternals *) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
CAcTcUiPaletteView() (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView |
CAcTcUiPaletteView(AcTcUiSystemInternals *) (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protected
CanPaste(IDataObject *pDataObject) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
Copy(const CAcTcUiCatalogViewItemArray &itemsCopied, IDataObject *pDataObject) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
Create(DWORD dwWndStyle, DWORD dwCatalogViewStyle, const RECT &rect, CWnd *pParent, UINT nID=ACTCUI_IDW_CATALOGVIEW) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
DragEnter(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protectedvirtual
DragLeave(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protectedvirtual
DragOver(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protectedvirtual
Drop(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protectedvirtual
DropEx(ADUI_DRAGDATA *pDragData) (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protectedvirtual
EditLabel(int nIndex) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
EndLabelEdit(BOOL bCancel=FALSE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
EnsureVisible(int nIndex, BOOL bPartialOk) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetCatalogItem(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetCatalogViewStyle(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetColumnsInPage(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetCurrentItem(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetDragDropOption(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetFirstSelectedItemPosition(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetFirstVisibleItemIndex(BOOL bPartialOk=TRUE) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetImageSize(LPSIZE lpSize) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetInsertMark(int &nIndex, BOOL &bAfter) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItem(int iIndex) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemCount(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemData(int iIndex) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemFromPoint(const CPoint &pt) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemIndex(CAcTcUiCatalogViewItem *pItem) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemOrder(AcTcCatalogItemArray &items) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetItemRect(int iIndex, LPRECT lpRect, int nCode) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetLastVisibleItemIndex(BOOL bPartialOk=TRUE) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetMinimumSize(CSize &size) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
GetNextSelectedItem(POSITION &pos) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetOverlayImageAlignment(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetOverlayImageSize(LPSIZE lpSize) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetRowsInPage(BOOL bIncludePartialRows) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetScheme(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetSelectedCount(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetSelectedItem(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
GetViewRect(LPRECT lpRect) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
HitTest(const CPoint &pt, UINT *pHitFlags) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
IsLabelEditing(void) const (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Load(IUnknown *pUnk) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
mpImpObj (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnAddSeparator() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnAddText() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnAllowDocking() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnAutoHide() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnBeginAcadDrop(BOOL *pCancelDrop) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnBeginAcadDrop(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnBeginDrag(const CAcTcUiCatalogViewItemArray &itemsDragged, IDataObject *pDataObject, DWORD dwKeyState) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnBeginLabelEdit(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemCopy() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemCut() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemHelp() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemInstallTool() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemPaste() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemProperties() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemRefresh() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemRemove() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemRemoveImage() (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protected
OnCatalogItemRename() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogItemSpecifyImage() (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protected
OnCatalogItemUpdateImage() (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protected
OnCatalogParentProperties() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogParentRefresh() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCatalogParentRename() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnChildAdded(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnChildDeleted(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnChildDetached(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCloseShapePalette(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnContextMenu(CWnd *pWnd, CPoint pos) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCustomize() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnCustomizeCUI() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDestroy() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragEnter(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragEnterToolbarItem(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragInProgress(DROPEFFECT dropEffect) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnDragLeave(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragLeaveToolbarItem(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragOver(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragOverToolbarItem(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDragScroll(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDrop(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDropEx(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnDropToolbarItem(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnEndAcadDrop(BOOL bSuccess) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnEndAcadDrop(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnEndDrag(DROPEFFECT dropEffect) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnEndLabelEdit(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetDlgCode() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetItemCount(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetItemRect(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetItemTextLen(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGetText(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnGiveFeedback(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnHelpInfo(HELPINFO *pHelpInfo) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnInvokeCommand(UINT nID) (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protected
OnItemCopy(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemCut(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemHelp(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemInstallTool(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemPaste(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemProperties(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemRefresh(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemRemove(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnItemRename(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protected
OnLButtonClicked(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnLButtonDblClicked(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnLButtonDown(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnLButtonUp(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnMButtonDown(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnMButtonUp(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnMouseMove(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnNewPalette() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnPaint() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnPaletteRemove() (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protected
OnRButtonDown(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnRButtonUp(UINT nFlags, CPoint point) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnRenderData(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnSize(UINT nType, int cx, int cy) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnSortByName() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnSortByType() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | protected
OnTimer(UINT_PTR nIDEvent) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnToolTipGetDispInfo(UINT id, NMHDR *pNMHDR, LRESULT *pResult) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnTransparency() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnViewButton() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnViewOptions() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
OnVScroll(UINT nSBCode, UINT nPos, CScrollBar *pScrollBar) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | protected
Paste(IDataObject *pDataObject, int iIndex=-1, AcTcCatalogItemArray *pNewTools=NULL) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
PreTranslateMessage(MSG *pMsg) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
ResetItemOrder(void) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Save(IUnknown *pUnk) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Scroll(CSize sizeScroll) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SelectItem(int nIndex, BOOL bSelect=TRUE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SelectItemRange(int nStartIndex, int nEndIndex, BOOL bSelect=TRUE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetCatalogItem(AcTcCatalogItem *pCatalogItem) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetCatalogViewStyle(DWORD dwStyle) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetDragDropOption(DWORD dwOption) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetImageSize(const SIZE &size) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetInsertMark(int nIndex, BOOL bAfter=FALSE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetItemData(int iIndex, DWORD dwData) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetItemOrder(const AcTcCatalogItemArray &items) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetOverlayImageAlignment(int nAlignment) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
SetOverlayImageSize(const SIZE &size) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Sort(int nSortOption) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
Update(BOOL bRedraw=TRUE) (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView |
~CAcTcUiCatalogView() (defined in CAcTcUiCatalogView) | CAcTcUiCatalogView | virtual
~CAcTcUiPaletteView() (defined in CAcTcUiPaletteView) | CAcTcUiPaletteView | virtual


ZRX API Reference: CAcTcUiScheme Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Attributes | Friends | List of all members
CAcTcUiScheme Class Reference

Public Types

enum | RefreshScope { kAllPalettes = (0x1 << 0), kRefreshEnabledPalettes = (0x1 << 1), kAutoRefreshEnabledPalettes = (0x1 << 2) }
enum | ShowOption { kShow = (0x1 << 0), kHide = (0x1 << 1), kSaveState = (0x1 << 2), kRestoreState = (0x1 << 3) }

Public Member Functions

CAcTcUiScheme (AcTcScheme *pScheme)
CAcTcUiToolPaletteSet * | CreatePaletteSet (LPCTSTR pszPalSetName)
BOOL | Export (LPCTSTR pszFile)
BOOL | Export (LPCTSTR pszFile, const AcTcUiToolPaletteArray *palettes)
BOOL | FindPalette (const AcTcCatalogItem *pItem, CAcTcUiToolPalette **ppToolPalette) const
BOOL | FindPalette (const AcTcCatalogItem *pItem, CAcTcUiToolPalette **ppToolPalette, CAcTcUiToolPaletteSet **ppToolPaletteSet) const
BOOL | FindPalette (const GUID &itemId, CAcTcUiToolPalette **ppToolPalette) const
BOOL | FindPalette (const GUID &itemId, CAcTcUiToolPalette **ppToolPalette, CAcTcUiToolPaletteSet **ppToolPaletteSet) const
CAcTcUiToolPaletteSet * | GetPaletteSet (void)
BOOL | Import (LPCTSTR pszFile)
BOOL | Load (IUnknown *pUnknown)
BOOL | Refresh (RefreshScope nScope)
BOOL | Refresh (RefreshScope nScope, DWORD dwRefreshFlag)
BOOL | Save (IUnknown *pUnknown)
BOOL | Show (ShowOption nOption, LONG_PTR lKey)
BOOL | Unload (void)

Protected Attributes

void * mpImpObj

Friends

class AcTcUiSystemInternals
The documentation for this class was generated from the following file:
  • AcTcUiScheme.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcTcUiScheme Member List

This is the complete list of members for CAcTcUiScheme, including all inherited members.

AcTcUiSystemInternals (defined in CAcTcUiScheme) | CAcTcUiScheme | friend
CAcTcUiScheme(AcTcScheme *pScheme) (defined in CAcTcUiScheme) | CAcTcUiScheme |
CreatePaletteSet(LPCTSTR pszPalSetName) (defined in CAcTcUiScheme) | CAcTcUiScheme |
Export(LPCTSTR pszFile) (defined in CAcTcUiScheme) | CAcTcUiScheme |
Export(LPCTSTR pszFile, const AcTcUiToolPaletteArray *palettes) (defined in CAcTcUiScheme) | CAcTcUiScheme |
FindPalette(const AcTcCatalogItem *pItem, CAcTcUiToolPalette **ppToolPalette) const (defined in CAcTcUiScheme) | CAcTcUiScheme |
FindPalette(const AcTcCatalogItem *pItem, CAcTcUiToolPalette **ppToolPalette, CAcTcUiToolPaletteSet **ppToolPaletteSet) const (defined in CAcTcUiScheme) | CAcTcUiScheme |
FindPalette(const GUID &itemId, CAcTcUiToolPalette **ppToolPalette) const (defined in CAcTcUiScheme) | CAcTcUiScheme |
FindPalette(const GUID &itemId, CAcTcUiToolPalette **ppToolPalette, CAcTcUiToolPaletteSet **ppToolPaletteSet) const (defined in CAcTcUiScheme) | CAcTcUiScheme |
GetPaletteSet(void) (defined in CAcTcUiScheme) | CAcTcUiScheme |
Import(LPCTSTR pszFile) (defined in CAcTcUiScheme) | CAcTcUiScheme |
kAllPalettes enum value (defined in CAcTcUiScheme) | CAcTcUiScheme |
kAutoRefreshEnabledPalettes enum value (defined in CAcTcUiScheme) | CAcTcUiScheme |
kHide enum value (defined in CAcTcUiScheme) | CAcTcUiScheme |
kRefreshEnabledPalettes enum value (defined in CAcTcUiScheme) | CAcTcUiScheme |
kRestoreState enum value (defined in CAcTcUiScheme) | CAcTcUiScheme |
kSaveState enum value (defined in CAcTcUiScheme) | CAcTcUiScheme |
kShow enum value (defined in CAcTcUiScheme) | CAcTcUiScheme |
Load(IUnknown *pUnknown) (defined in CAcTcUiScheme) | CAcTcUiScheme |
mpImpObj (defined in CAcTcUiScheme) | CAcTcUiScheme | protected
Refresh(RefreshScope nScope) (defined in CAcTcUiScheme) | CAcTcUiScheme |
Refresh(RefreshScope nScope, DWORD dwRefreshFlag) (defined in CAcTcUiScheme) | CAcTcUiScheme |
RefreshScope enum name (defined in CAcTcUiScheme) | CAcTcUiScheme |
Save(IUnknown *pUnknown) (defined in CAcTcUiScheme) | CAcTcUiScheme |
Show(ShowOption nOption, LONG_PTR lKey) (defined in CAcTcUiScheme) | CAcTcUiScheme |
ShowOption enum name (defined in CAcTcUiScheme) | CAcTcUiScheme |
Unload(void) (defined in CAcTcUiScheme) | CAcTcUiScheme |
~CAcTcUiScheme() (defined in CAcTcUiScheme) | CAcTcUiScheme | virtual


ZRX API Reference: CAcTcUiToolPalette Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAcTcUiToolPalette Class Reference
+ Inheritance diagram for CAcTcUiToolPalette:

Public Member Functions

virtual bool | CanFrameworkTakeFocus ()
virtual BOOL | CanPaste (IDataObject *pDataObject)
virtual BOOL | Create (CAdUiPaletteSet *pParent)
BOOL | Create (DWORD dwStyle, LPCTSTR pszName, CAdUiPaletteSet *pParent, DWORD dwPaletteStyle=0)
virtual BOOL | Export (IUnknown *pUnk, LPCTSTR pszRefPath)
virtual BOOL | GetMinimumSize (CSize &size)
CAcTcUiScheme * | GetScheme (void) const
CAcTcUiPaletteView * | GetView (void)
virtual BOOL | Import (IUnknown *pUnk, LPCTSTR pszRefPath)
virtual BOOL | Load (IUnknown *pUnk)
virtual BOOL | NameEditValidation (CEdit *pEdit)
virtual BOOL | OnKillActive (void)
virtual void | OnSetActive (void)
virtual BOOL | Paste (IDataObject *pDataObject, int iIndex=-1, AcTcCatalogItemArray *pNewTools=NULL)
virtual BOOL | Save (IUnknown *pUnk)
BOOL | SetView (CAcTcUiPaletteView *pView)
- Public Member Functions inherited from CAdUiPalette
virtual void | EditName (CPoint &ptLoc)
virtual void | EditName ()
BOOL | EditNameStyle ()
virtual CString | GetClassName ()
virtual BOOL | GetMaximumSize (CSize &size)
CString | GetName ()
CAdUiPaletteSet * | GetPaletteSet ()
DWORD | GetPaletteStyle ()
void | SetName (CString strName)
void | SetPaletteSet (CAdUiPaletteSet *pSet)
void | SetPaletteStyle (DWORD dwStyle)

Protected Member Functions

afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg LRESULT | OnDragEnter (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragLeave (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragOver (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDrop (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDropEx (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnEndNameEdit (WPARAM, LPARAM)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint point)
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg LRESULT | OnUpdate (WPARAM wParam, LPARAM lParam)
- Protected Member Functions inherited from CAdUiPalette
afx_msg LRESULT | OnBeginNameEdit (WPARAM, LPARAM)
afx_msg BOOL | OnEraseBkgnd (CDC *pdc)
afx_msg BOOL | OnSetCursor (CWnd *pwnd, UINT nHitTest, UINT msg)

Protected Attributes

void * mpImpObj

Friends

class AcTcUiSystemInternals

Additional Inherited Members

- Static Public Member Functions inherited from CAdUiPalette
static bool PaletteNameEditInProgress ()
The documentation for this class was generated from the following file:
  • actcuitoolpalette.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcTcUiToolPalette Member List

This is the complete list of members for CAcTcUiToolPalette, including all inherited members.

AcTcUiSystemInternals (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | friend
CAcTcUiToolPalette() (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette |
CAdUiPalette() (defined in CAdUiPalette) | CAdUiPalette |
CanFrameworkTakeFocus() (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
CanPaste(IDataObject *pDataObject) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
Create(CAdUiPaletteSet *pParent) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
Create(DWORD dwStyle, LPCTSTR pszName, CAdUiPaletteSet *pParent, DWORD dwPaletteStyle=0) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette |
EditName(CPoint &ptLoc) (defined in CAdUiPalette) | CAdUiPalette | virtual
EditName() (defined in CAdUiPalette) | CAdUiPalette | virtual
EditNameStyle() (defined in CAdUiPalette) | CAdUiPalette | inline
Export(IUnknown *pUnk, LPCTSTR pszRefPath) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
GetClassName() (defined in CAdUiPalette) | CAdUiPalette | virtual
GetMaximumSize(CSize &size) (defined in CAdUiPalette) | CAdUiPalette | virtual
GetMinimumSize(CSize &size) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
GetName() (defined in CAdUiPalette) | CAdUiPalette |
GetPaletteSet() (defined in CAdUiPalette) | CAdUiPalette | inline
GetPaletteStyle() (defined in CAdUiPalette) | CAdUiPalette |
GetScheme(void) const (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette |
GetView(void) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette |
Import(IUnknown *pUnk, LPCTSTR pszRefPath) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
Load(IUnknown *pUnk) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
mpImpObj (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
NameEditValidation(CEdit *pEdit) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
OnBeginNameEdit(WPARAM, LPARAM) (defined in CAdUiPalette) | CAdUiPalette | protected
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnDragEnter(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnDragLeave(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnDragOver(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnDrop(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnDropEx(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnEndNameEdit(WPARAM, LPARAM) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnEraseBkgnd(CDC *pdc) (defined in CAdUiPalette) | CAdUiPalette | protected
OnKillActive(void) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
OnLButtonDown(UINT nFlags, CPoint point) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnSetActive(void) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
OnSetCursor(CWnd *pwnd, UINT nHitTest, UINT msg) (defined in CAdUiPalette) | CAdUiPalette | protected
OnSetFocus(CWnd *pOldWnd) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnSize(UINT nType, int cx, int cy) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
OnUpdate(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | protected
PaletteNameEditInProgress() (defined in CAdUiPalette) | CAdUiPalette | inlinestatic
Paste(IDataObject *pDataObject, int iIndex=-1, AcTcCatalogItemArray *pNewTools=NULL) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
Save(IUnknown *pUnk) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
SetName(CString strName) (defined in CAdUiPalette) | CAdUiPalette |
SetPaletteSet(CAdUiPaletteSet *pSet) (defined in CAdUiPalette) | CAdUiPalette |
SetPaletteStyle(DWORD dwStyle) (defined in CAdUiPalette) | CAdUiPalette |
SetView(CAcTcUiPaletteView *pView) (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette |
~CAcTcUiToolPalette() (defined in CAcTcUiToolPalette) | CAcTcUiToolPalette | virtual
~CAdUiPalette() (defined in CAdUiPalette) | CAdUiPalette | virtual


ZRX API Reference: CAcTcUiToolPaletteGroup Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
CAcTcUiToolPaletteGroup Class Reference

Public Member Functions

int | AddItem (CAcTcUiToolPalette *pPalette)
int | AddItem (CAcTcUiToolPaletteGroup *pGroup)
virtual BOOL | Clone (CAcTcUiToolPaletteGroup *&pClone)
BOOL | DeleteAllItems (void)
BOOL | DeleteAllPalettes (void)
BOOL | DeleteItem (CAcTcUiToolPalette *pPalette, BOOL bRecursive=FALSE)
BOOL | DeleteItem (CAcTcUiToolPaletteGroup *pGroup)
CAcTcUiToolPaletteGroup * | FindGroup (LPCTSTR pszGroup, BOOL bRecursive=TRUE)
CAcTcUiToolPalette * | FindPalette (LPCTSTR pszPalName, CAcTcUiToolPaletteGroup **ppGroup, BOOL bRecursive=TRUE) const
int | GetActivePalette (void) const
BOOL | GetCustomData (IUnknown **ppUnknown)
CString | GetDescription (void) const
BOOL | GetItem (int iIndex, CAcTcUiToolPalette *&pPalette) const
BOOL | GetItem (int iIndex, CAcTcUiToolPaletteGroup *&pGroup) const
int | GetItemCount (void) const
CString | GetName (void) const
int | InsertItem (int iIndex, CAcTcUiToolPalette *pPalette)
int | InsertItem (int iIndex, CAcTcUiToolPaletteGroup *pGroup)
BOOL | IsItemPalette (int iIndex) const
virtual BOOL | Load (IUnknown *pUnk)
BOOL | RemoveItem (CAcTcUiToolPalette *pPalette, BOOL bRecursive=FALSE)
BOOL | RemoveItem (CAcTcUiToolPaletteGroup *pGroup)
BOOL | Reset (void)
virtual BOOL | Save (IUnknown *pUnk)
BOOL | SetActivePalette (int nIndex)
BOOL | SetDescription (LPCTSTR pszDesc)
BOOL | SetName (LPCTSTR pszName)

Protected Attributes

void * mpImpObj

Friends

class AcTcUiSystemInternals
The documentation for this class was generated from the following file:
  • actcuitoolpalettegroup.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcTcUiToolPaletteGroup Member List

This is the complete list of members for CAcTcUiToolPaletteGroup, including all inherited members.

AcTcUiSystemInternals (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup | friend
AddItem(CAcTcUiToolPalette *pPalette) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
AddItem(CAcTcUiToolPaletteGroup *pGroup) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
CAcTcUiToolPaletteGroup() (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
Clone(CAcTcUiToolPaletteGroup *&pClone) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup | virtual
DeleteAllItems(void) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
DeleteAllPalettes(void) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
DeleteItem(CAcTcUiToolPalette *pPalette, BOOL bRecursive=FALSE) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
DeleteItem(CAcTcUiToolPaletteGroup *pGroup) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
FindGroup(LPCTSTR pszGroup, BOOL bRecursive=TRUE) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
FindPalette(LPCTSTR pszPalName, CAcTcUiToolPaletteGroup **ppGroup, BOOL bRecursive=TRUE) const (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
GetActivePalette(void) const (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
GetCustomData(IUnknown **ppUnknown) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
GetDescription(void) const (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
GetItem(int iIndex, CAcTcUiToolPalette *&pPalette) const (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
GetItem(int iIndex, CAcTcUiToolPaletteGroup *&pGroup) const (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
GetItemCount(void) const (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
GetName(void) const (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
InsertItem(int iIndex, CAcTcUiToolPalette *pPalette) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
InsertItem(int iIndex, CAcTcUiToolPaletteGroup *pGroup) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
IsItemPalette(int iIndex) const (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
Load(IUnknown *pUnk) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup | virtual
mpImpObj (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup | protected
RemoveItem(CAcTcUiToolPalette *pPalette, BOOL bRecursive=FALSE) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
RemoveItem(CAcTcUiToolPaletteGroup *pGroup) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
Reset(void) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
Save(IUnknown *pUnk) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup | virtual
SetActivePalette(int nIndex) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
SetDescription(LPCTSTR pszDesc) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
SetName(LPCTSTR pszName) (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup |
~CAcTcUiToolPaletteGroup() (defined in CAcTcUiToolPaletteGroup) | CAcTcUiToolPaletteGroup | virtual


ZRX API Reference: CAcTcUiToolPaletteSet Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
CAcTcUiToolPaletteSet Class Reference
+ Inheritance diagram for CAcTcUiToolPaletteSet:

Public Member Functions

int | AddPalette (CAdUiPalette *pPalette)
virtual BOOL | Export (IUnknown *pUnk, LPCTSTR pszRefPath)
CAcTcUiToolPalette * | FindPalette (LPCTSTR pszPalName, CAcTcUiToolPaletteGroup **ppGroup, BOOL bSearchOnlyCurrentGroup) const
CAcTcUiToolPaletteGroup * | GetActivePaletteGroup (void)
BOOL | GetActivePaletteGroup (LPTSTR pszGroup, int cbSize) const
CAcTcUiToolPaletteGroup * | GetAllPalettesGroup (void)
CAcTcUiScheme * | GetScheme (void) const
CAcTcUiToolPaletteGroup * | GetToolPaletteGroup (BOOL bCreate=FALSE)
virtual BOOL | HitTest (CPoint pt, UINT &nFlag, DWORD &dwData)
virtual BOOL | Import (IUnknown *pUnk, LPCTSTR pszRefPath)
int | InsertPalette (int iIndex, CAdUiPalette *pPalette)
virtual BOOL | Load (IUnknown *pUnk)
BOOL | RemovePalette (CAdUiPalette *pPalette)
BOOL | RemovePalette (int iIndex)
virtual BOOL | Save (IUnknown *pUnk)
BOOL | SetActivePalette (CAdUiPalette *pPalette)
BOOL | SetActivePalette (int nPaletteIndex)
BOOL | SetActivePalette (LPCTSTR pszPalName, BOOL bSearchOnlyCurrentGroup) const
BOOL | SetActivePaletteGroup (CAcTcUiToolPaletteGroup *pGroup)
BOOL | SetActivePaletteGroup (LPCTSTR pszGroup)
BOOL | Show (void)
BOOL | Show (BOOL bShow)
virtual void | TitleBarLocationUpdated (AdUiTitleBarLocation newLoc)
- Public Member Functions inherited from CAdUiPaletteSet
BOOL | AutoRollupStyle ()
CAdUiPaletteSet (int nStyle=0)
BOOL | CloseButtonStyle ()
BOOL | Create (LPCTSTR strTitle, DWORD dwStyle, const RECT &rect, CWnd *pwndParent, DWORD dwPaletteSetStyle=PSS_PROPERTIES_MENU|PSS_AUTO_ROLLUP|PSS_CLOSE_BUTTON|PSS_SNAP)
BOOL | EditNameStyle ()
void | EnableDocking (DWORD dwDockStyle)
CAdUiPalette * | GetActivePalette ()
int | GetActivePaletteTabIndex ()
BOOL | GetAutoRollup ()
void | GetFullRect (CRect &rect)
CString | GetName ()
BOOL | GetNonClientSize (CSize &size)
int | GetOpacity () const
CAdUiPalette * | GetPalette (int nIndex)
int | GetPaletteCount ()
DWORD | GetPaletteSetStyle ()
int | GetTabIndex (CAdUiPalette *pPalette)
CAdUiTheme * | GetTheme ()
CFont * | GetWindowFont ()
virtual BOOL | NameEditValidation (CEdit *pEdit)
void | OnTogglePin ()
virtual BOOL | PreTranslateMessage (MSG *msg)
BOOL | PropertiesMenuStyle ()
BOOL | RolledUp ()
void | RollOut (bool bDelay=false)
void | RollUp ()
bool | SetAllowTransparency (CString key, bool bDefault)
BOOL | SetAutoRollup (BOOL bSet=TRUE)
BOOL | SetName (LPCTSTR pszName)
BOOL | SetOpacity (int nOpacity)
void | SetPaletteSetStyle (DWORD dwStyle)
CAdUiTheme * | SetTheme (CAdUiTheme *pTheme)
void | SetTitleBarLocation (AdUiTitleBarLocation loc)
BOOL | SinglePaletteTabStyle ()
BOOL | SnapStyle ()
AdUiTitleBarLocation | TitleBarLocation ()
void | UpdateTabs ()
BOOL | UseSinglePaletteTabNameStyle ()
- Public Member Functions inherited from CAdUiDockControlBar
bool | AdjustVertDockedBarHeight (int nHeight)
bool | AllowDockingMenuItemState ()
bool | Anchored ()
CAdUiDockControlBar (int nStyle=ADUI_DOCK_CS_STDMOUSECLICKS)
virtual CSize | CalcFixedLayout (BOOL bStretch, BOOL bHorz)
BOOL | Create (CWnd *pParent, LPCTSTR lpszTitle, UINT nID, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, const RECT &rect=CFrameWnd::rectDefault)
BOOL | Create (LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
void | DockControlBar (UINT nOrientation, RECT *pRect)
DWORD | GetDockStyle ()
void | GetFloatingRect (CRect *pFloatingPos)
void | GetPersistedDockingRect (CRect *pDockRect)
void | GetPersistedFloatingRect (CRect *pFloatRect)
CLSID * | GetToolID ()
void | InitFloatingPosition (CRect *pSizeFloating)
BOOL | IsFloating ()
void | RestoreControlBar (UINT nPreferredOrientation=AFX_IDW_DOCKBAR_LEFT, CRect *pSizeFloating=NULL)
void | SetAllowDockingMenuItemState (bool bState)
void | SetToolID (CLSID *pCLSID)
void | TileInRow ()

Protected Member Functions

virtual BOOL | AddContextMenuItems (CMenu *pMenu, int nHitFlag, int nRightClkTab=0)
virtual void | DestroyStackedPaletteSet (void)
virtual BOOL | OnBeginDrag (COleDataSource *pDataSource, CPtrArray &arrayPalettes)
virtual BOOL | OnBeginMove (COleDataSource *pDataSource, CPtrArray &arrayPalettes)
afx_msg void | OnClose ()
afx_msg int | OnCreate (LPCREATESTRUCT lpCreateStruct)
afx_msg LRESULT | OnDragEnter (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragLeave (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDragOver (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDrop (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnDropEx (WPARAM wParam, LPARAM lParam)
virtual void | OnEndDrag (DROPEFFECT dropEffect)
virtual void | OnEndMove (DROPEFFECT dropEffect)
afx_msg void | OnInvokeCommand (UINT nID)
afx_msg void | OnMoveDown ()
afx_msg void | OnMoveUp ()
afx_msg void | OnNewPalette ()
afx_msg void | OnPaletteProperties ()
afx_msg void | OnPaste ()
afx_msg void | OnRefreshActivePalette ()
afx_msg void | OnRefreshPaletteSet ()
afx_msg void | OnRemoveActivePalette ()
afx_msg void | OnRemovePalette ()
afx_msg void | OnRemovePaletteSet ()
virtual BOOL | OnRenderData (LPFORMATETC lpFormatEtc, LPSTGMEDIUM lpStgMedium)
afx_msg LRESULT | OnRenderData (WPARAM wParam, LPARAM lParam)
afx_msg void | OnSelectPaletteGroup (UINT nID)
afx_msg void | OnShowCustomizeDialog ()
afx_msg void | OnShowCustomizeDialogCUI ()
afx_msg void | OnShowWindow (BOOL bShow, UINT nStatus)
virtual void | OnTabDrag (CPtrArray &arrayPalettes)
virtual void | OnTearOff (CAdUiPaletteSet *pSet)
afx_msg void | OnTimer (UINT_PTR nIDEvent)
afx_msg LRESULT | OnUpdate (WPARAM wParam, LPARAM lParam)
afx_msg void | OnViewOptions ()
afx_msg void | OnWindowPosChanged (WINDOWPOS *lpwndpos)
virtual void | ThemeModified (AdUiThemeElement element)
- Protected Member Functions inherited from CAdUiPaletteSet
virtual void | AutoRollupChanged (BOOL bAutoRollupIsOn)
virtual bool | CanFrameworkTakeFocus ()
virtual void | EditName ()
afx_msg void | EditPaletteName ()
void | GetAdjustedClientRect (CRect &rect)
virtual int | GetBottomReservedHeight ()
virtual void | GetMaximumSize (CSize &size)
virtual void | GetMinimumSize (CSize &size)
virtual int | GetTopReservedHeight ()
afx_msg void | OnActivate (UINT nState, CWnd *pWndOther, BOOL bMinimized)
afx_msg LRESULT | OnBeginNameEdit (WPARAM, LPARAM)
virtual void | OnContextMenu (CWnd *pWnd, CPoint pos)
afx_msg LRESULT | OnEndNameEdit (WPARAM, LPARAM)
afx_msg BOOL | OnEraseBkgnd (CDC *pdc)
afx_msg LRESULT | OnFloatStatus (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetPaletteCount (WPARAM wParam, LPARAM lParam)
afx_msg LRESULT | OnGetPaletteName (WPARAM wParam, LPARAM lParam)
afx_msg void | OnLButtonDblClk (UINT nFlags, CPoint pt)
afx_msg void | OnLButtonDown (UINT nFlags, CPoint pt)
afx_msg void | OnLButtonUp (UINT nFlags, CPoint pt)
afx_msg void | OnMenuClose ()
afx_msg void | OnMenuMove ()
afx_msg void | OnMenuSize ()
afx_msg void | OnMouseMove (UINT nFlags, CPoint pt)
afx_msg LRESULT | OnNcCalcSize (WPARAM wParam, LPARAM lParam)
afx_msg UINT | OnNcHitTest (CPoint point)
afx_msg void | OnNcPaint ()
afx_msg void | OnOptionTranslucency ()
afx_msg void | OnSetFocus (CWnd *pOldWnd)
afx_msg LRESULT | OnSetPaletteActive (WPARAM wParam, LPARAM lParam)
afx_msg void | OnSize (UINT nType, int cx, int cy)
afx_msg void | OnWindowPosChanging (WINDOWPOS *lpwndpos)
virtual void | PaletteActivated (CAdUiPalette *pActivated, CAdUiPalette *pDeactivated)
virtual void | PaletteAdded (CAdUiPalette *pPalette)
virtual void | PaletteRemoved (CAdUiPalette *pPalette)
- Protected Member Functions inherited from CAdUiDockControlBar
virtual BOOL | AddCustomMenuItems (LPARAM hMenu)
bool | CloseButtonVisible ()
virtual BOOL | CreateControlBar (LPCREATESTRUCT lpCreateStruct)
virtual void | GetFloatingMinSize (long *pnMinWidth, long *pnMinHeight)
void | GetUsedRect (CRect &rect)
afx_msg void | OnAllowDock ()
afx_msg void | OnAnchor ()
afx_msg void | OnAnchorLeft ()
afx_msg void | OnAnchorRight ()
virtual bool | OnClosing ()
virtual BOOL | OnCommand (WPARAM wParam, LPARAM lParam)
afx_msg void | OnHideBar ()
afx_msg void | OnPaint ()
virtual void | OnUserSizing (UINT nSide, LPRECT pRect)
afx_msg void | OnWindowPosChanged (WINDOWPOS FAR *lpwndpos)
virtual void | PaintControlBar (CDC *pDC)
void | ShowCloseButton (bool bShow)
virtual void | SizeChanged (CRect *lpRect, BOOL bFloating, int flags)

Protected Attributes

void * | mpImpObj
- Protected Attributes inherited from CAdUiPaletteSet
CAdUiImpPaletteSet * | m_pImpPS

Friends

class AcTcUiSystemInternals

Additional Inherited Members

- Public Types inherited from CAdUiPaletteSet
enum | AdUiTitleBarLocation { kLeft = 0, kRight }
- Static Public Member Functions inherited from CAdUiPaletteSet
static UINT | GetGlobalTransparency ()
static bool | SetGlobalTransparency (UINT flag)
- Protected Types inherited from CAdUiDockControlBar
enum | { btnWidth = 12, btnHeight = 12, idCloseBtn = 10001, idPinBtn = 10002 }
The documentation for this class was generated from the following file:
  • actcuitoolpaletteset.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CAcTcUiToolPaletteSet Member List

This is the complete list of members for CAcTcUiToolPaletteSet, including all inherited members.

AcTcUiSystemInternals (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | friend
AddContextMenuItems(CMenu *pMenu, int nHitFlag, int nRightClkTab=0) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
AddCustomMenuItems(LPARAM hMenu) | CAdUiDockControlBar | protectedvirtual
AddPalette(CAdUiPalette *pPalette) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
AdjustVertDockedBarHeight(int nHeight) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
AdUiTitleBarLocation enum name (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
AllowDockingMenuItemState() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
Anchored() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
AutoRollupChanged(BOOL bAutoRollupIsOn) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | inlineprotectedvirtual
AutoRollupStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
btnHeight enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
btnWidth enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
CAcTcUiToolPaletteSet() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
CAdUiDockControlBar(int nStyle=ADUI_DOCK_CS_STDMOUSECLICKS) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
CAdUiPaletteSet(int nStyle=0) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
CalcFixedLayout(BOOL bStretch, BOOL bHorz) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
CanFrameworkTakeFocus() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
CloseButtonStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
CloseButtonVisible() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotected
Create(LPCTSTR strTitle, DWORD dwStyle, const RECT &rect, CWnd *pwndParent, DWORD dwPaletteSetStyle=PSS_PROPERTIES_MENU|PSS_AUTO_ROLLUP|PSS_CLOSE_BUTTON|PSS_SNAP) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
Create(CWnd *pParent, LPCTSTR lpszTitle, UINT nID, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, const RECT &rect=CFrameWnd::rectDefault) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
CreateControlBar(LPCREATESTRUCT lpCreateStruct) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
DestroyStackedPaletteSet(void) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
DockControlBar(UINT nOrientation, RECT *pRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
EditName() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
EditNameStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
EditPaletteName() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
EnableDocking(DWORD dwDockStyle) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
Export(IUnknown *pUnk, LPCTSTR pszRefPath) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | virtual
FindPalette(LPCTSTR pszPalName, CAcTcUiToolPaletteGroup **ppGroup, BOOL bSearchOnlyCurrentGroup) const (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
GetActivePalette() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetActivePaletteGroup(void) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
GetActivePaletteGroup(LPTSTR pszGroup, int cbSize) const (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
GetActivePaletteTabIndex() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetAdjustedClientRect(CRect &rect) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
GetAllPalettesGroup(void) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
GetAutoRollup() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetBottomReservedHeight() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
GetDockStyle() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
GetFloatingMinSize(long *pnMinWidth, long *pnMinHeight) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
GetFloatingRect(CRect *pFloatingPos) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetFullRect(CRect &rect) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetGlobalTransparency() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | static
GetMaximumSize(CSize &size) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
GetMinimumSize(CSize &size) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
GetName() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetNonClientSize(CSize &size) | CAdUiPaletteSet |
GetOpacity() const (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetPalette(int nIndex) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetPaletteCount() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetPaletteSetStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetPersistedDockingRect(CRect *pDockRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetPersistedFloatingRect(CRect *pFloatRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
GetScheme(void) const (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
GetTabIndex(CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetTheme() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
GetToolID() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
GetToolPaletteGroup(BOOL bCreate=FALSE) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
GetToolsRestartMode() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | static
GetTopReservedHeight() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
GetUsedRect(CRect &rect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
GetWindowFont() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
HitTest(CPoint pt, UINT &nFlag, DWORD &dwData) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | virtual
idCloseBtn enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
idPinBtn enum value (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
Import(IUnknown *pUnk, LPCTSTR pszRefPath) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | virtual
InitFloatingPosition(CRect *pSizeFloating) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
InsertPalette(int iIndex, CAdUiPalette *pPalette) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
IsFloating() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
kLeft enum value (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
kRight enum value (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
Load(IUnknown *pUnk) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | virtual
m_pImpPS (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
mpImpObj (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
NameEditValidation(CEdit *pEdit) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | virtual
OnActivate(UINT nState, CWnd *pWndOther, BOOL bMinimized) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnAllowDock() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnAnchor() | CAdUiDockControlBar | protected
OnAnchorLeft() | CAdUiDockControlBar | protected
OnAnchorRight() | CAdUiDockControlBar | protected
OnBeginDrag(COleDataSource *pDataSource, CPtrArray &arrayPalettes) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
OnBeginMove(COleDataSource *pDataSource, CPtrArray &arrayPalettes) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
OnBeginNameEdit(WPARAM, LPARAM) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnClose() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnClosing() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
OnCommand(WPARAM wParam, LPARAM lParam) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
OnContextMenu(CWnd *pWnd, CPoint pos) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protectedvirtual
OnCreate(LPCREATESTRUCT lpCreateStruct) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnDragEnter(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnDragLeave(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnDragOver(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnDrop(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnDropEx(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnEndDrag(DROPEFFECT dropEffect) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
OnEndMove(DROPEFFECT dropEffect) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
OnEndNameEdit(WPARAM, LPARAM) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnEraseBkgnd(CDC *pdc) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnFloatStatus(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnGetPaletteCount(WPARAM wParam, LPARAM lParam) | CAdUiPaletteSet | protected
OnGetPaletteName(WPARAM wParam, LPARAM lParam) | CAdUiPaletteSet | protected
OnHideBar() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnInvokeCommand(UINT nID) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnLButtonDblClk(UINT nFlags, CPoint pt) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnLButtonDown(UINT nFlags, CPoint pt) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnLButtonUp(UINT nFlags, CPoint pt) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnMenuClose() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnMenuMove() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnMenuSize() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnMouseMove(UINT nFlags, CPoint pt) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnMoveDown() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnMoveUp() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnNcCalcSize(WPARAM wParam, LPARAM lParam) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnNcHitTest(CPoint point) | CAdUiPaletteSet | protected
OnNcPaint() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnNewPalette() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnOptionTranslucency() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnPaint() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnPaletteProperties() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnPaste() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnRefreshActivePalette() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnRefreshPaletteSet() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnRemoveActivePalette() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnRemovePalette() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnRemovePaletteSet() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnRenderData(LPFORMATETC lpFormatEtc, LPSTGMEDIUM lpStgMedium) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
OnRenderData(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnSelectPaletteGroup(UINT nID) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnSetFocus(CWnd *pOldWnd) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnSetPaletteActive(WPARAM wParam, LPARAM lParam) | CAdUiPaletteSet | protected
OnShowCustomizeDialog() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnShowCustomizeDialogCUI() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnShowWindow(BOOL bShow, UINT nStatus) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnSize(UINT nType, int cx, int cy) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
OnTabDrag(CPtrArray &arrayPalettes) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
OnTearOff(CAdUiPaletteSet *pSet) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
OnTimer(UINT_PTR nIDEvent) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnTogglePin() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
OnUpdate(WPARAM wParam, LPARAM lParam) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnUserSizing(UINT nSide, LPRECT pRect) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotectedvirtual
OnViewOptions() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnWindowPosChanged(WINDOWPOS *lpwndpos) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protected
OnWindowPosChanged(WINDOWPOS FAR *lpwndpos) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protected
OnWindowPosChanging(WINDOWPOS *lpwndpos) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | protected
PaintControlBar(CDC *pDC) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | protectedvirtual
PaletteActivated(CAdUiPalette *pActivated, CAdUiPalette *pDeactivated) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | inlineprotectedvirtual
PaletteAdded(CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | inlineprotectedvirtual
PaletteRemoved(CAdUiPalette *pPalette) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | inlineprotectedvirtual
PreTranslateMessage(MSG *msg) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | virtual
PropertiesMenuStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
RemovePalette(CAdUiPalette *pPalette) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
RemovePalette(int iIndex) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
RestoreControlBar(UINT nPreferredOrientation=AFX_IDW_DOCKBAR_LEFT, CRect *pSizeFloating=NULL) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
RolledUp() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
RollOut(bool bDelay=false) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
RollUp() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
Save(IUnknown *pUnk) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | virtual
SetActivePalette(CAdUiPalette *pPalette) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
SetActivePalette(int nPaletteIndex) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
SetActivePalette(LPCTSTR pszPalName, BOOL bSearchOnlyCurrentGroup) const (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
SetActivePaletteGroup(CAcTcUiToolPaletteGroup *pGroup) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
SetActivePaletteGroup(LPCTSTR pszGroup) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
SetAllowDockingMenuItemState(bool bState) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inline
SetAllowTransparency(CString key, bool bDefault) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetAutoRollup(BOOL bSet=TRUE) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetGlobalTransparency(UINT flag) (defined in CAdUiPaletteSet) | CAdUiPaletteSet | static
SetName(LPCTSTR pszName) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetOpacity(int nOpacity) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetPaletteSetStyle(DWORD dwStyle) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetTheme(CAdUiTheme *pTheme) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetTitleBarLocation(AdUiTitleBarLocation loc) (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SetToolID(CLSID *pCLSID) (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
SetToolsRestartMode(bool bMode) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | static
Show(void) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
Show(BOOL bShow) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet |
ShowCloseButton(bool bShow) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotected
SinglePaletteTabStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
SizeChanged(CRect *lpRect, BOOL bFloating, int flags) (defined in CAdUiDockControlBar) | CAdUiDockControlBar | inlineprotectedvirtual
SnapStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
ThemeModified(AdUiThemeElement element) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | protectedvirtual
TileInRow() (defined in CAdUiDockControlBar) | CAdUiDockControlBar |
TitleBarLocation() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
TitleBarLocationUpdated(AdUiTitleBarLocation newLoc) (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | virtual
UpdateTabs() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
UseSinglePaletteTabNameStyle() (defined in CAdUiPaletteSet) | CAdUiPaletteSet |
~CAcTcUiToolPaletteSet() (defined in CAcTcUiToolPaletteSet) | CAcTcUiToolPaletteSet | virtual
~CAdUiDockControlBar() (defined in CAdUiDockControlBar) | CAdUiDockControlBar | virtual
~CAdUiPaletteSet() (defined in CAdUiPaletteSet) | CAdUiPaletteSet | virtual


ZRX API Reference: CATCMDBTN_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
CATCMDBTN_ENTRY Struct Reference

Public Attributes

PROPCAT | m_CatID
const ACHAR * | m_lpDisBtnBmpRes
const ACHAR * | m_lpEnBtnBmpRes
UINT | m_nBtnNameId
UINT | m_nDisBtnBmpType
UINT | m_nEnBtnBmpType
long | m_nStyle
BUTTONPROC | m_pfnBtnProc
The documentation for this struct was generated from the following file:
  • opmimp.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CATCMDBTN_ENTRY Member List

This is the complete list of members for CATCMDBTN_ENTRY, including all inherited members.

m_CatID (defined in CATCMDBTN_ENTRY) | CATCMDBTN_ENTRY
m_lpDisBtnBmpRes (defined in CATCMDBTN_ENTRY) | CATCMDBTN_ENTRY
m_lpEnBtnBmpRes (defined in CATCMDBTN_ENTRY) | CATCMDBTN_ENTRY
m_nBtnNameId (defined in CATCMDBTN_ENTRY) | CATCMDBTN_ENTRY
m_nDisBtnBmpType (defined in CATCMDBTN_ENTRY) | CATCMDBTN_ENTRY
m_nEnBtnBmpType (defined in CATCMDBTN_ENTRY) | CATCMDBTN_ENTRY
m_nStyle (defined in CATCMDBTN_ENTRY) | CATCMDBTN_ENTRY
m_pfnBtnProc (defined in CATCMDBTN_ENTRY) | CATCMDBTN_ENTRY


ZRX API Reference: CATEGORY_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
CATEGORY_ENTRY Struct Reference

Public Attributes

PROPCAT | m_CatID
UINT | m_nDescId
UINT | m_nNameId
long | m_nWeight
PROPCAT | m_ParentCatID
The documentation for this struct was generated from the following file:
  • opmimp.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CATEGORY_ENTRY Member List

This is the complete list of members for CATEGORY_ENTRY, including all inherited members.

m_CatID (defined in CATEGORY_ENTRY) | CATEGORY_ENTRY
m_nDescId (defined in CATEGORY_ENTRY) | CATEGORY_ENTRY
m_nNameId (defined in CATEGORY_ENTRY) | CATEGORY_ENTRY
m_nWeight (defined in CATEGORY_ENTRY) | CATEGORY_ENTRY
m_ParentCatID (defined in CATEGORY_ENTRY) | CATEGORY_ENTRY


ZRX API Reference: CMDBTN_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
CMDBTN_ENTRY Struct Reference

Public Attributes

const ACHAR * | m_lpDisBtnBmpRes
const ACHAR * | m_lpEnBtnBmpRes
UINT | m_nBtnNameId
UINT | m_nDisBtnBmpType
UINT | m_nEnBtnBmpType
long | m_nStyle
BUTTONPROC | m_pfnBtnProc
The documentation for this struct was generated from the following file:
  • opmimp.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CMDBTN_ENTRY Member List

This is the complete list of members for CMDBTN_ENTRY, including all inherited members.

m_lpDisBtnBmpRes (defined in CMDBTN_ENTRY) | CMDBTN_ENTRY
m_lpEnBtnBmpRes (defined in CMDBTN_ENTRY) | CMDBTN_ENTRY
m_nBtnNameId (defined in CMDBTN_ENTRY) | CMDBTN_ENTRY
m_nDisBtnBmpType (defined in CMDBTN_ENTRY) | CMDBTN_ENTRY
m_nEnBtnBmpType (defined in CMDBTN_ENTRY) | CMDBTN_ENTRY
m_nStyle (defined in CMDBTN_ENTRY) | CMDBTN_ENTRY
m_pfnBtnProc (defined in CMDBTN_ENTRY) | CMDBTN_ENTRY


ZRX API Reference: CTypedPtrArray Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
CTypedPtrArray Class Reference
+ Inheritance diagram for CTypedPtrArray:
The documentation for this class was generated from the following file:
  • ANavArray.h


ZRX API Reference: e2f_ent Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
e2f_ent Struct Reference

Public Attributes

long | adr1
long | adr2
short | color
short | flags
char | id
long | layerindex
long | materialId
long | npoly
long | nverts
long | truecolor
short | type
The documentation for this struct was generated from the following file:
  • scene.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
e2f_ent Member List

This is the complete list of members for e2f_ent, including all inherited members.

adr1 (defined in e2f_ent) | e2f_ent
adr2 (defined in e2f_ent) | e2f_ent
color (defined in e2f_ent) | e2f_ent
flags (defined in e2f_ent) | e2f_ent
id (defined in e2f_ent) | e2f_ent
layerindex (defined in e2f_ent) | e2f_ent
materialId (defined in e2f_ent) | e2f_ent
npoly (defined in e2f_ent) | e2f_ent
nverts (defined in e2f_ent) | e2f_ent
truecolor (defined in e2f_ent) | e2f_ent
type (defined in e2f_ent) | e2f_ent


ZRX API Reference: e2f_hdr Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
e2f_hdr Struct Reference

Public Attributes

unsigned long | bgcolor
char * | cmap
short | cmaplen
short | flags
char | id
long | nents
long | nlayers
long | npoly
short | version
The documentation for this struct was generated from the following file:
  • scene.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
e2f_hdr Member List

This is the complete list of members for e2f_hdr, including all inherited members.

bgcolor (defined in e2f_hdr) | e2f_hdr
cmap (defined in e2f_hdr) | e2f_hdr
cmaplen (defined in e2f_hdr) | e2f_hdr
flags (defined in e2f_hdr) | e2f_hdr
id (defined in e2f_hdr) | e2f_hdr
nents (defined in e2f_hdr) | e2f_hdr
nlayers (defined in e2f_hdr) | e2f_hdr
npoly (defined in e2f_hdr) | e2f_hdr
version (defined in e2f_hdr) | e2f_hdr


ZRX API Reference: e2f_layer Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
e2f_layer Struct Reference

Public Attributes

char | id
short | layernamelen
ACHAR * | lname
The documentation for this struct was generated from the following file:
  • scene.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
e2f_layer Member List

This is the complete list of members for e2f_layer, including all inherited members.

id (defined in e2f_layer) | e2f_layer
layernamelen (defined in e2f_layer) | e2f_layer
lname (defined in e2f_layer) | e2f_layer


ZRX API Reference: e2f_xform Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
e2f_xform Struct Reference

Public Attributes

short | flags
char | id
double | xfmatrix [4][4]
The documentation for this struct was generated from the following file:
  • scene.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
e2f_xform Member List

This is the complete list of members for e2f_xform, including all inherited members.

flags (defined in e2f_xform) | e2f_xform
id (defined in e2f_xform) | e2f_xform
xfmatrix (defined in e2f_xform) | e2f_xform


ZRX API Reference: fchnd Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
fchnd Struct Reference

Public Attributes

int | fcode
int(* | fhdl )()
struct fchnd * | next
The documentation for this struct was generated from the following file:
  • adsrxdef.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
fchnd Member List

This is the complete list of members for fchnd, including all inherited members.

fcode (defined in fchnd) | fchnd
fhdl (defined in fchnd) | fchnd
next (defined in fchnd) | fchnd


ZRX API Reference: IAcadBaseObject Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcadBaseObject Class Reference
+ Inheritance diagram for IAcadBaseObject:
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: IAcadBaseObject2 Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IAcadBaseObject2 Class Reference
+ Inheritance diagram for IAcadBaseObject2:
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: IConnectionPointContainerImpl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IConnectionPointContainerImpl Class Reference
+ Inheritance diagram for IConnectionPointContainerImpl:
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: IConnectionPointImpl Class Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IConnectionPointImpl Class Reference
+ Inheritance diagram for IConnectionPointImpl:
The documentation for this class was generated from the following file:
  • axtempl.h


ZRX API Reference: PER_PROP_DISP_ENTRY Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
PER_PROP_DISP_ENTRY Struct Reference

Public Attributes

bool | m_bFullView
DISPID | m_dispid
DWORD | m_dwIntegralHeight
const ACHAR * | m_lpEllipsisBmpRes
const ACHAR * | m_lpLeftIconRes
UINT | m_nEllipsisBmpType
UINT | m_nLeftIconType
long | m_nWeight
const ACHAR * | m_ProgID
COLORREF | m_TextColor
The documentation for this struct was generated from the following file:
  • opmimp.h


ZRX API Reference: scn_cmesh Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
scn_cmesh Struct Reference

Public Attributes

short | color
short | flags
char | id
short | m
short | mshtype
short | n
long | next
short | nverts
The documentation for this struct was generated from the following file:
  • scene.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
scn_cmesh Member List

This is the complete list of members for scn_cmesh, including all inherited members.

color (defined in scn_cmesh) | scn_cmesh
flags (defined in scn_cmesh) | scn_cmesh
id (defined in scn_cmesh) | scn_cmesh
m (defined in scn_cmesh) | scn_cmesh
mshtype (defined in scn_cmesh) | scn_cmesh
n (defined in scn_cmesh) | scn_cmesh
next (defined in scn_cmesh) | scn_cmesh
nverts (defined in scn_cmesh) | scn_cmesh


ZRX API Reference: scn_cvrt Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
scn_cvrt Struct Reference

Public Attributes

char | id
long | index
The documentation for this struct was generated from the following file:
  • scene.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
scn_cvrt Member List

This is the complete list of members for scn_cvrt, including all inherited members.

id (defined in scn_cvrt) | scn_cvrt
index (defined in scn_cvrt) | scn_cvrt


ZRX API Reference: scn_node Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
scn_node Struct Reference

Public Attributes

long | left
double | normal [3]
long | right
double | vertex [3]
The documentation for this struct was generated from the following file:
  • scene.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
scn_node Member List

This is the complete list of members for scn_node, including all inherited members.

left (defined in scn_node) | scn_node
normal (defined in scn_node) | scn_node
right (defined in scn_node) | scn_node
vertex (defined in scn_node) | scn_node


ZRX API Reference: scn_pmsh Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
scn_pmsh Struct Reference

Public Attributes

long | adr1
long | adr2
short | color
short | flags
char | id
long | layerindex
long | mapperId
short | ncvrtx
long | truecolor
The documentation for this struct was generated from the following file:
  • scene.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
scn_pmsh Member List

This is the complete list of members for scn_pmsh, including all inherited members.

adr1 (defined in scn_pmsh) | scn_pmsh
adr2 (defined in scn_pmsh) | scn_pmsh
color (defined in scn_pmsh) | scn_pmsh
flags (defined in scn_pmsh) | scn_pmsh
id (defined in scn_pmsh) | scn_pmsh
layerindex (defined in scn_pmsh) | scn_pmsh
mapperId (defined in scn_pmsh) | scn_pmsh
ncvrtx (defined in scn_pmsh) | scn_pmsh
truecolor (defined in scn_pmsh) | scn_pmsh


ZRX API Reference: scn_vrtc Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
scn_vrtc Struct Reference

Public Attributes

char | id
double | vert [3]
The documentation for this struct was generated from the following file:
  • scene.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
scn_vrtc Member List

This is the complete list of members for scn_vrtc, including all inherited members.

id (defined in scn_vrtc) | scn_vrtc
vert (defined in scn_vrtc) | scn_vrtc


ZRX API Reference: tagOPMDWORD Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
tagOPMDWORD Struct Reference

Public Attributes

ULONG | cElems
DWORD __RPC_FAR * | pElems
The documentation for this struct was generated from the following file:
  • opmext.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
tagOPMDWORD Member List

This is the complete list of members for tagOPMDWORD, including all inherited members.

cElems (defined in tagOPMDWORD) | tagOPMDWORD
pElems (defined in tagOPMDWORD) | tagOPMDWORD


ZRX API Reference: tagOPMLPOLESTR Struct Reference

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
tagOPMLPOLESTR Struct Reference

Public Attributes

ULONG | cElems
LPOLESTR __RPC_FAR * | pElems
The documentation for this struct was generated from the following file:
  • opmext.h


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
tagOPMLPOLESTR Member List

This is the complete list of members for tagOPMLPOLESTR, including all inherited members.

cElems (defined in tagOPMLPOLESTR) | tagOPMLPOLESTR
pElems (defined in tagOPMLPOLESTR) | tagOPMLPOLESTR


ZRX API Reference: Class Hierarchy

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 123456789]
o C _ADSSYMBOL_ENTRY |
o C _ARXCOMMAND_ENTRY |
o C _DBX_REGISTER_OBJECT_ENTRY |
o C _dlgControlTag |
o C _IID |
o C _OPM_DYNPROP_ENTRY |
o C Acad |
o C ACAD_OPMPROPMAP_ENTRY |
o C AcadApp |
o C AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid > |
o C AcAp |
o C AcApProfileManager |
o C AcApProfileManagerReactor |
o C AcApProfileStorage |
o C AcApStatusBar |
o C AcArray< T, R > |
| \ C AcAxPoint3dArray |
o C AcArrayMemCopyReallocator< T > |
o C AcArrayObjectCopyReallocator< T > |
o C AcAxDocLock |
o C AcAxObjectRef |
o C AcAxOleLinkManager |
o C AcAxPoint2dArray |
o C AcCell |
o C AcCellRange |
o C AcCFile |
o C AcCmColorBase |
| o C AcCmColor |
| \ C AcCmDialogColor |
o C AcCmEntityColor |
o C AcCmTransparency |
o C AcColorSettings |
o C AcColorSettingsEx |
o C AcCStdioFile |
o C AcDb |
o C AcDbAppSystemVariables |
o C AcDbAuditInfo |
o C AcDbBlockChangeIterator |
o C AcDbBlockReferenceIdIterator |
o C AcDbBlockTableRecordIterator |
o C AcDbClassIterator |
o C AcDbCompositeFilteredBlockIterator |
o C AcDbCustomOsnapManager |
o C AcDbCustomOsnapMode |
o C AcDbDate |
o C AcDbDimData |
o C AcDbEvalEdgeInfo |
o C AcDbEvalIdMap |
o C AcDbFilteredBlockIterator |
| o C AcDbLayerIndexIterator |
| \ C AcDbSpatialIndexIterator |
o C AcDbFullSubentPath |
o C AcDbGripData |
o C AcDbHandle |
o C AcDbHostApplicationProgressMeter |
o C AcDbHyperlink |
o C AcDbHyperlinkCollection |
o C AcDbIdPair |
o C AcDbIndexUpdateData |
o C AcDbIndexUpdateDataIterator |
o C AcDbLoftOptions |
o C AcDbMPolygonCrossing |
o C AcDbMPolygonCrossingArray |
o C AcDbMpolygonLoops |
o C AcDbMPolygonNode |
o C AcDbMTextFragment |
o C AcDbObjectId |
| o C AcDbHardOwnershipId |
| o C AcDbHardPointerId |
| o C AcDbR13ObjectId |
| o C AcDbSoftOwnershipId |
| \ C AcDbSoftPointerId |
o C AcDbObjectPointerBase< T_OBJECT > |
| o C AcDbObjectPointer< T_OBJECT > |
| | \ C AcAxObjectRefPtr< T_OBJECT > |
| o C AcDbSymbolTablePointer< T_OBJECT > |
| \ C AcDbSymbolTableRecordPointer< T_OBJECT > |
o C AcDbPasswordedFile |
o C AcDbPlotSettingsValidator |
o C AcDbRecover |
o C AcDbRecoverCallBack |
o C AcDbRevolveOptions |
o C AcDbSectionManagerIterator |
o C AcDbSubentId |
o C AcDbSummaryInfoManager |
o C AcDbSummaryInfoReactor |
o C AcDbSweepOptions |
o C AcDbSymbolTableIterator |
| o C AcDbAbstractViewTableIterator |
| | o C AcDbViewportTableIterator |
| | \ C AcDbViewTableIterator |
| o C AcDbBlockTableIterator |
| o C AcDbDimStyleTableIterator |
| o C AcDbLayerTableIterator |
| o C AcDbLinetypeTableIterator |
| o C AcDbRegAppTableIterator |
| o C AcDbTextStyleTableIterator |
| \ C AcDbUCSTableIterator |
o C AcDbTableIterator |
o C AcDbUnderlayDrawContext |
o C AcDbUnderlayFile |
o C AcDbUnderlayHost |
o C AcDbUnderlayItem |
| \ C AcDbDgnUnderlayItem |
o C AcDbXrefObjectId |
o C AcDMMEntityReactorInfo |
o C AcDMMEPlotProperties |
o C AcDMMEPlotProperty |
o C AcDMMNode |
o C AcDMMResourceInfo |
o C AcDMMSheetReactorInfo |
o C AcDMMWideString |
o C AcDMMXMLAttribute |
o C AcEdAppGripService |
o C AcEdCommandStruc |
o C AcEdInputContextReactor |
| o C AcEdSSGetFilter |
| | o C AcEdSSGetFilter2 |
| | \ C AcEdSSGetFilter3 |
| \ C AcEdSSGetSubSelectFilter |
o C AcEdInputPointManager |
o C AcEdSelectionSetService |
o C AcEdSolidSubentitySelector |
o C AcEdSubSelectFilter |
o C AcEdSubSelectFilterService |
o C AcEdXrefFileLock |
o C AcFd |
o C AcFILE |
o C AcFileDependencyInfo |
o C AcFileDependencyManager |
o C AcGe |
o C AcGeContext |
o C AcGeCurveBoundary |
o C AcGeDwgIO |
o C AcGeDxfIO |
o C AcGeEntity2d |
| o C AcGeBoundBlock2d |
| o C AcGeClipBoundary2d |
| o C AcGeCurve2d |
| | o C AcGeCircArc2d |
| | o C AcGeCompositeCurve2d |
| | o C AcGeEllipArc2d |
| | o C AcGeExternalCurve2d |
| | o C AcGeLinearEnt2d |
| | | o C AcGeLine2d |
| | | o C AcGeLineSeg2d |
| | | \ C AcGeRay2d |
| | o C AcGeOffsetCurve2d |
| | \ C AcGeSplineEnt2d |
| | o C AcGeCubicSplineCurve2d |
| | o C AcGeNurbCurve2d |
| | \ C AcGePolyline2d |
| o C AcGeCurveCurveInt2d |
| \ C AcGePointEnt2d |
| o C AcGePointOnCurve2d |
| \ C AcGePosition2d |
o C AcGeEntity3d |
| o C AcGeBoundBlock3d |
| o C AcGeCurve3d |
| | o C AcGeCircArc3d |
| | o C AcGeCompositeCurve3d |
| | o C AcGeEllipArc3d |
| | o C AcGeExternalCurve3d |
| | o C AcGeLinearEnt3d |
| | | o C AcGeLine3d |
| | | o C AcGeLineSeg3d |
| | | \ C AcGeRay3d |
| | o C AcGeOffsetCurve3d |
| | \ C AcGeSplineEnt3d |
| | o C AcGeCubicSplineCurve3d |
| | o C AcGeNurbCurve3d |
| | \ C AcGePolyline3d |
| | \ C AcGeAugPolyline3d |
| o C AcGeCurveCurveInt3d |
| o C AcGeCurveSurfInt |
| o C AcGePointEnt3d |
| | o C AcGePointOnCurve3d |
| | o C AcGePointOnSurface |
| | \ C AcGePosition3d |
| o C AcGeSurface |
| | o C AcGeCone |
| | o C AcGeCylinder |
| | o C AcGeExternalBoundedSurface |
| | o C AcGeExternalSurface |
| | o C AcGeNurbSurface |
| | o C AcGeOffsetSurface |
| | o C AcGePlanarEnt |
| | | o C AcGeBoundedPlane |
| | | \ C AcGePlane |
| | o C AcGeSphere |
| | \ C AcGeTorus |
| \ C AcGeSurfSurfInt |
o C AcGeFileIO |
o C AcGeFiler |
o C AcGeInterval |
o C AcGeKnotVector |
o C AcGeLibVersion |
o C AcGeMatrix2d |
o C AcGeMatrix3d |
| \ C AcAxMatrix3d |
o C AcGePoint2d |
| \ C AcAxPoint2d |
o C AcGePoint3d |
| \ C AcAxPoint3d |
o C AcGeScale2d |
o C AcGeScale3d |
o C AcGeTol |
o C AcGeVector2d |
o C AcGeVector3d |
o C AcGiClipBoundary |
o C AcGiColorRGB |
o C AcGiColorRGBA |
o C AcGiLineAttributes |
o C AcGiLineAttrUtils |
o C AcGiRequestScanLines |
o C AcGiSentScanLines |
o C AcGiStyleAttributes |
o C AcGiTextEngine |
o C AcGridProperty |
o C AcGs |
o C AcGs2DViewLimitManager |
o C AcGsClassFactory |
o C AcGsClientViewInfo |
o C AcGsColor |
o C AcGsConfig |
o C AcGsDCPoint |
o C AcGsDCRect |
o C AcGsDevice |
o C AcGsManager |
o C AcGsModel |
o C AcGsNode |
o C AcGsReactor |
o C AcGsRenderProgressMonitor |
o C AcGsRenderStatistics |
o C AcGsScreenShot |
o C AcGsView |
o C AcHeapOperators |
| o C AcDbAnnotationScale |
| o C AcDbDatabase |
| o C AcDbDynBlockReference |
| o C AcDbDynBlockReferenceProperty |
| o C AcDbEvalContext |
| o C AcDbEvalContextIterator |
| o C AcDbEvalContextPair |
| o C AcDbExtents |
| o C AcDbGraph |
| | o C AcDbObjectIdGraph |
| | \ C AcDbXrefGraph |
| o C AcDbGraphNode |
| | o C AcDbObjectIdGraphNode |
| | \ C AcDbXrefGraphNode |
| o C AcDbGraphStack |
| o C AcDbObject |
| | o C AcDbBackground |
| | | o C AcDbGradientBackground |
| | | o C AcDbGroundPlaneBackground |
| | | o C AcDbImageBackground |
| | | o C AcDbSkyBackground |
| | | \ C AcDbSolidBackground |
| | o C AcDbBreakData |
| | o C AcDbBreakPointRef |
| | o C AcDbColor |
| | o C AcDbDataLink |
| | o C AcDbDataTable |
| | o C AcDbDictionary |
| | | \ C AcDbDictionaryWithDefault |
| | o C AcDbDimAssoc |
| | o C AcDbEntity |
| | | o C AcDb3dSolid |
| | | o C AcDbBlockBegin |
| | | o C AcDbBlockEnd |
| | | o C AcDbBlockReference |
| | | | o C AcDbMInsertBlock |
| | | | \ C AcDbTable |
| | | o C AcDbBody |
| | | o C AcDbCamera |
| | | o C AcDbCurve |
| | | | o C AcDb2dPolyline |
| | | | o C AcDb3dPolyline |
| | | | o C AcDbArc |
| | | | o C AcDbCircle |
| | | | o C AcDbEllipse |
| | | | o C AcDbLeader |
| | | | o C AcDbLine |
| | | | o C AcDbPolyline |
| | | | o C AcDbRay |
| | | | o C AcDbSpline |
| | | | | \ C AcDbHelix |
| | | | \ C AcDbXline |
| | | o C AcDbDimension |
| | | | o C AcDb2LineAngularDimension |
| | | | o C AcDb3PointAngularDimension |
| | | | o C AcDbAlignedDimension |
| | | | o C AcDbArcDimension |
| | | | o C AcDbDiametricDimension |
| | | | o C AcDbOrdinateDimension |
| | | | o C AcDbRadialDimension |
| | | | o C AcDbRadialDimensionLarge |
| | | | \ C AcDbRotatedDimension |
| | | o C AcDbFace |
| | | o C AcDbFcf |
| | | o C AcDbFrame |
| | | | \ C AcDbOleFrame |
| | | | \ C AcDbOle2Frame |
| | | o C AcDbHatch |
| | | o C AcDbImage |
| | | | \ C AcDbRasterImage |
| | | | \ C AcDbWipeout |
| | | o C AcDbLight |
| | | o C AcDbMLeader |
| | | o C AcDbMline |
| | | o C AcDbMPolygon |
| | | o C AcDbMText |
| | | o C AcDbPoint |
| | | o C AcDbPolyFaceMesh |
| | | o C AcDbPolygonMesh |
| | | o C AcDbProxyEntity |
| | | o C AcDbRegion |
| | | o C AcDbSection |
| | | o C AcDbSequenceEnd |
| | | o C AcDbShape |
| | | o C AcDbSolid |
| | | o C AcDbSurface |
| | | | o C AcDbExtrudedSurface |
| | | | o C AcDbLoftedSurface |
| | | | o C AcDbPlaneSurface |
| | | | o C AcDbRevolvedSurface |
| | | | \ C AcDbSweptSurface |
| | | o C AcDbText |
| | | | o C AcDbAttribute |
| | | | \ C AcDbAttributeDefinition |
| | | o C AcDbTrace |
| | | o C AcDbUnderlayReference |
| | | | o C AcDbDgnReference |
| | | | \ C AcDbDwfReference |
| | | o C AcDbVertex |
| | | | o C AcDb2dVertex |
| | | | o C AcDb3dPolylineVertex |
| | | | o C AcDbFaceRecord |
| | | | o C AcDbPolyFaceMeshVertex |
| | | | \ C AcDbPolygonMeshVertex |
| | | \ C AcDbViewport |
| | o C AcDbEvalExpr |
| | | \ C AcDbEvalConnectable |
| | o C AcDbEvalGraph |
| | o C AcDbField |
| | o C AcDbFilter |
| | | o C AcDbLayerFilter |
| | | \ C AcDbSpatialFilter |
| | o C AcDbGroup |
| | o C AcDbIndex |
| | | o C AcDbLayerIndex |
| | | \ C AcDbSpatialIndex |
| | o C AcDbLinkedData |
| | | \ C AcDbLinkedTableData |
| | | \ C AcDbFormattedTableData |
| | | \ C AcDbTableContent |
| | | \ C AcDbTableTemplate |
| | o C AcDbLongTransaction |
| | o C AcDbMaterial |
| | o C AcDbMLeaderStyle |
| | o C AcDbMlineStyle |
| | o C AcDbMotionPath |
| | o C AcDbNamedPath |
| | | o C AcDbCurvePath |
| | | \ C AcDbPointPath |
| | o C AcDbPlaceHolder |
| | o C AcDbPlotSettings |
| | | \ C AcDbLayout |
| | o C AcDbProxyObject |
| | o C AcDbRasterImageDef |
| | o C AcDbRasterImageDefReactor |
| | o C AcDbRasterVariables |
| | o C AcDbRenderEnvironment |
| | o C AcDbRenderGlobal |
| | o C AcDbRenderSettings |
| | | \ C AcDbMentalRayRenderSettings |
| | o C AcDbSectionManager |
| | o C AcDbSectionSettings |
| | o C AcDbSortentsTable |
| | o C AcDbSun |
| | o C AcDbSymbolTable |
| | | o C AcDbAbstractViewTable |
| | | | o C AcDbViewportTable |
| | | | \ C AcDbViewTable |
| | | o C AcDbBlockTable |
| | | o C AcDbDimStyleTable |
| | | o C AcDbLayerTable |
| | | o C AcDbLinetypeTable |
| | | o C AcDbRegAppTable |
| | | o C AcDbTextStyleTable |
| | | \ C AcDbUCSTable |
| | o C AcDbSymbolTableRecord |
| | | o C AcDbAbstractViewTableRecord |
| | | | o C AcDbViewportTableRecord |
| | | | \ C AcDbViewTableRecord |
| | | o C AcDbBlockTableRecord |
| | | o C AcDbDimStyleTableRecord |
| | | o C AcDbLayerTableRecord |
| | | o C AcDbLinetypeTableRecord |
| | | o C AcDbRegAppTableRecord |
| | | o C AcDbTextStyleTableRecord |
| | | \ C AcDbUCSTableRecord |
| | o C AcDbTableStyle |
| | o C AcDbUnderlayDefinition |
| | | o C AcDbDgnDefinition |
| | | \ C AcDbDwfDefinition |
| | o C AcDbVisualStyle |
| | \ C AcDbXrecord |
| o C AcDbObjectIterator |
| o C AcLyLayerFilter |
| | \ C AcLyLayerGroup |
| o C AcPlObject |
| | o C AcPlDSDData |
| | o C AcPlDSDEntry |
| | o C AcPlPlotConfig |
| | o C AcPlPlotConfigInfo |
| | o C AcPlPlotErrorHandler |
| | | \ C AcPlPlotLoggingErrorHandler |
| | o C AcPlPlotErrorHandlerLock |
| | o C AcPlPlotInfo |
| | o C AcPlPlotInfoValidator |
| | \ C AcPlPlotPageInfo |
| \ C AcString |
o C AcHyperlink |
o C AcIfstream |
o C AcLispAppInfo |
o C AcLyAndExpr |
o C AcLyBoolExpr |
o C AcLyLayerFilterManager |
o C AcLyRelExpr |
o C AcNameValuePair |
o C AcOfstream |
o C AcOutputBufMgr |
o C AcPl3dDwfOptions |
o C ACPL_PREVIEWENDPLOT |
o C AcPlHostAppServices |
o C AcPlPlotConfigManager |
o C AcPlPlotEngine |
o C AcPlPlotFactory |
o C AcPlPlotLogger |
o C AcPlPlotProgress |
| \ C AcPlPlotProgressDialog |
o C AcPlPlotReactorMgr |
o C AcPublishAggregationInfo |
o C AcPublishBeforeJobInfo |
o C AcPublishBeginJobInfo |
o C AcPublishReactorInfo |
o C AcPublishSheetInfo |
o C AcPublishUIReactorInfo |
o C AcRx |
o C AcRxDbxApp |
| \ C AcRxArxApp |
o C AcRxDynPropManager |
o C AcRxObject |
| o C Ac3dDwfNavTreeNode |
| o C AcadAppInfo |
| o C AcApDocManager |
| o C AcApDocManagerReactor |
| | \ C AcApDataManager< T > |
| o C AcApDocument |
| o C AcApDocumentIterator |
| o C AcApLongTransactionManager |
| o C AcApLongTransactionReactor |
| o C AcDbAlignment |
| o C AcDbAnnotativeObjectPE |
| o C AcDbAuditRecreatePE |
| o C AcDbCustomOsnapInfo |
| o C AcDbDatabase |
| o C AcDbDatabaseReactor |
| o C AcDbDatabaseSummaryInfo |
| o C AcDbDataCell |
| o C AcDbDataColumn |
| o C AcDbDataLinkManager |
| o C AcDbDictionaryIterator |
| o C AcDbDoubleClickEdit |
| o C AcDbDwgFiler |
| | \ C AcDbDeepCloneFiler |
| | \ C AcDbWblockCloneFiler |
| o C AcDbDxfFiler |
| o C AcDbDynamicUCSPE |
| o C AcDbEntityHyperlinkPE |
| o C AcDbEvalContext |
| o C AcDbEvalContextIterator |
| o C AcDbEvalVariant |
| o C AcDbGroupIterator |
| o C AcDbHostApplicationServices |
| o C AcDbIdMapping |
| o C AcDbIdMappingIter |
| o C AcDbInterferencePE |
| o C AcDbLayerStateManager |
| o C AcDbLayerStateManagerReactor |
| o C AcDbLayoutManager |
| | \ C AcApLayoutManager |
| o C AcDbLayoutManagerReactor |
| o C AcDbLongTransWorkSetIterator |
| o C AcDbMatchProperties |
| o C AcDbObjectContext |
| | \ C AcDbAnnotationScale |
| o C AcDbObjectContextCollection |
| o C AcDbObjectContextCollectionIterator |
| o C AcDbObjectContextInterface |
| o C AcDbObjectContextManager |
| o C AcDbObjectIterator |
| o C AcDbObjectReactor |
| | o C AcDbEntityReactor |
| | o C AcDbRasterImageDefFileAccessReactor |
| | \ C AcDbRasterImageDefTransReactor |
| o C AcDbPaperOrientationPE |
| o C AcDbPointRef |
| | \ C AcDbOsnapPointRef |
| o C AcDbSelectGrip |
| o C AcDbTransactionManager |
| | \ C AcTransactionManager |
| o C AcDbXObject |
| | \ C AcCmComplexColor |
| o C AcDbXrecordIterator |
| o C AcDMMReactor |
| o C AcEdCommand |
| o C AcEdCommandIterator |
| o C AcEdCommandStack |
| o C AcEdInputPointFilter |
| o C AcEdInputPointMonitor |
| o C AcEdJig |
| | \ C AsdkPromptBase< T, TCLSIDWrapper > |
| o C AcEdUIContext |
| o C AcFdFieldEngine |
| o C AcFdFieldEvaluator |
| o C AcFdFieldEvaluatorLoader |
| o C AcFdFieldReactor |
| o C AcFdFieldResult |
| o C AcGiCommonDraw |
| | o C AcGiViewportDraw |
| | \ C AcGiWorldDraw |
| o C AcGiContext |
| o C AcGiContextualColors |
| | \ C AcGiContextualColors2 |
| o C AcGiDisplayStyle |
| o C AcGiDrawable |
| | o C AcDbObject |
| | \ C AcGiGlyph |
| o C AcGiEdgeData |
| o C AcGiEdgeStyle |
| o C AcGiFaceData |
| o C AcGiFaceStyle |
| o C AcGiGeometry |
| | o C AcGiViewportGeometry |
| | \ C AcGiWorldGeometry |
| o C AcGiLightAttenuation |
| o C AcGiLinetypeEngine |
| o C AcGiMapper |
| o C AcGiMaterialColor |
| o C AcGiMaterialMap |
| o C AcGiMaterialTexture |
| | o C AcGiImageTexture |
| | | \ C AcGiImageFileTexture |
| | \ C AcGiProceduralTexture |
| | o C AcGiGenericTexture |
| | o C AcGiMarbleTexture |
| | \ C AcGiWoodTexture |
| o C AcGiShadowParameters |
| | \ C AcGiShadowParameters2 |
| o C AcGiSkyParameters |
| o C AcGiSubEntityTraits |
| | \ C AcGiDrawableTraits |
| | o C AcGiNonEntityTraits |
| | | o C AcGiGradientBackgroundTraits |
| | | o C AcGiGroundPlaneBackgroundTraits |
| | | o C AcGiImageBackgroundTraits |
| | | o C AcGiLightTraits |
| | | | \ C AcGiStandardLightTraits |
| | | | o C AcGiDistantLightTraits |
| | | | | \ C AcGiDistantLightTraits2 |
| | | | o C AcGiPointLightTraits |
| | | | | \ C AcGiPointLightTraits2 |
| | | | | \ C AcGiWebLightTraits |
| | | | \ C AcGiSpotLightTraits |
| | | | \ C AcGiSpotLightTraits2 |
| | | o C AcGiMaterialTraits |
| | | | \ C AcGiMaterialTraits2 |
| | | o C AcGiRenderEnvironmentTraits |
| | | o C AcGiRenderSettingsTraits |
| | | | \ C AcGiMentalRayRenderSettingsTraits |
| | | | \ C AcGiMentalRayRenderSettingsTraits2 |
| | | o C AcGiSkyBackgroundTraits |
| | | \ C AcGiSolidBackgroundTraits |
| | o C AcGiViewportTraits |
| | | \ C AcGiViewportTraits2 |
| | \ C AcGiVisualStyleTraits |
| o C AcGiTextStyle |
| o C AcGiToneOperatorParameters |
| o C AcGiVariant |
| o C AcGiVertexData |
| o C AcGiViewport |
| o C AcGiVisualStyle |
| o C AcLyLayerFilter |
| o C AcPlObject |
| o C AcPlPlotReactor |
| o C AcPublishReactor |
| o C AcPublishUIReactor |
| o C AcRxDictionary |
| o C AcRxDLinkerReactor |
| o C AcRxDynamicLinker |
| o C AcRxEvent |
| | \ C AcEditor |
| o C AcRxEventReactor |
| | \ C AcEditorReactor |
| | \ C AcEditorReactor2 |
| o C AcRxIterator |
| | \ C AcRxDictionaryIterator |
| o C AcRxProtocolReactor |
| | o C AcDbAppEntityGrips |
| | \ C AcDbBlockInsertionPoints |
| o C AcRxProtocolReactorIterator |
| o C AcRxProtocolReactorList |
| o C AcRxProtocolReactorListIterator |
| o C AcRxProtocolReactorManager |
| o C AcRxService |
| | o C AcDbServices |
| | o C AcEdServices |
| | o C AcRxKernel |
| | \ C AcRxProtocolReactorManagerFactory |
| o C AcTransaction |
| o C AcTransactionReactor |
| o C AcValue |
| | \ C AcFdFieldValue |
| o C OPMPerInstancePropertyExtension |
| o C OPMPerInstancePropertyExtensionFactory |
| o C OPMPerInstancePropertySources |
| o C OPMPropertyExtension |
| \ C OPMPropertyExtensionFactory |
o C AcStatusBarItem |
| o C AcPane |
| \ C AcTrayItem |
o C AcStatusBarMenuItem |
o C ACTC_IMAGE_INFO |
o C ACTC_TARGET_PRODUCT_INFO |
o C AcTcCatalogItem |
| o C AcTcCategory |
| | \ C AcTcCatalog |
| o C AcTcPackage |
| | \ C AcTcPalette |
| o C AcTcStockTool |
| \ C AcTcTool |
o C AcTcCatalogItemReactor |
o C AcTcCatalogSet |
o C AcTcImage |
o C AcTcImageList |
o C AcTcManager |
o C AcTcScheme |
o C ACTCUI_DRAG_HEADER |
o C AcTrayItemAnimationControl | For internal use only
o C AcTrayItemBubbleWindowControl |
o C AcUnderlayLayer |
o C AcUt |
o C AdCharFormatter |
o C Adesk |
o C ads_binary |
o C ads_callback_packet |
o C ads_u_val |
o C AdUiBmpBtnData |
o C AdUiGroupCtrlData |
o C asi_date |
o C asi_day |
o C asi_daytohour |
o C asi_daytominute |
o C asi_daytosecond |
o C asi_hour |
o C asi_hourtominute |
o C asi_hourtosecond |
o C asi_minute |
o C asi_minuteitosecond |
o C asi_month |
o C asi_second |
o C asi_time |
o C asi_timestamp |
o C asi_year |
o C asi_yeartomonth |
o C CAcExtensionModule |
o C CAcFdUiFieldDialogHook |
o C CAcFdUiFieldManager |
o C CAcGradientThumbnailEngine |
o C CAcModuleResourceOverride |
o C CAcTcUiCatalogView |
| \ C CAcTcUiPaletteView |
o C CAcTcUiCatalogViewItem |
o C CAcTcUiManager |
o C CAcTcUiScheme |
o C CAcTcUiToolPaletteGroup |
o C CAcUiLTypeRecord |
o C CAcUiMRUListBox |
o C CAcUiString |
| \ C CAcUiStringExp |
o C CAdUiBaseDialog |
| \ C CAdUiDialog |
| o C CAcFdUiFieldDialog |
| o C CAcFdUiFieldOptionDialog |
| o C CAcFdUiFormatDialog |
| | \ C CAcFdUiFieldFormatDialog |
| o C CAcUiDialog |
| o C CAdUiDialogWorksheet |
| | \ C CAcUiDialogWorksheet |
| o C CAdUiTabChildDialog |
| | \ C CAcUiTabChildDialog |
| o C CAdUiTabMainDialog |
| | \ C CAcUiTabMainDialog |
| \ C CNavDialog |
| \ C CAcUiNavDialog |
o C CAdUiComboBox |
| \ C CAcUiComboBox |
| o C CAcUiAngleComboBox |
| o C CAcUiMRUComboBox |
| | o C CAcUiArrowHeadComboBox |
| | o C CAcUiColorComboBox |
| | o C CAcUiLineTypeComboBox |
| | o C CAcUiLineWeightComboBox |
| | o C CAcUiPlotStyleNamesComboBox |
| | o C CAcUiPlotStyleTablesComboBox |
| | o C CAcUiPredefBlockComboBox |
| | \ C CAcUiTrueColorComboBox |
| o C CAcUiNumericComboBox |
| o C CAcUiStringComboBox |
| \ C CAcUiSymbolComboBox |
o C CAdUiCoupledGroupCtrl |
o C CAdUiDialogBar |
| \ C CAcUiDialogBar |
o C CAdUiDockControlBar |
| o C CAcUiDockControlBar |
| \ C CAdUiPaletteSet |
| \ C CAcTcUiToolPaletteSet |
o C CAdUiDockFrame |
| \ C CAcUiDockFrame |
o C CAdUiDrawTipText |
o C CAdUiDropTarget |
o C CAdUiEdit |
| \ C CAcUiEdit |
| o C CAcUiAngleEdit |
| o C CAcUiNumericEdit |
| o C CAcUiStringEdit |
| \ C CAcUiSymbolEdit |
o C CAdUiFileDialog |
| \ C CAcUiFileDialog |
o C CAdUiGroupCtrl |
o C CAdUiHeaderCtrl |
o C CAdUiListBox |
| \ C CAcFdUiFormatList |
| \ C CAcFdUiFieldFormatList |
o C CAdUiListCtrl |
| \ C CNavListCtrl |
o C CAdUiOwnerDrawButton |
| o C CAcUiOwnerDrawButton |
| o C CAdUiBitmapButton |
| | o C CAcUiBitmapButton |
| | o C CAcUiPickButton |
| | | \ C CAcUiSelectButton |
| | o C CAdUiBitmapStatic |
| | | o C CAcUiBitmapStatic |
| | | \ C CAdUiDropSite |
| | | \ C CAcUiDropSite |
| | \ C CAdUiToolButton |
| | \ C CAcUiToolButton |
| \ C CAdUiTrackButton |
o C CAdUiPalette |
| \ C CAcTcUiToolPalette |
o C CAdUiPaletteSetDockFrame |
| \ C CAcUiPaletteSetDockFrame |
o C CAdUiPathname |
| \ C CAcUiPathname |
o C CAdUiRegistryAccess |
| \ C CAdUiRegistryWriteAccess |
| \ C CAdUiRegistryDeleteAccess |
o C CAdUiTab |
| \ C CAcUiTab |
o C CAdUiTabExtensionManager |
o C CAdUiTheme |
o C CAdUiThemeManager |
o C CAdUiThemeMgrReactor |
o C CAdUiThemeModifiedReactor |
| \ C CAdUiODButtonThemeModReactor |
o C CAdUiTipWindow |
| o C CAdUiBalloonTip |
| \ C CAdUiTextTip |
o C CAdUiVolumeDescriptor |
| o C CAdUiCDFSVolumeDescriptor |
| o C CAdUiFATVolumeDescriptor |
| o C CAdUiHPFSVolumeDescriptor |
| o C CAdUiNOFSVolumeDescriptor |
| o C CAdUiNTFSVolumeDescriptor |
| o C CAdUiUFSVolumeDescriptor |
| \ C CAdUiVFATVolumeDescriptor |
o C CAseApiObj |
| o C CAseAppl |
| o C CAseLink |
| o C CAseLinkPath |
| \ C CAseLinkSel |
o C CAsiExceptionHandler |
o C CAsiObject |
| o C CAsiColumn |
| o C CAsiData |
| | o C CAsiBinary |
| | o C CAsiBlob |
| | o C CAsiChar |
| | o C CAsiDatetime |
| | | o C CAsiDate |
| | | o C CAsiTime |
| | | \ C CAsiTimeStamp |
| | o C CAsiIQualifier |
| | | \ C CAsiInterval |
| | | o C CAsiDT |
| | | \ C CAsiYM |
| | \ C CAsiNum |
| | o C CAsiApproxNum |
| | | o C CAsiDouble |
| | | o C CAsiFloat |
| | | \ C CAsiReal |
| | \ C CAsiExactNum |
| | o C CAsiDecimal |
| | o C CAsiInt |
| | o C CAsiNumeric |
| | \ C CAsiSmallInt |
| o C CAsiException |
| o C CAsiHostBuffer |
| | \ C CAsiParameter |
| o C CAsiIdent |
| o C CAsiIRow |
| o C CAsiList |
| o C CAsiRow |
| o C CAsiSQLObject |
| | o C CAsiAppl |
| | o C CAsiSession |
| | \ C CAsiStm |
| | o C CAsiCsr |
| | | \ C CAsiCsrTable |
| | | o C CAsiCsrInfSchema |
| | | o C CAsiCsrRegTable |
| | | \ C CAsiEnumerator |
| | \ C CAsiExecStm |
| o C CAsiTACond |
| \ C CAsiTCCond |
o C CAsiUcChar |
o C CAsiUcStr |
o C CATCMDBTN_ENTRY |
o C CATEGORY_ENTRY |
o C CMDBTN_ENTRY |
o C CNavData |
o C CNavDropSource |
o C CNavFilter |
o C CRectangle3d |
o C CTypedPtrArray |
| o C CNavArray< T > |
| o C CNavArray< CNavData > |
| | \ C CNavDataArray |
| \ C CNavArray< CNavFilter > |
| \ C CNavFilterArray |
o C AcApDocManager::DocOpenParams |
o C e2f_ent |
o C e2f_hdr |
o C e2f_layer |
o C e2f_xform |
o C AcGiVariant::EnumType |
o C fchnd |
o C IAcadBaseDatabaseImpl< pclsid > |
o C IAcadBaseObject |
| o C IAcadBaseObjectImpl< T, pclsid > |
| | \ C IAcadBaseObject2Impl< T, pclsid > |
| \ C IAcadBaseObjectImpl< C, pclsid > |
| \ C IAcadBaseObject2Impl< C, pclsid > |
| \ C IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > |
| \ C IAcadEntityDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > |
o C IAcadBaseObject2 |
| o C IAcadBaseObject2Impl< T, pclsid > |
| \ C IAcadBaseObject2Impl< C, pclsid > |
o C IAcadShadowDisplayImpl< C > |
o C IAcPiCategorizePropertiesImpl< T > |
o C IAcPiPropCommandButtonsImpl< T > |
o C IAcPiPropertyDisplayImpl< T > |
o C IConnectionPointContainerImpl |
| o C IAcadBaseObjectImpl< T, pclsid > |
| o C IAcadBaseObjectImpl< C, pclsid > |
| \ C IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > |
o C IConnectionPointImpl |
| o C CProxy_AcadObjectEvents< T > |
| | \ C IAcadBaseObjectImpl< T, pclsid > |
| o C CProxy_AcadObjectEvents< C > |
| | o C IAcadBaseObjectImpl< C, pclsid > |
| | \ C IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > |
| o C CProxy_PropertyNotifySink< T > |
| | \ C IAcadBaseObjectImpl< T, pclsid > |
| \ C CProxy_PropertyNotifySink< C > |
| o C IAcadBaseObjectImpl< C, pclsid > |
| \ C IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > |
o C IOPMPropertyExtensionImpl< T > |
o C IOPMPropertyExtensionImpl2< T > |
o C IRetrieveApplicationImpl |
| o C IAcadBaseSubEntityImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > |
| \ C IAcadObjectDispatchImpl< C, pclsid, T, piid, plibid, wMajor, wMinor, tihclass > |
o C ListItem |
o C Mline |
o C OwnerDraw3d |
o C PER_FLYOUT_ENTRY |
o C PER_PROP_DISP_ENTRY |
o C PER_PROP_DISP_ENTRY2 |
o C PROMPT_MAP_ENTRY |
o C resbuf |
| \ C AcDbEvalVariant |
o C AcCmEntityColor::RGBM |
o C RxADSAppTableEntryType |
o C scn_cmesh |
o C scn_cvrt |
o C scn_node |
o C scn_pmsh |
o C scn_vrtc |
o C SecurityParams |
o C AcDbSymbolUtilities::Services |
o C AcEdSymbolUtilities::Services |
o C SignatureInfo |
o C tagADUI_DRAGDATA |
o C tagChildFrmSettings |
o C tagClipboardInfo |
o C tagOPMDWORD |
o C tagOPMLPOLESTR |
\ C AcadToolImpl< TT, T, pclsid, szToolName, szToolImage, piid, plibid >::TOOL_MAP_ENTRY |


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • Abort() : CAsiAppl
  • abortAseTransaction() : CAseAppl
  • AcCmDialogColor() : AcCmDialogColor
  • AcDbCamera() : AcDbCamera
  • AcDbCurvePath() : AcDbCurvePath
  • AcDbDgnDefinition() : AcDbDgnDefinition
  • AcDbDwfDefinition() : AcDbDwfDefinition
  • AcDbEvalContext() : AcDbEvalContext
  • AcDbEvalContextIterator() : AcDbEvalContextIterator
  • AcDbEvalContextPair() : AcDbEvalContextPair
  • AcDbEvalEdgeInfo() : AcDbEvalEdgeInfo
  • AcDbEvalExpr() : AcDbEvalExpr
  • AcDbExtrudedSurface() : AcDbExtrudedSurface
  • AcDbGradientBackground() : AcDbGradientBackground
  • AcDbGroundPlaneBackground() : AcDbGroundPlaneBackground
  • AcDbImageBackground() : AcDbImageBackground
  • AcDbLight() : AcDbLight
  • AcDbLoftedSurface() : AcDbLoftedSurface
  • AcDbLoftOptions() : AcDbLoftOptions
  • AcDbMotionPath() : AcDbMotionPath
  • AcDbNamedPath() : AcDbNamedPath
  • AcDbPlaneSurface() : AcDbPlaneSurface
  • AcDbPointPath() : AcDbPointPath
  • AcDbRenderEnvironment() : AcDbRenderEnvironment
  • AcDbRenderGlobal() : AcDbRenderGlobal
  • AcDbRenderSettings() : AcDbRenderSettings
  • AcDbRevolvedSurface() : AcDbRevolvedSurface
  • AcDbRevolveOptions() : AcDbRevolveOptions
  • AcDbSection() : AcDbSection
  • AcDbSectionSettings() : AcDbSectionSettings
  • AcDbSkyBackground() : AcDbSkyBackground
  • AcDbSolidBackground() : AcDbSolidBackground
  • AcDbSun() : AcDbSun
  • AcDbSurface() : AcDbSurface
  • AcDbSweepOptions() : AcDbSweepOptions
  • AcDbSweptSurface() : AcDbSweptSurface
  • AcDbTableIterator() : AcDbTableIterator
  • AcDbUnderlayDefinition() : AcDbUnderlayDefinition
  • AcFdFieldValue() : AcFdFieldValue
  • AcGiDisplayStyle() : AcGiDisplayStyle
  • AcGiEdgeStyle() : AcGiEdgeStyle
  • AcGiFaceStyle() : AcGiFaceStyle
  • AcGiGenericTexture() : AcGiGenericTexture
  • AcGiImageFileTexture() : AcGiImageFileTexture
  • AcGiLinetypeEngine() : AcGiLinetypeEngine
  • AcGiMarbleTexture() : AcGiMarbleTexture
  • AcGiShadowParameters() : AcGiShadowParameters
  • AcGiShadowParameters2() : AcGiShadowParameters2
  • AcGiToneOperatorParameters() : AcGiToneOperatorParameters
  • AcGiVariant() : AcGiVariant
  • AcGiVisualStyle() : AcGiVisualStyle
  • AcGiWoodTexture() : AcGiWoodTexture
  • activate() : AcDbEvalGraph
  • activated() : AcDbEvalExpr
  • AcTrayItemAnimationControl() : AcTrayItemAnimationControl
  • AcUnderlayLayer() : AcUnderlayLayer
  • AddBmpBtnToHeader() : CAdUiGroupCtrl
  • addBreakPointRef() : AcDbBreakData
  • addConnection() : CAsiAppl
  • AddCouple() : CAdUiCoupledGroupCtrl
  • AddCustomMenuItems() : CAdUiDockControlBar
  • AddData() : CNavArray< T >
  • AddDataToHistory() : CNavDialog
  • addEdge() : AcDbEvalGraph
  • addedToGraph() : AcDbEvalExpr
  • addGraph() : AcDbEvalGraph
  • addId() : CAseLinkSel
  • addLight() : AcGiNonEntityTraits
  • addNode() : AcDbEvalGraph
  • addObj() : CAseAppl
  • addRow() : CAseLinkPath
  • addVertex() : AcDbSection
  • AddWnd() : CAdUiGroupCtrl
  • adjacentEdgeAdded() : AcDbEvalExpr
  • adjacentEdgeRemoved() : AcDbEvalExpr
  • adjacentNodeRemoved() : AcDbEvalExpr
  • align() : AcDbSweepOptions
  • alignAngle() : AcDbSweepOptions
  • alignDirection() : AcDbLoftOptions
  • alignSpace() : AcDbMLeaderStyle
  • alignStart() : AcDbSweepOptions
  • Allocate() : CAsiEnumerator , CAsiCsr , CAsiCsrRegTable , CAsiCsrInfSchema
  • allocAttr() : CAseApiObj
  • allocCursor() : CAseLinkPath
  • altitude() : AcDbSun
  • ambientLightColor() : AcDbAbstractViewTableRecord
  • annoAllVisible() : AcDbLayout , AcDbDatabase
  • annotationScale() : AcDbViewTableRecord
  • annotative() : AcDbMLeaderStyle
  • annotativeDwg() : AcDbDatabase
  • appDesc() : AcadAppInfo
  • Append() : CAsiUcStr
  • appImplements() : AcadAppInfo
  • appName() : AcadAppInfo
  • appThrow() : CAseApiObj
  • arcLengthParam() : AcDbLoftOptions
  • arrowSymbolId() : AcDbMLeaderStyle
  • asBoolean() : AcGiVariant
  • asChar() : AcGiVariant
  • asColor() : AcGiVariant
  • asDouble() : AcGiVariant
  • ase_fromAse() : CAseAppl
  • ase_invoke() : CAseAppl
  • ase_toAse() : CAseAppl
  • aseiCallAse() : CAseAppl
  • asEnum() : AcGiVariant
  • asFloat() : AcGiVariant
  • asInt() : AcGiVariant
  • asLong() : AcGiVariant
  • asShort() : AcGiVariant
  • asString() : AcGiVariant
  • asUchar() : AcGiVariant
  • asUint() : AcGiVariant
  • asUlong() : AcGiVariant
  • asUshort() : AcGiVariant
  • Atof() : CAsiUcStr
  • Atoi() : CAsiUcStr
  • Atol() : CAsiUcStr
  • attach() : AcFILE
  • axialNoise() : AcGiWoodTexture
  • azimuth() : AcDbSun


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • backFacesEnabled() : AcDbRenderSettings
  • background() : AcDbAbstractViewTableRecord
  • bank() : AcDbSweepOptions
  • basePoint() : AcDbSweepOptions
  • beginAseTransaction() : CAseAppl
  • BeginDownloadFiles() : CNavDialog
  • BeginEditorCommand() : CAcFdUiFieldDialog
  • BeginFieldDialog() : CAcFdUiFieldDialogHook
  • Bind() : CAsiExecStm , CAsiCsr , CAsiStm , CAsiCsr , CAsiStm , CAsiExecStm
  • bitFlags() : AcDbMLeaderStyle
  • blockColor() : AcDbMLeaderStyle
  • blockConnectionType() : AcDbMLeaderStyle
  • blockId() : AcDbMLeaderStyle
  • blockRotation() : AcDbMLeaderStyle
  • blockScale() : AcDbMLeaderStyle
  • blue() : AcCmDialogColor
  • body() : AcDbSurface , AcDbRegion , AcDb3dSolid
  • Body() : CAsiIdent
  • body() : AcDbBody
  • bookName() : AcCmDialogColor
  • breakPoint() : AcDbBreakPointRef
  • breakPoint2() : AcDbBreakPointRef
  • breakSize() : AcDbMLeaderStyle
  • brightness() : AcGiToneOperatorParameters , AcGiDisplayStyle , AcDbAbstractViewTableRecord
  • BrowseCurrentObject() : CNavDialog


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CAcFdUiFieldDialog() : CAcFdUiFieldDialog
  • CAcFdUiFieldDialogHook() : CAcFdUiFieldDialogHook
  • CAcFdUiFieldManager() : CAcFdUiFieldManager
  • CAcFdUiFieldOptionDialog() : CAcFdUiFieldOptionDialog
  • CAcFdUiFormatDialog() : CAcFdUiFormatDialog
  • CAcFdUiFormatList() : CAcFdUiFormatList
  • CAcUiString() : CAcUiString
  • CAcUiStringExp() : CAcUiStringExp
  • CAdUiCoupledGroupCtrl() : CAdUiCoupledGroupCtrl
  • CAdUiODButtonThemeModReactor() : CAdUiODButtonThemeModReactor
  • CalcItemHeight() : CAcUiMRUComboBox
  • camera() : AcDbViewTableRecord
  • cameraDisplay() : AcDbDatabase
  • cameraHeight() : AcDbDatabase
  • cameraPath() : AcDbMotionPath
  • Cancel() : CAsiExecStm , CAsiCsr
  • CancelEditorCommand() : CAcFdUiFieldDialog
  • cannoscale() : AcDbDatabase
  • capture() : AcDbTableTemplate
  • CAseApiObj() : CAseApiObj
  • CAseAppl() : CAseAppl
  • CAseLink() : CAseLink
  • CAseLinkPath() : CAseLinkPath
  • CAseLinkSel() : CAseLinkSel
  • CAsiAppl() : CAsiAppl
  • CAsiCsr() : CAsiCsr
  • CAsiCsrInfSchema() : CAsiCsrInfSchema
  • CAsiCsrRegTable() : CAsiCsrRegTable
  • CAsiCsrTable() : CAsiCsrTable
  • CAsiData() : CAsiData
  • CAsiEnumerator() : CAsiEnumerator
  • CAsiExactNum() : CAsiExactNum
  • CAsiException() : CAsiException
  • CAsiExceptionHandler() : CAsiExceptionHandler
  • CAsiExecStm() : CAsiExecStm
  • CAsiIdent() : CAsiIdent
  • CAsiNum() : CAsiNum
  • CAsiObject() : CAsiObject
  • CAsiSession() : CAsiSession
  • CAsiSmallInt() : CAsiSmallInt
  • CAsiSQLObject() : CAsiSQLObject
  • CAsiStm() : CAsiStm
  • CAsiTACond() : CAsiTACond
  • CAsiUcStr() : CAsiUcStr
  • castShadows() : AcDbLight
  • CharSet() : CAsiIdent
  • checkAdd() : CAsiData , CAsiNum , CAsiExactNum , CAsiSmallInt
  • checkCat() : CAsiData
  • CheckCCondition() : CAsiCsr
  • checkCrossSectionCurves() : AcDbLoftOptions
  • checkDiv() : CAsiData , CAsiNum , CAsiSmallInt
  • checkGuideCurves() : AcDbLoftOptions
  • checkIntersections() : AcDbSweepOptions
  • checkLoftCurves() : AcDbLoftOptions
  • checkMul() : CAsiData , CAsiNum , CAsiSmallInt
  • checkOp() : CAseLinkPath
  • CheckOp() : CAsiSQLObject
  • checkOptions() : AcDbLoftOptions
  • checkPathCurve() : AcDbLoftOptions , AcDbSweepOptions
  • checkRevolveCurve() : AcDbRevolveOptions
  • checkSet() : CAsiData , CAsiSmallInt
  • checkSub() : CAsiData , CAsiNum , CAsiSmallInt
  • checkSweepCurve() : AcDbSweepOptions
  • Chlen() : CAsiUcStr
  • ChlenChk() : CAsiUcStr
  • chromaticAdaptation() : AcGiToneOperatorParameters
  • Clear() : CAsiObject , CAsiIdent , CAsiData , CAsiUcStr
  • clearAseErr() : CAseAppl
  • clipBoundary() : AcDbUnderlayReference
  • clone() : CAseAppl , CAseLinkPath , CAseLink , CAseLinkSel
  • Close() : CAsiCsr , CAsiCsrTable
  • closed() : AcDbLoftOptions
  • closeDwg() : CAseAppl
  • closeToAxis() : AcDbRevolveOptions
  • cmaterial() : AcDbDatabase
  • cmpeqlan() : CAsiExactNum
  • cmpeqlen() : CAsiExactNum
  • cmpeqlenC() : CAsiExactNum
  • cmpgtean() : CAsiExactNum
  • cmpgteen() : CAsiExactNum
  • cmpgteenC() : CAsiExactNum
  • cmpgtran() : CAsiExactNum
  • cmpgtren() : CAsiExactNum
  • cmpgtrenC() : CAsiExactNum
  • cmpltean() : CAsiExactNum
  • cmplteen() : CAsiExactNum
  • cmplteenC() : CAsiExactNum
  • cmpltran() : CAsiExactNum
  • cmpltren() : CAsiExactNum
  • cmpltrenC() : CAsiExactNum
  • cmpName() : CAseLinkPath
  • cmpneqan() : CAsiExactNum
  • cmpneqen() : CAsiExactNum
  • cmpneqenC() : CAsiExactNum
  • CNavArray() : CNavArray< T >
  • CNavData() : CNavData
  • CNavDataArray() : CNavDataArray
  • CNavDialog() : CNavDialog
  • CNavDropSource() : CNavDropSource
  • CNavFilter() : CNavFilter
  • CNavFilterArray() : CNavFilterArray
  • CNavListCtrl() : CNavListCtrl
  • ColDsc() : CAsiStm , CAsiExecStm , CAsiCsr , CAsiCsrTable
  • collectionName() : AcDbAnnotationScale
  • color() : AcGiNonEntityTraits , AcCmDialogColor , AcDbSectionSettings
  • color1() : AcGiWoodTexture
  • color2() : AcGiWoodTexture
  • colorBottom() : AcDbGradientBackground
  • colorDifferentiation() : AcGiToneOperatorParameters
  • colorGroundPlaneFar() : AcDbGroundPlaneBackground
  • colorGroundPlaneNear() : AcDbGroundPlaneBackground
  • colorIndex() : AcCmDialogColor
  • colorMethod() : AcCmDialogColor
  • colorMiddle() : AcDbGradientBackground
  • colorName() : AcCmDialogColor
  • colorNameForDisplay() : AcCmDialogColor
  • colorSkyHorizon() : AcDbGroundPlaneBackground
  • colorSkyZenith() : AcDbGroundPlaneBackground
  • colorSolid() : AcDbSolidBackground
  • colorTop() : AcDbGradientBackground
  • colorUndergroundAzimuth() : AcDbGroundPlaneBackground
  • colorUndergroundHorizon() : AcDbGroundPlaneBackground
  • ColQty() : CAsiExecStm , CAsiStm , CAsiCsr , CAsiCsrTable
  • CombineDataTextWithFolderName() : CNavDialog
  • Commit() : CAsiSession
  • commitAseTransaction() : CAseAppl
  • Comp() : CAsiUcStr
  • Compi() : CAsiUcStr
  • CompleteEditorCommand() : CAcFdUiFieldDialog
  • concat() : AcString
  • CondQty() : CAsiException , CAsiSQLObject
  • configureForType() : AcGiVisualStyle
  • Connect() : CAsiSession
  • connectAse() : CAseAppl , CAseLinkPath
  • connectAseIniString() : CAseLinkPath
  • ConnectIniString() : CAsiSession
  • connectionAllowed() : AcDbEvalConnectable
  • connectTo() : AcDbEvalConnectable
  • constPtr() : AcString
  • contextCollection() : AcDbObjectContextManager
  • contextPair() : AcDbEvalContextIterator
  • contrast() : AcGiToneOperatorParameters , AcDbAbstractViewTableRecord , AcDbUnderlayReference
  • contrastDefault() : AcDbUnderlayReference
  • contrastLowerLimit() : AcDbUnderlayReference
  • contrastUpperLimit() : AcDbUnderlayReference
  • convertToBrepAtSubentPaths() : AcDb3dSolid
  • convertToRegion() : AcDbSurface
  • convertToTextField() : AcDbField
  • copiedIntoGraph() : AcDbEvalExpr
  • Copy() : CAsiUcStr
  • copyBuf() : CAseApiObj
  • copyFrom() : AcDbGradientBackground , CAseLinkPath , AcGiGenericTexture , AcDbRenderSettings , CAseApiObj , AcGiVariant , AcGiMarbleTexture , AcDbSkyBackground , CAseLink , AcDbGroundPlaneBackground , AcDbLight , CAseLinkSel , AcDbSolidBackground , AcGiWoodTexture , AcDbRenderGlobal , AcDbImageBackground , CAseAppl , AcGiImageFileTexture
  • cornerDecel() : AcDbMotionPath
  • creaseAngle() : AcGiEdgeStyle
  • create() : CAseLinkPath
  • Create() : CAcFdUiFormatDialog , CAcFdUiFieldOptionDialog
  • create() : CAseLinkPath , CAseLink , CAseLinkPath
  • Create() : CAcFdUiFieldOptionDialog
  • createExtrudedSurface() : AcDbExtrudedSurface
  • CreateField() : CAcFdUiFieldDialogHook
  • createFrom() : AcDbSurface
  • createFromRegion() : AcDbPlaneSurface
  • createGraph() : AcDbEvalGraph
  • createIndex() : CAseAppl
  • CreateInstance() : CAcFdUiFieldDialogHook
  • createJog() : AcDbSection
  • createLoftedSurface() : AcDbLoftedSurface
  • createLoops() : AcDbMPolygon
  • createLoopsFromBoundaries() : AcDbMPolygon
  • createRevolvedSurface() : AcDbRevolvedSurface
  • createSweptSurface() : AcDbSweptSurface
  • createTable() : CAseLinkPath , AcDbTableTemplate
  • cshadow() : AcDbDatabase
  • currentSectionType() : AcDbSectionSettings
  • Cvl() : CAsiCsrTable , CAsiStm , CAsiCsr , CAsiCsrTable , CAsiCsr
  • CvlInt() : CAsiStm


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • dateTime() : AcDbSun
  • DateTimeType() : CAsiData
  • DBMS() : CAsiSQLObject
  • Deallocate() : CAsiExecStm
  • DeallocCsr() : CAsiCsrTable
  • decomposeForSave() : AcDbLight , AcDbSun
  • deepClone() : AcDbCamera , AcDbLight
  • defaultLightingType() : AcDbAbstractViewTableRecord
  • DeferrConstr() : CAsiSession
  • definition() : AcGiGenericTexture
  • definitionId() : AcDbUnderlayReference
  • delAttrPtr() : CAseApiObj
  • delCursor() : CAseLinkPath
  • Delete() : CAsiCsr
  • deleteAllBreakPointRefs() : AcDbBreakData
  • deleteElem() : AcGiVariant
  • delId() : CAseLinkSel
  • delRow() : CAseLinkPath
  • description() : AcDbRenderSettings
  • DeselectGroupHeader() : CAdUiGroupCtrl
  • destinationBlock() : AcDbSectionSettings
  • destinationFile() : AcDbSectionSettings
  • dgnframe() : AcDbDatabase
  • diagnosticBackgroundEnabled() : AcDbRenderSettings
  • dictionaryKey() : AcDbUnderlayDefinition
  • dimensions() : AcDbRenderGlobal
  • dimfit() : AcDbDimension
  • dimObjId() : AcDbBreakData
  • dimunit() : AcDbDimension
  • Disconnect() : CAsiSession
  • DisconnectAll() : CAsiAppl
  • disconnectAse() : CAseLinkPath
  • disconnectFrom() : AcDbEvalConnectable
  • displayIndex() : AcDbRenderSettings
  • DisplaySearchError() : CNavDialog
  • displaySettings() : AcGiDisplayStyle
  • displayStyle() : AcGiVisualStyle
  • distances() : AcDbRenderEnvironment
  • divisionLines() : AcDbSectionSettings
  • DoChangeErrors() : CAsiCsr
  • DoDataExchange() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog , CAcFdUiFormatDialog , CNavDialog
  • DoModal() : CAcFdUiFieldDialog
  • done() : AcDbEvalContextIterator , AcDbTableIterator
  • draftAngle() : AcDbRevolveOptions , AcDbSweepOptions
  • draftEnd() : AcDbLoftOptions
  • draftEndMag() : AcDbLoftOptions
  • draftStart() : AcDbLoftOptions
  • draftStartMag() : AcDbLoftOptions
  • dragVisStyle() : AcDbDatabase
  • drawable() : AcDbRenderSettings , AcDbRenderEnvironment , AcDbSun
  • drawableType() : AcDbSolidBackground , AcDbGradientBackground , AcDbImageBackground , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbLight , AcDbSun
  • DrawGroupContent() : CAdUiGroupCtrl
  • DrawGroupHeader() : CAdUiGroupCtrl
  • DrawItemImage() : CAcUiMRUComboBox
  • DrawItemImageFromCargo() : CAcUiMRUComboBox
  • dropTable() : CAseLinkPath
  • DrvMessage() : CAsiSQLObject
  • duplicate() : CAsiException , CAsiTACond , CAsiObject , CAsiIdent , CAsiData , CAsiSmallInt
  • dwfframe() : AcDbDatabase
  • dwgInFields() : AcDbTableTemplate , AcDbSection , AcDbCamera , AcDbMotionPath , AcDbSolidBackground , AcDbGradientBackground , AcDbImageBackground , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbBreakData , AcDbBreakPointRef , AcDbExtrudedSurface , AcDbLight , AcDbLoftedSurface , AcDbCurvePath , AcDbPointPath , AcDbPlaneSurface , AcDbRenderSettings , AcDbRenderEnvironment , AcDbRenderGlobal , AcDbRevolvedSurface , AcDbSun , AcDbSurface , AcDbSweptSurface
  • dwgOutFields() : AcDbLoftedSurface , AcDbSun , AcDbSurface , AcDbSweptSurface , AcDbLight , AcDbBreakPointRef , AcDbGradientBackground , AcDbImageBackground , AcDbMotionPath , AcDbCamera , AcDbSolidBackground , AcDbRenderSettings , AcDbTableTemplate , AcDbPlaneSurface , AcDbRenderGlobal , AcDbSection , AcDbExtrudedSurface , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbBreakData , AcDbRevolvedSurface , AcDbCurvePath , AcDbPointPath , AcDbRenderEnvironment
  • dxeVal() : AcDbDatabase
  • dxfInFields() : AcDbImageBackground , AcDbGradientBackground , AcDbSolidBackground , AcDbMotionPath , AcDbSweptSurface , AcDbPointPath , AcDbTableTemplate , AcDbRenderGlobal , AcDbRevolvedSurface , AcDbBreakPointRef , AcDbCurvePath , AcDbRenderSettings , AcDbSection , AcDbPlaneSurface , AcDbLoftedSurface , AcDbBreakData , AcDbExtrudedSurface , AcDbLight , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbCamera , AcDbRenderEnvironment , AcDbSurface , AcDbSun
  • dxfOutFields() : AcDbImageBackground , AcDbBreakPointRef , AcDbRenderEnvironment , AcDbMotionPath , AcDbSurface , AcDbLoftedSurface , AcDbSun , AcDbSweptSurface , AcDbGradientBackground , AcDbRenderGlobal , AcDbSolidBackground , AcDbCurvePath , AcDbBreakData , AcDbLight , AcDbPointPath , AcDbRenderSettings , AcDbPlaneSurface , AcDbGroundPlaneBackground , AcDbRevolvedSurface , AcDbCamera , AcDbExtrudedSurface , AcDbSkyBackground , AcDbTableTemplate , AcDbSection


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • edgeColor() : AcGiEdgeStyle
  • edgeModel() : AcGiEdgeStyle
  • edgeModifiers() : AcGiEdgeStyle
  • edgeStyle() : AcGiVisualStyle
  • edgeStyleApply() : AcGiEdgeStyle
  • edgeStyles() : AcGiEdgeStyle
  • edgeTransparency() : AcDbSectionSettings
  • edgeWidth() : AcGiEdgeStyle
  • enableLiveSection() : AcDbSection
  • endDraftDist() : AcDbSweepOptions
  • EndFieldDialog() : CAcFdUiFieldDialogHook
  • entityId() : AcDbCurvePath
  • environmentImageEnabled() : AcDbRenderEnvironment
  • environmentImageFileName() : AcDbRenderEnvironment
  • equals() : AcDbEvalGraph , AcDbEvalExpr
  • erase() : CAseLinkPath , CAseLinkSel
  • erased() : AcDbRasterImageDefReactor
  • eraseFromDb() : AcDbBreakData
  • Err() : CAsiException , CAsiSQLObject
  • errClear() : CAseApiObj
  • errCode() : CAseApiObj
  • errDiagPar() : CAseApiObj
  • errDiagParNameCode() : CAseApiObj
  • errDsc() : CAseApiObj
  • errGet() : CAseApiObj
  • errInitAsi() : CAseApiObj
  • ErrMsg() : CAsiException , CAsiSQLObject
  • errMsg() : CAseApiObj
  • ErrPosition() : CAsiException , CAsiSQLObject
  • errQty() : CAseApiObj
  • evaluate() : AcDbEvalGraph , AcDbEvalExpr , AcDbEvalGraph
  • evaluatorId() : AcFdFieldEvaluator
  • Execute() : CAsiExecStm
  • exposureType() : AcDbRenderGlobal
  • extendedLightLength() : AcGiShadowParameters2
  • extendedLightRadius() : AcGiShadowParameters2
  • extendedLightShape() : AcGiShadowParameters2
  • extendedLightWidth() : AcGiShadowParameters2
  • exteriorDaylight() : AcGiToneOperatorParameters


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • faceColorMode() : AcGiFaceStyle
  • faceModifiers() : AcGiFaceStyle
  • faceStyle() : AcGiVisualStyle
  • faceTransparency() : AcDbSectionSettings
  • fade() : AcDbUnderlayReference
  • fadeDefault() : AcDbUnderlayReference
  • fadeLowerLimit() : AcDbUnderlayReference
  • fadeUpperLimit() : AcDbUnderlayReference
  • falloffAngle() : AcDbLight
  • Fetch() : CAsiCsr , CAsiEnumerator
  • FetchAbsolute() : CAsiCsr
  • FetchFirst() : CAsiCsr
  • FetchLast() : CAsiCsr
  • FetchPrior() : CAsiCsr
  • FetchRelative() : CAsiCsr
  • fillType() : AcGiNonEntityTraits
  • Find() : CNavFilter , CNavFilterArray
  • find() : AcArray< T, R > , AcString
  • findEvaluator() : AcFdFieldEvaluatorLoader
  • FindExact() : CNavFilterArray
  • FindFirst() : CAsiUcStr
  • findFrom() : AcArray< T, R >
  • FindInSearchPath() : CNavDialog
  • FindLast() : CAsiUcStr
  • findOneOf() : AcString
  • first() : AcArray< T, R >
  • fitToScreen() : AcDbImageBackground
  • flushCond() : CAsiException , CAsiSQLObject
  • fogBackgroundEnabled() : AcDbRenderEnvironment
  • fogColor() : AcDbRenderEnvironment
  • fogDensity() : AcDbRenderEnvironment
  • fogEnabled() : AcDbRenderEnvironment
  • format() : AcFdFieldEvaluator
  • formatV() : AcString
  • FracSecPrec() : CAsiData
  • frameRate() : AcDbMotionPath
  • frames() : AcDbMotionPath
  • freeSel() : CAseLinkSel
  • freeStr() : CAseApiObj
  • from() : AcDbEvalEdgeInfo


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • generateSectionGeometry() : AcDbSection
  • generationOptions() : AcDbSectionSettings
  • get3dDwfPrec() : AcDbDatabase
  • getAcadDsPath() : CAseAppl
  • GetAcceptAnyFileExtension() : CNavDialog
  • getActiveFileName() : AcDbUnderlayDefinition
  • getAdjustedColor() : AcDbUnderlayHost
  • GetAllDialogsData() : CNavDialog
  • getAllNodes() : AcDbEvalGraph
  • GetAnimationControl() : AcTrayItem
  • getAppl() : CAseApiObj
  • getArea() : AcDbSurface
  • getAseErr() : CAseAppl
  • getAseTransactionMode() : CAseAppl
  • getAt() : AcDbEvalContext
  • getAttr() : CAseLink
  • getAttrPtr() : CAseApiObj
  • getAttrType() : CAseApiObj
  • getAxisPnt() : AcDbRevolvedSurface
  • getAxisVec() : AcDbRevolvedSurface
  • getBreakPointId() : AcDbBreakPointRef
  • getBreakPointRef() : AcDbBreakData
  • GetCatalog() : CAsiSession
  • GetCategoryNames() : CAcFdUiFieldDialogHook
  • getCell() : AcDbTableIterator
  • getCellStyles() : AcDbTableStyle
  • getClassID() : AcDbExtrudedSurface , AcDbLight , AcDbLoftedSurface , AcDbPlaneSurface , AcDbRevolvedSurface , AcDbSection , AcDbSectionSettings , AcDbSurface , AcDbSweptSurface , AcDbCamera
  • getClipSpaceToWCSMatrix() : AcDbSpatialFilter
  • getColumn() : AcDbTableIterator
  • GetColValue() : CAsiCsr
  • GetConfirmReplace() : CNavDialog
  • getConnectedNames() : AcDbEvalConnectable
  • getConnectedObjects() : AcDbEvalConnectable
  • getConnectionNames() : AcDbEvalConnectable
  • GetConnectionString() : CAsiSession
  • getConnectionType() : AcDbEvalConnectable
  • getConnectionValue() : AcDbEvalConnectable
  • GetCount() : CNavArray< T > , CNavFilter
  • GetCreatingFile() : CNavDialog
  • getCrossSection() : AcDbLoftedSurface
  • GetCurrentField() : CAcFdUiFieldDialog
  • GetCurrentFileExtension() : CNavDialog
  • GetCurrentFolderForPersistence() : CNavDialog
  • GetCurrentFormat() : CAcFdUiFormatDialog , CAcFdUiFormatList
  • getCurrentRow() : CAsiCsr
  • getCursorRow() : CAseLinkPath
  • getDACols() : CAseLink
  • GetData() : CNavArray< T >
  • GetDataArray() : CNavDialog
  • GetDatabase() : CAcFdUiFieldDialogHook
  • GetDataType() : CNavData
  • GetDefaultBrowserStartURL() : CNavDialog
  • GetDefaultFileExtension() : CNavDialog
  • GetDefaultFilterIndex() : CNavDialog
  • GetDefaultInitialFolder() : CNavDialog
  • GetDescription() : CNavFilter
  • getDiagData() : CAsiException
  • getDiagPar() : CAsiException , CAsiSQLObject
  • GetDialogCaption() : CNavDialog
  • GetDownloadActionCodes() : CNavDialog
  • getDwg() : CAseLinkPath , CAseLink , CAseLinkSel
  • getEdgeInfo() : AcDbEvalGraph
  • getElem() : AcGiVariant
  • getElemAt() : AcGiVariant
  • getElemCount() : AcGiVariant
  • getEntity() : CAseLink
  • getEntSel() : CAseLinkSel
  • getEvaluator() : AcFdFieldEvaluatorLoader
  • GetEvaluatorIds() : CAcFdUiFieldDialogHook
  • GetExtensionName() : CNavData
  • GetFieldCode() : CAcFdUiFieldDialog
  • GetFieldCodeEditCtrl() : CAcFdUiFieldDialog
  • GetFieldDialog() : CAcFdUiFieldOptionDialog
  • GetFieldDialogHook() : CAcFdUiFieldOptionDialog
  • GetFieldNames() : CAcFdUiFieldDialogHook
  • GetFieldToEdit() : CAcFdUiFieldDialog
  • GetFilterArray() : CNavDialog
  • GetFilterIndex() : CNavDialog
  • GetFolderListCtrl() : CNavDialog
  • GetFoldersOnly() : CNavDialog
  • GetForceFilterIndex() : CNavDialog
  • GetForceInitialFolder() : CNavDialog
  • GetFormatList() : CAcFdUiFormatDialog
  • GetFormatType() : CAcFdUiFormatDialog , CAcFdUiFormatList
  • GetFullDescription() : CNavFilter
  • getFuncDsc() : CAsiData
  • getGeometry() : AcDbNamedPath , AcDbCurvePath , AcDbPointPath
  • getGeomExtents() : AcDbLight , AcDbMline , AcDbProxyEntity , AcDbSection
  • getGraph() : AcDbEvalGraph , AcDbEvalExpr
  • getGripEntityUCS() : AcDbExtrudedSurface , AcDbLoftedSurface , AcDbRevolvedSurface , AcDbSweptSurface
  • getGripPoints() : AcDbLight , AcDbLoftedSurface , AcDbPlaneSurface , AcDbRevolvedSurface , AcDbSection , AcDbSweptSurface , AcDbCamera , AcDbExtrudedSurface
  • getGuideCurve() : AcDbLoftedSurface
  • getHatchPattern() : AcDbSectionSettings
  • getHeight() : AcDbExtrudedSurface
  • getId() : CAseLink , CAseLinkSel
  • GetID() : CNavData
  • getIdArray() : CAseLinkSel
  • GetIDD() : CNavDialog
  • GetImpObject() : CNavDialog
  • getIncomingEdges() : AcDbEvalGraph
  • GetInitialFileName() : CNavDialog
  • GetInitialFilterIndex() : CNavDialog
  • getIsActive() : AcDbEvalGraph
  • getItemName() : AcDbUnderlayDefinition
  • getKey() : CAseLink
  • getKeyDsc() : CAseLinkPath
  • getLast() : CAseApiObj
  • GetLastCharacter() : CAdUiPathname
  • getLimits() : AcDbLayout
  • getLinkEnt() : CAseLinkSel
  • getLinkKey() : CAseLinkSel
  • getLinkName() : CAseLinkSel
  • getLinkNames() : CAseLinkPath , CAseLinkSel
  • getLoftOptions() : AcDbLoftedSurface
  • GetMultiSelectAllowed() : CNavDialog
  • getName() : AcDbSection , CAseLinkPath , CAseLink , AcDbAnnotationScale , AcDbSection
  • getNameSize() : CAseLinkPath , CAseLink
  • getNode() : AcDbEvalGraph
  • GetNoExtraExtensions() : CNavDialog
  • GetNoExtraExtensionsInPlaces() : CNavDialog
  • GetNoFTP() : CNavDialog
  • GetNonClientSize() : CAdUiPaletteSet
  • GetNoPlacesList() : CNavDialog
  • GetNoURLFileTransfer() : CNavDialog
  • GetNoURLsAllowed() : CNavDialog
  • GetOkButtonText() : CNavDialog
  • GetOptionDialog() : CAcFdUiFieldDialog , CAcFdUiFieldDialogHook
  • getOriginalInverseBlockXform() : AcDbSpatialFilter
  • getOsnapPoints() : AcDbDimension , AcDbLight , AcDbMLeader , AcDbSection , AcDbLight
  • getOutgoingEdges() : AcDbEvalGraph
  • GetPassword() : CNavData
  • getPassword() : AcDbHostApplicationServices
  • getPathCode() : CAseLinkPath
  • getPathEntity() : AcDbLoftedSurface , AcDbSweptSurface
  • getPathEntityTransform() : AcDbSweepOptions
  • getPathLength() : AcDbSweptSurface
  • GetPathname() : CNavData
  • getPaths() : CAseLinkPath
  • GetPersonalFolderPath() : CNavDialog
  • GetPreview() : CAcFdUiFieldDialogHook
  • GetProductName() : CNavDialog
  • getQty() : CAseLinkSel
  • GetReadOnlyAllowed() : CNavDialog
  • GetReadOnlyHidden() : CNavDialog
  • GetReadOnlySpecified() : CNavDialog
  • GetRecentDirectory() : CNavDialog
  • GetRegisteredDialogHooks() : CAcFdUiFieldManager
  • getRevolveAngle() : AcDbRevolvedSurface
  • getRevolveEntity() : AcDbRevolvedSurface
  • getRevolveOptions() : AcDbRevolvedSurface
  • getRow() : AcDbTableIterator , CAseLinkPath
  • getSectionManager() : AcDbDatabase
  • GetSelIndex() : CAdUiGroupCtrl
  • getSettings() : AcDbSection
  • GetSingleDataFullPath() : CNavDialog
  • getSkipHidden() : AcDbLayerTableIterator
  • getSkipReconciled() : AcDbLayerTableIterator
  • getSourceFileName() : AcDbUnderlayDefinition
  • getSourceObjects() : AcDbSectionSettings
  • getStartAngle() : AcDbRevolvedSurface
  • GetStatus() : CAsiCsr , CAsiSession
  • getStatus() : CAseLinkPath
  • GetStatus() : CAsiSQLObject , CAsiExecStm
  • getStretchPoints() : AcDbMLeader , AcDbCamera
  • getSweepEntity() : AcDbSweptSurface , AcDbExtrudedSurface
  • getSweepEntityTransform() : AcDbSweepOptions
  • getSweepOptions() : AcDbExtrudedSurface , AcDbSweptSurface
  • getSweepVec() : AcDbExtrudedSurface
  • getTableDsc() : CAseLinkPath
  • GetTagIndex() : CNavFilter
  • getTemplate() : AcDbTableStyle
  • GetText() : CNavData
  • GetTextInFolder() : CNavData
  • getTimeZoneInfo() : AcDbDatabase
  • getToChar() : CAsiUcStr
  • getToCharChk() : CAsiUcStr
  • GetToolsMenuItemPosition() : CNavDialog
  • GetToolsMenuItemsPresent() : CNavDialog
  • getToUcChar() : CAsiUcStr
  • getTransformedCopy() : AcDbLight
  • getType() : CAseLink
  • getUnderlayItem() : AcDbUnderlayDefinition
  • getUnderlayLayer() : AcDbUnderlayReference
  • getUnreconciledLayers() : AcDbLayerTable
  • GetURL() : CNavData
  • GetUserData() : CNavData
  • GetUseRegExtensionFlags() : CNavDialog
  • GetUserName() : CNavData
  • getValue() : CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt , CAsiData
  • getVertex() : AcDbSection
  • getVertices() : AcDbSection
  • GetViewMode() : CNavDialog
  • getVisualStyleDictionary() : AcDbDatabase
  • getVisualStyleList() : AcDbDatabase
  • getXName() : CAseLink
  • getXNames() : CAseLinkSel
  • GiveFeedback() : CNavDropSource
  • grainThickness() : AcGiWoodTexture
  • graphEvalAbort() : AcDbEvalExpr
  • graphEvalEnd() : AcDbEvalExpr
  • graphEvalStart() : AcDbEvalExpr
  • green() : AcCmDialogColor
  • gridMajor() : AcDbViewportTableRecord
  • growLength() : AcArray< T, R >
  • gsHighlightModel() : AcDbDatabase
  • gsNode() : AcDbSun


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • haloGap() : AcGiEdgeStyle
  • hasBookName() : AcCmDialogColor
  • hasColorName() : AcCmDialogColor
  • hasConnectionNamed() : AcDbEvalConnectable
  • hasGraph() : AcDbEvalGraph
  • hasTarget() : AcDbLight
  • hasUnreconciledLayers() : AcDbLayerTable
  • hatchAngle() : AcDbSectionSettings
  • hatchScale() : AcDbSectionSettings
  • hatchSpacing() : AcDbSectionSettings
  • hatchVisibility() : AcDbSectionSettings
  • height() : AcDbGradientBackground , AcDbSection
  • hiddenLine() : AcDbSectionSettings
  • hidePrecision() : AcGiEdgeStyle
  • highInfoLevel() : AcDbRenderGlobal
  • highlight() : AcDbLight , AcDbCamera
  • hitTest() : AcDbSection
  • horizon() : AcDbGradientBackground
  • hotspotAngle() : AcDbLight
  • hpInherit() : AcDbDatabase
  • hpOrigin() : AcDbDatabase


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • illuminanceDistance() : AcDbLight
  • imageFilename() : AcDbImageBackground
  • ImmConstr() : CAsiSession
  • ImmediateExecute() : CAsiExecStm
  • imp() : AcDbNamedPath
  • ImplDataType() : CAsiData
  • indicatorFillColor() : AcDbSection
  • indicatorTransparency() : AcDbSection
  • InheritStatusInfo() : CAsiSQLObject
  • init() : CAseApiObj , CAseAppl , CAseLinkPath , CAseLink , CAseLinkSel
  • Init() : CAsiAppl
  • InitAccessor() : CAsiCsr
  • InitColsDsc() : CAsiStm
  • initCurrent() : CAseLinkPath
  • initDA() : CAseLink
  • initEnt() : CAseLink , CAseLinkSel
  • InitErrorInfo() : CAsiSQLObject
  • initFilter() : CAseLinkSel
  • initialize() : AcDbLayout
  • initId() : CAseLink
  • initLp() : CAseLinkSel
  • initLpCond() : CAseLinkSel
  • initLpEnt() : CAseLinkSel
  • initLpKey() : CAseLinkSel
  • initLpSel() : CAseLinkSel
  • initName() : CAseLinkPath
  • InitOutputBind() : CAsiCsr
  • initPartialKey() : CAseLinkSel
  • initPath() : CAseLinkPath
  • initSel() : CAseLinkSel
  • initType() : CAseLink , CAseLinkSel
  • initXName() : CAseLinkSel
  • Insert() : CAsiCsr
  • insertAt() : AcArray< T, R > , AcDbEvalContext
  • InsertRow() : CAsiCsr
  • InsertUserItemInPlaces() : CNavDialog
  • intensity() : AcDbSun , AcDbLight
  • interfereColor() : AcDbDatabase
  • interfereObjVisStyle() : AcDbDatabase
  • interfereVpVisStyle() : AcDbDatabase
  • internalSubentId() : AcDbBody , AcDbRegion , AcDb3dSolid , AcDbSurface
  • internalSubentPtr() : AcDbBody , AcDbRegion , AcDb3dSolid , AcDbSurface
  • intersect() : CAseLinkSel
  • intersectEnt() : CAseLinkSel
  • intersectFilter() : CAseLinkSel
  • intersectionColor() : AcGiEdgeStyle
  • intersectionLinetype() : AcGiEdgeStyle
  • intersectLp() : CAseLinkSel
  • intersectLpCond() : CAseLinkSel
  • intersectLpKey() : CAseLinkSel
  • intersectPartialKey() : CAseLinkSel
  • intersectSel() : CAseLinkSel
  • intersectType() : CAseLinkSel
  • intersectWith() : AcDbBreakPointRef
  • intersectXName() : CAseLinkSel
  • IntervalType() : CAsiData
  • intValue() : CAsiNum , CAsiSmallInt
  • invalidateCachedBodySubentIds() : AcDbBody
  • is_approxnumeric() : CAsiData , CAsiNum , CAsiApproxNum
  • is_binary() : CAsiData
  • is_castable() : CAsiData , CAsiNum
  • is_character() : CAsiData
  • is_comparable() : CAsiData , CAsiNum
  • is_datetime() : CAsiData
  • is_dtinterval() : CAsiData
  • is_exactnumeric() : CAsiData , CAsiNum , CAsiExactNum
  • is_implement() : CAsiData
  • is_insensitive() : CAsiCsr
  • is_insertable() : CAsiCsr
  • is_interval() : CAsiData
  • is_numeric() : CAsiData , CAsiNum
  • is_open() : CAsiCsr
  • is_scrollable() : CAsiCsr
  • is_storable() : CAsiNum , CAsiData
  • is_updatable() : CAsiCsr
  • is_yminterval() : CAsiData
  • isA() : CAseAppl , CAseLinkPath , CAseLink , CAseLinkSel
  • isActivatable() : AcDbEvalExpr
  • isActive() : AcGiToneOperatorParameters
  • isAdjustedForBackground() : AcDbUnderlayReference
  • IsAllowed() : CNavFilter
  • IsAnyCtrlMinimizedOrIconic() : CAdUiCoupledGroupCtrl
  • isByACI() : AcCmDialogColor
  • isByBlock() : AcCmDialogColor
  • isByColor() : AcCmDialogColor
  • isByLayer() : AcCmDialogColor
  • isByPen() : AcCmDialogColor
  • isCameraPlottable() : AcDbViewTableRecord
  • isClipped() : AcDbUnderlayReference
  • isContentSnappable() : AcDbUnderlayReference
  • isDayLightSavingsOn() : AcDbSun
  • isDefaultLightingOn() : AcDbAbstractViewTableRecord
  • isDelimited() : CAsiIdent
  • isDependent() : AcDbLoftedSurface , AcDbRevolvedSurface , AcDbExtrudedSurface , AcDbSweptSurface , AcDbPlaneSurface
  • isDiffChar() : CAseApiObj
  • isDisplaySettingsFlagSet() : AcGiDisplayStyle
  • isDwgLazyOpened() : CAseAppl
  • isDwgOpened() : CAseAppl
  • isEdgeModifierFlagSet() : AcGiEdgeStyle
  • isEdgeStyleFlagSet() : AcGiEdgeStyle
  • isEmpty() : AcArray< T, R >
  • isEqualTo() : CAsiData , CAsiSmallInt
  • isEquivalent() : AcGiVariant
  • IsExtension() : CNavData
  • isFaceModifierFlagSet() : AcGiFaceStyle
  • IsFieldCodeDirty() : CAcFdUiFieldDialog
  • isForeground() : AcCmDialogColor
  • isFramePlottable() : AcDbUnderlayReference
  • isFrameVisible() : AcDbUnderlayReference
  • isGreaterThan() : CAsiData , CAsiSmallInt
  • isGridAdaptive() : AcDbViewportTableRecord
  • isGridBoundToLimits() : AcDbViewportTableRecord
  • isGridFollow() : AcDbViewportTableRecord
  • isGridSubdivisionRestricted() : AcDbViewportTableRecord
  • isHorizontalRefTextRotation() : AcDbDimension
  • isIndexExist() : CAseAppl
  • isIndexUpToDate() : CAseAppl
  • IsIndexValid() : CNavArray< T >
  • isInit() : CAseLinkSel , CAsiSQLObject , CAseLinkPath , CAseAppl , CAseLink , CAseApiObj
  • isInvertible() : AcDbEvalEdgeInfo
  • isLiveSectionEnabled() : AcDbSection
  • isLoaded() : AcDbUnderlayDefinition
  • isMonochrome() : AcDbUnderlayReference
  • isNull() : CAsiData
  • isolines() : AcGiEdgeStyle
  • isOn() : AcDbSun , AcDbUnderlayReference , AcDbLight
  • isPlottable() : AcDbLight
  • IsRemote() : CNavData
  • isResident() : AcDbObjectId
  • IsRowset() : CAsiExecStm , CAsiCsr , CAsiSQLObject
  • isSubgraphOf() : AcDbEvalGraph
  • isSuppressed() : AcDbEvalEdgeInfo
  • isTextField() : AcDbField
  • isUpdatable() : CAseLinkPath , CAseLink , CAseLinkSel


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • jitterAmount() : AcGiEdgeStyle


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • key() : AcDbEvalContextPair


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • lampColorPreset() : AcDbLight
  • lampColorRGB() : AcDbLight
  • lampColorTemp() : AcDbLight
  • lampColorType() : AcDbLight
  • last() : AcArray< T, R >
  • latitude() : AcDbDatabase
  • LaunchBrowserDialog() : CNavDialog
  • layer() : AcDbSectionSettings
  • layerId() : AcGiNonEntityTraits
  • LeadFieldPrec() : CAsiData
  • length() : AcArray< T, R >
  • Length() : CAsiIdent , CAsiData , CAsiUcStr
  • lensLength() : AcDbDatabase
  • lightAttenuation() : AcDbLight
  • lightColor() : AcDbLight
  • lightDirection() : AcDbLight
  • lightGlyphDisplay() : AcDbDatabase
  • lightingModel() : AcGiFaceStyle
  • lightingQuality() : AcGiFaceStyle
  • lightingUnits() : AcDbDatabase
  • lightsInBlocks() : AcDbDatabase
  • lightType() : AcDbLight
  • lineIndex() : AcDbBreakPointRef
  • linetype() : AcDbSectionSettings
  • lineTypeId() : AcGiNonEntityTraits
  • linetypeScale() : AcDbSectionSettings
  • lineTypeScale() : AcGiNonEntityTraits
  • lineWeight() : AcDbSectionSettings , AcGiNonEntityTraits
  • list() : AcDbCamera , AcDbExtrudedSurface , AcDbSection , AcDbLoftedSurface , AcDbRevolvedSurface , AcDbPlaneSurface , AcDbSurface , AcDbLight , AcDbSweptSurface
  • liveSection() : AcDbViewTableRecord
  • load() : AcDbUnderlayDefinition
  • loadLinks() : CAseAppl
  • LocateFile() : CNavDialog
  • loftAng1() : AcDbDatabase
  • loftAng2() : AcDbDatabase
  • loftMag1() : AcDbDatabase
  • loftMag2() : AcDbDatabase
  • loftNormals() : AcDbDatabase
  • loftParam() : AcDbDatabase
  • logicalLength() : AcArray< T, R >
  • longitude() : AcDbDatabase


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • maintainAspectRatio() : AcDbImageBackground
  • MakeCharUpper() : CAcUiString
  • MakeCursorProp() : CAsiCsr
  • makeFilter() : CAseLinkSel
  • MapAsiToColumnInfo() : CAsiData , CAsiSmallInt
  • MapAsiToParamInfo() : CAsiSmallInt , CAsiData
  • MapColumnInfoToAsi() : CAsiData
  • mapErrFromAse() : CAseAppl
  • MapParamInfoToAsi() : CAsiData
  • mappers() : AcGiFaceData
  • materialId() : AcGiNonEntityTraits
  • materials() : AcGiFaceData
  • materialsEnabled() : AcDbRenderSettings
  • membId() : CAseLinkSel
  • midTones() : AcGiToneOperatorParameters
  • MinMaxOneChild() : CAdUiCoupledGroupCtrl
  • miterOption() : AcDbSweepOptions
  • ModGroupStyle() : CAdUiGroupCtrl
  • modified() : AcDbRasterImageDefReactor
  • modifiedGraphics() : AcDbBreakData
  • moduleName() : AcadAppInfo
  • monoColor() : AcGiFaceStyle
  • movedFromGraph() : AcDbEvalExpr
  • movedIntoGraph() : AcDbEvalExpr
  • moveGripPointsAt() : AcDbPlaneSurface , AcDbRevolvedSurface , AcDbSection , AcDbLoftedSurface , AcDbLight , AcDbExtrudedSurface , AcDbSweptSurface , AcDbCamera
  • moveStretchPointsAt() : AcDbLoftedSurface , AcDbRevolvedSurface , AcDbCamera , AcDbSweptSurface , AcDbPlaneSurface , AcDbExtrudedSurface
  • msltscale() : AcDbDatabase
  • MultibyteLen() : CAsiUcStr


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • Name() : CAsiSession
  • name() : AcDbLight , AcUnderlayLayer , AcDbRenderSettings
  • NavigateToFolder() : CNavDialog
  • NewData() : CNavArray< T >
  • newIterator() : AcDbEvalContext
  • next() : AcDbEvalContextIterator
  • nextAttr() : CAseApiObj
  • nodeId() : AcDbEvalExpr
  • normal() : AcDbLoftOptions , AcDbSection , AcDbUnderlayReference
  • northDirection() : AcDbDatabase
  • noTwist() : AcDbLoftOptions
  • number() : AcDbViewportTableRecord
  • numCrossSections() : AcDbLoftedSurface
  • numGuideCurves() : AcDbLoftedSurface
  • numVertices() : AcDbSection


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • obscuredColor() : AcGiEdgeStyle
  • obscuredLinetype() : AcGiEdgeStyle
  • OnAnchor() : CAdUiDockControlBar
  • OnAnchorLeft() : CAdUiDockControlBar
  • OnAnchorRight() : CAdUiDockControlBar
  • OnBeginDrag() : CNavListCtrl
  • OnBeginFormatExDialog() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog
  • OnBnClickedAdditionalFormat() : CAcFdUiFormatDialog
  • OnBnClickedAppendSymbol() : CAcFdUiFormatDialog
  • OnBnClickedFilenameOnly() : CAcFdUiFormatDialog
  • OnBnClickedFormatEx() : CAcFdUiFormatDialog
  • OnBnClickedIncludeExtension() : CAcFdUiFormatDialog
  • OnBnClickedPathAndFilename() : CAcFdUiFormatDialog
  • OnBnClickedPathOnly() : CAcFdUiFormatDialog
  • OnBnClickedPointX() : CAcFdUiFormatDialog
  • OnBnClickedPointY() : CAcFdUiFormatDialog
  • OnBnClickedPointZ() : CAcFdUiFormatDialog
  • OnCancel() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog , CNavDialog
  • OnCbnEditChangeListSeparator() : CAcFdUiFormatDialog
  • OnCbnSelChangeCategoryList() : CAcFdUiFieldDialog
  • OnCbnSelChangeCurrencySymbol() : CAcFdUiFormatDialog
  • OnCbnSelChangeDecimalSeparator() : CAcFdUiFormatDialog
  • OnCbnSelChangeListSeparator() : CAcFdUiFormatDialog
  • OnCbnSelChangePrecision() : CAcFdUiFormatDialog
  • OnChevronClicked() : CAdUiGroupCtrl
  • OnCmdMsg() : CNavDialog
  • OnContextMenu() : CNavDialog
  • OnCtlColor() : CAdUiCoupledGroupCtrl , CAdUiGroupCtrl
  • onDeleteImage() : AcDbRasterImageDefReactor
  • OnDestroy() : CAcFdUiFormatDialog , CNavDialog
  • OnDialogHelp() : CAcFdUiFieldDialog , CNavDialog
  • OnDoFind() : CNavDialog
  • OnDoLocate() : CNavDialog
  • OnEnChangeFieldCode() : CAcFdUiFieldDialog
  • OnEnChangePreview() : CAcFdUiFormatDialog
  • OnEndFormatExDialog() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog
  • OnFieldSelected() : CAcFdUiFieldDialogHook , CAcFdUiFieldOptionDialog
  • OnFileNameChange() : CNavDialog
  • OnFileNameOK() : CNavDialog
  • OnFileNameSelectionChange() : CNavDialog
  • OnFilterChange() : CNavDialog
  • OnFolderChange() : CNavDialog
  • OnFolderItemChange() : CNavDialog
  • OnFormatChanged() : CAcFdUiFieldDialog
  • OnGetPaletteCount() : CAdUiPaletteSet
  • OnGetPaletteName() : CAdUiPaletteSet
  • OnGetTipRect() : CAcUiMRUListBox
  • OnHandleDrag() : CNavListCtrl
  • OnHelpInfo() : CNavDialog
  • OnInitDialog() : CAcFdUiFieldDialog , CNavDialog
  • OnKickIdle() : CNavDialog
  • OnKillActive() : CAcFdUiFieldOptionDialog
  • OnKillFocus() : CAdUiGroupCtrl
  • OnLbnSelChangeFieldNameList() : CAcFdUiFieldDialog
  • OnLbnSelChangeFormatList() : CAcFdUiFormatDialog
  • OnLbnSelChangeNegativeNumberList() : CAcFdUiFormatDialog
  • OnLButtonDown() : CAdUiCoupledGroupCtrl
  • OnLButtonUp() : CAdUiCoupledGroupCtrl
  • OnMouseMove() : CAdUiCoupledGroupCtrl
  • OnNcCalcSize() : CAdUiGroupCtrl
  • OnNcHitTest() : CAdUiGroupCtrl , CAdUiPaletteSet
  • OnNcLButtonDblClk() : CAdUiGroupCtrl
  • OnNcLButtonDown() : CAdUiGroupCtrl
  • OnNcPaint() : CAdUiGroupCtrl
  • OnNotifyControlChange() : CNavDialog
  • OnNotifyGeneric() : CNavDialog
  • OnOK() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog , CNavDialog
  • OnPaint() : CAdUiCoupledGroupCtrl , CAdUiGroupCtrl
  • OnSetActive() : CAcFdUiFieldOptionDialog
  • OnSetFocus() : CAdUiGroupCtrl
  • OnSetPaletteActive() : CAdUiPaletteSet
  • OnSize() : CAdUiCoupledGroupCtrl , CAdUiGroupCtrl
  • OnSysColorChange() : CNavDialog
  • OnToolsMenuOptions() : CAcUiNavDialog
  • OnURLDownloadSuccess() : CNavDialog
  • OnUrlOK() : CNavDialog
  • opacityLevel() : AcGiFaceStyle , AcGiEdgeStyle
  • Open() : CAcUiPathname , CAsiCsr , CAsiCsrTable
  • openDwg() : CAseAppl
  • openLazyDwg() : CAseAppl
  • operation() : AcGiVisualStyle
  • operator delete() : CAsiObject
  • operator new() : CAsiObject
  • operator!=() : CAsiApproxNum , AcCmDialogColor , CAsiNum , CAsiExactNum , CAsiApproxNum
  • operator*() : CAsiSmallInt
  • operator*=() : CAsiSmallInt
  • operator+() : CAsiSmallInt
  • operator++() : CAsiSmallInt
  • operator+=() : CAsiSmallInt
  • operator-() : CAsiSmallInt
  • operator--() : CAsiSmallInt
  • operator-=() : CAsiSmallInt
  • operator/() : CAsiSmallInt
  • operator/=() : CAsiSmallInt
  • operator<() : CAsiExactNum , CAsiApproxNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiApproxNum
  • operator<=() : CAsiNum , CAsiExactNum , CAsiApproxNum , CAsiExactNum , CAsiNum
  • operator=() : CAsiSmallInt , AcGiVariant , AcGiImageFileTexture , AcGiGenericTexture , AcGiWoodTexture , CAsiSmallInt , AcGiMarbleTexture , AcGiEdgeStyle , CAsiSmallInt , CAsiIdent , CAsiUcStr , CAsiSmallInt , AcGiVisualStyle , CAseApiObj , CAseAppl , CAsiSmallInt , CAseLink , CAsiSmallInt , CAseLinkPath , CAsiSmallInt , CAsiIdent , CAsiSmallInt , CAseLinkSel , AcCmDialogColor , AcDbLoftOptions , AcDbRevolveOptions , AcGiDisplayStyle , AcGiFaceStyle , AcArray< T, R > , CAsiUcStr , AcDbSweepOptions , AcCmDialogColor
  • operator==() : AcCmDialogColor , CAsiNum , CAsiApproxNum , CAsiNum , CAsiExactNum , CAsiIdent , CAsiExactNum , AcDbEvalEdgeInfo , CAsiExactNum , CAsiNum , AcCmDialogColor , AcGiGenericTexture , AcDbRenderEnvironment , AcGiMarbleTexture , AcDbRenderSettings , AcArray< T, R > , CAsiApproxNum , CAseLinkPath , CAseAppl , CAsiNum , CAsiExactNum , AcGiToneOperatorParameters , AcGiShadowParameters2 , CAsiApproxNum , AcGiVisualStyle , CAseLinkPath , CAseLinkSel , CAsiApproxNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiApproxNum , CAseLinkSel , CAsiExactNum , CAsiApproxNum , CAsiExactNum , AcGiDisplayStyle , CAsiNum , CAsiExactNum , AcGiEdgeStyle , CAseLink , CAseAppl , AcGiWoodTexture , AcGiFaceStyle , AcGiImageFileTexture , CAsiNum , AcGiVariant , AcGiShadowParameters , CAsiApproxNum
  • operator>() : CAsiNum , CAsiApproxNum , CAsiExactNum , CAsiApproxNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiApproxNum , CAsiExactNum , CAsiApproxNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiApproxNum , CAsiNum , CAsiExactNum , CAsiApproxNum
  • operator>=() : CAsiApproxNum , CAsiExactNum , CAsiApproxNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiApproxNum , CAsiNum , CAsiApproxNum , CAsiNum , CAsiApproxNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiApproxNum , CAsiNum , CAsiApproxNum , CAsiExactNum , CAsiNum
  • operator[]() : AcArray< T, R > , CAsiUcStr , AcArray< T, R >
  • overhangAmount() : AcGiEdgeStyle


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • packSize() : CAsiObject , CAsiIdent , CAsiSmallInt
  • packTo() : CAsiObject , CAsiIdent , CAsiSmallInt
  • packValueSize() : CAsiSmallInt , CAsiObject
  • packValueTo() : CAsiObject , CAsiSmallInt
  • ParamDsc() : CAsiStm , CAsiExecStm , CAsiCsr
  • ParamQty() : CAsiCsr , CAsiStm , CAsiExecStm
  • parseLisp() : CAseApiObj
  • penIndex() : AcCmDialogColor
  • physicalIntensity() : AcDbLight
  • physicalIntensityMethod() : AcDbLight
  • physicalLength() : AcArray< T, R >
  • pInput() : CAsiStm
  • plane() : AcDbSection
  • plotAsRaster() : AcDbPlotSettings
  • plotStyleName() : AcDbSectionSettings
  • plotWireframe() : AcDbPlotSettings
  • pointType() : AcDbBreakPointRef
  • position() : CAsiCsr , AcDbLight , AcDbUnderlayReference
  • postInDatabase() : AcDbEvalExpr , AcDbEvalGraph
  • postToDb() : AcDbBreakData
  • precat() : AcString
  • Precision() : CAsiNum , CAsiData
  • predefinedPresetsFirst() : AcDbRenderGlobal
  • Prepare() : CAsiExecStm
  • PrepareOkMenu() : CNavDialog
  • PrepareToolsMenu() : CNavDialog
  • PrepareViewsMenu() : CNavDialog
  • PreprocessData() : CNavDialog
  • PreTranslateMessage() : CNavDialog , CAdUiGroupCtrl
  • previewImageFileName() : AcDbRenderSettings
  • procedureAndDestination() : AcDbRenderGlobal
  • processBackground() : AcGiToneOperatorParameters
  • propertyType() : AcGiVisualStyle
  • psolHeight() : AcDbDatabase
  • psolWidth() : AcDbDatabase
  • pushCond() : CAsiException , CAsiSQLObject
  • pushErr() : CAsiSQLObject
  • pushHResult() : CAsiSQLObject


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QueryCursorProp() : CAsiCsr


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • radialNoise() : AcGiWoodTexture
  • RaiseApplyEvent() : CAdUiTabMainDialog
  • ReadData() : CAsiCsr
  • realValue() : CAsiNum , CAsiSmallInt
  • realWorldScale() : AcDbDatabase
  • receiveShadows() : AcDbLight
  • red() : AcCmDialogColor
  • refCount() : AcDbEvalEdgeInfo
  • Refresh() : CAcFdUiFormatList , CNavDialog
  • registerContextCollection() : AcDbObjectContextManager
  • RegisterFieldDialogHook() : CAcFdUiFieldManager
  • registerObject() : AcDbAuditInfo
  • reInit() : CAseLinkPath
  • ReleaseErrorInfo() : CAsiSQLObject
  • remappedNodeIds() : AcDbEvalExpr
  • remObj() : CAseAppl
  • remove() : AcArray< T, R > , CAseLink
  • removeAll() : AcArray< T, R >
  • RemoveAllData() : CNavArray< T >
  • removeAssociativity() : AcDbBreakData
  • removeAt() : AcArray< T, R > , AcDbEvalContext
  • RemoveBmpBtnFromHeader() : CAdUiGroupCtrl
  • removeConnection() : CAsiAppl
  • removedFromGraph() : AcDbEvalExpr
  • removeEdge() : AcDbEvalGraph
  • RemoveExtensionAlways() : CAdUiPathname
  • removeFirst() : AcArray< T, R >
  • removeGraph() : AcDbEvalGraph
  • removeIndex() : CAseAppl
  • removeLast() : AcArray< T, R >
  • removeNode() : AcDbEvalGraph
  • removeSubArray() : AcArray< T, R >
  • removeVertex() : AcDbSection
  • rename() : CAseLinkPath
  • replaceGraph() : AcDbEvalGraph
  • ReportURLTransferStatus() : CNavDialog
  • reselectSubRegion() : AcDbTable
  • reset() : AcDbSectionSettings
  • ResizeChildren() : CAdUiCoupledGroupCtrl
  • resultingColor() : AcDbLight
  • ReturnLength() : CAsiData , CAsiSmallInt
  • reverse() : AcArray< T, R >
  • Rollback() : CAsiSession
  • rotation() : AcDbUnderlayReference , AcDbGradientBackground
  • RowCount() : CAsiSQLObject
  • ruled() : AcDbLoftOptions


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • saveEnabled() : AcDbRenderGlobal
  • saveFileName() : AcDbRenderGlobal
  • Scale() : CAsiNum , CAsiData
  • scaleFactor() : AcDbSweepOptions
  • scaleFactors() : AcDbUnderlayReference
  • seek() : AcDbTableIterator
  • select() : AcDbTable
  • select_next_cell() : AcDbTable
  • SelectField() : CAcFdUiFieldDialog
  • selectionGeom() : AcGiNonEntityTraits
  • set() : AcGiVariant , AcGiFaceStyle , AcGiEdgeStyle , AcGiDisplayStyle , CAsiIdent , AcGiVariant
  • set3dDwfPrec() : AcDbDatabase
  • SetAcceptAnyFileExtension() : CNavDialog
  • SetActive() : CAdUiGroupCtrl
  • setAlign() : AcDbSweepOptions
  • setAlignAngle() : AcDbSweepOptions
  • setAlignDirection() : AcDbLoftOptions
  • setAlignStart() : AcDbSweepOptions
  • setAll() : AcArray< T, R >
  • SetAllDialogsData() : CNavDialog
  • setAltitude() : AcDbSun
  • setAmbientLightColor() : AcDbAbstractViewTableRecord
  • setAnnoAllVisible() : AcDbLayout , AcDbDatabase
  • setAnnotationScale() : AcDbViewTableRecord
  • setAnnotativeDwg() : AcDbDatabase
  • setAppDesc() : AcadAppInfo
  • setAppName() : AcadAppInfo
  • setArcLengthParam() : AcDbLoftOptions
  • setArrowSize() : AcDbMLeaderStyle
  • setAseTransactionMode() : CAseAppl
  • setAt() : AcArray< T, R >
  • setAttr() : CAseLink
  • setAttributes() : AcDbCamera , AcDbSolidBackground , AcDbGradientBackground , AcDbImageBackground , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbLight , AcDbMotionPath , AcDbCurvePath , AcDbPointPath , AcDbRenderSettings , AcDbRenderEnvironment , AcDbSun
  • setAttrPtr() : CAseApiObj
  • SetAuthor() : CAsiSession
  • setAxialNoise() : AcGiWoodTexture
  • setAxisPnt() : AcDbRevolvedSurface
  • setAxisVec() : AcDbRevolvedSurface
  • setAzimuth() : AcDbSun
  • setBackFacesEnabled() : AcDbRenderSettings
  • setBackground() : AcDbAbstractViewTableRecord
  • setBank() : AcDbSweepOptions
  • setBasePoint() : AcDbSweepOptions
  • setBlue() : AcCmDialogColor
  • setBody() : CAsiIdent , AcDbBody , AcDbRegion , AcDb3dSolid , AcDbSurface
  • setBreakPoint() : AcDbBreakPointRef
  • setBreakPoint2() : AcDbBreakPointRef
  • setBreakPointId() : AcDbBreakPointRef
  • setBrightness() : AcGiToneOperatorParameters , AcGiDisplayStyle , AcDbAbstractViewTableRecord
  • setCamera() : AcDbViewTableRecord
  • setCameraDisplay() : AcDbDatabase
  • setCameraHeight() : AcDbDatabase
  • setCameraPath() : AcDbMotionPath
  • setCannoscale() : AcDbDatabase
  • setCastShadows() : AcDbLight
  • SetCatalog() : CAsiSession
  • setChannelFlags() : AcDbMaterial
  • setCharSet() : CAsiIdent
  • setCheckIntersections() : AcDbSweepOptions
  • setChromaticAdaptation() : AcGiToneOperatorParameters
  • setClipBoundary() : AcDbUnderlayReference
  • setClosed() : AcDbLoftOptions
  • setCloseToAxis() : AcDbRevolveOptions
  • setCmaterial() : AcDbDatabase
  • setColor() : AcGiNonEntityTraits , AcCmDialogColor , AcDbSectionSettings
  • setColor1() : AcGiWoodTexture
  • setColor2() : AcGiWoodTexture
  • setColorBottom() : AcDbGradientBackground
  • setColorDifferentiation() : AcGiToneOperatorParameters
  • setColorGroundPlaneFar() : AcDbGroundPlaneBackground
  • setColorGroundPlaneNear() : AcDbGroundPlaneBackground
  • setColorIndex() : AcCmDialogColor
  • setColorMethod() : AcCmDialogColor
  • setColorMiddle() : AcDbGradientBackground
  • setColorSkyHorizon() : AcDbGroundPlaneBackground
  • setColorSkyZenith() : AcDbGroundPlaneBackground
  • setColorSolid() : AcDbSolidBackground
  • setColorTop() : AcDbGradientBackground
  • setColorUndergroundAzimuth() : AcDbGroundPlaneBackground
  • setColorUndergroundHorizon() : AcDbGroundPlaneBackground
  • SetConfirmReplace() : CNavDialog
  • setConnectionValue() : AcDbEvalConnectable
  • setContrast() : AcGiToneOperatorParameters , AcDbAbstractViewTableRecord , AcDbUnderlayReference
  • setCornerDecel() : AcDbMotionPath
  • setCreaseAngle() : AcGiEdgeStyle
  • SetCreatingFile() : CNavDialog
  • setCshadow() : AcDbDatabase
  • setCurrent() : CAseLinkPath
  • SetCurrentFormat() : CAcFdUiFormatDialog , CAcFdUiFormatList
  • setCurrentSectionType() : AcDbSectionSettings
  • setDACols() : CAseLink
  • setDAParms() : CAseLink
  • SetDataType() : CNavData
  • setDateTime() : AcDbSun
  • setDAValues() : CAseLink
  • setDayLightSavingsOn() : AcDbSun
  • SetDefaultFileExtension() : CNavDialog
  • SetDefaultFilterIndex() : CNavDialog
  • SetDefaultInitialFolder() : CNavDialog
  • setDefaultLightingOn() : AcDbAbstractViewTableRecord
  • setDefaultLightingType() : AcDbAbstractViewTableRecord
  • setDefinition() : AcGiGenericTexture
  • setDefinitionId() : AcDbUnderlayReference
  • setDelimited() : CAsiIdent
  • SetDescription() : CNavFilter
  • setDescription() : AcDbRenderSettings
  • setDestinationBlock() : AcDbSectionSettings
  • setDestinationFile() : AcDbSectionSettings
  • setDgnframe() : AcDbDatabase
  • setDiagnosticBackgroundEnabled() : AcDbRenderSettings
  • setDiagPar() : CAsiException , CAsiSQLObject
  • SetDialogCaption() : CNavDialog
  • SetDialogStyle() : CAcFdUiFormatDialog
  • setDimensions() : AcDbRenderGlobal
  • setDimfit() : AcDbDimension
  • setDimObjId() : AcDbBreakData
  • setDimunit() : AcDbDimension
  • setDisplayIndex() : AcDbRenderSettings
  • setDisplaySettings() : AcGiDisplayStyle
  • setDisplaySettingsFlag() : AcGiDisplayStyle
  • setDisplayStyle() : AcGiVisualStyle
  • setDistances() : AcDbRenderEnvironment
  • setDivisionLines() : AcDbSectionSettings
  • setDraftAngle() : AcDbRevolveOptions , AcDbSweepOptions
  • setDraftEnd() : AcDbLoftOptions
  • setDraftEndMag() : AcDbLoftOptions
  • setDraftStart() : AcDbLoftOptions
  • setDraftStartMag() : AcDbLoftOptions
  • setDragVisStyle() : AcDbDatabase
  • setDwfframe() : AcDbDatabase
  • setDwg() : CAseLinkPath , CAseLink , CAseLinkSel
  • setDxeVal() : AcDbDatabase
  • setEdgeColor() : AcGiEdgeStyle
  • setEdgeModel() : AcGiEdgeStyle
  • setEdgeModifierFlag() : AcGiEdgeStyle
  • setEdgeModifiers() : AcGiEdgeStyle
  • setEdgeStyle() : AcGiVisualStyle
  • setEdgeStyleApply() : AcGiEdgeStyle
  • setEdgeStyleFlag() : AcGiEdgeStyle
  • setEdgeStyles() : AcGiEdgeStyle
  • setEdgeTransparency() : AcDbSectionSettings
  • setEdgeWidth() : AcGiEdgeStyle
  • setElem() : AcGiVariant
  • setEndDraftDist() : AcDbSweepOptions
  • setEntity() : CAseLink
  • setEnvironmentImageEnabled() : AcDbRenderEnvironment
  • setEnvironmentImageFileName() : AcDbRenderEnvironment
  • setErr() : CAsiException , CAsiSQLObject
  • setErrMsg() : CAsiException , CAsiSQLObject
  • setErrPosition() : CAsiException
  • setEvaluationStatus() : AcFdFieldResult
  • setExposureType() : AcDbRenderGlobal
  • setExtendedLightLength() : AcGiShadowParameters2
  • setExtendedLightRadius() : AcGiShadowParameters2
  • setExtendedLightShape() : AcGiShadowParameters2
  • setExtendedLightWidth() : AcGiShadowParameters2
  • SetExtensionName() : CNavData
  • setExteriorDaylight() : AcGiToneOperatorParameters
  • setExtrude() : AcDbExtrudedSurface
  • setFaceColorMode() : AcGiFaceStyle
  • setFaceModifierFlag() : AcGiFaceStyle
  • setFaceModifiers() : AcGiFaceStyle
  • setFaceStyle() : AcGiVisualStyle
  • setFaceTransparency() : AcDbSectionSettings
  • setFade() : AcDbUnderlayReference
  • SetFieldCode() : CAcFdUiFieldDialog
  • SetFieldCodeReadOnly() : CAcFdUiFieldDialog
  • SetFieldToEdit() : CAcFdUiFieldDialogHook
  • setFieldValue() : AcFdFieldResult
  • setFillType() : AcGiNonEntityTraits
  • SetFilter() : CAsiCsrTable , CAsiEnumerator
  • SetFilterIndex() : CNavDialog
  • setFitToScreen() : AcDbImageBackground
  • setFogBackgroundEnabled() : AcDbRenderEnvironment
  • setFogColor() : AcDbRenderEnvironment
  • setFogDensity() : AcDbRenderEnvironment
  • setFogEnabled() : AcDbRenderEnvironment
  • SetFolderComboCurSel() : CNavDialog
  • SetFolderListCtrl() : CNavDialog
  • SetFoldersOnly() : CNavDialog
  • SetFont() : CAdUiGroupCtrl
  • SetForceFilterIndex() : CNavDialog
  • SetForceInitialFolder() : CNavDialog
  • SetFormatPreviewLabel() : CAcFdUiFormatDialog
  • SetFormatPreviewReadOnly() : CAcFdUiFormatDialog
  • SetFormatPreviewText() : CAcFdUiFormatDialog
  • SetFormatType() : CAcFdUiFormatDialog , CAcFdUiFormatList
  • setFrameRate() : AcDbMotionPath
  • setFrames() : AcDbMotionPath
  • SetFrom() : CNavFilter , CNavFilterArray
  • SetFullDescription() : CNavFilter
  • setGenerationOptions() : AcDbSectionSettings
  • setGeometry() : AcDbCurvePath , AcDbPointPath
  • setGrainThickness() : AcGiWoodTexture
  • setGreen() : AcCmDialogColor
  • setGridAdaptive() : AcDbViewportTableRecord
  • setGridBoundToLimits() : AcDbViewportTableRecord
  • setGridFollow() : AcDbViewportTableRecord
  • setGridMajor() : AcDbViewportTableRecord
  • setGridSubdivisionRestricted() : AcDbViewportTableRecord
  • setGrowLength() : AcArray< T, R >
  • setGsHighlightModel() : AcDbDatabase
  • setGsNode() : AcDbSun
  • setHaloGap() : AcGiEdgeStyle
  • setHasTarget() : AcDbLight
  • setHatchAngle() : AcDbSectionSettings
  • setHatchPattern() : AcDbSectionSettings
  • setHatchScale() : AcDbSectionSettings
  • setHatchSpacing() : AcDbSectionSettings
  • setHatchVisibility() : AcDbSectionSettings
  • setHeight() : AcDbGradientBackground , AcDbExtrudedSurface , AcDbSection
  • setHiddenLine() : AcDbSectionSettings
  • setHidePrecision() : AcGiEdgeStyle
  • setHighInfoLevel() : AcDbRenderGlobal
  • setHorizon() : AcDbGradientBackground
  • setHorizontalRefTextRotation() : AcDbDimension
  • setHotspotAndFalloff() : AcDbLight
  • setHpInherit() : AcDbDatabase
  • setHpOrigin() : AcDbDatabase
  • SetIcon() : AcPane
  • SetID() : CNavData
  • setIlluminanceDistance() : AcDbLight
  • setImageFilename() : AcDbImageBackground
  • setIndexSaveMode() : CAseAppl
  • setIndicatorFillColor() : AcDbSection
  • setIndicatorTransparency() : AcDbSection
  • SetInitialFileName() : CNavDialog
  • setIntensity() : AcDbLight , AcDbSun
  • setInterfereColor() : AcDbDatabase
  • setInterfereObjVisStyle() : AcDbDatabase
  • setInterfereVpVisStyle() : AcDbDatabase
  • setIntersectionColor() : AcGiEdgeStyle
  • setIntersectionLinetype() : AcGiEdgeStyle
  • setIsActive() : AcGiToneOperatorParameters
  • setIsAdjustedForBackground() : AcDbUnderlayReference
  • setIsCameraPlottable() : AcDbViewTableRecord
  • setIsClipped() : AcDbUnderlayReference
  • setIsMonochrome() : AcDbUnderlayReference
  • setIsolines() : AcGiEdgeStyle
  • setIsOn() : AcDbUnderlayReference
  • setIsPlottable() : AcDbLight
  • setItemName() : AcDbUnderlayDefinition
  • setJitterAmount() : AcGiEdgeStyle
  • setJogPointPP() : AcDbRadialDimensionLarge
  • setKey() : CAseLink , AcDbEvalContextPair
  • setLampColorPreset() : AcDbLight
  • setLampColorRGB() : AcDbLight
  • setLampColorTemp() : AcDbLight
  • setLampColorType() : AcDbLight
  • setLatitude() : AcDbDatabase
  • setLayer() : AcGiNonEntityTraits , AcDbSectionSettings
  • setLensLength() : AcDbDatabase
  • setLightAttenuation() : AcDbLight
  • setLightColor() : AcDbLight
  • setLightDirection() : AcDbLight
  • setLightGlyphDisplay() : AcDbDatabase
  • setLightingModel() : AcGiFaceStyle
  • setLightingQuality() : AcGiFaceStyle
  • setLightingUnits() : AcDbDatabase
  • setLightsInBlocks() : AcDbDatabase
  • setLightType() : AcDbLight
  • setLineType() : AcGiNonEntityTraits
  • setLinetype() : AcDbSectionSettings
  • setLinetypeScale() : AcDbSectionSettings
  • setLineTypeScale() : AcGiNonEntityTraits
  • setLineWeight() : AcGiNonEntityTraits , AcDbSectionSettings
  • setLiveSection() : AcDbViewTableRecord
  • setLoftAng1() : AcDbDatabase
  • setLoftAng2() : AcDbDatabase
  • setLoftMag1() : AcDbDatabase
  • setLoftMag2() : AcDbDatabase
  • setLoftNormals() : AcDbDatabase
  • setLoftOptions() : AcDbLoftedSurface
  • setLoftParam() : AcDbDatabase
  • setLogicalLength() : AcArray< T, R >
  • setLongitude() : AcDbDatabase
  • setMaintainAspectRatio() : AcDbImageBackground
  • setMappers() : AcGiFaceData
  • setMaterial() : AcGiNonEntityTraits , AcDbGroup
  • setMaterials() : AcGiFaceData
  • setMaterialsEnabled() : AcDbRenderSettings
  • setMidTones() : AcGiToneOperatorParameters
  • SetMinimized() : CAdUiGroupCtrl
  • setMiterOption() : AcDbSweepOptions
  • setModuleName() : AcadAppInfo
  • setMonoColor() : AcGiFaceStyle
  • setMsltscale() : AcDbDatabase
  • SetMultiSelectAllowed() : CNavDialog
  • setName() : CAseLinkPath , CAseLink , AcDbAnnotationScale , AcDbLight , AcDbRenderSettings , AcDbSection , AcUnderlayLayer
  • SetNames() : CAsiSession
  • setNames() : AcCmDialogColor
  • SetNoExtraExtensions() : CNavDialog
  • SetNoExtraExtensionsInPlaces() : CNavDialog
  • SetNoFTP() : CNavDialog
  • setNormal() : AcDbLoftOptions , AcDbUnderlayReference
  • setNorthDirection() : AcDbDatabase
  • setNoTwist() : AcDbLoftOptions
  • SetNoURLFileTransfer() : CNavDialog
  • SetNoURLsAllowed() : CNavDialog
  • setNull() : CAsiData
  • setObscuredColor() : AcGiEdgeStyle
  • setObscuredLinetype() : AcGiEdgeStyle
  • SetOkButtonMenuExists() : CNavDialog
  • SetOkButtonText() : CNavDialog
  • setOn() : AcDbSun , AcDbLight
  • setOpacityLevel() : AcGiFaceStyle , AcGiEdgeStyle
  • setOptionsFromSysvars() : AcDbLoftOptions
  • SetOrder() : CAsiCsrTable
  • setOverhangAmount() : AcGiEdgeStyle
  • setOverrideCenterPP() : AcDbRadialDimensionLarge
  • setParametersAt() : AcDbMline
  • SetPassword() : CNavData
  • setPathEntityTransform() : AcDbSweepOptions
  • SetPathname() : CNavData
  • setPenIndex() : AcCmDialogColor
  • SetPersistency() : CAcFdUiFormatList
  • setPhysicalIntensity() : AcDbLight
  • setPhysicalIntensityMethod() : AcDbLight
  • setPhysicalLength() : AcArray< T, R >
  • setPlotStyleName() : AcDbSectionSettings
  • setPointType() : AcDbBreakPointRef
  • setPosition() : AcDbLight , AcDbUnderlayReference
  • setPredefinedPresetsFirst() : AcDbRenderGlobal
  • setPreviewImageFileName() : AcDbRenderSettings
  • SetPreviewVisible() : CAcUiNavDialog
  • setProcedureAndDestination() : AcDbRenderGlobal
  • setProcessBackground() : AcGiToneOperatorParameters
  • setPsolHeight() : AcDbDatabase
  • setPsolWidth() : AcDbDatabase
  • setRadialNoise() : AcGiWoodTexture
  • SetReadOnlyAllowed() : CNavDialog
  • SetReadOnlyHidden() : CNavDialog
  • SetReadOnlySpecified() : CNavDialog
  • setRealWorldScale() : AcDbDatabase
  • setReceiveShadows() : AcDbLight
  • setRed() : AcCmDialogColor
  • setRevolve() : AcDbRevolvedSurface
  • setRevolveAngle() : AcDbRevolvedSurface
  • setRevolveOptions() : AcDbRevolvedSurface
  • setRGB() : AcCmDialogColor
  • SetRootKey() : CAcFdUiFormatList
  • setRotation() : AcDbUnderlayReference , AcDbGradientBackground
  • setRuled() : AcDbLoftOptions
  • setSaveEnabled() : AcDbRenderGlobal
  • setSaveFileName() : AcDbRenderGlobal
  • setScaleFactor() : AcDbSweepOptions
  • setScaleFactors() : AcDbUnderlayReference
  • SetSchema() : CAsiSession
  • setSelectionGeom() : AcGiNonEntityTraits
  • setSelectionMarker() : AcGiNonEntityTraits
  • SetSelIndex() : CAdUiGroupCtrl
  • SetSession() : CAsiStm
  • setShadowMapSize() : AcGiShadowParameters
  • setShadowMapSoftness() : AcGiShadowParameters
  • setShadowParameters() : AcDbLight , AcDbSun , AcDbLight
  • setShadowPlaneLocation() : AcDbDatabase
  • setShadowSamples() : AcGiShadowParameters2
  • setShadowsEnabled() : AcDbRenderSettings
  • setShadowsOn() : AcGiShadowParameters
  • setShadowType() : AcGiDisplayStyle , AcGiShadowParameters
  • setShapeVisibility() : AcGiShadowParameters2
  • setShowHist() : AcDbDatabase
  • setShowRasterRef() : AcDbDgnDefinition
  • setSilhouetteColor() : AcGiEdgeStyle
  • setSilhouetteWidth() : AcGiEdgeStyle
  • setSimplify() : AcDbLoftOptions
  • setSkipReconciled() : AcDbLayerTableIterator
  • setSkyParameters() : AcDbSun
  • setSolidHist() : AcDbDatabase
  • setSourceFileName() : AcDbUnderlayDefinition , AcGiImageFileTexture
  • setSourceObjects() : AcDbSectionSettings
  • setSpecularAmount() : AcGiFaceStyle
  • setSQLSTATE() : CAsiException , CAsiSQLObject
  • setStartDraftDist() : AcDbSweepOptions
  • setState() : AcUnderlayLayer , AcDbSection
  • setStepSize() : AcDbDatabase
  • setStepsPerSec() : AcDbDatabase
  • setStoneColor() : AcGiMarbleTexture
  • SetStyleMask() : CAdUiComboBox
  • setSun() : AcDbViewTableRecord , AcDbAbstractViewTableRecord
  • setSunColor() : AcDbSun
  • setSunDirection() : AcDbSun
  • setSunId() : AcDbSkyBackground
  • setSweepEntityTransform() : AcDbSweepOptions
  • setSweepOptions() : AcDbExtrudedSurface , AcDbSweptSurface
  • setSweepVec() : AcDbExtrudedSurface
  • setSysvarsFromOptions() : AcDbLoftOptions
  • SetTagIndex() : CNavFilter
  • setTargetLocation() : AcDbLight
  • setTargetPath() : AcDbMotionPath
  • SetTargetWindowForMessages() : CAdUiDropTarget
  • SetText() : CNavData
  • SetTextInFolder() : CNavData
  • setTextPositionPP() : AcDbRadialDimensionLarge
  • setTextureSampling() : AcDbRenderSettings
  • SetTheme() : CAdUiCoupledGroupCtrl , CAdUiGroupCtrl
  • setThickness() : AcGiNonEntityTraits
  • setTileModeLightSynch() : AcDbDatabase
  • setTimeZone() : AcDbDatabase
  • SetTimeZone() : CAsiSession
  • setTimeZoneAsUtcOffset() : AcDbDatabase
  • setToleranceLocation() : AcDbMLeader
  • setToneOperatorParameters() : AcDbAbstractViewTableRecord
  • SetToolsMenuItemsPresent() : CNavDialog
  • setTrait() : AcGiVisualStyle
  • setTraitFlag() : AcGiVisualStyle
  • SetTrans() : CAsiSession
  • setTransform() : AcDbUnderlayReference
  • setTrueColor() : AcGiNonEntityTraits
  • setTwistAngle() : AcDbRevolveOptions , AcDbSweepOptions
  • setTwistRefVec() : AcDbSweepOptions
  • setType() : AcGiVisualStyle
  • setUIsolineDensity() : AcDbSurface
  • setUnderlayItem() : AcDbUnderlayDefinition
  • setUnderlayLayer() : AcDbUnderlayReference
  • setupForEntity() : AcGiNonEntityTraits
  • setUseMasterUnits() : AcDbDgnDefinition
  • SetUserData() : CNavData
  • SetUseRegExtensionFlags() : CNavDialog
  • SetUserName() : CNavData
  • setUseTiling() : AcDbImageBackground
  • setValue() : AcDbEvalContextPair
  • setVeinColor() : AcGiMarbleTexture
  • setVeinSpacing() : AcGiMarbleTexture
  • setVeinWidth() : AcGiMarbleTexture
  • setVertex() : AcDbSection , AcDbMLeader
  • setVerticalDirection() : AcDbSection
  • setVertices() : AcDbSection
  • setView() : AcDbCamera
  • setViewingDirection() : AcDbSection
  • SetViewMode() : CNavDialog
  • setViewTableRecordId() : AcDbMotionPath
  • setVirtualGuide() : AcDbLoftOptions
  • setVisibility() : AcDbSectionSettings
  • setVIsolineDensity() : AcDbSurface
  • setVisualStyle() : AcDbAbstractViewTableRecord
  • setWebFile() : AcDbLight
  • setWebRotation() : AcDbLight
  • setWhiteColor() : AcGiToneOperatorParameters
  • setXclipFrame() : AcDbDatabase
  • setXOffset() : AcDbImageBackground
  • setXrefDepth() : AcDbDgnDefinition
  • setXScale() : AcDbImageBackground
  • setYOffset() : AcDbImageBackground
  • setYScale() : AcDbImageBackground
  • shadePlotId() : AcDbPlotSettings
  • shadowMapSize() : AcGiShadowParameters
  • shadowMapSoftness() : AcGiShadowParameters
  • shadowParameters() : AcDbSun , AcDbLight
  • shadowPlaneLocation() : AcDbDatabase
  • shadowSamples() : AcGiShadowParameters2
  • shadowsEnabled() : AcDbRenderSettings
  • shadowsOn() : AcGiShadowParameters
  • shadowType() : AcGiDisplayStyle , AcGiShadowParameters
  • shapeVisibility() : AcGiShadowParameters2
  • showHist() : AcDbDatabase
  • showRasterRef() : AcDbDgnDefinition
  • ShowWnd() : CAdUiGroupCtrl
  • silhouetteColor() : AcGiEdgeStyle
  • silhouetteWidth() : AcGiEdgeStyle
  • simplify() : AcDbLoftOptions
  • Size() : CAsiUcStr
  • skyParameters() : AcDbSun
  • Sob() : CAsiStm , CAsiCsr
  • SobValues() : CAsiCsr
  • solidHist() : AcDbDatabase
  • sourceFileName() : AcGiImageFileTexture
  • specularAmount() : AcGiFaceStyle
  • Sprintf() : CAsiUcStr
  • SQLLiteral() : CAsiSmallInt , CAsiData
  • SQLObject() : CAsiSQLObject
  • SQLSTATE() : CAsiException , CAsiSQLObject
  • SQLType() : CAsiData , CAsiSmallInt
  • start() : AcDbTableIterator , AcDbEvalContextIterator
  • startDraftDist() : AcDbSweepOptions
  • state() : AcUnderlayLayer , AcDbSection
  • step() : AcDbTableIterator
  • stepSize() : AcDbDatabase
  • stepsPerSec() : AcDbDatabase
  • stlOut() : AcDb3dSolid
  • StmType() : CAsiSQLObject
  • stoneColor() : AcGiMarbleTexture
  • storeValue() : CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt
  • StoreValueFromDBType() : CAsiCsr
  • StripMnemonic() : CAcUiString
  • StripPrecedingCharacters() : CAcUiString
  • Strtod() : CAsiUcStr
  • Strtol() : CAsiUcStr
  • subClose() : AcDbCamera , AcDbLight , AcDbMLeader , AcDbSection
  • subentPtr() : AcDbBreakPointRef , AcDbMLeader
  • subErase() : AcDbCamera , AcDbMLeader
  • subOpen() : AcDbCamera
  • subtract() : CAseLinkSel
  • sunColor() : AcDbSun
  • sunDirection() : AcDbSun
  • sunId() : AcDbSkyBackground , AcDbViewTableRecord
  • Svl() : CAsiCsr
  • swap() : AcArray< T, R >
  • swapBTRIds() : CAseAppl
  • swapEntIds() : CAseAppl


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • targetLocation() : AcDbLight
  • targetPath() : AcDbMotionPath
  • Term() : CAsiAppl
  • term() : CAseAppl
  • tessellate() : AcGiLinetypeEngine
  • textColor() : AcDbMLeaderStyle
  • textureSampling() : AcDbRenderSettings
  • ThemeModified() : CAdUiODButtonThemeModReactor
  • thicken() : AcDbSurface
  • thickness() : AcGiNonEntityTraits
  • tileModeLightSynch() : AcDbDatabase
  • TimePrec() : CAsiData
  • TimeStampPrec() : CAsiData
  • timeZone() : AcDbDatabase
  • to() : AcDbEvalEdgeInfo
  • toLower() : CAsiUcStr
  • toneOperatorParameters() : AcDbAbstractViewTableRecord
  • ToString() : CAsiIdent
  • toUpper() : CAsiUcStr
  • trait() : AcGiVisualStyle
  • traitFlag() : AcGiVisualStyle
  • transform() : AcDbUnderlayReference
  • transformBy() : AcDbLight , AcDbCamera , AcDbSection
  • translateDataSource() : CAseAppl
  • TrimWhiteSpace() : CNavDialog
  • trueColor() : AcGiNonEntityTraits
  • twistAngle() : AcDbRevolveOptions , AcDbSweepOptions
  • twistRefVec() : AcDbSweepOptions
  • type() : AcGiVariant , AcGiVisualStyle
  • Type() : CAsiData , CAsiSmallInt


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UcStr() : CAsiUcStr
  • uIsolineDensity() : AcDbSurface
  • underlayLayerCount() : AcDbUnderlayReference
  • unhighlight() : AcDbCamera , AcDbLight , AcDbMLeader
  • unite() : CAseLinkSel
  • unload() : AcDbUnderlayDefinition
  • unpackFrom() : CAsiObject , CAsiIdent , CAsiSmallInt
  • unpackValueFrom() : CAsiObject , CAsiSmallInt
  • unregisterContextCollection() : AcDbObjectContextManager
  • UnregisterFieldDialogHook() : CAcFdUiFieldManager
  • Update() : CAsiCsr , CAsiCsrTable , CAsiUcStr
  • update() : CAseLink
  • updateAssociativity() : AcDbBreakData
  • updateContentScale() : AcDbMLeader
  • updateDueToMirror() : AcDbOsnapPointRef
  • UpdateFieldCode() : CAcFdUiFieldDialogHook
  • UpdateFileExtension() : CNavDialog
  • updateLeaderLinePosition() : AcDbMLeader
  • updateObject() : AcDbAuditInfo
  • UpdateRow() : CAsiCsr
  • updateSubentPath() : AcDbOsnapPointRef
  • updateSubentPathGuts() : AcDbOsnapPointRef
  • UpdateUIState() : CNavDialog
  • updRow() : CAseLinkPath
  • useMasterUnits() : AcDbDgnDefinition
  • useTiling() : AcDbImageBackground


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • ValidateCtrls() : CAdUiCoupledGroupCtrl
  • value() : AcDbEvalExpr , AcDbEvalContextPair
  • veinColor() : AcGiMarbleTexture
  • veinSpacing() : AcGiMarbleTexture
  • veinWidth() : AcGiMarbleTexture
  • VerifyURLSave() : CNavDialog
  • version() : CAseApiObj
  • Version() : CAsiSQLObject
  • verticalDirection() : AcDbSection
  • view() : AcDbCamera
  • viewingDirection() : AcDbSection
  • viewportDraw() : AcDbMLeader , AcDbCamera , AcDbLight
  • viewTableRecordId() : AcDbMotionPath
  • virtualGuide() : AcDbLoftOptions
  • visibility() : AcDbSectionSettings
  • vIsolineDensity() : AcDbSurface
  • visualStyle() : AcDbAbstractViewTableRecord
  • VolMatch() : CAdUiVolumeDescriptor
  • VolumeValid() : CAdUiVolumeDescriptor


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • wblockClone() : AcDbCamera , AcDbLight
  • webFile() : AcDbLight
  • webRotation() : AcDbLight
  • whiteColor() : AcGiToneOperatorParameters
  • worldDraw() : AcDbLight , AcDbSection , AcDbCamera
  • writeCommandNameToRegistry() : AcadAppInfo
  • writeGroupNameToRegistry() : AcadAppInfo


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • xclipFrame() : AcDbDatabase
  • xOffset() : AcDbImageBackground
  • xrefDepth() : AcDbDgnDefinition
  • xrefReadSubstatus() : AcDbXrefGraphNode
  • xScale() : AcDbImageBackground


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • yOffset() : AcDbImageBackground
  • yScale() : AcDbImageBackground


ZRX API Reference: Class Members

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~AcCmDialogColor() : AcCmDialogColor
  • ~AcDbCamera() : AcDbCamera
  • ~AcDbCurvePath() : AcDbCurvePath
  • ~AcDbDgnDefinition() : AcDbDgnDefinition
  • ~AcDbDwfDefinition() : AcDbDwfDefinition
  • ~AcDbEvalConnectable() : AcDbEvalConnectable
  • ~AcDbEvalContext() : AcDbEvalContext
  • ~AcDbEvalContextIterator() : AcDbEvalContextIterator
  • ~AcDbEvalContextPair() : AcDbEvalContextPair
  • ~AcDbEvalExpr() : AcDbEvalExpr
  • ~AcDbExtrudedSurface() : AcDbExtrudedSurface
  • ~AcDbGradientBackground() : AcDbGradientBackground
  • ~AcDbGroundPlaneBackground() : AcDbGroundPlaneBackground
  • ~AcDbLight() : AcDbLight
  • ~AcDbLoftedSurface() : AcDbLoftedSurface
  • ~AcDbLoftOptions() : AcDbLoftOptions
  • ~AcDbMotionPath() : AcDbMotionPath
  • ~AcDbNamedPath() : AcDbNamedPath
  • ~AcDbPointPath() : AcDbPointPath
  • ~AcDbRasterImageDefFileAccessReactor() : AcDbRasterImageDefFileAccessReactor
  • ~AcDbRasterImageDefTransReactor() : AcDbRasterImageDefTransReactor
  • ~AcDbRenderEnvironment() : AcDbRenderEnvironment
  • ~AcDbRenderGlobal() : AcDbRenderGlobal
  • ~AcDbRenderSettings() : AcDbRenderSettings
  • ~AcDbRevolvedSurface() : AcDbRevolvedSurface
  • ~AcDbRevolveOptions() : AcDbRevolveOptions
  • ~AcDbSection() : AcDbSection
  • ~AcDbSectionSettings() : AcDbSectionSettings
  • ~AcDbSkyBackground() : AcDbSkyBackground
  • ~AcDbSolidBackground() : AcDbSolidBackground
  • ~AcDbSun() : AcDbSun
  • ~AcDbSurface() : AcDbSurface
  • ~AcDbSweepOptions() : AcDbSweepOptions
  • ~AcDbSweptSurface() : AcDbSweptSurface
  • ~AcDbTableIterator() : AcDbTableIterator
  • ~AcDbUnderlayDefinition() : AcDbUnderlayDefinition
  • ~AcDbUnderlayReference() : AcDbUnderlayReference
  • ~AcGiDisplayStyle() : AcGiDisplayStyle
  • ~AcGiEdgeStyle() : AcGiEdgeStyle
  • ~AcGiFaceStyle() : AcGiFaceStyle
  • ~AcGiGenericTexture() : AcGiGenericTexture
  • ~AcGiImageFileTexture() : AcGiImageFileTexture
  • ~AcGiLinetypeEngine() : AcGiLinetypeEngine
  • ~AcGiMarbleTexture() : AcGiMarbleTexture
  • ~AcGiShadowParameters() : AcGiShadowParameters
  • ~AcGiShadowParameters2() : AcGiShadowParameters2
  • ~AcGiToneOperatorParameters() : AcGiToneOperatorParameters
  • ~AcGiVariant() : AcGiVariant
  • ~AcGiVisualStyle() : AcGiVisualStyle
  • ~AcGiWoodTexture() : AcGiWoodTexture
  • ~AcTrayItemAnimationControl() : AcTrayItemAnimationControl
  • ~AcUnderlayLayer() : AcUnderlayLayer
  • ~CAcFdUiFieldDialog() : CAcFdUiFieldDialog
  • ~CAcFdUiFieldDialogHook() : CAcFdUiFieldDialogHook
  • ~CAcFdUiFieldManager() : CAcFdUiFieldManager
  • ~CAcFdUiFieldOptionDialog() : CAcFdUiFieldOptionDialog
  • ~CAcFdUiFormatDialog() : CAcFdUiFormatDialog
  • ~CAcFdUiFormatList() : CAcFdUiFormatList
  • ~CAdUiCoupledGroupCtrl() : CAdUiCoupledGroupCtrl
  • ~CAseApiObj() : CAseApiObj
  • ~CAseAppl() : CAseAppl
  • ~CAseLink() : CAseLink
  • ~CAseLinkPath() : CAseLinkPath
  • ~CAseLinkSel() : CAseLinkSel
  • ~CAsiAppl() : CAsiAppl
  • ~CAsiApproxNum() : CAsiApproxNum
  • ~CAsiCsr() : CAsiCsr
  • ~CAsiCsrInfSchema() : CAsiCsrInfSchema
  • ~CAsiCsrRegTable() : CAsiCsrRegTable
  • ~CAsiCsrTable() : CAsiCsrTable
  • ~CAsiData() : CAsiData
  • ~CAsiEnumerator() : CAsiEnumerator
  • ~CAsiExactNum() : CAsiExactNum
  • ~CAsiException() : CAsiException
  • ~CAsiExceptionHandler() : CAsiExceptionHandler
  • ~CAsiExecStm() : CAsiExecStm
  • ~CAsiIdent() : CAsiIdent
  • ~CAsiNum() : CAsiNum
  • ~CAsiObject() : CAsiObject
  • ~CAsiSession() : CAsiSession
  • ~CAsiSmallInt() : CAsiSmallInt
  • ~CAsiSQLObject() : CAsiSQLObject
  • ~CAsiStm() : CAsiStm
  • ~CAsiTACond() : CAsiTACond
  • ~CAsiUcStr() : CAsiUcStr
  • ~CNavArray() : CNavArray< T >
  • ~CNavData() : CNavData
  • ~CNavDataArray() : CNavDataArray
  • ~CNavDialog() : CNavDialog
  • ~CNavFilter() : CNavFilter
  • ~CNavFilterArray() : CNavFilterArray


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- a -

  • Abort() : CAsiAppl
  • abortAseTransaction() : CAseAppl
  • AcCmDialogColor() : AcCmDialogColor
  • AcDbCamera() : AcDbCamera
  • AcDbCurvePath() : AcDbCurvePath
  • AcDbDgnDefinition() : AcDbDgnDefinition
  • AcDbDwfDefinition() : AcDbDwfDefinition
  • AcDbEvalContext() : AcDbEvalContext
  • AcDbEvalContextIterator() : AcDbEvalContextIterator
  • AcDbEvalContextPair() : AcDbEvalContextPair
  • AcDbEvalEdgeInfo() : AcDbEvalEdgeInfo
  • AcDbEvalExpr() : AcDbEvalExpr
  • AcDbExtrudedSurface() : AcDbExtrudedSurface
  • AcDbGradientBackground() : AcDbGradientBackground
  • AcDbGroundPlaneBackground() : AcDbGroundPlaneBackground
  • AcDbImageBackground() : AcDbImageBackground
  • AcDbLight() : AcDbLight
  • AcDbLoftedSurface() : AcDbLoftedSurface
  • AcDbLoftOptions() : AcDbLoftOptions
  • AcDbMotionPath() : AcDbMotionPath
  • AcDbNamedPath() : AcDbNamedPath
  • AcDbPlaneSurface() : AcDbPlaneSurface
  • AcDbPointPath() : AcDbPointPath
  • AcDbRenderEnvironment() : AcDbRenderEnvironment
  • AcDbRenderGlobal() : AcDbRenderGlobal
  • AcDbRenderSettings() : AcDbRenderSettings
  • AcDbRevolvedSurface() : AcDbRevolvedSurface
  • AcDbRevolveOptions() : AcDbRevolveOptions
  • AcDbSection() : AcDbSection
  • AcDbSectionSettings() : AcDbSectionSettings
  • AcDbSkyBackground() : AcDbSkyBackground
  • AcDbSolidBackground() : AcDbSolidBackground
  • AcDbSun() : AcDbSun
  • AcDbSurface() : AcDbSurface
  • AcDbSweepOptions() : AcDbSweepOptions
  • AcDbSweptSurface() : AcDbSweptSurface
  • AcDbTableIterator() : AcDbTableIterator
  • AcDbUnderlayDefinition() : AcDbUnderlayDefinition
  • AcFdFieldValue() : AcFdFieldValue
  • AcGiDisplayStyle() : AcGiDisplayStyle
  • AcGiEdgeStyle() : AcGiEdgeStyle
  • AcGiFaceStyle() : AcGiFaceStyle
  • AcGiGenericTexture() : AcGiGenericTexture
  • AcGiImageFileTexture() : AcGiImageFileTexture
  • AcGiLinetypeEngine() : AcGiLinetypeEngine
  • AcGiMarbleTexture() : AcGiMarbleTexture
  • AcGiShadowParameters() : AcGiShadowParameters
  • AcGiShadowParameters2() : AcGiShadowParameters2
  • AcGiToneOperatorParameters() : AcGiToneOperatorParameters
  • AcGiVariant() : AcGiVariant
  • AcGiVisualStyle() : AcGiVisualStyle
  • AcGiWoodTexture() : AcGiWoodTexture
  • activate() : AcDbEvalGraph
  • activated() : AcDbEvalExpr
  • AcTrayItemAnimationControl() : AcTrayItemAnimationControl
  • AcUnderlayLayer() : AcUnderlayLayer
  • AddBmpBtnToHeader() : CAdUiGroupCtrl
  • addBreakPointRef() : AcDbBreakData
  • addConnection() : CAsiAppl
  • AddCouple() : CAdUiCoupledGroupCtrl
  • AddCustomMenuItems() : CAdUiDockControlBar
  • AddData() : CNavArray< T >
  • AddDataToHistory() : CNavDialog
  • addEdge() : AcDbEvalGraph
  • addedToGraph() : AcDbEvalExpr
  • addGraph() : AcDbEvalGraph
  • addId() : CAseLinkSel
  • addLight() : AcGiNonEntityTraits
  • addNode() : AcDbEvalGraph
  • addObj() : CAseAppl
  • addRow() : CAseLinkPath
  • addVertex() : AcDbSection
  • AddWnd() : CAdUiGroupCtrl
  • adjacentEdgeAdded() : AcDbEvalExpr
  • adjacentEdgeRemoved() : AcDbEvalExpr
  • adjacentNodeRemoved() : AcDbEvalExpr
  • align() : AcDbSweepOptions
  • alignAngle() : AcDbSweepOptions
  • alignDirection() : AcDbLoftOptions
  • alignSpace() : AcDbMLeaderStyle
  • alignStart() : AcDbSweepOptions
  • Allocate() : CAsiEnumerator , CAsiCsr , CAsiCsrRegTable , CAsiCsrInfSchema
  • allocAttr() : CAseApiObj
  • allocCursor() : CAseLinkPath
  • altitude() : AcDbSun
  • ambientLightColor() : AcDbAbstractViewTableRecord
  • annoAllVisible() : AcDbLayout , AcDbDatabase
  • annotationScale() : AcDbViewTableRecord
  • annotative() : AcDbMLeaderStyle
  • annotativeDwg() : AcDbDatabase
  • appDesc() : AcadAppInfo
  • Append() : CAsiUcStr
  • appImplements() : AcadAppInfo
  • appName() : AcadAppInfo
  • appThrow() : CAseApiObj
  • arcLengthParam() : AcDbLoftOptions
  • arrowSymbolId() : AcDbMLeaderStyle
  • asBoolean() : AcGiVariant
  • asChar() : AcGiVariant
  • asColor() : AcGiVariant
  • asDouble() : AcGiVariant
  • ase_fromAse() : CAseAppl
  • ase_invoke() : CAseAppl
  • ase_toAse() : CAseAppl
  • aseiCallAse() : CAseAppl
  • asEnum() : AcGiVariant
  • asFloat() : AcGiVariant
  • asInt() : AcGiVariant
  • asLong() : AcGiVariant
  • asShort() : AcGiVariant
  • asString() : AcGiVariant
  • asUchar() : AcGiVariant
  • asUint() : AcGiVariant
  • asUlong() : AcGiVariant
  • asUshort() : AcGiVariant
  • Atof() : CAsiUcStr
  • Atoi() : CAsiUcStr
  • Atol() : CAsiUcStr
  • attach() : AcFILE
  • axialNoise() : AcGiWoodTexture
  • azimuth() : AcDbSun


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- b -

  • backFacesEnabled() : AcDbRenderSettings
  • background() : AcDbAbstractViewTableRecord
  • bank() : AcDbSweepOptions
  • basePoint() : AcDbSweepOptions
  • beginAseTransaction() : CAseAppl
  • BeginDownloadFiles() : CNavDialog
  • BeginEditorCommand() : CAcFdUiFieldDialog
  • BeginFieldDialog() : CAcFdUiFieldDialogHook
  • Bind() : CAsiExecStm , CAsiCsr , CAsiStm , CAsiCsr , CAsiStm , CAsiExecStm
  • bitFlags() : AcDbMLeaderStyle
  • blockColor() : AcDbMLeaderStyle
  • blockConnectionType() : AcDbMLeaderStyle
  • blockId() : AcDbMLeaderStyle
  • blockRotation() : AcDbMLeaderStyle
  • blockScale() : AcDbMLeaderStyle
  • blue() : AcCmDialogColor
  • body() : AcDbSurface , AcDbRegion , AcDb3dSolid
  • Body() : CAsiIdent
  • body() : AcDbBody
  • bookName() : AcCmDialogColor
  • breakPoint() : AcDbBreakPointRef
  • breakPoint2() : AcDbBreakPointRef
  • breakSize() : AcDbMLeaderStyle
  • brightness() : AcGiToneOperatorParameters , AcGiDisplayStyle , AcDbAbstractViewTableRecord
  • BrowseCurrentObject() : CNavDialog


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- c -

  • CAcFdUiFieldDialog() : CAcFdUiFieldDialog
  • CAcFdUiFieldDialogHook() : CAcFdUiFieldDialogHook
  • CAcFdUiFieldManager() : CAcFdUiFieldManager
  • CAcFdUiFieldOptionDialog() : CAcFdUiFieldOptionDialog
  • CAcFdUiFormatDialog() : CAcFdUiFormatDialog
  • CAcFdUiFormatList() : CAcFdUiFormatList
  • CAcUiString() : CAcUiString
  • CAcUiStringExp() : CAcUiStringExp
  • CAdUiCoupledGroupCtrl() : CAdUiCoupledGroupCtrl
  • CAdUiODButtonThemeModReactor() : CAdUiODButtonThemeModReactor
  • CalcItemHeight() : CAcUiMRUComboBox
  • camera() : AcDbViewTableRecord
  • cameraDisplay() : AcDbDatabase
  • cameraHeight() : AcDbDatabase
  • cameraPath() : AcDbMotionPath
  • Cancel() : CAsiExecStm , CAsiCsr
  • CancelEditorCommand() : CAcFdUiFieldDialog
  • cannoscale() : AcDbDatabase
  • capture() : AcDbTableTemplate
  • CAseApiObj() : CAseApiObj
  • CAseAppl() : CAseAppl
  • CAseLink() : CAseLink
  • CAseLinkPath() : CAseLinkPath
  • CAseLinkSel() : CAseLinkSel
  • CAsiAppl() : CAsiAppl
  • CAsiCsr() : CAsiCsr
  • CAsiCsrInfSchema() : CAsiCsrInfSchema
  • CAsiCsrRegTable() : CAsiCsrRegTable
  • CAsiCsrTable() : CAsiCsrTable
  • CAsiData() : CAsiData
  • CAsiEnumerator() : CAsiEnumerator
  • CAsiExactNum() : CAsiExactNum
  • CAsiException() : CAsiException
  • CAsiExceptionHandler() : CAsiExceptionHandler
  • CAsiExecStm() : CAsiExecStm
  • CAsiIdent() : CAsiIdent
  • CAsiNum() : CAsiNum
  • CAsiObject() : CAsiObject
  • CAsiSession() : CAsiSession
  • CAsiSmallInt() : CAsiSmallInt
  • CAsiSQLObject() : CAsiSQLObject
  • CAsiStm() : CAsiStm
  • CAsiTACond() : CAsiTACond
  • CAsiUcStr() : CAsiUcStr
  • castShadows() : AcDbLight
  • CharSet() : CAsiIdent
  • checkAdd() : CAsiData , CAsiNum , CAsiExactNum , CAsiSmallInt
  • checkCat() : CAsiData
  • CheckCCondition() : CAsiCsr
  • checkCrossSectionCurves() : AcDbLoftOptions
  • checkDiv() : CAsiData , CAsiNum , CAsiSmallInt
  • checkGuideCurves() : AcDbLoftOptions
  • checkIntersections() : AcDbSweepOptions
  • checkLoftCurves() : AcDbLoftOptions
  • checkMul() : CAsiData , CAsiNum , CAsiSmallInt
  • checkOp() : CAseLinkPath
  • CheckOp() : CAsiSQLObject
  • checkOptions() : AcDbLoftOptions
  • checkPathCurve() : AcDbLoftOptions , AcDbSweepOptions
  • checkRevolveCurve() : AcDbRevolveOptions
  • checkSet() : CAsiData , CAsiSmallInt
  • checkSub() : CAsiData , CAsiNum , CAsiSmallInt
  • checkSweepCurve() : AcDbSweepOptions
  • Chlen() : CAsiUcStr
  • ChlenChk() : CAsiUcStr
  • chromaticAdaptation() : AcGiToneOperatorParameters
  • Clear() : CAsiObject , CAsiIdent , CAsiData , CAsiUcStr
  • clearAseErr() : CAseAppl
  • clipBoundary() : AcDbUnderlayReference
  • clone() : CAseAppl , CAseLinkPath , CAseLink , CAseLinkSel
  • Close() : CAsiCsr , CAsiCsrTable
  • closed() : AcDbLoftOptions
  • closeDwg() : CAseAppl
  • closeToAxis() : AcDbRevolveOptions
  • cmaterial() : AcDbDatabase
  • cmpeqlan() : CAsiExactNum
  • cmpeqlen() : CAsiExactNum
  • cmpeqlenC() : CAsiExactNum
  • cmpgtean() : CAsiExactNum
  • cmpgteen() : CAsiExactNum
  • cmpgteenC() : CAsiExactNum
  • cmpgtran() : CAsiExactNum
  • cmpgtren() : CAsiExactNum
  • cmpgtrenC() : CAsiExactNum
  • cmpltean() : CAsiExactNum
  • cmplteen() : CAsiExactNum
  • cmplteenC() : CAsiExactNum
  • cmpltran() : CAsiExactNum
  • cmpltren() : CAsiExactNum
  • cmpltrenC() : CAsiExactNum
  • cmpName() : CAseLinkPath
  • cmpneqan() : CAsiExactNum
  • cmpneqen() : CAsiExactNum
  • cmpneqenC() : CAsiExactNum
  • CNavArray() : CNavArray< T >
  • CNavData() : CNavData
  • CNavDataArray() : CNavDataArray
  • CNavDialog() : CNavDialog
  • CNavDropSource() : CNavDropSource
  • CNavFilter() : CNavFilter
  • CNavFilterArray() : CNavFilterArray
  • CNavListCtrl() : CNavListCtrl
  • ColDsc() : CAsiStm , CAsiExecStm , CAsiCsr , CAsiCsrTable
  • collectionName() : AcDbAnnotationScale
  • color() : AcGiNonEntityTraits , AcCmDialogColor , AcDbSectionSettings
  • color1() : AcGiWoodTexture
  • color2() : AcGiWoodTexture
  • colorBottom() : AcDbGradientBackground
  • colorDifferentiation() : AcGiToneOperatorParameters
  • colorGroundPlaneFar() : AcDbGroundPlaneBackground
  • colorGroundPlaneNear() : AcDbGroundPlaneBackground
  • colorIndex() : AcCmDialogColor
  • colorMethod() : AcCmDialogColor
  • colorMiddle() : AcDbGradientBackground
  • colorName() : AcCmDialogColor
  • colorNameForDisplay() : AcCmDialogColor
  • colorSkyHorizon() : AcDbGroundPlaneBackground
  • colorSkyZenith() : AcDbGroundPlaneBackground
  • colorSolid() : AcDbSolidBackground
  • colorTop() : AcDbGradientBackground
  • colorUndergroundAzimuth() : AcDbGroundPlaneBackground
  • colorUndergroundHorizon() : AcDbGroundPlaneBackground
  • ColQty() : CAsiExecStm , CAsiStm , CAsiCsr , CAsiCsrTable
  • CombineDataTextWithFolderName() : CNavDialog
  • Commit() : CAsiSession
  • commitAseTransaction() : CAseAppl
  • Comp() : CAsiUcStr
  • Compi() : CAsiUcStr
  • CompleteEditorCommand() : CAcFdUiFieldDialog
  • concat() : AcString
  • CondQty() : CAsiException , CAsiSQLObject
  • configureForType() : AcGiVisualStyle
  • Connect() : CAsiSession
  • connectAse() : CAseAppl , CAseLinkPath
  • connectAseIniString() : CAseLinkPath
  • ConnectIniString() : CAsiSession
  • connectionAllowed() : AcDbEvalConnectable
  • connectTo() : AcDbEvalConnectable
  • constPtr() : AcString
  • contextCollection() : AcDbObjectContextManager
  • contextPair() : AcDbEvalContextIterator
  • contrast() : AcGiToneOperatorParameters , AcDbAbstractViewTableRecord , AcDbUnderlayReference
  • contrastDefault() : AcDbUnderlayReference
  • contrastLowerLimit() : AcDbUnderlayReference
  • contrastUpperLimit() : AcDbUnderlayReference
  • convertToBrepAtSubentPaths() : AcDb3dSolid
  • convertToRegion() : AcDbSurface
  • convertToTextField() : AcDbField
  • copiedIntoGraph() : AcDbEvalExpr
  • Copy() : CAsiUcStr
  • copyBuf() : CAseApiObj
  • copyFrom() : AcDbGradientBackground , CAseLinkPath , AcGiGenericTexture , AcDbRenderSettings , CAseApiObj , AcGiVariant , AcGiMarbleTexture , AcDbSkyBackground , CAseLink , AcDbGroundPlaneBackground , AcDbLight , CAseLinkSel , AcDbSolidBackground , AcGiWoodTexture , AcDbRenderGlobal , AcDbImageBackground , CAseAppl , AcGiImageFileTexture
  • cornerDecel() : AcDbMotionPath
  • creaseAngle() : AcGiEdgeStyle
  • create() : CAseLinkPath
  • Create() : CAcFdUiFormatDialog , CAcFdUiFieldOptionDialog
  • create() : CAseLinkPath , CAseLink , CAseLinkPath
  • Create() : CAcFdUiFieldOptionDialog
  • createExtrudedSurface() : AcDbExtrudedSurface
  • CreateField() : CAcFdUiFieldDialogHook
  • createFrom() : AcDbSurface
  • createFromRegion() : AcDbPlaneSurface
  • createGraph() : AcDbEvalGraph
  • createIndex() : CAseAppl
  • CreateInstance() : CAcFdUiFieldDialogHook
  • createJog() : AcDbSection
  • createLoftedSurface() : AcDbLoftedSurface
  • createLoops() : AcDbMPolygon
  • createLoopsFromBoundaries() : AcDbMPolygon
  • createRevolvedSurface() : AcDbRevolvedSurface
  • createSweptSurface() : AcDbSweptSurface
  • createTable() : CAseLinkPath , AcDbTableTemplate
  • cshadow() : AcDbDatabase
  • currentSectionType() : AcDbSectionSettings
  • Cvl() : CAsiCsrTable , CAsiStm , CAsiCsr , CAsiCsrTable , CAsiCsr
  • CvlInt() : CAsiStm


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- d -

  • dateTime() : AcDbSun
  • DateTimeType() : CAsiData
  • DBMS() : CAsiSQLObject
  • Deallocate() : CAsiExecStm
  • DeallocCsr() : CAsiCsrTable
  • decomposeForSave() : AcDbLight , AcDbSun
  • deepClone() : AcDbCamera , AcDbLight
  • defaultLightingType() : AcDbAbstractViewTableRecord
  • DeferrConstr() : CAsiSession
  • definition() : AcGiGenericTexture
  • definitionId() : AcDbUnderlayReference
  • delAttrPtr() : CAseApiObj
  • delCursor() : CAseLinkPath
  • Delete() : CAsiCsr
  • deleteAllBreakPointRefs() : AcDbBreakData
  • deleteElem() : AcGiVariant
  • delId() : CAseLinkSel
  • delRow() : CAseLinkPath
  • description() : AcDbRenderSettings
  • DeselectGroupHeader() : CAdUiGroupCtrl
  • destinationBlock() : AcDbSectionSettings
  • destinationFile() : AcDbSectionSettings
  • dgnframe() : AcDbDatabase
  • diagnosticBackgroundEnabled() : AcDbRenderSettings
  • dictionaryKey() : AcDbUnderlayDefinition
  • dimensions() : AcDbRenderGlobal
  • dimfit() : AcDbDimension
  • dimObjId() : AcDbBreakData
  • dimunit() : AcDbDimension
  • Disconnect() : CAsiSession
  • DisconnectAll() : CAsiAppl
  • disconnectAse() : CAseLinkPath
  • disconnectFrom() : AcDbEvalConnectable
  • displayIndex() : AcDbRenderSettings
  • DisplaySearchError() : CNavDialog
  • displaySettings() : AcGiDisplayStyle
  • displayStyle() : AcGiVisualStyle
  • distances() : AcDbRenderEnvironment
  • divisionLines() : AcDbSectionSettings
  • DoChangeErrors() : CAsiCsr
  • DoDataExchange() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog , CAcFdUiFormatDialog , CNavDialog
  • DoModal() : CAcFdUiFieldDialog
  • done() : AcDbEvalContextIterator , AcDbTableIterator
  • draftAngle() : AcDbRevolveOptions , AcDbSweepOptions
  • draftEnd() : AcDbLoftOptions
  • draftEndMag() : AcDbLoftOptions
  • draftStart() : AcDbLoftOptions
  • draftStartMag() : AcDbLoftOptions
  • dragVisStyle() : AcDbDatabase
  • drawable() : AcDbRenderSettings , AcDbRenderEnvironment , AcDbSun
  • drawableType() : AcDbSolidBackground , AcDbGradientBackground , AcDbImageBackground , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbLight , AcDbSun
  • DrawGroupContent() : CAdUiGroupCtrl
  • DrawGroupHeader() : CAdUiGroupCtrl
  • DrawItemImage() : CAcUiMRUComboBox
  • DrawItemImageFromCargo() : CAcUiMRUComboBox
  • dropTable() : CAseLinkPath
  • DrvMessage() : CAsiSQLObject
  • duplicate() : CAsiException , CAsiTACond , CAsiObject , CAsiIdent , CAsiData , CAsiSmallInt
  • dwfframe() : AcDbDatabase
  • dwgInFields() : AcDbTableTemplate , AcDbSection , AcDbCamera , AcDbMotionPath , AcDbSolidBackground , AcDbGradientBackground , AcDbImageBackground , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbBreakData , AcDbBreakPointRef , AcDbExtrudedSurface , AcDbLight , AcDbLoftedSurface , AcDbCurvePath , AcDbPointPath , AcDbPlaneSurface , AcDbRenderSettings , AcDbRenderEnvironment , AcDbRenderGlobal , AcDbRevolvedSurface , AcDbSun , AcDbSurface , AcDbSweptSurface
  • dwgOutFields() : AcDbLoftedSurface , AcDbSun , AcDbSurface , AcDbSweptSurface , AcDbLight , AcDbBreakPointRef , AcDbGradientBackground , AcDbImageBackground , AcDbMotionPath , AcDbCamera , AcDbSolidBackground , AcDbRenderSettings , AcDbTableTemplate , AcDbPlaneSurface , AcDbRenderGlobal , AcDbSection , AcDbExtrudedSurface , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbBreakData , AcDbRevolvedSurface , AcDbCurvePath , AcDbPointPath , AcDbRenderEnvironment
  • dxeVal() : AcDbDatabase
  • dxfInFields() : AcDbImageBackground , AcDbGradientBackground , AcDbSolidBackground , AcDbMotionPath , AcDbSweptSurface , AcDbPointPath , AcDbTableTemplate , AcDbRenderGlobal , AcDbRevolvedSurface , AcDbBreakPointRef , AcDbCurvePath , AcDbRenderSettings , AcDbSection , AcDbPlaneSurface , AcDbLoftedSurface , AcDbBreakData , AcDbExtrudedSurface , AcDbLight , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbCamera , AcDbRenderEnvironment , AcDbSurface , AcDbSun
  • dxfOutFields() : AcDbImageBackground , AcDbBreakPointRef , AcDbRenderEnvironment , AcDbMotionPath , AcDbSurface , AcDbLoftedSurface , AcDbSun , AcDbSweptSurface , AcDbGradientBackground , AcDbRenderGlobal , AcDbSolidBackground , AcDbCurvePath , AcDbBreakData , AcDbLight , AcDbPointPath , AcDbRenderSettings , AcDbPlaneSurface , AcDbGroundPlaneBackground , AcDbRevolvedSurface , AcDbCamera , AcDbExtrudedSurface , AcDbSkyBackground , AcDbTableTemplate , AcDbSection


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- e -

  • edgeColor() : AcGiEdgeStyle
  • edgeModel() : AcGiEdgeStyle
  • edgeModifiers() : AcGiEdgeStyle
  • edgeStyle() : AcGiVisualStyle
  • edgeStyleApply() : AcGiEdgeStyle
  • edgeStyles() : AcGiEdgeStyle
  • edgeTransparency() : AcDbSectionSettings
  • edgeWidth() : AcGiEdgeStyle
  • enableLiveSection() : AcDbSection
  • endDraftDist() : AcDbSweepOptions
  • EndFieldDialog() : CAcFdUiFieldDialogHook
  • entityId() : AcDbCurvePath
  • environmentImageEnabled() : AcDbRenderEnvironment
  • environmentImageFileName() : AcDbRenderEnvironment
  • equals() : AcDbEvalGraph , AcDbEvalExpr
  • erase() : CAseLinkPath , CAseLinkSel
  • erased() : AcDbRasterImageDefReactor
  • eraseFromDb() : AcDbBreakData
  • Err() : CAsiException , CAsiSQLObject
  • errClear() : CAseApiObj
  • errCode() : CAseApiObj
  • errDiagPar() : CAseApiObj
  • errDiagParNameCode() : CAseApiObj
  • errDsc() : CAseApiObj
  • errGet() : CAseApiObj
  • errInitAsi() : CAseApiObj
  • ErrMsg() : CAsiException , CAsiSQLObject
  • errMsg() : CAseApiObj
  • ErrPosition() : CAsiException , CAsiSQLObject
  • errQty() : CAseApiObj
  • evaluate() : AcDbEvalGraph , AcDbEvalExpr , AcDbEvalGraph
  • evaluatorId() : AcFdFieldEvaluator
  • Execute() : CAsiExecStm
  • exposureType() : AcDbRenderGlobal
  • extendedLightLength() : AcGiShadowParameters2
  • extendedLightRadius() : AcGiShadowParameters2
  • extendedLightShape() : AcGiShadowParameters2
  • extendedLightWidth() : AcGiShadowParameters2
  • exteriorDaylight() : AcGiToneOperatorParameters


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- f -

  • faceColorMode() : AcGiFaceStyle
  • faceModifiers() : AcGiFaceStyle
  • faceStyle() : AcGiVisualStyle
  • faceTransparency() : AcDbSectionSettings
  • fade() : AcDbUnderlayReference
  • fadeDefault() : AcDbUnderlayReference
  • fadeLowerLimit() : AcDbUnderlayReference
  • fadeUpperLimit() : AcDbUnderlayReference
  • falloffAngle() : AcDbLight
  • Fetch() : CAsiCsr , CAsiEnumerator
  • FetchAbsolute() : CAsiCsr
  • FetchFirst() : CAsiCsr
  • FetchLast() : CAsiCsr
  • FetchPrior() : CAsiCsr
  • FetchRelative() : CAsiCsr
  • fillType() : AcGiNonEntityTraits
  • Find() : CNavFilter , CNavFilterArray
  • find() : AcArray< T, R > , AcString
  • findEvaluator() : AcFdFieldEvaluatorLoader
  • FindExact() : CNavFilterArray
  • FindFirst() : CAsiUcStr
  • findFrom() : AcArray< T, R >
  • FindInSearchPath() : CNavDialog
  • FindLast() : CAsiUcStr
  • findOneOf() : AcString
  • first() : AcArray< T, R >
  • fitToScreen() : AcDbImageBackground
  • flushCond() : CAsiException , CAsiSQLObject
  • fogBackgroundEnabled() : AcDbRenderEnvironment
  • fogColor() : AcDbRenderEnvironment
  • fogDensity() : AcDbRenderEnvironment
  • fogEnabled() : AcDbRenderEnvironment
  • format() : AcFdFieldEvaluator
  • formatV() : AcString
  • FracSecPrec() : CAsiData
  • frameRate() : AcDbMotionPath
  • frames() : AcDbMotionPath
  • freeSel() : CAseLinkSel
  • freeStr() : CAseApiObj
  • from() : AcDbEvalEdgeInfo


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- g -

  • generateSectionGeometry() : AcDbSection
  • generationOptions() : AcDbSectionSettings
  • get3dDwfPrec() : AcDbDatabase
  • getAcadDsPath() : CAseAppl
  • GetAcceptAnyFileExtension() : CNavDialog
  • getActiveFileName() : AcDbUnderlayDefinition
  • getAdjustedColor() : AcDbUnderlayHost
  • GetAllDialogsData() : CNavDialog
  • getAllNodes() : AcDbEvalGraph
  • GetAnimationControl() : AcTrayItem
  • getAppl() : CAseApiObj
  • getArea() : AcDbSurface
  • getAseErr() : CAseAppl
  • getAseTransactionMode() : CAseAppl
  • getAt() : AcDbEvalContext
  • getAttr() : CAseLink
  • getAttrPtr() : CAseApiObj
  • getAttrType() : CAseApiObj
  • getAxisPnt() : AcDbRevolvedSurface
  • getAxisVec() : AcDbRevolvedSurface
  • getBreakPointId() : AcDbBreakPointRef
  • getBreakPointRef() : AcDbBreakData
  • GetCatalog() : CAsiSession
  • GetCategoryNames() : CAcFdUiFieldDialogHook
  • getCell() : AcDbTableIterator
  • getCellStyles() : AcDbTableStyle
  • getClassID() : AcDbExtrudedSurface , AcDbLight , AcDbLoftedSurface , AcDbPlaneSurface , AcDbRevolvedSurface , AcDbSection , AcDbSectionSettings , AcDbSurface , AcDbSweptSurface , AcDbCamera
  • getClipSpaceToWCSMatrix() : AcDbSpatialFilter
  • getColumn() : AcDbTableIterator
  • GetColValue() : CAsiCsr
  • GetConfirmReplace() : CNavDialog
  • getConnectedNames() : AcDbEvalConnectable
  • getConnectedObjects() : AcDbEvalConnectable
  • getConnectionNames() : AcDbEvalConnectable
  • GetConnectionString() : CAsiSession
  • getConnectionType() : AcDbEvalConnectable
  • getConnectionValue() : AcDbEvalConnectable
  • GetCount() : CNavArray< T > , CNavFilter
  • GetCreatingFile() : CNavDialog
  • getCrossSection() : AcDbLoftedSurface
  • GetCurrentField() : CAcFdUiFieldDialog
  • GetCurrentFileExtension() : CNavDialog
  • GetCurrentFolderForPersistence() : CNavDialog
  • GetCurrentFormat() : CAcFdUiFormatDialog , CAcFdUiFormatList
  • getCurrentRow() : CAsiCsr
  • getCursorRow() : CAseLinkPath
  • getDACols() : CAseLink
  • GetData() : CNavArray< T >
  • GetDataArray() : CNavDialog
  • GetDatabase() : CAcFdUiFieldDialogHook
  • GetDataType() : CNavData
  • GetDefaultBrowserStartURL() : CNavDialog
  • GetDefaultFileExtension() : CNavDialog
  • GetDefaultFilterIndex() : CNavDialog
  • GetDefaultInitialFolder() : CNavDialog
  • GetDescription() : CNavFilter
  • getDiagData() : CAsiException
  • getDiagPar() : CAsiException , CAsiSQLObject
  • GetDialogCaption() : CNavDialog
  • GetDownloadActionCodes() : CNavDialog
  • getDwg() : CAseLinkPath , CAseLink , CAseLinkSel
  • getEdgeInfo() : AcDbEvalGraph
  • getElem() : AcGiVariant
  • getElemAt() : AcGiVariant
  • getElemCount() : AcGiVariant
  • getEntity() : CAseLink
  • getEntSel() : CAseLinkSel
  • getEvaluator() : AcFdFieldEvaluatorLoader
  • GetEvaluatorIds() : CAcFdUiFieldDialogHook
  • GetExtensionName() : CNavData
  • GetFieldCode() : CAcFdUiFieldDialog
  • GetFieldCodeEditCtrl() : CAcFdUiFieldDialog
  • GetFieldDialog() : CAcFdUiFieldOptionDialog
  • GetFieldDialogHook() : CAcFdUiFieldOptionDialog
  • GetFieldNames() : CAcFdUiFieldDialogHook
  • GetFieldToEdit() : CAcFdUiFieldDialog
  • GetFilterArray() : CNavDialog
  • GetFilterIndex() : CNavDialog
  • GetFolderListCtrl() : CNavDialog
  • GetFoldersOnly() : CNavDialog
  • GetForceFilterIndex() : CNavDialog
  • GetForceInitialFolder() : CNavDialog
  • GetFormatList() : CAcFdUiFormatDialog
  • GetFormatType() : CAcFdUiFormatDialog , CAcFdUiFormatList
  • GetFullDescription() : CNavFilter
  • getFuncDsc() : CAsiData
  • getGeometry() : AcDbNamedPath , AcDbCurvePath , AcDbPointPath
  • getGeomExtents() : AcDbLight , AcDbMline , AcDbProxyEntity , AcDbSection
  • getGraph() : AcDbEvalGraph , AcDbEvalExpr
  • getGripEntityUCS() : AcDbExtrudedSurface , AcDbLoftedSurface , AcDbRevolvedSurface , AcDbSweptSurface
  • getGripPoints() : AcDbLight , AcDbLoftedSurface , AcDbPlaneSurface , AcDbRevolvedSurface , AcDbSection , AcDbSweptSurface , AcDbCamera , AcDbExtrudedSurface
  • getGuideCurve() : AcDbLoftedSurface
  • getHatchPattern() : AcDbSectionSettings
  • getHeight() : AcDbExtrudedSurface
  • getId() : CAseLink , CAseLinkSel
  • GetID() : CNavData
  • getIdArray() : CAseLinkSel
  • GetIDD() : CNavDialog
  • GetImpObject() : CNavDialog
  • getIncomingEdges() : AcDbEvalGraph
  • GetInitialFileName() : CNavDialog
  • GetInitialFilterIndex() : CNavDialog
  • getIsActive() : AcDbEvalGraph
  • getItemName() : AcDbUnderlayDefinition
  • getKey() : CAseLink
  • getKeyDsc() : CAseLinkPath
  • getLast() : CAseApiObj
  • GetLastCharacter() : CAdUiPathname
  • getLimits() : AcDbLayout
  • getLinkEnt() : CAseLinkSel
  • getLinkKey() : CAseLinkSel
  • getLinkName() : CAseLinkSel
  • getLinkNames() : CAseLinkPath , CAseLinkSel
  • getLoftOptions() : AcDbLoftedSurface
  • GetMultiSelectAllowed() : CNavDialog
  • getName() : AcDbSection , CAseLinkPath , CAseLink , AcDbAnnotationScale , AcDbSection
  • getNameSize() : CAseLinkPath , CAseLink
  • getNode() : AcDbEvalGraph
  • GetNoExtraExtensions() : CNavDialog
  • GetNoExtraExtensionsInPlaces() : CNavDialog
  • GetNoFTP() : CNavDialog
  • GetNonClientSize() : CAdUiPaletteSet
  • GetNoPlacesList() : CNavDialog
  • GetNoURLFileTransfer() : CNavDialog
  • GetNoURLsAllowed() : CNavDialog
  • GetOkButtonText() : CNavDialog
  • GetOptionDialog() : CAcFdUiFieldDialog , CAcFdUiFieldDialogHook
  • getOriginalInverseBlockXform() : AcDbSpatialFilter
  • getOsnapPoints() : AcDbDimension , AcDbLight , AcDbMLeader , AcDbSection , AcDbLight
  • getOutgoingEdges() : AcDbEvalGraph
  • GetPassword() : CNavData
  • getPassword() : AcDbHostApplicationServices
  • getPathCode() : CAseLinkPath
  • getPathEntity() : AcDbLoftedSurface , AcDbSweptSurface
  • getPathEntityTransform() : AcDbSweepOptions
  • getPathLength() : AcDbSweptSurface
  • GetPathname() : CNavData
  • getPaths() : CAseLinkPath
  • GetPersonalFolderPath() : CNavDialog
  • GetPreview() : CAcFdUiFieldDialogHook
  • GetProductName() : CNavDialog
  • getQty() : CAseLinkSel
  • GetReadOnlyAllowed() : CNavDialog
  • GetReadOnlyHidden() : CNavDialog
  • GetReadOnlySpecified() : CNavDialog
  • GetRecentDirectory() : CNavDialog
  • GetRegisteredDialogHooks() : CAcFdUiFieldManager
  • getRevolveAngle() : AcDbRevolvedSurface
  • getRevolveEntity() : AcDbRevolvedSurface
  • getRevolveOptions() : AcDbRevolvedSurface
  • getRow() : AcDbTableIterator , CAseLinkPath
  • getSectionManager() : AcDbDatabase
  • GetSelIndex() : CAdUiGroupCtrl
  • getSettings() : AcDbSection
  • GetSingleDataFullPath() : CNavDialog
  • getSkipHidden() : AcDbLayerTableIterator
  • getSkipReconciled() : AcDbLayerTableIterator
  • getSourceFileName() : AcDbUnderlayDefinition
  • getSourceObjects() : AcDbSectionSettings
  • getStartAngle() : AcDbRevolvedSurface
  • GetStatus() : CAsiCsr , CAsiSession
  • getStatus() : CAseLinkPath
  • GetStatus() : CAsiSQLObject , CAsiExecStm
  • getStretchPoints() : AcDbMLeader , AcDbCamera
  • getSweepEntity() : AcDbSweptSurface , AcDbExtrudedSurface
  • getSweepEntityTransform() : AcDbSweepOptions
  • getSweepOptions() : AcDbExtrudedSurface , AcDbSweptSurface
  • getSweepVec() : AcDbExtrudedSurface
  • getTableDsc() : CAseLinkPath
  • GetTagIndex() : CNavFilter
  • getTemplate() : AcDbTableStyle
  • GetText() : CNavData
  • GetTextInFolder() : CNavData
  • getTimeZoneInfo() : AcDbDatabase
  • getToChar() : CAsiUcStr
  • getToCharChk() : CAsiUcStr
  • GetToolsMenuItemPosition() : CNavDialog
  • GetToolsMenuItemsPresent() : CNavDialog
  • getToUcChar() : CAsiUcStr
  • getTransformedCopy() : AcDbLight
  • getType() : CAseLink
  • getUnderlayItem() : AcDbUnderlayDefinition
  • getUnderlayLayer() : AcDbUnderlayReference
  • getUnreconciledLayers() : AcDbLayerTable
  • GetURL() : CNavData
  • GetUserData() : CNavData
  • GetUseRegExtensionFlags() : CNavDialog
  • GetUserName() : CNavData
  • getValue() : CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt , CAsiData
  • getVertex() : AcDbSection
  • getVertices() : AcDbSection
  • GetViewMode() : CNavDialog
  • getVisualStyleDictionary() : AcDbDatabase
  • getVisualStyleList() : AcDbDatabase
  • getXName() : CAseLink
  • getXNames() : CAseLinkSel
  • GiveFeedback() : CNavDropSource
  • grainThickness() : AcGiWoodTexture
  • graphEvalAbort() : AcDbEvalExpr
  • graphEvalEnd() : AcDbEvalExpr
  • graphEvalStart() : AcDbEvalExpr
  • green() : AcCmDialogColor
  • gridMajor() : AcDbViewportTableRecord
  • growLength() : AcArray< T, R >
  • gsHighlightModel() : AcDbDatabase
  • gsNode() : AcDbSun


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- h -

  • haloGap() : AcGiEdgeStyle
  • hasBookName() : AcCmDialogColor
  • hasColorName() : AcCmDialogColor
  • hasConnectionNamed() : AcDbEvalConnectable
  • hasGraph() : AcDbEvalGraph
  • hasTarget() : AcDbLight
  • hasUnreconciledLayers() : AcDbLayerTable
  • hatchAngle() : AcDbSectionSettings
  • hatchScale() : AcDbSectionSettings
  • hatchSpacing() : AcDbSectionSettings
  • hatchVisibility() : AcDbSectionSettings
  • height() : AcDbGradientBackground , AcDbSection
  • hiddenLine() : AcDbSectionSettings
  • hidePrecision() : AcGiEdgeStyle
  • highInfoLevel() : AcDbRenderGlobal
  • highlight() : AcDbLight , AcDbCamera
  • hitTest() : AcDbSection
  • horizon() : AcDbGradientBackground
  • hotspotAngle() : AcDbLight
  • hpInherit() : AcDbDatabase
  • hpOrigin() : AcDbDatabase


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- i -

  • illuminanceDistance() : AcDbLight
  • imageFilename() : AcDbImageBackground
  • ImmConstr() : CAsiSession
  • ImmediateExecute() : CAsiExecStm
  • imp() : AcDbNamedPath
  • ImplDataType() : CAsiData
  • indicatorFillColor() : AcDbSection
  • indicatorTransparency() : AcDbSection
  • InheritStatusInfo() : CAsiSQLObject
  • init() : CAseApiObj , CAseAppl , CAseLinkPath , CAseLink , CAseLinkSel
  • Init() : CAsiAppl
  • InitAccessor() : CAsiCsr
  • InitColsDsc() : CAsiStm
  • initCurrent() : CAseLinkPath
  • initDA() : CAseLink
  • initEnt() : CAseLink , CAseLinkSel
  • InitErrorInfo() : CAsiSQLObject
  • initFilter() : CAseLinkSel
  • initialize() : AcDbLayout
  • initId() : CAseLink
  • initLp() : CAseLinkSel
  • initLpCond() : CAseLinkSel
  • initLpEnt() : CAseLinkSel
  • initLpKey() : CAseLinkSel
  • initLpSel() : CAseLinkSel
  • initName() : CAseLinkPath
  • InitOutputBind() : CAsiCsr
  • initPartialKey() : CAseLinkSel
  • initPath() : CAseLinkPath
  • initSel() : CAseLinkSel
  • initType() : CAseLink , CAseLinkSel
  • initXName() : CAseLinkSel
  • Insert() : CAsiCsr
  • insertAt() : AcArray< T, R > , AcDbEvalContext
  • InsertRow() : CAsiCsr
  • InsertUserItemInPlaces() : CNavDialog
  • intensity() : AcDbSun , AcDbLight
  • interfereColor() : AcDbDatabase
  • interfereObjVisStyle() : AcDbDatabase
  • interfereVpVisStyle() : AcDbDatabase
  • internalSubentId() : AcDbBody , AcDbRegion , AcDb3dSolid , AcDbSurface
  • internalSubentPtr() : AcDbBody , AcDbRegion , AcDb3dSolid , AcDbSurface
  • intersect() : CAseLinkSel
  • intersectEnt() : CAseLinkSel
  • intersectFilter() : CAseLinkSel
  • intersectionColor() : AcGiEdgeStyle
  • intersectionLinetype() : AcGiEdgeStyle
  • intersectLp() : CAseLinkSel
  • intersectLpCond() : CAseLinkSel
  • intersectLpKey() : CAseLinkSel
  • intersectPartialKey() : CAseLinkSel
  • intersectSel() : CAseLinkSel
  • intersectType() : CAseLinkSel
  • intersectWith() : AcDbBreakPointRef
  • intersectXName() : CAseLinkSel
  • IntervalType() : CAsiData
  • intValue() : CAsiNum , CAsiSmallInt
  • invalidateCachedBodySubentIds() : AcDbBody
  • is_approxnumeric() : CAsiData , CAsiNum , CAsiApproxNum
  • is_binary() : CAsiData
  • is_castable() : CAsiData , CAsiNum
  • is_character() : CAsiData
  • is_comparable() : CAsiData , CAsiNum
  • is_datetime() : CAsiData
  • is_dtinterval() : CAsiData
  • is_exactnumeric() : CAsiData , CAsiNum , CAsiExactNum
  • is_implement() : CAsiData
  • is_insensitive() : CAsiCsr
  • is_insertable() : CAsiCsr
  • is_interval() : CAsiData
  • is_numeric() : CAsiData , CAsiNum
  • is_open() : CAsiCsr
  • is_scrollable() : CAsiCsr
  • is_storable() : CAsiNum , CAsiData
  • is_updatable() : CAsiCsr
  • is_yminterval() : CAsiData
  • isA() : CAseAppl , CAseLinkPath , CAseLink , CAseLinkSel
  • isActivatable() : AcDbEvalExpr
  • isActive() : AcGiToneOperatorParameters
  • isAdjustedForBackground() : AcDbUnderlayReference
  • IsAllowed() : CNavFilter
  • IsAnyCtrlMinimizedOrIconic() : CAdUiCoupledGroupCtrl
  • isByACI() : AcCmDialogColor
  • isByBlock() : AcCmDialogColor
  • isByColor() : AcCmDialogColor
  • isByLayer() : AcCmDialogColor
  • isByPen() : AcCmDialogColor
  • isCameraPlottable() : AcDbViewTableRecord
  • isClipped() : AcDbUnderlayReference
  • isContentSnappable() : AcDbUnderlayReference
  • isDayLightSavingsOn() : AcDbSun
  • isDefaultLightingOn() : AcDbAbstractViewTableRecord
  • isDelimited() : CAsiIdent
  • isDependent() : AcDbLoftedSurface , AcDbRevolvedSurface , AcDbExtrudedSurface , AcDbSweptSurface , AcDbPlaneSurface
  • isDiffChar() : CAseApiObj
  • isDisplaySettingsFlagSet() : AcGiDisplayStyle
  • isDwgLazyOpened() : CAseAppl
  • isDwgOpened() : CAseAppl
  • isEdgeModifierFlagSet() : AcGiEdgeStyle
  • isEdgeStyleFlagSet() : AcGiEdgeStyle
  • isEmpty() : AcArray< T, R >
  • isEqualTo() : CAsiData , CAsiSmallInt
  • isEquivalent() : AcGiVariant
  • IsExtension() : CNavData
  • isFaceModifierFlagSet() : AcGiFaceStyle
  • IsFieldCodeDirty() : CAcFdUiFieldDialog
  • isForeground() : AcCmDialogColor
  • isFramePlottable() : AcDbUnderlayReference
  • isFrameVisible() : AcDbUnderlayReference
  • isGreaterThan() : CAsiData , CAsiSmallInt
  • isGridAdaptive() : AcDbViewportTableRecord
  • isGridBoundToLimits() : AcDbViewportTableRecord
  • isGridFollow() : AcDbViewportTableRecord
  • isGridSubdivisionRestricted() : AcDbViewportTableRecord
  • isHorizontalRefTextRotation() : AcDbDimension
  • isIndexExist() : CAseAppl
  • isIndexUpToDate() : CAseAppl
  • IsIndexValid() : CNavArray< T >
  • isInit() : CAseLinkSel , CAsiSQLObject , CAseLinkPath , CAseAppl , CAseLink , CAseApiObj
  • isInvertible() : AcDbEvalEdgeInfo
  • isLiveSectionEnabled() : AcDbSection
  • isLoaded() : AcDbUnderlayDefinition
  • isMonochrome() : AcDbUnderlayReference
  • isNull() : CAsiData
  • isolines() : AcGiEdgeStyle
  • isOn() : AcDbSun , AcDbUnderlayReference , AcDbLight
  • isPlottable() : AcDbLight
  • IsRemote() : CNavData
  • isResident() : AcDbObjectId
  • IsRowset() : CAsiExecStm , CAsiCsr , CAsiSQLObject
  • isSubgraphOf() : AcDbEvalGraph
  • isSuppressed() : AcDbEvalEdgeInfo
  • isTextField() : AcDbField
  • isUpdatable() : CAseLinkPath , CAseLink , CAseLinkSel


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- j -

  • jitterAmount() : AcGiEdgeStyle


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- k -

  • key() : AcDbEvalContextPair


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- l -

  • lampColorPreset() : AcDbLight
  • lampColorRGB() : AcDbLight
  • lampColorTemp() : AcDbLight
  • lampColorType() : AcDbLight
  • last() : AcArray< T, R >
  • latitude() : AcDbDatabase
  • LaunchBrowserDialog() : CNavDialog
  • layer() : AcDbSectionSettings
  • layerId() : AcGiNonEntityTraits
  • LeadFieldPrec() : CAsiData
  • length() : AcArray< T, R >
  • Length() : CAsiIdent , CAsiData , CAsiUcStr
  • lensLength() : AcDbDatabase
  • lightAttenuation() : AcDbLight
  • lightColor() : AcDbLight
  • lightDirection() : AcDbLight
  • lightGlyphDisplay() : AcDbDatabase
  • lightingModel() : AcGiFaceStyle
  • lightingQuality() : AcGiFaceStyle
  • lightingUnits() : AcDbDatabase
  • lightsInBlocks() : AcDbDatabase
  • lightType() : AcDbLight
  • lineIndex() : AcDbBreakPointRef
  • linetype() : AcDbSectionSettings
  • lineTypeId() : AcGiNonEntityTraits
  • linetypeScale() : AcDbSectionSettings
  • lineTypeScale() : AcGiNonEntityTraits
  • lineWeight() : AcDbSectionSettings , AcGiNonEntityTraits
  • list() : AcDbCamera , AcDbExtrudedSurface , AcDbSection , AcDbLoftedSurface , AcDbRevolvedSurface , AcDbPlaneSurface , AcDbSurface , AcDbLight , AcDbSweptSurface
  • liveSection() : AcDbViewTableRecord
  • load() : AcDbUnderlayDefinition
  • loadLinks() : CAseAppl
  • LocateFile() : CNavDialog
  • loftAng1() : AcDbDatabase
  • loftAng2() : AcDbDatabase
  • loftMag1() : AcDbDatabase
  • loftMag2() : AcDbDatabase
  • loftNormals() : AcDbDatabase
  • loftParam() : AcDbDatabase
  • logicalLength() : AcArray< T, R >
  • longitude() : AcDbDatabase


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- m -

  • maintainAspectRatio() : AcDbImageBackground
  • MakeCharUpper() : CAcUiString
  • MakeCursorProp() : CAsiCsr
  • makeFilter() : CAseLinkSel
  • MapAsiToColumnInfo() : CAsiData , CAsiSmallInt
  • MapAsiToParamInfo() : CAsiSmallInt , CAsiData
  • MapColumnInfoToAsi() : CAsiData
  • mapErrFromAse() : CAseAppl
  • MapParamInfoToAsi() : CAsiData
  • mappers() : AcGiFaceData
  • materialId() : AcGiNonEntityTraits
  • materials() : AcGiFaceData
  • materialsEnabled() : AcDbRenderSettings
  • membId() : CAseLinkSel
  • midTones() : AcGiToneOperatorParameters
  • MinMaxOneChild() : CAdUiCoupledGroupCtrl
  • miterOption() : AcDbSweepOptions
  • ModGroupStyle() : CAdUiGroupCtrl
  • modified() : AcDbRasterImageDefReactor
  • modifiedGraphics() : AcDbBreakData
  • moduleName() : AcadAppInfo
  • monoColor() : AcGiFaceStyle
  • movedFromGraph() : AcDbEvalExpr
  • movedIntoGraph() : AcDbEvalExpr
  • moveGripPointsAt() : AcDbPlaneSurface , AcDbRevolvedSurface , AcDbSection , AcDbLoftedSurface , AcDbLight , AcDbExtrudedSurface , AcDbSweptSurface , AcDbCamera
  • moveStretchPointsAt() : AcDbLoftedSurface , AcDbRevolvedSurface , AcDbCamera , AcDbSweptSurface , AcDbPlaneSurface , AcDbExtrudedSurface
  • msltscale() : AcDbDatabase
  • MultibyteLen() : CAsiUcStr


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- n -

  • Name() : CAsiSession
  • name() : AcDbLight , AcUnderlayLayer , AcDbRenderSettings
  • NavigateToFolder() : CNavDialog
  • NewData() : CNavArray< T >
  • newIterator() : AcDbEvalContext
  • next() : AcDbEvalContextIterator
  • nextAttr() : CAseApiObj
  • nodeId() : AcDbEvalExpr
  • normal() : AcDbLoftOptions , AcDbSection , AcDbUnderlayReference
  • northDirection() : AcDbDatabase
  • noTwist() : AcDbLoftOptions
  • number() : AcDbViewportTableRecord
  • numCrossSections() : AcDbLoftedSurface
  • numGuideCurves() : AcDbLoftedSurface
  • numVertices() : AcDbSection


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- o -

  • obscuredColor() : AcGiEdgeStyle
  • obscuredLinetype() : AcGiEdgeStyle
  • OnAnchor() : CAdUiDockControlBar
  • OnAnchorLeft() : CAdUiDockControlBar
  • OnAnchorRight() : CAdUiDockControlBar
  • OnBeginDrag() : CNavListCtrl
  • OnBeginFormatExDialog() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog
  • OnBnClickedAdditionalFormat() : CAcFdUiFormatDialog
  • OnBnClickedAppendSymbol() : CAcFdUiFormatDialog
  • OnBnClickedFilenameOnly() : CAcFdUiFormatDialog
  • OnBnClickedFormatEx() : CAcFdUiFormatDialog
  • OnBnClickedIncludeExtension() : CAcFdUiFormatDialog
  • OnBnClickedPathAndFilename() : CAcFdUiFormatDialog
  • OnBnClickedPathOnly() : CAcFdUiFormatDialog
  • OnBnClickedPointX() : CAcFdUiFormatDialog
  • OnBnClickedPointY() : CAcFdUiFormatDialog
  • OnBnClickedPointZ() : CAcFdUiFormatDialog
  • OnCancel() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog , CNavDialog
  • OnCbnEditChangeListSeparator() : CAcFdUiFormatDialog
  • OnCbnSelChangeCategoryList() : CAcFdUiFieldDialog
  • OnCbnSelChangeCurrencySymbol() : CAcFdUiFormatDialog
  • OnCbnSelChangeDecimalSeparator() : CAcFdUiFormatDialog
  • OnCbnSelChangeListSeparator() : CAcFdUiFormatDialog
  • OnCbnSelChangePrecision() : CAcFdUiFormatDialog
  • OnChevronClicked() : CAdUiGroupCtrl
  • OnCmdMsg() : CNavDialog
  • OnContextMenu() : CNavDialog
  • OnCtlColor() : CAdUiCoupledGroupCtrl , CAdUiGroupCtrl
  • onDeleteImage() : AcDbRasterImageDefReactor
  • OnDestroy() : CAcFdUiFormatDialog , CNavDialog
  • OnDialogHelp() : CAcFdUiFieldDialog , CNavDialog
  • OnDoFind() : CNavDialog
  • OnDoLocate() : CNavDialog
  • OnEnChangeFieldCode() : CAcFdUiFieldDialog
  • OnEnChangePreview() : CAcFdUiFormatDialog
  • OnEndFormatExDialog() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog
  • OnFieldSelected() : CAcFdUiFieldDialogHook , CAcFdUiFieldOptionDialog
  • OnFileNameChange() : CNavDialog
  • OnFileNameOK() : CNavDialog
  • OnFileNameSelectionChange() : CNavDialog
  • OnFilterChange() : CNavDialog
  • OnFolderChange() : CNavDialog
  • OnFolderItemChange() : CNavDialog
  • OnFormatChanged() : CAcFdUiFieldDialog
  • OnGetPaletteCount() : CAdUiPaletteSet
  • OnGetPaletteName() : CAdUiPaletteSet
  • OnGetTipRect() : CAcUiMRUListBox
  • OnHandleDrag() : CNavListCtrl
  • OnHelpInfo() : CNavDialog
  • OnInitDialog() : CAcFdUiFieldDialog , CNavDialog
  • OnKickIdle() : CNavDialog
  • OnKillActive() : CAcFdUiFieldOptionDialog
  • OnKillFocus() : CAdUiGroupCtrl
  • OnLbnSelChangeFieldNameList() : CAcFdUiFieldDialog
  • OnLbnSelChangeFormatList() : CAcFdUiFormatDialog
  • OnLbnSelChangeNegativeNumberList() : CAcFdUiFormatDialog
  • OnLButtonDown() : CAdUiCoupledGroupCtrl
  • OnLButtonUp() : CAdUiCoupledGroupCtrl
  • OnMouseMove() : CAdUiCoupledGroupCtrl
  • OnNcCalcSize() : CAdUiGroupCtrl
  • OnNcHitTest() : CAdUiGroupCtrl , CAdUiPaletteSet
  • OnNcLButtonDblClk() : CAdUiGroupCtrl
  • OnNcLButtonDown() : CAdUiGroupCtrl
  • OnNcPaint() : CAdUiGroupCtrl
  • OnNotifyControlChange() : CNavDialog
  • OnNotifyGeneric() : CNavDialog
  • OnOK() : CAcFdUiFieldDialog , CAcFdUiFieldOptionDialog , CNavDialog
  • OnPaint() : CAdUiCoupledGroupCtrl , CAdUiGroupCtrl
  • OnSetActive() : CAcFdUiFieldOptionDialog
  • OnSetFocus() : CAdUiGroupCtrl
  • OnSetPaletteActive() : CAdUiPaletteSet
  • OnSize() : CAdUiCoupledGroupCtrl , CAdUiGroupCtrl
  • OnSysColorChange() : CNavDialog
  • OnToolsMenuOptions() : CAcUiNavDialog
  • OnURLDownloadSuccess() : CNavDialog
  • OnUrlOK() : CNavDialog
  • opacityLevel() : AcGiFaceStyle , AcGiEdgeStyle
  • Open() : CAcUiPathname , CAsiCsr , CAsiCsrTable
  • openDwg() : CAseAppl
  • openLazyDwg() : CAseAppl
  • operation() : AcGiVisualStyle
  • operator delete() : CAsiObject
  • operator new() : CAsiObject
  • operator!=() : CAsiApproxNum , AcCmDialogColor , CAsiNum , CAsiExactNum , CAsiApproxNum
  • operator*() : CAsiSmallInt
  • operator*=() : CAsiSmallInt
  • operator+() : CAsiSmallInt
  • operator++() : CAsiSmallInt
  • operator+=() : CAsiSmallInt
  • operator-() : CAsiSmallInt
  • operator--() : CAsiSmallInt
  • operator-=() : CAsiSmallInt
  • operator/() : CAsiSmallInt
  • operator/=() : CAsiSmallInt
  • operator<() : CAsiApproxNum , CAsiNum , CAsiApproxNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiApproxNum
  • operator<=() : CAsiExactNum , CAsiApproxNum , CAsiExactNum , CAsiNum , CAsiExactNum
  • operator=() : CAsiUcStr , AcGiVariant , AcGiImageFileTexture , AcGiGenericTexture , AcGiMarbleTexture , AcGiFaceStyle , AcGiEdgeStyle , AcGiVisualStyle , CAseApiObj , CAseAppl , CAsiUcStr , CAseLink , CAsiIdent , CAsiSmallInt , AcDbRevolveOptions , CAsiSmallInt , CAsiUcStr , CAsiSmallInt , CAseLinkPath , AcCmDialogColor , AcDbLoftOptions , CAsiIdent , CAseLinkSel , AcGiWoodTexture , AcGiDisplayStyle , AcArray< T, R > , AcDbSweepOptions , CAsiUcStr , AcCmDialogColor
  • operator==() : AcDbEvalEdgeInfo , CAsiNum , CAseLinkSel , CAsiApproxNum , CAsiExactNum , CAsiIdent , CAsiNum , CAseLink , CAseLinkPath , AcCmDialogColor , AcDbRenderEnvironment , CAsiApproxNum , AcArray< T, R > , AcGiShadowParameters2 , AcDbRenderSettings , CAsiApproxNum , AcGiVisualStyle , CAseAppl , CAsiExactNum , CAseLinkSel , CAsiNum , CAsiApproxNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiApproxNum , AcGiShadowParameters , CAsiApproxNum , CAsiExactNum , CAsiApproxNum , AcGiMarbleTexture , CAsiExactNum , AcGiDisplayStyle , AcGiToneOperatorParameters , CAsiNum , CAsiExactNum , AcGiGenericTexture , CAseLink , AcGiEdgeStyle , CAsiNum , CAseAppl , CAseLinkPath , AcGiFaceStyle , AcGiImageFileTexture , AcGiWoodTexture , CAsiApproxNum , AcGiVariant , AcCmDialogColor , CAsiNum
  • operator>() : CAsiNum , CAsiApproxNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiApproxNum , CAsiExactNum , CAsiApproxNum , CAsiNum , CAsiApproxNum , CAsiExactNum , CAsiNum , CAsiApproxNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiApproxNum , CAsiExactNum
  • operator>=() : CAsiNum , CAsiExactNum , CAsiNum , CAsiApproxNum , CAsiExactNum , CAsiApproxNum , CAsiNum , CAsiApproxNum , CAsiExactNum , CAsiApproxNum , CAsiExactNum , CAsiApproxNum , CAsiExactNum , CAsiNum , CAsiExactNum , CAsiNum , CAsiApproxNum , CAsiExactNum , CAsiApproxNum , CAsiExactNum , CAsiApproxNum , CAsiNum
  • operator[]() : AcArray< T, R > , CAsiUcStr
  • overhangAmount() : AcGiEdgeStyle


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- p -

  • packSize() : CAsiObject , CAsiIdent , CAsiSmallInt
  • packTo() : CAsiObject , CAsiIdent , CAsiSmallInt
  • packValueSize() : CAsiSmallInt , CAsiObject
  • packValueTo() : CAsiObject , CAsiSmallInt
  • ParamDsc() : CAsiStm , CAsiExecStm , CAsiCsr
  • ParamQty() : CAsiCsr , CAsiStm , CAsiExecStm
  • parseLisp() : CAseApiObj
  • penIndex() : AcCmDialogColor
  • physicalIntensity() : AcDbLight
  • physicalIntensityMethod() : AcDbLight
  • physicalLength() : AcArray< T, R >
  • pInput() : CAsiStm
  • plane() : AcDbSection
  • plotAsRaster() : AcDbPlotSettings
  • plotStyleName() : AcDbSectionSettings
  • plotWireframe() : AcDbPlotSettings
  • pointType() : AcDbBreakPointRef
  • position() : CAsiCsr , AcDbLight , AcDbUnderlayReference
  • postInDatabase() : AcDbEvalExpr , AcDbEvalGraph
  • postToDb() : AcDbBreakData
  • precat() : AcString
  • Precision() : CAsiNum , CAsiData
  • predefinedPresetsFirst() : AcDbRenderGlobal
  • Prepare() : CAsiExecStm
  • PrepareOkMenu() : CNavDialog
  • PrepareToolsMenu() : CNavDialog
  • PrepareViewsMenu() : CNavDialog
  • PreprocessData() : CNavDialog
  • PreTranslateMessage() : CNavDialog , CAdUiGroupCtrl
  • previewImageFileName() : AcDbRenderSettings
  • procedureAndDestination() : AcDbRenderGlobal
  • processBackground() : AcGiToneOperatorParameters
  • propertyType() : AcGiVisualStyle
  • psolHeight() : AcDbDatabase
  • psolWidth() : AcDbDatabase
  • pushCond() : CAsiException , CAsiSQLObject
  • pushErr() : CAsiSQLObject
  • pushHResult() : CAsiSQLObject


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- q -

  • QueryCursorProp() : CAsiCsr


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- r -

  • radialNoise() : AcGiWoodTexture
  • RaiseApplyEvent() : CAdUiTabMainDialog
  • ReadData() : CAsiCsr
  • realValue() : CAsiNum , CAsiSmallInt
  • realWorldScale() : AcDbDatabase
  • receiveShadows() : AcDbLight
  • red() : AcCmDialogColor
  • refCount() : AcDbEvalEdgeInfo
  • Refresh() : CAcFdUiFormatList , CNavDialog
  • registerContextCollection() : AcDbObjectContextManager
  • RegisterFieldDialogHook() : CAcFdUiFieldManager
  • registerObject() : AcDbAuditInfo
  • reInit() : CAseLinkPath
  • ReleaseErrorInfo() : CAsiSQLObject
  • remappedNodeIds() : AcDbEvalExpr
  • remObj() : CAseAppl
  • remove() : AcArray< T, R > , CAseLink
  • removeAll() : AcArray< T, R >
  • RemoveAllData() : CNavArray< T >
  • removeAssociativity() : AcDbBreakData
  • removeAt() : AcArray< T, R > , AcDbEvalContext
  • RemoveBmpBtnFromHeader() : CAdUiGroupCtrl
  • removeConnection() : CAsiAppl
  • removedFromGraph() : AcDbEvalExpr
  • removeEdge() : AcDbEvalGraph
  • RemoveExtensionAlways() : CAdUiPathname
  • removeFirst() : AcArray< T, R >
  • removeGraph() : AcDbEvalGraph
  • removeIndex() : CAseAppl
  • removeLast() : AcArray< T, R >
  • removeNode() : AcDbEvalGraph
  • removeSubArray() : AcArray< T, R >
  • removeVertex() : AcDbSection
  • rename() : CAseLinkPath
  • replaceGraph() : AcDbEvalGraph
  • ReportURLTransferStatus() : CNavDialog
  • reselectSubRegion() : AcDbTable
  • reset() : AcDbSectionSettings
  • ResizeChildren() : CAdUiCoupledGroupCtrl
  • resultingColor() : AcDbLight
  • ReturnLength() : CAsiData , CAsiSmallInt
  • reverse() : AcArray< T, R >
  • Rollback() : CAsiSession
  • rotation() : AcDbUnderlayReference , AcDbGradientBackground
  • RowCount() : CAsiSQLObject
  • ruled() : AcDbLoftOptions


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- s -

  • saveEnabled() : AcDbRenderGlobal
  • saveFileName() : AcDbRenderGlobal
  • Scale() : CAsiNum , CAsiData
  • scaleFactor() : AcDbSweepOptions
  • scaleFactors() : AcDbUnderlayReference
  • seek() : AcDbTableIterator
  • select() : AcDbTable
  • select_next_cell() : AcDbTable
  • SelectField() : CAcFdUiFieldDialog
  • selectionGeom() : AcGiNonEntityTraits
  • set() : AcGiVariant , AcGiFaceStyle , AcGiEdgeStyle , AcGiDisplayStyle , CAsiIdent , AcGiVariant
  • set3dDwfPrec() : AcDbDatabase
  • SetAcceptAnyFileExtension() : CNavDialog
  • SetActive() : CAdUiGroupCtrl
  • setAlign() : AcDbSweepOptions
  • setAlignAngle() : AcDbSweepOptions
  • setAlignDirection() : AcDbLoftOptions
  • setAlignStart() : AcDbSweepOptions
  • setAll() : AcArray< T, R >
  • SetAllDialogsData() : CNavDialog
  • setAltitude() : AcDbSun
  • setAmbientLightColor() : AcDbAbstractViewTableRecord
  • setAnnoAllVisible() : AcDbLayout , AcDbDatabase
  • setAnnotationScale() : AcDbViewTableRecord
  • setAnnotativeDwg() : AcDbDatabase
  • setAppDesc() : AcadAppInfo
  • setAppName() : AcadAppInfo
  • setArcLengthParam() : AcDbLoftOptions
  • setArrowSize() : AcDbMLeaderStyle
  • setAseTransactionMode() : CAseAppl
  • setAt() : AcArray< T, R >
  • setAttr() : CAseLink
  • setAttributes() : AcDbCamera , AcDbSolidBackground , AcDbGradientBackground , AcDbImageBackground , AcDbGroundPlaneBackground , AcDbSkyBackground , AcDbLight , AcDbMotionPath , AcDbCurvePath , AcDbPointPath , AcDbRenderSettings , AcDbRenderEnvironment , AcDbSun
  • setAttrPtr() : CAseApiObj
  • SetAuthor() : CAsiSession
  • setAxialNoise() : AcGiWoodTexture
  • setAxisPnt() : AcDbRevolvedSurface
  • setAxisVec() : AcDbRevolvedSurface
  • setAzimuth() : AcDbSun
  • setBackFacesEnabled() : AcDbRenderSettings
  • setBackground() : AcDbAbstractViewTableRecord
  • setBank() : AcDbSweepOptions
  • setBasePoint() : AcDbSweepOptions
  • setBlue() : AcCmDialogColor
  • setBody() : CAsiIdent , AcDbBody , AcDbRegion , AcDb3dSolid , AcDbSurface
  • setBreakPoint() : AcDbBreakPointRef
  • setBreakPoint2() : AcDbBreakPointRef
  • setBreakPointId() : AcDbBreakPointRef
  • setBrightness() : AcGiToneOperatorParameters , AcGiDisplayStyle , AcDbAbstractViewTableRecord
  • setCamera() : AcDbViewTableRecord
  • setCameraDisplay() : AcDbDatabase
  • setCameraHeight() : AcDbDatabase
  • setCameraPath() : AcDbMotionPath
  • setCannoscale() : AcDbDatabase
  • setCastShadows() : AcDbLight
  • SetCatalog() : CAsiSession
  • setChannelFlags() : AcDbMaterial
  • setCharSet() : CAsiIdent
  • setCheckIntersections() : AcDbSweepOptions
  • setChromaticAdaptation() : AcGiToneOperatorParameters
  • setClipBoundary() : AcDbUnderlayReference
  • setClosed() : AcDbLoftOptions
  • setCloseToAxis() : AcDbRevolveOptions
  • setCmaterial() : AcDbDatabase
  • setColor() : AcGiNonEntityTraits , AcCmDialogColor , AcDbSectionSettings
  • setColor1() : AcGiWoodTexture
  • setColor2() : AcGiWoodTexture
  • setColorBottom() : AcDbGradientBackground
  • setColorDifferentiation() : AcGiToneOperatorParameters
  • setColorGroundPlaneFar() : AcDbGroundPlaneBackground
  • setColorGroundPlaneNear() : AcDbGroundPlaneBackground
  • setColorIndex() : AcCmDialogColor
  • setColorMethod() : AcCmDialogColor
  • setColorMiddle() : AcDbGradientBackground
  • setColorSkyHorizon() : AcDbGroundPlaneBackground
  • setColorSkyZenith() : AcDbGroundPlaneBackground
  • setColorSolid() : AcDbSolidBackground
  • setColorTop() : AcDbGradientBackground
  • setColorUndergroundAzimuth() : AcDbGroundPlaneBackground
  • setColorUndergroundHorizon() : AcDbGroundPlaneBackground
  • SetConfirmReplace() : CNavDialog
  • setConnectionValue() : AcDbEvalConnectable
  • setContrast() : AcGiToneOperatorParameters , AcDbAbstractViewTableRecord , AcDbUnderlayReference
  • setCornerDecel() : AcDbMotionPath
  • setCreaseAngle() : AcGiEdgeStyle
  • SetCreatingFile() : CNavDialog
  • setCshadow() : AcDbDatabase
  • setCurrent() : CAseLinkPath
  • SetCurrentFormat() : CAcFdUiFormatDialog , CAcFdUiFormatList
  • setCurrentSectionType() : AcDbSectionSettings
  • setDACols() : CAseLink
  • setDAParms() : CAseLink
  • SetDataType() : CNavData
  • setDateTime() : AcDbSun
  • setDAValues() : CAseLink
  • setDayLightSavingsOn() : AcDbSun
  • SetDefaultFileExtension() : CNavDialog
  • SetDefaultFilterIndex() : CNavDialog
  • SetDefaultInitialFolder() : CNavDialog
  • setDefaultLightingOn() : AcDbAbstractViewTableRecord
  • setDefaultLightingType() : AcDbAbstractViewTableRecord
  • setDefinition() : AcGiGenericTexture
  • setDefinitionId() : AcDbUnderlayReference
  • setDelimited() : CAsiIdent
  • SetDescription() : CNavFilter
  • setDescription() : AcDbRenderSettings
  • setDestinationBlock() : AcDbSectionSettings
  • setDestinationFile() : AcDbSectionSettings
  • setDgnframe() : AcDbDatabase
  • setDiagnosticBackgroundEnabled() : AcDbRenderSettings
  • setDiagPar() : CAsiException , CAsiSQLObject
  • SetDialogCaption() : CNavDialog
  • SetDialogStyle() : CAcFdUiFormatDialog
  • setDimensions() : AcDbRenderGlobal
  • setDimfit() : AcDbDimension
  • setDimObjId() : AcDbBreakData
  • setDimunit() : AcDbDimension
  • setDisplayIndex() : AcDbRenderSettings
  • setDisplaySettings() : AcGiDisplayStyle
  • setDisplaySettingsFlag() : AcGiDisplayStyle
  • setDisplayStyle() : AcGiVisualStyle
  • setDistances() : AcDbRenderEnvironment
  • setDivisionLines() : AcDbSectionSettings
  • setDraftAngle() : AcDbRevolveOptions , AcDbSweepOptions
  • setDraftEnd() : AcDbLoftOptions
  • setDraftEndMag() : AcDbLoftOptions
  • setDraftStart() : AcDbLoftOptions
  • setDraftStartMag() : AcDbLoftOptions
  • setDragVisStyle() : AcDbDatabase
  • setDwfframe() : AcDbDatabase
  • setDwg() : CAseLinkPath , CAseLink , CAseLinkSel
  • setDxeVal() : AcDbDatabase
  • setEdgeColor() : AcGiEdgeStyle
  • setEdgeModel() : AcGiEdgeStyle
  • setEdgeModifierFlag() : AcGiEdgeStyle
  • setEdgeModifiers() : AcGiEdgeStyle
  • setEdgeStyle() : AcGiVisualStyle
  • setEdgeStyleApply() : AcGiEdgeStyle
  • setEdgeStyleFlag() : AcGiEdgeStyle
  • setEdgeStyles() : AcGiEdgeStyle
  • setEdgeTransparency() : AcDbSectionSettings
  • setEdgeWidth() : AcGiEdgeStyle
  • setElem() : AcGiVariant
  • setEndDraftDist() : AcDbSweepOptions
  • setEntity() : CAseLink
  • setEnvironmentImageEnabled() : AcDbRenderEnvironment
  • setEnvironmentImageFileName() : AcDbRenderEnvironment
  • setErr() : CAsiException , CAsiSQLObject
  • setErrMsg() : CAsiException , CAsiSQLObject
  • setErrPosition() : CAsiException
  • setEvaluationStatus() : AcFdFieldResult
  • setExposureType() : AcDbRenderGlobal
  • setExtendedLightLength() : AcGiShadowParameters2
  • setExtendedLightRadius() : AcGiShadowParameters2
  • setExtendedLightShape() : AcGiShadowParameters2
  • setExtendedLightWidth() : AcGiShadowParameters2
  • SetExtensionName() : CNavData
  • setExteriorDaylight() : AcGiToneOperatorParameters
  • setExtrude() : AcDbExtrudedSurface
  • setFaceColorMode() : AcGiFaceStyle
  • setFaceModifierFlag() : AcGiFaceStyle
  • setFaceModifiers() : AcGiFaceStyle
  • setFaceStyle() : AcGiVisualStyle
  • setFaceTransparency() : AcDbSectionSettings
  • setFade() : AcDbUnderlayReference
  • SetFieldCode() : CAcFdUiFieldDialog
  • SetFieldCodeReadOnly() : CAcFdUiFieldDialog
  • SetFieldToEdit() : CAcFdUiFieldDialogHook
  • setFieldValue() : AcFdFieldResult
  • setFillType() : AcGiNonEntityTraits
  • SetFilter() : CAsiCsrTable , CAsiEnumerator
  • SetFilterIndex() : CNavDialog
  • setFitToScreen() : AcDbImageBackground
  • setFogBackgroundEnabled() : AcDbRenderEnvironment
  • setFogColor() : AcDbRenderEnvironment
  • setFogDensity() : AcDbRenderEnvironment
  • setFogEnabled() : AcDbRenderEnvironment
  • SetFolderComboCurSel() : CNavDialog
  • SetFolderListCtrl() : CNavDialog
  • SetFoldersOnly() : CNavDialog
  • SetFont() : CAdUiGroupCtrl
  • SetForceFilterIndex() : CNavDialog
  • SetForceInitialFolder() : CNavDialog
  • SetFormatPreviewLabel() : CAcFdUiFormatDialog
  • SetFormatPreviewReadOnly() : CAcFdUiFormatDialog
  • SetFormatPreviewText() : CAcFdUiFormatDialog
  • SetFormatType() : CAcFdUiFormatDialog , CAcFdUiFormatList
  • setFrameRate() : AcDbMotionPath
  • setFrames() : AcDbMotionPath
  • SetFrom() : CNavFilter , CNavFilterArray
  • SetFullDescription() : CNavFilter
  • setGenerationOptions() : AcDbSectionSettings
  • setGeometry() : AcDbCurvePath , AcDbPointPath
  • setGrainThickness() : AcGiWoodTexture
  • setGreen() : AcCmDialogColor
  • setGridAdaptive() : AcDbViewportTableRecord
  • setGridBoundToLimits() : AcDbViewportTableRecord
  • setGridFollow() : AcDbViewportTableRecord
  • setGridMajor() : AcDbViewportTableRecord
  • setGridSubdivisionRestricted() : AcDbViewportTableRecord
  • setGrowLength() : AcArray< T, R >
  • setGsHighlightModel() : AcDbDatabase
  • setGsNode() : AcDbSun
  • setHaloGap() : AcGiEdgeStyle
  • setHasTarget() : AcDbLight
  • setHatchAngle() : AcDbSectionSettings
  • setHatchPattern() : AcDbSectionSettings
  • setHatchScale() : AcDbSectionSettings
  • setHatchSpacing() : AcDbSectionSettings
  • setHatchVisibility() : AcDbSectionSettings
  • setHeight() : AcDbGradientBackground , AcDbExtrudedSurface , AcDbSection
  • setHiddenLine() : AcDbSectionSettings
  • setHidePrecision() : AcGiEdgeStyle
  • setHighInfoLevel() : AcDbRenderGlobal
  • setHorizon() : AcDbGradientBackground
  • setHorizontalRefTextRotation() : AcDbDimension
  • setHotspotAndFalloff() : AcDbLight
  • setHpInherit() : AcDbDatabase
  • setHpOrigin() : AcDbDatabase
  • SetIcon() : AcPane
  • SetID() : CNavData
  • setIlluminanceDistance() : AcDbLight
  • setImageFilename() : AcDbImageBackground
  • setIndexSaveMode() : CAseAppl
  • setIndicatorFillColor() : AcDbSection
  • setIndicatorTransparency() : AcDbSection
  • SetInitialFileName() : CNavDialog
  • setIntensity() : AcDbLight , AcDbSun
  • setInterfereColor() : AcDbDatabase
  • setInterfereObjVisStyle() : AcDbDatabase
  • setInterfereVpVisStyle() : AcDbDatabase
  • setIntersectionColor() : AcGiEdgeStyle
  • setIntersectionLinetype() : AcGiEdgeStyle
  • setIsActive() : AcGiToneOperatorParameters
  • setIsAdjustedForBackground() : AcDbUnderlayReference
  • setIsCameraPlottable() : AcDbViewTableRecord
  • setIsClipped() : AcDbUnderlayReference
  • setIsMonochrome() : AcDbUnderlayReference
  • setIsolines() : AcGiEdgeStyle
  • setIsOn() : AcDbUnderlayReference
  • setIsPlottable() : AcDbLight
  • setItemName() : AcDbUnderlayDefinition
  • setJitterAmount() : AcGiEdgeStyle
  • setJogPointPP() : AcDbRadialDimensionLarge
  • setKey() : CAseLink , AcDbEvalContextPair
  • setLampColorPreset() : AcDbLight
  • setLampColorRGB() : AcDbLight
  • setLampColorTemp() : AcDbLight
  • setLampColorType() : AcDbLight
  • setLatitude() : AcDbDatabase
  • setLayer() : AcGiNonEntityTraits , AcDbSectionSettings
  • setLensLength() : AcDbDatabase
  • setLightAttenuation() : AcDbLight
  • setLightColor() : AcDbLight
  • setLightDirection() : AcDbLight
  • setLightGlyphDisplay() : AcDbDatabase
  • setLightingModel() : AcGiFaceStyle
  • setLightingQuality() : AcGiFaceStyle
  • setLightingUnits() : AcDbDatabase
  • setLightsInBlocks() : AcDbDatabase
  • setLightType() : AcDbLight
  • setLineType() : AcGiNonEntityTraits
  • setLinetype() : AcDbSectionSettings
  • setLinetypeScale() : AcDbSectionSettings
  • setLineTypeScale() : AcGiNonEntityTraits
  • setLineWeight() : AcGiNonEntityTraits , AcDbSectionSettings
  • setLiveSection() : AcDbViewTableRecord
  • setLoftAng1() : AcDbDatabase
  • setLoftAng2() : AcDbDatabase
  • setLoftMag1() : AcDbDatabase
  • setLoftMag2() : AcDbDatabase
  • setLoftNormals() : AcDbDatabase
  • setLoftOptions() : AcDbLoftedSurface
  • setLoftParam() : AcDbDatabase
  • setLogicalLength() : AcArray< T, R >
  • setLongitude() : AcDbDatabase
  • setMaintainAspectRatio() : AcDbImageBackground
  • setMappers() : AcGiFaceData
  • setMaterial() : AcGiNonEntityTraits , AcDbGroup
  • setMaterials() : AcGiFaceData
  • setMaterialsEnabled() : AcDbRenderSettings
  • setMidTones() : AcGiToneOperatorParameters
  • SetMinimized() : CAdUiGroupCtrl
  • setMiterOption() : AcDbSweepOptions
  • setModuleName() : AcadAppInfo
  • setMonoColor() : AcGiFaceStyle
  • setMsltscale() : AcDbDatabase
  • SetMultiSelectAllowed() : CNavDialog
  • setName() : CAseLinkPath , CAseLink , AcDbAnnotationScale , AcDbLight , AcDbRenderSettings , AcDbSection , AcUnderlayLayer
  • SetNames() : CAsiSession
  • setNames() : AcCmDialogColor
  • SetNoExtraExtensions() : CNavDialog
  • SetNoExtraExtensionsInPlaces() : CNavDialog
  • SetNoFTP() : CNavDialog
  • setNormal() : AcDbLoftOptions , AcDbUnderlayReference
  • setNorthDirection() : AcDbDatabase
  • setNoTwist() : AcDbLoftOptions
  • SetNoURLFileTransfer() : CNavDialog
  • SetNoURLsAllowed() : CNavDialog
  • setNull() : CAsiData
  • setObscuredColor() : AcGiEdgeStyle
  • setObscuredLinetype() : AcGiEdgeStyle
  • SetOkButtonMenuExists() : CNavDialog
  • SetOkButtonText() : CNavDialog
  • setOn() : AcDbSun , AcDbLight
  • setOpacityLevel() : AcGiFaceStyle , AcGiEdgeStyle
  • setOptionsFromSysvars() : AcDbLoftOptions
  • SetOrder() : CAsiCsrTable
  • setOverhangAmount() : AcGiEdgeStyle
  • setOverrideCenterPP() : AcDbRadialDimensionLarge
  • setParametersAt() : AcDbMline
  • SetPassword() : CNavData
  • setPathEntityTransform() : AcDbSweepOptions
  • SetPathname() : CNavData
  • setPenIndex() : AcCmDialogColor
  • SetPersistency() : CAcFdUiFormatList
  • setPhysicalIntensity() : AcDbLight
  • setPhysicalIntensityMethod() : AcDbLight
  • setPhysicalLength() : AcArray< T, R >
  • setPlotStyleName() : AcDbSectionSettings
  • setPointType() : AcDbBreakPointRef
  • setPosition() : AcDbLight , AcDbUnderlayReference
  • setPredefinedPresetsFirst() : AcDbRenderGlobal
  • setPreviewImageFileName() : AcDbRenderSettings
  • SetPreviewVisible() : CAcUiNavDialog
  • setProcedureAndDestination() : AcDbRenderGlobal
  • setProcessBackground() : AcGiToneOperatorParameters
  • setPsolHeight() : AcDbDatabase
  • setPsolWidth() : AcDbDatabase
  • setRadialNoise() : AcGiWoodTexture
  • SetReadOnlyAllowed() : CNavDialog
  • SetReadOnlyHidden() : CNavDialog
  • SetReadOnlySpecified() : CNavDialog
  • setRealWorldScale() : AcDbDatabase
  • setReceiveShadows() : AcDbLight
  • setRed() : AcCmDialogColor
  • setRevolve() : AcDbRevolvedSurface
  • setRevolveAngle() : AcDbRevolvedSurface
  • setRevolveOptions() : AcDbRevolvedSurface
  • setRGB() : AcCmDialogColor
  • SetRootKey() : CAcFdUiFormatList
  • setRotation() : AcDbUnderlayReference , AcDbGradientBackground
  • setRuled() : AcDbLoftOptions
  • setSaveEnabled() : AcDbRenderGlobal
  • setSaveFileName() : AcDbRenderGlobal
  • setScaleFactor() : AcDbSweepOptions
  • setScaleFactors() : AcDbUnderlayReference
  • SetSchema() : CAsiSession
  • setSelectionGeom() : AcGiNonEntityTraits
  • setSelectionMarker() : AcGiNonEntityTraits
  • SetSelIndex() : CAdUiGroupCtrl
  • SetSession() : CAsiStm
  • setShadowMapSize() : AcGiShadowParameters
  • setShadowMapSoftness() : AcGiShadowParameters
  • setShadowParameters() : AcDbLight , AcDbSun , AcDbLight
  • setShadowPlaneLocation() : AcDbDatabase
  • setShadowSamples() : AcGiShadowParameters2
  • setShadowsEnabled() : AcDbRenderSettings
  • setShadowsOn() : AcGiShadowParameters
  • setShadowType() : AcGiDisplayStyle , AcGiShadowParameters
  • setShapeVisibility() : AcGiShadowParameters2
  • setShowHist() : AcDbDatabase
  • setShowRasterRef() : AcDbDgnDefinition
  • setSilhouetteColor() : AcGiEdgeStyle
  • setSilhouetteWidth() : AcGiEdgeStyle
  • setSimplify() : AcDbLoftOptions
  • setSkipReconciled() : AcDbLayerTableIterator
  • setSkyParameters() : AcDbSun
  • setSolidHist() : AcDbDatabase
  • setSourceFileName() : AcDbUnderlayDefinition , AcGiImageFileTexture
  • setSourceObjects() : AcDbSectionSettings
  • setSpecularAmount() : AcGiFaceStyle
  • setSQLSTATE() : CAsiException , CAsiSQLObject
  • setStartDraftDist() : AcDbSweepOptions
  • setState() : AcUnderlayLayer , AcDbSection
  • setStepSize() : AcDbDatabase
  • setStepsPerSec() : AcDbDatabase
  • setStoneColor() : AcGiMarbleTexture
  • SetStyleMask() : CAdUiComboBox
  • setSun() : AcDbViewTableRecord , AcDbAbstractViewTableRecord
  • setSunColor() : AcDbSun
  • setSunDirection() : AcDbSun
  • setSunId() : AcDbSkyBackground
  • setSweepEntityTransform() : AcDbSweepOptions
  • setSweepOptions() : AcDbExtrudedSurface , AcDbSweptSurface
  • setSweepVec() : AcDbExtrudedSurface
  • setSysvarsFromOptions() : AcDbLoftOptions
  • SetTagIndex() : CNavFilter
  • setTargetLocation() : AcDbLight
  • setTargetPath() : AcDbMotionPath
  • SetTargetWindowForMessages() : CAdUiDropTarget
  • SetText() : CNavData
  • SetTextInFolder() : CNavData
  • setTextPositionPP() : AcDbRadialDimensionLarge
  • setTextureSampling() : AcDbRenderSettings
  • SetTheme() : CAdUiCoupledGroupCtrl , CAdUiGroupCtrl
  • setThickness() : AcGiNonEntityTraits
  • setTileModeLightSynch() : AcDbDatabase
  • setTimeZone() : AcDbDatabase
  • SetTimeZone() : CAsiSession
  • setTimeZoneAsUtcOffset() : AcDbDatabase
  • setToleranceLocation() : AcDbMLeader
  • setToneOperatorParameters() : AcDbAbstractViewTableRecord
  • SetToolsMenuItemsPresent() : CNavDialog
  • setTrait() : AcGiVisualStyle
  • setTraitFlag() : AcGiVisualStyle
  • SetTrans() : CAsiSession
  • setTransform() : AcDbUnderlayReference
  • setTrueColor() : AcGiNonEntityTraits
  • setTwistAngle() : AcDbRevolveOptions , AcDbSweepOptions
  • setTwistRefVec() : AcDbSweepOptions
  • setType() : AcGiVisualStyle
  • setUIsolineDensity() : AcDbSurface
  • setUnderlayItem() : AcDbUnderlayDefinition
  • setUnderlayLayer() : AcDbUnderlayReference
  • setupForEntity() : AcGiNonEntityTraits
  • setUseMasterUnits() : AcDbDgnDefinition
  • SetUserData() : CNavData
  • SetUseRegExtensionFlags() : CNavDialog
  • SetUserName() : CNavData
  • setUseTiling() : AcDbImageBackground
  • setValue() : AcDbEvalContextPair
  • setVeinColor() : AcGiMarbleTexture
  • setVeinSpacing() : AcGiMarbleTexture
  • setVeinWidth() : AcGiMarbleTexture
  • setVertex() : AcDbSection , AcDbMLeader
  • setVerticalDirection() : AcDbSection
  • setVertices() : AcDbSection
  • setView() : AcDbCamera
  • setViewingDirection() : AcDbSection
  • SetViewMode() : CNavDialog
  • setViewTableRecordId() : AcDbMotionPath
  • setVirtualGuide() : AcDbLoftOptions
  • setVisibility() : AcDbSectionSettings
  • setVIsolineDensity() : AcDbSurface
  • setVisualStyle() : AcDbAbstractViewTableRecord
  • setWebFile() : AcDbLight
  • setWebRotation() : AcDbLight
  • setWhiteColor() : AcGiToneOperatorParameters
  • setXclipFrame() : AcDbDatabase
  • setXOffset() : AcDbImageBackground
  • setXrefDepth() : AcDbDgnDefinition
  • setXScale() : AcDbImageBackground
  • setYOffset() : AcDbImageBackground
  • setYScale() : AcDbImageBackground
  • shadePlotId() : AcDbPlotSettings
  • shadowMapSize() : AcGiShadowParameters
  • shadowMapSoftness() : AcGiShadowParameters
  • shadowParameters() : AcDbSun , AcDbLight
  • shadowPlaneLocation() : AcDbDatabase
  • shadowSamples() : AcGiShadowParameters2
  • shadowsEnabled() : AcDbRenderSettings
  • shadowsOn() : AcGiShadowParameters
  • shadowType() : AcGiDisplayStyle , AcGiShadowParameters
  • shapeVisibility() : AcGiShadowParameters2
  • showHist() : AcDbDatabase
  • showRasterRef() : AcDbDgnDefinition
  • ShowWnd() : CAdUiGroupCtrl
  • silhouetteColor() : AcGiEdgeStyle
  • silhouetteWidth() : AcGiEdgeStyle
  • simplify() : AcDbLoftOptions
  • Size() : CAsiUcStr
  • skyParameters() : AcDbSun
  • Sob() : CAsiStm , CAsiCsr
  • SobValues() : CAsiCsr
  • solidHist() : AcDbDatabase
  • sourceFileName() : AcGiImageFileTexture
  • specularAmount() : AcGiFaceStyle
  • Sprintf() : CAsiUcStr
  • SQLLiteral() : CAsiSmallInt , CAsiData
  • SQLObject() : CAsiSQLObject
  • SQLSTATE() : CAsiException , CAsiSQLObject
  • SQLType() : CAsiData , CAsiSmallInt
  • start() : AcDbTableIterator , AcDbEvalContextIterator
  • startDraftDist() : AcDbSweepOptions
  • state() : AcUnderlayLayer , AcDbSection
  • step() : AcDbTableIterator
  • stepSize() : AcDbDatabase
  • stepsPerSec() : AcDbDatabase
  • stlOut() : AcDb3dSolid
  • StmType() : CAsiSQLObject
  • stoneColor() : AcGiMarbleTexture
  • storeValue() : CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt , CAsiData , CAsiSmallInt
  • StoreValueFromDBType() : CAsiCsr
  • StripMnemonic() : CAcUiString
  • StripPrecedingCharacters() : CAcUiString
  • Strtod() : CAsiUcStr
  • Strtol() : CAsiUcStr
  • subClose() : AcDbCamera , AcDbLight , AcDbMLeader , AcDbSection
  • subentPtr() : AcDbBreakPointRef , AcDbMLeader
  • subErase() : AcDbCamera , AcDbMLeader
  • subOpen() : AcDbCamera
  • subtract() : CAseLinkSel
  • sunColor() : AcDbSun
  • sunDirection() : AcDbSun
  • sunId() : AcDbSkyBackground , AcDbViewTableRecord
  • Svl() : CAsiCsr
  • swap() : AcArray< T, R >
  • swapBTRIds() : CAseAppl
  • swapEntIds() : CAseAppl


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- t -

  • targetLocation() : AcDbLight
  • targetPath() : AcDbMotionPath
  • Term() : CAsiAppl
  • term() : CAseAppl
  • tessellate() : AcGiLinetypeEngine
  • textColor() : AcDbMLeaderStyle
  • textureSampling() : AcDbRenderSettings
  • ThemeModified() : CAdUiODButtonThemeModReactor
  • thicken() : AcDbSurface
  • thickness() : AcGiNonEntityTraits
  • tileModeLightSynch() : AcDbDatabase
  • TimePrec() : CAsiData
  • TimeStampPrec() : CAsiData
  • timeZone() : AcDbDatabase
  • to() : AcDbEvalEdgeInfo
  • toLower() : CAsiUcStr
  • toneOperatorParameters() : AcDbAbstractViewTableRecord
  • ToString() : CAsiIdent
  • toUpper() : CAsiUcStr
  • trait() : AcGiVisualStyle
  • traitFlag() : AcGiVisualStyle
  • transform() : AcDbUnderlayReference
  • transformBy() : AcDbLight , AcDbCamera , AcDbSection
  • translateDataSource() : CAseAppl
  • TrimWhiteSpace() : CNavDialog
  • trueColor() : AcGiNonEntityTraits
  • twistAngle() : AcDbRevolveOptions , AcDbSweepOptions
  • twistRefVec() : AcDbSweepOptions
  • type() : AcGiVariant , AcGiVisualStyle
  • Type() : CAsiData , CAsiSmallInt


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- u -

  • UcStr() : CAsiUcStr
  • uIsolineDensity() : AcDbSurface
  • underlayLayerCount() : AcDbUnderlayReference
  • unhighlight() : AcDbCamera , AcDbLight , AcDbMLeader
  • unite() : CAseLinkSel
  • unload() : AcDbUnderlayDefinition
  • unpackFrom() : CAsiObject , CAsiIdent , CAsiSmallInt
  • unpackValueFrom() : CAsiObject , CAsiSmallInt
  • unregisterContextCollection() : AcDbObjectContextManager
  • UnregisterFieldDialogHook() : CAcFdUiFieldManager
  • Update() : CAsiCsr , CAsiCsrTable , CAsiUcStr
  • update() : CAseLink
  • updateAssociativity() : AcDbBreakData
  • updateContentScale() : AcDbMLeader
  • updateDueToMirror() : AcDbOsnapPointRef
  • UpdateFieldCode() : CAcFdUiFieldDialogHook
  • UpdateFileExtension() : CNavDialog
  • updateLeaderLinePosition() : AcDbMLeader
  • updateObject() : AcDbAuditInfo
  • UpdateRow() : CAsiCsr
  • updateSubentPath() : AcDbOsnapPointRef
  • updateSubentPathGuts() : AcDbOsnapPointRef
  • UpdateUIState() : CNavDialog
  • updRow() : CAseLinkPath
  • useMasterUnits() : AcDbDgnDefinition
  • useTiling() : AcDbImageBackground


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- v -

  • ValidateCtrls() : CAdUiCoupledGroupCtrl
  • value() : AcDbEvalExpr , AcDbEvalContextPair
  • veinColor() : AcGiMarbleTexture
  • veinSpacing() : AcGiMarbleTexture
  • veinWidth() : AcGiMarbleTexture
  • VerifyURLSave() : CNavDialog
  • version() : CAseApiObj
  • Version() : CAsiSQLObject
  • verticalDirection() : AcDbSection
  • view() : AcDbCamera
  • viewingDirection() : AcDbSection
  • viewportDraw() : AcDbMLeader , AcDbCamera , AcDbLight
  • viewTableRecordId() : AcDbMotionPath
  • virtualGuide() : AcDbLoftOptions
  • visibility() : AcDbSectionSettings
  • vIsolineDensity() : AcDbSurface
  • visualStyle() : AcDbAbstractViewTableRecord
  • VolMatch() : CAdUiVolumeDescriptor
  • VolumeValid() : CAdUiVolumeDescriptor


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- w -

  • wblockClone() : AcDbCamera , AcDbLight
  • webFile() : AcDbLight
  • webRotation() : AcDbLight
  • whiteColor() : AcGiToneOperatorParameters
  • worldDraw() : AcDbLight , AcDbSection , AcDbCamera
  • writeCommandNameToRegistry() : AcadAppInfo
  • writeGroupNameToRegistry() : AcadAppInfo


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- x -

  • xclipFrame() : AcDbDatabase
  • xOffset() : AcDbImageBackground
  • xrefDepth() : AcDbDgnDefinition
  • xrefReadSubstatus() : AcDbXrefGraphNode
  • xScale() : AcDbImageBackground


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- y -

  • yOffset() : AcDbImageBackground
  • yScale() : AcDbImageBackground


ZRX API Reference: Class Members - Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- ~ -

  • ~AcCmDialogColor() : AcCmDialogColor
  • ~AcDbCamera() : AcDbCamera
  • ~AcDbCurvePath() : AcDbCurvePath
  • ~AcDbDgnDefinition() : AcDbDgnDefinition
  • ~AcDbDwfDefinition() : AcDbDwfDefinition
  • ~AcDbEvalConnectable() : AcDbEvalConnectable
  • ~AcDbEvalContext() : AcDbEvalContext
  • ~AcDbEvalContextIterator() : AcDbEvalContextIterator
  • ~AcDbEvalContextPair() : AcDbEvalContextPair
  • ~AcDbEvalExpr() : AcDbEvalExpr
  • ~AcDbExtrudedSurface() : AcDbExtrudedSurface
  • ~AcDbGradientBackground() : AcDbGradientBackground
  • ~AcDbGroundPlaneBackground() : AcDbGroundPlaneBackground
  • ~AcDbLight() : AcDbLight
  • ~AcDbLoftedSurface() : AcDbLoftedSurface
  • ~AcDbLoftOptions() : AcDbLoftOptions
  • ~AcDbMotionPath() : AcDbMotionPath
  • ~AcDbNamedPath() : AcDbNamedPath
  • ~AcDbPointPath() : AcDbPointPath
  • ~AcDbRasterImageDefFileAccessReactor() : AcDbRasterImageDefFileAccessReactor
  • ~AcDbRasterImageDefTransReactor() : AcDbRasterImageDefTransReactor
  • ~AcDbRenderEnvironment() : AcDbRenderEnvironment
  • ~AcDbRenderGlobal() : AcDbRenderGlobal
  • ~AcDbRenderSettings() : AcDbRenderSettings
  • ~AcDbRevolvedSurface() : AcDbRevolvedSurface
  • ~AcDbRevolveOptions() : AcDbRevolveOptions
  • ~AcDbSection() : AcDbSection
  • ~AcDbSectionSettings() : AcDbSectionSettings
  • ~AcDbSkyBackground() : AcDbSkyBackground
  • ~AcDbSolidBackground() : AcDbSolidBackground
  • ~AcDbSun() : AcDbSun
  • ~AcDbSurface() : AcDbSurface
  • ~AcDbSweepOptions() : AcDbSweepOptions
  • ~AcDbSweptSurface() : AcDbSweptSurface
  • ~AcDbTableIterator() : AcDbTableIterator
  • ~AcDbUnderlayDefinition() : AcDbUnderlayDefinition
  • ~AcDbUnderlayReference() : AcDbUnderlayReference
  • ~AcGiDisplayStyle() : AcGiDisplayStyle
  • ~AcGiEdgeStyle() : AcGiEdgeStyle
  • ~AcGiFaceStyle() : AcGiFaceStyle
  • ~AcGiGenericTexture() : AcGiGenericTexture
  • ~AcGiImageFileTexture() : AcGiImageFileTexture
  • ~AcGiLinetypeEngine() : AcGiLinetypeEngine
  • ~AcGiMarbleTexture() : AcGiMarbleTexture
  • ~AcGiShadowParameters() : AcGiShadowParameters
  • ~AcGiShadowParameters2() : AcGiShadowParameters2
  • ~AcGiToneOperatorParameters() : AcGiToneOperatorParameters
  • ~AcGiVariant() : AcGiVariant
  • ~AcGiVisualStyle() : AcGiVisualStyle
  • ~AcGiWoodTexture() : AcGiWoodTexture
  • ~AcTrayItemAnimationControl() : AcTrayItemAnimationControl
  • ~AcUnderlayLayer() : AcUnderlayLayer
  • ~CAcFdUiFieldDialog() : CAcFdUiFieldDialog
  • ~CAcFdUiFieldDialogHook() : CAcFdUiFieldDialogHook
  • ~CAcFdUiFieldManager() : CAcFdUiFieldManager
  • ~CAcFdUiFieldOptionDialog() : CAcFdUiFieldOptionDialog
  • ~CAcFdUiFormatDialog() : CAcFdUiFormatDialog
  • ~CAcFdUiFormatList() : CAcFdUiFormatList
  • ~CAdUiCoupledGroupCtrl() : CAdUiCoupledGroupCtrl
  • ~CAseApiObj() : CAseApiObj
  • ~CAseAppl() : CAseAppl
  • ~CAseLink() : CAseLink
  • ~CAseLinkPath() : CAseLinkPath
  • ~CAseLinkSel() : CAseLinkSel
  • ~CAsiAppl() : CAsiAppl
  • ~CAsiApproxNum() : CAsiApproxNum
  • ~CAsiCsr() : CAsiCsr
  • ~CAsiCsrInfSchema() : CAsiCsrInfSchema
  • ~CAsiCsrRegTable() : CAsiCsrRegTable
  • ~CAsiCsrTable() : CAsiCsrTable
  • ~CAsiData() : CAsiData
  • ~CAsiEnumerator() : CAsiEnumerator
  • ~CAsiExactNum() : CAsiExactNum
  • ~CAsiException() : CAsiException
  • ~CAsiExceptionHandler() : CAsiExceptionHandler
  • ~CAsiExecStm() : CAsiExecStm
  • ~CAsiIdent() : CAsiIdent
  • ~CAsiNum() : CAsiNum
  • ~CAsiObject() : CAsiObject
  • ~CAsiSession() : CAsiSession
  • ~CAsiSmallInt() : CAsiSmallInt
  • ~CAsiSQLObject() : CAsiSQLObject
  • ~CAsiStm() : CAsiStm
  • ~CAsiTACond() : CAsiTACond
  • ~CAsiUcStr() : CAsiUcStr
  • ~CNavArray() : CNavArray< T >
  • ~CNavData() : CNavData
  • ~CNavDataArray() : CNavDataArray
  • ~CNavDialog() : CNavDialog
  • ~CNavFilter() : CNavFilter
  • ~CNavFilterArray() : CNavFilterArray


ZRX API Reference: Class Members - Related Functions

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Related Functions
  • operator* : CAsiSmallInt
  • operator+ : CAsiSmallInt
  • operator- : CAsiSmallInt
  • operator/ : CAsiSmallInt


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEdSSGetFilter Member List

This is the complete list of members for AcEdSSGetFilter, including all inherited members.

beginDragSequence(const ACHAR *promptString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginEntsel(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetAngle(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetColor(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetCorner(const AcGePoint3d *firstCorner, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetDistance(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetInteger(const int *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetKeyword(const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetOrientation(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetPoint(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetReal(const double *dfault, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetScaleFactor(const AcGePoint3d *pointIn, const ACHAR *promptString, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginGetString(const ACHAR *promptString, int initGetFlags) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginNentsel(const ACHAR *promptString, Adesk::Boolean pickFlag, int initGetFlags, const ACHAR *pKeywords) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
beginSSGet(const ACHAR *pPrompt, int initGetFlags, const ACHAR *pKeywords, const ACHAR *pSSControls, const AcArray< AcGePoint3d > &points, const resbuf *entMask) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endDragSequence(Acad::PromptStatus returnStatus, AcGePoint3d &pickPoint, AcGeVector3d &vec) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endEntsel(Acad::PromptStatus returnStatus, const AcDbObjectId &pickedEntity, const AcGePoint3d &pickedPoint, AcEdSelectionSetService &service) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
endEntsel(Acad::PromptStatus returnStatus, AcDbObjectId &entPicked, AcGePoint3d &pickPoint, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetAngle(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetColor(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetCorner(Acad::PromptStatus returnStatus, AcGePoint3d &secondCorner, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetDistance(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetInteger(Acad::PromptStatus returnStatus, int &retValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetKeyword(Acad::PromptStatus returnStatus, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetOrientation(Acad::PromptStatus returnStatus, double &angle, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetPoint(Acad::PromptStatus returnStatus, const AcGePoint3d &pointOut, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetReal(Acad::PromptStatus returnStatus, double &returnValue, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetScaleFactor(Acad::PromptStatus returnStatus, double &distance, const ACHAR *&pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endGetString(Acad::PromptStatus returnStatus, ACHAR *pString) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endNentsel(Acad::PromptStatus returnStatus, AcDbObjectId entPicked, const AcGePoint3d &pickPoint, const AcGeMatrix3d &xform, const resbuf *referenceStack, const ACHAR *pKeyword) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endQuiescentState() (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
endSSGet(Acad::PromptStatus returnStatus, int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
endSSGet(Acad::PromptStatus returnStatus, const AcArray< AcDbObjectId > &ss) (defined in AcEdInputContextReactor) | AcEdInputContextReactor | inlinevirtual
ssgetAddFailed(int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetAddFilter(int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetRemoveFailed(int ssgetFlags, int ssgetMode, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, resbuf *rbPoints, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual
ssgetRemoveFilter(int ssgetFlags, AcEdSelectionSetService &service, const AcDbObjectIdArray &selectionSet, const AcDbObjectIdArray &subSelectionSet, AcDbIntArray &removeIndexes, AcDbArrayIntArray &removeSubentIndexes) (defined in AcEdSSGetFilter) | AcEdSSGetFilter | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcEditorReactor Member List

This is the complete list of members for AcEditorReactor, including all inherited members.

abortAttach(AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortDeepClone(AcDbIdMapping &) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortDxfIn(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortDxfOut(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortInsert(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortRestore(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortSave(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
abortWblock(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
AcEditorImp (defined in AcEditorReactor) | AcEditorReactor | friend
AcEditorReactor() (defined in AcEditorReactor) | AcEditorReactor | inline
ACRX_DECLARE_MEMBERS(AcEditorReactor) (defined in AcEditorReactor) | AcEditorReactor |
ACRX_DECLARE_MEMBERS(AcRxEventReactor) (defined in AcRxEventReactor) | AcRxEventReactor |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
beginAttach(AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginClose(AcDbDatabase *pDwg) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDeepClone(AcDbDatabase *pTo, AcDbIdMapping &) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDeepCloneXlation(AcDbIdMapping &, Acad::ErrorStatus *) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDoubleClick(const AcGePoint3d &clickPoint) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDwgOpen(ACHAR *filename) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDxfIn(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginDxfOut(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginInsert(AcDbDatabase *pTo, const ACHAR *pBlockName, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginInsert(AcDbDatabase *pTo, const AcGeMatrix3d &xform, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginQuit() (defined in AcEditorReactor) | AcEditorReactor | virtual
beginRestore(AcDbDatabase *pTo, const ACHAR *, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginRightClick(const AcGePoint3d &clickPoint) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginSave(AcDbDatabase *, const ACHAR *pIntendedName) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginWblock(AcDbDatabase *pTo, AcDbDatabase *pFrom, const AcGePoint3d *&insertionPoint) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginWblock(AcDbDatabase *pTo, AcDbDatabase *pFrom, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginWblock(AcDbDatabase *pTo, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
beginWblockObjects(AcDbDatabase *pFrom, AcDbIdMapping &) (defined in AcEditorReactor) | AcEditorReactor | virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
cmdIUnkModified(const ACHAR *strCommand) (defined in AcEditorReactor) | AcEditorReactor | virtual
comandeered(AcDbDatabase *pTo, AcDbObjectId id, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
commandCancelled(const ACHAR *cmdStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
commandEnded(const ACHAR *cmdStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
commandFailed(const ACHAR *cmdStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
commandWillStart(const ACHAR *cmdStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
databaseConstructed(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
databaseToBeDestroyed(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
desc() (defined in AcRxObject) | AcRxObject | static
docFrameMovedOrResized(Adesk::LongPtr hwndDocFrame, bool bMoved) (defined in AcEditorReactor) | AcEditorReactor | virtual
dwgFileOpened(AcDbDatabase *, ACHAR *fileName) (defined in AcEditorReactor) | AcEditorReactor | virtual
dxfInComplete(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
dxfOutComplete(AcDbDatabase *) (defined in AcEditorReactor) | AcEditorReactor | virtual
endAttach(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
endDeepClone(AcDbIdMapping &) (defined in AcEditorReactor) | AcEditorReactor | virtual
endDwgOpen(const ACHAR *filename, AcDbDatabase *pDb) (defined in AcEditorReactor) | AcEditorReactor | virtual
endInsert(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
endRestore(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
endWblock(AcDbDatabase *pTo) (defined in AcEditorReactor) | AcEditorReactor | virtual
initialDwgFileOpenComplete(AcDbDatabase *pDwg) (defined in AcEditorReactor) | AcEditorReactor | virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
layoutSwitched(const ACHAR *newLayoutName) (defined in AcEditorReactor) | AcEditorReactor | virtual
lispCancelled() (defined in AcEditorReactor) | AcEditorReactor | virtual
lispEnded() (defined in AcEditorReactor) | AcEditorReactor | virtual
lispWillStart(const ACHAR *firstLine) (defined in AcEditorReactor) | AcEditorReactor | virtual
mainFrameMovedOrResized(Adesk::LongPtr hwndMainFrame, bool bMoved) (defined in AcEditorReactor) | AcEditorReactor | virtual
modelessOperationEnded(const ACHAR *contextStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
modelessOperationWillStart(const ACHAR *contextStr) (defined in AcEditorReactor) | AcEditorReactor | virtual
objectsLazyLoaded(const AcDbObjectIdArray &idArray) (defined in AcEditorReactor) | AcEditorReactor | virtual
otherAttach(AcDbDatabase *pTo, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
otherInsert(AcDbDatabase *pTo, AcDbIdMapping &idMap, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
otherWblock(AcDbDatabase *pTo, AcDbIdMapping &, AcDbDatabase *pFrom) (defined in AcEditorReactor) | AcEditorReactor | virtual
partialOpenNotice(AcDbDatabase *pDb) (defined in AcEditorReactor) | AcEditorReactor | virtual
pickfirstModified() (defined in AcEditorReactor) | AcEditorReactor | virtual
preXrefLockFile(AcDbObjectId btrId) (defined in AcEditorReactor) | AcEditorReactor | virtual
preXrefLockFile(AcDbDatabase *pDb, AcDbObjectId btrId) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
quitAborted() (defined in AcEditorReactor) | AcEditorReactor | virtual
quitWillStart() (defined in AcEditorReactor) | AcEditorReactor | virtual
redirected(AcDbObjectId newId, AcDbObjectId oldId) (defined in AcEditorReactor) | AcEditorReactor | virtual
saveComplete(AcDbDatabase *, const ACHAR *pActualName) (defined in AcEditorReactor) | AcEditorReactor | virtual
sysVarChanged(const ACHAR *varName, Adesk::Boolean success) (defined in AcEditorReactor) | AcEditorReactor | virtual
sysVarWillChange(const ACHAR *varName) (defined in AcEditorReactor) | AcEditorReactor | virtual
toolbarBitmapSizeChanged(Adesk::Boolean bLarge) (defined in AcEditorReactor) | AcEditorReactor | virtual
toolbarBitmapSizeWillChange(Adesk::Boolean bLarge) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandAuto(int activity, Adesk::Boolean state) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandBack(int activity) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandBegin(int activity) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandControl(int activity, int option) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandEnd(int activity) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandMark(int activity) (defined in AcEditorReactor) | AcEditorReactor | virtual
undoSubcommandNumber(int activity, int num) (defined in AcEditorReactor) | AcEditorReactor | virtual
unknownCommand(const ACHAR *cmdStr, AcDbVoidPtrArray *al) (defined in AcEditorReactor) | AcEditorReactor | virtual
veto() (defined in AcEditorReactor) | AcEditorReactor | protected
viewChanged() (defined in AcEditorReactor) | AcEditorReactor | virtual
wblockNotice(AcDbDatabase *pDb) (defined in AcEditorReactor) | AcEditorReactor | virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
xrefSubCommandAborted(AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
xrefSubcommandAttachItem(AcDbDatabase *pHost, int activity, const ACHAR *pPath) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandBindItem(AcDbDatabase *pHost, int activity, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandDetachItem(AcDbDatabase *pHost, int activity, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandOverlayItem(AcDbDatabase *pHost, int activity, const ACHAR *pPath) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandPathItem(int activity, AcDbObjectId blockId, const ACHAR *pNewPath) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubcommandReloadItem(AcDbDatabase *pHost, int activity, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubCommandStart(AcXrefSubCommand subcmd, const AcDbObjectIdArray &btrIds, const ACHAR *const *btrNames, const ACHAR *const *paths) (defined in AcEditorReactor) | AcEditorReactor | virtual
xrefSubCommandStart(AcDbDatabase *pHostDb, AcXrefSubCommand op, const AcArray< AcDbObjectId > &ids, const ACHAR *const *btrNames, const ACHAR *const *paths, bool &vetoOp) (defined in AcRxEventReactor) | AcRxEventReactor | virtual
xrefSubcommandUnloadItem(AcDbDatabase *pHost, int activity, AcDbObjectId blockId) (defined in AcEditorReactor) | AcEditorReactor | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiContextualColors Member List

This is the complete list of members for AcGiContextualColors, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiContextualColors) (defined in AcGiContextualColors) | AcGiContextualColors |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cameraClipping() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
cameraFrustrum() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
cameraGlyphs() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
flagsSet(Adesk::UInt32 flg) const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridAxisLines() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridAxisLineTintXYZ() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridMajorLines() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridMajorLineTintXYZ() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridMinorLines() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
gridMinorLineTintXYZ() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
lightEndLimit() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
lightFalloff() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
lightGlyphs() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
lightHotspot() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
lightStartLimit() const =0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setContextFlags(Adesk::UInt32 flg, bool set=true)=0 (defined in AcGiContextualColors) | AcGiContextualColors | pure virtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiDistantLightTraits Member List

This is the complete list of members for AcGiDistantLightTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiDistantLightTraits) (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits |
ACRX_DECLARE_MEMBERS(AcGiStandardLightTraits) (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits |
ACRX_DECLARE_MEMBERS(AcGiLightTraits) (defined in AcGiLightTraits) | AcGiLightTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
intensity() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOn() const =0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
isSunlight() const =0 (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits | pure virtual
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightColor() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
lightDirection() const =0 (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setIntensity(double inten)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setIsSunlight(bool isSunlight)=0 (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightColor(const AcCmColor &color)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLightDirection(const AcGeVector3d &vec)=0 (defined in AcGiDistantLightTraits) | AcGiDistantLightTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setOn(bool on)=0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowParameters(const AcGiShadowParameters &params)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowParameters(AcGiShadowParameters &params) const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiMaterialTraits Member List

This is the complete list of members for AcGiMaterialTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiMaterialTraits) (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
ambient(AcGiMaterialColor &color) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
bump(AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
ChannelFlags enum name (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
channelFlags() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
diffuse(AcGiMaterialColor &color, AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
IlluminationModel enum name (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
illuminationModel() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAdvanced enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kBlinnShader enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kMetalShader enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kRealistic enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kUseAll enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseBump enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseDiffuse enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseNormalMap enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseOpacity enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseReflection enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseRefraction enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kUseSpecular enum value (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
mode() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
Mode enum name (defined in AcGiMaterialTraits) | AcGiMaterialTraits |
opacity(double &dPercentage, AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
reflection(AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
reflectivity() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
refraction(double &dIndex, AcGiMaterialMap &map) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
selfIllumination() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setAmbient(const AcGiMaterialColor &color)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setBump(const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setChannelFlags(ChannelFlags flags)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDiffuse(const AcGiMaterialColor &color, const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setIlluminationModel(IlluminationModel model)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setMode(Mode value)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setOpacity(double dPercentage, const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setReflection(const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setReflectivity(double value)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setRefraction(double dIndex, const AcGiMaterialMap &map)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setSelfIllumination(double value)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSpecular(const AcGiMaterialColor &color, const AcGiMaterialMap &map, double dGloss)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTranslucence(double value)=0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
specular(AcGiMaterialColor &color, AcGiMaterialMap &map, double &dGloss) const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
translucence() const =0 (defined in AcGiMaterialTraits) | AcGiMaterialTraits | pure virtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiMentalRayRenderSettingsTraits Member List

This is the complete list of members for AcGiMentalRayRenderSettingsTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiMentalRayRenderSettingsTraits) (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits |
ACRX_DECLARE_MEMBERS(AcGiRenderSettingsTraits) (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
backFacesEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
diagnosticBackgroundEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
diagnosticBSPMode() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
diagnosticGridMode(AcGiMrDiagnosticGridMode &mode, float &fSize) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
diagnosticMode() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
diagnosticPhotonMode() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
energyMultiplier() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
exportMIEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
exportMIFileName() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
fgRayCount() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
fgSampleRadius(double &min, double &max) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
fgSampleRadiusState(bool &bMin, bool &bMax, bool &bPixels)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
finalGatheringEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
giPhotonsPerLight() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
giSampleCount() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
giSampleRadius() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
giSampleRadiusEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
globalIlluminationEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightLuminanceScale() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
memoryLimit() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
modelScaleFactor(void) const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
photonTraceDepth(int &reflection, int &refraction, int &sum) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
progressMonitor(void) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
rayTraceDepth(int &reflection, int &refraction, int &sum) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
rayTraceEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
sampling(int &min, int &max) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
samplingContrastColor(float &r, float &g, float &b, float &a) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
SamplingFilter(AcGiMrFilter &filter, double &width, double &height) const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setBackFacesEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDiagnosticBackgroundEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setDiagnosticBSPMode(AcGiMrDiagnosticBSPMode mode)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setDiagnosticGridMode(AcGiMrDiagnosticGridMode mode, float fSize)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setDiagnosticMode(AcGiMrDiagnosticMode mode)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setDiagnosticPhotonMode(AcGiMrDiagnosticPhotonMode mode)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEnergyMultiplier(float fScale)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setExportMIEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setExportMIFileName(const ACHAR *miName)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setFGRadiusState(bool bMin, bool bMax, bool bPixels)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setFGRayCount(int num)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setFGSampleRadius(double min, double max)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setFinalGatheringEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setGIPhotonsPerLight(int num)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setGISampleCount(int num)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setGISampleRadius(double radius)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setGISampleRadiusEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setGlobalIlluminationEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightLuminanceScale(double luminance)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setMaterialEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setMemoryLimit(int limit)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setModelScaleFactor(double scaleFactor)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setPhotonTraceDepth(int reflection, int refraction, int sum)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setProgressMonitor(void *pMonitor)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setRayTraceDepth(int reflection, int refraction, int sum)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setRayTraceEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setSampling(int min, int max)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setSamplingContrastColor(float r, float g, float b, float a)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setSamplingFilter(AcGiMrFilter filter, double width, double height)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowMapEnabled(bool enabled)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setShadowMode(AcGiMrShadowMode mode)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setShadowsEnabled(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setTextureSampling(bool enabled)=0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTileOrder(AcGiMrTileOrder order)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setTileSize(int size)=0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowMapEnabled() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
shadowMode() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
shadowsEnabled() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
textureSampling() const =0 (defined in AcGiRenderSettingsTraits) | AcGiRenderSettingsTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
tileOrder() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
tileSize() const =0 (defined in AcGiMentalRayRenderSettingsTraits) | AcGiMentalRayRenderSettingsTraits | pure virtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiPointLightTraits Member List

This is the complete list of members for AcGiPointLightTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiPointLightTraits) (defined in AcGiPointLightTraits) | AcGiPointLightTraits |
ACRX_DECLARE_MEMBERS(AcGiStandardLightTraits) (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits |
ACRX_DECLARE_MEMBERS(AcGiLightTraits) (defined in AcGiLightTraits) | AcGiLightTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
intensity() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOn() const =0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightAttenuation(AcGiLightAttenuation &atten) const =0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
lightColor() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
position() const =0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setAttenuation(const AcGiLightAttenuation &atten)=0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setIntensity(double inten)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightColor(const AcCmColor &color)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setOn(bool on)=0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPosition(const AcGePoint3d &pos)=0 (defined in AcGiPointLightTraits) | AcGiPointLightTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowParameters(const AcGiShadowParameters &params)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowParameters(AcGiShadowParameters &params) const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiShadowParameters Member List

This is the complete list of members for AcGiShadowParameters, including all inherited members.

AcGiShadowParameters() | AcGiShadowParameters |
ACRX_DECLARE_MEMBERS(AcGiShadowParameters) (defined in AcGiShadowParameters) | AcGiShadowParameters |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kAreaSampled enum value (defined in AcGiShadowParameters) | AcGiShadowParameters |
kShadowMaps enum value (defined in AcGiShadowParameters) | AcGiShadowParameters |
kShadowsRayTraced enum value (defined in AcGiShadowParameters) | AcGiShadowParameters |
operator==(const AcGiShadowParameters &params) const | AcGiShadowParameters |
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
setShadowMapSize(Adesk::UInt16 sz) | AcGiShadowParameters | virtual
setShadowMapSoftness(Adesk::UInt8 soft) | AcGiShadowParameters | virtual
setShadowsOn(bool on) | AcGiShadowParameters | virtual
setShadowType(ShadowType typ) | AcGiShadowParameters | virtual
shadowMapSize() const | AcGiShadowParameters | virtual
shadowMapSoftness() const | AcGiShadowParameters | virtual
shadowsOn() const | AcGiShadowParameters | virtual
shadowType() const | AcGiShadowParameters | virtual
ShadowType enum name (defined in AcGiShadowParameters) | AcGiShadowParameters |
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcGiShadowParameters() | AcGiShadowParameters | virtual
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiSpotLightTraits Member List

This is the complete list of members for AcGiSpotLightTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiSpotLightTraits) (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits |
ACRX_DECLARE_MEMBERS(AcGiStandardLightTraits) (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits |
ACRX_DECLARE_MEMBERS(AcGiLightTraits) (defined in AcGiLightTraits) | AcGiLightTraits |
ACRX_DECLARE_MEMBERS(AcGiNonEntityTraits) (defined in AcGiNonEntityTraits) | AcGiNonEntityTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &id) | AcGiNonEntityTraits | inlinevirtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const | AcGiNonEntityTraits | inlinevirtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
falloff() const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
fillType(void) const | AcGiNonEntityTraits | inlinevirtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
hotspot() const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
intensity() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
isOn() const =0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const | AcGiNonEntityTraits | inlinevirtual
lightAttenuation(AcGiLightAttenuation &atten) const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
lightColor() const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
lineTypeId(void) const | AcGiNonEntityTraits | inlinevirtual
lineTypeScale(void) const | AcGiNonEntityTraits | inlinevirtual
lineWeight(void) const | AcGiNonEntityTraits | inlinevirtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const | AcGiNonEntityTraits | inlinevirtual
position() const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const | AcGiNonEntityTraits | inlinevirtual
setAttenuation(const AcGiLightAttenuation &atten)=0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
setColor(const Adesk::UInt16 color) | AcGiNonEntityTraits | inlinevirtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType fillType) | AcGiNonEntityTraits | inlinevirtual
setHotspotAndFalloff(double hotspot, double falloff)=0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
setIntensity(double inten)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLayer(const AcDbObjectId layerId) | AcGiNonEntityTraits | inlinevirtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLightColor(const AcCmColor &color)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setLineType(const AcDbObjectId linetypeId) | AcGiNonEntityTraits | inlinevirtual
setLineTypeScale(double dScale) | AcGiNonEntityTraits | inlinevirtual
setLineWeight(const AcDb::LineWeight lw) | AcGiNonEntityTraits | inlinevirtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId matId) | AcGiNonEntityTraits | inlinevirtual
setOn(bool on)=0 (defined in AcGiLightTraits) | AcGiLightTraits | pure virtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPosition(const AcGePoint3d &pos)=0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) | AcGiNonEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId) | AcGiNonEntityTraits | inlinevirtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setShadowParameters(const AcGiShadowParameters &params)=0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
setTargetLocation(const AcGePoint3d &loc)=0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
setThickness(double thickness) | AcGiNonEntityTraits | inlinevirtual
setTrueColor(const AcCmEntityColor &color) | AcGiNonEntityTraits | inlinevirtual
setupForEntity(AcDbEntity *pEntity) | AcGiNonEntityTraits | inlinevirtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowParameters(AcGiShadowParameters &params) const =0 (defined in AcGiStandardLightTraits) | AcGiStandardLightTraits | pure virtual
targetLocation() const =0 (defined in AcGiSpotLightTraits) | AcGiSpotLightTraits | pure virtual
thickness(void) const | AcGiNonEntityTraits | inlinevirtual
trueColor(void) const | AcGiNonEntityTraits | inlinevirtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
AcGiViewportTraits Member List

This is the complete list of members for AcGiViewportTraits, including all inherited members.

ACRX_DECLARE_MEMBERS(AcGiViewportTraits) (defined in AcGiViewportTraits) | AcGiViewportTraits |
ACRX_DECLARE_MEMBERS(AcGiDrawableTraits) (defined in AcGiDrawableTraits) | AcGiDrawableTraits |
ACRX_DECLARE_MEMBERS(AcGiSubEntityTraits) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
AcRxObject() (defined in AcRxObject) | AcRxObject | protected
addLight(const AcDbObjectId &lightId) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlinevirtual
ambientLightColor() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
background() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
brightness() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
cast(const AcRxObject *inPtr) (defined in AcRxObject) | AcRxObject | static
clone() const (defined in AcRxObject) | AcRxObject | virtual
color(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
comparedTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
contrast() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
copyFrom(const AcRxObject *other) (defined in AcRxObject) | AcRxObject | virtual
DefaultLightingType enum name (defined in AcGiViewportTraits) | AcGiViewportTraits |
defaultLightingType() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
desc() (defined in AcRxObject) | AcRxObject | static
drawFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
DrawFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
edgeStyleOverride(AcGiEdgeStyleMask &mask, AcGiEdgeStyle &edgeStyle) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
fillType(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
getPlotStyleNameId(AcDbObjectId &idResult) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
isA() const (defined in AcRxObject) | AcRxObject | virtual
isDefaultLightingOn() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
isEqualTo(const AcRxObject *other) const (defined in AcRxObject) | AcRxObject | virtual
isKindOf(const AcRxClass *aClass) const (defined in AcRxObject) | AcRxObject | inline
kBackLighting enum value (defined in AcGiViewportTraits) | AcGiViewportTraits |
kDrawBackfaces enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kDrawHatchGroup enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kFrozen enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kNoDrawFlags enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kNone enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOff enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
kOneDistantLight enum value (defined in AcGiViewportTraits) | AcGiViewportTraits |
kShadowsCastAndReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotCast enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsDoesNotReceive enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kShadowsIgnore enum value (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
kTwoDistantLights enum value (defined in AcGiViewportTraits) | AcGiViewportTraits |
kZero enum value (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
LayerFlags enum name (defined in AcGiDrawableTraits) | AcGiDrawableTraits | protected
layerId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeId(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineTypeScale(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
lineWeight(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
mapper(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
materialId(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
queryX(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
renderEnvironment() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
renderSettings() const =0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
sectionable(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
selectionGeom(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setAmbientLightColor(const AcCmColor &clr)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setBackground(const AcDbObjectId backgroundId)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setBrightness(double brightness)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setColor(const Adesk::UInt16 color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setContrast(double contrast)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setDefaultLightingOn(bool on)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setDefaultLightingType(DefaultLightingType typ)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setDrawFlags(Adesk::UInt32 flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setEdgeStyleOverride(AcGiEdgeStyleMask mask, const AcGiEdgeStyle &edgeStyle) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setFillType(const AcGiFillType)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLayer(const AcDbObjectId layerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLayerFlags(Adesk::UInt8 flags) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | inlineprotectedvirtual
setLineType(const AcDbObjectId linetypeId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineTypeScale(double dScale=1.0)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setLineWeight(const AcDb::LineWeight lw)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setMapper(const AcGiMapper *mapper) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setMaterial(const AcDbObjectId materialId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setPlotStyleName(AcDb::PlotStyleNameType type, const AcDbObjectId &id=AcDbObjectId::kNull) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setRenderEnvironment(const AcDbObjectId renderEnvId)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setRenderSettings(const AcDbObjectId renderSettingsId)=0 (defined in AcGiViewportTraits) | AcGiViewportTraits | pure virtual
setSectionable(bool bSectionable) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionGeom(bool bSelectionflag) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setSelectionMarker(const Adesk::LongPtr markerId)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setShadowFlags(ShadowFlags flags) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
setThickness(double dThickness)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setTrueColor(const AcCmEntityColor &color)=0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
setupForEntity(AcDbEntity *pEntity) (defined in AcGiDrawableTraits) | AcGiDrawableTraits | virtual
setVisualStyle(const AcDbObjectId visualStyleId) (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
ShadowFlags enum name (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits |
shadowFlags(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
thickness(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
trueColor(void) const =0 (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | pure virtual
visualStyle(void) const (defined in AcGiSubEntityTraits) | AcGiSubEntityTraits | inlinevirtual
x(const AcRxClass *protocolClass) const (defined in AcRxObject) | AcRxObject |
~AcRxObject() (defined in AcRxObject) | AcRxObject | inlinevirtual


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
IOPMPropertyExtensionImpl< T > Member List

This is the complete list of members for IOPMPropertyExtensionImpl< T >, including all inherited members.

Editable(DISPID dispID, BOOL __RPC_FAR *bEditable) (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
GetCategoryName(PROPCAT propcat, LCID lcid, BSTR *pbstrName) (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
GetDisplayName(DISPID dispID, BSTR *pBstr) (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
GetDisplayString(DISPID dispID, BSTR *pBstr) (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
GetPredefinedStrings(DISPID dispID, CALPOLESTR *pCaStringsOut, CADWORD *pCaCookiesOut) (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
GetPredefinedValue(DISPID dispID, DWORD dwCookie, VARIANT *pVarOut) (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
GetResourceInstance()=0 (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | pure virtual
IOPMPropertyExtensionImpl() (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
MapPropertyToCategory(DISPID dispid, PROPCAT *ppropcat) (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
MapPropertyToPage(DISPID dispID, CLSID *pClsid) (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
ShowProperty(DISPID dispID, BOOL *pShow) (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inline
~IOPMPropertyExtensionImpl() (defined in IOPMPropertyExtensionImpl< T >) | IOPMPropertyExtensionImpl< T > | inlinevirtual


ZRX API Reference: Class Index

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Class Index
A | C | D | E | F | I | L | M | O | P | R | S | T | _
A
AcDbLight AcFdFieldEngine AcNameValuePair CAdUiFATVolumeDescriptor
AcDbLine AcFdFieldEvaluator AcOfstream CAdUiFileDialog
Ac3dDwfNavTreeNode AcDbLinetypeTable AcFdFieldEvaluatorLoader AcOutputBufMgr CAdUiGroupCtrl
Acad AcDbLinetypeTableIterator AcFdFieldReactor AcPane CAdUiHeaderCtrl
ACAD_OPMPROPMAP_ENTRY AcDbLinetypeTableRecord AcFdFieldResult AcPl3dDwfOptions CAdUiHPFSVolumeDescriptor
AcadApp AcDbLinkedData AcFdFieldValue ACPL_PREVIEWENDPLOT CAdUiListBox
AcadAppInfo AcDbLinkedTableData AcFILE AcPlDSDData CAdUiListCtrl
AcadToolImpl AcDbLoftedSurface AcFileDependencyInfo AcPlDSDEntry CAdUiNOFSVolumeDescriptor
AcAp AcDbLoftOptions AcFileDependencyManager AcPlHostAppServices CAdUiNTFSVolumeDescriptor
AcApDataManager AcDbLongTransaction AcGe AcPlObject CAdUiODButtonThemeModReactor
AcApDocManager AcDbLongTransWorkSetIterator AcGeAugPolyline3d AcPlPlotConfig CAdUiOwnerDrawButton
AcApDocManagerReactor AcDbMatchProperties AcGeBoundBlock2d AcPlPlotConfigInfo CAdUiPalette
AcApDocument AcDbMaterial AcGeBoundBlock3d AcPlPlotConfigManager CAdUiPaletteSet
AcApDocumentIterator AcDbMentalRayRenderSettings AcGeBoundedPlane AcPlPlotEngine CAdUiPaletteSetDockFrame
AcApLayoutManager AcDbMInsertBlock AcGeCircArc2d AcPlPlotErrorHandler CAdUiPathname
AcApLongTransactionManager AcDbMLeader AcGeCircArc3d AcPlPlotErrorHandlerLock CAdUiRegistryAccess
AcApLongTransactionReactor AcDbMLeaderStyle AcGeClipBoundary2d AcPlPlotFactory CAdUiRegistryDeleteAccess
AcApProfileManager AcDbMline AcGeCompositeCurve2d AcPlPlotInfo CAdUiRegistryWriteAccess
AcApProfileManagerReactor AcDbMlineStyle AcGeCompositeCurve3d AcPlPlotInfoValidator CAdUiTab
AcApProfileStorage AcDbMotionPath AcGeCone AcPlPlotLogger CAdUiTabChildDialog
AcApStatusBar AcDbMPolygon AcGeContext AcPlPlotLoggingErrorHandler CAdUiTabExtensionManager
AcArray AcDbMPolygonCrossing AcGeCubicSplineCurve2d AcPlPlotPageInfo CAdUiTabMainDialog
AcArrayMemCopyReallocator AcDbMPolygonCrossingArray AcGeCubicSplineCurve3d AcPlPlotProgress CAdUiTextTip
AcArrayObjectCopyReallocator AcDbMpolygonLoops AcGeCurve2d AcPlPlotProgressDialog CAdUiTheme
AcAxDocLock AcDbMPolygonNode AcGeCurve3d AcPlPlotReactor CAdUiThemeManager
AcAxMatrix3d AcDbMText AcGeCurveBoundary AcPlPlotReactorMgr CAdUiThemeMgrReactor
AcAxObjectRef AcDbMTextFragment AcGeCurveCurveInt2d AcPublishAggregationInfo CAdUiThemeModifiedReactor
AcAxObjectRefPtr AcDbNamedPath AcGeCurveCurveInt3d AcPublishBeforeJobInfo CAdUiTipWindow
AcAxOleLinkManager AcDbObject AcGeCurveSurfInt AcPublishBeginJobInfo CAdUiToolButton
AcAxPoint2d AcDbObjectContext AcGeCylinder AcPublishReactor CAdUiTrackButton
AcAxPoint2dArray AcDbObjectContextCollection AcGeDwgIO AcPublishReactorInfo CAdUiUFSVolumeDescriptor
AcAxPoint3d AcDbObjectContextCollectionIterator AcGeDxfIO AcPublishSheetInfo CAdUiVFATVolumeDescriptor
AcAxPoint3dArray AcDbObjectContextInterface AcGeEllipArc2d AcPublishUIReactor CAdUiVolumeDescriptor
AcCell AcDbObjectContextManager AcGeEllipArc3d AcPublishUIReactorInfo CAseApiObj
AcCellRange AcDbObjectId AcGeEntity2d AcRx CAseAppl
AcCFile AcDbObjectIdGraph AcGeEntity3d AcRxArxApp CAseLink
AcCmColor AcDbObjectIdGraphNode AcGeExternalBoundedSurface AcRxDbxApp CAseLinkPath
AcCmColorBase AcDbObjectIterator AcGeExternalCurve2d AcRxDictionary CAseLinkSel
AcCmComplexColor AcDbObjectPointer AcGeExternalCurve3d AcRxDictionaryIterator CAsiAppl
AcCmDialogColor AcDbObjectPointerBase AcGeExternalSurface AcRxDLinkerReactor CAsiApproxNum
AcCmEntityColor AcDbObjectReactor AcGeFileIO AcRxDynamicLinker CAsiBinary
AcCmTransparency AcDbOle2Frame AcGeFiler AcRxDynPropManager CAsiBlob
AcColorSettings AcDbOleFrame AcGeInterval AcRxEvent CAsiChar
AcColorSettingsEx AcDbOrdinateDimension AcGeKnotVector AcRxEventReactor CAsiColumn
AcCStdioFile AcDbOsnapPointRef AcGeLibVersion AcRxIterator CAsiCsr
AcDb AcDbPaperOrientationPE AcGeLine2d AcRxKernel CAsiCsrInfSchema
AcDb2dPolyline AcDbPasswordedFile AcGeLine3d AcRxObject CAsiCsrRegTable
AcDb2dVertex AcDbPlaceHolder AcGeLinearEnt2d AcRxProtocolReactor CAsiCsrTable
AcDb2LineAngularDimension AcDbPlaneSurface AcGeLinearEnt3d AcRxProtocolReactorIterator CAsiData
AcDb3dPolyline AcDbPlotSettings AcGeLineSeg2d AcRxProtocolReactorList CAsiDate
AcDb3dPolylineVertex AcDbPlotSettingsValidator AcGeLineSeg3d AcRxProtocolReactorListIterator CAsiDatetime
AcDb3dSolid AcDbPoint AcGeMatrix2d AcRxProtocolReactorManager CAsiDecimal
AcDb3PointAngularDimension AcDbPointPath AcGeMatrix3d AcRxProtocolReactorManagerFactory CAsiDouble
AcDbAbstractViewTable AcDbPointRef AcGeNurbCurve2d AcRxService CAsiDT
AcDbAbstractViewTableIterator AcDbPolyFaceMesh AcGeNurbCurve3d AcStatusBarItem CAsiEnumerator
AcDbAbstractViewTableRecord AcDbPolyFaceMeshVertex AcGeNurbSurface AcStatusBarMenuItem CAsiExactNum
AcDbAlignedDimension AcDbPolygonMesh AcGeOffsetCurve2d AcString CAsiException
AcDbAlignment AcDbPolygonMeshVertex AcGeOffsetCurve3d ACTC_IMAGE_INFO CAsiExceptionHandler
AcDbAnnotationScale AcDbPolyline AcGeOffsetSurface ACTC_TARGET_PRODUCT_INFO CAsiExecStm
AcDbAnnotativeObjectPE AcDbProxyEntity AcGePlanarEnt AcTcCatalog CAsiFloat
AcDbAppEntityGrips AcDbProxyObject AcGePlane AcTcCatalogItem CAsiHostBuffer
AcDbAppSystemVariables AcDbR13ObjectId AcGePoint2d AcTcCatalogItemReactor CAsiIdent
AcDbArc AcDbRadialDimension AcGePoint3d AcTcCatalogSet CAsiInt
AcDbArcDimension AcDbRadialDimensionLarge AcGePointEnt2d AcTcCategory CAsiInterval
AcDbAttribute AcDbRasterImage AcGePointEnt3d AcTcImage CAsiIQualifier
AcDbAttributeDefinition AcDbRasterImageDef AcGePointOnCurve2d AcTcImageList CAsiIRow
AcDbAuditInfo AcDbRasterImageDefFileAccessReactor AcGePointOnCurve3d AcTcManager CAsiList
AcDbAuditRecreatePE AcDbRasterImageDefReactor AcGePointOnSurface AcTcPackage CAsiNum
AcDbBackground AcDbRasterImageDefTransReactor AcGePolyline2d AcTcPalette CAsiNumeric
AcDbBlockBegin AcDbRasterVariables AcGePolyline3d AcTcScheme CAsiObject
AcDbBlockChangeIterator AcDbRay AcGePosition2d AcTcStockTool CAsiParameter
AcDbBlockEnd AcDbRecover AcGePosition3d AcTcTool CAsiReal
AcDbBlockInsertionPoints AcDbRecoverCallBack AcGeRay2d ACTCUI_DRAG_HEADER CAsiRow
AcDbBlockReference AcDbRegAppTable AcGeRay3d AcTransaction CAsiSession
AcDbBlockReferenceIdIterator AcDbRegAppTableIterator AcGeScale2d AcTransactionManager CAsiSmallInt
AcDbBlockTable AcDbRegAppTableRecord AcGeScale3d AcTransactionReactor CAsiSQLObject
AcDbBlockTableIterator AcDbRegion AcGeSphere AcTrayItem CAsiStm
AcDbBlockTableRecord AcDbRenderEnvironment AcGeSplineEnt2d AcTrayItemAnimationControl CAsiTACond
AcDbBlockTableRecordIterator AcDbRenderGlobal AcGeSplineEnt3d AcTrayItemBubbleWindowControl CAsiTCCond
AcDbBody AcDbRenderSettings AcGeSurface AcUnderlayLayer CAsiTime
AcDbBreakData AcDbRevolvedSurface AcGeSurfSurfInt AcUt CAsiTimeStamp
AcDbBreakPointRef AcDbRevolveOptions AcGeTol AcValue CAsiUcChar
AcDbCamera AcDbRotatedDimension AcGeTorus AdCharFormatter CAsiUcStr
AcDbCircle AcDbSection AcGeVector2d Adesk CAsiYM
AcDbClassIterator AcDbSectionManager AcGeVector3d ads_binary CATCMDBTN_ENTRY
AcDbColor AcDbSectionManagerIterator AcGiClipBoundary ads_callback_packet CATEGORY_ENTRY
AcDbCompositeFilteredBlockIterator AcDbSectionSettings AcGiColorRGB ads_u_val CMDBTN_ENTRY
AcDbCurve AcDbSelectGrip AcGiColorRGBA AdUiBmpBtnData CNavArray
AcDbCurvePath AcDbSequenceEnd AcGiCommonDraw AdUiGroupCtrlData CNavData
AcDbCustomOsnapInfo AcDbServices AcGiContext AsdkPromptBase CNavDataArray
AcDbCustomOsnapManager AcDbShape AcGiContextualColors asi_date CNavDialog
AcDbCustomOsnapMode AcDbSkyBackground AcGiContextualColors2 asi_day CNavDropSource
AcDbDatabase AcDbSoftOwnershipId AcGiDisplayStyle asi_daytohour CNavFilter
AcDbDatabaseReactor AcDbSoftPointerId AcGiDistantLightTraits asi_daytominute CNavFilterArray
AcDbDatabaseSummaryInfo AcDbSolid AcGiDistantLightTraits2 asi_daytosecond CNavListCtrl
AcDbDataCell AcDbSolidBackground AcGiDrawable asi_hour CProxy_AcadObjectEvents
AcDbDataColumn AcDbSortentsTable AcGiDrawableTraits asi_hourtominute CProxy_PropertyNotifySink
AcDbDataLink AcDbSpatialFilter AcGiEdgeData asi_hourtosecond CRectangle3d
AcDbDataLinkManager AcDbSpatialIndex AcGiEdgeStyle asi_minute CTypedPtrArray
AcDbDataTable AcDbSpatialIndexIterator AcGiFaceData asi_minuteitosecond
D
AcDbDate AcDbSpline AcGiFaceStyle asi_month
AcDbDeepCloneFiler AcDbSubentId AcGiGenericTexture asi_second AcApDocManager::DocOpenParams
AcDbDgnDefinition AcDbSummaryInfoManager AcGiGeometry asi_time
E
AcDbDgnReference AcDbSummaryInfoReactor AcGiGlyph asi_timestamp
AcDbDgnUnderlayItem AcDbSun AcGiGradientBackgroundTraits asi_year e2f_ent
AcDbDiametricDimension AcDbSurface AcGiGroundPlaneBackgroundTraits asi_yeartomonth e2f_hdr
AcDbDictionary AcDbSweepOptions AcGiImageBackgroundTraits
C
e2f_layer
AcDbDictionaryIterator AcDbSweptSurface AcGiImageFileTexture e2f_xform
AcDbDictionaryWithDefault AcDbSymbolTable AcGiImageTexture CAcExtensionModule AcGiVariant::EnumType
AcDbDimAssoc AcDbSymbolTableIterator AcGiLightAttenuation CAcFdUiFieldDialog
F
AcDbDimData AcDbSymbolTablePointer AcGiLightTraits CAcFdUiFieldDialogHook
AcDbDimension AcDbSymbolTableRecord AcGiLineAttributes CAcFdUiFieldFormatDialog fchnd
AcDbDimStyleTable AcDbSymbolTableRecordPointer AcGiLineAttrUtils CAcFdUiFieldFormatList
I
AcDbDimStyleTableIterator AcDbTable AcGiLinetypeEngine CAcFdUiFieldManager
AcDbDimStyleTableRecord AcDbTableContent AcGiMapper CAcFdUiFieldOptionDialog IAcadBaseDatabaseImpl
AcDbDoubleClickEdit AcDbTableIterator AcGiMarbleTexture CAcFdUiFormatDialog IAcadBaseObject
AcDbDwfDefinition AcDbTableStyle AcGiMaterialColor CAcFdUiFormatList IAcadBaseObject2
AcDbDwfReference AcDbTableTemplate AcGiMaterialMap CAcGradientThumbnailEngine IAcadBaseObject2Impl
AcDbDwgFiler AcDbText AcGiMaterialTexture CAcModuleResourceOverride IAcadBaseObjectImpl
AcDbDxfFiler AcDbTextStyleTable AcGiMaterialTraits CAcTcUiCatalogView IAcadBaseSubEntityImpl
AcDbDynamicUCSPE AcDbTextStyleTableIterator AcGiMaterialTraits2 CAcTcUiCatalogViewItem IAcadEntityDispatchImpl
AcDbDynBlockReference AcDbTextStyleTableRecord AcGiMentalRayRenderSettingsTraits CAcTcUiManager IAcadObjectDispatchImpl
AcDbDynBlockReferenceProperty AcDbTrace AcGiMentalRayRenderSettingsTraits2 CAcTcUiPaletteView IAcadShadowDisplayImpl
AcDbEllipse AcDbTransactionManager AcGiNonEntityTraits CAcTcUiScheme IAcPiCategorizePropertiesImpl
AcDbEntity AcDbUCSTable AcGiPointLightTraits CAcTcUiToolPalette IAcPiPropCommandButtonsImpl
AcDbEntityHyperlinkPE AcDbUCSTableIterator AcGiPointLightTraits2 CAcTcUiToolPaletteGroup IAcPiPropertyDisplayImpl
AcDbEntityReactor AcDbUCSTableRecord AcGiProceduralTexture CAcTcUiToolPaletteSet IConnectionPointContainerImpl
AcDbEvalConnectable AcDbUnderlayDefinition AcGiRenderEnvironmentTraits CAcUiAngleComboBox IConnectionPointImpl
AcDbEvalContext AcDbUnderlayDrawContext AcGiRenderSettingsTraits CAcUiAngleEdit IOPMPropertyExtensionImpl
AcDbEvalContextIterator AcDbUnderlayFile AcGiRequestScanLines CAcUiArrowHeadComboBox IOPMPropertyExtensionImpl2
AcDbEvalContextPair AcDbUnderlayHost AcGiSentScanLines CAcUiBitmapButton IRetrieveApplicationImpl
AcDbEvalEdgeInfo AcDbUnderlayItem AcGiShadowParameters CAcUiBitmapStatic
L
AcDbEvalExpr AcDbUnderlayReference AcGiShadowParameters2 CAcUiColorComboBox
AcDbEvalGraph AcDbVertex AcGiSkyBackgroundTraits CAcUiComboBox ListItem
AcDbEvalIdMap AcDbViewport AcGiSkyParameters CAcUiDialog
M
AcDbEvalVariant AcDbViewportTable AcGiSolidBackgroundTraits CAcUiDialogBar
AcDbExtents AcDbViewportTableIterator AcGiSpotLightTraits CAcUiDialogWorksheet Mline
AcDbExtrudedSurface AcDbViewportTableRecord AcGiSpotLightTraits2 CAcUiDockControlBar
O
AcDbFace AcDbViewTable AcGiStandardLightTraits CAcUiDockFrame
AcDbFaceRecord AcDbViewTableIterator AcGiStyleAttributes CAcUiDropSite OPMPerInstancePropertyExtension
AcDbFcf AcDbViewTableRecord AcGiSubEntityTraits CAcUiEdit OPMPerInstancePropertyExtensionFactory
AcDbField AcDbVisualStyle AcGiTextEngine CAcUiFileDialog OPMPerInstancePropertySources
AcDbFilter AcDbWblockCloneFiler AcGiTextStyle CAcUiLineTypeComboBox OPMPropertyExtension
AcDbFilteredBlockIterator AcDbWipeout AcGiToneOperatorParameters CAcUiLineWeightComboBox OPMPropertyExtensionFactory
AcDbFormattedTableData AcDbXline AcGiVariant CAcUiLTypeRecord OwnerDraw3d
AcDbFrame AcDbXObject AcGiVertexData CAcUiMRUComboBox
P
AcDbFullSubentPath AcDbXrecord AcGiViewport CAcUiMRUListBox
AcDbGradientBackground AcDbXrecordIterator AcGiViewportDraw CAcUiNavDialog PER_FLYOUT_ENTRY
AcDbGraph AcDbXrefGraph AcGiViewportGeometry CAcUiNumericComboBox PER_PROP_DISP_ENTRY
AcDbGraphNode AcDbXrefGraphNode AcGiViewportTraits CAcUiNumericEdit PER_PROP_DISP_ENTRY2
AcDbGraphStack AcDbXrefObjectId AcGiViewportTraits2 CAcUiOwnerDrawButton PROMPT_MAP_ENTRY
AcDbGripData AcDMMEntityReactorInfo AcGiVisualStyle CAcUiPaletteSetDockFrame
R
AcDbGroundPlaneBackground AcDMMEPlotProperties AcGiVisualStyleTraits CAcUiPathname
AcDbGroup AcDMMEPlotProperty AcGiWebLightTraits CAcUiPickButton resbuf
AcDbGroupIterator AcDMMNode AcGiWoodTexture CAcUiPlotStyleNamesComboBox AcCmEntityColor::RGBM
AcDbHandle AcDMMReactor AcGiWorldDraw CAcUiPlotStyleTablesComboBox RxADSAppTableEntryType
AcDbHardOwnershipId AcDMMResourceInfo AcGiWorldGeometry CAcUiPredefBlockComboBox
S
AcDbHardPointerId AcDMMSheetReactorInfo AcGridProperty CAcUiSelectButton
AcDbHatch AcDMMWideString AcGs CAcUiString scn_cmesh
AcDbHelix AcDMMXMLAttribute AcGs2DViewLimitManager CAcUiStringComboBox scn_cvrt
AcDbHostApplicationProgressMeter AcEdAppGripService AcGsClassFactory CAcUiStringEdit scn_node
AcDbHostApplicationServices AcEdCommand AcGsClientViewInfo CAcUiStringExp scn_pmsh
AcDbHyperlink AcEdCommandIterator AcGsColor CAcUiSymbolComboBox scn_vrtc
AcDbHyperlinkCollection AcEdCommandStack AcGsConfig CAcUiSymbolEdit SecurityParams
AcDbIdMapping | AcEdCommandStruc | AcGsDCPoint | CAcUiTab | Services (AcEdSymbolUtilities)
AcDbIdMappingIter | AcEdInputContextReactor | AcGsDCRect | CAcUiTabChildDialog | Services (AcDbSymbolUtilities)
AcDbIdPair AcEdInputPointFilter AcGsDevice CAcUiTabMainDialog SignatureInfo
AcDbImage AcEdInputPointManager AcGsManager CAcUiToolButton
T
AcDbImageBackground AcEdInputPointMonitor AcGsModel CAcUiTrueColorComboBox
AcDbIndex AcEditor AcGsNode CAdUiBalloonTip tagADUI_DRAGDATA
AcDbIndexUpdateData AcEditorReactor AcGsReactor CAdUiBaseDialog tagChildFrmSettings
AcDbIndexUpdateDataIterator AcEditorReactor2 AcGsRenderProgressMonitor CAdUiBitmapButton tagClipboardInfo
AcDbInterferencePE AcEdJig AcGsRenderStatistics CAdUiBitmapStatic tagOPMDWORD
AcDbLayerFilter AcEdSelectionSetService AcGsScreenShot CAdUiCDFSVolumeDescriptor tagOPMLPOLESTR
AcDbLayerIndex AcEdServices AcGsView CAdUiComboBox AcadToolImpl::TOOL_MAP_ENTRY
AcDbLayerIndexIterator AcEdSolidSubentitySelector AcHeapOperators CAdUiCoupledGroupCtrl
_
AcDbLayerStateManager AcEdSSGetFilter AcHyperlink CAdUiDialog
AcDbLayerStateManagerReactor AcEdSSGetFilter2 AcIfstream CAdUiDialogBar _ADSSYMBOL_ENTRY
AcDbLayerTable AcEdSSGetFilter3 AcLispAppInfo CAdUiDialogWorksheet _ARXCOMMAND_ENTRY
AcDbLayerTableIterator AcEdSSGetSubSelectFilter AcLyAndExpr CAdUiDockControlBar _DBX_REGISTER_OBJECT_ENTRY
AcDbLayerTableRecord AcEdSubSelectFilter AcLyBoolExpr CAdUiDockFrame _dlgControlTag
AcDbLayout AcEdSubSelectFilterService AcLyLayerFilter CAdUiDrawTipText _IID
AcDbLayoutManager AcEdUIContext AcLyLayerFilterManager CAdUiDropSite _OPM_DYNPROP_ENTRY
AcDbLayoutManagerReactor AcEdXrefFileLock AcLyLayerGroup CAdUiDropTarget
AcDbLeader AcFd AcLyRelExpr CAdUiEdit
A | C | D | E | F | I | L | M | O | P | R | S | T | _


ZRX API Reference: Main Page

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
ZRX API Reference Documentation


ZRX API Reference: Class Hierarchy

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
Class Hierarchy

Go to the textual class hierarchy


ReleaseNote

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
What's New in ZRX for ZWCAD 2015(2015.00)

New methods in AcDb:

Acad::ErrorStatus | reclaimMemoryFromErasedObjects(const AcDbObjectIdArray& erasedObjects);
Acad::ErrorStatus | toPolyline(AcDbCurve*& pCurve, int precision = 10, int* maxSuggestedPrecision = NULL, unsigned int numOfVerticesThreshold = kPlineVerticesThrehold) const;

New in Global Functions:

Acad::ErrorStatus | acedTraceBoundary(const AcGePoint3d& seedPoint, bool detectIslands, AcDbVoidPtrArray& resultingBoundarySet);
BOOL | acedAddDropTarget(COleDropTarget* pTarget);
BOOL | acedRemoveDropTarget(COleDropTarget* pTarget);
BOOL | acedStartOverrideDropTarget(COleDropTarget* pTarget);
BOOL | acedEndOverrideDropTarget(COleDropTarget* pTarget);
BOOL | acedRegisterCustomDropTarget(IDropTarget* pItarget);
BOOL | acedRevokeCustomDropTarget();
BOOL | acedLoadPartialMenu(const TCHAR* pszMenuFile);
BOOL | acedUnloadPartialMenu(const TCHAR* pszMenuFile);

New in AcGe Functions:

void getSamplePoints(int numSample, AcGePoint3dArray& pointArray, AcGeDoubleArray& paramArray) const;

What's New in ZRX for ZWCAD 2015 SP1(2015.10)
No Additions

What's New in ZRX for ZWCAD 2015 SP2(2015.20)

New methods in AcDb:

AcDbDynBlockReferenceProperty();
AcDbDynBlockReference(AcDbObjectId blockRefId);
AcDbEvalVariant(double dVal);
virtual | ~AcDbDynBlockReference();
virtual | ~AcDbDynBlockReferenceProperty();
Acad::ErrorStatus | AcDbDynBlockReferenceProperty::getAllowedValues(AcDbEvalVariantArray& values);
Acad::ErrorStatus | AcDbDynBlockReferenceProperty::setValue(const AcDbEvalVariant& value);
AcDbEvalVariant | AcDbDynBlockReferenceProperty::value() const;
AcString | AcDbDynBlockReferenceProperty::propertyName() const;
bool | AcDbDynBlockReference::isDynamicBlock() const;
void | AcDbDynBlockReference::getBlockProperties(AcDbDynBlockReferencePropertyArray& properties) const;

New in Global Functions:

void acplPublishExecute(AcPl2DSDData dsdDataObj, AcPlPlotConfig* pConfig, bool bShowPlotProgress);

What's New in ZRX for ZWCAD 2015 SP3(2015.30)

New methods in AcDb:

AcGePoint3d | AcDbRasterImage::position() const;
AcDbObjectId | AcDbAbstractViewTableRecord::sunId() const;
Acad::ErrorStatus | AcDbLayerTableRecord::setMaterialId(AcDbObjectId id);
AcDbObjectId | AcDbLayerTableRecord::materialId() const;
AcDbDynBlockReference::AcDbDynBlockReference(AcDbBlockReference * pRef)
AcDbObjectId | AcDbDynBlockReference::anonymousBlockTableRecord() const;
AcDbObjectId | AcDbDynBlockReference::blockId() const;
Acad::ErrorStatus | AcDbDynBlockReference::convertToStaticBlock();
Acad::ErrorStatus | AcDbDynBlockReference::convertToStaticBlock(const AcString & newBlockName);
AcDbObjectId | AcDbDynBlockReference::dynamicBlockTableRecord() const;
bool | AcDbDynBlockReference::isDynamicBlock(AcDbObjectId blockTableRecordId);
Acad::ErrorStatus | AcDbDynBlockReference::resetBlock();
AcDbDynBlockReferenceProperty::AcDbDynBlockReferenceProperty(const AcDbDynBlockReferenceProperty & other);
AcDbObjectId | AcDbDynBlockReferenceProperty::blockId() const;
AcString | AcDbDynBlockReferenceProperty::description() const;
AcDbDynBlockReferenceProperty& AcDbDynBlockReferenceProperty::operator=(const AcDbDynBlockReferenceProperty & other);
AcDbEvalVariant::Type | AcDbDynBlockReferenceProperty::propertyType() const;
bool | AcDbDynBlockReferenceProperty::readOnly() const;
bool | AcDbDynBlockReferenceProperty::show() const;
UnitsType | AcDbDynBlockReferenceProperty::unitsType() const;
AcDbEvalVariant::AcDbEvalVariant()
AcDbEvalVariant::AcDbEvalVariant(const AcDbEvalVariant & other)
AcDbEvalVariant::AcDbEvalVariant(const AcDbEvalVariant * pOther)
AcDbEvalVariant::~AcDbEvalVariant()
AcDbEvalVariant::AcDbEvalVariant(short iVal)
AcDbEvalVariant::AcDbEvalVariant(const ACHAR * szVal)
AcDbEvalVariant::AcDbEvalVariant(long lVal)
AcDbEvalVariant::AcDbEvalVariant(const AcDbObjectId & id)
AcDbEvalVariant::AcDbEvalVariant(const AcGePoint2d & pt)
AcDbEvalVariant::AcDbEvalVariant(const AcGePoint3d & pt)
void | AcDbEvalVariant::clear();
virtual | Acad::ErrorStatus AcDbEvalVariant::copyFrom(const AcRxObject * pOther);
AcDbEvalVariant& | AcDbEvalVariant::operator=(double dVal);
AcDbEvalVariant& | AcDbEvalVariant::operator=(short iVal);
AcDbEvalVariant& | AcDbEvalVariant::operator=(long lVal);
AcDbEvalVariant& | AcDbEvalVariant::operator=(const ACHAR * szVal);
AcDbEvalVariant& | AcDbEvalVariant::operator=(const AcDbEvalVariant & other);
AcDbEvalVariant& | AcDbEvalVariant::operator=(const AcDbObjectId & id);
AcDbEvalVariant& | AcDbEvalVariant::operator=(const AcGePoint2d & pt);
AcDbEvalVariant& | AcDbEvalVariant::operator=(const AcGePoint3d & pt);

New in Global Functions:

int ads_queueexpr(ACHAR* expr);


ZRX API Reference: Member List

Documents the ZRX classes, member functions, global functions, namespaces, enumerations, structures, and macros.
  • Main Page
  • Modules
  • Classes
  • Class List
  • Class Hierarchy
  • Class Members
PER_PROP_DISP_ENTRY Member List

This is the complete list of members for PER_PROP_DISP_ENTRY, including all inherited members.

m_bFullView (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY
m_dispid (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY
m_dwIntegralHeight (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY
m_lpEllipsisBmpRes (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY
m_lpLeftIconRes (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY
m_nEllipsisBmpType (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY
m_nLeftIconType (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY
m_nWeight (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY
m_ProgID (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY
m_TextColor (defined in PER_PROP_DISP_ENTRY) | PER_PROP_DISP_ENTRY